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Environment

This course requires the following VM's [Virtual Machines] to be configured. You only 
need to run 1 VM at the time and you can shut down the VM that you are not using.

You should find shortcuts in the desktop named as the VM.

For Labs 1 to 7, use  VM _WA2874_REL_1_0

For Lab 8, use  WA2675-REL-2-1-minikube-MASTER

For Lab 9 to 10, use  VM_WA2873_REL 3_0_CentOS

For the Project Labs, use  VM_WA2873_Project_2020-02-14
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Lab 1 - Using the GitFlow Workflow
In this lab you will explore the GitFlow workflow to create features, releases, hotfixes, 
and various other types of branches.

Part 1 - Create a directory for storing GitFlow lab content.

In this part you will create a directory for storing GitFlow lab content.

In the following Labs you will work in the 'VM _WA2874_REL_1_0' but instead 
you may have the software installed directly on the computer. Check with your 
instructor. 

Start 'VM _WA2874_REL_1_0' and close all other running VMs. 

__1. Open a command prompt window, and then enter:

cd \workspace

Note: If C:\workspace directory doesn't exist, create it manually.

__2. Create a directory for storing GitFlow lab content:

mkdir gitflow_test

__3. Switch to the created directory:

cd gitflow_test

Part 2 - Create and setup Remote and Local repositories.

In this part you will create a remote and a local repository.

__1. Initialize a new bare repository:

git init --bare remote_repo.git

__2. Verify the remote repository is created:

tree remote_repo.git
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Notice it shows directory tree like this:

__3. Clone the bare remote repository to a local working copy:

git clone remote_repo.git local_repo

Notice it's a blank repository that's why there is warning displayed on the screen.

__4. Verify local repository is created:

tree local_repo

Notice the directory structure is blank.

__5. Switch to the local working copy:

cd local_repo

__6. Configure user email for the repository:

git config user.email "bob@abc.com"

__7. Configure user name for the repository: 

git config user.name "Bob"

Part 3 - Set up the Basic GitFlow branches in the local repository 

GitFlow suggests that we should have a 'master' branch that represents our latest release, 
and a 'develop' branch that holds ongoing work towards the next release.  We'll create 
those now.
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__1. In the steps above, we created an empty repository and then cloned it.  Git won't let 
us create branches until we have at least one commit in the repository, so we'll do that 
now, with an empty commit:

git commit --allow-empty -m "Initial commit."

__2. Create a 'develop' branch and switch to it as shown:

git checkout -b develop 

__3. Run the following command: 

git flow init

__4. Press the Enter key to use default values for all options.

__5. View the branch list: 

git branch 

Notice it shows following branches:

"develop" is the active branch. In case if you want to activate a different branch, use 
following command:

git checkout <branch>

Part 4 - Create a Gitflow feature.

In this part you will create a Gitflow feature.

__1. Create a new feature.  Recall that we build features on a feature branch.  You could 
name this anything, but we'll use a common convention of naming the feature branches 
'feature/FNAME':

git checkout -b feature/HOME_PAGE

__2. Get branch list:

git branch 
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Notice it shows following branches:

feature/HOME_PAGE feature has been added as a branch.

__3. Get git status:

git status

Notice feature/HOME_PAGE is the active branch and currently there are no files to 
commit.

Part 5 - Add content as part of the feature.

In this part you will create an HTML file as part of the feature created in the previous 
part.

__1. Start Notepad, click Yes to create the file:

notepad index.html

__2. In the Notepad window enter following text:

<html>
 <body>
 </body>
</html>

__3. Save the file and close the Notepad window:

__4. Get git status:

git status

Notice that 'index.html' is listed as 'untracked'. 

__5. Add the new file to the index for the next commit:

git add index.html
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__6. Get git status:

git status

Notice index.html is added the repository but it's not committed yet.

__7. Commit changes:

git commit -m "Added index.html"

__8. View feature/HOME_PAGE branch contents:

git ls-tree -r --name-only feature/HOME_PAGE

Notice it shows index.html. If you don't use --name-only switch, it will show file size in 
addition to the file ID.

__9. Switch to the 'develop' branch and merge this feature into it.  Since we want a record
of this merge, we'll use '--no-ff' to make sure there's a merge commit recorded:

git checkout develop 
git merge --no-ff feature/HOME_PAGE

__10. View develop branch contents:

git ls-tree -r --name-only develop

__11. Switch back to the feature branch:

git checkout feature/HOME_PAGE

__12. Open index.html file in notepad:

notepad index.html

__13. Add <h1> tag to the body tag:

<h1>Hello world!</h1>

__14. Save the file and close the Notepad window.
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__15. Get git status:

git status

Notice index.html file is updated on the file system, but it's not updated in the repository.
Also notice you are on the develop branch.

__16. Stage the changed index.html:

git add index.html

__17. Commit changes to the feature branch:

git commit -m "Added h1 tag to the index.html"

__18. Merge feature branch into the develop branch without deleting the feature branch:

git checkout develop 
git merge --no-ff feature/HOME_PAGE

__19. View remote repository content:

git ls-remote

Notice currently no branches are in the remote repository. All the changes are in the 
local repository right now.

__20. Push changes from local repository into the remote repository:

git push --all

__21. View remote repository content:

git ls-remote

Notice it displays develop and master branches.
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Part 6 - Create a new Release

In this part you will create a Gitflow release.

__1. Create a new release "REL_1.0" based on develop branch.  We'll use the common 
convention of calling the release "release/REL_1.0".  Enter the following lines, pressing 
'return' after each line:

git checkout develop 
git checkout -b release/REL_1.0

In a real situation, you might need to do some commits on the release branch, at the very 
least to change the version number if it appears in the source code.  You might also find 
things in pre-release testing that need to be fixed.  You'd normally commit the required 
changes on the release branch.

__2. Let's finish the release.  As a reminder, the GitFlow workflow suggests that we 
should merge the release branch into 'master' and then tag the release.  Enter the 
following lines, pressing 'return' after each line:

git checkout master
git merge release/REL_1.0
git tag REL_1.0 -m "REL_1.0"

Notice that we are using the '-m' option to supply a tag message.  This option implies '-a', 
which causes Git to create an 'annotated' tag.  In a real situation, you might want to 
include more information in the tag message.

__3. Now, we should get rid of the release branch and then update the 'develop' branch to 
reflect the latest release (as reflected by the state of the 'master' branch).  Enter the 
following lines, pressing 'return' after each line:

git branch -d release/REL_1.0
git checkout develop 
git merge master

Notice that when we merged 'master', we got a message saying that the develop branch is 
already up-to-date.  That's may or may not be the case in real life.  In fact if development 
has continued in parallel with the release testing, you might have to resolve one or two 
merge conflicts.

__4. Get branch list:

git branch 
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Notice it shows branch list like this:

__5. Push all changes to the remote repository:

git push --all 

__6. Switch to the feature/HOME_PAGE branch:

git checkout feature/HOME_PAGE

__7. Open index.html file in Notepad:

notepad index.html

__8. Below h1 tag, add following text:

Welcome to ABC Inc.

Notice you haven't enclosed the above text in any tag. You are purposefully skipping a 
tag. You will treat as a bug and fix it later.

__9. Save the file and close the Notepad window.

__10. Stage the changed index.html:

git add index.html 

__11. Commit the changes:

git commit -m "Added company name to index.html"

__12. Merge feature changes into the develop branch without deleting the feature branch.
Enter the following lines, pressing 'return' after each line:

git checkout develop 
git merge --no-ff feature/HOME_PAGE
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__13. Start another release from develop branch:

git checkout -b release/REL_2.0

__14. ...and finish it off by merging it back into master and tagging it:

git checkout master
git merge release/REL_2.0
git tag "REL_2.0" -m "REL_2.0"

(note that we haven't really accomplished much here - we could have got the same result 
by merging the feature branch into 'master' and tagging it, but we want to get in the habit 
of merging the release branches properly.  Also, some shops like to use '--no-ff' to make 
sure the merge is recorded).

__15. Finally, let's merge back to 'develop' and get rid of the release branch:

git checkout develop 
git merge master
git branch -d release/REL_2.0

__16. View tag list:

git tag 

Notice it shows REL_1.0 and REL_2.0.

If you want to checkout a certain release based on tag, you can execute following 
command:

git checkout tags/<tag_name>

Part 7 - Working with Hotfixes.

In this part you will create a Gitflow hotfix.

__1. Create a new hotfix, based on the 'master' branch (of course you could base it on a 
different release tag if needed):

git checkout master
git checkout -b hotfix/REL_2.0.1

Notice hotfix will end up creating a new release.
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__2. Open index.html file in the Notepad:

notepad index.html

__3. Enclose Welcome to ABC Inc. within <b> HTML tag.

__4. Save the file and close the Notepad window.

__5. Stage the changed index.html file:

git add index.html

__6. Commit changes:

git commit -m "Enclosed company name in the bold HTML tag"

__7. Finish the hotfix by entering the following commands, pressing 'return' after each 
line:

git checkout master
git merge hotfix/REL_2.0.1
git tag "REL_2.0.1" -m "REL_2.0.1"
git branch -d hotfix/REL_2.0.1

__8. ...and, let's bring the change back to 'develop':

git checkout develop 
git merge master

__9. Finally, push all changes into the remote repository:

git push --all

Part 8 - Verify all releases are created

In this part you will verify all releases are created.

__1. Get tag list:

git tag 

Notice REL_1.0, REL_2.0, and REL_2.0.1 are available.
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__2. View current tag name:

git describe

Notice the prefix is REL_2.0.1

__3. Checkout REL_1.0:

git checkout tags/REL_1.0

__4. View current tag name:

git describe

Notice the prefix is REL_1.0

__5. View index.html file contents:

type index.html

Notice there's no "Welcome to ABC Inc." text.

__6. Checkout REL_2.0:

git checkout tags/REL_2.0

__7. View current tag name:

git describe

Notice the prefix is REL_2.0

__8. View index.html file contents:

type index.html

Notice there's "Welcome to ABC Inc." text, but it's not enclosed in <b> tag.
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__9. Checkout REL_2.0.1:

git checkout tags/REL_2.0.1

__10. View current tag name:

git describe

Notice the prefix is REL_2.0.1

__11. View index.html file contents:

type index.html

Notice there's "Welcome to ABC Inc." text enclosed in <b> tag.

__12. Close all.

Part 9 - Review

In this lab you explored Gitflow feature, release, hotfix, and various other options.
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Lab 2 - Monolith vs Microservices Design
In this lab, you will be presented with two types of application architecture for a fictitious
Java EE application: the monolith and a microservices-based one.  You will be required to
identify the main differences in their designs and answer some questions.  For certain 
questions there is no single answer; feel free to share your answer(s) with the rest of the 
group. 

Part 1 - Breaking the Monolith

__1. Compare the Monolith Application Architecture 1 (Fig.1) with Microservices 
Architecture 2 (Fig.2), and name some of the differences.  
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 Fig 1. Application Architecture 1: Traditional (Java) Enterprise Application Architecture Example.

Fig. 2 Application Architecture 2: Microservices-based Architecture Example.
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__2. What kind of Quality of Service properties we gain / lose by going from 
Architecture 1 to  Architecture 2?

__3. Which type of architecture more easily support scalability? 

__4. What would be involved if you need to change a single Java file (e.g. a servlet)?

__5. In which type of architecture you need to have more powerful computers? Is it about
CPU, RAM, or both?

__6. You need to recycle the machines hosting the applications. In which case you will 
have a shorter application start up time? 

Part 2 - The 12-Factor App 

Go through the twelve-factor app principles [http://12factor.net] and try to see how, if at 
all, that methodology is applied in both App Architecture (Fig. 1 and Fig.2).  

For example, you can notice that the Application in Fig.1 may be hard to scale through 
the process principle (VIII) that is broken as all code is bundled together (in one bundle / 
archive).

Mind you that not all factors can be identified here, though.

Part 3 - Microservices Pros and Cons

Which of the following statements you believe may be related to microservices, and, if 
so, which ones should be viewed as being an argument in favor or against using 
microservices.  Compare/share your findings with the class, if you wish so.

1. As my app is deployed and executed in its own run-time (often in a container or a 
VM of sorts), I can get stronger process isolation properties.

2. Change cycles for different services can be more easily decoupled.  For example, 
I can re-deploy Service A without affecting Service B.

3. I have to deal with performance overhead related to inter-process communication.

4. Deployment cycles and developer velocity are faster (due to the smaller footprint 
of the service).

5. With this type of app, I can do scaling per service / per tier.

6. My app boasts a fantastic performance and fast service interactions; it also has a 
nice and small security perimeter.

7. Now I have to deal with a considerable operational overhead (the accidental 
complexity) with more distinct moving parts that require precisely orchestrated 
deployment and distributed monitoring.

8. My application has all the required services housed in one place and they get 
deployed using a single archive.  The app is designed using the standard SOA 
principles: its services are mapped to distinct business capabilities, the services  
are narrow, composable, and accessible through a well-defined WSDL-based web 
service interface.
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9. Now it is more of a nanoservice, really.  Which is really cool, right?

10. Smaller development teams can be set up to develop and maintain the services 
which leads to faster getting-up-to-speed and development cycles.

11. Now, with this type of design, you must persist any state in a reliable external 
(e.g. caching) service. 

Part 4 - Review 

In this lab, we compared two types of application architecture: the monolith and one 
based on microservices.  
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Lab 3 - A Simple RESTful API in Spring Boot
In this lab we're going to build a simple "Hello World" API using Spring Framework and 
Spring Boot.  The API will implement a single resource, "/hello-message" that returns a 
JSON object that contains a greeting.

Part 1 - Update Gradle in Eclipse

You will continue using the 'VM _WA2874_REL_1_0' on this Lab or your local 
setup in your computer depending where the software was installed.

We're going to start from scratch on this project, with an empty Gradle project, and add in
the dependencies that will make a Spring Boot project with a core set of capabilities that 
we can use to implement our "Hello World" API.

__1. Open Eclipse by navigating to C:\Software\eclipse and double-clicking on 
eclipse.exe

__2. In the Workspace Launcher dialog, enter 'C:\Workspace' in the Workspace field, 
and then click Launch.

__3. Close the Welcome panel.
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We need to update gradle.

__4. From the menu, select Help > Eclipse Marketplace.

__5. In the Find box, type gradle and hit enter.

__6. Click the Installed tab.

__7. Locate Buildship Gradle Integration 3.0 and click the Installed button.

__8. This will take you to the Installed tab, locate Buildship Gradle Integration 3.0 and
click the Update button.

__9. Accept the license agreement and click Finish.

Wait for the installation to be completed.
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__10. A dialog will open when the updates are installed, click Restart Now.

We are ready to work with Gradle.

Part 2 - Create a Gradle Project

__1. From the main menu, select File →  New →  Project…

__2. In the New Project dialog, select Gradle → Gradle Project.

__3. Click Next.

__4. If it shows you a Welcome dialog, uncheck the checkbox Show the welcome page 
the next time the wizard appears and click Next.
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__5. In the New Gradle Project dialog, enter the following and then click Next:

Project name: hello-api

__6. Click Finish.

If necessary, wait for Eclipse to finish any background process.

You should see an error in the project.

__7. Right click the hello-api project and select Properties.

__8. In the left pane, select Java Build Path and in the right select the Libraries tab.

__9. Select JRE System Library [JavaSE-14] and click Edit.

__10. Select Workspace default JRE (jdk-14) and click Finish.

__11. Click Apply and Close.

The error in the project will be gone.

Part 3 - Configure the Project as a Spring Boot Project

The steps so far have created a basic Gradle project.  Now we'll add the dependencies to 
make a Spring Boot project.
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__1. Expand the hello-api project in the Project Explorer.

__2. Expand src/main/java tree node.

__3. Delete everything that you see inside this folder.

__4. Expand src/test/java tree node.

__5. Delete everything that you see inside this folder.

__6. Double-click on build.gradle to open it.

__7. Select and delete all the existing content of build.gradle file.

__8. Enter the following content to the file:

apply plugin: 'java'
apply plugin: 'maven'

group = 'com.webage.spring.samples'
version = '0.0.1-SNAPSHOT'

sourceCompatibility = 1.8
targetCompatibility = 1.8

repositories {
        
     mavenCentral()
}

dependencies {
    compile group: 'org.springframework.boot', name: 'spring-boot-
starter-web', version:'2.1.8.RELEASE'
}

The entries above call out the Spring Boot dependencies.  

__9. Save the file by pressing Ctrl-S or selecting File →  Save from the main menu.

__10. Right-click the project and click Gradle > Refresh Gradle Project.

__11. Make sure the Markers tab doesn’t show any error.

Part 4 - Create an Application Class

Spring Boot uses a 'Main' class to startup the application and hold the configuration for 
the application.  In this section, we'll create the main class.

__1. In the Project Explorer, right-click on src/main/java and then select New →  
Package.
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__2. Enter com.webage.spring.samples.hello in the Name field, and then click Finish.

__3. In the Project Explorer, right-click on the newly-created package and then select 
New →  Class.

__4. In the New Java Class dialog, enter 'HelloApi' as the Name, and then click Finish.

__5. Add the @SpringBootApplication annotation to the class, so it appears like:

@SpringBootApplication
public class HelloApi {

__6. Add the following 'main' method inside the class:

public static void main(String[] args) {
SpringApplication.run(HelloApi.class, args);

}
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__7. The editor is probably showing errors due to missing 'import' statements.  Press 
Ctrl-Shift-O to organize the imports.

__8. Save the file.

__9. Switch to Gradle Tasks pane and expand hello-api project.

Note: If Gradle Tasks pane isn’t visible, in Eclipse, click Window > Show View > 
Other... > Gradle > Gradle Tasks and then click OK

__10. Expand build, then right-click build and select Run Gradle Tasks.

__11. Switch to Console pane and ensure the build was performed successfully.

Now all we need to do is add a resource class and a response class.

Part 5 - Implement the RESTful Service

In this part of the lab, we will create a response class and a RESTful resource class.

__1. In the Project Explorer, right-click on src/main/java and then select New →  
Package.

__2. Enter com.webage.spring.samples.hello.api in the Name field, and then click 
Finish.
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__3. In the Project Explorer, right-click on the newly-created package and then select 
New →  Class.

__4. In the New Java Class dialog, enter HelloResponse as the Name, and then click 
Finish.

__5. Edit the body of the class so it reads as follows:

package com.webage.spring.samples.hello.api;

public class HelloResponse {
String message;

public HelloResponse(String message) {
super();
this.message = message;

}

public String getMessage() {
return message;

}

public void setMessage(String message) {
this.message = message;

}

}

__6. Save the file.

__7. In the Project Explorer, right-click on the com.webage.spring.samples.hello.api 
package and then select New →  Class.

__8. In the New Java Class dialog, enter HelloResource as the Name, and then click 
Finish.

__9. Add the following 'getMessage' method inside the new class:

public HelloResponse getMessage() {
return new HelloResponse("Hello!");

}

Spring Boot recognizes and configures the RESTful resource components by the 
annotations that we're about to place on the resource class that we just created.
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__10. Add the '@RestController' annotation to HelloResource, so it looks like:

@RestController
public class HelloResource {

__11. Add the '@GetMapping' annotation to the 'getMessage' method, so it looks like:

@GetMapping("/hello-message")
public HelloResponse getMessage() {

__12. Organize the imports by pressing Ctrl-Shift-O.

__13. Save all files by pressing Ctrl-Shift-S.

__14. Switch to Gradle Tasks pane and expand hello-api project.

__15. Expand build, then right-click build and select Run Gradle Tasks.

__16. Switch to Console pane and ensure the build was performed successfully.

Note. If fails building try again and the second time should works.

The console should show a successful build.  

Part 6 - Run and Test

That's all the components required to create a simple RESTful API with Spring Boot.  
Now let's fire it up and test it!

__1. In the Project Explorer, right-click on the HelloApi class and select Run as → 
Java Application.

__2. If the Windows Security Alert window pops up, click on Allow Access.

__3. Watch the Console panel.  At the bottom of it, you should see a message indicating 
that the HelloApi program has started successfully:

__4. Open the Chrome browser and enter the following URL in the location bar:

http://localhost:8080/hello-message
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__5. You should see the following response:

Notice that the response is in the form of a JSON object whose structure matches the 
'HelloResponse' class contents.

__6. Close the browser.

__7. Click on the red 'Stop' button on the Console panel to stop the application.

__8. Click Remove All Terminated Launches.

__9. Close all open files.

Part 7 - Review

In this lab, we setup a rudimentary Spring Boot application.  There are a few things you 
should notice:

• There was really very little code and configuration required to implement the very
simple RESTful API.

• The resulting application runs in a standalone configuration without requiring a
web or application server.  It opens its own port on 8080 (we'll see later how to
configure this port to any value you want).

• Although the Eclipse IDE is providing some nice features, like type-ahead support
and automatic imports, the only tool we really need is a build tool that does
dependency management (e.g. Gradle).
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	__19. View remote repository content:
	__20. Push changes from local repository into the remote repository:
	__21. View remote repository content:

	Part 6 - Create a new Release
	__1. Create a new release "REL_1.0" based on develop branch. We'll use the common convention of calling the release "release/REL_1.0".  Enter the following lines, pressing 'return' after each line:
	__2. Let's finish the release.  As a reminder, the GitFlow workflow suggests that we should merge the release branch into 'master' and then tag the release.  Enter the following lines, pressing 'return' after each line:
	__3. Now, we should get rid of the release branch and then update the 'develop' branch to reflect the latest release (as reflected by the state of the 'master' branch). Enter the following lines, pressing 'return' after each line:
	__4. Get branch list:
	__5. Push all changes to the remote repository:
	__6. Switch to the feature/HOME_PAGE branch:
	__7. Open index.html file in Notepad:
	__8. Below h1 tag, add following text:
	__9. Save the file and close the Notepad window.
	__10. Stage the changed index.html:
	__11. Commit the changes:
	__12. Merge feature changes into the develop branch without deleting the feature branch. Enter the following lines, pressing 'return' after each line:
	__13. Start another release from develop branch:
	__14. ...and finish it off by merging it back into master and tagging it:
	__15. Finally, let's merge back to 'develop' and get rid of the release branch:
	__16. View tag list:

	Part 7 - Working with Hotfixes.
	In this part you will create a Gitflow hotfix.
	__1. Create a new hotfix, based on the 'master' branch (of course you could base it on a different release tag if needed):
	__2. Open index.html file in the Notepad:
	__3. Enclose Welcome to ABC Inc. within <b> HTML tag.
	__4. Save the file and close the Notepad window.
	__5. Stage the changed index.html file:
	__6. Commit changes:
	__7. Finish the hotfix by entering the following commands, pressing 'return' after each line:
	__8. ...and, let's bring the change back to 'develop':
	__9. Finally, push all changes into the remote repository:

	Part 8 - Verify all releases are created
	In this part you will verify all releases are created.
	__1. Get tag list:
	__2. View current tag name:
	__3. Checkout REL_1.0:
	__4. View current tag name:
	__5. View index.html file contents:
	__6. Checkout REL_2.0:
	__7. View current tag name:
	__8. View index.html file contents:
	__9. Checkout REL_2.0.1:
	__10. View current tag name:
	__11. View index.html file contents:
	__12. Close all.

	Part 9 - Review

	Lab 2 - Monolith vs Microservices Design
	Part 1 - Breaking the Monolith
	__1. Compare the Monolith Application Architecture 1 (Fig.1) with Microservices Architecture 2 (Fig.2), and name some of the differences.
	__2. What kind of Quality of Service properties we gain / lose by going from Architecture 1 to Architecture 2?
	__3. Which type of architecture more easily support scalability?
	__4. What would be involved if you need to change a single Java file (e.g. a servlet)?
	__5. In which type of architecture you need to have more powerful computers? Is it about CPU, RAM, or both?
	__6. You need to recycle the machines hosting the applications. In which case you will have a shorter application start up time?

	Part 2 - The 12-Factor App
	Part 3 - Microservices Pros and Cons
	Part 4 - Review

	Lab 3 - A Simple RESTful API in Spring Boot
	Part 1 - Update Gradle in Eclipse
	__1. Open Eclipse by navigating to C:Softwareeclipse and double-clicking on eclipse.exe
	__2. In the Workspace Launcher dialog, enter 'C:Workspace' in the Workspace field, and then click Launch.
	__3. Close the Welcome panel.
	__4. From the menu, select Help > Eclipse Marketplace.
	__5. In the Find box, type gradle and hit enter.
	__6. Click the Installed tab.
	__7. Locate Buildship Gradle Integration 3.0 and click the Installed button.
	__8. This will take you to the Installed tab, locate Buildship Gradle Integration 3.0 and click the Update button.
	__9. Accept the license agreement and click Finish.
	__10. A dialog will open when the updates are installed, click Restart Now.

	Part 2 - Create a Gradle Project
	__1. From the main menu, select File → New → Project…
	__2. In the New Project dialog, select Gradle → Gradle Project.
	__3. Click Next.
	__4. If it shows you a Welcome dialog, uncheck the checkbox Show the welcome page the next time the wizard appears and click Next.
	__5. In the New Gradle Project dialog, enter the following and then click Next:
	Project name: hello-api
	__6. Click Finish.
	__7. Right click the hello-api project and select Properties.
	__8. In the left pane, select Java Build Path and in the right select the Libraries tab.
	__9. Select JRE System Library [JavaSE-14] and click Edit.
	__10. Select Workspace default JRE (jdk-14) and click Finish.
	__11. Click Apply and Close.

	Part 3 - Configure the Project as a Spring Boot Project
	__1. Expand the hello-api project in the Project Explorer.
	__2. Expand src/main/java tree node.
	__3. Delete everything that you see inside this folder.
	__4. Expand src/test/java tree node.
	__5. Delete everything that you see inside this folder.
	__6. Double-click on build.gradle to open it.
	__7. Select and delete all the existing content of build.gradle file.
	__8. Enter the following content to the file:
	__9. Save the file by pressing Ctrl-S or selecting File → Save from the main menu.
	__10. Right-click the project and click Gradle > Refresh Gradle Project.
	__11. Make sure the Markers tab doesn’t show any error.

	Part 4 - Create an Application Class
	__1. In the Project Explorer, right-click on src/main/java and then select New → Package.
	__2. Enter com.webage.spring.samples.hello in the Name field, and then click Finish.
	__3. In the Project Explorer, right-click on the newly-created package and then select New → Class.
	__4. In the New Java Class dialog, enter 'HelloApi' as the Name, and then click Finish.
	__5. Add the @SpringBootApplication annotation to the class, so it appears like:
	__6. Add the following 'main' method inside the class:
	__7. The editor is probably showing errors due to missing 'import' statements. Press Ctrl-Shift-O to organize the imports.
	__8. Save the file.
	__9. Switch to Gradle Tasks pane and expand hello-api project.
	__10. Expand build, then right-click build and select Run Gradle Tasks.
	__11. Switch to Console pane and ensure the build was performed successfully.

	Part 5 - Implement the RESTful Service
	__1. In the Project Explorer, right-click on src/main/java and then select New → Package.
	__2. Enter com.webage.spring.samples.hello.api in the Name field, and then click Finish.
	__3. In the Project Explorer, right-click on the newly-created package and then select New → Class.
	__4. In the New Java Class dialog, enter HelloResponse as the Name, and then click Finish.
	__5. Edit the body of the class so it reads as follows:
	__6. Save the file.
	__7. In the Project Explorer, right-click on the com.webage.spring.samples.hello.api package and then select New → Class.
	__8. In the New Java Class dialog, enter HelloResource as the Name, and then click Finish.
	__9. Add the following 'getMessage' method inside the new class:
	__10. Add the '@RestController' annotation to HelloResource, so it looks like:
	__11. Add the '@GetMapping' annotation to the 'getMessage' method, so it looks like:
	__12. Organize the imports by pressing Ctrl-Shift-O.
	__13. Save all files by pressing Ctrl-Shift-S.
	__14. Switch to Gradle Tasks pane and expand hello-api project.
	__15. Expand build, then right-click build and select Run Gradle Tasks.
	__16. Switch to Console pane and ensure the build was performed successfully.

	Part 6 - Run and Test
	__1. In the Project Explorer, right-click on the HelloApi class and select Run as → Java Application.
	__2. If the Windows Security Alert window pops up, click on Allow Access.
	__3. Watch the Console panel. At the bottom of it, you should see a message indicating that the HelloApi program has started successfully:
	__4. Open the Chrome browser and enter the following URL in the location bar:
	__5. You should see the following response:
	__6. Close the browser.
	__7. Click on the red 'Stop' button on the Console panel to stop the application.
	__8. Click Remove All Terminated Launches.
	__9. Close all open files.

	Part 7 - Review

	Lab 4 - Use the Spring JDBCTemplate under Spring Boot
	Part 1 - Import the Starter Project
	__1. In eclipse, from the menu, select Window > Preferences.
	__2. From the left menu, select Gradle.
	__3. Select Specific Gradle version and pick 6.3 from the drop-down.
	__4. Click Apply and Close.
	__5. Extract the contents of C:LabFilesGradleSpring-Boot-JDBC-Starter.zip to C:Workspace directory.
	__6. Verify the following folder was created:
	__7. From Eclipse's main menu, select File →  Import and select Gradle →  Existing Gradle Project, and then click Next.
	__8. If you see the Welcome page, uncheck the box and click Next.
	__9. Click Browse button.
	__10. Select C:Workspacespring-boot-jdbc2-starter and click Select Folder.
	__11. Make sure you have the right project as shown below:
	__12. Click Finish.

	Part 2 - Enable the Default Embedded Database
	__1. In the Project Explorer, locate the build.gradle file for spring-boot-jdbc2-starter project and double-click it to open it.
	__2. Add the following dependency into the dependencies block:
	__3. Save the file.
	__4. Right-click the spring-boot-jdbc2-starter project and click Gradle > Refresh Gradle Project.
	__5. Switch to Gradle Tasks pane.
	__6. Expand spring-boot-jdbc2-starter > build.
	__7. Right-click on build and click Run Gradle tasks.
	__8. Switch to Console pane and ensure there are no error messages.

	Part 3 - Configure the JDBCTemplate
	__1. In the Project Explorer, expand spring-boot-jdbc2-starter > src/main/java.
	__2. Right-click on the 'com.webage.dao' package and select New → Class.
	__3. Enter DAOConfig as the new class name and then click Finish.
	__4. Add the annotation '@Configuration' to the class, as shown below:
	__5. Organize the imports by pressing Ctrl-Shift-O.
	__6. Inside the class, create a method 'jdbcTemplate()' as shown below:
	__7. Organize the imports by pressing Ctrl-Shift-O. Select javax.sql.DataSource, if prompted.
	__8. Save the file.

	Part 4 - Complete the DAO Class
	__1. Locate the class called 'JDBCPurchaseDAO' in the 'com.webage.dao' package. Double-click on the class to open it.
	__2. Look for the method that currently looks like below:
	__3. Replace the line 'return null;' with a call to jdbcTemplate, so that the method appears as:
	__4. Save all files by pressing Ctrl-Shift-S.

	Part 5 - Compile and Test
	__1. Switch to Gradle Tasks pane.
	__2. Expand spring-boot-jdbc2-starter > build.
	__3. Right-click build and click Run Gradle tasks.
	__4. Switch to Console pane and ensure there are no error messages.
	__5. Expand src/main/java > com.webage
	__6. Right click App.java and select Run As > Java application.
	__7. Wait until you see this message:
	__8. Open a browser and enter the following url:
	__9. You should see the results of our database query.
	__10. Close the browser.
	__11. Close all open files.
	__12. Click on the red stop button in the console panel to stop the Spring Boot application:
	__13. Click Remove All Terminated Launches.

	Part 6 - Review

	Lab 5 - Use the Spring Data JPA under Spring Boot
	Part 1 - Import the Starter Project
	__1. Extract the contents of C:LabFilesGradleSpring-Boot-JPA-Starter.zip to C:Workspace directory.
	__2. Verify the following folder was created:
	__3. From Eclipse's main menu, select File →  Import and select Gradle →  Existing Gradle Project, and then click Next.
	__4. Click Browse button.
	__5. Select C:Workspacespring-boot-jpa and click Select Folder.
	__6. Click Finish.

	Part 2 - Examine the Starter Project
	__1. Expand the spring-boot-jpa project.
	__2. Open buid.gradle.

	Part 3 - Annotate the Domain Classes
	__1. Expand spring-boot-jpa > src/main/java > com.webage.domain.
	__2. Open the Customer class.
	__3. Add the '@Entity' and '@Table' annotations to the class as shown below. These annotations designate that the class should be managed by JPA and tell JPA what database table name to use for the class:
	__4. Add annotations to the 'id' field so it appears as below. These annotations mark the 'id' field as the primary key of 'Customer' and tell JPA how it's going to be generated:
	__5. The 'name' field in 'Customer' is modeled by a column called 'CUSTOMER_NAME' in the database table that we are using. So, the default mapping of field name to column name will not work in this case. Annotate the field as shown below to override the default name mapping:
	__6. Organize the imports by pressing Ctrl-Shift-O. Select javax.persistence.Entity, javax.persistence.Table and javax.persistence.Id.
	__7. Save the file.
	__8. Open the Purchase class inside 'com.webage.domain'.
	__9. Add the '@Entity' and '@Table' annotations to the class as shown below. These annotations designate that the class should be managed by JPA and tell JPA what database table name to use for the class:
	__10. Add annotations to the 'id' field so it appears as below. These annotations mark the 'id' field as the primary key of 'Customer' and tell JPA how it's going to be generated.
	__11. Annotate the 'customer' field as shown below to tell JPA that it should load the value from an associated table.
	__12. Organize the imports by pressing Ctrl-Shift-O. Select javax.persistence.Entity, javax.persistence.Table and javax.persistence.Id.
	__13. Save the file.

	Part 4 - Create the Repository Interfaces
	__1. Open the interface called 'PurchaseRepository' in the 'com.webage.repository' package.

	Part 5 - Observe the Usage
	__1. Open the 'PurchaseServiceImpl' class in the com.webage.services package. For convenience, the contents are shown below:

	Part 6 - Compile and Test
	__1. Right click spring-boot-jpa and select Gradle → Refresh Gradle Project.
	__2. Switch to Gradle Tasks pane.
	__3. Expand spring-boot-jpa > build.
	__4. Right click build and click Run Gradle tasks.
	__5. Ensure there are no errors in Console pane.
	__6. Run the 'App' class as a Java application.
	__7. Open a browser and enter the following url:
	__8. You should see the results of our database query.
	__9. Close the browser.
	__10. Close all open files.
	__11. Click on the red stop button in the console panel to stop the Spring Boot application:
	__12. Click Remove All Terminated Launches.

	Part 7 - Review

	Lab 6 - Create a RESTful API with Spring Boot
	Part 1 - Import the Starter Project
	__1. Extract the contents of C:LabFilesGradleSpring-Boot-REST-Starter.zip to C:Workspace directory.
	__2. Verify the following folder was created:
	__3. From Eclipse's main menu, select File →  Import and select Gradle →  Existing Gradle Project, and then click Next.
	__4. Click Browse button.
	__5. Select C:Workspacespring-boot-rest and click Select Folder.
	__6. Click Finish.

	Part 2 - Examine the Starter Project
	__1. Right click spring-boot-rest and select Gradle → Refresh Gradle Project.
	__2. Switch to Gradle Tasks pane.
	__3. Expand spring-boot-rest > build.
	__4. Right click build and click Run Gradle tasks.
	__5. Ensure there are no errors in Console pane.

	Part 3 - Create the Customer API Class
	__1. In the Project Explorer, locate the 'spring-boot-rest > src/main/java' node.
	__2. Right-click on 'src/main/java' and select New → Package.
	__3. Enter com.webage.api as the package name and then click Finish.
	__4. Right-click on the newly-created package and select New → Class.
	__5. Enter CustomerAPI as the class name and then click Finish.
	__6. We need to flag this class as a resource controller and assign a URL path for it. To do that, add annotations to the class as shown below:
	__7. Inside the body of the class, add an '@Autowired' reference to the 'CustomersRepository' implementation, as shown below:

	Part 4 - Implement a GET method
	__1. In the body of the 'CustomerAPI' class, add the following method. It will use the repository proxy to retrieve an 'Iterable' object that iterates through all the customers:
	__2. We want this method to respond to a 'GET' request on the '/customers' path. Since the API class is already annotated with the required path, all we need to do is flag this class as a 'GET' method. To do so, add the '@GetMapping' annotation to the method as shown below:
	__3. Organize the imports by pressing Ctrl-Shift-O.
	__4. Save the file.

	Part 5 - Test the GET Method
	__1. Switch to Gradle Tasks pane.
	__2. Expand spring-boot-rest > build.
	__3. Right click build and click Run Gradle tasks.
	__4. Ensure there are no errors in Console pane.
	__5. Run the 'App' class as a Java Application.
	__6. From the Start menu, find and open Postman.
	__7. Click the + to add a new tab.
	__8. Select the 'GET' request using the drop-down box, and enter localhost:8080/customers as the URL:
	__9. Click the Send button.

	Part 6 - Lookup a Specific Customer by ID
	__1. Back in eclipse, in the body of the CustomerAPI class, add the following method:
	__2. Organize imports. Select java.util.Optional.
	__3. Save the file.
	__4. If you still have 'App.java' running from the previous test, stop it using the red stop button in the console window.
	__5. Switch to Gradle Tasks pane.
	__6. Expand spring-boot-rest > build.
	__7. Right click build and click Run Gradle tasks.
	__8. Ensure there are no errors in Console pane.
	__9. Run App.java
	__10. In the Postman tool, add an identifier to the end of the URL:
	__11. Click Send.
	__12. Once again, leave Postman open, but stop 'App.java'.

	Part 7 - Add a POST Method Handler
	__1. In the 'CustomerAPI' class, add the following method.
	__2. Organize imports. Select org.springframework.http.HTTPRequest, if prompted.
	__3. Save the file.
	__4. Switch to Gradle Tasks pane.
	__5. Expand spring-boot-rest > build.
	__6. Right click build and click Run Gradle tasks.
	__7. Ensure there are no errors in Console pane.
	__8. Run App.java
	__9. In the Postman tool, open a new tab by clicking on the '+' icon in the tab headers.
	__10. Click the 'method' drop-down box and select 'POST'.
	__11. Enter localhost:8080/customers as the request URL.
	__12. Select the Body tab and then click the radio button for raw.
	__13. Expand the drop-down box and select JSON
	__14. Enter the following new customer object in the body text area (hint: you might find it convenient to copy and edit an object from the response to the 'GET' request that we issued earlier - it's in the other tab in Postman):
	__15. When it looks like below, click Send.
	__16. Click on the Headers tab in the response area [bottom section]. You should see the 'Location' header:
	__17. Copy the contents of the 'Location' header into the URL area and issue a GET request.
	__18. Leave Postman open, but stop 'App.java'

	Part 8 - Add a PUT Method Handler
	__1. Add the following method to the 'CustomerAPI' class:
	__2. Organize the imports by pressing Ctrl-Shift-O.
	__3. Save the file.
	__4. Switch to Gradle Tasks pane.
	__5. Expand spring-boot-rest > build.
	__6. Right click build and click Run Gradle tasks.
	__7. Ensure there are no errors in Console pane.
	__8. Run App.java
	__9. In the Postman tool, open a new tab by clicking on the '+' icon in the tab headers.
	__10. Click the 'method' drop-down box and select 'PUT'.
	__11. Enter 'localhost:8080/customers/4' as the request URL.
	__12. Select the 'Body' tab and then click the radio button for 'raw'.
	__13. Expand the drop-down box and select JSON.
	__14. Enter the following new customer object in the body text area:
	__15. When looks like below click Send.
	__16. In a different tab in Postman, do a 'GET' request to '/customers'
	__17. Close Postman.
	__18. Back in eclipse, close all open files.
	__19. Stop 'App.java' by clicking on the red stop button.
	__20. Click Remove All Terminated Launches.

	Part 9 - Review

	Lab 7 - Enable Basic Security
	Part 1 - Import the Starter Project
	__1. Extract the contents of C:LabFilesGradleSpring-Boot-Basic-Security-Starter.zip to C:Workspace directory.
	__2. Verify the following folder was created:
	__3. From Eclipse's main menu, select File →  Import and select Gradle →  Existing Gradle Project, and then click Next.
	__4. Click Browse button.
	__5. Select C:Workspacespring-boot-basic-security and click Select Folder.
	__6. Click Finish.

	Part 2 - Enable Security
	__1. In the Project Explorer, expand spring-boot-basic-security.
	__2. Locate 'build.gradle' and double-click on it to open the file.
	__3. Add the following dependency element just before the closing dependencies block {:
	__4. Save and close the file.

	Part 3 - Configure the User Password
	__1. In the Project Explorer, locate the node for 'src/main/resources'.
	__2. Right-click on 'src/main/resources' and then select New → Other, and select General → File.
	__3. Enter application.properties as the filename and click Finish.
	__4. In the new file, enter the following lines:
	__5. Save and close the file.

	Part 4 - Build and Test
	__1. Right click spring-boot-basic-security and select Gradle → Refresh Gradle Project.
	__2. Switch to Gradle Tasks pane.
	__3. Expand spring-boot-basic-security > build.
	__4. Right click build and click Run Gradle tasks.
	__5. Ensure there are no errors in Console pane.
	__6. Right-click App.java under src/main/java → com.webage and click Run As → Java Application.
	__7. Open a browser and navigate to:
	__8. You will be prompted for a user name and password.
	__9. Enter user as the username and Pa$$w0rd as the password and then click Sign in.
	__10. Once you've entered your password, you will have full access to the application.
	__11. Close the browser.
	__12. Stop 'App.java' by clicking on the red stop button.
	__13. Click Remove All Terminated Launches.
	__14. Close all open files.

	Part 5 - Review

	Lab 8 - Getting Started with Docker
	Part 1 - Setting the Stage
	__1. Make sure internet is connected in the VM.
	__2. Open a new Terminal window by clicking Applications > Terminal.
	__3. Switch the logged-in user to root:
	__4. Enter the following command:
	__5. Enter the following command:
	__6. Get directory listing:

	Part 2 - Learning the Docker Command-line
	__1. Run the following command:
	__2. Navigate through the scrollable output using your arrow keys and review Docker's commands.
	__3. Enter q to exit.
	__4. You can get command-specific help by using the --help flag added to the commands invocation line, e.g. to list containers created by Docker (the command is called ps), use the following command:

	Part 3 - Run the "Hello World!" Command on Docker
	__1. Enter the following command:
	__2. Enter the following command:

	Part 4 - List and Delete Container
	__1. Open a new terminal, expand it width wise (horizontally) to capture the output of the docker ps command we are going to run into it. Also make sure it does not completely overlap the original terminal window.
	__2. In the new terminal (T2) become root (use the sudo -i command).
	__3. Change to the ~/Works directory:
	__4. Enter the following command:
	__5. To see a list of all containers, whether active or inactive, run the following command:
	__6. Switch to the original terminal window (T1).
	__7. Enter the following command and replace the container id with the one from T2:
	__8. Switch to the T2 terminal.
	__9. Enter the following command:

	Part 5 - Working with Containers
	__1. Switch to the T1 terminal.
	__2. Enter the following command:
	__3. Enter the following command to stop the container and exit out to the host OS:
	__4. Enter the following command to see the containers:
	__5. Enter the following command to restart the container (pick the new one from the list):
	__6. Connect to the container:
	__7. Enter the following command:
	__8. Enter the following command:
	__9. Enter the following command:

	Part 6 - Create a Custom Image
	__1. Enter the following command providing your container id (aed47e954acd, in our case):
	__2. Enter the following command:
	__3. Enter the following command:
	__4. Enter the following command at the container prompt:

	Part 7 - Workspace Clean-Up
	__1. Enter the following command:
	__2. Enter the following command for every listed container id:
	__3. Verify there are no docker containers:
	__4. Remove the my_server:v1.0 image we created and persisted in our local image repository:
	__5. Verify your image has gone:

	Part 8 - Create a Dockerfile for Building a Custom Image
	__1. In the terminal, type following command to create Dockerfile:
	__2. Type in following code:
	__3. Click Save button.
	__4. Close gedit. You will see some errors on the Terminal, ignore them.
	__5. Type ls and verify your new file is there.
	__6. Run following command to build a custom image:

	Part 9 - Verify the Custom Image
	__1. In the terminal, run following command to verify the custom image exists:
	__2. Create a container based on the above image and connect to it:
	__3. Switch to the root directory in the container:
	__4. Get the directory list:
	__5. Execute the jar file:
	__6. Exit out from the container to the command prompt:
	__7. Get active docker container list:
	__8. Get list of all docker containers:

	Part 10 - Working with a Docker Volume
	__1. Create a volume:
	__2. Create a container and mount it in the container:
	__3. View mount point in container: (it will show the /world directory)
	__4. Create a file in the volume:
	__5. Exit out of the container:
	__6. Destroy the container: (Note: Make a note of the ID of your container and substitute it below)
	__7. Create another container and attach the volume as a mount point:
	__8. View mount point in container: (it will show the /world directory)
	__9. View contents of the file:
	__10. Exit out of the container:
	__11. View all volumes:

	Part 11 - Cleanup Docker
	__1. In the terminal, run following to get list of all containers:
	__2. In case, if there are any containers, stop (if running) and remove them by running following commands. Don't remove the ones you haven't created yourself in this lab:
	__3. Get list of all docker containers:
	__4. Delete the volume:
	__5. Get docker image list:
	__6. Remove all images that you created by executing following command:
	__7. Make sure your image has been deleted:
	__8. In each Terminal type exit and then close the Terminal window.

	Part 12 - Review

	Lab 9 - Load Balancing using Kubernetes
	Part 1 - Setting the Stage
	__1. Open a new Terminal window by clicking Applications > Terminal.
	__2. Switch the logged-in user to root:
	__3. Enter the following command:
	__4. Switch to the home directory:

	Part 2 - Start-Up Kubernetes
	__1. Check OpenShift cluster status: (Note: If the cluster is already started, skip all the steps of the part and move on to part 3 of the lab. Otherwise, if the cluster isn’t already started, perform all the remaining steps of this part and then move on to part 3 of this lab)
	__2. If the cluster isn’t running, perform all the remaining steps of this part of the lab.
	__3. Enter these commands to disable security:
	__4. Enter these commands to ensure an IP address is assigned to the machine:
	__5. Enter the following command to start Docker:
	__6. Start OpenShift by running the following command:

	Part 3 - Deploy an Application
	__1. Run a sample application, on Kubernetes with the kubectl run command:
	__2. List the deployments:
	__3. View pods:

	Part 4 - Expose a Service and Test It
	__1. To create a new service in Kubernetes, based on the application which you have in the deployed image, and expose it, run the following command:
	__2. Get the services list and ensure the service is exposed:
	__3. Make a note of the port listed in front of /TCP (it’s highlighted in the screen-shot displayed above. Your port number might be different)
	__4. Obtain the cluster IP:
	__5. Run the following command to test the service:
	__6. Run the curl command, mentioned in step above, multiple times.

	Part 5 - Scale-Up the Pod(s) and Verify Load Balancing
	__1. Get the pods list:
	__2. Scale up the pod by adding 4 replicas:
	__3. List the deployments:
	__4. Get the pods list:
	__5. Get the IP address of each pod:
	__6. Run the following command multiple times:

	Part 6 - Clean-Up
	__1. Stop Kubernetes cluster:
	__2. Close the terminal window.

	Part 7 - Review

	Lab 10 - Getting Started with Istio
	Part 1 - Setting the Stage
	__1. Open a new Terminal window by clicking Applications > Terminal.
	__2. Switch the logged-in user to root:
	__3. Enter the following command:
	__4. Switch to the home directory:

	Part 2 - Connect to OpenShift
	__1. Check OpenShift cluster status (Note: If the cluster is already started, skip all the steps of the part and move on to part 3 of the lab. Otherwise, if the cluster isn’t already started, perform all the remaining steps of this part and then move on to part 3 of this lab)
	__2. Enter these commands to disable security:
	__3. Enter these commands to ensure an IP address is assigned to the machine:
	__4. Enter the following command to start Docker:
	__5. Delete any existing kubernetes/OpenShift configuration:
	__6. Generate new configuration for Kubernetes/OpenShift:
	__7. Configure Kubernetes/OpenShift so sidecar/Envoy/Istio proxy can be injected:
	__8. Start OpenShift by running the following command:
	__9. After OpenShift cluster is started, make a note of the web console URL:
	__10. Find the user you are connected to OpenShift Origin as:
	__11. Let's connect as system:admin account:
	__12. Verify you are connected as system:admin:

	Part 3 - Setup Istio
	__1. Switch to the directory where Istio is available:
	__2. Add Istio to the path:
	__3. Run a script to setup prerequisites for BookInfo sample application: (Note: directory names are cAsE-sEnSiTiVe)
	__4. Install all the Istio Custom Resource Definitions (CRDs) using kubectl apply, and wait a few seconds for the CRDs to be committed in the Kubernetes API-server: (Note: there is a single statement. Due to text formatting, the second statement appears in two separate lines)
	__5. Install core components:

	Part 4 - Verify Istio Installation
	__1. Ensure the following Kubernetes services are deployed: istio-citadel, istio-pilot, istio-ingressgateway, istio-policy, and istio-telemetry (you'll also see the other deployed services):
	__2. You can also verify the above information by using OpenShift’s oc command:
	__3. Verify pods are running:
	__4. When all the pods are in Running or Completed state, set privileged to true for the istio-sidecar-injector:

	Part 5 - Circuit Breaker
	__1. Create a new project/namespace:
	__2. Make the new project the active project:
	__3. View httpbin.yaml:
	__4. The contents of the file looks like this:
	__5. Set up a sample application: (Note: It’s a single statement)
	__6. Verify a pod for the service is running:
	__7. Inject Fortio client with the Istio sidecar proxy so network interactions are governed by Istio:
	__8. Verify the pods are created:

	Part 6 - Explore the Service Application and the Client
	__1. Expose service:
	__2. Get routes exposed for the httpbin service.
	__3. Make a note of HOST/PORT (you can select the text using the mouse and copy it to clipboard).
	__4. From the Application menu, start Firefox.
	__5. Enter the URL you made a note of earlier in step 2 of this part. (HOST/PORT)
	__6. Expand HTTP Methods:
	__7. Enter the following URL in the browser: (Note: Don’t forget to add /get at the end)
	__8. Switch back to the Terminal window. Log in to the client pod and use the fortio tool to call httpbin. Pass in -curl to indicate that you just want to make one call:

	Part 7 - Configuring the Circuit Breaker
	__1. Inspect the contents of a yaml file which specifies circuit breaker rule:
	__2. Create a destination rule to apply circuit breaking settings when calling the httpbin service:
	__3. Verify the destination rule was created correctly:

	Part 8 - Tripping the Circuit Breaker
	__1. Call the service with one connection (-c 1) and send 20 requests (-n 20): (Don’t forget to add a space in between -- and load):
	__2. Call the service with two concurrent connections (-c 2) and send 20 requests (-n 20): (Note: Don’t forget to add a space in between -- and load):
	__3. Bring the number of concurrent connections up to 3:
	__4. Query the istio-proxy stats to see more:

	Part 9 - Clean-Up
	__1. Remove the rules:
	__2. Shutdown the httpbin service and client:
	__3. Delete the project/namespace:
	__4. Close the Terminal window and Web browser.
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