
WA2684 Developing MicroServices

Student Labs

Web Age Solutions Inc.

Copyright 2018 Web Age Solutions Inc. 1

EVALU
ATIO

N O
NLY



Table of Contents
Lab 1 - Setting Up a React Development Environment......................................................4
Lab 2 - Basic React Components.......................................................................................11
Lab 3 - More React Component Concepts.........................................................................25
Lab 4 - A Simple RESTful API in Spring Boot.................................................................43
Lab 5 - Use the Spring Web MVC Web Framework under Spring Boot...........................52
Lab 6 - Use the Spring JDBCTemplate under Spring Boot...............................................58
Lab 7 - Use the Spring Data JPA under Spring Boot.........................................................64
Lab 8 - Create a RESTful API with Spring Boot...............................................................71
Lab 9 - Create a RESTful Client with Spring Boot...........................................................84
Lab 10 - Enable Basic Security..........................................................................................88
Lab 11 - Use AMQP Messaging with Spring Boot............................................................92
Lab 12 - Use Netflix Eureka for Service Discovery..........................................................98
Lab 13 - Use Netflix Ribbon for Client-Side Load Balancing........................................108
Lab 14 - Use Netflix Hystrix for the Circuit Breaker Pattern..........................................114
Lab 15 - Develop a Simple AWS Lambda Function........................................................120
Lab 16 - Create Microservice Using AWS Lambda and Couchbase...............................131
Lab 17 - Kafka Basics......................................................................................................147
Lab 18 - Apache Kafka with Spring Boot and Nodejs.....................................................160
Lab 19 - Debugging a Node.js Application.....................................................................169
Lab 20 - Kubernetes Hello World ...................................................................................173
Lab 21 - Secret Handling in Kubernetes..........................................................................183
Lab 22 - Create an OpenShift Jenkins Pipeline for a Microservice.................................188
Lab 23 - Create an OpenShift Blue Ocean Pipeline for a Microservice..........................200
Lab 24 - Creating a REST Client with Feign...................................................................209

Copyright 2018 Web Age Solutions Inc. 2

EVALU
ATIO

N O
NLY



This course uses the following Virtual Machines on Windows and CentOS:

VM_WA2684 Windows

VM_WA2684 CentOS 1

VM_WA2684 CentOS 2

VM_WA2676 Windows

During the Labs you will be ask to connect to the right VM. 

You will also need a AWS key and a Couchbase Server IP that the instructor will provide 
to you.
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Lab 1 - Setting Up a React Development Environment
In this lab you will create a development setup that supports React development. The 
setup will take care of three essential issues:

• Transpiling ES6 code 

• Transpiling JSX code

• Serving React Application files ( index.html, etc. )

Node.js and npm should have been installed on your machine as part of the course setup. 
You will need them to complete this lab.

Part 1 - ES6 Transpilation support
In this part you will setup a development environment that transpiles ES6.

THE FOLLOWING LABS USE THE VIRTUAL MACHINE CALLED 
WA2676 VMware #3. CONNECT TO THIS VM FROM THE 
DESKTOP.
[For internal use: WA2676 Windows]

Make sure you are doing the Lab in the WA2676 VMware.

__1. Open a command prompt

__2. Create a directory to work in named:

C:\LabWork

__3. Create a directory "react-dev-env" inside the LabWork directory:

C:\LabWork\react-dev-env

This directory will be referred to in the lab as the project root.

__4. Navigate into the directory you just created
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__5. Create a new package.json file using the following command (take defaults for all 
settings):

npm init

__6. Use node package manager to install each of the following development 
dependencies into the project:

babel-cli
babel-preset-es2015
chokidar

Hint: npm install package-name --save-dev

es2015 is another name for JavaScript ES6 

chokidar helps babel watch for file changes

__7. Add the following scripts to the package.json file

"babel": "babel src --out-dir dist",
"babelw": "babel src --watch --out-dir dist"

__8. Create a ".babelrc" file in the project root with the following contents:

{"presets": ["es2015"]}

__9. Create a "\src" directory in the project directory

__10. Create a file named "test.js" in the "\src" directory.

__11. Add some ES6 code to test.js file. The code below can be used, or you can add 
your own. When done save the file.

class myclass{
  constructor(name){this.name = name;}
  display(){console.log(this.name);}
}
new myclass("myclass").display();

__12. Run the babel compiler using one of the scripts you added to package.json: 

npm run babel

__13. Check that babel did it job ( test.js should have been created in dist dir )
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__14. Open \dist\test.js in and editor. The code you see should look like this:

var _createClass = function () { ... }();

function _classCallCheck(instance, Constructor) { if (!
(instance instanceof Constructor)) { throw new 
TypeError("Cannot call a class as a function"); } }

var myclass = function () {
 function myclass(name) {
    _classCallCheck(this, myclass);

    this.name = name;
  }

  _createClass(myclass, [{
    key: "display",
    value: function display() {
      console.log(this.name);
    }
  }]);

  return myclass;
}();

new myclass("myclass").display();

This is the result of the ES6 transpilation.

__15. Use node.js to run the test file:

node dist\test.js 

__16. The output should be: 

myclass

__17. The current setup is suitable for development of standalone JavaScript code that 
uses ES6 and needs to be compiled to ES5. In the next part we will add JSX transpilation.
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Part 2 - JSX Transpilation support
In this part you will add JSX transpilation support to the development environment.

__1. Use node package manager to install the following dependencies into the project:

react@15.6.2 

react-dom@15.6.2

prop-types@15.6.0

Hint: npm install package-name --save
      for package-name use name@version_number above

__2. Use node package manager to install the following development dependencies into 
the project:

babel-preset-react

Hint: npm install package-name --save-dev

__3. Add "react" to the ".babelrc" file as shown here:

{"presets": ["es2015","react"]}

__4. Create a basic index.html file in the project root with the following contents:

<!doctype html>
<html>
<head>
<title>My React Project</title>
</head>
<body>
</body>
</html>

__5. Modify the index.html file:

• Add <script> tags to the <head> section to include the react and react-dom 
JavaScript libraries.

• Add a <div> to the body with "id=main" 

• Add a <script> tag just before the ending </body> tag to include an 'app.js' file 
from the "dist" directory.

• Save index.html
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__6. When you are done your index.html file should look something like this:

<!doctype html>
<html>
<head>
<title>My React Project</title>
<script src="node_modules/react/dist/react.js"></script>
<script src="node_modules/react-dom/dist/react-
dom.js"></script>
</head>
<body>
<div id="main"></div>
<script src="dist/app.js"></script>
</body>
</html>

__7. Create an "app.js" file in the "\src" directory with the following contents:

ReactDOM.render(
    <h3>My App Title</h3>,
    document.getElementById('main'));

__8. Run the babel compiler:

npm run babel 

Note: running "babelw" instead of "babel" will open it in "watch" mode. In 
"watch" mode  babel will stay active after it runs and will run again every 
time you save changes to your files. 

__9. Check that babel did its job. Open the transpiled file from the dist directory in an 
editor:

\dist\app.js
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__10. You should notice that the content from the original file that appeared like this:

<h3>My App Title</h3>

Now appears like this in \dist\app.js 

React.createElement(
 'h3',
  null,
 'My App Title'
)

This is the result of  React JSX transpilation.

__11. Open index.html from the file system in the Chrome browser. The page should 
show "My App Title".

__12. Some application operations require the index.html to be served from a file server 
instead of directly from the file system. In the next part we will add a development server 
to the setup.

Part 3 - File Server Support
In this part you will add a development file server to the setup.

__1. Use node package manager to install the following development dependencies into 
the project:

http-server

Hint: npm install package-name --save-dev

__2. Add the following script to the package.json file

"start": "http-server"

__3. Start the server:

npm start

__4. Open index.html in the Chrome browser using the following url:

http://localhost:8080/index.html
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__5. The page should load as before but this time from the development file server.

Part 4 - Review
In this lab you have created a development setup that:

• Transpiles ES6 code 

• Transpiles JSX code

• Serves React Application files ( index.html, etc. )
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Lab 2 - Basic React Components
In this lab, you will build a React application from functional components. 

Part 1 - Create a Main App Components
In this part, you will create a main App component that can hold other components.

__1. Open "src\app.js"from the "react-dev-env" project.

__2. Create a function named App() that uses JSX to return a component with the 
following structure:

<div><h3>My App Title</h3></div>

__3. Modify the ReactDOM.render function to render the App component you just 
created. 

__4. When you are done with the above steps, your src\app.js should look like this:

function App(){
    return <div><h3>My App Title</h3></div>;
}

ReactDOM.render( <App />,
    document.getElementById('react-container')
);

__5. Save the file.

__6. Add a functional component named Header that displays the app title.

__7. Modify the App function. Remove the <h3> tag and replace it with a JSX tag for the 
Header component you just created.

__8. The resulting src\app.js should look like this:

function App(){
    return <div><Header /></div>;
}

function Header(){
    return <h3>My App Title</h3>;
}

ReactDOM.render( <App />,
    document.getElementById('main')
);

__9. Save the file.
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__10. Create a variable named "title" with the value "My React App"

__11. Replace the contents of the <h3> in the Header component with a JSX expression 
so that it displays the "title" variable you just created.

__12. The changes made to src\app.js should look like this:

const title = "My React App"

function Header(){
    return <h3>{title}</h3>;
}
...

__13. Save the file.

__14. Add a functional component named Body that displays a div containing a 
paragraph with some random text.

__15. Add the Body component to the JSX code on the App component.

__16.  Add a functional component named Footer that displays a div containing an <h4> 
tag with the text "App Footer"

__17. Add the Footer component to the JSX code on the App component.

__18. When you are done, the component functions should look something like this:

function App(){
    return <div><Header /><Body /><Footer /></div>;
}

function Body(){
    return ( <div><p>some random text</p></div> );
}

function Footer(){
    return ( <div><h4>App Footer</h4></div> );
}

__19. Open a new command prompt window and run the following commands:

cd C:\LabWork\react-dev-env
title React
npm run babel 

We are using a new window called React to compile changes in files.
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__20. Open a second command prompt window and run the following commands:

cd C:\LabWork\react-dev-env
npm start

We are using a new window to run the server.

__21. Open "index.html" in the Chrome browser using the following url:

http://localhost:8080/index.html

__22. The browser window should look like this:

Troubleshooting: 

If your browser is not showing the content above means that you need to clear cache. 
There are some approaches below, use the one of your preference.

Option 1.- Open Chrome, select More tools > developer tools (F12), select the 
Network tab and check the Disable cache option. Then restart Chrome.
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Option 2.- Open Chrome, select More Tools > Clear browsing data. Then click the 
Advanced tab, select all and click CLEAR DATA. Then restart Chrome. With this 
option you may need to clear data and restart chrome every time you need to test the 
app.

Option 3- Close Chrome and then open it as "Incognito Mode". Doing this you way 
you need to restart Chrome as Incognito to test changes but you don't need to clear 
cache.

Use the method of your preference during the labs when we refer to open a 
browser.

__23. Close the browser.

Part 2 - Pass Properties to Components
In this part, you will create variables to hold property values and pass them to 
components.
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__1. Create two variables as shown here:

var footerText = "footer text"
var author = { name:"John Doe", 
               phone: "800-555-1212", 
               email: "jdoe@gmail.com" }

__2. Modify the component to pass footerText a property named "text" to the Footer 
component where it appears inside the App component. 

__3. The resulting App component should look like this:

function App(){
    return (
    <div>
        <Header />
        <Body />
        <Footer text={footerText} />
    </div> );
}

__4. Modify the Footer functional component to take "props" as a parameter and then use 
a JSX expression to replace the text in the <h4> tag with "props.text"

__5. The resulting Footer component should look like this:

function Footer(props){
    return (<div><h4>{props.text}</h4></div>);
}

__6. Save changes.

__7. Switch to the React window and compile:

npm run babel 

__8. Open Chrome browser using the following url and make sure the footer is showing 
the property value that was passed to it. 

http://localhost:8080/index.html
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__9. Let's do the same with the Body component.

• Pass "author" as a property named "author" to the Body component. 

• Modify the Body component to take "props" as a parameter.

• Add a paragraph before the existing paragraph in the Body component that 
displays the author's information.

__10. The resulting App component should look like this:

function App(){
    return (
    <div>
        <Header />
        <Body author={author}  />
        <Footer text={footerText}/>
    </div> );
}

__11. The resulting Body component might look like this:

function Body(props){
    return ( <div>
        <p>Author:{props.author.name}</p>
        <p>some random text</p>
        </div> );
}

__12. Save changes.

__13. Switch to the React window and compile:

npm run babel 

__14. Refresh the browser make sure the page is showing the property value that was 
passed to it. 
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Part 3 - Add some style
In this part, we will add some CSS styles to the components.

__1. Edit index.html

__2. Add a <style> section.

__3. In the <style> section, add section for a class named "boxed" with the following 
rules:

• Width = 200px ( width: 200px; )

• Solid single line black border ( border: 1px solid black; )

__4. Your code should look like this:

<style>
.boxed{
    width:200px; 
    border: 1px black solid;
    }   
</style>

__5. Save the file.

__6. Edit src\app.js

__7. Modify the App component.

• add the "boxed"class to the outer div of the component. 

• the syntax required for this is specified in JSX as.

__8. The code should look like below in bold:

function App(){
    return (
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    <div className={'boxed'}>
...

__9. Add the following style directly to the <h3> and <h4> elements of the Header and 
Footer components respectively. 

backgroundColor: lightgrey

__10. The code to do this in JSX would look like this:

<h3 style={{backgroundColor: 'lightgrey'}} >
...
<h4 style={{backgroundColor: 'lightgrey'}} >

__11. Save changes.

__12. Switch to the React window and compile:

npm run babel 

__13. Refresh the browser and make sure the page is showing the property value that was 
passed to it. 

This does not look so great. We will add the following:

    margin: '0px',
    padding: '5px', 
    textAlign: 'center',

__14. We probably don't want to place these all inline in the component. Instead let's 
create a variable to hold them:
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const divStyle = {
    backgroundColor: 'lightgrey',
    margin: '0px',
    padding: '5px', 
    textAlign: 'center',
};

__15. Now, we can use the variable in the component like this:

<h3 style={divStyle} >
...
<h4 style={divStyle} >

__16. The final Header and Footer components would look like this:

function Header(){
    return <h3 style={divStyle} >{title}</h3>;
}

function Footer(props){
    return ( <div>

<h4 style={divStyle} >{props.text}</h4>
</div> );

}

__17. Save changes.

__18. Switch to the React window and compile:

npm run babel 

__19. Refresh the browser and make sure the page is showing the property value that was 
passed to it. The browser output should now look like this:
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Part 4 - Fragments (Optional)
When creating React component functions with JSX one of the requirements is that the 
JSX code return a single element. In practice thought, there are situations where you need 
to have it return multiple adjacent elements. In this lab part, we will review the issue and 
how the situation is solved by using React Fragments. 

__1. Create a new component function in App.js called "FragTest". 

function FragTest(props){
   return <ul><ColorList /></ul>
}

__2. Create a new component function named "ColorList" that returns a list of colors:

function ColorList(props){
    return "Red, Yellow, Blue"
}

__3. Add "Fragtest" to your  App component after the Body component and before the 
Footer component.

function App(){
    return (
    <div>
        <Header />
        <Body />
        <FragTest />
        <Footer text={footerText} />
    </div> );
}

__4. Save changes.

__5. Switch to the React window and compile:

npm run babel 

__6. Refresh the browser and you should see the following:
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__7. Now let's change the ColorList component so that it returns multiple adjacent 
elements. Change the return statement to match the following:

function ColorList(props){
    return <li>Red</li>
    <li>Yellow</li>
    <li>Blue</li>
}

__8. Save changes.

__9. Switch to the React window and compile:

npm run babel 

__10. Take a look at the compile window; you should see the following error:

SyntaxError: src/app.js: Adjacent JSX elements must be wrapped in an 
enclosing tag (45:4)
  43 | function ColorList(props){
  44 |     return <li>Red</li>
> 45 |     <li>Yellow</li>
     |     ^
  46 |     <li>Blue</li>
  47 | }
  48 |

You may not see the above error but you should see an error.

__11. One way we could fix this is by wrapping the <li> elements with a <div>

function ColorList(props){
    return <div>
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    <li>Red</li>
    <li>Yellow</li>
    <li>Blue</li>
    </div>
}

__12. Save changes.

__13. Switch to the React window and compile:

npm run babel 

__14. Refresh the browser. The error in the babel compile window should go away and 
you should see the following in the browser:

__15. Open Chrome developer tools (F12) and click on the "Elements" tab. Expanding 
the elements so you can see the ones added by ColorList you should see this:

Notice how the <div> element sits between the <ul> element and the <li> elements. As 
far as the DOM is concerned, we really don't need this extra <div>. In this case, it does 
not seem to cause a problem with the display but it does get in the way if we try to 
reference the <li> elements as direct children of the <ul>. 

What we really want is to create the ColorList component so that there is no extra <div>.

We can do that using React Fragments. 
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__16. Replace the <div> in ColorList with <React.Fragment>:

function ColorList(props){
    return <React.Fragment>
    <li>Red</li>
    <li>Yellow</li>
    <li>Blue</li>
    </React.Fragment>
}

This might at first seem like a useless substitution. After all, aren't we not just going to 
get  a different type of element in place of the <div>? Well actually, No. The 
<React.Fragment> element is treated differently. When React creates the DOM it skips 
over and leaves out instances of the React.Fragment. 

__17. Save changes.

__18. Switch to the React window and compile:

npm run babel 

__19. Refresh the browser. The babel compiler should run without any errors. In the 
browser, you should see the bulleted list like before. 

__20. Open the Elements tab in the Chrome dev tools and check out the list. You should 
see that there is no longer a <div> or any other element in the hierarchy between <ul> 
and the <li> elements. 

__21. Before moving on the the next lab comment out the <FragTest /> element in the 
App component using the JSX comment syntax:
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function App(){
    return (
    <div>
        <Header />
        <Body />
        {/* <FragTest /> */}
        <Footer text={footerText} />
    </div> );
}

__22. Save changes.

__23. Switch to the React window and compile:

npm run babel 

__24. Refresh the browser. The app should work fine and not showing the colors.

__25. Close all open editors.

__26. In the command prompt windows, press CTRL-C to shut down the server and then 
close all the windows.

Part 5 - Review
In this lab, we have:

• Build a React application from functional components.

• Passed parameters to components.

• Set styles and classes in components.
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Lab 3 - More React Component Concepts
In this lab, you will work with the following React component concepts:

• Moving state into the root component

• Displaying Lists

• Updating input fields

• Click Event handling

• Passing parameters to event handlers

This lab picks up where the previous lab left off. If you did not do the previous lab you 
can use the solution file from that lab to get started. Solution files are available in the 
C:\LabFiles\Solution directory.

Part 1 - Moving state into the root component
In this part, we will move some state into the root component. The root component in our 
case is the App component. We' will start by moving the title property.  

__1. Edit "src/app.js" from the "react-dev-env" project.

The title property is currently displayed in the Header component. The variable "title" is 
in scope so it is used directly. 

const title = "My React App"

function Header(){
    return <h3 style={divStyle} >{title}</h3>;
}

__2. Instead of relying on scope, let's pass the title in as a property like we did with the 
"text" in the footer. 

• Edit the Header component.

• Pass "props" into the Header component function.

• Change the JSX expression that displays the title to get its value from 
"props.title".

• Update the App component to pass title as a property to the Header component.
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__3. The resulting Header component should look like this:

function Header(props){
    return <h3 style={divStyle} >{props.title}</h3>;
}

__4. And the Header tag in the App component looks like this:

<Header title={props.title}/>

The App component currently looks like this. Notice how the values for title, author and 
footerText are coming from variables defined outside the App component. This works 
because they are in scope but we would like to move those values inside the component. 

function App(){
    return (
    <div className={'boxed'}>
        <Header title={props.title}/>
        <Body author={author} />
        <Footer text={footerText} />
    </div> );
}

__5. Setup the App component to take a single object containing all the state values.

• Add "props" as a parameter to the App component method.

• Combine  title, author and footerText into a single object where they exist as 
properties. Name the object "scope".

• Use the spread operator to pass the scope to the App component when it is 
rendered.

__6. The resulting changes should look like this:

var scope = {
    title: "My React App",
    footerText: "footer text",
    author: { 
            name:"John Doe", 
            phone: "800-555-1212", 
            email: "jdoe@gmail.com" 
        }
    }

...
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function App(props){
    return (
    <div className={'boxed'}>
        <Header title={props.title}/>
        <Body author={props.author} />
        <Footer text={props.footerText} />
    </div> );
}

...

ReactDOM.render( <App {...scope}/>,
    document.getElementById('react-container')
);

__7. Save the file.

__8. Open a new command prompt window and run the following commands:

cd C:\LabWork\react-dev-env
title React
npm run babelw

We are using a new window called React to compile changes in files and in watch mode 
the project will be recompiled in automatic after any changes in the project.

__9. Open a second command prompt window and run the following commands:

cd C:\LabWork\react-dev-env
npm start

We are using a new window to run the server.

__10. Open Chrome browser to the following URL and make sure the app is still 
working: 

http://localhost:8080/index.html
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Part 2 - Displaying Lists
Displaying lists is essential to creating real applications. In this part we will display a list 
of books in our app.  

__1. Add "books" to the scope object:

, books: [
    {isbn:'123', title:'The Time Machine', price:5.95 },
    {isbn:'123', title:'War of the Worlds', price:6.95 },
    {isbn:'123', title:'The Invisible Man', price:4.95 }
]

__2. Add a BookList functional component to the Body component. BookList should 
takes props as a parameter and returns an unordered list of book items.

• Create the BookList component.

• Edit BookList to return <ul></ul>.

• Inside the <ul> tags add a JSX expression that uses the array.map function to 
display a list of book titles.

• Add BookList right after the author paragraph in the Body component.

• Make sure to pass books to the Body component and inside the Body component 
pass books again to BookList.

__3. The resulting code changes should look like this:

var scope = {
    title: "My React App",
    footerText: "footer text",
    author: { 
            name:"John Doe", 
            phone: "800-555-1212", 
            email: "jdoe@gmail.com" 
        },
    books: [
        {isbn:'123', title:'The Time Machine', price:5.95 },
        {isbn:'456', title:'War of the Worlds', price:6.95 },
        {isbn:'789', title:'The Invisible Man', price:4.95 }
        ]
    }
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...

function BookList(props){
    return ( <ul>
        {props.books.map(
            (book, index) => {return ( 

  <li key={index} >{book.title}</li> )}
        )}
        </ul>
    );
}

function Body(props){
    return ( <div>
        <p>Author:{props.author.name}</p>
        <BookList books={props.books} />
        <p>some random text</p>
        </div> );
}

__4. The Body tag in App() should look like this:

<Body {...props} />

__5. Save the file.

__6. Refresh the browser and the output should look like this:
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Part 3 - Updating input fields
In this part, we add an <input> field and update the app so that when users type into the 
field the changes are shown on the screen. 

__1. Add a "color" property to the scope object with the value "blue".

var scope = {
    title: "My React App",
    footerText: "footer text",
    color: "blue",
...

__2. Add an input field just before the </div> tag in the Body component.

• The type of the input should be "text".

• The value of the field should come from the "color" property of the scope object.

• The name of the input field should be set to 'color'.

• You will need to pass the "color" property to the Body component where it 
appears in the App component. You can do this the same way you passed author 
and books or you can replace them with the spread operator {...props} which will 
then create properties inside of Body for all the properties in scope. 

__3. Modify the text in the <p> above the input field. Change it from "some random text" 
to "Enter your favorite color:"

__4. The code should now look like this:

function App(props){
    return (
    <div className={'boxed'}>
        <Header title={props.title}/>
        <Body {...props} />
        <Footer text={props.footerText} />
    </div> );
}

function Body(props){
    return ( <div>
        <p>Author:{props.author.name}</p>
        <BookList books={props.books} />
        <p>Enter your favorite color:</p>
        <input type='text' name='color' 

     value={props.color} />
        </div> );
}

__5. Save the file.
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__6. Refresh the browser and the input field should be visible in the browser:

__7. Note though that if you try to enter any text into the field it does not appear on the 
screen. This is because React keeps supplying the same color value to the input field each 
time it is rendered. To fix this we need to respond to any changes the user makes to the 
input field and update the color value on the scope object. 

__8. Before we do this we need to wrap the ReactDOM.render() call in a method so that 
we can call it after the "color" has been updated. 

function renderApp(scope){
    ReactDOM.render( <App {...scope}/>,
        document.getElementById('react-container')
    );
}

__9. And since ReactDOM.render is no longer executing (since it's wrapped inside a 
function now) we need to call this new function as the last line of the '\src\app.js' file:

renderApp(scope);

__10. Now, add an onChange handler to the text input field:

onChange = {handleChange}
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__11. Next, add a handleChange method to "\src\app.js". The method should:

• take "event" as a parameter.

• update the "color" property of the scope object.

• make a call to renderApp and pass the scope object.

__12. The handleChange method should look like this:

function handleChange(event){
    scope[event.currentTarget.name] = event.currentTarget.value;
    renderApp(scope);
}

Now text entered into the input field will be visible in the input field as you type it and it 
will be added at the same time to the scope.color property.

__13. Save the file.

Part 4 - Click Event Handling
In the last part, we saw how to handle the onChange event of input fields that are used in 
React components. In this part, we will take a look at handling onClick events of buttons. 

__1. Add an input element with type=button right below the other input field in the Body 
component.

• Input field's type is button.

• Add an onClick handler named "handleButtonClick".

• Add a value attribute set to "Click Here".

__2. Add a "message" property to the scope object. For now set its value to an empty 
string.

var scope = {
    title: "My React App",
    footerText: "footer text",
    color: "blue",
    message: "",
...

__3. Add paragraph below the button that gets its text from the "scope.message" property.
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__4. The Body component should now look like this:

function Body(props){
    return ( <div>
        <p>Author:{props.author.name}</p>
        <BookList books={props.books} />
        <p>Enter your favorite color:</p>
        <input type='text' name='color' 

onChange = {handleChange} 
value={props.color} />

        <input type='button' value="Click Here" 
onClick = {handleButtonClick} /> 

        <p>{props.message}</p>
     </div> );
}

__5. Add a "handleButtonClick" method to "\src\app.js"

• Code the handler to set the scope.message so that it shows like this, with the color 
coming from scope.color:

You like the color Red!

• As the last line of the handler make a call to renderApp

__6. It should look like this:

function handleButtonClick(event){
   scope.message = "You like the color " + scope.color + "!";
   renderApp(scope);
}

__7. Save the file.
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__8. Refresh the browser and the try out the app. Enter your favorite color and click the 
button. The message below the button should update to reflect your choice. 

Part 5 - Passing Parameters to Event Handlers
In this part, we will take a look at passing parameters to the onClick event handler for list 
items.

__1. Add a property named "selectedIndex" to the scope object. Set its value to -1. 

var scope = {
    title: "My React App",
    footerText: "footer text",
    color: "blue",
    message: "",
    selectedIndex: -1,
...

__2. Add a method to '\src\app.js' named "handleListItemClick".

• The method should take two parameters, "event' & "index".

• It should use the "index" parameter to:

◦ Set the "scope.selectedIndex" property.

◦ And to look up a book from the scope.booklist array.

◦ After updating the selectedIndex the handler should make a call to renderApp.

◦ As the last line of the method details of the chosen book should be output to 
the console.
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__3. The handleListItemClick method code should look like this:

function handleListItemClick(event, index){
    scope.selectedIndex = index;
    const book = scope.books[index];
    renderApp(scope);
    console.log("You chose: " + book.isbn + ", " +
     book.title + ", " + book.price);
}

__4. Add an onClick attribute to the <li> in the BookList component:

onClick = {(e)=>handleListItemClick(e, index)}

• We are using an arrow function which autobinds "this" and we are 
passing multiple parameters. 

• The event parameter is always passed first. After that, you can pass 
whatever other parameters you need. Here we are passing the 
"index" parameter.

__5. Highlight the clicked item.

• Make sure to pass the selectedIndex to the BookList component 

• Insert a statement into the <li> that sets the class to "selected"  when the index of 
an item matches the selectedIndex

className={ index === props.selected ? "selected" : ""}

__6. The Resulting code should look like this:

function Body(props){
    return ( <div>
        <p>Author:{props.author.name}</p>
        <BookList books={props.books} selected={props.selectedIndex} />
        <p>Enter your favorite color:</p>
        <input type='text' name='color' 

   onChange = {handleChange} 
   value={props.color} />

        <input type='button' value="Click Here" 
  onClick = {handleButtonClick} /> 

        <p>{props.message}</p>
        </div> );
}
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function BookList(props){
  return ( <ul>
    {props.books.map(
        (book, index) => {
            return ( <li 
                onClick = {(e)=>handleListItemClick(e, index)}
                className={ index === props.selected ? "selected" : ""}
                key={index} >{book.title}</li> )}
    )}
    </ul>
  );
}

__7. Save the file.

__8. Open "index.html".

__9. Add a style to the <style> section for a "selected" class that makes text bold when 
the class is applied.

__10. The style should look like this:

<style>
.boxed{
    width:200px; 
    border: 1px black solid;
    } 
.selected{
    font-weight: bold;
}      
</style>

__11. Save the file.

__12. Refresh the browser and open Chrome's Developer tools (F12) so you can see the 
JavaScript console. 

__13. Click on Console tab.

__14. Click on an item in the list.
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__15. The selected item should appear in bold and the details of the item should appear 
printed out in the console.

Part 6 - The React Developer Tools ( Optional)
This part is optional. 

With frameworks like React, it can sometimes be difficult to see relevant details at 
runtime. For this purpose the company that created and supports React created the React 
Developer Tools plugin for the Chrome browser. In this part, we will take a look at how 
to use the tools.

Installing React Developer Tools

__1. Open the following url in the Chrome browser:

https://chrome.google.com/webstore/category/extensions

This will open up the Chrome Web Store page.

__2. Click on the "Extensions" button.
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__3. Enter the text "React Developer Tools" into the "search the store field" and hit enter. 
React Developer tools should show up in the list.

__4. Click on the "Add to Chrome" button. You will get a popup asking "Add 'React 
Developer Tools?'". 

__5. Click "Add Extension" You will get a dialog saying that the tools have been added to 
Chrome. 

Using the Tools

__6. Open the URL for the current project:

http://localhost:8080/

You should see the app you've been working with in this lab:

__7. Open the Chrome Developer Tools by clicking one of the following key 
combinations in Chrome:

◦ F12

◦ Ctrl-Shift-I
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__8. Next, click on the "" ('>>') item at the right of the Chrome Developer Tools tab bar 
and choose "React" from the drop-down menu:

This will open the React Developer Tools panel:

__9. In the left side of the React Developer Tools panel select the "<App ...>" element.
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The right hand side of the panel shows the React properties for the App component:

__10. Let's compare this to what we see in the source code for the app. First, take a look 
at the render function call. We can see from here that the properties passed to the App 
component include all the apps in the "scope" object which has been spread using the 
"…" operator: 

function renderApp(scope){
    ReactDOM.render( <App {...scope}/>,
        document.getElementById('main')
    );
}

__11. Next, let's look at the scope object. Comparing this to the React Developer Tools 
display, we can see that the tools are accurately displaying the properties that were passed 
to the selected App component.

var scope = 
{
  title: "My React App",
  footerText: "footer text",
  color: "blue",
  message: "",
  selectedIndex: -1,
  author: { 
          name:"John Doe", 
          phone: "800-555-1212", 
          email: "jdoe@gmail.com" 
      },
  books: [
      {isbn:'123', title:'The Time Machine', price:5.95 },
      {isbn:'456', title:'War of the Worlds', price:6.95 },
      {isbn:'789', title:'The Invisible Man', price:4.95 }
      ]
}
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__12. Click on the <Header> element to select the Header component.

Notice that the title is being passed in as the only property.

This matches the source code of the App component which uses the Header:

function App(props){
  return (
  <div className={'boxed'}>
    <Header title={props.title}/>
    <Body {...props} />
    <Footer text={props.footerText} />
  </div> );
}

__13. Notice that the props are listed in React Dev Tools as read-only:

This is because the React components in the current application are all "functional" 
components. Later on when we start using class-based components, we will be able to 
modify the property values at run-time in React Developer Tools. 

__14. Close Google Developer Tools (F12 or Ctrl-Shift-I )

__15. Close the browser.

__16. Close all editors.

__17. Press CTRL-C to shutdown the compiler and the server command prompt windows 
and close them.
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Part 7 - Review
In this lab, we covered the following React component concepts:

• Moving state into the root component.

• Displaying Lists.

• Updating input fields.

• Click Event handling.

• Passing parameters to event handlers.
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	__3.  Start the server:
	__4.  Open index.html in the Chrome browser using the following url:
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	Part 4 -  Review
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	__1.  Open "src\app.js"from the "react-dev-env" project.
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	__4.  When you are done with the above steps, your src\app.js should look like this:
	__5.  Save the file.
	__6.  Add a functional component named Header that displays the app title.
	__7.  Modify the App function. Remove the <h3> tag and replace it with a JSX tag for the Header component you just created.
	__8.  The resulting src\app.js should look like this:
	__9.  Save the file.
	__10.  Create a variable named "title" with the value "My React App"
	__11.  Replace the contents of the <h3> in the Header component with a JSX expression so that it displays the "title" variable you just created.
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	__13.  Save the file.
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	__3.  The resulting App component should look like this:
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	__5.  The resulting Footer component should look like this:
	__6.  Save changes.
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	__12.  Save changes.
	__13.  Switch to the React window and compile:
	__14.  Refresh the browser make sure the page is showing the property value that was passed to it. 
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	__1.  Edit index.html
	__2.  Add a <style> section.
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	__5.  Save the file.
	__6.  Edit src\app.js
	__7.  Modify the App component.
	__8.  The code should look like below in bold:
	__9.  Add the following style directly to the <h3> and <h4> elements of the Header and Footer components respectively. 
	__10.  The code to do this in JSX would look like this:
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	__17.  Save changes.
	__18.  Switch to the React window and compile:
	__19.  Refresh the browser and make sure the page is showing the property value that was passed to it. The browser output should now look like this:

	Part 4 -  Fragments (Optional)
	__1.  Create a new component function in App.js called "FragTest". 
	__2.  Create a new component function named "ColorList" that returns a list of colors:
	__3.  Add "Fragtest" to your  App component after the Body component and before the Footer component.
	__4.  Save changes.
	__5.  Switch to the React window and compile:
	__6.  Refresh the browser and you should see the following:
	__7.  Now let's change the ColorList component so that it returns multiple adjacent elements. Change the return statement to match the following:
	__8.  Save changes.
	__9.  Switch to the React window and compile:
	__10.  Take a look at the compile window; you should see the following error:
	__11.  One way we could fix this is by wrapping the <li> elements with a <div>
	__12.  Save changes.
	__13.  Switch to the React window and compile:
	__14.  Refresh the browser. The error in the babel compile window should go away and you should see the following in the browser:
	__15.  Open Chrome developer tools (F12) and click on the "Elements" tab. Expanding the elements so you can see the ones added by ColorList you should see this:
	__16.  Replace the <div> in ColorList with <React.Fragment>:
	__17.  Save changes.
	__18.  Switch to the React window and compile:
	__19.  Refresh the browser. The babel compiler should run without any errors. In the browser, you should see the bulleted list like before. 
	__20.  Open the Elements tab in the Chrome dev tools and check out the list. You should see that there is no longer a <div> or any other element in the hierarchy between <ul> and the <li> elements. 
	__21.  Before moving on the the next lab comment out the <FragTest /> element in the App component using the JSX comment syntax:
	__22.  Save changes.
	__23.  Switch to the React window and compile:
	__24.  Refresh the browser. The app should work fine and not showing the colors.
	__25.  Close all open editors.
	__26.  In the command prompt windows, press CTRL-C to shut down the server and then close all the windows.

	Part 5 -  Review

	Lab 3 -  More React Component Concepts
	Part 1 -  Moving state into the root component
	__1.  Edit "src/app.js" from the "react-dev-env" project.
	__2.  Instead of relying on scope, let's pass the title in as a property like we did with the "text" in the footer. 
	__3.  The resulting Header component should look like this:
	__4.  And the Header tag in the App component looks like this:
	__5.  Setup the App component to take a single object containing all the state values.
	__6.  The resulting changes should look like this:
	__7.  Save the file.
	__8.  Open a new command prompt window and run the following commands:
	__9.  Open a second command prompt window and run the following commands:
	__10.  Open Chrome browser to the following URL and make sure the app is still working: 

	Part 2 -  Displaying Lists
	__1.  Add "books" to the scope object:
	__2.  Add a BookList functional component to the Body component. BookList should takes props as a parameter and returns an unordered list of book items.
	__3.  The resulting code changes should look like this:
	__4.  The Body tag in App() should look like this:
	__5.  Save the file.
	__6.  Refresh the browser and the output should look like this:

	Part 3 -  Updating input fields
	__1.  Add a "color" property to the scope object with the value "blue".
	__2.  Add an input field just before the </div> tag in the Body component.
	__3.  Modify the text in the <p> above the input field. Change it from "some random text" to "Enter your favorite color:"
	__4.  The code should now look like this:
	__5.  Save the file.
	__6.  Refresh the browser and the input field should be visible in the browser:
	__7.  Note though that if you try to enter any text into the field it does not appear on the screen. This is because React keeps supplying the same color value to the input field each time it is rendered. To fix this we need to respond to any changes the user makes to the input field and update the color value on the scope object. 
	__8.  Before we do this we need to wrap the ReactDOM.render() call in a method so that we can call it after the "color" has been updated. 
	__9.  And since ReactDOM.render is no longer executing (since it's wrapped inside a function now) we need to call this new function as the last line of the '\src\app.js' file:
	__10.  Now, add an onChange handler to the text input field:
	__11.  Next, add a handleChange method to "\src\app.js". The method should:
	__12.  The handleChange method should look like this:
	__13.  Save the file.

	Part 4 -  Click Event Handling
	__1.  Add an input element with type=button right below the other input field in the Body component.
	__2.  Add a "message" property to the scope object. For now set its value to an empty string.
	__3.  Add paragraph below the button that gets its text from the "scope.message" property.
	__4.  The Body component should now look like this:
	__5.  Add a "handleButtonClick" method to "\src\app.js"
	__6.  It should look like this:
	__7.  Save the file.
	__8.  Refresh the browser and the try out the app. Enter your favorite color and click the button. The message below the button should update to reflect your choice. 

	Part 5 -  Passing Parameters to Event Handlers
	__1.  Add a property named "selectedIndex" to the scope object. Set its value to -1. 
	__2.  Add a method to '\src\app.js' named "handleListItemClick".
	__3.  The handleListItemClick method code should look like this:
	__4.  Add an onClick attribute to the <li> in the BookList component:
	__5.  Highlight the clicked item.
	__6.  The Resulting code should look like this:
	__7.  Save the file.
	__8.  Open "index.html".
	__9.  Add a style to the <style> section for a "selected" class that makes text bold when the class is applied.
	__10.  The style should look like this:
	__11.  Save the file.
	__12.  Refresh the browser and open Chrome's Developer tools (F12) so you can see the JavaScript console. 
	__13.  Click on Console tab.
	__14.  Click on an item in the list.
	__15.  The selected item should appear in bold and the details of the item should appear printed out in the console.

	Part 6 -  The React Developer Tools ( Optional)
	__1.  Open the following url in the Chrome browser:
	__2.  Click on the "Extensions" button.
	__3.  Enter the text "React Developer Tools" into the "search the store field" and hit enter. React Developer tools should show up in the list.
	__4.  Click on the "Add to Chrome" button. You will get a popup asking "Add 'React Developer Tools?'". 
	__5.  Click "Add Extension" You will get a dialog saying that the tools have been added to Chrome. 
	__6.  Open the URL for the current project:
	__7.  Open the Chrome Developer Tools by clicking one of the following key combinations in Chrome:
	__8.  Next, click on the "" ('>>') item at the right of the Chrome Developer Tools tab bar and choose "React" from the drop-down menu:
	__9.  In the left side of the React Developer Tools panel select the "<App ...>" element.
	__10.  Let's compare this to what we see in the source code for the app. First, take a look at the render function call. We can see from here that the properties passed to the App component include all the apps in the "scope" object which has been spread using the "…" operator: 
	__11.  Next, let's look at the scope object. Comparing this to the React Developer Tools display, we can see that the tools are accurately displaying the properties that were passed to the selected App component.
	__12.  Click on the <Header> element to select the Header component.
	__13.  Notice that the props are listed in React Dev Tools as read-only:
	__14.  Close Google Developer Tools (F12 or Ctrl-Shift-I )
	__15.  Close the browser.
	__16.  Close all editors.
	__17.  Press CTRL-C to shutdown the compiler and the server command prompt windows and close them.

	Part 7 -  Review

	Lab 4 -  A Simple RESTful API in Spring Boot
	Part 1 -  Create a Maven Project
	__1.  Open Eclipse by navigating to C:\Software\eclipse and double-clicking on eclipse.exe (note that the '.exe.' extension may not be shown, depending on the view options that have been set).
	__2.  In the Workspace Launcher dialog, enter 'C:\Workspace' in the Workspace field, and then click OK.
	__3.  Close the Welcome panel by clicking on the 'X':
	__4.  From the main menu, select File →  New →  Maven Project.
	__5.  In the New Maven Project dialog, click on the checkbox to select "Create a simple project (skip archetype selection)", and then click Next.
	__6.  Enter the following fields:
	__7.  When the dialog looks like below, click Finish.

	Part 2 -  Configure the Project as a Spring Boot Project
	__1.  Expand the helloAPI project in the Project Explorer.
	__2.  Double-click on pom.xml to open it.
	__3.  At the bottom of the editor panel, click the pom.xml tab to view the XML source for pom.xml.
	__4.  Insert the following text after the "<version>...</version>" element, and before the closing "</project>" tag.
	__5.  Save the file by pressing Ctrl-S or selecting File -> Save from the main menu.

	Part 3 -  Create an Application Class
	__1.  In the Project Explorer, right-click on src/main/java and then select New →  Package.
	__2.  Enter 'com.webage.spring.samples.hello' in the Name field, and then click Finish.
	__3.  In the Project Explorer, right-click on the newly-created package and then select New →  Class.
	__4.  In the New Java Class dialog, enter 'HelloAPI' as the Name, and then click Finish.
	__5.  Add the '@SpringBootApplication' annotation to the class, so it appears like:
	__6.  Add the following 'main' method inside the class:
	__7.  The editor is probably showing errors due to missing 'import' statements.  Press Ctrl-Shift-O to organize the imports.
	__8.  Save the file.
	__9.  The helloAPI project node may show a small red 'x' to indicate an error.  If so, right-click on the helloAPI project and then select Maven →  Update Project, and then click OK in the resulting dialog.
	__10.  In the Project Explorer, right-click on either the helloAPI project node or the 'pom.xml' file and then select Run As →  Maven Install.

	Part 4 -  Implement the RESTful Service
	__1.  In the Project Explorer, right-click on src/main/java and then select New →  Package.
	__2.  Enter 'com.webage.spring.samples.hello.api' in the Name field, and then click Finish.
	__3.  In the Project Explorer, right-click on the newly-created package and then select New →  Class.
	__4.  In the New Java Class dialog, enter 'HelloResponse' as the Name, and then click Finish.
	__5.  Edit the body of the class so it reads as follows:
	__6.  Save the file.
	__7.  In the Project Explorer, right-click on the 'com.webage.spring.samples.hello.api' package and then select New →  Class.
	__8.  In the New Java Class dialog, enter 'HelloResource' as the Name, and then click Finish.
	__9.  Add the following 'getMessage' method inside the new class:
	__10.  Add the '@RestController' annotation to HelloResource, so it looks like:
	__11.  Add the '@GetMapping' annotation to the 'getMessage' method, so it looks like:
	__12.  Organize the imports by pressing Ctrl-Shift-O.
	__13.  Save all files by pressing Ctrl-Shift-S.
	__14.  In the Project Explorer, right-click on either the helloAPI project node or the 'pom.xml' file and then select Run As →  Maven Install.

	Part 5 -  Run and Test
	__1.  In the Project Explorer, right-click on the HelloAPI class and then select Run as → Java Application.
	__2.  If the Windows Security Alert window pops up, click on Allow Access.
	__3.  Watch the Console panel.  At the bottom of it, you should see a message indicating that the 'HelloAPI'  program has started successfully:
	__4.  Open the Chrome browser and enter the following URL in the location bar:
	__5.  You should see the following response:
	__6.  Close the browser.
	__7.  Click on the red 'Stop' button on the Console panel to stop the application.
	__8.  Close all open files.

	Part 6 -  Review

	Lab 5 -  Use the Spring Web MVC Web Framework under Spring Boot
	Part 1 -  Lab Setup
	__1.  From Eclipse's main menu, click File →  Import and then select General →  Existing Projects into Workspace, and then click Next.
	__2.  Click the radio button for Select archive file.
	__3.  Click the Browse button and navigate to select C:\LabFiles\Spring-Boot-MVC-Starter.zip and then click Open.
	__4.  On the Import dialog, leave the defaults as-is and click Finish.

	Part 2 -  Examine the Spring Boot Configuration
	Part 3 -  Test Spring MVC Configuration
	__1.  In the Project Explorer right-click on the spring-boot-mvc project and select Run as →  Maven install. The build should run successfully. You may need to build twice since the first time sometimes doesn't build fine.
	__2.  Right-click on the class App.java in the src/main/java/com.webage package and then select Run as →  Java Application.  You should see a message in the console that the app has started.
	__3.  Open a web browser and enter 'http://localhost:8080' into the location bar.  You should see the browser redirect to 'localhost:8080/index.html' and display the index page.
	__4.  Click on the red stop button in the console panel to stop the Spring Boot application.

	Part 4 -  Implement Browse Function
	__1.  Open the 'src/main/resources/templates/index.html' file.
	__2.  Find the first comment about a URL for the 'Add Purchase' link.  Add the 'th:href' attribute of the link as shown in bold below.  Be careful with the syntax as there are several double quotes and tag brackets.
	__3.  Find the second comment about needing a URL for the link for the 'Browse Purchases' link.  Add the 'th:href' attribute of the link as shown in bold below.  Be careful with the syntax as there are several double quotes and tag brackets.
	__4.  Save the file and make sure there are no errors.
	__5.  In the Package Explorer view, expand the following folders:
	__6.  Open the PurchaseController.java file in the com.webage.web package by double clicking it.  Notice that right now it has @GetMapping methods for '/index.html' and '/'.  These mappings forward to the requisite temples.  There is also an @Controller annotation on the class and an @Autowired injection of a 'PurchaseService' component.  There's also a method annotated with '@ModelAttribute' that supplies the current date for use in the page footer.
	__7.  Add the following new 'browsePurchases' method to the body of the class.  The @RequestMapping annotation links this method to the '/browse' URL you used in the index.html page.
	__8.  Select Source → Organize Imports.
	__9.  Save the file and make sure there are no errors.
	__10.  Open the 'src/main/resources/templates/browsePurchases.html' file.
	__11.  Find the <tr th:each="purchase : ${purchaseList}"> tag in the file about 2/3 of the way down.  Notice that it will iterate over the 'purchaseList' that was made available by the controller.  Each individual item will be available as the 'purchase' variable.
	__12.  Within the four columns that are currently empty add the following syntax for various expressions and a date format, all in Thymeleaf format.
	__13.  Save the file and make sure there are no errors.

	Part 5 -  Test Browse Function
	__1.  Run 'Maven install' and then execute the 'App.java' class using the same technique as in the previous lab part.
	__2.  Open a web browser to:
	__3.  Click on the 'Browse Purchases' link and be sure you get the list of the three purchases currently in the database.
	__4.  Click on the 'Back to Main Menu' link and make sure the home page is displayed.
	__5.  Close the browser.
	__6.  Click on the red stop button in the console panel to stop the Spring Boot application.
	__7.  Close all open files.

	Part 6 -  Review

	Lab 6 -  Use the Spring JDBCTemplate under Spring Boot
	Part 1 -  Import the Starter Project
	__1.  From Eclipse's main menu, click File →  Import and then select General →  Existing Projects into Workspace, and then click Next.
	__2.  Click the radio button for Select archive file:
	__3.  Click the Browse button and navigate to select C:\LabFiles\Spring-Boot-JDBC\Spring-Boot-JDBC-Starter.zip and then click Open.
	__4.  On the Import dialog, leave the defaults as-is and click Finish.

	Part 2 -  Enable the Default Embedded Database
	__1.  In the Project Explorer, locate the 'pom.xml' file for spring-boot-jdbc project and double-click it to open it.
	__2.  Select the pom.xml tab.
	__3.  Add the following dependency into the '<dependencies>' element:
	__4.  Save the file. You will notice that the errors in the project have gone.
	__5.  Locate the files 'C:\LabFiles\Spring-Boot-JDBC\schema.sql' and 'C:\LabFiles\Spring-Boot-JDBC\data.sql'.  
	__6.  Copy both these files into the 'src/main/resources' folder in Eclipse.  These files are used at startup time to initialize the in-memory HSQLDB database. Overwrite the existing files. 
	__7.  Right click on the spring-boot-jdbc project and select Run as → Maven install to Run a Maven install and ensure that there are no errors. This will confirm that you have no typos in the dependencies. You may need to run the Maven Install two times to get the Build Success message.

	Part 3 -  Configure the JDBCTemplate
	__1.  Locate the package 'com.webage.dao' in the Project Explorer under 'spring-boot-jdbc/src/main/java'.
	__2.  Right-click on the 'com.webage.dao' package and select New →  Class.
	__3.  Enter 'DAOConfig' as the new class name and then click Finish.
	__4.  Add the annotation '@Configuration' to the class, as shown below:
	__5.  Organize the imports by pressing Ctrl-Shift-O.
	__6.  Inside the class, create a method 'jdbcTemplate()' as shown below:
	__7.  Organize the imports by pressing Ctrl-Shift-O. Select javax.sql.DataSource.
	__8.  Save the file.

	Part 4 -  Complete the DAO Class
	__1.  Locate the class called 'JDBCPurchaseDAO' in the 'com.webage.dao' package. Double-click on the class to open it.
	__2.  Look for the method called that currently looks like below:
	__3.  Replace the line 'return null;' with a call to jdbcTemplate, so that the method appears as :
	__4.  Save all files by pressing Ctrl-Shift-S.

	Part 5 -  Compile and Test
	__1.  Using the same technique as in previous labs, run a 'Maven install' operation.
	__2.  Run the 'App' class as a Java application.
	__3.  Open a browser and enter the following url:
	__4.  You should see the results of our database query.
	__5.  Close the browser.
	__6.  Close all open files.
	__7.  Click on the red stop button in the console panel to stop the Spring Boot application:

	Part 6 -  Review

	Lab 7 -  Use the Spring Data JPA under Spring Boot
	Part 1 -  Import the Starter Project
	__1.  From Eclipse's main menu, click File →  Import and then select General →  Existing Projects into Workspace, and then click Next.
	__2.  Click the radio button for Select archive file.
	__3.  Click the Browse button and navigate to select C:\LabFiles\Spring-Boot-JPA\Spring-Boot-JPA-Starter.zip.and then click Open.
	__4.  On the Import dialog, leave the defaults as-is and click Finish.

	Part 2 -  Examine the Starter Project
	__1.  Expand the spring-boot-jpa project.
	__2.  Open pom.xml and select the pom.xml tab.

	Part 3 -  Annotate the Domain Classes
	__1.  Locate the package 'com.webage.domain' in the Project Explorer.
	__2.  Locate the Customer class inside 'com.webage.domain' and double-click on the class to open it.
	__3.  Add the '@Entity' and '@Table' annotations to the class as shown below.  These annotations designate that the class should be managed by JPA and tell JPA what database table name to use for the class:
	__4.  Add annotations to the 'id' field so it appears as below.  These annotations mark the 'id' field as the primary key of 'Customer' and tell JPA how it's going to be generated.
	__5.  The 'name' field in 'Customer' is modeled by a column called 'CUSTOMER_NAME' in the database table that we are using.  So, the default mapping of field name to column name will not work in this case.  Annotate the field as shown below to override the default name mapping:
	__6.  Organize the imports by pressing Ctrl-Shift-O. Select javax.persistence.Entity and javax.persistence.Id.
	__7.  Save the file.
	__8.  Locate the Purchase class inside 'com.webage.domain' and double-click on the class to open it.
	__9.  Add the '@Entity' and '@Table' annotations to the class as shown below.  These annotations designate that the class should be managed by JPA and tell JPA what database table name to use for the class:
	__10.  Add annotations to the 'id' field so it appears as below.  These annotations mark the 'id' field as the primary key of 'Customer' and tell JPA how it's going to be generated.
	__11.  Annotate the 'customer' field as shown below to tell JPA that it should load the value from an associated table.
	__12.  Organize the imports by pressing Ctrl-Shift-O. Select javax.persistence.Entity, javax.persistence.Table and javax.persistence.Id.
	__13.  Save the file.

	Part 4 -  Create the Repository Interfaces
	__1.  Locate the interface called 'PurchaseRepository' in the 'com.webage.repository' package. Double-click on the class to open it.  

	Part 5 -  Observe the Usage
	__1.  Locate the 'PurchaseServiceImpl' class in the 'com.webage.services' package. Double-click on the class to open it.  For convenience, the contents are shown below:
	__2.  Notice the '@Autowired' field for the PurchaseRepository.  Spring Data will automatically create a class that implements the PurchaseRepository interface and plug it in to the instance of 'PurchaseServiceImpl'.
	__3.  Notice that the service calls the methods 'save(...)', 'findAll()' and 'findOne(...)' on the repository interface.  These methods will be implemented by Spring Data's automatic proxy, so as to provide the expected functionality.

	Part 6 -  Compile and Test
	__1.  Right click spring-boot-jpa and select Maven → Update Project.
	__2.  Make sure  spring-boot-jpa is selected and click OK.
	__3.  Right click on the spring-boot-jpa project and select Run as → Maven install to Run a Maven install and ensure that there are no errors. You may need to run the Maven Install two times to get the Build Success message.
	__4.  Run the 'App' class as a Java application.
	__5.  Open a browser and enter the following url:
	__6.  You should see the results of our database query.
	__7.  Close the browser.
	__8.  Close all open files.
	__9.  Click on the red stop button in the console panel to stop the Spring Boot application:

	Part 7 -  Review

	Lab 8 -  Create a RESTful API with Spring Boot
	Part 1 -  Import the Starter Project
	__1.  From Eclipse's main menu, click File →  Import and then select General →  Existing Projects into Workspace, and then click Next.
	__2.  Click the radio button for Select archive file:
	__3.  Click the Browse button and navigate to select C:\LabFiles\Spring-Boot-REST\Spring-Boot-REST-Starter.zip.and then click Open.
	__4.  On the Import dialog, leave the defaults as-is and click Finish.

	Part 2 -  Examine the Starter Project
	__1.  Right click spring-boot-rest and select Maven → Update Project.
	__2.  Make sure  spring-boot-rest is selected and click OK.
	__3.  Right click on the spring-boot- rest project and select Run as → Maven install to Run a Maven install and ensure that there are no errors. You may need to run the Maven Install two times to get the Build Success message.

	Part 3 -  Create the Customer API Class
	__1.  In the Project Explorer, locate the 'spring-boot-rest/src/main/java' node.
	__2.  Right-click on 'src/main/java' and select New →  Package.
	__3.  Enter 'com.webage.api' as the package name and then click Finish.
	__4.  Right-click on the newly-created package and select New →  Class.
	__5.  Enter 'CustomerAPI' as the class name and then click Finish.
	__6.  We need to flag this class as a resource controller and assign a URL path for it.  To do that, add annotations to the class as shown below:
	__7.  Inside the body of the class, add an '@Autowired' reference to the 'CustomersRepository' implementation, as shown below:

	Part 4 -  Implement a GET method
	__1.  In the body of the 'CustomerAPI' class, add the following method.  It will use the repository proxy to retrieve an 'Iterable' object that iterates through all the customers.
	__2.  We want this method to respond to a 'GET' request on the '/customers' path.  Since the API class is already annotated with the required path, all we need to do is flag this class as a 'GET' method.  To do so, add the '@GetMapping' annotation to the method as shown below:
	__3.  Organize the imports by pressing Ctrl-Shift-O.
	__4.  Save the file.

	Part 5 -  Test the GET Method
	__1.  Using the same techniques as in previous labs, run a 'Maven install'.
	__2.  Run the 'App' class as a Java Application.  
	__3.  Open Chrome and find the Postman App.
	__4.  Select the Postman under Apps and click ADD TO CHROME.
	__5.  Click Add App.
	__6.  A new tab showing chrome://apps/ will open, click Postman.
	__7.  Select the a 'GET' request using the drop-down box, and enter 'localhost:8080/customers' as the URL:
	__8.  Click the Send button.  

	Part 6 -  Lookup a Specific Customer by ID
	__1.  Back in eclipse, in the body of the 'CustomerAPI' class, add the following method:
	__2.  Annotate the method with @GetMapping as follows:
	__3.  Annotate the 'long id' parameter as follows:
	__4.  Organize imports.
	__5.  Save the file.
	__6.  If you still have 'App.java' running from the previous test, stop it using the red stop button in the console window.
	__7.  Run 'Maven install'.
	__8.  Run 'App.java'.
	__9.  In the Postman tool, add an identifier to the end of the URL:
	__10.  Click Send.  
	__11.  Once again, leave Postman open, but stop 'App.java'.

	Part 7 -  Add a POST Method Handler
	__1.  In the 'CustomerAPI' class, add the following method.
	__2.  Organize imports.
	__3.  Save the file.
	__4.  Run 'Maven install'.
	__5.  Run 'App.java'.
	__6.  In the Postman tool, open a new tab by clicking on the '+' icon in the tab headers.
	__7.  Click the 'method' drop-down box and select 'POST'.
	__8.  Enter 'localhost:8080/customers' as the request URL.
	__9.  Select the 'Body' tab and then click the radio button for 'raw'.  
	__10.  Expand the drop-down box  and select 'JSON(application/json)'
	__11.  Enter the following new customer object in the body text area (hint: you might find it convenient to copy and edit an object from the response to the 'GET' request that we issued earlier - it's in the other tab in Postman).
	__12.  When it looks like below click Send.  
	__13.  Click on the Headers tab in the response area [bottom section].  You should see the 'Location' header:
	__14.  Copy the contents of the 'Location' header into the URL area and issue a GET request.  
	__15.  Leave Postman open, but stop 'App.java'

	Part 8 -  Add a PUT Method Handler
	__1.  Add the following method to the 'CustomerAPI' class.
	__2.  Organize the imports by pressing Ctrl-Shift-O. 
	__3.  Save the file.
	__4.  Run 'Maven install'.
	__5.  Run 'App.java'.
	__6.  In the Postman tool, open a new tab by clicking on the '+' icon in the tab headers.
	__7.  Click the 'method' drop-down box and select 'PUT'.
	__8.  Enter 'localhost:8080/customers/4' as the request URL.
	__9.  Select the 'Body' tab and then click the radio button for 'raw'.  
	__10.  Expand the drop-down box  and select 'JSON(application/json)'
	__11.  Enter the following new customer object in the body text area.
	__12.  When looks like below click Send. 
	__13.  In a different tab in Postman, do a 'GET' request to '/customers'
	__14.  Close Postman.
	__15.  Back in eclipse, close all open files.
	__16.  Stop 'App.java' by clicking on the red stop button.

	Part 9 -  Review

	Lab 9 -  Create a RESTful Client with Spring Boot
	Part 1 -  Import the Starter Project
	__1.  From Eclipse's main menu, click File →  Import and then select General →  Existing Projects into Workspace, and then click Next.
	__2.  Click the radio button for Select archive file:
	__3.  Click the Browse button and navigate to select C:\LabFiles\Spring-Boot-REST-Client\Spring-Boot-REST-Client-Starter.zip.and then click Open.
	__4.  On the Import dialog, leave the defaults as-is and click Finish.

	Part 2 -  Examine the Starter Project
	__1.  Right click spring-boot-rest-client and select Maven → Update Project.
	__2.  Make sure  spring-boot-rest-client is selected and click OK.
	__3.  Right click on the spring-boot-rest-client project and select Run as → Maven install to Run a Maven install and ensure that there are no errors. You may need to run the Maven Install two times to get the Build Success message.

	Part 3 -  Complete the CustomerDAO
	__1.  In the Project Explorer, locate the 'APIClientCustomersDAO' class in the 'spring-boot-rest-client/src/main/java/com.webage.dao' package.  Double-click on the file to open it.
	__2.  Add the following line inside the class to provide the connection URL as an instance variable:
	__3.  Look for the 'Insert code here...' comment inside the 'getAllCustomers' method.
	__4.  Edit the method to look like this:
	__5.  Organize imports by pressing Ctrl-Shift-O. Select java.util.Arrays.
	__6.  Save the file.
	__7.  Run a 'Maven install'. 
	__8.  Run the 'App.java' to startup the server  on the spring-boot-rest-client project.
	__9.  Run the 'App.java' to startup the server on the spring-boot-rest project. [Previous Lab].
	__10.  Open a Web Browser and enter 'http://localhost:8081/browseCustomers' as the url.  
	__11.  Close the browser.
	__12.  Stop 'App.java' by clicking on the red stop button.
	__13.  Click Remove All Terminated Launches.
	__14.  Repeat the previous 2 steps as many times as needed until your console is clean.
	__15.  Close all open files.

	Part 4 -  Review

	Lab 10 -  Enable Basic Security
	Part 1 -  Import the Starter Project
	__1.  From Eclipse's main menu, click File →  Import and then select General →  Existing Projects into Workspace, and then click Next.
	__2.  Click the radio button for Select archive file:
	__3.  Click the Browse button and navigate to select C:\LabFiles\Spring-Boot-Basic-Security\Spring-Boot-Basic-Security-Starter.zip and then click Open.
	__4.  On the Import dialog, leave the defaults as-is and click Finish.

	Part 2 -  Enable Security
	__1.  In the Project Explorer, locate 'pom.xml' and double-click on it to open the file. When the editor opens, click on the 'pom.xml' tab at the bottom of the editor panel to view the plain xml.
	__2.  Add the following dependency element just before the closing </dependencies> tag:
	__3.  Save and close the file.

	Part 3 -  Configure the User Password
	__1.  In the Project Explorer, locate the node for 'src/main/resources'.
	__2.  Right-click on 'src/main/resources' and then select New->  Other, and select General →  File in the dialog and click Next.
	__3.  Enter 'application.properties' as the filename and click Finish.
	__4.  In the new file, enter the following line:
	__5.  Save and close the file.

	Part 4 -  Build and Test
	__1.  Right click spring-boot-basic-security and select Maven → Update Project.
	__2.  Make sure spring-boot-basic-security is selected and click OK.
	__3.  Right click on the spring-boot-basic-security project and select Run as → Maven install to Run a Maven install and ensure that there are no errors. You may need to run the Maven Install two times to get the Build Success message.
	__4.  Run the 'App.java' to startup the server  on the spring-boot-basic-security.
	__5.  Open a browser and navigate to 'localhost:8080'.
	__6.  You will be prompted for a user name and password.  
	__7.  Enter 'user' as the username and 'Pa$$w0rd' as the password and then click Login.
	__8.  Do not save the password.
	__9.  Once you've entered your password, you will have full access to the application.
	__10.  Close the browser.
	__11.  Stop 'App.java' by clicking on the red stop button.
	__12.  Click Remove All Terminated Launches.
	__13.  Close all open files.

	Part 5 -  Review

	Lab 11 -  Use AMQP Messaging with Spring Boot
	Part 1 -  Import the Starter Project
	__1.  From Eclipse's main menu, click File →  Import and then select General →  Existing Projects into Workspace, and then click Next.
	__2.  Click the radio button for Select archive file:
	__3.  Click the Browse button and navigate to select C:\LabFiles\Spring-Boot-AMQP\Spring-Boot-AMQP-Starter.zip.and then click Open.
	__4.  On the Import dialog, leave the defaults as-is and click Finish.

	Part 2 -  Examine the Starter Project
	Part 3 -  Complete the MessageConfig
	__1.  In the Project Explorer, locate the 'com.webage.amqp' package node.
	__2.  Inside the 'com.webage.amqp' package, locate the 'MessagingConfig.java' file. Double-click on the file to open it.  You will see that the class is empty.
	__3.  Add the following declaration to the body of the class:
	__4.  Save and close the file.

	Part 4 -  Complete the MessageSenderImpl
	__1.  In the 'com.webage.amqp' package, locate the 'MessageSenderImpl' class, and then double-click on the class to open it.
	__2.  The class should look something like this:
	__3.  Add the following method into the body of the class:
	__4.  Save the file. Bite that the error is gone.
	__5.  Right click spring-boot-amqp and select Maven → Update Project.
	__6.  Make sure spring-boot-amqp is selected and click OK.
	__7.  Right click on the spring-boot-amqp project and select Run as → Maven install to Run a Maven install and ensure that there are no errors. You may need to run the Maven Install two times to get the Build Success message.

	Part 5 -  Add a Message Listener
	__1.  Create a new class called 'MyListener' in the 'com.webage.amqp' package.
	__2.  Edit the class so the body of it looks like:
	__3.  Organize imports by pressing Ctrl-Shift-O. Select com.webage.domain.Order.
	__4.  Save the file. 

	Part 6 -  Test
	__1.  Run 'Maven Install'.
	__2.  Run the 'App.java' class as a Java application.
	__3.  Notice that rabbit has been called.
	__4.  Open a web browser and navigate to 'localhost:8080/input.html'.
	__5.  Enter in the following order details:
	__6.  Click on Send Message.
	__7.  You will see this message:
	__8.  Look in the system console: You should see output that suggest the message was sent and received.
	__9.  Close the browser.
	__10.  Stop 'App.java' by clicking on the red stop button.
	__11.  Click Remove All Terminated Launches.
	__12.  Close all open files.

	Part 7 -  Review

	Lab 12 -  Use Netflix Eureka for Service Discovery
	Part 1 -  Run the Eureka Server
	__1.  From Eclipse's main menu, click File →  Import and then select General →  Existing Projects into Workspace, and then click Next.
	__2.  Click the radio button for Select archive file:
	__3.  Click the Browse button and navigate to select C:\LabFiles\Spring-Cloud-Eureka\Spring-Spring-Cloud-Eureka-Server.zip.and then click Open.
	__4.  On the Import dialog, leave the defaults as-is and click Finish.

	Part 2 -  Examine the Server Project
	Part 3 -  Build and Run the Eureka Server
	__1.  In the Project Explorer, right-click on the project node for 'eureka-server' and then select Run as →  Maven install.
	__2.  Open a Windows Command Prompt.  You can generally find this in the Start menu under All Programs →  Accessories.
	__3.  Enter the following and then press Return, to change directory to the Eclipse project where we built Eureka
	__4.  Enter the following and then press Return.
	__5.  You may be requested to allow access to continue.
	__6.  You should see the Eureka server start up without any errors.

	Part 4 -  Run a Eureka-Enabled API
	__1.  From Eclipse's main menu, click File →  Import and then select General →  Existing Projects into Workspace, and then click Next.
	__2.  Click the radio button for Select archive file:
	__3.  Click the Browse button and navigate to select C:\LabFiles\Cloud-Hello.zip.and then click Open.
	__4.  On the Import dialog, leave the defaults as-is and click Finish.
	__5.  In the Project Explorer, locate the class 'CloudHelloApp' in the 'com.webage.spring.samples.hello' package.  Double-click on the class to open it.
	__6.  Note the annotation on the main class:
	__7.  Close the file 'CloudHelloApp.java'.
	__8.  Locate the file 'application.yml' in the 'src/main/resources' folder and double-click to open it.
	__9.  Close the file 'application.yml'.
	__10.  In the Project Explorer, right-click on the cloud-hello project node and then select Run As →  Maven install.  This will build the project, and should complete without errors.
	__11.  Open a Windows Command Prompt and then type the following to get to the cloud-hello target folder:
	__12.  Start a cloud-hello server by typing the following:
	__13.  You should see the server start up with no errors.  To be extra sure, open a web browser and navigate to 'http://localhost:8080/hello-message'
	__14.  Open a web browser and enter 'http://localhost:8761' into the location bar.  

	Part 5 -  Complete a Eureka-Enabled Client
	__1.  From Eclipse's main menu, click File →  Import and then select General →  Existing Projects into Workspace, and then click Next.
	__2.  Click the radio button for Select archive file:
	__3.  Click the Browse button and navigate to select C:\LabFiles\Spring-Cloud-Eureka\Cloud-Hello-Client-Starter.zip and then click Open.
	__4.  On the Import dialog, leave the defaults as-is and click Finish.
	There are a few things to notice about the project before we start:
	__5.  Locate the file 'HelloClient.java' in the package com.webage.spring.samples.helloclient' and double-click the file to open it.
	__6.  Insert the following code, after the line that reads '//Insert Lookup Code here...'
	__7.  Save the file by pressing Ctrl-Shift-S.
	__8.  Right-click on 'cloud-hello-client' and then select Run as →  Maven install.
	__9.  Right-click on the 'HelloClientApp' class and then select Run As →  Java Application.
	__10.  Watch the console - the program will ask "What's your name?".  Enter a name and then press Return.
	__11.  You should see output like the following:
	__12.  Open a Windows Command Prompt and then type the following to get to the cloud-hello target folder:
	__13.  Start a cloud-hello server by typing the following:
	__14.  Right-click on the 'HelloClientApp' class and then select Run As →  Java Application.
	__15.  Watch the console - the program will ask "What's your name?".  Enter a name and then press Return.
	__16.  You should see output like the following:

	Part 6 -  Complete the API Call
	__1.  In the 'HelloClient.java' file, add the following, just under the line that reads '//Insert code to make the call here...'.  For convenience, this code is available in the file 'C:\LabFiles\Spring-Cloud-Eureka\APICall.txt', if you'd prefer to copy and paste it.
	__2.  Save the file.
	__3.  Using the same techniques as before, run a Maven install on the 'cloud-hello-client' project.
	__4.  Right-click on the 'HelloClientApp' class and then select Run As →  Java Application.
	__5.  Watch the console - the program will ask "What's your name?".  Enter a name and then press Return.
	__6.  You should now see output something like this:
	__7.  If you run the program a few more times, you should see that we're selecting a server randomly between server A and server B.
	__8.  Leave the 'cloud-hello' servers and the Eureka servers running - we'll use them in the next lab.
	__9.  Close the editors.

	Part 7 -  Review

	Lab 13 -  Use Netflix Ribbon for Client-Side Load Balancing
	Part 1 -  Run the Eureka Server
	__1.  From Eclipse's main menu, click File →  Import and then select General →  Existing Projects into Workspace, and then click Next.
	__2.  Click the radio button for Select archive file:
	__3.  Click the Browse button and navigate to select C:\LabFiles\Spring-Cloud-Eureka\Spring-Cloud-Eureka-Server.zip and then click Open.
	__4.  On the Import dialog, leave the defaults as-is and click Finish.
	__5.  In the Project Explorer, right-click on the project node for 'eureka-server' and then select Run as →  Maven install.
	__6.  Open a Windows Command Prompt.  You can generally find this in the Start menu under All Programs →  Accessories.
	__7.  Enter the following and then press Return, to change directory to the Eclipse project where we built Eureka
	__8.  Enter the following and then press Return.
	__9.  You should see the Eureka server start up without any errors.

	Part 2 -  Run a Pair of Cloud-Hello Instances
	__1.  From Eclipse's main menu, click File →  Import and then select General →  Existing Projects into Workspace, and then click Next.
	__2.  Click the radio button for Select archive file:
	__3.  Click the Browse button and navigate to select C:\LabFiles\Cloud-Hello.zip and then click Open.
	__4.  On the Import dialog, leave the defaults as-is and click Finish.
	__5.  In the Project Explorer, right-click on the cloud-hello project node and then select Run As →  Maven install.  This will build the project, and should complete without errors.
	__6.  Open a Windows Command Prompt and then type the following to get to the cloud-hello target folder:
	__7.  Start a cloud-hello server by typing the following:
	__8.  You should see the server start up with no errors.  To be extra sure, open a web browser and navigate to 'http://localhost:8080/hello-message'.  You should see a JSON response from the hello server.
	__9.  Open another Windows Command Prompt and then type the following to get to the cloud-hello target folder:
	__10.  Start a cloud-hello server by typing the following:
	__11.  Open a web browser and enter 'http://localhost:8761' into the location bar.  You should see the Eureka Server page, showing the 'CLOUD-HELLO' service with two instances registered.

	Part 3 -  Complete a Ribbon-Enabled Client
	__1.  From Eclipse's main menu, click File →  Import and then select General →  Existing Projects into Workspace, and then click Next.
	__2.  Click the radio button for Select archive file:
	__3.  Click the Browse button and navigate to select C:\LabFiles\Spring-Cloud-Ribbon\Ribbon-Hello-Client-Starter.zip and then click Open.
	__4.  On the Import dialog, leave the defaults as-is and click Finish.
	There are a few things to notice about the project before we start:
	__5.  Locate the file 'HelloAPI' in the package 'com.webage.spring.samples.helloclient' and double-click the file to open it. 
	__6.  For reference, it's reproduced here:
	__7.  Locate the file 'RibbonHelloClient.java' in the package 'com.webage.spring.samples.helloclient' and double-click the file to open it.
	__8.  Add the following code just after the line that reads '// Insert autowired HelloAPI here...'
	__9.  Insert the following code, after the line that reads '//  Insert code to make the call here...'
	__10.  Save the file by pressing Ctrl-Shift-S.
	__11.  Right-click on 'cloud-ribbon-hello-client' and then select Run as →  Maven install.
	__12.  Right-click on the 'RibbonHelloClientApp' class and then select Run As →  Java Application.
	__13.  Watch the console - the program will ask "What's your name?".  Enter a name and then press Return.
	__14.  You should see output like the following:
	__15.  Press any click inside the Console to terminate the process.
	__16.  Click the icon below as many times until the Console is clean.
	__17.  Shut down the two 'cloud-hello' servers by closing each of their command prompt windows but leave the eureka running.
	__18.  Close any open browser.
	__19.  Close all open editors.

	Part 4 -  Review

	Lab 14 -  Use Netflix Hystrix for the Circuit Breaker Pattern
	Part 1 -  Run the Eureka Server
	__1.  From Eclipse's main menu, click File →  Import and then select General →  Existing Projects into Workspace, and then click Next.
	__2.  Click the radio button for Select archive file:
	__3.  Click the Browse button and navigate to select C:\LabFiles\Spring-Cloud-Eureka\Spring-Cloud-Eureka-Server.zip and then click Open.
	__4.  On the Import dialog, leave the defaults as-is and click Finish.
	__5.  In the Project Explorer, right-click on the project node for 'eureka-server' and then select Run as →  Maven install.
	__6.  Open a Windows Command Prompt.  You can generally find this in the Start menu under All Programs →  Accessories.
	__7.  Enter the following and then press Return, to change directory to the Eclipse project where we built Eureka
	__8.  Enter the following and then press Return.
	__9.  You should see the Eureka server start up without any errors.

	Part 2 -  Run a Pair of Cloud-Hello Instances
	__1.  Make sure there are not cloud-hello instances running.
	__2.  Open a Windows Command Prompt and then type the following to get to the cloud-hello target folder:
	__3.  Start a cloud-hello server by typing the following:
	__4.  You should see the server start up with no errors.  To be extra sure, open a web browser and navigate to 'http://localhost:8080/hello-message'.  You should see a JSON response from the hello server.
	__5.  Open another Windows Command Prompt and then type the following to get to the cloud-hello target folder:
	__6.  Start a cloud-hello server by typing the following:
	__7.  Open a web browser and enter 'http://localhost:8761' into the location bar.  You should see the Eureka Server page, showing the 'CLOUD-HELLO' service with two instances registered.

	Part 3 -  Complete a Hystrix-Enabled Client
	__1.  From Eclipse's main menu, click File →  Import and then select General →  Existing Projects into Workspace, and then click Next.
	__2.  Click the radio button for Select archive file:
	__3.  Click the Browse button and navigate to select C:\LabFiles\Spring-Cloud-Hystrix\Cloud-Hystrix-Hello-Client-Starter.zip and then click Open.
	__4.  On the Import dialog, leave the defaults as-is and click Finish.
	__5.  There are a few things to notice about the project before we start:
	__6.  Locate the file 'HelloAPI' in the package 'com.webage.spring.samples.helloclient' and double-click the file to open it.  
	__7.  Modify the '@FeignClient' annotation to read as follows:
	__8.  Organize imports.
	__9.  Save the class. You will see an error.
	__10.  Right-click on the 'com.webage.spring.samples.helloclient' and then select New →  Class.
	__11.  Enter 'HelloAPIFallback' as the class name and click Finish.
	__12.  Edit the main body of the new class to read as follows.
	__13.  Organize imports.
	__14.  Save and close the file. The error in HelloAPI will gone.
	__15.  Right-click on 'cloud-hystrix-hello-client' and then select Run as →  Maven install.
	__16.  Right-click on the 'HystrixHelloClientApp' class and then select Run As →  Java Application.
	__17.  Watch the console - the program will ask "What's your name?".  Enter a name and then press Return.
	__18.  You should see output like the following:
	__19.  Press return to exit the console.
	__20.  Click the icon below as many times until the Console is clean.
	__21.  If you'd like to run the program again, wait about 30 seconds for the simulated failures to reset.
	__22.  Close all open files.
	__23.  Close all browsers.
	__24.  Close all command prompt windows.

	Part 4 -  Review

	Lab 15 -  Develop a Simple AWS Lambda Function
	Part 1 -  The Business Requirement for the Lambda
	Part 2 -  Create an Eclipse Project
	__1.  Launch Eclipse.
	__2.  From the menu select File > New > Project.
	__3.  Expand Maven, select Maven Project and click Next.
	__4.  Check Create a simple project.
	__5.  Click Next.
	__6.  Enter the Maven coordinates for the package as follows.
	__7.  Click Finish.
	__8.  In Eclipse, expand greeting-lambda and then double click pom.xml to open it.
	__9.  At the bottom of the editor select the pom.xml tab to directly access the text for the file.
	__10.  Below the line:
	__11.  Below that add the shade plugin.
	__12.  Save changes.

	Part 3 -  Create the Request and Response Data Model
	__1.  Right click the greeting-lambda project and select New > Class.
	__2.  Enter these fields:
	__3.  Click Finish.
	__4.  Add a member variable to the class like this.
	__5.  Generate getter and setter for the variable.
	__6.  Save changes.
	__7.  In the same package create a class called GreetingResponse.
	__8.  Add a member variable as follows:
	__9.  Generate getter and setter for the variable.
	__10.  Save changes.

	Part 4 -  Create the Lambda Class
	__1.  In the same package (com.acme.greet) create a class called GreetingLambda.
	__2.  Make the class implement the RequestHandler interface as shown below in bold face.
	__3.  From menu select Source > Organize Imports.
	__4.  The class must implement the handleRequest() method. Let's do that like this:
	__5.  From menu select Source > Organize Imports again. Select com.amazonaws.services.lambda.runtime.Context.
	__6.  Save changes.

	Part 5 -  Build the Package
	__1.  In Eclipse right click the greeting-lambda project and choose Run As > Maven Build …
	__2.  As Goals enter package.
	__3.  Click Run.
	__4.  Make sure that the Console shows BUILD SUCCESS. Also note the location of the built JAR file.

	Part 6 -  Create the Lambda Function in AWS
	__1.  Open a web browser and enter the URL: https://console.aws.amazon.com.
	__2.  Log in using your AWS credentials. [Ask your instructor if you don't have your credentials]
	__3.  Search for Lambda and select the service.
	__4.  Click Create a function.
	__5.  Click Author from scratch.
	__6.  As the name enter GreetingLambda. This does not have to be the class name. But we have no other better name for it.
	__7.  As role, select Create new role from template(s).
	__8.  As role name enter BasicRoleForLambda
	__9.  From the Policy templates dropdown select Simple Microservice permission.
	__10.  Click Create Function.
	__11.  As Runtime select Java 8.
	__12.  As Handler enter the fully qualified class name com.acme.greet.GreetingLambda
	__13.  Click the Upload button. Navigate to the greeting-lambda/target folder within your Eclipse workspace.
	__14.  Select the greeting-lambda-0.0.1-SNAPSHOT.jar file.
	__15.  Click the Save button at the top.

	Part 7 -  Test the Lambda
	__1.  Click the Test button.
	__2.  As the Event name enter BasicTest
	__3.  Enter the body of the request like this:
	__4.  Click Create.
	__5.  Make sure BasicTest is selected. Then click Test.
	__6.  Make sure that you see Execution result: succeeded.
	__7.  Expand Details.
	__8.  You should see the response document as shown below.

	Part 8 -  A Note About Triggers
	Part 9 -  Review

	Lab 16 -  Create Microservice Using AWS Lambda and Couchbase
	Part 1 -  Business Requirement
	Part 2 -  The Software Topology
	Part 3 -  Create the Project
	__1.  In Eclipse create a Maven project with these coordinates:
	__2.  Replace the pom.xml file of the project with LabFiles/add-user/pom.xml.

	Part 4 -  Add the Request and Response Classes
	__1.  In the add-user project add a Java package called com.acme.user
	__2.  In that package add a class called RegistrationRequest
	__3.  Add these member variables:
	__4.  Generate getters and setters for the member variables.
	__5.  Save changes.
	__6.  In the same package, create a class called RegistrationResponse
	__7.  Add this member variable:
	__8.  Generate getters and setters for the member variables.
	__9.  Save changes.

	Part 5 -  Create the Lambda Class
	__1.  In the com.acme.user package create a class called AddUserLambda
	__2.  Make the class implement the RequestHandler interface.
	__3.  We will configure various Couchbase connection parameters as environment variables for the Lambda. Let's define the environment variable names as constants. Add these lines to the class.
	__4.  Add this method that will open a connection to the Couchbase cluster and open the "default" bucket for storage.
	__5.  Finally add the handleRequest() method:
	__6.  Organize imports. Select com.amazonaws.services.lambda.runtime.Context and com.amazonaws.services.lambda.runtime.RequestHandler if prompt. Make sure that there are no compilation errors.
	__7.  Save changes.

	Part 6 -  Export the JAR File
	__1.  Right click the add-user project and select Run As > Maven Build.
	__2.  As goal enter package.
	__3.  Click Run.
	__4.  Make sure that the Console shows BUILD SUCCESS.

	Part 7 -  Create the Lambda in AWS
	__1.  Make sure you are connected in AWS.
	__2.  Open a web browser and go to https://console.aws.amazon.com/lambda.
	__3.  Make sure you are in US-West Oregon region.
	__4.  Click Create function.
	__5.  Click Author from scratch.
	__6.  Enter the information as shown below.
	__7.  Click Create function.
	__8.  Scroll down to the Function code section and as the Handler enter the fully qualified class name of the Lambda: com.acme.user.AddUserLambda
	__9.  Click the Upload button.
	__10.  Select the JAR file exported earlier. It should be within the Eclipse workspace as add-user/target/add-user-0.0.1-SNAPSHOT.jar.
	__11.  Expand Environment variables.
	__12.  Add these environment variables. In your case the EC2 instance for Couchbase will have a different IP address. 
	__13.  From the top of the page click the Save button. This will upload the JAR file and configure the other parameters.

	Part 8 -  Increase Memory and Timeout
	__1.  Under Basic settings enter these values:
	__2.  Click the Save button from the top.

	Part 9 -  Test the Lambda
	__1.  Click the Test button.
	__2.  Enter an event name. In a multi-user lab environment add a distinguishing marker to the name to make it unique.
	__3.  Enter an example request like below. Change the values to distinguish them in the server.
	__4.  Click Create.
	__5.  Click Test again. It will take a few seconds to complete the test.
	__6.  Expand Details. Make sure that you see the response document.

	Part 10 -  Access Couchbase Console
	__1.  Open a web browser. 
	__2.  Enter the URL http://COUCHBASE_IP:8091. Where COUCHBASE_IP is the public IP address of the Couchbase EC2 instance. 
	__3.  Use Administrator as user ID.
	__4.  Use wasadmin as password.
	__5.  Click Sign in.
	__6.  Click Buckets from the top.
	__7.  We are using the default data bucket. Click the Documents link.
	__8.  Make sure that you see the documents added by our Lambda there. You will see other students documents. Click on the ID link to view the contents of a document.

	Part 11 -  Create a HTTP Frontend for the Lambda
	__1.  Go back to AWS. Scroll down then click API Gateway under Configuration / Designer section.
	__2.  Scroll down, in the Configure triggers section click the drop down and select Create a new API.
	__3.  Enter  LambdaMicroservice_YourName as API name and deployment stage, make sure you use your name to identify your own Amazon API Gateway.
	__4.  Expand Security and select Open. This is because our web service has no security requirements. 
	__5.  Click Add.
	__6.  Click Save.
	__7.  Under API Gateway section, click the LambdaMicroservice_YourName link. This will open the Amazon API Gateway console page.
	__8.  Observe the following items:
	__9.  Click the ANY method name to configure the endpoint.
	__10.  Click the Integration Request link.
	__11.  Uncheck Use Lambda Proxy integration. And accept the confirmation dialog.

	Part 12 -  Test the API Gateway
	__1.  Click the ANY method under the RegisterUser_YourName resource.
	__2.  Click TEST.
	__3.  Choose POST as the method.
	__4.  Under Request Body enter a valid JSON request. For example:
	__5.  From the bottom of the page click the Test button.
	__6.  Verify that the response status code is 200 and the response document looks good.
	__7.  Log into Couchbase console and verify that the user document is showing up. 
	__8.  Delete all your the document so that we can easily verify future tests.

	Part 13 -  Deploy the API
	__1.  Go back to AWS, under APIs select LambdaMicroservice_YourName.
	__2.  Click the Actions button and select Deploy API.
	__3.  As the Deployment stage select your LambdaMicroservice_YourName
	__4.  Click Deploy.
	__5.  From the left hand side, click Stages.
	__6.  Expand your API and click POST.
	__7.  You will see the URL on the top of the page.

	Part 14 -  Access the Web Service from the Internet
	__1.  Copy the URL for the web service from the previous part. We will need it soon.
	__2.  Open a command prompt window.
	__3.  Change directory to the LabFiles folder.
	__4.  An input file called c:\LabFiles\user.json is present there. Open the file using an editor and customize the values to make it unique.
	__5.  In the command prompt enter (in one line):
	__6.  Make sure that the response status is 200 and the response document looks correct.
	__7.  Go back to Couchbase console and verify that the user got created.
	__8.  Close the browser and eclipse.

	Part 15 -  Review

	Lab 17 -  Kafka Basics
	Part 1 -  Start ZooKeper
	__1.  Open Terminal window by clicking Application > Terminal.
	__2.  In menu bar, click Terminal > Set Title…
	__3.  Enter Zookeeper in the Title field and click OK.
	__4.  Connect as admin:
	__5.  Enter wasadmin as password.
	__6.  Execute “sestatus” and check the value of Current Mode. 
	__7.  If it is NOT set to “permissive” then execute this command:
	__8.  get "sestatus" again and verify it’s permissive. 
	__9.  Switch to the Kafka directory by executing these 2 commands:
	__10.  Start Zookeeper:
	__11.  Keep the Terminal window open.

	Part 2 -  Start Kafka Server
	__1.  Open a new Terminal window by clicking Application > Terminal.
	__2.  In menu bar, click Terminal > Set Title…
	__3.  Enter Kafka Server in the Title field and click OK.
	__4.  Connect as admin:
	__5.  Enter wasadmin as password.
	__6.  Switch to the Kafka directory by executing these 2 commands:
	__7.  Start Kafka server:
	__8.  Keep the Terminal window open.

	Part 3 -  Create a Kafka Topic
	__1.  Open a new Terminal window by clicking Application > Terminal.
	__2.  In menu bar, click Terminal > Set Title…
	__3.  Enter Producer in the Title field and click OK.
	__4.  Connect as admin:
	__5.  Enter wasadmin as password.
	__6.  Switch to the Kafka directory by executing these 2 commands:
	__7.  Create a Kafka topic:
	__8.  Get a list of Kafka topics:

	Part 4 -  Send some messages
	__1.  In the Terminal window, which you opened in Part 3 of this lab, execute the following command to send some messages to the Kafka cluster: 
	__2.  Enter the following messages:
	__3.  Keep the Terminal window open.

	Part 5 -  Read messages from the Kafka cluster 
	__1.  Open a new Terminal window by clicking Application > Terminal.
	__2.  In menu bar, click Terminal > Set Title…
	__3.  Enter Consumer in the Title field and click OK.
	__4.  Connect as admin:
	__5.  Enter wasadmin as password.
	__6.  Switch to the Kafka directory by executing these 2 commands:
	__7.  In the Terminal window, enter the following command to read the messages:
	__8.  Notice it shows the following messages.
	__9.  Switch back to the Producer Terminal window and enter more messages.
	__10.  Switch to the Producer Terminal window and press Ctrl+Z to stop entering more messages. Keep the Terminal window open.
	__11.  Switch to the Consumer Terminal window and press Ctrl+Z to stop reading messages. Keep the Terminal window open.

	Part 6 -  Setting up a multi-broker clusters
	__1.  Open a new Terminal window by clicking Application > Terminal.
	__2.  In menu bar, click Terminal > Set Title…
	__3.  Enter Kafka Server 1 in the Title field and click OK.
	__4.  Connect as admin:
	__5.  Enter wasadmin as password.
	__6.  Switch to the Kafka directory by executing these 2 commands:
	__7.  Open server.properties in text editor: 
	__8.  Press Ctrl+Q to exit to the Terminal window. 
	__9.  Execute the following command to find the number of nodes/brokers in the Kafka cluster:
	__10.  Create two copies of server.properties:
	__11.  Edit server-1.properties:
	__12.  Locate broker.id=0 and change it to broker.id=1
	__13.  Locate #listeners=PLAINTEXT://:9092  remove the comment (#) symbol, and change change the port number to 9093
	__14.  Locate log.dirs=/tmp/kafka-logs  and change it to  log.dirs=/tmp/kafka-logs-1
	__15.  Press Ctrl+S to save the file.
	__16.  Press Ctrl+Q to exit to the Terminal window.
	__17.   Edit server-2.properties:
	__18.  Locate broker.id=0 and change it to broker.id=2
	__19.  Locate #listeners=PLAINTEXT://:9092  remove the comment (#) symbol, and change change the port number to 9094
	__20.  Locate log.dirs=/tmp/kafka-logs  and change it to  log.dirs=/tmp/kafka-logs-2
	__21.  Press Ctrl+S to save the file.
	__22.  Press Ctrl+Q to exit to the Terminal window.

	Part 7 -  Start up a multi-broker cluster and verify the cluster 
	__1.  In the Kafka Server 1 Terminal window, run the following command to start up the second node:
	__2.  Open a new Terminal window by clicking Application > Terminal.
	__3.  In menu bar, click Terminal > Set Title…
	__4.  Enter Kafka Server 2 in the Title field and click OK.
	__5.  Connect as admin:
	__6.  Enter wasadmin as password.
	__7.  Switch to the Kafka directory by executing these 2 commands:
	__8.  Execute the following command to find the number of nodes/brokers in the Kafka cluster:
	__9.  In the Kafka Server 2 Terminal window, run the following command to start up the second node:
	__10.   Switch to the Producer Terminal window and execute the following command to find the number of nodes/brokers in the Kafka cluster:

	Part 8 -  Create a new topic on the multi-broker cluster
	__1.  In the Producer Terminal window, execute the following command to create a new topic: 
	__2.  Verify the new topic is created:
	__3.  Get webage topic details to see the node(s) handling the topic:
	__4.  Get webage-replicated-topic details to see the node(s) handling the topic:

	Part 9 -  Send messages to the new replicated topic
	__1.  In the Producer Terminal window, enter the following command to send messages
	__2.  At the Producer prompt, enter the following messages:
	__3.  Remain at the Producer prompt (>) and keep the Terminal window open.

	Part 10 -  Read messages from the new replicated topic 
	__1.  Switch to the Consumer Terminal that you used before. If you closed it then follow same steps to create a new one.
	__2.  Execute the following command to read messages from the replicated topic which you created in the previous parts of the lab:

	Part 11 -  Test Cluster Fault Tolerance
	__1.  Open a new Terminal window by clicking Application > Terminal.
	__2.  In menu bar, click Terminal > Set Title…
	__3.  Enter FaultTolerance in the Title field and click OK.
	__4.  Connect as admin:
	__5.  Enter wasadmin as password.
	__6.  Switch to the Kafka directory by executing these 2 commands:
	__7.  Find process ID of Kafka Server 1 instance (broker.id = 1) by running the following command in the Terminal window:
	__8.  Scroll up and locate the process ID listed in the first line immediately below the command you executed in the previous step.
	__9.  Kill the process:
	__10.  Verify there's one less node in the cluster: 
	__11.  Get webage topic details to see the node(s) handling the topic:
	__12.  Switch to the Producer Terminal window and enter another message:
	__13.  Switch to the Consumer Terminal window and verify it shows "still working" message.

	Part 12 -  Use Kafka Connect to import/export data
	__1.  Switch to the Producer Terminal window and press Ctrl+C to exit to the terminal.
	__2.  Create a text file with some seed data: 
	__3.  Enter the following text:
	__4.  Press Ctrl-S to save the file.
	__5.  Press Ctrl-Q to exit.
	__6.  Verify you have the text file with data: 
	__7.  Notice it shows the following data. 
	__8.  Edit Kafka Connect source configuration:
	__9.  Change test.txt to webage.txt
	__10.  Change topic from connect-test to webage-replicated-topic
	__11.  Press Ctrl+S to save the file.
	__12.  Press Ctrl+Q to exit to the Terminal window. 
	__13.  Start Kafka Connect:
	__14.  Switch to the Consumer Terminal window and notice two new rows are available as shown below:

	Part 13 -  Cleanup
	__1.  Close the following Terminal windows. Press Ctrl+C in Terminal windows where any process is running.

	Part 14 -  Review

	Lab 18 -  Apache Kafka with Spring Boot and Nodejs
	Part 1 -  Create a directory and copy a sample project
	__1.  Open a new Terminal window by clicking Application > Terminal.
	__2.  In menu bar, click Terminal > Set Title…
	__3.  Enter SpringBoot in the Title field and click OK.
	__4.  Switch to the project directory:
	__5.  Keep the Terminal window open.

	Part 2 -  Explore the existing project
	__1.  View the directory tree:
	__2.  View pom.xml file:
	__3.  View service/KafkaSender.java:
	__4.  View controller/ApacheKafkaWebController.java:
	__5.  View SpringBootHelloWorldApplication.java:

	Part 3 -  Add Apache Kafka Dependency
	__1.  Edit pom.xml:
	__2.  Inside the <dependencies> tag, add the following dependency:
	__3.  Press Ctrl+S to save the file. 
	__4.  Press Ctrl+Q to exit to the Terminal window.

	Part 4 -  Write service code to send message(s) 
	__1.  Edit KafkaSender.java:
	__2.  Below the existing import statements, enter the following code:
	__3.  Press Ctrl+S to save the file. 
	__4.  Press Ctrl+Q to exit to the Terminal window.

	Part 5 -  Write code for the controller
	__1.  Edit ApacheKafkaWebController.java:
	__2.  Below the existing import statements, enter the following code:
	__3.  Press Ctrl+S to save the file. 
	__4.  Press Ctrl+Q to exit to the Terminal window.

	Part 6 -  Write code for bootstrapping the Spring Boot application
	__1.  Edit SpringBootHelloWorldApplication.java:
	__2.  Below the existing import statements, enter the following code:
	__3.  Press Ctrl+S to save the file. 
	__4.  Press Ctrl+Q to exit to the Terminal window.

	Part 7 -  Build and test the application
	__1.  In the Terminal window, enter the following code to build and run the Spring Boot application:
	__2.  Open Firefox web browser window by clicking Application > Firefox.
	__3.  Enter the following URL in the browser: 
	__4.  Switch to the Consumer Terminal window, which must be running from the previous lab.
	__5.  Switch to the Consumer Terminal window and Press Ctrl+C to stop the consumer.

	Part 8 -  Create a Nodejs consumer
	__1.  Open a new Terminal window by clicking Application > Terminal.
	__2.  In menu bar, click Terminal > Set Title…
	__3.  Enter Nodejs in the Title field and click OK.
	__4.  Switch to the Downloads directory:
	__5.  Create a directory for Nodejs consumer project: 
	__6.  Switch to the directory: 
	__7.  Install Kafka dependency:
	__8.  Create index.js file and write code for retrieving data from a Kafka topic:
	__9.  Enter the following code:
	__10.  Press Ctrl+S to save the file.
	__11.  Press Ctrl+Q to exit to the Terminal window.
	__12.  Run the application:
	__13.  Switch back to the web browser and enter the following URL:
	__14.  Switch to the  Consumer Terminal window.

	Part 9 -  Cleanup
	__1.  Close all the Terminal windows. Press Ctrl+C in Terminal windows where any process is running.
	__2.  Close the Firefox window.

	Part 10 -  Review

	Lab 19 -  Debugging a Node.js Application
	Part 1 -  Install node-inspector
	__1.  In a command prompt window switch directory to C:\LabFiles.
	__2.  Run this command to install the module.
	__3.  Verify that the module was installed by running this command.

	Part 2 -  Debug a Program
	__1.  In a command prompt window switch to the C:\LabFiles\movies directory.
	__2.  Run this command to start debugging the program.
	__3.  That command will launch Chrome. You will get this prompt about notification. Click Allow.
	__4.  By default the program will halt in the first line.
	__5.  Click the resume button  to continue.
	__6.  Add a breakpoint as shown below.
	__7.  Open a new command prompt window and switch to C:\LabFiles.
	__8.  Run this command to send a POST request.
	__9.  The debugger will hit the break point and pause.
	__10.  On the right hand side expand Closure to locate the movies variable. There should be three movies there at this point.
	__11.  Click the step over button  to move to the next line.
	__12.  Expand Local and inspect the newMovie variable.
	__13.  Click the step over button  to move to the next line.
	__14.  At this point there should be 4 items in the movies array.
	__15.  Click the resume button  to continue.
	__16.  Close the Chrome window.
	__17.  In the command prompt where you ran node-debug hit Control+C to end the program.
	__18.  Close all.

	Part 3 -  Review

	Lab 20 -  Kubernetes Hello World 
	Part 1 -  Setting the Stage 
	__1.  Open a new Terminal window by clicking Applications > Terminal.
	__2.  Switch the logged-in user to root: 
	__3.  Enter the following command:

	Part 2 -  Ensure you can run minikube and kubectl
	__1.  Add /usr/local/bin to the path environment variable:
	__2.  Verify you can execute minikube:
	__3.  Get minikube help:
	__4.  Verify you can execute kubectl and also obtain Kubernetes version:
	__5.  Find out if this version of minikube supports the installed version of Kubernetes:
	__6.  Get Kubernetes cluster information:

	Part 3 -  Start the Cluster
	__1.  Run following command to start a cluster:
	__2.  Wait until it switches back to the terminal.
	__3.  Switch back to the terminal and run following command:
	__4.  Run following command to obtain the cluster IP address:

	Part 4 -  View Kubernetes Dashboard
	__1.  In the terminal, run following command to view the dashboard URL:
	__2.  It will open Firefox web browser and show the Kubernetes page.
	__3.  On left side of the dashboard, click Nodes.
	__4.  Open a new terminal by clicking Applications > Terminal.
	__5.  Switch the logged-in user to root: 
	__6.  In the terminal, run following commands to view nodes:

	Part 5 -  Create a Container 
	__1.  Run following command:
	__2.  Run following command to view pod list:
	__3.   Switch to the Firefox window, where dashboard is open, and click Pods on left side of the page.

	Part 6 -  View Logs and Details
	__1.  On the dashboard, click my-web-server pod.
	__2.  Make a note of the pod name under Details on the dashboard.
	__3.  In the terminal run following command to view pod details:
	__4.  Run following command to view node details:
	__5.  On the dashboard, click Pods on left side of the page, then click the Logs icon next to the pod. 
	__6.  Close the tab where the log is displayed and go back to the tab where the dashboard is open.

	Part 7 -  Expose a Service
	__1.  In the terminal, run following command:
	__2.  In the Firefox web browser tab where dashboard is open, click Services on left side of the page.
	__3.  In the terminal run following command to view the exposed services:
	__4.  View my-web-server service details:
	__5.  In the terminal, run following command to access the service's public IP address:
	__6.  Ctrl+Click the URL in the terminal. It will launch the page in Firefox web browser. 
	__7.  On the dashboard, click Services, then click your service, and click Log icon next to the service. 
	__8.  Make a note of the full service name, as shown in the above picture.
	__9.  In the terminal run following command:

	Part 8 -  Scaling the Services
	__1.  In the terminal, run following command:
	__2.  Run following command to scale the service:
	__3.  Run following command to get the service instance count:
	__4.  On the dashboard page, in the web browser, click Deployments on left side of the page.
	__5.  On the dashboard page, click Services on left side of the page, then click my-web-server service.
	__6.  On left side of the page, click Pods.

	Part 9 -  Stop and Delete the Cluster 
	__1.  In the terminal, run following command to stop the cluster:
	__2.  Run following command to delete the cluster: 
	__3.  Close all open browsers.
	__4.  Type exit in each Terminal and then close it.

	Part 10 -  Review

	Lab 21 -  Secret Handling in Kubernetes
	Part 1 -  Login and Create a Project
	__1.  You need to be 'root user' to use 'oc'.  If necessary, become superuser by typing:
	__2.  Ensure that the cluster is running, by typing the following:
	__3.  Login as system administrator:
	__4.  Make sure we're in the 'myproject' project:

	Part 2 -  Create a Secret
	__1.  Make sure you're in 'wasadmin's home directory by typing:
	__2.  Create a folder for the secret values:
	__3.  We want to put the text 'servicedb' in a file called 'userid' in the secrets directory:
	__4.  Similarly, create a file called 'password' that contains 'very-secret-1' as the content:
	__5.  Now we can go ahead and create the secret:
	__6.  'oc' will output the name of the newly-created secret:
	__7.  We can check that the secret exists by typing the following:
	__8.  'oc' will print a JSON representation of the secret object:

	Part 3 -  Create an Application that Uses the Secret 
	__1.  Change into the '/home/wasadmin/LabFiles/SecretsOnOpenShift/show-secrets' folder by typing the following:
	__2.  Create a new image based on the Dockerfile contained in this folder:
	Make sure you type the dot at the end of the command.
	__3.  Create a new application based on the new image:
	__4.  Expose the application by entering the following (as one line):
	__5.  Open a web browser and enter the following URL:
	Notice that the browser shows an error:
	__6.  As part of the new-application process, OpenShift created a deployment configuration for 'ssh-host'.  We need to modify that deployment configuration to use the secrets.  Add the secret volume by typing:
	__7.  Wait for a few moments, then refresh the browser window that you opened in the step above:
	__8.  Enter the following url in the browser:
	__9.  Keep the terminal and the web browser open for the next lab.

	Part 4 -  Review

	Lab 22 -  Create an OpenShift Jenkins Pipeline for a Microservice
	Part 1 -  Create a Node.js Application 
	__1.  In the terminal, run following command:
	__2.  Switch to the directory:
	__3.  Initialize a new node application:
	__4.  Press Enter key to use default value for each option, at the end enter y and hit Enter.
	__5.  Download express node module:
	__6.  Create index.js file:
	__7.  Enter following code:
	__8.  Click the Save button to save the file. Then close gedit.
	__9.  Run the service: 
	__10.  Open Firefox web browser and enter following URL in a new tab:
	__11.  Now stop the command by pressing CTRL+C.
	__12.  Close the tab in the browser.

	Part 2 -  Create a Docker Image
	__1.  Ensure you are under /var/lib/jenkins/repos/hello-node directory:
	__2.  Create Dockerfile:
	__3.  Enter following text (Note: To save time, you can skip the comments with # in front of them. They do contain some important instructions which you must perform):
	__4.  Save the file and close gedit.
	__5.  Create a .dockerignore file:
	__6.  Enter following text:
	__7.  Save the file and close gedit.
	__8.  Run following command to build a custom image: 
	__9.  After the above command completes, verify the custom image exists:

	Part 3 -  Check in the code into Git repository
	__1.  Ensure you are under /var/lib/jenkins/repos/hello-node directory:
	__2.  Create .gitignore file: 
	__3.  Enter following text:
	__4.  Save the file and close gedit.
	__5.  Initialize a Git repository:
	__6.  Stage changed files:
	__7.  Commit the changes: 

	Part 4 -  Manually Deploy the Custom Image and Verify the Service 
	__1.  Set myproject as the active project: 
	__2.  Create a new application by deploying your custom docker image: 
	__3.  Get status:
	__4.  Get pod list:
	__5.  In the web browser, click My Project (if it's not already selected), then click Overview on left side of the page.
	

	Part 5 -  Expose node-app Service and Access it
	__1.  In the terminal, run following command to see service details. 
	__2.  In the web browser, on left side of the page, click Applications > Services.
	__3.  Click the node-app service.
	__4.  In the terminal, run following command to expose the service:
	__5.  Right click the URL under HostName and click Open in new tab.
	__6.  Keep the tab open. Later lab instructions will refer to it as "Hello Node Tab".

	Part 6 -  Connect to Jenkins and Configure it
	__1.  Open a new tab in the web browser and enter following URL:
	__2.  Enter following credentials to log in:
	__3.  On left side of the page, click Manage Jenkins.
	__4.  Click Configure System.
	__5.  Under Global properties, select check box in front of Environment variables.
	__6.  Click Add button.
	__7.  Add a new environment variable with following values:
	__8.  Click Save button.

	Part 7 -  Create a New Jenkins Job
	__1.  On left side of the Jenkins home page, click New Item.
	__2.  Enter CI-CD as the job name.
	__3.  Select Freestyle project type.
	__4.  Click OK button.
	__5.  Under Source Code Management select Git.
	__6.  In Repository URL enter following location and then hit Tab.
	__7.  Click Apply button.
	__8.  Under Build Triggers, select Poll SCM and enter following Schedule:
	__9.  Click Apply button.
	__10.  Under Build, click Add build step and select Execute shell.
	__11.  Enter following in Command text box:
	__12.  Click Save button.

	Part 8 -  Test Jenkins CI/CD Job
	__1.  In the terminal you are located under /var/lib/jenkins/repos/hello-node directory.
	__2.  Edit index.js file:
	__3.  Change v1.0 to v2.0
	__4.  Save the file and close gedit.
	__5.  Stage the changed files.
	__6.  Commit changes.
	__7.  In the web browser, go to the page where Jenkins CI-CD job is available.
	__8.  Wait for about a minute or so. Under Build History you should be able to see a new build.
	__9.  While the build is getting performed, click the build and go to Console Output.
	__10.  After the Job finishes, in the web browser, go to the tab where OpenShift page is open and click Overview tab.
	__11.  If you time it properly, you should be able to see the node-app pod is getting reinitialized. 
	__12.  When the pod is up and running, in the web browser, go to the Hello Node Tab and refresh the page.
	__13.  In the terminal, execute following command. 
	__14.  Keep the terminal and the web browser open for the next part.

	Part 9 -  Create a New Jenkins Job - Pipeline
	__1.  On left side of the Jenkins home page, go home and then click New Item.
	__2.  Enter CI-CD Pipeline as the job name.
	__3.  Select Pipeline type.
	__4.  Click OK button.
	__5.  Under Pipeline, in Script text box, type in following script.
	__6.  Click Save button.

	Part 10 -  Test Jenkins CI/CD Pipeline
	__1.  In the terminal you are located under /var/lib/jenkins/repos/hello-node directory:
	__2.  Edit index.js file:
	__3.  Change v2.0 to v3.0
	__4.  Save the file and close gedit.
	__5.  Stage the changed files:
	__6.  Commit changes: 
	__7.  In the web browser, go to the page where Jenkins CI-CD Pipeline is available.
	__8.  Click Build Now.
	__9.  Under Build History you should be able to see a new build.
	__10.  After the Job finishes, in the web browser, go to the tab where OpenShift page is open and click Overview tab.
	__11.  If you time it properly, you should be able to see the node-app pod is getting reinitialized. 
	__12.  When the pod is up and running, in the web browser, go to the Hello Node Tab and refresh the page.
	__13.  In the terminal, execute following command:
	__14.  Keep the terminal and the web browser open for the next lab.

	Part 11 -  Review

	Lab 23 -  Create an OpenShift Blue Ocean Pipeline for a Microservice
	Part 1 -  Create Jenkins file 
	__1.  In the terminal, run following command:
	__2.  Switch to the web browser where Jenkins is open. If you close it open it from:
	__3.  Click CI-CD Pipeline job.
	__4.  Click Configure.
	__5.  Go to the Pipeline section.
	__6.  Select entire script in the Script text box and copy it to clipboard.
	__7.  In the terminal, create Jenkinsfile:
	__8.  Paste the text from the clipboard.
	__9.  Save and close.
	__10.  Stage the changed files:
	__11.  Commit changes: 

	Part 2 -  Access Blue Ocean
	__1.  On the Jenkins page, click Jenkins to access the home page.
	__2.  Click Open Blue Ocean.
	
	__3.  Click CI-CD. (Note: If you recall, it's a Freestyle Jenkins job)
	__4.  Click the most recent build.
	__5.  Click the close button (x).
	
	__6.  Click Pipelines.
	
	__7.  Click CI-CD Pipeline. (Note: It's a Jenkins Pipeline where you typed the script manually).
	__8.  Click Run button. (Note: It's equivalent to Jenkins' Build Now). You may need to refresh the browser to see the Build.
	__9.  When the build appears under the history, click the most recent build.
	__10.  Click the close button (x).
	__11.  Click Pipelines.

	Part 3 -  Create a new Jenkins Blue Ocean Pipeline 
	__1.  Click New Pipeline.
	
	__2.  Click Git.
	
	__3.  In Repository URL, enter follow text:
	__4.  Click Create Pipeline.
	__5.  Click the first build, while it's still getting executed.
	__6.  It will show you the status of each pipeline stage.
	

	Part 4 -  Test Jenkins CI/CD Pipeline
	__1.  In the terminal you are located under /var/lib/jenkins/repos/hello-node directory:
	__2.  Edit index.js file:
	__3.  Change v3.0 to v4.0
	__4.  Save the file and close gedit.
	__5.  Stage the changed files :
	__6.  Commit changes:
	__7.  In the web browser, go to the page where Blue Ocean page is open.
	__8.  Click rerun button.
	
	After few seconds it shows the build progress like this, if you don't see a progress then refresh the page:
	
	__9.  After the Job finishes, in the web browser, go to the tab where OpenShift page is open and click Overview tab.
	__10.  If you time it properly, you should be able to see the node-app pod is getting reinitialized. 
	__11.  When the pod is up and running, in the web browser, go to the Hello Node Tab and refresh the page.
	__12.  In the terminal, execute following command:
	__13.  In the web browser, where Jenkins Blue Ocean page is open, click the close button (x).
	__14.  Click Pipelines.
	__15.  Switch back to the class mode.
	
	__16.  Keep the terminal and the web browser open for the next lab.

	Part 5 -  Review

	Lab 24 -  Creating a REST Client with Feign
	Part 1 -  Start a sample service
	__1.  Open Command Prompt window by running following command:
	__2.  Switch to the book service directory:
	__3.  Run the service:
	__4.  Wait until it shows "JVM running for nnn.nnn" message.
	__5.  Open a web browser window and type in the following URL:
	__6.  In the web browser window, type the following URL to access a book by isbn:
	__7.  Keep the Command Prompt open with the service running. You will create a client by using Feign, later in the lab.

	Part 2 -  Create directory structure for storing Feign client 
	__1.  Open another Command Prompt window:
	__2.  Create a Workspace directory: (It may be already created)
	__3.  Switch to the directory:
	__4.  Create a directory for storing the Feign client and switch to the directory:
	__5.  Create directory structure for storing the client (interface) code:
	__6.  Create directory structure for storing the Book model(s):
	__7.  Create directory structure for storing the unit tests:
	__8.  Get the directory tree:
	__9.  Verify your directory structure looks like this:

	Part 3 -  Add dependencies to pom.xml
	__1.  Run the following command in the Command Prompt to copy pom.xml file into the Feign client directory:
	__2.  Open C:\Workspace\feign-client\pom.xml in Notepad++ or in some other text editor/IDE.
	__3.  To the dependencies section, add the following dependency:
	__4.  To the dependencies section, add the following dependency:
	__5.  To the dependencies section, add the following dependency:
	__6.  To the dependencies section, add the following dependency:
	__7.  Save the file and close the file.

	Part 4 -  Create the model(s)
	__1.  Create a file named Book.java under src/main/java/com/simple/feign/models in the same project.
	__2.  Add following code to the Book.java file:
	__3.  Add following code to the Book.java file:
	__4.  Save the file and close the file.
	__5.  Create a file named BookResource.java under src/main/java/com/simple/feign/models.
	__6.  Add following code to the BookResource.java file:
	__7.  Add following lines to the BookResource.java file:
	__8.  Save the file and close the file.

	Part 5 -  Create a Feign Client
	__1.  Create a file named BookClient.java under src/main/java/com/simple/feign/clients.
	__2.  Add following code to the BookClient.java file:
	__3.  Add following lines to declare a BookClient interface:
	__4.  Save the file and close the file.

	Part 6 -  Create a Controller / Client builder
	__1.  Create a file named BookControllerFeignClientBuilder.java under src/main/java/com/simple/feign.
	__2.  Add following code to the BookControllerFeignClientBuilder.java file:
	__3.  Add following lines to declare a BookControllerFeignClientBuilder interface:
	__4.  Save the file and close the file.

	Part 7 -  Create a unit test to test the Feign client functionality
	__1.  Create a file named BookClientLiveTest.java under src/test/java/com/simple/feign/clients.
	__2.  Add the following code to the BookClientLiveTest.java file:
	__3.  Add the following code to the file: 
	__4.  To the class, add the following code:
	__5.  Add the following code to the class: 
	__6.  Add the following lines of code to the class: 
	__7.  Add the following lines of code to the class: 
	__8.  Save the file and close the file.

	Part 8 -  Build the Feign client and run the tests
	__1.  In the Command Prompt window, switch to the Feign client directory:
	__2.  Run the tests:
	__3.  Switch to the Command Prompt window where the book service is running and press Ctrl+C followed by Y to stop the service.
	__4.  Switch to the Command Prompt window where you executed the unit tests and run the tests again:
	__5.  Close all Command Prompt windows and the web browser.

	Part 9 -  Review




