
WA2621 DevOps Foundations for
Java with Git, Jenkins, and Maven

Student Labs

Web Age Solutions Inc.

Copyright 2019 Web Age Solutions Inc. 1

EVALU
ATIO

N O
NLY



Table of Contents
Lab 1 - Version Control - Git...............................................................................................3
Lab 2 - Branching, Merging and Working with Remotes....................................................8
Lab 3 - GitFlow Workflow.................................................................................................14
Lab 4 - Configure Tools in Jenkins....................................................................................24
Lab 5 - Install Maven.........................................................................................................29
Lab 6 - Create a Maven Project.........................................................................................34
Lab 7 - Create a Web Application from an Archetype.......................................................41
Lab 8 - Add Web Site, Static Analysis, and Code Coverage ............................................53
Lab 9 - Create a Jenkins Job..............................................................................................62
Lab 10 - A Multi-Module Project.......................................................................................80
Lab 11 - Create a Standard Set of Dependencies...............................................................89
Lab 12 - Write a Simple  Maven Plugin............................................................................92
Lab 13 - Create an Archetype..........................................................................................103
Lab 14 - Create a Corporate Repository with Artifactory................................................112
Lab 15 - Deploy to the Corporate Repository with Artifactory.......................................118
Lab 16 - Add Development Metrics.................................................................................124
Lab 17 - Create a Pipeline................................................................................................131

Copyright 2019 Web Age Solutions Inc. 2

EVALU
ATIO

N O
NLY



Lab 1 - Version Control - Git

Open the WA2606 Linux image.

In this chapter you will install, configure, and use Git.

Part 1 - Launch terminal
In this part you will launch the Linux terminal.

__1. Open the Terminal window.

Alternatively, you can press Ctrl+Alt+T to access the terminal.

Part 2 - Install Git
__1. Update APT repository

sudo apt-get update

Enter wasadmin as password, if prompted

__2. Install git.

sudo apt-get install git

Press Y, if prompted

__3. In the terminal run following command to find git version number.

git –version
git help
git help -a

Part 3 - Using Git
In this part you will use Git to perform various operations, such as, check in, check status 
etc.

__1. Switch to the "Documents" directory.

cd ~/Documents

__2. Create a directory.

mkdir -p workspace/git
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__3. Switch to the "git" directory.

cd workspace/git

__4. Initialize repository.

git init

__5. Tell Git who you are.

git config --global user.name "Alice Smith"
git config --global user.email alice@smith.com

Note: One interesting aspect of Git is that it separates user identity in the repository from 
any sort of authentication or authorization.  Because a distributed repository will 
generally be maintained by many separate individuals or systems, the identity of the 
committer must be contained in the repository – it can't just be supplied as a user id 
when we do the commit.  So, even if we're not connected to any central repository, we 
need to tell Git who we are.  The identity that we supply will be recorded whenever we 
commit to a repository.

__6. Create a text file.

nano sample.txt

__7. Enter following text.

First Version!

__8. Press Ctrl+O to save the file and hit enter.

__9. Press Ctrl+X to exit to the terminal.

__10. Get Git status.

git status

Notice sample.txt is listed under untracked files.

__11. Add the files to tracked.

git add .

Note: Here you are adding the current directory. You could also add the file using "git 
sample.txt".

__12. Get Git status again.
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git status

Notice sample.txt is tracked.

__13. Commit changes.

git commit

Notice it launched text editor automatically which lists operations that will get 
performed when files are committed. Here you can add detailed description that will get 
saved when you commit the changes.

__14. Add following text in the first line.

Added sample.txt

__15. Press Ctrl+O to save the file and hit enter.

__16. Press Ctrl+X to exit to the terminal.

__17. Get Git status.

git status

Notice it says there's nothing to commit since you have already committed all changes.

__18. Modify sample.txt.

nano sample.txt

__19. Change "First Version!" to "Second Version!"

__20. Press Ctrl+O to save the file and hit enter.

__21. Press Ctrl+X to exit to the terminal.

__22. Get Git status.

git status

Notice it says the file is modified.

__23. View changes.

git diff

Notice it shows old text in red and new text in green.

__24. Create another file.
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nano another.txt

__25. Add the following text.

Hello World!

__26. Press Ctrl+O to save the file and hit enter.

__27. Press Ctrl+X to exit to the terminal.

__28. Add all files.

git add .

__29. Get Git status.

git status

Notice it's showing 1 file as modified and 1 file as a newly added file.

__30. Commit changes.

git commit -m "Made 2 changes"

Notice when you pass -m switch, you can store a simple single line comment.

__31. Get Git status.

git status

Notice there's nothing to commit.

__32. Delete sample.txt

rm sample.txt

__33. Recover file.

git checkout sample.txt

__34. View sample.txt

cat sample.txt

Note: It restored latest version by default.
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__35. Delete file again.

rm sample.txt

__36. View all versions of a file.

git log

Notice it shows user, commit id, date time, and comment.

__37. Copy the commit id for the older version.

__38. View changes between current and the first version.

git diff <commit_id>

__39. Restore the older version.

git checkout <commit_id> sample.txt

__40. View file content.

cat sample.txt

Notice it's the first version.

__41. Close the terminal.

Part 4 - Review
In this chapter you installed and used Git.
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Lab 2 - Branching, Merging and Working with Remotes
One of the main themes of Git is the idea that we should isolate work on branches and 
use those branches to coordinate the work of multiple developers.  In this lab, we'll 
examine the use of branches and the act of merging.

In addition, Git works on the basis of distributed repositories.  We will explore the use of 
more than one repository, or Remote repositories.

At the end of this lab you will be able to:
1. Clone an existing repository

2. Create a branch

3. Merge a branch onto another branch.

Part 1 - Launch terminal
In this part you will launch the Linux terminal.

__1. Open the Terminal window.

Alternatively, you can press Ctrl+Alt+T to access the terminal.

Part 2 - Clone a Repository
For this lab, we will clone a pre-existing repository that has been provided to you.

__1. Switch to the "Documents" directory.

cd ~/Documents

__2. Switch to the "git" directory.

cd workspace/git

__3. Clone the repository:

git clone ~/Downloads/BranchMergeRemotes

This command creates a clone of the repository that is located in the file system.

In this case, we're cloning from a repository that is in the file system, but the exact same 
syntax can be used to clone from a repository on a remote server.  The only difference is 
the URL that's used to identify the original repository.

For instance, 'git clone https://github.com/angular/angular.js.git' would create a local 
copy of the repository that contains the popular 'AngularJS' framework, which is hosted 
on GitHub.

__4. In the Terminal window, type the following:
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cd BranchMergeRemotes

Part 3 - Create a Branch to Work on a Feature.
In many version control systems, particularly older systems, creating a branch is a 
difficult and often expensive operation.  In Git, however, creating a branch is a very 
lightweight operation, and in general, we want to create a branch for every feature that 
we work on.  When a feature reaches a stable state, we'll merge it back to the master 
branch.  In this way, the master branch only contains stable features, and any developer's 
work is isolated in its own feature branch.

__1. In the Terminal window, type the following, pressing return after each line:

git branch add-text
git checkout add-text

The lines above create a new branch called 'add-text' (which is a description of what we 
are about to do), and then switch to that branch.

Note: The two commands above could have been shortened to 'git checkout -b add-text'.

__2. Get Git status.

git status

Notice that the status message indicates that we are on the branch called 'add-text'.

That's all that's required to create a branch in Git!

__3. Enter the branch command:

git branch

The branch command on its own simply lists the branches that are defined in the 
repository.  Notice that the 'add-text' branch is both highlighted and has an asterisk next 
to its name, indicating that we are on that branch.

Part 4 - Work on the Branch
When we are on a branch, we can go ahead and make some changes and then stage and 
commit those changes.

__1. Open the index file.

nano index.html

Enter wasadmin or the password provided by your organization. Contact your instructor 
to get this information.
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__2. Replace the text 'Hello World.' with 'This is the text that we really want.'

__3. Press Ctrl+O to save the file and hit enter.

__4. Press Ctrl+X to exit to the terminal.

__5. Get Git status.

git status

Notice that git now tells us that the file 'index.html' has been updated, but not staged. 
We could use the 'git add' command to stage the changed file, but instead we are going to 
add an option to 'git commit' that will automatically stage all the changes.

__6. Type the following and then press return:

git commit -a -m "We now have the text we want."

__7. Open a file browser and navigate to the following folder.

~/Documents/workspace/git/BranchMergeRemotes/

__8. Right click on 'index.html' and select 'Open with Firefox Web Browser'.

Notice that the newer text is displayed.

__9. Close the web browser.

Part 5 - Merge Back to the Master Branch
We have committed changes to the feature branch that we created and called 'add-text'. 
Now let's say that we are happy with the feature and want to 'promote' it to the master 
branch.

The general procedure is as follows:

• Switch to the master branch
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• Merge the changes from the feature branch

• Optionally, delete the feature branch

__1. In the Terminal window, enter the following line:

git checkout master

__2. As above, open 'index.html' with a web browser, but notice that the text now reads 
'Hello World' again.

__3. Enter:

git merge add-text

__4. As above, open 'index.html' with a web browser, but notice that we have the 
updated text.

__5. We are done with this feature branch, so let's delete it.  

git branch -d add-text

There's no cost the keeping the branch around (remember that a branch is really just a 
reference to a particular committed snapshot), but it will generally prevent confusion if 
we keep the branch set clean by deleting branches that we are not actively using.

Part 6 - Push to Another Remote Repository
Let's say we wanted to create a new repository and store all our changes there.  In 
essence, this is what we would do when we first create a project.

As it stands, we have a local repository that contains a number of snapshots.  The basic 
procedure to create a remote repository will be:

• Create an empty remote repository

• Push our changes to that repository

For simplicity, we will use another repository in the local file system, but as with pulling 

11

EVALU
ATIO

N O
NLY



from a remote server, the only difference would be the url used for the repository.

__1. Create a new folder.

mkdir ~/Documents/workspace/AnotherRemote

__2. Make sure you are on the  BranchMergeRemotes.

cd ~/Documents/workspace/git/BranchMergeRemotes/

__3. In the Terminal window, type the following: 

git init --bare ~/Documents/workspace/AnotherRemote

The '--bare' option tells git that this repository will never have a working copy.  It will 
only be used as a git repository.  This is usually the case for 'remote' repositories that are 
used to share code.  Setting up the repository in this way allows us to "push" changes to it 
freely, even if our changes would make a working directory obsolete if it existed. 
Otherwise, we would need to go into that repository and "pull" changes into it.

If you have a look at the contents of \workspace\AnotherRemote, you will notice that 
it's different from the repositories we've already seen – there is no hidden '.git' folder. 
Rather, the contents that would have been in that folder are present in the 
AnotherRemote folder.

__4. In the Terminal window, type the following:

git remote add another-remote ~/Documents/workspace/AnotherRemote

This command tells git to add a reference to a remote repository at 
'/workspace/AnotherRemote', and to call it 'another-remote' locally.

__5. We can display the remote repository's status.

git remote show another-remote

__6. Finally, let's push our data to the remote. 

git push another-remote master
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__7. Display the remote repository's status.

git remote show another-remote

Notice that this time, the remote status indicates that the remote HEAD branch is 'master' 
and that we are tracking the remote master branch.

__8. Close the Terminal window and browsers.

Part 7 - Review
In this lab, we tried out a common workflow, the "feature branch" workflow.  We checked 
out a project stored in a remote repository.  We created a new branch, did some work on 
it, committed it, and then merged it back onto the master branch.  Finally, we created yet 
another remote repository and pushed our changes to it.

The thing to notice here is that using remote repositories is natural in git.  In fact, the 
"remote" repository is basically identical to the "local" repository – in this case, we used 
simple repositories in the file system, but they could equally have been accessed remotely 
using secure-shell or a repository manager.
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Lab 3 - GitFlow Workflow
Switch to the WA2606 Windows image.
 In this lab you will explore GitFlow feature, release, hotfix, and various other options.

Part 1 - Create a directory for storing GitFlow lab content.
In this part you will create a directory for storing GitFlow lab content.

__1. Open a command prompt window.

__2. Create your working directory.

md c:\workspace

__3. Change to  your working directory.

cd \workspace

__4. Create a directory for storing GitFlow lab content.

mkdir gitflow_test

__5. Switch to the created directory.

cd gitflow_test

Part 2 - Create and setup Remote and Local repositories.
In this part you will create a remote and a local repository.

__1. Initialize a new bare repository.

git init --bare remote_repo.git

__2. Verify the remote repository is created.

tree remote_repo.git

Notice it shows directory tree like this.
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__3. Clone the bare remote repository to a local working copy.

git clone remote_repo.git local_repo

Notice it's a blank repository that's why there is warning displayed on the screen.

__4. Verify local repository is created.

tree local_repo

Notice the directory structure is blank.

__5. Switch to the local working copy.

cd local_repo

__6. Configure user email for the repository.

git config user.email "bob@abc.com"

__7. Configure user name for the repository.

git config user.name "Bob"

Part 3 - Set up Gitflow in the local repository 
In this part you will set up Gitflow in the local Repository. You will create various 
branches required by the Gitflow.

__1. Initialize Gitflow in the local repository.

git flow init 

__2. Press the Enter key to use default values for all options. 

Notice the screen looks like this.
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__3. View the branch list.

git branch 

Notice it shows following branches.

"develop" is the active branch. In case if you want to activate a different branch, use 
following command:

git checkout <branch>

Part 4 - Create a Gitflow feature.
In this part you will create a Gitflow feature.

__1. Get feature list.

git flow feature list 

Notice currently there are no features.

__2. Create a new feature.

git flow feature start HOME_PAGE

__3. Get feature list again.

git flow feature list 

Notice it shows HOME_PAGE feature.

__4. Get branch list. 

git branch 
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Notice it shows following branches:

feature/HOME_PAGE feature has been added as a branch.

__5. Get git status.

git status

Notice feature/HOME_PAGE is the active branch and currently there are no files to 
commit.

Part 5 - Add content as part of the feature.
In this part you will create an HTML file as part of the feature created in the previous 
part.

__1. Start Notepad.

notepad index.html

__2. Click Yes to create the file.

__3. In the Notepad window enter following text.

<html>
 <body>
 </body>
</html>

__4. Save the file and close the Notepad window.

__5. Get git status.

git status

Notice "index.html" file isn't available in the repository.

__6. Add index.html to the local repository's feature/HOME_PAGE branch. 

git add index.html

__7. Get git status.

git status
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Notice index.html is added the repository but it's not committed yet.

__8. Commit changes.

git commit -m "Added index.html"

__9. View feature/HOME_PAGE branch contents.

git ls-tree -r --name-only feature/HOME_PAGE

Notice it shows index.html. If you don't use --name-only switch, it will show file size in 
addition to the file ID.

__10. Merge feature branch into the develop branch without deleting the feature branch.

git flow feature finish HOME_PAGE --no-ff -k

Notice feature/HOME_PAGE branch has been merged into the develop branch. The -k 
switch keeps the feature branch intact. Without this switch, it will delete the feature 
branch. Skip -k switch only when the feature has been fully developed and you want to 
merge the feature into the develop branch and then delete the feature branch. Also note 
that you are switched to the develop branch after performing the merge operation.

The –no-ff switch disables "fast forward".  

__11. View develop branch contents.

git ls-tree -r --name-only develop

__12. Switch back to the feature branch.

git checkout feature/HOME_PAGE

__13. Open index.html file in notepad.

notepad index.html

__14. Add <h1> tag to the body tag.

<h1>Hello world!</h1>

__15. Save the file and close the Notepad window.

__16. Get git status.

git status

Notice index.html file is updated on the file system, but it's not updated in the repository. 
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Also notice you are on the develop branch.

__17. Stage the changed index.html.

git add index.html

__18. Commit changes to the feature branch. 

git commit -m "Added h1 tag to the index.html"

__19. Merge feature branch into the develop branch without deleting the feature branch.

git flow feature finish HOME_PAGE --no-ff -k

__20. View remote repository content. 

git ls-remote

Notice currently no branches are in the remote repository. All the changes are in the 
local repository right now.

__21. Push changes from local repository into the remote repository.

git push --all

__22. View remote repository content. 

git ls-remote

Notice it displays develop and master branches.

Part 6 - Create a new Release
In this part you will create Gitflow release.

__1. Create a new release "REL_1.0" based on develop branch.

git flow release start 'REL_1.0' develop 

__2. Finish the release REL_1.0 and delete the release branch.

git flow release finish 'REL_1.0' -m "v1.0"

Notice release branch REL_1.0 has been merged into master. The release has been back-
merged into develop. You are switched to the develop branch.

__3. Get branch list. 
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git branch 

Notice it shows branch list like this.

__4. Push all changes to the remote repository.

git push --all

__5. Switch to the feature/HOME_PAGE branch.

git checkout feature/HOME_PAGE

__6. Open index.html file in Notepad.

notepad index.html

__7. Below h1 tag, add following text.

Welcome to ABC Inc.

Notice you haven't enclosed the above text in any tag. You are purposefully skipping a 
tag. You will treat as a bug and fix it later.

__8. Save the file and close the Notepad window.

__9. Stage the changed index.html.

git add index.html 

__10. Commit the changes.

git commit -m "Added company name to index.html"

__11. Merge feature changes into the develop branch without deleting the feature branch.

git flow feature finish HOME_PAGE --no-ff -k

__12. Start another release from develop branch.

git flow release start 'REL_2.0'
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__13. Finish the release REL_2.0 and delete the release branch.

git flow release finish 'REL_2.0' -m "v2.0"

Notice release REL_2.0 has been merged into 'master'. The release was tagged 
'REL_2.0'. Release REL_2.0 has been back-merged into 'develop'. Release branch 
REL_2.0 has been locally deleted and you are switched to 'develop' branch.

__14. View tag list. 

git tag 

Notice it shows REL_1.0 and REL_2.0.

If you want to checkout a certain release based on tag, you can execute following 
command:

git checkout tags/<tag_name>

Part 7 - Working with Hotfixes.
In this part you will create a Gitflow hotfix.

__1. Create a new hotfix.

git flow hotfix start 'REL_2.0.1'

Notice hotfix will end up creating a new release.

__2. Open index.html file in the Notepad.

notepad index.html

__3. Enclose Welcome to ABC Inc. within <b> HTML tag.

__4. Save the file and close the Notepad window.

__5. Stage the changed index.html file. 

git add index.html

__6. Commit changes. 

git commit -m "Enclosed company name in the bold HTML tag"

__7. Finish the hotfix.

git flow hotfix finish 'REL_2.0.1' -m "v2.0.1"
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Notice the hotfix branch has been merged into 'master'. The hotfix was tagged 
REL_2.0.1. The hotfix has been back-merged into 'develop' branch and has been locally 
deleted. If you want to keep the hotfix branch then use -k switch. You are switched to 
the 'develop' branch.

__8. Push all changes into the remote repository.

git push --all

Part 8 - Verify all releases are created
In this part you will verify all releases are created.

__1. Get tag list. 

git tag 

Notice REL_1.0, REL_2.0, and REL_2.0.1 are available.

__2. View current tag name. 

git describe

Notice the prefix is REL_2.0.1

__3. Checkout REL_1.0

git checkout tags/REL_1.0

__4. View current tag name. 

git describe

Notice the prefix is REL_1.0

__5. View index.html file contents.

type index.html

Notice there's no "Welcome to ABC Inc." text.

__6. Checkout REL_2.0.

git checkout tags/REL_2.0

__7. View current tag name.
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git describe

Notice the prefix is REL_2.0.

__8. View index.html file contents.

type index.html

Notice there's "Welcome to ABC Inc." text, but it's not enclosed in <b> tag.

__9. Checkout REL_2.0.1.

git checkout tags/REL_2.0.1

__10. View current tag name. 

git describe

Notice the prefix is REL_2.0.1.

__11. View index.html file contents.

type index.html

Notice there's "Welcome to ABC Inc." text enclosed in <b> tag.

__12. Close all.

Part 9 - Review
In this lab you explored Gitflow feature, release, hotfix, and various other options.
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	__5.  Switch to the local working copy.
	__6.  Configure user email for the repository.
	__7.  Configure user name for the repository.

	Part 3 -  Set up Gitflow in the local repository 
	__1.  Initialize Gitflow in the local repository.
	__2.  Press the Enter key to use default values for all options. 
	__3.  View the branch list.

	Part 4 -  Create a Gitflow feature.
	__1.  Get feature list.
	__2.  Create a new feature.
	__3.  Get feature list again.
	__4.  Get branch list. 
	__5.  Get git status.

	Part 5 -  Add content as part of the feature.
	__1.  Start Notepad.
	__2.  Click Yes to create the file.
	__3.  In the Notepad window enter following text.
	__4.  Save the file and close the Notepad window.
	__5.  Get git status.
	__6.  Add index.html to the local repository's feature/HOME_PAGE branch. 
	__7.  Get git status.
	__8.  Commit changes.
	__9.  View feature/HOME_PAGE branch contents.
	__10.  Merge feature branch into the develop branch without deleting the feature branch.
	__11.  View develop branch contents.
	__12.  Switch back to the feature branch.
	__13.  Open index.html file in notepad.
	__14.  Add <h1> tag to the body tag.
	__15.  Save the file and close the Notepad window.
	__16.  Get git status.
	__17.  Stage the changed index.html.
	__18.  Commit changes to the feature branch. 
	__19.  Merge feature branch into the develop branch without deleting the feature branch.
	__20.  View remote repository content. 
	__21.  Push changes from local repository into the remote repository.
	__22.  View remote repository content. 

	Part 6 -  Create a new Release
	__1.  Create a new release "REL_1.0" based on develop branch.
	__2.  Finish the release REL_1.0 and delete the release branch.
	__3.  Get branch list. 
	__4.  Push all changes to the remote repository.
	__5.  Switch to the feature/HOME_PAGE branch.
	__6.  Open index.html file in Notepad.
	__7.  Below h1 tag, add following text.
	__8.  Save the file and close the Notepad window.
	__9.  Stage the changed index.html.
	__10.  Commit the changes.
	__11.  Merge feature changes into the develop branch without deleting the feature branch.
	__12.  Start another release from develop branch.
	__13.  Finish the release REL_2.0 and delete the release branch.
	__14.  View tag list. 

	Part 7 -  Working with Hotfixes.
	In this part you will create a Gitflow hotfix.
	__1.  Create a new hotfix.
	__2.  Open index.html file in the Notepad.
	__3.  Enclose Welcome to ABC Inc. within <b> HTML tag.
	__4.  Save the file and close the Notepad window.
	__5.  Stage the changed index.html file. 
	__6.  Commit changes. 
	__7.  Finish the hotfix.
	__8.  Push all changes into the remote repository.

	Part 8 -  Verify all releases are created
	In this part you will verify all releases are created.
	__1.  Get tag list. 
	__2.  View current tag name. 
	__3.  Checkout REL_1.0
	__4.  View current tag name. 
	__5.  View index.html file contents.
	__6.  Checkout REL_2.0.
	__7.  View current tag name.
	__8.  View index.html file contents.
	__9.  Checkout REL_2.0.1.
	__10.  View current tag name. 
	__11.  View index.html file contents.
	__12.  Close all.

	Part 9 -  Review

	Lab 4 -  Configure Tools in Jenkins
	Part 1 -  Configure Jenkins
	__1.  To connect to Jenkins, open Firefox and enter the following URL .
	__2.  Enter wasadmin as user and password and click Log in.
	__3.  Don’t save the password if prompt or select Never Remember password for this site. 
	__4.  Click on the Manage Jenkins link.
	__5.  Click Global Tool Configuration.
	__6.  Scroll down and find the JDK section, Click Add JDK.
	__7.  Enter OracleJDK for JDK name.
	__8.  Don't  check the ‘Install automatically’ option. Uncheck if already checked.
	__9.  Open a browser and navigate to the java folder as below; if this folder is not present there find the right location that you will use in the next step:
	__10.  Go back to the web browser  and enter JAVA_HOME value as C:\Program Files (x86)\Java\jdk1.8.0_45 or the path where Java is installed.
	__11.  Verify your settings look as below:
	__12.  In the Maven section, click Add Maven.
	__13.  Enter Maven for Maven name.
	__14.  Uncheck the ‘Install automatically’ option.
	__15.  Enter C:\Software\apache-maven-3.3.9 for MAVEN_HOME. Make sure this folder is correct.
	__16.  Verify your settings look as below:
	__17.  Scroll to the Git section.
	__18.  Open a File explorer and search for C:\Program Files (x86)\Git\bin if doesn't work try searching on other folder like C:\Program File\Git\bin.
	__19.  Enter C:\Program Files (x86)\Git\bin\git.exe (or the path where GIT is installed) as Path to Git executable and press the Tab key.
	__20.  Scroll down and click Save.
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	Lab 5 -  Install Maven
	__1.  In the Windows Start Menu, right-click on the Computer link in the right-hand side of the Start panel, and then select Properties.
	__2.  Click on Advanced system settings.
	__3.  The system will display the System Properties dialog.  Select the Advanced tab and click Environment Variables.
	__4.  Verify the JAVA_HOME variable is set to C:\Progra~2\Java\jdk1.8.0_45 or similar path.
	__5.  Under the System Variables list, click the New button. 
	__6.  Enter M2_HOME as Variable name.
	__7.  As Variable value enter the following. (Make sure is a valid location)
	__8.  Click OK.
	__9.  In the 'System Variables' panel, locate the entry for 'Path' and double-click on it.
	__10.  Add the following to the end of the Variable Value field (including the semi-colon)
	__11.  Click OK on the variable editor dialog.
	__12.  Click OK on the Environment Variables dialog.
	__13.  Click OK in the System Properties dialog.
	__14.  Open a command prompt window (in the start menu, click All Programs --> Accessories --> DOS Prompt.
	__15.  In the command window, type:
	__16.  You should see output similar to:
	Part 2 -  Setup Maven in Eclipse
	__1.  Use Windows Explorer to navigate to C:\Software\eclipse, and then double-click on 'eclipse.exe' to start up the IDE.
	__2.  You may see a security dialog.  If so, un-check the box for “Always ask before opening this file” and then click Run.
	__3.  Change the workspace to C:\Workspace and click OK.
	__4.  Eclipse Kepler will start launching.
	__5.  Close the Welcome screen by clicking the 'X' next to Welcome on the tab.
	__6.  From the main menu, select Window → Preferences and then expand the tree node for Maven.
	__7.  Click on the tree node for Installations.
	__8.  On the right-hand side of the Preferences window, click on the Add... button.
	__9.  Navigate to C:\Software\apache-maven-3.3.9, ensure the node is selected, and click OK.
	__10.  In the Preferences dialog, verify Maven path and click OK.
	__11.  From the main menu, select Window → Preferences and then expand the tree node for Java → Installed JREs.
	__12.  Select the jdk in the list and click Edit.
	__13.  Enter -Dmaven.multiModuleProjectDirectory=$M2_HOME as Default VM arguments.
	__14.  Click Finish.
	__15.  Click OK.
	__16.  Close all open windows.
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	Lab 6 -  Create a Maven Project
	Part 1 -  Create a Project
	__1.  If necessary, start eclipse from C:\Software\eclipse\eclipse.exe using the same workspace.
	__2.  From the main menu, select File →  New →  Maven Project
	__3.  Click the check box for “Create a simple project (skip archetype selection)”, and then click Next.
	__4.  We need to provide the so-called “Maven Coordinates” that will identify the artifacts produced by this project, and optionally a name and description for the project.  Enter the following fields:
	__5.  Leave the Version and Packaging fields at their default values.  Leave the Parent Project fields empty.  
	__6.  The dialog should look like:
	__7.  Click Finish.  The system will create the project we've asked for, it may take a minute.

	Part 2 -  Explore the Project Structure
	__1.  In the Project Explorer, expand the node for the hello-world project.
	__2.  Double-click “pom.xml” to open it in the Project Object Model editor.  At the bottom of the editor, you should see a number of tab labels, with the Overview tab currently selected.
	__3.  Click on the pom.xml tab.  This view displays the raw XML formatted text of the Project Object Model.  At the present time, all we really have is the project coordinates.
	__4.  Click on the Effective POM tab.  This view shows the results of combining the projects POM with the “Super-POM” that is built into Maven.  If you scroll down through the effective POM, you'll see the defaults for the various plugin configurations that are built into Maven, as well as the required locations for things like resources, output directories, etc.
	__5.  Click on the Dependencies tab.  This view shows what libraries are referenced from this project.  Right now, the project doesn't reference any dependencies.  In the next step, we'll change that to add a dependency on the JUnit test framework.
	__6.  Click on the Add... button underneath Dependencies
	__7.  In the field marked Enter groupId,..., type 'junit'.  After a second or two, the Search Results box will populate with a link to the “junit” library.  Expand the node for junit.
	__8.  In the Version field, enter '4.11'.  (typically we would discover the current version through an internet search, or by querying Maven Central at http://search.maven.org)
	__9.  In the Scope drop-down box, select test. 
	__10.  When the dialog looks similar to the following, click OK.

	Part 3 -  Perform a “Priming” Build
	__1.  In the Project Explorer, right-click on pom.xml and then select Run As →  Maven Build.  
	__2.  The system will display the Edit Configuration dialog. Since this is the first time we've run a Maven build, we need to specify what goal we want to build.  In the Goals field, enter 'install', and then click Run
	__3.  The system may display a Save Resource dialog.  If so, click Yes to save any changes that we've made.

	Part 4 -  Add Some Code
	__1.  In the Project Explorer, right-click on src/main/java and select New →   Class.
	__2.  Enter a Package of “com.mycom.demo” and “HelloWorld” for the class name, and then click Finish.
	__3.  Edit the new class to include the main(...) method shown below.
	__4.  Save the file by clicking File →  Save or by typing Ctrl-S.  At this point, you could run the file by right-clicking and selecting Run As →  Java Application, but we don't really need to.
	__5.  Lets add required plugins in the project . Open pom.xml and click on the pom.xml tab.
	__6.  Add the following code as shown in bold after </dependencies> and before </project>:
	__7.  Save the file.
	__8.  In the Project Explorer, right-click on pom.xml and select Run As →  Maven build.  
	__9.  In the Project Explorer, right-click on the target node and then select Refresh.
	__10.  Expand the target node. You should now see the jar file that is generated by the project – this is the standard Maven output for a packaging type of 'jar'.
	__11.  From the menu, select File → Close All.  
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	Lab 7 -  Create a Web Application from an Archetype
	Part 1 -  Create the Project
	__1.  Make sure that Eclipse is running.  If not, start it by double-clicking on the “Eclipse.exe” entry in “C:\Software\Eclipse”.
	__2.  In the main menu, select File →  New →  Maven Project.
	__3.  The system will display the New Maven Project dialog.  Ensure that the box marked Create a simple project (skip archetype selection) is un-checked, and click Next.
	__4.  In the Filter field, enter 'webapp'.  
	__5.  The set of archetypes will be narrowed down to the ones that include the word 'webapp' in the archetype name.  Click on the row with Artifact Id as 'maven-archetype-webapp', and then click Next.
	__6.  Enter 'com.mycom.demo' as Group Id.
	__7.  In the Artifact Id field, enter 'mywebapp'
	__8.  Verify the Package is updated to com.mycom.demo.mywebapp or do it manually.
	__9.  Click Finish.
	__10.  After a few seconds, the Project Explorer will show the new project.  You will see an error in the project, let's fix it. Expand the project and open pom.xml.
	__11.  Click the pom.xml tab.
	__12.  Scroll down and remove all the code between the <plugins> tags in the build element. The build element should look like this:
	__13.  Enter the following code in bold inside the plugins tags.
	__14.  Save the file. The pom error will go away.
	__15.  Right click mywebapp project and select Maven > Update project. 
	__16.  Then click OK. 
	__17.  Expand the node for mywebapp, and then expand the src → main → webapp node.
	__18.  Notice that the folder structure includes the structure of a standard web application, including a WEB-INF directory.  If you want, expand the WEB-INF folder to see that there is a web.xml file in it.
	__19.  Right-click on the src →  main node in the Project Explorer and then select New →  Folder.  
	__20.  Enter 'java' as the folder name and then click Finish.
	__21.  In the Project Explorer, right-click on mywebapp, and then select Maven →  Update Project..., and then click OK.

	Part 2 -  Create a “Hello World” Servlet
	__1.  Expand the Project Explorer node for Java Resources, to expose the node for src/main/java.
	__2.  Right-click on the src/main/java node and then select New → Other.
	__3.  Expand Web from the list, select Servlet and then click Next.
	__4.  Enter the following in the Create Servlet dialog:
	__5.  Click Finish.
	__6.  Double-click on pom.xml in the Project Explorer to open it.
	__7.  Click on the Dependencies tab.
	__8.  Click on  the Add... button under Dependencies.
	__9.  Enter the following values:
	__10.  Select provided in the Scope drop-down.
	__11.  When the dialog appears as follows, click OK
	__12.  Save the file by pressing Ctrl-S or using File → Save from the main menu.
	__13.  Close the pom.xml file.
	__14.  You should see the resolution errors in HelloServlet.java disappear.  If not, update maven project as you did it before.
	__15.  Let's put some code into the HelloServlet.java servlet, so we can run it.  Edit the doGet(...) method so it looks like:
	__16.  Press Ctrl-Shift-O to organize the imports.
	__17.  Save the file.
	__18.  Right-click on pom.xml in the Project Explorer and select Run As → Maven install.  
	__19.  You should see the build end with Build Success.

	Part 3 -  Test the Web Application
	__1.  Open the file pom.xml
	__2.  Click on the tab marked pom.xml tab to select the XML source.
	__3.  Near the bottom of the file, inside the <build> element, add the following plugin, make sure you don't delete the other plugins:
	__4.  Save the file.
	__5.  Right-click on pom.xml in the Project Explorer, and then select Run As →  Maven Build....  (Note the '...'  We need to create a new run configuration).
	__6.  Under Goals enter tomcat6:run and then click Run.
	__7.  Watch the Console view.  You may need to give access to continue. You will probably see a flurry of file downloads as Maven gets the Tomcat plugin from Maven Central.  In the end, the console will say:
	__8.  Open a web browser and enter:
	__9.  Close the browser.
	__10.  In the Console view, click on the red 'stop' button to stop the Maven build that is running the Tomcat server.

	Part 4 -  Install and Run Apache Tomcat
	__1.  Select the Servers tab.
	__2.  Right-click in the Servers view and select New → Server
	__3.  The system will show the New Server dialog.  Expand the Apache node and select Tomcat v6.0 Server and then click Next.
	__4.  Click on the Browse... button and navigate to 'C:\Software\apache-tomcat-6.0.37', and then click OK.
	__5.  Click Finish.
	__6.  The server will be added.
	__7.  Right click the server and select Open.
	__8.  Expand Ports section.
	__9.  Change the HTTP/1.1 port to 8085
	__10.  Save and close the Server window.
	__11.  In the Project Explorer, find the node for HelloServlet.java
	__12.  Right-click on HelloServlet.java and then select Run As → Run on Server.
	__13.  When the Run On Server dialog is displayed, click Finish.
	__14.  Windows may show a security alert dialog.  If it does, click on Allow Access.
	__15.  The system will open a web browser inside Eclipse and show the selected page.
	__16.  In the Servers view, right-click on the Tomcat node and select Stop.
	__17.  From the menu, select File → Close All.
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	Lab 8 -  Add Web Site, Static Analysis, and Code Coverage 
	Part 1 -  Generate the Web Site
	__1.  Open a Command window by clicking the Start Menu →  All Programs →  Accessories →  Command Prompt.
	__2.  Change directory to the project's home directory.  In this case, the project is inside Eclipse's workspace, so we can enter (your typing is in bold.  Note that the prompt may appear different on your machine):
	__3.  From here, run the 'site' goal from the command line.
	__4.  Wait until you see BUILD SUCCESS
	__5.  Now if you navigate (using Windows Explorer) to the 'target' directory under the project directory (in this case 'C:\Workspace\hello-world\target', you will find a new directory called 'site'.  Navigate to the 'site' directory and double-click on index.html.  The system will open a web browser window and display the project's web site.
	__6.  While you're there, you can also explore the webpage.  Basically it lists all the information that's in the POM.
	__7.  Go back to Eclipse, and expand the src node in the Project Explorer under the hello-world project.  
	__8.  Right-click on src and then select New →  Folder.
	__9.  In the New Folder dialog, enter site as the folder name, and then click Finish.
	__10.  Using the same technique as above, create a folder under src/site called markdown
	__11.  Right-click on the src/site/markdown node and select New →  File.  
	__12.  Enter 'index.md' as the file name and click Finish.
	__13.  Enter the following text into the new file:
	__14.  Save the file.
	__15.  Back in the Command Prompt window, execute mvn site again.
	__16.  Go back to the browser and hit the refresh button.
	__17.  Note that the 'About' page now looks like this:

	Part 2 -  Add Static Analysis
	__1.  Using Windows Explorer, navigate to C:\LabFiles\AddStaticAnalysis.
	__2.  Right-click on the file 'ExpressionParser.java' and then select Copy.
	__3.  In the Project Explorer in Eclipse, right-click on the node for 'com.mycom.demo' underneath 'src/main/java', and then select Paste.
	__4.  Right-click on the node for 'src/test/java' in the Project Explorer, and then choose New →  Package. 
	__5.  Enter 'com.mycom.demo' as the package name, and then click Finish.
	__6.  Now go back to the Windows Explorer.  Right-click 'TestExpressionParser.java' and then choose Copy.
	__7.  In the Project Explorer, paste the file into the 'com.mycom.demo' package underneath 'src/test/java'.
	__8.  Run a “Maven install” on the hello-world project (Right-click on the 'hello-world' project, and then choose 'Run As →  Maven install').
	__9.  You should note that in addition to the build output we've seen so far, there is also a section that reports unit test results, you may need to scroll up in the Console.
	__10.  Now we can configure the PMD plugin.  Open the 'pom.xml' file for the 'hello-world' project.
	__11.  Click the pom.xml tab.
	__12.  Insert the following text underneath the </dependencies> tag:
	__13.  Save the pom.xml file.
	__14.  As in the previous part, run 'mvn site' from the Command Prompt and look at the generated site in your browser.
	__15.  Refresh the page.
	__16.  Click on Project Information  link at the left menu.
	__17.  You will now see a 'Project Reports' section in the generated site (last in the menu), click on it.
	__18.  You can browse at the PMD Report and CPD Report.  
	__19.  In this case, PMD has reported that we have an unused private field in 'ExpressionParser.java'.

	Part 3 -  Add Code Coverage Report
	__1.  Open the 'pom.xml' file for 'hello-world' if necessary.
	__2.  Add the following lines inside the plugins element in the reporting section (add the code that is bold).
	__3.  Just like before, save the 'pom.xml' file, run 'mvn site', and refresh the browser. 
	__4.  You should now find a 'Cobertura Test Coverage' report in the 'Project Reports' section. 
	__5.  Click on Cobertura Test Coverage, then click on the package link for 'com.mycom.demo'.  
	__6.  Click on the ExpressionParser class link.  The report will show a line-by-line report of the test coverage for ExpressionParser.
	__7.  Back in Eclipse, from the menu, select File → Close All. 
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	Lab 9 -  Create a Jenkins Job
	Part 1 -  Enable Jenkins' Maven Plugin
	__1.  Go to the Jenkins console:
	__2.  Login as wasadmin for user and password.
	__3.  Click on the Manage Jenkins link
	__4.  Ignore any message regarding an update.
	__5.  Click on Manage Plugins
	__6.  Click on the Available tab.
	__7.  In the filter box at the top-right of the window, enter 'Maven Integration'. Note: Don't hit Return!
	__8.  Entering the filter text will narrow down the available plugins a little.  Scroll down to find the 'Maven Integration' listing, and click on the check box next to it.
	__9.  Click Install Without Restart.
	__10.  Click Go back to the top page.

	Part 2 -  Create a Git Repository
	__1.  Open to the folder C:\LabFiles\Create A Jenkins Job\SimpleGreeting.
	__2.  Right click in the empty area and select Git Bash Here.  The Git command prompt will open.
	__3.  Enter the following command:
	__4.  Enter the following lines.  Press enter after each line:
	__5.  Enter the following lines to actually create the Git repository:
	__6.  Enter the following, to create a folder called repos under the C:\Software folder.  
	__7.  Enter the following to clone the current Git repository into a new remote repository.

	Part 3 -  Configure Git
	__1.  Go to Jenkins home.
	__2.  Click Manage Jenkins.
	__3.  Click Global Tool Configuration.
	__4.  Scroll to the Git section.
	__5.  Make sure git path is the right one, if not fix it and save. (Your path could be different)

	Part 4 -  Create the Jenkins Job
	__1.  Go to the Jenkins home.
	__2.  Click on the New Item link.
	__3.  Enter SimpleGreeting for the project name.
	__4.  Select Maven Project as the project type.
	__5.  Click OK, to add a new job.
	__6.  Scroll down to the Source Code Management section and then select Git.
	__7.  Under Repositories, enter C:\Software\repos\SimpleGreeting.git and press tab key.
	__8.  Click Save.
	__9.  You will see the Job screen. Click Workspace.
	__10.  Click Build Now. 
	__11.  After a few seconds the build will complete, the progress bar will stop. Click on Workspace.
	__12.  Find the Build History box, and click on the 'time' value for the most recent build. You should see that the build was successful.
	__13.  Click the Console Output from the left menu.
	__14.  At the end of the console you will also see the build success and successful build finish.

	Part 5 -  Enable Polling on the Repository
	__1.  In the Jenkins web application, navigate to the SimpleGreeting project.  You can probably find the project in the breadcrumb trail near the top of the window.  Alternately, go to the Jenkins home page and then click on the project.
	__2.  Click the Configure link.
	__3.  Scroll down to find the Build Triggers section.
	__4.  Click on the check box next to Poll SCM, and then enter '* * * * *' into the Schedule text box. [Make sure there is a space between each *] 
	__5.  Click Save.

	Part 6 -  Import the Project into Eclipse
	__1.  If eclipse was closed then start Eclipse by  running C:\Software\eclipse\eclipse.exe and use C:\Workspace as Workspace. 
	__2.  From the main menu, select File → Import...
	__3.  Select Git →  Projects from Git.
	__4.  Click Next.
	__5.  Select Clone URI and then click Next.
	__6.  Click on Local File... and then navigate to C:\Software\repos\SimpleGreeting.git
	__7.  Click OK.
	__8.  Back in the Import Projects dialog, click Next.
	__9.  Click Next to accept the default 'master' branch.
	__10.  In the Local Destination pane, leave the defaults and click Next.
	__11.  Select Import as a General Project and click Next.
	__12.  Click Finish.
	__13.  You should see the new project in the Project Explorer, expand it.
	__14.  Right-click on the SimpleGreeting project in the Project Explorer, and then select Configure →  Convert to Maven Project.
	__15.  After few seconds, you should now see the project represented as a Maven project in the Project Explorer.

	Part 7 -  Make Changes and Trigger a Build
	__1.  In the Project Explorer, expand the src/main/java tree node.
	__2.  Expand the com.simple package to reveal the Greeting.java file.
	__3.  Double-click on Greeting.java to open the file.
	__4.  Find the line that says 'return "GOOD";'.  Edit the line to read 'return "BAD";'
	__5.  Save the file by pressing Ctrl-S or selecting File →  Save.
	__6.  Right-click on SimpleGreeting in the Project Explorer and then select Team →  Commit...
	__7.  Enter a few words as a commit message, and then click Commit and Push.
	__8.  Click OK in the status dialog that pops up.
	__9.  Now, flip back to the web browser window that we had Jenkins running in.  If you happen to have closed it, open a new browser window and navigate to http://localhost:8080/SimpleGreeting.  After a few seconds, you should see a new build start up. You can launch a new build if it's taking too long.
	__10.  If you refresh the page, you should see that there is now a 'Test Result Trend' graph that shows we have a new test failure.

	Part 8 -  Fix the Unit Test Failure
	__1.  Back in eclipse, edit the file Greeting.java so that the class once again returns 'GOOD'.
	__2.  As above, save, commit and push the change.
	__3.  Watch the Jenkins web browser window.  After a minute or two you should see the build start automatically or you can click Build now, when the build is done then refresh the page.
	__4.  Close all.
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	Lab 10 -  A Multi-Module Project
	Part 1 -  Create a multi-module project
	__1.  Open the eclipse if it's not opened from C:\Software\eclipse\eclipse.exe and then choose the workspace location as C:\workspace. 
	__2.  From the menu, select Window → Open Perspective → Other.
	__3.  Select Java and click OK. 
	__4.  Create a general project, from the menu select, File → New → Project.
	__5.  Choose Project under General tab and click Next.
	__6.  Enter SimpleParentProject for project name.
	__7.  Click Finish.
	A general project is created. Now let's put the pom.xml for this project.
	__8.  Right click SimpleParentProject and select New → File.
	__9.  Enter pom.xml for file name and click Finish.
	__10.  File opens, at the bottom of the file select pom.xml.
	This file is already available. We will copy the content.
	__11.  Open C:\LabFiles\A Multi-Module Project\SimpleParentProject\SimpleParentProject-pom.xml file using a text editor.
	__12.  Copy the content and then paste it to the pom.xml file you created in the eclipse.
	Go through the pom.xml, 2 main element you should notice, <packaging> is set to pom since it consists of a pom.xml file but no artifact and <module> is set to SimpleProject. Meaning there will be a sub-module called SimpleProject exists to process.
	__13.  Save the file.
	__14.  Right-Click SimpleParentProject, and create a folder called SimpleProject to represent the parent project.
	__15.  Create a pom.xml file within SimpleProject folder.
	__16.  File opens, at the bottom of the file select pom.xml.
	__17.  Copy the entire content of C:\LabFiles\A Multi-Module Project\SimpleParentProject\SimpleProject-pom.txt file into pom.xml. Make sure you select the right file.
	Notes: 
	__18.  Save the file.
	__19.  Create a folder inside SimpleProject called simple-delay
	__20.  Copy the src folder from C:\LabFiles\A Multi-Module Project\SimpleParentProject\simple-delay into simple-delay folder in the eclipse.
	__21.  Also copy the C:\LabFiles\A Multi-Module Project\SimpleParentProject\simple-delay\pom.xml file to the simple-delay folder in the eclipse.
	__22.  Open the file and save the file to make sure you can edit in the file. 
	__23.  The project structure in the eclipse should be as shown below:
	__24.  Now lets work on simple-webapp module:
	__25.  Create a folder inside SimpleProject called simple-webapp
	__26.  Copy the src folder from C:\LabFiles\A Multi-Module Project\SimpleParentProject\simple-webapp into simple-webapp folder in the eclipse.
	__27.  Also copy the pom.xml file from C:\LabFiles\A Multi-Module Project\SimpleParentProject\simple-webapp folder and put it in simple-webapp folder in the eclipse.
	__28.  The project structure for simple-webapp in the eclipse should be as shown below:
	We have just completed the multi-module maven project. Lets run the package. 
	__29.  Open a command prompt and change the directory to C:\workspace\SimpleParentProject
	__30.  Run the following command:
	__31.  See the console output as below:
	__32.  Run the following command:
	__33.  You would see the a successful built in the console output.
	__34.  Scroll up a locate the following messages.
	__35.  Refresh the eclipse root directory, you would see the generated artifacts:
	You can try this build using jenkins by importing the project to SVN and then configure the jenkins to get the root pom.xml configured.
	__36.  From the menu, select File -> Close All. 

	Part 2 -  Review

	Lab 11 -  Create a Standard Set of Dependencies
	Part 1 -  Define dependency
	__1.  Make sure eclipse is open.
	__2.  Open a browser and locate the folder C:\LabFiles\Create a Standard Set of Dependencies\SimpleGreeting. 
	__3.  Copy the SimpleGreeting folder into C:\Workspace.
	__4.  Rename C:\Workspace\SimpleGreeting as C:\Workspace\SimpleGreeting2
	__5.  In eclipse, from the menu select File → Import. 
	__6.  Expand General, select Existing Projects into Workspace and click Next.
	__7.  Click browse button beside “Select root directory”.
	__8.  Select the project folder C:\Workspace\SimpleGreeting2.
	__9.  Click Finish.
	__10.  Expand the SimpleGreeting2 project and open Log4JGreeting.java file.
	You would see that Log4J standard library has been used in this class, that means when this file get compiled correct Log4J jar file is needed. We will now configure the pom to get the jar using dependency element.
	__11.  Open pom file from the SimpleGreeting2 project and select the pom.xml tab.
	__12.  Enter an empty line after the first dependency and add the log4J dependency (maven coordinates) shown below:
	This means, It will download the log4j version 1.2.14 library automatically. If the “version” tag is ignored, it will upgrade the library automatically when there is a newer version.
	__13.  Save the file.
	__14.  Open command prompt and change the folder to C:\Workspace\SimpleGreeting2
	__15.  Run the command:
	__16.  You will see a BUILD success message, scroll up and locate the messages where log4j library were downloaded during the command.
	Search log4j in Maven local repository.
	Search log4j in Maven central repository.
	Search log4j in Maven remote repository (if defined in pom.xml).
	__17.  Close the command prompt window used in this lab.
	__18.  In eclipse, from the menu, select File -> Close All. 

	Part 2 -  Review

	Lab 12 -  Write a Simple  Maven Plugin
	Part 1 -  Add Maven JavaDoc Plugin
	__1.  Make sure eclipse is open.
	__2.  Open a browser and locate the folder C:\LabFiles\Write a Simple Maven Plugin\SimpleGreetingPlugin
	__3.  Copy the SimpleGreetingPlugin folder into C:\Workspace.
	__4.  From the Eclipse menu, select File → Import... 
	__5.  Expand General select Existing Projects and click Next.
	__6.  Click browse button beside “Select root directory”.
	__7.  Select C:\Workspace\SimpleGreetingPlugin
	__8.  Click Finish.
	__9.  Expand the SimpleGreetingPlugin project and open Log4JGreeting.java and Greeting.java file. 
	Next we will configure plug-in to generate java doc.
	__10.  Open the pom.xml file from the SimpleGreetingPlugin project.
	__11.  Click the the pom.xml tab.
	__12.  Enter an empty line after the first <plugin> and add the java doc plug-in (maven coordinates) shown below:
	__13.  Save the file.

	Part 2 -  Build and Deploy
	__1.  Open command prompt.
	__2.  Change the folder to C:\workspace\SimpleGreetingPlugin
	__3.  Run the command:
	__4.  Look at the console output:
	Java doc JAR is generated.
	Look further down on the console output:
	__5.  Refresh your project in eclipse.
	__6.  Expand the project, you would see there are 2 JAR files and java doc folder also created:

	Part 3 -  Creating a project
	The first step is to create the project containing the custom maven plugin. This project is quite different from the regular java project because it is not a regular java artifact like JAR, WAR etc. Instead it is going to be a maven plugin project.
	__1.  In the command prompt, change the directory to C:\Workspace.
	__2.  Run the following command to create the maven plugin project.
	mvn archetype:generate -DgroupId=com.simple -DartifactId=SimpleDatePlugin -DarchetypeArtifactId=maven-archetype-mojo
	__3.  Hit Enter any time the prompt request for an input.
	The build should complete successfully.
	The above command creates a project with the name SimpleDatePlugin with the standard directory layout containing the source. 
	__4.  Using a File browser expand  C:\workspace\SimpleDatePlugin
	__5.  With notepad open the pom.xml file created under  C:\workspace\SimpleDatePlugin\
	If you look into the POM file, the package type is maven-plugin to indicate that this is a maven plugin project.
	__6.  Close the file.
	__7.  Change the directory on the command prompt window to "C:\workspace\SimpleDatePlugin".
	__8.  Run the following command to make it eclipse project which creates the Eclipse .project and .classpath files so that we can open it in the eclipse.
	__9.  You should get the success build:
	__10.  In eclipse, from the menu, select File → Import...  Expand General select Existing Projects and click Next.
	__11.  Click browse button beside “Select root directory”. Select C:\Workspace\SimpleDatePlugin and click Finish.
	__12.  In the Package Explorer view, the project should look like as below:

	Part 4 -  Creating a plugin
	In Maven, the plugin that achieves a specific task is called by the name MOJO (Maven Old Java Object similar to POJO). A MOJO defines the goal which is nothing but the custom action which is executed upon user’s request.
	We will create a custom plugin which will simply display the current date information.
	__1.  Right click SimpleDatePlugin and select New → class. 
	__2.  Enter DisplayCurrentDate for the class name.
	__3.  Enter com.simple for  package name.
	__4.  Enter org.apache.maven.plugin.AbstractMojo for Super class.
	__5.  Click Finish.
	__6.  Annotate the following java doc comments just above the class name:
	__7.  Enter the following code in the execute() method.
	__8.  Enter “Ctrl+Shift+O” to import packages.
	__9.  If  prompt for the package to choose, select java.util.Date.
	__10.  Save the file.
	__11.  The source code should be as shown below:

	Part 5 -  Compiling the project
	__1.  First make sure you are at the following directory on the command prompt:
	"C:\workspace\SimpleDatePlugin"
	__2.  Run the following command for compiling the maven plugin project which will compile the java classes.
	__3.  If you are not compiling the first time then you will get Nothing to compile message as shown below:

	Part 6 -  Packaging the project
	__1.  Enter the following command to package the plugin project which will package the classes into jar.
	The plugin class is packaged into JAR.

	Part 7 -  Installing the project
	__1.  To install the project into the local Maven repository, issue the following command.
	__2.  Go to your maven local repository directory to check the plugin install at local repository.
	There are several ways to run the maven plugin. 

	Part 8 -  Run plugin in stand-alone mode
	__1.  Enter the following command:

	Part 9 -  Add Maven Plugin to Build Process
	__1.  In the eclipse, open the pom file of the SimpleGreetingPlugin project.
	__2.  Click the pom.xml tab.
	__3.  Add the following plugin above </plugins> element which is inside the <build> element:
	__4.  Save the file.
	__5.  On the command prompt, change the directory to C:\workspace\SimpleGreetingPlugin
	__6.  Run the command.
	__7.  Your console should show the goal executed during compile phase as shown below:
	__8.  Close the command prompt window used in this lab.
	__9.  In eclipse, from the menu, select File →  Close All. 
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	Lab 13 -  Create an Archetype
	Part 1 -  Create your skeleton project
	__1.   Back in the Eclipse Package Explorer view, expand the SimpleParentProject →  SimpleProject
	__2.  Open pom.xml under SimpleProject folder, make sure to open the right file.
	__3.  Click the pom.xml tab.
	__4.  Replace the entire build section with the following code.
	__5.  Save and close the file.
	__6.  Using command prompt, change the directory to  C:\workspace\SimpleParentProject
	__7.  Run the following target to create the project.
	__8.  Back in the eclipse, refresh the project folder, you would see the archetype.

	Part 2 -   Install the archetype locally
	__1.  In the prompt, change the directory to C:\workspace\SimpleParentProject\target\generated-sources\archetype
	__2.  Run the following command to install.
	__3.  You should see the following console output as shown below:
	__4.  Now let's go to user's .m2 directory and look for  archetype-catalog.xml. Remember the users directory on Windows 7 should be under C:\Users\<username>\.m2\repository:
	__5.  Open the file using an editor like wordpad.
	__6.  Close the file.

	Part 3 -  Create New project from Newly created Archetype
	__1.  Create a folder called test-archetype in the C:\LabFiles folder.
	__2.  Change the directory to  test-archetype as shown below: 
	__3.  Run the following command:
	__4.  Select 1 to create the com.simple.multi:parent-archetype(parent-archetype) project.
	__5.  Enter:
	__6.   Enter:
	__7.  Enter: 
	__8.  Enter:
	__9.  Enter Y to complete the task.
	__10.  Change the directory as follows:
	__11.  Run this command to make it eclipse project.
	Build is successful, now we can import the project into eclipse and check the structure of the project to make sure it is from template. 
	__12.  In eclipse, from the menu, select File → Switch Workspace → Other.
	__13.  Enter  C:\workspace_temp and click OK.
	__14.  Wait until starts and then close the Welcome page.
	__15.  From the menu select, File → Import … then expand General and select Existing Project into workspace and click Next.
	__16.  Click the Browse  button next to Select root directory and navigate to C:\LabFiles\maven-archetype-test folder.
	__17.  Click Finish.
	__18.  You would see that the structure is similar in the other workspace location.
	__19.  Close the command prompt used in this lab and all open files.
	__20.  In eclipse, from the menu, select File → Switch Workspace → C:\workspace.
	__21.  Close all open files.
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	Lab 14 -  Create a Corporate Repository with Artifactory
	Part 1 -  Setup Maven Repository with JFrog Artifactory
	__1.   Using Windows Explorer, navigate to the folder C:\Software\artifactory-3.3.0\bin.
	__2.  In the Explorer window, locate the file artifactory.bat.  Right-click on the file and select Edit.  Windows will open the file in a text editor.
	__3.  In the editor, locate the line that begins with 'set JAVA_OPTIONS'.
	__4.  The line above sets the startup options for the Java Virtual Machine.  Note the entry '-Xmx2g'.  That entry sets the maximum memory to 2GB.  Change the entry to read '-Xmx1g'.  Leave the other entries on the JAVA_OPTIONS line as-is.
	__5.  Save and close the file.
	__6.  Using the Windows Start Menu, open a command prompt.
	__7.  Change the directory to:
	__8.  Run Artifactory from the command line, by typing.
	__9.  If Windows displays the Windows Security Alert dialog, click on Allow Access.
	__10.  Minimize but do not close the command prompt window.  Closing the window will shut down Artifactory.  If you do accidentally close the command prompt window, repeat steps 6-10 above.
	__11.   Navigate to the following URL using Mozilla browser: 
	__12.  Click the Login link.
	__13.  Use the default username/password as  admin/password

	Part 2 -  Creating a Test project
	__1.  Open another command prompt window.  Change the directory of your prompt to C:\workspace
	__2.  Run the following command to generate a new project using a maven archetype.
	__3.  Enter values  for the following questions:
	__4.  To test the project creation, change the directory to testproject
	__5.  Run:
	__6.  Copy settings.xml from  C:\LabFiles\Create a Corporate Repository put it into <User_Home>\.m2 folder. In Windows 7 or above use “C:\Users\<username>\.m2” Example:
	__7.  Using a file browser navigate to C:\Workspace\testproject.
	__8.  Open pom.xml using a file editor.
	__9.  Put <distributionManagement> element before <dependencies> element.
	__10.  Save and close the file.

	Part 3 -  Posting Snapshots to Nexus
	__1.  Make sure you are at C:\workspace\testproject directory in the prompt command window.
	__2.  To deploy the project to the Artifactory repository, enter:

	Part 4 -  Verify Artifactory repository
	__1.  Navigate to the following URL, using Mozilla browser:
	__2.  Click the Artifacts tab.
	__3.  Click on the Simple Browser item on the left navigation. 
	__4.  Click libs-snapshot-local and you should be able to see the test project you just created above.
	__5.  Close the command prompt window used in this lab but leave the Artifactory window open.
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	Lab 15 -  Deploy to the Corporate Repository with Artifactory
	Part 1 -  Create a Test Project with Dependency
	__1.  Open a command prompt window.
	__2.  Change the directory of your prompt to C:\workspace. 
	__3.  Run the following command to generate a new project using a maven archetype.
	__4.  Enter values  for the following questions:
	__5.  To test the project creation, change the directory to C:\workspace\testReleaseProject
	__6.  Run: 
	__7.  Open C:\workspace\testReleaseProject\pom.xml using a text editor.
	__8.  Add the following dependency code:
	__9.  Put <distributionManagement> element before <dependencies> element.
	__10.  Save and close the file.
	__11.  Verify dependencies by entering the following on the command prompt.

	Part 2 -  Deploying to the Release Repository
	__1.  Open pom.xml at C:\workspace\testReleaseProject directory.
	__2.  Remove  “-SNAPSHOT” next to version.
	__3.  Save and close the file.
	__4.  To deploy the project to the Artifactory release repository, enter:

	Part 3 -  Verify Artifactory repository
	__1.  Navigate to the URL http://localhost:8081/ using Mozilla browser.
	__2.  Click on the Artifacts item on the on the top navigation bar, and then click on Simple Browser in the left-hand navigation bar.  
	__3.  From the list click libs-release-local.  You should see the testReleaseProject entry.
	__4.  You should be able to navigate down through to the '1.0' folder to see your artifacts deployed as shown below.
	__5.  Close the command prompt window used in this lab and close the Artifactory window.
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	Lab 16 -  Add Development Metrics
	Part 1 -  Install the Jenkins Cobertura Plugin 
	__1.  Make sure Jenkins is started. Since we configured as windows service it will be started every time you start the machine.
	__2.  Go to the Jenkins console at: 
	__3.  Login as wasadmin for user/password if required.
	__4.  To install a new plugin, click Manage Jenkins on the left. Disregard the warning if you see one.
	__5.  Click on the Manage Plugins entry.
	__6.  Click on Available tab. 
	__7.  Type cobertura in the Filter and then check the check-box next to Cobertura.
	__8.  Click on the Download now and Install after restart button at the bottom of the screen.
	__9.  Select the check-box for Restart Jenkins....
	__10.  At this point, Jenkins should restart itself. Wait some minutes if it doesn't return to the main screen do it manually.
	__11.  If ask to login use wasadmin for user and password.

	Part 2 -  Enable Jenkins Reporting
	__1.  Click on the job we created for SimpleGreeting.
	__2.  On the left-hand menu, click Configure.
	__3.  Scroll down to the Post-Build Actions section.
	__4.  Click on the Add post-build action button and then select Publish Cobertura Coverage Report.
	__5.  Enter the following for the Cobertura XML Report Pattern.
	__6.  Scroll up to find the Build section.
	__7.  In the Goals and Options text box, enter the following:
	__8.  Click Save.
	__9.  Open Eclipse.  
	__10.  In the Project Explorer, navigate to the SimpleGreeting project.
	__11.  Double-click on the file pom.xml to open it.
	__12.  On the lower edge of the editor panel, click on pom.xml to select the XML view of the file.
	__13.  Add the text that is shown in bold text below (the 'plugin' and 'reporting' sections).
	__14.  Save and close the file.
	__15.  Right-click on SimpleGreeting in the Project Explorer and then select Team → Commit...
	__16.  Enter a few words as a commit message, and click Commit and Push. Then click OK.
	__17.  Back in the Jenkins page, you should see a build launched within a minute or two.  If you don't see an automatic build, click the Build Now to kick off a manual build.
	__18.  Once the build is completed, move the mouse over the build number window and make check that it is successful:
	__19.  Click on the Build small triangle and select Console Output.
	__20.  Scroll down and verify Cobertura report  has been generated.
	__21.  Go back to the project.
	__22.  Now let's click on the Coverage Report.
	__23.  Close all.
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	Lab 17 -  Create a Pipeline
	Part 1 -  Create a Simple Pipeline
	__1.  To connect to Jenkins, open Firefox and enter the following URL:
	__2.  Login as wasadmin for user/password.
	__3.  Click on the New Item link.
	__4.  Enter 'SimpleGreetingPipeline' as the new item name, and select 'Pipeline' as the item type.
	__5.  When the input looks as above, click on OK to create the new item.
	__6.  Scroll down to the Pipeline section and enter the following in the Script text window.
	__7.  Click on Save to save the changes and return to the project page.
	__8.  Click on Build Now to start up a pipeline instance.
	__9.  After a few moments, you should see the Stage View appear, and successive stages will appear as the build proceeds, until all three stages are completed.

	Part 2 -  Pipeline Definition in a 'Jenkinsfile'
	__1.  Open the Eclipse editor.  If this lab is completed in the normal sequence, you should have the 'SimpleGreeting' project already in Eclipse's workspace.  If not, check out the project from version control (consult your instructor for directions if necessary).
	__2.  In the Project Explorer, right-click on the root node of the SimpleGreeting project, and then select New →  File.  
	__3.  Enter 'Jenkinsfile' as the file name.
	__4.  Click Finish to create the new file.
	__5.  Enter the following text into the new file (Note: this is the same script that we used above, so you could copy/paste it from the Jenkins Web UI if you want to avoid some typing):
	__6.  Save the Jenkinsfile by selecting File →  Save from the main menu, or by hitting Ctrl-S.
	__7.  In the Project Explorer, right-click on the SimpleGreeting node, and then select Team →  Commit...
	__8.  Eclipse will display the Commit Changes dialog.  Click the check box next to Jenkinsfile (to include that file in the commit) and enter a commit message.
	__9.  Click Commit and Push, and then click OK to dismiss the status dialog.
	__10.  In the Jenkins user interface, navigate to the root page, and then click on New Item.
	__11.  Enter 'SimpleGreetingPipelineFromGit' as the name of the new item, and select Pipeline as the item type.
	__12.  Click OK to create the new item.
	__13.  Scroll down to the Build Triggers section.  
	__14.  Click on Poll SCM and enter '* * * * *' as the polling schedule.  This entry will cause Jenkins to poll once per minute.
	__15.  Scroll down to the Pipeline section, and change the Definition entry to 'Pipeline Script from SCM'
	__16.  Enter the following:
	__17.  The Pipeline section should look similar to:
	__18.  Click Save to save the new configuration.
	__19.  Click Build Now to launch the pipeline.
	__20.  You should see the pipeline execute, similar to the previous section.

	Part 3 -  Try out a Failing Build
	__1.  In Eclipse, go to the Project Explorer and locate the file 'Greeting.java'.  It will be under src/main/java in the package 'com.simple'.  
	__2.  Open 'Greeting.java'.
	__3.  Locate the line that reads 'return "GOOD";'.  Change it to read 'return "BAD";'
	__4.  Save the file.
	__5.  In the Project Explorer, right-click on Greeting.java and then select Team →  Commit... (This is a shortcut for committing a single file).
	__6.  Enter an appropriate commit message and then click Commit and Push.
	__7.  Click OK in the results box, to close it.
	__8.  Switch back to Jenkins.
	__9.  In a minute or so, you should see a build launched automatically.  Jenkins has picked up the change in the 'Git' repository and initiated a build. If nothing happens then click Build Now.
	__10.  Go back to Eclipse and open the 'Jenkinsfile' if necessary.
	__11.  Alter the 'bat "mvn..." line to read as follows:
	__12.  Save the 'Jenkinsfile'.  Commit and push the changes using the same technique as above.
	__13.  After a minute or so, you should see a new Pipeline instance launched.  If nothing happens then click Build Now.

	Part 4 -  Add a Manual Approval Step
	__1.  Go to 'Eclipse' and open the 'Jenkinsfile' if necessary.
	__2.  Add the following to the end of the file after the closing }:
	__3.  Save and commit 'Jenkinsfile' as previously.
	__4.  Move your mouse over the 'User Acceptance Test' step, select Yes and click Proceed. 
	__5.  Run the pipeline again (click Build Now), but this time, select No on the 'User Acceptance Test' and click Proceed, you'll see that the pipeline exits early and doesn't run the 'deploy' stage.
	__6.  Close all.
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