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Lab 1 - Java Logging
Since logging messages is usually an important part of an application this ability is 
available in the standard Java language.  Although this ability was standardized in JDK 
1.4 almost all environments now run on this Java version or above.

An important aspect of this logging is the concept that you might need different levels of 
messages.  Some messages generated when errors occur are critical and will likely need 
to be shown in every environment.  Other messages that log debugging information are 
not as critical for production and often should be disabled to improve performance and 
keep the production messages focused on more important information.

In this lab you will see some of the features of this Java logging framework.  Although 
the code we will log from will be fairly simple, you will see how to generate messages of 
different logging levels and control some important settings.

Part 1 - Create Code with Basic Logging
The first step is to establish some code that will be logging some kind of messages.  You 
will see how this code behaves without any configuration settings so you can understand 
how those settings will change the logging behavior in the future.

__1. From C:\Software\eclipse execute eclipse.exe

__2. You will be prompted to select a workspace.  Change the the Workspace to 
C:\workspace
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__3. Click the OK button.

__4. You will see the Welcome screen. Close it.

__5. From the Eclipse menus, select File → New → Project. 

__6. In the New Project window, select Java → Java Project and click Next.

__7. Enter LogProject as Project Name.

__8. Click Finish. Click yes if asked to switch perspective.

__9. In the new project create a new Java class with the following attributes.  You can do 
this by selecting File → New → Class.

Name: HelloWorldLogger

Package: com.webage.logging
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__10. In the code for the 'HelloWorldLogger' class, add the declaration of a 'Logger' field 
that will be initialized based on the name of the class.

public class HelloWorldLogger {
Logger logger = Logger.getLogger(this.getClass().getName());

__11. Organize imports (CTRL-SHIFT-O) and select java.util.logging.Logger if 
prompted.

__12. In the class create the following empty method shown in bold.

Logger logger = Logger.getLogger(this.getClass().getName());

public void sayHello(String name) {
}

__13. Within the code of this new method simply add a line to log the name passed as a 
parameter as an INFO message.

public void sayHello(String name) {
logger.info("Hello " + name);

}

Note: Avoiding the use of System.out.println and instead using a logging framework is a 
best practice since the logging can be controlled as we will see later.

__14. Save the 'HelloWorldLogger' class and make sure there are no errors.

__15. In the project create a new Java class with the following attributes:

Name: Driver

Package: com.webage.main

main method: checked

__16. Modify the code of the 'main' method to match the following.  You will get errors 
but they will be fixed next.

public static void main(String[] args) {
new Driver().runProgram();

}
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__17. Add the following empty method to the 'Driver' class.  You can also use the Eclipse 
'Quick fixes' to add the code.

private void runProgram() {
}

__18. In the code for the new 'runProgram' method add the declaration of a 'Logger' 
variable that will be initialized based on the name of the class.

private void runProgram() {
Logger logger = Logger.getLogger(this.getClass().getName());

Note: It is important that we add this code not in the 'main' method because that is a 
static method and can't use 'this.getClass()' which is generally the easiest way to obtain a 
logger so we can control the logging by class or package as we will see later.

__19. Add the following line to declare a new 'HelloWorldLogger' object.

Logger logger = Logger.getLogger(this.getClass().getName());
HelloWorldLogger hw = new HelloWorldLogger();

__20. Organize imports (CTRL-SHIFT-O).

__21. Save the class and there shouldn't be any errors although there will be some 
warnings.

__22. Add the following code that will use the logger and HelloWorldLogger objects. 
Notice that we are logging from this class also to see the effects of configuration 
properties later.

...
HelloWorldLogger hw = new HelloWorldLogger();
String name = "Bob";
logger.info("About to say hello to " + name);
hw.sayHello(name);

__23. Save the class and make sure there are no errors.

__24. Select Run → Run As → Java Application from the Eclipse menus.
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__25. Check that in the Console view you get the following output.  Notice that the 
messages of both classes appear.

Part 2 - Control Logging with Properties File
It is common to want to change the behavior of the logging framework in different 
environments.  This is done by supplying logging configuration with a properties file. 
This section will show you how to establish that and begin supplying custom 
configuration properties which will be expanded later.

__1. Right click on the 'LogProject' project and select 'New → File'.

__2. Fill in a name of 'myLogging.properties', make sure the 'LogProject' is selected and 
click the Finish button.

__3. Leave the file open but don't add anything to it yet.

__4. Select Run → Run Configurations from the menu.

__5. Select the Driver run configuration on the left if it is not already.
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__6. Switch to the 'Arguments' tab and in the 'VM arguments' section add the following 
argument:

-Djava.util.logging.config.file=myLogging.properties

Note: Notice the setting for the 'Working directory' at the bottom is the root of the 
LogProject.  This is why we placed the properties file at the root of the project.  We 
could have placed the properties file in the 'src' directory and modified the parameter 
above but since it is often desired to have different settings in different environments it 
is good not to have this in the 'src' directory where it would be included with the code if 
exported.

__7. Press the Apply and then the Run buttons to run the modified configuration.

__8. You should see in the Console view that nothing appears.  This actually proves that 
your properties are being picked up and we will fix this in a second.
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__9. Switch back to the 'myLogging.properties' file.

__10. Add the following to the file.

handlers = java.util.logging.ConsoleHandler

Note: The ConsoleHandler is enabled by default in the standard logging properties but if 
we supply our own we must enable the 'handlers' that we want to be in effect.

__11. Save the 'myLogging.properties' file.

__12. Select 'Run → Run History → Driver' to run the program again.  This time you 
should get the same output as before you had custom properties.

__13. Switch back to the 'myLogging.properties' file and add the following to the file.

.level = WARNING

Note: This will set the default level of messages for all loggers.
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__14. Save the 'myLogging.properties' file and select 'Run → Run History → Driver' 
to run the program again.  This time you will again get empty output.

__15. Switch back to the 'myLogging.properties' file and add the following to the file.

com.webage.logging.level = ALL

Note: This will override the default level of messages for the logger for the 
'com.webage.logging' package.

__16. Save the 'myLogging.properties' file and select 'Run → Run History → Driver' 
to run the program again.  This time you will get messages from the 'HelloWorldLogger' 
class but not the 'Driver' class.

Part 3 - Advanced Logging Code
There are some advanced logging methods that are available that will be explored in this 
section.  You will also see more levels of logging than appear in the INFO levels shown 
previously.

__1. Open the 'HelloWorldLogger' class if it is not already and add the following field to 
the class:

Logger logger = Logger.getLogger(this.getClass().getName());
String[] badNames = {"Bob", "Susan", "Yolanda"};

__2. Add the code to throw an Exception to the signature of the 'sayHello' method as 
shown below.

public void sayHello(String name) throws Exception {
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__3. Add the following code that will check if the parameter is one of the "bad names" 
and throw an Exception.

public void sayHello(String name) throws Exception {
    for (String checkName : badNames) {
        if (checkName.equalsIgnoreCase(name)) {
            throw new Exception("Don't want to say hello to " + name);
        }
    }
    logger.info("Hello " + name);
}

__4. Save the file.  You will get errors in the other class that we will fix.  There should be 
no errors in the 'HelloWorldLogger' class.

__5. Switch back to the 'Driver' class and add the following try/catch block around the 
call to the 'sayHello' method.

try {
hw.sayHello(name);

} catch (Exception e) {
logger.severe("Exception: " + e.getMessage());

}

__6. Save the file.  There should not be any errors in any classes.

__7. Select 'Run → Run History → Driver' to run the program again.  This time you 
will get the 'Severe' message from the Driver class but not any messages from the 
'sayHello' method since the exception was thrown before the INFO message would have 
been printed out.
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__8. Return to the 'sayHello' method of the 'HelloWorldLogger' class and change the if 
clause as follows the following code.

if (checkName.equalsIgnoreCase(name)) {
    Exception error = new Exception("Don't want to say hello to " 
        + name);
    logger.throwing(this.getClass().getName(), 
        Thread.currentThread().getStackTrace()[1].getMethodName(),
        error);
    throw error;
}

Note: This code will create a log record of throwing the error without relying on the 
calling code to also log something.

__9. Save the file.  There should not be any errors in any classes.

__10. Select 'Run → Run History → Driver' to run the program again.  Even though 
you added the 'throwing' method from the logger you don't see it!  Right now the Console 
logging is filtering out this message so we need to fix that.

__11. Switch back to the 'myLogging.properties' file and add the following line as 
shown below.

java.util.logging.ConsoleHandler.level = FINER
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__12. Save the 'myLogging.properties' file and select 'Run → Run History → Driver' 
to run the program again.  This time you will get a 'FINER' message about the exception 
that was thrown.

Note: By default the ConsoleHandler is set to a level of INFO so it was filtering out the 
log record before.

Notice you also get detailed Exception info like the stack trace even though the program 
caught the Exception and it would not normally be printed to the log output.

__13. Back in the 'HelloWorldLogger.sayHello' method add the following code.

public void sayHello(String name) throws Exception {
    logger.entering(this.getClass().getName(), 
        Thread.currentThread().getStackTrace()[1].getMethodName(), 
        name);
    for (String checkName : badNames) {

Note: This will log a FINER message about entering the method.  This version logs a 
single parameter from the enclosing method but there are other methods with no 
parameters from the enclosing method or an array of Objects as parameters of the 
method.
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__14. Save the file and select 'Run → Run History → Driver' to run the program again. 
This time you will see a log message 'FINER: ENTRY Bob' which indicates the method 
was called with a name of 'Bob' for the parameter.

__15. Add the following code to the 'sayHello' method.

logger.entering(this.getClass().getName(), 
    Thread.currentThread().getStackTrace()[1].getMethodName(), 
    name);
if (logger.isLoggable(Level.FINEST)) {
    logger.info("FINEST Logging available");
    for (int i = 0; i < 10; i++) {
        logger.finest("FINEST Message #" + i);
    }
}
for (String checkName : badNames) {

__16. Organize imports.

__17. Save the file and select 'Run → Run History → Driver' to run the program again. 
You will see the INFO message about FINEST logging being available but notice you do 
not see any FINEST messages.

Copyright 2016 Web Age Solutions Inc. 14

EVALU
ATIO

N O
NLY



Note: You don't see FINEST messages because the 'isLoggable' method just checks if 
the logger would log the message, not if the handlers involved are going to let it through 
their threshold to the output.  The threshold level of the ConsoleHandler is set to FINER, 
above the lowest level FINEST.

__18. Switch back to the 'myLogging.properties' file and modify the following line.

com.webage.logging.level = FINE

__19. Save the 'myLogging.properties' file and select 'Run → Run History → Driver' 
to run the program again.  This time you are back to only seeing the SEVERE message. 
Notice that the INFO message about the 'FINEST' level being available is also not 
logged.  You also lose the ENTRY and THROW messages since they were FINER level.

Part 4 - Log to a Log File
Another common requirement is to log to a log file.  So far we have just used the 
ConsoleHandler to quickly see the effect of logging code.  Now we will add logging to a 
file also.

__1. Switch back to the 'myLogging.properties' file and modify the following line in 
bold.  Also remove the line for the ConsoleHandler since we will not use it.

handlers = java.util.logging.FileHandler
java.util.logging.ConsoleHandler.level = FINER

Copyright 2016 Web Age Solutions Inc. 15

EVALU
ATIO

N O
NLY



__2. Add the following two new properties.  Note that the 'formatter' property should be 
entered with the value on the same line.  It wraps to the next line shown below.

java.util.logging.FileHandler.pattern = java%u.%g.log
java.util.logging.FileHandler.formatter =

java.util.logging.SimpleFormatter

__3. Save the 'myLogging.properties' file.

__4. From the Eclipse menus select Window → Preferences.

__5. From the preference groups on the left select General → Workspace.

__6. Check the box to 'Refresh using native hooks or polling' and click the OK button.

__7. Select 'Run → Run History → Driver' to run the program again.  
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__8. Check that you see a 'java0.0.log' file show up in the project as shown below.

__9. Open the file and you should see the same SEVERE message we saw before.  Take 
note of the timestamp of the message.

__10. Close the file.

__11. Select 'Run → Run History → Driver' to run the program again.  

__12. Wait several seconds for Eclipse to refresh the projects contents and then open the 
log file again.  Notice that you see just the one SEVERE message but it should have a 
different timestamp.

__13. Close the log file.
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__14. Switch back to the 'myLogging.properties' file and add the following line.  

java.util.logging.FileHandler.append = true

__15. Save the 'myLogging.properties' file and select 'Run → Run History → Driver' 
to run the program again.

__16. Wait several seconds for Eclipse to refresh the projects contents and then open the 
log file again.  This time you should see that the previous message was kept and the 
logging appended new messages on the end.

__17. Close the log file.

__18. Switch back to the 'myLogging.properties' file and add the following two lines. 
Also modify the 'com.webage.logging.level' property to 'ALL'.

java.util.logging.FileHandler.append = true
java.util.logging.FileHandler.limit = 1000
java.util.logging.FileHandler.count = 2
.level = WARNING
com.webage.logging.level = ALL
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__19. Save the 'myLogging.properties' file and select 'Run → Run History → Driver' 
to run the program again.

__20. Wait for the Eclipse project to refresh which should show two log files as shown 
below.

__21. Open the 'java0.1.log' file first.  Notice that this log file should have the earlier 
SEVERE messages in addition to the start of the loop of FINEST messages.

Note: The default level of the file handler is ALL so it should show all log messages 
unlike the default of the Console handler which filtered some out unless we set it 
different.
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__22. Open the 'java0.0.log' file.  This log file should have the rest of the FINEST 
messages along with the other expected messages at the end.

Note: The log files have been set to 'rotate' once the main file gets to a certain size.  Our 
limit of 1000 bytes was obviously very small and chosen just to show the behavior.

__23. Close both log files.

__24. Delete both log files from the project.
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Part 5 - Use Memory Buffer Logging
Often it is not desired to write a long log file with all of the messages.  Since we are often 
most interested in errors these are often the main messages we want to make it to a log 
file.  At the same time we may not want to completely exclude the non-error messages 
that immediately precede the error as they may also be useful.  

So what will be useful is some logging that collects all messages, buffers a certain 
amount of the messages, and then dumps them when certain conditions occur.  The 
MemoryHandler class of Java logging can accomplish this.  It will keep a certain number 
of log records in memory, rotating out the oldest ones, and direct the log records to 
another log handler that could write them to a file.  You will configure this in this section.

__1. Modify the 'handlers' property in the 'myLogging.properties' file as shown below 
and add the new property to configure the 'target' of the Memory Handler.

handlers = java.util.logging.MemoryHandler
java.util.logging.MemoryHandler.target = java.util.logging.FileHandler

__2. Save the 'myLogging.properties' file and select 'Run → Run History → Driver' to 
run the program again.

__3. Wait for the Eclipse project to refresh which should show two log files as shown 
below.
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__4. Open the 'java0.1.log' file first.  Notice this still starts the complete loop of the 
FINEST messages.

__5. Open the 'java0.0.log' file.  This log file should have the other expected messages at 
the end.

Right now we are not really filtering out many messages so we will set some additional 
properties to do this.

__6. Close both log files.

__7. Delete both log files from the project.
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__8. Add the following line to the 'myLogging.properties' file.  This will limit the 
number of messages in the memory buffer.

java.util.logging.MemoryHandler.target = java.util.logging.FileHandler
java.util.logging.MemoryHandler.size = 5

__9. Save the 'myLogging.properties' file and select 'Run → Run History → Driver' to 
run the program again.

__10. Wait for the Eclipse project to refresh which should show only one log file.

__11. Open the 'java0.0.log' file.  This log file should have only the last few FINEST 
messages from the loop and the other messages expected at the end.  This proves that it is 
logging messages of all levels but only the last 5 messages so the log file of a larger 
program might be easier to find errors but still provide some context for messages 
immediately before the errors.

__12. Close all open files.
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Part 6 - Review
In this lab you saw a lot of different features of Java logging.  Even though our code was 
simple we created various levels of log messages, modified logging behavior with a 
properties file, filtered out different kinds of messages without changing logging code, 
and used some of the abilities to rotate log files and use memory buffering.

You can apply these same techniques to your own applications.  The benefit of this code 
is that it is using the Java standards so you can be certain it is available in all JDK 
environments and does not depend on some other logging library to be included in your 
applications.
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Lab 2 - Accessing Database
What this exercise is about
In this lab exercise, you will use the JDBC API to connect to a database and perform some 
simple reads/inserts.
You will create code that will work with “UserStore” code. We will create class(es) to 
store/retrieve users via a database.
Your code will use the Derby database, which is already installed on your computer.

What you will be able to do
✔ Use the SQL API to perform database queries
✔ Use prepared statements to simplify queries

Part 1 - Import a Java Application Project
__1. If not already running, open Eclipse from C:\Software\eclipse by executing eclipse.exe and 
selecting the workspace C:\workspace

__2. From the menu, select File -> Import.

__3. Expand and select General → Existing Projects into Workspace and click the Next 
button.
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__4. Select the radio button next to the Select archive file option and use the matching Browse 
button to find and open the file 'C:\LabFiles\AdvJava-Starter.zip'.

__5. Select the project listed in the file if it is not already as shown below.

__6. Press the Finish button to import the project.

__7. Expand AdvJava from the Project Explorer view.

You can ignore any errors at the moment. These are pertaining to other labs and we will fix them 
at that point.

Part 2 - Add the Derby JDBC Drivers to the Eclipse Project
__1. Right click on the ‘AdvJava’ project in the Project Explorer and select Properties.

__2. In the properties window, select the Java Build Path node and the Libraries tab:

__3. Click the Add External JARs… button.

__4. Navigate to the directory  C:\Software\db-derby-10.12.1.1-bin\lib  and select 
derbyclient.jar then press Open. 

__5.  Press OK in the Properties dialog.
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Part 3 - Start Derby Server
It is possible to use the database we are using, Derby, in both client/server mode and "embedded" 
mode.  The client/server mode allows multiple concurrent connections which is more like other 
database types so this is the mode we will use.

__1. Open a Windows File Explorer window and navigate to the C:\Software\db-derby-
10.12.1.1-bin\bin directory.

__2. Double click the startNetworkServer.bat batch file to run the Derby network server.

Note: You must run this command to start the Derby server every time you run a program that 
will access the database otherwise it will not be able to connect.  This is especially important if 
you have restarted the machine between days of class.

__3. Minimize but do not close the command window that appears.  Closing the window will 
stop the Derby server.

Part 4 - Complete DBUtils Implementation
A class has been provided for you that will simplify some of the steps of working with the 
database.  This class implementation is incomplete so that you can add some code to see 
common code that would be required when writing JDBC code with a database.

__1. Back in Eclipse, open the DBUtils class under the com.webagesolutions.users package.

__2. Find the 'readUser' method.  This method will be used to initialize a Java object based on 
the data from the database.

__3. Find the comment 'Set user properties from ResultSet' and add the following code in bold 
after the comment.  Be careful with the spelling of the column names.

if ("Y".equals(isAdmin)) {
u=new Administrator();

} else {
u=new RegularUser();

}
// Set user properties from ResultSet
u.setEmail(rs.getString("EMAIL"));
u.setFirstName(rs.getString("FIRSTNAME"));
u.setLastName(rs.getString("LASTNAME"));
u.setUserName(rs.getString("USERNAME"));
u.setPassword(rs.getString("PASSWORD"));
return u;
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__4. Find the 'writeUser' method.  This method will be used to initialize a Java object based on 
the data from the database.

__5. Examine the Strings used for the update and insert statements.  These have been provided 
for you to avoid typos but are critical in writing JDBC code.  In particular notice that a lot of the 
Strings used in concatenation end with an extra space to make sure that two keywords are not 
concatenated without a space between them.  This is a common error in JDBC statements.

__6. Find the comment 'Set query parameters from User properties' and add the following 
code in bold after the comment.  Be careful to match the correct number for the query parameter 
to the correct property of the user object.

PreparedStatement insert=conn.prepareStatement(insQuery);

/* Try the update. */
// Set query parameters from User properties
update.setString(1, aUser.getFirstName());
update.setString(2, aUser.getLastName());
update.setString(3, aUser.getEmail());
update.setString(4, aUser.getPassword());
update.setString(5, aUser.isAdministrator()?"Y":"N");
update.setString(6, aUser.getUserName());
int count=update.executeUpdate();

Note: Notice that the logic of the method tries an update statement and checks if any rows were 
updated.  If not, an insert statement is run.  The code you added only worked with the update 
statement although the code for the insert statement is similar.  

__7. Replace the getConnection method as follows:

public static Connection getConnection() throws ClassNotFoundException, 
SQLException {

Connection conn = DriverManager.getConnection
  ("jdbc:derby://localhost:1527/C:/LabFiles/Users;create=true");
return conn;

}

__8. Save the class.  There should be no errors or warnings in this class.
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Part 5 - Implement the UserStore Service
We will modify a class called “DBUserStore” that wraps a database connection object and uses it 
to supply the UserStore services that client programs will use to manipulate the stored users.

__1. Expand AdvJava → com.webagesolutions.users and examine the interface UserStore. 
This interface defines a generic service that stores instances of User objects and allows a client to 
retrieve the User objects based on the user’s email address.  You will be creating a JDBC-based 
database storage implementation of this interface.

__2. In the AdvJava → com.webagesolutions.jdbc package, open the DBUserStore.java file. 
Notice this file already indicates that it implements the UserStore interface but doesn't have the 
complete code for this.

__3. Declare a private instance variable called connection to store a reference to an instance of 
java.sql.Connection.

public class DBUserStore implements UserStore {
private Connection connection;

__4. Organize imports (CTRL+SHIFT+O). Select java.sql.Connection.

__5. Add the following code in bold to the constructor:

public DBUserStore(Connection conn) {
connection=conn;

}

__6. Save the class.  There should be no errors or warnings.
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__7. In the DBUserStore class, implement the “putUser” method to validate the user’s 
password (similar to the previous lab) and then delegate the write operation to DBUtils if the 
validation passes.  The code should look something like this when done:

public void putUser(User user, String verifyPassword)
throws UserAddException {

if (verifyPassword.equals(aUser.getPassword())) {
try {

DBUtils.writeUser(connection, aUser);
} catch (SQLException e) {

e.printStackTrace();
throw new UserAddException(e);

}
} else {

throw new UserAddException("Password incorrect.");
}

}

__8. Organize imports. 

__9. Save the class.  There should be no errors or warnings in this file.

__10. From the com.webagesolutions.users package, right click on CreateUsersTable.java and 
select Run as → Java Application.  

__11. You should see the success message.  

__12. Now you will populate the table. From the com.webagesolutions.users package, right 
click on PopulateUsersTable.java and select Run as →  Java Application.  

__13. You should see the success message.  

__14. Open the classes above if you want to look at the code that performed these tasks.
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Part 6 - Browse the data
After the PopulateUsersTable class has been run, you should be able to see the newly created 
records in the database by using a tool to connect directly to the database.

__1. Open a Windows command prompt.  You can do this by selecting Start → Run, entering 
'cmd' without the quotes and clicking the OK button.

__2. Use the 'cd' command to switch to the C:\Software\db-derby-10.12.1.1-bin\bin directory.

__3. Issue the command  'ij.bat'  to launch the Derby command line tool.

__4. Issue the following command to connect to the database:

connect 'jdbc:derby://localhost:1527/C:/LabFiles/Users';

__5. Issue the following command to list the content of the Users table:

select * from Users;

__6. Issue the following command to exit:

exit;

__7. Close the command window.  Make sure to leave the command window running Derby 
open.
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Part 7 - Implementing code
__1. In the com.webagesolutions.users package, there is a class called TestDBUserStore that 
will list all the users that are contained in the database, then search for one particular user by 
email.  If you run that class now, you get a NullPointerException, because we haven’t 
implemented the listAllUsers method yet. Run the TestDBUserStore class to see the exception.

The listAllUsers method needs to return an Iterable object, which is an object that implements 
the iterator() method.  This is a good use for an inner class; the iterator() method will return an 
instance of an inner class that has access to an open ResultSet and iterates through that ResultSet.

__2. In the DBUserStore class, enter the following code for the listAllUsers() method:

public Iterable<User> listAllUsers() {
return new Iterable<User>() {

public Iterator<User> iterator() {
return new ListAllIterator();

}
};

}

__3. Perform Organize imports. Select java.util.Iterator. You will still have an error that will be 
fixed next.

The above method returns an instance of an anonymous inner class that implements the 
Iterable<User> interface (i.e. the generic Iterable<T> interface specialized to iterate over 
instances of the User interface).  As you can verify in the JavaDocs, the Iterable<T> interface 
consists of one method, iterator<T>().  This anonymous inner class returns a new instance of an 
inner class ‘ListAllIterator’ that will implement the iterator.  The next step is to define that inner 
class.

Unfortunately, when we do all the exception handling and implement the required methods, we 
have a large amount of typing for the inner class.  
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__4. Enter the following class definition inside the DBUserStore class, so as to create an inner 
class called ‘ListIterator’.  Instances of this inner class will have access to the instance variables 
of the outer class, namely the open connection object:

Remember to put this code inside the DBUserStore class definition but outside any other 
methods, otherwise it will not have access to the fields of the DBUserStore class it requires.

Note: The file 'C:\LabFiles\ListAllIterator.txt' has been provided if you want to copy code from 
there.  It is ONLY the code for the inner class though and is NOT the full solution to the 
DBUserStore class.  You will still need to be careful to paste the code within the DBUserStore 
class.

private class ListAllIterator implements Iterator<User> {
Iterator<User> iterator = null;

ListAllIterator() {
try (Statement st = 

connection.createStatement();
ResultSet rs = 

st.executeQuery("SELECT * FROM USERS")) {
List<User> users = new 

ArrayList<>();
while (rs.next()) {

users.add(DBUtils.readUser(rs));
}
iterator = users.iterator();

} catch (SQLException e) {
e.printStackTrace();
throw new RuntimeException(e);

}
}

@Override
public boolean hasNext() {

return iterator.hasNext();
}

@Override
public User next() {

return iterator.next();
}

@Override
public void remove() {

throw new UnsupportedOperationException();
}

}

Note: The constructor uses a Java  'try-with-resources' statement to make sure the Statement 
and ResultSet are closed at the end of the constructor.  This avoids leaving database resources 
open and instead constructs an Iterator from the query results to use when iterating.
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__5. Perform Organize imports. Select java.util.List, java.sql.ResultSet and 
java.sql.Statement. 

__6. Save the class.  You should have no errors at this point.

Now all that’s left is to implement the getUser(…) method that looks up a user by email address. 
To do this, we need to run a query against the database and create a User object with the resulting 
row, if any.  

__7. Enter the following for the getUser(…) method in DBUserStore:

public User getUser(String email) {
String query = "SELECT * from USERS where EMAIL=?";
try (PreparedStatement st = connection.prepareStatement(query)) {

st.setString(1, email);
ResultSet rs = st.executeQuery();
if (rs.next()) {

return DBUtils.readUser(rs);
} else {

return null;
}

} catch (SQLException e) {
e.printStackTrace();
return null;

}
}

Note: This code uses a Java 'try-with-resources' statement that will automatically close the 
PreparedStatement object at the end just as if it were explicitly done with a 'finally' block.

__8. Organize imports.  Select java.sql.PreparedStatement when prompted.

__9. Save the class.  You should have no errors.

Note that in the above method, the "try-with-resources" statement will automatically close the 
Prepared Statement.  The result set is automatically closed when the Statement object is closed.

__10. Run the TestDBUserStore class again.  You should now see the final lookup returns the 
record for Jim Waldo in addition to all the records being listed.
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__11. Close all open files.

Part 8 - Summary
We have created an implementation of the UserStore service that uses a database as the storage 
mechanism.  You should note that the utility classes in the Lab Starter files do not need to know 
which type of implementation they are dealing with; as an example, see the 
UserStoreUtils.populate() method.  Similarly, your business logic and user interface logic classes 
would not need to be rewritten to adopt the database-backed storage.

We used an inner class to implement the Iterable and Iterator interfaces to load business model 
objects from the database.  This also has the advantage of making it possible for code which uses 
the 'listAllUsers' method to iterate over the collection of users with Java 5’s ‘for-each’ syntax.

Finally, we demonstrated the use of a PreparedStatement object to insert variables into a SQL 
query without having to manipulate the query string using concatenation or formatting.  Apart 
from being easier to read, this approach gives better resistance to SQL script execution attacks in 
form-filling applications.  It also prevents us having to deal with any formatting concerns, for 
instance if we were using date values as parameters.
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Lab 3 - Using JPA
Java Persistence, or JPA, is a Java standard that makes it possible to easily store data from Java 
objects in databases.  This standard was developed when various third party frameworks, like 
Hibernate, first introduced the concept in to the Java community.  Although many times JPA is 
mentioned in relation to Java Enterprise, or Java EE because Java EE servers are required to 
support it, JPA can be used from standalone Java SE applications also.

In this lab you will use JPA from a regular Java project.  Since a Java SE environment is not 
required to support JPA, you will be using a JPA "Provider", Hibernate to actually implement the 
persistence.  Notice though that your code does not refer to Hibernate APIs and the only mention 
of Hibernate will be in some JPA configuration settings.

Part 1 - Lab Setup
To simplify the code that you need to create you will be given a "starter project" to import with 
much of the code.  This will let you focus on the JPA configuration and code.

__1. Open Eclipse if it is not already running.

__2. Select File → Import from the Eclipse menus.

__3. Expand the General group and select Existing Projects into Workspace and press the 
Next button.

__4. Select the radio button next to the Select archive file option and use the matching Browse 
button to find and open the file 'C:\LabFiles\JPAUserStore-Starter.zip'.

__5. Select the project listed in the file if it is not already as shown below.

__6. Press the Finish button to import the project.

__7. In the Problems view check that you have no errors for this project.  You may have errors 
for other projects.
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Part 2 - Modify Project Properties
Right now the project you imported is just a Java project.  There are tools available with Eclipse 
which can add support for JPA.  You will enable these JPA tools for the project because among 
other things they will automatically add the JPA configuration file, called persistence.xml, to the 
project.  You will also add a JAR file for the database we will use and a JPA implementation to 
the project build path.

__1. In Eclipse select Window → Preferences.

__2. In the list of preferences select Java → Build Path → User Libraries.

__3. Press the New button.

__4. Fill in a library name of Hibernate and click the OK button.

__5. With the newly create Hibernate library still selected press the Add External JARs... 
button.

__6. Browse to the 'C:\LabFiles\Hibernate-lib' directory, select all the JAR files by holding the 
CTRL key while selecting them (or use CTRL-A), then click the Open button to complete the 
selection.

__7. Make sure that all 11 of the JAR files are listed as part of the library.
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__8. Click the OK button to close the Eclipse preferences.

__9. Right click on the JPAUserStore project and select Properties.

__10. Select Project Facets from the left side of the project properties.

__11. Check the box for the 'Utility Module' and 'JPA' facets and make sure the version of the 
JPA facet is 2.1.  Do not close the properties yet though.

Note: If this were a Java EE web or EJB module project you would not need the 'Utility 
Module' facet in order to enable the JPA facet.

Also note that the version of JPA when deployed to a Java EE server may be controlled by the 
server.  A Java EE 5 server would supply JPA 1.0, a Java EE 6 server would supply JPA 2.0, and 
a Java EE 7 server would supply JPA 2.1.  In this case we are free to choose JPA 2.1 because 
this is a stand-alone Java project.  The version of Hibernate you are using uses JPA 2.1.

__12. Click on the title of the 'JPA' facet so it is selected and then click the link for 'Further 
configuration required' below.

38

EVALU
ATIO

N O
NLY



__13. On the configuration of the JPA facet, under the setting for 'JPA Implementation' select 
the 'User Library' Type and check the Hibernate library check box; click the OK button when 
your screen looks like shown below.

Note: Notice that the library will be included with the application.  This would be important 
since the project is not running in an environment where JPA support is already available.

Notice you can also use the Eclipse database tools to connect to a database and link the JPA 
project to that database configuration for validation but we won't do this.

__14. Still on the Project Facets page click the Apply button in the lower right.  This will 
configure the build path of the project for Hibernate which is important.

__15. Once you have configured the JPA facet and are back in the project properties select the 
Java Build Path project properties on the left.

__16. Select the Libraries tab of the Java build path properties and click the button for 'Add 
External JARs' on the right.

__17. Navigate to the 'c:\Software\db-derby-10.7.1.1-bin\lib' directory and select the 
'derbyclient.jar' file and press the Open button to complete the selection.
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__18. Check that the Derby JAR file and Hibernate library is listed as shown and then click the 
OK button to close the project properties. 

Note: We are adding the Derby database drivers this way instead of using a build dependency 
tool like Maven because we won't be writing any code that depends on Derby.  A JPA project 
will need to connect to a database but usually this is done by providing a database connection 
that is configured as part of the environment, like a Java EE server DataSource, so that is not 
done in the project.  We are adding this JAR because we will be configuring a database 
connection with JPA configuration but this is simply because this project will not be deployed to 
a server so this configuration is more for the particular way we are testing this project and not a 
permanent application configuration.

__19. In the Problems view check that you have only warnings and no errors for the 
JPAUserStore project.  You will have more warnings than before because of some of the 
classpath settings but this will be fine.

Part 3 - Configure JPA Entity
In JPA the objects that are saved to the database are "Entities".  The first step in using JPA in the 
project will be to convert Java classes already in the project into Entities.  This is done by adding 
a few simple annotations to the class.

__1. In the Package Explorer view, expand the following folders:

JPAUserStore -> src -> com.webage.users

__2. Open the RegularUser.java file in the com.webage.users package by double clicking it. 
Notice that this is just a regular Java class with a few properties and get/set methods.
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__3. Add the following code annotations in bold to the existing class.  You will have some errors 
until fixed in the next step.

import java.io.PrintStream;

@Entity
public class RegularUser {

private String firstName;
private String lastName;
@Id
private String email;
private String userName;

Note: Only the @Entity and @Id annotations are required for JPA.  There are also other JPA 
annotations that can control the table and column mapping but we will not use these.

__4. Select Source → Organize Imports from the menus.  When prompted select 
javax.persistence.Entity and click the Finish button.

Note: Notice that even though Hibernate has similar code that could be added we are adding 
standard JPA annotations.

__5. Save the class.  You will have another error that will be fixed in a future step.

__6. Open the Administrator.java file in the com.webage.users package by double clicking it.

__7. Add the following code annotation in bold to the existing class.  You will have some errors 
until fixed in the next step.

package com.webage.users;

@Entity
public class Administrator extends RegularUser {

Note: This class does not need to have an @Id property since that is already in the RegularUser 
class which this class extends.
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__8. Select Source → Organize Imports from the menus.  When prompted select 
javax.persistence.Entity and click the Finish button.

__9. Save the class.  You will have another error that will be fixed in a future step.

__10. In the Package Explorer view, expand the following folders:

JPAUserStore -> src -> META-INF

__11. Right click the persistence.xml file and select JPA Tools → Synchronize Class List from 
near the bottom.

__12. Check that the error in the RegularUser and Administrator classes are gone.  Now these 
classes are explicitly listed in the persistence.xml file so JPA will know to manage them.

Part 4 - Complete JPA UserStore Implementation
Although JPA will perform all of the complicated database work for us we still need to have 
some code in the application that works with JPA to indicate which Java objects should be saved 
to the database and perform queries to find existing data.  This is done through the JPA "Entity 
Manager".  Currently there is a skeletal implementation of a 'UserStore' interface that provides 
some of these kinds of methods.  This section will use JPA to implement some of those methods.

__1. In the Package Explorer view, expand the following folders:

JPAUserStore -> src -> com.webage.jpa

__2. Open the JPAUserStore.java file in the com.webage.jpa package by double clicking it. 
Notice that right now it is just an empty implementation of the 'UserStore' interface.
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__3. Add the following new field to the class shown in bold.  This will add the JPA 
EntityManager used to persist data.  You will still have errors in the code.

public class JPAUserStore implements UserStore {
// Put JPA EntityManagerFactory here
private EntityManagerFactory emFactory = Persistence

.createEntityManagerFactory("JPAUserStore");
@Override
public void putUser(RegularUser aUser, String verifyPassword)

Note: In a Java SE environment the EntityManagerFactory is the class that is the entry point 
into JPA.  The parameter of 'JPAUserStore' will match the name of the "Persistence Unit" in the 
persistence.xml file.

__4. Locate the 'putUser' method and replace the implementation with the bold code below. 
This uses a method already supplied by the EntityManager to persist data.

@Override
public void putUser(RegularUser aUser, String verifyPassword)
          throws UserAddException {
     // implement saving user with JPA
     EntityManager em = emFactory.createEntityManager();
     try {
          em.getTransaction().begin();
          em.persist(aUser);
          em.getTransaction().commit();
     } catch (Exception e) {
          throw new UserAddException(e);
     } finally {
          em.close();
     }
}

Note: In a Java SE environment you need to manually create and close the EntityManager as 
well as begin and commit the transaction.  In a Java EE environment these lines of code are 
sometimes omitted if using JPA from an EJB.

__5. Select Source → Organize Imports from the menus.  

__6. Save the class and make sure there are no errors.
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Part 5 - Modify JPA Configuration
The last step to do is to modify the JPA configuration so it contains the various JPA and database 
configurations.

__1. Open the 'src/META-INF/persistence.xml' file.  

__2. Make sure the editor shows the file in the General tab and switch to this tab if needed.

__3. For the value of the "Persistence provider" fill in a value of 
'org.hibernate.jpa.HibernatePersistenceProvider' without the quotes as shown below.

__4. Switch to the Connection tab in the editor.

__5. In the drop-down for 'Transaction type' select the option for 'Resource Local'.

Note: This option indicates the JPA transaction will be linked only to the database transaction 
and not part of a distributed transaction that might be present in a server environment.  This is 
the appropriate option since we will be running in a stand-alone Java application.
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__6. Further down on the page fill in the following properties in the 'JDBC connection 
properties' setting.

Driver: org.apache.derby.jdbc.ClientDriver

URL: jdbc:derby://localhost:1527/JPAUserStore;create=true

User: jpa

Password: jpa

Note: These properties can be set like this because we are using JPA 2.0+ which has 
standardized the name of JPA properties for these settings.  If you were using JPA 1.0 the 
properties for a database connection would be set using property names specific to the JPA 
provider.

Notice also that if you link the JPA project to a database connection from Eclipse's database 
tools you can populate JPA properties with those settings.

__7. Switch to the Properties tab in the editor.  Notice the existing standardized connection 
properties are already present.

__8. Click the Add button to add a row for a new property.
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__9. Fill in the following 'Name' and 'Value' for the new property by typing it in after clicking the 
appropriate column.

Name: hibernate.hbm2ddl.auto

Value: create

__10. Click the Add button a second time to add another new property.

__11. Fill in the following 'Name' and 'Value' for the new property by typing it in after clicking 
the appropriate column.

Name: hibernate.show_sql

Value: true

__12. Save the file and be sure there are no errors from incorrect syntax.

Note: The 'hibernate.hbm2ddl.auto' property indicates to Hibernate if it should automatically 
modify the database schema to reflect the structure of the JPA classes.  The value of 'create' we 
are using will recreate the database tables every time.  This will be good for testing although 
you might often use a different value or not use this property in other environments like 
production.

The 'hibernate.show_sql' property will enable logging of the SQL statements issued by 
Hibernate which can help in debugging issues in complex queries, etc.
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Part 6 - Test JPA Functionality
All of the JPA code and configuration is complete.  In this section you will add to a test class that 
will test the JPA functionality.

__1. Make sure you have the Derby server running, if not then navigate to the 
'C:\Software\db-derby-10.7.1.1-bin\bin' folder and run the 'startNetworkServer.bat' 
command by double clicking it.  Make sure to run the correct command as there are several 
similarly named batch files. Wait for the Derby server to report that it is waiting for connections.

__2. Do not close the command prompt window that is running Derby.

__3. Back in Eclipse, in the Package Explorer view, expand the following folders:

JPAUserStore -> src -> com.webage.jpa

__4. Open the JPAUsersTest.java file in the com.webage.jpa package by double clicking it. 
Notice that right now it is just a Java class with an empty 'main' method.

__5. Add the following new code to the empty 'main' method.  This code simply creates a new 
instance of the JPA 'UserStore' implementation and then passes it to the UserStoreUtils.populate 
method which will create some new users to add to the persistent storage.

public static void main(String[] args) {
// Add code to test JPAUserStore
UserStore store = new JPAUserStore();
UserStoreUtils.populate(store);
System.out.println("Users table was populated succesfully.");

}

__6. Select Source → Organize Imports from the menus.  

__7. Save the file and make sure there are no errors although you will get warnings.
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__8. Right click the JPAUsersTest class and select 'Run As → Java Application'

__9. Look in the Console view and you should see the message that the Users table was 
populated successfully.  You will also see the Hibernate SQL statements (although without the 
actual values) after several other messages from Hibernate about setting up the database 
connection and exporting the database schema to the database.

Part 7 - Implement Other UserStore Methods
Right now the code only persists users to the database.  Although no Exception is thrown we 
don't actually select data from the database to verify that the database contains the data.  In this 
section you will implement methods that query the data.

__1. Return to the JPAUserStore.java file in the com.webage.jpa package and open it if you 
had closed it.
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__2. Provide the following implementation to the 'listAllUsers' method.  Be careful with the 
'createQuery' method syntax as it has several parameters that wrap to several lines below.  You 
will have errors until the next step.

@Override
public Iterable<RegularUser> listAllUsers() {

// implement query with JPA
EntityManager em = emFactory.createEntityManager();
em.getTransaction().begin();
TypedQuery<RegularUser> q = em.createQuery(

"select u from RegularUser u", 
RegularUser.class);

List<RegularUser> results = q.getResultList();
em.getTransaction().commit();
em.close();
return results;

}

Note: This method uses the JPA Query API and the "JPA QL" query syntax to form a query that 
will select all users from the database.  Even though the query looks like SQL it is written in the 
syntax of the JPA entities in the application so does not have to match the database table 
structure like SQL would.  This is especially useful when the table and column names in the 
database do not match the class and property names in Java.

__3. Select Source → Organize Imports from the menus.  When prompted select  java.util.List 
and click the Finish button.

49

EVALU
ATIO

N O
NLY



__4. Next, provide the following implementation to the 'getUser' method.  

@Override
public RegularUser getUser(String email) {

// implement query with JPA
EntityManager em = emFactory.createEntityManager();
em.getTransaction().begin();
RegularUser result = em.find(RegularUser.class, email);
em.getTransaction().commit();
em.close();
return result;

}

__5. Save the file and make sure there are no errors.

__6. Return to the JPAUsersTest.java file in the com.webage.jpa package and open it if you 
had closed it.

__7. Add the following new code to the 'main' method after the current code that populates the 
database.  This code uses the method to get all users and then prints those users from a loop.  It 
also searches for a specific user that had been created in the  UserStoreUtils.populate method.

public static void main(String[] args) {
// Add code to test JPAUserStore
UserStore store = new JPAUserStore();
UserStoreUtils.populate(store);
System.out.println("Users table was populated succesfully.");

System.out.println("Listing all users");
Iterable<RegularUser> users = store.listAllUsers();
for (RegularUser regularUser : users) {

regularUser.printTo(System.out);
}
System.out.println("Searching for: wyantg@sun.com");
RegularUser match = store.getUser("wyantg@sun.com");
if (match != null) {

match.printTo(System.out);
}

}

__8. Select Source → Organize Imports from the menus.

__9. Save the file and make sure there are no errors.
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__10. From the menus select 'Run → Run History → JPAUsersTest'.

__11. This time in the Console view you should see in addition to the output from last time, a list 
of all the users that were selected from the database and then the details of the individual user 
that was searched for by email.

__12. Close all open files.

__13. In a Windows Explorer window, navigate to the 'C:\Software\db-derby-10.7.1.1-bin\bin' 
folder.

__14. Run the 'stopNetworkServer.bat' command by double clicking it.  Make sure to run the 
correct command as there are several similarly named batch files. This will close the Derby 
server.

Part 8 - Review
JPA programming can greatly simplify working with data in databases as the JPA implementation 
does the work of storing the data.  The JPA API really hides a lot of the complexity for us.

Besides the use of the JPA EntityManager API most of the work is configuring the various JPA 
properties in the persistence.xml file.  Since this is a regular Java application there is a little more 
code to create the EntityManager from the EntityManagerFactory and begin and commit the 
transaction but this is pretty standard for any JPA operation.
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	Lab 1 -  Java Logging
	Part 1 -  Create Code with Basic Logging
	__1.  From C:\Software\eclipse execute eclipse.exe
	__2.  You will be prompted to select a workspace.  Change the the Workspace to C:\workspace
	__3.  Click the OK button.
	__4.  You will see the Welcome screen. Close it.
	__5.  From the Eclipse menus, select File → New → Project. 
	__6.  In the New Project window, select Java → Java Project and click Next.
	__7.  Enter LogProject as Project Name.
	__8.  Click Finish. Click yes if asked to switch perspective.
	__9.  In the new project create a new Java class with the following attributes.  You can do this by selecting File → New → Class.
	__10.  In the code for the 'HelloWorldLogger' class, add the declaration of a 'Logger' field that will be initialized based on the name of the class.
	__11.  Organize imports (CTRL-SHIFT-O) and select java.util.logging.Logger if prompted.
	__12.  In the class create the following empty method shown in bold.
	__13.  Within the code of this new method simply add a line to log the name passed as a parameter as an INFO message.
	__14.  Save the 'HelloWorldLogger' class and make sure there are no errors.
	__15.  In the project create a new Java class with the following attributes:
	__16.  Modify the code of the 'main' method to match the following.  You will get errors but they will be fixed next.
	__17.  Add the following empty method to the 'Driver' class.  You can also use the Eclipse 'Quick fixes' to add the code.
	__18.  In the code for the new 'runProgram' method add the declaration of a 'Logger' variable that will be initialized based on the name of the class.
	__19.  Add the following line to declare a new 'HelloWorldLogger' object.
	__20.  Organize imports (CTRL-SHIFT-O).
	__21.  Save the class and there shouldn't be any errors although there will be some warnings.
	__22.  Add the following code that will use the logger and HelloWorldLogger objects. Notice that we are logging from this class also to see the effects of configuration properties later.
	__23.  Save the class and make sure there are no errors.
	__24.  Select Run → Run As → Java Application from the Eclipse menus.
	__25.  Check that in the Console view you get the following output.  Notice that the messages of both classes appear.

	Part 2 -  Control Logging with Properties File
	__1.  Right click on the 'LogProject' project and select 'New → File'.
	__2.  Fill in a name of 'myLogging.properties', make sure the 'LogProject' is selected and click the Finish button.
	__3.  Leave the file open but don't add anything to it yet.
	__4.  Select Run → Run Configurations from the menu.
	__5.  Select the Driver run configuration on the left if it is not already.
	__6.  Switch to the 'Arguments' tab and in the 'VM arguments' section add the following argument:
	__7.  Press the Apply and then the Run buttons to run the modified configuration.
	__8.  You should see in the Console view that nothing appears.  This actually proves that your properties are being picked up and we will fix this in a second.
	__9.  Switch back to the 'myLogging.properties' file.
	__10.  Add the following to the file.
	__11.  Save the 'myLogging.properties' file.
	__12.  Select 'Run → Run History → Driver' to run the program again.  This time you should get the same output as before you had custom properties.
	__13.  Switch back to the 'myLogging.properties' file and add the following to the file.
	__14.  Save the 'myLogging.properties' file and select 'Run → Run History → Driver' to run the program again.  This time you will again get empty output.
	__15.  Switch back to the 'myLogging.properties' file and add the following to the file.
	__16.  Save the 'myLogging.properties' file and select 'Run → Run History → Driver' to run the program again.  This time you will get messages from the 'HelloWorldLogger' class but not the 'Driver' class.

	Part 3 -  Advanced Logging Code
	__1.  Open the 'HelloWorldLogger' class if it is not already and add the following field to the class:
	__2.  Add the code to throw an Exception to the signature of the 'sayHello' method as shown below.
	__3.  Add the following code that will check if the parameter is one of the "bad names" and throw an Exception.
	__4.  Save the file.  You will get errors in the other class that we will fix.  There should be no errors in the 'HelloWorldLogger' class.
	__5.  Switch back to the 'Driver' class and add the following try/catch block around the call to the 'sayHello' method.
	__6.  Save the file.  There should not be any errors in any classes.
	__7.  Select 'Run → Run History → Driver' to run the program again.  This time you will get the 'Severe' message from the Driver class but not any messages from the 'sayHello' method since the exception was thrown before the INFO message would have been printed out.
	__8.  Return to the 'sayHello' method of the 'HelloWorldLogger' class and change the if clause as follows the following code.
	__9.  Save the file.  There should not be any errors in any classes.
	__10.  Select 'Run → Run History → Driver' to run the program again.  Even though you added the 'throwing' method from the logger you don't see it!  Right now the Console logging is filtering out this message so we need to fix that.
	__11.  Switch back to the 'myLogging.properties' file and add the following line as shown below.
	__12.  Save the 'myLogging.properties' file and select 'Run → Run History → Driver' to run the program again.  This time you will get a 'FINER' message about the exception that was thrown.
	__13.  Back in the 'HelloWorldLogger.sayHello' method add the following code.
	__14.  Save the file and select 'Run → Run History → Driver' to run the program again.    This time you will see a log message 'FINER: ENTRY Bob' which indicates the method was called with a name of 'Bob' for the parameter.
	__15.  Add the following code to the 'sayHello' method.
	__16.  Organize imports.
	__17.  Save the file and select 'Run → Run History → Driver' to run the program again.  You will see the INFO message about FINEST logging being available but notice you do not see any FINEST messages.
	__18.  Switch back to the 'myLogging.properties' file and modify the following line.
	__19.  Save the 'myLogging.properties' file and select 'Run → Run History → Driver' to run the program again.  This time you are back to only seeing the SEVERE message.  Notice that the INFO message about the 'FINEST' level being available is also not logged.  You also lose the ENTRY and THROW messages since they were FINER level.

	Part 4 -  Log to a Log File
	__1.  Switch back to the 'myLogging.properties' file and modify the following line in bold.  Also remove the line for the ConsoleHandler since we will not use it.
	__2.  Add the following two new properties.  Note that the 'formatter' property should be entered with the value on the same line.  It wraps to the next line shown below.
	__3.  Save the 'myLogging.properties' file.
	__4.  From the Eclipse menus select Window → Preferences.
	__5.  From the preference groups on the left select General → Workspace.
	__6.  Check the box to 'Refresh using native hooks or polling' and click the OK button.
	__7.  Select 'Run → Run History → Driver' to run the program again.  
	__8.  Check that you see a 'java0.0.log' file show up in the project as shown below.
	__9.  Open the file and you should see the same SEVERE message we saw before.  Take note of the timestamp of the message.
	__10.  Close the file.
	__11.  Select 'Run → Run History → Driver' to run the program again.  
	__12.  Wait several seconds for Eclipse to refresh the projects contents and then open the log file again.  Notice that you see just the one SEVERE message but it should have a different timestamp.
	__13.  Close the log file.
	__14.  Switch back to the 'myLogging.properties' file and add the following line.  
	__15.  Save the 'myLogging.properties' file and select 'Run → Run History → Driver' to run the program again.
	__16.  Wait several seconds for Eclipse to refresh the projects contents and then open the log file again.  This time you should see that the previous message was kept and the logging appended new messages on the end.
	__17.  Close the log file.
	__18.  Switch back to the 'myLogging.properties' file and add the following two lines.  Also modify the 'com.webage.logging.level' property to 'ALL'.
	__19.  Save the 'myLogging.properties' file and select 'Run → Run History → Driver' to run the program again.
	__20.  Wait for the Eclipse project to refresh which should show two log files as shown below.
	__21.  Open the 'java0.1.log' file first.  Notice that this log file should have the earlier SEVERE messages in addition to the start of the loop of FINEST messages.
	__22.  Open the 'java0.0.log' file.  This log file should have the rest of the FINEST messages along with the other expected messages at the end.
	__23.  Close both log files.
	__24.  Delete both log files from the project.

	Part 5 -  Use Memory Buffer Logging
	__1.  Modify the 'handlers' property in the 'myLogging.properties' file as shown below and add the new property to configure the 'target' of the Memory Handler.
	__2.  Save the 'myLogging.properties' file and select 'Run → Run History → Driver' to run the program again.
	__3.  Wait for the Eclipse project to refresh which should show two log files as shown below.
	__4.  Open the 'java0.1.log' file first.  Notice this still starts the complete loop of the FINEST messages.
	__5.  Open the 'java0.0.log' file.  This log file should have the other expected messages at the end.
	__6.  Close both log files.
	__7.  Delete both log files from the project.
	__8.  Add the following line to the 'myLogging.properties' file.  This will limit the number of messages in the memory buffer.
	__9.  Save the 'myLogging.properties' file and select 'Run → Run History → Driver' to run the program again.
	__10.  Wait for the Eclipse project to refresh which should show only one log file.
	__11.  Open the 'java0.0.log' file.  This log file should have only the last few FINEST messages from the loop and the other messages expected at the end.  This proves that it is logging messages of all levels but only the last 5 messages so the log file of a larger program might be easier to find errors but still provide some context for messages immediately before the errors.
	__12.  Close all open files.

	Part 6 -  Review

	Lab 2 -  Accessing Database
	Part 1 -  Import a Java Application Project
	__1.  If not already running, open Eclipse from C:\Software\eclipse by executing eclipse.exe and selecting the workspace C:\workspace
	__2.  From the menu, select File -> Import.
	__3.  Expand and select General → Existing Projects into Workspace and click the Next button.
	__4.  Select the radio button next to the Select archive file option and use the matching Browse button to find and open the file 'C:\LabFiles\AdvJava-Starter.zip'.
	__5.  Select the project listed in the file if it is not already as shown below.
	__6.  Press the Finish button to import the project.
	__7.  Expand AdvJava from the Project Explorer view.
	You can ignore any errors at the moment. These are pertaining to other labs and we will fix them at that point.

	Part 2 -  Add the Derby JDBC Drivers to the Eclipse Project
	__1.  Right click on the ‘AdvJava’ project in the Project Explorer and select Properties.
	__2.  In the properties window, select the Java Build Path node and the Libraries tab:
	__3.  Click the Add External JARs… button.
	__4.  Navigate to the directory  C:\Software\db-derby-10.12.1.1-bin\lib  and select derbyclient.jar then press Open. 
	__5.   Press OK in the Properties dialog.

	Part 3 -  Start Derby Server
	__1.  Open a Windows File Explorer window and navigate to the C:\Software\db-derby-10.12.1.1-bin\bin directory.
	__2.  Double click the startNetworkServer.bat batch file to run the Derby network server.
	__3.  Minimize but do not close the command window that appears.  Closing the window will stop the Derby server.

	Part 4 -  Complete DBUtils Implementation
	__1.  Back in Eclipse, open the DBUtils class under the com.webagesolutions.users package.
	__2.  Find the 'readUser' method.  This method will be used to initialize a Java object based on the data from the database.
	__3.  Find the comment 'Set user properties from ResultSet' and add the following code in bold after the comment.  Be careful with the spelling of the column names.
	__4.  Find the 'writeUser' method.  This method will be used to initialize a Java object based on the data from the database.
	__5.  Examine the Strings used for the update and insert statements.  These have been provided for you to avoid typos but are critical in writing JDBC code.  In particular notice that a lot of the Strings used in concatenation end with an extra space to make sure that two keywords are not concatenated without a space between them.  This is a common error in JDBC statements.
	__6.  Find the comment 'Set query parameters from User properties' and add the following code in bold after the comment.  Be careful to match the correct number for the query parameter to the correct property of the user object.
	__7.  Replace the getConnection method as follows:
	__8.  Save the class.  There should be no errors or warnings in this class.

	Part 5 -  Implement the UserStore Service
	__1.  Expand AdvJava → com.webagesolutions.users and examine the interface UserStore.  This interface defines a generic service that stores instances of User objects and allows a client to retrieve the User objects based on the user’s email address.  You will be creating a JDBC-based database storage implementation of this interface.
	__2.  In the AdvJava → com.webagesolutions.jdbc package, open the DBUserStore.java file.  Notice this file already indicates that it implements the UserStore interface but doesn't have the complete code for this.
	__3.  Declare a private instance variable called connection to store a reference to an instance of java.sql.Connection.
	__4.  Organize imports (CTRL+SHIFT+O). Select java.sql.Connection.
	__5.  Add the following code in bold to the constructor:
	__6.  Save the class.  There should be no errors or warnings.
	__7.  In the DBUserStore class, implement the “putUser” method to validate the user’s password (similar to the previous lab) and then delegate the write operation to DBUtils if the validation passes.  The code should look something like this when done:
	__8.  Organize imports. 
	__9.  Save the class.  There should be no errors or warnings in this file.
	__10.  From the com.webagesolutions.users package, right click on CreateUsersTable.java and select Run as → Java Application.  
	__11.  You should see the success message.  
	__12.  Now you will populate the table. From the com.webagesolutions.users package, right click on PopulateUsersTable.java and select Run as →  Java Application.  
	__13.  You should see the success message.  
	__14.  Open the classes above if you want to look at the code that performed these tasks.

	Part 6 -  Browse the data
	__1.  Open a Windows command prompt.  You can do this by selecting Start → Run, entering 'cmd' without the quotes and clicking the OK button.
	__2.  Use the 'cd' command to switch to the C:\Software\db-derby-10.12.1.1-bin\bin directory.
	__3.  Issue the command  'ij.bat'  to launch the Derby command line tool.
	__4.  Issue the following command to connect to the database:
	__5.  Issue the following command to list the content of the Users table:
	__6.  Issue the following command to exit:
	__7.  Close the command window.  Make sure to leave the command window running Derby open.

	Part 7 -  Implementing code
	__1.  In the com.webagesolutions.users package, there is a class called TestDBUserStore that will list all the users that are contained in the database, then search for one particular user by email.  If you run that class now, you get a NullPointerException, because we haven’t implemented the listAllUsers method yet. Run the TestDBUserStore class to see the exception.
	__2.  In the DBUserStore class, enter the following code for the listAllUsers() method:
	__3.  Perform Organize imports. Select java.util.Iterator. You will still have an error that will be fixed next.
	__4.  Enter the following class definition inside the DBUserStore class, so as to create an inner class called ‘ListIterator’.  Instances of this inner class will have access to the instance variables of the outer class, namely the open connection object:
	__5.  Perform Organize imports. Select java.util.List, java.sql.ResultSet and java.sql.Statement. 
	__6.  Save the class.  You should have no errors at this point.
	__7.  Enter the following for the getUser(…) method in DBUserStore:
	__8.  Organize imports.  Select java.sql.PreparedStatement when prompted.
	__9.  Save the class.  You should have no errors.
	Note that in the above method, the "try-with-resources" statement will automatically close the Prepared Statement.  The result set is automatically closed when the Statement object is closed.
	__10.  Run the TestDBUserStore class again.  You should now see the final lookup returns the record for Jim Waldo in addition to all the records being listed.
	__11.  Close all open files.

	Part 8 -  Summary

	Lab 3 -  Using JPA
	Part 1 -  Lab Setup
	__1.  Open Eclipse if it is not already running.
	__2.  Select File → Import from the Eclipse menus.
	__3.  Expand the General group and select Existing Projects into Workspace and press the Next button.
	__4.  Select the radio button next to the Select archive file option and use the matching Browse button to find and open the file 'C:\LabFiles\JPAUserStore-Starter.zip'.
	__5.  Select the project listed in the file if it is not already as shown below.
	__6.  Press the Finish button to import the project.
	__7.  In the Problems view check that you have no errors for this project.  You may have errors for other projects.

	Part 2 -  Modify Project Properties
	__1.  In Eclipse select Window → Preferences.
	__2.  In the list of preferences select Java → Build Path → User Libraries.
	__3.  Press the New button.
	__4.  Fill in a library name of Hibernate and click the OK button.
	__5.  With the newly create Hibernate library still selected press the Add External JARs... button.
	__6.  Browse to the 'C:\LabFiles\Hibernate-lib' directory, select all the JAR files by holding the CTRL key while selecting them (or use CTRL-A), then click the Open button to complete the selection.
	__7.  Make sure that all 11 of the JAR files are listed as part of the library.
	__8.  Click the OK button to close the Eclipse preferences.
	__9.  Right click on the JPAUserStore project and select Properties.
	__10.  Select Project Facets from the left side of the project properties.
	__11.  Check the box for the 'Utility Module' and 'JPA' facets and make sure the version of the JPA facet is 2.1.  Do not close the properties yet though.
	__12.  Click on the title of the 'JPA' facet so it is selected and then click the link for 'Further configuration required' below.
	__13.  On the configuration of the JPA facet, under the setting for 'JPA Implementation' select the 'User Library' Type and check the Hibernate library check box; click the OK button when your screen looks like shown below.
	__14.  Still on the Project Facets page click the Apply button in the lower right.  This will configure the build path of the project for Hibernate which is important.
	__15.  Once you have configured the JPA facet and are back in the project properties select the Java Build Path project properties on the left.
	__16.  Select the Libraries tab of the Java build path properties and click the button for 'Add External JARs' on the right.
	__17.  Navigate to the 'c:\Software\db-derby-10.7.1.1-bin\lib' directory and select the 'derbyclient.jar' file and press the Open button to complete the selection.
	__18.  Check that the Derby JAR file and Hibernate library is listed as shown and then click the OK button to close the project properties. 
	__19.  In the Problems view check that you have only warnings and no errors for the JPAUserStore project.  You will have more warnings than before because of some of the classpath settings but this will be fine.

	Part 3 -  Configure JPA Entity
	__1.  In the Package Explorer view, expand the following folders:
	__2.  Open the RegularUser.java file in the com.webage.users package by double clicking it.  Notice that this is just a regular Java class with a few properties and get/set methods.
	__3.  Add the following code annotations in bold to the existing class.  You will have some errors until fixed in the next step.
	__4.  Select Source → Organize Imports from the menus.  When prompted select javax.persistence.Entity and click the Finish button.
	__5.  Save the class.  You will have another error that will be fixed in a future step.
	__6.  Open the Administrator.java file in the com.webage.users package by double clicking it.
	__7.  Add the following code annotation in bold to the existing class.  You will have some errors until fixed in the next step.
	__8.  Select Source → Organize Imports from the menus.  When prompted select javax.persistence.Entity and click the Finish button.
	__9.  Save the class.  You will have another error that will be fixed in a future step.
	__10.  In the Package Explorer view, expand the following folders:
	__11.  Right click the persistence.xml file and select JPA Tools → Synchronize Class List from near the bottom.
	__12.  Check that the error in the RegularUser and Administrator classes are gone.  Now these classes are explicitly listed in the persistence.xml file so JPA will know to manage them.

	Part 4 -  Complete JPA UserStore Implementation
	__1.  In the Package Explorer view, expand the following folders:
	__2.  Open the JPAUserStore.java file in the com.webage.jpa package by double clicking it.  Notice that right now it is just an empty implementation of the 'UserStore' interface.
	__3.  Add the following new field to the class shown in bold.  This will add the JPA EntityManager used to persist data.  You will still have errors in the code.
	__4.  Locate the 'putUser' method and replace the implementation with the bold code below.  This uses a method already supplied by the EntityManager to persist data.
	__5.  Select Source → Organize Imports from the menus.  
	__6.  Save the class and make sure there are no errors.

	Part 5 -  Modify JPA Configuration
	__1.  Open the 'src/META-INF/persistence.xml' file.  
	__2.  Make sure the editor shows the file in the General tab and switch to this tab if needed.
	__3.  For the value of the "Persistence provider" fill in a value of 'org.hibernate.jpa.HibernatePersistenceProvider' without the quotes as shown below.
	__4.  Switch to the Connection tab in the editor.
	__5.  In the drop-down for 'Transaction type' select the option for 'Resource Local'.
	__6.  Further down on the page fill in the following properties in the 'JDBC connection properties' setting.
	__7.  Switch to the Properties tab in the editor.  Notice the existing standardized connection properties are already present.
	__8.  Click the Add button to add a row for a new property.
	__9.  Fill in the following 'Name' and 'Value' for the new property by typing it in after clicking the appropriate column.
	__10.  Click the Add button a second time to add another new property.
	__11.  Fill in the following 'Name' and 'Value' for the new property by typing it in after clicking the appropriate column.
	__12.  Save the file and be sure there are no errors from incorrect syntax.

	Part 6 -  Test JPA Functionality
	__1.  Make sure you have the Derby server running, if not then navigate to the 'C:\Software\db‑derby‑10.7.1.1-bin\bin' folder and run the 'startNetworkServer.bat' command by double clicking it.  Make sure to run the correct command as there are several similarly named batch files. Wait for the Derby server to report that it is waiting for connections.
	__2.  Do not close the command prompt window that is running Derby.
	__3.  Back in Eclipse, in the Package Explorer view, expand the following folders:
	__4.  Open the JPAUsersTest.java file in the com.webage.jpa package by double clicking it.  Notice that right now it is just a Java class with an empty 'main' method.
	__5.  Add the following new code to the empty 'main' method.  This code simply creates a new instance of the JPA 'UserStore' implementation and then passes it to the UserStoreUtils.populate method which will create some new users to add to the persistent storage.
	__6.  Select Source → Organize Imports from the menus.  
	__7.  Save the file and make sure there are no errors although you will get warnings.
	__8.  Right click the JPAUsersTest class and select 'Run As → Java Application'
	__9.  Look in the Console view and you should see the message that the Users table was populated successfully.  You will also see the Hibernate SQL statements (although without the actual values) after several other messages from Hibernate about setting up the database connection and exporting the database schema to the database.

	Part 7 -  Implement Other UserStore Methods
	__1.  Return to the JPAUserStore.java file in the com.webage.jpa package and open it if you had closed it.
	__2.  Provide the following implementation to the 'listAllUsers' method.  Be careful with the 'createQuery' method syntax as it has several parameters that wrap to several lines below.  You will have errors until the next step.
	__3.  Select Source → Organize Imports from the menus.  When prompted select  java.util.List and click the Finish button.
	__4.  Next, provide the following implementation to the 'getUser' method.  
	__5.  Save the file and make sure there are no errors.
	__6.  Return to the JPAUsersTest.java file in the com.webage.jpa package and open it if you had closed it.
	__7.  Add the following new code to the 'main' method after the current code that populates the database.  This code uses the method to get all users and then prints those users from a loop.  It also searches for a specific user that had been created in the  UserStoreUtils.populate method.
	__8.  Select Source → Organize Imports from the menus.
	__9.  Save the file and make sure there are no errors.
	__10.  From the menus select 'Run → Run History → JPAUsersTest'.
	__11.  This time in the Console view you should see in addition to the output from last time, a list of all the users that were selected from the database and then the details of the individual user that was searched for by email.
	__12.  Close all open files.
	__13.  In a Windows Explorer window, navigate to the 'C:\Software\db‑derby‑10.7.1.1-bin\bin' folder.
	__14.  Run the 'stopNetworkServer.bat' command by double clicking it.  Make sure to run the correct command as there are several similarly named batch files. This will close the Derby server.

	Part 8 -  Review

	Lab 4 -  JAXB Programming
	Part 1 -  Add JAXB Implementation to Project Classpath
	__1.  From the Eclipse menus, select File → New → Project. 
	__2.  In the New Project window, select Java → Java Project and click Next.
	__3.  Enter XMLProject as Project Name.
	__4.  Click Finish. Click yes if asked to switch perspective.
	__5.  In Eclipse select Window → Preferences.
	__6.  In the list of preferences select Java → Build Path → User Libraries.
	__7.  Press the New button.
	__8.  Fill in a library name of JAXB and click the OK button.
	__9.  With the newly create JAXB library still selected press the Add External JARs button.
	__10.  Browse to the 'C:\LabFiles\JAXB-lib' directory, select all the JAR files by holding the CTRL key while selecting them, then click the Open button to complete the selection.
	__11.  Make sure that all 6 of the JAR files are listed as part of the library.
	__12.  Click the OK button to close the Eclipse preferences.
	__13.  Back in Eclipse, right click the XMLProject project and select Build Path → Add Libraries.
	__14.  Select User Library and click the Next button.
	__15.  Check the box next to the JAXB library you defined and click the Finish button.
	__16.  Check that the JAXB library is associated with the project.

	Part 2 -  Generating the Bindings
	__1.  Open a Windows Explorer window and navigate to the 'C:\LabFiles' folder.
	__2.  Copy the 'movie.xsd' file from the folder.  Make sure it is the XSD schema file and not the XML file.
	__3.  Return to Eclipse and select the 'XMLProject'.
	__4.  Right click 'XMLProject' and select 'Paste'.
	__5.  Check that you see the 'movie.xsd' file at the root of the project.
	__6.  Right click the movie.xsd file and select Generate → JAXB Classes.
	__7.  Select XMLProject and click Next.
	__8.  Change the Package to 'com.jaxb.movie' as shown below and click the Finish button.  
	__9.  If you get an overwrite warning, click Yes.
	__10.  Expand the src folder of project XMLProject. 
	__11.  A newly created package com.jaxb.movie should appear.  Expand it and you should see the generated binding classes.
	__12.  Open the 'MovieType.java' file from this package.  It is probably the more complex example of how JAXB annotations are used to map between Java and XML.
	__13.  Scroll past the comments at the beginning and look at the various JAXB annotations just before and after the class declaration.  These link back to the XML schema structure along with which attributes were required by the schema.
	__14.  Close the file without making any changes.

	Part 3 -  Use the Binding Classes To Read XML
	__1.  In the XMLProject project, create a new package called com.mycom.test 
	__2.  In the com.mycom.test package, create a new class called JAXBMoviePrinter adding a main method.
	(If you have trouble typing in the following code, we have provided the completed class source code at C:\LabFiles\Solutions\SOLUTION-JAXBMoviePrinter.java  Feel free to copy and paste if necessary).
	__3.  In the main method, we first need to setup the unmarshaler. Add the following code to the main method. 
	__4.  There are some errors in the code.  To fix a few of them, perform an Organize imports. (Ctrl + Shift + O) , selecting javax.xml.bind.Unmarshaller if prompted. After you do this, you will still see some errors, but ignore them for now.  
	__5.  Recall that in our schema, that “top-most” element was database.  If you look at the generated binding classes, you will notice that a Database class was created.  We can use the unmarshaler to create an instance of this object.  Add the following code:
	__6.  Fix this by performing an Organize Imports. Select java.io.File if prompted.  There will still be some errors.  Do not worry about them for now. 
	__7.  Remember that a <database> element contained several <movie> elements. Similarly, the database object will have a field that represents a list of MovieType objects.  We can get this list.  Add the following code:
	__8.  We now have a hold of the list of movies that the database was keeping track of.  We can iterate through it, and operate on it!  Let us simply go through the list and print the title of each movie.  Add the following code:
	__9.  Organize imports again. Select java.util.List when prompted.
	__10.  Select all the code in the main method (but not the method declaration). 
	__11.  Right click on it and select Surround With->Try/catch block.
	__12.  Save the code.

	Part 4 -  Test JAXB
	__1.  Right click on the code and select Run As → Java Application.
	__2.  Close all open editors.

	Part 5 -  Review

	Lab 5 -  Introduction to Lambda Expressions
	Part 1 -  Import Starting Project
	__1.  If Eclipse is not already running, from C:\Software\eclipse execute eclipse.exe
	__2.  You will be prompted to select a workspace.  Change the the workspace to C:\workspace
	__3.  Click the OK button.
	__4.  You will see the Welcome screen. Close it.
	__5.  From the menu, select File -> Import.
	__6.  Expand and select General → Existing Projects into Workspace and click the Next button.
	__7.  Select the radio button next to the Select archive file option and use the matching Browse button to find and open the file 'C:\LabFiles\LambdaProject-Starter.zip'.
	__8.  Select the project listed in the file if it is not already as shown below.
	__9.  Press the Finish button to import the project.
	__10.  Switch to the Java perspective by selecting Window → Perspective → Open Perspective → Java.
	__11.  Expand LambdaProject from the Package Explorer view.

	Part 2 -  Examine and Run Current Code
	__1.  From the LambdaProject, expand src → com.webage.lambda.person.
	__2.  Open and examine the purpose of some of the following classes:
	__3.  Close any classes that are currently open.
	__4.  In the project expand LambdaProject → src → com.webage.lambda.intro and open the PersonSearch.java file.
	__5.  Notice how the various methods all take a List of Person objects, select some of them based on some criteria, and then print out various details about the person. Although there are only 3 methods here currently, imagine how difficult it would be to have a method for all three contact options (mail, email, and call) for all three groups (voters, people in New York, and draftees).
	__6.  Open the PersonSearchTest.java file from the com.webage.lambda.intro package.
	__7.  Notice how this class simply gets the list of sample data for people and passes it into the various methods in the PersonSearch class.
	__8.  With the PersonSearchTest class still open, select Run → Run As → Java Application.
	__9.  The Console view should appear and show the output of the application.  You may want to maximize the view (double click the view's tab or use the maximize button in the upper right corner of the view) to see all of the output.
	__10.  Restore the view to normal if you maximized it before going to the next section.

	Part 3 -  Refactor Test Logic Into Methods
	__1.  Open the PersonSearch.java file from the com.webage.lambda.intro package if it is not already open.
	__2.  Add the following three methods to the class.  Make sure they are outside other methods but within the brackets for the class itself.
	__3.  Save the code and make sure you don't have any errors before moving on.
	__4.  Find the existing 'callVoters' method and replace the condition of the 'if' statement with a call to one of the new methods as shown in bold below.
	__5.  Find the existing 'mailNewYorkCity' method and replace the condition of the 'if' statement with a call to one of the new methods as shown in bold below.
	__6.  Find the existing 'emailDraftees' method and replace the condition of the 'if' statement with a call to one of the new methods as shown in bold below.
	__7.  Save the code and make sure you don't have any errors.
	__8.  From the Eclipse menus, select 'Run → Run History → PersonSearchTest'
	__9.  Check that the output in the Console view is the same as it was before.
	__10.  Restore the Console view to normal if you maximized it before going to the next section.

	Part 4 -  Pass Predicate From Calling Code
	__1.  Open the PersonSearch.java file from the com.webage.lambda.intro package if it is not already open.
	__2.  Find the existing 'callVoters' method and make the following changes to the method signature.  Notice this includes changing the name of the method, since it will no longer be specific to voters, AND adding a new parameter for a Predicate object.  You will have compilation errors for several steps.
	__3.  Organize imports (Source → Organize Imports or CTRL+SHIFT+O) and pick 'java.util.function.Predicate' when prompted.
	__4.  Within the body of the method, change the condition of the 'if' statement to use the test of the Predicate passed in as a parameter.  Note how this makes the method more generic as any condition can be passed as a parameter.
	__5.  Save the code and make sure you don't have any errors in this file before moving on. You will have errors elsewhere in the project though.
	__6.  Find the existing 'mailNewYorkCity' method and make the following changes to the method signature.  Again you are changing the name of the method AND adding a new parameter for a Predicate object. 
	__7.  Within the body of the method, change the condition of the 'if' statement to use the test of the Predicate passed in as a parameter.  
	__8.  Find the existing 'emailDraftees' method and make the following changes to the method signature.  Again you are changing the name of the method AND adding a new parameter for a Predicate object. 
	__9.  Within the body of the method, change the condition of the 'if' statement to use the test of the Predicate passed in as a parameter.  
	__10.  Remove the 'isVoter', 'isNewYork' and 'isDraftee' methods as you will no longer need these since the conditions will be passed as a Predicate parameter instead of being defined by the PersonSearch class.  You can also remove the 'Gender' import if you wish as it will no longer be used.
	__11.  Save the code and make sure you don't have any errors in this file before moving on. You will have errors elsewhere in the project though.
	__12.  Open the PersonSearchTest.java file from the com.webage.lambda.intro package if it is not already open.  This class now has compilation errors that need to be fixed.
	__13.  Find the code in the 'main' method that currently calls the 'callVoters' method and make the following changes.  Note you are changing the name of the method being called AND creating a new instance of the Predicate interface as an Anonymous Inner Class (AIC).  Be careful with the syntax as defining the AIC within the parameters of the method is tricky.
	__14.  Organize imports (Source → Organize Imports or CTRL+SHIFT+O) and pick 'java.util.function.Predicate' when prompted.
	__15.  Save the code and make sure you no longer have any compilation errors in the code you just modified.  You will still have other compilation errors though.
	__16.  Find the code in the 'main' method that currently calls the 'mailNewYorkCity' method and make the following changes.  Again note you are changing the name of the method being called AND creating a new instance of the Predicate interface as an Anonymous Inner Class (AIC).  
	__17.  Save the code and make sure you no longer have any compilation errors in the code you just modified.  You will still have other compilation errors though.
	__18.  Find the code in the 'main' method that currently calls the 'emailDraftees' method and make the following changes.  Again note you are changing the name of the method being called AND creating a new instance of the Predicate interface as an Anonymous Inner Class (AIC).  
	__19.  Organize imports (Source → Organize Imports or CTRL+SHIFT+O) to import the Gender enumeration definition.
	__20.  Save the code and make sure there are no compilation errors in any files.
	__21.  From the Eclipse menus, select 'Run → Run History → PersonSearchTest'
	__22.  Check that the output in the Console view is the same as it was before.
	__23.  Restore the Console view to normal if you maximized it before going to the next section.

	Part 5 -  Use Lambda Expression
	__1.  Open the PersonSearchTest.java file from the com.webage.lambda.intro package if it is not already open. 
	__2.  Find the code in the 'main' method that currently calls the 'callMatchingPeople' method with voters and make the following changes.  Note that you are removing the AIC instance and replacing it with a Lambda expression.  Make sure the syntax for the method parameters is still correct.
	__3.  Save the code and make sure you do not have any compilation errors.
	__4.  Find the code in the 'main' method that currently calls the 'mailMatchingPeople' method with residents of “New York” and make the following changes.  Again note that you are removing the AIC instance and replacing it with a Lambda expression.  
	__5.  Save the code and make sure you do not have any compilation errors.
	__6.  Find the code in the 'main' method that currently calls the 'emailMatchingPeople' method with draftees and make the following changes.  Again note that you are removing the AIC instance and replacing it with a Lambda expression.  The syntax of this expression is a bit more complex.
	__7.  Save the code and make sure you do not have any compilation errors.
	__8.  From the Eclipse menus, select 'Run → Run History → PersonSearchTest'
	__9.  Check that the output in the Console view is the same as it was before.
	__10.  Restore the Console view to normal if you maximized it before going to the next section.

	Part 6 -  Reuse Lambda Expressions
	__1.  Open the PersonSearchTest.java file from the com.webage.lambda.intro package if it is not already open. 
	__2.  Select the code of the Lambda expression for the voters by highlighting it as shown below.  Make sure to only select the Lambda expression and not the comma or parenthesis before and after it.
	__3.  From the Eclipse menus select 'Refactor → Extract Local Variable'.  If this option is not available or gives an error double check what you have selected and try again.
	__4.  Change the name of the local variable that will be created to 'voters' and click the OK button to define the variable.
	__5.  Check that the code is modified to match that shown below.
	__6.  Select the code of the Lambda expression for the New York residents by highlighting it as shown below.  Make sure to select only one of the parenthesis at the end.
	__7.  From the Eclipse menus select 'Refactor → Extract Local Variable'.  If this option is not available or gives an error double check what you have selected and try again.
	__8.  Change the name of the local variable that will be created to 'newYorkResidents' and click the OK button to define the variable.
	__9.  Check that the code is modified to match that shown below.
	__10.  Select the code of the Lambda expression for the draftees by highlighting it as shown below.  Make sure not to select the parenthesis at the end.
	__11.  From the Eclipse menus select 'Refactor → Extract Local Variable'.  If this option is not available or gives an error double check what you have selected and try again.
	__12.  Change the name of the local variable that will be created to 'draftees' and click the OK button to define the variable.
	__13.  Check that the code is modified to match that shown below.
	__14.  From the Eclipse menus, select 'Run → Run History → PersonSearchTest'.
	__15.  Check that the output in the Console view is the same as it was before.
	__16.  Modify the code that had called voters to instead call retirees as shown below.
	__17.  Save the code and make sure you do not have any errors.
	__18.  From the Eclipse menus, select 'Run → Run History → PersonSearchTest'.
	__19.  Check that the output changes to reflect calling the new group.
	__20.  Modify the code that had mailed New York residents to instead mail retirees as shown below.
	__21.  Save the code and make sure you do not have any errors.
	__22.  From the Eclipse menus, select 'Run → Run History → PersonSearchTest'.
	__23.  Make sure the output changes as shown below.
	__24.  Close all open files. 

	Part 7 -  Review

	Lab 6 -  Collection Stream API
	Part 1 -  Use forEach With Lambda Expressions
	__1.  Open Eclipse in the project 'LambdaProject' if it is not already.
	__2.  In the project expand LambdaProject → src → com.webage.lambda.stream and open the StreamTest.java file.
	__3.  Add the following to the existing 'main' method.
	__4.  Save the file and make sure there are no errors.
	__5.  With the StreamTest class still open, select Run → Run As → Java Application.
	__6.  Check that the Console view shows the following output.
	__7.  Back in the code of the StreamTest class, change the code in the 'forEach' parameter to use a method expression as shown below.  This is possible since each element of the collection is simply being printed out on a line and there is no additional text being supplied.
	__8.  Save the file and make sure there are no errors.
	__9.  From the Eclipse menus select Run → Run History → StreamTest.
	__10.  Make sure the output is the same as before.

	Part 2 -  Use Stream API Filtering
	__1.  Add the following code to the end of the 'main' method of the StreamTest class.  This will create a PersonContact object that can be used for operations and a Lambda expression that will be used with filtering.
	__2.  Organize imports (Source → Organize Imports or CTRL+SHIFT+O) and pick 'java.util.function.Predicate' when prompted.
	__3.  After the code you just entered, enter the following code to get a stream, filter the stream with the Lambda expression for voters and call the 'callPerson' method.
	__4.  Save the file and make sure there are no errors.
	__5.  From the Eclipse menus select Run → Run History → StreamTest.
	__6.  Check that the end of the output displays the following.
	__7.  Add the following code to the end of the 'main' method.
	__8.  Save the file and make sure there are no errors.
	__9.  From the Eclipse menus select Run → Run History → StreamTest.
	__10.  Check that the end of the output displays the following.
	__11.  Add the following code to the end of the 'main' method.
	__12.  Organize imports (Source → Organize Imports or CTRL+SHIFT+O) to import the Gender enumeration definition.
	__13.  Save the file and make sure there are no errors.
	__14.  From the Eclipse menus select Run → Run History → StreamTest.
	__15.  Check that the end of the output displays the following.

	Part 3 -  Working With Multiple Filters
	__1.  Add the following code to the end of the 'main' method.
	__2.  Save the file and make sure there are no errors.
	__3.  From the Eclipse menus select Run → Run History → StreamTest.
	__4.  Check that the end of the output displays the following.  Notice the same Person is used with the only difference being the type of info printed out.
	__5.  Add the following code to the end of the 'main' method.
	__6.  Save the file and make sure there are no errors.
	__7.  From the Eclipse menus select Run → Run History → StreamTest.
	__8.  Check that the end of the output displays the following.  
	__9.  Close all open files.

	Part 4 -  Review

	Lab 7 -  Using Built-In Lambda Types
	Part 1 -  Use Predicate
	__1.  Open Eclipse in the project 'LambdaProject' if it is not already.
	__2.  In the project expand LambdaProject → src → com.webage.lambda.function and open the FunctionTest.java file.
	__3.  Add the following to the existing 'main' method.
	__4.  Save the file and make sure there are no errors.
	__5.  With the FunctionTest class still open, select Run → Run As → Java Application.
	__6.  Check that the Console view shows the following output.

	Part 2 -  Use Consumer
	__1.  In the main method of the FunctionTest class, modify the code to match that shown below.  This will call a private method that you will implement next.
	__2.  In the FunctionTest class, find the existing 'useConsumer' method and examine the method declaration.  Pay attention to the names of the 'Predicate' and 'Consumer' method arguments since these will be used in the code you will implement next.
	__3.  Add to the existing code what is shown in bold below.  Note how the method parameters are used.  The code essentially does the same thing twice but with two different styles available with the parameters (using Stream API or manual looping).
	__4.  Save the file and make sure there are no errors.
	__5.  From the Eclipse menus select Run → Run History → FunctionTest.
	__6.  Make sure the output matches that shown below.  Note how the output is more complex but you only had to define it once with the Consumer object.

	Part 3 -  Use Function
	__1.  In the project expand LambdaProject → src → com.webage.lambda.person and open the PersonOperations.java file.
	__2.  Examine the existing 'fullAddress' method.  This suits the requirements and is provided for you since it is just a basic method.  Notice there is no use of types from the 'java.util.function' package in this class.
	__3.  Close this class as you will not make any changes to it.
	__4.  Back in the FunctionTest class, add the following bold code to the end of the 'main' method.  Note the “method reference” for the Function object to the 'fullAddress' method you just examined.
	__5.  In the FunctionTest class, find the existing 'useFunction' method and add to the existing code what is shown in bold below.  Note how both the Consumer AND Function method parameters are used.  This will use the existing Consumer object for the Person details like name and email and the Function for the adress.
	__6.  Save the file and make sure there are no errors.
	__7.  From the Eclipse menus select Run → Run History → FunctionTest.
	__8.  Make sure the end of the output matches that shown below.  

	Part 4 -  Use Supplier
	__1.  If you want, examine the 'generateNewPerson' method in the PersonOperations.java file from the com.webage.lambda.person package.  This method picks a random Person object from 3 choices and returns it.  This method will be referenced as a 'Supplier'.
	__2.  Back in the FunctionTest class, add the following bold code to the end of the 'main' method.  This adds a single line to call a method you will complete next.
	__3.  In the FunctionTest class, find the existing 'useSupplier' method and add to the existing code what is shown in bold below.  Note how the Supplier object refers to the 'generateNewPerson' method.
	__4.  Save the file and make sure there are no errors.
	__5.  From the Eclipse menus select Run → Run History → FunctionTest.
	__6.  Make sure the end of the output matches that shown below.  The Person output will probably vary but you should see the name and email of a single Person object.
	__7.  Run the code a few more times to see different Person objects being returned.

	Part 5 -  Use BiPredicate
	__1.  Back in the FunctionTest class, add the following bold code to the end of the 'main' method.  This adds a single line to call a method you will complete next.
	__2.  In the FunctionTest class, find the existing 'useBiPredicate' method and add to the existing code what is shown in bold below.  Note how in this case the state of the Person object is compared to a String supplied as the second parameter.
	__3.  Save the file and make sure there are no errors.
	__4.  From the Eclipse menus select Run → Run History → FunctionTest.
	__5.  Make sure the end of the output matches that shown below.  

	Part 6 -  Use BiFunction
	__1.  Back in the FunctionTest class, add the following bold code to the end of the 'main' method.  This adds a single line to call a method you will complete next.
	__2.  In the FunctionTest class, find the existing 'useBiFunction' method and add to the existing code what is shown in bold below.  Take time to understand the logic in the 'countInState' object.  It creates a stream from a List of Person objects, filters the ones that match a state, and returns the count of the matches.  The count is the long value returned by the 'ToLongBiFunction' object.  Note how nicely that logic is wrapped up in the object.
	__3.  Save the file and make sure there are no errors.
	__4.  From the Eclipse menus select Run → Run History → FunctionTest.
	__5.  Make sure the end of the output matches that shown below.  
	__6.  Close all open files.

	Part 7 -  Review

	Lab 8 -  Collection Operations
	Part 1 -  Use Map & Peek
	__1.  Open Eclipse in the project 'LambdaProject' if it is not already.
	__2.  From the LambdaProject, expand src → com.webage.lambda.employee.
	__3.  Open and examine the purpose of some of the following classes:
	__4.  Close any classes that are currently open.
	__5.  In the project expand LambdaProject → src → com.webage.lambda.operations and open the OperationsTest.java file.
	__6.  Examine the code at the top of the current class.  You do not need to change anything but notice some of the Consumer and Function objects that are declared to use elsewhere in the code.  These are provided so you can focus on writing the code that is not familiar to you.  It is important to note that the 'outputName' object is a 'Consumer<Employee>' so it works with an Employee input parameter while the 'printFormatBonus' is a 'Consumer<Double>' so it takes Double input.  
	__7.  In the OperationsTest class, add the following bold code to the end of the 'main' method.  This adds a single line to call a method you will complete next.
	__8.  In the OperationsTest class, find the existing 'useMapPeek' method and add to the existing code what is shown in bold below.  Notice how the 'peek' method will use the stream of employees to output the name before the 'map' method turns the stream into a stream of Doubles for the bonus.  The terminal 'forEach' method operates on the Doubles of the bonuses to output the bonus.
	__9.  Save the file and make sure there are no errors.
	__10.  With the OperationsTest class still open, select Run → Run As → Java Application.
	__11.  Check that the Console view shows the following output.  Notice how the peek to output the name and the mapping to get the bonus is done on each element before the next one is processed.

	Part 2 -  Use findFirst and Optional
	__1.  In the OperationsTest class, add the following bold code to the end of the 'main' method.  This adds a single line to call a method you will complete next.
	__2.  In the OperationsTest class, find the existing 'useFindFirst' method and add to the existing code what is shown in bold below.  This will print the bonus of every employee using the 'forEach' method after applying a filter and mapping and a few 'peek' operations.
	__3.  In the second half of the 'useFindFirst' method add the code in bold.  This will actually use the 'findFirst' method along with an 'Optional<Employee>' object which will hold the result if there is a match.
	__4.  Save the file and make sure there are no errors.
	__5.  From the Eclipse menus select Run → Run History → OperationsTest.
	__6.  Make sure the end of the output matches that shown below.  Note how the 'forEach' code prints out the bonus of several matching elements while the 'findFirst' code stops when the first is found.

	Part 3 -  Count and Sum Functions
	__1.  In the OperationsTest class, add the following bold code to the end of the 'main' method.  This adds a single line to call a method you will complete next.
	__2.  In the OperationsTest class, find the existing 'useCount' method and add to the existing code what is shown in bold below.  Note how easy it is to program the desired counting logic.
	__3.  Save the file and make sure there are no errors.
	__4.  From the Eclipse menus select Run → Run History → OperationsTest.
	__5.  Make sure the end of the output matches that shown below.  
	__6.  In the OperationsTest class, add the following bold code to the end of the 'main' method.  This adds a single line to call a method you will complete next.
	__7.  In the OperationsTest class, find the existing 'useSum' method and add to the existing code what is shown in bold below.  The key is the 'mapToDouble' method which converts the stream of employees to a stream of Double values so they can be summed.
	__8.  Save the file and make sure there are no errors.
	__9.  From the Eclipse menus select Run → Run History → OperationsTest.
	__10.  Make sure the end of the output matches that shown below.  

	Part 4 -  Use Comparison and Sorting
	__1.  In the OperationsTest class, add the following bold code to the end of the 'main' method.  This adds a single line to call a method you will complete next.
	__2.  In the OperationsTest class, find the existing 'useMin' method and add to the existing code what is shown in bold below.  Notice the use of the default 'comparingDouble' method on the 'Comparator' interface to provide an implementation of comparing the double values of the employee salary as a parameter to the 'min' method.  Also note the use of the 'Optional' class.
	__3.  Save the file and make sure there are no errors.
	__4.  From the Eclipse menus select Run → Run History → OperationsTest.
	__5.  Make sure the end of the output matches that shown below.  
	__6.  In the OperationsTest class, add the following bold code to the end of the 'main' method.  This adds a single line to call a method you will complete next.
	__7.  In the OperationsTest class, find the existing 'useSort' method and add to the existing code what is shown in bold below.  The key to this code is that the 'map' method converts the stream to a stream of Double values of the calculated bonuses before the sorting is done.  Since Double implements the 'Comparable' interface this is possible.  If the 'map' method had not been included, the Employee class would need to be Comparable, which it currently is not, in order to sort the Employee objects directly.
	__8.  Save the file and make sure there are no errors.
	__9.  From the Eclipse menus select Run → Run History → OperationsTest.
	__10.  Make sure the end of the output matches that shown below.  

	Part 5 -  Use Collectors
	__1.  In the OperationsTest class, add the following bold code to the end of the 'main' method.  This adds a single line to call a method you will complete next.
	__2.  In the OperationsTest class, find the existing 'useCollect' method and add to the existing code what is shown in bold below.  Note that the result is stored as a new collection, the 'sortedManagers' variable.  Although this code only does the 'forEach' method on the result, which could have been added to the Stream, it shows how to get a new collection when needed.  Another key to this code, besides the filtering and sorting done on the stream, is the 'Collectors.toList' method indicating the result should be returned in a new List.
	__3.  Save the file and make sure there are no errors.
	__4.  From the Eclipse menus select Run → Run History → OperationsTest.
	__5.  Make sure the end of the output matches that shown below.  
	__6.  In the OperationsTest class, add the following bold code to the end of the 'main' method.  This adds a single line to call a method you will complete next.
	__7.  In the OperationsTest class, find the existing 'useCollectGrouping' method and add to the existing code what is shown in bold below.  Be careful as the syntax is a little more complex with a Lambda expression with curly brackets for a body of several statements instead of just one.  The key to the code is the 'Collectors.groupingBy' method that indicates the resulting Map will be grouped by the department of the Employee with the name of the department being the key to the Map.  The Lambda expression in 'forEach' then outputs all members of a department after a single line with the department name.
	__8.  Save the file and make sure there are no errors.
	__9.  From the Eclipse menus select Run → Run History → OperationsTest.
	__10.  Make sure the end of the output matches that shown below.  
	__11.  In the OperationsTest class, add the following bold code to the end of the 'main' method.  This adds a single line to call a method you will complete next.
	__12.  In the OperationsTest class, find the existing 'useCollectPartition' method and add to the existing code what is shown in bold below.  Be careful as the syntax is a little more complex with two parameters to the 'collect' method and a Lambda expression with curly brackets for a body of several statements instead of just one.  In this case the criteria for the partitioning is whether or not an Employee is an Executive.  On the two partitions, the salary of all members of the partition is summed up.  Notice the type contained as the value in the Map is Double for the sum of the salaries.  This is some fairly compact logic in a compact form.
	__13.  Save the file and make sure there are no errors.
	__14.  From the Eclipse menus select Run → Run History → OperationsTest.
	__15.  Make sure the end of the output matches that shown below.  
	__16.  Close all open files.

	Part 6 -  Review 

	Lab 9 -  Annotations
	Part 1 -  Create Custom Annotation
	__1.  In the AdvJava project, create a new package called com.webagesolutions.annotation 
	__2.  Select the new package and select File → New → Annotation from the Eclipse menus.
	__3.  Create the annotation with the following properties:
	__4.  Add the following code in bold to the inside of the annotation declaration.  This will define the properties that can be used with the annotation.
	__5.  Before the annotation declaration, add the following bold code.  You will have errors until a future step.
	__6.  Organize imports (CTRL-SHIFT-O).
	__7.  Save the code and make sure you don't have any errors.

	Part 2 -  Use Annotation
	__1.  In the com.webagesolutions.annotation package, create a new class called UsingAnnotations.  Make sure it doesn't have a 'main' method.
	__2.  At the class level, add the use of the custom annotation as shown in bold below.  In this location don't add any annotation properties.
	__3.  Inside the class declaration add the following bold code.  This will declare a few methods and use the annotation with those methods.  The content of the methods really doesn't matter as we are just using them for a location to use the annotation.
	__4.  Save the class and make sure there are no errors.

	Part 3 -  Use Reflection to Discover Annotation Properties
	__1.  In the com.webagesolutions.annotation package, create a new class called PrintAnnotations.  Make sure it DOES have a 'main' method.
	__2.  Add the following new method to the class.  Make sure it is outside the 'main' method but within the brackets for the declaration of the class.  You will have errors until the next steps.
	__3.  Modify the implementation of the 'main' method with the following code.
	__4.  Organize imports (CTRL-SHIFT-O).  Select java.lang.annotation.Annotation when prompted.
	__5.  Save the code and make sure you don't have any errors.
	__6.  Make sure the PrintAnnotations class is active in the editor and select Run → Run As → Java Application.
	__7.  Make sure you see the following output in the Console view.  There are many additional methods inherited from the Object class not shown since they don't have the annotation.  Note that in the methods that did have the annotation you will either see the value from the annotation property or the default value.
	__8.  Close all open files.

	Part 4 -  Review

	Lab 10 -  Internationalization
	Part 1 -  Currency Formatting
	__1.  Expand the AdvJava project.
	__2.  Create a new package in your AdvJava project called com.webagesolutions.i18n. Make sure to match the package name exactly as that will be important later.
	__3.  Create a class called CurrencyFormats in the existing package com.webagesolutions.i18n.  Include a public static void main(…) method.
	__4.  In the main method, create three Locale references for America, England, and the default locale, as shown in bold below:
	__5.  Organize imports.
	__6.  Create a double precision floating-point value that we will format:
	__7.  To format currency values, we need a NumberFormat instance configured to format currencies in the given locale.  Create three formatters, one for each locale, as follows:
	__8.  Organize imports.
	__9.  Output the value using each of the formats we’ve created:
	__10.  Organize imports. Select java.util.logging.Logger.
	__11.  Save the class.
	__12.  Run the class using Run As -> Java Application, the output should look like (assuming your default locale is US):
	__13.  You can try changing your computer’s default locale using the Window Control Panel. This differs slightly depending on Windows version but generally involves the  Regional and Language Options tool.   Once in this tool, change the value selected under Formats.  If you do change the language it is suggested to use a language or dialect that you can still understand to make sure you can switch it back later.
	__14.  If you changed the language, run the class again and see if the default format changed.
	__15.  Change back to the default format and test again to check everything is working fine.

	Part 2 -  Date and Time Formatting
	__1.  Create a new class called DateFormats in the com.webagesolutions.i18n package and include the main method.
	__2.  In the main method, create a sampling of DateFormat objects for various locales and date formats as follows:
	__3.  Organize imports.
	__4.  Prompt the user for a date in the local default format, and gather the user’s input value:
	__5.  Organize imports again and select java.util.Scanner, java.util.Date and java.util.logging.Logger.
	__6.  Use the default formatter to convert the input string to a Date object.  When we do the conversion, we need to allow for the fact that the user may have entered an invalid date, which would cause the formatter to throw a ParseException.  We’ll use the current date if this happens:
	__7.  Organize imports again and select java.text.ParseException.
	__8.  Finally, we’ll output the user’s date in the various formats:
	__9.  Save the class.
	__10.  Run the class as a Java application. 
	__11.  Enter a date and hit Enter.
	__12.  The output should look like:

	Part 3 -  Resource Bundles
	__1.  In the AdvJava project, right click the com.webagesolutions.i18n package and select New → Other...
	__2.  Select General → File and click the Next button.
	__3.  Fill in a file name of 'messages_en.properties' without the quotes.  Check that you are in the correct folder that matches the package as shown below and then click the Finish button.
	__4.  In the property file that gets created, add the following text and then save and close the file.
	__5.  In a similar fashion, create a file called 'messages_fr.properties' in the same package.
	__6.  In the 'messages_fr.properties' file that is created, add the following text and then save and close the file.
	__7.  In a similar fashion, create a file called 'messages_de.properties' in the same package with the following text for content.
	__8.  Make sure all files are saved and closed.
	__9.  Make sure the contents of the com.webagesolutions.i18n package match that shown below.
	__10.  Create a new class in the com.webagesolutions.i18n package called LocalizedMessages and include a main method.
	__11.  Inside the main method, obtain the resource bundles for various locales, as shown:
	__12.  Organize imports.
	__13.  Output a welcome message in the various locales as shown:
	__14.  Organize imports. Select java.util.logging.Logger.
	__15.  Save the class.
	__16.  Run the LocalizedMessages class as Java Application.
	__17.  Examine the output.
	__18.  Close all open files.

	Part 4 -  Summary

	Lab 11 -  Date and Time API
	Part 1 -  Import Starting Project
	__1.  If Eclipse is not already running, from C:\Software\eclipse execute eclipse.exe.  Use the workspace C:\workspace
	__2.  From the menu, select File → Import.
	__3.  Expand and select General → Existing Projects into Workspace and click the Next button.
	__4.  Select the radio button next to the Select archive file option and use the matching Browse button to find and open the file 'C:\LabFiles\DateProject-Starter.zip'.
	__5.  Select the project listed in the file if it is not already as shown below.
	__6.  Press the Finish button to import the project.
	__7.  Switch to the Java perspective if not open already by selecting Window → Perspective → Open Perspective → Java.

	Part 2 -  Work With LocalDate
	__1.  Expand DateProject from the Package Explorer view.
	__2.  In the project expand DateProject → src → com.webage.date and open the LocalDateExample.java file.  Right now there is just some basic code to gather input but nothing is done with it.
	__3.  Modify the code of the 'main' method to add the code in bold below.
	__4.  Save the code and make sure you don't have any errors before moving on.
	__5.  With the LocalDateExample class still open, select Run → Run As → Java Application.
	__6.  In the Console view, enter some valid data based on the prompts.  You may need to click the cursor inside the Console view before you can enter anything.  Check that a LocalDate is constructed and output.
	__7.  Back in the 'main' method add the following bold code to declare a LocalDate of the current date and perform some calculations comparing the date you picked with the current date.
	__8.  Save the code and make sure you don't have any errors.
	__9.  From the Eclipse menus, select 'Run → Run History → LocalDateExample'
	__10.  Again enter a date in the Console view.  Examine some of the data printed out about the date you picked.  Try running the class a few times and picking different dates to see the different results.
	__11.  Back in the 'main' method add the following bold code to declare a LocalDate of July 4th and perform some calculations with the current date.
	__12.  Save the code and make sure you don't have any errors.
	__13.  From the Eclipse menus, select 'Run → Run History → LocalDateExample'
	__14.  Again enter a date in the Console view.  The one line that was added to the output is the last one about July 4th which won't be affected by the date you entered.
	__15.  Close any open files.

	Part 3 -  Work With LocalTime
	__1.  In the project expand DateProject → src → com.webage.date and open the LocalTimeExample.java file.  Right now there is just some basic code to gather input but nothing is done with it.
	__2.  Modify the code of the 'main' method to add the code in bold below.
	__3.  Save the code and make sure you don't have any errors before moving on.
	__4.  With the LocalTimeExample class still open, select Run → Run As → Java Application.
	__5.  In the Console view, enter some valid data based on the prompts.  You may need to click the cursor inside the Console view before you can enter anything.  You will need to enter the hour as on a 24 hour clock.  Check that a LocalTime is constructed and output.
	__6.  Back in the 'main' method add the following bold code to declare a LocalTime of the current time and perform some calculations comparing the time you picked with the current time.
	__7.  Save the code and make sure you don't have any errors.
	__8.  From the Eclipse menus, select 'Run → Run History → LocalTimeExample'
	__9.  Again enter a time in the Console view.  Examine some of the data printed out about the time you picked.  Try running the class a few times and picking different times to see the different results.
	__10.  Close any open files.

	Part 4 -  Work With Time Zone
	__1.  In the project expand DateProject → src → com.webage.date and open the TimeZoneExample.java file.  
	__2.  Modify the code of the 'main' method to add the code in bold below.  This will simple define some 'ZoneId' objects used in later code.
	__3.  Modify the 'main' method further with the following bold code.
	__4.  Save the code and make sure you don't have any errors.
	__5.  With the TimeZoneExample class still open, select Run → Run As → Java Application.
	__6.  Check that you see the correct output in the Console view which should show the time of departure in Boston to be three hours later on the next day.  Also note how the time zone offset (7 and 4 here) is part of the output.
	__7.  Return to the 'main' method and add the following code in bold.  Be careful of the syntax as several lines shown below wrap because of space.
	__8.  Save the code and make sure you don't have any errors.
	__9.  From the Eclipse menus, select 'Run → Run History → TimeZoneExample'
	__10.  Check that you see the correct output in the Console view.  The order of things being printed out is reversed but again both are 3 hours offset and 5 hours 30 minutes later than the departure times.
	__11.  Go back to the 'main' method and make the following bold change near the beginning for the date of the flight.  Make sure to use March 8th, 2014 as this will show adjustment for daylight saving time.
	__12.  Save the code and make sure you don't have any errors.
	__13.  From the Eclipse menus, select 'Run → Run History → TimeZoneExample'
	__14.  Check that you see the correct output in the Console view.  Note that the time zone offsets that are listed change from 8 & 5 to 7 & 4, representing the adjustment to daylight time while the flight was in the air.  Also note the arrival times are an hour later than when the flight departed in June because of the hour added by the daylight time adjustment.
	__15.  Close any open files.

	Part 5 -  Review

	Lab 12 -  Threading and Synchronization
	Part 1 -  Procedure
	__1.  Expand AdvJava project.
	__2.  In the existing package com.webagesolutions.synch, open the class called SharedBean
	__3.  In this class create a single int property called value.  
	__4.  Create a setter and getter method for ‘value’.  
	__5.  Check that your class appears as shown below.
	__6.  Save the class and make sure there are no errors in the class.
	__7.  Inside the same package, open another class called Incrementor, which implements the Runnable interface. 
	__8.  Define an instance variable in Incrementor called bean that holds a reference to an instance of SharedBean as shown in the bold code below.
	__9.  Implement the constructor that takes an instance of SharedBean and stores it in ‘bean’.
	__10.  Implement the run() method in Incrementor as shown below:
	The code above sits in a loop, incrementing the SharedBean’s value property every 75 milliseconds or so.
	__11.  Save the class.
	__12.  Switch to SharedBean class and modify in SharedBean class the setValue() method to flag cases where the new value is not the increment of the current value, as shown below:
	__13.  Save the class.
	__14.  Open the com.webagesolutions.synch.RunIncrementors class, which was included in the LabStarterFiles project, and inspect the existing code.  This class creates two existing Incrementor classes and runs them both.
	__15.  Run the RunIncrementors class as a Java application (Run → Run As → Java Application) and inspect the output.  You will likely see many cases where there are ‘bad’ increments because of the concurrent access.
	__16.  Modify the Incrementor class’s run() method to synchronize against the bean for the entire operation. Add in the synchronized block shown in bold face below:
	__17.  Save and make sure there are no errors.
	__18.  Run the RunIncrementors class again.  Do we still get bad increments? Why or why not?
	__19.  Close all open files.

	Part 2 -  Summary

	Lab 13 -  Java Concurrency Features
	Part 1 -  Lab Setup
	__1.  Open Eclipse if it is not already running.
	__2.  Select File → Import from the Eclipse menus.
	__3.  Expand the General group and select Existing Projects into Workspace and press the Next button.
	__4.  Select the radio button next to the Select archive file option and use the matching Browse button to find and open the file 'C:\LabFiles\AdvConcurrency-Starter.zip'.
	__5.  Select the project listed in the file if it is not already as shown below.
	__6.  Press the Finish button to import the project.

	Part 2 -  Use ExecutorService
	__1.  In Eclipse, expand the 'AdvConcurrency → src → com.webage.executor' package and open the 'RunnableCounter.java' file.
	__2.  Notice that this class is just a standard implementation of the 'Runnable' interface.
	__3.  Find the currently empty 'run' method and add the following bold code to complete the implementation.  You will have errors until the next step.
	__4.  Organize imports (CTRL+SHIFT+O).
	__5.  Save the file and make sure there are no errors in this class.
	__6.  Open the 'ExecutorThreadPoolTest.java' file in the 'com.webage.executor' package.
	__7.  In the 'main' method, find the comment for the 'single thread executor' and add the following bold code.  This will use the 'Executors' class to get an instance of an 'ExecutorService'.
	__8.  Under the first comment for 'loop to execute runnable counters' as shown below add the following bold code.  This will create instances of the 'RunnableCounter' class you completed and execute them with the 'ExecutorService' instance you just obtained.
	__9.  Find the comment for 'shutdown single thread executor and await termination' and add the following bold code.  This will initiate shutdown and timeout if it takes too long.
	__10.  Save this class and make sure there are no errors.  Ignore the "thread pool" comments as we will add those after testing the single thread executor.
	__11.  With the 'ExecutorThreadPoolTest' class active in the Java editor, select 'Run → Run As → Java Application' from the Eclipse menus.
	__12.  It could take several seconds but you should eventually see many messages from the 'RunnableCounter' instances with the sum values and then a message about how long the 'single thread execution' took.  You can ignore the 'pool execution' as we haven't used that yet.
	__13.  Return to the 'main' method of the 'ExecutorThreadPoolTest' class, find the comment for the 'thread pool executor' and add the following bold code.  This will get an instance of the 'ExecutorService' interface which will use a thread pool.  Notice this uses a value that was declared as a constant already in the class.
	__14.  Under the comment for 'loop to execute runnable counters' add the following bold code.  This will again create instances of the 'RunnableCounter' class and execute them with the thread pool 'ExecutorService' instance you just obtained.
	__15.  Find the comment for 'shutdown thread pool executor and await termination' and add the following bold code.  This will initiate shutdown and timeout if it takes too long.
	__16.  Save this class and make sure there are no errors.  
	__17.  With the 'ExecutorThreadPoolTest' class active in the Java editor, select 'Run → Run As → Java Application' from the Eclipse menus.
	__18.  After several seconds you should see the messages about how long each of the types of execution took.  Depending on the hardware of your machine (in particular the presence of a multi-core processor) you may see a difference or not in the results and the single thread executor may even perform slightly better.
	__19.  If you want, you can go back and change the value of the 'NUM_THREADS' constant at the top of the class, save the file and run it again.
	__20.  Close all open files.

	Part 3 -  Use Callable and Future
	__1.  Expand the 'AdvConcurrency → src → com.webage.future' package.
	__2.  Right click the 'com.webage.future' package and select 'New → Class'.
	__3.  Fill in 'CallableAdder' for the class name but don't yet create the class.
	__4.  Next to the empty list of interfaces click the Add button.
	__5.  In the dialog that appears, type in 'callable' in the top box, pick the 'Callable' interface from the java.util.concurrent package that appears, and click the OK button.
	__6.  The cursor should appear in the line of the interface you just added.  Use it to change the 'Callable<V>' line to 'Callable<Long>' as shown below.
	__7.  Once your settings for the new class match those shown above click the Finish button.
	__8.  In the new class replace the implementation of the 'call' method with the bold code below.  Notice this code does not use the 'Future' interface as that will be done for you.
	__9.  Save the 'CallableAdder' class and make sure there are no errors in the class.
	__10.  Open the 'FutureTest.java' file in the 'com.webage.future' package.
	__11.  In the 'main' method, find the comment for the 'loop to add Callable Adders to a Future result list' and add the following bold code.  This will create instances of the 'CallableAdder' class and submit them to be processed by the executor.  The 'Future' objects that are returned are added to a list to process later in the code.  
	__12.  Look at the 'while' loop near the end of the 'main' method.  Even though there is no code you need to complete here, notice how it loops through the results, checks to see if each one is "done" (this is a method of the 'Future' object) and if it is adds the result to the running total and removes the 'Future' object from the list.  The idea of this code is that if a result were not done it would be skipped but left in the list and the loop would come back to it later.  This shows the asynchronous behavior of the 'Future' object.
	__13.  Save this class and make sure there are no errors. 
	__14.  With the 'FutureTest' class active in the Java editor, select 'Run → Run As → Java Application' from the Eclipse menus.
	__15.  You should fairly quickly get messages back about the size of the list of results and the total sum that was computed.
	__16.  Close all open files.

	Part 4 -  Use Atomic Operations
	__1.  Expand the 'AdvConcurrency → src → com.webage.atomic' package and open the 'SharedBean.java' file.
	__2.  Near the top of the class, find the comment for 'add field for AtomicInteger' and add the following bold code.  You will have some errors until the next step.  Rather than just  regular 'int' or 'Integer' value we use the 'AtomicInteger' class to track the data that will be accessed concurrently.
	__3.  Organize imports (CTRL+SHIFT+O).
	__4.  Find the comment for 'add getValue method' and modify the implementation as shown in bold below.  Notice how we use the 'get' method of the 'AtomicInteger' class to return the data that is being stored.
	__5.  Find the currently empty 'increment' method and add the following bold code to implement the method.  Notice the use of the 'compareAndSet' method that is provided by AtomicInteger.
	__6.  Save the file and make sure there are no errors in this file.
	__7.  Open the 'Incrementor.java' file in the 'com.webage.atomic' package.
	__8.  Notice that this is a fairly basic implementation of the 'Runnable' interface which takes an instance of the 'SharedBean' class and increments it several hundred times with waiting added between increments.  There is no code you need to add to this class.
	__9.  Open the 'RunIncrementors.java' file in the 'com.webage.atomic' package.
	__10.  Notice that this code has a 'main' method and will create two instances of the 'Incrementor' class that will shared the same instance of the 'SharedBean' class.  These will both be executed with an Executor.
	__11.  With the 'RunIncrementors' class active in the Java editor, select 'Run → Run As → Java Application' from the Eclipse menus.
	__12.  As it runs you should see lots of messages about all of the increments that are performed.  At no point should you see a message about a "bad increment" that was performed.
	__13.  Expand the 'AdvConcurrency → src → com.webage.atomic' package and delete the 'SharedBean.java' file, confirming the deletion when asked.  You will have several errors after doing this but it is an easy way to find out what must be changed.
	__14.  Open the 'RunIncrementors.java' file in the 'com.webage.atomic' package if not already open.
	__15.  Modify the code in the 'main' method as shown below.  This will change the type of the object for the 'bean' variable.  You will have errors until the next step.
	__16.  Organize imports (CTRL+SHIFT+O).
	__17.  Save the 'RunIncrementors.java' file.  You will still have errors but this will be fixed when you modify the 'Incrementor' class next.
	__18.  Open the 'Incrementor.java' file in the 'com.webage.atomic' package if not already open.
	__19.  In the 'Incrementor' class, modify the type of the 'bean' field of the class and the type of the parameter to the constructor as shown in bold below.  There are two changes being introduced here.
	__20.  Organize imports (CTRL+SHIFT+O).  You will still have one more error in the file fixed next.
	__21.  Find the code near the end of the 'run' method and change the call of 'bean.getValue' to 'bean.longValue' as shown in bold below.  This will properly use the API of the LongAdder class.
	__22.  Save the code.  At this point you should no longer have any errors in any files.
	__23.  From the Eclipse menus, select 'Run → Run History → RunIncrementors'.
	__24.  Check that you get the output shown below.  It is the same as before but you used the LongAdder class built into Java 8 instead of needing a custom class.
	__25.  Close all open files.

	Part 5 -  Review

	Lab 14 -  Java Fork & Join
	Part 1 -  Recursively Find the Maximum in an Array
	__1.  Expand the 'AdvConcurrency → src → com.webage.forkjoin' package and open the 'BigNumberList.java' file.
	__2.  Examine the code in this class.  Notice it is just a way to create an array of random integer values in a fairly large range.  This will be used by the other classes for the "problems" they are trying to solve.
	__3.  Open the 'MaxNumberProblemSolver.java' file in the 'com.webage.forkjoin' package.
	__4.  In the class declaration, add the code in bold below so the class extends the 'RecursiveTask<Integer>' class.  You will have errors until the next few steps.
	__5.  Find the comment 'implement compute method' and add the new method implementation as shown in bold code below.  This 'compute' method returns the result of the task.  Notice the code that will split the problem in half, then use the 'fork' and 'join' methods on one half to process it.  Make sure you do not add this method inside the declaration of other methods.
	__6.  Examine the 'computeDirectly' method in the class that is already provided for you. Notice this will simply find the maximum number in an array and is called by the main 'compute' method once the problem is broken down small enough.
	__7.  Save the file and make sure you don't have any errors.
	__8.  Open the 'ForkJoinTest.java' file in the 'com.webage.forkjoin' package.
	__9.  In the 'main' method, find the comment for the “Add declaration of ForkJoinPool using 'common' pool” and add the following bold code.  This will use the “common” ForkJoinPool added with Java 8.
	__10.  In the 'main' method, find the comment for the 'create MaxProblemSolver instance' and add the following bold code.  The will use the list of random integers with the 'MaxNumberProblemSolver' class you just implemented with a recursive Fork/Join algorithm.
	__11.  Find the comment 'modify to invoke ForkJoinPool on task' and change how the 'maximumResult' variable is initialized as shown in the bold code below.  This will ask the ForkJoinPool to invoke the task that was created and return the result.
	__12.  Save the file and make sure you don't have any errors.
	__13.  With the 'ForkJoinTest' class active in the Java editor, select 'Run → Run As → Java Application' from the Eclipse menus.
	__14.  In the Console view, ignore the messages about sorting the array since we haven't implemented that yet and scroll back to the messages from calculating the maximum in the array.  Your value may be different but you should see that it is a number very close to 500,000.  Also note the number of recursive splits of the problem in what should be a very short processing time.  If you run the code several times the processing time may even improve further.

	Part 2 -  Recursively Sort an Array
	__1.  Open the 'ArraySorter.java' file in the 'com.webage.forkjoin' package.
	__2.  In the class declaration, add the code in bold below so the class extends the 'RecursiveAction' class.  You will have errors until the next few steps.
	__3.  Find the comment 'implement compute method' and add the new method implementation as shown in bold code below.  This 'compute' method does not return any result but performs the action of the class.  Notice the code that will split the problem in half, then call 'invokeAll' on both halves to trigger the fork/join processing.
	__4.  Examine the 'mergeResults' method in the class that is already provided for you. Notice this will simply merge the results of the two smaller sorted arrays back into one.
	__5.  Save the file and make sure you don't have any errors.
	__6.  Open the 'ForkJoinTest.java' file in the 'com.webage.forkjoin' package.
	__7.  In the 'main' method, find the comment for the 'create ArraySorter instance' and add the following bold code.  The will use the list of random integers with the 'ArraySorter' class you just implemented with a recursive Fork/Join algorithm.
	__8.  Find the comment 'invoke ForkJoinPool on task' and add the new line as shown in the bold code below.  This will ask the ForkJoinPool to invoke the task that was created.  Notice that no result is returned from the 'invoke' method.
	__9.  Find the comment 'modify to get sorted list from ArraySorter' and change how the 'sorted' variable is initialized as shown in the bold code below.  This will ask the ArraySorter instance that was created and finished running what the sorted numbers are.
	__10.  Save the file and make sure you don't have any errors.
	__11.  With the 'ForkJoinTest' class active in the Java editor, select 'Run → Run As → Java Application' from the Eclipse menus.
	__12.  In the Console view, check the messages from the sorting portion of the test class that the message 'Sorted list has maximum in last position' is shown.  This should verify that the list is sorted if the maximum value ends up in the last position.  Also note the number of recursive splits of the problem in what should be a very short processing time.
	__13.  Close all open files.

	Part 3 -  Review

	Lab 15 -  Parallel Streams
	Part 1 -  Convert to Stream API 
	__1.  In the project expand LambdaProject → src → com.webage.lambda.parallel and open the ParallelTest.java file.
	__2.  Find the 'convertOldStyle' method and examine the code.  Currently this is being called from the 'main' method.
	__3.  With the ParallelTest class still open, select Run → Run As → Java Application.
	__4.  Make sure the output in the Console view matches that shown below.  You should see two employees output and the total salary.
	__5.  In the ParallelTest class, add the start and end to a block comment as shown in bold below to comment out the entire 'for' loop.
	__6.  Save the code and make sure there are no errors so you know the loop is commented out properly.
	__7.  After the commented out section but before the print statement, add the following bold code.  This is not quite the exact same logic yet but it does sum the salaries of employees.
	__8.  Save the file and make sure there are no errors.
	__9.  From the Eclipse menus select Run → Run History → ParallelTest.
	__10.  Make sure the output matches that shown below.  There are no employees printed out and we clearly have a different sum but at least it is showing a total of salaries.
	__11.  Back in the code, add the following two 'filter' method calls in the middle of the chain of method calls.  Make sure to place them in the correct location, after the stream is obtained but before the mapping to double for the salary.
	__12.  Save the file and make sure there are no errors.
	__13.  From the Eclipse menus select Run → Run History → ParallelTest.
	__14.  Make sure the output matches that shown below.  Note that now the correct filtering is being done to match the condition in the 'if' statement from before, the correct total salary is being obtained.  You still don't have the employees output though.
	__15.  Back in the code, add the following 'peek' method call in the middle of the chain of method calls.  Make sure to place it in the correct location, after the filtering is applied but before the mapping to double for the salary.  This will print out only the employees that match the filter conditions.
	__16.  Save the file and make sure there are no errors.
	__17.  From the Eclipse menus select Run → Run History → ParallelTest.
	__18.  Make sure the output matches that shown below.  Now you should be back to the output from before.  The only thing missing is doing it in any kind of parallel processing.
	__19.  Back in the code, add the following 'parallel' method call in the middle of the chain of method calls.  Make sure to place it in the correct location, after the mapping but before the call to the terminal 'sum' method.
	__20.  Save the file and make sure there are no errors.
	__21.  From the Eclipse menus select Run → Run History → ParallelTest.
	__22.  Make sure the output matches that shown below.  Although the output isn't any different, behind the scenes it is being done in parallel.

	Part 2 -  Avoid Stateful Operations
	__1.  In the main method of the ParallelTest class, modify the code to match that shown below.  This will call a private method that you will implement next.
	__2.  In the ParallelTest class, find the existing 'avoidStateful' method and add to the existing code what is shown in bold below.  The reason this is the “bad” way to do things is any matching elements are added to the existing list created outside of the stream.  In parallel there might be several threads trying to concurrently modify the same List.
	__3.  Further down in the 'avoidStateful' method, add to the existing code what is shown in bold below.  This code is better because the 'collect' method and 'Collectors.toList' parameter indicates that the results should be returned in a List that is constructed BY THE STREAM and the 'newList2' variable is simply set to refer to the List returned from the stream.
	__4.  Save the file and make sure there are no errors.
	__5.  From the Eclipse menus select Run → Run History → ParallelTest.
	__6.  Make sure the output matches that shown below.  Although the output is the same in both cases, the important thing is that the way the operation is done in the second example would be much safer to execute in parallel.

	Part 3 -  Non-Deterministic Operations
	__1.  In the main method of the ParallelTest class, modify the code to match that shown below.  This will call a private method that you will implement next.
	__2.  In the ParallelTest class, find the existing 'nonDeterministic' method and add to the existing code what is shown in bold below.  The main operation here is the 'findAny' operation which is non-deterministic.  Note that one stream is done sequentially while the other is done in parallel and a test is done to see if the result is the same.
	__3.  Save the file and make sure there are no errors.
	__4.  From the Eclipse menus select Run → Run History → ParallelTest.
	__5.  You may need to run the test several times but you should be able to get a result where the returned values from the two stream operations do not match as shown below.

	Part 4 -  Reduction Operations
	__1.  In the main method of the ParallelTest class, modify the code to match that shown below.  This will call a private method that you will implement next.
	__2.  In the ParallelTest class, find the existing 'demoReduction' method and add to the existing code what is shown in bold below.  Note that one result is calculated sequentially while the second is done in parallel.
	__3.  Save the file and make sure there are no errors.
	__4.  From the Eclipse menus select Run → Run History → ParallelTest.
	__5.  Check that the output matches that shown below.  Since addition is associative, the result from parallel processing is the same as sequential.
	__6.  Modify the code in the 'demoReduction' method to change the function performed from addition to subtraction as shown in below [result - element].  Subtraction is not associative so reduction is expected to not function correctly in parallel processing.
	__7.  Save the file and make sure there are no errors.
	__8.  From the Eclipse menus select Run → Run History → ParallelTest.
	__9.  Check that the output matches that shown below.  Note that the results differ between sequential and parallel processing.  You can run the test several times and it should always return results that differ.
	__10.  Close all open files. 

	Part 5 -  Review

	Lab 16 -  Networking with Sockets
	Part 1 -  Main Connection Loop
	__1.  Expand AdvJava project.
	__2.  Create a new package in your project called com.webagesolutions.socks
	__3.  Create a new class in this package, called Responder and create the class with a ‘public static void main(String[] args)’ method.  This class will contain the overall server code that listens for connections and delegates to a handler.
	__4.  Create another new class in the com.webagesolutions.socks package called ResponderHandler that implements the java.lang.Runnable interface.
	__5.  Create a constructor in ResponderHandler that takes a java.net.Socket as its argument, and stores the supplied socket in a private instance variable called socket.
	__6.  Organize imports and save the class.
	__7.  In the main(…) method of the Responder class, declare a variable called serverSocket and initialize it with a new instance of a java.net.ServerSocket attached to port ‘10001’ as shown in bold below.
	__8.  Add the bold code below to declare a variable called threadPool to reference a new instance of a cached thread pool:
	__9.  Add a line to print out a message so you will be able to tell that the Responder is awaiting connections.
	__10.  Add code to repeatedly accept a connection on the socket, create a ResponderHandler based on that connection, then submit the handler to the thread pool for execution:
	__11.  Organize imports to resolve errors relating to imports.  You will still have other errors.
	__12.  Surround the code in try and catch in the main method of Responder.  The easiest way to do this is to highlight the lines of code in the 'main' method, right click, and select Surround with → Try/catch Block.
	__13.  Now that you have the 'try/catch' block, move the declaration and initialization of the serverSocket variable so that it is a "try-with-resources" statement.  Notice that you will need to delete the line inside the 'try' block and add it back in within parenthesis immediately after the 'try' keyword.
	__14.  Save the class. There should be no errors in this class.

	Part 2 -  Connection Handler
	__1.  Return to the ResponderHandler class and implement the run(..) method as follows.  Note that the 'inputScanner' and 'output' variables are declared and initialized within a 'try‑with‑resources' statement.
	__2.  Organize imports and select java.util.Scanner when prompted.
	__3.  Save the file. There should be no errors in any class. 
	__4.  Run the ‘Responder’ class.  It will stay running while you finish the client code in the next section.

	Part 3 -  Console Client
	__1.  Create a new class called Sender in the com.webagesolutions.socks package.  Create the class with a ‘public static void main(String[] args)’ method.
	__2.  Insert the following into the main method.  Notice there are lots of resources declared and initialized within the 'try‑with‑resources' statement.
	__3.  Organize imports and select java.util.Scanner and java.io.DataOutputStream when prompted.
	__4.  Save the class and make sure there are no errors.
	__5.  Verify that the Responder class is running.
	__6.  Now run the Sender class.
	__7.  You may need to select the required console in the Eclipse console window, since you have more than one Java program running.  To do so, click on the select-console drop down box, and select the console you want to see:
	__8.  In the Sender console type   Testing 1,2,3   and hit Enter. 
	__9.  The Responder console will show:
	__10.  Switch back to the Sender console again and notice the response received there is all upper case.
	__11.  In the Sender console again, type    Send to upper case   and hit Enter.
	__12.  Finally, in the Sender console, type  bye  and hit Enter. 
	__13.  Your Responder console should show:
	__14.  Your Sender console should look like this:
	__15.  Close all open files.
	__16.  Click the Terminate button.
	__17.  Remove all terminated launches by clicking the Remove All Terminated Launches button.
	__18.  You probably will have to Terminate and remove all Launches more than one time until the Console is empty. 

	Part 4 -  Review

	Lab 17 -  Distributed Objects with RMI
	Part 1 -  Procedure
	__1.  Before starting this Lab, terminate all programs running in the Console. Click the Terminate button.
	__2.  Remove all terminated launches by clicking the Remove All Terminated Launches button.
	__3.  You probably will have to Terminate and Remove All Launches more than one time until the Console is empty. Make sure nothing is running in the Console.
	__4.  Expand the AdvJava project.
	__5.  In the com.webagesolutions.rmi package, create a new class called RemoteUserStoreService that extends from java.rmi.server.UnicastRemoteObject superclass and implements the RemoteUserStore interface.  Have the wizard generate a 'main' method and stub methods for all the inherited abstract methods. 
	__6.  Once your 'New Java Class' wizard appears as shown above, click the Finish button to create the class.
	__7.  Add the following constructor to RemoteUserStoreService.  Note that the constructor throws RemoteException, since the superclass constructor is declared to throw RemoteException.
	__8.  Save the file but leave it open.  You should have no compilation errors at this point although you may still have warnings.
	__9.  Declare an instance variable called userStore in RemoteUserStoreService that references an instance of UserStore and initialize it to a new instance of InMemoryUserStore as shown in bold below.
	__10.  Organize imports.
	__11.  Add code to the stub methods that were added, such that they delegate the method call to the object referenced by ‘userStore’.  This would be similar to the bold code shown below.  Make sure you match the correct implementation below with the correct method.  
	__12.  Add the following implementation of the main method to RemoteUserStoreService.  It creates a new instance of RemoteUserStoreService and registers it with the rmi naming service.
	__13.  Organize imports, select java.rmi.AlreadyBoundException.
	__14.  Save the class and make sure there are no errors.  You may have warnings.
	__15.  We need to start the rmi naming daemon.  In the Package Explorer, expand the node for JRE System Library…, then expand the node for rt.jar.  
	__16.  Under the “rt.jar” node, expand the package sun.rmi.registry.  
	__17.  Finally locate the class called RegistryImpl under this package.  This class is the implementation class that actually runs when you start ‘rmiregistry’ from the command line.  
	__18.  Right click on RegistryImpl.class and select Run As.. -> Run Configurations...
	__19.  In the left scroll and select Java Application.
	__20.  Click New Launch Configuration.
	__21.  Click the Browse button next to Project.
	__22.  Select AdvJava and click OK.
	__23.  Make sure RegistryImpl is Name.
	__24.  Make sure sun.rmi.registry.RegistryImpl is Main class.
	__25.  Make sure your configuration looks like this:
	__26.  Click the Apply button in the lower right if enabled.
	__27.  Click Run.
	__28.  There will be no output in the console window, but the registry daemon is now running.
	__29.  Run your RemoteUserStoreService class as Java Application.  The output console should display the following:
	__30.  In the AdvJava project, there is a class that exercises the RemoteUserStoreService class. Open and examine the com.webagesolutions.users.TestRemoteUserStoreService class.
	__31.  Right click on it and select Run As > Java Application. 
	__32.  The output should be (browse back):
	__33.  Remove all terminated launches by clicking the Remove All Terminated Launches button.
	__34.  As you did in the beginning of this lab, terminate running processes in the Console by clicking the Terminate button.
	__35.  You probably will have to Terminate and Remove All Launches more than one time until the Console is empty. Make sure nothing is running in the Console.
	__36.  Close all open files.

	Part 2 -  Summary

	Lab 18 -  JAAS Security
	Part 1 -  The Login Code
	__1.  Right click on your AdvJava project and select Properties.
	__2.  In the project properties, go to the Java Build Path settings on the left and select the Libraries tab on the right.
	__3.  Select the 'JRE System Library' from the list of libraries and click the Remove button on the right.
	__4.  Click the Apply button in the lower right to apply the changes but leave the dialog window open.
	__5.  On the right click the 'Add Library' button.
	__6.  Select the 'JRE System Library' option and click the Next button.
	__7.  Select the 'Workspace default JRE' if not already selected and click the Finish button.
	__8.  Click OK.
	__9.  Create a new package called com.webagesolutions.security in your AdvJava project.
	__10.  Create a new class called Login in the new package above.  Include a public static void main(String[] args) method.
	__11.  Add the following bold code into the main() method:
	__12.  Surround the code in a try-catch block.  You can use 'Source → Surround With → Try/catch Block' after selecting all of the code if you want.
	__13.  Organize imports to add the required import statements for the external classes
	__14.  Save the class.  Make sure there are no errors.  You will get a warning about the DialogCallbackHandler class being deprecated that can be ignored.

	Part 2 -  Login Configuration
	__1.  Run the Login class as a Java application.  
	__2.  You will get an exception similar to the following:
	__3.  Right click on the AdvJava project in the project explorer, and select New -> File.  
	__4.  Enter Login.acn as the file name, and click Finish.
	__5.  Add the following text into the new file:
	__6.  Save the file.
	__7.  Right click on the Login class and select Run As -> Run Configurations… to edit the runtime configuration for this class.  
	__8.  If a 'Login' configuration does not appear in the configuration list then click 'New launch configuration' then set the 'Project' and 'Main class' settings to match that shown above.
	__9.  Make sure the Login node is selected, and click on the Arguments tab. 
	__10.   Enter the virtual machine argument shown below:
	__11.  Click the Apply button in the lower right corner and then click Run.  
	__12.  The console window should display output similar to:

	Part 3 -  Implement Custom Login Module
	__1.  Expand the 'com.webagesolutions.users' package in the 'AdvJava' project.
	__2.  Open the 'UserLoginModule.java' file.  Ignore the warnings in the file.
	__3.  Find the current implementation of the 'initialize' method and add the bold code below.  This will initialize the list of users we will authenticate against.
	__4.  Find the current implementation of the 'login' method.  After the comment for 'Get a user name and password' add the following bold code.  This will define the elements of the dialog box that will popup to include prompts for email and password.
	__5.  Find the next comment for 'Perform the callbacks' and add the following bold code.  This will end up displaying the dialog box to prompt for credentials.
	__6.  Find the last comment in the 'login' method for 'Authenticate against our user store' and add the following bold code.  Note that you will need to remove the 'return false;' statement that was present before to replace it with the given logic.  This code is taking the email and password information supplied from the popup dialog and 
	__7.  Find the current implementation of the 'commit' method and replace it with the bold code below.  Note that you will need to remove the 'return false;' statement that was present before to replace it with the given logic.  This code creates a 'Principal' object to associate with the authenticated identity using the name that was obtained from our user store.
	__8.  Find the current implementation of the 'logout' method and replace it with the bold code below.  Note that you will need to remove the 'return false;' statement that was present before to replace it with the given logic.  This code resets some of the fields of the LoginModule just to make sure we are back to the state before the login occurred.
	__9.  Save the 'UserLoginModule.java' file and make sure there are no errors.  You may have warnings.
	__10.  Open the Login.acn file if you do not still have it open.
	__11.  Edit the Login.acn file to read as follows:
	__12.  Save the file.
	__13.  Run the Login program again, you can do it by clicking the green run button in the menu bar.  
	__14.  You should now see a dialog box presented.  
	__15.  Enter an email of ‘waldoj@sun.com’ and a password of ‘note’.  
	__16.  Click OK. 
	__17.  The login should succeed. 
	__18.  Try to run the program again with the same email but a different password.  You should get an exception thrown by the 'UserLoginModule' indicating a bad password.
	__19.  Run the program again and this time supply an email address that is not in the user store.  You should get an Exception about a bad email.
	__20.  Close all open files.
	__21.  Terminate all running process in the Console.


	Part 4 -  Summary

	Lab 19 -  Input/Output with NIO and NIO.2
	Part 1 -  Lab Setup
	__1.  Open Eclipse if it is not already running.
	__2.  Select File → Import from the Eclipse menus.
	__3.  Expand the General group and select Existing Projects into Workspace and press the Next button.
	__4.  Select the radio button next to the Select archive file option and use the matching Browse button to find and open the file 'C:\LabFiles\NIO-Starter.zip'. 
	__5.  Select the project listed in the file if it is not already as shown below.
	__6.  Press the Finish button to import the project.

	Part 2 -  Work With a Path
	__1.  In Eclipse, expand the 'AdvNIO → src → com.webage.nio' package and open the 'FileOperations.java' file.
	__2.  Add a new method to the class as shown below.  Make sure you add this method inside the brackets for the class but outside the brackets for the currently empty 'run' method.  You will have errors until future steps.
	__3.  Organize imports (CTRL+SHIFT+O).
	__4.  Add the following bold code to the empty 'run' method that is already defined.  This will use the root path returned from the other method to locate the 'LabFiles' directory using the 'Paths.get' method.  The path to this directory will then be printed out.
	__5.  Save the file and make sure there are no errors in this class.
	__6.  Open the 'NIOFileSystemDriver.java' file in the 'com.webage.nio' package.  Note that this class simply creates an instance of the 'FileOperations' class and calls the 'run' method.
	__7.  With the 'NIOFileSystemDriver' class active in the Java editor, select 'Run → Run As → Java Application' from the Eclipse menus.
	__8.  In the Eclipse 'Console' view you should get output similar to the following.

	Part 3 -  List Files in a Directory
	__1.  Expand the 'AdvNIO → src → com.webage.nio' package and open the 'FileNamePrinter.java' file.  Notice the class is currently just some simple code with a 'Set' of Strings for an 'excludes' list and a field to count a number of files.
	__2.  In the class declaration, add the code in bold below so the class extends the 'SimpleFileVisitor<Path>' class.  You will have errors until the next few steps.
	__3.  Find the comment 'override methods' and add the new method as shown in bold code below.
	__4.  Organize imports (CTRL+SHIFT+O).
	__5.  Save the file and make sure you don't have any errors.
	__6.  Return to the 'run' method of the 'FileOperations' class, opening the file if you had closed it.  Add the following bold code.  You will have errors until future steps.
	__7.  Add a new method to the class as shown below.  Make sure you add this method inside the brackets for the class but outside the brackets for any other method.  You will have errors until future steps.
	__8.  Organize imports (CTRL+SHIFT+O).
	__9.  Save the file and make sure you don't have any errors.
	__10.  From the Eclipse menus select 'Run → Run History → NIOFileSystemDriver'.
	__11.  The 'Console' view should print several files and then the total number of files in the 'LabFiles' directory.  This number may vary from what is shown below.
	__12.  Return to the 'FileNamePrinter' class.
	__13.  Add a new method to the class as shown below.  Make sure you add this method inside the brackets for the class but outside the brackets for any other method.  
	__14.  Save the file and make sure you don't have any errors.
	__15.  Return to the 'printFiles' method of the 'FileOperations' class.
	__16.  Modify the first few lines of the method as shown in bold below.  Make sure to change the way the 'FileNamePrinter' constructor is called even though the rest of the line does not change.  You will have errors until future steps.
	__17.  Organize imports (CTRL+SHIFT+O).
	__18.  Save the file and make sure you don't have any errors.
	__19.  From the Eclipse menus select 'Run → Run History → NIOFileSystemDriver'.
	__20.  The 'Console' view should print several files and then the total number of files in the 'LabFiles' directory except for the files in the excluded directories.  Your number may be different than that shown below but it should be less than the number you got previously.

	Part 4 -  Search for Files
	__1.  Expand the 'AdvNIO → src → com.webage.nio' package and open the 'FileSearcher.java' file.  Notice the class is currently just some simple code with a field to count a number of files. 
	__2.  In the class declaration, add the code in bold below so the class extends the 'SimpleFileVisitor<Path>' class.  You will have errors until the next few steps.
	__3.  In the fields of the class declaration, find the comment 'add PathMatcher' and add the following bold code to declare a new field of this type.  You will have errors until the next few steps.
	__4.  Find the constructor for the 'FileSearcher' class and add the following bold line of code to initialize the field for the PathMatcher.
	__5.  Find the comment 'override method' and add the new method as shown in bold code below.
	__6.  Organize imports (CTRL+SHIFT+O).
	__7.  Save the file and make sure you don't have any errors.
	__8.  Return to the 'run' method of the 'FileOperations' class, opening the file if you had closed it.  Add the following bold code.  You will have errors until future steps.
	__9.  Add a new method to the class as shown below.  Make sure you add this method inside the brackets for the class but outside the brackets for any other method.  You will have errors until future steps.
	__10.  Save the file and make sure you don't have any errors.
	__11.  From the Eclipse menus select 'Run → Run History → NIOFileSystemDriver'.
	__12.  The end of the output in the 'Console' view should print several files that match the pattern and then a total number of files that matched the pattern.  Your total number may be different but it should be less than the number of total files (before the exclusions) printed in the last section.
	__13.  Return to the 'run' method of the 'FileOperations' class and change the pattern to search for by changing the parameter passed to the 'findFiles' method as shown below. 
	__14.  Save the file and make sure you don't have any errors.
	__15.  From the Eclipse menus select 'Run → Run History → NIOFileSystemDriver'.
	__16.  Check that you see different files that match being printed out and a different number of files that matched.

	Part 5 -  Create Subdirectory
	__1.  Return to the 'run' method of the 'FileOperations' class, opening the file if you had closed it.  Add the following bold code to the end of the method.  You will have errors until future steps.
	__2.  Add a new method to the class as shown below.  Make sure you add this method inside the brackets for the class but outside the brackets for any other method.  You will have errors until future steps.
	__3.  Save the file and make sure you don't have any errors.  You will have a warning that can be ignored.
	__4.  From the Eclipse menus select 'Run → Run History → NIOFileSystemDriver'.  The output in the 'Console' view will not be different than last time.
	__5.  Open a Windows Explorer file browser and navigate to the 'C:\LabFiles' directory.
	__6.  Check that you have a newly created 'watched' subdirectory.

	Part 6 -  Watch Directory for New File
	__1.  Return to the 'run' method of the 'FileOperations' class, opening the file if you had closed it.  Modify the code of the method as shown in bold below.  You will have errors until future steps.
	__2.  Add a new method to the class as shown below.  Make sure you add this method inside the brackets for the class but outside the brackets for any other method.  You will have errors until future steps.
	__3.  Finish the new method implementation with the following bold code.  Make sure this code is within the brackets for the method declaration but after the other code you have already added.  You will still have errors in the code.
	__4.  Organize imports (CTRL+SHIFT+O).
	__5.  Save the file and make sure you don't have any errors.  You will have a warning that can be ignored.
	__6.  From the Eclipse menus select 'Run → Run History → NIOFileSystemDriver'.  The output in the 'Console' view will not be different than last time although you should notice that the program does not immediately finish and display '<terminated>' in the status.
	__7.  Open a Windows Explorer file browser and navigate to the 'C:\LabFiles' directory.
	__8.  Copy the 'movie.xml' file from the directory by selecting 'Edit → Copy' or using 'CTRL-C'.
	__9.  Navigate into the 'watched' subdirectory.
	__10.  Paste the file you copied into the directory by selecting 'Edit → Paste' or using 'CTRL-V'.
	__11.  Return to the 'Console' view of Eclipse.  You should now see that the process is listed as '<terminated>' and that the name of the new file you copied is printed.
	__12.  Return to the Windows Explorer file browser window and navigate to the 'C:\LabFiles' directory.
	__13.  Delete the 'watched' directory and confirm you want to delete the directory if prompted.

	Part 7 -  Copy File Contents With Buffers
	__1.  Return to the 'run' method of the 'FileOperations' class, opening the file if you had closed it.  Modify the code of the method as shown in bold below.  You will have errors until future steps.
	__2.  Add a new method to the class as shown below.  Make sure you add this method inside the brackets for the class but outside the brackets for any other method.  You will have errors until future steps.
	__3.  Add another new method to the class as shown below.  Make sure you add this method inside the brackets for the class but outside the brackets for any other method. You will have errors until future steps.
	__4.  Save the file and make sure you don't have any errors.  You will have a warning that can be ignored.
	__5.  From the Eclipse menus select 'Run → Run History → NIOFileSystemDriver'.  
	__6.  Open a Windows Explorer file browser and navigate to the 'C:\LabFiles' directory.
	__7.  Copy the 'movie.xml' file from the directory by selecting 'Edit → Copy' or using 'CTRL-C'.
	__8.  Navigate into the 'watched' subdirectory.
	__9.  Paste the file you copied into the directory by selecting 'Edit → Paste' or using 'CTRL-V'.
	__10.  You will see that two new files are created that have the same name but have a '-1' and '-2' appended to the end of the file name.  Also notice these files are empty as you haven't done anything with the file contents yet.
	__11.  Navigate back up to the 'C:\LabFiles' directory.
	__12.  Delete the 'watched' directory and confirm you want to delete the directory if prompted.
	__13.  Return to the 'makeNCopiesOfFile' method of the 'FileOperations' class, opening the file if you had closed it.  Modify the code of the end of the method as shown in bold below.  You will have errors until future steps.
	__14.  Add a new method to the class as shown below.  Make sure you add this method inside the brackets for the class but outside the brackets for any other method.  Also be careful as this code has several sets of embedded curly brackets and wraps onto the next page.  You will have errors until future steps.
	__15.  Organize imports (CTRL+SHIFT+O).
	__16.  Save the file and make sure you don't have any errors.  You will have a warning that can be ignored.
	__17.  From the Eclipse menus select 'Run → Run History → NIOFileSystemDriver'.  
	__18.  Open a Windows Explorer file browser and navigate to the 'C:\LabFiles' directory.
	__19.  Copy the 'movie.xml' file from the directory by selecting 'Edit → Copy' or using 'CTRL-C'.
	__20.  Navigate into the 'watched' subdirectory.
	__21.  Paste the file you copied into the directory by selecting 'Edit → Paste' or using 'CTRL-V'.
	__22.  You should see that the same two new files are created but this time they are not empty.
	__23.  Open one of the files that were created and verify that it has content and is the same as the file you copied in.
	__24.  Close all open files in Eclipse.

	Part 8 -  Review

	Lab 20 -  Advanced Functional Programming
	Part 1 -  Conditional Collection Modification
	__1.  Open Eclipse in the project 'LambdaProject' if it is not already.
	__2.  In the project expand LambdaProject → src → com.webage.lambda.advanced and open the AdvancedFunctionTest.java file.
	__3.  Examine the current code.  Besides the empty 'main' method, there are a few fields declared that will be used later and an 'initializeStateMap' method that will be called to return a Map with a few state capitals keyed by state.  Examine the states used in the state map as that will be used several times.
	__4.  In the AdvancedFunctionTest class, add the following bold code to the end of the 'main' method.  This adds a single line to call a method you will complete next.
	__5.  In the AdvancedFunctionTest class, find the existing 'useRemoveIf' method and add to the existing code what is shown in bold below.  This will remove any employees from the list if the state they are in is “MO”.  Note the cast to the 'ArrayList' class as this method is not present in the 'List' interface directly.
	__6.  Save the file and make sure there are no errors.
	__7.  With the AdvancedFunctionTest class still open, select Run → Run As → Java Application.
	__8.  Check that the Console view shows the following output.  The content of the list should have changed by removing the two MO employees.
	__9.  In the AdvancedFunctionTest class, add the following bold code to the end of the 'main' method.  This adds a single line to call a method you will complete next.
	__10.  In the AdvancedFunctionTest class, find the existing 'useComputeIfAbsent' method and add to the existing code what is shown in bold below.  This code will add a Map entry if there is not one currently.
	__11.  Save the file and make sure there are no errors.
	__12.  From the Eclipse menus select Run → Run History → AdvancedFunctionTest.
	__13.  Check that the Console view shows the following output.  Note that the 'IL' key value was added since it didn't exist yet but that the value for the 'AZ' key was not added or modified.
	__14.  In the AdvancedFunctionTest class, add the following bold code to the end of the 'main' method.  This adds a single line to call a method you will complete next.
	__15.  In the AdvancedFunctionTest class, find the existing 'useMerge' method and add to the existing code what is shown in bold below.  The code first collects all of the map entries where the key starts with an 'M' into a List.  The 'merge' method of the 'Map' interface is then used for each of the states that start with 'M' and a new value will be stored which will be the current value concatenated with the given message.
	__16.  Save the file and make sure there are no errors.
	__17.  From the Eclipse menus select Run → Run History → AdvancedFunctionTest.
	__18.  Check that the Console view shows the following output.  Note that for the two states that were already in the Map, the message was combined with the current value according to the Lambda expression passed as a parameter.  For the one state (MA) that didn't exist, the message was simply used as the value directly and a new Map entry added.

	Part 2 -  Use NIO.2 Java 8 Changes
	__1.  In the AdvancedFunctionTest class, add the following bold code to the end of the 'main' method.  This adds a single line to call a method you will complete next.
	__2.  In the AdvancedFunctionTest class, find the existing 'useReadAllLines' method and add to the existing code what is shown in bold below.  The 'readAllLines' method was added in Java 8 so the returned List of all lines could be used with the Stream API. There is also a 'Files.lines' method you will see later that directly returns a Stream. The code uses a text file already part of the project that has an excerpt of Romeo and Juliet.
	__3.  Save the file and make sure there are no errors.
	__4.  From the Eclipse menus select Run → Run History → AdvancedFunctionTest.
	__5.  Check that the Console view shows the following output.  You should see 5 lines, all of which contain the word 'Romeo'.
	__6.  In the AdvancedFunctionTest class, add the following bold code to the end of the 'main' method.  This adds a single line to call a method you will complete next.
	__7.  In the AdvancedFunctionTest class, find the existing 'useFilesList' method and add to the existing code what is shown in bold below.  The 'Files.list' method returns a Stream of all the files in a directory.
	__8.  Save the file and make sure there are no errors.
	__9.  From the Eclipse menus select Run → Run History → AdvancedFunctionTest.
	__10.  Check that the Console view shows the following output.  You should see a short list of the files at the root of the current project.
	__11.  In the AdvancedFunctionTest class, add the following bold code to the end of the 'main' method.  This adds a single line to call a method you will complete next.
	__12.  In the AdvancedFunctionTest class, find the existing 'useFilesWalk' method and add to the existing code what is shown in bold below.  The 'Files.walk' method returns a Stream of all the files in a directory and all subdirectories.
	__13.  Save the file and make sure there are no errors.
	__14.  From the Eclipse menus select Run → Run History → AdvancedFunctionTest.
	__15.  Check that the Console view shows the following output.  Compared to the 'Files.list' demo you should see a lot more files listed.
	__16.  In the AdvancedFunctionTest class, add the following bold code to the end of the 'main' method.  This adds a single line to call a method you will complete next.
	__17.  In the AdvancedFunctionTest class, find the existing 'useFlatMap' method and add to the existing code what is shown in bold below.  This calls the 'Files.lines' method to get a stream of the lines, then the 'flatMap' method to transform the stream into a stream of all of the words after splitting the lines on spaces.  It then prints the words that match because they contain 'thou' along with the count of how many there were.
	__18.  Save the file and make sure there are no errors.
	__19.  From the Eclipse menus select Run → Run History → AdvancedFunctionTest.
	__20.  Check that the Console view shows the following output.  You should get 8 matching words.
	__21.  Close all open files.

	Part 3 -  Review

	Lab 21 -  JUnit
	Part 1 -  Create a Java project with JUnit Support
	__1.  From the Eclipse menus, select File → New → Project. 
	__2.  In the New Project window, select Java → Java Project and click Next.
	__3.  Enter JUnit as Project Name.
	__4.  Click Finish. Click yes if asked to switch perspective.
	__5.  From the menu, select File → New → Project. 
	__6.  In the New Project window, select Java →  Java Project and click Next.
	__7.  Enter JUnitTest as Project Name.
	__8.  Click Finish. 
	__9.  Right click the JUnitTest project and select Build Path →  Configure Build Path...
	__10.  Select the Projects tab in the dialog and click the Add button.
	__11.  Check the JUnit project and press the OK button.
	__12.  Select the Libraries tab in the dialog and click the Add Library... button.
	__13.  Select JUnit and click the Next button.
	__14.  Change the drop-down to select JUnit 4 
	__15.  Click the Finish button.
	__16.  Click the OK button to close the build path properties.

	Part 2 -  Create a Java Class and Test Class
	__1.  Right click the JUnit project and select New →  Class.
	__2.  Fill in a package of com.webage.domain 
	__3.  Fill in a class name of Money but do not yet create the class.
	__4.  Press the Add button next to the list of implemented interfaces.
	__5.  Fill in 'Comparable' to select the java.lang.Comparable interface and press the OK button.
	__6.  Click the Finish.
	__7.  Define the class Money as follows:
	__8.  Save the changes. There should not be any compile errors.
	__9.  Right click on the JUnitTest project and select New →  JUnit Test Case.
	__10.  Fill in a class name of MoneyTest but do not yet create the class.
	__11.  Fill in a package of com.webage.domain.test
	__12.  Press the Browse button at the bottom of the dialog next to the “Class under test”.
	__13.  Type Money  and then select the Money class that appears and press the OK button.
	__14.  Press the Next button once the dialog appears as below.
	__15.  Check the box next to the compareTo, equals and toString methods.  This will create tests for these methods.
	__16.  Press the Finish button to create the test class.
	__17.  Notice that JUnit 4 test methods are marked with the @Test annotation.  The wizard in Eclipse that created the test also put a statement that would guarantee the test to fail until we change it.

	Part 3 -  Test and Implement toString
	__1.  Modify the testToString method as follows.  You will have an error until the next step.
	__2.  From the Eclipse menus select Source →  Organize Imports.  This should add an import for the Money class.
	__3.  Save the code and be sure there are no errors.
	__4.  Right click on the MoneyTest.java file and select Run as →  JUnit Test. 
	__5.  The JUnit view should eventually open on the left.  There will be two failures but the testToString test should pass.
	__6.  Back in the MoneyTest class add the following new method.
	__7.  Save the code and be sure there are no errors.
	__8.  Right click on the MoneyTest.java editor and select Run as →  JUnit Test. 
	__9.  Select the testToString_SingleDigitCents method and scroll in the failure trace section. You will see that the zero was not present in one of the things being compared.  Obviously this means we need to adjust the implementation of the toString method to handle this condition.
	__10.  Switch to the Money.java editor or open the file if you closed it.
	__11.  Modify the implementation of the toString method to match the following.
	__12.  Save the code and be sure there are no errors.
	__13.  In the JUnit view, click the Rerun Test button.
	__14.  This time the test should pass in the testToString and testToString_SingleDigitCents tests.  There are still other failures but the two tests we have implemented have passed.  You could add other types of formatting function and define the tests but we will not do that now.

	Part 4 -  Implement compareTo and Tests
	__1.  Open MoneyTest.java
	__2.  Modify the testCompareTo method as follows.  You will have an error until the next step.
	__3.  Add the following import before the class declaration.
	__4.  Save the code and be sure there are no errors.
	__5.  Rerun the JUnit tests.  The test should fail in the testCompareTo method indicating that our implementation is not correct.
	__6.  Switch to the Money.java file and change the implementation of the compareTo method.
	__7.  Save the code and be sure there are no errors.
	__8.  Rerun the JUnit tests.  This time the test should pass in the testCompareTo test.
	__9.  Back in the MoneyTest class add the following new method.  100 US dollars is less than 100 Euros so this test makes sense for now.
	__10.  Save the changes and run the tests.  The test fails in the new method.
	__11.  Change the implementation of the testCompareTo_DifferentCurrencies to the following.  This uses the 'expected' property of the @Test annotation to indicate that this test expects an IllegalArgumentException to be thrown.
	__12.  Make sure you delete the assertTrue(american.compareTo(euros) < 0); line.
	__13.  Save the code and be sure there are no errors.
	__14.  Rerun the tests.  
	__15.  Select the testCompareTo_DifferentCurrencies method. The test will still fail but this time the failure message indicates the expected exception was not thrown.
	__16.  Switch to the Money.java file and change the implementation of the compareTo method.
	__17.  Save the code and be sure there are no errors.
	__18.  Rerun the JUnit tests.  This time the test should pass for the testCompareTo_DifferentCurrencies test.

	Part 5 -  Implement equals and Tests
	__1.  Select MoneyTest.java
	__2.  Modify the testEqualsObject method as follows.  
	__3.  Save the code and be sure there are no errors.
	__4.  Rerun the JUnit tests.  The test should fail and if you select it you can see the custom failure message.
	__5.  Switch to the Money.java file and change the implementation of the equals method.
	__6.  Save the code and be sure there are no errors.
	__7.  Rerun the JUnit tests.  
	__8.  This time the test should pass in all the methods.  Notice when all the tests pass the bar turns green to indicate success.
	__9.  Close all the files.

	Part 6 -  Create a Test Suite
	__1.  In Eclipse, switch to the Package Explorer view on the left which has likely been hidden by the JUnit view.
	__2.  Expand the JUnitTest → src folders until you see the com.webage.domain.test package.
	__3.  Right click this package and select New → Class.
	__4.  Fill in a class name of AllTests and click the Finish button.
	__5.  Add the following code to the declaration of the class.  You will have some errors until the next step.
	__6.  From the Eclipse menus select Source -> Organize Imports.  This should add some JUnit imports.
	__7.  Save the code and be sure there are no errors.
	__8.  Right click on the AllTests.java file and select Run as → JUnit Test. 
	__9.  You should get the same test passing results. Expand all in the JUnit view.  
	__10.  Close all open files.

	Part 7 -  Review




