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Lab 1 - Setup the Development Environment
In this lab you will setup the environment for developing Java EE applications for 
WildFly using JBoss Developer Studio.  This includes installing JBoss Eclipse plug-ins.

Part 1 - Verify Java Install
Since this course uses Java 7, you will do a few quick steps just to verify everything is 
setup properly.  Java 7 should have been installed as part of the class setup but these steps 
will help verify and avoid other issues later when they are harder to debug.

__1. Open a Windows command prompt.  You can usually do this on most versions of 
Windows by selecting 'Start → Programs → Accessories → Command Prompt'.

__2. Run the following command and make sure you get a Java “1.7.x” version.  If you 
do not see this, the next steps will help figure out what setting is incorrect.  Also, if you 
get an error about java not being “recognized” as a command the next steps will help 
figure out why.

java -version

__3. Run the following command to see the current value of the 'PATH' environment 
variable.  Check that you see the 'bin' directory of a Java 1.7 installation in the PATH.  If 
you do not see Java 1.7 or if you see multiple versions of Java referenced this could be 
causing errors.

set PATH

Note: Your actual value may be slightly different but it should be obvious that it is a 
Java (or “JDK”) 1.7 version.
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__4. Run the following command and look at the value of the 'JAVA_HOME' 
environment variable. Make sure that it points to the root directory of a Java 1.7 
installation.  If you get a message about 'JAVA_HOME' not being defined this could also 
cause issues.

set JAVA_HOME

Note: Your actual value may be slightly different but it should be obvious that it is a 
Java (or “JDK”) 1.7 version.

__5. If you have not seen output similar to that shown in the previous steps, inform your 
instructor.  They can help determine if all students have the same (or similar) issue and 
the best way to fix it so it won't cause problems later.

__6. Close the command prompt.

Part 2 - Install JBoss Eclipse Plug-ins
Besides allowing us to use WildFly as a test server, the "JBoss Developer Studio" Eclipse 
plug-ins have a few tools specific to JBoss/WildFly.  This section will install those tools. 
This was not done as part of the class setup because the steps are a little more involved. 
It will also be good for you to know how to install these tools if you want to obtain them 
for your own environment from:

http://tools.jboss.org/downloads/

The JBoss Developer Studio version you will use has already been downloaded and is 
compatible with the Eclipse version you are using.

__1. Start Eclipse by launching <SOFTWARE>\eclipse\eclipse.exe

Eclipse will launch.

You will be prompted to select a Workspace. 

__2. Set the Workspace to C:\workspace
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__3. Click OK.

Eclipse will start. 

__4. Eclipse may be displaying the Welcome screen.  Close the welcome screen by 
clicking the x in its tab.  

__5. From the Eclipse menus select Help → Install New Software...

Note: If you get an error about some sites not being found it is because Eclipse can't 
connect to the Internet.  Since you will be provided with a local copy of the updates you 
can ignore this error and click 'OK'.

__6. Click the Add button on the upper right to add a new update site.
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__7. Click the Archive... button.

Note: You are using this option since the JBoss Developer Studio plugins are provided 
as a single Zip file with the class software.

__8. In the dialog to choose a file, find and open the file 
'<SOFTWARE>\JBoss Developer Studio\jboss-devstudio-....zip'.  The end of the file 
name is not given as it may change but this should be the only Zip file which starts with 
that name at that location.

__9. Once you have chosen the appropriate Zip file, give the update site a name of 'JBoss 
Developer Studio Archive' and press the OK button when your options are similar to 
that shown below.

__10. In the list of available features, select the 'JBoss Developer Studio 8.0 – Core' 
features as shown below.  Click the Next button when you have the correct features 
selected as shown below.
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__11. You may get an error that some parts of the installation can't be performed.  As 
long as most of the features will be installed, as shown below, you can click the Next 
button and proceed with the installation.  Click the Next button after verifying only a few 
features won't be installed as shown below. If you don't see the Install Remediation Page 
then go to the next step.

Note: If you do not have a Next button or any features indicating they will be installed, 
you may have selected the wrong option in the previous step.  Go back one page in the 
Eclipse wizard and check the selection of that option.

__12. You will see a list of software that will be installed as shown below.  There should 
be no checkboxes next to any features.  Press the Next button.
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__13. On the 'Review Licenses' screen, select the radio button in the lower right labeled 
'I accept the terms of the license agreements' and press the Finish button.  This will 
begin installing the software.

__14. Leave the dialog box that appears running so that you can see when the installation 
process completes.

__15. When you get a prompt about unsigned plugins click the OK button.

__16. You may see a Windows Firewall window, if so then click Allow access.
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__17. Once the installation is complete you will get a prompt to restart Eclipse.  Press the 
Yes button to restart.

__18. Open Eclipse in the same workspace when it restarts.

__19. Click No if the JBoss Tools Usage dialog opens.

Part 3 - Configure WildFly Test Server in Eclipse
Now that the JBoss Developer Studio Eclipse tools are installed the next step is to define 
a WildFly test server.  This will let you deploy and test applications directly from Eclipse.

__1. Click on the Servers view located in the bottom of the Eclipse window.

__2. Right click in the empty area and select New -> Server.
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__3. From the list expand JBoss Community and select WildFly 8.x

__4. Click Next.

__5. In the options for the server adapter, leave the defaults of a local server controlled by 
"Filesystem and shell operations' as shown below.  Click the Next button.

__6. Click the first Browse button next to Home Directory and navigate to 
<SOFTWARE>\wildfly-8.2.0.Final and then click OK.  Stay on the same page in the 
main wizard.

__7. For the JRE option leave the default of the JavaSE-1.7 execution environment.
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__8. Click Finish once your dialog matches the settings shown below.

__9. The new server will appear in the Servers list.

__10. Right click on the Server and select Open.

__11. The configuration page of the Server will open.

__12. Expand Publishing on the right side.
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__13. Select Never publish automatically.

__14. At the bottom of the Eclipse server configuration editor click the 'Deployment' tab.

__15. Check the 'Deploy projects as compressed archives' option.

Note: This option is generally best to allow rapid deployment and testing of changes 
made in Eclipse.  The default settings would deploy an “exploded” archive.  Even 
though modifying and publishing an updated Java class would recompile the .class file 
copied to the server, the application would not be restarted and the previous version of 
the class loaded by the server might still be used.

By deploying a compressed archive, any change to any file in that project would recreate 
the entire archive and cause the entire application to be redeployed.  This would 
guarantee the most recent code is being used.  Since WildFly deployment is very quick, 
this method is preferred to avoid any confusing behavior where code changes have not 
been picked up by the server.

__16. Save the changes and close the server editor.

__17. In the Servers view, right click the 'WildFly 8.x' server and select Start.  
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__18. Check that the server starts successfully.  You may need to switch back to the 
Servers view.

__19. Leave the server running for the next section.

Part 4 - Configure WildFly Management User
By default the web administration console of WildFly is secure but doesn't have any users 
configured.  This effectively locks it down until you configure users to access it.  Since 
several labs may need to go into this administrative console to perform various tasks, this 
section will enable an administrative user.

__1. Open a Windows command prompt.  You can usually do this on most versions of 
Windows by selecting 'Start → Programs → Accessories → Command Prompt'.

__2. Use the following 'cd' command to switch to the WildFly 'bin' directory.

cd C:\Software\wildfly-8.2.0.Final\bin

__3. Run the following 'add-user' command to start the interactive tool to add a user. 
How to respond to various prompts is given in the next steps.

add-user

__4. On the first prompt, hit the <ENTER> key to accept the default option of 'a' to 
create a “management user”.
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__5. Enter a username of 'admin'.  Enter 'yes' when asked if you want to use a user name 
that is "easy to guess".

__6. Type the following password for both prompts that ask you to enter a password. 
Note that the program will not even show stars while you type.

wildf!y8

Note: This version of the tool requires a password that is at least 8 characters and has 
one number and one non-alphanumeric character.

__7. Hit <ENTER> to accept that the user will not be added to any groups.

__8. Type 'yes' to confirm you want to add the 'admin' user to the 'ManagementRealm'.

__9. Type 'no' when asked if the user will be used for communication between servers.

__10. Hit any key to let the program finish and return you to the command prompt.

__11. Close the command prompt.
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__12. Go back to the Servers view in Eclipse and make sure your WildFly server is 
running.  Start it if it is not.

__13. Open a web browser to the following address which should bring up a security 
prompt.

http://localhost:9990/console

__14. In the security prompt, enter a username of 'admin' and a password of 'wildf!y8'. 
You can check the option to remember the password if offered.

__15. Check that you see the overview page of the administration console.  If it doesn't 
display try refreshing the page.
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Note: If you get an authentication error it may be because somehow the password you 
entered in the browser is different than what you configured in the script tool.  If you 
can't provide the correct password you can run the 'add-user' tool again but you first 
have to manually delete some lines from two text files.

Find the following two text files, open them with a text editor like WordPad, and delete 
the line that starts with 'admin=...' without a leading '#' as a comment.

C:\Software\wildfly-8.2.0.Final\domain\configuration\mgmt-users.properties

C:\Software\wildfly-8.2.0.Final\standalone\configuration\mgmt-users.properties

You need to delete this line from both files because even though your configuration is 
only looking at the 'standalone' properties file, you can't run the 'add-user' tool again 
with the same user if it already exists in either one of these files.

__16. Close the browser you are using to access the administration console.

__17. Stop the server in the Eclipse Servers view.

Part 5 - Review
In this lab you installed JBoss Developer Studio Eclipse plug-ins for the rest of the labs. 
You could do these steps in your own development environment after downloading the 
proper JBoss Developer Studio downloads.  You also did several configuration steps that 
will let you work with WildFly from Eclipse and access the administration console if 
required.
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Lab 2 - Develop a Simple RESTful Service
In this lab, we will develop a very simple RESTful web service. This will let us focus on 
the development process using eclipse and the WildFly server. We will also learn about 
the basic JAX-RS annotations.

The main goal of this lab is to understand how to create a web service project and 
develop a few basic REST services.

Part 1 - Create the Web Service Project
In Eclipse, the project to use to develop JAX-RS services is just a regular “Dynamic 
Web” project.  When you target a server, the JAR files for the JAX-RS API are already on 
the classpath.

__1. Open Eclipse in your workspace if it is not already open.

__2. From the menubar, select File > New > Dynamic Web Project.

__3. Enter JAXRS-Intro for the Project name.  Leave the other settings with the defaults 
as shown below.

__4. Click Finish to create the web project.  If prompted, don't switch to the web 
perspective by clicking No.
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We will briefly review the project.

__5. Right click the newly created JAXRS-Intro project and select Properties.

__6. Now, select the Project Facets property.

__7. Note that the JAX-RS facet is not selected. This facet plays no role in developing 
JAX-RS services when the server already supports the JAX-RS API as WildFly does. 
This project facet could be used with Java EE 5 servers that do not support JAX-RS.

__8. Click Cancel to close the dialog.

Part 2 - Register the REST Application
There are a few different ways to configure a REST application.  This can depend on if 
you want a common URL prefix for all REST services.  This might be useful if you have 
REST services within a project with other web components.  If you want to register a 
common URL prefix you can do so in a web.xml file.  

__1. In Eclipse, right click the JAXRS-Intro project and select 'Java EE Tools → 
Generate Deployment Descriptor Stub'.

Note: Since a web.xml file is optional in Java EE 6 and later, the project does not 
include on initially.

__2. Expand the following folders of the Eclipse project, JAXRS-Intro → WebContent 
→ WEB-INF

__3. Double-click the web.xml file to open it in an editor.

Note: There is a solution file <LABFILES>/JAXRS-Intro/Solution/web.xml if you have 
trouble getting the correct settings for the web.xml file.
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__4. Right click on the 'welcome-file-list' entry and select Delete.  Confirm you want to 
delete the 6 entries.

Note: The default content refers to some files that don't exist so this will avoid 
confusing warnings.

__5. Right click on the web.xml entry in the tree and select 'New → Servlet...'

Note: If you do not see this entry you are not clicking the web.xml entry in the tree.

__6. In the dialog that appears, fill in 'javax.ws.rs.core.Application' for the Servlet name 
and class.  Click the Finish button once your settings match those shown below.
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__7. Double check your new Servlet shows up in the list.

__8. Right click on the Servlets entry in the tree and select 'New → Servlet Mapping...'

__9. In the dialog, use the drop-down to select the JAX-RS Application servlet and fill in 
a value of '/svc/*' (without the quotes) for the URL pattern.  Click the Finish button once 
your settings match those shown below.

__10. Double check your new Servlet mapping shows up in the list.
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__11. Use the 'Source' tab at the bottom of the editor to switch to the source of web.xml 

At this point we need to fix a minor problem in the web.xml.  To configure the JAX-RS 
mapping, you use a servlet definition with a name of 'javax.ws.rs.core.Application' but 
without a Servlet class.  The popup in the visual web.xml editor though would not have 
let us create the entry without a Servlet class.

__12. Find the source code for the definition of the <servlet> and remove the 
<servlet-class> entry (shown in strikethrough below)

 <servlet>
  <servlet-name>javax.ws.rs.core.Application</servlet-name>
  <servlet-class>javax.ws.rs.core.Application</servlet-class>
 </servlet>

__13. Also study how the REST application URL is configured. Specifically, note the 
servlet mapping:

 <servlet-mapping>
  <servlet-name>javax.ws.rs.core.Application</servlet-name>
  <url-pattern>/svc/*</url-pattern>
 </servlet-mapping>

This means, the URL for every REST request will start with http://host:port/JAXRS-
Intro/svc/. You can choose any other path for the REST application. But, we will stick to 
the short and sweet "svc".

__14. Save and close the file.

Part 3 - Create the Resource Class
The Java class that implements a RESTful service is called a resource. We will now 
develop a Java class for a simple service.

__1. Right click JAXRS-Intro project and select New > Class.

__2. Enter com.acme.services as the package name and SimpleService as the class 
name.
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__3. Click Finish to create the new class.

__4. Add a member variable that will help us do logging.  You will have errors until the 
next steps.

public class SimpleService {
Logger logger = Logger.getLogger("SimpleService");

__5. Organize imports (Control+Shift+O) and select java.util.logging.Logger.  Make 
sure you select the correct class as there are several 'Logger' classes on the classpath.

We will now add the testGET() method. It will not have any business logic. Later, we will 
map this method to a GET request.

__6. Add the method as follows, making sure to place it inside the curly brackets of the 
class definition.

public String testGET() {
logger.info("Got a GET request");
return "OK";

}

__7. Save changes and make sure there are no compilation errors.

Part 4 - Configure the Resource
We will now configure the URI and HTTP method for the service resource and its 
methods. We will use the "/simple" root URI for the service.

__1. Define the URI of the root resource, by adding the @Path annotation above the 
class.  You will have errors until the next steps.

@Path("/simple")
public class SimpleService {

The testGET() method does not need any path extension. All we have to do is set GET as 
the HTTP method. 

We will also set "text/plain" as the content MIME type of the reply. That is good enough 
for this method. For XML data type, the MIME will be "text/xml".
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__2. Set the HTTP method and reply MIME type for the testGET() method sub-resource 
as follows.  Make sure to add these annotations before the method declaration.

@GET
@Produces("text/plain")
public String testGET() {

__3. Organize imports (Control+Shift+O). Select javax.ws.rs.Produces.

__4. Save changes.

Part 5 - Unit Test
We will now exercise the web service from a browser.

__1. Start the WildFly server.

__2. Right click the server and select Add and Remove.

__3. Add the JAXRS-Intro project to the server.

__4. Click Finish.

__5. Right click the server and select Publish. Do this every time you are requested to 
Publish the server.  This time the project should already be synchronized on the server so 
nothing may happen when you publish.

__6. Open a web browser and enter the URL: 

http://localhost:8080/JAXRS-Intro/svc/simple/

__7. You should see OK in the browser.
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__8. The Console view will show the log output.

This proves that our project has been setup correctly and JAX-RS is working fine.

Part 6 - Use Path Extension for Sub-resource
A sub-resource – Java method – can be mapped to an URI extension path. Any HTTP 
request for that path will be handled by that method. We will now create a method that 
will respond to the /simple/mypath URI.

__1. First, add this method to the SimpleService class.  Make sure it is inside the curly 
brackets for the class but outside of other method definitions.

public String testGETWithPath() {
logger.info("Got a GET request with path extension.");
return "OK – from subresource";

}

__2. Annotate the method as follows.

@GET
@Produces("text/plain")
@Path("/mypath")
public String testGETWithPath() {

__3. Save changes.
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Part 7 - Unit Test
__1. Right click the server and select Publish.

__2. In a web browser, enter the URL: 

http://localhost:8080/JAXRS-Intro/svc/simple/mypath

__3. Make sure that the Console shows the log output.

__4. Open a new browser or tab and re-test the testGET method for regression using the 
URL: 

http://localhost:8080/JAXRS-Intro/svc/simple/

Part 8 - Get Root Resource Path Parameters
Input data can be added to the path of the root resource as well as the path of a method 
(sub-resource). In REST, data is added to the URI to form an unique identifier.

First, we will add an input parameter in the root path of the SimpleService resource. The 
root URI will now look like /simple/somedata. The root URI will continue to execute the 
testGET() method since this method defines no path extension. To execute the 
testGETWithPath(), the URI will need to be /simple/somedata/mypath.

__1. Open SimpleService.java from the JAXRS-Intro project.

__2. Change the @Path annotation for the class and add a parameter there.

@Path("/simple/{myRootPathData}")
public class SimpleService {
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Here, {myRootPathData} is a placeholder for a parameter. You can use anything as a 
name of the parameter. The name will play a role to obtain the value of the parameter.

The best place to capture input from a root path is a member variable of the resource. We 
will do that now.

__3. Add a member variable as follows.

public class SimpleService {
String rootPathData;
Logger logger = Logger.getLogger("SimpleService");

__4. Annotate the member variable to save the value of the myRootPathData parameter. 
You will have errors until the next steps.

@PathParam("myRootPathData")
String rootPathData;

That's it. Now, JAX-RS will extract the value of the parameter from the URI and set it to 
the member variable right after the resource object is created. By default, a POJO 
resource instance is created for every HTTP request. Hence, every request can have a 
different parameter value in the path.

__5. Organize imports.  Select 'javax.ws.rs.PathParam' when prompted.

__6. Change the log statement of the testGET() method as follows.

public String testGET() {
logger.info("Got a GET request with root path data: " +

rootPathData);
return "OK";

}

__7. Make a similar change to the testGETWithPath() method.

public String testGETWithPath() {
logger.info("Got a GET request with root path data: "

+ rootPathData + " with path extension");
return "OK - from subresource";

}

__8. Save changes.
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Part 9 - Unit Test
__1. Publish the server.

__2. First, test the testGET() method by entering the URL: 

http://localhost:8080/JAXRS-Intro/svc/simple/pathdata/ 

__3. The log output will like this:

__4. Now, test the testGETWithPath() method using the URL: 

http://localhost:8080/JAXRS-Intro/svc/simple/pathdata/mypath

__5. The log output will be:

Part 10 - Get Sub-resource Path Parameters
Methods can also let us add parameters to its path. For example to get the billing address 
of an order #1051, we can use the URI: /orders/1051/address/billing. Never lose sight of 
the fact that a URI uniquely identifies an entity or a collection of entities. In this example, 
we are specifically pointing to the billing address used with an order. Here, the orderId as 
well as the type of address requested can be added as parameters to the path of the sub-
resource. Let's try out this example.

__1. Add a basic method as follows.  Make sure to add it inside the curly brackets of the 
class but outside other methods.

public String getAddress(
int oId, 
String type) {
logger.info("Root Path data: " + rootPathData);
logger.info("Order Id: " + oId);
logger.info("Address type: " + type);

return "OK";
}
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__2. Annotate method with path and method.  Add these annotations before the method 
declaration.

@GET
@Produces("text/plain")
@Path("/{orderId}/address/{addressType}")
public String getAddress(

__3. Now, extract the path parameters and save them in the two input argument variables 
of the method.  The syntax for the @PathParam annotation on a method parameter is 
tricky so be careful.

public String getAddress(
@PathParam("orderId")
int oId, 
@PathParam("addressType")
String type) {

__4. Save changes.

__5. Publish the server.

__6. Test the method by entering the following URL (it wraps to a second line because it 
is long but should all be entered together).

http://localhost:8080/JAXRS-Intro/svc/
simple/pathdata/1051/address/billing

__7. Check that the Console view shows the expected message in the server log.

__8. Close all browsers.

__9. Close all open files.
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Part 11 - Cleanup
__1. Undeploy and close the JAXRS-Intro project as described in the 'Common Lab 
Steps' at the 'Lab Cleanup' part on page 103.

Part 12 - Review
In this lab, we created and configured a web service project. We created a very simple 
JAX-RS web service. You saw how to configure the URL mapping in web.xml that will 
be used to determine if a request is for a JAX-RS REST service or some other web 
resource.  You saw how to configure the path a particular JAX-RS resource class and 
method will respond to with the @Path annotation.  You saw how to extract data from the 
request URI with the @PathParam annotation.
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	__9.  Once you have chosen the appropriate Zip file, give the update site a name of 'JBoss Developer Studio Archive' and press the OK button when your options are similar to that shown below.
	__10.  In the list of available features, select the 'JBoss Developer Studio 8.0 – Core' features as shown below.  Click the Next button when you have the correct features selected as shown below.
	__11.  You may get an error that some parts of the installation can't be performed.  As long as most of the features will be installed, as shown below, you can click the Next button and proceed with the installation.  Click the Next button after verifying only a few features won't be installed as shown below. If you don't see the Install Remediation Page then go to the next step.
	__12.  You will see a list of software that will be installed as shown below.  There should be no checkboxes next to any features.  Press the Next button.
	__13.  On the 'Review Licenses' screen, select the radio button in the lower right labeled 'I accept the terms of the license agreements' and press the Finish button.  This will begin installing the software.
	__14.  Leave the dialog box that appears running so that you can see when the installation process completes.
	__15.  When you get a prompt about unsigned plugins click the OK button.
	__16.  You may see a Windows Firewall window, if so then click Allow access.
	__17.  Once the installation is complete you will get a prompt to restart Eclipse.  Press the Yes button to restart.
	__18.  Open Eclipse in the same workspace when it restarts.
	__19.  Click No if the JBoss Tools Usage dialog opens.

	Part 3 -  Configure WildFly Test Server in Eclipse
	__1.  Click on the Servers view located in the bottom of the Eclipse window.
	__2.  Right click in the empty area and select New -> Server.
	__3.  From the list expand JBoss Community and select WildFly 8.x
	__4.  Click Next.
	__5.  In the options for the server adapter, leave the defaults of a local server controlled by "Filesystem and shell operations' as shown below.  Click the Next button.
	__6.  Click the first Browse button next to Home Directory and navigate to <SOFTWARE>\wildfly-8.2.0.Final and then click OK.  Stay on the same page in the main wizard.
	__7.  For the JRE option leave the default of the JavaSE-1.7 execution environment.
	__8.  Click Finish once your dialog matches the settings shown below.
	__9.  The new server will appear in the Servers list.
	__10.  Right click on the Server and select Open.
	__11.  The configuration page of the Server will open.
	__12.  Expand Publishing on the right side.
	__13.  Select Never publish automatically.
	__14.  At the bottom of the Eclipse server configuration editor click the 'Deployment' tab.
	__15.  Check the 'Deploy projects as compressed archives' option.
	__16.  Save the changes and close the server editor.
	__17.  In the Servers view, right click the 'WildFly 8.x' server and select Start.  
	__18.  Check that the server starts successfully.  You may need to switch back to the Servers view.
	__19.  Leave the server running for the next section.

	Part 4 -  Configure WildFly Management User
	__1.  Open a Windows command prompt.  You can usually do this on most versions of Windows by selecting 'Start → Programs → Accessories → Command Prompt'.
	__2.  Use the following 'cd' command to switch to the WildFly 'bin' directory.
	__3.  Run the following 'add-user' command to start the interactive tool to add a user. How to respond to various prompts is given in the next steps.
	__4.  On the first prompt, hit the <ENTER> key to accept the default option of 'a' to create a “management user”.
	__5.  Enter a username of 'admin'.  Enter 'yes' when asked if you want to use a user name that is "easy to guess".
	__6.  Type the following password for both prompts that ask you to enter a password. Note that the program will not even show stars while you type.
	__7.  Hit <ENTER> to accept that the user will not be added to any groups.
	__8.  Type 'yes' to confirm you want to add the 'admin' user to the 'ManagementRealm'.
	__9.  Type 'no' when asked if the user will be used for communication between servers.
	__10.  Hit any key to let the program finish and return you to the command prompt.
	__11.  Close the command prompt.
	__12.  Go back to the Servers view in Eclipse and make sure your WildFly server is running.  Start it if it is not.
	__13.  Open a web browser to the following address which should bring up a security prompt.
	__14.  In the security prompt, enter a username of 'admin' and a password of 'wildf!y8'.  You can check the option to remember the password if offered.
	__15.  Check that you see the overview page of the administration console.  If it doesn't display try refreshing the page.
	__16.  Close the browser you are using to access the administration console.
	__17.  Stop the server in the Eclipse Servers view.

	Part 5 -  Review

	Lab 2 -  Develop a Simple RESTful Service
	Part 1 -  Create the Web Service Project
	__1.  Open Eclipse in your workspace if it is not already open.
	__2.  From the menubar, select File > New > Dynamic Web Project.
	__3.  Enter JAXRS-Intro for the Project name.  Leave the other settings with the defaults as shown below.
	__4.  Click Finish to create the web project.  If prompted, don't switch to the web perspective by clicking No.
	__5.  Right click the newly created JAXRS-Intro project and select Properties.
	__6.  Now, select the Project Facets property.
	__7.  Note that the JAX-RS facet is not selected. This facet plays no role in developing JAX-RS services when the server already supports the JAX-RS API as WildFly does.  This project facet could be used with Java EE 5 servers that do not support JAX-RS.
	__8.  Click Cancel to close the dialog.

	Part 2 -  Register the REST Application
	__1.  In Eclipse, right click the JAXRS-Intro project and select 'Java EE Tools → Generate Deployment Descriptor Stub'.
	__2.  Expand the following folders of the Eclipse project, JAXRS-Intro → WebContent → WEB-INF
	__3.  Double-click the web.xml file to open it in an editor.
	__4.  Right click on the 'welcome-file-list' entry and select Delete.  Confirm you want to delete the 6 entries.
	__5.  Right click on the web.xml entry in the tree and select 'New → Servlet...'
	__6.  In the dialog that appears, fill in 'javax.ws.rs.core.Application' for the Servlet name and class.  Click the Finish button once your settings match those shown below.
	__7.  Double check your new Servlet shows up in the list.
	__8.  Right click on the Servlets entry in the tree and select 'New → Servlet Mapping...'
	__9.  In the dialog, use the drop-down to select the JAX-RS Application servlet and fill in a value of '/svc/*' (without the quotes) for the URL pattern.  Click the Finish button once your settings match those shown below.
	__10.  Double check your new Servlet mapping shows up in the list.
	__11.  Use the 'Source' tab at the bottom of the editor to switch to the source of web.xml 
	__12.  Find the source code for the definition of the <servlet> and remove the <servlet‑class> entry (shown in strikethrough below)
	__13.  Also study how the REST application URL is configured. Specifically, note the servlet mapping:
	__14.  Save and close the file.

	Part 3 -  Create the Resource Class
	__1.  Right click JAXRS-Intro project and select New > Class.
	__2.  Enter com.acme.services as the package name and SimpleService as the class name.
	__3.  Click Finish to create the new class.
	__4.  Add a member variable that will help us do logging.  You will have errors until the next steps.
	__5.  Organize imports (Control+Shift+O) and select java.util.logging.Logger.  Make sure you select the correct class as there are several 'Logger' classes on the classpath.
	__6.  Add the method as follows, making sure to place it inside the curly brackets of the class definition.
	__7.  Save changes and make sure there are no compilation errors.

	Part 4 -  Configure the Resource
	__1.  Define the URI of the root resource, by adding the @Path annotation above the class.  You will have errors until the next steps.
	__2.  Set the HTTP method and reply MIME type for the testGET() method sub-resource as follows.  Make sure to add these annotations before the method declaration.
	__3.  Organize imports (Control+Shift+O). Select javax.ws.rs.Produces.
	__4.  Save changes.

	Part 5 -  Unit Test
	__1.  Start the WildFly server.
	__2.  Right click the server and select Add and Remove.
	__3.  Add the JAXRS-Intro project to the server.
	__4.  Click Finish.
	__5.  Right click the server and select Publish. Do this every time you are requested to Publish the server.  This time the project should already be synchronized on the server so nothing may happen when you publish.
	__6.  Open a web browser and enter the URL: 
	__7.  You should see OK in the browser.
	__8.  The Console view will show the log output.

	Part 6 -  Use Path Extension for Sub-resource
	__1.  First, add this method to the SimpleService class.  Make sure it is inside the curly brackets for the class but outside of other method definitions.
	__2.  Annotate the method as follows.
	__3.  Save changes.

	Part 7 -  Unit Test
	__1.  Right click the server and select Publish.
	__2.  In a web browser, enter the URL: 
	__3.  Make sure that the Console shows the log output.
	__4.  Open a new browser or tab and re-test the testGET method for regression using the URL: 

	Part 8 -  Get Root Resource Path Parameters
	__1.  Open SimpleService.java from the JAXRS-Intro project.
	__2.  Change the @Path annotation for the class and add a parameter there.
	__3.  Add a member variable as follows.
	__4.  Annotate the member variable to save the value of the myRootPathData parameter.  You will have errors until the next steps.
	__5.  Organize imports.  Select 'javax.ws.rs.PathParam' when prompted.
	__6.  Change the log statement of the testGET() method as follows.
	__7.  Make a similar change to the testGETWithPath() method.
	__8.  Save changes.

	Part 9 -  Unit Test
	__1.  Publish the server.
	__2.  First, test the testGET() method by entering the URL: 
	__3.  The log output will like this:
	__4.  Now, test the testGETWithPath() method using the URL: 
	__5.  The log output will be:

	Part 10 -  Get Sub-resource Path Parameters
	__1.  Add a basic method as follows.  Make sure to add it inside the curly brackets of the class but outside other methods.
	__2.  Annotate method with path and method.  Add these annotations before the method declaration.
	__3.  Now, extract the path parameters and save them in the two input argument variables of the method.  The syntax for the @PathParam annotation on a method parameter is tricky so be careful.
	__4.  Save changes.
	__5.  Publish the server.
	__6.  Test the method by entering the following URL (it wraps to a second line because it is long but should all be entered together).
	__7.  Check that the Console view shows the expected message in the server log.
	__8.  Close all browsers.
	__9.  Close all open files.

	Part 11 -  Cleanup
	__1.  Undeploy and close the JAXRS-Intro project as described in the 'Common Lab Steps' at the 'Lab Cleanup' part on page 103.

	Part 12 -  Review

	Lab 3 -  Extracting Information from a HTTP Request
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\JAXRS-Data\JAXRS-Data-Starter.zip' file as described in the 'Common Lab Steps' at the 'Lab Setup' part on page 100.

	Part 2 -  Extract Query Parameters
	__1.  Open SimpleService.java from the 'com.acme.services' Java package of the  JAXRS-Data project.
	__2.  Add the giveRaise() method as shown below.  Make sure this is outside of other method definitions but inside the class.  You will get errors until the next steps.
	__3.  Organize imports (Control+Shift+O). Select javax.ws.rs.Produces.
	__4.  Save changes and make sure there are no compilation errors.
	__5.  Start the WildFly server if it was not running.
	__6.  Right click the server and select Add and Remove.
	__7.  Add the JAXRS-Data project to the server.
	__8.  Click Finish.
	__9.  Test the new method by entering the following URL in a browser: 
	__10.  Make sure that the Console shows:
	__11.  Return to the SimpleService class.
	__12.  Modify the method to add a @DefaultValue annotation as shown below.
	__13.  Organize imports (Control+Shift+O). 
	__14.  Save changes and make sure there are no compilation errors.
	__15.  In the Servers view, right click the server and select Publish.
	__16.  Test the change by entering the following URL in a browser: 
	__17.  Make sure that the Console shows:

	Part 3 -  Extracting Form Post Data
	__1.  In the JAXRS-Data project, expand the WebContent folder and open the post.html page in an editor by double clicking it.
	__2.  Examine the source of the form.  You may want to switch to a 'Source' tab at the bottom of the editor to make this easier.  In particular, notice the settings for the form itself and the names of the elements inside the form.  These will be picked up by various settings in the JAX-RS annotations next.
	__3.  Close the post.html file without making any changes.
	__4.  Add the following method to the SimpleService class.  Make sure this is outside of other methods but inside the class definition.  You will get errors until the next steps.
	__5.  Organize imports. Select  java.util.List.
	__6.  Save changes.
	__7.  In the Servers view, right click the server and select Publish.
	__8.  Open a browser and enter the URL: 
	__9.  Fill out the form with some sample data and submit it. 
	__10.  Make sure that the console log shows the input values correctly.

	Part 4 -  Extract Cookie Data
	__1.  Add the following method to the SimpleService class.  Make sure this is outside of other methods but inside the class definition.  You will get errors until the next steps.
	__2.  Organize imports (Control+Shift+O). 
	__3.  Save changes and make sure there are no compilation errors.
	__4.  In the Servers view, right click the server and select Publish.
	__5.  Open the RESTClient tool as described in the 'Common Lab Steps' at the 'Start RESTClient Tool' part on page 102.
	__6.  Check that the 'HTTP Method' is set to GET and in the URL text box, enter: 
	__7.  Click the Cookie tab below the URL text box.
	__8.  Fill in 'sampleCookie' for the 'Key', whatever text you want in the 'Value' box, then click the 'Add' button (with the plus sign) to add the cookie to the request.
	__9.  Check that your cookie shows up in the table below and has the correct name.
	__10.  We are now ready start testing. Click the  icon next to the URL.
	__11.  Check in the 'HTTP Response' section that a "No Content" status of 204 is returned.
	__12.  Make sure that the Eclipse console log shows the cookie value correctly.
	__13.  Leave the RESTClient tool open for the next section.

	Part 5 -  Extract Custom Object
	__1.  Open Employee.java from the 'com.acme.services' Java package of the  JAXRS-Data project.
	__2.  Examine the Employee class and realize right now it is just a regular Java class with a few fields and some get/set methods.
	__3.  To the top of the class definition, add the @XmlRootElement annotation as shown below.  You will have some errors until the next steps.
	__4.  Organize imports (Control+Shift+O). 
	__5.  Save changes and make sure there are no compilation errors.
	__6.  Add the following method to the SimpleService class.  Make sure this is outside of other methods but inside the class definition.  
	__7.  Save changes and make sure there are no compilation errors.
	__8.  In the Servers view, right click the server and select Publish.
	__9.  Return to the RESTClient tool you left open from the previous section.
	__10.  Change the URL text box to:
	__11.  Click the Method tab below the URL text box.
	__12.  Change the 'HTTP Method' to POST as shown below.
	__13.  Click the Body tab below the URL text box.
	__14.  Use the drop-down on the Body tab to select 'String body'.
	__15.  Click the 'Edit Content-type & Charset' button
	__16.  From the drop-down select the text/xml content type.
	__17.  Click OK.
	__18.  Click the 'Load from file' button.
	__19.  Find and select the 'employee.xml' file in the '<LABFILES>\JAXRS-Data' folder and press the 'Open' button when you have the correct file selected.
	__20.  Check that your request has the correct URL, content-type and body for the request.
	__21.  Click the  icon next to the URL.
	__22.  Check in the 'HTTP Response' section that a "No Content" status of 204 is returned.
	__23.  Make sure that the Eclipse console log shows the employee data correctly.
	__24.  Return to the RESTClient tool and add a minus sign in front of the employee ID.  You can do this by just clicking inside the body and typing.  Make sure it is between the two XML tags for the 'empID' value.
	__25.  Click the  icon next to the URL.
	__26.  Observe that this time in the Eclipse console the negative ID is used.
	__27.  Leave the RESTClient tool open.
	__28.  Open Employee.java from the 'com.acme.services' Java package of the  JAXRS-Data project if you had closed it.
	__29.  Add the following @Min annotation before the 'empID' field.  Make sure it is located inside the class and right before the declaration of the 'empID' field.  You will have some errors until the next steps.
	__30.  Organize imports (Control+Shift+O). 
	__31.  Save changes and make sure there are no compilation errors.
	__32.  Return to the 'submitEmployee' method of the 'SimpleService' class.
	__33.  Add the following @Valid annotation before the 'Emplyee' method parameter as shown below.  Make sure it is inside the parenthesis of the method parameters but before the 'Employee' type of the parameter.  You will have some errors until the next steps.
	__34.  Organize imports (Control+Shift+O). 
	__35.  Save changes and make sure there are no compilation errors.
	__36.  In the Servers view, right click the server and select Publish.
	__37.  Return to the RESTClient tool.  Make sure you have the same request still loaded with the negative employee ID from before.
	__38.  Click the  icon next to the URL.
	__39.  This time your response should be a 400 "Bad Request" response.  If it is still the same '204' as before check that you published the updates to the server.
	__40.  Click the Body tab on the response section.  Notice that the body contains some text indicating that the supplied value must be greater than or equal to '0'.
	__41.  If you look in Eclipse notice there are no messages from the service.  This is because the service is never called with invalid data.
	__42.  Close all browsers and the RESTClient tool.
	__43.  Close all open files.

	Part 6 -  Cleanup
	__1.  Undeploy and close the JAXRS-Data project as described in the 'Common Lab Steps' at the 'Lab Cleanup' part on page 103.

	Part 7 -  Review

	Lab 4 -  Designing a RESTful Service
	Part 1 -  The Business Requirements
	Part 2 -  Define Project Scope
	Part 3 -  Designing the Object Model
	__1.  Can you go through the business requirements and identify the entities? 
	__2.  Now that you have identified the entities, can you list the attributes or fields for each entity? Once again, the answer is below. But do your best to do the design yourself.

	Part 4 -  Identify the Service
	__1.  Can you go through the requirements and list the tasks or operations that various yet to be identified services need to perform? Then compare your findings with the answer below.
	__2.  Can you group the operations based on the entity they work with? Name each group as a service accordingly. The answer is below.

	Part 5 -  Design the Service Interface
	__1.  First, let us decide on the URI for each entity. This is a pretty straightforward exercise. Note: As a matter convention, plural forms of the entity names are used in URI.

	Part 6 -  Decide on the Data Format
	Part 7 -  Unaddressed Architectural Issues
	Part 8 -  Review

	Lab 5 -  Working With Content Types
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\JAXRS‑Content\JAXRS‑Content‑Starter.zip' file as described in the 'Common Lab Steps' at the 'Lab Setup' part on page 100.

	Part 2 -  Complete the Entity Classes
	__1.  Open QuoteRequest.java from the 'com.acme.services.entities' Java package of the  JAXRS-Content project.
	__2.  In the QuoteRequest class, add these member variables. Feel free to refer back to the object model to make sure we are doing this correctly.
	__3.  Generate getters and setters for the variables. To do this select any variable, then from the menu select Source >  Generate Getters and Setters. Click Select All and click OK.
	__4.  Add the @XmlRootElement JAXB annotation to the class as shown in bold below.  You will get errors until the next steps.
	__5.  Organize imports.
	__6.  Save changes.
	__7.  Open QuoteResponse.java from the 'com.acme.services.entities' Java package of the  JAXRS-Content project.
	__8.  Examine some of the existing code in the class.  Notice it is just standard Java code.
	__9.  Add the @XmlRootElement JAXB annotation to the class as shown in bold below.  You will get errors until the next steps.
	__10.  Organize imports.
	__11.  Save changes.

	Part 3 -  Generate the XML Schema
	__1.  In the Project Explorer view, right click on the JAXRS-Content project and select New → Other.
	__2.  Expand JAXB and select Schema from JAXB Classes and click the Next button.
	__3.  Change the name of the schema to JAXRS-Content.xsd
	__4.  Click Next.
	__5.  Expand the JAXRS-Content → src folder and select the com.acme.services.entities package.
	__6.  Click the Finish button to generate the schema.
	__7.  Close the editor that appears and ignore the error about a resource not being found.
	__8.  After a few seconds check that the root of the project has the schema, note that it was renamed to JAXRS-Content1.xsd.
	__9.  Open the generated schema file and study it if you wish.
	__10.  Close all open files.

	Part 4 -  Code the Quote Service Class
	__1.  Open QuoteService.java from the 'com.acme.services' Java package of the JAXRS-Content project.  Note that the only code is a field used for logging.
	__2.  Set the root URI of the service as shown in bold below.  You will get errors until the next steps.
	__3.  Add the getQuote() method as shown below. The business logic is very simple. We hard code the price and availability.
	__4.  Annotate the method as shown below.
	__5.  Organize imports. 
	__6.  Save changes.  Make sure you have no errors.

	Part 5 -  Better Content Handling
	__1.  Add the @Consumes annotation to getQuote as follows in bold.
	__2.  Similarly, add the @Produces annotation to support both MIME types for XML.
	__3.  Organize imports. Select javax.ws.rs.core.MediaType and javax.ws.rs.Produces.
	__4.  Save changes.  Make sure you have no errors.

	Part 6 -  Unit Testing
	__1.  Start the WildFly server if it was not running.
	__2.  Right click the server and select Add and Remove.
	__3.  Add the JAXRS-Content project to the server.
	__4.  Click Finish.
	__5.  Open the RESTClient tool as described in the 'Common Lab Steps' at the 'Start RESTClient Tool' part on page 102.
	__6.  In the URL text box, enter: 
	__7.  Select POST method.
	__8.  Click the Body tab below the URL text box.
	__9.  Use the drop-down on the Body tab to select 'String body'.
	__10.  Click the 'Edit Content-type & Charset' button
	__11.  From the drop-down select the text/xml content type.
	__12.  Click OK.
	__13.  Click the 'Load from file' button.
	__14.  Find and select the 'quote_request.xml' file in the '<LABFILES>\JAXRS‑Content' folder and press the 'Open' button when you have the correct file selected.
	__15.  Check that your request has the correct URL, content-type and body for the request.
	__16.  Click the  icon next to the URL.
	__17.  Make sure that the HTTP reply status code is 200.
	__18.  Click the Body tab for the response.
	__19.  Right click the response body text and select Format > XML.
	__20.  Study the response document.
	__21.  Leave the REST Client tool open for the next section.

	Part 7 -  Add Support for JSON
	__1.  Open the QuoteService class if you had closed it.
	__2.  First, add the shell of the method.  Make sure this is outside of other method definitions but inside the class.  You will get errors until the next steps.
	__3.  Then, annotate the method as shown in bold below.
	__4.  Now, fill in the body of the method. It basically calls the getQuote() method to get the job done.
	__5.  Save changes.

	Part 8 -  Understanding Content Negotiation
	Part 9 -  Test
	__1.  Publish the server by right-clicking and selecting Publish.
	__2.  Launch the REST client tool if it is not already running.  
	__3.  If you needed to relaunch the RESTClient tool, use steps from part 6 of this lab to configure the URL, method, and body of the request but do not yet submit the request.  If you had left the RESTClient tool running these should already be configured.
	__4.  Click the Headers tab.
	__5.  Enter Accept as Key and text/xml as Value.
	__6.  Click the + icon to add the header.
	__7.  Run the test by clicking .
	__8.  Right click the response body area in the Body tab and select Format > XML.
	__9.  Verify that the reply body contains the response in XML format.
	__10.  In the Header tab of the request section, select the Accept header, then right click on it and select Remove Selected.
	__11.  Enter Accept as Key and application/json as Value, then click the + icon to add the header.
	__12.  Click the Body tab in the request area.
	__13.  Click the 'Edit Content-type & Charset' button
	__14.  From the drop-down select the application/json content type.
	__15.  Click OK.
	__16.  Click the 'Load from file' button.
	__17.  Find and select the 'quote_request.json' file in the '<LABFILES>\JAXRS‑Content' folder and press the 'Open' button when you have the correct file selected.
	__18.  Check that your request has the correct URL, content-type and body for the request.
	__19.  Click the  icon next to the URL to run the test.
	__20.  Make sure that the HTTP reply status code is 200.
	__21.  Click the Body tab for the response.
	__22.  Right click the response body text and select Format > JSON.
	__23.  Study the response document.
	__24.  In Eclipse, close all open files.

	Part 10 -  Cleanup
	__1.  Undeploy and close the JAXRS-Content project as described in the 'Common Lab Steps' at the 'Lab Cleanup' part on page 103.

	Part 11 -  Review

	Lab 6 -  Complex JAX-RS Responses
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\JAXRS‑Complex\JAXRS‑Complex‑Starter.zip' file as described in the 'Common Lab Steps' at the 'Lab Setup' part on page 100.

	Part 2 -  Examine Existing Code
	__1.  Open Order.java from the 'com.acme.services.entities' Java package of the  JAXRS-Complex project.
	__2.  Notice this is just a basic Java class with some properties and a JAXB @XmlRootElement annotation.  There is also a @XmlElement annotation on the 'getLineItemList' to control the XML element used for each line item so it makes more sense in the XML.
	__3.  Examine the code in the LineItem.java and OrderList.java files in the same package.
	__4.  Open OrderDAO.java from the 'com.acme.services' Java package.
	__5.  Examine the code and notice that this establishes an in-memory database of Order objects that can be added to and queried.  It is implemented with a static Hashtable just so we can retrieve Orders created by previous service requests without involving database code or configuration.
	__6.  Close all open files without any changes.

	Part 3 -  Implement Order Retrieval
	__1.  Open OrderService.java from the 'com.acme.services' Java package.
	__2.  Annotate the class to set the path as follows.
	__3.  Organize imports. 
	__4.  Save changes.
	__5.  Inside the OrderService class, add the following method shell along with the required annotations.  You will have errors until later steps.
	__6.  Next, fill in the method body.
	__7.  Organize imports. Select these classes when prompted (they may come up in a different order).  
	javax.ws.rs.core.MediaType
	com.acme.services.entities.Order
	javax.ws.rs.PathParam
	javax.ws.rs.Produces
	java.util.logging.Level
	__8.  Save changes.  There should be no errors.

	Part 4 -  Implement Order Placement
	__1.  Write the shell of the method as follows in the OrderService class. We will not deal with the returned response just yet.
	__2.  Annotate the method with @POST and @Consumes.
	__3.  Organize imports. Select the javax.ws.rs.core.Response class when prompted.
	__4.  Save changes.
	__5.  In the placeOrder method of the OrderService class, use OrderDAO as shown in boldface below.
	__6.  First, add a member variable to the class as follows.  You will have errors until the next steps.
	__7.  In the placeOrder() method, add the bold code within the 'try' block:
	__8.  Add this line in bold below:
	__9.  Next, add the following line. This plugs in the actual value of the order ID to the path and returns a java.net.URI object.
	__10.  Finally, add this line. 
	__11.  Organize imports. Choose this class:
	__12.  Check that your final code for the complete method matches that shown below.
	__13.  Save the file and make sure you don't have any compilation errors.

	Part 5 -  Test
	__1.  Start the WildFly server if it was not running.
	__2.  Right click the server and select Add and Remove.
	__3.  Add the JAXRS-Complex project to the server.
	__4.  Click Finish.
	__5.  Open the RESTClient tool as described in the 'Common Lab Steps' at the 'Start RESTClient Tool' part on page 102.
	__6.  From the REST client's menubar, select File > Open Request (Ctrl+O).
	__7.  Open <LABFILES>\JAXRS-Complex\order_create.rcq
	__8.  Review these items about the request:
	__9.  Click the  button to send the request.
	__10.  Verify that:
	__11.  In the Console, verify the log output from the OrderDAO class.
	__12.  In the REST client, open the request file <LABFILES>\JAXRS‑Complex\order_retrieve.rcq.
	__13.  Verify:
	__14.  Send the request.
	__15.  Verify that the reply body has the correct order information.
	__16.  Leave the RESTClient tool running for the next sections.

	Part 6 -  Enable Error Handling
	__1.  In the placeOrder() method of OrderService class, add this line shown in bold.
	__2.  Comment out the following unreachable line:
	__3.  Organize imports. 
	__4.  In the getOrder() method, add the following code to the end of the method before the return statement:
	__5.  Organize imports. Choose this class:
	javax.ws.rs.core.Response.Status
	__6.  Save changes.  Make sure there are no errors.

	Part 7 -  Test
	__1.  Publish the  server in the Servers view.
	__2.  In the REST client, the order retrieval request file should be open already. Just run the test.
	__3.  Verify that the status code is 404.  This is because the previous order was lost when the application was updated and restarted.
	__4.  Open the request file <LABFILES>\JAXRS-Complex\order_create.rcq.
	__5.  In the Body tab, delete all the <item> elements.
	__6.  Run the test.  
	__7.  Verify that status code 500 is returned.
	__8.  Do regression tests to make sure that success conditions are working fine.
	__9.  Do not close the REST Client.

	Part 8 -  Implement Order Cancellation
	__1.  Return to the OrderService.java file and open it if you had closed it.
	__2.  Add this method.  Make sure it is inside the class but outside other methods.
	__3.  Add these lines to the cancelOrder() method.
	__4.  Organize imports.
	__5.  Save changes.

	Part 9 -  Test
	__1.  Publish the  server.
	__2.  Launch the REST client tool if it is not already running. 
	__3.  From the client, open the request file <LABFILES>\JAXRS‑Complex\order_create.rcq
	__4.  Run the test. You should get a status code of 201. 
	__5.  Open the request file <LABFILES>\JAXRS‑Complex\order_retrieve.rcq
	__6.  Run the test. You should get a status code of 200 and the order data in the body.
	__7.  From the Method tab, select DELETE.
	__8.  Run the test. 
	__9.  Since the reply body is empty, you should see HTTP status code 204. This is equivalent to status 200 and indicates success.
	__10.  In the Method tab, select GET method.
	__11.  Run the test.
	__12.  Verify that 404 is returned.

	Part 10 -  Implement Order History
	__1.  In the OrderService class, add the method shell as follows.
	__2.  Add the method body as follows.
	__3.  Organize imports.
	__4.  Save changes.

	Part 11 -  Test
	__1.  Publish the server.
	__2.  From the REST test client, open the request file <LABFILES>\JAXRS‑Complex\order_create.rcq
	__3.  From the Body tab of the request, note the client ID – C001.
	__4.  Run the test to create an order.
	__5.  From the Body tab of the request, change the part number and quantity ordered.
	__6.  Run the test to place a few more orders.  You should see a different order ID in the 'Location' header of the response.
	__7.  From the test client, open the request file <LABFILES>\JAXRS‑Complex\order_history.rcq
	__8.  Run the test.
	__9.  Select Format → XML in the body of the response, scroll down and verify that all orders are shown.

	Part 12 -  Implement Order Update Function
	__1.  In the OrderService class, add the method shell.
	__2.  Fill in the method body as follows.
	__3.  Organize imports.
	__4.  Save changes.

	Part 13 -  Test
	__1.  Publish the  server.
	__2.  From the REST test client, open the request file <LABFILES>\JAXRS‑Complex\order_create.rcq
	__3.  Run the test.
	__4.  Add the order ID 1000 to the URL (add  /1000  at the end of the URL).
	__5.  From the Method tab, choose PUT.
	__6.  From the Body tab, change quantity and/or part number.
	__7.  Run the test.
	__8.  Verify that status code 200 is returned.
	__9.  Now lets check the retrieve request. Open the request file <LABFILES>\JAXRS‑Complex\order_retrieve.rcq
	__10.  Run the test.
	__11.  Verify that status code 200 is returned.   
	__12.  Format the result (Format > XML ) and verify that the body contains the information that you changed.
	__13.  Open the request file <LABFILES>\JAXRS‑Complex\order_create.rcq
	__14.  Add an invalid order ID in the URL as shown below.
	__15.  From the Method tab, choose PUT.
	__16.  Run the test and make sure 404 status code is returned.
	__17.  In Eclipse, close all the open files.

	Part 14 -  Cleanup
	__1.  Undeploy and close the JAXRS-Complex project as described in the 'Common Lab Steps' at the 'Lab Cleanup' part on page 103.

	Part 15 -  Review

	Lab 7 -  Developing a JAX-RS Client
	Part 1 -  Java Client Design Considerations
	Part 2 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\JAXRS‑Client\JAXRS‑Client‑Starter.zip' file as described in the 'Common Lab Steps' at the 'Lab Setup' part on page 100.  Note you are importing two projects, one for a service and one for client code.

	Part 3 -  Examine Existing Java Code  
	__1.  Open QuoteService.java from the 'com.acme.services' Java package of the JAXRS-Client-Service project.  Note this is just a simple JAX-RS service that is provided so we can focus on the client code.
	__2.  In the JAXRS-Client-Client project, expand the Java code and notice the classes in the 'com.acme.services.entities' Java package are already in the client project.  These represent Java classes for the data structures used by the REST service.  Even if the service itself was not implemented in Java, you would still need classes like these for a Java client.
	__3.  Close all open files without making any changes.

	Part 4 -  Build the Service Proxy Layer
	__1.  Open QuoteProxy.java from the 'com.acme.services.proxy' Java package of the  JAXRS-Client-Client project.
	__2.  In the QuoteProxy class, add a variable to store the service URL.
	__3.  Add the shell of a method that will invoke the quote web service.  Make sure to add this inside the class declaration.  You will have errors until the next steps.
	__4.  In the getQuote() method, add this line to instantiate a JAX-RS Client and WebTarget objects.
	__5.  Add the following code to set properties of the JAX-RS Invocation object that will be used to invoke the service.  Note that this is a single statement with many method calls "chained together" so double check the syntax.
	__6.  Finally, add the following code to invoke the service, close the client and return the QuoteResponse object obtained with the response from the 'getQuote' proxy method.
	__7.  Organize imports and select the following classes when prompted:
	__8.  Save changes.  Make sure you don't have any compilation errors at this point.

	Part 5 -  Build the Presentation Layer
	__1.  From the WebContent folder of the JAXRS-Client-Client project, right click input.jsp and select Open With >  Web Page Editor.
	__2.  Study the form.
	__3.  Open result.jsp in the Web Page Editor and study how the QuoteResponse object properties are shown.
	__4.  Close both JSP files without making any changes.
	__5.  From the com.webage.servlet package, open QuoteController.java.
	__6.  Locate the doPost method.
	__7.  Add these lines to construct a QuoteRequest object.  You will have errors until future steps.
	__8.  Add these lines to invoke the service using the proxy class we created earlier:
	__9.  Add these lines to show the response in a JSP
	__10.  Organize imports.
	__11.  Save changes.  Check that you have no errors in the file.

	Part 6 -  Test
	__1.  Start the WildFly server if it was not running.
	__2.  Right click the server and select Add and Remove.
	__3.  Add BOTH the JAXRS-Client-Client and JAXRS-Client-Service projects to the server.
	__4.  Click Finish.
	__5.  Open a web browser and enter the URL: 
	__6.  Enter some values and click Get Quote.
	__7.  Verify the result.
	__8.  Close the browser.
	__9.  Leave the server running for the next section.
	__10.  Close all open files.

	Part 7 -  Send Request With JavaScript Client
	__1.  From the WebContent folder of the JAXRS-Client-Client project, right click rest_utils.js and select Open With >  JavaScript Editor.
	__2.  Examine the code of the 'invokeByPost' function.  This function takes parameters for the URL to invoke, the request data to send in the body as a JSON object, the 'onLoad' function to call when the response is returned, and the acceptable content type for the response.  Probably the key line in the function is the call to the 'JSON.stringify' function that takes an object and converts it into a JSON string for the body of the request.
	__3.  Close the 'rest_utils.js' file without making any changes.
	__4.  From the WebContent folder of the JAXRS-Client-Client project, right click inputAJAX.html and select Open With >  Web Page Editor.
	__5.  To make it easier to work with the source code of the page, select the 'Only Show Source Page' button in the toolbar of Eclipse.
	__6.  Notice the following line of code in the HTML file which will load the utility functions from the file you just examined.
	__7.  Find the declaration of the 'sendRequest' function in the code of the HTML page.
	__8.  At the beginning of the 'sendRequest' method, add the following code to construct an object with properties for the request parameters to be sent.  This will be used by a utility method to send the POST request.
	__9.  Add code to use the invokeByPost() utility method to send the request.  Be careful with the syntax as the code wraps to several lines below because of the long URL.
	__10.  Save changes.

	Part 8 -  Process the JavaScript Response
	__1.  Find the declaration of the 'showResponse' function in the code of the HTML page.
	__2.  After the comment about parsing the JSON response, add the following code in bold.
	__3.  Add the following bold code to display the data returned by the response on elements of the page.
	__4.  Save changes.

	Part 9 -  Test
	__1.  Publish the Wildfly server in the Servers view.  Start the server if you had stopped it.
	__2.  Open a browser and enter the following URL.  If you use Internet Explorer it must be IE 9 or later with HTML5 JSON support.
	__3.  Enter some data and click Get Quote AJAX.
	__4.  The application will send a request and you should see the response data in the same page.
	__5.  If you look in the Console view in Eclipse, you should see a message that the service processed a JSON response.
	__6.  Close all open browsers.
	__7.  Close all open files in Eclipse.

	Part 10 -  Cleanup
	__1.  Undeploy and close the JAXRS-Client-Client and JAXRS-Client-Service projects as described in the 'Common Lab Steps' at the 'Lab Cleanup' part on page 103.

	Part 11 -  Review




