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Lab 1 - Starting Out With Git

At the end of this lab you will be able to:
1. Install git on windows

2. Create a git repository

3. Perform basic git functions on the repository

Part 1 - Install Git
First, we're going to install “Git For Windows”.  For the lab, we have provided the 
download file for you.  For your real installations, you can retrieve the download from 
“http://git-scm.com/download/win”.  It is free software, licensed under the GPL.

__1. Using Windows Explorer, navigate to C:\Software.
__2. Locate the file Git-2.8.1-32-bit.exe, and double-click on the file to run it.

__3. Windows may show a message as below. Click Yes.
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__4. The installer shows the licensing dialog.  Click Next.

__5. Accept the default for the installation location by clicking Next.
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__6. The installer shows the Select Components dialog.  Leave all the defaults as-is, and 
then click Next.

__7. The installer will display the Select Start Menu Folder dialog.  Leave the default 
as-is and then click Next.
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__8. The installer will display the Adjusting your PATH environment dialog. Select the 
radio button for Use Git from the Windows Command Prompt, and then click Next.

__9. The installer displays the Configuring the line ending conversion dialog.  Leave 
the default as-is, and then click Next.
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__10. Click Next to leave the default.

__11. Click Install.

The installer will run for a few seconds installing Git.

7

EVALU
ATIO

N O
NLY



__12. The installer will display the Git Setup dialog.  Un-check the checkbox for View 
Release Notes, and then click Finish.

That's it! We've installed Git for Windows

Part 2 - Set Windows Explorer View Options
By default, Windows Explorer hides the extensions of files when there is an application 
associated with that file.  We're going to shut that off so that we can see the entire file 
name in Windows Explorer.

__1. Open Windows Explorer.

Note. The following steps are for Windows 7 and may vary on other OS.

__2. From the menu, select Tools → Folder Options.
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__3. Click the View tab to select it.

__4. Find the entry for “Hide extensions for known file types”.  Make sure it is un-
checked, and then click OK.

__5. Leave the Windows Explorer window open – we'll be using it in the next part of the 
lab.

Part 3 - Create a Workspace Folder with a Repository
__1. Use Windows Explorer to create a folder in the C: drive called C:\workspace
__2. Double-click on the new folder to open it.

__3. Create a new folder called BasicOperations

__4. Open a Windows Command Prompt by going to the start menu and then type 'com'. 
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The search box will appear, and one of the entries in it should be the "Command Prompt". 
Click the command prompt to open it.

__5. At the command prompt, enter
cd \workspace\BasicOperations

__6. At the command prompt, enter
git init

__7. You should see git create the repository, as shown:

__8. Go back to the Window Explorer.  Double-click on the BasicOperations folder to 
enter it.

There probably appears to be nothing in this folder, but there is actually a hidden folder 
that contains the git repository.  Let's change the view options so we can see it.
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__9. In the Explorer main menu, click Tools → Folder Options. Then click the View tab 
and select Show hidden files, folders, and drives and click OK.

__10. Now we can see that there is a folder called '.git' inside the BasicOperations 
folder. This folder is the git repository.  The name comes from the Unix convention where 
the shell's 'ls' command considers a file 'hidden' if it starts with a '.' character.

Part 4 - Tell Git Who You Are
One interesting aspect of Git is that it separates user identity in the repository from any 
sort of authentication or authorization.  Because a distributed repository will generally be 
maintained by many separate individuals or systems, the identity of the committer must 
be contained in the repository.  A system like 'Subversion' would ask you to authenticate 
against its authentication database when you did a “commit” to its remote repository, but 
Git has some challenges in this area:  First, the act of doing a “commit” is separate from 
the act of “pushing” changes to a remote repository.  Second, there is no central 
repository or authentication database.  Third, when we eventually send changes to a 
remote, those changes could include changes that we got from other developers, and we 
want to preserve information on “who did what changes”.  So, even if we're not 
connected to any central repository, we need to tell Git who we are.  The identity that we 
supply will be recorded whenever we commit to a repository.  This identity is part of Git's 
configuration.  As such, you could have a global identity (i.e. for every repository you 
have), or you could have a different identity in each local repository.  We're going to set 
up a global identity.

For the purposes of this lab, we're going to use an imaginary user named “Alice Smith”, 
who has an email address “alice@smith.com”.

__1. Ensure that the Command Prompt is showing the BasicOperations folder from the 
last part of the lab.

__2. Enter the following two lines in the Command Prompt:
git config --global user.name "Alice Smith"
git config --global user.email alice@smith.com
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__3. Ensure that there were no error messages.  The output should be similar to:

Part 5 - Create Files and Commit Them to the Repository
Now we'll create a file or two and do our first commit.  For the sake of simple tools, we're 
going to just use Notepad here, since it's already installed with Windows, but feel free to 
install and use a different editor if you prefer.

__1. Ensure that Windows Explorer is showing the BasicOperations folder from the last 
part of the lab.

__2. Right-click in an empty area of the main panel, and select New → Text Document.
__3. Windows will create the new file, and should leave the file name selected for you to 
edit.  Change the file name to Sample.txt
__4. Double-click on Sample.txt to open it in Notepad.  Change the contents to read 
“First Version.” and hit enter.

__5. Save the file by clicking File → Save, and then close the file by clicking the close 
button.

At this point, the file is there, but Git isn't tracking it yet (even though Git certainly 
knows it's there, after all it's in the file system).  Let's add the file into Git's staging area.

__6. In the command prompt, enter:
git status

Git will tell us about the files it sees in the folder:
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As we can see, git is aware of the new file, but it is "untracked".  Let's change that.

__7. At the command prompt, enter:
git add .

The '.' says to add the contents of the current directory.  If you preferred, you could have 
called out the name of the file itself.

__8. At the command prompt, enter:
git status

Git should now report that the file is "staged" as a file to be committed.

Before we do the commit, let's talk about the default editor.  A Commit needs to be 
accompanied by a 'commit message' that goes into the repository's log to explain the 
commit.  We could provide a commit message with the '-m' option to git's command line, 
however, that tends to lead to short, one-line commit messages.  Normally, we'd like to be 
a little more descriptive with the commit message.  As a result, if we don't specify a 
commit message, git will open up an editor with a default message from a template.
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By default, the editor is a Windows version of 'vim' that was installed with the git 
package.  If you're familiar with 'vim' then go ahead and use it (it's an excellent 
programmer-oriented editor), but if you're not already a 'vim' user, it's a little complicated 
to explain here.  So, we'll change the default editor to Wordpad in the next step.

__9. At the command prompt, enter (all this should be on one line):
git config --global core.editor "'C:\Program 
Files\Windows NT\Accessories\wordpad.exe'"

Note the single quotes and double-quotes in the above line.  They need to be typed 
exactly as shown, because the path to the wordpad executable contains spaces.

__10. At the command prompt, enter:
git commit

__11. An instance of Wordpad should open, with the default commit message in it.
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__12. Enter a message at the top of the file.  For instance, “First commit in the new repo.”

__13. Save the file by selecting File → Save, and then exit Wordpad by clicking the close 
button.

__14. The command prompt should reflect the completed commit:

__15. Open the 'Sample.txt' file with Notepad again, and then change the contents to 
read 'Second Version'.  

__16. Save and close the file.

__17. Once again, go to the command prompt and enter:
git status

Git should tell us that 'Sample.txt' was modified, but is not currently staged for commit.

If we were to commit now, we would actually be committing without any changes. In fact 
git will tell us that there are no changes staged, and we need to add files before 
committing.

__18. At the command prompt, enter:
git diff

Git will show us what' changed in the folder.
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__19. Having reviewed the 'diff', we can decide to go ahead and commit all the changes. 
At the command prompt, add all the updated files into the staging area by entering:

git add .
__20. At the command line, enter:

git commit
__21. Git opens up Wordpad with the proposed commit message. Note that the file now 
appears under 'Changes to be committed'.

__22. The commit message is intended for us to give a description of the commit that will 
be useful when we review the logs.  Enter 'We're on the second version.', and then save 
the file and close Wordpad.

Part 6 - Review the Change History
At this point, we've now committed two different versions of the file 
'Sample.txt'.  Let's see if we can find any evidence of this history.
Just to be different, let's try out Git's command shell.
__1. Ensure that the Windows Explorer window is still open and displaying the 
C:\workspace\BasicOperations folder.

__2. Right-click in an empty area of the window, and then click on 'Git Bash Here'.

Git will display a new terminal window with a '$' prompt.  If you've used Unix or Linux, 
you may recognize this as the Bourne shell or 'bash' prompt.  In fact, Git for Windows 
includes a variant of the 'bash' shell derived from the 'Cygwin' system.  Cygwin is a 
software package that provides a traditional Unix-style shell and the full set of Unix-style 
utilities in a Windows environment.  Git for Windows includes a subset of these utilities.

The git commands are available at a command prompt, or through the 'Git Bash' facility, 
or also in Windows PowerShell.  The commands and arguments are identical in all three 
access modes, so choosing one is a matter of individual taste.

__3. Type 'git log' and press return.
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Git displays a list of all the commits that we have done, in reverse chronological order.

__4. Leave the Git Bash window open for the next part of the lab.

Part 7 - Delete a File and Recover It
In this section, we'll demonstrate that files are actually stored in the repository, even if we 
delete the file in our folder.

__1. Using Windows Explorer, delete the file 'Sample.txt'.  Right-click on the file and 
select Delete.
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__2. In the Git Bash window, type 'git status' and press return.

Notice that git sees the removal as a change that has not been staged or committed.  If we 
really wanted the change to stick, we could say 'git rm Sample.txt' to stage the removal, 
and then we could commit the change.  Instead, we'll recover the file from the repository.

__3. Type 'git checkout -- Sample.txt' and then press return.

'Sample.txt' has re-appeared in Windows Explorer.

Note:  The command 'git checkout -- Sample.txt' looks a little funny – what's the double-
dash for?  The answer will make more sense after we've talked about branches. 
Basically, it's possible to pull a file in from a different branch than the one that we're 
currently on, so the 'git checkout' command actually allows you to specify the branch 
name and the file path we want to recover.  '--' separates the parameters from the list of 
files, and basically indicates the current branch.

Part 8 - Use a '.gitignore' File
It's common to have files in a working directory that we don't really want to put into the 
repository.  For example, a compiler might take “hello.c” and generate “hello.o”.  Since 
“hello.o” is a generated file, and will be regenerated every time we execute the build, it 
makes no sense to put it into version control.  We can create a file called '.gitignore' that 
specifies a set of patterns to specify files that should be excluded from the repository.

__1. Ensure that our Windows Explorer is still displaying the 
'C:\workspace\BasicOperations' folder.  
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__2. Right-click in an empty area of the Explorer window, and then select New → Text 
Document.
__3. Explorer will show the new file, with the base part of the name (excluding '.txt') 
selected.  Type 'gitignore'.  Right now we are calling the file 'gitignore.txt'.

Note:  We really want the file to be called '.gitignore', but Windows Explorer doesn't like 
that style of name.  We're going to edit the file in a format that Explorer likes, and then 
rename it in the bash prompt window.

Alternately, if you are familiar with the 'vi' editor, the git bash utility includes a version 
of 'vim' that you can open from the bash prompt, with command 'vi .gitignore'.

__4. Double-click on 'gitignore.txt' to open it in Notepad.

__5. Add the following three lines to 'gitignore.txt':

*.o
local.properties
temp/**

__6. Save and close the file.

__7. In the git bash window, enter:

mv gitignore.txt .gitignore
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__8. In the git bash window, enter:

git status

Notice that git is telling us that we have unstaged changes – the '.gitignore' file that we 
just created.  This time we'll use the command line to add and commit them.

__9. In the git bash window, enter 'git add .' (note the 'dot' at the end) and then press 
return.

__10. In the git bash window, enter the following line, and then press return:

git commit -m "We now have an ignore file."

In this example, we've used a shortcut "-m" option to specify the commit message.  If you 
leave out that option on the command line, git will open up an editor (in this case 'vi') to 
let you edit the commit message.

__11. Enter the following line and then press return, to create a file called 'hello.o':

echo 'Hi there' > hello.o

__12. Enter 'git status' and press return.

Notice that git reports nothing to commit.  Because the file name 'hello.o' matches the 
pattern in the line '*.o' in our '.gitignore' file, git ignores it.  It would also ignore a file 
called 'local.properties' and a folder called 'temp'.
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Part 9 - Review
In this lab, we started off by installing Git for Windows, and then created a repository and 
executed a few simple operations on it.

One concept to note is the idea of the separate areas of a project that we're managing 
under git: the working directory, the staging area, and the repository.  The working 
directory is the area that is currently in the operating system's file system.  We make 
changes to files in the file system, and then tell git which changes we want to record by 
copying the changes to the staging area (or 'staging' them) using 'git add'.  Then we put 
the changed snapshot into the repository by 'comitting' them.  Once a file is in the 
repository, it is there forever, even if we remove it from the working directory.  We can 
recover any version of the file that we've previously committed.
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Lab 2 - Branching, Merging and Working with Remotes
One of the main themes of Git is the idea that we should isolate work on branches and 
use those branches to coordinate the work of multiple developers.  In this lab, we'll 
examine the use of branches and the act of merging.

In addition, Git works on the basis of distributed repositories.  We'll explore the use of 
more than one repository, or Remote repositories.

At the end of this lab you will be able to:
1. Clone an existing repository

2. Create a branch

3. Merge a branch onto another branch.

Part 1 - Clone a Repository
For this lab, we will clone a pre-existing repository that has been provided to you

__1. Using Windows Explorer, navigate to C:\workspace

__2. Open a command prompt window, and then enter:
cd \workspace

__3. In the command prompt window, enter:
git clone \LabFiles\BranchMergeRemotes

This command creates a clone of the repository that is located in the file system at 
'C:\LabFiles\BranchMergeRemotes'.  

Notice that in the Windows Explorer window, there is a new folder called 
BranchMergeRemotes.

In this case, we're cloning from a repository that is in the file system, but the exact same 
syntax can be used to clone from a repository on a remote server.  The only difference is 
the URL that's used to identify the original repository.

For instance, 'git clone https://github.com/angular/angular.js.git' would create a local 
copy of the repository that contains the popular 'AngularJS' framework, which is hosted 
on GitHub.

__4. In the Command Prompt window, type the following and then press return:
cd BranchMergeRemotes

Part 2 - Create a Branch to Work on a Feature.
In many version control systems, particularly older systems, creating a branch is a 
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difficult and often expensive operation.  In Git, however, creating a branch is a very 
lightweight operation, and in general, we want to create a branch for every feature that 
we work on.  When a feature reaches a stable state, we'll merge it back to the master 
branch.  In this way, the master branch only contains stable features, and any developer's 
work is isolated in its own feature branch.

__1. In the Command Prompt window, type the following, pressing return after each 
line:

git branch add-text
git checkout add-text

The lines above create a new branch called 'add-text' (which is a description of what 
we're about to do), and then switch to that branch.

Note: The two commands above could have been shortened to 'git checkout -b add-text'.

__2. Type 'git status'.

Notice that the status message indicates that we're on the branch called 'add-text'.

That's all that's required to create a branch in Git!

__3. Type 'git branch'.

The branch command on its own simply lists the branches that are defined in the 
repository.  Notice that the 'add-text' branch is both highlighted and has an asterisk next 
to its name, indicating that we're on that branch.

Part 3 - Work on the Branch
When we're on a branch, we can go ahead and make some changes and then stage and 
commit those changes.

__1. In Windows Explorer, navigate to 'C:\workspace\BranchMergeRemotes'.

__2. Right-click on 'index.html', and then select Open With → Notepad.

__3. Replace the text 'Hello World' with 'This is the text that we really want.'
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__4. Save and close the file.

__5. Back in the Command Prompt window, type 'git status'.

Notice that git now tells us that the file 'index.html' has been updated, but not staged. 
We could use the 'git add' command to stage the changed file, but instead we're going to 
add an option to 'git commit' that will automatically stage all the changes.

__6. Type the following and then press return:
git commit -a -m "We now have the text we want."

__7. In Windows Explorer, double-click on 'index.html' to open it in a web browser.

Notice that the newer text is displayed.

__8. Close the web browser.

Part 4 - Merge Back to the Master Branch
We have committed changes to the feature branch that we created and called 'add-text'. 
Now let's say that we're happy with the feature and want to 'promote' it to the master 
branch.

The general procedure is as follows:

•Switch to the master branch
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•Merge the changes from the feature branch

•Optionally, delete the feature branch

__1. In the Command Prompt window, enter the following line, and then press return:

git checkout master

__2. As above, open 'index.html' with a web browser, but notice that the text now reads 
'Hello World' again.

__3. In the Command Prompt window, type 'git merge add-text'.

__4. As above, open 'index.html' with a web browser, but notice that we have the 
updated text.

__5. We're done with this feature branch, so let's delete it.  In the Command Prompt 
window, type 'git branch -d add-text' and then press return.

There's no cost the keeping the branch around (remember that a branch is really just a 
reference to a particular committed snapshot), but it will generally prevent confusion if 
we keep the branch set clean by deleting branches that we're not actively using.

Part 5 - Push to Another Remote Repository
Let's say we wanted to create a new repository and store all our changes there.  In 
essence, this is what we would do when we first create a project.

As it stands, we have a local repository that contains a number of snapshots.  The basic 
procedure to create a remote repository will be:

•Create an empty remote repository

•Push our changes to that repository

For simplicity, we'll use another repository in the local file system, but as with pulling 
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from a remote server, the only difference would be the url used for the repository.

__1. In the Command Prompt window, enter the following, and then press return:
mkdir \workspace\AnotherRemote

__2. In the Windows Explorer window, navigate to C:/workspace.  Notice that there is a 
new folder called 'AnotherRemote'.

__3. In the Command Prompt window type the following, and then press return:
git init –-bare \workspace\AnotherRemote

The '--bare' option tells git that this repository will never have a working copy.  It will 
only be used as a git repository.  This is usually the case for 'remote' repositories that are 
used to share code.  Setting up the repository in this way allows us to "push" changes to it 
freely, even if our changes would make a working directory obsolete if it existed. 
Otherwise, we would need to go into that repository and "pull" changes into it.

If you have a look at the contents of C:\workspace\AnotherRemote, you'll notice that 
it's different from the repositories we've already seen – there is no hidden '.git' folder. 
Rather, the contents that would have been in that folder are present in the 
AnotherRemote folder.

__4. In the Command Prompt window, type the following on one line, and then press 
return:

git remote add another-remote 
\workspace\AnotherRemote

This command tells git to add a reference to a remote repository at 
'C:/workspace/AnotherRemote', and to call it 'another-remote' locally.

__5. We can display the remote repository's status.  Type 'git remote show another-
remote' and then press return:

__6. Finally, let's push our data to the remote. Enter 'git push another-remote master'.

__7. Once again, enter 'git remote show another-remote'
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Notice that this time, the remote status indicates that the remote HEAD branch is 'master' 
and that we are tracking the remote master branch.

__8. Close the git command and all browsers.

Part 6 - Review
In this lab, we tried out a common workflow, the "feature branch" workflow.  We checked 
out a project stored in a remote repository.  We created a new branch, did some work on 
it, committed it, and then merged it back onto the master branch.  Finally, we created yet 
another remote repository and pushed our changes to it.

The thing to notice here is that using remote repositories is natural in git.  In fact, the 
"remote" repository is basically identical to the "local" repository – in this case, we used 
simple repositories in the file system, but they could equally well have been accessed 
remotely using secure-shell or a repository manager.
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	__20.  At the command line, enter:
	__21.  Git opens up Wordpad with the proposed commit message. Note that the file now appears under 'Changes to be committed'.
	__22.  The commit message is intended for us to give a description of the commit that will be useful when we review the logs.  Enter 'We're on the second version.', and then save the file and close Wordpad.

	Part 6 -  Review the Change History
	__1.  Ensure that the Windows Explorer window is still open and displaying the C:\workspace\BasicOperations folder.
	__2.  Right-click in an empty area of the window, and then click on 'Git Bash Here'.
	__3.  Type 'git log' and press return.
	__4.  Leave the Git Bash window open for the next part of the lab.

	Part 7 -  Delete a File and Recover It
	__1.  Using Windows Explorer, delete the file 'Sample.txt'.  Right-click on the file and select Delete.
	__2.  In the Git Bash window, type 'git status' and press return.
	__3.  Type 'git checkout -- Sample.txt' and then press return.

	Part 8 -  Use a '.gitignore' File
	__1.  Ensure that our Windows Explorer is still displaying the 'C:\workspace\BasicOperations' folder.  
	__2.  Right-click in an empty area of the Explorer window, and then select New → Text Document.
	__3.  Explorer will show the new file, with the base part of the name (excluding '.txt') selected.  Type 'gitignore'.  Right now we are calling the file 'gitignore.txt'.
	__4.  Double-click on 'gitignore.txt' to open it in Notepad.
	__5.  Add the following three lines to 'gitignore.txt':
	__6.  Save and close the file.
	__7.  In the git bash window, enter:
	__8.  In the git bash window, enter:
	__9.  In the git bash window, enter 'git add .' (note the 'dot' at the end) and then press return.
	__10.  In the git bash window, enter the following line, and then press return:
	__11.  Enter the following line and then press return, to create a file called 'hello.o':
	__12.  Enter 'git status' and press return.

	Part 9 -  Review

	Lab 2 -  Branching, Merging and Working with Remotes
	Part 1 -  Clone a Repository
	__1.  Using Windows Explorer, navigate to C:\workspace
	__2.  Open a command prompt window, and then enter:
	__3.  In the command prompt window, enter:
	__4.  In the Command Prompt window, type the following and then press return:

	Part 2 -  Create a Branch to Work on a Feature.
	__1.  In the Command Prompt window, type the following, pressing return after each line:
	__2.  Type 'git status'.
	__3.  Type 'git branch'.

	Part 3 -  Work on the Branch
	__1.  In Windows Explorer, navigate to 'C:\workspace\BranchMergeRemotes'.
	__2.  Right-click on 'index.html', and then select Open With → Notepad.
	__3.  Replace the text 'Hello World' with 'This is the text that we really want.'
	__4.  Save and close the file.
	__5.  Back in the Command Prompt window, type 'git status'.
	__6.  Type the following and then press return:
	__7.  In Windows Explorer, double-click on 'index.html' to open it in a web browser.
	__8.  Close the web browser.

	Part 4 -  Merge Back to the Master Branch
	__1.  In the Command Prompt window, enter the following line, and then press return:
	__2.  As above, open 'index.html' with a web browser, but notice that the text now reads 'Hello World' again.
	__3.  In the Command Prompt window, type 'git merge add-text'.
	__4.  As above, open 'index.html' with a web browser, but notice that we have the updated text.
	__5.  We're done with this feature branch, so let's delete it.  In the Command Prompt window, type 'git branch -d add-text' and then press return.

	Part 5 -  Push to Another Remote Repository
	__1.  In the Command Prompt window, enter the following, and then press return:
	__2.  In the Windows Explorer window, navigate to C:/workspace.  Notice that there is a new folder called 'AnotherRemote'.
	__3.  In the Command Prompt window type the following, and then press return:
	__4.  In the Command Prompt window, type the following on one line, and then press return:
	__5.  We can display the remote repository's status.  Type 'git remote show another-remote' and then press return:
	__6.  Finally, let's push our data to the remote. Enter 'git push another-remote master'.
	__7.  Once again, enter 'git remote show another-remote'
	__8.  Close the git command and all browsers.

	Part 6 -  Review

	Lab 3 -  Experimenting with Workflows
	Part 1 -  Simulate Two Developers
	__1.  Open a Command Prompt window.
	__2.  In the Command Prompt window, type the following lines, pressing return after each line:
	__3.  Type 'git clone --bare \LabFiles\CentralRepo'.  This will create a copy of the CentralRepo that is supplied in the LabFiles folder, so that we can commit to it without changing the supplied repository (in case you want to repeat the lab at some point).
	__4.  In the Command Prompt window, enter 'cd alice', to change to Alice's directory.
	__5.  Type 'git clone \workspace\CentralRepo.git'.
	__6.  Type 'cd ..' to return to the workspace folder.
	__7.  Type 'cd chuck' to change to Chuck's directory.
	__8.  Type 'git clone \workspace\CentralRepo.git'.
	__9.  Type 'cd ..' to change back to the workspace folder.
	__10.  Enter the following lines, pressing return after each line:

	Part 2 -  Try Out the Centralized Work Flow
	__1.  In Windows Explorer, navigate to C:\workspace\alice\CentralRepo
	__2.  Right-click on index.html and then select Open With → Notepad.
	__3.  Edit the file so that the line inside the <body> element reads 'This is how Alice wants it.'
	__4.  Save and close the file.
	__5.  In the command prompt window, go to Alice's CentralRepo folder by typing the following:
	__6.  Enter the following, to commit Alice's changes:
	__7.  In the Command Prompt window, enter:
	__8.  We'll take git's advice and set the global push behavior to 'simple' in order to avoid this message in the future. Enter the following:
	__9.  At this point, Alice has pushed her changes to the central repository.  Now let's have Chuck do some work.
	__10.  In Windows Explorer, navigate to C:\workspace\chuck\CentralRepo
	__11.  Right-click on index.html and then select Open With → Notepad.
	__12.  Edit the file so that the line inside the <body> element reads 'This is how Chuck wants it.'
	__13.  Save and close the file.
	__14.  Git began life as a Linux command line program, and arguably, the command line is the preferred way of interacting with git.  But just once, let's try out the GUI interface.  Right-click in the empty area of Windows Explorer and then select Git Commit Tool.  Notice that the change to index.html shows as an unstaged change.
	__15.  Click the Stage Changed button.
	__16.  Enter a commit message like "Chuck wants to commit.", and then click Commit.
	__17.  Right-click in the empty area of Windows Explorer, and then select Git GUI.
	__18.  The Git GUI window is displayed.  From the main menu, select Remote →  Push...
	__19.  The Push dialog appears.  Leave the defaults as-is, and then click Push.
	__20.  Now we have a bit of a problem.  Git reports a command failure.
	__21.  Click Close in the dialog that was reporting the merge failure.
	__22.  In the Git GUI, select Remote →  Fetch From →  origin
	__23.  Close the resulting 'Success' window
	__24.  Select Merge →  Local Merge...
	__25.   The Merge dialog is displayed.  Notice that it is defaulting to merge the remote branch 'origin/HEAD' to the local branch 'master'.  This is what we want, so click on Merge.
	__26.  The GUI reports a merge conflict:
	__27.  Click Close.  The GUI will now show that we have a conflict and invite us to resolve the conflict.
	__28.  Close Git GUI.
	__29.  Open the file again with Notepad, and edit the body so it looks like:
	__30.  Save and close the file.
	__31.  In the Command Prompt window, enter the following to navigate to Chuck's copy of the CentralRepo repository:
	__32.  Type 'git add index.html' and hit enter.
	__33.  Type 'git commit' and press enter.
	__34.  Git will open WordPad with the commit message.  Notice that git has already filled in a message saying that this commit is a "merge", with details of the merge.  Close WordPad to let the commit continue.
	__35.  In the Command Prompt window, type 'Git push' and then press enter (Recall that this was the step that failed when we tried it last time in the GUI).

	Part 3 -  Try Out the Integration Manager Work Flow
	__1.  In Command Prompt, navigate to C:\workspace\alice\CentralRepo by typing:
	__2.  First, let's make sure we're up-to-date with the CentralRepo (remember that in the previous part of the lab, Chuck made and integrated some changes after Alice made changes).  In the Command Prompt window, type 'git status' and press return.
	__3.  Enter 'git pull origin' and then press return.
	__4.  In Windows Explorer, right-click on c:\workspace\alice\CentralRepo\index.html and then select Open With →  Notepad.
	__5.  Add a line before </body> that reads "Another change by Alice."  When the file appears as below, save and close the file.
	__6.  Back in the Command Prompt window, enter
	__7.  We'll now do a change to Chuck's working copy.  In the Command Prompt window, enter:
	__8.  In the Windows Explorer window, navigate to C:\workspace\chuck\CentralRepo
	__9.  In the Command Prompt window, enter 'git pull origin' and press return.  This command will ensure that Chuck also is starting from the latest updates.
	__10.  In Windows Explorer, open the file index.html with Notepad, and add a line just after <body> that says "Here's a Chuck line."  When the file appears as below, save and close the file.
	__11.  In the Command Prompt window, commit the changes, by entering:
	__12.  In the Command Prompt window, enter the following lines, pressing return after each line:
	__13.  Enter the following in the Command Prompt window
	__14.  Enter the following:
	__15.  In the Command Prompt window, enter 'git push origin master' and press return.
	__16.  Enter the following in the Command Prompt window:
	__17.  Enter the following:
	__18.  In the Command Prompt window, enter 'git push origin master' and press return.

	Part 4 -  Review

	Lab 4 -  Using the GitFlow Workflow
	Part 1 -  Create a directory for storing GitFlow lab content.
	__1.  Open a command prompt window, and then enter:
	__2.  Create a directory for storing GitFlow lab content.
	__3.  Switch to the created directory.

	Part 2 -  Create and setup Remote and Local repositories.
	__1.  Initialize a new bare repository.
	__2.  Verify the remote repository is created.
	__3.  Clone the bare remote repository to a local working copy.
	__4.  Verify local repository is created.
	__5.  Switch to the local working copy.
	__6.  Configure user email for the repository. 
	__7.  Configure user name for the repository. 

	Part 3 -  Set up the Basic GitFlow branches in the local repository 
	__1.  In the steps above, we created an empty repository and then cloned it.  Git won't let us create branches until we have at least one commit in the repository, so we'll do that now, with an empty commit.
	__2.  Create a 'develop' branch and switch to it as shown:
	__3.  Press the Enter key to use default values for all options. 
	__4.  View the branch list. 

	Part 4 -  Create a Gitflow feature.
	__1.  Create a new feature.  Recall that we build features on a feature branch.  You could name this anything, but we'll use a common convention of naming the feature branches 'feature/FNAME'.
	__2.  Get branch list. 
	__3.  Get git status.

	Part 5 -  Add content as part of the feature.
	__1.  Start Notepad, click Yes to create the file.
	__2.  In the Notepad window enter following text.
	__3.  Save the file and close the Notepad window.
	__4.  Get git status.
	__5.  Add the new file to the index for the next commit.
	__6.  Get git status.
	__7.  Commit changes.
	__8.  View feature/HOME_PAGE branch contents.
	__9.  Switch to the 'develop' branch and merge this feature into it.  Since we want a record of this merge, we'll use '--no-ff' to make sure there's a merge commit recorded.
	__10.  View develop branch contents.
	__11.  Switch back to the feature branch.
	__12.  Open index.html file in notepad.
	__13.  Add <h1> tag to the body tag.
	__14.  Save the file and close the Notepad window.
	__15.  Get git status.
	__16.  Stage the changed index.html
	__17.  Commit changes to the feature branch. 
	__18.  Merge feature branch into the develop branch without deleting the feature branch.
	__19.  View remote repository content. 
	__20.  Push changes from local repository into the remote repository.
	__21.  View remote repository content. 

	Part 6 -  Create a new Release
	__1.  Create a new release "REL_1.0" based on develop branch.  We'll use the common convention of calling the release "release/REL_1.0".  Enter the following lines, pressing 'return' after each line.
	__2.  Let's finish the release.  As a reminder, the GitFlow workflow suggests that we should merge the release branch into 'master' and then tag the release.  Enter the following lines, pressing 'return' after each line.
	__3.  Now, we should get rid of the release branch and then update the 'develop' branch to reflect the latest release (as reflected by the state of the 'master' branch).  Enter the following lines, pressing 'return' after each line:
	__4.  Get branch list. 
	__5.  Push all changes to the remote repository.
	__6.  Switch to the feature/HOME_PAGE branch.
	__7.  Open index.html file in Notepad.
	__8.  Below h1 tag, add following text.
	__9.  Save the file and close the Notepad window.
	__10.  Stage the changed index.html
	__11.  Commit the changes.
	__12.  Merge feature changes into the develop branch without deleting the feature branch. Enter the folllowing lines, pressing 'return' after each line.
	__13.  Start another release from develop branch.
	__14.  ...and finish it off by merging it back into master and tagging it 
	__15.  Finally, let's merge back to 'develop' and get rid of the release branch.
	__16.  View tag list. 

	Part 7 -  Working with Hotfixes.
	In this part you will create a Gitflow hotfix.
	__1.  Create a new hotfix, based on the 'master' branch (of course you could base it on a different release tag if needed).
	__2.  Open index.html file in the Notepad.
	__3.  Enclose Welcome to ABC Inc. within <b> HTML tag.
	__4.  Save the file and close the Notepad window.
	__5.  Stage the changed index.html file. 
	__6.  Commit changes. 
	__7.  Finish the hotfix by entering the following commands, pressing 'return' after each line.
	__8.  ...and, let's bring the change back to 'develop'...
	__9.  Finally, push all changes into the remote repository.

	Part 8 -  Verify all releases are created
	In this part you will verify all releases are created.
	__1.  Get tag list. 
	__2.  View current tag name. 
	__3.  Checkout REL_1.0
	__4.  View current tag name. 
	__5.  View index.html file contents.
	__6.  Checkout REL_2.0
	__7.  View current tag name. 
	__8.  View index.html file contents.
	__9.  Checkout REL_2.0.1
	__10.  View current tag name. 
	__11.  View index.html file contents.
	__12.  Close all.

	Part 9 -  Review

	Lab 5 -  Rebasing and Rewriting History
	Part 1 -  Pull From the Starting Point Repository
	__1.  Open a command prompt window if you don't have one already available, and navigate to C:\workspace by typing:
	__2.  In the Command Prompt window, type the following lines, pressing return after each line
	__3.  Type 'git log --format=oneline', and then press return.
	__4.  Press q to return to the prompt.

	Part 2 -  Rebase Commits Onto a Different Branch
	__1.  Type 'git checkout bdb807b0'.
	__2.  In the Git Bash window, enter 'git checkout -b new-count'.
	__3.  Now the big one – we're going to tell git to take all the changes that have been done since the 'new-count' branch was created, and put them onto the new-count branch.  Type 'git rebase master'
	__4.  Type 'git checkout master'.
	__5.  Type 'git reset bdb807b0' and press return.
	__6.  Now type 'git log --format=oneline', press return and then press q.

	Part 3 -  Squash A Series of Commits
	__1.  In the Command Prompt window, type 'del count.txt' (this file should not actually exist on this branch.
	__2.  Type 'git checkout new-count'.
	__3.  Type 'git log --format=oneline', press return and then press 'q'.
	__4.  We want to start from the commit that has id starting with bdb807b.  Type 'git rebase -i bdb807b' and press return.
	__5.  git will open an editor with a script that will  perform the rebase operation.  Edit the file to read as follows:
	__6.  Save the file and exit the editor.
	__7.  Git does the changes, and opens an editor to let you edit the final commit message.  By default, it simply concatenates the commit messages that we squashed.  We'll leave that for this example, so just close WordPad
	__8.  Just to see the results, type 'git log --oneline'.
	__9.  Close all.

	Part 4 -  Review

	Lab 6 -  Git Submodules
	Part 1 -  Clone the Application
	__1.  Use Windows Explorer to navigate to C:\
	__2.  There should already be a folder called 'workspace'.  If not, create one and then double-click to enter the new folder.
	__3.  Inside C:\workspace, create  folder called Submodules
	__4.  Right-click on C:\workspace\Submodules and then select 'Git Bash Here'.
	__5.  Enter the following command:
	__6.  Git should clone the project.  Enter the following:
	__7.  Enter the following:

	Part 2 -  Add a Submodule
	__1.  Enter the following:
	__2.  Enter 'ls -a' and examine the result:
	__3.  Enter 'ls AModule' to see what's in the module.
	__4.  Enter 'git submodule' and then press return.
	__5.  Enter 'git status' and then press return.
	__6.  Notice that we have some uncommitted changes.  Let's commit them before moving on.  Enter the following lines, pressing return after each line.
	__7.  Enter the following lines, pressing return after each line.
	__8.  Leave the terminal window open for the next part.  Notice that the current directory should be shown in both the window title and the command prompt (although this may vary on different operating systems).

	Part 3 -  Scenario – The Module is Updated Outside the Project
	__1.  Use Windows Explorer to navigate to C:\workspace
	__2.  Right-click on in the empty panel representing C:\workspace and then select 'Git Bash Here'.
	__3.  Check that the new terminal window shows that we're in the workspace directory.  This should be shown in the command prompt:
	__4.  Enter the following command:
	__5.  Git should clone the project.  Enter the following:
	__6.  The “module” contains three files, 'a.txt', 'b.txt', and 'readme.txt'.  Let's create another file, 'd.txt'.  Enter the line below:
	__7.  Enter 'git status' and then press return.
	__8.  Let's add the new file to the index and then commit it.  Enter the following lines, pressing 'return' after each line.
	__9.  Finally, let's push our changes to the module's remote repository.  Enter the following:
	__10.  Switch to the other Git window, which should still be open and pointing at '/c/workspace/Submodules/AnApp/AModule'..
	__11.  Enter 'cd ..' and press return.  This should leave the working directory set to '/c/workspace/Submodules/AnApp'.
	__12.  Normally, to see if an upstream project has had updates, we'd do a fetch and then check the status.  Let's try that.  Enter the following lines, pressing enter after each line...
	__13.  Git shows that we're actually ahead of the remote by one commit (this is because we didn't 'push' our changes previously), but curiously doesn't mention anything about the updated module.
	__14.  Let's see if things are different inside the module.  Enter the following, pressing 'return' after each line...
	__15.  Now, git indicates that we're behind the remote by a commit.
	__16.  Enter 'cd ..' to return to the '/c/workspace/Submodules' directory.
	__17.  Enter the following:
	__18.  Enter 'git status' and then press return.
	__19.  Notice that updating the module leaves a change that we need to commit.  The submodule system tracks the current 'HEAD' for each module and considers that information to be part of the working copy's status.  Since there are new commits in the module, the working copy's status is considered to have changed.  Enter the following to commit and push the changes.

	Part 4 -  Use a Project with Submodules
	__1.  Open a Git Bash shell on 'C:\workspace\Submodules' and enter the following:
	__2.  We've just cloned the project that we updated in the previous part, but into a fresh directory called 'AnAppCopy'.  Enter 'ls' to see what's there.
	__3.  Notice that there is a directory called 'AModule'.  Type 'ls AModule' to see what's in it.
	__4.  Enter the following, pressing 'return' after each line.
	__5.  Now, if you enter 'ls AModule', you'll see the contents of the remote repository.

	Part 5 -  Scenario – Editing the Submodule
	__1.  You should still have the terminal window open from the previous part.  If not, open a Git Bash window on '/c/workspace/Submodules/AnAppCopy/'
	__2.  Enter the following, pressing 'return' after each line.
	__3.  The output should look something like this:
	__4.  Notice that the module is in “detached head” state.  If we did any commits in this state, they would be lost.  We need to checkout a branch to work on.  Enter the following:
	__5.  Let's add another file and then commit it.  Type the following, pressing 'enter' after each line.
	__6.  Now type 'cd ..' to move to the main project directory.
	__7.  Type 'git status' and then press return.
	__8.  Close all.

	Part 6 -  Conclusion

	Lab 7 -  (Optional) GitFlow Workflow With the GitFlow Extensions
	Part 1 -  Create a directory for storing GitFlow lab content.
	__1.  Open a command prompt window, and then enter:
	__2.  If "\workspace\gitflow_test" folder already exists then remove it as follows, and press Y.
	__3.  Create a directory for storing GitFlow lab content.
	__4.  Switch to the created directory.

	Part 2 -  Create and setup Remote and Local repositories.
	__1.  Initialize a new bare repository.
	__2.  Verify the remote repository is created.
	__3.  Clone the bare remote repository to a local working copy.
	__4.  Verify local repository is created.
	__5.  Switch to the local working copy.
	__6.  Configure user email for the repository. 
	__7.  Configure user name for the repository. 

	Part 3 -  Set up Gitflow in the local repository 
	__1.  Initialize Gitflow in the local repository. 
	__2.  Press the Enter key to use default values for all options. 
	__3.  View the branch list. 

	Part 4 -  Create a Gitflow feature.
	__1.  Get feature list. 
	__2.  Create a new feature.
	__3.  Get feature list again.
	__4.  Get branch list. 
	__5.  Get git status.

	Part 5 -  Add content as part of the feature.
	__1.  Start Notepad, click Yes to create the file.
	__2.  In the Notepad window enter following text.
	__3.  Save the file and close the Notepad window.
	__4.  Get git status.
	__5.  Add index.html to the local repository's feature/HOME_PAGE branch. 
	__6.  Get git status.
	__7.  Commit changes.
	__8.  View feature/HOME_PAGE branch contents.
	__9.  Merge feature branch into the develop branch without deleting the feature branch.
	__10.  View develop branch contents.
	__11.  Switch back to the feature branch.
	__12.  Open index.html file in notepad.
	__13.  Add <h1> tag to the body tag.
	__14.  Save the file and close the Notepad window.
	__15.  Get git status.
	__16.  Stage the changed index.html
	__17.  Commit changes to the feature branch. 
	__18.  Merge feature branch into the develop branch without deleting the feature branch.
	__19.  View remote repository content. 
	__20.  Push changes from local repository into the remote repository.
	__21.  View remote repository content. 

	Part 6 -  Create a new Release
	__1.  Create a new release "REL_1.0" based on develop branch.
	__2.  Finish the release REL_1.0 and delete the release branch.
	__3.  Get branch list. 
	__4.  Push all changes to the remote repository.
	__5.  Switch to the feature/HOME_PAGE branch.
	__6.  Open index.html file in Notepad.
	__7.  Below h1 tag, add following text.
	__8.  Save the file and close the Notepad window.
	__9.  Stage the changed index.html
	__10.  Commit the changes.
	__11.  Merge feature changes into the develop branch without deleting the feature branch.
	__12.  Start another release from develop branch.
	__13.  Finish the release REL_2.0 and delete the release branch.
	__14.  View tag list. 

	Part 7 -  Working with Hotfixes.
	In this part you will create a Gitflow hotfix.
	__1.  Create a new hotfix.
	__2.  Open index.html file in the Notepad.
	__3.  Enclose Welcome to ABC Inc. within <b> HTML tag.
	__4.  Save the file and close the Notepad window.
	__5.  Stage the changed index.html file. 
	__6.  Commit changes. 
	__7.  Finish the hotfix.
	__8.  Push all changes into the remote repository.

	Part 8 -  Verify all releases are created
	In this part you will verify all releases are created.
	__1.  Get tag list. 
	__2.  View current tag name. 
	__3.  Checkout REL_1.0
	__4.  View current tag name. 
	__5.  View index.html file contents.
	__6.  Checkout REL_2.0
	__7.  View current tag name. 
	__8.  View index.html file contents.
	__9.  Checkout REL_2.0.1
	__10.  View current tag name. 
	__11.  View index.html file contents.
	__12.  Close all.

	Part 9 -  Review




