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Lab 1 - Setup the Development Environment
In this lab you will setup the environment for developing Web Services for JBoss.  This 
includes installing JBoss Eclipse plug-ins.

Part 1 - Verify Java Install
Java 7 should have been installed as part of the class setup but these steps will help verify 
and avoid other issues later when they are harder to debug.

__1. Open a Windows command prompt.  You can usually do this on most versions of 
Windows by selecting 'Start → Programs → Accessories → Command Prompt'.

__2. Run the following command and make sure you get a Java “1.7.x” version.  If you 
do not see this, the next steps will help figure out what setting is incorrect.  Also, if you 
get an error about java not being “recognized” as a command the next steps will help 
figure out why.

java -version

__3. Run the following command to see the current value of the 'PATH' environment 
variable.  Check that you see the 'bin' directory of a Java 1.7 installation in the PATH.  If 
you do not see Java 1.7 or if you see multiple versions of Java referenced this could be 
causing errors.

set PATH

Note: Your actual value may be slightly different but it should be obvious that it is a 
Java (or “JDK”) 1.7 version.
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__4. Run the following command and look at the value of the 'JAVA_HOME' 
environment variable. Make sure that it points to the root directory of a Java 1.7 
installation.  If you get a message about 'JAVA_HOME' not being defined this could also 
cause issues.

set JAVA_HOME

Note: Your actual value may be slightly different but it should be obvious that it is a 
Java (or “JDK”) 1.7 version.

__5. If you have not seen output similar to that shown in the previous steps, inform your 
instructor.  They can help determine if all students have the same (or similar) issue and 
the best way to fix it so it won't cause problems later.

__6. Close the command prompt.

Part 2 - Configure Tomcat Test Server in Eclipse
Eclipse includes support for the Tomcat server.  Now we need to define the instance of 
that server.  This will let you deploy and test applications directly from Eclipse.

__1. Open a file browser and launch:

C:\Software\eclipse\eclipse.exe

__2. Change the workspace to C:\workspace and click OK.
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__3. Close the Welcome page that opens.

__4. Click on the Servers view located in the bottom of the Eclipse window.

__5. Right click in the empty area and select New -> Server.

__6. From the list expand Apache and select Tomcat v7.0

Copyright 2014 Web Age Solutions Inc. 5

EVALUATIO
N O

NLY



__7. Click Next.

__8. Click the first Browse button next to Tomcat Installation Directory and navigate to 
C:\Software\apache-tomcat-7.0.50 and then click OK.  Stay on the same page in the 
main wizard.

__9. For the JRE option use the drop-down to select the JDK 1.7 that is installed.

__10. Click Finish once your dialog matches the settings shown above.

__11. The new server will appear in the Servers list.

__12. Right click on the Server and select Open.

__13. The configuration page of the Server will open. Expand Publishing on the right 
side.

__14. Select Never publish automatically.

__15. Save the changes and close the window.
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__16. In the Servers view, right click the 'Tomcat v7.0 Server at localhost' and select 
Start.  

__17. Check that the server starts successfully.  You may need to switch back to the 
Servers view.

__18. Leave the server running.

Part 3 - Configure the CXF Library
In the labs that follow, we will be using the Apache CXF library to implement web 
services.  Before doing that, we need to tell Eclipse which version of the library we want 
to use.

__1. From the Eclipse main menu, select Window -> Preferences.  The Preferences 
window will open.

__2. In the left-hand menu, select Web Services -> CXF 2.x Preferences.

__3. In the CXF Runtime tab, click on the Add... button.

__4. The system will display the AddCXF Runtime dialog.  Click on the Browse... 
button next to the CXF home field.  Navigate to C:\Software and select apache-cxf-
2.7.11 and then click OK.
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__5. Click Finish in the Add CXF Runtime dialog.

__6. Check the checkbox to select the CXF Runtime that we just added and then click 
OK.

Part 4 - Review
In this lab you configured the Tomcat server instance for the rest of the labs, and you 
setup Eclipse with the current version of the Apache CXF library.  You could do these 
steps in your own development environment after downloading the proper version of 
Tomcat and CXF.
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Lab 2 - Introduction to Web Services
In this lab, you will review some of the key components of Web Services, namely, WSDL 
and SOAP. You will also get a chance to see a Web Service in action. The goal of this lab 
is to get yourself familiar with what a Web service looks like. We will not get into too 
much detail at this point; just walk away with a basic understanding of the components 
involved in a web service.

The web service in question is very simple. It has two operations called sayHello and 
sayGoodbye. Each operation takes as input a person's name (say "John") and returns as 
output a greeting message (say, "Hello John").

Part 1 - Import the Project
To save time, the web service is already implemented. You will simply import it into 
Eclipse for examination.

__1. Make sure Eclipse is open in the workspace 'C:\workspace'.

__2. In Eclipse, choose File → Import from the menubar.

__3. Expand General. Select Existing Projects into Workspace. Click Next.

__4. Select the Select archive file radio button.

__5. Click the Browse button and select the C:\LabFiles\TestWS.zip archive file and 
click Open.

__6. Click Finish to import the project from the archive file.  This project is a web 
module project. This represents a WAR file in Java EE.
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Part 2 - Inspect the Implementation Class
The business logic for a Web Service is implemented in a Java class. The Java class may 
be a plain class or a session EJB. In this case, we used a plain Java class in a web module. 
We will briefly have a look at it.

__1. In the Project Explorer view, expand the TestWS project as shown below.

__2. Double click Hello.java to open it.

__3. Have a quick look at the sayHello() method. Note the following:

● By default, the Java method that implements a Web Service operation has the 
same name as the operation.

● The @WebService annotation is used to designate the Hello class as a Web 
Service implementation.

● By default, all the methods are available as Web Service operations.  If we wanted 
tighter control, we could use the @WebMethod annotation to designate certain 
methods as  Web Service operations. These annotations are made available as a 
part of the JAX-WS specification.

__4. Close the Java file.
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Part 3 - Deploy the Project to Tomcat Server
You can directly deploy a project to the Tomcat server.  Once a project has been deployed 
to the server, Eclipse will repeat the build-deploy cycle every time you make any change 
to the projects. This makes development and unit testing quite easy.

__1. In the Servers view, right click Tomcat v7.0 Server at localhost and select Add 
and Remove...

__2. Select the TestWS project and click the Add button.

__3. Click Finish.

__4. Right click the server and select Restart.

__5. After several seconds, check the Servers view again; expand the server and make 
sure that the Status is Synchronized. That means the code deployed to the server is the 
same as what is in Eclipse.

Part 4 - Examine the WSDL File
A WSDL file is used to describe what a Web Service can do and what type of input and 
output data it works with.

__1. Open a web browser to the following address.

http://localhost:8080/TestWS/services

__2. You should see the CXF page listing available services.

__3. Click on the WSDL url.
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__4. You should see the XML syntax of the WSDL of the deployed web service.

The <portType> element in WSDL describes the Web Service. Note that an <operation> 
element exists with the name attribute set to "sayHello".

The <input> and <output> elements within <operation> describes the format of the input 
and output data for the operation. We won't go any further to explore the WSDL at this 
stage.

Part 5 - Invoke the Service
We should now actually test the service.  Testing the service would imply actually 
invoking the operation.  

Typically, doing so would require that we create a web service client.  A web service 
client is, as its name implies, any program that makes a call to a web service.  The 
program could be written in Java, .NET, or any other language that understands web 
service standards. 

Writing a client can be time consuming, so we will “cheat” and use a tool built into 
Eclipse called the Web Services Explorer (WSE).  The WSE works by reading a WSDL 
file and then figuring out what services are available and how to invoke them.  The WSE 
will then dynamically generate a form that represents the service's operations that will 
allow you to invoke it.

Recall that our service has two operations called sayHello and sayGoodbye which take a 
single string as a parameter.  The service then returns a greeting based on that parameter. 

__1. In the browser, where we viewed the WSDL, copy the URL address of the WSDL. 
We will need this WSDL location to run the Web Services Explorer.

__2. Back in Eclipse, launch the WSE.  To do this, use the menu and select Run → 
Launch the Web Services Explorer.  This is probably at the bottom of the menu.
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The WSE will open.

__3. We need to point the WSE at our generated WSDL file.  Locate the row of buttons in 
the top right hand side of the WSE. 

__4. Click the second button from the right to switch the WSE to WSDL mode.

The main Navigator of the WSE will change.

__5. Click WSDL Main in the Navigator pane.

__6. In the Actions pane on the right, you will be prompted for a WSDL URL.

__7. Paste the URL you copied earlier, which was:

http://localhost:8080/TestWS/services/hello?wsdl

__8. Click Go.
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At this point, the WSE will read the WSDL file.  It notices our sayHello operation. 

__9. Click the link for sayHello. WSE will create a form to enter the input data for the 
sayHello operation.

__10. Click the Add link to create a text box for the name parameter. 

Note: The WSE thinks that the name parameter is optional since its value may be null. 
Subtleties such as these are captured in the XML schema for the input and output data 
for the operation.

__11. Enter a name into the field and click Go.

__12. Scroll down and look in the Status  pane.  If you have trouble seeing the response 
you can double click on the title bar of the Status section to maximize the window. This 
shows what the call to the web service returned.

In this case, it returns the String “Hi there, <name>”. Our web service invocation has 
worked!
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Part 6 - Inspect the SOAP Messages
When we invoked the sayHello operation, WSE actually sent a SOAP formatted XML 
document to the server using the HTTP protocol. The server also replied back using a 
SOAP formatted XML document.  SOAP is a versatile data format for request response 
type communication. In its most basic form, as is the case in this lab, it is utterly simple. 
At the same time, it is capable of taking on more advanced aspects of communication, 
such as, encryption, message signature, transaction and guaranteed delivery.

__1. If it is not already maximized, double click on the title bar of the Status section to 
maximize the window and  have a better look of the information.

__2. In the Status pane of WSE, click the Source link.

__3. Briefly inspect the request and response messages as shown below. Don't worry 
about the details. You will learn SOAP shortly.

__4. Restore the Status window.  You can do this by double clicking on the title bar of the 
Status section.

__5. Close all open files.

__6. Stop the Tomcat server by right clicking on it and selecting Stop.
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Part 7 - Review
In this lab, you had a brief encounter with a Web Service. First, we looked at the Java 
class that implements the business logic of the Web Service. That is the true meat behind 
the Web Service. When building a Web Service, you will probably spend most of the time 
writing the business logic. Next, we inspected the WSDL file that describes the nature of 
the Web Service. After that we tested the Web Service and inspected the SOAP messages.

The lab also served two other purposes. You learned how to deploy an application to the 
server. We will do that frequently throughout these lab exercises. You also found out how 
to use the Web Services Explorer to quickly unit test a Web Service.
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Lab 3 - Creating an XML Schema
An XML schema is used to verify that the contents of an XML file are valid; essentially, 
it is a set of “rules” for an XML file.  A particular XML file can be checked against a 
particular schema, and a parser can decide if the XML conforms to the rules set out in the 
schema.  

If, for some reason, the XML does not conform to the schema, the XML parser can reject 
the XML and raise an immediate error.  Essentially, schema adds a layer of validation to 
any XML-based application. Given that web services use XML as their communication 
layer, we can see the value of schema.  Schema are actually used quite frequently in the 
various layers of web service communication.

In this lab, we will create an XML schema.

Part 1 - The Movie.xml File
Throughout these labs, we will be developing a system that deals with movies.  We have 
thus decided to model a movie as an XML file.  This modeling will come in handy when 
we start building the web service. 

__1. Let us start things off by taking a look at a sample movie.xml file.  Using a text 
editor, open file C:\LabFiles\movie.xml

It looks like the following: 

<?xml version="1.0" encoding="UTF-8"?>
<m:database xmlns:m="http://www.mycom.com/movie">

<movie title="Preaching to the Choir" rating="PG13">
<description>
Two estranged brothers -- one a hip-hop star and
the other a Baptist preacher -- find a way 
to make amends and help one another out as 
they each face a crisis in their lives.
</description>
<actor>Billoah Greene</actor>
<actor>Novella Nelson</actor>

</movie>
<movie title="Kekexili: Mountain Patrol" rating="PG13">

<description>
A moving true story about volunteers protecting
antelope against 
poachers in the severe mountains of Tibet.
</description>
<actor>Zhang Lei</actor>
<actor>Qi Liang</actor>

</movie>
</m:database>
<!-- Contains some copyrighted material from imdb.com -->
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Let us analyze this XML file.

The outermost element is called <database> and it contains multiple <movie> elements. 

Each <movie> has two attributes; one called title and one called rating, which reflects a 
movies title and rating respectively. 

Additionally, each <movie> has a single child element called <description> (which 
contains a description of the movie in question) and multiple elements called <actor>, 
with each one representing an actor in the associated movie. 

This is a fairly simple modeling of the movie.  We capture some important information 
about each movie (the title, the description, the rating and the actors), and store this 
information using a mixture of attributes and child elements. 

What we should do now is formalize this model by creating an schema for the 
<database> element (remember that the root element here is <database>, not <movie>).

Once that is done, an application reading/writing one of these movie XML files will be 
able to use the schema to validate that the structure of the XML is good.  (Validating the 
content of the XML, however, is another matter completely).

__2. Close the text editor.

Part 2 - Create the Project
A schema is itself an XML file, and we could create it using a text editor.  However, 
Eclipse provides some nice tools for creating a schema, so we will use those instead. 

__1. Start Eclipse if it is not already running.  

__2. Stop the server if it is running.

__3. Close any open editor windows. (Ctrl-Shift-W)

__4. We will now create a new project to hold our schema file.  From the Eclipse menu 
bar, select File | New | Project...

The New Project window will appear.  

__5. In the list, select Java Project and click Next.

The New Java Project screen will appear.
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__6. Set the Project name to be XMLProject and click Finish.

__7. Eclipse will then prompt you if you would like to switch to the Java Perspective.

__8. Check Remember my decision and click No.

The XMLProject project will be created and listed in the Project Explorer view. (You 
may want to minimize all other projects – e.g. TestWeb in the Project Explorer to keep 
things a little easier to read)

We should create a folder to hold our XML resources. 

__9. Right-click on the newly created XMLProject and select New | Folder.

__10. The New Folder window will appear.  Set the Folder name to be xml and click 
Finish.
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The folder will be created, and should be visible under the project.

Part 3 - Create the Schema
We can now create the schema.

__1. Right click on the newly created xml folder and select New | Other...

The New window will appear.

__2. Scroll down and expand XML.  

__3. Select XML Schema File and click Next.

__4. The Create XML Schema window will appear.  Set the File name to be movie.xsd 
and click Finish. (By convention, schemas always have an XSD extension)
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The XML Schema Editor will open.  This is Eclipse's graphical XSD schema editor. This 
will save us having to create the schema by hand.  We will be using this editor to design 
our schema.  

First, we should change the schema's default name space which is currently set to 
http://www.example.org/movie as can be seen at the top of the editor.

__5. Right-click anywhere on the opened schema editor and select Show properties.

Now, at the bottom of Eclipse, the Properties view should have opened.

__6. Here, change the Prefix to m

__7. Change the Target namespace to http://www.mycom.com/movie

We should also specify that by default, the namespaces are not qualified.  

__8. Click the Advanced tab on the left of the Properties view.
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__9. Change the Prefix for elements drop down to a blank.

__10. Save changes by hitting Ctrl-S.

The editor should update with the new namespace.

We can now go about defining the types that make up this schema.  The core type 
represents the movie data, which we will call the movieType.  (The other type is the 
<database>, which is composed of multiple movieType elements – we will get to that 
later).  We will also define a simple type for the rating since that is a choice of specific 
values and we can use the restrictions available with XML schema.

We will start by defining the simple type for the rating since that is used by the movie 
type.  That way when we define the movie type it will already be available.

__11. Right click inside the Types pane and select Add Simple Type.

__12. A new type will appear.  Change its name to ratingType by typing a new name and 
hitting <Enter> to accept the new name.
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Note: If the name is no longer selected to change you might need to right click it and 
select Refactor → Rename.

The type has been defined.  We now need to specify what data it contains.  

__13. Double click on the newly created ratingType.

The view will change to a closeup of the ratingType.  

__14. Right click an empty area and select Show Properties and check that the basic 
properties of the simple type show up in the Properties view.  The 'Base type' is string 
which is fine for us but might be one thing that is changed for data that is better qualified 
as another data type.

__15. Click the Constraints tab on the left of the Properties view.
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__16. Scroll to the far right of the view and click the second 'Add...' button in the 
'Specific constraint values' section.

__17. In the dialog that appears, enter 'G,PG,PG13,R' making sure there are commas and 
no spaces between the values and click OK.

Note: If you click the wrong 'Add' button you will not get this useful dialog.  If that 
happens delete the single entry that was added by using the 'Delete' button and then click 
the correct 'Add...' button.

__18. Check that your constraint values listed appear as shown below.

__19. Go back to the main schema design page by clicking the icon in the top left corner.
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Next we will define the movieType.   Recall that we want the movieType to model 
rating, description, title and multiple actors as a combination of attributes and elements.

__20. Right click inside the Types pane and select Add Complex Type.

__21. A new type will appear.  Change its name to movieType by typing a new name and 
hitting <Enter> to accept the new name.

Note: If the name is no longer selected to change you might need to right click it and 
select Refactor → Rename.

The type has been defined.  We now need to specify what data it contains.  

__22. Double click on the newly created movieType.

The view will change to a closeup of the movieType.  

It is from here that we can add elements/attributes.  Let us add the description element 
first.   
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__23. Right-click on the movieType and select Add Element.

__24. A new element box will appear.  Rename it to description and hit <Enter> when 
you have supplied the new name.

Notice that the type for description was automatically set to string.  This is fine because 
we want our description modeled as a string.

We have now just declared that our schema defines a type called movieType which itself 
has an element called description of type string.

Now, we can add the actor element. 

__25. Right click on movieType  and again select Add Element.  

__26. This time, name it actor

Recall however, that our movie should have one or more actor elements associated with 
it.  We can specify that here in the schema by using multiplicity.
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__27. Right click on the actor element and select Set Multiplicity | 1..* (One or more)

When you do this, the diagram should update to show the 1..* notation, which means “1 
or more”.  You might need to click in an open area of the editor for the view to show the 
[1..*] notation.

Now we can add the rating and title attributes.

__28. Right click on movieType and select Add Attribute.  Note this is an attribute and 
not element.

__29. Name the attribute title and hit <Enter> to accept the attribute name.
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__30. Repeat this step and add another attribute called rating

We need to change the type of the rating attribute though to use the simple type defined 
earlier.

__31. Double click on string next to the 'rating' attribute and a drop-down box should 
appear. 

__32. Select Browse... from the drop-down box. 

The Set Type window will appear.

__33. In the Name field, enter ratingType (or scroll through the list and select it) 

__34. Click OK.

The movieType element should now look like this.

As discussed earlier, a movieType has attributes for title and rating and elements for 
description and multiple actors.   (All of these are of type string, except the rating).
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We now need to define a database element that contains multiple instances of this 
movieType.  

__35. Go back to the main schema design page by clicking the icon in the top left corner.

__36. Back at the main schema page, the movieType and ratingType should be shown.

__37. Right click in the Elements pane (on the left) and select Add Element.

__38. Name it database

Let us now define that a database is composed of multiple movie elements. We will do 
so using an anonymous type.  

__39. Right click on database and select Set Type | New...
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The New Type window will appear.

__40. Check Create as local anonymous type.   This will grey out the Name field. 

__41. Click OK.

Seemingly, nothing will change.  

__42. Double click on database.

We see that the database element points to something called a (database type).  This is 
an anonymous field, which means is basically just a placeholder for another element type 
– like our movie!  (Using anonymous types can simplify schema).

We should now specify that the (databaseType) points to multiple movie elements.

__43. Right click on (databaseType) and select Add Element.
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__44. A new element will be created.  Name the element movie and hit <Enter> to accept 
the new name.

__45. We know there are multiple movies, so we should set the multiplicity.  Right click 
on movie and select Set Multiplicity | 1..* (One or more).  You may need to click 
somewhere blank once the multiplicity is set to show the [1..*] syntax.

One more thing. We have to set the type of each movie element to be movieType.

__46. Double click on string next to movie and a drop-down box should appear. 

__47. Select Browse... from the drop-down box. 

The Set Type window will appear.

__48. In the Name field, enter movieType (or scroll through the list and select it) 

__49. Click OK.
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The editor will now show the association between the <movie> element and the 
movieType.

We are done! 

__50. Hit Ctrl-S to save changes.

We have completed creating the schema.

Part 4 - Examine the Schema
We have now successfully created a schema using the Eclipse schema editor tool.  The 
tool generated all the necessary code for us; let us take a look at it now.  

__1. Click the Source tab at the bottom of the schema editor. The raw source code 
forming the schema will be displayed.  It should look like the following:

<?xml version="1.0" encoding="UTF-8"?>
<schema targetNamespace="http://www.mycom.com/movie" 
xmlns="http://www.w3.org/2001/XMLSchema" 
xmlns:m="http://www.mycom.com/movie">

<simpleType name="ratingType">
<restriction base="string">

    <enumeration value="G"></enumeration>
    <enumeration value="PG"></enumeration>
    <enumeration value="PG13"></enumeration>
    <enumeration value="R"></enumeration>
    </restriction>
</simpleType>

<complexType name="movieType">
<sequence>
    <element name="description" type="string"></element>

<element name="actor" type="string" maxOccurs="unbounded"
minOccurs="1">

</element>
</sequence>
<attribute name="title" type="string"></attribute>
<attribute name="rating" type="m:ratingType"></attribute>
</complexType>
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<element name="database">
<complexType>

<sequence>
<element name="movie" type="m:movieType"

maxOccurs="unbounded" minOccurs="1">
</element>

</sequence>
</complexType>
</element>
</schema>

Notice that the schema itself is written in XML. 

__2. Go through it and mentally understand what is being described here.

We state that a database is composed of 1 or more movie elements.  Each movie element 
is of type movieType.

A movieType is composed of elements representing description and 1 or more actor, 
and attributes representing the title and rating. 

If you compare this with the movie.xml we examined at the start of this lab, you should 
realize that movie.xml indeed conforms to the rules set out in the schema.  

Now, when an XML parser reads movie.xml, it can automatically check with this xsd to 
ensure it is valid.  We will use this schema in later labs in exactly this manner.

__3. Close the schema editor. 

Part 5 - Review
In this lab, you examined XML schema. 

We started off by examining an XML file that gave us an idea of how to represent a 
movie.  

We then created a schema that to formalize these rules of representation.  We used the 
Eclipse schema editor to create the XML file and in there defined the various elements 
and attributes that should make up a movie database.

Finally, we examined the raw XML source behind the schema to get a feel for what it 
describes, and saw that it indeed validates the movie.xml that we started off with.
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	Lab 1 -  Setup the Development Environment
	Part 1 -  Verify Java Install
	__1.  Open a Windows command prompt.  You can usually do this on most versions of Windows by selecting 'Start → Programs → Accessories → Command Prompt'.
	__2.  Run the following command and make sure you get a Java “1.7.x” version.  If you do not see this, the next steps will help figure out what setting is incorrect.  Also, if you get an error about java not being “recognized” as a command the next steps will help figure out why.
	__3.  Run the following command to see the current value of the 'PATH' environment variable.  Check that you see the 'bin' directory of a Java 1.7 installation in the PATH.  If you do not see Java 1.7 or if you see multiple versions of Java referenced this could be causing errors.
	__4.  Run the following command and look at the value of the 'JAVA_HOME' environment variable. Make sure that it points to the root directory of a Java 1.7 installation.  If you get a message about 'JAVA_HOME' not being defined this could also cause issues.
	__5.  If you have not seen output similar to that shown in the previous steps, inform your instructor.  They can help determine if all students have the same (or similar) issue and the best way to fix it so it won't cause problems later.
	__6.  Close the command prompt.

	Part 2 -  Configure Tomcat Test Server in Eclipse
	__1.  Open a file browser and launch:
	__2.  Change the workspace to C:\workspace and click OK.
	__3.  Close the Welcome page that opens.
	__4.  Click on the Servers view located in the bottom of the Eclipse window.
	__5.  Right click in the empty area and select New -> Server.
	__6.  From the list expand Apache and select Tomcat v7.0
	__7.  Click Next.
	__8.  Click the first Browse button next to Tomcat Installation Directory and navigate to C:\Software\apache-tomcat-7.0.50 and then click OK.  Stay on the same page in the main wizard.
	__9.  For the JRE option use the drop-down to select the JDK 1.7 that is installed.
	__10.  Click Finish once your dialog matches the settings shown above.
	__11.  The new server will appear in the Servers list.
	__12.  Right click on the Server and select Open.
	__13.  The configuration page of the Server will open. Expand Publishing on the right side.
	__14.  Select Never publish automatically.
	__15.  Save the changes and close the window.
	__16.  In the Servers view, right click the 'Tomcat v7.0 Server at localhost' and select Start.  
	__17.  Check that the server starts successfully.  You may need to switch back to the Servers view.
	__18.  Leave the server running.

	Part 3 -  Configure the CXF Library
	__1.  From the Eclipse main menu, select Window -> Preferences.  The Preferences window will open.
	__2.  In the left-hand menu, select Web Services -> CXF 2.x Preferences.
	__3.  In the CXF Runtime tab, click on the Add... button.
	__4.  The system will display the AddCXF Runtime dialog.  Click on the Browse... button next to the CXF home field.  Navigate to C:\Software and select apache-cxf-2.7.11 and then click OK.
	__5.  Click Finish in the Add CXF Runtime dialog.
	__6.  Check the checkbox to select the CXF Runtime that we just added and then click OK.

	Part 4 -  Review

	Lab 2 -  Introduction to Web Services
	Part 1 -  Import the Project
	__1.  Make sure Eclipse is open in the workspace 'C:\workspace'.
	__2.  In Eclipse, choose File → Import from the menubar.
	__3.  Expand General. Select Existing Projects into Workspace. Click Next.
	__4.  Select the Select archive file radio button.
	__5.  Click the Browse button and select the C:\LabFiles\TestWS.zip archive file and click Open.
	__6.  Click Finish to import the project from the archive file.  This project is a web module project. This represents a WAR file in Java EE.

	Part 2 -  Inspect the Implementation Class
	__1.  In the Project Explorer view, expand the TestWS project as shown below.
	__2.  Double click Hello.java to open it.
	__3.  Have a quick look at the sayHello() method. Note the following:
	__4.  Close the Java file.

	Part 3 -  Deploy the Project to Tomcat Server
	__1.  In the Servers view, right click Tomcat v7.0 Server at localhost and select Add and Remove...
	__2.  Select the TestWS project and click the Add button.
	__3.  Click Finish.
	__4.  Right click the server and select Restart.
	__5.  After several seconds, check the Servers view again; expand the server and make sure that the Status is Synchronized. That means the code deployed to the server is the same as what is in Eclipse.

	Part 4 -  Examine the WSDL File
	__1.  Open a web browser to the following address.
	__2.  You should see the CXF page listing available services.
	__3.  Click on the WSDL url.
	__4.  You should see the XML syntax of the WSDL of the deployed web service.

	Part 5 -  Invoke the Service
	__1.  In the browser, where we viewed the WSDL, copy the URL address of the WSDL. We will need this WSDL location to run the Web Services Explorer.
	__2.  Back in Eclipse, launch the WSE.  To do this, use the menu and select Run → Launch the Web Services Explorer.  This is probably at the bottom of the menu.
	__3.  We need to point the WSE at our generated WSDL file.  Locate the row of buttons in the top right hand side of the WSE. 
	__4.  Click the second button from the right to switch the WSE to WSDL mode.
	__5.  Click WSDL Main in the Navigator pane.
	__6.  In the Actions pane on the right, you will be prompted for a WSDL URL.
	__7.  Paste the URL you copied earlier, which was:
	http://localhost:8080/TestWS/services/hello?wsdl
	__8.  Click Go.
	__9.  Click the link for sayHello. WSE will create a form to enter the input data for the sayHello operation.
	__10.  Click the Add link to create a text box for the name parameter. 
	__11.  Enter a name into the field and click Go.
	__12.  Scroll down and look in the Status  pane.  If you have trouble seeing the response you can double click on the title bar of the Status section to maximize the window. This shows what the call to the web service returned.

	Part 6 -  Inspect the SOAP Messages
	__1.  If it is not already maximized, double click on the title bar of the Status section to maximize the window and  have a better look of the information.
	__2.  In the Status pane of WSE, click the Source link.
	__3.  Briefly inspect the request and response messages as shown below. Don't worry about the details. You will learn SOAP shortly.
	__4.  Restore the Status window.  You can do this by double clicking on the title bar of the Status section.
	__5.  Close all open files.
	__6.  Stop the Tomcat server by right clicking on it and selecting Stop.

	Part 7 -  Review

	Lab 3 -  Creating an XML Schema
	Part 1 -  The Movie.xml File
	__1.  Let us start things off by taking a look at a sample movie.xml file.  Using a text editor, open file C:\LabFiles\movie.xml
	__2.  Close the text editor.

	Part 2 -  Create the Project
	__1.  Start Eclipse if it is not already running.  
	__2.  Stop the server if it is running.
	__3.  Close any open editor windows. (Ctrl-Shift-W)
	__4.  We will now create a new project to hold our schema file.  From the Eclipse menu bar, select File | New | Project...
	__5.  In the list, select Java Project and click Next.
	__6.  Set the Project name to be XMLProject and click Finish.
	__7.  Eclipse will then prompt you if you would like to switch to the Java Perspective.
	__8.  Check Remember my decision and click No.
	__9.  Right-click on the newly created XMLProject and select New | Folder.
	__10.  The New Folder window will appear.  Set the Folder name to be xml and click Finish.

	Part 3 -  Create the Schema
	We can now create the schema.
	__1.  Right click on the newly created xml folder and select New | Other...
	__2.  Scroll down and expand XML.  
	__3.  Select XML Schema File and click Next.
	__4.  The Create XML Schema window will appear.  Set the File name to be movie.xsd and click Finish. (By convention, schemas always have an XSD extension)
	__5.  Right-click anywhere on the opened schema editor and select Show properties.
	__6.  Here, change the Prefix to m
	__7.  Change the Target namespace to http://www.mycom.com/movie
	__8.  Click the Advanced tab on the left of the Properties view.
	__9.  Change the Prefix for elements drop down to a blank.
	__10.  Save changes by hitting Ctrl-S.
	__11.  Right click inside the Types pane and select Add Simple Type.
	__12.  A new type will appear.  Change its name to ratingType by typing a new name and hitting <Enter> to accept the new name.
	__13.  Double click on the newly created ratingType.
	__14.  Right click an empty area and select Show Properties and check that the basic properties of the simple type show up in the Properties view.  The 'Base type' is string which is fine for us but might be one thing that is changed for data that is better qualified as another data type.
	__15.  Click the Constraints tab on the left of the Properties view.
	__16.  Scroll to the far right of the view and click the second 'Add...' button in the 'Specific constraint values' section.
	__17.  In the dialog that appears, enter 'G,PG,PG13,R' making sure there are commas and no spaces between the values and click OK.
	__18.  Check that your constraint values listed appear as shown below.
	__19.  Go back to the main schema design page by clicking the icon in the top left corner.
	__20.  Right click inside the Types pane and select Add Complex Type.
	__21.  A new type will appear.  Change its name to movieType by typing a new name and hitting <Enter> to accept the new name.
	__22.  Double click on the newly created movieType.
	__23.  Right-click on the movieType and select Add Element.
	__24.  A new element box will appear.  Rename it to description and hit <Enter> when you have supplied the new name.
	__25.  Right click on movieType  and again select Add Element.  
	__26.  This time, name it actor
	__27.  Right click on the actor element and select Set Multiplicity | 1..* (One or more)
	__28.  Right click on movieType and select Add Attribute.  Note this is an attribute and not element.
	__29.  Name the attribute title and hit <Enter> to accept the attribute name.
	__30.  Repeat this step and add another attribute called rating
	__31.  Double click on string next to the 'rating' attribute and a drop-down box should appear. 
	__32.  Select Browse... from the drop-down box. 
	__33.  In the Name field, enter ratingType (or scroll through the list and select it) 
	__34.  Click OK.
	__35.  Go back to the main schema design page by clicking the icon in the top left corner.
	__36.  Back at the main schema page, the movieType and ratingType should be shown.
	__37.  Right click in the Elements pane (on the left) and select Add Element.
	__38.  Name it database
	__39.  Right click on database and select Set Type | New...
	__40.  Check Create as local anonymous type.   This will grey out the Name field. 
	__41.  Click OK.
	__42.  Double click on database.
	__43.  Right click on (databaseType) and select Add Element.
	__44.  A new element will be created.  Name the element movie and hit <Enter> to accept the new name.
	__45.  We know there are multiple movies, so we should set the multiplicity.  Right click on movie and select Set Multiplicity | 1..* (One or more).  You may need to click somewhere blank once the multiplicity is set to show the [1..*] syntax.
	__46.  Double click on string next to movie and a drop-down box should appear. 
	__47.  Select Browse... from the drop-down box. 
	__48.  In the Name field, enter movieType (or scroll through the list and select it) 
	__49.  Click OK.
	__50.  Hit Ctrl-S to save changes.

	Part 4 -  Examine the Schema
	__1.  Click the Source tab at the bottom of the schema editor. The raw source code forming the schema will be displayed.  It should look like the following:
	__2.  Go through it and mentally understand what is being described here.
	__3.  Close the schema editor. 

	Part 5 -  Review

	Lab 4 -  JAXB Programming
	Part 1 -  Add JAXB Implementation to Project Classpath
	__1.  In Eclipse select Window → Preferences.
	__2.  In the list of preferences select Java → Build Path → User Libraries.
	__3.  Press the New button.
	__4.  Fill in a library name of JAXB and click the OK button.
	__5.  With the newly created JAXB library still selected press the Add External JARs button.
	__6.  Browse to the 'C:\LabFiles\JAXB-lib' directory, select all the JAR files by holding the CTRL key while selecting them, then click the Open button to complete the selection.
	__7.  Make sure that all 6 of the JAR files are listed as part of the library. You may want to collapse the JAR files.
	__8.  Click the OK button to close the Eclipse preferences.
	__9.  Back in Eclipse right click the XMLProject project and select Build Path → Configure Build Path...
	__10.  In the build path settings select the Libraries tab and click the Add Library... button.
	__11.  Select User Library and click the Next button.
	__12.  Check the box next to the JAXB library you defined and click the Finish button.
	__13.  Click the OK button to close the project properties.
	__14.  Check that the JAXB library is associated with the project.

	Part 2 -  Generating the Bindings
	__1.  Right click the movie.xsd file in the XMLProject → xml folder and select Generate → JAXB Classes.
	__2.  Make sure the 'XMLProject' is selected as the destination project and click the Next button.
	__3.  Change the Target Package to 'com.jaxb.movie' as shown below and click the Finish button.  It will take a few seconds to generate the classes.
	__4.  Eclipse may display a dialog asking for permission to generate files.  If so, select the Do not show this message again checkbox, and then click Yes.
	__5.  Expand the src folder of project XMLProject. 
	__6.  A newly created package com.jaxb.movie should appear.  Expand it and you should see the generated binding classes.

	Part 3 -  Use the Binding Classes To Read XML
	__1.  In the XMLProject project, create a new package called com.mycom.test (right click the project and select New → Package, fill in the name and click Finish).
	__2.  In the com.mycom.test package, create a new class called JAXBMoviePrinter and check the option to create a 'main' method then click the Finish button.
	__3.  In the main method, we first need to setup the unmarshaler. Add the following code to the main method. 
	__4.  There are some errors in the code.  To fix a few of them, perform an Organize imports (Ctrl + Shift + O).  After you do this, you will still see some errors, but ignore them for now.  
	__5.  Recall that in our schema, that “top-most” element was database.  If you look at the generated binding classes, you will notice that a Database class was created.  We can use the unmarshaler to create an instance of this object.  Add the following code in bold:
	__6.  Fix this by performing an Organize Imports – which is done by typing Ctrl-Shift-O. There will still be some errors.  Do not worry about them for now. 
	__7.  Remember that a <database> element contained several <movie> elements. Similarly, the database object will have a field that represents a list of MovieType objects.  We can get this list.  Add the following code in bold:
	__8.  We now have a a reference to the list of movies contained in the database.  We can iterate through it, and operate on it!  Let us simply go through the list and print the title of each movie.  Add the following code in bold:
	__9.  Organize imports again, by hitting Ctrl-Shift-O. Select java.util.List when prompted.
	__10.  Select all of the code in the main method (but not the method declaration). 
	__11.  Right click on it and select Surround With → Try/catch block.
	__12.  Save the code.

	Part 4 -  Test JAXB
	__1.  Right click on the code and select Run As → Java Application.
	__2.  Close all open editors.

	Part 5 -  Review

	Lab 5 -  Create A Bottom Up Web Service
	Part 1 -  Create the Project
	__1.  From the menu, select File → New → Project...
	__2.  Expand Web and select Dynamic Web Project.
	__3.  Click Next.
	The New Dynamic Web Project window will appear.  
	__4.  For the Project name, enter WebServiceProject
	__5.  Next to the Configuration drop-down box, click Modify.
	__6.  The system displays the Project Facets dialog.  Select the checkbox next to CXF 2.x Web Services, and then click OK.
	__7.  Once your main project settings match those shown below click the Next button.
	__8.  Accept the default Java settings and click the Next button again.
	__9.  On the web module settings, check the box for 'Generate web.xml deployment descriptor' and click the Next button.
	__10.  On the 'CXF Facet' settings accept the default option for 'Apache CXF 2.7.11' and click Finish to create the project.
	__11.  The dynamic web project and EAR project will be created and displayed in the Project Explorer view. Expand it.

	Part 2 -  Create the Implementation Class
	__1.  Right click on WebServiceProject and select New → Class.
	__2.  Set the Package to be com.simple 
	__3.  Set the Name to Greeter
	__4.  Make sure the option to create a 'main' method is unchecked and click Finish when your dialog appears as shown below:
	__5.  An editor will open on the newly created source file.  Add the following method to the class:
	__6.  Save the code.  There should be no errors.

	Part 3 -  Annotate the Class
	__1.  We should first mark the class as being a web service.  To do this, add the following annotation in bold to the class, right before the class definition.  You will have errors that can be ignored for now.
	__2.  Annotate the sayHello method as follows in bold:
	__3.  There will be two errors on the code, complaining about the annotations.  Fix that now by performing an Organize Imports. (Ctrl-Shift-O).
	__4.  Save the code.  There should be no errors.

	Part 4 -  Configure the Web App for Apache CXF
	__1.  Expand WebServiceProject → WebContent → WEB-INF.
	__2.  Open web.xml.
	__3.  Click the Source tab at the bottom of the editor.
	__4.  Add the following code in bold after the closing tag for “welcome-file-list” (for your convenience, this text is also provided in the file 'C:\LabFiles\web-xml-cxf-fragment.txt'.  If it's more convenient, you can open that file with Notepad and copy/paste the text):
	__5.  Save and close the file.

	Part 5 -  Create the CXF Configuration File
	__1.  Using Windows Explorer, navigate to 'C:\LabFiles'.
	__2.  Right-click on the file 'cxf-services.xml' and then select Copy.
	__3.  Go to the Eclipse window, and right-click on the 'WebContent/WEB-INF' node underneath 'WebServiceProject' and then select Paste.
	__4.  In Eclipse, double-click on the newly-added 'cxf-services' file to open it.
	__5.  Note that the file includes the following callout:

	Part 6 -  Deploy the Application
	We can deploy the project from inside Eclipse. 
	__1.  Open the Servers view. 
	__2.  Start the server if it is stopped.  Wait for it to start completely.
	__3.  Right click on the server and select Add and Remove...
	The Add and Remove projects window will appear. 
	__4.  In the left pane, select WebServiceProject and click Add.
	__5.  Click Finish.
	__6.  Restart the Tomcat server by right-clicking on the server and selecting Restart
	__7.  Open a web browser to the following address which should bring up the list of deployed services
	__8.  Ensure that the Greeter service is present, as shown:
	__9.  Close the browser.

	Part 7 -  Test the Web Service
	__1.  In Eclipse, open the WSE by going to the menu and selecting Run → Launch the Web Services Explorer.
	__2.  Switch to WSDL mode by clicking the WSDL Page button (second button from the right in the top right corner of the WSE).  You may also want to maximize the screen by clicking the tab for the Web Services Explorer.
	__3.  Click WSDL Main.
	__4.  In the right pane, for the URL, enter:
	__5.  Click Go.
	The WSE connects and reads the WSDL file, figuring out what operations are available.
	
	__6.  It notices the sayHello operation.  Click on it.
	The WSE realizes that the sayHello service expects an argument – however, it does not appear to have rendered a field for us to enter an argument. 
	Why is this happening?  This is because the WSDL file that was automatically generated did not specify that a parameter must be there.
	__7.  For now, however, we can still test our service.  Click the Add link, and a field will appear.
	
	__8.  Enter a name into the field.
	
	__9.  Click Go.
	
	Our web service has been invoked successfully!

	Part 8 -  Change the Implementation
	__1.  Let us examine some of the conventions that the generated service is using.  In the WSE, examine the test page.
	Notice that the name of the parameter is arg0.  What exactly is the impact of this?  To see, we have to look at the underlying SOAP messages.  
	To be precise, we want to take a look at the SOAP request message that the WSE generated and was submitted to the service for processing.  
	__2.  Click Go.
	__3.  In the lower Status pane of the WSE, click the Source link.  
	__4.  Expand the Status pane by double clicking on its title bar. 
	Examine the SOAP Request Envelope.  This is the top pane.  We want to note two things here:
	First of all, notice that the default q0 namespace prefix is for the namespace http://simple.com.  This was derived from the package name of the implementation class.  This works, but sometimes simply using the package name as the name space is not desirable. 
	Secondly, We see that the main body of the SOAP message contains the element <q0:sayHello> which is the name of the operation.  That is fine; what is not ideal, however, is the fact that the argument is simply called arg0.  While there is technically nothing wrong with this, it does make the SOAP a little more abstract;  arg0 is not a very meaningful name to any human reading the SOAP message.  
	The question is now this: how did these two conventions (the default namespace and the argument name) receive these default values?  An even better question is this: how do we control these default values?  The answer is simple; via annotations. 
	We can annotate the implementation class and specify what we want the namespace and the argument names to be.  
	Let us fix these now.  
	__5.  Return the Status pane to its normal size by double clicking on it again. 
	__6.  Open Greeter.java again (under com.simple package). 
	__7.  Update the @WebService annotation of the class to look like the following:
	Here, we update the @WebService annotation to specify what we want the target namespace to be; in this case we will use www.example.org 
	__8.  Now, let us fix the arg0 problem.  Add the following annotation to the parameter of the sayHello method, as follows in bold.  Note that the syntax is a bit tricky since the annotation is inside the method parameter list.
	We are annotating the parameter to have a more meaningful name. 
	__9.  Organize imports (CTRL+Shift+O).  There should be no errors. 
	__10.  Save the file.
	We have updated our implementation class by changing (and adding) annotations. 
	__11.  Return to the Servers view and restart the server by right clicking the server and selecting Restart.  

	Part 9 -  Examine the Updated Service
	We should now see if the annotations worked. 
	__1.  Go back to the WSE.  You should still be in WSDL mode.  
	__2.   In the Navigator pane, clear the existing WSDL connection by clicking the Clear button. (the little eraser icon in the top right of the Navigator pane)
	__3.  In the right pane, the old URL should still be displayed:
	__4.  Click Go.
	__5.  The operation is located.  Click sayHello.
	__6.  Click Add, enter a name and click Go.
	__7.  Click the Source link in the Status pane, and then maximize the Status pane.
	__8.  Restore the Status pane to normal size and in the Navigator pane, clear the existing WSDL connection by clicking the Clear button. (the little eraser icon in the top right of the Navigator pane).
	__9.  Close all open editors, stop the server and close any web browser.

	Part 10 -  Review

	Lab 6 -  Creating A Web Service With Eclipse Tools
	Part 1 -  Remove the Manual CXF Configuration
	__1.  In the WebServiceProject, right-click on the file WebContent/WEB-INF/cxf-services.xml and then select Delete...
	__2.  Eclipse will display a confirmation dialog. Click OK.
	__3.  Double-click on the file WebContent/WEB-INF/web.xml to open it.
	__4.  Remove the servlet and servlet-mapping elements shown  below.
	__5.  Save and close the file.

	Part 2 -  Create the Implementation Class
	__1.  Using the Project Explorer view create a class in the WebServiceProject called Adder  belonging to the com.simple package.  
	__2.  Add the following method to the class:
	__3.  Add the following web service annotations to the class.
	__4.  There may be two errors on the code, complaining about the annotations.  Fix that now by performing an Organize Imports. (Ctrl-Shift-O).
	__5.  Save the class. There should be no errors.
	__6.  Close Adder.java

	Part 3 -  Generate the Web Service
	__1.  From the Eclipse menus select Window → Preferences.
	__2.  Expand Web Services and select the Server and Runtime preferences.
	__3.  Change the 'Server runtime' to Tomcat v7.0 Server 
	__4.  Change the 'Web service runtime' to Apache CXF 2.x.
	__5.  Click the OK button to close the Eclipse preferences.
	__6.  In the Project Explorer, right-click on Adder.java and select Web Services → Create Web Service.
	__7.  Drag the top slider down to Assemble service.  
	__8.  Make sure it looks like below and click Next.
	__9.  Click the Next button two times
	__10.  In the Apache CXF 2.7.11 Web Service Java 2WS Configuration dialog ensure that the option to 'Generate WSDL file' is selected.  
	__11.  Click Finish.  Eclipse will begin code generation. 
	__12.  Examine the com.simple.jaxws package in the Project Explorer.  Notice there are new classes here called Add and AddResponse.  These are JAXB annotated classes generated by the tool.
	__13.  Look in the WebServiceProject/WebContent/wsdl folder.  There is a WSDL file and schema that were generated for the service.
	__14.  Look in the WebServiceProject/WebContent/WEB-INF folder.  Note that Eclipse has added a file called cxf-beans.xml 

	Part 4 -  Test the Service
	__1.  Return to the Servers view and publish the server by right clicking the server and selecting Publish.
	__2.  Start the server if it is not already running.  Wait for it to start completely.
	__3.  Open a web browser to the following address which should bring up a list of services:
	__4.  Check that you see the “Adder” service listed.
	__5.  In the Eclipse main menu, select Run -> Launch the Web Services Explorer.
	__6.  Click on the WSDL Page Mode icon at the top-right of the window
	__7.  Click on the WSDL Main node in the left-hand part of the WSE window.
	__8.  In the WSDL URL text box, enter: 
	__9.  Click Go.
	__10.  Maximize the Web Services Explorer by clicking the Maximize button in the upper right.
	__11.  Click the add link under Operations.  
	__12.  Enter two numbers and click Go.
	__13.  Make sure the correct result comes back.
	__14.  Restore the Web Services Explorer to normal size and in the Navigator pane, clear the existing WSDL connection by clicking the Clear button. (the little eraser icon in the top right of the Navigator pane).
	__15.  Close all open editors, stop the server and close the web browser.

	Part 5 -  Review

	Lab 7 -  Creating a WSDL File
	Part 1 -  Create A WSDL File
	__1.  In the Project Explorer view, expand the XMLProject → xml folder.
	__2.  Copy the movie.xsd file.
	__3.  Paste the movie.xsd file into the WebContent/wsdl folder of the WebServiceProject project.
	__4.  Right click on the WebServiceProject /WebContent/wsdl folder and select New → Other...
	__5.  In the New window that appears, expand Web Services and select  WSDL File.
	__6.  Click Next.
	__7.  Set the File name to be MovieService.wsdl and check the folder is the 'WebServiceProject/WebContent/wsdl' folder.
	__8.  Click Next.
	__9.  Set the Target namespace to be http://www.mycom.com/movie
	__10.  Set the Prefix to be m
	__11.  Click Finish.
	__12.  Take a moment to examine the source code of the underlying WSDL file.  It may seem a little daunting, but we will examine in a little more detail later on.
	__13.  Click the Design tab at the bottom of the editor.  This shows a graphical representation of the WSDL file and is much easier to deal with.  
	__14.  First of all, let us rename the port to something a little more proper.  In the port box (the box on the left), click the title area where MovieServiceSOAP is displayed. Double click the text MovieServiceSOAP and rename it to MovieServiceSOAPPort.  Hit <Enter> to accept the new name.
	__15.  Let us rename the service first.  In the operation box (the box on the right) double click NewOperation and rename it to addMovie hitting <Enter> to accept the new name. 
	__16.  Double click on parameters next to input and rename it to movieToAdd hitting <Enter> to accept the new name. 
	__17.  Double click on parameters next to output and rename it to opStatus hitting <Enter> to accept the new name. 
	__18.  Double click on the right-facing arrow on the far right of the input row.
	__19.  Click the Design tab at the bottom of the editor.  The view will change to show a diagram.
	__20.  Click on the icon in the top left of the editor.
	__21.  In the Directives box, right-click and select Add Include.
	__22.  Leave the default option of Workbench projects and click the Next button.
	__23.  Expand WebServiceProject → WebContent → wsdl and select the movie.xsd file.
	__24.  Click the Finish button to create the link to the file.
	__25.  In the Elements area, double click on addMovie.
	__26.  In the box on the right, rename in to movie
	__27.  We now need to set the type.  Double-click on string and expand the dropdown that appears.
	__28.  In the list, click on Browse...
	__29.  In the list, locate movieType and double-click on it.
	__30.  Go back to the main schema view by clicking on the icon in the top left of the editor.
	__31.  In the Elements box, double-click on addMovieResponse. 
	__32.  Rename the out to status
	__33.  We are done!  Save changes by hitting Ctrl-S.
	__34.  Close the Inline Schema of MovieService.wsdl view.  (Leave the other editor, showing MovieService.wsdl open)

	Part 2 -  Examine the Generated WSDL Source
	__1.  Click the Source tab at the bottom of the WSDL editor.
	__2.  The indentation may be a little off; right click anywhere on the source and select Source | Format (Ctrl+Shift+F).
	__3.  Save all the files by selecting from the menu, File > Save All.
	__4.  Close the WSDL editor. 

	Part 3 -  Review

	Lab 8 -  Creating A Top-Down Web Service
	Part 1 -  Generate the Implementation Classes
	__1.  In the Project Explorer, expand WebServiceProject → WebContent → wsdl. 
	__2.  Right-click on MovieService.wsdl and select Web Services → Generate Java bean skeleton.
	__3.  Drag the top slider down to Assemble service.  
	__4.  Also check that the 'Server runtime' and 'Web service runtime' options are the Tomcat and CXF choices.  
	__5.  Click the Finish button when your choices match those below.

	Part 2 -  Examine the Generated Artifacts
	__1.  Expand WebServiceProject → Java Resources → src → com.mycom.movie 
	__2.  Open MovieService.java
	__3.  Next, open MovieType.java
	__4.  Finally, look at the AddMovie.java and AddMovieResponse.java. They represent the input and output data for the addMovie operation. They are wrapper types only. They are created to conform to the document literal wrapped style of SOAP. As a result, the actual addMovie() method in the MovieService interface does not use them and uses the inner types only (such as MovieType).

	Part 3 -  Create the Implementation Class
	__1.  Open MovieServiceImpl.java in the com.mycom.movie package.
	__2.  Set the code for addMovie method as shown in boldface below:
	__3.  Organize imports and select java.util.List when prompted.
	__4.  Save the code.  There should be no errors.
	__5.  In the Project Explorer, expand WebServiceProject → JAX-WS Web Services → Web Services.

	Part 4 -  Test the Service
	__1.  Close all open editor windows.
	__2.  Right click the server and select Start. 
	__3.  Start the server and wait for it to start completely.
	__4.  Open a web browser to the following address which should bring up a list of services:
	__5.  Check that you see the “MovieService” service listed.
	__6.  In the Eclipse main menu, select Run -> Launch the Web Services Explorer.
	__7.  Click on the WSDL Page Mode icon at the top-right of the window.
	__8.  Click on the WSDL Main node in the left-hand part of the WSE window.
	__9.  In the WSDL URL text box, enter: 
	__10.  Click Go.
	__11.  Maximize the Web Services Explorer by clicking the Maximize button in the upper right.
	__12.  Click the addMovie link under Operations.  
	__13.  Enter some sample data.  (To add multiple actors, click the Add button next to actor).
	__14.  Click Go.  The service will be invoked.
	__15.  Restore the Web Services Explorer to normal size if you maximized it.
	__16.  Switch to the Console view.
	__17.  Try adding a few more movies and make sure everything works. 
	__18.  In the Navigator pane of the Web Services Explorer, clear the existing WSDL connection by clicking the Clear button. (the little eraser icon in the top right of the Navigator pane).
	__19.  Close all open files and web browsers.
	__20.  Stop the server.

	Part 5 -  Review

	Lab 9 -  Developing A Web Service Client
	Part 1 -  Create Projects
	__1.  From the menu, select File → New → Project...
	__2.  Expand Web and select Dynamic Web Project.
	__3.  Click Next.
	The New Dynamic Web Project window will appear.  
	__4.  For the Project name, enter MovieClientWeb
	__5.  Next to the 'Configuration' setting, press the Modify button.
	__6.  Find and check the 'CXF 2.x Web Services' project facet.  
	__7.  Click the OK button to accept the new configuration.
	__8.  Click the Next button.
	__9.  Accept the default Java settings and click the Next button again.
	__10.  On the web module settings, make sure the box for 'Generate web.xml deployment descriptor' is unchecked and click the Next button.
	__11.  On the 'CXF Facet' settings chose the option for 'Apache CXF 2.7.11'.
	__12.  Click Finish to create the project.
	__13.  From the menu, select File → New → Project...
	__14.  Select Java Project and click Next.
	__15.  Change the Project name to MovieClientJava and click the Finish button.  Do not switch over to the Java perspective if asked. 

	Part 2 -  Generate the Client Stub
	__1.  Start the Tomcat server in the Servers view.  The 'WebServiceProject' application should still be deployed to the server so this will make the service WSDL available. Wait for the server to start completely.
	__2.  Open a web browser to the following address which should bring up the list of services.
	__3.  Select the WSDL URL for MovieService and copy it (depending on the browser, this will be something like 'right-click on the WSDL link and then select Copy Link Location').  
	__4.  Close the browser.
	__5.  Back in Eclipse, right click the MovieClientWeb project and select New → Other...
	__6.  Select Web Services → Web Service Client and click the Next button.
	__7.  In the box for 'Service definition' paste the link to the WSDL location.
	__8.  On the left, drag the slider down to Assemble Client.  
	__9.  Also check that the setting for 'Client project' is set to MovieClientWeb, which it should be since you right clicked the project to run the wizard.  Finally check that the two runtime options are set to Tomcat and CXF.
	__10.  Click Next once your settings match that shown above.  
	__11.  Enter 'com.movie' for the Package name.
	__12.  Click the Finish button.  The stub will be generated.  
	__13.  Expand the MovieClientWeb → Java Resources → src folders.  Notice a new package com.movie has been created.  This package contains our client stub classes! 
	__14.  Expand com.movie.
	__15.  Open the MovieService_Service.java file. This is the client side proxy class.
	__16.  Close all open files.
	__17.  Right click the 'com.movie' package and select Copy.
	__18.  Expand the MovieClientJava project so you can see the 'src' folder.
	__19.  Right click the 'src' folder and select Paste.
	__20.  Check that you have the generated client code in the MovieClientJava project.

	Part 3 -  Create Standalone Java Client
	__1.  In the MovieClientJava project, create a new Java class called StandaloneMovieClient having  com.movie.client as package with a main method.
	__2.  We should first create an instance of a movie and populate it with some data.  Add the following code to the main method.
	__3.  Organize imports (CTRL+Shift+O), to import the MovieType and RatingType classes. There should be no errors.
	__4.  Add the following code to the main method:
	__5.  Organize imports.  There should be no errors. 
	__6.  We can now go ahead and invoke the service.  Add the following code in bold at the end of the main method.
	__7.  Save the code.  We have completed coding our client.

	Part 4 -  Run the Client
	__1.  In Eclipse, select the MovieClientJava → src → com.movie.client → StandaloneMovieClient class.
	__2.  Right click StandaloneMovieClient and select Run As → Java Application.
	__3.  After a few seconds, your Console view should be showing the output from the client class.  This will be a single line indicating the movie was added.  
	__4.  Over on the right of the Console view, find the button with a drop down arrow next to it that is labeled 'Display Selected Console'.
	__5.  Use the drop down arrow next to the button to select the output from the 'Tomcat v7.0 Server at localhost'.  You might also be able to simply click the button directly and swap the output.
	__6.  Check that you see the output from the server that indicates the movie was received by the service and prints out various details.  This proves the service was invoked on the server.
	__7.  If you want to run the client again you can select Run → Run History → StandaloneMovieClient.

	Part 5 -  Adding A Web Layer
	__1.  Close all open editor windows. (Ctrl-Shift-W)
	__2.  Navigate to C:\LabFiles and locate file index.jsp.  Copy it into the WebContent folder of the MovieClientWeb project.
	__3.  Open up and take look at this index.jsp in the editor.  It is a very simple form that posts to a servlet called AddMovieServlet. It is the servlet that will take the data input from the form, and invoke the service with it. We will code this servlet in a moment. 
	__4.  Close the file.
	__5.  Right click MovieClientWeb and select New > Other.
	__6.  Select Web → Servlet and click Next.
	__7.  Enter com.movie.servlet package and AddMovieServlet as name.
	__8.  Click Finish.
	__9.  In the servlet code, locate the doPost method.  Here, we will now add the code to get the data submitted from the form and create a new movie based on that data.
	__10.  Delete the comment inside the doPost method and then add the following code in the doPost method.
	__11.  Organize imports.
	__12.  Now that we have a populated movie, we can make a call to the service!  Add the following code in bold to the doPost method:
	__13.  Organize imports.
	__14.  Finally, add the following code in bold to the doPost method:
	__15.  We are done!  Save the code.  There should be no errors. 

	Part 6 -  Deploy and Test
	__1.  Right click on the Tomcat server in the Servers view and select Add and Remove...
	__2.  Select MovieClientWeb  and select Add.
	__3.  Click Finish and wait for the project to be published to the server.
	__4.  Restart the server.
	__5.  Right-click on index.jsp under WebContent in the MovieClientWeb project and select Run As → Run On Server.
	__6.  In the 'Run On Server' dialog, select the option “Always use the server when running this project”, click Finish.
	__7.  Enter some sample data.
	__8.  Click Add Movie.
	__9.  Check the server console to make sure the appropriate print statements are generated.
	__10.  Try submitting the form a few more times.
	__11.  Close all open editor windows and web browsers.
	__12.  Stop the server.

	Part 7 -  Review

	Lab 10 -  Controlling JAXB Mappings
	Part 1 -  Update the Implementation
	__1.  In the WebServiceProject, create a new Java class called Person belonging to package com.beans.  Make sure it does not have a 'main' method.
	__2.  Add the following two fields to the class.
	__3.  Organize imports (CTRL-SHIFT-O) and pick java.util.Date when prompted.
	__4.  Save the class.
	__5.  In the Outline view (to the right), select both fields.
	__6.  Right click on these selected fields and select Source → Generate Getters and Setters...
	__7.  Click the OK button.  
	__8.  Save the file.  
	__9.  Close it. 
	__10.  We have created our Java bean.  Now, let us create an operation that uses it. Open Greeter.java (in the com.simple package, in the WebServiceProject)
	__11.  Add the following method to the class, making sure it is outside other method definitions but within the brackets for the class:
	__12.  Organize imports (CTRL-SHIFT-O) and pick java.util.Date when prompted.
	__13.  Now, add the following method:
	__14.  Save changes.  There should be no errors.

	Part 2 -  Expose the Web Service
	__1.  Double-click on the file 'cxf-beans.xml' in the WebContent/WEB-INF folder to open it.
	__2.  Add the following element to the file, just before the closing tag for the beans element ('/beans').
	__3.  Save and close the file.

	Part 3 -  Test the Web service
	__1.  In the Servers view, start the Tomcat server.  If the server was already running right click the server and select Restart.  Wait for the server to start completely and publish the new version of the application.
	__2.  In Eclipse, open the WSE by going to the menu and selecting Run → Launch the Web Services Explorer.  You might want to maximize the tool window.
	__3.  Switch to WSDL mode by clicking the WSDL Page button (second button from the right in the top right corner of the WSE).  You may also want to maximize the screen by clicking the tab for the Web Services Explorer.
	__4.  Click WSDL Main.
	__5.  In the right pane, for the URL, enter:
	__6.  Click Go.
	__7.  Click the createPerson link.
	__8.  Click the Add link and then enter a name.  
	__9.  Click Go.
	__10.  Click the Source link and then maximize the pane.
	__11.  Click the Form link the Status pane to show the original return message. 
	__12.  Restore the Status pane to the normal size.
	__13.  Display the getPersonName method.  (This can be done by clicking the getPersonName in the left pane).
	__14.  Click the Add button, next to arg0.  What happens?
	__15.  Click Add for each  field and follow the steps below.
	__16.  Click the Browse link to the right of the creationDate.
	__17.  In the popup that appears, click a date.
	__18.  Enter a name and make sure both fields have some data.
	__19.  Click Go.
	__20.  Maximize the Status pane and examine the Source. Look at the SOAP Request Envelope.
	__21.  Click the Form link in the Status pane to show the original return message. 
	__22.  Restore the Status pane to its normal size in the WSE.  
	__23.  Return to the values submitted for the 'getPersonName' method and remove the time from the 'creationDate' parameter so it is just the date in YYYY-MM-DD format.
	__24.  Make sure there is still a name filled in and click the Go button to submit another request.
	__25.  In the Status pane, notice there is an error.  This is because the default XML schema type for a 'Date' property in Java is the 'dateTime' XML schema type which is incorrect without a time.
	__26.  Close the WSE.  

	Part 4 -  Change the JAXB Mappings
	__1.   Open Person.java in the com.beans package.
	__2.  Add the following annotation in bold to the class.  You will have errors until future steps.
	__3.  Now, annotate the two fields as follows in bold:
	__4.  Organize imports (Ctrl-Shift-O). When prompted, select javax.xml.bind.annotation.XmlElement and click Finish.
	__5.  Save the class. There should be no errors.  
	__6.  Close Person.java

	Part 5 -  Fix the Greeter Service Mappings
	__1.  Open Greeter.java
	__2.  Locate the createPerson method, and add the following bold annotation.  You will have errors for a few steps.
	__3.  Locate the getPersonName method, and add the following bold annotation.  Make sure to add the annotation inside the parenthesis for the method but before the type of the parameter.  You will have errors for a few steps.
	__4.  Organize imports.
	__5.  Save changes.  There should be no errors.

	Part 6 -  Test JAXB Binding Changes
	__1.  Return to the Servers view where your Tomcat server should still be running and publish the server by right clicking the server and selecting Restart.  
	__2.  Run the WSE (Run → Launch Web Services Explorer).  
	__3.  Switch to the WSDL mode.  
	__4.  If the Navigator pane is not empty then click the Clear button.  We need to use the new WSDL and not the old one.
	__5.  Click WSDL Main.  
	__6.  In the right pane, enter the URL:
	http://localhost:8080/WebServiceProject/services/GreeterServiceSoapPort?wsdl
	__7.  Click Go.
	__8.  Click the createPerson link.
	__9.  Click Add. 
	__10.  Enter a name and click Go.
	__11.  Examine the response.  Note that the names person_name and creation_date are being used, as expected. 
	__12.  Examine the source for the response.  (Click the Source link and maximize the pane)
	__13.  Restore the Status pane to the normal size.
	__14.  Display the getPersonName method.  (This can be done by clicking the getPersonName in the left pane).
	__15.  Click the Add button, next to queryPerson.  
	__16.  Click Add for both these fields and enter some sample data for both fields.  Make sure to use the YYYY-MM-DD format for the date but you do not need time.
	__17.  Click Go.
	__18.  Maximize the Status pane and examine the Source. Look at the SOAP Request Envelope.
	__19.  Close all open editor windows.
	__20.  Stop the server

	Part 7 -  Review

	Lab 11 -  Monitoring SOAP Messages
	Part 1 -  Activate the Monitor 
	__1.  In the Servers tab in the Eclipse main window, right-click on the Tomcat server and then select Monitoring -> Properties...
	__2.  In the dialog, click Add...
	__3.  Select the HTTP port, and then click OK
	__4.  Back in the Properties dialog, select the new monitor and then click Start.
	__5.  Click OK.

	Part 2 -  Use Port 8081 from the Client
	__1.  In the Servers view, right click the Tomcat server and select Start.  
	__2.  Open a browser and browse to:
	__3.  Scroll to the bottom of the WSDL file and locate the <soap:address> tag
	http://localhost:8080/WebServiceProject/services/MovieServiceSOAPPort"
	__4.  Open the client class AddMovieServlet.java. It is in the MovieClientWeb project and com.movie.servlet package.
	__5.  Add these lines shown in bold face in the doPost method:
	__6.  Organize imports and select java.util.Map if prompted.
	__7.  Save and close the file. 

	Part 3 -  Test
	Let us now invoke the service.  If all goes well, any traffic the web service encounters will be displayed in the TCP/IP monitor. 
	__1.  In the Servers view, right click the Tomcat server and select Restart.  
	__2.  Browse to our application:
	__3.  Fill in some sample data and click Add Movie.
	__4.  When the movie is added, go back to Eclipse.
	__5.   Click the tab of the TCP/IP Monitor view.
	__6.  Double click on the title tab for this view to maximize it.
	__7.  In both of these panes, change the byte drop-down to XML. This will make the formatting a little easier to read.  
	__8.  Examine the request message.
	__9.  Now, look at the response message.
	__10.  Double click again on the title tab for the TCP/IP Monitor view to restore it.

	Part 4 -  WS-I Validation
	__1.  In the top right hand corner of TCP/IP Monitor, click the Validate WS-I Message Log File toolbar button.
	The system will prompt you to enter a location of the log file. All the request and response messages captured so far will be logged in that log file. This will come handy if the tool finds problems with the WS-I compatibility.
	__2.  Choose the client web project as shown below. 
	__3.  Click Finish.
	__4.  The tool will create the log file and validate it right away. Click OK to close the message dialog.
	__5.  Click the Clear button in the TCP/IP Monitor view to clear the messages.
	__6.  Stop the server and close any open editors or web browsers.

	Part 5 -  Review

	Lab 12 -  Handle Web Service Faults
	Part 1 -  Import the Pizza Ordering Service API
	__1.  First, we're going to import a project that contains the Application Programming Interface (API) for the pizza ordering service.  From the Eclipse main menu, select File -> Import -> General -> Existing Projects into Workspace and then click Next.
	__2.  Click on the radio button for Select archive file: and then click on the Browse button next to the input box.
	__3.  Navigate to C:\LabFiles and select PizzaAPI.zip, and then click Open.
	__4.  Click Finish.
	__5.  Have a look at the source code in the new project PizzaAPI.  Note in particular the interface called PizzaOrderTaker:

	Part 2 -  Import the Pizza API
	__1.  In the Eclipse Project Explorer, right-click on the WebServiceProject and then select Properties...
	__2.  Select Deployment Assembly
	__3.  Click the Add... button.  The system will display the New Assembly Directive dialog.  Select Project and then click Next.
	__4.  Select  PizzaAPI project and then click Finish.
	__5.  Click OK in the properties dialog.
	__6.  If you go into the PizzaAPI project and look at the interface 'com.mycom.pizza.api.PizzaOrderTaker', you'll see that it looks like this:
	__7.  If you have a look at the class 'com.mycom.pizza.api.PizzaOrder', you'll see that it looks like this:
	__8.  You might also have a look at the file 'com.mycom.pizza.api.package-info.java':

	Part 3 -  Create the Pizza Ordering Service
	__1.  In the WebServiceProject, create a new class called OrderTakerService in a package called com.mycom.pizza.impl.
	__2.  Replace the body of the class so that it looks like the following (leave the package definition as it is):
	__3.  Use Ctrl-Shift-O to organize the imports.  There should be no errors after this step.
	__4.  Save and close the file.
	__5.  In the WebServiceProject, locate the file 'WebContent/WEB-INF/cxf-beans.xml'. Open the file by double-clicking on it.
	__6.  Add the bold-faced part of the following code to the file, just before the closing tag for '</beans>':
	__7.  Save and close the file.

	Part 4 -  Verify the Pizza Ordering Service
	__1.  Restart the Tomcat server, and use a web browser to navigate to the services page at: 
	__2.  Verify that your PizzaOrderTaker service is listed.
	__3.  If you wish, you can test out the service with the Web Service Explorer.

	Part 5 -  Add a Web Client
	__1.  In the Eclipse main menu, select File -> Import..., and then select General-> Existing Projects into Workspace..., and then click Next.
	__2.  Make sure the radio button for Select archive file: is selected, and then click Browse...
	__3.  Select the file 'C:\LabFiles\PizzaClientWeb.zip', and click Open.
	__4.  Click Finish.
	__5.  In the PizzaClientWeb project, find the servlet 'com.mycom.pizza.ui.PizzaForm'
	__6.  Right-click on PizzaForm.java and then select Run As-> Run on Server.
	__7.  Make sure the Tomcat server is selected, and then click Finish.
	__8.  Click OK.
	__9.  Eclipse will open a web browser with a pizza order form.  Enter some data, and then click Place Order.
	__10.  The web app should respond with a message from the pizza place:

	Part 6 -  Add an Exception to the Pizza Order Interface
	__1.  In the PizzaAPI project, create a new class in the package 'com.mycom.pizza.api', called 'BadPizzaException'.  At this point, don't bother making it extend from any class but Object – we'll handle that in a minute.
	__2.  Edit the class definition so that it looks as follows:
	__3.  Use Ctrl-Shift-O to organize the imports.  There should be no errors after this step.
	__4.  Save the file.
	__5.  Open the 'PizzaOrderTaker.java' file in the package 'com.mycom.pizza.api'.
	__6.  Modify the declaration of 'acceptOrder(...)' to throw the new exception, as shown below:
	__7.  Save and close all files.
	__8.  We want to make sure that dependent projects (PizzaClientWeb and WebServiceProject) get rebuilt against the new interface.  To make sure, we'll do a 'clean' operation on the projects.  From the Eclipse main menu, select Project -> Clean.
	__9.  Ensure that the Clean all projects option is selected, and then click OK.

	Part 7 -  Modify the Service to Throw the Exception
	__1.  Open the source file for 'com.mycom.pizza.impl.OrderTakerService' from WebServiceProject.
	__2.  Modify the 'acceptOrder(...)' method, adding the bold-faced text, to read as follows:
	__3.  Use Ctrl-Shift-O to organize the imports.
	__4.  Save the code.
	__5.  Restart Tomcat.
	__6.  Open a web browser and go to the ordering page:
	__7.  Enter an order, but this time, make sure you include “Peppers” (note the upper-case 'P').
	__8.  Click Place Order.
	__9.  You will see an ugly error in the page.
	__10.  Double-click on the Console tab in the Eclipse window to expand it to fill the window.
	__11.  Search for the following message.

	Part 8 -  Modify Web Client to Handle Fault
	__1.  Expand the PizzaClientWeb → Java Resources → src folders.
	__2.  Right-click on the  com.mycom.pizza.impl package and then select Delete.  Click OK to confirm the deletion.
	__3.  Right-click on the com.mycom.pizza package, and then select Delete.  
	__4.  Ensure that the option for Delete subpackages of selected packages is not selected, and then click OK.
	__5.  You will get errors in other code, but we'll fix that in a minute.
	__6.  Right-click on PizzaClientWeb and then select New-> Other...
	__7.  In the dialog, select Web Services -> Web Service Client, and then click Next.
	__8.  Slide the slider down to Assemble Client.
	__9.  In the service definition, enter the url for the PizzaService wsdl file:
	__10.  Ensure that the Server and Web service runtime options are set to the 'Tomcat' and 'CXF 2.X' options.  When the dialog looks like below, click Finish.
	__11.  You will see still errors in PizzaClientWeb.
	__12.  In the PizzaClientWeb, double-click on 'com.mycom.pizza.ui.PizzaForm.java' to open it.
	__13.  Have a look at the doPost(...) method.  Note the line that says:
	__14.  Edit the doPost(...) method, adding the code shown in bold, so it looks like below:
	__15.  Organize imports.
	__16.  Save the class. There should be no errors in any class.
	__17.  Find the file 'WebContent/WEB-INF/jsp/PizzaForm.jsp' in PizzaClientWeb.  Double-click on the file to open it.
	__18.  Add the text shown in bold below, just under the opening '<body>' tag.
	__19.  Save and close all files.
	__20.  Close the web browser.

	Part 9 -  Test the Final System
	__1.  Restart Tomcat.
	__2.  Open a web browser and go to the ordering page:
	__3.  Enter an order, make sure you include “Peppers” (note the upper-case 'P').
	__4.  Click Place Order.
	__5.  Notice that instead of an ugly error message, the application redirects us to the input page, with an explanation:
	__6.  Close all open files and web browsers.
	__7.  Stop the server.

	Part 10 -  Review

	Lab 13 -  WS-Security with UsernameToken
	Part 1 -  Import and Test Service
	__1.  Right click the server and select Add and Remove.
	__2.  Click Remove All.
	__3.  Click Finish.
	__4.  Right click the server and select Start. This will clean up the server and will start faster.
	__5.  Select File → Import from the Eclipse menus.
	__6.  Expand the General group and select Existing Projects into Workspace and press the Next button.
	__7.  Select the radio button next to the Select archive file option and use the matching Browse button to find the 'C:\LabFiles\PreSecurityStarter.zip' file that contains the project.  
	__8.  Select the projects listed in the file if they are not already as shown below.
	__9.  Press the Finish button to import the project.
	__10.  Check that the two 'Security...' projects show up in the list and do not have any red errors.  
	__11.  Right click on the server and select Add and Remove...
	__12.  In the left pane, select SecurityBillingClientWeb and click Add.
	__13.  In the left pane, select SecurityBillingServiceWeb and click Add.
	__14.  Click Finish.  This will deploy the new projects to the server.
	__15.  Restart the Tomcat server.
	__16.  Open a web browser to the following address which should bring up the list of deployed services in the SecurityBillingServiceWeb application
	__17.  Make sure that the BillingManager Web service is registered.  
	__18.  Return the the TCP/IP Monitor view if you have it open.  If it is not open you can open it by selecting Window → Show View and then Debug → TCP/IP Monitor.
	__19.  Click the Clear button in the TCP/IP Monitor view to clear out any previous requests.
	__20.  In the Servers tab, Right click on the Tomcat server and then select  Monitoring -> Properties.
	__21.  Ensure that the status is shows as “Started”.  If it isn't, select the monitor and then click Start.
	__22.  Once your monitor is restarted click the OK button to close the preferences.
	__23.  Back in the web browser enter the URL:
	__24.  Fill in some sample info and click the Add button.  This page will use a Servlet in the client web application to submit a web service request to the service application.
	__25.  Make sure you get an 'OK' response from the server.
	__26.  Return to the Eclipse Console view and make sure there is information you entered printed out by the 'BillingManager' service.
	__27.  Look at the XML format of the request in the  TCP/IP Monitor view and notice it is just a regular service request.  The makeup of the requests and responses will vary quite a bit as WS-Security features are utilized.

	Part 2 -  Examine Template CXF Configuration
	__1.  In the SecurityBillingServiceWeb project, locate the file 'WebContent/WEB-INF/cxf-beans.xml'.  Double-click on the file to open it.
	__2.  Switch to the Source tab in the editor if it is not already.
	__3.  Notice the <jaxws:endpoint> element that configures the service, as shown below:
	__4.  Close the 'cxf-beans.xml' file for the CXF service configuration.
	__5.  In the SecurityBillingClientWeb project, locate the file 'WebContent/WEB-INF/cxf-beans.xml'.  Double-click on the file to open it.
	__6.  Switch to the Source tab in the editor if it is not already.
	__7.  Notice the <jaxws:client> element that configures the service, as shown below:
	__8.  Close the 'cxf-beans.xml' file for the CXF service configuration.

	Part 3 -  Add CXF Configuration for UsernameToken
	__1.  In Eclipse expand the following folder:
	__2.  Double click the 'cxf-beans.xml' file to open it.
	__3.  Add the following 'outInterceptors' element and nested elements within the <jaxws:client> element.  Note that the 'class' attribute of the <bean> tags are long and wrap to another line.
	__4.  Add the following new 'bean' definition that will configure the 'WSS4JOutInterceptor' with the appropriate settings for supplying the UsernameToken with the outgoing request.  Notice the 'id' of this 'bean' matches the 'outInterceptors' you added above.
	__5.  Save the XML file and be sure there are no errors.
	__6.  In the Project Explorer, right-click on SecurityBillingClientWeb and select New > Class.
	__7.  Set the Package to be com.webage.billing.security
	__8.  Set the Name to be ClientUsernamePasswordCallback
	__9.  Next to the empty list of interfaces click the Add button.
	__10.  Type 'CallbackHandler' in the filter box, select the CallbackHandler interface, and click the OK button.
	__11.  Check that your settings match that shown below and click the Finish button.
	__12.  Add the following code in bold.  This will create a Map of users and passwords that can be used by the client to send the request.  You will have errors fixed later.
	__13.  Modify the implementation of the 'handle' method to match that below.
	__14.  Organize imports (CTRL-SHIFT-O). Select java.util.Map.
	__15.  Save the file and make sure there are no errors.
	__16.  Close all open files.
	__17.  In Eclipse expand the following folder from the service project:
	__18.  Double click the 'cxf-beans.xml' file to open it.
	__19.  Add the following 'inInterceptors' element and nested elements within the <jaxws:endpoint> element. Make sure you remove the closing /.
	__20.  Add the following new 'bean' definition that will configure the 'WSS4JInInterceptor' with the appropriate settings for letting the service look for the incoming UsernameToken in the request.  Notice the 'id' of this 'bean' matches the 'inInterceptors' you added above.
	__21.  Save the file and be sure there are no errors.
	__22.  In the Project Explorer, right-click on SecurityBillingServiceWeb and select New > Class.
	__23.  Set the Package to be com.webage.billing.security
	__24.  Set the Name to be UsernamePasswordCallback
	__25.  Next to the empty list of interfaces click the Add button.
	__26.  Type 'CallbackHandler' in the filter box, select the CallbackHandler interface, and click the OK button.
	__27.  Check that your settings match that shown below and click the Finish button.
	__28.  Add the following code in bold.  This will create a Map of users and passwords assumed to be the users allowed to access the service.  You will have errors fixed later.
	__29.  Modify the implementation of the 'handle' method to match that below.
	__30.  Organize imports (CTRL-SHIFT-O). Select java.util.Map.
	__31.  Save the file and make sure there are no errors.
	__32.  Close all open files.

	Part 4 -  Test UsernameToken with PasswordText
	__1.  Return to the Servers view.
	__2.  Restart your Tomcat server
	Wait until its status is Synchronized.
	__3.  Right click the Server and select Monitoring → Properties.
	__4.  Make sure you have the 8081 Monitor port started, if not then select it and click Start.
	__5.  Click OK to close the Properties.
	__6.  Return the the TCP/IP Monitor view if you have it open.  If it is not open you can open it by selecting Window → Show View and then Debug → TCP/IP Monitor.
	__7.  Click the Clear button in the TCP/IP Monitor view to clear out any previous requests.
	__8.  Back in the web browser enter the URL:
	__9.  Fill in some sample info and click the Add button.  
	__10.  Make sure you get an 'OK' response from the server.  
	__11.  Maximize the Console view and notice that besides the messages you get from the service like normal we are also getting the logging from the 'LoggingOutInterceptor' of the client.  This helps verify the CXF client configuration is in fact being used.
	__12.  Switch to the TCP/IP Monitor view and make sure the last request submitted is selected.
	__13.  Switch to the XML display option and notice that the request has a number of additional WS-Security elements (with the 'wsse' and 'wsu' prefixes) along with the normal service request data for the account to add.
	__14.  Look at the <wsse:Username> and <wsse:Password> elements (scroll to the right for the password) and notice that the username and the password are sent in clear text.
	__15.  Switch to the XML display output in the response and notice that nothing about it has been changed for WS-Security.
	__16.  Restore any views you had maximized.
	__17.  In Eclipse expand the following folder:
	__18.  Double click the 'cxf-beans.xml' file to open it.
	__19.  In the map of properties in the CXF configuration of the "OutInterceptor" change the user property to 'badclient' as shown below.
	__20.  Save the file and make sure there are no errors.  Leave the file open.
	__21.  Return to the Servers view.
	__22.  Restart your Tomcat server
	__23.  Clear the TCP/IP monitor.
	__24.  Back in the web browser return to the page to submit request data:
	__25.  Fill in some sample info and click the Add button.  You should get an error saying the security token was not valid.  Even though the client web application did not handle this error "nicely" it is clear the service has refused the request with a bad user. 
	__26.  Close the web browser.
	__27.  Leave the server running.

	Part 5 -  Use a PasswordDigest UsernameToken
	__1.  Return to the editor for the 'cxf-beans.xml' file in the SecurityBillingClientWeb project.  Open it again if you closed it remembering it is in the WebContent -> WEB‑INF folder.
	__2.  Change the 'PasswordType' property to 'PasswordDigest' as shown below.   Also change the user used back to 'goodclient' which will pass the authentication check on the service side.
	__3.  Save and close the file after making sure there are no errors.

	Part 6 -  Test PasswordDigest Changes
	__1.  Return to the Servers view.
	__2.  Restart Tomcat.
	__3.  Open a the web browser and enter the URL:
	__4.  Fill in some sample info and click the Add button.  
	__5.  Make sure you get an 'OK' response from the server.  If you get an error you may have forgotten to switch the client user property back to 'goodclient'.
	__6.  Back in Eclipse. switch to the TCP/IP Monitor view and make sure the last request submitted is selected.
	__7.  Switch to the XML display option on the request side and scroll to the right to find the value of the <wsse:Password> element.  Notice it is hashed and there is also a <wsse:Nonce> element which is used in the password digest hashing.
	__8.  Restore any views you had maximized.

	Part 7 -  Provide UsernameToken as Part of Service Response
	__1.  In Eclipse close all open files and expand the following folder:
	__2.  Double click the 'cxf-beans.xml' file to open it.  Make sure it is the service CXF configuration.
	__3.  Add the following 'outInterceptors' element and nested elements within the <jaxws:endpoint> element but separate from the <jaxws:invoker> and existing <jaxws:inInterceptors>.  Note that the 'class' attribute of the <bean> tag is long and wraps to another line.
	__4.  Add the following new 'bean' definition that will configure the 'WSS4JOutInterceptor' with the appropriate settings for letting the service supply a UsernameToken as part of the response.  An important property is the 'user' property with the value of 'serverID' which will be the "username" of the service supplied back to the client.  Notice the 'id' of this 'bean' matches the 'outInterceptors' you added above.
	__5.  Save and close the file after checking there are no errors.
	__6.  Open the UsernamePasswordCallback.java file in the com.webage.billing.security package of the SecurityBillingServiceWeb project. 
	__7.  Add the following code in the constructor of the class.  This will supply the password of the service when the CXF configuration supplies the 'serverID' username before sending the response.
	__8.  Save and close the file after checking there are no errors.
	__9.  Expand the following folder:
	__10.  Double click the 'cxf-beans.xml' file to open it.
	__11.  Add the following 'inInterceptors' element and nested elements within the <jaxws:client> element but separate from the existing <jaxws:outInterceptors> element.  Note that the 'class' attribute of the <bean> tags are long and wrap to another line.
	__12.  Add the following new 'bean' definition that will configure the 'WSS4JInInterceptor' with the appropriate settings to check the service supplied UsernameToken that is part of the response with a "Callback Handler" class that will supply the password the server is expected to return.  Notice the 'id' of this 'bean' matches the 'inInterceptors' you added above.
	__13.  Save and close the file after checking there are no errors.
	__14.  Open the ClientUsernamePasswordCallback.java file in the com.webage.billing.security package of the SecurityBillingClientWeb project. 
	__15.  Add the following code in the constructor of the class.  This will supply the expected password of the service response.
	__16.  Save and close the file after checking there are no errors.

	Part 8 -  Test Service UsernameToken With Response
	__1.  Return to the Servers view.
	__2.  Restart Tomcat.
	__3.  Clear the TCP/IP monitor.
	__4.  Back in the web browser enter the URL:
	__5.  Fill in some sample info and click the Add button.  
	__6.  Make sure you get an 'OK' response from the server. 
	__7.  Back in Eclipse. switch to the TCP/IP Monitor view and make sure the last request submitted is selected.
	__8.  Switch to the XML display option on the response side (the right side) and notice the response now has various WS-Security elements in the response in addition to the usual 'OK' status near the end of the response.
	__9.  Restore any views you had maximized.
	__10.  Close any files and browsers, and stop the server.

	Part 9 -  Review

	Lab 14 -  WS-Security With Signature
	Part 1 -  Generate Keys
	__1.  Open a command prompt window.  You can do this by selecting Start → Run, entering 'cmd' and hitting <ENTER>.
	__2.  Change directory to C:\LabFiles.
	__3.  Run the command 'keytool' to make sure you have access to the program.  It shouldn't do anything but come back with the options to run the command.
	__4.  Run the script provided for you that will generate security certificates and exchange between “keystores”:
	__5.  Make sure that there are no error messages. The output should look like above.
	__6.  Run the following command to list all keys in service.jks:
	__7.  Similarly, list all keys in client.jks.
	__8.  Close the command prompt.
	__9.  Open a Windows explorer window and navigate to C:\LabFiles.
	__10.  Right click on the 'genkeys.bat' file and select Edit.  Make sure you do not double click it as this will run it.
	__11.  Examine the first key generation command for the service's key and the important settings:
	__12.  Notice the second command generates the key for the client.  Most of the settings are similar to some you will see later in CXF configuration.
	__13.  The next pair of commands exports the key from the service keystore into a separate file and imports this key into the client keystore as a "trusted" certificate.  Notice the keystore password of the appropriate keystore is required and the alias of the key to export and import (myservicekey) is used to identify which key to work with.
	__14.  The final pair of commands performs the export/import process in the reverse direction so the service keystore will trust the client certificate.
	__15.  Close the file.
	__16.  From the Windows Explorer window showing the contents of C:\LabFiles copy the 'service.jks' file.  Make sure you don't copy the 'MyService.cer' file.
	__17.  Return to Eclipse and expand the following folder:
	__18.  Right click the 'src' folder (not any of the packages) and select Paste.  Make sure the 'service.jks' file is pasted at the root of the 'src' folder as shown below.  This is the easiest way to ensure the file is available on the classpath of the deployed application.
	__19.  Return to the Windows Explorer window showing the contents of the C:\LabFiles directory.
	__20.  Copy the 'client.jks' file.
	__21.  Return to Eclipse and expand the following folder:
	__22.  Right click the 'src' folder (not any of the packages) and select Paste.  Make sure the 'client.jks' file is pasted at the root of the 'src' folder as shown below.  

	Part 2 -  Modify Client Configuration for Signature
	__1.  In Eclipse expand the following folder:
	__2.  Double click the 'cxf-beans.xml' file to open it.
	__3.  Find the definition of the 'Security_Request' bean associated with the "Out" interceptor and modify the value of the 'action' property to include 'Signature' with a space before the new action.
	__4.  Add the following new <entry> elements to the configuration of the 'Security_Request' bean.  Be careful entering the values, especially with the 'signatureParts' property which should all be on one line.
	__5.  Find the definition of the 'Security_Response' bean associated with the "In" interceptor and modify the value of the 'action' property to include 'Signature' with a space before the new action.
	__6.  Add the following new <entry> element to the configuration of the 'Security_Response' bean.  This sets the 'signaturePropFile' to a properties file that will be created in the next steps.
	__7.  Save and close the file after making sure there are no errors.  Eclipse may show errors in the XML file if you are not connected to the internet to have access to the CXF schemas.
	__8.  Expand the following folder:
	__9.  Open the ClientUsernamePasswordCallback.java file.
	__10.  Add the following code in bold to the constructor of the class.  This will supply the password of the alias for the key used to sign the request.
	__11.  Save and close the file after making sure there are no errors.
	__12.  In the SecurityBillingClientWeb → Java Resources folder, right click the 'src' folder (not any of the packages) and select New → Other...
	__13.  In the wizard select General → File and click the Next button.
	__14.  Fill in a 'File name' of 'client.properties', check that the 'parent folder' is 'SecurityBillingClientWeb/src', and click the Finish button.
	__15.  Check that the new file appears at the root of the 'src' folder along with the 'client.jks' file you had already pasted there.  If it seems to show up in the wrong place try selecting the project and hitting the F5 key to refresh the project.
	__16.  In the file that is opened enter the following properties.  The first property below is too long to be shown on one line but should be entered on the same line as the property key of 'org.apache.ws.security.crypto.provider'.
	__17.  Save and close the file after making sure there are no errors.

	Part 3 -  Configure Service for Signature
	__1.  In Eclipse expand the following folder:
	__2.  Double click the 'cxf-beans.xml' file to open it.
	__3.  Find the definition of the 'Security_Request' bean associated with the "In" interceptor and modify the value of the 'action' property to include 'Signature' with a space before the new action.
	__4.  Add the following new <entry> element to the configuration of the 'Security_Request' bean.  This sets the 'signaturePropFile' to a properties file that will be created in the next steps.
	__5.  Find the definition of the 'Security_Response' bean associated with the "Out" interceptor and modify the value of the 'action' property to include 'Signature' with a space before the new action.
	__6.  Add the following new <entry> elements to the configuration of the 'Security_Response' bean.  Be careful entering the values, especially with the 'signatureParts' property which should all be on one line.
	__7.  Save and close the file after making sure there are no errors.  Eclipse may think there are errors if it can't connect to the internet to get the CXF XML schemas.
	__8.  Expand the following folder:
	__9.  Open the UsernamePasswordCallback.java file.
	__10.  Add the following code in bold to the constructor of the class.  This will supply the password of the alias for the key used to sign the response.
	__11.  Save and close the file after making sure there are no errors.
	__12.  Expand the following folder from the client project:
	__13.  Right click the client.properties file and select Copy.
	__14.  Expand the following folder in the service project:
	__15.  Right click the 'src' folder (not any of the packages) and select Paste.
	__16.  Refresh the project.
	__17.  Right click the client.properties file you pasted in the service project and select Rename.
	__18.  Change the name of the file to service.properties and click the OK button.
	__19.  Check that the file appears at the root of the 'src' folder along with the 'service.jks' file you had already pasted there.
	__20.  Double click the service.properties file to open it.
	__21.  Change the following property values that are shown in bold so they match the values for the service keystore.  Remember the first property below is too long to be shown on one line but the value should be on the same line and the value is the same as what was used for the client.
	__22.  Save and close the file after making sure there are no errors.

	Part 4 -  Test Signature
	__1.  Open the Servers view. 
	__2.  Restart Tomcat
	__3.  Return the the TCP/IP Monitor view if you have it open.  If it is not open you can open it by selecting Window → Show View and then Debug → TCP/IP Monitor.
	__4.  Click the Clear button in the TCP/IP Monitor view to clear out any previous requests.
	__5.  Open a web browser and enter the URL:
	__6.  Fill in some sample info and click the Add button.  
	__7.  Make sure you get an 'OK' response from the server.
	__8.  Back in Eclipse switch to the TCP/IP Monitor view and make sure the last request submitted is selected.
	__9.  Switch to the XML display option on the request side and notice there are new elements like <ds:Signature> and <ds:DigestValue> which are involved in the signature.
	__10.  Notice at the end of the message the content of the message is still in plain text.  The signature only provides validity of the message and doesn't encrypt the message itself.
	__11.  Switch to the XML display view of the response on the right and notice the same signature elements are there also.
	__12.  Restore any views you had maximized.
	__13.  Close any files and stop the server.

	Part 5 -  Review

	Lab 15 -  WS-Security With Encryption
	Part 1 -  Modify Client Configuration for Encryption
	__1.  In Eclipse expand the following folder:
	__2.  Double click the 'cxf-beans.xml' file to open it.
	__3.  Find the definition of the 'Security_Request' bean associated with the "Out" interceptor and modify the value of the 'action' property to include 'Encrypt' with a space before the new action.
	__4.  Add the following new <entry> elements to the configuration of the 'Security_Request' bean.  Be careful entering the values, especially with the 'encryptionParts' property which should all be on one line.  Notice that the 'encryptionUser' is 'myservicekey' which will use the public key of the service to encrypt the request from the client.
	__5.  Find the definition of the 'Security_Response' bean associated with the "In" interceptor and modify the value of the 'action' property to include 'Encrypt' with a space before the new action.
	__6.  Add the following new <entry> element to the configuration of the 'Security_Response' bean.  This sets the 'decryptionPropFile' to the same properties file as used before.
	__7.  Save and close the file after making sure there are no errors.  Eclipse may think there are XML errors if you are not connected to the internet.

	Part 2 -  Configure Service for Encryption
	__1.  In Eclipse expand the following folder:
	__2.  Double click the 'cxf-beans.xml' file to open it.
	__3.  Find the definition of the 'Security_Request' bean associated with the "In" interceptor and modify the value of the 'action' property to include 'Encrypt' with a space before the new action.
	__4.  Add the following new <entry> element to the configuration of the 'Security_Request' bean.  This sets the 'decryptionPropFile' to the same properties file as used before.
	__5.  Find the definition of the 'Security_Response' bean associated with the "Out" interceptor and modify the value of the 'action' property to include 'Encrypt' with a space before the new action.
	__6.  Add the following new <entry> elements to the configuration of the 'Security_Response' bean.  Be careful entering the values, especially with the 'encryptionParts' property which should all be on one line.  Notice that the 'encryptionUser' is 'myclientkey' which will use the public key of the client to encrypt the response from the service.
	__7.  Save and close the file after making sure there are no errors.  Eclipse may think there are XML errors if you are not connected to the internet.

	Part 3 -  Test Encryption
	__1.  Open the Servers view. 
	__2.  Restart the Tomcat server.
	__3.  Return the the TCP/IP Monitor view if you have it open.  If it is not open you can open it by selecting Window → Show View and then Debug → TCP/IP Monitor.
	__4.  Click the Clear button in the TCP/IP Monitor view to clear out any previous requests.
	__5.  Back in the web browser enter the URL:
	__6.  Fill in some sample info and click the Add button.  
	__7.  Make sure you get an 'OK' response from the server.
	__8.  Back in Eclipse scroll back in the Console view and you should be able to see the account info printed which proves the service was able to decrypt it.
	__9.  Switch to the TCP/IP Monitor view and make sure the last request submitted is selected.
	__10.  Switch to the XML display option on the request side and scroll to the bottom notice there are elements within the <soap:Body> element that contain the encrypted text.  You also no longer see the plain text of the message with the account info like you saw before.  This is because it is now being encrypted.
	__11.  Switch to the XML display view of the response on the right and notice at the end of the response the message is also encrypted.  Although our service just responds with "OK" it could easily send back an account number or something similar that would be good to encrypt.
	__12.  Restore any views you had maximized.
	__13.  Close any files, web browsers.
	__14.  Remove all projects from the server.
	__15.  Right click the server and select Publish.
	__16.  Stop the server.

	Part 4 -  Review

	Lab 16 -  Develop a Simple RESTful Service
	Part 1 -  Create the Web Service Project
	__1.  From the menubar, select File > New > Dynamic Web Project.
	__2.  Enter AcmeWeb for the Project name.
	__3.  Ensure that the Add project to an EAR checkbox is not selected.
	__4.  Your screen should now look like the following:
	__5.  Click Finish.  The WAR will be created.  If prompted, don't switch to the web perspective by clicking No.
	__6.  Right click the newly created AcmeWeb project and select Properties.
	__7.  Now, select the Project Facets property.
	__8.  Note that the JAX-RS facet is not selected. This facet plays no role in developing JAX-RS services.
	__9.  Click Cancel to close the dialog.

	Part 2 -  Add the CXF Library
	__1.  Right-click on the AcmeWeb project, and then select Build Path -> Configure Build Path...
	__2.  Click on the Libraries tab.
	__3.  Click on Add Library...
	__4.  Select CXF Runtime and then click Next.
	__5.  Ensure that the CXF runtime is selected as Apache CXF 2.7.11 and then click Finish.
	__6.  Back in the Java Build Path dialog, select the Order and Export tab.
	__7.  Click to select the check box for Apache CXF Library [2.7.11]
	__8.  Click OK to exit the build path dialog.

	Part 3 -  Register the REST Application
	__1.  Open Windows file explorer.
	__2.  Go to C:\LabFiles\
	__3.  Copy web.xml
	__4.  In eclipse, paste the file inside the WebContent > WEB-INF folder of AcmeWeb.
	__5.  Open web.xml and study how the REST application is configured. Switch to the Source view and specifically, note the servlet mapping:
	__6.  Also notice that we have a callout to the Spring Framework context loader listener. As before, CXF is most easily configured using the Spring Framework.
	__7.  Close the file.
	__8.  Go back to the Windows Explorer window that was open to 'C:\LabFiles'.  Copy the file 'cxf-beans-jaxrs.xml'.
	__9.  In eclipse, paste the file inside the WebContent > WEB-INF folder of AcmeWeb.
	__10.  This file is already setup for the simple resource we're going to setup in the next section.  We'll examine the file after we setup that resource.

	Part 4 -  Create the Resource Class
	__1.  Right click AcmeWeb project and select New > Class.
	__2.  Enter com.acme.services as the package name and SimpleService as the class name.
	__3.  Click Finish to create the new class.
	__4.  Add a member variable that will help us do logging.
	__5.  Organize imports (Control+Shift+O) and select java.util.logging.Logger.  Make sure you select the correct class as there are several 'Logger' classes on the classpath.
	__6.  Add the method as follows.
	__7.  Save changes.

	Part 5 -  Configure the Resource
	__1.  Define the URI of the root resource, by adding the @Path annotation above the class. 
	__2.  Set the HTTP method and reply MIME type for the testGET() method sub-resource as follows.
	__3.  Organize imports. Select javax.ws.rs.Produces.
	__4.  Save changes.
	__5.  Open the 'cxf-beans-jaxrs' file that we copied into 'WEB-INF' in the last part.  Part of the file is shown below:

	Part 6 -  Unit Test
	__1.  In the main Eclipse window, select the Servers tab.  
	__2.  Right click the Tomcat server and select Add and Remove.
	__3.  Add the AcmeWeb project to the server.
	__4.  Click Finish.
	__5.  Restart the Tomcat server.
	__6.  Open a web browser and enter the URL: 
	__7.  You should see OK in the browser.
	__8.  The Console view will show the log output.

	Part 7 -  Use Path Extension for Sub-resource
	__1.  First, add this method to the SimpleService class.
	__2.  Annotate the method as follows.
	__3.  Save changes.

	Part 8 -  Unit Test
	__1.  Restart Tomcat.
	__2.  In a web browser, enter the URL: 
	__3.  Make sure that the Console shows the log output.
	__4.  Open a new browser or tab and re-test the testGET method for regression using the URL: 
	__5.  Close all browsers.
	__6.  Close all open files.

	Part 9 -  Review

	Lab 17 -  Extracting Information from a HTTP Request
	Part 1 -  Get Root Resource Path Parameters
	__1.  Open SimpleService.java from the AcmeWeb project.
	__2.  Change the @Path annotation for the class and add a parameter there.
	__3.  Add a member variable as follows.
	__4.  Annotate the member variable to save the value of the myRootPathData parameter.
	__5.  Organize imports (select javax.ws.rs.PathParam if asked).
	__6.  Change the log statement of the testGET() method as follows.
	__7.  Make a similar change to the testGETWithPath() method.
	__8.  Save changes.

	Part 2 -  Unit Test
	__1.  Restart the server.
	__2.  First, test the testGET() method by entering the URL: 
	__3.  The log output will like this:
	__4.  Now, test the testGETWithPath() method using the URL: 
	__5.  The log output will be:

	Part 3 -  Get Sub-resource Path Parameters
	__1.  Add a basic method as follows.
	__2.  Annotate method with path and method.
	__3.  Now, extract the path parameters and save them in the two input argument variables of the method.  The syntax for the @PathParam annotation on a method parameter is tricky so be careful.
	__4.  Save changes.
	__5.  Restart the server.
	__6.  Test the method by entering the URL: 

	Part 4 -  Extract Query Parameters
	__1.  Add the giveRaise() method as shown below.
	__2.  Organize imports.
	__3.  Save changes.
	__4.  Restart the server.
	__5.  Test the change by entering the URL: 
	__6.  Make sure that the Console shows:

	Part 5 -  Extracting Form Post Data
	__1.  Add this method.
	__2.  Organize imports. Select  java.util.List.
	__3.  Save changes.

	Part 6 -  Unit Test
	__1.  We will import the form HTML page. Copy C:\LabFiles\post.html and paste it inside the WebContent folder of the AcmeWeb project.
	__2.  Restart the Tomcat server
	__3.  Open a browser and enter the URL: 
	__4.  Fill out the form and submit it. 
	__5.  Make sure that the console log shows the input values correctly.
	__6.  Close all open files.
	__7.  Close all open browsers. 

	Part 7 -  Review

	Lab 18 -  Designing a RESTful Service
	Part 1 -  The Business Requirements
	Part 2 -  Define Project Scope
	Part 3 -  Designing the Object Model
	__1.  Can you go through the business requirements and identify the entities? 
	__2.  Now that you have identified the entities, can you list the attributes or fields for each entity? Once again, the answer is below. But do your best to do the design yourself.

	Part 4 -  Identify the Service
	__1.  Can you go through the requirements and list the tasks or operations that various yet to be identified services need to perform? Then compare your findings with the answer below.
	__2.  Can you group the operations based on the entity they work with? Name each group as a service accordingly. The answer is below.

	Part 5 -  Design the Service Interface
	__1.  First, let us decide on the URI for each entity. This is a pretty straightforward exercise. Note: As a matter convention, plural forms of the entity names are used in URI.

	Part 6 -  Decide on the Data Format
	Part 7 -  Unaddressed Architectural Issues
	Part 8 -  Review

	Lab 19 -  Add Support for XML Format
	Part 1 -  Create the Entity Classes
	__1.  In the AcmeWeb project, create a package called com.acme.services.entities
	__2.  Within that package, create a Java class called QuoteRequest
	__3.  In the QuoteRequest class, add these member variables. Feel free to refer back to the object model to make sure we are doing this correctly.
	__4.  Generate getters and setters for the variables. To do this select any variable, then from the menu select Source >  Generate Getters and Setters. Click Select All and click OK.
	__5.  Add the @XmlRootElement JAXB annotation to the class as shown in boldface below.
	__6.  Organize imports.
	__7.  Save changes.
	__8.  Open a file browser and go to C:\LabFiles\entities.
	__9.  Copy all the files within the folder and then paste them into the com.acme.services.entities package.
	__10.  Open each entity class file and review them. Specifically, look at the Order class. Working with list of child objects can be tricky in JAXB. Look at how we are dealing with line items:
	__11.  Close all open files.

	Part 2 -  Generate the XML Schema
	__1.  In the Project Explorer view, right click on the AcmeWeb project and select New → Other.
	__2.  Expand JAXB and select Schema from JAXB Classes and click the Next button.
	__3.  Change the name of the schema to AcmeWeb.xsd
	__4.  Click Next.
	__5.  Expand the AcmeWeb → src folder and select the com.acme.services.entities package.
	__6.  Click the Finish button to generate the schema.
	__7.  After a few seconds check that the root of the project has the schema, note that it was renamed to AcmeWeb1.xsd.
	__8.  Open the generated schema file and study it if you wish.
	__9.  Close all open files.

	Part 3 -  Create the Quote Service Class
	__1.  In the com.acme.services package, create a class called QuoteService
	__2.  Set the root URI of the service as shown in boldface below.
	__3.  Add a member variable for logging.
	__4.  Add the getQuote() method as shown below. The business logic is very simple. We hard code the price and availability.
	__5.  Annotate the method as shown below.
	__6.  Organize imports. Select javax.ws.rs.Produces and java.util.logging.Logger.
	__7.  Save changes.

	Part 4 -  Better Content Handling
	__1.  Add the @Consumes annotation to getQuote as follows in bold.
	__2.  Similarly, change the @Produces annotation to support both MIME types for XML.
	__3.  Organize imports. Select javax.ws.rs.core.MediaType.
	__4.  Save changes.

	Part 5 -  Register the Resource with CXF
	__1.  In the 'WebContent/WEB-INF' folder, find the file 'cxf-beans-jaxrs.xml' and then double-click on the file to open it.
	__2.  Locate the jaxrs:serviceBeans element, and then add the bean definition shown in bold below.
	__3.  Save and close all open files.

	Part 6 -  Unit Testing
	__1.  Restart the server.
	__2.  Open a command window and change directories with the 'cd' command to C:\Software\RESTClient.
	__3.  Run the command:
	__4.  In the URL text box, enter: 
	__5.  Select POST method.
	__6.  Click the Body tab.
	__7.  Click the  icon.
	__8.  From the drop-down select the text/xml content type.
	__9.  Click OK.
	__10.  Click the  icon to open the file.
	__11.  Select C:\LabFiles\quote_request.xml and open it.
	__12.  The tool will offer you an option to change the MIME type to application/xml. This is not necessary (either text/xml or application/xml will work fine), click NO.
	__13.  Study the request document briefly.
	__14.  We are now ready start testing. Click the  icon next to the URL.
	__15.  Make sure that the HTTP reply status code is 200.
	__16.  Click the Body tab for the response.
	__17.  Right click the response body text and select Indent > Indent XML.
	__18.  Study the response document.
	__19.  Back in eclipse close all open files.
	__20.  Do not close the REST Client.

	Part 7 -  Review

	Lab 20 -  Add Support for JSON
	Part 1 -  Do the Design First
	Part 2 -  Add the JSON Method
	__1.  Open QuoteService class.
	__2.  First, add the shell of the method.
	__3.  Then, annotate the method and the input parameters as shown in boldface below.
	__4.  Now, fill in the body of the method. It basically calls the getQuote() method to get the job done.
	__5.  Organize imports.
	__6.  Save changes.

	Part 3 -  Understanding Content Negotiation
	Part 4 -  Test
	__1.  Restart the Tomcat server.
	__2.  Launch the REST client tool if it is not already running.  Use steps from previous labs to set the 'JAVA_HOME' variable in the command prompt to launch the tool.
	__3.  Set the URL to: 
	__4.  Choose POST method.
	__5.  Set the body using the XML code in C:\LabFiles\quote_request.xml 
	__6.  Set content type to application/xml; chartset=UTF-8.
	__7.  Click the Headers tab.
	__8.  Enter Accept as Key and text/xml as Value.
	__9.  Click the + icon to add the header.
	__10.  Run the test by clicking .
	__11.  Right click the response body area in the Body tab and select Indent > Indent XML.
	__12.  Verify that the reply body contains the response.
	__13.  Select the Accept header, then right click on it and select Delete.
	__14.  Enter Accept as Key and application/json as Value, then click the + icon to add the header.
	__15.  Select the request Body tab and click on the button for 'Insert parameters'
	__16.  Confirm that you want to erase the current body text by clicking the Yes button.
	__17.  Confirm that you want to switch the content type to the value needed for a form, 'application/x-www-form-urlencoded', by clicking the Yes button.
	__18.  Use the tool to add each of the following parameters by filling in the key and value and clicking the button to add the parameter.
	__19.  Once you have all the parameters filled in as shown below, click the Generate button.
	__20.  Run the test.
	__21.  Right click the response body area and select Indent > Indent JSON.
	__22.  Verify the result.
	__23.  Back in eclipse close all open files.
	__24.  Do not close the REST Client.

	Part 5 -  Review

	Lab 21 -  Build the Order Web Service
	Part 1 -  Create the Resource Class
	__1.  In the com.acme.services package, create a class called OrderService
	__2.  Annotate the class to set the path as follows.
	__3.  Add a member variable for logging.
	__4.  Organize imports. Select java.util.logging.Logger.
	__5.  Save changes.

	Part 2 -  Implement Order Placement
	__1.  Write the shell of the method as follows. We will not deal with the returned URL just yet.
	__2.  Annotate the method with @POST and @Consumes.
	__3.  Organize imports. Select these classes when prompted (they may come up in a different order):
	javax.ws.rs.core.MediaType
	com.acme.services.entities.Order
	javax.ws.rs.core.Response
	__4.  Save changes.
	__5.  Copy the file C:\LabFiles\OrderDAO.java into the com.acme.services package.
	__6.  Open the class and briefly study it. The code should be very simple.
	__7.  In the placeOrder method of the OrderService class, use OrderDAO as shown in boldface below.
	__8.  Organize imports. Select this class:
	java.util.logging.Level
	__9.  Save changes.

	Part 3 -  Implement Retrieval of Order
	__1.  First write the method shell along with the required annotations.
	__2.  Next, fill in the method body.
	__3.  Organize imports. Select these classes:
	__4.  Save changes.

	Part 4 -  Register the Resource with CXF
	__1.  In the 'WebContent/WEB-INF' folder, find the file 'cxf-beans-jaxrs.xml' and then double-click on the file to open it.
	__2.  Locate the jaxrs:serviceBeans element, and then add the bean definition shown in bold below.
	__3.  Save and close the file.

	Part 5 -  Construct Entity URL
	__1.  First, add a member variable to the class as follows.
	__2.  In the placeOrder() method, add the bold code:
	__3.  Add this line in bold below:
	__4.  Finally, add this line. 
	__5.  Organize imports. Choose this class:
	__6.  Save the file and make sure you don't have any compilation errors.

	Part 6 -  Test
	__1.  Go to the 'Servers' view restart the Tomcat server.
	__2.  Launch the REST client tool if it is not already running. 
	__3.  From the REST client's menubar, select File > Open Request (Control+O).
	__4.  Open C:\LabFiles\order_create.rcq
	__5.  Review these items about the request:
	__6.  Click the  button to send the request.
	__7.  Verify that:
	__8.  In the Console, verify the log output from the OrderDAO class.
	__9.  In the REST client, open the request file C:\LabFiles\order_retrieve.rcq.
	__10.  Verify:
	__11.  Send the request.
	__12.  Verify that the reply body has the correct order information.

	Part 7 -  Enable Error Handling
	__1.  In the placeOrder() method of OrderService class, add this line shown in bold face.
	__2.  Comment out the following unreachable line:
	__3.  Organize imports. 
	__4.  In the getOrder() method, above the line:
	__5.  Organize imports. Choose this class:
	javax.ws.rs.core.Response.Status
	__6.  Save changes.

	Part 8 -  Test
	__1.  Restart the  server in the Servers view.
	__2.  In the REST client, the order retrieval request file should be open already. Just run the test.
	__3.  Verify that the status code is 404.  This is because the previous order was lost when the application was updated and restarted.
	__4.  Open the request file C:\LabFiles\order_create.rcq.
	__5.  In the Body tab, delete all the <item> elements.
	__6.  Run the test.
	__7.  Verify that status code 500 is returned.
	__8.  Do regression tests to make sure that success conditions are working fine.
	__9.  In eclipse close all open files.
	__10.  Do not close the REST Client.

	Part 9 -  Review

	Lab 22 -  Complete the Order Service
	Part 1 -  Implement Order Cancellation
	__1.  In the AcmeWeb project, open OrderService.java
	__2.  Add this method.
	__3.  Add these lines to the cancelOrder() method.
	__4.  Organize imports.
	__5.  Save changes.

	Part 2 -  Test
	__1.  Restart the  server.
	__2.  Launch the REST client tool if it is not already running.  Use steps from previous labs to set the 'JAVA_HOME' variable in the command prompt to launch the tool.
	__3.  From the client, open the request file C:\LabFiles\order_create.rcq
	__4.  Run the test. You should get a status code of 201. 
	__5.  Open the request file C:\LabFiles\order_retrieve.rcq
	__6.  Run the test. You should get a status code of 200.
	__7.  From the Method tab, select DELETE.
	__8.  Run the test. 
	__9.  Since the reply body is empty, you should see HTTP status code 204. This is equivalent to status 200 and indicates success.
	__10.  In the Method tab, select GET method.
	__11.  Run the test.
	__12.  Verify that 404 is returned.

	Part 3 -  Implement Order History
	__1.  From the com.acme.services.entities package, open OrderList.java and inspect it.
	__2.  Close the class.
	__3.  In the OrderService class, add the method shell as follows.
	__4.  Add the method body as follows.
	__5.  Organize imports.
	__6.  Save changes.

	Part 4 -  Test
	__1.  Publish the  server.
	__2.  From the REST test client, open the request file C:\LabFile\order_create.rcq
	__3.  From the Body tab, note the client ID – C001.
	__4.  Run the test to create an order.
	__5.  From the Body tab of the request, change the part number and quantity ordered.
	__6.  Run the test to place a few more orders.
	__7.  From the test client, open the request file C:\LabFiles\order_history.rcq
	__8.  Run the test.
	__9.  Scroll down and verify that both orders are shown.

	Part 5 -  Implement Order Update Function
	__1.  In the OrderService class, add the method shell.
	__2.  Fill in the method body as follows.
	__3.  Organize imports.
	__4.  Save changes.

	Part 6 -  Test
	__1.  Restart the  server.
	__2.  From the REST test client, open the request file C:\LabFile\order_create.rcq
	__3.  Run the test.
	__4.  Add the order ID 1000 to the URL (add  /1000  at the end of the URL).
	__5.  From the Method tab, choose PUT.
	__6.  From the Body tab, change quantity and/or part number.
	__7.  Run the test.
	__8.  Verify that status code 200 is returned.
	__9.  Now lets check the retrieve request. Open the request file C:\LabFiles\order_retrieve.rcq
	__10.  Run the test.
	__11.  Verify that status code 200 is returned.   
	__12.  Format the result (Indent > Indent XML ) and verify that the body contains the information that you changed.
	__13.  Open the request file C:\LabFile\order_create.rcq
	__14.  Change the order ID in the URL to an invalid value as shown below.
	__15.  From the Method tab, choose PUT.
	__16.  Run the test and make sure 404 status code is returned.
	__17.  In eclipse, close all the open files.

	Part 7 -  Review

	Lab 23 -  Developing a JAX-RS Client
	Part 1 -  Client Design Considerations
	Part 2 -  Import the Client Application
	__1.  From the eclipse menubar, select File > Import.
	__2.  Select General > Existing Projects into Workspace and click Next.
	__3.  Select the 'Select archive file' radio button and use the Browse button to the right to select the C:\LabFiles\SimpleClientStarter.zip file.
	__4.  Make sure the project is selected as shown above and click Finish.

	Part 3 -  Add the AcmeAPI jar
	__1.  In Eclipse right-click on SimpleClient and then select Build Path -> Configure Build Path...
	__2.  Select the Libraries tab.
	__3.  Click the Add External JARs... button.
	__4.  Navigate to 'C:\LabFiles' and select the AcmeAPI.jar file.
	__5.  Click Open.
	__6.  Back in the Java Build Path dialog, select the Order and Export tab.
	__7.  Click the checkbox for 'ACMEApi.jar'.
	__8.  In the left-hand side of the Properties dialog, click on Deployment Assembly.
	__9.  Click Apply in the following dialog.
	__10.  Click the Add... button.
	__11.  Click on Java Build Path Entries and then click Next.
	__12.  Click on AcmeAPI.jar to select it, then press Finish.
	__13.  Click OK.

	Part 4 -  Build the Presentation Layer
	__1.  In the WebContent/WEB-INF/jsp folder, right click on  QuoteForm.jsp and select Open with > Web Page Editor.
	__2.  Study the form.
	__3.  Open result.jsp and study how the QuoteResponse object properties are shown.
	__4.  From the com.webage.servlet package, open QuoteController.java.
	__5.  Locate the doPost method.
	__6.  Below the line:
	__7.  Add these lines to construct a QuoteRequest object:
	__8.  Below the line: 
	__9.  Add these lines to invoke the service using the proxy class we created earlier:
	__10.  Below the line:
	__11.  Add these lines to show the response in a JSP
	__12.  Organize imports.
	__13.  Save changes.

	Part 5 -  Test
	__1.  Deploy SimpleClientWeb project to the server with the Add and Remove.. option when you right click the server.
	__2.  Restart the Tomcat server.
	__3.  Open a web browser and enter the URL: 
	__4.  Enter some values and click Get Quote.
	__5.  Verify the result.
	__6.  Close the browser.
	__7.  Close all open files.

	Part 6 -  Review

	Lab 24 -  Securing JAX-RS REST Services
	Part 1 -  Configure Tomcat Application Security
	__1.  In the Eclipse Project Explorer window, locate the Servers project, and locate the Tomcat v7.0 Server at localhost-config -> tomcat-users.xml file contained inside it.
	__2.  Double-click on tomcat-users.xml to open it.
	__3.  Add the lines shown in bold below, just before the closing tag '</tomcat-users>':
	__4.  Save and close the file.

	Part 2 -  Secure the Quote Service
	__1.  Back in Eclipse, in the AcmeWeb project expand com.acme.services package.
	__2.  Open QuoteService.java.
	__3.  Add the following annotation in bold to the class.
	__4.  Organize imports. 
	__5.  Save changes.
	__6.  In the AcmeWeb project expand the AcmeWeb\WebContent\WEB-INF folder.
	__7.  Double click the web.xml file to open it in an editor and view the source.
	__8.  Add the XML in bold below to the end of the file but within the end '</web-app>' tag.  Pay particular attention to the values of the XML elements because the Eclipse validation will only pick up errors in the structure of the elements themselves and not in the contained values.
	__9.  Save and close the file after making sure there are no errors.
	__10.  Close all open files.

	Part 3 -  Test
	__1.  Restart the server.
	__2.  Open a browser and enter the URL: 
	__3.  You will be prompted to enter credentials.
	__4.  Click Cancel and close the browser.

	Part 4 -  Modify the Test Client
	__1.  Launch the RESTClient tool if it is not already running.  
	__2.  In the URL text box, enter: 
	__3.  Select POST method.
	__4.  Click the Body tab.
	__5.  Click the  icon to open the file. Click Yes to erase the existing code if any.
	__6.  Select C:\LabFiles\quote_request.xml and open it. Click 'Yes' when the tool offers you an option to change the MIME type to application/xml. 
	__7.  Click the  icon next to the URL.
	__8.  Make sure that the HTTP reply status code is 401.
	__9.  Click the Auth tab in the 'HTTP Request' section of the tool.
	__10.  Enter these values:
	__11.  Run the test again.
	__12.  Verify that status code 200 is returned.  You can check the body of the response as well but the status code alone should be able to tell it is working.

	Part 5 -  Enable Audit Logging
	__1.  In the AcmeWeb project, open OrderService.java.
	__2.  Configure the valid role for the service as shown in bold face below.
	__3.  Add a member variable to the class as follows.
	__4.  In the placeOrder() method, add the following bold code below the line to create the order:
	__5.  Organize imports and select the 'javax.ws.rs.core.SecurityContext' class.
	__6.  Save changes.
	__7.  Restart the server.

	Part 6 -  Test
	__1.  Launch the REST test client if it is not already running.
	__2.  Select File > Open Request from the menubar.
	__3.  Open C:\LabFiles\order_create.rcq
	__4.  Click the  button to send the request.
	__5.  Make sure that a status code 401 is returned.
	__6.  Click the Auth tab.
	__7.  Enter these values:
	__8.  Run the test again.
	__9.  Verify that status code 201 is returned.
	__10.  Check Eclipse console for the audit log. It will look like this:
	__11.  Close all open browsers.
	__12.  Close all open files.
	__13.  Close REST client.
	__14.  Stop the server.

	Part 7 -  Review




