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Lab 1 - Configure Tools in Jenkins
In this lab you will verify that Jenkins Continuous Integration is already installed and you 
will configure it.   

At the end of this lab you will be able to:
1. Verify Jenkins is running

2. Configure tools in Jenkins

Part 1 - Configure Jenkins
After the Jenkins installation, you can configure few other settings to complete the 
installation before creating jobs.

You will be setting JDK HOME and Maven Installation directory.

__1. To connect to Jenkins, open Firefox and enter the following URL .

http://localhost:8080/

__2. Enter wasadmin as user and password and click Log in.

__3. Don’t save the password if prompt or select Never Remember password for this site. 
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__4. Click on the Manage Jenkins link.

__5. Click Global Tool Configuration.

__6. Scroll down and find the JDK section, Click Add JDK.

__7. Enter OracleJDK for JDK name.

__8. Don't  check the ‘Install automatically’ option. Uncheck if already checked.

__9. Open a browser and navigate to the java folder as below; if this folder is not present 
there find the right location that you will use in the next step:

C:\Program Files\Java\jdk1.8.0_45

Note. Contact your instructor if you can't find the Java installation folder. 
__10. Go back to the web browser  and enter JAVA_HOME value as C:\Program 
Files\Java\jdk1.8.0_45 or the path where Java is installed.
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__11. Verify your settings look as below:

__12. In the Maven section, click Add Maven.

__13. Enter Maven for Maven name.

__14. Uncheck the ‘Install automatically’ option.

__15. Enter C:\Software\apache-maven-3.3.9 for MAVEN_HOME. Make sure this 
folder is correct.

__16. Verify your settings look as below:

__17. Scroll down and click Save.

Part 2 - Review
In this lab you configured the Jenkins Continuous Integration Server.
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Lab 2 - Install Maven
In this lab, we're going to install Apache Maven.  First, we'll install Maven for command-
line use, and verify it in the DOS command window.  Then, we'll setup the Eclipse 
installation to use that version of Maven as its implementation.

Although most developer's use of Maven will be through their IDE, it's a good idea to 
know a little bit of command-line usage.  That knowledge will come in handy when you 
go to setup continuous integration, and also when you want to do a quick build, perhaps 
for generating deployment or QA artifacts (although that might also be done through 
continuous integration).  Also, it's a good idea to set the Maven implementation, so you 
have control over the exact Maven version that gets run.

__1. In the Windows Start Menu, right-click on the Computer link in the right-hand side 
of the Start panel, and then select Properties.

__2. Click on Advanced system settings.

__3. The system will display the System Properties dialog.  Select the Advanced tab 
and click Environment Variables.

__4. Verify the JAVA_HOME variable is set to C:\Progra~1\Java\jdk1.8.0_45 or 
similar path.
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__5. Under the System Variables list, click the New button. 

__6. Enter M2_HOME as Variable name.

__7. As Variable value enter the following.  This should be the value you verified in the 
Set the Environment variables section - step 2.

C:\Software\apache-maven-3.3.9

__8. Click OK.

__9. In the 'System Variables' panel, locate the entry for 'Path' and double-click on it.

__10. Add the following to the end of the Variable Value field (including the semi-
colon)

;C:\Software\apache-maven-3.3.9\bin

__11. Click OK on the variable editor dialog.

__12. Click OK on the Environment Variables dialog.

__13. Click OK in the System Properties dialog.

__14. Open a command prompt window (in the start menu, click All Programs --> 
Accessories --> DOS Prompt.
__15. In the command window, type:

mvn -version
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__16. You should see output similar to:

Java version may be different.

Part 2 - Setup Maven in Eclipse
We have installed Maven for command-line use, but in reality, we are probably going to 
use Eclipse as the primary interface to it.  So there's a little configuration to do.

__1. Use Windows Explorer to navigate to C:\Software\eclipse, and then double-click on 
'eclipse.exe' to start up the IDE.

__2. You may see a security dialog.  If so, un-check the box for “Always ask before 
opening this file” and then click Run.

__3. Change the workspace to C:\Workspace and click OK.

__4. Eclipse Kepler will start launching.

__5. Close the Welcome screen by clicking the 'X' next to Welcome on the tab.
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__6. From the main menu, select Window → Preferences and then expand the tree node 
for Maven.

__7. Click on the tree node for Installations.

__8. On the right-hand side of the Preferences window, click on the Add... button.

__9. Navigate to C:\Software\apache-maven-3.3.9, ensure the node is selected, and 
click OK.

__10. In the Preferences dialog, verify Maven path and click OK.
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__11. From the main menu, select Window → Preferences and then expand the tree 
node for Java → Installed JREs.

__12. Select the jdk in the list and click Edit.
__13. Enter -Dmaven.multiModuleProjectDirectory=$M2_HOME as Default VM 
arguments.

__14. Click Finish.

__15. Click OK.

__16. Close all open windows.

Part 3 - Review
In this lab, we verified Apache Maven was already unpacked, then set up the environment 
variables that will be required to execute Maven.  Once we had the command-line setup 
complete, we started Eclipse and set up Eclipse to use the same installation of Maven that 
we have on the command line.

Although there is a version of Maven embedded in Eclipse, it is not generally the latest 
version released, so it's usually a good idea to install Maven separately and then 
configure Eclipse to use that version. 
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Lab 3 - Create a Maven Project
In this lab we're going to use the Maven integration in Eclipse to create a simple “Hello 
World” project that builds with Maven, and we'll explore what happens when we execute 
various Maven “goals” and “phases”.

Part 1 - Create a Project
__1. If necessary, start eclipse from C:\Software\eclipse\eclipse.exe using the same 
workspace.

__2. From the main menu, select File →  New →  Maven Project

__3. Click the check box for “Create a simple project (skip archetype selection)”, and 
then click Next.

__4. We need to provide the so-called “Maven Coordinates” that will identify the artifacts 
produced by this project, and optionally a name and description for the project.  Enter the 
following fields:

Group Id: com.mycom.demo
Artifact Id: hello-world

__5. Leave the Version and Packaging fields at their default values.  Leave the Parent 
Project fields empty.  
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__6. The dialog should look like:

__7. Click Finish.  The system will create the project we've asked for.

Part 2 - Explore the Project Structure
In the section above, we created the new project.  Let's take a look at the project structure 
and the files that were created by the IDE.

__1. In the Project Explorer, expand the node for the hello-world project.

__2. Notice that the IDE has created folders named “src/main/java”, 
“src/main/resources”, “src/test/java”, “src/test/resources”, and “target”.  This 
structure for the project folder is Maven's default structure.  All the inputs to the build 
process are stored under the “src” hierarchy, and all the outputs are under the “target” 
hierarchy.  This structure will be the same for any Maven project.

__3. Double-click “pom.xml” to open it in the Project Object Model editor.  At the 
bottom of the editor, you should see a number of tab labels, with the Overview tab 
currently selected.

__4. This view shows us the Maven Project Object Model and lets us edit it in a user-
friendly fashion.  You can see the coordinates that we entered when we created the 
project.
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__5. Click on the pom.xml tab.  This view displays the raw XML formatted text of the 
Project Object Model.  At the present time, all we really have is the project coordinates.

__6. Click on the Effective POM tab.  This view shows the results of combining the 
projects POM with the “Super-POM” that is built into Maven.  If you scroll down 
through the effective POM, you'll see the defaults for the various plugin configurations 
that are built into Maven, as well as the required locations for things like resources, 
output directories, etc.

__7. Click on the Dependencies tab.  This view shows what libraries are referenced from 
this project.  Right now, the project doesn't reference any dependencies.  In the next step, 
we'll change that to add a dependency on the JUnit test framework.

__8. Click on the Add... button underneath Dependencies

__9. In the field marked Enter groupId,..., type 'junit'.  After a second or two, the Search 
Results box will populate with a link to the “junit” library.  Expand the node for junit.

__10. When we clicked on the junit node, the Group Id, Artifact Id, and Version fields 
were automatically filled in.  However, we'd like to use a newer version of JUnit.  What's 
happened is that the search box has searched our local repository 
(<HOME>\.m2\repository) for possible matches.  JUnit 3.1.1 is already there, because 
some component of Maven or m2eclipse depends on it.  We can override the version even 
though the version we want is not currently in the local repository – Maven will go get it 
when we do the build.

__11. In the Version field, enter '4.11'.  (typically we would discover the current version 
through an internet search, or by querying Maven Central at http://search.maven.org)
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__12. In the Scope drop-down box, select test. When the dialog looks similar to the 
following, click OK.

Part 3 - Perform a “Priming” Build
At this point, we have a dependency on JUnit 4.1.1 in our project, but because we've 
never used that dependency before, the jar file for JUnit 4.1.1 is not available in our local 
repository.  Even though we don't have any code in the project yet, we can perform a 
build that will cause Maven to download the dependencies from Maven Central or 
another repository.  This is sometimes referred to as a “Priming Build”.

__1. In the Project Explorer, right-click on pom.xml and then select Run As →  Maven 
Build.  

__2. The system will display the Edit Configuration dialog. Since this is the first time 
we've run a Maven build, we need to specify what goal we want to build.  In the Goals 
field, enter 'install', and then click Run

__3. The system may display a Save Resource dialog.  If so, click Yes to save any 
changes that we've made.
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__4. If you watch the console, you'll probably see quite a lot of “Downloading...” 
messages, and finally an indication of “Build Success”.

What has happened is that Maven has downloaded all the required project dependencies 
to the local repository in “<HOME>\.m2”.  But the only dependency we mentioned was 
the JUnit jar file, so why did so many files get downloaded?  Maven uses the dependency 
resolution mechanism to resolve any dependencies that Maven or any plugin needs.  So 
effectively, Maven just downloaded most of the “real” Maven installation; when we 
installed Maven, it was really just the “boot loader” for Maven.

Part 4 - Add Some Code
__1. In the Project Explorer, right-click on src/main/java and select New →   Class.

__2. Enter a Package of “com.mycom.demo” and “HelloWorld” for the class name, and 
then click Finish.

__3. Edit the new class to include the main(...) method shown below.

public class HelloWorld {
public static void main(String[] args) {

System.out.println("Hello World");
}

}

__4. Save the file by clicking File →  Save or by typing Ctrl-S.  At this point, you could 
run the file by right-clicking and selecting Run As →  Java Application, but we don't 
really need to.
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__5. In the Project Explorer, right-click on pom.xml and select Run As →  Maven 
build.  

You should see the build progress in the console, ending with BUILD SUCCESS.

__6. In the Project Explorer, right-click on the target node and then select Refresh.

__7. Expand the target node. You should now see the jar file that is generated by the 
project – this is the standard Maven output for a packaging type of 'jar'.

__8. From the menu, select File → Close All. 

Part 5 - Review
In this lab, we created a simple Maven project using m2eclipse.  Running the Maven 
build caused all of the standard build plugins and their dependencies to be downloaded to 
our local repository.  Also, as a result of the build, the Maven archiver plugin generated a 
jar file that holds the compiled classes in our project. 
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	Part 1 -  Configure Jenkins
	__1.  To connect to Jenkins, open Firefox and enter the following URL .
	__2.  Enter wasadmin as user and password and click Log in.
	__3.  Don’t save the password if prompt or select Never Remember password for this site. 
	__4.  Click on the Manage Jenkins link.
	__5.  Click Global Tool Configuration.
	__6.  Scroll down and find the JDK section, Click Add JDK.
	__7.  Enter OracleJDK for JDK name.
	__8.  Don't  check the ‘Install automatically’ option. Uncheck if already checked.
	__9.  Open a browser and navigate to the java folder as below; if this folder is not present there find the right location that you will use in the next step:
	__10.  Go back to the web browser  and enter JAVA_HOME value as C:\Program Files\Java\jdk1.8.0_45 or the path where Java is installed.
	__11.  Verify your settings look as below:
	__12.  In the Maven section, click Add Maven.
	__13.  Enter Maven for Maven name.
	__14.  Uncheck the ‘Install automatically’ option.
	__15.  Enter C:\Software\apache-maven-3.3.9 for MAVEN_HOME. Make sure this folder is correct.
	__16.  Verify your settings look as below:
	__17.  Scroll down and click Save.

	Part 2 -  Review

	Lab 2 -  Install Maven
	__1.  In the Windows Start Menu, right-click on the Computer link in the right-hand side of the Start panel, and then select Properties.
	__2.  Click on Advanced system settings.
	__3.  The system will display the System Properties dialog.  Select the Advanced tab and click Environment Variables.
	__4.  Verify the JAVA_HOME variable is set to C:\Progra~1\Java\jdk1.8.0_45 or  similar path.
	__5.  Under the System Variables list, click the New button. 
	__6.  Enter M2_HOME as Variable name.
	__7.  As Variable value enter the following.  This should be the value you verified in the Set the Environment variables section - step 2.
	__8.  Click OK.
	__9.  In the 'System Variables' panel, locate the entry for 'Path' and double-click on it.
	__10.  Add the following to the end of the Variable Value field (including the semi-colon)
	__11.  Click OK on the variable editor dialog.
	__12.  Click OK on the Environment Variables dialog.
	__13.  Click OK in the System Properties dialog.
	__14.  Open a command prompt window (in the start menu, click All Programs --> Accessories --> DOS Prompt.
	__15.  In the command window, type:
	__16.  You should see output similar to:
	Part 2 -  Setup Maven in Eclipse
	__1.  Use Windows Explorer to navigate to C:\Software\eclipse, and then double-click on 'eclipse.exe' to start up the IDE.
	__2.  You may see a security dialog.  If so, un-check the box for “Always ask before opening this file” and then click Run.
	__3.  Change the workspace to C:\Workspace and click OK.
	__4.  Eclipse Kepler will start launching.
	__5.  Close the Welcome screen by clicking the 'X' next to Welcome on the tab.
	__6.  From the main menu, select Window → Preferences and then expand the tree node for Maven.
	__7.  Click on the tree node for Installations.
	__8.  On the right-hand side of the Preferences window, click on the Add... button.
	__9.  Navigate to C:\Software\apache-maven-3.3.9, ensure the node is selected, and click OK.
	__10.  In the Preferences dialog, verify Maven path and click OK.
	__11.  From the main menu, select Window → Preferences and then expand the tree node for Java → Installed JREs.
	__12.  Select the jdk in the list and click Edit.
	__13.  Enter -Dmaven.multiModuleProjectDirectory=$M2_HOME as Default VM arguments.
	__14.  Click Finish.
	__15.  Click OK.
	__16.  Close all open windows.

	Part 3 -  Review

	Lab 3 -  Create a Maven Project
	Part 1 -  Create a Project
	__1.  If necessary, start eclipse from C:\Software\eclipse\eclipse.exe using the same workspace.
	__2.  From the main menu, select File →  New →  Maven Project
	__3.  Click the check box for “Create a simple project (skip archetype selection)”, and then click Next.
	__4.  We need to provide the so-called “Maven Coordinates” that will identify the artifacts produced by this project, and optionally a name and description for the project.  Enter the following fields:
	__5.  Leave the Version and Packaging fields at their default values.  Leave the Parent Project fields empty.  
	__6.  The dialog should look like:
	__7.  Click Finish.  The system will create the project we've asked for.

	Part 2 -  Explore the Project Structure
	__1.  In the Project Explorer, expand the node for the hello-world project.
	__2.  Notice that the IDE has created folders named “src/main/java”, “src/main/resources”, “src/test/java”, “src/test/resources”, and “target”.  This structure for the project folder is Maven's default structure.  All the inputs to the build process are stored under the “src” hierarchy, and all the outputs are under the “target” hierarchy.  This structure will be the same for any Maven project.
	__3.  Double-click “pom.xml” to open it in the Project Object Model editor.  At the bottom of the editor, you should see a number of tab labels, with the Overview tab currently selected.
	__4.  This view shows us the Maven Project Object Model and lets us edit it in a user-friendly fashion.  You can see the coordinates that we entered when we created the project.
	__5.  Click on the pom.xml tab.  This view displays the raw XML formatted text of the Project Object Model.  At the present time, all we really have is the project coordinates.
	__6.  Click on the Effective POM tab.  This view shows the results of combining the projects POM with the “Super-POM” that is built into Maven.  If you scroll down through the effective POM, you'll see the defaults for the various plugin configurations that are built into Maven, as well as the required locations for things like resources, output directories, etc.
	__7.  Click on the Dependencies tab.  This view shows what libraries are referenced from this project.  Right now, the project doesn't reference any dependencies.  In the next step, we'll change that to add a dependency on the JUnit test framework.
	__8.  Click on the Add... button underneath Dependencies
	__9.  In the field marked Enter groupId,..., type 'junit'.  After a second or two, the Search Results box will populate with a link to the “junit” library.  Expand the node for junit.
	__10.  When we clicked on the junit node, the Group Id, Artifact Id, and Version fields were automatically filled in.  However, we'd like to use a newer version of JUnit.  What's happened is that the search box has searched our local repository (<HOME>\.m2\repository) for possible matches.  JUnit 3.1.1 is already there, because some component of Maven or m2eclipse depends on it.  We can override the version even though the version we want is not currently in the local repository – Maven will go get it when we do the build.
	__11.  In the Version field, enter '4.11'.  (typically we would discover the current version through an internet search, or by querying Maven Central at http://search.maven.org)
	__12.  In the Scope drop-down box, select test. When the dialog looks similar to the following, click OK.

	Part 3 -  Perform a “Priming” Build
	__1.  In the Project Explorer, right-click on pom.xml and then select Run As →  Maven Build.  
	__2.  The system will display the Edit Configuration dialog. Since this is the first time we've run a Maven build, we need to specify what goal we want to build.  In the Goals field, enter 'install', and then click Run
	__3.  The system may display a Save Resource dialog.  If so, click Yes to save any changes that we've made.
	__4.  If you watch the console, you'll probably see quite a lot of “Downloading...” messages, and finally an indication of “Build Success”.

	Part 4 -  Add Some Code
	__1.  In the Project Explorer, right-click on src/main/java and select New →   Class.
	__2.  Enter a Package of “com.mycom.demo” and “HelloWorld” for the class name, and then click Finish.
	__3.  Edit the new class to include the main(...) method shown below.
	__4.  Save the file by clicking File →  Save or by typing Ctrl-S.  At this point, you could run the file by right-clicking and selecting Run As →  Java Application, but we don't really need to.
	__5.  In the Project Explorer, right-click on pom.xml and select Run As →  Maven build.  
	__6.  In the Project Explorer, right-click on the target node and then select Refresh.
	__7.  Expand the target node. You should now see the jar file that is generated by the project – this is the standard Maven output for a packaging type of 'jar'.
	__8.  From the menu, select File → Close All. 

	Part 5 -  Review

	Lab 4 -  Create a Web Application from an Archetype
	Part 1 -  Create the Project
	__1.  Make sure that Eclipse is running.  If not, start it by double-clicking on the “Eclipse.exe” entry in “C:\Software\Eclipse”.
	__2.  In the main menu, select File →  New →  Maven Project.
	__3.  The system will display the New Maven Project dialog.  Ensure that the box marked Create a simple project (skip archetype selection) is un-checked, and click Next.
	__4.  In the Filter field, enter 'webapp'.  
	__5.  The set of archetypes will be narrowed down to the ones that include the word 'webapp' in the archetype name.  Click on the row with Artifact Id as 'maven-archetype-webapp', and then click Next.
	__6.  Enter 'com.mycom.demo' as Group Id.
	__7.  In the Artifact Id field, enter 'mywebapp'
	__8.  Verify the Package is updated to com.mycom.demo.mywebapp or do it manually.
	__9.  Click Finish.
	__10.  After a few seconds, the Project Explorer will show the new project.  Expand the node for mywebapp, and then expand the src → main → webapp node.
	__11.  Notice that the folder structure includes the structure of a standard web application, including a WEB-INF directory.  If you want, expand the WEB-INF folder to see that there is a web.xml file in it.
	__12.  Right-click on the src →  main node in the Project Explorer and then select New →  Folder.  
	__13.  Enter 'java' as the folder name and then click Finish.
	__14.  In the Project Explorer, right-click on mywebapp, and then select Maven →  Update Project..., and then click OK.

	Part 2 -  Create a “Hello World” Servlet
	__1.  Expand the Project Explorer node for Java Resources, to expose the node for src/main/java.
	__2.  Right-click on the src/main/java node and then select New → Other.
	__3.  Expand Web from the list, select Servlet and then click Next.
	__4.  Enter the following in the Create Servlet dialog:
	__5.  Click Finish.
	__6.  Double-click on pom.xml in the Project Explorer to open it.
	__7.  Click on the Dependencies tab.
	__8.  Click on  the Add... button under Dependencies.
	__9.  Enter the following values:
	__10.  Select provided in the Scope drop-down.
	__11.  When the dialog appears as follows, click OK
	__12.  Save the file by pressing Ctrl-S or using File → Save from the main menu.
	__13.  Close the pom.xml file.
	__14.  You should see the resolution errors in HelloServlet.java disappear.  If not, execute the install phase of the Maven build, so as to trigger Maven to load the servlet API to the local repository.
	__15.  Let's put some code into the HelloServlet.java servlet, so we can run it.  Edit the doGet(...) method so it looks like:
	__16.  Press Ctrl-Shift-O to organize the imports.
	__17.  Save the file.
	__18.  Right-click on pom.xml in the Project Explorer and select Run As → Maven install.  
	__19.  You should see the build end with Build Success.

	Part 3 -  Test the Web Application
	__1.  Open the file pom.xml
	__2.  Click on the tab marked pom.xml tab to select the XML source.
	__3.  Near the bottom of the file, edit the <build> element so it appears as follows (the text to be added is shown in bold):
	__4.  Save the file.
	__5.  Right-click on pom.xml in the Project Explorer, and then select Run As →  Maven Build....  (Note the '...'  We need to create a new run configuration).
	__6.  Under Goals enter tomcat6:run and then click Run.
	__7.  Watch the Console view.  You may need to give access to continue. You will probably see a flurry of file downloads as Maven gets the Tomcat plugin from Maven Central.  In the end, the console will say:
	__8.  Open a web browser and enter:
	__9.  In the Console view, click on the red 'stop' button to stop the Maven build that is running the Tomcat server.

	Part 4 -  Install and Run Apache Tomcat
	__1.  Select the Servers tab.
	__2.  Right-click in the Servers view and select New → Server
	__3.  The system will show the New Server dialog.  Expand the Apache node and select Tomcat v6.0 Server and then click Next.
	__4.  Click on the Browse... button and navigate to 'C:\Software\apache-tomcat-6.0.37', and then click OK.
	__5.  Click Finish.
	__6.  The server will be added.
	__7.  Right click the server and select Open.
	__8.  Expand Ports section.
	__9.  Change the HTTP/1.1 port to 8085
	__10.  Save and close the Server window.
	__11.  In the Project Explorer, find the node for HelloServlet.java
	__12.  Right-click on HelloServlet.java and then select Run As → Run on Server.  When the Run On Server dialog is displayed, click Finish.
	__13.  Windows may show a security alert dialog.  If it does, click on Allow Access.
	__14.  The system will open a web browser inside Eclipse and show the selected page.
	__15.  In the Servers view, right-click on the Tomcat node and select Stop.
	__16.  From the menu, select File → Close All.

	Part 5 -  Review

	Lab 5 -  Add Web Site, Static Analysis, and Code Coverage 
	Part 1 -  Generate the Web Site
	__1.  Open a Command window by clicking the Start Menu →  All Programs →  Accessories →  Command Prompt.
	__2.  Change directory to the project's home directory.  In this case, the project is inside Eclipse's workspace, so we can enter (your typing is in bold.  Note that the prompt may appear different on your machine):
	__3.  From here, run the 'site' goal from the command line.
	__4.  Wait until you see BUILD SUCCESS
	__5.  Now if you navigate (using Windows Explorer) to the 'target' directory under the project directory (in this case 'C:\Workspace\hello-world\target', you will find a new directory called 'site'.  Navigate to the 'site' directory and double-click on index.html.  The system will open a web browser window and display the project's web site.
	__6.  While you're there, you can also explore the webpage.  Basically it lists all the information that's in the POM.
	__7.  Go back to Eclipse, and expand the src node in the Project Explorer under the hello-world project.  
	__8.  Right-click on src and then select New →  Folder.
	__9.  In the New Folder dialog, enter site as the folder name, and then click Finish.
	__10.  Using the same technique as above, create a folder under src/site called markdown
	__11.  Right-click on the src/site/markdown node and select New →  File.  
	__12.  Enter 'index.md' as the file name.
	__13.  Enter the following text into the new file:
	__14.  Save the file.
	__15.  Back in the Command Prompt window, execute mvn site again.
	__16.  Go back to the browser and hit the refresh button.
	__17.  Note that the 'About' page now looks like this:

	Part 2 -  Add Static Analysis
	__1.  Using Windows Explorer, navigate to C:\LabFiles\AddStaticAnalysis.
	__2.  Right-click on the file 'ExpressionParser.java' and then select Copy.
	__3.  In the Project Explorer in Eclipse, right-click on the node for 'com.mycom.demo' underneath 'src/main/java', and then select Paste.
	__4.  Right-click on the node for 'src/test/java' in the Project Explorer, and then choose New →  Package. 
	__5.  Enter 'com.mycom.demo' as the package name, and then click Finish.
	__6.  Now go back to the Windows Explorer.  Right-click 'TestExpressionParser.java' and then choose Copy.
	__7.  In the Project Explorer, paste the file into the 'com.mycom.demo' package underneath 'src/test/java'.
	__8.  Run a “Maven install” on the hello-world project (Right-click on the 'hello-world' project, and then choose 'Run As →  Maven install').
	__9.  You should note that in addition to the build output we've seen so far, there is also a section that reports unit test results, you may need to scroll up in the Console.
	__10.  Now we can configure the PMD plugin.  Open the 'pom.xml' file for the 'hello-world' project.
	__11.  Insert the following text underneath the </dependencies> tag:
	__12.  Save the pom.xml file.
	__13.  As in the previous part, run 'mvn site' from the Command Prompt and look at the generated site in your browser.
	__14.  Refresh the page and click on Project Information  link at the left menu.
	__15.  You will now see a 'Project Reports' section in the generated site (last in the menu), click on it.
	__16.  You can browse at the PMD Report and CPD Report.  In this case, PMD has reported that we have an unused private field in 'ExpressionParser.java'.

	Part 3 -  Add Code Coverage Report
	__1.  Open the 'pom.xml' file for 'hello-world' if necessary.
	__2.  Add the following lines inside the plugins element in the reporting section (add the code that is bold).
	__3.  Just like before, save the 'pom.xml' file, run 'mvn site', and refresh the browser. 
	__4.  You should now find a 'Cobertura Test Coverage' report in the 'Project Reports' section. 
	__5.  Click on Cobertura Test Coverage, then click on the package link for 'com.mycom.demo'.  The report should look something like this:
	__6.  Click on the ExpressionParser class link.  The report will show a line-by-line report of the test coverage for ExpressionParser.
	__7.  Back in Eclipse, from the menu, select File -> Close All. 

	Part 4 -  Review

	Lab 6 -  Create a Jenkins Job
	Part 1 -  Enable Jenkins' Maven Plugin
	__1.  Go to the Jenkins console:
	__2.  Click on the Manage Jenkins link
	__3.  Click on Manage Plugins
	__4.  Click on the Available tab.
	__5.  In the filter box at the top-right of the window, enter 'maven'. Note: Don't hit Return!
	__6.  Entering the filter text will narrow down the available plugins a little.  Scroll down to find the 'Maven Integration Plugin' listing, and click on the checkbox next to it.
	__7.  Click on Install Without Restart.
	__8.  Click on Go back to the top page.

	Part 2 -  Create a Git Repository
	__1.  Open to the folder C:\LabFiles\Create A Jenkins Job\SimpleGreeting.
	__2.  Right click in the empty area and select Git Bash Here.  The Git command prompt will open.
	__3.  Enter the following command:
	__4.  Enter the following lines.  Press enter after each line:
	__5.  Enter the following lines to actually create the Git repository:
	__6.  Enter the following, to create a folder called repos under the C:\Software folder.  
	__7.  Enter the following to clone the current Git repository into a new remote repository.

	Part 3 -  Configure Git
	__1.  Go to Jenkins home.
	__2.  Click Manage Jenkins.
	__3.  Click Global Tool Configuration.
	__4.  Scroll to the Git section.
	__5.  Enter C:\Program Files\Git\bin\git.exe as Path to Git executable.
	__6.  Click Save.

	Part 4 -  Create the Jenkins Job
	__1.  Go to the Jenkins home.
	__2.  Click on the New Item link.
	__3.  Enter SimpleGreeting for the project name.
	__4.  Select Maven Project as the project type.
	__5.  Click OK, to add a new job.
	__6.  Scroll down to the Source Code Management section and then select Git.
	__7.  Under Repositories, enter C:\Software\repos\SimpleGreeting.git
	__8.  Click the Tab key in your keyboard. 
	__9.  Click Save.
	__10.  You will see the Job screen. Click Workspace.
	__11.  Click Build Now. 
	__12.  After a few seconds the build will complete, the progress bar will stop. Click on Workspace.
	__13.  Find the Build History box, and click on the 'time' value for the most recent build. You should see that the build was successful.
	__14.  Click the Console Output from the left menu.
	__15.  At the end of the console you will also see the build success and successful build finish.

	Part 5 -  Enable Polling on the Repository
	__1.  In the Jenkins web application, navigate to the SimpleGreeting project.  You can probably find the project in the breadcrumb trail near the top of the window.  Alternately, go to the Jenkins home page and then click on the project.
	__2.  Click the Configure link.
	__3.  Scroll down to find the Build Triggers section.
	__4.  Click on the checkbox next to Poll SCM, and then enter '* * * * *' into the Schedule text box. [Make sure there is a space between each *] 
	__5.  Click Save.

	Part 6 -  Import the Project into Eclipse
	__1.  If eclipse was closed then start Eclipse by  running C:\Software\eclipse\eclipse.exe and use C:\Workspace as Workspace. 
	__2.  From the main menu, select File → Import...
	__3.  Select Git →  Projects from Git.
	__4.  Click Next.
	__5.  Select Clone URI and then click Next.
	__6.  Click on Local File... and then navigate to C:\Software\repos\SimpleGreeting.git
	__7.  Click OK.
	__8.  Back in the Import Projects dialog, click Next.
	__9.  Click Next to accept the default 'master' branch.
	__10.  In the Local Destination pane, leave the defaults and click Next.
	__11.  Select Import as a General Project and click Next.
	__12.  Click Finish.
	__13.  You should see the new project in the Project Explorer, expand it.
	__14.  Right-click on the SimpleGreeting project in the Project Explorer, and then select Configure →  Convert to Maven Project.
	__15.  After few seconds, you should now see the project represented as a Maven project in the Project Explorer.

	Part 7 -  Make Changes and Trigger a Build
	__1.  In the Project Explorer, expand the src/main/java tree node.
	__2.  Expand the com.simple package to reveal the Greeting.java file.
	__3.  Double-click on Greeting.java to open the file.
	__4.  Find the line that says 'return "GOOD";'.  Edit the line to read 'return "BAD";'
	__5.  Save the file by pressing Ctrl-S or selecting File →  Save.
	__6.  Right-click on SimpleGreeting in the Project Explorer and then select Team →  Commit...
	__7.  Enter a few words as a commit message, and then click Commit and Push.
	__8.  Click OK in the status dialog that pops up.
	__9.  Now, flip back to the web browser window that we had Jenkins running in.  If you happen to have closed it, open a new browser window and navigate to http://localhost:8080/SimpleGreeting.  After a few seconds, you should see a new build start up.
	__10.  If you refresh the page, you should see that there is now a 'Test Result Trend' graph that shows we have a new test failure.

	Part 8 -  Fix the Unit Test Failure
	__1.  Back in eclipse , edit the file Greeting.java so that the class once again returns 'GOOD'.
	__2.  As above, save, commit and push the change.
	__3.  Watch the Jenkins web browser window.  After a minute or two you should see the build start automatically, when the build is done then refresh the page.
	__4.  Close all.

	Part 9 -  Review

	Lab 7 -  A Multi-Module Project
	Part 1 -  Create a multi-module project
	__1.  Open the eclipse if it's not opened from C:\Software\eclipse\eclipse.exe and then choose the workspace location as C:\workspace. 
	__2.  From the menu, select Window → Open Perspective → Other.
	__3.  Select Java and click OK. 
	__4.  Create a general project, from the menu select, File → New → Project.
	__5.  Choose Project under General tab and click Next.
	__6.  Enter SimpleParentProject for project name.
	__7.  Click Finish.
	A general project is created. Now let's put the pom.xml for this project.
	__8.  Right click SimpleParentProject and select New → File.
	__9.  Enter pom.xml for file name and click Finish.
	__10.  File opens, at the bottom of the file select pom.xml.
	This file is already available. We will copy the content.
	__11.  Open C:\LabFiles\A Multi-Module Project\SimpleParentProject\SimpleParentProject-pom.xml file using a text editor.
	__12.  Copy the content and then paste it to the pom.xml file you created in the eclipse.
	Go through the pom.xml, 2 main element you should notice, <packaging> is set to pom since it consists of a pom.xml file but no artifact and <module> is set to SimpleProject. Meaning there will be a sub-module called SimpleProject exists to process.
	__13.  Save the file.
	__14.  Right-Click SimpleParentProject, and create a folder called SimpleProject to represent the parent project.
	__15.  Create a pom.xml file within SimpleProject folder.
	__16.  Copy the entire content of C:\LabFiles\A Multi-Module Project\SimpleParentProject\SimpleProject-pom.txt file into pom.xml. Make sure you select the right file.
	Notes: 
	__17.  Create a folder inside SimpleProject called simple-delay
	__18.  Copy the src folder from C:\LabFiles\A Multi-Module Project\SimpleParentProject\simple-delay into simple-delay folder in the eclipse.
	__19.  Also copy the C:\LabFiles\A Multi-Module Project\SimpleParentProject\simple-delay\pom.xml file to the simple-delay folder in the eclipse.
	__20.  Open the file and save the file to make sure you can edit in the file. 
	__21.  The project structure in the eclipse should be as shown below:
	Now lets work on simple-webapp module:
	__22.  Create a folder inside SimpleProject called simple-webapp
	__23.  Copy the src folder from C:\LabFiles\A Multi-Module Project\SimpleParentProject\simple-webapp into simple-webapp folder in the eclipse.
	__24.  Also copy the pom.xml file from C:\LabFiles\A Multi-Module Project\SimpleParentProject\simple-webapp folder and put it in simple-webapp folder in the eclipse.
	__25.  The project structure for simple-webapp in the eclipse should be as shown below:
	We have just completed the multi-module maven project. Lets run the package. 
	__26.  Open a command prompt and change the directory to C:\workspace\SimpleParentProject.
	__27.  Run the following command:
	__28.  See the console output as below:
	__29.  Run the following command:
	__30.  You would see the a successful built in the console output.
	__31.  Scroll up a locate the following messages.
	__32.  Refresh the eclipse root directory, you would see the generated artifacts:
	You can try this build using jenkins by importing the project to SVN and then configure the jenkins to get the root pom.xml configured.
	__33.  From the menu, select File -> Close All. 

	Part 2 -  Review

	Lab 8 -  Create a Standard Set of Dependencies
	Part 1 -  Define dependency
	__1.  Make sure eclipse is open.
	__2.  Open a browser and locate the folder C:\LabFiles\Create a Standard Set of Dependencies\SimpleGreeting. 
	__3.  Copy the SimpleGreeting folder into C:\Workspace.
	__4.  Rename C:\Workspace\SimpleGreeting as C:\Workspace\SimpleGreeting2.
	__5.  In eclipse, from the menu select File → Import. 
	__6.  Expand General, select Existing Projects into Workspace and click Next.
	
	__7.  Click browse button beside “Select root directory”.
	__8.  Select the project folder C:\Workspace\SimpleGreeting2.
	__9.  Click Finish.
	__10.  Expand the SimpleGreeting2 project and open Log4JGreeting.java file.
	You would see that Log4J standard library has been used in this class, that means when this file get compiled correct Log4J jar file is needed. We will now configure the pom to get the jar using dependency element.
	__11.  Open pom file from the SimpleGreeting project and select the pom.xml tab.
	__12.  Enter an empty line after the first dependency and add the log4J dependency (maven coordinates) shown below:
	This means, It will download the log4j version 1.2.14 library automatically. If the “version” tag is ignored, it will upgrade the library automatically when there is a newer version.
	__13.  Save the file.
	__14.  Dependencies element should be as shown below:
	__15.  Open command prompt and change the folder to C:\Workspace\SimpleGreeting2.
	__16.  Run the command:
	__17.  You will see a BUILD success message, scroll up and locate the messages where log4j library were downloaded during the command.
	Search log4j in Maven local repository.
	Search log4j in Maven central repository.
	Search log4j in Maven remote repository (if defined in pom.xml).
	__18.  Close the command prompt window used in this lab.
	__19.  In eclipse, from the menu, select File -> Close All. 

	Part 2 -  Review

	Lab 9 -  Write a Simple  Maven Plugin
	Part 1 -  Add Maven JavaDoc Plugin
	__1.  Make sure eclipse is open.
	__2.  Open a browser and locate the folder C:\LabFiles\Write a Simple  Maven Plugin\SimpleGreetingPlugin. 
	__3.  Copy the SimpleGreetingPlugin folder into C:\Workspace.
	__4.  From the menu, select File → Import... 
	__5.  Expand General select Existing Projects and click Next.
	__6.  Click browse button beside “Select root directory”.
	__7.  Select C:\Workspace\SimpleGreetingPlugin
	__8.  Click Finish.
	__9.  Expand the SimpleGreetingPlugin project and open Log4JGreeting.java and Greeting.java file. 
	Next we will configure plug-in to generate java doc.
	__10.  Open the pom.xml file from the SimpleGreetingPlugin project.
	__11.  Enter an empty line after the first <plugin> and add the  java doc plug-in (maven coordinates) shown below:
	__12.  Save pom file.

	Part 2 -  Build and Deploy
	__1.  Open command prompt.
	__2.  Change the folder to C:\workspace\SimpleGreetingPlugin
	__3.  Run the command:
	__4.  Look at the console output:
	Java doc JAR is generated.
	Look further down on the console output:
	__5.  Refresh your project in eclipse.
	__6.  Expand the project, you would see there are 2 JAR files and java doc folder also created:

	Part 3 -  Creating a project
	The first step is to create the project containing the custom maven plugin. This project is quite different from the regular java project because it is not a regular java artifact like JAR, WAR etc. Instead it is going to be a maven plugin project.
	__1.  In the command prompt, change the directory to “C:\Workspace”.
	__2.  Run the following command to create the maven plugin project.
	mvn archetype:generate -DgroupId=com.simple -DartifactId=SimpleDatePlugin -DarchetypeArtifactId=maven-archetype-mojo
	__3.  Hit Enter any time the prompt request for an input.
	The build should complete successfully.
	The above command creates a project with the name SimpleDatePlugin with the standard directory layout containing the source. 
	__4.  Using a File browser expand  C:\workspace\SimpleDatePlugin
	__5.  With notepad open the pom.xml file created under  C:\workspace\SimpleDatePlugin\
	If you look into the POM file, the package type is maven-plugin to indicate that this is a maven plugin project.
	__6.  Close the file.
	__7.  Change the directory on the command prompt window to "C:\workspace\SimpleDatePlugin".
	__8.  Run the following command to make it eclipse project which creates the Eclipse .project and .classpath files so that we can open it in the eclipse.
	__9.  You should get the success build:
	__10.  In eclipse, from the menu, select File → Import...  Expand General select Existing Projects and click Next.
	__11.  Click browse button beside “Select root directory”. Select C:\Workspace\SimpleDatePlugin and click Finish.
	__12.  In the Package Explorer view, the project should look like as below:

	Part 4 -  Creating a plugin
	In Maven, the plugin that achieves a specific task is called by the name MOJO (Maven Old Java Object similar to POJO). A MOJO defines the goal which is nothing but the custom action which is executed upon user’s request.
	We will create a custom plugin which will simply display the current date information.
	__1.  Right click SimpleDatePlugin and select New → class. 
	__2.  Enter DisplayCurrentDate for the class name.
	__3.  Enter com.simple for  package name.
	__4.  Enter org.apache.maven.plugin.AbstractMojo for Super class.
	__5.  Click Finish.
	__6.  Annotate the following java doc comments just above the class name:
	__7.  Enter the following code in the execute() method.
	__8.  Enter “Ctrl+Shift+O” to import packages.
	__9.  If  prompt for the package to choose, select java.util.Date.
	__10.  Save the file.
	__11.  The source code should be as shown below:

	Part 5 -  Compiling the project
	__1.  First make sure you are at the following directory on the command prompt:
	"C:\workspace\SimpleDatePlugin"
	__2.  Run the following command for compiling the maven plugin project which will compile the java classes.
	__3.  If you are not compiling the first time then you will get Nothing to compile message as shown below:

	Part 6 -  Packaging the project
	__1.  Enter the following command to package the plugin project which will package the classes into jar.
	The plugin class is packaged into JAR.

	Part 7 -  Installing the project
	__1.  To install the project into the local Maven repository, issue the following command.
	__2.  Go to your  maven local repository directory to check the plugin install at local repository.
	There are several ways to run the maven plugin. 

	Part 8 -  Run plugin in stand-alone mode
	__1.  Enter the following command:

	Part 9 -  Add Maven Plugin to Build Process
	__1.  In the eclipse, open the pom file of the SimpleGreetingPlugin project.
	__2.  Add the following plugin above </plugins> element which is inside the <build> element:
	__3.  Save the file.
	__4.  On the command prompt, change the directory to C:\workspace\SimpleGreetingPlugin
	__5.  Run the command.
	__6.  Your console should show the goal executed during compile phase as shown below:
	__7.  You have successfully create and build custom plugin. You can try configuring this to execute on maven install process and make the Jenkins work as well.
	__8.  Close the command prompt window used in this lab.
	__9.  In eclipse, from the menu, select File →  Close All. 

	Part 10 -  Review

	Lab 10 -  Create an Archetype
	Part 1 -  Create your skeleton project
	__1.   Back in the Eclipse Package Explorer view, find the SimpleParentProject as shown below:
	__2.  Open pom.xml
	__3.  Add the following code below the closing </project>.
	__4.  Save and close the file.
	__5.  Using command prompt, change the directory to  C:\workspace\SimpleParentProject.
	__6.  Run the following target to create the project.
	__7.  Back in the eclipse, refresh the project folder, you would see the archetype.

	Part 2 -   Install the archetype locally
	__1.  In the prompt, change the directory to C:\workspace\SimpleParentProject\target\generated-sources\archetype
	__2.  Run the following command to install.
	__3.  You should see the following console output as shown below:
	__4.  Now let's go to user's .m2 directory and look for  archetype-catalog.xml. Remember the users directory on Windows Vista/7 is under C:\Users\<username>\.m2
	__5.  Open the file using an editor.
	__6.  Close the file.

	Part 3 -  Create New project from Newly created Archetype
	__1.  Create a folder called test-archetype in the C:\LabFiles folder.
	__2.  Change the directory to  test-archetype as shown below: 
	__3.  Run the following command:
	__4.  Select 1 to create the com.simple.multi:parent-archetype(parent-archetype) project.
	__5.  Enter:
	__6.   Enter:
	__7.  Enter: 
	__8.  Enter:
	__9.  Enter Y to complete the task.
	__10.  Change the directory as follows:
	__11.  Run this command to make it eclipse project.
	Build is successful, now we can import the project into eclipse and check the structure of the project to make sure it is from template. 
	__12.  In eclipse, from the menu, select File → Switch Workspace → Other.
	__13.  Enter  C:\workspace_temp and click OK.
	__14.  Wait until starts and then close the Welcome page.
	__15.  From the menu select, File → Import … then expand General and select Existing Project into workspace and click Next.
	__16.  Click the Browse  button next to Select root directory and navigate to C:\LabFiles\maven-archetype-test folder.
	
	__17.  Click Finish.
	__18.  You would see that the structure is similar in the other workspace location.
	__19.  Close the command prompt used in this lab and all open files.
	__20.  In eclipse, from the menu, select File → Switch Workspace → C:\workspace.
	__21.  Close all open files.

	Part 4 -  Review

	Lab 11 -  Create a Corporate Repository
	Part 1 -  Setup Maven Repository with Sonatype Nexus
	__1.   To start nexus, Open a command prompt. 
	__2.  Change the directory to:
	__3.  Make the start up as windows service by running following command:
	__4.  To start the nexus as windows service, enter:
	__5.  Navigate to the following URL using Mozilla browser: 

	Part 2 -  Creating a Test project
	__1.  Change the directory of your prompt to C:\workspace
	__2.  Run the following command to generate a new project using a maven archetype.
	__3.  Enter values  for the following questions:
	__4.  The Build should finish successfully, and the following console output is shown:
	__5.  To test the project creation, change the directory to testproject
	__6.  Run:
	__7.  Once all the tests pass the console should show like below.
	__8.  Copy settings.xml from  C:\LabFiles\Create a Corporate Repository put it into <User_Home>\.m2 folder. For windows XP, “C:\Documents and Settings\<username>\.m2” In Windows Vista/7 use “C:\Users\<username>\.m2”
	__9.  Using a file browser navigate to C:\Workspace\testproject.
	__10.  Open pom.xml using a file editor.
	__11.  Put <distributionManagement> element before <dependencies> element.
	__12.  Save and close the file.

	Part 3 -  Posting Snapshots to Nexus
	__1.  Make sure you are at C:\workspace\testproject directory in the prompt command window.
	__2.  To deploy the project to the Nexus repository, enter:
	__3.  The console output shows that the files were uploaded to repositories:

	Part 4 -  Verify Nexus repository
	__1.  Navigate to the following URL, using Mozilla browser:
	__2.  Click on the Repositories item on the left navigation. 
	__3.  Click Snapshots and you should be able to see the test project you just created above.
	__4.  Close the browser.
	__5.  Close the command prompt window used in this lab.

	Part 5 -  Review

	Lab 12 -  Deploy to the Corporate Repository
	Part 1 -  Creating a test project that depends on another project
	__1.  Open a command prompt window.
	__2.  Change the directory of your prompt to C:\workspace. 
	__3.  Run the following command to generate a new project using a maven archetype.
	__4.  Enter values  for the following questions:
	__5.  The Build should finish successfully, and the following console output is shown:
	__6.  To test the project creation, change the directory to:
	__7.  Run: 
	__8.  Once all the tests pass the console should show like below.
	__9.  Open C:\workspace\testReleaseProject\pom.xml using a text editor.
	__10.  Add the following dependency code:
	__11.  Put <distributionManagement> element before <dependencies> element.
	__12.  Save and close the file.
	__13.  Verify dependencies by entering the following on the command prompt.

	Part 2 -  Deploying to the Release Repository
	__1.  Open pom.xml at C:\workspace\testReleaseProject directory.
	__2.  Remove  “-SNAPSHOT” next to version.
	__3.  It should be like below:
	__4.  Save and close the file.
	__5.  To deploy the project to the Nexus repository, enter:
	__6.  The console output shows that the files were uploaded to release repositories:

	Part 3 -  Verify Nexus repository
	__1.  Navigate to the Nexus console using Mozilla browser.
	__2.  Click on the Repositories item on the left navigation.
	__3.  From the list click Releases. 
	__4.  You should be able to see the test release project you just created deployed here.
	__5.  Close the browser.
	__6.  Close the command prompt window used in this lab.

	Part 4 -  Review

	Lab 13 -  Add Development Metrics
	Part 1 -  Install the Jenkins Cobertura Plugin 
	__1.  Make sure Jenkins is started. Since we configured as windows service it will be started every time you start the machine.
	__2.  Go to the Jenkins console at: 
	__3.  Login as wasadmin for user/password if required.
	__4.  To install a new plugin, click Manage Jenkins on the left.
	__5.  Click on the Manage Plugins entry.
	__6.  Click on Available tab. 
	__7.  Type cobertura in the Filter and then check the check-box next to Cobertura Plugin.
	__8.  Click on the Download now and Install after restart button at the bottom of the screen.
	__9.  Select the checkbox for Restart Jenkins....
	__10.  At this point, Jenkins should restart itself. Wait some minutes if it doesn't return to the main screen do it manually
	__11.  If ask to login use wasadmin for user and password.

	Part 2 -  Enable Jenkins Reporting
	__1.  Click on the job we created for SimpleGreeting.
	__2.  On the left-hand menu, click Configure.
	__3.  Scroll down to the Post-Build Actions section.
	__4.  Click on the Add post-build action button and then select Publish Cobertura Coverage Report.
	__5.  Enter the following for the Cobertura XML Report Pattern.
	__6.  Scroll up to find the Build section.
	__7.  In the Goals and Options text box, enter the following:
	__8.  Click Save.
	__9.  Open Eclipse.  
	__10.  In the Project Explorer, navigate to the SimpleGreeting project.
	__11.  Double-click on the file pom.xml to open it.
	__12.  On the lower edge of the editor panel, click on pom.xml to select the XML view of the file.
	__13.  Add the text that is shown in bold text below (the 'plugin' and 'reporting' sections).
	__14.  Save and close the file.
	__15.  Right-click on SimpleGreeting in the Project Explorer and then select Team →  Commit...
	__16.  Enter a few words as a commit message, and click Commit and Push. Then click OK.
	__17.  Back in the Jenkins page, you should see a build launched within a minute or two.  If you don't see an automatic build, click the Build Now to kick off a manual build.
	__18.  Once the build is completed, move the mouse over the build number window and make check that it is successful:
	__19.  Now let's click on the Coverage Report.
	__20.  Close all.

	Part 3 -  Review

	Lab 14 -  Create a Pipeline
	Part 1 -  Create a Simple Pipeline
	__1.  To connect to Jenkins, open Firefox and enter the following URL:
	__2.  Click on the New Item link.
	__3.  Enter 'SimpleGreetingPipeline' as the new item name, and select 'Pipeline' as the item type.
	__4.  When the input looks as above, click on OK to create the new item.
	__5.  Scroll down to the Pipeline section and enter the following in the Script text window.
	__6.  Click on Save to save the changes and return to the project page.
	__7.  Click on Build Now to startup a pipeline instance.
	__8.  After a few moments, you should see the Stage View appear, and successive stages will appear as the build proceeds, until all three stages are completed.

	Part 2 -  Pipeline Definition in a 'Jenkinsfile'
	__1.  Open the Eclipse editor.  If this lab is completed in the normal sequence, you should have the 'SimpleGreeting' project already in Eclipse's workspace.  If not, check out the project from version control (consult your instructor for directions if necessary).
	__2.  In the Project Explorer, right-click on the root node of the SimpleGreeting project, and then select New →  File.  
	__3.  Enter 'Jenkinsfile' as the file name.
	__4.  Click Finish to create the new file.
	__5.  Enter the following text into the new file (Note: this is the same script that we used above, so you could copy/paste it from the Jenkins Web UI if you want to avoid some typing):
	__6.  Save the Jenkinsfile by selecting File →  Save from the main menu, or by hitting Ctrl-S.
	__7.  In the Project Explorer, right-click on the SimpleGreeting node, and then select Team →  Commit...
	__8.  Eclipse will display the Commit Changes dialog.  Click the checkbox next to Jenkinsfile (to include that file in the commit) and enter a commit message.
	__9.  Click Commit and Push, and then click OK to dismiss the status dialog.
	__10.  In the Jenkins user interface, navigate to the root page, and then click on New Item.
	__11.  Enter 'SimpleGreetingPipelineFromGit' as the name of the new item, and select Pipeline as the item type.
	__12.  Click OK to create the new item.
	__13.  Scroll down to the Build Triggers section.  
	__14.  Click on Poll SCM and enter '* * * * *' as the polling schedule.  This entry will cause Jenkins to poll once per minute.
	__15.  Scroll down to the Pipeline section, and change the Definition entry to 'Pipeline Script from SCM'
	__16.  Enter the following:
	__17.  The Pipeline section should look similar to:
	__18.  Click Save to save the new configuration.
	__19.  Click Build Now to launch the pipeline.
	__20.  You should see the pipeline execute, similar to the previous section.

	Part 3 -  Try out a Failing Build
	__1.  In Eclipse, go to the Project Explorer and locate the file 'Greeting.java'.  It will be under src/main/java in the package 'com.simple'.  Open 'Greeting.java'.
	__2.  Locate the line that reads 'return "GOOD";'.  Change it to read 'return "BAD";'
	__3.  Save the file.
	__4.  In the Project Explorer, right-click on Greeting.java and then select Team →  Commit... (This is a shortcut for committing a single file).
	__5.  Enter an appropriate commit message and then click Commit and Push.
	__6.  Click OK in the results box, to close it.
	__7.  Switch back to Jenkins.
	__8.  In a minute or so, you should see a build launched automatically.  Jenkins has picked up the change in the 'Git' repository and initiated a build. If nothing happens then click Build Now.
	__9.  Go back to Eclipse and open the 'Jenkinsfile' if necessary.
	__10.  Alter the 'bat "mvn..." line to read as follows:
	__11.  Save the 'Jenkinsfile'.  Commit and push the changes using the same technique as above.
	__12.  After a minute or so, you should see a new Pipeline instance launched.  If nothing happens then click Build Now.

	Part 4 -  Add a Manual Approval Step
	__1.  Go to 'Eclipse' and open the 'Jenkinsfile' if necessary.
	__2.  Add the following to the end of the file after the closing }:
	__3.  Save and commit 'Jenkinsfile' as previously.
	__4.  When the pipeline executes, watch for a "paused" stage called 'User Acceptance Test".  If you move your mouse over this step, you'll be able to select "Yes" or "No", and then click Proceed.
	__5.  Select Yes and click Proceed, you should see the job run to completion.
	__6.  If you run the pipeline again (click Build Now), but this time, select No on the 'User Acceptance Test', you'll see that the pipeline exits early and doesn't run the 'deploy' stage.
	__7.  Close all.
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