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Environment

In this course we will use the following VM images:

▪ WA2271_REL_6_0

▪ VM_WA2271

Maybe instead having a VM called WA2271_REL_6_0, you have the software 
installed directly on your computer, check with your instructor.
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Lab 1 - Configure Tools in Jenkins
In this lab you will verify that Jenkins Continuous Integration is already installed and you
will configure it.   

At the end of this lab you will be able to:

1. Verify Jenkins is running

2. Configure tools in Jenkins

Part 1 - Configure Jenkins

The following labs requires a VM named 'WA2271_REL_6_0', but maybe instead 
having this VM you have the software installed directly on your computer, check 
with your instructor.

Close other VMs if running and double-click the shortcut on the desktop to launch 
the VM. Use wasadmin for the user name and password. 

This Lab requires the internet connection to work. 

After Jenkins installation, you can configure few other settings to complete the 
installation before creating jobs.

__1. To connect to Jenkins, open Firefox and enter the following URL.

http://localhost:8080/

__2. Enter wasadmin as user and password and click Sign in.

__3. Don’t save the password if prompt or select Never Remember password for this site.
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__4. Click on the Manage Jenkins link.

__5. Click Global Tool Configuration.

__6. Scroll down and find the JDK section, Click Add JDK.

__7. Enter OracleJDK for JDK name.

__8. Uncheck the ‘Install automatically’ option.

__9. Enter JAVA_HOME value as:

C:\Program Files\Java\jdk-11.0.8

Note. You may need to use another path if Java was installed in a different folder like 
above, contact your instructor or search for the right path and use it as JAVA_HOME.

__10. Verify your settings look as below:
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__11. In the Maven section, click Add Maven.

__12. Enter Maven for Maven name.

__13. Uncheck the ‘Install automatically’ option.

__14. Enter the following parth for MAVEN_HOME. Make sure this folder is correct.

C:\Software\apache-maven-3.6.3

__15. Verify your settings look as below:

__16. Scroll and find Git, you may see an error regarding the git path. Enter the 
following path and then hit the tab key (Make sure the path is valid or find the right path):

C:\Program Files\Git\bin\git.exe

__17. Click Save.
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Part 2 - Review

In this lab you configured the Jenkins Continuous Integration Server.
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Lab 2 - Create a Jenkins Job
In this lab you will create and build a job in Jenkins. 

Jenkins supports several different types of build jobs. The two most commonly-used are 
the freestyle builds and the Maven 2/3 builds. The freestyle projects allow you to 
configure just about any sort of build job,  they are highly flexible and very configurable. 
The Maven 2/3 builds understand the Maven project structure, and can use this to let you 
set up Maven build jobs with less effort and a few extra features. 

At the end of this lab you will be able to:

1. Create a Jenkins Job that accesses a Git repository.

Part 1 - Enable Jenkins' Maven Plugin

__1. Go to the Jenkins console:

http://localhost:8080

__2. Login as wasadmin for user and password.

__3. Click on the Manage Jenkins link

__4. Ignore any message regarding an update.
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__5. Click on Manage Plugins

__6. Click on the Available tab.

__7. In the filter box at the top-right of the window, enter 'Maven Integration'. Note: 
Don't hit Return!

__8. Entering the filter text will narrow down the available plugins a little.  Scroll down 
to find the 'Maven Integration' listing, and click on the check box next to it.

__9. Click Install Without Restart.
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__10. Wait until finish installing the product and click Go back to the top page.

Part 2 - Create a Git Repository

As a distributed version control system, Git works by moving changes between different 
repositories.  Any repository apart from the one you're currently working in is called a 
"remote" repository.  Git doesn't differentiate between remote repositories that reside on 
different machines and remote repositories on the same machine.  They're all remote 
repositories as far as Git is concerned.  In this lab, we're going to start from a source tree, 
create a local repository in the source tree, and then clone it to a local repository.  Then 
we'll create a Jenkins job that pulls the source files from that remote repository.  Finally, 
we'll make some changes to the original files, commit them and push them to the 
repository, showing that Jenkins automatically picks up the changes.

__1. Open to the folder C:\LabFiles\Create A Jenkins Job\SimpleGreeting.
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__2. Right click in the empty area and select Git Bash Here.  The Git command prompt 
will open.

__3. Enter the following command:

ls

__4. Enter the following lines.  Press enter after each line:

git config --global user.email "wasadmin@webagesolutions.com"
git config --global user.name "Bob Smith"

The lines above are actually part of the initial configuration of Git.  Because of Git's 
distributed nature, the user's identity is included with every commit as part of the commit 
data.  So we have to tell Git who we are before we'll be able to commit any code.
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__5. Enter the following lines to actually create the Git repository:

git init
git add .
git commit -m "Initial Commit"

The above lines create a git repository in the current directory (which will be C:\
LabFiles\Create a Jenkins Job\SimpleGreeting), add all the files to the current commit
set (or 'index' in git parlance), then actually performs the commit.

__6. Enter the following, to create a folder called repos under the C:\Software folder.  

mkdir /c/Software/repos

__7. Enter the following to clone the current Git repository into a new remote repository.

git clone --bar . /c/Software/repos/SimpleGreeting.git

At this point, we have a "remote" Git repository in the folder C:\Software\repos\
SimpleGreeting.git. Jenkins will be quite happy to pull the source files for a job from 
this repo.
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Part 3 - Create the Jenkins Job

__1. Go to the Jenkins home.

__2. Click on the New Item link.

__3. Enter SimpleGreeting for the project name.

__4. Select Maven Project as the project type.

__5. Click OK, to add a new job.

After the job is created, you will be on the job configuration page.
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__6. Scroll down to the Source Code Management section and then select Git.

__7. Under Repositories, enter C:\Software\repos\SimpleGreeting.git and press tab key.

__8. Click Save.

__9. You will see the Job screen.

__10. From the left menu, click Build Now. 
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You should see the build in progress in the Build History area.

__11. After a few seconds the build will complete, the progress bar will stop. Click on 
Workspace.

You will see that the directory is populated with the source code for our project.

Copyright 2020 Web Age Solutions Inc. 15

EVALU
ATIO

N C
OPY



__12. Find the Build History box, and click on the 'time' value for the most recent build. 
You should see that the build was successful.

__13. Click the Console Output from the left menu.

__14. At the end of the console you will also see the build success and successful build 
finish.

You have created a project and built it successfully.

Part 4 - Enable Polling on the Repository

So far, we have created a Jenkins job that pulls a fresh copy of the source tree prior to 
building.  But we triggered the build manually.  In most cases, we would like to have the 
build triggered automatically whenever a developer makes changes to the source code in 
the version control system.
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__1. In the Jenkins web application, navigate to the SimpleGreeting project.  You can 
probably find the project in the breadcrumb trail near the top of the window.  Alternately, 
go to the Jenkins home page and then click on the project.

__2. Click the Configure link.

__3. Scroll down to find the Build Triggers section.

__4. Click on the check box next to Poll SCM, and then enter '* * * * *' into the 
Schedule text box. [Make sure there is a space between each *] 

Note: The above schedule sets up a poll every minute.  In a production scenario, that's a 
higher frequency than we need, and it can cause unnecessary load on the repository 
server and on the Jenkins server.  You'll probably want to use a more reasonable 
schedule - perhaps every 15 minutes.  That would be 'H/15 * * * *' in the schedule box.

__5. Click Save.

Part 5 - Import the Project into Eclipse

In order to make changes to the source code, we'll clone a copy of the Git repository into 
an Eclipse project.

__1. Start Eclipse by running C:\Software\eclipse\eclipse.exe 

__2. Enter C:\Workspace as Workspace and click Launch. 

__3. From the main menu, select File → Import...
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__4. Select Git →  Projects from Git.

__5. Click Next.

__6. Select Clone URI and then click Next.

You might think that 'Existing local repository' would be the right choice, since we're 
cloning from a folder on the same machine.  Eclipse, however, expects a "local 
repository" to be a working directory, not a bare repository.  On the other hand, Jenkins 
will complain if we try to get source code from a repository with a working copy.  So the 
correct thing is to have Jenkins pull from a bare repository, and use Clone URI to have 
Eclipse import the project from the bare repository.

__7. Click on Local File... and then navigate to C:\Software\repos\SimpleGreeting.git

__8. Click Select Folder.

__9. Back in the Import Projects dialog, verify folders are select as below and click 
Next.

__10. Click Next to accept the default 'master' branch.
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__11. In the Local Destination pane, leave the defaults and click Next.

__12. Select Import as a General Project and click Next.

__13. Click Finish.
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__14. You should see the new project in the Project Explorer, expand it.

At this point, we could go ahead and edit the files, but Eclipse doesn't understand the 
project's layout.  Let's tell Eclipse what we know - that this project is built using Apache 
Maven.

__15. Right-click on the SimpleGreeting project in the Project Explorer, and then 
select Configure →  Convert to Maven Project.

__16. After few seconds, you should now see the project represented as a Maven project 
in the Project Explorer.

Part 6 - Make Changes and Trigger a Build

The project that we used as a sample consists of a basic "Hello World" style application, 
and a unit test for that application.  In this section, we'll alter the core application so it 
fails the test, and then we'll see how that failure appears in Jenkins.
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__1. In the Project Explorer, expand the src/main/java > com.simple package to reveal 
the Greeting.java file.

__2. Double-click on Greeting.java to open the file.

__3. Find the line that says 'return "GOOD";'.  Edit the line to read 'return "BAD";'

__4. Save the file by pressing Ctrl-S or selecting File →  Save.

Now we've edited the local file.  The way Git works is that we'll first 'commit' the file to 
the local workspace repository, and then we'll 'push' the changes to the upstream 
repository.  That's the same repository that Jenkins is reading from.  Eclipse has a short-
cut button that will commit and push at the same time.

__5. Right-click on SimpleGreeting in the Project Explorer and then select Team →  
Commit...

__6. Enter a few words as a commit message, and then click Commit and Push.

__7. Click Close in the status dialog that pops up.
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__8. Now, flip back to the web browser window that we had Jenkins running in.  If you 
happen to have closed it, open a new browser window and navigate to 
http://localhost:8080/SimpleGreeting.  After a few seconds, you should see a new build
start up. You can launch a new build if it's taking too long.

__9. Refresh the page, you should see that there is now a 'Test Result Trend' graph that 
shows we have a new test failure.

__10. The build will failed too.

What happened is that we pushed the source code change to the Git repository that 
Jenkins is reading from.  Jenkins is continually polling the repository to look for changes.
When it saw that a new commit had been performed, Jenkins checked out a fresh copy of 
the source code and performed a build.  Since Maven automatically runs the unit tests as 
part of a build, the unit test was run.  It failed, and the failure results were logged.
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Part 7 - Fix the Unit Test Failure

__1. Back in eclipse, edit the file Greeting.java so that the class once again returns 
'GOOD'.

__2. As above, save, commit and push the change.

__3. Watch the Jenkins web browser window.  After a minute or two you should see the 
build start automatically or you can click Build now, when the build is done then refresh 
the page.

__4. Close all.

Part 8 - Review

In this lab you learned

• How to Set-up a set of distributed Git repositories

• How to create a Jenkins Job that reads from a Git repository

• How to configure Jenkins to build automatically on source code changes.

Copyright 2020 Web Age Solutions Inc. 23

EVALU
ATIO

N C
OPY


	WA2271_REL_6_0
	VM_WA2271
	Lab 1 - Configure Tools in Jenkins
	Part 1 - Configure Jenkins
	__1. To connect to Jenkins, open Firefox and enter the following URL.
	__2. Enter wasadmin as user and password and click Sign in.
	__3. Don’t save the password if prompt or select Never Remember password for this site.
	__4. Click on the Manage Jenkins link.
	__5. Click Global Tool Configuration.
	__6. Scroll down and find the JDK section, Click Add JDK.
	__7. Enter OracleJDK for JDK name.
	__8. Uncheck the ‘Install automatically’ option.
	__9. Enter JAVA_HOME value as:
	__10. Verify your settings look as below:
	__11. In the Maven section, click Add Maven.
	__12. Enter Maven for Maven name.
	__13. Uncheck the ‘Install automatically’ option.
	__14. Enter the following parth for MAVEN_HOME. Make sure this folder is correct.
	__15. Verify your settings look as below:
	__16. Scroll and find Git, you may see an error regarding the git path. Enter the following path and then hit the tab key (Make sure the path is valid or find the right path):
	__17. Click Save.

	Part 2 - Review

	Lab 2 - Create a Jenkins Job
	Part 1 - Enable Jenkins' Maven Plugin
	__1. Go to the Jenkins console:
	__2. Login as wasadmin for user and password.
	__3. Click on the Manage Jenkins link
	__4. Ignore any message regarding an update.
	__5. Click on Manage Plugins
	__6. Click on the Available tab.
	__7. In the filter box at the top-right of the window, enter 'Maven Integration'. Note: Don't hit Return!
	__8. Entering the filter text will narrow down the available plugins a little. Scroll down to find the 'Maven Integration' listing, and click on the check box next to it.
	__9. Click Install Without Restart.
	__10. Wait until finish installing the product and click Go back to the top page.

	Part 2 - Create a Git Repository
	__1. Open to the folder C:LabFilesCreate A Jenkins JobSimpleGreeting.
	__2. Right click in the empty area and select Git Bash Here. The Git command prompt will open.
	__3. Enter the following command:
	__4. Enter the following lines. Press enter after each line:
	__5. Enter the following lines to actually create the Git repository:
	__6. Enter the following, to create a folder called repos under the C:Software folder.
	__7. Enter the following to clone the current Git repository into a new remote repository.

	Part 3 - Create the Jenkins Job
	__1. Go to the Jenkins home.
	__2. Click on the New Item link.
	__3. Enter SimpleGreeting for the project name.
	__4. Select Maven Project as the project type.
	__5. Click OK, to add a new job.
	__6. Scroll down to the Source Code Management section and then select Git.
	__7. Under Repositories, enter C:SoftwarereposSimpleGreeting.git and press tab key.
	__8. Click Save.
	__9. You will see the Job screen.
	__10. From the left menu, click Build Now.
	__11. After a few seconds the build will complete, the progress bar will stop. Click on Workspace.
	__12. Find the Build History box, and click on the 'time' value for the most recent build. You should see that the build was successful.
	__13. Click the Console Output from the left menu.
	__14. At the end of the console you will also see the build success and successful build finish.

	Part 4 - Enable Polling on the Repository
	__1. In the Jenkins web application, navigate to the SimpleGreeting project. You can probably find the project in the breadcrumb trail near the top of the window. Alternately, go to the Jenkins home page and then click on the project.
	__2. Click the Configure link.
	__3. Scroll down to find the Build Triggers section.
	__4. Click on the check box next to Poll SCM, and then enter '* * * * *' into the Schedule text box. [Make sure there is a space between each *]
	__5. Click Save.

	Part 5 - Import the Project into Eclipse
	__1. Start Eclipse by running C:Softwareeclipseeclipse.exe
	__2. Enter C:Workspace as Workspace and click Launch.
	__3. From the main menu, select File → Import...
	__4. Select Git → Projects from Git.
	__5. Click Next.
	__6. Select Clone URI and then click Next.
	__7. Click on Local File... and then navigate to C:SoftwarereposSimpleGreeting.git
	__8. Click Select Folder.
	__9. Back in the Import Projects dialog, verify folders are select as below and click Next.
	__10. Click Next to accept the default 'master' branch.
	__11. In the Local Destination pane, leave the defaults and click Next.
	__12. Select Import as a General Project and click Next.
	__13. Click Finish.
	__14. You should see the new project in the Project Explorer, expand it.
	__15. Right-click on the SimpleGreeting project in the Project Explorer, and then select Configure → Convert to Maven Project.
	__16. After few seconds, you should now see the project represented as a Maven project in the Project Explorer.

	Part 6 - Make Changes and Trigger a Build
	__1. In the Project Explorer, expand the src/main/java > com.simple package to reveal the Greeting.java file.
	__2. Double-click on Greeting.java to open the file.
	__3. Find the line that says 'return "GOOD";'. Edit the line to read 'return "BAD";'
	__4. Save the file by pressing Ctrl-S or selecting File → Save.
	__5. Right-click on SimpleGreeting in the Project Explorer and then select Team → Commit...
	__6. Enter a few words as a commit message, and then click Commit and Push.
	__7. Click Close in the status dialog that pops up.
	__8. Now, flip back to the web browser window that we had Jenkins running in. If you happen to have closed it, open a new browser window and navigate to http://localhost:8080/SimpleGreeting. After a few seconds, you should see a new build start up. You can launch a new build if it's taking too long.
	__9. Refresh the page, you should see that there is now a 'Test Result Trend' graph that shows we have a new test failure.
	__10. The build will failed too.

	Part 7 - Fix the Unit Test Failure
	__1. Back in eclipse, edit the file Greeting.java so that the class once again returns 'GOOD'.
	__2. As above, save, commit and push the change.
	__3. Watch the Jenkins web browser window. After a minute or two you should see the build start automatically or you can click Build now, when the build is done then refresh the page.
	__4. Close all.

	Part 8 - Review

	Lab 3 - Advanced Jobs
	Part 1 - Connect to Jenkins
	__1. To connect to Jenkins, open Chrome or Firefox and enter the following URL.
	__2. Enter wasadmin as user and password and click Log in.
	__3. Don’t save the password if prompt or select Never Remember password for this site.

	Part 2 - Create a new Maven Project-based Jenkins Job
	__1. On left side of the page, click New Item.
	__2. Enter "ParamTest", without quotes, in the Enter an item name text box.
	__3. Select Maven project as project type.
	__4. Click OK.
	__5. In the General tab, check the box in front of This project is parameterized.
	__6. Click Add Parameter.
	__7. Select String Parameter.
	__8. Enter the following values in the fields:
	__9. Click Add Parameter again.
	__10. Select Choice Parameter.
	__11. Enter the following values in the fields.
	__12. Click Apply button.
	__13. Scroll through the web page and navigate to Source Code Management section.
	__14. Select Git radio button.
	__15. In Repository URL, enter C:SoftwarereposSimpleGreeting.git
	__16. Press Tab.
	__17. Click Apply button.
	__18. Scroll through the page and locate Build section.
	__19. In Goals and options, enter install
	__20. Click Apply button.
	__21. Scroll through the page and locate Post Steps section.
	__22. Click Add post-build step.
	__23. Select Execute Windows batch command.
	__24. Enter the following command:
	__25. Click the Save button.

	Part 3 - Run and Test the Job
	__1. On the left side of the page, click Build with Parameters.
	__2. Enter the following parameter values:
	__3. Click the Build button.
	__4. While the build is running, click the drop down for the build and click Console Output.
	__5. Scroll through the console output and notice a message similar to this, near the end:
	__6. Open Windows Explorer and navigate to C:Software.
	__7. Delete C:SoftwareProduction directory.
	__8. In the web browser on the Jenkins page, click Jenkins to go back to the home page.

	Part 4 - Create a Multi-Configuration project
	__1. On the left side of the page, click New Item.
	__2. Enter "MultiConfigTest", without quotes, in the Enter an item name text box.
	__3. Select Multi-configuration project as the project type.
	__4. Click OK.
	__5. Scroll through the web page and navigate to the Source Code Management section.
	__6. Select the Git radio button.
	__7. In Repository URL, enter C:SoftwarereposSimpleGreeting.git
	__8. Press tab.
	__9. Click the Apply button.
	__10. Scroll through the page and locate the Configuration Matrix section.
	__11. Click Add axis and select User-defined axis.
	__12. Enter the following values in the fields:
	__13. Click Apply button.
	__14. Scroll through the page and locate the Build section.
	__15. Click Add build step and then click Invoke top-level Maven targets.
	__16. In Maven Version, select Maven (Note: You might have different name).
	__17. In Goals enter install
	__18. Click the Apply button.
	__19. Click the Save button.

	Part 5 - Run and Test the Multi-Configuration Project
	__1. On the left side of the page, click Build Now.
	__2. At the bottom of the page, notice that there are 3 entries showing up like this.
	__3. Wait for the build to complete for all configurations.
	__4. Using Windows Explorer, navigate to C:UserswasadminAppDataLocalJenkins.jenkinsworkspaceMultiConfigTest
	__5. Under the Environment directory, there are three sub-directories: Development, Production, Test.
	__6. Examine the contents of each directory.

	Part 6 - Review

	Lab 4 - Node.js based Jenkins Job
	Part 1 - Create a Jenkins job and add Node.js related steps to it
	__1. In the web browser, ensure you are on Jenkins web page.
	__2. Enter wasadmin as user and password and click Log in.
	__3. Click New Item link.
	__4. In Enter an item name enter NodeApp
	__5. Select Freestyle project.
	__6. Click OK.
	__7. Under Source Code Management, click the radio button for Git.
	__8. Enter 'C:LabFilesNodeApp.git' as the repository URL and press tab.
	__9. Scroll down the page and locate Build section.
	__10. Click Add build step and in the drop down, click Execute Windows batch command.
	__11. In the Command text box, enter following command:
	__12. Click Apply button.
	__13. In the Build section, click again Add build step and click Execute Windows batch command.
	__14. In the Command text box, enter following command (the two lines that start with '..node...' should be entered as one line in the text box).
	__15. In the Post-build Actions section, click Add post-build action and select Publish JUnit test result report.
	__16. In the Test report XMLs text box, enter following text.
	__17. Click Save button.
	__18. Click Build Now.
	__19. In Build History notice there's one entry with blue colored icon. Click it.
	__20. Click Console Output.
	__21. Click Test Result from the left menu.
	__22. Under All Tests click (root).
	__23. Click "returns a hello message".
	__24. Click "The message module returns a hello message" link.
	__25. In the web browser, click Back to Project.
	__26. Close all.

	Part 2 - Review

	Lab 5 - Create a Pipeline
	Part 1 - Create a Simple Pipeline
	__1. To connect to Jenkins, open a browser and enter the following URL:
	__2. Login as wasadmin for user/password.
	__3. Click on the New Item link.
	__4. Enter 'SimpleGreetingPipeline' as the new item name, and select 'Pipeline' as the item type.
	__5. When the input looks as above, click OK to create the new item.
	__6. Scroll down to the Pipeline section and enter the following in the Script text window.
	__7. Click on Save to save the changes and return to the project page.
	__8. Click on Build Now to start up a pipeline instance.
	__9. After a few moments, you should see the Stage View appear, and successive stages will appear as the build proceeds, until all three stages are completed.

	Part 2 - Pipeline Definition in a 'Jenkinsfile'
	__1. Open the Eclipse editor. If this lab is completed in the normal sequence, you should have the 'SimpleGreeting' project already in Eclipse's workspace.  If not, check out the project from version control (consult your instructor for directions if necessary).
	__2. In the Project Explorer, right-click on the root node of the SimpleGreeting project, and then select New → File.
	__3. Enter 'Jenkinsfile' as the file name.
	__4. Click Finish to create the new file.
	__5. You may get a message from Marketplace. Click Cancel to dismiss.
	__6. Enter the following text into the new file (Note: this is the same script that we used above, so you could copy/paste it from the Jenkins Web UI if you want to avoid some typing):
	__7. Save the Jenkinsfile by selecting File → Save from the main menu, or by hitting Ctrl-S.
	__8. In the Project Explorer, right-click on the project and then select Team → Commit...
	__9. Under Unstaged changes list, select Jenkinsfile and click the plus icon.
	__10. Jenkinsfile will be moved to the Staged changes section. Enter a commit message and click Commit and Push. Then click Close.
	__11. In the Jenkins user interface, navigate to the root page, and then click on New Item.
	__12. Enter 'SimpleGreetingPipelineFromGit' as the name of the new item, and select Pipeline as the item type and click OK to create the new item.
	__13. Scroll down to the Build Triggers section.
	__14. Click on Poll SCM and enter '* * * * *' as the polling schedule. This entry will cause Jenkins to poll once per minute.
	__15. Scroll down to the Pipeline section, and change the Definition entry to 'Pipeline Script from SCM'
	__16. Enter the following:
	__17. The Pipeline section should look similar to:
	__18. Click Save to save the new configuration.
	__19. Click Build Now to launch the pipeline.

	Part 3 - Try out a Failing Build
	__1. In Eclipse, go to the Project Explorer and locate the file 'Greeting.java'. It will be under src/main/java in the package 'com.simple'.
	__2. Open 'Greeting.java'.
	__3. Locate the line that reads 'return "GOOD";'. Change it to read 'return "BAD";'
	__4. Save the file.
	__5. In the Project Explorer, right-click on Greeting.java and then select Team → Commit... (This is a shortcut for committing a single file).
	__6. Enter an appropriate commit message and then click Commit and Push. Then click Close.
	__7. Switch back to Jenkins.
	__8. Go back to Eclipse and open the 'Jenkinsfile' if necessary.
	__9. Alter the 'bat "mvn..." line to read as follows:
	__10. Save the 'Jenkinsfile'.
	__11. Commit and push the changes using the same technique as above.
	__12. After a minute or so, you should see a new Pipeline instance launched. If nothing happens then click Build Now.

	Part 4 - Add a Manual Approval Step
	__1. Go to 'Eclipse' and open the 'Jenkinsfile' if necessary.
	__2. Add the following to the end of the file after the closing }:
	__3. Save and commit 'Jenkinsfile' as previously.
	__4. Move your mouse over the 'User Acceptance Test' step, select Yes and click Proceed.
	__5. Run the pipeline again (click Build Now), but this time, select No on the 'User Acceptance Test' and click Proceed, you'll see that the pipeline exits early and doesn't run the 'deploy' stage.
	__6. Close all.

	Part 5 - Review

	Lab 6 - Advanced Pipeline with Groovy DSL
	Part 1 - Explore Groovy DSL basics
	__1. In the web browser enter the following URL to access Jenkins.
	__2. Login as wasadmin for user and password.
	__3. Click Manage Jenkins.
	__4. Click Manage Nodes and Clouds.
	__5. If you see a Linux Build like below, click on it.
	__6. Then click Delete Agent and click Yes to confirm deletion.
	__7. Click Manage Jenkins.
	__8. Scroll down and click Script Console.
	__9. Enter following text:
	__10. Click Run button.
	__11. In the Script Console text box, remove previous code and enter the following code:
	__12. Click Run.

	Part 2 - Create a directory structure for storing Shared Library content and initialize the Git repository.
	__1. Open Command Prompt.
	__2. Switch to the Workspace directory.
	__3. Create a directory for storing Groovy libraries and switch to it.
	__4. Create a directory for storing your first library's scripts and switch to the directory.
	__5. Initialize Git repository.
	__6. Configure user name and email address required for committing changes to the repository.
	__7. Create directory structure for storing the Groovy source code.

	Part 3 - Create a simple Groovy script, commit it to the repository, and add it to Jenkins as a shared library.
	__1. Create a simpleClass.groovy file using the Notepad. Click Yes to create the file.
	__2. Enter following text.
	__3. Save and close the file.
	__4. Add the content to the Git repository.
	__5. Commit changes.
	__6. In the web browser open Jenkins.
	__7. Click Manage Jenkins.
	__8. Click Configure System.
	__9. Scroll down the page, locate Global Pipeline Libraries, and click Add button.
	__10. In Name text box, enter "my-shared-lib" (without quotes).
	__11. In Default Version text box, enter "master" (without quotes).
	__12. Under Retrieval Method, click "Modern SCM".
	__13. Under Source Code Management click Git.
	__14. In Project Repository text box, enter "c:workspacegroovyMyFirstLibrary.git" (without quotes).
	__15. Click Apply button.
	__16. Click Save button.
	__17. Click Manage Jenkins.
	__18. Click Configure System.
	__19. Scroll down the page and notice it shows the repository revision number.

	Part 4 - Create a Jenkins Job and utilize the shared library you created previously
	__1. In the web browser ensure you have Jenkins web site open.
	__2. Click New Item.
	__3. In Enter an item name enter "Shared Library Pipeline" (without quotes).
	__4. Select Pipeline.
	__5. Click OK button.
	__6. Scroll through the page, locate Pipeline section, and in Script enter following text.
	__7. Click Apply button.
	__8. Click Save button.
	__9. Click Build Now.
	__10. Click the build under Build History.
	__11. Click Console Output.

	Part 5 - Create a standardized software engineering process shared library
	__1. In the Command Prompt switch to the directory where you will store scripts for the shared library.
	__2. Open Notepad and create file for the library. Click Yes to create the file.
	__3. Enter following text.
	__4. Save and close the file.
	__5. In Command Prompt stage the new file.
	__6. Commit the changes to the repository.

	Part 6 - Create a Jenkins Job and utilize the shared library
	__1. In the web browser ensure you have Jenkins web site open.
	__2. Click New Item.
	__3. In Enter an item name enter "ABCInc" (without quotes).
	__4. Select Pipeline.
	__5. Click OK button.
	__6. Scroll through the page, locate Pipeline section, and in Script enter following text.
	__7. Click Apply button.
	__8. Click Save button.
	__9. Open eclipse in the same workspace.
	__10. Go to the Project Explorer and locate the file 'Greeting.java'. It will be under src/main/java in the package 'com.simple'.
	__11. Open 'Greeting.java'.
	__12. Locate the line that reads 'return "BAD";'. Change it to read 'return "GOOD";'
	__13. Save the file.
	__14. In the Project Explorer, right-click on Greeting.java and then select Team → Commit... (This is a shortcut for committing a single file).
	__15. Enter an appropriate commit message and then click Commit and Push.
	__16. Click Close in the results box, to close it.
	__17. Go back to Jenkins.
	__18. Click Build Now.
	__19. When the stage progresses to "User Acceptance", hover the mouse over "User Acceptance Test", select "Yes", and click "Proceed" button.
	__20. After all stages are completed, notice a new build shows up under Build History.
	__21. Click the latest build.
	__22. Click Console Output.
	__23. Notice it shows all stages and their details.
	__24. In File Explorer go to C:Workspacedev and notice SimpleGreeting-*.jar is copied here by the shared library script upon user acceptance.
	__25. Close all.

	Part 7 - Review

	Lab 7 - Configure Jenkins Security
	Part 1 - Enable Jenkins Security
	__1. Make sure Jenkins is started. Since we configured as windows service it will be started every time you start the machine.
	__2. Go to the Jenkins console:
	__3. Enter wasadmin as user and password and click Log in.
	__4. On the Menu click Manage Jenkins.
	__5. Click Configure Global Security.
	__6. Jenkins will display the Configure Global Security page.
	__7. Under the Security Realm heading, select Jenkins own user database.
	__8. Select Allow users to sign up.
	__9. Click the Save button at the bottom of the page.

	Part 2 - Create an Administrative User
	__1. In the “Manage Jenkins” page (the last part of the lab should have left you here), click on Manage Users.
	__2. Click on Create User.
	__3. The system displays the Sign Up page. Enter the following information in the appropriate fields:
	__4. When the page looks like below, click on the Create User button.
	__5. The system will display the list of current users, including the 'admin' user that you just created.
	__6. Click on Manage Jenkins to return to the management console.

	Part 3 - Enable Authentication
	__1. Click on the link for Configure Global Security.
	__2. Under the Authorization heading, select Project-based Matrix Authorization Strategy.
	__3. A table will open, below the table click Add user or group.
	__4. Enter admin, and then click OK.
	__5. Jenkins displays the newly-added user in the list of users. Now we need to select all the permissions. You could click each permission box listed for 'admin' individually, but to save a little time, if you scroll the window horizontally all the way over to the right-hand side, you'll find a button that will select all the permissions in one operation.  Find that button and click it.
	__6. Click Save.
	__7. Since we have altered the authorization strategy, Jenkins resets its security system, which requires us to log in again. You will see that wasadmin access has been denied. Click the log out link at the upper-right corner of Jenkins' home page.
	__8. At the login screen, enter admin as the userid and password as the password, then click Sign in.
	__9. Do not save the password.
	__10. Click the log out link at the upper-right corner of Jenkins' home page.

	Part 4 - Create a Self-Signed-Up User
	__1. Click on Create an account in the login page.
	__2. Jenkins will display the Sign up page. Enter the following information in the appropriate fields:
	__3. Click Create account.
	__4. Jenkins will display the Success window. Do not save the password.
	__5. Click on the link to go to the top page.
	__6. Click on the log out link, and then Sign in using 'admin/password'.
	__7. We should see the main dashboard page. Click on the SimpleGreeting job (we created this job in an earlier lab).
	__8. Click Configure.
	__9. In the configuration page, click on the check box marked Enable project-based security, to select it.
	__10. Click Add user or group.
	__11. Enter jane, and click OK.
	__12. In the row labeled Non-Administrative User, select the check boxes for Discover, Read and Workspace.
	__13. Click Save.
	__14. We also need to grant jane the 'overall read' permission. Click Back to Dashboard.
	__15. Click the Manage Jenkins link, and then select Configure Global Security.
	__16. Under the Authorization heading, Click Add user or group.
	__17. Enter jane, and click OK.
	__18. In the row labeled Non-Administrative User, select the check box for Read under Overall.
	__19. Click Save.
	__20. Log out, and then log back in as 'jane/password'.
	__21. Click on the SimpleGreeting job.
	__22. Notice that Jane doesn't have full privileges – there is no Build Now or Configure option on the project.
	__23. Log out of Jenkins.
	__24. Login back as admin/password.
	__25. Click Manage Jenkins.
	__26. Click on the link for Configure Global Security.
	__27. Under the Authorization heading, Click Add user or group.
	__28. Enter wasadmin, and click OK.
	__29. Jenkins displays the newly-added 'Administrator' user in the list of users. Now we need to select all the permissions. You could click each permission box listed for 'Administrator' individually, but to save a little time, if you scroll the window horizontally all the way over to the right-hand side, you'll find a button that will select all the permissions in one operation.  Find that button and click it.
	__30. Click Save.
	__31. Log out.
	__32. Sign in back as wasadmin and make sure you have full access.
	__33. Close all.

	Part 5 - Review

	Lab 8 - Optional - Ephemeral Build Agents with Docker
	Part 1 - Configure a Docker Image for the Agent
	If you are running the Linux virtual machine locally then perform steps 1 through 5 to obtain the IP of your Linux instance otherwise skip to step 6 if you have already been provided with the IP.
	__1. Open VMware player.
	__2. Start the VM_2271 image. [it should be listed]
	__3. Log in using the following credentials:
	__4. Open a Terminal and then enter ifconfig to get the IP. The output will show the configuration of several network adapters. You are looking for the IP address of the ethernet adapter which is typically eth0.
	__5. Write down the IP as you will need it in further steps.
	__6. Switch back to the Windows VM.
	__7. Right-click on the Windows Desktop and then select 'Git Bash Here'. Enter the following, substituting the IP address for your Linux machine:
	__8. If this is the first time connecting to this host, you will be prompted "Are you sure you want to continue connecting?" Answer 'yes'.
	__9. When prompted for the password, enter 'wasadmin'.
	__10. Enter the following to change directory to the folder where the Dockerfile exists:
	__11. Enter the following to become the root user (this is required to run Docker commands):
	__12. Enter the password 'wasadmin' if prompted by the 'sudo' command.
	__13. Inspect the Dockerfile by entering 'cat Dockerfile':
	__14. Create the docker image by typing the following:
	__15. At the end you should see a message like this:
	__16. Close the 'ssh' shell by pressing Ctrl-D twice.
	__17. Close the 'bash' window.

	Part 2 - Configure Host Mapping in the Windows Machine
	__1. Open Windows Explorer, and then navigate to the directory 'C:WindowsSystem32driversetc'. This directory should have a file in it called 'hosts'. The location may vary based on what version of Windows you have installed. If you can't find it, ask your instructor for assistance.
	__2. Right-click on the 'hosts' file, and then select Properties.
	__3. Select the Security tab.
	__4. Click on the Edit button.
	__5. Under Groups or user names, select Users.
	__6. Under Permissions for Users, click the check-box for Modify.
	__7. Click OK.
	__8. Windows will show the Windows Security dialog. Click Yes.
	__9. Click OK until properties is closed.
	__10. Right-click on the 'hosts' file, and then select Open.
	__11. Click on the button for Notepad.
	__12. At the end of the file, add an entry mapping your Linux IP address to 'docker-host', as shown below (Make sure to substitute your Linux IP address, in this example '192.168.1.120':
	__13. From the Notepad main menu, select File → Save and then close Notepad.
	__14. Close the Windows Explorer window.

	Part 3 - Configure Jenkins
	__1. Open a web browser to http://localhost:8080
	__2. Login with the administrator credentials (typically user-id: wasadmin, password: wasadmin).
	__3. Click on Manage Jenkins, and then click on Manage Plugins.
	__4. Click on the Available tab.
	__5. In the Filter box, enter 'Docker', but don't press the return key.
	__6. Scroll down to find the Docker plugin, and click the check-box to select it.
	__7. Click the Install without restart button.
	__8. Click Manage Jenkins.
	__9. Click Configure System.
	__10. Scroll down to the Cloud section and then click the link "a separate configuration page".
	__11. On the Add a new cloud drop-down box, and select Docker.
	__12. Enter the following value for Name:
	__13. Click Docker Cloud Details.
	__14. Enter for Docker Host URI:
	__15. Click on the Add drop-down button next to the Server Credentials label and select Jenkins:
	__16. In the pop-up window, find the Kind drop-down and then select X.509 Client Certificate
	__17. Leave the dialog box open, and open a command-line window. The exact steps to open a command-line window vary depending on what version of Windows you're running.  Typically, you will go to the Start menu and type "command", and then click on the Command Prompt option.  Check with your instructor if necessary.
	__18. In the command prompt, type "cd LabFilesEphemeralAgent" and then press Enter.
	__19. Type 'dir' and then press Enter.
	__20. In the command prompt window, type the following (Note: '|' is the vertical bar or 'pipe' character, found above the 'Enter' key on most keyboards):
	__21. In the Jenkins credential dialog box, click into the field named Client Key and then click Add.
	__22. Then press Ctrl-v.
	__23. In the command prompt window, type the following:
	__24. In the Jenkins credential dialog box, click into the field named Client Certificate and then press Ctrl-v.
	__25. In the command prompt window, type the following:
	__26. In the Jenkins credential dialog box, click into the field named Server CA Certificate and then press Ctrl-v.
	__27. Under Description, enter 'Docker Credentials'.
	__28. Click Add.
	__29. Select the newly-created credentials in the Server Credentials drop-down:
	__30. Click Test Connection. You should see a result back.
	__31. Check the Enabled box.
	__32. Click Docker Agent Templates...
	__33. Now click Add Docker Template.
	__34. Under Labels, enter 'docker-cloud'. This will identify the ephemeral agent so that we can target jobs towards it.
	__35. Check the Enabled box.
	__36. As Name enter 'docker-cloud'.
	__37. Under Docker Image, enter 'jenkins-agent'.
	__38. As Remote File System Root enter '/home/jenkins'.
	__39. Scroll down to the Connect Method section. Select "Connect with SSH":
	__40. Look for the SSH Key subsection. Use the drop-down box to select "Use Configured SSH Credentials". This option configures the credentials that Jenkins will use when it connects to the agent machine using 'ssh'.
	__41. Click on the Add drop-down and then select Jenkins.
	__42. This time, select and/or enter the following values:
	__43. When the dialog looks like the following, click Add:
	__44. Back in the cloud configuration, select 'jenkins/*****' under the SSH Credentials drop-down.
	__45. Select "Non-verifying Verification Strategy" under the Host Key Verification Strategy.
	__46. Look for the Pull Strategy drop-down box, and select "Never pull".
	__47. Next to Node Properties click the drop-down box for Add Node Property, and then select "Tool Locations".
	__48. Click on the Add button next to List of tool locations.
	__49. Click on the Name box and then select "(JDK) OracleJDK".
	__50. In the Home field, enter "/usr/lib/jvm/java-8-openjdk-amd64".
	__51. Click the Add button again.
	__52. Select (Git) Default and enter "/usr/bin/git" in the Home field.
	__53. Click the Add button again.
	__54. Select (Maven) Maven and enter "/usr/share/maven" in the Home field.
	__55. Click Save.

	Part 4 - Create a Jenkins Item
	__1. Click on the New Item entry in the left-hand navigation menu:
	__2. Enter 'SimpleGreeting-Docker' as the item name, and then select Maven project.
	__3. Click OK.
	__4. Click the check box for 'Restrict where this project can be run' to select it.
	__5. Enter 'docker-cloud' as the Label Expression.
	__6. Under Source Code Management, select Git.
	__7. Enter 'https://github.com/WebAgeSolutions/SimpleGreeting.git' as the Repository URL and press tab.
	__8. Under Branch Specifier, enter 'tags/sample-working'.
	__9. Under Build, enter 'install' for Goals and options.
	__10. Click Save.

	Part 5 - Run a Build
	__1. Click on Build Now.
	__2. You can follow the console output while the build is running. Click on the drop-down box next to the build number and then select Console Output (same as with any job).
	__3. Go back to the project, the status should be completed.
	__4. Click on the build to see the Results.

	Part 6 - Review




