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Lab 1 - Basic Mediation Flow Development
In this lab, we will develop a very simple mediation flow. A mediation flow can be used 
to implement most patterns. We will not get into pattern implementation just yet. Our 
focus will be to learn the basics of development and testing using IID. We will also get to 
see a very simple mediation flow in action.

A mediation flow always acts as an intermediary between an actual service provider and 
consumer. To the consumer, the mediation flow appears as the service provider. To the 
provider, the mediation flow is the consumer. The true consumer is decoupled from the 
true provider.

In this lab, we will use a Java class as the service provider. Java class based service 
providers are quicker to develop compared to web services. They are great for testing.

We will not develop any consumer application. Instead, we will use the universal test tool 
to invoke methods of the mediation flow.

The business logic for the service will be very simple. It will have a method called 
sayHello. It will accept as input a string. It will return a greeting message as a string. 
From a Java point of view, the method will look like this:

String sayHello(String name)

The business logic is kept intentionally simple so you can focus on the mechanisms of 
software development and testing using IID. Later labs will assume that you know these 
skills and avoid giving detailed instructions.

Part 1 - Getting Started with IBM Integration Designer
__1. From Windows start menu select: All Programs > IBM > IBM Integration 
Designer ->  IBM Integration Designer 8.0
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__2.  In the Workspace Launcher dialog, change the workspace  to C:\workspaceIID

__3. Click OK.

__4. If the Getting Started page appears, close it.

At this point, you should be in the Business Integration perspective.  The Business 
Integration perspective is a special perspective included with IID which is used for 
creating SCA modules.

Part 2 - Create a Mediation Module
SCA development can happen in two types of projects – Module and Mediation Module. 
A Mediation Module only allows you to create artifacts, such as a mediation flow, that 
can be deployed in WebSphere ESB.   A Module, on the other hand, allows you to create 
all artifacts that can be deployed in WebSphere Process Server. For example, a BPEL 
business process can only be created in a Module. A mediation flow can be created in 
either of the two projects.

Tip: If your target server runtime is WebSphere ESB, you should always use the 
Mediation Module project. This will prevent you from creating an artifact that can not 
be deployed in WebSphere ESB.

__1. From the menubar, select File > New > Mediation Module.

__2. Enter the following values:

Module name: SimpleModule

Target runtime server: IBM Process Server v8.0.

Create mediation component: Uncheck. This adds a dummy component to the 
assembly diagram without any implementation. This is more of an inconvenience than 
helpful, so we uncheck it.

Open module assembly diagram: Uncheck. We will not work with the assembly 
diagram yet. So, uncheck this option.
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__3. Click Finish.

__4. IID will create the mediation module. In the Business Integration view, under the 
Projects section, verify that SimpleModule is shown.

Part 3 - Study the Project Structure
We will now observe how exactly a mediation module project is represented on the file 
system.

__1. From the menubar, select Window > Open Perspective > Other.
__2. Select Java EE.

__3. Click OK.

__4. Notice, the projects have been created for SimpleModule:
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These projects are as follows:

Project Remarks

SimpleModule This is a plain Java project that represents the actual 
mediation module. All SCA artifacts, like mediation flow 
and data transformation maps, are created here.

SimpleModuleApp This is a J2EE enterprise application project. This is what 
gets deployed to the server as an EAR file. The EAR file 
includes the mediation module Java project as a JAR file.

SimpleModuleWeb This is a Web module project.

__5. Close the Java EE perspective by selecting Window > Close Perspective.

Part 4 - Create a Service Interface
Every SCA service must support one or more interfaces. A service interface is a 
collection of operations. SCA uses WSDL portType to define interfaces. You could also 
use a Java interface for that purpose. But, in SOA, vendor and language neutral WSDL is 
always recommended.

We will now create the interface for our very simple mediation flow. Recall, it has only 
one operation that looks like this: String sayHello(String name)

__1. Expand SimpleModule  project.

__2. Right click Interfaces and select New > Interface.

__3. Enter Greeting as the name of the interface.

__4. Click Finish.

IID will create the interface and open it in the editor.
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__5. In the editor, click the Add Request Response Operation toolbar icon to add a new 
operation.

Make the following changes:

__6. Change the name of the operation to sayHello
__7. Change the name of the input parameter to name 

__8. Change the name of the output parameter to message

__9. Save and close the editor.

Part 5 - Create the Mediation Flow
Our mediation flow will conform to the service interface we have defined in the previous 
part.

__1. Right click Integration Logic under SimpleModule project and select New > 
Mediation Flow.

__2. Enter GreeterFlow as the name.

__3. Click Next.
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As the source interface, you will add the Greeting interface we have defined previously. 
The source interface is what the mediation flow offers to its consumers.

__4. Click the Add button for Sources interfaces.

__5. The Greeting interface should be selected, just click OK.

The sources interfaces will be updated.

As the target interface, also you will add the Greeting interface. The actual service 
provider supports this interface.

__6. Click the Add button for Target references.

__7. The Greeting interface should be selected, just click OK.

The target references will be updated.

The source and target interface does not have to be the same. In fact, the data translation 
pattern requires that they be different. In that case, the actual service consumer and 
provider support different service interfaces. The mediation flow acts as the bridge. We 
will see the implementation of this pattern in a lab later.

__8. Click Finish. IID will create the mediation flow and open it in the editor.
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Part 6 - Design the Mediation Flow
Our mediation flow will be the simplest kind. There will be no mediation primitive in the 
message flow. We will simply pass the input message straight to the service provider. 
Similarly, the response from the service provider will be sent back to the consumer.

__1. At the top of the editor, you will see two interfaces.

On the left hand side, we see the source interface. On the right hand side, we see the 
partner reference. The partner reference is a place holder for the actual service provider.

When a consumer calls the sayHello operation of the source interface, we would like the 
mediation flow to call the sayHello operation of the service provider. As a result, we need 
to connect the two operations.

__2. Click over the sayHello operation of the source interface.  

__3. The Select a Mediation Flow Template dialog will open, click the Service 
Integration link.

__4. The Select the Services window will open, click Add.
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__5. The Select Reference Operation window will open showing the sayHello Target 
operation of GreetingPartner, click OK.

__6. Back in the Select the Services window, the list will be updated with the selected 
target. click OK.

__7. The Request tab will open.

__8. Connect the output terminal of sayHello of Greeting (the source interface) to the 
input terminal of sayHello of GreetingPartner (target interface).

This creates a very simple passthrough message flow. Later, we will learn how to add 
mediation primitives in that flow to solve complex problems.
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__9. Click the Response tab to open the response flow design.

__10. Connect the output terminal of sayHello of GreetingPartner (the target interface) 
to the input terminal of sayHello of Greeting.  Make sure you select the pointed output 
terminal of the GreetingPartner and not the rectangular fail terminal.

That means, the output from the service provider is passed as is to the consumer.

__11. Click the Overview tab and check that the source and target are connected now.

__12. Save and close the editor.

__13. Open the Problems view and expand Warnings. You should notice a warning 
about "A direct connection exists from the mediation input to output." This is fine for our 
very simple mediation flow.

There should be no error messages.

Part 7 - Create Service Provider
We will now implement the actual service provider. According to our design, it conforms 
to the Greeting service interface.

__1. Double click Assembly Diagram under SimpleModule project to open it.

__2. Right click the white area of the editor and select Add > Java.

__3. Change the name of the Java component to GreeterBean
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__4. Right click the component and select Add > Interface.

__5. Select the Greeting interface and click OK.

__6. Right click the component again and select Generate Implementation.

__7. Click New Package.

__8. Enter com.webage.greet as the package name.

__9. Click OK to create the package.

__10. Click OK to select the new package for the implementation.

IID will create a class called com.webage.greet.GreaterBeanImpl and open it in the 
editor.

__11. Change the implementation of the sayHello method as follows.

public String sayHello(String name) {
System.out.println("Saying hello to: " + name);
return "Hello " + name;

}

__12. Save all files (Control+Shift+S).

Note: In this case, our Java class is implementing a service interface which is defined in 
a WSDL file. This is a unique feature of SCA. SCA uses a strict pattern where a service 
implementation, no matter how it is implemented, must support a WSDL based 
interface. In this case, the implementation is a Java class.

__13. Close the Java editor.

Part 8 - Wire the Components
Our mediation flow has a reference partner which is a placeholder for the actual service 
provider. We must wire that reference partner to the Java based service provider we have 
created above.

__1. Make sure that the assembly diagram is still open. If not open it.

__2. Drag the GreeterFlow mediation flow on to the diagram.

__3. Hover the mouse over the reference partner of the mediation flow and a lollipop will 
open up.
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__4. Drag the lollipop and drop it over the interface of the Java implementation. This will 
connect the two as shown below.

__5. Save changes.

Part 9 - Deploy the Application to Server
__1. Open the Servers view.

__2. Start the server if it is not running. Wait until the status changes to Started. Note. 
The first time the server starts takes a while.

__3. From the menu, select Window → Show View → Console.

__4. Console view will open, there you can see the server progress until starts 
completely.

__5. You may see the following window, just click OK.

__6. When the server finally opens it status should be Started, Synchronized.
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__7. Right click the server again and select Add and Remove...
__8. First we will undeploy all the projects running there, since this will help to start and 
publish faster. If there is any on the right side then Click Remove All.
__9. Select SimpleModuleApp and click Add.

__10. Click Finish.

__11. IID will start publishing the application files. Wait for the status of the server to 
change to Synchronized. 

__12. Expand the Server. 

Part 10 - Test the Application
We will test the application by invoking the sayHello operation exposed by the mediation 
flow. We will use the built-in test client for that.

__1. Open the assembly diagram if it is not open.

__2. Right click any white area of the assembly diagram and select Test Module.

IID will open the test client page.

__3. Verify the Component is set to GreeterFlow. That means, the test client will invoke 
the operations of the mediation flow.  It may default to GreeterBean, but this would not 
test the whole flow.

__4. Verify that the sayHello operation is selected since that is the only operation 
available from the interface.

__5. In the Initial request parameters table, set the value of the name parameter to 
something.
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__6. Under Events click the Continue toolbar button to invoke the operation.

__7. In the Deployment Location dialog, select IBM Process Server v8.0 at localhost. 
__8. Also, check Use this as the default and do not ask again.

__9. Click Finish.

__10. If asked, check the checkbox to always use the same authentication settings and 
click OK in the User Login dialog. Security is enabled for the server. This is where the 
administrative user ID and password is entered. Without a valid password, publishing will 
fail.
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__11. After the test ends, the Return parameters table will show the reply.

__12. Open the Server Logs view. At the very bottom, the output from the Java 
component will be shown.

__13. Close the test page without saving.

Part 11 - Configure Build Activities
Every time you change an SCA artifact file or assembly diagram, IID performs a build. 
As a part of the build, three things have to happen. 

1.  Validate the changes made.

2.  Generate new code and compile them.

3. Publish updated files to the server.

You can configure how many of these three steps are performed automatically.

__1. Open the Build Activities view.

Note that by default Validate and update deployment code is selected. Here, "update 
deployed code" is referring to code generation.
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That means, updated files are not published to the server by default after a build. You can 
click on the Update Running Servers button to do that. Many of the changes will be 
picked up by the server after files are published. In a few rare cases, we have to restart the 
server.

__2. Close all open files. (Ctrl+Shift+W)

Part 12 - Review
In this lab, we created a very simple mediation flow. During testing, we invoked the 
sayHello operation of the mediation flow. The flow, in turn, invoked the sayHello 
operation of the reference partner. The partner was wired to a Java implementation. As a 
result, the sayHello method of the Java class got invoked.

The response from the service provider Java class was returned back to the test client.

A few things to remember from this lab:

1. Every mediation flow has a source interface and one or more target interfaces.

2. For each target interface, a reference partner is defined in the mediation flow.

3. A method from the source interface is connected to one or more methods of the 
target interfaces.

4. For each source method, you need to design the request and response flow.

5. Every reference partner needs to be wired to an actual service implementation (or 
an import if the implementation exists outside the module).
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Lab 2 - Using Mediation Primitives
In the previous lab, we did not use any mediation primitives in the request or response 
flow. In this lab, we will add the message logger primitive to both flows. This primitive 
can save a message in a file or database.

Now, for the first time, our mediation flow will begin to offer some real value. In this 
case, we are essentially implementing the audit logging pattern. A part of the audit 
logging pattern saves request and response messages for later retrieval.

Part 1 - Add Primitive to Request Flow
__1. Expand SimpleModule > Integration Logic > Mediation Flows.

__2. Open GreeterFlow mediation flow in the editor by double clicking on it.

__3. Click the sayHello operation in the source interface. This will open the Request flow 
tab in the editor.

__4. In the Request flow, select the connection between  Greeting / sayHello and 
GreetingPartner / sayHello.

__5. Press the delete key to remove the connection.

__6. On the left hand side of the editor, expand the Tracing section.

__7. Drag and drop the Message Logger primitive on the editor.

__8. Connect the output terminal of Greeting  / sayHello to the input terminal of 
MessageLogger1.
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__9. Connect the output terminal of MessageLogger1 to the input terminal of 
GreetingPartner  / sayHello.

This means, the request message will first go inside the logger primitive. This primitive 
does not alter the message in any way and outputs the same message that came in as 
input. The output of the logger is then fed into the reference partner as input.

Now, we will configure the logger.

__10. Select MessageLogger1.

__11. Open the Properties view.

__12. Select the Details tab.

__13. Change the Logging type from Database to Custom.

Note: By default, a logger saves messages in a database. The database is pointed to by 
the Data source name property. The default data source name is 
jdbc/mediation/messageLog. This points to a Cloudscape (Derby) database where the 
necessary schema is already defined. Alternatively, you can point the message logger to 
a DB2 or Oracle database.

If you set the logging type to Custom, then the logger saves the messages in a file.
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Part 2 - Add Primitive to Response Flow
__1. Click the Response tab to switch to the response flow.

__2. Follow the steps in the previous part to insert a logger primitive in the flow.

__3. Change the logging type of the logger to custom.

__4. Save the mediation flow.

Part 3 - Publish Changes
__1. Open the Build Activities tab.

__2. Click Update Running Servers.

__3. Make sure IBM Process Server v8.0 is selected.

__4. Check the 'Do not show this dialog again' box.

__5. Press the Publish button.

The server will start publishing.  Wait until it's done.

Troubleshooting:  If you see the error message "Failure uploading archive to server", 
right click the server and select Publish. You can also stop and start the server.

Part 4 - Test
__1. Open the Assembly Diagram under SimpleModule project.

__2. Right click the white area and select Test Module.

__3. Set the component to GreeterFlow.  It may default to GreeterBean, but this would 
not test the whole flow.
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__4. Enter a name in the input table.

__5. Click the Continue toolbar button under Events.

__6. Close the test without saving it.

We will now inspect the messages saved in the log files. Messages are saved in the folder 
pointed to by the TEMP environment variable (both in Windows and UNIX).
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__7. Open a command prompt window.

__8. Enter the following command:

cd  /d  %TEMP%

__9. List all message log files:

dir  *.log

__10. You should see MessageLog.log that contains request and response messages.

__11. View the request message as follows.

type  MessageLog.log

__12. There locate the request and response messages as shown below:

__13. Close the Command prompt window.

__14. Back in IID, close all open files.

__15. Close IID.

Part 5 - Review
In this lab, we implemented the audit logging pattern. Note, how the pattern can be used 
to audit log a service without changing the service implementation. Now, you are 
beginning to see some of the advantages of using an ESB as an intermediary. 
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	__9.  List all message log files:
	__10.  You should see MessageLog.log that contains request and response messages.
	__11.  View the request message as follows.
	__12.  There locate the request and response messages as shown below:
	__13.  Close the Command prompt window.
	__14.  Back in IID, close all open files.
	__15.  Close IID.

	Part 5 -  Review

	Lab 3 -  Develop a Simple RESTful Service
	Part 1 -  Create the Web Service Project
	__1.  Make sure you have full access to C:\Software\WebLogic folder. If not contact your Instructor.
	__2.  Start OEPE by launching C:\Software\OEPE\eclipse.exe
	__3.  Select C:\workspace as workspace.
	__4.  Switch to the Java EE perspective. [Windows → Open Perspective → Other → Java EE]
	__5.  From the menubar, select File > New > Web Service Project.
	__6.  Enter AcmeWeb as the project name.
	__7.  Ensure that Oracle WebLogic Server 12c as the targeted runtime.
	__8.  Add the project to an enterprise application archive project called AcmeApp
	__9.  Click Finish.
	__10.  Right click the newly created AcmeWeb project and select Properties.
	__11.  Select the Java Build Path properties.
	__12.  Click the Libraries tab.
	__13.  Expand WebLogic Systems Library.
	__14.  Scroll down and locate the Jersey JAR files. If you use a plain dynamic web project, you will need to manually add these JAR files to the build path.
	__15.  Now, select the Project Facets property.
	__16.  Note that the JAX-RS facet is not selected. This facet plays no role in developing JAX-RS services for WebLogic.
	__17.  Click Cancel to close the dialog.

	Part 2 -  Register the REST Handler Servlet
	__1.  Open Windows file explorer.
	__2.  Go to C:\LabFiles\
	__3.  Copy web.xml
	__4.  In Eclipse OEPE, paste the file inside the WebContent > WEB-INF folder of AcmeWeb.
	__5.  Open web.xml and study how the servlet is registered. Specifically, note the servlet mapping:

	Part 3 -  Create the Resource Class
	__1.  Right click AcmeWeb project and select New > Class.
	__2.  Enter com.acme.services as the package name and SimpleService as the class name.
	__3.  Click Finish.
	__4.  Add a member variable that will help us do logging.
	__5.  Add the method as follows.
	__6.  Organize imports (Control+Shift+O) and select java.util.logging.Logger.
	__7.  Save changes.

	Part 4 -  Configure the Resource
	__1.  Define the URI of the root resource, by adding the @Path annotation above the class. This is shown in bold face below.
	__2.  Set the HTTP method and reply MIME type for the testGET() method sub-resource as follows.
	__3.  Organize imports. Select javax.ws.rs.Produces.
	__4.  Save changes.

	Part 5 -  Unit Test
	__1.  Start the Oracle WebLogic Server.
	__2.  Right click the server and select Add and Remove.
	__3.  Add the AcmeApp project to the server.
	__4.  Click Finish.
	__5.  Make sure the server is synchronized.
	__6.  Open a web browser and enter the URL: 
	__7.  You should see OK in the browser.
	__8.  The Console view in Eclipse will show the log output.

	Part 6 -  Use Path Extension for Sub-resource
	__1.  First, add this method.
	__2.  Annotate the method as follows.
	__3.  Save changes.

	Part 7 -  Unit Test
	__1.  Right click the server and select Publish.
	__2.  In a web browser, enter the URL: 
	__3.  Make sure that the Console shows the log output.
	__4.  Open a new browser and re-test the testGET method for regression using the URL: 
	__5.  Close all open files.
	__6.  Close all browsers.

	Part 8 -  Review

	Lab 4 -  Extracting Information from a HTTP Request
	Part 1 -  Get Root Resource Path Parameters
	__1.  Open SimpleService.java
	__2.  Change the @Path annotation for the class and add a parameter there.
	__3.  Add a member variable as follows.
	__4.  Annotate the member variable to save the value of the myRootPathData parameter.
	__5.  Change the log statement of the testGET() method as follows.
	__6.  Make a similar change to the testGETWithPath() method.
	__7.  Organize imports.
	__8.  Save changes.

	Part 2 -  Unit Test
	__1.  Publish the server.
	__2.  First, test the testGET() method by entering the URL: 
	__3.  The log output will like this:
	__4.  Now, test the testGETWithPath() method using the URL: 
	__5.  The log output will be:

	Part 3 -  Get Sub-resource Path Parameters
	__1.  Add a basic method as follows.
	__2.  Annotate method with path and method.
	__3.  Now, extract the path parameters and save them in the two input argument variables of the method.
	__4.  Save changes.
	__5.  Test the method by entering the URL: 

	Part 4 -  Extract Query Parameters
	__1.  Add the giveRaise() method as shown below.
	__2.  Organize imports.
	__3.  Save changes.
	__4.  Test the change by entering the URL: 
	__5.  Make sure that the Console shows:

	Part 5 -  Extracting Form Post Data
	__1.  Add this method.
	__2.  Organize imports. Select  java.util.List.
	__3.  Save changes.

	Part 6 -  Unit Test
	__1.  We will import the form HTML page. Copy C:\LabFiles\post.html and paste it inside the WebContent folder of AcmeWeb project.
	__2.  In the Servers view, right click the server and select Publish.
	__3.  Open a browser and enter the URL: 
	__4.  Fill out the form and submit it. 
	__5.  Make sure that the console log shows the input values correctly.
	__6.  Close all open files.
	__7.  Close all open browsers.
	__8.  Close eclipse.

	Part 7 -  Review

	Lab 5 -  Designing a RESTful Service
	Part 1 -  The Business Requirements
	Part 2 -  Define Project Scope
	Part 3 -  Designing the Object Model
	__1.  Can you go through the business requirements and identify the entities? 
	__2.  Now that you have identified the entities, can you list the attributes or fields for each entity? Once again, the answer is below. But do your best to do the design yourself.

	Part 4 -  Identify the Service
	__1.  Can you go through the requirements and list the tasks or operations that various yet to be identified services need to perform? Then compare your findings with the answer below.
	__2.  Can you group the operations based on the entity they work with? Name each group as a service accordingly. The answer is below.

	Part 5 -  Design the Service Interface
	__1.  First, let us decide on the URI for each entity. This is a pretty straightforward exercise. Note: As a matter convention, plural forms of the entity names are used in URI.

	Part 6 -  Decide on the Data Format
	Part 7 -  Unaddressed Architectural Issues
	Part 8 -  Review

	Lab 6 -  Using S3 for Website Hosting
	Part 1 -  Log in to the Amazon Management Console
	__1.  Open a web browser and navigate to the Amazon Web Service Management Console web page at:
	__2.  Enter your credentials provided by the instructor.
	__3.  Click Sign in.
	__4.  Click Console Home.
	__5.  Make sure you are in the Oregon region.
	__6.  Click S3 in the Storage & Content Delivery section.
	You will be placed in the S3 Dashboard.

	Part 2 -  Create a Bucket 
	__1.  Click the Create Bucket button.  
	__2.  In the dialog that appears, select the US Standard for the Region and enter a unique bucket name, for example, you can use your first name concatenated with the number of seconds in the current time, e.g. nick9
	__3.  Click the Create button; change the name if prompted that the requested bucket name is not available (not unique); you may be prompted with other error messages (text will vary), try to come up with a different unique bucket name.

	Part 3 -  Enabling the Website Hosting Feature 
	__1.  Click the Properties button in the top right-hand corner of the page.
	__2.  In the Properties page that opens, click the Static Website Hosting menu option.
	__3.  In the expanded page section under the Static Website Hosting caption copy down the Endpoint URL (nick9.s3-website-us-east-1.amazonaws.com, in our case), which will be the HTTP endpoint created courtesy of S3 service for your website, and click the Enable website hosting radio button.
	__4.  In the Index Document input box, enter index.html, for the Error Document, enter s3website/error.html  
	__5.  Click the Save button on the page.

	Part 4 -  Upload a File to the Bucket 
	__1.  Click the bucket link you created (as there may already be buckets created by other students). 
	__2.  In the Actions drop-down button, select the Upload action item.
	__3.  Using Windows Explorer on your student machine, open the C:\LabFiles\ folder and select (holding the Control button down for multiple selections) the following items:
	__4.  Drag and drop the above elements into the Drag and drop files zone on the Upload dialog in the browser. 
	__5.  Click the Start Upload button.

	Part 5 -  Access Your Website
	__1.  Open a new tab in your browser, and enter the location URL you copied in one of the above steps (http://nick9.s3-website-us-east-1.amazonaws.com, in our case).
	__2.   Switch back to the browser tab that holds the S3 page, and select all items in your bucket as shown in the screenshot below.  
	__3.  Click the Actions button and select Make Public 
	__4.  Click OK in the confirmation dialog that pops up.
	__5.  Switch back to the tab where you tried to access the website and got the 403 error, and refresh the page (Ctrl-R).
	__6.  Try to access a resource not available at your website, e.g. foobar.html.
	As an optional exercise, you can try out a couple of things to see how you can further manage objects in your S3 bucket exposed as the Web content:

	Part 6 -  Working Area Clean-up
	__1.  Delete all the files and folders in your S3 bucket (nick9, in our case) by right-clicking them and selecting Delete in the context menu. 
	__2.  In the Delete confirmation dialog that opens, click OK
	__3.  Finally, delete your bucket.
	__4.  In the delete confirmation dialog that opens, click OK

	Part 7 -  Review 

	Lab 7 -  Using Amazon Simple Queue Service
	Part 1 -  Create a Queue
	__1.  Open your browser and sign in to the AWS Management Console.
	__2.  Go to Console Home.
	__3.  Make sure you are in the Oregon region.
	__4.  Search for and select SQS (Message Queue Service) 
	__5.  Look for any queue with the name <You Login Name>Queue (e.g. S2Queue) already created. 
	__6.  Click the Create New Queue button.
	__7.   For Queue Name, enter your login name concatenated with the word "Queue", e.g. S2Queue.
	__8.  Select Standard Queue (it may be already preselected).
	__9.  Click Configure Queue at the bottom of the page.
	__10.  For Message Retention Period, enter 1 and select hours for time interval.
	__11.  For Maximum Message Size, enter 1
	__12.  Click Create Queue.

	Part 2 -  Send a Message to the Queue
	__1.  Right-click your queue and select Send a Message.
	__2.  In the message text area, enter some text of more than 1KB of characters (you can use your text editor, or scrape some content from a web page).
	__3.  Click Send Message. 
	__4.  Enter a smaller message text under 1 KB in size, e.g. Hi SQS!
	__5.  Click the Message Attributes tab of the Send a Message dialog.  
	__6.  Enter ReplyTo for the Name.
	__7.  Enter ReplyQueue for the Value.
	__8.  Click Add Attribute.
	__9.  Click Send Message.
	__10.  Click Close.

	Part 3 -  View and Delete a Message 
	__1.  Right-click your queue and select View / Delete Messages.
	__2.  Click Start Polling for Messages.
	__3.  Click Close.
	__4.  Right-click your queue and select View / Delete Messages.
	__5.  Click Start Polling for Messages.
	__6.  Check the Delete box.
	__7.  Click Delete 1 Message button at the bottom of the dialog window.
	__8.  In the Delete Messages dialog that pops up, click Yes, Delete Checked Messages.
	__9.  Click Close in the New / Delete Messages dialog window.
	__10.  Refresh the page to get the Messages Available counter updated (now it should show 0).

	Part 4 -  SQS Programmatic Access (Review)
	Part 5 -  Workspace Clean-Up
	__1.  Right-click you queue and select Delete Queue.
	__2.  In the confirmation dialog that opens, click Yes, Delete Queue.
	__3.  Sign out from the Management Console.
	__4.  Close your browser.

	Part 6 -  Review 

	Lab 8 -  Provisioning Tomcat Web Server in EC2  
	Part 1 -  Workspace Set-up
	__1.  Open your browser and sign in to the AWS Management Console. 
	__2.  Make sure you are in the Oregon region.
	__3.  Search for and select EC2 (Virtual Servers in the Cloud)
	__4.  Click Instances in the left-hand navigation pane.
	__5.  If you see any instance with your name, select the instance (shown as SX below), click the Actions button and select Instance State | Terminate  

	Part 2 -  Create an EC2 Instance 
	__1.  Click the Launch Instance button at the top of the page.
	__2.  Click the Select button for the item listed on top to choose the 64-bit Amazon Linux AMI.
	__3.   Click the check box to the left on the list to choose the t2.micro type. 
	__4.  Click Next: Configure Instance Details.
	__5.  Click the Review and Launch button at the bottom of the page. 
	__6.  Click the Launch button at the bottom of the page.
	__7.  Select the Choose an existing key pair option in the first drop-down box and the key pair you generated in one of the previous labs and identified by your user name (SX below); and check the I acknowledge … box to confirm that you have the private key.
	__8.  Click the Launch Instances button in the bottom right corner of the page.
	__9.  Write down the EC2 instance name shown at the top of the page.
	__10.  Click the View Instances button in the bottom right corner of the page.
	__11.  Click the Name area, which is currently blank, and enter your user name (e.g. S4). 
	__12.  First, check the Security groups by clicking the associated link in the Description tab of the instance details page section (your security group link may have a different name).
	__13.  On the Inbound tab of the details page section of the security group you clicked, you can see that the SSH port 22 is, in fact, open.
	__14.  On the Instances page, also notice that the instance has been assigned a public IP address and a public DNS name.  Note that after you restart the instance, the instance will receive a new IP address and a new DNS name, so those values are not static.
	On you student machine, open a command prompt terminal window and type in the following command: 
	nslookup <YOUR INSTANCE PUBLIC DNS NAME>
	 e.g. 
	__15.  Write down or remember the public IP address – you will use it when connecting to the instance over SSH later in the lab. 

	Part 3 -  Working with Security Group
	__1.  Click the Security groups link under the Description tab of the instance details page section (your security group link may have a different name).
	__2.  On the Inbound tab of the details page section of the security group you clicked, you can see that the SSH port 22 is, in fact, open.
	__3.  Click the Edit button.
	__4.  In the Edit inbound rules dialog that opens, click the Add Rule button.
	__5.   In the new rule record that appears right below the SSH rule, select Custom TCP Rule in the Type drop-down box, enter port 8080 in the Port Range cell and make sure the Source drop down has Anywhere option selected. 
	__6.   Click Save.

	Part 4 -  Connect to the EC2 Instance using an SSH Client 
	__1.  On the Instances page, select your instance (there may already be other instances created by other students in your class), and click the Connect button on the top of the page.
	__2.  Select A standalone SSH client
	__3.  Copy to clipboard the ssh example command (your details will differ).
	__4.  Open a Windows Command Prompt window. 
	__5.  Change directory to c:\LabFiles\Keys folder where you saved your private file (e.g. S4.pem) in one of the previous labs.
	__6.  Enter the SSH command you copied above.
	__7.  When prompted with this message:

	Part 5 -  Provision an Instance of Tomcat Web Server
	__1.  Enter the following command:
	__2.  Enter the following command:
	__3.  When you are prompted to confirm the operation with this prompt:
	__4.  Enter y 
	__5.  Enter the following command:
	__6.  Enter the following command to change directory to Tomcat's home directory:
	__7.  Enter the following command:
	__8.  Change directory to the webapps folder by entering this command:
	__9.  Open a Windows Command Prompt window. 
	__10.  Change directory to c:\LabFiles\
	__11.  Enter the following command:
	__12.  Switch to the SSH Terminal window, and execute this command: 
	__13.  Enter the following command:
	__14.  Enter the following command to start Tomcat:
	__15.  Enter the following command to verify that the WAR file was unpacked (which is an indication that Tomcat has, indeed, deployed it):
	__16.  Switch to the browser.
	__17.   In the Instances page, copy the Public IP address listed in the Description tab at the bottom of the page (54.213.229.67, in our case).
	__18.   Open a new browser tab and navigate to http://<Public IP address>:8080/BeansTalkTest
	__19.  Refresh the page a couple of times.

	Part 6 -  Workspace  Clean-Up
	__1.  In the browser tab opened on the Instances page, right-click your instance and select Instance State → Terminate.
	__2.  In the Terminate Instances confirmation dialog, click Yes, Terminate.
	__3.  Click the Key Pairs link in the navigation panel.
	__4.   In the Key Pairs page, delete your key by selecting your key and clicking the Delete button.
	__5.  In the Delete Key Pair confirmation dialog that pops up, click the Yes button.
	__6.  Sign out from the Management Console.
	__7.  Close all Command Prompt Windows.
	__8.  Close all open browsers and text editors.

	Part 7 -  Review 




