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Lab 1 - Setup the Development Environment
In this lab you will setup the environment for developing Web Services for JBoss. This
includes installing JBoss Eclipse plug-ins.

Part 1 - Verify Java Install
Since this course uses Java 7, which is still relatively new, you will do a few quick steps
just to verify everything is setup properly. Java 7 should have been installed as part of
the class setup but these steps will help verify and avoid other issues later when they are
harder to debug.
__1. Open a Windows command prompt. You can usually do this on most versions of
Windows by selecting 'Start → Programs → Accessories → Command Prompt'.

N
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__2. Run the following command and make sure you get a Java “1.7.x” version. If you
do not see this, the next steps will help figure out what setting is incorrect. Also, if you
get an error about java not being “recognized” as a command the next steps will help
figure out why.
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java -version
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__3. Run the following command to see the current value of the 'PATH' environment
variable. Check that you see the 'bin' directory of a Java 1.7 installation in the PATH. If
you do not see Java 1.7 or if you see multiple versions of Java referenced this could be
causing errors.
set PATH

Note: Your actual value may be slightly different but it should be obvious that it is a
Java (or “JDK”) 1.7 version.
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__4. Run the following command and look at the value of the 'JAVA_HOME'
environment variable. Make sure that it points to the root directory of a Java 1.7
installation. If you get a message about 'JAVA_HOME' not being defined this could also
cause issues.
set JAVA_HOME

Note: Your actual value may be slightly different but it should be obvious that it is a
Java (or “JDK”) 1.7 version.
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__5. If you have not seen output similar to that shown in the previous steps, inform your
instructor. They can help determine if all students have the same (or similar) issue and
the best way to fix it so it won't cause problems later.
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Part 2 - Install JBoss Eclipse Plug-ins
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__6. Close the command prompt.
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Besides allowing us to use JBoss as a test server, the "JBoss Tools" Eclipse plug-ins have
a few tools specific to web services. This section will install those tools. This was not
done as part of the class setup because the steps are a little more involved. It will also be
good for you to know how to install these tools if you want to obtain them for your own
environment from:

EV

http://www.jboss.org/tools/download

The JBoss Tools version you will use has already been downloaded and is compatible
with the Eclipse version you are using.
__1. Start Eclipse by launching C:\Software\eclipse\eclipse.exe
Eclipse will launch.
You will be prompted to select a Workspace.
__2. Set the Workspace to C:\workspace
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__3. Click OK.
Eclipse will start.
__4. Eclipse may be displaying the Welcome screen. Close the welcome screen by
clicking the x in its tab.

AT
I

O

N

O

N

LY

__5. From the Eclipse menus select Help → Install New Software...
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Note: If you get an error about some sites not being found it is because Eclipse can't
connect to the Internet. Since you will be provided with a local copy of the updates you
can ignore this error and click 'OK'.
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__6. Click the Add button on the upper right to add a new update site.

__7. Click the Archive... button.

Note: You are using this option since the JBoss Tools are provided as a single Zip file
with the class software.
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__8. In the dialog to choose a file, find and open the file
'C:\Software\JBoss Tools\jbosstools-4.0.1.Final....zip'. The end of the file name is not
given as it may change but this should be the only Zip file which starts with that name at
that location.
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__9. Once you have chosen the appropriate Zip file, give the update site a name of 'JBoss
Tools Archive' and press the OK button when your options are similar to that shown
below.
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__10. In the list of available features expand the 'Abridged JBoss Tools 4.0' category and
check ONLY the 'JBoss WebServices Tools' and the 'JBossAS Tools' options as shown
below and press the Next button.

Note: Although JBoss Tools has other tools available we will only use these tools for the
labs.
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__11. You will see a list of software that will be installed as shown below. There should
be no checkboxes next to any features. Press the Next button.
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__12. On the 'Review Licenses' screen, select the radio button in the lower right labeled
'I accept the terms of the license agreements' and press the Finish button. This will
begin installing the software.

AL
U

__13. Leave the dialog box that appears running so that you can see when the installation
process completes.
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__14. When you get a prompt about unsigned plugins click the OK button.
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__15. Once the installation is complete you will get a prompt to restart Eclipse. Press the
Yes button to restart.

__16. Open Eclipse in the same workspace when it restarts.
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__17. Click No if the JBoss Tools Usage dialog opens.
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Part 3 - Configure JBoss Test Server in Eclipse
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Now that the JBoss Eclipse tools are installed the next step is to define a JBoss test
server. This will let you deploy and test applications directly from Eclipse.
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__1. Click on the Servers view located in the bottom of the Eclipse window.

__2. Right click in the empty area and select New -> Server.
__3. From the list expand JBoss Community and select JBoss AS 7.1
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__4. Click Next.
__5. Click the first Browse button next to Home Directory and navigate to
C:\Software\jboss-as-7.1.1.Final and then click OK. Stay on the same page in the main
wizard.
__6. For the JRE option use the drop-down to select the JDK 1.7 that is installed.
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__7. Click Finish once your dialog matches the settings shown below.
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__8. The new server will appear in the Servers list.

__9. Right click on the Server and select Open.
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__10. The configuration page of the Server will open.

__11. Expand Publishing on the right side.
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__12. Select Never publish automatically.
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__13. At the bottom of the Eclipse server configuration editor click the 'Deployment' tab.
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__14. Check the 'Deploy projects as compressed archives' option.
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Note: This option is generally best to allow rapid deployment and testing of changes
made in Eclipse. The default settings would deploy an “exploded” archive. Even
though modifying and publishing an updated Java class would recompile the .class file
copied to the server, the application would not be restarted and the previous version of
the class loaded by the server would still be used.
By deploying a compressed archive, any change to any file in that project would recreate
the entire archive and cause the entire application to be redeployed. This would
guarantee the most recent code is being used. Since JBoss deployment is very quick,
this method is preferred to avoid any confusing behavior where code changes have not
been picked up by the server.
__15. Save the changes and close the window.
__16. In the Servers view, right click the 'JBoss 7.1 Runtime Server' and select Start.
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__17. Click the tab for the Console view and scroll back to find the message about JBoss
Web Services starting. Notice that it is using the “CXF Stack” from Apache CXF. This
will be important in advanced web service features in later labs.
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__18. Check that the server starts successfully. You may need to switch back to the
Servers view.

__19. Leave the server running for the next section.

Part 4 - Configure JBoss Management User
By default the web administration console of JBoss is secure but doesn't have any users
configured. This effectively locks it down until you configure users to access it. Since
several labs may need to go into this administrative console to perform various tasks, this
section will enable an administrative user.
__1. Open a Windows command prompt. You can usually do this on most versions of
Windows by selecting 'Start → Programs → Accessories → Command Prompt'.
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__2. Use the following 'cd' command to switch to the JBoss 'bin' directory.
cd C:\Software\jboss-as-7.1.1.Final\bin

__3. Run the following 'add-user' command to start the interactive tool to add a user.
How to respond to various prompts is given in the next steps.

LY

add-user
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__4. On the first prompt, hit the <ENTER> key to accept the default option of 'a' to
create a “management user”.
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__5. On the second prompt, hit the <ENTER> key to accept the default option of
'ManagementRealm' for the security realm. This is the name of the security realm
already defined in the JBoss server so using this ensures we do not have to change any
other JBoss configuration.

__6. Enter a username of 'admin'.
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__7. Type the following password for both prompts that ask you to enter a password.
Note that the program will not even show stars while you type.
jbo$$ee6

Note: This version of the tool requires a password that is at least 8 characters and has
one number and one non-alphanumeric character.
__8. Type 'yes' to accept the username 'admin' since it is “easy” to guess.
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__9. Type 'yes' to confirm you want to add the 'admin' user to the 'ManagementRealm'.
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__10. Hit any key to let the program finish and return you to the command prompt.
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__11. Close the command prompt.

__12. Go back to the Servers view in Eclipse and make sure your JBoss server is
running. Start it if it is not.
__13. Open a web browser to the following address which should bring up a security
prompt.
http://localhost:9990/console
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__14. In the security prompt, enter a username of 'admin' and a password of 'jbo$$ee6'.
You can check the option to remember the password if offered.
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__15. Check that you see the overview page of the administration console. If it doesn't
display try refreshing the page.
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Note: If you get an authentication error it may be because somehow the password you
entered in the browser is different than what you configured in the script tool. If you
can't provide the correct password you can run the 'add-user' tool again but you first
have to manually delete some lines from two text files.

EV

Find the following two text files, open them with a text editor like WordPad, and delete
the line that starts with 'admin=...' without a leading '#' as a comment.
C:\Software\jboss-as-7.1.1.Final\domain\configuration\mgmt-users.properties
C:\Software\jboss-as-7.1.1.Final\standalone\configuration\mgmt-users.properties

You need to delete this line from both files because even though your configuration is
only looking at the 'standalone' properties file, you can't run the 'add-user' tool again
with the same user if it already exists in either one of these files.
__16. Close the browser you are using to access the administration console.
__17. Stop the server in the Eclipse Servers view.
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Part 5 - Update JBoss Web Service Runtime
Although the JBoss server already has the JBossWS-CXF “stack” installed, it is missing
some modules that will be needed for more advanced functions later. Since this lab is all
about setting up the environment it would be good to run a command to update this now.
Also, although we won't change the JBoss web services version, you could use this
technique to upgrade your own environment to a more recent version if desired.
The software for a version of the CXF "stack" of JBoss Web Services has already been
provided as part of the class software. Installing different "stacks" for JBoss Web
Services is very easy. All come with an Ant build file that we can run from Eclipse after
changing a few settings.
Even though the JBoss Web Services runtime we will use is provided for you the JBoss
Web Services site has various downloads of the different options:
http://www.jboss.org/jbossws/downloads

LY

__1. Make sure the JBoss server is stopped in the Servers view. This is important since
we will be modifying the JAR libraries and some of the deployed services of the server.
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__2. Open a Windows Explorer window and navigate to the
'C:\Software\jbossws-cxf-bin-dist\' directory.
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__4. In Eclipse, select File → Open File...
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__3. Rename the 'ant.properties.example' file to 'ant.properties'.
__5. Open the file 'C:\Software\jbossws-cxf-bin-dist\ant.properties'
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__6. Set the location of JBoss by setting the jboss711.home property as follows. Make
sure to use forward slashes (/) and not backslashes (\) or the Ant build will fail. You can
leave the other home directories of other JBoss versions as they are.
jboss711.home=C:/Software/jboss-as-7.1.1.Final

Note: If for some reason your lab software was extracted to a different location, adjust
this value so it points to the correct directory for the JBoss server.
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__7. Modify the jbossws.integration.target property so it has the value of 'jboss711'.
jbossws.integration.target=jboss711

__8. Select File → Save from the Eclipse menus.
__9. In Eclipse, choose File → Open File from the menubar.
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__10. Open C:\Software\jbossws-cxf-bin-dist\build.xml.
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__11. From the Outline view on the right, right-click the 'JBossWS-CXF' root project
definition and select Run As → Ant Build... Make sure to select the "Ant Build..."
option (with ellipsis) and not just the regular "Ant Build" option.

__12. From the list of targets, select only the deploy-jboss711 target but do not run the
build yet. Be careful which target you select as there are several with similar names.
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__13. Click the JRE tab at the top and fill in a value of '-Dspring=true' without the
quotes (but with the leading dash).

__14. Click the Run button at the bottom right.
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Note: Although there are targets that appear they would only deploy the Spring modules,
they don't appear to work without running the main 'deploy' target.

EV

AL
U

__15. The Console should show the output from Ant which should end with the "BUILD
SUCCESSFUL" message.
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Note: If you have errors during the build and try to run the command again, Eclipse may
be remembering your previous (and perhaps incorrect) settings. You can go to 'Run →
External Tools → External Tools Configurations...' to modify (and perhaps delete to
start over) the configuration Eclipse used to run the Ant build.

__16. In a Windows Explorer window, open the following folder and be sure you see a
number of Spring JAR files.

LY

C:\Software\jboss-as-7.1.1.Final\modules\org\springframework\spring\main

__17. From the Servers view of Eclipse start the JBoss 7.1 server.
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__18. After the server starts search for the 'JBoss Web Services' version as shown below.
This is probably about 1/3 of the way from the start of the messages.
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__19. Check that the CXF version 4.0.2.GA version is listed as shown above. This is the
same it was before.

Part 6 - Review

EV

__20. Stop the JBoss server and close all open files.

In this lab you installed JBoss Eclipse plug-ins for the rest of the labs. You could do
these steps in your own development environment after downloading the proper JBoss
Tools downloads. You also did several configuration steps that will let you work with
JBoss from Eclipse and access the administration console if required. You also saw how
to install a different version of JBoss Web Services in a JBoss server. Although we just
installed the Spring modules for later and used the same JBossWS-CXF version, you
could also download a different version in your own environment.
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Lab 2 - Introduction to Web Services
In this lab, you will review some of the key components of Web Services, namely, WSDL
and SOAP. You will also get a chance to see a Web Service in action. The goal of this lab
is to get yourself familiar with what a Web service looks like. We will not get into too
much detail at this point; just walk away with a basic understanding of the components
involved in a web service.
The web service in question is very simple. It has one operation called sayHello. It takes
as input a person's name (say "John") and returns as output a greeting message (say,
"Hello John").

Part 1 - Import the Project
To save time, the web service is already implemented. You will simply import it into
Eclipse for examination.

LY

__1. Make sure Eclipse is open in the workspace 'C:\workspace'.

N

__2. In Eclipse, choose File → Import from the menubar.

O

__3. Expand General. Select Existing Projects into Workspace.

N

__4. Click Next.

O

__5. Select the Select archive file radio button.
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__6. Click the Browse button and select the C:\LabFiles\TestWS.zip archive file and
click Open.

__7. Click Finish to import the project from the archive file. This project is a web
module project. This represents a WAR file in Java EE.
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Part 2 - Inspect the Implementation Class
The business logic for a Web Service is implemented in a Java class. The Java class may
be a plain class or a session EJB. In this case, we used a plain Java class in a web module.
We will briefly have a look at it.
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__1. In the Project Explorer view, expand the TestWeb project as shown below.
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__2. Double click HelloSvc.java to open it.

EV

__3. Have a quick look at the sayHello() method. Note the following:
●

By default, the Java method that implements a Web Service operation has the
same name as the operation.

●

The @WebService annotation is used to designate the HelloSvc class as a Web
Service implementation.

●

The @WebMethod annotation is used for the sayHello() method to designate it as
a Web Service operation. These annotations are made available as a part of the
JAX-WS specification.

__4. Close the Java file.
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Part 3 - Deploy the Project to JBoss Server
You can directly deploy a project to the JBoss server. Eclipse will automatically invoke a
build process which will produce a WAR file for the project and then the WAR file will
be deployed into the server. Once a project has been deployed to the server, Eclipse will
repeat the build-deploy cycle every time you make any change to the projects. This
makes development and unit testing quite easy.
__1. In the Servers view, right click JBoss 7.1 Runtime Server and select Add and
Remove...
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__3. Click Finish.
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__2. Select the TestWeb project and click the Add button.

__4. Start the JBoss server in the Servers view.
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__5. After several seconds, check the Servers view again and make sure that the Status
is Synchronized. That means, the code deployed to the server is same as what is in
Eclipse.
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Part 4 - Examine the WSDL File
A WSDL file is used to describe what a Web Service can do and what type of input and
output data it works with.
__1. Open a web browser to the following address which should bring up a security
prompt.
http://localhost:9990/console
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__2. In the security prompt, you may have to enter a username of 'admin' and a password
of 'jbo$$ee6'. You can check the option to remember the password if offered.
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Note: This should be the administration user you configured by running the 'add-user'
script in the development environment setup lab.
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__3. Check that you see the overview page of the administration console. If it doesn't
display try refreshing the page.

Note: Sometimes you might also see that the admin console page displays but the
HTML styles are not being applied. JBoss 7.1 seems to have trouble where sometimes
the stylesheet doesn't load properly. Refresh the page and hopefully the page will
display properly.
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__4. On the left side of the console, click the link for 'Deployments → Webservices'
which should be expanded and visible.
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__5. Check that you see the details of the 'HelloSvc' web service displayed. It may not be
obvious since we have only one web service but the top is a table that you could click
different rows of to show the details of a web service in the 'Selection' area below.
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__6. Open another browser tab or window to the 'WSDL URL' shown for the web
service (http://localhost:8080/TestWeb/HelloSvc?wsdl). You should see the XML
syntax of the WSDL of the deployed web service.

Note: Unfortunately the administration console does not present this as a link that you
could click so you would have to copy the URL into the browser.

LY

The <portType> element in WSDL describes the Web Service. Note that an <operation>
element exists with the name attribute set to "sayHello".

N

O

N

The <input> and <output> elements within <operation> describes the format of the input
and output data for the operation. We won't go any further to explore the WSDL at this
stage.

O

Part 5 - Invoke the Service

AT
I

We should now actually test the service. Testing the service would imply actually
invoking the operation.
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Typically, doing so would require that we create a web service client. A web service
client is, as its name implies, any program that makes a call to a web service. The
program could be written in Java, .NET, or any other language that understands web
service standards.
Writing a client can be time consuming, so we will “cheat” and use a tool built into
Eclipse called the Web Services Explorer (WSE). The WSE works by reading a WSDL
file and then figuring out what services are available and how to invoke them. The WSE
will then dynamically generate a form that represents the service's operations that will
allow you to invoke it.
Think about this for a moment: our service, at its core, was a single operation called
sayHello which took a single string as a parameter. The service would then return a
greeting based on that parameter.
__1. In the browser, where we viewed the WSDL, copy the URL address of the WSDL.
We will need this WSDL location to run the Web Services Explorer.
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__2. Back in Eclipse, launch the WSE. To do this, use the menu and select Run →
Launch the Web Services Explorer. This is probably at the bottom of the menu.
The WSE will open.

LY

Note: The JBoss Tools Eclipse plug-ins have a 'Web Service Tester' view but it is not as
easy to use as the Web Services Explorer so we won't use it.

N

__3. We need to point the WSE at our generated WSDL file. Locate the row of buttons in
the top right hand side of the WSE.
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__4. Click the second button from the right to switch the WSE to WSDL mode.
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The main Navigator of the WSE will change.

__5. Click WSDL Main in the Navigator pane.
In the Actions pane on the right, you will be prompted for a WSDL URL.
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__6. Paste the URL you copied earlier, which was:
http://localhost:8080/TestWeb/HelloSvc?wsdl

__7. Click Go.
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At this point, the WSE will read the WSDL file. It notices our sayHello operation.
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__8. Click the link for sayHello. WSE will create a form to enter the input data for the
sayHello operation.
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__9. Click the Add link to create a text box for the name parameter.
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Note: The WSE thinks that the name parameter is optional since its value may be null.
Subtleties such as these are captured in the XML schema for the input and output data
for the operation.
__10. Enter a name into the field and click Go.

Copyright 2013 Web Age Solutions Inc.

26

__11. Scroll down and look in the Status pane. If you have trouble seeing the response
you can double click on the title bar of the Status section to maximize the window.
This shows what the call to the web service returned.

In this case, it returns the String “Hello <name>”.

LY

Our web service invocation has worked!

N

Part 6 - Inspect the SOAP Messages
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When we invoked the sayHello operation, WSE actually sent a SOAP formatted XML
document to the server using the HTTP protocol. The server also replied back using a
SOAP formatted XML document. SOAP is a versatile data format for request response
type communication. In its most basic form, as is the case in this lab, it is utterly simple.
At the same time, it is capable of taking on more advanced aspects of communication,
such as, encryption, message signature, transaction and guaranteed delivery.
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__1. If it is not already maximized, double click on the title bar of the Status section to
maximize the window and have a better look of the information.
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__2. In the Status pane of WSE, click the Source link.
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__3. Briefly inspect the request and response messages as shown below. Don't worry
about the details. You will learn SOAP shortly.
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__4. Restore the Status window. You can do this by double clicking on the title bar of the
Status section.
__5. Close all open files.

__6. Stop the JBoss server.

Part 7 - Review
In this lab, you had a brief encounter with a Web Service. First, we looked at the Java
class that implements the business logic of the Web Service. That is the true meat behind
the Web Service. When building a Web Service, you will probably spend most of the time
writing the business logic. Next, we inspected the WSDL file that describes the nature of
the Web Service. After that we tested the Web Service and inspected the SOAP messages.
The lab also served two other purposes. You learned how to deploy an application to the
server. We will do that frequently throughout these lab exercises. You also found out how
to use the Web Services Explorer to quickly unit test a Web Service.
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Lab 3 - Creating an XML Schema
An XML schema is used to verify that the contents of an XML file are valid; essentially,
it is a set of “rules” for an XML file. A particular XML file can be checked against a
particular schema, and a parser can decide if the XML conforms to the rules set out in the
schema.
If, for some reason, the XML does not conform to the schema, the XML parser can reject
the XML and raise an immediate error. Essentially, schema adds a layer of validation to
any XML-based application. Given that web services use XML as their communication
layer, we can see the value of schema. Schema are actually used quite frequently in the
various layers of web service communication.
In this lab, we will create an XML schema.

Part 1 - The Movie.xml File

N
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Throughout these labs, we will be developing a system that deals with movies. We have
thus decided to model a movie as an XML file. This modeling will come in handy when
we start building the web service.
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__1. Let us start things off by taking a look at a sample movie.xml file. Using a text
editor, open file C:\LabFiles\movie.xml
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It looks like the following:
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<?xml version="1.0" encoding="UTF-8"?>
<m:database xmlns:m="http://www.mycom.com/movie">
<movie title="Preaching to the Choir" rating="PG13">
<description>
Two estranged brothers -- one a hip-hop star and
the other a Baptist preacher -- find a way
to make amends and help one another out as
they each face a crisis in their lives.
</description>
<actor>Billoah Greene</actor>
<actor>Novella Nelson</actor>
</movie>
<movie title="Kekexili: Mountain Patrol" rating="PG13">
<description>
A moving true story about volunteers protecting
antelope against
poachers in the severe mountains of Tibet.
</description>
<actor>Zhang Lei</actor>
<actor>Qi Liang</actor>
</movie>
</m:database>
<!-- Contains some copyrighted material from imdb.com -->
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Let us analyze this XML file.
The outermost element is called <database> and it contains multiple <movie> elements.
Each <movie> has two attributes; one called title and one called rating, which reflects a
movies title and rating respectively.
Additionally, each <movie> has a single child element called <description> (which
contains a description of the movie in question) and multiple elements called <actor>,
with each one representing an actor in the associated movie.
This is a fairly simple modeling of the movie. We capture some important information
about each movie (the title, the description, the rating and the actors), and store this
information using a mixture of attributes and child elements.
What we should do now is formalize this model by creating an schema for the
<database> element (remember that the root element here is <database>, not <movie>).

LY

Once that is done, an application reading/writing one of these movie XML files will be
able to use the schema to validate that the structure of the XML is good. (Validating the
content of the XML, however, is another matter completely).
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__2. Close the text editor.
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Part 2 - Create the Project
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A schema is itself an XML file, and we could create it using a text editor. However,
Eclipse provides some nice tools for creating a schema, so we will use those instead.
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__1. Start Eclipse if it is not already running.
__2. Stop the server if it is running.
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__3. Close any open editor windows. (Ctrl-Shift-W)
__4. We will now create a new project to hold our schema file. From the Eclipse menu
bar, select File | New | Project...
The New Project window will appear.
__5. In the list, select Java Project and click Next.
The New Java Project screen will appear.
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__6. Set the Project name to be XMLProject and click Finish.
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__7. Eclipse will then prompt you if you would like to switch to the Java Perspective.
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__8. Check Remember my decision and click No.
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The XMLProject project will be created and listed in the Project Explorer view. (You
may want to minimize all other projects – e.g. TestWeb in the Project Explorer to keep
things a little easier to read)

We should create a folder to hold our XML resources.
__9. Right-click on the newly created XMLProject and select New | Folder.
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__10. The New Folder window will appear. Set the Folder name to be xml and click
Finish.
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The folder will be created, and should be visible under the project.

Part 3 - Create the Schema
We can now create the schema.
__1. Right click on the newly created xml folder and select New | Other...
The New window will appear.
__2. Scroll down and expand XML.
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__3. Select XML Schema and click Next.
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__4. The Create XML Schema window will appear. Set the File name to be movie.xsd
and click Finish. (By convention, schemas always have an XSD extension)
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The XML Schema Editor will open. This is Eclipse's graphical XSD schema editor. This
will save us having to create the schema by hand.
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We will be using this editor to design our schema.
First, we should change the schema's default name space which is currently set to
http://www.example.org/movie as can be seen at the top of the editor.
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__5. Right-click anywhere on the opened schema editor and select Show properties.
Now, at the bottom of Eclipse, the Properties view should have opened.

__6. Here, change the Prefix to m
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__7. Change the Target namespace to http://www.mycom.com/movie
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We should also specify that by default, the namespaces are not qualified.
__8. Click the Advanced tab on the left of the Properties view.
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__9. Change the Prefix for elements drop down to a blank.

__10. Save changes by hitting Ctrl-S.
The editor should update with the new namespace.
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We can now go about defining the types that make up this schema. The core type
represents the movie data, which we will call the movieType. (The other type is the
<database>, which is composed of multiple movieType elements – we will get to that
later). We will also define a simple type for the rating since that is a choice of specific
values and we can use the restrictions available with XML schema.
We will start by defining the simple type for the rating since that is used by the movie
type. That way when we define the movie type it will already be available.
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__11. Right click inside the Types pane and select Add Simple Type.
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__12. A new type will appear. Change its name to ratingType by typing a new name and
hitting <Enter> to accept the new name.
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Note: If the name is no longer selected to change you might need to right click it and
select Refactor → Rename.
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The type has been defined. We now need to specify what data it contains.
__13. Double click on the newly created ratingType.
The view will change to a closeup of the ratingType.
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__14. Right click an empty area and select Show Properties and check that the basic
properties of the simple type show up in the Properties view. The 'Base type' is string
which is fine for us but might be one thing that is changed for data that is better qualified
as another data type.
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__15. Click the Constraints tab on the left of the Properties view.
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__16. Scroll to the far right of the view and click the second 'Add...' button in the
'Specific constraint values' section.
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__17. In the dialog that appears, enter 'G,PG,PG13,R' making sure there are commas and
no spaces between the values.

Note: If you click the wrong 'Add' button you will not get this useful dialog. If that
happens delete the single entry that was added by using the 'Delete' button and then click
the correct 'Add...' button.
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__18. Check that your constraint values listed appear as shown below.
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__19. Go back to the main schema design page by clicking the icon in the top left corner.
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Next we will define the movieType. Recall that we want the movieType to model
rating, description, title and multiple actors as a combination of attributes and elements.
__20. Right click inside the Types pane and select Add Complex Type.
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__21. A new type will appear. Change its name to movieType by typing a new name and
hitting <Enter> to accept the new name.
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Note: If the name is no longer selected to change you might need to right click it and
select Refactor → Rename.
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The type has been defined. We now need to specify what data it contains.
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__22. Double click on the newly created movieType.
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The view will change to a closeup of the movieType.

It is from here that we can add elements/attributes. Let us add the description element
first.
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__23. Right-click on the movieType and select Add Element.
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__24. A new element box will appear. Rename it to description and hit <Enter> when
you have supplied the new name.
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Notice that the type for description was automatically set to string. This is fine because
we want our description modeled as a string.
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We have now just declared that our schema defines a type called movieType which itself
has an element called description of type string.
Now, we can add the actor element.

AL
U

__25. Right click on movieType and again select Add Element.
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__26. This time, name it actor

Recall however, that our movie should have one or more actor elements associated with
it. We can specify that here in the schema by using multiplicity
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__27. Right click on the actor element and select Set Multiplicity | 1..* (One or more)
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When you do this, the diagram should update to show the 1..* notation, which means “1
or more”. You might need to click in an open area of the editor for the view to show the
[1..*] notation.
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Now we can add the rating and title attributes.
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__28. Right click on movieType and select Add Attribute. Note this is an attribute and
not element.

__29. Name the attribute title and hit <Enter> to accept the attribute name.
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__30. Repeat this step and add another attribute called rating
We need to change the type of the rating attribute though to use the simple type defined
earlier.
__31. Double click on string next to the 'rating' attribute and a drop-down box should
appear.
__32. Select Browse... from the drop-down box.

The Set Type window will appear.

__34. Click OK.
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__33. In the Name field, enter ratingType (or scroll through the list and select it)

EV

The movieType element should now look like this.

As discussed earlier, a movieType has attributes for title and rating and elements for
description and multiple actors. (All of these are of type string, except the rating).
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We now need to define a database element that contains multiple instances of this
movieType.
__35. Go back to the main schema design page by clicking the icon in the top left corner.
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__36. Back at the main schema page, the movieType and ratingType should be shown.
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__37. Right click in the Elements pane (on the left) and select Add Element.
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__38. Name it database

Let us now define that a database is composed of multiple movie elements. We will do
so using an anonymous type.
__39. Right click on database and select Set Type | New...
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The New Type window will appear.
__40. Check Create as local anonymous type. This will grey out the Name field.
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__41. Click OK.
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Seemingly, nothing will change.
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__42. Double click on database.

We see that the database element points to something called a (database type). This is
an anonymous field, which means is basically just a placeholder for another element type
– like our movie! (Using anonymous types can simplify schema).
We should now specify that the (databaseType) points to multiple movie elements.
__43. Right click on (databaseType) and select Add Element.
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__44. A new element will be created. Name the element movie and hit <Enter> to accept
the new name.
__45. We know there are multiple movies, so we should set the multiplicity. Right click
on movie and select Set Multiplicity | 1..* (One or more). You may need to click
somewhere blank once the multiplicity is set to show the [1..*] syntax.

One more thing. We have to set the type of each movie element to be movieType.
__46. Double click on string next to movie and a drop-down box should appear.
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__47. Select Browse... from the drop-down box.
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The Set Type window will appear.

__48. In the Name field, enter movieType (or scroll through the list and select it)

__49. Click OK.
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The editor will now show the association between the <movie> element and the
movieType.

We are done!
__50. Hit Ctrl-S to save changes.
We have completed creating the schema.

Part 4 - Examine the Schema
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We have now successfully created a schema using the Eclipse schema editor tool. The
tool generated all the necessary code for us; let us take a look at it now.

O

N

__1. Click the Source tab at the bottom of the schema editor. The raw source code
forming the schema will be displayed. It should look like the following:
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<?xml version="1.0" encoding="UTF-8"?>
<schema targetNamespace="http://www.mycom.com/movie"
xmlns="http://www.w3.org/2001/XMLSchema"
xmlns:m="http://www.mycom.com/movie">
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<simpleType name="ratingType">
<restriction base="string">
<enumeration value="G"></enumeration>
<enumeration value="PG"></enumeration>
<enumeration value="PG13"></enumeration>
<enumeration value="R"></enumeration>
</restriction>
</simpleType>
<complexType name="movieType">
<sequence>
<element name="description" type="string"></element>
<element name="actor" type="string" maxOccurs="unbounded"
minOccurs="1">
</element>
</sequence>
<attribute name="title" type="string"></attribute>
<attribute name="rating" type="m:ratingType"></attribute>
</complexType>
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<element name="database">
<complexType>
<sequence>
<element name="movie" type="m:movieType"
maxOccurs="unbounded" minOccurs="1">
</element>
</sequence>
</complexType>
</element>
</schema>

Notice that the schema itself is written in XML.
__2. Go through it and mentally understand what is being described here.
We state that a database is composed of 1 or more movie elements. Each movie element
is of type movieType.
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A movieType is composed of elements representing description and 1 or more actor,
and attributes representing the title and rating.
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If you compare this with the movie.xml we examined at the start of this lab, you should
realize that movie.xml indeed conforms to the rules set out in the schema.

Part 5 - Review
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__3. Close the schema editor.
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Now, when an XML parser reads movie.xml, it can automatically check with this xsd to
ensure it is valid. We will use this schema in later labs in exactly this manner.
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In this lab, you examined XML schema.
We started off by examining an XML file that gave us an idea of how to represent a
movie.
We then created a schema that to formalize these rules of representation. We used the
Eclipse schema editor to create the XML file and in there defined the various elements
and attributes that should make up a movie database.
Finally, we examined the raw XML source behind the schema to get a feel for what it
describes, and saw that it indeed validates the movie.xml that we started off with.
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