
WA2214 Mastering JAX-RS REST
Web Services and AJAX Clients -

JBoss / Eclipse

Student Labs

Web Age Solutions Inc.

1

EVALUATIO
N O

NLY



Table of Contents
Lab 1 - Setup the Development Environment......................................................................3
Lab 2 - Develop a Simple RESTful Service......................................................................16
Lab 3 - Extracting Information from a HTTP Request......................................................23
Lab 4 - Designing a RESTful Service................................................................................30
Lab 5 - Add Support for XML Format...............................................................................37
Lab 6 - Add Support for JSON..........................................................................................46
Lab 7 - Build the Order Web Service.................................................................................52
Lab 8 - Complete the Order Service..................................................................................62
Lab 9 - Developing a JAX-RS Client................................................................................72
Lab 10 - Introduction to AJAX..........................................................................................81
Lab 11 - Making POST Requests.......................................................................................93
Lab 12 - Basic DOM API...................................................................................................99
Lab 13 - AJAX Client using XML  .................................................................................104
Lab 14 - AJAX Client Using JSON.................................................................................112
Lab 15 - Securing JAX-RS REST Services.....................................................................115
Lab 16 - AJAX Client Security........................................................................................127

2

EVALUATIO
N O

NLY



Lab 1 - Setup the Development Environment
In this lab you will setup the environment for developing Web Services for JBoss.  This 
includes installing JBoss Eclipse plug-ins.

Part 1 - Verify Java Install
Since this course uses Java 7, which is still relatively new, you will do a few quick steps 
just to verify everything is setup properly.  Java 7 should have been installed as part of 
the class setup but these steps will help verify and avoid other issues later when they are 
harder to debug.

__1. Open a Windows command prompt.  You can usually do this on most versions of 
Windows by selecting 'Start → Programs → Accessories → Command Prompt'.

__2. Run the following command and make sure you get a Java “1.7.x” version.  If you 
do not see this, the next steps will help figure out what setting is incorrect.  Also, if you 
get an error about java not being “recognized” as a command the next steps will help 
figure out why.

java -version

__3. Run the following command to see the current value of the 'PATH' environment 
variable.  Check that you see the 'bin' directory of a Java 1.7 installation in the PATH.  If 
you do not see Java 1.7 or if you see multiple versions of Java referenced this could be 
causing errors.

set PATH

Note: Your actual value may be slightly different but it should be obvious that it is a 
Java (or “JDK”) 1.7 version.
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__4. Run the following command and look at the value of the 'JAVA_HOME' 
environment variable. Make sure that it points to the root directory of a Java 1.7 
installation.  If you get a message about 'JAVA_HOME' not being defined this could also 
cause issues.

set JAVA_HOME

Note: Your actual value may be slightly different but it should be obvious that it is a 
Java (or “JDK”) 1.7 version.

__5. If you have not seen output similar to that shown in the previous steps, inform your 
instructor.  They can help determine if all students have the same (or similar) issue and 
the best way to fix it so it won't cause problems later.

__6. Close the command prompt.

Part 2 - Install JBoss Eclipse Plug-ins
Besides allowing us to use JBoss as a test server, the "JBoss Tools" Eclipse plug-ins have 
a few tools specific to web services.  This section will install those tools.  This was not 
done as part of the class setup because the steps are a little more involved.  It will also be 
good for you to know how to install these tools if you want to obtain them for your own 
environment from:

http://www.jboss.org/tools/download

The JBoss Tools version you will use has already been downloaded and is compatible 
with the Eclipse version you are using.

__1. Start Eclipse by launching C:\Software\eclipse\eclipse.exe

Eclipse will launch.

You will be prompted to select a Workspace. 

__2. Set the Workspace to C:\workspace
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__3. Click OK.

Eclipse will start. 

__4. Eclipse may be displaying the Welcome screen.  Close the welcome screen by 
clicking the x in its tab.  

__5. From the Eclipse menus select Help → Install New Software...

Note: If you get an error about some sites not being found it is because Eclipse can't 
connect to the Internet.  Since you will be provided with a local copy of the updates you 
can ignore this error and click 'OK'.

__6. Click the Add button on the upper right to add a new update site.

__7. Click the Archive... button.

Note: You are using this option since the JBoss Tools are provided as a single Zip file 
with the class software.
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__8. In the dialog to choose a file, find and open the file 
'C:\Software\JBoss Tools\jbosstools-4.0.1.Final....zip'.  The end of the file name is not 
given as it may change but this should be the only Zip file which starts with that name at 
that location.

__9. Once you have chosen the appropriate Zip file, give the update site a name of 'JBoss 
Tools Archive' and press the OK button when your options are similar to that shown 
below.

__10. In the list of available features expand the 'Abridged JBoss Tools 4.0' category and 
check ONLY the 'JBoss WebServices Tools' and the 'JBossAS Tools' options as shown 
below and press the Next button.

Note: Although JBoss Tools has other tools available we will only use these tools for the 
labs.
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__11. You will see a list of software that will be installed as shown below.  There should 
be no checkboxes next to any features.  Press the Next button.

__12. On the 'Review Licenses' screen, select the radio button in the lower right labeled 
'I accept the terms of the license agreements' and press the Finish button.  This will 
begin installing the software.

__13. Leave the dialog box that appears running so that you can see when the installation 
process completes.

__14. When you get a prompt about unsigned plugins click the OK button.
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__15. Once the installation is complete you will get a prompt to restart Eclipse.  Press the 
Yes button to restart.

__16. Open Eclipse in the same workspace when it restarts.

__17. Click No if the JBoss Tools Usage dialog opens.

Part 3 - Configure JBoss Test Server in Eclipse
Now that the JBoss Eclipse tools are installed the next step is to define a JBoss test 
server.  This will let you deploy and test applications directly from Eclipse.

__1. Click on the Servers view located in the bottom of the Eclipse window.

__2. Right click in the empty area and select New -> Server.

__3. From the list expand JBoss Community and select JBoss AS 7.1
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__4. Click Next.

__5. Click the first Browse button next to Home Directory and navigate to 
C:\Software\jboss-as-7.1.1.Final and then click OK.  Stay on the same page in the main 
wizard.

__6. For the JRE option use the drop-down to select the JDK 1.7 that is installed.

__7. Click Finish once your dialog matches the settings shown below.

__8. The new server will appear in the Servers list.

__9. Right click on the Server and select Open.
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__10. The configuration page of the Server will open.

__11. Expand Publishing on the right side.

__12. Select Never publish automatically.

__13. At the bottom of the Eclipse server configuration editor click the 'Deployment' tab.
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__14. Check the 'Deploy projects as compressed archives' option.

Note: This option is generally best to allow rapid deployment and testing of changes 
made in Eclipse.  The default settings would deploy an “exploded” archive.  Even 
though modifying and publishing an updated Java class would recompile the .class file 
copied to the server, the application would not be restarted and the previous version of 
the class loaded by the server would still be used.

By deploying a compressed archive, any change to any file in that project would recreate 
the entire archive and cause the entire application to be redeployed.  This would 
guarantee the most recent code is being used.  Since JBoss deployment is very quick, 
this method is preferred to avoid any confusing behavior where code changes have not 
been picked up by the server.

__15. Save the changes and close the window.

__16. In the Servers view, right click the 'JBoss 7.1 Runtime Server' and select Start.  

__17. Click the tab for the Console view and scroll back to find the message about JBoss 
Web Services starting.  Notice that it is using the “CXF Stack” from Apache CXF.  This 
will be important in advanced web service features in later labs.
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__18. Check that the server starts successfully.  You may need to switch back to the 
Servers view.

__19. Leave the server running for the next section.

Part 4 - Configure JBoss Management User
By default the web administration console of JBoss is secure but doesn't have any users 
configured.  This effectively locks it down until you configure users to access it.  Since 
several labs may need to go into this administrative console to perform various tasks, this 
section will enable an administrative user.

__1. Open a Windows command prompt.  You can usually do this on most versions of 
Windows by selecting 'Start → Programs → Accessories → Command Prompt'.

__2. Use the following 'cd' command to switch to the JBoss 'bin' directory.

cd C:\Software\jboss-as-7.1.1.Final\bin

__3. Run the following 'add-user' command to start the interactive tool to add a user. 
How to respond to various prompts is given in the next steps.

add-user

__4. On the first prompt, hit the <ENTER> key to accept the default option of 'a' to 
create a “management user”.
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__5. On the second prompt, hit the <ENTER> key to accept the default option of 
'ManagementRealm' for the security realm.  This is the name of the security realm 
already defined in the JBoss server so using this ensures we do not have to change any 
other JBoss configuration.

__6. Enter a username of 'admin'.

__7. Type the following password for both prompts that ask you to enter a password. 
Note that the program will not even show stars while you type.

jbo$$ee6

Note: This version of the tool requires a password that is at least 8 characters and has 
one number and one non-alphanumeric character.

__8. Type 'yes' to accept the username 'admin' since it is “easy” to guess.

__9. Type 'yes' to confirm you want to add the 'admin' user to the 'ManagementRealm'.

__10. Hit any key to let the program finish and return you to the command prompt.

__11. Close the command prompt.
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__12. Go back to the Servers view in Eclipse and make sure your JBoss server is 
running.  Start it if it is not.

__13. Open a web browser to the following address which should bring up a security 
prompt.

http://localhost:9990/console

__14. In the security prompt, enter a username of 'admin' and a password of 'jbo$$ee6'. 
You can check the option to remember the password if offered. Click OK.

__15. Check that you see the overview page of the administration console.  If it doesn't 
display try refreshing the page.
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Note: If you get an authentication error it may be because somehow the password you 
entered in the browser is different than what you configured in the script tool.  If you 
can't provide the correct password you can run the 'add-user' tool again but you first 
have to manually delete some lines from two text files.

Find the following two text files, open them with a text editor like WordPad, and delete 
the line that starts with 'admin=...' without a leading '#' as a comment.

C:\Software\jboss-as-7.1.1.Final\domain\configuration\mgmt-users.properties

C:\Software\jboss-as-7.1.1.Final\standalone\configuration\mgmt-users.properties

You need to delete this line from both files because even though your configuration is 
only looking at the 'standalone' properties file, you can't run the 'add-user' tool again 
with the same user if it already exists in either one of these files.

__16. Close the browser you are using to access the administration console.

__17. Stop the server in the Eclipse Servers view.

Part 5 - Review
In this lab you installed JBoss Eclipse plug-ins for the rest of the labs.  You could do 
these steps in your own development environment after downloading the proper JBoss 
Tools downloads.  You also did several configuration steps that will let you work with 
JBoss from Eclipse and access the administration console if required.  You also saw how 
to install a different version of JBoss Web Services in a JBoss server.  Although we just 
installed the Spring modules for later and used the same JBossWS-CXF version, you 
could also download a different version in your own environment.
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Lab 2 - Develop a Simple RESTful Service
Over the next few labs, our goal will be to learn the fundamentals of the JAX-RS API. 

In this lab, we will develop a very simple RESTful web service. This will let us focus on 
the development process using eclipse and the JBoss server. We will also learn about the 
basic JAX-RS annotations.

The main goal of this lab is to understand how to create a web service project and 
develop a few basic REST services.

Part 1 - Create the Web Service Project
In eclipse, the project to use to develop JAX-RS services is just a regular “Dynamic Web” 
project.  When you target a server, the JAR files for the JAX-RS API are already on the 
classpath.

__1. From the menubar, select File > New > Dynamic Web Project.

__2. Enter AcmeWeb for the Project name.

__3. At the bottom of the window, in the EAR Membership section, click the button 
marked New Project....  (We will want to add this WAR file into an EAR file)

The New EAR Application Project screen will appear.

__4. Set the Project name to AcmeApp and make sure the target server is JBoss.

__5. Click Finish to create the EAR project

You will be returned to the New Dynamic Web Project screen.
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Your screen should now look like the following:

__6. Click Finish.  Both the EAR and the WAR will be created.  If prompted, don't 
switch to the web perspective by clicking No.

We will briefly review the project.

__7. Right click the newly created AcmeWeb project and select Properties.

__8. Now, select the Project Facets property.

__9. Note that the JAX-RS facet is not selected. This facet plays no role in developing 
JAX-RS services.

__10. Click Cancel to close the dialog.

17

EVALUATIO
N O

NLY



Part 2 - Register the REST Application
There are a few different ways to configure a REST application.  This can depend on if 
you want a common URL prefix for all REST services.  This might be useful if you have 
REST services within a project with other web components.  If you want to register a 
common URL prefix you can do so in a web.xml file.  To save time, this file is given to 
you. You will simply import it.

__1. Open Windows file explorer.

__2. Go to C:\LabFiles\

__3. Copy web.xml

__4. In eclipse, paste the file inside the WebContent > WEB-INF folder of AcmeWeb.

__5. Open web.xml and study how the REST application is configured. Switch to the 
Source view and specifically, note the servlet mapping:

    <servlet-mapping>
        <servlet-name>javax.ws.rs.core.Application</servlet-name>
        <url-pattern>/svc/*</url-pattern>
    </servlet-mapping>

This means, the URL for every REST request will start with 
http://host:port/AcmeWeb/svc/. You can choose any other path for the REST application. 
But, we will stick to the short and sweet "svc".

__6. Close the file.
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Part 3 - Create the Resource Class
The Java class that implements a RESTful service is called a resource. We will now 
develop a Java class for a simple service.

__1. Right click AcmeWeb project and select New > Class.

__2. Enter com.acme.services as the package name and SimpleService as the class 
name.

__3. Click Finish to create the new class.

__4. Add a member variable that will help us do logging.

public class SimpleService {
Logger logger = Logger.getLogger("SimpleService");

__5. Organize imports (Control+Shift+O) and select java.util.logging.Logger.  Make 
sure you select the correct class as there are several 'Logger' classes on the classpath.

We will now add the testGET() method. It will not have any business logic. Later, we will 
map this method to a GET request.

__6. Add the method as follows.

public String testGET() {
logger.info("Got a GET request");
return "OK";

}

__7. Save changes.
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Part 4 - Configure the Resource
We will now configure the URI and HTTP method for the service resource and its 
methods. We will use the "/simple" root URI for the service.

__1. Define the URI of the root resource, by adding the @Path annotation above the 
class. 

@Path("/simple")
public class SimpleService {

The testGET() method does not need any path extension. All we have to do is set GET as 
the HTTP method. 

We will also set "text/plain" as the content MIME type of the reply. That is good enough 
for this method. For XML data type, the MIME will be "text/xml".

__2. Set the HTTP method and reply MIME type for the testGET() method sub-resource 
as follows.

@GET
@Produces("text/plain")
public String testGET() {

__3. Organize imports. Select javax.ws.rs.Produces.

__4. Save changes.

Part 5 - Unit Test
We will now exercise the web service from a browser.

__1. Start the server.

__2. Right click the server and select Add and Remove.

__3. Add the AcmeApp project to the server.

__4. Click Finish.

__5. Right click the server and select Publish. Do this every time you are requested to 
Publish the server.
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__6. Open a web browser and enter the URL: 

http://localhost:8080/AcmeWeb/svc/simple/

__7. You should see OK in the browser.

__8. The Console view will show the log output.

This proves that our project has been setup correctly and JAX-RS is working fine.

Part 6 - Use Path Extension for Sub-resource
A sub-resource – Java method – can be mapped to an URI extension path. Any HTTP 
request for that path will be handled by that method. We will now create a method that 
will respond to the /simple/mypath URI.

__1. First, add this method to the SimpleService class.

public String testGETWithPath() {
logger.info("Got a GET request with path extension.");
return "OK";

}

__2. Annotate the method as follows.

@GET
@Produces("text/plain")
@Path("/mypath")
public String testGETWithPath() {

__3. Save changes.
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Part 7 - Unit Test
__1. Right click the server and select Publish.

__2. In a web browser, enter the URL: 

http://localhost:8080/AcmeWeb/svc/simple/mypath

__3. Make sure that the Console shows the log output.

__4. Open a new browser or tab and re-test the testGET method for regression using the 
URL: 

http://localhost:8080/AcmeWeb/svc/simple/

__5. Close all browsers.

__6. Close all open files.

Part 8 - Review
In this lab, we created and configured a web service project. We created a very simple 
JAX-RS web service. At this point, you should know how to configure the URI of the 
root resource – the Java class - using the @Path annotation. Also, we configured the 
HTTP method of a sub-resource – a method – using the @GET annotation.
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Lab 3 - Extracting Information from a HTTP Request
RESTful services are executed by sending HTTP requests. The request contains input 
data in various areas:

1. In the URI path. For example: /orders/1051.

2. As URL parameters. For example: /orders?status=P

3. Input data from a form submission.

4. Less commonly, from HTTP header and cookie.

We will now learn how to extract data from common locations.

Part 1 - Get Root Resource Path Parameters
Input data can be added to the path of the root resource as well as the path of a method 
(sub-resource). In REST, data is added to the URI to form an unique identifier.

First, we will add an input parameter in the root path of the SimpleService resource. The 
root URI will now look like /simple/somedata. The root URI will continue to execute the 
testGET() method since this method defines no path extension. To execute the 
testGETWithPath(), the URI will need to be /simple/somedata/mypath.

__1. Open SimpleService.java from the AcmeWeb project.

__2. Change the @Path annotation for the class and add a parameter there.

@Path("/simple/{myRootPathData}")
public class SimpleService {

Here, {myRootPathData} is a placeholder for a parameter. You can use anything as a 
name of the parameter. The name will play a role to obtain the value of the parameter.

The best place to capture input from a root path is a member variable of the resource. We 
will do that now.

__3. Add a member variable as follows.

public class SimpleService {
String rootPathData;
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__4. Annotate the member variable to save the value of the myRootPathData parameter.

@PathParam("myRootPathData")
String rootPathData;

That's it. Now, JAX-RS will extract the value of the parameter from the URI and set it to 
the member variable right after the resource object is created. By default, a POJO 
resource instance is created for every HTTP request. Hence, every request can have a 
different parameter value in the path.

__5. Organize imports.

__6. Change the log statement of the testGET() method as follows.

logger.info("Got a GET request with root path data: " + rootPathData);

__7. Make a similar change to the testGETWithPath() method.

logger.info(
    "Got a GET request with path extension with root path data: " +
    rootPathData);

__8. Save changes.

Part 2 - Unit Test
__1. Publish the server.

__2. First, test the testGET() method by entering the URL: 

http://localhost:8080/AcmeWeb/svc/simple/somedata/ 

__3. The log output will like this:

Got a GET request with root path data: somedata

__4. Now, test the testGETWithPath() method using the URL: 

http://localhost:8080/AcmeWeb/svc/simple/somedata/mypath
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__5. The log output will be:

Got a GET request with path extension with root path data: somedata

Part 3 - Get Sub-resource Path Parameters
Methods can also let us add parameters to its path. For example to get the billing address 
of an order #1051, we can use the URI: /orders/1051/address/billing. Never lose sight of 
the fact that a URI uniquely identifies an entity or a collection of entities. In this example, 
we are specifically pointing to the billing address used with an order. Here, the orderId as 
well as the type of address requested can be added as parameters to the path of the sub-
resource. Let's try out this example.

__1. Add a basic method as follows.

public String getAddress(
int oId, 
String type) {
logger.info("Order Id: " + oId);
logger.info("Address type: " + type);

return "OK";
}

__2. Annotate method with path and method.

@GET
@Produces("text/plain")
@Path("/{orderId}/address/{addressType}")
public String getAddress(

__3. Now, extract the path parameters and save them in the two input argument variables 
of the method.  The syntax for the @PathParam annotation on a method parameter is 
tricky so be careful.

public String getAddress(
@PathParam("orderId")
int oId, 
@PathParam("addressType")
String type) {

__4. Save changes.
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__5. Publish the server.

__6. Test the method by entering the URL: 

http://localhost:8080/AcmeWeb/svc/simple/somedata/1051/address/billing

Part 4 - Extract Query Parameters
Query parameters are available from the requested URI as:

GET /path?param1=value&param2=value2 HTTP/1.1

You can capture them either using resource class member variable or method argument 
variable. The latter is generally recommended for better code readability. We will try that 
out now.

__1. Add the giveRaise() method as shown below.

@GET
@Produces("text/plain")
@Path("raise")
public String giveRaise(
    @QueryParam("name")
    String employeeName,
    @QueryParam("amount")
    double amount
    ) {
    logger.info("Giving raise to " + employeeName + " by " + amount);

    return "OK";
}

__2. Organize imports.

__3. Save changes.
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__4. Publish the server.

__5. Test the change by entering the URL: 

http://localhost:8080/AcmeWeb/svc/simple/somedata/raise?name=Daffy&amount=10000

__6. Make sure that the Console shows:

Giving raise to Daffy by 10000.0

Note, how JAX-RS converted the amount URL parameter from text to double.

Part 5 - Extracting Form Post Data
Form data is available in the HTTP request body. The data is encoded using MIME type 
application/x-www-form-urlencoded. Usually, such data is submitted using the POST 
method. 

Note: The Java EE Servlet specification does not distinguish between URL query 
parameter and POST data in HTTP request body. They are both accessed using 
request.getParameter() method. JAX-RS, however, makes a distinction. Query parameter 
can be accessed using @QueryParam. Form POST data has to be accessed using 
@FormParam.

We will now build a service method that will accept input from the form above.
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__1. Add this method.

@POST
@Produces("text/plain")
@Path("feedback")
public String submitFeed(
        @FormParam("interest")
        List<String> interestList,
        @FormParam("comments")
        String comments
    ) {
    for (String interest : interestList) {
        logger.info("Interest: " + interest);
    }
    logger.info("Comments: " + comments);

    return "OK";
}

Note that the HTTP method is set to POST. Also, we expect multiple values for the 
"interest" parameter. That is why we have set the data type of the variable to 
java.util.List<String>.

__2. Organize imports. Select  java.util.List.

__3. Save changes.

Part 6 - Unit Test
__1. We will import the form HTML page. Copy C:\LabFiles\post.html and paste it 
inside the WebContent folder of the AcmeWeb project.

__2. In the Servers view, right click the server and select Publish.
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__3. Open a browser and enter the URL: 

http://localhost:8080/AcmeWeb/post.html

__4. Fill out the form and submit it. 

__5. Make sure that the console log shows the input values correctly.

__6. Close all open files.

__7. Close all open browsers.

Part 7 - Review
In this lab, we learned how to gather input data from a couple of common sources:

1. URI path of the root resource

2. URI path of the method sub-resource.

3. URL query parameter.

4. Form POST data.
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	__9.  Once you have chosen the appropriate Zip file, give the update site a name of 'JBoss Tools Archive' and press the OK button when your options are similar to that shown below.
	__10.  In the list of available features expand the 'Abridged JBoss Tools 4.0' category and check ONLY the 'JBoss WebServices Tools' and the 'JBossAS Tools' options as shown below and press the Next button.
	__11.  You will see a list of software that will be installed as shown below.  There should be no checkboxes next to any features.  Press the Next button.
	__12.  On the 'Review Licenses' screen, select the radio button in the lower right labeled 'I accept the terms of the license agreements' and press the Finish button.  This will begin installing the software.
	__13.  Leave the dialog box that appears running so that you can see when the installation process completes.
	__14.  When you get a prompt about unsigned plugins click the OK button.
	__15.  Once the installation is complete you will get a prompt to restart Eclipse.  Press the Yes button to restart.
	__16.  Open Eclipse in the same workspace when it restarts.
	__17.  Click No if the JBoss Tools Usage dialog opens.

	Part 3 -  Configure JBoss Test Server in Eclipse
	__1.  Click on the Servers view located in the bottom of the Eclipse window.
	__2.  Right click in the empty area and select New -> Server.
	__3.  From the list expand JBoss Community and select JBoss AS 7.1
	__4.  Click Next.
	__5.  Click the first Browse button next to Home Directory and navigate to C:\Software\jboss-as-7.1.1.Final and then click OK.  Stay on the same page in the main wizard.
	__6.  For the JRE option use the drop-down to select the JDK 1.7 that is installed.
	__7.  Click Finish once your dialog matches the settings shown below.
	__8.  The new server will appear in the Servers list.
	__9.  Right click on the Server and select Open.
	__10.  The configuration page of the Server will open.
	__11.  Expand Publishing on the right side.
	__12.  Select Never publish automatically.
	__13.  At the bottom of the Eclipse server configuration editor click the 'Deployment' tab.
	__14.  Check the 'Deploy projects as compressed archives' option.
	__15.  Save the changes and close the window.
	__16.  In the Servers view, right click the 'JBoss 7.1 Runtime Server' and select Start.  
	__17.  Click the tab for the Console view and scroll back to find the message about JBoss Web Services starting.  Notice that it is using the “CXF Stack” from Apache CXF.  This will be important in advanced web service features in later labs.
	__18.  Check that the server starts successfully.  You may need to switch back to the Servers view.
	__19.  Leave the server running for the next section.

	Part 4 -  Configure JBoss Management User
	__1.  Open a Windows command prompt.  You can usually do this on most versions of Windows by selecting 'Start → Programs → Accessories → Command Prompt'.
	__2.  Use the following 'cd' command to switch to the JBoss 'bin' directory.
	__3.  Run the following 'add-user' command to start the interactive tool to add a user. How to respond to various prompts is given in the next steps.
	__4.  On the first prompt, hit the <ENTER> key to accept the default option of 'a' to create a “management user”.
	__5.  On the second prompt, hit the <ENTER> key to accept the default option of 'ManagementRealm' for the security realm.  This is the name of the security realm already defined in the JBoss server so using this ensures we do not have to change any other JBoss configuration.
	__6.  Enter a username of 'admin'.
	__7.  Type the following password for both prompts that ask you to enter a password. Note that the program will not even show stars while you type.
	__8.  Type 'yes' to accept the username 'admin' since it is “easy” to guess.
	__9.  Type 'yes' to confirm you want to add the 'admin' user to the 'ManagementRealm'.
	__10.  Hit any key to let the program finish and return you to the command prompt.
	__11.  Close the command prompt.
	__12.  Go back to the Servers view in Eclipse and make sure your JBoss server is running.  Start it if it is not.
	__13.  Open a web browser to the following address which should bring up a security prompt.
	__14.  In the security prompt, enter a username of 'admin' and a password of 'jbo$$ee6'.  You can check the option to remember the password if offered. Click OK.
	__15.  Check that you see the overview page of the administration console.  If it doesn't display try refreshing the page.
	__16.  Close the browser you are using to access the administration console.
	__17.  Stop the server in the Eclipse Servers view.

	Part 5 -  Review

	Lab 2 -  Develop a Simple RESTful Service
	Part 1 -  Create the Web Service Project
	__1.  From the menubar, select File > New > Dynamic Web Project.
	__2.  Enter AcmeWeb for the Project name.
	__3.  At the bottom of the window, in the EAR Membership section, click the button marked New Project....  (We will want to add this WAR file into an EAR file)
	The New EAR Application Project screen will appear.
	__4.  Set the Project name to AcmeApp and make sure the target server is JBoss.
	__5.  Click Finish to create the EAR project
	__6.  Click Finish.  Both the EAR and the WAR will be created.  If prompted, don't switch to the web perspective by clicking No.
	__7.  Right click the newly created AcmeWeb project and select Properties.
	__8.  Now, select the Project Facets property.
	__9.  Note that the JAX-RS facet is not selected. This facet plays no role in developing JAX-RS services.
	__10.  Click Cancel to close the dialog.

	Part 2 -  Register the REST Application
	__1.  Open Windows file explorer.
	__2.  Go to C:\LabFiles\
	__3.  Copy web.xml
	__4.  In eclipse, paste the file inside the WebContent > WEB-INF folder of AcmeWeb.
	__5.  Open web.xml and study how the REST application is configured. Switch to the Source view and specifically, note the servlet mapping:
	__6.  Close the file.

	Part 3 -  Create the Resource Class
	__1.  Right click AcmeWeb project and select New > Class.
	__2.  Enter com.acme.services as the package name and SimpleService as the class name.
	__3.  Click Finish to create the new class.
	__4.  Add a member variable that will help us do logging.
	__5.  Organize imports (Control+Shift+O) and select java.util.logging.Logger.  Make sure you select the correct class as there are several 'Logger' classes on the classpath.
	__6.  Add the method as follows.
	__7.  Save changes.

	Part 4 -  Configure the Resource
	__1.  Define the URI of the root resource, by adding the @Path annotation above the class. 
	__2.  Set the HTTP method and reply MIME type for the testGET() method sub-resource as follows.
	__3.  Organize imports. Select javax.ws.rs.Produces.
	__4.  Save changes.

	Part 5 -  Unit Test
	__1.  Start the server.
	__2.  Right click the server and select Add and Remove.
	__3.  Add the AcmeApp project to the server.
	__4.  Click Finish.
	__5.  Right click the server and select Publish. Do this every time you are requested to Publish the server.
	__6.  Open a web browser and enter the URL: 
	__7.  You should see OK in the browser.
	__8.  The Console view will show the log output.

	Part 6 -  Use Path Extension for Sub-resource
	__1.  First, add this method to the SimpleService class.
	__2.  Annotate the method as follows.
	__3.  Save changes.

	Part 7 -  Unit Test
	__1.  Right click the server and select Publish.
	__2.  In a web browser, enter the URL: 
	__3.  Make sure that the Console shows the log output.
	__4.  Open a new browser or tab and re-test the testGET method for regression using the URL: 
	__5.  Close all browsers.
	__6.  Close all open files.

	Part 8 -  Review

	Lab 3 -  Extracting Information from a HTTP Request
	Part 1 -  Get Root Resource Path Parameters
	__1.  Open SimpleService.java from the AcmeWeb project.
	__2.  Change the @Path annotation for the class and add a parameter there.
	__3.  Add a member variable as follows.
	__4.  Annotate the member variable to save the value of the myRootPathData parameter.
	__5.  Organize imports.
	__6.  Change the log statement of the testGET() method as follows.
	__7.  Make a similar change to the testGETWithPath() method.
	__8.  Save changes.

	Part 2 -  Unit Test
	__1.  Publish the server.
	__2.  First, test the testGET() method by entering the URL: 
	__3.  The log output will like this:
	__4.  Now, test the testGETWithPath() method using the URL: 
	__5.  The log output will be:

	Part 3 -  Get Sub-resource Path Parameters
	__1.  Add a basic method as follows.
	__2.  Annotate method with path and method.
	__3.  Now, extract the path parameters and save them in the two input argument variables of the method.  The syntax for the @PathParam annotation on a method parameter is tricky so be careful.
	__4.  Save changes.
	__5.  Publish the server.
	__6.  Test the method by entering the URL: 

	Part 4 -  Extract Query Parameters
	__1.  Add the giveRaise() method as shown below.
	__2.  Organize imports.
	__3.  Save changes.
	__4.  Publish the server.
	__5.  Test the change by entering the URL: 
	__6.  Make sure that the Console shows:

	Part 5 -  Extracting Form Post Data
	__1.  Add this method.
	__2.  Organize imports. Select  java.util.List.
	__3.  Save changes.

	Part 6 -  Unit Test
	__1.  We will import the form HTML page. Copy C:\LabFiles\post.html and paste it inside the WebContent folder of the AcmeWeb project.
	__2.  In the Servers view, right click the server and select Publish.
	__3.  Open a browser and enter the URL: 
	__4.  Fill out the form and submit it. 
	__5.  Make sure that the console log shows the input values correctly.
	__6.  Close all open files.
	__7.  Close all open browsers.

	Part 7 -  Review

	Lab 4 -  Designing a RESTful Service
	Part 1 -  The Business Requirements
	Part 2 -  Define Project Scope
	Part 3 -  Designing the Object Model
	__1.  Can you go through the business requirements and identify the entities? 
	__2.  Now that you have identified the entities, can you list the attributes or fields for each entity? Once again, the answer is below. But do your best to do the design yourself.

	Part 4 -  Identify the Service
	__1.  Can you go through the requirements and list the tasks or operations that various yet to be identified services need to perform? Then compare your findings with the answer below.
	__2.  Can you group the operations based on the entity they work with? Name each group as a service accordingly. The answer is below.

	Part 5 -  Design the Service Interface
	__1.  First, let us decide on the URI for each entity. This is a pretty straightforward exercise. Note: As a matter convention, plural forms of the entity names are used in URI.

	Part 6 -  Decide on the Data Format
	Part 7 -  Unaddressed Architectural Issues
	Part 8 -  Review

	Lab 5 -  Add Support for XML Format
	Part 1 -  Create the Entity Classes
	__1.  In the AcmeWeb project, create a package called com.acme.services.entities
	__2.  Within that package, create a Java class called QuoteRequest
	__3.  In the QuoteRequest class, add these member variables. Feel free to refer back to the object model to make sure we are doing this correctly.
	__4.  Generate getters and setters for the variables. To do this select any variable, then from the menu select Source >  Generate Getters and Setters. Click Select All and click OK.
	__5.  Add the @XmlRootElement JAXB annotation to the class as shown in boldface below.
	__6.  Organize imports.
	__7.  Save changes.
	__8.  Open a file browser and go to C:\LabFiles\entities.
	__9.  Copy all the files within the folder and then paste them into the com.acme.services.entities package.
	__10.  Open each entity class file and review them. Specifically, look at the Order class. Working with list of child objects can be tricky in JAXB. Look at how we are dealing with line items:

	Part 2 -  Generate the XML Schema
	__1.  In the Project Explorer view, right click on the AcmeWeb project and select New → Other.
	__2.  Expand JAXB and select Schema from JAXB Classes and click the Next button.
	__3.  Change the name of the schema to AcmeWeb.xsd
	__4.  Click Next.
	__5.  Expand the AcmeWeb → src folder and select the com.acme.services.entities package.
	__6.  Click the Finish button to generate the schema.
	__7.  After a few seconds check that the root of the project has the schema, note that it was renamed to AcmeWeb1.xsd.
	__8.  Open the generated schema file and study it if you wish.

	Part 3 -  Create the Quote Service Class
	__1.  In the com.acme.services package, create a class called QuoteService
	__2.  Set the root URI of the service as shown in boldface below.
	__3.  Add a member variable for logging.
	__4.  Add the getQuote() method as shown below. The business logic is very simple. We hard code the price and availability.
	__5.  Annotate the method as shown below.
	__6.  Organize imports. Select javax.ws.rs.Produces and java.util.logging.Logger.
	__7.  Save changes.

	Part 4 -  Better Content Handling
	__1.  Add the @Consumes annotation to getQuote as follows in bold.
	__2.  Similarly, change the @Produces annotation to support both MIME types for XML.
	__3.  Organize imports. Select javax.ws.rs.core.MediaType.
	__4.  Save changes.

	Part 5 -  Unit Testing
	__1.  Start the server if it is not running.
	__2.  Publish the server.
	__3.  Open a command window and change directories with the 'cd' command to C:\Software\RESTClient.
	__4.  Run the command:
	__5.  In the URL text box, enter: 
	__6.  Select POST method.
	__7.  Click the Body tab.
	__8.  Click the  icon.
	__9.  From the drop-down select the text/xml content type.
	__10.  Click OK.
	__11.  Click the  icon to open the file.
	__12.  Select C:\LabFiles\quote_request.xml and open it.
	__13.  The tool will offer you an option to change the MIME type to application/xml. This is not necessary (either text/xml or application/xml will work fine), click NO.
	__14.  Study the request document briefly.
	__15.  We are now ready start testing. Click the  icon next to the URL.
	__16.  Make sure that the HTTP reply status code is 200.
	__17.  Click the Body tab for the response.
	__18.  Right click the response body text and select Indent > Indent XML.
	__19.  Study the response document.
	__20.  Back in eclipse close all open files.
	__21.  Do not close the REST Client.

	Part 6 -  Review

	Lab 6 -  Add Support for JSON
	Part 1 -  Do the Design First
	Part 2 -  Add the JSON Method
	__1.  Open QuoteService class.
	__2.  First, add the shell of the method.
	__3.  Then, annotate the method and the input parameters as shown in boldface below.
	__4.  Now, fill in the body of the method. It basically calls the getQuote() method to get the job done.
	__5.  Organize imports.
	__6.  Save changes.

	Part 3 -  Understanding Content Negotiation
	Part 4 -  Test
	__1.  Publish the server by right-clicking and selecting Publish.
	__2.  Launch the REST client tool if it is not already running.  Use steps from previous labs to set the 'JAVA_HOME' variable in the command prompt to launch the tool.
	__3.  Set the URL to: 
	__4.  Choose POST method.
	__5.  Set the body using the XML code in C:\LabFiles\quote_request.xml a
	__6.  Set content type to application/xml; chartset=UTF-8.
	__7.  Click the Headers tab.
	__8.  Enter Accept as Key and text/xml as Value.
	__9.  Click the + icon to add the header.
	__10.  Run the test by clicking .
	__11.  Right click the response body area in the Body tab and select Indent > Indent XML.
	__12.  Verify that the reply body contains the response.
	__13.  Select the Accept header, then right click on it and select Delete.
	__14.  Enter Accept as Key and application/json as Value, then click the + icon to add the header.
	__15.  Select the request Body tab and click on the button for 'Insert parameters'
	__16.  Confirm that you want to erase the current body text by clicking the Yes button.
	__17.  Confirm that you want to switch the content type to the value needed for a form, 'application/x-www-form-urlencoded', by clicking the Yes button.
	__18.  Use the tool to add each of the following parameters by filling in the key and value and clicking the button to add the parameter.
	__19.  Once you have all the parameters filled in as shown below, click the Generate button.
	__20.  Run the test.
	__21.  Right click the response body area and select Indent > Indent JSON.
	__22.  Verify the result.
	__23.  Back in eclipse close all open files.
	__24.  Do not close the REST Client.

	Part 5 -  Review

	Lab 7 -  Build the Order Web Service
	Part 1 -  Create the Resource Class
	__1.  In the com.acme.services package, create a class called OrderService
	__2.  Annotate the class to set the path as follows.
	__3.  Add a member variable for logging.
	__4.  Organize imports. Select java.util.logging.Logger.
	__5.  Save changes.

	Part 2 -  Implement Order Placement
	__1.  Write the shell of the method as follows. We will not deal with the returned URL just yet.
	__2.  Annotate the method with @POST and @Consumes.
	__3.  Organize imports. Select these classes when prompted (they may come up in a different order):
	javax.ws.rs.core.MediaType
	com.acme.services.entities.Order
	javax.ws.rs.core.Response
	__4.  Save changes.
	__5.  Copy the file C:\LabFiles\OrderDAO.java into the com.acme.services package.
	__6.  Open the class and briefly study it. The code should be very simple.
	__7.  In the placeOrder method of the OrderService class, use OrderDAO as shown in boldface below.
	__8.  Organize imports. Select this class:
	java.util.logging.Level
	__9.  Save changes.

	Part 3 -  Implement Retrieval of Order
	__1.  First write the method shell along with the required annotations.
	__2.  Next, fill in the method body.
	__3.  Organize imports. Select these classes:
	__4.  Save changes.

	Part 4 -  Construct Entity URL
	__1.  First, add a member variable to the class as follows.
	__2.  In the placeOrder() method, add the bold code:
	__3.  Add this line in bold below:
	__4.  Next, add the following line. This plugs in the actual value of the order ID to the path and returns a java.net.URI object.
	__5.  Finally, add this line. 
	__6.  Organize imports. Choose this class:
	__7.  Save the file and make sure you don't have any compilation errors.

	Part 5 -  Test
	__1.  Go to the 'Servers' view and publish the changes to the server by right clicking the server and selecting 'Publish'.
	__2.  Launch the REST client tool if it is not already running. 
	__3.  From the REST client's menubar, select File > Open Request (Control+O).
	__4.  Open C:\LabFiles\order_create.rcq
	__5.  Review these items about the request:
	__6.  Click the  button to send the request.
	__7.  Verify that:
	__8.  In the Console, verify the log output from the OrderDAO class.
	__9.  In the REST client, open the request file C:\LabFiles\order_retrieve.rcq.
	__10.  Verify:
	__11.  Send the request.
	__12.  Verify that the reply body has the correct order information.

	Part 6 -  Enable Error Handling
	__1.  In the placeOrder() method of OrderService class, add this line shown in bold face.
	__2.  Comment out the following unreachable line:
	__3.  Organize imports. 
	__4.  In the getOrder() method, above the line:
	__5.  Organize imports. Choose this class:
	javax.ws.rs.core.Response.Status
	__6.  Save changes.

	Part 7 -  Test
	__1.  Publish the  server in the Servers view.
	__2.  In the REST client, the order retrieval request file should be open already. Just run the test.
	__3.  Verify that the status code is 404.  This is because the previous order was lost when the application was updated and restarted.
	__4.  Open the request file C:\LabFiles\order_create.rcq.
	__5.  In the Body tab, delete all the <item> elements.
	__6.  Run the test.
	__7.  Verify that status code 500 is returned.
	__8.  Do regression tests to make sure that success conditions are working fine.
	__9.  In eclipse close all open files.
	__10.  Do not close the REST Client.

	Part 8 -  Review

	Lab 8 -  Complete the Order Service
	Part 1 -  Implement Order Cancellation
	__1.  In the AcmeWeb project, open OrderService.java
	__2.  Add this method.
	__3.  Add these lines to the cancelOrder() method.
	__4.  Organize imports.
	__5.  Save changes.

	Part 2 -  Test
	__1.  Publish the  server.
	__2.  Launch the REST client tool if it is not already running.  Use steps from previous labs to set the 'JAVA_HOME' variable in the command prompt to launch the tool.
	__3.  From the client, open the request file C:\LabFiles\order_create.rcq
	__4.  Run the test. You should get a status code of 201. 
	__5.  Open the request file C:\LabFiles\order_retrieve.rcq
	__6.  Run the test. You should get a status code of 200.
	__7.  From the Method tab, select DELETE.
	__8.  Run the test. 
	__9.  Since the reply body is empty, you should see HTTP status code 204. This is equivalent to status 200 and indicates success.
	__10.  In the Method tab, select GET method.
	__11.  Run the test.
	__12.  Verify that 404 is returned.

	Part 3 -  Implement Order History
	__1.  From the com.acme.services.entities package, open OrderList.java and inspect it.
	__2.  Close the class.
	__3.  In the OrderService class, add the method shell as follows.
	__4.  Add the method body as follows.
	__5.  Organize imports.
	__6.  Save changes.

	Part 4 -  Test
	__1.  Publish the  server.
	__2.  From the REST test client, open the request file C:\LabFile\order_create.rcq
	__3.  From the Body tab, note the client ID – C001.
	__4.  Run the test to create an order.
	__5.  From the Body tab of the request, change the part number and quantity ordered and place a few more orders.
	__6.  From the test client, open the request file C:\LabFiles\order_history.rcq
	__7.  Run the test.
	__8.  Verify the response.

	Part 5 -  Implement Order Update Function
	__1.  In the OrderService class, add the method shell.
	__2.  Fill in the method body as follows.
	__3.  Organize imports.
	__4.  Save changes.

	Part 6 -  Test
	__1.  Publish the  server.
	__2.  From the REST test client, open the request file C:\LabFile\order_create.rcq
	__3.  Run the test.
	__4.  Add the order ID 1000 to the URL (add  /1000  at the end of the URL).
	__5.  From the Method tab, choose PUT.
	__6.  From the Body tab, change quantity and/or part number.
	__7.  Run the test.
	__8.  Verify that status code 200 is returned.
	__9.  Now lets check the retrieve request. Open the request file C:\LabFiles\order_retrieve.rcq
	__10.  Run the test.
	__11.  Verify that status code 200 is returned.   
	__12.  Format the result (Indent > Indent XML ) and verify that the body contains the information that you changed.
	__13.  Open the request file C:\LabFile\order_create.rcq
	__14.  Change the order ID in the URL to an invalid value as shown below.
	__15.  From the Method tab, choose PUT.
	__16.  Run the test and make sure 404 status code is returned.
	__17.  In eclipse, close all the open files.

	Part 7 -  Review

	Lab 9 -  Developing a JAX-RS Client
	Part 1 -  Client Design Considerations
	Part 2 -  Import the Client Application
	__1.  From the eclipse menubar, select File > Import.
	__2.  Select General > Existing Projects into Workspace and click Next.
	__3.  Select the 'Select archive file' radio button and use the Browse button to the right to select the C:\LabFiles\SimpleClientStarter.zip file.
	__4.  Make sure both projects are selected as shown above and click Finish.

	Part 3 -  Configure Project for RESTEasy
	__1.  In Eclipse select Window → Preferences.
	__2.  In the list of preferences select Java → Build Path → User Libraries.
	__3.  Press the New button.
	__4.  Fill in a library name of RESTEasy and click the OK button.
	__5.  With the newly create RESTEasy library still selected press the Add External JARs button.
	__6.  Browse to the 'C:\Software\jboss‑as‑7.1.1.Final\modules\org\jboss\resteasy\resteasy-jaxrs\main' directory, select all of the JAR files by holding the CTRL key as you select each one, then click the Open button to complete the selection.  If your software was extracted to a different location adjust the beginning of that path for the correct location of the JBoss 7.1 files.
	__7.  Make sure that the JAR files are listed as part of the library.
	__8.  Click the OK button to close the Eclipse preferences.
	__9.  Back in Eclipse right click the SimpleClient project and select Build Path → Configure Build Path...
	__10.  In the build path settings select the Libraries tab and click the Add Library... button.
	__11.  Select User Library and click the Next button.
	__12.  Check the box next to the RESTEasy library you defined and click the Finish button.
	__13.  Click the OK button to close the project properties.
	__14.  Check that the RESTEasy library is associated with the project.
	__15.  In the SimpleClient project, open the WebContent/META‑INF/MANIFEST.MF file.
	__16.  Remove the line with 'Class-Path' and add the following bold line to the end of the file.  The three dependencies listed should all be on one line.
	__17.  Save and close the file.

	Part 4 -  Build the Service Proxy Layer
	__1.  From the AcmeWeb project, copy the com.acme.services.entities package.  Make sure to copy the entire package by right clicking the package and selecting Copy.
	__2.  In the SimpleClient project, paste it in the src folder.
	__3.  In the SimpleClient project, create a package called com.acme.services.proxy
	__4.  In that package, create a class called QuoteProxy
	__5.  In the QuoteProxy class, add a variable to store the service root URL.
	__6.  Add the shell of a method that will invoke the quote web service.
	__7.  In the getQuote() method, add this line to instantiate a org.jboss.resteasy.client.ClientRequest object.
	__8.  Add these lines to set the content type of the request and the accept header.
	__9.  Add this line to send the request using a POST request.
	__10.  Finally, add this line to return the quote response.
	__11.  Organize imports and select this class:
	__12.  Save changes.

	Part 5 -  Build the Presentation Layer
	__1.  From the WebContent folder, right click index.jsp and select Open With >  Web Page Editor.
	__2.  Study the form.
	__3.  Open result.jsp as Web Page Editor and study how the QuoteResponse object properties are shown.
	__4.  From the com.webage.servlet package, open QuoteController.java.
	__5.  Locate the doPost method.
	__6.  Below the line:
	__7.  Below the line: 
	__8.  Below the line:
	__9.  Organize imports.
	__10.  Save changes.

	Part 6 -  Test
	__1.  Start the server if it is not running.
	__2.  Deploy SimpleClientEAR project to the server with the Add and Remove.. option when you right click the server.
	__3.  Open a web browser and enter the URL: 
	__4.  Enter some values and click Get Quote.
	__5.  Verify the result.
	__6.  Close the browser.
	__7.  Close all open files.

	Part 7 -  Review

	Lab 10 -  Introduction to AJAX
	Part 1 -  Create a Project
	__1.  From the menubar, select File > New > Dynamic Web Project.
	__2.  Enter SimpleAjax for the Project name.
	__3.  At the bottom of the window, in the EAR Membership section, check the box and click the button marked New Project....  (We will want to add this WAR file into an EAR file)
	The New EAR Application Project screen will appear.
	__4.  Set the Project name to SimpleAjaxEAR
	__5.  Click Finish to create the EAR project
	__6.  Click Finish.  Both the EAR and the WAR will be created.  If prompted, don't switch to the web perspective by clicking No.

	Part 2 -  Import the XHTML Template Page
	__1.  Open a file explorer. 
	__2.  Change directory to C:\LabFiles. 
	__3.  Copy the template.html file (Control+C). 
	__4.  Switch back to Eclipse. Select the SimpleAjax → WebContent folder and paste the file (Control+V).
	__5.  Now, we will study the XHTML syntax of this file. Double click template.html to open it in the editor. Notice the following aspects:
	__6.  Close the file.

	Part 3 -  Create a Simple Web Page
	__1.  In Eclipse, select template.html and copy it (Control+C).
	__2.  Paste the file by hitting Control+V. System will ask you to enter a name for the new file.
	__3.  Enter ajax_intro.html as the file name. 
	__4.  Click OK.

	Part 4 -  Create the Button
	__1.  Double click ajax_intro.html to open it.
	__2.  Within the <body> tag, enter the following lines:
	__3.  Save the file (Control+S).
	__4.  Start the server if it is not running.
	__5.  Right click the server and select Add and Remove.
	__6.  Add the SimpleAjaxEAR project to the server.
	__7.  Click Finish.
	__8.  Right click the server and select Publish. Do this every time you are requested to Publish the server.
	__9.  Now, we will test the look and feel of the page. Open a browser window. Enter the URL: 
	__10.  Make sure that the page looks like this.

	Part 5 -  Add JavaScript
	__1.  Back in the ajax_intro.html, locate the <script> element.
	__2.  Below the line:
	__3.  Below the end of the createRequestSimple function, add a global variable to store a reference to the request object.
	__4.  Below that, add these two functions.
	__5.  Save the file.

	Part 6 -  Create the Response File
	__1.  Right click the SimpleAjax → WebContent folder and select New->File. 
	__2.  Enter response.txt as the file name. Click Finish.
	__3.  Enter the following text in the newly created file.
	__4.  Save this file. Note: The file has only fragments of a HTML page. For a typical AJAX HTTP request, the reply is made up of only small amounts of HTML fragments (and not a whole HTML page). This is a key distinction of a AJAX based application.

	Part 7 -  Test
	__1.  Make sure that all files are saved in Eclipse.
	__2.  Publish the  server and make sure it is running with all files synchronized.
	__3.  Open a browser and enter the URL: http://localhost:8080/SimpleAjax/ajax_intro.html. If a browser is already open with this URL, refresh it to get the latest version of the page. If you are using IE, your setting may cause the page to be cached for the duration of the session. In that case, you will need to close the browser and open a new window.
	__4.  Click the Test It! button. 
	__5.  Back in Eclipse, change the contents of the response.txt file in some way and save the file and then Publish the server. 
	__6.  In the browser, click the Test It! button again. Make sure that the updated contents of response.txt is shown. (Once again, your IE settings may cache the reply for the response.txt URL. Either use Chrome, FireFox or restart IE to make sure that the updated version of response.txt is being shown in the browser).

	Part 8 -  Add Logging to JavaScript
	__1.  Open a file explorer.
	__2.  Change directory to C:\LabFiles. 
	__3.  Copy the file log4javascript.js. 
	__4.  Back in eclipse, paste it inside SimpleAlax → WebContent
	__5.  Open ajax_intro.html in Eclipse.
	__6.  Above the following line:

	Part 9 -  Add Logging Code
	__1.  Above the line:
	__2.  Add logging to the startTest() and showReply() methods as shown in bold face below.
	__3.  Save changes.

	Part 10 -  Test
	__1.  Publish the server and make sure it is running with all files synchronized.
	__2.  In a browser, enter the URL: http://localhost:8080/SimpleAjax/ajax_intro.html. Refresh the page, if it is already open.
	__3.  Click the Test It! button. The application itself will behave as before. However, a log console window will open up. It will look like this.
	__4.  Close all browsers.
	__5.  Back in Eclipse close all open files.

	Part 11 -  Review

	Lab 11 -  Making POST Requests
	Part 1 -  Create the Login Servlet
	__1.  Right click the project SimpleAjax and select New->Servlet.
	__2.  Enter these values:
	__3.  Click Finish to create the Servlet.
	__4.  For the doPost() method, enter the following code.
	__5.  Press Control+Shift+O to organize imports. 
	__6.  Save changes. You should not have any compilation error at this point.

	Part 2 -  Create the Login Form Page
	__1.  To speed up this lab, a basic page is given to you. Copy the file C:\LabFiles\login.html and paste it in the SimpleAjax\WebContent folder inside of Eclipse.
	__2.  Similarly, import the home.html file from C:\LabFiles folder. This page will be shown after the user successfully logs in.
	__3.  Open login.html in Eclipse. Notice these items:
	__4.  In the script section, add a global variable for the request.
	__5.  Next, write the sendAjaxRequest method. Unlike the previous labs, now, we will make a POST request.
	__6.  Finally, we will add the showResult function.
	__7.  Save changes.

	Part 3 -  Test
	__1.  Publish the server and make sure it is running with all files synchronized.  The SimpleAjax project should already be deployed to the server from previous labs.
	__2.  Open a web browser and enter the URL: 
	__3.  First, we will simulate a few failure conditions. Enter billy as the user ID and click Login. Make sure that you see the error message as shown below.
	__4.  Now, enter bob as the user ID and pass for password. Click Login. System will show an error message about the invalid password.
	__5.  Now, enter bob as user ID and cat as password. Click Login. System should show the home.html page.
	__6.  Close all open browsers.
	__7.  Close all open files.

	Part 4 -  Review

	Lab 12 -  Basic DOM API
	Part 1 -  Create the XHTML File
	__1.  In the SimpleAjax project copy template.html and paste it as find_test.html
	__2.  Open the newly created file.
	__3.  Within the <body> tag, add the following XHTML markup.
	__4.  Save changes. 
	__5.  Publish the server.
	__6.  Open Chrome or Mozilla Firefox (not IE) .
	__7.  Test the page by opening this URL in the browser:
	__8.  It should look like this.

	Part 2 -  Add JavaScript
	__1.  Below the line:
	__2.  Save the file (Control+S).

	Part 3 -  Test
	__1.  Publish the server.
	__2.  Refresh the browser where the page was already opened.
	__3.  Enter p1 in the text box. Click Find by ID. The paragraph with text "This is para1" should now have a yellow background.
	__4.  Enter error in the text box. Click Find by Name. The two <div> elements with name "error" will now have red background.
	__5.  To make things interesting, enter id_or_name in the text box. Click Find by ID. Now, the text box itself will have yellow background.
	__6.  Now, launch IE and enter the URL: 
	__7.  Enter p1 in the text box. Test for the Find by ID button. It should work fine.
	__8.  Test for the Find by Name button (by entering error in the text box). It will fail to locate any element by name "error". 
	__9.  Close all open browsers.
	__10.  Close all open files.

	Part 4 -  Review

	Lab 13 -  AJAX Client using XML  
	Part 1 -  Import the AJAX Utility Library
	__1.  Open a Windows file browser and go to C:\LabFiles.
	__2.  Copy rest_utils.js and paste it in the WebContent folder of SimpleClient project.
	__3.  Open index.jsp.
	__4.  Within the <head> element, add a script tag to import rest_utils.js.
	__5.  Save changes.

	Part 2 -  Change the GUI
	__1.  In index.jsp, near the end of the form, add this line to add another submit button. This button will initiate an AJAX call.
	__2.  Below the </form> line, add these lines. This is where the response will be shown.
	__3.  Save changes.

	Part 3 -  Send a Quote Request
	__1.  Within the <head> element of index.jsp, add a script tag as follows.
	__2.  Within the script tag, add the shell of the sendRequest() method as follows:
	__3.  Within the sendRequest() method, add this line to create a new DOM document with "quote_request" as the root element.
	__4.  Add this line to append a child element called "clientId". The value will be hard coded to "C01029".
	__5.  Open rest_utils.js and study how the addElement() function works.
	__6.  Back in index.jsp, add this line to sendRequest().
	__7.  Similarly, add these lines to sendRequest().
	__8.  Add this line:
	__9.  Study the invokeByXMLPost() function in rest_utils.js.
	__10.  Finally, add this line to sendRequest(). This will prevent the form from getting submitted.
	__11.  Save changes.

	Part 4 -  Show the Response from the Web Service
	__1.  In index.jsp, add the showResult() function as follows.  Make sure to add it within the existing <script> tag but outside of the other method.
	__2.  First, do error handling.
	__3.  Add this line to obtain the DOM reply document.
	__4.  Add these lines to display the contents of the <productAvailable> element in the <span> with ID "available".
	__5.  Similarly, add these lines to show more result data.
	__6.  Save changes.

	Part 5 -  Test
	__1.  Make sure the server is running and publish the server.
	__2.  Open Chrome or FireFox and enter the URL: 
	__3.  Enter some data.
	__4.  Click Get Quote AJAX.
	__5.  Verify that the result is displayed correctly.  Check the total price since that is calculated by the service and will prove the service was invoked.
	__6.  Do a regression test by clicking the old Get Quote button and make sure that the RESTEasy client API based approach is still working.  This will use the other page to display the results.
	__7.  Close all open browsers.
	__8.  Close all open files.

	Part 6 -  Review

	Lab 14 -  AJAX Client Using JSON
	Part 1 -  Send the Request
	__1.  Open index.jsp in SimpleClient project.
	__2.  Delete the body of sendRequest(), except the last line, so it looks like this.
	__3.  At the beginning of the 'sendRequest' method, add the following code to construct an object with properties for the request parameters to be sent.  This will be used by a utility method to send the POST request.
	__4.  Use the invokeByPost() utility method to send the request.
	__5.  Save changes.
	__6.  Study the invokeByPost() method in rest_utils.js.

	Part 2 -  Process the Response
	__1.  In the showResult() function, comment out this line:
	__2.  Below that line, add this line to convert the JSON response string into an object.
	__3.  Change the way the result data is displayed. This is shown in bold face below.
	__4.  Save changes.

	Part 3 -  Test
	__1.  Publish the server.
	__2.  Open Chrome or FireFox and enter the following URL.  Make sure your page has been refreshed to pick up the code changes.
	__3.  Enter some data and click Get Quote AJAX.
	__4.  The application will behave same as before and you should see the response data.
	__5.  Check in the Console view in Eclipse that you saw the message printed out by the JSON method of the service.
	__6.  Close all open browsers.
	__7.  Close all open files.

	Part 4 -  Review

	Lab 15 -  Securing JAX-RS REST Services
	Part 1 -  Configure JBoss Application Security
	__1.  Open a Windows command prompt.  You can usually do this on most versions of Windows by selecting 'Start → Programs → Accessories → Command Prompt'.
	__2.  Use the following 'cd' command to switch to the JBoss 'bin' directory.
	__3.  Run the following 'add-user' command to start the interactive tool to add a user. How to respond to various prompts is given in the next steps.
	__4.  On the first prompt, type the letter 'b' and hit the <ENTER> key to indicate we want to create an 'Application User'.
	__5.  On the second prompt, hit the <ENTER> key to accept the default option of 'ApplicationRealm' for the security realm.  This is the name of the security realm already defined in the JBoss server so using this ensures we do not have to change any other JBoss configuration.  
	__6.  Enter a username of 'bob'.
	__7.  Type the following password for both prompts that ask you to enter a password. Note that the program will not even show stars while you type.
	__8.  When prompted for the roles the user should belong to, enter 'Customer' (with a capital 'C') and  hit the <ENTER> key.
	__9.  Type 'yes' and  hit the <ENTER> key to confirm you want to add the 'bob' user to the 'ApplicationRealm'.
	__10.  Hit any key to let the program finish and return you to the command prompt.
	__11.  Close the command prompt.

	Part 2 -  Secure the Quote Service
	__1.  Back in Eclipse, in the AcmeWeb project expand com.acme.services package.
	__2.  Open QuoteService.java.
	__3.  Add the following annotation in bold to the class.
	__4.  Organize imports. 
	__5.  Save changes.
	__6.  In the AcmeWeb project expand the AcmeWeb\WebContent\WEB-INF folder.
	__7.  Double click the web.xml file to open it in an editor and view the source.
	__8.  Add the XML in bold below to the end of the file but within the end '</web-app>' tag.  Pay particular attention to the values of the XML elements because the Eclipse validation will only pick up errors in the structure of the elements themselves and not in the contained values.
	__9.  Save and close the file after making sure there are no errors.
	__10.  Back in the AcmeWeb project, right click the WEB-INF folder and select 'New → File'.
	__11.  Fill in a file name of 'jboss-web.xml' and check that the file will be created in the AcmeWeb\WebContent\WEB-INF folder.
	__12.  Click the Finish button when your settings for the new file match above.
	__13.  In the empty file that opens in the editor, switch to the Source view with the tab along the bottom of the editor.
	__14.  Add the following XML that will link the application to the default security domain (which has a name of 'other').
	__15.  Save and close the file.

	Part 3 -  Test
	__1.  Publish and start the server.
	__2.  Open a browser and enter the URL: 
	__3.  Enter some data and then click the Get Quote button (not the AJAX one).
	__4.  The browser will show an error.
	__5.  Close the browser.

	Part 4 -  Modify the Test Client
	__1.  Launch the RESTClient tool if it is not already running.  
	__2.  In the URL text box, enter: 
	__3.  Select POST method.
	__4.  Click the Body tab.
	__5.  Click the  icon to open the file. Click Yes to erase the existing code if any.
	__6.  Select C:\LabFiles\quote_request.xml and open it. Click 'Yes' when the tool offers you an option to change the MIME type to application/xml. 
	__7.  Click the  icon next to the URL.
	__8.  Make sure that the HTTP reply status code is 401.
	__9.  Click the Auth tab in the 'HTTP Request' section of the tool.
	__10.  Enter these values:
	__11.  Run the test again.
	__12.  Verify that status code 200 is returned.  You can check the body of the response as well but the status code alone should be able to tell it is working.

	Part 5 -  Enable Audit Logging
	__1.  In the AcmeWeb project, open OrderService.java.
	__2.  Configure the valid role for the service as shown in bold face below.
	__3.  Add a member variable to the class as follows.
	__4.  In the placeOrder() method, add the following bold code below the line to create the order:
	__5.  Organize imports and select the 'javax.ws.rs.core.SecurityContext' class.
	__6.  Save changes.
	__7.  Publish the JBoss server.

	Part 6 -  Test
	__1.  Launch the REST test client if it is not already running.
	__2.  Select File > Open Request from the menubar.
	__3.  Open C:\LabFiles\order_create.rcq
	__4.  Click the  button to send the request.
	__5.  Make sure that a status code 401 is returned.
	__6.  Click the Auth tab.
	__7.  Enter these values:
	__8.  Run the test again.
	__9.  Verify that status code 201 is returned.
	__10.  Check Eclipse console for the audit log. It will look like this:
	__11.  Close all open browsers.
	__12.  Close all open files.
	__13.  Close REST client.

	Part 7 -  Review

	Lab 16 -  AJAX Client Security
	Part 1 -  Change the Client Code
	__1.  In the SimpleClient project, open rest_utils.js located under WebContent folder.
	__2.  Change the method signature of invokeByPost as follows.
	__3.  Modify the following line to add username and password:
	__4.  Save changes.

	Part 2 -  Change the GUI
	__1.  Open index.jsp.
	__2.  Within the form, add the fields for user name and password.
	__3.  In the sendRequest() function, supply the credentials.
	__4.  Save changes.

	Part 3 -  Test
	__1.  Publish and make sure the server is running.
	__2.  Close any open browser. 
	__3.  Open a browser, go to settings and do these changes:
	Clear browsing history.
	Empty the cache.
	__4.  Open a browser and enter the URL: 
	__5.  Enter bob as user name and pa55word as the password.
	__6.  Enter other values.
	__7.  Click Get Quote AJAX.
	__8.  Verify that the result is shown.
	__9.  Close the browser.
	__10.  Open a new browser to:
	__11.  This time enter invalid credentials and click Get Quote AJAX.
	__12.  The 'Request failed' message will appear in a new popup.
	__13.  Click OK in the request failed window.
	__14.  Close all open browsers.
	__15.  Close all open files.
	__16.  Stop the server.

	Part 4 -  Review




