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Lab 1 - Demonstration: Developing a Simple Application

*** This Lab will be demonstrated by the instructor ***
In this lab, we will develop a very simple application. It will simply display the "Hello 
World" message. The goal is to understand the basic develop-test-debug cycle. We will 
not spend much time understanding the API itself.

Part 1 - Inspect the Project
When you first create the project a few Java classes and XML files are created 
automatically. We will take a quick look at them.

__1. Make sure you are viewing the 'HelloWorld' project in Android Studio that was 
created in the last lab.  If you aren't, open Android Studio and select the project from the 
Welcome dialog if needed.

__2. In the upper left you should see the files of the project.  You might want to double 
check that you are in the 'Android' view of the project with the drop-down of the upper-
left tab.
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__3. Expand a few levels of the top level folders of the Android project view and look at 
the contents.  The 'app' folder is the IntelliJ module for the Android application. You 
should see some of the following folders:

java/ - Source files for the module.

manifests/ - Manifest files for the module.

res/ - Resource files for the module.

Gradle Scripts/ - Gradle build and property files.

__4. Switch to the 'Project' option in the project view in the upper left of Android Studio 
by selecting this option from the drop-down list.
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__5. Notice in this 'Project' view, which is not really specific to the Android tools, you 
see a different structure for the application module (app).  You see many of the exact 
folders that are used for project settings and building code that were hidden in the 
Android view of the tool.

Note: Generally the 'Android' view of the project is better as it helps focus on the files 
and settings you should be working with and helps ignore some of the things maintained 
by the Android Studio tool itself.

__6. Switch to the 'Android' option in the project view in the upper left of Android 
Studio by selecting this option from the drop-down list.
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__7. Expand the app/res/layout folder and find the file called activity_hello_world.xml. 
This XML file has the layout of a screen. The HelloWorldActivity class loads the layout 
from this file.

__8. Expand the app/res/values folder and find the file called strings.xml. This file 
contains text used by various widgets. For example, the label for a button can be stored 
here. You could directly specify the label in the layout file. But, externalizing text from 
the layout is essential for localization of an app in multiple languages.

__9. Expand the app/manifests folder and find the file called AndroidManifest.xml. This 
has a few key pieces of information:

• The name, label and icon of the app. 

• Every activity is listed here. The main activity, the one that is displayed first when 
the app is launched is designated as such.

Part 2 - Inspect the Activity Class
__1. Open HelloWorldActivity.java from the app/java/com.webage.www.helloworld 
folder if it is not already open.

Note that it extends the ActionBarActivity class.

The onCreate() callback method is called by the runtime so that the activity can create the 
GUI widgets and setup the layout. Right after that happens, the activity is displayed on 
screen.
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The key line in onCreate is this one.

setContentView(R.layout.activity_hello_world);

The setContentView() needs the unique integer ID of a layout file. The layout is then 
loaded from that file. In our case, the layout file is res/layout/activity_hello_world.xml. 
The system has already designated a unique ID for it and saved in a generated “R” class. 

The setContentView() method takes the unique ID of the layout file which the system 
was gracious enough to assign for us and save it in the R class. We don't have to hard 
code the ID in the activity class.

Note: The Android Studio tool (through the Android SDK) keeps the R class always up 
to date. If you create another layout file call my_layout.xml, it will automatically add a 
member variable to the layout inner class called my_layout. That variable will have the 
unique ID of the new layout file.

As an alternative to using layout files, you can directly use API in the onCreate method 
to create the GUI widgets. In most cases, however, that will be more cumbersome than 
the use of a layout file.

Part 3 - Inspect the Layout
__1. Open app/res/layout/activity_hello_world.xml.
__2. From the bottom of the editor, select Text to view the XML source.

Note that a RelativeLayout has been used. Such a layout component can group many 
children widgets. Right now, there is a TextView child widget. 

The label text has been externalized in a string resource as follows.  Click inside the 
following attribute to see how this is done.

android:text="@string/hello_world"

Note: The editor in Android Studio resolves the value and shows it in place of the actual 
attribute value.  Clicking on the attribute shows the source directly.
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__3. From the bottom of the editor, select the Design tab. Now, you can preview the 
layout before the application is launched.

__4. Click the drop-down arrow next to the display of 'Nexus 4'.  Note, the resolution of 
the device is set to 4.7 inch. You can easily change the resolution to see how the GUI will 
accommodate that resolution.

__5. Click the Reset Zoom to 100% icon to see how the GUI will look like in the 
selected resolution.

__6. Close all open files making sure you have not made any changes to the file.
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Part 4 - Test the Application
The next step is to test the application and see it deployed and running on the emulator. 
You will also see some tools in Android Studio to see messages coming from the 
emulator.

__1. Click on the Android tab at the very bottom left of Android Studio.  This will 
initialize some Android tools, most notably the 'logcat' tool, that will be useful during 
testing.

__2. From the Android Studio menus select 'Run → Run 'app''.  The project may run 
some build commands but eventually a dialog should appear for how to run the 
application.

__3. In the 'Choose Device' dialog that appears, leave the default option of 'Launch 
emulator', make sure the 'my_avd' device is selected in the drop-down, check the 'Use 
same device for future launches' option and click the OK button.
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__4. While the emulator is booting (after the window appears) you can check the 
messages in the 'logcat' portion of the Android views to see messages from the emulator 
starting.  The view gets hidden when you click the Android tab a second time so click 
again and it should reappear if it is hidden.

__5. The Emulator may be locked at this moment as shown below.

__6. If it is locked, click and hold the LOCK icon and drag it up to unlock the virtual 
device.

__7. You may see a message that the process system isn't responding.  If you do just click 
the Wait button.
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__8. You should see the app displayed in the emulator.

As you have just seen, booting the AVD takes time. Fortunately, this is something you 
need to do only once or twice a day. Most code changes can be executed in the AVD 
without a full reboot. We will try that now.

__9. Leave the 'my_avd' emulator running.

__10. Open the layout file activity_hello_world.xml.  This is in the 'app/res/layout' 
folder in the project.

__11. Click the 'Text' tab in the bottom.

__12. Change the label text to something else, like this.  Ignore the warning that may 
appear about hardcoding a value.

android:text="Hello Wonderful World!!!"

__13. Save the file (File → Save All or CTRL-S).
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__14. From the Android Studio menus select 'Run → Run 'app''. 
__15. From the 'Choose Device' dialog that appears, leave the option to use the running 
device, check the 'Use same device for future launches' option and click the OK button.

__16. The Logcat view will show messages during redeployment.

__17. The new app will be launched in the AVD pretty quickly, switch to the emulator 
and click on it.
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Part 5 - Debugging the App
Debugging is really easy and no different from debugging any Java application in IntelliJ. 
One cool feature is that, you do not need to reboot the AVD in debug mode. You simply 
launch the app in debug mode.

__1. Back in Android Studio, open HelloWorldActivity.java.  This is in the 
app/java/com.webage.www.helloworld folder.

__2. Put a breakpoint next to super.onCreate.  You do this by clicking in the gray left 
margin.

__3. From the Android Studio menus select 'Run → Debug 'app''. 
__4. Eventually program control will be stuck at the breakpoint and the 'Debug' view 
becomes active in the tabs on the lower left of Android Studio.
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We will take this opportunity to tweak the title label of the application.

__5. In the toolbar of the debugger, click the 'Step Over' button once.  Make sure to click 
it only once.

__6. In the Variables view, expand this.

__7. Scroll down, and locate the mTitle member variable of the object.

__8. Right click mTitle, and select Set Value.

__9. Enter "My First App" with the double quotes as the new value.

__10. Hit <ENTER> to modify the value.  It may take some time to change the value.
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__11. Now, we are ready to release the program control. Click the Resume Program 
button on the top left of the debugger or press F9.

__12. Switch back to the emulator and notice the application title is different.

Note: In this exercise, we tweaked an internal member variable of the activity. This was 
done for demonstration purposes only. You are free to modify variables in your own 
classes. But, changing state managed by the SDK can cause serious problems.

__13. Close all open files.

__14. Leave the AVD emulator running.

Part 6 - Review
This was a simple lab. But, we learned a few vital information about an Android app.

1. An activity class shows a screen full of GUI widgets.

2. The screen is designed in a layout file. The activity class loads the layout from the 
onCreate method.

3. The R class keeps the unique IDs of various objects, including the layout files. 
This file is automatically kept up to date as you create or delete objects in the 
project.

4. To launch an app you use the 'Run' menu of Android Studio

5. To debug an app, put breakpoints and then run the app in debug mode.
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Lab 2 -  Priority of Coverage Determination
This is a Pen & Paper type of lab where you are required to analyze a number of use 
cases and arrive at the appropriate solution to the problem.

Part 1 - Uses Cases
A car broker application is designed to provide functionality to perform the following use 
cases:

1. Sales people come to look for information on vehicles.

2. The software enables dealerships to provide Customer relationship management
features.

3. Sales people get inventory information from the database.

4. Various manufacturers enter inventory information.

5. Leads arrive from web sites like autoweb.

6. Leads arrive from walk-ins – after initial discussion; sales people fill in a form online
to collect details about the customer request.

7. Sales people fill in contact forms as they continue to deal with customers.

8. Sales people close sale and fill in a form to indicate the close.

Perform a priority of coverage determination for this application.
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	__3.  Enter C:\workspace_mobile_web_testing in the Workspace window.
	__4.  Check the Use this as the default and do not ask again check-box.
	__5.  Click OK  
	__6.  Close the Welcome screen that may open 
	__7.  In the Eclipse's Project Explorer view, right-click and select New > Worklight Project 
	__8.  In the New Worklight Project dialog, for the Name, enter MobileAppTest 
	__9.  Click Next >
	__10.  In the New Worklight Project dialog: for Application name, enter MobileAppTest; check the Add jQuery Mobile check-box and for the Location, enter C:\Software\jQueryMobile; select all items in that folder. 
	__11.  Click Finish
	__12.  In the Open Associated Perspective? dialog, check the Remember my decision check-box and click No
	__13.  Right-click the MobileAppTest project and select New > Worklight Environment
	__14.  In New Worklight Environment dialog: select MobileAppTest in the Application/Component drop-down list; select iPhone and Android phones and tablets mobile platform environments.   
	__15.  Click Finish
	__16.  Right-click the apps\MobileAppTest\common\MobileAppTest.html file and select Open With > HTML Editor 
	__17.  Locate the <div data-role="content" style="padding: 15px">MobileAppTest</div> line in the MobileAppTest.html file.
	__18.  Replace MobileAppTest with Hello the mobile world!
	__19.  Save the file by pressing Ctrl-S

	Part 2 -  Building and Running Worklight Application  
	__1.  Right-click the apps/MobileAppTest node in the project tree and select RunAs > Build All and Deploy

	Part 3 -  Verifying Application Deployment on Worklight Server 
	__1.  Open your Chrome browser and navigate to http://localhost:10080/MobileAppTest/console
	__2.  Click the eye icon on the iPhone line (to the right of the blue X) to preview the iPhone version of the app. 
	__3.  Click the menu in the upper left corner of the iPhone simulator (it may be labeled as Apple iPhone 4).   
	__4.  Expand the iOS – iPhone node that is displayed.

	Part 4 -  Review

	Lab 4 -   Testing Hybrid Mobile Applications
	Part 1 -  Testing Native Device Info Functionality
	__1.  In Worklight Studio, expand the MobileAppTest project and navigate to the apps\MobileAppTest\common folder 
	__2.  Right-click the MobileAppTest.html file and select Open With > HTML Editor
	__3.  Using Notepad or any other text editor, open the GetDeviceInfo.html file in the c:\LabFiles folder. 
	__4.  Replace the content of the MobileAppTest.html file with that of the GetDeviceInfo.html file. 
	__5.  Right-click the apps/MobileAppTest node in the project tree and select RunAs > Build All and Deploy
	__6.  Open your Chrome browser and navigate to http://localhost:10080/MobileAppTest/console
	__7.  Click the eye icon to the left of the iPhone icon.  
	__8.  Click the menu in the top left corner of the iPhone simulator (labeled as Apple iPhone 4 in this lab's screen-shots). 
	__9.  Expand the iOS – iPhone node that is displayed.

	Part 2 -  Testing Battery Levels
	__1.  Replace the content of the MobileAppTest.html file with that of the BatteryStatus.html file in the c:\LabFiles folder.
	__2.  Right-click the apps/MobileAppTest node in the project tree and select RunAs > Build All and Deploy
	__3.  In your Chrome browser, navigate to http://localhost:10080/MobileAppTest/console
	__4.  Select the iPhone app preview.
	__5.  Expand the Battery menu option on the left-hand side of the page.

	Part 3 -  Review

	Lab 5 -   Mobile Web Client Stress Testing
	Part 1 -  Creating a Web Server 
	__1.  Click the Servers view tab  located in the bottom of the Eclipse IDE workbench.
	__2.  Click the new server wizard ... link in the Servers view that opens.
	__3.  Expand the Basic folder and select J2EE Preview server type. 
	__4.  Click Finish.

	Part 2 -  Creating a Web Project 
	__1.  From the menu, select File > New > Dynamic Web Project from the context menu.
	__2.  In the New Dynamic Web Project dialog, enter MobileWebClientLab for the Project name, keep other defaults.
	__3.  Click Finish. 
	__4.  Expand the MobileWebClientLab\WebContent folder of the new project (we are going to copy a couple of files over here in a moment). 
	__5.  From the c:\LabFiles folder, copy mobile_web_client_stress_test.html and utils.js files to the MobileWebClientLab\WebContent folder (just drag the files from the file system and drop them in the target folder; confirm your operation, if prompted).
	__6.  Right-click the MobileWebClientLab project node and select Run As > Run on Server option from context menu.
	__7.  In the Run on Server dialog, click the Always use this server when running this project check-box.
	__8.  Click Finish. 
	__9.  In the embedded browser window, click the mobile_web_client_stress_test.html link. 
	__10.  Open your Chrome browser and copy over the page URL you see in the embedded browser.

	Part 3 -  Testing the Capacity of the Session Storage
	__1.  In the Chrome browser that is pointing to the mobile_web_client_stress_test.html URL, click the Check HTML5 storage support button.
	__2.  In the Chrome browser, press Ctrl-Shift-I to open the DevTools panel and click Resources.
	__3.  Expand the Session Storage node and click the  http://localhost:8080 line.
	__4.  Click Add bytes to the Store button in your browser. 
	__5.  Enter 2700000 in the Number of bytes text window.
	__6.  Click Add bytes to the Store button. 

	Part 4 -  Testing Local Storage
	__1.  Start Windows Task Manager by right-clicking the Windows Task bar and selecting Start Task Manager. (This step varies depending on your OS, ask the instructor how to do it).
	__2.  In the Windows Task Manager window that opens, select the Processes tab. 
	__3.  Click the View menu option and select the Select Columns... menu option. 
	__4.  In the Select Process Page Columns dialog, de-select the User Name check-box, and select I/O Reads and I/O Writes check-boxes.
	__5.  Click OK.
	__6.  In the Windows Task Manager dialog, click the CPU column so that the little arrow tip next to the title of the column points downward (this will show processes with higher CPU utilization on top of the dialog).
	__7.  Switch to the Eclipse IDE.
	__8.  Stop the web server by clicking the red square in the Servers view. 
	__9.  In the Project Explorer view, right-click the utils.js file and select Open With > JavaScript Editor from the context menu.
	__10.  Find the following code fragment:
	__11.  Remove the /* */ comment delimiters around the code fragment.
	__12.  Save the changes.
	__13.  Start the web server by clicking the green circle icon in the Servers view. 
	__14.  Switch to the Chrome browser and press Ctrl-R to reload the page.
	__15.  In the HTML page displayed in the Chrome browser, click the Add bytes to the  Store button.  
	__16.  Close Chrome and Windows Task Manager.
	__17.  Stop the web server by clicking the red square in the Servers view. 
	__18.  Close all open files (Ctrl+Shift+W).

	Part 5 -  Review

	Lab 6 -   HTTP Session Hijacking
	Part 1 -  Setting up the Lab Environment
	__1.   Click the Servers view tab  located in the bottom of the Eclipse IDE workbench.
	__2.  Click the new server wizard ... link in the Servers view that opens.
	__3.  Expand the Basic folder and select J2EE Preview server type. 
	__4.  Click Finish. 
	__5.   Right-click in the Project Explorer view area and select New > Dynamic Web Project from the context menu.
	__6.  In the New Dynamic Web Project dialog, enter WebSecurityLab for the Project name, keep other defaults.
	__7.  Click Finish. 
	__8.  Expand the WebSecurityLab\WebContent folder of the new project. 
	__9.  From the c:\LabFiles folder, copy SessionReader.jsp and SessionSetter.jsp files to the WebSecurityLab\WebContent folder (just drag the files from the file system and drop them in the target folder; confirm your operation, if prompted).
	__10.  Right-click the WebSecurityLab project node and select Run As > Run on Server option from context menu.
	__11.  In the Run on Server dialog, click the Always use this server when running this project check-box.
	__12.  Click Finish. 
	__13.  In the embedded browser window, click the SessionSetter.jsp link. 
	__14.  Open your Chrome browser and copy over the page URL you see in the embedded browser.
	__15.  In Chrome, open a new tab by pressing Ctrl-T.
	__16.  Switch to the new tab and type in:
	__17.  Click the Get more extensions link at the bottom of the Extensions page.
	__18.  In the Search the store text box, enter edit this cookie
	__19.  Press Enter. 
	__20.  Click the ADD TO CHROME blue button on the right of the page.  
	__21.  Confirm the adding an extension operation on any dialog that may pop up.
	__22.  Switch to the Extensions Chrome's  tab.  In the Edit This Cookie section, click Allow in incognito. 
	__23.  Close all tabs except the one that holds the Session Reader page.

	Part 2 -  Session Hijacking 
	__1.  [Alice's session] Enter Wonderland in the Enter Your ID box.
	__2.  [Alice's session] Click the Submit Your ID button.
	__3.  [Alice's session] Click the Cookie Manager icon in the Chrome browser. 
	__4.  In the Chrome browser, enter Ctrl-Shift-N to start a new incognito browser window.
	__5.  [Cheshire Cat's session] Enter Session Reader page's URL (same as Alice's): 
	__6.  [Cheshire Cat's session] Enter Smile! in the Enter Your ID text box.
	__7.  [Cheshire Cat's session] Click the Submit Your ID button.
	__8.  [Cheshire Cat's session] Click the Cookie Manager icon in the Chrome browser. 
	__9.  [Cheshire Cat's session] Click the JSESSIONID | localhost item in the Cookie Manager console if it is not already expanded. 
	__10.  In the Value box, Cheshire Cat pastes (from the text editor where you saved it) the value of Alice's session cookie.
	__11.  [Cheshire Cat's session] Click the green checkmark the bottom of the console.
	__12.  [Cheshire Cat's session] Click the Reload this page icon in Chrome's toolbar.
	__13.  Close both Chrome browsers.
	__14.  Close Notepad, don't save the file.
	__15.  Switch back to Eclipse and select the Servers tab, then select the J2EE server link.
	__16.  Stop the web server by clicking the red square in the Servers view. 

	Part 3 -  Review

	Lab 7 -   Tooling Support for Mobile Web Testing 
	Part 1 -  Chrome's Emulator for Mobile Browsers
	__1.  Start Chrome browser and navigate to: 
	__2.  In the browser, enter Ctrl-Shift-I. 
	__3.  Open the DevTools menu clicking three dots in the upper right corner of the DevTools window.
	__4.  Click the undock icon to undock the DevTools window and give us more room to work
	__5.  Click on the button shown below to toggle the browser's device toolbar. 
	__6.  This allows you to select a variety of mobile device types to emulate in the browser. The types include Responsive, this allows you to set the viewport to an arbitrary size by dragging the handles. There are also several pre-configured device types and you can select Edit to modify them or create new ones

	

	__7.  The device toolbar has a rotate button on the right to emulate device rotation.

	__8.  At the DevTools window, you should see the Console Drawer. (If you do not, click Show console drawer in the DevTools menu.
	__9.  The Console Drawer menu has a Sensors item
	__10.  Click the Sensors menu item
	__11.  The Console Drawer menu has a Network conditions item.
	__12.  The Network Conditions page lets you select a User Agent from a drop-down. Select a mobile device like, Android (4.0.2) Browser – Galaxy Nexus.
	__13.  Reload the page in the browser you should see a mobile version of the page even though the browser is actually full screen.

	Part 2 -  Servicing Mobile Web Pages 
	__1.  Close the Console Drawer  by clicking the X icon in the top right-hand corner. 
	__2.  In the DevTools panel, click the Network tab.
	__3.  In the Network View, click XHR view and reload the page.
	__4.  This allows you to look at all the HTTP requests made from the web site, timing information and HTTP status codes.

	Part 3 -  Review




