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Lab 1 - Install Maven
In this lab, we're going to install Apache Maven.  First, we'll install Maven for command-
line use, and verify it in the DOS command window.  Then, we'll setup the Eclipse 
installation to use that version of Maven as its implementation.

Although most developer's use of Maven will be through their IDE, it's a good idea to 
know a little bit of command-line usage.  That knowledge will come in handy when you 
go to setup continuous integration, and also when you want to do a quick build, perhaps 
for generating deployment or QA artifacts (although that might also be done through 
continuous integration).  Also, it's a good idea to set the Maven implementation, so you 
have control over the exact Maven version that gets run.

Part 1 - Test Maven
Maven is already extracted for you under C:\Software\apache-maven-3.1.1

__1. Open a file explorer a navigate to C:\Software\apache-maven-3.1.1

__2. Open a command prompt window (in the start menu, click All Programs --> 
Accessories --> DOS Prompt.

__3. In the command window, type:

mvn -version

__4. You should see output similar to:

We have Maven available from the command line!
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Part 2 - Setup Maven in Eclipse
We have installed Maven for command-line use, but in reality, we are probably going to 
use Eclipse as the primary interface to it.  So there's a little configuration to do.

__1. Use Windows Explorer to navigate to C:\Software\eclipse, and then double-click on 
'eclipse.exe' to start up the IDE.

__2. You may see a security dialog.  If so, un-check the box for “Always ask before 
opening this file” and then click Run.

__3. Change the workspace to C:\Workspace and click OK.

__4. Eclipse Kepler will start launching.

__5. Close the Welcome screen by clicking the 'X' next to Welcome on the tab.

__6. From the main menu, select Window --> Preferences and then expand the tree node 
for Maven.
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__7. Click on the tree node for Installations.

__8. On the right-hand side of the Preferences window, click on the Add... button.

__9. Navigate to C:\Software\apache-maven-3.1.1, ensure the node is selected, and 
click OK.

__10. In the Preferences dialog, verify Maven path and click OK.

That's it!  We're now setup to use Maven in the IDE as well as on the command line.

Part 3 - Review
In this lab, we verified Apache Maven was already unpacked, then we tested using the 
command-line, we started Eclipse and set up Eclipse to use the same installation of 
Maven that we have on the command line.

Although there is a version of Maven embedded in Eclipse, it is not generally the latest 
version released, so it's usually a good idea to install Maven separately and then 
configure Eclipse to use that version.
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Lab 2 - Create a Maven Project
In this lab we're going to use the Maven integration in Eclipse to create a simple “Hello 
World” project that builds with Maven, and we'll explore what happens when we execute 
various Maven “goals” and “phases”.

Part 1 - Create a Project
__1. If necessary, start eclipse from C:\Software\eclipse\eclipse.exe using the same 
workspace.

__2. From the main menu, select File →  New →  Maven Project

__3. Click the check box for “Create a simple project (skip archetype selection)”, and 
then click Next.

__4. We need to provide the so-called “Maven Coordinates” that will identify the artifacts 
produced by this project, and optionally a name and description for the project.  Enter the 
following fields:

Group Id: com.mycom.demo
Artifact Id: hello-world
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__5. Leave the Version and Packaging fields at their default values.  

__6. Leave the Parent Project fields empty.  

__7. The dialog should look like:

__8. Click Finish.  The system will create the project we've asked for.

Part 2 - Explore the Project Structure
In the section above, we created the new project.  Let's take a look at the project structure 
and the files that were created by the IDE.

__1. In the Project Explorer, expand the node for the hello-world project.

__2. Notice that the IDE has created folders named “src/main/java”, 
“src/main/resources”, “src/test/java”, “src/test/resources”, and “target”.  This 
structure for the project folder is Maven's default structure.  All the inputs to the build 
process are stored under the “src” hierarchy, and all the outputs are under the “target” 
hierarchy.  This structure will be the same for any Maven project.

__3. Double-click “pom.xml” to open it in the Project Object Model editor.  At the 
bottom of the editor, you should see a number of tab labels, with the Overview tab 
currently selected.
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__4. This view shows us the Maven Project Object Model and lets us edit it in a user-
friendly fashion.  You can see the coordinates that we entered when we created the 
project.

__5. Click on the pom.xml tab.  This view displays the raw XML formatted text of the 
Project Object Model.  At the present time, all we really have is the project coordinates.

__6. Click on the Effective POM tab.  This view shows the results of combining the 
projects POM with the “Super-POM” that is built into Maven.  If you scroll down 
through the effective POM, you'll see the defaults for the various plugin configurations 
that are built into Maven, as well as the required locations for things like resources, 
output directories, etc.

__7. Click on the Dependencies tab.  This view shows what libraries are referenced from 
this project.  Right now, the project doesn't reference any dependencies.  In the next step, 
we'll change that to add a dependency on the JUnit test framework.

__8. Click on the Add... button underneath Dependencies

__9. In the field marked Enter groupId,..., type 'junit'.  After a second or two, the Search 
Results box will populate with a link to the “junit” library.  Expand the node for junit.

__10. When we clicked on the junit node, the Group Id, Artifact Id, and Version fields 
were automatically filled in.  However, we'd like to use a newer version of JUnit.  What's 
happened is that the search box has searched our local repository 
(<HOME>\.m2\repository) for possible matches.  JUnit 3.1.1 is already there, because 
some component of Maven or m2eclipse depends on it.  We can override the version even 
though the version we want is not currently in the local repository – Maven will go get it 
when we do the build.

__11. In the Version field, enter '4.11'.  (typically we would discover the current version 
through an internet search, or by querying Maven Central at http://search.maven.org)
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__12. In the Scope drop-down box, select test. When the dialog looks similar to the 
following, click OK.

Part 3 - Perform a “Priming” Build
At this point, we have a dependency on JUnit 4.1.1 in our project, but because we've 
never used that dependency before, the jar file for JUnit 4.1.1 is not available in our local 
repository.  Even though we don't have any code in the project yet, we can perform a 
build that will cause Maven to download the dependencies from Maven Central or 
another repository.  This is sometimes referred to as a “Priming Build”.

__1. In the Project Explorer, right-click on pom.xml and then select Run As →  Maven 
Build.  The system will display the Edit Configuration dialog.

__2. Since this is the first time we've run a Maven build, we need to specify what goal we 
want to build.  In the Goals field, enter 'install', and then click Run

__3. The system may display a Save Resource dialog.  If so, click Yes to save any 
changes that we've made.

__4. If you watch the console, you'll probably see quite a lot of “Downloading...” 
messages, and finally an indication of “Build Success”.

What has happened is that Maven has downloaded all the required project dependencies 
to the local repository in “<HOME>\.m2”.  But the only dependency we mentioned was 
the JUnit jar file, so why did so many files get downloaded?  Maven uses the dependency 
resolution mechanism to resolve any dependencies that Maven or any plugin needs.  So 
effectively, Maven just downloaded most of the “real” Maven installation; when we 
installed Maven, it was really just the “boot loader” for Maven.
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Part 4 - Add Some Code
__1. In the Project Explorer, right-click on src/main/java and select New →   Class.

__2. Enter a Package of “com.mycom.demo” and “HelloWorld” for the class name, and 
then click Finish.

__3. Edit the new class to include the main(...) method shown below.

public class HelloWorld {
public static void main(String[] args) {

System.out.println("Hello World");
}

}

__4. Save the file by clicking File →  Save or by typing Ctrl-S.  At this point, you could 
run the file by right-clicking and selecting Run As →  Java Application, but we don't 
really need to.

__5. In the Project Explorer, right-click on pom.xml and select Run As →  Maven 
build.  You should see the build progress in the console, ending with BUILD SUCCESS.

__6. In the Project Explorer, right-click on the target node and then select Refresh.

__7. Expand the target node. You should now see the jar file that is generated by the 
project – this is the standard Maven output for a packaging type of 'jar'.

__8. From the menu, select File → Close All. 

Part 5 - Review
In this lab, we created a simple Maven project using m2eclipse.  Running the Maven 
build caused all of the standard build plugins and their dependencies to be downloaded to 
our local repository.  Also, as a result of the build, the Maven archiver plugin generated a 
jar file that holds the compiled classes in our project.
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Lab 3 - Create a Web Application from an Archetype
In this lab we're going to use a Maven archetype to generate a basic web application, 
including the source folder structure and the Project Object Model.  After we add a small 
amount of functionality, we'll examine two methods of running the web application using 
Apache Tomcat.  First we'll run Tomcat as an embedded add-on to a Maven build, and 
then we'll use the Tomcat Maven plugin to deploy the web application to a stand-alone 
Tomcat container.

Part 1 - Create the Project
Previously, when we created a Maven project in Eclipse, we requested a simple project, 
with a basic Project Object Model.  However, Maven and m2eclipse offers another 
option.  We can use a Maven archetype to build a project according to a predefined 
structure.  In this way, we can build a standard style of project very quickly.

__1. Make sure that Eclipse is running.  If not, start it by double-clicking on the 
“Eclipse.exe” entry in “C:\Software\Eclipse”.

__2. In the main menu, select File →  New →  Maven Project.

__3. The system will display the New Maven Project dialog.  Ensure that the box 
marked Create a simple project (skip archetype selection) is un-checked, and click 
Next.

__4. In the Filter field, enter 'webapp'.  

__5. The set of archetypes will be narrowed down to the ones that include the word 
'webapp' in the archetype name.  Click on the row with Artifact Id as 'maven-
archetype-webapp', and then click Next.
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__6. Enter 'com.mycom.demo' as Group Id.

__7. In the Artifact Id field, enter 'mywebapp'

__8. Enter 'com.mycom.demo.mywebapp' as Package.

__9. Click Finish.

__10. After a few seconds, the Project Explorer will show the new project.  Expand the 
node for mywebapp, and then expand the src → main → webapp node.

__11. Notice that the folder structure includes the structure of a standard web application, 
including a WEB-INF directory.  If you want, expand the WEB-INF folder to see that 
there is a web.xml file in it.

Unfortunately, there isn't a folder for Java sources in the default archetype.  So to add a 
servlet, we're going to need to create one.

__12. Right-click on the src →  main node in the Project Explorer and then select New 
→  Folder.  
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__13. Enter 'java' as the folder name and then click Finish.

__14. In the Project Explorer, right-click on mywebapp, and then select Maven → 
Update Project..., and then click OK.

Now we have a project that we can create servlets in.

Part 2 - Create a “Hello World” Servlet
__1. Expand the Project Explorer node for Java Resources, to expose the node for 
src/main/java.

__2. Right-click on the src/main/java node and then select New → Other.

__3. Expand Web from the list, select Servlet and then click Next.
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__4. Enter the following in the Create Servlet dialog:

Java Package: com.mycom.demo

Class Name: HelloServlet

__5. Click Finish.

The system creates a servlet class and displays it in the editor.  Notice that there will be 
errors.  Specifically, eclipse does not currently recognize the HttpServlet class, or any 
other classes defined in the Servlet API.  We need to add a dependency on the Servlet 
API.

__6. Double-click on pom.xml in the Project Explorer to open it.

__7. Click on the Dependencies tab.

__8. Click on  the Add... button under Dependencies.

__9. Enter the following values:

Group Id: javax.servlet

Artifact Id: servlet-api

Version: 2.4

__10. Select provided in the Scope drop-down.
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__11. When the dialog appears as follows, click OK

__12. Save the file by pressing Ctrl-S or using File → Save from the main menu.

__13. Close the pom.xml file.

__14. You should see the resolution errors in HelloServlet.java disappear.  If not, 
execute the install phase of the Maven build, so as to trigger Maven to load the servlet 
API to the local repository.

__15. Let's put some code into the HelloServlet.java servlet, so we can run it.  Edit the 
doGet(...) method so it looks like:

protected void doGet(HttpServletRequest request, 
HttpServletResponse response) throws ServletException, IOException {

response.setContentType("text/html");
PrintWriter out=response.getWriter();
out.println("<html><body>Hi there!</body></html>");

}

__16. Press Ctrl-Shift-O to organize the imports.

__17. Save the file.

__18. Right-click on pom.xml in the Project Explorer and select Run As → Maven 
install.  

__19. You should see the build end with Build Success.
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Part 3 - Test the Web Application
There is more than one way to run the application for testing.  First we'll reference the 
Apache Tomcat Maven plugin and run an embedded version of Tomcat within the Maven 
build.

__1. Open the file pom.xml

__2. Click on the tab marked pom.xml tab to select the XML source.

__3. Near the bottom of the file, edit the <build> element so it appears as follows (the 
text to be added is shown in bold):

<build>
   <finalName>mywebapp</finalName>
   <pluginManagement>
      <plugins>
         <plugin>           
            <groupId>org.apache.tomcat.maven</groupId>
            <artifactId>tomcat6-maven-plugin</artifactId>
            <version>2.2</version>
            <configuration>
               <port>9090</port>
            </configuration>
         </plugin>
      </plugins>
   </pluginManagement>
</build>

The text above configures the Apache Tomcat plugin.

__4. Save the file.

__5. Right-click on pom.xml in the Project Explorer, and then select Run As → 
Maven Build....  (Note the '...'  We need to create a new run configuration).

__6. Under Goals enter tomcat6:run and then click Run.
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__7. Watch the Console view.  You will probably see a flurry of file downloads as Maven 
gets the Tomcat plugin from Maven Central.  In the end, the console will say 

INFO: Starting Coyote HTTP/1.1 on http-9090

__8. Open a web browser and enter:

http://localhost:9090/mywebapp/HelloServlet

We haven't installed Apache Tomcat, but the plugin has downloaded all the required jar 
files and setup an embedded version of the Tomcat server.  This gives us a convenient 
way to run a web app using only the Maven infrastructure (similar plugins are available 
for most web servers).

__9. In the Console view, click on the red 'stop' button to stop the Maven build that is 
running the Tomcat server.

__10. Close the web browser.

Part 4 - Install and Run Apache Tomcat
It's also possible to install and run the Apache Tomcat server, or any other server 
supported by Eclipse WTP.  

__1. Right-click in the Servers view and select New → Server
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__2. The system will show the New Server dialog.  Expand the Apache node and select 
Tomcat v6.0 Server and then click Next.

__3. Click on the Browse... button and navigate to 'C:\Software\apache-tomcat-6.0.37', 
and then click OK.

__4. Click Finish.

__5. The server will be added.

__6. Right click the server and select Open.
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__7. Expand Ports section.

__8. Change the HTTP/1.1 port to 8085

__9. Save and close the Server window.

__10. In the Project Explorer, find the node for HelloServlet.java

__11. Right-click on HelloServlet.java and then select Run As → Run on Server. 
When the Run On Server dialog is displayed, click Finish.

__12. Windows may show a security alert dialog.  If it does, click on Allow Access.

__13. The system will open a web browser inside Eclipse and show the selected page.

That's it – We're running the web application in Tomcat using the functionality that's built 
into Eclipse WTP.

__14. In the Servers view, right-click on the Tomcat node and select Stop.

__15. From the menu, select File → Close All.
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Part 5 - Review
In this lab, we created a basic web application using a Maven archetype and ran it two 
different ways.  First, we specified the Apache Tomcat Maven plugin and ran the web app 
using a Tomcat instance embedded within Maven.  Second, we setup a Tomcat server in 
Eclipse and then ran the application using that server.

Copyright 2017 Web Age Solutions Inc. 20

EVALU
ATIO

N O
NLY


	Lab 1 -  Install Maven
	Part 1 -  Test Maven
	__1.  Open a file explorer a navigate to C:\Software\apache-maven-3.1.1
	__2.  Open a command prompt window (in the start menu, click All Programs --> Accessories --> DOS Prompt.
	__3.  In the command window, type:
	__4.  You should see output similar to:

	Part 2 -  Setup Maven in Eclipse
	__1.  Use Windows Explorer to navigate to C:\Software\eclipse, and then double-click on 'eclipse.exe' to start up the IDE.
	__2.  You may see a security dialog.  If so, un-check the box for “Always ask before opening this file” and then click Run.
	__3.  Change the workspace to C:\Workspace and click OK.
	__4.  Eclipse Kepler will start launching.
	__5.  Close the Welcome screen by clicking the 'X' next to Welcome on the tab.
	__6.  From the main menu, select Window --> Preferences and then expand the tree node for Maven.
	__7.  Click on the tree node for Installations.
	__8.  On the right-hand side of the Preferences window, click on the Add... button.
	__9.  Navigate to C:\Software\apache-maven-3.1.1, ensure the node is selected, and click OK.
	__10.  In the Preferences dialog, verify Maven path and click OK.

	Part 3 -  Review

	Lab 2 -  Create a Maven Project
	Part 1 -  Create a Project
	__1.  If necessary, start eclipse from C:\Software\eclipse\eclipse.exe using the same workspace.
	__2.  From the main menu, select File →  New →  Maven Project
	__3.  Click the check box for “Create a simple project (skip archetype selection)”, and then click Next.
	__4.  We need to provide the so-called “Maven Coordinates” that will identify the artifacts produced by this project, and optionally a name and description for the project.  Enter the following fields:
	__5.  Leave the Version and Packaging fields at their default values.  
	__6.  Leave the Parent Project fields empty.  
	__7.  The dialog should look like:
	__8.  Click Finish.  The system will create the project we've asked for.

	Part 2 -  Explore the Project Structure
	__1.  In the Project Explorer, expand the node for the hello-world project.
	__2.  Notice that the IDE has created folders named “src/main/java”, “src/main/resources”, “src/test/java”, “src/test/resources”, and “target”.  This structure for the project folder is Maven's default structure.  All the inputs to the build process are stored under the “src” hierarchy, and all the outputs are under the “target” hierarchy.  This structure will be the same for any Maven project.
	__3.  Double-click “pom.xml” to open it in the Project Object Model editor.  At the bottom of the editor, you should see a number of tab labels, with the Overview tab currently selected.
	__4.  This view shows us the Maven Project Object Model and lets us edit it in a user-friendly fashion.  You can see the coordinates that we entered when we created the project.
	__5.  Click on the pom.xml tab.  This view displays the raw XML formatted text of the Project Object Model.  At the present time, all we really have is the project coordinates.
	__6.  Click on the Effective POM tab.  This view shows the results of combining the projects POM with the “Super-POM” that is built into Maven.  If you scroll down through the effective POM, you'll see the defaults for the various plugin configurations that are built into Maven, as well as the required locations for things like resources, output directories, etc.
	__7.  Click on the Dependencies tab.  This view shows what libraries are referenced from this project.  Right now, the project doesn't reference any dependencies.  In the next step, we'll change that to add a dependency on the JUnit test framework.
	__8.  Click on the Add... button underneath Dependencies
	__9.  In the field marked Enter groupId,..., type 'junit'.  After a second or two, the Search Results box will populate with a link to the “junit” library.  Expand the node for junit.
	__10.  When we clicked on the junit node, the Group Id, Artifact Id, and Version fields were automatically filled in.  However, we'd like to use a newer version of JUnit.  What's happened is that the search box has searched our local repository (<HOME>\.m2\repository) for possible matches.  JUnit 3.1.1 is already there, because some component of Maven or m2eclipse depends on it.  We can override the version even though the version we want is not currently in the local repository – Maven will go get it when we do the build.
	__11.  In the Version field, enter '4.11'.  (typically we would discover the current version through an internet search, or by querying Maven Central at http://search.maven.org)
	__12.  In the Scope drop-down box, select test. When the dialog looks similar to the following, click OK.

	Part 3 -  Perform a “Priming” Build
	__1.  In the Project Explorer, right-click on pom.xml and then select Run As →  Maven Build.  The system will display the Edit Configuration dialog.
	__2.  Since this is the first time we've run a Maven build, we need to specify what goal we want to build.  In the Goals field, enter 'install', and then click Run
	__3.  The system may display a Save Resource dialog.  If so, click Yes to save any changes that we've made.
	__4.  If you watch the console, you'll probably see quite a lot of “Downloading...” messages, and finally an indication of “Build Success”.

	Part 4 -  Add Some Code
	__1.  In the Project Explorer, right-click on src/main/java and select New →   Class.
	__2.  Enter a Package of “com.mycom.demo” and “HelloWorld” for the class name, and then click Finish.
	__3.  Edit the new class to include the main(...) method shown below.
	__4.  Save the file by clicking File →  Save or by typing Ctrl-S.  At this point, you could run the file by right-clicking and selecting Run As →  Java Application, but we don't really need to.
	__5.  In the Project Explorer, right-click on pom.xml and select Run As →  Maven build.  You should see the build progress in the console, ending with BUILD SUCCESS.
	__6.  In the Project Explorer, right-click on the target node and then select Refresh.
	__7.  Expand the target node. You should now see the jar file that is generated by the project – this is the standard Maven output for a packaging type of 'jar'.
	__8.  From the menu, select File → Close All. 

	Part 5 -  Review

	Lab 3 -  Create a Web Application from an Archetype
	Part 1 -  Create the Project
	__1.  Make sure that Eclipse is running.  If not, start it by double-clicking on the “Eclipse.exe” entry in “C:\Software\Eclipse”.
	__2.  In the main menu, select File →  New →  Maven Project.
	__3.  The system will display the New Maven Project dialog.  Ensure that the box marked Create a simple project (skip archetype selection) is un-checked, and click Next.
	__4.  In the Filter field, enter 'webapp'.  
	__5.  The set of archetypes will be narrowed down to the ones that include the word 'webapp' in the archetype name.  Click on the row with Artifact Id as 'maven-archetype-webapp', and then click Next.
	__6.  Enter 'com.mycom.demo' as Group Id.
	__7.  In the Artifact Id field, enter 'mywebapp'
	__8.  Enter 'com.mycom.demo.mywebapp' as Package.
	__9.  Click Finish.
	__10.  After a few seconds, the Project Explorer will show the new project.  Expand the node for mywebapp, and then expand the src → main → webapp node.
	__11.  Notice that the folder structure includes the structure of a standard web application, including a WEB-INF directory.  If you want, expand the WEB-INF folder to see that there is a web.xml file in it.
	__12.  Right-click on the src →  main node in the Project Explorer and then select New →  Folder.  
	__13.  Enter 'java' as the folder name and then click Finish.
	__14.  In the Project Explorer, right-click on mywebapp, and then select Maven →  Update Project..., and then click OK.

	Part 2 -  Create a “Hello World” Servlet
	__1.  Expand the Project Explorer node for Java Resources, to expose the node for src/main/java.
	__2.  Right-click on the src/main/java node and then select New → Other.
	__3.  Expand Web from the list, select Servlet and then click Next.
	__4.  Enter the following in the Create Servlet dialog:
	__5.  Click Finish.
	__6.  Double-click on pom.xml in the Project Explorer to open it.
	__7.  Click on the Dependencies tab.
	__8.  Click on  the Add... button under Dependencies.
	__9.  Enter the following values:
	__10.  Select provided in the Scope drop-down.
	__11.  When the dialog appears as follows, click OK
	__12.  Save the file by pressing Ctrl-S or using File → Save from the main menu.
	__13.  Close the pom.xml file.
	__14.  You should see the resolution errors in HelloServlet.java disappear.  If not, execute the install phase of the Maven build, so as to trigger Maven to load the servlet API to the local repository.
	__15.  Let's put some code into the HelloServlet.java servlet, so we can run it.  Edit the doGet(...) method so it looks like:
	__16.  Press Ctrl-Shift-O to organize the imports.
	__17.  Save the file.
	__18.  Right-click on pom.xml in the Project Explorer and select Run As → Maven install.  
	__19.  You should see the build end with Build Success.

	Part 3 -  Test the Web Application
	__1.  Open the file pom.xml
	__2.  Click on the tab marked pom.xml tab to select the XML source.
	__3.  Near the bottom of the file, edit the <build> element so it appears as follows (the text to be added is shown in bold):
	__4.  Save the file.
	__5.  Right-click on pom.xml in the Project Explorer, and then select Run As →  Maven Build....  (Note the '...'  We need to create a new run configuration).
	__6.  Under Goals enter tomcat6:run and then click Run.
	__7.  Watch the Console view.  You will probably see a flurry of file downloads as Maven gets the Tomcat plugin from Maven Central.  In the end, the console will say 
	__8.  Open a web browser and enter:
	__9.  In the Console view, click on the red 'stop' button to stop the Maven build that is running the Tomcat server.
	__10.  Close the web browser.

	Part 4 -  Install and Run Apache Tomcat
	__1.  Right-click in the Servers view and select New → Server
	__2.  The system will show the New Server dialog.  Expand the Apache node and select Tomcat v6.0 Server and then click Next.
	__3.  Click on the Browse... button and navigate to 'C:\Software\apache-tomcat-6.0.37', and then click OK.
	__4.  Click Finish.
	__5.  The server will be added.
	__6.  Right click the server and select Open.
	__7.  Expand Ports section.
	__8.  Change the HTTP/1.1 port to 8085
	__9.  Save and close the Server window.
	__10.  In the Project Explorer, find the node for HelloServlet.java
	__11.  Right-click on HelloServlet.java and then select Run As → Run on Server.  When the Run On Server dialog is displayed, click Finish.
	__12.  Windows may show a security alert dialog.  If it does, click on Allow Access.
	__13.  The system will open a web browser inside Eclipse and show the selected page.
	__14.  In the Servers view, right-click on the Tomcat node and select Stop.
	__15.  From the menu, select File → Close All.

	Part 5 -  Review

	Lab 4 -  Add Web Site, Static Analysis, and Code Coverage 
	Part 1 -  Generate the Web Site
	__1.  Open a Command window by clicking the Start Menu →  All Programs →  Accessories →  Command Prompt.
	__2.  Change directory to the project's home directory.  In this case, the project is inside Eclipse's workspace, so we can enter (your typing is in bold.  Note that the prompt may appear different on your machine):
	__3.  From here, run the 'site' goal from the command line.
	__4.  Now if you navigate (using Windows Explorer) to the 'target' directory under the project directory (in this case 'C:\Workspace\hello-world\target', you will find a new directory called 'site'.  Navigate to the 'site' directory and double-click on index.html.  The system will open a web browser window and display the project's web site.
	__5.  While you're there, you can also explore the webpage.  Basically it lists all the information that's in the POM.
	__6.  Go back to Eclipse, and expand the src node in the Project Explorer under the hello-world project.  
	__7.  Right-click on src and then select New →  Folder.
	__8.  In the New Folder dialog, enter site as the folder name, and then click Finish.
	__9.  Using the same technique as above, create a folder under src > site called markdown.
	__10.  Right-click on the src > site > markdown node and select New →  File.  
	__11.  Enter 'index.md' as the file name.
	__12.  Enter the following text into the new file:
	__13.  Save the file.
	__14.  Back in the Command Prompt window, execute mvn site again.
	__15.  Go back to the browser and hit the refresh button.
	__16.  Note that the 'About' page now looks like this:

	Part 2 -  Add Static Analysis
	__1.  Using Windows Explorer, navigate to C:\LabFiles\AddStaticAnalysis.
	__2.  Right-click on the file 'ExpressionParser.java' and then select Copy.
	__3.  In the Project Explorer in Eclipse, right-click on the node for 'com.mycom.demo' underneath 'src/main/java', and then select Paste.
	__4.  Right-click on the node for 'src/test/java' in the Project Explorer, and then choose New →  Package. Enter 'com.mycom.demo' as the package name, and then click Finish.
	__5.  Now go back to the Windows Explorer.  Right-click 'TestExpressionParser.java' and then choose Copy.
	__6.  In the Project Explorer, paste the file into the 'com.mycom.demo' package underneath 'src/test/java'.
	__7.  Run a “Maven install” on the hello-world project (Right-click on the 'hello-world' project, and then choose 'Run As →  Maven install').
	__8.  You should note that in addition to the build output we've seen so far, there is also a section that reports unit test results, you may need to scroll up in the Console.
	__9.  Now we can configure the PMD plugin.  Open the 'pom.xml' file for the 'hello-world' project.
	__10.  Insert the following text underneath the </dependencies> tag:
	__11.  Save the pom.xml file.
	__12.  As in the previous part, run 'mvn site' from the Command Prompt and look at the generated site in your browser.
	__13.  Refresh the page and click on Project Information  link at the left menu.
	__14.  You will now see a 'Project Reports' section in the generated site (last in the menu), click on it.
	__15.  You can browse at the PMD Report and CPD Report.  In this case, PMD has reported that we have an unused private field in 'ExpressionParser.java'.

	Part 3 -  Add Code Coverage Report
	__1.  Open the 'pom.xml' file for 'hello-world' if necessary.
	__2.  Add the following lines inside the plugins element in the reporting section (add the code that is bold).
	__3.  Just like before, save the 'pom.xml' file, run 'mvn site', and refresh the browser. 
	__4.  You should now find a 'Cobertura Test Coverage' report in the 'Project Reports' section. 
	__5.  Click on Cobertura Test Coverage, then click on the package link for 'com.mycom.demo'.  The report should look something like this:
	__6.  Click on the ExpressionParser class link.  The report will show a line-by-line report of the test coverage for ExpressionParser.
	__7.  Back in Eclipse, from the menu, select File -> Close All. 
	__8.  Close the browser and the command prompt window.
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	Lab 5 -  A Multi-Module Project
	Part 1 -  Create a multi-module project
	__1.  Open the eclipse if it's not opened from C:\Software\eclipse\eclipse.exe and then choose the workspace location as C:\workspace. 
	__2.  From the menu, select Window → Open Perspective → Java. 
	__3.  Create a general project, from the menu select, File → New → Project.
	__4.  Choose Project under General tab and click Next.
	__5.  Enter SimpleParentProject for project name.
	__6.  Click Finish.
	A general project is created. Now let's put the pom.xml for this project.
	__7.  Right click SimpleParentProject and select New → File.
	__8.  Enter pom.xml for file name and click Finish.
	__9.  File opens, at the bottom of the file select pom.xml.
	This file is already available. We will copy the content.
	__10.  Open C:\LabFiles\A Multi-Module Project\SimpleParentProject\SimpleParentProject-pom.xml file using a text editor.
	__11.  Copy the content and then paste it to the pom.xml file you created in the eclipse.
	Go through the pom.xml, 2 main element you should notice, <packaging> is set to pom since it consists of a pom.xml file but no artifact and <module> is set to SimpleProject. Meaning there will be a sub-module called SimpleProject exists to process.
	__12.  Save the file.
	__13.  Right-Click SimpleParentProject, and create a folder called SimpleProject to represent the parent project.
	__14.  Create a pom.xml file within SimpleProject folder.
	__15.  Copy the content of C:\LabFiles\A Multi-Module Project\SimpleParentProject\SimpleProject-pom.txt file into pom.xml.
	Notes: 
	__16.  Save the file.
	__17.  Create a folder inside SimpleProject called simple-delay
	__18.  Copy the src folder from C:\LabFiles\A Multi-Module Project\SimpleParentProject\simple-delay into simple-delay folder in the eclipse.
	__19.  Also copy the C:\LabFiles\A Multi-Module Project\SimpleParentProject\simple-delay\pom.xml file to the simple-delay folder in the eclipse.
	__20.  Open the file, add an empty space at the end of the file and save the file to make sure you can edit in the file. 
	__21.  The project structure in the eclipse should be as shown below:
	Now lets work on simple-webapp module:
	__22.  Create a folder inside SimpleProject called simple-webapp
	__23.  Copy the src folder from C:\LabFiles\A Multi-Module Project\SimpleParentProject\simple-webapp into simple-webapp folder in the eclipse.
	__24.  Also copy the pom.xml file from C:\LabFiles\A Multi-Module Project\SimpleParentProject\simple-webapp folder and put it in simple-webapp folder in the eclipse.
	__25.  The project structure for simple-webapp in the eclipse should be as shown below:
	We have just completed the multi-module maven project. Lets run the package. 
	__26.  Open a command prompt and change the directory to C:\workspace\SimpleParentProject.
	__27.  Run the following command:
	__28.  See the console output as below:
	__29.  Run the following command:
	__30.  You would see the a successful built in the console output.
	__31.  Scroll up a locate the following messages.
	__32.  Refresh the eclipse root directory, you would see the generated artifacts:
	__33.  You have done the basic build.
	You can try this build using jenkins by importing the project to SVN and then configure the jenkins to get the root pom.xml configured.
	__34.  From the menu, select File -> Close All. 
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	Lab 6 -  Create a Standard Set of Dependencies
	Part 1 -  Define dependency
	__1.  Make sure eclipse is opened.
	__2.  Open a browser and locate the folder C:\LabFiles\Create a Standard Set of Dependencies\SimpleGreeting. 
	__3.  Copy the SimpleGreeting folder into C:\Workspace.
	__4.  In eclipse, from the menu select File → Import. 
	__5.  Expand General, select Existing Projects into Workspace and click Next.
	
	__6.  Click browse button beside “Select root directory”.
	__7.  Select the project folder C:\Workspace\SimpleGreeting.
	__8.  Click Finish.
	__9.  Expand the SimpleGreeting project and open Log4JGreeting.java file.
	You would see that Log4J standard library has been used in this class, that means when this file get compiled correct Log4J jar file is needed. We will now configure the pom to get the jar using dependency element.
	__10.  Open pom file from the SimpleGreeting project and select the pom.xml tab.
	__11.  Enter an empty line after the first dependency and add the log4J dependency (maven coordinates) shown below:
	This means, It will download the log4j version 1.2.14 library automatically. If the “version” tag is ignored, it will upgrade the library automatically when there is a newer version.
	__12.  Save the file.
	__13.  Dependencies element should be as shown below:
	__14.  Open command prompt and change the folder to C:\Workspace\SimpleGreeting.
	__15.  Run the command:
	__16.  You will see a BUILD success message, scroll up and locate the messages where log4j library were downloaded during the command.
	Search log4j in Maven local repository.
	Search log4j in Maven central repository.
	Search log4j in Maven remote repository (if defined in pom.xml).
	__17.  Close all command prompt windows.
	__18.  In eclipse, from the menu, select File -> Close All. 
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	Lab 7 -  Write a Simple  Maven Plugin
	Part 1 -  Add Maven JavaDoc Plugin
	__1.  Make sure eclipse is opened.
	__2.  Open a browser and locate the folder C:\LabFiles\Write a Simple Maven Plugin\SimpleGreetingPlugin. 
	__3.  Copy the SimpleGreetingPlugin folder into C:\Workspace.
	__4.  From the menu, select File → Import... 
	__5.  Expand General select Existing Projects and click Next.
	__6.  Click browse button beside “Select root directory”.
	__7.  Select C:\Workspace\SimpleGreetingPlugin
	__8.  Click Finish.
	__9.  Expand the SimpleGreetingPlugin project and open Log4JGreeting.java and Greeting.java file.  There are java doc define in those classes.
	Next we will configure plug-in to generate java doc.
	__10.  Open the pom.xml file from the SimpleGreetingPlugin project.
	__11.  You would see that there is already a plug-in defined. We will define another plug-in and see the action.
	__12.  Enter an empty line after the first <plugin> and add the  java doc plug-in (maven coordinates) shown below:
	__13.  Save the pom file.

	Part 2 -  Build and Deploy
	__1.  Open command prompt.
	__2.  Change the folder to C:\workspace\SimpleGreetingPlugin
	__3.  Run the command:
	__4.  Look at the console output:
	Java doc JAR is generated.
	Look further down on the console output:
	__5.  Refresh your project in eclipse.
	__6.  Expand the project, you would see there are 2 JAR files and java doc folder also created:

	Part 3 -  Creating a project
	The first step is to create the project containing the custom maven plugin. This project is quite different from the regular java project because it is not a regular java artifact like JAR, WAR etc. Instead it is going to be a maven plugin project.
	__1.  In the command prompt, change the directory to “C:\Workspace”.
	__2.  Run the following command to create the maven plugin project.
	mvn archetype:create -DgroupId=com.simple -DartifactId=SimpleDatePlugin -DarchetypeArtifactId=maven-archetype-mojo
	The above command creates a project with the name SimpleDatePlugin with the standard directory layout containing the source. 
	__3.  Using a File browser expand  C:\workspace\SimpleDatePlugin
	__4.  With notepad open the pom.xml file created under  C:\workspace\SimpleDatePlugin\
	If you look into the POM file, the package type is maven-plugin to indicate that this is a maven plugin project.
	__5.  Close the file.
	__6.  Change the directory on the command prompt window to "C:\workspace\SimpleDatePlugin".
	__7.  Run the following command to make it eclipse project which creates the Eclipse .project and .classpath files so that we can open it in the eclipse.
	__8.  You should get the success build:
	__9.  In eclipse, from the menu, select File → Import...  Expand General select Existing Projects and click Next.
	__10.  Click browse button beside “Select root directory”. Select C:\Workspace\SimpleDatePlugin and click Finish.
	__11.  In the Package Explorer view, the project should look like as below:

	Part 4 -  Creating a plugin
	In Maven, the plugin that achieves a specific task is called by the name MOJO (Maven Old Java Object similar to POJO). A MOJO defines the goal which is nothing but the custom action which is executed upon user’s request.
	We will create a custom plugin which will simply display the current date information.
	__1.  Right click SimpleDatePlugin and select New → class. 
	__2.  Enter DisplayCurrentDate for the class name.
	__3.  Enter com.simple for  package name.
	__4.  Enter org.apache.maven.plugin.AbstractMojo for Super class.
	__5.  Click Finish.
	__6.  Annotate the following java doc comments just above the class name:
	__7.  Enter the following code in the execute() method.
	__8.  Enter “Ctrl+Shift+O” to import packages.
	__9.  If prompt for the package to choose, select java.util.Date.
	__10.  Save the file.
	__11.  The source code should be as shown below:

	Part 5 -  Compiling the project
	__1.  First make sure you are at the following directory on the command prompt:
	"C:\workspace\SimpleDatePlugin"
	__2.  Run the following command for compiling the maven plugin project which will compile the java classes.
	One java class is compiled if you are compiling first time, otherwise you will get Nothing to compile message as shown below:

	Part 6 -  Packaging the project
	__1.  Enter the following command to package the plugin project which will package the classes into jar.
	The plugin class is packaged into JAR.

	Part 7 -  Installing the project
	__1.  To install the project into the local Maven repository, issue the following command.
	__2.  Go to your  maven local repository directory to check the plugin install at local repository.
	There are several ways to run the maven plugin. 

	Part 8 -  Run plugin in stand-alone mode
	__1.  Enter the following command:
	__2.  You should see the current date shown in the Console, that means our plugin works.

	Part 9 -  Add Maven Plugin to Build Process
	__1.  In the eclipse, open the pom file of the SimpleGreetingPlugin project.
	__2.  Add the following plugin above </plugins> element which is inside the <build> element:
	__3.  The plugin portion of the pom should looks like shown below:
	__4.  Save the file.
	__5.  On the command prompt, change the directory to C:\workspace\SimpleGreetingPlugin
	__6.  Run the command.
	__7.  Your console should show the goal executed during compile phase as shown below:
	You have successfully create and build custom plugin. You can try configuring this to execute on maven install process and make the Jenkins work as well.
	__8.  Close the command prompt window used in this lab.
	__9.  In eclipse, from the menu, select File →  Close All. 
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	Lab 8 -  Create an Archetype
	Part 1 -  Create your skeleton project
	__1.   Back in the Eclipse Package Explorer view, find the SimpleParentProject as shown below:
	__2.  Using command prompt, change the directory to where parent pom file, C:\workspace\SimpleParentProject.
	__3.  Run the following target to create the project.
	__4.  Back in the eclipse, refresh the project folder, you would see the archetype.

	Part 2 -   Install the archetype locally
	__1.  In the prompt, change the directory to C:\workspace\SimpleParentProject\target\generated-sources\archetype
	__2.  Run the following command to install.
	__3.  You should see the following console output as shown below:
	__4.  Now let's go to user's .m2 directory and look for  archetype-catalog.xml. Remember the users directory on Windows Vista/7 is under C:\Users\<username>\.m2
	__5.  Open the file using an editor.
	__6.  Close the file.

	Part 3 -  Create New project from Newly created Archetype
	__1.  Create a folder called test-archetype in the C:\LabFiles folder.
	__2.  Change the directory to  test-archetype as shown below: 
	__3.  Run the following command:
	__4.  Select 1 to create the com.simple.multi:parent-archetype(parent-archetype) project.
	__5.  Enter:
	__6.   Enter:
	__7.  Enter: 
	__8.  Enter:
	__9.  Enter Y to complete the task.
	__10.  Change the directory as follows:
	__11.  Run this command to make it eclipse project.
	Build is successful, now we can import the project into eclipse and check the structure of the project to make sure it is from template. 
	__12.  In eclipse, from the menu, select File → Switch Workspace → Other.
	__13.  Enter  C:\workspace_temp and click OK.
	__14.  Wait until eclipse re-starts and then close the Welcome page.
	__15.  From the menu select, File → Import … then expand General and select Existing Project into workspace and click Next.
	__16.  Click the Browse  button next to Select root directory and navigate to C:\LabFiles\maven-archetype-test folder.
	
	__17.  Click Finish.
	__18.  You would see that the structure is similar in the other workspace location.
	__19.  Close the command prompt used in this lab and all open files.
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	Lab 9 -  Create a Corporate Repository
	Part 1 -  Setup Maven Repository with JFrog Artifactory
	__1.   Using Windows Explorer, navigate to the folder C:\Software\artifactory-3.3.0\bin.
	__2.  In the Explorer window, locate the file artifactory.bat.  Right-click on the file and select Edit.  Windows will open the file in a text editor.
	__3.  In the editor, locate the line that begins with 'set JAVA_OPTIONS'.
	__4.  The line above sets the startup options for the Java Virtual Machine.  Note the entry '-Xmx2g'.  That entry sets the maximum memory to 2GB.  Change the entry to read '-Xmx1g'.  Leave the other entries on the JAVA_OPTIONS line as-is.
	__5.  Save and close the file.
	__6.  Using the Windows Start Menu, open a command prompt.
	__7.  Change the directory to:
	__8.  Run Artifactory from the command line, by typing 
	__9.  If Windows displays the Windows Security Alert dialog, click on Allow Access.
	__10.  Minimize but do not close the command prompt window.  Closing the window will shut down Artifactory.  If you do accidentally close the command prompt window, repeat steps 6-10 above.
	__11.   Navigate to the following URL using Mozilla browser: 

	Part 2 -  Creating a Test project
	__1.  Open another command prompt window.  Change the directory of your prompt to C:\workspace
	__2.  Run the following command to generate a new project using a maven archetype.
	__3.  Enter values  for the following questions:
	__4.  The Build should finish successfully, and the following console output is shown:
	__5.  To test the project creation, change the directory to testproject
	__6.  Run:
	__7.  Once all the tests pass the console should look like below.
	__8.  Copy settings.xml from  C:\LabFiles\Create a Corporate Repository put it into <User_Home>\.m2 folder. For windows XP, “C:\Documents and Settings\<username>\.m2” In Windows Vista/7 use “C:\Users\<username>\.m2”
	__9.  Using a file browser navigate to C:\Workspace\testproject.
	__10.  Open pom.xml using a file editor.
	__11.  Put <distributionManagement> element before <dependencies> element.
	__12.  Save and close the file.

	Part 3 -  Posting Snapshots to Nexus
	__1.  Make sure you are at C:\workspace\testproject directory in the prompt command window.
	__2.  To deploy the project to the Artifactory repository, enter:
	__3.  The console output shows that the files were uploaded to repositories:

	Part 4 -  Verify Artifactory repository
	__1.  Navigate to the following URL, using Mozilla browser:
	__2.  Click the Artifacts tab.
	__3.  Click on the Simple Browser item on the left navigation. 
	__4.  Click libs-snapshot-local and you should be able to see the test project you just created above.
	__5.  Close the command prompt window used in this lab; do not clowe the artifactiry command prompt window.
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	Lab 10 -  Deploy to the Corporate Repository
	Part 1 -  Create a Test Project with Dependency
	__1.  Open a command prompt window.
	__2.  Change the directory of your prompt to C:\workspace. 
	__3.  Run the following command to generate a new project using a maven archetype.
	__4.  Enter values  for the following questions:
	__5.  The Build should finish successfully, and the following console output is shown:
	__6.  To test the project creation, change the directory to C:\workspace\testReleaseProject
	__7.  Run: 
	__8.  Once all the tests pass the console should show like below.
	__9.  Open C:\workspace\testReleaseProject\pom.xml using a text editor.
	__10.  Add the following dependency code:
	__11.  Put <distributionManagement> element before <dependencies> element.
	__12.  Save and close the file.
	__13.  Verify dependencies by entering the following on the command prompt.

	Part 2 -  Deploying to the Release Repository
	__1.  Open pom.xml at C:\workspace\testReleaseProject directory.
	__2.  Remove  “-SNAPSHOT” next to version.
	__3.  It should be like below:
	__4.  Save and close the file.
	__5.  To deploy the project to the Artifactory release repository, enter:
	__6.  The console output shows that the files were uploaded to release repositories:

	Part 3 -  Verify Artifactory repository
	__1.  Navigate to the URL http://localhost:8081/ using Mozilla browser.
	__2.  Click on the Artifacts item on the on the top navigation bar, and then click on Simple Browser in the left-hand navigation bar.  
	__3.  From the list click libs-release-local.  
	__4.  You should be able to navigate down through to the '1.0' folder to see your artifacts deployed.
	__5.  Close the browser.
	__6.  Close all command prompt windows.
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