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Directory Paths Used in Labs
The following directories will be referred to often in the labs.  To simplify lab 
instructions there are many places where the variables listed below will be used in place 
of the actual directory path.

Some directories which should already exist before you start the labs are listed below 
with values.  Please verify the location of these directories matches what is listed here 
and make a note of the change if it does not.  Also notify your instructor if anything does 
not match.

Some directories will not yet exist as you will be installing software in the labs.  These 
are listed here so you can write down the appropriate directory here when installing the 
software.

Directories that should exist already:

<WAS_SOFTWARE_DIR>:  /root/Software/WAS-ND-85

<LABFILES_DIR>:  /root/LabFiles

<DB2_ROOT>:  /opt/ibm/db2/V9.5

<MQ_ROOT>:  /opt/mqm

<JMETER_ROOT>:  /root/Software/jakarta-jmeter-2.3.4

Directories created during labs:

<IM_ROOT>:                                                                                                           

<WAS_ROOT>:                                                                                                        

<IHS_ROOT>:                                                                                                          

<PLUGIN_ROOT>:                                                                                                
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Lab Notes
This section has notes that will be referred to throughout the labs.  Various labs will have 
you write down information in this section to document important settings or to use in 
later labs.

Lab 1 - WebSphere 8.5 Installation
Profile name <profile>:                                                                                         

Node name <nodename>:                                                                                                            

Host name <hostname>:                                                                                                              

Lab 4 - Solving Problems
System.out File Name (including path):                                                                                    

Lab 7 & Alternate Lab 1 - JMS Messaging
JNDI Name for Connection Factory:                                                                                        

JNDI Name for Queue:                                                                                         

JNDI Name of Activation Specification:                                                                                   

Lab 15 – Create Deployment Manager Profile
Node Name of Deployment Manager Profile:                                                                           

Cell Name of Deployment Manager Profile:                                                                             

Host name of Deployment Manager machine <DM-hostname>:                                         

Admin Console port of Deployment Manager:                                                                        

SOAP port of Deployment Manager (DM_SOAP_PORT):                                                   
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Lab 1 - WebSphere 8.5 Installation
In this lab you will install the WebSphere Application Server 8.5.  WebSphere 
Application Server relies on TCP/IP networking.  It is important to have networking 
correctly configured before starting the installation and the host name must remain fixed. 
Your lab machine should be configured correctly for the lab.  

WebSphere Application Server 8.5 also uses a new installation method (since WebSphere 
8.0) called the "Installation Manager".  This is a separate software package that is 
installed specifically to install and update the software required for WAS.

You will be logging in as the root user to install and configure WebSphere:

User ID: root

password: CentOS

At the end of this lab you will be able to:

1. Install WebSphere Application Server 8.5

2. Explore the major WebSphere directories

3. Start the Application Server

4. Test the WebSphere Installation

5. Stop the Application Server

Part 1 - Install the Installation Manager
The first step in installing WebSphere is to install the 'Installation Manager' software.  In 
this section you will use a custom script to install the 'Installation Manager' software 
silently.  This is a common approach to installing software instead of the graphical wizard 
you could also run.

__1. Make sure that you are logged in as the administrative user listed above.  If you are 
not, log off and log back on as the user root above.

Note:  You can install and run a WebSphere server as a non-root user.  Search the 
InfoCenter with the phrase “non-root” to find many topics about how to accomplish this. 
In the labs, you will remain logged in as the root user to simplify the labs.

Be sure to check the platform specific installation instructions before installing 
WebSphere on your own machines.  The details about disk space and other requirements 
will be detailed there.  This lab should not be used as the only resource in preparing for 
your WebSphere installation.

__2. Open a terminal window.  You can do this by selecting 'Applications -> Accessories 
-> Terminal'.
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__3. Use the 'cd' command to navigate to the <LABFILES_DIR>/InstallWAS directory 
substituting the value of the <LABFILES_DIR> variable with the location mentioned in 
the list of directory paths at the beginning of these labs.  Check with your instructor if 
you can't find the directory listed.

__4. Execute the following command to verify the script is executable.

# chmod +x *

__5. Open a File Browser window.  You can do this by selecting 'Applications -> System 
Tools -> File Browser'.

__6. Browse to /opt/IBM folder.

__7. Using the tools of the File Browser create the following new directory.  Notice there 
is an 'ITM' directory that already exists as part of the DB2 install but you are creating a 
separate directory as shown below.

/opt/IBM/IM

Note: This will make sure you can write to this directory which will be important later. 
If for some reason you can't create this directory inform your instructor as you will need 
to alter the 'IM_LOCATION' variable in the script that is run later.

__8. In the File Browser window navigate to the <LABFILES_DIR>/InstallWAS 
directory substituting the value of the <LABFILES_DIR> variable with the location 
mentioned in the list of directory paths at the beginning of these labs.  

__9. Copy the 'custom_install_im.sh' file from this folder.  Only copy this file.  This file 
is a custom file that will run the Installation Manager install process silently.  The file is 
customized already to help reduce install errors.
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__10. Navigate to the <WAS_SOFTWARE_DIR>/InstallationManager/tools directory 
substituting the value of the <WAS_SOFTWARE_DIR> variable with the location 
mentioned in the list of directory paths at the beginning of these labs.  Check with your 
instructor if you can't find the directory listed.

__11. Paste the copied file into the 
<WAS_SOFTWARE_DIR>/InstallationManager/tools directory.

__12. In a terminal window, use the 'cd' command to navigate to the 
<WAS_SOFTWARE_DIR>/InstallationManager/tools directory.

__13. Use the following command to show the content of the file you copied.

# cat custom_install_im.sh

__14. Notice the main line in this file calls the 'imcl' program.  Although there are various 
ways to install the Installation Manager this method is the easiest to customize the 
installation directory.  We are also installing with 'nonAdmin' access rights which will 
help avoid some potential security issues.  Your needs for installing the Installation 
Manager may be slightly different so refer to the Installation Manager documentation for 
the difference in installation methods.
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Note: One important option is the -installationDirectory option.  By default for the 
"nonadmin" installation it would be in the user home directory so we are setting a more 
visible directory for this setting.

__15. Issue the following command to start the execution of the custom silent install. 
You will not be immediately returned to the command prompt which indicates the silent 
installation is proceeding.  Leave the command prompt open.

# ./custom_install_im.sh

__16. After a few minutes check that you are returned to the command prompt with a 
message about something being installed and without any errors being displayed.

__17. In a File Browser window navigate to the '/opt/IBM/IM' directory and verify you 
see files installed as shown below.

__18. Write down this installation directory as the value of the <IM_ROOT> variable in 
the list of directory paths at the beginning of these labs.
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Part 2 - Record Response File
Although it is common to want to install software with a response file, coming up with 
the syntax of these files can be difficult.  Performing an installation using a GUI tool can 
be easier since it can show you the various options and make it easier to supply values.

With the Installation Manager a hybrid solution can be used that will use the GUI install 
tool to create the response file that can then be used in a command line software 
installation.  The key to doing this with the Installation Manager is to launch the tool in 
"record" mode. 

__1. Open a File Browser window.

__2. Navigate to the <LABFILES_DIR>/InstallWAS directory substituting the value of 
the <LABFILES_DIR> variable with the location mentioned in the list of directory paths 
at the beginning of these labs.  Check with your instructor if you can't find the directory 
listed.

__3. Copy the 'custom_im_record.sh' file from this folder.  Only copy this file.  This file 
is a custom file that will run the Installation Manager to record a response file.  This can 
only be done by supplying command line parameters when starting the Installation 
Manager which is why this file is supplied for you.

__4. Navigate to the <IM_ROOT> directory substituting the value of the <IM_ROOT> 
variable with the location you wrote down in the list of directory paths at the beginning of 
these labs.  

__5. Paste the copied file into the <IM_ROOT> directory.

__6. In a terminal window, use the 'cd' command to navigate to the <IM_ROOT> 
directory.

__7. Use the following command to show the content of the file you copied.

# cat custom_im_record.sh
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__8. Notice the key options of -skipInstall which will prevent the Installation Manager 
from actually installing anything and -record with the file to be created with the recorded 
response file.

Note: The directory used after -skipInstall (DATA_LOCATION above) should be a 
directory used only when recording response files.  The installation manager uses this to 
track what has perhaps already been installed and using the same directory as a previous 
use of the tool when recording a response file might corrupt that configuration.  If using 
one Installation Manager setup to record response files for different WebSphere 
environments you would want to have a different data directory that tracks what has 
been installed into each environment.

__9. Issue the following command to start the Installation Manager. Leave the command 
prompt open.

# ./custom_im_record.sh

__10. From the Installation Manager window that appears select 'File → Preferences'.

__11. Next to what should be an empty list of repositories click the 'Add Repository' 
button.
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__12. Click the Browse button and navigate to the <WAS_SOFTWARE_DIR>/Main 
directory.

__13. Select the 'repository.config' file in this location as shown below and click the OK 
button to select the file. 

__14. Back in the Installation Manager, make sure the proper location for the repository 
configuration file is listed and click the OK button.

__15. Make sure the repository is listed and click the OK button to close the preferences.
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__16. Back in the Installation Manager select 'File → Open → Install Packages'.  

__17. On the Install Packages screen check the box next to 'IBM WebSphere 
Application Server Network Deployment' which should be listed and click the Next 
button.

Note: If you see any issue with prerequisites check with your instructor.

__18. After a few seconds the license screen should be shown.  Accept the license and 
click the Next button.

__19. Change the value of the shared resources directory to '/opt/IBM/IMShared' as 
shown below.  If you had to install the Installation Manager to a different location 
because you didn't have write access to the hard drive let your instructor know so a 
different directory could be chosen.

Note: You could install into the default which is in the user home directory which could 
avoid issues with file permissions.  We are using a different directory here to install 
everything under '/opt/IBM'.

__20. Click the Next button once your shared resources directory is modified.
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__21. Change the value of the WebSphere installation directory to 
'/opt/IBM/WebSphere/AppServer' as shown below.

__22. Write down the installation directory for the <WAS_ROOT> variable in the list of 
directory paths at the beginning of these labs.  This directory will be used later in the labs.

__23. Click the Next button once your WebSphere installation directory is modified.

__24. Leave the default options for installed languages and click the Next button.

__25. Leave the default features selected and click the Next button.

Note: On 64-bit systems you would see a choice for the JDK version to install.  On 
systems that support it, you might normally select the 64-bit JDK, especially in 
production.
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__26. Verify that the options are configured as below and click the 'Install' button.

Note: This does not actually install anything but creates a response file with the 
appropriate settings you configured going through the process.

__27. After just a few seconds you should see a message that the "installation" was 
successful.  Click the Finish button.
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__28. In the Installation Manager select 'File → Exit'.

__29. Check in your <LABFILES_DIR> folder that you see the XML response file that 
was recorded.

Part 3 - Install WebSphere with Response File
Now that you have recorded a response file, it can be used to install the WebSphere 
software.  If you were installing WebSphere on several machines you might only need to 
record the response file once and on each machine you could install the Installation 
Manager and the WebSphere software.

__1. Open a File Browser window.

__2. Navigate to the <LABFILES_DIR>/InstallWAS directory substituting the value of 
the <LABFILES_DIR> variable with the location mentioned in the list of directory paths 
at the beginning of these labs.  Check with your instructor if you can't find the directory 
listed.

__3. Copy the 'custom_install_WAS.sh' file from this folder.  Only copy this file.  This 
file is a custom file that will run the Installation Manager to use the recorded response file 
generated in the last section.

__4. Navigate to the <IM_ROOT> directory substituting the value of the <IM_ROOT> 
variable with the location you wrote down in the list of directory paths at the beginning of 
these labs.  
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__5. Paste the copied file into the <IM_ROOT> directory.

__6. In a terminal window, use the 'cd' command to navigate to the <IM_ROOT> 
directory.

__7. Use the following command to show the content of the file you copied.

# cat custom_install_WAS.sh

__8. Notice the key option of 'input' which will point to the custom response file you 
recorded.

Note: It is also important that you are using the 'imcl' from within the '/eclipse/tools' 
subdirectory of the Installation Manager install.  Even though this was the same thing 
you used to install the Installation Manager, you should use the version from within the 
Installation Manager once it is installed.
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__9. Issue the following command to start the installation of WAS.  You will not be 
immediately returned to the command prompt which indicates the silent installation is 
proceeding.  Leave the command prompt open.  You might want to take a quick break at 
this point.

# ./custom_install_WAS.sh

__10. After several minutes check that you are returned to the command prompt with a 
message about WebSphere being installed and without any errors being displayed.

__11. In a File Browser window navigate to the '/opt/IBM/' directory and verify you see 
files installed as shown below.  You should see the 'IMShared' and 'WebSphere' folders 
that were not there before.
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Part 4 - Create a WebSphere Profile
One of the last steps to having a working WebSphere installation is to create a "profile". 
This is the configuration of the software which can include actual servers.  Since we will 
start out with a single server environment we will start by creating an "Application 
Server" profile.  This can be done graphically or with a response file as shown in this 
section. 

__1. Open a File Browser window.

__2. Navigate to the <LABFILES_DIR>/InstallWAS directory substituting the value of 
the <LABFILES_DIR> variable with the location mentioned in the list of directory paths 
at the beginning of these labs.  Check with your instructor if you can't find the directory 
listed.

__3. Copy the 'custom_create_profile.sh' file from this folder.  Only copy this file.  This 
file is a custom file that will run the profile management tool with a few options.  This 
file is simply being provided to help prevent typos when running the profile management 
tool.

__4. Navigate to the <WAS_ROOT>/bin directory substituting the value of the 
<WAS_ROOT> variable with the location you wrote down in the list of directory paths at 
the beginning of these labs.  

__5. Paste the copied file into the <WAS_ROOT>/bin directory.

__6. In a terminal window, use the 'cd' command to navigate to the <WAS_ROOT>/bin 
directory.

__7. Use the following command to show the content of the file you copied.

# cat custom_create_profile.sh
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__8. Notice the key options of -create and -templatePath which are the minimum options 
needed when using the "default" profile as this command does.  Some additional options 
are provided to configure administrative security also.

Note: Although there are a lot of options you can provide when creating a profile, the 
"default" profile can provide defaults for all of them.  It is a very useful template for a 
quick profile configuration.  The only reason you were provided a script file to run 
instead of typing the command directly is to enable administrative security which would 
require quite a bit of typing.  By default administrative security is disabled so you will 
enable it with this command.

__9. Issue the following command to start the profile creation.  Leave the command 
prompt open.  You might want to take a quick break at this point.

# ./custom_create_profile.sh

__10. After several minutes the command should complete and return to the command 
prompt without errors.  Make sure you get a message about 'INSTCONFSUCCESS' as 
shown below.
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__11. Open a File Browser window and navigate to the 
<WAS_ROOT>/profiles/AppSrv01/logs directory.

__12. Open the 'AboutThisProfile.txt' file in a text editor.  Select 'Display' if you are 
given choices when double-clicking the file.

__13. In the file that is opened, note the Profile name, Node name, and Host name. 
Write these values down in the Lab Notes section at the beginning of the lab guide.

__14. Close the text file showing the profile information.
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Part 5 - Verify Application Server
Now that the profile exists it will be good to verify the server can start and can be 
accessed.

__1. Start the Application Server.  Do this by following the set of steps below:

● Open a terminal window.  You can do this by selecting 'Applications -> 
Accessories -> Terminal'.

● Use the 'cd' command to change to the <WAS_ROOT>/profiles/AppSrv01/bin 
directory.  

● Issue the command './startServer.sh server1'.

Note: Get familiar with opening a terminal window in this directory and running this 
command as this will be the default way used to start the server.

__2. Verify that you get a message that the server is "open for e-business".  Leave the 
terminal window open.
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__3. Once the server is started, open a web browser and type the URL 
'http://localhost:9080/snoop' into the address bar.  You should see the output below.

__4. Close the web browser used to test the Application Server.

__5. Stop the Application Server.  Do this by following the set of steps below:

● Open a terminal window.  You can do this by selecting 'Applications -> 
Accessories -> Terminal'.

● Use the 'cd' command to change to the <WAS_ROOT>/profiles/AppSrv01/bin 
directory.  

● Issue the command './stopServer.sh server1'.

● When prompted for security enter a user and password of wasadmin.

Note: In the future, when you are asked to start and stop the server you will use the steps 
outlined in this section.

You can also issue the following command to stop the server to avoid getting prompted 
for security information each time:

./stopServer.sh server1 -username wasadmin -password wasadmin

The issue with supplying the user and password in the command is that these would be 
visible to the 'ps' process listing command.  This can be viewed as a security risk.
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__6. Wait until you see the following result.

Part 6 - Explore Application Server Directory Structure
This section will point out some of the major directories in the WebSphere installation.

__1. Open a File Browser window.

__2. Navigate to the <WAS_ROOT> directory you wrote down in the notes at the 
beginning of these labs.  This should be the main installation directory for WebSphere.

__3. Look at some of the major directories and their contents:

● bin – executable programs, scripts, and DLLs

● installableApps – complete applications which can be installed

● java – JDK 1.6 files (supports Java SE v6)

● lib – library of various Java .jar files used by WebSphere

● web – documentation resources

● profiles/AppSrv01/config – configuration files for the installation

● profiles/AppSrv01/etc – default SSL files

● profiles/AppSrv01/installedApps – applications installed on the server

● profiles/AppSrv01/logs – default directory for various trace and log files

● profiles/AppSrv01/properties – configuration property files used by WebSphere

__4. Look at some of the log files created during the installation and verification:

● <WAS_ROOT>/logs/postinstall/postinstall.log - logs installation events

● <WAS_ROOT>/logs/manageprofiles/AppSrv01_create.log - log messages 
related to the creation of the AppSrv01 profile

● <WAS_ROOT>/profiles/AppSrv01/logs/server1/SystemOut.log - main log file 
for Application Server
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__5. Close all File Browser windows.

__6. Close all terminal command prompts.

__7. Close all web browsers.

Part 7 - Review
In this lab you installed the WebSphere Application Server.  You also ran some basics 
tests of the server and familiarized yourself with some basic commands.  You are now 
able to start and stop the server and can identify some of the major directories in the 
WebSphere installation.

One of the key things to take away from this lab is the role of the 'Installation Manager' 
software.  Even though we just saw this a little it will be a primary tool used to manage 
WebSphere software installations.

Even though you installed the Network Deployment software, the profile that you created 
is exactly what you would have after installing the “Base” edition of WebSphere.  The 
only difference is that when you install the “Base” edition you only get one option for the 
type of environment to create. 
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Lab 2 - Install an Application
In this lab you will install a simple application to the Application Server.  This application 
has only one simple function, printing a message out to the screen.  It does not use any 
external resources.  This is so you can concentrate on installing an application without 
needing to configure any other resources first.

At the end of this lab you will be able to:

1. Use the Admin Console for administering applications on the server.

2. Install an application to the Application Server.

3. Test applications that have been deployed to the server by submitting web 
requests.

Part 1 - Control Applications From the Admin Console
In this section you will use the Admin Console to control applications deployed to the 
server.  You will also see an example of the response returned if a deployed application is 
stopped.

__1. Start the Application Server.  Do this by following the set of steps below:

● Open a terminal window.  You can do this by selecting 'Applications -> 
Accessories -> Terminal'.

● Use the 'cd' command to change to the <WAS_ROOT>/profiles/AppSrv01/bin 
directory.  

● Issue the command './startServer.sh server1'.

__2. Start the Admin Console by opening a Web browser and entering the URL 
http://localhost:9060/ibm/console/
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__3. Since security is enabled you will get a warning about the server certificate.  Accept 
the certificate or continue to the website depending on the browser you are using.

Note:  You will get this warning every time you access the Admin Console.  You could 
also “Install” the certificate in your web browser to indicate you trust the site to prevent 
the warning.

With Firefox you "Add an exception".

__4. Enter a user ID and password of ‘wasadmin’ and click “Log in” on the Login screen 
of the Console.
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__5. Expand the Applications group in the Navigation tree, expand Application Types 
and click on the link for WebSphere enterprise applications.

__6. Check the checkbox next to the DefaultApplication and press the Stop button.  You 
should get a message that the application was stopped and a red ‘X’ in the status column.

__7. Open a separate Web browser and try to access the Snoop Servlet as in the last lab. 
The URL is http://localhost:9080/snoop.  You should get an error.  This is because it is 
part of the DefaultApplication which is stopped. 

__8. In the Admin Console, check the checkbox next to the DefaultApplication and 
press the Start button.  You should get a message that the application was started and a 
green arrow in the status column.

__9. In the Web browser you used to access the Snoop Servlet, hit the refresh button. 
You should see the normal output of the Snoop Servlet.  

__10. Close the extra Web browser you were using to test the Snoop application.
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Part 2 - Install an Application to the Server
In this section you will install an application to the server.  After installing and starting 
the application the Application Server will be able to handle requests that were not part of 
the testing and verification applications that already come installed on the server.  This 
section will familiarize you with the basic process of installing an application.

__1. Return to the web browser you were using for the Admin Console.  If you had 
closed it you can open it at http://localhost:9060/ibm/console/ and login is wasadmin.

__2. In the Applications group in the navigation, click the link for New Application.

__3. Click the link for New Enterprise Application.

__4. Next to the Local file system box, press the Browse button.

__5. Find the file <LABFILES_DIR>/InstallApp/HitCount.ear and select Open in the 
file chooser dialog.  Remember to substitute the value of the <LABFILES_DIR> variable 
from the notes at the beginning of the labs.

__6. Press the Next button.

__7. Check the option for Detailed installation.  This will show all steps.

__8. Once you have the options specified as below, press the Next button.
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Note:  The next sequence of steps will vary depending on the application you are 
installing.  Since this application is fairly simple there are only a few steps and a 
summary.  There would be fewer steps if we had not checked the option for showing all 
options.

__9. On step 1, check the Precompile JavaServer Pages files option and click Next.

__10. Accept the default values on steps 2-14 by pressing the Next button on each step. 
Some of these steps will only appear once you go through other steps.  You should end up 
at step 15 which is the summary.  Some of the intermediate steps are explained below:

Step 2: Map modules to servers - This step would be more important in a multi-server 
environment.  This step will also be more important with web servers later.

Step 3: Provide options to compile JSPs - This step appears because of the option you 
selected to precompile JSPs.  Most of the time the code needed to compile JSPs is in the 
application itself but if it is not you may need to supply additional options here.

Step 4: Provide JSP reloading options for Web modules - This service can 
automatically check if a new version of a JSP file has been deployed to the application 
without restarting the entire application.  Most of the time you would leave this service 
on but you could increase the time interval in production.

Steps 5 & 6: Shared libraries - Shared libraries are shared code that is required by an 
application but is not packaged with the application itself.  If you have previously 
configured a shared library you can map it to an application module with these steps.

Step 7: Provide JNDI names for beans & Step 8: Bind EJB Business – These steps 
are presented if the application includes EJBs.  The JNDI name can be used by EJB 
clients to locate the EJB.  Some EJB clients can also obtain a reference to the EJB using 
Java EE “injection” where the JNDI name may not be required.  If your developers are 
using Rational software this value may be filled in already.  It would be important to 
coordinate the values of these properties with developers.
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Step 9: Map EJB references to beans – An EJB reference is another way for an EJB 
client to be linked to a target EJB.  Again, this value may not be required if an application 
uses Java EE “injection”.

Step 10: Map virtual hosts for Web modules - Virtual hosts affect the URL that is used 
to access the application.  This will be discussed more later.

Step 11: Map context roots for Web modules - The context root also makes up part of 
the application URL.  You could change it here if you wish.  This will be discussed more 
later.

Step 12: Map JASPI Provider – Java EE 6 defined a way to integrate an external web 
application security authentication mechanism.  If you were using this feature here is 
where you could provide those options for this application.

Step 13: Metadata for modules – Deployment information for applications can be 
provided by XML deployment descriptors or through annotations in the code itself.  If 
you check the 'metadata-complete attribute' in this step for a module of the application, 
any deployment information provided in code annotations is ignored.  Developers may be 
counting on some of these annotations being applied to configure an application so this is 
another aspect to coordinate with developers.

Step 14: Display module build Ids – If installing modules with a build ID in the 
MANIFEST.MF file of the module that value will be displayed here.  It can't be changed 
though and is only displayed.  This is often used if using some of the automated build 
tools available from IBM as part of the Rational family.

__11. On step 15, the Summary, click the Finish button.  Wait for it to complete the 
installation and be sure you get a message that says Application HitCount installed 
successfully.

__12. Click the link to Review changes to the master configuration below the message 
about the successful installation.
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__13. On the Save screen, click the '+' sign to expand the list of changes that will be 
made.

Note:  The number of changed documents you see may be slightly different.

__14. Click the Save button at the bottom of the page to save the master configuration.

__15. In the Applications group in the navigation, expand the Application Types section 
and click the link for WebSphere enterprise applications.

__16. Start the HitCount application by checking the checkbox next to it and clicking the 
Start button.

Note: Sometimes you may see that the red 'X' doesn't turn to a green arrow after starting 
an application until you hover your mouse over it.
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Part 3 - Test the HitCount Application
Now that the application is installed and started you can test it.  You will find out how to 
submit a web request for an installed application by using properties available from the 
Admin Console.

__1. Make sure that you are viewing the list of Enterprise Applications in the Admin 
Console.  If not, you can expand the 'Applications → Application Types' group in the 
navigation and click the link for 'WebSphere enterprise applications'.

__2. From the list of applications, click the link for the HitCount application by clicking 
on the application name.  This will show you a page of options and configuration related 
to that particular application.

__3. From the list of Detail Properties associated with the HitCount application click the 
link for View Deployment Descriptor.

Copyright 2013 Web Age Solutions Inc. 32

EVALUATIO
N O

NLY



__4. In the text of the Deployment Descriptor find the value of the context-root.  This is 
what you can add to the host name and port of the server to access the application.

__5. Open a new web browser and enter the URL http://localhost:9080/HitCountWeb. 
Notice this URL ends in the “context-root” of the web application.  You should see the 
following page.

__6. Click the link of the home page of the application.  You should get an initial count of 
'1'.

__7. Refresh the page several times to see the count increase.

__8. Leave the web browser open that you are using to test the application.
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__9. Return to your Admin Console web browser.  If you closed it, open a new window to 
the URL http://localhost:9060/ibm/console/.  Make sure you leave the web browser 
running the HitCount application open.

__10. Expand the 'Applications → Application Types' group in the navigation and click 
the link for 'WebSphere enterprise applications'.

__11. Check the checkbox next to the HitCount application and press the Stop button.

__12. Once the application is stopped, check the checkbox next to the HitCount 
application again and press the Start button.

__13. Return to the web browser you were using to test the application and refresh the 
page.  The count should return to 1 even though you are using the same web browser. 
The “state” of the stateful session EJB has been lost by restarting the application.

__14. Close the web browser you used to test the new application.

Part 4 - Deploy Applications with a Monitored Directory
WebSphere Application Server 8.0 added a new way to deploy applications.  The server 
can be configured to monitor a directory and deploy applications copied into that 
directory.  This feature is disabled by default and must be enabled.

__1. Return to your Admin Console web browser.  If you closed it, open a new window to 
the URL http://localhost:9060/ibm/console/.  Make sure you leave the web browser 
running the HitCount application open.

__2. Expand the 'Applications → Application Types' group in the navigation and click 
the link for 'WebSphere enterprise applications'.

__3. Check the checkbox next to the HitCount application and press the Stop button.

__4. Once the application is stopped, check the checkbox next to the HitCount 
application again and press the Uninstall button.

__5. Click the OK button to confirm you want to uninstall the application.

__6. In the messages that display at the top of the browser click the Save link.
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__7. In the Applications group in the navigation, click the link for Global deployment 
settings.

__8. Check the box for the 'Monitor directory to automatically deploy applications' 
and press the the Apply button.  You can leave the default settings.

__9. In the messages that display at the top of the browser click the Save link.

__10. In the web browser showing the Admin Console click the Logout link near the top 
of the Console.  If you have unsaved changes save them before logging out.

__11. Stop the Application Server.  Do this by following the set of steps below:

● Open a terminal window.  You can do this by selecting 'Applications -> 
Accessories -> Terminal'.

● Use the 'cd' command to change to the <WAS_ROOT>/profiles/AppSrv01/bin 
directory.  

● Issue the command './stopServer.sh server1'.

● When prompted for security enter a user and password of wasadmin.

__12. Once the server has stopped issue the command './startserver.sh server1' to restart 
it.  The server must be restarted after enabling monitored directory deployment.
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__13. Open a File Browser window.

__14. Navigate to the <LABFILES_DIR>/InstallApp directory substituting the value of 
the <LABFILES_DIR> variable with the location mentioned in the list of directory paths 
at the beginning of these labs.

__15. Copy the HitCount.ear file from the directory.

__16. Navigate to the following directory:

<WAS_ROOT>/profiles/AppSrv01/monitoredDeployableApps/servers/server1

__17. Paste the HitCount.ear file in this directory.

__18. Return to your Admin Console web browser.  If you closed it, open a new window 
to the URL http://localhost:9060/ibm/console/.  

__19. Login to the Admin Console with a user and password of 'wasadmin'.

__20. Expand the 'Applications → Application Types' group in the navigation and click 
the link for 'WebSphere enterprise applications'.

__21. Check that you see the HitCount application installed and running.

__22. Open a new web browser and enter the URL http://localhost:9080/HitCountWeb.

__23. Test the application as you did before and make sure it works.
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__24. Close the web browser you used to test the new application.

__25. In the web browser showing the Admin Console click the Logout link near the top 
of the Console.

__26. Close the web browser you were using for the Admin Console.

__27. Stop the application server.  Do this with the './stopserver.sh server1' command in 
a terminal command prompt in the <WAS_ROOT>/profiles/AppSrv01/bin directory. 
Remember that you can use the command with credentials as  './stopserver.sh server1 
-user wasadmin -password wasadmin'.

__28. Close all open windows.

Part 5 - Review
In this lab you installed a simple application and saw the main steps of installing an 
application.  Even though most applications will be much more complex and require 
more steps during the installation the same basic process will be followed.

You also used the "monitored directory" deployment technique to deploy an application 
to the server.  This is often used most in development or test servers and is most useful if 
the application doesn't need additional configuration during installation.  If additional 
configuration is needed it might be more desirable to develop a script to deploy the 
application instead.

You also saw how to access properties for installed applications to find out how to submit 
web requests for testing.  There are many other properties associated with applications 
and you only saw a few but others are accessed in the same way, by clicking the name of 
the application in the list of applications.  In fact all configuration properties and options 
available in the Admin Console are accessed in a similar fashion.  When you click a link 
on one page it displays another page with properties for that item.
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Lab 3 - IBM HTTP Server and Web Server Plug-in
You have already seen how the WebSphere Application Server can handle HTTP requests 
without a Web Server.  For enhanced network security and performance it is often 
desirable to use a Web Server.  In this lab you will see how the Web Server and the 
WebSphere Application Server work together in this environment.

You will be installing the IBM HTTP Server and Web Server Plug-in using the “local” 
configuration which is shown below.  In this configuration the web server, plug-in, and 
WebSphere server are all on the same machine.  Much of the plug-in configuration within 
the WebSphere configuration will be done for you using a batch command generated 
during the web server installation.

At the end of this lab you will be able to:

1. Install the IBM HTTP Server and Web Server Plug-in.

2. Add a new host name to the IBM HTTP Server.

3. Route requests for this new host name back to your own machine.

4. Configure applications in the WebSphere Application Server to use this host 
name.

Part 1 - Install IBM HTTP Server
The first step will be to install the IBM HTTP Server.  This has a separate installation 
than the WebSphere installation.  Although you will be installing the IBM HTTP Server 
on the same machine as WebSphere, often this would be done on a different machine.

__1. Make sure you are logged in as the 'root' user ID.
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__2. Open a terminal window.  You can do this by selecting 'Applications -> Accessories 
-> Terminal'.

__3. In a terminal window, use the 'cd' command to navigate to the <IM_ROOT> 
directory.

__4. Issue the following command to start the Installation Manager. Leave the command 
prompt open.

# ./eclipse/IBMIM &

Note: We are benefiting from the fact that the Installation Manager was already installed 
when WebSphere Application Server was installed.  If you were installing the web 
server and plugin on a different machine you would also have to install Installation 
Manager as well.

You could also record a response file and then install from this as you did with 
WebSphere Application Server.  We will simply install directly from the Installation 
Manager GUI.

__5. From the Installation Manager window that appears select 'File → Preferences'.

__6. Next to the list of repositories click the 'Add Repository' button.

__7. Click the Browse button and navigate to the 
<WAS_SOFTWARE_DIR>/Supplement directory.  Remember the 
<WAS_SOFTWARE_DIR> directory is where the WebSphere software can be installed 
FROM and not where WebSphere is currently installed.
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__8. Select the 'repository.config' file in this location as shown below and click the OK 
button to select the file. 

__9. Back in the Installation Manager, make sure the proper location for the repository 
configuration file is listed and click the OK button.
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__10. Make sure the repository is listed and click the OK button to close the preferences.

__11. Back in the Installation Manager select 'File → Open → Install Packages'.  

__12. On the Install Packages screen check the box next to the following options:

• IBM HTTP Server for WebSphere Application Server

• Web Server Plug-ins for IBM WebSphere Application Server

• WebSphere Customization Toolbox
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__13. Once the above options are selected click the Next button.

__14. After a few seconds the license screen should be shown.  Accept the license and 
click the Next button.

__15. From the list shown select each package that will be installed and Change the 
installation directory so they will be installed to a subdirectory of the '/opt/IBM' 
directory. The installation directories should be:

IBM HTTP Server /opt/IBM/HTTPServer

Web Server Plug-ins /opt/IBM/WebSphere/Plugins

Customization Toolbox /opt/IBM/WebSphere/Toolbox

__16. Write down the installation directory for the HTTP Server as the <IHS_ROOT> 
variable in the list of directory paths at the beginning of these labs.  Also write down the 
Web Server Plug-ins installation directory as the <PLUGIN_ROOT> variable.  These 
directories will be used later in the labs.

__17. Once your installation directories are configured as shown above click the Next 
button.
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__18. Leave the default features to install and click the Next button.

__19. Check that your Web Server Configuration options show using port 80.

__20. Once you have confirmed you see the proper web server configuration options, 
leave the default settings and click the Next button.

__21. Verify that the options are configured as below and click the 'Install' button. 
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__22. After several minutes installing software you should see a success message.  Leave 
the option to launch the 'WebSphere Customization Toolbox' selected and click the 
Finish button.

__23. Leave the 'WebSphere Customization Toolbox' open for the next section.

__24. Close the Installation Manager by selecting File → Exit from the appropriate 
window.

Part 2 - Configure Web Server Plug-in
After the web server and plug-in software is installed it needs to be configured to link the 
web server to the WebSphere Application Server configuration.  This is done differently 
in WebSphere 8.5 with the 'Web Server Plug-ins Configuration Tool'.

__1. In the 'WebSphere Customization Toolbox' tool that appeared from the last section, 
select the 'Web Server Plug-ins Configuration Tool' and click the Launch Selected 
Tool button.
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Note: If you do not have the WebSphere Customization Toolbox open you can run:

/opt/IBM/WebSphere/Toolbox/WCT/wct.sh

__2. In the tool that appears, next to the empty list of 'Web Server Plug-in Runtime 
Locations' click the Add button.

__3. Fill in a 'Name' value of 'Main Plugin' and use the Browse button to select the 
<PLUGIN_ROOT> directory written down in the directory paths from early in this lab.

__4. Once you settings appear as shown above click the Finish button.
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__5. With the new entry for the plug-in location selected above, click the Create button 
next to the empty lower list of 'Web Server Plug-in Configurations'.

__6. Leave the default option of IBM HTTP Server 8.5 selected and click the Next 
button.
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__7. In the options for the web server configuration file use the Browse button to select 
the <IHS_ROOT>/conf/httpd.conf file if it is not already selected and click OK.

__8. Back in the wizard, make sure that you have the correct configuration file listed and 
there is no error in the top margin.  Also leave the default port of 80 and click the Next 
button.
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__9. In the options for the 'Setup IBM HTTP Server Administration Server' fill in a 
userid, password and password confirmation of 'ihsadmin'.  You may need to manually 
expand the window size to see all fields.  Leave the other default options and click the 
Next button.

Note: This user and password is different than the WebSphere user so that it will be 
clear of the difference between them in various situations.  This step runs the 'htpasswd' 
command from the IBM HTTP Server to configure a user and password that can be used 
to remotely administer the web server.

This is also not a user for the operating system but for authentication with the 
administration service.
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__10. On the next page, fill in a 'User ID' and 'Group' of 'ihsadmin'.  Leave the option 
checked to create a new unique system user ID and click the Next button.

Note: This step runs the 'setupadm' command from the IBM HTTP Server to configure 
what id will be used to run the HTTP Administration service.  This will also change 
permissions of various web server configuration directories.  This user does have to be a 
user on the operating system.  If you do not already have a user you would like to use 
you can leave the option checked, as we are doing and one will be created.

The user from the previous step and this step do not need to be the same ID.  This is 
done in the labs to keep things simple.

You can also run the htpasswd command from the previous step and the setupadm 
command from this step manually.  Doing this as part of the plug-in configuration can 
be easier as the configuration wizard already knows what directories and files would 
need to be modified.  If you do not run these commands as part of the installation the 
remote administration ability will be disabled until you run the commands manually.

__11. Leave the default value of the web server name and click the Next button.  

Note: This is the name that you will see later in the WebSphere Admin Console.
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__12. Leave the default option of a "remote" scenario and fill in the value for the 
<hostname> variable you wrote down in the lab notes section for the WebSphere 
installation.  You can also open a command prompt and run the 'hostname' command to 
get the value.  Click the Next button when you have configured the settings on this page.

Note: Even though the web server and WebSphere server are on the same machine we 
are choosing the "remote" scenario here because this will more accurately represent a 
configuration where they are on different machines.  This way, the steps you use when 
they are on different machines will be similar to those done here.
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__13. Make sure that your settings match those shown below and click the Configure 
button.

__14. Make sure that you get a success message, uncheck the 'Launch the plug-in 
configuration roadmap', and then click the Finish button.  The roadmap could normally 
be used to verify the next steps in the configuration of the web server and plug-in.

Note: Also notice there is a script that was created to configure the web server.  This will 
be used to configure WebSphere.
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__15. Check that your new plug-in configuration is listed and select 'File → Exit' to exit 
the Customization Toolbox.

__16. Open a terminal window.  

__17. Use the 'cd' command to change to the <WAS_ROOT>/profiles/AppSrv01/bin 
directory.  

__18. Issue the command './startServer.sh server1'.

__19. Open another terminal window.  

__20. Change directories using the 'cd' command to the <IHS_ROOT>/bin directory. 
Be sure to substitute the value of <IHS_ROOT> from the “Directory Paths” page at the 
beginning of the lab instructions.

__21. Execute the following command to start the web server.  

# ./apachectl start

__22. Execute the following command to start the HTTP administration service.

# ./adminctl start
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Note: Although it is possible to register the IBM HTTP Server and HTTP administration 
service to start automatically if the system reboots, we have not done this.  If you restart 
your machine you will need to execute these commands to be sure the web server and 
the HTTP administration service are running.  Generally they should remain running 
unless you are told to stop or restart it.

__23. Open a File Browser window or use one you already have open.

__24. Navigate to the directory <PLUGIN_ROOT>/bin where the <PLUGIN_ROOT> 
is the variable you wrote down from the IBM HTTP Server and Plugin installation in the 
previous section.

__25. Find the file 'configurewebserver1.sh' in the directory.  Check that you find the 
correct file as there are several that start with 'configure...'.  

__26. Copy the 'configurewebserver1.sh' file by right clicking and selecting Copy from 
the popup menu.

__27. Open another File Browser and navigate to the directory <WAS_ROOT>/bin 
where the <WAS_ROOT> is the variable you wrote down from the WebSphere 
installation lab.

__28. Paste the 'configurewebserver1.sh' file into this directory by selecting Edit -> 
Paste from the menus.
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__29. Be sure you see the 'configurewebserver1.sh' file in the list of files.

Note:  Also note that there is a 'configureWebserverDefinition.jacl' file in the same 
directory.  This file will be called by the script you just copied in with parameters 
configured during the web server installation.

__30. Make sure you have logged out of any previously open Admin Console browser 
windows.

Note:  It is important to logout because you will run a script in the next few steps as the 
same user you used in the Admin Console.  The script seems to have conflicts in this 
situation.

__31. Open a terminal window.  

__32. Change directories using the 'cd' command to the <WAS_ROOT>/bin directory. 
Be sure to substitute the value of <WAS_ROOT> from the “Directory Paths” page at the 
beginning of the lab instructions.
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__33. Enter the following command to check that the WebSphere server is started:

# ./serverStatus.sh -all -username wasadmin -password wasadmin

You should see on server1 started.

__34. Enter the following command to configure the web server definition in the 
WebSphere configuration.  The command should all be entered on the same line even 
though it wraps to a second line below.

# ./configurewebserver1.sh -profileName AppSrv01 -user wasadmin 
-password wasadmin -ihsAdminPassword ihsadmin

Note: It may take several seconds to show the results.

__35. Scroll back through the messages that were output and be sure you do not see any 
errors.

__36. Close any extra command prompts or File Browser windows.
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Part 3 - Configure Virtual Host on Web Server
The next step will be to configure the IBM HTTP Server to respond to a unique host 
name that is not the same as the host name of the machine itself.  This “virtual hosting” 
will separate the physical hostnames of your network from the logical hostnames you 
expose to the clients of the applications.  You will use a host name of ‘was.myhost.com’.

In the labs there is not any static content hosted on the web server.  This section is 
provided to show how to use the WebSphere Admin Console to configure the web server. 
The settings in this section configure the web server so it responds to the 
'was.myhost.com' hostname we will use.

__1. Open a web browser and enter http://localhost:9060/ibm/console in the address 
bar, the URL of the Admin Console.  Remember to continue if you get any certificate 
errors.

__2. Login as the 'wasadmin' user.

__3. Navigate to the Servers → Server Types → Web Servers section of the admin 
console.  Notice there is now a configuration for 'webserver1' which the script you ran 
added.

__4. Click the link for webserver1 from the list.

__5. Under the Additional Properties click the link for Configuration File.  If you get 
an error displaying the configuration file let your instructor know as this likely means 
there is a problem with your IHS administration password.

__6. Scroll to the very end of the file and add a few blank lines.  It may be a little difficult 
to scroll as you will have a scrollbar for the whole page in the browser as well as for the 
configuration file itself.
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__7. Add the following text exactly as it appears below at the end of the configuration 
file.  

<VirtualHost was.myhost.com>
    ServerName was.myhost.com
    ErrorLog logs/was.myhost.com-error_log
    CustomLog logs/was.myhost.com-access_log common
</VirtualHost>

__8. Check that your configuration appears as below and press the OK button.

__9. Go back to the list of web servers by navigating to the Servers → Server Types → 
Web Servers section of the admin console.

__10. Check the box next to the webserver1 entry and click the Stop button.  Make sure 
you get a message about the server stopping.

__11. Check the box next to webserver1 and click the Start button.  If you have trouble 
starting the web server check your configuration file syntax.

__12. Logout of the Admin Console.
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Part 4 - Update Network Setup
You will now change the networking setup of your Linux virtual machine to send 
requests for this new host name back to your own machine.  You will use the ‘hosts’ file 
on the machine to perform this mapping.  Normally you would have other network 
components perform this mapping but the ‘hosts’ file will simplify the process for the lab. 
If this step is not done then requests sent to the host name 'was.myhost.com' would not be 
redirected back to you local machine.

__1. Open a File Browser window or use one you already have open.

__2. Navigate to the '/etc' directory.

__3. Find the 'hosts' file in this directory.

__4. Copy the 'hosts' file and rename the copy to something like 'hosts-backup'.  This 
will ensure you can restore the original if needed.

__5. Double-click on the ‘hosts’ file and open it with a text editor like gedit.

__6. If you do not already have a line that starts with the IP address 127.0.0.1 add it. 

__7. Add to this line 'was.myhost.com' with spaces between the IP address and each of 
the hostnames.  Make sure to add any entries AFTER the real hostname as shown below. 
The file should be similar to this: 

__8. Save the file and close the text editor.

__9. Open a terminal window.  
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__10. Be sure you can ping the new host name.  Enter the command below.  Be sure you 
don’t get an “unknown host” or “request timed out” error message.  

# ping -c 4 was.myhost.com

__11. Close the terminal window.

__12. Open a web browser window.

__13. Enter the URL http://was.myhost.com in the address bar of the browser and hit 
Return. You should see the homepage of the IBM HTTP Server running on your machine. 
If you do not see this screen contact your instructor.

__14. Close out any extra terminal windows, web browsers, or File Browser windows 
you may have open.
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Part 5 - Test Plug-in
Now that you have tested the web server you should test that requests sent to the web 
server can be forwarded to WebSphere through the Plug-in.

__1. Open a web browser and enter the URL http://localhost:9080/HitCountWeb/ in the 
address bar and hit the Return key.  You should see the normal output of the HitCount 
application.

__2. Test the function of the application to be sure it is working properly.

__3. Enter the URL http://localhost/HitCountWeb into the address bar of the web 
browser and hit Return.  You should see the same application.  If you get any errors check 
that your web server is running.

Note:  The difference is that the URL above does not list the 9080 port.  Because there is 
no port listed it sends the request to the default HTTP port which is port 80.  This is the 
port the web server is listening on.  The fact that you got the normal response proves that 
the web server can forward requests for the HitCount application to WebSphere through 
the Plug-in.

__4. Test the application again to be sure the same behavior is shown even though the 
requests are now being forwarded through the Plug-in.

__5. Enter the URL http://was.myhost.com/HitCountWeb/ into the address bar of the 
web browser and hit Return.  Again you should see the same HitCount application.  This 
is because you have configured the web server to respond to the host name 
was.myhost.com.  It can also forward requests for this host name to WebSphere.

Note: The hit count will be reset because it was associated with your web session that 
was linked to the 'localhost' hostname.  When you use a new hostname of 
was.myhost.com the browser starts a new web session.

__6. Close the web browser you have been using to test.
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Part 6 - Examine Plug-in Configuration
The configuration of the Plug-in is often a mystery.  It is confusing to most people how 
the Plug-in makes decisions about what requests to forward.  In this section you will see 
how you can examine the Plug-in configuration in the WebSphere Admin Console.

__1. Start the Admin Console by opening a Web browser and entering the URL 
http://localhost:9060/ibm/console/

__2. Enter a user ID and password of ‘wasadmin’ and click “Log in” on the Login screen 
of the Console.

__3. In the navigation panel on the left expand the Servers → Server Types group and 
click the link for Web Servers.

__4. Click the link for the webserver1 web server.

__5. Under the Additional Properties for the web server click the link for Plug-in 
properties.

__6. Press the View button next to the Plug-in configuration file name.

__7. Search through the configuration for the VirtualHostGroup element.  This has the 
definition of several VirtualHosts.  These are the host name and port combinations the 
Plug-in can expect to receive requests for.  The host name is listed as an asterisk (*) right 
now which means the Plug-in will accept requests for any host name the web server 
responds to.
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__8. Search through the configuration for the Server element.  Within this element you 
will see “Transports” which have values for the host name and port numbers of the 
Application Server.  This is how the Plug-in knows what host name and port to use to 
forward requests to the Application Server.

Note:  The syntax for the server section in the Plug-in configuration can be confusing. 
The parent tag in the configuration is “ServerCluster”.  You do not have a cluster of 
servers right now.  This term is only used so that if you did have a cluster of servers in a 
Network Deployment Cell the syntax of the Plug-in configuration would be the same. 
Right now your Plug-in is configured as if you have a “cluster” with only one server in 
it.

__9. Search through the configuration for the UriGroup element.  Within this element 
you should see an entry for '/HitCountWeb/*'.  This is the entry that indicates the Plug-
in can forward requests to the HitCount application.

__10. Search through the configuration for the Route entry.  This links together the three 
other parts of the Plug-in configuration you have looked at so far.

Note:  The “Route” is probably the most important part of the configuration.  This is 
what the Plug-in uses to make decisions about what requests to forward and how.  The 
Route indicates that if a request comes in for a host name and port listed by the 
VirtualHostGroup and for an application listed in the UriGroup that the request should 
be forwarded to a server in the ServerCluster.

__11. Click the OK button on the bottom of the Plug-in configuration to close the view of 
the configuration file.
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Part 7 - Configure Virtual Host in WebSphere
Right now the Plug-in is forwarding lots of requests to the HitCount application. 
Requests can be submitted using the hostnames localhost or was.myhost.com on one of 
several different ports.  This is because the current Plug-in configuration uses an asterisk 
(*) for the host name of the VirtualHost definitions.

In certain situations you might want to restrict the host name and port combinations that 
are mapped to your applications through the Plug-in.  To do this you must add a 
VirtualHost definition in the WebSphere configuration and configure the “host aliases” 
that it will use.  You would then map an application to this new VirtualHost you created 
to indicate the application would only be available on the given host and port 
combinations.  Finally you would update the web server Plug-in configuration so it uses 
the new rules for how to forward requests to your applications.

__1. In the WebSphere Admin Console expand the Environment navigation group and 
click the link for Virtual hosts.

__2. Notice that right now there are only two virtual hosts.  One is the “default_host” 
that you saw in the Plug-in configuration.  The other is an “admin_host” that is used 
only for the Admin Console.

__3. Click the New button above the list of virtual hosts.

__4. Fill in a Name of myhost for the new virtual host and press the Apply button.  Make 
sure you hit the Apply button as the OK button will not keep you on the same screen.
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__5. To the right under Additional Properties, click the link for Host Aliases.

__6. Right now there are no host aliases.  Click the New button above the empty list of 
host aliases.

__7. Change the Host Name to was.myhost.com and leave the default port of 80.  Click 
the OK button when you have the properties filled in as below.

__8. The new host alias now appears in the list.  This is now the ONLY host name and 
port that applications mapped to this virtual host will recognize.

__9. Click on the Save link in the list of messages near the top of the main Console area.

__10. In the navigation area of the Console expand the Applications → Application 
Types group and click the link for WebSphere enterprise applications.

__11. Click the link for the HitCount application.
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__12. In the list of Web Module Properties on the right click the link for “Virtual hosts”.

__13. Use the drop down next to the HitCountWeb Web module to select the myhost 
Virtual host from the list.  Press the OK button when you have the properties set as 
below.

__14. Back on the screen for the HitCount application, click the link for “Manage 
Modules” in the Modules section of properties.

__15. Notice that the Web module is already mapped to the webserver1 web server AND 
the server1 Application Server.  This indicates that requests for that application will pass 
through the webserver1 web server on the way to server1.  This is a critical setting for 
configuring the web server Plug-in configuration for webserver1.

Note:  This mapping was already done for you even though you did not do it.  This was 
done by the script that you ran to configure the web server in the WebSphere 
configuration.  The script automatically mapped all of the applications that were 
currently installed to the web server definition that it created for the Plug-in.

In the future, when you install applications that have Web modules, mapping them to a 
web server will be an important step.

__16. Click on the Save link in the list of messages near the top of the main Console area.
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__17. In the navigation panel on the left expand the Servers → Server Types group and 
click the link for Web Servers.

__18. Check the checkbox next to webserver1 and click the Generate Plug-in button.

You will see the following message:

__19. Check the checkbox next to webserver1 and click the Propagate Plug-in button.

You will see the following message:
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__20. Click the link for the webserver1 web server.

__21. Under the Additional Properties for the web server click the link for Plug-in 
properties.

__22. Press the View button next to the Plug-in configuration file name.

__23. If you look in the configuration you will notice there are now entries for the 
myhost VirtualHostGroup you created and the UriGroup for the HitCountWeb Uri is 
now listed separately.  There is also a new Route entry that associates the entries relating 
to the HitCount application.  You may need to scroll around the file as there are many 
other entries.

.............

__24. When you are done looking at the new Plug-in configuration, click the Logout link 
in the Admin Console.

Part 8 - Test the New Virtual Host
Now that you have configured a new virtual host with only one host name and port 
combination and associated the HitCount application with it you will want to see how this 
affects the behavior of the application.  No longer will you be able to send requests using 
any host name or port besides was.myhost.com on port 80.

__1. Open a terminal window.  

__2. Use the 'cd' command to change to the <WAS_ROOT>/profiles/AppSrv01/bin 
directory.  Be sure to substitute the value of <WAS_ROOT> from the “Directory Paths” 
page at the beginning of the lab instructions.
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__3. Issue the command:

# ./stopServer.sh server1 -username wasadmin -password wasadmin

__4. Issue the command to restart the server:

# ./startServer.sh server1

Note:  You need to restart the Application Server because some of the configuration 
changes you just made are only read when the server starts.  

__5. Open a web browser and enter the URL http://was.myhost.com/HitCountWeb/ 
into the address bar of the web browser and hit Return.  You will see the normal output of 
the HitCount application.  This is expected since the application is still registered to 
respond to this host name and port combination.

__6. Test the function of the application to verify it is working correctly.

__7. Notice the URL that appears in the browser for the page that displays the messages. 
It is:

http://was.myhost.com/HitCountWeb/HitCountServlet
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__8. Enter the following URLs into the web browser that have worked before:

● http://localhost/HitCountWeb

● http://localhost:9080/HitCountWeb

● http://was.myhost.com:9080/HitCountWeb

Notice that all of these URLs now generate various “page cannot be found” 404 errors. 
This is because these host name and port combinations are not listed as host aliases of the 
virtual host that the HitCount application is mapped to.  This is true even for URLs that 
use the direct WebSphere port of 9080 and do not try to go through the web server.

Note: Using the 'Virtual Host' configuration in WebSphere is one way to control exactly 
how clients can access an application.  If web applications are configured to be available 
through web servers and/or proxy servers for security reasons this configuration will 
prevent users from bypassing that route to the application, even for "internal" users.

__9. Close the web browser you were using for testing.

Part 9 - Investigate Application Settings (Optional)
So far in this lab you have seen how to change the host name and port an application will 
respond to using a Virtual Host.  In this section you will see where the other parts of the 
URL are specified.  You will use the Admin Console to display the “Deployment 
Descriptors” that contain this information.  Remember the URL you used to access the 
application was:

http://was.myhost.com/HitCountWeb/HitCountServlet

__1. Open a web browser and enter http://localhost:9060/ibm/console in the address 
bar, the URL of the Admin Console.

__2. Login as the 'wasadmin' user.
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__3. In the navigation area of the Console expand the Applications → Application 
Types group and click the link for WebSphere enterprise applications.

__4. Click the link for the HitCount application.

__5. Under the Detail Properties section, click the link for View Deployment Descriptor.

__6. Make sure all the entries are expanded and locate the 'context-root' element.  This 
forms the first part of the URL that comes after the host name and port.  Notice this also 
mentions a 'HitCountWeb.war' module for the application.

__7. In the “breadcrumb” trail at the top of the page click the link for the “HitCount” 
application.  This will take you back to the properties of the application configuration.

__8. At the top of the page of properties for the HitCount application click the link for 
Manage Modules under the Modules section of properties.
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__9. In the list of modules click the link for the HitCountWeb module.

__10. On the right side, click the link for View Deployment Descriptor.

__11. Make sure all the entries are expanded and locate the 'servlet-mapping' element. 
This links the servlet in the application to the URL suffix '/HitCountServlet'.

__12. Logout of the Admin Console and close the web browser.

__13. Stop the Application Server using the './stopServer.sh server1' command in a 
command prompt in the <WAS_ROOT>/profiles/AppSrv01/bin directory. Remember 
that you can use the command with credentials as  './stopServer.sh server1 -user 
wasadmin -password wasadmin'.

Note:  You now know how to read the URLs used to access application components. 
These are of the form:

<protocol>://<hostname>:<port>/<context root>/<URL mapping>

Applying this to the HitCountServlet URL:

http://was.myhost.com/HitCountWeb/HitCountServlet

<protocol> - HTTP

<hostname> - was.myhost.com

<port> - 80, this is the default HTTP port if none is listed

<context root> -  HitCountWeb

<URL mapping> - /HitCountServlet
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Part 10 - Review
This lab showed several different aspects of using web servers with WebSphere.  The first 
sections involved installing and configuring the IBM HTTP Server.  This included 
configuring the web server to respond to a “virtual host” which was different than the 
actual host name of your machine.  You also had to modify the network setup of your 
machine to be sure that the requests for this host name would be routed back to your 
machine and not sent out to the network.

The next sections tested the web server Plug-in.  Because most of the initial setup of the 
Plug-in was done by the plug-in customization and the script you ran there was not much 
to do immediately after the script to get it to work.  You also became familiar with how to 
read the Plug-in configuration and discovered how the Plug-in will forward requests for 
applications.

In the last set of sections you reconfigured the HitCount application so it would only 
respond to requests sent to the was.myhost.com host name on port 80.  This may be 
required when you need to have more control over how applications respond to requests. 
The first step in this was to create a new virtual host and host alias that only included the 
desired host name and port.  You then changed the configuration of the HitCount 
application to use this new virtual host.  After restarting the servers you saw how these 
settings restrict the host name and ports that you can use to submit requests.

You also saw how to obtain some basic information about the internal settings of an 
application using the Admin Console to view the deployment descriptors.
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	Lab 1 -  WebSphere 8.5 Installation
	Part 1 -  Install the Installation Manager
	__1.  Make sure that you are logged in as the administrative user listed above.  If you are not, log off and log back on as the user root above.
	__2.  Open a terminal window.  You can do this by selecting 'Applications -> Accessories -> Terminal'.
	__3.  Use the 'cd' command to navigate to the <LABFILES_DIR>/InstallWAS directory substituting the value of the <LABFILES_DIR> variable with the location mentioned in the list of directory paths at the beginning of these labs.  Check with your instructor if you can't find the directory listed.
	__4.  Execute the following command to verify the script is executable.
	__5.  Open a File Browser window.  You can do this by selecting 'Applications -> System Tools -> File Browser'.
	__6.  Browse to /opt/IBM folder.
	__7.  Using the tools of the File Browser create the following new directory.  Notice there is an 'ITM' directory that already exists as part of the DB2 install but you are creating a separate directory as shown below.
	__8.  In the File Browser window navigate to the <LABFILES_DIR>/InstallWAS directory substituting the value of the <LABFILES_DIR> variable with the location mentioned in the list of directory paths at the beginning of these labs.  
	__9.  Copy the 'custom_install_im.sh' file from this folder.  Only copy this file.  This file is a custom file that will run the Installation Manager install process silently.  The file is customized already to help reduce install errors.
	__10.  Navigate to the <WAS_SOFTWARE_DIR>/InstallationManager/tools directory substituting the value of the <WAS_SOFTWARE_DIR> variable with the location mentioned in the list of directory paths at the beginning of these labs.  Check with your instructor if you can't find the directory listed.
	__11.  Paste the copied file into the <WAS_SOFTWARE_DIR>/InstallationManager/tools directory.
	__12.  In a terminal window, use the 'cd' command to navigate to the <WAS_SOFTWARE_DIR>/InstallationManager/tools directory.
	__13.  Use the following command to show the content of the file you copied.
	__14.  Notice the main line in this file calls the 'imcl' program.  Although there are various ways to install the Installation Manager this method is the easiest to customize the installation directory.  We are also installing with 'nonAdmin' access rights which will help avoid some potential security issues.  Your needs for installing the Installation Manager may be slightly different so refer to the Installation Manager documentation for the difference in installation methods.
	__15.  Issue the following command to start the execution of the custom silent install.  You will not be immediately returned to the command prompt which indicates the silent installation is proceeding.  Leave the command prompt open.
	__16.  After a few minutes check that you are returned to the command prompt with a message about something being installed and without any errors being displayed.
	__17.  In a File Browser window navigate to the '/opt/IBM/IM' directory and verify you see files installed as shown below.
	__18.  Write down this installation directory as the value of the <IM_ROOT> variable in the list of directory paths at the beginning of these labs.

	Part 2 -  Record Response File
	__1.  Open a File Browser window.
	__2.  Navigate to the <LABFILES_DIR>/InstallWAS directory substituting the value of the <LABFILES_DIR> variable with the location mentioned in the list of directory paths at the beginning of these labs.  Check with your instructor if you can't find the directory listed.
	__3.  Copy the 'custom_im_record.sh' file from this folder.  Only copy this file.  This file is a custom file that will run the Installation Manager to record a response file.  This can only be done by supplying command line parameters when starting the Installation Manager which is why this file is supplied for you.
	__4.  Navigate to the <IM_ROOT> directory substituting the value of the <IM_ROOT> variable with the location you wrote down in the list of directory paths at the beginning of these labs.  
	__5.  Paste the copied file into the <IM_ROOT> directory.
	__6.  In a terminal window, use the 'cd' command to navigate to the <IM_ROOT> directory.
	__7.  Use the following command to show the content of the file you copied.
	__8.  Notice the key options of -skipInstall which will prevent the Installation Manager from actually installing anything and -record with the file to be created with the recorded response file.
	__9.  Issue the following command to start the Installation Manager. Leave the command prompt open.
	__10.  From the Installation Manager window that appears select 'File → Preferences'.
	__11.  Next to what should be an empty list of repositories click the 'Add Repository' button.
	__12.  Click the Browse button and navigate to the <WAS_SOFTWARE_DIR>/Main directory.
	__13.  Select the 'repository.config' file in this location as shown below and click the OK button to select the file. 
	__14.  Back in the Installation Manager, make sure the proper location for the repository configuration file is listed and click the OK button.
	__15.  Make sure the repository is listed and click the OK button to close the preferences.
	__16.  Back in the Installation Manager select 'File → Open → Install Packages'.  
	__17.  On the Install Packages screen check the box next to 'IBM WebSphere Application Server Network Deployment' which should be listed and click the Next button.
	__18.  After a few seconds the license screen should be shown.  Accept the license and click the Next button.
	__19.  Change the value of the shared resources directory to '/opt/IBM/IMShared' as shown below.  If you had to install the Installation Manager to a different location because you didn't have write access to the hard drive let your instructor know so a different directory could be chosen.
	__20.  Click the Next button once your shared resources directory is modified.
	__21.  Change the value of the WebSphere installation directory to '/opt/IBM/WebSphere/AppServer' as shown below.
	__22.  Write down the installation directory for the <WAS_ROOT> variable in the list of directory paths at the beginning of these labs.  This directory will be used later in the labs.
	__23.  Click the Next button once your WebSphere installation directory is modified.
	__24.  Leave the default options for installed languages and click the Next button.
	__25.  Leave the default features selected and click the Next button.
	__26.  Verify that the options are configured as below and click the 'Install' button.
	__27.  After just a few seconds you should see a message that the "installation" was successful.  Click the Finish button.
	__28.  In the Installation Manager select 'File → Exit'.
	__29.  Check in your <LABFILES_DIR> folder that you see the XML response file that was recorded.

	Part 3 -  Install WebSphere with Response File
	__1.  Open a File Browser window.
	__2.  Navigate to the <LABFILES_DIR>/InstallWAS directory substituting the value of the <LABFILES_DIR> variable with the location mentioned in the list of directory paths at the beginning of these labs.  Check with your instructor if you can't find the directory listed.
	__3.  Copy the 'custom_install_WAS.sh' file from this folder.  Only copy this file.  This file is a custom file that will run the Installation Manager to use the recorded response file generated in the last section.
	__4.  Navigate to the <IM_ROOT> directory substituting the value of the <IM_ROOT> variable with the location you wrote down in the list of directory paths at the beginning of these labs.  
	__5.  Paste the copied file into the <IM_ROOT> directory.
	__6.  In a terminal window, use the 'cd' command to navigate to the <IM_ROOT> directory.
	__7.  Use the following command to show the content of the file you copied.
	__8.  Notice the key option of 'input' which will point to the custom response file you recorded.
	__9.  Issue the following command to start the installation of WAS.  You will not be immediately returned to the command prompt which indicates the silent installation is proceeding.  Leave the command prompt open.  You might want to take a quick break at this point.
	__10.  After several minutes check that you are returned to the command prompt with a message about WebSphere being installed and without any errors being displayed.
	__11.  In a File Browser window navigate to the '/opt/IBM/' directory and verify you see files installed as shown below.  You should see the 'IMShared' and 'WebSphere' folders that were not there before.

	Part 4 -  Create a WebSphere Profile
	__1.  Open a File Browser window.
	__2.  Navigate to the <LABFILES_DIR>/InstallWAS directory substituting the value of the <LABFILES_DIR> variable with the location mentioned in the list of directory paths at the beginning of these labs.  Check with your instructor if you can't find the directory listed.
	__3.  Copy the 'custom_create_profile.sh' file from this folder.  Only copy this file.  This file is a custom file that will run the profile management tool with a few options.  This file is simply being provided to help prevent typos when running the profile management tool.
	__4.  Navigate to the <WAS_ROOT>/bin directory substituting the value of the <WAS_ROOT> variable with the location you wrote down in the list of directory paths at the beginning of these labs.  
	__5.  Paste the copied file into the <WAS_ROOT>/bin directory.
	__6.  In a terminal window, use the 'cd' command to navigate to the <WAS_ROOT>/bin directory.
	__7.  Use the following command to show the content of the file you copied.
	__8.  Notice the key options of -create and -templatePath which are the minimum options needed when using the "default" profile as this command does.  Some additional options are provided to configure administrative security also.
	__9.  Issue the following command to start the profile creation.  Leave the command prompt open.  You might want to take a quick break at this point.
	__10.  After several minutes the command should complete and return to the command prompt without errors.  Make sure you get a message about 'INSTCONFSUCCESS' as shown below.
	__11.  Open a File Browser window and navigate to the <WAS_ROOT>/profiles/AppSrv01/logs directory.
	__12.  Open the 'AboutThisProfile.txt' file in a text editor.  Select 'Display' if you are given choices when double-clicking the file.
	__13.  In the file that is opened, note the Profile name, Node name, and Host name.  Write these values down in the Lab Notes section at the beginning of the lab guide.
	__14.  Close the text file showing the profile information.

	Part 5 -  Verify Application Server
	__1.  Start the Application Server.  Do this by following the set of steps below:
	__2.  Verify that you get a message that the server is "open for e-business".  Leave the terminal window open.
	__3.  Once the server is started, open a web browser and type the URL 'http://localhost:9080/snoop' into the address bar.  You should see the output below.
	__4.  Close the web browser used to test the Application Server.
	__5.  Stop the Application Server.  Do this by following the set of steps below:
	__6.  Wait until you see the following result.

	Part 6 -  Explore Application Server Directory Structure
	__1.  Open a File Browser window.
	__2.  Navigate to the <WAS_ROOT> directory you wrote down in the notes at the beginning of these labs.  This should be the main installation directory for WebSphere.
	__3.  Look at some of the major directories and their contents:
	__4.  Look at some of the log files created during the installation and verification:
	__5.  Close all File Browser windows.
	__6.  Close all terminal command prompts.
	__7.  Close all web browsers.

	Part 7 -  Review

	Lab 2 -  Install an Application
	Part 1 -  Control Applications From the Admin Console
	__1.  Start the Application Server.  Do this by following the set of steps below:
	__2.  Start the Admin Console by opening a Web browser and entering the URL http://localhost:9060/ibm/console/
	__3.  Since security is enabled you will get a warning about the server certificate.  Accept the certificate or continue to the website depending on the browser you are using.
	__4.  Enter a user ID and password of ‘wasadmin’ and click “Log in” on the Login screen of the Console.
	__5.  Expand the Applications group in the Navigation tree, expand Application Types and click on the link for WebSphere enterprise applications.
	__6.  Check the checkbox next to the DefaultApplication and press the Stop button.  You should get a message that the application was stopped and a red ‘X’ in the status column.
	__7.  Open a separate Web browser and try to access the Snoop Servlet as in the last lab. The URL is http://localhost:9080/snoop.  You should get an error.  This is because it is part of the DefaultApplication which is stopped. 
	__8.  In the Admin Console, check the checkbox next to the DefaultApplication and press the Start button.  You should get a message that the application was started and a green arrow in the status column.
	__9.  In the Web browser you used to access the Snoop Servlet, hit the refresh button.  You should see the normal output of the Snoop Servlet.  
	__10.  Close the extra Web browser you were using to test the Snoop application.

	Part 2 -  Install an Application to the Server
	__1.  Return to the web browser you were using for the Admin Console.  If you had closed it you can open it at http://localhost:9060/ibm/console/ and login is wasadmin.
	__2.  In the Applications group in the navigation, click the link for New Application.
	__3.  Click the link for New Enterprise Application.
	__4.  Next to the Local file system box, press the Browse button.
	__5.  Find the file <LABFILES_DIR>/InstallApp/HitCount.ear and select Open in the file chooser dialog.  Remember to substitute the value of the <LABFILES_DIR> variable from the notes at the beginning of the labs.
	__6.  Press the Next button.
	__7.  Check the option for Detailed installation.  This will show all steps.
	__8.  Once you have the options specified as below, press the Next button.
	__9.  On step 1, check the Precompile JavaServer Pages files option and click Next.
	__10.  Accept the default values on steps 2-14 by pressing the Next button on each step.  Some of these steps will only appear once you go through other steps.  You should end up at step 15 which is the summary.  Some of the intermediate steps are explained below:
	__11.  On step 15, the Summary, click the Finish button.  Wait for it to complete the installation and be sure you get a message that says Application HitCount installed successfully.
	__12.  Click the link to Review changes to the master configuration below the message about the successful installation.
	__13.  On the Save screen, click the '+' sign to expand the list of changes that will be made.
	__14.  Click the Save button at the bottom of the page to save the master configuration.
	__15.  In the Applications group in the navigation, expand the Application Types section and click the link for WebSphere enterprise applications.
	__16.  Start the HitCount application by checking the checkbox next to it and clicking the Start button.

	Part 3 -  Test the HitCount Application
	__1.  Make sure that you are viewing the list of Enterprise Applications in the Admin Console.  If not, you can expand the 'Applications → Application Types' group in the navigation and click the link for 'WebSphere enterprise applications'.
	__2.  From the list of applications, click the link for the HitCount application by clicking on the application name.  This will show you a page of options and configuration related to that particular application.
	__3.  From the list of Detail Properties associated with the HitCount application click the link for View Deployment Descriptor.
	__4.  In the text of the Deployment Descriptor find the value of the context-root.  This is what you can add to the host name and port of the server to access the application.
	__5.  Open a new web browser and enter the URL http://localhost:9080/HitCountWeb.  Notice this URL ends in the “context-root” of the web application.  You should see the following page.
	__6.  Click the link of the home page of the application.  You should get an initial count of '1'.
	__7.  Refresh the page several times to see the count increase.
	__8.  Leave the web browser open that you are using to test the application.
	__9.  Return to your Admin Console web browser.  If you closed it, open a new window to the URL http://localhost:9060/ibm/console/.  Make sure you leave the web browser running the HitCount application open.
	__10.  Expand the 'Applications → Application Types' group in the navigation and click the link for 'WebSphere enterprise applications'.
	__11.  Check the checkbox next to the HitCount application and press the Stop button.
	__12.  Once the application is stopped, check the checkbox next to the HitCount application again and press the Start button.
	__13.  Return to the web browser you were using to test the application and refresh the page.  The count should return to 1 even though you are using the same web browser.  The “state” of the stateful session EJB has been lost by restarting the application.
	__14.  Close the web browser you used to test the new application.

	Part 4 -  Deploy Applications with a Monitored Directory
	__1.  Return to your Admin Console web browser.  If you closed it, open a new window to the URL http://localhost:9060/ibm/console/.  Make sure you leave the web browser running the HitCount application open.
	__2.  Expand the 'Applications → Application Types' group in the navigation and click the link for 'WebSphere enterprise applications'.
	__3.  Check the checkbox next to the HitCount application and press the Stop button.
	__4.  Once the application is stopped, check the checkbox next to the HitCount application again and press the Uninstall button.
	__5.  Click the OK button to confirm you want to uninstall the application.
	__6.  In the messages that display at the top of the browser click the Save link.
	__7.  In the Applications group in the navigation, click the link for Global deployment settings.
	__8.  Check the box for the 'Monitor directory to automatically deploy applications' and press the the Apply button.  You can leave the default settings.
	__9.  In the messages that display at the top of the browser click the Save link.
	__10.  In the web browser showing the Admin Console click the Logout link near the top of the Console.  If you have unsaved changes save them before logging out.
	__11.  Stop the Application Server.  Do this by following the set of steps below:
	__12.  Once the server has stopped issue the command './startserver.sh server1' to restart it.  The server must be restarted after enabling monitored directory deployment.
	__13.  Open a File Browser window.
	__14.  Navigate to the <LABFILES_DIR>/InstallApp directory substituting the value of the <LABFILES_DIR> variable with the location mentioned in the list of directory paths at the beginning of these labs.
	__15.  Copy the HitCount.ear file from the directory.
	__16.  Navigate to the following directory:
	__17.  Paste the HitCount.ear file in this directory.
	__18.  Return to your Admin Console web browser.  If you closed it, open a new window to the URL http://localhost:9060/ibm/console/.  
	__19.  Login to the Admin Console with a user and password of 'wasadmin'.
	__20.  Expand the 'Applications → Application Types' group in the navigation and click the link for 'WebSphere enterprise applications'.
	__21.  Check that you see the HitCount application installed and running.
	__22.  Open a new web browser and enter the URL http://localhost:9080/HitCountWeb.
	__23.  Test the application as you did before and make sure it works.
	__24.  Close the web browser you used to test the new application.
	__25.  In the web browser showing the Admin Console click the Logout link near the top of the Console.
	__26.  Close the web browser you were using for the Admin Console.
	__27.  Stop the application server.  Do this with the './stopserver.sh server1' command in a terminal command prompt in the <WAS_ROOT>/profiles/AppSrv01/bin directory. Remember that you can use the command with credentials as  './stopserver.sh server1 -user wasadmin -password wasadmin'.
	__28.  Close all open windows.

	Part 5 -  Review

	Lab 3 -  IBM HTTP Server and Web Server Plug-in
	Part 1 -  Install IBM HTTP Server
	__1.  Make sure you are logged in as the 'root' user ID.
	__2.  Open a terminal window.  You can do this by selecting 'Applications -> Accessories -> Terminal'.
	__3.  In a terminal window, use the 'cd' command to navigate to the <IM_ROOT> directory.
	__4.  Issue the following command to start the Installation Manager. Leave the command prompt open.
	__5.  From the Installation Manager window that appears select 'File → Preferences'.
	__6.  Next to the list of repositories click the 'Add Repository' button.
	__7.  Click the Browse button and navigate to the <WAS_SOFTWARE_DIR>/Supplement directory.  Remember the <WAS_SOFTWARE_DIR> directory is where the WebSphere software can be installed FROM and not where WebSphere is currently installed.
	__8.  Select the 'repository.config' file in this location as shown below and click the OK button to select the file. 
	__9.  Back in the Installation Manager, make sure the proper location for the repository configuration file is listed and click the OK button.
	__10.  Make sure the repository is listed and click the OK button to close the preferences.
	__11.  Back in the Installation Manager select 'File → Open → Install Packages'.  
	__12.  On the Install Packages screen check the box next to the following options:
	__13.  Once the above options are selected click the Next button.
	__14.  After a few seconds the license screen should be shown.  Accept the license and click the Next button.
	__15.  From the list shown select each package that will be installed and Change the installation directory so they will be installed to a subdirectory of the '/opt/IBM' directory. The installation directories should be:
	__16.  Write down the installation directory for the HTTP Server as the <IHS_ROOT> variable in the list of directory paths at the beginning of these labs.  Also write down the Web Server Plug-ins installation directory as the <PLUGIN_ROOT> variable.  These directories will be used later in the labs.
	__17.  Once your installation directories are configured as shown above click the Next button.
	__18.  Leave the default features to install and click the Next button.
	__19.  Check that your Web Server Configuration options show using port 80.
	__20.  Once you have confirmed you see the proper web server configuration options, leave the default settings and click the Next button.
	__21.  Verify that the options are configured as below and click the 'Install' button. 
	__22.  After several minutes installing software you should see a success message.  Leave the option to launch the 'WebSphere Customization Toolbox' selected and click the Finish button.
	__23.  Leave the 'WebSphere Customization Toolbox' open for the next section.
	__24.  Close the Installation Manager by selecting File → Exit from the appropriate window.

	Part 2 -  Configure Web Server Plug-in
	__1.  In the 'WebSphere Customization Toolbox' tool that appeared from the last section, select the 'Web Server Plug-ins Configuration Tool' and click the Launch Selected Tool button.
	__2.  In the tool that appears, next to the empty list of 'Web Server Plug-in Runtime Locations' click the Add button.
	__3.  Fill in a 'Name' value of 'Main Plugin' and use the Browse button to select the <PLUGIN_ROOT> directory written down in the directory paths from early in this lab.
	__4.  Once you settings appear as shown above click the Finish button.
	__5.  With the new entry for the plug-in location selected above, click the Create button next to the empty lower list of 'Web Server Plug-in Configurations'.
	__6.  Leave the default option of IBM HTTP Server 8.5 selected and click the Next button.
	__7.  In the options for the web server configuration file use the Browse button to select the <IHS_ROOT>/conf/httpd.conf file if it is not already selected and click OK.
	__8.  Back in the wizard, make sure that you have the correct configuration file listed and there is no error in the top margin.  Also leave the default port of 80 and click the Next button.
	__9.  In the options for the 'Setup IBM HTTP Server Administration Server' fill in a userid, password and password confirmation of 'ihsadmin'.  You may need to manually expand the window size to see all fields.  Leave the other default options and click the Next button.
	__10.  On the next page, fill in a 'User ID' and 'Group' of 'ihsadmin'.  Leave the option checked to create a new unique system user ID and click the Next button.
	__11.  Leave the default value of the web server name and click the Next button.  
	__12.  Leave the default option of a "remote" scenario and fill in the value for the <hostname> variable you wrote down in the lab notes section for the WebSphere installation.  You can also open a command prompt and run the 'hostname' command to get the value.  Click the Next button when you have configured the settings on this page.
	__13.  Make sure that your settings match those shown below and click the Configure button.
	__14.  Make sure that you get a success message, uncheck the 'Launch the plug-in configuration roadmap', and then click the Finish button.  The roadmap could normally be used to verify the next steps in the configuration of the web server and plug-in.
	__15.  Check that your new plug-in configuration is listed and select 'File → Exit' to exit the Customization Toolbox.
	__16.  Open a terminal window.  
	__17.  Use the 'cd' command to change to the <WAS_ROOT>/profiles/AppSrv01/bin directory.  
	__18.  Issue the command './startServer.sh server1'.
	__19.  Open another terminal window.  
	__20.  Change directories using the 'cd' command to the <IHS_ROOT>/bin directory.  Be sure to substitute the value of <IHS_ROOT> from the “Directory Paths” page at the beginning of the lab instructions.
	__21.  Execute the following command to start the web server.  
	__22.  Execute the following command to start the HTTP administration service.
	__23.  Open a File Browser window or use one you already have open.
	__24.  Navigate to the directory <PLUGIN_ROOT>/bin where the <PLUGIN_ROOT> is the variable you wrote down from the IBM HTTP Server and Plugin installation in the previous section.
	__25.  Find the file 'configurewebserver1.sh' in the directory.  Check that you find the correct file as there are several that start with 'configure...'.  
	__26.  Copy the 'configurewebserver1.sh' file by right clicking and selecting Copy from the popup menu.
	__27.  Open another File Browser and navigate to the directory <WAS_ROOT>/bin where the <WAS_ROOT> is the variable you wrote down from the WebSphere installation lab.
	__28.  Paste the 'configurewebserver1.sh' file into this directory by selecting Edit -> Paste from the menus.
	__29.  Be sure you see the 'configurewebserver1.sh' file in the list of files.
	__30.  Make sure you have logged out of any previously open Admin Console browser windows.
	__31.  Open a terminal window.  
	__32.  Change directories using the 'cd' command to the <WAS_ROOT>/bin directory.  Be sure to substitute the value of <WAS_ROOT> from the “Directory Paths” page at the beginning of the lab instructions.
	__33.  Enter the following command to check that the WebSphere server is started:
	__34.  Enter the following command to configure the web server definition in the WebSphere configuration.  The command should all be entered on the same line even though it wraps to a second line below.
	__35.  Scroll back through the messages that were output and be sure you do not see any errors.
	__36.  Close any extra command prompts or File Browser windows.

	Part 3 -  Configure Virtual Host on Web Server
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.  Remember to continue if you get any certificate errors.
	__2.  Login as the 'wasadmin' user.
	__3.  Navigate to the Servers → Server Types → Web Servers section of the admin console.  Notice there is now a configuration for 'webserver1' which the script you ran added.
	__4.  Click the link for webserver1 from the list.
	__5.  Under the Additional Properties click the link for Configuration File.  If you get an error displaying the configuration file let your instructor know as this likely means there is a problem with your IHS administration password.
	__6.  Scroll to the very end of the file and add a few blank lines.  It may be a little difficult to scroll as you will have a scrollbar for the whole page in the browser as well as for the configuration file itself.
	__7.  Add the following text exactly as it appears below at the end of the configuration file.  
	__8.  Check that your configuration appears as below and press the OK button.
	__9.  Go back to the list of web servers by navigating to the Servers → Server Types → Web Servers section of the admin console.
	__10.  Check the box next to the webserver1 entry and click the Stop button.  Make sure you get a message about the server stopping.
	__11.  Check the box next to webserver1 and click the Start button.  If you have trouble starting the web server check your configuration file syntax.
	__12.  Logout of the Admin Console.

	Part 4 -  Update Network Setup
	__1.  Open a File Browser window or use one you already have open.
	__2.  Navigate to the '/etc' directory.
	__3.  Find the 'hosts' file in this directory.
	__4.  Copy the 'hosts' file and rename the copy to something like 'hosts-backup'.  This will ensure you can restore the original if needed.
	__5.  Double-click on the ‘hosts’ file and open it with a text editor like gedit.
	__6.  If you do not already have a line that starts with the IP address 127.0.0.1 add it. 
	__7.  Add to this line 'was.myhost.com' with spaces between the IP address and each of the hostnames.  Make sure to add any entries AFTER the real hostname as shown below.  The file should be similar to this: 
	__8.  Save the file and close the text editor.
	__9.  Open a terminal window.  
	__10.  Be sure you can ping the new host name.  Enter the command below.  Be sure you don’t get an “unknown host” or “request timed out” error message.  
	__11.  Close the terminal window.
	__12.  Open a web browser window.
	__13.  Enter the URL http://was.myhost.com in the address bar of the browser and hit Return. You should see the homepage of the IBM HTTP Server running on your machine.  If you do not see this screen contact your instructor.
	__14.  Close out any extra terminal windows, web browsers, or File Browser windows you may have open.

	Part 5 -  Test Plug-in
	__1.  Open a web browser and enter the URL http://localhost:9080/HitCountWeb/ in the address bar and hit the Return key.  You should see the normal output of the HitCount application.
	__2.  Test the function of the application to be sure it is working properly.
	__3.  Enter the URL http://localhost/HitCountWeb into the address bar of the web browser and hit Return.  You should see the same application.  If you get any errors check that your web server is running.
	__4.  Test the application again to be sure the same behavior is shown even though the requests are now being forwarded through the Plug-in.
	__5.  Enter the URL http://was.myhost.com/HitCountWeb/ into the address bar of the web browser and hit Return.  Again you should see the same HitCount application.  This is because you have configured the web server to respond to the host name was.myhost.com.  It can also forward requests for this host name to WebSphere.
	__6.  Close the web browser you have been using to test.

	Part 6 -  Examine Plug-in Configuration
	__1.  Start the Admin Console by opening a Web browser and entering the URL http://localhost:9060/ibm/console/
	__2.  Enter a user ID and password of ‘wasadmin’ and click “Log in” on the Login screen of the Console.
	__3.  In the navigation panel on the left expand the Servers → Server Types group and click the link for Web Servers.
	__4.  Click the link for the webserver1 web server.
	__5.  Under the Additional Properties for the web server click the link for Plug-in properties.
	__6.  Press the View button next to the Plug-in configuration file name.
	__7.  Search through the configuration for the VirtualHostGroup element.  This has the definition of several VirtualHosts.  These are the host name and port combinations the Plug-in can expect to receive requests for.  The host name is listed as an asterisk (*) right now which means the Plug-in will accept requests for any host name the web server responds to.
	__8.  Search through the configuration for the Server element.  Within this element you will see “Transports” which have values for the host name and port numbers of the Application Server.  This is how the Plug-in knows what host name and port to use to forward requests to the Application Server.
	__9.  Search through the configuration for the UriGroup element.  Within this element you should see an entry for '/HitCountWeb/*'.  This is the entry that indicates the Plug-in can forward requests to the HitCount application.
	__10.  Search through the configuration for the Route entry.  This links together the three other parts of the Plug-in configuration you have looked at so far.
	__11.  Click the OK button on the bottom of the Plug-in configuration to close the view of the configuration file.

	Part 7 -  Configure Virtual Host in WebSphere
	__1.  In the WebSphere Admin Console expand the Environment navigation group and click the link for Virtual hosts.
	__2.  Notice that right now there are only two virtual hosts.  One is the “default_host” that you saw in the Plug-in configuration.  The other is an “admin_host” that is used only for the Admin Console.
	__3.  Click the New button above the list of virtual hosts.
	__4.  Fill in a Name of myhost for the new virtual host and press the Apply button.  Make sure you hit the Apply button as the OK button will not keep you on the same screen.
	__5.  To the right under Additional Properties, click the link for Host Aliases.
	__6.  Right now there are no host aliases.  Click the New button above the empty list of host aliases.
	__7.  Change the Host Name to was.myhost.com and leave the default port of 80.  Click the OK button when you have the properties filled in as below.
	__8.  The new host alias now appears in the list.  This is now the ONLY host name and port that applications mapped to this virtual host will recognize.
	__9.  Click on the Save link in the list of messages near the top of the main Console area.
	__10.  In the navigation area of the Console expand the Applications → Application Types group and click the link for WebSphere enterprise applications.
	__11.  Click the link for the HitCount application.
	__12.  In the list of Web Module Properties on the right click the link for “Virtual hosts”.
	__13.  Use the drop down next to the HitCountWeb Web module to select the myhost Virtual host from the list.  Press the OK button when you have the properties set as below.
	__14.  Back on the screen for the HitCount application, click the link for “Manage Modules” in the Modules section of properties.
	__15.  Notice that the Web module is already mapped to the webserver1 web server AND the server1 Application Server.  This indicates that requests for that application will pass through the webserver1 web server on the way to server1.  This is a critical setting for configuring the web server Plug-in configuration for webserver1.
	__16.  Click on the Save link in the list of messages near the top of the main Console area.
	__17.  In the navigation panel on the left expand the Servers → Server Types group and click the link for Web Servers.
	__18.  Check the checkbox next to webserver1 and click the Generate Plug-in button.
	__19.  Check the checkbox next to webserver1 and click the Propagate Plug-in button.
	__20.  Click the link for the webserver1 web server.
	__21.  Under the Additional Properties for the web server click the link for Plug-in properties.
	__22.  Press the View button next to the Plug-in configuration file name.
	__23.  If you look in the configuration you will notice there are now entries for the myhost VirtualHostGroup you created and the UriGroup for the HitCountWeb Uri is now listed separately.  There is also a new Route entry that associates the entries relating to the HitCount application.  You may need to scroll around the file as there are many other entries.
	__24.  When you are done looking at the new Plug-in configuration, click the Logout link in the Admin Console.

	Part 8 -  Test the New Virtual Host
	__1.  Open a terminal window.  
	__2.  Use the 'cd' command to change to the <WAS_ROOT>/profiles/AppSrv01/bin directory.  Be sure to substitute the value of <WAS_ROOT> from the “Directory Paths” page at the beginning of the lab instructions.
	__3.  Issue the command:
	__4.  Issue the command to restart the server:
	__5.  Open a web browser and enter the URL http://was.myhost.com/HitCountWeb/ into the address bar of the web browser and hit Return.  You will see the normal output of the HitCount application.  This is expected since the application is still registered to respond to this host name and port combination.
	__6.  Test the function of the application to verify it is working correctly.
	__7.  Notice the URL that appears in the browser for the page that displays the messages.  It is:
	__8.  Enter the following URLs into the web browser that have worked before:
	__9.  Close the web browser you were using for testing.

	Part 9 -  Investigate Application Settings (Optional)
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the navigation area of the Console expand the Applications → Application Types group and click the link for WebSphere enterprise applications.
	__4.  Click the link for the HitCount application.
	__5.  Under the Detail Properties section, click the link for View Deployment Descriptor.
	__6.  Make sure all the entries are expanded and locate the 'context-root' element.  This forms the first part of the URL that comes after the host name and port.  Notice this also mentions a 'HitCountWeb.war' module for the application.
	__7.  In the “breadcrumb” trail at the top of the page click the link for the “HitCount” application.  This will take you back to the properties of the application configuration.
	__8.  At the top of the page of properties for the HitCount application click the link for Manage Modules under the Modules section of properties.
	__9.  In the list of modules click the link for the HitCountWeb module.
	__10.  On the right side, click the link for View Deployment Descriptor.
	__11.  Make sure all the entries are expanded and locate the 'servlet-mapping' element.  This links the servlet in the application to the URL suffix '/HitCountServlet'.
	__12.  Logout of the Admin Console and close the web browser.
	__13.  Stop the Application Server using the './stopServer.sh server1' command in a command prompt in the <WAS_ROOT>/profiles/AppSrv01/bin directory. Remember that you can use the command with credentials as  './stopServer.sh server1 -user wasadmin -password wasadmin'.

	Part 10 -  Review

	Lab 4 -  Solving Problems
	Part 1 -  Introduce Problem
	__1.  If it is not already running, start the Application Server.  You can do this by executing the command './startServer.sh server1' from the <WAS_ROOT>/profiles/AppSrv01/bin directory.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console/, the URL for the Admin Console.
	__3.  Login to the Admin Console as 'wasadmin'.
	__4.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__5.  From the list of Enterprise Applications, click on the link for the HitCount application.
	__6.  Under the Enterprise Java Bean Properties section on the right side click the link for EJB JNDI names.
	__7.  In the JNDI Name field, change the value to ‘ejb/GARBAGE’ and press the OK button.	
	__8.  Click the Save link in the messages at the top of the Admin Console.
	__9.  Logout of the Admin Console and close the browser window.
	__10.  Stop the IBM HTTP Server by executing the './apachectl stop' command from the <IHS_ROOT>/bin directory in a terminal window.
	__11.  Stop the WebSphere Application Server by executing the following command from the <WAS_ROOT>/profiles/AppSrv01/bin directory.

	Part 2 -  Isolate Problems
	__1.  Open a Web Browser and enter http://was.myhost.com/ in the address bar.  You should get an error message which says something like “Unable to connect”.  
	__2.  Leave the web browser window open.
	__3.  Open a terminal window. 
	__4.  Enter the command 'ping -c 4 was.myhost.com'.  Be sure you do not get a response which states “Unknown Host”.  If you did get this response the problem would be in the networking setup. You should get replies as shown below.
	__5.  Change directories to the <IHS_ROOT>/logs directory.  Make sure to substitute the value of the <IHS_ROOT> variable you wrote down in the Directory Paths page at the beginning of the labs.  The command for this should be ‘cd /opt/IBM/HTTPServer/logs’.
	__6.  Execute the command 'ls httpd.pid'.  If this file is not found it means the web server is not running.
	__7.  Change directories to the <IHS_ROOT>/bin directory.
	__8.  Start the IBM HTTP Server using the './apachectl start' command.
	__9.  Return to the web browser that you used to access http://was.myhost.com and refresh the page.  This time you should see the homepage of the IBM HTTP Server.  This confirms you can communicate with the web server.
	__10.  Enter http://localhost/snoop in the address bar of the web browser.  You should get an “Internal Server Error”.  This request should be sent to the Application Server through the Web Server plug-in.
	__11.  To test the Application Server directly enter http://localhost:9080/snoop in the address bar.  You should get the same “Unable to connect”.  Since this request should be sent directly to the Application Server on port 9080 the problem is in communicating with the Application Server.  The previous “Internal Server Error” occurred because the plug-in tried to forward the request to the Application Server but could not contact it.
	__12.  Start the WebSphere Application Server by executing the './startServer.sh server1' command from the <WAS_ROOT>/profiles/AppSrv01/bin directory.  Wait for the service to start completely.
	__13.  Close the previous Web Browser.  This ensures that the browser is not caching the error response.
	__14.  Open a new Web Browser and enter http://localhost:9080/snoop in the address bar.  You should get the normal response from the Application Server. (You may need to press SHIFT and refresh).
	__15.  Remove the port from the URL and resubmit the request for http://localhost/snoop.  This ensures the Web Server plug-in can forward the request properly.
	__16.  Change the URL to http://localhost/snoop5 and resubmit the request.  You should get a “The page cannot be found” error.  This is from an HTTP 404 error.  Since we know this request is not mapped to anything this error is expected.
	__17.  Enter http://was.myhost.com/HitCountWeb in the address bar.  You should see the main page of the HitCount application.
	__18.  Click the link to attempt to access the page that displays the counter.  You will get a 500 “Internal Server Error” because of the problem that was introduced in the first part of the lab. Notice that the “Internal Server Error” may be formatted differently because it is coming from the WebSphere Application Server and not the web server.

	Part 3 -  Check Admin Console Messages
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  Expand the Troubleshooting section in the navigation panel and expand Runtime Messages.
	__4.  Click the link for Runtime error messages.  By default the runtime messages are disabled so you will not see any.
	__5.  Use the dropdown to select Warning and press the Apply button.
	__6.  Click the link to Save the configuration.
	__7.  Go back to the browser you were using to test the HitCount application.  Open a new one if you closed it.  Test the application again and be sure that you see the error again.
	__8.  Return to the Admin Console.
	__9.  Click the link for Runtime error messages again in the Admin Console.
	__10.  You should see some messages as shown below.  You may have more if you viewed the page more than once or caused other errors previously.  
	__11.  Click the link for one of the messages.
	__12.  In the details of the message you should see a message about "bean count not found within scope".

	Part 4 -  Check Log Files
	__1.  In the Admin Console click on the link for Troubleshooting -> Logs and Trace.
	__2.  Click the link for server1 in the list.
	__3.  Click the link for JVM Logs.
	__4.  On the Configuration tab look at some of the settings available.  Notice that you can configure the file name used for the log, enable and configure log file automatic rotation, and the number of historical log files to keep if rotation is enabled.  You can even disable “application print statements” although this is usually not a good idea because developers may be printing out valuable messages for tracking down errors.
	__5.  Click the Runtime tab.
	__6.  Write down the File Name of the System.out log in the Lab Notes section at the beginning of the labs.  Use the drop-down to make sure you are not looking at the log file that ends with '.owner'.  This File Name is assembled using the settings from the Configuration tab along with the values of several environment variables.  Notice the default location of the log file is in a ‘server1’ subdirectory of the main ‘logs’ directory of your 'AppSrv01' WebSphere profile.
	__7.  Click the View button next to the System.out log file name to display the log file in the Admin Console.
	__8.  When the Admin Console displays the log file, notice the two numbers near the top.  The Admin Console displays the Total number of lines in the log file and the Filtered total which is what is actually displayed in the Console.
	__9.  Display the last three hundred lines of the log by entering in the Retrieve Lines text box a range that starts about four hundred lines before the total number of lines and ends with the last line.  In the above example this might be 2700-3100.  Press the Refresh button after entering the new range.
	__10.  When the log file is redisplayed (which may take a moment), scroll to the very bottom and begin scrolling backwards.  This will view the most recent messages first and go back to earlier messages.  Stop when you see any line that is tabbed in from the left and does not start with a time stamp.  This is the end of a Java “stack trace”.
	__11.  Continue to scroll backwards until you reach a block of several “normal” messages that start with timestamps and have an “I” or “A” for the event type.  You may pass several Java problems being reported together.  This is common in a Java multi-threaded application like a Java EE Application Server.  Usually the most detailed information is present in the first problem that gets reported.
	__12.  In the first line of the first Java problem reported scroll to the right.  You should see the same “bean count not found within scope” mentioned in the console message.  
	__13.  Logout of the admin console and close any extra web browsers or windows.

	Part 5 -  Use dumpNameSpace Tool
	__1.  Open a terminal window.  
	__2.  Change directories using the 'cd' command to the <WAS_ROOT>/profiles/AppSrv01/bin directory.  Be sure to substitute the value of <WAS_ROOT> from the “Directory Paths” page at the beginning of the lab instructions.
	__3.  Issue the command './dumpNameSpace.sh'.
	__4.  In the security prompt supply a user ID and password of 'wasadmin'.
	__5.  In the output look for the entry in the right column for hitcount.Counter.  You will need to scroll around a bit to find it.  This is the interface used by the EJB client.  Notice the entry on the left side is the incorrect JNDI name that we supplied.  There may be other entries with the 'hitcount.Counter' type but only one with the incorrect name you gave the bean.  The line number where your entry shows up may be different.
	__6.  If you find difficult to find it then copy and paste the result in a text document and search for it.
	__7.  Close the terminal command prompt window and browsers.

	Part 6 -  Review

	Lab 5 -  Logging With HPEL
	Part 1 -  Enable and Configure HPEL
	__1.  If it is not already running, start the Application Server.  You can do this by executing the command './startServer.sh server1' from the <WAS_ROOT>/profiles/AppSrv01/bin directory.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console/, the URL for the Admin Console.
	__3.  Login to the Admin Console as 'wasadmin'.
	__4.  In the Admin Console click on the link for Troubleshooting -> Logs and Trace.
	__5.  Click the link for server1 in the list.
	__6.  Click the 'Switch to HPEL Mode' button to switch the logging method.
	__7.  Click the Save link in the messages at the top of the Admin Console.
	__8.  Click the link for server1 in the list again to go back to the logging configuration.
	__9.  Click the link for 'Configure HPEL text log'.
	__10.  Notice that some of these settings look like the "legacy" logging settings.  We will leave the text log enabled although for even better performance you would disable this and use the binary repositories only.  Click the Cancel button.
	__11.  Click the link for 'Configure HPEL logging'.
	__12.  Notice some of the settings available including the event that will trigger the cleanup of the oldest records.
	__13.  Change the 'Maximum log size' to 25 Megabytes and then click the OK button.
	__14.  Click the Save link in the messages at the top of the Admin Console.
	__15.  Logout of the Admin Console and close the web browser.
	__16.  Stop the WebSphere Application Server by executing the following command from the <WAS_ROOT>/profiles/AppSrv01/bin directory.
	__17.  Restart the server with the './startServer.sh server1' command.

	Part 2 -  Generate Errors to Locate in Logs
	__1.  Open a new web browser window.
	__2.  Enter http://was.myhost.com/HitCountWeb in the address bar.  You should see the main page of the HitCount application.
	__3.  Click the link to attempt to access the page that displays the counter.  You will get a 500 “Internal Server Error” because of the problem that still exists in the 'HitCount' application.
	__4.  Hit the back button to return to the previous page that shows the main page of the HitCount application.
	__5.  Click the link to display the counter again.  This should give us a few error messages to look for.
	__6.  Close the browser used to access the HitCount application.

	Part 3 -  View HPEL Log Records in the Admin Console
	__1.  Open a browser for the Admin Console and open the URL http://localhost:9060/ibm/console
	__2.  Login as the 'wasadmin' user.
	__3.  In the Admin Console click on the link for Troubleshooting -> Logs and Trace.
	__4.  Click the link for server1 in the list.
	__5.  Notice that now that HPEL is active there are more settings shown for the first HPEL page.
	__6.  In the list of links on the bottom click the 'View HPEL logs and trace' link.
	__7.  In the table that appears, scroll to the far right and click the 'Last Page' button.
	__8.  Scroll back to the left and you will likely see a number of 'INFO' messages from accessing the Admin Console.  You may want to expand the 'Level' column to see it better.  This is because you used the Admin Console after the error from the HitCount application.
	__9.  Click the '+' sign next to the 'Content and Filtering Details' section to expand it.  Notice there is an option to select the time when the server started.  You should only have one since the server was just restarted in HPEL mode.
	__10.  Scroll down to the 'View Contents' section and change the 'Minimum level' setting to 'SEVERE' as shown below.
	__11.  Click the Apply button below the settings to apply the new minimum level setting.
	__12.  Check that in the table below you should see only the longer errors that occurred from the HitCount errors.  The content in the “Message” column is quite large because of the Java exception stack trace.
	__13.  Click on the timestamp of one of these longer messages.  It should turn blue and stay blue after the mouse moves off of it.
	__14.  With the log record of interest selected below, click the 'Show Only Selected Threads' button at the top of the table.
	__15.  Notice you are back to showing all kinds of messages but they should all have the same 'Thread ID' property.  This might help you track down related messages being processed by the same JVM thread.
	__16.  If you want you can experiment with some more of the filtering options available in the Admin Console.  There is also filtering by logger name that can be done as well as by event time.  Filtering by event time will likely be the most useful to see other messages around the time of an error message.
	__17.  When you are done log out of the Admin Console.

	Part 4 -  Use Command Line HPEL Tools
	__1.  Open a terminal window. 
	__2.  Use the 'cd' command to switch to the <WAS_ROOT>/profiles/AppSrv01/bin directory, using the value you wrote down in the notes at the start of the labs.
	__3.  Stop the WebSphere Application Server by executing the following command from the <WAS_ROOT>/profiles/AppSrv01/bin directory.
	__4.  Restart the server with the './startServer.sh server1' command.
	__5.  Issue the './logViewer.sh' command without any options.  This shows all log records and is clearly not going to be as useful.  We need to figure out how to filter out information that is not interesting.
	__6.  In the terminal window, issue the following command and look at some of the options for the 'logViewer' command line tool.
	__7.  Since we are often looking for error messages, probably the most useful option will be '-minLevel'.  Issue the following command:
	__8.  Notice that although your numbers may be slightly different, there should be many fewer records processed than before without the option.  
	__9.  Scroll back a little bit and look for the text 'Start Display Current Environment'.  This is shown every time the server is restarted and is always included in the logViewer output so you are aware of this event.  Right before this you should see some of the error messages that were from the HitCount application error.
	__10.  Scroll a little further and find the beginning of one of the error messages from the HitCount application testing.  This should start with a timestamp and other information followed by lots of lines of the Java “stacktrace”.  Note the thread ID of the message which is the value right after the timestamp and ignoring the zeros.  In this case the thread ID is '1c' (one c).  Yours will likely be slightly different.
	__11.  We will use the '-thread' option along with the thread ID of interest.  Issue the following command, substituting your value for the thread ID:
	__12.  Notice that although your numbers may be slightly different, there should be even fewer records processed than before.  This is because you are selecting only messages from that thread with a level of SEVERE or above.
	__13.  Since we have restarted our server there is more than one “instance” in the log records.  What if you wanted to see only messages from one time the server was running? Issue the following command which will show the “instances”:
	__14.  Take the first instance ID listed and use it in the following command:
	__15.  Notice that you should get a number of records between the numbers you have had before.  This is because you are not filtering by a thread ID but you are seeing only errors from the first time the server ran.
	__16.  What about seeing the log records of a currently running server only?  Since this is a common situation there is a '-latestInstance' option available.  Issue the following command:
	__17.  Now you should see messages only from the currently running server session.  It is likely you may not have any errors since we haven't accessed the HitCount application and generated errors since restarting the server.
	__18.  There is also a way to monitor the log repository and print out new records as they appear.  This will obviously be a common feature for seeing messages while troubleshooting.  Issue the following command to start this:
	__19.  Notice that you are not returned to the command prompt.
	__20.  Open a new web browser window or tab.
	__21.  Enter http://was.myhost.com/HitCountWeb in the address bar.  You should see the main page of the HitCount application.
	__22.  Click the link to attempt to access the page that displays the counter.  You will get a 500 “Internal Server Error”.
	__23.  Close the browser used to access the HitCount application.
	__24.  Return to the terminal window that was running the 'logViewer' command and you should see the error messages from the error that just occurred printed out.
	__25.  Hit the <CTRL>-C keys together. This will stop monitoring the log repository.
	__26.  Although it is useful to have such interactive options, reading the messages in the command prompt is not always easy.  Issue the following command, which should all be on a single line even though it wraps below, to output to a file instead of the command prompt:
	__27.  Open a File Browser window and navigate to the <WAS_ROOT>/profiles/AppSrv01/logs directory.
	__28.  Open the 'myLog.txt' file with a text editor.
	__29.  Notice you should have just the error messages from the latest running instance of the server.  This is likely much easier to read and search than viewing in the command prompt.
	__30.  Leave the server running but close out any extra windows or terminal windows.

	Part 5 -  Correct the Problem
	__1.  Open a web browser and enter http://localhost:9060/ibm/console/, the URL for the Admin Console.
	__2.  Login to the Admin Console as 'wasadmin'.
	__3.  In the Admin Console, navigate to Applications → Application Types →  WebSphere enterprise applications.
	__4.  From the list of Enterprise Applications, click on the link for the HitCount application.
	__5.  Under the Enterprise Java Bean Properties section on the right side click the link for EJB JNDI names.
	__6.  In the JNDI Name field, change the value to ‘ejb/Counter’ and press the OK button.  
	__7.  Click the Save link in the messages at the top of the Admin Console.
	__8.  Check the checkbox next to the HitCount application and press the Stop button.
	__9.  Once the application is stopped, check the checkbox next to the HitCount application again and press the Start button.
	__10.  Open a web browser and enter http://was.myhost.com/HitCountWeb in the address bar.  You should see the main page of the application.
	__11.  Click the link on the page to submit a request that will begin counting the number of times you view a page.  The application should be able to correctly count the number of hits.
	__12.  Refresh the page several times to see the count increase.
	__13.  Logout of the Admin Console.
	__14.  Close any extra web browsers, File Browser windows, or terminal windows you may have open.

	Part 6 -  Review

	Lab 6 -  Install Database Application
	Part 1 -  Create Database
	__1.  Open a terminal window. 
	__2.  Use the 'cd' command to navigate to the <LABFILES_DIR>/Database directory.
	__3.  Execute the command 'which db2'.  This will verify you can execute DB2 commands.  If you do not get the response below contact your instructor.
	__4.  Execute the 'chmod +x createDatabase.sh' command to verify the script is executable.
	__5.  Run the script by executing the command './createDatabase.sh'.  You should start to see messages about the script performing database commands.  Wait a few minutes while the script finishes creating and setting up the database.
	__6.  Open the CreateDB.log file from the same directory as the script using a text editor or the 'more' command.  Look for any obvious errors creating the database or importing the data.  In particular be sure there are several tables listed at the end of the log as shown below.

	Part 2 -  Configure JDBC Provider
	__1.  Make sure your WebSphere server is running.  If it is not running start it using one of the methods you are already familiar with.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the Admin Console, navigate to Resources -> JDBC -> JDBC Providers.
	__5.  Use the drop down for the Scope setting at the top of the list to select Cell=<cellname>.  Once the scope of <cellname> is shown press the New button.
	__6.  On the first screen of the New JDBC Provider setup select the following options.  The contents of the last two drop down lists will change once you start selecting the first two options.  Press  the Next button once you have filled in the options as shown below.
	__7.  Fill in the box for DB2UNIVERSAL_JDBC_DRIVER_PATH with a value of <DB2_ROOT>/java and remember to substitute the value of <DB2_ROOT> from the Directory Paths section at the beginning of the labs.  The final value should be something like '/opt/ibm/db2/V9.5/java'.  Leave the value of Native library path empty.
	__8.  Press the Next button when your screen appears as below.
	__9.  Press the Finish button to create the JDBC Provider.  You should see the new JDBC Provider in the list.
	__10.  Click the Save link in the messages at the top of the Admin Console.

	Part 3 -  Configure Security Authentication
	__1.  In the Admin Console navigate to Security -> Global Security.
	__2.  On the right side, under the Authentication section, expand Java Authentication and Authorization Service and click the link for J2C Authentication data.
	__3.  Press the New button on the list of entries.
	__4.  In the fields for the new Authentication Data Entry fill in the following properties.  Note that you only supply the password once and there is no “Confirm password” box that will check you enter the same value so be careful typing the password.  Press the OK button when the properties are filled in as below.
	__5.  Verify that the new entry shows up in the list.  Notice that the alias is prefixed with the name of the Node where the Application Server resides.
	__6.  Click the Save link in the messages at the top of the Admin Console.

	Part 4 -  Configure Data Source
	__1.  In the Admin Console, navigate to Resources -> JDBC -> JDBC Providers.
	__2.  Check that you are at the <cellname> scope as in previous sections of this lab.  If you need to switch scope, select the scope using the drop down list.
	__3.  Click the link for the JDBC Provider you configured in a previous section.  This should be DB2 Universal JDBC Driver Provider (XA) if you left the default name from before.
	__4.  On the right, under the Additional Properties section, click the link for Data Sources.  Be sure not to select the 'Data Sources (Version 4)' link.
	__5.  Press the New button above the list of Data Sources.
	__6.  On the first page of the Data Source configuration fill in or change the following values.
	__7.  Press the Next button once your values are filled in as below.
	__8.  On the second configuration page fill in the following values:
	__9.  Press the Next button once your values are filled in as below (with your hostname).
	__10.  On the security aliases step select the following choices and press the Next button.
	__11.  Press the Finish button to create the Data Source.  You should see the new Data source in the list.
	__12.  Click the Save link in the messages at the top of the Admin Console.
	__13.  In the list of Data Sources, check the box next to the Online Store DB Data Source and press the Test Connection button.
	__14.  Check that you get a message about a successful test.  You may get a warning but be sure you do not see red errors.  If you do not get a successful test, check the values of the database name of the Data Source, the value of the environment variable, and the user ID and password for the authentication alias as these are the most common errors.  You can use the troubleshooting techniques from the last lab to track down the problem or contact your instructor.
	__15.  Click the Logout link to logout of the Admin Console and close the browser.
	__16.  Use a method you are familiar with to stop the Application Server.
	__17.  Once the Application Server is stopped start it again.

	Part 5 -  Install OnlineStore Database Application
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the Applications group in the navigation, click the link for New Application.
	__4.  Click the link for New Enterprise Application.
	__5.  Next to the Local file system box, press the Browse button.
	__6.  Find the file <LABFILES_DIR>/Database/OnlineStore-Database.ear and select Open in the file chooser dialog.  Remember to substitute the value of the <LABFILES_DIR> variable from the notes at the beginning of the labs.
	__7.  Press the Next button.
	__8.  Check the option for Detailed installation.  This will show all steps.
	__9.  Once you have the options specified as below, press the Next button.
	__10.  On Step 1: Select installation options leave the default options and press the Next button.
	__11.  On Step 2: Map modules to servers check the checkbox next to the OnlineStoreWeb module.  Select both servers from the list above by holding down the CTRL key as you select each one.  Press the Apply button to apply the changes to the mapping of the web module.  Make sure the OnlineStoreWeb module is mapped to BOTH servers as shown below and press the Next button.
	__12.  Click the link for Step 9 on the left to skip to this step.
	__13.  Check that the resource reference mapping for the data source matches the JNDI name you gave the data source in previous sections.  If you are not sure you can use the Browse button to pick the name of the data source from a list.  Once your resource reference mapping is set press the Next button.
	__14.  On Step 10: Map virtual hosts for web modules select myhost from the drop down menu and press the Next button.  This choice will make the application only available by using the was.myhost.com host name on port 80.
	__15.  Click the link for Step 15 on the left to skip to this step.
	__16.  On Step 15: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__17.  Click the Save link in the messages at the bottom of the Admin Console.
	__18.  Go back to the list of web servers by navigating to the Servers → Server Types → Web Servers section of the admin console.
	__19.  Check the box next to the webserver1 entry and click the Stop button.
	__20.  Check the box next to webserver1 and click the Start button.
	__21.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__22.  Check the checkbox next to the OnlineStore application and press the Start button.  Wait for a message that the application started successfully.

	Part 6 -  Test OnlineStore Application
	__1.  Open a Web Browser and enter http://was.myhost.com/Store in the address bar.  You should see the homepage of the application.
	__2.  Click on the Register link to display the page to register as a new Customer.
	__3.  Fill in the fields with some sample data.  The only requirements are that the Email and Full Name fields must be filled in and the Zip must contain only numbers.  Press the Register button. If there is any problem with the database or Data Source setup this is when you will find out.
	__4.  Click the link to Start Shopping.
	__5.  On the Product List, change some of the quantities to be non-zero and press the Add to Cart button.
	__6.  At this point you can either click the link to Add More Items or fill in the required address information and press the Complete purchase button.
	__7.  Test some of the other functions of the application.  Be sure you try to logout and log back in under the ID that you registered.
	__8.  Close the web browser you were using to test the application.
	__9.  Logout of the Admin Console and close the web browser.
	__10.  Close any extra web browsers, File Browser windows, or command prompts you may have open.

	Part 7 -  Review

	Lab 7 -  Enable JMS Messaging Using WebSphere MQ
	Part 1 -  Configure WebSphere MQ
	__1.  Open a terminal window.  
	__2.  Use the 'cd' command to navigate to the <LABFILES_DIR>/Messaging directory.
	__3.  Execute the 'chmod +x createStoreQueue.sh' command to verify the script is executable.
	__4.  Run the script by executing the command './createStoreQueue.sh $PWD'.  You should start to see messages about the script performing WebSphere MQ commands. Wait a few minutes while the script finishes creating and setting up the WebSphere MQ resources.
	__5.  Check that you get messages about the queue creation being successful as shown below.
	__6.  Close the terminal window you were using to configure the queue.  The queue manager will remain running for the rest of the lab.  Anytime you restart the virtual machine you will need to also manually restart the Queue manager.

	Part 2 -  Configure WebSphere MQ JMS Provider
	__1.  Start your Application Server.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the navigation panel, navigate to Environment -> WebSphere Variables.
	__5.  Click on the link for the MQ_INSTALL_ROOT.  You may need to view the second page of variables to see this variable.  Notice that you may not see the underscore characters because it is a link.
	__6.  Change the value of this variable to match the value of the <MQ_ROOT> variable in the Directory Paths section at the beginning of the labs.
	__7.  Once the value is filled in as above press the OK button.
	__8.  Click the Save link in the messages at the top of the Admin Console.
	__9.  In the navigation pane select Resources -> JMS -> Connection factories.
	__10.  Use the drop down for the Scope setting at the top of the list to select Cell=<cellname>.  Once the scope of your cell is shown press the New button.
	__11.  Select the radio button for WebSphere MQ messaging provider and press the OK button.
	__12.  At the Configure basic attributes page, enter the following information.  Write down the JNDI Name of the Connection Factory in the “Lab 7” section of the Lab Notes section.  Press the Next button when done.
	__13.  Leave the default option to enter all connection information in the wizard and press the Next button.
	__14.  Enter 'STOREQM' for the queue manager and press the Next button.
	__15.  Enter your <hostname> in the connection details and press the Next button.
	__16.  Skip the test connection step and press the Next button.
	__17.  Press the Finish button to create the connection factory.
	__18.  Click the Save link in the messages at the top of the Admin Console.
	__19.  Click the link in the navigation pane for Resources -> JMS  -> Queues.
	__20.  Check that you are at the cell scope as in previous sections of this lab.  If you need to switch scope, select the scope using the drop down list.
	__21.  At the Queues list, press the New button.
	__22.  Select the radio button for WebSphere MQ messaging provider and press the OK button.
	__23.  At the New Queue page, enter the following information.  Leave the rest of the settings with the defaults.  Write down the JNDI Name of the Queue in the “Lab 7” section of the Lab Notes section.  Note the screenshots below only show the sections that have settings that are changed.
	__24.  When the values match those above press the OK button.
	__25.  Click the Save link in the messages at the top of the Admin Console.

	Part 3 -  Configure the JMS Activation Specification
	__1.  In the navigation pane select Resources -> JMS -> Activation specifications.
	__2.  Check that you are at the cell scope as in previous sections of this lab.  If you need to switch scope, select the scope using the drop down list.
	__3.  At the JMS Activation Specifications list, press the New button.
	__4.  Select WebSphere MQ messaging provider as the choice for provider and press the OK button.
	__5.  At the Configure basic attributes page, enter the following information.
	__6.  Write down the JNDI name of the Activation Specification in the “Lab 7” section of the Lab Notes and press the Next button.
	__7.  At the Specify MDB destination data page, enter the following information.
	__8.  Check that the Destination JNDI name matches the value you had written down in the Lab Notes section and press the Next button.
	__9.  Leave the default option to enter all connection information in the wizard and press the Next button.
	__10.  Enter 'STOREQM' for the queue manager and press the Next button.
	__11.  Enter your <hostname> in the connection details and press the Next button.
	__12.  Skip the test connection step and press the Next button.
	__13.  Press the Finish button to create the activation specification.
	__14.  Click the Save link in the messages at the top of the Admin Console.
	__15.  Expand the Troubleshooting section in the navigation panel and expand Runtime Messages.
	__16.  Click the link for Runtime Error messages.
	__17.  Check that your settings for runtime events are set to 'Warning' or 'Error'.  If it is not, change the setting to 'Warning', press the Apply button, and save the configuration.
	__18.  Logout of the Admin Console.
	__19.  Restart your Application Server.  Wait several seconds after stopping the server to restart it to allow network connections to reset.

	Part 4 -  Install a Messaging Application
	__1.  Return to the web browser you were using for the Admin Console.  If you closed it, open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  Expand the Troubleshooting section in the navigation panel and expand Runtime Messages.
	__4.  Click the link for Runtime Error messages.
	__5.  Make sure that you do not see any messaging errors that occurred while starting the server.  If you do, contact your instructor so you can resolve these before continuing.
	__6.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__7.  Check the checkbox next to the OnlineStore application and press the Update button.
	__8.  Leave the option of Replace the entire application selected and Local File System radio button.
	__9.  Hit the Browse button next to the Full path text box.
	__10.  Navigate to the <LABFILES_DIR>/Messaging directory, select the OnlineStore‑Messaging.ear file, and press Open.
	__11.  With the path to the EAR file filled in press the Next button.
	__12.  Check the option for Detailed installation.  This will show all steps.
	__13.  Press the Next button.
	__14.  On Step 1: Select Installation options leave the default options and press the Next button.
	__15.  On Step 2: Map modules to servers check to see if the 'OnlineStoreWeb' module is mapped to both servers in the list.  If it is not, check the checkbox next to the OnlineStoreWeb module.  Select both servers from the list above by holding down the CTRL key as you select each one.  Press the Apply button to apply the changes to the mapping of the web module.  
	__16.  Make sure the OnlineStoreWeb module is mapped to BOTH servers as shown below and press the Next button.
	__17.  On the list of steps on the left click the link for Step 6 to skip to this step.
	__18.  On Step 6: Provide listener bindings For message-driven beans use the following options for the PurchasePrinter EJB.  Check the values for these compare with the values you have written down in the Lab Notes section.
	__19.  Once you have checked this value press the Next button.
	__20.  Click the link for Step 10 on the list of steps on the left to skip to this step.
	__21.  On Step 10: Map resource references to resources check that the JNDI name of the Connection Factory listed matches what you had written down for these values in the Lab Notes section.  Also check that the JNDI name of the data source is still 'jdbc/store'.  Note that you will need to scroll around to find these values and the screenshots below only show the part of the screen with the settings.  Also note that the screenshot showing the Connection Factory below does not show the entire JNDI name value.  If you need to change these values for any reason you can use the Browse button to select the configured resource from a list which will eliminate chance for errors due to typos.
	__22.  Once you have checked these values press the Next button.
	__23.  On Step 11: Map resource environment entry references to resources check that the JNDI name of the queue matches what you had written down for these values in the Lab Notes section.
	__24.  Once you have checked these values press the Next button.
	__25.  At this point you will get a warning message.  Everything is fine.  Press the Continue button.
	__26.  On Step 12: Map virtual hosts for web modules select myhost from the drop down menu. This option may already be filled in but double check.
	__27.  On the list of steps on the left click the link for Step 17 to skip to the summary.
	__28.  On Step 17: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__29.  Click the Save link in the messages at the bottom of the Admin Console.
	__30.  Navigate to Applications → Application Types → WebSphere enterprise applications if this list is not automatically displayed.
	__31.  In the list of Enterprise Applications, be sure the OnlineStore application is started, if it is not then start it, if you get an error starting the application, then restart the server following the steps that you know, after restarting, login again and verify the application is started.  If you do need to restart because the application doesn't start, make sure to wait several seconds between stopping and starting the server.

	Part 5 -  Test the Application
	__1.  Make sure you have apache server started.
	__2.  Open a web browser and enter http://was.myhost.com/Store in the address bar.
	__3.  Login as a user that already exists on the system and has placed orders.
	__4.  Once you have logged in, click on the link on the left for Request Email.
	__5.  Once this page is displayed, click on the Request button.  This will generate a message from the Servlet that responds to the request.  You should get a fairly quick reply.  The normal response is shown below.
	__6.  In the Admin Console click on the link for Troubleshooting -> Logs and Trace.
	__7.  Click the link for server1 in the list.
	__8.  In the list of links on the bottom click the 'View HPEL logs and trace' link.
	__9.  Click the '+' sign next to the 'Content and Filtering Details' section to expand it.
	__10.  In the 'View Contents' section of the filter settings, uncheck the setting for 'System err' and 'Logs and trace' as shown below and click the Apply button.
	__11.  Scroll down and look at the last messages in the list.  As shown below there should be a message with the text “In onMessage” followed by a message for each purchase made by the user.
	__12.  Close the web browser you were using to test the application.
	__13.  Logout of the Admin Console and close the web browser.
	__14.  Close all terminal windows.

	Part 6 -  Review

	Lab 8 -  Configure WebSphere Security
	Part 1 -  Backup Configuration
	__1.  Open a terminal window.  
	__2.  Change directories using the 'cd' command to the <WAS_ROOT>/profiles/AppSrv01/bin directory.  Be sure to substitute the value of <WAS_ROOT> from the “Directory Paths” page at the beginning of the lab instructions.
	__3.  Enter the following command to backup the configuration to the file 'BeforeSecurity.zip':
	__4.  Check that you get a message about the configuration being successfully backed up.
	__5.  Leave the terminal window open as you will use it in several sections in the lab.

	Part 2 -  Examine Current Security Settings
	__1.  If the server is not already running, use the command prompt for the profile 'bin' directory used in the previous section to issue the following command to start the server:
	__2.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the Admin Console navigate to Security → Global Security.
	__5.  On the main security page click the button for “Security Configuration Wizard”.
	__6.  In the wizard that appears notice that there are steps for collecting basic security configuration options.  The actual steps are not shown on the left until you make selections on the first step.
	__7.  Click the Cancel button to cancel the wizard.
	__8.  Notice that the option to “Enable administrative security” has already been checked off.
	__9.  Click the button for 'Security Configuration Report'.
	__10.  In the window that appears notice that this is a dump of all the security related settings.  Unfortunately it is difficult to navigate the long list and even to save this as a file but it does show every setting and where you would configure it.
	__11.  Close the window for the security report.
	__12.  In the User account repository section notice that “Federated repositories” is already set as the current setting.  Click the Configure button to view the current settings.
	__13.  Notice that there is already a Primary administrative user name of 'wasadmin' set.  This is why we can currently login to the Admin Console with this ID and perform all administrative tasks.
	__14.  In the navigation section on the left side of the Admin Console navigate to Users and Groups -> Manage Users.
	__15.  Click the Search button if the 'wasadmin' user is not already listed.
	__16.  Click the link for the 'wasadmin' user ID.
	__17.  Notice this is where you could change the password for the current default administrator or set additional properties like name and email.  Click the Cancel button.

	Part 3 -  Configure Admin Console Users
	__1.  In the navigation section on the left side of the Admin Console navigate to Users and Groups -> Manage Users.
	__2.  Click the Create button and fill in the following user information:
	__3.  When the options are filled in as above click the Create button to create the user.
	__4.  On the confirmation screen click the Create Like button to create another similar user with the following information:
	__5.  Click the Create button to create the second new user.
	__6.  On the confirmation screen click the Create Like button to create another similar user with the following information:
	__7.  Click the Create button to create the third new user.
	__8.  Click the Close button to return to the list of users.
	__9.  Check that your list of users appears as below.
	__10.  In the navigation section on the left side of the Admin Console navigate to Users and Groups → Administrative User Roles.
	__11.  Click the Add button to add a new administrative user role.
	__12.  Select the 'Operator' role from the list above.  You may have to scroll down to see it.
	__13.  Press the Search button to show all current users.
	__14.  Select the 'wasoperator' user from the list on the left and press the right arrow button to add it to the list on the right.
	__15.  Click the OK button to add the user once your settings match those below.
	__16.  Check that the user shows up in the list of users and is an “Operator”.  
	__17.  In the navigation section on the left side of the Admin Console navigate to Users and Groups -> Administrative Group Roles.
	__18.  Click the Add button to add a new administrative group role.
	__19.  Fill in the following properties:
	__20.  Press the OK button when the options are as shown above.
	__21.  Make sure the administrative group role shows up in the list.
	__22.  Click the Save link in the messages at the top of the Admin Console.
	__23.  Click the link to Logout of the Admin Console.

	Part 4 -  Test Administrative Roles
	__1.  On the login page of the Admin Console login using the user and password of 'wasoperator'.
	__2.  In the navigation section on the left side of the Admin Console navigate to Applications → Application Types → WebSphere enterprise applications.
	__3.  In the list of applications notice that you can stop and start applications but you can't install or uninstall applications.  These abilities are restricted to Administrators, Configurators, and Deployers.
	__4.  Click the link to Logout of the Admin Console.
	__5.  On the login page of the Admin Console login using the user and password of 'wasmonitor'.
	__6.  In the navigation section on the left side of the Admin Console navigate to Applications → Application Types → WebSphere enterprise applications.
	__7.  In the list of applications notice that you do not even have the ability to start or stop applications.  This is because the “Monitor” role has the fewest privileges.
	__8.  Click a link for one of the applications and notice that you can browse the settings but will not be able to change anything.  The text boxes and checkboxes for the settings are often “grayed out” or there is no “Apply” or “OK” button to be able to submit any changes.
	__9.  Once you have experimented to familiarize yourself with the various options that are disabled for non-Administrator roles click the Logout link in the Admin Console.

	Part 5 -  Configure Fine-grained Security
	__1.  On the login page of the Admin Console login using the user and password of 'wasadmin'.
	__2.  In the Admin Console navigate to Security -> Administrative Authorization Groups.
	__3.  Press the New button.
	__4.  Fill in a name of 'StoreSecurity'.
	__5.  Expand the 'Applications' group to check the 'OnlineStore' application.
	__6.  Expand the 'Nodes → <nodename> → Servers' group to check 'server1' as shown below.
	__7.  Press the OK button once your settings are as shown above.
	__8.  Back on the list of Administrative Authorization Groups, click on StoreSecurity.
	__9.  Under 'Additional Properties' click the link for 'Administrative user roles'.
	__10.  Click the Add button to add a new administrative user role.
	__11.  Select the 'Administrator' role from the list above.  
	__12.  Press the Search button to show all current users.
	__13.  Select the 'storeadmin' user from the list on the left and press the right arrow button to add it to the list on the right.
	__14.  Click the OK button to add the user once your settings match those below.
	__15.  Check that the user shows up in the list of users and is an “Administrator”.  
	__16.  Click the Save link in the messages at the top of the Admin Console.
	__17.  Click the link to Logout of the Admin Console.
	__18.  On the login page of the Admin Console login using the user and password of 'storeadmin'.
	__19.  In the navigation section on the left side of the Admin Console navigate to Applications → Application Types → WebSphere enterprise applications.
	__20.  Notice that the list of applications is different and indicates what level of administrative access this user has for the different applications.  Notice that if you check the checkbox next to any application besides 'OnlineStore' most of the buttons are disabled.
	__21.  In the navigation section on the left side of the Admin Console navigate to Resources → JDBC → Data sources.
	__22.  Note that you can display the settings of the 'Online Store DB' data source but you can't modify the settings.  You could modify the settings of the 'Default Datasource' because it is at server scope which is part of the 'Administrative Authorization Group' of resources this user has Administrator privileges for.  You could also create a new data source at server scope if we needed to. You may see a different number of data sources but you should still see that you have different authority for the different data sources.
	__23.  Once you have experimented to familiarize yourself with the various options that are available using the fine-grained security click the Logout link in the Admin Console.

	Part 6 -  Review

	Lab 9 -  Configure Java EE Security
	Part 1 -  Examine Current Behavior
	__1.  Be sure your Application Server is running.  Start it if it is not running.
	__2.  Open a Web Browser and enter http://was.myhost.com/Store in the address bar.  If you get any errors try restarting the web server.
	__3.  Click on the Find Purchases link on the left of the application homepage.
	__4.  In the form that appears fill in a Userid that you are sure has completed purchases and press the Find button.  If you have not completed any shopping cart purchases do that first.
	__5.  A screen is shown with a summary of all of the completed purchases for that user.  Click on the Details button for one of the purchases.
	__6.  Another screen shows the details of the purchase.
	__7.  Close the browser you were using to test the application.

	Part 2 -  Configure Security Domain
	__1.  On the login page of the Admin Console login using the user and password of 'wasadmin'.
	__2.  In the Admin Console navigate to Security → Security domains.
	__3.  Click the 'Copy Global Security' button.
	__4.  Change the name of the domain to 'StoreDomain' and click the Apply button.
	__5.  On the page showing the properties of the new security domain, expand the tree under the 'Assigned Scopes' section so you can see the 'server1' server as shown below.  Check the box for the 'server1' server but do not yet move away from this page.
	__6.  In the 'Security Attributes' section, expand the 'Application Security' setting and check the box for 'Enable application security' but do not yet move away from this page.
	__7.  Also in the 'Security Attributes' section, expand the 'Java 2 Security' setting and check the following boxes but do not yet move away from this page.
	__8.  With the various settings in the last several steps modified, scroll down and click the Apply button for the page.  This will apply all of the changes on this page.
	__9.  Click the Save link in the messages at the top of the Admin Console.
	__10.  In the list of security domains, click the link for 'StoreDomain'.
	__11.  In the 'Security Attributes' section, expand the 'User Realm' setting and click the Configure button.  Notice that federated repositories is already configured since the global settings were copied for this domain.
	__12.  Change the Realm name to 'StoreRealm' and check the box for 'Use global schema for model'.
	__13.  Hit the Apply button after making these changes.
	__14.  Near the bottom of the page, click the link for Manage repositories.
	__15.  Click the Add button from above the list of repositories and select 'File repository' from the drop down list.
	__16.  Change the following properties of the new file repository and click the OK button.
	__17.  In the breadcrumb trail, click the link for 'Federated repositories'.
	__18.  Above the list of repositories, click the 'Add repositories' button.
	__19.  Make sure that the 'StoreRegistry' repository is listed in the drop-down and fill in a value of 'o=StoreFileBasedRealm' in the 'Unique distinguished name ...' property and click the OK button.
	__20.  Back in the list of repositories, check the box next to the 'InternalFileRepository' and click the Remove button.
	__21.  Near the bottom of the page, click the link for Supported entity types.
	__22.  Click on the entry for 'Group' in the list.
	__23.  Change the 'Base entry for the default parent' to 'o=StoreFileBasedRealm' and click the OK button.
	__24.  Make the same change to the 'OrgContainer' and 'PersonAccount' entity types so your table appears as below.
	__25.  Click the Save link in the messages at the top of the Admin Console.
	__26.  Logout of the Admin Console and close the browser.

	Part 3 -  Restart Application Server
	__1.  Return to the terminal window you used to start the server.  If you do not have one open, open a terminal window and change to the <WAS_ROOT>/profiles/AppSrv01/bin folder.
	__2.  Issue the command to stop the server and supply username and password options, './stopServer.sh server1 -username wasadmin -password wasadmin'.
	__3.  Wait several seconds after the server has stopped, then issue the command to start the server, './startServer.sh server1'.

	Part 4 -  Create Users for Secure Access
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the Admin Console navigate to Security → Security domains.
	__4.  In the list of security domains, click the link for 'StoreDomain'.
	__5.  In the 'Security Attributes' section, expand the 'User Realm' setting and click the Manage Users link.
	__6.  Click the Create button and fill in the following user information:
	__7.  When the options are filled in as above click the Create button to create the user.
	__8.  On the confirmation screen click the Create Like button to create another similar user with the following information:
	__9.  Click the Create button to create the second new user.
	__10.  On the confirmation screen click the Create Like button to create another similar user with the following information:
	__11.  Click the Create button to create the third new user.
	__12.  Click the Close button to return to the list of users.
	__13.  Check that your list of users appears as below.  The first and last names can be anything.
	__14.  In the breadcrumb trail at the top, click the link for StoreDomain.
	__15.  In the 'Security Attributes' section, expand the 'User Realm' setting and click the Manage Groups link.
	__16.  Click the Create button and fill in the following group information:
	__17.  Click the Create button to create the group.
	__18.  Click the Close button to return to the list of groups.
	__19.  Click on the link for the new 'OnlineCSRs' group in the list of groups.
	__20.  Click the Members tab along the top of the group information.
	__21.  Click on the Add Users... button.
	__22.  Click on the Search button to list users.
	__23.  Hold the Ctrl button while you click the 'bob' and 'susan' users but don't select the 'tony' user.
	__24.  Once both users are selected press the Add button.
	__25.  Click the Close button.
	__26.  Be sure that both users are listed as members of the group.

	Part 5 -  Install Secure Version of OnlineStore
	__1.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__2.  Check the checkbox next to the OnlineStore application and press the Update button.
	__3.  Leave the option of Replace the entire application selected and Local File System radio button.
	__4.  Hit the Browse button next to the Full path text box.
	__5.  Navigate to the <LABFILES_DIR>/Security directory, select the OnlineStore‑Security.ear file, and press Open.
	__6.  Press the Next button when you have indicated the new EAR to use.
	__7.  Leave the default option of a “Fast Path” installation selected as shown below and press the Next button.
	__8.  On Step 1: Select Installation options leave the default options and press the Next button.
	__9.  On Step 2: Map modules to servers the appropriate mappings should already be filled in. Make sure the OnlineStoreWeb module is mapped to BOTH servers as shown below.  If it is not for some reason, check the checkbox next to the OnlineStoreWeb module.  Select both servers from the list above by holding down the CTRL key as you select each one.  Press the Apply button to apply the changes to the mapping of the web module.  
	__10.  Press the Next button once you have checked the module mapping.
	__11.  On Step 3: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__12.  Click the Save link in the messages at the bottom of the Admin Console.
	__13.  You should be returned to the list of applications.  If you are not navigate to Applications → Application Types → WebSphere enterprise applications.
	__14.  Click the link for the OnlineStore application.
	__15.  Under the Detail Properties section click the link for Security role to user/group mapping
	__16.  Check the checkbox next to the CSR role and click the Map Groups button.
	__17.  Make sure that 'StoreRealm' is listed as the user realm and press the Search button to list available groups.
	__18.  Select the OnlineCSRs group and press the right arrow button to move the group over to the “Selected” list on the right.
	__19.  Press the OK button on the group search page to accept the group.
	__20.  Check that the group is listed on the row with the CSR role and press the OK button.
	__21.  In the list of application properties click the link for User RunAs roles.
	__22.  Note that there are components in the application that are set to “run as” a specific security role.  In this application that is the message-driven EJB which must also access the functions that are being secured.
	__23.  Click the Cancel button to avoid making changes to this setting.
	__24.  Click the Save link in the messages at the top of the Admin Console.
	__25.  In the navigation section of the console expand the Servers → Server Types section and click the link for Web servers.
	__26.  Check the checkbox next to webserver1 and click the Generate Plug-in button.
	__27.  Check the checkbox next to webserver1 and click the Propagate Plug-in button.
	__28.  Check the checkbox next to webserver1 and click the Stop button.
	__29.  Check the checkbox next to webserver1 and click the Start button.
	__30.  Logout of the Admin Console.
	__31.  Close all web browsers you are using.

	Part 6 -  Test the Secure OnlineStore Application
	__1.  Open a Web Browser and enter http://was.myhost.com/Store in the address bar.
	__2.  Click on the Find Purchases link on the left of the application homepage.
	__3.  In the form that appears fill in a Userid that you are sure has completed purchases and press the Find button.
	__4.  You will be immediately prompted with a dialog that asks you for User name and password information.  Fill in 'hacker' as both of these values and press the OK button.
	__5.  You will be presented with the same dialog again because this user is not in the user registry.  Fill in a User name and password of 'susan' or 'bob' and press the OK button.  You should be shown the list of purchases as before since this user was assigned to the security role for the application.
	__6.  Note the URL of the request that you were prompted for security information for.  This should be was.myhost.com/Store/FindPurchases.
	__7.  Click the Details button next to one of the purchases.
	__8.  Note the URL of this page as well.  This should be was.myhost.com/Store/PurchaseDetails.
	__9.  Close the web browser you were using to test the application.  Make sure all web browser windows are closed.
	__10.  Open a new Web Browser and enter http://was.myhost.com/Store in the address bar.
	__11.  Click on the Find Purchases link on the left of the application homepage.
	__12.  In the form that appears fill in a Userid that you are sure has purchases and press the Find button.
	__13.  When prompted for the User name and password fill in 'tony' for both values and press the OK button.
	__14.  You will be presented with a page that indicates you are not authorized to view this page. This is because even though the 'wasadmin' user has the right to access the WebSphere Admin Console it was not granted access to the security role for the OnlineStore application.
	__15.  Close the web browser you were using to test the application.
	__16.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__17.  Login as the 'wasadmin' user.
	__18.  In the Admin Console navigate to Security → Security domains.
	__19.  In the list of security domains, click the link for 'StoreDomain'.
	__20.  In the 'Security Attributes' section, expand the 'User Realm' setting and click the Manage Users link.
	__21.  Click the Create button and fill in the following user information:
	__22.  When the options are filled in as above click the Group Membership button.
	__23.  Click the Search button to search for groups.
	__24.  Select the OnlineCSRs group on the right and click the < Add button to move it to the left.
	__25.  Press the Close button to close the group membership dialog.
	__26.  Press the Create button to create the user.
	__27.  Logout of the Admin Console and close the web browser.
	__28.  Open a new Web Browser and enter http://was.myhost.com/Store in the address bar.
	__29.  Click on the Find Purchases link on the left of the application homepage.
	__30.  In the form that appears fill in a Userid that you are sure has purchases and press the Find button.
	__31.  When prompted for the User name and password fill in 'newCSR' for both values and press the OK button.
	__32.  You should see the page showing the list of orders placed by the user you filled in the form for.  This proves you can allow new users to access the secure functions simply by adding them to the group defined in the user registry.
	__33.  Close the web browser you were using to test the application.

	Part 7 -  Disable Application Security
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the Admin Console navigate to Security → Security domains.
	__4.  In the list of security domains, click the link for 'StoreDomain'.
	__5.  In the 'Security Attributes' section, expand the 'Application Security' setting and uncheck the box for 'Enable application security' but do not yet move away from this page.
	__6.  Also in the 'Security Attributes' section, expand the 'Java 2 Security' setting and uncheck the 'Use Java 2 security to restrict application access to local resources' box but do not yet move away from this page.
	__7.  With the various settings in the last several steps modified, scroll down and click the Apply button for the page.  This will apply all of the changes on this page.
	__8.  Click the Save link in the messages at the top of the Admin Console.
	__9.  Logout of the Admin Console.
	__10.  Restart your Application Server using any method you are familiar with.  Remember to wait several seconds between stopping the server and restarting it.
	__11.  Close any extra web browsers, Windows Explorer windows, or command prompts you may have open.

	Part 8 -  Examine Security Policies (Optional)
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__4.  Click the link for the OnlineStore application.
	__5.  On the right of the application properties, click the Manage Modules link.
	__6.  Click the link for the OnlineStoreWeb module.
	__7.  Click the View Deployment Descriptor link.
	__8.  Scroll down until you see the 'security-constraint' tag.
	__9.  Notice within this tag the two major entries of 'web-resource-collection' and 'auth‑constraint'.  The 'web-resource-collection' indicates that the two URLs we have seen are secure and the 'auth‑constraint' associates these URLs with the CSR security role.
	__10.  Notice that the CSR security role is also defined in a separate tag of the deployment descriptor after the end of the 'security-constraint' tag.
	__11.  In the “breadcrumbs” at the top of the page click the Manage Modules link to return to the list of modules.
	__12.  Click the link for the OnlineStoreEJB module.
	__13.  Click the View Deployment Descriptor link.
	__14.  Scroll down until you see the 'assembly-descriptor' tag.
	__15.  Note that inside this tag there is also a definition of the CSR security role.
	__16.  Also notice that there are two 'method-permission' tags.  These indicate that the two methods listed here are granted access only to the CSR role.
	__17.  Look a little further up at the definition of the “PurchasePrinterBean” message-driven EJB.  Notice that it is configured with the 'run-as' configuration and linked to the CSR security role.  Without this setting the message-driven EJB would fail when it attempted to access the secure EJB method to find all the purchases for the user which sent the message.
	__18.  Logout of the Admin Console and close the web browser.

	Part 9 -  Review

	Lab 10 -  Web Services
	Part 1 -  Update OnlineStore with Web Service
	__1.  Be sure your Application Server is running.  Start it if it is not running.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__3.  Login as the 'wasadmin' user. 
	__4.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__5.  Check the checkbox next to the OnlineStore application and press the Update button.
	__6.  Leave the option of Replace the entire application selected and Local File System radio button.
	__7.  Hit the Browse button next to the Full path text box.
	__8.  Navigate to the <LABFILES_DIR>/WebServices directory, select the OnlineStore‑WebService.ear file, and press Open.
	__9.  With the path to the EAR file filled in press the Next button. 
	__10.  Leave the default option of a “Fast Path” installation selected as shown below and press the Next button.
	__11.  On Step 1: Select Installation options leave the default options and press the Next button.
	__12.  On Step 2: Map modules to servers check both the checkboxes next to the OnlineStoreWeb and OnlineStore-HTTPRouter modules.  Select both servers from the list above by holding down the CTRL key as you select each one.  Press the Apply button to apply the changes to the mapping of the web modules.  Make sure BOTH the modules are mapped to BOTH servers as shown below and press the Next button.
	__13.  On Step 3: Map virtual hosts for web modules select myhost from the drop down menu next to both web modules and press the Next button.  This choice will make the application only available by using the was.myhost.com host name on port 80.  This means the web service will also be available only on this address.
	__14.  On Step 4: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__15.  Click the Save link in the messages at the bottom of the Admin Console.

	Part 2 -  Update Web Service HTTP Endpoint
	__1.  If you are not currently viewing the list of enterprise applications, navigate to Applications → Application Types → WebSphere enterprise applications.
	__2.  Click the link for the OnlineStore application.
	__3.  Scroll down and in the list of 'Web Services Properties' on the right click the link for Provide HTTP endpoint URL information.
	__4.  Note that because we mapped the “router” module to a virtual host which has only one alias and that alias is not the default hostname and port of the WebSphere server we do not have any “default” HTTP prefixes available.
	__5.  Delete any current values like '://:' inside the HTTP URL prefix field. 
	__6.  Fill in 'http://was.myhost.com' without the quotes for the HTTP URL prefix value next to the module listed and press the OK button.  Note that you can just type the value in directly and you do not need to use the options and Apply button above the settings.
	__7.  Click the Save link in the messages at the top of the Admin Console.
	__8.  Back in the list of applications click the link for the OnlineStore application.
	__9.  Scroll down and in the list of 'Web Services Properties' on the right click the link for Publish WSDL files.
	__10.  On the page that appears click the link for the zip file of WSDL files.
	__11.  If prompted to open or save the file, open it with zip file software if possible.  If you can't open it directly save it first and then open the zip file.
	__12.  Expand the folders of the zip file if needed until you see the 'StoreFacadeService.wsdl' file.
	__13.  Open the 'StoreFacadeService.wsdl' file with a text editor like gedit.  You may need to extract the file first and then open it.
	__14.  Scroll down in the WSDL file and notice at the end that the SOAP address uses a location that starts with 'http://was.myhost.com'.  If we did not set the endpoint URL information for the service the WSDL package to publish would not be useable.
	__15.  Close the WSDL and the zip file.
	__16.  Back in the Admin Console return to the list of enterprise applications by navigating to Applications → Application Types → WebSphere enterprise applications.
	__17.  Check the checkbox next to the OnlineStore application and press the Stop button.  
	__18.  Check the checkbox next to the OnlineStore application and press the Start button. Wait for a message that the application started successfully.
	__19.  Open a Web Browser and enter http://was.myhost.com/Store in the address bar. You should see the homepage of the application.
	__20.  Login as a registered user.
	__21.  Close the web browser.

	Part 3 -  Install Web Service Client
	__1.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__2.  Click the Install button to start the installation process.
	__3.  Next to the Local file system box, press the Browse button.
	__4.  Navigate to the <LABFILES_DIR>/WebService directory, select the OnlineStoreServiceClient.ear file, and press Open.
	__5.  Press the Next button when you have indicated the new EAR to use.
	__6.  Select the option of a “Detailed” installation as shown below and press the Next button.
	__7.  On Step 1: Select Installation options leave the default options and press the Next button.
	__8.  On Step 2: Map modules to servers check the checkbox next to the OnlineStoreServiceClientWeb module.  Select both servers from the list above by holding down the CTRL key as you select each one.  Press the Apply button to apply the changes to the mapping of the web module.  Make sure the module is mapped to BOTH servers as shown below and press the Next button.
	__9.  Click the link for Step 6 to skip to this step.
	__10.  On Step 6: Map virtual hosts for web modules select myhost from the drop down menu next to the web module and press the Next button.  This choice will make the application only available by using the was.myhost.com host name on port 80.  
	__11.  Click the link for Step 11 to skip to this step.
	__12.  On Step 11: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__13.  Click the Save link in the messages at the bottom of the Admin Console.
	__14.  Check the checkbox next to the OnlineStoreServiceClient application and press the Start button.  Wait for a message that the application started successfully.
	__15.  Open a new Web Browser and enter http://was.myhost.com/ServiceClient in the address bar. You should see the homepage of the application.
	__16.  Click the link to 'View Partner Products'.  After several seconds you will get an error that will be explained and fixed in the next section.
	__17.  Close the browser you were using to test the web service client application.

	Part 4 -  Fix Web Service Client
	__1.  Back in the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__2.  Click the link for the OnlineStoreServiceClient application.
	__3.  Scroll down and in the list of 'Web Services Properties' on the right click the link for Service clients.
	__4.  Click the 1st link for the Module on the right.  If you click the service name on the left it will take you to web service policies which are not being used for this web service.
	__5.  In the list of module 'Web Services Properties' on the right click the link for Web services client bindings.
	__6.  In the list you will see two entries for “services” that have the same name.  This is because the code generated by the development tool contains a reference to the service as well as the Servlet used to display the page you saw before.  We will update settings for both.
	__7.  Click the first 'Edit' link in the 'Port Information' column on the far right.  Make sure you do not click the link in the 'mappings' column.
	__8.  As you can see from the address listed this is why the client did not work.  It was using the default location that was part of the WSDL generated by the development environment which is not the URL the web service is available on now.
	__9.  Change the hostname of the URL so the entire URL is 'http://was.myhost.com/StoreRouter/StoreFacadeService' without the quotes.  Once your value is set as shown below press the OK button.  Note the screenshot below does not show the end of the URL but the hostname portion is the only thing you need to update.
	__10.  Click the second 'Edit' link in the 'Port Information' column.  Make sure you do not click the link in the 'mappings' column.
	__11.  Notice that the URL of the service reference has already been modified with the new hostname.  This is because both of the service references use the same name of 'StoreFacadeService'.  If the references used different names you would need to change both.
	__12.  Click the Save link in the messages at the top of the Admin Console.
	__13.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__14.  Check the checkbox next to the OnlineStoreServiceClient application and press the Stop button.  
	__15.  Check the checkbox next to the OnlineStoreServiceClient application and press the Start button. Wait for a message that the application started successfully.
	__16.  Open a new Web Browser and enter http://was.myhost.com/ServiceClient in the address bar. 
	__17.  Click the link to 'View Partner Products'.  After several seconds you will get the normal response which is a table with the list of products.
	__18.  Close the browser you were using to test the web service client application.
	__19.  Open a Windows Explorer window and navigate to the <IHS_ROOT>/logs directory.
	__20.  Open the 'was.myhost.com-access_log' file with a text editor.
	__21.  Scroll to the bottom of the file and notice that in addition to calls to the '/ServiceClient/...' application which is the web application of the web service client, there is a call to '/StoreRouter/StoreFacadeService'.  This is the web service implementation and this proves that the web service request from the web service client is being routed through the web server.
	__22.  Close the log file.
	__23.  Logout of the Admin Console and close any extra web browsers or command prompts.

	Part 5 -  Review

	Lab 11 -  Monitor Performance
	Part 1 -  Create a Simple Stress Test
	__1.  Check that your Application Server is running and start it if it is not running.
	__2.  Open a web browser to http://was.myhost.com/Store and check that the various functions of the application are working properly.  Also make sure you know an existing user for the system as you will use this user when recording the stress test.
	__3.  Close the web browser you used to check the application.  Make sure you do not have any other open browsers (including any used with the Admin Console or web email access) as this may interfere with recording the test.
	__4.  Open a terminal window.  
	__5.  Use the 'cd' command to switch to the <JMETER_ROOT>/bin directory.  Substitute the value of the <JMETER_ROOT> variable from the directory paths listed at the beginning of the labs.
	__6.  Issue the following command to start JMeter.  Wait for a minute for it to start completely.
	__7.  Leave the terminal window open for the rest of the lab so JMeter continues to run.
	__8.  You might want to maximize the JMeter window so fields in some screens are larger.
	__9.  In the left column, right click on “Test Plan” and select 'Add -> Thread Group'. A thread group allows us to enter the number of threads that will actively send HTTP requests.
	__10.  Right click on the new Thread Group and select 'Add -> Config Element -> HTTP Request Defaults'. 
	__11.  Set the Server Name or IP field to was.myhost.com
	__12.  Right click on Thread Group and select 'Add -> Config Element -> HTTP Cookie Manager'.  This will collect cookies that are sent back with the responses.
	__13.  Select the HTTP Cookie Manager on the left and change the Cookie policy to default on the right.  Also, check the box for 'Clear cookies each iteration'. This will make sure the session cookie for our login is saved but make sure a new one is used every time the test iterates.
	__14.  In the left column, right click on “Workbench” and select 'Add -> Non-test Elements -> HTTP Proxy Server'.
	__15.  With the new 'HTTP Proxy Server' element on the left selected click on the Start button at the bottom of the screen on the right.  You may need to scroll down to see the button.
	__16.  Check that the elements on the left appear as shown below.  If they do not, double check the previous steps.
	__17.  Select 'File -> Save Test Plan as' from the menus.
	__18.  Navigate to the <LABFILES_DIR> directory and save with a filename of 'OnlineStoreTest.jmx'.
	__19.  Open a Firefox web browser window.
	__20.  Select 'Edit -> Preferences' from the menus.
	__21.  Select the “Advanced” group along the top and the "Network" tab below.
	__22.  Click the button for “Settings”.
	__23.  Select the option for “Manual proxy configuration”, change the proxy to use 'localhost', port '8080', and check the box to “Use this proxy server for all protocols”.
	__24.  Check that the settings appear as above and press the 'OK' button.
	__25.  Click the 'Close' button to close the browser preferences.
	__26.  Enter 'http://was.myhost.com/Store' in the address bar of the browser.
	__27.  Perform the following functions in the application:
	__28.  Return to the JMeter window.
	__29.  With the 'HTTP Proxy Server' element on the left selected click on the Stop button at the bottom of the screen on the right.  You may need to scroll down to see the button.
	__30.  On the left side check that all entries under the Thread Group start with '/Store'.  If any do not look like they should be present simply right click and select 'Remove'.
	__31.  Select 'File -> Save' from the menus to save your test plan.

	Part 2 -  Validate Test Script
	__1.  On the left side select the Thread Group by clicking on it.
	__2.  Check the settings on the right side to be sure the test will run only one “thread” and the test will loop only once.  This will verify the script.
	__3.  On the left side, right click on Thread Group and select 'Add -> Listener -> View Results Tree'.
	__4.  On the left side, right click on Thread Group and select 'Add -> Listener -> Summary Report'.
	__5.  From the menus select 'Run -> Start'.
	__6.  On the left side, select the 'View Results Tree' if it is not already.
	__7.  Check that all responses have a green check icon.
	__8.  Select one of the responses on the left of the results list.
	__9.  On the right, click the tab for “Response data”.
	__10.  Along the bottom of the right side select the option for “Render HTML”.
	__11.  Select each entry from the list and verify the response appears about as you would expect. The page will appear different because the embedded images are not displayed but the major elements of the pages should be present.
	__12.  On the left side select the 'Summary Report'.
	__13.  Check the various statistics.  In particular check that the 'Error %' is zero for all requests.
	__14.  From the JMeter menus select 'Run -> Clear All'.
	__15.  Select File → Save to save your test plan with the report elements.
	__16.  Leave JMeter open for the next sections.

	Part 3 -  Fix Firefox Proxy
	__1.  Open a Firefox web browser.
	__2.  Select 'Edit -> Preferences' from the menus.
	__3.  Select the “Advanced” group along the top and the "Network" tab below.
	__4.  Click the button for “Settings”.
	__5.  Select the option for “No proxy".
	__6.  Once the settings are restored click any OK or Close buttons to close out open dialogs.
	__7.  Access the Online Store application to check that the settings are restored.

	Part 4 -  Check Performance Monitoring Service
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  Expand the Monitoring and Tuning section and click the link for Performance Monitoring Infrastructure (PMI).
	__4.  Click the link for server1 on the right to show the PMI settings for the server.
	__5.  On the settings notice the PMI service is already enabled.  It is also set to collect “Basic” information.  You can click the '+' sign under the Basic setting to see exactly what counters that will include.
	__6.  At the top notice there are Runtime and Configuration tabs.  The settings in the Configuration tab will be saved and used as the defaults when the server starts up.  The Runtime tab can be used to temporarily change the performance data being collected to run a specific performance test or examine the performance of specific components in more detail.
	__7.  Logout of the Admin Console.
	__8.  Close all open web browsers.

	Part 5 -  Measure Performance Data
	__1.  Restart the Application Server using the method you are most familiar with.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the left hand pane, expand Monitoring and Tuning -> Performance Viewer.
	__5.  Click on the link for Current Activity.
	__6.  Check the checkbox next to server1 and press the Start Monitoring button.
	__7.  Check that server1 shows that it is being monitored.
	__8.  Click the link for server1 in the list.
	__9.  Expand the server1 -> Settings section and click User to change user options.
	__10.  On the right side, change the Refresh Rate setting to 5 seconds and press the Apply button.
	__11.  Back on the left side expand the server1 -> Performance Modules section.
	__12.  Check the checkbox next to the following modules to enable data from that module:
	__13.  Still under the list of performance modules, expand 'Web Applications → OnlineStore#SampleApps‑EE6‑OnlineStoreWeb‑WebSphere.war' and check the Servlets box.  This will enable collecting data only for the OnlineStore web application.  Be careful which is selected as others are for the web service applications.
	__14.  Click the View Modules button at the top of the list on the left to view the data.
	__15.  On the right side you should see a graph displaying various data points.  If you do not see the graph but were not prompted to download the viewer your proxy settings may not be restored to the previous settings.
	__16.  Take some time to adjust the layout of the performance viewer with the tips above.
	__17.  Under the graph of data press the Clear Buffer button and then the Reset To Zero button.
	__18.  Launch JMeter if it is not already running.  Switch to the window if it is running already.
	__19.  On the left side select the Thread Group by clicking on it.
	__20.  Change the settings on the right side so the test will loop 50 times.
	__21.  From the menus select 'Run -> Start'.
	__22.  While the test is running switch back to the Admin Console and the performance viewer. You should see the values of the counters changing.
	__23.  Find out which line in the graph represents the “Service Time” metric.  If you want to see what a particular line represents you will need to associate the colors and icons from the table below with the lines in the graph.  You could also disable certain counters if you are not interested in them.
	__24.  You can also look at the table on the bottom to see exactly what the current value is of any counter.
	__25.  Go back to JMeter and select the 'Summary Report' from the test elements and look for the line for the '/Store/Login' request.  This should have the highest maximum time because this is the first time the database was used and the database connection needed to be initialized.
	__26.  Wait for the test to complete before going to the next section.  The test is likely already finished but there is a rectangle in the upper right of the JMeter tool that will be green if the test is still running.

	Part 6 -  View Summary Reports
	__1.  Switch back to the browser running the Admin Console and performance viewer.
	__2.  Expand the server1 -> Summary Reports section on the left of the viewer and click Servlets to view the servlet summary report.
	__3.  Make sure you can see all of the scrollbars along the bottom of the viewer.  Scroll down in the outer Admin Console page if you can't.
	__4.  Scroll back and forth to examine the data in the summary report.  Especially look at Total Requests and  Avg Resp Time.
	__5.  Click on the arrows in the Total Requests column to sort the column.
	__6.  Make sure that you see at the top of the list the resources with the most requests.  You may need to click the sort arrows again to sort in descending order.

	Part 7 -  Use Logging
	__1.  In the Tivoli Performance Viewer of the Admin Console expand the server1 -> Settings section on the left and click Log to setup logging.
	__2.  Change the File Name to be '/root/LabFiles/Stress' and press the Apply button.  The actual file name will be similar to Stress_server1_xxxx.zip.
	__3.  Back on the left side expand the server1 -> Performance Modules section.
	__4.  Check the checkbox next to the following modules to enable data from that module if these modules are not already selected:
	__5.  On the left side of the Performance Viewer, click on the View Modules button.
	__6.  Under the graph of data click the Undo Reset to Zero button.
	__7.  Press the Clear Buffer button and then the Reset To Zero button.
	__8.  Click the Start Logging button along the top of the viewer.
	__9.  Return to the JMeter window.
	__10.  From the JMeter menus select 'Run -> Clear All'.
	__11.  From the menus select 'Run -> Start'.  The performance viewer will behave exactly the same as before except it will log the metrics in the background.
	__12.  Once the stress test is completed, stop the logging by clicking on the Stop Logging button in the performance viewer window of the Admin Console.
	__13.  In the left hand pane of the Admin Console, expand Monitoring and Tuning -> Performance Viewer.
	__14.  Click on the link for Current Activity.
	__15.  Check the checkbox next to server1 and press the Stop Monitoring button.
	__16.  To replay the logged data, select Monitoring and Tuning -> Performance Viewer -> View Logs in the Admin Console navigation.
	__17.  Click on the Browse button next to the Explicit Path to Log File option. 
	__18.  Navigate to the '/root/LabFiles' directory and look for a file that starts with 'Stress_server1_xxx'.    Select this file and press the Open button to select the file.
	__19.  After specifying the path to the file, click on the View Log button.  The file starts to play automatically.
	__20.  Expand Performance Modules on the left hand side and select the modules from before:
	__21.  Click the View Modules button to display the data.
	__22.  You can use the VCR-like controls above the viewer to control the playback.  Depending on how long the file is you may need to press the rewind button to restart playing the file.
	__23.  If you switched the web browser to full screen, hit F11 again to restore it.
	__24.  Logout of the Admin Console and close the web browser.
	__25.  From the JMeter menus select 'Run -> Clear All'.
	__26.  In the JMeter window select 'File -> Save' and then 'File -> Exit'.
	__27.  Close any extra web browsers, File Browser windows, or command prompts you may have open.

	Part 8 -  Review

	Lab 12 -  Configuring and Analyzing Memory
	Part 1 -  Enable Verbose Garbage Collection
	__1.  Check that your Application Server is running and start it if it is not running.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  Expand the Servers → Server Types section and click the link for WebSphere application servers.
	__5.  Click the link for server1 on the right.
	__6.  In the 'Server Infrastructure' section expand 'Java and Process Management' and click the link for 'Process Definition'.
	__7.  Under the 'Additional Properties' click the link for 'Java Virtual Machine'.
	__8.  Check the box for 'Verbose garbage collection'.  Also make sure the two “heap size” setting boxes are empty and press the OK button.
	__9.  Click the Save link in the messages at the top of the Admin Console.
	__10.  Logout of the Admin Console.
	__11.  Restart your Application Server using any method you are familiar with.  Wait until it is completely restarted to continue.

	Part 2 -  Establish a Baseline
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the left hand pane, expand Monitoring and Tuning -> Performance Viewer.
	__4.  Click on the link for Current Activity.
	__5.  Check the checkbox next to server1 and press the Start Monitoring button.
	__6.  Check that server1 shows that it is being monitored.
	__7.  Click the link for server1 in the list.
	__8.  On the left side expand the server1 -> Performance Modules section.
	__9.  Check the checkbox next to the following module to enable data from that module:
	__10.  Click the View Modules button at the top of the list on the left to view the data.
	__11.  Under the graph on the right, uncheck the metric of UpTime and check the ProcessCpuUsage.  You may need to scroll in the performance viewer as you change settings and the graph resets.
	__12.  Open a command prompt and start the JMeter tool as you did in the last lab.  You can refer to the instructions on page 193 if you need to know how to do this.
	__13.  Once the JMeter tool is running, select File → Open to open the test script you used in the last lab.  This is most likely <LABFILES_DIR>/OnlineStoreTest.jmx.  If you had trouble with your test script you can also open up a solution script at <LABFILES_DIR>/Performance/SolutionOnlineStoreTest.jmx.
	__14.  On the left side select the Thread Group by clicking on it.
	__15.  Make sure the settings on the right side are set so the test will loop 50 times.
	__16.  Switch back to the Admin Console.
	__17.  Under the graph of data press the Clear Buffer button.
	__18.  Switch back to JMeter.
	__19.  From the menus select 'Run -> Start'.
	__20.  Wait for the test to complete before going to the next step.  There is a rectangle in the upper right of the JMeter tool that will be green if the test is still running.
	__21.  Switch back to the Admin Console.
	__22.  Examine the graph of JVM data.  Although it may be slightly different than that shown below you will likely notice several trends:
	__23.  In the left hand pane of the Admin Console, expand Monitoring and Tuning -> Performance Viewer.
	__24.  Click on the link for Current Activity.
	__25.  Check the checkbox next to server1 and press the Stop Monitoring button.
	__26.  Leave the Admin Console open.
	__27.  Leave the JMeter tool running.

	Part 3 -  Set Heap Settings
	__1.  Return to the Admin Console open from the previous section.  If you had closed it open it and login as the 'wasadmin' user.
	__2.  Expand the Servers → Server Types section and click the link for WebSphere application servers.
	__3.  Click the link for server1 on the right.
	__4.  In the 'Server Infrastructure' section expand 'Java and Process Management' and click the link for 'Process Definition'.
	__5.  Under the 'Additional Properties' click the link for 'Java Virtual Machine'.
	__6.  Find out how much memory your virtual machine has.  This can be done by opening a terminal window and running the 'free' command.  Look for the entry for total memory.  In the example below there is about 1.6 GB of memory.
	__7.  In the Admin Console, fill in the following heap size settings and press the OK button.
	__8.  Click the Save link in the messages at the top of the Admin Console.
	__9.  Logout of the Admin Console.
	__10.  Restart your Application Server using any method you are familiar with.  Wait until it is completely restarted to continue.

	Part 4 -  Repeat Test with New Heap Settings
	__1.  Make sure your server is restarted from the previous section after the heap settings were adjusted.
	__2.  Return to the JMeter tool and your open test script.  Use the directions from earlier in the lab to start JMeter and open the test script if you closed it. 
	__3.  Make sure the Thread Group is set to loop 50 times.
	__4.  From the JMeter menus select 'Run -> Start'.
	__5.  Wait for the test to complete before going to the next step.  There is a rectangle in the upper right of the JMeter tool that will be green if the test is still running.
	__6.  Once the JMeter test is complete select 'File -> Exit'.  Save the test if prompted.
	__7.  Leave your WebSphere server running for the next section.

	Part 5 -  Generate a Heap Dump
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the left hand pane of the Admin Console, expand Troubleshooting and click on the link for Java dumps and cores.
	__4.  Select the checkbox for server1 and click the Heap dump button.
	__5.  Look at the message at the top of the console and notice that a file is listed for where the heap dump is stored.  Although we will not use this file now it is good to know where the default location of the file is.
	__6.  Expand the Servers → Server Types section and click the link for WebSphere application servers.
	__7.  Click the link for server1 on the right.
	__8.  In the 'Performance' section click the link for 'Performance and Diagnostic Advisor Configuration'.
	__9.  Click the 'Runtime' tab at the top of the page displayed.
	__10.  Notice the setting for 'Enable automatic heap dump collection'.  When enabled along with the 'Performance and Diagnostic Provider' the server can automatically generate heap dumps if a memory leak condition is suspected.
	__11.  Logout of the Admin Console.
	__12.  Stop your server using the method you are most familiar with.

	Part 6 -  Examine Verbose Garbage Collection
	__1.  Open a File Browser window.
	__2.  Navigate to the <WAS_ROOT>/profiles/AppSrv01/logs/server1 directory.
	__3.  Find the native_stderr.log file and open it with a text editor.
	__4.  Scroll to the very bottom of the file and notice that there are various entries for garbage collection (or “gc”) events or data.
	__5.  Close the file and any extra windows that are open.

	Part 7 -  Review

	Lab 13 -  Use wsadmin Scripting
	Part 1 -  Start an Interactive wsadmin Session
	__1.  Start the Application Server.
	__2.  Be sure you have logged out of any Admin Console windows that may be open and closed the web browsers you were using.
	__3.  Open a File Explorer window and navigate to the <WAS_ROOT>/profiles/AppSrv01/properties directory.
	__4.  Open the wsadmin.properties file with a text editor.
	__5.  Find the section in the file for the 'defaultLang' property and change the value to 'jython' as shown below.
	__6.  Save and close the file.
	__7.  Open a terminal window.  
	__8.  In the Command Prompt, switch to your <WAS_ROOT>/profiles/AppSrv01/bin directory.  Use the value of <WAS_ROOT> that you wrote down in the Directory Paths section.
	__9.  Issue the following wsadmin command to start the wsadmin environment in interactive mode:
	__10.  When prompted, enter a username and password of 'wasadmin'.
	__11.  Make sure that you do not get any authentication errors when connecting.  If you do issue the quit command and start the session again.

	Part 2 -  List Installed Applications
	__1.  Since a list of applications is required the AdminApp object will probably be involved. Issue the command: 
	__2.  In the output of the help text you should see a list function.  This looks like the function you need and now just need to check the syntax of how to use it.  Issue the command:
	__3.  From the output of the help on the list function you should see that the command does not require any arguments.  This makes the command easy to call.  Issue the command:
	__4.  You should see all the installed applications listed.  Leave the wsadmin window open for the next section.

	Part 3 -  Stop and Start an Application
	__1.  You should already have a wsadmin window open from the last section.  If you do not, start one using the instructions from the beginning of this lab.
	__2.  To get the help text for the AdminApp object issue the command:
	__3.  If you look through the functions available you should notice there are none for stopping and starting an application.  Since you are trying to control whether or not an application is running it is likely you will go through the AdminControl object since this provides access to other MBeans in the runtime environment.
	__4.  Declare a variable to store a reference to the ApplicationManager MBean.
	__5.  Now you need to find out how to use this object to control applications.
	__6.  In the help output notice there is an operations function available from the Help object that can list all the operations of an MBean.  Now you need to know how to use this function.
	__7.  Notice there are two versions of this function.  One can list all operations available in an MBean the other can give you help on a specific operation.
	__8.  Notice that there are startApplication and stopApplication operations available from the ApplicationManager MBean.  These are the operations you will need to use.  Issue the command to get help on the stopApplication operation.
	__9.  Notice the only parameter required for the stopApplication operation is a String of the application name.
	__10.  Issue the command:
	__11.  There are a few different ways to invoke operations on other MBeans depending on if they have arguments.  Issue the following command and note there will be no output:
	__12.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__13.  Login as the 'wasadmin' user.
	__14.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__15.  Notice the HitCount application is stopped.
	__16.  Back in the wsadmin scripting session issue the command:
	__17.  In the Admin Console, click the link for Applications → Application Types → WebSphere enterprise applications again to refresh the page.
	__18.  Notice the HitCount application is started.  
	__19.  Logout of the Admin Console and close the web browser.  Leave the wsadmin window open for the next section.

	Part 4 -  View Data Source Properties
	__1.  You should already have a wsadmin window open from the last section.  If you do not, start one using the instructions from the beginning of this lab.
	__2.  The properties of an existing DataSource object would be stored in the WebSphere configuration. To work with the WebSphere configuration you will be using the AdminConfig object.  Issue the command:
	__3.  Notice that the AdminConfig object has a list operation just like the AdminApp object does.  Issue the command:
	__4.  Notice that both versions of the list function take an argument for the ‘type’.  Although we are fairly certain of the type of object you are looking for here it would still be good to check to be sure.  It is good to do this just to check things like spelling and capitalization which are important in wsadmin.  Look back at the general help for the AdminConfig object.  Notice there is also a types function.  Issue the command:
	__5.  Notice there are a lot of types available in the configuration structure.  Scroll up this list and look for some you recognize like WebContainer, VirtualHost, Server, MessageListenerService, JMSDestination, JDBCProvider, EJBContainer, and finally DataSource.
	__6.  Now you know you can use the list operation of the AdminConfig object to list all configuration elements of a DataSource type.  Issue the command:
	__7.  You should see that there are several DataSource objects listed.  You are trying to list information about the "Online Store DB" DataSource.  To get the properties of one of them you need a reference to the appropriate configuration ID.  This is so you can identify exactly which configuration object to work with as this id will be unique.  The AdminConfig operation used to get the configuration ID is getid.  Issue the command:
	__8.  Notice the only thing needed to get a configuration ID is a "containment path".
	__9.  The AdminConfig object has a parents operation which lists what configuration objects are valid parents of a configuration type.  Issue the command:
	__10.  Notice the only valid parent of a DataSource is a JDBCProvider.  Issue the command below to find the valid parents of a JDBCProvider:
	__11.  Notice there are five valid parents of a JDBCProvider.  This is determined by what scope the JDBCProvider is configured at.  The "Deployment" scope is used if the application is deployed as an "Enhanced EAR" that has additional deployment information in the EAR file itself.  In the single server mode of WebSphere Application Server the other four scopes are not very different.  They will become very important as we discuss the clustering support of WebSphere.  Now you need to figure out what JDBCProvider contains the DataSource you are looking for and at what scope it is defined.  Issue the following command:
	__12.  In the output notice there is a "DB2 Universal …" JDBCProvider listed.  This is the JDBCProvider which is the parent of the "Online Store DB" DataSource.  Notice in the rest of the information printed the JDBCProvider is configured in a "resources.xml" file and the scope is "cells/<hostname>Node01Cell".  This JDBCProvider is at the cell scope.
	__13.  Now you finally have enough information to locate the DataSource you need.  You will store the reference to the DataSource using a variable so it will be easier to work with in future commands.  Note that since the resource is at cell scope we do not need node or server name.  Note that this command must be entered on one line.  The containment path is also enclosed by a pair of double quotes because the containment path contains spaces.  Issue the command below noting that the containment path is so long it has wrapped onto several lines.  Enter this command on one line.  Make sure that there is not a blank value stored in the variable.  If you get an error with this command double-check the command again, especially the name of the JDBCProvider and the name of the DataSource.
	__14.  Make sure you do not see any errors in the output of the last command before continuing.
	__15.  Notice in the output of this command (or 2 commands with Jython) that there is only one configuration id listed.  Although it is the same value as what you got by listing all of the DataSources you are now referring to only one of them.
	__16.  You can now show the attributes of the DataSource.  There are several operations that can be used to show attributes.
	__17.  Notice the operation attributes which can be used to show what attributes are available for a given type.  This operation also lists the type of value for each attribute.
	__18.  Notice the output refers to basic attributes that have "String" values and complex attributes like "connectionPool" or "mapping" which have values of other configuration types.  You can find the attributes of these other types also.
	__19.  The AdminConfig object also has show, showall, and showAttribute operations which display information about a specific configuration object.  These can be used depending on how much information you require.  The showall operation displays the most information as it recursively displays information for any child configuration objects.  The showAttribute displays only the value of a single attribute. 
	__20.  Notice you can see attribute values of the DataSource the ds variable refers to like the jndiName of "jdbc/store" and the name of "Online Store DB".
	__21.  Leave your wsadmin window open as you will be working with the DataSource in the next section and can reuse the variable that refers to it.

	Part 5 -  Modify Data Source Properties
	__1.  You should already have a wsadmin window open from the last section.  If you do not, start one using the instructions from the beginning of this lab.
	__2.   If you had to open a new wsadmin session, execute the commands from step 13 of the previous section.  This will setup a ds variable to refer to the DataSource you will modify.
	__3.  Now that you have a reference to the DataSource you can view the current value of the name property you will be modifying.
	__4.  Since you have a reference to the DataSource and know the property you wish to change you can tell the AdminConfig object to change the property value.  This is done with the modify operation of the AdminConfig object.
	__5.  Notice this operation takes two parameters, config id and attributes.  The config id is already stored in the ds variable.  The attributes parameter is a list of attributes that you wish to modify.  This means that you must supply a list of name/value pairs.  This is done slightly differently for each of the two scripting languages.  With Jython you use double quotes around the name and value of the property (whether or not they contain spaces); plus, you need a comma between them.  With Jacl you only need double quotes around the property value if it contains spaces.  
	__6.  Now that you have changed the value of the property you can check that the new property is being used.
	__7.  Even though the new property value is listed by the above command it is not yet saved to the configuration.  It is just a temporary change in your wsadmin session.
	__8.  This lists the resources.xml file that stores the DataSource configuration as containing unsaved changes.  Issue the command:
	__9.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__10.  Login as the 'wasadmin' user.
	__11.  In the Admin Console, navigate to Resources -> JDBC -> Data sources.
	__12.  Be sure the scope listed at the top of the page is set to your cell.  If it is not, use the drop-down list to switch to this scope.
	__13.  Notice the name of the Data Source listed has changed from "Online Store DB" to "Online Store Database".
	__14.  Logout of the Admin Console and close the web browser.  Leave the wsadmin window open for the next section.

	Part 6 -  Retrieve Server Properties
	__1.  You should already have a wsadmin window open from the last section.  If you do not, start one using the instructions from the beginning of this lab.
	__2.  You can also get additional information about the server process itself.  This requires referring to the MBean which represents the server process.  Issue the command:
	__3.  You can now use this reference and the operations available from the Help object to determine what else you can use the server variable to find.
	__4.  Among the other operations available notice the operations for retrieving the name and Pid of the server.  Neither of these operations requires parameters.  Again, as before, you must use the AdminControl object to invoke operations of MBeans.
	__5.  Note the Process ID returned by the operation here: 	 .  
	__6.  Open a separate terminal window.
	__7.  Issue the following command to list all the Java processes on your machine.  One of these is the WebSphere server.
	__8.  Notice the process which matches the Process ID is a ‘java’ process.  You may notice another ‘java.exe’ process.  This is the interactive wsadmin environment.  This represents the power of JMX, having one Java process connect and manage another.
	__9.  Close the terminal window listing the processes.
	__10.  In the terminal window running the wsadmin session issue the quit command to finish the wsadmin session.
	__11.  Stop the Application Server using the method you are most familiar with.
	__12.  Close any extra web browsers, File Browser windows, or terminal windows you may have open.

	Part 7 -  Review

	Lab 14 -  Additional Jython Scripting
	Part 1 -  Experiment with Scripting Commands
	__1.  If it is not already running, use the method of starting the Application Server you are most familiar with.
	__2.  Be sure you have logged out of any Admin Console windows that may be open and closed the web browsers you were using.
	__3.  Open a terminal window.  
	__4.  In the terminal window, switch to your <WAS_ROOT>/profiles/AppSrv01/bin directory.  Use the value of <WAS_ROOT> that you wrote down in the Directory Paths section.
	__5.  Issue the following wsadmin command to start the wsadmin environment in interactive mode:
	__6.  When prompted, enter a username and password of 'wasadmin'.
	__7.  Make sure that you do not get any authentication errors when connecting.  If you do issue the quit command and start the session again.
	__8.  The first place to start is to get general help for what is available in the scripting library.  Issue the following command to print this help.
	__9.  Notice that there are many different script libraries which all start with 'Admin' and indicate in the name the general purpose of the library.  If you scroll up in the list notice there is a 'AdminApplication' which is the library for installing and configuring applications.
	__10.  Each of the script libraries has a 'help' method which can print out help information for that library.  Issue the following command to print this help for the AdminApplication library.
	__11.  Notice that there are lots of methods in this library.  They are split into groups depending on what they do.  There are also many similar methods that take a different number of type of parameters but accomplish similar things.
	__12.  Look in the first group of methods for the various ways to install applications. Thinking back to how we installed other applications remember that we mapped an application to an application server and a web server so the 'installAppWithTargetOption' might be the method we are looking for.
	__13.  Issue the following command to get help on this particular method.  Make sure to spell the name of the method carefully including capitalization.  
	__14.  In the output of the command notice that the parameters would include the name of the application as it would be identified by WebSphere, the EAR file of the application, the node name and the names of two servers to target the application to.
	__15.  Another important aspect of installing our application was mapping it to the new virtual host we had created.  This linked the application to a specific hostname and port combination.  Notice that nothing of the scripting command we just examined mentions the virtual host.
	__16.  There is also another installation method where you can set "default bindings".  Issue the following command to get help on this method.  
	__17.  Notice in the output of this method that we can provide a virtual host binding but there is no way to target more than one server.
	__18.  Issue the following command to find out about a method that will help check if the application is already installed.
	__19.  Notice this method takes an application name and will return true or false if an application is already installed with the same name.
	__20.  Issue the following command to find out about a method that will start the application on the single application server it will be deployed to.  
	__21.  Notice this method takes an application name and the name of the node and server to start the application on.
	__22.  Since we will obviously need to make a choice for which setting to set during installation and which setting to modify post-installation it will be good to find out how to modify each setting.  We will use some of the functions of the AdminApp object to do this.
	__23.  Issue the following command to print out some of the available options for the EAR file we will install.  Modify the parameter if for some reason your lab files are not in the location below.
	__24.  Although there are several options notice at the start of the list the options 'MapModulesToServers' and 'MapWebModToVH'.  These are the primary options that interest us as this simple application will not actually need any of the others.
	__25.  Issue the following command to print out the information for how to supply the information for the map modules task.  Note that the command is all one line even though shown on two below.
	__26.  Notice that the syntax of how to supply the server to map to is a little more complex than the script library method which will only need the short name of the server.
	__27.  Issue the following command to print out the information for how to supply the information for the map virtual host task.  Note that the command is all one line even though shown on two below.
	__28.  Notice that this one may be a bit easier to supply information for as all that is needed is the name of the virtual host.
	__29.  In the terminal window running the wsadmin session issue the quit command to finish the wsadmin session.
	__30.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__31.  Login as the 'wasadmin' user.
	__32.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__33.  In the list of applications, click the link for the 'DefaultApplication'.
	__34.  Under the list of 'Web Module Properties' click the link for 'Virtual hosts'.
	__35.  Change the virtual host drop-down to 'myhost' and press the OK button.
	__36.  Do not save the changes but instead click the link in the 'Help' area on the right for "Command Assistance".  This will show you the scripting equivalent of changing the virtual host for an application.  If you get a warning about the server certificate you can ignore it.
	__37.  In the command that is shown notice that it calls the 'edit' function of the 'AdminApp' object.  Notice that there are two parameters (in single quotes) for this function even though the second one is very long.  The parameters are the name of the application and the list of application options to modify.  In this case we see the '‑MapWebModToVH' option that was seen in the scripting session.  We will build a similar command in the script file although it will be simpler because it will use wildcards for some of the values.
	__38.  Close the popup window that is showing the command syntax.
	__39.  Click the Review link at the top of the Admin Console to review the configuration changes that were made.
	__40.  Click the Discard button to discard the configuration changes.  We do not actually want to change the configuration but were simply submitting the changes to see what the equivalent scripting command would be.
	__41.  Confirm that you want to discard the changes by clicking the Yes button.
	__42.  In the navigation section of the console expand the Servers → Server Types section and click the link for Web servers.
	__43.  Check the checkbox next to webserver1 and click the Generate Plug-in button.
	__44.  Click the link in the 'Help' area on the right for "Command Assistance".  This will show you the scripting equivalent of generating the plugin configuration.  Again ignore the certificate error if shown.
	__45.  The first command shown does a 'ping' test but the second command is more interesting.  It invokes a 'generate' function on a "PluginCfgGenerator" MBean to generate the plug-in configuration.  If you were to search the InfoCenter for information on the "PluginCfgGenerator" MBean you would find that the parameters for this function include the configuration root of the profile, the name of the cell, node, and web server to generate, and a boolean for whether or not to also propagate the plug-in configuration.  We will use a version of this function as well in our script file.
	__46.  Close the extra window displaying the command assistance.
	__47.  Logout of the Admin Console and close the web browser.

	Part 2 -  Install Application with Scripting
	__1.  Open a File Browser window and navigate to the <LABFILES_DIR>/Scripting directory.
	__2.  Open the file installHelloWorld.py with a text editor.  In this file there are a few commands with the text COMPLETE that you will need to edit.
	__3.  Examine the first part of the file which prints some usage information for the user. This is important as it is very common for a script to be written by different people than the ones that use it.
	__4.  The section labeled 'SECTION 1' checks how many parameters were passed in when calling the script file.  The 'sys.argv' variable is an array with the command parameters and you can check the length.  This is important because if you try to use an index that is too high you will get a scripting exception.  If the number of parameters is incorrect the script prints out a friendly error and then exits the script which will be much more user friendly.  There is nothing for you to complete in this section.
	__5.  Once the number of parameters has been checked and stored in some more descriptive variable names the script prints out what will happen using the values passed in by the user.
	__6.  In SECTION 2 some code is added to make sure the script is only run for an application that is not already installed.  Modify the code that currently reads 'AdminApplication.COMPLETE' and replace the COMPLETE text with the name of the correct method from the script library that will check if the application is already installed.  Also remember that this method takes the name of the application as a parameter so use the correct variable that was initialized at the beginning of the script.
	__7.  In SECTION 3 there is code to call the method from the scripting library we decided to use to install the application 'installAppWithTargetOption'.  Replace the COMPLETE text with the five parameters this method requires separated by commas.  All of the parameters are variables already initialized.  Be careful to get the parameters in the correct order for the method although the order of the last two parameters doesn't matter because these will be the two servers.
	__8.  In SECTION 4 the code is building a list of options to supply to the AdminApp.edit command.  Replace the COMPLETE text with the name of the option you saw with the AdminApp.options command that will map the application to a virtual host.  Remember to leave the single quotes and the dash as these are needed for the list of options.  Notice that associated with this option is another list which has three values separated by commas.  The first two '.*' values use pattern matching so that every application web module will be mapped to the virtual host indicated by the third value which is the variable storing the name of the virtual host.
	__9.  In SECTION 5 there is just the usual save configuration once the application has been installed and edited for the virtual host.  There is nothing for you to complete in this section.
	__10.  In SECTION 6 the application will be started.  Replace the COMPLETE text with the name of the method that will start the application on the single server.  The parameters have already been supplied for you.
	__11.  The last part of SECTION 7 gets a reference to the 'PluginCfgGenerator' MBean and builds the list of options that will be required including the configuration root, cell, node, and web server name, and a final value of 'true' to also propagate the plug-in configuration.  Replace the COMPLETE text with the three parameters required for the AdminControl.invoke command.  Remember this is the MBean to invoke a method on, the name of the method to invoke, and a list of options to provide.
	__12.  Save your file once you have made sure to replace all occurrences of the COMPLETE text with the appropriate code.  You may also want to check your script file against the solution version also provided to help avoid errors when running it.
	__13.  Open a terminal window.  
	__14.  In the terminal window, switch to your <WAS_ROOT>/profiles/AppSrv01/bin directory.  Use the value of <WAS_ROOT> that you wrote down in the Directory Paths section.
	__15.  Issue the following command to execute the script file with the six parameters that are required.  Double check that you have spaces between the parameters, the order is correct, and use the correct value for your <nodename> from the Lab Notes section in the command below.  Note this is all one command even though it is on multiple lines below.
	__16.  When prompted, enter a username and password of 'wasadmin'.
	__17.  Wait for several seconds as the script executes.  The last messages you should receive are that the application was started successfully and the plug-in configuration was generated and propagated.
	__18.  If you get any errors you will likely need to login to the Admin Console and uninstall the application before trying to run the script file again.  If you do get errors, check the values that you pass in as parameters to the script in addition to the syntax of the code you typed.  You may want to use the "up arrow" in the terminal window and change the call to wsadmin to use the solution script file with the same parameters to check whether it was the parameter values or the script code that was causing errors.
	__19.  Once the script file installs the application successfully open the admin console and login as wasadmin.  If you were already logged in you may want to logout and back in to verify you do not have any cached settings.
	__20.  In the navigation area of the Console expand the Applications → Application Types group and click the link for WebSphere enterprise applications.
	__21.  You should see that the HelloWorld application is running.
	__22.  Click the link for the HelloWorld application.
	__23.  In the list of 'Web Module Properties' on the right click the link for "Virtual hosts".
	__24.  Note that the web module is mapped to the 'myhost' virtual host.
	__25.  In the "breadcrumbs" at the top of the main console area, click the link for the HelloWorld application.
	__26.  Under the 'Modules' section click the link for Manage Modules.
	__27.  Notice that the web module is mapped to both the application server and the web server.
	__28.  Logout of the Admin Console.

	Part 3 -  Test the HelloWorld Application
	__1.  Open a web browser and enter the URL http://was.myhost.com/HelloWeb/ into the address bar of the web browser and hit Return.  You should see the following page.
	__2.  Click the first link to display the standard message of "Hello There!".
	__3.  Press the Back button on the browser to return to the entry page of the application.
	__4.  Fill in the text box with a custom message and press the Display Special Message button.
	__5.  Your special message will be displayed.
	__6.  Close the web browser you used to test the new application.

	Part 4 -  Modify Configuration with Properties Files
	__1.  Be sure you have logged out of any Admin Console windows that may be open and closed the web browsers you were using.
	__2.  Open a terminal window.  
	__3.  In the terminal window, switch to your <WAS_ROOT>/profiles/AppSrv01/bin directory.  Use the value of <WAS_ROOT> that you wrote down in the Directory Paths section.
	__4.  Issue the following wsadmin command to start the wsadmin environment in interactive mode:
	__5.  When prompted, enter a username and password of 'wasadmin'.
	__6.  Make sure that you do not get any authentication errors when connecting.  If you do issue the quit command and start the session again.
	__7.  Issue the following commands to create a Jython list and add some of the options you will need to extract a properties file.
	__8.  Issue the following command to use the list of options to extract a properties file.
	__9.  Make sure you do not get any errors but instead get an empty String printed out.  Leave the scripting session open.
	__10.  Open the /root/LabFiles/Scripting/server.properties file with a text editor.
	__11.  Notice that there are a LOT of properties in this file.  Although this file might be good for the configuration of an entire server it will be best to work with subsets of properties if possible.
	__12.  Close the file without making any changes.
	__13.  Back in the wsadmin scripting session issue the following commands.  This will change the name of the properties file for the second extraction we will perform.
	__14.  Issue the following commands to add to the list some additional options to filter the properties.
	__15.  We are not quite done with our revised options.  The subtypes that you want to filter must be supplied as a list of types embedded within the list of options.  Issue the following commands to create a new list, append the subtypes to it, and append the subtypes list to the options list.
	__16.  Issue the following command to use the list of options to extract a second properties file.
	__17.  Make sure you do not get any errors but instead get an empty String printed out.  Leave the scripting session open.
	__18.  Open the /root/LabFiles/Scripting/serverSubset.properties file with a text editor.
	__19.  Notice that even though there are still several properties in the file there is a more manageable number.
	__20.  In the Java Virtual Machine properties which should be at the top change the value for the 'initialHeapSize' property to 50.  Make sure you supply a valid integer and also double check that this is less than the value for the maximum heap size.
	__21.  Search the file for the text 'WebContainer' without the quotes.  This text should only appear once for the properties for the web container thread pool.
	__22.  Change the value for the 'minimumSize' of the thread pool to 10 in the properties of the WebContainer.  Again make sure that it is a valid integer and less than the value of the maximumSize property.
	__23.  Save and close the file.
	__24.  Go back to the scripting session window.
	__25.  Issue the following commands to create a Jython list and add some of the options you will need to validate the properties file.
	__26.  Issue the following command to use the list of options to validate the properties in the file against the environment.
	__27.  You should see a return value of true indicating the values were validated properly. If you get an exception reported examine the printout of the options to check the values that are in the list of options.
	__28.  Open the /root/LabFiles/Scripting/ValidateReport.txt file with a text editor.  
	__29.  Examine the messages in the report which will show you only what values have changed.  There are no specific messages that the properties are OK but there are no errors mentioned so these properties are good.
	__30.  Close the report file.
	__31.  Go back to the scripting session window.
	__32.  Issue the following commands to create a new list of options for applying the properties.  Notice that the new list starts with the first three values in the list of validation options.  This will allow a new file name for the report.  Notice that we are not filtering the report so it will show all of the messages.
	__33.  Issue the following command to use the list of options to apply the properties in the file against the environment.
	__34.  Issue the following command to save the configuration changes.
	__35.  Open the /root/LabFiles/Scripting/ApplyReport.txt file with a text editor.  Notice you have all of the messages including the values that were not changed.
	__36.  Close the file.
	__37.  In the terminal window running the wsadmin session issue the quit command to finish the wsadmin session.
	__38.  Stop the server and close all open windows.

	Part 5 -  Review

	Lab 15 -  Create Deployment Manager Profile
	Part 1 -  Create Deployment Manager Profile
	__1.  Stop your standalone WebSphere server if it is still running.
	__2.  Open a terminal window. 
	__3.  Use the 'cd' command to change to the <WAS_ROOT>/bin/ProfileManagement directory. Be sure to substitute the value of <WAS_ROOT> from the “Directory Paths” page at the beginning of the lab instructions.
	__4.  Issue the following command to start the Profile Management Tool.
	__5.  Press the Create button next to the list of profiles.
	__6.  In the Environment Selection dialog, select the option for Management and press the Next button.
	__7.  Leave the default option of Deployment manager selected and press the Next button.  If you get a security prompt unblock the process.
	__8.  Select the option for Advanced profile creation and press the Next button.
	__9.  Leave the default option to deploy the administrative console and press the Next button.
	__10.  Leave the default profile name and directory and press the Next button.
	__11.  Leave the default Node, Host and Cell names.  Write down the values for the Node  name, Host name, and the Cell  name of the Deployment Manager profile in the “Lab 15” section of the Lab Notes section.  Press the Next button.
	__12.  Leave the box for Enable administrative security checked.  Fill in a user and password of wasadmin.  Press the Next button when your screen matches that shown below.
	__13.  In the first page of security certificate options, leave the default to create a new default personal certificate.  Press the Next button.
	__14.  On the second page of security certificate options again leave the defaults and press the Next button.
	__15.  In the Port values assignment page, note the Administrative console port and SOAP connector port.  Write these values down in the Lab Notes section at the beginning of the lab guide in the “Lab 15” section.  Leave the default port numbers as is and press Next. WebSphere ND automatically assigns port numbers that do not clash with the existing port numbers with the existing profile.  It's a good idea to go through the port numbers. 
	__16.  Leave the options on the Linux service screen so the deployment manager is NOT run as a Linux service and press the Next button.  
	__17.  Press Create in the Summary page to begin profile creation.  This will take several minutes.
	__18.  When the profile creation is complete, leave the option for launching the First Steps console and press the Finish button.
	__19.  When the First Steps console appears, click on the Installation verification link to verify profile creation. 
	__20.  Make sure that you get a message that the verification succeeded.  You will get a number of warnings but there should be no errors.
	__21.  Close the verification window.
	__22.  Leave the Deployment Manager running for the next lab.
	__23.  Close the First Steps console.
	__24.  Select File → Exit on the Profile Management Tool. 

	Part 2 -  Review

	Lab 16 -  Configure Cell Architecture
	Part 1 -  Federate the Node
	__1.  Verify the Deployment Manager is started.  If you did not restart the machine after doing the verification in the Deployment manager profile creation lab it should still be running.  To start the Deployment Manager open a terminal window, switch to the <WAS_ROOT>/profiles/Dmgr01/bin directory, and execute the startManager.sh command. Remember to substitute the value of <WAS_ROOT> from the Directory Paths section of the lab guide.
	__2.  Open a web browser and enter http://localhost:9061/ibm/console in the address bar. Note that the port is slightly different because the Deployment Manager profile used different ports to avoid conflicting with the previous profile.
	__3.  Add an exception for the security certificate so you can continue to the Admin Console.
	__4.  Login as the 'wasadmin' user.
	__5.  In the navigation panel of the Admin Console expand the System Administration section and click the link for Deployment manager.
	__6.  On the right side, under Additional Properties, click the '+' sign to expand the list of Ports and be sure you do not click on the link itself.
	__7.  Look for the value of the SOAP_CONNECTOR_ADDRESS and write it down in the lab 15 section of the Lab Notes as the 'DM_SOAP_PORT' variable.  You may already have this value written down so check that it is the same as shown in the Admin Console.  This port will be used by the nodes to communicate with the Deployment Manager when adding the node.
	__8.  Logout of the Admin Console.  This is very important or you will not see the new node in the Admin Console after it is added.
	__9.  Open a terminal window.
	__10.  In the terminal window switch to the <WAS_ROOT>/profiles/AppSrv01/bin directory and issue the following command.  Remember that only one node can be added at a time.  Substitute the appropriate values from what you wrote down in the Lab Notes section.
	__11.  Check that the addNode command completed successfully.  Notify your instructor if there are problems.

	Part 2 -  Verify the Cell Configuration
	__1.  Open a web browser and enter http://localhost:9061/ibm/console in the address bar, the URL of the Deployment Manager Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the navigation pane select System Administration -> Nodes.
	__4.  Verify that the node you expect to see in the cell is indeed in the cell.  You will see an extra “Node” for the Deployment Manager server which will have a node name that includes “Manager” in the name.
	__5.  In the navigation pane select Servers → Server Types → WebSphere application servers.
	__6.  Verify that you see an entry for the server on the node.  Note the Node listed for each server.  Right now this will just list the 'server1' server but later there will be other servers in this list.

	Part 3 -  Set Synchronization Preferences
	__1.  In the Admin Console, expand System Administration and click the link for Console Preferences.
	__2.  On the Preferences page check the box for Synchronize changes with Nodes and press the Apply button.

	Part 4 -  Configure VirtualHost
	__1.  In the Admin Console, navigate to Environment -> Virtual Hosts.
	__2.  In the list of virtual hosts notice the 'myhost' virtual host is not present.  The reasoning was discussed in the introduction to this section.
	__3.  Press the New button above the list of virtual hosts.
	__4.  Fill in a Name of myhost.  Press the Apply button to apply the new name and make the additional properties on the right available.
	__5.  Click the link for Host Aliases in the Additional Properties section.
	__6.  Press the New button above the empty list of host aliases.
	__7.  Fill in a Host Name of  'was.myhost.com'.  Leave the default Port value of 80 and press the OK button.
	__8.  Check that the new alias shows up in the list.
	__9.  Click the Save link in the messages at the top of the Console and confirm the node is synchronized.

	Part 5 -  Check Node Resources and Variables
	__1.  In the Admin Console, navigate to Environment -> WebSphere Variables.
	__2.  In the section at the top for the Scope use the drop down box to select All scopes.
	__3.  Scroll down the list of variables and check that the value on the node of the DB2UNIVERSAL_JDBC_DRIVER_PATH variable is filled in with a value that is correct.  Only the “manager” node should not have a value.  Make sure you look at the correct variable name because there are lots of DB2 variables.  This should already be correct since we would not have been able to run the OnlineStore application on that node without a proper value.
	__4.  In the Admin Console navigate to Resources -> JDBC -> Data sources.
	__5.  In the section at the top for the Scope use the drop down box to select All scopes.
	__6.  The only data sources listed are the default ones that are configured for servers or the cell.  The data source you configured for the OnlineStore is not listed because it was at cell scope.  This resource was lost when the node was added to the Deployment manager cell.
	__7.  Logout of the Admin Console.

	Part 6 -  Summary

	Lab 17 -  Configure Cluster and Remote Web Server
	Part 1 -  Create a Cluster
	__1.  Make sure that the Deployment Manager and the Node Agent are running.  Open a command prompt and run one of the following commands to check the status.
	__2.  Open a web browser and enter http://localhost:9061/ibm/console in the address bar, the URL of the Deployment Manager Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the navigation pane select Servers → Server Types → WebSphere application servers.
	__5.  Click the link for 'server1' from the list.
	__6.  On the right under Container Settings, click the link for Session management.
	__7.  Under the General Properties section, click the link for 'Enable cookies'.  Make sure you only click the link and leave the checkbox itself checked.
	__8.  Uncheck the box for 'Set session cookies to HTTPOnly...' and click the OK button.
	__9.  Click the Save link in the messages at the top of the Admin Console.
	__10.  Check that your changes are synchronized with the nodes and press the OK button.  If your changes are not automatically synchronized you should go to System administration -> Console Preferences to enable this option.
	__11.  In the navigation pane select Servers → Clusters → WebSphere application server clusters.
	__12.  Press the New button.
	__13.  For Cluster name, enter LabCluster.  Check the checkbox for Configure HTTP session memory-to-memory replication.  
	__14.  Check that your values match that shown above, especially the “memory-to-memory replication” option which will be important later, and press the Next button.
	__15.  Enter the name of the new cluster member. For Member Name, enter Clustered1.  Cluster member names must be unique for the node they are being added to. 
	__16.  Since you only have one node in this cell that can run application servers you do not need to make a choice for node.  Normally this is how you would choose which machine the cluster member will run on.
	__17.  For Select basis for first cluster member, select the Create the member using an existing application server as a template radio button. This will use your existing 'server1' as the template.
	__18.  Press the Next button to go to the next step.
	__19.  Check that the first cluster member shows up in the list.
	__20.  Enter the name of the next cluster member. For Member Name, enter Clustered2.
	__21.  Check the settings for the new cluster member and press the Add Member button to add the cluster member to the list.
	__22.  Check that the list of cluster members has two servers both configured for your node.  Running both cluster members on the same node is what makes this architecture vertical scaling.  If you need to make changes you can check the checkbox next to the cluster member and use the Edit or  Delete buttons.
	__23.  Once you have correctly configured the list of cluster members press the Next button to move to Step 4.
	__24.  At the summary page, press the Finish button to create the cluster.
	__25.  Back on the list of clusters you should now see the new cluster in the list.
	__26.  Click the Save link in the messages at the top of the Admin Console.  Make sure your changes are synchronized with the node.
	__27.  In the navigation panel of the Admin Console select Servers → Clusters → Cluster Topology.
	__28.  Expand the entries in the hierarchy with the '+' signs like you would directories in a Windows Explorer window.  Be sure not to click any of the links directly as this would take you to the properties of the element.
	__29.  Logout of the Admin Console.

	Part 2 -  Prepare for Web Server Configuration
	__1.  Open a terminal window.
	__2.  Change directories using the 'cd' command to the <IHS_ROOT>/bin directory.  Be sure to substitute the value of <IHS_ROOT> from the “Directory Paths” page at the beginning of the lab instructions.
	__3.  Execute the following command to stop the web server.
	__4.  Execute the following command to stop the HTTP administration service.
	__5.  Open a File Browser window and navigate to the <PLUGIN_ROOT>/config folder. Use the value of <PLUGIN_ROOT> that you had written in the Directory Paths section in the lab guide.
	__6.  Create a new folder in this directory called OnlineStoreWebServer.  You can create a new folder by selecting File -> Create Folder from the menus when viewing the correct directory.  Be sure to match the name of the folder exactly as it will be important in the next section.
	__7.  Right click on the new OnlineStoreWebServer directory in the <PLUGIN_ROOT>/config folder and select “Properties” from the popup.
	__8.  Select the “Permissions” tab along the top of the property dialog.
	__9.  Change the "Folder Access" property for “Group” and “Others” to the 'Create and delete files'.  This will let any user write to the directory.
	__10.  Click the “Close” button to close the folder properties.
	__11.  In the same File Browser window navigate to the <PLUGIN_ROOT>/logs directory again substituting the value of <PLUGIN_ROOT> from the Directory Paths section.
	__12.  Create a new folder in the logs directory called OnlineStoreWebServer.  Again double check the name of the new folder.
	__13.  In the File Browser window navigate to the <IHS_ROOT>/conf directory substituting the value of the <IHS_ROOT> variable from the Directory Paths section in the lab guide.
	__14.  Open the httpd.conf file with a text editor.
	__15.  Scroll to the very bottom of the file and find the line that indicates the location of the WebSpherePluginConfig.  Right now this should point into the webserver1 configuration.
	__16.  Change the file name of the plugin configuration to the following value remembering to substitute the value of the <PLUGIN_ROOT> variable from the Directory Paths section.
	__17.  Check that your configuration is similar to that shown below.  Note that the screenshot below wraps the file name onto a second line to display the entire value.  Make sure this is entered without any line breaks.
	__18.  Once the WebSpherePluginConfig file name is set save the web server configuration file.  Be sure the text editor doesn't add a '.txt' extension when saving the file.
	__19.  Close the text editor and File Browser windows you have been using.
	__20.  Open a terminal window and switch to the <IHS_ROOT>/bin directory.
	__21.  Issue the command below to start the web server administrative processes.  Do not start the actual web server yet as it will not start until the next section is complete.
	__22.  If you do not have the console open already then open a web browser and enter http://localhost:9061/ibm/console in the address bar, the URL of the Deployment Manager Admin Console and login as the 'wasadmin' user.
	__23.  Navigate to Servers → Server Types → Web Servers.
	__24.  Check the checkbox next to the web server listed and press the Delete button.
	__25.  Press the OK button to confirm deletion of the web servers.
	__26.  Click the Save link in the messages at the top of the Admin Console.
	__27.  Check that your changes are synchronized with the nodes and press the OK button.

	Part 3 -  Configure Remote Web Server
	__1.  If you do not already have one open, open a web browser and enter http://localhost:9061/ibm/console in the address bar, the URL of the Deployment Manager Admin Console, and login as the 'wasadmin' user.
	__2.  In the navigation pane of the Admin Console select System Administration -> Nodes. 
	__3.  Click on the Add Node button above the list of nodes. 
	__4.  Select the Unmanaged node radio button and press the Next button.
	__5.  Under General Properties, enter the Name as IHSNode. Enter the Host Name of the machine. This should be the value for the <hostname> variable that you have written down in the Lab Notes section of the lab guide.  Leave the default for the Platform Type of Linux.
	__6.  Check that your options match and press the OK button.
	__7.  Click the Save link in the messages at the top of the Admin Console and be sure your changes are synchronized with the nodes.
	__8.  In the navigation pane of the Admin Console select Servers → Server Types → Web servers. 
	__9.  Press the New button above the empty list of web servers.
	__10.  On Step 1: Select a node, choose the IHSNode from the drop down list.  Enter the Server name as OnlineStoreWebServer.  Once your values match that shown below press the Next button. 
	__11.  In Step 2: Select a Web server template, select the IHS radio button as the web server template and press the Next button.
	__12.  In Step 3: Enter the properties for the new Web server, enter the following information.  Substitute the value of the <IHS_ROOT> and <PLUGIN_ROOT> variables with the values you had written down in the Directory Paths section in the lab guide.  Note that the 'Plug-in installation location' is likely a slightly different value than the default that is supplied.
	__13.  Check that your values for the new web server match that shown for the last step. Press the Next button when everything matches.
	__14.  In Step 4: Confirm new Web Server, press the Finish button to create the web server.
	__15.  Click the Save link in the messages at the top of the Admin Console and be sure your changes are synchronized with the nodes.
	__16.  In the navigation pane of the Admin Console select Servers → Server Types → Web servers.
	__17.  Check the checkbox next to OnlineStoreWebServer and click the Generate Plug-in button.
	__18.  Check the checkbox next to OnlineStoreWebServer and click the Propagate Plug-in button.
	__19.  Make sure that you get a successful message about propagating the plugin config file.  If you do not it is likely that the settings for the web server administration service including port, user ID, and password are not correct.  Contact your instructor to help resolve this.
	__20.  Check the checkbox next to OnlineStoreWebServer and click the Start button.
	__21.  Make sure that the OnlineStoreWebServer is shown as started.  If it is not contact your instructor.
	__22.  Logout of the Admin Console.

	Part 4 -  Review

	Lab 18 -  Install Clustered Application
	Part 1 -  Create Cluster Data Source
	__1.  Make sure that the Deployment Manager and the Node Agent are running.  Open a command prompt and run one of the following commands to check the status.
	__2.  If you do not already have one open, open a web browser and enter http://localhost:9061/ibm/console in the address bar, the URL of the Deployment Manager Admin Console, and login as the 'wasadmin' user.  If you did already have one open your session may have expired and you may need to login again.
	__3.  In the admin console, navigate to Resources -> JDBC -> JDBC Providers.
	__4.  Use the drop down for the Scope setting at the top of the list to select Cluster=LabCluster.  Once the scope of Cluster=LabCluster is shown press the New button.
	__5.  On the first screen of the New JDBC Provider setup select the following options.  The contents of the last two drop down lists will change once you start selecting the first two options.  Press  the Next button once you have filled in the options as shown below.
	__6.  On the next page you should see some additional properties related to the Class path.  Look at the setting for Class path and notice it is defined with some environment variables.  Even though the value for the variables appears empty you do not need a value here.  In the previous lab you checked that you already had a value for this variable on the node that will run cluster members.  This means that WebSphere will have a value for this variable set and be able to run the data source.  
	__7.  Leave the variable value empty and press the Next button.
	__8.  Press the Finish button to create the JDBC Provider.  You should see the new JDBC Provider in the list.
	__9.  Click the Save link in the messages at the top of the admin console.
	__10.  Make sure your node is synchronized and click OK.
	__11.  Click the link for the new JDBC Provider you configured.
	__12.  On the right, under the Additional Properties section, click the link for Data Sources.  Be sure not to select the 'Data Sources (WebSphere Application Server V4)' link.
	__13.  Press the New button above the list of Data Sources.
	__14.  On the first page of the Data Source configuration fill in or change the following values.
	__15.  Press the Next button once your values are filled in as below.
	__16.  On the second configuration page fill in the following values:
	__17.  Press the Next button once your values are filled in as above.
	__18.  On the security aliases step select the following choices and press the Next button.  
	__19.  Press the Finish button to create the Data Source.  You should see the new Data source in the list.
	__20.  Click the Save link in the messages at the top of the admin console and make sure your node synchronizes.
	__21.  In the navigation pane select Servers → Clusters → WebSphere application server clusters.
	__22.  Check the checkbox next to the LabCluster and press the Start button.
	__23.  Wait a few minutes until the cluster is completely started and shows a filled in green arrow.  If you need to update the status of the cluster click the “Refresh” icon above the Status column.
	__24.  In the admin console, navigate to Resources -> JDBC -> Data sources.
	__25.  Use the drop down for the Scope setting at the top of the list to select Cluster=LabCluster. 
	__26.  In the list of Data Sources, check the box next to the Online Store DB Data Source and press the Test Connection button.
	__27.  Check that you get a message about a successful test.  It will say there was a warning but make sure it is not an error.  If you do not get a successful test, check the values of the database name of the Data Source, the value of the environment variable, and the user ID and password for the authentication alias as these are the most common errors. 

	Part 2 -  Install Clustered OnlineStore Application
	__1.  In the Applications group in the navigation, click the link for New Application.
	__2.  Click the link for New Enterprise Application.
	__3.  Next to the Local file system box, press the Browse button.
	__4.  Find the file <LABFILES_DIR>/Clustering/OnlineStore‑Clustering.ear and select Open in the file chooser dialog.  Remember to substitute the value of the <LABFILES_DIR> variable from the notes at the beginning of the labs.
	__5.  Press the Next button.
	__6.  Check the option for Detailed installation and press the Next button.  This will show all steps.
	__7.  On Step 1: Select installation options leave the default options and press the Next button.
	__8.  On Step 2: Map modules to servers check the checkbox next to both the OnlineStoreEJB and OnlineStoreWeb modules.  Select LabCluster and OnlineStoreWebServer from the list above by holding down the CTRL key as you select each one.  Make sure you pick the correct entries as the order may differ than that shown in the list below.  Press the Apply button to apply the changes to the mapping of the modules.  
	__9.  Click the link for Step 9 on the left to skip to this step.
	__10.  Check that the resource reference mapping for the data source matches the JNDI name you gave the data source in previous sections.  If you are not sure you can use the Browse button to pick the name of the data source from a list.  Once your resource reference mapping is set press the Next button.
	__11.  On Step 10: Map virtual hosts for web modules select myhost from the drop down menu and press the Next button.  This choice will make the application only available by using the was.myhost.com host name on port 80.
	__12.  Click the link for Step 15 on the left to skip to this step.
	__13.  On Step 15: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__14.  Click the Save link in the messages at the bottom of the Admin Console and be sure the configuration is synchronized with the Node.
	__15.  In the navigation pane of the Admin Console select Servers → Server Types → Web Servers.
	__16.  Check the checkbox next to OnlineStoreWebServer and click the Stop button.
	__17.  Check the checkbox next to OnlineStoreWebServer and click the Start button.
	__18.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__19.  Check the checkbox next to the OnlineStore application and press the Start button.  Wait for a message that the application started successfully.
	__20.  Logout of the Admin Console.

	Part 3 -  Test the OnlineStore Application
	__1.  Close all open web browsers, including the Admin Console.
	__2.  Open a web browser and enter http://was.myhost.com/Store in the address bar. Note that the first request may take a while as the application is initialized.
	__3.  Notice that in the left navigation there is an area that shows which server responded with your request.
	__4.  Click the Show cookies button on the left.
	__5.  Note that the dialog is empty which means there is no session cookie and you are viewed as a new client.
	__6.  Click the OK button to close the dialog.
	__7.  Register a new customer.  Make sure you do not register as an ID that is already in the database.  The first attempt to register will also probably take longer as the database connection is being initialized.
	__8.  Try some of the other functions of the applications like browsing products, adding and removing items from the cart, submitting orders, and viewing the orders for your user.
	__9.  Make sure you are logged in to the OnlineStore application.
	__10.  Click the Show cookies button on the left.
	__11.  Note the last few characters of the session id cookie before the colon ':'.  You do not need the whole value but just enough to recognize if it changes.
	__12.  Click the OK button to close the dialog.
	__13.  Close all open web browsers.
	__14.  Open a web browser and enter http://was.myhost.com/Store in the address bar.
	__15.  Log back in to the OnlineStore application using the id you registered.
	__16.  Click the Show cookies button on the left.
	__17.  Note the last few characters of the session id cookie before the colon ':'.  The value has changed to indicate that the server views this as a new session since you opened a new browser.  If you see exactly the same value make sure you closed every browser window before trying to access the application again.
	__18.  Notice that the cluster member that is handling your requests should be different than the one that was handling requests the first time.  This is the load balancing of clients between cluster members.

	Part 4 -  Test Server Failover
	__1.  Close all open web browsers.
	__2.  Open a web browser and enter http://localhost:9061/ibm/console in the address bar, the URL of the Deployment Manager Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the navigation pane select Servers → Server Types → Web servers.
	__5.  Click the link for the OnlineStoreWebServer.
	__6.  Under the Additional Properties section click the link for Plug-in properties.
	__7.  Scroll down to the bottom of the page and change the Log level setting to Stats.  Press the OK button when the settings match that below.
	__8.  Click the Save link in the messages at the top of the admin console.
	__9.  Make sure the changes are synchronized with the nodes. Click OK.
	__10.  Check the checkbox next to OnlineStoreWebServer and click the Stop button.
	__11.  Check the checkbox next to OnlineStoreWebServer and click the Start button.
	__12.  Open a new web browser and go to the homepage of the application at http://was.myhost.com/Store.
	__13.  Login as an existing user and submit a few requests as you have done before. Make sure that you do not “Logout” of the application.
	__14.  You should see that all of the last few requests have been handled by the same server.  Note which cluster member is now processing all of your requests.
	__15.  Keep the browser window you have been using to submit requests open. This step is critical so you retain the session associated with the user that is logged in.
	__16.  In the navigation pane of the admin console, select Servers → Server Types → Web servers if you are not there already.
	__17.  Click the link for the OnlineStoreWebServer.
	__18.  Under the Additional Properties section click the link for Plug-in properties.
	__19.  Click the 'Runtime' tab at the top of the page of plug-in properties.
	__20.  Next to the name of the plug-in log, click the View button.
	__21.  At the top of the log display, check that there are not more “Total” lines than the “Filtered total”.  If there are, this means you may not be looking at the bottom of the log file.  If this is the case enter a range that would include the last lines of the log file in the “Retrieve Lines” box and hit the 'Refresh' button.
	__22.  Look at the details of how the requests were routed.  You should see that initially that requests may have gone to both servers but then all requests start going to only one server.
	__23.  In the navigation pane of the Admin Console select Servers → Server Types → WebSphere application servers.
	__24.  In the list of Application Servers, check the checkbox next to the server that processed your requests and press the Stop button.  Below we are stopping the 'Clustered2' server but your server that was handling requests may be different.
	__25.  Click the OK button to confirm that you want to stop the server.
	__26.  Click the OK button after all the messages about stopping the server have been displayed.
	__27.  Back in the list of servers verify the server that had been processing your requests is stopped.
	__28.  Return to the web browser you were using for the OnlineStore application.
	__29.  Submit another request except a request to logout.  The application will continue to function as normal.  You should see that now the other server is handling your requests.
	__30.  In the navigation pane of the admin console, select Servers → Server Types → Web servers if you are not there already.
	__31.  Click the link for the OnlineStoreWebServer.
	__32.  Under the Additional Properties section click the link for Plug-in properties.
	__33.  Click the 'Runtime' tab at the top of the page of plug-in properties.
	__34.  Next to the name of the plug-in log, click the View button.
	__35.  Again check that there are not more “Total” lines than the “Filtered total”.  If there are, this means you may not be looking at the bottom of the log file.  If this is the case enter a range that would include the last lines of the log file in the “Retrieve Lines” box and hit the 'Refresh' button.
	__36.  Look at the details of how the requests were routed.  You should see a few messages about failing to connect to the original server and then the server being “marked down”.  

	Part 5 -  Examine Distributed Sessions
	__1.  If you closed the admin console then open a web browser and enter http://localhost:9061/ibm/console in the address bar, the URL of the Deployment Manager Admin Console and login as the 'wasadmin' user if you are not already.
	__2.  In the navigation pane select Servers → Server Types → WebSphere application servers.
	__3.  Select the link for the first clustered server in the list.
	__4.  On the right side, in the Container Settings section, click the link for Session management.
	__5.  On the right side, under the Additional Properties, select Distributed environment settings.
	__6.  Note that the current settings already use memory-to-memory replication for distributed sessions.
	__7.  Click the link for Memory-to-memory replication.
	__8.  Notice that the setting is already using a “Replication domain” that matches the name of the cluster.
	__9.  Close the web browser you were using to test the application.
	__10.  Logout of the Admin Console and close the web browser.
	__11.  Close any extra web browsers, File Browser windows, or command prompts you may have open.

	Part 6 -  Review

	Alternate Lab 1 -  Enable JMS Messaging Using Default Messaging
	Part 1 -  Configure Service Integration Bus
	__1.  If it is not already running, start the server using the method you are most familiar with.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the navigation pane, select Service integration -> Buses.
	__5.  At the Buses list, press New.
	__6.  For the properties of the new Bus change the following properties.
	__7.  When the properties appear as above press the Next button.
	__8.  Press the Finish button to create the bus.
	__9.  In the list of Buses click the link for the OnlineStoreBus.
	__10.  Under the Topology section click the link for Bus members.
	__11.  Press the Add button.
	__12.  Accept the defaults for Server and press the Next button.
	__13.  Select the Data store option for type of message store.
	__14.  Press the Next button when the option to use a Data store is selected.
	__15.  Leave the default option of Create default data source with generated JNDI name selected and press the Next button.
	__16.  Leave the default options under Tune performance parameters so that the heap size is not adjusted and press the Next button.
	__17.  Press the Finish button to add the server as a Bus member.
	__18.  Ensure the new server is added to the list of bus members.
	__19.  In the “Breadcrumb” trail at the top of the page click the link for OnlineStoreBus to return to the properties of the Bus.
	__20.  Under the Destination Resources section click the link for Destinations.
	__21.  Press the New button.
	__22.  Select a destination type of Queue and press the Next button.
	__23.  Fill in OnlineStoreQueue as the Identifier and press the Next button.
	__24.  Leave the server as the bus member assigned to the Queue and press the Next button.
	__25.  Press the Finish button to complete creating the Queue.
	__26.  Ensure the Queue is listed on the list.
	__27.  Click the Save link in the messages at the top of the Admin Console.

	Part 2 -  Configure the Default Messaging Provider
	__1.  In the navigation pane select Resources -> JMS -> Connection factories.
	__2.  Use the drop down for the Scope setting at the top of the list to select Cell=<cellname>.  Once the scope of your cell is shown press the New button.
	__3.  Select the radio button for Default messaging provider and press the OK button.
	__4.  At the New JMS Connection Factory page, enter the following information.  Write down the JNDI Name of the Connection Factory in the “Lab 7 & Alternate Lab 1” section of the Lab Notes.  Note the screenshots below only show the sections that have settings that are changed.
	__5.  When the properties match that above press the OK button.
	__6.  Click the link in the navigation pane for Resources -> JMS  -> Queues.
	__7.  Check that you are at the cell scope as in previous sections of this lab.  If you need to switch scope, select the scope using the drop down list.
	__8.  At the Queues list, press the New button.
	__9.  Select the radio button for Default messaging provider and press the OK button.
	__10.  At the New Queue page, enter the following information.  Leave the rest of the settings with the defaults.  Write down the JNDI Name of the Queue in the “Lab 7 & Alternate Lab 1” section of the Lab Notes.  Note the screenshots below only show the sections that have settings that are changed.
	__11.  When the values match those above press the OK button.
	__12.  Click the Save link in the messages at the top of the Admin Console.

	Part 3 -  Configure the JMS Activation Specification
	__1.  In the navigation pane select Resources -> JMS -> Activation specifications.
	__2.  Check that you are at the cell scope as in previous sections of this lab.  If you need to switch scope, select the scope using the drop down list.
	__3.  At the JMS Activation Specifications list, press the New button.
	__4.  Select Default messaging provider as the choice for provider and press the OK button.
	__5.  At the New Activation Specification page, enter the following information but do not press the OK button yet.
	__6.  Check that the Destination JNDI name matches the value you had written down in the Lab Notes section.
	__7.  Write down the JNDI name of the Activation Specification in the “Lab7 & Alternate Lab 1” section of the Lab Notes.
	__8.  When the properties match that shown in the previous steps press the OK button.
	__9.  Click the Save link in the messages at the top of the Admin Console.
	__10.  Expand the Troubleshooting section in the navigation panel and expand Runtime Messages.
	__11.  Click the link for Runtime Error messages.
	__12.  Check that your settings for runtime events are set to 'Warning' or 'Error'.  If it is not, change the setting to 'Warning', press the Apply button, and save the configuration.
	__13.  Logout of the Admin Console and close the browser.
	__14.  Restart your Application Server.

	Part 4 -  Install a Messaging Application
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  Expand the Troubleshooting section in the navigation panel and expand Runtime Messages.
	__4.  Click the link for Runtime Error messages.
	__5.  Make sure that you do not see any errors related to messaging that occurred while starting the server.  If you do, contact your instructor so you can resolve these before continuing.
	__6.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__7.  Check the checkbox next to the OnlineStore application and press the Update button.
	__8.  Leave the option of Replace the entire application selected and Local File System radio button.
	__9.  Hit the Browse button next to the Full path text box.
	__10.  Navigate to the <LABFILES_DIR>/Messaging directory, select the OnlineStore‑Messaging.ear file, and press Open.
	__11.  With the path to the EAR file filled in press the Next button.
	__12.  Check the option for Detailed installation.  This will show all steps.
	__13.  Press the Next button.
	__14.  On Step 1: Select Installation options leave the default options and press the Next button.
	__15.  On Step 2: Map modules to servers check to see if the 'OnlineStoreWeb' module is mapped to both servers in the list.  If it is not, check the checkbox next to the OnlineStoreWeb module.  Select both servers from the list above by holding down the CTRL key as you select each one.  Press the Apply button to apply the changes to the mapping of the web module.  
	__16.  Make sure the OnlineStoreWeb module is mapped to BOTH servers as shown below and press the Next button.
	__17.  On the list of steps on the left click the link for Step 6 to skip to this step.
	__18.  On Step 6: Provide listener bindings For message-driven beans use the following options for the PurchasePrinter EJB.  Check the value for this compares with the value you have written down in the Lab Notes section.
	__19.  Once you have checked this value press the Next button.
	__20.  Click the link for Step 10 on the list of steps on the left to skip to this step.
	__21.  On Step 10: Map resource references to resources check that the JNDI name of the Connection Factory listed matches what you had written down for these values in the Lab Notes section.  Also check that the JNDI name of the data source is still 'jdbc/store'.  Note that you will need to scroll around to find these values and the screenshots below only show the part of the screen with the settings.  Also note that the screenshot showing the Connection Factory below does not show the entire JNDI name value.  If you need to change these values for any reason you can use the Browse button to select the configured resource from a list which will eliminate chance for errors due to typos.
	__22.  Once you have checked these values press the Next button.
	__23.  On Step 11: Map resource environment entry references to resources check that the JNDI name of the queue matches what you had written down for these values in the Lab Notes section.
	__24.  Once you have checked these values press the Next button.
	__25.  At this point you will get a warning message.  Everything is fine.  Press the Continue button.
	__26.  On Step 12: Map virtual hosts for web modules select myhost from the drop down menu. This option may already be filled in but double check.
	__27.  On the list of steps on the left click the link for Step 17 to skip to the summary.
	__28.  On Step 17: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__29.  Click the Save link in the messages at the bottom of the Admin Console.
	__30.  In the list of Enterprise Applications, be sure the OnlineStore application is started. Navigate to Applications → Application Types → WebSphere enterprise applications if this list is not automatically displayed.

	Part 5 -  Test the Application
	__1.  Make sure your IHS server is running.
	__2.  Open a web browser and enter http://was.myhost.com/Store in the address bar.
	__3.  Login as a user that already exists on the system and has placed orders.
	__4.  Once you have logged in, click on the link on the left for Request Email.
	__5.  Once this page is displayed, click on the Request button.  This will generate a message from the Servlet that responds to the request.  You should get a fairly quick reply.  The normal response is shown below.
	__6.  In the Admin Console click on the link for Troubleshooting -> Logs and Trace.
	__7.  Click the link for server1 in the list.
	__8.  In the list of links on the bottom click the 'View HPEL logs and trace' link.
	__9.  Click the '+' sign next to the 'Content and Filtering Details' section to expand it.
	__10.  In the 'View Contents' section of the filter settings, uncheck the setting for 'System err' and 'Logs and trace' as shown below and click the Apply button.
	__11.  Scroll down and look at the last messages in the list.  As shown below there should be a message with the text “In onMessage” followed by a message for each purchase made by the user.
	__12.  Close the web browser you were using to test the application.
	__13.  Logout of the Admin Console and close the web browser.

	Part 6 -  Review




