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Lab 1 - Configure the Development Environment
Throughout these labs, you will be developing Java EE components with two main pieces 
of software: IBM WebSphere 8.0 and IBM Rational Application Developer 8.0.

IBM WebSphere 8.0 (WebSphere) is a JEE application server that serves up JEE 
applications. 

Rational Application Developer (RAD) provides tools that make it easier to develop 
applications utilizing specific WebSphere technologies and provides control of the 
WebSphere server.  Based on the Eclipse tool, it is the programming environment we will 
use for this class. 

In this lab exercise, we will configure WebSphere and RAD to form our development 
environment. 

Part 1 - Configure a server in RAD
We need to configure RAD to be able to communicate with the WebSphere instance that 
is installed on our lab PC.  Doing so will allow us to perform simple operations with the 
server (e.g. Starting, stopping and deploying applications).  

RAD has already been installed on your computer.  We just need to configure it. 

__1. Start RAD from the Rational Application Developer icon on the desktop. If the 
icon is not there you can start RAD from Start menu and then select All Programs > 
IBM Software Delivery Platform >IBM Rational Application Developer 8.0 > 
Rational Application Developer. 

RAD will launch.

You will be prompted to select a Workspace. 

__2. Set the Workspace to C:\workspace

__3. Click OK.

RAD will start.  If this is the first time RAD has been started in this workspace (which is 
the likely case), RAD will display a dialog box called Configuring the WebSphere 
Application Server.
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__4. Click Next.  On the next page of the dialog, RAD asks you to configure the user id 
and password for the WebSphere instance.  Enter the following values:

User ID: wasadmin

Password: wasadmin

Retype Password: wasadmin
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__5. Click Finish.

__6. If the Features with Trial Licenses dialog appears, click Ignore.

__7. RAD will open, displaying the Welcome view.  Click on the “X” icon on the 
Welcome view to close it if appears.
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As mentioned earlier, RAD is built on top of Eclipse. If you are familiar with Eclipse, 
you should have no problems using RAD.  

Part 2 - Disable Automatic Publishing
By default, RAD will publish your work to the server every time you edit and save a file. 
Although this sounds like a good idea, in practice, it leads to a continuous stream of 
specious warnings and errors, not to mention delays.  We will shut off this behavior in the 
server we just created.

__1. In the Servers view, double-click on WebSphere Application Server v8.0 at 
localhost.

__2. RAD will display the server configuration window.  Look for the Publishing tab and 
click on it to expand it.

__3. Click the radio button for Never publish automatically, and then save and close the 
file.

Part 3 - Working with the Server
Throughout this class, we will be using this view to perform 3 basic operations: server 
stop, start and publish.  We will discuss publishing in a later lab, right now let's focus on 
starting and stopping the server. 

__1. Let us start things off by starting the server.  In the Servers view, right click on the 
server called “WebSphere Application Server v8.0 at localhost and then select Start.

The Console view should automatically open.  This will allow us to “see” WebSphere 
booting.  Eventually, the server will start.  Once it does, click on the Servers tab to 
display the Servers view again.  

After RAD finishes publishing the server State should be Started.
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__2. Examine the Console window by clicking the Console tab. 

In later lab steps, when we ask you to refer to the server console, this is the view we will 
be referring to.  

__3. Let us try stopping the server.  Go back to the Servers view. 

__4. Right click on the server and select Stop.

As with starting the server, the console view will open briefly.  Then the Server view will 
appear, listing the status as Stopped.

You have stopped the server.

Part 4 - Review
In this lab, you configured the development environment.

You started things off by configuring environment to recognize the WebSphere 
Application Server, which will be used to host our web service applications.

You saw how to start and stop a WebSphere Server instance.
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Lab 2 - Creating A Stateless Session Bean
Time for Lab: 30 minutes

In this lab exercise, you will use RAD to create an EJB 3.1 stateless session bean, which 
will then be tested by a web client. 

Part 1 - Create the Projects
RAD uses the concept of projects to group code.  The projects we need to create are the 
following:

● An EJB project called SimpleEJBProject.  This will contain our core EJB code. 
In this lab exercise, it will merely contain the stateless session bean.

● An EJB client project called SimpleEJBProjectClient.  This will contain the 
interfaces required for the EJBs in SimpleEJBProject.   In this lab exercise, it will 
contain the local interface for the stateless session bean. 

● A web project  called EJBWebApp.  This will contain the web layer that will act 
as a testing point for our EJBs.  In this lab, we will simply create a servlet that 
invokes the session bean.

● An enterprise project called EJBEARProject.  This will contain all the other 
projects and serve as a single deployable unit. 

We will use these projects throughout this course's lab exercises.

__1. If it is not already running, start RAD by double-clicking on the desktop icon. If 
prompted open the 'C:\workspace' workspace.

Recall that in RAD, a view is a particular window (e.g. Servers view displays information 
about servers) and a perspective is a collection of views with a common purpose (e.g. the 
data perspective displays several database related views)

Copyright 2013 Web Age Solutions Inc. 8

EVALUATIO
N O

NLY



RAD will be displaying the Java EE perspective. 

We will first create the enterprise project. 

__2. From the menu, select File → New → Enterprise Application Project.  The New 
EAR Application Project window will appear. 

__3. For the Project name, enter EJBEARProject

__4. Click Finish.  The project will be created and listed in the Enterprise Explorer 
view. 
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Next, we create the EJB Project.  

__5. From the menu, select File → New → EJB Project.  The New EJB Project window 
will appear.

__6. Set the Project name to be SimpleEJBProject  but do not move to the next page.

__7. In the main project wizard window, check the option for 'Add project to an EAR' 
and be sure the EAR project you created is selected.

__8. Once your project settings appear as below, click Next.

__9. Accept the Java options and click the Next button.

__10. Notice that the check box to create a client JAR is selected.  This wizard will create 
an additional JAR that will be used to contain EJB client interfaces. 
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__11. Click Finish.

The projects will be created and displayed in the Enterprise Explorer view. There will 
be a warning but you can ignore it until you create the first EJB.

Finally, we can create the web project that will contain our EJB web clients. 

__12. If the Technology Quickstarts view appears, de-select the checkbox for Open on 
creation of new projects at the right end of the page as shown below, and then close it 
by clicking on the large X next to the title. 

__13. From the menu, select File → New → Dynamic Web Project.  The New Dynamic 
Web Project screen will appear.

__14. For the Project Name, enter EJBWebApp but remain on the first page.

__15. For the Configuration setting, use the drop-down to select JavaServer Faces v2.0 
Project.

__16. Check the option for 'Add project to an EAR' and be sure the EAR project you 
created is selected.
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__17. Once your project settings appear as below, click the Finish button, and then click 
Yes when RAD asks if you want to switch to the Web Perspective.

The dynamic web project will be created.  

The projects have been created.  We now need to set a few library dependencies.  Since 
the components in the web project will be acting as clients to the EJB, we need to make 
sure that the SimpleEJBProjectClient is in the web project's class path.  

__18. Right-click on the white area of the Enterprise Explorer view and select Refresh.

__19. Right-click on EJBWebApp and select Properties.  The Properties for 
EJBWebApp screen will appear.  

__20. In the left pane, click Deployment Assembly.
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__21. In the right pane, click the tab for 'Manifest Entries'.

__22. Click the Add button to bring up a dialog to add an entry.

__23. Select the SimpleEJBProjectClient.jar entry and click the Finish button.

__24. Using the same procedure as above, add the SimpleEJBProject.jar to the manifest 
entries as well.

__25. Check that your Manifest Entries tab appears as below and click the OK button.

Now, code created in the web project will be able to use the interface code created in the 
client project.  

We can now begin coding the bean.
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Part 2 - Develop the Bean
We will now begin coding the actual session bean.  The session bean we will create is a 
very simple one; it will be called the Greeting and will simply have one business method 
called sayHello(), which will return an appropriate String.

__1. In the Project Explorer view, right-click on SimpleEJBProject and select New → 
Session Bean(EJB 3.x).

The Create EJB 3.x Session Bean window will appear. 

__2. Set the Java Package to simple.stateless

__3. Set the Class name to Greeting

__4. Leave the State type as Stateless

__5. Under Create business interface, check Local and un-check No-interface.  

This means that RAD will generate a local interface for this EJB for us. 

Your screen should now look like the following:

__6. Click Finish.

RAD will create the required components. 

An editor should now be open on Greeting.java – which is the bean implementation 
class which is where we will place our bean business logic.  It has been partially 
generated by RAD. 

Immediately notice the following about the generated bean class. 
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■ The @Stateless annotation.  This annotation marks the class as a stateless 
session bean.  

■ The class implements an interface called GreetingLocal.  As you may 
have guessed, GreetingLocal is the EJB's local interface; any methods 
that a client wishes to invoke must be declared on that interface and 
implemented in this class. 

We will come back and add code to this bean class later; let us first update the local 
interface to declare what methods this EJB will support.  

__7. In the Enterprise Explorer, expand SimpleEJBProjectClient → ejbModule → 
simple.stateless.

Recall that this project (SimpleEJBProjectClient) contains our EJB client code; it makes 
sense then that the EJB's local interface was created here by RAD.  

__8. Double-click on GreetingLocal.java to open it in the editor.  

Note that it is an interface, not a class. 

__9. Add the following method declaration to the interface.  

public String sayHello(String name);

__10. Save the file. There should be no errors in the file. (An error, however, will appear 
back in the Greeting class; we will fix that in a moment).

You have completed coding the business interface of our session bean.  This will 
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represent the view that any client using this session bean will work with.  As you can see, 
it is very simple; this business interface states that the session bean will have only one 
method, called sayHello which returns a string. 

We can now add code to the bean implementation class, which contains the actual 
business logic for the methods defined in the business interface.  

__11. Switch back to Greeting.java.

An error has appeared here; it is because this class implements an interface 
(GreetingLocal), but has not implemented that interface's methods (sayHello).  

Let us get RAD to show us what methods need to be implemented. 

__12. In the margin, click the red X.  A pop up will appear:

__13. Double-click Add unimplemented methods.

RAD will add a method to the class:
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This is the code we need to complete.  

__14. Delete the contents of this method; instead, set it to the following in bold:

public String sayHello(String name) {
if (name == null || name.isEmpty()) {

return "Hello World!";
} else {

return "Hello " + name + "!";
}

}

Very simple!  

__15. Save the file.  There should be no errors.

You have successfully finished coding the stateless session bean!   You have created a 
local interface which declares the sayHello method, and also coded an appropriate bean 
implementation class that provides the actual business logic for that method.  

Part 3 - Create the Web Client
Since the EJB has been coded, we need a mechanism to test it to make sure it works.  To 
do this, we will create a simple test client. 

Our client will be a simple JSF page and managed bean.  Much of the code will be 
provided for you so we can focus on the interaction with the EJB.

__1. In the Project Explorer, right click on EJBWebApp and select New → Package.

__2. Set the name of the new package to simple.jsf and click the Finish button.

__3. Open a Windows Explorer file browser window and navigate to 
'C:\LabFiles\StatelessEJB' (assuming the lab files for the class are located in 
C:\LabFiles)

__4. Copy the StatelessController.java file.
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__5. Return to RAD and find the Java package you created under EJBWebApp → Java 
Resources → src → simple.jsf.

__6. Select the package by clicking it and paste the file (you can use CTRL-V or Edit → 
Paste from the RAD menus).

__7. Expand the package and make sure the file appears in the correct location as shown 
below.

__8. Double click the StatelessController.java file to open it.

Notice the Java class already has some code including a few fields for a reference to the 
'GreetingLocal' EJB and a few fields for the JSF page you will import in a few steps.  It is 
also a JSF managed bean.

@ManagedBean
public class StatelessController {

private String message;
private String name;

private GreetingLocal greetingBean;
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__9. Find the currently empty constructor for the StatelessController class and add the 
following code to initialize the field for the EJB.  This uses a JNDI name that follows the 
standardized JNDI name patterns introduced in EJB 3.1.

public StatelessController() {
try {

Context ctx = new InitialContext();
greetingBean = (GreetingLocal) ctx
.lookup("java:app/SimpleEJBProject/Greeting");

} catch (NamingException e) {
e.printStackTrace();

}
}

__10. Find the 'displayGreeting' method and add the line of code in bold below.  This 
will use the EJB to get the greeting and then store the message in a field the JSF page will 
use to display it.

public String displayGreeting() {
// use EJB here
message = greetingBean.sayHello(name);
return null;

}

__11. Save the code.  Make sure there are no errors.

__12. Return to the Windows Explorer file browser window showing the 
'C:\LabFiles\StatelessEJB' directory and open a new one if you had closed it.

__13. Copy the stateless.xhtml file.

__14. Return to RAD and find the web resources folder under EJBWebApp → 
WebContent.

__15. Select the 'WebContent' folder by clicking it and paste the file (you can use CTRL-
V or Edit → Paste from the RAD menus).

__16. Expand the folder and make sure the file appears in the correct location as shown 
below.

__17. Double click the stateless.xhtml file to open it.
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__18. You don't have to change any code but notice the core of the code is a form that 
will submit a name value by calling the 'displayGreeting' method and then display the 
'message' in an output component.

<h:form>
Name: <h:inputText value="#{statelessController.name}">
</h:inputText><br/>
<h:commandButton value="Get Greeting" 
action="#{statelessController.displayGreeting}"></h:commandButton>
</h:form>
<p><h:outputText value="#{statelessController.message}" /></p>

You have successfully completed coding the EJB client.  Once the application has been 
deployed, we can now test everything by simply browsing to this JSF page.  

So now all we need to do is deploy and test. 

__19. Close all open files.

Part 4 - Deploy and Test
Since our code is complete, we can deploy it to WebSphere, and test it once it has started. 
We will do this now. 

__1. Locate the Servers view, at the bottom middle of RAD.

This server listed here is the WebSphere test environment that was configured in a 
previous lab. All we need to do is add the project to the server and then start it.  

__2. Right-click on the server and select Add and Remove...  

__3. The Add and Remove screen will appear.  Click Add All and click Finish.
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__4. Right-click on the server and select Publish.  This will start the server as well as 
deploy the project. 

__5. Wait for the server to start.  This may take a few minutes, depending on how 
powerful your computer is.  

The Console view will open, showing the boot process.  

Eventually, the console will show a screen like the following:

__6. Switch back to the Servers view.  

The server State should become Started and the server's Status should be Synchronized. 
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This means the server is running, and the latest version of the code you are writing has 
been pushed onto the server.  It is ready for testing!

__7. In the Enterprise Explorer, right-click on the file stateless.xhtml and then select 
Run As → Run on Server.

__8. The Run On Server dialog will appear.  Click to select the checkbox for Always 
use this server when running this project, then click Finish.

You should see the following:
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__9. Fill in the box with some name and click the 'Get Greeting' button.

Success!  It looks like the JSF page is successfully invoking the EJB!

Congratulations!  You have successfully developed and tested an EJB 3.1 Stateless 
Session Bean.

__10. Close the web browser view.
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Part 5 - Use Injection to Initialize EJB
Although the standardized JNDI name used to lookup the EJB would be portable between 
application server vendors it was still a little complex.  It turns out that since there is only 
one implementation of this EJB and it is in the same EAR project there is an even easier 
way to initialize the EJB with @EJB injection.

__1. Return to RAD and find the Java package under EJBWebApp → Java Resources 
→ src → simple.jsf.

__2. Double click the StatelessController.java file to open it.

__3. Find the constructor for the StatelessController class and delete all of the code so the 
constructor is again empty.

public StatelessController() {

}

__4. Find the 'greetingBean' field in the class that refers to the EJB and add the '@EJB' 
annotation shown below immediately before the field.  You will have errors fixed in the 
next step.

@ManagedBean
public class StatelessController {

private String message;
private String name;

@EJB
private GreetingLocal greetingBean;

__5. Organize imports by selecting Source → Organize Imports from the RAD menus.

__6. Save the code.  Make sure there are no errors.

__7. In the RAD Servers view, right-click on the server and select Publish.  This will 
update the code on the server.
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__8. In the Enterprise Explorer, right-click on the file stateless.xhtml and then select 
Run As → Run on Server.  You should again see the JSF form:

__9. Fill in the box with some name and click the 'Get Greeting' button.  Make sure you 
still get a response.  This response verifies that the field for the EJB is still being 
initialized.

__10. Close the web browser.

__11. Stop the server.  To do this, right-click on the server (in the Servers view) and 
select Stop.

__12. Close all open files. (Ctrl+Shift+W)
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Part 6 - Review
In this lab, you:

■ Created and configured projects to hold our lab exercise code.

■ Developed a stateless session bean by creating a business interface and a 
bean class.  

■ Modified a JSF test client to work with the EJB and make sure the EJB did 
in fact work properly.

■ Saw how to deploy to and start the WebSphere test environment.
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Lab 3 - Creating A Stateful Session Bean
In this exercise, you will create a stateful session bean.  You will also create a web client 
for this stateful session bean.

Part 1 - Create the Stateful Session Bean
In this part of the lab, we will create the stateful session bean that will be the core of our 
application.  The stateful session bean will manage a ToDo list.  Simply put, it will 
maintain a member variable called items which will be a simple List, representing a list 
of Strings. This items variable will represent the state of the session bean.

The bean will be able to perform 3 basic operations: it will be able to add an item to its 
vector; it will be able to return a list of all added items; and it will be able to empty its 
own list. Let us create this bean now.

__1. In the Enterprise Explorer, right-click on SimpleEJBProject and New → Session 
Bean.

The Create EJB 3.x Session Bean window will appear.

__2. Set the Java package to be simple.stateful

__3. Set the Class name to be ToDo

__4. Change the State type to Stateful

__5. Under Create business interface, check Local and un-check No-interface.  

__6. Click the Next button.
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__7. Uncheck Inherited abstract methods and Constructors from superclass.

__8. Click Finish.

RAD will open an editor on the ToDo.java bean implementation class.

In the previous lab exercise, we coded the interface first, and then added unimplemented 
methods to the bean implementation class; in this lab exercise, we will do things in the 
opposite direction.  We will code the implementation methods first, and then promote 
them to the local interface.  

Examine the opened ToDo.java.  Once again, notice the annotation - @Stateful which 
marks this class as being a stateful session bean.  Also note that the class implements the 
local interface ToDoLocal.  
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We can now start adding implementation code. 

Let us declare that this class has some state.  Recall that as we said earlier, this bean's 
state will be reflected by a List called items which will be an instance variable (member 
variable) for the class. 

__9. Add this declaration immediately after the class declaration as follows (in bold)

@Stateful
public class ToDo implements ToDoLocal {

private List<String> items = new ArrayList<String>();

__10. An error will appear.  Organize imports (Ctrl-Shift-O) to import the List and 
ArrayList class. It turns out that there is more than one class called List in the classpath, 
so RAD will show the Organize Imports dialog.  Choose java.util.List and click Finish

__11. Save the class.  There should be no errors.  

Now we can start writing the actual EJB methods.   Our EJB will support 3 methods 
addItem, clearItems and listItems.

These 3 methods, which will be invokable by the client, are what allows a client to 
interact with the EJB's state – they are essentially front ends to the list that this EJB 
maintains.  We can now add these methods.

__12. Add the following method to the class.  Make sure it is within the curly brackets 
for the class but outside the constructor.

public void addItem(String item) {
    items.add(item);
}

Recall that this method will be called by a client.  A client wishing to add an item (a 
String) to the do list will use this method.   Ignore the warning.
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__13. Now, add the following method to the class:

public void clearItems() {
items.clear();

}

This method will clear all the elements of the items list. 

__14. Add the following method to the class:

public List<String> listItems() {
return items;

}

A client can call this method to retrieve the list. 

__15. Save the code.  There should be no errors.

We now need to make sure these 3 methods are declared in the local interface.  We could 
do this by opening open the local interface class (ToDoLocal) and copying and pasting 
the method declarations in.  That, however, would be a little cumbersome. Instead, we 
will have RAD do it for us! 

__16. Examine the Outline view (on the right).

As implied, it shows an outline of the class.  

__17. Holding down the Ctrl button (this performs a multiple select), click the three 
methods addItem(String), clearItems() and listItems().

__18. Right-click on the selected methods and select Refactor → Pull Up...

The Refactoring window will appear. 
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__19. Make sure your wizard appears as below and press the Finish button.

RAD will go off and add the methods to the local interface.  You will have an error in 
ToDo.java which will be fixed next.

__20. In the Project Explorer, expand SimpleEJBProjectClient → ejbModule → 
simple.stateful and double click ToDoLocal.java.

The interface will open in an editor.

Notice that the methods were indeed added to the interface.  Very nice! 

__21. Although the methods were added to the interface, the import of the List class was 
not.  This creates some compilation problems.  Right-click in the editor and select Source 
-->Organize Imports to fix the problem.  Once again, select java.util.List and then click 
Finish.

You can see that the refactoring tool has made it somewhat easier for us to add the 
methods to the EJB interface.  The tool was designed more to “Pull up” definitions from 
a subclass to a superclass though so we had to make some adjustments to ensure it 
generated code properly.  In the future you can decide for yourself if it is easier to use this 
tool or simply copy the method definitions.

__22. Save the file and check the Problems view to be sure you do not have any errors.

We have completed coding our stateful session bean! We now need to create a test client 
for this newly created and deployed EJB.  
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Part 2 - Create A Web Client
We will create a client to test this bean.  You will be provided some JSF code that will act 
as the EJB client.  Some properties of this code will be critical to preserve the state of the 
stateful session EJB.

__1. Open a Windows Explorer file browser window and navigate to 
'C:\LabFiles\StatefulEJB' (assuming the lab files for the class are located in 
C:\LabFiles)

__2. Copy the ToDoController.java file.

__3. Return to RAD and find the Java package under EJBWebApp → Java Resources 
→ src → simple.jsf.

__4. Select the package by clicking it and paste the file (you can use CTRL-V or Edit → 
Paste from the RAD menus).

__5. Expand the package and make sure the file appears in the correct location as shown 
below.
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__6. Double click the ToDoController.java file to open it.

Notice the code is already a JSF managed bean and has a field for storing a reference to 
the stateful EJB.  So as long as the JSF managed bean object is not discarded, the state 
maintained by the EJB will be available.

@ManagedBean
@SessionScoped
public class ToDoController {

@EJB
private ToDoLocal toDoBean;

The easiest way to make sure the JSF managed bean is available over multiple requests is 
to store the bean in the user's session.  Notice that the managed bean has the 
@SessionScoped annotation applied to it.

Now there are a few methods to complete to work with the EJB.

__7. Find the 'clearList' method and add the code in bold below.  This will clear the list 
in the EJB and make sure the JSF bean has the current list.

public void clearList() {
// add EJB method calls
toDoBean.clearItems();
currentList = toDoBean.listItems();
currentItem = "";

}

__8. Find the 'addItem' method and add the code in bold below.  This will add the item 
submitted by the user to the EJB list and make sure the JSF bean has the current list.

public void addItem() {
// add EJB method calls
toDoBean.addItem(currentItem);
currentList = toDoBean.listItems();
currentItem = "";

}

__9. Save the code.  Make sure there are no errors.
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__10. Return to the Windows Explorer file browser window showing the 
'C:\LabFiles\StatefulEJB' directory and open a new one if you had closed it.

__11. Copy the toDoStateful.xhtml file.

__12. Return to RAD and find the web resources folder under EJBWebApp → 
WebContent.

__13. Select the 'WebContent' folder by clicking it and paste the file (you can use CTRL-
V or Edit → Paste from the RAD menus).

__14. Expand the folder and make sure the file appears in the correct location as shown 
below.

__15. Double click the toDoStateful.xhtml file to open it.

You don't have to change any code but notice the core of the code is a form that the user 
can use to submit a task to add or to indicate the task list should be cleared.  There is also 
a table which will show the current content of the task list.

<h:form>
Task: <h:inputText value="#{toDoController.currentItem}">
</h:inputText><br/>
<h:commandButton value="Add Task" action="#{toDoController.addItem}">
</h:commandButton>
<h:commandButton value="Clear Tasks" 
action="#{toDoController.clearList}"></h:commandButton>
</h:form>
<h:dataTable border="1" value="#{toDoController.currentList}"

var="item">
...

</h:dataTable>

Copyright 2013 Web Age Solutions Inc. 34

EVALUATIO
N O

NLY



Part 3 - Test the Code
Let us deploy the project and start the server.

__1. Close all open files. (Ctrl+Shift+W)

__2. Publish the server.  (From the Servers view, right-click on the server and select 
Publish)  This will update the code on the server and start the server if needed.

Wait for the server to start. 

__3. In the Enterprise Explorer, right-click on toDoStateful.xhtml, and then select Run 
As → Run on Server

You should see the following:

__4. Enter some text into the task text box (e.g. Do Laundry) and click Add Task.  Check 
that the task is added to the list.

__5. Add a few more tasks, making sure that the tasks that were added previously are still 
listed.
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What is happening here?  Every time we click the Add Item button, the JSF page is 
sending the item to be added to a single unique instance of a stateful session bean, which 
is adding it to its state.  This is why, in between invocations from the browser, the 
application seems to "remember" what has previously been added.  

__6. Click the 'Clear Tasks' button to clear the list and then add some more items to the 
list again.

Congratulations! You have completed testing your stateful session bean.

__7. Close any open browser windows.

Part 4 - Review
In this lab you:

■ Created a stateful session bean.

■ Created a web client (a session-scoped JSF bean) for the stateful session 
bean.

■ Tested the stateful session bean and saw how it maintained state.
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	Lab 1 -  Configure the Development Environment
	Part 1 -  Configure a server in RAD
	__1.  Start RAD from the Rational Application Developer icon on the desktop. If the icon is not there you can start RAD from Start menu and then select All Programs > IBM Software Delivery Platform >IBM Rational Application Developer 8.0 > Rational Application Developer. 
	__2.  Set the Workspace to C:\workspace
	__3.  Click OK.
	__4.  Click Next.  On the next page of the dialog, RAD asks you to configure the user id and password for the WebSphere instance.  Enter the following values:
	__5.  Click Finish.
	__6.  If the Features with Trial Licenses dialog appears, click Ignore.
	__7.  RAD will open, displaying the Welcome view.  Click on the “X” icon on the Welcome view to close it if appears.

	Part 2 -  Disable Automatic Publishing
	__1.  In the Servers view, double-click on WebSphere Application Server v8.0 at localhost.
	__2.  RAD will display the server configuration window.  Look for the Publishing tab and click on it to expand it.
	__3.  Click the radio button for Never publish automatically, and then save and close the file.

	Part 3 -  Working with the Server
	__1.  Let us start things off by starting the server.  In the Servers view, right click on the server called “WebSphere Application Server v8.0 at localhost and then select Start.
	__2.  Examine the Console window by clicking the Console tab. 
	__3.  Let us try stopping the server.  Go back to the Servers view. 
	__4.  Right click on the server and select Stop.

	Part 4 -  Review

	Lab 2 -  Creating A Stateless Session Bean
	Part 1 -  Create the Projects
	__1.  If it is not already running, start RAD by double-clicking on the desktop icon. If prompted open the 'C:\workspace' workspace.
	We will first create the enterprise project. 
	__2.  From the menu, select File → New → Enterprise Application Project.  The New EAR Application Project window will appear. 
	__3.  For the Project name, enter EJBEARProject
	__4.  Click Finish.  The project will be created and listed in the Enterprise Explorer view. 
	__5.  From the menu, select File → New → EJB Project.  The New EJB Project window will appear.
	__6.  Set the Project name to be SimpleEJBProject  but do not move to the next page.
	__7.  In the main project wizard window, check the option for 'Add project to an EAR' and be sure the EAR project you created is selected.
	__8.  Once your project settings appear as below, click Next.
	__9.  Accept the Java options and click the Next button.
	__10.  Notice that the check box to create a client JAR is selected.  This wizard will create an additional JAR that will be used to contain EJB client interfaces. 
	__11.  Click Finish.
	__12.  If the Technology Quickstarts view appears, de-select the checkbox for Open on creation of new projects at the right end of the page as shown below, and then close it by clicking on the large X next to the title. 
	__13.  From the menu, select File → New → Dynamic Web Project.  The New Dynamic Web Project screen will appear.
	__14.  For the Project Name, enter EJBWebApp but remain on the first page.
	__15.  For the Configuration setting, use the drop-down to select JavaServer Faces v2.0 Project.
	__16.  Check the option for 'Add project to an EAR' and be sure the EAR project you created is selected.
	__17.  Once your project settings appear as below, click the Finish button, and then click Yes when RAD asks if you want to switch to the Web Perspective.
	__18.  Right-click on the white area of the Enterprise Explorer view and select Refresh.
	__19.  Right-click on EJBWebApp and select Properties.  The Properties for EJBWebApp screen will appear.  
	__20.  In the left pane, click Deployment Assembly.
	__21.  In the right pane, click the tab for 'Manifest Entries'.
	__22.  Click the Add button to bring up a dialog to add an entry.
	__23.  Select the SimpleEJBProjectClient.jar entry and click the Finish button.
	__24.  Using the same procedure as above, add the SimpleEJBProject.jar to the manifest entries as well.
	__25.  Check that your Manifest Entries tab appears as below and click the OK button.

	Part 2 -  Develop the Bean
	We will now begin coding the actual session bean.  The session bean we will create is a very simple one; it will be called the Greeting and will simply have one business method called sayHello(), which will return an appropriate String.
	__1.  In the Project Explorer view, right-click on SimpleEJBProject and select New → 
Session Bean(EJB 3.x).
	The Create EJB 3.x Session Bean window will appear. 
	__2.  Set the Java Package to simple.stateless
	__3.  Set the Class name to Greeting
	__4.  Leave the State type as Stateless
	__5.  Under Create business interface, check Local and un-check No-interface.  
	__6.  Click Finish.
	__7.  In the Enterprise Explorer, expand SimpleEJBProjectClient → ejbModule →  simple.stateless.
	__8.  Double-click on GreetingLocal.java to open it in the editor.  
	__9.  Add the following method declaration to the interface.  
	__10.  Save the file. There should be no errors in the file. (An error, however, will appear back in the Greeting class; we will fix that in a moment).
	__11.  Switch back to Greeting.java.
	__12.  In the margin, click the red X.  A pop up will appear:
	__13.  Double-click Add unimplemented methods.
	__14.  Delete the contents of this method; instead, set it to the following in bold:
	__15.  Save the file.  There should be no errors.

	Part 3 -  Create the Web Client
	__1.  In the Project Explorer, right click on EJBWebApp and select New → Package.
	__2.  Set the name of the new package to simple.jsf and click the Finish button.
	__3.  Open a Windows Explorer file browser window and navigate to 'C:\LabFiles\StatelessEJB' (assuming the lab files for the class are located in C:\LabFiles)
	__4.  Copy the StatelessController.java file.
	__5.  Return to RAD and find the Java package you created under EJBWebApp → Java Resources → src → simple.jsf.
	__6.  Select the package by clicking it and paste the file (you can use CTRL-V or Edit → Paste from the RAD menus).
	__7.  Expand the package and make sure the file appears in the correct location as shown below.
	__8.  Double click the StatelessController.java file to open it.
	__9.  Find the currently empty constructor for the StatelessController class and add the following code to initialize the field for the EJB.  This uses a JNDI name that follows the standardized JNDI name patterns introduced in EJB 3.1.
	__10.  Find the 'displayGreeting' method and add the line of code in bold below.  This will use the EJB to get the greeting and then store the message in a field the JSF page will use to display it.
	__11.  Save the code.  Make sure there are no errors.
	__12.  Return to the Windows Explorer file browser window showing the 'C:\LabFiles\StatelessEJB' directory and open a new one if you had closed it.
	__13.  Copy the stateless.xhtml file.
	__14.  Return to RAD and find the web resources folder under EJBWebApp → WebContent.
	__15.  Select the 'WebContent' folder by clicking it and paste the file (you can use CTRL-V or Edit → Paste from the RAD menus).
	__16.  Expand the folder and make sure the file appears in the correct location as shown below.
	__17.  Double click the stateless.xhtml file to open it.
	__18.  You don't have to change any code but notice the core of the code is a form that will submit a name value by calling the 'displayGreeting' method and then display the 'message' in an output component.
	__19.  Close all open files.

	Part 4 -  Deploy and Test
	__1.  Locate the Servers view, at the bottom middle of RAD.
	__2.  Right-click on the server and select Add and Remove...  
	__3.  The Add and Remove screen will appear.  Click Add All and click Finish.
	__4.  Right-click on the server and select Publish.  This will start the server as well as deploy the project. 
	__5.  Wait for the server to start.  This may take a few minutes, depending on how powerful your computer is.  
	__6.  Switch back to the Servers view.  
	__7.  In the Enterprise Explorer, right-click on the file stateless.xhtml and then select Run As → Run on Server.
	__8.  The Run On Server dialog will appear.  Click to select the checkbox for Always use this server when running this project, then click Finish.
	__9.  Fill in the box with some name and click the 'Get Greeting' button.
	__10.  Close the web browser view.

	Part 5 -  Use Injection to Initialize EJB
	__1.  Return to RAD and find the Java package under EJBWebApp → Java Resources → src → simple.jsf.
	__2.  Double click the StatelessController.java file to open it.
	__3.  Find the constructor for the StatelessController class and delete all of the code so the constructor is again empty.
	__4.  Find the 'greetingBean' field in the class that refers to the EJB and add the '@EJB' annotation shown below immediately before the field.  You will have errors fixed in the next step.
	__5.  Organize imports by selecting Source → Organize Imports from the RAD menus.
	__6.  Save the code.  Make sure there are no errors.
	__7.  In the RAD Servers view, right-click on the server and select Publish.  This will update the code on the server.
	__8.  In the Enterprise Explorer, right-click on the file stateless.xhtml and then select Run As → Run on Server.  You should again see the JSF form:
	__9.  Fill in the box with some name and click the 'Get Greeting' button.  Make sure you still get a response.  This response verifies that the field for the EJB is still being initialized.
	__10.  Close the web browser.
	__11.  Stop the server.  To do this, right-click on the server (in the Servers view) and select Stop.
	__12.  Close all open files. (Ctrl+Shift+W)

	Part 6 -  Review

	Lab 3 -  Creating A Stateful Session Bean
	Part 1 -  Create the Stateful Session Bean
	__1.  In the Enterprise Explorer, right-click on SimpleEJBProject and New → Session Bean.
	__2.  Set the Java package to be simple.stateful
	__3.  Set the Class name to be ToDo
	__4.  Change the State type to Stateful
	__5.  Under Create business interface, check Local and un-check No-interface.  
	__6.  Click the Next button.
	__7.  Uncheck Inherited abstract methods and Constructors from superclass.
	__8.  Click Finish.
	__9.  Add this declaration immediately after the class declaration as follows (in bold)
	__10.  An error will appear.  Organize imports (Ctrl-Shift-O) to import the List and ArrayList class. It turns out that there is more than one class called List in the classpath, so RAD will show the Organize Imports dialog.  Choose java.util.List and click Finish
	__11.  Save the class.  There should be no errors.  
	__12.  Add the following method to the class.  Make sure it is within the curly brackets for the class but outside the constructor.
	__13.  Now, add the following method to the class:
	__14.  Add the following method to the class:
	__15.  Save the code.  There should be no errors.
	__16.  Examine the Outline view (on the right).
	__17.  Holding down the Ctrl button (this performs a multiple select), click the three methods addItem(String), clearItems() and listItems().
	__18.  Right-click on the selected methods and select Refactor → Pull Up...
	__19.  Make sure your wizard appears as below and press the Finish button.
	__20.  In the Project Explorer, expand SimpleEJBProjectClient → ejbModule →  simple.stateful and double click ToDoLocal.java.
	__21.  Although the methods were added to the interface, the import of the List class was not.  This creates some compilation problems.  Right-click in the editor and select Source -->Organize Imports to fix the problem.  Once again, select java.util.List and then click Finish.
	__22.  Save the file and check the Problems view to be sure you do not have any errors.

	Part 2 -  Create A Web Client
	__1.  Open a Windows Explorer file browser window and navigate to 'C:\LabFiles\StatefulEJB' (assuming the lab files for the class are located in C:\LabFiles)
	__2.  Copy the ToDoController.java file.
	__3.  Return to RAD and find the Java package under EJBWebApp → Java Resources → src → simple.jsf.
	__4.  Select the package by clicking it and paste the file (you can use CTRL-V or Edit → Paste from the RAD menus).
	__5.  Expand the package and make sure the file appears in the correct location as shown below.
	__6.  Double click the ToDoController.java file to open it.
	__7.  Find the 'clearList' method and add the code in bold below.  This will clear the list in the EJB and make sure the JSF bean has the current list.
	__8.  Find the 'addItem' method and add the code in bold below.  This will add the item submitted by the user to the EJB list and make sure the JSF bean has the current list.
	__9.  Save the code.  Make sure there are no errors.
	__10.  Return to the Windows Explorer file browser window showing the 'C:\LabFiles\StatefulEJB' directory and open a new one if you had closed it.
	__11.  Copy the toDoStateful.xhtml file.
	__12.  Return to RAD and find the web resources folder under EJBWebApp → WebContent.
	__13.  Select the 'WebContent' folder by clicking it and paste the file (you can use CTRL-V or Edit → Paste from the RAD menus).
	__14.  Expand the folder and make sure the file appears in the correct location as shown below.
	__15.  Double click the toDoStateful.xhtml file to open it.

	Part 3 -  Test the Code
	__1.  Close all open files. (Ctrl+Shift+W)
	__2.  Publish the server.  (From the Servers view, right-click on the server and select Publish)  This will update the code on the server and start the server if needed.
	__3.  In the Enterprise Explorer, right-click on toDoStateful.xhtml, and then select Run As → Run on Server
	__4.  Enter some text into the task text box (e.g. Do Laundry) and click Add Task.  Check that the task is added to the list.
	__5.  Add a few more tasks, making sure that the tasks that were added previously are still listed.
	__6.  Click the 'Clear Tasks' button to clear the list and then add some more items to the list again.
	__7.  Close any open browser windows.

	Part 4 -  Review

	Lab 4 -  Basic Dependency Injection
	Part 1 -  Import the Project
	__1.  From menubar, select File →  Import.
	__2.  Select General →   Existing Projects into Workspace and click Next.
	__3.  Click on the radio button for Select archive file and then use the Browse button to navigate to the file C:\LabFiles\CDITestFacesWeb.zip.
	__4.  Click Finish.

	Part 2 -  Inspect the Project
	__1.  From the com.webage.test package, open Dog.java.
	__2.  Note that it has only a single method called speak() as follows.
	__3.  Open NoiseMaker.java.
	__4.  Note that it has a single method called makeNoise(). All it does is ask a dog to speak.
	__5.  Open the Managed Bean class NoiseBean.java.
	__6.  Study the speak() method. This method will be called by a command button.  It asks a NoiseMaker to make some noise, then places the result, along with a time stamp, in a property called message that will be displayed by means of a JSF EL expression.
	__7.  Finally, open the Facelets page called MainPage.xhtml.  Inside the body, we have an html form that contains a message display and a command button that executes the speak() method on the NoiseBean.

	Part 3 -  Deploy and Run
	__1.  In the Servers view, right-click on WebSphere Application Server v8.0 at localhost, and then select Add and Remove...
	__2.  Click on Add All, and then click Finish.
	__3.  If the server is not synchronized then Publish the server.  To do this, right click on the server and select Publish.
	__4.  In the Enterprise Explorer, right-click on MainPage.xhtml in the CDITestFacesWeb project, and then select Run As → Run on Server.
	__5.  Check the box to always use this server and click Finish.
	__6.  RAD will open up a web browser window with a button marked Speak.  
	__7.  Click the button.
	__8.  As you can see, the button called through the NoiseBean to the NoiseMaker, to the Dog, and got back a message, “Woof!”.

	Part 4 -  Start Using Dependency Injection
	__1.  Open NoiseMaker.java.
	__2.  Change this line:
	__3.  Organize imports and select javax.inject.Inject annotation if prompted.
	__4.  Save changes.
	__5.  Open a Windows file browser and go to C:\LabFiles.
	__6.  Copy beans.xml.
	__7.  Paste it within the WEB-INF folder of CDITestFacesWeb project.
	__8.  Open the beans.xml file and have a quick look at it. We will use it for more advanced uses later. For now, it will stay empty.
	__9.  Right click on server on the servers view and Publish.
	__10.  Check the console and wait for the project to publish.
	__11.  Run MainPage.xhtml as before and click on the Speak button.
	__12.  Oops! You got a NullPointerException.  If you look through the stack trace, you'll find that the root cause is in NoiseMaker.java at line 11. What happened?
	__13.  Open NoiseMaker.java and go to line 11 (Control+L).
	__14.  Basically, the dog variable is set to null. Dependency Injection did not work! Why?
	__15.  Open the managed bean class NoiseBean.java.
	__16.  Add an injection annotation to the noiseMaker member variable and remove the initializer as follows.
	__17.  Organize imports and select  javax.inject.Inject annotation if prompted.
	__18.  Save changes.
	__19.   Right click on server on the servers view and Publish.
	__20.  Check the console and wait for publishing to end.
	__21.  Run MainPage.xhtml as before, and then click Speak.
	__22.  Verify the console and make sure that the DI version of the application is working.
	__23.  Close the browser.
	__24.  Close all open files.

	Part 5 -  Review

	Lab 5 -  Indirection in Object Instantiation
	Part 1 -  Create the Interface
	__1.  In the Enterprise Explorer view, right click Dog.java and select Refactor →  Extract Interface.
	__2.  Enter Animal as the interface name.
	__3.  Check the speak() method.
	__4.  Verify that the refactor dialog looks like above and click OK.
	__5.  Open Animal.java and Dog.java and briefly inspect the code. Basically, the Dog class now implements Animal interface.

	Part 2 -  Change Injection
	__1.  Open NoiseMaker.java.
	__2.  To make the code more readable, change the variable name from "dog" to "animal".
	__3.  Save changes.
	__4.  To make a more visible change to the application, change the speak() method in the Dog class as shown in bold face below.
	__5.  Save changes.

	Part 3 -  Test
	__1.  Right click on server on the servers view and  Publish.
	__2.  Wait for publishing to take effect.
	__3.  Run MainPage.xhtml
	__4.  Click on Speak.
	__5.  Verify that the page shows the updated message.

	Part 4 -  Create the Cat Class
	__1.  Right click com.webage.test package and select New → Class.
	__2.  Enter Cat as the class name.
	__3.  Next to Interfaces, click Add.
	__4.  Type Animal and then select the Animal interface and click Add.
	__5.  Click OK to close the interface chooser dialog.
	__6.  Make sure you added the Animal interface and then click Finish.
	__7.  Write the speak() method as follows.
	__8.  Save changes.

	Part 5 -  Test
	__1.  Right click on server on the servers view and Publish.
	__2.  Switch to the console and it will show a problem with deployment. In the error message, you can find “There is more than one api type for injection into...NoiseMaker.animal”.

	Part 6 -  Configure Default Class Through Annotation
	__1.  Open Cat.java.
	__2.  Add the @Default annotation as shown in bold face below.
	__3.  Organize imports.
	__4.  Save changes.
	__5.  Open Dog.java.
	__6.  Add the @Alternative annotation as shown in bold face below.
	__7.  Organize imports.
	__8.  Save changes.

	Part 7 -  Test
	__1.  Clear the console.
	__2.  Right click on the server and select Publish.
	__3.  Run MainPage.xhtml and then click Speak.
	__4.  Verify that console shows the desired output from the Cat class.

	Part 8 -  Configure Default Class Through beans.xml
	__1.  Open WEB-INF/beans.xml.
	__2.  Click the Source tab at the bottom of the editor.
	__3.  Within the body of the <beans> element, add these lines:
	__4.  Save beans.xml.

	Part 9 -  Test
	__1.  Clear the console.
	__2.  Right click on server on the servers view and publish.
	__3.  Verify that there is no error.
	__4.  Run MainPage.xhtml and then click Speak.
	__5.  Make sure that the output from the Dog class is shown in the browser.
	__6.  Close all browsers and all open files.

	Part 10 -  Review

	Lab 6 -  Using Qualifiers
	Part 1 -  Create the Qualifier Annotations
	__1.  In the CDITestFacesWeb project, create a new package called com.webage.qualifiers
	__2.  Right click  com.webage.qualifiers package and select New → Annotation.
	__3.  Enter CatQualifier as the name.
	__4.  Click Finish.
	__5.  Since this annotation will be used as a qualifier, annotate the interface using @Qualifier.
	__6.  This annotation is processed at runtime (by the CDI container) and can be used at injection points for member variables, method parameters. Set that up using the lines shown in bold face below.
	__7.  Organize imports. Choose these annotations if prompted:
	__8.  Save changes.
	__9.  In the Enterprise Explorer, select the newly created CatQualifier.java annotation file.
	__10.  Hit Control+C to copy.
	__11.  Hit Control+V to paste.
	__12.  Enter DogQualifier as the name and click OK.

	Part 2 -  Associate Qualifiers with Classes
	__1.  From com.webage.test package, open Cat.java. 
	__2.  Associate the @CatQualifier annotation to this class as shown in bold face below.
	__3.  Organize imports.
	__4.  Save changes.
	__5.  Similarly, open Dog.java and annotate it as follows.
	__6.  Organize imports.
	__7.  Save changes.

	Part 3 -  Use Qualifiers at Injection Point
	__1.  Open NoiseMaker.java.
	__2.  Delete the animal member variable by deleting these lines.
	__3.  In its place, add these member variables.
	__4.  Change the makeNoise() method as follows.
	__5.  Organize imports.
	__6.  Save changes.

	Part 4 -  Test
	__1.  Right click on server on the servers view and select publish.
	__2.  As in previous labs, run MainPage.xhtml and then click Speak.  The browser should display a combined message:
	__3.  Close the browser.
	__4.  Close all open files.
	__5.  Right click the server and select Add and Remove.
	__6.  Remove all projects from the server and click Finish.
	__7.  Right click the server and select Clean and then click OK.

	Part 5 -  Review

	Lab 7 -  Accessing A Database From A Session Bean
	Part 1 -  Configure the Database 
	__1.  We should first start the actual database that we will be working with.  Using Windows Explorer, navigate to folder: 
	__2.  From there, launch startNetworkServer.bat.  You may want to add a shortcut to this command to the desktop as we will be running this database often.
	__3.  Minimize, but do not close this window.  This is the Derby database server process.  Leave it running. (If you close the window, the process will terminate).  
	__4.  Start RAD if necessary.
	__5.  From the main menu, select Window → Open Perspective → Other.
	__6.  Select Database Development and click OK.
	__7.  RAD will display the Database Development perspective.  This perspective includes a set of views that are useful when creating database programs and schema.
	__8.  On the left-hand side of the main window, you will find the Data Source Explorer view. 
	__9.  Right-click on the Database Connections node and then select New...  RAD will display the New Connection dialog.
	__10.  In the list box under Select a database manager, select Derby.
	__11.  Set the JDBC Driver to Derby 10.5 – Derby Client JDBC Driver Default.
	__12.  Click on the triangular icon just to the right of the JDBC Driver field:
	__13.  RAD will display the Edit Jar List dialog.  Click Clear All.
	__14.  Click Add JAR/Zip..., navigate to 'C:\IBM\WebSphere\AppServer\derby\lib', and then double-click on derbyclient.jar.
	__15.  Ensure that the dialog appears as below, and then click OK.
	__16.  RAD will return to the New Connection dialog.  Set the following properties:
	__17.  Click on Test Connection.  The connection should succeed, as below.  If it doesn't, consult your instructor.
	__18.   Click OK and then click Finish.
	__19.  From the main menu, select File → Open File..., and then navigate to 'C:\LabFiles\DatabaseSessionBean' and double-click on accountTable.sql'.
	__20.  RAD will display the file in a SQL editor view.  Click on the drop-down list for Connection profile → Name and select 'C:\LabFiles\DerbyDatabase\test'.
	__21.  Right-click anywhere in the 'accountTable.sql' view and then select Execute All. The commands should execute without errors.
	__22.  In the SQL Results view review that the commands were successfully executed.
	__23.  Close the sql file and don't save changes.

	Part 2 -  Create the Data Source
	__1.  Make sure the Derby database is running.  If it is not, run the command from the first part to start it. 
	__2.  In RAD switch back to the Java EE perspective if you are not there already.  You can do this by selecting Window → Open Perspective → Other or if it is still open use the button for the perspective that may appear in the upper right corner.  Sometimes you may need to click a double arrow to see the perspectives that are open.
	__3.  Make sure the WebSphere server is started from the Servers view.
	__4.  Right-click on the WebSphere Application Server v8.0 at localhost in the Servers view, and then select Administration → Run Administrative Console.
	__5.  You may see Security Alert windows, if so click Yes.
	__6.  At the login screen, enter wasadmin for the User ID and wasadmin for the Password.
	__7.  Click Login.
	__8.  The Admin Console often has a lot of text on the screen, so maximize the AdminConsole view by double-clicking on the Admin Console tab.
	__9.  In the left-hand menu area of the Admin Console, expand the Security panel and select Global Security.
	__10.  In the Authentication area on the right-hand side of the Admin Console, expand the Java Authentication and Authorization Service item.
	__11.  Click on J2C authentication data.
	__12.  Click on the New... button.
	__13.  Enter the following data, and then click OK:
	__14.  Click on Save to update the master configuration:
	__15.  In the left-hand menu of the Admin Console, expand the Resources > JDBC.
	__16.  Click on JDBC Providers.
	__17.  The system displays the JDBC Providers page.  You might notice that there is already a Derby provider.  We can't use that one, however, because it is setup to use the “embedded” version of Derby, and we want to use a client to the network server that we are running.  On the bright side, since WebSphere uses Derby internally, it already has all the required 'jar' files in its server class path, so we don't need to do any extra configuration.
	__18.  Select the Node XXXNode01, Server=server1.
	__19.  Click on the New... button.
	__20.  Enter the following data using the drop-down boxes:
	__21.  Click Next.
	__22.  With some database providers we would need to setup the class path for the driver.  However, the Derby drivers are already built in to WebSphere, so the wizard goes directly to the summary screen.  Click Finish.
	__23.  Click Save.
	__24.  In the left-hand menu of the Admin Console, click on Data sources.
	__25.  Click on the drop-down box for Scope and select the scope that ends with 'Server=server1'.
	__26.  Click the New... button.
	__27.  Enter the following information:
	__28.  Click Next.
	__29.  We already created the JDBC provider, so select the radio button for Select an existing JDBC provider, and then select Derby Network Server Using Derby Client (XA) as the provider.
	__30.  Click Next.
	__31.  Enter 'C:\LabFiles\DerbyDatabase\test' as the Database name, and then click Next.
	__32.  Under Component-managed authentication alias, select the 'wasadmin' alias that we created earlier.  Note that the alias is prefixed with the host name.  That is normal.
	__33.  Click Next, and then click Finish.
	__34.  Click the Save link.
	__35.  Click on the check-box in the Select column for the BankDS data source, and then click Test connection.
	__36.  The connection test should pass.
	__37.  Logout of the admin console (by clicking the Log Out link at the top).
	__38.  Double-click on the Admin Console tab to restore the view to its non-maximized form, and then close the Admin Console.

	Part 3 -  Create the Session Bean
	__1.  We will start by creating the bean implementation class.  In the Enterprise Explorer, right click on SimpleEJBProject and select New → Session Bean (EJB 3.x).
	__2.  Set the Java package to be com.webage.bank 
	__3.  Set the Class name to be Teller
	__4.  Under Create business interface, check Local and un-check No-interface.  
	__5.  Once your options match those shown above, click the Finish button.
	__6.  Examine Teller.java.  As usual, this is our bean implementation class.  Note @Stateless annotation.  
	__7.  Add a data source instance variable and @Resource annotation to the class, right after the class definition.  There will be some errors highlighted that will be fixed later.
	__8.  You will see some errors in the Teller Java class.  Organize imports (Ctrl-Shift-O). When prompted, select javax.sql.DataSource and click Finish.  
	__9.  Save the code. There should be no errors. 
	__10.  In the Enterprise Explorer, find the deployment descriptor node for SimpleEJBProject and double-click to open it.
	__11.  Click the Design tab. The system will display the ejb-jar.xml file in a graphical editor.  Click on the link for Open WebSphere Bindings Descriptor.
	__12.  We don't yet have a WebSphere-specific deployment descriptor, so RAD will display a dialog asking if you want to create ibm-ejb-jar-bnd.xml.  Click Yes.
	__13.  Switch to the Source view if necessary, and then add the following element just before the line that reads '</ejb-jar-bnd>'
	__14.  Save and close both the ibm-ejb-jar-bnd.xml file and the ejb-jar.xml file.
	__15.  Now, go back to Teller.java.  Open the file from the com.webage.bank package if you do not already have it open.
	__16.  We can now start coding the actual persistence code.  Add the following method definition to the class:
	__17.  Edit the body of the createAccount(...) method so it reads:
	__18.  RAD will complain that it cannot resolve Connection, PreparedStatement, and SQLException.  Fix that by organizing imports (CTRL-SHIFT-O). Select java.sql.Connection and java.sql.PreparedStatement when prompted.
	__19.  Save the code.  There should be no errors.
	__20.  Open up TellerLocal.java. Remember that the interface is in the SimpleEJBProjectClient project and com.webage.bank package.
	__21.  Next, add the following code to the interface.
	__22.  Save and close all open files.

	Part 4 -  Enable CDI in Projects
	__1.  Open a Windows file explorer.
	__2.  Go to C:\LabFiles folder.
	__3.  Copy beans.xml.
	__4.  Paste the file into the ejbModule → META-INF folder of SimpleEJBProject project.
	__5.  Also paste the file into the WebContent → WEB-INF folder of EJBWebApp project.

	Part 5 -  Create A Client
	__1.  In the Enterprise Explorer, right click on EJBWebApp and select New | Package.
	__2.  Set the name of the new package to com.webage.bank and click the Finish button.
	__3.  Open a Windows Explorer file browser window and navigate to 'C:\LabFiles\DatabaseSessionBean' (assuming the lab files for the class are located in C:\LabFiles)
	__4.  Copy the CreateJDBCController.java file.
	__5.  Return to RAD and find the Java package you created under EJBWebApp → Java Resources → src → com.webage.bank.
	__6.  Select the package by clicking it and paste the file (you can use CTRL-V or Edit → Paste from the RAD menus).
	__7.  Expand the package and make sure the file appears in the correct location as shown below.
	__8.  Double click the CreateJDBCController.java file to open it.
	__9.  Add the following code as a field to reference an injected instance of the Teller EJB.
	__10.  Add the following new 'createAccount' method to the class.  This will be called when the JSF form is submitted.  The other data fields are reset so the page will change and make it easier to tell the form was submitted.
	__11.  Organize imports.
	__12.  Save the code.  Make sure there are no errors.
	__13.  Return to the Windows Explorer file browser window showing the 'C:\LabFiles\DatabaseSessionBean' directory.
	__14.  Copy the createAccountJDBC.xhtml file.
	__15.  Return to RAD and find the web resources folder under EJBWebApp → WebContent.
	__16.  Select the 'WebContent' folder by clicking it and paste the file (you can use CTRL-V or Edit → Paste from the RAD menus).
	__17.  Expand the folder and make sure the file appears in the correct location as shown below.
	__18.  Double click the createAccountJDBC.xhtml file to open it.
	__19.  You don't have to change any code but notice the core of the code is a form that will submit account details to the JSF component using the 'createAccount' method you added.
	__20.  Close all open files.

	Part 6 -  Test
	__1.  At the end of the previous lab, we removed all the projects from the server.  In order to test this code, we need to add the EJBEARProject back onto the server.  In the Servers view, right-click on the WebSphere... server and then select Add and Remove...
	__2.  Click on EJBEARProject and then click Add.
	__3.  Click Finish.
	__4.  When the server finishes publishing, clear the console view by clicking the button that looks like this: 
	__5.  Open a browser and navigate to: 
	__6.  Enter some sample data and click Add Account. 
	__7.  Try adding another account.  You should see another Account Created message. So it looks like our application is working; but how can we really tell?  Simple.  We can go straight to the database and query the table directly. 
	__8.  In RAD, show the Database Development perspective.  
	__9.  In the Data Source Explorer, right click the database and select Refresh.
	__10.  Navigate to the BANKACTS_TBL table:
	__11.  Right-click on BANKACTS_TBL and then select Data → Return All Rows.
	__12.  You should see the data that you just entered in the SQL Results view.
	If you do not see the entries you entered via the form, then you have a bug in your code. Examine your console window to see if any exceptions have shown up.  Most likely, there is a typo in the SQL string you created in the Teller class.  The console should show the string it tried to insert; examine it for syntax errors (e.g. missing brackets)
	If the server was stopped when you made the change to the EJB code, you simply have to Publish the server. 
	__13.  Close any open browser windows.
	__14.  Close all open files.

	Part 7 -  Review

	Lab 8 -  Using Entities
	Part 1 -  The Entity Project
	__1.  Switch to the Java EE perspective if you are not there already.
	__2.  From the menu, select File | New | JPA Project...
	__3.  Set the Project Name to be BankAccountJPA
	__4.  Check the option for 'Add project to an EAR' and be sure the EJBEARProject you created is selected.
	__5.  Once your options appear as below click Finish.
	__6.  You will be prompted to switch to the JPA Perspective.  Click Yes.
	__7.  Close the help file that opens.

	Part 2 -  Creating the Database Table
	__1.  Start the Derby database if it is not running (Launch startNetworkServer.bat from  C:\IBM\WebSphere\AppServer\derby\bin\networkServer)
	__2.  Switch to the Database Development perspective (You may find it by clicking the “>>” symbol near the top-right of the RAD window, or from the main menu, select Window → Open Perspective → Other... → Database Development).
	__3.  There is a SQL Data Definition Language (DDL) file in the lab files that contains the commands to create the new database table.  From RAD's main menu, select File → Open File... and then use the file browser to open C:\LabFiles\IntroJPA\createTable.sql
	__4.  At the top of the editor window that opens, click the drop-down box for Name: and then select C:\LabFiles\DerbyDatabase\test (this is the database connection that we created in the previous lab).
	__5.  Right-click anywhere in the createTable.sql editor window and select Execute All.
	__6.  The SQL Results view should show a successful completion (no errors).
	__7.  Close the sql file and do not save changes.

	Part 3 -  Code the Entity
	__1.  If you are not already in it, switch to the JPA perspective by selecting Window | Open Perspective | Other, selecting JPA from the list and click the OK button.
	__2.  In the Project Explorer, right-click on BankAccountJPA and select New | Entity...
	__3.  For the Java package, enter com.webage.entity
	__4.  For the Class name, enter BankAccount
	__5.  Click Finish when your dialog appears as shown below.
	__6.  RAD will open a new editor on the newly created entity BankAccount.java. There is an error shown.  We will fix the error in a later step, so ignore it for now.
	__7.  Add the following annotation in bold to the class declaration.  
	__8.  Add the following fields to the class:
	__9.  We should create getter and setter methods for these instance variables.  In the Outline view, expand the class and select the three instance variables.  You can select all three by holding the CTRL key while clicking each one.  You may need to select the Outline tab on the upper right if it is hidden.
	__10.  Right click on the selected fields and select Source -> Generate Getters and Setters.  
	__11.  In the dialog that pops up, click OK.
	__12.  Add the following field annotations in bold:
	__13.  Now, let us add some interesting business logic methods to the class.  Since it is a bank account, let us create some appropriate methods.  Add the following two methods:
	__14.  Organize imports (CTRL-SHIFT-O).
	__15.  Save the class.  There should be no errors.

	Part 4 -  The Persistence Descriptor
	__1.  In the Project Explorer, expand BankAccountJPA > JPA Content.
	__2.  Right-click on persistence.xml and select Synchronize Class List.
	__3.  Now, double-click on persistence.xml  to open it in the editor.
	__4.  Click the Source tab at the bottom of the editor.  
	__5.  Click on the Design tab at the bottom of the persistence.xml editor.
	__6.  Click on the Persistence Unit (BankAccountJPA) node in the overview panel.
	__7.  Use the drop down to select a Transaction Type of JTA.
	__8.  Set JTA Data Source Name  to  jdbc/BankDS
	__9.  Save the file once it appears as below.
	__10.  Close persistence.xml.

	Part 5 -  Other JPA Tools
	__1.  Make sure that the BankAccount.java file is open in the editor or open it from the com.webage.entity package if you closed it.
	__2.  Select the JPA Structure view tab in the upper right.
	__3.  Expand the BankAccount class and notice that this view lists the fields that are stored in database columns and even shows which one is used as a primary key.  With more complex entities this view can show things like relationships.
	__4.  Select the id field in the JPA Structure view.
	__5.  Select the tab for the JPA Details view in the lower right.  
	__6.  Notice this lists the values of many of the annotations you entered in the code. Often it may be easier to use this view (and the drop down boxes it provides) to set some of the annotation properties.  If you change settings in this view the annotations in the code will be updated (don't do this now!).
	__7.  Close all open files.

	Part 6 -  The Entity Client
	__1.  Switch to the Java EE perspective by selecting Window | Open Perspective | Other and picking it from the list.
	__2.  Open up Teller.java.  (Recall that it is in the SimpleEJBProject project, in package  com.webage.bank)
	__3.  We need to add a field to hold onto an instance of an EntityManager.  An entity manager is a facility provided by the persistence manager to handle synchronization of java objects to the database.  Add the following field to the class:
	__4.  Initialization of the entity manager can be done using an annotation, much like the data source.  Add the following bold annotation before the field declaration:
	__5.  Organize imports, selecting javax.persistence.EntityManager if prompted.  
	__6.  Add the two following methods:
	__7.  Organize imports (CTRL-SHIFT-O).
	__8.  Save the file.
	__9.  Open TellerLocal.java (in the SimpleEJBProjectClient) and add the following two method declarations to the interface:
	__10.  Organize imports (CTRL-SHIFT-O).
	__11.  Save the file.
	__12.  Close all open Java files.

	Part 7 -  Update The Web Client
	__1.  Open a Windows Explorer file browser window and navigate to 'C:\LabFiles\IntroJPA' (assuming the lab files for the class are located in C:\LabFiles)
	__2.  Copy the BankController.java file.
	__3.  Return to RAD and find the Java package under EJBWebApp → Java Resources → src → com.webage.bank.
	__4.  Select the package by clicking it and paste the file (you can use CTRL-V or Edit → Paste from the RAD menus).
	__5.  Expand the package and make sure the file appears in the correct location as shown below.
	__6.  Double click the BankController.java file to open it.
	__7.  Close the file and make sure you didn't make any changes.
	__8.  Return to the Windows Explorer file browser window showing the 'C:\LabFiles\IntroJPA' directory and open a new one if you had closed it.
	__9.  Copy the createAccountJPA.xhtml and accountDetails.xhtml files.  You can hold the CTRL key while you select each one and make sure you only copy these two files.
	__10.  Return to RAD and find the web resources folder under EJBWebApp → WebContent.
	__11.  Select the 'WebContent' folder by clicking it and paste the files (you can use CTRL-V or Edit → Paste from the RAD menus).
	__12.  Expand the folder and make sure the files appear in the correct location as shown below.
	__13.  Double click the createAccountJPA.xhtml file to open it.
	__14.  Close all open files.

	Part 8 -  Test the Application
	__1.  Start the server in the Servers view.  If the server was already running, do a Publish and make sure you don't get errors.
	__2.  When the server starts, browse to:
	__3.  Enter a new account and click Add Account.  
	__4.  You should see the page with the details of the new account including the id.
	__5.  Click on the “Create a new Account” link and add a few more accounts.  There should be no errors. 
	__6.  Switch to the Database Development perspective.
	__7.  Navigate through the Data Source Explorer to select the BANKACCOUNT table that we created earlier (Database Connections → C:\LabFiles\DerbyDatabase\test → C:\LabFiles\DerbyDatabse\test → Schemas → WASADMIN → Tables –> BANKACCOUNT). Note: You may need to refresh first to see the table.
	__8.  Right-click on BANKACCOUNT and then select Data → Return All Rows.
	__9.  The SQL Results view should show the results of the query against BANKACCOUNT.
	__10.  Close all editor and browser windows.

	Part 9 -  Review

	Lab 9 -  JPA Entity Lifecycle
	Part 1 -  Add More Functionality to the EJB
	__1.  Switch to the Java EE perspective.
	__2.  Start the Derby database if it is not running.
	__3.  Open the TellerLocal.java code by double clicking it.  This is in 'SimpleEJBProjectClient → ejbModule → com.webage.bank'
	__4.  Add the following code in bold to the interface.  There will be some errors that will be fixed in a few steps.
	__5.  Save the file. There should be no errors in this file although there will be errors introduced elsewhere.
	__6.  Open Teller.java (which is in the SimpleEJBProject → ejbModule → com.webage.bank) .  
	__7.  Right click in the editor and select Source | Override/Implement Methods...
	__8.  Leave the default options which will add the three methods that were added to the interface and press the OK button.
	__9.  Find the following method:
	__10.  Replace the existing code in the method with the following code in bold.  Ignore errors for now.
	__11.  Add the following code in bold:
	__12.  Finally, we return the updated bank account to the client side as shown in  bold.
	__13.  Save the code.  There should be no errors.
	__14.  Find the method to perform a withdrawal and replace the existing code with the code below. 
	__15.  The entity manager can handle such deletion for us.  All we need to give it is the primary key of the instance we wish to delete.  Replace the code of the closeAccount method with the following:
	__16.  Save changes.  There should be no errors.
	__17.  Close all open files.

	Part 2 -  Update the Web Client
	__1.  Find the Java package under EJBWebApp → Java Resources → src → com.webage.bank and double click the BankController.java file to open it.
	__2.  Add the following new fields to the JSF managed bean.  This will provide a way to store the ID of the account to modify and the amount for deposits and withdrawals.
	__3.  Right click in the editor and select Source -> Generate Getters and Setters.  
	__4.  Check the box next to the 'amount' and 'idToModify' fields and click the OK button.
	__5.  Add the following new methods to the class.  Make sure to add them inside the curly brackets for the class definition but outside other methods.  Notice that these methods simply use the appropriate function on the Teller EJB and then redirect to the account details page with the private method that builds the redirect String.
	__6.  Add another new method to the class to process the request to close the account.  Notice that some of the primary function of this method is to call the 'closeAccount' method on the Teller EJB and redirect to an 'accountClosed' page.  The other code in this method is to create a JSF message that can be displayed on the page using the JSF “Flash” object which survives redirects.
	__7.  Organize imports (CTRL-SHIFT-O).
	__8.  Save the class.  There should be no errors.
	__9.  Open a Windows Explorer file browser window and navigate to 'C:\LabFiles\JPA‑Lifecycle' (assuming the lab files for the class are located in C:\LabFiles)
	__10.  Copy the accountActions.xhtml and accountClosed.xhtml files.  You can hold the CTRL key while you select each one and make sure you only copy these two files.
	__11.  Return to Eclipse and find the web resources folder under EJBWebApp → WebContent.
	__12.  Select the 'WebContent' folder by clicking it and paste the files (you can use CTRL-V or Edit → Paste from the Eclipse menus).
	__13.  Expand the folder and make sure the files appear in the correct location as shown below.
	__14.  Double click the accountActions.xhtml file to open it.
	__15.  Double click the accountDetails.xhtml file to open it.
	__16.  Near the bottom of the file add a new <h:link> tag to display the account actions page.  This will help navigate around the application.
	__17.  Save the file and make sure there are no errors.
	__18.  Close all open files.

	Part 3 -  Test the Application
	__1.  Start the server in the Servers view.  If the server was already running, do a Publish and make sure you don't get errors.
	__2.  When the server starts, browse to:
	__3.  Enter a new account and click Add Account.
	__4.  Make sure the account is shown.
	__5.  Click the “Account Actions” link.
	__6.  Fill in the id of an account you know exists (it can be the same one you just created) and an amount and then click the 'Deposit' button.
	__7.  The details of the account should display again but the account balance should be greater by the amount of the deposit.
	__8.  Click the “Account Actions” link.
	__9.  Fill in the id of an account you know exists and an amount and then click the 'Withdraw' button.
	__10.  Again make sure the balance is adjusted appropriately.
	__11.  Click the “Account Actions” link.
	__12.  Fill in the id of an account (you can leave the amount alone) and click the 'Close Account' button.
	__13.  Make sure that you get the page that says the account has been closed.
	__14.  If you want, you can continue to test the features of the application with other accounts.
	__15.  Close the web browser.

	Part 4 -  Review

	Lab 10 -  Entity Queries
	Part 1 -  Adding Query Logic To The Teller Bean
	__1.  Open the TellerLocal.java code by double clicking it.  This is in 'SimpleEJBProjectClient → ejbModule → com.webage.bank'
	__2.  Add the following code to the interface.  There will be some errors that will be fixed in a few steps.
	__3.  Organize imports (CTRL-SHIFT-O).  Select java.util.List when prompted and click the Finish button. 
	__4.  Save the file.  There should be no errors in the file although there will be errors other places.
	__5.  Open Teller.java (which is in the SimpleEJBProject → ejbModule → com.webage.bank).  
	__6.  Right click in the editor and select Source | Override/Implement Methods...
	__7.  Leave the default options which will add the two methods that were added to the interface and press the OK button.
	__8.  First, we will code the listAllAccounts method.  Add the following code in bold 
	__9.  Organize imports (CTRL-SHIFT-O).
	__10.  Finally, we will code the findWithBalance method. Enter the following code in bold.  Make sure to place some spaces within the String concatenation or the query syntax won't be correct.
	__11.  Save the code.  There should be no errors.

	Part 2 -  Update The Web Client
	__1.  Open a Windows Explorer file browser window and navigate to 'C:\LabFiles\JPA‑QL' (assuming the lab files for the class are located in C:\LabFiles)
	__2.  Copy the SearchController.java file.
	__3.  Return to Eclipse and find the Java package under EJBWebApp → Java Resources → src → com.webage.bank.
	__4.  Select the package by clicking it and paste the file (you can use CTRL-V or Edit → Paste from the Eclipse menus).
	__5.  Expand the package and make sure the file appears in the correct location as shown below.
	__6.  Double click the SearchController.java file to open it.
	__7.  Close the file and make sure you didn't make any changes.
	__8.  Return to the Windows Explorer file browser window showing the 'C:\LabFiles\JPA‑QL' directory and open a new one if you had closed it.
	__9.  Copy the accountSearch.xhtml file.
	__10.  Return to Eclipse and find the web resources folder under EJBWebApp → WebContent.
	__11.  Select the 'WebContent' folder by clicking it and paste the file (you can use CTRL-V or Edit → Paste from the Eclipse menus).
	__12.  Expand the folder and make sure the file appear in the correct location as shown below.
	__13.  Double click the accountSearch.xhtml file to open it.
	__14.  Close all open files.

	Part 3 -  Test the Search Features
	__1.  Make sure the Derby database is started.
	__2.  Start the server.  If the server was already running, do a Publish and make sure you don't get errors.
	__3.  When the server starts, browse to:
	__4.  Click the List All Accounts button.  
	__5.  Next, try searching by balance.  Pick a balance that you know will return some results but not the entire list.
	__6.  Now try searching by account id.
	__7.  Check that you are redirected to the account details page for the appropriate account.
	__8.  Try using the features of previous labs to create new accounts and modify existing accounts by depositing and withdrawing.  Search on them.  Realize that we've managed to get all this data persisted without writing a single line of SQL code!
	__9.  Close the browser.

	Part 4 -  Review

	Lab 11 -  Basic Relationships
	Part 1 -  Create the New Entity
	__1.  In the Package Explorer, right-click on BankAccountJPA project and select New → Entity.
	__2.  Set the Java package to com.webage.entity and set the Class name to Owner and click the Next button.
	__3.  On the next page, in the 'Table name' settings uncheck the 'Use default' option.
	__4.  Change the name of the table to 'OWNERS' (plural form, all capitals) as shown below.
	__5.  On the same page click the Add button next to the empty list of fields.
	__6.  Fill in the following properties for the new field and click the OK button.
	__7.  After the new field is added to the list check the box under the Key column to mark this as the key for the new entity.
	__8.  In a similar fashion add two new 'java.lang.String' fields for 'name' and 'address' as shown below (note: these fields are not part of the key, so don't check the key box).
	__9.  Finally add a new field of a 'java.util.Date' type and a name of 'dateOfBirth' as shown below.
	__10.  Once your settings match those shown below click the Finish button.  
	__11.  Notice that the class created has properties with get/set methods and some of the basic JPA annotations.  This has saved quite a bit of effort.
	__12.  Before the 'id' field add the following two JPA annotations in bold.  This will change the name of the column for the field and set the key generation strategy.  These annotations can't be set from the wizard you ran.
	__13.  Find the 'dateOfBirth' field and make the following changes in bold.  This will initialize the field with a Date object and use the @Temporal annotation to indicate the type of mapping for the java.util.Date field.
	__14.  Save the file and make sure there are no errors.
	__15.  Expand BankAccountJPA | JPA Content.  
	__16.  Right-click on persistence.xml and select Synchronize Class List.
	__17.  Open persistence.xml.
	__18.  Select the Source tab.
	__19.  Leave the persistence.xml file open for the next section.

	Part 2 -  Update Database
	__1.  In persistence.xml, add the following code in bold.  Open the persistence.xml file from the BankAccountJPA project if you had closed it from the last section.
	__2.  Save and close persistence.xml.
	__3.  Close Owner.java.  
	__4.  Stop the server.
	__5.  Start the Derby database if it is not running (Launch startNetworkServer.bat from C:\Software\db-derby-10.7.1.1-bin\bin)
	__6.  Switch to the Database Development perspective.
	__7.  In the Data Source Explorer, navigate to the BANKACCOUNT table in the C:\LabFiles\DerbyDatabase... database.
	__8.  From the menu, select File > Open File. 
	__9.  Open the file C:\LabFiles\JPA-BasicRelationship\dropTable.sql.
	__10.  Select C:\LabFiles\DerbyDatabase\test as Name.
	__11.  Right click and select Execute All.
	__12.  Verify the commands were successfully executed.
	__13.  Close dropTable.sql and don't save changes.
	__14.  Refresh the table and make sure the table is gone.
	__15.  Switch back to the Java EE perspective.

	Part 3 -  Update the BankAccount Entity
	__1.  Open up BankAccount.java in the com.webage.entity package of the BankAccountJPA project.
	__2.  In the Outline view right-click the 'ownerName' field and select Delete.
	__3.  Click the OK button to confirm deleting the field and the Yes to All button to delete the getter/setter methods.
	__4.  Make sure the class is saved and compiles with no errors.  Note that you may see an error on the @Table annotation saying that the table cannot be resolved.  That error will be cleared later, so ignore it for now.
	__5.  Add the following new field to the BankAccount class for the reference to the Owner of the account.
	__6.  Generate a getter/setter for the new field by selecting Source → Generate Getters and Setters, making sure the owner field is the only one selected, and clicking the OK button.
	__7.  Again save the code and make sure there are no errors.
	__8.  Adding the field is not enough for the relationship.  Add the following annotations before the declaration of the 'owner' field.  Make sure they are placed in the right location.  You will have some errors until the next step.
	__9.  Organize imports (Source → Organize Imports). 
	__10.  Save changes and make sure there are no errors.  

	Part 4 -  Use Owner When Creating an Account
	__1.  In the Package Explorer view, expand the following folders:
	__2.  Open the BankController.java file in the com.webage.bank package by double clicking it.
	__3.  Add the following new field for an Owner instance as shown in bold below.  This will be linked to elements in the JSF page.  You will have errors until the next step.
	__4.  Organize imports and select com.webage.entity.Owner when prompted.
	__5.  Generate a getter/setter for the new field by selecting Source → Generate Getters and Setters, making sure the owner field is the only one selected, and clicking the OK button.
	__6.  Save the file and make sure there are no errors.
	__7.  Add a new 'BankController' constructor as shown below.  Make sure this is inside the class definition but outside any other method.  This code will create a new Owner object and associate the BankAccount and Owner objects used by the JSF component.
	__8.  Save the file and make sure there are no errors.
	__9.  Find the 'createAccount' method in the BankController class.  Notice that this method only passes the BankAccount object to the EJB component that will save it using JPA.  This is why the relationship needed to be established in the JSF component.
	__10.  In the EJBWebApp → WebContent folder, double click the createAccountJPA.xhtml file to open it.
	__11.  Find the textbox which is linked to the name of the account owner.  Modify the 'value' expression so that the textbox is linked directly to the 'name' property of the 'owner' property of the JSF managed bean instead of to any property of the account.  Make sure to use lowercase.
	__12.  Between the 'Name' and 'Balance' elements of the form, insert some new form elements to collect the 'dateOfBirth' and 'address' properties of the owner.  Notice the date is formatted with JSF formatting.
	__13.  Save the file and make sure there are no errors.
	__14.  In the EJBWebApp → WebContent folder, double click the accountDetails.xhtml file to open it.
	__15.  Find the output of the owner name and modify the expression to use the 'name' property of the 'owner' linked to the account.  You should only need to add a period and change the 'n' to lowercase.
	__16.  Add some new output between the owner name and balance to show the owner 'dateOfBirth' and 'address' properties.
	__17.  Save the file and make sure there are no errors.
	__18.  Finally, open the accountSearch.xhtml page in the EJBWebApp → WebContent folder.
	__19.  Modify the output of the owner name in the search results as shown below to use the 'account.owner.name' property.  The output below wraps to two lines although yours should all be on one line.
	__20.  Save the file and make sure there are no errors.
	__21.  Close all open files.

	Part 5 -  Test the Application
	__1.  Start the server in the Servers view. 
	__2.  When the server starts, browse to:
	__3.  Enter a new account and click Add Account.  Use the MM/DD/YY short format for the birth date.
	__4.  Click on the “Create a new Account” link and add a few more accounts.  There should be no errors. 
	__5.  Click on the 'Account Actions' link and deposit and withdraw money from existing accounts to verify those function work.
	__6.  Change the address of the browser to:
	__7.  Click the 'List All Accounts' button and verify the list comes up and can still display the owner name.
	__8.  Next, try searching by balance.  Pick a balance that you know will return some results but not the entire list.  When you click the 'Balance Search' button you should get back some kind of error.
	__9.  Go back to the search page and verify the 'ID Search' feature works.
	__10.  Close the browser you were using to test.

	Part 6 -  Fix Balance Search
	__1.  Open Teller.java (which is in the SimpleEJBProject → ejbModule → com.webage.bank).
	__2.  Find the 'findWithBalance' method and modify it so that the 'ORDER BY' clause is 'ba.owner.name'.  Again, this should be little more than adding the period and making the 'n' lowercase.
	__3.  Save the file and make sure there are no errors.
	__4.  Publish the server.
	__5.  When the server is published, open a browser and browse to:
	__6.  Pick a balance that you know will return some results but not the entire list of accounts and click the 'Balance Search' button.  Verify that you do get back accounts with a higher balance and not an error.
	__7.  Close the browser.
	__8.  Switch to the Database Development perspective.
	__9.  In the Database Explorer, locate the node that corresponds to the database C:\LabFiles\DerbyDatabase\test.
	__10.  Right-click on this node and then select Refresh
	__11.  Navigate down through Schemas → WASADMIN → Tables.  Expand Tables.
	__12.  Right-click on BANKACCOUNT and then select Data → Return All Rows.  The SQL Results view should show you the accounts you created.
	__13.  Similarly, have a look at the data in OWNERS.  You should see the owners of the accounts you created.
	__14.  Switch back to the Java EE perspective.

	Part 7 -  Modify Application to Show Owners
	__1.  Open the TellerLocal.java code by double clicking it.  This is in 'SimpleEJBProjectClient → ejbModule → com.webage.bank'
	__2.  Add the following code in bold to the interface.  There will be some errors that will be fixed in a few steps.
	__3.  Organize imports (Source → Organize Imports).  Pick the 'com.webage.entity.Owner' class when prompted.
	__4.  Save the file. There should be no errors in this file although there will be errors introduced elsewhere.
	__5.  Open Teller.java (which is in the SimpleEJBProject → ejbModule → com.webage.bank) .  
	__6.  Right click in the editor and select Source | Override/Implement Methods...
	__7.  Leave the default options which will add the method that was added to the interface and press the OK button.
	__8.  Replace the existing code in the 'findOwnerById' method with the following code in bold.  
	__9.  Save the code.  There should be no errors.
	__10.  Open a Windows Explorer file browser window and navigate to 'C:\LabFiles\JPA‑BasicRelationship' (assuming the lab files for the class are located in C:\LabFiles)
	__11.  Copy the OwnerController.java file.
	__12.  Return to RAD and find the Java package under EJBWebApp → Java Resources → src → com.webage.bank.
	__13.  Select the package by clicking it and paste the file (you can use CTRL-V or Edit → Paste from the RAD menus).
	__14.  Expand the package and make sure the file appears in the correct location as shown below.
	__15.  Double click the OwnerController.java file to open it.
	__16.  Return to the Windows Explorer file browser window showing the 'C:\LabFiles\JPA‑BasicRelationship' directory and open a new one if you had closed it.
	__17.  Copy the accountSearch.xhtml and ownerDetails.xhtml files.  You can hold the CTRL key while you select each one and make sure you only copy these two files.
	__18.  Return to RAD and find the web resources folder under EJBWebApp → WebContent.
	__19.  Select the 'WebContent' folder by clicking it and paste the files (you can use CTRL-V or Edit → Paste from the RAD menus).  Click the 'Yes' button when asked if you want to replace the existing accountSearch.xhtml file.
	__20.  Expand the folder and make sure the files appear in the correct location as shown below.
	__21.  Double click the accountSearch.xhtml file to open it.
	__22.  Start the server in the Servers view.  If the server was already running, do a Publish and make sure you don't get errors.
	__23.  Browse to:
	__24.  Click the List All Accounts button.  
	__25.  Click on a link for one of the names and make sure the owner details page appears.
	__26.  Fill in the ID textbox with another valid owner ID (likely the same as the existing account IDs) and click the Display Another Owner button.  Make sure the other owner is displayed.
	__27.  Close the web browser being used to test.
	__28.  Close all open files.

	Part 8 -  Review

	Lab 12 -  Complex Relationships
	Part 1 -  Create the PhoneNumber Entity
	__1.  Stop the server if it is running.
	__2.  In the Enterprise Explorer, right-click on BankAccountJPA project and select New → Entity.
	__3.  Set the Java package to com.webage.entity and set the Class name to PhoneNumber and click the Next button.
	__4.  On the next page, in the 'Table name' settings uncheck the 'Use default' option and change the name of the table to 'PHONENO' (all capitals).
	__5.  On the same page click the Add button next to the empty list of fields.
	__6.  Fill in the following properties for the new field and click the OK button.
	__7.  After the new field is added to the list check the box under the Key column to mark this as the key for the new entity.
	__8.  In a similar fashion add new 'int' fields for 'areaCode' and 'number' as shown below.
	__9.  Click the Finish button.  
	__10.  Before the 'id' field add the following JPA annotation in bold.  This will set the key generation strategy.  
	__11.  Save the file and make sure there are no syntax errors.
	__12.  Expand BankAccountJPA | JPA Content.  
	__13.  Right-click on persistence.xml and select Synchronize Class List.

	Part 2 -  Create Relationship
	__1.  Return to the PhoneNumber.java entity code and open it again if you closed it.
	__2.  Add the following field to the class, which is a reference to the owner.  
	__3.  Annotate the field:
	__4.  Organize imports.
	__5.  Generate a getter/setter for the new field by selecting Source → Generate Getters and Setters, making sure the owner field is the only one selected, and clicking the OK button.
	__6.  Save the code and make sure there are no errors.
	__7.  Open up Owner.java in the com.webage.entity package of the BankAccountJPA project.
	__8.  Add the following field to the class.  You will have errors until the next steps.
	__9.  Add the following annotation to the field.
	__10.  Add a method to the class that will allow for the addition of new phone numbers. 
	__11.  Add the following method that will let the list of phone numbers be retrieved.  
	__12.  Organize imports, selecting java.util.List if asked. 
	__13.  Save the file and be sure there are no errors.

	Part 3 -  Drop Database Tables
	__1.  Switch to the Database Development perspective.
	__2.  From the main menu, select File → Open File, and then use the file chooser window to open the file C:\LabFiles\JPA-ComplexRelationship\dropTables.sql
	__3.  In the editor window that opens, use the dropdown box to set the connection name to C:\LabFiles\DerbyDatabase\test.
	__4.  Right-click anywhere in the editor window and then select Execute All.
	__5.  Make sure the commands were executed with no errors.
	__6.  Refresh the database to verify the tables were removed.
	__7.  Close the editor that is displaying dropTables.sql.  Click No when asked to save changes.
	__8.  Switch back to the Java EE perspective.

	Part 4 -  Modify Account Creation
	__1.  In the Enterprise Explorer view, expand the following folders:
	__2.  Open the BankController.java file in the com.webage.bank package by double clicking it.  
	__3.  Add the following new field for a PhoneNumber instance as shown in bold below.  This will be linked to elements in the JSF page.  You will have errors until the next step.
	__4.  Organize imports.
	__5.  Generate a getter/setter for the new field by selecting Source → Generate Getters and Setters, making sure the phone field is the only one selected, and clicking the OK button.
	__6.  Find the BankController constructor and make the following changes.  This will establish the relationship between the new Owner and the PhoneNumber instances.  Remember that the 'addNumber' method has logic to make sure that both sides of the relationship link to each other since this is a bidirectional relationship.
	__7.  Save the file and make sure there are no errors.
	__8.  In the EJBWebApp → WebContent folder, double click the createAccountJPA.xhtml file to open it.
	__9.  Find the textboxes for owner address and balance and insert the following two new textboxes for the PhoneNumber properties.
	__10.  Save the file and make sure there are no errors.
	__11.  In the EJBWebApp → WebContent folder, double click the ownerDetails.xhtml file to open it.
	__12.  Near the bottom of the page, after the </h:form> tag but before the end of the body enter the following code.  This will display a table of phone numbers for the owner to make it easier to see the data.
	__13.  Save the file and make sure there are no errors.
	__14.  Close all open files.

	Part 5 -  Test the Application
	__1.  Start the server in the Servers view. 
	__2.  When the server starts, browse to:
	__3.  Enter a new account and click Add Account.  Use the MM/DD/YY short format for the birth date.  Also do not enter anything but numeric characters in the phone fields.
	__4.  You should see the page with the details of the new account including the id.
	__5.  Click on the “Create a new Account” link and add a few more accounts.  There should be no errors. 
	__6.  Change the address of the browser to:
	__7.  Click the 'List All Accounts' button and verify the list comes up and displays the accounts you added.
	__8.  Click on a link for one of the names and make sure the owner details page appears.  The phone number you entered should also be displayed.
	__9.  Fill in the ID textbox with another valid owner ID (likely the same as the existing account IDs) and click the Display Another Owner button.  Make sure the other owner is displayed complete with the phone number of that owner.
	__10.  Close the web browser being used to test.

	Part 6 -  Modify Application to Add New Phone Numbers
	__1.  Open the TellerLocal.java code by double clicking it.  This is in 'SimpleEJBProjectClient → ejbModule → com.webage.bank'
	__2.  Add the following code in bold to the interface.  There will be some errors that will be fixed in a few steps.
	__3.  Organize imports (Source → Organize Imports).  
	__4.  Save the file. There should be no errors in this file although there will be errors introduced elsewhere.
	__5.  Open Teller.java (which is in the SimpleEJBProject → ejbModule → com.webage.bank) .  
	__6.  Right click in the editor and select Source | Override/Implement Methods...
	__7.  Leave the default options which will add the method that was added to the interface and press the OK button.
	__8.  Replace the existing code in the 'addNumber' method with the following code in bold.  
	__9.  Save the code.  There should be no errors.
	__10.  In the Enterprise Explorer view, expand the following folders:
	__11.  Open the OwnerController.java file in the com.webage.bank package by double clicking it.  
	__12.  Add the following new field for a PhoneNumber instance as shown in bold below.  This will be linked to elements in the JSF page.  You will have errors until the next step.
	__13.  Organize imports.
	__14.  Generate a getter/setter for the new field by selecting Source → Generate Getters and Setters, making sure the phoneToAdd field is the only one selected, and clicking the OK button.
	__15.  Add the following new method to the class.  This will be called when you submit the form to add the new phone number.
	__16.  Save the code.  There should be no errors.
	__17.  In the EJBWebApp → WebContent folder, double click the ownerDetails.xhtml file to open it.
	__18.  After the display of the owner address but inside the ending </h:form> tag add the following code for textboxes to submit new phone data.
	__19.  Save the file and make sure there are no errors.
	__20.  Publish the server in the Servers view.  This should also start the server if you happened to stop it.
	__21.  Close all open files.
	__22.  When the server is updated, browse to:
	__23.  Click the List All Accounts button.  
	__24.  Click on a link for one of the names and make sure the owner details page appears with the new form elements to add a new phone number.
	__25.  Fill in some values for a new phone number, making sure to only enter numbers, and click the Add New Phone Number button.
	__26.  Verify that the page is redisplayed with the new phone number in the list.
	__27.  Try adding some other numbers or switching to a different owner and adding numbers.
	__28.  Close the web browser being used to test.

	Part 7 -  Review

	Lab 13 -  Relationship Queries
	Part 1 -  More Complex Queries
	__1.  Open the TellerLocal.java code by double clicking it.  This is in 'SimpleEJBProjectClient → ejbModule → com.webage.bank'
	__2.  Add the following code in bold to the interface. 
	__3.  Save the file. There should be no errors in this file although there will be errors introduced elsewhere.
	__4.  Open Teller.java (which is in the SimpleEJBProject → ejbModule → com.webage.bank) .  
	__5.  Right click in the editor and select Source | Override/Implement Methods...
	__6.  Leave the default options which will add the method that was added to the interface and press the OK button.
	__7.  Replace the existing code in the 'findAccountsForAreaCode' method with the following code in bold.  Be careful with the spaces in the query statement syntax and the way the statements are shown to split lines below.
	__8.  Save the code.  There should be no errors.
	__9.  Replace the existing code in the 'findNumbersForAmount' method with the following code in bold.  Again be careful with the spaces in the query statement syntax.
	__10.  Save the code.  There should be no errors.

	Part 2 -  Modify Web Client
	__1.  Open a Windows Explorer file browser window and navigate to 'C:\LabFiles\JPA-RelationshipQueries' (assuming the lab files for the class are located in C:\LabFiles)
	__2.  Copy the QueryController.java file.
	__3.  Return to RAD and find the Java package under EJBWebApp → Java Resources → src → com.webage.bank.
	__4.  Select the package by clicking it and paste the file (you can use CTRL-V or Edit → Paste from the RAD menus).
	__5.  Expand the package and make sure the file appears in the correct location as shown below.
	__6.  Double click the QueryController.java file to open it.
	__7.  Find the 'areaCodeQuery' method and add the line in bold below.  This will call the EJB method to run this query and store the results in a variable that can be accessed from the JSF page.
	__8.  Find the 'phoneQuery' method and add the line in bold below.  
	__9.  Save the code.  There should be no errors.
	__10.  Return to the Windows Explorer file browser window showing the 'C:\LabFiles\JPA-RelationshipQueries' directory and open a new one if you had closed it.
	__11.  Copy the querySearch.xhtml file. 
	__12.  Return to RAD and find the web resources folder under EJBWebApp → WebContent.
	__13.  Select the 'WebContent' folder by clicking it and paste the file (you can use CTRL-V or Edit → Paste from the RAD menus).  
	__14.  Expand the folder and make sure the file appears in the correct location as shown below.
	__15.  Double click the querySearch.xhtml file to open it.
	__16.  Close all open files.

	Part 3 -  Test the New Queries
	__1.  Start the server in the Servers view.  If the server was already running, do a Publish and make sure you don't get errors.
	__2.  When the server starts, browse to:
	__3.  Click the List All Accounts button.  
	__4.  Click on a link for one of the names and make sure the owner details page appears.
	__5.  If there are not more than one phone number for the account, use the form to add a few.  Also remember some of the area codes of the numbers.
	__6.  If you did not have many bank accounts, use the following page to add some more.
	__7.  Now that you have several bank accounts and phone numbers and know some of the area codes, go to the following page.
	__8.  Enter an area code you know has accounts linked to it and click the 'Area Code Search' button.
	__9.  Check that the search results area lists the accounts.  You can also click the links for the owner names if you want.
	__10.  Enter an amount that will select some accounts but not all and click the 'Telemarketers Click Here' button.
	__11.  Check that the search results show the phone numbers linked to accounts with that amount or greater.  You may want to add some more accounts or use a value that selects more than one account so that you can see the list of phone numbers is all phone numbers and not just for a single account.
	__12.  Close the web browser being used to test.

	Part 4 -  Review

	Lab 14 -  Inheritance
	Part 1 -  Define the Subclass
	__1.  Stop the server if it is running.
	__2.  In the Package Explorer, right-click on BankAccountJPA project and select New → Entity.
	__3.  Set the Java package to com.webage.entity and set the Class name to SavingsAccount and for the Superclass, enter com.webage.entity.BankAccount then click the Next button.
	__4.  On the next page, click the Add button next to the empty list of fields.
	__5.  Fill in the following properties for the new field and click the OK button.
	__6.  Once your settings match those shown below click the Finish button.  
	__7.  Now annotate the class as follows:
	__8.  Save the file and make sure there are no errors.
	__9.  Expand BankAccountJPA | JPA Content.  
	__10.  Right-click on persistence.xml and select Synchronize Class List.

	Part 2 -  Map the Parent
	__1.  Open BankAccount.java in the com.webage.entity package of the BankAccountJPA project.  
	__2.  Add the following annotations in bold to the class definition:
	__3.  Organize the imports.
	__4.  Save the code.  There should be no errors.  

	Part 3 -  Update Client for Creating Savings Accounts
	__1.  Open a Windows Explorer file browser window and navigate to 'C:\LabFiles\JPA-Inheritance' (assuming the lab files for the class are located in C:\LabFiles)
	__2.  Copy the BankController.java file.
	__3.  Return to RAD and find the Java package under EJBWebApp → Java Resources → src → com.webage.bank.
	__4.  Select the package by clicking it and paste the file (you can use CTRL-V or Edit → Paste from the RAD menus).  Click the 'Yes' button when asked if you want to replace the existing BankController.java file.
	__5.  Expand the package and make sure the file appears in the correct location as shown below.
	__6.  Double click the BankController.java file to open it.
	__7.  Return to the Windows Explorer file browser window showing the 'C:\LabFiles\JPA-Inheritance' directory and open a new one if you had closed it.
	__8.  Copy the createAccountJPA.xhtml file.
	__9.  Return to RAD and find the web resources folder under EJBWebApp → WebContent.
	__10.  Select the 'WebContent' folder by clicking it and paste the file (you can use CTRL-V or Edit → Paste from the RAD menus).  Click the 'Yes' button when asked if you want to replace the existing createAccountJPA.xhtml file.
	__11.  Expand the folder and make sure the file appears in the correct location as shown below.
	__12.  Double click the createAccountJPA.xhtml file to open it.
	__13.  Close all open files.

	Part 4 -  Display Interest Rate for Savings Accounts
	__1.  Open the TellerLocal.java code by double clicking it.  This is in 'SimpleEJBProjectClient → ejbModule → com.webage.bank'
	__2.  Add the following code in bold to the interface.  There will be some errors that will be fixed in a few steps.
	__3.  Organize imports (Source → Organize Imports).  
	__4.  Save the file. There should be no errors in this file although there will be errors introduced elsewhere.
	__5.  Open Teller.java (which is in the SimpleEJBProject → ejbModule → com.webage.bank). 
	__6.  Right click in the editor and select Source | Override/Implement Methods...
	__7.  Leave the default options which will add the method that was added to the interface and press the OK button.
	__8.  Replace the existing code in the 'listAllSavingsAccounts' method with the following code in bold.  
	__9.  Save the code.  There should be no errors.
	__10.  In the Enterprise Explorer view, expand the following folders:
	__11.  Open the SearchController.java file in the com.webage.bank package by double clicking it.  
	__12.  Find the 'results' field and modify the definition of the generic qualifier as shown in bold below.  The syntax is a little tricky so make sure to modify within the brackets.
	__13.  Find the existing 'getResults' method and modify the signature of the method to make a similar change to the generic.
	__14.  Add a new method called 'listAllSavingsAccounts' that will call the new method you added to the EJB and store the results in the 'results' field.  This will be called by pressing a new button that will be added to the search page.
	__15.  Save the code.  There should be no errors.
	__16.  In the EJBWebApp → WebContent folder, double click the accountDetails.xhtml file to open it.
	__17.  Between the output of the balance and the link to the account creation page, add the following code in bold.  This will show the interest rate only if it is a savings account.
	__18.  Locate this code:
	__19.  Replace the above code with:
	__20.  Save the code.  There should be no errors.
	__21.  In the EJBWebApp → WebContent folder, double click the accountSearch.xhtml file to open it.
	__22.  Within the '<h:form>' tag enter a new button to trigger the search for only savings accounts with the bold code below.  Put a new '<br/>' tag after the previous button also.
	__23.  In the '<ui:repeat>' tag for the search results, put a new '<h:outputText>' element between the current output of the balance and the '<br/>' tag that would be at the end of every line.  This will be displayed only for savings accounts.
	__24.  Locate the code:
	__25.  Change the above code with:
	__26.  Save the code.  There should be no errors.
	__27.  Close all open files.

	Part 5 -  Drop Database Tables
	__1.  Switch to the Database Development perspective.
	__2.  From the main menu, select File → Open File, and then use the file chooser window to open the file C:\LabFiles\JPA-Inheritance\dropTables.sql
	__3.  In the editor window that opens, use the dropdown box to set the connection name to C:\LabFiles\DerbyDatabase\test.
	__4.  Clear the SQL Results view.
	__5.  Right-click anywhere in the editor window and then select Execute All.
	__6.  Make sure the commands were executed with no errors.
	__7.  Refresh the database to verify the tables were removed.
	__8.  Close the editor that is displaying dropTables.sql.  Click No when asked to save changes.
	__9.  Switch back to the Java EE perspective.

	Part 6 -  Test Creating a Savings Account
	__1.  Start the server in the Servers view.  If the server was already running, do a Publish and make sure you don't get errors.
	__2.  When the server starts, browse to:
	__3.  Enter a new account and click Add Account.  For the first account do not check the savings account checkbox so we can check that regular BankAccount objects can be created.
	__4.  You should see the page with the details of the new account including the id.
	__5.  Click on the “Create a new Account” link.
	__6.  Fill in some other details for a second account.  This time check the box for a savings account and fill in an integer for the textbox that appears.
	__7.  Once you have account details filled in, press the 'Add Account' button and make sure there are no errors.
	__8.  Change the address of the browser to:
	__9.  Click the 'List All Accounts' button and verify the list comes up and displays the accounts you added.
	__10.  Close the browser being used to test.

	Part 7 -  Test Savings Account
	__1.  When the server is updated, browse to:
	__2.  Click the List All Accounts button.  You should see that the accounts that were created as savings accounts display the interest rate.
	__3.  Click the button for 'List All Savings Accounts' and verify you only get the savings accounts displayed.
	__4.  Now try searching by account id.  Use the id of an account you know is a savings account.
	__5.  Check that you get the value of the interest rate printed in the account details page.
	__6.  Go back and search for an account id you know is not a savings account.  Verify that you get the normal response and not an error.
	__7.  Close the web browser being used to test.
	__8.  Switch to the Database Development perspective.
	__9.  Under the Database Connections → C:\LabFiles\DerbyDatabase\test node, navigate to: 
	__10.  Right-click on the BANKACCOUNT table and select Data → Return All Rows.
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	Lab 15 -  JPA Criteria Queries
	Part 1 -  Modify “List All” Queries in EJB
	__1.  Make sure that you are in the Java EE perspective.
	__2.  Open Teller.java (which is in the SimpleEJBProject → ejbModule → com.webage.bank)
	__3.  Look at the listAllAccounts() method. It is currently running the JPA QL query "SELECT a FROM BankAccount a". We will migrate this to criteria query.
	__4.  First, delete the line that creates the JPA QL query.  You will have errors but we will ignore errors until all code is added.
	__5.  In place of the deleted line, add this line to create a criteria query object.
	__6.  Add this line after the previous line, that builds the entity from where the data will be selected.
	__7.  Add the following line. This will configure the criteria query to do a select from BankAccount entity.
	__8.  Add the following line to obtain a TypedQuery from the criteria query.
	__9.  Add a log statement to make a visual change to the application. Otherwise, it will be difficult to tell if the updated code is actually being used by the server.
	__10.  Verify that the method now looks like this:
	__11.  Organize imports (CTRL-SHIFT-O). Select javax.persistence.criteria.Root.
	__12.  Save changes.  There should be no errors in the file.
	__13.  Find the listAllSavingsAccounts() method.  Replace the code so it appears as shown below.  Notice this is similar to the other method except using the SavingsAccount class instead of BankAccount.  If you would like to copy the code there is a file 'C:\LabFiles\CriteriaQuery\ModifiedEJBCode.txt' to copy from.
	__14.  Save changes.  There should be no errors in the file.

	Part 2 -  Test First Criteria Query Changes
	__1.  Make sure your Derby database is running and start it if it is not.
	__2.  Start the server in the Servers view.  If the server was already running, do a Publish and make sure you don't get errors.
	__3.  When the server is updated, browse to:
	__4.  Click the List All Accounts button.  You should see all the current accounts since only the method of performing the query changed and the client did not change.
	__5.  Click the button for 'List All Savings Accounts' and verify you only get the savings accounts displayed.
	__6.  Switch back to Eclipse and look in the Console view at the bottom.  You should see the messages printed out that were added to verify that criteria queries were being used.
	__7.  Close the browser used to test.

	Part 3 -  Enable JPA Criteria Metamodel with Project
	__1.  Right click on the BankAccountJPA project in the Project Explorer view and select Properties.
	__2.  When the properties appear, select the Java Persistence properties on the left.
	__3.  At the bottom of the JPA properties, find the 'Canonical metamodel' property and use the drop down to select the 'src' source folder.
	__4.  Click the OK button to close the properties.  Wait for Eclipse to finish building the project.
	__5.  Expand the 'BankAccountJPA → src → com.webage.entity', then refresh the package and notice the metamodel classes that were added that all have the same name as the entity class but end with an underscore.
	__6.  Collapse the folders in the BankAccountJPA project.

	Part 4 -  Convert Balance Search to Criteria Query
	__1.  Open the TellerLocal.java code by double clicking it.  This is in 'SimpleEJBProjectClient → ejbModule → com.webage.bank'
	__2.  Find the 'findWithBalance' method and add a new boolean parameter to the method signature as shown below.  Make sure to also add the comma between parameters.
	__3.  Save the file. There should be no errors in this file although there will be errors introduced elsewhere.
	__4.  Open Teller.java (which is in the SimpleEJBProject → ejbModule → com.webage.bank) if you don't already have it open.  
	__5.  Locate the 'findWithBalance' method which should have errors and add the new boolean parameter to the method signature as shown below.  Make sure to also add the comma between parameters.
	__6.  Save the file. There should be no errors in this file although there will be errors introduced elsewhere.  This indicates the method signature is correct.
	__7.  Delete all lines in the findWithBalance() method until it looks like this.  Ignore errors until we are done modifying the code.
	__8.  Within the method, add these lines. They setup a basic query from the BankAccount entity.  If you would like to copy the code there is a file 'C:\LabFiles\CriteriaQuery\ModifiedEJBCode.txt' to copy from.
	__9.  Add these lines, that will set up a "greater than equal to" where clause with the balance field.  Notice the use of the 'BankAccount_' criteria metadata class.
	__10.  Add these lines that will setup an optional order by clause for the ownerName field in ascending order if the boolean parameter indicates the results should be sorted.  Also notice that the metamodel classes are used to build a path to the 'name' property of the Owner entity to use as the element to sort by.
	__11.  Add this line that will create a regular query object from the criteria query.
	__12.  Set the value of the parameter.
	__13.  Finally, add these lines that log information and returns the result of the query.
	__14.  Check that the final version of your method appears as the code below.
	__15.  Organize imports and select these classes.
	__16.  Save the file. There should be no errors in this file although there will still be errors in other projects.

	Part 5 -  Modify Client for New Balance Search
	__1.  In the Enterprise Explorer view, expand the following folders:
	__2.  Open the SearchController.java file in the com.webage.bank package by double clicking it.  
	__3.  Add the following new field for a boolean as shown in bold below.  This will be linked to elements in the JSF page.  
	__4.  Generate a getter/setter for the new field by selecting Source → Generate Getters and Setters, making sure the sortResults field is the only one selected, and clicking the OK button.
	__5.  Find the 'balanceSearch' method and modify the call to the EJB 'findWithBalance' method to include the value of the new boolean field you just added.  Make sure to add the comma between parameters also.
	__6.  Save the file. Check that there are no longer any errors in any projects.
	__7.  In the EJBWebApp → WebContent folder, double click the accountSearch.xhtml file to open it.
	__8.  Find the textbox for the amount of the balance search and the button that submits the balance search request and add the code in bold below.  This will add a checkbox the user can use to indicate if the results of the balance search should be sorted.
	__9.  Save the file and make sure there are no errors.
	__10.  Close all open files.
	__11.  Publish the server in the Servers view.  This should also start the server if you happened to stop it.
	__12.  When the server is updated, browse to:
	__13.  Click the List All Accounts button.  
	__14.  Look at the list of accounts and determine a value that would return quite a few accounts and fill that in for the amount of the balance search.  For now leave the option for sorting disabled and click the 'Balance Search' button.
	__15.  Perform the balance search again with the sorting enabled and check if results come back in a different order.  You may need to click the 'Create a new Account' link and add another account with an owner name that starts with one of the first letters of the alphabet.
	__16.  Close the web browser being used to test.
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	Lab 16 -  Asynchronous Session EJB
	Part 1 -  Import the Application
	__1.  From Eclipse menubar, select File → Import.
	__2.  Select General → Existing Projects into Workspace and click Next.
	__3.  Choose Select archive file.
	__4.  Use the Browse button to select C:\LabFiles\SimpleMTApp.zip.
	__5.  Click Finish.
	__6.  You should see the projects structure in the Enterprise Explorer as shown below:

	Part 2 -  Develop A Bean
	__1.  In the Project Explorer view, right-click on SimpleMTProject and select New → Session Bean(EJB 3.x).
	The Create EJB 3.x Session window will appear.
	__2.  Set the Java Package to com.simple.async.stateless
	__3.  Set the Class name to AsyncBean
	__4.  Leave the State type as Stateless.
	__5.  Under Create business interface, check no-interface.
	__6.  Your screen should now look like the following:
	__7.  Click Next.
	__8.  On the next screen, uncheck Inherited abstract methods and Constructors from super class.
	Your screen should now look like the following:
	__9.  Click Finish.
	__10.  A bean is created.  In the Enterprise Explorer, expand SimpleMTProject →  ejbModule → com.simple.async.stateless. It should look as shown below.
	__11.  AsyncBean should be open in the editor, if it is not you can open it. We will create a method and annotate as asynchronous.
	__12.  Add the following method:
	__13.  Annotate the above method with @Asynchronous
	__14.  Organize imports (Ctrl+Shift+O). 
	__15.  Save the file. There should not be any errors.
	__16.  Return to the @Stateless annotation of the class and add the 'mappedName' attribute as shown below.
	__17.  Save the file.

	Part 3 -  Create the Web Client
	__1.  In the Project Explorer, right-click on SimpleWebProject and select New → Servlet.
	__2.  Set the Java package to com.simple.servlet
	__3.  Set the Class name to AsyncTestServlet
	__4.  Click Finish.
	__5.  Inside the Servlet, add the following declaration, along with the annotation that will trigger resource injection:
	__6.  Right-click SimpleWebProject and select  Properties.
	__7.  Select Deployment Assembly on the left pane and then select Manifest Entries tab.
	__8.  Click the Add button.
	__9.  Click on SimpleMTProject.jar and then click Finish.
	__10.  Click OK to apply the changes and exit from the project properties dialog.
	__11.  Go back to the Servlet class.  Click anywhere in the editor for AsyncTestServlet.
	__12.  Organize imports.
	__13.  Save the file. There should not be any errors.
	__14.  Locate the doGet() method, and delete all its content.
	__15.  Add the following code to the doGet method.
	__16.   Save the file. There should not be any errors.

	Part 4 -  Deploy and Test
	__1.  Locate the Servers view, at the bottom middle of RAD.
	__2.  Start the server if it is not running. Wait until it finishes starting.
	__3.  Right click on the server and select Add and Remove...
	__4.  In the left pane, select SimpleMTProjectEAR and click Add.
	__5.  Click Finish.
	__6.  If the server is not synchronized then Publish the server.  To do this, right click on the server and select Publish and check the console and wait for the application to be fully deployed.
	__7.  Open a browser and enter the URL: 
	__8.  Look at the console, the output from the method calls showing that the async method is called in a different thread.
	__9.  Close the browser.

	Part 5 -  Asynchronous EJB Calls with Return Value
	__1.  Open the AsyncBean class from SimpleMTProject.
	__2.  Add the following method to  AsyncBean class.
	__3.  Organize imports and select javax.ejb.AsyncResult and java.util.concurrent.Future if prompted.
	__4.  Save the file.
	__5.  Open  AsyncTestServlet.
	__6.  Inside the doGet method first comment everything or add a block comment.
	__7.  Add the following code in the doGet method:
	__8.  Organize the imports (Ctrl + Shift + O) and select java.util.concurrent.Future.
	__9.  Save the file.
	__10.  Right click on the server and select Publish.
	__11.  Clear the console.
	__12.  Open a browser and enter the URL: 
	__13.  Look at the console, you should get.
	__14.  Close all open files.
	__15.  Close all browsers.
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	Lab 17 -  Singleton Session EJB
	Part 1 -  Create Singleton Session Bean
	__1.  In the Project Explorer view, right-click on SimpleMTProject and select New > Session Bean(EJB 3.x).
	__2.  Set the Java Package to com.simple.ejb.singleton
	__3.  Set the Class name to ManageConfig
	__4.  Select the State type as Singleton
	__5.  Under Create business interface, check no-interface.
	__6.  Your screen should now look like the following:
	__7.  Click Next.
	__8.  On the next screen, uncheck Inherited abstract methods and Constructors from super class.
	__9.  Click Finish.
	__10.  A Singleton bean is created, in the Project Explorer expand SimpleMTProject | ejbModule |com.simple.ejb.singleton. It should look as shown below.
	__11.  Add an instance variable:
	__12.  Add a method:
	__13.  Save the file and make sure there is no errors.

	Part 2 -  Create A Servlet
	__1.  In the Project Explorer, right-click on SimpleWebProject and select New | Servlet.
	__2.  Set the Java package to com.simple.servlet.test
	__3.  Set the Class name to SingletonTestServlet
	__4.  Click Finish.
	__5.  Locate the doGet() method of SingletonTestServlet, and delete all its content.
	__6.  Inside the Servlet, add the following Dependency Injection code to access the singleton bean:
	__7.  Organize imports (Ctrl+Shift+O). There should be no errors.
	__8.  We now need to write the test code. We should first set up the print stream so that the servlet can output text to the browser. Add the following code to the doGet method.
	__9.  Add the following code to the doGet method.
	__10.  Organize imports (Ctrl+Shift+O). There should be no errors.
	__11.  Save the file. There should not be any errors.

	Part 3 -  Deploy and Test
	__1.  Start the server if it is not running.
	__2.  If the server is not synchronized then Publish the server.  To do this, right click on the server and select Publish. Check the console and wait for the application to be fully deployed.
	__3.  Open a browser and enter the URL: 
	__4.  You should get the output on the screen as below:
	__5.  Refresh the browser.
	__6.  On the server view, expand the server, right click on the SimpleMTProjectEAR and select Restart. This means only the application is re-started, if you access the above URL again, the counter should reset and begin from one, indicating that the singleton instance is restarted.

	Part 4 -  Test Concurrency and Lock Type
	__1.  Open the ManageConfig bean from SimpleMTProject.
	__2.  Add the following annotation at the class level:
	__3.  Add the following annotation at the getHits method:
	__4.  Add the following method to the bean class:
	__5.  Organize imports (Ctrl+Shift+O). Select javax.ejb.ConcurrencyManagementType. 
	__6.  Save the file. There should not be any errors.
	__7.  Open SingletonTestServlet class.
	__8.  Change the doGet(...) method so it reads as follows (new lines are in bold):
	__9.  Save the file.
	__10.  Publish the server.
	__11.  Right-click on the SimpleWebProject project in the Enterprise Explorer and select New → Package.
	__12.  Enter com.simple.commandLine as the package name:
	__13.  Click Finish.
	__14.  Using Windows Explorer, navigate to C:\LabFiles\SingletonEJB.  Right-click on the file 'HitCountDisplayer.java' and then select Copy.
	__15.  In the Enterprise Explorer in RAD, right-click on the package we just created, com.simple.commandLine, and then select Paste.
	__16.  Close all open files and browsers.
	__17.  Clear the Console.
	__18.  Right-click on the class HitCountDisplayer.java, and then select Run As → java Application.
	__19.  After few seconds the console display should look like this:
	__20.  When the class still running open a web browser and enter the following url into the location bar (note that the url is a single line in the location bar):
	__21.  Watch the console output.  First it will show:
	__22.  Then will switch back to the running console, and will resume:
	__23.  Notice that the reading was delayed by four seconds while the writing thread finished its Thread.sleep() call.  This indicates that the concurrency management delayed the reader while the singleton bean was locked for writing.
	__24.  Close all open browsers.
	__25.  Close all open files.
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	Lab 18 -  EJB Timer Service
	Part 1 -  Programmatic Timer
	__1.  In the Project Explorer view, right-click on SimpleMTProject and select New | Session Bean(EJB 3.x).
	__2.  Set the Java Package to com.simple.ejb.singleton.timer
	__3.  Set the Class name to HelloTimerService
	__4.  Select the State type as Stateless
	__5.  Under Create business interface, check no-interface.
	__6.  Your screen should now look like the following:
	__7.  Click Next.
	__8.  On the next screen, uncheck Inherited abstract methods and Constructors from super class.
	__9.  Your screen should now look like the following:
	__10.  Click Finish.
	__11.  A Singleton bean is created, in the Project Explorer, expand SimpleMTProject | ejbModule |com.simple.ejb.singleton.timer. It should look as shown below.
	__12.  The timer service is obtained by placing an annotated timer service field on the session bean. Do this now by adding the following field definition to the class:
	__13.  Organize imports (Ctrl+Shift+O). There should be no errors.
	__14.  Add the following method to wake up timer service:
	__15.  Organize imports (Ctrl+Shift+O).  Select javax.ejb.Timer. There should be no errors.
	__16.  Add the following method:
	__17.  Organize imports (Ctrl+Shift+O). There should be no errors.
	__18.  Save the class.

	Part 2 -  Create A Test Servlet
	__1.  In the Project Explorer, right click on SimpleWebProject and select New | Servlet.
	__2.  Set the Java package to com.simple.servlet.timer.test
	__3.  Set the Class name to TimerTestServlet
	__4.  Click Finish.
	__5.  Locate the doGet() method of TimerTestServlet, and delete all its content.
	__6.  Inside the Servlet, add the following Dependency Injection code to access the singleton bean.:
	__7.  Organize imports (Ctrl+Shift+O). There should be no errors.
	__8.  Add the following code to the doGet method.
	__9.   Organize imports (Ctrl+Shift+O). There should be no errors.
	__10.  Save the file. There should not be any errors.
	__11.  Close all open files.

	Part 3 -  Test
	__1.  Start the server if it is not running.
	__2.  If the server is not synchronized then Publish the server.  To do this, right click on the server and select Publish. Check the console and wait for the application to be fully deployed.
	__3.  Open a browser and enter the URL: 
	__4.  You should get the output on the screen as below:
	__5.  Look at the Console view for message after 20 seconds.
	__6.  Open the HelloTimerService bean from the SimpleMTProject  and look for scheduleProgrammaticTimer method.
	__7.  Lets change the tc.setPersistent(false); code to tc.setPersistent(true);
	__8.  Save the file.
	__9.  Stop the server.
	__10.  Start the server.
	__11.  Clear the console.
	__12.  Close the browser and open a new one, then enter the URL:
	__13.  Once you see the above message on the browser immediately go back to eclipse's Server's View and Stop the server before 20 seconds elapsed.
	__14.  Once the server is stopped, Start again the server, then look at the console view and you should see that the timer executed the pending task. You will see the following message:

	Part 4 -  Automatic Timer
	__1.  Add the following schedule task to the  HelloTimerService bean.
	__2.  Organize imports (Ctrl+Shift+O). There should be no errors.
	__3.  Save the file. There should not be any errors.
	__4.  Clear the console.
	__5.  Publish the server.
	__6.  Switch to the Console.
	__7.  Stop the server.
	__8.  Close the browser.
	__9.  Close all open files.
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