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Lab 1 - WebSphere Workspace Configuration
In this lab you will configure the RAD workspace to work with a WebSphere test 
environment server.  This will include creating a WebSphere "profile" which will have 
the server definition.  It is sometimes useful to have different profile configurations for 
testing purposes so this process is good to be familiar with.

Part 1 - Create Profile
The WebSphere Application Server software is installed along with RAD.  In this section 
you will run a standard WebSphere tool, the Profile Management Tool, to create a profile.

__1. From the Windows Start menu select Start → Programs → IBM Software 
Delivery Platform → IBM Rational Application Developer 8.0 →  Rational 
Application Developer.

__2. In the workspace window, change the Workspace to C:\workspace

__3. Click OK.
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RAD 8.0.4 will start.

__4. In the Runtime environment and profile settings dialog that appears check that the 
option to '<Create a new profile>' is available and click the Next button.

Note: If you DO NOT get this prompt it is possible that a profile was created for this 
workspace already.  Since it is always best for the user who will be using the workspace 
to create the profile restart RAD and use a different workspace with RAD.  Inform your 
instructor of this to see if it is a common problem in the class.

If there is an existing profile listed in the dialog a previous profile may already exist. 
Let your instructor know about this because although this profile can likely be used with 
your workspace, if it has applications deployed to it from another workspace, there may 
be errors when starting the server.  It is also possible to run the 'Profile Management 
Tool' to create a new profile but this will be complex and should be guided by the 
instructor.
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__5. Uncheck the 'enable administrative security on the profile' option as shown 
below and click the Finish button.

The Features with Trial Licenses dialog will open.

__6. Click Ignore.

__7. If prompted about help content select Work without Help.

__8. Wait until the messages in the lower right corner of RAD disappear to know the 
work of creating the server is complete.
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__9. If prompted by Windows firewall security hit the Cancel button.

__10. Close the Welcome page if it appears.

__11. Select the Servers view on the bottom of the Java EE perspective.

__12. Check that a WebSphere Application Server v8.0 server is shown.

__13. Open the following file: 

C:\IBM\WebSphere\AppServer\logs\manageprofiles\AppSrv1_create.log

__14. Look at the end of the file for the message: 

If you see the message INSTCONFSUCCESS, it means that the WebSphere Application 
Server profile was created correctly.
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__15. Close the log file.

__16. Switch back to RAD and the Servers view.

__17. Make sure the server is stopped.

__18. Double click on the server to open the server properties.

__19. On the right, expand Publishing and select the 'Never publish automatically' 
option.

__20. Save and close the server properties.

__21. Select the WebSphere Application Server v8.0 server that was created in the 
Servers view and click the Start the server button on the right.
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__22. From the menu, select Window > Show View > Console.

__23. Check the Console view as the server starts to look for errors.

__24. Switch back to the Servers view and check that the server was started.

__25. Right click the server and select Stop.

__26. Check that the server was Stopped.

Part 2 - Review
You have now configured a test server to use with the RAD workspace.
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Lab 2 - Develop a Simple RESTful Service
Over the next few labs, our goal will be to learn the fundamentals of the JAX-RS API. 

In this lab, we will develop a very simple RESTful web service. This will let us focus on 
the development process using RAD and the WebSphere server. We will also learn about 
the basic JAX-RS annotations.

The main goal of this lab is to understand how to create a web service project and 
develop a few basic REST services.

Part 1 - Create the Web Service Project
In RAD, the project to use to develop JAX-RS services is just a regular “Dynamic Web” 
project.  When you target a WebSphere 8.0 server, the JAR files for the JAX-RS API are 
already on the classpath.

__1. From the menubar, select File > New > Dynamic Web Project.

__2. Enter AcmeWeb for the Project name.

__3. At the bottom of the window, in the EAR Membership section, click the button 
marked New Project....  (We will want to add this WAR file into an EAR file)

The New EAR Application Project screen will appear.

__4. Set the Project name to AcmeApp and make sure the target server is WebSphere 
8.0.

__5. Click Finish to create the EAR project

You will be returned to the New Dynamic Web Project screen.
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Your screen should now look like the following:

__6. Click Finish.  Both the EAR and the WAR will be created.  If prompted, don't 
switch to the web perspective by clicking No.

__7. Close the 'Technology Quickstarts' if it opens.

We will briefly review the project.

__8. Right click the newly created AcmeWeb project and select Properties.

__9. Now, select the Project Facets property.

__10. Note that the JAX-RS facet is not selected. This facet plays no role in developing 
JAX-RS services for WebSphere 8.0.

__11. Click Cancel to close the dialog.

10

EVALUATIO
N O

NLY



Part 2 - Register the REST Application
There are a few different ways to configure a REST application.  This can depend on if 
you want a common URL prefix for all REST services.  This might be useful if you have 
REST services within a project with other web components.  If you want to register a 
common URL prefix you can do so in a web.xml file.  To save time, this file is given to 
you. You will simply import it.

__1. Open Windows file explorer.

__2. Go to C:\LabFiles\

__3. Copy web.xml

__4. In RAD, paste the file inside the WebContent > WEB-INF folder of AcmeWeb.

__5. Open web.xml and study how the REST application is configured. Switch to the 
Source view and specifically, note the servlet mapping:

    <servlet-mapping>
        <servlet-name>javax.ws.rs.core.Application</servlet-name>
        <url-pattern>/svc/*</url-pattern>
    </servlet-mapping>

This means, the URL for every REST request will start with 
http://host:port/AcmeWeb/svc/. You can choose any other path for the REST application. 
But, we will stick to the short and sweet "svc".

__6. Close the file.
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Part 3 - Create the Resource Class
The Java class that implements a RESTful service is called a resource. We will now 
develop a Java class for a simple service.

__1. Right click AcmeWeb project and select New > Class.

__2. Enter com.acme.services as the package name and SimpleService as the class 
name.

__3. Click Finish to create the new class.

__4. Add a member variable that will help us do logging.

public class SimpleService {
Logger logger = Logger.getLogger("SimpleService");

__5. Organize imports (Control+Shift+O) and select java.util.logging.Logger.  Make 
sure you select the correct class as there are several 'Logger' classes on the classpath.

We will now add the testGET() method. It will not have any business logic. Later, we will 
map this method to a GET request.

__6. Add the method as follows.

public String testGET() {
logger.info("Got a GET request");
return "OK";

}

__7. Save changes.
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Part 4 - Configure the Resource
We will now configure the URI and HTTP method for the service resource and its 
methods. We will use the "/simple" root URI for the service.

__1. Define the URI of the root resource, by adding the @Path annotation above the 
class. 

@Path("/simple")
public class SimpleService {

The testGET() method does not need any path extension. All we have to do is set GET as 
the HTTP method. 

We will also set "text/plain" as the content MIME type of the reply. That is good enough 
for this method. For XML data type, the MIME will be "text/xml".

__2. Set the HTTP method and reply MIME type for the testGET() method sub-resource 
as follows.

@GET
@Produces("text/plain")
public String testGET() {

__3. Organize imports. Select javax.ws.rs.Produces.

__4. Save changes.

Part 5 - Unit Test
We will now exercise the web service from a browser.

__1. Start the WebSphere server.

__2. Right click the WebSphere server and select Add and Remove.

__3. Add the AcmeApp project to the server.

__4. Click Finish.

__5. Right click the server and select Publish. Do this every time you are requested to 
Publish the server.
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__6. Open a web browser and enter the URL: 

http://localhost:9080/AcmeWeb/svc/simple/

__7. You should see OK in the browser.

__8. The Console view in RAD will show the log output.

This proves that our project has been setup correctly and JAX-RS is working fine.

Part 6 - Use Path Extension for Sub-resource
A sub-resource – Java method – can be mapped to an URI extension path. Any HTTP 
request for that path will be handled by that method. We will now create a method that 
will respond to the /simple/mypath URI.

__1. First, add this method to the SimpleService class.

public String testGETWithPath() {
logger.info("Got a GET request with path extension.");
return "OK";

}

__2. Annotate the method as follows.

@GET
@Produces("text/plain")
@Path("/mypath")
public String testGETWithPath() {

__3. Save changes.
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Part 7 - Unit Test
__1. Right click the WebSphere server and select Publish.

__2. In a web browser, enter the URL: 

http://localhost:9080/AcmeWeb/svc/simple/mypath

__3. Make sure that the Console shows the log output.

__4. Open a new browser and re-test the testGET method for regression using the URL: 

http://localhost:9080/AcmeWeb/svc/simple/

__5. Close all open files.

__6. Close all browsers.

Part 8 - Review
In this lab, we created and configured a web service project. We created a very simple 
JAX-RS web service. At this point, you should know how to configure the URI of the 
root resource – the Java class - using the @Path annotation. Also, we configured the 
HTTP method of a sub-resource – a method – using the @GET annotation.
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	Lab 1 -  WebSphere Workspace Configuration
	Part 1 -  Create Profile
	__1.  From the Windows Start menu select Start → Programs → IBM Software Delivery Platform → IBM Rational Application Developer 8.0 →  Rational Application Developer.
	__2.  In the workspace window, change the Workspace to C:\workspace
	__3.  Click OK.
	__4.  In the Runtime environment and profile settings dialog that appears check that the option to '<Create a new profile>' is available and click the Next button.
	__5.  Uncheck the 'enable administrative security on the profile' option as shown below and click the Finish button.
	__6.  Click Ignore.
	__7.  If prompted about help content select Work without Help.
	__8.  Wait until the messages in the lower right corner of RAD disappear to know the work of creating the server is complete.
	__9.  If prompted by Windows firewall security hit the Cancel button.
	__10.  Close the Welcome page if it appears.
	__11.  Select the Servers view on the bottom of the Java EE perspective.
	__12.  Check that a WebSphere Application Server v8.0 server is shown.
	__13.  Open the following file: 
	__14.  Look at the end of the file for the message: 
	__15.  Close the log file.
	__16.  Switch back to RAD and the Servers view.
	__17.  Make sure the server is stopped.
	__18.  Double click on the server to open the server properties.
	__19.  On the right, expand Publishing and select the 'Never publish automatically' option.
	__20.  Save and close the server properties.
	__21.  Select the WebSphere Application Server v8.0 server that was created in the Servers view and click the Start the server button on the right.
	__22.  From the menu, select Window > Show View > Console.
	__23.  Check the Console view as the server starts to look for errors.
	__24.  Switch back to the Servers view and check that the server was started.
	__25.  Right click the server and select Stop.
	__26.  Check that the server was Stopped.

	Part 2 -  Review

	Lab 2 -  Develop a Simple RESTful Service
	Part 1 -  Create the Web Service Project
	__1.  From the menubar, select File > New > Dynamic Web Project.
	__2.  Enter AcmeWeb for the Project name.
	__3.  At the bottom of the window, in the EAR Membership section, click the button marked New Project....  (We will want to add this WAR file into an EAR file)
	The New EAR Application Project screen will appear.
	__4.  Set the Project name to AcmeApp and make sure the target server is WebSphere 8.0.
	__5.  Click Finish to create the EAR project
	__6.  Click Finish.  Both the EAR and the WAR will be created.  If prompted, don't switch to the web perspective by clicking No.
	__7.  Close the 'Technology Quickstarts' if it opens.
	__8.  Right click the newly created AcmeWeb project and select Properties.
	__9.  Now, select the Project Facets property.
	__10.  Note that the JAX-RS facet is not selected. This facet plays no role in developing JAX-RS services for WebSphere 8.0.
	__11.  Click Cancel to close the dialog.

	Part 2 -  Register the REST Application
	__1.  Open Windows file explorer.
	__2.  Go to C:\LabFiles\
	__3.  Copy web.xml
	__4.  In RAD, paste the file inside the WebContent > WEB-INF folder of AcmeWeb.
	__5.  Open web.xml and study how the REST application is configured. Switch to the Source view and specifically, note the servlet mapping:
	__6.  Close the file.

	Part 3 -  Create the Resource Class
	__1.  Right click AcmeWeb project and select New > Class.
	__2.  Enter com.acme.services as the package name and SimpleService as the class name.
	__3.  Click Finish to create the new class.
	__4.  Add a member variable that will help us do logging.
	__5.  Organize imports (Control+Shift+O) and select java.util.logging.Logger.  Make sure you select the correct class as there are several 'Logger' classes on the classpath.
	__6.  Add the method as follows.
	__7.  Save changes.

	Part 4 -  Configure the Resource
	__1.  Define the URI of the root resource, by adding the @Path annotation above the class. 
	__2.  Set the HTTP method and reply MIME type for the testGET() method sub-resource as follows.
	__3.  Organize imports. Select javax.ws.rs.Produces.
	__4.  Save changes.

	Part 5 -  Unit Test
	__1.  Start the WebSphere server.
	__2.  Right click the WebSphere server and select Add and Remove.
	__3.  Add the AcmeApp project to the server.
	__4.  Click Finish.
	__5.  Right click the server and select Publish. Do this every time you are requested to Publish the server.
	__6.  Open a web browser and enter the URL: 
	__7.  You should see OK in the browser.
	__8.  The Console view in RAD will show the log output.

	Part 6 -  Use Path Extension for Sub-resource
	__1.  First, add this method to the SimpleService class.
	__2.  Annotate the method as follows.
	__3.  Save changes.

	Part 7 -  Unit Test
	__1.  Right click the WebSphere server and select Publish.
	__2.  In a web browser, enter the URL: 
	__3.  Make sure that the Console shows the log output.
	__4.  Open a new browser and re-test the testGET method for regression using the URL: 
	__5.  Close all open files.
	__6.  Close all browsers.

	Part 8 -  Review

	Lab 3 -  Extracting Information from a HTTP Request
	Part 1 -  Get Root Resource Path Parameters
	__1.  Open SimpleService.java from the AcmeWeb project.
	__2.  Change the @Path annotation for the class and add a parameter there.
	__3.  Add a member variable as follows.
	__4.  Annotate the member variable to save the value of the myRootPathData parameter.
	__5.  Organize imports.
	__6.  Change the log statement of the testGET() method as follows.
	__7.  Make a similar change to the testGETWithPath() method.
	__8.  Save changes.

	Part 2 -  Unit Test
	__1.  Publish the server.
	__2.  First, test the testGET() method by entering the URL: 
	__3.  The log output will like this:
	__4.  Now, test the testGETWithPath() method using the URL: 
	__5.  The log output will be:

	Part 3 -  Get Sub-resource Path Parameters
	__1.  Add a basic method as follows.
	__2.  Annotate method with path and method.
	__3.  Now, extract the path parameters and save them in the two input argument variables of the method.  The syntax for the @PathParam annotation on a method parameter is tricky so be careful.
	__4.  Save changes.
	__5.  Publish the server.
	__6.  Test the method by entering the URL: 

	Part 4 -  Extract Query Parameters
	__1.  Add the giveRaise() method as shown below.
	__2.  Organize imports.
	__3.  Save changes.
	__4.  Publish the server.
	__5.  Test the change by entering the URL: 
	__6.  Make sure that the Console shows:

	Part 5 -  Extracting Form Post Data
	__1.  Add this method.
	__2.  Organize imports. Select  java.util.List.
	__3.  Save changes.

	Part 6 -  Unit Test
	__1.  We will import the form HTML page. Copy C:\LabFiles\post.html and paste it inside the WebContent folder of the AcmeWeb project.
	__2.  In the Servers view, right click the server and select Publish.
	__3.  Open a browser and enter the URL: 
	__4.  Fill out the form and submit it. 
	__5.  Make sure that the console log shows the input values correctly.
	__6.  Close all open files.
	__7.  Close all open browsers.

	Part 7 -  Review

	Lab 4 -  Designing a RESTful Service
	Part 1 -  The Business Requirements
	Part 2 -  Define Project Scope
	Part 3 -  Designing the Object Model
	__1.  Can you go through the business requirements and identify the entities? 
	__2.  Now that you have identified the entities, can you list the attributes or fields for each entity? Once again, the answer is below. But do your best to do the design yourself.

	Part 4 -  Identify the Service
	__1.  Can you go through the requirements and list the tasks or operations that various yet to be identified services need to perform? Then compare your findings with the answer below.
	__2.  Can you group the operations based on the entity they work with? Name each group as a service accordingly. The answer is below.

	Part 5 -  Design the Service Interface
	__1.  First, let us decide on the URI for each entity. This is a pretty straightforward exercise. Note: As a matter convention, plural forms of the entity names are used in URI.

	Part 6 -  Decide on the Data Format
	Part 7 -  Unaddressed Architectural Issues
	Part 8 -  Review

	Lab 5 -  Add Support for XML Format
	Part 1 -  Create the Entity Classes
	__1.  In the AcmeWeb project, create a package called com.acme.services.entities
	__2.  Within that package, create a Java class called QuoteRequest
	__3.  In the QuoteRequest class, add these member variables. Feel free to refer back to the object model to make sure we are doing this correctly.
	__4.  Generate getters and setters for the variables. To do this select any variable, then from the menu select Source >  Generate Getters and Setters. Click Select All and click OK.
	__5.  Add the @XmlRootElement JAXB annotation to the class as shown in boldface below.
	__6.  Organize imports.
	__7.  Save changes.
	__8.  Open a file browser and go to C:\LabFiles\entities.
	__9.  Copy all the files within the folder and then paste them into the com.acme.services.entities package.
	__10.  Open each entity class file and review them. Specifically, look at the Order class. Working with list of child objects can be tricky in JAXB. Look at how we are dealing with line items:

	Part 2 -  Generate the XML Schema
	__1.  In the Enterprise Explorer view, right click on the com.acme.services.entities package and select New → Other
	__2.  Select JAXB → Schema from JAXB Classes and click the Next button.
	__3.  Expand the AcmeWeb → src folder and select the com.acme.services.entities package to make sure all Java files in the package are selected to be included.
	__4.  Click the Finish button to generate the schema.
	__5.  After a few seconds check that the root of the project has the schema.
	__6.  Open the generated schema file and study it if you wish.

	Part 3 -  Create the Quote Service Class
	__1.  In the com.acme.services package, create a class called QuoteService
	__2.  Set the root URI of the service as shown in boldface below.
	__3.  Add a member variable for logging.
	__4.  Add the getQuote() method as shown below. The business logic is very simple. We hard code the price and availability.
	__5.  Annotate the method as shown below.
	__6.  Organize imports. Select java.util.logging.Logger and javax.ws.rs.Produces.
	__7.  Save changes.

	Part 4 -  Better Content Handling
	__1.  Add the @Consumes annotation to getQuote as follows in bold.
	__2.  Similarly, change the @Produces annotation to support both MIME types for XML.
	__3.  Organize imports. Select javax.ws.rs.core.MediaType.
	__4.  Save changes.

	Part 5 -  Unit Testing
	__1.  Start the server if it is not running.
	__2.  Publish the server.
	__3.  Open a Windows Explorer file browser and verify the following directory exists.  If it doesn't you might need to find out where WebSphere was installed and alter the next several steps accordingly.
	__4.  Open a command window and change directories with the 'cd' command to C:\Software\RESTClient.
	__5.  Issue the following command assuming the WebSphere java directory was at the location previously mentioned:
	__6.  Run the command:
	__7.  In the URL text box, enter: 
	__8.  Select POST method.
	__9.  Click the Body tab.
	__10.  Click the  icon.
	__11.  From the drop-down select the text/xml content type.
	__12.  Click OK.
	__13.  Click the  icon to open the file.
	__14.  Select C:\LabFiles\quote_request.xml and open it.
	__15.  The tool will offer you an option to change the MIME type to application/xml. This is not necessary (either text/xml or application/xml will work fine), click NO.
	__16.  Study the request document briefly.
	__17.  We are now ready start testing. Click the  icon next to the URL.
	__18.  Make sure that the HTTP reply status code is 200.
	__19.  Click the Body tab for the response.
	__20.  Right click the response body text and select Indent > Indent XML.
	__21.  Study the response document.
	__22.  Back in RAD close all open files.
	__23.  Do not close the REST Client.

	Part 6 -  Review

	Lab 6 -  Add Support for JSON
	Part 1 -  Do the Design First
	Part 2 -  Add the JSON Method
	__1.  Open QuoteService class.
	__2.  First, add the shell of the method.
	__3.  Then, annotate the method and the input parameters as shown in boldface below.
	__4.  Now, fill in the body of the method. It basically calls the getQuote() method to get the job done.
	__5.  Organize imports.
	__6.  Save changes.

	Part 3 -  Understanding Content Negotiation
	Part 4 -  Test
	__1.  Publish the WebSphere server by right-clicking and selecting Publish.
	__2.  Launch the REST client tool if it is not already running.  Use steps from previous labs to set the 'JAVA_HOME' variable in the command prompt to launch the tool.
	__3.  Set the URL to: 
	__4.  Choose POST method.
	__5.  Set the body using the XML code in C:\LabFiles\quote_request.xml and set content type to application/xml; chartset=UTF-8.
	__6.  Click the Headers tab.
	__7.  Enter Accept as Key and text/xml as Value.
	__8.  Click the + icon to add the header.
	__9.  Run the test by clicking .
	__10.  Right click the response body area in the Body tab and select Indent > Indent XML.
	__11.  Verify that the reply body contains the response.
	__12.  Select the Accept header, then right click on it and select Delete.
	__13.  Enter Accept as Key and application/json as Value, then click the + icon to add the header.
	__14.  Select the request Body tab and click on the button for 'Insert parameters'
	__15.  Confirm that you want to erase the current body text by clicking the Yes button.
	__16.  Confirm that you want to switch the content type to the value needed for a form, 'application/x-www-form-urlencoded', by clicking the Yes button.
	__17.  Use the tool to add each of the following parameters by filling in the key and value and clicking the button to add the parameter.
	__18.  Once you have all the parameters filled in as shown below, click the Generate button.
	__19.  Run the test.
	__20.  Right click the response body area and select Indent > Indent JSON.
	__21.  Verify the result.
	__22.  Back in RAD close all open files.
	__23.  Do not close the REST Client.

	Part 5 -  Review

	Lab 7 -  Build the Order Web Service
	Part 1 -  Create the Resource Class
	__1.  In the com.acme.services package, create a class called OrderService
	__2.  Annotate the class to set the path as follows.
	__3.  Add a member variable for logging.
	__4.  Organize imports. Select java.util.logging.Logger.
	__5.  Save changes.

	Part 2 -  Implement Order Placement
	__1.  Write the shell of the method as follows. We will not deal with the returned URL just yet.
	__2.  Annotate the method with @POST and @Consumes.
	__3.  Organize imports. Select these classes when prompted (they may come up in a different order):
	javax.ws.rs.core.Response
	com.acme.services.entities.Order
	javax.ws.rs.core.MediaType
	__4.  Save changes.
	__5.  Copy the file C:\LabFiles\OrderDAO.java into the com.acme.services package.
	__6.  Open the class and briefly study it. The code should be very simple.
	__7.  In the placeOrder method of the OrderService class, use OrderDAO as shown in boldface below.
	__8.  Organize imports. Select this class:
	java.util.logging.Level
	__9.  Save changes.

	Part 3 -  Implement Retrieval of Order
	__1.  First write the method shell along with the required annotations.
	__2.  Next, fill in the method body.
	__3.  Organize imports. Select these classes:
	__4.  Save changes.

	Part 4 -  Construct Entity URL
	__1.  First, add a member variable to the class as follows.
	__2.  In the placeOrder() method, add the bold code:
	__3.  Add this line in bold below:
	__4.  Next, add the following line. This plugs in the actual value of the order ID to the path and returns a java.net.URI object.
	__5.  Finally, add this line. 
	__6.  Organize imports. Choose these classes:
	__7.  Save the file and make sure you don't have any compilation errors.

	Part 5 -  Test
	__1.  Go to the 'Servers' view and publish the changes to the server by right clicking the server and selecting 'Publish'.
	__2.  Launch the REST client tool if it is not already running.  Use steps from previous labs to set the 'JAVA_HOME' variable in the command prompt to launch the tool.
	__3.  From the REST client's menubar, select File > Open Request (Control+O).
	__4.  Open C:\LabFiles\order_create.rcq
	__5.  Review these items about the request:
	__6.  Click the  button to send the request.
	__7.  Verify that:
	__8.  In the RAD Console, verify the log output from the OrderDAO class.
	__9.  In the REST client, open the request file C:\LabFiles\order_retrieve.rcq.
	__10.  Inspect these items about the request:
	__11.  Send the request.
	__12.  Verify that the reply body has the correct order information.

	Part 6 -  Enable Error Handling
	__1.  In the placeOrder() method of OrderService class, add this line shown in bold face.
	__2.  Comment out the following unreachable line:
	__3.  Organize imports. 
	__4.  In the getOrder() method, above the line:
	__5.  Organize imports. Choose this class:
	javax.ws.rs.core.Response.Status
	__6.  Save changes.

	Part 7 -  Test
	__1.  Publish the WebSphere server in the Servers view.
	__2.  In the REST client, the order retrieval request file should be open already. Just run the test.
	__3.  Verify that the status code is 404.  This is because the previous order was lost when the application was updated and restarted.
	__4.  Open the request file C:\LabFiles\order_create.rcq.
	__5.  In the Body tab, delete all the <item> elements.
	__6.  Run the test.
	__7.  Verify that status code 500 is returned.
	__8.  Do regression tests to make sure that success conditions are working fine.
	__9.  In RAD close all open files.
	__10.  Do not close the REST Client.

	Part 8 -  Review

	Lab 8 -  Complete the Order Service
	Part 1 -  Implement Order Cancellation
	__1.  In the AcmeWeb project, open OrderService.java
	__2.  Add this method.
	__3.  Add these lines to the cancelOrder() method.
	__4.  Organize imports.
	__5.  Save changes.

	Part 2 -  Test
	__1.  Publish the WebSphere server.
	__2.  Launch the REST client tool if it is not already running.  Use steps from previous labs to set the 'JAVA_HOME' variable in the command prompt to launch the tool.
	__3.  From the client, open the request file C:\LabFiles\order_create.rcq
	__4.  Run the test. You should get a status code of 201. 
	__5.  Open the request file C:\LabFiles\order_retrieve.rcq
	__6.  Run the test. You should get a status code of 200.
	__7.  From the Method tab, select DELETE.
	__8.  Run the test. 
	__9.  Since the reply body is empty, you should see HTTP status code 204. This is equivalent to status 200 and indicates success.
	__10.  In the Method tab, select GET method.
	__11.  Run the test.
	__12.  Verify that 404 is returned.

	Part 3 -  Implement Order History
	__1.  From the com.acme.services.entities package, open OrderList.java and inspect it.
	__2.  Close the class.
	__3.  In the OrderService class, add the method shell as follows.
	__4.  Add the method body as follows.
	__5.  Organize imports.
	__6.  Save changes.

	Part 4 -  Test
	__1.  Publish the WebSphere server.
	__2.  From the REST test client, open the request file C:\LabFile\order_create.rcq
	__3.  From the Body tab, note the client ID – C001.
	__4.  Run the test to create an order.
	__5.  From the Body tab of the request, change the part number and quantity ordered and place a few more orders.
	__6.  From the test client, open the request file C:\LabFiles\order_history.rcq
	__7.  Run the test.
	__8.  Verify the response.

	Part 5 -  Implement Order Update Function
	__1.  In the OrderService class, add the method shell.
	__2.  Fill in the method body as follows.
	__3.  Organize imports.
	__4.  Save changes.

	Part 6 -  Test
	__1.  Publish the WebSphere server.
	__2.  From the REST test client, open the request file C:\LabFile\order_create.rcq
	__3.  Run the test.
	__4.  Add the order ID 1000 to the URL (add  /1000  at the end of the URL).
	__5.  From the Method tab, choose PUT.
	__6.  From the Body tab, change quantity and/or part number.
	__7.  Run the test.
	__8.  Verify that status code 200 is returned.
	__9.  Now lets check the retrieve request. Open the request file C:\LabFiles\order_retrieve.rcq
	__10.  Run the test.
	__11.  Verify that status code 200 is returned.   
	__12.  Format the result (Indent > Indent XML ) and verify that the body contains the information that you changed.
	__13.  Open the request file C:\LabFile\order_create.rcq
	__14.  Change the order ID in the URL to an invalid value as shown below.
	__15.  From the Method tab, choose PUT.
	__16.  Run the test and make sure 404 status code is returned.
	__17.  In RAD, close all the open files.

	Part 7 -  Review

	Lab 9 -  Developing a JAX-RS Client
	Part 1 -  Client Design Considerations
	Part 2 -  Import the Client Application
	__1.  From the RAD menubar, select File > Import.
	__2.  Select General > Existing Projects into Workspace and click Next.
	__3.  Select the 'Select archive file' radio button and use the Browse button to the right to select the C:\LabFiles\SimpleClientStarter.zip file.
	__4.  Make sure both projects are selected as shown above and click Finish.

	Part 3 -  Build the Service Proxy Layer
	__1.  From the AcmeWeb project, copy the com.acme.services.entities package.  Make sure to copy the entire package by right clicking the package and selecting Copy.
	__2.  In the SimpleClient project, paste it in the src folder.
	__3.  In the SimpleClient project, create a package called com.acme.services.proxy
	__4.  In that package, create a class called QuoteProxy
	__5.  In the QuoteProxy class, add a variable to store the service root URL.
	__6.  Add the shell of a method that will invoke the quote web service.
	__7.  In the getQuote() method, add this line to instantiate a org.apache.wink.client.RestClient object.
	__8.  Next, create a Resource object that points to the root web service resource.
	__9.  Add these lines to set the content type of the request and the accept header.
	__10.  Add this line to send a QuoteRequest XML using a POST request.
	__11.  Finally, add this line to return the quote response.
	__12.  Organize imports and select these classes:
	__13.  Save changes.

	Part 4 -  Build the Presentation Layer
	__1.  From the WebContent folder, open index.jsp and study the form.
	__2.  Open result.jsp and study how the QuoteResponse object properties are shown.
	__3.  From the com.webage.servlet package, open QuoteController.java.
	__4.  Locate the doPost method.
	__5.  Below the line:
	__6.  Below the line: 
	__7.  Below the line:
	__8.  Organize imports.
	__9.  Save changes.

	Part 5 -  Test
	__1.  Start the server if it is not running.
	__2.  Deploy SimpleClientEAR project to the server with the Add and Remove.. option when you right click the server.
	__3.  Open a web browser and enter the URL: 
	__4.  Enter some values and click Get Quote.
	__5.  Verify the result.
	__6.  Close the browser.
	__7.  Close all open files.

	Part 6 -  Review

	Lab 10 -  Securing RESTful Services
	Part 1 -  Enable Application Security
	__1.  Make sure the WebSphere server is running and start it if it is not.
	__2.  In the Servers view, right click the server and select Administration → Run Administrative Console.
	__3.  In the navigation on the left side, expand the Security section and click the link for Global security.
	__4.  Click the button for Security Configuration Wizard.
	__5.  On the first page, leave the default options so only Enable application security is checked and click the Next button.
	__6.  Switch the option to Federated repositories and click the Next button.
	__7.  Fill in a value of 'wasadmin' without the quotes for the 'Primary administrative user name' and both password fields and then click the Next button.
	__8.  Click the Finish button to complete the security configuration.
	__9.  In the messages at the top of the Admin Console, click the link to Save the changes.
	__10.  Click the Logout link in the upper right of the Admin Console.
	__11.  Close the Admin Console window.
	__12.  Switch back to the RAD Servers view.
	__13.  Stop the server.
	__14.  Once the server is stopped, double click on the server to open the server properties. 
	__15.  On the right, expand Security.
	__16.  Check the option for 'Security is enabled on this server' and fill in a value of 'wasadmin' without the quotes for the User ID and Password options.
	__17.  Save and close the server properties.
	__18.  Start the WebSphere server from the Servers view. If you see errors starting the server (e.g., "Unable to initialize SSL connection"), then stop the server and close RAD. After that, start RAD again and then start the server. The server should start with no errors.  If you have any problems, please contact your instructor.

	Part 2 -  Secure the Quote Service
	__1.  In the AcmeWeb project expand com.acme.services package.
	__2.  Open QuoteService.java.
	__3.  Add the following annotation in bold to the class.
	__4.  Organize imports. 
	__5.  Save changes.
	__6.  In the Enterprise Explorer view, right click the AcmeApp EAR project and select Java EE → Generate Deployment Descriptor Stub.  Make sure it is the AcmeApp project as the AcmeWeb project will have similar options.
	__7.  In the Enterprise Explorer view, expand AcmeApp → META-INF and double click the application.xml file to open it.
	__8.  Select the Design tab.
	__9.  In the Overview section on the left, click the Add button.
	__10.  Select Security Role and click the OK button.
	__11.  With the new security role selected on the left, fill in a Role Name of 'Customer' without the quotes on the right.
	__12.  Save and close the file.

	Part 3 -  Test
	__1.  Publish the server.
	__2.  Open a browser and enter the URL: 
	__3.  Enter some data and then click Get Quote.
	__4.  The browser will show an error.
	__5.  Close the browser.

	Part 4 -  Run Server with Resources on Server
	__1.  Make sure the server is started.
	__2.  Right click on the server and choose Add and Remove.
	__3.  In the Add and Remove dialog, click Remove All and then click Finish.
	__4.  Right click the server and select Clean. Then click OK to continue.
	__5.  Stop the server.
	__6.  Double click on the server to open the server configuration editor.
	__7.  Under Publishing settings for WebSphere Application Server, click the Run server with resources on Server radio button.
	__8.  Save your changes.
	__9.  Close the file.
	__10.  Add the AcmeApp and SimpleClientEAR projects back to the server.
	__11.  Start the server.

	Part 5 -  Configure Security at the Server
	__1.  Make sure the WebSphere server is running and start it if it is not.
	__2.  In the Servers view, right click the server and select Administration → Run Administrative Console.
	__3.  If you receive security alerts they are for the security certificate of the server.  Click Yes or OK to accept the certificate and continue.
	__4.  Login to the WebSphere Admin Console with a user ID and password of wasadmin.
	__5.  In the navigation section on the left side of the Admin Console navigate to Users and Groups -> Manage Users.
	__6.  Type * in the Search for field and click the Search button to list the current users.
	__7.  Click the Create button and fill in the following user information:
	__8.  When the options are filled in as above click the Create button to create the user.
	__9.  Click the Close button and be sure the new user shows up in the list.
	__10.  Navigate to Applications → Application Types → WebSphere enterprise applications.
	__11.  Click the link for the AcmeApp application.
	__12.  Under the Detail Properties section, click the link for Security role to user/group mapping.
	__13.  Check the checkbox next to the Customer role and click the Map Users button.
	__14.  Press the Search button to list available users.
	__15.  Select the bob user and press the right arrow button to move the user over to the “Selected” list on the right.
	__16.  Press the OK button on the user search page to accept the user.
	__17.  Check that the user is listed on the row with the Customer role and press the OK button.
	__18.  Click the Save link in the messages at the top of the Admin Console.
	__19.  Click the Logout link in the upper right corner of the Admin Console.
	__20.  Close the Admin Console window.

	Part 6 -  Modify the Test Client
	__1.  Launch the RESTClient tool if it is not already running.  Use steps from previous labs to set the 'JAVA_HOME' variable in the command prompt to launch the tool.
	__2.  In the URL text box, enter: 
	__3.  Select POST method.
	__4.  Click the Body tab.
	__5.  Click the  icon.
	__6.  From the drop-down select the text/xml content type.
	__7.  Click OK.
	__8.  Click the  icon to open the file. Click Yes to erase the existing code.
	__9.  Select C:\LabFiles\quote_request.xml and open it. The tool will offer you an option to change the MIME type to application/xml. This is not necessary (either text/xml or application/xml will work fine), click NO.
	__10.  Click the  icon next to the URL.
	__11.  Make sure that the HTTP reply status code is 403.
	__12.  Click the Auth tab.
	__13.  Enter these values:
	__14.  Run the test again.
	__15.  Verify that status code 200 is returned.

	Part 7 -  Enable Audit Logging
	__1.  In the AcmeWeb project, open OrderService.java.
	__2.  Configure the valid role for the service as shown in bold face below.
	__3.  Add a member variable to the class as follows.
	__4.  In the placeOrder() method, below the line:
	__5.  Organize import and select this class:
	__6.  Save changes.
	__7.  Publish the WebSphere server.

	Part 8 -  Test
	__1.  Launch the REST test client if it is not already running.
	__2.  Select File > Open Request from the menubar.
	__3.  Open C:\LabFiles\order_create.rcq
	__4.  Click the  button to send the request.
	__5.  Make sure that a status code 403 is returned.
	__6.  Click the Auth tab.
	__7.  Enter these values:
	__8.  Run the test again.
	__9.  Verify that status code 201 is returned.
	__10.  Check RAD console for the audit log. It will look like this:
	__11.  Close all open browsers.
	__12.  Close all open files.
	__13.  Close REST client.

	Part 9 -  Review




