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Lab 1 - WebSphere Workspace Configuration
In this lab you will configure the RAD workspace to work with a WebSphere test 
environment server.  This will include creating a WebSphere "profile" which will have 
the server definition.  It is sometimes useful to have different profile configurations for 
testing purposes so this process is good to be familiar with.

Part 1 - Create Profile
The WebSphere Application Server software is installed along with RAD.  In this section 
you will run a standard WebSphere tool, the Profile Management Tool, to create a profile.

__1. From the Windows Start menu select Start → Programs → IBM Software 
Delivery Platform → IBM Rational Application Developer 8.0 →  Rational 
Application Developer.

__2. In the workspace window, change the Workspace to C:\workspace

__3. Click OK.
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RAD 8.0.4 will start.

__4. In the Runtime environment and profile settings dialog that appears check that the 
option to '<Create a new profile>' is available and click the Next button.

Note: If you DO NOT get this prompt it is possible that a profile was created for this 
workspace already.  Since it is always best for the user who will be using the workspace 
to create the profile restart RAD and use a different workspace with RAD.  Inform your 
instructor of this to see if it is a common problem in the class.

If there is an existing profile listed in the dialog a previous profile may already exist. 
Let your instructor know about this because although this profile can likely be used with 
your workspace, if it has applications deployed to it from another workspace, there may 
be errors when starting the server.  It is also possible to run the 'Profile Management 
Tool' to create a new profile but this will be complex and should be guided by the 
instructor.
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__5. Uncheck the 'enable administrative security on the profile' option as shown 
below and click the Finish button.

The Features with Trial Licenses dialog will open.

__6. Click Ignore.

__7. If prompted about help content select Work without Help.

__8. Wait until the messages in the lower right corner of RAD disappear to know the 
work of creating the server is complete.

5

EVALUATIO
N O

NLY



__9. If prompted by Windows firewall security hit the Cancel button.

__10. Close the Welcome page if it appears.

__11. Select the Servers view on the bottom of the Java EE perspective.

__12. Check that a WebSphere Application Server v8.0 server is shown.

__13. Open the following file: 

C:\IBM\WebSphere\AppServer\logs\manageprofiles\AppSrv1_create.log

__14. Look at the end of the file for the message: 

If you see the message INSTCONFSUCCESS, it means that the WebSphere Application 
Server profile was created correctly.
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__15. Close the log file.

__16. Switch back to RAD and the Servers view.

__17. Make sure the server is stopped.

__18. Double click on the server to open the server properties.

__19. On the right, expand Publishing and select the 'Never publish automatically' 
option.

__20. Save and close the server properties.

__21. Select the WebSphere Application Server v8.0 server that was created in the 
Servers view and click the Start the server button on the right.
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__22. From the menu, select Window > Show View > Console.

__23. Check the Console view as the server starts to look for errors.

__24. Switch back to the Servers view and check that the server was started.

__25. Stop the server.

Part 2 - Review
You have now configured a test server to use with the RAD workspace.
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Lab 2 - Introduction To Web Services
In this lab, you will review some of the key components of Web Services, namely, WSDL 
and SOAP. You will also get a chance to see a Web Service in action. The goal of this lab 
is to get yourself familiar with what a Web service looks like. We will not get into too 
much detail at this point; just walk away with a basic understanding of the components 
involved in a web service.

The web service in question is very simple. It has one operation called sayHello. It takes 
as input a person's name (say "John") and returns as output a greeting message (say, 
"Hello John").

Part 1 - Import the Projects
To save time, the web service is already implemented. You will simply import it into 
RAD for examination.

You should be in the Java EE perspective, from which we will do the bulk of our work.

The next step is to import the projects into the workspace.  

__1. Right-click anywhere inside the Enterprise Explorer view (the pane on the left) and 
select Import | Import...

__2. The Import screen will appear. In the list of import sources, expand General and 
select Existing Projects into Workspace.

__3. Click Next.

The Import Projects screen will appear.

__4. Select the radio button for Select archive file.  

__5. Next to it, click the Browse... button.

__6. Select the C:\LabFiles\TestWS.zip file and click Open.

The list of Projects will automatically be populated, as shown here:
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__7. Click Finish. 

The projects will be imported into the workspace and will be listed in the Enterprise 
Explorer view.

The two projects imported in the workspace are:

1. TestApp – The enterprise application project. This represents the EAR file in Java 
EE.

2. TestWeb – The web module project. This represents a WAR file in Java EE

Our projects are imported.  Let us take a look at them.

Part 2 - Inspect the Implementation Class
The business logic for a web service is implemented in a Java class. The Java class may 
be a plain class or a session EJB. In this case, we used a plain Java class in a web module. 
We will briefly have a look at it.

__1. In the Enterprise Explorer view, expand the TestWeb project as shown below.
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__2. Double click HelloSvc.java to open it in a Java source code editor.

__3. Examine the class. Note the following aspects of the code:

● By default, the Java method that implements a Web Service operation has the 
same name as the operation.

● The @WebService annotation is used to designate the HelloSvc class as a Web 
Service implementation.

● The @WebMethod annotation is used for the sayHello() method to designate it 
as a Web Service operation. These annotations are made available as a part of the 
JAX-WS specification.

__4. Close the Java editor, by clicking the X in its tab.

__5. Back in the Enterprise Explorer, notice the Services node of the TestWeb project. 
Expand it. 
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This Services node lists all web services located in this web project.  Notice that it has 
located the HelloService service, and is listing it here accordingly, as 
{http://svc.webage.com/}HelloSvcService.  This is a good sign that our annotations are 
correct. 

Remember this node; we will be returning to it frequently. We can now test the service!

Part 3 - Deploy the Project to WebSphere Application Server (WAS)
Before we can test the service, we first need to deploy it to WAS.  We will do this now. 

__1. Locate the Servers view.

The server listed here is the one we will be using for all our deployments for the duration 
of this course.  We now need to add our TestApp project to it.  (Recall that the TestApp 
is an EAR file which contains TestWeb, which in turn contains the service).

__2. Right-click on the server listed and select Add and Remove...

__3. The Add and Remove Projects window will appear. In the left pane, select TestApp 
and click the Add> button.  This will move it to the right pane.  

The next time WAS is started, the project will be deployed.  
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__4. Click Finish.

Remember these steps as you will be deploying projects to WAS repeatedly throughout 
this course.

__5. Back in the Servers view, expand the server and you should see the newly added 
project.

We can now start the server.

__6. Start the server by right-clicking on it (in the Servers view) and selecting Start. 

The server will start up, and the Console view will open. This will display the output of 
the server as it boots up.  

__7. Open again the Servers view and verify the server's State is Started and the server's 
Status is Synchronized.

A Synchronized state means all the latest versions of the code in RAD have been 
deployed to the server.  This means we are able to test our code!

Note that the application is stopped we need to start it.

__8. Right click the server and select Publish.

Now the application is Started and Synchronized.

Part 4 - Examine the WSDL File
A WSDL file is used to describe what a web service can do and what type of input and 
output data it works with.  Let us examine the WSDL file for our service.

__1. In the Enterprise Explorer view, right click on the service beneath the Services node 
(in the TestWeb project) and select Show | WSDL Interface.
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RAD will open the WSDL Editor, which shows a diagram of the service's WSDL file. 

__2. This looks daunting, but we will return to it in more detail in a later lab.  For now, 
click the Source tab at the bottom of the WSDL editor.

The raw XML source code of the WSDL editor will be visible. 

To be honest, this looks even more frightening than the diagram view. Do not worry 
about it for now, though.

__3. Locate the <portType> element of the file.  This describe the Web Service. Note 
that an <operation> element exists with the name attribute set to "sayHello".

__4. Notice the <input> and <output> elements within <operation>.  They describe the 
format of the input and output data for the operation. We won't go any further to explore 
the WSDL at this stage, but will return to it in a later lab.
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__5. Close the WSDL editor.

Part 5 - Invoke the Service
We should now actually test the service.  Testing the service would imply actually 
invoking the operation.  

Typically, doing so would require that we create a web service client.  A web service 
client is, as its name implies, any program that makes a call to a web service.  The 
program could be written in Java, .NET, or any other language that understands web 
service standards. 

Writing a client can be time consuming, so we will “cheat” and use a tool built into RAD 
called the Web Services Explorer (WSE).  The WSE works by reading a WSDL file and 
then figuring out what services are available and how to invoke them.  The WSE will 
then dynamically generate a form that represents the service's operations that will allow 
you to invoke it.

Think about this for a moment: our service, at its core, was a single operation called 
sayHello which took a single string as a parameter.  The service would then return a 
greeting based on that parameter. 

Let us try this now.

__1. In the Enterprise Explorer, under TestWeb, right-click the service (under Services) 
and select Test with Web Services Explorer.

The WSE will open.
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Notice that it has located our service and has noticed the sayHello operation, which is 
listed in the right pane.  

__2. Click the link for sayHello. The WSE will create and display a form to enter the 
input data for the sayHello operation.

The WSE realizes that the operation requires a parameter, and the form presents a 
location to add one.  

__3. Click the Add link and enter a name. 

16

EVALUATIO
N O

NLY



__4. Click Go.

The WSE will take the name you entered and submit it to the service.  

The Status pane should now appear, immediately below the pane in which you entered 
the argument. 

This shows what the call to the web service returned. In this case, it will show Hello 
[name]

Our service works! We have successfully tested our service with the WSE.

Part 6 - Inspect the SOAP Messages
When we invoked the sayHello operation, WSE actually sent a SOAP formatted XML 
document to the server using the HTTP protocol. The server also replied back using a 
SOAP formatted XML document. SOAP is a versatile data format for request response 
type communication. In its most basic form, as is the case in this lab, it is utterly simple. 
At the same time, it is capable of taking on more advanced aspects of communication, 
such as, encryption, message signature, transaction and guaranteed delivery.

__1. In the Status pane of WSE, click the Source link.

The raw underlying XML SOAP messages will be displayed.
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__2. The windows are probably too small to see, however; double-click in the pane 
header (where it says Status) to maximize the window. 

__3. Briefly inspect the request and response messages as shown above. Don't worry 
about the details. You will learn SOAP shortly.

__4. Restore the Status window to the original size.

Congratulations!   You have successfully examined the source code for a web service, and 
then invoked it via the WSE. 
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__5. Close the WSE by clicking the X in its pane. 

__6. Close all open windows by selecting CTRL+Shift+W.

__7. Stop the server.  To do this, open the Servers view, right-click on the server listed 
and select Stop.

Part 7 - Review
In this lab, you had a brief encounter with a web service. First, we looked at the Java 
class that implements the business logic of the Web Service. That is the true meat behind 
the Web Service. When building a Web Service, you will probably spend most of the time 
writing the business logic. Next, we inspected the WSDL file that describes the nature of 
the Web Service. After that we tested the Web Service and inspected the SOAP messages.

The lab also served two other purposes. You learned how to deploy an application to the 
server. We will do that frequently throughout these lab exercises. You also found out how 
to use the Web Services Explorer to quickly unit test a Web Service.
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Lab 3 - Creating An XML Schema
An XML schema is used to verify that the contents of an XML file are valid; essentially, 
it is a set of “rules” for an XML file.  A particular XML file can be checked against a 
particular schema, and a parser can decide if the XML conforms to the rules set out in the 
schema.  

If, for some reason, the XML does not conform to the schema, the XML parser can reject 
the XML and raise an immediate error.  Essentially, schema adds a layer of validation to 
any XML-based application. Given that web services use XML as their communication 
layer, we can see the value of schema.  Schema are actually used quite frequently in the 
various layers of web service communication.

In this lab, we will create an XML schema.

Part 1 - The Movie.xml File
Throughout these labs, we will be developing a system that deals with movies.  We have 
thus decided to model a movie as an XML file.  This modeling will come in handy when 
we start building the web service. 

__1. Let us start things off by taking a look at a sample movie.xml file.  Using a text 
editor, open file C:\LabFiles\movie.xml

It looks like the following: 

<?xml version="1.0" encoding="UTF-8"?>
<m:database xmlns:m="http://www.mycom.com/movie">

<movie title="Preaching to the Choir" rating="PG13">
<description>
Two estranged brothers -- one a hip-hop star and
the other a Baptist preacher -- find a way 
to make amends and help one another out as 
they each face a crisis in their lives.
</description>
<actor>Billoah Greene</actor>
<actor>Novella Nelson</actor>

</movie>
<movie title="Kekexili: Mountain Patrol" rating="PG13">

<description>
A moving true story about volunteers protecting
antelope against 
poachers in the severe mountains of Tibet.
</description>
<actor>Zhang Lei</actor>
<actor>Qi Liang</actor>

</movie>
</m:database>
<!-- Contains some copyrighted material from imdb.com -->
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Let us analyze this XML file.

The outermost element is called <database> and it contains multiple <movie> elements. 

Each <movie> has two attributes; one called title and one called rating, which reflects a 
movies title and rating respectively. 

Additionally, each <movie> has a single child element called <description> (which 
contains a description of the movie in question) and multiple elements called <actor>, 
with each one representing an actor in the associated movie. 

This is a fairly simple modeling of the movie.  We capture some important information 
about each movie (the title, the description, the rating and the actors), and store this 
information using a mixture of attributes and child elements. 

What we should do now is formalize this model by creating an schema for the 
<database> element (remember that the root element here is <database>, not <movie>).

Once that is done, an application reading/writing one of these movie XML files will be 
able to use the schema to validate that the structure of the XML is good.  (Validating the 
content of the XML, however, is another matter completely).

__2. Close the text editor.

Part 2 - Create the Project
A schema is itself an XML file, and we could create it using a text editor.  However, 
RAD provides some nice tools for creating a schema, so we will use those instead. 

__1. We will now create a new project to hold our schema file.  From the RAD menu bar, 
select File | New | Project...

__2. The New Project window will appear.  In the list, select Java Project and click 
Next.

__3. The New Java Project screen will appear. Set the Project name to be XMLProject 
and click Finish.
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__4. RAD will then prompt you if you would like to switch to the Java Perspective.

__5. Check Remember my decision and click No.

The XMLProject project will be created and listed in the Enterprise Explorer view. (You 
may want to minimize all other projects – e.g. TestWeb and TestApp in the Enterprise 
Explorer to keep things a little easier to read)

We should create a folder to hold our XML resources. 

__6. Right-click on the newly created XMLProject and select New | Folder.

__7. The New Folder window will appear.  Set the Folder name to be xml and click 
Finish.

The folder will be created, and should be visible under the project.
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Part 3 - Create the Schema
We can now create the schema.

__1. Right click on the newly created xml folder and select New | Other...

__2. The New window will appear. Scroll down and expand XML.  

__3. Select XML Schema and click Next.

__4. The Create XML Schema window will appear.  Set the File name to be movie.xsd 
and click Finish. (By convention, schemas always have an XSD extension)

The XML Schema Editor will open.  This is RAD's graphical XSD schema editor. This 
will save us having to create the schema by hand.  

We will be using this editor to design our schema.  

Initially, the editor displays a simplified view of the schema.  We will want the detailed 
view, which will make creation of our schema easier. 

__5. In the top right corner of the editor, click the drop-down arrow next to Simplified 
and change it to Detailed.

__6. RAD will prompt you, notifying you that you are switching view modes.  Check the 
box Don't show me this again and click OK.

You should now be looking at the detailed view of the schema editor.

23

EVALUATIO
N O

NLY



First, we should change the schema's default name space which is currently set to 
http://www.example.org/movie as can be seen at the top of the editor.

__7. Right-click on this area and select Show properties.

Now, at the bottom of RAD, the Properties view should have opened.

__8. Here, change the Prefix to m

__9. Change the Target namespace to http://www.mycom.com/movie
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We should also specify that by default, the namespaces are not qualified.  

__10. Click the Advanced tab in the left.

__11. Change the Prefix for Elements drop down to a blank.

__12. Save changes by hitting Ctrl-S.

The editor should update with the new namespace.

We can now go about defining the types that make up this schema.  The core type 
represents the movie data, which we will call the movieType.  (The other type is the 
<database>, which is composed of multiple movieType elements – we will get to that 
later).

We will get started defining the movieType.   Recall that we want the movieType to 
model rating, description, title and multiple actors as a combination of attributes and 
elements.

__13. Right click inside the Types pane and select Add Complex Type.

__14. A new type will appear.  Change its name to movieType

The type has been defined.  We now need to specify what data it contains.  

__15. Double click on the newly created movieType.

The view will change to a closeup of the movieType.  
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It is from here that we can add elements/attributes.  Let us add the description element 
first.   

__16. Right-click on the movieType and select Add Element.

__17. A new element box will appear.  Rename it to description

Notice that the type for description was automatically set to string.  This is fine because 
we want our description modeled as a string.

We have now just declared that our schema defines a type called movieType which itself 
has an element called description of type string.

Now, we can add the actor element. 

__18. Right click on movieType  and again select Add Element.  

__19. This time, name it actor
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Recall however, that our movie should have one or more actor elements associated with 
it.  We can specify that here in the schema by using multiplicity

__20. Right click on the actor element and select Set Multiplicity | 1..* (One or more)

In the Properties for actor the minimum and maximum occurrence will change.

Now we can add the rating and title attributes.

__21. Right click on movieType and select Add Attribute.

__22. Name the attribute title

__23. Repeat this step and add another attribute called rating
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The movieType element should now look like this.

As discussed earlier, a movieType has attributes for title and rating and elements for 
description and multiple actors.   (All of these are of type string)

We now need to define a database element that contains multiple instances of this 
movieType.  

__24. Go back to the main schema design page by clicking the icon in the top left corner.

__25. Back at the main schema page, the movieType should be shown.

__26. Right click in the Elements pane (on the left) and select Add Element.

__27. Name it database

Let us now define that a database is composed of multiple movie elements. We will do 
so using an anonymous type.  

__28. Right click on database and select Set Type | New...
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The New Type window will appear.

__29. Check Create as local anonymous type.   This will grey out the Name field. 

__30. Click OK.

Seemingly, nothing will change.  

__31. Double click on database.

We see that the database element points to something called a (database type).  This is 
an anonymous field, which means is basically just a placeholder for another element type 
– like our movie!  (Using anonymous types can simplify schema).

We should now specify that the (databaseType) points to multiple movie elements.

__32. Right click on (databaseType) and select Add Element.

__33. A new element will be created.  Name the element movie

__34. We know there are multiple movies, so we should set the multiplicity.  Right click 
on movie and select Set Multiplicity | 1..* (One or more)

__35. Click the database to refresh the diagram.
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One more thing. We have to set the type of each movie element to be movieType.

__36. Double click on string and a drop-down box should appear. 

__37. Select Browse... from the drop-down box. 

The Set Type window will appear.

__38. In the Name field, enter movieType (or scroll through the list and select it) 

__39. Click OK.

The editor will now show the association between the <movie> element and the 
movieType.
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We are done! 

__40. Hit Ctrl-S to save changes.

We have completed creating the schema.

Part 4 - Examine the Schema
We have now successfully created a schema using the RAD schema editor tool.  The tool 
generated all the necessary code for us; let us take a look at it now.  

__1. Click the Source tab at the bottom of the schema editor. The raw source code 
forming the schema will be displayed.  It should look like the following:

<?xml version="1.0" encoding="UTF-8"?>
<schema targetNamespace="http://www.mycom.com/movie"
elementFormDefault="qualified" xmlns="http://www.w3.org/2001/XMLSchema"
xmlns:m="http://www.mycom.com/movie">

<complexType name="movieType">
<sequence>
<element name="description" type="string"></element>
<element name="actor" type="string" maxOccurs="unbounded"

minOccurs="1">
</element>
</sequence>
<attribute name="title" type="string"></attribute>
<attribute name="rating" type="string"></attribute>

</complexType>

<element name="database">
<complexType>
<sequence>

<element name="movie" type="m:movieType"
maxOccurs="unbounded" minOccurs="1">

</element>
</sequence>
</complexType>

</element>
</schema>

Notice that the schema itself is written in XML. 

__2. Go through it and mentally understand what is being described here.

We state that a database is composed of 1 or more movie elements.  Each movie element 
is of type movieType.
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A movieType is composed of elements representing description and 1 or more actor, 
and attributes representing the title and rating. 

If you compare this with the movie.xml we examined at the start of this lab, you should 
realize that movie.xml indeed conforms to the rules set out in the schema.  

Now, when an XML parser reads movie.xml, it can automatically check with this xsd to 
ensure it is valid.  We will use this schema in later labs in exactly this manner.

__3. Close the schema editor. 

Part 5 - Review
In this lab, you examined XML schema. 

We started off by examining an XML file that gave us an idea of how to represent a 
movie.  

We then created a schema that to formalize these rules of representation.  We used the 
RAD schema editor to create the XML file and in there defined the various elements and 
attributes that should make up a movie database.

Finally, we examined the raw XML source behind the schema to get a feel for what it 
describes, and saw that it indeed validates the movie.xml that we started off with.
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	__24.  Switch back to the Servers view and check that the server was started.
	__25.  Stop the server.

	Part 2 -  Review

	Lab 2 -  Introduction To Web Services
	Part 1 -  Import the Projects
	__1.  Right-click anywhere inside the Enterprise Explorer view (the pane on the left) and select Import | Import...
	__2.  The Import screen will appear. In the list of import sources, expand General and select Existing Projects into Workspace.
	__3.  Click Next.
	__4.  Select the radio button for Select archive file.  
	__5.  Next to it, click the Browse... button.
	__6.  Select the C:\LabFiles\TestWS.zip file and click Open.
	__7.  Click Finish. 

	Part 2 -  Inspect the Implementation Class
	__1.  In the Enterprise Explorer view, expand the TestWeb project as shown below.
	__2.  Double click HelloSvc.java to open it in a Java source code editor.
	__3.  Examine the class. Note the following aspects of the code:
	__4.  Close the Java editor, by clicking the X in its tab.
	__5.  Back in the Enterprise Explorer, notice the Services node of the TestWeb project. Expand it. 

	Part 3 -  Deploy the Project to WebSphere Application Server (WAS)
	__1.  Locate the Servers view.
	__2.  Right-click on the server listed and select Add and Remove...
	__3.  The Add and Remove Projects window will appear. In the left pane, select TestApp and click the Add> button.  This will move it to the right pane.  
	__4.  Click Finish.
	__5.  Back in the Servers view, expand the server and you should see the newly added project.
	__6.  Start the server by right-clicking on it (in the Servers view) and selecting Start. 
	__7.  Open again the Servers view and verify the server's State is Started and the server's Status is Synchronized.
	__8.  Right click the server and select Publish.

	Part 4 -  Examine the WSDL File
	__1.  In the Enterprise Explorer view, right click on the service beneath the Services node (in the TestWeb project) and select Show | WSDL Interface.
	__2.  This looks daunting, but we will return to it in more detail in a later lab.  For now, click the Source tab at the bottom of the WSDL editor.
	__3.  Locate the <portType> element of the file.  This describe the Web Service. Note that an <operation> element exists with the name attribute set to "sayHello".
	__4.  Notice the <input> and <output> elements within <operation>.  They describe the format of the input and output data for the operation. We won't go any further to explore the WSDL at this stage, but will return to it in a later lab.
	__5.  Close the WSDL editor.

	Part 5 -  Invoke the Service
	__1.  In the Enterprise Explorer, under TestWeb, right-click the service (under Services) and select Test with Web Services Explorer.
	__2.  Click the link for sayHello. The WSE will create and display a form to enter the input data for the sayHello operation.
	__3.  Click the Add link and enter a name. 
	__4.  Click Go.

	Part 6 -  Inspect the SOAP Messages
	__1.  In the Status pane of WSE, click the Source link.
	__2.  The windows are probably too small to see, however; double-click in the pane header (where it says Status) to maximize the window. 
	__3.  Briefly inspect the request and response messages as shown above. Don't worry about the details. You will learn SOAP shortly.
	__4.  Restore the Status window to the original size.
	__5.  Close the WSE by clicking the X in its pane. 
	__6.  Close all open windows by selecting CTRL+Shift+W.
	__7.  Stop the server.  To do this, open the Servers view, right-click on the server listed and select Stop.

	Part 7 -  Review

	Lab 3 -  Creating An XML Schema
	Part 1 -  The Movie.xml File
	__1.  Let us start things off by taking a look at a sample movie.xml file.  Using a text editor, open file C:\LabFiles\movie.xml
	__2.  Close the text editor.

	Part 2 -  Create the Project
	__1.  We will now create a new project to hold our schema file.  From the RAD menu bar, select File | New | Project...
	__2.  The New Project window will appear.  In the list, select Java Project and click Next.
	__3.  The New Java Project screen will appear. Set the Project name to be XMLProject and click Finish.
	__4.  RAD will then prompt you if you would like to switch to the Java Perspective.
	__5.  Check Remember my decision and click No.
	__6.  Right-click on the newly created XMLProject and select New | Folder.
	__7.  The New Folder window will appear.  Set the Folder name to be xml and click Finish.

	Part 3 -  Create the Schema
	We can now create the schema.
	__1.  Right click on the newly created xml folder and select New | Other...
	__2.  The New window will appear. Scroll down and expand XML.  
	__3.  Select XML Schema and click Next.
	__4.  The Create XML Schema window will appear.  Set the File name to be movie.xsd and click Finish. (By convention, schemas always have an XSD extension)
	__5.  In the top right corner of the editor, click the drop-down arrow next to Simplified and change it to Detailed.
	__6.  RAD will prompt you, notifying you that you are switching view modes.  Check the box Don't show me this again and click OK.
	__7.  Right-click on this area and select Show properties.
	__8.  Here, change the Prefix to m
	__9.  Change the Target namespace to http://www.mycom.com/movie
	__10.  Click the Advanced tab in the left.
	__11.  Change the Prefix for Elements drop down to a blank.
	__12.  Save changes by hitting Ctrl-S.
	__13.  Right click inside the Types pane and select Add Complex Type.
	__14.  A new type will appear.  Change its name to movieType
	__15.  Double click on the newly created movieType.
	__16.  Right-click on the movieType and select Add Element.
	__17.  A new element box will appear.  Rename it to description
	__18.  Right click on movieType  and again select Add Element.  
	__19.  This time, name it actor
	__20.  Right click on the actor element and select Set Multiplicity | 1..* (One or more)
	__21.  Right click on movieType and select Add Attribute.
	__22.  Name the attribute title
	__23.  Repeat this step and add another attribute called rating
	__24.  Go back to the main schema design page by clicking the icon in the top left corner.
	__25.  Back at the main schema page, the movieType should be shown.
	__26.  Right click in the Elements pane (on the left) and select Add Element.
	__27.  Name it database
	__28.  Right click on database and select Set Type | New...
	__29.  Check Create as local anonymous type.   This will grey out the Name field. 
	__30.  Click OK.
	__31.  Double click on database.
	__32.  Right click on (databaseType) and select Add Element.
	__33.  A new element will be created.  Name the element movie
	__34.  We know there are multiple movies, so we should set the multiplicity.  Right click on movie and select Set Multiplicity | 1..* (One or more)
	__35.  Click the database to refresh the diagram.
	__36.  Double click on string and a drop-down box should appear. 
	__37.  Select Browse... from the drop-down box. 
	__38.  In the Name field, enter movieType (or scroll through the list and select it) 
	__39.  Click OK.
	__40.  Hit Ctrl-S to save changes.

	Part 4 -  Examine the Schema
	__1.  Click the Source tab at the bottom of the schema editor. The raw source code forming the schema will be displayed.  It should look like the following:
	__2.  Go through it and mentally understand what is being described here.
	__3.  Close the schema editor. 

	Part 5 -  Review

	Lab 4 -  JAXB Programming
	Part 1 -  Generating the Bindings
	__1.  Right click XMLProject and select Refresh.
	__2.  Expand the xml folder of the XMLProject.
	__3.  Right click the movie.xsd file and select Generate → Java.
	__4.  For the type of generator, select Schema to JAXB Java Classes from the drop down.  Click the Next button when your selection appears as below.
	__5.  Change the Target Package to 'com.jaxb.movie' as shown below and click the Finish button.  
	__6.  Expand the src folder of project XMLProject. 
	__7.  A newly created package com.jaxb.movie should appear.  Expand it and you should see the generated binding classes.

	Part 2 -  Use the Binding Classes To Read XML
	__1.  Right click XMLProject and select New > Package.
	__2.  Enter com.mycom.test as the Name and click Finish.
	__3.  Right click the com.mycom.test package ans select New > Class.
	__4.  Enter JAXBMoviePrinter as Name.
	__5.  Check the Public static void main check box.
	__6.  Click Finish.
	(If you have trouble typing in the following code, we have provided the completed class source code at C:\LabFiles\JAXBMoviePrinter.java.solution  Feel free to copy and paste if necessary).
	__7.  In the main method, we first need to setup the unmarshaler. Add the following code to the main method. 
	__8.  There are some errors in the code.  To fix a few of them, perform an Organize imports. (Ctrl + Shift + O) , selecting javax.xml.bind.Unmarshaller when prompted. After you do this, you will still see some errors, but ignore them for now.  
	__9.  Recall that in our schema, that “top-most” element was database.  If you look at the generated binding classes, you will notice that a Database class was created.  We can use the unmarshaler to create an instance of this object.  Add the following code:
	__10.  Fix this by performing an Organize Imports  which is done by typing Ctrl-Shift-O. Select java.io.File when prompted.  There will still be some errors.  Do not worry about them for now. 
	__11.  Remember that a <database> element contained several <movie> elements. Similarly, the database object will have a field that represents a list of MovieType objects.  We can get this list.  Add the following code:
	__12.  We now have a hold of the list of movies that the database was keeping track of.  We can iterate through it, and operate on it!  Let us simply go through the list and print the title of each movie.  Add the following code:
	__13.  Organize imports again, by hitting Ctrl-Shift-O. Select java.util.List when prompted.
	__14.  Select all the code in the main method (but not the method declaration). 
	__15.  Right click on it and select Surround With->Try/catch block.
	__16.  Save the code.

	Part 3 -  Test JAXB
	__1.  Right click on the code and select Run As > Java Application.
	__2.  Close all open editors.

	Part 4 -  Review

	Lab 5 -  Create A Bottom Up Web Service
	Part 1 -  Create the Project
	__1.  From the menu, select File | New | Dynamic Web Project.
	__2.  Enter WebServiceProjectWAR for the Project name.
	__3.  At the bottom of the window, in the EAR Membership section, click the New Project....  button (We will want to add this WAR file into an EAR file)
	The New EAR Application Project screen will appear.
	__4.  Set the Project name to WebServiceProjectEAR
	__5.  Click Finish.  
	__6.  Click Finish.  Both the EAR and the WAR will be created.
	__7.  Close the Technology Quickstarts view.  You will not need it. 
	__8.  Start the Server. Wait until finish publishing.
	__9.  Right click on the server and select Add and Remove Projects..
	__10.  Click Add All.
	__11.  Click Finish.
	__12.  Right click the Server and select Publish.

	Part 2 -  Create the Implementation Class
	__1.  Right click on WebServiceProjectWAR and select New->Class.
	__2.  Set the Package to be com.simple
	__3.  Set the Name to be Greeter   (we will re-create the class we created in Lab 1).
	__4.  Click Finish.
	__5.  Add the following method to the class:
	__6.  Save the code.  There should be no errors.

	Part 3 -  Annotate the Class
	__1.  We should first mark the class as being a web service.  To do this, add the following annotation in bold to the class, right before the class definition:
	__2.  Annotate the sayHello method as follows in bold:
	__3.  There will be two errors on the code, complaining about the annotations.  Fix that now by performing an Organize Imports. (Ctrl-Shift-O).
	__4.  Save the code.  There should be no errors.

	Part 4 -  Deploy and Test the Service
	__1.  Open the Servers view.
	__2.  Right click the server and select Publish.
	__3.  In the Enterprise Explorer, click the Services tab.  This will open the Services view.  
	__4.  Expand the JAX-WS tree.
	__5.  Open a web browser and navigate to: 
	__6.  In the Services view, right-click on the WebServiceProjectWAR service and select Show > WSDL Interface.
	__7.  Select the Source tab to view the file as code.
	__8.  Scroll down to the bottom of the code and verify the soap address has been updated to the service URL.  If it is not showing the above URL continue with the steps, there is a note about this later (Step 10).
	__9.  In the Services view, right-click on the WebServiceProjectWAR service and select Test with Web Services Explorer.
	__10.  Verify the Endpoint is configured as shown above. If not then close all open files, stop the server, start the server and run the service again. If the endpoint is not updated then you will need to create a new workspace and perform this Lab again. Ask your instructor for help, there is the solution for previous Lab in C:\LabFiles\Solutionsthat you can import and start again this lab again.
	__11.  Look in the Actions pane, on the right, click in the sayHello operation.
	__12.  For now, however, we can still test our service.  Click the Add link, and a field will appear.
	__13.  Enter a name into the field.
	__14.  Click Go.
	Our web service has been invoked successfully!

	Part 5 -  Change the Implementation
	__1.  In the WSE, examine the Action pane.
	__2.  Click Go.
	__3.  In the lower Status pane of the WSE, click the Source link.  
	__4.  Maximize the Status pane by double clicking on its title bar. 
	__5.  Return the Status pane to its normal size by double clicking on it again. 
	__6.  Switch back to the Enterprise Explorer view and open Greeter.java in the editor again (under com.simple package). 
	__7.  Update the @WebService annotation of the class to look like the following:
	__8.  Now, let us fix the arg0 problem.  Add the following annotation to the parameter of the sayHello method, as follows in bold:
	__9.  Organize imports.  There should be no errors. 
	__10.  Save the file.
	We have updated our implementation class by changing (and adding) annotations.
	__11.  We now need to push these latest code changes out to the server.  Locate the Servers view and Publish the server by right-clicking on it and selecting Publish.

	Part 6 -  Examine the Updated Service
	We should now see if the annotations worked. 
	__1.  Go back to the WSE which should still be pointing at the GreeterService. 
	__2.  Click the “Refresh” button, which is to the right of the title bar in the Navigator pane of the WSE.
	__3.  Click the sayHello link again.  
	__4.  Notice the parameter is now called greet_name as opposed to arg0 as it was before.  
	__5.  Click Add, enter a name and click Go.
	__6.  Click the Source link in the Status pane, and then maximize the Status pane.
	Notice that the default namespace has been updated to www.example.org
	Congratulations!  You have successfully updated the web service implementation by making use of the annotations. 
	__7.  Stop the server.
	__8.  Close all open editor windows, including the WSE.
	__9.  Close the web browser that you opened.

	Part 7 -  Review

	Lab 6 -  Creating A WSDL File
	Part 1 -  Create A WSDL File
	__1.  In the Enterprise Explorer view, right click on WebServiceProjectWAR and select New | Folder.
	__2.  The New Folder window will appear.  Set the Folder name to be wsdl and click Finish.
	__3.  In the Enterprise Explorer view, expand the XMLProject → xml folder.
	__4.  Copy the movie.xsd file.
	__5.  Paste the movie.xsd file into the wsdl folder of the WebServiceProjectWAR project.
	__6.  Right click on the wsdl folder and select New > Other...
	__7.  In the New window that appears, expand Web Services and select  WSDL.
	__8.  Click Next.
	__9.  Set the File name to be movie_service.wsdl
	__10.  Click Next.
	__11.  Set the Target namespace to be http://www.mycom.com/movie
	__12.  Set the Prefix to be m
	__13.  Click Finish.
	__14.  Take a moment to examine the source code of the underlying WSDL file.  It may seem a little daunting, but we will examine in a little more detail later on.
	__15.  Click the Design tab at the bottom of the editor.  This shows a graphical representation of the WSDL file and is much easier to deal with.  
	__16.  Change the WSDL Editor to Advanced view by using the drop-down in the top right corner of the editor. 
	__17.  When you do this, you will be prompted with a box informing you that you are Switching View Modes. Click OK.
	__18.  First of all, let us rename the service to something a little more proper.  In the port box (the box on the left), click the title area where movie_service is displayed.  Click the text movie_service and rename it to MovieService
	__19.  Beneath it, in the same manner (i.e. clicking on the text and then renaming it), change movie_serviceSOAP to MovieServiceSOAPPort
	__20.  Let us rename the service first.  In the operation box (the box on the right) click NewOperation and rename it to addMovie
	__21.  Click on parameters next to input and rename it to movieToAdd
	__22.  Click on parameters next to output and rename it to opStatus
	__23.  Click on the right-facing arrow on the far right of the input row.
	__24.  Click the Design tab at the bottom of the editor.  The view will change to show a diagram.
	__25.  Click on the icon in the top left of the editor.
	__26.  In the Directives box, right-click and select Add Include.
	__27.  Leave the default option of Workbench projects and click the Next button.
	__28.  Expand WebServiceProjectWAR → wsdl and select the movie.xsd file.
	__29.  Click the Finish button to create the link to the file.
	__30.  In the Elements area, double click on addMovie.
	__31.  In the box on the right, rename in to movie
	__32.  We now need to set the type.  Double-click on string and expand the dropdown that appears.
	__33.  In the list, click on Browse...
	__34.  In the list, locate movieType and double-click on it.
	__35.  Go back to the main schema view by clicking on the icon in the top left of the editor.
	__36.  In the Elements box, double-click on addMovieResponse. 
	__37.  Rename the out to status
	__38.  We are done!  Save changes by hitting Ctrl-S.
	__39.  Close the Inline Schema of movie_service.wsdl view.  (Leave the other editor, showing movie_service.wsdl open)

	Part 2 -  Examine the Generated WSDL Source
	__1.  Click the Source tab at the bottom of the WSDL editor.
	__2.  The indentation may be a little off; right click anywhere on the source and select Source | Format.
	__3.  Save all the files by selecting from the menu, File > Save All.
	__4.  Close the WSDL editor. 

	Part 3 -  Review

	Lab 7 -  Creating A Top-Down Web Service
	Part 1 -  Generate the Implementation Classes
	__1.  Generating a web service implementation from a WSDL file is quite simple in RAD. In the Enterprise Explorer, expand WebServiceProjectWAR > wsdl. 
	__2.  Right-click on movie_service.wsdl and select Web Services | Generate Java bean skeleton.
	__3.  Drag the top slider down to Assemble service.
	__4.  Click Finish.

	Part 2 -  Examine the Generated Artifacts
	__1.  First,  the project needs to be “refreshed” so the generated components will be picked up by RAD. In the Enterprise Explorer, right click WebServiceProjectWAR and select Refresh.
	__2.  Expand WebServiceProjectWAR | Java Resources | src | com.mycom.movie
	__3.  Open MovieService.java
	__4.  Next, open MovieType.java

	Part 3 -  Create the Implementation Class
	__1.  Open Movie_serviceSOAPImpl.java.  This was the first class that was opened in the editor automatically by RAD when we generated the service. 
	__2.  Set the code for addMovie method as shown in boldface below:
	__3.  Organize imports and select java.util.List when prompted.
	__4.  Save the code.  There should be no errors.
	__5.  In the Enterprise Explorer, expand the Services node in the WebServiceProjectWAR

	Part 4 -  Test the Service
	__1.  Close all open editor windows.
	__2.  Start the server.
	__3.  Publish the server. 
	__4.  Right-click on the service under the Services node in the Enterprise Explorer and select Test with Web Services Explorer.
	__5.  Click the addMovie link.
	__6.  Click Add.
	__7.  Enter some sample data.  (To add multiple actors, click the Add button next to actor).
	__8.  Click Go.  The service will be invoked.
	__9.  Try adding a few more movies and make sure everything works. 
	__10.  Close all open files.

	Part 5 -  Review

	Lab 8 -  Developing A Web Service Client
	Part 1 -  Generate the Client Stub
	__1.  Create a new Java Project called WebServiceClientProject  
	__2.  Do not switch over to the Java perspective. 
	__3.  In the WebServiceClientProject, create a new Java class called StandaloneMovieClient  having  com.movie as package with a main method.
	__4.  In the Enterprise Explorer, expand the Services node of the WebServiceProjectWAR.
	__5.  Right-click on {http://www.mycom.com/movie}MovieService and select Generate > Client.
	__6.  On the left, drag the slider down to Assemble Client.
	__7.  On the right, under Configuration, click the link that says Client project: TestWeb
	__8.  Change the Client Project drop-down to WebServiceClientProject and click OK.
	__9.  Click Finish.  The stub will be generated. 
	__10.  In the Enterprise Explorer, right-click on WebServiceClientProject and select Refresh.
	__11.  Expand the src folder in WebServiceClientProject.  Notice a new package com.mycom.movie has been created.  This package contains our client stub classes! Expand it.
	__12.  Open the MovieService_Service.java file. This is the client side proxy class.
	__13.  Close all open files.

	Part 2 -  Code the Client
	__1.  Open the source for StandaloneMovieClient.java. (which was in the com.movie package in the WebServiceClientProject project)
	__2.  We should first create an instance of a movie and populate it with some data.  Add the following code to the main method.
	__3.  Organize imports, to import the MovieType class. There should be no errors.
	__4.  Add the following code to the main method, after the movieType code:
	__5.  Organize imports.  There should be no errors. 
	__6.  We can now go ahead and invoke the service.  Add the following code at the end of the main method.
	__7.  Save the code.  We have completed coding our client.

	Part 3 -  Run the Client
	__1.  Run the StandaloneMovieClient class as a Java application. To do this, right click anywhere on the source code and select Run As > Java Application.  
	__2.  Switch to the Console for the class by clicking in the icon to display all consoles running and selecting the <terminated> StandaloneMovieClient console.
	__3.  Check the console for the server.  (To view it, click the  button in the console tool bar.  It will swap between the console for the server and for our standalone program)

	Part 4 -  Adding A Web Layer
	__1.  Close all open editor windows. (Ctrl-Shift-W)
	__2.  Create a new Dynamic Web Project called MovieClientWebAppWAR belonging inside an Enterprise Application Project called MovieClientWebAppEAR
	__3.  Close the Technology Quickstarts window that appears.
	__4.  Navigate to C:\LabFiles and locate file index.jsp.  Copy it into the WebContent folder of the MovieClientWebAppWAR project.
	__5.  Open up and take look at this index.jsp in the editor.  It is a very simple form that posts to a servlet called AddMovieServlet. It is the servlet that will take the data input from the form, and invoke the service with it. We will code this servlet in a moment. 
	__6.  Close the file.
	__7.  Right click the server and select Publish.  Remember, we need the deployed WSDL file to generate a client. 
	__8.  In the Enterprise Explorer, expand WebServiceProjectWAR | Services.
	__9.  Right-click on {http://www.mycom.com/movie}MovieService and select Generate | Client.
	__10.  Drag the slider down to Assemble Client.
	__11.  The client project should already be set to MovieClientWebAppWAR. If it is not, change it.
	__12.  Click Finish.
	__13.  Refresh the MovieClientWebAppWAR project.
	__14.  Expand the project and make sure the client stub classes were generated. 
	__15.  Right click  MovieClientWebAppWAR and select New > Other.
	__16.  Expand Web and select Servlet.
	__17.  Click Next.
	__18.  Enter  AddMovieServlet  as name and com.movie.servlet package.
	__19.  Click Finish.
	__20.  An editor will open on the servlet.  In the servlet code, locate the doPost method. Here, we will now add the code to get the data submitted from the form and create a new movie based on that data. 
	__21.  Add the following code in the doPost method.
	__22.  Organize imports.
	__23.  Now that we have a populated movie, we can make a call to the service!  Add the following code in the doPost method:
	__24.  Organize imports.
	__25.  Add the following code in the doPost method:
	__26.  We are done!  Save the code.  There should be no errors. 

	Part 5 -  Deploy and Test
	__1.  Right click on the server and select Add and Remove...
	__2.  Select MovieClientWebAppEAR  and select Add.
	__3.  Click Finish.
	__4.  Publish the server.
	__5.  Right-click on index.jsp under WebContent in the MovieClientWebAppWAR project and select Run As | Run On Server.
	__6.  Make sure your WAS server is selected.
	__7.  Check the box to always use this server.
	__8.  Click Finish.
	__9.  Enter some sample data.
	__10.  Click Add Movie.
	__11.  Check the server console to make sure the appropriate print statements are generated.
	__12.  Close all open editor windows.

	Part 6 -  Review

	Lab 9 -  Monitoring SOAP Messages
	Part 1 -  Activate the Monitor 
	__1.  Start the server if it is not running. The server must be running to activate the monitor. 
	__2.  Open the Servers view. 
	__3.  Right-click on the server and select Monitoring | Properties.
	__4.  Click the Add... button.
	__5.  Select 9080 in the list.  This is the web container port on which our web services are running. 
	__6.  Click OK.
	__7.  Select the monitor and click Start.
	__8.  Click OK.

	Part 2 -  Update the Client
	__1.  In the Enterprise Explorer, expand WebServiceProjectWAR | Services.
	__2.  Right-click on {http://www.mycom.com/movie}MovieService and select Show |  WSDL Interface.
	__3.  Scroll to the bottom of the WSDL file and locate the <soap:address> tag.
	__4.  Close the WSDL file.
	__5.  Open AddMovieServlet.java located in the MovieClientWebAppWAR project.
	__6.  Add the following lines to the doPost method.  Notice they are added right before the call to service.addMovie(movie) line.
	__7.  Organize imports and select java.util.Map when prompted.
	__8.  Save the file.  There should be no errors.  (If a Publishing Error notification appears, merely ignore it)
	We are done updating our client.  Now, when the servlet attempts to invoke the service, it will go through port 9081, which is exactly what we want.

	Part 3 -  Test
	Let us now invoke the service.  If all goes well, any traffic the web service encounters will be displayed in the TCP/IP monitor. 
	__1.  Publish the server.
	__2.  Run the JSP. To do this, open a web browser and navigate to: 
	__3.  Enter some sample data  and click Add Movie.
	__4.  In RAD, down by the Console view, a new TCP/IP Monitor tab should have appeared.  Click on its tab.
	__5.  Maximize the TCP/IP Monitor view by double-clicking on its tab.
	__6.  In both of these panes, change the byte drop-down to say XML. This will make the formatting a little easier to read.
	__7.  Examine the request message.
	__8.  Now, look at the response message.
	__9.  Return the TCP/IP Monitor view to its original size by double-clicking on its tab.

	Part 4 -  WS-I Validation
	__1.  In the top right hand corner of TCP/IP Monitor, click the Validate WS-I Message Log File toolbar button.
	__2.  In the list, select MovieClientWebAppWAR and click Finish.
	__3.  Click OK to dismiss the dialog.
	__4.  Close all open editor windows.

	Part 5 -  Review

	Lab 10 -  Controlling JAXB Mappings
	Part 1 -  Update the Implementation
	__1.  In the WebServiceProjectWAR, create a new Java class called  Person  belonging to package  com.beans
	__2.  Add the following two fields to the class.
	__3.  Save the class.
	__4.  In the Outline view (to the right), select both fields.
	__5.  Right click on these selected fields and select Source | Generate Getters and Setters...
	__6.  Click the OK button.  
	__7.  Save the file.  
	__8.  Close it. 
	__9.  We have greeted our Java bean.  Now, let us create an operation that uses it. Open Greeter.java (in the com.simple package, in the WebServiceProjectWAR)
	__10.  Add the following method to the class:
	__11.  Now, add the following method:
	__12.  Organize imports.  When prompted, select com.beans.Person and click Finish.
	__13.  Save changes.  There should be no errors.

	Part 2 -  Test the Web service
	__1.  Publish the server. Wait until finish synchronizing.
	__2.  Start the WSE on the GreeterService.  To do this, expand Services in the WebServiceProjectWAR, right-click on {www.example.org}GreeterService and select Test with Web Services Explorer.
	__3.  Click the createPerson link.
	__4.  Click the Add link and then enter a name.  
	__5.  Click Go.
	__6.  Click the Source link and then maximize the pane.
	__7.  Minimize the Status pane.
	__8.  Execute the getPersonName method.  (This can be done by clicking the getPersonName in the left pane).
	__9.  Click the Form link the Status pane to show the original return message. 
	__10.  Click the Add button, next to arg0.  What happens?
	__11.  Click Add for both these fields.  
	__12.  Enter some sample data for both fields (the date can be any String) and click Go.
	__13.  The expected response is returned.  Maximize the Status pane and examine the Source. Look at the SOAP Request Envelope.
	__14.  Click the Form link the Status pane to show the original return message. 
	__15.  Minimize the Status pane to its normal size in the WSE.  
	__16.  Close the WSE.  

	Part 3 -  Change the JAXB Mappings
	__1.   Open Person.java 
	__2.  Add the following annotation in bold to the class.
	__3.  That means that JAXB will directly access the member variables (without going through the getter and setter methods). 
	__4.  Now, annotate the two fields as follows:
	__5.  A few errors will appear.  Organize imports (Ctrl-Shift-O). When prompted, select javax.xml.bind.annotation.XmlElement and click Finish.
	__6.  Save the class. There should be no errors.  
	__7.  Close Person.java

	Part 4 -  Fix the Return Element
	__1.  Open Greeter.java
	__2.  Locate the createPerson method, and add the following bolded annotation :
	__3.  Organize imports.
	__4.  Save changes.  There should be no errors.

	Part 5 -  Test JAXB Binding Changes
	__1.  Publish the server. 
	__2.  Open the WSE on the service, as you did before.
	__3.  Run the createPerson operation again.
	__4.  Click Add. 
	__5.  Enter a name and click Go.
	__6.  Examine the source for the response.  (Click the Source link and maximize the pane)
	__7.  Close all open editor windows.

	Part 6 -  Review

	Lab 11 -  Develop EJB Based Service
	Part 1 -  Create the Projects
	__1.  From the menu, select File | New | EJBProject.
	__2.  Set the Project name to EJBService
	__3.  In the EAR Membership area of the window, click New Project...
	__4.  Set the Project name to EJBServiceEAR
	__5.  Click Finish.
	__6.  Check that the new EAR project is listed and click the Finish button.
	__7.  Three projects will be created: EJBService, EJBServiceClient and EJBServiceEAR. Make sure you see them in the Enterprise Explorer.
	__8.  Close all files.

	Part 2 -  Create the EJB
	__1.  In the Enterprise Explorer, right click on the EJBServiceClient project and select New → Package.
	__2.  Enter com.webage.beans for the new package name and click the Finish button.
	__3.  Right click the new com.webage.beans package and select New → Class.
	__4.  Enter a class name of Soup but DON'T click the Finish button yet.
	__5.  Click the Add... button next to the empty list of interfaces.
	__6.  In the dialog that appears enter 'serializable' in the box and then pick the java.io.Serializable interface from the list and click the OK button.
	__7.  Check that your dialog appears as below, including the 'Serializable' interface and click the Finish button.
	__8.  In the editor that opens add the following two fields.
	__9.  From the RAD menus select Source → Generate Getters and Setters.
	__10.  In the dialog click the Select All button and click the OK button to generate the code.
	__11.  Save and close the Soup class.
	__12.  In the Enterprise Explorer, right click on the EJBService project and select New | Session Bean.
	__13.  Set the Java package to com.webage.ejb
	__14.  Set the Class name to OrderSoup
	__15.  In the section Create Business Interface, uncheck No-interface and check Remote.
	__16.  Check that your dialog appears like that below and click Finish.
	__17.  Add the following method to the class:
	__18.  Organize imports (Source → Organize Imports).
	__19.  Save the class.  There should be no errors. 
	__20.  We now need to promote the orderSoup method to the remote interface.  In the Enterprise Explorer, expand EJBService | ejbModule | com.webage.ejb.
	__21.  Right-click on OrderSoup.java and select Java EE Tools | Promote Methods...
	__22.  Check orderSoup(Soup) and click OK.

	Part 3 -  Test the Session Bean
	__1.  Start the WebSphere test server.
	__2.  Add EJBServiceEAR to the server.
	__3.  Publish the server.
	__4.  In the Enterprise Explorer, expand EJBService | EJBService | Session Beans.
	__5.  Right-click on OrderSoup and select Run As | Run On Server.
	__6.  Check the box at the bottom marked Always use this server when running this project.
	__7.  Click Finish.
	__8.  In the left pane of the UTC, expand EJB Beans | OrderSoupRemote | OrderSoupRemote if it isn't already.
	__9.  Click String orderSoup(Soup).
	__10.  Click the plus sign next to the Soup parameter so you can see the two properties that make it up.
	__11.  In the Value field, enter any name and soupType and click Invoke.
	__12.  Close the UTC but leave the server running.

	Part 4 -  Create the Web Service
	__1.  Open OrderSoup.java from the com.webage.ejb package of the EJBService project in the editor.
	__2.  Add the @WebService annotation to the class, immediately after the @Stateless annotation.
	__3.  Organize imports and save the code.  There should be no errors although there will be a warning about the lack of a router module.
	__4.  Close the file. 
	__5.  In the Enterprise Explorer, expand EJBService | Services.
	__6.  Right-click on {http://ejb.webage.com/}OrderSoupService and select Create Router Modules (Endpoint Enabler)
	__7.  Make sure HTTP is selected and click Finish.  
	__8.  Expand EJBService_HTTPRouter and open the project's web deployment descriptor (in WebContent | WEB-INF | web.xml)
	__9.  Click on the Source tab.  Notice the following:
	__10.  Close all open files.

	Part 5 -  Test the Web Service
	We can now test our web service wrapped session EJB.  We will do so using the WSE.
	__1.  Restart the server.
	__2.  Right-click on {http://ejb.webage.com/}OrderSoupService and select Test with Web Services Explorer.
	__3.  Click the link for the 'orderSoup' operation on the right.
	__4.  Click the Add link to add a parameter to the request body.
	__5.  Click the Add links again to be able to enter values for the parameters.
	__6.  Click the Go button and verify you get the expected response.
	__7.  Close the Web Services Explorer.

	Part 6 -  Create A Web Client
	__1.  We should create a web project to hold our client.  Create a new Dynamic Web Project called EJBServiceWebClient belonging to an EAR called EJBServiceWebClientEAR.  Make sure the web project is NOT added to an existing EAR project but a new EAR project.
	__2.  Make sure you are in the Java EE perspective.
	__3.  Make sure the server is running.
	__4.  In the Enterprise Explorer, expand EJBService | Services.
	__5.  Right-click on {http://ejb.webage.com/}OrderSoupService and select Generate → Client.
	__6.  Drag the slider down to Assemble client.
	__7.  Change the Client project to EJBServiceWebClient.
	__8.  Click Finish once your dialog appears as shown below.
	__9.  Refresh and then expand EJBServiceWebClient.  Make sure you see the client stub!
	__10.  Now, in the EJBServiceWebClient project, create a servlet called OrderServlet in the com.webage.servlet package.  You can do this by selecting the project, selecting File → New → Servlet from the list, filling in the dialog as shown below and clicking Finish.
	__11.  Set the text of the doGet(..) method to the following:
	__12.  Organize imports.  
	__13.  Save changes. There should be no errors.
	__14.  Close all open files.
	__15.  Copy and paste file C:\LabFiles\input.html into the WebContent folder of EJBServiceWebClient

	Part 7 -  Test 
	__1.  Add EJBServiceWebClientEAR to the server.
	__2.  Publish the server.
	__3.  Right-click on input.html (under EJBServiceWebClient | WebContent) and select Run As | Run on Server.
	__4.  The Run On Server screen may appear.  Check the box at the bottom marked Always use this server when running this project and click Finish.
	__5.  Fill in some sample input and click the Order button.
	__6.  Make sure that the response shows the appropriate response.
	__7.  Back in the Console view you should see a message that the web service request was indeed processed by the EJB code.
	__8.  Close all open files and web browsers.
	__9.  Stop the server.

	Part 8 -  Review

	Lab 12 -  Handle Web Service Faults
	Part 1 -  Create the Exception Class
	__1.  In the Enterprise Explorer, right-click on the EJBServiceClient project and select New → Class.
	__2.  Set the Package to be com.webage.ejb
	__3.  Set the Name to be BadCustomerException
	__4.  Set the Superclass to be java.lang.Exception
	__5.  Click Finish when your options match those below.
	__6.  Add the following annotations to the class declaration:
	__7.  Add the following code to the class:
	__8.  Organize imports.
	__9.  Save the file.  There should no errors.
	__10.  Close all open files. 

	Part 2 -  Modify Service Implementation Using Exception
	__1.  Open the OrderSoupRemote.java file in the com.webage.ejb package in the EJBServiceClient project.
	__2.  Modify the method on the interface to throw the exception:
	__3.  Save the interface and make sure there are no errors in the interface although you may have errors in other classes.
	__4.  Close the OrderSoupRemote.java file.
	__5.  Open the OrderSoup.java file in the com.webage.ejb package in the EJBService project.
	__6.  Modify the method signature to throw the exception class and the method implementation to check if the 'customerName' is "Elaine" and throw the exception if it is.
	__7.  Save and close all open files.

	Part 3 -  Test Web Service Fault
	__1.  Make sure your WebSphere server was stopped and stop it if it was running.
	__2.  Start the WebSphere server again.
	__3.  In the Enterprise Explorer, expand EJBService | Services.
	__4.  Right-click on {http://ejb.webage.com/}OrderSoupService and select Show → WSDL Interface.
	__5.  Click on the Source tab of the editor.
	__6.  There is a <fault ..> element in the definition of the 'orderSoup' operation of the service port.
	__7.  Close the WSDL file.
	__8.  In the Enterprise Explorer, expand EJBService | Services.
	__9.  Right-click on {http://ejb.webage.com/}OrderSoupService and select Test with Web Services Explorer.
	__10.  Click the orderSoup operation.
	__11.  Click the Add link next to the main operation parameter.
	__12.  Click the Add link next to the 'customerName' and 'soupType' elements of the form to create empty text boxes for these parameters.
	__13.  Fill in a 'customerName' of "Elaine" and a type of soup.
	__14.  Click Go.
	__15.  You will get a message that the content can't be displayed in this view.
	__16.  Click the Source link and maximize the Status pane.
	__17.  Examine the SOAP Response Envelope.
	__18.  Minimize the Status pane.
	__19.  Close the Web Services Explorer.
	__20.  Leave the WebSphere server running.

	Part 4 -  Modify Web Client to Handle Fault
	__1.  Expand the EJBServiceWebClient → Java Resources → src folders.
	__2.  Select the com.webage.ejb package.
	__3.  Right click the selected package and select Delete and then confirm you want to delete the package.  You will get errors in other code.
	__4.  Make sure your WebSphere server is running.
	__5.  In the Enterprise Explorer, expand EJBService | Services.
	__6.  Right-click on {http://ejb.webage.com/}OrderSoupService and select Generate → Client.
	__7.  Drag the slider down to Assemble client.
	__8.  Make sure the Client project is EJBServiceWebClient.
	__9.  Click Finish once your dialog appears as shown below.
	__10.  Refresh and then expand EJBServiceWebClient.  You will still have errors in the servlet.  Notice there are some classes generated for the Exception.
	__11.  Open the OrderServlet.java file in the com.webage.servlet package.
	__12.  Find the doGet method and modify the code at the end of the method to match the following:
	__13.  Organize imports.
	__14.  Save the file.  There should no longer be any errors in the project.

	Part 5 -  Test Updated Web Client
	__1.  Return to the Servers view and publish the server by right clicking the server and selecting Publish after making sure the server is running first.
	__2.  Right-click on input.html under WebContent in the EJBServiceWebClient project and select Run As → Run On Server.
	__3.  If prompted, leave all deployments selected and click Finish.
	__4.  Fill in some sample input (without using "Elaine" as the name) and click the Order button.
	__5.  Make sure that the response shows the appropriate response.
	__6.  Click the back arrow button in the upper left of the embedded browser to return to the form.
	__7.  Fill in data using the name "Elaine" and click the Order button.
	__8.  Check that you get the correct output that is triggered by the web service fault being returned from the service back to the client.
	__9.  Close all open files and web browsers.
	__10.  Stop the server.

	Part 6 -  Review

	Lab 13 -  Managed Service Client
	Part 1 -  Change Deployment Method for Test Server
	__1.  Start the server.
	__2.  Right-click on the server and select Add and Remove...
	__3.  Select the Remove All button to remove all projects from the server.
	__4.  Click the Finish button in the dialog.
	__5.  Right click the server and select Clean and click OK.
	__6.  Stop the server.
	__7.  Double click the server to open the server configuration editor.  You can also right click and select Open if double clicking does not open it.
	__8.  On the right side of the editor, expand the section for Publishing settings for WebSphere Application Server.
	__9.  Select the 'Run server with resources on Server' option as shown below.
	__10.  Save and close the server configuration editor.
	__11.  Start the server and be sure you don't get any errors in the Console view when starting.
	__12.  Right-click on the server and select Add and Remove...
	__13.  Add only the EJBServiceEAR and EJBServiceWebClientEAR projects.
	__14.  Click the Finish button in the dialog.
	__15.  Publish the server.
	__16.  Make sure you do not get any errors in the Console view when publishing.

	Part 2 -  Test Client
	__1.  Right-click on input.html (under EJBServiceWebClient | WebContent) and select Run As | Run on Server.
	__2.  Fill in some sample input (without using "Elaine" as the name) and click the Order button.
	__3.  Make sure that the response shows the appropriate response.
	__4.  Click the back arrow button in the upper left of the embedded browser to return to the form.
	__5.  Fill in data using the name "Elaine" and click the Order button.
	__6.  Check that you get the correct output that is triggered by the web service fault being returned from the service back to the client.
	__7.  Close the test browser but leave the server running.

	Part 3 -  Simulate Deploying the Client to a Different Environment
	__1.  Expand the EJBServiceWebClient → WebContent → WEB-INF → wsdl folder.
	__2.  Double click the OrderSoupService.wsdl file to open it.  This file defines the endpoint location currently used by the client code.
	__3.  Switch to the Source tab.
	__4.  At the bottom of the file change the SOAP address location property to 'localhost:9085'.  This port is not available on the server and will represent the client not being able to communicate with the version of the service used to develop the code.
	__5.  Save and close the file.
	__6.  Publish the server.
	__7.  Right-click on input.html (under EJBServiceWebClient | WebContent) and select Run As | Run on Server.
	__8.  Fill in any name on the input form and submit.  You should get an error shown.
	__9.  If you look in the Console view you should be able to find an error that mentions a 'ConnectException'.  You will not get many details besides the type of error but it is clear this is related to a network communication problem.
	__10.  Close the browser you were using to test the application but leave the server running.

	Part 4 -  Modify Code to Provide a Managed Endpoint Capability
	__1.  Expand the EJBServiceWebClient → Java Resources → src → com.webage.ejb folder.
	__2.  Open the OrderSoupService.java file by double clicking it.
	__3.  Notice the @WebServiceClient annotation.  This declares a "name" for the service client and a default WSDL location which is the file you edited previously.  The generated code also extends the javax.xml.ws.Service class.
	__4.  Look for the constructors in the class a little further down.  Notice that the constructor that doesn't take parameters uses the default WSDL location to construct a reference to the service.
	__5.  Close the OrderSoupService class.  
	__6.  Expand the com.webage.servlet package in the EJBServiceWebClient project.
	__7.  Open the OrderServlet.java file.
	__8.  In the doGet method remove the line of code that is crossed out below.  You will get errors after doing so but they will be fixed later.  You may also get errors if the server tries to republish but ignore them for now.
	__9.  Add the following code in bold as a new field in the class.  Make sure to add it inside the brackets for the class but outside of any other method.
	__10.  Organize imports (CTRL-SHIFT-O) to include the import for the WebServiceRef annotation.
	__11.  Save the code and be sure there are no errors.

	Part 5 -  Change Endpoint Binding Administratively
	__1.  Publish the server.
	__2.  Right-click on the server and select Add and Remove...
	__3.  Remove the EJBServiceWebClientEAR project by selecting it and clicking the Remove button.
	__4.  Click Finish in the dialog. Wait for the server to finish publishing.
	__5.  Publish the server.  
	__6.  Right-click on the server and select Add and Remove...
	__7.  Add the EJBServiceWebClientEAR project by selecting it and clicking the Add button.
	__8.  Click Finish in the dialog.
	__9.  Publish the server.  Wait for the server to finish publishing.
	__10.  Right click the server in the Servers view and select Administration → Run administrative console.
	__11.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__12.  Click the link for the EJBServiceWebClientEAR application.
	__13.  Scroll down and in the list of 'Web Services Properties'  click the link for Service clients.
	__14.  Click the link for one of the Modules on the right.  If you click the service name on the left it will take you to web service policies which are not being used for this web service.
	__15.  Under 'Web Services Properties' click the link for Web services client bindings.
	__16.  Click the first 'Edit' link in the 'Port Information' column.  Make sure you do not click the link in the 'mappings' column.
	__17.  Accept the default URL option as shown below and press the OK button.  This will apply the URL with the correct port to the endpoint binding.
	__18.  Click the Save link in the messages at the top of the Admin Console.
	__19.  Click the Logout link at the top of the Admin Console and close it.

	Part 6 -  Verify Client Works with the New Binding
	__1.  Right-click on input.html (under EJBServiceWebClient | WebContent) and select Run As | Run on Server.
	__2.  Fill in some sample input and click the Order button.
	__3.  You should get the "normal" output of the client which will be the "Served" or "Bad Customer" message depending on the name.  You will not get the generic error page you saw before because of the connection error when the client used the wrong port.

	Part 7 -  Get WSDL Files of Published Service (Optional)
	__1.  Right click the server in the Servers view and select Administration → Run administrative console.
	__2.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__3.  Click the link for the EJBServiceEAR application.
	__4.  Scroll down and in the list on the right of 'Web Services Properties' click the link for Publish WSDL files.
	__5.  On the page that appears click the link for the zip file of WSDL files.
	__6.  If prompted to open or save the file, open it with zip file software if possible.  If you can't open it directly save it first and then open the zip file.
	__7.  Expand the folders of the zip file if needed until you see the 'OrderSoupService.wsdl' file.
	__8.  Open the 'OrderSoupService.wsdl' file with a text editor like WordPad.  If you need to, extract the file first and then open it.
	__9.  Scroll down in the WSDL file and notice at the end that the SOAP address uses the actual hostname of your machine (which will be different than shown below).  Since this address uses the actual hostname and not 'localhost' this address could be used by a client even on another machine to link to this service implementation.
	__10.  Close the WSDL and the zip file.
	__11.  Back in RAD close all.

	Part 8 -  Review

	Lab 14 -  Getting Setup for WS-Security
	Part 1 -  Review Code
	__1.  Right-click on WebSphere Application Server in the list of servers and select Add and Remove...
	__2.  Click Remove All.
	__3.  Click Finish.
	__4.  Stop the server.
	__5.  We will now import the given projects and study before apply any security setting.
	__6.  From the menu select File > Import.
	__7.  Expand General and select Existing Projects into Workspace.
	__8.  Click Next.
	__9.  Chose the 'Select archive file' option and click the second Browse button next to the archive option.
	__10.  Select the ZIP file C:\LabFiles\Billing.zip and click Open.
	__11.  Click Select All to select all projects.
	__12.  Click Finish to import the projects.
	__13.  Expand the BillingWeb project.
	__14.  Then expand Java Resources > src > com.webage.billing.
	__15.  Double click BillingManager.java to open the provider implementation class.
	__16.  Notice that the @WebService annotation is used for the class.
	__17.  The class has only one public method called addAccount. Various JAX-WS annotations are used with that method to customize the XML schema for the request and response.
	__18.  Note that the addAccount operation simply prints out a few lines in the log file and finally returns "OK".
	__19.  Close the editor.
	__20.  Expand ClientWeb project.
	__21.  Then expand Java Resources > src > com.webage.servlet.
	__22.  Double click BillingClient.java to open the servlet implementation class.
	__23.  Observe the following:
	__24.  Close the editor.

	Part 2 -  Deploy the Applications
	__1.  Open the Servers view.
	__2.  Start the server.
	__3.  Launch a browser window like IE or FireFox.
	__4.  Enter the URL: 
	__5.  Enter anything as user ID (wasadmin) and log in.
	__6.  Expand Applications.
	__7.  Click New Application.
	__8.  Click New Enterprise Application.
	__9.  Make sure that Local file system is selected.
	__10.  Click Browse.
	__11.  Select C:\LabFiles\BillingApp.ear and click Open.
	__12.  Click Next.
	__13.  Leave the default in the How do you want to install the application? page and click Next.
	__14.  In the Step1: Select installation options page just click Next.
	__15.  In the Step 2: Map modules to servers page, again just click Next.
	__16.  In the Step 3: Metadata for modules page, again just click Next.
	__17.  Click Finish.
	__18.  The application will be installed, wait until you see the following message: 
	__19.  Click Save.

	Part 3 -  Test the Application
	__1.  On the left hand side, expand Applications > Application Types.
	__2.  Click WebSphere enterprise applications.
	__3.  Select the check box next to BillingApp.
	__4.  Click the Start button and wait until the status shows started.
	__5.  Launch a new web browser window.
	__6.  Enter the URL: 
	__7.  The page will be displayed. Add some input as shown below.
	__8.  Click Add.
	__9.  The JSP will call the web service. Make sure that the page shows the success message:
	__10.  Back in RAD, the Console view will show the log output from the web service.

	Part 4 -  Enable SOAP Monitoring
	__1.  In the Servers view, right click the server and select Monitoring > Properties.
	__2.  If you already have a monitor for port 9080 as shown below, skip to step 6.  If you do not have this port continue with the next few steps to create it.
	__3.  Click Add.
	__4.  Select the port 9080
	__5.  Click OK.
	__6.  Select the monitor port for 9080 and click Start.
	__7.  Click OK to close the monitoring properties.
	__8.  Select Window > Show View > Other.
	__9.  Expand Debug and select TCP/IP Monitor.
	__10.  Click OK.
	__11.  Select the TCP/IP Monitor view
	__12.  Click the Clear button.
	__13.  If you don't have one open already, open a web browser to the Admin Console URL and login with any user: 
	__14.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__15.  Click the link for the BillingApp application.
	__16.  Scroll down and in the list of 'Web Services Properties'  click the link for Service clients.
	__17.  Click the first link for the Module on the right.  If you click the service name on the left it will take you to web service policies which are not being used for this web service.
	__18.  Under 'Web Services Properties' click the link for Web services client bindings.
	__19.  Click the 'Edit' link in the 'Port Information' column.  Make sure you do not click the link in the 'mappings' column.
	__20.  Change the port to 9081 in the URL option as shown below and press the OK button.  This will apply the URL with the correct port to the endpoint binding.
	__21.  Click the Save link in the messages at the top of the Admin Console.
	__22.  Click the Logout link at the top of the Admin Console and close it.
	__23.  Go back to the consumer web page (http://localhost:9080/ClientWeb/index.jsp).
	__24.  Enter some input data and click Add.
	__25.  Make sure that the success message is shown.
	__26.  Select TCP/IP Monitor view.
	__27.  Maximize the TCP/IP Monitor  view.
	__28.  You should see a request already captured. Select it as shown below. Also, set the display type to XML.
	__29.  Study the request and response messages. They are in plain text since we have not enabled any message security.
	__30.  Click the eraser button in the TCP monitor view toolbar to remove all captured messages.
	__31.  Restore the size of the TCP/IP Monitor view.
	__32.  Close all web browsers.

	Part 5 -  Review

	Lab 15 -  Message Integrity using WS-Security
	Part 1 -  Understanding Policy Set
	__1.  Using a Windows file explorer, navigate to C:\LabFiles.  Notice that it contains a file called IntegrityOnly.zip.  This is the policy set has a policy that enables message integrity.  
	__2.  Open the ZIP file using Winzip or any other archiving program.
	__3.  In the PolicySets\IntegrityOnly folder, locate the policySet.xml file.
	__4.  Open the policySet.xml file. Note that the set includes a single policy as follows:
	__5.  Close the file.
	__6.  Open the PolicyTypes sub-folder. In here, there is a sub-directory called WSSecurity – which is exactly what the PolicyType element in policyTypes.xml referred to.  Basically, the run-time will read the policyTypes.xml file and then search for an appropriate sub-directory with the same name.  
	__7.  Open the WSSecurity folder. 
	__8.  Open policy.xml with a text editor. 
	__9.  Close the file and close the ZIP file.

	Part 2 -  Import the Policy Set
	__1.  In RAD, locate the Servers view.
	__2.  Start the server if it is not running.
	__3.  Right click the server in the Servers view and select Administration → Run administrative console.
	__4.  In the left pane, expand Services | Policy Sets. 
	__5.  Click Application policy sets.
	__6.  Scroll down the list to examine some of them and what they offer.  For example, examine the WS-I RSP profile, and look at what it offers.
	__7.  Scroll up.  Click the Import button, and select From Selected Location... from the drop-down.
	__8.  Click the Browse... button.
	__9.  Select C:\LabFiles\IntegrityOnly.zip and click Open.
	__10.  Click OK.
	__11.  Click the Save link.
	__12.  In the list of policies, scroll down.  You should see the newly imported policy set. 

	Part 3 -  Attach Policy Set
	__1.  On the left hand side of admin console, expand Services and click Service providers.
	__2.  Click BillingManagerService.
	__3.  Select the checkbox for BillingManagerService.
	__4.  Click the Attach Policy Set button and click IntegrityOnly.
	__5.  Select the checkbox for BillingManagerService again.
	__6.  Click Assign Binding > Provider sample.
	__7.  Verify that the correct policy set and binding is displayed for the service.
	__8.  Click the Save link at the top of the page to save changes.
	__9.  On the left hand side, click Service clients under Services.
	__10.  Click the first BillingManagerService.
	__11.  Select the checkbox for BillingManagerService.
	__12.  Click Attach Client Policy Set > IntegrityOnly.
	__13.  Select the checkbox for BillingManagerService again.
	__14.  Click Assign Binding > Client sample.
	__15.  Verify that the correct policy set and binding is displayed for the consumer.
	__16.  Click the Save link at the top of the page to save changes.
	__17.  Log out of admin console by clicking the Logout link at the top right corner.
	__18.  Close the browser.
	__19.  Select the server in Servers view.
	__20.  Press Control+Alt+R to restart the server or right click the server and select Restart.
	__21.  Wait for the server status to change to Started.

	Part 4 -  Test Message Integrity
	__1.  First make sure that the TCP monitoring proxy service is still running. To do that, right click the server and select Monitoring > Properties. Make sure the status is Started. Otherwise, start it.
	__2.  Click OK to close the monitor settings dialog.
	__3.  Open a browser window and enter the URL for the consumer application: 
	__4.  Enter some input value. Then click Add.
	__5.  Make sure that the success message is displayed.
	__6.  Back in RAD, open the TCP/IP Monitor view and maximize it.
	__7.  Change the display mode from Byte to XML for both request and response.
	__8.  For the request message, observe the SOAP <Body> element of the Request is still in plain text. This is expected since we have not enabled encryption.
	__9.  In the header of the Request, locate the <ds:SignatureValue> element.
	__10.  Similarly, locate and observe the  SignatureValue,  DigestValue and BinarySecurityToken elements in the SOAP response message.

	Part 5 -  Test for Integrity Failure
	__1.  In the TCP/IP Monitor view, move your mouse over the low-arrow at the top-right of the menu bar, it will display View Menu. 
	__2.  Click the View Menu button and select Show Header.
	__3.  The  TCP/IP Monitor view now will show the header for the Request and Response.
	__4.  In the top pane of the TCP/IP Monitor view, right click the request and select Modify request.
	__5.  In the Request editor, scroll carefully to the right and locate the <address> element in the bottom line.
	__6.  Replace some of the characters in the body of the <address> element. For example, change 1054 to 2054. Or, change an upper case letter to lower case. Important: Make sure that the total number of characters remain the same.
	__7.  Right click the modified request and select Send Modified Request.
	__8.  The Console view will show an exception from the service.
	__9.  Back in the TCP/IP Monitor view, for the Response pane, change the display mode to XML.
	__10.  Notice that a fault has been returned by the server. 
	__11.  Clear all requests in TCP/IP Monitor by clicking the eraser toolbar button.
	__12.  Hide the Header since you don't need it anymore, remember that you opened the header to modify a request.
	__13.  Close any open web browser.

	Part 6 -  Review

	Lab 16 -  Message Confidentiality
	Part 1 -  Import Policy Set
	__1.  In RAD, locate the Servers view.
	__2.  Start the server if it is not running.
	__3.  Right click the server in the Servers view and select Administration → Run administrative console.
	__4.  In the left pane, expand Services > Policy Sets. 
	__5.  Click Application policy sets.
	__6.  Click Import and select From Selected Location.
	__7.  Browse, select C:\LabFiles\ConfidentialityIntegrity.zip and click Open.
	__8.  Click OK.
	__9.  Make sure that the policy set called ConfidentialityIntegrity has been imported.
	__10.  Click Save at the top of the page to save changes.

	Part 2 -  Review the Confidentiality Policy
	__1.  Click ConfidentialityIntegrity.
	__2.  Click WS-Security.
	__3.  Click Main policy.
	__4.  Click Request message part protection. 
	__5.  Note that parts of the request message are protected for both encryption and integrity.
	__6.  Select app_encparts in the Encrypted parts list.
	__7.  Click Edit.
	__8.  Notice that the entire SOAP <Body> is setup to be encrypted.
	__9.  Click Cancel.
	__10.  Click Done.
	__11.  Click Response message part protection. 
	__12.  Verify that the response Body will also be encrypted.

	Part 3 -  Attach Policy Set
	__1.  On the left hand side click Service providers.
	__2.  Click BillingManagerService.
	__3.  Attach the ConfidentialityIntegrity policy set to the BillingManagerService.
	__4.  Assign the Provider sample binding to the service.
	__5.  Save changes.
	__6.  On the left hand side click Service clients.
	__7.  Click BillingManagerService.
	__8.  Attach the ConfidentialityIntegrity policy set to the BillingManagerService.
	__9.  Assign the Client sample binding to the consumer.
	__10.  Save changes.
	__11.  Log out of admin console and close the browser.
	__12.  Restart the server. Wait for the server to start.

	Part 4 -  Test for Confidentiality
	__1.  Open a browser window and enter the URL for the consumer application: 
	__2.  Enter some input value. Then click Add.
	__3.  Make sure that the success message is displayed.
	__4.  Back in RAD, review that the Console shows the output from the service provider.
	__5.  Open the TCP/IP Monitor view and maximize.
	__6.  Change the display mode from Byte to XML for both request and response.
	__7.  For the request message, observe the following. 
	__8.  Similarly, verify that the Body of the response message is also encrypted.
	__9.  Clear all requests and restore the size in the TCP/IP Monitor view.
	__10.  Close the web browser.

	Part 5 -  Review

	Lab 17 -  Develop a Simple RESTful Service
	Part 1 -  Create the Web Service Project
	__1.  From the menubar, select File > New > Dynamic Web Project.
	__2.  Enter AcmeWeb for the Project name.
	__3.  At the bottom of the window, in the EAR Membership section, click the button marked New Project....  (We will want to add this WAR file into an EAR file)
	The New EAR Application Project screen will appear.
	__4.  Set the Project name to AcmeApp and make sure the target server is WebSphere 8.0.
	__5.  Click Finish to create the EAR project
	__6.  Click Finish.  Both the EAR and the WAR will be created.  If prompted, don't switch to the web perspective by clicking No.
	__7.  Close the 'Technology Quickstarts' if it opens.
	__8.  Right click the newly created AcmeWeb project and select Properties.
	__9.  Now, select the Project Facets property.
	__10.  Note that the JAX-RS facet is not selected. This facet plays no role in developing JAX-RS services for WebSphere 8.0.
	__11.  Click Cancel to close the dialog.

	Part 2 -  Register the REST Application
	__1.  Open Windows file explorer.
	__2.  Go to C:\LabFiles\
	__3.  Copy web.xml
	__4.  In RAD, paste the file inside the WebContent > WEB-INF folder of AcmeWeb.
	__5.  Open web.xml and study how the REST application is configured. Switch to the Source view and specifically, note the servlet mapping:
	__6.  Close the file.

	Part 3 -  Create the Resource Class
	__1.  Right click AcmeWeb project and select New > Class.
	__2.  Enter com.acme.services as the package name and SimpleService as the class name.
	__3.  Click Finish to create the new class.
	__4.  Add a member variable that will help us do logging.
	__5.  Organize imports (Control+Shift+O) and select java.util.logging.Logger.  Make sure you select the correct class as there are several 'Logger' classes on the classpath.
	__6.  Add the method as follows.
	__7.  Save changes.

	Part 4 -  Configure the Resource
	__1.  Define the URI of the root resource, by adding the @Path annotation above the class. 
	__2.  Set the HTTP method and reply MIME type for the testGET() method sub-resource as follows.
	__3.  Organize imports. Select javax.ws.rs.Produces.
	__4.  Save changes.

	Part 5 -  Unit Test
	__1.  Start the WebSphere server.
	__2.  Right click the WebSphere server and select Add and Remove.
	__3.  Add the AcmeApp project to the server.
	__4.  Click Finish.
	__5.  Right click the server and select Publish. Do this every time you are requested to Publish the server.
	__6.  Open a web browser and enter the URL: 
	__7.  You should see OK in the browser.
	__8.  The Console view in RAD will show the log output.

	Part 6 -  Use Path Extension for Sub-resource
	__1.  First, add this method to the SimpleService class.
	__2.  Annotate the method as follows.
	__3.  Save changes.

	Part 7 -  Unit Test
	__1.  Right click the WebSphere server and select Publish.
	__2.  In a web browser, enter the URL: 
	__3.  Make sure that the Console shows the log output.
	__4.  Open a new browser and re-test the testGET method for regression using the URL: 
	__5.  Close all open files.
	__6.  Close all browsers.

	Part 8 -  Review

	Lab 18 -  Extracting Information from a HTTP Request
	Part 1 -  Get Root Resource Path Parameters
	__1.  Open SimpleService.java from the AcmeWeb project.
	__2.  Change the @Path annotation for the class and add a parameter there.
	__3.  Add a member variable as follows.
	__4.  Annotate the member variable to save the value of the myRootPathData parameter.
	__5.  Organize imports.
	__6.  Change the log statement of the testGET() method as follows.
	__7.  Make a similar change to the testGETWithPath() method.
	__8.  Save changes.

	Part 2 -  Unit Test
	__1.  Publish the server.
	__2.  First, test the testGET() method by entering the URL: 
	__3.  The log output will like this:
	__4.  Now, test the testGETWithPath() method using the URL: 
	__5.  The log output will be:

	Part 3 -  Get Sub-resource Path Parameters
	__1.  Add a basic method as follows.
	__2.  Annotate method with path and method.
	__3.  Now, extract the path parameters and save them in the two input argument variables of the method.  The syntax for the @PathParam annotation on a method parameter is tricky so be careful.
	__4.  Save changes.
	__5.  Publish the server.
	__6.  Test the method by entering the URL: 

	Part 4 -  Extract Query Parameters
	__1.  Add the giveRaise() method as shown below.
	__2.  Organize imports.
	__3.  Save changes.
	__4.  Publish the server.
	__5.  Test the change by entering the URL: 
	__6.  Make sure that the Console shows:

	Part 5 -  Extracting Form Post Data
	__1.  Add this method.
	__2.  Organize imports. Select  java.util.List.
	__3.  Save changes.

	Part 6 -  Unit Test
	__1.  We will import the form HTML page. Copy C:\LabFiles\post.html and paste it inside the WebContent folder of the AcmeWeb project.
	__2.  In the Servers view, right click the server and select Publish.
	__3.  Open a browser and enter the URL: 
	__4.  Fill out the form and submit it. 
	__5.  Make sure that the console log shows the input values correctly.
	__6.  Close all open files.
	__7.  Close all open browsers.

	Part 7 -  Review

	Lab 19 -  Designing a RESTful Service
	Part 1 -  The Business Requirements
	Part 2 -  Define Project Scope
	Part 3 -  Designing the Object Model
	__1.  Can you go through the business requirements and identify the entities? 
	__2.  Now that you have identified the entities, can you list the attributes or fields for each entity? Once again, the answer is below. But do your best to do the design yourself.

	Part 4 -  Identify the Service
	__1.  Can you go through the requirements and list the tasks or operations that various yet to be identified services need to perform? Then compare your findings with the answer below.
	__2.  Can you group the operations based on the entity they work with? Name each group as a service accordingly. The answer is below.

	Part 5 -  Design the Service Interface
	__1.  First, let us decide on the URI for each entity. This is a pretty straightforward exercise. Note: As a matter convention, plural forms of the entity names are used in URI.

	Part 6 -  Decide on the Data Format
	Part 7 -  Unaddressed Architectural Issues
	Part 8 -  Review

	Lab 20 -  Add Support for XML Format
	Part 1 -  Create the Entity Classes
	__1.  In the AcmeWeb project, create a package called com.acme.services.entities
	__2.  Within that package, create a Java class called QuoteRequest
	__3.  In the QuoteRequest class, add these member variables. Feel free to refer back to the object model to make sure we are doing this correctly.
	__4.  Generate getters and setters for the variables. To do this select any variable, then from the menu select Source >  Generate Getters and Setters. Click Select All and click OK.
	__5.  Add the @XmlRootElement JAXB annotation to the class as shown in boldface below.
	__6.  Organize imports.
	__7.  Save changes.
	__8.  Open a file browser and go to C:\LabFiles\entities.
	__9.  Copy all the files within the folder and then paste them into the com.acme.services.entities package.
	__10.  Open each entity class file and review them. Specifically, look at the Order class. Working with list of child objects can be tricky in JAXB. Look at how we are dealing with line items:

	Part 2 -  Generate the XML Schema
	__1.  In the Enterprise Explorer view, right click on the com.acme.services.entities package and select New → Other
	__2.  Select JAXB → Schema from JAXB Classes and click the Next button.
	__3.  Expand the AcmeWeb → src folder and select the com.acme.services.entities package to make sure all Java files in the package are selected to be included.
	__4.  Click the Finish button to generate the schema.
	__5.  After a few seconds check that the root of the project has the schema.
	__6.  Open the generated schema file and study it if you wish.

	Part 3 -  Create the Quote Service Class
	__1.  In the com.acme.services package, create a class called QuoteService
	__2.  Set the root URI of the service as shown in boldface below.
	__3.  Add a member variable for logging.
	__4.  Add the getQuote() method as shown below. The business logic is very simple. We hard code the price and availability.
	__5.  Annotate the method as shown below.
	__6.  Organize imports. Select java.util.logging.Logger and javax.ws.rs.Produces.
	__7.  Save changes.

	Part 4 -  Better Content Handling
	__1.  Add the @Consumes annotation to getQuote as follows in bold.
	__2.  Similarly, change the @Produces annotation to support both MIME types for XML.
	__3.  Organize imports. Select javax.ws.rs.core.MediaType.
	__4.  Save changes.

	Part 5 -  Unit Testing
	__1.  Start the server if it is not running.
	__2.  Publish the server.
	__3.  Open a Windows Explorer file browser and verify the following directory exists.  If it doesn't you might need to find out where WebSphere was installed and alter the next several steps accordingly.
	__4.  Open a command window and change directories with the 'cd' command to C:\Software\RESTClient.
	__5.  Issue the following command assuming the WebSphere java directory was at the location previously mentioned:
	__6.  Run the command:
	__7.  In the URL text box, enter: 
	__8.  Select POST method.
	__9.  Click the Body tab.
	__10.  Click the  icon.
	__11.  From the drop-down select the text/xml content type.
	__12.  Click OK.
	__13.  Click the  icon to open the file.
	__14.  Select C:\LabFiles\quote_request.xml and open it.
	__15.  The tool will offer you an option to change the MIME type to application/xml. This is not necessary (either text/xml or application/xml will work fine), click NO.
	__16.  Study the request document briefly.
	__17.  We are now ready start testing. Click the  icon next to the URL.
	__18.  Make sure that the HTTP reply status code is 200.
	__19.  Click the Body tab for the response.
	__20.  Right click the response body text and select Indent > Indent XML.
	__21.  Study the response document.
	__22.  Back in RAD close all open files.
	__23.  Do not close the REST Client.

	Part 6 -  Review

	Lab 21 -  Add Support for JSON
	Part 1 -  Do the Design First
	Part 2 -  Add the JSON Method
	__1.  Open QuoteService class.
	__2.  First, add the shell of the method.
	__3.  Then, annotate the method and the input parameters as shown in boldface below.
	__4.  Now, fill in the body of the method. It basically calls the getQuote() method to get the job done.
	__5.  Organize imports.
	__6.  Save changes.

	Part 3 -  Understanding Content Negotiation
	Part 4 -  Test
	__1.  Publish the WebSphere server by right-clicking and selecting Publish.
	__2.  Launch the REST client tool if it is not already running.  Use steps from previous labs to set the 'JAVA_HOME' variable in the command prompt to launch the tool.
	__3.  Set the URL to: 
	__4.  Choose POST method.
	__5.  Set the body using the XML code in C:\LabFiles\quote_request.xml and set content type to application/xml; chartset=UTF-8.
	__6.  Click the Headers tab.
	__7.  Enter Accept as Key and text/xml as Value.
	__8.  Click the + icon to add the header.
	__9.  Run the test by clicking .
	__10.  Right click the response body area in the Body tab and select Indent > Indent XML.
	__11.  Verify that the reply body contains the response.
	__12.  Select the Accept header, then right click on it and select Delete.
	__13.  Enter Accept as Key and application/json as Value, then click the + icon to add the header.
	__14.  Select the request Body tab and click on the button for 'Insert parameters'
	__15.  Confirm that you want to erase the current body text by clicking the Yes button.
	__16.  Confirm that you want to switch the content type to the value needed for a form, 'application/x-www-form-urlencoded', by clicking the Yes button.
	__17.  Use the tool to add each of the following parameters by filling in the key and value and clicking the button to add the parameter.
	__18.  Once you have all the parameters filled in as shown below, click the Generate button.
	__19.  Run the test.
	__20.  Right click the response body area and select Indent > Indent JSON.
	__21.  Verify the result.
	__22.  Back in RAD close all open files.
	__23.  Do not close the REST Client.

	Part 5 -  Review

	Lab 22 -  Build the Order Web Service
	Part 1 -  Create the Resource Class
	__1.  In the com.acme.services package, create a class called OrderService
	__2.  Annotate the class to set the path as follows.
	__3.  Add a member variable for logging.
	__4.  Organize imports. Select java.util.logging.Logger.
	__5.  Save changes.

	Part 2 -  Implement Order Placement
	__1.  Write the shell of the method as follows. We will not deal with the returned URL just yet.
	__2.  Annotate the method with @POST and @Consumes.
	__3.  Organize imports. Select these classes when prompted (they may come up in a different order):
	javax.ws.rs.core.Response
	com.acme.services.entities.Order
	javax.ws.rs.core.MediaType
	__4.  Save changes.
	__5.  Copy the file C:\LabFiles\OrderDAO.java into the com.acme.services package.
	__6.  Open the class and briefly study it. The code should be very simple.
	__7.  In the placeOrder method of the OrderService class, use OrderDAO as shown in boldface below.
	__8.  Organize imports. Select this class:
	java.util.logging.Level
	__9.  Save changes.

	Part 3 -  Implement Retrieval of Order
	__1.  First write the method shell along with the required annotations.
	__2.  Next, fill in the method body.
	__3.  Organize imports. Select these classes:
	__4.  Save changes.

	Part 4 -  Construct Entity URL
	__1.  First, add a member variable to the class as follows.
	__2.  In the placeOrder() method, add the bold code:
	__3.  Add this line in bold below:
	__4.  Next, add the following line. This plugs in the actual value of the order ID to the path and returns a java.net.URI object.
	__5.  Finally, add this line. 
	__6.  Organize imports. Choose these classes:
	__7.  Save the file and make sure you don't have any compilation errors.

	Part 5 -  Test
	__1.  Go to the 'Servers' view and publish the changes to the server by right clicking the server and selecting 'Publish'.
	__2.  Launch the REST client tool if it is not already running.  Use steps from previous labs to set the 'JAVA_HOME' variable in the command prompt to launch the tool.
	__3.  From the REST client's menubar, select File > Open Request (Control+O).
	__4.  Open C:\LabFiles\order_create.rcq
	__5.  Review these items about the request:
	__6.  Click the  button to send the request.
	__7.  Verify that:
	__8.  In the RAD Console, verify the log output from the OrderDAO class.
	__9.  In the REST client, open the request file C:\LabFiles\order_retrieve.rcq.
	__10.  Inspect these items about the request:
	__11.  Send the request.
	__12.  Verify that the reply body has the correct order information.

	Part 6 -  Enable Error Handling
	__1.  In the placeOrder() method of OrderService class, add this line shown in bold face.
	__2.  Comment out the following unreachable line:
	__3.  Organize imports. 
	__4.  In the getOrder() method, above the line:
	__5.  Organize imports. Choose this class:
	javax.ws.rs.core.Response.Status
	__6.  Save changes.

	Part 7 -  Test
	__1.  Publish the WebSphere server in the Servers view.
	__2.  In the REST client, the order retrieval request file should be open already. Just run the test.
	__3.  Verify that the status code is 404.  This is because the previous order was lost when the application was updated and restarted.
	__4.  Open the request file C:\LabFiles\order_create.rcq.
	__5.  In the Body tab, delete all the <item> elements.
	__6.  Run the test.
	__7.  Verify that status code 500 is returned.
	__8.  Do regression tests to make sure that success conditions are working fine.
	__9.  In RAD close all open files.
	__10.  Do not close the REST Client.

	Part 8 -  Review

	Lab 23 -  Complete the Order Service
	Part 1 -  Implement Order Cancellation
	__1.  In the AcmeWeb project, open OrderService.java
	__2.  Add this method.
	__3.  Add these lines to the cancelOrder() method.
	__4.  Organize imports.
	__5.  Save changes.

	Part 2 -  Test
	__1.  Publish the WebSphere server.
	__2.  Launch the REST client tool if it is not already running.  Use steps from previous labs to set the 'JAVA_HOME' variable in the command prompt to launch the tool.
	__3.  From the client, open the request file C:\LabFiles\order_create.rcq
	__4.  Run the test. You should get a status code of 201. 
	__5.  Open the request file C:\LabFiles\order_retrieve.rcq
	__6.  Run the test. You should get a status code of 200.
	__7.  From the Method tab, select DELETE.
	__8.  Run the test. 
	__9.  Since the reply body is empty, you should see HTTP status code 204. This is equivalent to status 200 and indicates success.
	__10.  In the Method tab, select GET method.
	__11.  Run the test.
	__12.  Verify that 404 is returned.

	Part 3 -  Implement Order History
	__1.  From the com.acme.services.entities package, open OrderList.java and inspect it.
	__2.  Close the class.
	__3.  In the OrderService class, add the method shell as follows.
	__4.  Add the method body as follows.
	__5.  Organize imports.
	__6.  Save changes.

	Part 4 -  Test
	__1.  Publish the WebSphere server.
	__2.  From the REST test client, open the request file C:\LabFile\order_create.rcq
	__3.  From the Body tab, note the client ID – C001.
	__4.  Run the test to create an order.
	__5.  From the Body tab of the request, change the part number and quantity ordered and place a few more orders.
	__6.  From the test client, open the request file C:\LabFiles\order_history.rcq
	__7.  Run the test.
	__8.  Verify the response.

	Part 5 -  Implement Order Update Function
	__1.  In the OrderService class, add the method shell.
	__2.  Fill in the method body as follows.
	__3.  Organize imports.
	__4.  Save changes.

	Part 6 -  Test
	__1.  Publish the WebSphere server.
	__2.  From the REST test client, open the request file C:\LabFile\order_create.rcq
	__3.  Run the test.
	__4.  Add the order ID 1000 to the URL (add  /1000  at the end of the URL).
	__5.  From the Method tab, choose PUT.
	__6.  From the Body tab, change quantity and/or part number.
	__7.  Run the test.
	__8.  Verify that status code 200 is returned.
	__9.  Now lets check the retrieve request. Open the request file C:\LabFiles\order_retrieve.rcq
	__10.  Run the test.
	__11.  Verify that status code 200 is returned.   
	__12.  Format the result (Indent > Indent XML ) and verify that the body contains the information that you changed.
	__13.  Open the request file C:\LabFile\order_create.rcq
	__14.  Change the order ID in the URL to an invalid value as shown below.
	__15.  From the Method tab, choose PUT.
	__16.  Run the test and make sure 404 status code is returned.
	__17.  In RAD, close all the open files.

	Part 7 -  Review

	Lab 24 -  Developing a JAX-RS Client
	Part 1 -  Client Design Considerations
	Part 2 -  Import the Client Application
	__1.  From the RAD menubar, select File > Import.
	__2.  Select General > Existing Projects into Workspace and click Next.
	__3.  Select the 'Select archive file' radio button and use the Browse button to the right to select the C:\LabFiles\SimpleClientStarter.zip file.
	__4.  Make sure both projects are selected as shown above and click Finish.

	Part 3 -  Build the Service Proxy Layer
	__1.  From the AcmeWeb project, copy the com.acme.services.entities package.  Make sure to copy the entire package by right clicking the package and selecting Copy.
	__2.  In the SimpleClient project, paste it in the src folder.
	__3.  In the SimpleClient project, create a package called com.acme.services.proxy
	__4.  In that package, create a class called QuoteProxy
	__5.  In the QuoteProxy class, add a variable to store the service root URL.
	__6.  Add the shell of a method that will invoke the quote web service.
	__7.  In the getQuote() method, add this line to instantiate a org.apache.wink.client.RestClient object.
	__8.  Next, create a Resource object that points to the root web service resource.
	__9.  Add these lines to set the content type of the request and the accept header.
	__10.  Add this line to send a QuoteRequest XML using a POST request.
	__11.  Finally, add this line to return the quote response.
	__12.  Organize imports and select these classes:
	__13.  Save changes.

	Part 4 -  Build the Presentation Layer
	__1.  From the WebContent folder, open index.jsp and study the form.
	__2.  Open result.jsp and study how the QuoteResponse object properties are shown.
	__3.  From the com.webage.servlet package, open QuoteController.java.
	__4.  Locate the doPost method.
	__5.  Below the line:
	__6.  Below the line: 
	__7.  Below the line:
	__8.  Organize imports.
	__9.  Save changes.

	Part 5 -  Test
	__1.  Start the server if it is not running.
	__2.  Deploy SimpleClientEAR project to the server with the Add and Remove.. option when you right click the server.
	__3.  Open a web browser and enter the URL: 
	__4.  Enter some values and click Get Quote.
	__5.  Verify the result.
	__6.  Close the browser.
	__7.  Close all open files.

	Part 6 -  Review

	Lab 25 -  Securing RESTful Services
	Part 1 -  Enable Application Security
	__1.  Make sure the WebSphere server is running and start it if it is not.
	__2.  In the Servers view, right click the server and select Administration → Run Administrative Console.
	__3.  In the navigation on the left side, expand the Security section and click the link for Global security.
	__4.  Click the button for Security Configuration Wizard.
	__5.  On the first page, leave the default options so only Enable application security is checked and click the Next button.
	__6.  Switch the option to Federated repositories and click the Next button.
	__7.  Fill in a value of 'wasadmin' without the quotes for the 'Primary administrative user name' and both password fields and then click the Next button.
	__8.  Click the Finish button to complete the security configuration.
	__9.  In the messages at the top of the Admin Console, click the link to Save the changes.
	__10.  Click the Logout link in the upper right of the Admin Console.
	__11.  Close the Admin Console window.
	__12.  Switch back to the RAD Servers view.
	__13.  Stop the server.
	__14.  Once the server is stopped, double click on the server to open the server properties. 
	__15.  On the right, expand Security.
	__16.  Check the option for 'Security is enabled on this server' and fill in a value of 'wasadmin' without the quotes for the User ID and Password options.
	__17.  Save and close the server properties.
	__18.  Start the WebSphere server from the Servers view. If you see errors starting the server (e.g., "Unable to initialize SSL connection"), then stop the server and close RAD. After that, start RAD again and then start the server. The server should start with no errors.  If you have any problems, please contact your instructor.

	Part 2 -  Secure the Quote Service
	__1.  In the AcmeWeb project expand com.acme.services package.
	__2.  Open QuoteService.java.
	__3.  Add the following annotation in bold to the class.
	__4.  Organize imports. 
	__5.  Save changes.
	__6.  In the Enterprise Explorer view, right click the AcmeApp EAR project and select Java EE → Generate Deployment Descriptor Stub.  Make sure it is the AcmeApp project as the AcmeWeb project will have similar options.
	__7.  In the Enterprise Explorer view, expand AcmeApp → META-INF and double click the application.xml file to open it.
	__8.  Select the Design tab.
	__9.  In the Overview section on the left, click the Add button.
	__10.  Select Security Role and click the OK button.
	__11.  With the new security role selected on the left, fill in a Role Name of 'Customer' without the quotes on the right.
	__12.  Save and close the file.

	Part 3 -  Test
	__1.  Publish the server.
	__2.  Open a browser and enter the URL: 
	__3.  Enter some data and then click Get Quote.
	__4.  The browser will show an error.
	__5.  Close the browser.

	Part 4 -  Run Server with Resources on Server
	__1.  Make sure the server is started.
	__2.  Right click on the server and choose Add and Remove.
	__3.  In the Add and Remove dialog, click Remove All and then click Finish.
	__4.  Right click the server and select Clean. Then click OK to continue.
	__5.  Stop the server.
	__6.  Double click on the server to open the server configuration editor.
	__7.  Under Publishing settings for WebSphere Application Server, click the Run server with resources on Server radio button.
	__8.  Save your changes.
	__9.  Close the file.
	__10.  Add the AcmeApp and SimpleClientEAR projects back to the server.
	__11.  Start the server.

	Part 5 -  Configure Security at the Server
	__1.  Make sure the WebSphere server is running and start it if it is not.
	__2.  In the Servers view, right click the server and select Administration → Run Administrative Console.
	__3.  If you receive security alerts they are for the security certificate of the server.  Click Yes or OK to accept the certificate and continue.
	__4.  Login to the WebSphere Admin Console with a user ID and password of wasadmin.
	__5.  In the navigation section on the left side of the Admin Console navigate to Users and Groups -> Manage Users.
	__6.  Type * in the Search for field and click the Search button to list the current users.
	__7.  Click the Create button and fill in the following user information:
	__8.  When the options are filled in as above click the Create button to create the user.
	__9.  Click the Close button and be sure the new user shows up in the list.
	__10.  Navigate to Applications → Application Types → WebSphere enterprise applications.
	__11.  Click the link for the AcmeApp application.
	__12.  Under the Detail Properties section, click the link for Security role to user/group mapping.
	__13.  Check the checkbox next to the Customer role and click the Map Users button.
	__14.  Press the Search button to list available users.
	__15.  Select the bob user and press the right arrow button to move the user over to the “Selected” list on the right.
	__16.  Press the OK button on the user search page to accept the user.
	__17.  Check that the user is listed on the row with the Customer role and press the OK button.
	__18.  Click the Save link in the messages at the top of the Admin Console.
	__19.  Click the Logout link in the upper right corner of the Admin Console.
	__20.  Close the Admin Console window.

	Part 6 -  Modify the Test Client
	__1.  Launch the RESTClient tool if it is not already running.  Use steps from previous labs to set the 'JAVA_HOME' variable in the command prompt to launch the tool.
	__2.  In the URL text box, enter: 
	__3.  Select POST method.
	__4.  Click the Body tab.
	__5.  Click the  icon.
	__6.  From the drop-down select the text/xml content type.
	__7.  Click OK.
	__8.  Click the  icon to open the file. Click Yes to erase the existing code.
	__9.  Select C:\LabFiles\quote_request.xml and open it. The tool will offer you an option to change the MIME type to application/xml. This is not necessary (either text/xml or application/xml will work fine), click NO.
	__10.  Click the  icon next to the URL.
	__11.  Make sure that the HTTP reply status code is 403.
	__12.  Click the Auth tab.
	__13.  Enter these values:
	__14.  Run the test again.
	__15.  Verify that status code 200 is returned.

	Part 7 -  Enable Audit Logging
	__1.  In the AcmeWeb project, open OrderService.java.
	__2.  Configure the valid role for the service as shown in bold face below.
	__3.  Add a member variable to the class as follows.
	__4.  In the placeOrder() method, below the line:
	__5.  Organize import and select this class:
	__6.  Save changes.
	__7.  Publish the WebSphere server.

	Part 8 -  Test
	__1.  Launch the REST test client if it is not already running.
	__2.  Select File > Open Request from the menubar.
	__3.  Open C:\LabFiles\order_create.rcq
	__4.  Click the  button to send the request.
	__5.  Make sure that a status code 403 is returned.
	__6.  Click the Auth tab.
	__7.  Enter these values:
	__8.  Run the test again.
	__9.  Verify that status code 201 is returned.
	__10.  Check RAD console for the audit log. It will look like this:
	__11.  Close all open browsers.
	__12.  Close all open files.
	__13.  Close REST client.

	Part 9 -  Review




