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Lab 1 - Using Media Rules to Build Universal Web Site
A universal web site uses a single web application to serve content for both mobile and 
desktop browsers. One of doing this is to return the same HTML markup but use a 
different stylesheet to render the content differently in different devices. CSS media rule 
is a simple way of achieving this. In this lab, we will develop two different style sheets 
for mobile and desktop screens.

Part 1 - Basic Approach
We will have two CSS files:

1. Mobile CSS file for screen width 480px or less.

2. Desktop CSS file for screen width larger than 480px.

Note: CSS specification also allows you to use the media type handheld for mobile 
device and screen for desktop. But, media type is very poorly supported. Screen width or 
height based rules are much safer.

Part 2 - Design the HTML Page
__1. In the web server document root (C:\Program Files\Apache Software 
Foundation\Apache2.2\htdocs) create a new file called universal.html.

__2. Open it with Notepad and enter the following code.

<!DOCTYPE html>

<html>
<head>

</head>

<body>

<div id="header">
<p>This is the header area</p>
<p>Home | About Us | Contact Us | News</p>
<hr/>
</div>

<div id="content">
<p>This is the main body area</p>
<img src="flower.jpg" id="big_image"/>
</div>

<div id="footer">
<hr/>
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<p>This is the footer area</p>
<p>Home | About Us | Contact Us | News</p>
</div>

</body>

</html>

__3. Save changes.

__4. Copy C:\LabFiles\flower.jpg to the web server document root (C:\Program 
Files\Apache Software Foundation\Apache2.2\htdocs).

__5. In a browser (Chrome or Safari is encouraged) the URL: 

http://localhost/universal.html

Note that the section links (Home, About Us, etc.) are repeated in the header and footer. 
Our goal is to hide the header entirely in a mobile device. That way, users can view most 
of the content right away without scrolling. For desktop, we will hide the footer.
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__6. Close the browser.

Part 3 - Design the Stylesheet
__1. Within the <head> </head> tag, enter these styles:

<style  type="text/css">
@media only screen and (min-width: 481px) {
#footer {
      display: none;
}
#header {
      display: block;
}
}

@media only screen and (max-width: 480px) {
#footer {
      display: block;
}
#header {
      display: none;
}  
#big_image {
      display:none;
}     
}       
</style>

__2. Save changes.

__3. For media rules to work properly in any Webkit based browser (as in Safari, iOS and 
Android), you will need to add this meta tag within <head> element.

<meta name="viewport" content="width=device-width" />

__4. Save changes and close the file.

Part 4 - Test Using Desktop Browser
__1. Open a browser. Make it fairly wide to simulate a desktop environment.

__2. Enter the URL: 

http://localhost/universal.html

__3. Make sure that header and image are displayed, but the footer is hidden.
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__4. Try shrinking the width of the browser. At some point (i.e., below 480px width), the 
header and image will get hidden and the footer will get displayed.

Part 5 - Testing Using Mobile Device
Next, we will use the Android device emulator to test the page on a mobile browser.  First 
you will need to create an emulator, which is also known as an Android Virtual Device 
(AVD). An emulator is typically used for testing and debugging Android applications.

__1. Open a file browser and navigate to.

C:\Software\android-sdk-windows

__2. Open the AVD Manager by running this file:

AVD Manager.exe
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__3. Click New.

__4. Enter my_avd as the name. 

__5. Select Android 4.0 – API Level 14 as the target.

__6. Make sure that screen resolution is set to Default (WVGA800). This resolution is a 
good approximation of most phones and fits nicely within most computer screens.

__7. Click Create AVD.

__8. Click OK inside the result confirmation dialog.  The AVD should now appear in the 
list of AVDs, as shown below.

Note, the AVD files are created in .android/avd folder within your user's home 
directory.
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When a user taps inside an HTML form field in an Android phone's web browser, a soft 
(virtual) keyboard is normally displayed.  In order to simulate this behavior, we need to 
modify the emulator settings.

__9. Select my_avd.

__10. Click the Edit button.

__11. Click the New button to the right of Hardware.

__12. In the pop-up dialog, select Keyboard support from the Property drop-down and 
click OK.

__13. Back in the Edit Android Virtual Device (AVD) dialog, change the value of 
Keyboard support from yes to no.

__14. Click the Edit AVD button to save the changes.

__15. Click OK inside the result confirmation dialog. 

Now that we're finished creating our AVD, we'll start it up.

__16. Select my_avd.

__17. Click Start.

__18. Click Launch.
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The AVD will be launched. It takes a while for the machine to boot. In the meanwhile, 
you will see an Android message.

__19. If you see a Thanks for using the Android SDK window, uncheck the box and click 
Proceed.

__20. Click OK when you see the image below.
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__21. Now click on the Application icon 

__22. Click OK again.

__23. The Apps page will be shown.
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__24. Click the Browser app to open the internal web browser.

Next, we will navigate to the web page inside the mobile browser that you previously 
tested using a desktop browser.  To access the web server from Android, we either have to 
use the IP address or edit the HOSTS file. We will take the former approach. 

__25. Find out the IP address of your machine (by running the ipconfig command from a 
a new command prompt).

__26. Back in the Android emulator, enter the following URL in the location bar of the 
mobile browser:  

http://<YOUR_IP_ADDRESS>/universal.html  

• If the location bar is not visible, then drag down (i.e., scroll down) to view it.

• When you click inside the location bar, a soft (virtual) keyboard will be displayed 
at the bottom of the browser, which you'll need to use to input the URL.  
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Note:  If you try to type the URL using your computer keyboard or the emulator 
keyboard (displayed on the right side of the emulator window), you won't be able to. 
This is because we disabled keyboard support when creating the emulator.  

• To delete the current URL displayed in the location bar, click inside the location 
bar again.  An X should appear to the right of the URL.  Click the X.

• Enter the URL above.  To type the colon (:) and forward slashes (/), click the ?123 
key on the keyboard.  To type the remaining letters, click the ABC key. 

• Click the Go key to navigate to the URL. 
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__27. Verify that the header and image are hidden, but the footer is displayed.

Note:  You may need to double click inside the browser to zoom in. 

__28. Leave the emulator running, since we will be using it in upcoming labs too.

Part 6 - Review
In this lab, we learned how to create a universal web site using the CSS media rule. We 
created two sets of styles, one for mobile devices and another one for the desktop.
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Lab 2 - Device Specific Rendering from JavaScript
In a previous lab, you used CSS media rules to do alternate rendering of the same HTML 
content. In this lab, you will achieve that goal using JavaScript. Using JavaScript, we will 
detect if the browser is running in a mobile device and then change the layout. This 
approach comes in handy in Web 2.0 style web sites where data is fetched using Ajax and 
then rendered using the JavaScript DOM API.

We will continue to work with universal.html. The logic will be the same. If running on a 
mobile device, we will hide the header and the image. Otherwise, we will hide the footer.

Part 1 - Write Device Detection Function
__1. Open universal.html in an editor.

__2. Comment out the entire <style> </style> tag so it has no effect.

__3. Save changes.

__4. Refresh the page in a browser and make sure that both the header, footer, and image 
are shown.

__5. Within the <head> </head> tag, add this code.

<script>
function isMobile() {
        var agent = navigator.userAgent.toLowerCase();
        var tokens = ["android", "iphone", "ipad", "ipod"];
        
        for (var i = 0; i < tokens.length; ++i) {
                if (agent.indexOf(tokens[i], 0) >= 0) {
                        return true;
                }
        }
        return false;
}
</script>

__6. Save changes.
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Part 2 - Hide Elements on Load
Now, we will write JavaScript code that will hide the appropriate section of the page.

__1. Within the <script> </script> tag, add this code.

window.onload = function() {
        var hideIds = new Array();
        
        if (isMobile()) {
                hideIds.push("header");
                hideIds.push("big_image");
        } else {
                hideIds.push("footer");
        }
        
        for (var i = 0; i < hideIds.length; i++) {
           document.getElementById(hideIds[i]).style.display = "none";
        }
}

__2. Save changes and close the file.

Part 3 - Test
Note: This lab is best tested using Safari; Safari should be installed as part of the setup 
for this course. It has a menu item – Develop > User Agent which allows you to 
impersonate a desktop browser and iPhone or iPad browser. If you cannot use Safari then 
go to step 5 and do the Emulator test.

__1. Open a browser and enter the URL: 

http://localhost/universal.html

__2. By default, you will see the desktop version. That is, the header and image will be 
shown and the footer will be hidden.

Note:  You may need to double click inside the browser to zoom in. 

__3. If you are using Safari, you need to enable the Developer menu. Select Edit-
>Preferences from the menu bar.  In the Advanced dialog, click the Advanced button in 
the toolbar and check the Show Develop menu in menu bar checkbox.  Close the dialog 
afterwards.
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__4. Now, from the menu bar, select  Develop > User Agent > Safari iOS 4.3.3 – 
iPhone. The page should refresh automatically and you should see the mobile version. 
That is, the header and image will be hidden and the footer will be shown.

Next, we will test the web page in the Android emulator.  If you closed the Android 
emulator, refer to Lab 1 for instructions on launching it and opening the internal web 
browser.

__5. In the Android emulator's web browser, enter the following URL or refresh the page: 

http://<YOUR_IP_ADDRESS>/universal.html

Note:  Remember that you'll need to use the soft keyboard to input the URL.  You may 
also need to drag down (i.e., scroll down) to see the location bar.

__6. Verify that the header and image are hidden and the footer is shown.

__7. Close all browsers.

__8. Close my_avd emulator window and close the ADV Manager window. 
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Part 4 - Review
Many Web 2.0 style applications use the JavaScript DOM API to manipulate content 
shown in a page. In a universal web site, you may need to do device specific rendering. In 
this lab, we learned how to do that.
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Lab 3 - Create a Basic HTML5 Layout
In this lab, you will create an HTML5 template which will serve as the starting point for 
creating new HTML  files in upcoming labs.

This lab will help you understand what a very simple HTML5 document looks like. 
Specifically, you will learn to declare the DOCTYPE and character encoding.

When creating HTML5 files, you will use Notepad as a text editor.  Of course, you're free 
to use another text editor if you'd prefer.

Also, we'll be using Google Chrome as a web browser, since it provides the best support 
for HTML5 in a Windows environment.  

Note:  On the Mac, Safari provides the best support for HTML5.  Feel free to 
experiment with other web browsers, such as Firefox 4 and Internet Explorer 9. 
However, we can't guarantee that all the HTML5 pages you create will render properly 
in those other browsers.  If you want to see how well your browser supports HTML5, 
navigate to http://www.html5test.com from within the associated browser.

Note:  These labs were written using Chrome 23.0.x.  If you're using a other version of 
Chrome, you may see slight differences in the GUI.

Part 1 - Clear the Browser Cache and Location Settings
In this part, you will clear Chrome's cache and location settings.  This will help ensure 
that any cached files and stored location settings will not interfere with any of the labs.  

__1. Open Chrome by selecting Start->All Programs->Google Chrome->Google 
Chrome.

__2. Click the icon to the right of the location bar and select Settings from the drop-down 
menu. Older Chrome versions will show Options instead Settings.
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__3. Under Settings expand Show advanced settings...

__4. Under Privacy click the Clear browsing data.

__5. Check all the checkboxes.

__6. Select the beginning of time option from the Obliterate the following items from 
drop-down box.

__7. Click the Clear browsing data button.
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Wait for the clearing process to complete.

__8. Click the Content settings button, which is located to the left of the Clear 
browsing data button.

__9. Scroll down in the browser and click the Manage exceptions button under the 
Location section.

__10. If any exceptions appear in the panel, select the exception and click the X to the 
right of it to delete the exception.
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__11. Click the X in the upper right corner of the Geolocation Exceptions panel to close 
the panel.

__12. Click the X in the upper right corner of the Content Settings panel to close the 
panel. 

__13. Close the browser.

Part 2 - Create the Template
In this part, you will create the HTML5 template.  The template will consist of the 
following elements:

• DOCTYPE 

• html

• head

• meta (used to specify character encoding)

• title

• body 

__1. Open Notepad by selecting Start->All Programs->Accessories->Notepad.

__2. Enter the DOCTYPE declaration, followed by the html element:

<!DOCTYPE html>
<html> 

The DOCTYPE declaration must be the very first element in your HTML5 document.  It 
even must appear before the html element.  

Note:  For those of you who are familiar with XML and XHTML (an XML compliant 
version of HTML), the DOCTYPE element is used to indicate the document type 
definition (DTD) that an XML document adheres to.  A DTD is used to specify the 
grammar of an XML document.  

However, an HTML5 document is not XML, so the DOCTYPE element is not required 
for this purpose.  Instead, it's used to trigger "no-quirks mode" (a.k.a. "standards mode"). 
"No-quirks mode" implies the browser renders the page according to the HTML5 and 
CSS standards.  "Quirks mode" implies it doesn't and instead tries to maintain backward 
compatibility with legacy pages created for older browser versions. 

Also, notice that in HTML5 the DOCTYPE element is kept very minimal and simply 
includes the root element name.  Normally, when entering a DOCTYPE element in an 
XHTML/XML document, you would need to specify several other pieces of 
information, including a URL pointing to the DTD (see example below).  However, 
since the DOCTYPE element is not being used to reference a DTD, we can omit this 
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additional information.  

e.g.,
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" 
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

Note:  The DOCTYPE element is case insensitive.  You could have written the 
following instead:
<!DOCTYPE HTML>
<!doctype html>

__3. Define the document's character encoding inside the head element as shown below. 

<head>  
   <meta charset="utf-8"/>  
   <title>HTML 5 Template</title>  
</head>

Note:  The character encoding declaration is shorter than the one you're accustomed to 
writing in HTML4:
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">

Note:  HTML5 is not XML.  Hence, element names are not case sensitive, elements 
don't require both a start and end tag, and attribute names don't need to be enclosed in 
quotes.  Hence, you could have expressed the meta element in any of the ways listed 
below:
<META CHARSET="utf-8"/>
<META CHARSET=utf-8/>
<meta charset="utf-8">
<meta charset=utf-8/>
<Meta CharSet=Utf-8>
Having said that, we will use XML syntax going forward.
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__4. Finally, add the body element and the html close tag to the document:

<body>  
   Contents goes here...
</body>  

</html> 

Next, you will save the HTML file to the Apache Web Server document root. 

__5. Open Windows Explorer.

__6. Create a folder called layout under the following directory (the Apache folder may 
be installed in other location, check with your instructor):  

C:\Program Files\Apache Software Foundation\Apache2.2\htdocs

__7. Save in this folder the HTML file as html5Template.html within the layout folder.

Part 3 - Test
In order to test the HTML5 document, we'll use Google Chrome, since it provides the 
best support for HTML5. 

__1. Open the Chrome browser.

__2. Enter the following URL into the address bar:

http://localhost/layout/html5Template.html 

__3. You should see the following screen:
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__4. Close the html file.

Part 4 - Review
In this lab, you created a template for your HTML5 files.  In the process, you learned 
how to declare DOCTYPE and meta elements.
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	Lab 1 -  Using Media Rules to Build Universal Web Site
	Part 1 -  Basic Approach
	Part 2 -  Design the HTML Page
	__1.  In the web server document root (C:\Program Files\Apache Software Foundation\Apache2.2\htdocs) create a new file called universal.html.
	__2.  Open it with Notepad and enter the following code.
	__3.  Save changes.
	__4.  Copy C:\LabFiles\flower.jpg to the web server document root (C:\Program Files\Apache Software Foundation\Apache2.2\htdocs).
	__5.  In a browser (Chrome or Safari is encouraged) the URL: 
	__6.  Close the browser.

	Part 3 -  Design the Stylesheet
	__1.  Within the <head> </head> tag, enter these styles:
	__2.  Save changes.
	__3.  For media rules to work properly in any Webkit based browser (as in Safari, iOS and Android), you will need to add this meta tag within <head> element.
	__4.  Save changes and close the file.

	Part 4 -  Test Using Desktop Browser
	__1.  Open a browser. Make it fairly wide to simulate a desktop environment.
	__2.  Enter the URL: 
	__3.  Make sure that header and image are displayed, but the footer is hidden.
	__4.  Try shrinking the width of the browser. At some point (i.e., below 480px width), the header and image will get hidden and the footer will get displayed.

	Part 5 -  Testing Using Mobile Device
	__1.  Open a file browser and navigate to.
	__2.  Open the AVD Manager by running this file:
	__3.  Click New.
	__4.  Enter my_avd as the name. 
	__5.  Select Android 4.0 – API Level 14 as the target.
	__6.  Make sure that screen resolution is set to Default (WVGA800). This resolution is a good approximation of most phones and fits nicely within most computer screens.
	__7.  Click Create AVD.
	__8.  Click OK inside the result confirmation dialog.  The AVD should now appear in the list of AVDs, as shown below.
	__9.  Select my_avd.
	__10.  Click the Edit button.
	__11.  Click the New button to the right of Hardware.
	__12.  In the pop-up dialog, select Keyboard support from the Property drop-down and click OK.
	__13.  Back in the Edit Android Virtual Device (AVD) dialog, change the value of Keyboard support from yes to no.
	__14.  Click the Edit AVD button to save the changes.
	__15.  Click OK inside the result confirmation dialog. 
	__16.  Select my_avd.
	__17.  Click Start.
	__18.  Click Launch.
	__19.  If you see a Thanks for using the Android SDK window, uncheck the box and click Proceed.
	__20.  Click OK when you see the image below.
	__21.  Now click on the Application icon 
	__22.  Click OK again.
	__23.  The Apps page will be shown.
	__24.  Click the Browser app to open the internal web browser.
	__25.  Find out the IP address of your machine (by running the ipconfig command from a a new command prompt).
	__26.  Back in the Android emulator, enter the following URL in the location bar of the mobile browser:  
	__27.  Verify that the header and image are hidden, but the footer is displayed.
	
	__28.  Leave the emulator running, since we will be using it in upcoming labs too.

	Part 6 -  Review

	Lab 2 -  Device Specific Rendering from JavaScript
	Part 1 -  Write Device Detection Function
	__1.  Open universal.html in an editor.
	__2.  Comment out the entire <style> </style> tag so it has no effect.
	__3.  Save changes.
	__4.  Refresh the page in a browser and make sure that both the header, footer, and image are shown.
	__5.  Within the <head> </head> tag, add this code.
	__6.  Save changes.

	Part 2 -  Hide Elements on Load
	__1.  Within the <script> </script> tag, add this code.
	__2.  Save changes and close the file.

	Part 3 -  Test
	__1.  Open a browser and enter the URL: 
	__2.  By default, you will see the desktop version. That is, the header and image will be shown and the footer will be hidden.
	__3.  If you are using Safari, you need to enable the Developer menu. Select Edit->Preferences from the menu bar.  In the Advanced dialog, click the Advanced button in the toolbar and check the Show Develop menu in menu bar checkbox.  Close the dialog afterwards.
	__4.  Now, from the menu bar, select  Develop > User Agent > Safari iOS 4.3.3 – iPhone. The page should refresh automatically and you should see the mobile version. That is, the header and image will be hidden and the footer will be shown.
	__5.  In the Android emulator's web browser, enter the following URL or refresh the page: 
	__6.  Verify that the header and image are hidden and the footer is shown.
	__7.  Close all browsers.
	__8.  Close my_avd emulator window and close the ADV Manager window. 

	Part 4 -  Review

	Lab 3 -  Create a Basic HTML5 Layout
	Part 1 -  Clear the Browser Cache and Location Settings
	__1.  Open Chrome by selecting Start->All Programs->Google Chrome->Google Chrome.
	__2.  Click the icon to the right of the location bar and select Settings from the drop-down menu. Older Chrome versions will show Options instead Settings.
	__3.  Under Settings expand Show advanced settings...
	__4.  Under Privacy click the Clear browsing data.
	__5.  Check all the checkboxes.
	__6.  Select the beginning of time option from the Obliterate the following items from drop-down box.
	__7.  Click the Clear browsing data button.
	__8.  Click the Content settings button, which is located to the left of the Clear browsing data button.
	__9.  Scroll down in the browser and click the Manage exceptions button under the Location section.
	__10.  If any exceptions appear in the panel, select the exception and click the X to the right of it to delete the exception.
	__11.  Click the X in the upper right corner of the Geolocation Exceptions panel to close the panel.
	__12.  Click the X in the upper right corner of the Content Settings panel to close the panel. 
	__13.  Close the browser.

	Part 2 -  Create the Template
	__1.  Open Notepad by selecting Start->All Programs->Accessories->Notepad.
	__2.  Enter the DOCTYPE declaration, followed by the html element:
	__3.  Define the document's character encoding inside the head element as shown below. 
	__4.  Finally, add the body element and the html close tag to the document:
	Next, you will save the HTML file to the Apache Web Server document root. 
	__5.  Open Windows Explorer.
	__6.  Create a folder called layout under the following directory (the Apache folder may be installed in other location, check with your instructor):  
	__7.  Save in this folder the HTML file as html5Template.html within the layout folder.

	Part 3 -  Test
	__1.  Open the Chrome browser.
	__2.  Enter the following URL into the address bar:
	__3.  You should see the following screen:
	
	__4.  Close the html file.

	Part 4 -  Review

	Lab 4 -  New HTML5 Semantic Elements
	Part 1 -  Create a Layout using HTML5 Semantic Elements
	__1.  Open the template file you created in the previous lab, html5Template.html, and save it as pageLayout.html within the same folder (C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\layout).
	__2.  Change the title content to:
	__3.  Remove the content inside the body element.
	__4.  Add the header element just after <body>:
	__5.  Add the footer element after the header element:
	__6.  Add an article element before the footer tag:
	__7.  Insert the following section elements before </article>.  If you'd prefer not to type all the code, feel free to copy and paste it from C:\LabFiles\pageLayout.html.
	__8.  Save and close the file.

	Part 2 -  Test
	__1.  Open Google Chrome.
	__2.  Navigate to the following URL:
	__3.  You should see the following screen:

	Part 3 -  Visually Style Semantic Elements
	__1.  Create a new file called styles.css in the C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\layout folder.
	__2.  Open this file using Notepad.
	__3.  Add the following style rules to the style sheet:
	__4.  Save and close the file.
	__5.  Open the pageLayout.html file and link the HTML page to the stylesheet by adding the following link element before </head>:
	__6.  Save and then refresh the page in the browser.  You should see the following screen:

	Part 4 -  Review

	Lab 5 -  Add More Semantic Value to Your Page with HTML5
	Part 1 -  Create Page Layout with other Semantic Elements
	__1.  Open the layout file that you created in the previous lab called pageLayout.html
	__2.  Add the aside and nested nav element after </header>: 
	__3.  Change the paragraph element indicating when the user review was posted to the following:  
	__4.  Save and close the file.

	Part 2 -  Test
	__1.  Open Google Chrome.
	__2.  Navigate to the following URL:
	__3.  You should see the following screen:
	__4.  Open the styles.css file that you created in the previous lab.
	__5.  Make the following changes/additions in bold:
	__6.  Save and close the file.
	__7.  Refresh the page in the browser.  You should see the following screen:
	__8.  Close all open files and browsers.

	Part 3 -  Review

	Lab 6 -  Improve Your Forms Using HTML5
	Part 1 -  Create an Input Form Using the New HTML5 Input Types
	__1.  Open C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\layout\html5Template.html. Save it as registerEmployee.html in the same folder.
	__2.  Change the title content to:
	__3.  Remove the content inside the body element.
	__4.  Add the following code inside the body element:
	__5.  Add the following form element:
	__6.  Add a label and a corresponding text field for the employee's name inside the form element:
	__7.  Add a label and an e-mail field for the employee's e-mail:
	__8.  Add a label and a date field for the employee's date of birth.
	__9.  Add a label and a number field for the employee's age:
	__10.  Add a label and a range field for the employee's number of years of experience:
	__11.  Add a label and a text field for the employee's phone number:
	__12.  Finally, add a submit button to allow the user to submit the form and a label indicating that any fields with an asterisk (*) next to them are required.
	__13.  Save and close the file.
	__14.  Copy C:\LabFiles\thankYou.html to C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\layout, since the form submits to that page.

	Part 2 -  Test
	__1.  Open Google Chrome.
	__2.  Navigate to the following URL:
	__3.  You should see the following screen:
	__4.  Also, notice the following:
	__5.  Input the following values:
	__6.  Submit the form by clicking Register.
	__7.  You should see the thank you page.
	__8.  Click the Back button (left arrow).
	__9.  Delete the text in the full name field.
	__10.  Try submitting the form.
	__11.  You should see the following error message:
	__12.  Enter Mike Harris back into the full name field.
	__13.  Change the e-mail address from mharris@yahoo.com to mharris.
	__14.  Try submitting the form.
	__15.  You should see the following error message:

	Part 3 -  Display the Value of the Range Field
	__1.  Open registerEmployee.html.
	__2.  First off, add a span element to the right of the range field.  The span element will display the value the user selected for the number of years of experience:
	__3.  Next, add an onchange event handler to the range field that gets called after the user drags the slider to a new position:
	__4.  Add a script element before </head>.
	__5.  Add the event handler function, displayRating, inside the script element:
	__6.  Save your changes.
	__7.  Close all open browsers.
	__8.  Navigate to the following URL:
	__9.  Drag the slider all the way to the right. Make sure the value increments in steps of 1 and reaches a maximum value of 100.   
	__10.  Now drag the slider all the way to left.  Make sure the value decrements in steps of 1 and reaches a minimum value of 0.  

	Part 4 -  Troubleshooting JavaScript Problems in Chrome
	__1.  Change the code as shown in bold below:
	__2.  Save the file.
	__3.  Refresh the browser to pick up the changes.
	__4.  Try dragging the slider.  
	__5.  Select Tools->Developer tools from the menu bar.  
	__6.  The Developer tools should appear in the lower half of the browser window. Click the Sources tab and expand the html code.
	__7.  Click the Console tab.  
	__8.  Click the registerEmployee.html:9 link.
	__9.  Chrome will show you the offending line of code in the Scripts tab.
	__10.  Fix the error in the code.  
	__11.  Save your changes and refresh the page.  
	__12.  Now try dragging the slider.  The value should be updated and you should see no red Xs in the Developer Tools.
	__13.  Click on the Sources tab inside the Developer Tools panel.
	__14.  Click inside the gray margin to the left of the document.getElementById() line of code inside the displayRating function
	__15.  Verify a breakpoint symbol (blue arrow) appears.
	__16.  Try dragging the slider.
	__17.  Verify that the breakpoint was hit.  The line of code should now appear in blue.
	__18.  In the right panel, look inside the Scope Variables panel and you'll see the slider variable listed.  
	__19.  Expand it and you can see the value of its properties. 
	__20.  To execute the line of code, click the Step over next function call button in the toolbar at the top of the panel.
	__21.  The cursor should advance to the next line of code.
	__22.  Click the Pause script execution button (to the left of the Step over next function call button) to resume running the script.
	__23.  Remove the breakpoint by clicking on the blue arrow in the margin.  The arrow should disappear.
	__24.  Close the Developer Tools by selecting Tools->Developer tools from the wrench menu bar.  

	Part 5 -  Display the Value of the Range Field Using the Output Element
	__1.  Replace the span element:
	__2.  Delete the script element, containing the displayRating function, since it's no longer needed.
	__3.  Save your changes.
	__4.  Refresh the browser.  You should now see 0 for the number of years of experience listed to the right of the slider. 
	__5.  Drag the slider all the way to the right. Make sure the value increments in steps of 1 and reaches a maximum value of 100.   
	__6.  Now drag the slider all the way to left.  Make sure the value decrements in steps of 1 and reaches a minimum value of 0.  

	Part 6 -  Style the Error Fields
	__1.  Add the following style element before </head>:
	__2.  Save and close the file.
	__3.  Refresh the page.
	__4.  Input Mike Harris for the full name.
	__5.  Now input mharris@yahoo.com for the e-mail.  
	__6.  Repeat this process for the remaining fields.
	__7.  Submit the form.  You should see the thank you page. 
	__8.  Close the browser.

	Part 7 -  Review

	Lab 7 -  Drawing Using the Canvas Element
	Part 1 -  Create a 2D Drawing Using the Canvas Element
	__1.  Create a new folder called canvas within the C:\Program Files\Apache Software Foundation\Apache2.2\htdocs folder.
	__2.  Open C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\layout\html5Template.html using Notepad and save it as drawOnCanvas.html in the canvas folder.
	__3.  Change the title content to:
	__4.  Remove the content inside the body element.
	__5.  Add a canvas element inside the body element:
	__6.  Add an onload event handler to the body element:
	__7.   Add the following script element before </head>:
	__8.  Add the declaration for the drawOnCanvas function before </script>:
	__9.  Add the following variable declarations inside the drawOnCanvas function:
	__10.  Add the following code to draw a green rectangle to the drawOnCanvas function:
	__11.  Add the following code to draw the first diagonal to the drawOnCanvas function:
	__12.  In a similar manner, add the following code to draw the second diagonal before </script>:
	__13.  Add the following code to render the two lines you drew in red ink to the drawOnCanvas function:
	__14.  Save and close the file.

	Part 2 -  Test
	__1.  Open Google Chrome.
	__2.  Navigate to the following URL:
	__3.  You should see the following screen:
	__4.  Open drawOnCanvas.html using notepad.
	__5.  To see the border of the canvas, add the following style attribute to the canvas element:
	__6.  Save the file.
	__7.  Refresh the page in the browser.
	__8.    Try changing the size of the rectangle to a value that exceeds the width of the canvas:
	__9.  Save your changes.
	__10.  Refresh the page in the browser.
	__11.  Change the rectangle width back to its original size and save your changes.
	__12.  Test again.
	__13.  Close the browser and the editor.

	Part 3 -  Review

	Lab 8 -  Dynamic Drawing Using the Canvas Element
	Part 1 -  Create an AJAX Request
	__1.  Open C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\layout\html5Template.html using Notepad. Save it as monthlySales.html in the canvas folder.
	__2.  Change the title content to:
	__3.  Remove the content inside the body element.
	__4.  Copy C:\LabFiles\ajax_utils.js to C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\canvas.
	__5.  Copy C:\LabFiles\salesData.txt to C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\canvas.
	__6.  Open salesData.txt and examine its contents:
	__7.  Close the file.
	__8.  Back in monthlySales.html, add the following script element before </head>:
	__9.  Add an onload event handler to the body element:
	__10.   Add the following script element before </head>:
	__11.  Add the displayMonthlySales function after the init function and inside the script tag:
	__12.  Add the drawBarChart function after the displayMonthlySales function:
	__13.  Save the file
	__14.  Open Google Chrome.
	__15.  Navigate to the following URL:
	__16.  Verify you see the following alert:
	__17.  Click OK.

	Part 2 -  Draw the Bar Chart Axes
	__1.  Add a canvas element inside the body element:
	__2.  Delete the call to the alert function inside the drawBarChart function.
	__3.  Add the following code inside the drawBarChart function to retrieve the canvas element and graphical context:
	__4.  Add the following variable definitions to the drawBarChart function:
	__5.  Add the following code to trace and draw the x and y axes to the drawBarChart function:
	__6.  Save your changes.
	__7.  Refresh the browser.
	__8.  Verify you see the following page:
	__9.  Add the following code to draw the labels to the drawBarChart function:
	__10.  Save the file.
	__11.  Refresh the page in the browser.
	__12.  Verify that the axes labels now appear:

	Part 3 -  Draw the Bars
	__1.  Add the following variable definitions to the drawBarChart function:
	__2.  Add the following code to loop through the salesList, retrieve each element in the array, and store the month and sale in a set of variables:
	__3.  Add the following code inside the for loop to draw the bars, including computing the bar height and starting coordinates of the upper left corner of the bar.  
	__4.  Save your changes.
	__5.  Refresh the page in the browser.
	__6.  Verify you see the following page:

	Part 4 -  Draw the Data Labels
	__1.   Add the following code inside the for loop to draw the sales amount above each bar:
	__2.   Finally, add the following code inside the for loop to draw the name of the month below each bar:
	__3.  Save your changes.
	__4.  Refresh the page in the browser.
	__5.  Verify you see the following page:
	__6.  Close the browser and editor.

	Part 5 -  Review

	Lab 9 -  Audio/Video Playback
	Part 1 -  Play an Audio File Using the Audio Element
	__1.  Create a new folder called audio_video within the C:\Program Files\Apache Software Foundation\Apache2.2\htdocs folder.
	__2.  Copy C:\LabFiles\guitar.ogg to C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\audio_video.  
	__3.  Copy C:\LabFiles\guitar.mp3 to C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\audio_video.  
	__4.  Open C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\layout\html5Template.html using Notepad. Save it as audioVideo.html in the audio_video folder.
	__5.  Change the title content to:
	__6.  Remove the content inside the body element.
	__7.  Add an audio element inside the body element:
	__8.  Save the file.
	__9.  Open Chrome.
	__10.  Navigate to the following URL:
	__11.  Verify you see the following page:
	__12.  Click the Play button (right arrow).
	__13.  Verify that the progress bar moves to the right and the time elapses.  If you have a sound card installed and speakers attached, you should also be able to hear the audio playback (i.e, a guitar playing).
	__14.  Pause the audio by clicking the Pause button (two vertical bars).  The button should toggle to Play.   
	__15.  Click the Play button again.
	__16.  Replace the controls attribute with the autoplay attribute.  
	__17.  Save the file.
	__18.  Refresh the page in the browser.
	__19.  Verify that the audio controls aren't displayed and that the music automatically begins playing.
	__20.  Add the controls attribute back.
	__21.  Save the file.
	__22.  Refresh the page in the browser.
	__23.  Verify that the audio controls are displayed again and the music automatically begins playing.
	__24.  Change the audio element to the following:
	__25.  Save the file.
	__26.  Refresh the page in the browser.
	__27.  Verify the audio controls are displayed.
	__28.  Click the Play button and verify audio playback.

	Part 2 -  Play a Video File Using the Video Element
	__1.  Copy C:\LabFiles\bbb400p.ogv to C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\audio_video.  
	__2.  Add a video element after the audio element:
	__3.  Save the file.
	__4.  Refresh the page in the browser.
	__5.  Verify you see the video control.  It should be listed underneath the audio control and looks virtually identical to it.
	__6.  Click the Play button.  The "Big Buck Bunny" video should begin playing.
	__7.  Add the width attribute to the video element:
	__8.  Save the file.
	__9.  Refresh the page in the browser.
	__10.  Click the Play button.
	__11.  Verify that the video preserve the aspect ratio.  This is because the browser calculated what the height dimension should be to preserve the aspect ratio, which is 1.8:1 in our case. 
	__12.  Right click on the playback area and select Inspect element.
	__13.  In the button a bar will appear, move your mouse over Video.
	__14.  The video will display the width and the height.
	__15.  Change the video element to include both the width and height as follows:
	__16.  Save the file.
	__17.  Refresh the page in the browser.
	__18.  Click the Play button.
	__19.  Verify that the video has blank space on both sides, which indicates its been pillarboxed.
	__20.  Right click on the playback area and select Inspect element.  You should see the whole video element highlighted, which clearly shows the blank spaces to the left and right of the image.
	__21.  Hide the Developer Tools by clicking the x in the button.
	__22.  Copy C:\LabFiles\buckBunnyPoster.jpg to C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\audio_video. 
	__23.  Modify the video element to use the poster attribute:
	__24.  Save the file.
	__25.  Refresh the page in the browser.
	__26.  Verify that the poster is displayed.
	__27.  Now click the Play button.  
	__28.  Verify that the poster disappears and the movie begins to play.
	__29.  Close the browser and editor.

	Part 3 -  Review

	Lab 10 -  Geolocation
	Part 1 -  Locate Yourself using the Geolocation API
	__1.  Create a new folder called geolocation within the C:\Program Files\Apache Software Foundation\Apache2.2\htdocs folder.
	__2.  Open C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\layout\html5Template.html using Notepad. Save it as geolocation.html in the geolocation folder.
	__3.  Change the title content to:
	__4.  Remove the content inside the body element.
	__5.  Add the following content inside the body element:
	__6.  Add the following script element before </head>:
	__7.  Save the file.
	__8.  Add the success event handler before </script>:
	__9.  Add the error event handler before </script>:
	__10.  Save your changes.

	Part 2 -  Test
	__1.  Open Google Chrome.
	__2.  Navigate to the following URL:
	__3.  Verify you see the following page:
	__4.  Click the Locate Me! button.
	__5.  Click the Allow button.
	__6.  Verify that the Found you at… text is displayed.
	__7.  Click the Locate Me! button again.  
	__8.  Click the clock icon in the upper right corner of the location bar.
	__9.  In the callout box that appears, click the Clear these settings for future visits link.
	__10.  Refresh the page (e.g., click F5).  
	__11.  Verify that the clock icon disappeared.
	__12.  Click the Locate Me! button again.  
	__13.  This time when prompted for permissions, click the Deny button.
	__14.  Verify that you see the following error message:
	__15.  Verify that the clock icon reappeared.  Notice there's now a red X inside the clock indicating that you've denied the browser the right to acquire your location.
	__16.  Repeat the process above, but this time give the browser access to obtain your location.

	Part 3 -  Display your Position on a Map
	__1.  To use the Google Maps API, include it within the page by adding the following script element before </head>.
	__2.  Add the following div element before </body>, which will contain the map:
	__3.  Add the following code to the end of the geoSuccess function.  If you'd prefer not to type it all in, copy and paste the code from C:\LabFiles\geolocation.html.
	__4.  Save the file.
	__5.  Refresh the page in the browser.
	__6.  Click the Locate Me! button.
	__7.  Verify that you see the map.
	__8.  Roll over the marker (red callout symbol).
	__9.  Verify you see the text You are located here.
	__10.  Close the browser and editor.

	Part 4 -  Review

	Lab 11 -  Web Storage
	Part 1 -  Create a To Do List GUI
	__1.  Create a new folder called webstorage within the C:\Program Files\Apache Software Foundation\Apache2.2\htdocs folder.
	__2.  Open C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\layout\html5Template.html using Notepad. Save it as toDo.html in the webstorage folder.
	__3.  Change the title content to:
	__4.  Remove the content inside the body element.
	__5.  Add the following content inside the body element:
	__6.  Save the file.
	__7.  Open Google Chrome.
	__8.  Navigate to the following URL:
	__9.  Verify you see the following page:

	Part 2 -  Add an Item 
	__1.  Add a script element before </head>:
	__2.  Declare a global array before </script>:
	__3.  Add the addTask event handler before </script>:
	__4.  Add the addTaskToListBox utility function:
	__5.  Save the file.
	__6.  Refresh the page in the browser.
	__7.  Enter a task and deadline and click the Add button.
	
	__8.  Verify that the task shows up in the list.

	Part 3 -  Store Items in Local Storage
	__1.  Add the saveTasks event handler before </script>:
	__2.  Save the file.
	__3.  Refresh the page in the browser.
	__4.  Enter a task and deadline and click the Add button.
	__5.  Verify the task appears in the list.
	__6.  Now click the Save Tasks button.
	__7.  Verify you see the following dialog:
	__8.  Click OK.

	Part 4 -  Retrieve Items from Local Storage
	__1.  Add the loadTasks function before </script>:
	__2.  Add the following line of code before </script>:
	__3.  Save the file.
	__4.  Refresh the page in the browser. You should see the task that you added before.
	__5.  Enter a task and deadline and click the Add button.
	__6.  Click the Save Tasks button.
	__7.  Click OK.
	__8.  Refresh the page in the browser.
	__9.  Verify that the tasks are still visible in the list box.  This proves that the information was stored to local storage.
	__10.  Open it again and navigate to the following URL:
	__11.  Verify that you still see the items in the list box.  This proves that the information is saved beyond the browser's session.

	Part 5 -  Delete Items from Local Storage
	__1.  Add the removeTasks function before </script>:
	__2.  Save the file.
	__3.  Refresh the page in the browser.
	__4.  Verify the old items should still appears in the list.
	__5.  Now click the Delete All Tasks button.
	__6.  Verify the list is now empty.
	__7.  Refresh the page in the browser.
	__8.  Verify that the list is still empty.
	__9.  Close the browser.
	__10.  Open it again and navigate to the following URL:
	__11.  Verify that the list is still empty.

	Part 6 -  Manipulate Local Storage Using Google Chrome Developer Tools
	__1.  Add some tasks to the to do list. 
	__2.  Click Save Tasks to save them to local storage.
	__3.  Select Tools->Developer tools from the menu bar.  
	__4.  Click the Resources tab.  
	__5.  In the left panel, expand Local Storage and click localhost.
	__6.  Verify that you see the tasks item in the list.   
	__7.  Right click on the tasks item and select Edit.
	__8.  Change the deadline for one of the tasks and click Enter.
	__9.  Refresh the page in the browser.  
	__10.  Verify that you can see the change.
	__11.  Right click the tasks item and select Delete.
	__12.  Verify the item disappeared from the list.
	__13.  Refresh the page in the browser.  
	__14.  Verify the list is empty again.
	__15.  Add some tasks to the to do list and save them to local storage.
	__16.  Select Tools->Clear browsing data from the menu bar.
	__17.  In the Clear Browsing Data dialog, make sure Delete cookies and other site data is checked.
	__18.  Click the Clear browsing data button.
	__19.  Click the To Do List tab in the browser.
	__20.  Refresh the page in the browser.
	__21.  Verify that the items in the list disappeared.
	__22.  Close the browser and editor.

	Part 7 -  Review

	Lab 12 -  Web SQL Database
	Part 1 -  Modify the To Do List GUI
	__1.  Create a new folder called sqlstorage within the C:\Program Files\Apache Software Foundation\Apache2.2\htdocs folder.
	__2.  Copy C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\webstorage\toDo.html to the sqlstorage folder.
	__3.  Edit the copied file.
	__4.  Remove the Save Tasks button by deleting the following line of code: 
	__5.  Also, delete the corresponding saveTasks function, since it will no longer be called.
	__6.  Save the file.
	__7.  Open Google Chrome.
	__8.  Navigate to the following URL:
	__9.  Verify you see the following page:

	Part 2 -  Create the Database
	__1.  Declare a global variable called db after the tasks array inside <script>:
	__2.  Add the declaration for the setupDatabase function before </script>:
	__3.  Add the code in the setupDatabase function to actually create the database:
	__4.   Add the following code to create a task table inside the database:
	__5.  Add the following code in bold:   
	__6.  Add the SQL statement error callback function before </script>: 
	__7.  Add the call to the setupDatabase function as the first line of code inside the loadTasks function:
	__8.  Save the file.
	__9.  Refresh the page in the browser.
	__10.  Verify you don't see an error message.  This means the database and database table should have been created.  We'll be able to confirm this later.  

	Part 3 -  Modify Code to Insert an Item in the Database 
	__1.  Add the declaration for the insertTask function before </script>:
	__2.  Create a database transaction by adding the following code to the body of the insertTask function:
	__3.  Add the following bolded code.  
	__4.  Last but not least, add the following bolded code for the SQL statement error callback function:
	__5.  Make sure the insertTask function looks like this:
	__6.  Remove the following code in the addTask function:
	__7.  Add the bolded code to the bottom of the addTask function:
	__8.  Save the file.
	__9.  Refresh the page in the browser.
	__10.  Enter a task and deadline and click the Add button.
	__11.  Verify no error message is displayed and the task appears in the list box.

	Part 4 -  Modify Code to Retrieve Items from the Database
	__1.  Add the declaration for the retrieveTasks function before </script>:
	__2.  Create a database transaction by adding the following code to the body of the retrieveTasks function:
	__3.  Add the following bolded code:
	__4.  Add the following bolded code to the end of the SQL statement success callback function.  Instead of hand typing in the code, simply cut and paste the last few lines of the loadTasks function inside the body of the function.
	__5.  First off, delete the lines of code related to the Web Storage API in the loadTasks function. 
	__6.  Add the call to the retrieveTasks function to the end of the function:
	__7.  Verify your function looks like the following:
	__8.  Save the file.
	__9.  Refresh the page in the browser.
	__10.  Verify no error message is displayed and that you still see the task you entered earlier.  This means the task was successfully loaded from the database.  
	__11.  Add a new task.  
	__12.  Close the browser.  
	__13.  Open it again and navigate to the following URL:
	http://localhost/sqlstorage/toDo.html
	__14.  Verify no error message is displayed and that you see both tasks:

	Part 5 -  Modify Code to Delete Items from the Database
	__1.  Add the declaration for the deleteTasks function before </script>:
	__2.  Create a database transaction by adding the following code to the body of the deleteTasks function:
	__3.  In the removeTasks function replace the first line of code which removes to do tasks from local storage with the bolded line of code that calls the deleteTasks function:
	__4.  Save the file.
	__5.  Refresh the page in the browser.
	__6.  Click the Delete All Tasks button.
	__7.  Verify no error message is displayed and the list box is empty.
	__8.  Close the browser.
	__9.  Open it again and navigate to the following URL:
	__10.  Verify no error message is displayed and the list is empty.

	Part 6 -  Manipulate Database Using Google Chrome Developer Tools
	__1.  Add some tasks to the to do list.
	__2.  Select Tools->Developer tools from the menu bar.  
	__3.  Click the Resources tab.  
	__4.  In the panel on the left, expand Web SQL.
	__5.  Verify you see the taskDB database listed underneath.
	__6.  Expand taskDB.
	__7.  Verify that you see the task table listed underneath.   
	__8.  Click the task table.  
	__9.  Verify that you see the to do tasks records you added in the right panel.
	__10.  Click on the text column.
	__11.  Notice that Chrome sorts the data by text in ascending order.
	__12.  Click on the text column again.
	__13.  Notice that Chrome sorts the data by text in descending order.
	__14.  In the left panel, click taskDB.
	__15.  Type the following SQL statement and press Enter:
	__16.  Verify you see the following result:
	__17.  Press the up arrow key on your keyboard.  
	__18.  Verify that Chrome displays the last statement you just executed.  
	__19.  Type the following SQL statement and press Enter:
	__20.  Click the task table in the left panel.
	__21.  Verify it says The "task" table is empty in the right panel.
	__22.  Refresh the page in the browser.
	__23.  Verify no error message is displayed and the list box is empty.
	__24.  Add some tasks to the to do list.
	__25.  Select Tools->Clear browsing data from the menu bar.
	__26.  In the Clear Browsing Data dialog, make sure Delete cookies and other site and plug-in data is checked.
	__27.  Click the Clear browsing data button.
	__28.  Click the To Do List tab in the browser.  
	__29.  Look inside the Resources tab of the Developer Tools.  
	__30.  Close the browser and the editor.

	Part 7 -  Review

	Lab 13 -  Exploring Mobile UI Patterns
	Part 1 -  Business Requirement
	Part 2 -  Getting Set Up
	__1.  Copy these two directories from C:\LabFiles to the web server's document root (C:\Program Files\Apache Software Foundation\Apache2.2\htdocs):

	Part 3 -  Create the Home Page
	__1.  Open Windows file explorer.
	__2.  Go to C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\mm folder.
	__3.  Copy template.html and paste it as index.html.
	__4.  Open index.html in your favorite editor.
	__5.  Notice some of the boiler plate code already present here:
	__6.  Within the <body> tag, add these lines to define a "page".
	__7.  Within the page div tag, add the content area:
	__8.  Within the content div tag, add the branding content:
	__9.  Save changes.

	Part 4 -  Test
	__1.  Open a WebKit based browser like Chrome or Safari. They will closely mimic the browsers in Android and iOS.
	__2.  Enter the URL: 
	__3.  Even for such simple content, jQuery Mobile is playing a role:

	Part 5 -  Display Movie List
	__1.  Below the </div> end tag of the branding content, add these lines:
	__2.  Within the <ul> tag, add three rows using <li> tag as follows.
	__3.  Save changes.

	Part 6 -  Test
	__1.  Refresh the browser that was showing http://localhost/mm/.
	__2.  Note the following aspects of the List View pattern:

	Part 7 -  Implement Movie Details Page
	__1.  In the mm folder of the document root, copy template.html and paste it as madagascar.html.
	__2.  Open madagascar.html in text editor.
	__3.  Within the <body> tag add a <div> for the page.
	__4.  Within the <div> for the page, add a header as follows.
	__5.  Below the header div, add these lines:
	__6.  Save changes.

	Part 8 -  Test
	__1.  In the browser, enter the URL: 
	__2.  Verify that it looks like above.

	Part 9 -  Implement Master Detail Navigation
	__1.  Open index.html in the editor.
	__2.  Add a hyperlink for the row for the Madagascar movie as shown in bold face below:
	__3.  Save changes.
	__4.  Open madagascar.html in editor.
	__5.  For the <div> tag of the page, add the attribute shown in bold face below.
	__6.  Save changes.

	Part 10 -  Test
	__1.  Close all browser windows. Navigation may not work properly if browser has pages cached.
	__2.  Open a new WebKit based browser. Enter the URL: 
	__3.  Notice, now the row with the hyperlink has a indicator accessory icon to the right. This is a hint to the user that tapping the row will show next level of details.
	__4.  Click the row for Madagascar.
	__5.  Note the back button in the header.
	__6.  Click the back button and make sure you go back to the home page.

	Part 11 -  Apply Page Transition
	__1.  Open index.html in editor.
	__2.  In the hyperlink for madagascar.html, add transition behavior as shown in bold face below.
	__3.  Save changes.

	Part 12 -  Test
	__1.  Close all open browsers.
	__2.  Open a new WebKit browser and enter the URL: 
	__3.  Click the row for Madagascar. Make sure that details page slides in from right to left.
	__4.  Click the back button from the details page. Make sure that the home page slides in from left to right.

	Part 13 -  Show Movie Trailer
	__1.  Open madagascar.html in editor.
	__2.  Below the line:
	__3.  Save changes.

	Part 14 -  Test
	__1.  Close all browsers.
	__2.  Open a WebKit browser and enter the URL: 
	__3.  Click the row for Madagascar.
	__4.  Click the Play Trailer button.
	__5.  Make sure that the browser begins to play the movie.
	__6.  Close the browser and editor.

	Part 15 -  Review




