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Lab 1 - Configure the Development Environment
Throughout these labs, you will be developing web service components with two main 
pieces of software: Oracle WebLogic Server v12c and Oracle Enterprise Pack for 
Eclipse(OEPE).

Oracle WebLogic Server v12c(12.1.1) (WLS) is a JEE application server that serves up 
JEE applications, and is also a web service container. 

OEPE, Provides tools that make it easier to develop applications utilizing specific Oracle 
Fusion Middleware technologies and Oracle Database.  Based on the Eclipse tool, it is the 
programming environment we will use for this class. 

In this lab exercise, we will configure WLS and OEPE to form our development 
environment. 

Part 1 - Oracle WebLogic server Setup
WebLogic Server is already extracted into C:\Software\WebLogic folder.

In this part we will setup necessary Environment variables and run installation 
configuration script.

Follow the instructions to set up JAVA_HOME, MW_HOME and JAVA_VENDOR 
environment variable

JAVA_HOME=C:\Software\Java

MW_HOME=C:\Software\WebLogic

JAVA_VENDOR=Oracle

__1. Right click on the My Computer icon on your computer and select properties. 

__2. Click the Advanced Tab. 

__3. Click the Environment Variables button. 

__4. From the System Variables list, select Path and click Edit.

__5. At the beginning of the line enter the following:

C:\Software\Java\bin;
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__6. Click OK.

__7. Under System Variables, click New. 

__8. Enter the variable name as JAVA_HOME

__9. Enter the variable value as the install path for the Development Kit. 

__10. Click OK. 

__11. Repeat these steps for MW_HOME and JAVA_VENDOR variables.

Once all done it should look like.

__12. Click OK until you close all windows.

Now you will run the installation configuration script in the MW_HOME directory. It 
should be run only once.

__13. Open a command prompt.

__14. Change the directory to C:\Software\WebLogic

__15. Enter configure.cmd and hit Enter.
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It takes few minutes to complete. 

You will get a notification when the installation is done.

__16. Close the command prompt window.

__17. Restart the machine.

__1. Open a Windows command prompt.  You can do this by selecting 'Start -> Run', 
entering 'cmd', and then pressing the OK button.

__2. Enter the following command:

java -version

Make sure you see the response shown below.

__3. Enter the following command:

javac

Verify that you get the options to run the Java compiler:

__4. Close the command prompt window. 
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Part 2 - Configure a server in OEPE
We now need to configure OEPE to be able to communicate with WLS.  Doing so will 
allow us to perform simple operations with the server (e.g. Starting, stopping and 
deploying applications).  While this is not strictly necessary for a development 
environment, it significantly simplifies development time. In order to setup the server we 
should also need to create a domain.

As with WLS, OEPE has already been installed on your computer.  We just need to 
configure it. 

__1. Start OEPE by launching C:\Software\OEPE\eclipse.exe

OEPE will launch.

You will be prompted to select a Workspace. 

__2. Set the Workspace to C:\workspace

__3. Click OK.

OEPE will start. 
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As mentioned earlier, OEPE is built on top of Eclipse.  If you are familiar with Eclipse, 
you should have no problems using OEPE.  

__4. WTP is displaying the Welcome screen (or view).  Close the view by clicking the x 
in its tab.  

__5. From the menu, select Window > Open Perspective > Java EE.

OEPE will then show the Java EE perspective. (A perspective is a collection of views)

__6. Select Windows | Preferences.

__7. Expand Server | Runtime Environments.

__8. Click Add...

__9. Expand  Oracle and select Oracle Weblogic Server 12c(12.1.1)
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__10. Click Next.

__11. For Weblogic home, enter C:\Software\WebLogic\wlserver or browse to find the 
location. Similarly enter C:\Software\Java for Java home.

You will see as shown below:
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__12. Click Finish.

__13. Click OK.

__14. We need to create domain and configure OEPE to point at the domain.  Locate the 
Server view. To do this, click the Servers tab in the bottom area of OEPE.

__15. Right click anywhere in the area and select New | Server.
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The New Server window will appear. 

__16. Select Oracle WebLogic Server 12c.

__17. Click Next.
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__18. Next to Domain directory, click the create icon and then select Create Domain.

__19. Enter LabDomain as the name. 

__20. Check specify password and enter w1sadmin as password where the password 
contains number one not L. 

__21. Don’t select any extensions, because we will not be using any of the advanced 
features like WS-Addressing.

__22. Click Finish.

__23. After some seconds the below screen will open, make sure Disable Automatic 
Publishing to server is checked.
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__24. Click Finish.

The server connection has been defined, and the server should now be listed in the 
Servers view.

Part 3 - Working with the Server
Throughout this class, we will be using this view to perform 3 basic operations: server 
stop, start and publish.  We will discuss publishing in a later lab, so let us now focus on 
starting and stopping the server. 

__1. Let us start things off by starting the server.  In the Servers view, right click on the 
server and select Start.
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The Console view should automatically open.  This will allow us to “see” OEPE booting. 
Eventually, the server will start and the Servers view will be brought to the focus again.  

After finish publishing the server State should be Started.

__2. Examine the Console window by clicking the Console tab. 

In later lab steps, when we ask you to refer to the server console, this is the view we will 
be referring to.  

__3. Let us try stopping the server.  Go back to the Servers view. 

__4. Right click on the server and select Stop.
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As with starting the server, the console view will open briefly.  Then the Server view will 
appear, listing the status as Stopped.

You have stopped the server.

Part 4 - Review
In this lab, you configured the development environment.  

You started things off by configuring environment followed by WebLogic Server domain 
creation and server setup, which will be used to host our web service applications.

You saw how to start and stop a WebLogic Server instance. 
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Lab 2 - Designing a RESTful Service
Before we get into actual coding of RESTful services, we need to learn about how to 
design or architect one. This skill will be independent of the programming model and will 
apply equally if you choose to use PHP, ASP.NET or JAX-RS as the programming model.

We will begin by gathering business requirements. We will then analyze the requirements 
and then take various architectural decisions.

You will only need a pen and a notepad for this lab.

Part 1 - The Business Requirements
Acme Inc. is a machine parts manufacturing company. It manufactures components that 
other companies buy to build machines. Most of the parts are standard and are purchased 
by many companies. Acme also offers custom parts manufacturing services. A customer 
can submit the design for a part which Acme manufactures just for that client.

Currently, Acme offers a web site where companies can place orders and check order 
status. This has worked well for a few years. Now, customers are increasingly asking for 
a Web Service interface. This will help the clients integrate parts ordering with their own 
internal software systems and allow them to place orders without human intervention.

Short Theory of Requirements

Usually, requirements are first written using brief unstructured statements. They are 
captured as feature requests, with unique number and status. In this manner, features are 
very similar to defects. Features that are within the scope of a project are approved and 
then further elaborated using use cases. Use cases also have unique identification 
numbers. Use cases follow a more structured format and are immensely helpful in any 
software design.

To keep things simple in this lab, we will just write down the basic requirements. In real 
life, you are encouraged to develop use cases before proceeding with the subsequent 
stages of service design.

R1. Get price quote and availability – A client organization should be able to get a quote 
for a part and a confirmation if it can be available within a given date. The quote includes 
unit price and total applicable price taking into account any discounts.

R2. Place an order for standard parts – A client organization should be able to place an 
order. An order is a list of part numbers and quantities. After the order is placed 
successfully, an identifier for the order is returned.

R3. Get order details – Client should be able to get the status of an order by the order ID. 
The information includes the total cost of the order. If the order is pending shipment then 
an expected delivery date is also returned.

R4. Get order history – Client should able to get a list of orders by order status.

R5. Cancel an order – Client should able to cancel an order.

Copyright 2013 Web Age Solutions Inc. 15

EVALUATIO
N O

NLY



R6. Place order for a custom part – Client uploads a CAD (computer aided design) 
document that captures the design of the part. 

Part 2 - Define Project Scope
In Phase I of the project, requirements R1-R5 will be addressed. Ordering of custom parts 
(R6) will be addressed in Phase II.

Part 3 - Designing the Object Model
This is the first stage in designing a RESTful web service. At this stage, we define the 
structure of the data that is exchanged between the web service and its consumers. The 
process is very similar to class design in Object Oriented Programming.

First step in object model definition is the identification of entities. Entities are nouns in 
business requirements. 

__1. Can you go through the business requirements and identify the entities? 

Here is the answer:

• Price quote request

• Price quote response

• Order

• Order line item

• Order status

__2. Now that you have identified the entities, can you list the attributes or fields for each 
entity? Once again, the answer is below. But do your best to do the design yourself.

Price quote request

• Part number

• Quantity

• Client organization ID

• Date the part needs to be available by

Price quote response

• Part number

• Quantity

• Date the part needs to be available by

• Unit price

• Total price
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• If order can be shipped within the required date.

Order line item

• Part ID

• Quantity requested

Order

• Order ID

• Client organization ID.

• Order total

• Status

• Expected shipment date

• List of order line items

Part 4 - Identify the Service
Service identification is an important stage in Service Oriented Architecture (SOA). At 
this point we study the requirements and look for services that need to be implemented.

First, we look for the verbs in the requirements. They signify the actions or operations 
that the services need to be performed. Then, we group the logically related operations 
into services.

__1. Can you go through the requirements and list the tasks or operations that various yet 
to be identified services need to perform? Then compare your findings with the answer 
below.

Operations:

• Get price quote and availability (R1)

• Place an order for standard parts (R2)

• Get order details (R3)

• Get order history for a client organization (R4)

• Cancel an order (R5)

Note: In our case, each requirement (or use case) yields one operation. In more complex 
cases, there may be multiple operations identified from a use case.

Next, we need to group the operations in a logical grouping called a service. In REST, 
they key factor that affects grouping is entity. That means, operations that work on any 
given entity (like Order, Customer), should be grouped in a single service.

__2. Can you group the operations based on the entity they work with? Name each group 
as a service accordingly. The answer is below.
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Quote Service:

• Get price quote and availability (R1)

Order Service:

• Place an order for standard parts (R2)

• Get order details (R3)

• Get order history for a client organization (R4)

• Cancel an order (R5)

Part 5 - Design the Service Interface
For SOAP based services, designing service interface involves writing the WSDL 
document and the associated XML schema files. For REST, the process involves 
assigning a URI structure and HTTP method for each identified operation.

In RESTful web service, a URI uniquely points to an entity. The HTTP method 
determines what action needs to be performed on that entity. For example, each order is 
identified by the /order/{orderId} URI. Hence, to get the status of an order, we do a GET 
on that URI. To place an order, we will do a PUT on the /order URI. 

Each operation identified from the business requirement needs to be mapped to a URI 
and HTTP method pair. 

__1. First, let us decide on the URI for each entity. This is a pretty straightforward 
exercise. Note: As a matter convention, plural forms of the entity names are used in URI.

1. Price quote - /quotes.

2. Order - /orders. 

There is no need for URIs for the other entities since we do not directly perform any 
action on them.

These URIs will also form the root URI for the identified services. Individual operations 
within a service may add extra path elements. For example, to get the status of order, the 
URI will be /orders/{orderId}. Some operations may need to add URL parameters. This is 
discussed in more details later.

Now, we are ready to design the service interfaces by assigning a URI/HTTP method pair 
to each operation. Since you might be new to this, the work has been already done for 
you. Go through the design below and try to understand the rationale for various 
decisions taken.
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Service: Quote Service
Root URI: /quotes

Operation URI extension HTTP 
Method

Remarks

Get price quote and 
availability (R1)

POST Normally for such a read-only 
request, we should use GET. 
But, we need to send the quote 
request XML document to the 
service. This will be difficult to 
do for a GET request. That is 
why we choose POST.

Service: Order Service
Root URI: /orders

Operation URI extension HTTP 
Method

Remarks

Place an order for 
standard parts (R2)

PUT Creation of an entity usually 
uses the PUT method. There is 
no need for an URI extension.

Get order details 
(R3)

/{orderId}

E.g.: /orders/1051

GET The order ID is now added to 
the root URI to point to a 
specific order. 

Get order history for 
a client organization 
(R4)

?clientId={clientId}
&status={status}

E.g.: 
/orders?clientId=18
&status=P

GET The client organization ID and 
status are supplied as URL 
parameters. We could consider 
the syntax /order/{clientId}/
{status} since that forms a valid 
identifier for a set of orders. 
But, that will confuse things 
with the /order/{orderId} syntax 
used for other actions.

Cancel an order (R5) /{orderId} DELETE We choose to use the DELETE 
method to signify cancellation. 
This is bit of a tricky decision 
because the entity is not actually 
deleted.
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Design Tip

According to REST methodology, the URI syntax is heavily entity centric, in the sense 
that a URI points to an entity or a set of entities that match certain criteria. Actual 
operations performed on the entity are not reflected in the URI. The HTTP methods go a 
long way to define the actions. But, even that may not be enough.

Consider the situation if we had two separate requirements to cancel and delete an order. 
In that case, the DELETE method will apply to the deletion case. How will we model 
cancellation? In situations like this, where HTTP method is not sufficient to model an 
operation, you need to resort to URL parameters. For example, /orders/{orderId}?
action=cancel can be used.

In summary, HTTP methods are sufficient to model CRUD (create, retrieve, update and 
delete) operations. Anything beyond that, use URL parameters.

Part 6 - Decide on the Data Format
The two prevalent formats in the REST world are JSON and XML. XML is better for 
applications written in Java, .NET and PHP since they all come with XML parsers. JSON 
is the most convenient format to work with from JavaScript. JavaScript includes the 
DOM API. So, in the worst case, you can consume XML from JavaScript.

As stated in our business requirements, the web service will be consumed mainly by 
software applications of the client organizations. This will steer our decision to XML. In 
future, if the need arises, we can support JSON.

Part 7 - Unaddressed Architectural Issues
Our web service has to be secured. Otherwise, anyone can place an order or check the 
status. To keep things simple at this stage, we will not deal with the security 
requirements. We will get to that in a latter lab.

We do not deal with hypermedia controls either. We will learn about hypermedia later.

Part 8 - Review
Designing a RESTful web service requires a series of steps. We saw some of these steps 
in play here:

1. Design the object model.

2. Identify services

3. Design the service interface (URI structure and HTTP method for the operations).

4. Decide on the data format (XML or JSON).
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Lab 3 - Develop a Simple RESTful Service
Over the next few labs, our goal will be to learn the fundamentals of the JAX-RS API. 
We will not get into implementing the services for Acme Inc. just yet.

In this lab, we will develop a very simple RESTful web service. This will let us focus on 
the development process using the OEPE tool and WebLogic server. We will also learn 
about the basic JAX-RS annotations.

The main goal of this lab is to understand how to create a web service project and 
configure it properly for JAX-RS development.

Part 1 - Create the Web Service Project
In OEPE, we can develop a JAX-RS web service inside of a dynamic web project or a 
web service project. The latter is just an extension of a dynamic web project with a few 
extra JAR files added to the compiler's build path. These extra JAR files include the 
Jersey 1.9 JAR files that implement the JAX-RS API. Hence, using the web service 
project will save us a bit of time. If you have a legacy dynamic web project where you 
will like to create a JAX-RS service, all you have to do is add the Jersey JAR files to the 
build path. We will look into that shortly.

__1. Launch OEPE if it is not already running.

__2. Switch to the Java EE perspective.

__3. From the menubar, select File > New > Web Service Project.

__4. Enter AcmeWeb as the project name.

__5. Ensure that Oracle WebLogic Server 12c as the targeted runtime.

__6. Add the project to an enterprise application archive project called AcmeApp
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Tip

You must add the web service project to a EAR. Otherwise, it appears, the JAX-RS 
services don't work. 

__7. Click Finish.

We will briefly review the project.

__8. Right click the newly created AcmeWeb project and select Properties.

__9. Select the Java Build Path properties.

__10. Click the Libraries tab.

__11. Expand WebLogic Systems Library.

__12. Scroll down and locate the Jersey JAR files. If you use a plain dynamic web 
project, you will need to manually add these JAR files to the build path.

__13. Now, select the Project Facets property.

__14. Note that the JAX-RS facet is not selected. This facet plays no role in developing 
JAX-RS services for WebLogic.

__15. Click Cancel to close the dialog.
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Part 2 - Register the REST Handler Servlet
A REST servlet handles all incoming request for RESTful services. In our case, this 
servlet is available from the Jersey implementation. All we have to do is register it in 
web.xml. To save time, this file is given to you. You will simply import it.

__1. Open Windows file explorer.

__2. Go to C:\LabFiles\

__3. Copy web.xml

__4. In Eclipse OEPE, paste the file inside the WebContent > WEB-INF folder of 
AcmeWeb.

__5. Open web.xml and study how the servlet is registered. Specifically, note the servlet 
mapping:

    <servlet-mapping>
        <servlet-name>RestServlet</servlet-name>
        <url-pattern>/svc/*</url-pattern>
    </servlet-mapping>

This means, the URL for every REST request will start with 
http://host:port/AcmeWeb/svc/. You can choose any other path for the REST servlet. But, 
we will stick to the short and sweet "svc".

Part 3 - Create the Resource Class
The Java class that implements a RESTful service is called a resource. We will now 
develop a Java class for a simple service.

__1. Right click AcmeWeb project and select New > Class.

__2. Enter com.acme.services as the package name and SimpleService as the class 
name.

__3. Click Finish.
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__4. Add a member variable that will help us do logging.

Logger logger = Logger.getLogger("SimpleService");

We will now add the testGET() method. It will not have any business logic. Later, we will 
map this method to a GET request.

__5. Add the method as follows.

public String testGET() {
logger.info("Got a GET request");

return "OK";
}

__6. Organize imports (Control+Shift+O) and select java.util.logging.Logger.

__7. Save changes.

Part 4 - Configure the Resource
We will now configure the URI and HTTP method for the service resource and its 
methods. We will use the "/simple" root URI for the service.

__1. Define the URI of the root resource, by adding the @Path annotation above the 
class. This is shown in bold face below.

@Path("/simple")
public class SimpleService {

The testGET() method does not need any path extension. All we have to do is set GET as 
the HTTP method. 

We will also set "text/plain" as the content MIME type of the reply. That is good enough 
for this method. For XML data type, the MIME will be "text/xml".

__2. Set the HTTP method and reply MIME type for the testGET() method sub-resource 
as follows.

@GET
@Produces("text/plain")
public String testGET() {

__3. Organize imports. Select javax.ws.rs.Produces.

__4. Save changes.
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Part 5 - Unit Test
We will now exercise the web service from a browser.

__1. Start the server if it is not running.

__2. Right click the server and select Add and Remove.

__3. Add the AcmeApp project to the server.

__4. Click Finish.

__5. Make sure the server is synchronized.

__6. Open a web browser and enter the URL: 

http://localhost:7001/AcmeWeb/svc/simple/

__7. You should see OK in the browser.

__8. The Console view in Eclipse will show the log output.

This proves that our project has been setup correctly and JAX-RS is working fine.

Part 6 - Use Path Extension for Sub-resource
A sub-resource – Java method – can be mapped to an URI extension path. Any HTTP 
request for that path will be handled by that method. We will now create a method that 
will respond to the /simple/mypath URI.

__1. First, add this method.

public String testGETWithPath() {
logger.info("Got a GET request with path extension.");
return "OK";

}
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__2. Annotate the method as follows.

@GET
@Produces("text/plain")
@Path("/mypath")
public String testGETWithPath() {

__3. Save changes.

Part 7 - Unit Test
__1. Right click the server and select Publish.

__2. In a web browser, enter the URL: 

http://localhost:7001/AcmeWeb/svc/simple/mypath

__3. Make sure that the Console shows the log output.

__4. Open a new browser and re-test the testGET method for regression using the URL: 

http://localhost:7001/AcmeWeb/svc/simple/

__5. Close all open files.

__6. Close all browsers.

Part 8 - Review
In this lab, we created and configured a web service project. We created a very simple 
JAX-RS web service. At this point, you should know how to configure the URI of the 
root resource – the Java class - using the @Path annotation. Also, we configured the 
HTTP method of a sub-resource – a method – using the @GET annotation.
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	Lab 1 -  Configure the Development Environment
	Part 1 -  Oracle WebLogic server Setup
	WebLogic Server is already extracted into C:\Software\WebLogic folder.
	In this part we will setup necessary Environment variables and run installation configuration script.
	Follow the instructions to set up JAVA_HOME, MW_HOME and JAVA_VENDOR environment variable
	JAVA_HOME=C:\Software\Java
	MW_HOME=C:\Software\WebLogic
	JAVA_VENDOR=Oracle
	__1.  Right click on the My Computer icon on your computer and select properties. 
	__2.  Click the Advanced Tab. 
	__3.  Click the Environment Variables button. 
	__4.  From the System Variables list, select Path and click Edit.
	__5.  At the beginning of the line enter the following:
	__6.  Click OK.
	__7.  Under System Variables, click New. 
	__8.  Enter the variable name as JAVA_HOME
	__9.  Enter the variable value as the install path for the Development Kit. 
	__10.  Click OK. 
	__11.  Repeat these steps for MW_HOME and JAVA_VENDOR variables.
	
	__12.  Click OK until you close all windows.
	__13.  Open a command prompt.
	__14.  Change the directory to C:\Software\WebLogic
	__15.  Enter configure.cmd and hit Enter.
	It takes few minutes to complete. 
	__16.  Close the command prompt window.
	__17.  Restart the machine.
	__1.  Open a Windows command prompt.  You can do this by selecting 'Start -> Run', entering 'cmd', and then pressing the OK button.
	__2.  Enter the following command:
	__3.  Enter the following command:
	__4.  Close the command prompt window. 

	Part 2 -  Configure a server in OEPE
	__1.  Start OEPE by launching C:\Software\OEPE\eclipse.exe
	__2.  Set the Workspace to C:\workspace
	__3.  Click OK.
	__4.  WTP is displaying the Welcome screen (or view).  Close the view by clicking the x in its tab.  
	__5.  From the menu, select Window > Open Perspective > Java EE.
	__6.  Select Windows | Preferences.
	__7.  Expand Server | Runtime Environments.
	__8.  Click Add...
	__9.  Expand  Oracle and select Oracle Weblogic Server 12c(12.1.1)
	__10.  Click Next.
	__11.  For Weblogic home, enter C:\Software\WebLogic\wlserver or browse to find the location. Similarly enter C:\Software\Java for Java home.
	You will see as shown below:
	__12.  Click Finish.
	__13.  Click OK.
	__14.  We need to create domain and configure OEPE to point at the domain.  Locate the Server view. To do this, click the Servers tab in the bottom area of OEPE.
	__15.  Right click anywhere in the area and select New | Server.
	__16.  Select Oracle WebLogic Server 12c.
	__17.  Click Next.
	__18.  Next to Domain directory, click the create icon and then select Create Domain.
	__19.  Enter LabDomain as the name. 
	__20.  Check specify password and enter w1sadmin as password where the password contains number one not L. 
	__21.  Don’t select any extensions, because we will not be using any of the advanced features like WS-Addressing.
	__22.  Click Finish.
	__23.  After some seconds the below screen will open, make sure Disable Automatic Publishing to server is checked.
	__24.  Click Finish.

	Part 3 -  Working with the Server
	__1.  Let us start things off by starting the server.  In the Servers view, right click on the server and select Start.
	__2.  Examine the Console window by clicking the Console tab. 
	__3.  Let us try stopping the server.  Go back to the Servers view. 
	__4.  Right click on the server and select Stop.

	Part 4 -  Review

	Lab 2 -  Designing a RESTful Service
	Part 1 -  The Business Requirements
	Part 2 -  Define Project Scope
	Part 3 -  Designing the Object Model
	__1.  Can you go through the business requirements and identify the entities? 
	__2.  Now that you have identified the entities, can you list the attributes or fields for each entity? Once again, the answer is below. But do your best to do the design yourself.

	Part 4 -  Identify the Service
	__1.  Can you go through the requirements and list the tasks or operations that various yet to be identified services need to perform? Then compare your findings with the answer below.
	__2.  Can you group the operations based on the entity they work with? Name each group as a service accordingly. The answer is below.

	Part 5 -  Design the Service Interface
	__1.  First, let us decide on the URI for each entity. This is a pretty straightforward exercise. Note: As a matter convention, plural forms of the entity names are used in URI.

	Part 6 -  Decide on the Data Format
	Part 7 -  Unaddressed Architectural Issues
	Part 8 -  Review

	Lab 3 -  Develop a Simple RESTful Service
	Part 1 -  Create the Web Service Project
	__1.  Launch OEPE if it is not already running.
	__2.  Switch to the Java EE perspective.
	__3.  From the menubar, select File > New > Web Service Project.
	__4.  Enter AcmeWeb as the project name.
	__5.  Ensure that Oracle WebLogic Server 12c as the targeted runtime.
	__6.  Add the project to an enterprise application archive project called AcmeApp
	__7.  Click Finish.
	__8.  Right click the newly created AcmeWeb project and select Properties.
	__9.  Select the Java Build Path properties.
	__10.  Click the Libraries tab.
	__11.  Expand WebLogic Systems Library.
	__12.  Scroll down and locate the Jersey JAR files. If you use a plain dynamic web project, you will need to manually add these JAR files to the build path.
	__13.  Now, select the Project Facets property.
	__14.  Note that the JAX-RS facet is not selected. This facet plays no role in developing JAX-RS services for WebLogic.
	__15.  Click Cancel to close the dialog.

	Part 2 -  Register the REST Handler Servlet
	__1.  Open Windows file explorer.
	__2.  Go to C:\LabFiles\
	__3.  Copy web.xml
	__4.  In Eclipse OEPE, paste the file inside the WebContent > WEB-INF folder of AcmeWeb.
	__5.  Open web.xml and study how the servlet is registered. Specifically, note the servlet mapping:

	Part 3 -  Create the Resource Class
	__1.  Right click AcmeWeb project and select New > Class.
	__2.  Enter com.acme.services as the package name and SimpleService as the class name.
	__3.  Click Finish.
	__4.  Add a member variable that will help us do logging.
	__5.  Add the method as follows.
	__6.  Organize imports (Control+Shift+O) and select java.util.logging.Logger.
	__7.  Save changes.

	Part 4 -  Configure the Resource
	__1.  Define the URI of the root resource, by adding the @Path annotation above the class. This is shown in bold face below.
	__2.  Set the HTTP method and reply MIME type for the testGET() method sub-resource as follows.
	__3.  Organize imports. Select javax.ws.rs.Produces.
	__4.  Save changes.

	Part 5 -  Unit Test
	__1.  Start the server if it is not running.
	__2.  Right click the server and select Add and Remove.
	__3.  Add the AcmeApp project to the server.
	__4.  Click Finish.
	__5.  Make sure the server is synchronized.
	__6.  Open a web browser and enter the URL: 
	__7.  You should see OK in the browser.
	__8.  The Console view in Eclipse will show the log output.

	Part 6 -  Use Path Extension for Sub-resource
	__1.  First, add this method.
	__2.  Annotate the method as follows.
	__3.  Save changes.

	Part 7 -  Unit Test
	__1.  Right click the server and select Publish.
	__2.  In a web browser, enter the URL: 
	__3.  Make sure that the Console shows the log output.
	__4.  Open a new browser and re-test the testGET method for regression using the URL: 
	__5.  Close all open files.
	__6.  Close all browsers.

	Part 8 -  Review

	Lab 4 -  Extracting Information from a HTTP Request
	Part 1 -  Get Root Resource Path Parameters
	__1.  Open SimpleService.java
	__2.  Change the @Path annotation for the class and add a parameter there.
	__3.  Add a member variable as follows.
	__4.  Annotate the member variable to save the value of the myRootPathData parameter.
	__5.  Change the log statement of the testGET() method as follows.
	__6.  Make a similar change to the testGETWithPath() method.
	__7.  Organize imports.
	__8.  Save changes.

	Part 2 -  Unit Test
	__1.  Publish the server.
	__2.  First, test the testGET() method by entering the URL: 
	__3.  The log output will like this:
	__4.  Now, test the testGETWithPath() method using the URL: 
	__5.  The log output will be:

	Part 3 -  Get Sub-resource Path Parameters
	__1.  Add a basic method as follows.
	__2.  Annotate method with path and method.
	__3.  Now, extract the path parameters and save them in the two input argument variables of the method.
	__4.  Save changes.
	__5.  Test the method by entering the URL: 

	Part 4 -  Extract Query Parameters
	__1.  Add the giveRaise() method as shown below.
	__2.  Organize imports.
	__3.  Save changes.
	__4.  Test the change by entering the URL: 
	__5.  Make sure that the Console shows:

	Part 5 -  Extracting Form Post Data
	__1.  Add this method.
	__2.  Organize imports. Select  java.util.List.
	__3.  Save changes.

	Part 6 -  Unit Test
	__1.  We will import the form HTML page. Copy C:\LabFiles\post.html and paste it inside the WebContent folder of AcmeWeb project.
	__2.  In the Servers view, right click the server and select Publish.
	__3.  Open a browser and enter the URL: 
	__4.  Fill out the form and submit it. 
	__5.  Make sure that the console log shows the input values correctly.
	__6.  Close all open files.
	__7.  Close all open browsers.

	Part 7 -  Review

	Lab 5 -  Add Support for XML Format
	Part 1 -  Create the Entity Classes
	__1.  In the AcmeWeb project, create a package called com.acme.services.entities
	__2.  Within that package, create a Java class called QuoteRequest
	__3.  In the QuoteRequest class, add these member variables. Feel free to refer back to the object model to make sure we are doing this correctly.
	__4.  Generate getters and setters for the variables. To do this from the menu, select Source >  Generate Getters and Setters. Then click Select All and click OK.
	__5.  Add the @XmlRootElement JAXB annotation to the class as shown in boldface below.
	__6.  Organize imports.
	__7.  Save changes.
	__8.  Open a file browser and go to C:\LabFiles\entities.
	__9.  Copy all the files and then paste them into the com.acme.services.entities package.
	__10.  Open each entity class file and review them. Specifically, look at the Order class. Working with list of child objects can be tricky in JAXB. Look at how we are dealing with line items:

	Part 2 -  Generate the XML Schema
	__1.  Open a command window.
	__2.  Change directory to C:\workspace\AcmeWeb\src
	__3.  Run this command.
	__4.  Back in OEPE refresh the project.
	__5.  Open the generated schema file schema1.xsd and study it.

	Part 3 -  Create the Quote Service Class
	__1.  In the com.acme.services package, create a class called QuoteService
	__2.  Set the root URI of the service as shown in boldface below.
	__3.  Add a member variable for logging.
	__4.  Add the getQuote() method as shown below. The business logic is very simple. We hard code the price and availability.
	__5.  Annotate the method as shown below.
	__6.  Organize imports. Select javax.ws.rs.Produces and java.util.logging.Logger.
	__7.  Save changes.

	Part 4 -  Better Content Handling
	__1.  Add the @Consumes annotation to getQuote as follows in bold.
	__2.  Similarly, change the @Produces annotation to support both MIME types for XML.
	__3.  Organize imports. Select javax.ws.rs.core.MediaType.
	__4.  Save changes.

	Part 5 -  Unit Testing
	__1.  Start the server if it is not running.
	__2.  Publish the server.
	__3.  Open a command window and go to C:\LabFiles.
	__4.  Run the command:
	__5.  In the URL text box, enter: 
	__6.  Select POST method.
	__7.  Click the Body tab.
	__8.  Click the  icon.
	__9.  From the drop-down select the text/xml content type.
	__10.  Click OK.
	__11.  Click the  icon to open the file.
	__12.  Select C:\LabFiles\quote_request.xml and open it.
	__13.  Study the request document briefly.
	__14.  We are now ready start testing. Click the  icon next to the URL.
	__15.  Make sure that the HTTP reply status code is 200.
	__16.  Click the Body tab for the response.
	__17.  Right click the response body text and select Indent > Indent XML.
	__18.  Study the response document.
	__19.  Back in OEPE close all open files.
	__20.  Do not close the REST Client.

	Part 6 -  Review

	Lab 6 -  Add Support for JSON
	Part 1 -  Do the Design First
	Part 2 -  Add the JSON Method
	__1.  Open QuoteService class.
	__2.  First, add the shell of the method.
	__3.  Then, annotate the method and the input parameters as shown in boldface below.
	__4.  Now, fill in the body of the method. It basically calls the getQuote() method to get the job done.
	__5.  Organize imports.
	__6.  Save changes.
	__7.  Publish the server.

	Part 3 -  Understanding Content Negotiation
	Part 4 -  Test
	__1.  Launch the REST client tool if it is not already running.
	__2.  Set the URL to: 
	__3.  Choose POST method.
	__4.  Set the body using the XML code in C:\LabFiles\quote_request.xml and set content type to application/xml; chartset=UTF-8.
	__5.  Click the Headers tab.
	__6.  Enter Accept as Key and text/xml as Value.
	__7.  Click the + icon to add the header.
	__8.  Run the test by clicking .
	__9.  Right click the response body area and select Indent > Indent XML.
	__10.  Verify that the reply body contains the response.
	__11.  Add this to the end of the URL:
	__12.  Set the method to GET.
	__13.  Select the Accept header, then right click on it and select Delete.
	__14.  Enter Accept as Key and application/json as Value, then click the + icon to add the header.
	__15.  Run the test.
	__16.  Right click the response body area and select Indent > Indent JSON.
	__17.  Verify the result.
	__18.  Back in OEPE close all open files.
	__19.  In OEPE close all open files.
	__20.  Do not close the REST Client.

	Part 5 -  Review

	Lab 7 -  Build the Order Web Service
	Part 1 -  Create the Resource Class
	__1.  In the com.acme.services package, create a class called OrderService
	__2.  Annotate the class to set the path as follows.
	__3.  Add a member variable for logging.
	__4.  Organizer imports. Select java.util.logging.Logger.
	__5.  Save changes.

	Part 2 -  Implement Order Placement
	__1.  Write the shell of the method as follows. We will not deal with the returned URL just yet.
	__2.  Annotate the method with @PUT and @Consumes.
	__3.  Organize imports. Select these classes:
	javax.ws.rs.core.MediaType
	com.acme.services.entities.Order
	__4.  Save changes.
	__5.  Import C:\LabFiles\OrderDAO.java into the com.acme.services package.
	__6.  Open the class and briefly study it. The code should be very simple.
	__7.  In the placeOrder method of the OrderService class, use OrderDAO as shown in boldface below.
	__8.  Organize imports. Select these classes:
	java.util.logging.Level
	__9.  Save changes.

	Part 3 -  Implement Retrieval of Order
	__1.  First write the method shell along with the required annotations.
	__2.  Next, fill in the method body.
	__3.  Organize imports. Select these classes:
	__4.  Save changes.

	Part 4 -  Construct Entity URL
	__1.  First, add a member variable to the class as follows.
	__2.  In the placeOrder() method, below the line:
	__3.  Add this line below:
	__4.  Next, add the following line. This plugs in the actual value of the order ID to the path and returns a java.net.URI object.
	__5.  Finally, add this line. We will explain this shortly.
	__6.  Organize imports. Choose these classes:
	__7.  Save the file and make sure you don't have compilation errors.
	__8.  Go to the 'Servers' view and publish the server by right clicking the server and selecting 'Publish'.

	Part 5 -  Test
	__1.  From the REST client's menubar, select File > Open Request (Control+O).
	__2.  Open C:\LabFiles\order_create.rcq
	__3.  Review these items about the request:
	__4.  Click the  button to send the request.
	__5.  Verify that:
	__6.  In the Eclipse Console, verify the log output from the OrderDAO class.
	__7.  In the REST client, open the request file C:\LabFiles\order_retrieve.rcq.
	__8.  Inspect these items about the request:
	__9.  Send the request.
	__10.  Verify that the reply body has the correct order information.

	Part 6 -  Enable Error Handling
	__1.  In the placeOrder() method of OrderService class, add this line shown in bold face.
	__2.  Comment out the following unreachable line:
	__3.  Organize imports. 
	__4.  In the getOrder() method, above the line:
	__5.  Organize imports. Organize imports. Choose these classes:
	javax.ws.rs.core.Response.Status
	__6.  Save changes.

	Part 7 -  Test
	__1.  In the REST client, the order retrieval request file should be open already. Just run the test.
	__2.  Verify that the status code is 404.
	__3.  Open the request file C:\LabFiles\order_create.rcq.
	__4.  In the Body tab, delete all the <item> elements.
	__5.  Run the test.
	__6.  Verify that status code 500 is returned.
	__7.  Do regression tests to make sure that success conditions are working fine.
	__8.  In OEPE close all open files.
	__9.  Do not close the REST Client.

	Part 8 -  Review

	Lab 8 -  Developing a JAX-RS Client
	Part 1 -  Client Design Considerations
	Part 2 -  Import the Client Application
	__1.  From the Eclipse menubar, select File > Import.
	__2.  Select General > Existing Projects into Workspace.
	__3.  Click Next.
	__4.  Select the SimpleClient project from C:\LabFiles\SimpleClientStarter.zip.
	__5.  Click Finish.

	Part 3 -  Build the Service Proxy Layer
	__1.  From the AcmeWeb project, copy the com.acme.services.entities package.
	__2.  In the SimpleClient project, paste it in the src folder.
	__3.  In the SimpleClient project, create a package called com.acme.services.proxy
	__4.  In that package, create a class called QuoteProxy
	__5.  In the QuoteProxy class, add a variable to store the service root URL.
	__6.  Add the shell of a method that will invoke the quote web service.
	__7.  In the getQuote() method, add this line to instantiate a com.sun.jersey.api.client.Client object.
	__8.  Next, create a WebResource object that points to the root web service resource.
	__9.  Add this line to send a QuoteRequest XML using a POST request.
	__10.  Finally, add this line to return the quote response.
	__11.  Organize imports and select this class:
	__12.  Save changes.

	Part 4 -  Build the Presentation Layer
	__1.  From the WebContent folder, open index.jsp and study the form.
	__2.  Open result.jsp and study how the QuoteResponse object properties are shown.
	__3.  From the com.webage.servlet package, open QuoteController.java.
	__4.  Locate the doPost method.
	__5.  Below the line:
	__6.  Below the line: 
	__7.  Below the line:
	__8.  Organize imports.
	__9.  Save changes.

	Part 5 -  Test
	__1.  Start the server if it is not running.
	__2.  Deploy SimpleClient project to the server.
	__3.  Open a web browser and enter the URL: 
	__4.  Enter some values and click Get Quote.
	__5.  Verify the result.
	__6.  Close the browser.
	__7.  Close all open files.

	Part 6 -  Review

	Lab 9 -  Introduction to AJAX
	Part 1 -  Create a Project
	__1.  From the menu, select File->New->Project.
	__2.  Expand General and select Project. Click Next.
	__3.  Enter the following values.
	__4.  Click Finish to create the project.

	Part 2 -  Import the XHTML Template Page
	__1.  Open a file explorer. 
	__2.  Change directory to C:\LabFiles. 
	__3.  Copy the template.html file (Control+C). 
	__4.  Switch back to Eclipse. Select the SimpleAjax project and paste the file (Control+V).
	__5.  Now, we will study the XHTML syntax of this file. Double click template.html to open it in the editor. Notice the following aspects:
	__6.  Close the file.

	Part 3 -  Create a Simple Web Page
	__1.  In Eclipse, select template.html and copy it (Control+C).
	__2.  Paste the file by hitting Control+V. System will ask you to enter a name for the new file.
	__3.  Enter ajax_intro.html as the file name. Click OK.

	Part 4 -  Create the Button
	__1.  Double click ajax_intro.html to open it.
	__2.  Within the <body> tag, enter the following lines:
	__3.  Save the file (Control+S).
	__4.  Now, we will test the look and feel of the page. Open a browser window. Enter the URL: 
	http://localhost/labs/ajax_intro.html
	__5.  Make sure that the page looks like this.

	Part 5 -  Add JavaScript
	__1.  Back in the ajax_intro.html, locate the <script> element.
	__2.  Below the line:
	__3.  Below the end of the createRequestSimple function, add a global variable to store a reference to the request object.
	__4.  Below that, add these two functions.
	__5.  Save the file.

	Part 6 -  Create the Response File
	__1.  Right click the SimpleAjax project and select New->File. 
	__2.  Enter response.txt as the file name. Click Finish.
	__3.  Enter the following text in the newly created file.
	__4.  Save this file. Note: The file has only fragments of a HTML page. For a typical AJAX HTTP request, the reply is made up of only small amounts of HTML fragments (and not a whole HTML page). This is a key distinction of a AJAX based application.

	Part 7 -  Test
	__1.  Make sure that all files are saved in Eclipse.
	__2.  Open a browser and enter the URL: http://localhost/labs/ajax_intro.html. If a browser is already open with this URL, refresh it to get the latest version of the page. If you are using IE, your setting may cause the page to be cached for the duration of the session. In that case, you will need to close the browser and open a new window.
	__3.  Click the Test It! button. 
	__4.  Back in Eclipse, change the contents of the response.txt file in some way. Save it. In the browser, click the Test It! button again. Make sure that the updated contents of response.txt is shown. (Once again, your IE settings may cache the reply for the response.txt URL. Either use FireFox or restart IE to make sure that the updated version of response.txt is being shown in the browser).

	Part 8 -  Add Logging to JavaScript
	Part 9 -  Install log4 javascript
	__1.  Open a file explorer.
	__2.  Change directory to C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\
	__3.  There, create a new folder called log4javascript
	__4.  Change directory to C:\LabFiles. 
	__5.  Copy the file log4javascript.js. 
	__6.  Paste it inside C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\log4javascript

	Part 10 -  Import the log4javascript Library to ajax_intro.html
	__1.  Open ajax_intro.html in Eclipse.
	__2.  Above the following line:

	Part 11 -  Add Logging Code
	__1.  Above the line:
	__2.  Now that we have obtained the Logger object, we can start using it. In this lab, we will add a few trace logs to view how the AJAX request life cycle progresses. Add logging to the startTest() and showReply() methods as shown in bold face below.
	__3.  Save changes.

	Part 12 -  Test
	__1.  In a browser, enter the URL: http://localhost/labs/ajax_intro.html. Refresh the page, if it is already open.
	__2.  Click the Test It! button. The application itself will behave as before. However, a log console window will open up. It will look like this.
	__3.  Close all browsers.
	__4.  Back in Eclipse close all open files.

	Part 13 -  Review

	Lab 10 -  Making POST Requests
	Part 1 -  Create a Web Project
	__1.  From the menu select File->New->Project.
	__2.  Expand Web and select Dynamic Web Project. 
	__3.  Click Next.
	__4.  As the Project name, enter AjaxWeb
	__5.  Check Add project to an EAR and enter EAR project name as AjaxWebEAR
	__6.  Click Finish to create the project. 
	__7.  Right click AjaxWeb and select  Java EE Tools > Generate Deployment Descriptor Stub.
	__8.  This will crate web.xml

	Part 2 -  Create the Login Servlet
	__1.  Right click the newly created project AjaxWeb and select New->Servlet.
	__2.  Enter these values:
	__3.  Click Finish to create the Servlet.
	__4.  System will open LoginServlet.java in the editor. For the doPost() method, enter the following code.
	__5.  Press Control+Shift+O to organize imports. 
	__6.  Save changes. You should not have any compilation error at this point.

	Part 3 -  Import the log4javacsript Library
	__1.  Open a file explorer and go to C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\
	__2.  Copy the log4javascript folder.
	__3.  Paste the folder into the AjaxWeb\WebContent folder in Eclipse.

	Part 4 -  Create the Login Form Page
	__1.  To speed up this lab, a basic page is given to you. Copy the file C:\LabFiles\login.html and paste it in the AjaxWeb\WebContent folder inside of Eclipse.
	__2.  Similarly, import the home.html file from C:\LabFiles folder. This page will be shown after the user successfully logs in.
	__3.  Open login.html in Eclipse. Notice these items:
	__4.  In the script section, add a global variable for the request.
	__5.  Next, write the sendAjaxRequest method. Unlike the previous labs, now, we will make a POST request.
	__6.  Finally, we will add the showResult function.
	__7.  Save changes.

	Part 5 -  Test
	__1.  Right click the Server and select Add and Remove...
	__2.  Add AjaxWebEAR and press Finish.
	__3.  Start server if not started  from the Servers view.
	__4.  Open a web browser and enter the URL: 
	__5.  First, we will simulate a few failure conditions. Enter billy as the user ID and click Login. Make sure that you see the error message as shown below.
	__6.  Now, enter bob as the user ID and pass for password. Click Login. System will show an error message about the invalid password.
	__7.  Now, enter bob as user ID and cat as password. Click Login. System should show the home.html page.
	__8.  Close all open browsers.
	__9.  Close all open files.

	Part 6 -  Review

	Lab 11 -  Basic DOM API
	Part 1 -  Create the XHTML File
	__1.  In the SimpleAjax project copy template.html and paste it as find_test.html
	__2.  Open the newly created file.
	__3.  Within the <body> tag, add the following XHTML markup.
	__4.  Save changes. 
	__5.  Open a FireFox window (not IE). Test the page by opening this URL in a browser:
	__6.  It should look like this.

	Part 2 -  Add JavaScript
	__1.  Below the line:
	__2.  Save the file (Control+S).

	Part 3 -  Test
	__1.  Refresh the FireFox browser where the page was already opened.
	__2.  Enter p1 in the text box. Click Find by ID. The paragraph with text "This is para1" should now have a yellow background.
	__3.  Enter error in the text box. Click Find by Name. The two <div> elements with name "error" will now have red background.
	__4.  To make things interesting, enter id_or_name in the text box. Click Find by ID. Now, the text box itself will have yellow background.
	__5.  Now, launch IE. Enter the URL: http://localhost/labs/find_test.html 
	__6.  Enter p1 in the text box. Test for the Find by ID button. It should work fine.
	__7.  Test for the Find by Name button (by entering error in the text box). It will fail to locate any element by name "error". 
	__8.  Close all open browsers.
	__9.  Close all open files.

	Part 4 -  Review

	Lab 12 -  AJAX Client using XML
	Part 1 -  Import the AJAX Utility Library
	__1.  Open a Windows file browser and go to C:\LabFiles.
	__2.  Copy rest_utils.js and paste it in the WebContent folder of SimpleClient project.
	__3.  Open index.jsp.
	__4.  Within the <head> element, add a script tag to import rest_utils.js.
	__5.  Save changes.

	Part 2 -  Change the GUI
	__1.  In index.jsp, below the line:
	__2.  Below the </form> line, add these lines. This is where the response will be shown.
	__3.  Save changes.

	Part 3 -  Send a Quote Request
	__1.  Within the <head> element of index.jsp, add a script tag as follows.
	__2.  Within the script tag, add the shell of the sendRequest() method as follows:
	__3.  Within the sendRequest() method, add this line to create a new DOM document with "quote_request" as the root element.
	__4.  Add this line to append a child element called "clientId". The value will be hard coded to "C01029".
	__5.  Open rest_utils.js and study how the addElement() function works.
	__6.  Back in index.jsp, add this line to sendRequest().
	__7.  Similarly, add these lines to sendRequest().
	__8.  Add this line:
	__9.  Study the invokeByXMLPost() function in rest_utils.js.
	__10.  Finally, add this line to sendRequest(). This will prevent the form from getting submitted.
	__11.  Save changes.

	Part 4 -  Show the Response from the Web Service
	__1.  In index.jsp, add the showResult() function as follows.
	__2.  First, do error handling.
	__3.  Add this line to obtain the DOM reply document.
	__4.  Add these lines to display the contents of the <productAvailable> element in the <span> with ID "available".
	__5.  Similarly, add these lines to show more result data.
	__6.  Save changes.

	Part 5 -  Test
	__1.  Publish the server.
	__2.  Open Chrome or FireFox and enter the URL: 
	__3.  Enter some data and click Get Quote AJAX.
	__4.  Verify that the result is displayed correctly.
	__5.  Do a regression test by clicking the old Get Quote button and make sure that the Jersey client API based approach is still working.
	__6.  Close all open browsers.
	__7.  Close all open files.

	Part 6 -  Review

	Lab 13 -  AJAX Client Using JSON
	Part 1 -  Send the Request
	__1.  Open index.jsp in SimpleClient project.
	__2.  Delete the body of sendRequest(), except the last line, so it looks like this.
	__3.  Add this line to construct the URL.
	__4.  Use the invokeByGet() utility method to send the request.
	__5.  Study the invokeByGet() method in rest_utils.js.
	__6.  Save changes.

	Part 2 -  Process the Response
	__1.  In the showResult() function, comment out this line:
	__2.  Below that line, add this line to convert the JSON response string into an object.
	__3.  Change the way the result data is displayed. This is shown in bold face below.
	__4.  Save changes.

	Part 3 -  Test
	__1.  Publish the server.
	__2.  Open Chrome or FireFox and enter the URL: 
	__3.  Enter some data and click Get Quote.
	__4.  The application will behave same as before and you should see the response data.
	__5.  Close all open browsers.
	__6.  Close all open files.

	Part 4 -  Review

	Lab 14 -  Securing RESTful Services
	Part 1 -  Secure the Quote Service
	__1.  In the AcmeWeb project expand com.acme.services package.
	__2.  Open QuoteService.java.
	__3.  Add the following annotation in bold to the class.
	__4.  Organize imports. Select  javax.annotation.security.RolesAllowed.
	__5.  Save changes.
	__6.  Open web.xml from WebContent/WEB-INF folder.
	__7.  Add these lines shown in bold face.
	__8.  Save changes.

	Part 2 -  Test
	__1.  Restart the server. This is needed since we changed the web.xml file.
	__2.  Open a browser and enter the URL: 
	__3.  Enter some data and then click Get Quote.
	__4.  The browser will show an error, scroll to the right in the browser. 
	__5.  The client will fail with 403 error code. This proves that the service is now secured.
	__6.  Switch to the Console in Eclipse.
	__7.  You will see the error.

	Part 3 -  Configure Security at the Server
	__1.  Open a web browser and enter the URL: 
	__2.  Login using user weblogic and password w1sadmin
	__3.  Click Security Realm on the left.
	__4.  Click myrealm.
	__5.  Click Users and Groups tab.
	__6.  Click Groups tab.
	__7.  Click New.
	__8.  Enter ClientCompanyUsers as the group's name.
	__9.  Click OK.
	__10.  Click the Users tab.
	__11.  Click New.
	__12.  Enter bob as name and pa55word as the password.
	__13.  Click OK.
	__14.  Click the newly created user – bob.
	__15.  Click the Groups tab.
	__16.  Add the user to the ClientCompanyUsers group.
	__17.  Click Save.
	__18.  Click Security Realm on the left.
	__19.  Click myrealm.
	__20.  Click Roles and Policies tab.
	__21.  Expand Global Roles and click Roles.
	__22.  Click New.
	__23.  Enter Customer as the name.
	__24.  Click OK.
	__25.  Click the Customer role.
	__26.  Under Role Conditions click the Add Conditions button.
	__27.  Make sure that Group is selected in Predicate List.
	__28.  Click Next.
	__29.  Carefully enter ClientCompanyUsers in the group name text box.
	__30.  Click Add.
	__31.  Click Finish.
	__32.  Click Save.
	__33.  Close the browser.

	Part 4 -  Modify the Client Application
	__1.  In the SimpleClient project, open QuoteProxy class.
	__2.  Below the line:
	__3.  Organize imports.
	__4.  Save changes.

	Part 5 -  Test
	__1.  Publish the WebLogic server.
	__2.  Open a browser and enter the URL: 
	__3.  Enter some data and then click Get Quote. 
	__4.  Verify that the client is showing the response correctly.
	__5.  In the QuoteProxy class, change the password to an invalid one and save changes.
	__6.  Publish the WebLogic server.
	__7.  In the browser hit the back button to go again to the Quote page.
	__8.  Submit again the form and click Get Quote.
	__9.  Scroll to the right of the error message. Verify that status 401 is returned by the service.
	__10.  Change the credentials as follows.
	__11.  Save changes.
	__12.  Publish the WebLogic server.
	__13.  In the browser hit the back button to go again to the Quote page.
	__14.  Submit the form.
	__15.  Verify that server returned 403 error code.
	__16.  Change the code back to valid credentials and save.
	__17.  Publish the WebLogic server.
	__18.  In the browser hit the back button to go again to the Quote page.
	__19.  Submit the form and verify its working fine.

	Part 6 -  Enable Audit Logging
	__1.  In the AcmeWeb project, open OrderService.java.
	__2.  Configure the valid role for the service as shown in bold face below.
	__3.  Add a member variable to the class as follows.
	__4.  In the placeOrder() method, below the line:
	__5.  Organize import and select these classes:
	__6.  Save changes.
	__7.  Publish the WebLogic server.

	Part 7 -  Test
	__1.  Launch the REST test client if it is not already running.
	__2.  Select File > Open Request from the menubar.
	__3.  Open C:\LabFiles\order_create.rcq
	__4.  Click the  button to send the request.
	__5.  Make sure that a status code 403 is returned.
	__6.  Click the Auth tab.
	__7.  Enter these values:
	__8.  Run the test again.
	__9.  Verify that status code 201 is returned.
	__10.  Check Eclipse console for the audit log. It will look like this:
	__11.  From the menu, select File > Save Request.
	__12.  If this windows appears click OK.
	__13.  Make sure order_create.rcq is selected and click Save. 
	__14.  Then click Yes to overwrite the file.
	__15.  Open the request file C:\LabFiles\order_retrieve.rcq
	__16.  Click the Auth tab and enter these values:
	__17.  From the menu, select File > Save Request.
	__18.  If you see the UI parameters change click OK.
	__19.  Make sure order_retrieve.rcq is selected and click Save. 
	__20.  Then click Yes to overwrite the file.
	__21.  Close all open browsers.
	__22.  Close all open files.
	__23.  Do not close the REST Client.

	Part 8 -  Review

	Lab 15 -  AJAX Client Security
	Part 1 -  The Trouble With XMLHttpRequest API
	Part 2 -  Change the Client Code
	__1.  In the SimpleClient project, open rest_utils.js.
	__2.  Change the method signature of invokeByGet as follows.
	__3.  At the very beginning of  invokeByGet(), add these lines.
	__4.  Below the line:
	__5.  Save changes.

	Part 3 -  Change the GUI
	__1.  Open index.jsp.
	__2.  Within the form, add the fields for user name and password.
	__3.  In the sendRequest() function, supply the credentials.
	__4.  Save changes.

	Part 4 -  Test
	__1.  Close any open browser. Otherwise caching can influence our test.
	__2.  Open a browser and enter the URL: 
	__3.  Enter bob as user name and pa55word as the password.
	__4.  Enter other values.
	__5.  Click Get Quote AJAX.
	__6.  Verify that the result is shown.
	__7.  To test for failure, close the browser and open it again. This time, test using invalid credentials. 
	__8.  A dialog will open asking for credentials, click Cancel.
	__9.  Click OK in the request failed window.
	__10.  Close all open browsers.
	__11.  Close all open files.

	Part 5 -  Review

	Lab 16 -  Complete the Order Service
	Part 1 -  Implement Order Cancellation
	__1.  In the AcmeWeb project, open OrderService.java
	__2.  Add this method.
	__3.  Add these lines to the cancelOrder() method.
	__4.  Organize imports.
	__5.  Save changes.

	Part 2 -  Test
	__1.  Run the REST test client.
	__2.  From the client, open the request file C:\LabFiles\order_create.rcq
	__3.  Select the Auth tab and make sure credentials are configured.
	__4.  Run the test. You should get a status code of 201. 
	__5.  Open the request file C:\LabFiles\order_retrieve.rcq
	__6.  Select the Auth tab and make sure credentials are configured.
	__7.  Run the test. You should get a status code of 200.
	__8.  From the Method tab, select DELETE.
	__9.  Run the test. 
	__10.  Since the reply body is empty, you should see HTTP status code 204. This is equivalent to status 200 and indicates success.
	__11.  In the Method tab, select GET method.
	__12.  Run the test.
	__13.  Verify that 404 is returned.

	Part 3 -  Implement Order History
	__1.  From the com.acme.services.entities package, open OrderList.java and inspect it.
	__2.  In the OrderService class, add the method shell as follows.
	__3.  Add the method body as follows.
	__4.  Organize imports.
	__5.  Save changes.

	Part 4 -  Test
	__1.  From the REST test client, open the request file C:\LabFile\order_create.rcq
	__2.  From the Body tab, note the client ID – C001.
	__3.  Run the test to create an order.
	__4.  From the Body tab, change the part number and quantity ordered and place a few more orders.
	__5.  From the test client, open the request file C:\LabFiles\order_history.rcq
	__6.  Run the test.
	__7.  Verify the response.

	Part 5 -  Implement Order Update Function
	__1.  In the OrderService class, add the method shell.
	__2.  Fill in the method body as follows.
	__3.  Organize imports.
	__4.  Save changes.

	Part 6 -  Test
	__1.  From the REST test client, open the request file C:\LabFile\order_create.rcq
	__2.  Run the test.
	__3.  Add the order ID 1000 to the URL (add  /1000  at the end of the URL).
	__4.  From the Method tab, choose POST.
	__5.  From the Body tab, change quantity and/or part number.
	__6.  Run the test.
	__7.  Verify that status code 204 is returned.
	__8.  Now lets check the retrieve request. Open the request file C:\LabFile\order_retrieve.rcq
	__9.  Run the test.
	__10.  Verify that status code 200 is returned.
	__11.  Format the result (Indent > Indent XML ) and verify that the the body contains the information that you changed.
	__12.  Open the request file C:\LabFile\order_create.rcq
	__13.  Change the order ID in the URL to an invalid value as shown above.
	__14.  From the Method tab, choose POST.
	__15.  Run the test and make sure 404 status code is returned.
	__16.  Close all open files.

	Part 7 -  Review




