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Lab 1 - Configure the Development Environment
Throughout these labs, you will be developing web service components with two main 
pieces of software: Oracle WebLogic Server v12c and Oracle Enterprise Pack for 
Eclipse(OEPE).

Oracle WebLogic Server v12c(12.1.1) (WLS) is a JEE application server that serves up 
JEE applications, and is also a web service container. 

OEPE, Provides tools that make it easier to develop applications utilizing specific Oracle 
Fusion Middleware technologies and Oracle Database.  Based on the Eclipse tool, it is the 
programming environment we will use for this class. 

In this lab exercise, we will configure WLS and OEPE to form our development 
environment. 

Part 1 - Oracle WebLogic server Setup
WebLogic Server is already extracted into C:\Software\WebLogic folder.

In this part we will setup necessary Environment variables and run installation 
configuration script.

Follow the instructions to set up JAVA_HOME, MW_HOME and JAVA_VENDOR 
environment variable

JAVA_HOME=C:\Software\Java

MW_HOME=C:\Software\WebLogic

JAVA_VENDOR=Oracle

__1. Right click on the My Computer icon on your computer and select properties. 

__2. Click the Advanced Tab. 

__3. Click the Environment Variables button. 

__4. From the System Variables list, select Path and click Edit.

__5. At the beginning of the line enter the following:

C:\Software\Java\bin;
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__6. Click OK.

__7. Under System Variables, click New. 

__8. Enter the variable name as JAVA_HOME

__9. Enter the variable value as the install path for the Development Kit. 

__10. Click OK. 

__11. Repeat these steps for MW_HOME and JAVA_VENDOR variables.

Once all done it should look like.

__12. Click OK until you close all windows.

Now you will run the installation configuration script in the MW_HOME directory. It 
should be run only once.

__13. Open a command prompt.

__14. Change the directory to C:\Software\WebLogic

__15. Enter configure.cmd and hit Enter.
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It takes few minutes to complete. 

You will get a notification when the installation is done.

__16. Close the command prompt window.

__17. Restart the machine.

__1. Open a Windows command prompt.  You can do this by selecting 'Start -> Run', 
entering 'cmd', and then pressing the OK button.

__2. Enter the following command:

java -version

Make sure you see the response shown below.

__3. Enter the following command:

javac

Verify that you get the options to run the Java compiler:

__4. Close the command prompt window. 

Part 2 - Configure a server in OEPE
We now need to configure OEPE to be able to communicate with WLS.  Doing so will 
allow us to perform simple operations with the server (e.g. Starting, stopping and 
deploying applications).  While this is not strictly necessary for a development 
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environment, it significantly simplifies development time. In order to setup the server we 
should also need to create a domain.

As with WLS, OEPE has already been installed on your computer.  We just need to 
configure it. 

__1. Start OEPE by launching C:\Software\OEPE\eclipse.exe

OEPE will launch.

You will be prompted to select a Workspace. 

__2. Set the Workspace to C:\workspace

__3. Click OK.

OEPE will start. 

As mentioned earlier, OEPE is built on top of Eclipse.  If you are familiar with Eclipse, 
you should have no problems using OEPE.  

__4. WTP is displaying the Welcome screen (or view).  Close the view by clicking the x 
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in its tab.  

__5. From the menu, select Window > Open Perspective > Java EE.

OEPE will then show the Java EE perspective. (A perspective is a collection of views)

__6. Select Windows | Preferences.

__7. Expand Server | Runtime Environments.

__8. Click Add...

__9. Expand  Oracle and select Oracle Weblogic Server 12c(12.1.1)
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__10. Click Next.

__11. For Weblogic home, enter C:\Software\WebLogic\wlserver or browse to find the 
location. Similarly enter C:\Software\Java for Java home.

You will see as shown below:
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__13. Click OK.

__14. We need to create domain and configure OEPE to point at the domain.  Locate the 
Server view. To do this, click the Servers tab in the bottom area of OEPE.

__15. Right click anywhere in the area and select New | Server.
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The New Server window will appear. 

__16. Select Oracle WebLogic Server 12c.

__17. Click Next.
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__18. Next to Domain directory, click the create icon and then select Create Domain.

__19. Enter LabDomain as the name. 

__20. Check specify password and enter w1sadmin as password where the password 
contains number one not L. 

__21. Don’t select any extensions, because we will not be using any of the advanced 
features like WS-Addressing.

__22. Click Finish.

__23. After some seconds the below screen will open, make sure Disable Automatic 
Publishing to server is checked.
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The server connection has been defined, and the server should now be listed in the 
Servers view.

Part 3 - Working with the Server
Throughout this class, we will be using this view to perform 3 basic operations: server 
stop, start and publish.  We will discuss publishing in a later lab, so let us now focus on 
starting and stopping the server. 

__1. Let us start things off by starting the server.  In the Servers view, right click on the 
server and select Start.
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The Console view should automatically open.  This will allow us to “see” OEPE booting. 
Eventually, the server will start and the Servers view will be brought to the focus again.  

After finish publishing the server State should be Started.

__2. Examine the Console window by clicking the Console tab. 

In later lab steps, when we ask you to refer to the server console, this is the view we will 
be referring to.  

__3. Let us try stopping the server.  Go back to the Servers view. 

__4. Right click on the server and select Stop.
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As with starting the server, the console view will open briefly.  Then the Server view will 
appear, listing the status as Stopped.

You have stopped the server.

Part 4 - Review
In this lab, you configured the development environment.  

You started things off by configuring environment followed by WebLogic Server domain 
creation and server setup, which will be used to host our web service applications.

You saw how to start and stop a WebLogic Server instance. 
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Lab 2 - Develop a Simple RESTful Service
Over the next few labs, our goal will be to learn the fundamentals of the JAX-RS API. 
We will not get into implementing the services for Acme Inc. just yet.

In this lab, we will develop a very simple RESTful web service. This will let us focus on 
the development process using the OEPE tool and WebLogic server. We will also learn 
about the basic JAX-RS annotations.

The main goal of this lab is to understand how to create a web service project and 
configure it properly for JAX-RS development.

Part 1 - Create the Web Service Project
In OEPE, we can develop a JAX-RS web service inside of a dynamic web project or a 
web service project. The latter is just an extension of a dynamic web project with a few 
extra JAR files added to the compiler's build path. These extra JAR files include the 
Jersey 1.9 JAR files that implement the JAX-RS API. Hence, using the web service 
project will save us a bit of time. If you have a legacy dynamic web project where you 
will like to create a JAX-RS service, all you have to do is add the Jersey JAR files to the 
build path. We will look into that shortly.

__1. Launch OEPE if it is not already running.

__2. Switch to the Java EE perspective.

__3. From the menubar, select File > New > Web Service Project.

__4. Enter AcmeWeb as the project name.

__5. Ensure that Oracle WebLogic Server 12c as the targeted runtime.

__6. Add the project to an enterprise application archive project called AcmeApp
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Tip

You must add the web service project to a EAR. Otherwise, it appears, the JAX-RS 
services don't work. 

__7. Click Finish.

We will briefly review the project.

__8. Right click the newly created AcmeWeb project and select Properties.

__9. Select the Java Build Path properties.

__10. Click the Libraries tab.

__11. Expand WebLogic Systems Library.

__12. Scroll down and locate the Jersey JAR files. If you use a plain dynamic web 
project, you will need to manually add these JAR files to the build path.

__13. Now, select the Project Facets property.

__14. Note that the JAX-RS facet is not selected. This facet plays no role in developing 
JAX-RS services for WebLogic.

__15. Click Cancel to close the dialog.

Part 2 - Register the REST Handler Servlet
A REST servlet handles all incoming request for RESTful services. In our case, this 
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servlet is available from the Jersey implementation. All we have to do is register it in 
web.xml. To save time, this file is given to you. You will simply import it.

__1. Open Windows file explorer.

__2. Go to C:\LabFiles\

__3. Copy web.xml

__4. In Eclipse OEPE, paste the file inside the WebContent > WEB-INF folder of 
AcmeWeb.

__5. Open web.xml and study how the servlet is registered. Specifically, note the servlet 
mapping:

    <servlet-mapping>
        <servlet-name>RestServlet</servlet-name>
        <url-pattern>/svc/*</url-pattern>
    </servlet-mapping>

This means, the URL for every REST request will start with 
http://host:port/AcmeWeb/svc/. You can choose any other path for the REST servlet. But, 
we will stick to the short and sweet "svc".

Part 3 - Create the Resource Class
The Java class that implements a RESTful service is called a resource. We will now 
develop a Java class for a simple service.

__1. Right click AcmeWeb project and select New > Class.

__2. Enter com.acme.services as the package name and SimpleService as the class 
name.

__3. Click Finish.

__4. Add a member variable that will help us do logging.
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Logger logger = Logger.getLogger("SimpleService");

We will now add the testGET() method. It will not have any business logic. Later, we will 
map this method to a GET request.

__5. Add the method as follows.

public String testGET() {
logger.info("Got a GET request");

return "OK";
}

__6. Organize imports (Control+Shift+O) and select java.util.logging.Logger.

__7. Save changes.

Part 4 - Configure the Resource
We will now configure the URI and HTTP method for the service resource and its 
methods. We will use the "/simple" root URI for the service.

__1. Define the URI of the root resource, by adding the @Path annotation above the 
class. This is shown in bold face below.

@Path("/simple")
public class SimpleService {

The testGET() method does not need any path extension. All we have to do is set GET as 
the HTTP method. 

We will also set "text/plain" as the content MIME type of the reply. That is good enough 
for this method. For XML data type, the MIME will be "text/xml".

__2. Set the HTTP method and reply MIME type for the testGET() method sub-resource 
as follows.

@GET
@Produces("text/plain")
public String testGET() {

__3. Organize imports. Select javax.ws.rs.Produces.

__4. Save changes.
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Part 5 - Unit Test
We will now exercise the web service from a browser.

__1. Start the server if it is not running.

__2. Right click the server and select Add and Remove.

__3. Add the AcmeApp project to the server.

__4. Click Finish.

__5. Make sure the server is synchronized.

__6. Open a web browser and enter the URL: 

http://localhost:7001/AcmeWeb/svc/simple/

__7. You should see OK in the browser.

__8. The Console view in Eclipse will show the log output.

This proves that our project has been setup correctly and JAX-RS is working fine.

Part 6 - Use Path Extension for Sub-resource
A sub-resource – Java method – can be mapped to an URI extension path. Any HTTP 
request for that path will be handled by that method. We will now create a method that 
will respond to the /simple/mypath URI.

__1. First, add this method.

public String testGETWithPath() {
logger.info("Got a GET request with path extension.");
return "OK";

}

__2. Annotate the method as follows.

@GET
@Produces("text/plain")
@Path("/mypath")
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public String testGETWithPath() {

__3. Save changes.

Part 7 - Unit Test
__1. Right click the server and select Publish.

__2. In a web browser, enter the URL: 

http://localhost:7001/AcmeWeb/svc/simple/mypath

__3. Make sure that the Console shows the log output.

__4. Open a new browser and re-test the testGET method for regression using the URL: 

http://localhost:7001/AcmeWeb/svc/simple/

__5. Close all open files.

__6. Close all browsers.

Part 8 - Review
In this lab, we created and configured a web service project. We created a very simple 
JAX-RS web service. At this point, you should know how to configure the URI of the 
root resource – the Java class - using the @Path annotation. Also, we configured the 
HTTP method of a sub-resource – a method – using the @GET annotation.
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Lab 3 - Extracting Information from a HTTP Request
RESTful services are executed by sending HTTP requests. The request contains input 
data in various areas:

1. In the URI path. For example: /orders/1051.

2. As URL parameters. For example: /orders?status=P

3. Input data from a form submission.

4. Less commonly, from HTTP header and cookie.

We will now learn how to extract data from common locations.

Part 1 - Get Root Resource Path Parameters
Input data can be added to the path of the root resource as well as the path of a method 
(sub-resource). In REST, data is added to the URI to form an unique identifier.

First, we will add an input parameter in the root path of the SimpleService resource. The 
root URI will now look like /simple/somedata. The root URI will continue to execute the 
testGET() method since this method defines no path extension. To execute the 
testGETWithPath(), the URI will need to be /simple/somedata/mypath.

__1. Open SimpleService.java

__2. Change the @Path annotation for the class and add a parameter there.

@Path("/simple/{myRootPathData}")
public class SimpleService {

Here, {myRootPathData} is a placeholder for a parameter. You can use anything as a 
name of the parameter. The name will play a role to obtain the value of the parameter.

The best place to capture input from a root path is a member variable of the resource. We 
will do that now.

__3. Add a member variable as follows.

String rootPathData;

__4. Annotate the member variable to save the value of the myRootPathData parameter.

@PathParam("myRootPathData")
String rootPathData;

That's it. Now, JAX-RS will extract the value of the parameter from the URI and set it to 
the member variable right after the resource object is created. By default, a POJO 
resource instance is created for every HTTP request. Hence, every request can have a 
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different parameter value in the path.

__5. Change the log statement of the testGET() method as follows.

logger.info("Got a GET request with root path data: " + rootPathData);

__6. Make a similar change to the testGETWithPath() method.

logger.info(
    "Got a GET request with path extension with root path data: " +
    rootPathData);

__7. Organize imports.

__8. Save changes.

Part 2 - Unit Test
__1. Publish the server.

__2. First, test the testGET() method by entering the URL: 

http://localhost:7001/AcmeWeb/svc/simple/somedata/ 

__3. The log output will like this:

INFO: Got a GET request with root path data: somedata

__4. Now, test the testGETWithPath() method using the URL: 

http://localhost:7001/AcmeWeb/svc/simple/somedata/mypath

__5. The log output will be:

INFO: Got a GET request with path extension with root path data: 
somedata

Part 3 - Get Sub-resource Path Parameters
Methods can also let us add parameters to its path. For example to get the billing address 
of an order #1051, we can use the URI: /orders/1051/address/billing. Never lose sight of 
the fact that a URI uniquely identifies an entity or a collection of entities. In this example, 
we are specifically pointing to the billing address used with an order. Here, the orderId as 
well as the type of address requested can be added as parameters to the path of the sub-
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resource. Let's try out this example.

__1. Add a basic method as follows.

public String getAddress(
int oId, 
String type) {
logger.info("Order Id: " + oId);
logger.info("Address type: " + type);

return "OK";
}

__2. Annotate method with path and method.

@GET
@Produces("text/plain")
@Path("/{orderId}/address/{addressType}")
public String getAddress(

__3. Now, extract the path parameters and save them in the two input argument variables 
of the method.

public String getAddress(
@PathParam("orderId")
int oId, 
@PathParam("addressType")
String type) {

__4. Save changes.

__5. Test the method by entering the URL: 

http://localhost:7001/AcmeWeb/svc/simple/somedata/1051/address/billing

Part 4 - Extract Query Parameters
Query parameters are available from the requested URI as:

GET /path?param1=value&param2=value2 HTTP/1.1
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You can capture them either using resource class member variable or method argument 
variable. The latter is generally recommended for better code readability. We will try that 
out now.

__1. Add the giveRaise() method as shown below.

@GET
@Produces("text/plain")
@Path("raise")
public String giveRaise(
    @QueryParam("name")
    String employeeName,
    @QueryParam("amount")
    double amount
    ) {
    logger.info("Giving raise to " + employeeName + " by " + amount);

    return "OK";
}

__2. Organize imports.

__3. Save changes.

__4. Test the change by entering the URL: 

http://localhost:7001/AcmeWeb/svc/simple/somedata/raise?name=Daffy&amount=10000

__5. Make sure that the Console shows:

INFO: Giving raise to Daffy by 10000.0

Note, how JAX-RS converted the amount URL parameter from text to double.

Part 5 - Extracting Form Post Data
Form data is available in the HTTP request body. The data is encoded using MIME type 
application/x-www-form-urlencoded. Usually, such data is submitted using the POST 
method. 

Note: The Java EE Servlet specification does not distinguish between URL query 
parameter and POST data in HTTP request body. They are both accessed using 
request.getParameter() method. JAX-RS, however, makes a distinction. Query parameter 
can be accessed using @QueryParam. Form POST data has to be accessed using 
@FormParam.
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We will now build a service method that will accept input from the form above.

__1. Add this method.

@POST
@Produces("text/plain")
@Path("feedback")
public String submitFeed(
        @FormParam("interest")
        List<String> interestList,
        @FormParam("comments")
        String comments
    ) {
    for (String interest : interestList) {
        logger.info("Interest: " + interest);
    }
    logger.info("Comments: " + comments);

    return "OK";
}

Note that the HTTP method is set to POST. Also, we expect multiple values for the 
"interest" parameter. That is why we have set the data type of the variable to 
java.util.List<String>.

__2. Organize imports. Select  java.util.List.

__3. Save changes.

Part 6 - Unit Test
__1. We will import the form HTML page. Copy C:\LabFiles\post.html and paste it 
inside the WebContent folder of AcmeWeb project.

__2. In the Servers view, right click the server and select Publish.

__3. Open a browser and enter the URL: 

http://localhost:7001/AcmeWeb/post.html

__4. Fill out the form and submit it. 
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__5. Make sure that the console log shows the input values correctly.

__6. Close all open files.

__7. Close all open browsers.

Part 7 - Review
In this lab, we learned how to gather input data from a couple of common sources:

1. URI path of the root resource

2. URI path of the method sub-resource.

3. URL query parameter.

4. Form POST data.
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	__4.  Save changes.

	Part 5 -  Unit Test
	__1.  Start the server if it is not running.
	__2.  Right click the server and select Add and Remove.
	__3.  Add the AcmeApp project to the server.
	__4.  Click Finish.
	__5.  Make sure the server is synchronized.
	__6.  Open a web browser and enter the URL: 
	__7.  You should see OK in the browser.
	__8.  The Console view in Eclipse will show the log output.

	Part 6 -  Use Path Extension for Sub-resource
	__1.  First, add this method.
	__2.  Annotate the method as follows.
	__3.  Save changes.

	Part 7 -  Unit Test
	__1.  Right click the server and select Publish.
	__2.  In a web browser, enter the URL: 
	__3.  Make sure that the Console shows the log output.
	__4.  Open a new browser and re-test the testGET method for regression using the URL: 
	__5.  Close all open files.
	__6.  Close all browsers.

	Part 8 -  Review

	Lab 3 -  Extracting Information from a HTTP Request
	Part 1 -  Get Root Resource Path Parameters
	__1.  Open SimpleService.java
	__2.  Change the @Path annotation for the class and add a parameter there.
	__3.  Add a member variable as follows.
	__4.  Annotate the member variable to save the value of the myRootPathData parameter.
	__5.  Change the log statement of the testGET() method as follows.
	__6.  Make a similar change to the testGETWithPath() method.
	__7.  Organize imports.
	__8.  Save changes.

	Part 2 -  Unit Test
	__1.  Publish the server.
	__2.  First, test the testGET() method by entering the URL: 
	__3.  The log output will like this:
	__4.  Now, test the testGETWithPath() method using the URL: 
	__5.  The log output will be:

	Part 3 -  Get Sub-resource Path Parameters
	__1.  Add a basic method as follows.
	__2.  Annotate method with path and method.
	__3.  Now, extract the path parameters and save them in the two input argument variables of the method.
	__4.  Save changes.
	__5.  Test the method by entering the URL: 

	Part 4 -  Extract Query Parameters
	__1.  Add the giveRaise() method as shown below.
	__2.  Organize imports.
	__3.  Save changes.
	__4.  Test the change by entering the URL: 
	__5.  Make sure that the Console shows:

	Part 5 -  Extracting Form Post Data
	__1.  Add this method.
	__2.  Organize imports. Select  java.util.List.
	__3.  Save changes.

	Part 6 -  Unit Test
	__1.  We will import the form HTML page. Copy C:\LabFiles\post.html and paste it inside the WebContent folder of AcmeWeb project.
	__2.  In the Servers view, right click the server and select Publish.
	__3.  Open a browser and enter the URL: 
	__4.  Fill out the form and submit it. 
	__5.  Make sure that the console log shows the input values correctly.
	__6.  Close all open files.
	__7.  Close all open browsers.

	Part 7 -  Review

	Lab 4 -  Designing a RESTful Service
	Part 1 -  The Business Requirements
	Part 2 -  Define Project Scope
	Part 3 -  Designing the Object Model
	__1.  Can you go through the business requirements and identify the entities? 
	__2.  Now that you have identified the entities, can you list the attributes or fields for each entity? Once again, the answer is below. But do your best to do the design yourself.

	Part 4 -  Identify the Service
	__1.  Can you go through the requirements and list the tasks or operations that various yet to be identified services need to perform? Then compare your findings with the answer below.
	__2.  Can you group the operations based on the entity they work with? Name each group as a service accordingly. The answer is below.

	Part 5 -  Design the Service Interface
	__1.  First, let us decide on the URI for each entity. This is a pretty straightforward exercise. Note: As a matter convention, plural forms of the entity names are used in URI.

	Part 6 -  Decide on the Data Format
	Part 7 -  Unaddressed Architectural Issues
	Part 8 -  Review

	Lab 5 -  Add Support for XML Format
	Part 1 -  Create the Entity Classes
	__1.  In the AcmeWeb project, create a package called com.acme.services.entities
	__2.  Within that package, create a Java class called QuoteRequest
	__3.  In the QuoteRequest class, add these member variables. Feel free to refer back to the object model to make sure we are doing this correctly.
	__4.  Generate getters and setters for the variables. To do this from the menu, select Source >  Generate Getters and Setters. Then click Select All and click OK.
	__5.  Add the @XmlRootElement JAXB annotation to the class as shown in boldface below.
	__6.  Organize imports.
	__7.  Save changes.
	__8.  Open a file browser and go to C:\LabFiles\entities.
	__9.  Copy all the files and then paste them into the com.acme.services.entities package.
	__10.  Open each entity class file and review them. Specifically, look at the Order class. Working with list of child objects can be tricky in JAXB. Look at how we are dealing with line items:

	Part 2 -  Generate the XML Schema
	__1.  Open a command window.
	__2.  Change directory to C:\workspace\AcmeWeb\src
	__3.  Run this command.
	__4.  Back in OEPE refresh the project.
	__5.  Open the generated schema file schema1.xsd and study it.

	Part 3 -  Create the Quote Service Class
	__1.  In the com.acme.services package, create a class called QuoteService
	__2.  Set the root URI of the service as shown in boldface below.
	__3.  Add a member variable for logging.
	__4.  Add the getQuote() method as shown below. The business logic is very simple. We hard code the price and availability.
	__5.  Annotate the method as shown below.
	__6.  Organize imports. Select javax.ws.rs.Produces and java.util.logging.Logger.
	__7.  Save changes.

	Part 4 -  Better Content Handling
	__1.  Add the @Consumes annotation to getQuote as follows in bold.
	__2.  Similarly, change the @Produces annotation to support both MIME types for XML.
	__3.  Organize imports. Select javax.ws.rs.core.MediaType.
	__4.  Save changes.

	Part 5 -  Unit Testing
	__1.  Start the server if it is not running.
	__2.  Publish the server.
	__3.  Open a command window and go to C:\LabFiles.
	__4.  Run the command:
	__5.  In the URL text box, enter: 
	__6.  Select POST method.
	__7.  Click the Body tab.
	__8.  Click the  icon.
	__9.  From the drop-down select the text/xml content type.
	__10.  Click OK.
	__11.  Click the  icon to open the file.
	__12.  Select C:\LabFiles\quote_request.xml and open it.
	__13.  Study the request document briefly.
	__14.  We are now ready start testing. Click the  icon next to the URL.
	__15.  Make sure that the HTTP reply status code is 200.
	__16.  Click the Body tab for the response.
	__17.  Right click the response body text and select Indent > Indent XML.
	__18.  Study the response document.
	__19.  Back in OEPE close all open files.
	__20.  Do not close the REST Client.

	Part 6 -  Review

	Lab 6 -  Add Support for JSON
	Part 1 -  Do the Design First
	Part 2 -  Add the JSON Method
	__1.  Open QuoteService class.
	__2.  First, add the shell of the method.
	__3.  Then, annotate the method and the input parameters as shown in boldface below.
	__4.  Now, fill in the body of the method. It basically calls the getQuote() method to get the job done.
	__5.  Organize imports.
	__6.  Save changes.
	__7.  Publish the server.

	Part 3 -  Understanding Content Negotiation
	Part 4 -  Test
	__1.  Launch the REST client tool if it is not already running.
	__2.  Set the URL to: 
	__3.  Choose POST method.
	__4.  Set the body using the XML code in C:\LabFiles\quote_request.xml and set content type to application/xml; chartset=UTF-8.
	__5.  Click the Headers tab.
	__6.  Enter Accept as Key and text/xml as Value.
	__7.  Click the + icon to add the header.
	__8.  Run the test by clicking .
	__9.  Right click the response body area and select Indent > Indent XML.
	__10.  Verify that the reply body contains the response.
	__11.  Add this to the end of the URL:
	__12.  Set the method to GET.
	__13.  Select the Accept header, then right click on it and select Delete.
	__14.  Enter Accept as Key and application/json as Value, then click the + icon to add the header.
	__15.  Run the test.
	__16.  Right click the response body area and select Indent > Indent JSON.
	__17.  Verify the result.
	__18.  Back in OEPE close all open files.
	__19.  In OEPE close all open files.
	__20.  Do not close the REST Client.

	Part 5 -  Review

	Lab 7 -  Build the Order Web Service
	Part 1 -  Create the Resource Class
	__1.  In the com.acme.services package, create a class called OrderService
	__2.  Annotate the class to set the path as follows.
	__3.  Add a member variable for logging.
	__4.  Organizer imports. Select java.util.logging.Logger.
	__5.  Save changes.

	Part 2 -  Implement Order Placement
	__1.  Write the shell of the method as follows. We will not deal with the returned URL just yet.
	__2.  Annotate the method with @PUT and @Consumes.
	__3.  Organize imports. Select these classes:
	javax.ws.rs.core.MediaType
	com.acme.services.entities.Order
	__4.  Save changes.
	__5.  Import C:\LabFiles\OrderDAO.java into the com.acme.services package.
	__6.  Open the class and briefly study it. The code should be very simple.
	__7.  In the placeOrder method of the OrderService class, use OrderDAO as shown in boldface below.
	__8.  Organize imports. Select these classes:
	java.util.logging.Level
	__9.  Save changes.

	Part 3 -  Implement Retrieval of Order
	__1.  First write the method shell along with the required annotations.
	__2.  Next, fill in the method body.
	__3.  Organize imports. Select these classes:
	__4.  Save changes.

	Part 4 -  Construct Entity URL
	__1.  First, add a member variable to the class as follows.
	__2.  In the placeOrder() method, below the line:
	__3.  Add this line below:
	__4.  Next, add the following line. This plugs in the actual value of the order ID to the path and returns a java.net.URI object.
	__5.  Finally, add this line. We will explain this shortly.
	__6.  Organize imports. Choose these classes:
	__7.  Save the file and make sure you don't have compilation errors.
	__8.  Go to the 'Servers' view and publish the server by right clicking the server and selecting 'Publish'.

	Part 5 -  Test
	__1.  From the REST client's menubar, select File > Open Request (Control+O).
	__2.  Open C:\LabFiles\order_create.rcq
	__3.  Review these items about the request:
	__4.  Click the  button to send the request.
	__5.  Verify that:
	__6.  In the Eclipse Console, verify the log output from the OrderDAO class.
	__7.  In the REST client, open the request file C:\LabFiles\order_retrieve.rcq.
	__8.  Inspect these items about the request:
	__9.  Send the request.
	__10.  Verify that the reply body has the correct order information.

	Part 6 -  Enable Error Handling
	__1.  In the placeOrder() method of OrderService class, add this line shown in bold face.
	__2.  Comment out the following unreachable line:
	__3.  Organize imports. 
	__4.  In the getOrder() method, above the line:
	__5.  Organize imports. Organize imports. Choose these classes:
	javax.ws.rs.core.Response.Status
	__6.  Save changes.

	Part 7 -  Test
	__1.  In the REST client, the order retrieval request file should be open already. Just run the test.
	__2.  Verify that the status code is 404.
	__3.  Open the request file C:\LabFiles\order_create.rcq.
	__4.  In the Body tab, delete all the <item> elements.
	__5.  Run the test.
	__6.  Verify that status code 500 is returned.
	__7.  Do regression tests to make sure that success conditions are working fine.
	__8.  In OEPE close all open files.
	__9.  Do not close the REST Client.

	Part 8 -  Review

	Lab 8 -  Developing a JAX-RS Client
	Part 1 -  Client Design Considerations
	Part 2 -  Import the Client Application
	__1.  From the Eclipse menubar, select File > Import.
	__2.  Select General > Existing Projects into Workspace.
	__3.  Click Next.
	__4.  Select the SimpleClient project from C:\LabFiles\SimpleClientStarter.zip.
	__5.  Click Finish.

	Part 3 -  Build the Service Proxy Layer
	__1.  From the AcmeWeb project, copy the com.acme.services.entities package.
	__2.  In the SimpleClient project, paste it in the src folder.
	__3.  In the SimpleClient project, create a package called com.acme.services.proxy
	__4.  In that package, create a class called QuoteProxy
	__5.  In the QuoteProxy class, add a variable to store the service root URL.
	__6.  Add the shell of a method that will invoke the quote web service.
	__7.  In the getQuote() method, add this line to instantiate a com.sun.jersey.api.client.Client object.
	__8.  Next, create a WebResource object that points to the root web service resource.
	__9.  Add this line to send a QuoteRequest XML using a POST request.
	__10.  Finally, add this line to return the quote response.
	__11.  Organize imports and select this class:
	__12.  Save changes.

	Part 4 -  Build the Presentation Layer
	__1.  From the WebContent folder, open index.jsp and study the form.
	__2.  Open result.jsp and study how the QuoteResponse object properties are shown.
	__3.  From the com.webage.servlet package, open QuoteController.java.
	__4.  Locate the doPost method.
	__5.  Below the line:
	__6.  Below the line: 
	__7.  Below the line:
	__8.  Organize imports.
	__9.  Save changes.

	Part 5 -  Test
	__1.  Start the server if it is not running.
	__2.  Deploy SimpleClient project to the server.
	__3.  Open a web browser and enter the URL: 
	__4.  Enter some values and click Get Quote.
	__5.  Verify the result.
	__6.  Close the browser.
	__7.  Close all open files.

	Part 6 -  Review

	Lab 9 -  Securing RESTful Services
	Part 1 -  Secure the Quote Service
	__1.  In the AcmeWeb project expand com.acme.services package.
	__2.  Open QuoteService.java.
	__3.  Add the following annotation in bold to the class.
	__4.  Organize imports. Select  javax.annotation.security.RolesAllowed.
	__5.  Save changes.
	__6.  Open web.xml from WebContent/WEB-INF folder.
	__7.  Add these lines shown in bold face.
	__8.  Save changes.

	Part 2 -  Test
	__1.  Restart the server. This is needed since we changed the web.xml file.
	__2.  Open a browser and enter the URL: 
	__3.  Enter some data and then click Get Quote.
	__4.  The browser will show an error, scroll to the right in the browser. 
	__5.  The client will fail with 403 error code. This proves that the service is now secured.
	__6.  Switch to the Console in Eclipse.
	__7.  You will see the error.

	Part 3 -  Configure Security at the Server
	__1.  Open a web browser and enter the URL: 
	__2.  Login using user weblogic and password w1sadmin
	__3.  Click Security Realm on the left.
	__4.  Click myrealm.
	__5.  Click Users and Groups tab.
	__6.  Click Groups tab.
	__7.  Click New.
	__8.  Enter ClientCompanyUsers as the group's name.
	__9.  Click OK.
	__10.  Click the Users tab.
	__11.  Click New.
	__12.  Enter bob as name and pa55word as the password.
	__13.  Click OK.
	__14.  Click the newly created user – bob.
	__15.  Click the Groups tab.
	__16.  Add the user to the ClientCompanyUsers group.
	__17.  Click Save.
	__18.  Click Security Realm on the left.
	__19.  Click myrealm.
	__20.  Click Roles and Policies tab.
	__21.  Expand Global Roles and click Roles.
	__22.  Click New.
	__23.  Enter Customer as the name.
	__24.  Click OK.
	__25.  Click the Customer role.
	__26.  Under Role Conditions click the Add Conditions button.
	__27.  Make sure that Group is selected in Predicate List.
	__28.  Click Next.
	__29.  Carefully enter ClientCompanyUsers in the group name text box.
	__30.  Click Add.
	__31.  Click Finish.
	__32.  Click Save.
	__33.  Close the browser.

	Part 4 -  Modify the Client Application
	__1.  In the SimpleClient project, open QuoteProxy class.
	__2.  Below the line:
	__3.  Organize imports.
	__4.  Save changes.

	Part 5 -  Test
	__1.  Publish the WebLogic server.
	__2.  Open a browser and enter the URL: 
	__3.  Enter some data and then click Get Quote. 
	__4.  Verify that the client is showing the response correctly.
	__5.  In the QuoteProxy class, change the password to an invalid one and save changes.
	__6.  Publish the WebLogic server.
	__7.  In the browser hit the back button to go again to the Quote page.
	__8.  Submit again the form and click Get Quote.
	__9.  Scroll to the right of the error message. Verify that status 401 is returned by the service.
	__10.  Change the credentials as follows.
	__11.  Save changes.
	__12.  Publish the WebLogic server.
	__13.  In the browser hit the back button to go again to the Quote page.
	__14.  Submit the form.
	__15.  Verify that server returned 403 error code.
	__16.  Change the code back to valid credentials and save.
	__17.  Publish the WebLogic server.
	__18.  In the browser hit the back button to go again to the Quote page.
	__19.  Submit the form and verify its working fine.

	Part 6 -  Enable Audit Logging
	__1.  In the AcmeWeb project, open OrderService.java.
	__2.  Configure the valid role for the service as shown in bold face below.
	__3.  Add a member variable to the class as follows.
	__4.  In the placeOrder() method, below the line:
	__5.  Organize import and select these classes:
	__6.  Save changes.
	__7.  Publish the WebLogic server.

	Part 7 -  Test
	__1.  Launch the REST test client if it is not already running.
	__2.  Select File > Open Request from the menubar.
	__3.  Open C:\LabFiles\order_create.rcq
	__4.  Click the  button to send the request.
	__5.  Make sure that a status code 403 is returned.
	__6.  Click the Auth tab.
	__7.  Enter these values:
	__8.  Run the test again.
	__9.  Verify that status code 201 is returned.
	__10.  Check Eclipse console for the audit log. It will look like this:
	__11.  From the menu, select File > Save Request.
	__12.  If this windows appears click OK.
	__13.  Make sure order_create.rcq is selected and click Save. 
	__14.  Then click Yes to overwrite the file.
	__15.  Open the request file C:\LabFiles\order_retrieve.rcq
	__16.  Click the Auth tab and enter these values:
	__17.  From the menu, select File > Save Request.
	__18.  If you see the UI parameters change click OK.
	__19.  Make sure order_retrieve.rcq is selected and click Save. 
	__20.  Then click Yes to overwrite the file.
	__21.  Close all open browsers.
	__22.  Close all open files.
	__23.  Do not close the REST Client.

	Part 8 -  Review

	Lab 10 -  Complete the Order Service
	Part 1 -  Implement Order Cancellation
	__1.  In the AcmeWeb project, open OrderService.java
	__2.  Add this method.
	__3.  Add these lines to the cancelOrder() method.
	__4.  Organize imports.
	__5.  Save changes.

	Part 2 -  Test
	__1.  Run the REST test client.
	__2.  From the client, open the request file C:\LabFiles\order_create.rcq
	__3.  Select the Auth tab and make sure credentials are configured.
	__4.  Run the test. You should get a status code of 201. 
	__5.  Open the request file C:\LabFiles\order_retrieve.rcq
	__6.  Select the Auth tab and make sure credentials are configured.
	__7.  Run the test. You should get a status code of 200.
	__8.  From the Method tab, select DELETE.
	__9.  Run the test. 
	__10.  Since the reply body is empty, you should see HTTP status code 204. This is equivalent to status 200 and indicates success.
	__11.  In the Method tab, select GET method.
	__12.  Run the test.
	__13.  Verify that 404 is returned.

	Part 3 -  Implement Order History
	__1.  From the com.acme.services.entities package, open OrderList.java and inspect it.
	__2.  In the OrderService class, add the method shell as follows.
	__3.  Add the method body as follows.
	__4.  Organize imports.
	__5.  Save changes.

	Part 4 -  Test
	__1.  From the REST test client, open the request file C:\LabFile\order_create.rcq
	__2.  From the Body tab, note the client ID – C001.
	__3.  Run the test to create an order.
	__4.  From the Body tab, change the part number and quantity ordered and place a few more orders.
	__5.  From the test client, open the request file C:\LabFiles\order_history.rcq
	__6.  Run the test.
	__7.  Verify the response.

	Part 5 -  Implement Order Update Function
	__1.  In the OrderService class, add the method shell.
	__2.  Fill in the method body as follows.
	__3.  Organize imports.
	__4.  Save changes.

	Part 6 -  Test
	__1.  From the REST test client, open the request file C:\LabFile\order_create.rcq
	__2.  Run the test.
	__3.  Add the order ID 1000 to the URL (add  /1000  at the end of the URL).
	__4.  From the Method tab, choose POST.
	__5.  From the Body tab, change quantity and/or part number.
	__6.  Run the test.
	__7.  Verify that status code 204 is returned.
	__8.  Now lets check the retrieve request. Open the request file C:\LabFile\order_retrieve.rcq
	__9.  Run the test.
	__10.  Verify that status code 200 is returned.
	__11.  Format the result (Indent > Indent XML ) and verify that the the body contains the information that you changed.
	__12.  Open the request file C:\LabFile\order_create.rcq
	__13.  Change the order ID in the URL to an invalid value as shown above.
	__14.  From the Method tab, choose POST.
	__15.  Run the test and make sure 404 status code is returned.
	__16.  Close all open files.

	Part 7 -  Review




