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Common Lab Preparation Steps
This is not lab 1!

This section defines common steps that are often taken to setup for a lab or after a lab is 
complete.  Individual labs will refer to these directions and instruct you to perform 
various tasks following the steps in this section.

File Locations
Many labs will refer to files in a common location that have been provided as part of the 
setup for the class.  To be more generic, the lab directions will often contain the following 
placeholders that would normally refer to the locations listed here.  If your files have 
been placed in a different location make the corresponding adjustment to the location of 
these files.

<SOFTWARE> - C:\Software

<LABFILES> - C:\LabFiles

Lab Setup
Many labs will provide a "starter" project(s) to allow you to focus on the topic of interest 
in the lab.  This also allows you to start a lab without needing to complete previous labs. 
This section describes the steps taken in other labs to import a "starter" project(s).

1. Open up Eclipse if it is not already.

2. Select File → Import from the Eclipse menus.

3. Expand the General group and select Existing Projects into Workspace and 
press the Next button.

4. Select the radio button next to the Select archive file option and use the matching 
Browse button to find the file that contains the project.  The exact file to locate 
will be provided in each lab.
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5. Select the projects listed in the file if they are not already as shown below.

6. Press the Finish button to import the project.

7. Right click the imported project(s) and select Spring Tools → Add Spring 
Project Nature. This option may not be shown if the Spring project nature is 
already added.

Note: For some reason the Spring project nature is sometimes not part of the project 
after importing.  If a lab uses multiple projects not all of them may be Spring projects so 
look for additional directions in the lab if present.

Start Derby database
1. In a Windows Explorer window, navigate to the 

'<SOFTWARE>\db-derby-10.7.1.1-bin\bin' folder.

2. Run the 'startNetworkServer.bat' command by double clicking it.  Make sure to 
run the correct command as there are several similarly named batch files.

3. Wait for the Derby server to report that it is waiting for connections.

4. Do not close the command prompt window.

Stop Derby database
1. In a Windows Explorer window, navigate to the 

'<SOFTWARE>\db-derby-10.7.1.1-bin\bin' folder.

2. Run the 'stopNetworkServer.bat' command by double clicking it.  Make sure to 
run the correct command as there are several similarly named batch files.
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Initialize Derby Database
Some labs will import test data into the database to make it easier to test.  This will also 
create the database structure so that the application does not have to attempt to do this.

1. If your <LABFILES> directory is not 'C:\LabFiles' browse to the lab file 
directory for the lab, open the 'db.txt' file with a tool like Wordpad or Notepad, 
and edit the file location of any files referenced in the database script.  For 
example, the screenshot below references a file for data that will be imported but 
this will not work if the <LABFILES> directory is not 'C:\LabFiles'.

2. Save and close the 'db.txt' file if you modified it.

3. Make sure your Derby database is running as described in the 'Start Derby 
database' section of these common steps.

4. Open a command prompt.  You can do this by selecting Start → Run and 
entering 'cmd'.

5. Use the 'cd' command to switch to the 
'<SOFTWARE>\db-derby-10.7.1.1-bin\bin' directory.

6. Issue the following command making sure to substitute the correct value for your 
<LABFILES> location and the location of the lab folder for your current lab. 
For example, the screenshot below shows the command for the 'C:\LabFiles' 
location and the 'JPA-QL' lab.

ij <LABFILES>\<LAB FOLDER>\db.txt
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7. After a number of seconds several database commands should execute.  At the 
end make sure you see the contents of some of the test data that was imported. 
Also scroll back and check that you don't see any errors in the commands that ran. 
If you don't see sample data or think you might have errors notify your instructor.

Note: It is important that you only run the command to initialize the database once.  If 
you have errors the best way to start over is to:

1.  Stop the Derby database

2.  Go to the '<SOFTWARE>\db-derby-10.7.1.1-bin\bin' directory and delete the 
subdirectory which has the same name as the lab

3.  Restart the Derby database

4.  Run the command to import the data again after determining what caused an error.

8. Close the command prompt you used to initialize the database.
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Configure WebSphere DataSource
Many labs will use a database connection from an application deployed to WebSphere. 
This section details how to configure a DataSource within the WebSphere Admin 
Console to support the lab.

Note that the DataSource of each lab will have slightly different settings so make sure to 
reference the details of each individual lab and adjust these instructions accordingly.

1. Switch to the Servers view. If it is not shown from the menu, select Window > 
Show View > Servers.

2. Make sure you have not yet added the project to the server as it would have errors 
being deployed without the DataSource configured first.

3. Right click the WebSphere server and select Start.  Wait until it starts completely.

4. Right click the server and select Administration → Run Administrative 
Console.

5. In the Admin Console navigate to Security -> Global Security.

6. On the right side, under the Authentication section, expand Java Authentication 
and Authorization Service and click the link for J2C Authentication data.
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7. Check if you already have a 'wasadmin' user in the list.  If you do not have this 
user continue with the next steps.  If you do already have this user skip to step 
#12.

8. Press the New button on the empty list of entries.

9. In the fields for the new Authentication Data Entry fill in the following properties. 
Note that you only supply the password once and there is no “Confirm password” 
box that will check you enter the same value so be careful typing the password. 
Press the OK button when the properties are filled in as below.

Alias: wasadmin

User ID: wasadmin

Password: wasadmin

10. Verify that the new entry shows up in the list.  Notice that the alias is prefixed 
with the name of the Node where the Application Server resides.

11. Click the Save link in the messages at the top of the Admin Console.
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12. On the left, expand Resources → JDBC and click the JDBC providers link.

13. Check to see if you have a "Derby Network Server using Derby Client (XA)" 
Derby JDBC provider.  If you do not have this type, continue with the next step. 
If you do have this type you can skip to step #20.  The list below shows the 
default entries before adding the one you need.

14. If you do not have an entry for a Derby "Network" provider select the entry in the 
"scopes" drop-down that has you Node and Server name.  This will change the 
contents of the list below.

15. With the 'Server' scope selected click the New button above the list.
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16. From the drop downs shown select the following:

Database type: Derby

Provider type: Derby Network Server Using Derby Client

Implementation type: XA data source

17. Click Next.

18. On Step 3: summary page, click Finish.

19. Click the Save link at the top of the page.

20. From the list of JDBC providers, click the link for the "Derby Network Server" 
provider as shown below.

21. Click the 'Data sources' link on the right side of the JDBC provider property 
page.
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22. Above the list of Data sources, click the New button.

23. Fill in the following information, using the values provided as part of the lab. 
These are likely different than the screenshot shown below which is just to show 
you what to fill in.

Data source name - <Data source name from lab>

JNDI name - <JNDI name from lab>

24. Once your Data source properties are filled in to match the lab settings click the 
Next button.

25. Fill in the 'Database name' property with the value given in the lab.  Make sure to 
match the entry exactly, especially if ';create=true' is on the end of the name.

26. Once the 'Database name' property is filled in with the value indicated in the lab 
click the Next button.
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27. Select the wasadmin user from the drop-down for the following entries from the 
page:

Authentication alias for XA recovery

Component-managed authentication alias

Container-managed authentication alias

28. Once the security properties are filled in click the Next button.

29. From the Summary page click the Finish button to create the Data source.

30. At the top of the page, click the Save link.

31. Make sure your Derby database is running as described in the 'Start Derby 
database' section of these common steps.

32. Check the box for the Data source you just added and click the Test connection 
button.  Remember the name of the Data source will be different for different 
labs.
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33. You should get a successful message.

34. Logout and close the admin console.

Lab Cleanup
After a lab is complete you may be instructed to remove projects from a server or close 
a project to remove it from the build process.  This section describes the steps you would 
use to do that.

1. From the menus select Run → Run Configurations.

2. Delete any of the Run configurations used in the lab by selecting them, pressing 
the Delete button as shown below, and confirming that you want to delete the 
configuration.

3. Close the Run Configurations window.
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4. Switch to the Servers view. If it is not shown from the menu, select Window > 
Show View > Servers.

5. Right click on the 'WebSphere Application Server v8.0' server and select Add and 
Remove... 

6. Remove all applications that might be on the server by clicking the Remove All 
button.  Make sure there are no projects listed on the right side as being deployed 
to the server.

7. Click the Finish button to remove all applications from the server.  

8. Right click the server and select Clean and then click OK.

9. Right click the server and select Stop if it is running.

10. Select the Console view.

11. Click the Remove All Terminated Launches.

12. No consoles will be displayed.

Copyright 2013 Web Age Solutions Inc. 14

EVALUATIO
N O

NLY



13. Right click each project used in the lab and select Close Project.  This will 
remove the project from the build process and improve Eclipse performance.

14. If you want to hide closed projects from the various views, click the down arrow 
in the view toolbar which will bring up the 'View Menu'.

15. From the 'View Menu' select the Customize View... option.

16. Enable (check) the Closed projects filter and click the OK button.

17. You should no longer see any closed projects in the view.
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18. Switch to the Spring perspective.

19. Click the down arrow in the view toolbar which will bring up the 'View Menu'.

20. From the 'View Menu' select the Filters option.

21. Enable (check) the Closed projects filter and click the OK button.

22. You should no longer see any closed projects in the view.
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Lab 1 - Setup Eclipse for Spring 3 with WebSphere 8
Note: You will need to perform this lab before any other labs for the course.  This lab 
configures Eclipse with Maven which will be used to include Spring JARs in projects.

In this lab you will perform steps to prepare for Spring development in Eclipse.  Even 
though your own projects may be very different from the projects in future labs you 
would most likely take steps similar to this lab to prepare them for Spring.  

At the end of this lab you will be able to:

1. Define a WebSphere 8 server in Eclipse

2. Create a Web Project

3. Setup Maven dependencies on Spring JARs for the project

4. Create a Spring configuration file

Part 1 - Configure WebSphere Profile
Some labs will use a WebSphere server.  The WebSphere Application Server 8.0 for 
Developers software should have already been installed as part of the lab setup.  These 
steps will create a WebSphere environment called a "profile".

Although we will only create one profile this is a good process to know how to do.  If you 
work with multiple WebSphere applications from different Eclipse workspaces it is a 
good idea to create a different profile for each workspace so the applications in each 
workspace can have a unique WebSphere configuration and avoid any issues with 
deploying or testing those applications.

__1. From the Windows Start menu select 'Start → Programs → IBM WebSphere → 
WebSphere Application Server V8.0 → Tools → Profile Management Tool'.

__2. Press the Create button next to the list of profiles.

__3. In the Environment Selection dialog, select the option for Application Server and 
press the Next button.
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__4. Select the option for Advanced profile creation and press the Next button.

__5. Leave the default option to deploy the administrative console and default application 
and press the Next button.

__6. Leave the default profile name and note the value for later in Eclipse.  Leave the 
default profile directory which should be a directory NOT in the 'Program Files' directory. 
If the profile directory does include the 'Program Files' directory remove it as shown 
below.  Also change the option for 'Server runtime performance tuning setting' to 
Development as shown below.

Note: If your default profile directory does not match that shown above let your 
instructor know as this will alter other steps in this lab.
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Windows Vista/7/2008: If you are using Vista/2008 it is important to avoid the 
'Program Files' directory because you would not be able to alter the profile configuration 
files in this directory since they are protected by Windows security.  Creating the profile 
in a separate directory ensures we can configure the profile and save the configuration 
files.

__7. Once all of your profile settings match that shown above click the Next button.

__8. Leave the default Node, Host and Cell names.  Press the Next button.

__9. Uncheck the box for Enable administrative security and press the Next button.

__10. In the first page of security certificate options, leave the default to create a new 
default personal certificate.  Press the Next button.

__11. On the second page of security certificate options again leave the defaults and press 
the Next button.

Note: Normally you might use these options to customize how the default certificate is 
generated.
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__12. In the Port values assignment page, click the Default Port Values button to use 
default ports for the profile and click Next.

Note:  Normally the profile creation tool will attempt to locate other profiles and ensure 
this profile has unique ports.  Although this is helpful in administration of environments, 
profiles used for development are almost always run one at a time so using the default 
ports helps ensure the way to access applications in consistent for multiple profiles.

__13. If prompted to run the application server as a Windows process uncheck the option 
as shown below and click the Next button.

__14. Leave the option to create a web server unchecked and click the Next button.

__15. Press Create in the Summary page to begin profile creation. 
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__16. When the profile creation is complete, uncheck the option for launching the First 
Steps console and press the Finish button.

__17. Select File → Exit for the Profile Management Tool.

Part 2 - Launch Eclipse
Since we will be using WebSphere tools with Eclipse it is important that Eclipse is 
launched with the IBM JVM.  If it is not you will not be able to create a WebSphere 
server definition in your Eclipse workspace.  You will alter the Eclipse startup to do this 
in this section.

__1. If you had already launched Eclipse, close it.  Eclipse must be shut down to pick up 
changes in the startup options.

__2. Open a Windows Explorer window and navigate to <SOFTWARE>\eclipse

__3. Find the ‘eclipse.ini’ file and right click on the file and select Properties.  The 
extension may be hidden and just list the file type as ‘Configuration Settings’. 
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__4. Check that the file is not read only and uncheck the box if it is.  Close the file 
properties after making sure the file isn't read only.

Note: If the file is read only let your instructor know as errors will occur if other Eclipse 
files are read only.

__5. Open the eclipse.ini file with a text editor.  

__6. Once you have the file open, add the following two new lines to the start of the file, 
making sure not to put extra spaces at the end of the lines:

-vm
C:\IBM\WebSphere\AppServer\java\jre\bin\javaw.exe

Note: You should double check that your WebSphere software was installed to the 
location above as part of the setup for the class.

__7. Save the file when it is like above.  Make sure when you save it the file extension is 
not changed. 

__8. Close the eclipse.ini file.

__9. Launch Eclipse by double clicking on <SOFTWARE>\eclipse\eclipse.exe.  You 
may want to add a shortcut to this to the desktop.
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__10. Change the workspace location to C:\workspace if it is not already and click OK.

Note:  Always keep the workspace path name short. Otherwise, you may run into the 
Window's 255 character file name restriction problem.

Also note that if you are running Eclipse in an environment with security restrictions for 
creating folders on the 'C' drive you may have to create the workspace in the user 
'Documents' folder or in another folder you have permissions for.

__11. Click the Reject button on the 'User Agent Analysis' dialog if it appears.

__12. Close the Welcome or Dashboard pages if they appear.

Part 3 - Configure WebSphere Server in Eclipse
The final step of integrating WebSphere with Eclipse is to link a server definition in your 
Eclipse workspace to the profile created in a previous section.

__1. Select Window → Preferences from the menus.

__2. Select Server → Runtime Environments in the preferences.

__3. Click the Add button.
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__4. From the list expand IBM and select WebSphere Application Server v8.0.  Also 
check the box to 'Create a new local server' as this will perform all needed tasks during 
this wizard.

__5. Click Next.

__6. Click the Browse button next to Installation Directory and navigate to 
C:\IBM\WebSphere\AppServer and then click OK.

__7. Once your settings match those shown below click the Next button.

__8. Make sure the appropriate profile is selected, which should be 'AppSrv01', leave the 
other settings as the default and click the Finish button.
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Note: If you wanted to have multiple WebSphere profiles for different applications, this 
is the step where you could select the appropriate profile you wanted to use for the 
applications in your current Eclipse workspace.  

__9. Back in the Eclipse preferences, click the OK button to close the preferences.

__10. If it was not automatically selected, select the Servers view along the bottom and 
check that the new WebSphere server is shown.

__11. Right click on the Server and select Open.

The configuration page of the Server will open.

__12. Expand Publishing on the right.

__13. Select Never publish automatically.
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__14. Expand Timeouts.

__15. Change the Start (in seconds) to 600

__16. Expand the 'Publishing settings for WebSphere Application Server' and select 
the 'Run server with resources on Server' option.

Note: This setting appears to be important because without it the JARs included for the 
project would be included only by Maven from the workspace and sometimes 
WebSphere may have classloading problems this way.  Running with resources on the 
server will make sure the entire application (including dependent JARs) will be 
packaged and deployed as an application on the server more as if the normal 
administration console were used.

__17. Save the changes and close the window.

__18. In the Servers view, right click the 'WebSphere Application Server v8.0' and 
select Start.  The server will print several messages when starting.

__19. Switch back to the Servers view and check that the server starts successfully.

__20. Right click the server and select Stop.
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Part 4 - Configure Maven Mirror
Although not the only way, one way to manage the various JAR files that might be 
required for a Spring project is by using Maven.  The default setting in Maven is to 
download files from a central repository from the internet.

For the environment of these labs it is preferred not to require an internet connection or 
proxy settings so we want to point to a local repository that is delivered with the software 
for the class.  The problem is that Maven creates a local repository cache and when you 
convert an Eclipse project to use Maven if it does not yet know about this local repository 
it could get errors contacting the internet repository and stop attempting to download 
some important files for Maven functionality.

The way we will address this is to configure the local repository as a “mirror”.  This will 
redirect all Maven queries, even when first setting up a project to this local repository. 
This is done with a settings file.  Although this is one way to configure Maven it may not 
be the way you use Maven in other projects.  In other projects you may want to contact 
an internet repository and it would be more appropriate to configure proxy settings 
instead of a mirror.  Another approach is to have everyone on a team point to a team 
repository on the intranet that is managed by an individual or group that adds files to the 
team repository based on some standards on what libraries and versions will be available. 
We will not explore these possibilities but the “settings” file you work with is one of the 
main ways this would be accomplished.

__1. From the Eclipse menus select Window → Preferences.

__2. Select Maven → Installations from the left.  Notice that Eclipse is aware of an 
external installation of Maven which was delivered as part of the software for the class.

Note: Notify your instructor if you don't see the Maven installation shown above but it 
should be easy to add.
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__3. Note the location of the 'settings.xml' file for the external Maven installation that is 
installed.  We will use this file as a template in a little bit.

Note: Although we could try to modify the global settings file the Maven Eclipse plugin 
does not seem to pick this one up as well as a user-specific version.  There are some 
settings that may be user specific and should be secured (like proxy authentication 
settings) so using a user file will be good for this also.

__4. Open a Windows Explorer window.  Leave Eclipse and the preferences open.

__5. Navigate to the location of the external Maven settings file you saw in the previous 
step.

__6. Copy the 'settings.xml' file which should be the only file in the folder.

__7. Navigate to the '<LABFILES>\Setup' folder.  

__8. Paste the file into this folder.  There is also a solution file in the 'Solution' folder you 
can use if you want.

__9. Edit the file with a text editor like WordPad or NotePad.  If you just try to double 
click it will likely open in a browser which won't let you edit.

__10. In the file find the section for 'mirrors'.  This should have a sample mirror 
definition commented out so there are actually no mirrors defined.

__11. Add the following mirror definition being careful it is outside the comment but 
inside the <mirrors> tag.

<mirrors>
    <!-- mirror
     ... Comment left out 
    </mirror>
     -->
     <mirror>
     <id>localMirror</id>
     <mirrorOf>*</mirrorOf>
     <name>Local Override Repository</name>
     <url>file://C:\Software\MavenRepository</url>
     </mirror>
  </mirrors>

Note: This setting assumes that the software for the class was extracted to the 
C:\Software folder.  If the software was extracted somewhere else or into a subfolder 
check the location and adjust this setting appropriately.

The key part of this mirror configuration is the <mirrorOf>*</mirrorOf> property.  This 
redirects all Maven requests to the local mirror repository.  You could list individual 
repositories here also (like the Maven 'central' repository).
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__12. Save the file and close the editor for the settings.xml file.

Note: You can also configure the location of the local user repository which is used to 
cache repository entries if you want with the <localRepository> tag.  We will leave the 
default.

__13. Back in Eclipse, select Maven → User Settings from the left of the preferences. 
Open the preferences again if you closed them.

__14. Next to the user settings file press the Browse button.

__15. Navigate and select the 'settings.xml' file that you edited in the 
'<LABFILES>\Setup' folder.  Check that your location is updated as shown below.

Note: The default location for the file is in a '.m2' folder.  Since this folder starts with a 
period we can't create it manually.  The problem is the folder would be created when we 
went to create our first maven project but this will be too late to point to the local 
repository.  

__16. Press the Update Settings button to be sure the settings are loaded.

__17. Click  the OK button to close the preferences dialog.

__18. Select Window → Show View → Other from the Eclipse menus.

__19. Select the Maven → Maven Repositories view and click the OK button.

__20. In the view that appears at the bottom expand the 'Global Repositories' entry and 
be sure you see the 'local' repository listed.  Notice it also is overriding the normal 
'central' repository of Maven from the internet.
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__21. Right click the 'localMirror' global repository and select 'Rebuild Index'. 
Confirm that you want to rebuild.  This will make sure all library information is 
available.

Part 5 - Create a Web Project
In this section you will create a Web Project.  

__1. From the menu select File -> New -> Dynamic Web Project.

__2. Enter OEProject as Project name.
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__3. Check that the 'Target runtime' is WebSphere 8.0 which should be the default.  Also 
check the 'Add project to an EAR' option.

__4. Click Finish when your options match those shown above.

__5. If prompted to switch to the Web perspective click the No button.

__6. The project will appear under the Project Explorer view, expand it.
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Part 6 - Add Spring JARs with Maven
Most of the tools we will use from Eclipse are directly related to Spring or web 
applications.  The one area that is a little more general is how we will use Maven to 
obtain the Spring JARs for the project.  As more and more open source projects have 
become popular they often introduce dependencies from one project to another.  Maven 
can help manage these dependencies by getting automated information about them and 
use the Maven Eclipse plugin 'm2eclipse'.  Although Maven could also do more to 
manage builds and other aspects we will mainly use it to provide library JAR files as 
shown in this section.

__1. Right click the OEProject and select Configure → Convert to Maven Project.

__2. Change the Packaging drop-down to 'war'.

Note: Even though we will not use Maven to build the project we choose 'war' here as 
the type that would make sense if we were.

You could also define attributes of the project as a Maven library.  Since we will be 
focusing more on the features of Spring these won't really be important to us but they 
would be if you were using the Maven build process for your project.
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__3. Once your settings match that shown above click the Finish button.  The Maven 
POM file should open in an editor.

Unfortunately the Maven plugin also modifies some project properties that cause errors in 
the Eclipse build to appear.  We will fix those now.

__4. Right click the OEProject and select Properties.

__5. On the left side select Project Facets.

__6. Change the Java facet to 1.6 if it is not already.

__7. On the left select Java Compiler.

__8. On the right uncheck the box to allow project specific settings.

__9. Press the Apply button in the lower right (not the OK button) and confirm that you 
want to build.

__10. On the left select Java Build Path and select the Libraries tab on the right.

__11. Select the 'JRE System Library [J2SE-1.5]' from the list and click the Remove 
button on the far right.

__12. On the far right, click the Add Library button.
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__13. Select 'JRE System Library' and click the Next button.

__14. Leave the default option of 'Workspace default JRE' selected and click the Finish 
button.

__15. Make sure that the correct JRE library shows up in the list.

__16. Click the Source tab in the Java Build Path properties.

__17. If the list of source folders is empty, click the Add Folder... button.

__18. Check the 'src' folder of the OEProject and click the OK button.

__19. Check that the new source folder appears.
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__20. Change the 'Default output folder' at the bottom of the Source tab to 
'OEProject/WebContent/WEB-INF/classes'.

__21. Click the OK button to close the project properties.

Note: You must close the project properties for them to take effect for the next settings.

__22. Right click the OEProject and select Properties.

__23. On the left of the project properties dialog select 'Deployment Assembly'.

__24. Select the '/src/main/webapp' entry if it appears and press the Remove button.

__25. Press the Add button to the right of the list.

__26. Select 'Java Build Path Entries' and click the Next button.

__27. Select 'Maven Dependencies' and click the Finish button.

__28. Check that your final list appears as below.  Notice this will add the Maven 
dependencies we added to the 'lib' folder of the web project.
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Note: The 'Deployment Assembly' project properties are meant to replace the 'Module 
Dependencies' properties from previous Eclipse versions and turn it into a more generic 
mechanism for controlling how the project is built for deployment.  

The property you added will allow Maven dependencies to be packaged with the 
application for deployment but allow them to NOT be physically contained in the 
project to reduce the project size.  When combined with the features of Maven this is a 
perfect combination as Maven can manage a central repository of all the JARs that 
might be included in applications and developers can have their own repositories in 
addition to central repositories for teams.

__29. Click the OK button to close the project properties.

__30. Check in the Markers view that there are no errors reported.  There may be other 
messages listed in the view but make sure they are not errors.

Note: We need to fix some of the project properties because right now Maven expects 
that it would be doing everything for your project.  Future integrations of Maven and 
Eclipse may be easier to use features of both without some of these steps.

__31. Back in Eclipse make sure you still have the Maven pom.xml file for the project 
open. Open it again if not.

__32. In the editor switch to the 'Dependencies' tab at the bottom of the editor.

__33. Next to the empty list of Dependencies in the upper left, click the Add button.

__34. Enter 'context' in the search pattern box.
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__35. Expand the Spring library org.springframework.context and select the 3.0.5 
release version.

Note: This ability to search for a dependency is present because you have a local mirror 
repository.  If you had to download libraries remotely you might not have this easy 
search mechanism and might need to add the dependency manually.

__36. Once your settings match above click the OK button.

__37. Click the Add button again next to the dependencies.

__38. Enter 'web' in the search pattern box.

__39. Expand the org.springframework.web library and select the 3.0.5 release version.

__40. Once your settings match above click the OK button.

__41. Click the Add button again next to the dependencies.

__42. Enter 'logging' in the search pattern box.
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__43. Expand the Apache library that comes up and select the 1.1.1 release version.

__44. Once your settings match above click the OK button.

__45. Check that all three dependencies appear on the list.

Note: The 'context' bundle from Spring provides the support for the core Dependency 
Injection container which is the most popular feature of Spring so it is almost always 
declared.

The Spring 'web' bundle has some utility classes we would use to link our Spring 
configuration into a Servlet web application.

The Apache Commons Logging project is a popular logging framework.  This is one of 
the only external dependencies of the core of the Spring framework.  On some servers it 
might be required to include this JAR so we are including it here to make sure the 
application can compile.

__46. Save but don't close the file.
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__47. Select the Dependency Hierarchy tab along the bottom of the editor.  You should 
see various JARs that will be linked to the project because the dependencies you added 
require them.  You can even select them on the right and see the dependency chain.

__48. Close the pom.xml file.

__49. In the Project Explorer view, expand OEProject → Java Resources → 
Libraries → Maven Dependencies.  You should see the various JAR files added to the 
build path of the project.  Make sure the 'context' and 'web' JARs are in the list to make 
sure they will both be packaged with your project.
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Note: You may notice that the 'aopalliance' and 'commons.logging' JARs appear to be 
related to SpringSource even though it is not a Spring project.  This is because this 
version of the JAR is obtained through the SpringSource Enterprise Bundle Repository 
instead of the “central” Maven repository.  You can find out more info about this at:

https://ebr.springsource.com/repository/app/

http://blog.springsource.com/2009/12/02/obtaining-spring-3-artifacts-with-maven/

Part 7 - Create Spring Configuration File
Spring configuration is often read in from an XML Spring configuration file.  Even if 
much of Spring dependency injection is done through annotations you will need at least a 
little configuration in an XML file to bootstrap it.  In this section you will create a Spring 
configuration file based on the Spring XML schemas that Eclipse is aware of.

__1. Select Window → Open Perspective → Other.

__2. Select Spring and click the OK button.

__3. Right click the OEProject and select Spring Tools → Add Spring Project Nature.

Note: The Spring project nature is a way to add Spring tool features to a project.  It does 
not do everything for the setup of a Spring project so there are some additional steps to 
be done.
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__4. From the menu, select File -> New -> Spring Bean Configuration File.

Note: This option is available only if you are still in the 'Spring' perspective and not in 
the 'Java EE' perspective.

__5. Expand OEProject -> WebContent and select the WEB-INF folder as the parent 
folder. 

__6. Enter spring-beans.xml as File name.

__7. Click Next.

__8. Check the 'beans' namespace checkbox and press the Finish button.
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Note: Notice you could have also selected a specific Spring XML schema version.  If 
you do not the Spring tools will detect what schema version to use based on the version 
of the Spring JAR on the project classpath.

__9. Close all open files. (Ctrl+Shift+W)

Part 8 - Lab Cleanup
__1. Close the OEProject and OEProjectEAR projects as described in the 'Lab 
Cleanup' part of the 'Common Lab Preparation Steps'.

Part 9 - Review
In this lab you did several things that would be done to setup a project for using Spring. 
By configuring Maven to provide the Spring JAR files for the project and using the 
“Deployment Assembly” features of Eclipse to indicate that the Spring JARs should be 
included in the built project you can keep the actual size of the project small, introduce a 
new Spring version in the future relatively easily, and help automatically determine what 
other JAR files might be required when building Spring applications.
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Lab 2 - Defining and Using Spring Beans
The core of any Spring application revolves around defining and using Spring "Beans". 
These are Java components configured and managed by the Spring container.  This lab 
will show you how to obtain Spring beans from the container as well as various options 
for defining and configuring them.

Part 1 - Lab Setup
__1. Import the projects in the '<LABFILES>\Spring-Beans\Spring-Beans-Starter.zip' 
file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.

__2. Open the Spring perspective.

__3. In the Markers view check that you have only warnings and no errors.  If there are 
errors try a Project → Clean to rebuild the project.

Part 2 - Examine Existing Classes
A few basic classes have been provided for you.  

__1. Open ProductCodeGenerator.java under Spring-Beans → src → 
com.webage.bean package.

Notice that this is just a regular Java interface for a Java component that will generate a 
"Product code" and return it as a String.  It is typical for Spring components to implement 
Java interfaces to provide flexibility in the code.

__2. Open BasicProductCodeGenerator.java under Spring-Beans → src → 
com.webage.bean package.

Notice that this class has a few properties, the get/set methods for those properties, a few 
constructors, and the implementation of the 'getNextProductCode' method from the 
interface.  In the implementation of this method the properties are used to generate the 
code.  Although the properties have default values you will see later how setting them to 
different values will generate different product codes.  This is one way we will judge the 
impact of the Spring configuration.
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__3. Open ProductCodeGeneratorTest.java under Spring-Beans → src → 
com.webage.test package.

Notice that this code creates a ProductCodeGenerator implementation and then uses it to 
print out a few product codes.  The problem with this code right now is that even though 
the local variable uses the interface type to define the variable the constructor of the 
implementing class is called.  This does not provide flexibility to use a different 
implementation very easily in the future.  One way to address this problem is to apply the 
"Factory" design pattern which is what Spring will do for us.

ProductCodeGenerator generator = 
new BasicProductCodeGenerator("WA", "10");

__4. With the ProductCodeGeneratorTest class still open in the editor select Run → 
Run As → AspectJ/Java Application from the Eclipse menus.

Note: If you get an error when trying to run the code it is likely because you selected 
Run As → Java Application which does not seem to work.  This option does not seem 
to add the project code to the classpath and therefore can't run the application.

If this happens it is best to select Run → RunConfigurations so you can delete the 
incorrect run configuration so it won't cause problems in the future.

__5. Make sure that you get the following in the Console view when the class generates 
some basic product codes.  You should be able to figure out how the properties of the 
'BasicProductCodeGenerator' were used to generate these codes.
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Part 3 - Retrieve Component from Spring
The first step in using Spring is to modify the code to retrieve the component from the 
Spring container.  This will be done with the Spring ApplicationContext interface.  You 
will also supply an XML configuration file to configure this Spring environment.

__1. Make sure you have the code of the  ProductCodeGeneratorTest class open in the 
editor and open it if it is not.

__2. At the start of the 'main' method add the following as the first lines of code.  You 
will have errors until the next step.  This code will define the Spring container or 
"context" that will be used and indicate that the configuration will be in an XML file.

public static void main(String[] args) {
     ApplicationContext context = new
          ClassPathXmlApplicationContext("spring-beans.xml");
     ProductCodeGenerator generator = 
          new BasicProductCodeGenerator("WA", "10");

__3. Organize imports by selecting Source → Organize Imports.

__4. Modify the code that initializes the 'generator' variable with the code in bold below. 
Notice that instead of calling the constructor the code will get the component from the 
Spring environment.

ApplicationContext context = new ClassPathXmlApplicationContext(
"spring-beans.xml");

ProductCodeGenerator generator = context.getBean("generator",
ProductCodeGenerator.class);

__5. Save changes.

__6. Make sure you are in the Spring perspective and use the Window → Open 
Perspective → Other menu if needed.

__7. Select the Spring-Beans → src folder by clicking it.

__8. Select File → New → Spring Bean Configuration File.
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__9. Enter a file name of spring-beans.xml and make sure the parent folder is 
'Spring-Beans/src' before clicking the Finish button.

__10. On the Spring configuration editor that opens select the 'beans' tab along the 
bottom.

__11. Click the 'New Bean..' button in the 'Beans Overview' area.

__12. Enter a value of 'generator' for the 'id' property but don't yet finish the dialog. This 
will be the name of the bean retrieved from the Spring container.

__13. Press the Browse button for the class, type a few letters of the 
BasicProductCodeGenerator class until it is selected and then click the OK button.

__14. Check that your dialog is filled in as shown below and click the Finish button.

Note: If you went to the next page there are ways to add constructor arguments but this 
part of the dialog appears to throw Eclipse Exceptions.  We can add this manually.
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__15. In the 'Beans Overview' section, right click the 'generator' bean and select Insert 
<constructor-arg> element.

__16. With the new constructor-arg element still selected fill in a 'value' of 'WA' without 
the quotes as shown below.

__17. Right click the 'generator' bean again and select Insert <constructor-arg> 
element.

__18. For the second constructor-arg element fill in a value of '10' without the quotes.

__19. Check that your bean definition appears as shown below in the 'Beans Overview' 
section.  Notice that the id of the bean and the value of the constructor arguments is 
shown to make it easier to read.

__20. Save the file.
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__21. From the menus select Run → Run History → ProductCodeGeneratorTest. 
There may be other things listed but this should be the only entry with that name.

__22. Check that in the Console view, after a few Spring messages, you see the same 
product codes printed.  You get the same product codes because even though you are 
getting the generator from the Spring container it was configured just as it was before.

Note: Sometimes when you run the code you may see the Spring messages after the 
messages from the application code.  This is OK and is likely due to buffered output.

Part 4 - Resolve Constructor Arguments
Right now the application works because there is only one constructor that has two 
arguments.  If another constructor is added with two constructors something must 
indicate which one to call.

__1. Open BasicProductCodeGenerator.java under Spring-Beans → src → 
com.webage.bean package.

__2. Add the following new constructor making sure to add the code within the class 
definition curly brackets but outside of other methods or constructors.

public BasicProductCodeGenerator(String prefix, int current) {
super();
this.prefix = prefix;
this.current = current;

}

__3. Save the file.
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__4. From the menus select Run → Run History → ProductCodeGeneratorTest.

__5. Notice that in the Console view, the same output is generated.  This is because the 
code is still calling the constructor with two Strings since that is the type that Spring will 
assume for constructor-arg values.

__6. Return to the editor for the 'spring-beans.xml' file.

__7. Select the second constructor-arg element with the value of '10'.

__8. In the 'type' attribute enter a value of 'int' without the quotes.  You may need to 
maximize the editor or move the divider between the two sides to see the value well.

__9. Save the file.

__10. From the menus select Run → Run History → ProductCodeGeneratorTest.
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__11. Notice now that the output is different.  This is because the Spring bean is now 
defined to use the constructor that sets the initial 'current' value and not the suffix.  This is 
because the constructor-arg was configured to be an 'int'.

Part 5 - Configure Beans with Properties
Besides configuring Spring to call constructors you can also have Spring call the 
"default" no-argument constructor and then set properties.  This can provide more 
flexibility since you do not need a constructor to match every way a bean can be 
configured.

__1. Return to the editor for the 'spring-beans.xml' file.
__2. Click the 'Source' tab at the bottom of the editor.
__3. Modify the definition of the bean to remove the <constructor-arg> elements and 
replace them with <property> elements as shown in bold below.

<bean id="generator" 
class="com.webage.bean.BasicProductCodeGenerator">
<property name="prefix" value="WA"></property>
<property name="current" value="15"></property>
<property name="suffix" value="XL"></property>
<property name="increment" value="5"></property>

</bean>

__4. Save the file.
__5. In the editor select the 'beans' tab along the bottom.
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__6. Notice that the visual overview of the bean has changed since the properties are 
added instead of constructor arguments.  Select some of the properties if you want to see 
how they are defined in the editor.  In the future only source code may be given to 
simplify lab instructions although the editor is often easier to use to ensure correct syntax.

__7. From the menus select Run → Run History → ProductCodeGeneratorTest.

__8. Notice now that the output is different.  This is because the Spring bean is 
configured with different values for the properties.  This causes the generated product 
codes to be different which proves Spring is setting the properties of the Spring bean.

Part 6 - Configure Properties with 'p' Schema
Besides using child <property> elements it is also possible to set property values using 
attributes on the main <bean> element with the 'p' schema.  This reduces the amount of 
text required to set a property.

__1. Return to the editor for the 'spring-beans.xml' file.
__2. Click the 'Namespaces' tab at the bottom of the editor.

Copyright 2013 Web Age Solutions Inc. 51

EVALUATIO
N O

NLY



__3. Check the 'p' namespace as shown below and click the OK button on the dialog that 
appears when you do.

__4. Click the 'Source' tab at the bottom of the editor.
__5. Modify the bean definition so that instead of having nested <property> element tags 
there are 'p:..' attributes with the name of the property and the value.  Make sure that you 
put these new 'p:..' attributes within the brackets for the start <bean ..> tag.  Notice the 
property values are a little different and not all are present so it will be easy to tell the 
settings are taking effect.  Also make sure to remove the nested <property> tags.

<bean id="generator" class="com.webage.bean.BasicProductCodeGenerator"
p:prefix="WS" p:current="200" p:increment="10">

</bean>

__6. Save the file.
__7. In the editor select the 'beans' tab along the bottom.
__8. Notice that the visual overview of the bean has changed and you do not see the 
properties that are set by the 'p:..' attributes.  Even though the visual editor doesn't give 
support for the 'p:..' attributes the source code editor does have code completion that you 
can access by typing CTRL-SPACE after typing 'p:' to enter the attribute name.
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__9. From the menus select Run → Run History → ProductCodeGeneratorTest.

__10. Notice now that the output is different.  This is because the Spring bean is 
configured with different values for the properties even though they are configured with 
the 'p:..' attribute syntax.  If the property values had been the same the output would be 
the same as there is no difference in supplying basic property values with either method.

Note: Even though there is no difference in basic properties the 'p:..' attribute syntax 
does not have as many options for multi-valued properties or other things the nested 
<property> elements can do.

Part 7 - Observe Effect of Bean Scope
One important aspect of Spring beans to keep in mind is what "scope" the bean is defined 
at.  If you do not set a scope the default scope of "singleton" is used.  This may impact 
the behavior of the application so it is important to know how the scope of the bean can 
impact the behavior so your application can be made to behave the way you want.

__1. Open ProductCodeGeneratorTest.java under Spring-Beans → src → 
com.webage.test package if it is not already open in an editor.
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__2. Add the following code in bold to the end of the 'main' method.  Notice that this 
initializes a second variable that refers to a 'generator' but that the name of the Spring 
bean retrieved is the same as the other variable that was initialized.

System.out.println("Generator: " +
generator.getNextProductCode());

ProductCodeGenerator generator2 =
context.getBean("generator",
ProductCodeGenerator.class);

System.out.println("Generator2: " +
generator2.getNextProductCode());

System.out.println("Generator2: " +
generator2.getNextProductCode());

System.out.println("Generator2: " +
generator2.getNextProductCode());

}

__3. Save the file and make sure there are no errors.

__4. From the menus select Run → Run History → ProductCodeGeneratorTest.

__5. Notice in the output that the product codes keep incrementing without starting over 
for the second 'generator'.  This is because the scope of the 'generator' bean is "singleton" 
and both variables in the 'main' method refer to the same generator object.
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__6. Return to the editor for the 'spring-beans.xml' file.  Open it again if you had closed 
the file.
__7. Click the 'beans' tab at the bottom of the editor.
__8. Select the 'generator' bean from the left and scroll on the right until you see the 
'scope' setting.
__9. Use the drop-down for the scope setting to select a scope of 'prototype' as shown 
below.

__10. Save the file once the 'scope' setting is changed.

__11. From the menus select Run → Run History → ProductCodeGeneratorTest.

__12. Notice the output now is different and the second 'generator' bean starts the product 
codes over.

Note: This behavior is because the 'prototype' scope for a Spring bean indicates to 
Spring that a new bean should be created every time the 'getBean' method is called. 
With the default 'singleton' scope, Spring keeps a record of the objects that have been 
returned for certain bean names and returns the same object for future requests that use 
the same Spring bean name.
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Part 8 - Lab Cleanup
__1. Delete the ProductCodeGeneratorTest run configuration from the AspectJ/Java 
Application run configurations as described in the 'Common Lab Preparation Steps' at the 
'Lab Cleanup' part.

__2. Close the Spring-Beans project as described in the 'Common Lab Preparation Steps' 
at the 'Lab Cleanup' part.

Part 9 - Review
In this lab you saw many different ways to define Spring beans with XML.  You can use 
constructor arguments, set properties, and use the 'p' attribute schema depending on the 
code in the Java component you have available.  You also saw the effect of bean scope to 
make sure that an application behaves the way you want if a Spring component is 
retrieved more than once.
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Lab 3 - Advanced Spring Bean Definition
Besides defining Spring beans with XML there are other ways to define Spring beans. 
You can define Spring beans with annotations in the Java code which can greatly simplify 
the XML configuration.  You can also establish bean inheritance and externalize Spring 
bean configuration properties into property files.

Part 1 - Lab Setup
__1. Import the projects in the 
'<LABFILES>\Spring-BeanAnnotations\Spring-BeanAnnotations-Starter.zip' file as 
described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.

__2. Open the Spring perspective.

__3. In the Markers view check that you have only warnings and no errors.  If there are 
errors try a Project → Clean to rebuild the project.

Part 2 - Examine Existing Classes
A few basic files have been provided for you.  

__1. Open BasicProductCodeGenerator.java under Spring-BeanAnnotations → src 
→ com.webage.bean package.

Notice that this class has a few properties, the get/set methods for those properties, a few 
constructors, and the implementation of the 'getNextProductCode' method from the 
interface.  In the implementation of this method the properties are used to generate the 
code.  

__2. Open spring-beans.xml under the Spring-BeanAnnotations → src folder.
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Notice this Spring configuration file defines a 'generator' Spring bean and sets some of 
the properties.  This file uses the 'p' attribute property syntax although the effect would be 
the same if nested <property> elements were used.

<bean id="generator"
class="com.webage.bean.BasicProductCodeGenerator"
p:prefix="WS" p:current="200" 
p:increment="10" scope="prototype">

</bean>

__3. Open ProductCodeGeneratorTest.java under Spring-BeanAnnotations → src → 
com.webage.test package.

Notice that this code creates a Spring ApplicationContext based on the configuration file, 
retrieves the 'generator' bean, and then uses the bean to output a few product codes.  The 
'generator' bean is retrieved twice to observe the effects of the bean scope.

__4. With the ProductCodeGeneratorTest class still open in the editor select Run → 
Run As → AspectJ/Java Application from the Eclipse menus.

Note: If you get an error when trying to run the code it is likely because you selected 
Run As → Java Application which does not seem to work.  This option does not seem 
to add the project code to the classpath and therefore can't run the application.

If this happens it is best to select Run → RunConfigurations so you can delete the 
incorrect run configuration so it won't cause problems in the future.
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__5. Make sure that you get the following in the Console view when the class generates 
some basic product codes.  You should be able to figure out how the properties of the 
'BasicProductCodeGenerator' were used to generate these codes.  Also notice the effect of 
the bean scope of "prototype" as the product codes start over for the second 'generator' 
bean retrieved.  If the bean had been of "singleton" scope the codes from the second 
'generator' bean variable would have continued instead of started over.

Part 3 - Define Spring Beans with Annotations
Although defining Spring beans with XML is one option it is also possible to place 
certain annotations in the Java code that will also enable the creation of Spring beans.

__1. Open BasicProductCodeGenerator.java under Spring-BeanAnnotations → src 
→ com.webage.bean package.

__2. Add the following annotation on the class definition.  You will have errors until a 
following step.

@Component("generator")
public class BasicProductCodeGenerator 

implements ProductCodeGenerator {

Note: The default name of a Spring bean when you define it with annotations is the 
same as the class name.  Since our code currently looks up the bean using the 'generator' 
name the value of the @Component annotation is set to match this.

__3. Organize imports by selecting Source → Organize Imports.

__4. Save the file and make sure there are no errors.

__5. Return to the editor for the 'spring-beans.xml' file.  Open it again if you closed it.
__6. Click the 'Source' tab at the bottom of the editor.
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__7. Add comments around the current bean definition as shown below.  When you enter 
the start of the comment Eclipse will automatically add an end tag immediately after so 
you will have to delete this to add it back later in the file but before the ending </beans> 
tag.  Check that the bean definition is in blue so it is marked as a comment.

<!-- 
<bean id="generator"

class="com.webage.bean.BasicProductCodeGenerator"
p:prefix="WS" p:current="200" 
p:increment="10" scope="prototype">

</bean>
 -->

</beans>

__8. Click the 'Namespaces' tab at the bottom of the editor.
__9. Check the 'context' namespace as shown below and click the OK button on the 
dialog that appears when you do.

__10. Click the 'context' tab at the bottom of the editor.

__11. In the 'Context Overview' section, right click the 'beans' element in the empty list 
and select Insert <context:component-scan> element.
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__12. With the new 'component-scan' element selected fill in the value for the 'base-
package' attribute with the value of 'com.webage.bean'.  This package contains the bean 
that had the @Component annotation added.

__13. Save the file.

__14. Click the 'Beans Graph' tab at the bottom of the editor.

__15. Notice that the editor has detected that there will be a Spring bean named 
'generator' defined from the annotation component scanning you just enabled.

Note: This feature can be very useful because it can let you define beans by annotation 
which will simplify the XML but still determine what Spring beans are defined.  This 
addresses the concern with annotations that Spring bean definitions are "hidden" in the 
Java code unlike XML configuration where it is obvious.

__16. From the menus select Run → Run History → ProductCodeGeneratorTest.
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__17. Notice that even though the values of the product code generator changed because 
they are being set in the Java code and not by the XML the more important aspect is that 
the second generator is continuing the same sequence of product codes as the first 
'generator' bean retrieved.  This is because we have removed the 'scope' setting that was 
set using XML and are back to using the default of 'singleton' scope.

__18. Return to the editor for the BasicProductCodeGenerator.java file.  Open it again 
if you closed it.

__19. Add the following annotation on the class definition.  You will have errors until a 
following step.

@Component("generator")
@Scope("prototype")
public class BasicProductCodeGenerator 

implements ProductCodeGenerator {

__20. Organize imports by selecting Source → Organize Imports.

__21. Save the file and make sure there are no errors.

__22. From the menus select Run → Run History → ProductCodeGeneratorTest.

__23. Notice that you are now back to where the second code generator will start over 
from the beginning because the 'prototype' scope is in effect.
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__24. Return to the editor for the 'spring-beans.xml' file.
__25. Click the 'Source' tab at the bottom of the editor.
__26. Add the following bean definition with XML.  Make sure it is nested properly as a 
child element of the <beans> tag but outside any other tag or comment.

<bean id="generator" class="com.webage.bean.BasicProductCodeGenerator">
<property name="current" value="100"></property>

</bean>
<context:component-scan base-package="com.webage.bean">
</context:component-scan>

Note: Since this bean definition has the same id as that used by the annotation this will 
end up overriding the 'current' property and changing the output of the generated codes.

__27. Save the file.

__28. From the menus select Run → Run History → ProductCodeGeneratorTest.

__29. Notice that even though the values of the product code generator changed and are 
starting from 100 as overridden in the XML we are back to the codes not starting over 
with the second generator so obviously the singleton scope is in effect again.

Note: This behavior is because the XML definition overrides the annotation including 
the scope setting.  Even though there is no scope setting in the XML the lack of any 
setting means that the scope annotation is ignored and the default of singleton is applied 
by the XML schema.

__30. Modify the XML bean definition to include the 'scope' annotation set to a 
'prototype' value as shown below.

<bean id="generator" class="com.webage.bean.BasicProductCodeGenerator"
scope="prototype">
<property name="current" value="100"></property>

</bean>

__31. Save the file.
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__32. From the menus select Run → Run History → ProductCodeGeneratorTest.

__33. Notice that you are now back to where the second code generator will start over 
from the beginning because the 'prototype' scope is in effect.  You are also using the new 
starting point value set by the XML in combination with the other default values 
initialized in the Java code.

Part 4 - Using Standard JSR-330 Annotations
One of the downsides of the annotations in the previous section is they come from the 
Spring framework.  Often the goal is to write Java code that does not have any link to the 
Spring framework and these annotations violate that goal.  Even though this is only one 
class in your project it would be worse if you had dozens or even hundreds of Spring 
components declared this way.

The JSR-330 Java specification defines a set of standard annotations for dependency 
injection.  Spring recognizes these standard annotations and we can use those annotations 
to define Spring beans to avoid mentioning Spring directly in our Java code.

__1. Open the pom.xml file from the root of the 'Spring-BeanAnnotations' project.

__2. Switch to the source of the pom.xml by selecting the 'pom.xml' tab along the 
bottom of the editor.  You might need to look for some tabs that are hidden on the far 
right side and expand those to select the proper view.

__3. Find the section that is commented out (<!-- .. -->) that has the dependencies for the 
JSR-330 (javax.inject) libraries.  Remove the comment tags from before and after this 
section so the library is an active dependency. 

<dependency>
<groupId>javax.inject</groupId>
<artifactId>com.springsource.javax.inject
</artifactId>
<version>1.0.0</version>

</dependency>
</dependencies>
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__4. Save the file and be sure there are no red errors in the margin for the file.  These will 
occur if you don't remove the comment tags properly.

__5. Close the pom.xml file.

__6. Return to the editor for the BasicProductCodeGenerator.java file.  Open it again if 
you closed it.

__7. Comment out the Spring @Component and @Scope annotations and add the 
@Named annotation as shown below.  Note that we will give the bean a different name to 
easily avoid the XML overridden configuration.

//@Component("generator")
//@Scope("prototype")
@Named("namedGenerator")
public class BasicProductCodeGenerator 

implements ProductCodeGenerator {

__8. Organize imports by selecting Source → Organize Imports.

__9. Save the file and make sure there are no errors.

__10. Return to the editor for the ProductCodeGeneratorTest.java file.  Open it again if 
you closed it.

__11. Modify the name of the bean used in the 'getBean' method as shown below.  Make 
sure you change both locations the method is used.  This will find our bean defined with 
the JSR-330 @Named annotation.

ProductCodeGenerator generator = context.getBean("namedGenerator",
ProductCodeGenerator.class);

System.out.println("Generator: " + generator.getNextProductCode());
System.out.println("Generator: " + generator.getNextProductCode());
System.out.println("Generator: " + generator.getNextProductCode());

ProductCodeGenerator generator2 = context.getBean("namedGenerator",
ProductCodeGenerator.class);

System.out.println("Generator2: " + generator2.getNextProductCode());

__12. Save the file and make sure there are no errors.

__13. From the menus select Run → Run History → ProductCodeGeneratorTest.
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__14. Notice that the code does "work" because it finds a bean by that name and doesn't 
throw an Exception.  The problem is we are back to the singleton scope behavior for the 
bean where the second generator does not restart the generated code sequence.

Part 5 - Defining a Custom Component Stereotype Annotation
Unfortunately we are back to the singleton behavior instead of the 'prototype' behavior. 
At this point we need to figure out how to proceed.

Adding the Spring @Scope annotation would violate the goal of not having any Spring 
code or annotations directly in the code of the Java component.  JSR-330 also describes a 
@Scope annotation but it is not used the same way.  The JSR-330 @Scope annotation is 
meant for defining custom scope annotations for processing by a dependency injection 
framework.  Unfortunately Spring 3.0 currently doesn't support that approach and even if 
it did it would just be another Spring annotation and would not allow us to avoid Spring 
annotations in the Java component.

A third approach can be taken which is to define our own custom annotation for applying 
Spring component qualities (like scope) to Java components in the application.  These 
custom annotations will contain Spring annotations but will allow us to avoid Spring 
annotations in the components themselves.  Using this approach the Java components 
will have only standard Java annotations and/or our custom annotations which will be 
part of the application.  The "dependence" on the Spring framework is also now isolated 
to the custom annotation and if in the future the application doesn't use Spring we would 
only need to redefine the custom annotation.

__1. Right click the Spring-BeanAnnotations → src folder and select New → 
Annotation.
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__2. Fill in a name of AppComponent and a package of 'com.webage.annotation' for 
the annotation and click the Finish button.

__3. Modify the code by adding the following lines.  You will have errors until the next 
step.

@Target(ElementType.TYPE)
@Retention(RetentionPolicy.RUNTIME)
@Documented
@Service
@Scope("prototype")
public @interface AppComponent {

Note: The annotations @Service and @Scope are the only Spring annotations.  The 
other annotations are part of the Java annotation API and determine where the custom 
annotation can be used (@Target) and when the annotation is processed (@Retention).

__4. Organize imports by selecting Source → Organize Imports.  When prompted 
select the 'org.springframework.context.annotation.Scope', click the Next button, 
select the 'java.lang.annotation.ElementType' and click the Finish button.

__5. Save the file and make sure there are no errors.

__6. Return to the editor for the BasicProductCodeGenerator.java file.  Open it again if 
you closed it.
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__7. Add the new custom annotation to the declaration of the class.  Make sure the Spring 
annotations remain commented out or deleted.  You will have errors until the next step.

//@Component("generator")
//@Scope("prototype")
@Named("namedGenerator")
@AppComponent
public class BasicProductCodeGenerator 

implements ProductCodeGenerator {

__8. Organize imports by selecting Source → Organize Imports.  

__9. Save the file and make sure there are no errors.

__10. From the menus select Run → Run History → ProductCodeGeneratorTest. 
Notice that the prototype behavior is back since the second generator starts over at the 
initial value.

Part 6 - Bean Inheritance
Often you may have application components that are based on the same Java class but 
differ only in the value of some properties.  To reuse the greatest amount of the Spring 
bean definition it is often desired to inherit the Spring bean definitions and simply modify 
the properties that are different.

__1. Return to the editor for the 'spring-beans.xml' file.  Open it if you had closed it.
__2. Click the 'Source' tab at the bottom of the editor.
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__3. Add the following bean definition with XML.  Make sure it is nested properly as a 
child element of the <beans> tag but outside any other tag or comment.

<bean id="generator" class="com.webage.bean.BasicProductCodeGenerator"
 scope="prototype">
<property name="current" value="100"></property>

</bean>
 

<bean id="altPrefixGenerator" parent="generator">
<property name="prefix" value="ALT"></property>

</bean>
<context:component-scan base-package="com.webage.bean">
</context:component-scan>

Note: The 'generator' bean does not use a prefix but this inherited bean does.  We will 
know it works if the prefix shows up in the generated codes.

__4. Save the file.
__5. Click the 'Beans Graph' tab at the bottom of the editor.

__6. Notice that the editor has detected the bean inheritance and used a dashed arrow to 
indicate the relationship.  In this picture though the 'altPrefixGenerator' is shown above 
which would imply it is the parent so remember that the arrow points from the inheriting 
bean to the bean it inherits from.
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__7. Return to the editor for the ProductCodeGeneratorTest.java file.  Open it again if 
you closed it.

__8. Modify the name of the bean used in the 'getBean' method as shown below.  Make 
sure you change both locations the method is used.  This will find the bean definition that 
is defined with inheritance.

ProductCodeGenerator generator = context.getBean("altPrefixGenerator",
ProductCodeGenerator.class);

System.out.println("Generator: " + generator.getNextProductCode());
System.out.println("Generator: " + generator.getNextProductCode());
System.out.println("Generator: " + generator.getNextProductCode());

ProductCodeGenerator generator2 = context.getBean("altPrefixGenerator",
ProductCodeGenerator.class);

System.out.println("Generator2: " + generator2.getNextProductCode());

__9. Save the file and make sure there are no errors.

__10. From the menus select Run → Run History → ProductCodeGeneratorTest.  

__11. Notice that the prefix appears so it is using the inherited bean definition.  The scope 
setting is also inherited since this test shows the prototype behavior where the code 
restarts with the second generator.

Part 7 - Externalize Spring Configuration
Often some elements of the Spring configuration may change, often as the application is 
deployed in different environments.  Although it might be possible to have multiple 
Spring configuration files this might too often repeat too much of the Spring 
configuration allowing for the chance to have differences between multiple files.

The best solution is to externalize the configuration that is different into a file like a 
properties file and then refer to these properties.  This will reuse as much of the Spring 
configuration as possible but still allow for easily changing Spring configuration 
properties.
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__1. Select the Spring-BeanAnnotations → src folder by clicking it.

__2. Select File → New → File.

__3. Enter a file name of generator.properties and make sure the parent folder is 
'Spring-BeanAnnotations/src' before clicking the Finish button.

__4. Add the following property definitions in the property file.  The keys before the 
equals sign are important as these will be the property names used in the Spring 
configuration file.

generator.basePrefix=WA
generator.altPrefix=TOY
generator.initialCount=500
generator.defaultIncrement=5

__5. Save the file.

__6. Return to the editor for the 'spring-beans.xml' file.  Open it again if you closed it.
__7. Click the 'context' tab at the bottom of the editor.
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__8. In the 'Context Overview' section, right click the 'beans' element  and select Insert 
<context:property-placeholder> element.

__9. With the new 'property-placeholder' element selected fill in the value for the 
'location' attribute with the value of 'generator.properties'.  This is the location of the 
new properties file is located on the classpath of the project.

__10. Click the 'Source' tab at the bottom of the editor.
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__11. Modify the properties of the Spring bean definitions to use the property values. 
Notice there are also some new properties added to the 'generator' bean to show setting 
several bean properties with the property file.

<bean id="generator" class="com.webage.bean.BasicProductCodeGenerator"
scope="prototype">
<property name="current" value="${generator.initialCount}">
</property>

 <property name="prefix" value="${generator.basePrefix}">
</property>

 <property name="increment" 
value="${generator.defaultIncrement}"></property>

</bean>
 

<bean id="altPrefixGenerator" parent="generator">
<property name="prefix" value="${generator.altPrefix}">
</property>

</bean>

__12. Save the file.

__13. Return to the editor for the ProductCodeGeneratorTest.java file.  Open it again if 
you closed it.

__14. Modify the name of the bean used in the first 'getBean' method as shown below. 
This will show the codes generated by both Spring bean definitions and see how the 
properties are set with the external properties file.

ProductCodeGenerator generator = context.getBean("generator",
ProductCodeGenerator.class);

System.out.println("Generator: " + generator.getNextProductCode());
System.out.println("Generator: " + generator.getNextProductCode());
System.out.println("Generator: " + generator.getNextProductCode());

ProductCodeGenerator generator2 = context.getBean("altPrefixGenerator",
ProductCodeGenerator.class);

__15. Save the file and make sure there are no errors.

__16. From the menus select Run → Run History → ProductCodeGeneratorTest.  
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__17. Notice that the code generators behave as expected even though the properties are 
defined by the external property file.

__18. Close all open files.

Part 8 - Lab Cleanup
__1. Delete the ProductCodeGeneratorTest run configuration from the AspectJ/Java 
Application run configurations as described in the 'Common Lab Preparation Steps' at the 
'Lab Cleanup' part.

__2. Close the Spring-BeanAnnotations project as described in the 'Common Lab 
Preparation Steps' at the 'Lab Cleanup' part.

Part 9 - Review
In this lab you saw advanced ways to define Spring beans.  You can do this with a few 
different types of Java annotations.  There are annotations that are specific to Spring and 
also annotations defined as part of the JSR-330 Java specification for dependency 
injection annotations.  You even saw a way to avoid Spring annotations directly in the 
Java component and isolate the Spring annotations in custom annotations defined as part 
of your application.  Finally you saw how to externalize settings for Spring components 
that might change into external properties files using the "Property Placeholder" feature 
of Spring.
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	Lab 1 -  Setup Eclipse for Spring 3 with WebSphere 8
	Part 1 -  Configure WebSphere Profile
	__1.  From the Windows Start menu select 'Start → Programs → IBM WebSphere → WebSphere Application Server V8.0 → Tools → Profile Management Tool'.
	__2.  Press the Create button next to the list of profiles.
	__3.  In the Environment Selection dialog, select the option for Application Server and press the Next button.
	__4.  Select the option for Advanced profile creation and press the Next button.
	__5.  Leave the default option to deploy the administrative console and default application and press the Next button.
	__6.  Leave the default profile name and note the value for later in Eclipse.  Leave the default profile directory which should be a directory NOT in the 'Program Files' directory.  If the profile directory does include the 'Program Files' directory remove it as shown below.  Also change the option for 'Server runtime performance tuning setting' to Development as shown below.
	__7.  Once all of your profile settings match that shown above click the Next button.
	__8.  Leave the default Node, Host and Cell names.  Press the Next button.
	__9.  Uncheck the box for Enable administrative security and press the Next button.
	__10.  In the first page of security certificate options, leave the default to create a new default personal certificate.  Press the Next button.
	__11.  On the second page of security certificate options again leave the defaults and press the Next button.
	__12.  In the Port values assignment page, click the Default Port Values button to use default ports for the profile and click Next.
	__13.  If prompted to run the application server as a Windows process uncheck the option as shown below and click the Next button.
	__14.  Leave the option to create a web server unchecked and click the Next button.
	__15.  Press Create in the Summary page to begin profile creation. 
	__16.  When the profile creation is complete, uncheck the option for launching the First Steps console and press the Finish button.
	__17.  Select File → Exit for the Profile Management Tool.

	Part 2 -  Launch Eclipse
	__1.  If you had already launched Eclipse, close it.  Eclipse must be shut down to pick up changes in the startup options.
	__2.  Open a Windows Explorer window and navigate to <SOFTWARE>\eclipse
	__3.  Find the ‘eclipse.ini’ file and right click on the file and select Properties.  The extension may be hidden and just list the file type as ‘Configuration Settings’. 
	__4.  Check that the file is not read only and uncheck the box if it is.  Close the file properties after making sure the file isn't read only.
	__5.  Open the eclipse.ini file with a text editor.  
	__6.  Once you have the file open, add the following two new lines to the start of the file, making sure not to put extra spaces at the end of the lines:
	__7.  Save the file when it is like above.  Make sure when you save it the file extension is not changed. 
	__8.  Close the eclipse.ini file.
	__9.  Launch Eclipse by double clicking on <SOFTWARE>\eclipse\eclipse.exe.  You may want to add a shortcut to this to the desktop.
	__10.  Change the workspace location to C:\workspace if it is not already and click OK.
	__11.  Click the Reject button on the 'User Agent Analysis' dialog if it appears.
	__12.  Close the Welcome or Dashboard pages if they appear.

	Part 3 -  Configure WebSphere Server in Eclipse
	__1.  Select Window → Preferences from the menus.
	__2.  Select Server → Runtime Environments in the preferences.
	__3.  Click the Add button.
	__4.  From the list expand IBM and select WebSphere Application Server v8.0.  Also check the box to 'Create a new local server' as this will perform all needed tasks during this wizard.
	__5.  Click Next.
	__6.  Click the Browse button next to Installation Directory and navigate to C:\IBM\WebSphere\AppServer and then click OK.
	__7.  Once your settings match those shown below click the Next button.
	__8.  Make sure the appropriate profile is selected, which should be 'AppSrv01', leave the other settings as the default and click the Finish button.
	__9.  Back in the Eclipse preferences, click the OK button to close the preferences.
	__10.  If it was not automatically selected, select the Servers view along the bottom and check that the new WebSphere server is shown.
	__11.  Right click on the Server and select Open.
	__12.  Expand Publishing on the right.
	__13.  Select Never publish automatically.
	__14.  Expand Timeouts.
	__15.  Change the Start (in seconds) to 600
	__16.  Expand the 'Publishing settings for WebSphere Application Server' and select the 'Run server with resources on Server' option.
	__17.  Save the changes and close the window.
	__18.  In the Servers view, right click the 'WebSphere Application Server v8.0' and select Start.  The server will print several messages when starting.
	__19.  Switch back to the Servers view and check that the server starts successfully.
	__20.  Right click the server and select Stop.

	Part 4 -  Configure Maven Mirror
	__1.  From the Eclipse menus select Window → Preferences.
	__2.  Select Maven → Installations from the left.  Notice that Eclipse is aware of an external installation of Maven which was delivered as part of the software for the class.
	__3.  Note the location of the 'settings.xml' file for the external Maven installation that is installed.  We will use this file as a template in a little bit.
	__4.  Open a Windows Explorer window.  Leave Eclipse and the preferences open.
	__5.  Navigate to the location of the external Maven settings file you saw in the previous step.
	__6.  Copy the 'settings.xml' file which should be the only file in the folder.
	__7.  Navigate to the '<LABFILES>\Setup' folder.  
	__8.  Paste the file into this folder.  There is also a solution file in the 'Solution' folder you can use if you want.
	__9.  Edit the file with a text editor like WordPad or NotePad.  If you just try to double click it will likely open in a browser which won't let you edit.
	__10.  In the file find the section for 'mirrors'.  This should have a sample mirror definition commented out so there are actually no mirrors defined.
	__11.  Add the following mirror definition being careful it is outside the comment but inside the <mirrors> tag.
	__12.  Save the file and close the editor for the settings.xml file.
	__13.  Back in Eclipse, select Maven → User Settings from the left of the preferences.  Open the preferences again if you closed them.
	__14.  Next to the user settings file press the Browse button.
	__15.  Navigate and select the 'settings.xml' file that you edited in the '<LABFILES>\Setup' folder.  Check that your location is updated as shown below.
	__16.  Press the Update Settings button to be sure the settings are loaded.
	__17.  Click  the OK button to close the preferences dialog.
	__18.  Select Window → Show View → Other from the Eclipse menus.
	__19.  Select the Maven → Maven Repositories view and click the OK button.
	__20.  In the view that appears at the bottom expand the 'Global Repositories' entry and be sure you see the 'local' repository listed.  Notice it also is overriding the normal 'central' repository of Maven from the internet.
	__21.  Right click the 'localMirror' global repository and select 'Rebuild Index'.  Confirm that you want to rebuild.  This will make sure all library information is available.

	Part 5 -  Create a Web Project
	__1.  From the menu select File -> New -> Dynamic Web Project.
	__2.  Enter OEProject as Project name.
	__3.  Check that the 'Target runtime' is WebSphere 8.0 which should be the default.  Also check the 'Add project to an EAR' option.
	__4.  Click Finish when your options match those shown above.
	__5.  If prompted to switch to the Web perspective click the No button.
	__6.  The project will appear under the Project Explorer view, expand it.

	Part 6 -  Add Spring JARs with Maven
	__1.  Right click the OEProject and select Configure → Convert to Maven Project.
	__2.  Change the Packaging drop-down to 'war'.
	__3.  Once your settings match that shown above click the Finish button.  The Maven POM file should open in an editor.
	__4.  Right click the OEProject and select Properties.
	__5.  On the left side select Project Facets.
	__6.  Change the Java facet to 1.6 if it is not already.
	__7.  On the left select Java Compiler.
	__8.  On the right uncheck the box to allow project specific settings.
	__9.  Press the Apply button in the lower right (not the OK button) and confirm that you want to build.
	__10.  On the left select Java Build Path and select the Libraries tab on the right.
	__11.  Select the 'JRE System Library [J2SE-1.5]' from the list and click the Remove button on the far right.
	__12.  On the far right, click the Add Library button.
	__13.  Select 'JRE System Library' and click the Next button.
	__14.  Leave the default option of 'Workspace default JRE' selected and click the Finish button.
	__15.  Make sure that the correct JRE library shows up in the list.
	__16.  Click the Source tab in the Java Build Path properties.
	__17.  If the list of source folders is empty, click the Add Folder... button.
	__18.  Check the 'src' folder of the OEProject and click the OK button.
	__19.  Check that the new source folder appears.
	__20.  Change the 'Default output folder' at the bottom of the Source tab to 'OEProject/WebContent/WEB-INF/classes'.
	__21.  Click the OK button to close the project properties.
	__22.  Right click the OEProject and select Properties.
	__23.  On the left of the project properties dialog select 'Deployment Assembly'.
	__24.  Select the '/src/main/webapp' entry if it appears and press the Remove button.
	__25.  Press the Add button to the right of the list.
	__26.  Select 'Java Build Path Entries' and click the Next button.
	__27.  Select 'Maven Dependencies' and click the Finish button.
	__28.  Check that your final list appears as below.  Notice this will add the Maven dependencies we added to the 'lib' folder of the web project.
	__29.  Click the OK button to close the project properties.
	__30.  Check in the Markers view that there are no errors reported.  There may be other messages listed in the view but make sure they are not errors.
	__31.  Back in Eclipse make sure you still have the Maven pom.xml file for the project open. Open it again if not.
	__32.  In the editor switch to the 'Dependencies' tab at the bottom of the editor.
	__33.  Next to the empty list of Dependencies in the upper left, click the Add button.
	__34.  Enter 'context' in the search pattern box.
	__35.  Expand the Spring library org.springframework.context and select the 3.0.5 release version.
	__36.  Once your settings match above click the OK button.
	__37.  Click the Add button again next to the dependencies.
	__38.  Enter 'web' in the search pattern box.
	__39.  Expand the org.springframework.web library and select the 3.0.5 release version.
	__40.  Once your settings match above click the OK button.
	__41.  Click the Add button again next to the dependencies.
	__42.  Enter 'logging' in the search pattern box.
	__43.  Expand the Apache library that comes up and select the 1.1.1 release version.
	__44.  Once your settings match above click the OK button.
	__45.  Check that all three dependencies appear on the list.
	__46.  Save but don't close the file.
	__47.  Select the Dependency Hierarchy tab along the bottom of the editor.  You should see various JARs that will be linked to the project because the dependencies you added require them.  You can even select them on the right and see the dependency chain.
	__48.  Close the pom.xml file.
	__49.  In the Project Explorer view, expand OEProject → Java Resources → Libraries → Maven Dependencies.  You should see the various JAR files added to the build path of the project.  Make sure the 'context' and 'web' JARs are in the list to make sure they will both be packaged with your project.

	Part 7 -  Create Spring Configuration File
	__1.  Select Window → Open Perspective → Other.
	__2.  Select Spring and click the OK button.
	__3.  Right click the OEProject and select Spring Tools → Add Spring Project Nature.
	__4.  From the menu, select File -> New -> Spring Bean Configuration File.
	__5.  Expand OEProject -> WebContent and select the WEB-INF folder as the parent folder. 
	__6.  Enter spring-beans.xml as File name.
	__7.  Click Next.
	__8.  Check the 'beans' namespace checkbox and press the Finish button.
	__9.  Close all open files. (Ctrl+Shift+W)

	Part 8 -  Lab Cleanup
	__1.  Close the OEProject and OEProjectEAR projects as described in the 'Lab Cleanup' part of the 'Common Lab Preparation Steps'.

	Part 9 -  Review

	Lab 2 -  Defining and Using Spring Beans
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\Spring‑Beans\Spring‑Beans‑Starter.zip' file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.
	__2.  Open the Spring perspective.
	__3.  In the Markers view check that you have only warnings and no errors.  If there are errors try a Project → Clean to rebuild the project.

	Part 2 -  Examine Existing Classes
	__1.  Open ProductCodeGenerator.java under Spring‑Beans → src → com.webage.bean package.
	__2.  Open BasicProductCodeGenerator.java under Spring‑Beans → src → com.webage.bean package.
	__3.  Open ProductCodeGeneratorTest.java under Spring‑Beans → src → com.webage.test package.
	__4.  With the ProductCodeGeneratorTest class still open in the editor select Run → Run As → AspectJ/Java Application from the Eclipse menus.
	__5.  Make sure that you get the following in the Console view when the class generates some basic product codes.  You should be able to figure out how the properties of the 'BasicProductCodeGenerator' were used to generate these codes.

	Part 3 -  Retrieve Component from Spring
	__1.  Make sure you have the code of the  ProductCodeGeneratorTest class open in the editor and open it if it is not.
	__2.  At the start of the 'main' method add the following as the first lines of code.  You will have errors until the next step.  This code will define the Spring container or "context" that will be used and indicate that the configuration will be in an XML file.
	__3.  Organize imports by selecting Source → Organize Imports.
	__4.  Modify the code that initializes the 'generator' variable with the code in bold below.  Notice that instead of calling the constructor the code will get the component from the Spring environment.
	__5.  Save changes.
	__6.  Make sure you are in the Spring perspective and use the Window → Open Perspective → Other menu if needed.
	__7.  Select the Spring-Beans → src folder by clicking it.
	__8.  Select File → New → Spring Bean Configuration File.
	__9.  Enter a file name of spring-beans.xml and make sure the parent folder is 'Spring‑Beans/src' before clicking the Finish button.
	__10.  On the Spring configuration editor that opens select the 'beans' tab along the bottom.
	__11.  Click the 'New Bean..' button in the 'Beans Overview' area.
	__12.  Enter a value of 'generator' for the 'id' property but don't yet finish the dialog. This will be the name of the bean retrieved from the Spring container.
	__13.  Press the Browse button for the class, type a few letters of the BasicProductCodeGenerator class until it is selected and then click the OK button.
	__14.  Check that your dialog is filled in as shown below and click the Finish button.
	__15.  In the 'Beans Overview' section, right click the 'generator' bean and select Insert <constructor-arg> element.
	__16.  With the new constructor-arg element still selected fill in a 'value' of 'WA' without the quotes as shown below.
	__17.  Right click the 'generator' bean again and select Insert <constructor-arg> element.
	__18.  For the second constructor-arg element fill in a value of '10' without the quotes.
	__19.  Check that your bean definition appears as shown below in the 'Beans Overview' section.  Notice that the id of the bean and the value of the constructor arguments is shown to make it easier to read.
	__20.  Save the file.
	__21.  From the menus select Run → Run History → ProductCodeGeneratorTest.  There may be other things listed but this should be the only entry with that name.
	__22.  Check that in the Console view, after a few Spring messages, you see the same product codes printed.  You get the same product codes because even though you are getting the generator from the Spring container it was configured just as it was before.

	Part 4 -  Resolve Constructor Arguments
	__1.  Open BasicProductCodeGenerator.java under Spring‑Beans → src → com.webage.bean package.
	__2.  Add the following new constructor making sure to add the code within the class definition curly brackets but outside of other methods or constructors.
	__3.  Save the file.
	__4.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__5.  Notice that in the Console view, the same output is generated.  This is because the code is still calling the constructor with two Strings since that is the type that Spring will assume for constructor-arg values.
	__6.  Return to the editor for the 'spring-beans.xml' file.
	__7.  Select the second constructor-arg element with the value of '10'.
	__8.  In the 'type' attribute enter a value of 'int' without the quotes.  You may need to maximize the editor or move the divider between the two sides to see the value well.
	__9.  Save the file.
	__10.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__11.  Notice now that the output is different.  This is because the Spring bean is now defined to use the constructor that sets the initial 'current' value and not the suffix.  This is because the constructor-arg was configured to be an 'int'.

	Part 5 -  Configure Beans with Properties
	__1.  Return to the editor for the 'spring-beans.xml' file.
	__2.  Click the 'Source' tab at the bottom of the editor.
	__3.  Modify the definition of the bean to remove the <constructor-arg> elements and replace them with <property> elements as shown in bold below.
	__4.  Save the file.
	__5.  In the editor select the 'beans' tab along the bottom.
	__6.  Notice that the visual overview of the bean has changed since the properties are added instead of constructor arguments.  Select some of the properties if you want to see how they are defined in the editor.  In the future only source code may be given to simplify lab instructions although the editor is often easier to use to ensure correct syntax.
	__7.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__8.  Notice now that the output is different.  This is because the Spring bean is configured with different values for the properties.  This causes the generated product codes to be different which proves Spring is setting the properties of the Spring bean.

	Part 6 -  Configure Properties with 'p' Schema
	__1.  Return to the editor for the 'spring-beans.xml' file.
	__2.  Click the 'Namespaces' tab at the bottom of the editor.
	__3.  Check the 'p' namespace as shown below and click the OK button on the dialog that appears when you do.
	__4.  Click the 'Source' tab at the bottom of the editor.
	__5.  Modify the bean definition so that instead of having nested <property> element tags there are 'p:..' attributes with the name of the property and the value.  Make sure that you put these new 'p:..' attributes within the brackets for the start <bean ..> tag.  Notice the property values are a little different and not all are present so it will be easy to tell the settings are taking effect.  Also make sure to remove the nested <property> tags.
	__6.  Save the file.
	__7.  In the editor select the 'beans' tab along the bottom.
	__8.  Notice that the visual overview of the bean has changed and you do not see the properties that are set by the 'p:..' attributes.  Even though the visual editor doesn't give support for the 'p:..' attributes the source code editor does have code completion that you can access by typing CTRL-SPACE after typing 'p:' to enter the attribute name.
	__9.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__10.  Notice now that the output is different.  This is because the Spring bean is configured with different values for the properties even though they are configured with the 'p:..' attribute syntax.  If the property values had been the same the output would be the same as there is no difference in supplying basic property values with either method.

	Part 7 -  Observe Effect of Bean Scope
	__1.  Open ProductCodeGeneratorTest.java under Spring‑Beans → src → com.webage.test package if it is not already open in an editor.
	__2.  Add the following code in bold to the end of the 'main' method.  Notice that this initializes a second variable that refers to a 'generator' but that the name of the Spring bean retrieved is the same as the other variable that was initialized.
	__3.  Save the file and make sure there are no errors.
	__4.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__5.  Notice in the output that the product codes keep incrementing without starting over for the second 'generator'.  This is because the scope of the 'generator' bean is "singleton" and both variables in the 'main' method refer to the same generator object.
	__6.  Return to the editor for the 'spring-beans.xml' file.  Open it again if you had closed the file.
	__7.  Click the 'beans' tab at the bottom of the editor.
	__8.  Select the 'generator' bean from the left and scroll on the right until you see the 'scope' setting.
	__9.  Use the drop-down for the scope setting to select a scope of 'prototype' as shown below.
	__10.  Save the file once the 'scope' setting is changed.
	__11.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__12.  Notice the output now is different and the second 'generator' bean starts the product codes over.

	Part 8 -  Lab Cleanup
	__1.  Delete the ProductCodeGeneratorTest run configuration from the AspectJ/Java Application run configurations as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.
	__2.  Close the Spring-Beans project as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.

	Part 9 -  Review

	Lab 3 -  Advanced Spring Bean Definition
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\Spring‑BeanAnnotations\Spring‑BeanAnnotations‑Starter.zip' file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.
	__2.  Open the Spring perspective.
	__3.  In the Markers view check that you have only warnings and no errors.  If there are errors try a Project → Clean to rebuild the project.

	Part 2 -  Examine Existing Classes
	__1.  Open BasicProductCodeGenerator.java under Spring‑BeanAnnotations → src → com.webage.bean package.
	__2.  Open spring-beans.xml under the Spring‑BeanAnnotations → src folder.
	__3.  Open ProductCodeGeneratorTest.java under Spring‑BeanAnnotations → src → com.webage.test package.
	__4.  With the ProductCodeGeneratorTest class still open in the editor select Run → Run As → AspectJ/Java Application from the Eclipse menus.
	__5.  Make sure that you get the following in the Console view when the class generates some basic product codes.  You should be able to figure out how the properties of the 'BasicProductCodeGenerator' were used to generate these codes.  Also notice the effect of the bean scope of "prototype" as the product codes start over for the second 'generator' bean retrieved.  If the bean had been of "singleton" scope the codes from the second 'generator' bean variable would have continued instead of started over.

	Part 3 -  Define Spring Beans with Annotations
	__1.  Open BasicProductCodeGenerator.java under Spring‑BeanAnnotations → src → com.webage.bean package.
	__2.  Add the following annotation on the class definition.  You will have errors until a following step.
	__3.  Organize imports by selecting Source → Organize Imports.
	__4.  Save the file and make sure there are no errors.
	__5.  Return to the editor for the 'spring-beans.xml' file.  Open it again if you closed it.
	__6.  Click the 'Source' tab at the bottom of the editor.
	__7.  Add comments around the current bean definition as shown below.  When you enter the start of the comment Eclipse will automatically add an end tag immediately after so you will have to delete this to add it back later in the file but before the ending </beans> tag.  Check that the bean definition is in blue so it is marked as a comment.
	__8.  Click the 'Namespaces' tab at the bottom of the editor.
	__9.  Check the 'context' namespace as shown below and click the OK button on the dialog that appears when you do.
	__10.  Click the 'context' tab at the bottom of the editor.
	__11.  In the 'Context Overview' section, right click the 'beans' element in the empty list and select Insert <context:component-scan> element.
	__12.  With the new 'component-scan' element selected fill in the value for the 'base-package' attribute with the value of 'com.webage.bean'.  This package contains the bean that had the @Component annotation added.
	__13.  Save the file.
	__14.  Click the 'Beans Graph' tab at the bottom of the editor.
	__15.  Notice that the editor has detected that there will be a Spring bean named 'generator' defined from the annotation component scanning you just enabled.
	__16.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__17.  Notice that even though the values of the product code generator changed because they are being set in the Java code and not by the XML the more important aspect is that the second generator is continuing the same sequence of product codes as the first 'generator' bean retrieved.  This is because we have removed the 'scope' setting that was set using XML and are back to using the default of 'singleton' scope.
	__18.  Return to the editor for the BasicProductCodeGenerator.java file.  Open it again if you closed it.
	__19.  Add the following annotation on the class definition.  You will have errors until a following step.
	__20.  Organize imports by selecting Source → Organize Imports.
	__21.  Save the file and make sure there are no errors.
	__22.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__23.  Notice that you are now back to where the second code generator will start over from the beginning because the 'prototype' scope is in effect.
	__24.  Return to the editor for the 'spring-beans.xml' file.
	__25.  Click the 'Source' tab at the bottom of the editor.
	__26.  Add the following bean definition with XML.  Make sure it is nested properly as a child element of the <beans> tag but outside any other tag or comment.
	__27.  Save the file.
	__28.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__29.  Notice that even though the values of the product code generator changed and are starting from 100 as overridden in the XML we are back to the codes not starting over with the second generator so obviously the singleton scope is in effect again.
	__30.  Modify the XML bean definition to include the 'scope' annotation set to a 'prototype' value as shown below.
	__31.  Save the file.
	__32.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__33.  Notice that you are now back to where the second code generator will start over from the beginning because the 'prototype' scope is in effect.  You are also using the new starting point value set by the XML in combination with the other default values initialized in the Java code.

	Part 4 -  Using Standard JSR-330 Annotations
	__1.  Open the pom.xml file from the root of the 'Spring-BeanAnnotations' project.
	__2.  Switch to the source of the pom.xml by selecting the 'pom.xml' tab along the bottom of the editor.  You might need to look for some tabs that are hidden on the far right side and expand those to select the proper view.
	__3.  Find the section that is commented out (<!-- .. -->) that has the dependencies for the JSR-330 (javax.inject) libraries.  Remove the comment tags from before and after this section so the library is an active dependency. 
	__4.  Save the file and be sure there are no red errors in the margin for the file.  These will occur if you don't remove the comment tags properly.
	__5.  Close the pom.xml file.
	__6.  Return to the editor for the BasicProductCodeGenerator.java file.  Open it again if you closed it.
	__7.  Comment out the Spring @Component and @Scope annotations and add the @Named annotation as shown below.  Note that we will give the bean a different name to easily avoid the XML overridden configuration.
	__8.  Organize imports by selecting Source → Organize Imports.
	__9.  Save the file and make sure there are no errors.
	__10.  Return to the editor for the ProductCodeGeneratorTest.java file.  Open it again if you closed it.
	__11.  Modify the name of the bean used in the 'getBean' method as shown below.  Make sure you change both locations the method is used.  This will find our bean defined with the JSR-330 @Named annotation.
	__12.  Save the file and make sure there are no errors.
	__13.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__14.  Notice that the code does "work" because it finds a bean by that name and doesn't throw an Exception.  The problem is we are back to the singleton scope behavior for the bean where the second generator does not restart the generated code sequence.

	Part 5 -  Defining a Custom Component Stereotype Annotation
	__1.  Right click the Spring-BeanAnnotations → src folder and select New → Annotation.
	__2.  Fill in a name of AppComponent and a package of 'com.webage.annotation' for the annotation and click the Finish button.
	__3.  Modify the code by adding the following lines.  You will have errors until the next step.
	__4.  Organize imports by selecting Source → Organize Imports.  When prompted select the 'org.springframework.context.annotation.Scope', click the Next button, select the 'java.lang.annotation.ElementType' and click the Finish button.
	__5.  Save the file and make sure there are no errors.
	__6.  Return to the editor for the BasicProductCodeGenerator.java file.  Open it again if you closed it.
	__7.  Add the new custom annotation to the declaration of the class.  Make sure the Spring annotations remain commented out or deleted.  You will have errors until the next step.
	__8.  Organize imports by selecting Source → Organize Imports.  
	__9.  Save the file and make sure there are no errors.
	__10.  From the menus select Run → Run History → ProductCodeGeneratorTest.  Notice that the prototype behavior is back since the second generator starts over at the initial value.

	Part 6 -  Bean Inheritance
	__1.  Return to the editor for the 'spring-beans.xml' file.  Open it if you had closed it.
	__2.  Click the 'Source' tab at the bottom of the editor.
	__3.  Add the following bean definition with XML.  Make sure it is nested properly as a child element of the <beans> tag but outside any other tag or comment.
	__4.  Save the file.
	__5.  Click the 'Beans Graph' tab at the bottom of the editor.
	__6.  Notice that the editor has detected the bean inheritance and used a dashed arrow to indicate the relationship.  In this picture though the 'altPrefixGenerator' is shown above which would imply it is the parent so remember that the arrow points from the inheriting bean to the bean it inherits from.
	__7.  Return to the editor for the ProductCodeGeneratorTest.java file.  Open it again if you closed it.
	__8.  Modify the name of the bean used in the 'getBean' method as shown below.  Make sure you change both locations the method is used.  This will find the bean definition that is defined with inheritance.
	__9.  Save the file and make sure there are no errors.
	__10.  From the menus select Run → Run History → ProductCodeGeneratorTest.  
	__11.  Notice that the prefix appears so it is using the inherited bean definition.  The scope setting is also inherited since this test shows the prototype behavior where the code restarts with the second generator.

	Part 7 -  Externalize Spring Configuration
	__1.  Select the Spring-BeanAnnotations → src folder by clicking it.
	__2.  Select File → New → File.
	__3.  Enter a file name of generator.properties and make sure the parent folder is 'Spring‑BeanAnnotations/src' before clicking the Finish button.
	__4.  Add the following property definitions in the property file.  The keys before the equals sign are important as these will be the property names used in the Spring configuration file.
	__5.  Save the file.
	__6.  Return to the editor for the 'spring-beans.xml' file.  Open it again if you closed it.
	__7.  Click the 'context' tab at the bottom of the editor.
	__8.  In the 'Context Overview' section, right click the 'beans' element  and select Insert <context:property-placeholder> element.
	__9.  With the new 'property-placeholder' element selected fill in the value for the 'location' attribute with the value of 'generator.properties'.  This is the location of the new properties file is located on the classpath of the project.
	__10.  Click the 'Source' tab at the bottom of the editor.
	__11.  Modify the properties of the Spring bean definitions to use the property values.  Notice there are also some new properties added to the 'generator' bean to show setting several bean properties with the property file.
	__12.  Save the file.
	__13.  Return to the editor for the ProductCodeGeneratorTest.java file.  Open it again if you closed it.
	__14.  Modify the name of the bean used in the first 'getBean' method as shown below.  This will show the codes generated by both Spring bean definitions and see how the properties are set with the external properties file.
	__15.  Save the file and make sure there are no errors.
	__16.  From the menus select Run → Run History → ProductCodeGeneratorTest.  
	__17.  Notice that the code generators behave as expected even though the properties are defined by the external property file.
	__18.  Close all open files.

	Part 8 -  Lab Cleanup
	__1.  Delete the ProductCodeGeneratorTest run configuration from the AspectJ/Java Application run configurations as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.
	__2.  Close the Spring-BeanAnnotations project as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.

	Part 9 -  Review

	Lab 4 -  Spring Dependency Injection
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\Spring‑DI‑XML\Spring‑DI‑XML‑Starter.zip' file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.
	__2.  Open the Spring perspective.
	__3.  In the Markers view check that you have only warnings and no errors from the project.  If there are errors try a Project → Clean to rebuild the project.

	Part 2 -  Inject Spring Bean
	__1.  Open BasicProductCodeGenerator.java under Spring‑DI‑XML → src → com.webage.bean package.
	__2.  Open IncrementingIntGenerator.java under Spring‑DI‑XML → src → com.webage.bean package.
	__3.  Open spring-beans.xml under the Spring‑DI‑XML → src folder.
	__4.  Click the 'Source' tab at the bottom of the editor.
	__5.  In the 'prodCodeGenerator' bean definition, find the comment about injecting an 'intGenerator' and add the following <constructor-arg> and nested <bean> elements shown in bold.  Check the syntax of the XML elements carefully to make sure tags are balanced and valid XML.
	__6.  Save the spring-beans.xml file.  At this point there should be no errors in the project.  Check the Markers view if errors are shown.
	__7.  Open ProductCodeGeneratorTest.java under Spring‑Beans → src → com.webage.test package.  Notice this class simply loads the 'spring-beans.xml' bean configuration, retrieves the 'prodCodeGenerator' bean and prints out a few product codes.  Notice the bean is retrieved twice which will be important for bean scope.
	__8.  With the ProductCodeGeneratorTest class still open in the editor select Run → Run As → AspectJ/Java Application from the Eclipse menus.
	__9.  Make sure that you get the following in the Console view when the class generates some basic product codes.  Notice that the int values used to generate the codes restarts with the second set of codes.  
	__10.  Return to the editor for the 'spring-beans.xml' file.
	__11.  Modify the <constructor-arg> elements into <property> elements as shown below using the given property names.  Make sure to modify the end tag for the element also.
	__12.  Save the file and make sure there are no errors.  These will occur if the XML elements were not modified correctly.
	__13.  From the menus select Run → Run History → ProductCodeGeneratorTest. There may be other things listed but this should be the only entry with that name.
	__14.  Check that the output in the Console view is the same as last time.  Although you are doing "setter" injection with the properties instead of "constructor" injection the behavior is the same.
	__15.  Return to the editor for the 'spring-beans.xml' file.
	__16.  Modify the syntax of the 'intGenerator' property element so that instead of a nested <bean> element it uses a nested <ref> element as shown in bold below.  This will reference another bean definition for an IncrementingIntGenerator bean already present in the Spring configuration.
	__17.  Save the file and make sure there are no errors.  These will occur if the XML elements were not modified correctly.
	__18.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__19.  Notice that the output in the Console view shows six product codes that start at '25' and increment by '5' because of the properties set for the referenced bean definition.  Notice however that this time the int values do not reset with the second set of three product codes.
	__20.  Return to the editor for the 'spring-beans.xml' file.
	__21.  Modify the definition of the 'intGenerator' bean so it is using the 'prototype' scope as shown in bold below.
	__22.  Save the file and make sure there are no errors.  
	__23.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__24.  Notice in the Console view that this time the second set of product codes does start over at '25'.  This is because the IncrementingIntGenerator instance is getting recreated when it is injected into the second instance of the BasicProductCodeGenerator instance.

	Part 3 -  Inject Collection
	__1.  Open BasicProductCodeGenerator.java under Spring‑DI‑XML → src → com.webage.bean package.
	__2.  Examine the 'setSuffixList' and 'getNextProductCode' methods to understand more about how the suffixes are used.
	__3.  Return to the editor for the 'spring-beans.xml' file.
	__4.  Add a new nested <property> element to the 'prodCodeGenerator' bean definition with an embedded <list> as shown in bold below.  Make sure you nest the new element correctly as the code below does not show the other two properties to simplify things.
	__5.  Save the file and make sure there are no errors.  These will occur if the XML elements were not added correctly.
	__6.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__7.  Notice from the Console view that you now have suffixes of '50' or '60' printed at the end of each product code.  The suffixes restart after the end of the list is reached which is the behavior coded into the component.  The suffixes also restart for the second generator because of the bean scope behavior.
	__8.  Return to the BasicProductCodeGenerator.java editor and reopen it if you closed it.
	__9.  Find the 'getNextProductCode' method and make the changes shown in bold below.  You will have an error until the next step.  There are only two lines of modified code but the entire method is shown to make sure you place the modified code in the correct location.
	__10.  Organize imports by selecting Source → Organize Imports.
	__11.  Save the file and make sure there are no errors.
	__12.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__13.  Notice in the Console view you get an Exception.  The exception indicates the given object can't be formatted as a number.
	__14.  Return to the editor for the 'spring-beans.xml' file.
	__15.  Modify the definition of the <list> used for the 'suffixList' property to include the 'value-type' attribute as shown in bold below.
	__16.  Save the file and make sure there are no errors.
	__17.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__18.  Notice in the Console view that this time there is no Exception and the product codes are generated as before.
	__19.  Return to the BasicProductCodeGenerator editor and reopen it if you closed it.
	__20.  Modify the declaration of the 'suffixList' and 'suffixIterator' fields to include the generic qualifier <Integer> as shown in bold below.  You can also remove the @SuppressWarnings annotations if you want.
	__21.  Modify the declaration of the parameter for the 'setSuffixList' method to include the generic qualifier <Integer> as shown in bold below.  You can also remove the @SuppressWarnings annotations if you want.
	__22.  Save the file and make sure there are no errors.
	__23.  Return to the editor for the 'spring-beans.xml' file.
	__24.  Modify the definition of the <list> used for the 'suffixList' property to remove the 'value-type' attribute.  The syntax is now back to what it was before without any type information needed in the Spring configuration file.
	__25.  Save the file and make sure there are no errors.
	__26.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__27.  Notice in the Console view you did not get any errors and the product codes are generated.  This is because Spring can use the generic type qualifiers in the field and method to determine the type of the <list> elements and use Integer values that will not have any problem with the formatting code.
	__28.  Return to the editor for the 'spring-beans.xml' file.
	__29.  Click the 'Namespaces' tab at the bottom of the editor.
	__30.  Check the 'util' namespace as shown below and click the OK button on the dialog that appears when you do.
	__31.  Click the 'Source' tab at the bottom of the editor.
	__32.  Add the following <util:list> definition to the end of the configuration file but within the ending </beans> tag as shown below.
	__33.  Modify the 'suffixList' property of the 'prodCodeGenerator' bean so that instead of defining an embedded <list> it uses a <ref> element to reference the <util:list> definition you just created.
	__34.  Save the file and make sure there are no errors.
	__35.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__36.  Notice in the Console view that the suffixes of the output product codes are now different because the values of the separately defined <util:list> were different.  All of the other behavior is the same.

	Part 4 -  Autowire Dependencies
	__1.  Return to the editor for the 'spring-beans.xml' file.  Open it again if you had closed it.
	__2.  Modify the declaration of the 'prodCodeGenerator' bean to add the 'autowire' attribute with the setting to autowire 'byName' as shown in bold below.
	__3.  Comment out the definition of the wiring of the 'intGenerator' and 'suffixList' properties as shown below.  Note that when you add a starting comment tag Eclipse will automatically add the ending tag which you will have to delete and add further down.
	__4.  Save the file and make sure there are no errors.  These will occur if the XML comment tags were not added correctly.
	__5.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__6.  Notice in the Console view that the output should be the same.  This is because the autowiring by name is resolving the same dependencies to inject as were present before.
	__7.  Return to the editor for the 'spring-beans.xml' file.
	__8.  Modify the type of autowiring of the 'prodCodeGenerator' bean to 'constructor' as shown below.
	__9.  Save the file and make sure there are no errors.  
	__10.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__11.  Notice in the Console view that the output is different.  This is because even though there is a constructor with List<Integer> and IntGenerator arguments the standalone list can't be autowired this way.  It can only be autowired by name.  So the constructor with only the IntGenerator is picked and no suffix list is used.
	__12.  Return to the editor for the 'spring-beans.xml' file.
	__13.  Modify the type of autowiring of the 'prodCodeGenerator' bean to 'byType' as shown below.
	__14.  Save the file and make sure there are no errors.  
	__15.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__16.  Notice in the Console view that the output is the same as the autowiring by constructor.  Again the suffix list can't be autowired by type.
	__17.  Return to the editor for the 'spring-beans.xml' file.
	__18.  Add the following new <bean> definitions to the end of the configuration file but before the end </beans> tag.
	__19.  Save the file and make sure there are no errors.  
	__20.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__21.  Notice in the Console view that the output is back to containing suffix values but the suffix values are the ones coming from the separately defined beans of the Integer class.

	Part 5 -  Resolve Ambiguity of byType Autowiring
	__1.  Return to the editor for the 'spring-beans.xml' file.
	__2.  Check that the 'prodCodeGenerator' bean is set to autowire 'byType' as shown below.
	__3.  Add the following new <bean> definition to the end of the configuration file but before the end </beans> tag.
	__4.  Save the file and make sure there are no errors.  
	__5.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__6.  Notice in the Console view that there is an 'UnsatisfiedDependencyException' thrown.  If you look closely at the messages you should see that it is because there is "no unique bean" for the 'intGenerator' property.  This is because the bean above you defined is also an implementation of the IntGenerator interface.
	__7.  Return to the editor for the 'spring-beans.xml' file.
	__8.  Find the definition of the 'intGenerator' bean and add the 'autowire-candidate' attribute with a value of 'false' as shown below.
	__9.  Save the file and make sure there are no errors.  
	__10.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__11.  Notice in the Console view that you get product codes generated with the random numbers from the second component (which are longer).  There is no more error because the IncrementingIntGenerator bean is excluded from autowiring.
	__12.  Return to the editor for the 'spring-beans.xml' file.
	__13.  Find the definition of the 'intGenerator' bean.  Remove the 'autowire‑candidate' attribute and add a 'primary' attribute with a value of "true".  Both changes are shown below in bold with the attribute to be removed shown with a strikethrough effect.
	__14.  Save the file and make sure there are no errors.  
	__15.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__16.  Notice in the Console view that the output has returned to using the incrementing product codes and you also still do not get an error.  Although both beans are again eligible for auto-wiring, Spring now knows which one to prefer.

	Part 6 -  Lab Cleanup
	__1.  Delete the ProductCodeGeneratorTest run configuration from the AspectJ/Java Application run configurations as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.
	__2.  Close the Spring-DI‑XML project as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.

	Part 7 -  Review

	Lab 5 -  Annotation Dependency Injection
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\Spring‑DI‑Annotations\Spring‑DI‑Annotations‑Starter.zip' file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.
	__2.  Open the Spring perspective.
	__3.  In the Markers view check that you have only warnings and no errors from the project.  If there are errors try a Project → Clean to rebuild the project.

	Part 2 -  Enforce Required Dependencies
	__1.  Open BasicProductCodeGenerator.java under Spring‑DI‑Annotations → src → com.webage.bean package.
	__2.  Open ProductCodeGeneratorTest.java under Spring‑Beans → src → com.webage.test package.  Notice this class simply loads the 'spring-beans.xml' bean configuration, retrieves the 'prodCodeGenerator' bean and prints out a few product codes. Notice the bean is retrieved twice which will be important for bean scope.
	__3.  With the ProductCodeGeneratorTest class still open in the editor select Run → Run As → AspectJ/Java Application from the Eclipse menus.
	__4.  Verify that in the Console view you get a NullPointerException.  This is expected and occurs because the 'intGenerator' field was not initialized by dependency injection.
	__5.  Return to the editor for the BasicProductCodeGenerator class.  Open it again if you closed it.
	__6.  Find the 'setIntGenerator' method.
	__7.  Add the '@Required' annotation before the declaration of the method as shown below.  You will have errors until the next step.
	__8.  Organize imports by selecting Source → Organize Imports.
	__9.  Save the file and make sure there are no errors.
	__10.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__11.  Verify in the Console view that you do get an Exception that is not a NullPointerException.  This is expected.
	__12.  Open spring-beans.xml under the Spring‑DI‑Annotations → src folder.
	__13.  Click the 'Source' tab at the bottom of the editor.
	__14.  Remove the comment tags from before and after the 'prodCodeGenerator' bean definition.  This will make it active and allow the 'intGenerator' property to be set.
	__15.  Save the file and make sure there are no errors.  
	__16.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__17.  Verify that you get the following output in the Console view.

	Part 3 -  Inject Dependencies with Annotations
	__1.  Return to the editor for the 'spring-beans.xml' file and open it again if you closed it.
	__2.  Delete the entire XML definition for the 'prodCodeGenerator' bean.
	__3.  Save the file and make sure there are no errors.  
	__4.  Return to the editor for the BasicProductCodeGenerator class.  Open it again if you closed it.
	__5.  Find the 'setIntGenerator' method.
	__6.  Remove the @Required annotation and instead add the @Resource annotation shown below.  You will have errors.
	__7.  Organize imports by selecting Source → Organize Imports.
	__8.  Save the file and make sure there are no errors.
	__9.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__10.  Verify that you get the following output.
	__11.  Return to the 'setIntGenerator' method in the BasicProductCodeGenerator class.
	__12.  Remove the @Resource annotation so there is no longer any annotation before the declaration of the method.
	__13.  Find the constructor for the  BasicProductCodeGenerator class that takes a single parameter of an IntGenerator instance.
	__14.  Add the @Autowired annotation to the declaration of the constructor.  You will have errors.
	__15.  Organize imports by selecting Source → Organize Imports.
	__16.  Save the file and make sure there are no errors.
	__17.  Run the ProductCodeGeneratorTest configuration again and verify the same output.
	__18.  Return to the editor for the 'spring-beans.xml' file and open it again if you closed it.
	__19.  Delete the entire XML definition for the 'intGenerator' bean.
	__20.  Save the file and make sure there are no errors.
	__21.  Open IncrementingIntGenerator.java under Spring‑DI‑Annotations → src → com.webage.bean package.
	__22.  Add the following Spring annotations to declare the component using annotations.  You will have errors.
	__23.  Organize imports by selecting Source → Organize Imports.  
	__24.  Save the file and make sure there are no errors.
	__25.  Run the ProductCodeGeneratorTest configuration again and verify you get different output because the bean properties are now set by the field defaults in the class and not overridden by the XML configuration.
	__26.  Return to the editor for the BasicProductCodeGenerator class.  Open it again if you closed it.
	__27.  Find the constructor for the  BasicProductCodeGenerator class that takes two parameters, one of an IntGenerator instance and a second for a list of Integers for a suffix list.
	__28.  Add the following @Autowired annotation with the 'required=false' attribute.
	__29.  Return to the constructor which takes the single IntGenerator parameter and make the same change of adding the 'required=false' attribute as shown below.
	__30.  Save the file and make sure there are no errors.
	__31.  Run the ProductCodeGeneratorTest configuration again and verify you get different output because the Integer beans defined in the XML are being injected as the list of suffixes.
	__32.  Return to the editor for the BasicProductCodeGenerator class.  Open it again if you closed it.
	__33.  Remove the @Autowired annotations from both constructors.
	__34.  Find the 'setIntGenerator' method.
	__35.  Add the @Autowired annotation (without any attribute) to the definition of the method as shown below.
	__36.  Save the file and make sure there are no errors.
	__37.  Run the ProductCodeGeneratorTest configuration again and verify you get different output simply because the 'suffixList' is no longer being injected.
	__38.  Find the 'setSuffixList' method.
	__39.  Add the @Autowired annotation with the 'required=false' attribute to the definition of the method as shown below.
	__40.  Save the file and make sure there are no errors.
	__41.  Run the ProductCodeGeneratorTest configuration again and verify you get different output simply because the suffix list is being injected again.
	__42.  Return to the editor for the 'spring-beans.xml' file and open it again if you closed it.
	__43.  Delete both bean definitions of the Integers that were being used for the 'suffixList' injection.
	__44.  Save the file and make sure there are no errors.
	__45.  Run the ProductCodeGeneratorTest configuration again and verify you get different output because now there is no Integer beans that can be injected for the 'suffixList' property.

	Part 4 -  Resolve Autowire Conflicts
	__1.  Open RandomIntGenerator.java under Spring‑DI‑Annotations → src → com.webage.bean package.
	__2.  Add the following Spring annotations to declare the component using annotations.  You will have errors.
	__3.  Organize imports by selecting Source → Organize Imports.  
	__4.  Save the file and make sure there are no errors.
	__5.  Run the ProductCodeGeneratorTest configuration again.  You will get an Exception that is expected.  If you look closely at the messages you should see that it is because there is "no unique bean" for the 'IntGenerator' type.  This is because the bean above you defined is also an implementation of the IntGenerator interface.
	__6.  Open IncrementingIntGenerator.java under Spring‑DI‑Annotations → src → com.webage.bean package.
	__7.  Add the following Spring annotation to declare the component as the "Primary" implementation.  You will have errors.
	__8.  Organize imports by selecting Source → Organize Imports.
	__9.  Save the file and make sure there are no errors.
	__10.  Run the ProductCodeGeneratorTest configuration again.  You should be back to the usual output since Spring now has direction for which implementation to pick.
	__11.  Return to the editor for the RandomIntGenerator class and open it again if you closed it.
	__12.  Add the following Spring annotation to declare a "qualifier" for the component.  You will have errors.
	__13.  Organize imports by selecting Source → Organize Imports.  
	__14.  Save the file and make sure there are no errors.
	__15.  Return to the editor for the IncrementingIntGenerator class and open it again if you closed it.
	__16.  Add the following Spring annotation to declare a "qualifier" for the component.  You will have errors.
	__17.  Organize imports by selecting Source → Organize Imports.  
	__18.  Save the file and make sure there are no errors.
	__19.  Return to the editor for the BasicProductCodeGenerator class.  Open it again if you closed it.
	__20.  Find the 'setIntGenerator' method.
	__21.  Add the following Spring annotation to declare a "qualifier" for the autowired component.  You will have errors.
	__22.  Organize imports by selecting Source → Organize Imports.  
	__23.  Save the file and make sure there are no errors.
	__24.  Run the ProductCodeGeneratorTest configuration again.  The output should switch to using the random numbers from the other implementation.
	__25.  Return to the editor for the 'spring-beans.xml' file and open it again if you closed it.
	__26.  Remove the comment tags from before and after the 'largeIncrementingGenerator' bean so it is active.  Notice this is another version of the IncrementingIntGenerator with different properties set.
	__27.  Add the following <qualifier> element to the bean definition.
	__28.  Save the file and make sure there are no errors.
	__29.  Return to the editor for the BasicProductCodeGenerator class.  Open it again if you closed it.
	__30.  Modify the @Qualifier annotation on the 'setIntGenerator' method to use the String  "largeIncrement".  This will match the value in the XML declaration.
	__31.  Save the file and make sure there are no errors.
	__32.  Run the ProductCodeGeneratorTest configuration again.  The output should switch to using the incrementing properties defined in the XML.

	Part 5 -  Define Custom Qualifier Annotation
	__1.  Open StrategyType.java under Spring‑DI‑Annotations → src → com.webage.annotation package.
	__2.  Add the following Spring annotation to turn the annotation into a Spring Qualifier annotation.  Notice also that the annotation has an attribute of type GenerationStrategy.  This is an enumeration that has three values for the type of generation.
	__3.  Organize imports by selecting Source → Organize Imports.  
	__4.  Save the file and make sure there are no errors.
	__5.  Return to the editor for the BasicProductCodeGenerator class.  Open it again if you closed it.
	__6.  Remove the @Qualifier annotation on the 'setIntGenerator' method.
	__7.  Add the following @StrategyType annotation to the declaration of the method.  You will have errors.
	__8.  Organize imports by selecting Source → Organize Imports.  
	__9.  Save the file and make sure there are no errors.
	__10.  Return to the editor for the RandomIntGenerator class and open it again if you closed it.
	__11.  Remove the @Qualifier annotation from the class declaration.
	__12.  Add the following @StrategyType annotation to use the custom qualifier.  You will have errors.
	__13.  Organize imports by selecting Source → Organize Imports.  
	__14.  Save the file and make sure there are no errors.
	__15.  Return to the editor for the IncrementingIntGenerator class and open it again if you closed it.
	__16.  Remove the @Qualifier annotation from the class declaration.
	__17.  Add the following @StrategyType annotation to use the custom qualifier.  You will have errors.
	__18.  Organize imports by selecting Source → Organize Imports.  
	__19.  Save the file and make sure there are no errors.
	__20.  Run the ProductCodeGeneratorTest configuration again.  The output should switch to using the random numbers.
	__21.  Return to the editor for the 'spring-beans.xml' file and open it again if you closed it.
	__22.  Modify the <qualifier> element as shown below.  Make sure to enter the nested <attribute> tag correctly.
	__23.  Save the file and make sure there are no errors.
	__24.  Return to the editor for the BasicProductCodeGenerator class.  Open it again if you closed it.
	__25.  Remove the 'RANDOM' from the strategy attribute of the annotation but leave the following syntax.
	__26.  Put your cursor after the period after GenerationStrategy in the attribute value and press <CTRL> + <SPACE> to activate code completion.
	__27.  On the list that appears with code completion double click the LARGE_INCREMENTING value to use this value for the annotation.
	__28.  Check that the syntax of the annotation appears as shown below.
	__29.  Save the file and make sure there are no errors.
	__30.  Run the ProductCodeGeneratorTest configuration again.  The output should switch to using the incrementing implementation with larger intervals..

	Part 6 -  Lab Cleanup
	__1.  Delete the ProductCodeGeneratorTest run configuration from the AspectJ/Java Application run configurations as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.
	__2.  Close the Spring-DI‑Annotations project as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.

	Part 7 -  Review

	Lab 6 -  Dependency Injection with JSR-330 Annotations
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\Spring‑DI‑330\Spring‑DI‑330‑Starter.zip' file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.
	__2.  Open the Spring perspective.
	__3.  In the Markers view check that you have only warnings and no errors from the project.  If there are errors try a Project → Clean to rebuild the project.

	Part 2 -  Inject Dependencies with Annotations
	__1.  Open BasicProductCodeGenerator.java under Spring‑DI‑330 → src → com.webage.bean330 package.
	__2.  Also notice the annotations on the class definition.  The @Named annotation declares this as a component and the @PrototypeComponent annotation applies a Spring "prototype" scope to the component.  These annotations are also used on the IncrementingIntGenerator class to define it as a component.
	__3.  Open ProductCodeGenerator330Test.java under Spring‑Beans → src → com.webage.test package.  Notice this class simply loads the 'spring-beans-330.xml' bean configuration, retrieves the 'prodCodeGenerator' bean and prints out a few product codes. Notice the bean is retrieved twice which will be important for bean scope.
	__4.  With the ProductCodeGenerator330Test class still open in the editor select Run → Run As → AspectJ/Java Application from the Eclipse menus.
	__5.  Verify that in the Console view you get a NullPointerException.  This is expected and occurs because the 'intGenerator' field was not initialized by dependency injection.
	__6.  Return to the editor for the BasicProductCodeGenerator class.  Open it again if you closed it.
	__7.  Find the constructor for the  BasicProductCodeGenerator class that takes a single parameter of an IntGenerator instance.
	__8.  Add the @Inject annotation to the declaration of the constructor.  Make sure it is the constructor that only takes a single parameter which is an IntGenerator.  You will have errors.
	__9.  Organize imports by selecting Source → Organize Imports.
	__10.  Save the file and make sure there are no errors.
	__11.  From the menus select Run → Run History → ProductCodeGenerator330Test.
	__12.  In the Console view verify the output below.  This verifies the implementation of the IntGenerator interface is injected.
	__13.  Return to the editor for the BasicProductCodeGenerator class.  Open it again if you closed it.
	__14.  Remove the @Inject annotations from the constructor.
	__15.  Find the 'setIntGenerator' method.
	__16.  Add the @Inject annotation to the definition of the method as shown below.
	__17.  Save the file and make sure there are no errors.
	__18.  Run the ProductCodeGenerator330Test configuration again and verify you get the same output as the component is just being injected using the 'setter' method and not the constructor.
	__19.  Find the 'setSuffixList' method.
	__20.  Add the @Inject annotation to the definition of the method as shown below.
	__21.  Save the file and make sure there are no errors.
	__22.  Run the ProductCodeGenerator330Test configuration again and verify you get different output simply because the suffix list is being injected.  There are Integer components defined in the Spring configuration file that are being supplied for this property.
	__23.  Open spring-beans-330.xml under the Spring‑DI‑Annotations → src folder.
	__24.  Delete both bean definitions of the Integers that were being used for the 'suffixList' injection.
	__25.  Save the file and make sure there are no errors.
	__26.  Run the ProductCodeGenerator330Test configuration again and verify you get an Exception.  If you look closely at the messages you can see this is because there are no Integer beans to inject for the suffixList property.
	__27.  Return to the editor for the 'spring-beans-330.xml' file and open it again if you closed it.
	__28.  Remove the comment tags from before and after the 'prodCodeGenerator' bean so it is active.  Since this is the same bean name as used in the @Named annotation in the BasicProductCodeGenerator class this definition complements the definition there.
	__29.  Save the file and make sure there are no errors.
	__30.  Run the ProductCodeGenerator330Test configuration again and verify that you get valid output but without suffixes.  This is because the 'suffixList' property is injected and therefore doesn't cause the Exception even though it was injected with a null value.

	Part 3 -  Resolve Injection Conflicts
	__1.  Open RandomIntGenerator.java under Spring‑DI‑330 → src → com.webage.bean330 package.
	__2.  Add the following Spring annotations to declare the component using annotations.  You will have errors.
	__3.  Organize imports by selecting Source → Organize Imports.  
	__4.  Save the file and make sure there are no errors.
	__5.  Run the ProductCodeGenerator330Test configuration again.  You will get an Exception that is expected.  If you look closely at the messages you should see that it is because there is "no unique bean" for the 'IntGenerator' type.  This is because the bean above you defined is also an implementation of the IntGenerator interface.
	__6.  Return to the editor for the BasicProductCodeGenerator class.  Open it again if you closed it.
	__7.  Find the 'setIntGenerator' method.
	__8.  Add the following annotation to declare which named component to inject. 
	__9.  Save the file and make sure there are no errors.
	__10.  Run the ProductCodeGenerator330Test configuration again.  The output should switch to using the random numbers from the other implementation.

	Part 4 -  Define Custom Qualifier Annotation
	__1.  Open StrategyType330.java under Spring‑DI‑330 → src → com.webage.annotation package.
	__2.  Add the following annotation to turn the annotation into a JSR-330 Qualifier annotation.  Notice also that the annotation has an attribute of type GenerationStrategy.  This is an enumeration that has three values for the type of generation.
	__3.  Organize imports by selecting Source → Organize Imports.  Select the 'javax.inject.Qualifier' annotation when prompted.
	__4.  Save the file and make sure there are no errors.
	__5.  Return to the editor for the BasicProductCodeGenerator class.  Open it again if you closed it.
	__6.  Remove the @Named annotation on the 'setIntGenerator' method.
	__7.  Add the following @StrategyType330 annotation to the declaration of the method.  You will have errors.
	__8.  Organize imports by selecting Source → Organize Imports.  
	__9.  Save the file and make sure there are no errors.
	__10.  Return to the editor for the RandomIntGenerator class and open it again if you closed it.
	__11.  Add the following @StrategyType330 annotation to use the custom qualifier.  You will have errors.
	__12.  Organize imports by selecting Source → Organize Imports.  
	__13.  Save the file and make sure there are no errors.
	__14.  Open IncrementingIntGenerator.java under Spring‑DI‑Annotations → src → com.webage.bean330 package.
	__15.  Add the following @StrategyType330 annotation to use the custom qualifier.  You will have errors.
	__16.  Organize imports by selecting Source → Organize Imports.  
	__17.  Save the file and make sure there are no errors.
	__18.  Run the ProductCodeGenerator330Test configuration again.  The output should switch to using the incrementing numbers.
	__19.  Return to the editor for the 'spring-beans-330.xml' file and open it again if you closed it.
	__20.  Remove the comment tags from before and after the 'largeIncrementingGenerator' bean so it is active.  Notice this is another version of the IncrementingIntGenerator with different properties set.
	__21.  Add the following <qualifier> element to the bean definition.  Make sure to enter the nested <attribute> tag correctly.
	__22.  Save the file and make sure there are no errors.
	__23.  Return to the editor for the BasicProductCodeGenerator class.  Open it again if you closed it.
	__24.  Remove the 'INCREMENTING' from the strategy attribute of the annotation but leave the following syntax.
	__25.  Put your cursor after the period after GenerationStrategy in the attribute value and press <CTRL> + <SPACE> to activate code completion.
	__26.  On the list that appears with code completion double click the LARGE_INCREMENTING value to use this value for the annotation.
	__27.  Check that the syntax of the annotation appears as shown below.
	__28.  Save the file and make sure there are no errors.
	__29.  Run the ProductCodeGenerator330Test configuration again.  The output should switch to using the incrementing implementation with larger intervals.

	Part 5 -  Lab Cleanup
	__1.  Delete the ProductCodeGenerator330Test run configuration from the AspectJ/Java Application run configurations as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.
	__2.  Close the Spring-DI‑330 project as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.

	Part 6 -  Review

	Lab 7 -  Spring Testing Support
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\Spring‑Testing\Spring‑Testing‑Starter.zip' file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.
	__2.  Open the Spring perspective.
	__3.  In the Markers view you shouldn't have any errors but may have warnings.  These are OK to ignore.  If you do see errors select Project → Clean and these should go away.

	Part 2 -  Examine Project Settings
	__1.  First notice that there are two projects, 'Spring‑Testing‑UnderTest' and 'Spring‑Testing‑TestsProject'.  This helps separate the main code of the project from the code meant to test it.
	__2.  Open the pom.xml file from the root of the 'Spring‑Testing‑TestsProject' project.
	__3.  Switch to the source of the pom.xml by selecting the 'pom.xml' tab along the bottom of the editor.  You might need to look for some tabs that are hidden on the far right side and expand those to select the proper view.
	__4.  Scroll to the bottom and look at the dependencies that have been added specifically for testing.  The 'springframework.test' module has Spring's testing support classes, JUnit is a popular test framework, and EasyMock is a framework for Mock objects used later.
	__5.  Close the pom.xml file making sure you don't make any changes.
	__6.  Right click the 'Spring‑Testing‑TestsProject' and select Properties from the bottom of the popup menu.
	__7.  Select the 'Java Build Path' properties on the left and the 'Projects' tab on the right.  Notice that the 'Spring‑Testing‑UnderTest' is on the build path of this project so we can refer to the classes that are being tested from the tests themselves.
	__8.  Click the OK button to close the project properties.

	Part 3 -  Create First Test
	__1.  Open RandomTest.java under Spring‑Testing‑TestsProject → src → com.webage.test package.  Ignore the warnings about unused imports as they will be used later.
	__2.  Before the class declaration add the following two annotations.  The @RunWith annotation is a JUnit annotation and points to a special Spring class that will perform injection on the test class.  The @ContextConfiguration is a Spring annotation that indicates the Spring configuration file to load for the test.
	__3.  Add the following field to the test class.  This will inject the component to be tested.
	__4.  After the comment indicating where to add the test methods but within the brackets of the class definition, add the following test method, complete with the @Test annotation.  The @Test annotation is a JUnit annotation that marks the method as a test to run.
	__5.  Save the file and be sure there are no red errors.  You will still have a yellow warning that can be ignored.
	__6.  From the Eclipse menus select 'Window → Show View → Other'.
	__7.  Expand Java, select JUnit and click the OK button.
	__8.  Once the JUnit view opens, click and hold the mouse button down on the tab for the view, drag and drop the view tab over the area on the lower right with the Spring Explorer view.  Make sure to hold the mouse button down as you drag the view and let go when it is where you want it.  There will be a shaded box for where the view will go if you let go of the mouse button with the cursor in that spot.
	__9.  Back on the left in the 'Package Explorer' view, right click RandomTest.java under Spring‑Testing‑TestsProject → src → com.webage.test package and select 'Run As → JUnit Test'
	__10.  Over on the right in the JUnit view you should see an error.  This is expected and will be explained in the next steps.
	__11.  Open RandomIntGenerator.java under Spring‑Testing‑UnderTest → src → com.webage.bean package.  Notice that right now the 'nextNumber' method does not actually return random numbers which is why the failure occurred.
	__12.  Comment out the current return statement and replace it with the bold code below that will use the already initialized 'randomizer' field to return a random number.
	__13.  Save the code and make sure there are no errors.
	__14.  Go back to the JUnit view and click the 'Rerun Test' button.
	__15.  Verify that this time the bar is green and the tests pass.
	__16.  Go back to the RandomTest.java file in the Spring‑Testing‑TestsProject and open it again if you had closed it.
	__17.  Outside of other methods but within the brackets of the class definition add another test method as shown below.  This will test a new requirement that the component return only non-negative numbers.
	__18.  Save the code and make sure there are no errors.
	__19.  Go back to the JUnit view and click the 'Rerun Test' button several times.  You should notice that the test fails sometimes but that it also passes sometimes.  Since the component does not currently return a non-negative number all the time this test should always fail.  Having the test pass sometimes could give a false positive test.
	__20.  Go back to the RandomTest.java file.
	__21.  Modify the method you had just added to use the @Repeat Spring annotation as shown below.  Granted it is still possible but unlikely the test would generate 10 non-negative numbers in a row this will practically guarantee the test will fail unless the component behaves as expected.
	__22.  Save the code and make sure there are no errors.
	__23.  Go back to the JUnit view and click the 'Rerun Test' button several times.  You should see that the test fails each time although in the Console view you may notice different numbers of repetitions (the output below failed on repetition three).
	__24.  Return to the RandomIntGenerator.java file in the Spring‑Testing‑UnderTest project and open it again if you closed it.
	__25.  Modify the return value of the 'nextNumber' method to use the 'abs' method of the Math class.  Make sure to add the parenthesis around the current return value and that you don't have extra parenthesis in the wrong locations.
	__26.  Save the code and make sure there are no errors.
	__27.  Go back to the JUnit view and click the 'Rerun Test' button several times.  You should see that the tests always pass and that you always see the ten repetitions of the test method in the Console view.
	__28.  Close all open files.

	Part 4 -  Enforce Test Isolation
	__1.  Open IncrementingTest.java under Spring‑Testing‑TestsProject → src → com.webage.test package.  Ignore the warnings about unused imports as they will be used later.
	__2.  Since this test class already has a basic test you can run it by right clicking IncrementingTest.java under Spring‑Testing‑TestsProject → src → com.webage.test package and select 'Run As → JUnit Test'.
	__3.  Verify that the JUnit view does indeed show a green bar and the test passing.
	__4.  Go back to the IncrementingTest.java code and add the following new test method, making sure to put it BEFORE the other test method in the code.  This should cause this test to be run before the other test that we know had passed.
	__5.  Save the code and make sure there are no errors.
	__6.  Go back to the JUnit view and click the 'Rerun Test' button.  Verify that you get a failure but notice that the test method that fails is the second test run which is the one we had run before and it passed.  Also notice that if you scroll to the right in the 'Failure Trace' section the message indicates the returned value was a '60'.
	__7.  Go back to the IncrementingTest.java code and add the following @DirtiesContext annotation to the first test method.
	__8.  Save the code and make sure there are no errors.
	__9.  Go back to the JUnit view and click the 'Rerun Test' button.  Verify this time that all tests pass.
	__10.  Go back to the IncrementingTest.java code and comment out the @DirtiesContext annotation. 
	__11.  Save the code and make sure there are no errors.
	__12.  Go back to the JUnit view and click the 'Rerun Test' button.  Verify that the test fails again.
	__13.  Open IncrementingIntGenerator.java under Spring‑Testing‑UnderTest → src → com.webage.bean package.
	__14.  Remove the comment slashes from in front of the @Scope annotation so that it is now active and using a scope of prototype.
	__15.  Save the code and make sure there are no errors.
	__16.  Go back to the JUnit view and click the 'Rerun Test' button.  Verify that now the tests pass again.

	Part 5 -  Inject Other Spring Components to Test
	__1.  Go back to the IncrementingTest.java file in the Spring‑Testing‑TestsProject and open it again if you had closed it.
	__2.  Add the following field to the IncrementingTest class.  This will inject a different Spring bean defined in the project under test.
	__3.  Further down in the IncrementingTest class add another new test method making sure it is outside other methods but within the brackets for the class definition.
	__4.  Save the code and make sure there are no errors.
	__5.  Go back to the JUnit view and click the 'Rerun Test' button.  Verify that you get a failure which is expected.  Also notice that if you scroll to the right in the 'Failure Trace' section the message indicates the component was only incrementing by 15.
	__6.  Open spring-beans.xml under Spring‑Testing‑UnderTest → src folder.
	__7.  Find the definition of the 'largeIncrementingGenerator' bean and change the value of the 'increment' property to something like '40' so it is over the threshold of 25 expected by the test.
	__8.  Save the code and make sure there are no errors.
	__9.  Go back to the JUnit view and click the 'Rerun Test' button.  Verify that this time the tests pass.
	__10.  Go back to the IncrementingTest.java file and modify the @ContextConfiguration annotation to add another Spring configuration file.  Make sure to add the comma between the two Strings for the file names.
	__11.  Add the following field to the IncrementingTest class that will inject a Spring ApplicationContext.
	__12.  Further down in the IncrementingTest class add another new test method making sure it is outside other methods but within the brackets for the class definition.
	__13.  Save the code and make sure there are no errors.
	__14.  Open test-beans.xml under Spring‑Testing‑TestsProject → src folder.
	__15.  Notice the file has a Spring bean called 'customIncrementor' that will start at 25 and increment by 10 so our test method will verify this.
	__16.  Go back to the JUnit view and click the 'Rerun Test' button.  Verify that all the tests pass.
	__17.  Close all open files.

	Part 6 -  Utilize Mock Objects
	__1.  Open BasicProductCodeTest.java under Spring‑Testing‑TestsProject → src → com.webage.test package.  Ignore the warnings about unused imports as they will be used later.
	__2.  Notice that the class already has an instance of the BasicProductCodeGenerator being injected along with a field that will store a reference to an IntGenerator that will be created using the EasyMock library.
	__3.  Find the 'setUp' method and add the following code.  This will create the mock object that will be used and manually associate the mock object with the 'intGenerator' property of the component that is being tested.
	__4.  Find the 'validateMethodCalled' method and add the following code. 
	__5.  Save the code and make sure there are no errors.
	__6.  Right click BasicProductCodeTest.java under Spring‑Testing‑TestsProject → src → com.webage.test package and select 'Run As → JUnit Test'.
	__7.  Verify that you get a failure which is expected.  Also notice that if you scroll to the right in the 'Failure Trace' section the message indicates the reason for the failure is because the 'nextNumber' method in the mock object was called.  Right now this is because the mock object is “strict” and flags any calls to the mock object that are not expected as errors.
	__8.  Return to the 'setUp' method of the BasicProductCodeTest class and modify the method that creates the mock object to create a “Nice” mock object.
	__9.  Save the code and make sure there are no errors.
	__10.  Go back to the JUnit view and click the 'Rerun Test' button.  Verify that this time the test passes because the mock object does not view the call to 'nextNumber' of the mock object as an error.
	__11.  Return to the 'setUp' method of the BasicProductCodeTest class and modify the method that creates the mock object back to the default of just 'createMock'.
	__12.  Add the following line of code to the 'validateMethodCalled' method.  This will setup the mock object to expect one call to the 'nextNumber' method and return a value of 1700 when it does.
	__13.  Save the code and make sure there are no errors.
	__14.  Go back to the JUnit view and click the 'Rerun Test' button.  Verify that this time the test passes because the mock object was told to expect a call to the 'nextNumber' method and does not view the one call as an error.
	__15.  Further down in the BasicProductCodeTest class add another new test method making sure it is outside other methods but within the brackets for the class definition.
	__16.  Save the code and make sure there are no errors.
	__17.  Go back to the JUnit view and click the 'Rerun Test' button.  Verify that you get a failure which is expected.  Also notice that if you scroll to the right in the 'Failure Trace' section the message indicates the reason for the failure is because the expected String for the product code didn't match the expected.  This proves that the value of '150' returned from the mock object is being used in the product code.
	__18.  Return to the 'validateReturnedCode' method and change the value in the 'andReturn' method of the mock object to '1700' which should let the test pass.
	__19.  Save the code and make sure there are no errors.
	__20.  Go back to the JUnit view and click the 'Rerun Test' button.  Verify the tests do pass.
	__21.  Further down in the BasicProductCodeTest class add another new test method making sure it is outside other methods but within the brackets for the class definition.
	__22.  Save the code and make sure there are no errors.
	__23.  Go back to the JUnit view and click the 'Rerun Test' button.  Verify the tests do pass.
	__24.  Modify the definition of the 'generator' field of the BasicProductCodeTest class so that it is initialized with a “Nice” mock implementation.
	__25.  Modify the code in the 'setUp' method so that it clears the expected behavior of the mock object, sets it up to return three return values, and then puts it in replay mode.
	__26.  Modify the code of the 'validateMethodCalled' method to remove the lines that setup the mock object behavior shown in strikethrough below.
	__27.  Modify the code of the other test methods to remove the same code that sets behavior in the mock object.
	__28.  Save the code and make sure there are no errors.
	__29.  Go back to the JUnit view and click the 'Rerun Test' button.  Verify the tests do pass even though the mock object behavior is set only in the 'setUp' method.
	__30.  Further down in the BasicProductCodeTest class add another new test method making sure it is outside other methods but within the brackets for the class definition.  Notice this method will “pass” if the expected 'ProductCodeException' is thrown by the tested component.  We replicate the mock object throwing an exception by using the 'andThrow' method instead of 'andReturn'.
	__31.  Save the code and make sure there are no errors.
	__32.  Go back to the JUnit view and click the 'Rerun Test' button.   Verify that you get a failure which is expected.  Also notice that if you scroll to the right in the 'Failure Trace' section the message indicates the 'RuntimeException' thrown from the mock object did not match the expected exception type.
	__33.  Open BasicProductCodeGenerator.java under Spring‑Testing‑UnderTest → src → com.webage.bean package.
	__34.  Find the 'getNextProductCode' method in the class.
	__35.  Select ALL of the code within the 'getNextProductCode' method and then select 'Source → Surround With → Try/catch Block' from the Eclipse menus.
	__36.  Modify the contents of the catch block to match that shown below and make sure the structure of the entire method matches.  The code that is added for the try/catch is in bold and several lines of the original method are not shown to simplify this view.
	__37.  Save the code and make sure there are no errors.
	__38.  Go back to the JUnit view and click the 'Rerun Test' button.  Now all the tests should pass as the proper exception is thrown by the BasicProductCodeGenerator class.
	__39.  If you want you can look in the Console view and notice that the exception that was thrown from the mock object is printed out which is one of the steps done in the catch block you added.
	__40.  Close all open files.

	Part 7 -  Lab Cleanup
	__1.  Delete all of the JUnit run configurations as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.
	__2.  Close the Spring-Testing-TestsProject and Spring-Testing-UnderTest projects as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.

	Part 8 -  Review

	Lab 8 -  Spring Alternate Configuration
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\Spring‑Alternate\Spring‑Alternate‑Starter.zip' file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.
	__2.  Open the Spring perspective.
	__3.  In the Markers view check that you have only warnings and no errors from the project.  If there are errors try a Project → Clean to rebuild the project.

	Part 2 -  Examine Current Code
	__1.  Open the pom.xml file from the root of the 'Spring-Alternate' project.
	__2.  Switch to the source of the pom.xml by selecting the 'pom.xml' tab along the bottom of the editor.  You might need to look for some tabs that are hidden on the far right side and expand those to select the proper view.
	__3.  Close the pom.xml file without making any changes.
	__4.  Open spring-beans.xml under the Spring‑Alternate → src folder.
	__5.  Close the spring-beans.xml file without making any changes.
	__6.  Open BasicProductCodeGenerator.java under Spring‑Alternate → src → com.webage.bean package.
	__7.  Close all open files.

	Part 3 -  Perform Basic Java Configuration
	__1.  Open ProductCodeConfiguration.java under Spring‑Alternate → src → com.webage.config package.
	__2.  Add the following @Configuration annotation to the class definition.  You will have errors until future steps.
	__3.  Add the following new field and @Autowired annotation to the class definition.  You will have errors until future steps.
	__4.  Add the following new method to the class making sure to put it inside the curly brackets of the class definition.  You will have errors until future steps.
	__5.  Select Source → Organize Imports from the Eclipse menus.
	__6.  Save the file and be sure you don't have any errors.
	__7.  Open ProductCodeGeneratorTest.java under Spring‑Alternate → src → com.webage.test package.
	__8.  With the ProductCodeGeneratorTest class still open in the editor select Run → Run As → Java Application from the Eclipse menus.
	__9.  The output in the Console view should show product codes being output.  The codes don't start over but this will be fixed with the prototype scope later.
	__10.  Close the ProductCodeGeneratorTest.java file.

	Part 4 -  Qualify Beans for Injection Using Java Configuration
	__1.  Open IntGeneratorConfiguration.java under Spring‑Alternate → src → com.webage.config package.
	__2.  Add the following @Configuration annotation and new method (with @Bean annotation) to the class.  You will have errors until future steps.
	__3.  Select Source → Organize Imports from the Eclipse menus.
	__4.  Save the file and be sure you don't have any errors.
	__5.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__6.  Check that in the Console view you get an error.  This is because there are now two 'IntGenerator' beans defined (one in XML, one by Java configuration) and the Spring container doesn't know which to pick.
	__7.  Return to the ProductCodeConfiguration class and open it again if you had closed it.
	__8.  Add the following Spring @Qualifier annotation to the field definition.  You will have errors until future steps.
	__9.  Select Source → Organize Imports from the Eclipse menus.
	__10.  Save the file and be sure you don't have any errors.
	__11.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__12.  The output in the Console view should no longer show an error but should run correctly.  Notice now you are using the incrementing component that only goes up by 1 number each time.
	__13.  Return to the ProductCodeConfiguration class.
	__14.  Modify the annotations for the field definition to remove the Spring @Qualifier annotation and add the custom @StrategyType annotation from the application.  You will have errors until future steps.
	__15.  Select Source → Organize Imports from the Eclipse menus.
	__16.  Save the file and be sure you don't have any errors.
	__17.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__18.  The output in the Console view should now show you are back to using the incrementing bean that increments by 45.
	__19.  Return to the ProductCodeConfiguration class.
	__20.  Modify the annotations for the field definition to switch to the 'RANDOM' generation strategy in the @StrategyType annotation as shown below.
	__21.  Save the class.
	__22.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__23.  The output in the Console view should show an error since there is no component with that qualification currently defined.
	__24.  Return to the IntGeneratorConfiguration class and open it again if you had closed it.
	__25.  Add the following new method to the class making sure to put it inside the curly brackets of the class definition.  You will have errors until future steps.
	__26.  Select Source → Organize Imports from the Eclipse menus.
	__27.  Save the file and be sure you don't have any errors.
	__28.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__29.  The output in the Console view should now show you are using the random int generator.
	__30.  Return to the ProductCodeConfiguration class.
	__31.  Add the following new field to the class.  Also modify the @StrategyType of the 'intGenerator' bean back to 'LARGE_INCREMENTING' as shown below.  You will have errors until future steps.
	__32.  Modify the content of the 'prodCodeGenerator' @Bean method to match that shown below.
	__33.  Select Source → Organize Imports from the Eclipse menus, selecting java.util.List from the choices when prompted..
	__34.  Save the file and be sure you don't have any errors.
	__35.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__36.  The output in the Console view should now show you are using the large incrementing int generator and that the suffix list is being used.
	__37.  Close all open files.

	Part 5 -  Use Prototype Scope
	__1.  Open ProductCodeConfiguration.java under Spring‑Alternate → src → com.webage.config package.
	__2.  On the 'prodCodeGenerator' method add the @Scope annotation as shown below.  Also remove the line that sets the suffix list since that will make it easier to focus on the numbers used by the product codes.  You will have errors until future steps.
	__3.  Select Source → Organize Imports from the Eclipse menus.
	__4.  Save the file and be sure you don't have any errors.
	__5.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__6.  The output in the Console view should no longer show the suffixes being used but the numbers do not reset with the second group.  This behavior is expected and will be explained next.
	__7.  Return to the ProductCodeConfiguration class.
	__8.  Add the following @Scope annotation at the class level.  This indicates the entire configuration class is prototype scope and will be reconstructed for every bean retrieved.  This will make sure the references of the fields are not used multiple times and avoid the issue you have seen with the behavior.
	__9.  Save the file and be sure you don't have any errors.
	__10.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__11.  The output in the Console view should show that the numbers properly reset between using the two different prototype beans.
	__12.  Add the following new field to the ProductCodeConfiguration class.
	__13.  Modify the 'prodCodeGenerator' @Bean method to call the 'randomGenerator' configuration method directly and use the object returned to configure the product code generator.  Make sure to change the parameter of the 'setIntGenerator' method as shown below.
	__14.  Save the file and be sure you don't have any errors.
	__15.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__16.  The output in the Console view should show that you are again using the random number generator.
	__17.  Close all open files.

	Part 6 -  Use Values in Message Bundles for Configuration
	__1.  Open prefix.properties under the Spring‑Alternate → src folder.
	__2.  Open spring-beans.xml under the Spring‑Alternate → src folder.
	__3.  Add the following Spring bean definition to the configuration file.  This configures Spring to load the message bundle property files you just examined.
	__4.  Save the file and make sure there are no errors.
	__5.  Open ProductCodeConfiguration.java under Spring‑Alternate → src → com.webage.config package.
	__6.  Add the following new field and @Autowired annotation to the class definition. You will have errors until future steps.
	__7.  Add the following new code to the 'prodCodeGenerator' method.  This will look up a message from the message bundles and use it for the property of the bean to be returned.
	__8.  Select Source → Organize Imports from the Eclipse menus.
	__9.  Save the file and be sure you don't have any errors (although you may have warnings).
	__10.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__11.  The output in the Console view should show that the prefix from the message bundle file is being used.
	__12.  Return to the 'prodCodeGenerator' method and change the code to use a French locale for the last parameter in the 'getMessage' method.  You will have errors until the next step.
	__13.  Select Source → Organize Imports from the Eclipse menus.
	__14.  Save the file and be sure you don't have any errors (although you may have warnings).
	__15.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__16.  The output in the Console view should show that the prefix from the French message bundle is being used.
	__17.  Return to the 'prodCodeGenerator' method and change the code to use a different message key, pass an Object array for the message parameter and set the locale parameter back to 'null'.
	__18.  Save the file and be sure you don't have any errors (although you may have warnings).
	__19.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__20.  The output in the Console view should show that the prefix is being set by the other message and that the text of 'test' into the message as the parameter.
	__21.  Close all open files.

	Part 7 -  Create Custom Property Editors
	__1.  Open ComboIntType.java under Spring‑Alternate → src → com.webage.bean package.
	__2.  Open ComboIntGenerator.java under Spring‑Alternate → src → com.webage.bean package.
	__3.  Open ComboIntPropertyEditor.java under Spring‑Alternate → src → com.webage.editors package.
	__4.  Complete the implementation of the 'setAsText' method.  You will have errors until future steps.  You can also find code to copy/paste from in the <LABFILES>\Spring‑Alternate\Solution\ComboIntPropertyEditor.java file.
	__5.  Select Source → Organize Imports from the Eclipse menus, selecting java.util.List from the choices when prompted..
	__6.  Save the file and be sure you don't have any errors.
	__7.  Open ComboIntRegistrar.java under Spring‑Alternate → src → com.webage.editors package.
	__8.  Complete the implementation of the 'registerCustomEditors' method with the code below.
	__9.  Save the file and be sure you don't have any errors.
	__10.  Open spring-beans.xml under the Spring‑Alternate → src folder.
	__11.  Add the following Spring bean definition to the configuration file.  This configures the custom property registrar with Spring in addition to the standard Spring property editors.
	__12.  Add the following bean configuration to the XML file.  This will configure a bean for the ComboIntGenerator class using the special syntax recognized by the custom property editor which will convert from the String '145-10,100,1000'.
	__13.  Save the file and be sure you don't have any errors.
	__14.  Open ProductCodeConfiguration.java under Spring‑Alternate → src → com.webage.config package.
	__15.  Add the following new field and @Autowired annotation to the class definition. 
	__16.  Modify the implementation of the 'prodCodeGenerator' method to only include the one line shown below.  This will use the ComboIntGenerator and use the comboIntGenerator to create a prefix which will be explained in a little bit.
	__17.  Save the file and be sure you don't have any errors.
	__18.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__19.  The output in the Console view should now show some interesting behavior. Notice that the line that outputs what text is being converted is only called once even though the test class looks up the bean twice and it should be a prototype bean (as seen previously).  It appears that the behavior of Spring is that once it has converted a property value once it remembers the value that was set and uses the SAME OBJECT in the future WITHOUT calling the conversion again.
	__20.  Open ProductCodeGeneratorTest.java under Spring‑Alternate → src → com.webage.test package.
	__21.  Modify the 'main' method and the type of Spring ApplicationContext to turn it into a 'ConfigurableApplicationContext' as shown below.  You will have errors until the next step.
	__22.  Select Source → Organize Imports from the Eclipse menus.
	__23.  Add the following call to 'refresh' the context between the output from the first bean but before calling the 'getBean' method a second time.
	__24.  Save the file and be sure you don't have any errors.
	__25.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__26.  Now you should see that it is calling the property conversion a second time because the context was refreshed.  You may also see some text about refreshing the context between the two blocks of output.  You should also be able to run it a few times and get an output that shows that the starting number used by the second generator is less than the final number of the first generator which also proves the conversion is happening with a new object.

	Part 8 -  Lab Cleanup
	__1.  Delete the ProductCodeGeneratorTest run configuration from the Java Application run configurations as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.
	__2.  Close the Spring-Alternate project as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.

	Part 9 -  Review

	Lab 9 -  Use Spring JPA Support
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\JPA-Spring\JPA‑Spring‑Starter.zip' file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.
	__2.  Open the Spring perspective.
	__3.  In the Markers view check that you have only warnings and no errors.

	Part 2 -  Add JPA Dependencies
	__1.  Open the pom.xml file from the root of the 'JPA-Spring' project.
	__2.  Switch to the source of the pom.xml by selecting the 'pom.xml' tab along the bottom of the editor.  You might need to look for some tabs that are hidden on the far right side and expand those to select the proper view.
	__3.  Near the bottom of the file, find the section that is commented out (<!-- .. -->) that has the dependencies for the various Hibernate and Spring ORM JARs.  Remove the comment tags from before and after this section so the Hibernate and Spring ORM JARs are active dependencies. 
	__4.  Save the file and be sure there are no red errors in the margin for the file.  These will occur if you don't remove the comments properly.
	__5.  Wait for a few seconds while the project is built and then expand the 'Maven Dependencies' for the project in the 'Package Explorer' view and make sure you see the various Hibernate and Spring ORM JARs listed.  There will be other JARs also imported.
	__6.  Collapse the dependencies again.

	Part 3 -  Modify Project Properties
	__1.  Right click on the JPA-Spring project and select Properties.
	__2.  Select Project Facets from the left side of the project properties.
	__3.  Check the box for the 'Utility Module' and 'JPA' facets and make sure the version of the JPA facet is 2.0.  Do not close the properties yet though.
	__4.  Click on the title of the 'JPA' facet so it is selected and then click the link for 'Further configuration available' below.
	__5.  On the configuration of the JPA facet, under the setting for 'JPA Implementation' select the 'Disable Library Configuration' as shown below and click the OK button.
	__6.  Once you have configured the JPA facet and are back in the project properties select the Java Build Path project properties on the left.
	__7.  Select the Libraries tab of the Java build path properties and click the button for 'Add External JARs' on the right.
	__8.  Navigate to the '<SOFTWARE>\db-derby-10.7.1.1-bin\lib' directory and select the 'derbyclient.jar' file and press the Open button to complete the selection.
	__9.  Check that the JAR file is listed as shown and then click the OK button to close the project properties.
	__10.  In the Markers view check that you have only warnings and no errors.  You will have more warnings than before because of some of the classpath settings but this will be fine.

	Part 4 -  Configure JPA Entity
	__1.  In the Package Explorer view, expand the following folders:
	__2.  Open the Purchase.java file in the com.webage.domain package by double clicking it.  Notice that this is just a regular Java class with a few properties and get/set methods.
	__3.  Add the following code annotations in bold to the existing class.  You will have some errors until fixed in the next step.
	__4.  Select Source → Organize Imports from the menus.  When prompted select javax.persistence.Entity and click the Finish button.
	__5.  Save the class.  You will have another error that will be fixed next.
	__6.  In the Package Explorer view, expand the following folders:
	__7.  Right click the persistence.xml file and select JPA Tools → Synchronize Class List from near the bottom.
	__8.  Check that the error in the Purchase class is gone.  Now the Purchase class is explicitly listed in the persistence.xml file so JPA will know to manage it.

	Part 5 -  Modify Spring Configuration
	__1.  Open the 'src/spring-beans.xml' file.  Notice right now it is just a few configurations that will look for annotations and a property-placeholder that will load properties from a file.
	__2.  Switch to the Source tab in the editor.
	__3.  Add the following Spring bean configuration.  Make sure you add it outside of other bean configurations but within the containing <beans> tag. You can also find code to copy/paste from in the <LABFILES>\JPA-Spring\Solution\spring-beans.xml file.
	__4.  Add the following Spring bean definition to configure the Spring JPA support.  Be careful for how the bean definition wraps to multiple lines below.  This is the core configuration of Spring JPA support.
	__5.  Finally add the third Spring bean definition shown below.  This will define a DataSource that Spring will use with JPA to link to the actual database being used.
	__6.  Save the file and be sure there are no errors from incorrect syntax.
	__7.  Open the 'src/datasource.properties' file.  This is the file read from the Spring configuration to provide many properties which might change.  The property names used are already in the file but you will supply the values.
	__8.  Supply the following property values in bold for the properties.  Make sure not to add extra space at the end of the lines.  You can also find code to copy/paste from in the <LABFILES>\JPA-Spring\Solution\datasource.properties file.
	__9.  Save and close all files.

	Part 6 -  Begin JPA DAO Implementation
	__1.  In the Package Explorer view, expand the following folders:
	__2.  Open the PurchaseDAOJPAImpl.java file in the com.webage.dao package by double clicking it.  Notice that right now it is just an empty implementation of the 'PurchaseDAO' interface.
	__3.  Add the following code annotations in bold to the existing class.  You will have some errors until fixed in the next steps.
	__4.  Add the following new field to the class shown in bold.  This will add the JPA EntityManager used to persist data.  You will still have errors in the code.
	__5.  Select Source → Organize Imports from the menus.  
	__6.  Save the class and make sure there are no errors.
	__7.  Locate the 'savePurchase' method and provide the bold implementation below.
	__8.  Save the file and make sure there are no errors.

	Part 7 -  Test JPA Functionality
	__1.  Start the database following the steps in the 'Common Lab Preparation Steps' at the 'Start Derby Database' part.
	__2.  Back in Eclipse, open the 'src/test-beans.xml' file.  Notice that this simply declares a few Purchase beans for test data along with a 'java.util.Date' property editor for converting the date in the test beans into the correct format for the property.
	__3.  In the Package Explorer view, expand the following folders:
	__4.  Open the SpringJPATest.java file in the com.webage.test package by double clicking it.  Notice that right now it is just a JUnit test class without any declared tests. The class does have some fields already declared, some of which are injected by Spring, which you will use in your tests.
	__5.  Add the following new test method to the class below the comment for where to add test methods.  This test simply attempts to save the data from the two test Purchase beans.  You can also find code to copy/paste from in the <LABFILES>\JPA‑Spring\Solution\SpringJPATest.java file.
	__6.  Save the file and make sure there are no errors although you will get warnings.
	__7.  Find the SpringJPATest class in the Package Explorer view, right click on it, and select 'Run As → JUnit Test'
	__8.  The JUnit view should display and indicate after several seconds that the test passed.
	__9.  Look in the Console view, scroll up a little bit and you should see the Hibernate SQL statements (although without the actual values) after several other messages from Hibernate about setting up the database connection and exporting the database schema to the database.

	Part 8 -  Use Spring Database Test Utilities
	__1.  Open the 'src/test-beans.xml' file.  You may need to switch to the Package Explorer view to see the files of the project.
	__2.  Find the comment at the bottom of the file for adding Spring JDBC test utilities and add the following <bean> element before the ending </beans> tag but after the comment.
	__3.  Save the file and make sure there are no errors.
	__4.  Return to the SpringJPATest.java file in the com.webage.test package and open it again if you closed it.
	__5.  Add the following new field in the SpringJPATest class along with the Spring autowiring.  You will have errors until another step.  This will inject the bean you just added to the test Spring configuration.
	__6.  Add the following new lines before and after the existing code in the 'testInsert' method.  This will use the SimpleJdbcTestUtils class and the field you just injected to count the rows in the database.  
	__7.  Select Source → Organize Imports from the menus.  Select 'org.junit.Assert' when prompted.
	__8.  Save the file and make sure there are no errors.
	__9.  From the menus select 'Run → Run History → SpringJPATest'.
	__10.  You should see the test failure and the failure message.
	__11.  Go back to the end of the 'testInsert' method and change the assertion so it expects to end with 2 more records than the table started with.
	__12.  Save the file and make sure there are no errors.
	__13.  From the menus select 'Run → Run History → SpringJPATest'.
	__14.  This time you should see the test pass.

	Part 9 -  Implement Query Functionality
	__1.  Open the PurchaseDAOJPAImpl.java file in the com.webage.dao package by double clicking it. 
	__2.  Locate the 'getPurchase' method and replace the implementation with the bold code below.  This uses a method already supplied by the EntityManager to locate data by primary key.
	__3.  Save the file and make sure there are no errors.
	__4.  Return to the SpringJPATest.java file in the com.webage.test package and open it again if you closed it.
	__5.  Add the following new test method to the end of the test class.  Make sure to add it after the other test method.
	__6.  Save the file and make sure there are no errors.
	__7.  From the menus select 'Run → Run History → SpringJPATest'.
	__8.  Both tests should pass.

	Part 10 -  Isolate Tests
	__1.  Return to the SpringJPATest.java file in the com.webage.test package and open it again if you closed it.
	__2.  Add the following annotation to the 'testInsert' method.  You will have some errors.
	__3.  Select Source → Organize Imports from the menus.
	__4.  Save the file and make sure there are no errors.
	__5.  From the menus select 'Run → Run History → SpringJPATest'.
	__6.  This time you should see that the second test method fails with the failure message that there is no data.  This is what we actually expect based on the @DirtiesContext behavior and the Hibernate settings.

	Part 11 -  Initialize Test Data
	__1.  Open the 'src/test-beans.xml' file.  You will need to switch to the Package Explorer view to see the files of the project.
	__2.  Switch to the 'Namespaces' tab of the editor.
	__3.  In the list of namespaces, check the box for 'jdbc' as shown below.  If the confirmation dialog appears click the OK button.
	__4.  Click the 'Source' tab on the bottom of the editor.
	__5.  At the bottom of the file add the following <jdbc:initialize-database> element before the ending </beans> tag but after the other <bean> elements.
	__6.  Save the file and make sure there are no errors.
	__7.  Open the 'src/testData.sql' file.  This has three statements that will insert test data.
	__8.  Close the file without making any changes.
	__9.  From the menus select 'Run → Run History → SpringJPATest'.  This time you should see there are no failures.  Even though we didn't change the test it now passes because even though the Spring context is refreshed (and the data cleared) after the first test, the database initialization is making sure there is test data available for the 'testGetPurchase' method.

	Part 12 -  Finish JPA Implementation
	__1.  Open the PurchaseDAOJPAImpl.java file in the com.webage.dao package by double clicking it. 
	__2.  Locate the 'savePurchase' method and modify the implementation as shown below.
	__3.  Finally, provide the following implementation to the 'getAllPurchases' method.  You will have errors until the next step.
	__4.  Select Source → Organize Imports from the menus.  When prompted select javax.persistence.Query and click the Finish button.
	__5.  Save the file.
	__6.  Return to the SpringJPATest.java file and add the following new test method to the class below the existing test methods.
	__7.  Select Source → Organize Imports from the menus.  When prompted select java.util.List and click the Finish button.
	__8.  Save the file with the new test method.
	__9.  From the menus select 'Run → Run History → SpringJPATest'.
	__10.  Again check that the JUnit view shows success, this time with three test methods.
	__11.  Return to the SpringJPATest.java file and add the following new test method to the class.  This method selects one of the purchases from the database, modifies the 'Product' property, saves the Purchase, queries for the Purchase again (to select data after an update), and then compares the 'Product' property to be sure it was updated in the database.
	__12.  Save the file with the new test method.
	__13.  From the menus select 'Run → Run History → SpringJPATest'.
	__14.  Again check that the JUnit view shows success, this time with four test methods.
	__15.  Close any open files.

	Part 13 -  Lab Cleanup
	__1.  Delete the SpringJPATest run configuration from the JUnit run configurations as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.
	__2.  Close the JPA-Spring project as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.
	__3.  Follow the steps in the 'Common Lab Preparation Steps' at the 'Stop Derby Database' part.

	Part 14 -  Review

	Lab 10 -  Use JDBC Support of Spring
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\JDBC-Spring\JDBC‑Spring‑Starter.zip' file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.
	__2.  Open the Spring perspective.
	__3.  In the Markers view check that you have only warnings and no errors.

	Part 2 -  Examine JDBC Dependencies
	__1.  Open the pom.xml file from the root of the 'JDBC-Spring' project.
	__2.  Switch to the source of the pom.xml by selecting the 'pom.xml' tab along the bottom of the editor.  You might need to look for some tabs that are hidden on the far right side and expand those to select the proper view.
	__3.  Near the bottom of the file, find the following dependency for the Spring JDBC module.
	__4.  Select the 'Dependency Hierarchy' tab along the bottom of the editor.
	__5.  On the right side, under 'Resolved Dependencies' click on the org.springframework.transaction dependency.  Notice on the left that this module is only required for the JDBC module.
	__6.  On the right side, under 'Resolved Dependencies' click on the org.springframework.jdbc dependency.  Notice on the left that this module is not required by any other modules and is a top-level dependency added since code you write will use this module.
	__7.  Close the file making sure you did not make any changes.

	Part 3 -  Configure DataSource
	__1.  Right click on the JDBC-Spring project and select Properties.
	__2.  Select the Java Build Path project properties on the left.
	__3.  Select the Libraries tab of the Java build path properties and click the button for 'Add External JARs' on the right.
	__4.  Navigate to the '<SOFTWARE>\db-derby-10.7.1.1-bin\lib' directory and select the 'derbyclient.jar' file and press the Open button to complete the selection.
	__5.  Check that the JAR file is listed as shown and then click the OK button to close the project properties.
	__6.  Open the 'src/spring-beans.xml' file.  Notice right now it is just a few configurations that will look for annotations and a property-placeholder that will load properties from a file.
	__7.  Switch to the Source tab in the editor.
	__8.  Add the Spring bean definition shown below.  This will define a DataSource that Spring will use with JDBC support classes to link to the actual database being used.
	__9.  Save the file and be sure there are no errors from incorrect syntax.
	__10.  Open the 'src/datasource.properties' file.  Examine the following properties for how the project will connect to the database.
	__11.  Close all files.

	Part 4 -  Begin JDBC DAO Implementation
	__1.  In the Package Explorer view, expand the following folders:
	__2.  Open the PurchaseDAOJDBCImpl.java file in the com.webage.dao package by double clicking it.  Notice that right now it is just an empty implementation of the 'PurchaseDAO' interface.
	__3.  Add the following code annotation in bold to the existing class.  You will have some errors until fixed in the next steps.  You can also find code to copy/paste from in the <LABFILES>\JDBC‑Spring\Solution\PurchaseDAOJDBCImpl.java file.
	__4.  Add the following new field to the class shown in bold.  This will add a Spring SimpleJdbcTemplate which is one of the more common classes used with Spring JDBC support.
	__5.  Find the 'setDataSource' method and add the @Autowired annotation to the declaration of the method.
	__6.  In the body of the 'setDataSource' method add the following code in bold to initialize the 'simpleJdbcTemplate' field of the class.
	__7.  Go to the bottom of the PurchaseDAOJDBCImpl class and add the following class definition.  Make sure it is outside the curly brackets for the other class declaration.
	__8.  Save the class and make sure there are no errors.  You will have warnings.

	Part 5 -  Complete and Test 'getAllPurchases' Functionality
	__1.  Start the database following the steps in the 'Common Lab Preparation Steps' at the 'Start Derby Database' part.
	__2.  Back in Eclipse, open the 'src/test-beans.xml' file.  Notice that this simply declares a few Purchase beans for test data along with a 'java.util.Date' property editor for converting the date in the test beans into the correct format for the property.  There are also a few other Spring declarations for things used during testing.
	__3.  In the Package Explorer view, expand the following folders:
	__4.  Open the SpringJDBCTest.java file in the com.webage.test package by double clicking it.  Notice that right now it is just a JUnit test class without any declared tests. The class does have some fields already declared, some of which are injected by Spring, which you will use in your tests.
	__5.  Add the following new test method to the class below the comment for where to add test methods.  This test verifies the size of the list obtained from the 'getAllPurchases' method matches the number of rows in the table found independently with the SimpleJdbcTestUtils.countRowsInTable method.  You can also find code to copy/paste from in the <LABFILES>\JDBC‑Spring\Solution\SpringJDBCTest.java file.
	__6.  Save the file and make sure there are no errors although you will get warnings.
	__7.  Find the SpringJDBCTest class in the Package Explorer view, right click on it, and select 'Run As → JUnit Test'
	__8.  The JUnit view should display and indicate after several seconds that the test failed.  This is expected since we did not yet implement the functionality of the method being tested.
	__9.  Return to the PurchaseDAOJDBCImpl.java file and reopen it if you had closed it.
	__10.  Modify the implementation of the 'getAllPurchases' method to match the bold code below.  This will use the 'simpleJdbcTemplate' field and the 'PurchaseRowMapper' class you added code for earlier.
	__11.  Save the file and make sure there are no errors although you will get warnings.
	__12.  From the menus select 'Run → Run History → SpringJDBCTest'.  Now the test should pass.

	Part 6 -  Complete and Test 'getPurchase' Functionality
	__1.  Return to the SpringJDBCTest.java file in the com.webage.test package and open it again if you closed it.
	__2.  Add the following new test method to the end of the test class.  Make sure to add it after the other test method.  This will get a record from the database and compare it with the expected values.
	__3.  Save the file and make sure you have no errors.
	__4.  From the menus select 'Run → Run History → SpringJDBCTest'.  The new test should fail since the 'getPurchase' method isn't implemented yet.
	__5.  Return to the PurchaseDAOJDBCImpl.java file and reopen it if you had closed it.
	__6.  Add the following new field to the class shown in bold.  This uses  NamedParameterJdbcTemplate which is another class from the Spring JDBC classes.
	__7.  Find the 'setDataSource' method and add the following code in bold to initialize the 'simpleJdbcTemplate' field of the class.
	__8.  Modify the implementation of the 'getPurchase' method to match the bold code below.  You will have an error which will be fixed in the next step.  Be careful with how the SQL String is constructed as it is split between two lines below.
	__9.  Find the line with the error on the 'getIDParameterSource' method call and click the "Quick Fix" icon in the left margin of the editor.  Once the list of solutions to the error appears, double click the 'Create method getIDParameterSource(int)' option to add the method.
	__10.  Once the stub for the new method is added, change the implementation of the method to match the bold code below.
	__11.  Save the file and make sure there are no errors although you will get warnings.
	__12.  From the menus select 'Run → Run History → SpringJDBCTest'.  Now both tests should pass.

	Part 7 -  Implement Inserting New Records
	__1.  Return to the SpringJDBCTest.java file in the com.webage.test package and open it again if you closed it.
	__2.  Add the following new test method to the end of the test class.  Make sure to add it after the other test methods.  This will get Spring beans from the 'test-beans.xml' file and save them into the database.
	__3.  Save the file and make sure you have no errors.
	__4.  From the menus select 'Run → Run History → SpringJDBCTest'.  The new test should fail since the 'savePurchase' method isn't implemented yet.
	__5.  Return to the PurchaseDAOJDBCImpl.java file and reopen it if you had closed it.
	__6.  Add the following new field to the class shown in bold.  This uses the SimpleJdbcInsert class from the Spring JDBC classes.
	__7.  Find the 'setDataSource' method and add the following code in bold to initialize the 'SimpleJdbcInsert' field of the class.
	__8.  Add the following new method to the PurchaseDAOJDBCImpl class.  Make sure it is outside of any other methods but within the curly brackets for the class definition.
	__9.  Find the 'savePurchase' methos and modify the implementation to match the code in bold below.
	__10.  Save the file and make sure there are no errors although you will get warnings.
	__11.  From the menus select 'Run → Run History → SpringJDBCTest'.  Now all three tests should pass.

	Part 8 -  Update Existing Data
	__1.  Return to the SpringJDBCTest.java file in the com.webage.test package and open it again if you closed it.
	__2.  Add the following new test method to the end of the test class.  Make sure to add it after the other test methods.  This will update the product of an existing purchase and check if the updates were saved properly.
	__3.  Save the file and make sure you have no errors.
	__4.  From the menus select 'Run → Run History → SpringJDBCTest'.  The new test should fail since the 'savePurchase' method isn't able to update purchases yet.
	__5.  Return to the PurchaseDAOJDBCImpl.java file and reopen it if you had closed it.
	__6.  Add the following code in bold to the beginning of the 'savePurchase' method.  This will check if the Purchase passed as a parameter to the method already exists.
	__7.  Add the following 'if .. else' statement using the existing code for inserting a new record as the body of the 'if' portion of the statement.  For now we will leave the 'else' portion empty.
	__8.  Organize imports. (Ctrl+Shift+O)
	__9.  Save the file and make sure there are no errors although you will get warnings.
	__10.  From the menus select 'Run → Run History → SpringJDBCTest'.  Check that even though the 'testUpdate' method still fails, the 'testInsert' method still passes.  This verifies we haven't broken the functionality of inserting new records.
	__11.  Return to the empty 'else' of the 'if .. else' statement you added.  Fill in the bold code below which will implement the functionality to run an UPDATE SQL query.  Be careful with the creation of the SQL String as it splits between three lines below.  Also make sure that the parameter names in the query (':purchaseDate') have the correct spelling and capitalization or else the query will not work.
	__12.  Save the file and make sure there are no errors although you will get warnings.
	__13.  From the menus select 'Run → Run History → SpringJDBCTest'.  This time all the tests should pass.
	__14.  Close any open files.

	Part 9 -  Lab Cleanup
	__1.  Delete the SpringJDBCTest run configuration from the JUnit run configurations as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.
	__2.  Close the JDBC-Spring project as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.
	__3.  Follow the steps in the 'Common Lab Preparation Steps' at the 'Stop Derby Database' part.

	Part 10 -  Review

	Lab 11 -  Use AOP to Manage Transactions
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\Transaction\Transaction‑Starter.zip' file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.
	__2.  Open the Spring perspective if needed.
	__3.  In the Markers view check that you have only warnings and no errors.  If you do see errors select Project → Clean and clean all projects to see if they are resolved.

	Part 2 -  Add JPA Transaction Support
	__1.  In the Package Explorer view, expand the following folders:
	__2.  Open the PurchaseDAOJPAImpl.java file in the com.webage.dao package by double clicking it.  
	__3.  Add the following code annotation in bold to the existing class.  
	__4.  Save the class and make sure there are no errors.
	__5.  Open the 'src/spring-beans.xml' file.  Notice right now it contains things like the JPA 'EntityManagerFactory' configuration and a DataSource.  It doesn't have any transaction support yet though.
	__6.  Switch to the Source tab in the editor.
	__7.  Add the following Spring bean configuration.  Make sure you add it outside of other bean configurations but within the containing <beans> tag. You can also find code to copy/paste from in the <LABFILES>\Transaction\Solution\spring‑beans‑annotation.xml file.
	__8.  Add the following configuration which will tell the Spring transaction management to locate transaction details through the annotations in code like @Transactional.
	__9.  Save the file and make sure there are no errors.
	__10.  Close all open files.

	Part 3 -  Verify Current Functionality
	__1.  Start the database following the steps in the 'Common Lab Preparation Steps' at the 'Start Derby Database' part.
	__2.  In the Package Explorer view, expand the following folders:
	__3.  Open the DAOTests.java file in the com.webage.test package by double clicking it. Notice that this class already has tests that will directly test the 'PurchaseDAO' interface. Since this is the component that works directly with JPA these tests will independently verify the JPA functionality.  Examine the tests in more detail if you wish to understand what they do.
	__4.  Close the file making sure you did not make any changes.  All tests we add will be in a different file.
	__5.  Open the TransactionTest.java file in the com.webage.test package by double clicking it.  In the future we will add tests to this class to test the 'PurchaseManager' interface with transactions but right now no changes will be made.
	__6.  With the TransactionTest.java file open select 'Run → Run As → JUnit Test'.  If you do not see this option you may not have the editor on the 'TransactionTest' class selected and active.
	__7.  Verify that you see in the JUnit view that all four existing tests have passed.

	Part 4 -  Write Additional Transaction Tests
	__1.  In the Package Explorer view, expand the following folders:
	__2.  Open the PurchaseManagerImpl.java file in the com.webage.service package by double clicking it.  
	__3.  Examine the methods and notice that most of the methods simply pass through calls to the injected 'purchaseDAO' component.  In particular notice that the 'savePurchaseWithException' method saves the purchase and then calls a method that will always throw an Exception.  What we want to find out is how we can use transactions with this method to have the database updated be "rolled back" when the Exception occurs.
	__4.  Also notice there is another method, 'savePurchaseNoException' which saves the purchase but does not call the method to throw an Exception.  This is so we can manually verify transaction behavior by calling different methods in the tests.
	__5.  Close the file and make sure you didn't make any changes.
	__6.  Return to the TransactionTest.java file in the com.webage.test package and open it again if you closed it.
	__7.  Add the following two new test methods to the class.  You can also find code to copy/paste from in the <LABFILES>\Transaction\Solution\TransactionTest.java file although only copy these lines of code if you use it.
	__8.  Save the file and make sure there are no errors.
	__9.  From the menus select 'Run → Run History → TransactionTest'.  You should see that all six tests pass.
	__10.  Return to the TransactionTest.java file.
	__11.  Add the following new test that will call the method that throws an Exception and verify that the Exception was indeed thrown.
	__12.  Save the file and make sure there are no errors.
	__13.  From the menus select 'Run → Run History → TransactionTest'.  You should see that all seven tests pass.

	Part 5 -  Modify Transactional Behavior
	__1.  Return to the TransactionTest.java file in the com.webage.test package and open it again if you closed it.
	__2.  Add the following new test that will call the method that throws an Exception.  Notice the empty 'catch' block which will ignore the Exception that is thrown so the test can check if the number of rows in the database has changed.
	__3.  Save the file and make sure there are no errors.
	__4.  From the menus select 'Run → Run History → TransactionTest'.  You should see that the 'testSaveExpectingRollback' test is the only one that fails.  This verifies the 'PurchaseManager' is not transactional and that the database update was still made.
	__5.  In the Package Explorer view, expand the following folders:
	__6.  Open the PurchaseManagerImpl.java file in the com.webage.service package by double clicking it.  
	__7.  Add the following annotation to the class declaration.  You will have errors until the next step.
	__8.  Select Source → Organize Imports from the Eclipse menus.
	__9.  Save the file and make sure there are no errors.
	__10.  From the menus select 'Run → Run History → TransactionTest'.  You should now see that all eight tests pass.  Now that the 'PurchaseManager' component is transactional, the Exception causes the interaction with the JPA component to be "rolled back" and the database remains in the same state as the start of the test.
	__11.  Return to the PurchaseManagerImpl.java file.
	__12.  Add the following annotation only to the 'getPurchase' method.
	__13.  Save the file and make sure there are no errors.
	__14.  From the menus select 'Run → Run History → TransactionTest'.  You should see that all eight tests still pass.  
	__15.  Close all open files.

	Part 6 -  Configure Transaction Behavior With XML
	__1.  Open the 'src/spring-beans.xml' file from the Transactions project.
	__2.  Find the line with the <tx:annotation-driven> syntax and comment out or completely delete this entire tag.  Make sure you don't alter any other elements.  Also make sure you get an ending tag if there is one.  If you try to add a comment Eclipse will automatically close the comment so you will need to move the end comment tag.
	__3.  Save the file and make sure there are no errors.  Errors would occur if you didn't remove the entire <tx:annotation-driven> element correctly.
	__4.  From the menus select 'Run → Run History → TransactionTest'.  You should see a number of tests fail because none of the Spring components are transactional anymore which means even the basic JPA functionality isn't working. 
	__5.  Open the pom.xml file from the root of the 'Transactions' project.
	__6.  Switch to the source of the pom.xml by selecting the 'pom.xml' tab along the bottom of the editor.  You might need to look for some tabs that are hidden on the far right side and expand those to select the proper view.
	__7.  Near the bottom of the file, find the section that is commented out (<!-- .. -->) that has the dependency for the AspectJ "Tools" module.  Remove the comment tags from before and after this section so the AspectJ JAR is an active dependency. 
	__8.  Save the file and be sure there are no red errors in the margin for the file.  These will occur if you don't remove the comments properly.
	__9.  Return to the 'spring-beans.xml' file and open it if you had closed it.
	__10.  Add the following <tx:advice> syntax to the Spring configuration file, making sure it is outside other XML elements but within the overall <beans> root element.  You can also find code to copy/paste from in the <LABFILES>\Transaction\Solution\spring‑beans‑XML.xml file.
	__11.  Add the following <aop:config> syntax, making sure it is outside of all other elements.    Pay close attention to the spaces and asterisks in the 'expression' attribute of the pointcut configuration.  The syntax of this expression is the main reason XML configuration is more difficult.
	__12.  Save the file and be sure there are no red errors in the margin for the file.
	__13.  From the menus select 'Run → Run History → TransactionTest'.  You should see that the only test that fails is the 'testSaveExpectingRollback' test.  This proves our JPA component is transactional and functioning again but that the 'PurchaseManager' component isn't transactional.
	__14.  Return to the 'spring-beans.xml' file and open it if you had closed it.
	__15.  Add the following additional <aop:pointcut> and <aop:advisor> syntax within the existing <aop:config> element.  Notice that the order of the elements matters so you need to group the <aop:pointcut> elements together before the <aop:advisor> elements.
	__16.  Save the file and be sure there are no red errors in the margin for the file.
	__17.  From the menus select 'Run → Run History → TransactionTest'.  You should now see that all of the tests pass since the appropriate components are transactional again and behaving as expected.
	__18.  Close any open files.

	Part 7 -  Lab Cleanup
	__1.  Delete the TransactionTest run configuration from the JUnit run configurations as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.
	__2.  Close the Transactions project as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.
	__3.  Follow the steps in the 'Common Lab Preparation Steps' at the 'Stop Derby Database' part.

	Part 8 -  Review

	Lab 12 -  Add Custom AOP Functionality
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\Spring‑AspectJ\Spring‑AspectJ‑Starter.zip' file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.
	__2.  Open the Spring perspective if needed.
	__3.  In the Markers view check that you have only warnings and no errors from the project.  If there are errors try a Project → Clean to rebuild the project.

	Part 2 -  Test Current Function
	__1.  Open ProductCodeGeneratorTest.java under Spring‑AspectJ → src → com.webage.test package.  Notice this class simply loads the 'spring-beans.xml' bean configuration, retrieves the 'prodCodeGenerator' and 'randomCodeGenerator' beans and prints out a few product codes.  
	__2.  With the ProductCodeGeneratorTest class still open in the editor select Run → Run As → AspectJ/Java Application from the Eclipse menus.
	__3.  In the Console view you should see that a few codes which increment at large steps are printed followed by a few that are random.  The fact that the code uses different implementations of the 'IntGenerator' interface will be important later.
	__4.  Close the ProductCodeGeneratorTest.java file.

	Part 3 -  Add Logging Using AOP
	__1.  Open the pom.xml file from the root of the 'Spring-AspectJ' project.
	__2.  Switch to the source of the pom.xml by selecting the 'pom.xml' tab along the bottom of the editor.  You might need to look for some tabs that are hidden on the far right side and expand those to select the proper view.
	__3.  Near the bottom of the file, find the dependency for the AspectJ "Tools" module. Notice that this is already an active dependency so that some of the classes you imported could retain some import statements in the code to simplify coding without getting compilation errors.
	__4.  Close the file and make sure you didn't make any changes.
	__5.  Open LogAspect.java under Spring‑AspectJ → src → com.webage.aspects package.  Notice that right now it is an empty file you will edit to add our Logging AOP code.
	__6.  On the class declaration add the 'implements Ordered' code shown below.  You will have an error until further steps.
	__7.  Add the following code to the class.  This stores the "order" as a field and provides get/set methods for the value.   You can also find code to copy/paste from in the <LABFILES>\Spring‑AspectJ\Solution\LogAspect.java file.
	__8.  Save the file and make sure there are no errors.  Leave the file open for the next steps.
	__9.  Add the following two new methods.  Make sure you add them outside of other methods but within the curly brackets for the class definition.  Also be careful about the String concatenation that is split between multiple lines below.
	__10.  Save the file and make sure you have no errors.
	__11.  Open the 'src/spring-beans.xml' file.  Notice right now it contains a 'randomCodeGenerator' bean and a <context:component-scan> configuration but nothing about AOP.
	__12.  Add the following Spring bean configuration.  Make sure you add it outside of other bean configurations but within the containing <beans> tag. You can also find code to copy/paste from in the <LABFILES>\Spring‑AspectJ\Solution\spring‑beans‑logging.xml file.
	__13.  Add the following <aop:config> syntax, making sure it is outside of all other elements.  Pay close attention to the spaces and asterisks in the 'pointcut' attribute of the <aop:around> configuration.  Notice that this configuration will call the 'log' method of the 'aroundLogger' bean (the LogAspect class) for every method called on a component from the 'com.webage.bean' package.
	__14.  Save the file and make sure you don't have any errors.
	__15.  Open BasicProductCodeGenerator.java under Spring‑AspectJ → src → com.webage.bean package.
	__16.  Find the 'getNextProductCode' method.
	__17.  In the left margin, hover your mouse over the double arrows next to the method.  Notice in the popup dialog that Eclipse knows this method will be advised by the 'log' method of the LogAspect class.
	__18.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__19.  In the output you should see a number of 'BEFORE' and 'AFTER' messages being printed from the LogAspect class.  Notice these are all before the line that prints the code returned to each call in the test class.  You can also see the 'IntGenerator' implementation class that was used to generate the code from the 'nextNumber' method calls.
	__20.  Close all open files.

	Part 4 -  Introduce Execution Count Functionality Using AOP
	__1.  Open DefaultCountable.java under Spring‑AspectJ → src → com.webage.aspects package.  Notice that right now it is a pretty simple class that has a 'count' field that can be incremented and the current value can be retrieved.  It also implements the 'Countable' interface which is what we will use later.
	__2.  Close the file and make sure you didn't make any changes.
	__3.  Open CountAspect.java under Spring‑AspectJ → src → com.webage.aspects package. 
	__4.  Add the following three annotations to the class declaration.  You can also find code to copy/paste from in the <LABFILES>\Spring‑AspectJ\Solution\CountAspect.java file.  These will declare this as an AspectJ aspect class, configure the aspect ordering value, and define this as a Spring component by annotations.
	__5.  Add the following annotation and field to the class.  Make sure this is within the curly brackets for the class.  This will be a reference to a 'Countable' implementation that will be used later, a declaration that the default implementation is the class you saw earlier, and that all of the classes in the 'com.webage.bean' package will be declared to implement the 'Countable' interface at runtime.
	__6.  Finally, add the following 'doCount' method to the class along with the @Before annotation on the method declaration.  Be very careful about the 'value' attribute as the syntax here is the most complex yet and splits between several lines.  Remember you can also find code to copy/paste from in the <LABFILES>\Spring‑AspectJ\Solution\CountAspect.java file.  Make sure the method is inside the curly brackets for the class definition.
	__7.  Save the file and make sure you don't get any errors.
	__8.  Return to the 'spring-beans.xml' file and open it if you had closed it.
	__9.  Add the following to the file making sure it is outside other elements but within the overall <beans> element of the file.  You can also find code to copy/paste from in the <LABFILES>\Spring‑AspectJ\Solution\spring‑beans‑counting.xml file.
	__10.  Save the file and make sure you don't have any errors.
	__11.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__12.  Notice in the output you should see the message with 'COUNT' only on the call to the 'nextNumber' method of the 'IntGenerator' components between both 'BEFORE' and 'AFTER' messages.  You should also see that the count increments as expected between the different output messages of the codes.
	__13.  Return to the CountAspect.java file under Spring‑AspectJ → src → com.webage.aspects package and open it again if you had closed it. 
	__14.  Change the value of the @Order annotation to '5' and save the file.
	__15.  From the menus select Run → Run History → ProductCodeGeneratorTest.
	__16.  Notice now in the output that the 'COUNT' message appears after the 'BEFORE' message for the 'getNextProductCode' but before the 'BEFORE' message from the 'nextNumber' method.
	__17.  Close any open files.

	Part 5 -  Lab Cleanup
	__1.  Delete the ProductCodeGeneratorTest run configuration from the AspectJ/Java Application run configurations as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.
	__2.  Close the Spring‑AspectJ project as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.

	Part 6 -  Review

	Lab 13 -  Using Spring with JSF
	Part 1 -  Lab Setup
	__1.  Open SpringSource Tool Suite if it is not already.
	__2.  Make sure that you have a WebSphere 8.0 server as defined in the “Setup” lab.
	__3.  Import the projects in the '<LABFILES>\JSF-Spring\JSF-Spring-Starter.zip' file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.
	__4.  In the Markers view check that you have only warnings and no errors.  If there are errors try a Project → Clean to rebuild the project.

	Part 2 -  Add Spring Dependencies
	__1.  Open the pom.xml file from the root of the 'JSF-Spring' project.
	__2.  Switch to the source of the pom.xml by selecting the 'pom.xml' tab along the bottom of the editor.  You might need to look for some tabs that are hidden on the far right side and expand those to select the proper view.
	__3.  Find the section that is commented out (<!-- .. -->) that has the dependencies for the Spring libraries.  Remove the comment tags from before and after this section so the Spring JARs are active dependencies. 
	__4.  Save the file and be sure there are no red errors in the margin for the file.  These will occur if you don't remove the comments properly.
	__5.  Wait for a few seconds while the project is built and then expand the 'Maven Dependencies' for the project in the 'Project Explorer' view and make sure you see the various Spring JARs listed.  
	__6.  Collapse the dependencies again.

	Part 3 -  Add Spring Configuration to web.xml
	__1.  Open the 'WebContent/WEB-INF/web.xml' file.
	__2.  Switch to the source view of the editor.
	__3.  Uncomment the following for the Spring 'Context Loader' and 'Request Context' listeners.  Make sure to uncomment the section properly.  This references a Spring configuration file that will be created later.
	__4.  Save the file and be sure there are no errors in the file.  These will occur if you don't remove the comments properly.

	Part 4 -  Modify JSF Configuration
	__1.  Open the 'WebContent/WEB-INF/faces-config.xml' file.
	__2.  Switch to the source view of the editor.
	__3.  Within the <faces-config> element add the following configuration for the Spring EL Resolver.  Make sure it is nested in the outer element correctly.
	__4.  Save the file and be sure there are no errors in the file.
	__5.  Expand the 'src' folder of the project and open the GreetingBean.java file in the com.mycom.beans package.
	__6.  Remove the JSF annotations shown below in the class.  These were defining the class as a JSF managed bean.
	__7.  Save and close the GreetingBean.java file.

	Part 5 -  Create Spring Configuration File
	__1.  From the menu, select File -> New -> Other then select Spring → Spring Bean Configuration File and click the Next button.
	__2.  Expand JSF-Spring -> WebContent and select the WEB-INF folder as the parent folder. 
	__3.  Enter spring-jsf.xml as File name.
	__4.  Click Next.
	__5.  Check the 'beans' and 'context' namespace checkboxes and press the Finish button.
	__6.  Add the following bean definition within the outer <beans> element.
	__7.  Save the file and make sure there are no errors.  Leave the file open for later.

	Part 6 -  Test the JSF-Spring Integration
	__1.  If you haven't done so yet, make sure that you have a WebSphere 8.0 server as defined in the “Setup” lab.
	__2.  In the Servers view, locate WebSphere Application Server v8.0.
	__3.  Right click it and choose Start.
	__4.  Periodically switch to the Servers view and wait for the server's status to change to Started.
	__5.  Right click the server and select Add and Remove ...
	__6.  Select JSF-SpringEAR and click Add.
	__7.  Click the Finish button.  The application should be published to the server.
	__8.  Right click the WebContent/intro.xhtml page in the JSF-Spring project and select Run As -> Run on Server from the popup menu.
	__9.  If prompted, select the WebSphere 8.0 server, check the Always use this server when running this project checkbox and click Finish. 
	__10.  Enter a name and click on Submit. Make sure that the greeting message is displayed properly.
	__11.  Close the Web browser.

	Part 7 -  Modify Spring Bean to use Annotations
	__1.  Open the 'WebContent/WEB-INF/spring-jsf.xml' file if you had closed it.
	__2.  Remove the current <bean> definition in the file.  This should leave only the currently empty <beans> root element.
	__3.  Add the following to the spring-jsf.xml file.  This will configure annotation scanning.
	__4.  Save the file and make sure there are no errors.  You may have an error if you forgot to add the 'context' namespace when you created the file.
	__5.  Expand the 'src' folder of the project and open the GreetingBean.java file in the com.mycom.beans package.
	__6.  Add the following annotations to the declaration of the Java class.  You will have some errors until the next step.
	__7.  Organize imports (CTRL-SHIFT-O) to add the needed imports for the annotations.  Pick the org.springframework.context.annotation.Scope annotation when prompted and click the Finish button.
	__8.  Save the file and be sure there are no errors.

	Part 8 -  Test the Annotation Version
	__1.  Close all open files or web browsers.
	__2.  Switch to the Servers view and publish the WebSphere 8.0 server by right clicking and selecting Publish. Start the server if it is not running.
	__3.  Right click the WebContent/intro.xhtml page in the JSF-Spring project and select Run As -> Run on Server from the popup menu.
	__4.  Enter a name and click on Submit. Make sure that the greeting message is displayed properly.  Notice that the application should behave as it did before.
	__5.  Close the Web browser.

	Part 9 -  Use Spring Dependency Injection from Managed Bean
	__1.  In the JSF-Spring → src folder, right click the com.mycom.beans package and select New → Interface.
	__2.  Fill in a name of MessageGenerator for the name of the interface and click the Finish button.
	__3.  Add the following method to the interface.
	__4.  Save and close the file.
	__5.  In the JSF-Spring → src folder, right click the com.mycom.beans package and select New → Class.
	__6.  Enter SimpleMessageGeneratorImpl for the class name and make sure the package is set to com.mycom.beans.  Don't create the class yet though.
	__7.  Next to the Interfaces box click the Add button.
	__8.  Begin typing in 'MessageGenerator' until the interface is selected and click the OK button.
	__9.  Check that your settings for the new class match those shown below and click the Finish button.
	__10.  Modify the implementation of the 'generateMessage' method to match the following.
	__11.  Add the following annotation to the declaration of the Java class.
	__12.  Organize imports (CTRL-SHIFT-O) to add the needed imports for the annotation.
	__13.  Save and close the file after making sure there are no errors.
	__14.  Open the GreetingBean.java file in the com.mycom.beans package.
	__15.  Add the following field and annotation to the Java class.
	__16.  Organize imports (CTRL-SHIFT-O) to add the needed imports for the annotation.
	__17.  Modify the implementation of the 'getGreetingLabelText' method to use the message generator as shown below.
	__18.  Save and close the file after making sure there are no errors.

	Part 10 -  Test the Dependency Injection
	__1.  Close all open files or web browsers.
	__2.  Switch to the Servers view and publish the WebSphere 8.0 server by right clicking and selecting Publish.
	__3.  Right click the WebContent/intro.xhtml page in the JSF-Spring project and select Run As -> Run on Server from the popup menu.
	__4.  Enter a name and click on Submit. Notice that the application behaves differently because the message is coming from the message generator that was injected by Spring.
	__5.  Close the Web browser.

	Part 11 -  Lab Cleanup
	__1.  Undeploy and close the JSF-Spring project as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.

	Part 12 -  Review

	Lab 14 -  Use the Spring Web MVC Web Framework
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\Spring‑MVC\Spring‑MVC‑Starter.zip' file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.
	__2.  Open the Spring perspective.

	Part 2 -  Configure Database
	__1.  Start the database following the steps in the 'Common Lab Preparation Steps' at the 'Start Derby Database' part.
	__2.  Follow the steps in the 'Initialize Derby Database' section of the 'Common Lab Preparation Steps' using the 'db.txt' database script from the '<LABFILES>\Spring‑MVC' folder.
	__3.  Configure the database following the steps in the 'Common Lab Preparation Steps' at the 'Configure WebSphere DataSource' part.  When entering settings that are lab-specific use the following values:
	__4.  Once you have configured, saved, and tested the WebSphere Data source configuration make sure you have logged out of the Admin Console and closed the window.
	__5.  You can leave the WebSphere server running if you want but don't yet deploy the application you imported.

	Part 3 -  Add Spring MVC Dependencies
	__1.  Open the pom.xml file from the root of the 'Spring-MVC' project.
	__2.  Switch to the source of the pom.xml by selecting the 'pom.xml' tab along the bottom of the editor.  You might need to look for some tabs that are hidden on the far right side and expand those to select the proper view.
	__3.  Near the bottom of the file find the section that is commented out (<!-- .. -->) that has the dependencies for Spring Web MVC support.  Remove the comment tags from before and after this section so the Spring Web MVC modules are an active dependency. 
	__4.  Save the file and be sure there are no red errors in the margin for the file.  These will occur if you don't remove the comments properly.
	__5.  Expand the 'Maven Dependencies' for the project in the 'Package Explorer' view and make sure you see the Spring web modules listed.  There will be other JARs also imported.
	__6.  Collapse the dependencies again.

	Part 4 -  Modify Basic Spring MVC Configuration
	__1.  Open the 'WebContent/WEB-INF/web.xml' file.
	__2.  Notice there is an existing Servlet definition for the Spring MVC "DispatcherServlet".  This configuration is fairly complex so it was provided for you to simplify things.  Of particular importance notice there is an <init-param> for the servlet which configures which Spring configuration files to load.
	__3.  Close the file and make sure you didn't make any changes.
	__4.  Open the 'WebContent/WEB-INF/spring-mvc.xml' file.
	__5.  Switch to the 'Namespaces' tab of the editor.
	__6.  Notice the Spring 'mvc' configuration namespace has already been added for you.
	__7.  Switch to the 'Source' tab of the editor.
	__8.  Find the comment about the MVC annotation configuration and add the following element.  Make sure it is not within any other element except the root <beans> element.  You can also find code to copy/paste from in the <LABFILES>\Spring‑MVC\Solution\spring-mvc.xml file.
	__9.  Notice that there is already a <context:component-scan> element.  This will look for any classes annotated with Spring component declaration annotations.  In particular this will find a Spring MVC @Controller component.
	__10.  Find the comment about the "View Resolver" and add the following Spring bean definition.  Be careful as the class name is long and the configuration splits over several lines.
	__11.  Finally, find the comment that mentions a 'view-controller' for the index page.  Add the following syntax to configure this.
	__12.  Save the file and make sure there are no errors.

	Part 5 -  Test Spring MVC Configuration
	__1.  In the Servers view, right click on WebSphere 8.0 server and select Start if the server is not already running. Wait for the server to start completely.  
	__2.  Right click the server and select Add and Remove..., then remove all other applications that might be on the server. Select Spring-MVCEAR and click Add>.
	__3.  Click Finish. The project will be published in the server. You may see a red error print in the Console view but this can be ignored. 
	__4.  Expand the server and verify that the application is started.
	__5.  Open a web browser to:
	__6.  Close down any browser.
	__7.  Leave your server running.

	Part 6 -  Implement Browse Function
	__1.  Open the 'WebContent/index.jsp' file.
	__2.  Find the comment at the top of the file for the Spring taglib and add the following syntax.  You can also find code to copy/paste from in the <LABFILES>\Spring‑MVC\Solution\index.jsp file.
	__3.  Save the file and make sure there are no errors with the tag library declaration.
	__4.  Further down in the file find the first comment about a URL for the 'Add Purchase' link.  Modify the 'href' attribute of the link to include the Spring <s:url> tag shown in bold below.  Be careful with the syntax as there are several double quotes and tag brackets.
	__5.  Find the second comment about needing a URL for the link for the 'Browse Purchases' link.  Modify the 'href' attribute of the link to include the Spring <s:url> tag shown in bold below.  Be careful with the syntax as there are several double quotes and tag brackets.
	__6.  Save the file and make sure there are no errors.
	__7.  In the Package Explorer view, expand the following folders:
	__8.  Open the PurchaseController.java file in the com.webage.web package by double clicking it.  Notice that right now it is empty except for the Spring MVC @Controller annotation on the class and the @Autowired injection of a 'PurchaseService' component.
	__9.  Add the following new 'browsePurchases' method to the body of the class.  The @RequestMapping annotation links this method to the '/browse' URL you used in the index.jsp page.
	__10.  Select Source → Organize Imports selecting java.util.List and clicking the Finish button when prompted.
	__11.  Save the file and make sure there are no errors.
	__12.  Open the 'WebContent/browsePurchases.jsp' file.
	__13.  Find the comment at the top of the file for the Spring taglib and add the following syntax.  You can also find code to copy/paste from in the <LABFILES>\Spring‑MVC\Solution\browsePurchases-BROWSE.jsp file.
	__14.  Save the file and make sure there are no errors with the tag library declaration.
	__15.  Find the <c:forEach> tag in the file about 2/3 of the way down.  Notice that it will iterate over the 'purchaseList' that was made available by the controller.  Each individual item will be available as the 'purchase' variable.
	__16.  Within the four columns that are currently empty add the following syntax for various expressions and a <fmt:formatDate> tag.
	__17.  Further down in the file find the comment about a URL for the 'Back to Main Menu' link.  Modify the 'href' attribute of the link to include the Spring <s:url> tag shown in bold below.  Be careful with the syntax as there are several double quotes and tag brackets.  The value is also meant to be just a single slash as this will link to the root of the application.
	__18.  Save the file and make sure there are no errors.

	Part 7 -  Test Browse Function
	__1.  Make sure your WebSphere server is started in the Servers view and start it if it is not.
	__2.  Right click the WebSphere server and select Publish.  Wait for the publishing to complete.
	__3.  Open a web browser to:
	__4.  Click on the 'Browse Purchases' link and be sure you get the list of the three purchases currently in the database.
	__5.  Click on the 'Back to Main Menu' link and make sure the home page is displayed.
	__6.  Close down any browser.
	__7.  Leave your server running.

	Part 8 -  Implement Add Function
	__1.  Return to the PurchaseController.java file in the com.webage.web package and open it again if you had closed it.
	__2.  Add the following new 'addPurchase' method to the body of the class.  This will initialize a new Purchase object that will be bound to the various fields of the form on the 'addEditPurchase' page.  Notice in this case, after adding the new Purchase object into the "Model" we just return a String for the name of the next view.  You can also find code to copy/paste from in the <LABFILES>\Spring‑MVC\Solution\PurchaseController‑ADD.java file.
	__3.  Select Source → Organize Imports selecting org.springframework.ui.Model and clicking the Finish button when prompted.
	__4.  Save the file and make sure there are no errors but leave it open.
	__5.  Open the 'WebContent/addEditPurchase.jsp' file.
	__6.  Find the comment at the top of the file for the Spring taglib and add the following syntax.  You can also find code to copy/paste from in the <LABFILES>\Spring‑MVC\Solution\addEditPurchase-ADD.jsp file.
	__7.  Save the file and make sure there are no errors with the tag library declarations.
	__8.  Find the comment that mentions the "save URL" and add the following <s:url> tag.  This will declare the URL the form will be submitted to to save the Purchase as a variable so it can be used in the form action.
	__9.  Immediately after the comment that mentions the "Spring from tag around table" find the starting and ending <table> tags.  Place the starting and ending <form:form> tags around the table making sure all the tags are properly nested and balanced.  Note that in the code below the body of the table has been left out to see the start and end tags easily.
	__10.  In the first three rows of the table add the <form:input> tags shown in bold below.
	__11.  In the last row, modify the 'href' attribute of the link to include the Spring <s:url> tag shown in bold below.  Be careful with the syntax as there are several double quotes and tag brackets.
	__12.  Save the 'addEditPurchase.jsp' file and be sure there are no errors.
	__13.  Return to the PurchaseController.java file in the com.webage.web package and open it again if you had closed it.
	__14.  Add the following new 'savePurchase' method to the body of the class.  Notice the parameter of the method is a Purchase object.  Spring MVC is able to initialize this object based on the fact the form had been linked to properties of the object.  Also the view is a redirect request for the 'browse' view which is already mapped by the 'browsePurchases' method of the controller.
	__15.  Add the following new 'initBinder' method to the body of the class.  This will register a specific date format that will be used as the default for any Java object used in the display of a Spring MVC view.  
	__16.  Select Source → Organize Imports selecting java.util.Date and clicking the Finish button when prompted.
	__17.  Save the file.
	__18.  Close all open files and make sure there are no errors in the project.

	Part 9 -  Test Add Function
	__1.  Make sure your WebSphere server is started in the Servers view and start it if it is not.
	__2.  Right click the WebSphere server and select Publish.  Wait for the publishing to complete.
	__3.  Open a web browser to:
	__4.  Click on the 'Add Purchase' link to bring up the form.
	__5.  Click the Cancel link at the bottom and make sure you are sent back to the main page.
	__6.  Click on the 'Add Purchase' link again to bring up the form.
	__7.  Fill in some data for the form, making sure to use the correct format for the date.
	__8.  Click the 'Save' button to submit the form.  Make sure you see the list of all Purchases with the new record in the database.
	__9.  Close down any browser.
	__10.  Leave your server running.

	Part 10 -  Implement Edit Function
	__1.  Return to the PurchaseController.java file in the com.webage.web package and open it again if you had closed it.
	__2.  Add the following new 'editPurchase' method to the body of the class.  Notice this will take the 'purchaseId' property from the path of the request and pass it in as a method parameter.  This will be used to lookup the existing record and store the Purchase object as a Model attribute.  You can also find code to copy/paste from in the <LABFILES>\Spring‑MVC\Solution\PurchaseController‑EDIT.java file.
	__3.  Select Source → Organize Imports.
	__4.  Save the file and make sure there are no errors.
	__5.  Open the 'WebContent/browsePurchases.jsp' file.
	__6.  Find the comment about adding the 'Edit' link and add the following link around the text 'Edit' which is already there.  Make sure to add the ending </a> tag after the 'Edit' text.  Notice this is a regular HTML <a> anchor tag and only needs to add the purchase ID to the link.  You can also find code to copy/paste from in the <LABFILES>\Spring‑MVC\Solution\browsePurchases-EDIT.jsp file.
	__7.  Save the file and make sure there are no errors.
	__8.  Open the 'WebContent/addEditPurchase.jsp' file.
	__9.  Find the start of the <form:form> tag and add the following <form:hidden> tag, making sure it is inside the body of the form.  This will preserve the ID of the Purchase object if being edited.  You can also find code to copy/paste from in the <LABFILES>\Spring‑MVC\Solution\addEditPurchase-EDIT.jsp file.
	__10.  Save the file and make sure there are no errors.

	Part 11 -  Test Edit Function
	__1.  Make sure your WebSphere server is started in the Servers view and start it if it is not.
	__2.  Right click the WebSphere server and select Publish.  Wait for the publishing to complete.
	__3.  Open a web browser to:
	__4.  Click on the 'Browse Purchases' link.  You should see the same list but this time there should be a link for the 'Edit' text in the first column of every row of the table.
	__5.  Click on the 'Edit' link next to one of the Purchases.
	__6.  Make a change to the data.  Make sure it is a change you will recognize from the list.  Also, if you change the date, make sure to use the correct format.
	__7.  Click the 'Save' button to submit the form.  Make sure you see the change in the data you modified.
	__8.  Close down any browser.
	__9.  Close any open files.

	Part 12 -  Lab Cleanup
	__1.  Undeploy and close the Spring-MVC projects as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.
	__2.  Stop the database following the steps in the 'Common Lab Preparation Steps' at the 'Stop Derby Database' part.

	Part 13 -  Review

	Lab 15 -  Create a Web Application with Spring Web Flow
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\Spring‑WebFlow\Spring‑WebFlow‑Starter.zip' file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.
	__2.  Open the Spring perspective if needed.

	Part 2 -  Add Spring Web Flow Dependencies
	__1.  Open the pom.xml file from the root of the 'Spring-MVC' project.
	__2.  Switch to the source of the pom.xml by selecting the 'pom.xml' tab along the bottom of the editor.  You might need to look for some tabs that are hidden on the far right side and expand those to select the proper view.
	__3.  Near the bottom of the file find the section that is commented out (<!-- .. -->) that has the dependencies for Spring Web Flow support.  Remove the comment tags from before and after this section so the Spring Web Flow modules are an active dependency.  Notice that we are also adding support for the Spring "Web" modules from the core framework since we will be using Spring MVC integration with Web Flow.
	__4.  Save the file and be sure there are no red errors in the margin for the file.  These will occur if you don't remove the comments properly.
	__5.  Expand the 'Maven Dependencies' for the project in the 'Package Explorer' view and make sure you see the Spring Web Flow modules listed.  There will be other JARs also imported.
	__6.  Collapse the dependencies again.
	__7.  Select Project → Clean from the Eclipse menus and click the 'OK' button to clean all of the projects and trigger a rebuild.
	__8.  Check in the Markers view that you no longer have any errors related to the project.  These errors were present because the JSP files you imported had links to the Spring MVC JSP tags which were not present before adding the dependencies.  This was done to simplify the code you will write and focus more on Web Flow instead of Spring MVC.

	Part 3 -  Modify Configuration
	__1.  Open the 'WebContent/WEB-INF/web.xml' file.
	__2.  Notice there is an existing Servlet definition for the Spring MVC "DispatcherServlet".  This configuration is fairly complex so it was provided for you to simplify things.  Of particular importance notice there is an <init-param> for the servlet which configures which Spring configuration files to load.
	__3.  Close the file and make sure you didn't make any changes.
	__4.  Open the 'WebContent/WEB-INF/spring-webflow.xml' file.
	__5.  Switch to the 'Namespaces' tab of the editor.
	__6.  Notice the Spring 'webflow-config' configuration namespace has already been added for you.
	__7.  Switch to the 'Source' tab of the editor.
	__8.  Insert the following code for a 'FlowHandlerAdapter' bean above the </beans> tag.  You can also find code to copy/paste from in the <LABFILES>\Spring‑WebFlow\Solution\spring-webflow.xml file.
	__9.  Insert the following code for a 'FlowHandlerMapping' bean above the </beans> tag.  
	__10.  Insert the following code for the flowExecutor above the </beans> tag at the bottom of the file. A flow executor does just that, it executes flows.  
	__11.  Insert the following code for the flowRegistry above the </beans> tag at the bottom of the file.  
	__12.  Add the following code for the flowBuilderServices above the </beans> tag at the bottom of the file.  
	__13.  Add the following code for the mvcViewFactoryCreator above the </beans> tag at the bottom of the file.  
	__14.  Finally, add the following code for the viewResolver bean.
	__15.  Save the file and make sure you don't get any errors or warnings for the file.  You will get some if there are errors in syntax or if the elements do not reference the proper bean names.

	Part 4 -  Add First View State to Flow
	__1.  Open the 'WebContent/WEB-INF/flows/registration.xml' file.
	__2.  Place your cursor above the current 'cancel' end state and add the following <var> entry.  This will declare a variable for the entire flow which will reference a 'CustomerProfile' object which is a simple JavaBean already in the code of the project.  You can also find code to copy/paste from in the <LABFILES>\Spring‑WebFlow\Solution\registration-V1.xml file.
	__3.  Add the following <view-state> element after the <var> element you just added.  Use a separate start tag and end tag with some space between as you will nest another element within this view state later.
	__4.  Save the file and make sure there are no errors.
	__5.  Open the 'WebContent/personal.jsp' file.  This is a form that uses Spring MVC tags but is missing a few critical elements.
	__6.  Find the <form:form> tag and add the 'commandName' attribute as shown below.  You can also find code to copy/paste from in the <LABFILES>\Spring‑WebFlow\Solution\personal.jsp file.
	__7.  Find the <input> tags which are the submit buttons near the bottom of the file.  Add the 'name' attribute to each with the values shown below.  Make sure the name attribute and the text that will show up on the button are similar so the buttons will be labeled properly.
	__8.  Save the file and make sure there are no errors.

	Part 5 -  Test Initial View State and Configuration
	__1.  In the Servers view, right click on WebSphere 8.0 server and select Start if the server is not already running. Wait for the server to start completely.  
	__2.  Right click the server and select Add and Remove..., then remove all other applications that might be on the server. Select Spring-WebFlowEAR and click Add>.
	__3.  Click Finish. The project will be published in the server. You may see a red error print in the Console view but this can be ignored. 
	__4.  Expand the server and verify that the application is started.
	__5.  Open a web browser to:
	__6.  Fill in some sample information but then click the Cancel button.  Verify that the form displays again but it is empty.  This verifies the 'Cancel' transition in the flow is working.  The 'Next' button does not yet work though.
	__7.  Close down any browser.
	__8.  Leave your server running.

	Part 6 -  Implement More of the Flow
	__1.  Return to the registration.xml flow definition and open it again if you had closed it.
	__2.  Add the following <transition> element inside the 'personal' view state.  You may need to add an end tag if it were not present before.  Notice this will support the 'next' event that was linked to the button and transition to the 'hobbies' view.  You can also find code to copy/paste from in the <LABFILES>\Spring‑WebFlow\Solution\registration‑V2.xml file.
	__3.  Add the following two new view states for 'hobbies' and 'confirmRegistration'.  Notice how the generic 'next' and 'previous' events link to the different views even though on the pages there is only a reference to the 'next' and 'previous' event.
	__4.  Save the file and make sure there are no errors.  Errors will appear if you do not have the transitions referencing existing view states (because of a typo or something).
	__5.  Open the 'WebContent/hobbies.jsp' file.  Notice the 'commandName' attribute is already set for the form and the checkboxes in the form all link to the 'hobbies' property of the profile object.  This is possible because this property is an array.
	__6.  Find the <input> tags which are the submit buttons near the bottom of the file.  Add the 'name' attribute to each with the values shown below.  Make sure the name attribute and the text that will show up on the button are similar so the buttons will be labeled properly.
	__7.  Save the file and make sure there are no errors.
	__8.  Open the 'WebContent/confirm.jsp' file.  Without editing the file notice how it is simply displaying the properties of the 'profile' object to confirm the details for the registration.  There is also already the proper settings for the buttons, including a 'Finish' button.  These are already present since there is nothing different than previous JSP pages.
	__9.  Close the confirm.jsp file without making any changes.

	Part 7 -  Test Moving Between Pages
	__1.  Make sure you do not have any unsaved changes in files.
	__2.  Make sure your WebSphere 8 server is running in the Servers view.  Start it if needed.
	__3.  Right click the WebSphere server and select Clean and click the OK button to confirm.
	__4.  Open a web browser to:
	__5.  Fill in some sample information but then click the Next button.
	__6.  On the page that displays the hobbies select a few hobbies and then click the Next button.
	__7.  Verify that you see the data you had entered in the previous forms.  This proves the data has been maintained between requests as part of the 'profile' variable you defined for the flow.
	__8.  Click the Previous button in the form and be sure the hobbies page is displayed again with the correct hobbies checked off.
	__9.  Click the Cancel button and be sure you are returned to the empty personal data form again.  Also notice the URL has changed to indicate this is now the second execution of the flow with the '?execution=e2s1'.
	__10.  Close down any browser.
	__11.  Leave your server running.

	Part 8 -  Finish the Flow Implementation
	__1.  Expand the Spring-WebFlow → src → com.webage.service package and open the CustomerProfileManagerImpl.java file.
	__2.  Notice that it is registered as a Spring component with the name 'profileManager' and has an 'addNewProfile' method that would take a CustomerProfile object and returns an 'int'.
	__3.  Close the CustomerProfileManagerImpl.java file without making any changes.
	__4.  Return to the registration.xml flow definition and open it again if you had closed it.
	__5.  Add the following new "finish" <transition> element inside the 'confirmRegistration' view state.  Notice that this transition calls the 'profileManager.addNewProfile' method passing in the 'profile' object that had been maintained as a flow scope variable.  The results are stored in a new flow scope variable called 'profileID'.  You can also find code to copy/paste from in the <LABFILES>\Spring‑WebFlow\Solution\registration‑V3.xml file.
	__6.  Add the following new end view state for 'customerRegistered'.  This will indicate the final view to display when the flow is complete.
	__7.  Save the file and make sure there are no errors.  Errors will appear if you do not have the transitions referencing existing view states (because of a typo or something).
	__8.  Open the 'WebContent/results.jsp' file.  
	__9.  Find the existing <c:out> tags and fill in the currently empty 'value' property of each with the values in bold below.  This will access the data available in the flow as the flow ends.  Notice you do not need the 'flowScope' for the profileID property since Spring Web Flow will search for the variable in various scopes and find it in the flow scope.
	__10.  Save the file and make sure there are no errors.

	Part 9 -  Test Complete Flow
	__1.  Make sure you do not have any unsaved changes in files.
	__2.  Make sure your WebSphere 8 server is running in the Servers view.  Start it if needed.
	__3.  Right click the WebSphere server and select Clean and click the OK button to confirm.
	__4.  Open a web browser to:
	__5.  Fill in some sample information but then click the Next button.
	__6.  On the page that displays the hobbies select a few hobbies and then click the Next button.
	__7.  Verify that you see the data you had entered in the previous forms and click the Finish button to submit the form to confirm.
	__8.  Check that you see the "Registration Complete" page with the customer name and an ID listed.
	__9.  Return to Eclipse and look in the Console view and verify there are messages in the log.  These are only printed from the 'profileManager' component and confirm that the component method was invoked from the flow.
	__10.  Hit the Back button.  Notice that you are redirected to the empty form for personal data and NOT the page which confirmed the profile before adding it.  This is because we had reached an "end state" which means that execution of the flow is no longer valid and a new one is started.
	__11.  Close down any browser.
	__12.  Close any open files.

	Part 10 -  Lab Cleanup
	__1.  Undeploy and close the Spring-WebFlow projects as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.

	Part 11 -  Review

	Lab 16 -  Spring Security
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\Security\SpringSecurity‑Starter.zip' file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.

	Part 2 -  Add Spring Security Dependencies
	__1.  Open the pom.xml file from the root of the 'SpringSecurity' project.
	__2.  Switch to the source of the pom.xml by selecting the 'pom.xml' tab along the bottom of the editor.  You might need to look for some tabs that are hidden on the far right side and expand those to select the proper view.
	__3.  Near the bottom of the file find the section that is commented out (<!-- .. -->) that has the dependencies for the Spring Security JARs.  Remove the comment tags from before and after this section so the Spring Security JARs are active dependencies. 
	__4.  Save the file and be sure there are no red errors in the margin for the file.  These will occur if you don't remove the comments properly.
	__5.  Expand the 'Maven Dependencies' for the project in the 'Package Explorer' view and make sure you see the various Spring Security JARs listed.  There will be other JARs also imported.
	__6.  Collapse the dependencies again.

	Part 3 -  Add the Spring Security Filter to the Web Deployment Descriptor
	__1.  Open the 'WebContent/WEB-INF/web.xml' file.
	__2.  Switch to the source view of the editor.
	__3.  Add the following for the Spring Security filter.  Make sure to add it outside of other nested tags already in the web.xml.
	__4.  Save the file and be sure there are no errors in the file.  If there are you probably nested the filter tags incorrectly.

	Part 4 -  Initial Spring Security Configuration
	__1.  Open the 'WebContent/WEB-INF/spring-beans.xml' file.
	__2.  Switch to the 'Namespaces' tab of the editor.
	__3.  Scroll down in the list of namespaces and check the box for 'security' as shown below.
	__4.  If the confirmation dialog appears click the OK button.
	__5.  Click the 'sec' tab on the bottom of the editor.
	__6.  Right click on the 'beans' entry in the list and select the “Insert <security:http> element”.  This will be the root of much of our configuration.
	__7.  Select the new 'http' element from the list if it is not already.
	__8.  On the right, select the 'true' value from the drop-down next to the 'auto-config' property.
	__9.  Back on the list of beans on the left, right click on the 'http' entry in the list and select the “Insert <security:intercept-url> element”.
	__10.  On the properties of the new 'intercept-url' element set the following properties.
	__11.  Switch to the source tab of the editor.  Notice the syntax that has been created.
	__12.  Add the following configuration after the <security:http> element but before the ending </bean> tag.
	__13.  Save the file and be sure there are no errors.

	Part 5 -  Test Initial Security
	__1.  Switch to the Servers view. If it is not shown from the menu, select Window > Show View > Servers.
	__2.  Now right click on the 'WebSphere 8.0' server and select Add and Remove... 
	__3.  Remove all other applications that might be on the server.
	__4.  Add the 'SpringSecurityEAR' project to the server.
	__5.  Click the Finish button to deploy the application to the server.  
	__6.  Right click on the 'WebSphere 8.0' server and select Start.  Wait for the server to start completely.
	__7.  Open a web browser to:
	__8.  Supply a user of 'jsmith' and a password of 'john' and press the 'Submit Query' button.  You should see the home page of the application.
	__9.  Press the 'Second Page' link and verify that you can navigate between the pages.
	__10.  Close down any browser you have open.  Later we will add a logout ability but right now we have to close the browser.
	__11.  Open the following page in a browser:
	__12.  Supply a bad user and password of 'blah' and verify you can't login.  Notice you won't get any error message though about the reason.
	__13.  Login as a user of 'jdoe' and a password of 'jane' and verify you see the second page.
	__14.  Close down any browser.

	Part 6 -  Develop Custom Login Page
	__1.  Create a new JSP in 'WebContent' folder named 'login.jsp'.  You can do this by right clicking the 'WebContent' folder, selecting 'New → Other', selecting 'Web → JSP File' and clicking Next, and finally supplying the file name and clicking Finish.
	__2.  Add the following tag library before the title tag (which you can also change if you like).
	__3.  Replace the content of the <body> tag with the following.  This will display any errors during login using the supplied Spring Security Exception message.  The key to this is looking for a 'login_error' parameter which we will see in the configuration in a second.
	__4.  Add the following form after the error display logic but inside the end of the </body> tag.  This will submit a standard form with 'Action' and parameters that will be recognized by Spring Security.
	__5.  Save the login file after making sure there are no errors.
	__6.  Open the 'WebContent/WEB-INF/spring-beans.xml' file if you had closed it.
	__7.  Switch to the source view if not already.
	__8.  Add the following new intercept-url as a child of the <security:http> element.  Make sure it is before the global intercept URL (pattern=”/**”) as Spring Security will use the first match it comes to.
	__9.  Add the following <security:form-login> element as a child of <security:http> but outside of the intercept urls.
	__10.  Save the file making sure there are no errors.

	Part 7 -  Test Login Page
	__1.  Make sure the WebSphere server is running.
	__2.  In the Servers view, right-click the WebSphere 8.0 server and select Publish.
	__3.  Open a web browser to:
	__4.  Try to supply a bad user and verify an error appears.
	__5.  Supply a user of 'jsmith' and a password of 'john' and press the 'Login' button.  You should see the home page of the application.
	__6.  Close the browser.

	Part 8 -  Add Other Exceptions
	__1.  Open the login.jsp page if you closed it.
	__2.  Add the following image in the body of the page but above the portion displaying the login error.  This image is already in the project.
	__3.  Save the file.
	__4.  Make sure the WebSphere server is running.
	__5.  In the Servers view, right-click the WebSphere 8.0 server and select Publish.
	__6.  Open a web browser to:
	__7.  Close the browser.
	__8.  In the 'spring-beans.xml' file add the following intercept-url element.  Again make sure to add it before the global restriction.
	__9.  Save the file.
	__10.  Make sure the WebSphere server is running.
	__11.  In the Servers view, right-click the WebSphere 8.0 server and select Publish.
	__12.  Open a web browser to:
	__13.  Close the browser.

	Part 9 -  Add Logout
	__1.  Open the 'WebContent/index.jsp' page.
	__2.  Add the following link after the link to the second page.  Also add a <br/> between the two.
	__3.  Save the file.
	__4.  In the 'spring-beans.xml' file add the following configuration of the logout settings.
	__5.  Save the file.
	__6.  Make sure the WebSphere server is running.
	__7.  In the Servers view, right-click the WebSphere 8.0 server and select Publish.
	__8.  Open a web browser to:
	__9.  Supply a user of 'jsmith' and a password of 'john' and press the 'Login' button.  You should see the home page of the application with the logout link.
	__10.  Click the 'logout' link.  Verify that you are directed back to the login page.
	__11.  Login as a user of 'jdoe' and a password of 'jane' and verify you can login again.
	__12.  Close the browser.

	Part 10 -  Selectively Display Links to Secured Pages
	__1.  Create an 'admin' subfolder of the 'WebContent' folder by right clicking the 'WebContent' folder, selecting 'New → Folder', supplying the name 'admin' and pressing the Finish button. 
	__2.  Create an 'admin.jsp' file in this new 'admin' subfolder.  You can do this by right clicking the new 'WebContent/admin' folder, selecting 'New → Other', selecting 'Web → JSP File' and clicking Next, and finally supplying the file name and clicking Finish.
	__3.  Verify the new file is in the correct location.
	__4.  Provide some simple content like that below to be able to recognize the page when it is displayed.  Replace any content already in the >body> tag.
	__5.  Save the file.
	__6.  In the 'spring-beans.xml' file, add the following to create a security restriction for the '/admin' subfolder and notice that the role which has access is the 'ROLE_ADMIN' that only the 'jsmith' user has been granted.  Again make sure it is before the global rule.
	__7.  Save the file.
	__8.  Open the 'WebContent/index.jsp' page.
	__9.  Add the following JSP tag library declaration to the top of the page.
	__10.  Add the following security tag between the two existing links.  This will display the content within the tag, including the link to the admin.jsp file, only to those with the 'ROLE_ADMIN' access role.
	__11.  Save the file.
	__12.  Make sure the WebSphere server is running.
	__13.  In the Servers view, right-click the WebSphere 8.0 server and select Publish.
	__14.  Open a web browser to:
	__15.  Supply a user of 'jsmith' and a password of 'john' and press the 'Login' button.
	__16.  Click the link for 'Administrative Options' and verify you can access the 'admin.jsp' file.
	__17.  Hit the back button and then click logout.
	__18.  Close the browser.
	__19.  Open a new browser and login as a user of 'jdoe' and a password of 'jane'.  Notice that you don't see the link.  Stay logged in.
	__20.  Manually enter the following URL in the browser address bar.
	__21.  Close the browser.

	Part 11 -  Custom Access Denied Page
	__1.  Create a new JSP in 'WebContent' folder named 'AccessDenied.jsp'.
	__2.  Modify the content of the page to match that below.
	__3.  Save the file.
	__4.  Open the 'WebContent/WEB-INF/web.xml' file.
	__5.  Switch to the source view of the editor.
	__6.  Add the following to the bottom of the web.xml file but inside the </web-app> tag.
	__7.  Save the file.
	__8.  Make sure the WebSphere server is running.
	__9.  In the Servers view, right-click the WebSphere 8.0 server and select Publish.
	__10.  Manually enter the following URL in the browser address bar.
	__11.  Login as a user of 'jdoe' and a password of 'jane'.  
	__12.  Click the logout link.
	__13.  Manually enter the following URL in the browser address bar again.
	__14.  Supply a user of 'jsmith' and a password of 'john' and press the 'Login' button.
	__15.  Close the browser.
	__16.  Stop the server.
	__17.  Close All open files.

	Part 12 -  Lab Cleanup
	__1.  Undeploy and close the SpringSecurity project as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.

	Part 13 -  Review

	Lab 17 -  Use Spring JMS Support
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\JMS\JMS-Spring-Starter.zip' file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.
	__2.  Open the Spring perspective.

	Part 2 -  Add Spring JMS Dependencies
	__1.  Open the pom.xml file from the root of the 'SpringJMS' project.
	__2.  Switch to the source of the pom.xml by selecting the 'pom.xml' tab along the bottom of the editor.  You might need to look for some tabs that are hidden on the far right side and expand those to select the proper view.
	__3.  Near the bottom of the file find the section that is commented out (<!-- .. -->) that has the dependency for the Spring JMS JAR.  Remove the comment tags from before and after this section so the Spring JMS JAR is an active dependency. 
	__4.  Save the file and be sure there are no red errors in the margin for the file.  These will occur if you don't remove the comments properly.
	__5.  Expand the 'Maven Dependencies' for the project in the 'Package Explorer' view and make sure you see the Spring JMS JAR listed.  There will be other JARs also imported.
	__6.  Collapse the dependencies again.

	Part 3 -  Examine Existing Configuration
	__1.  Open the 'WebContent/WEB-INF/web.xml' file.
	__2.  Open the 'src/com.webage.web/RequestHandlerServlet.java' file.
	__3.  Close all open files.

	Part 4 -  Verify Pre-Messaging Function
	__1.  In the Servers view, right click on WebSphere 8.0 server and select Start. Wait for the server to start completely.  
	__2.  Right click the server and select Add and Remove..., then remove all other applications that might be on the server. Select SpringJMSEAR and click Add>.
	__3.  Click Finish. The project will be published in the server. You may see a red error print in the Console view but this can be ignored. 
	__4.  Expand the server and verify that the application is started.
	__5.  Open a web browser to:
	__6.  Input some sample order data and submit the page.  The order ID needs to be a number.
	__7.  You should see a page about the order being submitted.
	__8.  Switch back to Eclipse and verify that you see the order printed out in the Console view.
	__9.  Close down any browser.
	__10.  Leave your server running.

	Part 5 -  Create Message Converter
	__1.  Right click on the SpringJMS project in the Package Explorer view and select New -> Package. 
	__2.  Enter a package name of com.webage.jms and press the Finish button to create the package.
	__3.  Right click the com.webage.jms package and select New -> Class.
	__4.  Fill in a class name of OrderConverter but do not yet press the Finish button.
	__5.  Next to the empty list of interfaces press the Add button.
	__6.  Enter MessageConverter and select the spring interface as shown below.  Make sure you do not select the WebSphere 'SIB' interface.
	__7.  Press the OK button.
	__8.  Then click Finish once your dialog appears as shown below.
	__9.  Edit the code to match the following.  You can also find code to copy/paste from in the <LABFILES>\JMS\Solution\OrderConverter.java file.
	__10.  Save the file and make sure there are no errors.
	__11.  Close the file.

	Part 6 -  Create Message Sender
	__1.  Right click the com.webage.jms package and select New -> Interface.
	__2.  Fill in an interface name of MessageSender and press the Finish button.
	__3.  Edit the code so it matches the code below:
	__4.  Save and close the file after checking that there are no errors.
	__5.  Right click the com.webage.jms package and select New -> Class.
	__6.  Fill in a class name of MessageSenderImpl but do not yet press the Finish button.
	__7.  Next to the empty list of interfaces press the Add button.
	__8.  Enter MessageSender and press the OK button.
	__9.  Once the class properties are filled in as shown below press the Finish button.
	__10.  Edit the code to match the following.  You can also find code to copy/paste from in the <LABFILES>\JMS\Solution\MessageSenderImpl.java file.
	__11.  Save and close the file.

	Part 7 -  Create Message Listener
	__1.  Right click the com.webage.jms package and select New -> Class.
	__2.  Fill in a class name of MyListener but do not yet press the Finish button.
	__3.  Next to the empty list of interfaces press the Add button.
	__4.  Enter MessageListener and choose the  choice as shown below.  Make sure you have selected the interface in the javax.jms package and press the OK button. The path of the interface may be different.
	__5.  Once the class properties are filled in as shown below press the Finish button.
	__6.  Edit the code to match the following.  You can also find code to copy/paste from in the <LABFILES>\JMS\Solution\MyListener.java file.
	__7.  Save and close the file.

	Part 8 -  Modify RequestHandlerServlet
	__1.  In the Package Explorer view, expand the following folders:
	__2.  Open the RequestHandlerServlet.java file in the com.webage.web package by double clicking it.
	__3.  Add the following code in bold for a new field in the servlet to store a reference to a MessageSender.  You may have some errors that will be fixed next.
	__4.  Select Source → Organize Imports from the menus to add missing imports.
	__5.  Add the following line of code in bold near the end of the 'handleRequest' method.
	__6.  Save the file and be sure there are no errors.

	Part 9 -  Configure WebSphere Messaging Resources
	__1.  Switch to the Servers view.
	__2.  Make sure that your WebSphere server is running and start it if needed.
	__3.  In the Servers view, right-click on the running server and select Administration | Run administrative console.
	__4.  In the navigation panel on the left side of the admin console, expand Service integration and then click Buses.
	__5.  In the right pane, click the New button.
	__6.  Enter MessagingBus for the name of the bus.  Do not check Bus Security.
	__7.  Click Next.
	__8.  Simply click Finish.
	__9.  Click Save.
	__10.  Click the link for the newly created MessagingBus.
	__11.  On the right, underneath the Topology section, click Bus members.
	__12.  Click Add.
	__13.  Leave Server selected.  In its associated drop-down, it should specify the name of your server instance (of the form <yourHostName>Node01:server1).  This is what we want; we want this server to be a member of the cluster.
	__14.  Click Next.
	__15.  Leave File Store selected and click Next.
	__16.  Accept the defaults and click Next.
	__17.  Accept the defaults and click Next.
	__18.  Click Finish.
	__19.  As before, click Save.

	Part 10 -  Create A Bus Queue Destination
	__1.  In the “Breadcrumb” trail at the top of the page, click the link for MessagingBus to navigate to the properties of the bus.
	__2.  On the right, under Destination resources, click Destinations.
	__3.  Click New.
	__4.  Leave Queue selected and click Next.
	__5.  For the Identifier, enter SimpleApplicationQueue
	__6.  Click Next.
	__7.  The drop-down should list the bus member you created earlier.  Simply click Next.
	__8.  Click Finish.
	__9.  The Messages screen will appear again.  Click Save.

	Part 11 -  Create JMS Resources
	__1.  In the navigation panel on the left, expand Resources → JMS and click Queue connection factories.
	__2.  Under the Scope section, change the drop-down to select select Node=<node name>, Server=server1 (where <node name> is the value of your host name).
	__3.  Click New.
	__4.  Leave Default messaging provider selected and click OK.
	__5.  Set the following values:
	__6.  Leave the remaining defaults and click Apply at the bottom of the page.
	__7.  The Messages box will appear, click Save.
	__8.  In the left pane, expand Resources → JMS and click Queues.
	__9.  Change the Scope to point at your node/server as you did before. 
	__10.  Click the New button.
	__11.  The Select JMS resource provider screen will appear.  Leave Default Messaging Provider selected and click OK.
	__12.  Enter the following information:
	__13.  Leave the rest of the defaults and click Apply at the bottom of the page.
	__14.  From the Messages box, Save changes.
	__15.  Logout of the Administration Console and close the window.

	Part 12 -  Modify Spring Configuration
	__1.  Open the 'WebContent/WEB-INF/spring-beans.xml' file if it is not already.
	__2.  Switch to the 'Namespaces' tab of the editor.
	__3.  Scroll down in the list of namespaces and check the boxes for 'jms', 'jee', and 'tx' as shown below.  If the confirmation dialog appears click the OK button.
	__4.  Click the 'jms' tab on the bottom of the editor.
	__5.  Right click on the 'beans' entry in the list and select the “Insert <jms:listener‑container> element”.  
	__6.  Select the new 'listener-container' element from the list if it is not already.
	__7.  On the properties of the new 'listener-container' element set the following properties.
	__8.  Back on the list of beans on the left, right click on the 'listener-container' entry in the list and select the “Insert <jms:listener> element”.
	__9.  On the properties of the new 'listener' element set the following properties.
	__10.  Switch to the source tab of the editor.  Notice the syntax that has been created.
	__11.  Still in the source tab add the following Spring bean configurations.  Make sure you add these outside of other bean configurations but within the containing <beans> tag. You can also find code to copy/paste from in the <LABFILES>\JMS\Solution\spring-beans.xml file.
	__12.  Save the file and be sure there are no errors.

	Part 13 -  Test JMS Functionality
	__1.  Switch to the Servers view.
	__2.  Stop your WebSphere server if it is running.
	__3.  Once your server is stopped restart it by right clicking and selecting Start.
	__4.  In the Console view make sure there are no errors reported while the server starts or deploys the application.  In particular look for a message that keeps repeating every few seconds if Spring can't connect to the WebSphere messaging.
	__5.  Open a web browser to:
	__6.  Input some sample order data and submit the page.  The order ID needs to be a number.
	__7.  You should see a page about the order being submitted.
	__8.  Switch back to Eclipse and verify that you see the order printed out in the Console view.  You should see the order printed out three times, once from the Servlet, once from the MessageSender, and finally from the MessageListener.
	__9.  Close down any browser.
	__10.  Close any open files.

	Part 14 -  Lab Cleanup
	__1.  Undeploy and close the SpringJMS project as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.

	Part 15 -  Review

	Lab 18 -  JAX-WS Web Services with Spring
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\Spring‑JAX‑WS\Spring‑JAX‑WS‑Starter.zip' file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.
	__2.  Make sure you don't have any errors in the Markers view.

	Part 2 -  Examine Existing Code
	__1.  Open the pom.xml file from the root of the 'Spring-JAX-WS' project.
	__2.  Switch to the source of the pom.xml by selecting the 'pom.xml' tab along the bottom of the editor.  You might need to look for some tabs that are hidden on the far right side and expand those to select the proper view.
	__3.  Notice that for the dependencies there are only standard dependencies of Spring Context and Web modules (along with Commons Logging).
	__4.  In the editor click the tab for 'Dependency Hierarchy'.
	__5.  In the list of 'Resolved Dependencies' on the right notice that even though there are other standard Spring modules used there is nothing specific to Spring for XML or web services.  This is important because when using the JAX-WS standard for web services as you will do Spring is not actually involved in the web service aspect of the application.  We are using the native JAX-WS support of the Java EE server.
	__6.  Open the 'WebContent/WEB-INF/web.xml' file.
	__7.  Switch to the source view of the editor.
	__8.  Notice this is a very minimal configuration that will simply load a Spring configuration file using the Spring ContextLoaderListener.
	__9.  Open the 'WebContent/WEB-INF/spring-beans.xml' file.
	__10.  Notice that right now there is only a minimal configuration that will scan a package for Spring components.  In particular note this scans only the 'com.webage.model' package and NOT the 'com.webage.service' package which is where the web service implementation classes will be.
	__11.  Expand the 'src → com.webage.model' package and double click the SimpleMovieManager.java file to open it.
	__12.  Notice this is just a simple Spring component.  The important part of this Spring component is that this is the only application component that prints to system output so when you see messages in the log output later you will know that this Spring component is being used from the web service implementation classes.
	__13.  Close all open files.  Make sure you have not made any changes.

	Part 3 -  Implement a JAX-WS Web Service with Spring Autowiring
	__1.  Expand the 'src → com.webage.service' package and double click the MovieServiceAutowireImpl.java file to open it.
	__2.  Add the following annotation on the class definition.  You will have errors until a following step.
	__3.  On the class definition add the 'extends SpringBeanAutowiringSupport' as shown in bold below.  Make sure you add it between the class name and the 'implements' keyword.  You will have errors until a following step.
	__4.  Add the '@Autowired' annotation before the 'movieManager' field as shown below.  Make sure it is before the field definition but inside the class definition.  You will have errors until a following step.
	__5.  Organize imports by selecting Source → Organize Imports.
	__6.  Save the file and make sure there are no errors.

	Part 4 -  Test Autowired Service
	__1.  Switch to the Web perspective by selecting 'Window → Open Perspective → Other', selecting the Web perspective and then clicking the OK button.
	__2.  Switch to the Servers view. If it is not shown from the menu, select Window > Show View > Servers.
	__3.  Right click on the 'WebSphere Application Server v8.0' server and select Start. Wait for the server to start completely.
	__4.  Right click on the 'WebSphere Application Server v8.0' server and select Add and Remove... 
	__5.  Remove all other applications that might be on the server.
	__6.  Add the 'Spring-JAX-WSEAR' project to the server.
	__7.  Click the Finish button to deploy the application to the server, wait until finish publishing.  
	__8.  In the Eclipse menus select Run → Launch the Web Services Explorer.
	__9.  We need to point the WSE at the generated WSDL file of the service deployed to the server.  Locate the row of buttons in the top right hand side of the WSE. 
	__10.  Click the second button from the right to switch the WSE to WSDL mode.
	__11.  Click WSDL Main in the Navigator pane.
	__12.  Enter the following URL:
	http://localhost:9080/Spring-JAX-WS/MovieServiceAutowire?wsdl
	__13.  Click Go.
	__14.  In the window that appears click the 'addMovie' link listed under the operations.
	__15.  Right now there are no fields to enter data so click the 'Add' link next to 'arg0' of the 'addMovie' operation to create a form to submit data for the service.
	__16.  Click the 'Add' link next to the 'title' argument.  This is the minimum that we need to submit as this is what will be printed in the log by the Spring component proving the autowiring is working.
	__17.  If you want to, click the 'Add' link next to other data to enter data for those fields.  You may want to maximize the Web Service Explorer window by double clicking the title bar.
	__18.  Once you are done entering some sample data (or at least the movie title), click the Go button below the form to enter data..
	__19.  After a few seconds, check that in the Console view you get a message from the 'SimpleMovieManager' component with the name of the movie.  This proves the Spring component is being invoked from the web service implementation.
	__20.  Back in the lower right 'Status' section of the Web Services Explorer, check that you get the response message from the web service indicating the movie was added.  This proves you get a response from the web service implementation.
	__21.  In the 'Navigator' section on the left of the Web Services Explorer, click the Clear button to remove the information about the current WSDL.  This will clean it up for the next testing.
	__22.  Close the window for the Web Services Explorer.

	Part 5 -  Implement a JAX-WS Web Service with Context Lookup
	__1.  Expand the 'Java Resources → src → com.webage.service' package and double click the MovieServiceContextImpl.java file to open it.
	__2.  Add the following annotation on the class definition.  You will have errors until a following step.
	__3.  Add the following @WebMethod annotation to the existing 'addMovie' method.  This will make sure this method is exposed through the web service.  You will have errors until a following step.
	__4.  Find the comment that says where to add the '@PostConstruct method' and add the following code for a new method complete with the shown annotations.  Make sure that you add the entire method inside of the class definition and have balanced curly brackets ({ }) for the method body.  You will have errors until a following step.
	__5.  Organize imports by selecting Source → Organize Imports.
	__6.  Save the file and make sure there are no errors.  If you have errors check for a correct balance of curly brackets and that the @PostConstruct method is defined within the class definition.

	Part 6 -  Test Context Lookup Service
	__1.  Make sure you are still in the Web perspective.
	__2.  In the Servers view, right click the 'WebSphere Application Server v8.0' server and select Publish. Wait until finished publishing.
	__3.  Check that your server is in the 'Started, Synchronized' state.
	__4.  In the Eclipse menus select Run → Launch the Web Services Explorer.
	__5.  Locate the row of buttons in the top right hand side of the WSE.  Click the second button from the right to switch the WSE to WSDL mode.
	__6.  Click WSDL Main in the Navigator pane.
	__7.  Enter the following URL:
	http://localhost:9080/Spring-JAX-WS/MovieServiceAppContext?wsdl
	__8.  Click Go.
	__9.  In the window that appears click the 'addMovie' link listed under the operations.
	__10.  Right now there are no fields to enter data so click the 'Add' link next to 'arg0' of the 'addMovie' operation to create a form to submit data for the service.
	__11.  Click the 'Add' link next to the various data elements to enter data.  Remember to at least enter a movie title and use a different title than the last tests.  You may want to maximize the Web Service Explorer window by double clicking the title bar.
	__12.  Once you are done entering some sample data (or at least the movie title), click the Go button below the form to enter data..
	__13.  After a few seconds, check that in the Console view you get a message from the 'SimpleMovieManager' component with the name of the movie.  This proves the Spring component is being invoked from the web service implementation.
	__14.  Back in the lower right 'Status' section of the Web Services Explorer, check that you get the response message from the web service indicating the movie was added.  This proves you get a response from the web service implementation.
	__15.  In the 'Navigator' section on the left of the Web Services Explorer, click the Clear button to remove the information about the current WSDL.  This will clean it up for the next testing.
	__16.  Close the window for the Web Services Explorer.

	Part 7 -  Use Autowiring Without Inheritance
	__1.  Expand the 'src → com.webage.service' package and double click the MovieServiceAutowireImpl.java file to open it.
	__2.  On the class definition remove the 'extends SpringBeanAutowiringSupport' as shown in bold strikethrough below.  This should leave the class definition without extending any class and only implementing the normal web service interface.
	__3.  Add the following @WebMethod annotation to the existing 'addMovie' method.  This will make sure this method is exposed through the web service.  You will have errors until a following step.
	__4.  Add the following new method outside of any existing methods but within the class definition curly brackets.  You will have errors until a following step.
	__5.  Organize imports by selecting Source → Organize Imports.
	__6.  Save the file and make sure there are no errors.  If you have errors check for a correct balance of curly brackets and that the @PostConstruct method is defined within the class definition.

	Part 8 -  Test Third Implementation
	__1.  Make sure you are still in the Web perspective.
	__2.  In the Servers view, right click the 'WebSphere Application Server v8.0' server and select Publish.
	__3.  Check that your server is in the 'Started, Synchronized' state.
	__4.  In the Eclipse menus select Run → Launch the Web Services Explorer.
	__5.  Locate the row of buttons in the top right hand side of the WSE.  Click the second button from the right to switch the WSE to WSDL mode.
	__6.  Click WSDL Main in the Navigator pane.
	__7.  Enter the following URL:
	http://localhost:9080/Spring-JAX-WS/MovieServiceAutowire?wsdl
	__8.  Click Go.
	__9.  In the window that appears click the 'addMovie' link listed under the operations.
	__10.  Right now there are no fields to enter data so click the 'Add' link next to 'arg0' of the 'addMovie' operation to create a form to submit data for the service.
	__11.  Click the 'Add' link next to the various data elements to enter data.  Remember to at least enter a movie title and use a different title than the last tests.  You may want to maximize the Web Service Explorer window by double clicking the title bar.
	__12.  Once you are done entering some sample data (or at least the movie title), click the Go button below the form to enter data..
	__13.  After a few seconds, check that in the Console view you get a message from the 'SimpleMovieManager' component with the name of the movie.  This proves the Spring component is being invoked from the web service implementation.
	__14.  Back in the lower right 'Status' section of the Web Services Explorer, check that you get the response message from the web service indicating the movie was added.  This proves you get a response from the web service implementation.
	__15.  Close the window for the Web Services Explorer.
	__16.  Close all open files.

	Part 9 -  Lab Cleanup
	__1.  Return to the Spring perspective.  You should be able to do this by selecting 'Window → Close Perspective' to close the Web perspective.  If you are not in the Spring perspective you can open it by selecting 'Window → Open Perspective → Other', selecting the Spring perspective and clicking the OK button.
	__2.  Undeploy and close the Spring-JAX-WS projects as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.

	Part 10 -  Review

	Lab 19 -  Implement REST Services with Spring
	Part 1 -  Lab Setup
	__1.  Import the projects in the '<LABFILES>\Spring‑REST\Spring‑REST‑Starter.zip' file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.
	__2.  Open the Spring perspective.

	Part 2 -  Examine Existing Code
	__1.  Open the pom.xml file from the root of the 'Spring-REST' project.
	__2.  Switch to the source of the pom.xml by selecting the 'pom.xml' tab along the bottom of the editor.  You might need to look for some tabs that are hidden on the far right side and expand those to select the proper view.
	__3.  Notice that for the dependencies there are the standard Spring MVC dependencies for that service implementation choice.  You would also use these dependencies for the Spring RestTemplate client support shown later.  In this example there is no import of a JAX-RS implementation since the WebSphere 8.0 server you are using already provides this.  If you were running on a server that did not support JAX-RS, you would have a dependency here for a JAX-RS implementation like Jersey.
	__4.  Open the 'WebContent/WEB-INF/web.xml' file.
	__5.  Switch to the source view of the editor.
	__6.  The configuration is fairly involved but this is simply because the project will be using two different frameworks for implementing REST services and a JSF application to act as a REST service client.  In particular notice that the configuration is setup to route requests for '/rest-mvc/*' through Spring MVC, '/rest-rs/*' through the JAX-RS implementation, and '/faces/*' through JSF for the client.
	__7.  Open the 'WebContent/WEB-INF/spring-mvc.xml' file.
	__8.  Notice that right now there is only a minimal configuration that will configure Spring MVC through annotations and scan a package for Spring components.  In particular note this scans only the 'com.acme.services.mvc' package.  There are also two other Spring configuration files that load a package for the JSF components and the Spring component that will be used as the business logic behind the two REST services.  In particular note that there is NOT a Spring configuration that enables the JAX-RS REST service class as a Spring component.
	__9.  Expand the 'src → com.acme.services.entities' package and double click the QuoteRequest.java file to open it.  This is just a simple class to define the data that will be transferred by the two REST services.  The only thing unique about this class is the JAXB @XmlRootElement annotation that enables this class to be transformed into XML.  This is critical as both the REST support of Spring MVC and JAX-RS can use JAXB to transform Java objects into XML.  You can also look at QuoteResponse.java which is similar.
	__10.  Expand the 'src → com.acme.bean' package and double click the QuoteGenerator.java file to open it.  This is a basic Spring component that will take the data from a QuoteRequest object and form a QuoteResponse object to return.  The purpose of this component is to provide the business logic behind both REST services and show how to inject other Spring components into the two classes that will focus on the REST service communication.
	__11.  Close all open files.  Make sure you have not made any changes.

	Part 3 -  Implement a Spring REST service with JAX-RS
	__1.  Expand the 'src → com.acme.services.jaxrs' package and double click the QuoteServiceRS.java file to open it.
	__2.  Add the following @Path annotation to the class definition.  This will determine the path that will route a request to this REST service.  This will be combined with the '/rest‑rs/' path that routes into Jersey to begin with.
	__3.  Add the following @Autowired field to the class definition.  This will be the Spring component that will be used by the method that actually receives the REST request.
	__4.  Modify the logic of the 'getQuote' method to use the new 'generator' field as shown below to calculate the result that is returned instead of the null that is currently returned.
	__5.  Before the 'getQuote' method definition add the following three JAX-RS annotations.  These will indicate that a HTTP POST request is required for the method and that the REST service will expect XML data as input and return XML data.
	__6.  Finally, add a new method with a @PostConstruct annotation that will use the SpringBeanAutowiringSupport class to initialize the @Autowired field.  Make sure to add this method within the curly brackets of the class definition.
	__7.  Save the file and make sure there are no errors.
	__8.  Go to the top of the file and click the '+' symbol in the margin next to the import statements to expand all the import statements.  You will see a few Spring imports related to the @Autowired support but notice that all the annotations for configuring this as a REST service come from JAX-RS (javax.ws.rs).

	Part 4 -  Test JAX-RS REST Service
	__1.  If you haven't done so yet, make sure that you have a WebSphere 8.0 server as defined in the “Setup” lab.
	__2.  In the Servers view, locate WebSphere Application Server v8.0.
	__3.  Right click it and choose Start.
	__4.  Periodically switch to the Servers view and wait for the server's status to change to Started.
	__5.  Right click the server and select Add and Remove ...
	__6.  Select Spring-RESTEAR project and click Add.
	__7.  Click the Finish button.  The application should be published to the server.  
	__8.  Open a Windows File Explorer window and navigate to the <SOFTWARE>/RESTClient directory.
	__9.  Double click the 'restclient.bat' Windows batch file to run the command that will start the tool.  Make sure you don't close the command window that appears that is running the program.
	__10.  From the REST Client tool's menubar, select File > Open Request (Control+O).
	__11.  Open <LABFILES>\Spring-REST\quote_request.rcq
	__12.  Review these items about the request:
	__13.  Click the  button to send the request.
	__14.  Verify that:
	__15.  Click the Body tab for the response.
	__16.  Right click the response body text and select Indent > Indent XML.
	__17.  Study the response document.
	__18.  In the Eclipse Console, verify the log output from the QuoteServiceRS class.  This verifies the code you implemented was called.
	__19.  Leave the REST Client tool running for testing the next service.

	Part 5 -  Implement a Spring REST service with Spring MVC
	__1.  Expand the 'src → com.acme.services.mvc' package and double click the QuoteServiceMVC.java file to open it.
	__2.  Add the following two annotations to the class definition.  The @Controller annotation will define this as a Spring MVC controller which will allow it to handle requests.  The @RequestMapping annotation is the equivalent of the JAX-RS @Path annotation and indicates how requests will be mapped to this REST service.  This will be combined with the '/rest‑mvc/' path that routes into Spring MVC to begin with.
	__3.  Add the following @Autowired field to the class definition.  This will be the Spring component that will be used by the method that actually receives the REST request.
	__4.  Modify the logic of the 'getQuote' method to use the new 'generator' field as shown below to calculate the result that is returned instead of the null that is currently returned.
	__5.  Before the 'getQuote' method definition add the following two Spring MVC annotations.  These will indicate that a HTTP POST request is required for the method and that the return value of the method is to be used as the @ResponseBody.  Notice that mapping to the HTTP POST method is a little more complex then the JAX-RS @POST annotation but it is the same @RequestMapping annotation so you could indicate path and HTTP method with one annotation.
	__6.  In the method signature of the 'getQuote' method add the following @RequestBody annotation before the QuoteRequest method parameter.  Make sure the annotation is inside the parenthesis of the method parameters but before the type of the method parameter as shown below.
	__7.  Save the file and make sure there are no errors.
	__8.  Go to the top of the file and click the '+' symbol in the margin next to the import statements to expand all the import statements.  Notice there are many more Spring imports.

	Part 6 -  Test Spring MVC REST Service
	__1.  In the Servers view, check that your 'WebSphere 8.0' server is running and start it if it is not.
	__2.  Switch to the Servers view and publish the WebSphere 8.0 server by right clicking and selecting Publish.
	__3.  Return to the REST Client tool and open it again if you closed it.  Also if you had closed the tool, open the test file used in the last testing section.
	__4.  From the menus select Edit → Clear Response.  This will verify the response is a new one.
	__5.  In the URL field of the request section change the URL value so it uses the URL that will get sent to Spring MVC.  The complete URL should be:
	__6.  Click the  button to send the request.
	__7.  Verify that:
	__8.  Click the Body tab for the response.
	__9.  Right click the response body text and select Indent > Indent XML.
	__10.  Study the response document.  It should be the same as with the JAX-RS service.
	__11.  In the Eclipse Console, verify the log output from the QuoteServiceMVC class.  This verifies the code you implemented was called.
	__12.  Select File → Exit in the REST Client tool.
	__13.  Close any other open files in Eclipse.

	Part 7 -  Implement a Java REST Client Using Spring RestTemplate
	__1.  Open the 'WebContent/index.xhtml' file.  Notice this is a standard JSF page which will collect data and initialize properties of a 'request' property of the 'quoteRequestClient' JSF component.  There is also a response.xhtml file that will show output properties of the 'response' that is returned from the REST service.
	__2.  Close all open files.  Make sure you have not made any changes.
	__3.  Expand the 'src → com.acme.jsf' package and double click the QuoteRequestClient.java file to open it.  Notice that this class is detected as a Spring component at the request scope.  This is to make sure the data submitted and the response displayed will not live beyond a single request.
	__4.  Find the 'submitRequest' method and fill in the following lines of code.  Make sure to add them all before the 'return' statement.  The key to this code is using the RestTemplate 'postForObject' method which will take the 'request' object initialized by JSF and send a POST request to the URL provided.  The QuoteResponse class is the third parameter so that the object returned by the method is a QuoteResponse object initialized by parsing the XML in the body of the REST service response.
	__5.  Save the file and make sure there are no errors.
	__6.  In the Servers view, check that your 'WebSphere 8.0' server is running and start it if it is not.
	__7.  Switch to the Servers view and publish the WebSphere 8.0 server by right clicking and selecting Publish.
	__8.  Open a web browser and enter the following address:
	__9.  Fill in some sample data using a positive, non-zero value for the quantity.  The date is treated just as a String so any format will do.
	__10.  Press the 'Submit Request' button and verify you get a response.  Notice the total price and unit price that, while simple, were supplied by the REST service.
	__11.  In the Eclipse Console, verify the log output from the QuoteServiceRS class.  This verifies the REST service was called by the JSF client.
	__12.  If you want you could change the client code to use the '../rest-mvc/..' URL but the behavior should be the same.
	__13.  Close all open files and the web browser you used to test.

	Part 8 -  Lab Cleanup
	__1.  Undeploy and close the Spring-REST projects as described in the 'Common Lab Preparation Steps' at the 'Lab Cleanup' part.

	Part 9 -  Review




