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Lab 1 - Setup the Development Environment
In this lab you will setup the environment for developing Web Services for JBoss.  This 
includes installing JBoss Eclipse plug-ins.

Part 1 - Verify Java Install
Since this course uses Java 7, which is still relatively new, you will do a few quick steps 
just to verify everything is setup properly.  Java 7 should have been installed as part of 
the class setup but these steps will help verify and avoid other issues later when they are 
harder to debug.

__1. Open a Windows command prompt.  You can usually do this on most versions of 
Windows by selecting 'Start → Programs → Accessories → Command Prompt'.

__2. Run the following command and make sure you get a Java “1.7.x” version.  If you 
do not see this, the next steps will help figure out what setting is incorrect.  Also, if you 
get an error about java not being “recognized” as a command the next steps will help 
figure out why.

java -version

__3. Run the following command to see the current value of the 'PATH' environment 
variable.  Check that you see the 'bin' directory of a Java 1.7 installation in the PATH.  If 
you do not see Java 1.7 or if you see multiple versions of Java referenced this could be 
causing errors.

set PATH

Note: Your actual value may be slightly different but it should be obvious that it is a 
Java (or “JDK”) 1.7 version.
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__4. Run the following command and look at the value of the 'JAVA_HOME' 
environment variable. Make sure that it points to the root directory of a Java 1.7 
installation.  If you get a message about 'JAVA_HOME' not being defined this could also 
cause issues.

set JAVA_HOME

Note: Your actual value may be slightly different but it should be obvious that it is a 
Java (or “JDK”) 1.7 version.

__5. If you have not seen output similar to that shown in the previous steps, inform your 
instructor.  They can help determine if all students have the same (or similar) issue and 
the best way to fix it so it won't cause problems later.

__6. Close the command prompt.

Part 2 - Install JBoss Eclipse Plug-ins
Besides allowing us to use JBoss as a test server, the "JBoss Tools" Eclipse plug-ins have 
a few tools specific to web services.  This section will install those tools.  This was not 
done as part of the class setup because the steps are a little more involved.  It will also be 
good for you to know how to install these tools if you want to obtain them for your own 
environment from:

http://www.jboss.org/tools/download

The JBoss Tools version you will use has already been downloaded and is compatible 
with the Eclipse version you are using.

__1. Start Eclipse by launching C:\Software\eclipse\eclipse.exe

Eclipse will launch.

You will be prompted to select a Workspace. 

__2. Set the Workspace to C:\workspace
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__3. Click OK.

Eclipse will start. 

__4. Eclipse may be displaying the Welcome screen.  Close the welcome screen by 
clicking the x in its tab.  

__5. From the Eclipse menus select Help → Install New Software...

Note: If you get an error about some sites not being found it is because Eclipse can't 
connect to the Internet.  Since you will be provided with a local copy of the updates you 
can ignore this error and click 'OK'.

__6. Click the Add button on the upper right to add a new update site.

__7. Click the Archive... button.

Note: You are using this option since the JBoss Tools are provided as a single Zip file 
with the class software.
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__8. In the dialog to choose a file, find and open the file 
'C:\Software\JBoss Tools\jbosstools-4.0.1.Final....zip'.  The end of the file name is not 
given as it may change but this should be the only Zip file which starts with that name at 
that location.

__9. Once you have chosen the appropriate Zip file, give the update site a name of 'JBoss 
Tools Archive' and press the OK button when your options are similar to that shown 
below.

__10. In the list of available features expand the 'Abridged JBoss Tools 4.0' category and 
check ONLY the 'JBoss WebServices Tools' and the 'JBossAS Tools' options as shown 
below and press the Next button.

Note: Although JBoss Tools has other tools available we will only use these tools for the 
labs.
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__11. You will see a list of software that will be installed as shown below.  There should 
be no checkboxes next to any features.  Press the Next button.

__12. On the 'Review Licenses' screen, select the radio button in the lower right labeled 
'I accept the terms of the license agreements' and press the Finish button.  This will 
begin installing the software.

__13. Leave the dialog box that appears running so that you can see when the installation 
process completes.

__14. When you get a prompt about unsigned plugins click the OK button.
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__15. Once the installation is complete you will get a prompt to restart Eclipse.  Press the 
Yes button to restart.

__16. Open Eclipse in the same workspace when it restarts.

__17. Click No if the JBoss Tools Usage dialog opens.

Part 3 - Configure JBoss Test Server in Eclipse
Now that the JBoss Eclipse tools are installed the next step is to define a JBoss test 
server.  This will let you deploy and test applications directly from Eclipse.

__1. Click on the Servers view located in the bottom of the Eclipse window.

__2. Right click in the empty area and select New -> Server.

__3. From the list expand JBoss Community and select JBoss AS 7.1
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__4. Click Next.

__5. Click the first Browse button next to Home Directory and navigate to 
C:\Software\jboss-as-7.1.1.Final and then click OK.  Stay on the same page in the main 
wizard.

__6. For the JRE option use the drop-down to select the JDK 1.7 that is installed.

__7. Click Finish once your dialog matches the settings shown below.

__8. The new server will appear in the Servers list.

__9. Right click on the Server and select Open.
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__10. The configuration page of the Server will open.

__11. Expand Publishing on the right side.

__12. Select Never publish automatically.

__13. At the bottom of the Eclipse server configuration editor click the 'Deployment' tab.

__14. Check the 'Deploy projects as compressed archives' option.
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Note: This option is generally best to allow rapid deployment and testing of changes 
made in Eclipse.  The default settings would deploy an “exploded” archive.  Even 
though modifying and publishing an updated Java class would recompile the .class file 
copied to the server, the application would not be restarted and the previous version of 
the class loaded by the server would still be used.

By deploying a compressed archive, any change to any file in that project would recreate 
the entire archive and cause the entire application to be redeployed.  This would 
guarantee the most recent code is being used.  Since JBoss deployment is very quick, 
this method is preferred to avoid any confusing behavior where code changes have not 
been picked up by the server.

__15. Save the changes and close the window.

__16. In the Servers view, right click the 'JBoss 7.1 Runtime Server' and select Start.  

__17. Click the tab for the Console view and scroll back to find the message about JBoss 
Web Services starting.  Notice that it is using the “CXF Stack” from Apache CXF.  This 
will be important in advanced web service features in later labs.

__18. Check that the server starts successfully.  You may need to switch back to the 
Servers view.

__19. Leave the server running for the next section.

Part 4 - Configure JBoss Management User
By default the web administration console of JBoss is secure but doesn't have any users 
configured.  This effectively locks it down until you configure users to access it.  Since 
several labs may need to go into this administrative console to perform various tasks, this 
section will enable an administrative user.

__1. Open a Windows command prompt.  You can usually do this on most versions of 
Windows by selecting 'Start → Programs → Accessories → Command Prompt'.
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__2. Use the following 'cd' command to switch to the JBoss 'bin' directory.

cd C:\Software\jboss-as-7.1.1.Final\bin

__3. Run the following 'add-user' command to start the interactive tool to add a user. 
How to respond to various prompts is given in the next steps.

add-user

__4. On the first prompt, hit the <ENTER> key to accept the default option of 'a' to 
create a “management user”.

__5. On the second prompt, hit the <ENTER> key to accept the default option of 
'ManagementRealm' for the security realm.  This is the name of the security realm 
already defined in the JBoss server so using this ensures we do not have to change any 
other JBoss configuration.

__6. Enter a username of 'admin'.
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__7. Type the following password for both prompts that ask you to enter a password. 
Note that the program will not even show stars while you type.

jbo$$ee6

Note: This version of the tool requires a password that is at least 8 characters and has 
one number and one non-alphanumeric character.

__8. Type 'yes' to accept the username 'admin' since it is “easy” to guess.

__9. Type 'yes' to confirm you want to add the 'admin' user to the 'ManagementRealm'.

__10. Hit any key to let the program finish and return you to the command prompt.

__11. Close the command prompt.

__12. Go back to the Servers view in Eclipse and make sure your JBoss server is 
running.  Start it if it is not.

__13. Open a web browser to the following address which should bring up a security 
prompt.

http://localhost:9990/console
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__14. In the security prompt, enter a username of 'admin' and a password of 'jbo$$ee6'. 
You can check the option to remember the password if offered.

__15. Check that you see the overview page of the administration console.  If it doesn't 
display try refreshing the page.

Note: If you get an authentication error it may be because somehow the password you 
entered in the browser is different than what you configured in the script tool.  If you 
can't provide the correct password you can run the 'add-user' tool again but you first 
have to manually delete some lines from two text files.

Find the following two text files, open them with a text editor like WordPad, and delete 
the line that starts with 'admin=...' without a leading '#' as a comment.

C:\Software\jboss-as-7.1.1.Final\domain\configuration\mgmt-users.properties

C:\Software\jboss-as-7.1.1.Final\standalone\configuration\mgmt-users.properties

You need to delete this line from both files because even though your configuration is 
only looking at the 'standalone' properties file, you can't run the 'add-user' tool again 
with the same user if it already exists in either one of these files.

__16. Close the browser you are using to access the administration console.

__17. Stop the server in the Eclipse Servers view.
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Part 5 - Update JBoss Web Service Runtime
Although the JBoss server already has the JBossWS-CXF “stack” installed, it is missing 
some modules that will be needed for more advanced functions later.  Since this lab is all 
about setting up the environment it would be good to run a command to update this now. 
Also, although we won't change the JBoss web services version, you could use this 
technique to upgrade your own environment to a more recent version if desired.

The software for a version of the CXF "stack" of JBoss Web Services has already been 
provided as part of the class software.  Installing different "stacks" for JBoss Web 
Services is very easy.  All come with an Ant build file that we can run from Eclipse after 
changing a few settings.

Even though the JBoss Web Services runtime we will use is provided for you the JBoss 
Web Services site has various downloads of the different options:

http://www.jboss.org/jbossws/downloads

__1. Make sure the JBoss server is stopped in the Servers view.  This is important since 
we will be modifying the JAR libraries and some of the deployed services of the server.

__2. Open a Windows Explorer window and navigate to the 
'C:\Software\jbossws-cxf-bin-dist\' directory.

__3. Rename the 'ant.properties.example' file to 'ant.properties'.

__4. In Eclipse, select File → Open File...

__5. Open the file 'C:\Software\jbossws-cxf-bin-dist\ant.properties'

__6. Set the location of JBoss by setting the jboss711.home property as follows.  Make 
sure to use forward slashes (/) and not backslashes (\) or the Ant build will fail.  You can 
leave the other home directories of other JBoss versions as they are.

jboss711.home=C:/Software/jboss-as-7.1.1.Final

Note: If for some reason your lab software was extracted to a different location, adjust 
this value so it points to the correct directory for the JBoss server.
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__7. Modify the jbossws.integration.target property so it has the value of 'jboss711'.

jbossws.integration.target=jboss711

__8. Select File → Save from the Eclipse menus.

__9. In Eclipse, choose File → Open File from the menubar.

__10. Open C:\Software\jbossws-cxf-bin-dist\build.xml.

__11. From the Outline view on the right, right-click the 'JBossWS-CXF' root project 
definition and select Run As → Ant Build...  Make sure to select the "Ant Build..." 
option (with ellipsis) and not just the regular "Ant Build" option.

__12. From the list of targets, select only the deploy-jboss711 target but do not run the 
build yet.  Be careful which target you select as there are several with similar names.
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__13. Click the JRE tab at the top and fill in a value of '-Dspring=true' without the 
quotes (but with the leading dash). You may need to expand the dialog to be able to edit 
in the field.

__14. Click the Run button at the bottom right.

Note: Although there are targets that appear they would only deploy the Spring modules, 
they don't appear to work without running the main 'deploy' target.

__15. The Console should show the output from Ant which should end with the "BUILD 
SUCCESSFUL" message.
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Note: If you have errors during the build and try to run the command again, Eclipse may 
be remembering your previous (and perhaps incorrect) settings.  You can go to 'Run → 
External Tools → External Tools Configurations...' to modify (and perhaps delete to 
start over) the configuration Eclipse used to run the Ant build.

__16. In a Windows Explorer window, open the following folder and be sure you see a 
number of Spring JAR files.

C:\Software\jboss-as-7.1.1.Final\modules\org\springframework\spring\main

__17. From the Servers view of Eclipse start the JBoss 7.1 server.

__18. After the server starts search for the 'JBoss Web Services' version as shown below. 
This is probably about 1/3 of the way from the start of the messages.

__19. Check that the CXF version 4.0.2.GA version is listed as shown above.  This is the 
same it was before.

__20. Stop the JBoss server and close all open files.

Part 6 - Review
In this lab you installed JBoss Eclipse plug-ins for the rest of the labs.  You could do 
these steps in your own development environment after downloading the proper JBoss 
Tools downloads.  You also did several configuration steps that will let you work with 
JBoss from Eclipse and access the administration console if required.  You also saw how 
to install a different version of JBoss Web Services in a JBoss server.  Although we just 
installed the Spring modules for later and used the same JBossWS-CXF version, you 
could also download a different version in your own environment.
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Lab 2 - Introduction to Web Services
In this lab, you will review some of the key components of Web Services, namely, WSDL 
and SOAP. You will also get a chance to see a Web Service in action. The goal of this lab 
is to get yourself familiar with what a Web service looks like. We will not get into too 
much detail at this point; just walk away with a basic understanding of the components 
involved in a web service.

The web service in question is very simple. It has one operation called sayHello. It takes 
as input a person's name (say "John") and returns as output a greeting message (say, 
"Hello John").

Part 1 - Import the Project
To save time, the web service is already implemented. You will simply import it into 
Eclipse for examination.

__1. Make sure Eclipse is open in the workspace 'C:\workspace'.

__2. In Eclipse, choose File → Import from the menubar.

__3. Expand General. Select Existing Projects into Workspace.

__4. Click Next.

__5. Select the Select archive file radio button.

__6. Click the Browse button and select the C:\LabFiles\TestWS.zip archive file and 
click Open.

__7. Click Finish to import the project from the archive file.  This project is a web 
module project. This represents a WAR file in Java EE.
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Part 2 - Inspect the Implementation Class
The business logic for a Web Service is implemented in a Java class. The Java class may 
be a plain class or a session EJB. In this case, we used a plain Java class in a web module. 
We will briefly have a look at it.

__1. In the Project Explorer view, expand the TestWeb project as shown below.

__2. Double click HelloSvc.java to open it.

__3. Have a quick look at the sayHello() method. Note the following:

● By default, the Java method that implements a Web Service operation has the 
same name as the operation.

● The @WebService annotation is used to designate the HelloSvc class as a Web 
Service implementation.

● The @WebMethod annotation is used for the sayHello() method to designate it as 
a Web Service operation. These annotations are made available as a part of the 
JAX-WS specification.

__4. Close the Java file.
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Part 3 - Deploy the Project to JBoss Server
You can directly deploy a project to the JBoss server. Eclipse will automatically invoke a 
build process which will produce a WAR file for the project and then the WAR file will 
be deployed into the server. Once a project has been deployed to the server, Eclipse will 
repeat the build-deploy cycle every time you make any change to the projects. This 
makes development and unit testing quite easy.

__1. In the Servers view, right click JBoss 7.1 Runtime Server and select Add and 
Remove...

__2. Select the TestWeb project and click the Add button.

__3. Click Finish.

__4. Start the JBoss server in the Servers view.

__5. After several seconds, check the Servers view again and make sure that the Status 
is Synchronized. That means, the code deployed to the server is same as what is in 
Eclipse.
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Part 4 - Examine the WSDL File
A WSDL file is used to describe what a Web Service can do and what type of input and 
output data it works with.

__1. Open a web browser to the following address which should bring up a security 
prompt.

http://localhost:9990/console

__2. In the security prompt, you may have to enter a username of 'admin' and a password 
of 'jbo$$ee6'.  You can check the option to remember the password if offered.

Note: This should be the administration user you configured by running the 'add-user' 
script in the development environment setup lab.

__3. Check that you see the overview page of the administration console.  If it doesn't 
display try refreshing the page.

Note: Sometimes you might also see that the admin console page displays but the 
HTML styles are not being applied.  JBoss 7.1 seems to have trouble where sometimes 
the stylesheet doesn't load properly.  Refresh the page and hopefully the page will 
display properly.
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__4. On the left side of the console, click the link for 'Deployments → Webservices' 
which should be expanded and visible.

__5. Check that you see the details of the 'HelloSvc' web service displayed.  It may not be 
obvious since we have only one web service but the top is a table that you could click 
different rows of to show the details of a web service in the 'Selection' area below.
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__6. Open another browser tab or window to the 'WSDL URL' shown for the web 
service (http://localhost:8080/TestWeb/HelloSvc?wsdl).  You should see the XML 
syntax of the WSDL of the deployed web service.

Note: Unfortunately the administration console does not present this as a link that you 
could click so you would have to copy the URL into the browser.

The <portType> element in WSDL describes the Web Service. Note that an <operation> 
element exists with the name attribute set to "sayHello".

The <input> and <output> elements within <operation> describes the format of the input 
and output data for the operation. We won't go any further to explore the WSDL at this 
stage.

Part 5 - Invoke the Service
We should now actually test the service.  Testing the service would imply actually 
invoking the operation.  

Typically, doing so would require that we create a web service client.  A web service 
client is, as its name implies, any program that makes a call to a web service.  The 
program could be written in Java, .NET, or any other language that understands web 
service standards. 

Writing a client can be time consuming, so we will “cheat” and use a tool built into 
Eclipse called the Web Services Explorer (WSE).  The WSE works by reading a WSDL 
file and then figuring out what services are available and how to invoke them.  The WSE 
will then dynamically generate a form that represents the service's operations that will 
allow you to invoke it.

Think about this for a moment: our service, at its core, was a single operation called 
sayHello which took a single string as a parameter.  The service would then return a 
greeting based on that parameter. 

__1. In the browser, where we viewed the WSDL, copy the URL address of the WSDL. 
We will need this WSDL location to run the Web Services Explorer.
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__2. Back in Eclipse, launch the WSE.  To do this, use the menu and select Run → 
Launch the Web Services Explorer.  This is probably at the bottom of the menu.

The WSE will open.

Note: The JBoss Tools Eclipse plug-ins have a 'Web Service Tester' view but it is not as 
easy to use as the Web Services Explorer so we won't use it.

__3. We need to point the WSE at our generated WSDL file.  Locate the row of buttons in 
the top right hand side of the WSE. 

__4. Click the second button from the right to switch the WSE to WSDL mode.

The main Navigator of the WSE will change.

__5. Click WSDL Main in the Navigator pane.

In the Actions pane on the right, you will be prompted for a WSDL URL.
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__6. Paste the URL you copied earlier, which was:

http://localhost:8080/TestWeb/HelloSvc?wsdl

__7. Click Go.

At this point, the WSE will read the WSDL file.  It notices our sayHello operation. 

__8. Click the link for sayHello. WSE will create a form to enter the input data for the 
sayHello operation.

__9. Click the Add link to create a text box for the name parameter. 

Note: The WSE thinks that the name parameter is optional since its value may be null. 
Subtleties such as these are captured in the XML schema for the input and output data 
for the operation.

__10. Enter a name into the field and click Go.
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__11. Scroll down and look in the Status  pane.  If you have trouble seeing the response 
you can double click on the title bar of the Status section to maximize the window.

This shows what the call to the web service returned.

In this case, it returns the String “Hello <name>”. 

Our web service invocation has worked!

Part 6 - Inspect the SOAP Messages
When we invoked the sayHello operation, WSE actually sent a SOAP formatted XML 
document to the server using the HTTP protocol. The server also replied back using a 
SOAP formatted XML document.  SOAP is a versatile data format for request response 
type communication. In its most basic form, as is the case in this lab, it is utterly simple. 
At the same time, it is capable of taking on more advanced aspects of communication, 
such as, encryption, message signature, transaction and guaranteed delivery.

__1. If it is not already maximized, double click on the title bar of the Status section to 
maximize the window and  have a better look of the information.

__2. In the Status pane of WSE, click the Source link.
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__3. Briefly inspect the request and response messages as shown below. Don't worry 
about the details. You will learn SOAP shortly.

__4. Restore the Status window.  You can do this by double clicking on the title bar of the 
Status section.

__5. Close all open files.

__6. Stop the JBoss server.

Part 7 - Review
In this lab, you had a brief encounter with a Web Service. First, we looked at the Java 
class that implements the business logic of the Web Service. That is the true meat behind 
the Web Service. When building a Web Service, you will probably spend most of the time 
writing the business logic. Next, we inspected the WSDL file that describes the nature of 
the Web Service. After that we tested the Web Service and inspected the SOAP messages.

The lab also served two other purposes. You learned how to deploy an application to the 
server. We will do that frequently throughout these lab exercises. You also found out how 
to use the Web Services Explorer to quickly unit test a Web Service.
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Lab 3 - Creating an XML Schema
An XML schema is used to verify that the contents of an XML file are valid; essentially, 
it is a set of “rules” for an XML file.  A particular XML file can be checked against a 
particular schema, and a parser can decide if the XML conforms to the rules set out in the 
schema.  

If, for some reason, the XML does not conform to the schema, the XML parser can reject 
the XML and raise an immediate error.  Essentially, schema adds a layer of validation to 
any XML-based application. Given that web services use XML as their communication 
layer, we can see the value of schema.  Schema are actually used quite frequently in the 
various layers of web service communication.

In this lab, we will create an XML schema.

Part 1 - The Movie.xml File
Throughout these labs, we will be developing a system that deals with movies.  We have 
thus decided to model a movie as an XML file.  This modeling will come in handy when 
we start building the web service. 

__1. Let us start things off by taking a look at a sample movie.xml file.  Using a text 
editor, open file C:\LabFiles\movie.xml

It looks like the following: 

<?xml version="1.0" encoding="UTF-8"?>
<m:database xmlns:m="http://www.mycom.com/movie">

<movie title="Preaching to the Choir" rating="PG13">
<description>
Two estranged brothers -- one a hip-hop star and
the other a Baptist preacher -- find a way 
to make amends and help one another out as 
they each face a crisis in their lives.
</description>
<actor>Billoah Greene</actor>
<actor>Novella Nelson</actor>

</movie>
<movie title="Kekexili: Mountain Patrol" rating="PG13">

<description>
A moving true story about volunteers protecting
antelope against 
poachers in the severe mountains of Tibet.
</description>
<actor>Zhang Lei</actor>
<actor>Qi Liang</actor>

</movie>
</m:database>
<!-- Contains some copyrighted material from imdb.com -->
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Let us analyze this XML file.

The outermost element is called <database> and it contains multiple <movie> elements. 

Each <movie> has two attributes; one called title and one called rating, which reflects a 
movies title and rating respectively. 

Additionally, each <movie> has a single child element called <description> (which 
contains a description of the movie in question) and multiple elements called <actor>, 
with each one representing an actor in the associated movie. 

This is a fairly simple modeling of the movie.  We capture some important information 
about each movie (the title, the description, the rating and the actors), and store this 
information using a mixture of attributes and child elements. 

What we should do now is formalize this model by creating an schema for the 
<database> element (remember that the root element here is <database>, not <movie>).

Once that is done, an application reading/writing one of these movie XML files will be 
able to use the schema to validate that the structure of the XML is good.  (Validating the 
content of the XML, however, is another matter completely).

__2. Close the text editor.

Part 2 - Create the Project
A schema is itself an XML file, and we could create it using a text editor.  However, 
Eclipse provides some nice tools for creating a schema, so we will use those instead. 

__1. Start Eclipse if it is not already running.  

__2. Stop the server if it is running.

__3. Close any open editor windows. (Ctrl-Shift-W)

__4. We will now create a new project to hold our schema file.  From the Eclipse menu 
bar, select File | New | Project...

The New Project window will appear.  

__5. In the list, select Java Project and click Next.

The New Java Project screen will appear.
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__6. Set the Project name to be XMLProject and click Finish.

__7. Eclipse will then prompt you if you would like to switch to the Java Perspective.

__8. Check Remember my decision and click No.
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The XMLProject project will be created and listed in the Project Explorer view. (You 
may want to minimize all other projects – e.g. TestWeb in the Project Explorer to keep 
things a little easier to read)

We should create a folder to hold our XML resources. 

__9. Right-click on the newly created XMLProject and select New | Folder.

__10. The New Folder window will appear.  Set the Folder name to be xml and click 
Finish.

The folder will be created, and should be visible under the project.

Part 3 - Create the Schema
We can now create the schema.

__1. Right click on the newly created xml folder and select New | Other...

The New window will appear.

__2. Scroll down and expand XML.  
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__3. Select XML Schema File and click Next.

__4. The Create XML Schema window will appear.  Set the File name to be movie.xsd 
and click Finish. (By convention, schemas always have an XSD extension)

The XML Schema Editor will open.  This is Eclipse's graphical XSD schema editor. This 
will save us having to create the schema by hand.  

We will be using this editor to design our schema.  

First, we should change the schema's default name space which is currently set to 
http://www.example.org/movie as can be seen at the top of the editor.
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__5. Right-click anywhere on the opened schema editor and select Show properties.

Now, at the bottom of Eclipse, the Properties view should have opened.

__6. Here, change the Prefix to m

__7. Change the Target namespace to http://www.mycom.com/movie

We should also specify that by default, the namespaces are not qualified.  

__8. Click the Advanced tab on the left of the Properties view.

__9. Change the Prefix for elements drop down to a blank.

__10. Save changes by hitting Ctrl-S.

The editor should update with the new namespace.
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We can now go about defining the types that make up this schema.  The core type 
represents the movie data, which we will call the movieType.  (The other type is the 
<database>, which is composed of multiple movieType elements – we will get to that 
later).  We will also define a simple type for the rating since that is a choice of specific 
values and we can use the restrictions available with XML schema.

We will start by defining the simple type for the rating since that is used by the movie 
type.  That way when we define the movie type it will already be available.

__11. Right click inside the Types pane and select Add Simple Type.

__12. A new type will appear.  Change its name to ratingType by typing a new name and 
hitting <Enter> to accept the new name.

Note: If the name is no longer selected to change you might need to right click it and 
select Refactor → Rename.

The type has been defined.  We now need to specify what data it contains.  

__13. Double click on the newly created ratingType.

The view will change to a closeup of the ratingType.  
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__14. Right click an empty area and select Show Properties and check that the basic 
properties of the simple type show up in the Properties view.  The 'Base type' is string 
which is fine for us but might be one thing that is changed for data that is better qualified 
as another data type.

__15. Click the Constraints tab on the left of the Properties view.

__16. Scroll to the far right of the view and click the second 'Add...' button in the 
'Specific constraint values' section.
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__17. In the dialog that appears, enter 'G,PG,PG13,R' making sure there are commas and 
no spaces between the values and click OK.

Note: If you click the wrong 'Add' button you will not get this useful dialog.  If that 
happens delete the single entry that was added by using the 'Delete' button and then click 
the correct 'Add...' button.

__18. Check that your constraint values listed appear as shown below.

__19. Go back to the main schema design page by clicking the icon in the top left corner.
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Next we will define the movieType.   Recall that we want the movieType to model 
rating, description, title and multiple actors as a combination of attributes and elements.

__20. Right click inside the Types pane and select Add Complex Type.

__21. A new type will appear.  Change its name to movieType by typing a new name and 
hitting <Enter> to accept the new name.

Note: If the name is no longer selected to change you might need to right click it and 
select Refactor → Rename.

The type has been defined.  We now need to specify what data it contains.  

__22. Double click on the newly created movieType.

The view will change to a closeup of the movieType.  

It is from here that we can add elements/attributes.  Let us add the description element 
first.   
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__23. Right-click on the movieType and select Add Element.

__24. A new element box will appear.  Rename it to description and hit <Enter> when 
you have supplied the new name.

Notice that the type for description was automatically set to string.  This is fine because 
we want our description modeled as a string.

We have now just declared that our schema defines a type called movieType which itself 
has an element called description of type string.

Now, we can add the actor element. 

__25. Right click on movieType  and again select Add Element.  

__26. This time, name it actor

Recall however, that our movie should have one or more actor elements associated with 
it.  We can specify that here in the schema by using multiplicity
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__27. Right click on the actor element and select Set Multiplicity | 1..* (One or more)

When you do this, the diagram should update to show the 1..* notation, which means “1 
or more”.  You might need to click in an open area of the editor for the view to show the 
[1..*] notation.

Now we can add the rating and title attributes.

__28. Right click on movieType and select Add Attribute.  Note this is an attribute and 
not element.

__29. Name the attribute title and hit <Enter> to accept the attribute name.
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__30. Repeat this step and add another attribute called rating

We need to change the type of the rating attribute though to use the simple type defined 
earlier.

__31. Double click on string next to the 'rating' attribute and a drop-down box should 
appear. 

__32. Select Browse... from the drop-down box. 

The Set Type window will appear.

__33. In the Name field, enter ratingType (or scroll through the list and select it) 

__34. Click OK.

The movieType element should now look like this.

As discussed earlier, a movieType has attributes for title and rating and elements for 
description and multiple actors.   (All of these are of type string, except the rating).
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We now need to define a database element that contains multiple instances of this 
movieType.  

__35. Go back to the main schema design page by clicking the icon in the top left corner.

__36. Back at the main schema page, the movieType and ratingType should be shown.

__37. Right click in the Elements pane (on the left) and select Add Element.

__38. Name it database

Let us now define that a database is composed of multiple movie elements. We will do 
so using an anonymous type.  

__39. Right click on database and select Set Type | New...
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The New Type window will appear.

__40. Check Create as local anonymous type.   This will grey out the Name field. 

__41. Click OK.

Seemingly, nothing will change.  

__42. Double click on database.

We see that the database element points to something called a (database type).  This is 
an anonymous field, which means is basically just a placeholder for another element type 
– like our movie!  (Using anonymous types can simplify schema).

We should now specify that the (databaseType) points to multiple movie elements.

__43. Right click on (databaseType) and select Add Element.
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__44. A new element will be created.  Name the element movie and hit <Enter> to accept 
the new name.

__45. We know there are multiple movies, so we should set the multiplicity.  Right click 
on movie and select Set Multiplicity | 1..* (One or more).  You may need to click 
somewhere blank once the multiplicity is set to show the [1..*] syntax.

One more thing. We have to set the type of each movie element to be movieType.

__46. Double click on string next to movie and a drop-down box should appear. 

__47. Select Browse... from the drop-down box. 

The Set Type window will appear.

__48. In the Name field, enter movieType (or scroll through the list and select it) 

__49. Click OK.
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The editor will now show the association between the <movie> element and the 
movieType.

We are done! 

__50. Hit Ctrl-S to save changes.

We have completed creating the schema.

Part 4 - Examine the Schema
We have now successfully created a schema using the Eclipse schema editor tool.  The 
tool generated all the necessary code for us; let us take a look at it now.  

__1. Click the Source tab at the bottom of the schema editor. The raw source code 
forming the schema will be displayed.  It should look like the following:

<?xml version="1.0" encoding="UTF-8"?>
<schema targetNamespace="http://www.mycom.com/movie" 
xmlns="http://www.w3.org/2001/XMLSchema" 
xmlns:m="http://www.mycom.com/movie">

<simpleType name="ratingType">
<restriction base="string">

    <enumeration value="G"></enumeration>
    <enumeration value="PG"></enumeration>
    <enumeration value="PG13"></enumeration>
    <enumeration value="R"></enumeration>
    </restriction>
</simpleType>

<complexType name="movieType">
<sequence>
    <element name="description" type="string"></element>

<element name="actor" type="string" maxOccurs="unbounded"
minOccurs="1">

</element>
</sequence>
<attribute name="title" type="string"></attribute>
<attribute name="rating" type="m:ratingType"></attribute>
</complexType>
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<element name="database">
<complexType>

<sequence>
<element name="movie" type="m:movieType"

maxOccurs="unbounded" minOccurs="1">
</element>

</sequence>
</complexType>
</element>
</schema>

Notice that the schema itself is written in XML. 

__2. Go through it and mentally understand what is being described here.

We state that a database is composed of 1 or more movie elements.  Each movie element 
is of type movieType.

A movieType is composed of elements representing description and 1 or more actor, 
and attributes representing the title and rating. 

If you compare this with the movie.xml we examined at the start of this lab, you should 
realize that movie.xml indeed conforms to the rules set out in the schema.  

Now, when an XML parser reads movie.xml, it can automatically check with this xsd to 
ensure it is valid.  We will use this schema in later labs in exactly this manner.

__3. Close the schema editor. 

Part 5 - Review
In this lab, you examined XML schema. 

We started off by examining an XML file that gave us an idea of how to represent a 
movie.  

We then created a schema that to formalize these rules of representation.  We used the 
Eclipse schema editor to create the XML file and in there defined the various elements 
and attributes that should make up a movie database.

Finally, we examined the raw XML source behind the schema to get a feel for what it 
describes, and saw that it indeed validates the movie.xml that we started off with.
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	Lab 1 -  Setup the Development Environment
	Part 1 -  Verify Java Install
	__1.  Open a Windows command prompt.  You can usually do this on most versions of Windows by selecting 'Start → Programs → Accessories → Command Prompt'.
	__2.  Run the following command and make sure you get a Java “1.7.x” version.  If you do not see this, the next steps will help figure out what setting is incorrect.  Also, if you get an error about java not being “recognized” as a command the next steps will help figure out why.
	__3.  Run the following command to see the current value of the 'PATH' environment variable.  Check that you see the 'bin' directory of a Java 1.7 installation in the PATH.  If you do not see Java 1.7 or if you see multiple versions of Java referenced this could be causing errors.
	__4.  Run the following command and look at the value of the 'JAVA_HOME' environment variable. Make sure that it points to the root directory of a Java 1.7 installation.  If you get a message about 'JAVA_HOME' not being defined this could also cause issues.
	__5.  If you have not seen output similar to that shown in the previous steps, inform your instructor.  They can help determine if all students have the same (or similar) issue and the best way to fix it so it won't cause problems later.
	__6.  Close the command prompt.

	Part 2 -  Install JBoss Eclipse Plug-ins
	__1.  Start Eclipse by launching C:\Software\eclipse\eclipse.exe
	__2.  Set the Workspace to C:\workspace
	__3.  Click OK.
	__4.  Eclipse may be displaying the Welcome screen.  Close the welcome screen by clicking the x in its tab.  
	__5.  From the Eclipse menus select Help → Install New Software...
	__6.  Click the Add button on the upper right to add a new update site.
	__7.  Click the Archive... button.
	__8.  In the dialog to choose a file, find and open the file 'C:\Software\JBoss Tools\jbosstools‑4.0.1.Final....zip'.  The end of the file name is not given as it may change but this should be the only Zip file which starts with that name at that location.
	__9.  Once you have chosen the appropriate Zip file, give the update site a name of 'JBoss Tools Archive' and press the OK button when your options are similar to that shown below.
	__10.  In the list of available features expand the 'Abridged JBoss Tools 4.0' category and check ONLY the 'JBoss WebServices Tools' and the 'JBossAS Tools' options as shown below and press the Next button.
	__11.  You will see a list of software that will be installed as shown below.  There should be no checkboxes next to any features.  Press the Next button.
	__12.  On the 'Review Licenses' screen, select the radio button in the lower right labeled 'I accept the terms of the license agreements' and press the Finish button.  This will begin installing the software.
	__13.  Leave the dialog box that appears running so that you can see when the installation process completes.
	__14.  When you get a prompt about unsigned plugins click the OK button.
	__15.  Once the installation is complete you will get a prompt to restart Eclipse.  Press the Yes button to restart.
	__16.  Open Eclipse in the same workspace when it restarts.
	__17.  Click No if the JBoss Tools Usage dialog opens.

	Part 3 -  Configure JBoss Test Server in Eclipse
	__1.  Click on the Servers view located in the bottom of the Eclipse window.
	__2.  Right click in the empty area and select New -> Server.
	__3.  From the list expand JBoss Community and select JBoss AS 7.1
	__4.  Click Next.
	__5.  Click the first Browse button next to Home Directory and navigate to C:\Software\jboss-as-7.1.1.Final and then click OK.  Stay on the same page in the main wizard.
	__6.  For the JRE option use the drop-down to select the JDK 1.7 that is installed.
	__7.  Click Finish once your dialog matches the settings shown below.
	__8.  The new server will appear in the Servers list.
	__9.  Right click on the Server and select Open.
	__10.  The configuration page of the Server will open.
	__11.  Expand Publishing on the right side.
	__12.  Select Never publish automatically.
	__13.  At the bottom of the Eclipse server configuration editor click the 'Deployment' tab.
	__14.  Check the 'Deploy projects as compressed archives' option.
	__15.  Save the changes and close the window.
	__16.  In the Servers view, right click the 'JBoss 7.1 Runtime Server' and select Start.  
	__17.  Click the tab for the Console view and scroll back to find the message about JBoss Web Services starting.  Notice that it is using the “CXF Stack” from Apache CXF.  This will be important in advanced web service features in later labs.
	__18.  Check that the server starts successfully.  You may need to switch back to the Servers view.
	__19.  Leave the server running for the next section.

	Part 4 -  Configure JBoss Management User
	__1.  Open a Windows command prompt.  You can usually do this on most versions of Windows by selecting 'Start → Programs → Accessories → Command Prompt'.
	__2.  Use the following 'cd' command to switch to the JBoss 'bin' directory.
	__3.  Run the following 'add-user' command to start the interactive tool to add a user. How to respond to various prompts is given in the next steps.
	__4.  On the first prompt, hit the <ENTER> key to accept the default option of 'a' to create a “management user”.
	__5.  On the second prompt, hit the <ENTER> key to accept the default option of 'ManagementRealm' for the security realm.  This is the name of the security realm already defined in the JBoss server so using this ensures we do not have to change any other JBoss configuration.
	__6.  Enter a username of 'admin'.
	__7.  Type the following password for both prompts that ask you to enter a password. Note that the program will not even show stars while you type.
	__8.  Type 'yes' to accept the username 'admin' since it is “easy” to guess.
	__9.  Type 'yes' to confirm you want to add the 'admin' user to the 'ManagementRealm'.
	__10.  Hit any key to let the program finish and return you to the command prompt.
	__11.  Close the command prompt.
	__12.  Go back to the Servers view in Eclipse and make sure your JBoss server is running.  Start it if it is not.
	__13.  Open a web browser to the following address which should bring up a security prompt.
	__14.  In the security prompt, enter a username of 'admin' and a password of 'jbo$$ee6'.  You can check the option to remember the password if offered.
	__15.  Check that you see the overview page of the administration console.  If it doesn't display try refreshing the page.
	__16.  Close the browser you are using to access the administration console.
	__17.  Stop the server in the Eclipse Servers view.

	Part 5 -  Update JBoss Web Service Runtime
	__1.  Make sure the JBoss server is stopped in the Servers view.  This is important since we will be modifying the JAR libraries and some of the deployed services of the server.
	__2.  Open a Windows Explorer window and navigate to the 'C:\Software\jbossws‑cxf‑bin‑dist\' directory.
	__3.  Rename the 'ant.properties.example' file to 'ant.properties'.
	__4.  In Eclipse, select File → Open File...
	__5.  Open the file 'C:\Software\jbossws-cxf-bin-dist\ant.properties'
	__6.  Set the location of JBoss by setting the jboss711.home property as follows.  Make sure to use forward slashes (/) and not backslashes (\) or the Ant build will fail.  You can leave the other home directories of other JBoss versions as they are.
	__7.  Modify the jbossws.integration.target property so it has the value of 'jboss711'.
	__8.  Select File → Save from the Eclipse menus.
	__9.  In Eclipse, choose File → Open File from the menubar.
	__10.  Open C:\Software\jbossws-cxf-bin-dist\build.xml.
	__11.  From the Outline view on the right, right-click the 'JBossWS-CXF' root project definition and select Run As → Ant Build...  Make sure to select the "Ant Build..." option (with ellipsis) and not just the regular "Ant Build" option.
	__12.  From the list of targets, select only the deploy-jboss711 target but do not run the build yet.  Be careful which target you select as there are several with similar names.
	__13.  Click the JRE tab at the top and fill in a value of '-Dspring=true' without the quotes (but with the leading dash). You may need to expand the dialog to be able to edit in the field.
	__14.  Click the Run button at the bottom right.
	__15.  The Console should show the output from Ant which should end with the "BUILD SUCCESSFUL" message.
	__16.  In a Windows Explorer window, open the following folder and be sure you see a number of Spring JAR files.
	__17.  From the Servers view of Eclipse start the JBoss 7.1 server.
	__18.  After the server starts search for the 'JBoss Web Services' version as shown below.  This is probably about 1/3 of the way from the start of the messages.
	__19.  Check that the CXF version 4.0.2.GA version is listed as shown above.  This is the same it was before.
	__20.  Stop the JBoss server and close all open files.

	Part 6 -  Review

	Lab 2 -  Introduction to Web Services
	Part 1 -  Import the Project
	__1.  Make sure Eclipse is open in the workspace 'C:\workspace'.
	__2.  In Eclipse, choose File → Import from the menubar.
	__3.  Expand General. Select Existing Projects into Workspace.
	__4.  Click Next.
	__5.  Select the Select archive file radio button.
	__6.  Click the Browse button and select the C:\LabFiles\TestWS.zip archive file and click Open.
	__7.  Click Finish to import the project from the archive file.  This project is a web module project. This represents a WAR file in Java EE.

	Part 2 -  Inspect the Implementation Class
	__1.  In the Project Explorer view, expand the TestWeb project as shown below.
	__2.  Double click HelloSvc.java to open it.
	__3.  Have a quick look at the sayHello() method. Note the following:
	__4.  Close the Java file.

	Part 3 -  Deploy the Project to JBoss Server
	__1.  In the Servers view, right click JBoss 7.1 Runtime Server and select Add and Remove...
	__2.  Select the TestWeb project and click the Add button.
	__3.  Click Finish.
	__4.  Start the JBoss server in the Servers view.
	__5.  After several seconds, check the Servers view again and make sure that the Status is Synchronized. That means, the code deployed to the server is same as what is in Eclipse.

	Part 4 -  Examine the WSDL File
	__1.  Open a web browser to the following address which should bring up a security prompt.
	__2.  In the security prompt, you may have to enter a username of 'admin' and a password of 'jbo$$ee6'.  You can check the option to remember the password if offered.
	__3.  Check that you see the overview page of the administration console.  If it doesn't display try refreshing the page.
	__4.  On the left side of the console, click the link for 'Deployments → Webservices' which should be expanded and visible.
	__5.  Check that you see the details of the 'HelloSvc' web service displayed.  It may not be obvious since we have only one web service but the top is a table that you could click different rows of to show the details of a web service in the 'Selection' area below.
	__6.  Open another browser tab or window to the 'WSDL URL' shown for the web service (http://localhost:8080/TestWeb/HelloSvc?wsdl).  You should see the XML syntax of the WSDL of the deployed web service.

	Part 5 -  Invoke the Service
	__1.  In the browser, where we viewed the WSDL, copy the URL address of the WSDL.  We will need this WSDL location to run the Web Services Explorer.
	__2.  Back in Eclipse, launch the WSE.  To do this, use the menu and select Run → Launch the Web Services Explorer.  This is probably at the bottom of the menu.
	__3.  We need to point the WSE at our generated WSDL file.  Locate the row of buttons in the top right hand side of the WSE. 
	__4.  Click the second button from the right to switch the WSE to WSDL mode.
	__5.  Click WSDL Main in the Navigator pane.
	__6.  Paste the URL you copied earlier, which was:
	http://localhost:8080/TestWeb/HelloSvc?wsdl
	__7.  Click Go.
	__8.  Click the link for sayHello. WSE will create a form to enter the input data for the sayHello operation.
	__9.  Click the Add link to create a text box for the name parameter. 
	__10.  Enter a name into the field and click Go.
	__11.  Scroll down and look in the Status  pane.  If you have trouble seeing the response you can double click on the title bar of the Status section to maximize the window.

	Part 6 -  Inspect the SOAP Messages
	__1.  If it is not already maximized, double click on the title bar of the Status section to maximize the window and  have a better look of the information.
	__2.  In the Status pane of WSE, click the Source link.
	__3.  Briefly inspect the request and response messages as shown below. Don't worry about the details. You will learn SOAP shortly.
	__4.  Restore the Status window.  You can do this by double clicking on the title bar of the Status section.
	__5.  Close all open files.
	__6.  Stop the JBoss server.

	Part 7 -  Review

	Lab 3 -  Creating an XML Schema
	Part 1 -  The Movie.xml File
	__1.  Let us start things off by taking a look at a sample movie.xml file.  Using a text editor, open file C:\LabFiles\movie.xml
	__2.  Close the text editor.

	Part 2 -  Create the Project
	__1.  Start Eclipse if it is not already running.  
	__2.  Stop the server if it is running.
	__3.  Close any open editor windows. (Ctrl-Shift-W)
	__4.  We will now create a new project to hold our schema file.  From the Eclipse menu bar, select File | New | Project...
	__5.  In the list, select Java Project and click Next.
	__6.  Set the Project name to be XMLProject and click Finish.
	__7.  Eclipse will then prompt you if you would like to switch to the Java Perspective.
	__8.  Check Remember my decision and click No.
	__9.  Right-click on the newly created XMLProject and select New | Folder.
	__10.  The New Folder window will appear.  Set the Folder name to be xml and click Finish.

	Part 3 -  Create the Schema
	We can now create the schema.
	__1.  Right click on the newly created xml folder and select New | Other...
	__2.  Scroll down and expand XML.  
	__3.  Select XML Schema File and click Next.
	__4.  The Create XML Schema window will appear.  Set the File name to be movie.xsd and click Finish. (By convention, schemas always have an XSD extension)
	__5.  Right-click anywhere on the opened schema editor and select Show properties.
	__6.  Here, change the Prefix to m
	__7.  Change the Target namespace to http://www.mycom.com/movie
	__8.  Click the Advanced tab on the left of the Properties view.
	__9.  Change the Prefix for elements drop down to a blank.
	__10.  Save changes by hitting Ctrl-S.
	__11.  Right click inside the Types pane and select Add Simple Type.
	__12.  A new type will appear.  Change its name to ratingType by typing a new name and hitting <Enter> to accept the new name.
	__13.  Double click on the newly created ratingType.
	__14.  Right click an empty area and select Show Properties and check that the basic properties of the simple type show up in the Properties view.  The 'Base type' is string which is fine for us but might be one thing that is changed for data that is better qualified as another data type.
	__15.  Click the Constraints tab on the left of the Properties view.
	__16.  Scroll to the far right of the view and click the second 'Add...' button in the 'Specific constraint values' section.
	__17.  In the dialog that appears, enter 'G,PG,PG13,R' making sure there are commas and no spaces between the values and click OK.
	__18.  Check that your constraint values listed appear as shown below.
	__19.  Go back to the main schema design page by clicking the icon in the top left corner.
	__20.  Right click inside the Types pane and select Add Complex Type.
	__21.  A new type will appear.  Change its name to movieType by typing a new name and hitting <Enter> to accept the new name.
	__22.  Double click on the newly created movieType.
	__23.  Right-click on the movieType and select Add Element.
	__24.  A new element box will appear.  Rename it to description and hit <Enter> when you have supplied the new name.
	__25.  Right click on movieType  and again select Add Element.  
	__26.  This time, name it actor
	__27.  Right click on the actor element and select Set Multiplicity | 1..* (One or more)
	__28.  Right click on movieType and select Add Attribute.  Note this is an attribute and not element.
	__29.  Name the attribute title and hit <Enter> to accept the attribute name.
	__30.  Repeat this step and add another attribute called rating
	__31.  Double click on string next to the 'rating' attribute and a drop-down box should appear. 
	__32.  Select Browse... from the drop-down box. 
	__33.  In the Name field, enter ratingType (or scroll through the list and select it) 
	__34.  Click OK.
	__35.  Go back to the main schema design page by clicking the icon in the top left corner.
	__36.  Back at the main schema page, the movieType and ratingType should be shown.
	__37.  Right click in the Elements pane (on the left) and select Add Element.
	__38.  Name it database
	__39.  Right click on database and select Set Type | New...
	__40.  Check Create as local anonymous type.   This will grey out the Name field. 
	__41.  Click OK.
	__42.  Double click on database.
	__43.  Right click on (databaseType) and select Add Element.
	__44.  A new element will be created.  Name the element movie and hit <Enter> to accept the new name.
	__45.  We know there are multiple movies, so we should set the multiplicity.  Right click on movie and select Set Multiplicity | 1..* (One or more).  You may need to click somewhere blank once the multiplicity is set to show the [1..*] syntax.
	__46.  Double click on string next to movie and a drop-down box should appear. 
	__47.  Select Browse... from the drop-down box. 
	__48.  In the Name field, enter movieType (or scroll through the list and select it) 
	__49.  Click OK.
	__50.  Hit Ctrl-S to save changes.

	Part 4 -  Examine the Schema
	__1.  Click the Source tab at the bottom of the schema editor. The raw source code forming the schema will be displayed.  It should look like the following:
	__2.  Go through it and mentally understand what is being described here.
	__3.  Close the schema editor. 

	Part 5 -  Review

	Lab 4 -  JAXB Programming
	Part 1 -  Add JAXB Implementation to Project Classpath
	__1.  In Eclipse select Window → Preferences.
	__2.  In the list of preferences select Java → Build Path → User Libraries.
	__3.  Press the New button.
	__4.  Fill in a library name of JAXB and click the OK button.
	__5.  With the newly create JAXB library still selected press the Add External JARs button.
	__6.  Browse to the 'C:\LabFiles\JAXB-lib' directory, select all the JAR files by holding the CTRL key while selecting them, then click the Open button to complete the selection.
	__7.  Make sure that all 6 of the JAR files are listed as part of the library.
	__8.  Click the OK button to close the Eclipse preferences.
	__9.  Back in Eclipse right click the XMLProject project and select Build Path → Configure Build Path...
	__10.  In the build path settings select the Libraries tab and click the Add Library... button.
	__11.  Select User Library and click the Next button.
	__12.  Check the box next to the JAXB library you defined and click the Finish button.
	__13.  Click the OK button to close the project properties.
	__14.  Check that the JAXB library is associated with the project.

	Part 2 -  Generating the Bindings
	__1.  Right click the movie.xsd file in the XMLProject → xml folder and select Generate → JAXB Classes.
	__2.  Make sure the 'XMLProject' is selected as the destination project and click the Next button.
	__3.  Change the Target Package to 'com.jaxb.movie' as shown below and click the Finish button.  It will take a few seconds to generate the classes.
	__4.  Confirm the warning about overwriting existing files by clicking the Yes button.
	__5.  Expand the src folder of project XMLProject. 
	__6.  A newly created package com.jaxb.movie should appear.  Expand it and you should see the generated binding classes.

	Part 3 -  Use the Binding Classes To Read XML
	__1.  In the XMLProject project, create a new package called com.mycom.test (right click the project and select New → Package, fill in the name and click Finish)
	__2.  In the com.mycom.test package, create a new class called JAXBMoviePrinter and check the option to create a 'main' method then click the Finish button.
	__3.  In the main method, we first need to setup the unmarshaler. Add the following code to the main method. 
	__4.  There are some errors in the code.  To fix a few of them, perform an Organize imports (Ctrl + Shift + O).  After you do this, you will still see some errors, but ignore them for now.  
	__5.  Recall that in our schema, that “top-most” element was database.  If you look at the generated binding classes, you will notice that a Database class was created.  We can use the unmarshaler to create an instance of this object.  Add the following code in bold:
	__6.  Fix this by performing an Organize Imports – which is done by typing Ctrl-Shift-O. There will still be some errors.  Do not worry about them for now. 
	__7.  Remember that a <database> element contained several <movie> elements. Similarly, the database object will have a field that represents a list of MovieType objects.  We can get this list.  Add the following code in bold:
	__8.  We now have a hold of the list of movies that the database was keeping track of.  We can iterate through it, and operate on it!  Let us simply go through the list and print the title of each movie.  Add the following code in bold:
	__9.  Organize imports again, by hitting Ctrl-Shift-O. Select java.util.List when prompted.
	__10.  Select all of the code in the main method (but not the method declaration). 
	__11.  Right click on it and select Surround With → Try/catch block.
	__12.  Save the code.

	Part 4 -  Test JAXB
	__1.  Right click on the code and select Run As → Java Application.
	__2.  Close all open editors.

	Part 5 -  Review

	Lab 5 -  Create A Bottom Up Web Service
	Part 1 -  Create the Project
	__1.  From the Eclipse menu, select File → New → Project...
	__2.  Expand Java EE and select Enterprise Application Project.
	__3.  Click Next.
	__4.  Enter WebServiceProjectEAR as the project's name.
	__5.  Click Finish.
	__6.  From the menu, select File → New → Project...
	__7.  Expand Web and select Dynamic Web Project.
	__8.  Click Next.
	The New Dynamic Web Project window will appear.  
	__9.  For the Project name, enter WebServiceProject
	__10.  At the bottom of the window, check Add project to an EAR.  Make sure the EAR Project Name dropdown shows WebServiceProjectEAR.  Do not click the Finish button yet.
	__11.  Next to the 'Configuration' setting, press the Modify button.
	__12.  Find and check the 'JBoss Web Services Core' project facet.  Make sure the version is 3.0.
	__13.  Click the OK button to accept the new configuration.
	__14.  Once your main project settings match those shown below click the Next button.
	__15.  Accept the default Java settings and click the Next button again.
	__16.  On the web module settings, check the box for 'Generate web.xml deployment descriptor' and click the Next button.
	__17.  On the 'JBossWS Facet 3.0' settings chose the option for 'Server Supplied JBossWS Runtime'.
	__18.  Click Finish to create the project.

	Part 2 -  Create the Implementation Class
	__1.  Right click on WebServiceProject and select New → Class.
	__2.  Set the Package to be com.simple, the Name to Greeter and make sure the option to create a 'main' method is unchecked.
	__3.  Click Finish when your dialog appears as shown below.
	__4.  An editor will open on the newly created source file.  Add the following method to the class:
	__5.  Save the code.  There should be no errors.

	Part 3 -  Annotate the Class
	__1.  We should first mark the class as being a web service.  To do this, add the following annotation in bold to the class, right before the class definition.  You will have errors that can be ignored for now.
	__2.  Annotate the sayHello method as follows in bold:
	__3.  There will be two errors on the code, complaining about the annotations.  Fix that now by performing an Organize Imports. (Ctrl-Shift-O).
	__4.  Save the code.  There should be no errors.

	Part 4 -  Generate the Web Service
	__1.  Expand WebServiceProject → WebContent → WEB-INF.
	__2.  Open web.xml.
	__3.  Click the Source tab at the bottom of the editor.
	__4.  Add the following code in bold:
	__5.  Save and close the file.

	Part 5 -  Deploy the Application
	We can deploy the project from inside Eclipse. 
	__1.  Open the Servers view. 
	__2.  Start the server if it is stopped.  Wait for it to start completely.
	__3.  Right click on the server and select Add and Remove...
	The Add and Remove projects window will appear. 
	__4.  In the left pane, select WebServiceProjectEAR and click Add.
	__5.  Click Finish.
	__6.  Open a web browser to the following address which should bring up a security prompt.
	__7.  In the security prompt, enter a username of 'admin' and a password of 'jbo$$ee6'.  You can check the option to remember the password if offered. Click OK if the user name and password is pre-filled.
	__8.  Check that you see the overview page of the administration console.  If it doesn't display try refreshing the page.
	__9.  On the left side of the console, click the link for 'Deployments → Webservices' which should be expanded and visible.
	__10.  Make sure that the GreeterService Web service is registered.  You might need to click it in the table to see the details.
	__11.  Close the browser for the admin console.

	Part 6 -  Test the Web Service
	__1.  In Eclipse, open the WSE by going to the menu and selecting Run → Launch the Web Services Explorer.
	__2.  Switch to WSDL mode by clicking the WSDL Page button (second button from the right in the top right corner of the WSE).  You may also want to maximize the screen by clicking the tab for the Web Services Explorer.
	__3.  Click WSDL Main.
	__4.  In the right pane, for the URL, enter:
	__5.  Click Go.
	The WSE connects and reads the WSDL file, figuring out what operations are available.
	
	__6.  It notices the sayHello operation.  Click on it.
	The WSE realizes that the sayHello service expects an argument – however, it does not appear to have rendered a field for us to enter an argument. 
	Why is this happening?  This is because the WSDL file that was automatically generated did not specify that a parameter must be there.
	__7.  For now, however, we can still test our service.  Click the Add link, and a field will appear.
	
	__8.  Enter a name into the field.
	
	__9.  Click Go.
	
	Our web service has been invoked successfully!

	Part 7 -  Change the Implementation
	__1.  Let us examine some of the conventions that the generated service is using.  In the WSE, examine the test page.
	Notice that the name of the parameter is arg0.  What exactly is the impact of this?  To see, we have to look at the underlying SOAP messages.  
	To be precise, we want to take a look at the SOAP request message that the WSE generated and was submitted to the service for processing.  
	__2.  Click Go.
	__3.  In the lower Status pane of the WSE, click the Source link.  
	__4.  Expand the Status pane by double clicking on its title bar. 
	Examine the SOAP Request Envelope.  This is the top pane.  We want to note two things here:
	First of all, notice that the default q0 namespace prefix is for the namespace http://simple.com.  This was derived from the package name of the implementation class.  This works, but sometimes simply using the package name as the name space is not desirable. 
	Secondly, We see that the main body of the SOAP message contains the element <q0:sayHello> which is the name of the operation.  That is fine; what is not ideal, however, is the fact that the argument is simply called arg0.  While there is technically nothing wrong with this, it does make the SOAP a little more abstract;  arg0 is not a very meaningful name to any human reading the SOAP message.  
	The question is now this: how did these two conventions (the default namespace and the argument name) receive these default values?  An even better question is this: how do we control these default values?  The answer is simple; via annotations. 
	We can annotate the implementation class and specify what we want the namespace and the argument names to be.  
	Let us fix these now.  
	__5.  Return the Status pane to its normal size by double clicking on it again. 
	__6.  Open Greeter.java again (under com.simple package). 
	__7.  Update the @WebService annotation of the class to look like the following:
	Here, we update the @WebService annotation to specify what we want the target namespace to be; in this case we will use www.example.org 
	__8.  Now, let us fix the arg0 problem.  Add the following annotation to the parameter of the sayHello method, as follows in bold.  Note that the syntax is a bit tricky since the annotation is inside the method parameter list.
	We are annotating the parameter to have a more meaningful name. 
	__9.  Organize imports (CTRL+Shift+O).  There should be no errors. 
	__10.  Save the file.
	We have updated our implementation class by changing (and adding) annotations. 
	__11.  Return to the Servers view and publish the server by right clicking the server and selecting Publish.  

	Part 8 -  Examine the Updated Service
	We should now see if the annotations worked. 
	__1.  Go back to the WSE.  You should still be in WSDL mode.  
	__2.   In the Navigator pane, clear the existing WSDL connection by clicking the Clear button. (the little eraser icon in the top right of the Navigator pane)
	__3.  In the right pane, the old URL should still be displayed:
	__4.  Click Go.
	__5.  The operation is located.  Click sayHello.
	__6.  Click Add, enter a name and click Go.
	__7.  Click the Source link in the Status pane, and then maximize the Status pane.
	__8.  Notice that the default namespace has been updated to www.example.org
	__9.  Restore the Status pane to normal size and in the Navigator pane, clear the existing WSDL connection by clicking the Clear button. (the little eraser icon in the top right of the Navigator pane).
	__10.  Close all open editors, stop the server and close any web browser.

	Part 9 -  Review

	Lab 6 -  Creating A Web Service With Eclipse Tools
	Part 1 -  Create the Implementation Class
	__1.  Using the Project Explorer view create a class in the WebServiceProject called Adder  belonging to the com.simple package.  
	__2.  Add the following method to the class:
	__3.  Add the following web service annotations to the class.
	__4.  There may be two errors on the code, complaining about the annotations.  Fix that now by performing an Organize Imports. (Ctrl-Shift-O).
	__5.  Save the class. There should be no errors.
	__6.  Close Adder.java

	Part 2 -  Generate the Web Service
	__1.  From the Eclipse menus select Window → Preferences.
	__2.  Expand Web Services and select the Server and Runtime preferences.
	__3.  Change the 'Server runtime' to JBoss AS 7.1 and the 'Web service runtime' to JBossWS.
	__4.  Click the OK button to close the Eclipse preferences.
	__5.  In the Project Explorer, right-click on Adder.java and select Web Services → Create Web Service.
	__6.  Drag the top slider down to Assemble service.  We will want to take a peek at what Eclipse generates before it is deployed.  Also check that the 'Server runtime' and 'Web service runtime' are both set to JBoss. Also make sure that Service project is set to WebServiceProject.
	__7.  Click the Next button.
	__8.  Select the option to 'Generate WSDL file'.  The option of updating the web.xml should already be selected and you can leave it selected.
	__9.  Click Finish.  Eclipse will begin code generation. 
	__10.  Examine the com.simple.jaxws package in the Project Explorer.  Notice there are new classes here called Add and AddResponse.  These are JAXB annotated classes generated by the tool.
	__11.  Look in the WebServiceProject/wsdl folder.  There is a WSDL file and schema that were generated for the service.

	Part 3 -  Test the Service
	__1.  Return to the Servers view and publish the server by right clicking the server and selecting Publish.
	__2.  Start the server if it is not already running.  Wait for it to start completely.
	__3.  Open a web browser to the following address which should bring up a security prompt.
	__4.  In the security prompt, enter a username of 'admin' and a password of 'jbo$$ee6'.  You can check the option to remember the password if offered or click OK if the credentials are already pre-filled
	__5.  Check that you see the overview page of the administration console.  If it doesn't display try refreshing the page.
	__6.  On the left side of the console, click the link for 'Deployments → Webservices' which should be expanded and visible.
	__7.  Make sure that the AdderService Web service is registered.  You might need to click it in the table to see the details.
	__8.  Close the browser for the admin console.
	__9.  Right-click on the AdderService.wsdl file in the WebServiceProject/wsdl folder and select Web Services  → Test with Web Services Explorer.
	__10.  Maximize the Web Services Explorer by clicking the Maximize button in the upper right.
	__11.  In the main area of the tool notice that the value in the 'Endpoints' section is not correct for the service.  This is because the WSDL file generated by Eclipse is not aware of how the web service is deployed.
	__12.  Click the 'Add' link in the endpoint section and fill in the following value for the endpoint.
	__13.  Click the Go button below the endpoints to save the new endpoint.
	__14.  Click the add link under Operations.  
	__15.  Make sure the new endpoint you added is selected in the endpoint drop-down list.
	__16.  Enter two numbers and click Go.
	__17.  Make sure the correct result comes back.
	__18.  Restore the Web Services Explorer to normal size and in the Navigator pane, clear the existing WSDL connection by clicking the Clear button. (the little eraser icon in the top right of the Navigator pane).
	__19.  Close all open editors, stop the server and close the web browser.

	Part 4 -  Review

	Lab 7 -  Creating a WSDL File
	Part 1 -  Create A WSDL File
	__1.  In the Project Explorer view, expand the XMLProject → xml folder.
	__2.  Copy the movie.xsd file.
	__3.  Paste the movie.xsd file into the wsdl folder of the WebServiceProject project.
	__4.  Right click on the WebServiceProject /wsdl folder and select New → Other...
	__5.  In the New window that appears, expand Web Services and select  WSDL File.
	__6.  Click Next.
	__7.  Set the File name to be MovieService.wsdl and check the folder is the 'WebServiceProject/wsdl' folder.
	__8.  Click Next.
	__9.  Set the Target namespace to be http://www.mycom.com/movie
	__10.  Set the Prefix to be m
	__11.  Click Finish.
	__12.  Take a moment to examine the source code of the underlying WSDL file.  It may seem a little daunting, but we will examine in a little more detail later on.
	__13.  Click the Design tab at the bottom of the editor.  This shows a graphical representation of the WSDL file and is much easier to deal with.  
	__14.  First of all, let us rename the port to something a little more proper.  In the port box (the box on the left), click the title area where MovieServiceSOAP is displayed. Double click the text MovieServiceSOAP and rename it to MovieServiceSOAPPort.  Hit <Enter> to accept the new name.
	__15.  Let us rename the service first.  In the operation box (the box on the right) double click NewOperation and rename it to addMovie hitting <Enter> to accept the new name. 
	__16.  Double click on parameters next to input and rename it to movieToAdd hitting <Enter> to accept the new name. 
	__17.  Double click on parameters next to output and rename it to opStatus hitting <Enter> to accept the new name. 
	__18.  Double click on the right-facing arrow on the far right of the input row.
	__19.  Click the Design tab at the bottom of the editor.  The view will change to show a diagram.
	__20.  Click on the icon in the top left of the editor.
	__21.  In the Directives box, right-click and select Add Include.
	__22.  Leave the default option of Workbench projects and click the Next button.
	__23.  Expand WebServiceProject → wsdl and select the movie.xsd file.
	__24.  Click the Finish button to create the link to the file.
	__25.  You should see some definitions that are grayed out.  These are the definitions included with the schema file.
	__26.  In the Elements area, double click on addMovie.
	__27.  In the box on the right, rename in to movie
	__28.  We now need to set the type.  Double-click on string and expand the dropdown that appears.
	__29.  In the list, click on Browse...
	__30.  In the list, locate movieType and double-click on it.
	__31.  Go back to the main schema view by clicking on the icon in the top left of the editor.
	__32.  In the Elements box, double-click on addMovieResponse. 
	__33.  Rename the out to status
	__34.  We are done!  Save changes by hitting Ctrl-S.
	__35.  Close the Inline Schema of MovieService.wsdl view.  (Leave the other editor, showing MovieService.wsdl open)

	Part 2 -  Examine the Generated WSDL Source
	__1.  Click the Source tab at the bottom of the WSDL editor.
	__2.  The indentation may be a little off; right click anywhere on the source and select Source | Format (Ctrl+Shift+F).
	__3.  Save all the files by selecting from the menu, File > Save All.
	__4.  Close the WSDL editor. 

	Part 3 -  Review

	Lab 8 -  Creating A Top-Down Web Service
	Part 1 -  Generate the Implementation Classes
	__1.  In the Project Explorer, expand WebServiceProject → wsdl. 
	__2.  Right-click on MovieService.wsdl and select Web Services → Generate Java bean skeleton.
	__3.  Drag the top slider down to Assemble service.  Also check that the 'Server runtime' and 'Web service runtime' options are the JBoss choices.  Click the Next button when your choices match those below.
	__4.  On the next page use the drop-down next to 'JAX-WS specification' to choose 2.2 which is the version used by the JBoss server.
	__5.  Click Finish to generate the web service code.

	Part 2 -  Examine the Generated Artifacts
	__1.  Expand WebServiceProject → Java Resources → src → com.mycom.movie and  com.mycom.movie.impl
	__2.  Open MovieService.java
	__3.  Next, open MovieType.java
	__4.  Finally, look at the AddMovie.java and AddMovieResponse.java. They represent the input and output data for the addMovie operation. They are wrapper types only. They are created to conform to the document literal wrapped style of SOAP. As a result, the actual addMovie() method in the MovieService interface does not use them and uses the inner types only (such as MovieType).

	Part 3 -  Create the Implementation Class
	__1.  Open MovieServiceImpl.java in the com.mycom.movie.impl package
	__2.  Set the code for addMovie method as shown in boldface below:
	__3.  Organize imports and select java.util.List when prompted.
	__4.  Save the code.  There should be no errors.
	__5.  In the Project Explorer, expand WebServiceProject → JAX-WS Web Services → Web Services.

	Part 4 -  Test the Service
	__1.  Close all open editor windows.
	__2.  Make sure the server is stopped.
	__3.  Right click the server and select Publish. 
	__4.  Start the server and wait for it to start completely.
	__5.  Open a web browser to the following address which should bring up a security prompt.
	__6.  In the security prompt, enter a username of 'admin' and a password of 'jbo$$ee6'.  You can check the option to remember the password if offered or Click OK if already pre-filled.
	__7.  Check that you see the overview page of the administration console.  If it doesn't display try refreshing the page.
	__8.  On the left side of the console, click the link for 'Deployments → Webservices' which should be expanded and visible.
	__9.  Make sure that the MovieService Web service is registered.  You might need to click it in the table to see the details.
	__10.  Select the entire WSDL URL and copy it.  You might want to hit the 'F11' key to temporarily switch the browser to full screen if you have trouble seeing the entire URL.
	__11.  Close the browser for the admin console.
	__12.  Back in Eclipse, launch the WSE.  To do this, use the menu and select Run → Launch the Web Services Explorer.
	__13.  Maximize the Web Services Explorer by clicking the Maximize button in the upper right.
	__14.  Click the second button from the right to switch the WSE to WSDL mode.
	__15.  Click WSDL Main in the Navigator pane.
	__16.  Paste the URL you copied earlier, which was:
	http://localhost:8080/WebServiceProject/MovieService?wsdl
	__17.  Click Go.
	__18.  Click the addMovie link.
	__19.  Enter some sample data.  (To add multiple actors, click the Add button next to actor).
	__20.  Click Go.  The service will be invoked.
	__21.  Restore the Web Services Explorer to normal size if you maximized it.
	__22.  Switch to the Console view.
	__23.  Try adding a few more movies and make sure everything works. 
	__24.  In the Navigator pane of the Web Services Explorer, clear the existing WSDL connection by clicking the Clear button. (the little eraser icon in the top right of the Navigator pane).
	__25.  Close all open files and web browsers.
	__26.  Stop the server.

	Part 5 -  Review

	Lab 9 -  Developing A Web Service Client
	Part 1 -  Create Projects
	__1.  From the menu, select File → New → Project...
	__2.  Expand Java EE and select Enterprise Application Project.
	__3.  Click Next.
	__4.  Enter MovieClientEAR as the project's name.
	__5.  Click Finish.
	__6.  From the menu, select File → New → Project...
	__7.  Expand Web and select Dynamic Web Project.
	__8.  Click Next.
	The New Dynamic Web Project window will appear.  
	__9.  For the Project name, enter MovieClientWeb
	__10.  At the bottom of the window, check Add project to an EAR.  Make sure the EAR Project Name drop down shows MovieClientEAR.  Do not click the Finish button yet.
	__11.  Next to the 'Configuration' setting, press the Modify button.
	__12.  Find and check the 'JBoss Web Services Core' project facet.  Make sure the version is 3.0.
	__13.  Click the OK button to accept the new configuration.
	__14.  Once your main project settings match those shown below click the Next button.
	__15.  Accept the default Java settings and click the Next button again.
	__16.  On the web module settings, make sure the box for 'Generate web.xml deployment descriptor' is unchecked and click the Next button.
	__17.  On the 'JBossWS Facet 3.0' settings chose the option for 'Server Supplied JBossWS Runtime'.
	__18.  Click Finish to create the project.
	__19.  From the menu, select File → New → Project...
	__20.  Select Java Project and click Next.
	__21.  Change the Project name to MovieClientJava and click the Finish button.  Do not switch over to the Java perspective if asked. 

	Part 2 -  Generate the Client Stub
	__1.  Start the JBoss server in the Servers view.  The 'WebServiceProjectEAR' application should still be deployed to the server so this will make the service WSDL available. Wait for the server to start completely.
	__2.  Open a web browser to the following address which should bring up a security prompt.
	__3.  In the security prompt, enter a username of 'admin' and a password of 'jbo$$ee6'.  You can check the option to remember the password if offered or click OK if credentials are already pre-filled.
	__4.  Check that you see the overview page of the administration console.  If it doesn't display try refreshing the page.
	__5.  On the left side of the console, click the link for 'Deployments → Webservices' which should be expanded and visible.
	__6.  Make sure that the MovieService Web service is registered.  You might need to click it in the table to see the details.
	__7.  Select the entire WSDL URL and copy it.  You might want to hit the 'F11' key to temporarily switch the browser to full screen if you have trouble seeing the entire URL.
	__8.  Close the browser for the admin console.
	__9.  Back in Eclipse, right click the MovieClientWeb project and select New → Other..
	__10.  Select Web Services → Web Service Client and click the Next button.
	__11.  In the box for 'Service definition' paste the link to the WSDL location.
	__12.  On the left, drag the slider down to Assemble Client.  
	__13.  Also check that the setting for 'Client project' is set to MovieClientWeb, which it should be since you right clicked the project to run the wizard.  Finally check that the two runtime options are set to JBoss.
	__14.  Click Next once your settings match that shown above.  
	__15.  Enter 'com.movie' for the Package name and switch the 'JAX-WS specification' version to 2.2.
	__16.  Click the Finish button.  The stub will be generated.  
	__17.  Expand the MovieClientWeb → Java Resources → src folders.  Notice a new package com.movie has been created.  This package contains our client stub classes! Expand it.
	__18.  Open the MovieService_Service.java file. This is the client side proxy class.
	__19.  Close all open files.
	__20.  Expand the  MovieClientWeb → Java Resources → src folders so you can see the 'com.movie' package.
	__21.  Right click the 'com.movie' package and select Copy.
	__22.  Expand the MovieClientJava project so you can see the 'src' folder.
	__23.  Right click the 'src' folder and select Paste.
	__24.  Check that you have the generated client code in the MovieClientJava project.

	Part 3 -  Create Standalone Java Client
	__1.  In the MovieClientJava project, create a new Java class called StandaloneMovieClient having  com.movie.client as package with a main method.
	__2.  We should first create an instance of a movie and populate it with some data.  Add the following code to the main method.
	__3.  Organize imports (CTRL+Shift+O), to import the MovieType and RatingType classes. There should be no errors.
	__4.  Add the following code to the main method, after the movieType code:
	__5.  Organize imports.  There should be no errors. 
	__6.  We can now go ahead and invoke the service.  Add the following code in bold at the end of the main method.
	__7.  Save the code.  We have completed coding our client.

	Part 4 -  Run the Client
	__1.  In Eclipse, select the MovieClientJava → src → com.movie.client → StandaloneMovieClient class.
	__2.  Right click StandaloneMovieClient and select Run As → Java Application.
	__3.  After a few seconds, your Console view should be showing the output from the client class.  This will be a single line indicating the movie was added.  
	__4.  Over on the right of the Console view, find the button with a drop down arrow next to it that is labeled 'Display Selected Console'.
	__5.  Use the drop down arrow next to the button to select the output from the 'JBoss 7.1 Runtime Server'.  You might also be able to simply click the button directly and swap the output.
	__6.  Check that you see the output from the server that indicates the movie was received by the service and prints out various details.  This proves the service was invoked on the server.
	__7.  If you want to run the client again you can select Run → Run History → StandaloneMovieClient.

	Part 5 -  Adding A Web Layer
	__1.  Close all open editor windows. (Ctrl-Shift-W)
	__2.  Navigate to C:\LabFiles and locate file index.jsp.  Copy it into the WebContent folder of the MovieClientWeb project.
	__3.  Open up and take look at this index.jsp in the editor.  It is a very simple form that posts to a servlet called AddMovieServlet. It is the servlet that will take the data input from the form, and invoke the service with it. We will code this servlet in a moment. 
	__4.  Close the file.
	__5.  Right click MovieClientWeb and select New > Other.
	__6.  Select Web → Servlet and click Next.
	__7.  Enter com.movie.servlet package and AddMovieServlet as name.
	__8.  Click Finish.
	__9.  In the servlet code, locate the doPost method.  Here, we will now add the code to get the data submitted from the form and create a new movie based on that data.
	__10.  Delete the comment inside the doPost method.
	__11.  Add the following code in the doPost method.
	__12.  Organize imports.
	__13.  Now that we have a populated movie, we can make a call to the service!  Add the following code in bold to the doPost method:
	__14.  Organize imports.
	__15.  Finally, add the following code in bold to the doPost method:
	__16.  We are done!  Save the code.  There should be no errors. 

	Part 6 -  Deploy and Test
	__1.  Right click on the JBoss server in the Servers view and select Add and Remove...
	__2.  Select MovieClientEAR  and select Add.
	__3.  Click Finish and wait for the project to be published to the server.
	__4.  Right-click on index.jsp under WebContent in the MovieClientWeb project and select Run As → Run On Server.
	__5.  In the 'Run On Server' dialog, select the option “Always use the server when running this project”, click Finish.
	__6.  Enter some sample data.
	__7.  Click Add Movie.
	__8.  Check the server console to make sure the appropriate print statements are generated.
	__9.  Try submitting the form a few more times.
	__10.  Close all open editor windows and web browsers.
	__11.  Stop the server.

	Part 7 -  Review

	Lab 10 -  Controlling JAXB Mappings
	Part 1 -  Update the Implementation
	__1.  In the WebServiceProject, create a new Java class called Person belonging to package com.beans.  Make sure it does not have a 'main' method
	__2.  Add the following two fields to the class.
	__3.  Organize imports (CTRL-SHIFT-O) and pick java.util.Date when prompted.
	__4.  Save the class.
	__5.  In the Outline view (to the right), select both fields.
	__6.  Right click on these selected fields and select Source → Generate Getters and Setters...
	__7.  Click the OK button.  
	__8.  Save the file.  
	__9.  Close it. 
	__10.  We have created our Java bean.  Now, let us create an operation that uses it. Open Greeter.java (in the com.simple package, in the WebServiceProject)
	__11.  Add the following method to the class, making sure it is outside other method definitions but within the brackets for the class:
	__12.  Organize imports (CTRL-SHIFT-O) and pick java.util.Date when prompted.
	__13.  Now, add the following method:
	__14.  Save changes.  There should be no errors.

	Part 2 -  Test the Web service
	__1.  In the Servers view, start the JBoss server.  If the server was already running right click the server and select Publish.  Wait for the server to start completely and publish the new version of the application.
	__2.  In Eclipse, open the WSE by going to the menu and selecting Run → Launch the Web Services Explorer.  You might want to maximize the tool window.
	__3.  Switch to WSDL mode by clicking the WSDL Page button (second button from the right in the top right corner of the WSE).  You may also want to maximize the screen by clicking the tab for the Web Services Explorer.
	__4.  Click WSDL Main.
	__5.  In the right pane, for the URL, enter:
	__6.  Click Go.
	__7.  Click the createPerson link.
	__8.  Click the Add link and then enter a name.  
	__9.  Click Go.
	__10.  Click the Source link and then maximize the pane.
	__11.  Click the Form link the Status pane to show the original return message. 
	__12.  Restore the Status pane to the normal size.
	__13.  Display the getPersonName method.  (This can be done by clicking the getPersonName in the left pane).
	__14.  Click the Add button, next to arg0.  What happens?
	__15.  Click Add for each  field and follow the steps below.
	__16.  Click the Browse link to the right of the creationDate.
	__17.  In the popup that appears, click a date.
	__18.  Enter a name and make sure both fields have some data.
	__19.  Click Go.
	__20.  Maximize the Status pane and examine the Source. Look at the SOAP Request Envelope.
	__21.  Click the Form link in the Status pane to show the original return message. 
	__22.  Restore the Status pane to its normal size in the WSE.  
	__23.  Return to the values submitted for the 'getPersonName' method and remove the time from the 'creationDate' parameter so it is just the date in YYYY-MM-DD format.
	__24.  Make sure there is still a name filled in and click the Go button to submit another request.
	__25.  In the Status pane, notice there is an error.  This is because the default XML schema type for a 'Date' property in Java is the 'dateTime' XML schema type which is incorrect without a time.
	__26.  Close the WSE.  

	Part 3 -  Change the JAXB Mappings
	__1.   Open Person.java in the com.beans package.
	__2.  Add the following annotation in bold to the class.  You will have errors until future steps.
	__3.  Now, annotate the two fields as follows in bold:
	__4.  Organize imports (Ctrl-Shift-O). When prompted, select javax.xml.bind.annotation.XmlElement and click Finish.
	__5.  Save the class. There should be no errors.  
	__6.  Close Person.java

	Part 4 -  Fix the Greeter Service Mappings
	__1.  Open Greeter.java
	__2.  Locate the createPerson method, and add the following bold annotation.  You will have errors for a few steps.
	__3.  Locate the getPersonName method, and add the following bold annotation.  Make sure to add the annotation inside the parenthesis for the method but before the type of the parameter.  You will have errors for a few steps.
	__4.  Organize imports.
	__5.  Save changes.  There should be no errors.

	Part 5 -  Test JAXB Binding Changes
	__1.  Return to the Servers view where your JBoss server should still be running and publish the server by right clicking the server and selecting Publish.  
	__2.  Run the WSE (Run → Launch Web Services Explorer).  
	__3.  Switch to the WSDL mode.  
	__4.  If the Navigator pane is not empty then click the Clear button.  We need to use the new WSDL and not the old one.
	__5.  Click WSDL Main.  
	__6.  In the right pane, enter the URL:
	http://localhost:8080/WebServiceProject/GreeterService?wsdl
	__7.  Click Go.
	__8.  Click the createPerson link.
	__9.  Click Add. 
	__10.  Enter a name and click Go.
	__11.  Examine the response.  Note that the names person_name and creation_date are being used, as expected. 
	__12.  Examine the source for the response.  (Click the Source link and maximize the pane)
	__13.  Restore the Status pane to the normal size.
	__14.  Display the getPersonName method.  (This can be done by clicking the getPersonName in the left pane).
	__15.  Click the Add button, next to queryPerson.  
	__16.  Click Add for both these fields and enter some sample data for both fields.  Make sure to use the YYYY-MM-DD format for the date but you do not need time.
	__17.  Click Go.
	__18.  Maximize the Status pane and examine the Source. Look at the SOAP Request Envelope.
	__19.  Close all open editor windows.
	__20.  Stop the server

	Part 6 -  Review

	Lab 11 -  Monitoring SOAP Messages
	Part 1 -  Activate the Monitor 
	__1.  Start the JBoss server in the Servers view.
	__2.  In Eclipse select Window → Show View → Other
	__3.  Expand the Debug group of views, select TCP/IP Monitor and click the OK button.  The view should open in the bottom section.
	__4.  Right click in the blank area above the section for the request and response and select Properties.
	__5.  In the preferences that appear click the Add button.
	__6.  In the dialog that appears configure the following properties:
	__7.  When your settings match those above click the OK button.  The new monitor should be configured and started automatically.
	__8.  Click the OK button again to close the preferences.

	Part 2 -  Use Port 8081 from the Client
	__1.  Open a browser and browse to:
	__2.  Scroll to the bottom of the WSDL file and locate the <soap:address> tag
	http://localhost:8080/WebServiceProject/MovieService
	__3.  Open the client class AddMovieServlet.java. It is in the MovieClientWeb project and com.movie.servlet package.
	__4.  Add these lines shown in bold face in the doPost method:
	__5.  Organize imports and select java.util.Map if prompted.
	__6.  Save and close the file. 

	Part 3 -  Test
	Let us now invoke the service.  If all goes well, any traffic the web service encounters will be displayed in the TCP/IP monitor. 
	__1.  In the Servers view, right click the JBoss 7.1 server and select Publish.  
	__2.  Browse to our application:
	http://localhost:8080/MovieClientWeb/index.jsp
	__3.  Fill in some sample data and add a movie.
	__4.  When the movie is added, go back to Eclipse.
	__5.   Click the tab of the TCP/IP Monitor view.
	__6.  Double click on the title tab for this view to maximize it.
	__7.  In both of these panes, change the byte drop-down to say XML.
	__8.  Examine the request message.
	__9.  Now, look at the response message.
	__10.  Double click again on the title tab for the TCP/IP Monitor view to restore it.

	Part 4 -  WS-I Validation
	__1.  In the top right hand corner of TCP/IP Monitor, click the Validate WS-I Message Log File toolbar button.
	The system will prompt you to enter a location of the log file. All the request and response messages captured so far will be logged in that log file. This will come handy if the tool finds problems with the WS-I compatibility.
	__2.  Choose the client web project as shown below. 
	__3.  Click Finish.
	__4.  The tool will create the log file and validate it right away. Click OK to close the message dialog.
	__5.  Click the Clear button in the TCP/IP Monitor view to clear the messages.
	__6.  Stop the server and close any open editors or web browsers.

	Part 5 -  Review

	Lab 12 -  Develop EJB Based Service
	Part 1 -  Create the EJB Service Project
	__1.  From the menu, select File → New → EJBProject.
	__2.  Set the Project name to EJBService
	__3.  Make sure the project is NOT added to an EAR.
	__4.  Once you options match those below click the Finish button.

	Part 2 -  Create the EJB
	__1.  In the Project Explorer, right click on EJBService and select New → Package.
	__2.  Enter com.webage.beans for the new package name and click the Finish button.
	__3.  Right click the new com.webage.beans package and select New → Class.
	__4.  Enter a class name of Soup and click the Finish button.
	__5.  In the editor that opens add the following two fields.
	__6.  From the Eclipse menus select Source → Generate Getters and Setters.
	__7.  In the dialog click the Select All button and click the OK button to generate the code.
	__8.  Save and close the Soup class.
	__9.  In the Project Explorer, right click on EJBService and select New → Session Bean.
	__10.  Set the Java package to com.webage.ejb and set the Class name to OrderSoup
	__11.  In the section Create Business Interface, uncheck No-interface View and check Remote.
	__12.  Once you settings match those below click Finish.
	__13.  Open the OrderSoupRemote.java file in the com.webage.ejb package.
	__14.  Add the following method to the interface:
	__15.  Organize imports (Source → Organize Imports).
	__16.  Save the interface and make sure there are no errors in the interface although you will have errors in other classes.
	__17.  Close the OrderSoupRemote.java file.
	__18.  Return to the OrderSoup.java file.
	__19.  From the menus select Source → Override/Implement Methods.
	__20.  The unimplemented method should already be checked so click the OK button to add a method stub.
	__21.  Modify the code of the 'orderSoup' method to match that shown below:
	__22.  Save the class.  There should be no errors. 

	Part 3 -  Create the Web Service
	__1.  Open OrderSoupRemote.java from the com.webage.ejb package of the  EJBService project.
	__2.  Add the annotations @WebService and @WebMethod as shown below.
	__3.  Organize imports.
	__4.  Save changes.
	__5.  Open OrderSoup.java from the EJBService project.
	__6.  Annotate the class with @WebService as follows.
	__7.  Organize imports.
	__8.  Save changes.

	Part 4 -  Test the Web Service
	__1.  Start the JBoss server.  Wait for it to start completely.
	__2.  Right click on the server and select Add and Remove...
	The Add and Remove projects window will appear. 
	__3.  In the left pane, select EJBService and click Add.
	__4.  Click Finish.
	__5.  Open a web browser to the following address which should bring up a security prompt.
	__6.  In the security prompt, enter a username of 'admin' and a password of 'jbo$$ee6'.  You can check the option to remember the password if offered or if the credientials were pre-filled, click OK.
	__7.  Check that you see the overview page of the administration console.  If it doesn't display try refreshing the page.
	__8.  On the left side of the console, click the link for 'Deployments → Webservices' which should be expanded and visible.
	__9.  Make sure that the OrderSoup Web service is registered.  You might need to click it in the table to see the details.
	__10.  Select the entire WSDL URL and copy it.  You might want to hit the 'F11' key to temporarily switch the browser to full screen if you have trouble seeing the entire URL.
	__11.  Open another browser tab or window and paste the WSDL URL into the address bar of the browser to display the WSDL.
	__12.  Notice among other things that the WSDL defines a 'soup' XML type to match the structure of the Soup class we used as the input parameter for the service method.
	__13.  Back in Eclipse, open the Web Services Explorer (Run → Launch the Web Services Explorer).
	__14.  Click the second button from the right to switch the WSE to WSDL mode.
	__15.  If there are already WSDL files listed in the Navigator pane of the Web Services Explorer, clear the existing WSDL connection by clicking the Clear button. (the little eraser icon in the top right of the Navigator pane).
	__16.  Click the WSDL Main link.
	__17.  Paste the WSDL URL you copied earlier.
	__18.  Click Go.
	__19.  Click the orderSoup operation.
	__20.  Click the Add link next to the main operation parameter.
	__21.  Click the Add link next to the 'customerName' and 'soupType' elements of the form to create empty text boxes for these parameters.
	__22.  Fill in some sample data for the input parameters.
	__23.  Click Go.
	__24.  Make sure that the response shows the appropriate response.
	__25.  In the Navigator pane of the Web Services Explorer, clear the existing WSDL connection by clicking the Clear button. (the little eraser icon in the top right of the Navigator pane).
	__26.  Close the Web Services Explorer.
	__27.  Back in the Console view you should see a message that the web service request was indeed processed by the EJB code.

	Part 5 -  Modify URL of EJB Web Service
	__1.  Stop the JBoss server.
	__2.  In Eclipse select Window → Preferences.
	__3.  In the list of preferences select Java → Build Path → User Libraries.
	__4.  Press the New button.
	__5.  Fill in a library name of JBossWS API and click the OK button.
	__6.  With the newly create JBossWS API library still selected press the Add External JARs button.
	__7.  Browse to the 'C:\Software\jboss-as-7.1.1.Final\modules\org\jboss\ws\api\main' directory, select the 'jbossws-api-1.0.0.GA' JAR file, then click the Open button to complete the selection.  If your software was extracted to a different location adjust the beginning of that path for the correct location of the JBoss 7.1 files.
	__8.  Make sure that the JAR file is listed as part of the library.
	__9.  Click the OK button to close the Eclipse preferences.
	__10.  Back in Eclipse right click the EJBService project and select Build Path → Configure Build Path...
	__11.  In the build path settings select the Libraries tab and click the Add Library... button.
	__12.  Select User Library and click the Next button.
	__13.  Check the box next to the JBossWS API library you defined and click the Finish button.
	__14.  Click the OK button to close the project properties.
	__15.  Check that the JBossWS API library is associated with the project.
	__16.  In the EJBService project, open the ejbModule/META-INF/MANIFEST.MF file.
	__17.  Remove the line with 'Class-Path' and add the following bold line to the end of the file:
	__18.  Save and close the file.
	__19.  Open OrderSoup.java from the EJBService project.
	__20.  Add the following annotation to the class definition:
	__21.  Organize imports.
	__22.  Save the file.
	__23.  Return to the Servers view and start the JBoss server.  If it were running stop it first.
	__24.  Open a web browser to the following address which should bring up a security prompt.
	__25.  In the security prompt, enter a username of 'admin' and a password of 'jbo$$ee6'.  You can check the option to remember the password if offered or if already pre-filled with credentials then click OK.
	__26.  Check that you see the overview page of the administration console.  If it doesn't display try refreshing the page.
	__27.  On the left side of the console, click the link for 'Deployments → Webservices' which should be expanded and visible.
	__28.  Make sure that the OrderSoup Web service is registered.  You might need to click it in the table to see the details.
	__29.  Notice that the deployed URL of the OrderSoup web service is now different.
	__30.  Close all open files but leave the server running.

	Part 6 -  Create A Web Client Project
	__1.  From the menu, select File → New → Enterprise Application Project.
	__2.  Enter EJBClientEAR as the project's name.
	__3.  Click Finish.
	__4.  From the menu, select File → New → Dynamic Web Project.
	__5.  For the Project name, enter EJBClientWeb
	__6.  At the bottom of the window, check Add project to an EAR.  Make sure the EAR Project Name dropdown shows EJBClientEAR.  Do not click the Finish button yet.
	__7.  Next to the 'Configuration' setting, press the Modify button.
	__8.  Find and check the 'JBoss Web Services Core' project facet.  Make sure the version is 3.0.
	__9.  Click the OK button to accept the new configuration.
	__10.  Once your main project settings match those shown below click the Next button.
	__11.  Accept the default Java settings and click the Next button again.
	__12.  Accept the default web module settings and click the Next button again.
	__13.  On the 'JBossWS Facet 3.0' settings chose the option for 'Server Supplied JBossWS Runtime'.
	__14.  Click Finish to create the project.

	Part 7 -  Code Web Client
	__1.  Right click the EJBClientWeb project and select New → Other...
	__2.  Select Web Services → Web Service Client and click the Next button.
	__3.  In the box for 'Service definition' use the following value for the WSDL location.  Notice this is the updated location of the WSDL for the EJB web service.
	__4.  On the left, drag the slider down to Assemble Client.  Also check that the setting for 'Client project' is set to EJBClientWeb, which it should be since you right clicked the project to run the wizard.  Finally check that the two runtime options are set to JBoss.
	__5.  Click Next once your settings match that shown above.  
	__6.  Enter 'com.webage.ejb.client' for the Package name and switch the 'JAX-WS specification' version to 2.2.
	__7.  Click the Finish button.  The stub will be generated.  
	__8.  Now, in the EJBClientWeb project, create a servlet called OrderServlet in the com.webage.servlet package.  You can do this by right clicking the EJBClientWeb project and selecting New → Servlet.
	__9.  Set the text of the doGet(..) method to the following:
	__10.  Organize imports.  
	__11.  Save changes. There should be no errors.
	__12.  Copy and paste file C:\LabFiles\input.html into the WebContent folder of EJBClientWeb

	Part 8 -  Deploy and Test
	__1.  Make sure the JBoss server is still running and start it if needed.
	__2.  Right click on the JBoss server in the Servers view and select Add and Remove...
	__3.  Select EJBClientEAR  and select Add.
	__4.  Click Finish and wait for the project to be published to the server.
	__5.  Right-click on input.html under WebContent in the EJBClientWeb project and select Run As → Run On Server.
	__6.  Leave all defaults in the 'Run On Server' dialog and click Finish.
	__7.  Fill in some sample input and click the Order button.
	__8.  Make sure that the response shows the appropriate response.
	__9.  Back in the Console view you should see a message that the web service request was indeed processed by the EJB code.
	__10.  Close all open files and web browsers.
	__11.  Stop the server.

	Part 9 -  Review

	Lab 13 -  Handle Web Service Faults
	Part 1 -  Create the Exception Class
	__1.  In the Project Explorer, right-click on the EJBService project and select New → Class.
	__2.  Set the Package to be com.webage.ejb
	__3.  Set the Name to be BadCustomerException
	__4.  Set the Superclass to be java.lang.Exception
	__5.  Click Finish when your options match those below.
	__6.  Add the following annotations to the class declaration:
	__7.  Add the following code in bold to the class:
	__8.  Organize imports.
	__9.  Save the file.  There should no errors.
	__10.  Close all open files. 

	Part 2 -  Modify Service Implementation Using Exception
	__1.  Open the OrderSoupRemote.java file in the com.webage.ejb package.
	__2.  Modify the method on the interface to throw the exception:
	__3.  Save the interface and make sure there are no errors in the interface although you may have errors in other classes.
	__4.  Close the OrderSoupRemote.java file.
	__5.  Open the OrderSoup.java file in the com.webage.ejb package.
	__6.  As shown in bold below, modify the method signature to throw the exception class and the method implementation to check if the 'customerName' is "Elaine" and throw the exception if it is.
	__7.  Save and close all open files.

	Part 3 -  Test Web Service Fault
	__1.  Make sure your JBoss server was stopped and stop it if it was running.
	__2.  Start the JBoss server again.
	__3.  Open a web browser to the following address which should bring up a security prompt.
	__4.  In the security prompt, enter a username of 'admin' and a password of 'jbo$$ee6'.  You can check the option to remember the password if offered or click OK if the credentials were pre-filled already,
	__5.  Check that you see the overview page of the administration console.  If it doesn't display try refreshing the page.
	__6.  On the left side of the console, click the link for 'Deployments → Webservices' which should be expanded and visible.
	__7.  Make sure that the OrderSoup Web service is registered.  You might need to click it in the table to see the details.
	__8.  Select the entire WSDL URL and copy it.  You might want to hit the 'F11' key to temporarily switch the browser to full screen if you have trouble seeing the entire URL.
	__9.  Open another browser tab or window and paste the WSDL URL into the address bar of the browser to display the WSDL.
	__10.  Notice among other things that the WSDL defines a 'BadCustomer' XML type to define the content of the web service fault and it contains a 'soupOrdered' element which was part of the exception class.  There is also a <wsdl:fault ..> element in the definition of the 'orderSoup' operation of the service port.
	__11.  Back in Eclipse, open the Web Services Explorer (Run → Launch the Web Services Explorer).
	__12.  Click the second button from the right to switch the WSE to WSDL mode.
	__13.  If there are already WSDL files listed in the Navigator pane of the Web Services Explorer, clear the existing WSDL connection by clicking the Clear button. (the little eraser icon in the top right of the Navigator pane).
	__14.  Click the WSDL Main link.
	__15.  Paste the WSDL URL you copied earlier.
	__16.  Click Go.
	__17.  Click the orderSoup operation.
	__18.  Click the Add link next to the main operation parameter.
	__19.  Click the Add link next to the 'customerName' and 'soupType' elements of the form to create empty text boxes for these parameters.
	__20.  Fill in a 'customerName' of "Elaine" and a type of soup.
	__21.  Click Go.
	__22.  You will get a message that the content can't be displayed in this view.
	__23.  Click the Source link and maximize the Status pane.
	__24.  Examine the SOAP Response Envelope.
	__25.  Restore the Status pane to normal size.
	__26.  Close the Web Services Explorer.
	__27.  Leave the JBoss server running.

	Part 4 -  Modify Web Client to Handle Fault
	__1.  Expand the EJBClientWeb → Java Resources → src folders.
	__2.  Select both the com.webage.ejb.client and com.webage.ejb.client.clientsample packages by holding the CTRL key while clicking on them.
	__3.  With both packages selected, right click the selected packages and select Delete and then confirm you want to delete the packages.  You will get errors in other code.
	__4.  Make sure your JBoss server is running.
	__5.  Right click the EJBClientWeb project and select New → Other...
	__6.  Select Web Services → Web Service Client and click the Next button.
	__7.  In the box for 'Service definition' use the following value for the WSDL location.  Notice this is the updated location of the WSDL for the EJB web service.
	__8.  On the left, drag the slider down to Assemble Client.  Also check that the setting for 'Client project' is set to EJBClientWeb, which it should be since you right clicked the project to run the wizard.  Finally check that the two runtime options are set to JBoss.
	__9.  Click Next once your settings match that shown above.  
	__10.  Enter 'com.webage.ejb.client' for the Package name and switch the 'JAX-WS specification' version to 2.2.
	__11.  Click the Finish button to generate the code.  
	__12.  In the Project Explorer, right-click on EJBClientWeb and select Refresh.
	__13.  Right click the com.webage.ejb.client.clientsample package and select Delete and confirm you want to delete the package.
	__14.  Check that the only compilation error left is shown in the OrderServlet.java file in the com.webage.servlet package.
	__15.  Open the OrderServlet.java file.
	__16.  Find the doGet method and modify the code at the end of the method to match the following:
	__17.  Organize imports.
	__18.  Save the file.  There should no longer be any errors in the project.

	Part 5 -  Test Updated Web Client
	__1.  Return to the Servers view and publish the server by right clicking the server and selecting Publish.  
	__2.  Right-click on input.html under WebContent in the EJBClientWeb project and select Run As → Run On Server.
	__3.  Leave all defaults in the 'Run On Server' dialog and click Finish.
	__4.  Fill in some sample input (without using "Elaine" as the name) and click the Order button.
	__5.  Make sure that the response shows the appropriate response.
	__6.  Click the back arrow button in the upper left of the embedded browser to return to the form.
	__7.  Fill in data using the name "Elaine" and click the Order button.
	__8.  Check that you get the correct output that is triggered by the web service fault being returned from the service back to the client.
	__9.  If you scroll through the Console view you should be able to see traces of the exception that was thrown.
	__10.  Close all open files and web browsers.
	__11.  Stop the server.

	Part 6 -  Review

	Lab 14 -  Managed Service Client
	Part 1 -  Modify Generated Code to Use Internal WSDL
	__1.  Start your JBoss server if it is not already running.
	__2.  Open a web browser to the following address which should bring up a security prompt.
	__3.  In the security prompt, enter a username of 'admin' and a password of 'jbo$$ee6'.  You can check the option to remember the password if offered or click OK if credentials were pre-filled.
	__4.  Check that you see the overview page of the administration console.  If it doesn't display try refreshing the page.
	__5.  On the left side of the console, click the link for 'Deployments → Webservices' which should be expanded and visible.
	__6.  Make sure that the OrderSoup Web service is registered.  You might need to click it in the table to see the details.
	__7.  Select the entire WSDL URL and copy it.  You might want to hit the 'F11' key to temporarily switch the browser to full screen if you have trouble seeing the entire URL.
	__8.  Open another browser tab or window and paste the WSDL URL into the address bar of the browser to display the WSDL.
	__9.  From the browser menus select Page → Save As.. or File → Save Page As... depending on which browser you are using.
	__10.  Change the name of the file to 'OrderSoupService.wsdl' and browse to save to the 'C:\LabFiles' folder.  Also switch the 'Save as type' option to list "All Files" or the browser may attempt to add a '.xml' file type.
	__11.  Click the Save button to save the file when the dialog appears as shown above.
	__12.  Close the web browser.
	__13.  Return to Eclipse and expand the EJBClientWeb → WebContent → WEB-INF folders.
	__14.  Right click the WEB-INF folder and select New → Folder.
	__15.  Give the folder a name of 'wsdl' and click the Finish button to create the folder.
	__16.  Find the saved WSDL file in the 'C:\LabFiles' folder, make sure it name is OrderSoupService.wsdl, right click it, and select Copy.  Leave the original file in the folder as we will use it later.
	__17.  Return to your Eclipse workspace.
	__18.  Paste the file in the EJBClientWeb → WebContent → WEB-INF → wsdl folder as shown below.
	__19.  Expand the com.webage.ejb.client package in the EJBClientWeb → Java Resources → src folder.
	__20.  Open the OrderSoupService.java file.
	__21.  Scroll down and find the '@WebServiceClient' annotation in the code.  Notice that it has a property that points to the WSDL on the network.  Also note the 'name' property of the client annotation.
	__22.  Modify the 'wsdlLocation' attribute of the annotation to the value shown below.  Make sure that you match the number of ".." to navigate the correct number of parent folders (which is 5) and also use the correct "forward" (/) slash.
	__23.  Find the static initializing block a little further down in the class and replace both references to the network WSDL with the changes below.  Note the changes required to refer to a relative path to the WSDL file.
	__24.  Look for the constructors in the class a little further down.  Notice that the constructor that doesn't take parameters uses the default WSDL location to construct a reference to the service.
	__25.  Save and close the OrderSoupService.java file.

	Part 2 -  Simulate Deploying the Client to a Different Environment
	__1.  Return to the Servers view and publish the server by right clicking the server and selecting Publish. 
	__2.  Make sure that your JBoss server is started.
	__3.  Right-click on input.html under WebContent in the EJBClientWeb project and select Run As → Run On Server.
	__4.  Leave all defaults in the 'Run On Server' dialog and click Finish.
	__5.  Fill in some sample input (without using "Elaine" as the name) and click the Order button.
	__6.  Make sure that the response shows the appropriate response.
	__7.  Close the web browser.
	__8.  Expand the EJBClientWeb → WebContent → WEB-INF → wsdl folder.
	__9.  Double click the OrderSoupService.wsdl file to open it.  This file defines the endpoint location currently used by the client code.
	__10.  Switch to the Source tab if not already.
	__11.  At the bottom of the file change the SOAP address location property to 'localhost:8085'.  This port is not available on the server and will represent the client not being able to communicate with the version of the service used to develop the code.
	__12.  Save and close the file.
	__13.  Return to the Servers view and stop the JBoss server.
	__14.  Once the JBoss server is stopped start it again.
	__15.  Right-click on input.html (under EJBClientWeb | WebContent) and select Run As | Run on Server.
	__16.  Click Finish to run the test.
	__17.  Fill in any name on the input form and submit.  You should get an error shown.
	__18.  If you look in the Console view you should be able to find an error that mentions a 'ConnectException'.  You will not get many details besides the type of error but it is clear this is related to a network communication problem.
	__19.  Close the browser you were using to test the application but leave the server running.

	Part 3 -  Modify Code to Provide a Managed Endpoint Capability
	__1.  Expand the EJBClientWeb → Java Resources → src → com.webage.servlet folder.
	__2.  Open the OrderServlet.java file.
	__3.  In the doGet method remove the line of code that is crossed out below.  You will get errors after doing so but they will be fixed later.  
	__4.  Add the following code in bold as a new field in the class.  Make sure to add it inside the brackets for the class but outside of any other method.
	__5.  Organize imports (CTRL-SHIFT-O) to include the import for the WebServiceRef annotation.
	__6.  Save the code and be sure there are no errors.

	Part 4 -  Override Client Configuration
	__1.  Copy and paste file C:\LabFiles\jboss-web.xml into the WebContent → WEB‑INF folder of EJBClientWeb
	__2.  Open the jboss-web.xml file in the WebContent → WEB‑INF folder.
	__3.  Switch to the Source tab of the editor.
	__4.  Notice this provides a 'wsdl-override' setting for the @WebServiceRef annotation you added to the code.  With this setting in the application all we would need to do is provide an alternate WSDL file at that location to override the WSDL packaged with the application.  If you saved the 'OrderSoupService.wsdl' file to a different location change the setting in this file and save it.
	__5.  Close the jboss-web.xml file.

	Part 5 -  Verify Client Works with the New Setting
	__1.  Return to the Eclipse Servers view and publish the server by right clicking the server and selecting Publish. 
	__2.  Make sure the JBoss server is still running and start it if needed.
	__3.  Right-click on input.html under WebContent in the EJBClientWeb project and select Run As → Run On Server.
	__4.  Leave all defaults in the 'Run On Server' dialog and click Finish.
	__5.  Fill in some sample input (without using "Elaine" as the name) and click the Order button.
	__6.  Make sure that the response shows the appropriate response.
	__7.  Close all open files and web browsers.
	__8.  Stop the JBoss server.

	Part 6 -  Review

	Lab 15 -  WS-Security with UsernameToken
	Part 1 -  Import and Test Service
	__1.  Open up Eclipse if it is not already.
	__2.  Select File → Import from the Eclipse menus.
	__3.  Expand the General group and select Existing Projects into Workspace and press the Next button.
	__4.  Select the radio button next to the Select archive file option and use the matching Browse button to find the 'C:\LabFiles\PreSecurityStarter.zip' file that contains the project.  
	__5.  Select the projects listed in the file if they are not already as shown below.
	__6.  Press the Finish button to import the project.
	__7.  Check that the four 'Security...' projects show up in the list and do not have any red errors.  
	__8.  Open the Servers view. 
	__9.  Start the server if it is stopped.  Wait for it to start completely.
	__10.  Right click on the server and select Add and Remove...
	The Add and Remove projects window will appear. 
	__11.  Remove all other projects from the server by clicking the 'Remove All' button.
	__12.  In the left pane, select SecurityBillingClientEAR and click Add.
	__13.  In the left pane, select SecurityBillingServiceEAR and click Add.
	__14.  Click Finish.  This will deploy the new projects to the server.
	__15.  Open a web browser to the following address which should bring up a security prompt.
	__16.  In the security prompt, enter a username of 'admin' and a password of 'jbo$$ee6'.  You can check the option to remember the password if offered.
	__17.  Check that you see the overview page of the administration console.  If it doesn't display try refreshing the page.
	__18.  On the left side of the console, click the link for 'Deployments → Webservices' which should be expanded and visible.
	__19.  Make sure that the BillingManager Web service is registered.  
	__20.  Return the the TCP/IP Monitor view if you have it open.  If it is not open you can open it by selecting Window → Show View and then Debug → TCP/IP Monitor.
	__21.  Click the Clear button in the TCP/IP Monitor view to clear out any previous requests.
	__22.  Right click in the empty top area of the view and select Properties.
	__23.  Select the existing port monitor and press the Stop and then the Start buttons to restart the monitor since it often stops listening with no activity.
	__24.  Once your monitor is restarted click the OK button to close the preferences.
	__25.  Back in the web browser enter the URL:
	__26.  Fill in some sample info and click the Add button.  This page will use a Servlet in the client web application to submit a web service request to the service application.
	__27.  Make sure you get an 'OK' response from the server.
	__28.  Return to the Eclipse Console view and make sure there is information you entered printed out by the 'BillingManager' service.
	__29.  Look at the XML format of the request in the  TCP/IP Monitor view and notice it is just a regular service request.  The makeup of the requests and responses will vary quite a bit as WS-Security features are utilized.

	Part 2 -  Provide Template CXF Configuration
	__1.  Open a Windows Explorer window and copy the following file:
	__2.  Return to Eclipse and expand the following folder:
	__3.  Right click the 'WEB-INF' folder and select Paste.
	__4.  Right click the new file that was pasted and select Rename...
	__5.  Remove the '-service' from the file name so the name of the file is just 'jbossws‑cxf.xml' and click the OK button to rename the file.
	__6.  Check that the file name and location match that shown below.
	__7.  Double click the 'jbossws-cxf.xml' file to open it.
	__8.  Switch to the Source tab in the editor if it is not already.
	__9.  Close the 'jbossws-cxf.xml' file for the CXF service configuration.
	__10.  Open a Windows Explorer window and copy the following file:
	__11.  Return to Eclipse and expand the following folder:
	__12.  Double check you are in the 'Client' project and right click the 'WEB-INF' folder and select Paste.
	__13.  Right click the new file that was pasted and select Rename...
	__14.  Remove the '-client' from the file name so the name of the file is just 'jbossws‑cxf.xml' and click the OK button to rename the file.
	__15.  Check that the file name and location match that shown below.
	__16.  Double click the 'jbossws-cxf.xml' file in the client project to open it.
	__17.  Switch to the Source tab in the editor if it is not already.
	__18.  Close the 'jbossws-cxf.xml' file for the CXF client configuration.
	__19.  Return to the Servers view.
	__20.  Make sure your JBoss server is running.
	__21.  Right-click on the server and select Publish.  
	Wait until its status is Synchronized.
	__22.  Back in the web browser enter the URL:
	__23.  Fill in some sample info and click the Add button.  
	__24.  Make sure you get an 'OK' response from the server.  You can also use the Console or TCP/IP Monitor views to verify the service and client still work.

	Part 3 -  Configure Project for CXF
	__1.  In Eclipse select Window → Preferences.
	__2.  In the list of preferences select Java → Build Path → User Libraries.
	__3.  Press the New button.
	__4.  Fill in a library name of WSS4J and click the OK button.
	__5.  With the newly create WSS4J library still selected press the Add External JARs button.
	__6.  Browse to the 'C:\Software\jboss‑as‑7.1.1.Final\modules\org\apache\ws\security\main' directory, select the 'wss4j' JAR file, then click the Open button to complete the selection.  If your software was extracted to a different location adjust the beginning of that path for the correct location of the JBoss 7.1 files.
	__7.  Make sure that the JAR file is listed as part of the library.
	__8.  Click the OK button to close the Eclipse preferences.
	__9.  Back in Eclipse right click the SecurityBillingClientWeb project and select Build Path → Configure Build Path...
	__10.  In the build path settings select the Libraries tab and click the Add Library... button.
	__11.  Select User Library and click the Next button.
	__12.  Check the box next to the WSS4J library you defined and click the Finish button.
	__13.  Click the OK button to close the project properties.
	__14.  Check that the WSS4J library is associated with the project.
	__15.  Repeat the steps to configure the build path of the SecurityBillingServiceWeb project and add the WSS4J user library.  You don't need to define the user library again but just link the WSS4J user library to the service project just like you did the client project.
	__16.  In the SecurityBillingClientWeb project, open the WebContent/META‑INF/MANIFEST.MF file.
	__17.  Remove the line with 'Class-Path' and add the following bold line to the end of the file. This should all be on one line even though it wraps to a second line below.
	__18.  Save and close the file.
	__19.  In the SecurityBillingServiceWeb project, open the WebContent/META‑INF/MANIFEST.MF file.
	__20.  Remove the line with 'Class-Path' and add the following bold line to the end of the file.  This should all be on one line even though it wraps to a second line below.
	__21.  Save and close the file.

	Part 4 -  Add CXF Configuration for UsernameToken
	__1.  In Eclipse expand the following folder:
	__2.  Double click the 'jbossws-cxf.xml' file to open it.
	__3.  Add the following 'outInterceptors' element and nested elements within the <jaxws:client> element.  Note that the 'class' attribute of the <bean> tags are long and wrap to another line.
	__4.  Add the following new 'bean' definition that will configure the 'WSS4JOutInterceptor' with the appropriate settings for supplying the UsernameToken with the outgoing request.  Notice the 'id' of this 'bean' matches the 'outInterceptors' you added above.
	__5.  Save the XML file and be sure there are no errors.
	__6.  In the Project Explorer, right-click on SecurityBillingClientWeb and select New > Class.
	__7.  Set the Package to be com.webage.billing.security
	__8.  Set the Name to be ClientUsernamePasswordCallback
	__9.  Next to the empty list of interfaces click the Add button.
	__10.  Type 'CallbackHandler' in the filter box, select the CallbackHandler interface, and click the OK button.
	__11.  Check that you do not have the option to create a 'main' method selected.
	__12.  Check that your settings match that shown below and click the Finish button.
	__13.  Add the following code in bold.  This will create a Map of users and passwords that can be used by the client to send the request.  You will have errors fixed later.
	__14.  Modify the implementation of the 'handle' method to match that below.
	__15.  Organize imports (CTRL-SHIFT-O).
	__16.  Save the file and make sure there are no errors.
	__17.  Close all open files.
	__18.  In Eclipse expand the following folder from the service project:
	__19.  Double click the 'jbossws-cxf.xml' file to open it.
	__20.  Add the following 'inInterceptors' element and nested elements within the <jaxws:endpoint> element.  Note that the 'class' attribute of the <bean> tag is long and wraps to another line.
	__21.  Add the following new 'bean' definition that will configure the 'WSS4JInInterceptor' with the appropriate settings for letting the service look for the incoming UsernameToken in the request.  Notice the 'id' of this 'bean' matches the 'inInterceptors' you added above.
	__22.  Save the file and be sure there are no errors.
	__23.  In the Project Explorer, right-click on SecurityBillingServiceWeb and select New > Class.
	__24.  Set the Package to be com.webage.billing.security
	__25.  Set the Name to be UsernamePasswordCallback
	__26.  Next to the empty list of interfaces click the Add button.
	__27.  Type 'CallbackHandler' in the filter box, select the CallbackHandler interface, and click the OK button.
	__28.  Check that your settings match that shown below and click the Finish button.
	__29.  Add the following code in bold.  This will create a Map of users and passwords assumed to be the users allowed to access the service.  You will have errors fixed later.
	__30.  Modify the implementation of the 'handle' method to match that below.
	__31.  Organize imports (CTRL-SHIFT-O).
	__32.  Save the file and make sure there are no errors.
	__33.  Close all open files.

	Part 5 -  Test UsernameToken with PasswordText
	__1.  Return to the Servers view.
	__2.  Make sure your JBoss server is running.
	__3.  Right-click on the server and select Publish. 
	Wait until its status is Synchronized.
	__4.  Return the the TCP/IP Monitor view if you have it open.  If it is not open you can open it by selecting Window → Show View and then Debug → TCP/IP Monitor.
	__5.  Click the Clear button in the TCP/IP Monitor view to clear out any previous requests.
	__6.  Right click in the empty top area of the view and select Properties.
	__7.  Select the existing port monitor and press the Stop and then the Start buttons to restart the monitor since it often stops listening with no activity.
	__8.  Once your monitor is restarted click the OK button to close the preferences.
	__9.  Back in the web browser enter the URL:
	__10.  Fill in some sample info and click the Add button.  
	__11.  Make sure you get an 'OK' response from the server.  
	__12.  Maximize the Console view and notice that besides the messages you get from the service like normal we are also getting the logging from the 'LoggingOutInterceptor' of the client.  This helps verify the CXF client configuration is in fact being used.
	__13.  Switch to the TCP/IP Monitor view and make sure the last request submitted is selected.
	__14.  Switch to the XML display option and notice that the request has a number of additional WS-Security elements (with the 'wsse' and 'wsu' prefixes) along with the normal service request data for the account to add.
	__15.  Look at the <wsse:Username> and <wsse:Password> elements (scroll to the right for the password) and notice that the username and the password are sent in clear text.
	__16.  Switch to the XML display output in the response and notice that nothing about it has been changed for WS-Security.
	__17.  Restore any views you had maximized.
	__18.  In Eclipse expand the following folder:
	__19.  Double click the 'jbossws-cxf.xml' file to open it.
	__20.  In the map of properties in the CXF configuration of the "OutInterceptor" change the user property to 'badclient' as shown below.
	__21.  Save the file and make sure there are no errors.  Leave the file open.
	__22.  Return to the Servers view.
	__23.  Make sure your JBoss server is running.
	__24.  Right-click on the server and select Publish. 
	__25.  Back in the web browser return to the page to submit request data:
	__26.  Fill in some sample info and click the Add button.  You should get an error saying the security token was not valid.  Even though the client web application did not handle this error "nicely" it is clear the service has refused the request with a bad user. 
	__27.  Close the web browser.
	__28.  Leave the server running.

	Part 6 -  Use a PasswordDigest UsernameToken
	__1.  Return to the editor for the 'jbossws-cxf.xml' file in the SecurityBillingClientWeb project.  Open it again if you closed it remembering it is in the WebContent -> WEB‑INF folder.
	__2.  Change the 'PasswordType' property to 'PasswordDigest' as shown below.   Also change the user used back to 'goodclient' which will pass the authentication check on the service side.
	__3.  Save and close the file after making sure there are no errors.

	Part 7 -  Test PasswordDigest Changes
	__1.  Return to the Servers view.
	__2.  Make sure your JBoss server is running.
	__3.  Right-click on the server and select Publish. 
	__4.  Back in the web browser enter the URL:
	__5.  Fill in some sample info and click the Add button.  
	__6.  Make sure you get an 'OK' response from the server.  If you get an error you may have forgotten to switch the client user property back to 'goodclient'.
	__7.  Back in Eclipse. switch to the TCP/IP Monitor view and make sure the last request submitted is selected.
	__8.  Switch to the XML display option on the request side and scroll to the right to find the value of the <wsse:Password> element.  Notice it is hashed and there is also a <wsse:Nonce> element which is used in the password digest hashing.
	__9.  Restore any views you had maximized.

	Part 8 -  Provide UsernameToken as Part of Service Response
	__1.  In Eclipse close all open files and expand the following folder:
	__2.  Double click the 'jbossws-cxf.xml' file to open it.  Make sure it is the service CXF configuration.
	__3.  Add the following 'outInterceptors' element and nested elements within the <jaxws:endpoint> element but separate from the <jaxws:invoker> and existing <jaxws:inInterceptors>.  Note that the 'class' attribute of the <bean> tag is long and wraps to another line.
	__4.  Add the following new 'bean' definition that will configure the 'WSS4JOutInterceptor' with the appropriate settings for letting the service supply a UsernameToken as part of the response.  An important property is the 'user' property with the value of 'serverID' which will be the "username" of the service supplied back to the client.  Notice the 'id' of this 'bean' matches the 'outInterceptors' you added above.
	__5.  Save and close the file after checking there are no errors.
	__6.  Open the UsernamePasswordCallback.java file in the com.webage.billing.security package of the SecurityBillingServiceWeb project. 
	__7.  Add the following code in the constructor of the class.  This will supply the password of the service when the CXF configuration supplies the 'serverID' username before sending the response.
	__8.  Save and close the file after checking there are no errors.
	__9.  Expand the following folder:
	__10.  Double click the 'jbossws-cxf.xml' file to open it.
	__11.  Add the following 'inInterceptors' element and nested elements within the <jaxws:client> element but separate from the existing <jaxws:outInterceptors> element.  Note that the 'class' attribute of the <bean> tags are long and wrap to another line.
	__12.  Add the following new 'bean' definition that will configure the 'WSS4JInInterceptor' with the appropriate settings to check the service supplied UsernameToken that is part of the response with a "Callback Handler" class that will supply the password the server is expected to return.  Notice the 'id' of this 'bean' matches the 'inInterceptors' you added above.
	__13.  Save and close the file after checking there are no errors.
	__14.  Open the ClientUsernamePasswordCallback.java file in the com.webage.billing.security package of the SecurityBillingClientWeb project. 
	__15.  Add the following code in the constructor of the class.  This will supply the expected password of the service response.
	__16.  Save and close the file after checking there are no errors.

	Part 9 -  Test Service UsernameToken With Response
	__1.  Return to the Servers view.
	__2.  Make sure your JBoss server is running.
	__3.  Right-click on the server and select Publish. 
	__4.  Back in the web browser enter the URL:
	__5.  Fill in some sample info and click the Add button.  
	__6.  Make sure you get an 'OK' response from the server. 
	__7.  Back in Eclipse. switch to the TCP/IP Monitor view and make sure the last request submitted is selected.
	__8.  Switch to the XML display option on the response side (the right side) and notice the response now has various WS-Security elements in the response in addition to the usual 'OK' status near the end of the response.
	__9.  Restore any views you had maximized.
	__10.  Close any files and browsers, and stop the server.

	Part 10 -  Review

	Lab 16 -  WS-Security With Signature
	Part 1 -  Generate Keys
	__1.  Open a command prompt window.  You can do this by selecting Start → Run, entering 'cmd' and hitting <ENTER>.
	__2.  Change directory to C:\LabFiles.
	__3.  Run the command 'keytool' to make sure you have access to the program.  It shouldn't do anything but come back with the options to run the command.
	__4.  Run the script provided for you that will generate security certificates and exchange between “keystores”:
	__5.  Make sure that there are no error messages. The output should look like above.
	__6.  Run the following command to list all keys in service.jks:
	__7.  Similarly, list all keys in client.jks.
	__8.  Close the command prompt.
	__9.  Open a Windows explorer window and navigate to C:\LabFiles.
	__10.  Right click on the 'genkeys.bat' file and select Edit.  Make sure you do not double click it as this will run it.
	__11.  Examine the first key generation command for the service's key and the important settings:
	__12.  Notice the second command generates the key for the client.  Most of the settings are similar with some you will see later in CXF configuration.
	__13.  The next pair of commands exports the key from the service keystore into a separate file and imports this key into the client keystore as a "trusted" certificate.  Notice the keystore password of the appropriate keystore is required and the alias of the key to export and import (myservicekey) is used to identify which key to work with.
	__14.  The final pair of commands performs the export/import process in the reverse direction so the service keystore will trust the client certificate.
	__15.  Close the file.
	__16.  From the Windows Explorer window showing the contents of C:\LabFiles copy the 'service.jks' file.  Make sure you don't copy the 'MyService.cer' file.
	__17.  Return to Eclipse and expand the following folder:
	__18.  Right click the 'src' folder (not any of the packages) and select Paste.  Make sure the 'service.jks' file is pasted at the root of the 'src' folder as shown below.  This is the easiest way to ensure the file is available on the classpath of the deployed application.
	__19.  Return to the Windows Explorer window showing the contents of the C:\LabFiles directory.
	__20.  Copy the 'client.jks' file.
	__21.  Return to Eclipse and expand the following folder:
	__22.  Right click the 'src' folder (not any of the packages) and select Paste.  Make sure the 'client.jks' file is pasted at the root of the 'src' folder as shown below.  

	Part 2 -  Modify Client Configuration for Signature
	__1.  In Eclipse expand the following folder:
	__2.  Double click the 'jbossws-cxf.xml' file to open it.
	__3.  Find the definition of the 'Security_Request' bean associated with the "Out" interceptor and modify the value of the 'action' property to include 'Signature' with a space before the new action.
	__4.  Add the following new <entry> elements to the configuration of the 'Security_Request' bean.  Be careful entering the values, especially with the 'signatureParts' property which should all be on one line.
	__5.  Find the definition of the 'Security_Response' bean associated with the "In" interceptor and modify the value of the 'action' property to include 'Signature' with a space before the new action.
	__6.  Add the following new <entry> element to the configuration of the 'Security_Response' bean.  This sets the 'signaturePropFile' to a properties file that will be created in the next steps.
	__7.  Save and close the file after making sure there are no errors.  Eclipse may show errors in the XML file if you are not connected to the internet to have access to the CXF schemas.
	__8.  Expand the following folder:
	__9.  Open the ClientUsernamePasswordCallback.java file.
	__10.  Add the following code in bold to the constructor of the class.  This will supply the password of the alias for the key used to sign the request.
	__11.  Save and close the file after making sure there are no errors.
	__12.  In the SecurityBillingClientWeb → Java Resources folder, right click the 'src' folder (not any of the packages) and select New → Other...
	__13.  In the wizard select General → File and click the Next button.
	__14.  Fill in a 'File name' of 'client.properties', check that the 'parent folder' is 'SecurityBillingClientWeb/src', and click the Finish button.
	__15.  Check that the new file appears at the root of the 'src' folder along with the 'client.jks' file you had already pasted there.  If it seems to show up in the wrong place try selecting the project and hitting the F5 key to refresh the project.
	__16.  In the file that is opened enter the following properties.  The first property below is too long to be shown on one line but should be entered on the same line as the property key of 'org.apache.ws.security.crypto.provider'.
	__17.  Save and close the file after making sure there are no errors.

	Part 3 -  Configure Service for Signature
	__1.  In Eclipse expand the following folder:
	__2.  Double click the 'jbossws-cxf.xml' file to open it.
	__3.  Find the definition of the 'Security_Request' bean associated with the "In" interceptor and modify the value of the 'action' property to include 'Signature' with a space before the new action.
	__4.  Add the following new <entry> element to the configuration of the 'Security_Request' bean.  This sets the 'signaturePropFile' to a properties file that will be created in the next steps.
	__5.  Find the definition of the 'Security_Response' bean associated with the "Out" interceptor and modify the value of the 'action' property to include 'Signature' with a space before the new action.
	__6.  Add the following new <entry> elements to the configuration of the 'Security_Response' bean.  Be careful entering the values, especially with the 'signatureParts' property which should all be on one line.
	__7.  Save and close the file after making sure there are no errors.  Eclipse may think there are errors if it can't connect to the internet to get the CXF XML schemas.
	__8.  Expand the following folder:
	__9.  Open the UsernamePasswordCallback.java file.
	__10.  Add the following code in bold to the constructor of the class.  This will supply the password of the alias for the key used to sign the response.
	__11.  Save and close the file after making sure there are no errors.
	__12.  Expand the following folder from the client project:
	__13.  Right click the client.properties file and select Copy.
	__14.  Expand the following folder in the service project:
	__15.  Right click the 'src' folder (not any of the packages) and select Paste.
	__16.  Refresh the project.
	__17.  Right click the client.properties file you pasted in the service project and select Rename.
	__18.  Change the name of the file to service.properties and click the OK button.
	__19.  Check that the file appears at the root of the 'src' folder along with the 'service.jks' file you had already pasted there.
	__20.  Double click the service.properties file to open it.
	__21.  Change the following property values that are shown in bold so they match the values for the service keystore.  Remember the first property below is too long to be shown on one line but the value should be on the same line and the value is the same as what was used for the client.
	__22.  Save and close the file after making sure there are no errors.

	Part 4 -  Test Signature
	__1.  Open the Servers view. 
	__2.  Start the server if it is stopped.  Wait for it to start completely.
	__3.  If the JBoss server was already running right-click on the server and select Publish. 
	__4.  Return the the TCP/IP Monitor view if you have it open.  If it is not open you can open it by selecting Window → Show View and then Debug → TCP/IP Monitor.
	__5.  Click the Clear button in the TCP/IP Monitor view to clear out any previous requests.
	__6.  Right click in the empty top area of the view and select Properties.
	__7.  Select the existing port monitor and press the Stop and then the Start buttons to restart the monitor since it often stops listening with no activity.
	__8.  Once your monitor is restarted click the OK button to close the preferences.
	__9.  Open a web browser and enter the URL:
	__10.  Fill in some sample info and click the Add button.  
	__11.  Make sure you get an 'OK' response from the server.
	__12.  Back in Eclipse switch to the TCP/IP Monitor view and make sure the last request submitted is selected.
	__13.  Switch to the XML display option on the request side and notice there are new elements like <ds:Signature> and <ds:DigestValue> which are involved in the signature.
	__14.  Notice at the end of the message the content of the message is still in plain text.  The signature only provides validity of the message and doesn't encrypt the message itself.
	__15.  Switch to the XML display view of the response on the right and notice the same signature elements are there also.
	__16.  Restore any views you had maximized.
	__17.  Close any files and stop the server.

	Part 5 -  Review

	Lab 17 -  WS-Security With Encryption
	Part 1 -  Modify Client Configuration for Encryption
	__1.  In Eclipse expand the following folder:
	__2.  Double click the 'jbossws-cxf.xml' file to open it.
	__3.  Find the definition of the 'Security_Request' bean associated with the "Out" interceptor and modify the value of the 'action' property to include 'Encrypt' with a space before the new action.
	__4.  Add the following new <entry> elements to the configuration of the 'Security_Request' bean.  Be careful entering the values, especially with the 'encryptionParts' property which should all be on one line.  Notice that the 'encryptionUser' is 'myservicekey' which will use the public key of the service to encrypt the request from the client.
	__5.  Find the definition of the 'Security_Response' bean associated with the "In" interceptor and modify the value of the 'action' property to include 'Encrypt' with a space before the new action.
	__6.  Add the following new <entry> element to the configuration of the 'Security_Response' bean.  This sets the 'decryptionPropFile' to the same properties file as used before.
	__7.  Save and close the file after making sure there are no errors.  Eclipse may think there are XML errors if you are not connected to the internet.

	Part 2 -  Configure Service for Encryption
	__1.  In Eclipse expand the following folder:
	__2.  Double click the 'jbossws-cxf.xml' file to open it.
	__3.  Find the definition of the 'Security_Request' bean associated with the "In" interceptor and modify the value of the 'action' property to include 'Encrypt' with a space before the new action.
	__4.  Add the following new <entry> element to the configuration of the 'Security_Request' bean.  This sets the 'decryptionPropFile' to the same properties file as used before.
	__5.  Find the definition of the 'Security_Response' bean associated with the "Out" interceptor and modify the value of the 'action' property to include 'Encrypt' with a space before the new action.
	__6.  Add the following new <entry> elements to the configuration of the 'Security_Response' bean.  Be careful entering the values, especially with the 'encryptionParts' property which should all be on one line.  Notice that the 'encryptionUser' is 'myclientkey' which will use the public key of the client to encrypt the response from the service.
	__7.  Save and close the file after making sure there are no errors.  Eclipse may think there are XML errors if you are not connected to the internet.

	Part 3 -  Test Encryption
	__1.  Open the Servers view. 
	__2.  Start the server if it is stopped.  Wait for it to start completely.
	__3.  If the JBoss server was already running right-click on the server and select Restart. 
	__4.  Return the the TCP/IP Monitor view if you have it open.  If it is not open you can open it by selecting Window → Show View and then Debug → TCP/IP Monitor.
	__5.  Click the Clear button in the TCP/IP Monitor view to clear out any previous requests.
	__6.  Right click in the empty top area of the view and select Properties.
	__7.  Select the existing port monitor and press the Stop and then the Start buttons to restart the monitor since it often stops listening with no activity.
	__8.  Once your monitor is restarted click the OK button to close the preferences.
	__9.  Back in the web browser enter the URL:
	__10.  Fill in some sample info and click the Add button.  
	__11.  Make sure you get an 'OK' response from the server.
	__12.  Back in Eclipse scroll back in the Console view and you should be able to see the account info printed which proves the service was able to decrypt it.
	__13.  Switch to the TCP/IP Monitor view and make sure the last request submitted is selected.
	__14.  Switch to the XML display option on the request side and scroll to the bottom notice there are elements within the <soap:Body> element that contain the encrypted text.  You also no longer see the plain text of the message with the account info like you saw before.  This is because it is now being encrypted.
	__15.  Switch to the XML display view of the response on the right and notice at the end of the response the message is also encrypted.  Although our service just responds with "OK" it could easily send back an account number or something similar that would be good to encrypt.
	__16.  Restore any views you had maximized.
	__17.  Close any files, web browsers.
	__18.  Remove all projects from the server and then stop the server.

	Part 4 -  Review

	Lab 18 -  Develop a Simple RESTful Service
	Part 1 -  Create the Web Service Project
	__1.  From the menubar, select File > New > Dynamic Web Project.
	__2.  Enter AcmeWeb for the Project name.
	__3.  Check the box for Add Project to an EAR.
	__4.  At the bottom of the window, in the EAR Membership section, click the button marked New Project....  (We will want to add this WAR file into an EAR file)
	The New EAR Application Project screen will appear.
	__5.  Set the Project name to AcmeApp and make sure the target server is JBoss.
	__6.  Click Finish to create the EAR project
	__7.  Click Finish.  Both the EAR and the WAR will be created.  If prompted, don't switch to the web perspective by clicking No.
	__8.  Right click the newly created AcmeWeb project and select Properties.
	__9.  Now, select the Project Facets property.
	__10.  Note that the JAX-RS facet is not selected. This facet plays no role in developing JAX-RS services.
	__11.  Click Cancel to close the dialog.

	Part 2 -  Register the REST Application
	__1.  Open Windows file explorer.
	__2.  Go to C:\LabFiles\
	__3.  Copy web.xml
	__4.  In eclipse, paste the file inside the WebContent > WEB-INF folder of AcmeWeb.
	__5.  Open web.xml and study how the REST application is configured. Switch to the Source view and specifically, note the servlet mapping:
	__6.  Close the file.

	Part 3 -  Create the Resource Class
	__1.  Right click AcmeWeb project and select New > Class.
	__2.  Enter com.acme.services as the package name and SimpleService as the class name.
	__3.  Click Finish to create the new class.
	__4.  Add a member variable that will help us do logging.
	__5.  Organize imports (Control+Shift+O) and select java.util.logging.Logger.  Make sure you select the correct class as there are several 'Logger' classes on the classpath.
	__6.  Add the method as follows.
	__7.  Save changes.

	Part 4 -  Configure the Resource
	__1.  Define the URI of the root resource, by adding the @Path annotation above the class. 
	__2.  Set the HTTP method and reply MIME type for the testGET() method sub-resource as follows.
	__3.  Organize imports. Select javax.ws.rs.Produces.
	__4.  Save changes.

	Part 5 -  Unit Test
	__1.  Start the server.
	__2.  Right click the server and select Add and Remove.
	__3.  Add the AcmeApp project to the server.
	__4.  Click Finish.
	__5.  Right click the server and select Publish. Do this every time you are requested to Publish the server.
	__6.  Open a web browser and enter the URL: 
	__7.  You should see OK in the browser.
	__8.  The Console view will show the log output.

	Part 6 -  Use Path Extension for Sub-resource
	__1.  First, add this method to the SimpleService class.
	__2.  Annotate the method as follows.
	__3.  Save changes.

	Part 7 -  Unit Test
	__1.  Right click the server and select Publish.
	__2.  In a web browser, enter the URL: 
	__3.  Make sure that the Console shows the log output.
	__4.  Open a new browser or tab and re-test the testGET method for regression using the URL: 
	__5.  Close all browsers.
	__6.  Close all open files.

	Part 8 -  Review

	Lab 19 -  Extracting Information from a HTTP Request
	Part 1 -  Get Root Resource Path Parameters
	__1.  Open SimpleService.java from the AcmeWeb project.
	__2.  Change the @Path annotation for the class and add a parameter there.
	__3.  Add a member variable as follows.
	__4.  Annotate the member variable to save the value of the myRootPathData parameter.
	__5.  Organize imports.
	__6.  Change the log statement of the testGET() method as follows.
	__7.  Make a similar change to the testGETWithPath() method.
	__8.  Save changes.

	Part 2 -  Unit Test
	__1.  Publish the server.
	__2.  First, test the testGET() method by entering the URL: 
	__3.  The log output will like this:
	__4.  Now, test the testGETWithPath() method using the URL: 
	__5.  The log output will be:

	Part 3 -  Get Sub-resource Path Parameters
	__1.  Add a basic method as follows.
	__2.  Annotate method with path and method.
	__3.  Now, extract the path parameters and save them in the two input argument variables of the method.  The syntax for the @PathParam annotation on a method parameter is tricky so be careful.
	__4.  Save changes.
	__5.  Publish the server.
	__6.  Test the method by entering the URL: 

	Part 4 -  Extract Query Parameters
	__1.  Add the giveRaise() method as shown below.
	__2.  Organize imports.
	__3.  Save changes.
	__4.  Publish the server.
	__5.  Test the change by entering the URL: 
	__6.  Make sure that the Console shows:

	Part 5 -  Extracting Form Post Data
	__1.  Add this method.
	__2.  Organize imports. Select  java.util.List.
	__3.  Save changes.

	Part 6 -  Unit Test
	__1.  We will import the form HTML page. Copy C:\LabFiles\post.html and paste it inside the WebContent folder of the AcmeWeb project.
	__2.  In the Servers view, right click the server and select Publish.
	__3.  Open a browser and enter the URL: 
	__4.  Fill out the form and submit it. 
	__5.  Make sure that the console log shows the input values correctly.
	__6.  Close all open files.
	__7.  Close all open browsers. 

	Part 7 -  Review

	Lab 20 -  Designing a RESTful Service
	Part 1 -  The Business Requirements
	Part 2 -  Define Project Scope
	Part 3 -  Designing the Object Model
	__1.  Can you go through the business requirements and identify the entities? 
	__2.  Now that you have identified the entities, can you list the attributes or fields for each entity? Once again, the answer is below. But do your best to do the design yourself.

	Part 4 -  Identify the Service
	__1.  Can you go through the requirements and list the tasks or operations that various yet to be identified services need to perform? Then compare your findings with the answer below.
	__2.  Can you group the operations based on the entity they work with? Name each group as a service accordingly. The answer is below.

	Part 5 -  Design the Service Interface
	__1.  First, let us decide on the URI for each entity. This is a pretty straightforward exercise. Note: As a matter convention, plural forms of the entity names are used in URI.

	Part 6 -  Decide on the Data Format
	Part 7 -  Unaddressed Architectural Issues
	Part 8 -  Review

	Lab 21 -  Add Support for XML Format
	Part 1 -  Create the Entity Classes
	__1.  In the AcmeWeb project, create a package called com.acme.services.entities
	__2.  Within that package, create a Java class called QuoteRequest
	__3.  In the QuoteRequest class, add these member variables. Feel free to refer back to the object model to make sure we are doing this correctly.
	__4.  Generate getters and setters for the variables. To do this select any variable, then from the menu select Source >  Generate Getters and Setters. Click Select All and click OK.
	__5.  Add the @XmlRootElement JAXB annotation to the class as shown in boldface below.
	__6.  Organize imports.
	__7.  Save changes.
	__8.  Open a file browser and go to C:\LabFiles\entities.
	__9.  Copy all the files within the folder and then paste them into the com.acme.services.entities package.
	__10.  Open each entity class file and review them. Specifically, look at the Order class. Working with list of child objects can be tricky in JAXB. Look at how we are dealing with line items:

	Part 2 -  Generate the XML Schema
	__1.  In the Project Explorer view, right click on the AcmeWeb project and select New → Other.
	__2.  Expand JAXB and select Schema from JAXB Classes and click the Next button.
	__3.  Change the name of the schema to AcmeWeb.xsd
	__4.  Click Next.
	__5.  Expand the AcmeWeb → src folder and select the com.acme.services.entities package.
	__6.  Click the Finish button to generate the schema.
	__7.  After a few seconds check that the root of the project has the schema, note that it was renamed to AcmeWeb1.xsd.
	__8.  Open the generated schema file and study it if you wish.
	__9.  Close all open files.

	Part 3 -  Create the Quote Service Class
	__1.  In the com.acme.services package, create a class called QuoteService
	__2.  Set the root URI of the service as shown in boldface below.
	__3.  Add a member variable for logging.
	__4.  Add the getQuote() method as shown below. The business logic is very simple. We hard code the price and availability.
	__5.  Annotate the method as shown below.
	__6.  Organize imports. Select javax.ws.rs.Produces and java.util.logging.Logger.
	__7.  Save changes.

	Part 4 -  Better Content Handling
	__1.  Add the @Consumes annotation to getQuote as follows in bold.
	__2.  Similarly, change the @Produces annotation to support both MIME types for XML.
	__3.  Organize imports. Select javax.ws.rs.core.MediaType.
	__4.  Save changes.

	Part 5 -  Unit Testing
	__1.  Start the server if it is not running.
	__2.  Publish the server.
	__3.  Open a command window and change directories with the 'cd' command to C:\Software\RESTClient.
	__4.  Run the command:
	__5.  In the URL text box, enter: 
	__6.  Select POST method.
	__7.  Click the Body tab.
	__8.  Click the  icon.
	__9.  From the drop-down select the text/xml content type.
	__10.  Click OK.
	__11.  Click the  icon to open the file.
	__12.  Select C:\LabFiles\quote_request.xml and open it.
	__13.  The tool will offer you an option to change the MIME type to application/xml. This is not necessary (either text/xml or application/xml will work fine), click NO.
	__14.  Study the request document briefly.
	__15.  We are now ready start testing. Click the  icon next to the URL.
	__16.  Make sure that the HTTP reply status code is 200.
	__17.  Click the Body tab for the response.
	__18.  Right click the response body text and select Indent > Indent XML.
	__19.  Study the response document.
	__20.  Back in eclipse close all open files.
	__21.  Do not close the REST Client.

	Part 6 -  Review

	Lab 22 -  Add Support for JSON
	Part 1 -  Do the Design First
	Part 2 -  Add the JSON Method
	__1.  Open QuoteService class.
	__2.  First, add the shell of the method.
	__3.  Then, annotate the method and the input parameters as shown in boldface below.
	__4.  Now, fill in the body of the method. It basically calls the getQuote() method to get the job done.
	__5.  Organize imports.
	__6.  Save changes.

	Part 3 -  Understanding Content Negotiation
	Part 4 -  Test
	__1.  Publish the server by right-clicking and selecting Publish.
	__2.  Launch the REST client tool if it is not already running.  Use steps from previous labs to set the 'JAVA_HOME' variable in the command prompt to launch the tool.
	__3.  Set the URL to: 
	__4.  Choose POST method.
	__5.  Set the body using the XML code in C:\LabFiles\quote_request.xml 
	__6.  Set content type to application/xml; chartset=UTF-8.
	__7.  Click the Headers tab.
	__8.  Enter Accept as Key and text/xml as Value.
	__9.  Click the + icon to add the header.
	__10.  Run the test by clicking .
	__11.  Right click the response body area in the Body tab and select Indent > Indent XML.
	__12.  Verify that the reply body contains the response.
	__13.  Select the Accept header, then right click on it and select Delete.
	__14.  Enter Accept as Key and application/json as Value, then click the + icon to add the header.
	__15.  Select the request Body tab and click on the button for 'Insert parameters'
	__16.  Confirm that you want to erase the current body text by clicking the Yes button.
	__17.  Confirm that you want to switch the content type to the value needed for a form, 'application/x-www-form-urlencoded', by clicking the Yes button.
	__18.  Use the tool to add each of the following parameters by filling in the key and value and clicking the button to add the parameter.
	__19.  Once you have all the parameters filled in as shown below, click the Generate button.
	__20.  Run the test.
	__21.  Right click the response body area and select Indent > Indent JSON.
	__22.  Verify the result.
	__23.  Back in eclipse close all open files.
	__24.  Do not close the REST Client.

	Part 5 -  Review

	Lab 23 -  Build the Order Web Service
	Part 1 -  Create the Resource Class
	__1.  In the com.acme.services package, create a class called OrderService
	__2.  Annotate the class to set the path as follows.
	__3.  Add a member variable for logging.
	__4.  Organize imports. Select java.util.logging.Logger.
	__5.  Save changes.

	Part 2 -  Implement Order Placement
	__1.  Write the shell of the method as follows. We will not deal with the returned URL just yet.
	__2.  Annotate the method with @POST and @Consumes.
	__3.  Organize imports. Select these classes when prompted (they may come up in a different order):
	javax.ws.rs.core.MediaType
	com.acme.services.entities.Order
	javax.ws.rs.core.Response
	__4.  Save changes.
	__5.  Copy the file C:\LabFiles\OrderDAO.java into the com.acme.services package.
	__6.  Open the class and briefly study it. The code should be very simple.
	__7.  In the placeOrder method of the OrderService class, use OrderDAO as shown in boldface below.
	__8.  Organize imports. Select this class:
	java.util.logging.Level
	__9.  Save changes.

	Part 3 -  Implement Retrieval of Order
	__1.  First write the method shell along with the required annotations.
	__2.  Next, fill in the method body.
	__3.  Organize imports. Select these classes:
	__4.  Save changes.

	Part 4 -  Construct Entity URL
	__1.  First, add a member variable to the class as follows.
	__2.  In the placeOrder() method, add the bold code:
	__3.  Add this line in bold below:
	__4.  Next, add the following line. This plugs in the actual value of the order ID to the path and returns a java.net.URI object.
	__5.  Finally, add this line. 
	__6.  Organize imports. Choose this class:
	__7.  Save the file and make sure you don't have any compilation errors.

	Part 5 -  Test
	__1.  Go to the 'Servers' view and publish the changes to the server by right clicking the server and selecting 'Publish'.
	__2.  Launch the REST client tool if it is not already running. 
	__3.  From the REST client's menubar, select File > Open Request (Control+O).
	__4.  Open C:\LabFiles\order_create.rcq
	__5.  Review these items about the request:
	__6.  Click the  button to send the request.
	__7.  Verify that:
	__8.  In the Console, verify the log output from the OrderDAO class.
	__9.  In the REST client, open the request file C:\LabFiles\order_retrieve.rcq.
	__10.  Verify:
	__11.  Send the request.
	__12.  Verify that the reply body has the correct order information.

	Part 6 -  Enable Error Handling
	__1.  In the placeOrder() method of OrderService class, add this line shown in bold face.
	__2.  Comment out the following unreachable line:
	__3.  Organize imports. 
	__4.  In the getOrder() method, above the line:
	__5.  Organize imports. Choose this class:
	javax.ws.rs.core.Response.Status
	__6.  Save changes.

	Part 7 -  Test
	__1.  Publish the  server in the Servers view.
	__2.  In the REST client, the order retrieval request file should be open already. Just run the test.
	__3.  Verify that the status code is 404.  This is because the previous order was lost when the application was updated and restarted.
	__4.  Open the request file C:\LabFiles\order_create.rcq.
	__5.  In the Body tab, delete all the <item> elements.
	__6.  Run the test.
	__7.  Verify that status code 500 is returned.
	__8.  Do regression tests to make sure that success conditions are working fine.
	__9.  In eclipse close all open files.
	__10.  Do not close the REST Client.

	Part 8 -  Review

	Lab 24 -  Complete the Order Service
	Part 1 -  Implement Order Cancellation
	__1.  In the AcmeWeb project, open OrderService.java
	__2.  Add this method.
	__3.  Add these lines to the cancelOrder() method.
	__4.  Organize imports.
	__5.  Save changes.

	Part 2 -  Test
	__1.  Publish the  server.
	__2.  Launch the REST client tool if it is not already running.  Use steps from previous labs to set the 'JAVA_HOME' variable in the command prompt to launch the tool.
	__3.  From the client, open the request file C:\LabFiles\order_create.rcq
	__4.  Run the test. You should get a status code of 201. 
	__5.  Open the request file C:\LabFiles\order_retrieve.rcq
	__6.  Run the test. You should get a status code of 200.
	__7.  From the Method tab, select DELETE.
	__8.  Run the test. 
	__9.  Since the reply body is empty, you should see HTTP status code 204. This is equivalent to status 200 and indicates success.
	__10.  In the Method tab, select GET method.
	__11.  Run the test.
	__12.  Verify that 404 is returned.

	Part 3 -  Implement Order History
	__1.  From the com.acme.services.entities package, open OrderList.java and inspect it.
	__2.  Close the class.
	__3.  In the OrderService class, add the method shell as follows.
	__4.  Add the method body as follows.
	__5.  Organize imports.
	__6.  Save changes.

	Part 4 -  Test
	__1.  Publish the  server.
	__2.  From the REST test client, open the request file C:\LabFile\order_create.rcq
	__3.  From the Body tab, note the client ID – C001.
	__4.  Run the test to create an order.
	__5.  From the Body tab of the request, change the part number and quantity ordered.
	__6.  Run the test to place a few more orders.
	__7.  From the test client, open the request file C:\LabFiles\order_history.rcq
	__8.  Run the test.
	__9.  Scroll down and verify that both orders are shown.

	Part 5 -  Implement Order Update Function
	__1.  In the OrderService class, add the method shell.
	__2.  Fill in the method body as follows.
	__3.  Organize imports.
	__4.  Save changes.

	Part 6 -  Test
	__1.  Publish the  server.
	__2.  From the REST test client, open the request file C:\LabFile\order_create.rcq
	__3.  Run the test.
	__4.  Add the order ID 1000 to the URL (add  /1000  at the end of the URL).
	__5.  From the Method tab, choose PUT.
	__6.  From the Body tab, change quantity and/or part number.
	__7.  Run the test.
	__8.  Verify that status code 200 is returned.
	__9.  Now lets check the retrieve request. Open the request file C:\LabFiles\order_retrieve.rcq
	__10.  Run the test.
	__11.  Verify that status code 200 is returned.   
	__12.  Format the result (Indent > Indent XML ) and verify that the body contains the information that you changed.
	__13.  Open the request file C:\LabFile\order_create.rcq
	__14.  Change the order ID in the URL to an invalid value as shown below.
	__15.  From the Method tab, choose PUT.
	__16.  Run the test and make sure 404 status code is returned.
	__17.  In eclipse, close all the open files.

	Part 7 -  Review

	Lab 25 -  Developing a JAX-RS Client
	Part 1 -  Client Design Considerations
	Part 2 -  Import the Client Application
	__1.  From the eclipse menubar, select File > Import.
	__2.  Select General > Existing Projects into Workspace and click Next.
	__3.  Select the 'Select archive file' radio button and use the Browse button to the right to select the C:\LabFiles\SimpleClientStarter.zip file.
	__4.  Make sure both projects are selected as shown above and click Finish.

	Part 3 -  Configure Project for RESTEasy
	__1.  In Eclipse select Window → Preferences.
	__2.  In the list of preferences select Java → Build Path → User Libraries.
	__3.  Press the New button.
	__4.  Fill in a library name of RESTEasy and click the OK button.
	__5.  With the newly create RESTEasy library still selected press the Add External JARs button.
	__6.  Browse to the 'C:\Software\jboss‑as‑7.1.1.Final\modules\org\jboss\resteasy\resteasy-jaxrs\main' directory, select all of the JAR files by holding the CTRL key as you select each one, then click the Open button to complete the selection.  If your software was extracted to a different location adjust the beginning of that path for the correct location of the JBoss 7.1 files.
	__7.  Make sure that the JAR files are listed as part of the library.
	__8.  Click the OK button to close the Eclipse preferences.
	__9.  Back in Eclipse right click the SimpleClient project and select Build Path → Configure Build Path...
	__10.  In the build path settings select the Libraries tab and click the Add Library... button.
	__11.  Select User Library and click the Next button.
	__12.  Check the box next to the RESTEasy library you defined and click the Finish button.
	__13.  Click the OK button to close the project properties.
	__14.  Check that the RESTEasy library is associated with the project.
	__15.  In the SimpleClient project, open the WebContent/META‑INF/MANIFEST.MF file.
	__16.  Remove the line with 'Class-Path' and add the following bold line to the end of the file.  The three dependencies listed should all be on one line.
	__17.  Save and close the file.

	Part 4 -  Build the Service Proxy Layer
	__1.  From the AcmeWeb project, copy the com.acme.services.entities package.  Make sure to copy the entire package by right clicking the package and selecting Copy.
	__2.  In the SimpleClient project, paste it in the src folder.
	__3.  In the SimpleClient project, create a package called com.acme.services.proxy
	__4.  In that package, create a class called QuoteProxy
	__5.  In the QuoteProxy class, add a variable to store the service root URL.
	__6.  Add the shell of a method that will invoke the quote web service.
	__7.  In the getQuote() method, add this line to instantiate a org.jboss.resteasy.client.ClientRequest object.
	__8.  Add these lines to set the content type of the request and the accept header.
	__9.  Add this line to send the request using a POST request.
	__10.  Finally, add this line to return the quote response.
	__11.  Organize imports and select this class:
	__12.  Save changes.

	Part 5 -  Build the Presentation Layer
	__1.  From the WebContent folder, right click index.jsp and select Open With >  Web Page Editor.
	__2.  Study the form.
	__3.  Open result.jsp as Web Page Editor and study how the QuoteResponse object properties are shown.
	__4.  From the com.webage.servlet package, open QuoteController.java.
	__5.  Locate the doPost method.
	__6.  Below the line:
	__7.  Below the line: 
	__8.  Below the line:
	__9.  Organize imports.
	__10.  Save changes.

	Part 6 -  Test
	__1.  Start the server if it is not running.
	__2.  Deploy SimpleClientEAR project to the server with the Add and Remove.. option when you right click the server.
	__3.  Open a web browser and enter the URL: 
	__4.  Enter some values and click Get Quote.
	__5.  Verify the result.
	__6.  Close the browser.
	__7.  Close all open files.

	Part 7 -  Review

	Lab 26 -  Securing JAX-RS REST Services
	Part 1 -  Configure JBoss Application Security
	__1.  Open a Windows command prompt.  You can usually do this on most versions of Windows by selecting 'Start → Programs → Accessories → Command Prompt'.
	__2.  Use the following 'cd' command to switch to the JBoss 'bin' directory.
	__3.  Run the following 'add-user' command to start the interactive tool to add a user. How to respond to various prompts is given in the next steps.
	__4.  On the first prompt, type the letter 'b' and hit the <ENTER> key to indicate we want to create an 'Application User'.
	__5.  On the second prompt, hit the <ENTER> key to accept the default option of 'ApplicationRealm' for the security realm.  This is the name of the security realm already defined in the JBoss server so using this ensures we do not have to change any other JBoss configuration.  
	__6.  Enter a username of 'bob'.
	__7.  Type the following password for both prompts that ask you to enter a password. Note that the program will not even show stars while you type.
	__8.  When prompted for the roles the user should belong to, enter 'Customer' (with a capital 'C') and  hit the <ENTER> key.
	__9.  Type 'yes' and  hit the <ENTER> key to confirm you want to add the 'bob' user to the 'ApplicationRealm'.
	__10.  Hit any key to let the program finish and return you to the command prompt.
	__11.  Close the command prompt.

	Part 2 -  Secure the Quote Service
	__1.  Back in Eclipse, in the AcmeWeb project expand com.acme.services package.
	__2.  Open QuoteService.java.
	__3.  Add the following annotation in bold to the class.
	__4.  Organize imports. 
	__5.  Save changes.
	__6.  In the AcmeWeb project expand the AcmeWeb\WebContent\WEB-INF folder.
	__7.  Double click the web.xml file to open it in an editor and view the source.
	__8.  Add the XML in bold below to the end of the file but within the end '</web-app>' tag.  Pay particular attention to the values of the XML elements because the Eclipse validation will only pick up errors in the structure of the elements themselves and not in the contained values.
	__9.  Save and close the file after making sure there are no errors.
	__10.  Back in the AcmeWeb project, right click the WEB-INF folder and select 'New → File'.
	__11.  Fill in a file name of 'jboss-web.xml' and check that the file will be created in the AcmeWeb\WebContent\WEB-INF folder.
	__12.  Click the Finish button when your settings for the new file match above.
	__13.  In the empty file that opens in the editor, switch to the Source view with the tab along the bottom of the editor.
	__14.  Add the following XML that will link the application to the default security domain (which has a name of 'other').
	__15.  Save and close the file.
	__16.  Close all open files.

	Part 3 -  Test
	__1.  Publish and start the server.
	__2.  Open a browser and enter the URL: 
	__3.  Enter some data and then click the Get Quote button.
	__4.  The browser will show an error.
	__5.  Close the browser.

	Part 4 -  Modify the Test Client
	__1.  Launch the RESTClient tool if it is not already running.  
	__2.  In the URL text box, enter: 
	__3.  Select POST method.
	__4.  Click the Body tab.
	__5.  Click the  icon to open the file. Click Yes to erase the existing code if any.
	__6.  Select C:\LabFiles\quote_request.xml and open it. Click 'Yes' when the tool offers you an option to change the MIME type to application/xml. 
	__7.  Click the  icon next to the URL.
	__8.  Make sure that the HTTP reply status code is 401.
	__9.  Click the Auth tab in the 'HTTP Request' section of the tool.
	__10.  Enter these values:
	__11.  Run the test again.
	__12.  Verify that status code 200 is returned.  You can check the body of the response as well but the status code alone should be able to tell it is working.

	Part 5 -  Enable Audit Logging
	__1.  In the AcmeWeb project, open OrderService.java.
	__2.  Configure the valid role for the service as shown in bold face below.
	__3.  Add a member variable to the class as follows.
	__4.  In the placeOrder() method, add the following bold code below the line to create the order:
	__5.  Organize imports and select the 'javax.ws.rs.core.SecurityContext' class.
	__6.  Save changes.
	__7.  Publish the server.

	Part 6 -  Test
	__1.  Launch the REST test client if it is not already running.
	__2.  Select File > Open Request from the menubar.
	__3.  Open C:\LabFiles\order_create.rcq
	__4.  Click the  button to send the request.
	__5.  Make sure that a status code 401 is returned.
	__6.  Click the Auth tab.
	__7.  Enter these values:
	__8.  Run the test again.
	__9.  Verify that status code 201 is returned.
	__10.  Check Eclipse console for the audit log. It will look like this:
	__11.  Close all open browsers.
	__12.  Close all open files.
	__13.  Close REST client.
	__14.  Stop the server.

	Part 7 -  Review




