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Lab 1 - Configure the Development Environment
Throughout these labs, you will be developing web service components with two main 
pieces of software: Oracle WebLogic Server v12c and Oracle Enterprise Pack for 
Eclipse(OEPE).

Oracle WebLogic Server v12c(12.1.1) (WLS) is a JEE application server that serves up 
JEE applications, and is also a web service container. 

OEPE, Provides tools that make it easier to develop applications utilizing specific Oracle 
Fusion Middleware technologies and Oracle Database.  Based on the Eclipse tool, it is the 
programming environment we will use for this class. 

In this lab exercise, we will configure WLS and OEPE to form our development 
environment. 

Part 1 - Oracle WebLogic server Setup
WebLogic Server is already extracted into C:\Software\WebLogic folder.

In this part we will setup necessary Environment variables and run installation 
configuration script.

Follow the instructions to set up JAVA_HOME, MW_HOME and JAVA_VENDOR 
environment variable

JAVA_HOME=C:\Software\Java

MW_HOME=C:\Software\WebLogic

JAVA_VENDOR=Oracle

__1. Right click on the My Computer icon on your computer and select properties. 

__2. Click the Advanced Tab. In Windows 7 click the Advanced system settings link.

__3. Click the Environment Variables button. 

__4. From the System Variables list, select Path and click Edit.

__5. At the beginning of the line enter the following:

C:\Software\Java\bin;
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__6. Click OK.

__7. Under System Variables, click New. 

__8. Enter the variable name as JAVA_HOME

__9. Enter the variable value as the install path for the Development Kit. 

C:\Software\Java

__10. Click OK. 

__11. Repeat these steps for MW_HOME variable.

C:\Software\WebLogic

__12. Repeat these steps for JAVA_VENDOR variable.

Oracle

Once all done it should look like.

__13. Click OK until you close all windows.

Now you will run the installation configuration script in the MW_HOME directory. It 
should be run only once.

__1. Open a Windows command prompt.  You can do this by selecting 'Start -> Run', 
entering 'cmd', and then pressing the OK button.

__2. Change the directory to C:\Software\WebLogic
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__3. Enter configure.cmd and hit Enter.

It takes few minutes to complete. 

You will get a notification when the installation is done.

__4. Close the command prompt window.

__5. Restart the machine.

__1. Open a Windows command prompt.  You can do this by selecting 'Start -> Run', 
entering 'cmd', and then pressing the OK button.

__2. Enter the following command:

java -version

Make sure you see the response shown below.

__3. Enter the following command:

javac
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Verify that you get the options to run the Java compiler:

__4. Close the command prompt window. 

Part 2 - Configure a server in OEPE
We now need to configure OEPE to be able to communicate with WLS.  Doing so will 
allow us to perform simple operations with the server (e.g. Starting, stopping and 
deploying applications).  While this is not strictly necessary for a development 
environment, it significantly simplifies development time. In order to setup the server we 
should also need to create a domain.

As with WLS, OEPE has already been installed on your computer.  We just need to 
configure it. 

__1. Start OEPE by launching C:\Software\OEPE\eclipse.exe

OEPE will launch.

You will be prompted to select a Workspace. 

__2. Set the Workspace to C:\workspace

__3. Click OK.
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OEPE will start. 

As mentioned earlier, OEPE is built on top of Eclipse.  If you are familiar with Eclipse, 
you should have no problems using OEPE.  

__4. WTP is displaying the Welcome screen (or view).  Close the view by clicking the x 
in its tab.  

__5. From the menu, select Window > Open Perspective > Java EE.

OEPE will then show the Java EE perspective. (A perspective is a collection of views)

__6. Select Windows | Preferences.
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__7. Expand Server | Runtime Environments.

__8. Click Add...

__9. Expand  Oracle and select Oracle Weblogic Server 12c(12.1.1)

__10. Click Next.
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__11. For Weblogic home, enter C:\Software\WebLogic\wlserver or browse to find the 
location. 

__12. Similarly enter C:\Software\Java for Java home.

__13. Click Finish.

__14. Click OK.

__15. We need to create domain and configure OEPE to point at the domain.  Locate the 
Server view. To do this, click the Servers tab in the bottom area of OEPE.

__16. Right click anywhere in the area and select New | Server.
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The New Server window will appear. 

__17. Select Oracle WebLogic Server 12c.

__18. Click Next.

__19. Next to Domain directory, click the create icon and then select Create Domain.

__20. Enter LabDomain as the name. 
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__21. Check specify password and enter w1sadmin as password where the password 
contains number one not L. 

__22. Don’t select any extensions, because we will not be using any of the advanced 
features like WS-Addressing.

__23. Click Finish.

__24. After some seconds the below screen will open, make sure Disable Automatic 
Publishing to server is checked.

__25. Click Finish.

The server connection has been defined, and the server should now be listed in the 
Servers view.
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Part 3 - Working with the Server
Throughout this class, we will be using this view to perform 3 basic operations: server 
stop, start and publish.  We will discuss publishing in a later lab, so let us now focus on 
starting and stopping the server. 

__1. Turn off the Firewall to avoid messages.

__2. Let us start things off by starting the server.  In the Servers view, right click on the 
server and select Start.

The Console view should automatically open.  This will allow us to “see” OEPE booting. 
Eventually, the server will start and the Servers view will be brought to the focus again.  

After finish publishing the server State should be Started.

__3. Examine the Console window by clicking the Console tab. 

In later lab steps, when we ask you to refer to the server console, this is the view we will 
be referring to.  

__4. Let us try stopping the server.  Go back to the Servers view. 

__5. Right click on the server and select Stop.

As with starting the server, the console view will open briefly.  Then the Server view will 
appear, listing the status as Stopped.

You have stopped the server.
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Part 4 - Review
In this lab, you configured the development environment.  

You started things off by configuring environment followed by WebLogic Server domain 
creation and server setup, which will be used to host our web service applications.

You saw how to start and stop a WebLogic Server instance. 
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Lab 2 - Introduction To Web Services
In this lab, you will review some of the key components of Web Services, namely, WSDL 
and SOAP. You will also get a chance to see a Web Service in action. The goal of this lab 
is to get yourself familiar with what a Web service looks like. We will not get into too 
much detail at this point; just walk away with a basic understanding of the components 
involved in a web service.

The web service in question is very simple. It has one operation called sayHello. It takes 
as input a person's name (say "John") and returns as output a greeting message (say, 
"Hello John").

Part 1 - Create a Web Service Project 
__1. Right-click anywhere inside the Project Explorer view (the pane on the left) and 
select New → Web Service Project.

The New Web Service Project screen will appear.
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__2. For Project name, enter HelloWS, accept other defaults.

__3. Click Finish. 

The HelloWS project node appears in the Project Explorer pane.

Part 2 - Create a WebLogic Web Service 
__1. Right-click the just created HelloWS project and select New → WebLogic Web 
Service.
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The New Web Service screen will appear.

__2. For Package, enter com.webage.svc 

__3. For Name, enter HelloSvc

__4. Click Finish.

The HelloSvc.java file will be auto-generated and loaded in the Eclipse's Java text editor.

package com.webage.svc;

import javax.jws.*;

@WebService
public class HelloSvc {

@WebMethod
public void hello() {
}

}

__5. Update the hello() method to match the following code snippet:

@WebMethod
public String sayHello(String name) {

return "Hello " + name;
}

__6. Save the file.

We renamed the method to be called sayHello(), and now it accepts name as a String 
input parameter and returns a String value.
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__7. Examine the HelloSvc module.  Note the following aspects of the code:

● By default, the Java method that implements a Web Service operation has the 
same name as the operation.

● The @WebService annotation is used to designate the HelloSvc class as a Web 
Service implementation.

● The @WebMethod annotation is used for the sayHello() method to designate it 
as a Web Service operation. These annotations are made available as part of the 
JAX-WS specification and are packaged under the javax.jws.* package.

__8. Click the two yellow arrows icon on the Project Explorer tab to synchronize the 
HelloSvc.java file with its location in the HelloWS project.

You should see the following screen.

Part 3 - Generate the WSDL File 
As you know, a WSDL file is used to describe what a web service can do and what type 
of input and output data it works with.  Let us generate and then inspect the WSDL file 
for our service.

__1. Right-click the HelloSvc.java icon in the Project Explorer pane and at the bottom of 
the pop-up menu select WebLogic Web Services → Generate WSDL.

The WSDL Destination screen will appear.

__2. Select the WebContent folder for its storage destination.
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__3. Click OK.

Wait for the jwsc task to complete generation of WSDL file and the related XSD schema.

__4. Expand the WebContent folder in the Project Explorer and double-click the 
HelloSvcService.wsdl file.

The file will open in the Eclipse WSDL editor, which shows a diagram of the service's 
WSDL file. 
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__5. This looks daunting, but we will return to it in more detail in a later lab.  For now, 
click the Source tab at the bottom of the WSDL editor to switch to the text view of the 
document.

The raw XML source code of the WSDL editor will be visible. 

To be honest, this looks even more frightening than the diagram view.  Do not worry 
about it for now, though.

__6. Locate the <portType> element of the file.  This describe the Web Service. Note 
that an <operation> element exists with the name attribute set to "sayHello".

__7. Notice the <input> and <output> elements within <operation>.  They describe the 
format of the input and output data for the operation.
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Also notice that our auto-generated WSDL file references the 
HelloSvcService_schema1.xsd schema file (that defines the XML types used in our Web 
Service) via the schemaLocation attribute of the import element (<xsd:import 
namespace="http://svc.webage.com/" schemaLocation="HelloSvcService_schema1.xsd"/>).

At the bottom of the HelloSvcService.wsdl file, you will see the following line with a 
placeholder for the actual Web Service end-point:

      <soap:address location="REPLACE_WITH_ACTUAL_URL"/>

The absence of the real location will, among other things, prevent us from testing our 
Web Service from inside Eclipse.  We are going to fix it in a moment.

Keep the HelloSvcService.wsdl file in the editor window as we will need after we have 
deployed our project on the server.

Part 4 - Deploy the Project to Oracle WebLogic Server 
__1. Locate the Servers view.

Let's add our HelloWS project to it.

__2. Right-click the server and select Start. 

Wait until it is started.

__3. Right-click the server listed and select Add and Remove...
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__4. The Add and Remove … window will appear. In the left pane, select HelloWS and 
click the Add> button.  This will move it to the right pane.  

__5. Click Finish. Wait until publishing is done.

Remember these steps as you will be deploying projects to the server repeatedly 
throughout this course.

__6. Back in the Servers view, expand the server and you should see the project we just 
added.

__7. Open your browser and navigate to

http://localhost:7001/HelloWS/HelloSvcService?WSDL

You should see a copy of the auto-generated WSDL file in your browser window.  

Note: This WSDL file is not the one we generated in one of previous steps.  Oracle 
WebLogic Server performed class introspection and generated one more copy of the 
WSDL file.  What we did this for is to show your one way to get the actual location of the 
SOAP end-point URL.

__8. Scroll to the bottom of the WSDL file and copy the location of the SOAP end-point, 
which is http://localhost:7001/HelloWS/HelloSvcService

__9. Close the browser.
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Part 5 - Testing the Web Service
We should now be able to test the service.  Testing the service would imply actually 
invoking the operation.  

Typically, doing so would require that we create a web service client.  A web service 
client is, as its name implies, any program that makes a call to a web service.  The 
program could be written in Java, .NET, or any other language that understands web 
service standards. 

Writing a client can be time consuming, so we will “cheat” and use a tool built into 
Eclipse called the Web Services Explorer (WSE).  The WSE works by reading a WSDL 
file and then figuring out what services are available and how to invoke them.  The WSE 
will then dynamically generate a form that represents the service's operations that will 
allow you to invoke it.

Think about this for a moment: our service, at its core, was a single operation called 
sayHello which took a single string as a parameter.  The service would then return a 
greeting based on that parameter.

Let's see how to work with WSE. But first let's fix our Web Service SOAP end-point 
URL.

__1. Switch back to the Eclipse. IDE. 

You should have the text editor open on HelloSvcService.wsdl.

__2. Replace the REPLACE_WITH_ACTUAL_URL placeholder located at the bottom 
of the HelloSvcService.wsdl file,with the actual SOAP end-point URL: 
http://localhost:7001/HelloWS/HelloSvcService

__3. Save the file (Ctrl-S).

Now it is the Web Services Explorer (WSE) show time!

__4. In Project Explorer, right-click the HelloSvcService.wsdl file and select Web 
Services → Test with Web Services Explorer 

The Web Services Explorer window will open. 

You may want to expand the Web Services Explorer window to get a better view of it. 
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For that, double-click the Web Services Explorer window's tab.  Note: For bringing the 
window back to the original size, double-click the tab again.

__5. Inside the Web Services Explorer window, double-click the HelloSvcService node.

The WSDL Service Details panel opens showing the link to the HelloSvcPortBinding 
element.

__6. Click the HelloSvcPortBinding link.

The WSDL Binding Details panel opens.

__7. Click the sayHello operation. 

__8. Click the Add link to add the name parameter (registered as arg0 parameter) to the 
sayHello operation. 

23

EVALUATIO
N O

NLY



__9. In the input box that opens, enter your name (example below uses Mike). 

__10. Click Go.

The Status pane should now appear immediately below the pane in which you entered the 
argument. 

__11. Check the Status pane's content at the bottom of the WSE.

You should see the Hello Mike message returned from the sayHello() operation.

Just to remind you, the code that generated this message is: 

@WebMethod
 public String sayHello(String name) {
     return "Hello " + name;
 }

When we invoked the sayHello operation, WSE actually sent a SOAP formatted XML 
document to the server using the HTTP protocol. The server also replied back using a 
SOAP formatted XML document. SOAP is a versatile data format for request response 
type communication. In its most basic form, as is the case in this lab, it is utterly simple. 
At the same time, it is capable of taking on more advanced aspects of communication, 
such as, encryption, message signature, transaction and guaranteed delivery.

You can also view the actual SOAP request and response messages as exchanged between 
the client (WSE) and the server.  For that you will need to switch from the Form view 
(the current one) to the Source view.
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__12. In the top right-hand corner of the Status panel, click the Source link.

__13. Double-click Status to maximize the window.

You should see the following captured SOAP client request (originated from the WSE 
when we clicked the Go button) and the Oracle WebLogic Server's response.

__14. Briefly inspect the request and response messages as shown above. Don't worry 
about the details. You will learn SOAP shortly.

__15. Click the Form link (which dynamically replaced the Source link) to go back to the 
original Status view. 

Congratulations!  You have successfully examined the source code for a web service, and 
then invoked it via the WSE. 

__16. Close the WSE by clicking the X in its pane. 

__17. Close all open editor windows by pressing Ctrl+Shift+W.

__18. Stop the server.  To do this, open the Servers view, right-click on the server listed 
and select Stop.
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Part 6 - Review
In this lab, you had a brief encounter with a web service. First, we looked at the Java 
class that implements the business logic of the Web Service. That is the true meat behind 
the Web Service. When building a Web Service, you will probably spend most of the time 
writing the business logic. Next, we inspected the WSDL file that describes the nature of 
the Web Service. After that we tested the Web Service and inspected the SOAP messages.

The lab also served two other purposes. You learned how to deploy an application to the 
server. We will do that frequently throughout these lab exercises. You also found out how 
to use the Web Services Explorer to quickly unit test a Web Service.
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Lab 3 - Creating an XML Schema in Eclipse
An XML schema is used to verify that the contents of an XML file are valid; essentially, 
it is a set of “rules” for an XML file.  A particular XML file can be checked against a 
particular schema, and a parser can decide if the XML conforms to the rules set out in the 
schema.  

If, for some reason, the XML does not conform to the schema, the XML parser can reject 
the XML and raise an immediate error.  Essentially, schema adds a layer of validation to 
any XML-based application. Given that web services use XML as their communication 
layer, we can see the value of schema.  Schema are actually used quite frequently in the 
various layers of web service communication.

In this lab, we will create an XML schema.

Part 1 - The Movie.xml File
Throughout these labs, we will be developing a system that deals with movies.  We have 
thus decided to model a movie as an XML file.  This modeling will come in handy when 
we start building the web service. 

__1. Let us start things off by taking a look at a sample movie.xml file.  Using a text 
editor, open file C:\LabFiles\movie.xml

It looks like the following: 

<?xml version="1.0" encoding="UTF-8"?>
<m:database xmlns:m="http://www.mycom.com/movie">

<movie title="Preaching to the Choir" rating="PG13">
<description>
Two estranged brothers -- one a hip-hop star and
the other a Baptist preacher -- find a way 
to make amends and help one another out as 
they each face a crisis in their lives.
</description>
<actor>Billoah Greene</actor>
<actor>Novella Nelson</actor>

</movie>
<movie title="Kekexili: Mountain Patrol" rating="PG13">

<description>
A moving true story about volunteers protecting
antelope against 
poachers in the severe mountains of Tibet.
</description>
<actor>Zhang Lei</actor>
<actor>Qi Liang</actor>

</movie>
</m:database>
<!-- Contains some copyrighted material from imdb.com -->
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Let us analyze this XML file.

The outermost element is called <database> and it contains multiple <movie> elements. 

Each <movie> has two attributes; one called title and one called rating, which reflects a 
movies title and rating respectively. 

Additionally, each <movie> has a single child element called <description> (which 
contains a description of the movie in question) and multiple elements called <actor>, 
with each one representing an actor in the associated movie. 

This is a fairly simple modeling of the movie.  We capture some important information 
about each movie (the title, the description, the rating and the actors), and store this 
information using a mixture of attributes and child elements. 

What we should do now is formalize this model by creating an schema for the 
<database> element (remember that the root element here is <database>, not <movie>).

Once that is done, an application reading/writing one of these movie XML files will be 
able to use the schema to validate that the structure of the XML is good.  (Validating the 
content of the XML, however, is another matter completely).

__2. Close the text editor.

Part 2 - Create the Project
A schema is itself an XML file, and we could create it using a text editor.  However, 
Eclipse IDE provides some nice tools for creating and authoring a schema, so we will use 
those instead. 

__1. We will now create a new project to hold our schema file.  From the Eclipse menu 
bar, select File | New | Project...

__2. The New Project window will appear.  In the list, select Java | Java Project and 
click Next.
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__3. The New Java Project screen will appear. Set the Project name to be XMLProject 
and click Finish.

__4. You will be prompted if you would like to switch to the Java Perspective.

__5. Check Remember my decision and click No.

The XMLProject project node will be created and displayed in the Project Explorer pane 
of the Enterprise Explorer view.

We should create a folder to hold our XML resources. 

__6. Right-click on the newly created XMLProject and select New | Folder.

__7. The New Folder window will appear.  Set the Folder name to be xml and click 
Finish.

The folder will be created, and should be visible under the project.

Part 3 - Create the Schema
We can now create the schema.

__1. Right click on the newly created xml folder and select New | Other...

__2. The New window will appear. Scroll down and expand XML.  

__3. Select XML Schema File and click Next.

__4. The Create XML Schema window will appear.  Set the File name to be movie.xsd 
and click Finish. (By convention, schemas always have an XSD extension).
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The XML Schema Editor will open.  This is Eclipse's graphical XSD schema editor which 
will save us having to create the schema by hand.  

We will be using this editor to design our schema.  

First, we should change the schema's default name space which is currently set to 
http://www.example.org/movie as can be seen at the top of the editor.

__5. Right-click on this area and select Show properties.

Now, at the bottom of the Eclipse IDE, the Properties view should have opened.

__6. Here, change the Prefix to m

__7. Change the Target namespace to http://www.mycom.com/movie

We should also specify that by default, the namespaces are not qualified.  
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__8. Click the Advanced tab in the left.

__9. Change the Prefix for Elements and Prefix for Attributes drop down controls to a 
blank.

__10. Save changes by hitting Ctrl-S.

The editor should update with the new namespace.

We can now go about defining the types that make up this schema.  The core type 
represents the movie data, which we will call the movieType.  (The other type is the 
<database>, which is composed of multiple movieType elements – we will get to that 
later).

We will get started defining the movieType.   Recall that we want the movieType to 
model rating, description, title and multiple actors as a combination of attributes and 
elements.

__11. Right click inside the Types pane and select Add Complex Type.

__12. A new type will appear.  Change its name to movieType

The type has been defined.  We now need to specify what data it contains.  

__13. Double click on the newly created movieType.
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The view will change to a closeup of the movieType type.  

It is from here that we can add elements/attributes.  Let us add the description element 
first.   

__14. Right-click on the movieType and select Add Element.

__15. A new element box will appear.  Rename it to description

Notice that the type for description was automatically set to string.  This is fine because 
we want our description modeled as a string.

We have now just declared that our schema defines a type called movieType which itself 
has an element called description of type string.

Now, we can add the actor element. 

__16. Right click on movieType  and again select Add Element.  

__17. This time, name it actor

Recall however, that our movie should have one or more actor elements associated with 
it.  We can specify that here in the schema by using multiplicity
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__18. Right click on the actor element and select Set Multiplicity | 1..* (One or more)

In the General tab of the Properties view for actor the minimum and maximum 
occurrence will change.

Now we can add the rating and title attributes.

__19. Right click on movieType and select Add Attribute.

__20. Name the attribute title

__21. Repeat this step and add another attribute called rating

The movieType element should now look like this.

__22. Save the schema file (Ctrl-S).

As discussed earlier, a movieType has attributes for title and rating and elements for 
description and multiple actors (all of these are of type string).

We now need to define a database element that contains multiple instances of this 
movieType.  

__23. Go back to the main schema design page by clicking the icon in the top left corner.
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__24. Back at the main schema page, the movieType should be shown.

__25. Right click in the Elements pane (on the left) and select Add Element.

__26. Name it database

Let us now define that a database is composed of multiple movie elements. We will do 
so using an anonymous type.  

__27. Right click on database and select Set Type | New...

The New Type window will appear.
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__28. Check Create as local anonymous type.   This will grey out the Name field. 

__29. Click OK.

Seemingly, nothing will change.  

__30. Double click on database.

We see that the database element points to something called a (database type).  This is 
an anonymous field, which means is basically just a placeholder for another element type 
– like our movie!  (Using anonymous types can simplify schema).

We should now specify that the (databaseType) points to multiple movie elements.

__31. Right click on (databaseType) and select Add Element.

__32. A new element will be created.  Name the element movie

__33. We know there are multiple movies, so we should set the multiplicity.  Right click 
on movie and select Set Multiplicity | 1..* (One or more)

__34. Click the database element to refresh the diagram.

One more thing. We have to set the type of each movie element to be movieType.
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__35. Double click on string and a drop-down box should appear. 

__36. Select Browse... from the drop-down box. 

The Set Type window will appear.

__37. In the Name field, enter movieType (or scroll through the list and select it) 

__38. Click OK.
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The editor will now show the association between the <movie> element and the 
movieType.

We are done! 

__39. Hit Ctrl-S to save changes.

We have completed creating the schema.

Part 4 - Examine the Schema
We have now successfully created a schema using the Eclipse schema editor tool.  The 
tool generated all the necessary code for us; let us take a look at it now.  

__1. Click the Source tab at the bottom of the schema editor. The raw source code 
forming the schema will be displayed.  It should look like the following:

<?xml version="1.0" encoding="UTF-8"?>
<schema targetNamespace="http://www.mycom.com/movie" 
xmlns="http://www.w3.org/2001/XMLSchema" xmlns:m="http://www.mycom.com/movie">

    <complexType name="movieType">
    <sequence>
       <element name="description" type="string"></element>
       <element name="actor" type="string" maxOccurs="unbounded"     

minOccurs="1"></element>
    </sequence>
    <attribute name="title" type="string"></attribute>
    <attribute name="rating" type="string"></attribute>
    </complexType>

    <element name="database">
    <complexType>
    <sequence>
       <element name="movie" type="m:movieType" 
maxOccurs="unbounded" minOccurs="1"></element>
    </sequence>
    </complexType>
    </element>
</schema>

Notice that the schema itself is written in XML. 

__2. Go through it and mentally understand what is being described here.

We state that a database is composed of 1 or more movie elements.  Each movie element 
is of type movieType.

A movieType is composed of elements representing description and 1 or more actor, 
and attributes representing the title and rating. 
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If you compare this with the movie.xml we examined at the start of this lab, you should 
realize that movie.xml indeed conforms to the rules set out in the schema.  

Now, when an XML parser reads movie.xml, it can automatically check with this xsd to 
ensure it is valid.  We will use this schema in later labs in exactly this manner.

__3. Close the schema editor. 

Part 5 - Review
In this lab, you examined XML schema. 

We started off by examining an XML file that gave us an idea of how to represent a 
movie.  

We then created a schema to formalize these rules of representation.  We used the 
Eclipse's schema editor to create the XSD file and in there defined the various elements 
and attributes that should make up a movie database.

Finally, we examined the raw XML source behind the schema to get a feel for what it 
describes, and saw that it indeed validates the movie.xml that we started off with.
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	Lab 1 -  Configure the Development Environment
	Part 1 -  Oracle WebLogic server Setup
	WebLogic Server is already extracted into C:\Software\WebLogic folder.
	In this part we will setup necessary Environment variables and run installation configuration script.
	Follow the instructions to set up JAVA_HOME, MW_HOME and JAVA_VENDOR environment variable
	JAVA_HOME=C:\Software\Java
	MW_HOME=C:\Software\WebLogic
	JAVA_VENDOR=Oracle
	__1.  Right click on the My Computer icon on your computer and select properties. 
	__2.  Click the Advanced Tab. In Windows 7 click the Advanced system settings link.
	__3.  Click the Environment Variables button. 
	__4.  From the System Variables list, select Path and click Edit.
	__5.  At the beginning of the line enter the following:
	__6.  Click OK.
	__7.  Under System Variables, click New. 
	__8.  Enter the variable name as JAVA_HOME
	__9.  Enter the variable value as the install path for the Development Kit. 
	__10.  Click OK. 
	__11.  Repeat these steps for MW_HOME variable.
	__12.  Repeat these steps for JAVA_VENDOR variable.
	__13.  Click OK until you close all windows.
	__1.  Open a Windows command prompt.  You can do this by selecting 'Start -> Run', entering 'cmd', and then pressing the OK button.
	__2.  Change the directory to C:\Software\WebLogic
	__3.  Enter configure.cmd and hit Enter.
	It takes few minutes to complete. 
	__4.  Close the command prompt window.
	__5.  Restart the machine.
	__1.  Open a Windows command prompt.  You can do this by selecting 'Start -> Run', entering 'cmd', and then pressing the OK button.
	__2.  Enter the following command:
	__3.  Enter the following command:
	__4.  Close the command prompt window. 

	Part 2 -  Configure a server in OEPE
	__1.  Start OEPE by launching C:\Software\OEPE\eclipse.exe
	__2.  Set the Workspace to C:\workspace
	__3.  Click OK.
	__4.  WTP is displaying the Welcome screen (or view).  Close the view by clicking the x in its tab.  
	__5.  From the menu, select Window > Open Perspective > Java EE.
	__6.  Select Windows | Preferences.
	__7.  Expand Server | Runtime Environments.
	__8.  Click Add...
	__9.  Expand  Oracle and select Oracle Weblogic Server 12c(12.1.1)
	__10.  Click Next.
	__11.  For Weblogic home, enter C:\Software\WebLogic\wlserver or browse to find the location. 
	__12.  Similarly enter C:\Software\Java for Java home.
	__13.  Click Finish.
	__14.  Click OK.
	__15.  We need to create domain and configure OEPE to point at the domain.  Locate the Server view. To do this, click the Servers tab in the bottom area of OEPE.
	__16.  Right click anywhere in the area and select New | Server.
	__17.  Select Oracle WebLogic Server 12c.
	__18.  Click Next.
	__19.  Next to Domain directory, click the create icon and then select Create Domain.
	__20.  Enter LabDomain as the name. 
	__21.  Check specify password and enter w1sadmin as password where the password contains number one not L. 
	__22.  Don’t select any extensions, because we will not be using any of the advanced features like WS-Addressing.
	__23.  Click Finish.
	__24.  After some seconds the below screen will open, make sure Disable Automatic Publishing to server is checked.
	__25.  Click Finish.

	Part 3 -  Working with the Server
	__1.  Turn off the Firewall to avoid messages.
	__2.  Let us start things off by starting the server.  In the Servers view, right click on the server and select Start.
	__3.  Examine the Console window by clicking the Console tab. 
	__4.  Let us try stopping the server.  Go back to the Servers view. 
	__5.  Right click on the server and select Stop.

	Part 4 -  Review

	Lab 2 -  Introduction To Web Services
	Part 1 -  Create a Web Service Project 
	__1.  Right-click anywhere inside the Project Explorer view (the pane on the left) and select New → Web Service Project.
	__2.  For Project name, enter HelloWS, accept other defaults.
	__3.  Click Finish. 

	Part 2 -  Create a WebLogic Web Service 
	__1.  Right-click the just created HelloWS project and select New → WebLogic Web Service.
	__2.  For Package, enter com.webage.svc 
	__3.  For Name, enter HelloSvc
	__4.  Click Finish.
	__5.  Update the hello() method to match the following code snippet:
	__6.  Save the file.
	__7.  Examine the HelloSvc module.  Note the following aspects of the code:
	__8.  Click the two yellow arrows icon on the Project Explorer tab to synchronize the HelloSvc.java file with its location in the HelloWS project.

	Part 3 -  Generate the WSDL File 
	__1.  Right-click the HelloSvc.java icon in the Project Explorer pane and at the bottom of the pop-up menu select WebLogic Web Services → Generate WSDL.
	__2.  Select the WebContent folder for its storage destination.
	__3.  Click OK.
	__4.  Expand the WebContent folder in the Project Explorer and double-click the HelloSvcService.wsdl file.
	__5.  This looks daunting, but we will return to it in more detail in a later lab.  For now, click the Source tab at the bottom of the WSDL editor to switch to the text view of the document.
	__6.  Locate the <portType> element of the file.  This describe the Web Service. Note that an <operation> element exists with the name attribute set to "sayHello".
	__7.  Notice the <input> and <output> elements within <operation>.  They describe the format of the input and output data for the operation.

	Part 4 -  Deploy the Project to Oracle WebLogic Server 
	__1.  Locate the Servers view.
	__2.  Right-click the server and select Start. 
	__3.  Right-click the server listed and select Add and Remove...
	__4.  The Add and Remove … window will appear. In the left pane, select HelloWS and click the Add> button.  This will move it to the right pane.  
	__5.  Click Finish. Wait until publishing is done.
	__6.  Back in the Servers view, expand the server and you should see the project we just added.
	__7.  Open your browser and navigate to
	__8.  Scroll to the bottom of the WSDL file and copy the location of the SOAP end-point, which is http://localhost:7001/HelloWS/HelloSvcService
	__9.  Close the browser.

	Part 5 -  Testing the Web Service
	__1.  Switch back to the Eclipse. IDE. 
	__2.  Replace the REPLACE_WITH_ACTUAL_URL placeholder located at the bottom of the HelloSvcService.wsdl file,with the actual SOAP end-point URL: http://localhost:7001/HelloWS/HelloSvcService
	__3.  Save the file (Ctrl-S).
	__4.  In Project Explorer, right-click the HelloSvcService.wsdl file and select Web Services → Test with Web Services Explorer 
	__5.  Inside the Web Services Explorer window, double-click the HelloSvcService node.
	__6.  Click the HelloSvcPortBinding link.
	__7.  Click the sayHello operation. 
	__8.  Click the Add link to add the name parameter (registered as arg0 parameter) to the sayHello operation. 
	__9.  In the input box that opens, enter your name (example below uses Mike). 
	__10.  Click Go.
	__11.  Check the Status pane's content at the bottom of the WSE.
	__12.  In the top right-hand corner of the Status panel, click the Source link.
	__13.  Double-click Status to maximize the window.
	__14.  Briefly inspect the request and response messages as shown above. Don't worry about the details. You will learn SOAP shortly.
	__15.  Click the Form link (which dynamically replaced the Source link) to go back to the original Status view. 
	__16.  Close the WSE by clicking the X in its pane. 
	__17.  Close all open editor windows by pressing Ctrl+Shift+W.
	__18.  Stop the server.  To do this, open the Servers view, right-click on the server listed and select Stop.

	Part 6 -  Review

	Lab 3 -  Creating an XML Schema in Eclipse
	Part 1 -  The Movie.xml File
	__1.  Let us start things off by taking a look at a sample movie.xml file.  Using a text editor, open file C:\LabFiles\movie.xml
	__2.  Close the text editor.

	Part 2 -  Create the Project
	__1.  We will now create a new project to hold our schema file.  From the Eclipse menu bar, select File | New | Project...
	__2.  The New Project window will appear.  In the list, select Java | Java Project and click Next.
	__3.  The New Java Project screen will appear. Set the Project name to be XMLProject and click Finish.
	__4.  You will be prompted if you would like to switch to the Java Perspective.
	__5.  Check Remember my decision and click No.
	__6.  Right-click on the newly created XMLProject and select New | Folder.
	__7.  The New Folder window will appear.  Set the Folder name to be xml and click Finish.

	Part 3 -  Create the Schema
	We can now create the schema.
	__1.  Right click on the newly created xml folder and select New | Other...
	__2.  The New window will appear. Scroll down and expand XML.  
	__3.  Select XML Schema File and click Next.
	__4.  The Create XML Schema window will appear.  Set the File name to be movie.xsd and click Finish. (By convention, schemas always have an XSD extension).
	__5.  Right-click on this area and select Show properties.
	__6.  Here, change the Prefix to m
	__7.  Change the Target namespace to http://www.mycom.com/movie
	__8.  Click the Advanced tab in the left.
	__9.  Change the Prefix for Elements and Prefix for Attributes drop down controls to a blank.
	__10.  Save changes by hitting Ctrl-S.
	__11.  Right click inside the Types pane and select Add Complex Type.
	__12.  A new type will appear.  Change its name to movieType
	__13.  Double click on the newly created movieType.
	__14.  Right-click on the movieType and select Add Element.
	__15.  A new element box will appear.  Rename it to description
	__16.  Right click on movieType  and again select Add Element.  
	__17.  This time, name it actor
	__18.  Right click on the actor element and select Set Multiplicity | 1..* (One or more)
	__19.  Right click on movieType and select Add Attribute.
	__20.  Name the attribute title
	__21.  Repeat this step and add another attribute called rating
	__22.  Save the schema file (Ctrl-S).
	__23.  Go back to the main schema design page by clicking the icon in the top left corner.
	__24.  Back at the main schema page, the movieType should be shown.
	__25.  Right click in the Elements pane (on the left) and select Add Element.
	__26.  Name it database
	__27.  Right click on database and select Set Type | New...
	__28.  Check Create as local anonymous type.   This will grey out the Name field. 
	__29.  Click OK.
	__30.  Double click on database.
	__31.  Right click on (databaseType) and select Add Element.
	__32.  A new element will be created.  Name the element movie
	__33.  We know there are multiple movies, so we should set the multiplicity.  Right click on movie and select Set Multiplicity | 1..* (One or more)
	__34.  Click the database element to refresh the diagram.
	__35.  Double click on string and a drop-down box should appear. 
	__36.  Select Browse... from the drop-down box. 
	__37.  In the Name field, enter movieType (or scroll through the list and select it) 
	__38.  Click OK.
	__39.  Hit Ctrl-S to save changes.

	Part 4 -  Examine the Schema
	__1.  Click the Source tab at the bottom of the schema editor. The raw source code forming the schema will be displayed.  It should look like the following:
	__2.  Go through it and mentally understand what is being described here.
	__3.  Close the schema editor. 

	Part 5 -  Review

	Lab 4 -  JAXB Programming
	Part 1 -  Generating the Bindings
	__1.  Right click XMLProject and select Refresh.
	__2.  Expand the xml folder of the XMLProject.
	__3.  Right click the movie.xsd file and select Generate → JAXB Classes ...
	__4.  In the New JAXB Classes from schema dialog that opens, for Package, enter com.jaxb.movie  as shown below and click the Finish button.  
	__5.  Click Yes
	__6.  Expand the src folder of project XMLProject. 
	__7.  A newly created package com.jaxb.movie should appear.  Expand it and you should see the generated JAXB binding classes.

	Part 2 -  Use the Binding Classes To Read XML
	__1.  Right click XMLProject and select New > Package.
	__2.  Enter com.mycom.test as the Name and click Finish.
	__3.  Right click the com.mycom.test package ans select New > Class.
	__4.  Enter JAXBMoviePrinter as Name.
	__5.  Check the Public static void main check box.
	__6.  Click Finish.
	__7.  (If you have trouble typing in the following code, we have provided the completed class source code at C:\LabFiles\JAXBMoviePrinter.java.solution  Feel free to copy and paste if necessary).
	__8.  In the main method, we first need to setup the unmarshaler. Add the following code to the main method. 
	__9.  There are some errors in the code.  To fix a few of them, perform an Organize imports. (Ctrl + Shift + O) , selecting javax.xml.bind.Unmarshaller if prompted. After you do this, you will still see some errors, but ignore them for now.  
	__10.  Recall that in our schema, that “top-most” element was database.  If you look at the generated binding classes, you will notice that a Database class was created.  We can use the unmarshaler to create an instance of this object.  Add the following code:
	__11.  Fix this by performing an Organize Imports  which is done by typing Ctrl-Shift-O. Select java.io.File if prompted.  There will still be some errors.  Do not worry about them for now. 
	__12.  Remember that a <database> element contained several <movie> elements. Similarly, the database object will have a field that represents a list of MovieType objects.  We can get this list.  Add the following code:
	__13.  We now have a hold of the list of movies that the database was keeping track of.  We can iterate through it, and operate on it!  Let us simply go through the list and print the title of each movie.  Add the following code:
	__14.  Organize imports again, by hitting Ctrl-Shift-O. Select java.util.List when prompted.
	__15.  Select all the code in the main method (but not the method declaration). 
	__16.  Right click on it and select Surround With->Try/catch block.
	__17.  Save the code.

	Part 3 -  Test JAXB
	__1.  Right click on the code and select Run As > Java Application.
	__2.  Close all open editors.

	Part 4 -  Review

	Lab 5 -  Create A Bottom Up JAX-WS Web Service
	Part 1 -  Reviewing the JAX-WS Annotations
	__1.  In Eclipse, press Ctrl-Shift-T 
	__2.  In the upper text box of the Open Type dialog, start typing HelloS that will narrow down the matching items in the list below; when you see HelloSvc type as shown in the screen below, press Enter. 
	__3.  The Java text editor opens on HelloSvc.java.
	__4.  Comment out the following three lines:
	__5.  Save the file. 
	__6.  Uncomment the JAX-WS annotations and the import statement in HelloSvc (you can undo the previous commenting out operations by pressing Ctrl-Z).
	__7.  Save the code.  There should be no errors.

	Part 2 -  Change the Implementation
	__1.  Switch back to the Project Explorer view where you have HelloSvc.java opened in the editor. 
	__2.  Update the @WebService annotation of the class to look like the following:
	__3.  Now, let us fix the arg0 problem.  Add the following annotation to the parameter of the sayHello method, as follows in bold:
	__4.  Organize imports.  There should be no errors. 
	__5.  Save the file.
	We have updated our implementation class by changing (and adding) annotations.
	__6.  In the Project Explorer, navigate to HelloWS | WebContent.
	__7.  Rename the files located there (click the file name and press F2 to invoke the Rename Resource dialog, enter the new name then press OK):
	__8.  Right-click the HelloSvc.java icon in the Project Explorer pane and at the bottom of the pop-up menu select WebLogic Web Services → Generate WSDL.
	__9.  Select the WebContent folder for its storage destination.
	__10.  Click OK.
	__11.  Expand the WebContent folder in the Project Explorer 
	You should see four files there: the new and old WSDL and XSD files.
	__12.  Select both XSD files (hold the Control button down when you click the files),  then right-click the selection of two files and from the pop-up  menu select Compare With → Each other 
	__13.  Switch back to the WebContent folder in the Project Explorer. 
	__14.  Select both WSDL files (hold the Control button down when you click the files), right-click and from the pop-up  menu select Compare With → Each other 
	__15.  Scroll to the bottom of the Text Compare view where you can see the soap:address element. 
	__16.  Click the  <soap:address location="REPLACE_WITH_ACTUAL_URL"/> line to set focus on it.
	__17.  Click the Copy Current Change from Right to Left arrow in the top right-hand corner of the Compare View.
	__18.  Save the HelloSvcService.wsdl file (Ctrl-S).

	Part 3 -  Testing the Changes
	__1.  Right-click the server and select Start.
	__2.  In Project Explorer, right-click the HelloSvcService.wsdl file and select Web Services → Test with Web Services Explorer 
	__3.  Inside the Web Services Explorer window, double-click the HelloSvcService node.
	__4.  Click the HelloSvcPortBinding link.
	__5.  Click the sayHello operation. 
	__6.  Click the Add link to add the name parameter to the sayHello operation. 
	__7.  In the input box that opens, enter your name (example below uses Mike). 
	__8.  Click Go.
	__9.  Check the Status pane's content at the bottom of the WSE.
	__10.  In the top right-hand corner of the Status panel, click the Source link.
	__11.  Maximize Status pane.
	__12.  Click the Form link (which dynamically replaced the Source link) to go back to the original Status view. 
	__13.  Close the WSE by clicking the X in its pane. 
	__14.  Close all open editor windows by pressing Ctrl+Shift+W.
	__15.  Stop the server.  To do this, open the Servers view, right-click on the server listed and select Stop.

	Part 4 -  Review

	Lab 6 -  Creating A WSDL File
	Part 1 -  Create A WSDL File
	__1.  In the Project Explorer view, right click on HelloWS and select New | Folder.
	__2.  The New Folder window will appear.  Set the Folder name to be wsdl and click Finish.
	__3.  In the Enterprise Explorer view, expand the XMLProject → xml folder.
	__4.  Copy the movie.xsd file.
	__5.  Paste the movie.xsd file into the wsdl folder of the HelloWS project.
	__6.  Right click on the wsdl folder and select New > Other...
	__7.  In the New window that appears, expand Web Services and select  WSDL.
	__8.  Click Next.
	__9.  Set the File name to be movie_service.wsdl
	__10.  Click Next.
	__11.  Set the Target namespace to be http://www.mycom.com/movie
	__12.  Set the Prefix to be m
	__13.  Click Finish.
	__14.  Click the Design tab at the bottom of the editor.  This shows a graphical representation of the WSDL file and is much easier to deal with.  
	__15.  First of all, let us rename the service to something a little more proper.  In the port box (the box on the left), click the title area where movie_service is displayed.  Click the text movie_service and rename it to MovieService; press Enter.
	__16.  Beneath it, in the same manner (i.e. clicking on the text and then renaming it), change movie_serviceSOAP to MovieServiceSOAPPort
	__17.  Let us rename the service first.  In the operation box (the box on the right) click NewOperation and rename it to addMovie
	__18.  Click on parameters next to input and rename it to movieToAdd
	__19.  Click on parameters next to output and rename it to opStatus
	__20.  Click on the right-facing arrow on the far right of the input row.
	__21.  Click the Design tab at the bottom of the editor.  The view will change to show a diagram.
	__22.  Click on the icon in the top left of the editor.
	__23.  In the Directives box, right-click and select Add Include.
	__24.  In the Select XML schema file dialog that opens, leave the default option of Workbench projects and click the Next button.
	__25.  Expand HelloWS → wsdl and select the movie.xsd file.
	__26.  Click the Finish button to create the link to the file.
	__27.  In the Elements area, double click on addMovie.
	__28.  In the box on the right, rename in to movie
	__29.  We now need to set the type.  Double-click on string and expand the dropdown that appears.
	__30.  In the list, click on Browse...
	__31.  In the list, locate movieType and double-click on it.
	__32.  Go back to the main schema view by clicking on the icon in the top left of the editor.
	__33.  In the Elements box, double-click on addMovieResponse. 
	__34.  Rename the out to status
	__35.  We are done!  Save changes by hitting Ctrl-S.
	__36.  Close the Inline Schema of movie_service.wsdl view.  (Leave the other editor, showing movie_service.wsdl open)

	Part 2 -  Examine the Generated WSDL Source
	__1.  Click the Source tab at the bottom of the WSDL editor.
	__2.  The indentation may be a little off; right click anywhere on the source and select Source | Format.
	__3.  Save all the files by pressing Ctrl-Shift-S
	__4.  Close the WSDL editor. 

	Part 3 -  Review

	Lab 7 -  Creating A Top-Down Web Service
	Part 1 -  Creating a Web Service Project 
	__1.  Right-click anywhere in the Project Explorer, and select New → Project … in the pop-up menu. 
	__2.  In the Wizards input text box, type in Web S which will narrow down the available items down to the Oracle WebLogic's Web Service Project option. 
	__3.  Click the Web Service Project item in the lower part of the dialog to set focus and click Next.
	__4.  In the New Web Service Project dialog, enter MovieService for the Project name and click Finish. 

	Part 2 -  Creating a Web Service from the WSDL file 
	__1.  Right-click the newly created MovieService project in the Project Explorer view and select New → Folder. 
	__2.  In the New Folder dialog that opens, enter wsdl for the Folder name and click Finish.  
	__3.  Expand the HelloWS \ wsdl folder and copy the movie.xsd and movie_service.wsdl over to MovieService \ wsdl folder.
	__4.  Expand the MovieService \ wsdl folder
	__5.  Double-click the movie_service.wsdl file to open it in the WSDL editor. 
	__6.  Scroll down the text until you find the 
	__7.  Update the value of the location attribute with the following URL: 
	__8.  Save the file.
	__9.  Right-click the movie_service.wsdl file and in the pop-up menu select WebLogic Web Services → Generate Web Service ...
	__10.  Click Finish. 

	Part 3 -  Examine the Generated Artifacts
	The first file of interest to us is MovieService.java. 
	__1.  In the MovieService_MovieServiceSOAPPortImpl file, find the reference to the  MovieService interface file, press the Control key down and click the MovieService link. 
	__2.  Next, open the MovieType class. 

	Part 4 -  Implement the Web Service Operation 
	__1.  Switch back to the MovieService_MovieServiceSOAPPortImpl file.
	__2.  Set the code for addMovie method as shown in boldface below:
	__3.  Organize imports and select java.util.List when prompted.
	__4.  Save the code.  There should be no errors.

	Part 5 -  Deploy the MovieService Web Service 
	__1.  Start the Server. 
	__2.  Right-click the Server and select Add and Remove …
	__3.  Add the MovieService project. 
	__4.  Click Finish. 

	Part 6 -  Test the Service
	__1.  Right-click the movie_service.wsdl file in the Project Explorer view and select Web Services → Test with Web Services Explorer. 
	__2.  In the Web Services Explorer (WSE) screen, click the addMovie operation in the WSDL Binding Details pane.
	__3.  Enter some sample data.  (To add multiple actors, click the Add button next to actor).
	__4.  Click Go.  The service will be invoked.
	__5.  Close all open files (Ctrl-Shift-W).
	__6.  Stop the Server.

	Part 7 -  Review

	Lab 8 -  Developing A Web Service Client
	Part 1 -  Create the Client
	__1.  From the menu, select File → New → Project.
	__2.  Expand Java and select Java Project and then click Next.
	__3.  Enter WebServiceClientProject as Project name.
	__4.  Click Finish.
	__5.  In the WebServiceClientProject, create a new Java class called StandaloneMovieClient having  com.movie as package with a main method.
	__6.  Start the server.
	__7.  In the Project Explorer, open the wsdl folder of the MovieService project. 
	__8.  Right-click the movie_service.wsdl file located there and select Web Services → Generate Client.
	__9.  For the Service definition, enter http://localhost:7001/MovieService/MovieService?wsdl
	__10.  On the left side of the Web Service Client dialog window, drag the slider down to Assemble Client.
	__11.  On the right, under Configuration, click the link that says Client project: MovieService
	__12.  Change the Client Project drop-down to the newly created WebServiceClientProject Java project, and then click OK.
	__13.  Click Finish.  The stub will be generated. 
	__14.  In the Project Explorer, right-click on WebServiceClientProject and select Refresh.
	__15.  Expand the src folder in WebServiceClientProject.  Notice a new package com.mycom.movie has been created.  This package contains our client stub classes. Expand the package node.

	Part 2 -  Code the Client
	__1.  Open the source for StandaloneMovieClient.java. (which was in the com.movie package in the WebServiceClientProject project)
	__2.  Update the entire main method as follows.
	__3.  Organize imports.  There should be no errors. 
	__4.  Save the file.

	Part 3 -  Run the Client
	__1.  Run the StandaloneMovieClient class as a Java application. To do this, right click anywhere on the source code and select Run As → Java Application.  
	__2.  Switch to the Console for the class by clicking in the icon to display all consoles running and selecting the <terminated> StandaloneMovieClient console.
	__3.  Close all open editor windows.

	Part 4 -  Review

	Lab 9 -  Monitoring SOAP Messages
	Part 1 -  Configure the TCP/IP Monitor 
	__1.  Start the server if it is not running. The server must be running to activate the monitor. 
	__2.  Open the Servers view. 
	__3.  Right-click on the server and select Monitoring → Properties.
	__4.  Click the Add... button.
	__5.  Enter 5678 for the Monitor port, and then click OK.
	__6.  Click OK.

	Part 2 -  Update the Client
	__1.  In Project Explorer, expand the WebServiceClientProject \ src folder.
	__2.  Locate and double-click the MovieServiceLocator.java file in the com.mycom.www.movie package.
	__3.  Locate the following line in the file:
	__4.  Replace the port 7001 with 5678
	__5.  Save the file.
	We are done updating our client.

	Part 3 -  Test
	Let us now invoke the web service instrumented with TCP/IP monitoring.
	__1.  Run the StandAloneMovieClient Java application.
	__2.  Maximize the TCP/IP Monitor view by double-clicking its tab.
	__3.  Change the Byte drop-down value to XML on both panels. This will make the contents of the request / response messages a little easier to read.
	__4.  Examine the request message.
	__5.  Now, look at the response message.
	__6.  Return the TCP/IP Monitor view to its original size by double-clicking on its tab.

	Part 4 -  WS-I Validation
	__1.  In the top right hand corner of TCP/IP Monitor, click the Validate WS-I Message Log File toolbar button.
	__2.  Select MovieService / wsdl folder for destination of the log.wsimsg file.
	__3.  Click Finish.
	__4.  Click OK to dismiss the dialog.
	__5.  Close all open editor windows.
	__6.  Stop TCP/IP monitoring by right-clicking the server in the Servers view and selecting Monitoring → Monitor port 7001 (http).

	Part 5 -  Review

	Lab 10 -  Controlling JAXB Mappings
	Part 1 -  Update the Implementation
	__1.  In the HelloWS project, create a new Java class called  Person  belonging to package  com.beans
	__2.  Add the following two fields to the class.
	__3.  Save the class.
	__4.  In the Outline view (to the right), select both fields.
	__5.  Right click on these selected fields and select Source | Generate Getters and Setters...
	__6.  Click the OK button.  
	__7.  Save the file.  
	__8.  Close it. 
	__9.  Open HelloSvc.java (in the com.webage.svc package).
	__10.  Add the following method to the class:
	__11.  Organize imports.  If prompted, select com.beans.Person and click Finish.
	__12.  Save changes.  There should be no errors.

	Part 2 -  Test the Web service
	__1.  In the HelloWS project, create a person_wsdl folder to keep the generated WSDL and schema files that we will need for testing our updated services. 
	__2.  Right-click the HelloSvc.java file in the Project Explorer pane and at the bottom of the pop-up menu select WebLogic Web Services → Generate WSDL.
	__3.  Select the person_wsdl folder for its storage destination.
	__4.  Click OK.
	__5.  In the HelloSvcService.wsdl, locate the following line:
	__6.  Save the file.
	__7.  Restart the server. Wait until finish synchronizing.
	__8.  In Project Explorer, right-click the HelloSvcService.wsdl file in the  person_wsdl folder and select Web Services → Test with Web Services Explorer 
	__9.  Inside the Web Services Explorer window, double-click the HelloSvcService node.
	__10.  Click the HelloSvcPortBinding link.
	__11.  Click the createPerson operation. 
	__12.  Click the Add link to add the name parameter (registered as arg0 parameter) to the createPerson operation. 
	__13.  In the input box that opens, enter your name (example below uses Mike). 
	__14.  Click Go.
	__15.  Check the Status pane's content at the bottom of the WSE (you can also expand it by double-clicking the top of the Status panel).
	__16.  Click the Source link and then maximize the pane.
	__17.  Minimize the Status pane.
	__18.  Close the WSE.  

	Part 3 -  Change the JAXB Mappings
	__1.   Open Person.java 
	__2.  Add the following annotation in bold to the class.
	__3.  That means that JAXB will directly access the member variables (without going through the getter and setter methods). 
	__4.  Now, annotate the two fields as follows:
	__5.  Add the following import statement (shown in bold below) just below the package name.
	__6.  Save the class. There should be no errors.  
	__7.  Close Person.java

	Part 4 -  Fix the Return Element
	__1.  Open HelloSvc.java
	__2.  Locate the createPerson method, and add the following bolded annotation :
	__3.  Organize imports.
	__4.  Save changes.  There should be no errors.
	__5.  Rename the files located in the person_wsdl folder (click the file name and press F2 to invoke the Rename Resource dialog, enter the new name then press OK):
	__6.  Close all open files.
	__7.  Right-click the HelloSvc.java file in the Project Explorer pane and at the bottom of the pop-up menu select WebLogic Web Services → Generate WSDL.
	__8.  Select the person_wsdl folder for its storage destination.
	__9.  Click OK.
	__10.  Open the person_wsdl folder and inspect the differences between the old and new schema and WSDL files.
	__11.  In the HelloSvcService.wsdl that we just generated, locate the following line:
	__12.  Save the file.

	Part 5 -  Test JAXB Binding Changes
	__1.  Publish the server. 
	__2.  Open the WSE on the HelloWS\person_wsdl\HelloSvcService.wsdl file, as you did before (right-click the WSDL file, and select Web Services → Test with Web Services Explorer).
	__3.  Run the createPerson operation again.
	__4.  Click Add. 
	__5.  Enter a name (Mike was used in the example below), and then click Go.
	__6.  Examine the source for the response.  (Click the Source link and maximize the pane)
	__7.  Close all open editor windows.

	Part 6 -  Review

	Lab 11 -  Develop EJB Based Service
	Part 1 -  Create the Projects
	__1.  From the menu, select File | New | EJBProject.
	__2.  Set the Project name to EJB_WebService
	__3.  In the EAR Membership area of the window, check Add project to an EAR, and then click New Project...
	__4.  Set the Project name to EJB_WebServiceEAR
	__5.  Click Finish.
	__6.  Check that the new EAR project is listed and click the Finish button.
	__7.  Three projects will be created: EJB_WebService, EJB_WebServiceClient and EJB_WebServiceEAR. Make sure you see them in the Project Explorer.
	__8.  Close all files.

	Part 2 -  Create the EJB
	__1.  In the Enterprise Explorer, right click on the EJB_WebServiceClient project and select New → Package.
	__2.  Enter com.webage.beans for the new package name and click the Finish button.
	__3.  Right click the new com.webage.beans package and select New → Class. 
	__4.  Enter a class name of Soup but DON'T click the Finish button yet.
	__5.  Click the Add... button next to the empty list of interfaces.
	__6.  In the dialog that appears enter 'serializable' in the box and then pick the java.io.Serializable interface from the list and click the OK button.
	__7.  Check that your dialog appears as below, including the 'Serializable' interface and click the Finish button.
	__8.  Enter the following fields.
	__9.  Right-click in the editor and select Source → Generate Getters and Setters from pop-up menu.
	__10.  In the dialog that appear, click the Select All button and click the OK button to generate the code.
	__11.  Save and close the Soup class.
	__12.  In the Enterprise Explorer, right click on the EJB_WebService project and select New | Session Bean (EJB 3.x).
	__13.  Set the Java package to com.webage.ejb
	__14.  Set the Class name to OrderSoup
	__15.  In the section Create Business Interface, uncheck No-interface and check Local.
	__16.  Check that your dialog appears like that below and click Finish.
	__17.  Add the following method to the class:
	__18.  Organize imports (Ctrl-Shift-O).
	__19.  Save the class.  There should be no errors.
	__20.  Under the EJB_WebServiceClient project, locate and then double-click to open the OrderSoupLocal.java file.
	__21.  Add the following method reference to this local EJB interface:
	__22.  Organize imports (Ctrl-Shift-O).
	__23.  Save the file.

	Part 3 -  Create the Web Service
	__1.  Open OrderSoup.java from the com.webage.ejb package of the EJB_WebService project in the editor.
	__2.  Add the @WebService annotation to the class, immediately after the @Stateless annotation.
	__3.  Organize imports and save the code.  
	__4.  Close all open files. 

	Part 4 -  Deploy the EAR File 
	__1.  Start the server if it is not running.
	__2.   Add the EJB_WebServiceEAR module to the server using the Add and Remove … dialog.

	Part 5 -  Test the Web Service
	We can now test our web service wrapped session EJB.  We will use the WebLogic Test Client for that which is similar to the Web Services Explorer but may be somewhat easier to use in some cases.  
	__1.  In the Eclipse IDE's menu, click the WebLogic Test Client icon. 
	__2.  In the Enter WSDL URL box, enter the following URL:
	__3.  Click the Test blue button.
	__4.  In the Operations area, type in (overwrite the string placeholder) Mr. Bean as the value for the customerName element, and then Borscht for soupType.
	__5.  Click the orderSoup button in the bottom right-hand side order.
	__6.  Close all open files and web browsers.
	__7.  Stop the server.

	Part 6 -  Review

	Lab 12 -  Handle Web Service Faults
	Part 1 -  Create the Exception (Fault) Class
	__1.  In the Project Explorer, right-click on the HelloWS project and select New → Class.
	__2.  Set the Package to be com.webage.svc
	__3.  Set the Name to be DuplicatePersonException 
	__4.  Set the Superclass to be java.lang.Exception
	__5.  Click Finish. 
	__6.  Update the class with the following code in bold:
	__7.  Save the file.
	__8.  Double-click HelloSvc.java for editing. 
	__9.  Add the following code:
	__10.  Update the createPerson(String name)  method as follows:
	__11.  Organize import, select java.util.ArrayList and java.util.List when prompted. 
	__12.  Save the file.  There should no errors.
	__13.  Close all open files. 

	Part 2 -  Creating the WSDL file 
	__1.  In the HelloWS project, create a fault folder to keep the generated WSDL and schema files that we will need for testing our updated services. 
	__2.  Right-click the HelloSvc.java file in the Project Explorer pane and at the bottom of the pop-up menu select WebLogic Web Services → Generate WSDL.
	__3.  Select the fault folder for its storage destination.
	__4.  Click OK.
	__5.  Quickly review both files to see the results of our code updates.
	__6.  Locate the <soap:address location="REPLACE_WITH_ACTUAL_URL"/> line in HelloSvcService.wsdl file and replace it with the following line:
	__7.  Save the HelloSvcService.wsdl file.

	Part 3 -  Test the Web Service Fault
	__1.  Start the server if it is not running.
	__2.  Publish to the server. 
	__3.  In Project Explorer, right-click the HelloSvcService.wsdl file in the fault folder and select Web Services → Test with Web Services Explorer. 
	__4.  Inside the Web Services Explorer window, click the HelloSvcService node.
	__5.  Click the HelloSvcPortBinding link.
	__6.  Click the createPerson operation. 
	__7.  Click the Add link to add the name parameter (registered as arg0 parameter) to the createPerson operation. 
	__8.  In the input box that opens, enter your name (example below uses Mike). 
	__9.  Click Go.
	__10.  Check the Status pane's content at the bottom of the WSE.
	__11.  Click the Go button again to resubmit the previous request.
	__12.  Click the Source link in the top right-hand side corner.
	__13.  Expand the Status panel, if more real estate needed for better viewing.
	__14.  Review the SOAP Response Envelope.
	__15.  Close all open files and web browsers.
	__16.  Stop the server.

	Part 4 -  Review

	Lab 13 -  Develop a Simple RESTful Service
	Part 1 -  Create the Web Service Project
	__1.  Launch OEPE if it is not already running.
	__2.  Switch to the Java EE perspective.
	__3.  From the menubar, select File > New > Web Service Project.
	__4.  Enter AcmeWeb as the project name.
	__5.  Ensure that Oracle WebLogic Server 12c as the targeted runtime.
	__6.  Add the project to an enterprise application archive project called AcmeApp
	__7.  Click Finish.
	__8.  Right click the newly created AcmeWeb project and select Properties.
	__9.  Select the Java Build Path properties.
	__10.  Click the Libraries tab.
	__11.  Expand WebLogic Systems Library.
	__12.  Scroll down and locate the Jersey JAR files. If you use a plain dynamic web project, you will need to manually add these JAR files to the build path.
	__13.  Now, select the Project Facets property.
	__14.  Note that the JAX-RS facet is not selected. This facet plays no role in developing JAX-RS services for WebLogic.
	__15.  Click Cancel to close the dialog.

	Part 2 -  Register the REST Handler Servlet
	__1.  Open Windows file explorer.
	__2.  Go to C:\LabFiles\
	__3.  Copy web.xml
	__4.  In Eclipse OEPE, paste the file inside the WebContent > WEB-INF folder of AcmeWeb.
	__5.  Open web.xml and study how the servlet is registered. Specifically, note the servlet mapping:

	Part 3 -  Create the Resource Class
	__1.  Right click AcmeWeb project and select New > Class.
	__2.  Enter com.acme.services as the package name and SimpleService as the class name.
	__3.  Click Finish.
	__4.  Add a member variable that will help us do logging.
	__5.  Add the method as follows.
	__6.  Organize imports (Control+Shift+O) and select java.util.logging.Logger.
	__7.  Save changes.

	Part 4 -  Configure the Resource
	__1.  Define the URI of the root resource, by adding the @Path annotation above the class. This is shown in bold face below.
	__2.  Set the HTTP method and reply MIME type for the testGET() method sub-resource as follows.
	__3.  Organize imports. Select javax.ws.rs.Produces.
	__4.  Save changes.

	Part 5 -  Unit Test
	__1.  Start the server if it is not running.
	__2.  Right click the server and select Add and Remove.
	__3.  Add the AcmeApp project to the server.
	__4.  Click Finish.
	__5.  Make sure the server is synchronized.
	__6.  Open a web browser and enter the URL: 
	__7.  You should see OK in the browser.
	__8.  The Console view in Eclipse will show the log output.

	Part 6 -  Use Path Extension for Sub-resource
	__1.  First, add this method.
	__2.  Annotate the method as follows.
	__3.  Save changes.

	Part 7 -  Unit Test
	__1.  Right click the server and select Publish.
	__2.  In a web browser, enter the URL: 
	__3.  Make sure that the Console shows the log output.
	__4.  Open a new browser and re-test the testGET method for regression using the URL: 
	__5.  Close all open files.
	__6.  Close all browsers.

	Part 8 -  Review

	Lab 14 -  Extracting Information from a HTTP Request
	Part 1 -  Get Root Resource Path Parameters
	__1.  Open SimpleService.java
	__2.  Change the @Path annotation for the class and add a parameter there.
	__3.  Add a member variable as follows.
	__4.  Annotate the member variable to save the value of the myRootPathData parameter.
	__5.  Change the log statement of the testGET() method as follows.
	__6.  Make a similar change to the testGETWithPath() method.
	__7.  Organize imports.
	__8.  Save changes.

	Part 2 -  Unit Test
	__1.  Publish the server.
	__2.  First, test the testGET() method by entering the URL: 
	__3.  The log output will like this:
	__4.  Now, test the testGETWithPath() method using the URL: 
	__5.  The log output will be:

	Part 3 -  Get Sub-resource Path Parameters
	__1.  Add a basic method as follows.
	__2.  Annotate method with path and method.
	__3.  Now, extract the path parameters and save them in the two input argument variables of the method.
	__4.  Save changes.
	__5.  Test the method by entering the URL: 

	Part 4 -  Extract Query Parameters
	__1.  Add the giveRaise() method as shown below.
	__2.  Organize imports.
	__3.  Save changes.
	__4.  Test the change by entering the URL: 
	__5.  Make sure that the Console shows:

	Part 5 -  Extracting Form Post Data
	__1.  Add this method.
	__2.  Organize imports. Select  java.util.List.
	__3.  Save changes.

	Part 6 -  Unit Test
	__1.  We will import the form HTML page. Copy C:\LabFiles\post.html and paste it inside the WebContent folder of AcmeWeb project.
	__2.  In the Servers view, right click the server and select Publish.
	__3.  Open a browser and enter the URL: 
	__4.  Fill out the form and submit it. 
	__5.  Make sure that the console log shows the input values correctly.
	__6.  Close all open files.
	__7.  Close all open browsers.

	Part 7 -  Review

	Lab 15 -  Designing a RESTful Service
	Part 1 -  The Business Requirements
	Part 2 -  Define Project Scope
	Part 3 -  Designing the Object Model
	__1.  Can you go through the business requirements and identify the entities? 
	__2.  Now that you have identified the entities, can you list the attributes or fields for each entity? Once again, the answer is below. But do your best to do the design yourself.

	Part 4 -  Identify the Service
	__1.  Can you go through the requirements and list the tasks or operations that various yet to be identified services need to perform? Then compare your findings with the answer below.
	__2.  Can you group the operations based on the entity they work with? Name each group as a service accordingly. The answer is below.

	Part 5 -  Design the Service Interface
	__1.  First, let us decide on the URI for each entity. This is a pretty straightforward exercise. Note: As a matter convention, plural forms of the entity names are used in URI.

	Part 6 -  Decide on the Data Format
	Part 7 -  Unaddressed Architectural Issues
	Part 8 -  Review

	Lab 16 -  Add Support for XML Format
	Part 1 -  Create the Entity Classes
	__1.  In the AcmeWeb project, create a package called com.acme.services.entities
	__2.  Within that package, create a Java class called QuoteRequest
	__3.  In the QuoteRequest class, add these member variables. Feel free to refer back to the object model to make sure we are doing this correctly.
	__4.  Generate getters and setters for the variables. To do this from the menu, select Source >  Generate Getters and Setters. Then click Select All and click OK.
	__5.  Add the @XmlRootElement JAXB annotation to the class as shown in boldface below.
	__6.  Organize imports.
	__7.  Save changes.
	__8.  Open a file browser and go to C:\LabFiles\entities.
	__9.  Copy all the files and then paste them into the com.acme.services.entities package.
	__10.  Open each entity class file and review them. Specifically, look at the Order class. Working with list of child objects can be tricky in JAXB. Look at how we are dealing with line items:

	Part 2 -  Generate the XML Schema
	__1.  Open a command window.
	__2.  Change directory to C:\workspace\AcmeWeb\src
	__3.  Run this command.
	__4.  Back in OEPE refresh the project.
	__5.  Open the generated schema file schema1.xsd and study it.

	Part 3 -  Create the Quote Service Class
	__1.  In the com.acme.services package, create a class called QuoteService
	__2.  Set the root URI of the service as shown in boldface below.
	__3.  Add a member variable for logging.
	__4.  Add the getQuote() method as shown below. The business logic is very simple. We hard code the price and availability.
	__5.  Annotate the method as shown below.
	__6.  Organize imports. Select javax.ws.rs.Produces and java.util.logging.Logger.
	__7.  Save changes.

	Part 4 -  Better Content Handling
	__1.  Add the @Consumes annotation to getQuote as follows in bold.
	__2.  Similarly, change the @Produces annotation to support both MIME types for XML.
	__3.  Organize imports. Select javax.ws.rs.core.MediaType.
	__4.  Save changes.

	Part 5 -  Unit Testing
	__1.  Start the server if it is not running.
	__2.  Publish the server.
	__3.  Open a command window and go to C:\LabFiles.
	__4.  Run the command:
	__5.  In the URL text box, enter: 
	__6.  Select POST method.
	__7.  Click the Body tab.
	__8.  Click the  icon.
	__9.  From the drop-down select the text/xml content type.
	__10.  Click OK.
	__11.  Click the  icon to open the file.
	__12.  Select C:\LabFiles\quote_request.xml and open it.
	__13.  Study the request document briefly.
	__14.  We are now ready start testing. Click the  icon next to the URL.
	__15.  Make sure that the HTTP reply status code is 200.
	__16.  Click the Body tab for the response.
	__17.  Right click the response body text and select Indent > Indent XML.
	__18.  Study the response document.
	__19.  Back in OEPE close all open files.
	__20.  Do not close the REST Client.

	Part 6 -  Review

	Lab 17 -  Add Support for JSON
	Part 1 -  Do the Design First
	Part 2 -  Add the JSON Method
	__1.  Open QuoteService class.
	__2.  First, add the shell of the method.
	__3.  Then, annotate the method and the input parameters as shown in boldface below.
	__4.  Now, fill in the body of the method. It basically calls the getQuote() method to get the job done.
	__5.  Organize imports.
	__6.  Save changes.
	__7.  Publish the server.

	Part 3 -  Understanding Content Negotiation
	Part 4 -  Test
	__1.  Launch the REST client tool if it is not already running.
	__2.  Set the URL to: 
	__3.  Choose POST method.
	__4.  Set the body using the XML code in C:\LabFiles\quote_request.xml and set content type to application/xml; chartset=UTF-8.
	__5.  Click the Headers tab.
	__6.  Enter Accept as Key and text/xml as Value.
	__7.  Click the + icon to add the header.
	__8.  Run the test by clicking .
	__9.  Right click the response body area and select Indent > Indent XML.
	__10.  Verify that the reply body contains the response.
	__11.  Add this to the end of the URL:
	__12.  Set the method to GET.
	__13.  Select the Accept header, then right click on it and select Delete.
	__14.  Enter Accept as Key and application/json as Value, then click the + icon to add the header.
	__15.  Run the test.
	__16.  Right click the response body area and select Indent > Indent JSON.
	__17.  Verify the result.
	__18.  Back in OEPE close all open files.
	__19.  In OEPE close all open files.
	__20.  Do not close the REST Client.

	Part 5 -  Review

	Lab 18 -  Build the Order Web Service
	Part 1 -  Create the Resource Class
	__1.  In the com.acme.services package, create a class called OrderService
	__2.  Annotate the class to set the path as follows.
	__3.  Add a member variable for logging.
	__4.  Organizer imports. Select java.util.logging.Logger.
	__5.  Save changes.

	Part 2 -  Implement Order Placement
	__1.  Write the shell of the method as follows. We will not deal with the returned URL just yet.
	__2.  Annotate the method with @PUT and @Consumes.
	__3.  Organize imports. Select these classes:
	javax.ws.rs.core.MediaType
	com.acme.services.entities.Order
	__4.  Save changes.
	__5.  Import C:\LabFiles\OrderDAO.java into the com.acme.services package.
	__6.  Open the class and briefly study it. The code should be very simple.
	__7.  In the placeOrder method of the OrderService class, use OrderDAO as shown in boldface below.
	__8.  Organize imports. Select these classes:
	java.util.logging.Level
	__9.  Save changes.

	Part 3 -  Implement Retrieval of Order
	__1.  First write the method shell along with the required annotations.
	__2.  Next, fill in the method body.
	__3.  Organize imports. Select these classes:
	__4.  Save changes.

	Part 4 -  Construct Entity URL
	__1.  First, add a member variable to the class as follows.
	__2.  In the placeOrder() method, below the line:
	__3.  Add this line below:
	__4.  Next, add the following line. This plugs in the actual value of the order ID to the path and returns a java.net.URI object.
	__5.  Finally, add this line. We will explain this shortly.
	__6.  Organize imports. Choose these classes:
	__7.  Save the file and make sure you don't have compilation errors.
	__8.  Go to the 'Servers' view and publish the server by right clicking the server and selecting 'Publish'.

	Part 5 -  Test
	__1.  From the REST client's menubar, select File > Open Request (Control+O).
	__2.  Open C:\LabFiles\order_create.rcq
	__3.  Review these items about the request:
	__4.  Click the  button to send the request.
	__5.  Verify that:
	__6.  In the Eclipse Console, verify the log output from the OrderDAO class.
	__7.  In the REST client, open the request file C:\LabFiles\order_retrieve.rcq.
	__8.  Inspect these items about the request:
	__9.  Send the request.
	__10.  Verify that the reply body has the correct order information.

	Part 6 -  Enable Error Handling
	__1.  In the placeOrder() method of OrderService class, add this line shown in bold face.
	__2.  Comment out the following unreachable line:
	__3.  Organize imports. 
	__4.  In the getOrder() method, above the line:
	__5.  Organize imports. Organize imports. Choose these classes:
	javax.ws.rs.core.Response.Status
	__6.  Save changes.

	Part 7 -  Test
	__1.  In the REST client, the order retrieval request file should be open already. Just run the test.
	__2.  Verify that the status code is 404.
	__3.  Open the request file C:\LabFiles\order_create.rcq.
	__4.  In the Body tab, delete all the <item> elements.
	__5.  Run the test.
	__6.  Verify that status code 500 is returned.
	__7.  Do regression tests to make sure that success conditions are working fine.
	__8.  In OEPE close all open files.
	__9.  Do not close the REST Client.

	Part 8 -  Review

	Lab 19 -  Developing a JAX-RS Client
	Part 1 -  Client Design Considerations
	Part 2 -  Import the Client Application
	__1.  From the Eclipse menubar, select File > Import.
	__2.  Select General > Existing Projects into Workspace.
	__3.  Click Next.
	__4.  Select the SimpleClient project from C:\LabFiles\SimpleClientStarter.zip.
	__5.  Click Finish.

	Part 3 -  Build the Service Proxy Layer
	__1.  From the AcmeWeb project, copy the com.acme.services.entities package.
	__2.  In the SimpleClient project, paste it in the src folder.
	__3.  In the SimpleClient project, create a package called com.acme.services.proxy
	__4.  In that package, create a class called QuoteProxy
	__5.  In the QuoteProxy class, add a variable to store the service root URL.
	__6.  Add the shell of a method that will invoke the quote web service.
	__7.  In the getQuote() method, add this line to instantiate a com.sun.jersey.api.client.Client object.
	__8.  Next, create a WebResource object that points to the root web service resource.
	__9.  Add this line to send a QuoteRequest XML using a POST request.
	__10.  Finally, add this line to return the quote response.
	__11.  Organize imports and select this class:
	__12.  Save changes.

	Part 4 -  Build the Presentation Layer
	__1.  From the WebContent folder, open index.jsp and study the form.
	__2.  Open result.jsp and study how the QuoteResponse object properties are shown.
	__3.  From the com.webage.servlet package, open QuoteController.java.
	__4.  Locate the doPost method.
	__5.  Below the line:
	__6.  Below the line: 
	__7.  Below the line:
	__8.  Organize imports.
	__9.  Save changes.

	Part 5 -  Test
	__1.  Start the server if it is not running.
	__2.  Deploy SimpleClient project to the server.
	__3.  Open a web browser and enter the URL: 
	__4.  Enter some values and click Get Quote.
	__5.  Verify the result.
	__6.  Close the browser.
	__7.  Close all open files.

	Part 6 -  Review

	Lab 20 -  Securing RESTful Services
	Part 1 -  Secure the Quote Service
	__1.  In the AcmeWeb project expand com.acme.services package.
	__2.  Open QuoteService.java.
	__3.  Add the following annotation in bold to the class.
	__4.  Organize imports. Select  javax.annotation.security.RolesAllowed.
	__5.  Save changes.
	__6.  Open web.xml from WebContent/WEB-INF folder.
	__7.  Add these lines shown in bold face.
	__8.  Save changes.

	Part 2 -  Test
	__1.  Restart the server. This is needed since we changed the web.xml file.
	__2.  Open a browser and enter the URL: 
	__3.  Enter some data and then click Get Quote.
	__4.  The browser will show an error, scroll to the right in the browser. 
	__5.  The client will fail with 403 error code. This proves that the service is now secured.
	__6.  Switch to the Console in Eclipse.
	__7.  You will see the error.

	Part 3 -  Configure Security at the Server
	__1.  Open a web browser and enter the URL: 
	__2.  Login using user weblogic and password w1sadmin
	__3.  Click Security Realm on the left.
	__4.  Click myrealm.
	__5.  Click Users and Groups tab.
	__6.  Click Groups tab.
	__7.  Click New.
	__8.  Enter ClientCompanyUsers as the group's name.
	__9.  Click OK.
	__10.  Click the Users tab.
	__11.  Click New.
	__12.  Enter bob as name and pa55word as the password.
	__13.  Click OK.
	__14.  Click the newly created user – bob.
	__15.  Click the Groups tab.
	__16.  Add the user to the ClientCompanyUsers group.
	__17.  Click Save.
	__18.  Click Security Realm on the left.
	__19.  Click myrealm.
	__20.  Click Roles and Policies tab.
	__21.  Expand Global Roles and click Roles.
	__22.  Click New.
	__23.  Enter Customer as the name.
	__24.  Click OK.
	__25.  Click the Customer role.
	__26.  Under Role Conditions click the Add Conditions button.
	__27.  Make sure that Group is selected in Predicate List.
	__28.  Click Next.
	__29.  Carefully enter ClientCompanyUsers in the group name text box.
	__30.  Click Add.
	__31.  Click Finish.
	__32.  Click Save.
	__33.  Close the browser.

	Part 4 -  Modify the Client Application
	__1.  In the SimpleClient project, open QuoteProxy class.
	__2.  Below the line:
	__3.  Organize imports.
	__4.  Save changes.

	Part 5 -  Test
	__1.  Publish the WebLogic server.
	__2.  Open a browser and enter the URL: 
	__3.  Enter some data and then click Get Quote. 
	__4.  Verify that the client is showing the response correctly.
	__5.  In the QuoteProxy class, change the password to an invalid one and save changes.
	__6.  Publish the WebLogic server.
	__7.  In the browser hit the back button to go again to the Quote page.
	__8.  Submit again the form and click Get Quote.
	__9.  Scroll to the right of the error message. Verify that status 401 is returned by the service.
	__10.  Change the credentials as follows.
	__11.  Save changes.
	__12.  Publish the WebLogic server.
	__13.  In the browser hit the back button to go again to the Quote page.
	__14.  Submit the form.
	__15.  Verify that server returned 403 error code.
	__16.  Change the code back to valid credentials and save.
	__17.  Publish the WebLogic server.
	__18.  In the browser hit the back button to go again to the Quote page.
	__19.  Submit the form and verify its working fine.

	Part 6 -  Enable Audit Logging
	__1.  In the AcmeWeb project, open OrderService.java.
	__2.  Configure the valid role for the service as shown in bold face below.
	__3.  Add a member variable to the class as follows.
	__4.  In the placeOrder() method, below the line:
	__5.  Organize import and select these classes:
	__6.  Save changes.
	__7.  Publish the WebLogic server.

	Part 7 -  Test
	__1.  Launch the REST test client if it is not already running.
	__2.  Select File > Open Request from the menubar.
	__3.  Open C:\LabFiles\order_create.rcq
	__4.  Click the  button to send the request.
	__5.  Make sure that a status code 403 is returned.
	__6.  Click the Auth tab.
	__7.  Enter these values:
	__8.  Run the test again.
	__9.  Verify that status code 201 is returned.
	__10.  Check Eclipse console for the audit log. It will look like this:
	__11.  From the menu, select File > Save Request.
	__12.  If this windows appears click OK.
	__13.  Make sure order_create.rcq is selected and click Save. 
	__14.  Then click Yes to overwrite the file.
	__15.  Open the request file C:\LabFiles\order_retrieve.rcq
	__16.  Click the Auth tab and enter these values:
	__17.  From the menu, select File > Save Request.
	__18.  If you see the UI parameters change click OK.
	__19.  Make sure order_retrieve.rcq is selected and click Save. 
	__20.  Then click Yes to overwrite the file.
	__21.  Close all open browsers.
	__22.  Close all open files.
	__23.  Do not close the REST Client.

	Part 8 -  Review

	Lab 21 -  Complete the Order Service
	Part 1 -  Implement Order Cancellation
	__1.  In the AcmeWeb project, open OrderService.java
	__2.  Add this method.
	__3.  Add these lines to the cancelOrder() method.
	__4.  Organize imports.
	__5.  Save changes.

	Part 2 -  Test
	__1.  Run the REST test client.
	__2.  From the client, open the request file C:\LabFiles\order_create.rcq
	__3.  Select the Auth tab and make sure credentials are configured.
	__4.  Run the test. You should get a status code of 201. 
	__5.  Open the request file C:\LabFiles\order_retrieve.rcq
	__6.  Select the Auth tab and make sure credentials are configured.
	__7.  Run the test. You should get a status code of 200.
	__8.  From the Method tab, select DELETE.
	__9.  Run the test. 
	__10.  Since the reply body is empty, you should see HTTP status code 204. This is equivalent to status 200 and indicates success.
	__11.  In the Method tab, select GET method.
	__12.  Run the test.
	__13.  Verify that 404 is returned.

	Part 3 -  Implement Order History
	__1.  From the com.acme.services.entities package, open OrderList.java and inspect it.
	__2.  In the OrderService class, add the method shell as follows.
	__3.  Add the method body as follows.
	__4.  Organize imports.
	__5.  Save changes.

	Part 4 -  Test
	__1.  From the REST test client, open the request file C:\LabFile\order_create.rcq
	__2.  From the Body tab, note the client ID – C001.
	__3.  Run the test to create an order.
	__4.  From the Body tab, change the part number and quantity ordered and place a few more orders.
	__5.  From the test client, open the request file C:\LabFiles\order_history.rcq
	__6.  Run the test.
	__7.  Verify the response.

	Part 5 -  Implement Order Update Function
	__1.  In the OrderService class, add the method shell.
	__2.  Fill in the method body as follows.
	__3.  Organize imports.
	__4.  Save changes.

	Part 6 -  Test
	__1.  From the REST test client, open the request file C:\LabFile\order_create.rcq
	__2.  Run the test.
	__3.  Add the order ID 1000 to the URL (add  /1000  at the end of the URL).
	__4.  From the Method tab, choose POST.
	__5.  From the Body tab, change quantity and/or part number.
	__6.  Run the test.
	__7.  Verify that status code 204 is returned.
	__8.  Now lets check the retrieve request. Open the request file C:\LabFile\order_retrieve.rcq
	__9.  Run the test.
	__10.  Verify that status code 200 is returned.
	__11.  Format the result (Indent > Indent XML ) and verify that the the body contains the information that you changed.
	__12.  Open the request file C:\LabFile\order_create.rcq
	__13.  Change the order ID in the URL to an invalid value as shown above.
	__14.  From the Method tab, choose POST.
	__15.  Run the test and make sure 404 status code is returned.
	__16.  Close all open files.

	Part 7 -  Review




