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Directory Paths Used in Labs
The following directories will be referred to often in the labs.  To simplify lab 
instructions there are many places where the variables listed below will be used in place 
of the actual directory path.

Some directories which should already exist before you start the labs are listed below 
with values.  Please verify the location of these directories matches what is listed here 
and make a note of the change if it does not.  Also notify your instructor if anything does 
not match.

Some directories will not yet exist as you will be installing software in the labs.  These 
are listed here so you can write down the appropriate directory here when installing the 
software.

Directories that should exist already:

<WAS_SOFTWARE_DIR>:  C:\Software\WAS ND v70

<LABFILES_DIR>:  C:\LabFiles

<DB2_ROOT>:  C:\Program Files\IBM\SQLLIB

<MQ_ROOT>:  C:\Program Files\IBM\WebSphere MQ

<JMETER_ROOT>:  C:\Software\jakarta-jmeter-2.3.4

Directories created during labs:

<WAS_ROOT>:                                                                                                        

<IHS_ROOT>:                                                                                                          
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Lab Notes
This section has notes that will be referred to throughout the labs.  Various labs will have 
you write down information in this section to document important settings or to use in 
later labs.

Lab 1 - WebSphere v7.0 Installation
Profile name <profile>:                                                                                                               

Node name <nodename>:                                                                                                            

Host name <hostname>:                                                                                                              

Lab 4 - Solving Problems
System.out File Name (including path):                                                                                    

Lab 7 & Alternate Lab 1 - JMS Messaging
JNDI Name for Connection Factory:                                                                                        

JNDI Name for Queue:                                                                                                               

JNDI Name of Activation Specification:                                                                                   
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Lab 1 - WebSphere v7.0 Installation
In this lab you will install the WebSphere Application Server v7.0.  WebSphere 
Application Server relies on TCP/IP networking.  It is important to have networking 
correctly configured before starting the installation and the host name must remain fixed. 
Your lab machine should be configured correctly for the lab.  

At the end of this lab you will be able to:

1. Install WebSphere Application Server V7.0

2. Explore the major WebSphere directories

3. Start the Application Server

4. Test the WebSphere Installation

5. Stop the Application Server

Part 1 - Install the Application Server
This section will run the installation wizard for WebSphere Application Server.

__1. Make sure that you are logged in as an administrative user.  An administrative user 
should be available on the lab machine as part of the setup for the class.  Ask your 
instructor if you are not sure which user to use when running the labs.

Note:  Certain aspects of WebSphere may require certain user rights of the Windows ID 
that will run the Application Server.  The required user rights on a Windows machine 
are: “Act as part of the operating system” and “Log on as a service”.

Be sure to check the platform specific installation instructions before installing 
WebSphere on your own machines.  The users, groups, and rights assignments will be 
detailed there.  This lab should not be used as the only resource in preparing for your 
WebSphere installation.

__2. If possible, disable any anti-virus or script-blocking software that may interfere with 
the installation.

__3. Open a Windows Explorer window.

__4. Navigate to the <WAS_SOFTWARE_DIR>\Main\WAS directory substituting the 
value of the <WAS_SOFTWARE_DIR> variable with the location mentioned in the list 
of directory paths at the beginning of these labs.  Check with your instructor if you can't 
find the directory listed.
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__5. Double click on the install.exe file to run it.

Windows Vista/2008: If you are running the labs on a Vista/2008 system, right click the 
install.exe program and select 'Run as Administrator'.

Keep an eye out for other notes with Vista/2008 instructions in other parts of the labs.

__6. On the Welcome page press the Next button.

__7. Accept the license agreement and press the Next button.

__8. Once the system passes the prerequisite checks press the Next button.  If the checks 
do not pass inform your instructor.

Note: One reason the prerequisite check might fail is if you are using a different form of 
Windows than was available when WebSphere was released.  Usually using a more 
recent service pack (like Windows XP SP3) is OK and you can continue with the 
installation but a completely new version of Windows (like Windows 7) is likely to 
cause issues.

__9. Leave the box for installing the sample applications unchecked and press the Next 
button.
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__10. Write down the installation directory for the <WAS_ROOT> variable in the list of 
directory paths at the beginning of these labs.  This directory will be used later in the labs. 
Leave the default installation directory as is and press the Next button.

Windows Vista/2008: If you are installing on Vista/2008 do not install in the 'Program 
Files' directory.  Remove this from the directory path and install to 
'C:\IBM\WebSphere\AppServer'.

If you install under the 'Program Files' directory you will have trouble saving 
WebSphere configuration changes in future labs.

__11. On the screen that appears about environments select to create an  Application 
Server environment and press the Next button.

Note:  An “Application Server” profile in the Network Deployment edition is exactly the 
same as the profiles created by the “Base” edition of the software.  This lets the labs 
focus on the core features of WebSphere before covering a clustered environment.
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__12. Leave the box for Enable administrative security checked.  Fill in a user and 
password of wasadmin.  Press the Next button when your screen matches that shown 
below.

__13. On the Installation Summary screen press the Next button to begin the 
installation.  If you are prompted with a security warning unblock the Java process.

__14. Once the installation is complete, click on the link for the AboutThisProfile.txt 
file.
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__15. In the file that is opened, note the Profile name, Node name, and Host name. 
Write these values down in the Lab Notes section at the beginning of the lab guide.

__16. Close the text file showing the profile information.

__17. When the installation is complete press the Finish button.  This will launch the 
First Steps console.

__18. Click the link for Installation verification.

__19. Make sure that you get a message that the verification succeeded.  You may get a 
few messages that are warnings (with a 'W') but there should be no errors.

__20. Close the verification window.

__21. In the First Steps window, click the link for Stop the Server.
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__22. When the server is stopped close the window that showed the output of stopping 
the server.

__23. Click Exit on the First Steps window.

Part 2 - Explore Application Server Directory Structure
This section will point out some of the major directories in the WebSphere installation.

__1. Open a Windows Explorer window.

__2. Navigate to the <WAS_ROOT> directory you wrote down in the notes at the 
beginning of these labs.  This should be the main installation directory for WebSphere.
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__3. Look at some of the major directories and their contents:

● bin – executable programs, scripts, and DLLs

● installableApps – complete applications which can be installed

● java – JDK 1.6.0 files (supports Java SE v6)

● lib – library of various Java .jar files used by WebSphere

● web – documentation resources

● profiles\AppSrv01\config – configuration files for the installation

● profiles\AppSrv01\etc – default SSL files

● profiles\AppSrv01\installedApps – applications installed on the server

● profiles\AppSrv01\logs – default directory for various trace and log files

● profiles\AppSrv01\properties – configuration property files used by WebSphere

__4. Look at some of the log files created during the installation and verification:

● <WAS_ROOT>\logs\install\log.txt - logs installation events

● <WAS_ROOT>\logs\manageprofiles\AppSrv01_create.log - log messages 
related to the creation of the AppSrv01 profile

● <WAS_ROOT>\profiles\AppSrv01\logs\ivtClient.log - output of verification test

● <WAS_ROOT>\profiles\AppSrv01\logs\server1\SystemOut.log - main log file 
for Application Server

__5. Close the Windows Explorer window and all open files.
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Part 3 - Test the Application Server
There is a default application that is installed with the Application Server that can be used 
to test.  This test is independent of the verification test.

__1. Start the Application Server.  There are several ways to start the Application Server, 
they are:

● Select Start -> Programs -> IBM WebSphere -> Application Server Network 
Deployment v7.0 -> Profiles -> AppSrv01 -> Start the Server.

● Open a command prompt.  Use the 'cd' command to change to the 
<WAS_ROOT>\profiles\AppSrv01\bin directory.  Issue the command 
'startServer server1'.

● Start the server from the Windows Services panel.

Starting with WebSphere v6 the ways to start and stop the server on Windows are more 
interchangeable.  It used to be that if the server was registered as a service the status of 
the service was not updated if the server was started from the command line.  With v6, if 
the server is registered as a Windows service, the other two options (i.e., Start menu 
option and command prompt option) start and stop the Windows service so they can be 
used more interchangeably.

__2. Once the server is started, open a web browser and type the URL 
'http://localhost:9080/snoop' into the address bar.  You should see the output below.

__3. Close the web browser used to test the Application Server.
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__4. Stop the Application Server.  There are several ways to stop the Application Server, 
they are:

● Select Start -> Programs -> IBM WebSphere -> Application Server Network 
Deployment v7.0 -> Profiles -> AppSrv01 -> Stop the Server.

● Open a command prompt.  Use the 'cd' command to change to the 
<WAS_ROOT>\profiles\AppSrv01\bin directory.  Issue the command 
'stopServer server1'.

● Stop the server from the Windows Services panel.

Part 4 - Summary
In this lab you installed the WebSphere Application Server.  You also ran some basics 
tests of the server and familiarized yourself with some basic commands.  You are now 
able to start and stop the server and can identify some of the major directories in the 
WebSphere installation.

Even though you installed the Network Deployment software, the profile that you created 
is exactly what you would have after installing the “Base” edition of WebSphere.  The 
only difference is that when you install the “Base” edition you only get one option for the 
type of environment to create.
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Lab 2 - Install an Application
In this lab you will install a simple application to the Application Server.  This application 
has only one simple function, printing a message out to the screen.  It does not use any 
external resources.  This is so you can concentrate on installing an application without 
needing to configure any other resources first.

At the end of this lab you will be able to:

1. Use the Admin Console for administering applications on the server.

2. Install an application to the Application Server

3. Test applications that have been deployed to the server by submitting web 
requests

Part 1 - Control Applications From the Admin Console
In this section you will use the Admin Console to control applications deployed to the 
server.  You will also see an example of the response returned if a deployed application is 
stopped.

__1. Start the Application Server.  There are several ways to start the Application Server, 
they are:

● Select Start -> Programs -> IBM WebSphere -> Application Server Network 
Deployment v7.0 -> Profiles -> AppSrv01 -> Start the Server.

● Open a command prompt.  Use the 'cd' command to change to the 
<WAS_ROOT>\profiles\AppSrv01\bin directory.  Issue the command 
'startServer server1'.

● Start the server from the Windows Services panel.

__2. Start the Admin Console by opening a Web browser and entering the URL 
http://localhost:9060/ibm/console/

__3. Since security is enabled you will get a warning about the server certificate.  Accept 
the certificate or continue to the website depending on the browser you are using.

Note:  You will get this warning every time you access the Admin Console.  You could 
also “Install” the certificate in your web browser to indicate you trust the site to prevent 
the warning.

__4. Enter a user ID and password of ‘wasadmin’ and click “Log in” on the Login screen 
of the Console.
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__5. Expand the Applications group in the Navigation tree, expand Application Types 
and click on the link for WebSphere enterprise applications.

__6. Check the checkbox next to the DefaultApplication and press the Stop button.  You 
should get a message that the application was stopped and a red ‘X’ in the status column.

__7. Open a separate Web browser and try to access the Snoop Servlet as in the last lab. 
The URL is http://localhost:9080/snoop.  You should get a ‘404’ error saying that the 
file can’t be found.  This is because it is part of the DefaultApplication which is stopped. 
You may get a slightly different error message if using a browser besides Internet 
Explorer.

__8. In the Admin Console, check the checkbox next to the DefaultApplication and 
press the Start button.  You should get a message that the application was started and a 
green arrow in the status column.

__9. In the Web browser you used to access the Snoop Servlet, hit the refresh button. 
You should see the normal output of the Snoop Servlet.  

__10. Close the extra Web browser you were using to test the Snoop application.
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Part 2 - Install an Application to the Server
In this section you will install an application to the server.  After installing and starting 
the application the Application Server will be able to handle requests that were not part of 
the testing and verification applications that already come installed on the server.  This 
section will familiarize you with the basic process of installing an application.

__1. Return to the web browser you were using for the Admin Console.  If you had 
closed it you can open it at http://localhost:9060/ibm/console/ and login is wasadmin.

__2. In the Applications group in the navigation, click the link for New Application.

__3. Click the link for New Enterprise Application.

__4. Next to the Local file system box, press the Browse button.

__5. Find the file <LABFILES_DIR>\Install\HitCount.ear and select Open in the file 
chooser dialog.  Remember to substitute the value of the <LABFILES_DIR> variable 
from the notes at the beginning of the labs.

__6. Press the Next button.

__7. Check the option for Detailed installation.  This will show all steps.

__8. Once you have the options specified as below, press the Next button.

Note:  The next sequence of steps will vary depending on the application you are 
installing.  Since this application is fairly simple there are only a few steps and a 
summary.  There would be fewer steps if we had not checked the option for showing all 
options.
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__9. On step 1, check the Precompile JavaServer Pages files option and click Next.

__10. Accept the default values on steps 2-12 by pressing the Next button on each step. 
Some of these steps will only appear once you go through other steps.  You should end up 
at step 13 which is the summary.  Some of the intermediate steps are explained below:

Step 2: Map modules to servers - This step would be more important in a multi-server 
environment.  This step will also be more important with web servers later.

Step 3: Provide options to compile JSPs - This step appears because of the option you 
selected to precompile JSPs.  Most of the time the code needed to compile JSPs is in the 
application itself but if it is not you may need to supply additional options here.

Step 4: Provide JSP reloading options for Web modules - This service can 
automatically check if a new version of a JSP file has been deployed to the application 
without restarting the entire application.  Most of the time you would leave this service 
on but you could increase the time interval in production.

Steps 5 & 6: Shared libraries - Shared libraries are shared code that is required by an 
application but is not packaged with the application itself.  If you have previously 
configured a shared library you can map it to an application module with these steps.

Step 7: Provide JNDI names for beans & Step 8: Bind EJB Business – These steps 
are presented if the application includes EJBs.  The JNDI name can be used by EJB 
clients to locate the EJB.  Some EJB clients can also obtain a reference to the EJB using 
Java EE “injection” where the JNDI name may not be required.  If your developers are 
using Rational software this value may be filled in already.  It would be important to 
coordinate the values of these properties with developers.

Step 9: Map EJB references to beans – An EJB reference is another way for an EJB 
client to be linked to a target EJB.  Again, this value may not be required if an application 
uses Java EE “injection”.

Step 10: Map virtual hosts for Web modules - Virtual hosts affect the URL that is used 
to access the application.  This will be discussed more later.

Step 11: Map context roots for Web modules - The context root also makes up part of 
the application URL.  You could change it here if you wish.  This will be discussed more 
later.
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Step 12: Metadata for modules – Deployment information for applications can be 
provided by XML deployment descriptors or through annotations in the code itself.  If 
you check the 'metadata-complete attribute' in this step for a module of the application, 
any deployment information provided in code annotations is ignored.  Developers may be 
counting on some of these annotations being applied to configure an application so this is 
another aspect to coordinate with developers.

__11. On step 13, the Summary, click the Finish button.  Wait for it to complete the 
installation and be sure you get a message that says Application HitCount installed 
successfully.

__12. Click the link to Review changes to the master configuration below the message 
about the successful installation.

__13. On the Save screen, click the '+' sign to expand the list of changes that will be 
made.

Note:  The number of changed documents you see may be slightly different.

__14. Click the Save button to save the master configuration.

__15. In the Applications group in the navigation, expand the Application Types section 
and click the link for WebSphere enterprise applications.
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__16. Start the HitCount application by checking the checkbox next to it and clicking the 
Start button.

Part 3 - Test the HitCount Application
Now that the application is installed and started you can test it.  You will find out how to 
submit a web request for an installed application by using properties available from the 
Admin Console.

__1. Make sure that you are viewing the list of Enterprise Applications in the Admin 
Console.  If not, you can expand the 'Applications → Application Types' group in the 
navigation and click the link for 'WebSphere enterprise applications'.

__2. From the list of applications, click the link for the HitCount application by clicking 
on the application name.  This will show you a page of options and configuration related 
to that particular application.
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__3. From the list of Detail Properties associated with the HitCount application click the 
link for View Deployment Descriptor.

__4. In the text of the Deployment Descriptor find the value of the context-root.  This is 
what you can add to the host name and port of the server to access the application.
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__5. Open a new web browser and enter the URL http://localhost:9080/HitCountWeb. 
Notice this URL ends in the “context-root” of the web application.  You should see the 
following page.

__6. Click the link of the home page of the application.  You should get an initial count of 
'1'.

__7. Refresh the page several times to see the count increase.

__8. Leave the web browser open that you are using to test the application.

__9. Return to your Admin Console web browser.  If you closed it, open a new window to 
the URL http://localhost:9060/ibm/console/.  Make sure you leave the web browser 
running the HitCount application open.

__10. Expand the 'Applications → Application Types' group in the navigation and click 
the link for 'WebSphere enterprise applications'.

__11. Check the checkbox next to the HitCount application and press the Stop button.

__12. Once the application is stopped, check the checkbox next to the HitCount 
application again and press the Start button.

__13. Return to the web browser you were using to test the application and refresh the 
page.  The count should return to 1 even though you are using the same web browser. 
The “state” of the stateful session EJB has been lost by restarting the application.
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__14. Close the web browser you used to test the new application.

__15. In the web browser showing the Admin Console click the Logout link near the top 
of the Console.

__16. Close the web browser you were using for the Admin Console.

__17. Stop the Application Server.  There are several ways to stop the Application Server, 
they are:

● Select Start -> Programs -> IBM WebSphere -> Application Server Network 
Deployment v7.0 -> Profiles -> AppSrv01 -> Stop the Server.

● Open a command prompt.  Use the 'cd' command to change to the 
<WAS_ROOT>\profiles\AppSrv01\bin directory.  Issue the command 
'stopServer server1'.

● Stop the server from the Windows Services panel.

Part 4 - Summary
In this lab you installed a simple application and saw the main steps of installing an 
application.  Even though most applications will be much more complex and require 
more steps during the installation the same basic process will be followed.

You also saw how to access properties for installed applications to find out how to submit 
web requests for testing.  There are many other properties associated with applications 
and you only saw a few but others are accessed in the same way, by clicking the name of 
the application in the list of applications.  In fact all configuration properties and options 
available in the Admin Console are accessed in a similar fashion.  When you click a link 
on one page it displays another page with properties for that item.

Copyright 2012 Web Age Solutions Inc. 22

EV
AL
UA
TIO
N O
NL
Y



Lab 3 - IBM HTTP Server and Web Server Plug-in
You have already seen how the WebSphere Application Server can handle HTTP requests 
without a Web Server.  For enhanced network security and performance it is often 
desirable to use a Web Server.  In this lab you will see how the Web Server and the 
WebSphere Application Server work together in this environment.

You will be installing the IBM HTTP Server and Web Server Plug-in using the “local” 
configuration which is shown below.  In this configuration the web server, plug-in, and 
WebSphere server are all on the same machine.  Much of the plug-in configuration within 
the WebSphere configuration will be done for you using a batch command generated 
during the web server installation.

At the end of this lab you will be able to:

1. Install the IBM HTTP Server and Web Server Plug-in.

2. Add a new host name to the IBM HTTP Server.

3. Route requests for this new host name back to your own machine.

4. Configure applications in the WebSphere Application Server to use this host 
name.

Part 1 - Install IBM HTTP Server
The first step will be to install the IBM HTTP Server.  This has a separate installation 
than the WebSphere installation.  Although you will be installing the IBM HTTP Server 
on the same machine as WebSphere, often this would be done on a different machine.

__1. Make sure you are logged in as an administrative user.

__2. Open a Windows Explorer window.
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__3. Navigate to the <WAS_SOFTWARE_DIR>\Supplement\IHS directory 
substituting the <WAS_SOFTWARE_DIR> variable location mentioned in the beginning 
of these labs.  Check with your instructor if you can't find the directory listed.

__4. Double click the install.exe file to start the launchpad.

Windows Vista/2008: If you are running the labs on a Vista/2008 system, right click the 
install.exe program and select 'Run as Administrator'.

__5. Click Next on the Welcome screen.

__6. Accept the license and click Next.

__7. Once the system passes the prerequisite checks press the Next button.  If the checks 
do not pass inform your instructor.

__8. Write down the installation directory for the <IHS_ROOT> variable in the list of 
directory paths at the beginning of these labs.  This directory will be used later in the labs. 
Leave the default installation directory as is and press the Next button.

Windows Vista/2008: If you are installing on Vista/2008 do not install in the 'Program 
Files' directory.  Remove this from the directory path and install to 
'C:\IBM\HTTPServer'.

__9. Accept the default values for the HTTP port and administration port.  Click the Next 
button.
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__10. Change the way the Windows service logs on to “Log on as local system account” 
as shown below.  Press the Next button.

__11. Leave the option for “Create a user ID for IBM HTTP administration server 
authentication” checked.  Fill in a user ID and password of 'ihsadmin'. Click the Next 
button.
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__12. Leave the option for “Install the IBM HTTP Server Plug-in for IBM 
WebSphere Application Server” option checked.  Make sure that the Host name listed 
matches the value for the <hostname> variable you wrote down in the lab notes section 
for the WebSphere installation.  Click the Next button when you have checked the 
settings on this page.

Note:  This screen refers to the plug-in installation as the “remote” scenario.  This is 
simply because we are not having the plug-in installation automatically alter the 
WebSphere configuration but will do that with a script file in the next section.  If you 
run the plug-in installation separately it is possible to do a “local” scenario where the 
installation automatically alters the WebSphere configuration.  The steps in the next 
section are most likely the steps you would follow in many WebSphere environments.

__13. Press the Next button in the summary screen to start the installation.

__14. Press the Finish button to close the installation wizard.

Part 2 - Configure Web Server in WebSphere Configuration
Now that you have installed the web server you need to define the web server settings in 
the WebSphere configuration.  There are several settings that need to be configured 
related to the web server.  The good thing is that there is a script that was created during 
the web server installation that can easily configure WebSphere with just a few 
parameters.  

__1. Open the Windows Control Panel by selecting Start -> Control Panel or Start -> 
Settings -> Control Panel depending on your Windows version.

__2. If you are using Windows XP or Vista switch to the “Classic View” by clicking the 
link on the left side of the Control Panel.
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__3. Double click the Administrative Tools group to open this category.

__4. Find the Services icon.  You may want to add a shortcut to this to the desktop since 
you may be using the Services panel very often in class.

__5. Double click the Services icon to open the list of services.

__6. Right click the following services and select Start from the popup menu if they are 
not already started:

IBM HTTP Administration 7.0

IBM HTTP Server 7.0

IBM WebSphere Application Server V7.0

__7. Open a Windows Explorer window or use one you already have open.

__8. Navigate to the directory <IHS_ROOT>\Plugins\bin where the <IHS_ROOT> is 
the variable you wrote down from the IBM HTTP Server installation in the previous 
section.

__9. Find the file 'configurewebserver1.bat' in the directory.  Check that you find the 
correct file as there are several that start with 'configure...'.  The file extension may be 
hidden from you depending on your Windows settings.
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__10. Copy the 'configurewebserver1.bat' file by right clicking and selecting Copy from 
the popup menu.

__11. Navigate to the directory <WAS_ROOT>\bin where the <WAS_ROOT> is the 
variable you wrote down from the WebSphere installation lab.

__12. Paste the 'configurewebserver1.bat' file into this directory by selecting Edit -> 
Paste from the menus.

__13. Hit F5 to refresh the view and be sure you see the 'configurewebserver1.bat' file 
in the list of files.

Note:  Also note that there is a 'configureWebserverDefinition.jacl' file in the same 
directory.  This file will be called by the script you just copied in with parameters 
configured during the web server installation.

__14. Make sure you have logged out of any previously open Admin Console browser 
windows.

Note:  It is important to logout because you will run a script in the next few steps as the 
same user you used in the Admin Console.  The script seems to have conflicts in this 
situation.

__15. Open a Command Prompt window.  You can do this by selecting Start -> Run, 
entering cmd and then pressing OK.

__16. Change directories using the 'cd' command to the <WAS_ROOT>\bin directory. 
Be sure to substitute the value of <WAS_ROOT> from the “Directory Paths” page at the 
beginning of the lab instructions.

__17. Enter the following command to check that the WebSphere server is started:

serverstatus -all -username wasadmin -password wasadmin
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__18. Enter the following command to configure the web server definition in the 
WebSphere configuration.  The command should all be entered on the same line even 
though it wraps to a second line below.

configurewebserver1 -profileName AppSrv01 -user wasadmin -password wasadmin 
-ihsAdminPassword ihsadmin

__19. Scroll back through the messages that were output and be sure you do not see any 
errors.

Part 3 - Configure Virtual Host on Web Server
The next step will be to configure the IBM HTTP Server to respond to a unique host 
name that is not the same as the host name of the machine itself.  This “virtual hosting” 
will separate the physical hostnames of your network from the logical hostnames you 
expose to the clients of the applications.  You will use a host name of ‘was.myhost.com’.

In the labs there is not any static content hosted on the web server.  This section is 
provided to show how to use the WebSphere Admin Console to configure the web server. 
The settings in this section configure the web server so it responds to the 
'was.myhost.com' hostname we will use.

__1. Open a web browser and enter http://localhost:9060/ibm/console in the address 
bar, the URL of the Admin Console.  Remember to continue if you get any certificate 
errors.

__2. Login as the 'wasadmin' user.

__3. Navigate to the Servers → Server Types → Web Servers section of the admin 
console.  Notice there is now a configuration for 'webserver1' which the script you ran 
added.

__4. Click the link for webserver1 from the list.

__5. Under the Additional Properties click the link for Configuration File.  If you get 
an error displaying the configuration file let your instructor know as this likely means 
there is a problem with your IHS administration password.

__6. Scroll to the very end of the file and add a few blank lines.
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__7. Add the following text exactly as it appears below at the end of the configuration 
file.  

<VirtualHost was.myhost.com>
    ServerName was.myhost.com
    ErrorLog logs/was.myhost.com-error_log
    CustomLog logs/was.myhost.com-access_log common
</VirtualHost>

__8. Check that your configuration appears as below and press the OK button.

__9. Go back to the list of web servers by navigating to the Servers → Server Types → 
Web Servers section of the admin console.

__10. Check the box next to the webserver1 entry and click the Stop button.  Make sure 
you get a message about the server stopping.

__11. Check the box next to webserver1 and click the Start button.  If you have trouble 
starting the web server check your configuration file syntax.

__12. Logout of the Admin Console.
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Part 4 - Update Network Setup
You will now change the networking setup of your Windows machine to send requests for 
this new host name back to your own machine.  You will use the ‘hosts’ file on the 
machine to perform this mapping.  Normally you would have other network components 
perform this mapping but the ‘hosts’ file will simplify the process for the lab.  If this step 
is not done then requests sent to the host name 'was.myhost.com' would not be redirected 
back to you local machine.

__1. Open a Windows Explorer window or use one you already have open.

__2. Navigate to the Windows Root directory.  This is usually C:\WINNT or 
C:\WINDOWS.

__3. Under this directory find the system32\drivers\etc directory.  In this directory there 
should be a ‘hosts’ file.

__4. Copy the 'hosts' file and rename the copy to something like 'hosts-backup'.  This will 
ensure you can restore the original if needed.

__5. Check that the file is not marked as read only by viewing the file properties.

__6. Double-click on the ‘hosts’ file and open it with WordPad.  WordPad is much better 
to use than other text editors such as Notepad because it saves files without adding a ‘.txt’ 
extension.

Note: If you are using Windows Vista you can't just double click the file.  You will have 
to right click the shortcut from the Start menu for Wordpad and select 'Run as 
administrator' and then open the file from within Wordpad.  If you do not run Wordpad 
this way you will not be able to save after making changes.

__7. If you do not already have a line that starts with the IP address 127.0.0.1 add it. 
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__8. Add to this line hostnames of localhost and was.myhost.com with spaces between 
the IP address and each of the hostnames.  The file should be similar to this: 

__9. Save the file and close WordPad.

__10. Open a Command Prompt window.  You can do this by selecting Start -> Run, 
entering cmd and then pressing OK.

__11. Be sure you can ping the new host name.  Enter the command ping 
was.myhost.com.  Be sure you don’t get an “unknown host” or “request timed out” error 
message.  
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__12. Close the Command Prompt.

__13. Open an Internet Explorer window.

__14. Open the Internet Options dialog.  This is usually done by selecting Tools -> 
Internet Options.

__15. Click on the Connections tab and click the button for LAN Settings.

__16. If your settings are configured to use a proxy server, similar to that shown below, 
press the Advanced button to configure advanced proxy settings and go to next step. If 
not click Cancel.

__17. Add a local exception for the 'was.myhost.com' address as shown below.  If there 
are other exceptions in the list be sure to put a semicolon (;) between the addresses.

__18. Click any OK buttons to close the Internet Options dialogs.
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__19. Enter the URL http://was.myhost.com in the address bar of the browser and hit 
Return. You should see the homepage of the IBM HTTP Server running on your machine. 
If you do not see this screen contact your instructor.

__20. Close out any extra command prompts, web browsers, or Windows Explorer 
windows you may have open.

Part 5 - Test Plug-in
Now that you have tested the web server you should test that requests sent to the web 
server can be forwarded to WebSphere through the Plug-in.

__1. Open a web browser and enter the URL http://localhost:9080/HitCountWeb/ in the 
address bar and hit the Return key.  You should see the normal output of the HitCount 
application.
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__2. Test the function of the application to be sure it is working properly.

__3. Enter the URL http://localhost/HitCountWeb into the address bar of the web 
browser and hit Return.  You should see the same application.  If you get any errors check 
that your web server is running.

Note:  The difference is that the URL above does not list the 9080 port.  Because there is 
no port listed it sends the request to the default HTTP port which is port 80.  This is the 
port the web server is listening on.  The fact that you got the normal response proves that 
the web server can forward requests for the HitCount application to WebSphere through 
the Plug-in.

__4. Test the application again to be sure the same behavior is shown even though the 
requests are now being forwarded through the Plug-in.

__5. Enter the URL http://was.myhost.com/HitCountWeb/ into the address bar of the 
web browser and hit Return.  Again you should see the same HitCount application.  This 
is because you have configured the web server to respond to the host name 
was.myhost.com.  It can also forward requests for this host name to WebSphere.

Note: The hit count will be reset because it was associated with your web session that 
was linked to the 'localhost' hostname.  When you use a new hostname of 
was.myhost.com the browser starts a new web session.

__6. Close the web browser you have been using to test.

Part 6 - Examine Plug-in Configuration
The configuration of the Plug-in is often a mystery.  It is confusing to most people how 
the Plug-in makes decisions about what requests to forward.  In this section you will see 
how you can examine the Plug-in configuration in the WebSphere Admin Console.

__1. Start the Admin Console by opening a Web browser and entering the URL 
http://localhost:9060/ibm/console/

__2. Enter a user ID and password of ‘wasadmin’ and click “Log in” on the Login screen 
of the Console.

__3. In the navigation panel on the left expand the Servers → Server Types group and 
click the link for Web Servers.

__4. Click the link for the webserver1 web server.

__5. Under the Additional Properties for the web server click the link for Plug-in 
properties.
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__6. Press the View button next to the Plug-in configuration file name.

__7. Search through the configuration for the VirtualHostGroup element.  This has the 
definition of several VirtualHosts.  These are the host name and port combinations the 
Plug-in can expect to receive requests for.  The host name is listed as an asterisk (*) right 
now which means the Plug-in will accept requests for any host name the web server 
responds to.

__8. Search through the configuration for the Server element.  Within this element you 
will see “Transports” which have values for the host name and port numbers of the 
Application Server.  This is so the Plug-in knows what host name and port to use to 
forward requests to the Application Server.

Note:  The syntax for the server section in the Plug-in configuration can be confusing. 
The parent tag in the configuration is “ServerCluster”.  You do not have a cluster of 
servers right now.  This term is only used so that if you did have a cluster of servers in a 
Network Deployment Cell the syntax of the Plug-in configuration would be the same. 
Right now your Plug-in is configured as if you have a “cluster” with only one server in 
it.
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__9. Search through the configuration for the UriGroup element.  Within this element 
you should see an entry for '/HitCountWeb/*'.  This is the entry that indicates the Plug-
in can forward requests to the HitCount application.

__10. Search through the configuration for the Route entry.  This links together the three 
other parts of the Plug-in configuration you have looked at so far.

Note:  The “Route” is probably the most important part of the configuration.  This is 
what the Plug-in uses to make decisions about what requests to forward and how.  The 
Route indicates that if a request comes in for a host name and port listed by the 
VirtualHostGroup and for an application listed in the UriGroup that the request should 
be forwarded to a server in the ServerCluster.

__11. Click the OK button on the bottom of the Plug-in configuration to close the view of 
the configuration file.

Part 7 - Configure Virtual Host in WebSphere
Right now the Plug-in is forwarding lots of requests to the HitCount application. 
Requests can be submitted using the hostnames localhost or was.myhost.com on one of 
several different ports.  This is because the current Plug-in configuration uses an asterisk 
(*) for the host name of the VirtualHost definitions.

In certain situations you might want to restrict the host name and port combinations that 
are mapped to your applications through the Plug-in.  To do this you must add a 
VirtualHost definition in the WebSphere configuration and configure the “host aliases” 
that it will use.  You would then map an application to this new VirtualHost you created 
to indicate the application would only be available on the given host and port 
combinations.  Finally you would update the web server Plug-in configuration so it uses 
the new rules for how to forward requests to your applications.
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__1. In the WebSphere Admin Console expand the Environment navigation group and 
click the link for Virtual hosts.

__2. Notice that right now there are only two virtual hosts.  One is the “default_host” 
that you saw in the Plug-in configuration.  The other is an “admin_host” that is used 
only for the Admin Console.

__3. Click the New button above the list of virtual hosts.

__4. Fill in a Name of myhost for the new virtual host and press the Apply button.  Make 
sure you hit the Apply button as the OK button will not keep you on the same screen.

__5. To the right under Additional Properties, click the link for Host Aliases.

__6. Right now there are no host aliases.  Click the New button above the empty list of 
host aliases.

__7. Change the Host Name to was.myhost.com and leave the default port of 80.  Click 
the OK button when you have the properties filled in as below.

__8. The new host alias now appears in the list.  This is now the ONLY host name and 
port that applications mapped to this virtual host will recognize.
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__9. Click on the Save link in the list of messages near the top of the main Console area.

__10. In the navigation area of the Console expand the Applications → Application 
Types group and click the link for WebSphere enterprise applications.

__11. Click the link for the HitCount application.

__12. In the list of Web Module Properties on the right click the link for “Virtual hosts”.

__13. Use the drop down next to the HitCountWeb Web module to select the myhost 
Virtual host from the list.  Press the OK button when you have the properties set as 
below.

__14. Back on the screen for the HitCount application, click the link for “Manage 
Modules” in the Modules section of properties.

__15. Notice that the Web module is already mapped to the webserver1 web server AND 
the server1 Application Server.  This indicates that requests for that application will pass 
through the webserver1 web server on the way to server1.  This is a critical setting for 
configuring the web server Plug-in configuration for webserver1.

Note:  This mapping was already done for you even though you did not do it.  This was 
done by the script that you ran to configure the web server in the WebSphere 
configuration.  The script automatically mapped all of the applications that were 
currently installed to the web server definition that it created for the Plug-in.

In the future, when you install applications that have Web modules, mapping them to a 
web server will be an important step.
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__16. Click on the Save link in the list of messages near the top of the main Console area.

__17. In the navigation panel on the left expand the Servers → Server Types group and 
click the link for Web Servers.

__18. Check the checkbox next to webserver1 and click the Generate Plug-in button.

__19. Check the checkbox next to webserver1 and click the Propagate Plug-in button.

__20. Click the link for the webserver1 web server.

__21. Under the Additional Properties for the web server click the link for Plug-in 
properties.

__22. Press the View button next to the Plug-in configuration file name.

__23. If you look in the configuration you will notice there are now entries for the 
myhost VirtualHostGroup you created and the UriGroup for the HitCountWeb Uri is 
now listed separately.  There is also a new Route entry that associates the entries relating 
to the HitCount application.  You may need to scroll around the file as there are many 
other entries.

.............

__24. When you are done looking at the new Plug-in configuration, click the Logout link 
in the Admin Console.
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Part 8 - Test the New Virtual Host
Now that you have configured a new virtual host with only one host name and port 
combination and associated the HitCount application with it you will want to see how this 
affects the behavior of the application.  No longer will you be able to send requests using 
any host name or port besides was.myhost.com on port 80.

__1. Open the Windows Services panel if it is not already open.  You can do this by 
following the instructions on page Error: Reference source not found if you did not create 
a shortcut to this on your desktop.

__2. Restart the “IBM HTTP Server 7.0” and “IBM WebSphere Application Server 
v7.0...” services.  You can right click on the services and select Restart from the popup 
menu.  Make sure to wait for both servers to restart completely.

Note:  You need to restart the Application Server because some of the configuration 
changes you just made are only read when the server starts.  You are restarting the web 
server just to be certain that it is using the new Plug-in configuration.

__3. Open a web browser and enter the URL http://was.myhost.com/HitCountWeb/ 
into the address bar of the web browser and hit Return.  You will see the normal output of 
the HitCount application.  This is expected since the application is still registered to 
respond to this host name and port combination.

__4. Test the function of the application to verify it is working correctly.

__5. Notice the URL that appears in the browser for the page that displays the messages. 
It is:

http://was.myhost.com/HitCountWeb/HitCountServlet
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__6. Enter the following URLs into the web browser that have worked before:

● http://localhost/HitCountWeb

● http://localhost:9080/HitCountWeb

● http://was.myhost.com:9080/HitCountWeb

Notice that all of these URLs now generate various “page cannot be found” 404 errors. 
This is because these host name and port combinations are not listed as host aliases of the 
virtual host that the HitCount application is mapped to.

__7. Close the web browser you were using for testing.

Part 9 - Investigate Application Settings
So far in this lab you have seen how to change the host name and port an application will 
respond to using a Virtual Host.  In this section you will see where the other parts of the 
URL are specified.  You will use the Admin Console to display the “Deployment 
Descriptors” that contain this information.  Remember the URL you used to access the 
application was:

http://was.myhost.com/HitCountWeb/HitCountServlet

__1. Open a web browser and enter http://localhost:9060/ibm/console in the address 
bar, the URL of the Admin Console.

__2. Login as the 'wasadmin' user.

__3. In the navigation area of the Console expand the Applications → Application 
Types group and click the link for WebSphere enterprise applications.

__4. Click the link for the HitCount application.
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__5. Under the Detail Properties section, click the link for View Deployment Descriptor.

__6. Make sure all the entries are expanded and locate the 'context-root' element.  This 
forms the first part of the URL that comes after the host name and port.  Notice this also 
mentions a 'HitCountWeb.war' module for the application.

__7. In the “breadcrumb” trail at the top of the page click the link for the “HitCount” 
application.  This will take you back to the properties of the application configuration.

__8. At the top of the page of properties for the HitCount application click the link for 
Manage Modules under the Modules section of properties.
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__9. In the list of modules click the link for the HitCountWeb module.

__10. On the right side, click the link for View Deployment Descriptor.

__11. Make sure all the entries are expanded and locate the 'servlet-mapping' element. 
This links the servlet in the application to the URL suffix '/HitCountServlet'.

__12. Logout of the Admin Console and close the web browser.

__13. Stop the Application Server using the method you are most familiar with.

Note:  You now know how to read the URLs used to access application components. 
These are of the form:

<protocol>://<hostname>:<port>/<context root>/<URL mapping>

Applying this to the HitCountServlet URL:

http://was.myhost.com/HitCountWeb/HitCountServlet

<protocol> - HTTP

<hostname> - was.myhost.com

<port> - 80, this is the default HTTP port if none is listed

<context root> -  HitCountWeb

<URL mapping> - /HitCountServlet
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Part 10 - Summary
This lab showed several different aspects of using web servers with WebSphere.  The first 
sections involved installing and configuring the IBM HTTP Server.  This included 
configuring the web server to respond to a “virtual host” which was different than the 
actual host name of your machine.  You also had to modify the network setup of your 
machine and browser to be sure that the requests for this host name would be routed back 
to your machine and not sent out to the network.

The next sections tested the web server Plug-in.  Because most of the initial setup of the 
Plug-in was done by the web server installation and the script you ran there was not much 
to do immediately after the script to get it to work.  You also became familiar with how to 
read the Plug-in configuration and discovered how the Plug-in will forward requests for 
applications.

In the last set of sections you reconfigured the HitCount application so it would only 
respond to requests sent to the was.myhost.com host name on port 80.  This may be 
required when you need to have more control over how applications respond to requests. 
The first step in this was to create a new virtual host and host alias that only included the 
desired host name and port.  You then changed the configuration of the HitCount 
application to use this new virtual host.  After restarting the servers you saw how these 
settings restrict the host name and ports that you can use to submit requests.

You also saw how to obtain some basic information about the internal settings of an 
application using the Admin Console to view the deployment descriptors.
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	Lab 1 -  WebSphere v7.0 Installation
	Part 1 -  Install the Application Server
	__1.  Make sure that you are logged in as an administrative user.  An administrative user should be available on the lab machine as part of the setup for the class.  Ask your instructor if you are not sure which user to use when running the labs.
	__2.  If possible, disable any anti-virus or script-blocking software that may interfere with the installation.
	__3.  Open a Windows Explorer window.
	__4.  Navigate to the <WAS_SOFTWARE_DIR>\Main\WAS directory substituting the value of the <WAS_SOFTWARE_DIR> variable with the location mentioned in the list of directory paths at the beginning of these labs.  Check with your instructor if you can't find the directory listed.
	__5.  Double click on the install.exe file to run it.
	__6.  On the Welcome page press the Next button.
	__7.  Accept the license agreement and press the Next button.
	__8.  Once the system passes the prerequisite checks press the Next button.  If the checks do not pass inform your instructor.
	__9.  Leave the box for installing the sample applications unchecked and press the Next button.
	__10.  Write down the installation directory for the <WAS_ROOT> variable in the list of directory paths at the beginning of these labs.  This directory will be used later in the labs.  Leave the default installation directory as is and press the Next button.
	__11.  On the screen that appears about environments select to create an  Application Server environment and press the Next button.
	__12.  Leave the box for Enable administrative security checked.  Fill in a user and password of wasadmin.  Press the Next button when your screen matches that shown below.
	__13.  On the Installation Summary screen press the Next button to begin the installation.  If you are prompted with a security warning unblock the Java process.
	__14.  Once the installation is complete, click on the link for the AboutThisProfile.txt file.
	__15.  In the file that is opened, note the Profile name, Node name, and Host name.  Write these values down in the Lab Notes section at the beginning of the lab guide.
	__16.  Close the text file showing the profile information.
	__17.  When the installation is complete press the Finish button.  This will launch the First Steps console.
	__18.  Click the link for Installation verification.
	__19.  Make sure that you get a message that the verification succeeded.  You may get a few messages that are warnings (with a 'W') but there should be no errors.
	__20.  Close the verification window.
	__21.  In the First Steps window, click the link for Stop the Server.
	__22.  When the server is stopped close the window that showed the output of stopping the server.
	__23.  Click Exit on the First Steps window.

	Part 2 -  Explore Application Server Directory Structure
	__1.  Open a Windows Explorer window.
	__2.  Navigate to the <WAS_ROOT> directory you wrote down in the notes at the beginning of these labs.  This should be the main installation directory for WebSphere.
	__3.  Look at some of the major directories and their contents:
	__4.  Look at some of the log files created during the installation and verification:
	__5.  Close the Windows Explorer window and all open files.

	Part 3 -  Test the Application Server
	__1.  Start the Application Server.  There are several ways to start the Application Server, they are:
	__2.  Once the server is started, open a web browser and type the URL 'http://localhost:9080/snoop' into the address bar.  You should see the output below.
	__3.  Close the web browser used to test the Application Server.
	__4.  Stop the Application Server.  There are several ways to stop the Application Server, they are:

	Part 4 -  Summary

	Lab 2 -  Install an Application
	Part 1 -  Control Applications From the Admin Console
	__1.  Start the Application Server.  There are several ways to start the Application Server, they are:
	__2.  Start the Admin Console by opening a Web browser and entering the URL http://localhost:9060/ibm/console/
	__3.  Since security is enabled you will get a warning about the server certificate.  Accept the certificate or continue to the website depending on the browser you are using.
	__4.  Enter a user ID and password of ‘wasadmin’ and click “Log in” on the Login screen of the Console.
	__5.  Expand the Applications group in the Navigation tree, expand Application Types and click on the link for WebSphere enterprise applications.
	__6.  Check the checkbox next to the DefaultApplication and press the Stop button.  You should get a message that the application was stopped and a red ‘X’ in the status column.
	__7.  Open a separate Web browser and try to access the Snoop Servlet as in the last lab. The URL is http://localhost:9080/snoop.  You should get a ‘404’ error saying that the file can’t be found.  This is because it is part of the DefaultApplication which is stopped. You may get a slightly different error message if using a browser besides Internet Explorer.
	__8.  In the Admin Console, check the checkbox next to the DefaultApplication and press the Start button.  You should get a message that the application was started and a green arrow in the status column.
	__9.  In the Web browser you used to access the Snoop Servlet, hit the refresh button.  You should see the normal output of the Snoop Servlet.  
	__10.  Close the extra Web browser you were using to test the Snoop application.

	Part 2 -  Install an Application to the Server
	__1.  Return to the web browser you were using for the Admin Console.  If you had closed it you can open it at http://localhost:9060/ibm/console/ and login is wasadmin.
	__2.  In the Applications group in the navigation, click the link for New Application.
	__3.  Click the link for New Enterprise Application.
	__4.  Next to the Local file system box, press the Browse button.
	__5.  Find the file <LABFILES_DIR>\Install\HitCount.ear and select Open in the file chooser dialog.  Remember to substitute the value of the <LABFILES_DIR> variable from the notes at the beginning of the labs.
	__6.  Press the Next button.
	__7.  Check the option for Detailed installation.  This will show all steps.
	__8.  Once you have the options specified as below, press the Next button.
	__9.  On step 1, check the Precompile JavaServer Pages files option and click Next.
	__10.  Accept the default values on steps 2-12 by pressing the Next button on each step.  Some of these steps will only appear once you go through other steps.  You should end up at step 13 which is the summary.  Some of the intermediate steps are explained below:
	__11.  On step 13, the Summary, click the Finish button.  Wait for it to complete the installation and be sure you get a message that says Application HitCount installed successfully.
	__12.  Click the link to Review changes to the master configuration below the message about the successful installation.
	__13.  On the Save screen, click the '+' sign to expand the list of changes that will be made.
	__14.  Click the Save button to save the master configuration.
	__15.  In the Applications group in the navigation, expand the Application Types section and click the link for WebSphere enterprise applications.
	__16.  Start the HitCount application by checking the checkbox next to it and clicking the Start button.

	Part 3 -  Test the HitCount Application
	__1.  Make sure that you are viewing the list of Enterprise Applications in the Admin Console.  If not, you can expand the 'Applications → Application Types' group in the navigation and click the link for 'WebSphere enterprise applications'.
	__2.  From the list of applications, click the link for the HitCount application by clicking on the application name.  This will show you a page of options and configuration related to that particular application.
	__3.  From the list of Detail Properties associated with the HitCount application click the link for View Deployment Descriptor.
	__4.  In the text of the Deployment Descriptor find the value of the context-root.  This is what you can add to the host name and port of the server to access the application.
	__5.  Open a new web browser and enter the URL http://localhost:9080/HitCountWeb.  Notice this URL ends in the “context-root” of the web application.  You should see the following page.
	__6.  Click the link of the home page of the application.  You should get an initial count of '1'.
	__7.  Refresh the page several times to see the count increase.
	__8.  Leave the web browser open that you are using to test the application.
	__9.  Return to your Admin Console web browser.  If you closed it, open a new window to the URL http://localhost:9060/ibm/console/.  Make sure you leave the web browser running the HitCount application open.
	__10.  Expand the 'Applications → Application Types' group in the navigation and click the link for 'WebSphere enterprise applications'.
	__11.  Check the checkbox next to the HitCount application and press the Stop button.
	__12.  Once the application is stopped, check the checkbox next to the HitCount application again and press the Start button.
	__13.  Return to the web browser you were using to test the application and refresh the page.  The count should return to 1 even though you are using the same web browser.  The “state” of the stateful session EJB has been lost by restarting the application.
	__14.  Close the web browser you used to test the new application.
	__15.  In the web browser showing the Admin Console click the Logout link near the top of the Console.
	__16.  Close the web browser you were using for the Admin Console.
	__17.  Stop the Application Server.  There are several ways to stop the Application Server, they are:

	Part 4 -  Summary

	Lab 3 -  IBM HTTP Server and Web Server Plug-in
	Part 1 -  Install IBM HTTP Server
	__1.  Make sure you are logged in as an administrative user.
	__2.  Open a Windows Explorer window.
	__3.  Navigate to the <WAS_SOFTWARE_DIR>\Supplement\IHS directory substituting the <WAS_SOFTWARE_DIR> variable location mentioned in the beginning of these labs.  Check with your instructor if you can't find the directory listed.
	__4.  Double click the install.exe file to start the launchpad.
	__5.  Click Next on the Welcome screen.
	__6.  Accept the license and click Next.
	__7.  Once the system passes the prerequisite checks press the Next button.  If the checks do not pass inform your instructor.
	__8.  Write down the installation directory for the <IHS_ROOT> variable in the list of directory paths at the beginning of these labs.  This directory will be used later in the labs.  Leave the default installation directory as is and press the Next button.
	__9.  Accept the default values for the HTTP port and administration port.  Click the Next button.
	__10.  Change the way the Windows service logs on to “Log on as local system account” as shown below.  Press the Next button.
	__11.  Leave the option for “Create a user ID for IBM HTTP administration server authentication” checked.  Fill in a user ID and password of 'ihsadmin'. Click the Next button.
	__12.  Leave the option for “Install the IBM HTTP Server Plug-in for IBM WebSphere Application Server” option checked.  Make sure that the Host name listed matches the value for the <hostname> variable you wrote down in the lab notes section for the WebSphere installation.  Click the Next button when you have checked the settings on this page.
	__13.  Press the Next button in the summary screen to start the installation.
	__14.  Press the Finish button to close the installation wizard.

	Part 2 -  Configure Web Server in WebSphere Configuration
	__1.  Open the Windows Control Panel by selecting Start -> Control Panel or Start -> Settings -> Control Panel depending on your Windows version.
	__2.  If you are using Windows XP or Vista switch to the “Classic View” by clicking the link on the left side of the Control Panel.
	__3.  Double click the Administrative Tools group to open this category.
	__4.  Find the Services icon.  You may want to add a shortcut to this to the desktop since you may be using the Services panel very often in class.
	__5.  Double click the Services icon to open the list of services.
	__6.  Right click the following services and select Start from the popup menu if they are not already started:
	__7.  Open a Windows Explorer window or use one you already have open.
	__8.  Navigate to the directory <IHS_ROOT>\Plugins\bin where the <IHS_ROOT> is the variable you wrote down from the IBM HTTP Server installation in the previous section.
	__9.  Find the file 'configurewebserver1.bat' in the directory.  Check that you find the correct file as there are several that start with 'configure...'.  The file extension may be hidden from you depending on your Windows settings.
	__10.  Copy the 'configurewebserver1.bat' file by right clicking and selecting Copy from the popup menu.
	__11.  Navigate to the directory <WAS_ROOT>\bin where the <WAS_ROOT> is the variable you wrote down from the WebSphere installation lab.
	__12.  Paste the 'configurewebserver1.bat' file into this directory by selecting Edit -> Paste from the menus.
	__13.  Hit F5 to refresh the view and be sure you see the 'configurewebserver1.bat' file in the list of files.
	__14.  Make sure you have logged out of any previously open Admin Console browser windows.
	__15.  Open a Command Prompt window.  You can do this by selecting Start -> Run, entering cmd and then pressing OK.
	__16.  Change directories using the 'cd' command to the <WAS_ROOT>\bin directory.  Be sure to substitute the value of <WAS_ROOT> from the “Directory Paths” page at the beginning of the lab instructions.
	__17.  Enter the following command to check that the WebSphere server is started:
	__18.  Enter the following command to configure the web server definition in the WebSphere configuration.  The command should all be entered on the same line even though it wraps to a second line below.
	__19.  Scroll back through the messages that were output and be sure you do not see any errors.

	Part 3 -  Configure Virtual Host on Web Server
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.  Remember to continue if you get any certificate errors.
	__2.  Login as the 'wasadmin' user.
	__3.  Navigate to the Servers → Server Types → Web Servers section of the admin console.  Notice there is now a configuration for 'webserver1' which the script you ran added.
	__4.  Click the link for webserver1 from the list.
	__5.  Under the Additional Properties click the link for Configuration File.  If you get an error displaying the configuration file let your instructor know as this likely means there is a problem with your IHS administration password.
	__6.  Scroll to the very end of the file and add a few blank lines.
	__7.  Add the following text exactly as it appears below at the end of the configuration file.  
	__8.  Check that your configuration appears as below and press the OK button.
	__9.  Go back to the list of web servers by navigating to the Servers → Server Types → Web Servers section of the admin console.
	__10.  Check the box next to the webserver1 entry and click the Stop button.  Make sure you get a message about the server stopping.
	__11.  Check the box next to webserver1 and click the Start button.  If you have trouble starting the web server check your configuration file syntax.
	__12.  Logout of the Admin Console.

	Part 4 -  Update Network Setup
	__1.  Open a Windows Explorer window or use one you already have open.
	__2.  Navigate to the Windows Root directory.  This is usually C:\WINNT or C:\WINDOWS.
	__3.  Under this directory find the system32\drivers\etc directory.  In this directory there should be a ‘hosts’ file.
	__4.  Copy the 'hosts' file and rename the copy to something like 'hosts-backup'.  This will ensure you can restore the original if needed.
	__5.  Check that the file is not marked as read only by viewing the file properties.
	__6.  Double-click on the ‘hosts’ file and open it with WordPad.  WordPad is much better to use than other text editors such as Notepad because it saves files without adding a ‘.txt’ extension.
	__7.  If you do not already have a line that starts with the IP address 127.0.0.1 add it. 
	__8.  Add to this line hostnames of localhost and was.myhost.com with spaces between the IP address and each of the hostnames.  The file should be similar to this: 
	__9.  Save the file and close WordPad.
	__10.  Open a Command Prompt window.  You can do this by selecting Start -> Run, entering cmd and then pressing OK.
	__11.  Be sure you can ping the new host name.  Enter the command ping was.myhost.com.  Be sure you don’t get an “unknown host” or “request timed out” error message.  
	__12.  Close the Command Prompt.
	__13.  Open an Internet Explorer window.
	__14.  Open the Internet Options dialog.  This is usually done by selecting Tools -> Internet Options.
	__15.  Click on the Connections tab and click the button for LAN Settings.
	__16.  If your settings are configured to use a proxy server, similar to that shown below, press the Advanced button to configure advanced proxy settings and go to next step. If not click Cancel.
	__17.  Add a local exception for the 'was.myhost.com' address as shown below.  If there are other exceptions in the list be sure to put a semicolon (;) between the addresses.
	__18.  Click any OK buttons to close the Internet Options dialogs.
	__19.  Enter the URL http://was.myhost.com in the address bar of the browser and hit Return. You should see the homepage of the IBM HTTP Server running on your machine.  If you do not see this screen contact your instructor.
	__20.  Close out any extra command prompts, web browsers, or Windows Explorer windows you may have open.

	Part 5 -  Test Plug-in
	__1.  Open a web browser and enter the URL http://localhost:9080/HitCountWeb/ in the address bar and hit the Return key.  You should see the normal output of the HitCount application.
	__2.  Test the function of the application to be sure it is working properly.
	__3.  Enter the URL http://localhost/HitCountWeb into the address bar of the web browser and hit Return.  You should see the same application.  If you get any errors check that your web server is running.
	__4.  Test the application again to be sure the same behavior is shown even though the requests are now being forwarded through the Plug-in.
	__5.  Enter the URL http://was.myhost.com/HitCountWeb/ into the address bar of the web browser and hit Return.  Again you should see the same HitCount application.  This is because you have configured the web server to respond to the host name was.myhost.com.  It can also forward requests for this host name to WebSphere.
	__6.  Close the web browser you have been using to test.

	Part 6 -  Examine Plug-in Configuration
	__1.  Start the Admin Console by opening a Web browser and entering the URL http://localhost:9060/ibm/console/
	__2.  Enter a user ID and password of ‘wasadmin’ and click “Log in” on the Login screen of the Console.
	__3.  In the navigation panel on the left expand the Servers → Server Types group and click the link for Web Servers.
	__4.  Click the link for the webserver1 web server.
	__5.  Under the Additional Properties for the web server click the link for Plug-in properties.
	__6.  Press the View button next to the Plug-in configuration file name.
	__7.  Search through the configuration for the VirtualHostGroup element.  This has the definition of several VirtualHosts.  These are the host name and port combinations the Plug-in can expect to receive requests for.  The host name is listed as an asterisk (*) right now which means the Plug-in will accept requests for any host name the web server responds to.
	__8.  Search through the configuration for the Server element.  Within this element you will see “Transports” which have values for the host name and port numbers of the Application Server.  This is so the Plug-in knows what host name and port to use to forward requests to the Application Server.
	__9.  Search through the configuration for the UriGroup element.  Within this element you should see an entry for '/HitCountWeb/*'.  This is the entry that indicates the Plug-in can forward requests to the HitCount application.
	__10.  Search through the configuration for the Route entry.  This links together the three other parts of the Plug-in configuration you have looked at so far.
	__11.  Click the OK button on the bottom of the Plug-in configuration to close the view of the configuration file.

	Part 7 -  Configure Virtual Host in WebSphere
	__1.  In the WebSphere Admin Console expand the Environment navigation group and click the link for Virtual hosts.
	__2.  Notice that right now there are only two virtual hosts.  One is the “default_host” that you saw in the Plug-in configuration.  The other is an “admin_host” that is used only for the Admin Console.
	__3.  Click the New button above the list of virtual hosts.
	__4.  Fill in a Name of myhost for the new virtual host and press the Apply button.  Make sure you hit the Apply button as the OK button will not keep you on the same screen.
	__5.  To the right under Additional Properties, click the link for Host Aliases.
	__6.  Right now there are no host aliases.  Click the New button above the empty list of host aliases.
	__7.  Change the Host Name to was.myhost.com and leave the default port of 80.  Click the OK button when you have the properties filled in as below.
	__8.  The new host alias now appears in the list.  This is now the ONLY host name and port that applications mapped to this virtual host will recognize.
	__9.  Click on the Save link in the list of messages near the top of the main Console area.
	__10.  In the navigation area of the Console expand the Applications → Application Types group and click the link for WebSphere enterprise applications.
	__11.  Click the link for the HitCount application.
	__12.  In the list of Web Module Properties on the right click the link for “Virtual hosts”.
	__13.  Use the drop down next to the HitCountWeb Web module to select the myhost Virtual host from the list.  Press the OK button when you have the properties set as below.
	__14.  Back on the screen for the HitCount application, click the link for “Manage Modules” in the Modules section of properties.
	__15.  Notice that the Web module is already mapped to the webserver1 web server AND the server1 Application Server.  This indicates that requests for that application will pass through the webserver1 web server on the way to server1.  This is a critical setting for configuring the web server Plug-in configuration for webserver1.
	__16.  Click on the Save link in the list of messages near the top of the main Console area.
	__17.  In the navigation panel on the left expand the Servers → Server Types group and click the link for Web Servers.
	__18.  Check the checkbox next to webserver1 and click the Generate Plug-in button.
	__19.  Check the checkbox next to webserver1 and click the Propagate Plug-in button.
	__20.  Click the link for the webserver1 web server.
	__21.  Under the Additional Properties for the web server click the link for Plug-in properties.
	__22.  Press the View button next to the Plug-in configuration file name.
	__23.  If you look in the configuration you will notice there are now entries for the myhost VirtualHostGroup you created and the UriGroup for the HitCountWeb Uri is now listed separately.  There is also a new Route entry that associates the entries relating to the HitCount application.  You may need to scroll around the file as there are many other entries.
	__24.  When you are done looking at the new Plug-in configuration, click the Logout link in the Admin Console.

	Part 8 -  Test the New Virtual Host
	__1.  Open the Windows Services panel if it is not already open.  You can do this by following the instructions on page Error: Reference source not found if you did not create a shortcut to this on your desktop.
	__2.  Restart the “IBM HTTP Server 7.0” and “IBM WebSphere Application Server v7.0...” services.  You can right click on the services and select Restart from the popup menu.  Make sure to wait for both servers to restart completely.
	__3.  Open a web browser and enter the URL http://was.myhost.com/HitCountWeb/ into the address bar of the web browser and hit Return.  You will see the normal output of the HitCount application.  This is expected since the application is still registered to respond to this host name and port combination.
	__4.  Test the function of the application to verify it is working correctly.
	__5.  Notice the URL that appears in the browser for the page that displays the messages.  It is:
	__6.  Enter the following URLs into the web browser that have worked before:
	__7.  Close the web browser you were using for testing.

	Part 9 -  Investigate Application Settings
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the navigation area of the Console expand the Applications → Application Types group and click the link for WebSphere enterprise applications.
	__4.  Click the link for the HitCount application.
	__5.  Under the Detail Properties section, click the link for View Deployment Descriptor.
	__6.  Make sure all the entries are expanded and locate the 'context-root' element.  This forms the first part of the URL that comes after the host name and port.  Notice this also mentions a 'HitCountWeb.war' module for the application.
	__7.  In the “breadcrumb” trail at the top of the page click the link for the “HitCount” application.  This will take you back to the properties of the application configuration.
	__8.  At the top of the page of properties for the HitCount application click the link for Manage Modules under the Modules section of properties.
	__9.  In the list of modules click the link for the HitCountWeb module.
	__10.  On the right side, click the link for View Deployment Descriptor.
	__11.  Make sure all the entries are expanded and locate the 'servlet-mapping' element.  This links the servlet in the application to the URL suffix '/HitCountServlet'.
	__12.  Logout of the Admin Console and close the web browser.
	__13.  Stop the Application Server using the method you are most familiar with.

	Part 10 -  Summary

	Lab 4 -  Solving Problems
	Part 1 -  Introduce Problem
	__1.  If it is not already running, start the Application Server from the Windows Services panel.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console/, the URL for the Admin Console.
	__3.  Login to the Admin Console as 'wasadmin'.
	__4.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__5.  From the list of Enterprise Applications, click on the link for the HitCount application.
	__6.  Under the Enterprise Java Bean Properties section on the right side click the link for EJB JNDI names.
	__7.  In the JNDI Name field, change the value to ‘ejb/GARBAGE’ and press the OK button.
	__8.  Click the Save link in the messages at the top of the Admin Console.
	__9.  Logout of the Admin Console and close the browser window.
	__10.  Go back to the Windows Services panel.
	__11.  Stop the “IBM HTTP Server 7.0” and the “IBM WebSphere Application Server” services.

	Part 2 -  Isolate Problems
	__1.  Open a Web Browser and enter http://was.myhost.com/ in the address bar.  You should get an error message which says something like “Cannot find server or DNS Error”.  The way to display details about the error may differ depending on browser version.  Try looking for a “More Information” link or something similar in this and other steps.
	__2.  Leave the web browser window open.
	__3.  Open a Command Prompt window.  You can do this by selecting Start -> Run, entering cmd and then pressing OK.
	__4.  Enter the command 'ping was.myhost.com'.  Be sure you do not get a response which states “Unknown Host”.  If you did get this response the problem would be in the networking setup. You should get replies as shown below.
	__5.  Change directories to the <IHS_ROOT>\logs directory.  Make sure to substitute the value of the <IHS_ROOT> variable you wrote down in the Directory Paths page at the beginning of the labs.  The command for this should be ‘cd C:\Program Files\IBM\HttpServer\logs’.
	__6.  Execute the command 'dir httpd.pid'.  If this file is not found it means the web server is not running.
	__7.  Close the command prompt.
	__8.  Start the “IBM HTTP Server 7.0” service in the Services panel.
	__9.  Return to the web browser that you used to access http://was.myhost.com and refresh the page.  This time you should see the homepage of the IBM HTTP Server.  This confirms you can communicate with the web server.
	__10.  Enter http://localhost/snoop in the address bar.  You should get an “Internal Server Error”.  This request should be sent to the Application Server through the Web Server plug-in.
	__11.  To test the Application Server directly enter http://localhost:9080/snoop in the address bar.  You should get the same “Cannot find server or DNS Error”.  Since this request should be sent directly to the Application Server on port 9080 the problem is in communicating with the Application Server.  The previous “Internal Server Error” occurred because the plug-in tried to forward the request to the Application Server but could not contact it.
	__12.  Start the “IBM WebSphere Application Server” from the Services panel.  Wait for the service to start completely.
	__13.  Close the previous Web Browser.  This ensures that the browser is not caching the error response.
	__14.  Open a new Web Browser and enter http://localhost:9080/snoop in the address bar.  You should get the normal response from the Application Server.
	__15.  Remove the port from the URL and resubmit the request for http://localhost/snoop.  This ensures the Web Server plug-in can forward the request properly.
	__16.  Change the URL to http://localhost/snoop5 and resubmit the request.  You should get a “The page cannot be found” error.  This is from an HTTP 404 error.  Since we know this request is not mapped to anything this error is expected.
	__17.  Enter http://was.myhost.com/HitCountWeb in the address bar.  You should see the main page of the HitCount application.
	__18.  Click the link to attempt to access the page that displays the counter.  You will get a 500 “Internal Server Error” because of the problem that was introduced in the first part of the lab. Notice that the “Internal Server Error” may be formatted differently because it is coming from the WebSphere Application Server and not the web server.

	Part 3 -  Check Admin Console Messages
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  Expand the Troubleshooting section in the navigation panel and expand Runtime Messages.
	__4.  Click the link for Runtime error messages.  By default the runtime messages are disabled so you will not see any.
	__5.  Use the dropdown to select Warning and press the Apply button.
	__6.  Click the link to Save the configuration.
	__7.  Go back to the browser you were using to test the HitCount application.  Open a new one if you closed it.  Test the application again and be sure that you see the error again.
	__8.  Return to the Admin Console.
	__9.  Click the link for Runtime warning messages in the Admin Console.
	__10.  You should see some messages as shown below.  You may have more if you viewed the page more than once or caused other errors previously.  
	__11.  Click the link for the message in the list which mentions something about “A NameNotFoundException occured...”.  
	__12.  In the details of the message you should see that the error is because the name 'ejb/Counter' could not be found.  This was the name before it was changed.

	Part 4 -  Check Log Files
	__1.  In the Admin Console click on the link for Troubleshooting -> Logs and Trace.
	__2.  Click the link for server1 in the list.
	__3.  Click the link for JVM Logs.
	__4.  On the Configuration tab look at some of the settings available.  Notice that you can configure the file name used for the log, enable and configure log file automatic rotation, and the number of historical log files to keep if rotation is enabled.  You can even disable “application print statements” although this is usually not a good idea because developers may be printing out valuable messages for tracking down errors.
	__5.  Click the Runtime tab.
	__6.  Write down the File Name of the System.out log in the Lab Notes section at the beginning of the labs.  This File Name is assembled using the settings from the Configuration tab along with the values of several environment variables.  Notice the default location of the log file is in a ‘server1’ subdirectory of the main ‘logs’ directory of your 'AppSrv01' WebSphere profile.
	__7.  Click the View button next to the System.out log file name to display the log file in the Admin Console.
	__8.  When the Admin Console displays the log file, notice the two numbers near the top.  The Admin Console displays the Total number of lines in the log file and the Filtered total which is what is actually displayed in the Console.
	__9.  Display the last three hundred lines of the log by entering in the Retrieve Lines text box a range that starts about three hundred lines before the total number of lines and ends with the last line.  In the above example this might be 7000-7340.  Press the Refresh button after entering the new range.
	__10.  When the log file is redisplayed (which may take a moment), scroll to the very bottom and begin scrolling backwards.  This will view the most recent messages first and go back to earlier messages.  Stop when you see any line that is tabbed in from the left and does not start with a time stamp.  This is the end of a Java “stack trace”.
	__11.  Continue to scroll backwards until you reach a block of several “normal” messages that start with timestamps and have an “I” or “A” for the event type.  You may pass several Java problems being reported together.  This is common in a Java multi-threaded application like a J2EE Application Server.  Usually the most detailed information is present in the first problem that gets reported.
	__12.  In the first line of the first Java problem reported scroll to the right.  You should see the same “NameNotFoundException” mentioned in the console message.  
	__13.  Logout of the admin console and close any extra web browsers or windows.

	Part 5 -  Use dumpNameSpace Tool
	__1.  Open a Command Prompt window.  You can do this by selecting Start -> Run, entering cmd and then pressing OK.
	__2.  Change directories using the 'cd' command to the <WAS_ROOT>\profiles\AppSrv01\bin directory.  Be sure to substitute the value of <WAS_ROOT> from the “Directory Paths” page at the beginning of the lab instructions.
	__3.  Issue the command dumpNameSpace.
	__4.  In the security prompt supply a user ID and password of 'wasadmin'.
	__5.  In the output look for the entry in the right column for hitcount.Counter.  You will need to scroll around a bit to find it.  This is the interface used by the EJB client.  Notice the entry on the left side is the incorrect JNDI name that we supplied.  You can use the messages we have seen to verify that the name expected by the EJB client, ejb/Counter, is not listed.  The line number where your entry shows up may be different.
	__6.  Close the command prompt window.

	Part 6 -  Correct the Problem
	__1.  Open a web browser and enter http://localhost:9060/ibm/console/, the URL for the Admin Console.
	__2.  Login to the Admin Console as 'wasadmin'.
	__3.  In the Admin Console, navigate to Applications → Application Types →  WebSphere enterprise applications.
	__4.  From the list of Enterprise Applications, click on the link for the HitCount application.
	__5.  Under the Enterprise Java Bean Properties section on the right side click the link for EJB JNDI names.
	__6.  In the JNDI Name field, change the value to ‘ejb/Counter’ and press the OK button.  
	__7.  Click the Save link in the messages at the top of the Admin Console.
	__8.  Check the checkbox next to the HitCount application and press the Stop button.
	__9.  Once the application is stopped, check the checkbox next to the HitCount application again and press the Start button.
	__10.  Open a web browser and enter http://was.myhost.com/HitCountWeb in the address bar.  You should see the main page of the application.
	__11.  Click the link on the page to submit a request that will begin counting the number of times you view a page.  The application should be able to correctly count the number of hits.
	__12.  Refresh the page several times to see the count increase.
	__13.  Logout of the Admin Console.
	__14.  Close any extra web browsers, Windows Explorer windows, or command prompts you may have open.

	Part 7 -  Summary

	Lab 5 -  IBM Support Assistant Troubleshooting
	Part 1 -  ISA Workbench
	__1.  Start the IBM Support Assistant by selecting 'Start → Programs → IBM Support Assistant → IBM Support Assistant Workbench 4.0'
	__2.  You may be prompted to run a customization wizard or to check for updates.  If you are prompted during this lab or other times using the ISA simply select 'No' or 'Cancel'.  
	__3.  Select 'File → Preferences' from the ISA menus.
	__4.  Select 'Network Connections'.  Do not change any settings now but this is where you would configure settings for a proxy server to allow the tool to connect to IBM and download updates to existing add-ons or install new add-ons.
	__5.  Select 'Updater Preferences'.  Do not change any settings now but this is where you can control how the ISA tool checks for updates to installed add-ons.
	__6.  Select 'Global Search → User Interface'.  This is where you can configure settings for the search tool.
	__7.  Click the Cancel button to close the preferences.
	__8.  Expand the Update menu to see the choices but do not make any selections.  This is where you can manually search for updates.  This is also the menu you would use to find new add-ons for other products or additional tools.  This can be very useful if using several different versions or types of IBM software.
	__9.  On the home screen, click the icon for the “Find Information” activity.
	__10.  The “Search Information” screen is where you can search multiple sources at once for various search terms.  The results are processed asynchronously so you do not have to wait for all sources to be searched before browsing results.  If you do not need a proxy to connect to the Internet you can try a search now.
	__11.  Click the tab for “Product Information”.  This page has useful links to product information.  If ISA can connect over the Internet it will also show links to some of the most recent product support news announcements.

	Part 2 -  Perform Guided Troubleshooting
	__1.  From the top left of the ISA tool, press the Launch Activity button to provide a menu and select Analyze Problem from the list.
	__2.  Click the 'Guided Troubleshooter' tab at the top.  It may take a second to initialize the tool.
	__3.  Leave the “Troubleshoot a problem” option selected and press the Next button.
	__4.  Fill in a “case name” of “Sample Problem” and press the Next button.  Normally you could also provide additional information about the problem here as well to store with the case.
	__5.  Select the “WebSphere Application Server Troubleshooting” option and press the Next button.  If you had support for other products installed you might be able to run guided troubleshooting for those products also.
	__6.  Leave the “Guide me...” option selected and press the Next button.
	__7.  Leave the “The application performs poorly...” option selected and press the Next button.  You will choose different options in this step depending on the actual problem you are trying to troubleshoot.  If you want more description about what types of problems each choice entails you can expand the information in the lower half of the screen using the '+' symbols.
	__8.  Select the “My application cannot connect...” option and press the Next button.
	__9.  Leave the option for “Troubleshoot JCA and JDBC...” selected and press the Next button.  If you select the “advanced troubleshooting” option early on instead of the “guide me” option you can skip directly to this type of choice.
	__10.  The next step simply describes in more detail the type of problems this troubleshooting covers so press the Next button.
	__11.  Leave the option for “JDBC Connection...” selected and press the Next button.
	__12.  The next step simply describes the steps that will be taken so press the Next button.
	__13.  Notice there is information in the lower section on how to open the Admin Console and perform a data source connection test.  Although we will not actually do this test the guided troubleshooting is helping you to perform basic tests like this.  Do not move to the next step yet.
	__14.  On the right side, in the “Case Manager” section, right click the 'Sample Problem' case and select 'New Note'.
	__15.  Fill in a name of 'Connection Test Error' for the note along with some sample text for the body of the note.  Normally you might copy the text of an error from the Admin Console or browser into the note text to store the results as part of the case.
	__16.  Press the OK button when you are done filling out the new note form.
	__17.  Back in the guided troubleshooting press the Next button.
	__18.  Press the Add Files button in the guided troubleshooting.
	__19.  On the window that appears expand the 'My Computer → Local Agent → Windows' groups.
	__20.  Expand the entry for the disk your WebSphere installation is on and find the location of the SystemOut.log file.  You should have this location written down in the lab notes from another lab.  Normally it is <Profile_Root>/logs/server1/SystemOut.log.
	__21.  Select the SystemOut.log file from the window.  If you have another file which starts with a timestamp this is a historical log file.  Select it also by holding the CTRL key while you click on it.  Once you have the logs you wish to include selected as shown below press the OK button.
	__22.  On the right side, in the “Case Manager” section, right click on one of the new files you added and notice the options.  Do not select any of them.
	__23.  Right click the 'Sample Problem' case and notice some of the various options.  Of particular importance is the import/export case options which would let you share all of the notes, results, and files of a case as a zip file.  You can also create a new “incident” if you see a repeat of a past problem but want to capture unique log files and other information.
	__24.  Back in the guided troubleshooter click the Pause Case button.
	__25.  Click the OK button to return to the first screen of the guided troubleshooter.

	Part 3 -  Analyze Log Files
	__1.  Open a Windows File explorer window and navigate to the <LABFILES_DIR>\Troubleshoot directory.
	__2.  Extract the zip file in this directory into the same location.  This should create a 'websphere_application_server_7_0_en.symptom' file.
	__3.  Select the Tools tab of the 'Analyze Problem' activity page.  If you do not have this section open select 'Launch Activity → Analyze Problem' first.
	__4.  From the list select the 'Log Analyzer' tool and press the Launch button at the bottom of the page.  Wait for a second for the tool to start.  The version of the Log Analyzer may be different and there may be other differences with the other tools that that shown below.
	__5.  When the tool opens you will be presented with the “Update Symptom Catalog List” dialog.  Press the No button.
	__6.  Select File -> Import Symptom Catalog...
	__7.  Check the Local host option and press the Browse button to locate the file <LABFILES_DIR>\Troubleshoot\websphere_application_server_7_0_en.symptom file.
	__8.  Press the Finish button to import the symptom catalog.  It may take a while to import.
	__9.  Select File → Import Log File from IBM Support Assistant... from the menus.  The wizard may take some time to initialize.
	__10.  Expand the 'Sample Problem' case and select all log files listed.  If you need to select more than one you can hold the CTRL key while clicking on the second.
	__11.  With the log files selected above, click the Add button below and to the right of the top list.  It may take a few seconds to add the logs.
	__12.  Next to the log file that appears below click the '<Select an adapter>' link.  If WebSphere is already listed as the adapter skip the next step.
	__13.  Select the 'IBM WebSphere Application Server (WAS) systemout log' choice from the list and click the OK button.
	__14.  Check that the logs you want to import appear on the bottom list and press the Finish button.  It may take several seconds to import the logs.
	__15.  In the 'Log Navigator' view you will see the various logs and symptom catalogs you imported.
	__16.  In the 'Log Navigator' view right click on the 'Logs' folder and select View All Logs.  This will combine the information from multiple logs if you have it.
	__17.  Click the Maximize button on the upper right corner of the Log View to expand it to take all the space in the window.
	__18.  At the top of the Log View you should see that there are many pages of records in the log.  Note the number of pages for your log file as it may be different than what is shown here.
	__19.  On the right side of the Log View click the button Go to Page as shown below.
	__20.  Enter the last page number for your log file and press the OK button.
	__21.  Scroll in the log file and see if you can find any error messages.  Although you could keep going to other pages to look for errors there is any easier way.
	__22.  Use the drop down next to the Manage Filters icon in the toolbar and select the 'Show warning and error log records' filter.
	__23.  Double click on one of the red log records that is in the list.
	__24.  Select the "Event Details" tab and look in the Properties view below to get the “Event Details” of the message.  Most importantly this should have the message text although you may want to maximize the Properties view or scroll in the message text to read it all.
	__25.  Close the Properties view.
	__26.  Select the warnings (with yellow severity) that mentions the NameNotFoundException.
	__27.  Right click on the message and select Analyze Selection.
	__28.  Maximize the 'Symptom Analysis Results View' that appears by double clicking on the title bar of the view.
	__29.  On the left, select the single result that appears in the list.
	__30.  On the right, select the 'Recommendations and actions' tab.
	__31.  In the detail section notice that the “Recommendation” has some additional information that could be used to help resolve the problem.
	__32.  Close the Log Analyzer.  When prompted, click Yes to save the log data.  If you were to click No the log file you imported (and perhaps the symptom database) would be lost.
	__33.  Close the IBM Support Assistant.

	Part 4 -  Review

	Lab 6 -  Install Database Application
	Part 1 -  Create Database
	__1.  Open a Windows Explorer window.
	__2.  Find the directory <LABFILES_DIR>\Database.
	__3.  If the instructor indicates that DB2 was installed with a different user and password open the 'SQLCommands.bat' file with a text editor like Wordpad and change the user and password in the file.  Remember to save when done.
	__4.  Run the script CreateDatabase.bat by double-clicking on it.  You should start to see messages about the script performing database commands.  Wait a few minutes while the script finishes creating and setting up the database.
	__5.  Open the CreateDB.log file from the same directory as the script and look for any obvious errors creating the database or importing the data.
	__6.  Close the Windows Explorer window.

	Part 2 -  Configure JDBC Provider
	__1.  Make sure your WebSphere server is running.  If it is not running start it using one of the methods you are already familiar with.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the Admin Console, navigate to Resources -> JDBC -> JDBC Providers.
	__5.  Use the drop down for the Scope setting at the top of the list to select Cell=<cellname>.  Once the scope of <cellname> is shown press the New button.
	__6.  On the first screen of the New JDBC Provider setup select the following options.  The contents of the last two drop down lists will change once you start selecting the first two options.  Press  the Next button once you have filled in the options as shown below.
	__7.  On the next page you should see some additional properties related to the Class path.  Look at the setting for Class path and notice it is defined with some environment variables. WebSphere detects that some of these variables have not been set and prompts you for the values.  Fill in the box for DB2UNIVERSAL_JDBC_DRIVER_PATH with a value of <DB2_ROOT>\java and remember to substitute the value of <DB2_ROOT> from the Directory Paths section at the beginning of the labs.  The final value should be something like 'C:\Program Files\IBM\SQLLIB\java'.  Leave the value of Native library path empty.
	__8.  Press the Next button when your screen appears as below.
	__9.  Press the Finish button to create the JDBC Provider.  You should see the new JDBC Provider in the list.
	__10.  Click the Save link in the messages at the top of the Admin Console.

	Part 3 -  Configure Security Authentication
	__1.  In the Admin Console navigate to Security -> Global Security.
	__2.  On the right side, under the Authentication section, expand Java Authentication and Authorization Service and click the link for J2C Authentication data.
	__3.  Press the New button on the list of entries.
	__4.  In the fields for the new Authentication Data Entry fill in the following properties.  Note that you only supply the password once and there is no “Confirm password” box that will check you enter the same value so be careful typing the password.  Press the OK button when the properties are filled in as below.
	__5.  Verify that the new entry shows up in the list.  Notice that the alias is prefixed with the name of the Node where the Application Server resides.
	__6.  Click the Save link in the messages at the top of the Admin Console.

	Part 4 -  Configure Data Source
	__1.  In the Admin Console, navigate to Resources -> JDBC -> JDBC Providers.
	__2.  Check that you are at the <cellname> scope as in previous sections of this lab.  If you need to switch scope, select the scope using the drop down list.
	__3.  Click the link for the JDBC Provider you configured in a previous section.  This should be DB2 Universal JDBC Driver Provider (XA) if you left the default name from before.
	__4.  On the right, under the Additional Properties section, click the link for Data Sources.  Be sure not to select the 'Data Sources (Version 4)' link.
	__5.  Press the New button above the list of Data Sources.
	__6.  On the first page of the Data Source configuration fill in or change the following values.
	__7.  Press the Next button once your values are filled in as below.
	__8.  On the second configuration page fill in the following values:
	__9.  Press the Next button once your values are filled in as below (with your hostname).
	__10.  On the security aliases step select the following choices and press the Next button.
	__11.  Press the Finish button to create the Data Source.  You should see the new Data source in the list.
	__12.  Click the Save link in the messages at the top of the Admin Console.
	__13.  In the list of Data Sources, check the box next to the Online Store DB Data Source and press the Test Connection button.
	__14.  Check that you get a message about a successful test.  You may get a warning but be sure you do not see red errors.  If you do not get a successful test, check the values of the database name of the Data Source, the value of the environment variable, and the user ID and password for the authentication alias as these are the most common errors.  You can use the troubleshooting techniques from the last lab to track down the problem or contact your instructor.
	__15.  Click the Logout link to logout of the Admin Console.
	__16.  Use a method you are familiar with to stop the Application Server.
	__17.  Once the Application Server is stopped start it again.

	Part 5 -  Install OnlineStore Database Application
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the Applications group in the navigation, click the link for New Application.
	__4.  Click the link for New Enterprise Application.
	__5.  Next to the Local file system box, press the Browse button.
	__6.  Find the file <LABFILES_DIR>\Database\OnlineStore-Database.ear and select Open in the file chooser dialog.  Remember to substitute the value of the <LABFILES_DIR> variable from the notes at the beginning of the labs.
	__7.  Press the Next button.
	__8.  Check the option for Detailed installation.  This will show all steps.
	__9.  Once you have the options specified as below, press the Next button.
	__10.  On Step 1: Select installation options leave the default options and press the Next button.
	__11.  On Step 2: Map modules to servers check the checkbox next to the OnlineStoreWeb module.  Select both servers from the list above by holding down the CTRL key as you select each one.  Press the Apply button to apply the changes to the mapping of the web module.  Make sure the OnlineStoreWeb module is mapped to BOTH servers as shown below and press the Next button.
	__12.  Click the link for Step 9 on the left to skip to this step.
	__13.  Check that the resource reference mapping for the data source matches the JNDI name you gave the data source in previous sections.  If you are not sure you can use the Browse button to pick the name of the data source from a list.  Once your resource reference mapping is set press the Next button.
	__14.  On Step 10: Map virtual hosts for web modules select myhost from the drop down menu and press the Next button.  This choice will make the application only available by using the was.myhost.com host name on port 80.
	__15.  Click the link for Step 13 on the left to skip to this step.
	__16.  On Step 13: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__17.  Click the Save link in the messages at the bottom of the Admin Console.
	__18.  Go back to the list of web servers by navigating to the Servers → Server Types → Web Servers section of the admin console.
	__19.  Check the box next to the webserver1 entry and click the Stop button.
	__20.  Check the box next to webserver1 and click the Start button.
	__21.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__22.  Check the checkbox next to the OnlineStore application and press the Start button.  Wait for a message that the application started successfully.

	Part 6 -  Test OnlineStore Application
	__1.  Open a Web Browser and enter http://was.myhost.com/Store in the address bar.  You should see the homepage of the application.
	__2.  Click on the Register link to display the page to register as a new Customer.
	__3.  Fill in the fields with some sample data.  The only requirements are that the Email and Full Name fields must be filled in and the Zip must contain only numbers.  Press the Register button. If there is any problem with the database or Data Source setup this is when you will find out.
	__4.  Click the link to Start Shopping.
	__5.  On the Product List, change some of the quantities to be non-zero and press the Add to Cart button.
	__6.  At this point you can either click the link to Add More Items or fill in the required address information and press the Complete purchase button.
	__7.  Test some of the other functions of the application.  Be sure you try to logout and log back in under the ID that you registered.
	__8.  Close the web browser you were using to test the application.
	__9.  Logout of the Admin Console and close the web browser.
	__10.  Close any extra web browsers, Windows Explorer windows, or command prompts you may have open.

	Part 7 -  Summary

	Lab 7 -  Enable JMS Messaging Using WebSphere MQ
	Part 1 -  Configure WebSphere MQ
	__1.  Open a Windows Command Prompt.  You can do this by selecting Start -> Run, entering cmd, and pressing OK.
	__2.  Create a new queue manager called STOREQM by entering the command below.
	__3.  Be sure you get a successful setup message as shown below.
	__4.  Start the Queue Manager by issuing the following command.
	__5.  Make sure that you get a message that the queue manager is started.
	__6.  Now you will create a local queue called STOREQ.  Enter the following command to start the MQSC administration tool.  Note that you will not be returned to a prompt but the tool will be waiting for input from you.  Go to the next step.
	__7.  Execute the following commands and hit Enter after each command.
	__8.  Test the configuration by putting a few messages in the queue.  To do this run the following command.  Again the tool will wait for further input after running this command.
	__9.  Enter a line of text and hit the Enter key.  Each line constitutes a message.  Enter a few different messages.  Finally, enter an empty line to end the session.
	__10.  Retrieve the messages using the following command.  Make sure you see the messages you put in the queue in the last step.  It will take several seconds for the tool to stop looking for messages.
	__11.  Close the command prompt you were using to configure the queue.  The queue manager will remain running for the rest of the lab.  If for some reason you restart your machine before finishing this lab you would need to restart the STOREQM queue manager.

	Part 2 -  Configure WebSphere MQ JMS Provider
	__1.  Be sure your Application Server is running.  Start it if it is not running.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the navigation pane select Resources -> JMS -> Connection factories.
	__5.  Use the drop down for the Scope setting at the top of the list to select Cell=<cellname>.  Once the scope of your cell is shown press the New button.
	__6.  Select the radio button for WebSphere MQ messaging provider and press the OK button.
	__7.  At the Configure basic attributes page, enter the following information.  Write down the JNDI Name of the Connection Factory in the Lab Notes section.  Press the Next button when done.
	__8.  Leave the default option to enter all connection information in the wizard and press the Next button.
	__9.  Enter 'STOREQM' for the queue manager and press the Next button.
	__10.  Enter your <hostname> in the connection details and press the Next button.
	__11.  Press the Test Connection button and be sure you get a successful connection.  Once you do press the Next button.
	__12.  Press the Finish button to create the connection factory.
	__13.  Click the link in the navigation pane for Resources -> JMS  -> Queues.
	__14.  Check that you are at the cell scope as in previous sections of this lab.  If you need to switch scope, select the scope using the drop down list.
	__15.  At the Queues list, press the New button.
	__16.  Select the radio button for WebSphere MQ messaging provider and press the OK button.
	__17.  At the New Queue page, enter the following information.  Leave the rest of the settings with the defaults.  Write down the JNDI Name of the Queue in the Lab Notes section.  Note the screenshots below only show the sections that have settings that are changed.
	__18.  When the values match those above press the OK button.
	__19.  Click the Save link in the messages at the top of the Admin Console.

	Part 3 -  Configure the JMS Activation Specification
	__1.  In the navigation pane select Resources -> JMS -> Activation specifications.
	__2.  Check that you are at the cell scope as in previous sections of this lab.  If you need to switch scope, select the scope using the drop down list.
	__3.  At the JMS Activation Specifications list, press the New button.
	__4.  Select WebSphere MQ messaging provider as the choice for provider and press the OK button.
	__5.  At the Configure basic attributes page, enter the following information.
	__6.  Write down the JNDI name of the Activation Specification in the “Lab 7” section of the Lab Notes and press the Next button.
	__7.  At the Specify MDB destination data page, enter the following information.
	__8.  Check that the Destination JNDI name matches the value you had written down in the Lab Notes section and press the Next button.
	__9.  Leave the default option to enter all connection information in the wizard and press the Next button.
	__10.  Enter 'STOREQM' for the queue manager and press the Next button.
	__11.  Enter your <hostname> in the connection details and press the Next button.
	__12.  Press the Test Connection button and be sure you get a successful connection.  Once you do press the Next button.
	__13.  Press the Finish button to create the activation specification.
	__14.  Click the Save link in the messages at the top of the Admin Console.
	__15.  Logout of the Admin Console.
	__16.  Restart your Application Server.

	Part 4 -  Install a Messaging Application
	__1.  Return to the web browser you were using for the Admin Console.  If you closed it, open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  Expand the Troubleshooting section in the navigation panel and expand Runtime Messages.
	__4.  Click the link for Runtime Error messages.
	__5.  Check that your settings for runtime events are set to 'Warning' or 'Error'.  If it is not then any errors that were reported during startup would not be shown in the Admin console.  If it was set to 'None', change the setting to 'Warning', press the Apply button, save the configuration and restart the server.
	__6.  Make sure that you do not see any messaging errors that occurred while starting the server.  If you do, contact your instructor so you can resolve these before continuing.
	__7.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__8.  Check the checkbox next to the OnlineStore application and press the Update button.
	__9.  Leave the option of Replace the entire application selected and Local File System radio button.
	__10.  Hit the Browse button next to the Full path text box.
	__11.  Navigate to the <LABFILES_DIR>\Messaging directory, select the OnlineStore‑Messaging.ear file, and press Open.
	__12.  With the path to the EAR file filled in press the Next button.
	__13.  Check the option for Detailed installation.  This will show all steps.
	__14.  Press the Next button.
	__15.  On Step 1: Select Installation options leave the default options and press the Next button.
	__16.  On Step 2: Map modules to servers check the checkbox next to the OnlineStoreWeb module.  Select both servers from the list above by holding down the CTRL key as you select each one.  Press the Apply button to apply the changes to the mapping of the web module.  Make sure the OnlineStoreWeb module is mapped to BOTH servers as shown below and press the Next button.
	__17.  On the list of steps on the left click the link for Step 6 to skip to this step.
	__18.  On Step 6: Provide listener bindings For message-driven beans use the following options for the PurchasePrinter EJB.  Check the values for these compare with the values you have written down in the Lab Notes section.
	__19.  Once you have checked this value press the Next button.
	__20.  Click the link for Step 10 on the list of steps on the left to skip to this step.
	__21.  On Step 10: Map resource references to resources check that the JNDI name of the Connection Factory listed matches what you had written down for these values in the Lab Notes section.  Also check that the JNDI name of the data source is still 'jdbc/store'.  Note that you will need to scroll around to find these values and the screenshots below only show the part of the screen with the settings.  Also note that the screenshot showing the Connection Factory below does not show the entire JNDI name value.  If you need to change these values for any reason you can use the Browse button to select the configured resource from a list which will eliminate chance for errors due to typos.
	__22.  Once you have checked these values press the Next button.
	__23.  On Step 11: Map resource environment entry references to resources check that the JNDI name of the queue matches what you had written down for these values in the Lab Notes section.
	__24.  Once you have checked these values press the Next button.
	__25.  At this point you will get a warning message.  Everything is fine.  Press the Continue button.
	__26.  On Step 12: Map virtual hosts for web modules select myhost from the drop down menu. This option may already be filled in but double check.
	__27.  On the list of steps on the left click the link for Step 15 to skip to the summary.
	__28.  On Step 15: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__29.  Click the Save link in the messages at the bottom of the Admin Console.
	__30.  In the list of Enterprise Applications, be sure the OnlineStore application is started. Navigate to Applications → Application Types → WebSphere enterprise applications if this list is not automatically displayed.

	Part 5 -  Test the Application
	__1.  Open a web browser and enter http://was.myhost.com/Store in the address bar.
	__2.  Login as a user that already exists on the system and has placed orders.
	__3.  Once you have logged in, click on the link on the left for Request Email.
	__4.  Once this page is displayed, click on the Request button.  This will generate a message from the Servlet that responds to the request.  You should get a fairly quick reply.  The normal response is shown below.
	__5.  Once you have verified that you can send a message properly, open a Windows Explorer window.
	__6.  Navigate to the directory that contains the System.out log file you had written down the location of in the Lab Notes section.  This should be the <WAS_ROOT>\profiles\AppSrv01\logs\server1 directory.
	__7.  Open the SystemOut.log file with a text editor.  Note that some text editors, like WordPad, may not want to open the file while the server is running.  Try to open it with NotePad if you have difficulty.
	__8.  Search for the text “onMessage” which is printed out when the application receives a message.  Underneath this you should see a section that prints out the details of orders for that user.  Note that some text editors, like NotePad, may not display the line breaks so you may see this information all on the same line as shown below or on several lines depending on the text editor.
	__9.  Close the log file.
	__10.  Close the web browser you were using to test the application.
	__11.  Logout of the Admin Console and close the web browser.

	Part 6 -  Summary

	Lab 8 -  Configure WebSphere Security
	Part 1 -  Backup Configuration
	__1.  Open a Command Prompt window.  You can do this by selecting Start -> Run, entering cmd and then pressing OK.
	__2.  Change directories using the 'cd' command to the <WAS_ROOT>\profiles\AppSrv01\bin directory.  Be sure to substitute the value of <WAS_ROOT> from the “Directory Paths” page at the beginning of the lab instructions.
	__3.  Enter the following command to backup the configuration to the file 'BeforeSecurity.zip':
	__4.  Check that you get a message about the configuration being successfully backed up.
	__5.  Leave the command prompt open as you will use it in several sections in the lab.

	Part 2 -  Examine Current Security Settings
	__1.  From the command prompt for the profile 'bin' directory used in the previous section issue the following command to start the server:
	__2.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the Admin Console navigate to Security → Global Security.
	__5.  On the main security page click the button for “Security Configuration Wizard”.
	__6.  In the wizard that appears notice that there are steps for collecting basic security configuration options.  The actual steps are not shown on the left until you make selections on the first step.
	__7.  Click the Cancel button to cancel the wizard.
	__8.  Notice that the option to “Enable administrative security” has already been checked off.
	__9.  In the User account repository section notice that “Federated repositories” is already set as the current setting.  Click the Configure button to view the current settings.
	__10.  Notice that there is already a Primary administrative user name of 'wasadmin' set.  This is why we can currently login to the Admin Console with this ID and perform all administrative tasks.
	__11.  In the navigation section on the left side of the Admin Console navigate to Users and Groups -> Manage Users.
	__12.  Click the Search button if the 'wasadmin' user is not already listed.
	__13.  Click the link for the 'wasadmin' user ID.
	__14.  Notice this is where you could change the password for the current default administrator or set additional properties like name and email.  Click the Cancel button.

	Part 3 -  Configure Admin Console Users
	__1.  In the navigation section on the left side of the Admin Console navigate to Users and Groups -> Manage Users.
	__2.  Type * in the Search for field and click the Search button to list the current users.
	__3.  Click the Create button and fill in the following user information:
	__4.  When the options are filled in as above click the Create button to create the user.
	__5.  On the confirmation screen click the Create Like button to create another similar user with the following information:
	__6.  Click the Create button to create the second new user.
	__7.  On the confirmation screen click the Create Like button to create another similar user with the following information:
	__8.  Click the Create button to create the third new user.
	__9.  Click the Close button to return to the list of users.
	__10.  Check that your list of users appears as below.
	__11.  In the navigation section on the left side of the Admin Console navigate to Users and Groups → Administrative User Roles.
	__12.  Click the Add button to add a new administrative user role.
	__13.  Select the 'Operator' role from the list above.  You may have to scroll down to see it.
	__14.  Press the Search button to show all current users.
	__15.  Select the 'wasoperator' user from the list on the left and press the right arrow button to add it to the list on the right.
	__16.  Click the OK button to add the user once your settings match those below.
	__17.  Check that the user shows up in the list of users and is an “Operator”.  
	__18.  In the navigation section on the left side of the Admin Console navigate to Users and Groups -> Administrative Group Roles.
	__19.  Click the Add button to add a new administrative group role.
	__20.  Fill in the following properties:
	__21.  Press the OK button when the options are as shown above.
	__22.  Click the Save link in the messages at the top of the Admin Console.
	__23.  Click the link to Logout of the Admin Console.

	Part 4 -  Test Administrative Roles
	__1.  On the login page of the Admin Console login using the user and password of 'wasoperator'.
	__2.  In the navigation section on the left side of the Admin Console navigate to Applications → Application Types → WebSphere enterprise applications.
	__3.  In the list of applications notice that you can stop and start applications but you can't install or uninstall applications.  These abilities are restricted to Administrators, Configurators, and Deployers.
	__4.  Click the link to Logout of the Admin Console.
	__5.  On the login page of the Admin Console login using the user and password of 'wasmonitor'.
	__6.  In the navigation section on the left side of the Admin Console navigate to Applications → Application Types → WebSphere enterprise applications.
	__7.  In the list of applications notice that you do not even have the ability to start or stop applications.  This is because the “Monitor” role has the fewest privileges.
	__8.  Click a link for one of the applications and notice that you can browse the settings but will not be able to change anything.  The text boxes and checkboxes for the settings are often “grayed out” or there is no “Apply” or “OK” button to be able to submit any changes.
	__9.  Once you have experimented to familiarize yourself with the various options that are disabled for non-Administrator roles click the Logout link in the Admin Console.

	Part 5 -  Configure Fine-grained Security
	__1.  On the login page of the Admin Console login using the user and password of 'wasadmin'.
	__2.  In the Admin Console navigate to Security -> Administrative Authorization Groups.
	__3.  Press the New button.
	__4.  Fill in a name of 'StoreSecurity', expand the 'Applications' group to check the 'OnlineStore' application, and expand the 'Nodes → <nodename> → Servers' group to check 'server1' as shown below.
	__5.  Press the Apply button once your settings are as shown above.
	__6.  Under 'Additional Properties' click the link for 'Administrative user roles'.
	__7.  Click the Add button to add a new administrative user role.
	__8.  Select the 'Administrator' role from the list above.  
	__9.  Press the Search button to show all current users.
	__10.  Select the 'storeadmin' user from the list on the left and press the right arrow button to add it to the list on the right.
	__11.  Click the OK button to add the user once your settings match those below.
	__12.  Check that the user shows up in the list of users and is an “Administrator”.  
	__13.  Click the Save link in the messages at the top of the Admin Console.
	__14.  Click the link to Logout of the Admin Console.
	__15.  On the login page of the Admin Console login using the user and password of 'storeadmin'.
	__16.  In the navigation section on the left side of the Admin Console navigate to Applications → Application Types → WebSphere enterprise applications.
	__17.  Notice that the list of applications is different and indicates what level of administrative access this user has for the different applications.  Notice that OnlineStore is the only application with a checkbox allowing us to start, stop, uninstall, etc.
	__18.  In the navigation section on the left side of the Admin Console navigate to Resources → JDBC → Data sources.
	__19.  Note that you can display the settings of the 'Online Store DB' data source but you can't modify the settings.  You could modify the settings of the 'Default Datasource' because it is at server scope which is part of the 'Administrative Authorization Group' of resources this user has Administrator privileges for.  You could also create a new data source at server scope if we needed to. Note. You may see a different number of data sources but you should have some to administrate and others to monitor.
	__20.  Once you have experimented to familiarize yourself with the various options that are available using the fine-grained security click the Logout link in the Admin Console.

	Part 6 -  Enable Application Security
	__1.  On the login page of the Admin Console login using the user and password of 'wasadmin'.
	__2.  In the Admin Console navigate to Security → Global Security.
	__3.  On the main security configuration page check the following options:
	__4.  Press the Apply button to submit the changes.
	__5.  Read some of the additional security related messages that appear once security is enabled.
	__6.  Click the Save link in the messages at the top of the Admin Console.
	__7.  Logout of the Admin Console.

	Part 7 -  Restart Application Server
	__1.  Return to the command prompt you used to start the server.  If you do not have one open, open a command prompt and change to the <WAS_ROOT>\profiles\AppSrv01\bin folder.
	__2.  Issue the command to stop the server and supply username and password options, 'stopServer server1 -username wasadmin -password wasadmin'.
	__3.  Issue the command to start the server, 'startServer server1'.

	Part 8 -  Summary

	Lab 9 -  Configure Java EE Security
	Part 1 -  Examine Current Behavior
	__1.  Be sure your Application Server is running.  Start it if it is not running.
	__2.  Open a Web Browser and enter http://was.myhost.com/Store in the address bar.  If you get any errors try restarting the web server.
	__3.  Click on the Find Purchases link on the left of the application homepage.
	__4.  In the form that appears fill in a Userid that you are sure has completed purchases and press the Find button.  If you have not completed any shopping cart purchases do that first.
	__5.  A screen is shown with a summary of all of the completed purchases for that user.  Click on the Details button for one of the purchases.
	__6.  Another screen shows the details of the purchase.
	__7.  Close the browser you were using to test the application.

	Part 2 -  Create Users for Secure Access
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the navigation section on the left side of the Admin Console navigate to Users and Groups -> Manage Users.
	__4.  Click the Search button to list the current users.
	__5.  Click the Create button and fill in the following user information:
	__6.  When the options are filled in as above click the Create button to create the user.
	__7.  On the confirmation screen click the Create Like button to create another similar user with the following information:
	__8.  Click the Create button to create the second new user.
	__9.  Click the Close button to return to the list of users.
	__10.  Check that your list of users appears as below.  The first and last names can be anything.
	__11.  In the navigation section on the left side of the Admin Console navigate to Users and Groups -> Manage Groups.
	__12.  Click the Create button and fill in the following group information:
	__13.  Click the Create button to create the group.
	__14.  Click the Close button to return to the list of groups.
	__15.  Click on the link for the new group name in the list of groups.
	__16.  Click the Members tab along the top of the group information.
	__17.  Click on the Add Users... button.
	__18.  Click on the Search button to list users.
	__19.  Hold the Ctrl button while you click the 'bob' and 'susan' users.
	__20.  Once both users are selected press the Add button.
	__21.  Click the Close button.
	__22.  Be sure that both users are listed as members of the group.

	Part 3 -  Install Secure Version of OnlineStore
	__1.  If you do not already have the Admin Console open, open a web browser and enter http://localhost:9060/ibm/console in the address bar.  Login as the 'wasadmin' user with a password of 'wasadmin'.
	__2.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__3.  Check the checkbox next to the OnlineStore application and press the Update button.
	__4.  Leave the option of Replace the entire application selected and Local File System radio button.
	__5.  Hit the Browse button next to the Full path text box.
	__6.  Navigate to the <LABFILES_DIR>\Security directory, select the OnlineStore‑Security.ear file, and press Open.
	__7.  Press the Next button when you have indicated the new EAR to use.
	__8.  Leave the default option of a “Fast Path” installation selected as shown below and press the Next button.
	__9.  On Step 1: Select Installation options leave the default options and press the Next button.
	__10.  On Step 2: Map modules to servers the appropriate mappings should already be filled in. Make sure the OnlineStoreWeb module is mapped to BOTH servers as shown below.  If it is not for some reason, check the checkbox next to the OnlineStoreWeb module.  Select both servers from the list above by holding down the CTRL key as you select each one.  Press the Apply button to apply the changes to the mapping of the web module.  
	__11.  Press the Next button once you have checked the module mapping.
	__12.  On Step 3: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__13.  Click the Save link in the messages at the bottom of the Admin Console.
	__14.  You should be returned to the list of applications.  If you are not navigate to Applications → Application Types → WebSphere enterprise applications.
	__15.  Click the link for the OnlineStore application.
	__16.  Under the Detail Properties section click the link for Security role to user/group mapping
	__17.  Check the checkbox next to the CSR role and click the Map Groups button.
	__18.  Press the Search button to list available groups.
	__19.  Select the OnlineCSRs group and press the right arrow button to move the group over to the “Selected” list on the right.
	__20.  Press the OK button on the group search page to accept the group.
	__21.  Check that the group is listed on the row with the CSR role and press the OK button.
	__22.  In the list of application properties click the link for User RunAs roles.
	__23.  Note that there are components in the application that are set to “run as” a specific security role.  In this application that is the message-driven EJB which must also access the functions that are being secured.
	__24.  Click the Save link in the messages at the top of the Admin Console.
	__25.  In the navigation section of the console expand the Servers → Server Types section and click the link for Web servers.
	__26.  Check the checkbox next to webserver1 and click the Generate Plug-in button.
	__27.  Check the checkbox next to webserver1 and click the Propagate Plug-in button.
	__28.  Check the checkbox next to webserver1 and click the Stop button.
	__29.  Check the checkbox next to webserver1 and click the Start button.
	__30.  Logout of the Admin Console.
	__31.  Close all web browsers you are using.

	Part 4 -  Test the Secure OnlineStore Application
	__1.  Open a Web Browser and enter http://was.myhost.com/Store in the address bar.
	__2.  Click on the Find Purchases link on the left of the application homepage.
	__3.  In the form that appears fill in a Userid that you are sure has completed purchases and press the Find button.
	__4.  You will be immediately prompted with a dialog that asks you for User name and password information.  Fill in 'hacker' as both of these values and press the OK button.
	__5.  You will be presented with the same screen again because this user is not in the user registry.  Fill in a User name and password of 'susan' or 'bob' and press the OK button.  You should be shown the list of purchases as before since this user was assigned to the security role for the application.
	__6.  Note the URL of the request that you were prompted for security information for.  This should be was.myhost.com/Store/FindPurchases.
	__7.  Click the Details button next to one of the purchases.
	__8.  Note the URL of this page as well.  This should be was.myhost.com/Store/PurchaseDetails.
	__9.  Close the web browser you were using to test the application.  Make sure all web browser windows are closed.
	__10.  Open a new Web Browser and enter http://was.myhost.com/Store in the address bar.
	__11.  Click on the Find Purchases link on the left of the application homepage.
	__12.  In the form that appears fill in a Userid that you are sure has purchases and press the Find button.
	__13.  When prompted for the User name and password fill in 'wasadmin' for both values and press the OK button.
	__14.  You will be presented with a page that indicates you are not authorized to view this page. This is because even though the 'wasadmin' user has the right to access the WebSphere Admin Console it was not granted access to the security role for the OnlineStore application.
	__15.  Close the web browser you were using to test the application.
	__16.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__17.  Login as the 'wasadmin' user.
	__18.  In the navigation section on the left side of the Admin Console navigate to Users and Groups -> Manage Users.
	__19.  Click the Search button to list the current users.
	__20.  Click the Create button and fill in the following user information:
	__21.  When the options are filled in as above click the Group Membership button.
	__22.  Click the Search button to search for groups.
	__23.  Select the OnlineCSRs group on the right and click the < Add button to move it to the left.
	__24.  Press the Close button to close the group membership dialog.
	__25.  Press the Create button to create the user.
	__26.  Logout of the Admin Console and close the web browser.
	__27.  Open a new Web Browser and enter http://was.myhost.com/Store in the address bar.
	__28.  Click on the Find Purchases link on the left of the application homepage.
	__29.  In the form that appears fill in a Userid that you are sure has purchases and press the Find button.
	__30.  When prompted for the User name and password fill in 'newCSR' for both values and press the OK button.
	__31.  You should see the page showing the list of orders placed by the user you filled in the form for.  This proves you can allow new users to access the secure functions simply by adding them to the group defined in the user registry.
	__32.  Close the web browser you were using to test the application.

	Part 5 -  Disable WebSphere Security
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the Admin Console navigate to Security → Global security.
	__4.  On the main security configuration page uncheck the following options:
	__5.  Press the Apply button to submit the changes.
	__6.  Click the Save link in the messages at the top of the Admin Console.
	__7.  Logout of the Admin Console.
	__8.  Restart your Application Server using any method you are familiar with.
	__9.  Close any extra web browsers, Windows Explorer windows, or command prompts you may have open.

	Part 6 -  Examine Security Policies (Optional)
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__4.  Click the link for the OnlineStore application.
	__5.  On the right of the application properties, click the Manage Modules link.
	__6.  Click the link for the OnlineStoreWeb module.
	__7.  Click the View Deployment Descriptor link.
	__8.  Scroll down until you see the 'security-constraint' tag.
	__9.  Notice within this tag the two major entries of 'web-resource-collection' and 'auth‑constraint'.  The 'web-resource-collection' indicates that the two URLs we have seen are secure and the 'auth‑constraint' associates these URLs with the CSR security role.
	__10.  Notice that the CSR security role is also defined in a separate tag of the deployment descriptor after the end of the 'security-constraint' tag.
	__11.  In the “breadcrumbs” at the top of the page click the Manage Modules link to return to the list of modules.
	__12.  Click the link for the OnlineStoreEJB module.
	__13.  Click the View Deployment Descriptor link.
	__14.  Scroll down until you see the 'assembly-descriptor' tag.
	__15.  Note that inside this tag there is also a definition of the CSR security role.
	__16.  Also notice that there are two 'method-permission' tags.  These indicate that the two methods listed here are granted access only to the CSR role.
	__17.  Look a little further up at the definition of the “PurchasePrinterBean” message-driven EJB.  Notice that it is configured with the 'run-as' configuration and linked to the CSR security role.  Without this setting the message-driven EJB would fail when it attempted to access the secure EJB method to find all the purchases for the user which sent the message.
	__18.  Logout of the Admin Console and close the web browser.

	Part 7 -  Summary

	Lab 10 -  Use wsadmin Scripting
	Part 1 -  Start an Interactive wsadmin Session
	__1.  If it is not already running, use the method of starting the Application Server you are most familiar with.
	__2.  Be sure you have logged out of any Admin Console windows that may be open and closed the web browsers you were using.
	__3.  Open a Windows Explorer window and navigate to the <WAS_ROOT>\profiles\AppSrv01\properties directory.
	__4.  Open the wsadmin.properties file with a text editor like WordPad.
	__5.  Find the section in the file for the 'defaultLang' property and change the value to 'jython' as shown below.
	__6.  Save and close the file.
	__7.  Open a Windows Command Prompt.  You can do this by selecting Start -> Run, entering cmd, and pressing OK.
	__8.  In the Command Prompt, switch to your <WAS_ROOT>\profiles\AppSrv01\bin directory.  Use the value of <WAS_ROOT> that you wrote down in the Directory Paths section.
	__9.  Issue the following wsadmin command to start the wsadmin environment in interactive mode:
	__10.  When prompted, enter a username and password of 'wasadmin'.
	__11.  Make sure that you do not get any authentication errors when connecting.  If you do issue the quit command and start the session again.

	Part 2 -  List Installed Applications
	__1.  Since a list of applications is required the AdminApp object will probably be involved. Issue the command: 
	__2.  In the output of the help text you should see a list function.  This looks like the function you need and now just need to check the syntax of how to use it.  Issue the command:
	__3.  From the output of the help on the list function you should see that the command does not require any arguments.  This makes the command easy to call.  Issue the command:
	__4.  You should see all the installed applications listed.  Leave the wsadmin window open for the next section.

	Part 3 -  Stop and Start an Application
	__1.  You should already have a wsadmin window open from the last section.  If you do not, start one using the instructions from the beginning of this lab.
	__2.  To get the help text for the AdminApp object issue the command:
	__3.  If you look through the functions available you should notice there are none for stopping and starting an application.  Since you are trying to control whether or not an application is running it is likely you will go through the AdminControl object since this provides access to other MBeans in the runtime environment.
	__4.  Declare a variable to store a reference to the ApplicationManager MBean.
	__5.  Now you need to find out how to use this object to control applications.
	__6.  In the help output notice there is an operations function available from the Help object that can list all the operations of an MBean.  Now you need to know how to use this function.
	__7.  Notice there are two versions of this function.  One can list all operations available in an MBean the other can give you help on a specific operation.
	__8.  Notice that there are startApplication and stopApplication operations available from the ApplicationManager MBean.  These are the operations you will need to use.  Issue the command to get help on the stopApplication operation.
	__9.  Notice the only parameter required for the stopApplication operation is a String of the application name.
	__10.  Issue the command:
	__11.  There are a few different ways to invoke operations on other MBeans depending on if they have arguments.  Issue the following command and note there will be no output:
	__12.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__13.  Login as the 'wasadmin' user.
	__14.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__15.  Notice the HitCount application is stopped.
	__16.  Back in the wsadmin scripting session issue the command:
	__17.  In the Admin Console, click the link for Applications → Application Types → WebSphere enterprise applications again to refresh the page.
	__18.  Notice the HitCount application is started.  
	__19.  Logout of the Admin Console and close the web browser.  Leave the wsadmin window open for the next section.

	Part 4 -  View Data Source Properties
	__1.  You should already have a wsadmin window open from the last section.  If you do not, start one using the instructions from the beginning of this lab.
	__2.  The properties of an existing DataSource object would be stored in the WebSphere configuration. To work with the WebSphere configuration you will be using the AdminConfig object.  Issue the command:
	__3.  Notice that the AdminConfig object has a list operation just like the AdminApp object does.  Issue the command:
	__4.  Notice that both versions of the list function take an argument for the ‘type’.  Although we are fairly certain of the type of object you are looking for here it would still be good to check to be sure.  It is good to do this just to check things like spelling and capitalization which are important in wsadmin.  Look back at the general help for the AdminConfig object.  Notice there is also a types function.  Issue the command:
	__5.  Notice there are a lot of types available in the configuration structure.  Scroll up this list and look for some you recognize like WebContainer, VirtualHost, Server, MessageListenerService, JMSDestination, JDBCProvider, EJBContainer, and finally DataSource.
	__6.  Now you know you can use the list operation of the AdminConfig object to list all configuration elements of a DataSource type.  Issue the command:
	__7.  You should see that there are two DataSource objects listed.  You are trying to list information about the "Online Store DB" DataSource.  To get the properties of one of them you need a reference to the appropriate configuration ID.  This is so you can identify exactly which configuration object to work with as this id will be unique.  The AdminConfig operation used to get the configuration ID is getid.  Issue the command:
	__8.  Notice the only thing needed to get a configuration ID is a "containment path".
	__9.  The AdminConfig object has a parents operation which lists what configuration objects are valid parents of a configuration type.  Issue the command:
	__10.  Notice the only valid parent of a DataSource is a JDBCProvider.  Issue the command below to find the valid parents of a JDBCProvider:
	__11.  Notice there are four valid parents of a JDBCProvider.  This is determined by what scope the JDBCProvider is configured at.  The "Deployment" scope is used if the application is deployed as an "Enhanced EAR" that has additional deployment information in the EAR file itself.  In the single server mode of WebSphere Application Server the other three scopes are not very different.  They will become very important as we discuss the clustering support of WebSphere.  Now you need to figure out what JDBCProvider contains the DataSource you are looking for and at what scope it is defined.  Issue the following command:
	__12.  In the output notice there is a "DB2 Universal …" JDBCProvider listed.  This is the JDBCProvider which is the parent of the "Online Store DB" DataSource.  Notice in the rest of the information printed the JDBCProvider is configured in a "resources.xml" file and the scope is "cells/<hostname>Node01Cell".  This JDBCProvider is at the cell scope.
	__13.  Now you finally have enough information to locate the DataSource you need.  You will store the reference to the DataSource using a variable so it will be easier to work with in future commands.  Note that since the resource is at cell scope we do not need node or server name.  Note that this command must be entered on one line.  The containment path is also enclosed by a pair of double quotes because the containment path contains spaces.  Issue the command below noting that the containment path is so long it has wrapped onto several lines.  Enter this command on one line.  Make sure that there is not a blank value stored in the variable.  If you get an error with this command double-check the command again, especially the name of the JDBCProvider and the name of the DataSource.
	__14.  Make sure you do not see any errors in the output of the last command before continuing.
	__15.  Notice in the output of this command (or 2 commands with Jython) that there is only one configuration id listed.  Although it is the same value as what you got by listing all of the DataSources you are now referring to only one of them.
	__16.  You can now show the attributes of the DataSource.  There are several operations that can be used to show attributes.
	__17.  Notice the operation attributes which can be used to show what attributes are available for a given type.  This operation also lists the type of value for each attribute.
	__18.  Notice the output refers to basic attributes that have "String" values and complex attributes like "connectionPool" or "mapping" which have values of other configuration types.  You can find the attributes of these other types also.
	__19.  The AdminConfig object also has show, showall, and showAttribute operations which display information about a specific configuration object.  These can be used depending on how much information you require.  The showall operation displays the most information as it recursively displays information for any child configuration objects.  The showAttribute displays only the value of a single attribute. 
	__20.  Notice you can see attribute values of the DataSource the ds variable refers to like the jndiName of "jdbc/store" and the name of "Online Store DB".
	__21.  Leave your wsadmin window open as you will be working with the DataSource in the next section and can reuse the variable that refers to it.

	Part 5 -  Modify Data Source Properties
	__1.  You should already have a wsadmin window open from the last section.  If you do not, start one using the instructions from the beginning of this lab.
	__2.   If you had to open a new wsadmin session, execute the commands from step 13 of the previous section.  This will setup a ds variable to refer to the DataSource you will modify.
	__3.  Now that you have a reference to the DataSource you can view the current value of the name property you will be modifying.
	__4.  Since you have a reference to the DataSource and know the property you wish to change you can tell the AdminConfig object to change the property value.  This is done with the modify operation of the AdminConfig object.
	__5.  Notice this operation takes two parameters, config id and attributes.  The config id is already stored in the ds variable.  The attributes parameter is a list of attributes that you wish to modify.  This means that you must supply a list of name/value pairs.  This is done slightly differently for each of the two scripting languages.  With Jython you use double quotes around the name and value of the property (whether or not they contain spaces); plus, you need a comma between them.  With Jacl you only need double quotes around the property value if it contains spaces.  
	__6.  Now that you have changed the value of the property you can check that the new property is being used.
	__7.  Even though the new property value is listed by the above command it is not yet saved to the configuration.  It is just a temporary change in your wsadmin session.
	__8.  This lists the resources.xml file that stores the DataSource configuration as containing unsaved changes.  Issue the command:
	__9.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__10.  Login as the 'wasadmin' user.
	__11.  In the Admin Console, navigate to Resources -> JDBC -> Data sources.
	__12.  Be sure the scope listed at the top of the page is set to your cell.  If it is not, use the drop-down list to switch to this scope.
	__13.  Notice the name of the Data Source listed has changed from "Online Store DB" to "Online Store Database".
	__14.  Logout of the Admin Console and close the web browser.  Leave the wsadmin window open for the next section.

	Part 6 -  Retrieve Server Properties
	__1.  You should already have a wsadmin window open from the last section.  If you do not, start one using the instructions from the beginning of this lab.
	__2.  You can also get additional information about the server process itself.  This requires referring to the MBean which represents the server process.  Issue the command:
	__3.  You can now use this reference and the operations available from the Help object to determine what else you can use the server variable to find.
	__4.  Among the other operations available notice the operations for retrieving the name and Pid of the server.  Neither of these operations requires parameters.  Again, as before, you must use the AdminControl object to invoke operations of MBeans.
	__5.  Note the Process ID returned by the operation here: 	 .  
	__6.  Open the Windows Task Manager.  You can do this by pressing Ctrl-Alt-Delete at the same time and pressing the ‘Task Manager’ button if a dialog appears.
	__7.  Find the process indicated by the Process ID.  You may need to select a "Processes" tab to view the processes.  If you are using Windows XP you may also need to select View -> Select Columns and check the "PID" column off on the list.  Often it is easiest to sort by memory used to find the server process.  
	__8.  Notice the process which matches the Process ID is a ‘java.exe’ process.  You may notice another ‘java.exe’ process.  This is the interactive wsadmin environment.  This represents the power of JMX, having one Java process connect and manage another.
	__9.  Close the Task Manager.
	__10.  In the command prompt running the wsadmin session issue the quit command to finish the wsadmin session.
	__11.  Stop the Application Server using the method you are most familiar with.
	__12.  Close any extra web browsers, Windows Explorer windows, or command prompts you may have open.

	Part 7 -  Summary

	Lab 11 -  Web Services
	Part 1 -  Update OnlineStore with Web Service
	__1.  Be sure your Application Server is running.  Start it if it is not running.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__5.  Check the checkbox next to the OnlineStore application and press the Update button.
	__6.  Leave the option of Replace the entire application selected and Local File System radio button.
	__7.  Hit the Browse button next to the Full path text box.
	__8.  Navigate to the <LABFILES_DIR>\WebServices directory, select the OnlineStore‑WebService.ear file, and press Open.
	__9.  With the path to the EAR file filled in press the Next button. 
	__10.  Leave the default option of a “Fast Path” installation selected as shown below and press the Next button.
	__11.  On Step 1: Select Installation options leave the default options and press the Next button.
	__12.  On Step 2: Map modules to servers check both the checkboxes next to the OnlineStoreWeb and OnlineStore-HTTPRouter modules.  Select both servers from the list above by holding down the CTRL key as you select each one.  Press the Apply button to apply the changes to the mapping of the web modules.  Make sure BOTH the modules are mapped to BOTH servers as shown below and press the Next button.
	__13.  On Step 3: Map virtual hosts for web modules select myhost from the drop down menu next to both web modules and press the Next button.  This choice will make the application only available by using the was.myhost.com host name on port 80.  This means the web service will also be available only on this address.
	__14.  On Step 4: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__15.  Click the Save link in the messages at the bottom of the Admin Console.

	Part 2 -  Update Web Service HTTP Endpoint
	__1.  If you are not currently viewing the list of enterprise applications, navigate to Applications → Application Types → WebSphere enterprise applications.
	__2.  Click the link for the OnlineStore application.
	__3.  Scroll down and in the list of 'Web Services Properties' on the right click the link for Provide HTTP endpoint URL information.
	__4.  Note that because we mapped the “router” module to a virtual host which has only one alias and that alias is not the default hostname and port of the WebSphere server we do not have any “default” HTTP prefixes available.
	__5.  Fill in 'http://was.myhost.com' without the quotes for the HTTP URL prefix value next to the module listed and press the OK button.  Note that you can just type the value in directly and you do not need to use the options and Apply button above the settings.
	__6.  Click the Save link in the messages at the top of the Admin Console.
	__7.  Back in the list of applications click the link for the OnlineStore application.
	__8.  Scroll down and in the list of 'Web Services Properties' on the right click the link for Publish WSDL files.
	__9.  On the page that appears click the link for the zip file of WSDL files.
	__10.  If prompted to open or save the file, open it with zip file software if possible.  If you can't open it directly save it first and then open the zip file.
	__11.  Expand the folders of the zip file if needed until you see the 'StoreFacadeService.wsdl' file.
	__12.  Open the 'StoreFacadeService.wsdl' file with a text editor like WordPad.  If you need to, extract the file first and then open it.
	__13.  Scroll down in the WSDL file and notice at the end that the SOAP address uses a location that starts with 'http://was.myhost.com'.  If we did not set the endpoint URL information for the service the WSDL package to publish would not be useable.
	__14.  Close the WSDL and the zip file.
	__15.  Back in the Admin Console return to the list of enterprise applications by navigating to Applications → Application Types → WebSphere enterprise applications.
	__16.  Check the checkbox next to the OnlineStore application and press the Stop button.  
	__17.  Check the checkbox next to the OnlineStore application and press the Start button. Wait for a message that the application started successfully.
	__18.  Open a Web Browser and enter http://was.myhost.com/Store in the address bar. You should see the homepage of the application.
	__19.  Login as a registered user.
	__20.  Close the web browser.

	Part 3 -  Install Web Service Client
	__1.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__2.  Click the Install button to start the installation process.
	__3.  Next to the Local file system box, press the Browse button.
	__4.  Navigate to the <LABFILES_DIR>\WebService directory, select the OnlineStoreServiceClient.ear file, and press Open.
	__5.  Press the Next button when you have indicated the new EAR to use.
	__6.  Leave the default option of a “Fast Path” installation selected as shown below and press the Next button.
	__7.  On Step 1: Select Installation options leave the default options and press the Next button.
	__8.  On Step 2: Map modules to servers check the checkbox next to the OnlineStoreServiceClientWeb module.  Select both servers from the list above by holding down the CTRL key as you select each one.  Press the Apply button to apply the changes to the mapping of the web module.  Make sure the module is mapped to BOTH servers as shown below and press the Next button.
	__9.  On Step 3: Map virtual hosts for web modules select myhost from the drop down menu next to the web module and press the Next button.  This choice will make the application only available by using the was.myhost.com host name on port 80.  
	__10.  On Step 4: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__11.  Click the Save link in the messages at the bottom of the Admin Console.
	__12.  Check the checkbox next to the OnlineStoreServiceClient application and press the Start button.  Wait for a message that the application started successfully.
	__13.  Open a Web Browser and enter http://was.myhost.com/ServiceClient in the address bar. You should see the homepage of the application.
	__14.  Click the link to 'View Partner Products'.  After several seconds you will get an error that will be explained and fixed in the next section.
	__15.  Close the browser you were using to test the web service client application.

	Part 4 -  Fix Web Service Client
	__1.  Back in the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__2.  Click the link for the OnlineStoreServiceClient application.
	__3.  Scroll down and in the list of 'Web Services Properties' on the right click the link for Service clients.
	__4.  Click the link for the Module on the right.  If you click the service name on the left it will take you to web service policies which are not being used for this web service.
	__5.  In the list of module 'Web Services Properties' on the right click the link for Web services client bindings.
	__6.  In the list you will see two entries for “services” that have the same name.  This is because the code generated by the development tool contains a reference to the service as well as the Servlet used to display the page you saw before.  We will update settings for both.
	__7.  Click the first 'Edit' link in the 'Port Information' column.  Make sure you do not click the link in the 'mappings' column.
	__8.  As you can see from the address listed this is why the client did not work.  It was using the default location that was part of the WSDL generated by the development environment which is not the URL the web service is available on now.
	__9.  Change the hostname of the URL so the entire URL is 'http://was.myhost.com/StoreRouter/StoreFacadeService' without the quotes.  Once your value is set as shown below press the OK button.  Note the screenshot below does not show the end of the URL but the hostname portion is the only thing you need to update.
	__10.  Click the second 'Edit' link in the 'Port Information' column.  Make sure you do not click the link in the 'mappings' column.
	__11.  Notice that the URL of the service reference has already been modified with the new hostname.  This is because both of the service references use the same name of 'StoreFacadeService'.  If the references used different names you would need to change both.
	__12.  Click the Save link in the messages at the top of the Admin Console.
	__13.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__14.  Check the checkbox next to the OnlineStoreServiceClient application and press the Stop button.  
	__15.  Check the checkbox next to the OnlineStoreServiceClient application and press the Start button. Wait for a message that the application started successfully.
	__16.  Open a Web Browser and enter http://was.myhost.com/ServiceClient in the address bar. 
	__17.  Click the link to 'View Partner Products'.  After several seconds you will get the normal response which is a table with the list of products.
	__18.  Close the browser you were using to test the web service client application.
	__19.  Open a Windows Explorer window and navigate to the <IHS_ROOT>\logs directory.
	__20.  Open the 'was.myhost.com-access_log' file with a text editor like NotePad.  Some text editors like WordPad may not want to open the file as it is in use by the web server.
	__21.  Scroll to the bottom of the file and notice that in addition to calls to the '/ServiceClient/...' application which is the web application of the web service client, there is a call to '/StoreRouter/StoreFacadeService'.  This is the web service implementation and this proves that the web service request from the web service client is being routed through the web server.
	__22.  Close the log file.
	__23.  Logout of the Admin Console and close any extra web browsers or command prompts.

	Part 5 -  Summary

	Alternate Lab 1 -  Enable JMS Messaging Using Default Messaging
	Part 1 -  Configure Service Integration Bus
	__1.  If it is not already running, start the server using the method you are most familiar with.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the navigation pane, select Service integration -> Buses.
	__5.  At the Buses list, press New.
	__6.  For the properties of the new Bus change the following properties.
	__7.  When the properties appear as above press the Next button.
	__8.  Press the Finish button to create the bus.
	__9.  In the list of Buses click the link for the OnlineStoreBus.
	__10.  Under the Topology section click the link for Bus members.
	__11.  Press the Add button.
	__12.  Accept the defaults for Server and press the Next button.
	__13.  Select the Data store option for type of message store.
	__14.  Press the Next button when the option to use a Data store is selected.
	__15.  Leave the default option of Create default data source with generated JNDI name selected and press the Next button.
	__16.  Leave the default options under Tune performance parameters so that the heap size is not adjusted and press the Next button.
	__17.  Press the Finish button to add the server as a Bus member.
	__18.  Ensure the new server is added to the list of bus members.
	__19.  In the “Breadcrumb” trail at the top of the page click the link for OnlineStoreBus to return to the properties of the Bus.
	__20.  Under the Destination Resources section click the link for Destinations.
	__21.  Press the New button.
	__22.  Select a destination type of Queue and press the Next button.
	__23.  Fill in OnlineStoreQueue as the Identifier and press the Next button.
	__24.  Leave the server as the bus member assigned to the Queue and press the Next button.
	__25.  Press the Finish button to complete creating the Queue.
	__26.  Ensure the Queue is listed on the list.
	__27.  Click the Save link in the messages at the top of the Admin Console.

	Part 2 -  Configure the Default Messaging Provider
	__1.  In the navigation pane select Resources -> JMS -> Connection factories.
	__2.  Use the drop down for the Scope setting at the top of the list to select Cell=<cellname>.  Once the scope of your cell is shown press the New button.
	__3.  Select the radio button for Default messaging provider and press the OK button.
	__4.  At the New JMS Connection Factory page, enter the following information.  Write down the JNDI Name of the Connection Factory in the “Lab 7 & Alternate Lab 1” section of the Lab Notes.  Note the screenshots below only show the sections that have settings that are changed.
	__5.  When the properties match that above press the OK button.
	__6.  Click the link in the navigation pane for Resources -> JMS  -> Queues.
	__7.  Check that you are at the cell scope as in previous sections of this lab.  If you need to switch scope, select the scope using the drop down list.
	__8.  At the Queues list, press the New button.
	__9.  Select the radio button for Default messaging provider and press the OK button.
	__10.  At the New Queue page, enter the following information.  Leave the rest of the settings with the defaults.  Write down the JNDI Name of the Queue in the “Lab 7 & Alternate Lab 1” section of the Lab Notes.  Note the screenshots below only show the sections that have settings that are changed.
	__11.  When the values match those above press the OK button.
	__12.  Click the Save link in the messages at the top of the Admin Console.

	Part 3 -  Configure the JMS Activation Specification
	__1.  In the navigation pane select Resources -> JMS -> Activation specifications.
	__2.  Check that you are at the cell scope as in previous sections of this lab.  If you need to switch scope, select the scope using the drop down list.
	__3.  At the JMS Activation Specifications list, press the New button.
	__4.  Select Default messaging provider as the choice for provider so press the OK button.
	__5.  At the New Activation Specification page, enter the following information but do not press the OK button yet.
	__6.  Check that the Destination JNDI name matches the value you had written down in the Lab Notes section.
	__7.  Write down the JNDI name of the Activation Specification in the “Lab7 & Alternate Lab 1” section of the Lab Notes.
	__8.  When the properties match that shown in the previous steps press the OK button.
	__9.  Click the Save link in the messages at the top of the Admin Console.
	__10.  Logout of the Admin Console.
	__11.  Restart your Application Server.

	Part 4 -  Install a Messaging Application
	__1.  Return to the web browser you were using for the Admin Console.  If you closed it, open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  Expand the Troubleshooting section in the navigation panel and expand Runtime Messages.
	__4.  Click the link for Runtime Error messages.
	__5.  Check that your settings for runtime events are set to 'Warning' or 'Error'.  If it is not then any errors that were reported during startup would not be shown in the Admin console.  If it was set to 'None', change the setting to 'Warning', press the Apply button, save the configuration and restart the server.
	__6.  Make sure that you do not see any errors that occurred while starting the server.  If you do, contact your instructor so you can resolve these before continuing.
	__7.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__8.  Check the checkbox next to the OnlineStore application and press the Update button.
	__9.  Leave the option of Replace the entire application selected and Local File System radio button.
	__10.  Hit the Browse button next to the Full path text box.
	__11.  Navigate to the <LABFILES_DIR>\Messaging directory, select the OnlineStore‑Messaging.ear file, and press Open.
	__12.  With the path to the EAR file filled in press the Next button.
	__13.  Check the option for Detailed installation.  This will show all steps.
	__14.  Press the Next button.
	__15.  On Step 1: Select Installation options leave the default options and press the Next button.
	__16.  On Step 2: Map modules to servers check the checkbox next to the OnlineStoreWeb module.  Select both servers from the list above by holding down the CTRL key as you select each one.  Press the Apply button to apply the changes to the mapping of the web module.  Make sure the OnlineStoreWeb module is mapped to BOTH servers as shown below and press the Next button.
	__17.  On the list of steps on the left click the link for Step 6 to skip to this step.
	__18.  On Step 6: Provide listener bindings For message-driven beans use the following options for the PurchasePrinter EJB.  Check the values for these compare with the values you have written down in the Lab Notes section.
	__19.  Once you have checked this value press the Next button.
	__20.  Click the link for Step 10 on the list of steps on the left to skip to this step.
	__21.  On Step 10: Map resource references to resources check that the JNDI name of the Connection Factory listed matches what you had written down for these values in the Lab Notes section.  Also check that the JNDI name of the data source is still 'jdbc/store'.  Note that you will need to scroll around to find these values and the screenshots below only show the part of the screen with the settings.  Also note that the screenshot showing the Connection Factory below does not show the entire JNDI name value.  If you need to change these values for any reason you can use the Browse button to select the configured resource from a list which will eliminate chance for errors due to typos.
	__22.  Once you have checked these values press the Next button.
	__23.  On Step 11: Map resource environment entry references to resources check that the JNDI name of the queue matches what you had written down for these values in the Lab Notes section.
	__24.  Once you have checked these values press the Next button.
	__25.  At this point you will get a warning message.  Everything is fine.  Press the Continue button.
	__26.  On Step 12: Map virtual hosts for web modules select myhost from the drop down menu. This option may already be filled in but double check.
	__27.  On the list of steps on the left click the link for Step 15 to skip to the summary.
	__28.  On Step 15: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__29.  Click the Save link in the messages at the bottom of the Admin Console.
	__30.  In the list of Enterprise Applications, be sure the OnlineStore application is started. Navigate to Applications → Application Types → WebSphere enterprise applications if this list is not automatically displayed.

	Part 5 -  Test the Application
	__1.  Open a web browser and enter http://was.myhost.com/Store in the address bar.
	__2.  Login as a user that already exists on the system and has placed orders.
	__3.  Once you have logged in, click on the link on the left for Request Email.
	__4.  Once this page is displayed, click on the Request button.  This will generate a message from the Servlet that responds to the request.  You should get a fairly quick reply.  The normal response is shown below.
	__5.  Once you have verified that you can send a message properly, open a Windows Explorer window.
	__6.  Navigate to the directory that contains the SystemOut.log log file you had written down the location of in the Lab Notes section.  This should be the <WAS_ROOT>\profiles\AppSrv01\logs\server1 directory.
	__7.  Open the SystemOut.log file with a text editor.  Note that some text editors, like WordPad, may not want to open the file while the server is running.  Try to open it with NotePad if you have difficulty.
	__8.  Search for the text “onMessage” which is printed out when the application receives a message.  Underneath this you should see a section that prints out the details of orders for that user.  Note that some text editors, like NotePad, may not display the line breaks so you may see this information all on the same line as shown below or on several lines depending on the text editor.
	__9.  Close the log file.
	__10.  Close the web browser you were using to test the application.
	__11.  Logout of the Admin Console and close the web browser.

	Part 6 -  Summary




