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Common Lab Preparation Steps
This is not lab 1!
This section defines common steps that are often taken to setup for a lab or after a lab is
complete. Individual labs will refer to these directions and instruct you to perform
various tasks following the steps in this section.

File Locations
Many labs will refer to files in a common location that have been provided as part of the
setup for the class. To be more generic, the lab directions will often contain the following
placeholders that would normally refer to the locations listed here. If your files have
been placed in a different location make the corresponding adjustment to the location of
these files.
<SOFTWARE> - C:\Software

LY

<LABFILES> - C:\LabFiles

N

Lab Setup

O
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Many labs will provide a "starter" project(s) to allow you to focus on the topic of interest
in the lab. This also allows you to start a lab without needing to complete previous labs.
This section describes the steps taken in other labs to import a "starter" project(s).
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1. Open up Eclipse if it is not already.

2. Select File → Import from the Eclipse menus.
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3. Expand the General group and select Existing Projects into Workspace and
press the Next button.

4. Select the radio button next to the Select archive file option and use the matching
Browse button to find the file that contains the project. The exact file to locate
will be provided in each lab.
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5. Select the projects listed in the file if they are not already as shown below.

6. Press the Finish button to import the project.
7. Right click the imported project(s) and select Spring Tools → Add Spring
Project Nature. This option may not be shown if the Spring project nature is
already added.

LY

Note: For some reason the Spring project nature is sometimes not part of the project
after importing. If a lab uses multiple projects not all of them may be Spring projects so
look for additional directions in the lab if present.

N

Start Derby database
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1. In a Windows Explorer window, navigate to the
'<SOFTWARE>\db-derby-10.7.1.1-bin\bin' folder.
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2. Run the 'startNetworkServer.bat' command by double clicking it. Make sure to
run the correct command as there are several similarly named batch files.
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3. Wait for the Derby server to report that it is waiting for connections.

4. Do not close the command prompt window.

Stop Derby database
1. In a Windows Explorer window, navigate to the
'<SOFTWARE>\db-derby-10.7.1.1-bin\bin' folder.
2. Run the 'stopNetworkServer.bat' command by double clicking it. Make sure to
run the correct command as there are several similarly named batch files.
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Initialize Derby Database
Some labs will import test data into the database to make it easier to test. This will also
create the database structure so that the application does not have to attempt to do this.
1. If your <LABFILES> directory is not 'C:\LabFiles' browse to the lab file
directory for the lab, open the 'db.txt' file with a tool like Wordpad or Notepad,
and edit the file location of any files referenced in the database script. For
example, the screenshot below references a file for data that will be imported but
this will not work if the <LABFILES> directory is not 'C:\LabFiles'.

2. Save and close the 'db.txt' file if you modified it.
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3. Make sure your Derby database is running as described in the 'Start Derby
database' section of these common steps.
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4. Open a command prompt. You can do this by selecting Start → Run and
entering 'cmd'.
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5. Use the 'cd' command to switch to the
'<SOFTWARE>\db-derby-10.7.1.1-bin\bin' directory.

EV

6. Issue the following command making sure to substitute the correct value for your
<LABFILES> location and the location of the lab folder for your current lab.
For example, the screenshot below shows the command for the 'C:\LabFiles'
location and the 'JPA-QL' lab.
ij <LABFILES>\<LAB FOLDER>\db.txt
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7. After a number of seconds several database commands should execute. At the
end make sure you see the contents of some of the test data that was imported.
Also scroll back and check that you don't see any errors in the commands that ran.
If you don't see sample data or think you might have errors notify your instructor.
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Note: It is important that you only run the command to initialize the database once. If
you have errors the best way to start over is to:

O
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1. Stop the Derby database
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3. Restart the Derby database
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2. Go to the '<SOFTWARE>\db-derby-10.7.1.1-bin\bin' directory and delete the
subdirectory which has the same name as the lab
4. Run the command to import the data again after determining what caused an error.
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8. Close the command prompt you used to initialize the database.
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Configure WebSphere DataSource
Many labs will use a database connection from an application deployed to WebSphere.
This section details how to configure a DataSource within the WebSphere Admin
Console to support the lab.
Note that the DataSource of each lab will have slightly different settings so make sure to
reference the details of each individual lab and adjust these instructions accordingly.
1. Switch to the Servers view. If it is not shown from the menu, select Window >
Show View > Servers.
2. Make sure you have not yet added the project to the server as it would have errors
being deployed without the DataSource configured first.
3. Right click the WebSphere server and select Start. Wait until it starts completely.
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4. Right click the server and select Administration → Run Administrative
Console.
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5. In the Admin Console navigate to Security -> Global Security.
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6. On the right side, under the Authentication section, expand Java Authentication
and Authorization Service and click the link for J2C Authentication data.

Copyright 2013 Web Age Solutions Inc.

7

7. Check if you already have a 'wasadmin' user in the list. If you do not have this
user continue with the next steps. If you do already have this user skip to step
#12.
8. Press the New button on the empty list of entries.
9. In the fields for the new Authentication Data Entry fill in the following properties.
Note that you only supply the password once and there is no “Confirm password”
box that will check you enter the same value so be careful typing the password.
Press the OK button when the properties are filled in as below.
wasadmin

User ID:

wasadmin

Password:

wasadmin
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Alias:

EV

10. Verify that the new entry shows up in the list. Notice that the alias is prefixed
with the name of the Node where the Application Server resides.

11. Click the Save link in the messages at the top of the Admin Console.
12. On the left, expand Resources → JDBC and click the JDBC providers link.
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13. Check to see if you have a "Derby Network Server using Derby Client (XA)"
Derby JDBC provider. If you do not have this type, continue with the next step.
If you do have this type you can skip to step #20. The list below shows the
default entries before adding the one you need.
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14. If you do not have an entry for a Derby "Network" provider select the entry in the
"scopes" drop-down that has your Node and Server name. This will change the
contents of the list below.
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15. With the 'Server' scope selected click the New button above the list.
16. From the drop downs shown select the following:
Provider type:

Derby

EV

Database type:

Implementation type:

Derby Network Server Using Derby Client
XA data source
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17. Click Next.
18. On Step 3: summary page, click Finish.
19. Click the Save link at the top of the page.
20. From the list of JDBC providers, click the link for the "Derby Network Server
Using Derby Client (XA)" provider as shown below.

LY

21. Click the 'Data sources' link on the right side of the JDBC provider property
page.

N

22. Above the list of Data sources, click the New button.
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23. Fill in the following information, using the values provided as part of the lab.
These are likely different than the screenshot shown below which is just to show
you what to fill in.
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Data source name - <Data source name from lab>
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JNDI name - <JNDI name from lab>

24. Once your Data source properties are filled in to match the lab settings click the
Next button.
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25. Fill in the 'Database name' property with the value given in the lab. Make sure to
match the entry exactly, especially if ';create=true' is on the end of the name.

LY

26. Once the 'Database name' property is filled in with the value indicated in the lab
click the Next button.

O
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27. Select the wasadmin user from the drop-down for the following entries from the
page:

O

Component-managed authentication alias

N

Authentication alias for XA recovery
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Container-managed authentication alias

28. Once the security properties are filled in click the Next button.
29. From the Summary page click the Finish button to create the Data source.
30. At the top of the page, click the Save link.
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31. Make sure your Derby database is running as described in the 'Start Derby
database' section of these common steps.
32. Check the box for the Data source you just added and click the Test connection
button. Remember the name of the Data source will be different for different
labs.

O

N

O

N

LY

33. You should get a successful message.
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Lab Cleanup
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34. Logout and close the admin console.
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After a lab is complete you may be instructed to remove projects from a server or close
a project to remove it from the build process. This section describes the steps you would
use to do that.
1. From the menus select Run → Run Configurations.
2. Delete any of the Run configurations used in the lab by selecting them, pressing
the Delete button as shown below, and confirming that you want to delete the
configuration.
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3. Close the Run Configurations window.
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4. Switch to the Servers view. If it is not shown from the menu, select Window >
Show View > Servers.
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5. Right click on the 'WebSphere Application Server v8.0' server and select Add and
Remove...
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6. Remove all applications that might be on the server by clicking the Remove All
button. Make sure there are no projects listed on the right side as being deployed
to the server.

7. Click the Finish button to remove all applications from the server.
8. Right click the server and select Clean and then click OK.
9. Right click the server and select Stop if it is running.
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10. Select the Console view.
11. Click the Remove All Terminated Launches.

12. No consoles will be displayed.

O

14. Switch to the Java EE perspective.
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13. Right click each project used in the lab and select Close Project. This will
remove the project from the build process and improve Eclipse performance.
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15. If you want to hide closed projects from the various views, click the down arrow
in the view toolbar which will bring up the 'View Menu'.

16. From the 'View Menu' select the Customize View... option.
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17. Enable (check) the Closed projects filter and click the OK button.

18. You should no longer see any closed projects in the view.

19. Switch to the Spring perspective.
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20. Click the down arrow in the view toolbar which will bring up the 'View Menu'.
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21. From the 'View Menu' select the Filters option.

22. Enable (check) the Closed projects filter and click the OK button.

23. You should no longer see any closed projects in the view.
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Lab 1 - Setup Eclipse for Spring 3 with WebSphere 8
Note: You will need to perform this lab before any other labs for the course. This lab
configures Eclipse with Maven which will be used to include Spring JARs in projects.
In this lab you will perform steps to prepare for Spring development in Eclipse. Even
though your own projects may be very different from the projects in future labs you
would most likely take steps similar to this lab to prepare them for Spring.
At the end of this lab you will be able to:
1. Define a WebSphere 8 server in Eclipse
2. Create a Web Project
3. Setup Maven dependencies on Spring JARs for the project
4. Create a Spring configuration file

LY

Part 1 - Configure WebSphere Profile
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Some labs will use a WebSphere server. The WebSphere Application Server 8.0 for
Developers software should have already been installed as part of the lab setup. These
steps will create a WebSphere environment called a "profile".
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Although we will only create one profile this is a good process to know how to do. If you
work with multiple WebSphere applications from different Eclipse workspaces it is a
good idea to create a different profile for each workspace so the applications in each
workspace can have a unique WebSphere configuration and avoid any issues with
deploying or testing those applications.

EV

__1. From the Windows Start menu select 'Start → Programs → IBM WebSphere →
WebSphere Application Server V8.0 → Tools → Profile Management Tool'.
__2. Press the Create button next to the list of profiles.
__3. In the Environment Selection dialog, select the option for Application Server and
press the Next button.
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__4. Select the option for Advanced profile creation and press the Next button.
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__5. Leave the default option to deploy the administrative console and default application
and press the Next button.
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__6. Leave the default profile name and note the value for later in Eclipse. Leave the
default profile directory which should be a directory NOT in the 'Program Files' directory.
If the profile directory does include the 'Program Files' directory remove it as shown
below. Also change the option for 'Server runtime performance tuning setting' to
Development as shown below.

Note: If your default profile directory does not match that shown above let your
instructor know as this will alter other steps in this lab.
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Windows Vista/7/2008: If you are using Vista/2008 it is important to avoid the
'Program Files' directory because you would not be able to alter the profile configuration
files in this directory since they are protected by Windows security. Creating the profile
in a separate directory ensures we can configure the profile and save the configuration
files.
__7. Once all of your profile settings match that shown above click the Next button.
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__8. Leave the default Node, Host and Cell names. Press the Next button.
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__9. Uncheck the box for Enable administrative security and press the Next button.

__10. In the first page of security certificate options, leave the default to create a new
default personal certificate. Press the Next button.
__11. On the second page of security certificate options again leave the defaults and press
the Next button.
Note: Normally you might use these options to customize how the default certificate is
generated.
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__12. In the Port values assignment page, click the Default Port Values button to use
default ports for the profile and click Next.
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Note: Normally the profile creation tool will attempt to locate other profiles and ensure
this profile has unique ports. Although this is helpful in administration of environments,
profiles used for development are almost always run one at a time so using the default
ports helps ensure the way to access applications in consistent for multiple profiles.
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__13. If prompted to run the application server as a Windows process uncheck the option
as shown below and click the Next button.

__14. Leave the option to create a web server unchecked and click the Next button.
__15. Press Create in the Summary page to begin profile creation.
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__16. When the profile creation is complete, uncheck the option for launching the First
Steps console and press the Finish button.

__17. Select File → Exit for the Profile Management Tool.
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Part 2 - Launch Eclipse
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Since we will be using WebSphere tools with Eclipse it is important that Eclipse is
launched with the IBM JVM. If it is not you will not be able to create a WebSphere
server definition in your Eclipse workspace. You will alter the Eclipse startup to do this
in this section.
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__1. If you had already launched Eclipse, close it. Eclipse must be shut down to pick up
changes in the startup options.
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__2. Open a Windows Explorer window and navigate to <SOFTWARE>\eclipse
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__3. Find the ‘eclipse.ini’ file and right click on the file and select Properties. The
extension may be hidden and just list the file type as ‘Configuration Settings’.
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__4. Check that the file is not read only and uncheck the box if it is. Close the file
properties after making sure the file isn't read only.

Note: If the file is read only let your instructor know as errors will occur if other Eclipse
files are read only.
__5. Open the eclipse.ini file with a text editor.
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__6. Once you have the file open, add the following two new lines to the start of the file,
making sure not to put extra spaces at the end of the lines:

EV

AL
U

AT
I

O

N

O

N

-vm
C:\IBM\WebSphere\AppServer\java\jre\bin\javaw.exe

Note: You should double check that your WebSphere software was installed to the
location above as part of the setup for the class.
__7. Save the file when it is like above. Make sure when you save it the file extension is
not changed.
__8. Close the eclipse.ini file.
__9. Launch Eclipse by double clicking on <SOFTWARE>\eclipse\eclipse.exe. You
may want to add a shortcut to this to the desktop.
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__10. Change the workspace location to C:\workspace if it is not already and click OK.
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Note: Always keep the workspace path name short. Otherwise, you may run into the
Window's 255 character file name restriction problem.
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Also note that if you are running Eclipse in an environment with security restrictions for
creating folders on the 'C' drive you may have to create the workspace in the user
'Documents' folder or in another folder you have permissions for.
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__11. Click the Reject button on the 'User Agent Analysis' dialog if it appears.
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__12. Close the Welcome or Dashboard pages if they appear.
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Part 3 - Configure WebSphere Server in Eclipse

EV

The final step of integrating WebSphere with Eclipse is to link a server definition in your
Eclipse workspace to the profile created in a previous section.
__1. Select Window → Preferences from the menus.
__2. Select Server → Runtime Environments in the preferences.
__3. Click the Add button.
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__4. From the list expand IBM and select WebSphere Application Server v8.0. Also
check the box to 'Create a new local server' as this will perform all needed tasks during
this wizard.

__5. Click Next.
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__6. Click the Browse button next to Installation Directory and navigate to
C:\IBM\WebSphere\AppServer and then click OK.
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__7. Once your settings match those shown below click the Next button.
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__8. Make sure the appropriate profile is selected, which should be 'AppSrv01', leave the
other settings as the default and click the Finish button.
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Note: If you wanted to have multiple WebSphere profiles for different applications, this
is the step where you could select the appropriate profile you wanted to use for the
applications in your current Eclipse workspace.
__9. Back in the Eclipse preferences, click the OK button to close the preferences.
__10. If it was not automatically selected, select the Servers view along the bottom and
check that the new WebSphere server is shown.

__11. Right click on the Server and select Open.
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The configuration page of the Server will open.

__12. Expand Publishing on the right.
__13. Select Never publish automatically.
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__14. Expand Timeouts.
__15. Change the Start (in seconds) to 600
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__16. Expand the 'Publishing settings for WebSphere Application Server' and select
the 'Run server with resources on Server' option.
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Note: This setting appears to be important because without it the JARs included for the
project would be included only by Maven from the workspace and sometimes
WebSphere may have classloading problems this way. Running with resources on the
server will make sure the entire application (including dependent JARs) will be
packaged and deployed as an application on the server more as if the normal
administration console were used.

EV

__17. Save the changes and close the window.
__18. In the Servers view, right click the 'WebSphere Application Server v8.0' and
select Start. The server will print several messages when starting.
__19. Switch back to the Servers view and check that the server starts successfully.

__20. Right click the server and select Stop.
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Part 4 - Configure Maven Mirror
Although not the only way, one way to manage the various JAR files that might be
required for a Spring project is by using Maven. The default setting in Maven is to
download files from a central repository from the internet.
For the environment of these labs it is preferred not to require an internet connection or
proxy settings so we want to point to a local repository that is delivered with the software
for the class. The problem is that Maven creates a local repository cache and when you
convert an Eclipse project to use Maven if it does not yet know about this local repository
it could get errors contacting the internet repository and stop attempting to download
some important files for Maven functionality.
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The way we will address this is to configure the local repository as a “mirror”. This will
redirect all Maven queries, even when first setting up a project to this local repository.
This is done with a settings file. Although this is one way to configure Maven it may not
be the way you use Maven in other projects. In other projects you may want to contact
an internet repository and it would be more appropriate to configure proxy settings
instead of a mirror. Another approach is to have everyone on a team point to a team
repository on the intranet that is managed by an individual or group that adds files to the
team repository based on some standards on what libraries and versions will be available.
We will not explore these possibilities but the “settings” file you work with is one of the
main ways this would be accomplished.

O

__1. From the Eclipse menus select Window → Preferences.
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__2. Select Maven → Installations from the left. Notice that Eclipse is aware of an
external installation of Maven which was delivered as part of the software for the class.

Note: Notify your instructor if you don't see the Maven installation shown above but it
should be easy to add.
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__3. Note the location of the 'settings.xml' file for the external Maven installation that is
installed. We will use this file as a template in a little bit.
Note: Although we could try to modify the global settings file the Maven Eclipse plugin
does not seem to pick this one up as well as a user-specific version. There are some
settings that may be user specific and should be secured (like proxy authentication
settings) so using a user file will be good for this also.
__4. Open a Windows Explorer window. Leave Eclipse and the preferences open.
__5. Navigate to the location of the external Maven settings file you saw in the previous
step.
__6. Copy the 'settings.xml' file which should be the only file in the folder.
__7. Navigate to the '<LABFILES>\Setup' folder.
__8. Paste the file into this folder. There is also a solution file in the 'Solution' folder you
can use if you want.
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__9. Edit the file with a text editor like WordPad or NotePad. If you just try to double
click it will likely open in a browser which won't let you edit.
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__10. In the file find the section for 'mirrors'. This should have a sample mirror
definition commented out so there are actually no mirrors defined.
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__11. Add the following mirror definition being careful it is outside the comment but
inside the <mirrors> tag.
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<mirrors>
<!-- mirror
... Comment left out
</mirror>
-->
<mirror>
<id>localMirror</id>
<mirrorOf>*</mirrorOf>
<name>Local Override Repository</name>
<url>file://C:\Software\MavenRepository</url>
</mirror>
</mirrors>

Note: This setting assumes that the software for the class was extracted to the
C:\Software folder. If the software was extracted somewhere else or into a subfolder
check the location and adjust this setting appropriately.
The key part of this mirror configuration is the <mirrorOf>*</mirrorOf> property. This
redirects all Maven requests to the local mirror repository. You could list individual
repositories here also (like the Maven 'central' repository).
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__12. Save the file and close the editor for the settings.xml file.
Note: You can also configure the location of the local user repository which is used to
cache repository entries if you want with the <localRepository> tag. We will leave the
default.
__13. Back in Eclipse, select Maven → User Settings from the left of the preferences.
Open the preferences again if you closed them.
__14. Next to the user settings file press the Browse button.
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__15. Navigate and select the 'settings.xml' file that you edited in the
'<LABFILES>\Setup' folder. Check that your location is updated as shown below.
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Note: The default location for the file is in a '.m2' folder. Since this folder starts with a
period we can't create it manually. The problem is the folder would be created when we
went to create our first maven project but this will be too late to point to the local
repository.
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__16. Press the Update Settings button to be sure the settings are loaded.
__17. Click the OK button to close the preferences dialog.
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__18. Select Window → Show View → Other from the Eclipse menus.
__19. Select the Maven → Maven Repositories view and click the OK button.
__20. In the view that appears at the bottom expand the 'Global Repositories' entry and
be sure you see the 'local' repository listed. Notice it also is overriding the normal
'central' repository of Maven from the internet.
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Part 5 - Create a Web Project
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__21. Right click the 'localMirror' global repository and select 'Rebuild Index'.
Confirm that you want to rebuild. This will make sure all library information is
available.

In this section you will create a Web Project.
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__1. From the menu select File -> New -> Dynamic Web Project.
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__2. Enter OEProject as Project name.
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__3. Check that the 'Target runtime' is WebSphere 8.0 which should be the default. Also
check the 'Add project to an EAR' option.
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__4. Click Finish when your options match those shown above.
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__5. If prompted to switch to the Web perspective click the No button.
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__6. The project will appear under the Project Explorer view, expand it.
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Part 6 - Add Spring JARs with Maven
Most of the tools we will use from Eclipse are directly related to Spring or web
applications. The one area that is a little more general is how we will use Maven to
obtain the Spring JARs for the project. As more and more open source projects have
become popular they often introduce dependencies from one project to another. Maven
can help manage these dependencies by getting automated information about them and
use the Maven Eclipse plugin 'm2eclipse'. Although Maven could also do more to
manage builds and other aspects we will mainly use it to provide library JAR files as
shown in this section.
__1. Right click the OEProject and select Configure → Convert to Maven Project.
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__2. Change the Packaging drop-down to 'war'.

Note: Even though we will not use Maven to build the project we choose 'war' here as
the type that would make sense if we were.
You could also define attributes of the project as a Maven library. Since we will be
focusing more on the features of Spring these won't really be important to us but they
would be if you were using the Maven build process for your project.
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__3. Once your settings match that shown above click the Finish button. The Maven
POM file should open in an editor.
Unfortunately the Maven plugin also modifies some project properties that cause errors in
the Eclipse build to appear. We will fix those now.
__4. Right click the OEProject and select Properties.
__5. On the left side select Project Facets.

LY

__6. Change the Java facet to 1.6 if it is not already.

__7. On the left select Java Compiler.
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__8. On the right uncheck the box to allow project specific settings.

__9. Press the Apply button in the lower right (not the OK button) and confirm that you
want to build.
__10. On the left select Java Build Path and select the Libraries tab on the right.
__11. Select the 'JRE System Library [J2SE-1.5]' from the list and click the Remove
button on the far right.
__12. On the far right, click the Add Library button.
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__13. Select 'JRE System Library' and click the Next button.
__14. Leave the default option of 'Workspace default JRE' selected and click the Finish
button.
__15. Make sure that the correct JRE library shows up in the list.

__16. Click the Source tab in the Java Build Path properties.
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__17. If the list of source folders is empty, click the Add Folder... button.
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__18. Check the 'src' folder of the OEProject and click the OK button.

EV

__19. Check that the new source folder appears.
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__20. Change the 'Default output folder' at the bottom of the Source tab to
'OEProject/WebContent/WEB-INF/classes'.

__21. Click the OK button to close the project properties.
Note: You must close the project properties for them to take effect for the next settings.
__22. Right click the OEProject and select Properties.
__23. On the left of the project properties dialog select 'Deployment Assembly'.
__24. Select the '/src/main/webapp' entry if it appears and press the Remove button.
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__25. Press the Add button to the right of the list.
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__26. Select 'Java Build Path Entries' and click the Next button.

__27. Select 'Maven Dependencies' and click the Finish button.
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__28. Check that your final list appears as below. Notice this will add the Maven
dependencies we added to the 'lib' folder of the web project.
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Note: The 'Deployment Assembly' project properties are meant to replace the 'Module
Dependencies' properties from previous Eclipse versions and turn it into a more generic
mechanism for controlling how the project is built for deployment.
The property you added will allow Maven dependencies to be packaged with the
application for deployment but allow them to NOT be physically contained in the
project to reduce the project size. When combined with the features of Maven this is a
perfect combination as Maven can manage a central repository of all the JARs that
might be included in applications and developers can have their own repositories in
addition to central repositories for teams.
__29. Click the OK button to close the project properties.
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__30. Check in the Markers view that there are no errors reported. There may be other
messages listed in the view but make sure they are not errors.
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Note: We need to fix some of the project properties because right now Maven expects
that it would be doing everything for your project. Future integrations of Maven and
Eclipse may be easier to use features of both without some of these steps.

AL
U

__31. Back in Eclipse make sure you still have the Maven pom.xml file for the project
open. Open it again if not.
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__32. In the editor switch to the 'Dependencies' tab at the bottom of the editor.
__33. Next to the empty list of Dependencies in the upper left, click the Add button.
__34. Enter 'context' in the search pattern box.
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__35. Expand the Spring library org.springframework.context and select the 3.0.5
release version.

Note: This ability to search for a dependency is present because you have a local mirror
repository. If you had to download libraries remotely you might not have this easy
search mechanism and might need to add the dependency manually.
__36. Once your settings match above click the OK button.
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__37. Click the Add button again next to the dependencies.
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__38. Enter 'web' in the search pattern box.
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__39. Expand the org.springframework.web library and select the 3.0.5 release version.

__40. Once your settings match above click the OK button.
__41. Click the Add button again next to the dependencies.
__42. Enter 'logging' in the search pattern box.
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__43. Expand the Apache library that comes up and select the 1.1.1 release version.

__44. Once your settings match above click the OK button.
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__45. Check that all three dependencies appear on the list.
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Note: The 'context' bundle from Spring provides the support for the core Dependency
Injection container which is the most popular feature of Spring so it is almost always
declared.
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The Spring 'web' bundle has some utility classes we would use to link our Spring
configuration into a Servlet web application.
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The Apache Commons Logging project is a popular logging framework. This is one of
the only external dependencies of the core of the Spring framework. On some servers it
might be required to include this JAR so we are including it here to make sure the
application can compile.
__46. Save but don't close the file.
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__47. Select the Dependency Hierarchy tab along the bottom of the editor. You should
see various JARs that will be linked to the project because the dependencies you added
require them. You can even select them on the right and see the dependency chain.
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__48. Close the pom.xml file.
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__49. In the Project Explorer view, expand OEProject → Java Resources →
Libraries → Maven Dependencies. You should see the various JAR files added to the
build path of the project. Make sure the 'context' and 'web' JARs are in the list to make
sure they will both be packaged with your project.
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Note: You may notice that the 'aopalliance' and 'commons.logging' JARs appear to be
related to SpringSource even though it is not a Spring project. This is because this
version of the JAR is obtained through the SpringSource Enterprise Bundle Repository
instead of the “central” Maven repository. You can find out more info about this at:
https://ebr.springsource.com/repository/app/
http://blog.springsource.com/2009/12/02/obtaining-spring-3-artifacts-with-maven/

Part 7 - Create Spring Configuration File
Spring configuration is often read in from an XML Spring configuration file. Even if
much of Spring dependency injection is done through annotations you will need at least a
little configuration in an XML file to bootstrap it. In this section you will create a Spring
configuration file based on the Spring XML schemas that Eclipse is aware of.
__1. Select Window → Open Perspective → Other.
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__2. Select Spring and click the OK button.
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__3. Right click the OEProject and select Spring Tools → Add Spring Project Nature.

Note: The Spring project nature is a way to add Spring tool features to a project. It does
not do everything for the setup of a Spring project so there are some additional steps to
be done.
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__4. From the menu, select File -> New -> Spring Bean Configuration File.
Note: This option is available only if you are still in the 'Spring' perspective and not in
the 'Java EE' perspective.
__5. Expand OEProject -> WebContent and select the WEB-INF folder as the parent
folder.
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__7. Click Next.
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__6. Enter spring-beans.xml as File name.

__8. Check the 'beans' namespace checkbox and press the Finish button.
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Note: Notice you could have also selected a specific Spring XML schema version. If
you do not the Spring tools will detect what schema version to use based on the version
of the Spring JAR on the project classpath.
__9. Close all open files. (Ctrl+Shift+W)

Part 8 - Lab Cleanup
__1. Close the OEProject and OEProjectEAR projects as described in the 'Lab
Cleanup' part of the 'Common Lab Preparation Steps'.

Part 9 - Review
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In this lab you did several things that would be done to setup a project for using Spring.
By configuring Maven to provide the Spring JAR files for the project and using the
“Deployment Assembly” features of Eclipse to indicate that the Spring JARs should be
included in the built project you can keep the actual size of the project small, introduce a
new Spring version in the future relatively easily, and help automatically determine what
other JAR files might be required when building Spring applications.
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Lab 2 - Defining and Using Spring Beans
The core of any Spring application revolves around defining and using Spring "Beans".
These are Java components configured and managed by the Spring container. This lab
will show you how to obtain Spring beans from the container as well as various options
for defining and configuring them.

Part 1 - Lab Setup

N

LY

__1. Import the projects in the '<LABFILES>\Spring-Beans\Spring-Beans-Starter.zip'
file as described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.

O

__2. Open the Spring perspective.
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__3. In the Markers view check that you have only warnings and no errors. If there are
errors try a Project → Clean to rebuild the project.

Part 2 - Examine Existing Classes
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A few basic classes have been provided for you.
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__1. Open ProductCodeGenerator.java under Spring-Beans → src →
com.webage.bean package.
Notice that this is just a regular Java interface for a Java component that will generate a
"Product code" and return it as a String. It is typical for Spring components to implement
Java interfaces to provide flexibility in the code.
__2. Open BasicProductCodeGenerator.java under Spring-Beans → src →
com.webage.bean package.
Notice that this class has a few properties, the get/set methods for those properties, a few
constructors, and the implementation of the 'getNextProductCode' method from the
interface. In the implementation of this method the properties are used to generate the
code. Although the properties have default values you will see later how setting them to
different values will generate different product codes. This is one way we will judge the
impact of the Spring configuration.
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__3. Open ProductCodeGeneratorTest.java under Spring-Beans → src →
com.webage.test package.
Notice that this code creates a ProductCodeGenerator implementation and then uses it to
print out a few product codes. The problem with this code right now is that even though
the local variable uses the interface type to define the variable the constructor of the
implementing class is called. This does not provide flexibility to use a different
implementation very easily in the future. One way to address this problem is to apply the
"Factory" design pattern which is what Spring will do for us.
ProductCodeGenerator generator =
new BasicProductCodeGenerator("WA", "10");
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__4. With the ProductCodeGeneratorTest class still open in the editor select Run →
Run As → AspectJ/Java Application from the Eclipse menus.
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Note: If you get an error when trying to run the code it is likely because you selected
Run As → Java Application which does not seem to work. This option does not seem
to add the project code to the classpath and therefore can't run the application.

EV

If this happens it is best to select Run → RunConfigurations so you can delete the
incorrect run configuration so it won't cause problems in the future.
__5. Make sure that you get the following in the Console view when the class generates
some basic product codes. You should be able to figure out how the properties of the
'BasicProductCodeGenerator' were used to generate these codes.
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Part 3 - Retrieve Component from Spring
The first step in using Spring is to modify the code to retrieve the component from the
Spring container. This will be done with the Spring ApplicationContext interface. You
will also supply an XML configuration file to configure this Spring environment.
__1. Make sure you have the code of the ProductCodeGeneratorTest class open in the
editor and open it if it is not.
__2. At the start of the 'main' method add the following as the first lines of code. You
will have errors until the next step. This code will define the Spring container or
"context" that will be used and indicate that the configuration will be in an XML file.
public static void main(String[] args) {
ApplicationContext context = new
ClassPathXmlApplicationContext("spring-beans.xml");
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ProductCodeGenerator generator =
new BasicProductCodeGenerator("WA", "10");

N

__3. Organize imports by selecting Source → Organize Imports.
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__4. Modify the code that initializes the 'generator' variable with the code in bold below.
Notice that instead of calling the constructor the code will get the component from the
Spring environment.
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ApplicationContext context = new ClassPathXmlApplicationContext(
"spring-beans.xml");

__5. Save changes.

EV

ProductCodeGenerator generator = context.getBean("generator",
ProductCodeGenerator.class);

__6. Make sure you are in the Spring perspective and use the Window → Open
Perspective → Other menu if needed.
__7. Select the Spring-Beans → src folder by clicking it.
__8. Select File → New → Spring Bean Configuration File.
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__9. Enter a file name of spring-beans.xml and make sure the parent folder is
'Spring-Beans/src' before clicking the Finish button.

N
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__10. On the Spring configuration editor that opens select the 'beans' tab along the
bottom.

O

__11. Click the 'New Bean..' button in the 'Beans Overview' area.

O

N

__12. Enter a value of 'generator' for the 'id' property but don't yet finish the dialog. This
will be the name of the bean retrieved from the Spring container.
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__13. Press the Browse button for the class, type a few letters of the
BasicProductCodeGenerator class until it is selected and then click the OK button.
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__14. Check that your dialog is filled in as shown below and click the Finish button.

Note: If you went to the next page there are ways to add constructor arguments but this
part of the dialog appears to throw Eclipse Exceptions. We can add this manually.
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__15. In the 'Beans Overview' section, right click the 'generator' bean and select Insert
<constructor-arg> element.
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__16. With the new constructor-arg element still selected fill in a 'value' of 'WA' without
the quotes as shown below.
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__17. Right click the 'generator' bean again and select Insert <constructor-arg>
element.
__18. For the second constructor-arg element fill in a value of '10' without the quotes.
__19. Check that your bean definition appears as shown below in the 'Beans Overview'
section. Notice that the id of the bean and the value of the constructor arguments is
shown to make it easier to read.

__20. Save the file.
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__21. From the menus select Run → Run History → ProductCodeGeneratorTest.
There may be other things listed but this should be the only entry with that name.
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__22. Check that in the Console view, after a few Spring messages, you see the same
product codes printed. You get the same product codes because even though you are
getting the generator from the Spring container it was configured just as it was before.

AL
U

Note: Sometimes when you run the code you may see the Spring messages after the
messages from the application code. This is OK and is likely due to buffered output.

Part 4 - Resolve Constructor Arguments

EV

Right now the application works because there is only one constructor that has two
arguments. If another constructor is added with two constructors something must
indicate which one to call.
__1. Open BasicProductCodeGenerator.java under Spring-Beans → src →
com.webage.bean package.
__2. Add the following new constructor making sure to add the code within the class
definition curly brackets but outside of other methods or constructors.
public BasicProductCodeGenerator(String prefix, int current) {
super();
this.prefix = prefix;
this.current = current;
}

__3. Save the file.
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__4. From the menus select Run → Run History → ProductCodeGeneratorTest.
__5. Notice that in the Console view, the same output is generated. This is because the
code is still calling the constructor with two Strings since that is the type that Spring will
assume for constructor-arg values.

__6. Return to the editor for the 'spring-beans.xml' file.
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__7. Select the second constructor-arg element with the value of '10'.

__9. Save the file.

EV

AL
U

AT
I

O

N

O

N

__8. In the 'type' attribute enter a value of 'int' without the quotes. You may need to
maximize the editor or move the divider between the two sides to see the value well.

__10. From the menus select Run → Run History → ProductCodeGeneratorTest.
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__11. Notice now that the output is different. This is because the Spring bean is now
defined to use the constructor that sets the initial 'current' value and not the suffix. This is
because the constructor-arg was configured to be an 'int'.

Part 5 - Configure Beans with Properties
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Besides configuring Spring to call constructors you can also have Spring call the
"default" no-argument constructor and then set properties. This can provide more
flexibility since you do not need a constructor to match every way a bean can be
configured.

N

__1. Return to the editor for the 'spring-beans.xml' file.

O

__2. Click the 'Source' tab at the bottom of the editor.
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__3. Modify the definition of the bean to remove the <constructor-arg> elements and
replace them with <property> elements as shown in bold below.
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<bean id="generator"
class="com.webage.bean.BasicProductCodeGenerator">
<property name="prefix" value="WA"></property>
<property name="current" value="15"></property>
<property name="suffix" value="XL"></property>
<property name="increment" value="5"></property>
</bean>

__4. Save the file.
__5. In the editor select the 'beans' tab along the bottom.
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__6. Notice that the visual overview of the bean has changed since the properties are
added instead of constructor arguments. Select some of the properties if you want to see
how they are defined in the editor. In the future only source code may be given to
simplify lab instructions although the editor is often easier to use to ensure correct syntax.
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__7. From the menus select Run → Run History → ProductCodeGeneratorTest.
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__8. Notice now that the output is different. This is because the Spring bean is
configured with different values for the properties. This causes the generated product
codes to be different which proves Spring is setting the properties of the Spring bean.

Part 6 - Configure Properties with 'p' Schema
Besides using child <property> elements it is also possible to set property values using
attributes on the main <bean> element with the 'p' schema. This reduces the amount of
text required to set a property.
__1. Return to the editor for the 'spring-beans.xml' file.
__2. Click the 'Namespaces' tab at the bottom of the editor.
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__3. Check the 'p' namespace as shown below and click the OK button on the dialog that
appears when you do.

LY

__4. Click the 'Source' tab at the bottom of the editor.
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__5. Modify the bean definition so that instead of having nested <property> element tags
there are 'p:..' attributes with the name of the property and the value. Make sure that you
put these new 'p:..' attributes within the brackets for the start <bean ..> tag. Notice the
property values are a little different and not all are present so it will be easy to tell the
settings are taking effect. Also make sure to remove the nested <property> tags.

__6. Save the file.

AL
U

AT
I

<bean id="generator" class="com.webage.bean.BasicProductCodeGenerator"
p:prefix="WS" p:current="200" p:increment="10">
</bean>

EV

__7. In the editor select the 'beans' tab along the bottom.
__8. Notice that the visual overview of the bean has changed and you do not see the
properties that are set by the 'p:..' attributes. Even though the visual editor doesn't give
support for the 'p:..' attributes the source code editor does have code completion that you
can access by typing CTRL-SPACE after typing 'p:' to enter the attribute name.
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__9. From the menus select Run → Run History → ProductCodeGeneratorTest.
__10. Notice now that the output is different. This is because the Spring bean is
configured with different values for the properties even though they are configured with
the 'p:..' attribute syntax. If the property values had been the same the output would be
the same as there is no difference in supplying basic property values with either method.

N

Part 7 - Observe Effect of Bean Scope

O

N

LY

Note: Even though there is no difference in basic properties the 'p:..' attribute syntax
does not have as many options for multi-valued properties or other things the nested
<property> elements can do.
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One important aspect of Spring beans to keep in mind is what "scope" the bean is defined
at. If you do not set a scope the default scope of "singleton" is used. This may impact
the behavior of the application so it is important to know how the scope of the bean can
impact the behavior so your application can be made to behave the way you want.
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__1. Open ProductCodeGeneratorTest.java under Spring-Beans → src →
com.webage.test package if it is not already open in an editor.
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__2. Add the following code in bold to the end of the 'main' method. Notice that this
initializes a second variable that refers to a 'generator' but that the name of the Spring
bean retrieved is the same as the other variable that was initialized.
System.out.println("Generator: " +
generator.getNextProductCode());
ProductCodeGenerator generator2 =
context.getBean("generator",
ProductCodeGenerator.class);
System.out.println("Generator2: " +
generator2.getNextProductCode());
System.out.println("Generator2: " +
generator2.getNextProductCode());
System.out.println("Generator2: " +
generator2.getNextProductCode());

LY

}

N

__3. Save the file and make sure there are no errors.
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__4. From the menus select Run → Run History → ProductCodeGeneratorTest.
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__5. Notice in the output that the product codes keep incrementing without starting over
for the second 'generator'. This is because the scope of the 'generator' bean is "singleton"
and both variables in the 'main' method refer to the same generator object.
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__6. Return to the editor for the 'spring-beans.xml' file. Open it again if you had closed
the file.
__7. Click the 'beans' tab at the bottom of the editor.
__8. Select the 'generator' bean from the left and scroll on the right until you see the
'scope' setting.
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__9. Use the drop-down for the scope setting to select a scope of 'prototype' as shown
below.
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__10. Save the file once the 'scope' setting is changed.
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__11. From the menus select Run → Run History → ProductCodeGeneratorTest.
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__12. Notice the output now is different and the second 'generator' bean starts the product
codes over.

Note: This behavior is because the 'prototype' scope for a Spring bean indicates to
Spring that a new bean should be created every time the 'getBean' method is called.
With the default 'singleton' scope, Spring keeps a record of the objects that have been
returned for certain bean names and returns the same object for future requests that use
the same Spring bean name.
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Part 8 - Lab Cleanup
__1. Delete the ProductCodeGeneratorTest run configuration from the AspectJ/Java
Application run configurations as described in the 'Common Lab Preparation Steps' at the
'Lab Cleanup' part.
__2. Close the Spring-Beans project as described in the 'Common Lab Preparation Steps'
at the 'Lab Cleanup' part.

Part 9 - Review
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In this lab you saw many different ways to define Spring beans with XML. You can use
constructor arguments, set properties, and use the 'p' attribute schema depending on the
code in the Java component you have available. You also saw the effect of bean scope to
make sure that an application behaves the way you want if a Spring component is
retrieved more than once.
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Lab 3 - Advanced Spring Bean Definition
Besides defining Spring beans with XML there are other ways to define Spring beans.
You can define Spring beans with annotations in the Java code which can greatly simplify
the XML configuration. You can also establish bean inheritance and externalize Spring
bean configuration properties into property files.

Part 1 - Lab Setup
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__1. Import the projects in the
'<LABFILES>\Spring-BeanAnnotations\Spring-BeanAnnotations-Starter.zip' file as
described in the 'Common Lab Preparation Steps' at the 'Lab Setup' part.

N

__2. Open the Spring perspective.
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__3. In the Markers view check that you have only warnings and no errors. If there are
errors try a Project → Clean to rebuild the project.
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Part 2 - Examine Existing Classes

A few basic files have been provided for you.

EV

__1. Open BasicProductCodeGenerator.java under Spring-BeanAnnotations → src
→ com.webage.bean package.
Notice that this class has a few properties, the get/set methods for those properties, a few
constructors, and the implementation of the 'getNextProductCode' method from the
interface. In the implementation of this method the properties are used to generate the
code.
__2. Open spring-beans.xml under the Spring-BeanAnnotations → src folder.
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Notice this Spring configuration file defines a 'generator' Spring bean and sets some of
the properties. This file uses the 'p' attribute property syntax although the effect would be
the same if nested <property> elements were used.
<bean id="generator"
class="com.webage.bean.BasicProductCodeGenerator"
p:prefix="WS" p:current="200"
p:increment="10" scope="prototype">
</bean>

__3. Open ProductCodeGeneratorTest.java under Spring-BeanAnnotations → src →
com.webage.test package.
Notice that this code creates a Spring ApplicationContext based on the configuration file,
retrieves the 'generator' bean, and then uses the bean to output a few product codes. The
'generator' bean is retrieved twice to observe the effects of the bean scope.
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__4. With the ProductCodeGeneratorTest class still open in the editor select Run →
Run As → AspectJ/Java Application from the Eclipse menus.
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Note: If you get an error when trying to run the code it is likely because you selected
Run As → Java Application which does not seem to work. This option does not seem
to add the project code to the classpath and therefore can't run the application.
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If this happens it is best to select Run → RunConfigurations so you can delete the
incorrect run configuration so it won't cause problems in the future.
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__5. Make sure that you get the following in the Console view when the class generates
some basic product codes. You should be able to figure out how the properties of the
'BasicProductCodeGenerator' were used to generate these codes. Also notice the effect of
the bean scope of "prototype" as the product codes start over for the second 'generator'
bean retrieved. If the bean had been of "singleton" scope the codes from the second
'generator' bean variable would have continued instead of started over.

O

Part 3 - Define Spring Beans with Annotations
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Although defining Spring beans with XML is one option it is also possible to place
certain annotations in the Java code that will also enable the creation of Spring beans.
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__1. Open BasicProductCodeGenerator.java under Spring-BeanAnnotations → src
→ com.webage.bean package.
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__2. Add the following annotation on the class definition. You will have errors until a
following step.
@Component("generator")
public class BasicProductCodeGenerator
implements ProductCodeGenerator {

Note: The default name of a Spring bean when you define it with annotations is the
same as the class name. Since our code currently looks up the bean using the 'generator'
name the value of the @Component annotation is set to match this.
__3. Organize imports by selecting Source → Organize Imports.
__4. Save the file and make sure there are no errors.
__5. Return to the editor for the 'spring-beans.xml' file. Open it again if you closed it.
__6. Click the 'Source' tab at the bottom of the editor.
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__7. Add comments around the current bean definition as shown below. When you enter
the start of the comment Eclipse will automatically add an end tag immediately after so
you will have to delete this to add it back later in the file but before the ending </beans>
tag. Check that the bean definition is in blue so it is marked as a comment.
<!-<bean id="generator"
class="com.webage.bean.BasicProductCodeGenerator"
p:prefix="WS" p:current="200"
p:increment="10" scope="prototype">
</bean>
-->
</beans>

__8. Click the 'Namespaces' tab at the bottom of the editor.
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__9. Check the 'context' namespace as shown below and click the OK button on the
dialog that appears when you do.

__10. Click the 'context' tab at the bottom of the editor.
__11. In the 'Context Overview' section, right click the 'beans' element in the empty list
and select Insert <context:component-scan> element.
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__12. With the new 'component-scan' element selected fill in the value for the 'basepackage' attribute with the value of 'com.webage.bean'. This package contains the bean
that had the @Component annotation added.

__13. Save the file.
__14. Click the 'Beans Graph' tab at the bottom of the editor.
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__15. Notice that the editor has detected that there will be a Spring bean named
'generator' defined from the annotation component scanning you just enabled.
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Note: This feature can be very useful because it can let you define beans by annotation
which will simplify the XML but still determine what Spring beans are defined. This
addresses the concern with annotations that Spring bean definitions are "hidden" in the
Java code unlike XML configuration where it is obvious.
__16. From the menus select Run → Run History → ProductCodeGeneratorTest.
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__17. Notice that even though the values of the product code generator changed because
they are being set in the Java code and not by the XML the more important aspect is that
the second generator is continuing the same sequence of product codes as the first
'generator' bean retrieved. This is because we have removed the 'scope' setting that was
set using XML and are back to using the default of 'singleton' scope.

N

__18. Return to the editor for the BasicProductCodeGenerator.java file. Open it again
if you closed it.
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__19. Add the following annotation on the class definition. You will have errors until a
following step.
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@Component("generator")
@Scope("prototype")
public class BasicProductCodeGenerator
implements ProductCodeGenerator {

EV

__20. Organize imports by selecting Source → Organize Imports.
__21. Save the file and make sure there are no errors.
__22. From the menus select Run → Run History → ProductCodeGeneratorTest.
__23. Notice that you are now back to where the second code generator will start over
from the beginning because the 'prototype' scope is in effect.
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__24. Return to the editor for the 'spring-beans.xml' file.
__25. Click the 'Source' tab at the bottom of the editor.
__26. Add the following bean definition with XML. Make sure it is nested properly as a
child element of the <beans> tag but outside any other tag or comment.
<bean id="generator" class="com.webage.bean.BasicProductCodeGenerator">
<property name="current" value="100"></property>
</bean>
<context:component-scan base-package="com.webage.bean">
</context:component-scan>

Note: Since this bean definition has the same id as that used by the annotation this will
end up overriding the 'current' property and changing the output of the generated codes.
__27. Save the file.
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__28. From the menus select Run → Run History → ProductCodeGeneratorTest.
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__29. Notice that even though the values of the product code generator changed and are
starting from 100 as overridden in the XML we are back to the codes not starting over
with the second generator so obviously the singleton scope is in effect again.

Note: This behavior is because the XML definition overrides the annotation including
the scope setting. Even though there is no scope setting in the XML the lack of any
setting means that the scope annotation is ignored and the default of singleton is applied
by the XML schema.
__30. Modify the XML bean definition to include the 'scope' annotation set to a
'prototype' value as shown below.
<bean id="generator" class="com.webage.bean.BasicProductCodeGenerator"
scope="prototype">
<property name="current" value="100"></property>
</bean>

__31. Save the file.
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__32. From the menus select Run → Run History → ProductCodeGeneratorTest.
__33. Notice that you are now back to where the second code generator will start over
from the beginning because the 'prototype' scope is in effect. You are also using the new
starting point value set by the XML in combination with the other default values
initialized in the Java code.
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Part 4 - Using Standard JSR-330 Annotations
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One of the downsides of the annotations in the previous section is they come from the
Spring framework. Often the goal is to write Java code that does not have any link to the
Spring framework and these annotations violate that goal. Even though this is only one
class in your project it would be worse if you had dozens or even hundreds of Spring
components declared this way.
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The JSR-330 Java specification defines a set of standard annotations for dependency
injection. Spring recognizes these standard annotations and we can use those annotations
to define Spring beans to avoid mentioning Spring directly in our Java code.
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__1. Open the pom.xml file from the root of the 'Spring-BeanAnnotations' project.

EV

__2. Switch to the source of the pom.xml by selecting the 'pom.xml' tab along the
bottom of the editor. You might need to look for some tabs that are hidden on the far
right side and expand those to select the proper view.
__3. Find the section that is commented out (<!-- .. -->) that has the dependencies for the
JSR-330 (javax.inject) libraries. Remove the comment tags from before and after this
section so the library is an active dependency.
<dependency>
<groupId>javax.inject</groupId>
<artifactId>com.springsource.javax.inject
</artifactId>
<version>1.0.0</version>
</dependency>
</dependencies>
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__4. Save the file and be sure there are no red errors in the margin for the file. These will
occur if you don't remove the comment tags properly.
__5. Close the pom.xml file.
__6. Return to the editor for the BasicProductCodeGenerator.java file. Open it again if
you closed it.
__7. Comment out the Spring @Component and @Scope annotations and add the
@Named annotation as shown below. Note that we will give the bean a different name to
easily avoid the XML overridden configuration.
//@Component("generator")
//@Scope("prototype")
@Named("namedGenerator")
public class BasicProductCodeGenerator
implements ProductCodeGenerator {
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__9. Save the file and make sure there are no errors.
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__8. Organize imports by selecting Source → Organize Imports.
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__10. Return to the editor for the ProductCodeGeneratorTest.java file. Open it again if
you closed it.
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__11. Modify the name of the bean used in the 'getBean' method as shown below. Make
sure you change both locations the method is used. This will find our bean defined with
the JSR-330 @Named annotation.
ProductCodeGenerator generator = context.getBean("namedGenerator",
ProductCodeGenerator.class);

EV

System.out.println("Generator: " + generator.getNextProductCode());
System.out.println("Generator: " + generator.getNextProductCode());
System.out.println("Generator: " + generator.getNextProductCode());
ProductCodeGenerator generator2 = context.getBean("namedGenerator",
ProductCodeGenerator.class);
System.out.println("Generator2: " + generator2.getNextProductCode());

__12. Save the file and make sure there are no errors.
__13. From the menus select Run → Run History → ProductCodeGeneratorTest.
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__14. Notice that the code does "work" because it finds a bean by that name and doesn't
throw an Exception. The problem is we are back to the singleton scope behavior for the
bean where the second generator does not restart the generated code sequence.

Part 5 - Defining a Custom Component Stereotype Annotation
Unfortunately we are back to the singleton behavior instead of the 'prototype' behavior.
At this point we need to figure out how to proceed.
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Adding the Spring @Scope annotation would violate the goal of not having any Spring
code or annotations directly in the code of the Java component. JSR-330 also describes a
@Scope annotation but it is not used the same way. The JSR-330 @Scope annotation is
meant for defining custom scope annotations for processing by a dependency injection
framework. Unfortunately Spring 3.0 currently doesn't support that approach and even if
it did it would just be another Spring annotation and would not allow us to avoid Spring
annotations in the Java component.
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A third approach can be taken which is to define our own custom annotation for applying
Spring component qualities (like scope) to Java components in the application. These
custom annotations will contain Spring annotations but will allow us to avoid Spring
annotations in the components themselves. Using this approach the Java components
will have only standard Java annotations and/or our custom annotations which will be
part of the application. The "dependence" on the Spring framework is also now isolated
to the custom annotation and if in the future the application doesn't use Spring we would
only need to redefine the custom annotation.
__1. Right click the Spring-BeanAnnotations → src folder and select New →
Annotation.
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__2. Fill in a name of AppComponent and a package of 'com.webage.annotation' for
the annotation and click the Finish button.
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@Target(ElementType.TYPE)
@Retention(RetentionPolicy.RUNTIME)
@Documented
@Service
@Scope("prototype")
public @interface AppComponent {

N
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__3. Modify the code by adding the following lines. You will have errors until the next
step.
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Note: The annotations @Service and @Scope are the only Spring annotations. The
other annotations are part of the Java annotation API and determine where the custom
annotation can be used (@Target) and when the annotation is processed (@Retention).
__4. Organize imports by selecting Source → Organize Imports. When prompted
select the 'org.springframework.context.annotation.Scope', click the Next button,
select the 'java.lang.annotation.ElementType' and click the Finish button.
__5. Save the file and make sure there are no errors.
__6. Return to the editor for the BasicProductCodeGenerator.java file. Open it again if
you closed it.
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__7. Add the new custom annotation to the declaration of the class. Make sure the Spring
annotations remain commented out or deleted. You will have errors until the next step.
//@Component("generator")
//@Scope("prototype")
@Named("namedGenerator")
@AppComponent
public class BasicProductCodeGenerator
implements ProductCodeGenerator {

__8. Organize imports by selecting Source → Organize Imports.
__9. Save the file and make sure there are no errors.

AL
U

Part 6 - Bean Inheritance
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__10. From the menus select Run → Run History → ProductCodeGeneratorTest.
Notice that the prototype behavior is back since the second generator starts over at the
initial value.
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Often you may have application components that are based on the same Java class but
differ only in the value of some properties. To reuse the greatest amount of the Spring
bean definition it is often desired to inherit the Spring bean definitions and simply modify
the properties that are different.
__1. Return to the editor for the 'spring-beans.xml' file. Open it if you had closed it.
__2. Click the 'Source' tab at the bottom of the editor.
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__3. Add the following bean definition with XML. Make sure it is nested properly as a
child element of the <beans> tag but outside any other tag or comment.
<bean id="generator" class="com.webage.bean.BasicProductCodeGenerator"
scope="prototype">
<property name="current" value="100"></property>
</bean>
<bean id="altPrefixGenerator" parent="generator">
<property name="prefix" value="ALT"></property>
</bean>
<context:component-scan base-package="com.webage.bean">
</context:component-scan>

Note: The 'generator' bean does not use a prefix but this inherited bean does. We will
know it works if the prefix shows up in the generated codes.
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__4. Save the file.
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__5. Click the 'Beans Graph' tab at the bottom of the editor.
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__6. Notice that the editor has detected the bean inheritance and used a dashed arrow to
indicate the relationship. In this picture though the 'altPrefixGenerator' is shown above
which would imply it is the parent so remember that the arrow points from the inheriting
bean to the bean it inherits from.
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__7. Return to the editor for the ProductCodeGeneratorTest.java file. Open it again if
you closed it.
__8. Modify the name of the bean used in the 'getBean' method as shown below. Make
sure you change both locations the method is used. This will find the bean definition that
is defined with inheritance.
ProductCodeGenerator generator = context.getBean("altPrefixGenerator",
ProductCodeGenerator.class);
System.out.println("Generator: " + generator.getNextProductCode());
System.out.println("Generator: " + generator.getNextProductCode());
System.out.println("Generator: " + generator.getNextProductCode());
ProductCodeGenerator generator2 = context.getBean("altPrefixGenerator",
ProductCodeGenerator.class);
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System.out.println("Generator2: " + generator2.getNextProductCode());
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__9. Save the file and make sure there are no errors.
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__10. From the menus select Run → Run History → ProductCodeGeneratorTest.
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__11. Notice that the prefix appears so it is using the inherited bean definition. The scope
setting is also inherited since this test shows the prototype behavior where the code
restarts with the second generator.

Part 7 - Externalize Spring Configuration
Often some elements of the Spring configuration may change, often as the application is
deployed in different environments. Although it might be possible to have multiple
Spring configuration files this might too often repeat too much of the Spring
configuration allowing for the chance to have differences between multiple files.
The best solution is to externalize the configuration that is different into a file like a
properties file and then refer to these properties. This will reuse as much of the Spring
configuration as possible but still allow for easily changing Spring configuration
properties.
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__1. Select the Spring-BeanAnnotations → src folder by clicking it.
__2. Select File → New → File.
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__3. Enter a file name of generator.properties and make sure the parent folder is
'Spring-BeanAnnotations/src' before clicking the Finish button.
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__4. Add the following property definitions in the property file. The keys before the
equals sign are important as these will be the property names used in the Spring
configuration file.

__5. Save the file.
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generator.basePrefix=WA
generator.altPrefix=TOY
generator.initialCount=500
generator.defaultIncrement=5

__6. Return to the editor for the 'spring-beans.xml' file. Open it again if you closed it.
__7. Click the 'context' tab at the bottom of the editor.
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__8. In the 'Context Overview' section, right click the 'beans' element and select Insert
<context:property-placeholder> element.
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__9. With the new 'property-placeholder' element selected fill in the value for the
'location' attribute with the value of 'generator.properties'. This is the location of the
new properties file is located on the classpath of the project.

__10. Click the 'Source' tab at the bottom of the editor.
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__11. Modify the properties of the Spring bean definitions to use the property values.
Notice there are also some new properties added to the 'generator' bean to show setting
several bean properties with the property file.
<bean id="generator" class="com.webage.bean.BasicProductCodeGenerator"
scope="prototype">
<property name="current" value="${generator.initialCount}">
</property>
<property name="prefix" value="${generator.basePrefix}">
</property>
<property name="increment"
value="${generator.defaultIncrement}"></property>
</bean>
<bean id="altPrefixGenerator" parent="generator">
<property name="prefix" value="${generator.altPrefix}">
</property>
</bean>
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__12. Save the file.
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__13. Return to the editor for the ProductCodeGeneratorTest.java file. Open it again if
you closed it.
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__14. Modify the name of the bean used in the first 'getBean' method as shown below.
This will show the codes generated by both Spring bean definitions and see how the
properties are set with the external properties file.
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ProductCodeGenerator generator = context.getBean("generator",
ProductCodeGenerator.class);
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System.out.println("Generator: " + generator.getNextProductCode());
System.out.println("Generator: " + generator.getNextProductCode());
System.out.println("Generator: " + generator.getNextProductCode());
ProductCodeGenerator generator2 = context.getBean("altPrefixGenerator",
ProductCodeGenerator.class);

__15. Save the file and make sure there are no errors.
__16. From the menus select Run → Run History → ProductCodeGeneratorTest.
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__17. Notice that the code generators behave as expected even though the properties are
defined by the external property file.

__18. Close all open files.

Part 8 - Lab Cleanup
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__1. Delete the ProductCodeGeneratorTest run configuration from the AspectJ/Java
Application run configurations as described in the 'Common Lab Preparation Steps' at the
'Lab Cleanup' part.
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__2. Close the Spring-BeanAnnotations project as described in the 'Common Lab
Preparation Steps' at the 'Lab Cleanup' part.
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Part 9 - Review
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In this lab you saw advanced ways to define Spring beans. You can do this with a few
different types of Java annotations. There are annotations that are specific to Spring and
also annotations defined as part of the JSR-330 Java specification for dependency
injection annotations. You even saw a way to avoid Spring annotations directly in the
Java component and isolate the Spring annotations in custom annotations defined as part
of your application. Finally you saw how to externalize settings for Spring components
that might change into external properties files using the "Property Placeholder" feature
of Spring.
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