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Lab 1 - Setting up the Development Environment
Technically, all you need to develop Android apps is a Java SDK and the Android SDK. 
Android Studio can speed up development a lot. And you can spend your time doing 
other fun things.

To save time, these items are already installed for you.

1. Android Studio has been installed in 'C:\Program Files\Android\Android Studio'

2. Android SDK has been installed in 'C:\Users\user-
name\AppData\Local\Android\Sdk'

Part 1 - Check Android Studio and Android SDK
The first step is to verify Android Studio and the Android SDK are using the same 
versions as when the labs for the course were tested.  Even if they initially are not, you 
can download the correct Android version fairly easily.

__1. Open Android Studio by clicking on its link.

__2. Click Configure and select SDK Manager.

__3. These SDK platforms should be installed:

Android 10.0+ (R)

Android 9.0 (Pie)

If one of these is not installed click on the check-mark next to it and then click the 
"Apply" button at the lower right of the window.
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Click OK to confirm change.

If needed wait for the files to be installed. This can take some time.

Click "Finish" when its done.

__4. Once the two SDKs are checked and their status is listed as "installed" you can click 
"Cancel" to dismiss the dialog window. 

Part 2 - Create Android Studio Project
We will now create a simple Android project and get familiar with some of the other 
aspects of Android Studio.

__1. Check that you are back in the 'Quick Start' page of the Android Studio Welcome 
dialog.  Reopen Android Studio if you had closed it.

__2. From the list of 'Quick Start' options, click the option for '+ Start a new Android 
Studio project'.
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__3. In the "Select a Project Template" Dialog, select the "Phone and Tablet" tab and the 
"Empty Activity" App type.

__4. Click "Next"

__5. In the "Configure Your Project" dialog, Change the properties of the project to 
match the following:

Application name – HelloWorld

Package name – www.webage.com

Save Location - C:\LabFiles\AndroidStudioProjects\HelloWorld

Minimum SDK -  API 28: Android 9.0 (Pie)
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__6. Click the Finish button when your project options match those above.

__7. Leave 'Phone and Tablet' as the only platform and Change the option for minimum 
SDK to 'API 26: Android 8.0 (Oreo)'.  You may need to scroll up in the drop-down list 
to see this option.

Note: The tool gives you a useful tip of what percentage of devices your app would be 
compatible with depending on your minimum SDK selection.

__8. Click the Next button when your project options match those above.

__9. Select the option for an Empty Activity and click the Next button.
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__10. Change the name of the activity to create to 'HelloWorldActivity'.

__11. Once your last page appears as shown above click the Next button.

__12. On the Component Installer dialog click Finish.
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__13. If prompted by Windows Firewall while Android Studio is creating the project, 
select to unblock the process.

__14. Wait for gradle to sync and build, The first time takes the longest,

__15. Progress is displayed in status bar at the bottom of the Android Studio window.

__16. You can see more details if you click on "Event Log"

__17. It may take a few minutes but Android Studio should eventually create the project 
and open a few files.  

__18. Once sync and build has completed you can move on to the next section.

Part 3 - Modify Android Studio Settings
There are some settings that will make working with Android Studio easier but are not 
the defaults.

__1. From the Android Studio menus select 'File → Settings'.

__2. In the settings, expand and select 'Editor → General → Auto Import'.

__3. Under the Java options, check the box for 'Add unambiguous imports on the fly'.
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__4. Click the OK button to close the settings.

Part 4 - Create a Virtual Device
An Android Virtual Device (AVD) is a device (phone) emulator. You will use it to test 
and debug applications.

__1. From the Android Studio menu-bar, select 'Tools → AVD Manager'.

Note. If you don't see this option wait until Android is fully loaded.

__2. This will open the following dialog:

__3. In the "Your Virtual Devices" dialog, click the 'Create Virtual Device' button.

__4. In the "Select Hardware" dialog choose "Phone" from the "Category" choices on the 
left, then choose "Pixel XL" in the center box:
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__5. Click "Next"

__6. You will see the "System Image" dialog. Click the tab "x86 Images" and then Select 
"Pie 28 x86_64 Android 9.0 (Google APIs)"

__7. You may notice the word "Download" in blue text next to the word "Pie". 

__8. Click on "Download" to install the emulator files for that Android version. You will 
see a licensing agreement dialog come up.
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__9. Click "Accept" and "Next". 

__10. Let the install finish. This can take some time.

__11. The word "Download" should now be gone

__12. Click the "Next" button. This will show the "Android Virtual Device (AVD)" 
dialog.

__13. Change the "AVD Name" to my_avd and then click "Finish"

__14. Your AVD should show in the "Your Virtual Devices" dialog:
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__15. Click the Start arrow icon on the far right for the 'my_avd' entry.  Hovering over 
the arrow should show this message.

The AVD will be launched. Even after the progress bar disappears you may not see the 
emulator immediately.  Once the emulator window does appear, it takes a while for the 
machine to boot.  
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__16. Close the Emulator by clicking on the X in the control panel on the right side of the 
emulator.

__17. Close the "Android Virtual Device Manager" dialog.

__18. Leave Android Studio open in the 'Hello World' project.

As you have just seen, booting the AVD can take some time. Fortunately, this is 
something you need to do only once or twice a day. Most code changes can be executed 
in the AVD without a full reboot.

Note: To improve the emulator performance, the emulator uses something called the 
Intel Hardware Accelerated Execution Manager (HAXM) which treats the emulator as a 
virtual machine.
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Part 5 - Review
In this lab, we prepared the development environment. Now, we are ready to develop and 
test Android apps.

We did these key things:

1. Review Android SDK Platform.

2. Create an Android project in Android Studio.

3. Create a virtual device (AVD).

14



Lab 2 - Developing a Simple Application
In this lab, we will develop a very simple application. It will simply display the "Hello 
World" message. The goal is to understand the basic develop-test-debug cycle. We will 
not spend much time understanding the API itself.

Part 1 - Inspect the Project
When you first create the project a few Java classes and XML files are created 
automatically. We will take a quick look at them.

__1. Make sure you are viewing the 'HelloWorld' project in Android Studio that was 
created in the last lab.  If you aren't, open Android Studio and select the project from the 
Welcome dialog if needed.

__2. In the upper left you should see the files of the project.  You might want to double 
check that you are in the 'Android' view of the project with the drop-down of the upper-
left tab.

__3. 

__4. Expand a few levels of the top level folders of the Android project view and look at 
the contents.  The 'app' folder is the IntelliJ module for the Android application. You 
should see some of the following folders:

manifests/ - Manifest files for the module.

java/ - Source files for the module.

res - Resource files for the module.

Gradle Scripts/ - Gradle build and property files.

__5. Switch to the 'Project' option in the project view in the upper left of Android Studio 
by selecting this option from the drop-down list.

__6. 
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__7. Notice in this 'Project' view, which is not really specific to the Android tools, you 
see a different structure for the application module (app).  You see many of the exact 
folders that are used for project settings and building code that were hidden in the 
Android view of the tool.

Note: Generally the 'Android' view of the project is better as it helps focus on the files 
and settings you should be working with and helps ignore some of the things maintained 
by the Android Studio tool itself.

__8. 

__9. Switch back to the 'Android' option in the project view in the upper left of Android 
Studio by selecting this option from the drop-down list.

__10. Expand the app/res/layout folder and find the file called activity_main.xml. This 
XML file has the layout of a screen. The MainActivity class loads the layout from this 
file.

__11. Expand the app/res/values folder and find the file called strings.xml. This file 
contains text used by various widgets. For example, the label for a button can be stored 
here. You could directly specify the label in the layout file. But, externalizing text from 
the layout is essential for localization of an app in multiple languages.

__12. Expand the app/manifests folder and find the file called AndroidManifest.xml. 
This has a few key pieces of information:

• The name, label and icon of the app.

__13. Every activity is listed here. The main activity, the one that is displayed first when 
the app is launched is designated as such.
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Part 2 - Inspect the Activity Class
__1. Open MainActivity.java from the app/java/www.webage.com folder if it is not 
already open.

Note that it extends the AppCompatActivity class.

The onCreate() callback method is called by the runtime so that the activity can create the 
GUI widgets and setup the layout. Right after that happens, the activity is displayed on 
screen.

The key line in onCreate is this one.

setContentView(R.layout.activity_main);

The setContentView() needs the unique integer ID of a layout file. The layout is then 
loaded from that file. In our case, the layout file is res/layout/activity_main.xml. The 
system has already designated it a unique ID and saved it in a generated “R” class.

The setContentView() method takes the unique ID of the layout file which the system 
was gracious enough to assign for us and save it in the R class. We don't have to hard 
code the ID in the activity class.

Note: The R class is always kept up to date by the build process. If you create another 
layout file call my_layout.xml, it will automatically add a member variable to the layout 
inner class called my_layout. That variable will have the unique ID of the new layout 
file.

As an alternative to using layout files, you can directly use API in the onCreate method 
to create the GUI widgets. In most cases, however, that will be more cumbersome than 
the use of a layout file.

Part 3 - Inspect the Layout
__1. Open app/res/layout/activity_main.xml.

__2. From the top-right of the editor, select the Code icon.

__3. 

Note that a ConstraintLayout has been used. Such a layout component can group many 
child widgets. Right now it contains a TextView child widget.

The label text is hard coded as shown below:

android:text="Hello World!"

__4. From the top right of the editor, select the Design icon.
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__5. 

__6. You can select a target device to preview the layout before the application is 
launched.

__7. 

__8. Click the drop-down arrow next to the device name. You can easily change the 
resolution to see how the GUI will accommodate that resolution.

__9. Close all open files making sure you have not made any changes to the file.

Part 4 - Test the Application
The next step is to test the application and see it deployed and running on the emulator. 
You will also see some tools in Android Studio to see messages coming from the 
emulator.

__1. Take a look at the following section near the top of the Android Studio screen:
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__2. 

__3. 

The dropdown to the right (currently showing the "my_avd" virtual device you created in 
the AVD Manager) allows you to pick a location where you want to run the application. 
The location can be an Android Virtual Device or a physical Android device.

__4. In Android Studio select "Run 'app'' from the "Run" menu.  The project may run 
some build commands but eventually a dialog should appear for how to run the 
application.

__5. While the emulator is booting (after the window appears) you can check the 
messages in the 'logcat' portion of the Android views to see messages from the emulator 
starting.  If Logcat is not open then select View → Tool Windows → Logcat from the 
menu or by clicking on the "LogCat" label just above the status bar at the bottom of the 
screen.

__6. This is a sample logcat view.
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Log entries in logcat let you know what's going-on on the device

__7. Once the emulator has started you should see the app displayed.

Note that booting the AVD can take time. Fortunately, this is something you need to do 
only once or twice a day. Most code changes can be executed in the AVD without a full 
reboot. We will try that now.

__8. Leave the 'my_avd' emulator running.
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__9. Open the layout file activity_main.xml.  This is in the 'app/res/layout' folder in the 
project.

__10. Click the 'Code' icon in the upper right of the edit window.

__11. Change the label text to something else, like this.  Ignore the warning that may 
appear about hardcoding a value.

android:text="Hello Wonderful World!!!"

__12. Save the file (File → Save All or CTRL-S).

__13. From the Android Studio menus select 'Run → Run 'app''.

__14. The new app will be launched in the AVD

Part 5 - Debugging the App
Debugging is really easy and no different from debugging any Java application in IntelliJ. 
One cool feature is that, you do not need to reboot the AVD in debug mode. You simply 
launch the app in debug mode.
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__1. Back in Android Studio, open MainActivity.java.  This is in the 
app/java/www.webage.com folder.

__2. Put a breakpoint next to super.onCreate.  You do this by clicking in the gray left 
margin.

__3. From the Android Studio menus select 'Run → Debug 'app''.

__4. 

__5. Eventually program control will stop at the breakpoint and the 'Debug' view 
becomes active in the tabs on the lower left of Android Studio.

We will take this opportunity to tweak the title label of the application.

__6. In the toolbar of the debugger, click the 'Step Over (F8)' button once.  Make sure to 
click it only once.

__7. In the Variables view, expand this.
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__8. Scroll down, and locate the mTitle member variable of the object.

__9. Right click mTitle, and select Set Value.

__10. Enter "My First App" with the double quotes as the new value.

__11. Hit <ENTER> to modify the value.  It may take some time to change the value.

__12. Now, we are ready to release the program control. Click the Resume Program 
button (Green Arrow) on the top left of the debugger or press F9.

__13. Switch back to the emulator and notice the application title is different.
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Note: In this exercise, we tweaked an internal member variable of the activity. This was 
done for demonstration purposes only. You are free to modify variables in your own 
classes. But, changing state managed by the SDK can cause serious problems.

__14. Close all open files.

__15. Leave the AVD emulator running.

Part 6 - Review
This was a simple lab. But,we learned a few vital information about an Android app.

1. An activity class shows a screen full of GUI widgets.

2. The screen is designed in a layout file. The activity class loads the layout from the 
onCreate method.

3. The R class keeps the unique IDs of various objects, including the layout files. 
This resource is automatically kept up to date as you create or delete objects in the 
project.

4. To launch an app you use the 'Run' menu of Android Studio

5. To debug an app, put breakpoints and then run the app in debug mode.
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Lab 3 - Basic UI Development
So far we have played with the layout file that was already created at the time of project 
creation. We will now create a new layout and load it from our activity. We will also work 
briefly with event handling. This will give us a deeper understanding of how GUI 
programming works and take more mystery away from the mysterious R class.

The business logic of the app will be as follows. The user will enter a message in a text 
box and click the Show Me button. The message will be displayed back in a label.

Part 1 - Create a New Layout
__1. Launch Android Studio in the HelloWorld project if it is not already running.

__2. Right click the 'app/res/layout' folder and select New → Layout Resource File.

__3. Enter my_layout as the file name and set LinearLayout as root element.

__4. Click OK when your options match those shown above.

Part 2 - Design the Layout
__1. Open res/layout/my_layout.xml if it is not already.

__2. Select the Design icon from the top-right of the editor.

__3. Check that the resolution is set to 'Pixel XL' if required.  This is set a drop-down at 
the top of the editor (you may need to maximize the Android Studio window to see it).
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__4. Locate the Component Tree view that should be in the bottom of the left pane.

This view shows the hierarchy of all views in the layout. When a layout is complex, it is 
easier to select a view here rather than on the editor.

There are two ways of setting properties of a view selected in the editor. You can use the 
Properties view. Alternatively, you can right click the view and use the context menu.

__5. Click on that LinearLayout in the Component Tree view.

__6. In the Attributes view on the right pane, verify that the Orientation property is set to 
vertical.
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Now, we will add a TextView within the LinearLayout.

__7. In the tool palette, locate the Text section (expand if needed) and locate TextView.

__8. Select the 'TextView' entry in the list of widgets.

__9. Drag 'TextView' to the design right below the words 'HelloWorld'.  Before you un-
click to drop the element, you should colored boxes where the element will be added.

__10. Select the textView in the ComponentTree.

__11. Now go to the Attributes view and change value of the 'ID' property (textView), 
change the value to 'MessageLabel' as shown below, then hit the <ENTER> key to 
accept the change.
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Note: The ID name determines the name of the corresponding member variable in the R 
class. Changing the ID name to a more meaningful value will make our code more 
readable.

__12. Notice the Id updates in the Component Tree view also.

__13. Find the  'text' property in the Attributes view. Hover over the button to the right of 
the text field. The tooltip text that pops up should say "Pick a Resource".

__14. 

__15. Click on the button to bring up the 'Pick a Resource' dialog.

__16. The Resources dialog displays existing string resources. Click the plus (+) sign at 
the upper left of the dialog and select "String Value"

__17. Enter a 'Resource name' of 'MessageString' and a 'Resource value' of 'Please enter a 
message:' and click the OK button.
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__18. You should now see the value you added in the 'pick a resource' dialog:

__19. Click on MessageString and then click 'OK'

__20. The value of the 'text' attribute should have been updated to 
"@string/MessageString".

Note: You can also change the text by directly selecting it in the Properties view and 
typing a new value as long as you hit the Enter key when finished entering text.  

__21. In the Attributes panel, set the textAppearance dropdown to Large

__22. 

__23. 

__24. In the palette, find the Text section.

__25. Select the 'PlainText' and drag it below the TextView field you added in the 
previous steps.

__26. Check that the editText element is added below the message and is still selected. If 
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needed you can select it in the component tree.

__27. Follow the same procedure as before to change the 'Id' property to 'MessageText'.

__28. 

__29. In the Attributes panel clear the value from the TextView → text field.

__30. Check that the Id has been updated in the Component Tree view.

__31. In the tool palette, locate the 'Button' widget.

__32. Add a Button view to the screen below the EditText element.

__33. 
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__34. Change the button's attributes to match the following:

• Id: ShowButton

• Text: Show Me

__35. The screen should now look like this.

__36. Save changes.

Part 3 - Use the New Layout from the Activity
__1. Start the 'my_avd' device from the AVD Manager if it is not already running.

__2. Open MainActivity.java.

__3. Load the new layout by making this change shown in bold.

protected void onCreate(Bundle savedInstanceState) {
    super.onCreate(savedInstanceState);
    setContentView(R.layout.my_layout);
}

__4. Save changes.

__5. If needed wait for the AVD device to complete its startup. (not necessary if it was 
already running)

__6. From the Android Studio menus select 'Run → Run 'app''.  The project may run 
some build commands but eventually the emulator should update and show the updated 
application.

__7. Click on the emulator.  
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Looking good so far. You can enter text into the field and click the button but nothing will 
happen just yet. We need to hook up the button so that we can do something with the 
entered text.

Part 4 - Obtain References to the Views
Before we can get the text entered by the user and show it in the label, we have to obtain 
references to view elements. Similarly, before we can attach an event handler for the 
button, we need a reference for the button object. We have already assigned unique IDs 
for them. Getting the references will be a piece of cake.

__1. Open the MainActivity java class and add member variables as shown here:

public class HelloWorldActivity extends AppCompatActivity {
TextView mMessageLabel;
EditText mMessageText;
Button mShowButton;

__2. You may have errors for unknown classes.  If you do, click on each one and hit 'Alt 
+ Enter' to add the import statement after the popup appears.

__3. Within the onCreate method, below the setContentView line, add these lines to 
obtain references to the views.

    protected void onCreate(Bundle savedInstanceState) {
        super.onCreate(savedInstanceState);
        setContentView(R.layout.my_layout);
        mMessageLabel = (TextView) findViewById(R.id.MessageLabel);
        mMessageText = (EditText) findViewById(R.id.MessageText);
        mShowButton = (Button) findViewById(R.id.ShowButton);
    }

Part 5 - Attach an Event Handler to the Button
We will attach an "on click" event handler for the button. Don't worry too much about the 
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details of the API. Just focus on the concept at this time.

__1. At the end of the onCreate method add the bold lines below.

        mMessageLabel = (TextView) findViewById(R.id.MessageLabel);
        mMessageText = (EditText) findViewById(R.id.MessageText);
        mShowButton = (Button) findViewById(R.id.ShowButton);
        mShowButton.setOnClickListener(new View.OnClickListener() {
            public void onClick(View arg0) {
                String msg = "You entered: " +
                    mMessageText.getText().toString();
                mMessageLabel.setText(msg);
            }
        });
    }

The method gets the text entered by the user and shows it in the label.

__2. Save changes and make sure there are no errors.

__3. Close all open files.

Part 6 - Test
__1. From the Android Studio menus select 'Run → Run 'app''.  Wait for the new app to 
be uploaded and launched in the AVD.

__2. Enter some text and click the Show Me button. Make sure that the label is updated.
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Awesome!

__3. You can leave Android Studio and the AVD device open.

Part 7 - Review
At the end of this lab, you pretty much know how to develop a basic GUI driven Android 
application. New skills learned here are as follows:

1. How to use the interactive layout builder.

2. How to assign Ids to the views and obtain references to the view objects using the 
IDs.

3. Basic event handling.

4. How to obtain user input data.

After this, once you know how to save data and how to use richer views, like list, date 
picker and checkbox, you are ready write professional and useful apps.
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	__5.  Switch to the 'Project' option in the project view in the upper left of Android Studio by selecting this option from the drop-down list.
	__7.  Notice in this 'Project' view, which is not really specific to the Android tools, you see a different structure for the application module (app).  You see many of the exact folders that are used for project settings and building code that were hidden in the Android view of the tool.
	__9.  Switch back to the 'Android' option in the project view in the upper left of Android Studio by selecting this option from the drop-down list.
	__10.  Expand the app/res/layout folder and find the file called activity_main.xml. This XML file has the layout of a screen. The MainActivity class loads the layout from this file.
	__11.  Expand the app/res/values folder and find the file called strings.xml. This file contains text used by various widgets. For example, the label for a button can be stored here. You could directly specify the label in the layout file. But, externalizing text from the layout is essential for localization of an app in multiple languages.
	__12.  Expand the app/manifests folder and find the file called AndroidManifest.xml. This has a few key pieces of information:
	__13.  Every activity is listed here. The main activity, the one that is displayed first when the app is launched is designated as such.

	Part 2 -  Inspect the Activity Class
	__1.  Open MainActivity.java from the app/java/www.webage.com folder if it is not already open.

	Part 3 -  Inspect the Layout
	__1.  Open app/res/layout/activity_main.xml.
	__2.  From the top-right of the editor, select the Code icon.
	__4.  From the top right of the editor, select the Design icon.
	__6.  You can select a target device to preview the layout before the application is launched.
	__8.  Click the drop-down arrow next to the device name. You can easily change the resolution to see how the GUI will accommodate that resolution.
	__9.  Close all open files making sure you have not made any changes to the file.

	Part 4 -  Test the Application
	__1.  Take a look at the following section near the top of the Android Studio screen:
	__4.  In Android Studio select "Run 'app'' from the "Run" menu.  The project may run some build commands but eventually a dialog should appear for how to run the application.
	__5.  While the emulator is booting (after the window appears) you can check the messages in the 'logcat' portion of the Android views to see messages from the emulator starting.  If Logcat is not open then select View → Tool Windows → Logcat from the menu or by clicking on the "LogCat" label just above the status bar at the bottom of the screen.
	__6.  This is a sample logcat view.
	__7.  Once the emulator has started you should see the app displayed.
	__8.  Leave the 'my_avd' emulator running.
	__9.  Open the layout file activity_main.xml.  This is in the 'app/res/layout' folder in the project.
	__10.  Click the 'Code' icon in the upper right of the edit window.
	__11.  Change the label text to something else, like this.  Ignore the warning that may appear about hardcoding a value.
	__12.  Save the file (File → Save All or CTRL-S).
	__13.  From the Android Studio menus select 'Run → Run 'app''.
	__14.  The new app will be launched in the AVD

	Part 5 -  Debugging the App
	__1.  Back in Android Studio, open MainActivity.java.  This is in the  app/java/www.webage.com folder.
	__2.  Put a breakpoint next to super.onCreate.  You do this by clicking in the gray left margin.
	__3.  From the Android Studio menus select 'Run → Debug 'app''.
	__5.  Eventually program control will stop at the breakpoint and the 'Debug' view becomes active in the tabs on the lower left of Android Studio.
	__6.  In the toolbar of the debugger, click the 'Step Over (F8)' button once.  Make sure to click it only once.
	__7.  In the Variables view, expand this.
	__8.  Scroll down, and locate the mTitle member variable of the object.
	__9.  Right click mTitle, and select Set Value.
	__10.  Enter "My First App" with the double quotes as the new value.
	__11.  Hit <ENTER> to modify the value.  It may take some time to change the value.
	__12.  Now, we are ready to release the program control. Click the Resume Program button (Green Arrow) on the top left of the debugger or press F9.
	__13.  Switch back to the emulator and notice the application title is different.
	__14.  Close all open files.
	__15.  Leave the AVD emulator running.

	Part 6 -  Review

	Lab 3 -  Basic UI Development
	Part 1 -  Create a New Layout
	__1.  Launch Android Studio in the HelloWorld project if it is not already running.
	__2.  Right click the 'app/res/layout' folder and select New → Layout Resource File.
	__3.  Enter my_layout as the file name and set LinearLayout as root element.
	__4.  Click OK when your options match those shown above.

	Part 2 -  Design the Layout
	__1.  Open res/layout/my_layout.xml if it is not already.
	__2.  Select the Design icon from the top-right of the editor.
	__3.  Check that the resolution is set to 'Pixel XL' if required.  This is set a drop-down at the top of the editor (you may need to maximize the Android Studio window to see it).
	__4.  Locate the Component Tree view that should be in the bottom of the left pane.
	__5.  Click on that LinearLayout in the Component Tree view.
	__6.  In the Attributes view on the right pane, verify that the Orientation property is set to vertical.
	__7.  In the tool palette, locate the Text section (expand if needed) and locate TextView.
	__8.  Select the 'TextView' entry in the list of widgets.
	__9.  Drag 'TextView' to the design right below the words 'HelloWorld'.  Before you un-click to drop the element, you should colored boxes where the element will be added.
	__10.  Select the textView in the ComponentTree.
	__11.  Now go to the Attributes view and change value of the 'ID' property (textView), change the value to 'MessageLabel' as shown below, then hit the <ENTER> key to accept the change.
	__12.  Notice the Id updates in the Component Tree view also.
	__13.  Find the  'text' property in the Attributes view. Hover over the button to the right of the text field. The tooltip text that pops up should say "Pick a Resource".
	__15.  Click on the button to bring up the 'Pick a Resource' dialog.
	__16.  The Resources dialog displays existing string resources. Click the plus (+) sign at the upper left of the dialog and select "String Value"
	__17.  Enter a 'Resource name' of 'MessageString' and a 'Resource value' of 'Please enter a message:' and click the OK button.
	__18.  You should now see the value you added in the 'pick a resource' dialog:
	__19.  Click on MessageString and then click 'OK'
	__20.  The value of the 'text' attribute should have been updated to "@string/MessageString".
	__21.  In the Attributes panel, set the textAppearance dropdown to Large
	__24.  In the palette, find the Text section.
	__25.  Select the 'PlainText' and drag it below the TextView field you added in the previous steps.
	__26.  Check that the editText element is added below the message and is still selected. If needed you can select it in the component tree.
	__27.  Follow the same procedure as before to change the 'Id' property to 'MessageText'.
	__29.  In the Attributes panel clear the value from the TextView → text field.
	__30.  Check that the Id has been updated in the Component Tree view.
	__31.  In the tool palette, locate the 'Button' widget.
	__32.  Add a Button view to the screen below the EditText element.
	__34.  Change the button's attributes to match the following:
	__35.  The screen should now look like this.
	__36.  Save changes.

	Part 3 -  Use the New Layout from the Activity
	__1.  Start the 'my_avd' device from the AVD Manager if it is not already running.
	__2.  Open MainActivity.java.
	__3.  Load the new layout by making this change shown in bold.
	__4.  Save changes.
	__5.  If needed wait for the AVD device to complete its startup. (not necessary if it was already running)
	__6.  From the Android Studio menus select 'Run → Run 'app''.  The project may run some build commands but eventually the emulator should update and show the updated application.
	__7.  Click on the emulator.  

	Part 4 -  Obtain References to the Views
	__1.  Open the MainActivity java class and add member variables as shown here:
	__2.  You may have errors for unknown classes.  If you do, click on each one and hit 'Alt + Enter' to add the import statement after the popup appears.
	__3.  Within the onCreate method, below the setContentView line, add these lines to obtain references to the views.

	Part 5 -  Attach an Event Handler to the Button
	__1.  At the end of the onCreate method add the bold lines below.
	__2.  Save changes and make sure there are no errors.
	__3.  Close all open files.

	Part 6 -  Test
	__1.  From the Android Studio menus select 'Run → Run 'app''.  Wait for the new app to be uploaded and launched in the AVD.
	__2.  Enter some text and click the Show Me button. Make sure that the label is updated.
	__3.  You can leave Android Studio and the AVD device open.

	Part 7 -  Review

	Lab 4 -  Basics of Activity and Process Lifecycle
	Part 1 -  Add Lifecycle Callback Methods
	__1.  Open MainActivity.java.
	__2.  From the Android Studio menus select Code → Override Methods.
	__3.  Click the button in the dialog to 'Sort Alphabetically'.
	__4.  Select these methods one at a time by typing their name and clicking OK to insert them into the MainActivity class: 
	__5.  Note that Android Studio has already added calls to the super class methods.

	Part 2 -  Log Message from Callback Methods
	__1.  Add a member variable to the class as follows.
	__2.  Add a log message to the onDestroy method as follows.
	__3.  Similarly, add a log message to all other callback methods, including onCreate.  Make sure to change the message that is logged to match the name of the callback method. Here is a complete list:
	__4.  Save changes.

	Part 3 -  Test
	__1.  Go to the logcat view.  Remember the logcat view is part of the Android tool window tab that should be visible along the lower edge of Android Studio.
	__2.  Launch the application by selecting 'Run → Run 'app''.
	__3.  In the log cat view, set the second dropdown to www.webage.com and the last drop down to Show only selected application. Logcat will now only display messages related to your application.
	__4.  The LogCat view will show output from the onCreate and onResume  methods right away. You may need to scroll to find them. Typing "MainActivity" into LogCat's filter field ( the field between "Verbose" and "Regex") will isolate the lines we are looking for.
	__5.  In the AVD, clicking the back button: 
	     Back: 
	__6.   This will cause our activity to be permanently destroyed.
	__7.  Check the LogCat view. onPause, onStop and finally onDestroy are called.
	__8.  Right click inside LogCat and choose, "clear logcat" to clear the view.
	__9.  In the AVD, click on the Home button.
	        Home: 
	__10.  Drag from the bottom of the emulator device screen upward, This will reveal apps that are installed  in the emulator:
	__11.  Click the icon labeled "HelloWorld". 
	__12.  An activity instance will be created. Check the LogCat view for messages. The onResume and onCreate callbacks will be called again.

	Part 4 -  Testing for Stop and Restart
	__1.  Make sure that the Hello World application is running in the foreground(that it is visible) in the emulator. If not, launch re-launch the application from Android Studio.
	__2.  Clear the LogCat view.
	__3.  In the AVD, simulate home button click by hitting the Home keyboard button or clicking the Home button in the emulator interface.
	__4.  Check the LogCat view. You should see that onPause() and onStop() were called in that order.
	__5.  Drag the  from the bottom of the device screen upwards to reveal installed apps
	__6.  Click the HelloWorld icon.
	__7.  Check the LogCat view and make sure that onRestart() is called followed by onResume().
	__8.  Clear LogCat view.

	Part 5 -  Process Management
	__1.  Make sure that the Hello World application is running in the foreground of the emulator.
	__2.  On your Windows desktop, open a command prompt window. 
	         {Windows-Start}
	          Type in "cmd"
	          Choose "command prompt"
	__3.  Change directory as shown here:
	__4.  Enter the command:
	__5.  In the shell, enter the command:
	__6.  Look for the process called www.webage.com by entering the following command in the shell
	__7.  Now, in AVD, click the back button to destroy the activity.
	__8.  Back in the shell, run the command again.  
	__9.  Drag from the bottom of the device screen up to see the list of application icons.
	__10.  Click and hold on the HelloWorld app icon until you see the bubble appear with the words "App Info"
	__11.  Click on "App Info" this will open up the App Info screen
	__12.  Click on the "Uninstall" button and choose OK to confirm.
	__13.  Return to the command prompt and re-run the process command. The app is no longer listed as a process.
	__14.  Enter the command "exit" to quit the shell.
	__15.  Close the command prompt.
	__16.  In Android Studio, select 'File → Close Project' to close the HelloWorld project.

	Part 6 -  Review

	Lab 5 -  Using Simple Views
	Part 1 -  Create a New Project
	__1.  Make sure you are in the Android Studio Welcome dialog.  You can do this by opening Android Studio if needed and selecting 'File → Close Project' if needed.
	__2.  In the Android Studio welcome dialog select 'Start a new Android Studio project'.
	__3.  Select "Empty Activity" and then click on the Next button.
	__4.  Enter the following in the "Name" field:
	__5.  Set the "Minimum SDK":
	__6.  Leave the rest of the fields as-is and click on Finish:
	__7.  Wait for the project to be created.
	__8.  Find the MainActivity.java class in the project browser.
	__10.  Right click on MainActivity and choose Refactor -> Rename
	__11.  Type in "MainFeedback" into the Rename dialog and click the Refactor button.
	__13.  The class should now appear with the name MainFeedback.

	Part 2 -  Create the Views
	__1.  In the new project, open app/res/layout/activity_main.xml if it is not already
	__2.  Choose the Design icon from the top-right of the editor.
	__3.  Right click on "ConstraintLayout" in the Component Tree and select "Convert view..." from the drop down menu.
	__4.  In the dialog that appears select "RelativeLayout" and click Apply. You should now see "RelativeLayout" in the Component Tree.
	__5.  Click on the "eye" icon and make sure that "Show System UI" is selected.
	__7.  Toggle the 'magnet' icon so it appears like this (no line through it):
	__10.  Drop down the 'paper stack' icon and choose 'Design'
	__12.  Now lets drag the 'HelloWorld' TextView to leave a small margin between it and the top and left of the app.
	__13.  Make sure the TextView is selected and then examine the  Attributes pane to see the key properties of the widget.
	__14.  In the Attributes pane set the textAppearance to Large
	__15.  Each section in the Attributes area can be expanded by clicking on the triangle icon in its header. Try doing that now for the "All Attributes" area.
	__16.  Scroll through the list and check out some of the attributes that can be set.
	__17.  Try typing the word 'margin' into the search box at the top of the attributes area. This will filter out the attributes and you should see the "layout margin" values that we just set when we moved the TextView.
	__19.  Remove the word 'margin' from the search box. The list should go back to showing all items.
	__20.  Find the 'Text' property and change the value from 'Hello World' to 'Your name:' as shown below, then hit the <ENTER> key to accept the change.
	__21.  Verify that the text displayed has changed.
	__22.  In the palette, find the Text section.
	__23.  Drag a 'Plain Text' widget from the Pallette onto the Design view and drop it below the existing TextView. Use the design aids (light blue arrows) to align the control with the text above it.
	__24.  Set the 'id' property of the new control to 'FullName'
	__25.  Use the dropdown in the attributes view for layout_width to set it to the value  "match_parent". The field now takes up the width of the screen.
	__28.  Add a CheckBox below the FullName EditText element.  You can find CheckBox in the 'Buttons' section of the palette.
	__29.  Click the new element and edit these properties in the Attributes pane.
	__30.  Add a TextView element below the checkbox.
	__31.  Change the text to 'How did you hear about us?'.  
	__32.  Set the textAppearance to Large. The field should show in the design view like this.
	__33.  In the Buttons folder of the palette, find the RadioGroup element.
	__34.  Drag-and-drop a RadioGroup container onto the layout below "How did you hear about us?"
	__35.  Select the RadioGroup in the Component Tree.
	__36.  Change the 'id' property of the element to 'HearAboutGroup'.
	__37.  Next, change the layout_width and layout_height attributes of the RadioGroup to:
	__38.                layout_width: match_parent
	__39.                layout_height: 50dp
	__40.  Note: setting the height to 50dp is only temporary. Giving the component a fixed, non-zero height makes it easier to work with in design view.
	__41.  Drag a RadioButton from the Palette to the RadioGroup
	__42.  Change the 'Text' property of the RadioButton to 'Newspaper Ad' and the 'id' property of the element to 'NewspaperAd'.
	__43.  Change the textAppearance of the RadioButton to Large. It should look like this in the design view.
	__44.  Select the HearAboutGroup in the Component Tree.
	__45.  Set the layout_height to wrap_content. (Remember we set the layout_height initially to 50dp to make it easier to work with the RadioGroup)
	__46.  Add a second RadioButton under the first with an 'id' of 'Internet' and 'Text' of 'From Internet'. Set the RadioButton textAppearance to Large.
	__47.  Add a third RadioButton under the second with an 'id' of 'Friends' and 'Text' of 'From friends'. Set the RadioButton textAppearance to Large.
	__48.  Notice the Component Tree view will update with the ID and text of the radio buttons making it easy to check these key properties.  Also check the id of the radio group they are in.
	__49.  Add two Button views at the very bottom with these properties.  Make sure to add them below the radio group.  For now put them one under the other.
	__50.  Check in the Component Tree view that the buttons are not child elements of the radio group.
	__51.  Save changes once your buttons appear as shown.

	Part 3 -  Test
	__1.  Start your 'my_avd” device from the AVD Manager if it is not already running.  Wait for it to start completely.
	__2.  Unlock the AVD if needed.
	__3.  From the Android Studio menus select 'Run → Run 'app''.  
	__4.  Use the running device and select the option to use the same device in the future when prompted.
	__5.  Verify the layout.
	__6.  Click the 'Home' button (circle) to close the app.

	Part 4 -  Obtain View Objects
	__1.  Add these member variables to the activity class (MainFeedback.java).
	__2.  Import the correct Android classes in the Java import statements if they do not automatically update.
	__3.  In the onCreate method append these lines to obtain the view object references.
	__4.  Save changes.

	Part 5 -  Add Button Event Handler
	__1.  At the end of onCreate method add these lines.  Make sure to place this code within the curly bracket that ends the method.
	__2.  Manually add the following import statement to the class that is not done automatically.
	__3.  Note the following items about the code.
	__4.  Save changes.
	__5.  Add another event handler for the "No Thank You!" button at the end of onCreate method.  Make sure to place this code within the curly bracket that ends the method.
	__6.  Save changes.

	Part 6 -  Test
	__1.  Run the application.
	__2.  Enter some text for the name and select a radio button.
	__3.  Click Submit.  Once you submit the screen will disappear since the code indicated the activity was finished.
	__4.  Make sure that the LogCat view shows the log output. (use the term "/Feedback" in the logcat filter box to isolate the lines of interest)

	Part 7 -  Review

	Lab 6 -  Layout Management
	Part 1 -  Add ScrollView
	__1.  Open the SimpleViewTest project.
	__2.  Open app/res/layout/activity_main.xml layout.
	__3.  Switch to the design view of the file by clicking the 'Design' icon at the top-right of the editor.
	__4.  Right click on the root layout, RelativeLayout, in the ComponentTree and choose 'Convert View'
	__5.  From the Convert View dialog select LinearLayout and click the Apply button.
	__6.  Click on LinearLayout in the ComponentTree
	__7.  Find the 'orientation' attribute for the LinearLayout in the Attribute view (under Common Attributes) and use the drop down to set it to vertical.
	__8.  Now switch to the Code view of the file by clicking the 'Code' icon at the top-right of the editor. We are now going to wrap the LinearLayout with a ScrollView. 
	__9.  In the Code view, Above the current 'LinearLayout' root element, add a new 'ScrollView' element as the new root of the document as shown below.  Android Studio may automatically add an end tag to the element which we will deal with in a second.  You will have errors until the next few steps.
	__10.  Delete the ending tag to the 'ScrollView' element if  Android Studio automatically added.
	__11.  Go to the very bottom of the page and add the ending tag back in after the end to the current LinearLayout as shown below.
	__12.  Switch back to the Design view of the editor and select the root 'LinearLayout' element by clicking on it.  Also check that the hierarchy of the elements matches what is shown below.
	__13.  Now take a look at the layout of items on the screen. You may notice that the fields are spaced apart quite a bit vertically. If so you can fix this by deleting the values of the layout_margin_? attributes. You will need to make these changes for all the fields inside the LinearLayout in the Component tree.  
	Once you've removed the layout_margin_top values your layout should look like this:
	__14.  While we're at it why don't we add a margin_left value for the LinearLayout itself. To do that first select the LinearLayot in the ComponentTree. 
	__15.  Next, find the layout_margin_left attribute in the Attribute view and set its value to 15dp
	 
	__16.  The fields should now be all indented from the left of the screen.
	__17.  Hit Ctrl-S to save your changes so far.  

	Part 2 -  Add More Form Elements
	__1.  Drag a TextView onto the display just above the Submit button. Make sure it is not in the RadioGroup.
	__2.  Set the text to 'Rate this application:'
	__3.  Set the textAppearance to Material.Large.
	__4.  Drag a RatingBar onto the display just above the Submit button. 
	__5.  Set the id to UserRating
	__6.  Set the layout_width to wrap_content
	__7.  Drag a TextView onto the display just above the Submit button.
	__8.  Set the text to 'Comments:'
	__9.  Set the textAppearance to Material.Large.
	__10.  Drag a Multiline Text onto the display just above the Submit button.
	__11.  Set the id to Comments
	__12.  Set the textAppearance to Material.Large.
	__13.  Switch the Attributes pane to the All Attributes view.
	__14.  Use the Search field to search for the lines property.
	__15.  Set lines to '5'
	__16.  Examine the new layout.
	__17.  Notice that there are a few minor layout issues. The Name and Comment fields look like they are too wide, they bleed into the right edge of the screen. Also the Rate this application text box could use a little more separation from the radio buttons.
	__18.  Select the Name and expand Layout_Margin in the All Attributes view.
	__19.  Set the right attribute to 10dp and the top to 13dp.
	__20.  Set the Layout_Margin → right attribute of the Comments Multiline Text to 10dp
	__21.  Set the Layout_Margin → top attribute of Rate this application: to 15dp
	__22.  Examine the layout, the spacing issues should be fixed.
	__23.  Save changes.

	Part 3 -  Test for Scrolling
	__1.  Start your 'my_avd” device from the AVD Manager if it is not already running.  Wait for it to start completely.
	__2.  Unlock the AVD if needed.
	__3.  From the Android Studio menus select 'Run → Run 'app''.  
	__4.  Use the running device.
	__5.  Make sure that you can view the RatingBar and multi-line text box. 
	__6.  To scroll, click on any area of the screen and drag the mouse up while you hold the mouse button down.

	Part 4 -  Stack Buttons Side By Side
	__1.  Back in Android Studio, go to the Component Tree view in the 'Design' tab of the editor and scroll to the bottom so you can see both buttons and the comments element immediately before.
	__2.  In the Palette view of the Design tab, select 'Layouts'
	__3.  Drag a 'Linear Layout (Horizontal)' element to the display above the Submit button.
	__4.  Check the Component Tree and make sure that the new LinearLayout is placed in the correct location.
	__5.  In the ComponentTree, Click and drag the 'Submit' button and drop it on the 'LinearLayout' you just added.  It should show as a child element of the 'LinearLayout'.
	__6.  Do the same thing with the 'NoThanks' button so both buttons are child elements contained by the 'LinearLayout' element.
	__7.  In the layout graphical editor view the buttons should look like this:
	__8.  Select both buttons in the Component Tree view (by holding the Ctrl key as you click each one).
	__9.  Right click on the selection and choose LinearLayout → Distribute Weights Evenly. 
	__10.  Verify that the buttons look like this:
	__11.  Save changes.
	__12.  Test the application again to check the layout of the buttons.

	Part 5 -  Complete the Code
	__1.  Open the MainFeedback.java file.  
	__2.  In the MainFeedback class, add the following two member variables in bold.
	__3.  In the onCreate method, add the following bold lines to initialize the new fields:
	__4.  Within the code of the 'onClick' implementation of the listener for the Submit button, alter the code which logs the values to include the following two new bold lines.
	__5.  Save changes and make sure there are no errors in the project.
	__6.  Test the application, making sure to select a number of stars for the rating and fill in some comments before submitting.  You may need to scroll up to submit the data.
	__7.  Check the messages in the LogCat view to check the messages about the values that were filled in are present.
	__8.  Back in Android Studio, close all open files.  You can leave the AVD device running.

	Part 6 -  Review

	Lab 7 -  Resource Management
	Part 1 -  Enter String Resources
	__1.  Open the SimpleViewTest project in Android Studio if it is not already.
	__2.  Double click on app/res/values/strings.xml and it will open in an XML editor.
	__3.  Click on 'Open Editor' to open the Translations Editor view.
	__5.  Click the '+' sign at the top left of the editor to enter a new string item. This will open the 'Add Key' dialog.
	__7.  Enter the new string resource as follows.
	__8.  Once your entry matches that shown above click the OK button.
	__9.  Similarly, add another new key as follows.
	__10.  Check that your list appears as shown below.
	__11.  Save changes.
	__12.  Close the Translations editor.
	__13.  Open the app/res/values/strings.xml file in the regular editor by double-clicking it.
	__14.  Check that the following elements appear in the file.
	__15.  Leave the file open.

	Part 2 -  Use String Resources
	__1.  Open app/res/layout/activity_main.xml.
	__2.  Select the Design icon at the top-right of the editor.
	__3.  Click the TextView - "Your name:" in the ComponentTree.
	__4.  Click the 'Pick a Resource' button next to the 'text' property. The button is tall and narrow and shows the text 'Pick a Resource' when you hover over it.
	__5.  Select the name_label string resource and click the OK button.
	__7.  Check that the text is updated in the graphical preview.
	__8.  Similarly, set the text of the "Send me e-mail promotions" check box to email_promo string resource.
	__9.  Save changes.
	__10.  Look at the XML source of the layout file. Note how the resource is used by its ID.

	Part 3 -  Test
	__1.  Test the application on the 'my_avd' device. Make sure that the extracted text labels are working fine.

	Part 4 -  Extract More Strings
	__1.  Add the following new lines in bold in the XML of the strings.xml file.  Then use each new string from the appropriate place in the activity_main.xml layout.  The last two are for the buttons.
	__2.  After replacing string.xml and activity_main.xml then test the application to make sure you don't have errors.

	Part 5 -  Access Resource from Code
	__1.  In strings.xml file, add a string resource as follows.
	__2.  Save changes.
	__3.  In the MainFeedback class, add the following bold lines of code:
	__4.  Save changes.
	__5.  Run the application.
	__6.  Enter some values.
	__7.  Submit the form.  Remember you may need to click and drag the form up to see the buttons.
	__8.  Look at the log output in the LogCat view.
	__9.  Back in Android Studio, close all open files.  You can leave the AVD device running.

	Part 6 -  Review

	Lab 8 -  Localization
	Part 1 -  Create the Spanish Resource File
	__1.  Open the SimpleViewTest project in Android Studio if it is not already.
	__2.  Right click on app/res/values/strings.xml and select 'Open Translations Editor' (at the bottom of the right click menu).
	__3.  Click the 'Add Locale' button at the top left of the editor.
	__4.  When the list of languages comes up, type 'span' to search for the 'Spanish' entry and then choose it from the list.
	__5.  You should see a new column added for the Spanish values of the strings.  Many of the strings will be red as they currently have no translation.
	__6.  Enter the following values in the Spanish column for the matching key.  You need to double click in the Spanish column to type in a value directly.  If you do not have a key simply skip it.
	__7.  Once all of the entries have an alternate value, click one of the other rows in the list and make sure all entries are no longer red.
	__8.  Save changes.

	Part 2 -  Test
	__1.  Test the application and make sure that the app is still working in English.
	__2.  Click the Home button (circle).
	__3.  Click and drag from the bottom of the screen upwards to reveal the installed apps screen.
	__4.  Click the Settings icon.  
	__5.  Scroll down and select System.
	__6.  Select Language & input. 
	__7.  Click Languages.
	__8.  Click Add a language.
	__9.  Click Español and pick Argentina.
	__10.  You should see English and Español listed. Click the menu icon in the upper right. 
	__11.  Select Remove from the menu.
	__12.  Select the checkbox for English and click the 'trash can' icon.
	__13.  Agree to remove the language.
	__14.  Click the Home button.
	__15.  Open up the installed apps screen (drag from bottom of screen upwards).
	__16.  Click SimpleView Test.  
	__17.  Verify that Spanish text is being displayed. If not all fields are shown in Spanish then close the emulator and run the application again after checking your translation.
	__18.  Fill in some data and submit the form ('Enviar' button) and make sure that the LogCat view shows the Spanish output.
	__19.  Close the Translation Editor showing the strings.xml file.

	Part 3 -  Localize Image
	__1.  Open a file explorer and navigate to C:\LabFiles\drawable\
	__2.  Copy flag.png 
	__3.  Back in Android right click on app/res/drawable and click paste.
	__4.  A window will pop up, click OK.
	__5.  Check that the file is listed in the folder.
	__6.  Right click on the 'res' folder and select 'New → Directory'.  Make sure NOT to do this on the 'drawable” folder directly.
	__7.  Use a directory name of 'drawable-es' and click the OK button.  Even after it is created you will NOT see this directory in the Android view of the project structure.
	__8.  Following the same steps as above copy/paste C:\LabFiles\drawable-es\flag.png into the app/res/drawable folder of the project.  This time when prompted, select the second folder from the directory drop-down which should be the 'drawable-es' directory as shown below. Click OK.
	__9.  Click the OK button once you have checked that the file will be copied into the 'drawable-es' directory.
	__10.  In the upper left of the project view window, use the drop-down to select the 'Project' view of the files in the project.
	__11.  Expand the 'drawable' and 'drawable-es' folders in the 'SimpleViewTest/app/src/main/res' folder and check they both exist in the correct location and have a 'flag.png' file.
	__12.  In the upper left of the project view window, use the drop-down to select the 'Android' view of the files in the project.
	__13.  Check that the Android view of the project in the upper left is updated to show both files as being grouped together under what appears to be a 'flag' sub-folder.

	Part 4 -  Add an ImageView to the Form
	__1.  Open app/res/layout/activity_main.xml.
	__2.  Switch to the Code view using the 'Code' icon at the upper-right of the editor.
	__3.  Above the first TextView element, right after the starting tag for the 'LinearLayout', add the ImageView as shown below.
	__4.  Save changes.
	__5.  Switch to the graphical design view to preview the form.  You may need to zoom in.
	__6.  Click in the drop-down at the top of the graphical editor (to the right of the AppTheme  dropdown) as shown below, and switch between languages.
	__7.  Check that the image changes with the new language.

	Part 5 -  Test
	__1.  Run the application in the 'my_avd' device, starting it if it is not running.
	__2.  You can double check the functionality if you want but that should not have changed.

	Part 6 -  Test for Unsupported Locale
	__1.  Switch the language to Français (Canada) following these screens: Installed App Page > Click on icon = Ajustes >  Choose Sistema > Idiomas e Introducción de texto  > Idiomas > + Añadir un idioma >  Français > Canada.
	__2.  Then move  Français (Canada) on top of the list.
	__3.  Access the app again.
	__4.  The screen should look same as when English locale is selected.
	__5.  Set the language back to  English (United States). Installed Apps Screen > Parametres > Systeme > Langues et modes d'entée > Langues > + Ajouter une langue > English (United States).
	__6.  Rearrange as follows:
	__7.  Open the App and make sure the language has changed to English.
	__8.  In Android Studio, select 'File → Close Project' to close the SimpleViewTest project.

	Part 7 -  Review

	Lab 9 -  Using Intent to Launch Activities
	Part 1 -  Open Project
	__1.  Start Android Studio.
	__2.  On the Welcome Dialog choose  Open an existing Android Studio project.
	__3.  Open 'C:\LabFiles\Intents\SimpleProvider'.
	__4.  Check that you are in the 'Android' view of the project and switch to this view if you are not.

	Part 2 -  Create TermsCondition Activity
	__1.  In the app module of the SimpleProvider project, expand app → java → com.webage.www.simpleprovider.
	__2.  Right click  com.webage.www.simpleprovider package and select New → Java Class.
	__3.  Enter TermsCondition as the class name, leave the default 'Kind' to create a Class and then click the OK button.
	__4.  Once the source of the new class appears, add the declaration that the class extends the 'Activity' class, making sure that the editor automatically inserts the import of the matching 'android.app.Activity' class.
	__5.  Write the onCreate method as follows.  Make sure to put this inside the brackets of the class declaration.
	__6.  Check that the editor automatically inserted an import for 'android.os.Bundle' and that there are no compilation problems listed.
	__7.  Save changes to the Java class.
	__8.  Open app/res/layout/terms.xml. Have a quick look at the layout. If what you see is missing the app name "SimpleProvider" try clicking on the "eye" icon in the icon bar and choose "Show System UI".

	Part 3 -  Register the Activity
	__1.  Open AndroidManifest.xml under the app/manifests folder.
	__2.  Add the following XML source after the current activity but before the end of the 'application' tag as shown in bold below.
	__3.  Make sure you have no errors.
	__4.  Save changes.
	__5.  Close all files.

	Part 4 -  Launch the Activity
	__1.  Open MainActivity.java from the app → java → com.webage.www.simpleprovider folder.
	__2.  An onClick() method of an 'OnClickListener' is already created for you. When the Launch button is clicked, this method will be called. Enter the following code within onClick().
	__3.  Make sure that the editor has automatically added the correct Android imports and you have no errors in the code.
	__4.  Save changes.

	Part 5 -  Test
	__1.  Test the application on the 'my_avd' device (Run → 'Run app').
	__2.  In the AVD, click the Launch Activity button.
	__3.  At this point, the buttons in the Terms activity don't do anything. Click the back  button.

	Part 6 -  Send Data to Launched Activity
	__1.  In the MainActivity class, set the text for terms and condition as shown in bold below.
	__2.  Save changes.
	__3.  Open the TermsCondition class.
	__4.  In the onCreate() method of  TermsCondition, add these lines.
	__5.  Make sure that the editor has automatically added the correct Android imports and you have no errors in the code.
	__6.  Save changes.

	Part 7 -  Test
	__1.  Run the application again.
	__2.  Click Launch Activity and check the text appears.

	Part 8 -  Return Data from Launched Activity
	__1.  Return to the editor for the TermsCondition class.
	__2.  In the onCreate() method, add these lines.
	__3.  Next, attach an event handler for the Don't Accept button.
	__4.  Check that you have no errors from unknown classes.  The  android.view.View.OnClickListener interface may not be automatically imported.  Add it manually if needed.
	__5.  Save changes.
	__6.  Open the MainActivity class.
	__7.  Change the line:
	__8.  Add this method.  Make sure to add it outside of the 'onCreate' method but within the brackets for the class.
	__9.  Make sure that the editor has automatically added the correct Android imports and you have no errors in the code.
	__10.  Save changes.

	Part 9 -  Test
	__1.  Run the application again.
	__2.  Click the Launch Activity button back in the emulator.
	__3.  Click Accept.
	__4.  Verify that LogCat view shows the above message.
	__5.  Click the Launch Activity button in the emulator.
	__6.  This time click Don't Accept.
	__7.  Make sure that the log message reflects the result.
	__8.  Click the Launch Activity button in the emulator.
	__9.  Click the back button (triangle icon) to cancel the activity.
	__10.  You should see this message.
	__11.  Click the Home button in the AVD to close the application.

	Part 10 -  Launch Activity from a Different Application
	__1.  Leave the current project open in Android Studio.
	__2.  Select File → Open from the Android Studio menu
	__3.  Open 'C:\LabFiles\Intents\SimpleConsumer'
	__4.  In the Open Project dialog select New Window
	__5.  Click OK in the SDK message.
	__6.  Wait a minute while Android Studio opens the project and does a build.
	__7.  Check that you are in the 'Android' view of the project and switch to this view if you are not. Open a Windows File Explorer window to see the files on your system.
	__8.  Expand app → java → com.webage.www.simpleconsumer.
	__9.  Open MainActivity class.
	__10.  Copy the onCreate() and onActivityResult() from MainActivity of SimpleProvider project into the MainActivity of SimpleConsumer project replacing all of the content of the MainActivity class.  Make sure you do not end up with extra brackets or paste the code in the wrong location.
	__11.  If prompted to import classes, click the Cancel button.  The suggested import is incorrect for the current situation.
	__12.  Right after you paste the code in, you should have compilation errors for OnClickListener and TermsCondition. Both of these will show in red in the code.   
	__13.  Fix the first issue by adding the following import statemnt:
	__14.  The second issue, with TermCondition, is different. The TermCondition class is not defined in SimpleConsumer project. If that's the case then how can we launch the activity? The solution is to specify the activity to be launched implicitly. We will rely upon category and action hint to tell Android what activity should be launched.
	__15.  Delete (or comment out) the line with the compile problem (seen below).
	__16.  Replace the line with the following:
	__17.  Ensure that there are no compile errors.
	__18.  Change the terms and condition text slightly to help us recognize it when it is passed to the activity.
	__19.  Save changes.
	__20.  Close all files.
	__21.  Go back to the Android Studio window of the SimpleProvider project.
	__22.  Open AndroidManifest.xml of SimpleProvider project.
	__23.  Add the following XML source shown in bold below to describe an intent filter for the TermsCondition activity.  Make sure the code you add is properly inside the start and end tags of the activity.
	__24.  Save and close the file.

	Part 11 -  Test
	__1.  Make sure you are in the Android Studio window for the SimpleProvider project.
	__2.  Run the app (Run → Run 'app').
	__3.  Wait for the application to launch in the AVD.
	__4.  Return to the Android Studio window for the SimpleConsumer project.
	__5.  Before testing we need to rebuild the project to pickup local settings. From the menu, select Build > Rebuild Project.
	__6.  Test the application on the 'my_avd' device (Run → 'Run app').
	__7.  Click Launch External Activity.
	__8.  Click Accept.
	__9.  Ensure that the LogCat view in the Android Studio window for the SimpleConsumer project shows the correct result.
	__10.  Similarly, test for Don't Accept button and the back button.
	__11.  Hit the Home key in the AVD to close all open applications.
	__12.  Close the AVD.
	__13.  In the Android Studio window for each project select 'File → Close Project'.

	Part 12 -  Review

	Lab 10 -  Using Fragments
	Part 1 -  Import Projects
	__1.  Close all projects in Android Studio.
	__2.  In the Android Studio welcome dialog select 'Open an Existing Android Studio Project'.
	__3.  Give the path 'C:\LabFiles\FragmentApp' and click OK button.
	__4.  Wait a minute while Android Studio opens the project and does a build.
	__5.  Check that you are in the 'Android' view of the project and switch to this view if you are not.

	Part 2 -  Examine Current Code
	__1.  Open the following file in the FragmentApp project:
	__2.  You may get a message "Gradle project sync failed." Make sure to click "Try Again" when this appears. 
	__3.  Notice the following things about the code in this file:
	__4.  Close the 'Content.java' file, making sure you did not make any changes.
	__5.  Open the following file in the FragmentApp project:
	__6.  Select the Code icon at the top-right of the editor to see the XML layout Code.
	__7.  Notice this layout only has a single element which is the <fragment> tag.  In particular notice the 'id' of 'person_list' and the link to the code in the 'PersonListFragment' class that will be seen later.  This layout is used on smaller devices that will only display the list and will show the details of an item clicked on a second page.
	__8.  Close the 'activity_person_list.xml' file, making sure you did not make any changes.
	__9.  Open the following file in the FragmentApp project:
	__10.  Select the Code icon at the top-right of the editor to see the XML layout code.
	__11.  Notice that this layout has two main elements, the same <fragment> tag that was in the "list only" layout but also a <FrameLayout> with the id 'person_detail_container'.  This is a placeholder that starts out empty but can be set to display the details of a person clicked on the list on the left side of the layout.
	__12.  Close the 'activity_person_twopane.xml' file, making sure you did not make any changes.
	__13.  Open the following file in the FragmentApp project:
	__14.  Select the Code icon at the top-right of the editor to see the XML layout code.
	__15.  Notice this shows the same 'person_detail_container' element but as the only element in the layout.  This will be used by smaller devices that show the details on a separate page.
	__16.  Close the 'activity_person_detail.xml' file, making sure you did not make any changes.
	__17.  Open the following file in the FragmentApp project:
	__18.  Select the Code icon at the top-right of the editor to see the XML layout code.
	__19.  Notice there is a lot more code here but the main elements are the <TextView> elements that have labels and values for the name, email, and phone for the details of a Person that will be displayed.
	__20.  Close the 'fragment_person_detail.xml' file, making sure you did not make any changes. 
	__21.  Close any files you still have open.

	Part 3 -  Work With PersonListFragment Class
	__1.  Open the following file in the FragmentApp project:
	__2.  Add the following import.
	__3.  Examine the class declaration.  This class extends the ListFragment class that provides support for binding the fragment to a list of data and provides event handlers for when an item from the list is selected.  This is actually a class from the "support" library although the standard ListFragment class in the Android API is similar.
	__4.  Examine the following lines of code in the class.  This defines an inner 'Callbacks' interface and a reference to an instance of this interface from within the PersonListFragment class.  Since this class is used for the fragment with the list of people, this interface will help the list communicate with the activity if needed to inform the activity that an item in the list was selected.  
	__5.  Examine the following methods in the PersonListFragment class and notice their function:
	__6.  Find the code for the 'onListItemClick' method in the PersonListFragment class.
	__7.  Under the "ADD CODE" comment, add a new line that will call the 'onItemSelected' method of the current Callbacks implementation linked to the fragment.
	__8.  Save the file and make sure there are no errors.
	__9.  Close the 'PersonListFragment.java'.

	Part 4 -  Work With PersonListActivity Class
	__1.  Open the following file in the FragmentApp project:
	__2.  Examine the class declaration.  This class extends the FragmentActivity class and implements the PersonListFragment.Callbacks interface.  The FragmentActivity class is part of the "support" library and only needs to be extended when your activity is using the support library to add support for fragments with older Android versions.  If you were using the "regular" Android API classes for fragments you would extend the regular Activity class since it has support for fragments.  The 'Callbacks' implementation allows the list fragment to notify the activity when an item in the list is clicked.
	__3.  Find the 'onCreate' method of the PersonListActivity class.  
	__4.  Notice that this method sets the content for the activity to the 'activity_person_list' layout.  This is the layout that has an alias so the layout appropriate for the device (two pane or single) is selected.  Notice that it also looks for the 'person_detail_container' and sets a boolean value for being in "two pane" mode.  This is because this will only be found in the layouts that are showing the list and the detail at the same time.
	__5.  Under the "ADD CODE" comment, add a new line in bold below and make sure it is within the brackets for the 'if' block that only applies to the two pane layout.  This code will find the fragment for the 'person_list' layout element and indicate that the item in the list that is clicked should show up as "activated".  This will change how the item appears since the list will continue to display while the details are shown next to it.  This doesn't matter in the other mode since the list will be hidden by showing the details.
	__6.  Find the 'onItemSelected' method of the PersonListActivity class.  This is the method that implements the PersonListFragment.Callbacks interface and will be called by the list fragment when an item is clicked.
	__7.  Under the first "ADD CODE" comment, add the new lines in bold below and make sure it is within the brackets for the 'if' block that only applies to the two pane layout.  This will create an instance of the 'PersonDetailFragment' class, pass the arguments for which item is selected, and replace the content of the 'person_detail_container' with the fragment.
	__8.  Under the second "ADD CODE" comment, add the new lines in bold below and make sure it is within the brackets for the 'else' block that only applies to the one pane layout.
	__9.  Save the file and make sure there are no errors.
	__10.  Close the 'PersonListActivity.java'.

	Part 5 -  Work With PersonDetailActivity Class
	__1.  Open the following file in the FragmentApp project:
	__2.  Examine the class declaration.  Notice this class also extends the AppCompatActivity class but does not need to implement the PersonListFragment.Callbacks interface since it will not interact with the list of data.
	__3.  Find the 'onCreate' method of the PersonDetailActivity class.  
	__4.  Under the "ADD CODE" comment, add the new lines in bold below and make sure it is within the brackets for the 'if' block.  This will create an instance of the 'PersonDetailFragment' class, pass the arguments for which item is selected, and replace the content of the 'person_detail_container' with the fragment.  Notice how this is the same basic code as when the two pane layout directly creates the PersonDetailFragment within the PersonListActivity class.
	__5.  Save the file and make sure there are no errors.  There may still be some warnings.
	__6.  Close the 'PersonDetailActivity.java'.

	Part 6 -  Finish PersonDetailFragment Class
	__1.  Open the following file in the FragmentApp project:
	__2.  Find the 'onCreate' method of the PersonDetailFragment class.  
	__3.  Notice this method will store a reference to the Person object to display the details for in the 'mItem' field.
	__4.  Find the 'onCreateView' method of the PersonDetailFragment class.
	__5.  Notice that the first line of code "inflates" the 'fragment_person_detail' layout.  This is important since none of the layout files loaded by the other classes directly reference the layout for the person detail fragment.  This code indicates that layout should be used for the view of this fragment.  It is this view that will be returned at the end of the method.
	__6.  Under the "ADD CODE" comment, add the new lines in bold below and make sure it is within the brackets for the 'if' block.  This will set the values displayed by the elements of the detail view to the properties of the Person object to be displayed.  This is done before the view is returned.
	__7.  Save the file and make sure there are no errors. 
	__8.  Close the 'PersonDetailFragment.java'.

	Part 7 -  Test the Phone Interaction
	__1.  Run the application by clicking run in the menu (Run → 'Run app').
	__2.  After a delay you should see a list of names appear.  This should be the only thing you see as the phone virtual device uses the "one pane" layout and only shows the person list fragment.
	__3.  Click on one of the names on the list and you should see a new page display the content as set by the person detail fragment.
	__4.  Click the Back button to return to the list.
	__5.  Click on another name and verify the correct details for that person are displayed.
	__6.  Completely close the 'my_avd' window so the virtual device is not running anymore.  You can do this by clicking the 'X' in the upper right of the virtual device window.

	Part 8 -  Test the Tablet Interaction (Optional)
	__1.  Make sure that the virtual device for the phone is not running in another window.
	__2.  In Android Studio, select Tools → AVD Manager.
	__3.  In Android Virtual Device Manager click 'Create Virtual Device' button.
	__4.  Select Tablet as Category. 
	__5.  Select 'Nexus 7 (7.0", 800 x 1280: tvdpi)' for the device then click Next button.  
	__6.  Click on x86 Images
	__7.  Select "Pie API Level 28 Android 9.0" and click Next.
	__8.  Set the 'AVD name' to "my_tablet"
	__9.  Click Show Advanced Settings button to show more options.
	__10.  Scroll down to the 'Memory Options' area and change the RAM to 750 MB.
	__11.  Change the VM heap to 32 and internal storage as 200.
	__12.  Check that your settings match those below and click Finish.
	__13.  It may take several seconds but eventually the new AVD should appear in the list.
	__14.  Select my_tablet.
	__15.  Double click on my_tablet to Start and Launch it.
	__16.  Return to Android Studio and close the 'Android Virtual Device Manager' window if still open.
	__17.  Run the application by clicking run in the menu(Run → 'Run app'). 
	__18.  Select my_tablet and click OK.
	__19.  After a delay you should see a list of names appear.  There should be some blank space left to the right of the list although nothing is displayed there currently.
	__20.  Click on one of the names on the list and you should see that the name is highlighted and the details appear on the right.
	__21.  Click on another name and verify the correct details for that person are displayed.
	__22.  Completely close the 'my_tablet' window so the virtual device is not running anymore.
	__23.  In Android Studio, select Tools → Android → AVD Manager.
	__24.  Select the 'my_tablet' AVD from the list, expand the triangle at the end and click Delete from the dropdown.
	__25.  Confirm that you want to delete the AVD by clicking the Yes button.
	__26.  If you want, you can select the 'my_avd' entry and start it in preparation for the next lab.
	__27.  Close the 'Android Virtual Device Manager' window.
	__28.  Close all open files in Android Studio.
	__29.  From the menu, select File → Close Project.

	Part 9 -  Review

	Lab 11 -  Implementing the Action Bar
	Part 1 -  Create a new project
	__1.  Close all projects in Android Studio.
	__2.  In the Android Studio welcome dialog select '+ Start a new Android Studio Project'.
	__3.  In the "Select a Project Template" dialog select the app type "Phone and Tablet" and select the application template "Basic Activity". 
	__4.  Click Next
	__5.  In the "Configure Your Project"dialog set Name = "Action Bar", Language = Java, API 28 for Minimum SDK. Your dialog should look like this:
	__6.  Click "Finish"
	__7.  Wait a minute while Android Studio creates the project and does a build.
	__8.  Check that you are in the 'Android' view of the project and switch to this view if you are not.

	Part 2 -  Examine Existing Application
	__1.  Open the following file in the ActionBar project:
	__2.  Notice the following things about the code in this file:
	__3.  Close the 'MainActivity.java' file, making sure you did not make any changes.
	__4.  Open the following file in the ActionBar project:
	__5.  Select the Code icon at top-right of the editor to see the XML layout code.
	__6.  Do not modify the code but notice that the layout uses the AppBarLayout and Toolbar items.
	__7.  Close the 'activity_main.xml' file, making sure you did not make any changes.
	__8.  Open the following file in the ActionBar project:
	__9.  Select the Code icon at top-right of the editor to see the XML menu code.
	__10.  Do not modify the code but notice that the menu has one Item.
	__11.  The Item element specifies orderInCategory is set to 100. Items are arranged Left to Right (or Top to Bottom) in ascending order.
	__12.  The showAsAction attribute value of never means that this item will always be displayed as overflow and never directly on the ActionBar.
	__13.  Close the 'menu_main.xml' file, making sure you did not make any changes.
	__14.  Run the application in the Emulator and you should see the ActionBar and the ActionOverflow icon.
	__15.  Click on the ActionOverflow icon and you should see the Settings item.

	Part 3 -  Add Items to the Menu 
	__1.  Open the following file in the ActionBar project:
	__2.  Select the Code icon at top-right of the editor to see the XML menu code.
	__3.  To accommodate the new menu items change the android:orderInCategory value to 400.
	__4.  Insert these two menu items before the existing item. Note that these menu items use the android:icon combined with app:showAsAction="always" so they will appear as icons in the ActionBar.
	__5.  Save and Run the application again and you should see the icons in the Action Bar.
	__6.  Add these two menu items to main_menu.xml after the other items. These two items will not be displayed directly in the Action Bar. These items will be ordered around the Settings item based on their android:orderInCategory values.
	__7.  Save and Run the application again, the Action Bar looks the same as before.
	__8.  Click on the Android Overflow Icon. You should see the Settings item along with the newly added About and Exit items. 

	Part 4 -  Implement Menu Handlers 
	__1.  Open MainActivity.java 
	__2.  In the onOptionsItemSelected method comment out or delete the following code:
	__3.  In the onOptionsItemSelected method add the following code before the return code. 
	__4.  The onOptionsItemSelected method is called when any menu item is clicked. Add a switch statement to determine which menu item has been clicked as shown below:
	__5.  Next add a case statements to handle the Add button. The return statement is necessary to prevent the base class onOptionsItemSelected method from being called since the click is being handled here.
	__6.  Save and Run the application and click on the Add icon. You should see the text: 
	             User clicked 'Add'
	__7.  Add case statements to handle the other Action items as shown below. Exit is a special case and will be handled separately.
	__8.  Save and Run the application again and try all the Action items. You should see the text change for all of them except Exit.
	__9.  Add the following case statement to handle the Exit item. The finish method causes the app to terminate.
	__10.  Save and Run the application again and click on the Exit item. The application should exit.
	__11.  In the Android Studio window for each project select 'File → Close Project'.

	Part 5 -  Review

	Lab 12 -  Showing Notification Messages
	Part 1 -  Show a Toast Message
	__1.  Open  ActionBar project.
	__2.  In the MainActivity class of ActionBar project, add a utility function that will display a toast message.  Make sure it is outside of the brackets for other methods but within the brackets for the class definition.
	__3.  Make sure to add the necessary imports.
	__4.  In the onOptionsItemSelected() method add a call to showToast in the case statement for R.id.action_add
	__5.  Run the application.
	__6.  After the application starts, click the 'Plus' icon in the Action Bar. You should see the Toast.

	Part 2 -  Display a Snackbar Message
	__1.  Open res/layout/activity_main.xml in the editor
	__2.  Add the line in bold as shown below
	Note: The layout needs an id because the Snackbar must be anchored to a view. Activities are not views but layouts are.
	__3.  In the onOptionsItemSelected() method of MainActivity find the case statement for R.id.action_reset
	__4.  Add the code in bold  as shown below. This will display a Snackbar message  when the user clicks the Reset action in the Action Bar. The Snackbar message will disappear after a short while similar to the Toast in the previous part.
	__5.  Run the application.
	__6.  After the application starts, click the 'Reset' icon in the Action Bar. You should see the Snackbar Message
	Next we will add an action to the Snackbar message. Since the Snackbar message is displayed when the user selects Reset, we will give the user the option to Undo
	Inside the MainActivity class we will create a new private inner class called UndoHandler. UndoHandler must implement View.OnClickListener to handle events from the SnackBar. In this example the action handler simply logs that the user has selected it. In a real application it would do something useful like undo the requested reset.
	__7.  Create the UndoHandler class by adding the following code inside the MainActivity∫class
	__8.  Add the Undo action and handler to the Snackbar by adding the code in bold
	__9.  Run the application.
	__10.  After the application starts, click the 'Reset' icon in the Action Bar. You should see the Snackbar Message but this time it will have the Undo action.
	__11.  Click Undo (you may have to click Reset again if the Snackbar message has disappeared.) 
	__12.  Look in the logcat window of Android Studio and you should see the Undo message

	Part 3 -  Post Status Bar Message
	__1.  Right click on the package com.webage.actionbar and select New → Activity → Empty Activity
	__2.  Add a new class to package com.webage.actionbar as shown below:
	          Activity Name: FooActivity,
	         Keep other defaults,
	__3.  Click Finish.
	__4.  Add the code in bold  as shown below to the onCreate method. 
	__6.  Choose the following import:
	__7.  Open app/manifests/AndroidManifest.xml 
	__8.  Update the following activity element inside the application element.
	__9.  Right click on the res/layout directory and open activity_foo.xml 
	__10.  In activity_foo.xml select the Code view.
	__11.  Copy the contents of activity_main.xml to activity_foo.xml
	__12.  In activity_foo.xml change the value of the android:id attribute of the CoordinatorLayout to:
	__13.  In activity_foo.xml change the value of the tools:context attribute of the CoordinatorLayout to:
	__14.  In activity_foo.xml replace this element:
	__15.  Open MainActivity.java 
	__16.  Add these manifest constants to the MainActivity class
	__17.  Add the following method to the MainActivity class
	__18.   Add a call to configureNotification() at the end of the onCreate method as shown in bold.
	__19.  Add the following method to the MainActivity class
	__20.  Add the following import:
	__21.  In onOptionsItemSelected() add a new case statement to handle the user clicking on the Foo action as shown in bold.
	__22.  Open /res/menu/menu_main.xml
	__23.  Select the Code tab at the top-right of the editor
	__24.  Add the following item. 
	__25.  Open FooActivity.java
	__26.  In order to close the Status Bar Message when the Foo activity is displayed, add the following code to the end of the onCreate method
	__27.  Run the application.
	__28.  Click the overflow icon and select Foo 
	__29.  You should see the Status Bar Message displayed. If you are running on a device instead of the emulator the device will vibrate and display a red light if supported!
	__30.  Eventually the message will disappear but it will still be represented in the status bar with an icon.
	__31.  If you drag the status bar downward you will see our message and possibly others.
	__32.  Swiping the message left-to-right will close it.
	__33.  You will be back to the ActionBar app. Click the overflow icon and select Foo
	__34.  Drag the status bar downward, you will see our message.
	__35.  This time click on the message, it will bring up the Foo activity and dismiss the message.
	__36.  In the Android Studio window for each project select 'File → Close Project'.

	Part 4 -  Review

	Lab 13 -  Custom ListView Adapter
	Part 1 -  Create a new project
	__1.  Close all projects in Android Studio.
	__2.  In the Android Studio welcome dialog select '+ Start a new Android Studio Project'.
	__3.  In the "Select a Project Template" dialog select the app type "Phone and Tablet" and select the application template "Empty Activity".
	__4.  Click Next
	__5.  In the "Configure Your Project"dialog set Name = "ListView", Package Name = "com.webage.mobile.list", Language = Java, API 28 for Minimum SDK. Your dialog should look like this:
	__8.  Click "Finish"
	__9.  Wait a minute while Android Studio creates the project and does a build.
	__10.  Next we will copy in an image that will be used later in the lab.
	__11.  And we will copy a layout file as well:

	Part 2 -  Create the Adapter Class
	__1.  In the com.webage.mobile.list package of the ListTest project, create a new class as follows.
	__2.  Right click the com.webage.mobile.list package and select New → JavaClass.
	__3.  Set the name as follows and click OK.
	__4.  Edit the class to add a superclass as shown here:
	__5.  Hover over the class signature, then choose "implement methods", the following dialog will appear:
	__7.  In the Select Methods to Implement Dialog, select all the methods and click OK.
	__8.  In FancyListAdapter.java, above the declaration of the 'FancyListAdapter' class add the following bold lines:
	__9.  Within the FancyListAdapter class, add these member variables from the bold code below.
	__11.  Save the file and make sure there are no errors but leave the file open.
	__12.  Create a constructor as follows.  Make sure it is within the brackets for the class declaration but outside of other methods:
	__13.  Add this method to FancyListAdapter class. It allows someone to add a new row.
	__14.  Modify the getCount() method as follows.
	__15.  Save changes.
	__16.  Open res/layout/fancy_list_item.xml.
	__17.  Switch to the XML Code view and note the IDs of various views:
	__18.  Close the layout XML file.
	__19.  Back in FancyListAdapter.java file, change the names of the input parameters of getView() method to something more meaningful.
	__20.  Replace the existing code with these lines in the method. They will create a view from the layout. We need to create a view only when there is no view being recycled.  You will have errors as you add code the next several steps.
	__21.  Add these lines next to obtain reference to the child views.
	__22.  Add these lines to show row data in the child views.
	__23.  Finally, return the view.
	__24.  Save changes.  There should be no errors.

	Part 3 -  Use the Custom Adapter
	__1.  Open res/layout/activity_main.xml.
	__2.  Make sure you are in the graphical layout view.
	__3.  Delete the "HelloWorld" Text View
	__4.  Then add a ListView as shown below.
	__6.  Set the id in the Attributes view to ProductList
	__8.  Save and close the file.
	__9.  Open MainActivity.java.
	__10.  In the 'onCreate' method add these lines to create and initialize the adapter:
	__11.  Finally, lookup the ListView and set its adapter.
	__12.  Save changes.  There should be no errors.

	Part 4 -  Test
	__1.  Now run the List Test application.
	__2.  Close all open files.
	__3.  Close the project.

	Part 5 -  Review

	Lab 14 -  Using a Spinner
	Part 1 -  Import Projects
	__1.  Open the C:\LabFiles\SpinnerTest project in Android Studio.
	__2.  Wait a minute while Android Studio opens the project and does a build.
	__3.  Open app\java\com.webage.android\MainActivity.java

	Part 2 -  Test Existing Application
	__1.  Run the SpinnerTest project (Run--> Run 'app') and select to use the same device.
	__2.  In the application notice there is a list of programming  languages.  You can try clicking them and the application may appear to highlight them but they do not stay selected and nothing else happens.
	__3.  Open res/layout/activity_main.xml.
	__4.  Switch to the Code view.
	__5.  Above the <ListView> element, add the following bold code for the spinner:
	__6.  Save and close the file.

	Part 3 -  Populate the Spinner
	__1.  Open MainActivity.java in the com.webage.android Java package.
	__2.  At the end of the onCreate method add the following bold code:
	__3.  Save changes.

	Part 4 -  Test
	__1.  Run the SpinnerTest project.
	__2.  Click on the spinner. The popup dialog will open.
	__3.  Click on a programming language. The popup will close and that language will be shown on the spinner.

	Part 5 -  Handling Selection Events
	__1.  Add the following bold code to the end of the method onCreate method in the MainActivity class:
	__2.  Save changes.
	__3.  Run the application again.
	__4.  In the LogCat view, notice that the selection change event will fire right away for the spinner. You will see the text "Position: 0"
	__5.  Select a different item in the spinner. Make sure that the position is shown correctly in the LogCat view.  Remember like an array the position starts at 0.

	Part 6 -  Handling ListView Clicking
	__1.  Add the following bold code to the end of the method onCreate method in the MainActivity class:
	__2.  Save changes.
	__3.  Run the application again.
	__4.  This time do not expand the spinner, from the list select a language. Now, when you click on a ListView items, you should see ListView log messages.

	Part 7 -  Working With Array Resource
	__1.  Open res/values/strings.xml.
	__2.  Add the bold elements below:
	__3.  Save and close the file.
	__4.  Open res/layout/activity_main.xml.
	__5.  Set the entries property for the Spinner as shown below.
	__6.  Save and close the file.
	__7.  Open MainActivity.java.
	__8.  Delete the line that hard codes the array. We won't need it any more.  You will have errors until the next steps.
	__9.  For the ListView, we will create an adapter from the array resource. So, delete the line.
	__10.  In its place, enter:
	__11.  For the Spinner, we have already setup the array resource in the layout file. We don't need to set the adapter any more. So, delete these lines.
	__12.  Check that after all of the code changes you are left with this code in the middle of the 'onCreate' method.  Some code that does not change is not shown.
	__13.  Save changes.
	__14.  Make sure that there are no compilation errors.
	__15.  Test the application.  Check the spinner values are still the same.
	__16.  Open res/layout/activity_main.xml.
	__17.  Specify the entries attribute for the ListView. Make sure deleting the existing /> in the third line. 
	__18.  Save and close the file.
	__19.  In MainActivity.java, delete these lines.
	__20.  Save changes.
	__21.  Test the application. It should behave the same as before.
	__22.  Close all open files.
	__23.  Close the project, if a dialog open asking to close the app just click Disconnect.

	Part 8 -  Review

	Lab 15 -  Using Loaders for Background Work
	Part 1 -  Import Project
	__1.  Following same steps as in previous Labs, open the C:\LabFiles\LoaderDemo project.
	__2.  Open res/layout/activity_main.xml from the LoaderDemo project.
	__3.  Click the Design icon at the upper-right of the layout editor.
	__4.  Click on the "eye" icon and select "Show System UI" to enable that mode
	__6.  Use Ctrl-Plus Sign to zoom in so you can see the graphical layout. It should look like this:
	__7.  Click the Code icon at the upper right of the layout editor so that you can see the XML layout code. We are not going to make any edits at this point. We just want to see where to find the listview element that we will be loading data into.
	__8.  Locate the ListView with ID as @+id/listview. This is where we will display the list of items.
	__9.  Close all open files.

	Part 2 -  Provide Loader Implementation
	__1.  Open MainActivity.java in the 'com.webage.loader' package of the LoaderDemo project.
	__2.  Find the code for the private, static class 'SampleLoader'.  This is declared inside the code of the MainActivity class.
	__3.  Modify the declaration of the class so it extends the AsyncTaskLoader<List<String>> class as shown in bold below.  You will have errors until the next steps.
	__4.  Add the following constructor to the class.  You will still have errors.
	__5.  In the body of the 'SampleLoader' class but outside of other declarations in the class, add the new public method shown in bold below.
	__6.  Add the following import.

	Part 3 -  Implement Loader Callbacks
	__1.  Find the declaration of the 'MainActivity' class and add the following bold code to indicate the class will implement the 'LoaderCallbacks<List<String>>' interface.  You will have errors through the next several steps.
	__2.  Add the following import:
	__3.  In the body of the 'MainActivity' class but outside of other declarations, add the following private constant.  This will be an ID of the Loader class we want to use.
	__4.  Add the following three methods that will implement the LoaderCallback interface.
	__5.  From the Code menu, select "optimize imports".
	__6.  Save the class and you should have no errors or warnings.

	Part 4 -  Use Loader from Activity
	__1.  Find the existing 'onCreate' method of the 'MainActivity' class and add the following bold line of code to the end of the method.
	__2.  Save and make sure you do not have any errors.
	__3.  Run the LoaderDemo project as an Android application.  You should see the list appear with some sample data after a slight delay.
	__4.  If you get an error regarding the APK path, click OK.
	__5.  From the menu, select Build > Clean Project and then Run the app again.
	__6.  Close all open files.

	Part 5 -  Review

	Lab 16 -  Network Programming
	Part 1 -  Import Project
	__1.  Following same steps as in previous Labs, open the C:\LabFiles\Restaurants project.
	__2.  Click OK to dismiss the 'Sync Android SDK' dialog message.
	__3.  Close the "tip of the day" window if it comes up.
	__4.  Close any files that might be open in the project.
	__5.  If it's not already open, click the 'Build' tab at the bottom of the screen to open up the console view.
	__6.  In the Build > Sync console you might see "ERROR: Failed to find Build Tools revision 26.0.2". Click on the error if you see it.
	__7.  To the right you will see, in blue, "Upgrade plugin to version 3.6.3 and sync project". Click on it then wait for the IDE to finish processing.
	__8.  Next you will see the error "CONFIGURE FAILED" in the console. Select Build > Clean Project from the Build menu. Wait until the IDE finishes. This should result in "BUILD SUCCESSFUL"
	__9.  Open app\java\com.webage.restaurants\MainActivity.java
	__10.  You may get a message "Gradle project sync failed." Make sure to click "Try Again" when it appears. This should clear the remaining errors.
	__11.  Open res/layout/activity_main.xml.
	__12.  Click the Design icon at the upper-right of the layout editor window.
	__13.  Click on the "eye" icon and select "Show System UI" to enable that mode
	__15.  Use Ctrl-Plus Sign to zoom in so you can see the graphical layout. It should look like this:
	__17.  Click the Code icon in the upper right of the layout window.
	__18.  Locate the ListView with ID  @+id/restaurant_list. Keep this in mind, we will used this listview later to display the restaurant names
	__19.  Close all open files.

	Part 2 -  Copy File to Web Server
	__1.  Examine C:\LabFiles\data\restaurants.json in a text editor
	__2.  Close the file.
	__3.  Open a file explorer and locate the document root of your web server (typical location for apache is 'C:\Apache2.2\htdocs').
	__4.  Copy C:\LabFiles\data\restaurants.json  and paste it inside the htdocs folder of Apache.
	__5.  Open a web browser (IE or FireFox preferred) and access the file at http://localhost/restaurants.json
	__6.  Open a command prompt.  You can do this by selecting 'Start → Run', typing 'cmd' and hitting <ENTER>.
	__7.  In the command prompt, enter the command 'ipconfig' without the quotes.  Make a note of the IP address here as you will need it later: ___________________________
	__8.  In the web browser showing the JSON file, replace 'localhost' with your IP address so the address is:
	__9.  Make sure that you get the same JSON file using your IP address as when you used 'localhost'.
	__10.  Close the browser.

	Part 3 -  Add Code to Download JSON
	__1.  Open MainActivity.java
	__2.  Before adding code we need to clean up a little bit the code, delete any commented lines //.
	__3.  Your class should look like this, make sure you don't have any errors:
	__4.  Add the following static variables. The URL should use the IP address you found when you ran ipconfig
	__5.  Add a private inner class inside the main class as shown below: (There will be errors!)
	__6.  Insert the following method into FetchRestaurants (There will be errors!)
	__7.  Insert the following code after // Create Connection. This code configures and makes the connection to the web server. Notice the HTTP GET method.
	__8.  Insert the following code after // Configure Stream. This code gets a BufferedReader from the connection.
	__9.  Insert this code after // Read Data. This code reads the data into a String object and returns it.
	__10.  Insert the following method into the FetchRestaurants class. It is called after the doInBackground method completes. It takes the results, in this case JSON, and populates the ListView.
	__11.  Note: This code first converts the result to a JSONObject the extracts the JSONArray of restaurants from it. Next it builds up an ArrayList of Restaurant names by iterating through the JSONArray. Finally it uses an Adaptor populate the list.
	__12.  Insert the following lines of code at the end of the onCreate method.
	__13.  From the menu, select Code > Optimize imports.

	Part 4 -  Add Permission to Manifest File
	__1.  Open AndroidManifest.xml file for the project.
	__2.  Add this line before the application tag to give permission to use internet.
	__3.  Add the following setting inside the <application ... > tag:
	__4.  Save and close the file.

	Part 5 -  Test
	__1.  Run the application.
	__2.  The app when it runs should look like this:
	__3.  Close the project.

	Part 6 -  Review

	Lab 17 -  Working With File Storage
	Part 1 -  Import the Project
	__1.  Close all the open projects.
	__2.  Following same steps as in previous Labs, open the  C:\LabFiles\SimpleFileAccess project.
	__3.  Wait for the project to finish loading. 
	__4.  Open res/layout/activity_main.xml.
	__5.  Click the Design icon at the upper-right of the layout editor window.
	__6.  Click on the "eye" icon and select "Show System UI" to enable that mode
	__7.  Use Ctrl-Plus Sign to zoom in so you can see the graphical layout. It should look like this:
	__8.  Close all files.

	Part 2 -  Clear SD Card
	__1.  If you currently have it running, exit the AVD by clicking the X in the tool bar.
	__2.  In the Android Studio, select Tools > AVD Manager.
	__3.  Select the AVD created earlier and click the DropDown menu button.
	__4.  Select Wipe Data from the menu.  
	__5.  Confirm Data wipe by clicking yes button
	__6.  Click on the green arrow to start the virtual device.
	__7.   Close the AVD Manager window.

	Part 3 -  Review the Project
	__1.  Open AndroidManifest.xml from the SimpleFileAccess project.
	__2.  Open the activity class MainActivity.java in the 'com.webage.file' package.

	Part 4 -  Enable File Access from Main Thread
	__1.  At the beginning of the onCreate() method, add the following bold code:
	__2.  Save changes in the MainActivity.java file.

	Part 5 -  Implement Save Feature
	__1.  Add a member variable to the activity class to hold the file name:
	__2.  Find the line:
	__3.  Below this comment add these lines to save the text entered by the user in the file.
	__4.  If not auto added add the import android.util.Log.
	__5.  Save changes.

	Part 6 -  Test
	__1.  Run SimpleFileAccess project (Run >  Run app) in my_avd emulator.
	__2.  Enter some data.
	__3.  Click the little triangle to hide the keyboard.
	__4.  Click Save.
	__5.  You should see the "File was saved" toast message.
	__6.  Open a Windows command prompt.
	__7.  Use the 'cd' command to change directories to the root folder of the ADT software.  This is probably something like 'C:\Users\<<USER>>\AppData\Local\Android\Sdk\platform-tools'
	__8.  Run the following command to open a shell login into the Android device as root.
	__9.  The above shell command should open a prompt:
	__10.  At the prompt, do a directory listing of the application's internal storage folder:
	__11.  View the contents of the file by entering the command:
	__12.  Leave the command shell running.

	Part 7 -  Load the File on Start Up
	__1.  In the MainActivity class, add a new method as follows.
	__2.  Optimize imports (on the Code menu) if there were no auto added.
	__3.  In the onCreate() method, add the following bold line to call the new method:
	__4.  Save changes.

	Part 8 -  Test
	__1.  Run the application. You may need to select again your emulator.
	__2.  In AVD, you may see your old message, enter some some text in the application and then click the Save button.
	__3.  Click the back button of the AVD to quit the application.
	__4.  From Android Studio, run the application again and immediately switch to the AVD. You will see the 'File was loaded successfully' message and it will disappear after a second.
	__5.  Make sure that the last saved data is shown in the EditText using the shell command from earlier (cat /data/d...).

	Part 9 -  Implement the Delete Feature
	__1.  Add a new method to the activity class to delete the file.
	__2.  In the onCreate() method, find the line:
	__3.  Below that line, add the code:
	__4.  Save changes.

	Part 10 -  Test
	__1.  Run the application again.  You should see the existing file is displayed.
	__2.  Click the Delete File button.
	__3.  Make sure that the success message is shown.
	__4.  Click Delete File again. This time the failure message will be shown (because the file does not exist).
	__5.  Back in the shell, run the command:
	__6.  Leave the command shell running.

	Part 11 -  Implement the Export Feature
	__1.  In the class, write a new method to copy the file to external storage.
	__2.  In the onCreate() method, find the line:
	__3.  Below that line, add the code:
	__4.  Save changes.
	__5.  Expand the SimpleFileAccess project and open the AndroidManifest.xml file by double clicking it. Now we need to give permissions to write on external storage.
	__6.  Add this line before the application tag to give permission to use external storage.
	__7.  Save the manifest file.

	Part 12 -  Test
	__1.  Make sure the AVD is running.
	__2.  Run the application. Unlock the emulator if needed.
	__3.  If you are not sure if you deleted the file, click Delete File again.
	__4.  Now, click Export. It will fail.
	__5.  Enter some text.
	__6.  Click Save to create the file in internal storage.
	__7.  Click Export. This time, it will succeed.
	__8.  Back in the command shell, enter the command below to list files in the application's external storage area.  You can launch the command shell in a Windows command prompt from the 'platform‑tools' folder using the 'adb shell' command if you had closed it.
	__9.  Exit the shell with this command:
	__10.  Close the command prompt window.
	__11.  In Android Studio , close all open files.

	Part 13 -  Review

	Lab 18 -  Content Provider and Consumer
	Part 1 -  Initialize Content Provider
	__1.  Close all the open projects.
	__2.  From Android Studio's welcome page select Open an Existing Android Studio Project.
	__3.  Give the path C:\LabFiles\SuperSoccerApp
	__4.  Click OK to import the SuperSoccerApp project.
	__5.  Open res/layout/activity_main.xml.
	__6.  Click the Design icon at the upper-right of the layout editor window.
	__7.  Click on the "eye" icon and select "Show System UI" to enable that mode
	__8.  Use Ctrl-Plus Sign to zoom in so you can see the graphical layout. It should look like this:
	__10.  Close all files.
	__11.  In the SuperSoccerApp project, find the 'com.webage.soccer' package and open the 'MatchDataProvider.java' file.
	__12.  Examine the existing code of the fields in the class and notice there is a two dimensional String array for initial data and an ArrayList to store the data in memory.  
	__13.  In the declaration of the class, add the code in bold below to extend the 'ContentProvider' class.  You will have errors until the next step.
	__14.  Optimize imports.  You will still have errors.
	__15.  Right click ContentProvider and select Generate → Implement Methods.
	__16.  In the dialog that appears, leave the default methods that are checked (which are the minimum that need to be implemented) and click the OK button.
	__18.  The onCreate method is called after the content provider has been created. We can load the initial data from there. Implement the method as follows.
	__19.  Save changes.  There should be no compilation errors.

	Part 2 -  Implement Content Query
	__1.  First, we will develop a utility method that will validate the URL and return the match ID if present. In the body of the class but outside of other declarations, add the following new private method:
	__2.  Save changes.
	__3.  Now, we are ready to develop the query() method. First, change the names of the input arguments to something more meaningful.
	__4.  Within the method, replace the code adding these lines to create a new cursor object above the return code.
	__5.  Add this line to get the match ID if present in the URL after the previous code.
	__6.  Add these lines that will populate the cursor based on the search criteria after the previous code.
	__7.  Finally modify the return statement to return the cursor.
	__8.  Save changes.  
	__9.  As a part of the query logic, we should also implement the getType method that associates a MIME type with a URI. Change the getType method as shown in bold below.  Note the name of the method parameter was changed also.
	__10.  Save changes.  Make sure you have no compilation errors.

	Part 3 -  Implement the Insert Method
	__1.  First, change the parameter names to something more meaningful in the insert method.
	__2.  Delete all code inside the method.  You will have errors for several steps.
	__3.  Now add this line to validate the URI.  This will throw an Exception if the URI is not of a valid format.
	__4.  Add these lines to add a new row to the in-memory database.
	__5.  Finally, return the URL of the newly added soccer match.
	__6.  Save changes.  Make sure you have no compilation errors.

	Part 4 -  Register the Provider
	__1.  Double click AndroidManifest.xml of the SuperSoccerApp to open it.
	__2.  Write the following bold code above the closing application tag.
	__3.  Save and close the file.

	Part 5 -  Deploy the Application
	__1.  Run the SupperSoccerApplication  
	__2.  We didn't really do anything with the main activity. So, the application will look simply as follows.

	Part 6 -  Develop a Content Consumer
	__1.  Now import the SimpleContentConsumer project ( File → Open ).
	__2.  Enter the path C:\LabFiles\SimpleContentConsumer and give OK.
	__3.  Click New Window.
	__4.   
	__5.  Open res/layout/activity_main.xml.
	__6.  Click the Design icon at the upper-right of the layout editor window.
	__7.  Click on the "eye" icon and select "Show System UI" to enable that mode
	__9.  Use Ctrl-Plus Sign to zoom in so you can see the graphical layout. It should look like this:
	__11.  While still in the SimpleContentConsumer project, go back to the  'MainActivity.java' file. Make sure you select the right project since there are projects with similar names.
	__12.  Find the following line and change AppCompatActivity to FragmentActivity:
	__13.  Within the body of the class, add a new field to refer to the URI of the content provider as shown in bold below.  You will have errors for several steps.
	__14.  Find the existing 'onCreate' method and add the following bold code to the end of the method to initialize a loader with the constant that is already defined for the loader ID.
	__15.  Modify the existing 'onCreateLoader' method so that it returns a new instance of the 'CursorLoader' class linked to the URI for the soccer match content provider.
	__16.  Find the existing 'onLoadFinished' method and add these lines to iterate through the cursor and display the result.
	__17.  If imports missing then import android.util.Log and androidx.loader.content.CursorLoader.
	__18.  Save changes.  Make sure you have no compilation errors.

	Part 7 -  Test
	__1.  Run SimpleContentConsumer project in my_avd emulator.
	__2.  We have not done anything with the GUI, so the display will look like this.
	__3.  Check the LogCat view for the log messages. They will show the query result.

	Part 8 -  Display Data in ListView
	__1.  Locate and open res/layout/soccer_match_display.xml in  SimpleContentConsumer project. This sets the layout for each row in ListView.
	__2.  Back in the MainActivity class of the SimpleContentConsumer project, add a new field to refer to the 'SimpleCursorAdapter' object.  You will have errors for several steps.
	__3.  In the existing 'onCreate' method, add the following bold lines that will bind the cursor to the ListView.
	__4.  Optimize imports.  Select the 'androidx.cursoradapter.widget.SimpleCursorAdapter ' class if prompted.;
	__5.  Remove all of the current code in the 'onLoadFinished' method and replace it with the single bold line shown below.  This will swap the data used by the SimpleCursorAdapter to be what the results returned.
	__6.  Add the following bold line to the 'onLoaderReset' method.  This will release the data currently held by the adapter when the loader is reset.
	__7.  Save changes.  Make sure you don't have any compilation errors.

	Part 9 -  Test
	__1.  Run SimpleContentConsumer project again.
	__2.  Verify that all matches are displayed.

	Part 10 -  Insert Data
	__1.  In the MainActivity class of the SimpleContentConsumer project add the following new private method.  Make sure it is declared in the body of the class but outside other method declarations.
	__2.  Modify the code of the existing 'onCreate' method to call the new method that will insert data.
	__3.  Optimize imports.  Select android.util.Log if prompted.
	__4.  Save changes.

	Part 11 -  Test
	__1.  Run SimpleContentConsumer project again.
	__2.  Verify that the newly added match data shows up.

	Part 12 -  Implement Update Feature
	__1.  In the SuperSoccerApp project, find the 'com.webage.soccer' package and open the 'MatchDataProvider.java' file.
	__2.  Find the current implementation of the 'update' method and replace it with the following bold code.  Note that the parameter names have been updated also.
	__3.  Save the file and make sure there are no compilation errors.
	__4.  Run the SuperSoccerApp project as an Android application just to update the version of code deployed to the emulator.
	__5.  Return to the MainActivity class of the SimpleContentConsumer project add the following new private method.  Make sure it is declared in the body of the class but outside other method declarations.
	__6.  Modify the code of the existing 'onCreate' method to call the new method that will update data.
	__7.  Save changes.
	__8.  Run the SimpleContentConsumer project again.  Check that you see the fourth match being inserted along with the updates to the 'Oldham vs. Walsall' match.
	__9.  In the Android Studio 'LogCat' view, select com.webage.content.consumer; you should see the URI of the new match that was inserted along with a message about the one match being updated.

	Part 13 -  Implement Delete Feature
	__1.  In the SuperSoccerApp project, return to the 'MatchDataProvider.java' file.
	__2.  Find the current implementation of the 'delete' method and replace it with the following bold code.  Note that the parameter names have been updated also.
	__3.  Save the file and make sure there are no compilation errors.
	__4.  Run the SuperSoccerApp project as an Android application just to update the version of code deployed to the emulator.  Remember this will reset the in-memory data.
	__5.  Return to the MainActivity class of the SimpleContentConsumer project add the following new private method.  Make sure it is declared in the body of the class but outside other method declarations.
	__6.  Modify the code of the existing 'onCreate' method to call the new method that will update data.
	__7.  Save changes.
	__8.  Run the SimpleContentConsumer project again.  Check that you see three total matches.  This is because one was inserted and one was deleted.  You should also see the updates to the one match.
	__9.  In the Android Studio 'LogCat' view you should see the URI of the new match that was inserted along with messages about the matches being updated and deleted.
	__10.  Close all open files in Android Studio.

	Part 14 -  Review

	Lab 19 -  Development Using SQLite Database
	Part 1 -  Import Projects
	__1.  Import the ShoppingList project by selecting Open an existing project from the welcome screen of Android studio and enter the path C:\LabFiles\ShoppingList and click OK.
	__2.  Wait for the project to be created and built.

	Part 2 -  Test Existing Implementation
	__1.  Run the shoppingList application.
	__2.  Initially you should see a sample list of items.  The current implementation can only display a single line for each item.
	__3.  Click on one of the items to bring up the edit screen for that item.
	__5.  If you look in the 'LogCat' view you should see a few messages printed from the application.  One tracks the position and ID of the item in the list that is clicked.  In this implementation notice that these will always be reported the same.  Also there is a message about loading data which will help tell when this happens.
	__7.  Modify the details of the item and click the Update button.  You will only be able to detect the change from the main list if you change the name of the item.
	__9.  Back on the main list, click on one of the items again and when the edit page is displayed click the Delete button.  You should see that the item is gone from the list.
	__10.  Repeat this process to delete all items from the list.  You should see a message that there are no more items.
	__11.  At the bottom of the application, click the Add menu item.
	__12.  Try to click the Add button with an empty product name and notice that a warning message is displayed and the screen does not change.
	__13.  Fill in some sample data and click the Add button again.  Notice the screen is generally the same except for the buttons.
	__14.  Check that the new item shows up in the list.
	__15.  Click the Back button from the list to close the application.

	Part 3 -  Modify SQLiteOpenHelper Class
	__1.  Back in Android Studio, open the 'ShoppingListTable.java' file in the 'com.webage.shopping.content' package of the ShoppingList project.
	__2.  Notice this file has several constants for the names of the columns along with what statement will be used to create the table.  There are several places in the code where you might need column names so this approach will help make sure they are consistent.  Also notice is just a POJO (Plain Old Java Object) and doesn't extend or implement anything.
	__3.  Add the following bold line to the 'onCreate' method.  This will execute the statement to create the table.
	__4.  Save the file and make sure there are no errors.
	__5.  Open the 'MyDBHelper.java' file in the 'com.webage.shopping.content' package of the ShoppingList project.  
	__6.  Notice a few key things about this class:
	__7.  Add the following bold line to the 'onCreate' method.  This method is called when database is created for the first time.  This will call the code of the class that has the details about the table.  
	__8.  Save the file and make sure there are no errors.
	__9.  Close all open files.

	Part 4 -  Modify Content Provider to Support Query
	__1.  Open the 'ShoppingListContentProvider.java' file in the 'com.webage.shopping.content' package of the ShoppingList project.  
	__2.  At the top of the class declaration, under the comment of 'field for database' add the following bold line of code.  This will store an instance of the "helper" class since this will be involved in the various database operations.
	__3.  Examine some of the other existing fields.  Notice these are basic things for a content provider, like a 'UriMatcher' and a few constants related to the URIs of the content provider.  These are provided for you as they don't impact how the content provider uses a database.
	__4.  Find the existing 'onCreate' method and add the following bold line of code to initialize the field for the database "helper" class.
	__5.  Find the existing 'query' method and add the bold code below to the method.  Make sure it is inside the body of the method and at the beginning as you will be adding other code to the method after this.  
	__6.  Below the code you just added but before the return statement, add the following bold code for a switch statement.  This uses the 'UriMatcher' to check what type of URI was used and build the appropriate query depending on the type.  This adds a 'WHERE' clause if the query was for an individual item.
	__7.  Below the code you just added but before the return statement, add the following bold code to perform the query and return the 'Cursor' with the results.  Make sure to change the 'return' statement so it returns the Cursor instead of 'null'.  You will have errors until the next step.
	__8.  Find the existing 'checkColumns' method and add the bold code below to the method.  Make sure it is inside the body of the method.  You will have errors until the next step.
	__9.  Save the file and make sure there are no compilation errors.

	Part 5 -  Modify Controller to Use Content Provider
	__1.  Open the 'ShoppingItemListFragment.java' file in the 'com.webage.shopping.memory' package of the ShoppingList project.  
	__2.  Notice that besides extending the Android 'ListFragment' class, the class also implements the 'LoaderCallbacks' interface which is used with content providers.
	__3.  At the top of the class declaration, under the comment of 'fields for Content Provider solution' add the following bold lines of code.  You will have errors until the next step.
	__4.  Add the following import:
	__5.  Find the existing 'fillData' method and delete (or comment out) the current code that sets the 'listAdapter' using an ArrayAdapter.  The code to remove is shown in bold strikethrough below.
	__6.  After the comment that mentions the 'Content Provider solution..' but still within the ending bracket for the method, add the following bold code.  You will have errors until the next steps.  This code indicates what view should be used by the list adapter and what columns should be mapped to what view elements.  This code also works with the 'LoaderManager' which will trigger some of the 'LoaderCallbacks' methods you will implement next.
	__7.  Find the existing 'onCreateLoader' method and add the following bold code.  Make sure to change the 'return' statement so it returns the CursorLoader instead of 'null'.  You will have errors until the next step.  This code uses the Android CursorLoader class to query the content provider at the URI that is supplied and with the given projection of database columns to obtain.
	__8.  Add the following import:
	__9.  Find the existing 'onLoadFinished' and 'onLoadReset' methods and add the bold code shown below to each.  Note that these lines use slightly different parameters so make sure the appropriate code is in the correct location.
	__10.  Save the file and make sure there are no compilation errors.

	Part 6 -  Test List Query
	__1.  Clear the LogCat view.
	__2.  Run the application.
	__3.  The screen shows the message about there being no items because we have no data in the database. But, check the LogCat view and make sure that the schema was created successfully.
	__4.  On your Windows desktop, open a command prompt window.
	__5.  Change directory to
	__6.  Enter the command:
	__7.  Change to the application's database folder.
	__8.  Run this command to make sure that the database file was created.
	__9.  The sqlite3 tool is used to open a SQL command prompt. Run the command as follows.
	__10.  Enter the following command to enter a row in the shoppinglist table.
	__11.  Enter another item:
	__12.  Enter this command to make sure records are added:
	__13.  Leave the 'sqlite3' session and command window open.
	__14.  Click the back button of the AVD to exit the application.
	__15.  Run the application again from Android Studio.  You should see the items you inserted manually show up in the list.

	Part 8 -  Implement Add Feature
	__1.  Open the 'ShoppingListContentProvider.java' file in the 'com.webage.shopping.content' package of the ShoppingList project if you had closed it.
	__2.  Find the existing 'insert' method and add the bold code below to the method.  Make sure it is inside the body of the method and at the beginning as you will be adding other code to the method after this.  
	__3.  After the code you just added but before the return statement of the method, add the following bold code.  This will insert the data if the correct URI is used or throw an error.
	__4.  To the end of the method, add the following bold code to trigger notification for any process listening to the source of data and return the URI of the new item added.  Make sure to modify the return statement as shown below.
	__5.  Save the file and make sure there are no compilation errors.
	__6.  Open the 'ShoppingItemListActivity.java' file in the 'com.webage.shopping' package of the ShoppingList project.
	__7.  Find the existing 'showItemDetail' method and change the method parameter as shown below.  The new solution will use the URI of the item that should be shown on the detail page.  You will have errors for the next several steps.
	__8.  In the 'if' statements in the first part of the method, make the following three changes shown in bold below.  Make sure to change the condition of the inner 'if' test, remove the code that stored the 'ARG_ITEM_ID' parameter and add the code for the content provider solution.
	__9.  In the 'else' block in the second part of the method, make the following three changes shown in bold below.  Make sure to change the condition of the inner 'if' test, remove the code that stored the 'ARG_ITEM_ID' parameter and add the code for the content provider solution.
	__10.  Find the existing 'onItemSelected' and 'onAddItem' methods.  Change the way they call the 'showItemDetail' method to pass in a 'null' value as shown in bold below.
	__11.  Save the file and make sure there are no compilation errors.
	__12.  Open the 'ShoppingItemDetailActivity.java' file in the 'com.webage.shopping' package of the ShoppingList project.
	__13.  In the existing 'onCreate' method remove the code for the memory solution and add the bold code below for the content provider solution.  This will copy the itemURI from the Activity "extras" into the Fragment "arguments".
	__14.  Save the file.
	__15.  Open the 'ShoppingItemDetailFragment.java' file in the 'com.webage.shopping' package of the ShoppingList project.
	__16.  At the top of the class declaration, under the comment of 'fields for Content Provider solution' add the following bold lines of code.  
	__17.  Find the existing 'saveData' method.  Delete the code for the memory solution as shown with bold strikethrough below.
	__18.  In the same method, below the 'Use Content Provider to load data' comment, add the following bold code.  If the screen is not linked to an existing item (as in the case of adding an item), the 'insert' method of the content provider will be called.  You will have errors until the next step.
	__19.  Save the file and make sure there are no compilation errors.
	__20.  Close all open files.

	Part 9 -  Test Add Feature
	__1.  Run the application again.  Check that you see the same items in the list as there were before.
	__2.  Click the Add menu item at the bottom of the list.
	__3.  Enter some sample data then click the Add button.
	__4.  Make sure that the list is displayed again and the newly added item shows up.

	Part 10 -  Implement Edit Feature
	__1.  Open the 'ShoppingListContentProvider.java' file in the 'com.webage.shopping.content' package of the ShoppingList project if you had closed it.
	__2.  Find the existing 'update' method and add the bold code below to the method.  Be careful when adding the code for the 'ITEM_ID' case as it is more complex.  
	__3.  Save the file and make sure there are no compilation errors.
	__4.  Open the 'ShoppingItemListActivity.java' file in the 'com.webage.shopping' package of the ShoppingList project.
	__5.  Find the existing 'onItemSelected' method.  Add the code in bold below to calculate an item URI and pass that to the call to the 'showItemDetail' method.
	__6.  Save the file and make sure there are no compilation errors.
	__7.  Open the 'ShoppingItemListFragment.java' file in the 'com.webage.shopping' package of the ShoppingList project.
	__8.  Find the existing code for the 'onListItemClick' method.  Make the changes for the code in bold below which will remove the code for the memory solution and add simpler code for the content provider solution.
	__9.  Save the file and make sure there are no compilation errors.
	__10.  Open the 'ShoppingItemDetailFragment.java' file in the 'com.webage.shopping' package of the ShoppingList project.
	__11.  Find the existing 'onCreate' method.  In the 'if' statement from the first part of the method, remove the memory solution code as marked in bold strikethrough below and add the bold code for the content provider solution.  Make sure the code added is within the brackets of the 'if' statement.  This code would restore the item URI on orientation change.
	__12.  In the 'if' statement from the second part of the method, change the key that is tested for in the 'if' condition as marked in bold below.  Also remove the memory solution code as marked in bold strikethrough below and add the bold code for the content provider solution.  Make sure the code added is within the brackets of the 'if' statement.  This code will initialize the item URI when the fragment is first created if there is an argument indicating to display an item.
	__13.  Find the existing 'onSaveInstanceState' method.  Remove the memory solution code as marked in bold strikethrough below and add the bold code for the content provider solution.  This code will store the item URI before an orientation change.
	__14.  Find the existing 'fillData' method.  Fill in the body of the method with the bold code below, being careful that most of the added code is within a new 'if' statement that is added.  
	__15.  Find the existing 'onCreateView' method.  At the very end of the method, remove the memory solution code in bold strikethrough below and add the bold code that will call the 'fillData' method.  Make sure the code added comes before the existing return statement.
	__16.  Save the file.
	__17.  Close all open files.

	Part 11 -  Test Edit Feature
	__1.  Run the application again.  You should see the same list of items you stopped with last time.
	__2.  Click on an item.
	__3.  Make sure that the edit form is shown. Note that besides showing the existing data in the form, the buttons are different with the 'Delete' button being active (even though that function isn't implemented yet) and the right button being 'Update' instead of 'Add'.
	__4.  Make some changes to the data and click Update.
	__5.  Make sure that the list shows updated data.

	Part 12 -  Implement Delete Feature
	__1.  Open the 'ShoppingListContentProvider.java' file in the 'com.webage.shopping.content' package of the ShoppingList project if you had closed it.
	__2.  Find the existing 'delete' method and add the bold code below to the method.  Be careful when adding the code for the 'ITEM_ID' case as it is more complex.  
	__3.  Save the file and make sure there are no compilation errors.
	__4.  Open the 'ShoppingItemDetailFragment.java' file in the 'com.webage.shopping' package of the ShoppingList project.
	__5.  Find the existing 'onCreateView' method and the code that sets an 'OnClickListener' for the delete button.  Remove the code for the memory solution that would have used the 'ShoppingItemDAO' class and add the bold code below to call the 'delete' method of the content provider.  Make sure you delete and add code to the correct location as this is inside an anonymous inner class declared for the OnClickListener.
	__6.  Go to the declaration of the ShoppingItemDetailFragment class and delete the fields that were present for the in‑memory solution.
	__7.  Save the file and make sure you do not get any compilation errors.  You will have warnings.  This proves the elements of the in‑memory solution are no longer used.
	__8.  Close all open files.

	Part 13 -  Test Delete Feature
	__1.  Run the application again.  You should see the same list of items you stopped with last time.
	__2.  Click on an item.
	__3.  From the page displaying the item, click the Delete button.
	__4.  Make sure that the item is deleted from the main list when it is re-displayed.
	__5.  Work with the other features of the application as you have now implemented everything.  You should be able to delete all items and see the message about the empty list.  You can then add additional new items and edit these items.

	Part 14 -  Perform Schema Upgrade
	__1.  Open the ShoppingListTable class from the 'com.webage.shopping.content' package.
	__2.  Within the declaration of the class but outside of other methods, add the following new field which will refer to the new column.
	__3.  Within the declaration of the class but outside of other methods, add the following new method which will update the database table.
	__4.  Save the file and make sure you have no compilation errors.
	__5.  Open the MyDBHelper class from the 'com.webage.shopping.content' package.
	__6.  Change the version number to 2 as follows.
	__7.  Change the parameter names for onUpgrade() to more meaningful values.
	__8.  Modify the method implementation as shown in bold below.
	__9.  Save the file and make sure you have no compilation errors.

	Part 15 -  Test Schema Upgrade
	__1.  Run the application again.
	__2.  Check the LogCat view to make sure that the message from onUpgrade() shows up.
	__3.  You should currently still have an 'sqlite3' session open.  If not, you can follow steps from the part of the lab that tested the list query feature to open a new sqlite3 session since this is when you manually inserted data using this tool.
	__4.  Back in the sqlite3 command prompt, enter:
	__5.  Note that the "notes" column has been added.
	__6.  Type .exit {enter} to exit from sqlite.
	__7.  Close the command prompt window.
	__8.  Close all open files.

	Part 16 -  Review

	Lab 20 -  Play Audio Files 
	Part 1 -  Import Project
	__1.  Import the AudioCity project from C:\LabFiles\AudioCity.
	__2.  Wait for the project to load and build.
	__3.  Open the activity class AudioPlayerActivity.java from the 'com.webage.audio' package of the project.

	Part 2 -  Play Audio from Raw Resource
	__1.  Expand res/raw folder and locate the sound file doh.mp3.
	__2.  In the AudioPlayerActivity.java class, find the comment 'Code to start playing' and add the following bold code.  You will have errors until the next step.
	__3.  Save changes.  Make sure there are no compilation errors.

	Part 3 -  Test
	__1.  Run the AudioCity project from Android Studio.
	__2.  Click on the Start button. You should hear the "do'h" sound.

	Part 4 -  Play Music from Internet Stream
	__1.  Copy C:\LabFiles\data\guitar.mp3 to the htdocs folder of your web server (likely C:\Apache2.2\htdocs).
	__2.  In the AudioPlayerActivity class, add a field for the media player.  Make sure the field is declared within the class but outside any other methods.
	__3.  Add a new method that will start playing audio.  Replace 'YOUR_IP' with your actual IP address.  Make sure the new method is within the class but outside any other methods.  You will have errors for a few more steps.
	__4.  Modify the code after the comment 'Code to start playing' in the 'onClick' method for the Start button to only call the new method you just added.  Your code should match that shown below with the changes in bold.
	__5.  Save changes.
	__6.  Add a new method as follows.  Make sure the new method is within the class but outside any other methods.
	__7.  Call stopPlay() when the Stop button is clicked.  Find the comment 'Code to stop playing' and add the following bold code.
	__8.  Save changes.  Make sure you don't have any compilation errors.

	Part 5 -  Update the Manifest
	__1.  Open AndroidManifest.xml for the AudioCity project.
	__2.  Add this line above the <application> tag, to give permission to use internet.
	__3.  Add the following attribute to the opening <application ...> tag in the manifest:
	__4.  Save and close the manifest file.

	Part 6 -  Test
	__1.  Run the application.
	__2.  Click the Start button. You should start hearing music right away. If you don't, check the LogCat view for exception stack trace logged by the startPlay() method.
	__3.  Click the Stop button. Playback should stop.
	__4.  Click Start again. Music should restart. This proves that we can reuse the same MediaPlayer provided we call reset() after stopping it.
	__5.  With the music still playing, click the back button of the AVD to finish the activity. Music will continue to play. Oops. That's not what we want. We will fix the problem next.

	Part 7 -  Clean Up
	__1.  From the onDestroy() method, add the following old code to stop playing and free up all resources right away (without waiting for garbage collection to kick in).
	__2.  Save changes.

	Part 8 -  Test
	__1.  Run the application.  As the new version is deployed, the music will stop if still playing.
	__2.  Click Start to start playing music.
	__3.  Click the back button of the AVD to finish the activity. The music playback should stop when the application closes.
	__4.  Close all open files.

	Part 9 -  Review

	Lab 21 -  Develop a Simple Service
	Part 1 -  Create the Service Class
	__1.  In the com.webage.audio package of the AudioCity project, create a new class as follows:
	Right click the package com.webage.audio → New → Service → Service.
	__2.  Open the Android Manifest.xml file. Locate the <service> element and take a look at it. It should appear like this:

	Part 2 -  Develop the Service Code
	__1.  In the PlayerService class, add the following code.  You can likely copy this code from the AudioPlayerActivity class.  Remember to replace 'YOUR_IP' in the code below with the actual IP address of your machine.  Make sure the new code is within the class but outside any other methods.  You may have errors until the next steps.
	__2.  Add the following new method to the PlayerService class.  The method is slightly different than the activity class so it is best not to copy it directly.  Make sure the new method is within the class but outside any other methods.
	__3.  Add the following new method to the PlayerService class.  Make sure the new method is within the class but outside any other methods.
	__4.  Save the file and make sure there are no compilation errors in the file.

	Part 3 -  Modify Activity
	__1.  Open the AudioPlayerActivity.java file if you do not already have it open.
	__2.  Remove the 'startPlay' and 'stopPlay' methods from the AudioPlayerActivity class. You will have several errors that will be fixed next.
	__3.  Delete the field of the class that refers to the 'MediaPlayer' as the service will now be the only class that works with the MediaPlayer.
	__4.  Find the code for the 'Start' button click and modify the code after the 'Code to start playing' comment as shown in bold below.
	__5.  Find the code for the 'Stop' button click and modify the code after the 'Code to stop playing' comment as shown in bold below.
	__6.  Modify the code of the 'onDestroy' method and remove the two lines that clean up the resources as shown below.  These lines are likely giving compilation errors.
	__7.  Save the file and make sure there are no compilation errors in the file.

	Part 4 -  Test
	__1.  Start AudioCity application.
	__2.  Click the Start button. Make sure music playback starts.
	__3.  Click Stop. Make sure playback stops.
	__4.  Start the music again.
	__5.  While the music is playing, click the back button to destroy the activity. Make sure that playback continues.
	__6.  Re-launch the application. Since no code has changed, Android Studio will simply start the application (without killing the JVM).
	__7.  Click Stop. Make sure that playback stops.
	__8.  Close all open files.
	__9.  Close the project.

	Part 5 -  Review

	Lab 22 -  Developing Broadcast Receiver
	Part 1 -  Create a Project
	__1.  Create a new Android project.
	__2.  For "Select a Project Template" choose the "Phone and Tablet" tab, 
	__3.  Then select the "Empty Activity" and click Next.
	__4.  For "Configure Your Project" enter the following settings then click "Finish":
	__5.  Android Studio will create the project and do an initial build. Wait until it is finished. 
	__6.  Close the files related to the new activity that are opened once the project is created.  We will work with them later.

	Part 2 -  Create the Broadcast Receiver Class
	__1.  In the www.webage.smsinterceptor package of the SMSInterceptor project, right click the "com.webage.smsinterceptor" package and select New →  Other→  Broadcast Receiver.
	__2.  Create the new class with the following properties:
	         Class Name: SMSReceiver
	         Take defaults for the rest of the properties
	__3.  Click "Finish"
	__4.  Open the new SMSReceiver.java file.
	__5.  Replace the existing onReceive method with the following code:
	__6.  Save changes.  Make sure there are no compilation errors.

	Part 3 -  Register the Receiver
	__1.  Open AndroidManifest.xml.
	__2.  Locate the <receiver ... > element
	__3.  Add the intent filter shown in bold below in between the start and end <receiver> tags:
	__4.  Add the following uses-permission element above right before the final </manifest> tag:
	__5.  Save and close the manifest file.
	In Android an application must ask the user explicitly to grant dangerous permissions. Accessing incoming SMS is dangerous because they may contain sensitive information.
	__6.  Open MainActivity.java
	__7.  Add the following code to the end of the onCreate method
	__8.  When the app starts Android will prompt the user for permission. The following method should be added to MainActivity to handle the result:

	Part 4 -  Test
	__1.  Run the SMSInterceptor project. 
	__2.  You should be prompted to give the app permission to access incoming SMS messages. Click Allow and the app will continue loading.
	__3.  Clear all messages in LogCat view.
	__4.  Click the 'three dots' at the bottom of the Emulator toolbar to display the Extended controls window.
	__5.  Select Phone in the Extended controls dialog.
	__6.  Click Send Message to send the text 'Nougat is sweet!' You should see the incoming text in the emulator:
	__7.  You should also see that the message has been received in LogCat
	__8.  Close the project. 

	Part 5 -  Review

	Lab 23 -  Location Based Application
	Part 1 -  Import Project
	__1.  Import LocationTest project from C:\LabFiles\LocationTest.
	__2.  Wait for the project to be created and built.
	__3.  Open the activity class LocationFinder.java from com.webage.location package.
	__4.  Note the two methods – startMonitoring() and stopMonitoring(). We will develop these methods. 

	Part 2 -  Begin Monitoring Location
	__1.  Make the  LocationFinder activity class implement LocationListener interface.
	__2.  Save. There is a problem that we will fix next.
	__3.  Right click on  LocationListener, then click Generate and select  Implement Methods.
	There are 5 methods all 5 methods should be implemented. Click OK.
	__4.  Update the onLocationChanged method with the bold code shown below.
	__5.  The startMonitoring() method is called when the Start button is pressed. Develop that method as follows. You will start to see a "permissions" error. We will fix that in the next step.
	__6.  Save changes.  

	Part 3 -  Permissions
	__1.  Open AndroidManifest.xml.
	__2.  Switch to the 'Text' tab at the bottom of the editor.
	__3.  Above the opening <application> tag but after the opening <manifest> tag, add the following bold permission entry:
	__4.  Save and close the file.
	__5.  Open LocationFinder.java
	__6.  Add the code in bold to onCreate to check for permissions and request them if necessary
	__7.  Add a new method to the LocationFinder class

	Part 4 -  Test
	__1.  Run LocationTest application.
	__2.  You should be prompted to grant the application location access permissions. Click ALLOW
	__3.  You should also see a message in LogCat that permission has been granted.
	__4.  Click on the button on the bottom of the emulator toolbar to open the Extended controls window
	__5.  Choose Location 
	__6.  Type into the search box "San Jose" and choose "San Jose, CA, USA" from the list.
	__7.  Click the "Save Point" button and then the "Ok" button to save the location.
	__8.  Click the "Set Location" button in the lower right corner of the dialog.
	__9.  Back in the Location Test app, click the "Start" button and verify that the Lat and Long location shown match those of the location point you saved and set earlier.

	Part 5 -  Stop Monitoring
	__1.  Implement the stopMonitoring() method of the LocationFinder class as follows.
	__2.  Save changes.

	Part 6 -  Test
	__1.  Run the application again. Do not click Start yet.
	__2.  Using emulator control, search for and save another location point and note its  longitude and latitude settings. 
	__3.  Click the "Set Location" button to establish the emulated location.
	__4.  Back in the Location Test application. Click the Start button in the application. It should pick up the latest location.
	__5.  Click the Stop button.
	__6.  Push out new location coordinates by selecting a point and clicking on the "Set Location" button.  At this point the application will not pick up the updates.
	__7.  Click Start again. It should pick up the latest location again.
	__8.  Close all open files. 
	__9.  Close the project.

	Part 7 -  Review

	Lab 24 -  Using the Telephony API
	Part 1 -  Import Project
	__1.  Open the TelephonyTest project from C:\LabFiles\TelephonyTest.
	__2.  Wait for the project to be created and built.
	__3.  Run the application and make sure that it looks like the image above.  Currently nothing happens when you interact with the application.
	__4.  Open the activity class EmployeeDetails.java.

	Part 2 -  Make a Phone Call
	__1.  Implement the dialPhone() method as follows.  You will have errors until future steps.
	__2.  Save changes.
	__3.  Open AndroidManifest.xml.
	__4.  Verify it has the following permission entry:    
	__5.  Close the file.

	Part 3 -  Test
	__1.  Run the application.
	__2.  Click the Phone number ("007").
	__3.  You can close the phone app.

	Part 4 -  Send SMS Message
	__1.  Open EmployeeDetails.java
	__2.  Implement the sendSMS() method as follows.
	__3.  Add these declarations near the top of the EmployeeDetails class.
	Note: The PERMISSION_REQUEST_ID is used to coordinate responses. The permissions array is a collection of required permissions.
	__4.  Add the following method to handle permission requests.
	__5.  Check that the following imports have been added. Add them if they are not already there:
	__6.  Add the following code at the end of the onCreate method:
	__7.  Save changes.
	__8.  Add the permission in bold below to the manifest file:
	__9.  Save changes.

	Part 5 -  Test
	__1.  Run the application.
	__2.  You should be prompted for permissions, click Allow for both.
	__3.  Enter some text in the message text box.
	__4.  Click the Send SMS button. 
	__5.  The emulator will not actually send any message. That is normal. The app crashing is NOT normal. If that happens you should go back and check the code. 

	Part 6 -  Better Telephony Testing
	__1.  Back in Android studio, from the menu, select Tools >  Android > AVD Manager.
	__2.  Click Create Virtual Device.
	__3.  Choose the Pixel XL as the device and click Next button.
	__4.  Click on the 'x86 Images' tab.
	__5.  Select Pie API 28 and click Next.
	__6.  On the Android Virtual Device page accept the defaults and click Finish.
	__7.  Select the new AVD and click the Start button.
	__8.  When the new emulator is up and running click on its '...' more button to the right of the device:
	__9.  From the screen that comes up click on "settings"
	__10.  Find the setting for "Show window frame around device" and make sure it is turned on.
	__11.  Close the settings window.
	__12.  The Emulator itself should now have a frame around it that includes the AVD name and its DDMS port number:
	__13.  The image above shows a DDMS number of "5556".
	__14.  Check to see which number shows on your emulator.
	__15.  Leave the new AVD open.
	__16.  Close the "Android Virtual Device Manager" dialog.
	__17.  Open res/values/strings.xml in the TelephonyTest project.
	__18.  Change the phone number to the DDMS port number of the new device emulator.
	__19.  Make sure that the original AVD name shows up in Android Studio. 
	__20.  Re-start the application. Notice that the phone number has changed.
	__21.  Enter a text message and click Send SMS. 
	__22.  You should see the message being received in the second AVD emulator.
	__23.  Close the second emulator  "Pixel_XL_API_28".
	__24.  Close the project.

	Part 7 -  Review

	Lab 25 -  Unit Testing an Application
	Part 1 -  Import the Application Project
	__1.  Open the TemperatureConverter project from C:\LabFiles\TemperatureConverter
	__2.  Wait for the project to open and build.
	__3.  Open ConverterActivity.java from the project.

	Part 2 -  Manually Test the Application
	__1.  Run the application from Android Studio.
	__2.  Enter 80 in the Fahrenheit text box.
	__3.  Click the down arrow to convert to Celsius.
	__4.  Enter 20 in the Celsius text box.
	__5.  Click the up arrow to convert to Fahrenheit.

	Part 3 -  Run Pre-built Test
	__1.  In your project window expand the folders under app > java.
	__2.  You will see two packages with the same name com.webage.temp. The second one will have (androidTest). Expand that one.
	__4.  Open ExampleInstrumentedTest.java
	__5.  Examine the source.
	__6.  To run the test right click on app\java\com.webage.temp(androidTest) and choose 'run tests in com.webage...'.
	__7.  You can view the test results in the Run window of the IDE. You can see that the test succeeded.

	Part 4 -  Create Test Cases
	__1.  Open ExampleInstrumentedTest in the editor.
	__2.  Add the following declarations to the beginning of the class. These variables will hold reference to the Activity itself and the GUI widgets with which we must interact.
	__3.  Next we will add a Rule immediately below the declarations. This Rule is evaluated before any methods in the class. In this case we use the rule to get  runtime access to the activity.
	__4.  JUnit uses the @Before annotation to mark a method to be run before each test method. This method acquires references to the widgets we will use in our testing. Insert the following method into the class:
	__5.  Next we will create two test methods. JUnit uses the @Test annotation to mark test methods. The @UiThreadTest method is required to force the test to be run on the thread that created the UI components.

These tests put a value in one of the temperature boxes and then press a button to perform the conversion. The assertEquals method test the conversion result. The first two parameters of assertEquals are the results to be compared. Since this overloaded version of the function compares floating point values, the third parameter lets you specify how close results must be to consider them equal. In our special case we have set the value to 0.0f since the conversions we are using should come out to be whole numbers.
	__6.  Insert the two test functions into the class:
	__7.  Right click on  ExampleInstrumentedTest and select Run > 'ExampleInstrumentedTest' from the context menu to run the tests.
	__8.  If prompted choose to run on the AVD.
	__9.   You may see the values flash briefly in the emulator since this is an instrumented test it runs in the emulator or on a real device.
	__10.  You should see that all three tests have passed. You may wish to experiment with different numbers and see if you can break the tests.
	__11.  Close the project.

	Part 5 -  Review
	__1.  In this lab you built JUnit tests to test application functionality. You learned how basic JUnit annotations work and ran the tests in the emulator.


	Lab 26 -  Packaging and Installing Application
	Part 1 -  Get the Application Ready for Distribution
	__1.  Open the TemperatureConverter project from C:\LabFiles\TemperatureConverter 
	__2.  Right click on app and select New → Image Asset.
	__3.  Find the Source Asset \ Path setting and click the folder all the way to the right of the field to open the file browser.
	__4.  Browse to and select C:\LabFiles\thermometer.png then click OK.
	__5.  Back in the Asset Studio dialog, use the Resize slider to adjust the image sizes so they look the best.
	__6.  click Next.
	__7.  On the Confirm Icon Path page notice that the tool is going to make multiple copies of your icon for different uses. Click Finish.
	__8.  Open Gradle Scripts\build.gradle(Module: app) file for the module of the TemperatureConverter project. 
	__9.  Check the version name and code. This is our first version. So, the defaults are just fine. 
	__10.  Close build.gradle
	__11.  Open AndroidManifest.xml
	__12.  Set the Install location to auto. In manifest file add an attribute to manifest element as below.
	__13.  Save changes and close the manifest file.

	Part 2 -  Export the .apk File
	__1.  From the menu select  Build → Generate Signed Bundle/ APK.
	__2.  Select APK and click Next
	__3.  The "Generate Signed Bundle or APK" dialog will appear:
	__4.  Click on the button "Choose Existing"
	__5.  Select the keystore: C:\LabFiles\MyKey.jks
	__6.  Enter the following values and then click Next.
	       Key store password: pass123
	       Key alias: TheKey
	       Key password:  pass123
	__7.  Set the "Destination Folder" to C:\LabFiles\
	__8.  Choose "release" and select V2 (Full Apk Signature).
	__9.  Click Finish.
	__10.  You will find the APK created by the above steps in the C:\LabFiles\release folder. (app-release.apk)
	__11.  Rename the APK file to TemperatureConverter.apk

	Part 3 -  Distribute the Application Internally
	__1.  Copy C:\LabFiles\release\TemperatureConverter.apk into C:\Apache2.2\htdocs folder.

	Part 4 -  Uninstall Previous Installs
	__1.  Start the my_avd emulator.
	__2.  Close the Temperature Converter app using the back arrow. 
	__3.  Drag from the bottom of the emulator screen upwards to show installed applications
	__4.  Long-Click the Temerature app icon to pop up the App Info bubble
	__5.  Click on App Info
	__6.  Click on Uninstall and click OK. The Temperature app should no longer appear on the installed apps screen. 
	__7.  Uninstall the TestTemperatureConverterTest app in the same way (long click, app-info, etc.)
	__8.  Shut down the emulator (use the small 'x' at the top right of the emulator)
	__9.  From inside Android Studio click on "AVD Manager" under the Tools menu.
	__10.  Click the green arrow on the my_avd emulator to start it. Remember, you are trying to start it without automatically installing the app at the same time. This is why we are starting the emulator from the AVD Manager. 
	__11.  Once the emulator is open without the Temperature Converter app installed you are ready to continue.

	Part 5 -  Install the Application
	__1.  Click Home in the AVD (the white circle at the lower center of the screen).
	__2.  Click the Chrome web browser icon in the lower right of the emulator.
	__3.  If you are requested to sing in chrome just click No Thanks.
	__4.  In the address bar, carefully enter http://YOUR_IP/TemperatureConverter.apk and click the Arrow as shown below. Here, YOUR_IP is the IP address of the web server machine. 
	__5.  You should be prompted for storage access, click Continue.
	__6.  On the next popup click Allow. 
	__7.  Click Download on the Download file dialog:
	__8.  The browser will download the file and put a message at the bottom of the screen and in the status bar saying the apk was downloaded.
	__9.  Even though the APK is signed, it was signed with a self-signed certificate. So there is no Certificate Authority to vouch for it. So Chrome puts up a warning. Click Settings to go into the settings and allow the install.
	__10.  Flip the toggle switch to enable the download.
	__11.  Click the back button to return to the Installation.
	__12.  Click the Install button at the lower right corner of the screen. 
	__13.  You should see:
	__14.  Click Open. The app will open.
	__15.  View all applications and you can see the TemperatureConverter app installed with its fancy icon.
	__16.  Close the application.
	__17.  Close Android studio.
	__18.  Close the emulator.

	Part 6 -  Review




