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Lab 1 - Basic Mediation Flow Development
In this lab, we will develop a very simple mediation flow. A mediation flow can be used 
to implement most Enterprise Service Bus patterns. We will not get into pattern 
implementation just yet. Our focus will be to learn the basics of development and testing 
using WID. We will also get to see a very simple mediation flow in action.

A mediation flow always acts as an intermediary between an actual service provider and 
consumer. To the consumer, the mediation flow appears as the service provider. To the 
provider, the mediation flow is the consumer. The true consumer is decoupled from the 
true provider.

In this lab, we will use a Java class as the service provider. Java class based service 
providers are quicker to develop compared to web services. They are great for testing.

We will not develop any consumer application. Instead, we will use the universal test tool 
to invoke methods of the mediation flow.

The business logic for the service will be very simple. It will have a method called 
sayHello. It will accept as input a string. It will return a greeting message as a string. 
From a Java point of view, the method will look like this:

String sayHello(String name)

The business logic is kept intentionally simple so you can focus on the mechanisms of 
software development and testing using WID. Later labs will assume that you know these 
skills and avoid giving detailed instructions.

Part 1 - Create a Mediation Module
SCA development can happen in two types of projects – Module and Mediation Module. 
A Mediation Module only allows you to create artifacts, such as a mediation flow, that 
can be deployed in WebSphere ESB. A Module, on the other hand, allows you to create 
all artifacts that can be deployed in WebSphere Process Server. For example, a BPEL 
business process can only be created in a Module. A mediation flow can be created in 
either of the two projects.

Tip: If your target server runtime is WebSphere ESB, you should always use the 
Mediation Module project. This will prevent you from creating an artifact that can not 
be deployed in WebSphere ESB.

__1. From the menubar, select File > New > Mediation Module.
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__2. Enter the following values:

Module name: SimpleModule

Target runtime server: WebSphere ESB Server v7.0.

Create mediation component: Uncheck. This adds a dummy component to the 
assembly diagram without any implementation. This is more of an inconvenience than 
helpful, so we uncheck it.

Open module assembly diagram: Uncheck. We will not work with the assembly 
diagram yet. So, uncheck this option.

__3. Click Finish.

__4. WID will create the mediation module. In the Business Integration view, under the 
Projects section, verify that SimpleModule is shown.
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Part 2 - Study the Project Structure
We will now observe how exactly a mediation module project is represented on the file 
system.

__1. From the menubar, select Window > Open Perspective > Other.

__2. Select Java EE.

__3. Click OK.

__4. Notice, three projects have been created for SimpleModule:

These projects are as follows:

Project Remarks

SimpleModule This is a plain Java project that represents the actual 
mediation module. All SCA artifacts, like mediation flow 
and data transformation maps, are created here.

SimpleModuleApp This is a J2EE enterprise application project. This is what 
gets deployed to the server as an EAR file. The EAR file 
includes the mediation module Java project as a JAR file.

SimpleModuleWeb This is a Web module project.

__5. Close the Java EE perspective by selecting Window > Close Perspective.

Part 3 - Create a Service Interface
Every SCA service must support one or more interfaces. A service interface is a 
collection of operations. SCA uses WSDL portType to define interfaces. You could also 
use a Java interface for that purpose. But, in SOA, vendor and language neutral WSDL is 
always recommended.

We will now create the interface for our very simple mediation flow. Recall, it has only 
one operation that looks like this: String sayHello(String name)

__1. Expand SimpleModule  project.

__2. Right click Interfaces and select New > Interface.

__3. Enter Greeting as the name of the interface.
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__4. Click Finish.

WID will create the interface and open it in the editor.

__5. In the editor, click the Add Request Response Operation toolbar icon to add a new 
operation.

Make the following changes:

__6. Change the name of the operation to sayHello

__7. Change the name of the input parameter to name 

__8. Change the name of the output parameter to message

__9. Save and close the editor.

Part 4 - Create the Mediation Flow
Our mediation flow will conform to the service interface we have defined in the previous 
part.

__1. Right click Integration Logic and select New > Mediation Flow.

__2. Enter GreeterFlow as the name.

__3. Click Next.

As the source interface, you will add the Greeting interface we have defined previously. 
The source interface is what the mediation flow offers to its consumers.

__4. Click the Add button for Sources interfaces.

__5. The Greeting interface should be selected, just click OK.

The sources interfaces will be updated.
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As the target interface, also you will add the Greeting interface. The actual service 
provider supports this interface.

__6. Click the Add button for Target references.

__7. The Greeting interface should be selected, just click OK.

The target references will be updated.

The source and target interface does not have to be the same. In fact, the data translation 
pattern requires that they be different. In that case, the actual service consumer and 
provider support different service interfaces. The mediation flow acts as the bridge. We 
will see the implementation of this pattern in a lab later.

__8. Click Finish. WID will create the mediation flow and open it in the editor.

Part 5 - Design the Mediation Flow
Our mediation flow will be the simplest kind. There will be no mediation primitive in the 
message flow. We will simply pass the input message straight to the service provider. 
Similarly, the response from the service provider will be sent back to the consumer.

__1. At the top of the editor, you will see two interfaces.
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On the left hand side, we see the source interface. On the right hand side, we see the 
partner reference. The partner reference is a place holder for the actual service provider.

When a consumer calls the sayHello operation of the source interface, we would like the 
mediation flow to call the sayHello operation of the service provider. As a result, we need 
to connect the two operations.

__2. Click over the sayHello operation of the source interface.  The Select a Mediation 
Flow Template dialog will open.

We intend to call a service operation at the end of the request message flow. Hence, we 
will select the Service Integration option. A blank mediation flow gives us a blank 
canvas where we can do more complicated service composition. We will get to see that 
in a lab later on.

__3. Click the Service Integration link.

__4. The Select the Services window will open, click Add.

__5. The Select Reference Operation window will open showing the sayHello Target 
operation of GreetingPartner, click OK.
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__6. Back in the Select the Services window, the list will be updated with the selected 
target. click OK.

__7. The Request tab will open.

__8. Connect the output terminal of sayHello of Greeting (the source interface) to the 
input terminal of sayHello of GreetingPartner (target interface).

This creates a very simple passthrough message flow. Later, we will learn how to add 
mediation primitives in that flow to solve complex problems.

__9. Click the Response tab to open the response flow design.

__10. Connect the output terminal of sayHello of GreetingPartner (the target interface) 
to the input terminal of sayHello of Greeting.  Make sure you select the pointed output 
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terminal of the GreetingPartner and not the rectangular fail terminal.

That means, the output from the service provider is passed as is to the consumer.

__11. Click the Overview tab and check that the source and target are connected now.

__12. Save and close the editor.

__13. Open the Problems view and expand Warnings. You should notice a warning 
about "A direct connection exists from the mediation input to output." This is fine for our 
very simple mediation flow.

There should be no error messages.

Part 6 - Create Service Provider
We will now implement the actual service provider. According to our design, it conforms 
to the Greeting service interface.

__1. Double click Assembly Diagram to open it.

__2. Right click the white area of the editor and select Add > Java.

__3. Change the name of the Java component to GreeterBean

__4. Right click the component and select Add > Interface.

__5. Select the Greeting interface and click OK.

__6. Right click the component again and select Generate Implementation.
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__7. Click New Package.

__8. Enter com.webage.greet as the package name.

__9. Click OK to create the package.

__10. Click OK to select the new package for the implementation.

WID will create a class called com.webage.greet.GreaterBeanImpl and open it in the 
editor.

__11. Change the implementation of the sayHello method as follows.

public String sayHello(String name) {
System.out.println("Saying hello to: " + name);
return "Hello " + name;

}

__12. Save all files (Control+Shift+S).

Note: In this case, our Java class is implementing a service interface which is defined in 
a WSDL file. This is a unique feature of SCA. SCA uses a strict pattern where a service 
implementation, no matter how it is implemented, must support a WSDL based 
interface. In this case, the implementation is a Java class.

__13. Close the Java editor.

Part 7 - Wire the Components
Our mediation flow has a reference partner which is a placeholder for the actual service 
provider. We must wire that reference partner to the Java based service provider we have 
created above.

__1. Make sure that the assembly diagram is still open. If not open it.

__2. Drag the GreeterFlow mediation flow on to the diagram.

__3. Hover the mouse over the reference partner of the mediation flow and a lollipop will 
open up.

__4. Drag the lollipop and drop it over the interface of the Java implementation. This will 
connect the two as shown below.
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__5. Save changes.

Part 8 - Deploy the Application to Server
__1. Open the Servers view.

__2. Start the server. Wait until the status changes to Started.

__3. Right click the server again and select Add and Remove Projects...

__4. Select SimpleModuleApp and click Add.

__5. Click Finish.

__6. WID will start publishing the application files. Wait for the status of the server to 
change to Synchronized.

Part 9 - Test the Application
We will test the application by invoking the sayHello operation exposed by the mediation 
flow. We will use the built-in test client for that.

__1. Open the assembly diagram if it is not open.

__2. Right click any white area of the assembly diagram and select Test Module.

WID will open the test client page.

__3. Verify the Component is set to GreeterFlow. That means, the test client will invoke 
the operations of the mediation flow.  It may default to GreeterBean, but this would not 
test the whole flow.

__4. Verify that the sayHello operation is selected since that is the only operation 
available from the interface.

__5. In the Initial request parameters table, set the value of the name parameter to 
something.

__6. Under Events click the Continue toolbar button to invoke the operation.
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__7. In the Deployment Location dialog, Expand WebSphere Enterprise Service Bus 
Server and select WebSphere ESB Server v7.0 at localhost.

__8. Also, check Use this as the default and do not ask again.

__9. Click Finish.

__10. If asked, check the checkbox to always use the same authentication settings and 
click OK in the User Login dialog. Security is enabled for the server. This is where the 
administrative user ID and password is entered. Without a valid password, publishing will 
fail.

__11. After the test ends, the Return parameters table will show the reply.

__12. Open the Server Logs view. At the very bottom, the output from the Java 
component will be shown.
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__13. Close the test page without saving.

Part 10 - Configure Build Activities
Every time you change an SCA artifact file or assembly diagram, WID performs a build. 
As a part of the build, three things have to happen. 

1.  Validate the changes made.

2.  Generate new code and compile them.

3. Publish updated files to the server.

You can configure how many of these three steps are performed automatically.

__1. Open the Build Activities view.

Note that by default Validate and update deployment code is selected. Here, "update 
deployed code" is referring to code generation.

That means, updated files are not published to the server by default after a build. You can 
click on the Update Running Servers button to do that. Many of the changes will be 
picked up by the server after files are published. In a few rare cases, we have to restart the 
server.

__2. Close all open files. (Ctrl+Shift+W)

__3. Stop the server.

Part 11 - Review
In this lab, we created a very simple mediation flow. During testing, we invoked the 
sayHello operation of the mediation flow. The flow, in turn, invoked the sayHello 
operation of the reference partner. The partner was wired to a Java implementation. As a 
result, the sayHello method of the Java class got invoked.
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The response from the service provider Java class was returned back to the test client.

A few things to remember from this lab:

1. Every mediation flow has a source interface and one or more target interfaces.

2. For each target interface, a reference partner is defined in the mediation flow.

3. A method from the source interface is connected to one or more methods of the 
target interfaces.

4. For each source method, you need to design the request and response flow.

5. Every reference partner needs to be wired to an actual service implementation (or 
an import if the implementation exists outside the module).
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Lab 2 - Using Mediation Primitives
In the previous lab, we did not use any mediation primitives in the request or response 
flow. In this lab, we will add the message logger primitive to both flows. This primitive 
can save a message in a file or database.

Now, for the first time, our mediation flow will begin to offer some real value. In this 
case, we are essentially implementing the audit logging pattern. A part of the audit 
logging pattern saves request and response messages for later retrieval.

Part 1 - Add Primitive to Request Flow
__1. Start the Server.

__2. Expand SimpleModule > Integration Logic > Mediation Flows.

__3. Open GreeterFlow mediation flow in the editor by double clicking on it.

__4. Click sayHello operation in the source interface. This will open the Request flow in 
the editor.

__5. In the request message flow, select the connection between  Greeting / sayHello and 
GreetingPartner / sayHello.

__6. Press the delete key to remove the connection.

__7. On the left hand side of the editor, expand the Tracing section.

__8. Drag and drop the Message Logger primitive on the editor.

__9. Connect the output terminal of Greeting  / sayHello to the input terminal of 
MessageLogger1.

__10. Connect the output terminal of MessageLogger1 to the input terminal of 
GreetingPartner  / sayHello.

This means, the request message will first go inside the logger primitive. This primitive 
does not alter the message in any way and outputs the same message that came in as 
input. The output of the logger is then fed into the reference partner as input.
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Now, we will configure the logger.

__11. Select MessageLogger1.

__12. Open the Properties view.

__13. Select the Details tab.

__14. Change the Logging type from Database to Custom.

Note: By default, a logger saves messages in a database. The database is pointed to by 
the Data source name property. The default data source name is 
jdbc/mediation/messageLog. This points to a Cloudscape (Derby) database where the 
necessary schema is already defined. Alternatively, you can point the message logger to 
a DB2 or Oracle database.

If you set the logging type to Custom, then the logger saves the messages in a file.

Part 2 - Add Primitive to Response Flow
__1. Click the Response tab to switch to the response flow.

__2. Follow the steps in the previous part to insert a logger primitive in the flow.

__3. Change the logging type of the logger to custom.

__4. Save the mediation flow.

Part 3 - Publish Changes
__1. Open the Build Activities tab.

__2. Click Update Running Servers.

__3. Make sure WebSphere ESB Server v7.0 is selected.

__4. Check the 'Do not show this dialog again' box.
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__5. Press the Publish button.

The server will start publishing.  Wait until it's done.

Part 4 - Test
__1. Open the Assembly Diagram.

__2. Right click the white area and select Test Module.

__3. Set the component to GreeterFlow.  It may default to GreeterBean, but this would 
not test the whole flow.

__4. Enter a name in the input table.

__5. Click the Continue toolbar button under Events.
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__6. Close the test without saving it.

We will now inspect the messages saved in the log files. Messages are saved in the folder 
pointed to by the TEMP environment variable (both in Windows and UNIX).

__7. Open a command prompt window.

__8. Enter the following command:

cd  /d  %TEMP%

__9. List all message log files:

dir  *.log

__10. You should see MessageLog.log that contains request and response messages.

__11. View the request message as follows.

type  MessageLog.log
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__12. There locate the request and response messages as shown below:

__13. Close the Command prompt window.

__14. Back in WID, close all open files.

Part 5 - Review
In this lab, we implemented the audit logging pattern. Note, how the pattern can be used 
to audit log a service without changing the service implementation. Now, you are 
beginning to see some of the advantages of using an ESB as an intermediary. 
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Lab 3 - Create Business Objects
Business objects represent the data that's passed between service components in your 
SCA modules.  When you create interfaces (WSDL or Java) for your components, which 
you'll do in the next lab, the input and output parameters correspond with business 
objects.  Business objects are defined using XML Schema Definition (XSD) files.  

WebSphere ESB and Process Server uses the Service Data Object (SDO) API to work 
with business objects. Specifically, the commonj.sdo.DataObject interface represents a 
data object.

Business objects can store both simple attributes (e.g., string, int, double, boolean) and 
complex attributes (i.e., other business objects).  An attribute can be multi-valued, which 
means it can be stored as an array.  

In this lab, you will create several business objects.  Specifically, you will create 
Customer, Address, Order, and OrderItem business objects which are inter-related.  A 
Customer can have multiple Orders.  An Order can have multiple OrderItems.  An Order 
can also have a shipping address and billing address, both of which are of type Address.

Following this exercise, you should be able to:

● Create a default namespace.
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● Create a business integration module.

● Create business objects using the Business Object Editor.

● View the physical files created by WID

Part 1 - Create a Default Namespace
Namespaces are used in XML to uniquely identify XML elements and attributes.  They 
help prevent collisions between elements and attributes with the same names. 
Namespaces are analogous to Java packages which uniquely identify class names.  When 
creating an XML schema, a target namespace is specified.  All elements and attributes 
defined in the schema belong to that target namespace.

In this part, you will create a default namespace that's used when creating business 
objects and other kinds of XML artifacts.  Namespaces typically correspond with a URI 
(usually a URL), since they must be unique and URIs are unique.  You will set the default 
namespace to http://www.webagesolutions.com.  Normally, you would set it to your 
company's URL.

__1. Select Window->Preferences from the menu bar.

__2. In the left pane, expand Business Integration and select Default Namespace.

__3. In the right pane, click the New button to create a new default namespace.

__4. Type Corporate Default in the Name field.

__5. Enter www.webagesolutions.com in the Pattern field.

__6. Click OK to create the namespace.
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__7. Click OK to close the preferences.

Part 2 - Create a Business Integration Module
In this part, you will create a business integration module (module for short) for storing 
your business objects. 

__1. Select File > New > Mediation Module from the menu bar.  

__2. Enter CustomerOrder for the Module Name.

__3. Select WebSphere ESB Server 7.0 as Target runtime environment.

__4. Uncheck Create mediation component.

__5. Uncheck Open module assembly diagram.
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__6. Click Finish.  The CustomerOrder project should appear in the Business 
Integration view.

Part 3 - Create the Customer Business Object 
In this part, you will create the Customer business object using the Business Object 
Editor.  You will add simple fields to it, such string, boolean, and int.  You will also see 
how you can specify metadata for the fields, including whether or not its required, has 
enumerated values and/or matches a pattern.

__1. In the Business Integration view, under the CustomerOrder module, right click 
Data Types and select New > Business Object.

__2. Notice that the Namespace field is pre-populated with the default you set earlier: 
http://www.webagesolutions.com.  

__3. Enter Customer in the Name field.
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__4. Click Finish.

The Customer business object will be created and should automatically be opened inside 
the Business Object Editor.

__5.  Now let's define our Customer business object.  Select the Customer object.  Then 
click the field icon (F in a blue circle) to add a field to the business object.  A field called 
field1 should be added to the Customer object of type string.

__6. Click on field1 and rename it as customerId

You may need to hit <ENTER> to accept the new name before you can make other 
changes.

__7. Click on string and select int from the drop-down.
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__8. Using the procedure above, add the following fields:

Name Type

customerType string

active boolean

firstName string

lastName string

homePhone string

workPhone string

Your business object should look as follows:

__9. Save your changes.

__10. Since the customerId uniquely identifies a customer, it should be required.  To 
specify this, right click on customerId and select Show in > Properties view from the 
menu.  

__11. The Properties view should appear at the bottom of WID.  Change the Minimum 
occurrences to 1.
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__12. It's also possible to specify that a field can only contain certain values using the 
enumerations feature.  For example, the customerType can only be set to the values 
silver, gold, or platinum.  Click on the customerType field in the Business Object Editor. 

__13. In the Properties view, check the Only permit certain values checkbox.  (you 
may need to scroll down)

__14. Select the Enumerations radio button.

__15. Click the Add button.

__16. Enter silver in the Add Enumeration dialog.

__17. Click OK.

__18. In the same way add gold and platinum in the list.
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__19. You can also specify a regular expression pattern that a field must match when 
being input.  The homePhone and workPhone fields should be entered in the format: xxx-
xxx-xxxx.  To accomplish this, click on the homePhone field in the Business Object 
Editor.  

__20. In the Properties view, check the Only permit certain values checkbox.  

__21. Then, click the Patterns radio button.

__22. Click Add.

__23. In the Regular Expression Wizard dialog, select Digit ( \d ) from the Token 
contents drop-down.  

__24. Then, click the Repeat radio button and type 3 in the text field to the right of it.  

__25. Then click the Add button.  

The Current Regular Expression field should now show \d{3} which means the user 
needs to type in 3 digits for the phone number.  We're not done yet.

__26. Type a dash (-) next to \d{3} in the Current regular expression field.

__27. Click the Add button again to append \d{3} to the regular expression. 
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__28. Type another dash (-) next to \d{3}-\d{3} in the Current regular expression field. 

__29. Change the Repeat value from 3 to 4 and click Add again.  Voila!  Your regular 
expression is complete.

__30. WID also allows you test your regular expression to make sure you input it 
correctly.  To do so, click the Next button.  

__31. In the Sample text field, enter 123-456-7890  

__32. The message The text matches the regular expression should appear at the top of 
the dialog.

Try entering an wrongly formatted phone number.

__33. Click Finish.

__34. Repeat the process for the workPhone. 

__35. Save your changes.

__36. Close the file.

Part 4 - Create the Address Business Object
Up until this point, you've created fields having only simple data types.  It's also possible 
to create fields having complex data types.  The complex data types are themselves other 
business objects.  For example, an Order, which you will be creating shortly, has a 
shipping address and a billing address.  Since an Order has multiple addresses rather than 
just one, it's recommended to create another business object called Address, instead of 
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simply adding address fields to the Order business object.  In this part, you'll create the 
Address business object.  

__1. In the Business Integration view, right click on Data Types under CustomerOrder 
and select New > Business Object.

__2. Type Address in the Name field.  

__3. Click Finish.

The Address business object will be created and should automatically be opened inside 
the Business Object Editor.

__4. Enter the following fields:

Name Type Minimum 
ocurrences

addressId int 1

street1 string

street2 string

city string

state string

zip string

country string

name string
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Your business object should look as follows:

Note

You added a name field to Address, since a customer may have an order shipped to an 
address where she doesn't live.  The name would correspond with the name of the 
person who lives at that address. 

__5. Save your changes.

__6. Close the file.

Part 5 - Create the Order and OrderItem Business Objects
In this part, you'll create the Order business object.  You'll use the Address business 
object you created in the last part when declaring the shippingAddress and billingAddress 
fields.  You'll also add an orderItems field to the Order business object.  When declaring 
the orderItems field, you'll create an OrderItem business object on the fly, since an order 
can consist of multiple order items.  Afterwards, you'll complete the Customer business 
object by adding a field called orders to it of type Order.  Since both orderItems and 
orders are multi-valued, you'll declare them as arrays.  

When you create a business object on the fly (e.g., OrderItem) when defining the parent 
business object, this is referred to as a top-down based approach to business object 
development.  On the other hand, when you create the business object in advance (e.g., 
Address and Order), this is referred to as a bottom-up based approach to business object 
development.  Both approaches are valid.

__1. In the Business Integration view, right click on Data Types under CustomerOrder 
and select New > Business Object.
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__2. Type Order in the Name field.  

__3. Click Finish.

__4. The Order business object will be created and should automatically be opened 
inside the Business Object Editor.  Enter the following fields:

Name Type Minimum 
ocurrences

orderId int 1

orderDate date

shippingAddress Address

billingAddress Address

__5. When specifying the Address type, you'll need to scroll to the bottom of the type 
drop-down, since that's where all business objects are located.

Your business object should look as follows:

Notice that Address was added to the diagram and two arrows were drawn between 
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Order and Address showing the parent-child relationship between the two business 
objects.  

__6. Click on the plus (+) sign next to Address to expand it and see its fields.  Use the 
bottom arrow to scroll through its fields.  

Also, notice that you can't edit any of Address's fields.  To edit Address, you can simply 
double click on Address and it will open up in the Business Object editor.

__7. Return to the business object editor showing the Order business object if you are 
not there already.  

__8. Add another field named orderItems

__9. This time, when specifying the data type, click the New... option in the drop-down. 
It's located at the top of the drop-down.

__10. In the New Business Object dialog, type OrderItem in the Name field and click 
Finish.  

The OrderItem business object will be created and should automatically be opened 
inside the Business Object Editor.  

__11. For the OrderItem business object, enter the following fields:

Name Type Minimum 
ocurrences

itemId int 1

description string

quantity int

price float

__12. Your business object should look as follows:

Copyright 2011 Web Age Solutions Inc. 33

EVALUATIO
N O

NLY



__13. Save your changes and close the OrderItem file.

Back in the Order Business Object Editor, you will specify that an Order can have more 
than one OrderItem.

__14. Click on the orderItems field.  

__15. In the Properties view, from the drop-down change the Maximum occurrences 
to unbounded.

__16. Click anywhere in the editor.

Notice that a set of square brackets ([ ]) now appears to the right of orderItems 
indicating that it contains an array of OrderItem business objects.

__17. Save your changes and close the file.

__18. Last but not least, open the Customer business object.

__19. Add a field to the Customer business object named orders of type Order.  You 
may need to click the Customer business object in the editor to select it first.

__20. Change the Maximum occurrences  to unbounded to declare the field as an array.
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Note

WID allows you to view business objects only one level deep.  Consequently, you can't 
view OrderItem in the Customer's Business Object Editor.

__21. Save your changes.

__22. It's also possible to display the Customer business object in a tabular format.  To do 
so, click on the icon on the far right of the editor toolbar.

__23. Now you're in the table view.  In addition to displaying the field names and data 
types for the business object and its children, the table view displays their default values 
(if any) and multiplicity (number of minimum occurrences and maximum occurrences).   

Also observe the following:

● customerId has a Min Occurs and Max Occurs both set to 1.  This means that it 
must have one and only one value, since we declared it as a required field.

● orders has a Min Occurs set to 0 and a Max Occurs set to unbounded.  This 
means that a Customer can have 0 or more orders.  These values are used when 
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specifying arrays.  Likewise, orderItems has a Min Occurs set to 0 and a Max 
Occurs set to unbounded, since it's also an array.

● All of the other attributes have a Min Occurs of 0 and Max Occurs of 1, which 
means they're optional fields (as opposed to required fields)

__24. Switch back to the diagram view by clicking on the icon on the far right of the 
editor toolbar.  Notice the icon has changed.

__25. Close all open files.  Save if there are any unsaved changes.

Congratulations!  You've successfully created a hierarchy of business objects.

Part 6 - View the Physical Files
In this part, you'll see the files that get created behind the scenes when you create a 
business object.  Specifically, you'll see that an XML schema definition (XSD) was 
created for each business object. 

WID tries to keep things as "logical" as possible to make things easier on the integration 
developer, since he/she is only required to have basic programming skills (knows how to 
create loops, conditionals, and perform string manipulation).  WID provides graphical 
editors wherever possible to simplify and abstract complex programming details.  

__1. In the Business Integration view, right click on the CustomerOrder module and 
select Show Files.

__2. WID will open the Physical Resources view and stack it on top of the Business 
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Integration view.  Notice that the business objects you created are located directly 
underneath the CustomerOrder project and correspond with XSDs (can tell based on the 
file extension).

Note

In a future lab, you will begin to use folders when creating business objects and other 
kinds of SCA artifacts, so that the resulting files are better organized.  This is especially 
important when creating larger projects.

__3. Double click on Customer.xsd.  Notice that WID still opens it with the Business 
Object Editor.  

__4. To change this behavior, close the file.  Then right click on it and select Open With-
>Text Editor from the menu.  WID will now open it with a text editor so you can view 
the actual XML.  

Notice the following:

● The targetNamespace attribute is set to http://www.webagesolutions.com, 
which is the default namespace we set at the beginning of the lab.

● The XML schema file Order.xsd is included so the Customer XSD can reference 
the Order element.

● Customer is declared as a complex type, since it contains child elements 
(correspond with the fields we declared).

● The Max Occurs and Min Occurs columns you saw earlier in the Business Object 
Editor's table view correspond with the maxOccurs and minOccurs XSD 
attributes.

<?xml version="1.0" encoding="UTF-8"?>

<xsd:schema targetNamespace="http://www.webagesolutions.com"
   xmlns:xsd="http://www.w3.org/2001/XMLSchema"
   xmlns:bons0="http://www.webagesolutions.com">
   <xsd:include schemaLocation="Order.xsd"></xsd:include>
   <xsd:complexType name="Customer">
      <xsd:sequence>
         <xsd:element minOccurs="1" name="customerId"
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            type="xsd:int">
         </xsd:element>
         ...
      </xsd:sequence>
   </xsd:complexType>
</xsd:schema>

__5. Close the file.

Note

You could have also opened the file with the full XML Schema editor.  We opened it 
with the text editor just to see the contents easily.

__6. The Customer.xsd file will automatically be opened with the text editor from this 
point forward unless you change it back to open with the Business Object Editor.  To 
change this, right click on the file and select Open With > Business Object Editor.  

__7. Close the Business Object Editor.  

__8. Switch back to the Business Integration view.

Part 7 - Review
In this lab, you set a default namespace within WID for any XML files you create.  Next, 
you created four inter-related business objects:  Customer, Address, Order, and 
OrderItem.  Business objects are used to represent data in a SOA.  The business objects 
get passed to and between service components when they communicate with one another 
by invoking each other's operations.  You used the Business Object Editor, which is quite 
powerful, to create the business objects.  You also switched to the Physical Resources 
view and saw that WID creates XML schema files behind the scenes to represent the 
business objects.
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	Lab 1 -  Basic Mediation Flow Development
	Part 1 -  Create a Mediation Module
	__1.  From the menubar, select File > New > Mediation Module.
	__2.  Enter the following values:
	__3.  Click Finish.
	__4.  WID will create the mediation module. In the Business Integration view, under the Projects section, verify that SimpleModule is shown.

	Part 2 -  Study the Project Structure
	__1.  From the menubar, select Window > Open Perspective > Other.
	__2.  Select Java EE.
	__3.  Click OK.
	__4.  Notice, three projects have been created for SimpleModule:
	__5.  Close the Java EE perspective by selecting Window > Close Perspective.

	Part 3 -  Create a Service Interface
	__1.  Expand SimpleModule  project.
	__2.  Right click Interfaces and select New > Interface.
	__3.  Enter Greeting as the name of the interface.
	__4.  Click Finish.
	__5.  In the editor, click the Add Request Response Operation toolbar icon to add a new operation.
	__6.  Change the name of the operation to sayHello
	__7.  Change the name of the input parameter to name 
	__8.  Change the name of the output parameter to message
	__9.  Save and close the editor.

	Part 4 -  Create the Mediation Flow
	__1.  Right click Integration Logic and select New > Mediation Flow.
	__2.  Enter GreeterFlow as the name.
	__3.  Click Next.
	__4.  Click the Add button for Sources interfaces.
	__5.  The Greeting interface should be selected, just click OK.
	__6.  Click the Add button for Target references.
	__7.  The Greeting interface should be selected, just click OK.
	__8.  Click Finish. WID will create the mediation flow and open it in the editor.

	Part 5 -  Design the Mediation Flow
	__1.  At the top of the editor, you will see two interfaces.
	__2.  Click over the sayHello operation of the source interface.  The Select a Mediation Flow Template dialog will open.
	__3.  Click the Service Integration link.
	__4.  The Select the Services window will open, click Add.
	__5.  The Select Reference Operation window will open showing the sayHello Target operation of GreetingPartner, click OK.
	__6.  Back in the Select the Services window, the list will be updated with the selected target. click OK.
	__7.  The Request tab will open.
	__8.  Connect the output terminal of sayHello of Greeting (the source interface) to the input terminal of sayHello of GreetingPartner (target interface).
	__9.  Click the Response tab to open the response flow design.
	__10.  Connect the output terminal of sayHello of GreetingPartner (the target interface) to the input terminal of sayHello of Greeting.  Make sure you select the pointed output terminal of the GreetingPartner and not the rectangular fail terminal.
	__11.  Click the Overview tab and check that the source and target are connected now.
	__12.  Save and close the editor.
	__13.  Open the Problems view and expand Warnings. You should notice a warning about "A direct connection exists from the mediation input to output." This is fine for our very simple mediation flow.

	Part 6 -  Create Service Provider
	__1.  Double click Assembly Diagram to open it.
	__2.  Right click the white area of the editor and select Add > Java.
	__3.  Change the name of the Java component to GreeterBean
	__4.  Right click the component and select Add > Interface.
	__5.  Select the Greeting interface and click OK.
	__6.  Right click the component again and select Generate Implementation.
	__7.  Click New Package.
	__8.  Enter com.webage.greet as the package name.
	__9.  Click OK to create the package.
	__10.  Click OK to select the new package for the implementation.
	__11.  Change the implementation of the sayHello method as follows.
	__12.  Save all files (Control+Shift+S).
	__13.  Close the Java editor.

	Part 7 -  Wire the Components
	__1.  Make sure that the assembly diagram is still open. If not open it.
	__2.  Drag the GreeterFlow mediation flow on to the diagram.
	__3.  Hover the mouse over the reference partner of the mediation flow and a lollipop will open up.
	__4.  Drag the lollipop and drop it over the interface of the Java implementation. This will connect the two as shown below.
	__5.  Save changes.

	Part 8 -  Deploy the Application to Server
	__1.  Open the Servers view.
	__2.  Start the server. Wait until the status changes to Started.
	__3.  Right click the server again and select Add and Remove Projects...
	__4.  Select SimpleModuleApp and click Add.
	__5.  Click Finish.
	__6.  WID will start publishing the application files. Wait for the status of the server to change to Synchronized.

	Part 9 -  Test the Application
	__1.  Open the assembly diagram if it is not open.
	__2.  Right click any white area of the assembly diagram and select Test Module.
	__3.  Verify the Component is set to GreeterFlow. That means, the test client will invoke the operations of the mediation flow.  It may default to GreeterBean, but this would not test the whole flow.
	__4.  Verify that the sayHello operation is selected since that is the only operation available from the interface.
	__5.  In the Initial request parameters table, set the value of the name parameter to something.
	__6.  Under Events click the Continue toolbar button to invoke the operation.
	__7.  In the Deployment Location dialog, Expand WebSphere Enterprise Service Bus  Server and select WebSphere ESB Server v7.0 at localhost.
	__8.  Also, check Use this as the default and do not ask again.
	__9.  Click Finish.
	__10.  If asked, check the checkbox to always use the same authentication settings and click OK in the User Login dialog. Security is enabled for the server. This is where the administrative user ID and password is entered. Without a valid password, publishing will fail.
	__11.  After the test ends, the Return parameters table will show the reply.
	__12.  Open the Server Logs view. At the very bottom, the output from the Java component will be shown.
	__13.  Close the test page without saving.

	Part 10 -  Configure Build Activities
	__1.  Open the Build Activities view.
	__2.  Close all open files. (Ctrl+Shift+W)
	__3.  Stop the server.

	Part 11 -  Review

	Lab 2 -  Using Mediation Primitives
	Part 1 -  Add Primitive to Request Flow
	__1.  Start the Server.
	__2.  Expand SimpleModule > Integration Logic > Mediation Flows.
	__3.  Open GreeterFlow mediation flow in the editor by double clicking on it.
	__4.  Click sayHello operation in the source interface. This will open the Request flow in the editor.
	__5.  In the request message flow, select the connection between  Greeting / sayHello and GreetingPartner / sayHello.
	__6.  Press the delete key to remove the connection.
	__7.  On the left hand side of the editor, expand the Tracing section.
	__8.  Drag and drop the Message Logger primitive on the editor.
	__9.  Connect the output terminal of Greeting  / sayHello to the input terminal of MessageLogger1.
	__10.  Connect the output terminal of MessageLogger1 to the input terminal of GreetingPartner  / sayHello.
	__11.  Select MessageLogger1.
	__12.  Open the Properties view.
	__13.  Select the Details tab.
	__14.  Change the Logging type from Database to Custom.

	Part 2 -  Add Primitive to Response Flow
	__1.  Click the Response tab to switch to the response flow.
	__2.  Follow the steps in the previous part to insert a logger primitive in the flow.
	__3.  Change the logging type of the logger to custom.
	__4.  Save the mediation flow.

	Part 3 -  Publish Changes
	__1.  Open the Build Activities tab.
	__2.  Click Update Running Servers.
	__3.  Make sure WebSphere ESB Server v7.0 is selected.
	__4.  Check the 'Do not show this dialog again' box.
	__5.  Press the Publish button.

	Part 4 -  Test
	__1.  Open the Assembly Diagram.
	__2.  Right click the white area and select Test Module.
	__3.  Set the component to GreeterFlow.  It may default to GreeterBean, but this would not test the whole flow.
	__4.  Enter a name in the input table.
	__5.  Click the Continue toolbar button under Events.
	__6.  Close the test without saving it.
	__7.  Open a command prompt window.
	__8.  Enter the following command:
	__9.  List all message log files:
	__10.  You should see MessageLog.log that contains request and response messages.
	__11.  View the request message as follows.
	__12.  There locate the request and response messages as shown below:
	__13.  Close the Command prompt window.
	__14.  Back in WID, close all open files.

	Part 5 -  Review

	Lab 3 -  Create Business Objects
	Part 1 -  Create a Default Namespace
	__1.  Select Window->Preferences from the menu bar.
	__2.  In the left pane, expand Business Integration and select Default Namespace.
	__3.  In the right pane, click the New button to create a new default namespace.
	__4.  Type Corporate Default in the Name field.
	__5.  Enter www.webagesolutions.com in the Pattern field.
	__6.  Click OK to create the namespace.
	__7.  Click OK to close the preferences.

	Part 2 -  Create a Business Integration Module
	__1.  Select File > New > Mediation Module from the menu bar.  
	__2.  Enter CustomerOrder for the Module Name.
	__3.  Select WebSphere ESB Server 7.0 as Target runtime environment.
	__4.  Uncheck Create mediation component.
	__5.  Uncheck Open module assembly diagram.
	__6.  Click Finish.  The CustomerOrder project should appear in the Business Integration view.

	Part 3 -  Create the Customer Business Object 
	__1.  In the Business Integration view, under the CustomerOrder module, right click Data Types and select New > Business Object.
	__2.  Notice that the Namespace field is pre-populated with the default you set earlier:  http://www.webagesolutions.com.  
	__3.  Enter Customer in the Name field.
	__4.  Click Finish.
	__5.   Now let's define our Customer business object.  Select the Customer object.  Then click the field icon (F in a blue circle) to add a field to the business object.  A field called field1 should be added to the Customer object of type string.
	__6.  Click on field1 and rename it as customerId
	__7.  Click on string and select int from the drop-down.
	__8.  Using the procedure above, add the following fields:
	__9.  Save your changes.
	__10.  Since the customerId uniquely identifies a customer, it should be required.  To specify this, right click on customerId and select Show in > Properties view from the menu.  
	__11.  The Properties view should appear at the bottom of WID.  Change the Minimum occurrences to 1.
	__12.  It's also possible to specify that a field can only contain certain values using the enumerations feature.  For example, the customerType can only be set to the values silver, gold, or platinum.  Click on the customerType field in the Business Object Editor.  
	__13.  In the Properties view, check the Only permit certain values checkbox.  (you may need to scroll down)
	__14.  Select the Enumerations radio button.
	__15.  Click the Add button.
	__16.  Enter silver in the Add Enumeration dialog.
	__17.  Click OK.
	__18.  In the same way add gold and platinum in the list.
	__19.  You can also specify a regular expression pattern that a field must match when being input.  The homePhone and workPhone fields should be entered in the format: xxx-xxx-xxxx.  To accomplish this, click on the homePhone field in the Business Object Editor.  
	__20.  In the Properties view, check the Only permit certain values checkbox.  
	__21.  Then, click the Patterns radio button.
	__22.  Click Add.
	__23.  In the Regular Expression Wizard dialog, select Digit ( \d ) from the Token contents drop-down.  
	__24.  Then, click the Repeat radio button and type 3 in the text field to the right of it.  
	__25.  Then click the Add button.  
	The Current Regular Expression field should now show \d{3} which means the user needs to type in 3 digits for the phone number.  We're not done yet.
	__26.  Type a dash (-) next to \d{3} in the Current regular expression field.
	__27.  Click the Add button again to append \d{3} to the regular expression. 
	__28.  Type another dash (-) next to \d{3}-\d{3} in the Current regular expression field.  
	__29.  Change the Repeat value from 3 to 4 and click Add again.  Voila!  Your regular expression is complete.
	__30.  WID also allows you test your regular expression to make sure you input it correctly.  To do so, click the Next button.  
	__31.  In the Sample text field, enter 123-456-7890  
	__32.  The message The text matches the regular expression should appear at the top of the dialog.
	__33.  Click Finish.
	__34.  Repeat the process for the workPhone. 
	__35.  Save your changes.
	__36.  Close the file.

	Part 4 -  Create the Address Business Object
	Up until this point, you've created fields having only simple data types.  It's also possible to create fields having complex data types.  The complex data types are themselves other business objects.  For example, an Order, which you will be creating shortly, has a shipping address and a billing address.  Since an Order has multiple addresses rather than just one, it's recommended to create another business object called Address, instead of simply adding address fields to the Order business object.  In this part, you'll create the Address business object.  
	__1.  In the Business Integration view, right click on Data Types under CustomerOrder and select New > Business Object.
	__2.  Type Address in the Name field.  
	__3.  Click Finish.
	__4.  Enter the following fields:
	__5.  Save your changes.
	__6.  Close the file.

	Part 5 -  Create the Order and OrderItem Business Objects
	__1.  In the Business Integration view, right click on Data Types under CustomerOrder and select New > Business Object.
	__2.  Type Order in the Name field.  
	__3.  Click Finish.
	__4.  The Order business object will be created and should automatically be opened inside the Business Object Editor.  Enter the following fields:
	__5.  When specifying the Address type, you'll need to scroll to the bottom of the type drop-down, since that's where all business objects are located.
	__6.  Click on the plus (+) sign next to Address to expand it and see its fields.  Use the bottom arrow to scroll through its fields.  
	__7.  Return to the business object editor showing the Order business object if you are not there already.  
	__8.  Add another field named orderItems
	__9.  This time, when specifying the data type, click the New... option in the drop-down.  It's located at the top of the drop-down.
	__10.  In the New Business Object dialog, type OrderItem in the Name field and click Finish.  
	__11.  For the OrderItem business object, enter the following fields:
	__12.  Your business object should look as follows:
	__13.  Save your changes and close the OrderItem file.
	__14.  Click on the orderItems field.  
	__15.  In the Properties view, from the drop-down change the Maximum occurrences  to unbounded.
	__16.  Click anywhere in the editor.
	__17.  Save your changes and close the file.
	__18.  Last but not least, open the Customer business object.
	__19.  Add a field to the Customer business object named orders of type Order.  You may need to click the Customer business object in the editor to select it first.
	__20.  Change the Maximum occurrences  to unbounded to declare the field as an array.
	__21.  Save your changes.
	__22.  It's also possible to display the Customer business object in a tabular format.  To do so, click on the icon on the far right of the editor toolbar.
	__23.  Now you're in the table view.  In addition to displaying the field names and data types for the business object and its children, the table view displays their default values (if any) and multiplicity (number of minimum occurrences and maximum occurrences).   
	__24.  Switch back to the diagram view by clicking on the icon on the far right of the editor toolbar.  Notice the icon has changed.
	__25.  Close all open files.  Save if there are any unsaved changes.

	Part 6 -  View the Physical Files
	__1.  In the Business Integration view, right click on the CustomerOrder module and select Show Files.
	__2.  WID will open the Physical Resources view and stack it on top of the Business Integration view.  Notice that the business objects you created are located directly underneath the CustomerOrder project and correspond with XSDs (can tell based on the file extension).
	__3.  Double click on Customer.xsd.  Notice that WID still opens it with the Business Object Editor.  
	__4.  To change this behavior, close the file.  Then right click on it and select Open With->Text Editor from the menu.  WID will now open it with a text editor so you can view the actual XML.  
	__5.  Close the file.
	__6.  The Customer.xsd file will automatically be opened with the text editor from this point forward unless you change it back to open with the Business Object Editor.  To change this, right click on the file and select Open With > Business Object Editor.  
	__7.  Close the Business Object Editor.  
	__8.  Switch back to the Business Integration view.

	Part 7 -  Review

	Lab 4 -  Create a Service Interface
	Part 1 -  Create an Interface
	__1.  In the Business Integration view, expand CustomerOrder.  
	__2.  Right click on Interfaces and select New > Interface.
	__3.  Type CustomerOrder in the Name field.  Do not press Finish yet.
	__4.  Notice that the Namespace field is pre-populated.  It starts with the default namespace, but it ends with the interface name.  Instead, we only want it set to the default namespace.  (This is the only wizard that appends anything to the default namespace.)  To remedy this, uncheck Default and remove /CustomerOrder. The namespace should now be http://www.webagesolutions.com
	__5.  Click Finish.
	__6.  To create the operation, click the Add Request Response Operation icon in the toolbar (first icon on the left).
	__7.  Click on operation1 and rename it createCustomer
	__8.  Click on input1 and rename it customer
	__9.  Click on string and select Customer from the drop-down.
	__10.  Click on output1 and rename it customerId
	__11.  Click on string and select int from the drop-down.
	__12.  Your operation should look as follows:
	__13.  Similarly, create the findCustomer operation. But as Input use customerId as type int and as Output define customer as type Customer. 
	__14.  Your interface should look as follows:
	__15.  Save your changes and close the file.
	__16.  Right click on the CustomerOrder project in the Business Integration view and select Show Files.  Notice that CustomerOrder corresponds with the file CustomerOrder.wsdl.
	__17.   Open CustomerOrder.wsdl as text editor.  Observe the following:
	__18.  Close the file.
	__19.  To reset the file to open with the Interface Editor, right click on the file and select Open With > Interface Editor.
	__20.  Close the file.
	__21.  Switch back to the Business Integration view.

	Part 2 -  Review

	Lab 5 -  Manipulating Business Objects with SDO API
	Part 1 -  Create a Java Component
	__1.  In the Business Integration view, expand the CustomerOrder project and open the Assembly Diagram.
	__2.  Add a Java component to the diagram by clicking on the Java icon in the palette (left side of editor) and clicking inside the assembly diagram.
	__3.  Rename the component CustomerOrder by right clicking on and selecting selecting Rename.
	__4.  Drag and drop the CustomerOrder interface from the Business Integration view on top of the CustomerOrder component in the assembly diagram.  
	__5.  Right click on CustomerOrder and select Show in > Properties view.  
	__6.  Click on the Details tab.  Notice that the CustomerOrder interface appears underneath the Interfaces node.  
	__7.  Expand the interface and you will see its operations.
	__8.  In the assembly diagram, right click on CustomerOrder and select Generate Implementation.  
	__9.  In the Generate Implementation dialog, click the New Package... button.
	__10.  In the Create Package dialog, type com.webage and click OK.
	__11.  Select the com.webage package you created and click OK.
	__12.  Switch back to the Assembly Diagram.  
	__13.  Save your changes to the Assembly Diagram.  
	__14.  Switch back to the Java editor for  CustomerOrderImpl.
	__15.  From the menu, select Window > Show View > Outline.
	__16.  On the Outline view notice that CustomerOrderImpl has two public methods which correspond with the operations you defined in your interface.
	__17.  Click on the createCustomer(DataObject) method.  WID will jump to the method inside the Java editor and highlight the method name.  The Outline view provides an easy way to navigate a Java file, as well as other types of files.  

	Part 2 -  Implement createCustomer Operation
	__1.  Add the following code in bold after the CustomerOrderImpl class declaration to instantiate a Logger object:
	__2.  A red X will appear in the editor indicating a compile time error.  Fix this error by importing the Logger class into your class.  To do so, right click in the editor and select Source > Organize Imports.  
	__3.  In the Organize Imports dialog, select java.util.logging.Logger and click Finish.
	__4.  Save your changes.  The red X should have disappeared.    
	__5.  Replace the code inside the createCustomer method with the following code in bold.  The code logs the name of the operation to the server log file (SystemOut.log), calls a helper method you'll add next to log the Customer object that was passed in, and returns the customer id:
	__6.  Next, add the logCustomer method beneath the createCustomer method:
	__7.  logCustomer delegates to logOrder for logging each Order business object, so add the logOrder method beneath the logCustomer method.  
	__8.  Press Ctrl-Shift-O to Organize Imports.  
	__9.  Select java.util.Iterator from the Organize Imports dialog and click Next.
	__10.  Select java.util.List from the Organize Imports dialog and click Finish.
	__11.  Save your changes.  There should be no errors in the Problems view.

	Part 3 -  Implement findCustomer Operation
	In this part, you will implement the findCustomer operation.  In real life, your Java component would retrieve a record from a database and construct a DataObject based on the data.  To simplify things, you'll construct a fake DataObject and return it to the caller. To construct the Customer DataObject, you'll use the BOFactory class.  
	__1.  Delete the code inside the findCustomer method.
	__2.  Verify that the findCustomer method is declared as follows. If not notify your instructor.
	__3.  Add the following code to the top of the findCustomer method. The code logs the name of the operation and the input customer id to the server log file (SystemOut.log):
	__4.  Next, add the code to locate the BOFactory using the ServiceManager class.  The ServiceManager class is used for locating services given an SCA service reference.
	__5.  Add the following line of code to create the Customer business object.  The create method takes two parameters, the first of which corresponds with the namespace of the business object and the second of which corresponds with the name of the business object.  Both of these values can be found in the Properties view of the Business Object Editor.
	__6.  Now that you've created the business object, add the following code to populate its scalar (single-value) fields:
	__7.  Save your changes.
	__8.  Add the following code to create the orders field:
	__9.  Add the following code to create an order:
	__10.  Add the following code to populate the orderId and orderDate fields:
	__11.  Add the following code to populate the shippingAddress and billingAddress fields.  
	Notice that when a DataObject has a scalar (single-value) field that is itself a DataObject, you must use its createDataObject(String field) method instead of the BOFactory's create method to create an instance of the DataObject.  This simplifies coding, since the BOFactory's method requires an extra parameter (i.e., namespace).
	__12.  Add the following code to create the orderItems field and populate it:
	__13.  Now that you've finished constructing your order items, add the order items to the order:
	__14.  Now that you've finished constructing your order, add the order to the orders list. 
	__15.  Now that you've finished constructing your order list, add the orders list to the customer.
	__16.  Log the customer returned and return the customer to the caller by adding the final two lines of code to the findCustomer method:
	__17.  Finally, add the createOrderItem helper method below the findCustomer method:
	__18.  Press Ctrl-Shift-O to Organize Imports.  
	__19.  Select com.ibm.websphere.bo.BOFactory from the Organize Imports dialog and click Next.
	__20.  Select java.util.Date from the Organize Imports dialog and click Next.
	__21.  Select java.util.Calendar from the Organize Imports dialog and click Finish.
	__22.  Save your changes.  
	__23.  Make sure there are no errors in the Problems view before proceeding to the next part.
	__24.  Close all open files.

	Part 4 -  Test Java Component
	__1.  If the server is not started, then start it.
	__2.  Once the server shows a Started status, right click the server and select Add and Remove Projects.
	__3.  Select CustomerOrderApp and click Add to move the CustomerOrderApp project to the Configured projects list.
	__4.  Click Finish.
	__5.  Wait for publishing to end. The Status of the server should become Synchronized. Expand to see all project running.
	__6.  Open the Assembly Diagram in the CustomerOrder project. 
	__7.  Right click on CustomerOrder and select Test Component.  
	__8.  Under Detailed Properties, set the component to be tested to CustomerOrder. The choices should be as follows:
	In order to unit test the createCustomer operation, we need to provide some Customer data, which corresponds with the customer variable.  
	__9.  Enter the following client data by double clicking on the filed object next to each value:  
	Your Initial request parameters should look as follows:
	__10.  Right click on orders and select Add Elements...
	__11.  The Add Element dialog will appear and allows you add one or more elements to the orders array.  Leave the default value of 1 and click OK.
	__12.  Expand orders, shippingAddress, and billingAddress and enter the following data:
	__13.  Now, right click on orderItems and select Add Elements...
	__14.  Leave the default value of 1 in the Add Element dialog and click OK.
	__15.  Enter the following data:
	Your Initial request parameters should look as follows:
	__16.  Now that you've input your data, we can proceed with the test.  Under the Events heading, click the Continue button.
	__17.  Expand WebSphere Enterprise Service Bus Server  and select WebSphere ESB Server v7.0 at localhost.
	__18.  Check Use this as the default and do not ask again checkbox. 
	__19.  Click Finish.
	__20.  Accept the default user ID and password if prompted.
	__21.  After the test finishes running, you should see both Invoke (CustomerOrder:createCustomer) and Return(CustomerOrder:createCustomer) listed in the Events panel, since the createCustomer operation is a request-response operation.
	You should also see in the Return parameters pane that a customerId of 0 was returned, since that's the value we supplied as an input.
	__22.  From the menu, select Window > Show View > Console.  
	__23.  Now look in the Console view.  You should see the following messages at the end of the list:
	__24.  Click the Invoke icon under the Events heading to run another test.
	__25.  Now  test the findCustomer operation by selecting findCustomer from the Operation drop-down under Detailed Properties.
	__26.  Leave the customerId set to 0 and click the Continue button.
	__27.  Examine the customer that gets returned.  It should match the one that you constructed inside the findCustomer method. 
	__28.   Notice the customer is also printed to the Console view.
	__29.  Do not close the test as you will use it in the next section.

	Part 5 -  Rerunning a Test
	__1.  If you have closed the CustomerOrderImpl class reopen it by expanding Integration Logic > Java Usages in the CustomerOrder project in the Business Integration view and double clicking on CustomerOrderImpl.
	__2.  Introduce a minor bug in the logCustomer method.  Change:
	__3.  Save your changes.
	__4.  Look in the Servers view.  The state of the server should be Republish, since you changed your code, but didn't deploy the changed code to the server.  
	__5.  To remedy this, right click on the server and select Publish.
	__6.  After publishing finishes, in the Servers view, the state of the server should now be Synchronized.
	__7.  You should see the following message in the Console view with a recent time stamp Application started: CustomerOrderApp
	__8.  Switch back to the test editor.
	__9.  In the Events list, Re-run the createCustomer by right clicking on Invoke (CustomerOrder:createCustomer) and selecting Rerun.
	__10.  This time when the test executes, you'll see the following exception in the Exception trace box, which is what we expected:
	__11.  Fix the problem and save the file, publish to the server, and re-run the test.  The test should complete successfully.

	Part 6 -  Storing Test Data in the Data Pool
	Aside from being able to re-run tests using the Integration Test Client, you can also save data to a data pool.  This way if you close the test editor and open a new one later, you don't need to re-enter your test data all over again.  The data in the data pool gets stored inside of your workspace.  In this part, you will store the customer business object you input to the data pool, including its children.  You will close the editor, open a new one, and use the test value from the data pool to run the createCustomer test again.
	__1.  To add the customer data to the data pool, click on Invoke (CustomerOrder:createCustomer) under Events (select the first one from the list as there will be several from rerunning the test).
	__2.  In the Initial Request Parameters box,  right click on customer and select Add Value to Pool...
	__3.  Click the Next button on the New Data Pool wizard.
	__4.  Click the New button next to the empty list of projects.
	__5.  Enter a project name of TestProject and press the Finish button.
	__6.  Enter a name of TestData for the data pool file and press the Finish button when your dialog appears as below.
	__7.  In the Value Name window, provide the following descriptive name for the test value:
	__8.  Click OK.
	__9.  To view values that you added to the pool, click the Data Pool (grid) icon in the Events toolbar.
	__10.  The Integration Test Client Data Pool dialog will display any test values you've added to the data pool.  Expand customer and its children to see the test data you input.  
	If you need to change a test value, you can do so from this dialog by modifying the corresponding business object's fields and clicking the Save button in the WID toolbar. 
	You can also remove a test value by right clicking on the test value and selecting Remove.  Then click Save.
	__11.  Close the data pool and the test editor.  Don't save your changes.
	__12.  In the Assembly diagram, right click on CustomerOrder and select Test Component.  
	__13.  Make sure createCustomer is the operation under test.  
	__14.  Right click on customer in the Initial request parameters box and select Use Value from Pool...
	__15.  Select customer – Linda Peterson and click OK.
	__16.  Click the Continue button on the Events toolbar to run the test.  It should run successfully.
	__17.  Close all open editors. Don't save changes in the test editors.
	__18.  Stop the server.

	Part 7 -  Review

	Lab 6 -  Web Service Binding and Data Transformation
	Part 1 -  The Business Problem
	Part 2 -  Import the Project
	__1.  From the menu bar select File > Import.
	__2.  Expand Other and select Project Interchange.
	__3.  Click Next.
	__4.  Using the browse button, select C:\LabFiles\DataMappingExample.zip
	__5.  Click Select all to select all projects.
	__6.  Click Finish.

	Part 3 -  Inspect Generic Data Types and Service Interface
	__1.  Expand DataMappingExample > Data Types.
	__2.  Open CustomerGBO. Note, customer's name is broken up in first and last name.
	__3.  Open StatusGBO. Note that the data type of the Code field is int.
	__4.  Expand Interfaces.
	__5.  Open the GenericAccountingSystem interface.
	__6.  Close all open files.

	Part 4 -  Inspect the Web Service
	__1.  Expand AccountingWeb > Java Resources > src > com.acme.accounting.
	__2.  Open ACMEAccounting.java.
	__3.  Note how various JAX-WS annotations like @WebService, @WebMethod, @WebResult and @WebParam are used to create the web service.
	__4.  Study the CustomerASBO and StatusASBO classes.
	__5.  Close all open files.

	Part 5 -  Import Web Service WSDL
	__1.  Start the server if it is not started. Wait for it to start.
	__2.  Deploy AccountingApp project to the server. Make sure to only add that project.  Wait for publishing to end.
	__3.  Right click the server and select Administration > Run administrative console.  If you are notified of a security certificate issue accept the certificate.
	__4.  Log in using user ID and password "admin".
	__5.  Click Applications → Application Types → WebSphere enterprise applications.
	__6.  Click AccountingApp.
	__7.  Click Publish WSDL files under the Web Services Properties section.
	__8.  Click AccountingApp_WSDLFiles.zip and save it somewhere in the hard drive.
	__9.  Open and Extract the ZIP file in C:\LabFiles folder.
	__10.  Log out of and close the admin console.
	__11.  If you are familiar with WSDL and XML schema, go to C:\LabFiles\AccountingApp.ear\AccountingWeb.war\generatedWSDLDir and study the WSDL and XSD files.
	__12.  In WID, right click the DataMappingExample project and select Import.
	__13.  Expand Business Integration and select WSDL and XSD.
	__14.  Click Next.
	__15.  Select Local WSDL or XSD file, or both.
	__16.  Click Next.
	__17.  Use the Browse button to select the C:\LabFiles\AccountingApp.ear\AccountingWeb.war\generatedWSDLDir folder and click OK.
	__18.  Check ACMEAccountingService.wsdl
	__19.  Accept the other defaults as shown below.
	__20.  Click Finish.

	Part 6 -  Inspect Application Specific Data Types and Service Interface
	__1.  Expand Data Types in the DataMappingExample project and note that customerASBO and statusASBO are defined.
	__2.  Open each data type and inspect.
	__3.  Expand Interfaces. Note that the ACMEAccounting interface has been defined.
	__4.  Open the interface and study the createAccount operation.
	__5.  Close all files.

	Part 7 -  Create the Mediation Flow
	__1.  Right click Integration Logic in the same project and select New > Mediation Flow.
	__2.  Enter AccountingMediation as the name and click the Next button.
	__3.  As source interface, add GenericAccountingSystem.
	__4.  As target interface, add ACMEAccounting.
	__5.  Click Finish.
	__6.  Click addCustomerAccount source method.
	__7.  Click Service integration. 
	__8.  Now, we will choose the target operation. Click Add.
	__9.  Make sure that the createAccount operation of ACMEAccountingPartner is selected. Click OK to select createAccount target operation.
	__10.  Click OK.
	__11.  The Request tab will open.
	__12.  Connect the addCustomerAccount output with the createAccount input.
	__13.  A message of incompatibility will appears:
	__14.  Click Transform the message using an XSL Transformation primitive.
	__15.  WID will add a XSLTransformation1 and link the objects.
	__16.  Select the XSL transformer primitive – XSLTransformation1.
	__17.  In the Properties view change the display name to CustomerGBO_To_CustomerASBO
	__18.  Click in the Name field and it will be changed too.
	__19.  In the Properties view click the Details tab.
	__20.  Click the New button to create a new XSL map.
	__21.  Change the name to CustomerGBO_To_CustomerASBO_Request
	__22.  Click Next.
	__23.  Click Finish.
	__24.  WID will create the map and open it in the editor. We will edit the map later after we are done designing the message flows. So close the map editor for now.
	__25.  Back in the mediation flow editor, click the Response tab at the top of the editor to start editing the response flow.
	__26.  Connect the output terminal of createAccount to the input terminal of addCustomerAccount.
	__27.  An incompatibility message will appear.
	__28.  Click Transform the message using an XSL Transformation primitive.
	__29.  Change the name of the transformation primitive to StatusASBO_To_StatusGBO
	__30.  In the Details tab of the transformation primitive property, click New.
	__31.  Change the name of the map to StatusASBO_To_StatusGBO_Response
	__32.  Click Next.
	__33.  Click Finish.
	__34.  Close the map editor. We will deal with that later.
	__35.  Save the mediation flow. Make sure that there are no error messages in the Problems view.
	__36.  Our mediation flow is now complete. Close the editor.

	Part 8 -  Complete the Data Maps
	__1.  In the same project, expand Transformations > Data Maps.
	__2.  Double click  CustomerGBO_To_CustomerASBO_Request to open it.
	__3.  Expand the objects to show all the fields as shown below.
	__4.  Mapping the Telephone field to phone field is straightforward. Click and drag the Telephone field and drop it on the Phone field. A Move mapping will be create between the two.
	__5.  First drag FirstName to name and create a basic Move map.
	__6.  Then drag LastName and drop it on the box for Move map. The mapping will automatically change to Concat.
	__7.  Click the box for Concat.
	__8.  In the Properties view, select the General tab.
	__9.  For the FirstName input field, set the Delimiter to a single space character.
	__10.  Save and close the map.
	__11.  Open StatusASBO_To_StatusGBO_Response map in the editor.
	__12.  Setup a basic Move mapping between errorMessage to Message.
	__13.  Setup a basic Move mapping between errorCode and Code.
	__14.  Save changes. Make sure that there are no errors in Problems view.
	__15.  Close all open files.

	Part 9 -  Test the Data Maps
	__1.  We will test CustomerGBO_To_CustomerASBO_Request. Right click the map and select Test.
	__2.  Enter some values in the input table as shown below.
	__3.  Click the Continue toolbar button.
	__4.  Verify that the output looks valid.
	__5.  Close the test editor without saving.

	Part 10 -  Setup Web Service Binding
	__1.  Open the assembly diagram for the DataMappingExample mediation module.
	__2.  Expand Web Service Ports and locate the ACMEAccountingPort that was created after the WSDL was imported.
	__3.  Drag  ACMEAccountingPort on the assembly diagram.
	__4.  Select SOAP1.1/HTTP option.
	__5.  Click Finish.
	__6.  Select the newly created import. 
	__7.  In the Properties view, select the Binding tab.
	__8.  Note the endpoint address.
	__9.  Drag the AccountingMediation mediation flow on the assembly editor.
	__10.  Wire the reference partner of the mediation flow to the service interface of the web service import.
	__11.  Save changes.

	Part 11 -  Test
	__1.  Start the server if it is not running.
	__2.  Add DataMappingExampleApp project to the server.
	__3.  Wait for publishing to end.
	__4.  Right click anywhere in the white area of the assembly diagram and select Test Module.
	__5.  Set the Component to AccountingMediation.
	__6.  Make sure that the operation is set to addCustomerAccount.
	__7.  In the input parameters table, enter some values.
	__8.  Click the Continue toolbar button.
	__9.  Expand WebSphere Enterprise Service Bus Server and select WebSphere ESB Server 7.0 at localhost and set it up as default as shown below.
	__10.  Click Finish.
	__11.  Make sure that in the return data, Code is 0.
	__12.  In the Console view, make sure that the output from the web service is shown.  You may need to click the double Xs to remove terminated launches for any mappings.
	__13.  Close the test but do not save it.

	Part 12 -  Expose Mediation Flow as Web Service
	__1.  Open the assembly diagram.
	__2.  Right click AccountingMediation and select Generate Export > Web Service Binding.
	__3.  Choose SOAP1.1/HTTP option.
	__4.  Click Finish.
	__5.  Select the newly created export component.
	__6.  In the Properties view select the Binding tab. Note the endpoint URL of the web service binding.
	__7.  Save changes.

	Part 13 -  Test the Exported Web Service
	__1.  Right click the server in the Servers view and select Publish.  Wait for the server to be synchronized.
	__2.  In the Business Integration view expand DataMappingExample > Web Service Ports.
	__3.  Right click the GenericAccountSystemExport1_GenericAccountSystemHttpPort and select Web Services > Test with Web Services Explorer.
	__4.  Under the list of operations click the link for the addCustomerAccount operation.
	__5.  Click the Add link next to the various customer properties like names and phone and add some sample data as shown below.
	__6.  Press the Go button under the parameters to submit the web service request.
	__7.  Check that you get a response in the Status area.  You may need to expand it to see the body of the response.
	__8.  Check in the Console view and you should see that the same message as before is printed.  This proves that the request made to the web service of the mediation flow export made it through the mediation flow and to the end service provider and back.
	__9.  Close all open files.

	Part 14 -  Review

	Lab 7 -  Service Composition Pattern
	Part 1 -  Business Use Case
	Part 2 -  Create the Module
	__1.  From the menubar, select File > New > Mediation Module.
	__2.  Enter CompositionTest as the name.
	__3.  Set target runtime to WebSphere ESB Server 7.0.
	__4.  Uncheck Create mediation component.
	__5.  Click Finish.

	Part 3 -  Create the Product Data Type
	__1.  Expand  CompositionTest.
	__2.  Right click Data Types and select New > Business Object.
	__3.  Enter Product as the name.
	__4.  Click Finish.
	__5.  Read the use case and try to figure out the various attributes of the product. The table below shows the solution. Add the following fields to the data type.
	__6.  Save and close.

	Part 4 -  Identify and Specify Services
	__1.  Under CompositionTest, right click Interfaces and select New > Interface.
	__2.  Enter  InventoryEnricher as the name and click Finish.
	__3.  Click the Add Request Response Operation toolbar button to create a two-way operation.
	__4.  Change the name of the operation to supplyInventory
	__5.  Change the name of the input parameter to product and the data type to Product
	__6.  Change the name of the output parameter to product and the data type to Product
	__7.  Save and close the interface.
	__8.  In the same project, create a new interface and call it ProductSink
	__9.  Add a one-way operation.
	__10.  Change the name of the operation to updateProduct
	__11.  Change the name of the input parameter to product and the data type to Product
	__12.  Save and close.

	Part 5 -  Implement the Message Flow
	__1.  Right click Integration Logic and select New > Mediation Flow.
	__2.  Enter PropagateProductChange as the name.
	__3.  Click Next.
	__4.  As the source interface add ProductSink.
	__5.  Click Finish.
	__6.  In the top pane of the mediation flow editor, click the Add Reference button.
	__7.  Select the InventoryEnricher interface. 
	__8.  Accept the default "InventoryEnricherPartner" name for the partner. 
	__9.  Click OK.
	__10.  Similarly, add the following references.
	__11.  Click the updateProduct operation in the source interface to select it.
	__12.  Click Blank Mediation Flow link.
	__13.  The Request pane will open.
	__14.  From the Service Invocation folder in the tool palette, locate the Service Invoke item.
	__15.  Drag the Service Invoke primitive and drop it on the message flow. 
	__16.  Select InventoryEnricherPartner.  The operation will change to supplyInventory.
	__17.  Click OK.
	__18.  Change the name of the invoke primitive to EnrichInventory
	__19.  Similarly add two more service invoke primitives with the following specifications.
	__20.  Connect the output terminal of ProductSink : updateProduct to the input of EnrichInventory. 
	__21.  Click Transform the message using an XSL Transformation primitive.
	__22.  Connect the output terminal of EnrichInventory to the input of AccountingSystem. Another XSL transformer will be inserted.  Make sure you use the out terminal of EnrichInventory and not the timeout terminal.
	__23.  Connect the output of XSLTransformer2 to the input of WebSite.
	__24.  Verify the message flow design.
	__25.  Save changes.  
	__26.  Ignore the error messages related to the XSL transformers.  You will resolve them in the next part.

	Part 6 -  Design the Data Maps
	__1.  Select the first transformer called XSLTransformation1.
	__2.  In the Properties view, select the Details tab.
	__3.  Click New.
	__4.  Accept all defaults and click Finish.
	__5.  In the map editor, connect the two Product objects as shown below.
	__6.  Save and close the map.
	__7.  Select the second transformer called XSLTransformation2.
	__8.  In the Properties view, select the Details tab.
	__9.  Click New.
	__10.  Accept all defaults and click Finish.
	__11.  In the map editor, connect the two Product objects as shown below.
	__12.  Save and close the map.
	__13.  Save the mediation flow. Verify that the Problems view has no error messages.

	Part 7 -  Implement the Services
	__1.  Open the assembly diagram.
	__2.  Right click the white area and select Add > Java.
	__3.  Change the name of the component to InventoryEnricher
	__4.  Right click it and select Add > Interface.
	__5.  Select  InventoryEnricher and click OK.
	__6.  Right click the component again and select Generate Implementation.
	__7.  Select (default package) and click OK.
	__8.  Change the supplyInventory method as follows.
	__9.  Save and close.
	__10.  Right click the white area and select Add > Java.
	__11.  Change the name of the component to AccountingSystem
	__12.  Right click it and select Add > Interface.
	__13.  Select ProductSink and click OK.
	__14.  Right click the component again and select Generate Implementation.
	__15.  Select (default package) and click OK.
	__16.  Change the updateProduct method as follows.
	__17.  Save and close.
	__18.  Right click the white area and select Add > Java.
	__19.  Change the name of the component to WebSite
	__20.  Right click it and select Add > Interface.
	__21.  Select ProductSink and click OK.
	__22.  Right click the component again and select Generate Implementation.
	__23.  Select (default package) and click OK.
	__24.  Change the updateProduct method as follows.
	__25.  Save and close.

	Part 8 -  Wire the Solution
	__1.  Drag the PropagateProductChange mediation flow and drop it on the assembly diagram.
	__2.  Study each one of its three reference partners by moving the mouse over it and opening the tooltip.
	__3.  Set up these wirings:
	__4.  Save changes. Make sure that there are no errors in the Problems view.

	Part 9 -  Test
	__1.  Make sure the server is started in the Servers view and start it if it is not.
	__2.  Right click the server in Servers view and select Add Remove Projects.
	__3.  Click Remove All to undeploy all existing applications.
	__4.  Click Finish. Wait until finish publishing.
	__5.  Right click the server in Servers view and select Add Remove Projects.
	__6.  Add the CompositionTestApp project.
	__7.  Click Finish. Wait until finish publishing.
	__8.  Right click in the white area of the assembly diagram and select Test Module.
	__9.  Carefully choose PropagateProductChange mediation flow as the component to be tested.
	__10.  In the input area, enter some values. Leave the inventory as 0.
	__11.  Click the Continue button in the test editor.
	__12.  Expand WebSphere Enterprise Service Bus Server and select WebSphere ESB Server 7.0 at localhost and set it up as default. Click Finish.
	__13.  Click OK in the user id and password dialog if prompted.
	__14.  In the Console view, verify the message logs show the progress of the message flow. Note that the sink services received the correct inventory value.
	__15.  Close the test, but do not save it.
	__16.  Close any other open files.
	__17.  Stop the server.

	Part 10 -  Review

	Lab 8 -  Message Routing
	Part 1 -  Business Problem Use Case
	Part 2 -  Import the Module
	__1.  Import all projects from C:\LabFiles\FilterTest.zip. (use the project Interchange option)
	__2.  Study the following data types. They have been developed following the use case.
	__3.  Study these service interfaces. They have also been developed based on the use case.

	Part 3 -  Model the Message Flow
	Part 4 -  Implement the Message Flow
	__1.  Create a new mediation flow with these specifications:
	__2.  Click placeOrder.
	__3.  Click Service integration.
	__4.  Click Add.
	__5.  Click OK  to select the placeOrder target. 
	__6.  Click OK.
	__7.  Click the Add button to add a new reference,
	__8.  Select the InventoryManager interface and click OK.
	__9.  Select the input node OrderTaker : placeOrder.
	__10.  In the Properties view, select the Details tab.
	__11.  Next to Transient context click Browse.
	__12.  Select Order and click OK.
	__13.  On the right hand palette, under References expand InventoryManagerPartner.
	__14.  Drag the getInventoryLevel operation and drop it on the message flow. WID will automatically add a service invoke operation properly configured.
	__15.  Select the service invoke and click the Details tab in Properties view.
	__16.  Change the display name of that primitive to GetInventory
	__17.  Connect the output of placeOrder : OrderTaker to the input of GetInventory. 
	__18.  Click Transform the message using an XSL Transformation primitive.
	__19.  WID will add a transformer primitive in the middle.
	__20.  Add a Message Filter primitive to the flow editor.
	__21.  Change its display name to CheckInventory
	__22.  Connect the out terminal of GetInventory to the input of CheckInventory.  Make sure you use the out terminal of GetInventory and not the timeout terminal.
	__23.  Connect the match1 terminal of CheckInventory to the input terminal of OrderTakerPartner : placeOrder.  Make sure you hover the mouse to see the name of the terminal as the second one should be the match1 terminal.
	__24.  Click Transform the message using an XSL Transformation primitive.
	__25.  WID will add the corresponding transformation.
	__26.  Add a service invoke primitive by dragging getProductReplacement operation on the flow.
	__27.  Change its display name to GetReplacement
	__28.  Connect the default terminal of CheckInventory to the input of GetReplacement. 
	__29.  Click Transform the message using an XSL Transformation primitive.
	__30.  WID will add a XSL transformer.
	__31.  Right click on the flow and select Automatic Layout.
	__32.  Right click the diagram and select Layout Contents to clean things up.
	__33.  Add another message filter primitive. This will decide if a replacement is available.
	__34.  Change its display name to CheckReplacement
	__35.  Connect the out terminal of GetReplacement to the input of CheckReplacement.
	__36.  Add a Stop primitive from the Error Handling group in the Palette.
	__37.  Connect the default terminal of CheckReplacement to the stop primitive.
	__38.  Connect the match1 terminal of  CheckReplacement to OrderTakerPartner  : placeOrder. 
	__39.  Click Transform the message using an XSL Transformation primitive.
	__40.  WID will add XSL Transformation4 in the middle.
	__41.  Right click the diagram and select Layout Contents to clean things up.
	__42.  Save changes. There will be several error messages. We will fix them later.
	__43.  Our basic flow design is done. Can you compare the flow with the drawing you made on paper?

	Part 5 -  Complete the Data Maps
	__1.  Select XSL Transformation1. 
	__2.  In the Properties view, select Details tab.
	__3.  Click New.
	__4.  Accept all defaults. Click Next.
	__5.  As the Message Root select  /
	__6.  Click Finish. WID will create the map and open it in the editor.
	__7.  For the input message (on the left hand side), expand body > placeOrder > order.
	__8.  For the output message, expand context > transient.
	__9.  Drag the order element of the source to the transient element of the target.
	__10.  In the target, expand body > getInventoryLevel.
	__11.  Map the sku element from the source to the sku element of the target.
	__12.  Save and close the map.
	__13.  Select XSL Transformation2.
	__14.  In the Properties view, select Details tab.
	__15.  Click New.
	__16.  Accept all defaults. Click Next.
	__17.  As the Message Root select  /
	__18.  Click Finish. WID will create the map and open it in the editor.
	__19.  Expand context in the source.
	__20.  Expand body > placeOrder in the target.
	__21.  Map the transient element of the source to the order element of the target body.
	__22.  Save and close the map.
	__23.  Select XSL Transformation3.
	__24.  In the Properties view, select Details tab.
	__25.  Click New.
	__26.  Accept all defaults. Click Next.
	__27.  As the Message Root select  /
	__28.  Click Finish. WID will create the map and open it in the editor.
	__29.  Expand context > transient in the source.
	__30.  Expand body > getProductReplacement in the target.
	__31.  Map the sku element from the transient area of the source to the sku element in the body of the target.
	__32.  Expand context > transient in the target.
	__33.  Map the transient element of the source to the transient element of the target. Otherwise, we will lose the data saved in the transient area.
	__34.  Save and close the map.
	__35.  Select XSL Transformation4.
	__36.  In the Properties view, select Details tab.
	__37.  Click New.
	__38.  Accept all defaults. Click Next.
	__39.  As the Message Root select  /
	__40.  Click Finish. WID will create the map and open it in the editor.
	__41.  Expand context > transient in the source.
	__42.  Expand body > placeOrder > order in the target.
	__43.  Reconstruct all elements of the order in the target body except for sku from the transient area of the source.
	__44.  Expand body >  getProductReplacementResponse from the source.
	__45.  Map the toSKU element of the body of the source to the sku element of the target body.
	__46.  Save and close the map.
	__47.  Save the mediation flow. There should be no error messages. There are a few warnings and we will take care of that soon.

	Part 6 -  Define the Routing Logic
	__1.  Select CheckInventory.
	__2.  In the Properties view, select Details tab.
	__3.  Click the Add button to specify a Filter.
	__4.  Make sure that the terminal to be fired is set as match1.
	__5.  Carefully enter the following condition in the Pattern field:
	__6.  Make sure your expression looks like below:
	__7.  Click Finish to create the routing filter pattern.
	__8.  Save changes.
	__9.  Select CheckReplacement.
	__10.  In the Properties view, select Details tab.
	__11.  Click the Add button to specify a routing rule.
	__12.  Make sure that the terminal to be fired is set as match1.
	__13.  Click the Edit button to define the XPath expression associated with this rule. If this expression evaluates to true, the match1 terminal will fire.
	__14.  Expand Data Types > ServiceMessageObject > body : getProductReplacementResponseMsg > getProductReplacementResponse > replacement: ReplacementProduct.
	__15.  Select replacementAvailable : boolean.
	__16.  Click OK.
	__17.  The XPath expression will be:
	__18.  Click Finish to create the routing filter pattern.
	__19.  Save changes. The design of the mediation flow is now complete.
	__20.  Close the editor.

	Part 7 -  Wire the Solution
	__1.  Open the assembly diagram.
	__2.  Verify that two Java components are already created for you.
	__3.  Double click InventoryManager to view the business logic.
	__4.  Close the Java editor.
	__5.  Drag OrderMediation and drop it on the assembly diagram.
	__6.  Right click on the flow and select Automatic Layout.
	__7.  Right click the OrderMediation and select Wire to Existing.  This should automatically wire up the reference partners.
	__8.  Save.

	Part 8 -  Deploy the Module
	__1.  Start the server.
	__2.  Right click the server and select Add Remove Projects.
	__3.  Click Remove All to undeploy all existing applications.
	__4.  Add FilterTestApp.
	__5.  Click Finish. Wait for publishing to end.

	Part 9 -  Test
	__1.  Right click the assembly diagram and select Test Module.
	__2.  Set the component to be tested to OrderMediation.
	__3.  Enter some input data.
	__4.  Click the Continue button.
	__5.  Choose as always the WebSphere ESB Server v7.0 at localhost runtime and set it as default.
	__6.  Click Finish.
	__7.  Accept the default user ID and password if asks.
	__8.  At the end of the test, the console will show.
	__9.  Under Events click the Invoke button to start another test.
	__10.  Enter some input as shown below.
	__11.  Click the Continue button.
	__12.  Now, the console will show this.
	__13.  Select placeOrder : OrderTaker primitive as shown above. This is the input node and the first primitive to be executed.
	__14.  In the Mediation Message area, note that the transient context is now empty. But the body has the input Order object.
	__15.  Select XSL Transformation1 in the left. At this point, the order data has been copied into the transient area. Also, the body is now ready as input for the getInventoryLevel operation.
	__16.  Select GetInventory. This a service invoke primitive that calls the getInventoryLevel operation.
	__17.  Note that the transient context area has remained unchanged. But the body of the SMO now contains the output of getInventoryLevel. This proves that a service invoke primitive does not alter the message context area but replaces the body with the output of the operation called.
	__18.  Next select CheckInventory. This a message filter primitive. It does not alter the SMO in anyway.
	__19.  Close the test editor without saving it.
	__20.  Close any other open files.
	__21.  Stop the server.

	Part 10 -  Review

	Lab 9 -  Implementing the Splitting and Aggregation Patterns
	Part 1 -  The Business Logic
	Part 2 -  Service Identification
	Part 3 -  Import Mediation Module
	__1.  Import the project interchange file C:\LabFiles\PriceQuoteFlow.zip.
	__2.  Verify that the PriceQuoteFlow mediation module is created.
	__3.  Take a moment to study these data types:
	__4.  Study these service interfaces. The service identification part describes them in details.
	__5.  Close all open editors.

	Part 4 -  Define Shared Context Data Type
	__1.  Create a new business object data type called QuoteSharedContextData
	__2.  Add these fields
	__3.  Save and close the editor.

	Part 5 -  Create the Mediation Flow
	__1.  Right click Integration Logic and select New > Mediation Flow.
	__2.  Enter OrderMediation as the name and click Next.
	__3.  As the source interface, pick OrderTaker.
	__4.  As the target interface, pick Supplier.
	__5.  Click Finish.
	__6.  Click placeOrder.
	__7.  Click Service Integration.
	__8.  Click Add.
	__9.  Select placeOrder target operation and click OK.
	__10.  Click OK.
	__11.  Save changes.

	Part 6 -  Save Order in Shared Context
	__1.  In the message flow editor pane, select the OrderTaker: placeOrder input node.
	__2.  In the Properties view, select the Details tab.
	__3.  Set Shared context to QuoteSharedContextData.
	__4.  Add an XSL Transformation primitive to the message flow.
	__5.  In the Details tab of the Properties view, click New.
	__6.  Accept the default name for the map and click Next.
	__7.  Set the Message root to "/".
	__8.  Next to Input Message Body click Browse.
	__9.  Select the Specific message type radio button.
	__10.  Expand OrderTaker > placeOrder.
	__11.  Select placeOrderRequestMsg.
	__12.  Click OK.
	__13.  Similarly, for Output Message Body, select the same message type.
	__14.  Click Finish.
	__15.  For the source message, expand body > placeOrder.
	__16.  For the target message, expand context > shared.
	__17.  Drag the order element from the source on the order element of the target.
	__18.  Save and close the map editor.
	__19.  Connect the output of the OrderTaker: placeOrder node to the input of XSLTransformation1.
	__20.  Save changes.

	Part 7 -  Create a Basic Splitting and Aggregation Flow
	__1.  Expand the Routing pallete.
	__2.  Drag Fan Out and drop it on the message flow.
	__3.  Drag Fan In and drop it on the message flow.
	__4.  In the window that opens, select FanOut1 as the primitive that will correspond with the FanIn.
	__5.  Click OK.
	__6.  On the right hand side of the editor, expand the SupplierPartner reference.
	__7.  Drag getPriceQuote and drop it between the FanOut and FanIn.
	__8.  Change the display name of the service invoke to CallAJAX
	__9.  Similarly, drag and drop getPriceQuote again to create another service invoke. 
	__10.  Change the display name of the service invoke to CallACME
	__11.  Connect the output terminal of XSLTransformation1 to the input of FanOut1.
	__12.  Select the FanIn1 primitive. 
	__13.  Select the Details tab in the Properties view.
	__14.  Set the number of input messages that the primitive will wait for to 2.  You may need to scroll in the view to see this option.
	__15.  Save changes.  We will now develop each path of execution.

	Part 8 -  Develop Parallel Flow Paths
	__1.  Connect the out terminal of FanOut1 to the in terminal of CallAJAX.  Make sure you connect the 'out' terminal of the FanOut as it also has a 'noOccurences' terminal.  Hover over the terminals to see the terminal names.
	__2.  Select Transform the message using XSL Transformation primitive.
	__3.  Select  XSLTransformation2.
	__4.  In the Details tab of the Properties view, click New.
	__5.  Click Next.
	__6.  Choose "/" as the root.
	__7.  Click Finish.
	__8.  Map the fields as shown below.
	__9.  Save and close the map editor.
	__10.  Add a new XSL Transformation primitive to the right of CallAJAX. The name of the primitive should be XSLTransformation3
	__11.  Select XSLTransformation3.
	__12.  In the Details tab of the Properties view, click New.
	__13.  Click Next.
	__14.  Set "/" as the root.
	__15.  Next to Input Message Body click Browse.
	__16.  Select Specific message type.
	__17.  Expand Supplier >getPriceQuote.
	__18.  Select getPriceQuoteResponseMsg.
	__19.  Click OK.
	__20.  Set the Output Message Body to be the same.
	__21.  Click Finish.
	__22.  First copy the existing shared context data as shown below. When you select "/" as the message root, you must copy context data. Otherwise, they will be lost.
	__23.  Map the response element from the body of the source to the Move map of responses element.
	__24.  Save and close the map editor.
	__25.  Connect the out terminal of CallAJAX to the in terminal of XSLTransformation3.
	__26.  Connect the out terminal of XSLTransformation3 to the in of FanIn1.  Make sure you connect to the 'in' terminal as there is also a 'stop' terminal.
	__27.  Verify that the path for AJAX looks like this.  The layout may differ slightly but the order of the connections should match.
	__28.  Save changes.
	__29.  Right click the flow and select Automatic Layout.
	__30.  Repeat the steps from the beginning of this part and implement the flow for ACME. In the end the flows will look like this.
	__31.  Save changes.

	Part 9 -  Pick the Winning Bid
	__1.  In the References section click the Add button to add a new partner reference.
	__2.  Select the WinningQuotePicker interface. 
	__3.  Click OK.
	__4.  Expand WinningQuotePicker reference.
	__5.  Drag the pickQuote operation of the WinningQuotePickerPartner to the right of FanIn1.
	__6.  Change the display name of the service invoke primitive to PickQuote
	__7.  Connect the output of FanIn1 to the input of PickQuote.  Make sure to select the 'out' terminal of the FanIn as there is also an 'incomplete' terminal.
	__8.  Select Transform the message using XSL Transformation primitive.
	__9.  Double click XSLTransformation6 to start creating the map.
	__10.  Click Next.
	__11.  Set the message root to "/".
	__12.  Click Finish.
	__13.  Map the aggregate element from the shared context to the input element of the target body. 
	__14.  Save and close the map.

	Part 10 -  Place the Order
	__1.  Connect the out terminal of  PickQuote primitive to the  SupplierPartner : placeOrder node.
	__2.  Select Transform the message using XSL Transformation primitive.
	__3.  Double click XSL Transformation7.
	__4.  Click Next.
	__5.  Select "/" as the Message root.
	__6.  Click Finish.
	__7.  Map the order element from the shared context to the order element in the body of the target.
	__8.  Save and close the map.
	__9.  Save the mediation flow.

	Part 11 -  Dynamic Invocation
	__1.  Open the assembly diagram for the PriceQuoteFlow project.
	__2.  Drag the Supplier interface on the diagram.
	__3.  Select Import with Web Service Binding.
	__4.  Click OK.
	__5.  Select Do not specify a web service port at this time.
	__6.  Click OK.
	__7.  Rename the import to AJAXImport
	__8.  Similarly, add ACMEImport
	__9.  Drag and drop the OrderMediation component on the diagram.
	__10.  Save the assembly diagram. Ignore various errors.
	__11.  Back in the mediation flow, double click XSL Transformation4. 
	__12.  In the target message, expand headers > SMOHeader > Target.
	__13.  Right click the import element and select Create Assign.
	__14.  Select the Assign map.
	__15.  In the Properties view, set the value to ACMEImport.  Make sure this matches exactly the name you gave the import in the assembly diagram.
	__16.  Save and close the map.
	__17.  Double click the  XSL Transformation2 primitive. 
	__18.  This one is used before CallAJAX. Use the assign mapping to set the import element in the header to be AJAXImport as you just did.
	__19.  Save and close the map.
	__20.  Double click XSL Transformation7.
	__21.  First setup a regular move map between supplierId in the source to the import element of the target.
	__22.  Click the down arrow for the Move map, expand Custom Transforms and then select Custom XPath.
	__23.  In the Properties view, enter the following XPath expression under General tab.
	__24.  Save and close the map.
	__25.  Select one of the service invoke primitives, such as CallACME.
	__26.  In the Properties view, select the Details tab.
	__27.  Ensure that Use dynamic endpoint if set in the message header is selected.

	Part 12 -  Review

	Lab 10 -  Service Design and Implementation
	Part 1 -  Create the AJAX Supplier Web Service
	__1.  Ensure that the server is running. WID deploys the web service project to the server when a new web service is created.
	__2.  Open the assembly diagram for PriceQuoteFlow.
	__3.  Right click AJAXImport and select Regenerate Binding.
	__4.  Click OK to confirm.
	__5.  Select Generate a new web service definition and implementation.
	__6.  Click OK.
	__7.  Select SOAP1.1/HTTP since this enables JAX-WS.
	__8.  Click Finish.
	__9.  Click the Service Project link.
	__10.  Carefully, enter the Service project name to AJAXWeb and the Service EAR project to AJAXApp
	__11.  Click OK.
	__12.  Verify the page.
	__13.  Click Next.
	__14.  Check Copy WSDL to project.
	__15.  Click Next. 
	__16.  Click Finish.
	__17.  Add a member variable for a java.util.Logger object.
	__18.  Use Control+Shift+O to organize imports and select java.util.logging.Logger when prompted.
	__19.  Implement the getPriceQuote method as follows.
	__20.  Implement the placeOrder method as follows.
	__21.  Save changes to the service implementation and close it.
	__22.  Back in the assembly diagram, save changes.

	Part 2 -  Create the ACME Supplier Web Service
	__1.  Follow the same steps as in the previous part to generate an implementation for the ACMEImport. Except, use "ACME" everywhere "AJAX" appears. Below is a summary.
	__2.  After you are done writing the code for the web service, go back to the assembly diagram and save it. There should be no errors. There will be a few warnings related to not wiring the reference partners of the mediation flow. That is normal for dynamic invocation.

	Part 3 -  Develop the WinningQuotePicker Service
	__1.  Right click the assembly diagram and select Add > Java.
	__2.  Change its name to  WinningQuotePicker
	__3.  Right click it and select Add >Interface.
	__4.  Select  WinningQuotePicker.
	__5.  Click OK.
	__6.  Right click  WinningQuotePicker again and select Generate Implementation.
	__7.  Click OK.
	__8.  Implement the pickQuote method as follows. It receives as input a QuoteResponseAggregate object and returns the QuoteResponse object with the lowest price.
	__9.  Organize imports selecting the java.util.List interface.
	__10.  Save changes and close the Java editor.
	__11.  Back in the assembly diagram, wire the WinningQuotePickerPartner reference of the mediation flow to the WinningQuotePicker Java component.
	__12.  Save the assembly diagram.

	Part 4 -  Expose Mediation Flow as a Web Service
	__1.  In the assembly diagram, right click OrderMediation and select Generate Export > Web Service Binding.
	__2.  Select SOAP1.1/HTTP.
	__3.  Click Finish.
	__4.  Save the assembly diagram.

	Part 5 -  Deploy and Test
	__1.  Start the server.
	__2.  Deploy only the following three projects to the server.
	__3.  Wait for publishing to end.
	__4.  Clear the Console view.
	__5.  Under PriceQuoteFlow project, expand Web Service Ports.
	__6.  The OrderTakerExport1_OrderTakerHttpPort port is for the export of the mediation flow. Right click it and select Web Services > Test with Web Services Explorer.
	__7.  Click the placeOrder operation.
	__8.  Next to sku, click Add.
	__9.  Enter some value for sku.
	__10.  Similarly, enter some value for quantity and address.
	__11.  Click the Go button.
	__12.  After some seconds in the Console view, there will be a flurry of logging activity. There may even be a few exception stacktraces. Most of them can be ignored. Look for the output from the AJAX and ACME web services as shown below.
	__13.  Make sure that the supplier with the lowest bid has received the order (AJAX in the example above).
	__14.  Clear the console.
	__15.  Repeat the test by clicking the Go button again in the web services explorer window. Make sure that winning bid always gets the order.  The subsequent requests will likely come back so quickly you may not even think they were submitted.
	__16.  Close all open files. (Ctrl+Shift+W)

	Part 6 -  Review

	Lab 11 -  Application Integration Using JMS Messaging
	Part 1 -  Business Logic and Architecture
	Part 2 -  Create the Message Queues
	__1.  Start the Server unless it is already running.
	__2.  Right click the server and select Administration > Run administrative console. Click Yes in the security certificate window. 
	__3.  Log in as admin and admin.
	__4.  Click Service integration.
	__5.  Click Buses.
	__6.  Click New to create a new message bus.
	__7.  Enter DemoBus as the name.
	__8.  Clear the Bus Security checkbox to disable security protection for the bus.
	__9.  Click Next.
	__10.  Click Finish.
	__11.  Click DemoBus from the list of buses.
	__12.  Click Bus members.
	__13.  Click Add.
	__14.  Click Next.
	__15.  Click Next again to choose File store as default.
	__16.  Click Next to accept message store properties.
	__17.  Click Next to accept message performance parameters.
	__18.  Click Finish to add the bus member.
	__19.  Click Buses on the left hand navigation tree.
	__20.  Click DemoBus.
	__21.  Click Destinations.
	__22.  Click New.
	__23.  Choose Queue (default). Note: For pub/sub you will create a topic instead.
	__24.  Click Next.
	__25.  Enter AccountingRequestQ as the identifier.
	__26.  Click Next.
	__27.  The bus member to host the queue should be server1. Click Next.
	__28.  Click Finish to create the queue.
	__29.  Similarly, create another queue called AccountingResponseQ
	__30.  Click the Save link to save your changes.

	Part 3 -  Create JMS Resources
	__1.  In the left hand navigation tree, expand Resources > JMS.
	__2.  Click Queue Connection Factories.
	__3.  Set the scope to server1 as shown below.
	__4.  Click New.
	__5.  Click OK to create the resource for the default messaging provider.
	__6.  Enter these values:
	__7.  Click OK.
	__8.  Click Queues on the left side.
	__9.  Set the scope to server1.
	__10.  Click New.
	__11.  Click OK.
	__12.  Enter these values.
	__13.  Click OK.
	__14.  Click New again and create another destination as follows.
	__15.  Click OK.
	__16.  Save changes.
	__17.  Logout and close the Admin Console.

	Part 4 -  Create the JMS Import
	__1.  Open the assembly diagram for PriceQuoteFlow.
	__2.  Right click and select Add > Import.
	__3.  Change the name of the import to AccountingApp
	__4.  Right click AccountingApp and select Add > Interface.
	__5.  Select WinningQuotePicker and click OK.
	__6.  Right click it again and select Generate Binding > Messaging Binding > JMS Binding.
	__7.  Choose Use pre-configured messaging provider resources.
	__8.  Carefully enter the JNDI names of the JMS resources as shown below.  Double check the spelling carefully.
	__9.  Verify you configuration as below:
	__10.  The data format should be set to UTF8XMLDataHandler. This puts messages as XML documents. This is what we want.
	__11.  Click OK.
	__12.  Delete the existing wiring of WinningQuotePickerPartner to the Java component.
	__13.  Wire WinningQuotePickerPartner to the JMS import.
	__14.  Save changes.

	Part 5 -  Configure the JMS Import
	__1.  In the assembly diagram, select the JMS import – AccountingApp.
	__2.  In the Properties view, select the End-point configuration tab.
	__3.  Select the JMS Destinations tab.
	__4.  Expand Callback Destination Properties.
	__5.  Make sure that Specify the properties for configuring new messaging provider resource checkbox is selected. Here we will provide enough information so that WebSphere ESB can dynamically create the destination.
	__6.  In the Bus name field, enter DemoBus
	__7.  Press tab to leave the text box. Then save changes.
	__8.  Select the JMS import – AccountingApp again.
	__9.  In the Properties view, select the Method bindings tab.
	__10.  In the right, expand Bound Methods and select pickQuote.
	__11.  At the right of it, select the Data Serialization tab.
	__12.  Change the Message type to Text.
	__13.  Save the file.

	Part 6 -  Configure Asynchronous Qualifier
	__1.  In the assembly diagram, select the OrderMediation component.
	__2.  In the Properties view, select the Details tab.
	__3.  Under References, select WinningQuotePickerPartner reference.
	__4.  Click the Qualifiers tab.
	__5.  Select Asynchronous invocation qualifier.
	__6.  Set it's value to Call.
	__7.  Save changes.
	__8.  Select the JMS import – AccountingApp.
	__9.  From the Properties view, select the Message configuration tab.
	__10.  Note that the default setting for correlation scheme is Request Message ID to Correlation ID. That means, the accounting application must copy the request message ID as the correlation ID of the response. We will leave that as it is.

	Part 7 -  A Question of Timeout
	__1.  Open the OrderMediation mediation flow.
	__2.  Verify that for the PickQuote primitive, the timeout is set to 5 seconds by default. Location of the Async timeout property is shown below.
	__3.  Close all open files.

	Part 8 -  Review

	Lab 12 -  Develop the Message Driven Bean (MDB)
	Part 1 -  Create the MDB
	__1.  From the menubar, select File > New > Project.
	__2.  Expand EJB and select EJB Project.
	__3.  Click Next.
	__4.  Enter the following values.
	__5.  Click Next.
	__6.  Uncheck Create an EJB client JAR ...
	__7.  Click Finish.
	__8.  Click Yes when WID asks you to switch perspective to Java EE.
	__9.  Right click  SimpleAccountingEJB project and select New > Message-Driven Bean.
	__10.  Enter QuotePickerBean as the Class name.
	__11.  Enter com.webage.ejb as the Java package name.
	__12.  Click Finish.

	Part 2 -  Develop the Code
	__1.  Expand SimpleAccountingEJB > ejbModule > com.webage.ejb and open the MDB implementation class QuotePickerBean.java in case you close it.
	__2.  A solution for this file is given to you in C:\LabFiles\QuotePickerBean.java. Open the file in notepad. Copy its contents.
	__3.  Replace the entire contents of QuotePickerBean.java in WID with the copied content.
	__4.  Save changes. Make sure there are no compilation errors.

	Part 3 -  Review the MDB Code
	__1.  Locate the onMessage() method. This method is called by the EJB container when the mediation flow posts a new request message.
	__2.  We create a DOM document from the request message.
	__3.  We then iterate through all suppliers in the message and determine the lowest bid.
	__4.  We then create the response DOM document.
	__5.  We save the winning supplier's ID and price in the document.
	__6.  We prepare the response message.
	__7.  We then setup the correlation ID of the response to be same as the ID of the request message. This is the scheme expected by the JMS import we have created in the previous lab.
	__8.  Finally, we post the response message.

	Part 4 -  Configure the MDB
	__1.  Open the administration console for the server.
	__2.  Log in using admin/admin.
	__3.  Expand Resources > JMS.
	__4.  Click Activation specifications.
	__5.  Set the scope to server1.
	__6.  Click New.
	__7.  Click OK.
	__8.  Enter the following values.
	__9.  Click OK.
	__10.  Save changes.
	__11.  Log out of administration console and close the window.
	We first need to create a binding descriptor for the EJB.  Our activation spec information will be listed in here.  Fortunately, WID can create this for us. 
	__12.  In the Enterprise Explorer, right-click on SimpleAccountingEJB and select Java EE | Generate WebSphere Binding Deployment Descriptor.
	__13.  An editor will open on the newly created descriptor. Select the Source tab.
	
	__14.  Click the Design tab at the bottom of the editor. 
	__15.  Click the Add button. 
	__16.  The Add Item window will appear.  Select Message Driven and click OK. 
	__17.  Select  QuotePickerBean
	__18.  Click Finish.
	Ignore the error.
	__19.  Click Add... again.  
	__20.  The Add Item window will appear.  Select JCA Adapter and click OK.
	The newly added JCA Adapter will be listed in the left pane. 
	__21.  In the right pane, for the Activation Spec Binding Name, enter jms/DemoAS
	__22.  Save changes.
	__23.  Close all open files.

	Part 5 -  Deploy Application
	__1.  Add the SimpleAccountingApp project to the server.
	__2.  Wait for the server to finish publishing. Make sure all projects are Synchronized, if not then Publish.

	Part 6 -  Test
	__1.  Switch back to the Business Integration perspective.
	__2.  Under the PriceQuoteFlow project, expand Web Service Ports.
	__3.  Right click OrderTakerExport1_OrderTakerHttpPort and select Web Services > Test With Web Services Explorer.
	__4.  Click placeOrder operation.
	__5.  Next to sku, click Add. 
	__6.  Enter a sku value.
	__7.  Similarly, add a value for quantity and address.
	__8.  Click Go.
	__9.  Open the Console view.
	__10.  Ignore any exception.
	__11.  Locate various log messages from QuoteMDB logger.
	__12.  Make sure the winning supplier got the order.
	__13.  Close all open files.

	Part 7 -  Review

	Lab 13 -  Using FanOut in Iteration Mode
	Part 1 -  Business Logic and Architecture
	Part 2 -  Modify Schema
	__1.  Create a new business object called SupplierInfo in the PriceQuoteFlow project.
	__2.  Add these fields to the data type.
	__3.  Save and close the editor.
	__4.  Open the Order business object.
	__5.  Add a new field called supplier which is an array of SupplierInfo.
	__6.  Select the supplier field and select the Description tab in the Properties view.
	__7.  Select unbounded as Maximum occurrences.
	__8.  Save and close.

	Part 3 -  Modify the Mediation Flow
	__1.  Open the OrderMediation mediation flow.
	__2.  Open the Request tab by clicking on top of the placeOrder for OrderTaker source.
	__3.  Delete all three primitives in the path for ACME. (We could have deleted any one of the two paths. Here, we choose ACME).
	__4.  Change the Display name of the CallAJAX primitive to SendPriceQuote
	__5.  After that, the path coming out of FanOut1 will look like this.
	__6.  Select FanOut1.
	__7.  In the Properties view, select the Details tab.
	__8.  Select the for each element in XPath expression.
	__9.  Click Edit to enter the expression.
	__10.  Expand Data Types > ServiceMessageObject > context > shared > order.
	__11.  Select the supplier element.
	__12.  Click OK.
	__13.  Select the FanIn1 primitive.
	__14.  In the Properties view, select the Details tab.
	__15.  Select the associated Fan Out primitive has iterated through all messages.
	__16.  Save changes.

	Part 4 -  Dynamically Set Quote Request to a Supplier
	__1.  Select XSLTransformation2 and delete it.
	__2.  Connect the output of FanOut1 to the input of SendPriceQuote.
	__3.  Click Transforms the message using and XSL Transformation primitive. 
	__4.  XSLTransformation2 will be re-created.
	__5.  Select XSLTransformation2.
	__6.  In the Properties view, select the Details tab.
	__7.  Click New.
	__8.  Click Next.
	__9.  Select "/" as the message root.
	__10.  Click Finish.
	__11.  First re-map the sku and quantity elements from the shared context of the source to the body of the target. This was already done in the old map but we have to do it again. 
	__12.  In the source object, expand  context/primitiveContext/FanOutContext/occurrence.
	__13.  In the target message, expand headers/SMOHeader/Target.
	__14.  Map supplierId from the source to the import element of the target.
	__15.  Click the dropdown icon for the Move map and select Custom.
	__16.  Set the XPath expression to: concat($supplierId, 'Import')
	__17.  Save and close the map.
	__18.  Save the mediation flow.

	Part 5 -  Test
	__1.  Right click the server and select Publish. Wait for publishing to finish.
	__2.  Expand Web Service Ports in the PriceQuoteFlow project.
	__3.  Right click OrderTakerExport1_OrderTakerHttpPort and select Web Services > Test With Web Services Explorer.
	__4.  Click placeOrder operation.
	__5.  Click the Add link for sku, quantity and address and enter some values.
	__6.  Click the Add link for supplier.
	__7.  Click the Add link for supplierId and enter AJAX
	__8.  Similarly, add another supplier and set its supplierId to ACME
	__9.  Click the Go button.
	__10.  In the Console view, make sure that both suppliers sent a quote reply back.
	__11.  Verify that the supplier with the lowest quote got the order.
	__12.  Clear the Console.
	__13.  In the web services explorer, change supplierId from ACME to BOB.
	__14.  Click the Go button.
	__15.  There will be a flurry of exceptions in the console. You should be able to locate the following error message. Do a search in the console if you need to.
	__16.  In the web services explorer, select the checkbox for supplier BOB as shown below.
	__17.  Click the Remove link for the supplier element.
	__18.  Make sure that supplier BOB is deleted.
	__19.  Clear the console.
	__20.  Click the Go button.
	__21.  Now, we should see quote from only AJAX which will also be the winning bidder.
	__22.  Clear the Console.
	__23.  Finally, delete supplier AJAX also.
	__24.  Click the Go button.
	__25.  Close all open files.
	__26.  Clear the Console.

	Part 6 -  Review

	Lab 14 -  Basic Error Handling in Mediation Flow
	Part 1 -  Business Logic and Architecture
	Part 2 -  Alter the Mediation Flow
	__1.  Open OrderMediation in the PriceQuoteFlow project.
	__2.  Click placeOrder of the OrderTaker source to open the flow. 
	__3.  Delete the connection between OrderTaker : placeOrder and XSLTransformation1.
	__4.  Add a Message Filter primitive between those two primitives.
	__5.  Rename the filter to ValidateSupplier
	__6.  Connect the out terminal of OrderTaker : placeOrder to the in terminal of ValidateSupplier.
	__7.  Connect the match1 terminal of ValidateSupplier to the in terminal of XSLTransformation1.
	__8.  In the tool palette, expand Error Handling.
	__9.  Add a Fail primitive from there to near the ValidateSupplier primitive.
	__10.  Connect the default terminal of ValidateSupplier to the in terminal of Fail1.
	__11.  Right click the message flow and select Layout Contents. The modified portion should look like this.
	__12.  Save changes.

	Part 3 -  Specify Filter Rule
	__1.  Select ValidateSupplier.
	__2.  In the Properties view, select Details.
	__3.  Next to the Filters table, click Add.
	__4.  Make sure that Terminal name is match1.
	__5.  In the Pattern text area, enter:
	__6.  Click Finish.
	__7.  Save changes.

	Part 4 -  Specify Error Message
	__1.  Select Fail1.
	__2.  In the Properties view, select Details.
	__3.  Enter an error message such as this.
	__4.  Click any  place in the flow.
	__5.  Save changes.

	Part 5 -  Test
	__1.  Publish changes to the server. Wait for publishing to end.
	__2.  Expand Web Service Ports.
	__3.  Right click OrderTakerExport1_OrderTakerHttpPort and select Web Services > Test With Web Services Explorer.
	__4.  Click placeOrder operation.
	__5.  Click the Add link for sku, quantity and address and enter some values.
	__6.  Do not add any supplier. We are trying test for the failure condition.
	__7.  Click the Go button.
	__8.  In the Console view, search for FailFlowException. You should find a line with the exception stacktrace for it. Also, locate the error message.
	__9.  Close all open files.

	Part 6 -  Review

	Lab 15 -  Planned Error Handling
	Part 1 -  Business Logic and Architecture
	Part 2 -  Alter the Service Interface
	__1.  Create a new business object called OrderFailure in the PriceQuoteFlow project.
	__2.  Add these fields.
	__3.  Save and close the editor.
	__4.  Close the OrderMediation mediation flow editor if it is open. We will make a lot of changes to its service interface. Keeping the editor open can cause problems.
	__5.  Open OrderTaker interface.
	__6.  Click the placeOrder operation to select it.
	__7.  Right click on the placeOrder operation and select Change to Request Response Operation.
	__8.  Select output1. 
	__9.  Right click it and select Delete. The operation does not have any output.
	__10.  Select the placeOrder operation again.
	__11.  Click the Add Fault toolbar button to add a fault.
	__12.  Change the name of the fault parameter to error
	__13.  Set the data type of the fault parameter to OrderFailure
	__14.  Verify that the operation now looks like this.
	__15.  Save and close the editor.

	Part 3 -  Change the Mediation Flow
	__1.  Open OrderMediation mediation flow.
	__2.  Open the Request tab by clicking on top of the placeOrder for OrderTaker source.
	__3.  Scroll to the very right and you will see that a fault node has been added.
	__4.  Move the fault node close to the ValidateSupplier message filter.
	__5.  Delete the Fail1 primitive. We will not need it any more.
	__6.  Connect the default terminal of ValidateSupplier to the input terminal of the new fault node. 
	__7.  Click Transform the message using an XSL Transformation primitive.
	__8.  WID will automatically insert a XSL transformation (XSLTransformation4) primitive in the middle.
	__9.  Save changes. Changes to our flow is now complete.

	Part 4 -  Specify Error Data
	__1.  Double click XSLTransformation4.
	__2.  Click Finish.
	__3.  Map the sku and quantity elements.
	__4.  Right click the reason element in the target and select Create Assign.
	__5.  In the Properties view, set the error message.
	__6.  Save and close the editor.
	__7.  Save the changes in the OrderMediation and close the editor.

	Part 5 -  Regenerate Export Binding
	__1.  Open the assembly diagram in the PriceQuoteFlow project.
	__2.  Right click OrderTakerExport1 and select Delete.
	__3.  Save changes.
	__4.  From the Business Integration view, expand PriceQuoteFlow > Web Services Port.
	__5.  Right click OrderTakerExport1_OrderTakerHttpPort and select Delete.
	__6.  Click Yes to confirm the deletion.
	__7.  Back in the Assembly Diagram, right click OrderMediation and select Generate Export > Web Service Binding.
	__8.  Leave selected SOAP1.1/HTTP.
	__9.  Click Finish.
	__10.  Save the assembly diagram.

	Part 6 -  Test
	__1.  Close all open windows (Control+Shift+W). Specifically, the web services explorer windows should be closed since the service interface has changed.
	__2.  Publish changes to the server. If you get an error message, then clean the PriceQuoteFlow project and have it rebuilt. Then try publishing again.
	__3.  Clear the console.
	__4.  Expand Web Service Ports.
	__5.  Right click OrderTakerExport1_OrderTakerHttpPort and select Web Services > Test With Web Services Explorer.
	__6.  Click placeOrder operation.
	__7.  Click the Add link for sku, quantity and address and enter some values.
	__8.  Do not add any supplier. We are trying test for the failure condition.
	__9.  Click the Go button.
	__10.  In the web services explorer, in the Status pane, click the Source link to view the SOAP messages.
	__11.  Verify that the SOAP response contains a fault and the error data.
	__12.  Close all open files.

	Part 7 -  Review

	Lab 16 -  Failed Event Manager
	Part 1 -  Import the Projects
	__1.  Import all projects from the project interchange file C:\LabFiles\ProductCatalog.zip.
	__2.  The ProductCatalogWeb has the web service implementation. Open the CatalogManager.java class to have a quick look at the addProduct method.
	__3.  The CatalogModule project is the mediation flow. Open the AddProductFlow mediation flow.
	__4.  In the Overview flow, click on AddProduct and study the request flow for the addProduct operation.
	__5.  Close all open files.

	Part 2 -  Create Java Bridge Component
	__1.  Open the assembly diagram for CatalogModule.
	__2.  Right click the assembly diagram, and select Add > Java.
	__3.  Change the name of the Java component to JavaBridge
	__4.  Right click JavaBridge and select Add > Interface.
	__5.  Select CatalogManager interface. This is the interface of the target web service.
	__6.  Click OK.
	__7.  Right click JavaBridge and select Add > Reference. 
	__8.  By default CatalogManagerPartner is set as the reference name. Also, CatalogManager should be selected as the interface. Click OK.
	__9.  Connect the mediation flow to the Java component and the Java component to the web service import.
	__10.  Right click JavaBridge and select Generate implementation.
	__11.  Click OK to accept the default package.
	__12.  Implement the addProduct method as follows.
	__13.  Save and close the Java file.
	__14.  Save the assembly diagram.

	Part 3 -  Deploy and Test the System
	__1.  Start the server if it is not running.
	__2.  Deploy these two applications to the server.
	__3.  In the assembly diagram, right click AddProductFlow and select Test Component.
	__4.  Enter some input data as shown below.
	__5.  Click the Continue button and initiate testing. Choose the server properly and enter administrative user ID and password if prompted.
	__6.  After the test completes, check the Console view for log messages.

	Part 4 -  Test for Service Failure
	__1.  In the Servers view, right click ProductCatalogApp and select Stop. This will shutdown the target service.
	__2.  Clear the Console view.
	__3.  Back in the test GUI, click the Invoke button.
	__4.  Enter some input data and click Continue.
	__5.  Observe a couple of things:
	__6.  In the test GUI, invoke the operation one more time with a different product name.

	Part 5 -  Recovery Using FEM
	__1.  In the Servers view, start the ProductCatalogApp application. In real life, you will need to fix the prevailing error condition.
	__2.  In the Servers view, right click the server and select Administration > Run administrative console.
	__3.  Log in using admin/admin.
	__4.  Expand Integration Applications.
	__5.  Click Failed Event Manager.
	__6.  Click Get all failed events link.
	__7.  Click the event ID of one of the messages.
	__8.  You can view the name of the import and the operation that failed. You can also edit the business data by clicking Edit business data. Play with the interface a little. But don't change anything.
	__9.  Clear the Console.
	__10.  Back in administration console, click Failed Event Manager on the left hand side. Then click Get all failed events again.
	__11.  Click the Select All button to select all failed events.
	__12.  Click the Resubmit button.
	__13.  Make sure that the Console view shows the log messages from the target service. For example:
	__14.  Logout the admin console and close the browser.
	__15.  Close the test and do not save changes.

	Part 6 -  Review

	Lab 17 -  Recovery Using Store and Forward
	Part 1 -  Enable Store and Forward
	__1.  Right click the server and select Add and Remove Projects.
	__2.  Select CatalogModuleApp and click Remove.
	__3.  Click Finish. Wait until the server finish publishing.
	__4.  In the assembly diagram, select CatalogManagerImport1.
	__5.  In the Properties view, select the Details tab.
	__6.  Select the CatalogManager service interface.
	__7.  On the right hand side, click the Qualifiers tab.
	__8.  Click Add.
	__9.  Select Store and forward and click OK.
	__10.  Select the newly added Store and forward qualifier. Set the Configuration name property to MySF.  You may need to expand the Property view to see the settings.
	__11.  Save changes.

	Part 2 -  Test for Error Condition
	__1.  Make sure the server is running.
	__2.  In the Servers view, stop ProductCatalogApp.
	__3.  Right click the server and select Add and Remove Projects.
	__4.  Select CatalogModuleApp and click Add.
	__5.  Click Finish. Wait until the server finish publishing.
	__6.  Right click AddProductFlow in the assembly diagram and select Test Component.
	__7.  From the test GUI, invoke the addProduct operation at least three times. Write down the names of all products you have added this way.

	Part 3 -  Recovery Using Store and Forward
	__1.  Start ProductCatalogApp application. This simulates fixing of the error condition.
	__2.  Clear the Console view.
	__3.  In the Servers view, right click the server and select Administration > Run administrative console.
	__4.  Log in using admin/admin.
	__5.  In the administration console, expand Integration Applications.
	__6.  Click Failed Event Manager on the left and then click Get all failed events.
	__7.  There should be one failed event there. Select the checkbox for it. Then click Resubmit.
	__8.  Open a web browser. Enter the URL: https://localhost:9443/BusinessSpace/
	__9.  Get past the SSL certificate warning of the browser.
	__10.  Log in as admin/admin.
	__11.  Go to the Home page and click the Start button.
	__12.  Expand Service Administration. Note that Store and Forward is listed there.
	__13.  Click the Store and Forward link.
	__14.  Click MySF to select it. On the right hand side, you will see details.
	__15.  Check the checkbox for MySF. 
	__16.  Click the Forward button.
	__17.  The status icon will change to show that it is in forwarding state.
	__18.  The Console view will now show all log messages from the target web service. Make sure that all messages have been recovered.
	__19.  Logout from the admin console and business space.
	__20.  Close all open files and browsers.

	Part 4 -  Review

	Lab 18 -  Protocol Translation Pattern
	Part 1 -  Business Logic and Architecture
	Part 2 -  Create a Mediation Module
	__1.  Create a mediation module called AdapterTest. Choose not to create any mediation component.

	Part 3 -  Design Data Model
	__1.  Inside the mediation module that you just created, create a new business object (data type) called ProductACMS
	__2.  Add these fields.
	__3.  Save and close.
	__4.  Create a new business object called ProductGBO
	__5.  Add these fields.
	__6.  Save and close.
	__7.  Create a new business object called ProductListGBO
	__8.  Add a field as follows. It is an array of ProductGBO. Remember to make it array.
	__9.  Save and close.

	Part 4 -  Define the Mediation Service Interface
	__1.  Create a new interface called CatalogManager
	__2.  Add a new one-way operation as follows.
	__3.  Save and close.

	Part 5 -  Create the Adapter Based Service for ACMS
	__1.  Right click the AdapterTest project and select New > External Service.
	__2.  Take a moment to study the list of available adapters.
	__3.  Expand Flat File.
	__4.  Select Advanced: Create a Flat file service using the complete wizard.
	__5.  Click Next.
	__6.  Click Next again.
	__7.  Change the name of the Connector project to CatalogFlatFile
	__8.  Select WebSphere ESB Server v7.0 as the runtime.
	__9.  Click Next.
	__10.  Select Outbound. This is because, the mediation flow will send out data from it.
	__11.  Click Next.
	__12.  Leave the default deployment option. This will cause the JCA project (CatalogFlatFile) to be included in the mediation module application (AdapterTestApp).
	__13.  From the drop down, select the Data format options to Specify a data format for each operation
	__14.  Click Next.
	__15.  Click Add.
	__16.  A few things to note in this screen.
	__17.  Click Next.
	__18.  Set the operation name to createProduct
	__19.  Click the Browse button.
	__20.  Select the input type ProductACMS
	__21.  Click OK.
	__22.  In the Data format options drop down, select Use a data format configuration.
	__23.  Click the Select button to choose the format.
	__24.  In the window that opens, click Next.
	__25.  Click the Select button 
	__26.  Expand Delimited and select CSVDataHandler.
	__27.  Click Finish.
	__28.  Click Next.
	__29.  Click Finish.
	__30.  Our operation design is now complete. Click Finish.
	__31.  Click Next.
	__32.  Change the name of the service to ACMSService
	__33.  Click Finish.
	__34.  Note that a new interface called ACMSService has been created. Open it and study the interface.
	__35.  Close the file.

	Part 6 -  Configure the Import
	__1.  Open the assembly diagram.
	__2.  Note that an EIS import called ACMSService has been created for the adapter based service. Select it.
	__3.  In the Properties page, select the Method bindings tab.
	__4.  Select the createProduct method.
	__5.  Set the output directory name to C:\temp\out
	__6.  Click Advanced.
	__7.  Check Generate a unique file.
	__8.  Save changes and close the assembly diagram.

	Part 7 -  Design the Mediation Flow
	__1.  Right click Integration Logic and select New > Mediation Flow.
	__2.  Enter CatalogMediation as the name.
	__3.  Click Next.
	__4.  As source interface, add the generic interface CatalogManager.
	__5.  As the target reference add the ACMSService interface.
	__6.  Click Finish.
	__7.  Click the createProduct source method.
	__8.  Click Service Integration.
	__9.  Click Add.
	__10.  Click OK to select the createProduct target operation.
	__11.  Click OK to create the service.
	__12.  Add a Fan Out primitive to the flow.
	__13.  Connect the output of CatalogManager: createProduct to the input of FanOut1.
	__14.  Select FanOut1.
	__15.  In the Properties page, select Details tab.
	__16.  Select  for each element in XPath expression.
	__17.  Click Edit.
	__18.  Expand Data Types > ServiceMessageObject > body > createProduct > list : ProductListGBO.
	__19.  Select Product : ProductListGBO [0..n].
	__20.  Click OK.
	__21.  Connect the out terminal of FanOut1 to the in terminal of  ACMSServicePartner : createProduct. 
	__22.  Click Transform the message using an XSL Transformation primitive.
	__23.  Double click XSL Transformation1.
	__24.  Click Next.
	__25.  Choose "/" as the message root. Why do we do this?
	__26.  Click Finish.
	__27.  Map the elements from FanOutContext/occurrence of the source to the target as shown below.
	__28.  Save and close the map.
	__29.  Save the mediation flow. We are done!

	Part 8 -  Wire Components
	__1.  Open the assembly diagram.
	__2.  Add the mediation flow to it.
	__3.  Wire the reference of the mediation flow to ACMSService import.
	__4.  Save changes.

	Part 9 -  Expose Mediation Flow as Web Service
	__1.  In the assembly diagram, right click CatalogMediation and select Generate Export > Web Service Binding.
	__2.  Select SOAP1.1/HTTP.
	__3.  Click Finish.
	__4.  Save changes.

	Part 10 -  Deploy and Test
	__1.  Start the server if it is not running. Wait for the server to start.
	__2.  Right click the server and select Add and Remove Projects.
	__3.  Remove all currently deployed projects.
	__4.  Add AdapterTestApp.
	__5.  Expand AdapterTestApp and note that CatalogFlatFile JCA project is a part of it.
	__6.  Click Finish. Wait for publishing to end.
	__7.  Create the output folder C:\temp\out
	__8.  In the AdapterTest module, expand Web Services Ports.
	__9.  Right click CatalogManagerExport1_CatalogManagerHttpPort and select Web Services > Test With Web Services Explorer.
	__10.  Click createProduct.
	__11.  Next to the product element click Add.
	__12.  Add sku, name and price elements and enter some values for them.
	__13.  Similarly, add one more product.
	__14.  Click Go.
	__15.  The console may show an Exception. We can ignore that.
	__16.  Verify that C:\temp\out now contains two files (one for each product).
	__17.  View the contents of the files using Notepad. Make sure that they are valid.
	__18.  Close these files.
	__19.  Back in Business Integration close all open files.

	Part 11 -  Review

	Lab 19 -  Implementing Service Gateway Pattern
	Part 1 -  Business Logic and Solution Architecture
	Part 2 -  Import Projects
	__1.  Import all projects from the project interchange file C:\LabFiles\ACMEOrder.zip.
	__2.  Verify that these projects are created:
	__3.  Open the assembly diagram for OrderModule. Note these components, probably you need to right click on the diagram and select Automatic Layout:

	Part 3 -  Generate Gateway Pattern Implementation
	__1.  From the tool bar, click Open Patterns Explorer.
	__2.  Select Proxy Service Gateway under Service Gateway .
	__3.  On the right hand side – in the editor area – study how the pattern works. Then click Create New Instance.
	__4.  Enter OrderProxy as the solution name and click OK.
	__5.  System will open the pattern configuration editor. The default settings are pretty good for our requirements. Let's review them:
	__6.  Click Generate to generate all the artifacts.
	__7.  Close all open editor windows (Control+Shift+F4).

	Part 4 -  Review Generated Artifacts
	__1.  Verify that system has created a new mediation module called OrderProxy_Gateway. All artifacts are generated there.
	__2.  Locate the ServiceGateway interface and open it.
	__3.  Note the following aspects about the interface.
	__4.  Next most important artifact is the gateway mediation flow itself. Locate and open the OrderProxy_Gateway mediation flow.
	__5.  Click the requestResponse source method to view the message flow.
	__6.  Note that a Gateway Endpoint lookup primitive called RouteMessage has been added.
	__7.  Select RouteMessage.
	__8.  In the Properties view, select the Details tab and make sure that the lookup method is URL.

	Part 5 -  Develop Common Logic
	__1.  This message flow for requestResponse source operation that should be already open in the editor. If not, open it.
	__2.  Right click the flow and select Automatic Layout.
	__3.  In the message flow, delete the connection between the input node and the RouteMessage Gateway Endpoint Lookup primitive.
	__4.  On the left hand side palette, locate the Trace primitive in the Tracing drawer.
	__5.  Add a Trace primitive to the diagram.
	__6.  Connect the input node to the in terminal of the Trace primitive.
	__7.  Connect the out terminal of the Trace primitive to the in terminal of RouteMessage Gateway Endpoint Lookup primitive.
	__8.  Select Trace1. 
	__9.  In the Properties view, click the Details tab.
	__10.  Enter the following values.
	__11.  Click the Response tab at the top of the editor.
	__12.  Connect the Callout Fault node to Input Fault node.
	__13.  Add a Fail primitive to the flow. 
	__14.  Connect the fail terminal of Callout Response to the Fail primitive.
	__15.  Save changes. Make sure that there are no errors.

	Part 6 -  Configure Virtual Services in Business Space
	__1.  Start the server if it is not running.
	__2.  Deploy these applications:
	__3.  Wait until finish synchronizing.
	__4.  Open a browser and enter the URL for Business Space: 
	__5.  If ask for security certificate click Yes in IE or Add an Exception in Mozilla Firefox.
	__6.  Log in using user ID and password: admin
	__7.  If a security risk window shows up, click Yes to continue at any time.
	__8.  Click the Start button.
	__9.  Click Service Administration.
	__10.  Click the Proxy Gateway tab at the top.
	__11.  Click  OrderProxyProxyGroup. A proxy group is a collection of virtual services.
	__12.  Click the pencil icon for the group.
	__13.  Enter the URL for the WSDL of the place order service:
	__14.  Click Add Service.
	__15.  Change the name to PlaceOrderTarget
	__16.  Click Save.
	__17.  Similarly, add another virtual service with these parameters:
	__18.  Verify that the list of virtual services look like this.

	Part 7 -  Testing the Gateway
	__1.  Open the assembly diagram of OrderModule.
	__2.  Right click PlaceOrderSvcExport1 and select Test Component.
	__3.  Enter some value for the elements of the message body as shown below.
	__4.  Click Continue.
	__5.  Select WebSphere Enterprise Service Bus Server > WebSphere ESB Server 7.0 at localhost and make it the default server.
	__6.  Click Finish.
	__7.  In the Console view, you will see the message from the PlaceOrderFlow mediation flow.
	__8.  Click the invoke button to create new test.
	__9.  Change the Component to CancelOrderSvcExport1.
	__10.  Enter some sample data as shown below.
	__11.  Click Continue.
	__12.  The Console view will have the output from the CancelOrderFlow mediation flow.
	__13.  Close all open editors (Control+Shift+F4), do not save changes in the test component.
	__14.  Expand OrderLib > Web Service Ports. 
	__15.  Right click PlaceOrderSvcExport1_PlaceOrderSvcHttpPort and select Web Services > Test With Web Services Explorer.
	__16.  In the Endpoints section, click Add.
	__17.  Enter the URL for the PlaceOrder service exposed through the gateway mediation flow:
http://localhost:9080/OrderProxy_GatewayWeb/sca/OrderProxy_GatewayExport_WS_SOAP11/PlaceOrderTarget
	__18.  Click Go.
	__19.  In the Operations section click placeOrder.
	__20.  Verify that the endpoint for the gateway is selected by default.
	__21.  Next to SKU, click Add. Enter a value for the SKU.
	__22.  Similarly, enter some values for quantity and customerId.
	__23.  Clear the Console view.
	__24.  Back in web services explorer, click Go.
	__25.  Look at the Console. There will be a few exception stack traces. We will explain that soon. 
	__26.  Scroll up to the very top. Make sure that you see the audit log of the request message as well as the output from PlaceOrderFlow mediation flow.
	__27.  Close all open files.
	__28.  Clear the console.
	__29.  Similarly, test the cancel order scenario. This time use these values:
	__30.  Close all open files.
	__31.  Clear the console.
	__32.  Logout in Business Space and close the browser.

	Part 8 -  Review

	Lab 20 -  Event Monitoring
	Part 1 -  Emit Event from Mediation Flow
	__1.  In the OrderModule, open PlaceOrderFlow.
	__2.  Click the placeOrder source operation to view the message flow.
	__3.  Add an  Event Emitter primitive to the flow (under Tracing).
	__4.  Connect the out Trace1 primitive to the in EventEmitter1 primitive.
	__5.  Select  the EventEmitter1 primitive. 
	__6.  From the Properties view, click Details tab.
	__7.  As the root element of the event's message, enter  /body/placeOrder
	__8.  Save and close the mediation flow.

	Part 2 -  Configure Events for an SCA Component
	__1.  Open the assembly diagram for OrderModule.
	__2.  Select the PlaceOrderFlow component.
	__3.  From the Properties view, click Details tab.
	__4.  Expand Interfaces > PlaceOrderSvc and select the placeOrder operation.
	__5.  On the right hand side, click the Event Monitor tab.
	__6.  Click Selected.
	__7.  Check the Entry and Exit events.
	__8.  Save changes.

	Part 3 -  Configure CEI Security
	__1.  Right click the server in the Servers view, and select Administration > Run administration console. Click Yes for security is asks.
	__2.  Log in as admin/admin.
	__3.  In the left pane, expand Service Integration > Common Event Infrastructure and click Event Service.
	__4.  In the right pane, under Additional Properties, click Map security roles to users or groups.
	__5.  Check all 6 boxes and select Everyone under the drop-down for Map Special Subjects.
	__6.  Click OK once the settings match that shown below.
	__7.  Click the Save link.
	__8.  Wait for the synchronization to complete. We have completed configuring CEI security.

	Part 4 -  Test
	__1.  Publish changes to the server.
	__2.  In the assembly diagram, right click PlaceOrderSvcExport1 and select Test Component.
	__3.  Enter some input data.
	__4.  Click Continue to invoke the method.

	Part 5 -  Browse Events
	__1.  Back in the Administrative Console, in the left pane, expand the Integration Applications group and click on Common Base Event Browser.  
	__2.  Click All Events.
	__3.  You should see these three events.
	__4.  The event with the name OrderModule_PlaceOrderFlow_EventEmitter1_Req is the one posted from within the mediation flow. Click its timestamp to view details.
	__5.  In the bottom pane, scroll down and locate the wbi:event attribute.
	__6.  Click on the message hyperlink.
	__7.  You should see the contents of the request message.
	__8.  Log out of administration console.
	__9.  Close all open editor windows. Don't save changes in the test component.

	Part 6 -  Review

	Lab 21 -  Understanding Static Relationship
	Part 1 -  Solution Summary
	Part 2 -  Import the Solution
	__1.  Import the project interchange file C:\LabFiles\StaticRelationshipDemo‑Starter.zip.
	__2.  Expand the imported project.

	Part 3 -  Inspect the Data Types
	__1.  Expand StaticRelationshipDemo->Data Types.
	__2.  Inspect them quickly. The purpose of these data types should be self explanatory. They have a very similar structure, but use slightly different field names.

	Part 4 -  Inspect the Interfaces
	__1.  Expand StaticRelationshipDemo->Interfaces.
	__2.  Have a brief look at them.
	__3.  Close all open files.

	Part 5 -  Inspect the Data Maps
	__1.  Expand Transformations->Data Maps.
	__2.  Open AccountingAddress_To_AddressGBO object map.  (You can ignore the maps in the subfolders as they are just to wrap these main Business Object maps)
	__3.  Notice how the country code fields are not currently mapped as these will use the relationship you create later.
	__4.  Similarly, inspect the AddressGBO_To_WarehouseAddress object map.
	__5.  Close all open files.

	Part 6 -  Inspect the Mediation Flows
	__1.  Expand Integration Logic → Mediation Flows.
	__2.  Open the AccountingAddressValidator_To_GenericAddressValidator mediation flow.
	__3.  Select the link for the validate method.
	__4.  Select the Business Object mapping primitive in the middle of the request mediation flow.
	__5.  Go to the Properties view and select the Details tab.
	__6.  Click the Edit button for the mapping file and notice that the map that is being used (in the 'bo' folder of the data maps) is using the data map you looked at previously as a submap.
	__7.  Similarly, inspect the GenericAddressValidator_To_WarehouseAddressValidator mediation flow.
	__8.  Close all open editors.

	Part 7 -  Inspect the Assembly Diagram.
	__1.  Open the assembly diagram.

	Part 8 -  Create the Relationship
	__1.  Right click on Transformations and select New → Relationship.
	__2.  Fill in a name of CountryRel and click the Next button.
	__3.  Switch to a Static relationship type and click the Next button.
	__4.  Leave the option for Identity relationship selected and click the Finish button.
	__5.  Once you have created the relationship click the Add role button as shown below.
	__6.  Select the AccountingAddress type and click the OK button.
	__7.  With the AccountingAddress role still selected click the Add key attribute button.
	__8.  Select the COUNTRY_ID property and click the OK button.
	__9.  Back in the relationship editor again click the Add role button.
	__10.  This time select AddressGBO from the list and click the OK button.
	__11.  With the second role still selected click the Add key attribute button.
	__12.  Select the country property and click the OK button.
	__13.  Click the Add role button a third time and this time scroll down to select WarehouseAddress from the list before clicking the OK button.
	__14.  With the third role still selected click the Add key attribute button and then select the countryCode property and click the OK button.
	__15.  At this point the roles are complete.  Save the relationship but keep the file open for the next section and make sure that there are no errors on the roles but there is an error shown on the main 'CountryRel' icon as shown below.

	Part 9 -  Initialize the Lookup Table
	__1.  Click the CountryRel button in the relationship editor. This selects the relationship itself so that we can view and modify its properties.
	__2.  In the Properties view, click the Instance Data tab.  You may want to maximize the view to give you more room.
	__3.  There is already one instance row in the table (with an 'Instance ID' of 1) but the values are empty.  Click the empty columns in the first row so you can type values.
	__4.  Enter the values as follows.
	__5.  Check that your values for the first row appear as shown below.
	__6.  Click the Add button to create a second new instance for Canada.
	__7.  Enter the values as follows.
	__8.  Click the Add button to create a new instance for France.
	__9.  Enter the values as follows.
	__10.  Check that your relationship has three complete rows in the instance data as shown below and there are no blank rows or values.
	__11.  Save and close the relationship.  There should be no errors shown in the relationship after you save it.  You may first need to restore your Properties view to normal size if you maximized it.

	Part 10 -  Complete the Data Maps with Relationships
	__1.  Expand Transformations->Data Maps.
	__2.  Open AccountingAddress_To_AddressGBO object map.
	__3.  Click and drag a connection from the COUNTRY_ID property of AccountingAddress on the left to the country property of AddressGBO on the right to create a mapping between the two.  Right now it will be a 'Move' mapping but we will change that.
	__4.  With the transformation still selected (click the blue box if it is not) look in the Properties view.
	__5.  Change the Transform type to a Relationship Lookup.  You will need to scroll down the list to see this option.
	__6.  Once the transform type is switched click the Details tab.
	__7.  Change the following properties in the Details tab:
	__8.  Click somewhere else in the Properties view to make sure your properties are set and then save and close the data map.
	__9.  Open AddressGBO_To_WarehouseAddress object map.
	__10.  Click and drag a connection from the country property of AddressGBO on the left to the countryCode property of WarehouseAddress on the right to create a mapping between the two.  Right now it will be a 'Move' mapping but we will change that.
	__11.  With the transformation still selected (click the blue box if it is not) look in the Properties view.
	__12.  Change the Transform type to a Relationship Lookup.  You will need to scroll down the list to see this option.
	__13.  Once the transform type is switched click the Details tab.
	__14.  Change the following properties in the Details tab:
	__15.  Click somewhere else in the Properties view to make sure your properties are set and then save and close the data map.

	Part 11 -  Deploy and Test
	__1.  Start your server if it is not already.
	__2.  Add the StaticRelationshipDemoApp project to the server.
	__3.  Open the assembly diagram, right click in the assembly diagram and select Test Module.
	__4.  In the Component drop down select AccountingAddressValidator_To_GenericAddressValidator. 
	__5.  Enter something in the address fields. Make sure that the COUNTRY_ID is -1 for US as shown below:
	__6.  Click the Continue button to start testing.
	__7.  In the Deployment Location dialog, check the Use this as default ... checkbox and click Finish.
	__8.  The system will halt at the emulation point when the warehouse service is invoked.
	__9.  Select the Input tab and notice the countryCode field is automatically set to US, which is appropriate for the warehouse.
	__10.  Select the Output tab.
	__11.  Change the out parameter's value to true.
	__12.  Click the Continue button to continue with testing.
	__13.  In the Events listing table, select the Request node as shown below. This shows the input fed into the GenericAddressValidator_To_WarehouseAddressValidator map by the AccountingAddressValidator_To_GenericAddressValidator map.
	__14.  You will see that the generic country field was set to United States.
	__15.  Repeat the test with country code -2.  Below is the data that would be in the generic object and notice the 'country' value of Canada.
	__16.  Do the test again with country code -4. It should fail.
	__17.  Close all open editors. Don't save changes.

	Part 12 -  Review

	Lab 22 -  Service Version Migration
	Part 1 -  Import Starting Projects
	__1.  Select File → Import from the WID menus.
	__2.  Select Other → Project Interchange and click the Next button.
	__3.  Browse to select the zip file <LABFILES>\VersionDemoStarter.zip.
	__4.  Back in the import dialog press the Select All button to choose all the projects as shown below and click the Finish button.
	__5.  After the projects are imported and built check the Problems view to be sure there are no errors.  You may see some warnings.

	Part 2 -  Deploy to the Test Server
	__1.  Start the server if it is not running and be sure you don't get any errors in the Console view when starting.
	__2.  Right-click on the server and select Add and Remove Projects...
	__3.  Undeploy all projects.
	__4.  Add only the VersionDemoServiceApp, VersionDemoClientAppV1, and VersionDemoClientAppV2 projects.  These are the enterprise applications that contain the two service versions and the client.
	__5.  Click the Finish button in the dialog.
	__6.  Publish the server if it doesn't automatically.
	__7.  Make sure you do not get any errors in the Console view when publishing.

	Part 3 -  Test Projects
	__1.  Right-click on input.jsp (under VersionDemoClient | WebContent) and select Run As | Run on Server.
	__2.  Select your ESB test server if not already, check the box to always use this server  and click Finish to deploy all projects.
	__3.  Fill in a value of '3' for the account ID and '50.00' for the amount and click the Withdraw button.
	__4.  Open the Console view if it is not open (Window → Show View → Other, then General → Console) and check that you see the following output.  Note among other things that this is the V1.0 service implementation.
	__5.  Press the back button and fill in an account ID of '3' and any positive amount and click Deposit.
	__6.  In the Console view you should see the output.
	__7.  Press the back button and fill in an account ID of '5' and any positive amount and click Deposit.  This account ID will generate an error every time.
	__8.  Close the test browser but leave the server running.
	__9.  Expand the VersionDemoServiceV1 → WebContent → WEB-INF → wsdl folder.
	__10.  Right click on the VersionDemoServiceV1ImplService.wsdl file and select Web Services → Test with Web Services Explorer.
	__11.  Notice the Endpoint has the version of the service in the URL.  This can be important because you might need to run several versions of a service concurrently.
	__12.  Click on the link for the deposit operation.
	__13.  Fill in an id of '12' and some positive value for the amount and click the Go button to submit the request to the service.
	__14.  In the Status section (you may want to double click the section header to temporarily maximize the panel) notice that you get a boolean value of 'true' indicating that the operation completed successfully.
	__15.  Notice that you also get similar Console output.
	__16.  Back in the parameters of the deposit operation (you may need to restore the size of the Status section) fill in a value of '5' for the ID and any positive value for amount and click the Go button again to submit the request.
	__17.  Look in the Status section again and notice this time the return value is a boolean value of 'false' to indicate there was an error.
	__18.  Expand the VersionDemoServiceV2 → WebContent → WEB-INF → wsdl folder.
	__19.  Right click on the VersionDemoServiceV2ImplService.wsdl file and select Web Services → Test with Web Services Explorer.
	__20.  Notice that besides the new 'openAccount' operation the endpoint location is also different.  As mentioned this could let us run both service versions at the same time which is often required for many service version migrations.
	__21.  Click on the link for the deposit operation.
	__22.  Fill in an id of '12' and some positive value for the amount.  Also fill in a value of 'Savings' for the 'accountType' and click the Go button to submit the request to the service.
	__23.  In the Status section notice that you now get a double value for the current balance of the account.  This is one change we will have to take into account in the mediation flow.
	__24.  In the Console output notice the output indicates this is the V2.0 service and also prints out the type of account being used.
	__25.  Back in the parameters of the deposit operation fill in a value of '5' for the ID and any positive value for amount and the same accountType and click the Go button again to submit the request.
	__26.  In the Status section notice the output can't be displayed in the form view.  Click the Source link to switch the view.
	__27.  In the source view notice the SOAP Response Envelope is a fault which includes the same error message ("Invalid Account Number") that previously we had only been able to see in the Console output on the server.  Clearly this version of the service has more advanced error handling that returns a fault when there is a problem instead of a boolean value indicating success or failure of the operation.  This is something that will affect our mediation flow also because our mediation flow will need to respond like the V1 service does.
	__28.  Close the browser for the Web Service Explorer but leave the server running.

	Part 4 -  Create Mediation Module and Import Resources
	__1.  From the menus, select File → New → Mediation Module.
	__2.  Enter the following values:
	__3.  Click Finish.
	__4.  In WID, right click the VersionDemoMediation project and select Import.
	__5.  Expand Business Integration and select WSDL and XSD.
	__6.  Click Next.
	__7.  Select Local WSDL or XSD file, or both.
	__8.  Click Next.
	__9.  Use the Browse button to select the C:\workspace\VersionDemoServiceV1\WebContent\WEB-INF\wsdl folder and click OK.
	__10.  Check VersionDemoServiceV1ImplService.wsdl
	__11.  Accept the other defaults as shown below.
	__12.  Click Finish.
	__13.  In the project you should see various imported resources.
	__14.  Again, right click the VersionDemoMediation project and select Import.
	__15.  Expand Business Integration and select WSDL and XSD.
	__16.  Click Next.
	__17.  Select Local WSDL or XSD file, or both.
	__18.  Click Next.
	__19.  Use the Browse button to select the C:\workspace\VersionDemoServiceV2\WebContent\WEB-INF\wsdl folder and click OK.
	__20.  Check VersionDemoServiceV2ImplService.wsdl
	__21.  Accept the other defaults as shown below.
	__22.  Click Finish.
	__23.  At the top of the Business Integration view click the Show Namespaces button.
	__24.  In the project you should see that the resources are organized by namespace which will make them easier to distinguish since they often have duplicate names but differ by the namespace which is a common approach to service versioning.

	Part 5 -  Create Mediation Flow
	__1.  Right click VersionDemoMediation > Integration Logic and select New > Mediation Flow.
	__2.  Enter VersionDemoV1ToV2Flow as the name.
	__3.  Click Next.
	__4.  Click the Add button for Sources interfaces.
	__5.  Select the VersionDemoService interface and make sure it is the one from the 'V1' namespace as shown below and click OK.
	__6.  Click the Add button for Target references.
	__7.  Select the VersionDemoService interface this time making sure it is the one from the 'V2' namespace as shown below and click OK.
	__8.  Double check that you have the interface from the 'V1' namespace as the source interface and the interface from the 'V2' namespace as shown below and click the Finish button.
	__9.  Leave the mediation flow open for the next section.

	Part 6 -  Implement Withdraw Mediation Flow
	__1.  From the WID menu select Window → Preferences.
	__2.  Expand the Business Integration group and select the Mediation Flow Editor preferences.
	__3.  Check the box next to the 'Show mediation template options when editing an unimplemented source operation' preference if this is not already checked.  You may have disabled this in previous labs but it will help us quite a bit for this mediation flow.
	__4.  Click OK to close the preferences dialog.
	__5.  Back in the mediation flow editor click the link for the 'withdraw' operation and then the link for 'Operation Map' in the template pop-up that appears.
	__6.  Select the withdraw operation in the dialog that appears and click OK.  This will map the 'withdraw' operation of the V1 source interface to the 'withdraw' operation of the V2 target interface which is what we want.
	__7.  Notice that using this template has already done a lot of work.  It has already added a Request/Response mediation flow with data transformation node linking the input and callout nodes in the flow.  The main thing we will need to do is to implement the data mapping and handle the fault in the response flow.
	__8.  Make sure you are in the 'Request' part of the flow and right click the 'input_map' transformation node and select Rename from the context menu.
	__9.  Change the name to 'withdrawRequestV1_To_V2' and hit <ENTER> to accept the new name.
	__10.  Double click the transformation node to open the dialog to create a new XML map.
	__11.  Remove the added suffix of '_req_1' so the name is just 'withdrawRequestV1_To_V2' as shown below and click the Finish button.
	__12.  In the mapping editor that opens click the 'Map source to target based on name and types' button.  This will create a local map.
	__13.  Expand the 'withdraw' types on both sides and click on the blue box of the local map to select it if it is not already selected.  You should see that all the properties are green indicating that they are all included in the mapping.
	__14.  Click on the 'Edit' arrow icon on the right corner of the local map transformation.  This will open the mapping to view even though we will not change it.
	__15.  Notice that the values are just using the standard 'Move' mapping which is fine for this mapping since the data structure and types are the same.
	__16.  Save and close the mapping editor.
	__17.  Back in the mediation flow editor click the 'Response' tab.
	__18.  Make sure you are in the 'Response' part of the flow and right click the 'output_map' transformation node and select Rename from the context menu.
	__19.  Change the name to 'withdrawResponseV2_To_V1' and hit <ENTER> to accept the new name.
	__20.  Double click the transformation node to open the dialog to create a new XML map.
	__21.  Remove the added suffix of '_res_1' so the name is just 'withdrawResponseV2_To_V1' as shown below and click the Finish button.
	__22.  Expand both of the 'withdrawResponse' types in the mapping.  Notice that in this case the return types are different so we must decide how to create the behavior we want with the mapping.
	__23.  Right click on the 'complete' element of the 'withdrawResponse' type on the right and select Create Assign.
	__24.  With the newly created 'Assign' transformation still selected go to the Properties view and change the value to 'true'.
	__25.  Click somewhere else in the mapping editor to make sure the new value is set.
	__26.  Save and close the mapping editor.
	__27.  Back in the mediation flow editor expand the Transformation section of the mediation editor palette.
	__28.  Click and drag a new XSL Transformation node to the right of the Callout Fault node.
	__29.  Right click the new transformation node and select Rename from the context menu.
	__30.  Change the name to 'withdrawFaultV2_To_V1' and hit <ENTER> to accept the new name.
	__31.  Click and drag a new connection between the output terminal of the Callout Fault node and the input terminal of the withdrawFaultV2_To_V1 node as shown below.  Make sure they are connected as this will set the terminal type on the transformation node.
	__32.  Click and drag a new connection between the output terminal of the withdrawFaultV2_To_V1 node and the input terminal of the Input Response node as shown below.
	__33.  Double click the withdrawFaultV2_To_V1 transformation node to open the dialog to create a new XML map.
	__34.  Remove the added suffix of '_res_1' so the name is just 'withdrawFaultV2_To_V1' as shown below and click the Finish button.
	__35.  Expand both of the data types in the mapping.  Again there is not a direct mapping between the types.
	__36.  Right click on the 'complete' element of the 'withdrawResponse' type on the right and select Create Assign.
	__37.  With the newly created 'Assign' transformation still selected go to the Properties view and check that the value is set to 'false'.
	__38.  Save and close the mapping editor.
	__39.  Back in the mediation flow editor check that your response flow of the 'withdraw' operation appears as shown below and save the mediation flow.

	Part 7 -  Deploy and Test in Isolation
	__1.  Open the Assembly Diagram of the VersionDemoMediation project.
	__2.  Drag the VersionDemoV1ToV2Flow mediation flow onto the diagram.
	__3.  Save the assembly diagram but don't close it.
	__4.  Start the server if it is not already and be sure you don't get any errors in the Console view when starting.
	__5.  Right-click on the server and select Add and Remove Projects...
	__6.  Add only the VersionDemoMediationApp project in addition to the three others already deployed.
	__7.  Click the Finish button in the dialog.
	__8.  Publish the server if it doesn't automatically.
	__9.  Make sure you do not get any errors in the Console view when publishing.
	__10.  Back in the assembly diagram right click the  mediation flow and select Test Component.
	__11.  Switch the operation being tested to 'withdraw' and modify the input values as shown below.
	__12.  Press the Continue button on the left side to start the test.
	__13.  If prompted, select the ESB server from the choices, make it the default and click the Finish button.
	__14.  After a second you should be asked to provide a value to emulate the service. Select the Input tab on the right to check that the values you input have made it through the data transformation.
	__15.  Click the Output tab again and fill in a balance value and again click the Continue button on the left side to continue the test.
	__16.  Finally check that you get a return value of 'true'.
	__17.  Close but don't save the test.

	Part 8 -  Implement Deposit Mediation Flow
	__1.  Switch back to the mediation flow editor and make sure you are in the 'Overview' tab.
	__2.  Click the link for the 'deposit' operation and then the link for 'Operation Map' in the template pop-up that appears.
	__3.  Select the deposit operation in the dialog that appears and click OK.  This will map the 'withdraw' operation of the V1 source interface to the 'withdraw' operation of the V2 target interface which is what we want.
	__4.  Make sure you are in the 'Request' part of the flow and right click the 'input_map' transformation node and select Rename from the context menu.
	__5.  Change the name to 'depositRequestV1_To_V2' and hit <ENTER> to accept the new name.
	__6.  Double click the transformation node to open the dialog to create a new XML map.
	__7.  Remove the added suffix of '_req_1' so the name is just 'depositRequestV1_To_V2' as shown below and click the Finish button.
	__8.  In the mapping editor that opens click the 'Map source to target based on name and types' button.  This will create a local map.
	__9.  Expand the 'deposit' types on both sides and click on the blue box of the local map to select it if it is not already selected.  You should see that all the properties are green indicating that they are all included in the mapping.  Unlike the previous mapping though there is a change we need to make to this one.
	__10.  Click on the 'Edit' arrow icon on the right corner of the local map transformation.  This will open the mapping to view even though we will not change it.
	__11.  Notice that the 'id' and 'amount' values are mapped by a "Move' mapping but the 'accountType' is not currently mapped.
	__12.  Right click on the 'accountType' property and select Create Assign.
	__13.  With the newly created 'Assign' transformation still selected go to the Properties view and change the value to 'Checking'.
	__14.  Click somewhere else in the mapping editor to make sure the new value is set.
	__15.  Save and close the mapping editor.
	__16.  Back in the mediation flow editor click the 'Response' tab.
	__17.  Make sure you are in the 'Response' part of the flow and right click the 'output_map' transformation node and select Rename from the context menu.
	__18.  Change the name to 'depositResponseV2_To_V1' and hit <ENTER> to accept the new name.
	__19.  Double click the transformation node to open the dialog to create a new XML map.
	__20.  Remove the added suffix of '_res_1' so the name is just 'depositResponseV2_To_V1' as shown below and click the Finish button.
	__21.  Expand both of the 'depositResponse' types in the mapping.  
	__22.  Right click on the 'complete' element of the 'depositResponse' type on the right and select Create Assign.
	__23.  With the newly created 'Assign' transformation still selected go to the Properties view and change the value to 'true'.
	__24.  Click somewhere else in the mapping editor to make sure the new value is set.
	__25.  Save and close the mapping editor.
	__26.  Back in the mediation flow editor expand the Transformation section of the mediation editor palette.
	__27.  Click and drag a new XSL Transformation node to the right of the Callout Fault node.
	__28.  Right click the new transformation node and select Rename from the context menu.
	__29.  Change the name to 'depositFaultV2_To_V1' and hit <ENTER> to accept the new name.
	__30.  Click and drag a new connection between the output terminal of the Callout Fault node and the input terminal of the depositFaultV2_To_V1 node as shown below.  
	__31.  Click and drag a new connection between the output terminal of the depositFaultV2_To_V1 node and the input terminal of the Input Response node as shown below.
	__32.  Double click the depositFaultV2_To_V1 transformation node to open the dialog to create a new XML map.
	__33.  Remove the added suffix of '_res_1' so the name is just 'depositFaultV2_To_V1' as shown below and click the Finish button.
	__34.  Expand both of the data types in the mapping.  Again there is not a direct mapping between the types.
	__35.  Right click on the 'complete' element of the 'withdrawResponse' type on the right and select Create Assign.
	__36.  With the newly created 'Assign' transformation still selected go to the Properties view and check that the value is set to 'false'.
	__37.  Save and close the mapping editor.
	__38.  Back in the mediation flow editor check that your response flow of the 'deposit' operation appears as shown below.
	__39.  Save and close the mediation flow.

	Part 9 -  Link Mediation Flow to Imports and Test
	__1.  Return to the assembly diagram and open it if you had closed it previously.
	__2.  On the left in the Business Integration view expand the Web Service Ports and the V2 namespace and find the VersionDemoService_v2_0_Port.
	__3.  Drag and drop the VersionDemoService_v2_0_Port onto the assembly diagram. This should open a wizard.
	__4.  Leave the default option of SOAP 1.1/HTTP selected and click the Finish button.  This will add an import to the assembly diagram.
	__5.  Right click on the VersionDemoV1TOV2Flow and select Wire to Existing.  This should wire the reference partner of the mediation flow to the import of the V2 service since they both use the same interface.
	__6.  Save the mediation flow but leave it open.
	__7.  In the Servers view publish your server to make sure it has the current assembly of the module.
	__8.  Back in the assembly diagram right click the mediation flow and select Test Component.
	__9.  Switch the operation being tested to 'deposit' and modify the input values as shown below.  Use a positive ID except '5' and a positive value for amount.
	__10.  Press the Continue button on the left side to start the test.
	__11.  If prompted, select the ESB server from the choices and click the Finish button.
	__12.  After a second you should get a return value of 'true'.  Notice that you were not prompted to emulate the service as it called the actual service implementation.
	__13.  Switch to the Console view and you should see the output from the V2 service implementation including the fact that a type of 'Checking' was supplied by the mediation flow for the 'accountType' property.
	__14.  Right click the 'Invoke' test on the left and select Remove.
	__15.  Click the button to add a new Invoke test.
	__16.  Check that the mediation flow component is listed for the 'Component' and the 'deposit' operation is picked.  This time fill in an ID of '5' along with a positive amount value.
	__17.  Press the Continue button on the left side to start the test.
	__18.  If prompted, select the ESB server from the choices and click the Finish button.
	__19.  After a second you should get a return value of 'false'.  Also notice that there was a fault thrown (with the red exclamation icons) to indicate that the V2 service implementation did throw a fault as we saw when testing with the Web Services Explorer.
	__20.  Close but don't save the test.

	Part 10 -  Export Mediation Flow and Use From Client
	__1.  Back in the assembly diagram right click the VersionDemoV1ToV2Flow and select Generate Export → Web Service Binding.
	__2.  Leave the default of SOAP 1.1/HTTP selected and click the Finish button.
	__3.  Check that you have an export binding wired up to the interface of the mediation flow.
	__4.  Save and close the assembly diagram.
	__5.  In the Servers view right-click on the server and select Add and Remove Projects...
	__6.  Select the VersionDemoServiceAppV1 project and click the Remove button.  This will leave only the V2 service deployed to the server so we know the client is going through the mediation flow and not calling the V1 service directly.
	__7.  Click the Finish button in the dialog.
	__8.  Publish the server if it doesn't automatically.
	__9.  Make sure you do not get any errors in the Console view when publishing.
	__10.  Right click the server in the Servers view and select Administration → Run administrative console.
	__11.  Login with the userid/password of admin/admin.
	__12.  In the Admin Console, navigate to Applications → SCA Modules.
	__13.  Click the link for the VersionDemoMediation application.
	__14.  On the right side of the properties expand Exports → VersionDemoServiceExport1 → Binding and click the link for the JAX-WS binding.
	__15.  Highlight and then right click and Copy the entire endpoint address of the binding.  Make sure to get all of it as there may be two lines.
	__16.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__17.  Click the link for the VersionDemoClientApp application.
	__18.  Scroll down and in the list of 'Web Services Properties'  click the link for Service clients.
	__19.  Click the link for the Module on the right.  If you click the service name on the left it will take you to web service policies which are not being used for this web service.
	__20.  Under 'Web Services Properties' click the link for Web services client bindings.
	__21.  Click the first 'Edit' link in the 'Port Information' column.  Make sure you do not click the link in the 'mappings' column.
	__22.  Delete the current value in the 'Overridden Endpoint URL' box and paste in the value of the mediation flow export.  If you do not still have this in your clipboard it should be:
	__23.  Once your value is filled in as shown above click the OK button to submit the change.
	__24.  Click the Save link in the messages at the top of the Admin Console.
	__25.  Click the Logout link at the top of the Admin Console and close it.
	__26.  Right-click on input.jsp (under VersionDemoClient | WebContent) and select Run As | Run on Server.
	__27.  Select your ESB test server if not already and click Finish to deploy all projects.
	__28.  Fill in a value of '3' for the account ID and '50.00' for the amount and click the Withdraw button.
	__29.  Open the Console view if it is not open (Window → Show View → Other, then General → Console) and check that you see the following output.  Note that the output is now coming from the V2 service implementation.
	__30.  Press the back button and fill in an account ID of '3' and any positive amount and click Deposit.
	__31.  In the Console view you should see the output from the V2 service.  Notice the account type of 'Checking' being supplied by the mediation flow.
	__32.  Press the back button and fill in an account ID of '5' and any positive amount and click Deposit.  Notice the error is first generated by the V2 service which throws a fault which is then handled by the mediation flow and a value of 'false' is returned by the service operation triggering the display of the error page.
	__33.  Close the test browser and any other files.
	__34.  Stop the server.

	Part 11 -  Review

	Lab 23 -  Managed Service Client
	Part 1 -  Import Starting Projects
	__1.  Select File → Import from the WID menus.
	__2.  Select Other → Project Interchange and click the Next button.
	__3.  Browse to select the zip file <LABFILES>\ManagedClientStartingProjects.zip.
	__4.  Back in the import dialog press the Select All button to choose all the projects as shown below and click the Finish button.
	__5.  After the projects are imported and built check the Problems view to be sure there are no errors.  You may see some warnings.
	__6.  Switch to the Web Perspective by selecting 'Window -> Open Perspective -> Other -> Web'.

	Part 2 -  Deploy to the Test Server
	__1.  Start the server and be sure you don't get any errors in the Console view when starting.
	__2.  Right-click on the server and select Add and Remove Projects...
	__3.  Undeploy all projects.
	__4.  Add only the SimpleEJBEAR and SimpleEJBWebClientEAR projects.
	__5.  Click the Finish button in the dialog.
	__6.  Publish the server if it doesn't automatically.
	__7.  Make sure you do not get any errors in the Console view when publishing.

	Part 3 -  Test Client
	__1.  Right-click on input.html (under SimpleEJBWebClient | WebContent) and select Run As | Run on Server.
	__2.  Select your ESB test server if not already, make it the default and click Finish to deploy all projects.
	__3.  Fill in the name field with a value (apart from Elaine) and click Order.
	__4.  In the browser, click the back button and enter Elaine
	__5.  Click Order.
	__6.  Close the test browser but leave the server running.

	Part 4 -  Simulate Deploying the Client to a Different Environment
	__1.  Expand the SimpleEJBWebClient → WebContent → WEB-INF → wsdl folder.
	__2.  Double click the OrderService.wsdl file to open it.  This file defines the endpoint location currently used by the client code.  Click Yes if asked to use the WSDL editor.
	__3.  Switch to the Source tab.
	__4.  At the bottom of the file change the SOAP address location property to 'localhost:9085'.  This port is not available on the server and will represent the client not being able to communicate with the version of the service used to develop the code.
	__5.  Save and close the file.
	__6.  Publish the server.
	__7.  Right-click on input.html (under SimpleEJBWebClient | WebContent) and select Run As | Run on Server.
	__8.  Click Finish to deploy the projects if asks.
	__9.  Fill in any name on the input form and submit.  You should get an error shown.
	__10.  Enable the Console by selecting from the menu, Window > Show View > Other > Console.
	__11.  If you look in the Console view you should be able to find an error that mentions a 'ConnectException'.  You will not get many details besides the type of error but it is clear this is related to a network communication problem.
	__12.  Close the browser you were using to test the application but leave the server running.

	Part 5 -  Modify Code to Provide a Managed Endpoint Capability
	__1.  Expand the SimpleEJBWebClient → Java Resources → src → com.webage.ejb folder.
	__2.  Open the OrderService.java file by double clicking it.
	__3.  Notice the @WebServiceClient annotation.  This declares a "name" for the service client and a default WSDL location which is the file you edited previously.  The generated code also extends the javax.xml.ws.Service class.
	__4.  Look for the two constructors in the class a little further down.  Notice that the constructor that doesn't take parameters uses the default WSDL location to construct a reference to the service.
	__5.  Close the OrderService class.  
	__6.  Expand the com.webage.servlet package in the SimpleEJBWebClient project.
	__7.  Open the OrderServlet.java file.
	__8.  In the doGet method remove the line of code that is crossed out below.  You will get errors after doing so but they will be fixed later.  You may also get errors if the server tries to republish but ignore them for now.
	__9.  Add the following code in bold as a new field in the class.  Make sure to add it inside the brackets for the class but outside of any other method.
	__10.  Organize imports (CTRL-SHIFT-O) to include the import for the WebServiceRef annotation.
	__11.  Save the code and be sure there are no errors.

	Part 6 -  Change Endpoint Binding Administratively
	__1.  Publish the server.
	__2.  Right-click on the server and select Add and Remove Projects...
	__3.  Remove the SimpleEJBWebClientEAR project by selecting it and clicking the Remove button.
	__4.  Click Finish in the dialog.
	__5.  Publish the server.  Wait for the server to finish publishing.
	__6.  Right-click on the server and select Add and Remove Projects...
	__7.  Add the SimpleEJBWebClientEAR project by selecting it and clicking the Add button.
	__8.  Click Finish in the dialog.
	__9.  Publish the server.  Wait for the server to finish publishing.
	__10.  Right click the server in the Servers view and select Administration → Run administrative console.
	__11.  Login with the userid/password of admin/admin.
	__12.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__13.  Click the link for the SimpleEJBWebClientEAR application.
	__14.  Scroll down and in the list of 'Web Services Properties'  click the link for Service clients.
	__15.  Click the link for the Module on the right.  If you click the service name on the left it will take you to web service policies which are not being used for this web service.
	__16.  Under 'Web Services Properties' click the link for Web services client bindings.
	__17.  Click the first 'Edit' link in the 'Port Information' column.  Make sure you do not click the link in the 'mappings' column.
	__18.  Accept the default URL option as shown below and press the OK button.  This will apply the URL with the correct port to the endpoint binding.
	__19.  Click the Save link in the messages at the top of the Admin Console.
	__20.  Click the Logout link at the top of the Admin Console and close it.

	Part 7 -  Verify Client Works with the New Binding
	__1.  Right-click on input.html (under SimpleEJBWebClient | WebContent) and select Run As | Run on Server.
	__2.  Click Finish to deploy if asks.
	__3.  Fill in any name on the input form and submit.  
	__4.  You should get the "normal" output of the client which will be the "Soup Served" or "Bad Customer" message depending on the name.  You will not get the generic error page you saw before because of the connection error when the client used the wrong port.

	Part 8 -  Get WSDL Files of Published Service (Optional)
	__1.  Right click the server in the Servers view and select Administration → Run administrative console.  Login as the admin/admin userid/password.
	__2.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__3.  Click the link for the SimpleEJBEAR application.
	__4.  Scroll down and in the list on the right of 'Web Services Properties' click the link for Publish WSDL files.
	__5.  On the page that appears click the link for the zip file of WSDL files.
	__6.  If prompted to open or save the file, open it with zip file software if possible.  If you can't open it directly save it first and then open the zip file.
	__7.  Expand the folders of the zip file if needed until you see the 'OrderService.wsdl' file.
	__8.  Open the 'OrderService.wsdl' file with a text editor like WordPad.  If you need to, extract the file first and then open it.
	__9.  Scroll down in the WSDL file and notice at the end that the SOAP address uses the actual hostname of your machine (which will be different than shown below).  Since this address uses the actual hostname and not 'localhost' this address could be used by a client even on another machine to link to this service implementation.
	__10.  Close the WSDL and the zip file.
	__11.  Logout and close the admin console.
	__12.  Back in WID close all open files.
	__13.  Also close the Web perspective by selecting Window → Close Perspective.
	__14.  Stop the Server.

	Part 9 -  Review

	Lab 24 -  Setup WebSphere ESB Server (Optional)
	Part 1 -  Delete the Existing Profile
	__1.  Open a command prompt window.
	__2.  Change directory to the bin folder where the server runtime is installed.
	__3.  Run the following command to list all the profiles.
	__4.  Enter this command to delete the profile.
	__5.  It will take a few minutes. After that you should see the INSTCONFSUCCESS or INSTCONFPARTIALSUCCESS message.
	__6.  Run this command to validate that there is no profile there.
	__7.  Delete the profile's folder C:\Program Files\IBM\WID7_WTE\runtimes\bi_v7\profiles\qwps.

	Part 2 -  Modify WID Installation
	__1.  From the Windows Start menu select Programs → IBM Installation Manager → IBM Installation Manager.
	__2.  When the Installation Manager appears click on the Modify button.
	__3.  If you are prompted to update the Installation Manager click Yes to update and complete the update process.  Once Installation Manager has been updated and restarted click the Modify button again.
	__4.  Select IBM WebSphere Application Server - NDXX from the list to modify and click the Next button.  This is actually the Process Server installation we will modify to create an ESB profile.
	__5.  In the Features page, expand IBM WebSphere Process Server 7.0.0.0 > WebSphere Process Server.
	__6.  Check Stand-alone development WebSphere Enterprise Service Bus Profile (qesb).  You will still have a check for the Process Server profile but this can be ignored.
	__7.  Click Next.
	__8.  Leave the User name and Password as admin in the Common configurations page as shown below and click Next.
	__9.  Verify that Enterprise Service Bus profile (qesb) package is selected.
	__10.  Click Modify.
	__11.  The profile will take several minutes to create and the progress bar may appear stuck for most of that time.  Wait for the process to finish and click the Finish button when it is complete.
	__12.  Close the Installation Manager by selecting File → Exit.

	Part 3 -  Create a Test Server in WID
	__1.  Launch WID (Start > All Programs > IBM WebSphere Integration Developer > IBM WebSphere Integration Developer V7.0 > WebSphere Integration Developer V7.0).
	__2.  Change the workspace to 'C:\workspace' if it is not already and launch WID.
	__3.  From the Servers view, delete the existing server if present.
	__4.  In the Servers view, right click and select New > Server.
	__5.  Select WebSphere ESB Server v7.0 as the type.
	__6.  Click Next.
	__7.  Make sure that qesb is selected as profile name.  Enter admin as the password.
	__8.  Click Finish.

	Part 4 -  Verify Server Creation
	__1.  Start WebSphere ESB Server v7.0 at localhost.
	__2.  Make sure that server starts without a problem.

	Part 5 -  Review




