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Directory Paths Used in Labs
The following directories will be referred to often in the labs.  To simplify lab 
instructions there are many places where the variables listed below will be used in place 
of the actual directory path.

Some directories which should already exist before you start the labs are listed below 
with values.  Please verify the location of these directories matches what is listed here 
and make a note of the change if it does not.  Also notify your instructor if anything does 
not match.

Some directories will not yet exist as you will be installing software in the labs.  These 
are listed here so you can write down the appropriate directory here when installing the 
software.

Directories that should exist already:

<WESB_SOFTWARE_DIR>:  C:\Software\ESB_7.0
<WAS_SOFTWARE_DIR>:  C:\Software\WAS ND v70
<LABFILES_DIR>:  C:\LabFiles
<DB2_ROOT>:  C:\Program Files\IBM\SQLLIB
(C:\Program Files (x86)\IBM\SQLLIB on Windows Vista)

Directories created during labs:

<WESB_ROOT>:                                                                                  
<DM_PROFILE_ROOT>:                                                                  
<CUSTOM_ROOT>:  __________________________________
<IHS_ROOT>:  __________________________________

Other notes:

<HOSTNAME>:                                                                                    
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Lab 1 - Installing  WebSphere ESB
In this lab, you will install WebSphere Enterprise Service Bus v7.0 (WESB).  WESB is 
built on top of WebSphere Application Server, Network Deployment (WAS ND) edition 
v7.0, so when you install WebSphere Enterprise Service Bus, you're really installing 
WAS ND too.  

WESB relies on TCP/IP networking.  It is important to have networking correctly 
configured before starting the installation and the host name must remain fixed.  Your lab 
machine should be configured correctly for the lab.  

A Windows user, who belongs to the Administrators group, has already been created for 
you.  You should use this user to log in to Windows and install WebSphere Enterprise 
Service Bus:

User id:  wasadmin

Password:  wasadmin

Note that we will be using a different set of user ids and passwords to configure WESB 
and DB2 in the next lab.

Following this exercise, you should be able to:

● Install WESB

● Examine the installation and learn how to check the version of WESB

Part 1 - Install the Software
Make sure that you are logged in as the administrative user listed above.  If you are not, 
log off and log back on as the user wasadmin above.

If possible, disable any anti-virus or script-blocking software that may interfere with the 
installation.

__1. Open a Windows Explorer window.

__2. Navigate to the <LABFILES_DIR>\Install directory substituting the value of the 
<LABFILES_DIR> variable with the location mentioned in the list of directory paths at 
the beginning of these labs.  Check with your instructor if you can't find the directory 
listed.

__3. Copy the 'custom_run_template.bat' and 'custom_template_response.xml' files 
from this folder.  These files are customized versions of some files included in the ESB 
software.  They are customized already to help reduce install errors.

__4. Navigate to the <WESB_SOFTWARE_DIR>\responsefiles\WBI directory 
substituting the value of the <WESB_SOFTWARE_DIR> variable with the location 
mentioned in the list of directory paths at the beginning of these labs.  Check with your 
instructor if you can't find the directory listed.
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__5. Paste the files in this location.  You should see that these are files similar to those 
already present.

__6. Open the text editor Wordpad.  This will be better than Notepad that does not always 
show the line breaks in these files correctly.

__7. In Wordpad open the 
<WESB_SOFTWARE_DIR>\responsefiles\WBI\custom_run_template.bat file.

__8. In this file search for the text 'MODIFIED' to see the settings that were modified 
from the default file contents provided with the ESB software as shown below.

Note: Also note that the command run at the end of this file uses the 
'custom_template_response.xml' file that you also copied.

__9. Look for the 'WAS_LOCATION' variable in the batch file.   

__10. Write down this installation directory as the value of the <WESB_ROOT> 
variable in the list of directory paths at the beginning of these labs.

Note: WebSphere ESB will be installed into the same directory that WAS is installed to.

__11. Close the file and make sure you have not made any changes.

__12. In Wordpad open the 
<WESB_SOFTWARE_DIR>\responsefiles\WBI\custom_template_response.xml file.
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__13. In this file search for the text 'MODIFIED' to see the settings that were modified 
from the default file contents provided with the ESB software.  Mostly this is to point to 
the same WAS software installation under 'C:/IBM/WebSphere/ESB' and to install the 
Installation Manager under 'C:/IBM/IM'.

__14. Close the file and make sure you have not made any changes.

__15. Open a Command Prompt.  You can do this with 'Start → Programs → 
Accessories → Command Prompt'.

__16. Use the 'cd' command to switch to the 
<WESB_SOFTWARE_DIR>\responsefiles\WBI directory.

__17. Issue the command 'custom_run_template.bat' to start the execution of the 
custom silent install.  You will not be immediately returned to the command prompt 
which indicates the silent installation is proceeding.  Leave the command prompt open.

At this point, since the install may take a while your instructor will likely continue with a 
lecture or you can take a break.
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Part 2 - Confirm the Installation
In this part, you will confirm the results of the software that was installed, including some 
of the directories and the software versions.

__1. Return to the command prompt that was performing the installation.  Verify that you 
see text describing creating profiles which starts "The next step...".

__2. In the same command prompt use the 'cd' command to switch to the 
<WESB_ROOT>\bin directory using the value you wrote down for the 
<WESB_ROOT> variable earlier in the lab.

__3. Enter the command: 

versionInfo

Among other info the following will appear:

Copyright 2011 Web Age Solutions Inc. 7

EVALUATIO
N O

NLY



This command is useful if you need to confirm whether or not a fix pack or refresh pack 
from IBM has been applied.  Notice the following:

● The version of WAS ND is 7.0.0.7.
● The version of WebSphere Enterprise Service Bus is 7.0.0.0.  (This implies no fix 

packs or refresh packs have been applied to WESB.)

__4. Enter the command: 

installver_wbi -log

You will not see any output so simply wait for the command to end.

__5. Close the command prompt.

__6. Click Start > All Programs > IBM WebSphere and you will see two shortcuts 
listed underneath:  Application Server Network Deployment v7.0, and Enterprise 
Service Bus 7.0.

Also, notice that the shortcuts listed underneath Application Server Network 
Deployment v7.0 and Enterprise Service Bus 7.0 are almost identical.

__7. Last but not least, open a Windows Explorer window.
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__8. Navigate to the <WESB_ROOT> directory you wrote down in the notes at the 
beginning of these labs.  This serves as the main installation directory for WESB.

Note there is no separate directory for WAS ND, which explains why most of the 
directories are identical to the ones you'd find in a WAS ND installation.
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Some new directories introduced in the mix include:

● dbscripts – this directory has several scripts that will be needed for databases for 
Enterprise Service Bus.  We will be customizing and using these scripts later in 
other labs.

● uninstall.wbi – contains an executable used to uninstall the underlying WAS ND 
server and feature packs.

● universalDriver_wbi – contains the WESB embedded DB2 Universal JDBC 
driver.  We will be referring to this directory multiple times as we will be using 
these drivers to connect to DB2. 

__9. Navigate to the <WESB_ROOT>\logs directory.

__10. Open the 'installver' log file.  This was created by the installation verification 
utility.

__11. In the log file search for 'package.java.sdk' and be sure you see 3 issues with this 
component.  You can see this is from overlap with another package.

__12. Go to the end of the log file and be sure those were the only issues found.  There 
should only be 3 total issues.

__13. Close this log file.
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__14. Go to the <WESB_ROOT>\logs\install directory.

__15. Open the 'log.txt' file in this directory.

__16. Scroll to the bottom and check that you see the message 'INSTCONFSUCCESS' 
in the last log entry.

__17. Close this log file.

__18. Go to the <WESB_ROOT>\logs\wesb directory.

__19. Open the 'silent_install' log file.

__20. Check that there are only info messages about using the manageProfiles command 
as the "next step".  This is the same as the output in the command prompt and there isn't a 
"success" message like the regular WAS install log.

__21. Close all open windows.

Congratulations!  You have installed WebSphere Enterprise Service Bus.

Part 3 - Review
In this lab, you installed WebSphere Enterprise Service Bus.  You also examined some of 
the artifacts of the installation process and learned how to check the version of the 
software.
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Lab 2 - Configuring the Databases
WebSphere Enterprise Service Bus (WESB) is built atop WebSphere Application Server, 
Network Deployment (WAS ND).  WESB is made up of a number of components.  These 
components use a number of different databases to store and keep track of information.

One of the primary things done in this lab is to use the new database design tool that can 
establish what choices we want to make for database names and schemas in the 
environment.  Since the are several databases involved in WebSphere Enterprise Service 
Bus and they will likely be created by database administrators and adhere to certain 
standards it is important to know how to use this new tool to allow flexibility in the 
database configuration but also reduce chance of errors because of mismatch with the 
configuration.  Even though we will need these databases at different times we will create 
the design and scripts of all of the databases that will eventually be required.  Below is a 
table that shows the database and schema names we will use and a description of the 
purpose of the database.

Database Schema(s) Description

WPRCSDB COMMONDB It's recommended to create this database before 
profile creation.  Must exist before the deployment 
manager can be started with no errors. 

MEDB SCASYS

SCAAPP

CEIME

Used by the service integration bus (SIB) 
messaging engines to store information, such as 
persistent messages and transaction states.  The 
Service Component Architecture (SCA), and the 
Common Event Infrastructure (CEI) each have 
their own buses.  You can share the same database 
although environments that have a very high 
volume of messages may benefit from separate 
databases.

BSPCDB IBMBUSSP The Business Space database is used for the 
Business Space application which provides a user 
interface environment for applications and some 
useful administrative controls.

EVENT <None> Used to capture WebSphere Enterprise Service Bus 
events.  (Every server or cluster must have its 
own.)

Copyright 2011 Web Age Solutions Inc. 12

EVALUATIO
N O

NLY



As you can see from this table, we will eventually need four databases:   WPRCSDB, 
MEDB, EVENT, and BSPCDB.  The EVENT database must be created after your 
Enterprise Service Bus environment is setup but all others can be created beforehand.

So, in this lab, we will accomplish two basic tasks:

• Use the database design tool to decide settings for the databases

• Create the required WPRCSDB , MEDB, and BSPCDB databases.

Part 1 - Create Database Design and Scripts
Since the design of the database is an important part of the configuration of a Enterprise 
Service Bus environment we will start with that step.  Making these decisions now will 
help guide the rest of the configuration process.  The database design tools will also 
create a file that can be used in other parts of the configuration to make sure the settings 
match the actual database values used.  It might also be a common step that the database 
design and scripts are handed off to a team of database administrators so it will be good 
to do this as one of the first steps in a new environment.

__1. Open a command prompt  window.  You can do this by selecting Start → Programs 
→ Accessories → Command Prompt.

__2. Enter the command 'hostname' and write the result in the <HOSTNAME> variable 
from the beginning of the labs as you will use this value often.

__3. Change directories using the cd command to the <WESB_ROOT>\util\dbUtils 
directory. 

__4. Start the database design tool with the following command.  This tool prompts for 
information on the command line so it will be several steps before the tool exits.

DbDesignGenerator.bat

Note:  If you see the following warning message, you can ignore it:

WSVR0615W: The user.install.root system property is not set. Some product classes 
might not be found.

Copyright 2011 Web Age Solutions Inc. 13

EVALUATIO
N O

NLY



__5. Select option '1' and hit <Enter> as we will create a complete database design.  You 
could also use the tool to create the design of only one database or to take an existing 
database design file and generate the scripts for it.

__6. Select option '1' and hit <Enter> as we will create a design for Enterprise Service 
Bus in a Network Deployment environment.  You could also create standalone or 
WebSphere Process Server designs.

__7. Select option '1' to configure the common database and hit <Enter>.

__8. Enter a 'y' to confirm and hit <Enter>.  We will configure the common database first.

Copyright 2011 Web Age Solutions Inc. 14

EVALUATIO
N O

NLY



__9. Enter the following options in order for each step of the common database 
configuration.

1 This will use DB2 distributed

<Enter> This will accept the default database name of 'WPRCSDB'

db2admin The DB2 admin user

COMMONDB The schema name we will use

<Enter> Default page size

<Enter> Default tablespace

<Enter> Default temp page size

<Enter> Default temp tablespace

__10. At this point you will be entering properties for the WebSphere data source so hit 
the <Enter> key to continue to this part.
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__11. Enter the following options in order for each step of the common database data 
source configuration.

1 This will use the DB2 Universal JDBC Provider

<HOSTNAME> Enter the value of your hostname as the database is running on 
the same machine.

<Enter> Default port

<Enter> Default database user of db2admin

db2admin Data source password

<Enter> Default driver path

<Enter> Default driver path

Note: At this point we could quit and all the Enterprise Service Bus information would 
go into one database.  Since this is not what we want we will continue to edit other 
components.
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__12. Select option '2' and hit <Enter>.

__13. Then hit a 'y' to confirm and hit <Enter>.  We will configure the Business Space 
database.

Troubleshooting: If you make a mistake at any point you can continue until you get 
back to the main menu below and go back into that section.  If you think you have 
changed a default value and don't know what that value was to change back it might be 
best to enter 'q' and start the tool again.

__14. Enter the following options in order for each step of the Business Space database 
configuration.

<Enter> Same database type

BSPCDB Switching the database name to the chosen setting

<Enter> Same user name

<Enter> The default schema of 'IBMBUSSP' matches what we have chosen

<Enter> Default prefix for table spaces

<Enter> Default table space directory
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__15. At this point you will be entering properties for the WebSphere data source so hit 
the <Enter> key to continue to this part.

__16. Enter the following options in order for each step of the Business Space database 
data source configuration.

<Enter> Same driver provider

<Enter> Same hostname

<Enter> Same port

<Enter> Same user

<Enter> Same password

<Enter> Same driver location

<Enter> Same driver location
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__17. Select option '3' and hit <Enter>.

__18. Then hit a 'y' to confirm and hit <Enter>.  We will configure the CEI Event 
database.

Note: Even though you will get an error later about generating the scripts for CEI you 
still want to configure it in the database design file as this file is used to initialize 
WebSphere settings also.

__19. Enter the following options in order for each step of the CEI Event database 
configuration.

<Enter> Same database type

__20. At this point you will be entering properties for the WebSphere data source so hit 
the <Enter> key to continue to this part.
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__21. Enter the following options in order for each step of the BPC database data source 
configuration.

<Enter> Same driver provider

EVENT Switching the database name to the chosen setting

<Enter> Same hostname

<Enter> Same port

1 We will create the tables with scripts. Notice you type '1' and not 
false

<Enter> Same user

<Enter> Same password

<Enter> Same driver location

__22. Select option '4' and hit <Enter>.

__23. Then hit a 'y' to confirm and hit <Enter>.  We will configure the system message 
engine database.  This database will also share some options with the other messaging 
databases.
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__24. Enter the following options in order for each step of the messaging database 
configuration.

<Enter> Same database type

<Enter> Same user name

SCASYS The schema we have chosen

<Enter> Default statement end

__25. At this point you will be entering properties for the WebSphere data source so hit 
the <Enter> key to continue to this part.

__26. Enter the following options in order for each step of the BPC database data source 
configuration.

<Enter> Same driver provider

MEDB The database name we have chosen

<Enter> Same hostname

<Enter> Same port

1 We will create the tables with scripts. Notice you type '1' and not 
false

<Enter> Same user

<Enter> Same password

<Enter> Same driver location

<Enter> Same driver location
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__27. Select option '5' and hit <Enter>.

__28. Then hit a 'y' to confirm and hit <Enter>.  We will configure the CEI message 
engine database.  

__29. Enter the following options in order for each step of the messaging database 
configuration.

CEIME The schema we have chosen
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__30. Select option '6' and hit <Enter>.

__31. Then hit a 'y' to confirm and hit <Enter>.  We will configure the application 
message engine database.  

__32. Enter the following options in order for each step of the messaging database 
configuration.

SCAAPP The schema we have chosen

__33. Select option '7' and hit <Enter>.

__34. For the output directory enter C:\LabFiles\dbscripts  and hit enter.  This will put 
the file somewhere besides buried in the Enterprise Service Bus installation.

__35. Hit <Enter> to accept the default filename.

__36. Answer 'n' to quit without generating the scripts.  We will do this in a second an 
easier way.
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Note: If you have trouble creating the database design file with the tool there is a 
'SOLUTION.wesb.nd.topology.dbDesign' file that can be used with some modification. 
Check with your instructor to find out what changes would need to be made.

__37. Run the following command to generate scripts from the design file you just 
created.  Note that this command should all be on one line even though it wraps below.  

DbDesignGenerator.bat -g C:\LabFiles\dbscripts\wesb.nd.topology.dbDesign
-d C:\LabFiles\dbscripts

Note: The reason we are doing this is it is easier to specify the output directory only 
once when you generate in batch mode.

If you see the following warning message, you can ignore it:

WSVR0615W: The user.install.root system property is not set. Some product classes 
might not be found.

__38. You will get a warning about generating some CEI scripts but that is OK as these 
must be generated based on the deployment environment which we have not created yet.

__39. Close the command prompt once the tool exits.

Part 2 - Create the WPRCSDB Common Database
The deployment manager in a WESB environment requires a database, known as the 
Common DB, to operate. During the the previous lab part, you created scripts for a 
database called WPRCSDB which is the Common DB, but you did not actually create the 
required database and tables.  You will do so now.

Creating the tables involves executing scripts that were generated by the database design 
tool.  Scripts can also be generated during the creation of the Deployment Manager 
profile but it is generally easier to use the database design tool as database administrators 
can create the database(s) required before you attempt to create the WebSphere 
configuration.
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__1. Make sure you are logged in as an administrative user.  Some of the commands to 
create databases or connect to databases may not be available if you are not.

Note: If for some reason you did not have an administrative user available you might be 
able to login locally as the 'db2admin' user that was used to install DB2.  Coordinate 
with your instructor if this is the case.

__2. Open a command prompt window.

__3. In the command prompt window, enter:

cd C:\LabFiles\dbscripts\WBI_CommonDB_DB2-distributed-CommonDB

__4. Enter the following command:

configCommonDB.bat createDB 

Note: It is important that the database scripts issue commands as the user that will be 
used to connect to the database.  Some scripts like this one could be run as a different 
user as they will prompt you but for other databases we will connect to the database 
directly as the db2admin user.

__5. You should see fairly quickly that the command is creating the database and then 
after a minute or two you will be prompted for the password.  Enter db2admin

Type carefully as the window will not echo your characters! 

This script will create the WPRSCDB database, as well as all the required tables. You 
will likely see several messages.  Ignore any "No row was found" messages but make 
sure there are no errors.

We should now verify that the tables were created correctly. 

__6. In the same command prompt window, enter the command:

db2cmd
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__7. A new command window will open.  In that window, enter the command: 

db2 connect to WPRCSDB

This connects us to the database that we just created.  If this worked successfully, it 
means the database was indeed created successfully.  We should now check to see if the 
tables were correctly created.  

__8. Enter the command: 

db2 list tables for schema COMMONDB

A list of 31 tables should appear. 

__9. Enter the command: 

db2 list tables for schema db2admin

A list of 4 tables should appear. 

__10. Enter the command: 

db2 connect reset

__11. Close all command prompt windows.

The Common DB has been successfully created! 
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Note: If the tables do not appear it is likely due to a security issue not being able to 
create the tables.  The problem is that the database exists because that does not require 
permissions but creating tables may have failed.

If this is the case the safest course of action is likely to drop the database and reissue the 
commands.  You can drop the database with the command:

db2 drop database WPRCSDB

You should also double check the name of the database used and check with other 
students and the instructor to see if others have similar issues.

Part 3 - Create the MEDB database
One of the databases that our Enterprise Service Bus cluster will need is the MEDB 
database.  We will create this database manually, and then manually create the required 
tables in the database by running the scripts generated by the database design tool.

Note: If we had not run the database design tool we would use the 'SibDDLGenerator' 
command to generate the database scripts by providing parameters like database type, 
schema, etc that you provided to the database design tool.

__1. Open a new command prompt window.

__2. In the new window, enter: 

cd C:\LabFiles\dbscripts

__3. In the command window, enter:

db2cmd

__4. A new command window will open.  In that one, enter the command: 

db2 create db MEDB

This creates the database.  The command will take a few minutes to complete.

Now we can run the scripts to create the required tables.
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__5. Now, enter the following: 

db2 connect to MEDB user db2admin using db2admin

Note: It is important to connect as the database administrator as this is the id with rights 
to create tables, etc.

__6. Now, enter:

db2 -tf WBI_CEI_ME_DB2-distributed-SibME/DB2-distributed-SibME.sql

Note: You may want to open a Windows Explorer window and navigate to the directory 
of the generated script to copy the location correctly.

__7. You should see a number of success messages.  There may be some 'Existing index' 
messages but these are OK.

Note: If the database scripts created earlier had errors you may not notice them until 
these steps.  Common errors you might see are a mention that database elements 
"already exist" or that the "end of file" is reached.

If these errors occur the safest route to follow is to drop the MEDB database and find 
out what settings in your database design file are causing conflicts.
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__8. Next, enter: 

db2 list tables for schema CEIME

You should have 9 tables shown.

Note: The name and structure of the messaging tables is the same and the only 
difference is the schema.

__9. Next, enter: 

db2 -tf WBI_SCA_APP_ME_DB2-distributed-SibME/DB2-distributed-SibME.sql

__10. Again check that you have similar success messages.

__11. Next, enter: 

db2 list tables for schema SCAAPP

You should have 9 tables shown.

__12. Next, enter: 

db2 -tf WBI_SCA_SYS_ME_DB2-distributed-SibME/DB2-distributed-SibME.sql

__13. Again check that you have similar success messages.
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__14. Next, enter: 

db2 list tables for schema SCASYS

You should have 9 tables shown.

__15. Finally, enter: 

db2 connect reset

__16. Close the DB2 command window.

The MEDB database has been configured successfully! 

Note: Earlier, we specified that we would need three databases: MEDB, BSPCDB and 
EVENT (in addition to the already created WPRCSDB).  In this part of the lab, we 
created the MEDB database. 

The next part of the lab will create the BSPCDB (Business Space) database.  The 
EVENT database must be created after the creation of the deployment environment.

Part 4 - Create and Configure the BSPCDB Database
Finally we need to create and configure the database for the Business Space application. 
This will be similar to other parts that have used our generated scripts.

__1. Open a command prompt window.

__2. In the command prompt window, enter:

cd C:\LabFiles\dbscripts\WBI_BSPACE_DB2-distributed-BSpace

__3. Enter the following command:

configBusinessSpaceDB.bat createDB 

__4. Enter the db2admin for the user name.
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__5. The script will execute and after a minute, you will be prompted for a password. 
Enter db2admin

Type carefully as the window will not echo your characters! 

This script will create the BSPCDB database, as well as all the required tables. You will 
likely see several messages.  Ignore any "No row was found" messages but make sure 
there are no errors.

We should now verify that the tables were created correctly. 

__6. In the same command prompt window, enter the command:

db2cmd

__7. A new command window will open.  In that window, enter the command: 

db2 connect to BSPCDB

This connects us to the database that we just created.  If this worked successfully, it 
means the database was indeed created successfully.  We should now check to see if the 
tables were correctly created.  

__8. Enter the command: 

db2 list tables for schema IBMBUSSP

A list of 29 tables should appear. 

__9. Finally, enter: 

db2 connect reset
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__10. Close the DB2 command window.

The Business Space database has been successfully created! 

__11. Close any other extra command prompts or windows.

Part 5 - Review
In this lab, you:

• Ran the database design tool to collect all the database settings.

• Ran database scripts generated by the tool to create the databases and required 
tables.
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Lab 3 - Configuring the Profiles
In this lab, you will begin the task of configuring WebSphere Enterprise Service Bus 
(WESB).  Getting a full “functional” WESB environment up and running is a complex 
process and involves many steps, which we will not attempt to complete in one lab.  In 
real life, however, you will probably choose to do everything at once.  

The goal of this lab is to configure a network deployment environment, consisting of a 
deployment manager and a node. This implies creating two profiles, one which will host 
the deployment manager and a second "custom" profile that will be the node.  Note that 
the deployment manager profile cannot be used to host applications, but rather to manage 
a deployment environment.  The second profile is being created to provide a place to run 
the servers involved in the deployment environment.  In a later lab, we will create the 
deployment environment which will be the actual server environment that will host 
WESB applications.

So, in this lab, we will accomplish three basic tasks:

• Create the deployment manager profile.

• Create a custom profile for a node.

• Backup the configuration.

Part 1 - Create the Deployment Manager Profile
The next step is to create the Deployment Manager profile.  Remember that in a later lab 
we will be creating a deployment environment in the profile we are creating here, and it is 
that deployment environment that will be used to host applications. 

__1. Make sure you are logged in as the user that installed WESB.

__2. From the Start menu, select All Programs > IBM WebSphere > Enterprise 
Service Bus 7.0 > Profile Management Tool.  Accept any Windows security prompts if 
they appear.

Note: Alternatively, you can change to the <WESB_ROOT>\bin\ProfileManagement 
directory and run pmt.bat.

The Profile Management Tool welcome page will launch.
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__3. On the Welcome page click the Launch Profile Management Tool button.

__4. On the right of the empty list of profiles click the Create button.

The Environment Selection screen will appear.  

Note: In addition to creating brand new WESB profiles, you have the ability to augment, 
or add WESB capabilities to an existing WAS 7.0 or WAS ND 7.0 profile.  This is 
because WESB is built on top of WAS ND, which is built on top of WAS. 

__5. Expand the WebSphere Enterprise Service Bus section, select Enterprise Service 
Bus deployment manager and click Next.  If you get a security prompt from Windows 
Firewall unblock the process.

Note: A Deployment Manager profile in Enterprise Service Bus, like a Network 
Deployment Deployment Manager profile, creates a cell, a deployment manager node, 
and a deployment manager server that's used to administer application servers running 
on nodes that are federated into it.  In addition, it is used to federate Enterprise Service 
Bus servers (really specialized application servers) that are federated into it.
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__6. Select Advanced Profile Creation as shown below and click Next.

We will not want to use the defaults provided by a Typical profile creation, so we will go 
with the Advanced approach.

__7. Leave the box checked for deploying the administrative console and click Next.

__8. Note that the profile name for this deployment manager profile will be Dmgr01. 
Also note that the profile directory is <WESB_ROOT>\profiles\Dmgr01.  This path 
will be referred to as <DM_PROFILE_ROOT> throughout these labs; record this name 
in the Directory Path page in the front of these lab exercises.

__9. Accept the defaults for profile name and directory and click Next.
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__10. Accept the default host, node, and cell names and click Next.  Note that the Host 
name should be the same as your computer's hostname.  (In the screenshots shown in 
these examples, the host name was Trinity.  The node and cell names are generated 
accordingly. 

__11. The Administrative Security screen will appear.  Here, we specify the 
administrative user name and password for the deployment manager environment.  This 
will be the overall “administrative” user.  Set the User name to wasadmin.

__12. Set the Password and Confirm password to wasadmin.  Make sure to carefully 
type the username and password or you may not be able to login to WebSphere later.

__13. Click Next to accept the administrative settings.

__14. Accept the default settings for generating a certificate and press the Next button.

__15. Accept the default certificate details and press the Next button.
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__16. Accept the defaults for port values and click Next. Make a note of the port 9060 for 
the Administrative Console – you will be using this port when you access the console 
through your browser later in the exercise.

__17. If present, uncheck the option to run the Deployment Manager as a Windows 
service as shown below and click the Next button.

__18. Check the box for 'Use a database design file' for database configuration.

__19. Use the Browse button to find the file 
'C:\LabFiles\dbscripts\wesb.nd.topology.dbDesign'. Do not yet move to the next screen 
though.

Note: Make sure to pick the one you generated, since the 'Solution' file can only be used 
after some customization.
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__20. Back in the database settings check the box marked Delay execution of database 
scripts.

Realize that all we are doing is pointing to the databases defined in the database design 
file.  We have already created the database and tables which will commonly be done 
before creating the profile.

__21. Click Next once your screen appears as shown above.

__22. The Profile Creation Summary screen will appear.  Click Create.

The profile will be created.  Please be patient, this will take a few minutes.  This is a good 
time for a quick break.

Eventually, it will complete.

__23. Uncheck the box Launch the First steps console and click Finish.

__24. Close the Profile Management Tool.

The Deployment Manager profile has now been created!
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Part 2 - Start the Deployment Manager
We will now start the deployment manager to make sure creation was successful.  

Note: On Windows Vista it will be more difficult to start and stop the WebSphere 
management processes if your environment enforces User Account Control.  To avoid 
problems use one of the methods described below to start and stop the processes like the 
Deployment Manager.

1.  Right click a shortcut to a Command Prompt and select 'Run As Administrator' and 
then follow the commands described below.  This is likely the best as Node Agents will 
require this elevation of a command prompt.

2.  Find the shortcut in the Windows Start menu that will stop or start the process and 
right click it and select 'Run As Administrator'.

3.  If you have it configured as a Windows Service, open up the Windows Services panel 
from the 'Administrative Tools' area of the Control panel and start and stop the related 
service directly.  

__1. Open a command prompt window and cd to <DM_PROFILE_ROOT>\bin

__2. There, enter the command below.  If you get a Windows Firewall prompt unblock 
the process.

startManager.bat

Note: If you had not already created the common database you would need to do that 
before starting the Deployment Manager.

__3. The deployment manager will boot.  Wait until you see the following message:

The “open for e-business” is typically a sign that the server has started successfully. 
Memorize these steps for starting the deployment manager as you will be using it again 
throughout the course.

Leave the command prompt window open as you will need it again later in this lab.

Let us see if we can login to the admin console.  
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__4. Open a web browser, and navigate to http://localhost:9060/ibm/console

Your browser may throw a warning about an untrusted certificate.  Ignore the warning 
and proceed  (for example, on Internet Explorer, simply click on the Continue to this 
website link to proceed.)

A login screen will appear. You may need to disable the intranet settings in your browser.

__5. Enter wasadmin for the username and password as shown above and click Log in. 
Do not save the password if asks.
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The Administrative Console will appear.  This is where you will be doing the bulk of 
your administration over the following labs. 

This is the same URL that you use to access the Administrative Console for WAS ND, 
which makes sense, since WESB is built on top of WAS ND.  

You may notice:
● In the Welcome box, the version of WESB and WAS ND is listed. 
● There's an extra group in the Navigation tree (in the left pane) called Integration 

Applications, which we will access later.

__6. Using your browser, bookmark this link, as you will be continually logging into the 
admin console throughout these exercises.

Our deployment manager profile has been successfully created and is working fine!

__7. Logout of the admin console, by clicking the Logout link in the top right corner of 
the admin console.

__8. Close the browser.
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Part 3 - Create the Custom Profile
A profile besides the deployment manager profile will be needed to host any servers. 
These are the server(s) that will host WESB applications. We will use a custom profile for 
this.  A custom profile simply defines a node, but with no servers.  The server will be 
added later, by the deployment environment  wizard. 

We will create the custom profile using the Profile Management Tool. 

__1. Start the Deployment Manager if it is not already running.  Use the 
startManager.bat command from the <DM_PROFILE_ROOT>\bin directory.

Make sure the deployment manager is running before continuing these steps.

Note: There are some batch files in the C:\LabFiles\manage directory that can be used as 
easy ways to stop and start the WebSphere management processes in the labs.  If you are 
using Windows Vista you should be able to right-click these batch files and select 'Run 
as administrator' to execute the commands.

__2. From the Start menu, select All Programs > IBM WebSphere > Enterprise 
Service Bus 7.0 > Profile Management Tool.  Accept any Windows security prompts if 
they appear.

The Profile Management Tool will launch.

__3. On the Welcome page, click the Launch Profile Management Tool button.

__4. On the right of the list of profiles, click the Create button.

The Environment Selection screen will appear.  
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__5. Expand the WebSphere Enterprise Service Bus section, select Enterprise Service 
Bus custom profile and click Next.  If you get a security prompt from Windows Firewall 
unblock the process.

__6. Select Advanced Profile Creation as shown below and click Next.

We will not want to use the defaults provided by a Typical profile creation, so we will go 
with the Advanced approach.
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The Profile Name and Location screen will appear. 

Note that the profile name is Custom01.  Also note that the profile directory will is 
<WESB_ROOT>\profiles\Custom01.  Record this as the value of 
<CUSTOM_ROOT> in the listing of directory paths at the start of this lab guide. 

__7. Accept the defaults and click Next.

The Node and Host Names screen will appear. 

Your machine's host name will be shown, and the node name will be generated 
accordingly. 

__8. Click Next.
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The Federation screen will appear.  As soon as the profile is created, it will attempt to 
join a cell; in our case, we want it to join the cell we created in the previous section.  This 
is why the the deployment manager must be running at the beginning of this part. 

Note that the settings here already point to the deployment manager (server localhost on 
port 8879 in our case).  Naturally, if the deployment manager was running on a different 
machine/port, you would specify those details here instead. Consequently, you would 
replace this value with the value of <HOSTNAME> specific to your machine. 

We just need to specify the DM's username and password to authenticate the federation 
process.

__9. Set the User name and Password to wasadmin

__10. Click Next when your settings match that shown above.
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Note: If you see an error message like the following:

the likely cause is that your Deployment Manager is not running. Go back to the 
command prompt and type startManager.bat to start it up. Once the Manager is 
running try to click on Next again. This time it should proceed  to the next page of the 
wizard.

__11. Accept the default settings for generating a certificate and press the Next button.

__12. Accept the default certificate details and press the Next button.

The Port Values Assignment screen will appear. 

Realize that these port numbers are for the node agent that will run out of this profile. 
Also note that the wizard is able to detect whether any of the ports listed here are already 
being used by other applications or profiles and in this case has incremented all of them 
by one until this is no longer the case. This helps to guarantee to some extent that port 
clashes do not occur, but you should always check manually just to make sure.

__13. Accept the defaults and click Next.
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The Database Configuration screen will appear. 

__14. Change the drop-down to DB2 Universal and click Next.

As with the deployment manager, this node will need access to the CommonDB 
(WPRCSDB) and so it needs database driver location information that is appropriate for 
this node.  The configuration of the actual database is not needed here which is why we 
aren't using the database design file.

__15. On the Profile Creation Summary screen, click Create.

The profile will be created.  Wait patiently.

Eventually, the profile creation will complete.  
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__16. Uncheck the box marked Launch the First steps console and click Finish.

__17. Close the Profile Management Tool.

The profile has been created!

Part 4 - Backup the Configuration
We will now make a backup of the configuration.  Make a habit of doing so on a regular 
basis; that way, in the event of a failure, you can always restore the configuration.

__1. Open a command prompt window and cd to  <DM_PROFILE_ROOT>\bin

__2. At the command prompt, enter the following command:

backupConfig.bat PostProfileCreation.zip -nostop

Congratulations!  You have successfully created a backup of the profile.
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Part 5 - Review
Although you do not yet have a deployment environment that can host Enterprise Service 
Bus applications you now have the architecture that will allow you to create that 
environment.  

In the next lab you will see how you will add servers with the ability to host Enterprise 
Service Bus applications to the node created with the custom profile.  If you had more 
than the one machine involved in the WebSphere environment you would have created a 
separate custom profile on each one and had it join the cell managed by the deployment 
manager in the same way.

In this lab, you:

• Created the deployment manager profile Dmgr01

• Started the deployment manager to make sure it worked

• Logged onto the Admin Console

• Created the custom profile Custom01

• Made a backup of the Deployment Manager profile.
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	Lab 1 -  Installing  WebSphere ESB
	Part 1 -  Install the Software
	__1.  Open a Windows Explorer window.
	__2.  Navigate to the <LABFILES_DIR>\Install directory substituting the value of the <LABFILES_DIR> variable with the location mentioned in the list of directory paths at the beginning of these labs.  Check with your instructor if you can't find the directory listed.
	__3.  Copy the 'custom_run_template.bat' and 'custom_template_response.xml' files from this folder.  These files are customized versions of some files included in the ESB software.  They are customized already to help reduce install errors.
	__4.  Navigate to the <WESB_SOFTWARE_DIR>\responsefiles\WBI directory substituting the value of the <WESB_SOFTWARE_DIR> variable with the location mentioned in the list of directory paths at the beginning of these labs.  Check with your instructor if you can't find the directory listed.
	__5.  Paste the files in this location.  You should see that these are files similar to those already present.
	__6.  Open the text editor Wordpad.  This will be better than Notepad that does not always show the line breaks in these files correctly.
	__7.  In Wordpad open the <WESB_SOFTWARE_DIR>\responsefiles\WBI\custom_run_template.bat file.
	__8.  In this file search for the text 'MODIFIED' to see the settings that were modified from the default file contents provided with the ESB software as shown below.
	__9.  Look for the 'WAS_LOCATION' variable in the batch file.   
	__10.  Write down this installation directory as the value of the <WESB_ROOT> variable in the list of directory paths at the beginning of these labs.
	__11.  Close the file and make sure you have not made any changes.
	__12.  In Wordpad open the <WESB_SOFTWARE_DIR>\responsefiles\WBI\custom_template_response.xml file.
	__13.  In this file search for the text 'MODIFIED' to see the settings that were modified from the default file contents provided with the ESB software.  Mostly this is to point to the same WAS software installation under 'C:/IBM/WebSphere/ESB' and to install the Installation Manager under 'C:/IBM/IM'.
	__14.  Close the file and make sure you have not made any changes.
	__15.  Open a Command Prompt.  You can do this with 'Start → Programs → Accessories → Command Prompt'.
	__16.  Use the 'cd' command to switch to the <WESB_SOFTWARE_DIR>\responsefiles\WBI directory.
	__17.  Issue the command 'custom_run_template.bat' to start the execution of the custom silent install.  You will not be immediately returned to the command prompt which indicates the silent installation is proceeding.  Leave the command prompt open.

	Part 2 -  Confirm the Installation
	__1.  Return to the command prompt that was performing the installation.  Verify that you see text describing creating profiles which starts "The next step...".
	__2.  In the same command prompt use the 'cd' command to switch to the <WESB_ROOT>\bin directory using the value you wrote down for the <WESB_ROOT> variable earlier in the lab.
	__3.  Enter the command: 
	__4.  Enter the command: 
	__5.  Close the command prompt.
	__6.  Click Start > All Programs > IBM WebSphere and you will see two shortcuts listed underneath:  Application Server Network Deployment v7.0, and Enterprise Service Bus 7.0.
	__7.  Last but not least, open a Windows Explorer window.
	__8.  Navigate to the <WESB_ROOT> directory you wrote down in the notes at the beginning of these labs.  This serves as the main installation directory for WESB.
	__9.  Navigate to the <WESB_ROOT>\logs directory.
	__10.  Open the 'installver' log file.  This was created by the installation verification utility.
	__11.  In the log file search for 'package.java.sdk' and be sure you see 3 issues with this component.  You can see this is from overlap with another package.
	__12.  Go to the end of the log file and be sure those were the only issues found.  There should only be 3 total issues.
	__13.  Close this log file.
	__14.  Go to the <WESB_ROOT>\logs\install directory.
	__15.  Open the 'log.txt' file in this directory.
	__16.  Scroll to the bottom and check that you see the message 'INSTCONFSUCCESS' in the last log entry.
	__17.  Close this log file.
	__18.  Go to the <WESB_ROOT>\logs\wesb directory.
	__19.  Open the 'silent_install' log file.
	__20.  Check that there are only info messages about using the manageProfiles command as the "next step".  This is the same as the output in the command prompt and there isn't a "success" message like the regular WAS install log.
	__21.  Close all open windows.

	Part 3 -  Review

	Lab 2 -  Configuring the Databases
	Part 1 -  Create Database Design and Scripts
	__1.  Open a command prompt  window.  You can do this by selecting Start → Programs → Accessories → Command Prompt.
	__2.  Enter the command 'hostname' and write the result in the <HOSTNAME> variable from the beginning of the labs as you will use this value often.
	__3.  Change directories using the cd command to the <WESB_ROOT>\util\dbUtils directory. 
	__4.  Start the database design tool with the following command.  This tool prompts for information on the command line so it will be several steps before the tool exits.
	__5.  Select option '1' and hit <Enter> as we will create a complete database design.  You could also use the tool to create the design of only one database or to take an existing database design file and generate the scripts for it.
	__6.  Select option '1' and hit <Enter> as we will create a design for Enterprise Service Bus in a Network Deployment environment.  You could also create standalone or WebSphere Process Server designs.
	__7.  Select option '1' to configure the common database and hit <Enter>.
	__8.  Enter a 'y' to confirm and hit <Enter>.  We will configure the common database first.
	__9.  Enter the following options in order for each step of the common database configuration.
	__10.  At this point you will be entering properties for the WebSphere data source so hit the <Enter> key to continue to this part.
	__11.  Enter the following options in order for each step of the common database data source configuration.
	__12.  Select option '2' and hit <Enter>.
	__13.  Then hit a 'y' to confirm and hit <Enter>.  We will configure the Business Space database.
	__14.  Enter the following options in order for each step of the Business Space database configuration.
	__15.  At this point you will be entering properties for the WebSphere data source so hit the <Enter> key to continue to this part.
	__16.  Enter the following options in order for each step of the Business Space database data source configuration.
	__17.  Select option '3' and hit <Enter>.
	__18.  Then hit a 'y' to confirm and hit <Enter>.  We will configure the CEI Event database.
	__19.  Enter the following options in order for each step of the CEI Event database configuration.
	__20.  At this point you will be entering properties for the WebSphere data source so hit the <Enter> key to continue to this part.
	__21.  Enter the following options in order for each step of the BPC database data source configuration.
	__22.  Select option '4' and hit <Enter>.
	__23.  Then hit a 'y' to confirm and hit <Enter>.  We will configure the system message engine database.  This database will also share some options with the other messaging databases.
	__24.  Enter the following options in order for each step of the messaging database configuration.
	__25.  At this point you will be entering properties for the WebSphere data source so hit the <Enter> key to continue to this part.
	__26.  Enter the following options in order for each step of the BPC database data source configuration.
	__27.  Select option '5' and hit <Enter>.
	__28.  Then hit a 'y' to confirm and hit <Enter>.  We will configure the CEI message engine database.  
	__29.  Enter the following options in order for each step of the messaging database configuration.
	__30.  Select option '6' and hit <Enter>.
	__31.  Then hit a 'y' to confirm and hit <Enter>.  We will configure the application message engine database.  
	__32.  Enter the following options in order for each step of the messaging database configuration.
	__33.  Select option '7' and hit <Enter>.
	__34.  For the output directory enter C:\LabFiles\dbscripts  and hit enter.  This will put the file somewhere besides buried in the Enterprise Service Bus installation.
	__35.  Hit <Enter> to accept the default filename.
	__36.  Answer 'n' to quit without generating the scripts.  We will do this in a second an easier way.
	__37.  Run the following command to generate scripts from the design file you just created.  Note that this command should all be on one line even though it wraps below.  
	__38.  You will get a warning about generating some CEI scripts but that is OK as these must be generated based on the deployment environment which we have not created yet.
	__39.  Close the command prompt once the tool exits.

	Part 2 -  Create the WPRCSDB Common Database
	The deployment manager in a WESB environment requires a database, known as the Common DB, to operate. During the the previous lab part, you created scripts for a database called WPRCSDB which is the Common DB, but you did not actually create the required database and tables.  You will do so now.
	Creating the tables involves executing scripts that were generated by the database design tool.  Scripts can also be generated during the creation of the Deployment Manager profile but it is generally easier to use the database design tool as database administrators can create the database(s) required before you attempt to create the WebSphere configuration.
	__1.  Make sure you are logged in as an administrative user.  Some of the commands to create databases or connect to databases may not be available if you are not.
	__2.  Open a command prompt window.
	__3.  In the command prompt window, enter:
	__4.  Enter the following command:
	__5.  You should see fairly quickly that the command is creating the database and then after a minute or two you will be prompted for the password.  Enter db2admin
	Type carefully as the window will not echo your characters! 
	__6.  In the same command prompt window, enter the command:
	__7.  A new command window will open.  In that window, enter the command: 
	__8.  Enter the command: 
	__9.  Enter the command: 
	__10.  Enter the command: 
	__11.  Close all command prompt windows.

	Part 3 -  Create the MEDB database
	__1.  Open a new command prompt window.
	__2.  In the new window, enter: 
	__3.  In the command window, enter:
	__4.  A new command window will open.  In that one, enter the command: 
	__5.  Now, enter the following: 
	__6.  Now, enter:
	__7.  You should see a number of success messages.  There may be some 'Existing index' messages but these are OK.
	__8.  Next, enter: 
	__9.  Next, enter: 
	__10.  Again check that you have similar success messages.
	__11.  Next, enter: 
	__12.  Next, enter: 
	__13.  Again check that you have similar success messages.
	__14.  Next, enter: 
	__15.  Finally, enter: 
	__16.  Close the DB2 command window.

	Part 4 -  Create and Configure the BSPCDB Database
	__1.  Open a command prompt window.
	__2.  In the command prompt window, enter:
	__3.  Enter the following command:
	__4.  Enter the db2admin for the user name.
	__5.  The script will execute and after a minute, you will be prompted for a password. Enter db2admin
	Type carefully as the window will not echo your characters! 
	__6.  In the same command prompt window, enter the command:
	__7.  A new command window will open.  In that window, enter the command: 
	__8.  Enter the command: 
	__9.  Finally, enter: 
	__10.  Close the DB2 command window.
	__11.  Close any other extra command prompts or windows.

	Part 5 -  Review

	Lab 3 -  Configuring the Profiles
	Part 1 -  Create the Deployment Manager Profile
	__1.  Make sure you are logged in as the user that installed WESB.
	__2.  From the Start menu, select All Programs > IBM WebSphere > Enterprise Service Bus 7.0 > Profile Management Tool.  Accept any Windows security prompts if they appear.
	__3.  On the Welcome page click the Launch Profile Management Tool button.
	__4.  On the right of the empty list of profiles click the Create button.
	__5.  Expand the WebSphere Enterprise Service Bus section, select Enterprise Service Bus deployment manager and click Next.  If you get a security prompt from Windows Firewall unblock the process.
	__6.  Select Advanced Profile Creation as shown below and click Next.
	__7.  Leave the box checked for deploying the administrative console and click Next.
	__8.  Note that the profile name for this deployment manager profile will be Dmgr01. Also note that the profile directory is <WESB_ROOT>\profiles\Dmgr01.  This path will be referred to as <DM_PROFILE_ROOT> throughout these labs; record this name in the Directory Path page in the front of these lab exercises.
	__9.  Accept the defaults for profile name and directory and click Next.
	__10.  Accept the default host, node, and cell names and click Next.  Note that the Host name should be the same as your computer's hostname.  (In the screenshots shown in these examples, the host name was Trinity.  The node and cell names are generated accordingly. 
	__11.  The Administrative Security screen will appear.  Here, we specify the administrative user name and password for the deployment manager environment.  This will be the overall “administrative” user.  Set the User name to wasadmin.
	__12.  Set the Password and Confirm password to wasadmin.  Make sure to carefully type the username and password or you may not be able to login to WebSphere later.
	__13.  Click Next to accept the administrative settings.
	__14.  Accept the default settings for generating a certificate and press the Next button.
	__15.  Accept the default certificate details and press the Next button.
	__16.  Accept the defaults for port values and click Next. Make a note of the port 9060 for the Administrative Console – you will be using this port when you access the console through your browser later in the exercise.
	__17.  If present, uncheck the option to run the Deployment Manager as a Windows service as shown below and click the Next button.
	__18.  Check the box for 'Use a database design file' for database configuration.
	__19.  Use the Browse button to find the file 'C:\LabFiles\dbscripts\wesb.nd.topology.dbDesign'. Do not yet move to the next screen though.
	__20.  Back in the database settings check the box marked Delay execution of database scripts.
	__21.  Click Next once your screen appears as shown above.
	__22.  The Profile Creation Summary screen will appear.  Click Create.
	__23.  Uncheck the box Launch the First steps console and click Finish.
	__24.  Close the Profile Management Tool.
	The Deployment Manager profile has now been created!

	Part 2 -  Start the Deployment Manager
	__1.  Open a command prompt window and cd to <DM_PROFILE_ROOT>\bin
	__2.  There, enter the command below.  If you get a Windows Firewall prompt unblock the process.
	__3.  The deployment manager will boot.  Wait until you see the following message:
	__4.  Open a web browser, and navigate to http://localhost:9060/ibm/console
	Your browser may throw a warning about an untrusted certificate.  Ignore the warning and proceed  (for example, on Internet Explorer, simply click on the Continue to this website link to proceed.)
	__5.  Enter wasadmin for the username and password as shown above and click Log in. Do not save the password if asks.
	The Administrative Console will appear.  This is where you will be doing the bulk of your administration over the following labs. 
	__6.  Using your browser, bookmark this link, as you will be continually logging into the admin console throughout these exercises.
	__7.  Logout of the admin console, by clicking the Logout link in the top right corner of the admin console.
	__8.  Close the browser.

	Part 3 -  Create the Custom Profile
	__1.  Start the Deployment Manager if it is not already running.  Use the startManager.bat command from the <DM_PROFILE_ROOT>\bin directory.
	__2.  From the Start menu, select All Programs > IBM WebSphere > Enterprise Service Bus 7.0 > Profile Management Tool.  Accept any Windows security prompts if they appear.
	__3.  On the Welcome page, click the Launch Profile Management Tool button.
	__4.  On the right of the list of profiles, click the Create button.
	__5.  Expand the WebSphere Enterprise Service Bus section, select Enterprise Service Bus custom profile and click Next.  If you get a security prompt from Windows Firewall unblock the process.
	__6.  Select Advanced Profile Creation as shown below and click Next.
	__7.  Accept the defaults and click Next.
	__8.  Click Next.
	__9.  Set the User name and Password to wasadmin
	__10.  Click Next when your settings match that shown above.
	__11.  Accept the default settings for generating a certificate and press the Next button.
	__12.  Accept the default certificate details and press the Next button.
	__13.  Accept the defaults and click Next.
	__14.  Change the drop-down to DB2 Universal and click Next.
	__15.  On the Profile Creation Summary screen, click Create.
	The profile will be created.  Wait patiently.
	Eventually, the profile creation will complete.  
	__16.  Uncheck the box marked Launch the First steps console and click Finish.
	__17.  Close the Profile Management Tool.
	The profile has been created!

	Part 4 -  Backup the Configuration
	We will now make a backup of the configuration.  Make a habit of doing so on a regular basis; that way, in the event of a failure, you can always restore the configuration.
	__1.  Open a command prompt window and cd to  <DM_PROFILE_ROOT>\bin
	__2.  At the command prompt, enter the following command:

	Part 5 -  Review

	Lab 4 -  Creating the Deployment Environment
	Part 1 -  Create the Deployment Environment 
	__1.  Start the Deployment Manager if it is not already running.  Use the startManager.bat command from the <DM_PROFILE_ROOT>\bin directory.
	__2.  If you have not restarted the machine since creating the custom profile the node agent should still be running.  If it is not, start it with the startNode.bat command in the <CUSTOM_ROOT>\bin directory.
	__3.  Make sure the deployment manager is running before continuing these steps. Enter the following command to verify this from the <DM_PROFILE_ROOT>\bin folder.
	__4.  Enter wasadmin as user and password.
	__5.  You will get the following response.
	__6.  Now make sure the node agent is running. Enter the following command to verify this from the <CUSTOM_ROOT>\bin folder.
	__7.  Enter wasadmin as user and password.
	__8.  You will get the following response.
	__9.  Perform the previous steps each time you want to verify if the Deployment Manager and Node are running.
	__10.  Login to the admin console as wasadmin.  (http://localhost:9060/ibm/console)
	__11.  In the left pane of the Admin Console expand System administration and click Nodes.  Although your node names are different you should see that there is a 'Manager' node which contains the deployment manager and there is a '<HOSTNAME>Node01' node.  This second node was added by the custom profile and is where our Enterprise Service Bus instance will run in the deployment environment.
	__12.  In the left pane select Console Preferences from the System administration section.
	__13.  Select the options for Synchronize changes with Nodes and click the Apply button.  This will make it easier to keep the environment synchronized when changes are made.
	__14.  In the left pane, expand Servers and click Deployment Environments.
	__15.  In the right pane, click New...
	__16.  Set the Deployment environment name to MyTopology
	__17.  Click Next.
	__18.  Leave the option for WebSphere Enterprise Service Bus selected and click the Next button.
	__19.  Select Single Cluster as shown below and click Next.
	__20.  Select the node by checking its box and click Next.
	__21.  On the Clusters screen, leave the default of one application deployment target and click Next.
	__22.  On the System REST Service Endpoints screen, enter the value of your <HOSTNAME> variable and port 9080 and click Next.
	__23.  On the Import database configuration screen use the Browse button to find the file 'C:\LabFiles\dbscripts\wesb.nd.topology.dbDesign'.  Click the Next button when the setting is set as shown below. It may show a security dialog, click Yes to accept it.
	__24.  On the Database screen, notice the settings that are already set for you from the database design file.  This design file not only helped create database scripts it also greatly simplifies the process of a deployment environment.  Do not make any changes and simply click the Next button.
	__25.  On the Security screen, click Next.  You could change JMS and SCA authentication settings if you needed to here.
	__26.  On the Summary screen, confirm all settings then click Finish and Generate Environment.  If you only click Finish it will save the settings but not actually create the environment.
	__27.  Click Save Changes.
	__28.  Once you see the message, The configuration synchronization complete for cell, click OK.  
	__29.  In the left pane, expand Servers → Clusters  and click on WebSphere application server clusters.  The right pane will show a table of defined clusters.  You should see the cluster that was just created: MyTopology.AppTarget.
	__30.  In the table click MyTopology.AppTarget
	__31.  Logout of the admin console and close the browser.
	__32.  Stop the node agent and deployment manager processes.  This is done with the following commands.  Provide authentication information when prompted. Wait until one server has stopped and then stop the other one.

	Part 2 -  Complete Configuring the EVENT Database
	__1.  Make sure you are logged in as an administrative user.  Some of the commands to create databases or connect to databases may not be available if you are not.
	__2.  Open a new command prompt window.
	__3.  In the command prompt window, change to the folder: 
	__4.  Enter the command:
	The script will execute for a few minutes.  It should execute without any problems. There will seem like a lot of extra messages because the script echoes each command it issues to the database.

	Part 3 -  Verify your configuration
	__1.  Start the node agent and deployment manager processes.  This is done with the following commands.  
	__2.  Open the Deployment Manager Administrative Console in a browser if you are not already (http://localhost:9060/ibm/console).
	__3.  Login with your credentials (username and password of wasadmin).
	__4.  Navigate to Servers → Clusters  and click on WebSphere application server clusters. 
	__5.  Select the checkbox next to the cluster and click on the Start button. Be patient it could take some time depending on you processor and memory.
	__6.  After a few minutes click the 'refresh' link to the right of the status column.  Repeat this until you see a solid green arrow in the status column.  This indicates the cluster has started successfully:
	__7.  Still in the administrative console, select Applications → Application Types → WebSphere enterprise applications and verify that all applications have started (they should all show a solid green arrow in the status column).
	__8.  Logout and close the admin console browser.
	__9.  Close any open windows.

	Part 4 -  Review

	Lab 5 -  Install an SCA Module Application
	Part 1 -  Install Service Provider Application
	__1.  Access the Administrative Console by opening a browser and entering the URL:   
	__2.  Log on as the user wasadmin
	__3.  In the left pane, expand the Applications group and click New Application.
	__4.  Click the link for New Enterprise Application.
	__5.  Make sure Local file system is selected and click the Browse button.
	__6.  In the Choose file dialog, navigate to <LABFILES_DIR>\RoutingExampleApp.ear and click Open.
	__7.  Click Next.
	__8.  Leave the Fast Path option selected and press the Next button.
	__9.  Click Next at the bottom of the page.  
	__10.  Click Next.
	__11.  Click the Finish button to start the installation.
	__12.  Click the Save link to save changes.
	__13.  Once you see the message, The configuration synchronization complete for cell, click OK.  
	We now need to start the actual server instance that will host the application.  We will do so by starting the cluster (which implies starting all the servers within that cluster – which at the moment includes the server that we wish to target)
	__14.  In the left pane. expand the Servers → Clusters group and click WebSphere Application Server clusters.
	__15.  Start cluster MyTopology.AppTarget by checking the box next to it and clicking the Start button.
	__16.  In the left pane, expand the Servers → Server Types group and click Websphere Application Servers.
	__17.  If you check its Status, you should see the green arrow representing that the server has started. If not, wait a few more minutes and then click the refresh icon next to the Status column header to refresh the page. 
	__18.  Confirm that the RoutingExampleApp application started up successfully by expanding the Applications → Application Types group and clicking the WebSphere Enterprise Applications link.

	Part 2 -  Install the Service Consumer
	__1.  In the left pane, expand the Applications group and click New Application.
	__2.  Click the link for New Enterprise Application.
	__3.  In the right pane, make sure Local file system is selected and click the Browse button.
	__4.  In the Choose file dialog, select <LABFILES_DIR>\OnlineOrderApp.ear and click Open.
	__5.  Click Next.
	__6.  Leave the Fast Path option selected and press the Next button.
	__7.  Click Next.  
	__8.  Click on the Next button.
	__9.  Click the Finish button to start the installation.
	__10.  Click the Save link.
	__11.  Once you see the message, The configuration synchronization complete for cell, click OK.
	__12.  In the left pane, expand the Applications → Application Types group and click the WebSphere Enterprise Applications link.  You should see OnlineOrderApp listed.
	__13.  Check the box to the left of OnlineOrderApp and click the Start button.  The application status should changed to Started within a moment.

	Part 3 -  List the SCA Modules
	__1.  In the left pane, expand the Applications group and click the SCA Modules link.
	__2.  Check the box next to RoutingExample and click the Stop button. 
	__3.  In the left pane, click the WebSphere Enterprise Applications link under the Applications → Application Types group.  
	__4.  Click again on the SCA Modules link under the Applications group (in the left pane).  
	__5.  Check the box next to RoutingExample and click the Start button. 
	__6.  Confirm that RoutingExampleApp started back up.
	__7.  Log out of the Administrative Console.

	Part 4 -  Test the Service Provider Application
	__1.  Open a browser and enter the URL: 
	__2.  Enter some sample input as shown below:
	__3.  Click Register. 
	The browser should display the following page:
	__4.  To do so, in Windows Explorer, navigate to the <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<hostname>Node01.0 directory, and open the SystemOut.log file using Notepad.
	__5.  Scroll to the bottom of the file and you'll notice the following messages:
	__6.  Close the file.
	__7.  Click the Back button in the browser to go back to the registration page. Change the Country from USA to Canada and click Register. 
	__8.  Open the SystemOut.log file using Notepad again.
	__9.  Scroll to the bottom of the file and you'll  notice the following new messages:
	__10.  Close the log file.  

	Part 5 -  Confirm Mediation Logging
	__1.  Open the DB2 Control Center by selecting Start > All Programs > IBM DB2 > DB2COPY1 (Default) > General Administration Tools > Control Center.
	__2.  In the Control Center View dialog, uncheck the Show this window at startup time option and click OK.
	__3.  In the left pane, expand the All Databases folder.  
	__4.  A list of the databases that have been created thus far will be listed.  You should see WPRCSDB (Common database), MEDB (Message Bus database), BSPCDB (Business Space), and EVENT  (for CEI).
	__5.  Right click the WPRCSDB database and select Connect.
	__6.  Fill in a userid and password of 'db2admin' and click the OK button to connect.
	__7.  Expand WPRCSDB and click on the Tables folder.  A list of tables will be displayed in the upper-right panel.
	__8.  Click the Schema column to sort the rows by schema. You'll notice some of the tables that were created earlier when you configured the Common database.
	__9.  Scroll through the list of tables until you see the MSGLOG table.  Right click on MSGLOG and select Query from the pop-up menu.  
	__10.  Click the green arrow to execute the query, which selects all the records from the MSGLOG table.  
	__11.  Exit the DB2 Control Center.
	__12.  Close all browsers.
	__13.  Back up following the steps in Lab 3. 
	__14.  After the backup. Login the admin console and verify the cluster server  is started as well as all the applications.
	__15.  Logout and close the browser.

	Part 6 -  Review

	Lab 6 -  Configure Common Event Infrastructure
	Part 1 -  Install CEI Application 
	__1.  Make sure that your deployment manager, node agent, and AppTarget server are running.  Start them in that order if they are not.
	__2.  Login to the admin console.
	__3.  In the left pane, expand the Applications → Application Types group and click WebSphere Enterprise Applications.
	__4.  Check the box next to RoutingExampleApp and click the Update button.  
	__5.  Make sure the Replace the entire application radio button is selected under Application update options.
	__6.  Click the Local file system radio button and then the Browse button.
	__7.  In the Choose file dialog, select <LABFILES_DIR>\RoutingExampleAppCEI.ear and click Open.
	__8.  Scroll to the bottom of the page and click Next.
	__9.  Select the Fast Path installation option and click the Next button.
	__10.  The installation wizard will be displayed.  Click on the Step 3 link (on the left) to bypass the other steps and advance to the Summary page.  
	__11.  Click the Finish button to start the installation.
	The installation will take a moment or two to run.  Once the installation is finished, a success message should be displayed.  
	__12.  Click the Save link.
	__13.  Once you see the message, The configuration synchronization complete for cell, click OK.  

	Part 2 -  Configure CEI Security
	__1.  In the left pane, expand Service Integration > Common Event Infrastructure and click Event service.
	__2.  In the right pane, under Additional Properties, click Map security roles to users or groups.
	__3.  Check all 6 boxes under the Select column.
	__4.  Click the Map Special Subjects button and select Everyone from the list.
	__5.  Check that all roles list 'Everyone' in the Special subjects column and click OK.
	__6.  Click the Save link.
	__7.  When the synchronization is complete, click OK. We have completed configuring CEI security.

	Part 3 -  Test CEI
	__1.  To test the RoutingExampleApp application's mediation flow, open another browser and enter the URL: 
	__2.  Enter some sample input making sure to supply a value to all fields.
	__3.  Click Register. The browser should display the following page:
	__4.  Back in the Administrative Console, in the left pane, expand the Integration Applications group and click on Common Base Event Browser.  If you are using Mozulla Firefox you probably won't see the left pane, if so, use IE.
	__5.  Scroll to the bottom of the page and click the Get Events button.
	__6.  The Number of Events counter in the left pane should be 1.
	__7.  Click the All Events link under the Event Views heading to view the event.
	__8.    Click the Select radio button and the Event Data should be displayed in the bottom pane.
	__9.  Scroll down and you will see that the event was generated by the RoutingExample module and the EventEmitter1 mediation primitive.  The contextDataElement elements indicate that the addCustomerToSystem operation was invoked by the consumer on the mediation flow.
	__10.  At the very bottom of the event details click the link next to the wbi:event property.
	__11.  You should see some of the event details.  This is where custom events may have additional data included.
	__12.  Log out of the Administrative Console.
	__13.  Close all browsers.

	Part 4 -  Review

	Lab 7 -  Deploying a Complex Mediation Flow
	Part 1 -  The Business Problem
	Part 2 -  Import the Solution Projects in WID
	__1.  Stop the node and the deployment manager.
	__2.  Start the deployment manager. 
	__3.  Start the node.
	__4.  Open WID by selecting Start > All Programs > IBM WebSphere Integration Developer > IBM WebSphere Integration Developer V7.0 >  WebSphere Integration Developer V7.0 
	__5.  In the Workspace Launcher dialog, change the workspace to C:\workspace
	__6.  Click OK.
	__7.  The Getting Started view may be open.  Close it.
	__8.  From the menubar, select File > Import.
	__9.  Expand Other and select Project Interchange.
	__10.  Click Next.
	__11.  Click the Browse button and select C:\LabFiles\PriceQuote.zip and click Open.
	__12.  Click Select All to select all projects in the ZIP file.
	__13.  Click Finish.
	__14.  Click the Problems tab at the bottom to find out if the build had found any errors.

	Part 3 -  Understanding the Build Process
	__1.  Click the Build Activities tab at the bottom to open that view.
	__2.  Make sure that Validate and update deploy code is selected. This means, both steps will be performed during a build. If only Validate was selected, you could click Update Deploy Code to generate and compile the required code.

	Part 4 -  Review the Projects
	Part 5 -  Review the Mediation Flow
	__1.  Expand PriceQuoteFlow > Integration Logic > Mediation Flows.
	__2.  Double click OrderMediation to open the mediation flow.
	__3.  Click the link for the placeOrder operation on the left.
	__4.  Close the mediation flow making sure you did not make any changes.

	Part 6 -  Review the Assembly Diagram
	__1.  Double click Assembly Diagram under the PriceQuoteFlow project.
	__2.  Select ACMEImport on the assembly diagram.
	__3.  At the bottom, click the Properties tab. 
	__4.  Then click the Bindings tab.
	__5.  Close the assembly diagram making sure you did not make any changes.

	Part 7 -  Export EAR Files
	__1.  Under the Build Support project, double click build.xml to open it.
	__2.  Make sure that the C:\temp folder exists. If not, create it. This is where the EAR files will be created.
	__3.  Back in WID, right click build.xml and select Run As > 3 Ant Build...
	__4.  Select the Export EAR target.
	__5.  Click the JRE tab.
	__6.  Select Run in the same JRE as the workspace. This is needed so that the definition of the extended task earExport can be found.
	__7.  Click Apply. This will save the JRE selection so that you don't have to select it again.
	__8.  Click Run to run the script.
	__9.  From the menu, select Window > Show View > Console.
	__10.  In the Console view, go to the bottom and make sure that the build was successful.
	__11.  Verify that four EAR files are created in C:\temp.
	__12.  We are done with the build process. Exit out of WID (File > Exit).

	Part 8 -  Deploy the Applications
	__1.  Open a command prompt window.
	__2.  Change to the <DM_PROFILE_ROOT>\bin folder.
	__3.  Run the following command:
	__4.  When prompted for authentication supply a username and password of 'wasadmin'.
	__5.  If it is not started then enter the command startManager.bat and wait until starts.
	__6.  Also check that your node agent is started by issuing the same status command from the <CUSTOM_ROOT>\bin directory and use the startNode.bat command to start it if needed.
	__7.  Log into admin console as wasadmin.
	__8.  Expand Applications.
	__9.  Click New Application.
	__10.  Click New Enterprise Application.
	__11.  Click Browse.
	__12.  Select C:\temp\PriceQuoteFlowApp.ear
	__13.  Click Open.
	__14.  Click Next.
	__15.  Select the Fast Path option and click the Next button.
	__16.  In the Select installation options page, click Next.
	__17.  In the Map modules to servers page, click Next.
	__18.  Click Finish.
	__19.  Once deployment ends, click Save.
	__20.  Wait until the synchronization is completed.
	__21.  Similarly, install applications from these EAR files, save after every installation and wait until synchronization is completed.

	Part 9 -  Start Applications
	__1.  Expand System administration.
	__2.  Click Nodes.
	__3.  Make sure that the node is synchronized. If not, select it and click Synchronize.
	__4.  Expand Servers → Clusters and click WebSphere application server clusters.
	__5.  Start the server. Wait for it to start completely.
	__6.  Expand Applications → Application Types and click WebSphere Enterprise Applications.
	__7.  Select the check box for these applications.
	__8.  If these applications were not already started from restarting your cluster click the Start button.

	Part 10 -  Test the Solution
	__1.  Open a web browser and enter the URL of the web based application used to place an order:
	__2.  Enter some values.
	__3.  Click Go.
	__4.  Make sure that you see the success message.
	__5.  Open the server's SystemOut.log file from <CSTM_PROFILE_ROOT>\logs\MyTopology.AppTarget.<HOSTNAME>Node01.0.
	__6.  Go to the very end of the file. The log entries will tell a story. 
	__7.  Close the log file.

	Part 11 -  Edit Endpoint Address
	__1.  In the admin console, expand Applications and click SCA Modules.
	__2.  Check the box next to the 'PriceQuoteFlow' module and click the Stop button.
	__3.  Click the link for the PriceQuoteFlow module.
	__4.  Expand Imports and you will notice the two imports.
	__5.  Expand AJAXImport and then Binding.
	__6.  Click JAX-Web Service...
	__7.  Click Edit next to it.
	__8.  Change the URL to use plain HTTP modifying the protocol and the port: 
	__9.  Click OK.
	__10.  Click Save.
	__11.  Click OK after synchronization is complete. 
	__12.  Return to the list of SCA modules and start the PriceQuoteFlow SCA module.
	__13.  Open a new browser and enter:
	__14.  Enter some information and click Go.
	__15.  Verify that the message "Order was created successfully" appears in the browser.
	__16.  Open the SystemOut.log file of the server.
	__17.  Go to the bottom of the file and make sure the solution is working.
	__18.  Close the log file.

	Part 12 -  Troubleshooting Endpoint Address
	__1.  Using the steps from the previous part, set the port number of the endpoint URL for AJAXImport to 9081.  Make sure you stop the module before editing the endpoint address.
	__2.  Make sure you saved and the synchronization is complete. 
	__3.  Make sure the PriceQuoteFlow SCA module is started.
	__4.  Open a new browser and enter:
	__5.  Enter some information and click Go.
	__6.  Open the SystemOut.log file of the server. 
	__7.  Go to the very end. You will see a bunch of exception stack trace.
	__8.  The very first stack trace will show this.
	__9.  Close the log file.
	__10.  Fix the port number in the endpoint address. Save and wait for synchronization. Then restart the SCA module.
	__11.  Test the application and make sure it is working fine.
	__12.  Logout the admin.
	__13.  Close all open browsers and windows.

	Part 13 -  Review

	Lab 8 -  Application Integration Using JMS Messaging
	Part 1 -  Business Logic and Architecture
	Part 2 -  Create the Message Queues
	__1.  Start the deployment manager and node agent servers unless they are already running.
	__2.  Log in to admin console as wasadmin.
	__3.  Stop your MyTopology.AppTarget  server if it is running.  We will need to restart it after configuring some resources.
	__4.  Expand Service integration and click Buses.
	__5.  Click New to create a new message bus.
	__6.  Enter DemoBus as the name.
	__7.  Clear the Bus Security checkbox to disable security protection for the bus.
	__8.  Click Next.
	__9.  Click Finish.
	__10.  Click DemoBus from the list of buses.
	__11.  Click Bus members.
	__12.  Click the Add button.
	__13.  Select Cluster.
	__14.  Click Next.
	__15.  Leave the default settings for 'messaging engine policy assistance' and click the Next button.
	__16.  Choose Data store.
	__17.  Click Next.
	__18.  Click the link for the 'messaging engine' to configure the settings.  You won't be able to proceed until we do.
	__19.  Enter jdbc/WPSDB as the data source JNDI name.
	__20.  Select WPSDB_Auth_Alias as the database authentication alias.
	__21.  Click Next.
	__22.  Back on the list of messaging engines click the Next button.
	__23.  Ignore the request to change the Java heap sizes and click the Next button without changing the settings.
	__24.  Click Finish to add the bus member.
	__25.  On the left hand navigation tree, expand Service integration and click Buses.
	__26.  Click DemoBus.
	__27.  Click Destinations.
	__28.  Click New.
	__29.  Choose Queue (default). Note: For pub/sub you will create a topic instead.
	__30.  Click Next.
	__31.  Enter AccountingRequestQ as the identifier.
	__32.  Click Next.
	__33.  The bus member to host the queue should be the cluster. Click Next.
	__34.  Click Finish to create the queue.
	__35.  Similarly, create another queue called AccountingResponseQ
	__36.  Click the Save link to save your changes.
	__37.  Click OK when the synchronization is complete.

	Part 3 -  Create JMS Resources
	__1.  In the left hand navigation tree, expand Resources > JMS.
	__2.  Click Queue Connection Factories.
	__3.  Set the scope to the cluster MyToplogy.AppTarget as shown below.
	__4.  Click New.
	__5.  Click OK to create the resource for the default messaging provider.
	__6.  Enter these values:
	__7.  Click OK.
	__8.  Click Queues on the left side under Resources → JMS.
	__9.  Set the scope to the cluster MyTopology.AppTarget.
	__10.  Click New.
	__11.  Click OK to create a default messaging queue.
	__12.  Enter these values.
	__13.  Click OK.
	__14.  Click New again and create another destination.
	__15.  Click OK to create a default messaging queue.
	__16.  Enter the destination as follows.
	__17.  Click OK.
	__18.  Save changes.
	__19.  Click OK when the synchronization is complete.
	__20.  Logout and close the Admin Console.

	Part 4 -  Review JMS Enabled Solution
	__1.  Launch WID using the same workspace.
	__2.  Import all projects from the project interchange file C:\LabFiles\PriceQuoteJMS.zip. You will be asked to overwrite the PriceQuoteFlow module. Choose to do so.
	__3.  Wait for build to finish.
	__4.  Close all open files.
	__5.  Open the assembly diagram for the PriceQuoteFlow module.

	Part 5 -  Review the JMS Import Configuration
	__1.  In the assembly diagram, select the JMS import  AccountingApp.
	__2.  In the Properties view, select the End-point configuration tab.
	__3.  Select the JMS Destinations tab.
	__4.  Expand Send Destinations Properties.
	__5.  Make sure that the send destination JNDI name is set to jms/AccountingRequestQ.
	__6.  Similarly, verify the JNDI name of the receive destination queue.
	__7.  Expand Callback Destination Properties.
	__8.  Make sure that Specify properties for configuring new messaging provider resource checkbox is selected. Here we will provide enough information so that WebSphere ESB can dynamically create the destination.
	__9.  The Bus name field should be set to DemoBus
	__10.  Close all open files.
	__11.  Exit out of WID.

	Part 6 -  Update the PriceQuoteFlow Module
	__1.  Open the Admin console and login as wasadmin.
	__2.  Select Applications → Application Types → WebSphere Enterprise Applications.
	__3.  Select the checkbox for PriceQuoteFlowApp.
	__4.  Click Update.
	__5.  Select the Replace the entire application option.
	__6.  Using the Browse button, select C:\LabFiles\PriceQuoteFlowAppJMS.ear and click Open.
	__7.  Scroll all the way down and click Next.
	__8.  Select the Fast Path option and click the Next button.
	__9.  Click Next at Step1 page.
	__10.  Click Next at Step2 page.
	__11.  Click Finish.
	__12.  Save changes and wait for synchronization.

	Part 7 -  Deploy Accounting (MDB) Application
	__1.  Expand Resources > JMS.
	__2.  Click Activation specifications.
	__3.  Set the scope to the cluster MyTopology.MyTarget.
	__4.  Click New.
	__5.  Click OK to use the default messaging provider.
	__6.  Enter the following values.
	__7.  Scroll down and click OK.
	__8.  Save changes and wait for synchronization.
	__9.  On the left hand side, expand Applications and click New Application.
	__10.  Click the link for New enterprise application.
	__11.  Use the Browse button to select C:\LabFiles\SimpleAccountingApp.ear and click Open.
	__12.  Click Next.
	__13.  Select the Fast Path option and click the Next button.
	__14.  Click Next at Step1 page.
	__15.  Click Next at Step2 page.
	__16.  Click Finish.
	__17.  Save changes and wait for synchronization.
	__18.  On the left hand side click Applications → Application Types → WebSphere Enterprise Applications.
	__19.  Click SimpleAccountingApp.
	__20.  Click Message Driven Bean listener bindings.
	__21.  Make sure that the activation specification option is selected.
	__22.  We are all set, go to your list of Servers → Server Types → WebSphere application servers and start your AppTarget server.  This will initialize all of the resources you have configured.
	__23.  go back to the Applications → Application Types → WebSphere Enterprise Application page. 
	__24.  Check that the SimpleAccountingApp and the PriceQuoteFlowApp are running after starting the server.
	__25.  Open the server's SystemOut.log file and make sure that there are no exceptions. 
	__26.  Close the log file.

	Part 8 -  Test
	__1.  Open a web browser and enter the URL:  
	__2.  Enter some values and then click Go. Make sure that the form submits successfully.
	__3.  Open server's SystemOut.log file using notepad.
	__4.  Search for QuoteMDB to locate log messages from the MDB.
	__5.  Make sure the winning supplier got the order.
	__6.  Close the log file.

	Part 9 -  Review JMS Endpoint Address
	__1.  On the left hand side of the admin console, click Applications → SCA modules.
	__2.  Click PriceQuoteFlow.
	__3.  Expand Imports > AccountingApp > Binding.
	__4.  Click JMS.
	__5.  For sending messages, the JNDI names of the connection factory and send destination queue can be set here.
	__6.  Logout the admin console and close all the browsers.

	Part 10 -  Review

	Lab 9 -  Application Integration Using MQ JMS Binding
	Part 1 -  Business Logic
	Part 2 -  Understand the Solution
	Part 3 -  Create MQ Resources
	__1.  Make sure you are logged in as the administrative user used in the labs.
	__2.  Launch MQ Explorer from the Start menu > All Programs > IBM WebSphere MQ > WebSphere MQ Explorer.  If you are running on Windows Vista you must right click the shortcut and select 'Run as administrator'.
	__3.  Close the Welcome page.
	__4.  Right click Queue Managers and select New > Queue Manager...
	__5.  Enter MyQM as the name of the queue manager.
	__6.  Click Finish.
	__7.  The queue manager will be started automatically. If needed, you can always start and stop it by right clicking it. We will keep it running.
	__8.  Expand MyQM.
	__9.  Right click Queues and select New > Local Queue...
	__10.  Enter InputQ as the name.
	__11.  Click Finish.
	__12.  Click OK to close the information dialog.
	__13.  Similarly, create another local queue called OutputQ
	__14.  Verify that both queues are listed as follows.
	__15.  Minimize the MQ Explorer but leave it open as we will use it later to submit and examine messages.

	Part 4 -  Create JMS Resources
	__1.  Start your Deployment Manager and Node Agent if they are not running.
	__2.  Log into the admin console.
	__3.  Stop your Enterprise Service Bus instance if it is already running as we will need to start it after configuring resources anyway. Wait until is completely stopped.
	__4.  Expand Resources > JMS.
	__5.  Click Connection factories.
	__6.  Set the scope to the cluster MyTopology.AppTarget.
	__7.  Click New.
	__8.  Select WebSphere MQ messaging provider.
	__9.  Click OK.
	__10.  At the Configure basic attributes page, enter the following information.  Press the Next button when done.
	__11.  Leave the default option to enter all connection information in the wizard and press the Next button.
	__12.  Enter 'MyQM' for the queue manager and press the Next button.  This must match the name we had used to create the queue manager.
	__13.  Enter your <HOSTNAME> in the connection details and press the Next button.
	__14.  Press the Test Connection button and be sure you get a successful connection.  
	__15.  Once you do press the Next button.
	__16.  Press the Finish button to create the connection factory.
	__17.  Click the link in the navigation pane for Resources -> JMS  -> Queues.
	__18.  Set the scope to our cluster if it is not already.
	__19.  Click New.
	__20.  Select WebSphere MQ messaging provider.
	__21.  Click OK.
	__22.  At the New Queue page, enter the following information.  Leave the rest of the settings with the defaults.  Note the screenshots below only show the sections that have settings that are changed.
	__23.  When the values match those above press the OK button.
	__24.  Similarly, create another JMS destination as follows.
	__25.  Verify that both destinations have been created as follows.
	__26.  Save changes and wait for synchronization.

	Part 5 -  Configure the JMS Activation Specification
	__1.  In the navigation pane select Resources -> JMS -> Activation specifications.
	__2.  Check that you are at the MyTopology.AppTarget cluster scope as in previous sections of this lab.  If you need to switch scope, select the scope using the drop down list.
	__3.  At the JMS Activation Specifications list, press the New button.
	__4.  Select WebSphere MQ messaging provider as the choice for provider and press the OK button.
	__5.  At the Configure basic attributes page, enter the following information.
	__6.  Press the Next button when your settings match that shown above.
	__7.  At the Specify MDB destination data page, enter the following information.
	__8.  Check that the Destination JNDI name matches the value above and press the Next button.
	__9.  Leave the default option to enter all connection information in the wizard and press the Next button.
	__10.  Enter 'MyQM' for the queue manager and press the Next button.  
	__11.  Enter your <HOSTNAME> in the connection details and press the Next button.
	__12.  Press the Test Connection button and be sure you get a successful connection.  Once you do press the Next button.
	__13.  Press the Finish button to create the activation specification.
	__14.  Save changes and wait for synchronization.

	Part 6 -  Deploy the SCA Module
	__1.  You should be familiar by now to the steps needed to deploy an application. Follow those steps to deploy C:\LabFiles\MQTestApp.ear.
	__2.  Save changes and wait for synchronization.

	Part 7 -  Review MQ JMS Binding
	__1.  On the left hand side, click SCA modules under Applications.
	__2.  Click MQTest.
	__3.  Expand Imports > MQJMSImport > Binding.
	__4.  Click MQJMS.
	__5.  Notice that the Send Resources already match some of the JMS resources you configured earlier.
	__6.  Click the MQTest link in the breadcrumb trail.
	__7.  Back on the MQTest SCA module properties page expand Exports > MQJMSExport > Binding.
	__8.  Click MQJMS.
	__9.  Notice that the Receive Resources match the configuration you made earlier.

	Part 8 -  Test the SCA Module
	__1.  Go to Servers → Server Types → WebSphere application servers and start your Enterprise Service Bus instance.
	__2.  Open the Applications → SCA Modules page.
	__3.  Check that the MQTest SCA module is started.
	__4.  Open MQ Explorer, if it is not already open.  Remember if you are running on Windows Vista you must right-click the shortcut and run the MQ Explorer as an administrator.
	__5.  Expand Queue Managers > MyQM > Queues.
	__6.  Right click InputQ and select Put Test Message.
	__7.  Enter three comma separated fields for the customer data.
	__8.  Click Put Message.
	__9.  Click Close.
	__10.  The tool should automatically refresh the list of queues in a few seconds. Alternatively, click the Refresh toolbar button.
	__11.  The Current queue depth for the OutputQ should become 1.
	__12.  Right click OutputQ and select Browse Messages.
	__13.  Double click the message to view its contents.
	__14.  Click the Data property from the list on the left.
	__15.  The XML message is shown the the Message data field. To better view the message, copy the data and paste it in notepad.
	__16.  Click OK to close close the message.
	__17.  Click Close in the Message browser window and close the MQ Explorer.
	__18.  Logout of the admin console and close any open browser.

	Part 9 -  Review

	Lab 10 -  Deploying and Configuring JCA Adapters
	Part 1 -  Understanding the Adapter Architecture
	Part 2 -  The Business Logic of the Sample Application
	Part 3 -  Deploy the Application
	__1.  Login to the admin console as wasadmin.
	__2.  Using the steps that should be already familiar to you deploy the EAR file C:\LabFiles\AdapterExampleApp.ear.
	__3.  Save changes and wait for synchronization.
	__4.  Do not start the application yet. We will configure the adapter first.

	Part 4 -  Configure the Inbound Adapter
	__1.  In the list of SCA modules, click AdapterExample.
	__2.  Expand the imports and exports as shown below.
	__3.  In the left hand side, click Applications → Application Types → WebSphere Enterprise Applications to view the list of applications.
	__4.  Click AdapterExampleApp.
	__5.  Click Manage Modules.
	__6.  Click the RAR module IBM WebSphere Adapter for Flat Files.
	__7.  Click Resource Adapter.
	__8.  Click J2C activation specifications.
	__9.  Click AdapterExample.FlatFileInbound_AS.
	__10.  Click J2C activation specification custom properties.
	__11.  Note that the eventDirectory property is currently set to C:\dev\in.
	__12.  Click eventDirectory.
	__13.  Set the value to C:\temp\in
	__14.  Click OK.

	Part 5 -  Configure the Outbound Adapter
	__1.  In the left hand side, click Applications → Application Types → WebSphere Enterprise Applications to view the list of applications.
	__2.  Click AdapterExampleApp.
	__3.  Click Manage Modules.
	__4.  Click the RAR module IBM WebSphere Adapter for Flat Files.
	__5.  Click Resource Adapter.
	__6.  Recall, outbound adapter is configured using the connection factory. Click J2C connection factories.
	__7.  Click AdapterExample.FlatFileOutbound_CF.
	__8.  Click Custom properties.
	__9.  Set the values of various properties as follows:
	__10.  Save changes and wait for synchronization.

	Part 6 -  Test the Application
	__1.  Create these folders if they do not exist.
	C:\temp
	C:\temp\in
	C:\temp\out
	__2.  Start the application AdapterExampleApp. If you see a note at the top, refresh the list and make sure the application started sucessfully.
	__3.  A sample input file is made available as C:\LabFiles\file_in.xml. Open the file to have a look. 
	__4.  Close the file.
	__5.  Copy the C:\LabFiles\file_in.xml file into C:\temp\in. (After a couple seconds the file will disappear)
	__6.  Have a look at C:\temp\out. There should be a file called Customer.1.xml
	__7.  Copy the input file to C:\temp\in again. This will create Customer.2.xml in the output folder.
	__8.  Have a look at C:\temp\Sequence.txt. It should have the current sequence number.
	__9.  Close all open files.
	__10.  Logout the admin console and close the browser.

	Part 7 -  Review

	Lab 11 -  Administration Through Scripting
	Part 1 -  Launch wsadmin
	__1.  Open a command prompt window.
	__2.  Change directory to <DM_PROFILE_ROOT>\bin. 
	__3.  Launch wsadmin as follows.

	Part 2 -  List Installed Modules
	__1.  To view a list of all SCA modules run:
	__2.  To view the attributes of the PriceQuoteFlow SCA module run:

	Part 3 -  Work With Exports
	__1.  First, to view all exports in the module run:
	__2.  To view the attributes of the export called OrderTakerExport1, run:
	__3.  To view details of the binding used by the export, run:
	__4.  Note that the type of binding is a JAX-WS web service. To view more details about the export, run:

	Part 4 -  Work With Imports
	__1.  To view all the imports used in the PriceQuoteFlow module, run:
	__2.  To view more details about the import ACMEImport, run these commands:
	__3.  A common requirement is to change the endpoint URL of a web service import. Modify the endpoint URL of  ACMEImport as follows.  There is no output from this command.
	__4.  Verify that the change has taken place by running:
	__5.  Change the endpoint URL back to the original value:
	__6.  Verify that the change has taken place by running:
	__7.  Save and exit.
	__8.  Close the command prompt window.

	Part 5 -  Review

	Lab 12 -  Failed Events
	Part 1 -  Deploy and Test Related Applications
	__1.  Make sure that your deployment manager, node agent, and AppTarget ESB server are all running.  Start them if they are not.
	__2.  Login to the admin console as wasadmin.
	__3.  Using the steps that should be already familiar to you deploy the following EAR files to the AppTarget ESB server.
	__4.  Save any remaining changes and wait for synchronization.
	__5.  Go to Applications → Application Types → WebSphere enterprise applications.
	__6.  Start the following applications:
	__7.  Open a web browser to the following address:
	__8.  Enter some product information as shown below and click the Add Product button.
	__9.  Make sure you get a confirmation of success.
	__10.  Open the AppTarget SystemOut.log file as you have done before using the Pigtail application or a text editor.  It is in the <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<hostname>Node01.0 directory.
	__11.  Check that you see several messages about the product that you added.  The 'SystemOut' message is from the client application, the 'TraceMediation' message is from the mediation flow, and the 'CatalogManager' message is from the product catalog service that is invoked by the mediation flow.
	__12.  After you have confirmed that the application is working and routing the product information back to the catalog service you can close the log file (or press 'Clear' if you are using Pigtail).

	Part 2 -  Test for Service Failure
	__1.  Back in the Admin Console, go to Applications → Application Types → WebSphere enterprise applications.
	__2.  Stop the ProductCatalogApp application but leave the other applications you installed in this lab running.
	__3.  Return to the web browser you were using to test and go back to the input page. Open the following address if you closed the browser:
	__4.  Enter in some product information.  It would be good to use at least a different product name than before.  Click the Add Product button when done.
	__5.  Make sure that you still get the success message.  Since the service is invoked asynchronously the client is not aware the service is unavailable.
	__6.  Go back to the product input page and enter data for a second new product and submit again.  That should also be successful.
	__7.  Finally, go back to the product input page and enter data for a third new product.  In total you should have submitted three new products after the service was made unavailable.

	Part 3 -  Recovery Using Failed Event Manager (FEM)
	__1.  Open the AppTarget SystemOut.log file as you have done before using the Pigtail application or a text editor.
	__2.  Look for where your first new product was submitted.  You should see that the client application and the mediation flow both output the product name but then there was an error (with the 'E' message type).
	__3.  Look a little further down and you should see that right before the message for your second product there are messages from 'StoreAndForward' and 'Recovery'.  These messages indicate the saved failed event and the change in state to the 'Store' state to indicate the service will not be called again.  This is obvious since notice the second and third products added do not have errors immediately following them because they were never invoked in the first place.
	__4.  Close the log file (or press 'Clear' if you are using Pigtail).
	__5.  Back in the Admin Console, go to Applications → Application Types → WebSphere enterprise applications.
	__6.  Start the ProductCatalogApp application.
	__7.  On the left side of the Admin Console, expand Integration Applications.
	__8.  Click Failed Event Manager.
	__9.  Click the Get all failed events link.
	__10.  You should see one failed event.  Notice that there is information like what operation of what SCA component (in this case the CatalogManagerImport1 import) failed.
	__11.  Click the link for the Event ID.
	__12.  Notice that you can also get various details here including the exception text.  In this case the exception is a '404' error because the service application was stopped and the server did not know how to respond to our service request.
	__13.  Click the Edit business data button.
	__14.  Click the link for 'arg0'.  Most service operations have a single parameter which "wraps" the data sent to the service.
	__15.  Click the product link.
	__16.  Notice here you finally have the data that you entered in to the client application.
	__17.  Click the name link.
	__18.  Add the text '-EDIT' to the end so we know the value was edited in the Admin Console and click the OK button.
	__19.  Check that you see the edited value of the name and click the Resubmit button.  This will resubmit the failed event.
	__20.  On the left in the Admin Console click the link for Integration Applications → Failed Event Manager and check that there are no longer any failed events.

	Part 4 -  Recovery Using Store and Forward
	__1.  Open a web browser to the following address:
	__2.  If you get an error about the server certificate take the steps to accept the certificate and continue to the web page.
	__3.  Once you see the Business Space login, use the username and password of 'wasadmin' to login.  It may take a while to login.
	__4.  Go to the Home page and click the Start button.
	__5.  Expand Service Administration. Note that Store and Forward is listed there.
	__6.  Click the Store and Forward link.
	__7.  The MySF configuration of control point will be listed. A cylinder icon indicates that it is in stored state. 
	__8.  Click the MySF row to select it. On the right hand side, you will see details.
	__9.  On the left, check the checkbox for MySF. 
	__10.  Click the Forward button.
	__11.  The status icon will change to show that it is in forwarding state.
	__12.  Open the AppTarget SystemOut.log file as you have done before using the Pigtail application or a text editor.
	__13.  At the bottom of the log you should see that the requests to add all three products all make it to the service.  Notice the name of the product you edited from the Failed Event Manager.  You will not see other messages from the original client application or the mediation flow because these messages are the ESB server invoking the service operations now that the state is in the "Forward" state.
	__14.  Close the log file, log out of any admin applications, and close all open browsers.

	Part 5 -  Review

	Lab 13 -  Service Version Migration
	Part 1 -  Deploy v1 Service and Client and Test
	__1.  Make sure that your deployment manager, node agent, and AppTarget ESB server are all running.  Start them if they are not.
	__2.  Login to the admin console as wasadmin.
	__3.  Using the steps that should be already familiar to you deploy the following EAR files to the AppTarget ESB server.
	__4.  Save any remaining changes and wait for synchronization.
	__5.  Go to Applications → Application Types → WebSphere enterprise applications.
	__6.  Start the following applications.  You may need to go to the second page of applications to see the service application.
	__7.  Open a web browser to the following address:
	__8.  Open the AppTarget SystemOut.log file as you have done before using the Pigtail application.  It is in the <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<hostname>Node01.0 directory.
	__9.  Clear the Pigtail application so you will see only the messages that will be printed from submitting data.
	__10.  Fill in a value of '3' for the account ID and '50.00' for the amount and click the Withdraw button.
	__11.  Look in the log messages of the Pigtail application and check that you see the following output.  Note among other things that this is the V1.0 service implementation.
	__12.  Press the back button and fill in an account ID of '3' and any positive amount and click Deposit.
	__13.  In the Pigtail log messages you should see the output.
	__14.  Press the back button and fill in an account ID of '5' and any positive amount and click Deposit.  This account ID will generate an error every time.
	__15.  Close the test browser but leave the server running.

	Part 2 -  Deploy v2 Service and Obtain WSDL Files
	__1.  Using the steps that should be already familiar to you deploy the following EAR files to the AppTarget ESB server.
	__2.  Save changes and wait for synchronization.
	__3.  Go to Applications → Application Types → WebSphere enterprise applications.
	__4.  Start the following application.  You may need to go to the second page of applications to see the service application.
	__5.  Still in the list of applications click the link for the VersionDemoServiceAppV1 application.
	__6.  Scroll down and in the list of 'Web Services Properties' on the right, click the link for Publish WSDL files.
	__7.  On the page that appears click the link for the zip file of WSDL files.
	__8.  When prompted to open or save the file, save it in the <LABFILES_DIR> directory.
	__9.  Return to the list of enterprise applications click the link for the VersionDemoServiceAppV2 application.
	__10.  Scroll down and in the list of 'Web Services Properties' on the right click the link for Publish WSDL files.
	__11.  On the page that appears click the link for the zip file of WSDL files.
	__12.  When prompted to open or save the file, save it in the <LABFILES_DIR> directory.
	__13.  Logout of the Admin Console.
	__14.  Open a Windows Explorer window and navigate to the <LABFILES_DIR> directory.
	__15.  Using a zip utility extract the contents of the two zip files you saved.  Extract them both to the <LABFILES_DIR> folder which should create two new subdirectories, VersionDemoServiceAppV1.ear and VersionDemoServiceAppV2.ear.

	Part 3 -  Examine Changes Between Service Versions
	__1.  Open WID by selecting Start > All Programs > IBM WebSphere Integration Developer > IBM WebSphere Integration Developer V7.0 >  WebSphere Integration Developer V7.0 
	__2.  In the Workspace Launcher dialog, change the workspace to C:\workspace
	__3.  Click OK.
	__4.  Once WID starts wait a second for the tools to initialize and then open the Web perspective by selecting Window → Open Perspective → Other.., select Web, and then click the OK button.
	__5.  Select File → New → Project...
	__6.  Select General → Project and click the Next button.
	__7.  Enter LabFiles for the project name, Uncheck the Use default location checkbox, and browse to the <LABFILES_DIR> folder as the location of the project.
	__8.  Once your project settings match that shown above click the Finish button to create the project.
	__9.  Run the Web Services Explorer by selecting Run → Launch Web Services Explorer.
	__10.  Maximize the Web Services Explorer by double clicking the title tab or clicking the Maximize button in the upper right of the editor panel.
	__11.  In the upper right of the editor, click the icon for the WSDL Page.
	__12.  On the left click the link for WSDL Main.
	__13.  On the right click the Browse link to open the WSDL selection dialog.
	__14.  Select Workspace WSDL documents for the category and LabFiles under the Workspace Projects.  Don't click the Go button yet.
	__15.  For the WSDL URL use the drop down to select the 'VersionDemoServiceV10.wsdl' file in the 'generatedWSDLDir' directory of the V1 service WAR location as shown below.
	__16.  Once the generated V1 WSDL file is selected as shown above click the Go button to close the WSDL browser.
	__17.  Back in the Open WSDL portion of the Web Services Explorer click the Go button again to use the selected WSDL.
	__18.  Notice the Endpoint has the version of the service in the URL.  This can be important because you might need to run several versions of a service concurrently.
	__19.  Click on the link for the deposit operation.
	__20.  Fill in an id of '12' and some positive value for the amount and click the Go button to submit the request to the service.
	__21.  In the Status section (you may want to double click the section header to temporarily maximize the panel) notice that you get a boolean value of 'true' indicating that the operation completed successfully.
	__22.  Back in the parameters of the deposit operation (you may need to restore the size of the Status section) fill in a value of '5' for the ID and any positive value for amount and click the Go button again to submit the request.
	__23.  Look in the Status section again and notice this time the return value is a boolean value of 'false' to indicate there was an error.
	__24.  On the left click the link for WSDL Main.
	__25.  On the right click the Browse link to open the WSDL selection dialog.
	__26.  Select Workspace WSDL documents for the category and LabFiles under the Workspace Projects.  Don't click the Go button yet.
	__27.  For the WSDL URL use the drop down to select the 'VersionDemoServiceV20.wsdl' file in the 'generatedWSDLDir' directory of the V2 service WAR location as shown below.
	__28.  Once the generated V2 WSDL file is selected as shown above click the Go button to close the WSDL browser.
	__29.  Back in the Open WSDL portion of the Web Services Explorer click the Go button again to use the selected WSDL.
	__30.  Notice that besides the new 'openAccount' operation the endpoint location is also different.  As mentioned this could let us run both service versions at the same time which is often required for many service version migrations.
	__31.  Click on the link for the deposit operation.
	__32.  Fill in an id of '12' and some positive value for the amount.  For 'accountType' click the 'Add' link to add a value box and fill in a value of 'Savings' and click the Go button to submit the request to the service.
	__33.  In the Status section notice that you now get a double value for the current balance of the account.  This is one change we will have to take into account in the mediation flow.
	__34.  Open the AppTarget server log file with a text editor or the Pigtail application and notice the output indicates this is the V2.0 service and also prints out the type of account being used.
	__35.  Back in the parameters of the deposit operation fill in a value of '5' for the ID and any positive value for amount and the same accountType and click the Go button again to submit the request.
	__36.  In the Status section notice the output can't be displayed in the form view.  Click the Source link to switch the view.
	__37.  In the source view notice the SOAP Response Envelope is a fault which includes the same error message ("Invalid Account Number") that previously we had only been able to see in the Console output on the server.  Clearly this version of the service has more advanced error handling that returns a fault when there is a problem instead of a boolean value indicating success or failure of the operation.  This is something that will affect our mediation flow also because our mediation flow will need to respond like the V1 service does.
	__38.  Close the browser for the Web Service Explorer.
	__39.  Close the Web perspective by selecting Window → Close Perspective.
	__40.  Close WID by selecting File → Exit and confirm closing WID if prompted.

	Part 4 -  Deploy v1-to-v2 Mediation Flow and Update Client
	__1.  Return to the Admin Console and login as 'wasadmin'.
	__2.  Go to Applications → Application Types → WebSphere enterprise applications.
	__3.  Stop the VersionDemoServiceAppV1 application.  You may need to go to the second page of applications to see the service application.  Make sure you stop the V1 service and not V2.
	__4.  Now check the VersionDemoServiceAppV1 application and click the Uninstall button to uninstall the application.
	__5.  Click the OK button to confirm you want to uninstall.
	__6.  Save the configuration and wait for the node synchronization.
	__7.  Open a web browser to the following address:
	__8.  Open the AppTarget SystemOut.log file as you have done before using the Pigtail application.  It is in the <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<hostname>Node01.0 directory.
	__9.  Clear the Pigtail application so you will see only the messages that will be printed from submitting data.
	__10.  Fill in a value except '5' for the account ID and a positive value for the amount and click the Withdraw button.
	__11.  You should get a '500' error and perhaps a browser error page because the service client was not able to invoke the service.
	__12.  Return to the Pigtail application and you should see that the last part of the exception message mentions a '404' error that can't find the service at the v1 URL.
	__13.  Close the browser used to test.
	__14.  Using the steps that should be already familiar to you deploy the following EAR files to the AppTarget ESB server.
	__15.  Save changes and wait for synchronization.
	__16.  Go to Applications → Application Types → WebSphere enterprise applications.
	__17.  Start the following application.  You may need to go to the second page of applications to see the mediation application.
	__18.  In the Admin Console, navigate to Applications → SCA Modules.
	__19.  Click the link for the VersionDemoMediation application.
	__20.  On the right side of the properties expand Imports → VersionDemoServiceImport1 → Interfaces[WSDL] and click the link for the 'VersionDemoService' interface.
	__21.  Scroll to the bottom and notice the interface of the import is the V2 interface with the three operations including 'openAccount'.  This shows that the mediation will be sending requests to the V2 service.
	__22.  In the breadcrumb trail at the top click the VersionDemoMediation link.
	__23.  On the right side of the properties expand Imports → VersionDemoServiceImport1 → Binding and click the link for the JAX-WS binding.
	__24.  Notice that the mediation flow is already linked to the V2 service endpoint URL although you could modify it if needed.
	__25.  In the breadcrumb trail at the top click the VersionDemoMediation link.
	__26.  On the right side of the properties expand Exports → VersionDemoServiceExport1 → Binding and click the link for the JAX-WS binding.
	__27.  Highlight and then right click and Copy the entire endpoint address of the binding.  Make sure to get all of it as there may be two lines.
	__28.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__29.  Click the link for the VersionDemoClientApp application.
	__30.  Scroll down and in the list of 'Web Services Properties'  click the link for Service clients.
	__31.  Click the link for the Module on the right.  If you click the service name on the left it will take you to web service policies which are not being used for this web service.
	__32.  Under 'Web Services Properties' click the link for Web services client bindings.
	__33.  Click the first 'Edit' link in the 'Port Information' column.  Make sure you do not click the link in the 'mappings' column.
	__34.  Delete the current value in the 'Overridden Endpoint URL' box and paste in the value of the mediation flow export.  If you do not still have this in your clipboard it should be:
	__35.  Once your value is filled in as shown above click the OK button to submit the change.
	__36.  Click the Save link in the messages at the top of the Admin Console and wait for the node synchronization.
	__37.  Open a web browser to the following address:
	__38.  Fill in a value of '3' for the account ID and '50.00' for the amount and click the Withdraw button.
	__39.  Go to the Pigtail application showing the server log or open the server log file and check that you see the following output.  Note that the output is now coming from the V2 service implementation.
	__40.  Press the back button and fill in an account ID of '3' and any positive amount and click Deposit.
	__41.  In the log messages you should see the output from the V2 service.  Notice the account type of 'Checking' being supplied by the mediation flow.
	__42.  Press the back button and fill in an account ID of '5' and any positive amount and click Deposit.  Notice the error is first generated by the V2 service which throws a fault which is then handled by the mediation flow and a value of 'false' is returned by the service operation triggering the display of the error page.
	__43.  Close the test browser.
	__44.  Close pigtail.
	__45.  Stop your ESB AppTarget server but leave the deployment manager and node agent running.
	__46.  Logout of the Admin Console.

	Part 5 -  Review

	Lab 14 -  Routing Requests Through a Web Server
	Part 1 -  Install the Web Server
	__1.  Make sure you are logged in as an administrative user.
	__2.  Open a Windows Explorer window.
	__3.  Navigate to the <WAS_SOFTWARE_DIR>\Supplement\IHS directory substituting the <WAS_SOFTWARE_DIR> variable location mentioned in the beginning of these labs.  Check with your instructor if you can't find the directory listed.
	__4.  Double click the install.exe file to start the launchpad.
	__5.  Click Next on the Welcome screen.
	__6.  Accept the license and click Next.
	__7.  Once the system passes the prerequisite checks press the Next button.  
	__8.  Write down the installation directory for the <IHS_ROOT> variable in the list of directory paths at the beginning of these labs.  This directory will be used later in the labs.  Leave the default installation directory as is and press the Next button.
	__9.  Accept the default values for the HTTP port and administration port.  Click the Next button.
	__10.  Change the way the Windows service logs on to “Log on as local system account” as shown below.  Press the Next button.
	__11.  Leave the option for “Create a user ID for IBM HTTP administration server authentication” checked.  Fill in a user ID and password of 'ihsadmin'. Click the Next button.
	__12.  Leave the option for “Install the IBM HTTP Server Plug-in for IBM WebSphere Application Server” option checked.  Make sure that the Host name listed matches the value for the <HOSTNAME> variable you wrote down in the lab notes section.  It is important that it doesn't have 'localdomain' on the end.  Click the Next button when you have checked the settings on this page.
	__13.  Press the Next button in the summary screen to start the installation.
	__14.  Press the Finish button to close the installation wizard.
	__15.  Open the Windows Control Panel by selecting Start -> Control Panel or Start -> Settings -> Control Panel depending on your Windows version.
	__16.  If you are using Windows XP or Vista switch to the “Classic View” by clicking the link on the left side of the Control Panel.
	__17.  Double click the Administrative Tools group to open this category.
	__18.  Double click the Services icon to open the list of services.  Accept any Windows security prompts if presented.
	__19.  Right click the following services and select Start from the popup menu if they are not already started:
	__20.  Close the list of services.

	Part 2 -  Define Web Server in WebSphere Admin Console
	__1.  Start your Deployment Manager and Node Agent if they are not running.
	__2.  Log into the admin console.
	__3.  In the navigation pane of the Admin Console select System Administration -> Nodes. 
	__4.  Click on the Add Node button above the list of nodes. 
	__5.  Select the Unmanaged node radio button and press the Next button.
	__6.  Under General Properties, enter the Name as IHSNode and enter the Host Name of the web server machine. This should be the value for the <HOSTNAME> variable that you have written down in the Lab Notes section of the lab guide.  Leave the default for the Platform Type of Windows.
	__7.  Check that your options match that above (with your hostname) and press the OK button.
	__8.  Click the Save link in the messages at the top of the Admin Console and be sure your changes are synchronized with the nodes.
	__9.  In the navigation pane of the Admin Console select Servers → Server Types → Web servers. 
	__10.  Press the New button above the empty list of web servers.
	__11.  On Step 1: Select a node, choose the IHSNode from the drop down list.  Enter the Server name as webserver1.  Once your values match that shown below press the Next button. 
	__12.  In Step 2: Select a Web server template, select the IHS radio button as the web server template and press the Next button.
	__13.  In Step 3: Enter the properties for the new Web server, enter the following information.  Substitute the value of the <IHS_ROOT> variable with the value you had written down in the Directory Paths section in the lab guide.  Remember that <IHS_ROOT> may be different than the default if you are on Windows Vista/2008.
	__14.  Check that your values for the new web server match that shown for the last step. Double check the Service name and the installation locations as these are a common source of error.  Press the Next button when everything matches.
	__15.  In Step 4: Confirm new Web Server, press the Finish button to create the web server. This will take some seconds.
	__16.  Click the Save link in the messages at the top of the Admin Console and be sure your changes are synchronized with the nodes.

	Part 3 -  Configure Virtual Host on Web Server
	__1.  Navigate to the Servers → Server Types → Web Servers section of the admin console.  
	__2.  Click the link for webserver1 from the list.
	__3.  Under the Additional Properties click the link for Configuration File.  If you get an error displaying the configuration file let your instructor know as this likely means there is a problem with your IHS administration password.
	__4.  Scroll to the very end of the file and add a few blank lines.
	__5.  Add the following text exactly as it appears below at the end of the configuration file.  
	__6.  Check that your configuration appears as below and press the OK button.
	__7.  Go back to the list of web servers by navigating to the Servers → Server Types → Web Servers section of the admin console.
	__8.  Check the box next to the webserver1 entry and click the Stop button.  Make sure you get a message about the server stopping.
	__9.  Check the box next to webserver1 and click the Start button.  If you have trouble starting the web server check your configuration file syntax.
	__10.  Logout of the Admin Console.

	Part 4 -  Update Network Setup
	__1.  Open a Windows Explorer window or use one you already have open.
	__2.  Navigate to the Windows Root directory.  This is usually C:\WINNT or C:\WINDOWS.
	__3.  Under this directory find the system32\drivers\etc directory.  In this directory there should be a ‘hosts’ file.
	__4.  Copy the 'hosts' file and rename the copy to something like 'hosts-backup'.  This will ensure you can restore the original if needed.
	__5.  Check that the file is not marked as read only by viewing the file properties.
	__6.  Double-click on the ‘hosts’ file and open it with WordPad.  WordPad is much better to use than other text editors such as Notepad because it saves files without adding a ‘.txt’ extension.
	__7.  If you do not already have a line that starts with the IP address 127.0.0.1 add it. 
	__8.  Add to this line hostnames of localhost and was.myhost.com with spaces between the IP address and each of the hostnames.  The file should be similar to this: 
	__9.  Save the file and close WordPad.
	__10.  Open a Command Prompt window.  You can do this by selecting Start -> Run, entering cmd and then pressing OK.
	__11.  Be sure you can ping the new host name.  Enter the command ping was.myhost.com.  Be sure you don’t get an “unknown host” or “request timed out” error message.  
	__12.  Close the Command Prompt.
	__13.  Open an Internet Explorer window.
	__14.  Open the Internet Options dialog.  This is usually done by selecting Tools -> Internet Options.
	__15.  Click on the Connections tab and click the button for LAN Settings.
	__16.  If your settings are configured to use a proxy server, similar to that shown below, press the Advanced button to configure advanced proxy settings and go to next step. If not click Cancel and skip the next step.
	__17.  Add a local exception for the 'was.myhost.com' address as shown below.  If there are other exceptions in the list be sure to put a semicolon (;) between the addresses.
	__18.  Click any OK buttons to close the Internet Options dialogs.
	__19.  Enter the URL http://was.myhost.com in the address bar of the browser and hit Return. You should see the homepage of the IBM HTTP Server running on your machine.  If you do not see this screen contact your instructor.
	__20.  Close out any extra command prompts, web browsers, or Windows Explorer windows you may have open.

	Part 5 -  Configure Virtual Host in WebSphere
	__1.  Login to the WebSphere Admin Console.
	__2.  In the WebSphere Admin Console expand the Environment navigation group and click the link for Virtual hosts.
	__3.  Click the New button above the list of virtual hosts.
	__4.  Fill in a Name of myhost for the new virtual host and press the Apply button.  Make sure you hit the Apply button as the OK button will not keep you on the same screen.
	__5.  To the right under Additional Properties, click the link for Host Aliases.
	__6.  Right now there are no host aliases.  Click the New button above the empty list of host aliases.
	__7.  Change the Host Name to was.myhost.com and leave the default port of 80.  Click the OK button when you have the properties filled in as below.
	__8.  The new host alias now appears in the list.  
	__9.  Click the New button again above the list of host aliases.
	__10.  Change the Host Name to was.myhost.com and change the port to 443.  Click the OK button when you have the properties filled in as below.
	__11.  Check that you only have the two host aliases shown below.  This will require all requests go through the web server.
	__12.  Click on the Save link in the list of messages near the top of the main Console area.

	Part 6 -  Map Applications to Virtual Host
	__1.  In the navigation area of the Console expand the Applications → Application Types group and click the link for WebSphere enterprise applications.
	__2.  Click the link for the VersionDemoClientApp application.
	__3.  In the list of Web Module Properties on the right, click the link for “Virtual hosts”.
	__4.  Use the drop down next to the VersionDemoClient Web module to select the myhost Virtual host from the list.  Press the OK button when you have the properties set as below.
	__5.  Back on the screen for the VersionDemoClientApp application, click the link for “Manage Modules” in the Modules section of properties.
	__6.  Notice that the Web module is already mapped to the webserver1 web server AND the AppTarget cluster.  This indicates that requests for that application will pass through the webserver1 web server on the way to the AppTarget servers.  This is a critical setting for configuring the web server Plug-in configuration for webserver1.
	__7.  Click on the Save link in the list of messages near the top of the main Console area.
	__8.  Return to the list of enterprise applications and repeat the steps to map the applications to the 'myhost' virtual host for the following applications.  Some of them may be on the second page of applications listed.  Make sure to click the OK button after switching the virtual host for an application.
	__9.  Save the changes and wait for the node synchronization.

	Part 7 -  Generate Plug-in Configuration
	__1.  In the navigation pane of the Admin Console select Servers → Server Types → Web servers.
	__2.  Check the checkbox next to webserver1 and click the Generate Plug-in button.
	__3.  Check the checkbox next to webserver1 and click the Propagate Plug-in button.
	__4.  Make sure that you get a successful message about propagating the plugin config file.  If you do not it is likely that the settings for the web server administration service including port, user ID, and password are not correct.  Contact your instructor to help resolve this.
	__5.  Check the checkbox next to webserver1 and click the Stop button.
	__6.  Check the checkbox next to webserver1 and click the Start button.
	__7.  Make sure that the webserver1 is shown as started.  If it is not contact your instructor.

	Part 8 -  Exhibit Problem
	__1.  In the Admin Console start your Enterprise Service Bus AppTarget server.  If it were already running you must restart it to pick up the changes to the virtual host configuration.  Wait for the server to start completely, be patient, it could take long time.
	__2.  Open a browser and navigate to the following URL.  Note that this URL is slightly different than the previous one you have used as we need to go through the web server.
	__3.  Open the AppTarget SystemOut.log file as you have done before using the Pigtail application.  It is in the <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<hostname>Node01.0 directory.
	__4.  Clear the Pigtail application so you will see only the messages that will be printed from submitting data.
	__5.  Fill in an account ID of '3' and any positive amount and click Deposit.
	__6.  You should get a '500' error and perhaps a browser error page because the service client was not able to invoke the service.
	__7.  Return to the Pigtail application and you should see that the last part of the exception message mentions a '404' error that can't find the service using 'localhost:9080'.

	Part 9 -  Update Client Bindings to Mediation Flow
	__1.  Back in the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__2.  Click the link for the VersionDemoClientApp application.
	__3.  Scroll down and in the list of 'Web Services Properties' on the right, click the link for Service clients.
	__4.  Click the link for the VersionDemoClient.war Module on the right.  If you click the service name on the left it will take you to web service policies which are not being used for this web service.
	__5.  In the list of  'Web Services Properties' on the right, click the link for Web services client bindings.
	__6.  Click the 'Edit' link in the 'Port Information' column.  Make sure you do not click the link in the 'mappings' column.  Either 'Port Information' link will be OK as the names of the two services listed are the same so they will share the same settings.
	__7.  As you can see from the address listed this is why the client did not work.  It was still using 'localhost:9080' which is not the URL the mediation flow is available on now.
	__8.  Change the hostname of the URL so the entire URL is 'http://was.myhost.com/VersionDemoMediationWeb/sca/VersionDemoServiceExport1' without the quotes.  Note the screenshot below does not show the end of the URL but the hostname portion is the only thing you need to update.
	__9.  Once your value is set as shown above press the OK button.  
	__10.  Click the Save link in the messages at the top of the Admin Console.
	__11.  Click the OK button to confirm the node synchronization.

	Part 10 -  Demonstrate Mediation Import Problem
	__1.  Open a browser and navigate to the following URL.  
	__2.  If you do not already have it open, open the AppTarget SystemOut.log file as you have done before using the Pigtail application.
	__3.  Clear the Pigtail application so you will see only the messages that will be printed from submitting data.
	__4.  Fill in an account ID of '3' and any positive amount and click Deposit.
	__5.  You should get a '500' error because the mediation was not able to invoke the imported service.  Notice this time the error appears a little differently.
	__6.  Return to the Pigtail application and notice as one of the first error messages that you get a message about a 'WebGroup/VirtualHost' not being defined to handle the request.  Again this is because it is attempting to invoke the service with 'localhost:9080'.
	__7.  If you look further down in the errors you will see messages about elements not being 'wired' to any other node in the flow.  This is because the mediation flow is attempting to find another way to invoke the service and can't find it and there is no path in the mediation flow for the recovery of the error so it sends the error back to the client application that invoked the mediation flow.

	Part 11 -  Update SCA Import Bindings
	__1.  Expand the Applications group and click on the SCA Modules link.
	__2.  Check the box next to the 'VersionDemoMediation' module and click the Stop button.
	__3.  Click the VersionDemoMediation link to go to the SCA module configuration page.
	__4.  Expand Imports under the Module components heading. 
	__5.  Expand VersionDemoServiceImport1 → Binding and click on the JAX-Web Service link.
	__6.  To the far right of the Target endpoint address, click the Edit button.
	__7.  Change the URL host and port from 'localhost:9080' to 'was.myhost.com' so the URL appears as shown below and click the OK button.
	__8.  Save your changes and wait for the synchronization to occur.
	__9.  Expand the Applications group and click on the SCA Modules link.
	__10.  Check the box next to the 'VersionDemoMediation' module and click the Start button.

	Part 12 -  Test the Updated Configuration
	__1.  Make sure your Enterprise Service Bus instance is running.
	__2.  Open a browser and navigate to the following URL.  
	__3.  If you do not already have it open, open the AppTarget SystemOut.log file as you have done before using the Pigtail application.
	__4.  Clear the Pigtail application so you will see only the messages that will be printed from submitting data.
	__5.  Fill in an account ID of '3' and any positive amount and click Deposit.
	__6.  Check that you get the success message.
	__7.  In the Pigtail application you should see the normal messages output by the mediation flow and service indicating the deposit request made it all the way from the client application, through the mediation flow, and then to the target service.  The requests from each of these applications was sent through the web server.
	__8.  Close the Pigtail application and all the browsers you were using to test.

	Part 13 -  Update Web Service HTTP Endpoint (Optional)
	__1.  Navigate to Applications → Application Types → WebSphere enterprise applications.
	__2.  Click the link for the VersionDemoServiceAppV2 application.  You may need to go to the second page of applications.
	__3.  Scroll down and in the list of 'Web Services Properties' on the right, click the link for Provide HTTP endpoint URL information.
	__4.  Fill in 'http://was.myhost.com' without the quotes for the HTTP URL prefix value next to the module listed.  Note that you can just type the value in directly and you do not need to use the options and Apply button above the settings.
	__5.  Once you settings match those shown above click the OK button.
	__6.  Click the Save link in the messages at the top of the Admin Console and wait for sync.
	__7.  In the "breadcrumb" trail at the top click the link for the VersionDemoServiceAppV2 application.
	__8.  Scroll down and in the list of 'Web Services Properties' on the right, click the link for Publish WSDL files.
	__9.  On the page that appears click the link for the zip file of WSDL files.
	__10.  If prompted to open or save the file, open it with zip file software if possible.  If you can't open it directly save it first and then open the zip file.
	__11.  Expand the folders of the zip file if needed until you see the 'generatedWSDLDir' folder.
	__12.  Open the 'VersionDemoServiceV20.wsdl' file with a text editor like WordPad or Notepad.  If you need to, extract the file first and then open it.
	__13.  Scroll down in the WSDL file and notice at the end that the SOAP address uses a location that starts with 'http://was.myhost.com'.  If we did not set the endpoint URL information for the service the WSDL package to publish would not be useable as it may have an incorrect address.
	__14.  Close the WSDL and the zip file.
	__15.  Logout the admin console and close the browser.

	Part 14 -  Summary

	Lab 15 -  Clustering WebSphere ESB
	Part 1 -  Create A New Clustered Server
	__1.  Start your Deployment Manager and Node Agent if they are not already running.
	__2.  Login to the admin console.
	__3.  In the left pane, select Servers -> Clusters -> WebSphere application server clusters.  
	__4.  Stop the cluster if it is running which will stop the existing server.  Refresh the status of the cluster until it is listed as stopped.
	__5.  Select Servers -> Deployment Environments.
	__6.  Click the link for MyTopology.
	__7.  Click the link for Deployment Topology on the right.
	__8.  On the box under 'Application Deployment Target' for the line of the existing node, change the value to '2' from '1' as shown below. 
	__9.  Once your settings match that shown above click the OK button.  This  will take some time, be patient.
	__10.  Click on the Save link to save the configuration.  You can ignore the message about the deferred configuration because we already completed the configuration of the databases mentioned in one of the first labs.
	__11.  Select Servers -> Server Types -> WebSphere application servers.
	__12.  Notice there are two servers now both on the same node and the only difference in them is the last digit in the name which is an index of the servers of that type on the node.

	Part 2 -  Generate Plug-in Configuration
	__1.  In the navigation pane of the Admin Console select Servers → Server Types → Web servers.
	__2.  Check the checkbox next to webserver1 and click the Generate Plug-in button.
	__3.  Check the checkbox next to webserver1 and click the Propagate Plug-in button.
	__4.  Make sure that you get a successful message about propagating the plugin config file. 
	__5.  Check the checkbox next to webserver1 and click the Stop button.
	__6.  Check the checkbox next to webserver1 and click the Start button.
	__7.  Make sure that the webserver1 is shown as started.  If it is not contact your instructor.

	Part 3 -  Test New Server
	__1.  In the left pane, select Servers -> Server Types -> WebSphere application servers.
	__2.  Make sure that both servers are stopped and stop them if they are not.
	__3.  Check the box next to the second server, the one that ends in '..<node name>.1' and press the Start button.  Wait for the server to start completely, be patient.  Make sure not to start the first server (...Node01.0)  in the list.
	__4.  After the server is started click on the link for the '..<node name>.1' server to see the properties.
	__5.  Scroll down on the right and click the '+' sign next to the 'Ports' link to expand the list of ports.  Note that this server uses port 9081 which is not a default port.  This port is used to prevent conflict with the other server on the same node.
	__6.  From C:\LabFiles, run pigtail.exe
	__7.  Open in pigtail the log file of the new Enterprise Service Bus server.  This should be <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<Node>.1\SystemOut.log.
	__8.  Press the Clear button to remove prior messages.
	__9.  Open a browser and navigate to the following URL.  
	__10.  Fill in an account ID of '3' and any positive amount and click Deposit.
	__11.  Check that you get the success message.
	__12.  In the Pigtail application you should see the normal output of the mediation flow.  This proves the various applications are also working on the new server.
	__13.  Leave the Pigtail window showing the log of the new server open for the next section.

	Part 4 -  Test Failover
	__1.  In the left pane, select Servers -> Clusters -> WebSphere application server clusters. 
	__2.  Check the box next to your cluster and press the Start button.  This will start the other server in the cluster.  
	__3.  You will see the message that the other cluster member is starting. Wait until the server starts.
	__4.  Refresh the cluster status until you get the green bold arrow. If you move your mouse over the icon it will show you the Started message.
	__5.  In the navigation pane of the Admin Console select Servers → Server Types → Web servers.
	__6.  Check the checkbox next to webserver1 and click the Stop button.
	__7.  Check the checkbox next to webserver1 and click the Start button.
	__8.  Navigate to Applications → Application Types → WebSphere enterprise applications.
	__9.  Check the box for the VersionDemoClientApp application and press the Stop button.
	__10.  Click the Refresh button.
	__11.  Check the status of the VersionDemoClientApp application. It should be stopped. 
	__12.  Now, check the box for the VersionDemoClientApp application and press the Start button.
	__13.  Click the Refresh button.
	__14.  Check the status of the VersionDemoClientApp application it should be started.
	__15.  From C:\LabFiles, run pigtail.exe
	__16.  Open in pigtail the log file of the original Enterprise Service Bus instance.  This should be <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<Node>.0\SystemOut.log.
	__17.  Press the Clear button to remove prior messages.
	__18.  Return to the pigtail utility showing the log file of the new Enterprise Service Bus that you left open.  This should be <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<Node>.1\SystemOut.log.
	__19.  Press the Clear button to remove prior messages.
	__20.  Expand the pigtail windows to see the file name in the titlebar.  This will help determine which server is doing what.
	__21.  Open a new browser and navigate to the following URL.  
	__22.  Clear out any messages in pigtail windows if there are any.
	__23.  Fill in an account ID of '3' and any positive amount and click Deposit.
	__24.  In the pigtail window you should see most of the normal output in one of the log files.  If you see messages in both log files keep going and compare notes with other students to see if they are seeing something similar.
	__25.  In the browser you are using to test return to the input page.
	__26.  Fill in an account ID of '12' and a different positive amount than before and click Deposit.
	__27.  You should see the output messages in the same log file as before.
	__28.  Figure out which server has been processing your requests with the web application.  This should be the only server that is showing any messages in the log.  If you have seen messages in both logs figure out which server is showing the 'Called deposit – Amount: xx.x' messages.
	__29.  Return to the Admin Console and select Servers -> Server Types -> WebSphere application servers.  Login again if you have to.
	__30.  Check the box next to the server that was processing your requests and press the Stop button.
	__31.  Click OK if asked to confirm stopping the server.
	__32.  Wait until the status is shown as stopped  in the Server status feedback page and then click OK.
	__33.  Clear out any messages in pigtail windows.
	__34.  Open a new browser to:
	__35.  It may take a second but you should see that the other server starts processing your requests for the web application by looking at the pigtail window for the log.
	__36.  Fill in any account ID except '5' and a different positive amount than before and click Deposit.
	__37.  You should see that the server that is still running is the one with messages in the log from your request.
	__38.  Stop all servers in the AppTarget cluster.  You can leave the deployment manager and node agent running.
	__39.  Logout from the admin console.
	__40.  Close all pigtail windows and browser windows.

	Part 5 -  Review

	Lab 16 -  SIB Messaging Engine HA
	Part 1 -  Configure Messaging Engine Policies
	__1.  Start your Deployment Manager and Node Agent if they are not already running.
	__2.  Log into the admin console.
	__3.  In the left pane, select Servers -> Clusters -> WebSphere application server clusters. 
	__4.  If your cluster is started or partially started then check the box next to your cluster and press the Stop button.  This will make sure all servers are stopped.
	__5.  In the left pane select Service Integration -> Buses.
	__6.  Click on the link for the first bus in the list which should be 'CEI.<cellname>.Bus'.
	__7.  Under the 'Topology' section of additional properties select Bus members.
	__8.  Click on the link for 'MyTopology.AppTarget'.
	__9.  Check the box next to the listed messaging engine and press the Enable policy assistance button.
	__10.  Leave the default setting of 'High availability' and press the Next button.
	__11.  On the Summary page click the Finish button to create the policy.
	__12.  On the page that is displayed next, click the link for Messaging engine policy maintenance.
	__13.  Click the link for the policy that is listed.
	__14.  Enable the 'failback' property and the 'Preferred servers only' property and click the Apply button.  Make sure to use the Apply button to stay on the same page.
	__15.  In the additional properties for the policy click the link for Preferred servers.
	__16.  Select each server from the MyTopology.AppTarget cluster in the list on the left and use the Add button to move the server to the list on the right.  Use the Move up and Move down buttons to make sure the '...Node01.0' server is the first server listed.
	__17.  Once your settings match that shown above click the OK button.
	__18.  You should be back on the main list of policy properties so make sure your 'failback' and 'Preferred servers only' settings are still enabled and save the changes.
	__19.  In the left pane select Service Integration -> Buses.
	__20.  Click on the link for the third bus in the list which should be 'SCA.APPLICATION .<cellname>.Bus'.
	__21.  Follow the previous steps to enable a policy for this bus.  Remember to use the 'High Availability' policy, enable the 'failback' and 'Preferred servers only' properties, and configure both servers on the 'Preferred servers' list with the '..Node01.0' server at the top of the list.
	__22.  Return to the list of buses and click on the link for the fourth bus in the list which should be 'SCA.SYSTEM.<cellname>.Bus'.
	__23.  For the 'SCA.SYSTEM..' bus configure the policy but this time place the '..Node01.1' server at the top of the preferred servers list.
	__24.  Make sure all changes are saved and synchronized with the nodes.

	Part 2 -  Test Preferred Servers
	__1.  In the left pane, select Servers -> Server Types -> WebSphere application servers.
	__2.  Make sure that both servers are stopped and stop them if they are not.
	__3.  Check the box next to the first server, the one that ends in '..<node name>.0' and press the Start button.  Wait for the server to start completely.  Make sure not to start the second server (...Node01.1)  in the list.
	__4.  In the left pane, select Servers -> Clusters -> WebSphere application server clusters. 
	__5.  Click the link for the MyTopology.AppTarget cluster.
	__6.  Click the link for Messaging engines and make sure all messaging engines are started.
	__7.  From C:\LabFiles, run pigtail.exe
	__8.  Open in pigtail the log file of the '..<node name>.0' server.  This should be <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<Node>.0\SystemOut.log.
	__9.  Press the Clear button to remove prior messages.
	__10.  Open a browser and navigate to the following URL.  
	__11.  Fill in an account ID of '3' and any positive amount and click Deposit.
	__12.  In the pigtail window of the '..<node name>.0' server you should see the normal output.
	__13.  Open a second pigtail window and open the log file of the second AppTarget cluster server that is not yet running.  This should be <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<Node>.1\SystemOut.log.
	__14.  Press the Clear button to remove prior messages.
	__15.  Expand the pigtail windows to see the file name in the titlebar.  This will help determine which server is doing what.
	__16.  In the left pane, select Servers -> Server Types -> WebSphere application servers.
	__17.  Check the box next to the second server, the one that ends in '..<node name>.1' and press the Start button. 
	__18.  As the second server is starting, switch to the pigtail window showing the log of the first server.  At some point you should start to see many messages about the messaging engines stopping on the first server and then making connections to the messaging engine from the second server.
	__19.  Use the previous steps to test the service version mediation flow again and confirm it still works.
	__20.  Leave both servers running and the log viewer windows open for the next section.

	Part 3 -  Test Failover
	__1.  Make sure both log viewer windows are cleared of all messages. 
	__2.  In the left pane, select Servers -> Server Types -> WebSphere application servers.
	__3.  Check the box next to the first server, the one that ends in '..<node name>.0' and press the Stop button. 
	__4.  As the first server is stopping, switch to the pigtail window showing the log of the second '..<node name>.1' server.  You should see several messages as the messaging engines that were running on the first server failover to the second server.
	__5.  If you want you can test the service version mediation flow again.  Open a new browser for the application if you do.
	__6.  Stop all servers.
	__7.  Logout from the admin console.
	__8.  Close all pigtail windows and browser windows.
	__9.  Stop the node agent and the deployment manager.

	Part 4 -  Summary




