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Lab 1 - The HelloWorld Class

Time for lab: 40 minutes

In this lab, you will use JDeveloper to write a very simple “Hello World” Java class. 

Part 1 - Start JDeveloper and Explore the IDE

JDeveloper is a Java Integrated Development Environment (IDE).  It is a GUI-driven 
and tool-assisted program that we can use to develop Java code in an effective and 
efficient manner.  While developing Java code does not necessarily require an IDE (all 
the exercises in this lab guide could be achieved by using a simple text editor and the 
command line compiler), using an IDE will greatly simplify development and decrease 
coding time.  As such, we will use JDeveloper to develop all our code in this class.

We will begin by launching JDeveloper and exploring some of its facets.

__1. From the Start menu, select All programs > Oracle Fusion Middleware 11.1.1.2.0 
> JDeveloper Studio 11.1.1.2.0.

__2. The Select Role window will open, leave Default Role selected and click OK.
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__3. If the type associations dialog opens, just click Cancel.

__4. If the Oracle Usage Tracking window open, uncheck the Allow automated usage 
reporting to Oracle check box and click OK.

__5. Close the tip of the day dialog.

Oracle JDeveloper 11g Release 1 will open.
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Part 2 - Create A New Java Project

Before we can create any Java code, we first need to create a Java Project.  A project in 
JDeveloper is essentially a folder for related files. We will create a new project and then 
create our classes in that project.  Later on, if we work on a completely unrelated Java 
class, we could then create a separate, new project and create those classes in there.  This 
helps keep our code environment organized. 

__1. From the menu bar select File > New.

__2. The New Gallery window will open. Expand General and select Applications.

__3. From the right panel, select Java Desktop Application.  

JDeveloper can actually handle many different types of projects, depending on the code 
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that needs to be developed.  In our case, we will create a simple Java project.

__4. Click OK.

__5. Enter MyProjects as Application Name. 

__6. Leave the Default directory.

__7. Click Next.

__8. Enter SimpleProject as Project name.

__9. Leave the other defaults and click Finish.

The new project called SimpleProject will be created and will appear under the 
Application Navigator view.
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__10. We don't need at this moment the files that are opened, from the menu select File > 
Close All. You can also use Ctrl+Shift+F4 to close all open files.

Part 3 - Create A Java Class

Recall that in Java, all code must be contained within a Java class.  Within a class, code is 
typically placed within methods, and any class can have a main method which will serve 
as its “executable” method.  

We will now create a Java class called “HelloWorld” that will have a single main 
method, and this method will simply print out “Hello World” to the console.

__1. Right click on Simple Project and select New...

__2. Expand General and select Java.

__3. In the right, select Java Class.

__4. Click OK.

The Create Java Class window will appear.
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This wizard will create a new Java class for us, and allows us to specify some options on 
the class.   When we click the OK button on this wizard, JDeveloper will generate a new 
Java class according to the options we specify here.  Wizards like this are one of the 
reasons that JDeveloper is so useful; while it would have been possible to generate the 
class ourselves, JDeveloper does it much faster. 

Most importantly, we need to give the class a name.  

Java classes should also belong to a package, for naming convention reasons.  Think of a 
package as a name prefix.  Imagine you are working at an insurance company in a Claims 
department, and you create a class called Account.  However, imagine that another 
developer that you are working with (same company, but in the Billing division) also 
creates a class called Account.  These two classes are completely different, but have the 
same name.  How would we know which one to use?  

The answer is that each class can be placed in a package.  A package is a string of 
characters separated by periods (e.g. com.mycompany.www).  The characters can be 
anything (although typical Java naming convention usually has your company name or 
URL as a part of the package name), and it is pre-pended to the class name.  So a “fully 
qualified” class name is the name of the class preceded by its package.  

In the example above, the Billing department could be assigned a different package name 
from the Claims department; so there could be com.insuranceco.billing.Account and 
com.insuranceco.claims.Account as two separate entities. Even though the classes are 
both called Account, they belong to unique packages, thus allowing for differentiation.  

If the Main Method check box is selected  JDeveloper will automatically generate the 
main method for us. 

In any case, we will use the New Java Class dialog to specify a class name and package 
name for our new class.  

__5. Enter HelloWorld as Name.

__6. Enter com.simple as Package.

__7. Uncheck Constructors fro Superclass check box. We are not creating constructors 
now.

__8. Check the Main Method check box.
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__9. Click OK.

JDeveloper will now generate the Java class and open it in an editor.  

__10. Examine the Application Navigator view. 
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JDeveloper creates the packages under SimpleProject > Application Sources, in this 
case com.simple. 

Beneath the package is our class, HelloWorld.java.  If you double-clicked on it the file 
will open. 

If we created new packages/classes in the project, they would similarly appear here in the 
tree structure.  

__11. Examine the Structure view in the lower left pane.

This view presents a summary of the class that is currently open in the editor. At the 
moment, it is examining the HelloWorld class that belongs to the com.simple package.  

The Structure is also showing that the class currently has one method called 
main(String[]).  We know it is a public method because of the green box next to it, and 
we know that the method is static because of the S.  (We will discuss the concept of static 
and public modifiers later on).

Remember that this view is just a summary of the Java class.  As we add/remove code 
from the actual Java class, this view will update accordingly. 

Turn your attention back to the editor window. Let us examine the actual Java code now. 
All this code has been generated for us by JDeveloper as a convenience.  

Notice that the code is color coded. 

© Web Age Solutions Inc., 2010 10

EVALUATIO
N O

NLY



WA1884 Introduction to Java using Oracle JDeveloper 11g

__12. Look at the first line:

package com.simple;

This the package declaration.  This should always be the first line in a Java class.  This 
line simply states that the following class belongs to the com.simple package.

__13. Examine the next line:

public class HelloWorld {

Here, we declare the class.  We are saying that this is a new class that is called 
HelloWorld and that it is public (we will discuss public modifiers later).  

This is followed by an opening curly brace '{'.  Later, at the end of the file, this should be 
matched with a corresponding closing curly brace '}'.  Locate this closing brace now. 

Any code in between these braces will be considered belonging to this class.  This shows 
the use of braces to indicate scope.  

An unmatched curly brace pair will be flagged as an error and the code will refuse to 
compile. An important part of Java programming is learning how to properly open/close 
scope.  

__14. Examine the next few lines:

public static void main(String[] args) {
HelloWorld helloWorld = new HelloWorld();

}

This is a method.  The first line declares the method.   It is a public method that is static, 
and its return type is void.  It also takes one argument: an array of String objects.  This 
argument is called args.  

Remember that main is a special method.  Since this HelloWorld class has such a main 
method, it can be “run”.  When the class is run, any code inside this method will be 
executed.   Not all classes will necessarily have main methods, however. 

Again, note the use of curly braces to denote where the method begins and ends.  Just like 
the class declaration, any code that is in between these braces will be a part of this 
method.  
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JDeveloper by defaults add code for an empty method created by the wizard. You will 
configure the content of the method in the next steps.

__15. Delete the line:

HelloWorld helloWorld = new HelloWorld();

__16. Replace it with the following line:

System.out.println("Hello World");

What is this line doing?  This line is invoking the println method of System.out and 
passing the string “Hello World” to it.  System.out is an object that is provided by the 
Java language itself and represents the console (the default location where Java outputs 
to; typically the screen). 

println is a method that is provided for System.out and it takes one argument: a String 
object representing what needs to be printed.   (Objects will be discussed in more detail 
in class)

Pay special close attention to the brackets '(' and ')' as well as the trailing semi-colon. 
Every Java statement should end with a semi-colon. 

__17. Your code is complete.  Save your code by going to File > Save or by typing 
Ctrl+S.

__18. From the menu, select View > Status.

This will open the Status view where you will see any error in your code.

If you get red errors marked as 'X', they mean fatal and your code won't compile. Other 
messages like advisory and warnings let you run the code.

If any errors are there right now, go back and double check the code you typed in. 
Correct any mistakes you find. Do not proceed until there are no problems listed here.
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Your code is now complete.  The next step is to run it.

Part 4 - Run the Code

Now that we have completed writing the code, we can run it to see the results.  Running 
Java code implies launching an instance of the Java Virtual Machine (JVM), and then 
loading the appropriate Java class and executing its main method. Fortunately for us, 
JDeveloper makes that simple. 

__1. Right click on the code and select Run.

__2. A new view called Running: SimpleProject.jpr – Log will open. Any text sent to 
the console (e.g. by a call to System.out.println()) will appear in this view.

Voila!  Our Java code has executed and Hello World has been printed. Congratulations. 
You have written and run your first Java class.

Part 5 - Change the Code

Just as an exercise, let us change the code a little. 

Let us now introduce an error to see what sort of error handling features that JDeveloper 
offers. 

__1. Delete the closing " mark from the println statement and save your code.  

What happens?  The compiler detects a problem and market in red.
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__2. Locate the Status view.  

Note that an error has been detected, in this case is shown as "Expecting )". The java 
compiler not always bring the right error like this time, but it shown that something is 
wrong.

__3. Double click on the error, it will move your cursor to the code where JDeveloper 
detected the problem.

__4. Fix the problem by adding the closing " and save the file.

__5. All errors should go away.

__6. Immediately after the existing System.out line, add another line of code as follows. 

System.out.println("Goodbye, cruel world!");

If you are not particularly conscious about using tabs, spacing, and line breaks properly in 
your code (i.e. code style), it can end up looking a little disorganized. Fortunately, 
JDeveloper can format code for us so it looks neatly arranged.  

__7. From the menu, select Source >  Reformat.  

If your code was not “neatly” written, it will be miraculously re-formatted to look 
perfectly neat and organized. Use this every time you want to organize your code.

__8. Save the file.
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__9. Right click on the code and select Run. Do this every time you want to run the class.

Your output should be refreshed.

__10. Close all open files.

Part 6 - Review

In this lab exercise, you explored JDeveloper and coded your first Java class. 

You saw that a Java class has a name and (usually) a package.  It has methods and its 
method/class scope is determined by braces.  You learned how to print something to the 
console by invoking the System.out.println command.

Using JDeveloper , you created a Java project to contain the HelloWorld.java class.  You 
learned about views, and used wizards to generate some code for you.  Finally, you also 
saw some of the error-handling features of JDeveloper.
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Lab 2 - Refining The HelloWorld Class

Time for Lab: 30 minutes

In this lab exercise, you will make a few changes to the HelloWorld class that you 
created in the last lab exercise.  Specifically, you will make it a little more interactive. 
By using the Scanner class, you will actually prompt the user for a name which will then 
be printed back out.

By doing this, you will gain more exposure to both JDeveloper and the Java language. 
You should start to build a better understanding of the syntax of Java.

Part 1 - Edit the Class

Right now, our code gives out a generic “Hello World” greeting, which is a tad on the 
mundane side.  We will edit the class to print out a request for a name, and then use the 
Scanner class to extract input from the user.  A more personalized greeting will then be 
delivered to the user. 

__1. Open HelloWorld.java class.

__2. Remove the lines:

System.out.println("Hello World");
System.out.println("Goodbye, cruel world!");

__3. Then replace it with the following code:

System.out.println("Hello.  Please enter your name:");

Nothing interesting here; we are merely changing the greeting text.

__4. Immediately after that code, enter the following:

java.util.Scanner scan = new java.util.Scanner(System.in);

We need to use the Scanner object, and doing so will require us to declare and initialize 
an instance of the Scanner.  This is precisely what we are doing here. Scanner is a class 
provided by Java that is in the java.util package.

The first part of the statement (java.util.Scanner scan) is the declaration and the 
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second part (new java.util.Scanner(System.in)) is the initialization of the object.  

Note that the initialization uses the new keyword, which implies that we are using a 
constructor on the Scanner class.  This creates a new instance of the class.

Also note that the reference to java.util.Scanner is a fully qualified reference, 
meaning the entire package/class name has been specified. This can be clunky, and we 
will see how to shorten this later in this lab.

Finally, notice that the constructor of the Scanner takes an argument which in this case is 
System.in.  

System.in represents an 'input stream' that Java can obtain input from.  By default, this is 
the keyboard.  

So, put together, this line creates a new instance of a Scanner class, and sets it up to read 
data from the keyboard. 

__5. Immediately after that code, enter the following:

String name = scan.nextLine();

This line declares a new String variable (called name ) and assigns it to the result of a call 
to scan.nextLine().  In effect, when the user types something into the prompt and hits 
Enter, the text that is entered will be placed inside the name variable.

__6. Finally, enter the following line of code:

System.out.println("Hello, " + name);

This is similar to the usual System.out.println code we have used before, but with a twist; 
we are now using a variable inside the print argument. 

The code: "Hello, " + name

Uses the + symbol as a concatenation tool.  Basically, it combines the string "Hello, " 
with name.  A string can be concatenated with another string, and the result is a larger 
string.  It is this larger string that is actually sent to println. 

__7. Our code is done!  Save your code.  There should be no errors. If there are, fix them 
before proceeding.
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Part 2 - Run the Code

Before running the code we need to enable the input in the console.

__1. Right click SimpleProject and select Project Properties.

__2. In the left, select Run/Debug/Profile.

__3. In the right, select Debug and click Edit.

__4. In the left, select Tool Settings.

__5. In the right, check the Allow Program Input check box.

__6. Click OK.

__7. Click OK again to close the Project Properties window.
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We can now execute our more interactive HelloWorld class.  

__8. Run the code as you did before. 

Examine the Log view. This looks the same as before; our standard println commands 
are in use. However, what is different is that you can now enter text.  

__9. Click in the text box and it will display input next to it.

__10. Type your name there followed by the Enter key. 

The Java class will then respond with an appropriate message.

Note that the name you typed is added in the console and is shown in a different color 
followed by the System.out.println("Hello, " + name) code.
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Congratulations!  You have managed to add some interactivity to your simple 
HelloWorld program.

Part 3 - Import Packages

Earlier, when you entered the code to declare the Scanner object, you saw how the fully 
qualified class name was used.  This is because, by default, Java does not “know” about 
the Scanner class.  In order to locate and use it, the fully qualified package name had to 
be provided.  

If you know that the Scanner class will be used multiple times, it may be a good idea to 
import the class.  Importing a class will allow the code to use the class without having to 
fully qualify it.  Typically, a Java program will import all the appropriate classes to 
simplify coding.  We will do this now. 

__1. In the HelloWorld.java class, add the following statement immediately after the 
package statement:

import java.util.Scanner;

__2. Now, change the line where the scanner is initialized to the following:

Scanner scan = new Scanner(System.in);

Note that we no longer need the fully qualified Scanner package name because it has 
been imported.  

__3. Save the code.  There should be no problems.

__4. Run the code.  It should work the same as before.  

__5. Close your class.
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Part 4 - Review

In this lab, you edited your HelloWorld class to add some interactivity.  You saw the use 
of a constructor to initialize a new class instance, and you saw how a string can be 
assigned to the result of a method call.  

You also saw how importing of packages can simplify coding.
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Lab 3 - The Arithmetic Class

Time for Lab: 45 minutes

In this lab, you will build a slightly more complex class than the HelloWorld class; it will 
perform some basic arithmetic operations, and print out the results of the operations.

This lab is designed to give you yet more experience with the Java syntax.  Additionally, 
you will see an if statement to handle branching logic for the first time.

Part 1 - Create The Arithmetic Class

Instead of using the same HelloWorld.java class, we will create an all new class file to 
contain our code.  We will create this class in the same project (SimpleProject) and 
package (com.simple) as our existing class.

__1. Expand the SimpleProject > Application Sources > com.simple. 

__2. Right click on the com.simple package and click New.

__3. Under the Current Project Technologies tab, expand General and select Java.

__4. In the right pane, select Java Class  and click OK.
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This should look familiar; we used the same wizard to create the HelloWorld class. As 
before, we should specify a name for our new class using this wizard.

__5. Enter SimpleArithmetic as Name.

Notice that the Package field is already populated with com.simple saving us the trouble 
of typing it in.  This is because we right-clicked on the com.simple package before 
creating this new class. 

__6. Check the Main Method box. We will want JDeveloper to generate this method for 
us. 

__7. Uncheck the Constructors fro Superclass box.
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__8. Click OK.

JDeveloper will generate the class and open an editor on it.

© Web Age Solutions Inc., 2010 24

EVALUATIO
N O

NLY



WA1884 Introduction to Java using Oracle JDeveloper 11g

Part 2 - Edit the Class

Now we can begin coding the class.  It will be very simple in design; it will first prompt 
the user to enter a number, followed by a second number.  It will then display the results 
of the two numbers being added, subtracted, multiplied and divided by each other.

__1. Locate the main method and delete all the content inside the method. 

__2. Let us start by prompting the user to enter two numbers.  Enter the following code 
inside the main method.

System.out.println("Please enter two numbers:");

__3. Now, set up the Scanner class (as we did in the previous lab) with the following 
code:

Scanner scan = new Scanner(System.in);

__4. Save the file. 

__5. Note that JDeveloper will complain that there are errors on this line.  What is the 
error?  Look at the Status view.

JDeveloper does not understand what the Scanner class is.  This is because we did not 
use the fully qualified name of the class (java.util.Scanner), nor did we import the 
package that the class belongs to.  Fortunately, we can get JDeveloper to fix this for us 
automatically.  

__6. Move your mouse over the error in the code and a popup should appear suggesting 
to import the Scanner class.
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__7. Enter the following import class definition after the package declaration.

import java.util.Scanner;

__8. Save the file and all the errors should go away.

__9. We can continue coding the file.  Immediately following the scan initialization line, 
enter the following:

int x = scan.nextInt();
int y = scan.nextInt();

These two lines are quite straightforward.  They declare int variables (x and y) and assign 
them to the result of scan.nextInt() which will retrieve input from the user.  After 
these lines are executed, x will be the first number that was entered, and y will be the 
second number that was executed. 

__10. We can now print the results of the arithmetic operations. Continue by adding the 
following code:

System.out.println("You entered " + x + " for x");
System.out.println("You entered " + y + " for y");

Here we simply print out what the values entered were.   Note the use of concatenation to 
append the ints to the output string.

__11. Continue by adding the following code. 

System.out.println("The sum of x and y is " + (x+y));

This seems like a simple concatenation, but notice the difference; we are adding an 
operation to the concatenation!  The expression (x+y) will be evaluated first since it is in 
parentheses; that evaluated sum will then be concatenated to the string and println-ed
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Note that since x and y are both ints, Java understands that (x+y)  should invoke the 
addition operation.

__12. Continue with the subtraction and multiplication results.

System.out.println("The difference of x and y is " + (x-y));
System.out.println("The product of x and y is " + (x*y));

These work in the same way as before.  (Note that clever use of the copy-and-paste 
mechanism of JDeveloper can greatly speed up typing those lines...)

__13. Now, things become a little more complex.  We have yet to handle division but 
there is a problem. What happens if the user has entered 0 for the value of y?  Java will 
complain with a “division by 0” error.  We should prevent this from ever happening and 
we can do that by entering the following code:

if(y == 0) {
System.out.println("Cannot divide by 0.");

} else {
System.out.println("The division of x and y is " + (x / y));

}

Here, we see a traditional if-else statement.  The syntax can seem confusing at first (those 
pesky curly braces are everywhere), but is actually quite simple.  

Immediately following the if keyword is the test condition (which is in parenthesis).  In 
our case, we test to see if y is equal to 0.  (Notice that the condition uses a double equal 
sign; == is a test for equivalence; putting a single equal sign in there would imply that we 
are assigning the value of y to 0!)

Immediately after the condition, we open a curly brace and put our true clause code in. 
This is the code that will be executed if the condition evaluates to true.  In our case, we 
simply print out a message saying that division by 0 is not possible. This clause is open 
and terminated using the traditional curly braces { } 

After the true clause, we use the keyword else to begin the false clause.  The code 
contained within this set of curly braces will be executed in the event that the condition 
does not evaluate to true. In this case, if y is not equal to zero, we simply print out the 
corresponding division result.

__14. We are done.  Save the code and make sure there are no errors.
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Part 3 - Run the Code

__1. Right click on the code and select Run. Remember this since you will do it 
frequently.

__2. In the Log view, enter a positive non-zero numbers in the Input field following by 
the enter key.  

__3. Enter a second positive non-zero numbers in the Input field following by the enter 
key.  

Make sure you get expected results!

__4. Run it again and this time try entering a zero for the second number.  Make sure the 
appropriate “Cannot divide by 0” message is displayed.

Part 4 - Break the Application

__1. Run again the class.

__2. This time try entering a non-number (like characters and punctuation marks).  What 
happens? 
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A little on the ugly side.  Java has encountered a problem and is throwing an exception. 
Because the scan was expecting an int, entering character data instead has caused the 
scan object to complain.  The text in red is an exception – which is simply Java's way of 
telling you that something has gone wrong.  Exceptions will be discussed in more detail 
later on. 

This has happened because our code does not check for all error conditions – such as 
entering character data instead of numeric data.  Currently, our code does check for one 
error condition: division by zero.  

Knowing this, you could go back to the code and write if statements to check to see if x 
and y are indeed numeric values; doing so would be good error handling practice. 
Roughly sketch out (but do not code) what the if statements might look like if you were, 
in fact handling these types of errors. 

__3. From the menu, select File > Close all.

Part 5 - Review

In this exercise, you wrote another Java class and saw more detail of how to use Java 
statements, including arithmetic operations.  Finally, you saw how to use an if statement 
to control logical flow in Java code.
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	Lab 1 -  The HelloWorld Class
	Part 1 -  Start JDeveloper and Explore the IDE
	__1.  From the Start menu, select All programs > Oracle Fusion Middleware 11.1.1.2.0 > JDeveloper Studio 11.1.1.2.0.
	__2.  The Select Role window will open, leave Default Role selected and click OK.
	__3.  If the type associations dialog opens, just click Cancel.
	__4.  If the Oracle Usage Tracking window open, uncheck the Allow automated usage reporting to Oracle check box and click OK.
	__5.  Close the tip of the day dialog.

	Part 2 -  Create A New Java Project
	__1.  From the menu bar select File > New.
	__2.  The New Gallery window will open. Expand General and select Applications.
	__3.  From the right panel, select Java Desktop Application.  
	__4.  Click OK.
	__5.  Enter MyProjects as Application Name. 
	__6.  Leave the Default directory.
	__7.  Click Next.
	__8.  Enter SimpleProject as Project name.
	__9.  Leave the other defaults and click Finish.
	__10.  We don't need at this moment the files that are opened, from the menu select File >  Close All. You can also use Ctrl+Shift+F4 to close all open files.

	Part 3 -  Create A Java Class
	__1.  Right click on Simple Project and select New...
	__2.  Expand General and select Java.
	__3.  In the right, select Java Class.
	__4.  Click OK.
	__5.  Enter HelloWorld as Name.
	__6.  Enter com.simple as Package.
	__7.  Uncheck Constructors fro Superclass check box. We are not creating constructors now.
	__8.  Check the Main Method check box.
	__9.  Click OK.
	__10.  Examine the Application Navigator view. 
	__11.  Examine the Structure view in the lower left pane.
	__12.  Look at the first line:
	This the package declaration.  This should always be the first line in a Java class.  This line simply states that the following class belongs to the com.simple package.
	__13.  Examine the next line:
	Here, we declare the class.  We are saying that this is a new class that is called HelloWorld and that it is public (we will discuss public modifiers later).  
	This is followed by an opening curly brace '{'.  Later, at the end of the file, this should be matched with a corresponding closing curly brace '}'.  Locate this closing brace now. 
	Any code in between these braces will be considered belonging to this class.  This shows the use of braces to indicate scope.  
	An unmatched curly brace pair will be flagged as an error and the code will refuse to compile. An important part of Java programming is learning how to properly open/close scope.  
	__14.  Examine the next few lines:
	__15.  Delete the line:
	__16.  Replace it with the following line:
	__17.  Your code is complete.  Save your code by going to File > Save or by typing Ctrl+S.
	__18.  From the menu, select View > Status.

	Part 4 -  Run the Code
	__1.  Right click on the code and select Run.
	__2.  A new view called Running: SimpleProject.jpr – Log will open. Any text sent to the console (e.g. by a call to System.out.println()) will appear in this view.

	Part 5 -  Change the Code
	__1.  Delete the closing " mark from the println statement and save your code.  
	__2.  Locate the Status view.  
	__3.  Double click on the error, it will move your cursor to the code where JDeveloper detected the problem.
	__4.  Fix the problem by adding the closing " and save the file.
	__5.  All errors should go away.
	__6.  Immediately after the existing System.out line, add another line of code as follows. 
	__7.  From the menu, select Source >  Reformat.  
	__8.  Save the file.
	__9.  Right click on the code and select Run. Do this every time you want to run the class.
	__10.  Close all open files.

	Part 6 -  Review

	Lab 2 -  Refining The HelloWorld Class
	Time for Lab: 30 minutes
	Part 1 -  Edit the Class
	__1.  Open HelloWorld.java class.
	__2.  Remove the lines:
	__3.  Then replace it with the following code:
	Nothing interesting here; we are merely changing the greeting text.
	__4.  Immediately after that code, enter the following:
	__5.  Immediately after that code, enter the following:
	__6.  Finally, enter the following line of code:
	__7.  Our code is done!  Save your code.  There should be no errors. If there are, fix them before proceeding.

	Part 2 -  Run the Code
	__1.  Right click SimpleProject and select Project Properties.
	__2.  In the left, select Run/Debug/Profile.
	__3.  In the right, select Debug and click Edit.
	__4.  In the left, select Tool Settings.
	__5.  In the right, check the Allow Program Input check box.
	__6.  Click OK.
	__7.  Click OK again to close the Project Properties window.
	__8.  Run the code as you did before. 
	__9.  Click in the text box and it will display input next to it.
	__10.  Type your name there followed by the Enter key. 

	Part 3 -  Import Packages
	__1.  In the HelloWorld.java class, add the following statement immediately after the package statement:
	__2.  Now, change the line where the scanner is initialized to the following:
	__3.  Save the code.  There should be no problems.
	__4.  Run the code.  It should work the same as before.  
	__5.  Close your class.

	Part 4 -  Review

	Lab 3 -  The Arithmetic Class
	Time for Lab: 45 minutes
	Part 1 -  Create The Arithmetic Class
	__1.  Expand the SimpleProject > Application Sources > com.simple. 
	__2.  Right click on the com.simple package and click New.
	__3.  Under the Current Project Technologies tab, expand General and select Java.
	__4.  In the right pane, select Java Class  and click OK.
	__5.  Enter SimpleArithmetic as Name.
	__6.  Check the Main Method box. We will want JDeveloper to generate this method for us. 
	__7.  Uncheck the Constructors fro Superclass box.
	__8.  Click OK.

	Part 2 -  Edit the Class
	__1.  Locate the main method and delete all the content inside the method. 
	__2.  Let us start by prompting the user to enter two numbers.  Enter the following code inside the main method.
	__3.  Now, set up the Scanner class (as we did in the previous lab) with the following code:
	__4.  Save the file. 
	__5.  Note that JDeveloper will complain that there are errors on this line.  What is the error?  Look at the Status view.
	__6.  Move your mouse over the error in the code and a popup should appear suggesting to import the Scanner class.
	__7.  Enter the following import class definition after the package declaration.
	__8.  Save the file and all the errors should go away.
	__9.  We can continue coding the file.  Immediately following the scan initialization line, enter the following:
	__10.  We can now print the results of the arithmetic operations. Continue by adding the following code:
	__11.  Continue by adding the following code. 
	__12.  Continue with the subtraction and multiplication results.
	__13.  Now, things become a little more complex.  We have yet to handle division but there is a problem. What happens if the user has entered 0 for the value of y?  Java will complain with a “division by 0” error.  We should prevent this from ever happening and we can do that by entering the following code:
	__14.  We are done.  Save the code and make sure there are no errors.

	Part 3 -  Run the Code
	__1.  Right click on the code and select Run. Remember this since you will do it frequently.
	__2.  In the Log view, enter a positive non-zero numbers in the Input field following by the enter key.  
	__3.  Enter a second positive non-zero numbers in the Input field following by the enter key.  
	__4.  Run it again and this time try entering a zero for the second number.  Make sure the appropriate “Cannot divide by 0” message is displayed.

	Part 4 -  Break the Application
	__1.  Run again the class.
	__2.  This time try entering a non-number (like characters and punctuation marks).  What happens? 
	__3.  From the menu, select File > Close all.

	Part 5 -  Review

	Lab 4 -  Creating A Simple Object
	Part 1 -  Create A New Project
	__1.  From the menu, select File > New.
	__2.  In the left Expand General > Projects.
	__3.  In the right, select Java Project.
	__4.  Click OK.
	__5.  Enter BankAccountProject as Project name.
	__6.  Click Finish.

	Part 2 -  Create the BankAccount Class
	__1.  Right click on BankAccountProject and select New.
	__2.  In the left select Java under General.
	__3.  In the right, select Java Class  and click OK.
	__4.  For the Name, enter BankAccount
	__5.  We will create a new package.  For the Package, enter com.simple.account
	__6.  This class will not have a main method as it is strictly an domain object class, so make sure the box for Main Method  is left unchecked.
	__7.  Uncheck the Constructors from Superclass box.
	__8.  Click OK.
	__9.  Add the following field declarations, after the opening '{', following the class declaration.
	__10.  Save your code.  There should be no errors. It should look like this:
	__11.  In the left lower corner of the screen, the Structure view should be open. If it is not open, from the menu, select View >  Structure.
	__12.  Double click on one of the fields in the Structure view.  
	__13.  Enter the following code after the field declarations.
	__14.  Save the code.  There should be no errors.
	__15.  Examine the Structure view.  Notice that the method has been added to it.  What happens when you double click on it? 

	Part 3 -  Create the Tester Class
	__1.  Right click on BankAccountProject and select New.
	__2.  In the left select Java under General.
	__3.  In the right, select Java Class  and click OK.
	__4.  Enter BankAccountTester as name.
	__5.  Enter com.simple.test as package.
	__6.  Check the Main Method box.
	__7.  Uncheck the Constructors from Superclass box.
	__8.  Click OK.
	__9.  Remove the content inside the main method.
	__10.  Now, let us begin coding.  In the main method, add the following code:
	__11.  From the menu, select Source > Organize imports.
	__12.  Save the file.  There should be no errors.
	__13.  Immediately following the instantiation code, add the following statement:
	__14.  Set the state of the other two fields by adding the following two lines.
	__15.  Add the following code immediately after the setting of the balance.
	__16.  Save the code.
	__17.  Run this code as you did it with other classes.
	__18.  Immediately before the first println statements, insert the following:
	__19.  Save the file. 
	__20.  Test this by running the class again.

	Part 4 -  Review

	Lab 5 -  Getters and Setters
	Time for Lab: 30 minutes
	Part 1 -  Problems of Direct Method Access
	__1.  Open the BankAccount.java class.
	__2.  Change the modifiers to private as shown below.
	__3.  Save the file.  There should be no errors in the BankAccount class. 
	__4.  Now open the BankAccountTester.java file and look at the Status view.
	__5.  Open the BankAccount.java class.
	__6.  Add the following method, after the closing curly brace } of the deposit method.
	__7.  Save the file. 
	__8.  Switch back to BankAccountTester.java.  
	__9.  Locate the line: 
	__10.  Then change it to:
	__11.  Switch back to BankAccount.java and add the following method, after the previous set method:
	__12.  Save the file.
	__13.  Switch back to the BankAccountTester class and locate the line:
	__14.  Change it to the following:
	__15.  Save the file.  
	__16.  Switch back to BankAccount.java 
	__17.  Add the following two methods to the class:
	__18.  Save the file.  
	__19.  Switch back to the BankAccountTester class. We will change it to use the new get and set methods.  
	__20.  Locate the line: 
	__21.  Change it to:
	__22.  Now, locate the line:
	__23.  Change it to:
	__24.  Save the file.  Two more errors should go away. 

	Part 2 -  Generating Accessors
	__1.  Switch back to BankAccount.java and examine the Structure view. 
	__2.  Right click on balance: float and select Generate Accessors...
	__3.  Notice that it has located our balance field and is preparing to generate the get and set methods for it.  Click OK.
	__4.  Save the file.  There should be no errors.  
	__5.  Switch back to the BankAccountTester.java and change the code to use the new getter and setter methods for the balance of you did it in the previous part.
	__6.  Save the file. There should be no errors.
	__7.  Run BankAccountTester.  It should look the same as before. 

	Part 3 -  Accessor Error Handling 
	__1.  Open BankAccount.java.   
	__2.  Change the code for the setBalance(float balance) method to the following:
	__3.  Save the file.  There should be no error. 
	__4.  Switch back to the BankAccountTester class.
	__5.  Let's test this.  Change the setBalance() amount to be -100f 
	__6.  Save the class.
	__7.  Now run the code.  What do you see?
	__8.  Change the value of the setBalance back to the original amount (100f) and save the file.
	__9.  Run the code again. It should show again 150 as Balance.

	Part 4 -  Review

	Lab 6 -  Using Constructors
	Part 1 -  Creating Another Instance Of The BankAccount
	__1.  Open BankAccountTester.java.  
	__2.  Recall that in this code, we are only using one instance a BankAccount; we know this because we only declare a single instance (called account) and initialize it once.
	__3.  Add the following code inside the main method, after the println statements.
	__4.  Now, set some data on that instance.
	__5.  Immediately following this, create yet another instance of the account, and set its data as follows:
	__6.  Save the code. There should be no errors.

	Part 2 -  Create The New Constructor
	__1.  Open the BankAccount.java class.  
	__2.  Add the following method right after the field declarations.
	__3.  Save the code.  There should be no errors on the BankAccount class.  
	__4.  However, open the BankAccountTester class and you will get some errors.
	__5.  Delete the following code:
	__6.  Replace it with the much simpler:
	__7.  Use this constructor elsewhere in the code.  Delete this code:
	__8.  Replace it with:
	__9.  Finally, delete this code: 
	__10.  Replace it with this code: 
	__11.  Save the file. There should be no errors.
	__12.  Your method has now been greatly streamlined.  It should look like the following:
	__13.  Run the code.  It shouldn't look any different, but it is definitely cleaner in terms of style.
	__14.  Look in the Status view, you will see there are some warnings.

	Part 3 -  Object Instances
	__1.  Go back to the BankAccountTester.java class and add some println statements following the construction of account2 and account3, like the following:
	__2.  Save the class.
	__3.  Run again the class.  

	Part 4 -  Static Fields
	__1.  Open the BankAccount class.  
	__2.  Add a new field after the other field declarations as follows:
	__3.  Generate accessors for this field as you did in a previous lab. (Under the Structure view, right click on interestRate and select Generate Accessors, then click OK.)
	__4.  Save the file. There should be no errors.
	__5.  Go back to the BankAccountTester.java.  
	__6.  Let's try out these fields. We will set the field on account2.  Locate the following line:
	__7.  Immediately after, insert the following line:
	We are simply setting the field value on the instance account2.
	__8.  Now, at the end of the method, after the println of account3's balance, add the following 2 lines of code. 
	__9.  Save the file.
	__10.  Run the class. 
	__11.  In BankAccount.java, locate the field definition for interestRate and change it to the following:
	__12.  Also change the setInterestRate method and change it as follows:
	__13.  Save the class.
	__14.  Now, let us test this.  Go back to the BankAccountTester class and run the code again.  What do you see?
	__15.  Close all open files.

	Part 5 -  Review

	Lab 7 -  Looping 
	Part 1 -  Create the Class
	__1.  Inside the SimpleProject project, create a new Java Class with the following parameters:
	__2.  Your code should look like this:
	__3.  Delete the content in the Main method.
	__4.  Add the following statement immediately after the package statement:
	__5.  Enter the following code in the main method:
	__6.  Save the file.  There should be no errors.
	__7.  Add the following code into the body of the for loop.
	__8.  Save the code.  There should be no errors. 
	__9.  Right click on the code and select Run.
	__10.  The console shows the message and the input field is available.
	__11.  Enter a number in the Input field and hit enter.
	__12.  Keep entering numbers until the program completes.
	__13.  Run the class again and this time enter a non-numeric value for the first one (e.g. some character data).

	Part 2 -  Break and Continue
	__1.  Within the loop, right before the line:
	__2.  Enter the following:
	__3.  Save the code.  There should be no errors.
	__4.  Test the code by running the program again.  Enter 10 for the first number, and -1 for all the remaining others.  
	__5.  Insert the following code immediately before the line   sum += input;  and right after the last if statement:
	__6.  Save the code.  There should be no errors.
	__7.  Run the code.  
	__8.  This time enter one integer, one negative number and then 0.
	__9.  Close all open files.

	Part 3 -  Review

	Lab 8 -  Arrays
	Part 1 -  Object Arrays
	__1.  Inside BankAccountProject project, create a new Java Class with the following parameters:
	__2.  Your code should look like this:
	__3.  Delete the content inside the Main method.
	__4.  Add the following code to the main method.
	__5.  Continue by adding the following code in the main method:
	__6.  Add the following two lines of code:
	__7.  Save and run the code.  There should be no errors – but no output either.  That is fine for now.  
	__8.  Now, let us try something else.  Add the following line of code:
	__9.  Save and run the code.  What happens?
	__10.  Delete the offending line of code.  
	__11.  Add the following code: 
	__12.  Save and run the code. As expected:
	__13.  Now add the following code:
	__14.  Save and run the code.
	__15.  Finally, let us try something different.  Add the following code:
	__16.  Save and run the code. What happens?

	Part 2 -  Add An Array To the SimpleAdder
	__1.  Open the SimpleAdder.java code that you wrote in a previous lab from the SimpleProject project.  
	__2.  In the SimpleAdder.java main method, locate the following line:
	__3.  Immediately after this line, add the following code:
	__4.  Inside the loop body, locate the line:
	__5.  Immediately after this line, add the following code:
	__6.  Locate the line:
	__7.  And enter the following code immediately before it:
	__8.  Save the code.  There should be no errors. 
	__9.  Run the code.
	__10.  Enter 10 positive integers.
	__11.  Close all open files.

	Part 3 -  Review

	Lab 9 -  Subclasses
	Part 1 -  Create the SavingsAccount Class
	__1.  Right click BankAccountProject and select New.
	__2.  Expand General, select Java.
	__3.  In the right, select Java Class.
	__4.  Click OK.
	__5.  Enter SavingsAccount as name.
	__6.  Enter com.simple.account as package.
	__7.  Enter com.simple.account.BankAccount as Extends.
	__8.  Do not check the Main Method box.
	__9.  Uncheck the Constructors from Superclass box.
	__10.  Click OK.
	__11.  Right click anywhere in the source and select Source > Generate Constructors from Superclass
	__12.  Click OK.
	__13.  Save the file.  There should be no errors.

	Part 2 -  Test the New Subclass
	__1.  Open BankAccountTester.java.  
	__2.  Add the following code at the end of the main method.
	__3.  A problem appears for an instance and then disapear, JDeveloper found and added the import that is required. Go to the top of the file and look at the imports section. You may need to expand it and you will see the class added.
	__4.  Save the class, there should be no errors.
	__5.  Now find to following imports and delete them:
	__6.  Add the import following import:
	__7.  Save the class, there should be no errors.
	__8.  Add the following code after the instantiation of the SavingsAccount. 
	__9.  Save the file and run the code. 

	Part 3 -  Adding A Method
	__1.  Open SavingsAccount.java
	__2.  Before the closing curly brace } for the class, add the following method:
	__3.  Save the class.  There should be no errors. 

	Part 4 -  Adding The Field
	__1.  Open SavingsAccount.java.  
	__2.  Add the following field declaration, right after the class declaration, before the constructor:
	__3.  Change the payInterest() method to check the minimum balance before updating the balance, as follows in bold:
	__4.  Save the file.  There should no errors.
	__5.  In this Structure view, right click on SavingsAccount and select View Type Hierarchy. The Hierarchy view appears.
	__6.  Close the Hierarchy view.  We will not be needing it.

	Part 5 -  Test the Code
	__1.  Open the BankAccountTester.java class.
	__2.  Add the following code to the main method, immediately after the println showing the sAccount's balance.
	__3.  Save and run the code. 
	__4.  Now, let us try setting the balance below the minimum.  Locate the line where the constructor is called for the SavingsAccount and change it to: 
	__5.  Save and run the code. 
	__6.  Add the following code to the main method:
	__7.  Delete the line you just entered.  
	__8.  Save the file.  There should no errors.
	__9.  Close all open files.

	Part 6 -  Review

	Lab 10 -  Method Overriding
	Part 1 -  Adding A print Method
	__1.  Open the BankAccountTester.java class.  
	__2.  Open BankAccount.java.  
	__3.  Add the following method to the class.
	__4.  Save the class.
	__5.  Open BankAccountTester.java.  
	__6.  Right now, it is a mess of mostly println statements.  Let us start clean.  Delete all the code inside the main method except for all the constructor calls.  
	__7.  When you are done, it should look like this:
	__8.  Let us now test our new print method.  Add the following code to the main method after the constructors calls:
	__9.  Save and run the code.
	__10.  Let us see if the print statement works on our SavingsAccount.  Add the following code:
	__11.  Save and run the code.

	Part 2 -  Printing the SavingsAccount
	__1.  Open SavingsAccount.java.
	__2.  Add the following method to the class:
	__3.  Save the code.  There should be no errors. 
	__4.  Switch back to the BankAccountTester.  
	__5.  Without changing any code, run the class.  
	__6.  Go back to SavingsAccount.java.  
	__7.  In the print method, add the following bolded line: 
	__8.  Save the class.
	__9.  Switch back to and then run the BankAccountTester.

	Part 3 -  Using System.out.println
	__1.  Open BankAccountTester.java.  
	__2.  Add the following line of code at the end main method.
	__3.  Save and run the code.  What do you see?
	__4.  Open BankAccount.java.  
	__5.  Right click anywhere on the code editor and select Source | Override Methods.
	__6.  Check the box for toString().
	__7.  Click OK. 
	__8.  Delete the code inside this method, and change it to the following:
	__9.  Save the code.  There should be  no errors.
	__10.  Let us test the code.  Switch back to BankAccountTester.  
	__11.  Delete all the calls to print(), but leave the System.out.println() line.  
	__12.  Then, add the following lines:
	__13.  Save and run the code. What do you see?
	__14.  Add the following line to the main method of the BankAccountTester class.  
	__15.  Save the class.
	__16.  Run the class.

	Part 4 -  Override toString In the SavingsAccount
	__1.  Open SavingsAccount.java.  
	__2.  Right click anywhere on the code editor and select Source > Override Methods.
	__3.  Scroll down in the list and check toString().  
	__4.  Click OK.
	__5.  Change the method to look like the following:
	__6.  Save the code.  There should be no problems.
	__7.  Go back to the BankAccountTester and run the code.  You should see the following:
	__8.  Close all.

	Part 5 -  Review

	Lab 11 -  Exception Handling
	Part 1 -  The Try-Catch Block
	__1.  Open SimpleAdder.java.  
	__2.  Run it and enter a String instead of a number.  What is returned?
	__3.  In SimpleAdder.java locate the line
	__4.  Delete it and replace it with the following code:
	__5.  Save and run the code.  
	__6.  Again, enter a String instead of a number. What do you see?

	Part 2 -  Creating Your Own Exception
	__1.  Right click on BankAccountProject and select New.
	__2.  Select the Java Class and click OK.
	__3.  Set the Name to be InsufficientFundsException
	__4.  Set the Package to be com.simple.account
	__5.  Set the Superclass to be java.lang.Exception
	__6.  Uncheck Main method box.
	__7.  Check Constructors from superclass box.
	__8.  Click OK.
	__9.  Open BankAccount.java.
	__10.  Add the following method to the class:
	__11.  Save the code.  There should be no errors.
	__12.  Open BankAccountTester.java.  
	__13.  Add the following code at the end of the main method. 
	__14.  Look at the Status view. What is happening? 
	__15.  Left click on the exclamation in the margin next to this line and select Surround With Try/Catch.  
	__16.  Inside the catch block, enter the following:
	__17.  Save the file.  There should be no errors.

	Part 3 -  Run the Code and Trigger the Exception
	__1.  Let us see what this code now does, run the class.  
	__2.  Locate the line:
	__3.  Change it to:
	This should trigger a defect, which our code should catch. 
	__4.  Save and run the code.
	__5.  Close all open files.

	Part 4 -  Review

	Lab 12 -  Interfaces
	Part 1 -  Create the AccountManager Class
	__1.  Create a new class in the BankAccountProject and call the class AccountManager and it should belong to the package com.simple.account.  It should not have a main method nor contructors. 
	__2.  Add a field called account of type BankAccount as follows:
	__3.  Generate get/set methods for this field.
	__4.  Now, add the deposit/withdraw methods. 
	__5.  Save the code.  There should be no errors. 

	Part 2 -  Test the AccountManager
	__1.  In the BankAccountProject, create a class called AccountManagerTester that belongs to the package com.simple.test and it should have a main method but not constructors. 
	__2.  Delete in code in the main method.
	__3.  Add the following code to the main method.
	__4.  After some moments JDeveloper will import the classes required.
	__5.  Continue adding the following code:
	__6.  Add the following code to test this.
	__7.  After some moments JDeveloper will import the classes required.
	__8.  Finally, let's add some output.
	__9.  Save the class. There should be no errors.
	__10.  Run the code. The output should be:

	Part 3 -  Changing The AccountManager
	__1.  Open the AccountManagerTester.java.  
	__2.  Locate the line:
	__3.  Change it to:
	__4.  After some moments JDeveloper will import the classes required.
	__5.  Save the code.  There should be no errors.  
	__6.  Run the code.  The output returns:

	Part 4 -  Create the BusinessAccount Class
	__1.  In the BankAccountProject, create a new class called BusinessAccount, belonging to package com.simple.account. Leave it as extending java.lang.Object and do not create a main method for it nor constructors.
	__2.  Add the following fields:
	__3.  Generate accessors for these fields.  
	__4.  Right click on the code editor and select Source > Generate Constructor from  Fields.
	__5.  In the Generate Constructor from Fields window, click  Select All.
	__6.  Click OK.
	__7.  Add the toString method as follows:
	__8.  Add the deposit method as follows:
	__9.  Finally, add the withdraw methods as follows: 
	__10.  Save the code.  There should be no errors. 

	Part 5 -  Managing the BusinessAccount
	__1.  Open AccountManagerTester.java.  
	__2.  Locate the line:
	__3.  Change it to the following:
	__4.  JDeveloper will organize imports.  
	__5.  Save the code.  Look at the Problems view. There should be one error:

	Part 6 -  Examining Interfaces
	__1.  In the Package Explorer, right click on BankAccountProject and select New.
	__2.  Select Java under General and select Java Interface.
	__3.  Click OK. 
	__4.  For the Name, specify Account
	__5.  For the Package, specify com.simple.account
	__6.  Click OK.
	__7.  Add the following two method declaration to the interface.
	__8.  Save the code.  There should be no errors in this class. 
	Our contract is complete.  We can now state that our classes (BankAccount and BusinessAccount) conform to this contract.  
	__9.  Open BankAccount.java and change the class declaration to the following:
	__10.  Save the code.  
	__11.  Now, open BusinessAccount.java.  As before, change the class declaration to the following:
	__12.  Save the code.  
	__13.  In the BusinessAccount.java file, locate the method deposit() and rename it to something else (like deposit2()). 
	__14.  Look at  the Status view, a new error appears.  
	__15.  Undo the change (i.e. rename the method back to deposit()).
	__16.  Save the file.  This error should go away.

	Part 7 -  Update the AccountManager
	__1.  Open AccountManager.java.
	__2.  Locate the field declaration:
	__3.  Change it to use the interface as follows:
	__4.  Now, locate the code for the getter method:
	__5.  Change its return type as follows:
	__6.  Finally, locate the code for the setter method:
	__7.  Change the parameter declaration as follows:
	__8.  Save the file.  There should be no errors.  
	__9.  Switch back to the AccountManagerTester.  There should be no errors here.  
	__10.  Run the code. 
	__11.  Close all.

	Part 8 -  Review

	Lab 13 -  Collections
	Part 1 -  Revise the AccountManager
	__1.  Open AccountManager.java.  
	__2.  Locate the line 
	__3.  Delete it. In its place, add the following code.
	__4.  Delete the getAccount() and setAccount() methods.  They will not be used any more. 
	__5.  We now need a method to add an account to the HashMap.   Add the following method.
	__6.  There is still an error on this method. Click the bulb in the error line in the left margin, a box appears.
	__7.  In the white box, click Create Method 'getAccountID'
	__8.  A code editor will open on the Account interface.  Notice a new method has been added.
	__9.  The interface should be saved, if not save it.
	__10.  Switch back to the AccountManager.java class.  
	__11.  Add the following method:
	__12.  Now we can tackle the deposit and withdraw methods.  Locate the two following methods:
	__13.  Delete the methods.
	__14.  Now, add the following two methods:
	__15.  Add the following method:
	__16.  Our code is done.  Save it.  There should be no errors.  

	Part 2 -  Test the New AccountManager
	__1.  Open AccountManagerTester.java.  
	__2.  Locate the main method and delete all the code inside it.  We will write new test code from scratch.
	__3.  In the now empty main method, add the following code.
	__4.  Add the following code:
	__5.  Now let us take a look at the contents of the AccountManager.  Add the following code:
	__6.  Save the code.  There should be no errors.  
	__7.  Run the code.  You should see some interesting results.
	__8.  The entire result is:
	__9.  In AccountManagerTester, delete the line:
	__10.  In its place, add the code:
	__11.  Add the following code:
	__12.  Save the code.  There should be no errors. 
	__13.  Run the code. 
	__14.  Close all.

	Part 3 -  Review

	Lab 14 -  Writing To A File
	Part 1 -  Serialization
	__1.  Open BusinessAccount.java.  
	__2.  Change the class declaration as follows:
	__3.  An error will appear, press ALT+Enter.
	__4.  In the popup that appears, double click Serializable (java.io)
	__5.  The import will be added.
	__6.  Save the file.  There should be no errors.  
	__7.  Open BankAccount.java. 
	__8.  As before, change the class declaration as follows:
	__9.  As before, add the  java.io.Serializable class.
	__10.  Save the file.  There should be no errors.

	Part 2 -  Add the Write/Read Methods
	__1.  Open AccountManager.java. 
	__2.  Add the following method to the class.
	__3.  JDeveloper will import some classes but will complain about other. Press ALT+Enter.
	__4.  Double click  OutputStream (java.io)
	__5.  JDeveloper will import the rest of the required classes.
	__6.  Your import section should look like this:
	__7.  Save your file. There should be no errors.
	__8.  Add the following method to read data back in from the file.
	__9.  Press ALT+Enter.
	__10.  Double click  InputStream (java.io)
	__11.  JDeveloper will import the rest of the required classes.
	__12.  Save your file. There should be no errors.
	__13.  Save the file.  There should be no errors.

	Part 3 -  Test the Serialization
	__1.  Open AccountManagerTester.java.  
	__2.  Locate the line:
	__3.  Delete it.  In its place, add the following code:
	An error appears; this is happening because persist throws an IOException.  We have to catch it.  
	__4.  We will be lazy and let JDeveloper generate a try/catch clause for us. Click on the bulb in the margin next to the line.  
	__5.  In the pop-up box that appears, double click on Surrouned With Try/Catch.
	__6.  Save the code.  There should be no errors.  
	__7.   Run the code.  You should see ... nothing.  
	__8.  We have not printed anything to the console, so there will be no feedback here.  However, open a Windows file explorer and navigate to C:\.  
	__9.  You should see a new file called users.dat.    This is our persisted AccountManager's collection!
	__10.  Open this file with a text editor (like Notepad).   It looks like a jumbled mess of binary and character data.  Believe it or not, that is our persisted HashMap!   
	__11.  Close the text editor. 
	__12.  Back in JDeveloper, add the following code to the AccountManagerTester's main method after the try/catch block. 
	__13.  There is an error on the call to load().  As with the persist() method, we have to handle potential exceptions.  Left click on the bulb in the margin, and again select Surround with try/catch. It will look like this:
	__14.  Save the code.  There should be no errors. 
	__15.  Run the code.  You should see:
	__16.  Close all open files.

	Part 4 -  Review




