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Directory Paths Used in Labs
The following directories will be referred to often in the labs.  To simplify lab 
instructions there are many places where the variables listed below will be used in place 
of the actual directory path.

Some directories which should already exist before you start the labs are listed below 
with values.  Please verify the location of these directories matches what is listed here 
and make a note of the change if it does not.  Also notify your instructor if anything does 
not match.

Some directories will not yet exist as you will be installing software in the labs.  These 
are listed here so you can write down the appropriate directory here when installing the 
software.

Directories that should exist already:

<WPS_SOFTWARE_DIR>:  C:\Software\ProcessServer70
<WAS_SOFTWARE_DIR>:  C:\Software\WAS ND v70
<LABFILES_DIR>:  C:\LabFiles
<DB2_ROOT>:  C:\Program Files\IBM\SQLLIB
(C:\Program Files (x86)\IBM\SQLLIB on Windows Vista)

Directories created during labs:

<WPS_ROOT>:                                                                                     
<DM_PROFILE_ROOT>:                                                                  
<CUSTOM_ROOT>:  __________________________________
<IHS_ROOT>:  __________________________________

Other notes:

<HOSTNAME>:                                                                                    
<MACHINE_A_IP>:                                                                            
<MACHINE_B_IP>:                                                                            
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Lab 1 - Installing  WebSphere Process Server
In this lab, you will install WebSphere Process Server v7.0 (WPS).  WPS is built on top 
of WebSphere Application Server, Network Deployment (WAS ND) edition v7.0, so 
when you install WebSphere Process Server, you're really installing WAS ND too.  

WPS relies on TCP/IP networking.  It is important to have networking correctly 
configured before starting the installation and the host name must remain fixed.  Your lab 
machine should be configured correctly for the lab.  

A Windows user, who belongs to the Administrators group, has already been created for 
you.  You should use this user to log in to Windows and install WebSphere Process 
Server:

User id:  wasadmin

Password:  wasadmin

Note that we will be using a different set of user ids and passwords to configure WPS and 
DB2 in the next lab.

Following this exercise, you should be able to:

● Install WPS

● Examine the installation and learn how to check the version of WPS

Part 1 - Install the Software
Make sure that you are logged in as the administrative user listed above.  If you are not, 
log off and log back on as the user wasadmin above.

If possible, disable any anti-virus or script-blocking software that may interfere with the 
installation.

__1. Open a Windows Explorer window.

__2. Navigate to the <WPS_SOFTWARE_DIR> directory substituting the value of the 
<WPS_SOFTWARE_DIR> variable with the location mentioned in the list of directory 
paths at the beginning of these labs.  Check with your instructor if you can't find the 
directory listed.

__3. Double click on the launchpad.exe file to run it.

The launchpad program will launch.
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__4. On the left, click the link labeled Nonadministrative or nonroot installation.

Note: We are using this option even though you may be logged in as an administrative 
user as it will install the software in a directory other than the 'Program Files' directory. 
This will make it easier later when we create profiles as having profiles in the 'Program 
Files' directory can be an issue on some Windows editions.

__5. On the right, notice the installation location listed.  Write down this installation 
directory as the value of the <WPS_ROOT> variable in the list of directory paths at the 
beginning of these labs.

__6. Click the link for Install WebSphere Application Server.

__7. If you get a prompt about the Installation Manager already running click OK and the 
installation will start.
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__8. Check at the bottom and you should see a progress bar indicating the installation is 
running.

__9. The installation will take several minutes.  If you get any Windows security prompts 
accept them to allow the installation to continue.  Keep an eye on the taskbar in case any 
security prompts are hidden behind other windows.  Do not move on to the next steps 
until the progress bar is finished.  This will take some time.

__10. Confirm that you get the following dialog on completion of the installation and 
click the OK button.  If you get a different message notify your instructor.

__11. Back in the launchpad, click on the link for Install WebSphere Process Server.
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__12. Once the IBM Installation Manager opens and shows the 'Install Packages' screen, 
click the Next button.

__13. The License Agreement screen will appear.  Select I accept the terms in the 
license agreements and click Next.

__14. If you get any Windows security prompts allow them to continue.

__15. You will see the existing WebSphere Application Server ND installation that was 
installed.  Leave the option for 'Use the existing package group' selected and click the 
Next button.

__16. If you get any Windows security prompts allow them to continue.
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__17. If you want you can expand the features that will be installed but make sure not to 
make any changes.  Notice we are not installing sample applications or creating a 
development environment configuration.  Press the Next button.

__18. On the installation summary screen review the installation details and click the 
Install button.

__19. If you get any Windows security prompts allow them to continue.
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__20. Once the installation is complete select None for the packages to start and press the 
Finish button.  We will configure profiles in another lab.

__21. Close the Launchpad program.  We no longer need it. 

Congratulations!  You have installed WebSphere Process Server.

Part 2 - Examine the Installation
In this part, you will examine the software that was installed, including some of the 
directories and the software versions.

__1. Click Start > All Programs > IBM WebSphere and you will see two shortcuts 
listed underneath:  Application Server Network Deployment v7.0, and Process Server 
7.0.

__2. Also, notice that the shortcuts listed underneath Application Server Network 
Deployment v7.0 and Process Server 7.0 are almost identical.

__3. Next, open a command prompt  window.  You can do this by selecting Start → 
Programs → Accessories → Command Prompt.

__4. Change directories using the cd command to the <WPS_ROOT>\bin directory. 

Be sure to substitute the value of <WPS_ROOT> from the "Directory Paths" page at the 
beginning of the lab instructions.
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__5. Enter the command: 
versionInfo

The following will appear:

This command is useful if you need to confirm whether or not a fix pack or refresh pack 
from IBM has been applied.  Notice the following:

● The version of WAS ND is 7.0.0.7.
● The version of WebSphere Process Server is 7.0.0.0.  (This implies no fix packs 

or refresh packs have been applied to WPS.)

__6. Last but not least, open a Windows Explorer window.
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__7. Navigate to the <WPS_ROOT> directory you wrote down in the notes at the 
beginning of these labs.  This serves as the main installation directory for WPS.

Note there is no separate directory for WAS ND, which explains why most of the 
directories are identical to the ones you'd find in a WAS ND installation.

Copyright 2010 Web Age Solutions Inc. 11



EVALUATIO
N O

NLY

Some new directories introduced in the mix include:

● dbscripts – this directory has several scripts that will be needed for databases for 
Process Server.  We will be customizing and using these scripts later in other labs.

● uninstall.wbi – contains an executable used to uninstall the underlying WAS ND 
server and feature packs.

● universalDriver_wbi – contains the WPS embedded DB2 Universal JDBC 
driver.  We will be referring to this directory multiple times as we will be using 
these drivers to connect to DB2. 

__8. Close all open windows.

Part 3 - Review
In this lab, you installed WebSphere Process Server.  You also examined some of the 
artifacts of the installation process and learned how to check the version of the software.
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Lab 2 - Configuring the Databases
WebSphere Process Server (WPS) is built atop WebSphere Application Server, Network 
Deployment (WAS ND).  WPS is made up of a number of components.  These 
components use a number of different databases to store and keep track of information.

One of the primary things done in this lab is to use the new database design tool that can 
establish what choices we want to make for database names and schemas in the 
environment.  Since the are several databases involved in WebSphere Process Server and 
they will likely be created by database administrators and adhere to certain standards it is 
important to know how to use this new tool to allow flexibility in the database 
configuration but also reduce chance of errors because of mismatch with the 
configuration.  Even though we will need these databases at different times we will create 
the design and scripts of all of the databases that will eventually be required.  Below is a 
table that shows the database and schema names we will use and a description of the 
purpose of the database.

Database Schema(s) Description

WPRCSDB COMMONDB It's recommended to create this database before 
profile creation.  Must exist before the deployment 
manager can be started with no errors. 

MEDB SCASYS

SCAAPP

CEIME

BPCME

Used by the service integration bus (SIB) 
messaging engines to store information, such as 
persistent messages and transaction states.  The 
Service Component Architecture (SCA), Common 
Event Infrastructure (CEI) and the Business 
Process Choreographer (BPC) each have their own 
buses.  You can share the same database although 
environments that have a very high volume of 
messages may benefit from separate databases.

BPEDB BPC

BPCREP

The BPEDB database is used by the Business Flow 
Manager and the Human Task Manager. The BPC 
reporting function also uses this database in our 
topology (for better performance it is 
recommended that a separate database be used for 
this function).

BSPCDB IBMBUSSP The Business Space database is used for the 
Business Space application which provides a user 
interface environment for BPM applications.

EVENT <None> Used to capture WebSphere Process Server events. 
(Every server or cluster must have its own.)
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As you can see from this table, we will eventually need five databases:   WPRCSDB, 
MEDB, EVENT, BPEDB and BSPCDB.  The EVENT database must be created after 
your Process Server environment is setup but all others can be created beforehand.

So, in this lab, we will accomplish two basic tasks:

• Use the database design tool to decide settings for the databases

• Create the required WPRCSDB , MEDB, BPEDB, and BSPCDB databases.

Part 1 - Create Database Design and Scripts
Since the design of the database is an important part of the configuration of a Process 
Server environment we will start with that step.  Making these decisions now will help 
guide the rest of the configuration process.  The database design tools will also create a 
file that can be used in other parts of the configuration to make sure the settings match 
the actual database values used.  It might also be a common step that the database design 
and scripts are handed off to a team of database administrators so it will be good to do 
this as one of the first steps in a new environment.

__1. Open a command prompt  window.  You can do this by selecting Start → 
Programs → Accessories → Command Prompt.

__2. Enter the command 'hostname' and write the result in the <HOSTNAME> variable 
from the beginning of the labs as you will use this value often.

__3. Change directories using the cd command to the <WPS_ROOT>\util\dbUtils 
directory. 

__4. Start the database design tool with the following command.  This tool prompts for 
information on the command line so it will be several steps before the tool exists.

DbDesignGenerator.bat

Note:  If you see the following warning message, you can ignore it:

WSVR0615W: The user.install.root system property is not set. Some product classes 
might not be found.
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__5. Select option '1' and hit <Enter> as we will create a complete database design.  You 
could also use the tool to create the design of only one database or to take an existing 
database design file and generate the scripts for it.

__6. Select option '3' and hit <Enter> as we will create a design for Process Server in a 
Network Deployment environment.  You could also create standalone or WebSphere 
ESB designs.

__7. Select option '1' and hit <Enter>.

__8. Enter a 'y' to confirm and hit <Enter>.  We will configure the common database 
first.
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__9. Enter the following options in order for each step of the common database 
configuration.

1 This will use DB2 distributed

<Enter> This will accept the default database name of 'WPRCSDB'

db2admin The DB2 admin user

COMMONDB The schema name we will use

<Enter> Default page size

<Enter> Default tablespace

<Enter> Default temp page size

<Enter> Default temp tablespace

__10. At this point you will be entering properties for the WebSphere data source so hit 
the <Enter> key to continue to this part.
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__11. Enter the following options in order for each step of the common database data 
source configuration.

1 This will use the DB2 Universal JDBC Provider

<HOSTNAME> Enter the value of your hostname as the database is running on 
the same machine.

<Enter> Default port

<Enter> Default database user of db2admin

db2admin Data source password

<Enter> Default driver path

<Enter> Default driver path

Note: At this point we could quit and all the Process Server information would go into 
one database.  Since this is not what we want we will continue to edit other components.
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__12. Select option '2' and hit <Enter>.

__13. Then hit a 'y' to confirm and hit <Enter>.  We will configure the BPC reporting 
database.

Troubleshooting: If you make a mistake at any point you can continue until you get 
back to the main menu below and go back into that section.  If you think you have 
changed a default value and don't know what that value was to change back it might be 
best to enter 'q' and start the tool again.

__14. Enter the following options in order for each step of the BPC reporting database 
configuration.

<Enter> Same database type

1 Configuration of the database options

BPEDB Switching the database name to the chosen setting

<Enter> Default territory

BPCREP The schema we have chosen

<Enter> Accept default use of table spaces

\WPS Table space directory.  It is important to have the slash on the 
beginning.

<Enter> Default table space value
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__15. At this point you will be entering properties for the WebSphere data source so hit 
the <Enter> key to continue to this part.

__16. Enter the following options in order for each step of the BPC reporting database 
data source configuration.

<Enter> Same driver provider

false We will create the tables with the scripts

<Enter> Same hostname

<Enter> Same port

<Enter> Same user

<Enter> Same password

<Enter> Same driver location
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__17. Select option '3' and hit <Enter>.

__18. Then hit a 'y' to confirm and hit <Enter>.  We will configure the main BPC 
database.

__19. Enter the following options in order for each step of the BPC database 
configuration.

<Enter> Same database type

1 Configuration of the database options

BPEDB Switching the database name to the chosen setting

<Enter> Default territory

BPC The schema we have chosen

<Enter> Accept default use of table spaces

\WPS Table space directory.  It is important to have the slash on the 
beginning.

<Enter> Default table space value for audit logs

<Enter> Default table space value for instance items

<Enter> Default table space value for scheduler items

<Enter> Default table space value for staff query

<Enter> Default table space value for template

<Enter> Default table space value for work items
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__20. At this point you will be entering properties for the WebSphere data source so hit 
the <Enter> key to continue to this part.

__21. Enter the following options in order for each step of the BPC database data source 
configuration.

<Enter> Same driver provider

false We will create the tables with the scripts

<Enter> Same hostname

<Enter> Same port

<Enter> Same user

<Enter> Same password

<Enter> Same driver location
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__22. Select option '4' and hit <Enter>.

__23. Then hit a 'y' to confirm and hit <Enter>.  We will configure the Business Space 
database.

__24. Enter the following options in order for each step of the Business Space database 
configuration.

<Enter> Same database type

BSPCDB Switching the database name to the chosen setting

<Enter> Same user name

<Enter> The default schema of 'IBMBUSSP' matches what we have chosen

<Enter> Default prefix for table spaces

<Enter> Default table space directory
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__25. At this point you will be entering properties for the WebSphere data source so hit 
the <Enter> key to continue to this part.

__26. Enter the following options in order for each step of the Business Space database 
data source configuration.

<Enter> Same driver provider

<Enter> Same hostname

<Enter> Same port

<Enter> Same user

<Enter> Same password

<Enter> Same driver location

<Enter> Same driver location
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__27. Select option '5' and hit <Enter>.

__28. Then hit a 'y' to confirm and hit <Enter>.  We will configure the CEI Event 
database.

Note: Even though you will get an error later about generating the scripts for CEI you 
still want to configure it in the database design file as this file is used to initialize 
WebSphere settings also.

__29. Enter the following options in order for each step of the CEI Event database 
configuration.

<Enter> Same database type

__30. At this point you will be entering properties for the WebSphere data source so hit 
the <Enter> key to continue to this part.
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__31. Enter the following options in order for each step of the BPC database data source 
configuration.

<Enter> Same driver provider

EVENT Switching the database name to the chosen setting

<Enter> Same hostname

<Enter> Same port

1 We will create the tables with scripts. Notice you type '1' and not 
false

<Enter> Same user

<Enter> Same password

<Enter> Same driver location

__32. Select option '6' and hit <Enter>.

__33. Then hit a 'y' to confirm and hit <Enter>.  We will configure the system message 
engine database.  This database will also share some options with the other messaging 
databases.
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__34. Enter the following options in order for each step of the messaging database 
configuration.

<Enter> Same database type

<Enter> Same user name

SCASYS The schema we have chosen

<Enter> Default statement end

__35. At this point you will be entering properties for the WebSphere data source so hit 
the <Enter> key to continue to this part.

__36. Enter the following options in order for each step of the BPC database data source 
configuration.

<Enter> Same driver provider

MEDB The database name we have chosen

<Enter> Same hostname

<Enter> Same port

1 We will create the tables with scripts. Notice you type '1' and not 
false

<Enter> Same user

<Enter> Same password

<Enter> Same driver location

<Enter> Same driver location
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__37. Select option '7' and hit <Enter>.

__38. Then hit a 'y' to confirm and hit <Enter>.  We will configure the BPC message 
engine database.  

__39. Enter the following options in order for each step of the messaging database 
configuration.

BPCME The schema we have chosen
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__40. Select option '8' and hit <Enter>.

__41. Then hit a 'y' to confirm and hit <Enter>.  We will configure the CEI message 
engine database.  

__42. Enter the following options in order for each step of the messaging database 
configuration.

CEIME The schema we have chosen

__43. Select option '9' and hit <Enter>.

__44. Then hit a 'y' to confirm and hit <Enter>.  We will configure the application 
message engine database.  
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__45. Enter the following options in order for each step of the messaging database 
configuration.

SCAAPP The schema we have chosen

__46. Select option '10' and hit <Enter>.

__47. For the output directory enter  C:\LabFiles\dbscripts  and hit enter.  This will put 
the file somewhere besides buried in the Process Server installation.

__48. Hit <Enter> to accept the default filename.

__49. Answer 'n' to quit without generating the scripts.  We will do this in a second an 
easier way.

Note: If you have trouble creating the database design file with the tool there is a 
'SOLUTION.wps.nd.topology.dbDesign' file that can be used with some modification. 
Check with your instructor to find out what changes would need to be made.
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__50. Run the following command to generate scripts from the design file you just 
created.  Note that this command should all be on one line even though it wraps below.  

DbDesignGenerator.bat -g C:\LabFiles\dbscripts\wps.nd.topology.dbDesign
-d C:\LabFiles\dbscripts

Note: The reason we are doing this is it is easier to specify the output directory only 
once when you generate in batch mode.

If you see the following warning message, you can ignore it:

WSVR0615W: The user.install.root system property is not set. Some product classes 
might not be found.

__51. You will get a warning about generating some CEI scripts but that is OK as these 
must be generated based on the deployment environment which we have not created yet.

__52. Close the command prompt once the tool exits.

Part 2 - Create the WPRCSDB Common Database
The deployment manager in a WPS environment requires a database, known as the 
Common DB, to operate. During the the previous lab part, you created scripts for a 
database called WPRCSDB which is the Common DB, but you did not actually create the 
required database and tables.  You will do so now.

Creating the tables involves executing scripts that were generated by the database design 
tool.  Scripts can also be generated during the creation of the Deployment Manager 
profile but it is generally easier to use the database design tool as database administrators 
can create the database(s) required before you attempt to create the WebSphere 
configuration.

__1. Open a command prompt window.

__2. In the command prompt window, enter:

cd C:\LabFiles\dbscripts\WBI_CommonDB_DB2-distributed-CommonDB
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__3. Enter the following command:

configCommonDB.bat createDB 

Note: It is important that the database scripts issue commands as the user that will be 
used to connect to the database.  Some scripts like this one could be run as a different 
user as they will prompt you but for other databases we will connect to the database 
directly as the db2admin user.

__4. You should see fairly quickly that the command is creating the database and then 
after a minute or two you will be prompted for the password.  Enter db2admin

Type carefully as the window will not echo your characters! 

This script will create the WPRSCDB database, as well as all the required tables. You 
will likely see several messages.  Ignore any "No row was found" messages but make 
sure there are no errors.

We should now verify that the tables were created correctly. 

__5. In the same command prompt window, enter the command:

db2cmd

__6. A new command window will open.  In that window, enter the command: 

db2 connect to WPRCSDB

This connects us to the database that we just created.  If this worked successfully, it 
means the database was indeed created successfully.  We should now check to see if the 
tables were correctly created.  
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__7. Enter the command: 

db2 list tables for schema COMMONDB

A list of 40 tables should appear. 

__8. Enter the command: 

db2 list tables for schema db2admin

A list of 4 tables should appear. 

The Common DB has been successfully created! 

Note: If the tables do not appear it is likely due to a security issue not being able to 
create the tables.  The problem is that the database exists because that does not require 
permissions but creating tables may have failed.

If this is the case the safest course of action is likely to drop the database and reissue the 
commands.  You can drop the database with the command:

db2 drop database WPRCSDB

You should also double check the name of the database used and check with other 
students and the instructor to see if others have similar issues.

__9. Close all command prompt windows.
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Part 3 - Create the MEDB database
One of the databases that our Process Server cluster will need is the MEDB database. 
We will create this database manually, and then manually create the required tables in the 
database by running the scripts generated by the database design tool.

Note: If we had not run the database design tool we would use the 'SibDDLGenerator' 
command to generate the database scripts by providing parameters like database type, 
schema, etc that you provided to the database design tool.

__1. Open a new command prompt window.

__2. In the new window, enter: 

cd C:\LabFiles\dbscripts

__3. In the command window, enter:

db2cmd

__4. A new command window will open.  In that one, enter the command: 

db2 create db MEDB

This creates the database.  The command will take a few minutes to complete.

Now we can run the scripts to create the required tables.
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__5. Now, enter the following: 

db2 connect to MEDB user db2admin using db2admin

Note: It is important to connect as the database administrator as this is the id with rights 
to create tables, etc.

__6. Now, enter:

db2 -tf WBI_BPC_ME_DB2-distributed-SibME\DB2-distributed-SibME.sql

Note: You may want to open a Windows Explorer window and navigate to the directory 
of the generated script to copy the location correctly.

__7. You should see a number of success messages.  There may be some 'Existing index' 
messages but these are OK.

Note: If the database scripts created earlier had errors you may not notice them until 
these steps.  Common errors you might see are a mention that database elements 
"already exist" or that the "end of file" is reached.

If these errors occur the safest route to follow is to drop the MEDB database and find 
out what settings in your database design file are causing conflicts.
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__8. Next, enter: 

db2 list tables for schema BPCME

You should have 9 tables shown.

__9. Next, enter: 

db2 -tf WBI_CEI_ME_DB2-distributed-SibME/DB2-distributed-SibME.sql

__10. Again check that you have similar success messages.

__11. Next, enter: 

db2 list tables for schema CEIME

You should have 9 tables shown.

Note: The name and structure of the messaging tables is the same and the only 
difference is the schema.
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__12. Next, enter: 

db2 -tf WBI_SCA_APP_ME_DB2-distributed-SibME/DB2-distributed-SibME.sql

__13. Again check that you have similar success messages.

__14. Next, enter: 

db2 list tables for schema SCAAPP

You should have 9 tables shown.

__15. Next, enter: 

db2 -tf WBI_SCA_SYS_ME_DB2-distributed-SibME/DB2-distributed-SibME.sql

__16. Again check that you have similar success messages.

__17. Next, enter: 

db2 list tables for schema SCASYS

You should have 9 tables shown.

__18. Finally, enter: 

db2 connect reset

__19. Close the DB2 command window.

The MEDB database has been configured successfully! 

Note: Earlier, we specified that we would need four databases: MEDB, BPEDB, 
BSPCDB and EVENT (in addition to the already created WPRCSDB).  In this part of 
the lab, we created the MEDB database. 

The next two parts of the lab will create the BPEDB (BPC and reporting) and the 
BSPCDB (Business Space).  The EVENT database must be created after the creation of 
the deployment environment.
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Part 4 - Create and configure the BPEDB database
The Business Process Choreographer uses the BPEDB database for storage of various 
data. Some of the tables created for DB2 in this database and their growth rates are 
described here (more information is available from the WPS 7.0 InfoCenter):

• AUDITLOG - Contains the audit trail tables for processes and tasks. Depending 
on the degree of auditing that is used, access to tables in this table space can be 
significant. If auditing is turned off, tables in this table space are not accessed. 

• INSTANCE - Holds the process instance and task tables. It is always used 
intensively, regardless of the kind of long-running process that is run. Where 
possible, locate this table space on its own disk to separate the traffic from the rest 
of the process database. 

• SCHEDTS - Contains the tables that are used by the WebSphere scheduling 
component. Access to tables in the scheduler table space is usually low, because 
of the caching mechanisms used in the scheduler. 

• STAFFQRY - Contains the tables that are used to temporarily store staff query 
results that are obtained from staff registries like Lightweight Directory Access 
Protocol (LDAP). When business processes contain many person activities, tables 
in this table space are frequently accessed. 

• TEMPLATE - Contains the tables that store the template information for 
processes and tasks. The tables are populated during the deployment of an 
application. At run time the access rate is low. The data is not updated, and only 
new data is inserted during deployment. 

• WORKITEM - Holds the tables that are required for work item processing. Work 
items are used for human task interaction. Depending on the number of human 
tasks in the business processes, access to the tables in this table space can vary 
from a low access rate to significantly high access rate. The access rate is not 
zero, even when no explicit human tasks are used, because work items are also 
generated to support administration of long-running processes.

Let's create this database now. 

__1. Open a new command prompt window to C:\LabFiles\dbscripts if you do not 
already have one open.

__2. In the command window, enter:

db2cmd
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__3. A new command window will open.  In that one, enter the command: 
db2 create db BPEDB

This creates the database.  The command will take a few minutes to complete.

Now we can run the scripts to create the required tables.

__4. Now, enter the following: 
db2 connect to BPEDB user db2admin using db2admin

__5. Now, enter:
db2 create schema BPC

Note: The scripts we will use have the creation of everything but the schema.

__6. Now, enter:
db2 -tf WBI_BPC_DB2-distributed-BPC\createTablespace.sql
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__7. You should get success messages.  

__8. Now, enter:
db2 -tf WBI_BPC_DB2-distributed-BPC\createSchema.sql

__9. You should get lots of success messages, it will take a minute to complete.

__10. Next, enter: 
db2 list tables for schema BPC

You should have 173 tables shown.

__11. Finally, enter: 
db2 connect reset

__12. Close the DB2 command window.
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Part 5 - Configure the BPC Reporting Tables
Since we chose to put the BPC reporting tables in the same database as the other BPC 
data we don't need to perform as many steps but these tables still need to be created 
separately.

__1. Open a new command prompt window to C:\LabFiles\dbscripts if you do not 
already have one open.

__2. In the command window, enter:
db2cmd

__3. A new command window will open.  In that one, enter the command: 
db2 connect to BPEDB user db2admin using db2admin

__4. Now, enter:
db2 create schema BPCREP

Note: The scripts we will use have the creation of everything but the schema.

__5. Change to the 'WBI_BPCEventCollector_DB2-distributed-BPCReporting' 
directory.  This will simplify the next commands.
cd WBI_BPCEventCollector_DB2-distributed-BPCReporting
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__6. Now, enter:
db2 -tf createTablespace_Observer.sql

__7. Now, enter:
db2 -tf createSchema_Observer.sql

__8. Next, enter: 
db2 list tables for schema BPCREP

You should have 8 tables shown.

__9. Finally, enter: 
db2 connect reset

__10. Close the DB2 command window.
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Part 6 - Create and Configure the BSPCDB Database
Finally we need to create and configure the database for the Business Space application. 
This will be similar to other parts that have used our generated scripts.

__1. Open a command prompt window.

__2. In the command prompt window, enter:
cd C:\LabFiles\dbscripts\WBI_BSPACE_DB2-distributed-BSpace

__3. Enter the following command:
configBusinessSpaceDB.bat createDB 

__4. Enter the db2admin for the user name.

__5. The script will execute and after a minute, you will be prompted for a password. 
Enter db2admin

Type carefully as the window will not echo your characters! 

This script will create the BSPCDB database, as well as all the required tables. You will 
likely see several messages.  Ignore any "No row was found" messages but make sure 
there are no errors.

We should now verify that the tables were created correctly. 

__6. In the same command prompt window, enter the command:
db2cmd

__7. A new command window will open.  In that window, enter the command: 
db2 connect to BSPCDB

This connects us to the database that we just created.  If this worked successfully, it 
means the database was indeed created successfully.  We should now check to see if the 
tables were correctly created.  
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__8. Enter the command: 
db2 list tables for schema IBMBUSSP

A list of 29 tables should appear. 

__9. Finally, enter: 
db2 connect reset

__10. Close the DB2 command window.

The Business Space database has been successfully created! 

__11. Close any other extra command prompts or windows.

Part 7 - Review
In this lab, you:

• Ran the database design tool to collect all the database settings.

• Ran database scripts generated by the tool to create the databases and required 
tables.
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Lab 3 - Configuring the Profiles
In this lab, you will begin the task of configuring WebSphere Process Server (WPS). 
Getting a full “servable” WPS environment up and running is a complex process and 
involves many steps, which we will not attempt to complete in one lab.  In real life, 
however, you will probably choose to do everything at once.  

The goal of this lab is to configure a network deployment environment, consisting of a 
deployment manager and a node. This implies creating two profiles, one which will host 
the deployment manager and a second "custom" profile that will be the node.  Note that 
the deployment manager profile cannot be used to host applications, but rather to manage 
a deployment environment.  The second profile is being created to provide a place to run 
the servers involved in the deployment environment.  In a later lab, we will create the 
deployment environment which will be the actual server environment that will host WPS 
applications.

So, in this lab, we will accomplish three basic tasks:

• Create the deployment manager profile.

• Create a custom profile for a node.

• Backup the configuration.

Part 1 - Create the Deployment Manager Profile
The next step is to create the Deployment Manager profile.  Remember that in a later lab 
we will be creating a deployment environment in the profile we are creating here, and it is 
that deployment environment that will be used to host applications. 

__1. From the Start menu, select All Programs > IBM WebSphere > Process Server 
7.0 > Profile Management Tool.  Accept any Windows security prompts if they appear.

Note: Alternatively, you can change to the <WPS_ROOT>\bin\ProfileManagement 
directory and run pmt.bat.

The Profile Management Tool welcome page will launch.
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__2. On the Welcome page click the Launch Profile Management Tool button.

__3. On the right of the empty list of profiles click the Create button.

The Environment Selection screen will appear.  

Note: In addition to creating brand new WPS profiles, you have the ability to augment, 
or add WPS capabilities to an existing WAS 7.0 or WAS ND 7.0 profile.  This is 
because WPS is built on top of WAS ND, which is built on top of WAS. 

__4. Expand the WebSphere Process Server section, select Process server deployment 
manager and click Next.  If you get a security prompt from Windows Firewall unblock 
the process.

Note: A Deployment Manager profile in Process Server, like a Network Deployment 
Deployment Manager profile, creates a cell, a deployment manager node, and a 
deployment manager server that's used to administer application servers running on 
nodes that are federated into it.  In addition, it is used to federate process servers (really 
specialized application servers) that are federated into it.
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__5. Select Advanced Profile Creation as shown below and click Next.

We will not want to use the defaults provided by a Typical profile creation, so we will go 
with the Advanced approach.

__6. Leave the box checked for deploying the administrative console and click Next.

__7. Note that the profile name for this deployment manager profile will be Dmgr01. 
Also note that the profile directory is <WPS_ROOT>\profiles\Dmgr01.  This path will 
be referred to as <DM_PROFILE_ROOT> throughout these labs; record this name in 
the Directory Path page in the front of these lab exercises.

__8. Accept the defaults for profile name and directory and click Next.
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__9. Accept the default host, node, and cell names and click Next.  Note that the Host 
name should be the same as your computer's hostname.  (In the screenshots shown in 
these examples, the host name was Trinity.  The node and cell names are generated 
accordingly. 

__10. The Administrative Security screen will appear.  Here, we specify the 
administrative user name and password for the deployment manager environment.  This 
will be the overall “administrative” user.  Set the User name to wasadmin.

__11. Set the Password and Confirm password to wasadmin.  Make sure to carefully 
type the username and password or you may not be able to login to WebSphere later.

__12. Click Next to accept the administrative settings.

__13. Accept the default settings for generating a certificate and press the Next button.

__14. Accept the default certificate details and press the Next button.

Copyright 2010 Web Age Solutions Inc. 47



EVALUATIO
N O

NLY

__15. Accept the defaults for port values and click Next. Make a note of the port 9060 for 
the Administrative Console – you will be using this port when you access the console 
through your browser later in the exercise.

__16. Uncheck the option to run the Deployment Manager as a Windows service as 
shown below and click the Next button.

__17. Check the box for 'Use a database design file' for database configuration.

__18. Use the Browse button to find the file 
'C:\LabFiles\dbscripts\wps.nd.topology.dbDesign'. Do not yet move to the next screen 
though.

Note: Make sure to pick the one you generated, since the 'Solution' file can only be used 
after some customization.
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__19. Back in the database settings check the box marked Delay execution of database 
scripts.

Realize that all we are doing is pointing to the databases defined in the database design 
file.  We have already created the database and tables which will commonly be done 
before creating the profile.

__20. Click Next once your screen appears as shown above.

__21. The Profile Creation Summary screen will appear.  Click Create.

The profile will be created.  Please be patient, this will take a few minutes.  This is a good 
time for a quick break.

Eventually, it will complete. 

__22. Uncheck the box Launch the First steps console and click Finish.

__23. Close the Profile Management Tool.

The Deployment Manager profile has now been created!
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Part 2 - Start the Deployment Manager
We will now start the deployment manager to make sure creation was successful.  

Note: On Windows Vista it will be more difficult to start and stop the WebSphere 
management processes if your environment enforces User Account Control.  To avoid 
problems use one of the methods described below to start and stop the processes like the 
Deployment Manager.

1.  Right click a shortcut to a Command Prompt and select 'Run As Administrator' and 
then follow the commands described below.  This is likely the best as Node Agents will 
require this elevation of a command prompt.

2.  Find the shortcut in the Windows Start menu that will stop or start the process and 
right click it and select 'Run As Administrator'.

3.  If you have it configured as a Windows Service, open up the Windows Services 
panel from the 'Administrative Tools' area of the Control panel and start and stop the 
related service directly.  

__1. Open a command prompt window and cd to <DM_PROFILE_ROOT>\bin

__2. There, enter the command below.  If you get a Windows Firewall prompt unblock 
the process.

startManager.bat

__3. The deployment manager will boot.  Wait until you see the following message:

The “open for e-business” is typically a sign that the server has started successfully. 
Memorize these steps for starting the deployment manager as you will be using it again 
throughout the course.

Leave the command prompt window open as you will need it again later in this lab.

Let us see if we can login to the admin console.  
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__4. Open a web browser, and navigate to http://localhost:9060/ibm/console

Your browser may throw a warning about an untrusted certificate.  Ignore the warning 
and proceed  (for example, on Internet Explorer, simply click on the Continue to this 
website link to proceed.)

A login screen will appear. You may need to disable the intranet settings in your browser.

__5. Enter wasadmin for the username and password as shown above and click Log in. 
Do not save the password if asks.

Copyright 2010 Web Age Solutions Inc. 51



EVALUATIO
N O

NLY

The Administrative Console will appear.  This is where you will be doing the bulk of 
your administration over the following labs. 

This is the same URL that you use to access the Administrative Console for WAS ND, 
which makes sense, since WPS is built on top of WAS ND.  

You may notice:
● In the Welcome box, the version of WPS and WAS ND is listed. 
● There's an extra group in the Navigation tree (in the left pane) called Integration 

Applications, which we will access later.

__6. Using your browser, bookmark this link, as you will be continually logging into the 
admin console throughout these exercises.

Our deployment manager profile has been successfully created and is working fine!

__7. Logout of the admin console, by clicking the Logout link in the top right corner of 
the admin console.

__8. Close the browser.

Copyright 2010 Web Age Solutions Inc. 52



EVALUATIO
N O

NLY

Part 3 - Create the Custom Profile
A profile besides the deployment manager profile will be needed to host any servers. 
These are the server(s) that will host WPS applications. We will use a custom profile for 
this.  A custom profile simply defines a node, but with no servers.  The server will be 
added later, by the deployment environment  wizard. 

We will create the custom profile using the Profile Management Tool. 

__1. Start the Deployment Manager if it is not already running.  Use the 
startManager.bat command from the <DM_PROFILE_ROOT>\bin directory.

Make sure the deployment manager is running before continuing these steps.

Note: There are some batch files in the C:\LabFiles\manage directory that can be used as 
easy ways to stop and start the WebSphere management processes in the labs.  If you are 
using Windows Vista you should be able to right-click these batch files and select 'Run 
as administrator' to execute the commands.

__2. From the Start menu, select All Programs > IBM WebSphere > Process Server 
7.0 > Profile Management Tool.  Accept any Windows security prompts if they appear.

The Profile Management Tool will launch.

__3. On the Welcome page, click the Launch Profile Management Tool button.

__4. On the right of the list of profiles, click the Create button.

The Environment Selection screen will appear.  
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__5. Expand the WebSphere Process Server section, select Process server custom 
profile and click Next.  If you get a security prompt from Windows Firewall unblock the 
process.

__6. Select Advanced Profile Creation as shown below and click Next.

We will not want to use the defaults provided by a Typical profile creation, so we will go 
with the Advanced approach.
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The Profile Name and Location screen will appear. 

Note that the profile name is Custom01.  Also note that the profile directory will is 
<WPS_ROOT>\profiles\Custom01.  Record this as the value of <CUSTOM_ROOT> 
in the listing of directory paths at the start of this lab guide. 

__7. Accept the defaults and click Next.

The Node and Host Names screen will appear. 

Your machine's host name will be shown, and the node name will be generated 
accordingly. 

__8. Click Next.
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The Federation screen will appear.  As soon as the profile is created, it will attempt to 
join a cell; in our case, we want it to join the cell we created in the previous section.  This 
is why the the deployment manager must be running at the beginning of this part. 

Note that the settings here already point to the deployment manager (server localhost on 
port 8879 in our case).  Naturally, if the deployment manager was running on a different 
machine/port, you would specify those details here instead. Consequently, you would 
replace this value with the value of <HOSTNAME> specific to your machine. 

We just need to specify the DM's username and password to authenticate the federation 
process.

__9. Set the User name and Password to wasadmin

__10. Click Next when your settings match that shown above.
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Note: If you see an error message like the following:

the likely cause is that your Deployment Manager is not running. Go back to the 
command prompt and type startManager.bat to start it up. Once the Manager is 
running try to click on Next again. This time it should proceed  to the next page of the 
wizard.

__11. Accept the default settings for generating a certificate and press the Next button.

__12. Accept the default certificate details and press the Next button.

The Port Values Assignment screen will appear. 

Realize that these port numbers are for the node agent that will run out of this profile. 
Also note that the wizard is able to detect whether any of the ports listed here are already 
being used by other applications or profiles and in this case has incremented all of them 
by one until this is no longer the case. This helps to guarantee to some extent that port 
clashes do not occur, but you should always check manually just to make sure.

__13. Accept the defaults and click Next.
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The Database Configuration screen will appear. 

__14. Change the drop-down to DB2 Universal and click Next.

As with the deployment manager, this node will need access to the CommonDB 
(WPRCSDB) and so it needs database driver location information that is appropriate for 
this node.  The configuration of the actual database is not needed here which is why we 
aren't using the database design file.

__15. On the Profile Creation Summary screen, click Create.

The profile will be created.  Wait patiently.

Eventually, the profile creation will complete.  
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__16. Uncheck the box marked Launch the First steps console and click Finish.

__17. Close the Profile Management Tool.

The profile has been created!

Part 4 - Backup the Configuration
We will now make a backup of the configuration.  Make a habit of doing so on a regular 
basis; that way, in the event of a failure, you can always restore the configuration.

__1. Open a command prompt window and cd to  <DM_PROFILE_ROOT>\bin.

__2. At the command prompt, enter the following command:

backupConfig.bat PostProfileCreation.zip -nostop

Congratulations!  You have successfully created a backup of the profile.
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Part 5 - Review
Although you do not yet have a deployment environment that can host Process Server 
applications you now have the architecture that will allow you to create that environment. 

In the next lab you will see how you will add servers with the ability to host Process 
Server applications to the node created with the custom profile.  If you had more than the 
one machine involved in the WebSphere environment you would have created a separate 
custom profile on each one and had it join the cell managed by the deployment manager 
in the same way.

In this lab, you:

• Created the deployment manager profile Dmgr01

• Started the deployment manager to make sure it worked

• Logged onto the Admin Console

• Created the custom profile Custom01

• Made a backup of the Deployment Manager profile.
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	__36.  Enter the following options in order for each step of the BPC database data source configuration.
	__37.  Select option '7' and hit <Enter>.
	__38.  Then hit a 'y' to confirm and hit <Enter>.  We will configure the BPC message engine database.  
	__39.  Enter the following options in order for each step of the messaging database configuration.
	__40.  Select option '8' and hit <Enter>.
	__41.  Then hit a 'y' to confirm and hit <Enter>.  We will configure the CEI message engine database.  
	__42.  Enter the following options in order for each step of the messaging database configuration.
	__43.  Select option '9' and hit <Enter>.
	__44.  Then hit a 'y' to confirm and hit <Enter>.  We will configure the application message engine database.  
	__45.  Enter the following options in order for each step of the messaging database configuration.
	__46.  Select option '10' and hit <Enter>.
	__47.  For the output directory enter  C:\LabFiles\dbscripts  and hit enter.  This will put the file somewhere besides buried in the Process Server installation.
	__48.  Hit <Enter> to accept the default filename.
	__49.  Answer 'n' to quit without generating the scripts.  We will do this in a second an easier way.
	__50.  Run the following command to generate scripts from the design file you just created.  Note that this command should all be on one line even though it wraps below.  
	__51.  You will get a warning about generating some CEI scripts but that is OK as these must be generated based on the deployment environment which we have not created yet.
	__52.  Close the command prompt once the tool exits.

	Part 2 -  Create the WPRCSDB Common Database
	The deployment manager in a WPS environment requires a database, known as the Common DB, to operate. During the the previous lab part, you created scripts for a database called WPRCSDB which is the Common DB, but you did not actually create the required database and tables.  You will do so now.
	Creating the tables involves executing scripts that were generated by the database design tool.  Scripts can also be generated during the creation of the Deployment Manager profile but it is generally easier to use the database design tool as database administrators can create the database(s) required before you attempt to create the WebSphere configuration.
	__1.  Open a command prompt window.
	__2.  In the command prompt window, enter:
	__3.  Enter the following command:
	__4.  You should see fairly quickly that the command is creating the database and then after a minute or two you will be prompted for the password.  Enter db2admin
	Type carefully as the window will not echo your characters! 
	__5.  In the same command prompt window, enter the command:
	__6.  A new command window will open.  In that window, enter the command: 
	__7.  Enter the command: 
	__8.  Enter the command: 
	__9.  Close all command prompt windows.

	Part 3 -  Create the MEDB database
	__1.  Open a new command prompt window.
	__2.  In the new window, enter: 
	__3.  In the command window, enter:
	__4.  A new command window will open.  In that one, enter the command: 
	__5.  Now, enter the following: 
	__6.  Now, enter:
	__7.  You should see a number of success messages.  There may be some 'Existing index' messages but these are OK.
	__8.  Next, enter: 
	__9.  Next, enter: 
	__10.  Again check that you have similar success messages.
	__11.  Next, enter: 
	__12.  Next, enter: 
	__13.  Again check that you have similar success messages.
	__14.  Next, enter: 
	__15.  Next, enter: 
	__16.  Again check that you have similar success messages.
	__17.  Next, enter: 
	__18.  Finally, enter: 
	__19.  Close the DB2 command window.

	Part 4 -  Create and configure the BPEDB database
	__1.  Open a new command prompt window to C:\LabFiles\dbscripts if you do not already have one open.
	__2.  In the command window, enter:
	__3.  A new command window will open.  In that one, enter the command: 
	__4.  Now, enter the following: 
	__5.  Now, enter:
	__6.  Now, enter:
	__7.  You should get success messages.  
	__8.  Now, enter:
	__9.  You should get lots of success messages, it will take a minute to complete.
	__10.  Next, enter: 
	__11.  Finally, enter: 
	__12.  Close the DB2 command window.

	Part 5 -  Configure the BPC Reporting Tables
	__1.  Open a new command prompt window to C:\LabFiles\dbscripts if you do not already have one open.
	__2.  In the command window, enter:
	__3.  A new command window will open.  In that one, enter the command: 
	__4.  Now, enter:
	__5.  Change to the 'WBI_BPCEventCollector_DB2-distributed-BPCReporting' directory.  This will simplify the next commands.
	__6.  Now, enter:
	__7.  Now, enter:
	__8.  Next, enter: 
	__9.  Finally, enter: 
	__10.  Close the DB2 command window.

	Part 6 -  Create and Configure the BSPCDB Database
	__1.  Open a command prompt window.
	__2.  In the command prompt window, enter:
	__3.  Enter the following command:
	__4.  Enter the db2admin for the user name.
	__5.  The script will execute and after a minute, you will be prompted for a password. Enter db2admin
	Type carefully as the window will not echo your characters! 
	__6.  In the same command prompt window, enter the command:
	__7.  A new command window will open.  In that window, enter the command: 
	__8.  Enter the command: 
	__9.  Finally, enter: 
	__10.  Close the DB2 command window.
	__11.  Close any other extra command prompts or windows.

	Part 7 -  Review

	Lab 3 -  Configuring the Profiles
	Part 1 -  Create the Deployment Manager Profile
	__1.  From the Start menu, select All Programs > IBM WebSphere > Process Server 7.0 > Profile Management Tool.  Accept any Windows security prompts if they appear.
	__2.  On the Welcome page click the Launch Profile Management Tool button.
	__3.  On the right of the empty list of profiles click the Create button.
	__4.  Expand the WebSphere Process Server section, select Process server deployment manager and click Next.  If you get a security prompt from Windows Firewall unblock the process.
	__5.  Select Advanced Profile Creation as shown below and click Next.
	__6.  Leave the box checked for deploying the administrative console and click Next.
	__7.  Note that the profile name for this deployment manager profile will be Dmgr01. Also note that the profile directory is <WPS_ROOT>\profiles\Dmgr01.  This path will be referred to as <DM_PROFILE_ROOT> throughout these labs; record this name in the Directory Path page in the front of these lab exercises.
	__8.  Accept the defaults for profile name and directory and click Next.
	__9.  Accept the default host, node, and cell names and click Next.  Note that the Host name should be the same as your computer's hostname.  (In the screenshots shown in these examples, the host name was Trinity.  The node and cell names are generated accordingly. 
	__10.  The Administrative Security screen will appear.  Here, we specify the administrative user name and password for the deployment manager environment.  This will be the overall “administrative” user.  Set the User name to wasadmin.
	__11.  Set the Password and Confirm password to wasadmin.  Make sure to carefully type the username and password or you may not be able to login to WebSphere later.
	__12.  Click Next to accept the administrative settings.
	__13.  Accept the default settings for generating a certificate and press the Next button.
	__14.  Accept the default certificate details and press the Next button.
	__15.  Accept the defaults for port values and click Next. Make a note of the port 9060 for the Administrative Console – you will be using this port when you access the console through your browser later in the exercise.
	__16.  Uncheck the option to run the Deployment Manager as a Windows service as shown below and click the Next button.
	__17.  Check the box for 'Use a database design file' for database configuration.
	__18.  Use the Browse button to find the file 'C:\LabFiles\dbscripts\wps.nd.topology.dbDesign'. Do not yet move to the next screen though.
	__19.  Back in the database settings check the box marked Delay execution of database scripts.
	__20.  Click Next once your screen appears as shown above.
	__21.  The Profile Creation Summary screen will appear.  Click Create.
	__22.  Uncheck the box Launch the First steps console and click Finish.
	__23.  Close the Profile Management Tool.
	The Deployment Manager profile has now been created!

	Part 2 -  Start the Deployment Manager
	__1.  Open a command prompt window and cd to <DM_PROFILE_ROOT>\bin
	__2.  There, enter the command below.  If you get a Windows Firewall prompt unblock the process.
	__3.  The deployment manager will boot.  Wait until you see the following message:
	__4.  Open a web browser, and navigate to http://localhost:9060/ibm/console
	Your browser may throw a warning about an untrusted certificate.  Ignore the warning and proceed  (for example, on Internet Explorer, simply click on the Continue to this website link to proceed.)
	__5.  Enter wasadmin for the username and password as shown above and click Log in. Do not save the password if asks.
	The Administrative Console will appear.  This is where you will be doing the bulk of your administration over the following labs. 
	__6.  Using your browser, bookmark this link, as you will be continually logging into the admin console throughout these exercises.
	__7.  Logout of the admin console, by clicking the Logout link in the top right corner of the admin console.
	__8.  Close the browser.

	Part 3 -  Create the Custom Profile
	__1.  Start the Deployment Manager if it is not already running.  Use the startManager.bat command from the <DM_PROFILE_ROOT>\bin directory.
	__2.  From the Start menu, select All Programs > IBM WebSphere > Process Server 7.0 > Profile Management Tool.  Accept any Windows security prompts if they appear.
	__3.  On the Welcome page, click the Launch Profile Management Tool button.
	__4.  On the right of the list of profiles, click the Create button.
	__5.  Expand the WebSphere Process Server section, select Process server custom profile and click Next.  If you get a security prompt from Windows Firewall unblock the process.
	__6.  Select Advanced Profile Creation as shown below and click Next.
	__7.  Accept the defaults and click Next.
	__8.  Click Next.
	__9.  Set the User name and Password to wasadmin
	__10.  Click Next when your settings match that shown above.
	__11.  Accept the default settings for generating a certificate and press the Next button.
	__12.  Accept the default certificate details and press the Next button.
	__13.  Accept the defaults and click Next.
	__14.  Change the drop-down to DB2 Universal and click Next.
	__15.  On the Profile Creation Summary screen, click Create.
	The profile will be created.  Wait patiently.
	Eventually, the profile creation will complete.  
	__16.  Uncheck the box marked Launch the First steps console and click Finish.
	__17.  Close the Profile Management Tool.
	The profile has been created!

	Part 4 -  Backup the Configuration
	We will now make a backup of the configuration.  Make a habit of doing so on a regular basis; that way, in the event of a failure, you can always restore the configuration.
	__1.  Open a command prompt window and cd to  <DM_PROFILE_ROOT>\bin.
	__2.  At the command prompt, enter the following command:

	Part 5 -  Review

	Lab 4 -  Creating the Deployment Environment
	Part 1 -  Create the Deployment Environment 
	__1.  Start the Deployment Manager if it is not already running.  Use the startManager.bat command from the <DM_PROFILE_ROOT>\bin directory.
	__2.  If you have not restarted the machine since creating the custom profile the node agent should still be running.  If it is not, start it with the startNode.bat command in the <CUSTOM_ROOT>\bin directory.
	__3.  Make sure the deployment manager is running before continuing these steps. Enter the following command to verify this from the <DM_PROFILE_ROOT>\bin folder.
	__4.  Enter wasadmin as user and password.
	__5.  You will get the following response.
	__6.  Now make sure the node agent is running. Enter the following command to verify this from the <CUSTOM_ROOT>\bin folder.
	__7.  Enter wasadmin as user and password.
	__8.  You will get the following response.
	__9.  Perform the previous steps each time you want to verify if the Deployment Manager and Node are running.
	__10.  Login to the admin console as wasadmin.  (http://localhost:9060/ibm/console)
	__11.  In the left pane of the Admin Console expand System administration and click Nodes.  Although your node names are different you should see that there is a 'Manager' node which contains the deployment manager and there is a '<HOSTNAME>Node01' node.  This second node was added by the custom profile and is where our Process Server instance will run in the deployment environment.
	__12.  In the left pane select Console Preferences from the System administration section.
	__13.  Select the options for Synchronize changes with Nodes and click the Apply button.  This will make it easier to keep the environment synchronized when changes are made.
	__14.  In the left pane, expand Servers and click Deployment Environments.
	__15.  In the right pane, click New...
	__16.  Set the Deployment environment name to MyTopology
	__17.  Click Next.
	__18.  Leave the option for WebSphere Process Server selected and click the Next button.
	__19.  Select Single Cluster as shown below and click Next.
	__20.  Select the node by checking its box and click Next.
	__21.  On the Clusters screen, leave the default of one application deployment target and click Next.
	__22.  On the System REST Service Endpoints screen, enter the value of your <HOSTNAME> variable and port 9080 and click Next.
	__23.  On the Import database configuration screen use the Browse button to find the file 'C:\LabFiles\dbscripts\wps.nd.topology.dbDesign'.  Click the Next button when the setting is set as shown below. It may show a security dialog, click Yes to accept it.
	__24.  On the Database screen, notice the settings that are already set for you from the database design file.  This design file not only helped create database scripts it also greatly simplifies the process of a deployment environment.  Do not make any changes and simply click the Next button.
	__25.  On the Security screen, click Next.  You could change JMS and SCA authentication settings if you needed to here.
	__26.  On the Business Process Choreographer page fill in 'wasadmin' in all the password fields in the middle table.
	__27.  Scroll down and uncheck the box for  'Enable e-mail service'.
	__28.  Click on Next.  You can leave the users and groups in the top table with the defaults.
	__29.  On the Web Application Context Roots page, click Next.
	__30.  On the Summary screen, confirm all settings then click Finish and Generate Environment.  If you only click Finish it will save the settings but not actually create the environment.
	__31.  Click Save Changes.
	__32.  Once you see the message, The configuration synchronization complete for cell, click OK.  
	__33.  In the left pane, expand Servers → Clusters  and click on WebSphere application server clusters.  The right pane will show a table of defined clusters.  You should see the cluster that was just created: MyTopology.AppTarget.
	__34.  In the table click MyTopology.AppTarget
	__35.  Logout of the admin console and close the browser.

	Part 2 -  Complete Configuring the EVENT Database
	__1.  Open a new command prompt window.
	__2.  In the command prompt window, change to the folder: 
	__3.  Enter the command:
	The script will execute for a few minutes.  It should execute without any problems.  There will seem like a lot of extra messages because the script echoes each command it issues to the database.

	Part 3 -  Verify your configuration
	__1.  Open the Deployment Manager Administrative Console in a browser if you are not already (http://localhost:9060/ibm/console).
	__2.  Login with your credentials (username and password of wasadmin).
	__3.  Navigate to Servers → Clusters  and click on WebSphere application server clusters.  
	__4.  Select the checkbox next to the cluster and click on the Start button. Be patient it could take some time depending on you processor and memory.
	__5.  After a few minutes click the 'refresh' link to the right of the status column.  Repeat this until you see a solid green arrow in the status column.  This indicates the cluster has started successfully:
	Now we need to verify that the Business Flow Manager and Human Task Manager applications have started successfully. 
	__6.  Still in the administrative console, select Applications → Application Types → WebSphere enterprise applications and verify that the applications named BPEContainer_MyTopology.AppTarget and TaskContainer_MyTopology.AppTarget have started. 
	__7.  Confirm that all remaining applications are also started (they should all show a solid green arrow in the status column).
	Next, we need to verify that the BPC container functions correctly. 
	__8.  Ensure your cluster is started.
	__9.  Click on Applications → New Application.
	__10.  Click the link for New Enterprise Application.
	__11.  Click on the Browse button and navigate to
	C:\<WPS_ROOT>\installableApps\bpcivt.ear
	__12.  When you have the application location filled in as shown above click on Next.
	__13.  Click Next again to accept the "Fast Path" installation.
	__14.  Click on the Step 3 link to run through to the end of the installation wizard. This will take you directly to the Summary page.
	__15.  Click on the Finish button.
	__16.  Once the application has been installed, click on the Save link at the bottom of the page to save these changes to the master configuration.
	__17.  Once you see the message, The configuration synchronization complete for cell, click OK.  
	__18.  Navigate back to Applications → Application Types → WebSphere enterprise applications.
	__19.  Start the BPCIVTApp application. 
	__20.  Make sure you see messages that the application started successfully on all servers in the cluster.
	__21.  Now open a  new browser to the following URL:
	__22.  Fill in a username and password of wasadmin if prompted for security.
	__23.  You should see the following output in your browser:
	__24.  Close your browser window.
	__25.  Logout and close the admin console browser.
	__26.  Close any open windows.

	Part 4 -  Review

	Lab 5 -  Install a Service Application
	Part 1 -  Install Service Provider Application
	__1.  Make sure your Deployment Manager, Node Agent, and cluster are all running.  Start them up using techniques from previous labs if needed.  Be sure to start them in the order above if needed.
	__2.  Access the Administrative Console by opening a browser and entering the URL:   
	__3.  Log on as the user wasadmin
	__4.  Click on Applications → New Application.
	__5.  Click the link for New Enterprise Application.
	__6.  Click on the Browse button and navigate to C:\<LABFILES_DIR>\RoutingExampleApp.ear and click Open.
	__7.  When you have the application location filled in as shown above click on Next.
	__8.  Click Next again to accept the "Fast Path" installation.
	__9.  Click Next at the bottom of the page.  
	__10.  Click Next.
	__11.  Click the Finish button to start the installation.
	__12.  Click the Save directly to Master Configuration link.
	__13.  Once you see the message, The configuration synchronization complete for cell, click OK.  
	We now need to start the application.  If the cluster were not already running, starting the cluster would start the application.  
	__14.  In the left pane, expand the Applications → Application Types group and click WebSphere enterprise applications.
	__15.  Start application RoutingExampleApp by checking the box next to it and clicking the Start button.
	__16.  Click the double arrow icon to the right of the Status column to refresh the table. 
	__17.  Confirm that the RoutingExampleApp application started up successfully. 

	Part 2 -  Install the Service Consumer
	__1.  Click on Applications → New Application.
	__2.  Click the link for New Enterprise Application.
	__3.  In the right pane, make sure Local file system is selected and click the Browse button.
	__4.  In the Choose file dialog, select C:\<LABFILES_DIR>\OnlineOrderApp.ear and click Open.
	__5.  Click Next.
	__6.  Click Next again to accept the "Fast Path" installation.
	__7.  Click Next.  
	__8.  Click on the Next button.
	__9.  Click the Finish button to start the installation.
	__10.  Click the Save link.
	__11.  Once you see the message, The configuration synchronization complete for cell, click OK.
	__12.  In the left pane, expand the Applications → Application Types group and click WebSphere enterprise applications.  You should see OnlineOrderApp listed.
	__13.  Check the box to the left of OnlineOrderApp and click the Start button.  
	__14.  The application status should change to Started within a moment. Refresh the Application status column to make sure its started.

	Part 3 -  List the SCA Modules
	__1.  In the left pane, expand the Applications group and click the SCA modules link.
	__2.  Check the box next to RoutingExample and click the Stop button. 
	__3.  Notice that the status changed to Stopped.
	__4.  In the left pane, expand the Applications → Application Types group and click WebSphere enterprise applications.  
	__5.  Click again on the SCA Modules link under the Applications group (in the left pane).  
	__6.  Check the box next to RoutingExample and click the Start button. 
	__7.  Confirm that RoutingExampleApp started back up.
	__8.  Log out of the Administrative Console and close the browser.

	Part 4 -  Test the Service Provider Application
	__1.  Open a browser and enter the URL: 
	__2.  Enter some sample input for a USA registration as shown below.  All fields (including address2) are required.
	__3.  Click Register.  The browser should display the following page:
	__4.  To do so, in Windows Explorer, navigate to the <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<HOSTNAME>Node01.0 directory, and open the SystemOut.log file using Notepad.
	__5.  Scroll to the bottom of the file and you'll notice the following messages:
	
	__6.  Close the file.
	__7.  Click the Back button in the browser to go back to the registration page. Enter sample data if needed but change the Country from USA to Canada and click Register. 
	__8.  Open the SystemOut.log file using Notepad again.
	__9.  Scroll to the bottom of the file and you'll  notice the following new messages:
	__10.  Close the file.
	__11.  Close the Web Browser.

	Part 5 -  Confirm Mediation Logging
	__1.  Open the DB2 Control Center by selecting Start > All Programs > IBM DB2 > DB2COPY1 (Default) > General Administration Tools > Control Center.
	__2.  In the Control Center View dialog, uncheck the Show this window at startup time option and click OK.
	__3.  In the left pane, expand the All Databases folder.  
	__4.  A list of the databases that have been created thus far will be listed.  You should see WPRCSDB (Common database), MEDB (Message Bus database), BPEDB (Business Process Choreographer), BSPCDB (Business Space) and EVENT  (for CEI).
	__5.  Expand WPRCSDB and click on the Tables folder.  A list of tables will be displayed in the upper-right panel.
	__6.  Scroll through the list of tables until you see the MSGLOG table.  
	__7.  Right click on MSGLOG and select Query from the pop-up menu.  
	__8.  Click the green arrow to execute the query, which selects all the records from the MSGLOG table.  
	__9.  Exit the Control Center.
	__10.  Back up and restart the profiles following the steps in Lab 3.  Use a file name of 'ESBAppBackup.zip' for the backup file.  
	__11.  After the backup, start the deployment Manager and node agent and re-start the application server cluster from inside the Administrative console if they were stopped during the backup.

	Part 6 -  Review

	Lab 6 -  Configure Common Event Infrastructure
	Part 1 -  Install CEI Application 
	__1.  If you have not had to restart your Deployment Manager since creating the Deployment Environment stop and then restart your Deployment Manager.
	__2.  Make sure your Node agent and server instance are started.  Start them using methods from other labs if they are not.
	__3.  Login to the admin console.
	__4.  In the left pane, expand the Applications → Application Types group and click WebSphere enterprise applications.
	__5.  Check the box next to RoutingExampleApp and click the Update button.  
	__6.  Make sure the Replace the entire application radio button is selected under Application update options.
	__7.  Click the Local file system radio button and then the Browse button.
	__8.  In the Choose file dialog, select <LABFILES_DIR>\RoutingExampleAppCEI.ear and click Open.
	__9.  Scroll to the bottom of the page and click Next.
	__10.  Click Next again to accept the "Fast Path" installation.
	__11.  The installation wizard will be displayed.  Click on the Step 3 link (on the left) to bypass the other steps and advance to the Summary page.  
	__12.  Click the Finish button to start the installation.
	The installation will take a moment or two to run.  Once the installation is finished, a success message should be displayed.  
	__13.  Click the Save link.
	__14.  Once you see the message, The configuration synchronization complete for cell, click OK.  

	Part 2 -  Configure CEI Security
	__1.  In the left pane, expand Service Integration > Common Event Infrastructure and click Event Service.
	__2.  In the right pane, under Additional Properties, click Map security roles to users or groups.
	__3.  Check all 6 boxes and select Everyone under the drop-down for Map Special Subjects.
	__4.  Click OK once the settings match that shown below.
	__5.  Click the Save link.
	__6.  When the synchronization is complete, click OK. We have completed configuring CEI security.

	Part 3 -  Test CEI
	__1.  To test the RoutingExampleApp application's mediation flow, open another browser and enter the URL: 
	__2.  Enter some sample input as shown below:
	__3.  Click Register. The browser should display the following page:
	__4.  Back in the Administrative Console, in the left pane, expand the Integration Applications group and click on Common Base Event Browser.  
	__5.  Scroll to the bottom of the page and click the Get Events button.
	__6.  The Number of Events counter in the left pane should be set to 1.
	__7.  Click the All Events link under the Event Views heading to view the event.
	__8.  A single event should appear in the table (unless you registered more than once).
	__9.    Click the Select radio button and the Event Data should be displayed in the bottom pane.
	__10.  Scroll down and you will see that the event was generated by the RoutingExample module and the EventEmitter1 mediation primitive.  The sourceComponentId/subComponent element indicate that the addCustomerToSystem operation was invoked by the consumer on the mediation flow.
	__11.  Log out of the Administrative Console.
	__12.  Close all open browsers.

	Part 4 -  Review

	Lab 7 -  Install and Administer a Business Process Application
	Part 1 -  Install Applications
	__1.  Make sure that your environment is running.  Start Deployment Manager, Node Agent, and cluster if needed.
	__2.  Open the Administrative Console and login.
	__3.  Navigate to Applications → SCA modules.
	__4.  Click the Install button.
	__5.  Click on Browse and navigate to the <LABFILES_DIR> directory.
	__6.  Select the ExpensePhase2App.ear and click Open.
	__7.  Select the radio button Map the application to cluster  to target your cluster.
	__8.  Click Next to install the application.
	__9.  Click on the Save directly to the master configuration link.
	__10.  Once synchronization with the node is complete click OK.
	__11.  Click on Applications → New Application.
	__12.  Click the link for New Enterprise Application.
	__13.  In the right pane, make sure Local file system is selected and click the Browse button.
	__14.  In the Choose file dialog, select <LABFILES_DIR>\AcmeApp.ear and click Open.
	__15.  Click Next.
	__16.  Click Next again to accept the "Fast Path" installation.
	__17.  The installation wizard will be displayed.  Click on the Step 3 link (on the left) to bypass the other steps and advance to the Summary page.  
	__18.  Click the Finish button to start the installation.
	Make sure you see the message Application AcmeApp installed successfully.
	__19.  Click the Save link.
	__20.  Once you see the message, The configuration synchronization complete for cell, click OK.  
	__21.  Finally, install the client application ClaimApp.ear using the same process.  Make sure you save the configuration.
	__22.  Expand the Applications → Application Types group and click the WebSphere enterprise Applications link.  
	__23.  You should see all three applications that you installed.  
	__24.  Select each application and click on the Start button. Make sure all three applications are started before proceeding.
	__25.  Now let's briefly inspect the business process application.  Navigate to Applications → SCA modules.
	__26.  Click the ExpensePhase2 link to go to the properties of the SCA module.  Make sure not to click the link for the matching enterprise application.
	__27.  Notice that there are a few links listed under the Additional Properties heading:  Business processes and Human tasks.
	__28.  Click the Business processes link to view any process templates the application contains.  You should see ExpenseClaimDev listed and it should be in a Started state.  
	A process template defines a business process within an application.  A process template is used to create process instances.  When you install an application, any process templates it contains are automatically started up.  
	__29.  Click on the  ExpensePhase2 link in the breadcrumb trail.
	__30.  Click the Human tasks link to view any task templates the application contains. You should see ManagerReviewTask listed and it should be in a Started state.
	A task template is analogous to a process template.  It defines Service Component Architecture (SCA) services that are represented as stand-alone tasks within an application.  A task template is used to create task instances.  When you install and start up an application, any task templates it has are automatically started up.  
	__31.  Logout of the admin console.

	Part 2 -  Test Business Process Application
	__1.  Open a browser and navigate to the following URL.  You might want to create a bookmark to this as we will use it in several labs.
	__2.  Enter the following claim.  (If you decide to enter your own claim, be sure that the claim is for less than $200, since a claim of $200 or more requires authorization by a manager.)  
	__3.  Click Claim Expense.
	The browser should display the message Claim Successfully Submitted.  
	__4.  Write down the Claim ID here ________________________________
	__5.  Note that this process will not actually send an email but a real application might.  For us we must look in the server log so open  the SystemOut.log file for  using Notepad. The file is located in the <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<hostname>Node01.0 directory. You should see the following messages indicating the business process was kicked off.

	Part 3 -  View Business Process Instance using BPC Explorer
	__1.  Access the BPC Explorer by opening a browser and navigating to the following URL (replace <HOSTNAME> with your value):
	__2.  Bookmark the BPC Explorer application as you will be using it in several labs.
	__3.  Enter your wasadmin credentials in order to log into the application.
	__4.  Click the Currently Valid link under the Process Templates heading to see a listing of all the process templates deployed to your server cluster.
	Notice there are two process templates listed:   BPCIVTApplication and ExpenseClaimDev.  BPCIVTApplication was installed when you installed the corresponding application in the Lab 4 to test that the your deployment environment was configured and working properly.  ExpenseClaimDev is the process template you just installed.  Also, notice that both templates are in the Started state.
	__5.  Select the check box next to ExpenseClaimDev. 
	__6.  Click on the Instances button.
	__7.  The BPC Explorer should show one instance in the Running state. Click on the process instance name.
	__8.  Then click on the Activities tab.
	__9.  Now, we will simulate the arrival of receipts event.  The receipt application needs the Claim ID.  If you did not write this down from before, look in the SystemOut.log file for the text Claim ID.  
	__10.  Another way to find this value is to go back to the Business Process Choreographer Explorer and navigate to the process instance and select the Process Input Message tab.
	__11.  Open another browser and enter the URL.  You might want to create a bookmark to this as we will use it in several labs.
	__12.  Enter the ID in the browser. 
	__13.  Click on Log Receipts.
	The browser should display the message Operation successfully completed. Enter another?
	__14.  Close the SystemOut.log file if you opened it.  
	__15.  Open it again and scroll the bottom.  You'll see a message stating that the business process will be notified of the arrival of the receipts for the claim ID you entered.  You'll also see the addNonTaxablePayments method being invoked, which corresponds with a service from the supporting application that you installed.
	__16.  Close the log file.
	__17.  Back in the BPC Browser, click the View Process State button in the Process Instance page.  
	__18.  You should get an error message indicating that the object (i.e., process instance) does not exist.  
	__19.  To further confirm that the process instance no longer exists, click the Currently Valid link under the Process Templates heading.  
	__20.  Then select the check box next to ExpenseClaimDev and click on the Instances button.  
	No items should be found.  

	Part 4 -  Terminate a Business Process Instance using BPC Explorer
	__1.   Open a browser and navigate to the following URL:
	__2.  Submit another claim for under $200.
	__3.  Back in the BPC Explorer, click the Currently Valid link under the Process Templates heading.  
	__4.  Notice this time around that the ExpenseClaimDev process template is categorized as long running.  (It was before too; we just didn't pay attention to it.)
	__5.  Select the check box next to ExpenseClaimDev. 
	__6.  Click on the Instances button.
	__7.  Once again, the BPC Explorer should show one instance in the Running state. Click on the process instance name.
	__8.  Then click on the Activities tab.
	__9.  Again, you should see that the WaitforReceiptArrival receive activity is currently waiting.  The process will sit here and wait until the receipts are received unless we intervene.  This may take hours if not days to occur if it ever occurs.  Let's pretend that the company goes bankrupt and can't pay the expense claim.  In this case, we want to terminate this process instance.  To do so, simply click the Terminate button.
	The instance will now be displayed with a status of Terminated.
	__10.  Check the box next the instance and click on the Delete button and the instance will disappear.  The message Items found:0 should be listed in its place. In this case, the instance was not automatically deleted after termination; you had to do so manually.

	Part 5 -  Uninstall a Business Process Application
	__1.  File a new claim for under $200 using the web client.  Again, this will generate a new process instance, which will sit there waiting for receipt arrival.
	__2.  Login to the admin console.
	__3.  Expand Applications → Application Types and select WebSphere enterprise applications.
	__4.  Now, try stopping ExpensePhase2App in the Administrative Console.  To do so, check the box next to ExpensePhase2App and click the Stop button.  
	__5.  You should get an error trying to stop the application.
	__6.  With the ExpensePhase2App  application selected, click on the Uninstall button.
	
	__7.  Click  OK to uninstall the application.
	You should see the following error message appear.
	__8.  Navigate to the <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<hostname>Node01.0 directory. Open the SystemOut.log file then scroll to the bottom of the file. Scroll to the bottom of the file and you should see the following error message:
	The lesson is clear – you will not be allowed to uninstall the  ExpensePhase2App application until all associated process or task instances have been removed first.
	__9.  Close the log file.
	__10.  From the Administrative Console navigate to Applications > SCA Modules.
	__11.  Click the ExpensePhase2 link to go to the application configuration page.
	__12.  In the additional properties, click the Business processes link to view the process templates for ExpensePhase2.
	__13.  Check the box next to ExpenseClaimDev and click the Stop button.  
	__14.  Its status should change to Stopped.  
	__15.  You should see a confirmation message. Click on Save to save the changes and synchronize with the nodes. 
	__16.  Click OK once synchronization is complete.
	__17.  Click on the  ExpensePhase2 link in the breadcrumb trail.
	__18.  Click the Human tasks link to view the task templates for ExpensePhase2. 
	__19.  Check the box next to ManagerReviewTask and click the Stop button.  Its status should change to Stopped.  
	__20.  As before, you should see a confirmation message. Click on Save to save the changes and synchronize with the nodes. 
	__21.  Click OK once synchronization is complete. 
	__22.  Expand Applications → Application Types and select WebSphere enterprise applications.
	__23.  With the ExpensePhase2App  application selected, click on the Uninstall button.
	__24.  Click  OK to uninstall the application.
	__25.  Login to the BPC Explorer if you are not already and click the search icon in the upper right of the Process Templates view.
	__26.  Fill in ExpenseClaimDev for the View Name and the Name criteria as shown below.
	__27.  Click the Save button.  The new saved search will appear in the Process Templates view.
	__28.  Click the link for the saved ExpenseClaimDev search.  
	__29.  Check the ExpenseClaimDev template and click on the Instances button.
	__30.  Select the checkbox next to all process instances in the list and click on Terminate. You may need to refresh the page to see the Terminate state.
	__31.  Now, select the checkbox next to all process instances in the list and click on Delete.
	__32.  Log back in to the admin console, expand Applications → Application Types and select WebSphere enterprise Applications.
	__33.  With the ExpensePhase2App application selected, click on the Uninstall button.
	__34.  Click OK to uninstall the application.
	__35.  Click on the Save directly to the master configuration link.
	__36.  Once synchronization with the node is complete click OK.
	__37.  Logout of the admin console as well as the BPC explorer.
	__38.  Close all open windows.

	Part 6 -  Summary

	Lab 8 -  Use the BPC Explorer
	Part 1 -  Import Projects into WID
	__1.  To improve performance when you have WID open you might want to stop your Process Server instance and even your Deployment Manager and Node Agent.
	__2.  Open WID by selecting Start > All Programs > IBM WebSphere Integration Developer > IBM WebSphere Integration Developer V7.0 > WebSphere Integration Developer V7.0.
	__3.  Make sure the workspace is set to C:\workspace
	__4.  Click OK.
	__5.  Open the Business Integration perspective if it is not already by selecting Window >Open Perspective > Other.... Then in the Select Perspective dialog, select Business Integration (default) and click OK.
	__6.  Choose File > Import from the menu bar.
	__7.  Scroll down and select the Other → Project Interchange option in the Import dialog and click Next.
	__8.  Click the Browse button next to From zip file, select <LABFILES_DIR>\source\ExpensePhase2.zip and click Open.
	__9.  Back in the Import Project Interchange Contents dialog, you should see the ExpensePhase2 and ExpenseLibrary projects listed.  
	__10.  Click the Select All button to select both projects to be imported.  
	__11.  Click Finish.
	A progress bar will appear in the lower right hand corner of WID indicating that WID is rebuilding its workspace.  Wait until the progress bar disappears before proceeding onwards.
	In the Business Integration view, you should now see the ExpensePhase2 and ExpenseLibrary projects listed.  
	__12.  Click the Problems view at the bottom of WID and make sure there are no errors. You may see some warnings which will be OK.

	Part 2 -  Disable Process Instance Deletion
	__1.  In the Business Integration view, expand ExpensePhase2 → Integration Logic → Processes → Process and double click on ExpenseClaimDev.
	WID will open the business process in the editors pane using the process editor.  
	__2.  Right click anywhere in the white area of the process editor and click Show in → Properties view.  The Properties view will be displayed in the bottom of WID.  
	__3.  Click the Details tab on the left side of the Properties view.
	Notice the following:
	__4.  Set the Automatically delete the process after completion box to No.
	__5.  Save your changes by pressing Ctrl-S.
	__6.  Close the process editor.

	Part 3 -  Export and Install New EAR File
	__1.  Click the Problems view at the bottom of WID and make sure there are no errors. 
	__2.  Next we will export an EAR file for the revised business process application. Right click on the ExpensePhase2 project in the Business Integration view and select Export.
	__3.  In the Export wizard select Business Integration → Integration modules and libraries.
	__4.   Click Next. 
	__5.  Accept the defaults on the Integration Module Export page and click Next again.
	__6.  In the Specify the File Names and Target Directory page, enter the following target directory: <LABFILES_DIR>.
	__7.  Also change the name of the EAR File to ExpensePhase2App_AutoDelete.ear
	__8.  Click Finish.
	__9.  Exit WID.
	__10.  Make sure your Deployment Manager and Node Agent are running.
	__11.  Open a browser and log on to the Administrative Console as wasadmin.
	__12.  Start your Process Server instance if you stopped it to improve performance.
	__13.  Install this new business process application (ExpensePhase2App_AutoDelete.ear) using the Administrative Console.
	__14.  Save and wait until synchronization is complete. Then click OK.
	__15.  Display the enterprise applications (Applications → Application Types → WebSphere enterprise applications).  You should see ExpensePhase2App listed in a Stopped state.
	__16.  Before starting up the application, access the BPC Explorer by opening a new browser window or tab and navigating to the following URL (replace <HOSTNAME> with your value):
	__17.  Login as wasadmin.
	__18.  Click the Currently Valid link under the Process Templates heading to see a listing of all the process templates deployed to your cluster .  
	Notice there is only one template listed now for BPCIVTApplication.
	__19.  Back in the Administrative Console, start the ExpensePhase2App application.
	__20.  Back in the BPC Explorer, under Currently Valid Process Templates, click the Refresh button.  
	__21.  Click on the ExpenseClaimDev process template.
	__22.  Notice the following:
	__23.  Click the View Structure button above the details of the process template.
	__24.  Notice that you have various tools to graphically get information about the business process.

	Part 4 -  Verify Process Instances Don't Get Deleted
	__1.  Open a browser and navigate to the following URL :
	__2.  Enter a claim for under $200.   
	__3.  Click Claim Expense.
	The browser should display the message Claim Successfully Submitted.
	__4.  Write down the value of Claim ID here ____________________________. 
	__5.  Click the browser's back button and submit another claim for under $200.
	__6.  In the BPC Explorer, click the Administered By Me button under the Process Instances heading. 
	Both process instances should be displayed and they should both be in a Running state.
	__7.  Complete the first claim by accessing the following URL (change localhost to yours): 
	__8.  Enter the claim id that you recorded earlier and click Log Receipts.
	The browser should display the message Operation successfully completed. Enter another?
	__9.  Back in the BPC Explorer, under Process Instances Administered By Me, scroll to the far right and click the Refresh button.  The state of the first process instance that you started should change to Finished.  
	__10.  Click the Refresh button again and make sure that the process instance doesn't disappear.
	__11.  Check the box to the left of the other process instance and click the Terminate button.   
	__12.  Click the Refresh button and make sure that the process instance doesn't disappear.
	Congratulations!  You've succeeded in preventing process instances from being deleted.
	__13.  Logout of the BPC Explorer and the admin console.
	__14.  Close all open windows.

	Part 5 -  Review

	Lab 9 -  Human Task Management
	Part 1 -  Complete a Human Task
	__1.  Make sure your Deployment Manager, Node Agent, and Process Server instance are all started.
	__2.  Open a browser and navigate to the following URL:
	__3.  Submit a claim for over $200.   
	__4.  Write down the Claim ID here ____________________________
	__5.  Open a new browser and access the BPC Explorer.  
	__6.  Click on Task Instances > My To-dos.
	__7.  The human task named ManagerReviewTask will be listed.  Technically, this is a task instance created by the ManagerReviewTask template.  
	__8.  Click the ManagerReviewTask link.
	__9.  Click the Work on button to approve or reject the claim.
	__10.  Click the Approve radio button to approve the claim.  
	__11.  Click the Complete button to complete the human task.  
	__12.  Click the Administered by Me link under Process Instances to see the process  instance.  It should be in the Running state. You may see other Terminated or Finished processes.
	__13.  Click on the process instance name in running state.  
	__14.  Then click on the Activities tab.
	__15.  Complete the claim as you did previously by inputting the claim id into the URL:
	__16.  Back in the BPC Explorer, click the Administered by Me link under Process Instances to see the process  instance.  The status now is Finished.
	__17.  Click on this process instance name.  
	__18.  Then click on the Activities tab.
	__19.  Verify that the claim is in the Finished state.
	__20.  Above the process instance details click the View Process State button.
	__21.  Notice you have a graphical view of the specific path this process instance followed through the process.  This instance went through different steps because the amount of the expense was not within the limit for automatic approval and needed the human task of manager approval to complete.
	__22.  Click the Administered by Me link under Process Instances.
	__23.  Check all processes and select Delete. The list of process instances should now be empty.
	__24.  Let's try the reject scenario.  Submit another claim for over $200.
	__25.  In the BPC Explorer, click the My To-dos link under the Task Instances heading.
	__26.  Click the ManagerReviewTask link.
	__27.  Click the Work on button.
	__28.  Instead of approving or rejecting the claim, just click the Save button.  
	__29.  Check the box next to ManagerReviewTask and click the Work on button again.  
	__30.  This time click the Reject radio button and enter a comment as to why you rejected the claim.
	__31.  Click the Complete button to complete the human task.  
	__32.  Open your server cluster's SystemOut.log file.  
	__33.  Scroll to the bottom and notice the message rejectClaim called was printed.
	__34.  Verify that the process instance is now in the Terminated state by clicking the Administered by Me link under Process Instances.
	__35.  Verify that the ReviewbyManager and RejectClaim activities are both in the Finished state.  Do this by clicking the link for the process instance and selecting the Activities tab.
	__36.  Delete the process  instance.
	__37.  Before proceeding onwards, click on the My Task Templates link under the Task Templates heading.  

	Part 2 -  Allow a Human Task to Expire
	__1.  Switch back to BPC Explorer.
	__2.  If you have any existing task instances,  terminate them and then delete them.  To do so, click on the Administered by Me link under the Task Instances heading.  Check the box next to the task instance and click the Terminate button.  The instance state will change from Ready to Terminated.  Check the box next to the task instance again and this time click the Delete button.  The instance should disappear.
	__3.  Now open the administrative console.
	__4.  Go to Applications → Application Types → WebSphere enterprise applications.
	__5.  Update the ExpensePhase2App application to the business process application ExpensePhase2App_TaskExpiration.ear located in the <LABFILES_DIR> folder. 
	__6.  Save and wait for synchronization.
	__7.  Verify the ExpensePhase2App application is started, if not start it.
	__8.  In the BPC Explorer verify that the ExpenseClaimDev is listed under the Currently Valid list of Process Templates. 
	__9.  Submit a claim for over $200.   
	__10.  If you left the SystemOut.log file open, then close it.
	__11.  Open your server cluster's SystemOut.log file, scroll to the bottom, and verify that there are no exceptions.  You should see the following message:
	__12.  Look at the time stamp of the Maximum Limit message and wait 3 minutes to be on the safe side.  Now may be a good time to grab a cup of coffee.
	__13.  Close and open the file.  Scroll to the bottom you should see the following message:
	__14.  In the BPC Explorer, examine the process instance.  Notice that it's now in the Failed state.
	__15.  Click on the process instance name.  Then click on the Activities tab.  
	__16.  Click on the link for the ReviewbyManager activity.
	__17.  Click on the Error Details tab for the activity and you can see a similar message as from the log.
	__18.  Click the My To-dos link under the Task Instances heading.  Notice that you can still work on the ManagerReviewTask.
	__19.  Working on the task instance won't affect the process instance.  To prove this, approve or reject the claim.  Verify the process instance is still in the Failed state and that the list of activities has not changed.  The manager review activity should still be expired.
	__20.  To do so, check the box next to the process instance and click the Restart button.
	__21.  Verify that the process instance is in the Running state.  
	__22.  Quickly (before the 2 minutes is up) complete the task by approving the claim.  Do this by listing the human task by selecting click the My To-dos link under the Task Instances heading.
	__23.  Click on the process instance name.  Then click on the Activities tab.  
	__24.  Verify that the ReviewbyManager activity is in the Finished state and that the WaitforReceiptArrival1 activity is in the Waiting state.
	__25.  Complete the claim as you did previously by inputting the claim id into the URL:
	__26.  Back in the BPC Explorer, click the Administered by Me link under Process Instances to see the process  instance.  The status now is Finished.
	__27.  Delete all process instances.
	__28.  Open the server log and at the end you should see a message about paying the claim.
	__29.  Close the server log.
	__30.  You may want to stop your Process Server instance for better performance when using WID in the next sections.

	Part 3 -  Locate Input Message and Output Message JSPs for a Human Task
	__1.  Open WID using the same workspace.
	__2.  Make sure you are in the Business Integration perspective.
	__3.  Expand ExpensePhase2 → Integration Logic → Human Tasks → HumanTask.  
	__4.  Double click on ManagerReviewTask.  WID will open the task with the Human Task Editor.
	__5.  Right click on Business Process Choreographer Explorer, inside the User Interface box, and select Show in → Properties View.
	__6.  In the Properties view, notice that the Input message JSP and Output message JSP are both specified.  Specifically, the file name, context root, and context-relative path location are listed.
	__7.  Close the editor.
	__8.  To see the actual location of the JSP files, you'll first need to import the ClaimApp.zip file. To do so, choose File → Import from the menu bar.
	__9.  Scroll down and select the Other → Project Interchange option in the Import dialog and click Next.
	__10.  Click the Browse button next to From zip file.
	__11.  Select <LABFILES_DIR>\source\ClaimApp.zip and click Open. 
	__12.  Click Select All to select both the ClaimApp and ClaimWeb projects.
	__13.  Click Finish to import both projects.
	__14.  Expand ClaimWeb → WebContent → human_task.  Both files will be listed.

	Part 4 -  View Expiration Settings in WID
	__1.  Close any open files in WID.
	__2.  Import the ExpensePhase2 project in the project interchange file <LABFILES_DIR>\source\ExpensePhase2_TaskExpiration.zip.
	__3.  Select only the ExpensePhase2 project.
	__4.  Click Finish.
	__5.  Click OK when prompted to overwrite the existing project.
	__6.  After the workspace is rebuilt, verify that there are no errors listed in the Problems view.
	__7.  Open the ExpenseClaimDev process under ExpensePhase2 → Integration Logic → Processes → Process.
	__8.  Right click on the Review by Manager activity and select Show in → Properties View. 
	__9.  In the Properties view, click on the Description tab and notice the Name field corresponds with the name (i.e., ReviewbyManager) you saw in the Activities tab of the BPC Explorer.
	__10.  Click on the Expiration tab to see the expiration settings.  You may to use the arrows below the list of tabs on the left of the Properties view.
	__11.  Exit WID.
	__12.  Log out of the Administrative Console and BPC.
	__13.  Close any browsers and open files.

	Part 5 -  Review

	Lab 10 -  Business Rules
	Part 1 -  View Business Rule
	__1.  Make sure your Deployment Manager, Node Agent, and Process Server instance are started.
	__2.  Login to the main WebSphere admin console if you are not already.
	__3.  In the navigation, expand Servers → Server Types and select the WebSphere application servers link.
	__4.  Click the link for the existing server from your deployment environment.
	__5.  Scroll down on the right and expand the Business Rules group in the section of Business Integration properties.
	__6.  Click on the link for Business Rules from the group shown above.
	__7.  Notice that this is a simple list.  The only thing you can really tell is that there are business rules deployed.  Hopefully the name of the business rules would help you know what part of a deployed process it was involved in.
	__8.  Check the box next to the 'ExpenseLimitRG' rules and click the Export button.
	__9.  On the next page that is displayed, click the link for the file and open the file.  Allow any Windows security prompts to continue and you should be able to view the contents of the file.
	__10.  Although you will not really be able to use these files yourself they are clearly something you could pass back to developers to capture the current values for the rules being used by the business.
	__11.  Close the program which is showing the files for the exported business rules.
	__12.  Back in the admin console, click the Back button.
	__13.  In the breadcrumb trail at the top of the admin console, click the link for the name of your server to return to the page of server properties.
	__14.  Back in the Business Rules group of server properties, click the link for Business Rules and Selectors Auditing.
	__15.  Click the Runtime tab at the top of the page.  This will allow us to make changes without restarting the server.
	__16.  Check the box for 'Custom audit file' and click the OK button to save the settings.  Notice that we could have specified a different log file name although the default will create a separate log file which will be good enough for us right now.
	__17.  Click the Save link and wait for the changes to be synchronized.
	__18.  Click the OK button for the synchronization progress and navigate back to the properties of the server by clicking the link for the server name.
	__19.  Back in the Business Rules group of server properties, click the link for Business Rules Manager Configuration.
	__20.  Notice the business rules manager application is already installed with a context root of '/br'.  You will see this later when we go to that application.
	__21.  Navigate to Applications → Application Types → WebSphere enterprise applications.
	__22.  Notice in the list of applications the 'BusinessRulesManager...' application is listed with a suffix to indicate that it is targeted to our deployment environment.  It should also already be running.
	__23.  Logout of the admin console.  This will prevent login conflicts with the business rules manager we will use later.
	__24.  Open a new browser or browser tab and login to the BPC Explorer.  
	__25.  Click the Currently Valid link under the Process Templates heading.
	__26.  Click on the ExpenseClaimDev process template.
	__27.  Click the View Structure button above the details of the process template.
	__28.  Hover over the 'Get Maximum Limit' activity and then click on the 'Show BPEL' icon in the popup that appears.
	__29.  In the BPEL source that appears notice that the activity takes the 'employeeId' as an input parameter and returns the limit value.  We will understand what the employeeId is used for in a second.
	__30.  Close the popup of BPEL source.
	__31.  Stay logged in to the BPC Explorer but open a new browser or tab to the following URL: (you do want to use 'localhost')
	__32.  You will get an error about the security certificate so use the same method you have used for the admin console to continue to the application.
	__33.  Login with a userid and password of wasadmin.
	__34.  On the left, under Business Rule Groups, expand things until you see the 'MaximumLimitDT' link and click it.
	__35.  After clicking the 'MaximumLimitDT' link you will see the current state of the rule.  This indicates that the default limit is $200 (which we have seen) unless the employee ID starts with an upper or lower case 'm'.  Perhaps managers have IDs that start with 'm' and they have different rules about what expense limit will require manual approval.  We will see this in the next section.
	__36.  Stay logged in to the business rule manager application as we will use it later.

	Part 2 -  Test Existing Business Rule
	__1.  Open a browser and navigate to the following URL:
	__2.  Submit a claim for over $200 but under $500.   Make sure you use an employee id that does not have an 'm' on the start.
	__3.  Write down the Claim ID here ____________________________
	__4.  Return to the BPC Explorer and login if you are not already.
	__5.  Click on Task Instances > My To-dos.
	__6.  Click  the ManagerReviewTask link.
	__7.  Click  the Work on button.
	__8.  Approve or reject the claim and then click the Complete button.
	__9.  If you approved the claim, complete the claim as you did previously by inputting the claim id into the URL:
	__10.  Verify in the BPC Explorer that the process instance is now in the Finished or Terminated state by clicking the Administered by Me link under Process Instances.
	__11.  Check that the activities were called that you expected based on whether you approved or rejected the claim.  Do this by clicking the link for the process instance and selecting the Activities tab.
	__12.  Delete all process instances in the BPC Explorer.
	__13.  Return to the URL for submitting a claim:
	__14.  Submit a claim for over $200 but under $500.   This time use an employee ID that starts with an 'M' as shown below.
	__15.  Complete the claim as you did previously by inputting the claim id into the URL:
	__16.  Return to the BPC Explorer.
	__17.  Verify that the process instance is now in the Finished or Terminated state by clicking the Administered by Me link under Process Instances.
	__18.  Check the list of activities to prove that the 'Review by Manager' activity was not called.
	__19.  Click the link for the 'GetMaximumLimit' activity in the list.
	__20.  Click the tab for 'Activity Output Message' to show that the maximum limit returned was 500 which matches what our rule would have returned.
	__21.  Delete all process instances in the BPC Explorer.
	__22.  Return to the URL for submitting a claim:
	__23.  Submit a claim for over $500.   Also use an employee ID that starts with an 'M' as shown below.
	__24.  Return to the BPC Explorer and click on Task Instances > My To-dos.
	__25.  Click  the ManagerReviewTask link.
	__26.  Click  the Work on button.
	__27.  Approve or reject the claim and then click the Complete button.
	__28.  If you approved the claim, complete the claim as you did previously by inputting the claim id into the URL:
	__29.  Verify in the BPC Explorer that the process instance is now in the Finished or Terminated state by clicking the Administered by Me link under Process Instances.
	__30.  Verify that the activities you expect to execute based on whether you approved or rejected the claim were executed.

	Part 3 -  Modify Business Rule
	__1.  Return to the business rules manager application.  Login again as wasadmin if you logged out before.
	__2.  Even if you are currently displaying the page, click the 'MaximumLimitDT' link to make sure you were not timed out from the application.
	__3.  Click the Edit button to modify the decision table.
	__4.  Because developers converted the rules into a template, the action cells are editable.  Try changing the == 'M' and == 'm' cells from 500.00 to 1500.00.  Notice that an error appears.
	__5.  Change the cells from 1500.00 to 700.00.  The cells should change back to white and the error message should disappear. 
	__6.  Click Save to save your changes to the decision table.  
	__7.  Notice that a message appears in the Messages box indicating that the changes have been temporarily saved and that we may publish the changes.  Also, note that the Status of the decision table has changed from Original to Local Change.
	__8.  Click Publish and Revert in the left panel.  The Publish and Revert page will appear in the center panel.
	__9.  Again, you'll see that the Status of the decision table is set to Local Change.  Also, notice that there is a Revert button which allows you to change the rule back to its original state.  Instead, we want to publish our change to the server, so that the rule goes into effect.  To do so, click the Publish button at the top of the page.
	__10.  Expand ExpenseLimitRG->getMaximumLimit in the left panel.
	__11.  Click MaximumLimitDT.  Notice that the Last Published date has changed and that the Status was set back to Original.
	__12.  Logout of the business rules manager application.
	__13.  We also want to look at the audit log of the changes made to the business rules.  To do so, in Windows Explorer, navigate to the <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<HOSTNAME>Node01.0 directory, and open the BrSelAudit0.log file using Notepad.
	__14.  Search for '700' to see that the change you made to the rule was audited in the log.
	__15.  Close the log file.

	Part 4 -  Test Revised Rule
	__1.  Return to the URL for submitting a claim:
	__2.  Submit a claim for over $500 but under $700.   Use an employee ID that starts with an 'm' as shown below.
	__3.  Complete the claim as you did previously by inputting the claim id into the URL:
	__4.  Return to the BPC Explorer and login if you are not already.  You may need to login again if you were inactive for too long.
	__5.  Verify that the process instance is now in the Finished or Terminated state by clicking the Administered by Me link under Process Instances.
	__6.  Check the list of activities to prove that the 'Review by Manager' activity was not called.
	__7.  Click the link for the 'GetMaximumLimit' activity in the list.
	__8.  Click the tab for 'Activity Output Message' to show that the maximum limit returned was 700 which matches the change made to the rule.
	__9.  Delete all process instances in the BPC Explorer.
	__10.  Logout of the BPC Explorer and close any extra windows or files.

	Part 5 -  Summary

	Lab 11 -  SCA Import Bindings
	Part 1 -  Examine Import Binding in WID
	__1.  You may want to stop at least your Process Server instance to improve performance.
	__2.  Open WID by selecting Start > All Programs > IBM WebSphere Integration Developer V7.0 > IBM WebSphere Integration Developer V7.0.
	__3.  Make sure the workspace is set to C:\workspace.  Click OK.
	__4.  Make sure you are in the Business Integration perspective.
	__5.  Close all open files.
	__6.  From the menus, select File > Import.
	__7.  Expand Other and select Project Interchange.
	__8.  Click Next.
	__9.  Click the Browse button and select C:\LabFiles\source\PriceQuote.zip and click Open.
	__10.  Click Select All to select all projects in the ZIP file.
	__11.  Click Finish. Wait until finish building.
	__12.  Select Project → Clean from the menus, select Clean all projects and click OK to confirm that you want to clean all of the projects.
	__13.  Click the Problems tab at the bottom to find out if the build had found any errors.
	__14.  In the Business Integration view, expand PriceQuoteFlow and double click on Assembly Diagram.  WID will open the assembly diagram with the Assembly Editor.
	__15.  Scroll to the right in the diagram.
	__16.  Click on OrderMediation.  
	__17.  Look in the Properties view.
	__18.  In the assembly diagram click on CometImport.  
	__19.  Click the Binding tab in the Properties view.  
	__20.  Click on the line drawn between OrderMediation and WinningQuotePicker.  

	Part 2 -  Deploy the Applications
	__1.  Close all open files in WID and then close WID.
	__2.  Check that your Deployment Manager, Node Agent, and Process Server instance are running and start them if they are not.
	__3.  Open the Administrative Console and login as wasadmin.
	__4.  Navigate to Applications → SCA modules.
	__5.  Click the Install button.
	__6.  Click on Browse and navigate to the <LABFILES_DIR> directory.
	__7.  Select the PriceQuoteFlow.ear and click Open.
	__8.  Select the radio button to target your cluster.
	__9.  Click Next to install the application.
	__10.  Click on the Save directly to the master configuration link.
	__11.  Once synchronization with the node is complete click OK.
	__12.  Click on Applications → New Application.
	__13.  Click the link for New Enterprise Application.
	__14.  In the right pane, make sure Local file system is selected and click the Browse button.
	__15.  In the Choose file dialog, select <LABFILES_DIR>\PriceQuoteSupporting.ear and click Open.
	__16.  Click Next.
	__17.  Click Next again to accept the "Fast Path" installation.
	__18.  The installation wizard will be displayed.  Click on the Step 3 link (on the left) to bypass the other steps and advance to the Summary page.  
	__19.  Click the Finish button to start the installation.
	__20.  Click the Save link.
	__21.  Once you see the message, The configuration synchronization complete for cell, click OK.  
	__22.  Expand Applications → Application Types and click WebSphere enterprise Applications.
	__23.  Select the check box for these applications.  It may be possible that one or both of the applications is on the second page of applications.
	__24.  Click Start and wait until the applications are started.

	Part 3 -  Test the Applications
	__1.  Open a web browser and enter the URL of the web based application used to place an order:
	__2.  Enter some values.
	__3.  Click Go.
	__4.  Make sure that you see the success message.
	__5.  Open the server's SystemOut.log file from <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<HOSTNAME>Node01.0.
	__6.  Go to the very end of the file. The log entries will tell a story. 
	__7.  Close the log file.

	Part 4 -  Modify Import Binding Using Administrative Console
	__1.  Open a browser and log on to the Administrative Console as wasadmin if you are not already.
	__2.  Expand the Applications group and click on the SCA Modules link.
	__3.  Verify that the PriceQuoteFlow module, which corresponds with the mediation module you saw in WID, is listed and is in a Started state.  
	__4.  Click the PriceQuoteFlow link to go to the SCA module configuration page.
	__5.  Expand Imports under the Module components heading. 
	__6.  Expand CometImport.  
	__7.  Then, expand both options underneath:  Interfaces and Binding.
	__8.  Click on the Supplier interface and scroll to the bottom of the page.
	__9.  Click on PriceQuoteFlow in the breadcrumb trail.  
	__10.  Expand Imports > CometImport > Binding and click on JAX-Web Service [CometImport_SupplierHttpService...].  
	__11.  To the far right of the endpoint address click the Edit button.
	__12.  Change the endpoint's host name from localhost to your machine's <HOSTNAME>, which you wrote down earlier.
	__13.  Click OK.
	__14.  Save your changes and wait for the synchronization to occur.
	__15.  Expand Applications and select SCA modules.
	__16.  Stop and then start the PriceQuoteFlow SCA module.  Wait for the stop operation to complete before attempting to start.
	__17.  Open a new browser and enter:
	__18.  Enter some information and click Go.
	__19.  Verify that the message "Order was created successfully" appears in the browser.
	__20.  Open the SystemOut.log file of the server.
	__21.  Go to the bottom of the file and make sure the solution is working.
	__22.  Close the log file.

	Part 5 -  Test a Failure Scenario
	__1.  Navigate to the list of SCA modules at Applications → SCA modules and stop the PriceQuoteFlow module.
	__2.  In the Administrative Console, navigate to the CometImport's import binding page. Remember you first go to the properties of the PriceQuoteFlow SCA module and then expand the imports until you find the link for the binding.
	__3.  Click the Edit button by the endpoint address.
	__4.  Change the endpoint address host name to:
	__5.  Click OK.
	__6.  Save your changes. Wait for synchronization.
	__7.  Start the PriceQuoteFlow module from Applications → SCA modules.
	__8.  Open a new browser and enter:
	__9.  Enter some information and click Go.
	__10.  Open the SystemOut.log file of the server.  Reopen the file if it was already open in a text editor to be sure you get the most recent messages.
	__11.  Go to the very end. You will see a bunch of exception stack trace.
	__12.  The very first stack trace will show something like:
	__13.  Unfortunately this is not very useful but if you search before several "FFDC" messages you should see reference to opening a transport chain to 'dummyhostname'.  You may also see that the service which still has the correct binding responded normally.
	__14.  Close the log file.

	Part 6 -  Revert Back to a Valid Endpoint Location
	__1.  Navigate to the list of SCA modules at Applications → SCA modules and stop the PriceQuoteFlow module.
	__2.  Change the CometImport binding host name back to your machine's host name.
	__3.  Save your changes. Wait for synchronization.
	__4.  Start the PriceQuoteFlow module from Applications → SCA modules.
	__5.  Open a new browser and enter:
	__6.  Enter some information and click Go.
	__7.  Open the SystemOut.log file of the server and verify that you are getting responses from both services and no errors then close the file.
	__8.  Log out of the Administrative Console.
	__9.  Close any open browsers.

	Part 7 -  Review

	Lab 12 -  Application Integration Using JMS Messaging
	Part 1 -  Business Logic and Architecture
	Part 2 -  Review JMS Enabled Solution
	__1.  You may want to stop at least your Process Server instance to improve performance.
	__2.  Launch WID using the same workspace.
	__3.  Import all projects from the project interchange file C:\LabFiles\source\PriceQuoteJMS.zip. You will be asked to overwrite the PriceQuoteFlow module. Choose to do so.
	__4.  Select Project → Clean from the menus and confirm that you want to clean all of the projects.  Wait for the build to finish.
	__5.  Click the Problems tab at the bottom to find out if the build had found any errors.
	__6.  Close all open files.
	__7.  Open the assembly diagram for the PriceQuoteFlow module.

	Part 3 -  Review the JMS Import Configuration
	__1.  In the assembly diagram, select the JMS import AccountingApp.
	__2.  In the Properties view, select the End-point configuration tab.
	__3.  Select the JMS Destinations tab along the top of the Properties view.
	__4.  Expand Send Destinations Properties.
	__5.  Make sure that the send destination JNDI name is set to jms/AccountingRequestQ.  Again this will match the JNDI name of a resource configured later.
	__6.  Similarly, verify the JNDI name of the receive destination queue.
	__7.  Expand Callback Destination Properties.
	__8.  Make sure that Specify properties for configuring new messaging provider resource checkbox is selected. Here we will provide enough information so that WebSphere Process Server can dynamically create the destination.
	__9.  The Bus name field should be set to DemoBus
	__10.  Close all open files.
	__11.  Exit out of WID.

	Part 4 -  Create the Message Queues
	__1.  Start the Deployment Manager and Node Agent unless they are already running.
	__2.  Log in to admin console as wasadmin.
	__3.  Stop your Process Server instance if it is not already as we will need to restart later anyway.
	__4.  Expand Service integration and click Buses.
	__5.  Click New to create a new message bus.
	__6.  Enter DemoBus as the name.
	__7.  Clear the Bus Security checkbox to disable security protection for the bus.
	__8.  Click Next.
	__9.  Click Finish.
	__10.  Click DemoBus from the list of buses.
	__11.  Click Bus members.
	__12.  Click Add.
	__13.  Select Cluster.
	__14.  Click Next when your cluster is selected.
	__15.  Leave the default option for the 'Messaging engine policy assistance' and click the Next button.  Ignore the warning since we know our cluster only has one server right now.
	__16.  Choose Data store and click Next.
	__17.  The next screen will list the settings for the messaging engines.  Click the link for the 'MyTopology.AppTarget.000-DemoBus' messaging engine.
	__18.  Enter jdbc/WPSDB as the data source JNDI name.  
	__19.  Select WPSDB_Auth_Alias as the database authentication alias.  Make sure that Create tables is selected.
	__20.  Click Next when your data store properties are set as shown above.
	__21.  Click the Next button when the messaging engine is configured.
	__22.  Leave the default option for the current heap size settings and click the Next button.
	__23.  Click Finish to add the bus member.
	__24.  Click Buses on the left hand navigation tree.
	__25.  Click DemoBus.
	__26.  Click Destinations.
	__27.  Click New.
	__28.  Choose Queue (default). Note: For pub/sub you will create a topic instead.
	__29.  Click Next.
	__30.  Enter AccountingRequestQ as the identifier.
	__31.  Click Next.
	__32.  The bus member to host the queue should be the cluster. Click Next.
	__33.  Click Finish to create the queue.
	__34.  Similarly, create another queue called AccountingResponseQ
	__35.  Check that both queues are listed.
	__36.  Click the Save link to save your changes.
	__37.  Click OK when the synchronization is complete.

	Part 5 -  Create JMS Resources
	__1.  In the left hand navigation tree, expand Resources > JMS.
	__2.  Click Queue Connection Factories.
	__3.  Set the scope to the cluster MyToplogy.AppTarget as shown below.
	__4.  Click New.
	__5.  Click OK to create the resource for the default messaging provider.
	__6.  Enter these values:
	__7.  Click OK.
	__8.  Click Resources → JMS → Queues on the left side.
	__9.  Set the scope to the cluster MyTopology.AppTarget.
	__10.  Click New.
	__11.  Click OK to create the resource for the default messaging provider.
	__12.  Enter these values.
	__13.  Click OK to create the queue.
	__14.  Click New again and create another destination.
	__15.  Click OK to create the resource for the default messaging provider.
	__16.  Enter the destination as follows.
	__17.  Click OK.
	__18.  Save changes.
	__19.  Click OK when the synchronization is complete.

	Part 6 -  Update the PriceQuoteFlow Module
	__1.  Select Applications → Application Types →  WebSphere enterprise applications.
	__2.  Select the checkbox for PriceQuoteFlowApp.
	__3.  Click Update.
	__4.  Select the Replace the entire application option.
	__5.  Using the Browse button, select C:\LabFiles\PriceQuoteFlowJMS.ear and click Open.
	__6.  Scroll all the way down and click Next when you have indicated the file to use for the update.
	__7.  Click Next again to accept the "Fast Path" installation.
	__8.  Click on the Step 3 link (on the left) to bypass the other steps and advance to the Summary page.  
	__9.  Click Finish.
	__10.  Save changes and wait for synchronization.

	Part 7 -  Deploy Accounting (MDB) Application
	__1.  Expand Resources > JMS.
	__2.  Click Activation specifications.
	__3.  Set the scope to the cluster  MyToplogy.AppTarget.
	__4.  Click New.
	__5.  Click OK to create the resource for the default messaging provider.
	__6.  Enter the following values.
	__7.  Scroll down and click OK.
	__8.  Save changes and wait for synchronization. Maybe an error appear that another synchronization is performing, just click OK. We will synchronize again later. 
	__9.  Click on Applications → New Application.
	__10.  Click the link for New Enterprise Application.
	__11.  Use the Browse button to select C:\LabFiles\SimpleAccountingApp.ear and click Open.
	__12.  Click Next when you have the file to install selected.
	__13.  Click Next again to accept the "Fast Path" installation.
	__14.  Click on the Step 3 link (on the left) to bypass the other steps and advance to the Summary page.  
	__15.  Click Finish.
	__16.  Save changes and wait for synchronization.
	__17.  On the left hand side click Applications → Application Types → WebSphere enterprise applications.
	__18.  Go to the second page of applications and click SimpleAccountingApp.
	__19.  Click Message Driven Bean listener bindings.
	__20.  Make sure that the activation specification option is selected.
	__21.  Go to Servers → Server Types → WebSphere application servers and start your Process Server instance.  Restart it if it was already running.

	Part 8 -  Test
	__1.  Open a web browser and enter the URL:  
	__2.  Enter some values and then click Go. Make sure that the form submits successfully.
	__3.  Open server's SystemOut.log file using notepad.
	__4.  Search for QuoteMDB to locate log messages from the MDB.
	__5.  Make sure the winning supplier got the order.
	__6.  Close the log file.

	Part 9 -  Review JMS Endpoint Address
	__1.  On the left hand side, click Applications → SCA modules.
	__2.  Click PriceQuoteFlow.
	__3.  Expand Imports > AccountingApp > Binding.
	__4.  Click JMS.
	__5.  For sending messages, the JNDI names of the connection factory and send destination queue can be set here.
	__6.  Logout of the admin console and close all the browsers.

	Part 10 -  Review

	Lab 13 -  Application Integration Using MQ JMS Binding
	Part 1 -  Business Logic
	Part 2 -  Understand the Solution
	Part 3 -  Create MQ Resources
	__1.  Launch MQ Explorer from the Start menu > All Programs > IBM WebSphere MQ > WebSphere MQ Explorer.  If you are running on Windows Vista you must right click the shortcut and select 'Run as administrator'.
	__2.  Close the Welcome page.
	__3.  Right click Queue Managers and select New > Queue Manager...
	__4.  Enter MyQM as the name of the queue manager.
	__5.  Click Finish.
	__6.  The queue manager will be started automatically. If needed, you can always start and stop it by right clicking it. We will keep it running.
	__7.  Expand MyQM.
	__8.  Right click Queues and select New > Local Queue...
	__9.  Enter InputQ as the name.
	__10.  Click Finish.
	__11.  Click OK to close the information dialog.
	__12.  Similarly, create another local queue called OutputQ
	__13.  Verify that both queues are listed as follows.
	__14.  Minimize the MQ Explorer but leave it open as we will use it later to submit and examine messages.

	Part 4 -  Create JMS Resources
	__1.  Start your Deployment Manager and Node Agent if they are not running.
	__2.  Log into the admin console.
	__3.  Stop your Process Server instance if it is already running as we will need to start it after configuring resources anyway. Wait until is completely stopped.
	__4.  Expand Resources > JMS.
	__5.  Click Connection factories.
	__6.  Set the scope to the cluster MyTopology.AppTarget.
	__7.  Click New.
	__8.  Select WebSphere MQ messaging provider.
	__9.  Click OK.
	__10.  At the Configure basic attributes page, enter the following information.  Press the Next button when done.
	__11.  Leave the default option to enter all connection information in the wizard and press the Next button.
	__12.  Enter 'MyQM' for the queue manager and press the Next button.  This must match the name we had used to create the queue manager.
	__13.  Enter your <HOSTNAME> in the connection details and press the Next button.
	__14.  Press the Test Connection button and be sure you get a successful connection.  
	__15.  Once you do press the Next button.
	__16.  Press the Finish button to create the connection factory.
	__17.  Click the link in the navigation pane for Resources -> JMS  -> Queues.
	__18.  Set the scope to our cluster if it is not already.
	__19.  Click New.
	__20.  Select WebSphere MQ messaging provider.
	__21.  Click OK.
	__22.  At the New Queue page, enter the following information.  Leave the rest of the settings with the defaults.  Note the screenshots below only show the sections that have settings that are changed.
	__23.  When the values match those above press the OK button.
	__24.  Similarly, create another JMS destination as follows.
	__25.  Verify that both destinations have been created as follows.
	__26.  Save changes and wait for synchronization.

	Part 5 -  Configure the JMS Activation Specification
	__1.  In the navigation pane select Resources -> JMS -> Activation specifications.
	__2.  Check that you are at the MyTopology.AppTarget cluster scope as in previous sections of this lab.  If you need to switch scope, select the scope using the drop down list.
	__3.  At the JMS Activation Specifications list, press the New button.
	__4.  Select WebSphere MQ messaging provider as the choice for provider and press the OK button.
	__5.  At the Configure basic attributes page, enter the following information.
	__6.  Press the Next button when your settings match that shown above.
	__7.  At the Specify MDB destination data page, enter the following information.
	__8.  Check that the Destination JNDI name matches the value above and press the Next button.
	__9.  Leave the default option to enter all connection information in the wizard and press the Next button.
	__10.  Enter 'MyQM' for the queue manager and press the Next button.  
	__11.  Enter your <HOSTNAME> in the connection details and press the Next button.
	__12.  Press the Test Connection button and be sure you get a successful connection.  Once you do press the Next button.
	__13.  Press the Finish button to create the activation specification.
	__14.  Save changes and wait for synchronization.

	Part 6 -  Deploy the SCA Module
	__1.  You should be familiar by now to the steps needed to deploy an application. Follow those steps to deploy C:\LabFiles\MQTestApp.ear.
	__2.  Save changes and wait for synchronization.

	Part 7 -  Review MQ JMS Binding
	__1.  On the left hand side, click SCA modules under Applications.
	__2.  Click MQTest.
	__3.  Expand Imports > MQJMSImport > Binding.
	__4.  Click MQJMS.
	__5.  Notice that the Send Resources already match some of the JMS resources you configured earlier.
	__6.  Click the MQTest link in the breadcrumb trail.
	__7.  Back on the MQTest SCA module properties page expand Exports > MQJMSExport > Binding.
	__8.  Click MQJMS.
	__9.  Notice that the Receive Resources match the configuration you made earlier.

	Part 8 -  Test the SCA Module
	__1.  Go to Servers → Server Types → WebSphere application servers and start your Process Server instance.
	__2.  Open the Applications → SCA Modules page.
	__3.  Check that the MQTest SCA module is started.
	__4.  Open MQ Explorer, if it is not already open.  Remember if you are running on Windows Vista you must run the MQ Explorer as the administrator.
	__5.  Expand Queue Managers > MyQM > Queues.
	__6.  Right click InputQ and select Put Test Message.
	__7.  Enter three comma separated fields for the customer data.
	__8.  Click Put Message.
	__9.  Click Close.
	__10.  The tool should automatically refresh the list of queues in a few seconds. Alternatively, click the Refresh toolbar button.
	__11.  The Current queue depth for the OutputQ should become 1.
	__12.  Right click OutputQ and select Browse Messages.
	__13.  Double click the message to view its contents.
	__14.  Click the Data property from the list on the left.
	__15.  The XML message is shown the the Message data field. To better view the message, copy the data and paste it in notepad.
	__16.  Click OK to close close the message.
	__17.  Click Close in the Message browser window and close the MQ Explorer.
	__18.  Logout the admin console and close any open browser.

	Part 9 -  Review

	Lab 14 -  Deploying and Configuring JCA Adapters
	Part 1 -  Understanding the Adapter Architecture
	Part 2 -  The Business Logic of the Sample Application
	Part 3 -  Deploy the Application
	__1.  Login in the admin console as wasadmin.
	__2.  Stop your Process Server instance.
	__3.  Using the steps that should be already familiar to you deploy the EAR file C:\LabFiles\AdapterExampleApp.ear.
	__4.  Save changes and wait for synchronization.

	Part 4 -  Configure the Inbound Adapter
	__1.  In the list of SCA modules, click AdapterExample.
	__2.  Expand the imports and exports as shown below.
	__3.  In the left hand side, click Applications → Application Types → WebSphere enterprise applications to view the list of applications.
	__4.  Click AdapterExampleApp.
	__5.  Click Manage Modules.
	__6.  Click the RAR module IBM WebSphere Adapter for Flat Files.
	__7.  Click Resource Adapter.
	__8.  Click J2C activation specifications.
	__9.  Click AdapterExample.FlatFileInbound_AS.
	__10.  Click J2C activation specification custom properties.
	__11.  Note that the eventDirectory property is currently set to C:\dev\in.
	__12.  Click eventDirectory.
	__13.  Set the value to C:\temp\in
	__14.  Click OK.

	Part 5 -  Configure the Outbound Adapter
	__1.  In the left hand side, click WebSphere enterprise applications to view the list of applications.
	__2.  Click AdapterExampleApp.
	__3.  Click Manage Modules.
	__4.  Click the RAR module IBM WebSphere Adapter for Flat Files.
	__5.  Click Resource Adapter.
	__6.  Recall, outbound adapter is configured using the connection factory. Click J2C connection factories.
	__7.  Click AdapterExample.FlatFileOutbound_CF.
	__8.  Click Custom properties.
	__9.  Set the values of various properties as follows:
	__10.  Save changes.

	Part 6 -  Test the Application
	__1.  Create these folders if they do not exist.
	C:\temp
	C:\temp\in
	C:\temp\out
	__2.  Start the Process Server instance.
	__3.  A sample input file is made available as C:\LabFiles\file_in.xml. Open the file to have a look. 
	__4.  Close the file.
	__5.  Copy the C:\LabFiles\file_in.xml file into C:\temp\in. (After a couple seconds the file will disappear)
	__6.  Have a look at C:\temp\out. There should be a file called Customer.1.xml
	__7.  Copy the input file to C:\temp\in again. This will create Customer.2.xml in the output folder.
	__8.  Have a look at C:\temp\Sequence.txt. It should have the current sequence number.
	__9.  Close all open files.
	__10.  Logout the admin console and close the browser.

	Part 7 -  Review

	Lab 15 -  Deal with Failed Processes
	Part 1 -  Test a Process Instance Failure Scenario
	__1.  Open a browser and log on to the Administrative Console as wasadmin.
	__2.  Make sure that your Process Server instance is running and start it if it is not.
	__3.  Stop the ClaimApp application, which serves as both the process client and web service application.  Do this from Applications → Application Types → WebSphere enterprise applications.
	__4.  Open a new browser and access the BPC Explorer and login as wasadmin
	__5.  Click Currently Valid under the Process Templates heading.
	__6.  Check the box next to ExpenseClaimDev and click the Start Instance button to create a new process instance.
	__7.  The Process Input Message page will be displayed, which is used to start a process instance.  Enter a claim for under $200.  Note the following:
	__8.  Click the Submit button at the top of the page.
	__9.  There are many ways to view the instance.  Do one of the following:
	__10.  Verify that the process instance failed (i.e., is in the Failed state). Be patient it can take a few minutes for the process to fail.
	__11.  Click on the process instance name.  
	__12.  Click on the Activities tab.  
	__13.  Verify that when the process instance ran the ApproveClaim activity, it failed. 
	__14.  The failure occurred because the process instance was unable to contact the web service, since the web service application was stopped.  To verify this, open your server's SystemOut.log file, scroll to the bottom, and search upwards for the following message:
	__15.  Close the log file.
	__16.  Back in the Administrative Console, start the ClaimApp application.
	__17.  To restart the process instance, click the Restart button in the Process Instance page of the BPC Explorer.
	__18.  Verify that the process instance is now in the Running state.  You may need to click on the Process Instances → Started By Me link to refresh the status.
	__19.  Click on the process instance name.  Then click on the Activities tab.  
	__20.  Verify that the instance is now waiting for receipt arrival.  If it is not follow the steps to go back to the main list and come back to the list of activities to give it a minute to reach that state.
	__21.  Complete the claim by accessing the following URL: 
	__22.  Enter the claim id that you input earlier and click Log Receipts.  Remember that you can use the 'Process Input Message' tab of the process instance in the BPC explorer to get the claimId you had used.
	__23.  Open your server's SystemOut.log file, scroll to the bottom, and verify that you see the following messages:
	__24.  Close the log file.
	__25.  Back in the BPC Explorer, verify that the process instance is now in the Finished state (this may take a minute or two).  This confirms everything's working.
	__26.  Delete the process instance.  You can only do this from the 'Administered By Me' page.
	__27.  You may want to stop your Process Server instance to improve performance in the next lab.
	__28.  Log out of the Administrative Console and the BPC and close any open browsers.

	Part 2 -  Review

	Lab 16 -  Recovering a Failed Process
	Part 1 -  Modify Activity to Stop When An Error Occurs
	__1.  Open WID.
	__2.  Open the Business Integration perspective if it is not already.
	__3.  Close all open files.
	__4.  In the Business Integration view, expand ExpensePhase2 → Integration Logic → Processes → Process and double click on ExpenseClaimDev.
	__5.  In the editor, right click in a blank area of the process and select Show In → Properties View.
	__6.  In the Properties view, click on the Defaults tab.
	__7.  Change the value of 'Continue processing upon unhandled faults' from 'Yes' to 'No' as shown below.
	__8.  In the process editor above find and click on the 'Approve Claim' activity.  This is in the 'Yes' branch of whether the expense is within the maximum limit.
	__9.  Return to the Properties view which should now be showing the activity properties and click on the Server tab at the left.
	__10.  Change the value of 'Continue processing upon unhandled faults' from 'Yes' to 'Same as Process' as shown below.
	__11.  Save your changes.
	__12.  Close the editor.

	Part 2 -  Export and Install New EAR File
	__1.  Click the Problems view at the bottom of WID and make sure there are no errors. 
	__2.  Next we will export an EAR file for the revised business process application. Right click on the ExpensePhase2 project in the Business Integration view and select Export.
	__3.  In the Export wizard, select Business Integration → Integration modules and libraries.
	__4.   Click Next. 
	__5.  Accept the defaults on the Integration Module Export page and click  Next again.
	__6.  In the Specify the File Names and Target Directory dialog, enter the following:
	__7.  Click Finish.
	__8.  Exit WID.
	__9.  Make sure your Deployment Manager and Node Agent are running.
	__10.  Open a browser and log on to the Administrative Console as wasadmin.
	__11.  Start your Process Server instance if you stopped it to improve performance.
	__12.  Logout of the admin console since the scripts you will run will make configuration changes and may not get picked up if you are also logged into the admin console.
	__13.  Open a command prompt.
	__14.  Change directories to <WPS_ROOT>\ProcessChoreographer\admin.  
	__15.  Enter the following command to delete any process and task instances, stop the process and task templates, and uninstall the existing ExpensePhase2App application.  Make sure to enter this as one command even though it wraps below.
	__16.  Verify that the script printed the message:
	__17.  Change directories to the <DM_PROFILE_ROOT>\bin.
	__18.  Install the business process application (ExpensePhase2App) using the following wsadmin commands in interactive mode:
	__19.  Now enter the following command.  Make sure to enter it on one line and replace the <LABFILES_DIR> variable with a value.
	__20.  Verify that the script prints the message:
	__21.  While still in the wsadmin environment save your changes by typing:
	__22.  Type exit to exit the wsadmin scripting environment.
	__23.  Close the command prompt window.
	__24.  Open a browser and log on to the Administrative Console as wasadmin.
	__25.  Go to System administration → Nodes and check that your node is synchronized.  If it is not check the box and press the Full Resynchronize button.
	__26.  Look the Applications installed and note that ExpensePhase2App is stopped.
	__27.  Start the ExpensePhase2App application.

	Part 3 -  Test a Process Instance Failure Scenario
	__1.  In the Administrative Console, stop the ClaimApp application.
	__2.  Open a new browser and access the BPC Explorer.
	__3.  Execute pigtail.exe which is located inside of <LABFILES_DIR>. Pigtail is a utility which is the visual equivalent of the Unix tail command.  
	__4.  Select File > Open from the menu bar.
	__5.  Navigate to your server cluster's SystemOut.log file, and click Open.  
	__6.  In pigtail, click the Clear button so you're starting with an empty display.  
	__7.  In the BPC Explorer, click Currently Valid under the Process Templates heading.
	__8.  Check the box next to ExpenseClaimDev and click the Start Instance button to create a new process instance.
	__9.  Submit a claim for under $200.  Follow the same steps as you did in the previous lab.
	__10.  Verify that the process instance is in the Running state.  You can do this from the 'Process Instances Started By Me' page.
	__11.  Verify that when the process instance ran the ApproveClaim activity, it stopped (i.e., in the Stopped state). This may take a few minutes.
	__12.  Look in pigtail.  Notice that a bunch of messages were printed.  Make sure you see the following message at the bottom of the screen, since the web service application is stopped:
	__13.  In the BPC Explorer, click the ApproveClaim link.
	__14.  In pigtail, click the Clear button so you can clearly see what happens when you restart the operation.
	__15.  Click the Restart button in the BPC Explorer to navigate to the Activity Restart page.
	__16.  In the BPC Explorer, notice the following:
	__17.  Now click the Restart button.
	__18.  Look in pigtail and notice that the error message you saw before, as we were expecting, is reprinted.  Wait a minute just in case it takes a little longer to generate the error.
	__19.  Back in the Administrative Console, start the ClaimApp application.
	__20.  In pigtail, click the Clear button.
	__21.  In the BPC Explorer, restart the ApproveClaim activity.  
	__22.  Click the Administered by Me link after clicking the Restart button.
	__23.  Look in pigtail.  You should see messages indicating the claim was approved.
	__24.  Verify that the process instance is still in the Running state and that the instance is now waiting for receipt arrival.
	__25.  Terminate and delete the process instance.
	__26.  Log out of the Administrative Console and BPC and close any open browsers.
	__27.  Close pigtail.

	Part 4 -  Review

	Lab 17 -  Tracing
	Part 1 -  Enable Tracing
	__1.  Open a browser and log on to the Administrative Console as wasadmin.
	__2.  If it is not started already, start your Process Server instance.
	__3.  Expand Troubleshooting and click the Logs and Trace link.
	__4.  On the Logging and Tracing page, click the MyTopology.AppTarget.<hostname>Node01.0 link.
	__5.  On the General Properties page, click the Diagnostic Trace link.
	__6.  On the Diagnostic Trace Service page, notice that the File radio button is selected and that the trace events are stored to the trace.log file, which is located in the <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<hostname>Node01.0 directory, by default.
	__7.  Click the Change Log Detail Levels link under the Additional Properties heading to set the log detail (trace) level.
	__8.  We want our changes to take effect immediately, so click the Runtime tab.
	__9.  Click on the '+' next to [All Components] to expand all the available components.
	__10.  The Business flow manager, which makes up the Business process container, corresponds with the package com.ibm.bpe.*.  Scroll down inside the list of components until you see com.ibm.bpe.*.  
	__11.  Click on it and select All Messages and Traces from the drop-down list.  
	__12.  Scroll to the top of the window and observe that there are two trace strings listed now separated by a colon:
	__13.  The Human task manager, which makes up the Human task container, corresponds with the package above (com.ibm.bpe.*) and com.ibm.ws.staffsupport.*.  Scroll down inside the list of components until you see com.ibm.ws.* and expand it.  
	__14.  Scroll further down and click on com.ibm.ws.staffsupport.* and select All Messages and Traces from the drop-down list.  
	__15.  Scroll to the top of the window and observe that there are three trace strings listed now separated by a colon:
	__16.  Notice there is a checkbox at the top of the page to save the changes to the configuration.  We only want these changes to take effect at runtime, since tracing reduces the performance of the server due to increased I/O; therefore, leave the box unchecked.
	__17.  Scroll to the bottom of the window and click OK to place these runtime changes into effect.

	Part 2 -  Exhibit a Problem
	__1.  In the Administrative Console, stop the ClaimApp application.
	__2.  Open a new browser and login to the BPC Explorer.  
	__3.  Open the trace.log file using pigtail.  pigtail.exe is located in <LABFILES_DIR>.
	__4.  In the BPC Explorer, click Currently Valid under the Process Templates heading.
	__5.  Check the box next to ExpenseClaimDev and click the Start Instance button to create a new process instance.
	__6.  In pigtail, click the Clear button so you're starting with an empty display.  This way it's easy to see what events are printed to the trace.log file in response to any actions you take in the BPC Explorer.  
	__7.  Submit a claim for under $200.
	__8.  In pigtail, wait until the events finished getting printed.  This may take a moment. Leave it running for like 30 seconds,  then, select Watch > Pause from the menu bar to prevent any additional events from being displayed when using the BPC Explorer.
	__9.  In the BPC Explorer, verify that the process instance is in the Running state and the ApproveClaim activity is in the Stopped state.
	__10.  In pigtail, scroll to the top of the window.  Notice the events are very low level and include database calls, SOAP calls, and calls to individual methods that comprise the BPC.
	__11.  Scroll down a little bit and notice the following trace event.  It displays information that's used to create a process instance, based on the input you supplied using the BPC Explorer.  Also, notice that the package corresponds with one of the ones (com.ibm.bpe.*) that you configured for tracing. 
	__12.  Scroll down further and you'll notice the following event.  The event displays information about the process template, including its id (PTID), its name, its display name, the application it belongs to, whether or not the process is long running, and its state (started). 
	__13.  Scroll down further (probably about ¾ to the end) and you'll notice the following event.  It contains information about the ApproveClaim activity template, which is part of the process template above, since the PTIDs match.   This includes the activity template's name, its display name, its continue on error setting (false), and its state (running).
	__14.  Scroll down further and you'll notice the following event.  It displays information about an instance of the activity template above, since the ATIDs match.  This includes its id (AIID), its process instance id (PIID), its state (running), when it was started, and its continue on error setting  (which should initially match that of the activity template).
	__15.  All of the trace events you've seen up to this point have been interesting, but have not helped you determine what went wrong.  To view what went wrong, scroll to the bottom of the window and then scroll up a little bit.  Notice the following event.  The event displays information about the activity instance above, since the AIIDs match.  This includes that the activity is stopped, when it was started, the reason it was stopped and when it was last modified.
	__16.  Scroll a little higher and you'll see a trace event related to the web services error:
	__17.  In the Administrative Console, start ClaimApp.
	__18.  In the BPC Explorer, navigate to the ApproveClaim process instance's Activity Restart page but do not yet restart the activity.
	__19.  In pigtail, select Watch > Resume from end from the menu bar.  Pigtail will scroll to the bottom and display any new events from the trace.log file.  Wait a minute while it catches up.
	__20.  Click the Clear button.
	__21.  Click the Restart button in the BPC Explorer to restart the ApproveClaim activity.
	__22.  Look in pigtail and select Watch > Pause from the menu bar.
	__23.  Go to the bottom. Scroll a little bit higher and you should see the following event indicating the process instance is in a waiting state (waiting for the arrival of receipts).  This is what we expected.  
	__24.  Terminate and delete the process instance.
	__25.  Select Watch → Resume from end in Pigtail to unpause the log.

	Part 3 -  Exhibit Another Problem
	__1.  In pigtail, click the Clear button.
	__2.  Submit a claim for over $200 using the ClaimApp application:
	__3.  In pigtail, wait until the events finished getting printed, it will take like a minute.  Then, click the Clear button.
	__4.  Keep your eyes on pigtail.  After two minutes, pigtail should display a bunch of events related to the "Review by Manager" activity expiring. 
	__5.  Wait until all the messages appear. Then select Watch > Pause from the menu bar to prevent any additional events from being displayed when using the BPC Explorer.
	__6.  In the BPC Explorer, verify that the process instance that was created failed and that the ReviewbyManager activity expired.
	__7.  In pigtail, scroll to the top of the window.  Then scroll down through the events.  
	__8.  Scroll further down and notice there's an activity instance, which is an instance of the ReviewbyManager activity template, you just viewed.  You can tell this is true, because the value of the ATID matches.  Other relevant information displayed includes the activity instance id (AIID), the process instance id (PIID), when the activity was started, it's current state (running), when it expires (two minutes later), and its continue on error setting (which should initially match that of the activity template).
	__9.  Scroll down further and you'll see the following activity instance.  Notice that it's the same activity instance as the one you just viewed, since the AIID's match.  Also, notice that the activity expired.   You can see when the instance was started, when it was scheduled to expire, and when it was last modified.
	__10.  Scroll to the bottom of the window and then scroll up a little bit.  You'll see the following trace event.  Notice that the PIID matches the PIID for the activity instance you just viewed, which means this is the correct process instance.  Most importantly, notice that the process instance failed.  This is what we expected.  You'll also see when the process was started and when it was last modified, and its name.
	__11.  Close pigtail.
	__12.  Terminate and delete all process instances and human tasks.  You can do this from the 'Process Instances → Administered By Me' and 'Task Instances → Administered By Me' links.

	Part 4 -  Disable Tracing
	__1.  In the administrative console, expand Troubleshooting and click the Logs and Trace link.
	__2.  On the Logging and Tracing page, click the MyTopology.AppTarget.<localhost>Node01.0 link.
	__3.  On the General Properties page, click the Change Log Detail Levels  link.
	__4.  On the Change Log Detail Levels page, click the Runtime tab.
	__5.  For simplicity, change the log detail level back to its default value of *=info by deleting the additional trace strings.
	__6.  Scroll to the bottom of the page and click OK.
	__7.  Log out of the Administrative Console and BPC.
	__8.  Close any browsers.

	Part 5 -  Review

	Lab 18 -  Routing Requests Through a Web Server
	Part 1 -  Install the Web Server
	__1.  Make sure you are logged in as an administrative user.
	__2.  Open a Windows Explorer window.
	__3.  Navigate to the <WAS_SOFTWARE_DIR>\Supplement\IHS directory substituting the <WAS_SOFTWARE_DIR> variable location mentioned in the beginning of these labs.  Check with your instructor if you can't find the directory listed.
	__4.  Double click the install.exe file to start the launchpad.
	__5.  Click Next on the Welcome screen.
	__6.  Accept the license and click Next.
	__7.  Once the system passes the prerequisite checks press the Next button.  
	__8.  Write down the installation directory for the <IHS_ROOT> variable in the list of directory paths at the beginning of these labs.  This directory will be used later in the labs.  Leave the default installation directory as is and press the Next button.
	__9.  Accept the default values for the HTTP port and administration port.  Click the Next button.
	__10.  Change the way the Windows service logs on to “Log on as local system account” as shown below.  Press the Next button.
	__11.  Leave the option for “Create a user ID for IBM HTTP administration server authentication” checked.  Fill in a user ID and password of 'ihsadmin'. Click the Next button.
	__12.  Leave the option for “Install the IBM HTTP Server Plug-in for IBM WebSphere Application Server” option checked.  Make sure that the Host name listed matches the value for the <HOSTNAME> variable you wrote down in the lab notes section.  It is important that it doesn't have 'localdomain' on the end.  Click the Next button when you have checked the settings on this page.
	__13.  Press the Next button in the summary screen to start the installation.
	__14.  Press the Finish button to close the installation wizard.
	__15.  Open the Windows Control Panel by selecting Start -> Control Panel or Start -> Settings -> Control Panel depending on your Windows version.
	__16.  If you are using Windows XP or Vista switch to the “Classic View” by clicking the link on the left side of the Control Panel.
	__17.  Double click the Administrative Tools group to open this category.
	__18.  Double click the Services icon to open the list of services.  Accept any Windows security prompts if presented.
	__19.  Right click the following services and select Start from the popup menu if they are not already started:
	__20.  Close the list of services.

	Part 2 -  Define Web Server in WebSphere Admin Console
	__1.  Start your Deployment Manager and Node Agent if they are not running.
	__2.  Log into the admin console.
	__3.  In the navigation pane of the Admin Console select System Administration -> Nodes. 
	__4.  Click on the Add Node button above the list of nodes. 
	__5.  Select the Unmanaged node radio button and press the Next button.
	__6.  Under General Properties, enter the Name as IHSNode. Enter the Host Name of the web server machine. This should be the value for the <HOSTNAME> variable that you have written down in the Lab Notes section of the lab guide.  Leave the default for the Platform Type of Windows.
	__7.  Check that your options match that above and press the OK button.
	__8.  Click the Save link in the messages at the top of the Admin Console and be sure your changes are synchronized with the nodes.
	__9.  In the navigation pane of the Admin Console select Servers → Server Types → Web servers. 
	__10.  Press the New button above the empty list of web servers.
	__11.  On Step 1: Select a node, choose the IHSNode from the drop down list.  Enter the Server name as webserver1.  Once your values match that shown below press the Next button. 
	__12.  In Step 2: Select a Web server template, select the IHS radio button as the web server template and press the Next button.
	__13.  In Step 3: Enter the properties for the new Web server, enter the following information.  Substitute the value of the <IHS_ROOT> variable with the value you had written down in the Directory Paths section in the lab guide.
	__14.  Check that your values for the new web server match that shown for the last step. Double check the Service name as this is a common source of error.  Press the Next button when everything matches.
	__15.  In Step 4: Confirm new Web Server, press the Finish button to create the web server. This will take some seconds.
	__16.  Click the Save link in the messages at the top of the Admin Console and be sure your changes are synchronized with the nodes.

	Part 3 -  Configure Virtual Host on Web Server
	__1.  Navigate to the Servers → Server Types → Web Servers section of the admin console.  
	__2.  Click the link for webserver1 from the list.
	__3.  Under the Additional Properties click the link for Configuration File.  If you get an error displaying the configuration file let your instructor know as this likely means there is a problem with your IHS administration password.
	__4.  Scroll to the very end of the file and add a few blank lines.
	__5.  Add the following text exactly as it appears below at the end of the configuration file.  
	__6.  Check that your configuration appears as below and press the OK button.
	__7.  Go back to the list of web servers by navigating to the Servers → Server Types → Web Servers section of the admin console.
	__8.  Check the box next to the webserver1 entry and click the Stop button.  Make sure you get a message about the server stopping.
	__9.  Check the box next to webserver1 and click the Start button.  If you have trouble starting the web server check your configuration file syntax.
	__10.  Logout of the Admin Console.

	Part 4 -  Update Network Setup
	__1.  Open a Windows Explorer window or use one you already have open.
	__2.  Navigate to the Windows Root directory.  This is usually C:\WINNT or C:\WINDOWS.
	__3.  Under this directory find the system32\drivers\etc directory.  In this directory there should be a ‘hosts’ file.
	__4.  Copy the 'hosts' file and rename the copy to something like 'hosts-backup'.  This will ensure you can restore the original if needed.
	__5.  Check that the file is not marked as read only by viewing the file properties.
	__6.  Double-click on the ‘hosts’ file and open it with WordPad.  WordPad is much better to use than other text editors such as Notepad because it saves files without adding a ‘.txt’ extension.
	__7.  If you do not already have a line that starts with the IP address 127.0.0.1 add it. 
	__8.  Add to this line hostnames of localhost and was.myhost.com with spaces between the IP address and each of the hostnames.  The file should be similar to this: 
	__9.  Save the file and close WordPad.
	__10.  Open a Command Prompt window.  You can do this by selecting Start -> Run, entering cmd and then pressing OK.
	__11.  Be sure you can ping the new host name.  Enter the command ping was.myhost.com.  Be sure you don’t get an “unknown host” or “request timed out” error message.  
	__12.  Close the Command Prompt.
	__13.  Open an Internet Explorer window.
	__14.  Open the Internet Options dialog.  This is usually done by selecting Tools -> Internet Options.
	__15.  Click on the Connections tab and click the button for LAN Settings.
	__16.  If your settings are configured to use a proxy server, similar to that shown below, press the Advanced button to configure advanced proxy settings and go to next step. If not click Cancel and skip the next step.
	__17.  Add a local exception for the 'was.myhost.com' address as shown below.  If there are other exceptions in the list be sure to put a semicolon (;) between the addresses.
	__18.  Click any OK buttons to close the Internet Options dialogs.
	__19.  Enter the URL http://was.myhost.com in the address bar of the browser and hit Return. You should see the homepage of the IBM HTTP Server running on your machine.  If you do not see this screen contact your instructor.
	__20.  Close out any extra command prompts, web browsers, or Windows Explorer windows you may have open.

	Part 5 -  Configure Virtual Host in WebSphere
	__1.  Login to the WebSphere Admin Console.
	__2.  In the WebSphere Admin Console expand the Environment navigation group and click the link for Virtual hosts.
	__3.  In the list of virtual hosts click the link for the 'default_host'.
	__4.  To the right under Additional Properties, click the link for Host Aliases.
	__5.  Right now you can see there are lots of host aliases.  Check the box next to all of them and press the Delete button.
	__6.  Click the New button above the empty list of host aliases.
	__7.  Change the Host Name to was.myhost.com and leave the default port of 80.  Click the OK button when you have the properties filled in as below.
	__8.  The new host alias now appears in the list.  
	__9.  Click the New button again above the list of host aliases.
	__10.  Change the Host Name to was.myhost.com and change the port to 443.  Click the OK button when you have the properties filled in as below.
	__11.  Click on the Save link in the list of messages near the top of the main Console area.

	Part 6 -  Generate Plug-in Configuration
	__1.  In the navigation pane of the Admin Console select Servers → Server Types → Web servers.
	__2.  Check the checkbox next to webserver1 and click the Generate Plug-in button.
	__3.  Check the checkbox next to webserver1 and click the Propagate Plug-in button.
	__4.  Make sure that you get a successful message about propagating the plugin config file.  If you do not it is likely that the settings for the web server administration service including port, user ID, and password are not correct.  Contact your instructor to help resolve this.
	__5.  Check the checkbox next to webserver1 and click the Stop button.
	__6.  Check the checkbox next to webserver1 and click the Start button.
	__7.  Make sure that the webserver1 is shown as started.  If it is not contact your instructor.

	Part 7 -  Exhibit Problem
	__1.  In the Admin Console start your Process Server instance.  If it were already running you must restart it to pick up the changes to the virtual host configuration.  Wait for the server to start completely.
	__2.  Open a browser and navigate to the following URL.  Note that this URL is slightly different than the previous one you have used as we need to go through the web server.
	__3.  Submit a request for under $200.
	__4.  Immediately in the browser you should see the error below.  This indicates the claim web application is not able to even submit the claim to the business process as it is trying to invoke the web service through 'localhost:9080'.
	__5.  Access the BPC Explorer by opening a browser and navigating to the following URL.  Note again the URL is different because the BPC Explorer application is also being routed through the web server
	__6.  Login with the wasadmin id as you have done before.
	__7.  Open the SystemOut.log file of your server in the pigtail utility.
	__8.  In pigtail, click the Clear button so you're starting with an empty display.  
	__9.  In the BPC Explorer, click Currently Valid under the Process Templates heading.
	__10.  Check the box next to ExpenseClaimDev and click the Start Instance button to create a new process instance.
	__11.  Enter a claim for under $200.  Remember the following:
	__12.  Click the Submit button at the top of the page.
	__13.  Check the box next to ExpenseClaimDev and click the Instances button.
	__14.  Verify that the process instance is in the Running state and the ApproveClaim activity is in the Stopped state.
	__15.  Switch to pigtail and you should be able to find a message that the activity was stopped because the process could not connect to the service.  Notice that the URL listed is one of the imports from the business process.
	__16.  Terminate and delete all process instances.  Also terminate and delete all tasks listed at 'Task Instances → Administered By Me'.
	__17.  Close the pigtail utility.

	Part 8 -  Install a Dynamic Client Application
	__1.  Back in the Admin Console, select Applications -> Application Types -> WebSphere enterprise applications.
	__2.  Check the box next to the 'ClaimApp' application and press the Update button.
	__3.  Browse and select the <LABFILES_DIR>\ClaimApp-DynamicBinding.ear file, then click Open.
	__4.  Click the Next button.
	__5.  Click Next again to accept the "Fast Path" installation.
	__6.  Click on the Step 3 link to run through to the end of the installation wizard. This will take you directly to the Summary page.
	__7.  Click on the Finish button.
	__8.  Once the application has been installed, click on the Save link at the bottom of the page to save these changes to the master configuration.
	__9.  Click the OK button to confirm the node synchronization.

	Part 9 -  Update Client Bindings to Process
	__1.  Back in the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__2.  Click the link for the ClaimApp application.
	__3.  Scroll down and in the list of 'Web Services Properties' on the right, click the link for Service clients.
	__4.  Click the link for the Module on the right.  Either link for the module will work.  If you click the service name on the left it will take you to web service policies which are not being used for this web service.
	__5.  In the list of module 'Web Services Properties' on the right, click the link for Web services client bindings.
	__6.  Click the 'Edit' link in the 'Port Information' column.  Make sure you do not click the link in the 'mappings' column.
	__7.  As you can see from the address listed this is why the client did not work.  It was still using 'localhost:9080' which is not the URL the web service is available on now.
	__8.  Change the hostname of the URL so the entire URL is 'http://was.myhost.com/ExpensePhase2Web/sca/ExpenseClaimProcessExport1' without the quotes.  Once your value is set as shown below press the OK button.  Note the screenshot below does not show the end of the URL but the hostname portion is the only thing you need to update.
	__9.  Click the Save link in the messages at the top of the Admin Console.
	__10.  Click the OK button to confirm the node synchronization.

	Part 10 -  Update SCA Export Bindings
	__1.  Navigate to Applications → Application Types → WebSphere enterprise applications.
	__2.  Check the box next to the ExpensePhase2App application and press the Update button.
	__3.  Use the Browse button to select the '<LABFILES_DIR>\ExpensePhase2App_StopActivitySolutions.ear' file and open it.
	__4.  Once the file is selected as shown below press the Next button.
	__5.  Click Next again to accept the "Fast Path" installation.
	__6.  Click on the Step 3 link to run through to the end of the installation wizard. This will take you directly to the Summary page.
	__7.  Click on the Finish button.
	__8.  Once the application has been installed, click on the Save link at the bottom of the page to save these changes to the master configuration.
	__9.  Click the OK button to confirm the node synchronization.

	Part 11 -  Update SCA Import Bindings
	__1.  Expand the Applications group and click on the SCA Modules link.
	__2.  Check the box next to the 'ExpensePhase2' module and click the Stop button.
	__3.  Click the ExpensePhase2 link to go to the SCA module configuration page.
	__4.  Expand Imports under the Module components heading. 
	__5.  Expand ExpenseManagementWebService → Binding and click on the JAX-Web Service link.
	__6.  To the far right of the Target endpoint address, click the Edit button.
	__7.  Change the URL host and port from 'localhost:9080' to 'was.myhost.com' so the URL appears as shown below and click the OK button.
	__8.  Click on ExpensePhase2 in the breadcrumb trail.  
	__9.  Expand AcmeQuickAccounting → Binding and click on the JAX-Web Service link.  It is possible the order of the imports switched in the display so make so to pick the correct link.
	__10.  To the far right of the Target endpoint address click the Edit button.
	__11.  Change the first part of the URL from 'https://localhost:9443' to 'http://was.myhost.com' as shown below and click the OK button.  Be sure to change the protocol to http from https as the web server does not have SSL configured.
	__12.  Save your changes and wait for the synchronization to occur.
	__13.  Expand the Applications group and click on the SCA Modules link.
	__14.  Check the box next to the 'ExpensePhase2' module and click the Start button.

	Part 12 -  Update Web Service HTTP Endpoint
	__1.  Navigate to Applications → Application Types → WebSphere enterprise applications.
	__2.  Click the link for the ClaimApp application.
	__3.  Scroll down and in the list of 'Web Services Properties' on the right, click the link for Provide HTTP endpoint URL information.
	__4.  Fill in 'http://was.myhost.com' without the quotes for the HTTP URL prefix value next to the module listed and press the OK button.  Note that you can just type the value in directly and you do not need to use the options and Apply button above the settings.
	__5.  Click the Save link in the messages at the top of the Admin Console and wait for sync.
	__6.  Go back to the list of applications and click the link for the ClaimApp application.
	__7.  Scroll down and in the list of 'Web Services Properties' on the right, click the link for Publish WSDL files.
	__8.  On the page that appears click the link for the zip file of WSDL files.
	__9.  If prompted to open or save the file, open it with zip file software if possible.  If you can't open it directly save it first and then open the zip file.
	__10.  Expand the folders of the zip file if needed until you see the 'Interface' folder.
	__11.  Open the 'ExpensePhase1_ExpenseManagementSystemImport1.wsdl' file with a text editor like WordPad.  If you need to, extract the file first and then open it.
	__12.  Scroll down in the WSDL file and notice at the end that the SOAP address uses a location that starts with 'http://was.myhost.com'.  If we did not set the endpoint URL information for the service the WSDL package to publish would not be useable as it may have an incorrect address.
	__13.  Close the WSDL and the zip file.
	__14.  Navigate to Applications → Application Types → WebSphere enterprise applications.
	__15.  Click the link for the AcmeApp application.
	__16.  Scroll down and in the list of 'Web Services Properties' on the right, click the link for Provide HTTP endpoint URL information.
	__17.  Fill in 'http://was.myhost.com' without the quotes for the HTTP URL prefix value next to the module listed and press the OK button.
	__18.  Click the Save link in the messages at the top of the Admin Console.
	__19.  Go back to the list of applications and click the link for the AcmeApp application.
	__20.  Scroll down and in the list of 'Web Services Properties' on the right, click the link for Publish WSDL files.
	__21.  On the page that appears click the link for the zip file of WSDL files.
	__22.  If prompted to open or save the file, open it with zip file software if possible.  If you can't open it directly save it first and then open the zip file.
	__23.  Expand the folders of the zip file if needed until you see the 'wsdl' folder.
	__24.  Open the 'AcmeQuickAccounting.wsdl' file with a text editor like WordPad.  If you need to, extract the file first and then open it.
	__25.  Scroll down in the WSDL file and notice at the end that the SOAP address uses a location that starts with 'http://was.myhost.com'.  
	__26.  Close the WSDL and the zip file.

	Part 13 -  Test the Updated Configuration
	__1.  Make sure your Process Server instance is running.
	__2.  Open a browser and navigate to the following URL. 
	__3.  Submit a request for under $200.
	__4.  Make sure you get a message that the claim was successfully submitted.  This proves that the client is using the address of the web server to access the process correctly.
	__5.  Copy or write down the claim ID from the response.
	__6.  Open a browser and navigate to the following URL. 
	__7.  Enter the claim ID and submit the form and make sure you get a success message.
	__8.  Access the BPC Explorer by opening a browser and navigating to the following URL.  
	__9.  Login with the wasadmin id as you have done before.
	__10.  In the BPC Explorer, click Currently Valid under the Process Templates heading.
	__11.  Check the box next to ExpenseClaimDev and click the Instances button to list the instances.
	__12.  Click the link for the process instance listed and click the 'Activities' tab when the instance detail appears.  Verify that all activities are shown as "Finished".  This verifies that the process was able to communicate with the services, something it couldn't do before it used the web server hostname.
	__13.  Delete the process instance by pressing the Delete button on the page showing the instance or from the list of process instances to keep the list of instances clear.
	__14.  Log out of the BPC Explorer.
	__15.  Stop the Process Server instance and log out of the Admin Console.

	Part 14 -  Summary

	Lab 19 -  Clustering Process Server
	Part 1 -  Create A New Clustered Server
	__1.  Start your Deployment Manager and Node Agent if they are not already running.
	__2.  Login to the admin console.
	__3.  In the left pane, select Servers -> Clusters -> WebSphere application server clusters.  
	__4.  Stop the cluster if it is running which will stop the existing server.  Refresh the status of the cluster until it is listed as stopped.
	__5.  Select Servers -> Deployment Environments.
	__6.  Click the link for MyTopology.
	__7.  Click the link for Deployment Topology on the right.
	__8.  On the box under 'Application Deployment Target' for the line of the existing node, change the value to '2' from '1' as shown below and click the OK button. This  will take some time.
	__9.  Click on the Save link to save the configuration.  You can ignore the message about the deferred configuration because we already completed the configuration of the databases mentioned in one of the first labs.
	__10.  Select Servers -> Server Types -> WebSphere application servers.
	__11.  Notice there are two servers now both on the same node and the only difference in them is the last digit in the name which is an index of the servers of that type on the node.

	Part 2 -  Generate Plug-in Configuration
	__1.  In the navigation pane of the Admin Console select Servers → Server Types → Web servers.
	__2.  Check the checkbox next to webserver1 and click the Generate Plug-in button.
	__3.  Check the checkbox next to webserver1 and click the Propagate Plug-in button.
	__4.  Make sure that you get a successful message about propagating the plugin config file. 
	__5.  Check the checkbox next to webserver1 and click the Stop button.
	__6.  Check the checkbox next to webserver1 and click the Start button.
	__7.  Make sure that the webserver1 is shown as started.  If it is not contact your instructor.

	Part 3 -  Test New Server
	__1.  In the left pane, select Servers -> Server Types -> WebSphere application servers.
	__2.  Make sure that both servers are stopped and stop them if they are not.
	__3.  Check the box next to the second server, the one that ends in '..<node name>.1' and press the Start button.  Wait for the server to start completely.  Make sure not to start the first server (...Node01.0)  in the list.
	__4.  After the server is started click on the link for the '..<node name>.1' server to see the properties.
	__5.  Scroll down on the right and click the '+' sign next to the 'Ports' link to expand the list of ports.  Note that this server uses port 9081 which is not a default port.  This port is used to prevent conflict with the other server on the same node.
	__6.  From C:\LabFiles, run pigtail.exe
	__7.  Open in pigtail the log file of the new Process Server.  This should be <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<Node>.1\SystemOut.log.
	__8.  Press the Clear button to remove prior messages.
	__9.  Open a browser and navigate to the following URL.  
	__10.  Attempt to submit a request for under $200.  You should get a success message.  This proves the client application can submit a request for the process through the web server for the other server.
	__11.  Note or copy the claim ID.
	__12.  Open the URL below for the receipt application.  
	__13.  Enter the claim ID in the browser. 
	__14.  Click on Log Receipts.
	The browser should display the message Operation successfully completed. Enter another?
	__15.  Return to the pigtail window showing the server log of the new server.  You should see messages about the business process starting, calling the services like approveClaim, and the receipt notification.  This proves all process related events were handled by the new server.
	__16.  Access the BPC Explorer by opening a browser and navigating to the following URL.  
	__17.  Login with the wasadmin id as you have done before.
	__18.  Select 'Process Instances → Administered By Me' in the BPC Explorer.
	__19.  Click the link for the process instance listed and click the 'Activities' tab when the instance detail appears.  Verify that all activities are shown as "Finished".  This verifies that the process was able to communicate with the services even though the new server was the only one available.
	__20.  Delete the process instance by pressing the Delete button on the page showing the instance or from the list of process instances to keep the list of instances clear.
	__21.  Log out of the BPC Explorer.

	Part 4 -  Test Failover
	__1.  In the left pane, select Servers -> Clusters -> WebSphere application server clusters. 
	__2.  Check the box next to your cluster and press the Start button.  This will start the other server in the cluster.  
	__3.  You will see the message that the other cluster member is starting. Wait until the server starts.
	__4.  Refresh the cluster status until you get the green bold arrow. If you move your mouse over the icon it will show you the Started message.
	__5.  In the navigation pane of the Admin Console select Servers → Server Types → Web servers.
	__6.  Check the checkbox next to webserver1 and click the Stop button.
	__7.  Check the checkbox next to webserver1 and click the Start button.
	__8.  Navigate to Applications → Application Types → WebSphere enterprise applications.
	__9.  Check the box for the ClaimApp application and press the Stop button.
	__10.  Click the Refresh button.
	__11.  Check the status of the ClaimApp application. It should be stopped. 
	__12.  Now, check the box for the ClaimApp application and press the Start button.
	__13.  Click the Refresh button.
	__14.  Check the status of the ClaimApp application it should be started.
	__15.  From C:\LabFiles, run pigtail.exe
	__16.  Open in pigtail the log file of the original Process Server instance.  This should be <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<Node>.0\SystemOut.log.
	__17.  Press the Clear button to remove prior messages.
	__18.  Return to the pigtail utility showing the log file of the new Process Server that you left open.  This should be <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<Node>.1\SystemOut.log.
	__19.  Press the Clear button to remove prior messages.
	__20.  Expand the pigtail windows to see the file name in the titlebar.  This will help determine which server is doing what.
	__21.  Open a new browser and navigate to the following URL.  
	__22.  Clear out any messages in pigtail windows if there are any.
	__23.  Submit a request for under $200.  
	__24.  Note the claim ID for later.
	__25.  In one pigtail window you should see messages from the 'Claim Servlet' about submitting your claim.  Also notice that the outbound transport chain is using 'was.myhost.com:80' as we want it to.
	__26.  After some seconds you should see messages shown below that come from the services called by the business process.  You may see these in the same pigtail window or a different one.  Most likely they will come from the other server as the web server will try to keep things balanced out as it views the web service requests from the process as a "new" client.
	__27.  Access the BPC Explorer by opening a browser and navigating to the following URL.  
	__28.  Login with the wasadmin id as you have done before.
	__29.  Select 'Process Instances → Administered By Me' in the BPC Explorer.
	__30.  Click the link for the process instance that was just created that it should be in Running state.
	__31.  View the activities of the process instance and verify that the process is waiting for receipt arrival.  You may see the activities in a different order but the important detail is that the process was able to call the 'ApproveClaim' activity which calls one of the services from the imports.
	__32.  Clear out any messages in pigtail windows.  You may notice that all of your BPC Explorer requests go to the same server.
	__33.  Open the URL below for the receipt application.  Use the same browser or tab you used to submit the claim to make sure your sesion is kept and routed back to the same server to show the "sticky sessions" of the web server trying to route requests from each client back to the same server.
	__34.  Enter the claim ID in the browser. 
	__35.  Click on Log Receipts.
	The browser should display the message Operation successfully completed. Enter another?
	__36.  In the pigtail window that has been showing your interaction with the Claim web application you should see messages about sending the receipt information to the business process.
	__37.  In a pigtail window (either one is possible) you should also see messages from the 'AcmeQuickAcco' service about paying the employee.  This is the web service request from the process.
	__38.  Figure out which server has been processing your requests with the web application.  The server that is processing the web application requests is the one with messages from the ClaimServlet and ReceiptServlet.
	__39.  Return to the Admin Console and select Servers -> Server Types -> WebSphere application servers.  Login again if you have to.
	__40.  Check the box next to the server that was processing your requests for the web application and press the Stop button.
	__41.  Click OK if asked to confirm stopping the server.
	__42.  Wait until the status is shown as stopped  in the Server status feedback page and then click OK.
	__43.  Clear out any messages in pigtail windows.
	__44.  Open a new browser to:
	__45.  It may take a second but you should see that the other server starts processing your requests for the web application by looking at the pigtail window for the log.
	__46.  Submit a request for under $200.  Note the claim ID for later.
	__47.  This time you should see messages from the web application and from the services all in the pigtail window of the server that is still running.
	__48.  Open the URL below for the receipt application.  
	__49.  Enter the claim ID in the browser. 
	__50.  Click on Log Receipts.
	__51.  Back in the pigtail window you should see messages about sending the receipt information to the process and messages from the services called by the process.
	__52.  Stop all servers. 
	__53.  Logout from the admin console and BPC.
	__54.  Close all pigtail windows and browser windows.

	Part 5 -  Review

	Lab 20 -  SIB Messaging Engine HA
	Part 1 -  Configure Messaging Engine Policies
	__1.  Start your Deployment Manager and Node Agent if they are not already running.
	__2.  Log into the admin console.
	__3.  In the left pane, select Servers -> Clusters -> WebSphere application server clusters. 
	__4.  If your cluster is started or partially started check the box next to your cluster and press the Stop button.  This will make sure all servers are stopped.
	__5.  In the left pane select Service Integration -> Buses.
	__6.  Click on the link for the first bus in the list which should be 'BPC.<cellname>.Bus'.
	__7.  Under the 'Topology' section of additional properties select Bus members.
	__8.  Click on the link for 'MyTopology.AppTarget'.
	__9.  Check the box next to the listed messaging engine and press the Enable policy assistance button.
	__10.  Leave the default setting of 'High availability' and press the Next button.
	__11.  On the Summary page click the Finish button to create the policy.
	__12.  On the page that is displayed next, click the link for Messaging engine policy maintenance.
	__13.  Click the link for the policy that is listed.
	__14.  Enable the 'failback' property and the 'Preferred servers only' property and click the Apply button.  Make sure to use the Apply button to stay on the same page.
	__15.  In the additional properties for the policy click the link for Preferred servers.
	__16.  Select each server from the MyTopology.AppTarget cluster in the list on the left and use the Add button to move the server to the list on the right.  Use the Move up and Move down buttons to make sure the '...Node01.0' server is the first server listed.
	__17.  Once your settings match that shown above click the OK button.
	__18.  You should be back on the main list of policy properties so make sure your 'failback' and 'Preferred servers only' settings are still enabled and save the changes.
	__19.  In the left pane select Service Integration -> Buses.
	__20.  Click on the link for the second bus in the list which should be 'CEI.<cellname>.Bus'.
	__21.  Follow the previous steps to enable a policy for this bus.  Remember to use the 'High Availability' policy, enable the 'failback' and 'Preferred servers only' properties, and configure both servers on the 'Preferred servers' list with the '..Node01.0' server at the top of the list.
	__22.  Return to the list of buses and click on the link for the fourth bus in the list which should be 'SCA.APPLICATION.<cellname>.Bus'.
	__23.  For the 'SCA.APPLICATION..' bus configure the policy but this time place the '..Node01.1' server at the top of the preferred servers list.
	__24.  Return to the list of buses and click on the link for the fourth bus in the list which should be 'SCA.SYSTEM.<cellname>.Bus'.
	__25.  For the 'SCA.SYSTEM..' bus configure the policy but again place the '..Node01.1' server at the top of the preferred servers list.
	__26.  Make sure all changes are saved and synchronized with the nodes.

	Part 2 -  Test Preferred Servers
	__1.  In the left pane, select Servers -> Server Types -> WebSphere application servers.
	__2.  Make sure that both servers are stopped and stop them if they are not.
	__3.  Check the box next to the first server, the one that ends in '..<node name>.0' and press the Start button.  Wait for the server to start completely.  Make sure not to start the second server (...Node01.1)  in the list.
	__4.  In the left pane, select Servers -> Clusters -> WebSphere application server clusters. 
	__5.  Click the link for the MyTopology.AppTarget cluster.
	__6.  Click the link for Messaging engines and make sure all messaging engines are started.
	__7.  Open a browser and navigate to the following URL.  
	__8.  Attempt to submit a request for under $200.  You should get a success message.  
	__9.  Note or copy the claim ID.
	__10.  Open the URL below for the receipt application.  
	__11.  Enter the claim ID in the browser. 
	__12.  Click on Log Receipts.
	The browser should display the message Operation successfully completed. Enter another?
	__13.  Access the BPC Explorer by opening a browser and navigating to the following URL.  
	__14.  Login with the wasadmin id as you have done before.
	__15.  Select 'Process Instances → Administered By Me' in the BPC Explorer.
	__16.  Click the link for the most recent process instance listed and click the 'Activities' tab when the instance detail appears.  Verify that all activities are shown as "Finished".  
	__17.  From C:\LabFiles, run pigtail.exe
	__18.  Open in pigtail the log file of the running Process Server.  This should be <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<Node>.0\SystemOut.log.
	__19.  Press the Clear button to remove prior messages.
	__20.  Open a second pigtail window and open the log file of the second Process Server that is not yet running.  This should be <CUSTOM_ROOT>\logs\MyTopology.AppTarget.<Node>.1\SystemOut.log.
	__21.  Press the Clear button to remove prior messages.
	__22.  Expand the pigtail windows to see the file name in the titlebar.  This will help determine which server is doing what.
	__23.  In the left pane, select Servers -> Server Types -> WebSphere application servers.
	__24.  Check the box next to the second server, the one that ends in '..<node name>.1' and press the Start button. 
	__25.  As the second server is starting, switch to the pigtail window showing the log of the first server.  At some point you should start to see many messages about the messaging engines stopping on the first server and then making connections to the messaging engine from the second server.
	__26.  Use the previous steps to test the claim process again and confirm it still works.
	__27.  Leave both servers running and the log viewer windows open for the next section.

	Part 3 -  Test Failover
	__1.  Make sure both log viewer windows are cleared of all messages. 
	__2.  In the left pane, select Servers -> Server Types -> WebSphere application servers.
	__3.  Check the box next to the first server, the one that ends in '..<node name>.0' and press the Stop button. 
	__4.  As the first server is stopping, switch to the pigtail window showing the log of the second server.  You should see several messages as the messaging engines that were running on the first server failover to the second server.
	__5.  If you want you can test the claim process again.
	__6.  Stop all servers.
	__7.  Logout from the admin console and BPC.
	__8.  Close all pigtail windows and browser windows.
	__9.  Stop the node manager and the deployment manager.

	Part 4 -  Summary




