
WA1840 WebSphere Application
Server v7.0 Administration on

Linux

Student Labs

Web Age Solutions Inc.

Copyright info will be auto populated here 1



Table of Contents
Directory Paths Used in Labs..............................................................................................3
Lab Notes.............................................................................................................................4
Lab 1 - WebSphere v7.0 Installation....................................................................................5
Lab 2 - Install an Application.............................................................................................13
Lab 3 - IBM HTTP Server and Web Server Plug-in..........................................................22
Lab 4 - Solving Problems..................................................................................................46
Lab 5 - IBM Support Assistant Troubleshooting...............................................................61
Lab 6 - Install Database Application..................................................................................78
Lab 7 - Enable JMS Messaging Using WebSphere MQ....................................................94
Lab 8 - Configure WebSphere Security...........................................................................109
Lab 9 - Configure Java EE Security................................................................................124
Lab 10 - Monitor Performance........................................................................................142
Lab 11 - Configuring and Analyzing Memory.................................................................162
Lab 12 - Use wsadmin Scripting......................................................................................177
Lab 13 - Additional Jython Scripting...............................................................................194
Lab 14 - Web Services.....................................................................................................216
Lab 15 - Create Deployment Manager Profile.................................................................228
Lab 16 - Configure Cell Architecture..............................................................................234
Lab 17 - Configure Cluster and Remote Web Server......................................................244
Lab 18 - Install Clustered Application.............................................................................260
Alternate Lab 1 - Enable JMS Messaging Using Default Messaging.............................282

Copyright info will be auto populated here 2



Directory Paths Used in Labs
The following directories will be referred to often in the labs.  To simplify lab 
instructions there are many places where the variables listed below will be used in place 
of the actual directory path.

Some directories which should already exist before you start the labs are listed below 
with values.  Please verify the location of these directories matches what is listed here 
and make a note of the change if it does not.  Also notify your instructor if anything does 
not match.

Some directories will not yet exist as you will be installing software in the labs.  These 
are listed here so you can write down the appropriate directory here when installing the 
software.

Directories that should exist already:

<WAS_SOFTWARE_DIR>:  /root/Software/WAS-ND-7.0

<LABFILES_DIR>:  /root/LabFiles

<DB2_ROOT>:  /opt/ibm/db2/V9.5

<MQ_ROOT>:  /opt/mqm

<JMETER_ROOT>:  /root/Software/jakarta-jmeter-2.3.4

Directories created during labs:

<WAS_ROOT>:                                                                                                        

<IHS_ROOT>:                                                                                                          
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Lab Notes
This section has notes that will be referred to throughout the labs.  Various labs will have 
you write down information in this section to document important settings or to use in 
later labs.

Lab 1 - WebSphere v7.0 Installation
Profile name <profile>:                                                                                         

Node name <nodename>:                                                                                                            

Host name <hostname>:                                                                                                              

Lab 4 - Solving Problems
System.out File Name (including path):                                                                                    

Lab 7 & Alternate Lab 1 - JMS Messaging
JNDI Name for Connection Factory:                                                                                        

JNDI Name for Queue:                                                                                         

JNDI Name of Activation Specification:                                                                                   

Lab 15 – Create Deployment Manager Profile
Node Name of Deployment Manager Profile:                                                                           

Cell Name of Deployment Manager Profile:                                                                             

Host name of Deployment Manager machine <DM-hostname>:                                         

Admin Console port of Deployment Manager:                                                                        

SOAP port of Deployment Manager (DM_SOAP_PORT):                                                   
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Lab 1 - WebSphere v7.0 Installation
In this lab you will install the WebSphere Application Server v7.0.  WebSphere 
Application Server relies on TCP/IP networking.  It is important to have networking 
correctly configured before starting the installation and the host name must remain fixed. 
Your lab machine should be configured correctly for the lab.  

You will be logging in as the root user to install and configure WebSphere:

User ID: root

password: centOS

At the end of this lab you will be able to:

1. Install WebSphere Application Server V7.0

2. Explore the major WebSphere directories

3. Start the Application Server

4. Test the WebSphere Installation

5. Stop the Application Server

Part 1 - Install the Application Server
This section will run the installation wizard for WebSphere Application Server.

__1. Make sure that you are logged in as the administrative user listed above.  If you are 
not, log off and log back on as the user root above.

Note:  You can install and run a WebSphere server as a non-root user.  Search the 
InfoCenter with the phrase “non-root” to find many topics about how to accomplish this. 
In the labs, you will remain logged in as the root user to simplify the labs.

Be sure to check the platform specific installation instructions before installing 
WebSphere on your own machines.  The details about disk space and other requirements 
will be detailed there.  This lab should not be used as the only resource in preparing for 
your WebSphere installation.

__2. Open a terminal window.  You can do this by selecting 'Applications -> Accessories 
-> Terminal'.

__3. Use the 'cd' command to navigate to the <WAS_SOFTWARE_DIR>/Main/WAS 
directory substituting the value of the <WAS_SOFTWARE_DIR> variable with the 
location mentioned in the list of directory paths at the beginning of these labs.  Check 
with your instructor if you can't find the directory listed.
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__4. Execute the following command to launch the WebSphere installation.

./install &

__5. On the Welcome page press the Next button.

__6. Accept the license agreement and press the Next button.

__7. You will get a warning that the system does not pass the prerequisites check. 
CentOS 5 is built from the same source code as Red Hat Enterprise Linux 5.  Since 
RHEL 5 is a supported operating system we will still be able to run WebSphere.  Press 
the Next button to ignore the warning and continue.

__8. Leave the box for installing the sample applications unchecked and press the Next 
button.

__9. Write down the installation directory for the <WAS_ROOT> variable in the list of 
directory paths at the beginning of these labs.  This directory will be used later in the labs. 
Leave the default installation directory as is and press the Next button.
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__10. On the screen that appears about environments select to create an  Application 
Server environment and press the Next button.

Note:  An “Application Server” profile in the Network Deployment edition is exactly the 
same as the profiles created by the “Base” edition of the software.  This lets the labs 
focus on the core features of WebSphere before covering a clustered environment.

__11. Leave the box for Enable administrative security checked.  Fill in a user and 
password of wasadmin.  Press the Next button when your screen matches that shown 
below.

Note: This initial user is created as an internal WebSphere user and does NOT need to 
be a user on the system.

__12. On the Installation Summary screen, leave the option for checking permissions 
and press the Next button.

__13. Once your permissions check passes press the Next button to begin the installation. 
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__14. Once the installation is complete, click on the link for the AboutThisProfile.txt 
file.

__15. In the file that is opened, note the Profile name, Node name, and Host name. 
Write these values down in the Lab Notes section at the beginning of the lab guide.

__16. Close the text file showing the profile information.

__17. When the installation is complete press the Finish button.  This will launch the 
First Steps console.
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__18. Click the link for Installation verification.

__19. Make sure that you get a message that the verification succeeded.  You may get a 
few messages that are warnings (with a 'W') but there should be no errors.

__20. Close the verification window.

__21. In the First Steps window, click the link for Stop the Server.

__22. When prompted, enter 'wasadmin' for the user and password.

__23. When the server is stopped close the window that showed the output of stopping 
the server.

__24. Click Exit on the First Steps window.
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Part 2 - Explore Application Server Directory Structure
This section will point out some of the major directories in the WebSphere installation.

__1. Open a File Browser window.  You can do this by selecting 'Applications -> System 
Tools -> File Browser'.

__2. Navigate to the <WAS_ROOT> directory you wrote down in the notes at the 
beginning of these labs.  This should be the main installation directory for WebSphere.

__3. Look at some of the major directories and their contents:

● bin – executable programs, scripts, and DLLs

● installableApps – complete applications which can be installed

● java – JDK 1.6.0 files (supports Java SE v6)

● lib – library of various Java .jar files used by WebSphere

● web – documentation resources

● profiles/AppSrv01/config – configuration files for the installation

● profiles/AppSrv01/etc – default SSL files

● profiles/AppSrv01/installedApps – applications installed on the server

● profiles/AppSrv01/logs – default directory for various trace and log files

● profiles/AppSrv01/properties – configuration property files used by WebSphere

__4. Look at some of the log files created during the installation and verification:

● <WAS_ROOT>/logs/install/log.txt - logs installation events

● <WAS_ROOT>/logs/manageprofiles/AppSrv01_create.log - log messages 
related to the creation of the AppSrv01 profile

● <WAS_ROOT>/profiles/AppSrv01/logs/ivtClient.log - output of verification test

● <WAS_ROOT>/profiles/AppSrv01/logs/server1/SystemOut.log - main log file 
for Application Server

__5. Close the File Browser window and all open files.
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Part 3 - Test the Application Server
There is a default application that is installed with the Application Server that can be used 
to test.  This test is independent of the verification test.

__1. Start the Application Server.  Do this by following the set of steps below:

● Open a terminal window.  You can do this by selecting 'Applications -> 
Accessories -> Terminal'.

● Use the 'cd' command to change to the <WAS_ROOT>/profiles/AppSrv01/bin 
directory.  

● Issue the command './startServer.sh server1'.

__2. Once the server is started, open a web browser and type the URL 
'http://localhost:9080/snoop' into the address bar.  You should see the output below.

__3. Close the web browser used to test the Application Server.
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__4. Stop the Application Server.  Do this by following the set of steps below:

● Open a terminal window.  You can do this by selecting 'Applications -> 
Accessories -> Terminal'.

● Use the 'cd' command to change to the <WAS_ROOT>/profiles/AppSrv01/bin 
directory.  

● Issue the command './stopServer.sh server1'.

● When prompted for security enter a user and password of wasadmin.

Note: In the future, when you are asked to start and stop the server you will use the steps 
outlined in this section.

You can also issue the following command to stop the server to avoid getting prompted 
for security information each time:

./stopServer.sh server1 -username wasadmin -password wasadmin

The issue with supplying the user and password in the command is that these would be 
visible to the 'ps' process listing command.  This can be viewed as a security risk.

Part 4 - Summary
In this lab you installed the WebSphere Application Server.  You also ran some basics 
tests of the server and familiarized yourself with some basic commands.  You are now 
able to start and stop the server and can identify some of the major directories in the 
WebSphere installation.

Even though you installed the Network Deployment software, the profile that you created 
is exactly what you would have after installing the “Base” edition of WebSphere.  The 
only difference is that when you install the “Base” edition you only get one option for the 
type of environment to create.
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Lab 2 - Install an Application
In this lab you will install a simple application to the Application Server.  This application 
has only one simple function, printing a message out to the screen.  It does not use any 
external resources.  This is so you can concentrate on installing an application without 
needing to configure any other resources first.

At the end of this lab you will be able to:

1. Use the Admin Console for administering applications on the server.

2. Install an application to the Application Server

3. Test applications that have been deployed to the server by submitting web 
requests

Part 1 - Control Applications From the Admin Console
In this section you will use the Admin Console to control applications deployed to the 
server.  You will also see an example of the response returned if a deployed application is 
stopped.

__1. Start the Application Server.  Do this by following the set of steps below:

● Open a terminal window.  You can do this by selecting 'Applications -> 
Accessories -> Terminal'.

● Use the 'cd' command to change to the <WAS_ROOT>/profiles/AppSrv01/bin 
directory.  

● Issue the command './startServer.sh server1'.

__2. Start the Admin Console by opening a Web browser and entering the URL 
http://localhost:9060/ibm/console/

__3. Since security is enabled you will get a warning about the server certificate.  Accept 
the certificate or continue to the website depending on the browser you are using.

Note:  You will get this warning every time you access the Admin Console.  You could 
also “Install” the certificate in your web browser to indicate you trust the site to prevent 
the warning.

With Firefox you "Add an exception".

__4. Enter a user ID and password of ‘wasadmin’ and click “Log in” on the Login 
screen of the Console.
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__5. Expand the Applications group in the Navigation tree, expand Application Types 
and click on the link for WebSphere enterprise applications.

__6. Check the checkbox next to the DefaultApplication and press the Stop button.  You 
should get a message that the application was stopped and a red ‘X’ in the status column.

__7. Open a separate Web browser and try to access the Snoop Servlet as in the last lab. 
The URL is http://localhost:9080/snoop.  You should get an error.  This is because it is 
part of the DefaultApplication which is stopped. 

__8. In the Admin Console, check the checkbox next to the DefaultApplication and 
press the Start button.  You should get a message that the application was started and a 
green arrow in the status column.

__9. In the Web browser you used to access the Snoop Servlet, hit the refresh button. 
You should see the normal output of the Snoop Servlet.  

__10. Close the extra Web browser you were using to test the Snoop application.
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Part 2 - Install an Application to the Server
In this section you will install an application to the server.  After installing and starting 
the application the Application Server will be able to handle requests that were not part of 
the testing and verification applications that already come installed on the server.  This 
section will familiarize you with the basic process of installing an application.

__1. Return to the web browser you were using for the Admin Console.  If you had 
closed it you can open it at http://localhost:9060/ibm/console/ and login is wasadmin.

__2. In the Applications group in the navigation, click the link for New Application.

__3. Click the link for New Enterprise Application.

__4. Next to the Local file system box, press the Browse button.

__5. Find the file <LABFILES_DIR>/Install/HitCount.ear and select Open in the file 
chooser dialog.  Remember to substitute the value of the <LABFILES_DIR> variable 
from the notes at the beginning of the labs.

__6. Press the Next button.

__7. Check the option for Detailed installation.  This will show all steps.

__8. Once you have the options specified as below, press the Next button.

Note:  The next sequence of steps will vary depending on the application you are 
installing.  Since this application is fairly simple there are only a few steps and a 
summary.  There would be fewer steps if we had not checked the option for showing all 
options.
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__9. On step 1, check the Precompile JavaServer Pages files option and click Next.

__10. Accept the default values on steps 2-12 by pressing the Next button on each step. 
Some of these steps will only appear once you go through other steps.  You should end up 
at step 13 which is the summary.  Some of the intermediate steps are explained below:

Step 2: Map modules to servers - This step would be more important in a multi-server 
environment.  This step will also be more important with web servers later.

Step 3: Provide options to compile JSPs - This step appears because of the option you 
selected to precompile JSPs.  Most of the time the code needed to compile JSPs is in the 
application itself but if it is not you may need to supply additional options here.

Step 4: Provide JSP reloading options for Web modules - This service can 
automatically check if a new version of a JSP file has been deployed to the application 
without restarting the entire application.  Most of the time you would leave this service 
on but you could increase the time interval in production.

Steps 5 & 6: Shared libraries - Shared libraries are shared code that is required by an 
application but is not packaged with the application itself.  If you have previously 
configured a shared library you can map it to an application module with these steps.

Step 7: Provide JNDI names for beans & Step 8: Bind EJB Business – These steps 
are presented if the application includes EJBs.  The JNDI name can be used by EJB 
clients to locate the EJB.  Some EJB clients can also obtain a reference to the EJB using 
Java EE “injection” where the JNDI name may not be required.  If your developers are 
using Rational software this value may be filled in already.  It would be important to 
coordinate the values of these properties with developers.

Step 9: Map EJB references to beans – An EJB reference is another way for an EJB 
client to be linked to a target EJB.  Again, this value may not be required if an application 
uses Java EE “injection”.

Step 10: Map virtual hosts for Web modules - Virtual hosts affect the URL that is used 
to access the application.  This will be discussed more later.

Step 11: Map context roots for Web modules - The context root also makes up part of 
the application URL.  You could change it here if you wish.  This will be discussed more 
later.
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Step 12: Metadata for modules – Deployment information for applications can be 
provided by XML deployment descriptors or through annotations in the code itself.  If 
you check the 'metadata-complete attribute' in this step for a module of the application, 
any deployment information provided in code annotations is ignored.  Developers may be 
counting on some of these annotations being applied to configure an application so this is 
another aspect to coordinate with developers.

__11. On step 13, the Summary, click the Finish button.  Wait for it to complete the 
installation and be sure you get a message that says Application HitCount installed 
successfully.

__12. Click the link to Review changes to the master configuration below the message 
about the successful installation.

__13. On the Save screen, click the '+' sign to expand the list of changes that will be 
made.

Note:  The number of changed documents you see may be slightly different.

__14. Click the Save button to save the master configuration.

__15. In the Applications group in the navigation, expand the Application Types section 
and click the link for WebSphere enterprise applications.
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__16. Start the HitCount application by checking the checkbox next to it and clicking the 
Start button.

__17. Make sure HitCount is started.

Part 3 - Test the HitCount Application
Now that the application is installed and started you can test it.  You will find out how to 
submit a web request for an installed application by using properties available from the 
Admin Console.

__1. Make sure that you are viewing the list of Enterprise Applications in the Admin 
Console.  If not, you can expand the 'Applications → Application Types' group in the 
navigation and click the link for 'WebSphere enterprise applications'.

__2. From the list of applications, click the link for the HitCount application by clicking 
on the application name.  This will show you a page of options and configuration related 
to that particular application.
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__3. From the list of Detail Properties associated with the HitCount application click the 
link for View Deployment Descriptor.

__4. In the text of the Deployment Descriptor find the value of the context-root.  This is 
what you can add to the host name and port of the server to access the application.
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__5. Open a new web browser and enter the URL: 

http://localhost:9080/HitCountWeb.  

Notice this URL ends in the “context-root” of the web application.  You should see the 
following page.

__6. Click the link of the home page of the application.  You should get an initial count of 
'1'.

__7. Refresh the page several times to see the count increase.

__8. Leave the web browser open that you are using to test the application.

__9. Return to your Admin Console web browser.  If you closed it, open a new window to 
the URL http://localhost:9060/ibm/console/.  Make sure you leave the web browser 
running the HitCount application open.

__10. Expand the 'Applications → Application Types' group in the navigation and click 
the link for 'WebSphere enterprise applications'.

__11. Check the checkbox next to the HitCount application and press the Stop button.

__12. Once the application is stopped, check the checkbox next to the HitCount 
application again and press the Start button.

__13. Return to the web browser you were using to test the application and refresh the 
page.  The count should return to 1 even though you are using the same web browser. 
The “state” of the stateful session EJB has been lost by restarting the application.
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__14. Close the web browser you used to test the new application.

__15. In the web browser showing the Admin Console click the Logout link near the top 
of the Console.

__16. Close the web browser you were using for the Admin Console.

__17. Stop the Application Server.  Do this by following the set of steps below:

● Open a terminal window.  You can do this by selecting 'Applications -> 
Accessories -> Terminal'.

● Use the 'cd' command to change to the <WAS_ROOT>/profiles/AppSrv01/bin 
directory.  

● Issue the command './stopServer.sh server1'.

● When prompted for security enter a user and password of wasadmin.

Part 4 - Summary
In this lab you installed a simple application and saw the main steps of installing an 
application.  Even though most applications will be much more complex and require 
more steps during the installation the same basic process will be followed.

You also saw how to access properties for installed applications to find out how to submit 
web requests for testing.  There are many other properties associated with applications 
and you only saw a few but others are accessed in the same way, by clicking the name of 
the application in the list of applications.  In fact all configuration properties and options 
available in the Admin Console are accessed in a similar fashion.  When you click a link 
on one page it displays another page with properties for that item.
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Lab 3 - IBM HTTP Server and Web Server Plug-in
You have already seen how the WebSphere Application Server can handle HTTP requests 
without a Web Server.  For enhanced network security and performance it is often 
desirable to use a Web Server.  In this lab you will see how the Web Server and the 
WebSphere Application Server work together in this environment.

You will be installing the IBM HTTP Server and Web Server Plug-in using the “local” 
configuration which is shown below.  In this configuration the web server, plug-in, and 
WebSphere server are all on the same machine.  Much of the plug-in configuration within 
the WebSphere configuration will be done for you using a batch command generated 
during the web server installation.

At the end of this lab you will be able to:

1. Install the IBM HTTP Server and Web Server Plug-in.

2. Add a new host name to the IBM HTTP Server.

3. Route requests for this new host name back to your own machine.

4. Configure applications in the WebSphere Application Server to use this host 
name.

Part 1 - Install IBM HTTP Server
The first step will be to install the IBM HTTP Server.  This has a separate installation 
than the WebSphere installation.  Although you will be installing the IBM HTTP Server 
on the same machine as WebSphere, often this would be done on a different machine.
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It is important to note that most Linux distributions have a web server that can be 
installed.  Your CentOS setup has been performed to exclude this web server so it would 
not interfere with the IBM HTTP Server.  In another environment it would be good to 
disable or uninstall this web server if it is present if you wish to use the IBM HTTP 
Server.

__1. Make sure you are logged in as the 'root' user ID.

__2. Open a terminal window.  You can do this by selecting 'Applications -> Accessories 
-> Terminal'.

__3. Navigate to the <WAS_SOFTWARE_DIR>/Supplement/IHS directory 
substituting the <WAS_SOFTWARE_DIR> variable location mentioned in the beginning 
of these labs.  Check with your instructor if you can't find the directory listed.

__4. Execute the following command to launch the WebSphere installation.

./install &

__5. Click Next on the Welcome screen.

__6. Accept the license and click Next.

__7. You will get a warning that the system does not pass the prerequisites check.  Press 
the Next button to ignore the warning and continue.

__8. Write down the installation directory for the <IHS_ROOT> variable in the list of 
directory paths at the beginning of these labs.  This directory will be used later in the labs. 
Leave the default installation directory as is and press the Next button.

__9. Accept the default values for the HTTP port and administration port.  Click the Next 
button.
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__10. Leave the option for “Create a user ID for IBM HTTP administration server 
authentication” checked.  

__11. Fill in a user ID and password of 'ihsadmin'. Click the Next button.

Note: This step runs the 'htpasswd' command from the IBM HTTP Server to configure 
a user and password that can be used to remotely administer the web server.  This user 
does not have to be an actual user for the operating system.

__12. Leave the options for “Setup HTTP Administration Server” checked and fill in a 
User ID and group of 'ihsadmin'.  Click the Next button.
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Note: This step runs the 'setupadm' command from the IBM HTTP Server to configure 
what id will be used to run the HTTP Administration service.  This will also change 
permissions of various web server configuration directories.  This user does have to be a 
user on the operating system.  If you do not already have a user you would like to use 
you can leave the second option checked, as we are doing and one will be created.

The user from the previous step and this step do not need to be the same ID.  This is 
done in the labs to keep things simple.

You can also run the htpasswd command from the previous step and the setupadm 
command from this step manually.  Doing this as part of the installation can be easier as 
the installation wizard already knows what directories and files would need to be 
modified.  If you do not run these commands as part of the installation the remote 
administration ability will be disabled until you run the commands manually.

__13. Leave the option for “Install the IBM HTTP Server Plug-in for IBM 
WebSphere Application Server” option checked.  Make sure that the Host name listed 
matches the value for the <hostname> variable you wrote down in the lab notes section 
for the WebSphere installation.  Click the Next button when you have checked the 
settings on this page.

Note:  This screen refers to the plug-in installation as the “remote” scenario.  This is 
simply because we are not having the plug-in installation automatically alter the 
WebSphere configuration but will do that with a script file in the next section.  If you 
run the plug-in installation separately it is possible to do a “local” scenario where the 
installation automatically alters the WebSphere configuration.  The steps in the next 
section are most likely the steps you would follow in many WebSphere environments.

__14. Press the Next button in the summary screen to start the installation.

__15. Press the Finish button to close the installation wizard when IBM HTTP Server is 
successfully installed.
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Part 2 - Configure Web Server in WebSphere Configuration
Now that you have installed the web server you need to define the web server settings in 
the WebSphere configuration.  There are several settings that need to be configured 
related to the web server.  The good thing is that there is a script that was created during 
the web server installation that can easily configure WebSphere with just a few 
parameters.  

__1. Open a terminal window.  

__2. Use the 'cd' command to change to the <WAS_ROOT>/profiles/AppSrv01/bin 
directory.  

__3. Issue the command './startServer.sh server1'.

__4. Open another terminal window.  

__5. Change directories using the 'cd' command to the <IHS_ROOT>/bin directory.  Be 
sure to substitute the value of <IHS_ROOT> from the “Directory Paths” page at the 
beginning of the lab instructions.

__6. Execute the following command to start the web server.  

./apachectl start

__7. Execute the following command to start the HTTP administration service.

./adminctl start

Note: Although it is possible to register the IBM HTTP Server and HTTP administration 
service to start automatically if the system reboots, we have not done this.  If you restart 
your machine you will need to execute these commands to be sure the web server and 
the HTTP administration service are running.  Generally they should remain running 
unless you are told to stop or restart it.
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__8. Open a File Browser window or use one you already have open.

__9. Navigate to the directory <IHS_ROOT>/Plugins/bin where the <IHS_ROOT> is 
the variable you wrote down from the IBM HTTP Server installation in the previous 
section.

__10. Find the file 'configurewebserver1.sh' in the directory.  Check that you find the 
correct file as there are several that start with 'configure...'.  

__11. Copy the 'configurewebserver1.sh' file by right clicking and selecting Copy from 
the popup menu.

__12. Open another File Browser and navigate to the directory <WAS_ROOT>/bin 
where the <WAS_ROOT> is the variable you wrote down from the WebSphere 
installation lab.

__13. Paste the 'configurewebserver1.sh' file into this directory by selecting Edit -> 
Paste from the menus.
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__14. Be sure you see the 'configurewebserver1.sh' file in the list of files.

Note:  Also note that there is a 'configureWebserverDefinition.jacl' file in the same 
directory.  This file will be called by the script you just copied in with parameters 
configured during the web server installation.

__15. Make sure you have logged out of any previously open Admin Console browser 
windows.

Note:  It is important to logout because you will run a script in the next few steps as the 
same user you used in the Admin Console.  The script seems to have conflicts in this 
situation.

__16. Open a terminal window.  

__17. Change directories using the 'cd' command to the <WAS_ROOT>/bin directory. 
Be sure to substitute the value of <WAS_ROOT> from the “Directory Paths” page at the 
beginning of the lab instructions.

__18. Enter the following command to check that the WebSphere server is started:

./serverStatus.sh -all -username wasadmin -password wasadmin

You should see on server1 started.
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__19. Enter the following command to configure the web server definition in the 
WebSphere configuration.  The command should all be entered on the same line even 
though it wraps to a second line below.

./configurewebserver1.sh -profileName AppSrv01 -user wasadmin -password 
wasadmin -ihsAdminPassword ihsadmin

Note. It may takes some seconds to show the results.

__20. Scroll back through the messages that were output and be sure you do not see any 
errors.

Part 3 - Configure Virtual Host on Web Server
The next step will be to configure the IBM HTTP Server to respond to a unique host 
name that is not the same as the host name of the machine itself.  This “virtual hosting” 
will separate the physical hostnames of your network from the logical hostnames you 
expose to the clients of the applications.  You will use a host name of ‘was.myhost.com’.

In the labs there is not any static content hosted on the web server.  This section is 
provided to show how to use the WebSphere Admin Console to configure the web server. 
The settings in this section configure the web server so it responds to the 
'was.myhost.com' hostname we will use.

__1. Open a web browser and enter http://localhost:9060/ibm/console in the address 
bar, the URL of the Admin Console.  Remember to continue if you get any certificate 
errors.

__2. Login as the 'wasadmin' user.

__3. Navigate to the Servers → Server Types → Web Servers section of the admin 
console.  Notice there is now a configuration for 'webserver1' which the script you ran 
added.
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__4. Click the link for webserver1 from the list.

__5. Under the Additional Properties click the link for Configuration File.  If you get 
an error displaying the configuration file let your instructor know as this likely means 
there is a problem with your IHS administration password.

__6. Scroll to the very end of the file and add a few blank lines.

Note: There are two nested sets of scroll bars so it may be easiest to use CTRL-END 
when the cursor is in the configuration file.

__7. Add the following text exactly as it appears below at the end of the configuration 
file.  
<VirtualHost was.myhost.com>
    ServerName was.myhost.com
    ErrorLog logs/was.myhost.com-error_log
    CustomLog logs/was.myhost.com-access_log common
</VirtualHost>
__8. Check that your configuration appears as below and press the OK button.

__9. Go back to the list of web servers by navigating to the Servers → Server Types → 
Web Servers section of the admin console.
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__10. Check the box next to the webserver1 entry and click the Stop button.  Make sure 
you get a message about the server stopping.

Note: If you have trouble stopping the server it may be because you supplied an 
incorrect value for the 'ihsAdminPassword' option when running the script in the last 
section.  Contact your instructor to help resolve this.

__11. Check the box next to webserver1 and click the Start button.  If you have trouble 
starting the web server check your configuration file syntax.

__12. Logout of the Admin Console.

Part 4 - Update Network Setup
You will now change the networking setup of your Linux virtual machine to send 
requests for this new host name back to your own virtual machine.  You will use the 
‘hosts’ file on the machine to perform this mapping.  Normally you would have other 
network components perform this mapping but the ‘hosts’ file will simplify the process 
for the lab.  If this step is not done then requests sent to the host name 'was.myhost.com' 
would not be redirected back to your virtual machine.

__1. Open a File Browser window or use one you already have open.

__2. Navigate to the '/etc' directory.

__3. Find the 'hosts' file in this directory.

__4. Copy the 'hosts' file and rename the copy to something like 'hosts-backup'.  This 
will ensure you can restore the original if needed.

__5. Double-click on the ‘hosts’ file and open it with a text editor like gedit.

__6. If you do not already have a line that starts with the IP address 127.0.0.1 add it. 
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__7. Add to this line 'was.myhost.com' with spaces between the IP address and each of 
the hostnames.  Make sure to add any entries AFTER the real hostname as shown below. 
The file should be similar to this: 

__8. Save the file and close the text editor.

__9. Open a terminal window.  

__10. Be sure you can ping the new host name.  Enter the command below.  Be sure you 
don’t get an “unknown host” or “request timed out” error message.  

ping -c 4 was.myhost.com

__11. Close the terminal window.

__12. Open a web browser window.
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__13. Enter the URL http://was.myhost.com in the address bar of the browser and hit 
Return. You should see the homepage of the IBM HTTP Server running on your machine. 
If you do not see this screen contact your instructor.

__14. Close out any extra terminal windows, web browsers, or File Browser windows 
you may have open.

Part 5 - Test Plug-in
Now that you have tested the web server you should test that requests sent to the web 
server can be forwarded to WebSphere through the Plug-in.

__1. Open a web browser and enter the URL http://localhost:9080/HitCountWeb/ in the 
address bar and hit the Return key.  You should see the normal output of the HitCount 
application.
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__2. Test the function of the application to be sure it is working properly.

__3. Enter the URL http://localhost/HitCountWeb into the address bar of the web 
browser and hit Return.  You should see the same application.  If you get any errors check 
that your web server is running.

Note:  The difference is that the URL above does not list the 9080 port.  Because there is 
no port listed it sends the request to the default HTTP port which is port 80.  This is the 
port the web server is listening on.  The fact that you got the normal response proves that 
the web server can forward requests for the HitCount application to WebSphere through 
the Plug-in.

__4. Test the application again to be sure the same behavior is shown even though the 
requests are now being forwarded through the Plug-in.

__5. Enter the URL http://was.myhost.com/HitCountWeb/ into the address bar of the 
web browser and hit Return.  Again you should see the same HitCount application.  This 
is because you have configured the web server to respond to the host name 
was.myhost.com.  It can also forward requests for this host name to WebSphere.

Note: The hit count will be reset because it was associated with your web session that 
was linked to the 'localhost' hostname.  When you use a new hostname of 
was.myhost.com the browser starts a new web session.

__6. Close the web browser you have been using to test.

Part 6 - Examine Plug-in Configuration
The configuration of the Plug-in is often a mystery.  It is confusing to most people how 
the Plug-in makes decisions about what requests to forward.  In this section you will see 
how you can examine the Plug-in configuration in the WebSphere Admin Console.

__1. Start the Admin Console by opening a Web browser and entering the URL 
http://localhost:9060/ibm/console/

__2. Enter a user ID and password of ‘wasadmin’ and click “Log in” on the Login screen 
of the Console.

__3. In the navigation panel on the left expand the Servers → Server Types group and 
click the link for Web Servers.

__4. Click the link for the webserver1 web server.

__5. Under the Additional Properties for the web server click the link for Plug-in 
properties.
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__6. Press the View button next to the Plug-in configuration file name.

__7. Search through the configuration for the VirtualHostGroup element.  This has the 
definition of several VirtualHosts.  These are the host name and port combinations the 
Plug-in can expect to receive requests for.  The host name is listed as an asterisk (*) right 
now which means the Plug-in will accept requests for any host name the web server 
responds to.

__8. Search through the configuration for the Server element.  Within this element you 
will see “Transports” which have values for the host name and port numbers of the 
Application Server.  This is so the Plug-in knows what host name and port to use to 
forward requests to the Application Server.

Note:  The syntax for the server section in the Plug-in configuration can be confusing. 
The parent tag in the configuration is “ServerCluster”.  You do not have a cluster of 
servers right now.  This term is only used so that if you did have a cluster of servers in a 
Network Deployment Cell the syntax of the Plug-in configuration would be the same. 
Right now your Plug-in is configured as if you have a “cluster” with only one server.
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__9. Search through the configuration for the UriGroup element.  Within this element 
you should see an entry for '/HitCountWeb/*'.  This is the entry that indicates the Plug-
in can forward requests to the HitCount application.

__10. Search through the configuration for the Route entry.  This links together the three 
other parts of the Plug-in configuration you have looked at so far.

Note:  The “Route” is probably the most important part of the configuration.  This is 
what the Plug-in uses to make decisions about what requests to forward and how.  The 
Route indicates that if a request comes in for a host name and port listed by the 
VirtualHostGroup and for an application listed in the UriGroup that the request should 
be forwarded to a server in the ServerCluster.

__11. Click the OK button on the bottom of the Plug-in configuration to close the view of 
the configuration file.
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Part 7 - Configure Virtual Host in WebSphere
Right now the Plug-in is forwarding lots of requests to the HitCount application. 
Requests can be submitted using the hostnames localhost or was.myhost.com on one of 
several different ports.  This is because the current Plug-in configuration uses an asterisk 
(*) for the host name of the VirtualHost definitions.

In certain situations you might want to restrict the host name and port combinations that 
are mapped to your applications through the Plug-in.  To do this you must add a 
VirtualHost definition in the WebSphere configuration and configure the “host aliases” 
that it will use.  You would then map an application to this new VirtualHost you created 
to indicate the application would only be available on the given host and port 
combinations.  Finally you would update the web server Plug-in configuration so it uses 
the new rules for how to forward requests to your applications.

__1. In the WebSphere Admin Console expand the Environment navigation group and 
click the link for Virtual hosts.

__2. Notice that right now there are only two virtual hosts.  One is the “default_host” 
that you saw in the Plug-in configuration.  The other is an “admin_host” that is used 
only for the Admin Console.

__3. Click the New button above the list of virtual hosts.

__4. Fill in a Name of myhost for the new virtual host and press the Apply button.  Make 
sure you hit the Apply button as the OK button will not keep you on the same screen.

__5. To the right under Additional Properties, click the link for Host Aliases.

__6. Right now there are no host aliases.  Click the New button above the empty list of 
host aliases.
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__7. Change the Host Name to was.myhost.com and leave the default port of 80.  Click 
the OK button when you have the properties filled in as below.

__8. The new host alias now appears in the list.  This is now the ONLY host name and 
port that applications mapped to this virtual host will recognize.

__9. Click on the Save link in the list of messages near the top of the main Console area.

__10. In the navigation area of the Console expand the Applications → Application 
Types group and click the link for WebSphere enterprise applications.

__11. Click the link for the HitCount application.

__12. In the list of Web Module Properties on the right click the link for “Virtual 
hosts”.

__13. Use the drop down next to the HitCountWeb Web module to select the myhost 
Virtual host from the list.  Press the OK button when you have the properties set as 
below.
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__14. Back on the screen for the HitCount application, click the link for “Manage 
Modules” in the Modules section of properties.

__15. Notice that the Web module is already mapped to the webserver1 web server AND 
the server1 Application Server.  This indicates that requests for that application will pass 
through the webserver1 web server on the way to server1.  This is a critical setting for 
configuring the web server Plug-in configuration for webserver1.

Note:  This mapping was already done for you even though you did not do it.  This was 
done by the script that you ran to configure the web server in the WebSphere 
configuration.  The script automatically mapped all of the applications that were 
currently installed to the web server definition that it created for the Plug-in.

In the future, when you install applications that have Web modules, mapping them to a 
web server will be an important step.

__16. Click on the Save link in the list of messages near the top of the main Console area.

__17. In the navigation panel on the left expand the Servers → Server Types group and 
click the link for Web Servers.

__18. Check the checkbox next to webserver1 and click the Generate Plug-in button.

You will see the following message:
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__19. Check the checkbox next to webserver1 and click the Propagate Plug-in button.

You will see the following message:

__20. Click the link for the webserver1 web server.

__21. Under the Additional Properties for the web server click the link for Plug-in 
properties.

__22. Press the View button next to the Plug-in configuration file name.

__23. If you look in the configuration you will notice there are now entries for the 
myhost VirtualHostGroup you created and the UriGroup for the HitCountWeb Uri is 
now listed separately.  There is also a new Route entry that associates the entries relating 
to the HitCount application.  You may need to scroll around the file as there are many 
other entries.

.............

__24. When you are done looking at the new Plug-in configuration, click the Logout link 
in the Admin Console.
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Part 8 - Test the New Virtual Host
Now that you have configured a new virtual host with only one host name and port 
combination and associated the HitCount application with it you will want to see how this 
affects the behavior of the application.  No longer will you be able to send requests using 
any host name or port besides was.myhost.com on port 80.

__1. Open a terminal window.  

__2. Use the 'cd' command to change to the <WAS_ROOT>/profiles/AppSrv01/bin 
directory.  Be sure to substitute the value of <WAS_ROOT> from the “Directory Paths” 
page at the beginning of the lab instructions.

__3. Issue the command:

./stopServer.sh server1 -username wasadmin -password wasadmin

__4. Issue the command to restart the server:

./startServer.sh server1

Note:  You need to restart the Application Server because some of the configuration 
changes you just made are only read when the server starts.  You should not need to 
restart the web server as it will refresh the plug-in configuration every minute or so.

__5. Open a web browser and enter the URL http://was.myhost.com/HitCountWeb/ 
into the address bar of the web browser and hit Return.  You will see the normal output of 
the HitCount application.  This is expected since the application is still registered to 
respond to this host name and port combination.

__6. Test the function of the application to verify it is working correctly.

__7. Notice the URL that appears in the browser for the page that displays the messages. 
It is:

http://was.myhost.com/HitCountWeb/HitCountServlet
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__8. Enter the following URLs into the web browser that have worked before:

● http://localhost/HitCountWeb

● http://localhost:9080/HitCountWeb

● http://was.myhost.com:9080/HitCountWeb

Notice that all of these URLs now generate various “page cannot be found” 404 errors. 
This is because these host name and port combinations are not listed as host aliases of the 
virtual host that the HitCount application is mapped to.

__9. Close the web browser you were using for testing.

Part 9 - Investigate Application Settings
So far in this lab you have seen how to change the host name and port an application will 
respond to using a Virtual Host.  In this section you will see where the other parts of the 
URL are specified.  You will use the Admin Console to display the “Deployment 
Descriptors” that contain this information.  Remember the URL you used to access the 
application was:

http://was.myhost.com/HitCountWeb/HitCountServlet

__1. Open a web browser and enter http://localhost:9060/ibm/console in the address 
bar, the URL of the Admin Console.

__2. Login as the 'wasadmin' user.

__3. In the navigation area of the Console expand the Applications → Application 
Types group and click the link for WebSphere enterprise applications.

__4. Click the link for the HitCount application.
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__5. Under the Detail Properties section, click the link for View Deployment 
Descriptor.

__6. Make sure all the entries are expanded and locate the 'context-root' element.  This 
forms the first part of the URL that comes after the host name and port.  Notice this also 
mentions a 'HitCountWeb.war' module for the application.

__7. In the “breadcrumb” trail at the top of the page click the link for the “HitCount” 
application.  This will take you back to the properties of the application configuration.

__8. At the top of the page of properties for the HitCount application click the link for 
Manage Modules under the Modules section of properties.
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__9. In the list of modules click the link for the HitCountWeb module.

__10. On the right side, click the link for View Deployment Descriptor.

__11. Make sure all the entries are expanded and locate the 'servlet-mapping' element. 
This links the servlet in the application to the URL suffix '/HitCountServlet'.

__12. Logout of the Admin Console and close the web browser.

__13. Stop the Application Server using the method you are most familiar with.

Note:  You now know how to read the URLs used to access application components. 
These are of the form:

<protocol>://<hostname>:<port>/<context root>/<URL mapping>

Applying this to the HitCountServlet URL:

http://was.myhost.com/HitCountWeb/HitCountServlet

<protocol> - HTTP

<hostname> - was.myhost.com

<port> - 80, this is the default HTTP port if none is listed

<context root> -  HitCountWeb

<URL mapping> - /HitCountServlet
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Part 10 - Summary
This lab showed several different aspects of using web servers with WebSphere.  The first 
sections involved installing and configuring the IBM HTTP Server.  This included 
configuring the web server to respond to a “virtual host” which was different than the 
actual host name of your machine.  You also had to modify the network setup of your 
machine to be sure that the requests for this host name would be routed back to your 
machine and not sent out to the network.

The next sections tested the web server Plug-in.  Because most of the initial setup of the 
Plug-in was done by the web server installation and the script you ran there was not much 
to do immediately after the script to get it to work.  You also became familiar with how to 
read the Plug-in configuration and discovered how the Plug-in will forward requests for 
applications.

In the last set of sections you reconfigured the HitCount application so it would only 
respond to requests sent to the was.myhost.com host name on port 80.  This may be 
required when you need to have more control over how applications respond to requests. 
The first step in this was to create a new virtual host and host alias that only included the 
desired host name and port.  You then changed the configuration of the HitCount 
application to use this new virtual host.  After restarting the servers you saw how these 
settings restrict the host name and ports that you can use to submit requests.

You also saw how to obtain some basic information about the internal settings of an 
application using the Admin Console to view the deployment descriptors.

Copyright info will be auto populated here 45


	Lab 1 -  WebSphere v7.0 Installation
	Part 1 -  Install the Application Server
	__1.  Make sure that you are logged in as the administrative user listed above.  If you are not, log off and log back on as the user root above.
	__2.  Open a terminal window.  You can do this by selecting 'Applications -> Accessories -> Terminal'.
	__3.  Use the 'cd' command to navigate to the <WAS_SOFTWARE_DIR>/Main/WAS directory substituting the value of the <WAS_SOFTWARE_DIR> variable with the location mentioned in the list of directory paths at the beginning of these labs.  Check with your instructor if you can't find the directory listed.
	__4.  Execute the following command to launch the WebSphere installation.
	__5.  On the Welcome page press the Next button.
	__6.  Accept the license agreement and press the Next button.
	__7.  You will get a warning that the system does not pass the prerequisites check.  CentOS 5 is built from the same source code as Red Hat Enterprise Linux 5.  Since RHEL 5 is a supported operating system we will still be able to run WebSphere.  Press the Next button to ignore the warning and continue.
	__8.  Leave the box for installing the sample applications unchecked and press the Next button.
	__9.  Write down the installation directory for the <WAS_ROOT> variable in the list of directory paths at the beginning of these labs.  This directory will be used later in the labs.  Leave the default installation directory as is and press the Next button.
	__10.  On the screen that appears about environments select to create an  Application Server environment and press the Next button.
	__11.  Leave the box for Enable administrative security checked.  Fill in a user and password of wasadmin.  Press the Next button when your screen matches that shown below.
	__12.  On the Installation Summary screen, leave the option for checking permissions and press the Next button.
	__13.  Once your permissions check passes press the Next button to begin the installation.  
	__14.  Once the installation is complete, click on the link for the AboutThisProfile.txt file.
	__15.  In the file that is opened, note the Profile name, Node name, and Host name.  Write these values down in the Lab Notes section at the beginning of the lab guide.
	__16.  Close the text file showing the profile information.
	__17.  When the installation is complete press the Finish button.  This will launch the First Steps console.
	__18.  Click the link for Installation verification.
	__19.  Make sure that you get a message that the verification succeeded.  You may get a few messages that are warnings (with a 'W') but there should be no errors.
	__20.  Close the verification window.
	__21.  In the First Steps window, click the link for Stop the Server.
	__22.  When prompted, enter 'wasadmin' for the user and password.
	__23.  When the server is stopped close the window that showed the output of stopping the server.
	__24.  Click Exit on the First Steps window.

	Part 2 -  Explore Application Server Directory Structure
	__1.  Open a File Browser window.  You can do this by selecting 'Applications -> System Tools -> File Browser'.
	__2.  Navigate to the <WAS_ROOT> directory you wrote down in the notes at the beginning of these labs.  This should be the main installation directory for WebSphere.
	__3.  Look at some of the major directories and their contents:
	__4.  Look at some of the log files created during the installation and verification:
	__5.  Close the File Browser window and all open files.

	Part 3 -  Test the Application Server
	__1.  Start the Application Server.  Do this by following the set of steps below:
	__2.  Once the server is started, open a web browser and type the URL 'http://localhost:9080/snoop' into the address bar.  You should see the output below.
	__3.  Close the web browser used to test the Application Server.
	__4.  Stop the Application Server.  Do this by following the set of steps below:

	Part 4 -  Summary

	Lab 2 -  Install an Application
	Part 1 -  Control Applications From the Admin Console
	__1.  Start the Application Server.  Do this by following the set of steps below:
	__2.  Start the Admin Console by opening a Web browser and entering the URL http://localhost:9060/ibm/console/
	__3.  Since security is enabled you will get a warning about the server certificate.  Accept the certificate or continue to the website depending on the browser you are using.
	__4.  Enter a user ID and password of ‘wasadmin’ and click “Log in” on the Login screen of the Console.
	__5.  Expand the Applications group in the Navigation tree, expand Application Types and click on the link for WebSphere enterprise applications.
	__6.  Check the checkbox next to the DefaultApplication and press the Stop button.  You should get a message that the application was stopped and a red ‘X’ in the status column.
	__7.  Open a separate Web browser and try to access the Snoop Servlet as in the last lab. The URL is http://localhost:9080/snoop.  You should get an error.  This is because it is part of the DefaultApplication which is stopped. 
	__8.  In the Admin Console, check the checkbox next to the DefaultApplication and press the Start button.  You should get a message that the application was started and a green arrow in the status column.
	__9.  In the Web browser you used to access the Snoop Servlet, hit the refresh button.  You should see the normal output of the Snoop Servlet.  
	__10.  Close the extra Web browser you were using to test the Snoop application.

	Part 2 -  Install an Application to the Server
	__1.  Return to the web browser you were using for the Admin Console.  If you had closed it you can open it at http://localhost:9060/ibm/console/ and login is wasadmin.
	__2.  In the Applications group in the navigation, click the link for New Application.
	__3.  Click the link for New Enterprise Application.
	__4.  Next to the Local file system box, press the Browse button.
	__5.  Find the file <LABFILES_DIR>/Install/HitCount.ear and select Open in the file chooser dialog.  Remember to substitute the value of the <LABFILES_DIR> variable from the notes at the beginning of the labs.
	__6.  Press the Next button.
	__7.  Check the option for Detailed installation.  This will show all steps.
	__8.  Once you have the options specified as below, press the Next button.
	__9.  On step 1, check the Precompile JavaServer Pages files option and click Next.
	__10.  Accept the default values on steps 2-12 by pressing the Next button on each step.  Some of these steps will only appear once you go through other steps.  You should end up at step 13 which is the summary.  Some of the intermediate steps are explained below:
	__11.  On step 13, the Summary, click the Finish button.  Wait for it to complete the installation and be sure you get a message that says Application HitCount installed successfully.
	__12.  Click the link to Review changes to the master configuration below the message about the successful installation.
	__13.  On the Save screen, click the '+' sign to expand the list of changes that will be made.
	__14.  Click the Save button to save the master configuration.
	__15.  In the Applications group in the navigation, expand the Application Types section and click the link for WebSphere enterprise applications.
	__16.  Start the HitCount application by checking the checkbox next to it and clicking the Start button.
	__17.  Make sure HitCount is started.

	Part 3 -  Test the HitCount Application
	__1.  Make sure that you are viewing the list of Enterprise Applications in the Admin Console.  If not, you can expand the 'Applications → Application Types' group in the navigation and click the link for 'WebSphere enterprise applications'.
	__2.  From the list of applications, click the link for the HitCount application by clicking on the application name.  This will show you a page of options and configuration related to that particular application.
	__3.  From the list of Detail Properties associated with the HitCount application click the link for View Deployment Descriptor.
	__4.  In the text of the Deployment Descriptor find the value of the context-root.  This is what you can add to the host name and port of the server to access the application.
	__5.  Open a new web browser and enter the URL: 
	__6.  Click the link of the home page of the application.  You should get an initial count of '1'.
	__7.  Refresh the page several times to see the count increase.
	__8.  Leave the web browser open that you are using to test the application.
	__9.  Return to your Admin Console web browser.  If you closed it, open a new window to the URL http://localhost:9060/ibm/console/.  Make sure you leave the web browser running the HitCount application open.
	__10.  Expand the 'Applications → Application Types' group in the navigation and click the link for 'WebSphere enterprise applications'.
	__11.  Check the checkbox next to the HitCount application and press the Stop button.
	__12.  Once the application is stopped, check the checkbox next to the HitCount application again and press the Start button.
	__13.  Return to the web browser you were using to test the application and refresh the page.  The count should return to 1 even though you are using the same web browser.  The “state” of the stateful session EJB has been lost by restarting the application.
	__14.  Close the web browser you used to test the new application.
	__15.  In the web browser showing the Admin Console click the Logout link near the top of the Console.
	__16.  Close the web browser you were using for the Admin Console.
	__17.  Stop the Application Server.  Do this by following the set of steps below:

	Part 4 -  Summary

	Lab 3 -  IBM HTTP Server and Web Server Plug-in
	Part 1 -  Install IBM HTTP Server
	__1.  Make sure you are logged in as the 'root' user ID.
	__2.  Open a terminal window.  You can do this by selecting 'Applications -> Accessories -> Terminal'.
	__3.  Navigate to the <WAS_SOFTWARE_DIR>/Supplement/IHS directory substituting the <WAS_SOFTWARE_DIR> variable location mentioned in the beginning of these labs.  Check with your instructor if you can't find the directory listed.
	__4.  Execute the following command to launch the WebSphere installation.
	__5.  Click Next on the Welcome screen.
	__6.  Accept the license and click Next.
	__7.  You will get a warning that the system does not pass the prerequisites check.  Press the Next button to ignore the warning and continue.
	__8.  Write down the installation directory for the <IHS_ROOT> variable in the list of directory paths at the beginning of these labs.  This directory will be used later in the labs.  Leave the default installation directory as is and press the Next button.
	__9.  Accept the default values for the HTTP port and administration port.  Click the Next button.
	__10.  Leave the option for “Create a user ID for IBM HTTP administration server authentication” checked.  
	__11.  Fill in a user ID and password of 'ihsadmin'. Click the Next button.
	__12.  Leave the options for “Setup HTTP Administration Server” checked and fill in a User ID and group of 'ihsadmin'.  Click the Next button.
	__13.  Leave the option for “Install the IBM HTTP Server Plug-in for IBM WebSphere Application Server” option checked.  Make sure that the Host name listed matches the value for the <hostname> variable you wrote down in the lab notes section for the WebSphere installation.  Click the Next button when you have checked the settings on this page.
	__14.  Press the Next button in the summary screen to start the installation.
	__15.  Press the Finish button to close the installation wizard when IBM HTTP Server is successfully installed.

	Part 2 -  Configure Web Server in WebSphere Configuration
	__1.  Open a terminal window.  
	__2.  Use the 'cd' command to change to the <WAS_ROOT>/profiles/AppSrv01/bin directory.  
	__3.  Issue the command './startServer.sh server1'.
	__4.  Open another terminal window.  
	__5.  Change directories using the 'cd' command to the <IHS_ROOT>/bin directory.  Be sure to substitute the value of <IHS_ROOT> from the “Directory Paths” page at the beginning of the lab instructions.
	__6.  Execute the following command to start the web server.  
	__7.  Execute the following command to start the HTTP administration service.
	__8.  Open a File Browser window or use one you already have open.
	__9.  Navigate to the directory <IHS_ROOT>/Plugins/bin where the <IHS_ROOT> is the variable you wrote down from the IBM HTTP Server installation in the previous section.
	__10.  Find the file 'configurewebserver1.sh' in the directory.  Check that you find the correct file as there are several that start with 'configure...'.  
	__11.  Copy the 'configurewebserver1.sh' file by right clicking and selecting Copy from the popup menu.
	__12.  Open another File Browser and navigate to the directory <WAS_ROOT>/bin where the <WAS_ROOT> is the variable you wrote down from the WebSphere installation lab.
	__13.  Paste the 'configurewebserver1.sh' file into this directory by selecting Edit -> Paste from the menus.
	__14.  Be sure you see the 'configurewebserver1.sh' file in the list of files.
	__15.  Make sure you have logged out of any previously open Admin Console browser windows.
	__16.  Open a terminal window.  
	__17.  Change directories using the 'cd' command to the <WAS_ROOT>/bin directory.  Be sure to substitute the value of <WAS_ROOT> from the “Directory Paths” page at the beginning of the lab instructions.
	__18.  Enter the following command to check that the WebSphere server is started:
	__19.  Enter the following command to configure the web server definition in the WebSphere configuration.  The command should all be entered on the same line even though it wraps to a second line below.
	__20.  Scroll back through the messages that were output and be sure you do not see any errors.

	Part 3 -  Configure Virtual Host on Web Server
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.  Remember to continue if you get any certificate errors.
	__2.  Login as the 'wasadmin' user.
	__3.  Navigate to the Servers → Server Types → Web Servers section of the admin console.  Notice there is now a configuration for 'webserver1' which the script you ran added.
	__4.  Click the link for webserver1 from the list.
	__5.  Under the Additional Properties click the link for Configuration File.  If you get an error displaying the configuration file let your instructor know as this likely means there is a problem with your IHS administration password.
	__6.  Scroll to the very end of the file and add a few blank lines.
	__7.  Add the following text exactly as it appears below at the end of the configuration file.  
	__8.  Check that your configuration appears as below and press the OK button.
	__9.  Go back to the list of web servers by navigating to the Servers → Server Types → Web Servers section of the admin console.
	__10.  Check the box next to the webserver1 entry and click the Stop button.  Make sure you get a message about the server stopping.
	__11.  Check the box next to webserver1 and click the Start button.  If you have trouble starting the web server check your configuration file syntax.
	__12.  Logout of the Admin Console.

	Part 4 -  Update Network Setup
	__1.  Open a File Browser window or use one you already have open.
	__2.  Navigate to the '/etc' directory.
	__3.  Find the 'hosts' file in this directory.
	__4.  Copy the 'hosts' file and rename the copy to something like 'hosts-backup'.  This will ensure you can restore the original if needed.
	__5.  Double-click on the ‘hosts’ file and open it with a text editor like gedit.
	__6.  If you do not already have a line that starts with the IP address 127.0.0.1 add it. 
	__7.  Add to this line 'was.myhost.com' with spaces between the IP address and each of the hostnames.  Make sure to add any entries AFTER the real hostname as shown below.  The file should be similar to this: 
	__8.  Save the file and close the text editor.
	__9.  Open a terminal window.  
	__10.  Be sure you can ping the new host name.  Enter the command below.  Be sure you don’t get an “unknown host” or “request timed out” error message.  
	__11.  Close the terminal window.
	__12.  Open a web browser window.
	__13.  Enter the URL http://was.myhost.com in the address bar of the browser and hit Return. You should see the homepage of the IBM HTTP Server running on your machine.  If you do not see this screen contact your instructor.
	__14.  Close out any extra terminal windows, web browsers, or File Browser windows you may have open.

	Part 5 -  Test Plug-in
	__1.  Open a web browser and enter the URL http://localhost:9080/HitCountWeb/ in the address bar and hit the Return key.  You should see the normal output of the HitCount application.
	__2.  Test the function of the application to be sure it is working properly.
	__3.  Enter the URL http://localhost/HitCountWeb into the address bar of the web browser and hit Return.  You should see the same application.  If you get any errors check that your web server is running.
	__4.  Test the application again to be sure the same behavior is shown even though the requests are now being forwarded through the Plug-in.
	__5.  Enter the URL http://was.myhost.com/HitCountWeb/ into the address bar of the web browser and hit Return.  Again you should see the same HitCount application.  This is because you have configured the web server to respond to the host name was.myhost.com.  It can also forward requests for this host name to WebSphere.
	__6.  Close the web browser you have been using to test.

	Part 6 -  Examine Plug-in Configuration
	__1.  Start the Admin Console by opening a Web browser and entering the URL http://localhost:9060/ibm/console/
	__2.  Enter a user ID and password of ‘wasadmin’ and click “Log in” on the Login screen of the Console.
	__3.  In the navigation panel on the left expand the Servers → Server Types group and click the link for Web Servers.
	__4.  Click the link for the webserver1 web server.
	__5.  Under the Additional Properties for the web server click the link for Plug-in properties.
	__6.  Press the View button next to the Plug-in configuration file name.
	__7.  Search through the configuration for the VirtualHostGroup element.  This has the definition of several VirtualHosts.  These are the host name and port combinations the Plug-in can expect to receive requests for.  The host name is listed as an asterisk (*) right now which means the Plug-in will accept requests for any host name the web server responds to.
	__8.  Search through the configuration for the Server element.  Within this element you will see “Transports” which have values for the host name and port numbers of the Application Server.  This is so the Plug-in knows what host name and port to use to forward requests to the Application Server.
	__9.  Search through the configuration for the UriGroup element.  Within this element you should see an entry for '/HitCountWeb/*'.  This is the entry that indicates the Plug-in can forward requests to the HitCount application.
	__10.  Search through the configuration for the Route entry.  This links together the three other parts of the Plug-in configuration you have looked at so far.
	__11.  Click the OK button on the bottom of the Plug-in configuration to close the view of the configuration file.

	Part 7 -  Configure Virtual Host in WebSphere
	__1.  In the WebSphere Admin Console expand the Environment navigation group and click the link for Virtual hosts.
	__2.  Notice that right now there are only two virtual hosts.  One is the “default_host” that you saw in the Plug-in configuration.  The other is an “admin_host” that is used only for the Admin Console.
	__3.  Click the New button above the list of virtual hosts.
	__4.  Fill in a Name of myhost for the new virtual host and press the Apply button.  Make sure you hit the Apply button as the OK button will not keep you on the same screen.
	__5.  To the right under Additional Properties, click the link for Host Aliases.
	__6.  Right now there are no host aliases.  Click the New button above the empty list of host aliases.
	__7.  Change the Host Name to was.myhost.com and leave the default port of 80.  Click the OK button when you have the properties filled in as below.
	__8.  The new host alias now appears in the list.  This is now the ONLY host name and port that applications mapped to this virtual host will recognize.
	__9.  Click on the Save link in the list of messages near the top of the main Console area.
	__10.  In the navigation area of the Console expand the Applications → Application Types group and click the link for WebSphere enterprise applications.
	__11.  Click the link for the HitCount application.
	__12.  In the list of Web Module Properties on the right click the link for “Virtual hosts”.
	__13.  Use the drop down next to the HitCountWeb Web module to select the myhost Virtual host from the list.  Press the OK button when you have the properties set as below.
	__14.  Back on the screen for the HitCount application, click the link for “Manage Modules” in the Modules section of properties.
	__15.  Notice that the Web module is already mapped to the webserver1 web server AND the server1 Application Server.  This indicates that requests for that application will pass through the webserver1 web server on the way to server1.  This is a critical setting for configuring the web server Plug-in configuration for webserver1.
	__16.  Click on the Save link in the list of messages near the top of the main Console area.
	__17.  In the navigation panel on the left expand the Servers → Server Types group and click the link for Web Servers.
	__18.  Check the checkbox next to webserver1 and click the Generate Plug-in button.
	__19.  Check the checkbox next to webserver1 and click the Propagate Plug-in button.
	__20.  Click the link for the webserver1 web server.
	__21.  Under the Additional Properties for the web server click the link for Plug-in properties.
	__22.  Press the View button next to the Plug-in configuration file name.
	__23.  If you look in the configuration you will notice there are now entries for the myhost VirtualHostGroup you created and the UriGroup for the HitCountWeb Uri is now listed separately.  There is also a new Route entry that associates the entries relating to the HitCount application.  You may need to scroll around the file as there are many other entries.
	__24.  When you are done looking at the new Plug-in configuration, click the Logout link in the Admin Console.

	Part 8 -  Test the New Virtual Host
	__1.  Open a terminal window.  
	__2.  Use the 'cd' command to change to the <WAS_ROOT>/profiles/AppSrv01/bin directory.  Be sure to substitute the value of <WAS_ROOT> from the “Directory Paths” page at the beginning of the lab instructions.
	__3.  Issue the command:
	__4.  Issue the command to restart the server:
	__5.  Open a web browser and enter the URL http://was.myhost.com/HitCountWeb/ into the address bar of the web browser and hit Return.  You will see the normal output of the HitCount application.  This is expected since the application is still registered to respond to this host name and port combination.
	__6.  Test the function of the application to verify it is working correctly.
	__7.  Notice the URL that appears in the browser for the page that displays the messages.  It is:
	__8.  Enter the following URLs into the web browser that have worked before:
	__9.  Close the web browser you were using for testing.

	Part 9 -  Investigate Application Settings
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the navigation area of the Console expand the Applications → Application Types group and click the link for WebSphere enterprise applications.
	__4.  Click the link for the HitCount application.
	__5.  Under the Detail Properties section, click the link for View Deployment Descriptor.
	__6.  Make sure all the entries are expanded and locate the 'context-root' element.  This forms the first part of the URL that comes after the host name and port.  Notice this also mentions a 'HitCountWeb.war' module for the application.
	__7.  In the “breadcrumb” trail at the top of the page click the link for the “HitCount” application.  This will take you back to the properties of the application configuration.
	__8.  At the top of the page of properties for the HitCount application click the link for Manage Modules under the Modules section of properties.
	__9.  In the list of modules click the link for the HitCountWeb module.
	__10.  On the right side, click the link for View Deployment Descriptor.
	__11.  Make sure all the entries are expanded and locate the 'servlet-mapping' element.  This links the servlet in the application to the URL suffix '/HitCountServlet'.
	__12.  Logout of the Admin Console and close the web browser.
	__13.  Stop the Application Server using the method you are most familiar with.

	Part 10 -  Summary

	Lab 4 -  Solving Problems
	Part 1 -  Introduce Problem
	__1.  If it is not already running, start the Application Server.  You can do this by executing the command './startServer.sh server1' from the <WAS_ROOT>/profiles/AppSrv01/bin directory.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console/, the URL for the Admin Console.
	__3.  Login to the Admin Console as 'wasadmin'.
	__4.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__5.  From the list of Enterprise Applications, click on the link for the HitCount application.
	__6.  Under the Enterprise Java Bean Properties section on the right side click the link for EJB JNDI names.
	__7.  In the JNDI Name field, change the value to 'ejb/GARBAGE' and press the OK button.
	__8.  Click the Save link in the messages at the top of the Admin Console.
	__9.  Logout of the Admin Console and close the browser window.
	__10.  Stop the IBM HTTP Server by executing the './apachectl stop' command from the <IHS_ROOT>/bin directory.
	__11.  Stop the WebSphere Application Server by executing the following command from the <WAS_ROOT>/profiles/AppSrv01/bin directory.

	Part 2 -  Isolate Problems
	__1.  Open a Web Browser and enter http://was.myhost.com/ in the address bar.  
	__2.  Leave the web browser window open.
	__3.  Open a terminal window. 
	__4.  Enter the command 'ping -c 4 was.myhost.com'.  Be sure you do not get a response which states “Unknown Host”.  If you did get this response the problem would be in the networking setup. You should get replies as shown below.
	__5.  Change directories to the <IHS_ROOT>/logs directory.  Make sure to substitute the value of the <IHS_ROOT> variable you wrote down in the Directory Paths page at the beginning of the labs.  The command for this should be ‘cd /opt/IBM/HTTPServer/logs’.
	__6.  Execute the command 'ls httpd.pid'.  If this file is not found it means the web server is not running.
	__7.  Change directories to the <IHS_ROOT>/bin directory.
	__8.  Start the IBM HTTP Server using the './apachectl start' command.
	__9.  Return to the web browser that you used to access http://was.myhost.com and refresh the page.  This time you should see the homepage of the IBM HTTP Server.  This confirms you can communicate with the web server.
	__10.  Enter http://localhost/snoop in the address bar.  You should get an “Internal Server Error”.  This request should be sent to the Application Server through the Web Server plug-in.
	__11.  To test the Application Server directly enter http://localhost:9080/snoop in the address bar.  You should get the same “Cannot find server or Failed to Connect” error.  Since this request should be sent directly to the Application Server on port 9080 the problem is in communicating with the Application Server.  The previous “Internal Server Error” occurred because the plug-in tried to forward the request to the Application Server but could not contact it.
	__12.  Start the WebSphere Application Server by executing the './startServer.sh server1' command from the <WAS_ROOT>/profiles/AppSrv01/bin directory.  Wait for the service to start completely.
	__13.  Close the previous Web Browser.  This ensures that the browser is not caching the error response.
	__14.  Open a new Web Browser and enter http://localhost:9080/snoop in the address bar.  You should get the normal response from the Application Server.
	__15.  Remove the port from the URL and resubmit the request for http://localhost/snoop.  This ensures the Web Server plug-in can forward the request properly.
	__16.  Change the URL to http://localhost/snoop5 and resubmit the request.  You should get a “The page cannot be found” error.  This is from an HTTP 404 error.  Since we know this request is not mapped to anything this error is expected.
	__17.  Enter http://was.myhost.com/HitCountWeb in the address bar.  You should see the main page of the HitCount application.
	__18.  Click the link to attempt to access the page that displays the counter.  You will get a 500 “Internal Server Error” because of the problem that was introduced in the first part of the lab. Notice that the “Internal Server Error” may be formatted differently because it is coming from the WebSphere Application Server and not the web server.

	Part 3 -  Check Admin Console Messages
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  Expand the Troubleshooting section in the navigation panel and expand Runtime Messages.
	__4.  Click the link for Runtime error messages.  By default the runtime messages are disabled so you will not see any.
	__5.  Use the dropdown to select Warning and press the Apply button.
	__6.  Click the link to Save the configuration.
	__7.  Go back to the browser you were using to test the HitCount application.  Open a new one if you closed it.  Test the application again and be sure that you see the error again.
	__8.  Return to the Admin Console.
	__9.  Click the link for Runtime warning messages in the Admin Console.
	__10.  You should see some messages as shown below.  You may have more if you viewed the page more than once or caused other errors previously.  
	__11.  Click the link for the message in the list which mentions something about “A NameNotFoundException occured...”.  
	__12.  In the details of the message you should see that the error is because the name 'ejb/Counter' could not be found.  This was the name before it was changed.

	Part 4 -  Check Log Files
	__1.  In the Admin Console click on the link for Troubleshooting -> Logs and Trace.
	__2.  Click the link for server1 in the list.
	__3.  Click the link for JVM Logs.
	__4.  On the Configuration tab look at some of the settings available.  Notice that you can configure the file name used for the log, enable and configure log file automatic rotation, and the number of historical log files to keep if rotation is enabled.  You can even disable “application print statements” although this is usually not a good idea because developers may be printing out valuable messages for tracking down errors.
	__5.  Click the Runtime tab.
	__6.  Write down the File Name of the System.out log in the Lab Notes section at the beginning of the labs.  
	__7.  Click the View button next to the System.out log file name to display the log file in the Admin Console.
	__8.  When the Admin Console displays the log file, notice the two numbers near the top.  The Admin Console displays the Total number of lines in the log file and the Filtered total which is what is actually displayed in the Console.
	__9.  Display the last three hundred lines of the log by entering in the Retrieve Lines text box a range that starts about three hundred lines before the total number of lines and ends with the last line.  In the above example this might be 7000-7340.  Press the Refresh button after entering the new range.
	__10.  When the log file is redisplayed (which may take a moment), scroll to the very bottom and begin scrolling backwards.  This will view the most recent messages first and go back to earlier messages.  Stop when you see any line that is tabbed in from the left and does not start with a time stamp.  This is the end of a Java “stack trace”.
	__11.  Continue to scroll backwards until you reach a block of several “normal” messages that start with timestamps and have an “I” or “A” for the event type.  You may pass several Java problems being reported together.  This is common in a Java multi-threaded application like a J2EE Application Server.  Usually the most detailed information is present in the first problem that gets reported.
	__12.  In the first line of the first Java problem reported scroll to the right.  You should see the same “NameNotFoundException” mentioned in the console message.  
	__13.  Logout of the admin console and close any extra web browsers or windows.

	Part 5 -  Use dumpNameSpace Tool
	__1.  Open a terminal window.  
	__2.  Change directories using the 'cd' command to the <WAS_ROOT>/profiles/AppSrv01/bin directory.  Be sure to substitute the value of <WAS_ROOT> from the “Directory Paths” page at the beginning of the lab instructions.
	__3.  Issue the command './dumpNameSpace.sh'.
	__4.  In the security prompt supply a user ID and password of 'wasadmin'.
	__5.  In the output look for the entry in the right column for hitcount.Counter.  You will need to scroll around a bit to find it.  This is the interface used by the EJB client.  Notice the entry on the left side is the incorrect JNDI name that we supplied.  You can use the messages we have seen to verify that the name expected by the EJB client, ejb/Counter, is not listed.  The line number where your entry shows up may be different.
	__6.  Close the terminal window.

	Part 6 -  Correct the Problem
	__1.  Open a web browser and enter http://localhost:9060/ibm/console/, the URL for the Admin Console.
	__2.  Login to the Admin Console as 'wasadmin'.
	__3.  In the Admin Console, navigate to Applications → Application Types →  WebSphere enterprise applications.
	__4.  From the list of Enterprise Applications, click on the link for the HitCount application.
	__5.  Under the Enterprise Java Bean Properties section on the right side click the link for EJB JNDI names.
	__6.  In the JNDI Name field, change the value to 'ejb/Counter' and press the OK button.  
	__7.  Click the Save link in the messages at the top of the Admin Console.
	__8.  Check the checkbox next to the HitCount application and press the Stop button.
	__9.  Once the application is stopped, check the checkbox next to the HitCount application again and press the Start button.
	__10.  Logout of the Admin Console.
	__11.  Open a web browser and enter http://was.myhost.com/HitCountWeb in the address bar.  You should see the main page of the application.
	__12.  Click the link on the page to submit a request that will begin counting the number of times you view a page.  The application should be able to correctly count the number of hits.
	__13.  Refresh the page several times to see the count increase.
	__14.  Close any extra web browsers, File Browser windows, or terminal windows you may have open.

	Part 7 -  Summary

	Lab 5 -  IBM Support Assistant Troubleshooting
	Part 1 -  ISA Workbench
	__1.  Start the IBM Support Assistant by selecting 'Applications → Programming → IBM Support Assistant Workbench 4.1'  
	__2.  Select 'File → Preferences' from the ISA menus.
	__3.  Select 'Network Connections'.  Do not change any settings now but this is where you would configure settings for a proxy server to allow the tool to connect to IBM and download updates to existing add-ons or install new add-ons.
	__4.  Select 'Updater Preferences'.  Do not change any settings now but this is where you can control how the ISA tool checks for updates to installed add-ons.
	__5.  Select 'Global Search → User Interface'.  This is where you can configure settings for the search tool.
	__6.  Click the Cancel button to close the preferences.
	__7.  Expand the Update menu to see the choices but do not make any selections.  This is where you can manually search for updates.  This is also the menu you would use to find new add-ons for other products or additional tools.  This can be very useful if using several different versions or types of IBM software.
	__8.  On the home screen, click the icon for the “Find Information” activity.
	__9.  The “Search Information” screen is where you can search multiple sources at once for various search terms.  The results are processed asynchronously so you do not have to wait for all sources to be searched before browsing results.  If you do not need a proxy to connect to the Internet you can try a search now.
	__10.  Click the tab for “Product Information”.  This page has useful links to product information.  If ISA can connect over the Internet it will also show links to some of the most recent product support news announcements.

	Part 2 -  Perform Guided Troubleshooting
	__1.  From the top left of the ISA tool, press the Launch Activity button to provide a menu and select Analyze Problem from the list.
	__2.  Click the 'Guided Troubleshooter' tab at the top.  It may take a second to initialize the tool.
	__3.  Leave the “Troubleshoot a problem” option selected and press the Next button.
	__4.  Fill in a Case name of “Sample Problem” and press the Next button.  Normally you could also provide additional information about the problem here as well to store with the case.
	__5.  Select the “WebSphere Application Server Troubleshooting” option and press the Next button.  If you had support for other products installed you might be able to run guided troubleshooting for those products also.
	__6.  Leave the “Guide me...” option selected and press the Next button.
	__7.  Leave the “The application performs poorly...” option selected and press the Next button.  You will choose different options in this step depending on the actual problem you are trying to troubleshoot.  If you want more description about what types of problems each choice entails you can expand the information in the lower half of the screen using the '+' symbols.
	__8.  Select the “My application cannot connect...” option and press the Next button.
	__9.  Leave the option for “Troubleshoot JCA and JDBC...” selected and press the Next button.  If you select the “advanced troubleshooting” option early on instead of the “guide me” option you can skip directly to this type of choice.
	__10.  The next step simply describes in more detail the type of problems this troubleshooting covers so press the Next button.
	__11.  Leave the option for “JDBC Connection...” selected and press the Next button.
	__12.  The next step simply describes the steps that will be taken so press the Next button.
	__13.  Notice there is information in the lower section on how to open the Admin Console and perform a data source connection test.  Although we will not actually do this test the guided troubleshooting is helping you to perform basic tests like this.  Do not move to the next step yet.
	__14.  On the right side, in the “Case Manager” section, right click the 'Sample Problem' case and select 'New Note'.
	__15.  Fill in a name of 'Connection Test Error' for the note along with some sample text for the body of the note.  Normally you might copy the text of an error from the Admin Console or browser into the note text to store the results as part of the case.
	__16.  Press the OK button when you are done filling out the new note form.
	__17.  Back in the guided troubleshooting press the Next button.
	__18.  Press the Add Files button in the guided troubleshooting.
	__19.  On the window that appears expand the 'My Computer → Local Agent → Unix Root' groups.
	__20.  Expand the entry for the disk your WebSphere installation is on and find the location of the SystemOut.log file.  You should have this location written down in the lab notes from another lab.  Normally it is <WAS_ROOT>/profiles/AppSrv01/logs/server1/SystemOut.log.
	__21.  Select the SystemOut.log file from the window.  If you have another file which starts with a timestamp this is a historical log file.  Select it also by holding the CTRL key while you click on it.  Once you have the logs you wish to include selected as shown below press the OK button.
	__22.  On the right side, in the “Case Manager” section, right click on one of the new files you added and notice the options.  Do not select any of them.
	__23.  Right click the 'Sample Problem' case and notice some of the various options.  Of particular importance is the import/export case options which would let you share all of the notes, results, and files of a case as a zip file.  You can also create a new “incident” if you see a repeat of a past problem but want to capture unique log files and other information.
	__24.  Back in the guided troubleshooter click the Pause Case button.
	__25.  Click the OK button to return to the first screen of the guided troubleshooter.

	Part 3 -  Analyze Log Files
	__1.  Open a File Browser window and navigate to the <LABFILES_DIR>/Troubleshoot directory.
	__2.  Extract the zip file in this directory into the same location.  This should create a 'websphere_application_server_7_0_en.symptom' file.  Make sure the archive utility does not create a subdirectory.
	__3.  Select the Tools tab of the 'Analyze Problem' activity page.  If you do not have this section open select 'Launch Activity → Analyze Problem' first.
	__4.  From the list select the 'Log Analyzer' tool and press the Launch button at the bottom of the page.  
	__5.  Wait for a second for the tool to start.  The version of the Log Analyzer may be different and there may be other differences with the other tools that that shown below.
	__6.  Select File -> Import Symptom Catalog...
	__7.  Check the Local host option and press the Browse button to locate the file <LABFILES_DIR>/Troubleshoot/websphere_application_server_7_0_en.symptom file and click OK.
	__8.  Press the Finish button to import the symptom catalog.  It may take a while to import.
	__9.  Select File → Import Log... from the menus. 
	__10.  Select 'Import from an IBM Support Assistant Case' and press the Next button.
	__11.  Select the 'Sample Problem' case and select all log files listed.  If you need to select more than one you can hold the CTRL key while clicking on the second.
	__12.  With the log files selected above, click the Add button to the right of the top list.  It may take a few seconds to add the logs.
	__13.  Check that the logs you want to import appear on the bottom list and press the Finish button.  It may take several seconds to import the logs.
	__14.  If presented with a Download Symptom Catalogs dialog press the Cancel button.
	__15.  In the 'Navigator' view you will see the various logs and symptom catalogs you imported.
	__16.  In the 'Navigator' view right click on the 'Logs' folder and select View All Logs.  This will combine the information from multiple logs if you have it.
	__17.  At the bottom of the Log View you should see that there are many pages of records in the log.  Note the number of pages for your log file as it may be different than what is shown here.
	__18.  On the bottom of the Log View click the button Last Page.
	__19.  Scroll in the log file and see if you can find any error messages.  Although you could keep going to other pages to look for errors there is any easier way.
	__20.  Use the drop down next to the Manage Filters icon in the toolbar and select the 'Show warning and error log records' filter.
	__21.  Click on one of the red log records that is in the list.
	__22.  Select the "Event Details" tab in the 'Property View' to get the “Event Details” of the message.  Most importantly this should have the message text although you may want to maximize the Properties view or scroll in the message text to read it all.
	__23.  Close the "Property View" window.
	__24.  Select the warnings (with yellow severity) that mentions the NameNotFoundException.
	__25.  Right click on the message and select Analyze Selection.
	__26.  If presented with a Download Symptom Catalogs dialog press the Cancel button.
	__27.  Click OK in the Analysis Status window.
	__28.  Maximize the 'Symptom Analysis Results' that appears by double clicking on the title bar of the view.
	__29.  On the left, select the single result that appears in the list.
	__30.  On the right, select the 'Recommendations and actions' tab.
	__31.  In the detail section notice that the “Recommendation” has some additional information that could be used to help resolve the problem.
	__32.  Close the Log Analyzer.  When prompted, click Yes to save the log data.  If you were to click No the log file you imported (and perhaps the symptom database) would be lost.
	__33.  Close the IBM Support Assistant.

	Part 4 -  Review

	Lab 6 -  Install Database Application
	Part 1 -  Create Database
	__1.  Open a terminal window. 
	__2.  Use the 'cd' command to navigate to the <LABFILES_DIR>/Database directory.
	__3.  Execute the command 'which db2'.  This will verify you can execute DB2 commands.  If you do not get the response below contact your instructor.
	__4.  Execute the 'chmod +x createDatabase.sh' command to verify the script is executable.
	__5.  Run the script by executing the command ./createDatabase.sh.  You should start to see messages about the script performing database commands.  Wait a few minutes while the script finishes creating and setting up the database.
	__6.  Open the CreateDB.log file from the same directory as the script using a text editor or the 'more' command.  Look for any obvious errors creating the database or importing the data.  In particular be sure there are several tables listed at the end of the log as shown below.

	Part 2 -  Configure JDBC Provider
	__1.  Make sure your WebSphere server is running.  If it is not running start it using one of the methods you are already familiar with.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the Admin Console, navigate to Resources -> JDBC -> JDBC Providers.
	__5.  Use the drop down for the Scope setting at the top of the list to select Cell=<cellname>.  Once the scope of <cellname> is shown press the New button.
	__6.  On the first screen of the New JDBC Provider setup select the following options.  The contents of the last two drop down lists will change once you start selecting the first two options.  Press  the Next button once you have filled in the options as shown below.
	__7.  Fill in the box for DB2UNIVERSAL_JDBC_DRIVER_PATH with a value of <DB2_ROOT>/java and remember to substitute the value of <DB2_ROOT> from the Directory Paths section at the beginning of the labs.  The final value should be something like '/opt/ibm/db2/V9.5/java'.  Leave the value of Native library path empty.
	__8.  Press the Next button when your screen appears as below.
	__9.  Press the Finish button to create the JDBC Provider.  You should see the new JDBC Provider in the list.
	__10.  Click the Save link in the messages at the top of the Admin Console.

	Part 3 -  Configure Security Authentication
	__1.  In the Admin Console navigate to Security -> Global Security.
	__2.  On the right side, under the Authentication section, expand Java Authentication and Authorization Service and click the link for J2C Authentication data.
	__3.  Press the New button on the list of entries.
	__4.  In the fields for the new Authentication Data Entry fill in the following properties.  Note that you only supply the password once and there is no “Confirm password” box that will check you enter the same value so be careful typing the password.  Press the OK button when the properties are filled in as below.
	__5.  Verify that the new entry shows up in the list.  Notice that the alias is prefixed with the name of the Node where the Application Server resides.
	__6.  Click the Save link in the messages at the top of the Admin Console.

	Part 4 -  Configure Data Source
	__1.  In the Admin Console, navigate to Resources -> JDBC -> JDBC Providers.
	__2.  Check that you are at the <cellname> scope as in previous sections of this lab.  If you need to switch scope, select the scope using the drop down list.
	__3.  Click the link for the JDBC Provider you configured in a previous section.  This should be DB2 Universal JDBC Driver Provider (XA) if you left the default name from before.
	__4.  On the right, under the Additional Properties section, click the link for Data Sources.  Be sure not to select the 'Data Sources (Version 4)' link.
	__5.  Press the New button above the list of Data Sources.
	__6.  On the first page of the Data Source configuration fill in or change the following values.
	__7.  Press the Next button once your values are filled in as below.
	__8.  On the second configuration page fill in the following values:
	__9.  Press the Next button once your values are filled in as below (with your hostname).
	__10.  On the security aliases step select the following choices and press the Next button.
	__11.  Press the Finish button to create the Data Source.  You should see the new Data source in the list.
	__12.  Click the Save link in the messages at the top of the Admin Console.
	__13.  In the list of Data Sources, check the box next to the Online Store DB Data Source and press the Test Connection button.
	__14.  Check that you get a message about a successful test.  You may get a warning but be sure you do not see red errors.  If you do not get a successful test, check the values of the database name of the Data Source, the value of the environment variable, and the user ID and password for the authentication alias as these are the most common errors.  You can use the troubleshooting techniques from the last lab to track down the problem or contact your instructor.
	__15.  Click the Logout link to logout of the Admin Console.
	__16.  Use a method you are familiar with to stop the Application Server.
	__17.  Once the Application Server is stopped then start it again.

	Part 5 -  Install OnlineStore Database Application
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the Applications group in the navigation, click the link for New Application.
	__4.  Click the link for New Enterprise Application.
	__5.  Next to the Local file system box, press the Browse button.
	__6.  Find the file <LABFILES_DIR>/Database/OnlineStore-Database.ear and select Open in the file chooser dialog.  Remember to substitute the value of the <LABFILES_DIR> variable from the notes at the beginning of the labs.
	__7.  Press the Next button.
	__8.  Check the option for Detailed installation.  This will show all steps.
	__9.  Once you have the options specified as below, press the Next button.
	__10.  On Step 1: Select installation options leave the default options and press the Next button.
	__11.  On Step 2: Map modules to servers check the checkbox next to the OnlineStoreWeb module.  Select both servers from the list above by holding down the CTRL key as you select each one.  Press the Apply button to apply the changes to the mapping of the web module.  Make sure the OnlineStoreWeb module is mapped to BOTH servers as shown below and press the Next button.
	__12.  Click the link for Step 9 on the left to skip to this step.
	__13.  Check that the resource reference mapping for the data source matches the JNDI name you gave the data source in previous sections.  If you are not sure you can use the Browse button to pick the name of the data source from a list.  Once your resource reference mapping is set press the Next button.
	__14.  On Step 10: Map virtual hosts for web modules select myhost from the drop down menu and press the Next button.  This choice will make the application only available by using the was.myhost.com host name on port 80.
	__15.  Click the link for Step 13 on the left to skip to this step.
	__16.  On Step 13: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__17.  Click the Save link in the messages at the bottom of the Admin Console.
	__18.  Open a terminal window.  
	__19.  Change directories using the 'cd' command to the <IHS_ROOT>/bin directory.  Be sure to substitute the value of <IHS_ROOT> from the “Directory Paths” page at the beginning of the lab instructions.
	__20.  Issue the command './apachectl restart' to restart the web server.
	__21.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__22.  Check the checkbox next to the OnlineStore application and press the Start button.  Wait for a message that the application started successfully.

	Part 6 -  Test OnlineStore Application
	__1.  Open a Web Browser and enter http://was.myhost.com/Store in the address bar.  You should see the homepage of the application.
	__2.  Click on the Register link to display the page to register as a new Customer.
	__3.  Fill in the fields with some sample data.  The only requirements are that the Email and Full Name fields must be filled in and the Zip must contain only numbers.  Press the Register button. If there is any problem with the database or Data Source setup this is when you will find out.
	__4.  Click the link to Start Shopping.
	__5.  On the Product List, change some of the quantities to be non-zero and press the Add to Cart button.
	__6.  At this point you can either click the link to Add More Items or fill in the required address information and press the Complete purchase button.
	__7.  Test some of the other functions of the application.  Be sure you try to logout and log back in under the ID that you registered.
	__8.  Close the web browser you were using to test the application.
	__9.  Logout of the Admin Console and close the web browser.
	__10.  Close any extra web browsers, File Browser windows, or terminal windows you may have open.

	Part 7 -  Summary

	Lab 7 -  Enable JMS Messaging Using WebSphere MQ
	Part 1 -  Configure WebSphere MQ
	__1.  Open a terminal window.  
	__2.  Use the 'cd' command to navigate to the <LABFILES_DIR>/Messaging directory.
	__3.  Execute the 'chmod +x createStoreQueue.sh' command to verify the script is executable.
	__4.  Run the script by executing the command './createStoreQueue.sh $PWD'.  You should start to see messages about the script performing WebSphere MQ commands. Wait a few minutes while the script finishes creating and setting up the WebSphere MQ resources.
	__5.  Check that you get messages about the queue creation being successful as shown below.
	__6.  Close the terminal window you were using to configure the queue.  The queue manager will remain running for the rest of the lab.  Anytime you restart the virtual machine you will need to also manually restart the Queue manager.

	Part 2 -  Configure WebSphere MQ JMS Provider
	__1.  Be sure your Application Server is running.  Start it if it is not running.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the navigation panel, navigate to Environment -> WebSphere Variables.
	__5.  Click on the link for the MQ_INSTALL_ROOT.  You may need to view the second page of variables to see this variable.  Notice that you may not see the underscore characters because it is a link.
	__6.  Change the value of this variable to match the value of the <MQ_ROOT> variable in the Directory Paths section at the beginning of the labs.
	__7.  Once the value is filled in as above press the OK button.
	__8.  Click the Save link in the messages at the top of the Admin Console.
	__9.  In the navigation pane select Resources -> JMS -> Connection factories.
	__10.  Use the drop down for the Scope setting at the top of the list to select Cell=<cellname>.  Once the scope of your cell is shown press the New button.
	__11.  Select the radio button for WebSphere MQ messaging provider and press the OK button.
	__12.  At the Configure basic attributes page, enter the following information.  Write down the JNDI Name of the Connection Factory in the Lab Notes section.  Press the Next button when done.
	__13.  Leave the default option to enter all connection information in the wizard and press the Next button.
	__14.  Enter 'STOREQM' for the queue manager and press the Next button.
	__15.  Enter your <hostname> in the connection details and press the Next button.
	__16.  Skip the test connection step and press the Next button.
	__17.  Press the Finish button to create the connection factory.
	__18.  Click the link in the navigation pane for Resources -> JMS  -> Queues.
	__19.  Check that you are at the cell scope as in previous sections of this lab.  If you need to switch scope, select the scope using the drop down list.
	__20.  At the Queues list, press the New button.
	__21.  Select the radio button for WebSphere MQ messaging provider and press the OK button.
	__22.  At the New Queue page, enter the following information.  Leave the rest of the settings with the defaults.  Write down the JNDI Name of the Queue in the Lab Notes section.  Note the screenshots below only show the sections that have settings that are changed.
	__23.  When the values match those above press the OK button.
	__24.  Click the Save link in the messages at the top of the Admin Console.

	Part 3 -  Configure the JMS Activation Specification
	__1.  In the navigation pane select Resources -> JMS -> Activation specifications.
	__2.  Check that you are at the cell scope as in previous sections of this lab.  If you need to switch scope, select the scope using the drop down list.
	__3.  At the JMS Activation Specifications list, press the New button.
	__4.  Select WebSphere MQ messaging provider as the choice for provider so press the OK button.
	__5.  At the Configure basic attributes page, enter the following information.
	__6.  Write down the JNDI name of the Activation Specification in the “Lab 7” section of the Lab Notes and press the Next button.
	__7.  At the Specify MDB destination data page, enter the following information.
	__8.  Check that the Destination JNDI name matches the value you had written down in the Lab Notes section and press the Next button.
	__9.  Leave the default option to enter all connection information in the wizard and press the Next button.
	__10.  Enter 'STOREQM' for the queue manager and press the Next button.
	__11.  Enter your <hostname> in the connection details and press the Next button.
	__12.  Skip the test connection step and press the Next button.
	__13.  Press the Finish button to create the activation specification.
	__14.  Expand the Troubleshooting section in the navigation panel and expand Runtime Messages.
	__15.  Click the link for Runtime Error messages.
	__16.  Check that your settings for runtime events are set to 'Warning' or 'Error'.  If it is not then any errors that were reported during startup would not be shown in the Admin console.  If it was set to 'None', change the setting to 'Warning' and press the Apply button.
	__17.  Click the Save link in the messages at the top of the Admin Console.
	__18.  Logout of the Admin Console.
	__19.  Restart your Application Server.

	Part 4 -  Install a Messaging Application
	__1.  Return to the web browser you were using for the Admin Console.  If you closed it, open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  Expand the Troubleshooting section in the navigation panel and expand Runtime Messages.
	__4.  Click the link for Runtime Error messages.
	__5.  Make sure that you do not see any messaging errors that occurred while starting the server.  If you do, contact your instructor so you can resolve these before continuing.
	__6.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__7.  Check the checkbox next to the OnlineStore application and press the Update button.
	__8.  Leave the option of Replace the entire application selected and Local File System radio button.
	__9.  Hit the Browse button next to the Full path text box.
	__10.  Navigate to the <LABFILES_DIR>/Messaging directory, select the OnlineStore‑Messaging.ear file, and press Open.
	__11.  With the path to the EAR file filled in press the Next button.
	__12.  Check the option for Detailed installation.  This will show all steps.
	__13.  Press the Next button.
	__14.  On Step 1: Select Installation options leave the default options and press the Next button.
	__15.  On Step 2: Map modules to servers check the checkbox next to the OnlineStoreWeb module.  Select both servers from the list above by holding down the CTRL key as you select each one.  Press the Apply button to apply the changes to the mapping of the web module.  Make sure the OnlineStoreWeb module is mapped to BOTH servers as shown below and press the Next button.
	__16.  On the list of steps on the left click the link for Step 6 to skip to this step.
	__17.  On Step 6: Provide listener bindings For message-driven beans use the following options for the PurchasePrinter EJB.  Check the values for these compare with the values you have written down in the Lab Notes section.
	__18.  Once you have checked this value press the Next button.
	__19.  Click the link for Step 10 on the list of steps on the left to skip to this step.
	__20.  On Step 10: Map resource references to resources check that the JNDI name of the Connection Factory listed matches what you had written down for these values in the Lab Notes section.  Also check that the JNDI name of the data source is still 'jdbc/store'.  Note that you will need to scroll around to find these values and the screenshots below only show the part of the screen with the settings.  Also note that the screenshot showing the Connection Factory below does not show the entire JNDI name value.  If you need to change these values for any reason you can use the Browse button to select the configured resource from a list which will eliminate chance for errors due to typos.
	__21.  Once you have checked these values press the Next button.
	__22.  On Step 11: Map resource environment entry references to resources check that the JNDI name of the queue matches what you had written down for these values in the Lab Notes section.
	__23.  Once you have checked these values press the Next button.
	__24.  At this point you will get a warning message.  Everything is fine.  Press the Continue button.
	__25.  On Step 12: Map virtual hosts for web modules select myhost from the drop down menu. This option may already be filled in but double check.
	__26.  On the list of steps on the left click the link for Step 15 to skip to the summary.
	__27.  On Step 15: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__28.  Click the Save link in the messages at the bottom of the Admin Console.
	__29.  In the list of Enterprise Applications, be sure the OnlineStore application is started. Navigate to Applications → Application Types → WebSphere enterprise applications if this list is not automatically displayed.

	Part 5 -  Test the Application
	__1.  Open a web browser and enter http://was.myhost.com/Store in the address bar.
	__2.  Login as a user that already exists on the system and has placed orders.
	__3.  Once you have logged in, click on the link on the left for Request Email.
	__4.  Once this page is displayed, click on the Request button.  This will generate a message from the Servlet that responds to the request.  You should get a fairly quick reply.  The normal response is shown below.
	__5.  Once you have verified that you can send a message properly, open a File Browser window.
	__6.  Navigate to the directory that contains the System.out log file you had written down the location of in the Lab Notes section.  This should be the <WAS_ROOT>/profiles/AppSrv01/logs/server1 directory.
	__7.  Open the SystemOut.log file with a text editor.  
	__8.  Search for the text “onMessage” which is printed out when the application receives a message.  Underneath this you should see a section that prints out the details of orders for that user.  
	__9.  Close the log file.
	__10.  Close the web browser you were using to test the application.
	__11.  Logout of the Admin Console and close the web browser.

	Part 6 -  Summary

	Lab 8 -  Configure WebSphere Security
	Part 1 -  Backup Configuration
	__1.  Open a terminal window.  
	__2.  Change directories using the 'cd' command to the <WAS_ROOT>/profiles/AppSrv01/bin directory.  Be sure to substitute the value of <WAS_ROOT> from the “Directory Paths” page at the beginning of the lab instructions.
	__3.  Enter the following command to backup the configuration to the file 'BeforeSecurity.zip':
	__4.  When prompted, enter a username and password of 'wasadmin'.
	__5.  Check that you get a message about the configuration being successfully backed up.
	__6.  Leave the terminal window open as you will use it in several sections in the lab.

	Part 2 -  Examine Current Security Settings
	__1.  From the terminal window for the profile 'bin' directory used in the previous section issue the following command to start the server:
	__2.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the Admin Console navigate to Security → Global Security.
	__5.  On the main security page click the button for “Security Configuration Wizard”.
	__6.  In the wizard that appears notice that there are steps for collecting basic security configuration options.  The actual steps are not shown on the left until you make selections on the first step.
	__7.  Click the Cancel button to cancel the wizard.
	__8.  Notice that the option to “Enable administrative security” has already been checked off.
	__9.  In the User account repository section notice that “Federated repositories” is already set as the current setting.  Click the Configure button to view the current settings.
	__10.  Notice that there is already a Primary administrative user name of 'wasadmin' set.  This is why we can currently login to the Admin Console with this ID and perform all administrative tasks.
	__11.  In the navigation section on the left side of the Admin Console navigate to Users and Groups -> Manage Users.
	__12.  Click the Search button if the 'wasadmin' user is not already listed.
	__13.  Click the link for the 'wasadmin' user ID.
	__14.  Notice this is where you could change the password for the current default administrator or set additional properties like name and email.  Click the Cancel button.

	Part 3 -  Configure Admin Console Users
	__1.  In the navigation section on the left side of the Admin Console navigate to Users and Groups -> Manage Users.
	__2.  Type * in the Search for field and click the Search button to list the current users.
	__3.  Click the Create button and fill in the following user information:
	__4.  When the options are filled in as above click the Create button to create the user.
	__5.  On the confirmation screen click the Create Like button to create another similar user with the following information:
	__6.  Click the Create button to create the second new user.
	__7.  On the confirmation screen click the Create Like button to create another similar user with the following information:
	__8.  Click the Create button to create the third new user.
	__9.  Click the Close button to return to the list of users.
	__10.  Check that your list of users appears as below.
	__11.  In the navigation section on the left side of the Admin Console navigate to Users and Groups → Administrative User Roles.
	__12.  Click the Add button to add a new administrative user role.
	__13.  Select the 'Operator' role from the list above.  You may have to scroll down to see it.
	__14.  Press the Search button to show all current users.
	__15.  Select the 'wasoperator' user from the list on the left and press the right arrow button to add it to the list on the right.
	__16.  Click the OK button to add the user once your settings match those below.
	__17.  Check that the user shows up in the list of users and is an “Operator”.  
	__18.  In the navigation section on the left side of the Admin Console navigate to Users and Groups -> Administrative Group Roles.
	__19.  Click the Add button to add a new administrative group role.
	__20.  Fill in the following properties:
	__21.  Press the OK button when the options are as shown above.
	__22.  Click the Save link in the messages at the top of the Admin Console.
	__23.  Click the link to Logout of the Admin Console.

	Part 4 -  Test Administrative Roles
	__1.  On the login page of the Admin Console login using the user and password of 'wasoperator'.
	__2.  In the navigation section on the left side of the Admin Console navigate to Applications → Application Types → WebSphere enterprise applications.
	__3.  In the list of applications notice that you can stop and start applications but you can't install or uninstall applications.  These abilities are restricted to Administrators, Configurators, and Deployers.
	__4.  Click the link to Logout of the Admin Console.
	__5.  On the login page of the Admin Console login using the user and password of 'wasmonitor'.
	__6.  In the navigation section on the left side of the Admin Console navigate to Applications → Application Types → WebSphere enterprise applications.
	__7.  In the list of applications notice that you do not even have the ability to start or stop applications.  This is because the “Monitor” role has the fewest privileges.
	__8.  Click a link for one of the applications and notice that you can browse the settings but will not be able to change anything.  The text boxes and checkboxes for the settings are often “grayed out” or there is no “Apply” or “OK” button to be able to submit any changes.
	__9.  Once you have experimented to familiarize yourself with the various options that are disabled for non-Administrator roles click the Logout link in the Admin Console.

	Part 5 -  Configure Fine-grained Security
	__1.  On the login page of the Admin Console login using the user and password of 'wasadmin'.
	__2.  In the Admin Console navigate to Security -> Administrative Authorization Groups.
	__3.  Press the New button.
	__4.  Fill in a name of 'StoreSecurity', expand the 'Applications' group to check the 'OnlineStore' application, and expand the 'Nodes → <nodename> → Servers' group to check 'server1' as shown below.
	__5.  Press the Apply button once your settings are as shown above.
	__6.  Under 'Additional Properties' click the link for 'Administrative user roles'.
	__7.  Click the Add button to add a new administrative user role.
	__8.  Select the 'Administrator' role from the list above.  
	__9.  Press the Search button to show all current users.
	__10.  Select the 'storeadmin' user from the list on the left and press the right arrow button to add it to the list on the right.
	__11.  Click the OK button to add the user once your settings match those below.
	__12.  Check that the user shows up in the list of users and is an “Administrator”.  
	__13.  Click the Save link in the messages at the top of the Admin Console.
	__14.  Click the link to Logout of the Admin Console.
	__15.  On the login page of the Admin Console login using the user and password of 'storeadmin'.
	__16.  In the navigation section on the left side of the Admin Console navigate to Applications → Application Types → WebSphere enterprise applications.
	__17.  Notice that the list of applications is different and indicates what level of administrative access this user has for the different applications.  Notice that OnlineStore is the only application with a checkbox allowing us to start, stop, uninstall, etc.
	__18.  In the navigation section on the left side of the Admin Console navigate to Resources → JDBC → Data sources.
	__19.  Note that you can display the settings of the 'Online Store DB' data source but you can't modify the settings.  You could modify the settings of the 'Default Datasource' because it is at server scope which is part of the 'Administrative Authorization Group' of resources this user has Administrator privileges for.  You could also create a new data source at server scope if we needed to. You may see a different number of data sources but you should have some to administrate and others to monitor.
	__20.  Once you have experimented to familiarize yourself with the various options that are available using the fine-grained security click the Logout link in the Admin Console.

	Part 6 -  Enable Application Security
	__1.  On the login page of the Admin Console login using the user and password of 'wasadmin'.
	__2.  In the Admin Console navigate to Security → Global Security.
	__3.  On the main security configuration page check the following options:
	__4.  Press the Apply button to submit the changes.
	__5.  Read some of the additional security related messages that appear once security is enabled.
	__6.  Click the Save link in the messages at the top of the Admin Console.
	__7.  Logout of the Admin Console.

	Part 7 -  Restart Application Server
	__1.  Return to the terminal window you used to start the server.  If you do not have one open, open a terminal window and change to the <WAS_ROOT>/profiles/AppSrv01/bin folder.
	__2.  Issue the command to stop the server and supply username and password options, './stopServer.sh server1 -username wasadmin -password wasadmin'.
	__3.  Issue the command to start the server, './startServer.sh server1'.

	Part 8 -  Summary

	Lab 9 -  Configure Java EE Security
	Part 1 -  Examine Current Behavior
	__1.  Be sure your Application Server is running.  Start it if it is not running.
	__2.  Open a Web Browser and enter http://was.myhost.com/Store in the address bar.  If you get any errors try restarting the web server.
	__3.  Click on the Find Purchases link on the left of the application homepage.
	__4.  In the form that appears fill in a Userid that you are sure has completed purchases and press the Find button.  If you have not completed any shopping cart purchases do that first.
	__5.  A screen is shown with a summary of all of the completed purchases for that user.  Click on the Details button for one of the purchases.
	__6.  Another screen shows the details of the purchase.
	__7.  Close the browser you were using to test the application.

	Part 2 -  Create Users for Secure Access
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the navigation section on the left side of the Admin Console navigate to Users and Groups -> Manage Users.
	__4.  Click the Search button to list the current users.
	__5.  Click the Create button and fill in the following user information:
	__6.  When the options are filled in as above click the Create button to create the user.
	__7.  On the confirmation screen click the Create Like button to create another similar user with the following information:
	__8.  Click the Create button to create the second new user.
	__9.  Click the Close button to return to the list of users.
	__10.  Check that your list of users appears as below.  The first and last names can be anything.
	__11.  In the navigation section on the left side of the Admin Console navigate to Users and Groups -> Manage Groups.
	__12.  Click the Create button and fill in the following group information:
	__13.  Click the Create button to create the group.
	__14.  Click the Close button to return to the list of groups.
	__15.  Click on the link for the new group name in the list of groups.
	__16.  Click the Members tab along the top of the group information.
	__17.  Click on the Add Users... button.
	__18.  Click on the Search button to list users.
	__19.  Hold the Ctrl button while you click the 'bob' and 'susan' users.
	__20.  Once both users are selected press the Add button.
	__21.  Click the Close button.
	__22.  Be sure that both users are listed as members of the group.

	Part 3 -  Install Secure Version of OnlineStore
	__1.  If you do not already have the Admin Console open, open a web browser and enter http://localhost:9060/ibm/console in the address bar.  Login as the 'wasadmin' user with a password of 'wasadmin'.
	__2.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__3.  Check the checkbox next to the OnlineStore application and press the Update button.
	__4.  Leave the option of Replace the entire application selected and Local File System radio button.
	__5.  Hit the Browse button next to the Full path text box.
	__6.  Navigate to the <LABFILES_DIR>/Security directory, select the OnlineStore‑Security.ear file, and press Open.
	__7.  Press the Next button when you have indicated the new EAR to use.
	__8.  Leave the default option of a “Fast Path” installation selected as shown below and press the Next button.
	__9.  On Step 1: Select Installation options leave the default options and press the Next button.
	__10.  On Step 2: Map modules to servers the appropriate mappings should already be filled in. Make sure the OnlineStoreWeb module is mapped to BOTH servers as shown below.  If it is not for some reason, check the checkbox next to the OnlineStoreWeb module.  Select both servers from the list above by holding down the CTRL key as you select each one.  Press the Apply button to apply the changes to the mapping of the web module.  
	__11.  Press the Next button once you have checked the module mapping.
	__12.  On Step 3: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__13.  Click the Save link in the messages at the bottom of the Admin Console.
	__14.  You should be returned to the list of applications.  If you are not navigate to Applications → Application Types → WebSphere enterprise applications.
	__15.  Click the link for the OnlineStore application.
	__16.  Under the Detail Properties section click the link for Security role to user/group mapping
	__17.  Check the checkbox next to the CSR role and click the Map Groups button.
	__18.  Press the Search button to list available groups.
	__19.  Select the OnlineCSRs group and press the right arrow button to move the group over to the “Selected” list on the right.
	__20.  Press the OK button on the group search page to accept the group.
	__21.  Check that the group is listed on the row with the CSR role and press the OK button.
	__22.  In the list of application properties click the link for User RunAs roles.
	__23.  Note that there are components in the application that are set to “run as” a specific security role.  In this application that is the message-driven EJB which must also access the functions that are being secured.
	__24.  Click the Save link in the messages at the top of the Admin Console.
	__25.  In the navigation section of the console expand the Servers → Server Types section and click the link for Web servers.
	__26.  Check the checkbox next to webserver1 and click the Generate Plug-in button.
	__27.  Check the checkbox next to webserver1 and click the Propagate Plug-in button.
	__28.  Check the checkbox next to webserver1 and click the Stop button.
	__29.  Check the checkbox next to webserver1 and click the Start button.
	__30.  Logout of the Admin Console.
	__31.  Close all web browsers you are using.  This includes the browser you are using for the Admin Console.

	Part 4 -  Test the Secure OnlineStore Application
	__1.  Open a Web Browser and enter http://was.myhost.com/Store in the address bar.
	__2.  Click on the Find Purchases link on the left of the application homepage.
	__3.  In the form that appears fill in a Userid that you are sure has completed purchases and press the Find button.
	__4.  You will be immediately prompted with a dialog that asks you for User name and password information.  Fill in 'hacker' as both of these values and press the OK button.
	__5.  You will be presented with the same screen again because this user is not in the user registry.  Fill in a User name and password of 'susan' or 'bob' and press the OK button.  You should be shown the list of purchases as before since this user was assigned to the security role for the application.
	__6.  Note the URL of the request that you were prompted for security information for.  This should be was.myhost.com/Store/FindPurchases.
	__7.  Click the Details button next to one of the purchases.
	__8.  Note the URL of this page as well.  This should be was.myhost.com/Store/PurchaseDetails.
	__9.  Close the web browser you were using to test the application.  Make sure all web browser windows are closed.
	__10.  Open a new Web Browser and enter http://was.myhost.com/Store in the address bar.
	__11.  Click on the Find Purchases link on the left of the application homepage.
	__12.  In the form that appears fill in a Userid that you are sure has purchases and press the Find button.
	__13.  When prompted for the User name and password fill in 'wasadmin' for both values and press the OK button.
	__14.  You will be presented with a page that indicates you are not authorized to view this page. This is because even though the 'wasadmin' user has the right to access the WebSphere Admin Console it was not granted access to the security role for the OnlineStore application.
	__15.  Close the web browser you were using to test the application.
	__16.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__17.  Login as the 'wasadmin' user.
	__18.  In the navigation section on the left side of the Admin Console navigate to Users and Groups -> Manage Users.
	__19.  Click the Search button to list the current users.
	__20.  Click the Create button and fill in the following user information:
	__21.  When the options are filled in as above click the Group Membership button.
	__22.  Click the Search button to search for groups.
	__23.  Select the OnlineCSRs group on the right and click the < Add button to move it to the left.
	__24.  Press the Close button to close the group membership dialog.
	__25.  Press the Create button to create the user.
	__26.  Logout of the Admin Console and close the web browser.
	__27.  Open a new Web Browser and enter http://was.myhost.com/Store in the address bar.
	__28.  Click on the Find Purchases link on the left of the application homepage.
	__29.  In the form that appears fill in a Userid that you are sure has purchases and press the Find button.
	__30.  When prompted for the User name and password fill in 'newCSR' for both values and press the OK button.
	__31.  You should see the page showing the list of orders placed by the user you filled in the form for.  This proves you can allow new users to access the secure functions simply by adding them to the group defined in the user registry.
	__32.  Close the web browser you were using to test the application.

	Part 5 -  Disable WebSphere Security
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the Admin Console navigate to Security → Global security.
	__4.  On the main security configuration page uncheck the following options:
	__5.  Press the Apply button to submit the changes.
	__6.  Click the Save link in the messages at the top of the Admin Console.
	__7.  Logout of the Admin Console and close the browser.
	__8.  Restart your Application Server using any method you are familiar with.
	__9.  Close any extra web browsers, File Browser windows, or terminal windows you may have open.

	Part 6 -  Examine Security Policies (Optional)
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__4.  Click the link for the OnlineStore application.
	__5.  On the right of the application properties, click the Manage Modules link.
	__6.  Click the link for the OnlineStoreWeb module.
	__7.  Click the View Deployment Descriptor link.
	__8.  Scroll down until you see the 'security-constraint' tag.
	__9.  Notice within this tag the two major entries of 'web-resource-collection' and 'auth‑constraint'.  The 'web-resource-collection' indicates that the two URLs we have seen are secure and the 'auth‑constraint' associates these URLs with the CSR security role.
	__10.  Notice that the CSR security role is also defined in a separate tag of the deployment descriptor after the end of the 'security-constraint' tag.
	__11.  In the “breadcrumbs” at the top of the page click the Manage Modules link to return to the list of modules.
	__12.  Click the link for the OnlineStoreEJB module.
	__13.  Click the View Deployment Descriptor link.
	__14.  Scroll down until you see the 'assembly-descriptor' tag.
	__15.  Note that inside this tag there is also a definition of the CSR security role.
	__16.  Also notice that there are two 'method-permission' tags.  These indicate that the two methods listed here are granted access only to the CSR role.
	__17.  Look a little further up at the definition of the “PurchasePrinterBean” message-driven EJB.  Notice that it is configured with the 'run-as' configuration and linked to the CSR security role.  Without this setting the message-driven EJB would fail when it attempted to access the secure EJB method to find all the purchases for the user which sent the message.
	__18.  Logout of the Admin Console and close the web browser.

	Part 7 -  Summary

	Lab 10 -  Monitor Performance
	Part 1 -  Create a Simple Stress Test
	__1.  Check that your Application Server is running and start it if it is not running.
	__2.  Open a web browser to http://was.myhost.com/Store and check that the various functions of the application are working properly.  Also make sure you know an existing user for the system as you will use this user when recording the stress test.
	__3.  Close the web browser you used to check the application.  Make sure you do not have any other open browsers (including any used with the Admin Console or web email access) as this may interfere with recording the test.
	__4.  Open a terminal window.  
	__5.  Use the 'cd' command to switch to the <JMETER_ROOT>/bin directory.  Substitute the value of the <JMETER_ROOT> variable from the directory paths listed at the beginning of the labs.
	__6.  Issue the following command to start JMeter.  Wait for a minute for it to start completely.
	__7.  Leave the terminal window open for the rest of the lab so JMeter continues to run.
	__8.  In the left column, right click on "Test Plan" and select 'Add -> Thread Group'. A thread group allows us to enter the number of threads that will actively send HTTP requests.
	__9.  Right click on the new Thread Group and select 'Add -> Config Element -> HTTP Request Defaults'. 
	__10.  Set the Server Name or IP field to was.myhost.com
	__11.  Right click on Thread Group and select 'Add -> Config Element -> HTTP Cookie Manager'.  This will collect cookies that are sent back with the responses.
	__12.  Select the HTTP Cookie Manager on the left and change the Cookie policy to default on the right.  This will make sure the session cookie for our login is saved.
	__13.  In the left column, right click on “Workbench” and select 'Add -> Non-test Elements -> HTTP Proxy Server'.
	__14.  With the new 'HTTP Proxy Server' element on the left selected click on the Start button at the bottom of the screen on the right.  You may need to scroll down to see the button.
	__15.  If presented with a security dialog unblock the Java process.
	__16.  Check that the elements on the left appear as shown below.  If they do not, double check the previous steps.
	__17.  Select 'File -> Save Test Plan as' from the menus.
	__18.  Navigate to the <LABFILES_DIR> directory and save with a filename of 'OnlineStoreTest.jmx'.
	__19.  Open a Firefox web browser window.
	__20.  Select 'Edit -> Preferences' from the menus.
	__21.  Select the “Advanced” group along the top and the "Network" tab below.
	__22.  Click the button for “Settings”.
	__23.  Select the option for “Manual proxy configuration”, change the proxy to use 'localhost', port '8080', and check the box to “Use this proxy server for all protocols”.
	__24.  Check that the settings appear as above and press the 'OK' button.
	__25.  Click the 'Close' button to close the browser preferences.
	__26.  Enter 'http://was.myhost.com/Store' in the address bar of the browser.
	__27.  Perform the following functions in the application:
	__28.  Return to the JMeter window.
	__29.  With the 'HTTP Proxy Server' element on the left selected click on the Stop button at the bottom of the screen on the right.  You may need to scroll down to see the button.
	__30.  On the left side check that all entries under the Thread Group start with '/Store'.  If any do not look like they should be present simply right click and select 'Remove'.  If you have a request for '/favicon.ico' remove it from the list.
	__31.  Select 'File -> Save' from the menus to save your test plan.

	Part 2 -  Validate Test Script
	__1.  On the left side select the Thread Group by clicking on it.
	__2.  Check the settings on the right side to be sure the test will run only one “thread” and the test will loop only once.  This will verify the script.
	__3.  On the left side, right click on Thread Group and select 'Add -> Listener -> View Results Tree'.
	__4.  On the left side, right click on Thread Group and select 'Add -> Listener -> Summary Report'.
	__5.  From the menus select 'Run -> Start'.
	__6.  On the left side, select the 'View Results Tree' if it is not already.
	__7.  Check that all responses have a green check icon.
	__8.  Select one of the responses on the left of the results list.
	__9.  On the right, click the tab for “Response data”.
	__10.  Along the bottom of the right side select the option for “Render HTML”.
	__11.  Select each entry from the list and verify the response appears about as you would expect. The page will appear different because the embedded images are not displayed but the major elements of the pages should be present.
	__12.  On the left side select the 'Summary Report'.
	__13.  Check the various statistics.  In particular check that the 'Error %' is zero for all requests.
	__14.  From the menus select 'Run -> Clear All'.
	__15.  Leave JMeter running.

	Part 3 -  Fix Firefox Proxy
	__1.  Open a Firefox web browser.
	__2.  Select 'Edit -> Preferences' from the menus.
	__3.  Select the “Advanced” group along the top and the "Network" tab below.
	__4.  Click the button for “Settings”.
	__5.  Select the option for “No proxy".
	__6.  Once the settings are restored click any OK or Close buttons to close out open dialogs.
	__7.  Access the Online Store application to check that the settings are restored.

	Part 4 -  Check Performance Monitoring Service
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  Expand the Monitoring and Tuning section and click the link for Performance Monitoring Infrastructure (PMI).
	__4.  Click the link for server1 on the right to show the PMI settings for the server.
	__5.  On the settings notice the PMI service is already enabled.  It is also set to collect “Basic” information.  You can click the '+' sign under the Basic setting to see exactly what counters that will include.
	__6.  At the top notice there are Runtime and Configuration tabs.  The settings in the Configuration tab will be saved and used as the defaults when the server starts up.  The Runtime tab can be used to temporarily change the performance data being collected to run a specific performance test or examine the performance of specific components in more detail.
	__7.  Logout of the Admin Console.
	__8.  Close all open web browsers.

	Part 5 -  Measure Performance Data
	__1.  Restart the Application Server using the method you are most familiar with.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the left hand pane, expand Monitoring and Tuning -> Performance Viewer.
	__5.  Click on the link for Current Activity.
	__6.  Check the checkbox next to server1 and press the Start Monitoring button.
	__7.  Check that server1 shows that it is being monitored.
	__8.  Click the link for server1 in the list.
	__9.  Expand the server1 -> Settings section and click User to change user options.
	__10.  On the right side, change the Refresh Rate setting to 5 seconds and press the Apply button.
	__11.  Back on the left side expand the server1 -> Performance Modules section.
	__12.  Check the checkbox next to the following modules to enable data from that module:
	__13.  Back under the list of performance modules, expand 'Web Applications → OnlineStore#...' and check the Servlets box.  This will enable collecting data only for the OnlineStore web application.
	__14.  Click the View Modules button at the top of the list on the left to view the data.
	__15.  On the right side you should see a graph displaying various data points.  If you do not see the graph but were not prompted to download the viewer your proxy settings may not be restored to the previous settings.
	__16.  Take some time to adjust the layout of the performance viewer with the tips above.
	__17.  Under the graph of data press the Clear Buffer button and then the Reset To Zero button.
	__18.  Launch JMeter if it is not already running.  Switch to the window if it is running already.
	__19.  On the left side select the Thread Group by clicking on it.
	__20.  Change the settings on the right side so the test will loop 50 times.
	__21.  From the menus select 'Run -> Start'.
	__22.  While the test is running switch back to the Admin Console and the performance viewer. You should see the values of the counters changing.
	__23.  Find out which line in the graph represents the “Service Time” metric.  If you want to see what a particular line represents you will need to associate the colors and icons from the table below with the lines in the graph.  You could also disable certain counters if you are not interested in them.
	__24.  You can also look at the table on the bottom to see exactly what the current value is of any counter.
	__25.  Wait for the test to complete before going to the next section.  There is a rectangle in the upper right of the JMeter tool that will be green if the test is still running.

	Part 6 -  View Summary Reports
	__1.  In the Admin Console, expand the server1 -> Summary Reports section on the left of the viewer and click Servlets to view the servlet summary report.
	__2.  Make sure you can see all of the scrollbars along the bottom of the viewer.  Scroll down in the outer Admin Console page if you can't.
	__3.  Scroll back and forth to examine the data in the summary report.  Especially look at Total Requests and  Avg Resp Time.
	__4.  Click on the arrows in the Total Requests column to sort the column.
	__5.  Make sure that you see at the top of the list the resources with the most requests.  You may need to click the sort arrows again to sort in descending order.

	Part 7 -  Use Logging
	__1.  In the Tivoli Performance Viewer of the Admin Console expand the server1 -> Settings section on the left and click Log to setup logging.
	__2.  Change the File Name to be '/root/LabFiles/Stress' and press the Apply button.  The actual file name will be similar to Stress_server1_xxxx.zip.
	__3.  Back on the left side expand the server1 -> Performance Modules section.
	__4.  Check the checkbox next to the following modules to enable data from that module if these modules are not already selected:
	__5.  On the left side of the Performance Viewer, click on the View Modules button.
	__6.  Under the graph of data click the Undo Reset to Zero button.
	__7.  Press the Clear Buffer button and then the Reset To Zero button.
	__8.  Click the Start Logging button along the top of the viewer.
	__9.  Return to the JMeter window.
	__10.  From the menus select 'Run -> Start'.  The performance viewer will behave exactly the same as before except it will log the metrics in the background.
	__11.  Once the stress test is completed, stop the logging by clicking on the Stop Logging button in the performance viewer window of the Admin Console.
	__12.  In the left hand pane of the Admin Console, expand Monitoring and Tuning -> Performance Viewer.
	__13.  Click on the link for Current Activity.
	__14.  Check the checkbox next to server1 and press the Stop Monitoring button.
	__15.  To replay the logged data, select Monitoring and Tuning -> Performance Viewer -> View Logs in the Admin Console navigation.
	__16.  Click on the Browse button next to the Explicit Path to Log File option. 
	__17.  Navigate to the '/root/LabFiles' directory and look for a file that starts with 'Stress_server1_xxx'.    Select this file and press the Open button to select the file.
	__18.  After specifying the path to the file, click on the View Log button.  The file starts to play automatically.
	__19.  Expand Performance Modules on the left hand side and select the modules from before:
	__20.  Click the View Modules button to display the data.
	__21.  You can use the VCR-like controls above the viewer to control the playback.  Depending on how long the file is you may need to press the rewind button to restart playing the file.
	__22.  Logout of the Admin Console and close the web browser.
	__23.  In the JMeter window select 'File -> Save' and then 'File -> Exit'.
	__24.  Close any extra web browsers, File Browser windows, or terminal windows you may have open.

	Part 8 -  Summary

	Lab 11 -  Configuring and Analyzing Memory
	Part 1 -  Enable Verbose Garbage Collection
	__1.  Check that your Application Server is running and start it if it is not running.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  Expand the Servers → Server Types section and click the link for WebSphere application servers.
	__5.  Click the link for server1 on the right.
	__6.  In the 'Server Infrastructure' section expand 'Java and Process Management' and click the link for 'Process Definition'.
	__7.  Under the 'Additional Properties' click the link for 'Java Virtual Machine'.
	__8.  Check the box for 'Verbose garbage collection'.  Also make sure the two “heap size” setting boxes are empty and press the OK button.
	__9.  Click the Save link in the messages at the top of the Admin Console.
	__10.  Logout of the Admin Console and close the browser.
	__11.  Restart your Application Server using any method you are familiar with.  Wait until it is completely restarted to continue.

	Part 2 -  Establish a Baseline
	__1.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the left hand pane, expand Monitoring and Tuning -> Performance Viewer.
	__4.  Click on the link for Current Activity.
	__5.  Check the checkbox next to server1 and press the Start Monitoring button.
	__6.  Check that server1 shows that it is being monitored.
	__7.  Click the link for server1 in the list.
	__8.  On the left side expand the server1 -> Performance Modules section.
	__9.  Check the checkbox next to the following module to enable data from that module:
	__10.  Click the View Modules button at the top of the list on the left to view the data.
	__11.  Under the graph on the right, uncheck the metric of UpTime and check the ProcessCpuUsage.  You may need to scroll in the performance viewer as you change settings and the graph resets.
	__12.  Make sure you IBM HTTP Server is running and issue the 'apachectl start' command if needed.
	__13.  Open a terminal window and start the JMeter tool as you did in the last lab.  You can refer to the instructions on page 143 if you need to know how to do this.
	__14.  Once the JMeter tool is running, select File → Open to open the test script you used in the last lab.  This is most likely <LABFILES_DIR>/OnlineStoreTest.jmx.  If you had trouble with your test script you can also open up a solution script at <LABFILES_DIR>/Performance/SolutionOnlineStoreTest.jmx.
	__15.  On the left side select the Thread Group by clicking on it.
	__16.  Make sure the settings on the right side are set so the test will loop 50 times.
	__17.  Switch back to the Admin Conosle.
	__18.  Under the graph of data press the Clear Buffer button.
	__19.  Switch back to JMeter.
	__20.  From the menus select 'Run -> Start'.
	__21.  Wait for the test to complete before going to the next step.  There is a rectangle in the upper right of the JMeter tool that will be green if the test is still running.
	__22.  Switch back to the Admin Console.
	__23.  Examine the graph of JVM data.  Although it may be slightly different than that shown below you will likely notice several trends:
	__24.  In the left hand pane of the Admin Console, expand Monitoring and Tuning -> Performance Viewer.
	__25.  Click on the link for Current Activity.
	__26.  Check the checkbox next to server1 and press the Stop Monitoring button.
	__27.  Leave the Admin Console open.
	__28.  Leave the JMeter tool running.

	Part 3 -  Set Heap Settings
	__1.  Return to the Admin Console open from the previous section.  If you had closed it open it and login as the 'wasadmin' user.
	__2.  Expand the Servers → Server Types section and click the link for WebSphere application servers.
	__3.  Click the link for server1 on the right.
	__4.  In the 'Server Infrastructure' section expand 'Java and Process Management' and click the link for 'Process Definition'.
	__5.  Under the 'Additional Properties' click the link for 'Java Virtual Machine'.
	__6.  Find out how much memory your virtual machine has.  This can be done by opening a terminal window and running the 'free' command.  Look for the entry for total memory.  In the example below there is about 1.3 GB of memory.
	__7.  Back in the Admin Console, fill in the following heap size settings and press the OK button.
	__8.  Click the Save link in the messages at the top of the Admin Console.
	__9.  Logout of the Admin Console.
	__10.  Restart your Application Server using any method you are familiar with.  Wait until it is completely restarted to continue.

	Part 4 -  Repeat Test with New Heap Settings
	__1.  Return to the JMeter tool and your open test script.  Use the directions from earlier in the lab to start JMeter and open the test script if you closed it. 
	__2.  Make sure the Thread Group is set to loop 50 times.
	__3.  From the JMeter menus select 'Run -> Start'.
	__4.  Wait for the test to complete before going to the next section.  There is a rectangle in the upper right of the JMeter tool that will be green if the test is still running.
	__5.  Once the JMeter test is complete select 'File -> Exit'.  Save the test if prompted.
	__6.  Leave your WebSphere server running for the next section.

	Part 5 -  Generate a Heap Dump
	__1.  Open a terminal window.  
	__2.  In the terminal window, switch to your <WAS_ROOT>/profiles/AppSrv01/bin directory.  Use the value of <WAS_ROOT> that you wrote down in the Directory Paths section.
	__3.  Issue the following wsadmin command to start the wsadmin scripting environment in interactive mode:
	__4.  When prompted, enter 'wasadmin' for the username and password.
	__5.  Make sure that you do not get any authentication errors when connecting.  If you do issue the quit command and start the session again.
	__6.  Issue the following two commands.  The first sets a variable to refer to the JVM of the server and the second prints out the variable to be sure it is set properly:
	__7.  Enter the following command to generate the heap dump:
	__8.  Issue the following command to stop the scripting session:
	__9.  Stop the server using any method you are familiar with.

	Part 6 -  Analyze Memory Data with IBM Support Assistant Tools
	__1.  Start the IBM Support Assistant by selecting 'Applications → Programming → IBM Support Assistant Workbench 4.1'.
	__2.  You may be prompted to run a customization wizard or to check for updates.  If you are prompted during this lab or other times using the ISA simply select 'No' or 'Cancel'.  
	__3.  From the top left of the ISA tool, press the Launch Activity button to provide a menu and select Analyze Problem from the list.
	__4.  Select the Tools tab of the 'Analyze Problem' activity page.
	__5.  From the list select the 'IBM Monitoring and Diagnostic Tools for Java – Garbage Collection and Memory Visualizer' tool and press the Launch button at the bottom of the page.  Wait for a second for the tool to start.  The version of the tool may be different and there may be other differences with the other tools that that shown below.
	__6.  Immediately you are presented with a dialog to load the log file.  By default the verbose garbage collection data is saved to the 'native_stderr.log' file on Windows, Linux, and AIX.  Press the Browse button to open a dialog to find the file.
	__7.  In the “System File Browser” that appears click the tab for “Remote Artifact Browse”.  
	__8.  On the window that appears expand the 'My Computer → Local Agent → Unix Root' groups.
	__9.  Expand the entry for the disk your WebSphere installation is on and find the location of the log files of your profile.  Normally it is <WAS_ROOT>/profiles/AppSrv01/logs/server1/.
	__10.  Select the native_stderr.log file from the window.  Once you have the log you wish to analyze selected as shown below press the OK button.
	__11.  Back in the “Tool Input Parameter Values” dialog check that the log file is listed and press the Next button.
	__12.  The tool will take several seconds to parse the information and open.
	__13.  Once the tool opens you should see a line graph that indicates the history of the memory.  Although your graph may appear slightly different you should be able to notice a few similar trends:
	__14.  Click the 'Report' tab along the bottom and scroll to the Summary section of the report.  Of all of the statistics available, one of the most important is “Proportion of time spent in garbage collection pauses”.  This should be a fairly low percentage.
	__15.  Click the 'X' in the bar of the IBM Monitoring and Diagnostic Tools... to close the tool data but keep the rest of the IBM Support Assistant open.
	__16.  Back in the tools list of the 'Analyze Problem' activity page of the IBM Support Assistant, select the 'Memory Dump Diagnostic for Java' tool and press the Launch button at the bottom of the page.  Wait for a second for the tool to start.
	__17.  Immediately you are presented with a dialog to load the heap dump file.  By default the heap dump file is saved to the root of the profile directory.  Press the Browse button to open a dialog to find the file.
	__18.  In the “System File Browser” that appears click the tab for “Remote Artifact Browse”.  
	__19.  On the window that appears expand the 'My Computer → Local Agent → Unix Root' groups.
	__20.  Expand the entry for the disk your WebSphere installation is on and find the location of your profile directory.
	__21.  Select the heapdump.xxxx...phd file from the window.  Once you have the file you wish to analyze selected as shown below press the OK button.
	__22.  Back in the “Tool Input Parameter Values” dialog check that the heap dump file is listed and press the Next button.
	__23.  Once the tool opens, click the 'Suspects View' tab.  The tool is set to look for “leak suspects” to suggest object types in the application that may be sources of memory leaks.  Since our application does not have any memory leaks the tool is not as useful in analysis of our particular heap dump.
	__24.  Click on the 'Type View' tab at the top of the tool.
	__25.  Scroll to the bottom of the page (there may be two sets of scroll bars) and press the Filter button.
	__26.  Select the option to 'Display only objects containing custom filter', enter a value in the textbox of 'com/myhost', and press the OK button.
	__27.  Use the 'Previous page' and 'next page' buttons to go through the data.  Notice that most of the objects listed will likely have few instances which is another good indication that the application likely does not have memory leaks.
	__28.  Click on the 'Tree View' tab at the top of the tool.
	__29.  Right now this view is not populated because there are no data structure leak suspects for this heap dump.  If there were this view would be used to see how the various objects are related and try to find the root of the memory leak problem.  Using this type of information usually requires a more intimate knowledge of the application so developers would likely be involved in analysis of memory leak problems.
	__30.  Close the IBM Support Assistant.

	Part 7 -  Summary

	Lab 12 -  Use wsadmin Scripting
	Part 1 -  Start an Interactive wsadmin Session
	__1.  If it is not already running, use the method of starting the Application Server you are most familiar with.
	__2.  Be sure you have logged out of any Admin Console windows that may be open and closed the web browsers you were using.
	__3.  Open a File Browser window and navigate to the <WAS_ROOT>/profiles/AppSrv01/properties directory.
	__4.  Open the wsadmin.properties file with a text editor.
	__5.  Find the section in the file for the 'defaultLang' property and change the value to 'jython' as shown below.
	__6.  Save and close the file.
	__7.  Open a terminal window.  
	__8.  In the terminal window, switch to your <WAS_ROOT>/profiles/AppSrv01/bin directory.  Use the value of <WAS_ROOT> that you wrote down in the Directory Paths section.
	__9.  Issue the following wsadmin command to start the wsadmin environment in interactive mode:
	__10.  When prompted, enter a username and password of 'wasadmin'.
	__11.  Make sure that you do not get any authentication errors when connecting.  If you do issue the quit command and start the session again.

	Part 2 -  List Installed Applications
	__1.  Since a list of applications is required the AdminApp object will probably be involved. Issue the command: 
	__2.  In the output of the help text you should see a list function.  This looks like the function you need and now just need to check the syntax of how to use it.  Issue the command:
	__3.  From the output of the help on the list function you should see that the command does not require any arguments.  This makes the command easy to call.  Issue the command:
	__4.  You should see all the installed applications listed.  Leave the wsadmin window open for the next section.

	Part 3 -  Stop and Start an Application
	__1.  You should already have a wsadmin window open from the last section.  If you do not, start one using the instructions from the beginning of this lab.
	__2.  To get the help text for the AdminApp object issue the command:
	__3.  If you look through the functions available you should notice there are none for stopping and starting an application.  Since you are trying to control whether or not an application is running it is likely you will go through the AdminControl object since this provides access to other MBeans in the runtime environment.
	__4.  Declare a variable to store a reference to the ApplicationManager MBean.
	__5.  Now you need to find out how to use this object to control applications.
	__6.  In the help output notice there is an operations function available from the Help object that can list all the operations of an MBean.  Now you need to know how to use this function.
	__7.  Notice there are two versions of this function.  One can list all operations available in an MBean the other can give you help on a specific operation.
	__8.  Notice that there are startApplication and stopApplication operations available from the ApplicationManager MBean.  These are the operations you will need to use.  Issue the command to get help on the stopApplication operation.
	__9.  Notice the only parameter required for the stopApplication operation is a String of the application name.
	__10.  Issue the command:
	__11.  There are a few different ways to invoke operations on other MBeans depending on if they have arguments.  Issue the following command and note there will be no output:
	__12.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__13.  Login as the 'wasadmin' user.
	__14.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__15.  Notice the HitCount application is stopped.
	__16.  Back in the wsadmin scripting session issue the command:
	__17.  In the Admin Console, click the link for Applications → Application Types → WebSphere enterprise applications again to refresh the page.
	__18.  Notice the HitCount application is started.  
	__19.  Logout of the Admin Console and close the web browser.  Leave the wsadmin window open for the next section.

	Part 4 -  View Data Source Properties
	__1.  You should already have a wsadmin window open from the last section.  If you do not, start one using the instructions from the beginning of this lab.
	__2.  The properties of an existing DataSource object would be stored in the WebSphere configuration. To work with the WebSphere configuration you will be using the AdminConfig object.  Issue the command:
	__3.  Notice that the AdminConfig object has a list operation just like the AdminApp object does.  Issue the command:
	__4.  Notice that both versions of the list function take an argument for the ‘type’.  Although we are fairly certain of the type of object you are looking for here it would still be good to check to be sure.  It is good to do this just to check things like spelling and capitalization which are important in wsadmin.  Look back at the general help for the AdminConfig object.  Notice there is also a types function.  Issue the command:
	__5.  Notice there are a lot of types available in the configuration structure.  Scroll up this list and look for some you recognize like WebContainer, VirtualHost, Server, MessageListenerService, JMSDestination, JDBCProvider, EJBContainer, and finally DataSource.
	__6.  Now you know you can use the list operation of the AdminConfig object to list all configuration elements of a DataSource type.  Issue the command:
	__7.  You should see that there are several DataSource objects listed.  You are trying to list information about the "Online Store DB" DataSource.  To get the properties of one of them you need a reference to the appropriate configuration ID.  This is so you can identify exactly which configuration object to work with as this id will be unique.  The AdminConfig operation used to get the configuration ID is getid.  Issue the command:
	__8.  Notice the only thing needed to get a configuration ID is a "containment path".
	__9.  The AdminConfig object has a parents operation which lists what configuration objects are valid parents of a configuration type.  Issue the command:
	__10.  Notice the only valid parent of a DataSource is a JDBCProvider.  Issue the command below to find the valid parents of a JDBCProvider:
	__11.  Notice there are four valid parents of a JDBCProvider.  This is determined by what scope the JDBCProvider is configured at.  The "Deployment" scope is used if the application is deployed as an "Enhanced EAR" that has additional deployment information in the EAR file itself.  In the single server mode of WebSphere Application Server the other three scopes are not very different.  They will become very important as we discuss the clustering support of WebSphere.  Now you need to figure out what JDBCProvider contains the DataSource you are looking for and at what scope it is defined.  Issue the following command:
	__12.  In the output notice there is a "DB2 Universal …" JDBCProvider listed.  This is the JDBCProvider which is the parent of the "Online Store DB" DataSource.  Notice in the rest of the information printed the JDBCProvider is configured in a "resources.xml" file and the scope is "cells/<hostname>Node01Cell".  This JDBCProvider is at the cell scope.
	__13.  Now you finally have enough information to locate the DataSource you need.  You will store the reference to the DataSource using a variable so it will be easier to work with in future commands.  Note that since the resource is at cell scope we do not need node or server name.  Note that this command must be entered on one line.  The containment path is also enclosed by a pair of double quotes because the containment path contains spaces.  Issue the command below noting that the containment path is so long it has wrapped onto several lines.  Enter this command on one line.  Make sure that there is not a blank value stored in the variable.  If you get an error with this command double-check the command again, especially the name of the JDBCProvider and the name of the DataSource.
	__14.  Make sure you do not see any errors in the output of the last command before continuing.
	__15.  Notice in the output of this command (or 2 commands with Jython) that there is only one configuration id listed.  Although it is the same value as what you got by listing all of the DataSources you are now referring to only one of them.
	__16.  You can now show the attributes of the DataSource.  There are several operations that can be used to show attributes.
	__17.  Notice the operation attributes which can be used to show what attributes are available for a given type.  This operation also lists the type of value for each attribute.
	__18.  Notice the output refers to basic attributes that have "String" values and complex attributes like "connectionPool" or "mapping" which have values of other configuration types.  You can find the attributes of these other types also.
	__19.  The AdminConfig object also has show, showall, and showAttribute operations which display information about a specific configuration object.  These can be used depending on how much information you require.  The showall operation displays the most information as it recursively displays information for any child configuration objects.  The showAttribute displays only the value of a single attribute. 
	__20.  Notice you can see attribute values of the DataSource the ds variable refers to like the jndiName of "jdbc/store" and the name of "Online Store DB".
	__21.  Leave your wsadmin window open as you will be working with the DataSource in the next section and can reuse the variable that refers to it.

	Part 5 -  Modify Data Source Properties
	__1.  You should already have a wsadmin window open from the last section.  If you do not, start one using the instructions from the beginning of this lab.
	__2.   If you had to open a new wsadmin session, execute the commands from step 13 of the previous section.  This will setup a ds variable to refer to the DataSource you will modify.
	__3.  Now that you have a reference to the DataSource you can view the current value of the name property you will be modifying.
	__4.  Since you have a reference to the DataSource and know the property you wish to change you can tell the AdminConfig object to change the property value.  This is done with the modify operation of the AdminConfig object.
	__5.  Notice this operation takes two parameters, config id and attributes.  The config id is already stored in the ds variable.  The attributes parameter is a list of attributes that you wish to modify.  This means that you must supply a list of name/value pairs.  This is done slightly differently for each of the two scripting languages.  With Jython you use double quotes around the name and value of the property (whether or not they contain spaces); plus, you need a comma between them.  With Jacl you only need double quotes around the property value if it contains spaces.  
	__6.  Now that you have changed the value of the property you can check that the new property is being used.
	__7.  Even though the new property value is listed by the above command it is not yet saved to the configuration.  It is just a temporary change in your wsadmin session.
	__8.  This lists the resources.xml file that stores the DataSource configuration as containing unsaved changes.  Issue the command:
	__9.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__10.  Login as the 'wasadmin' user.
	__11.  In the Admin Console, navigate to Resources -> JDBC -> Data sources.
	__12.  Be sure the scope listed at the top of the page is set to your cell.  If it is not, use the drop-down list to switch to this scope.
	__13.  Notice the name of the Data Source listed has changed from "Online Store DB" to "Online Store Database".
	__14.  Logout of the Admin Console and close the web browser.  Leave the wsadmin window open for the next section.

	Part 6 -  Retrieve Server Properties
	__1.  You should already have a wsadmin window open from the last section.  If you do not, start one using the instructions from the beginning of this lab.
	__2.  You can also get additional information about the server process itself.  This requires referring to the MBean which represents the server process.  Issue the command:
	__3.  You can now use this reference and the operations available from the Help object to determine what else you can use the server variable to find.
	__4.  Among the other operations available notice the operations for retrieving the name and Pid of the server.  Neither of these operations requires parameters.  Again, as before, you must use the AdminControl object to invoke operations of MBeans.
	__5.  Note the Process ID returned by the operation here: 	 .  
	__6.  Open a separate terminal window.
	__7.  Issue the following command to list all the Java processes on your machine.  One of these is the WebSphere server.
	__8.  Notice the process which matches the Process ID is a ‘java’ process.  You may notice another ‘java.exe’ process.  This is the interactive wsadmin environment.  This represents the power of JMX, having one Java process connect and manage another.
	__9.  Close the terminal window listing the processes.
	__10.  In the terminal window running the wsadmin session issue the quit command to finish the wsadmin session.
	__11.  Stop the Application Server using the method you are most familiar with.
	__12.  Close any extra web browsers, File Browser windows, or terminal windows you may have open.

	Part 7 -  Summary

	Lab 13 -  Additional Jython Scripting
	Part 1 -  Experiment with Scripting Commands
	__1.  If it is not already running, use the method of starting the Application Server you are most familiar with.
	__2.  Be sure you have logged out of any Admin Console windows that may be open and closed the web browsers you were using.
	__3.  Open a terminal window.  
	__4.  In the terminal window, switch to your <WAS_ROOT>/profiles/AppSrv01/bin directory.  Use the value of <WAS_ROOT> that you wrote down in the Directory Paths section.
	__5.  Issue the following wsadmin command to start the wsadmin environment in interactive mode:
	__6.  When prompted, enter a username and password of 'wasadmin'.
	__7.  Make sure that you do not get any authentication errors when connecting.  If you do issue the quit command and start the session again.
	__8.  The first place to start is to get general help for what is available in the scripting library.  Issue the following command to print this help.
	__9.  Notice that there are many different script libraries which all start with 'Admin' and indicate in the name the general purpose of the library.  If you scroll up in the list notice there is a 'AdminApplication' which is the library for installing and configuring applications.
	__10.  Each of the script libraries has a 'help' method which can print out help information for that library.  Issue the following command to print this help for the AdminApplication library.
	__11.  Notice that there are lots of methods in this library.  They are split into groups depending on what they do.  There are also many similar methods that take a different number of type of parameters but accomplish similar things.
	__12.  Look in the first group of methods for the various ways to install applications. Thinking back to how we installed other applications remember that we mapped an application to an application server and a web server so the 'installAppWithTargetOption' might be the method we are looking for.
	__13.  Issue the following command to get help on this particular method.  Make sure to spell the name of the method carefully including capitalization.  
	__14.  In the output of the command notice that the parameters would include the name of the application as it would be identified by WebSphere, the EAR file of the application, the node name and the names of two servers to target the application to.
	__15.  Another important aspect of installing our application was mapping it to the new virtual host we had created.  This linked the application to a specific hostname and port combination.  Notice that nothing of the scripting command we just examined mentions the virtual host.
	__16.  There is also another installation method where you can set "default bindings".  Issue the following command to get help on this method.  
	__17.  Notice in the output of this method that we can provide a virtual host binding but there is no way to target more than one server.
	__18.  Issue the following command to find out about a method that will help check if the application is already installed.
	__19.  Notice this method takes an application name and will return true or false if an application is already installed with the same name.
	__20.  Issue the following command to find out about a method that will start the application on all deployed targets.  
	__21.  Notice this method takes an application name and the name of the node of the targets to start the application on.
	__22.  Since we will obviously need to make a choice for which setting to set during installation and which setting to modify post-installation it will be good to find out how to modify each setting.  We will use some of the functions of the AdminApp object to do this.
	__23.  Issue the following command to print out some of the available options for the EAR file we will install.
	__24.  Although there are several options notice at the start of the list the options 'MapModulesToServers' and 'MapWebModToVH'.  These are the primary options that interest us as this simple application will not actually need any of the others.
	__25.  Issue the following command to print out the information for how to supply the information for the map modules task.  Note that the command is all one line even though shown on two below.
	__26.  Notice that the syntax of how to supply the server to map to is a little more complex than the script library method which will only need the short name of the server.
	__27.  Issue the following command to print out the information for how to supply the information for the map virtual host task.  Note that the command is all one line even though shown on two below.
	__28.  Notice that this one may be a bit easier to supply information for as all that is needed is the name of the virtual host.
	__29.  Now it appears that the best way to install the application when mapping to both the application server and the web server and a custom virtual host will be to use the scripting library method that allows mapping to both servers and then modifying the virtual host configuration after installation.  There are just a few more things we would need to figure out how to do and for this we will use the command assistance feature of the Admin Console.
	__30.  In the terminal window running the wsadmin session issue the quit command to finish the wsadmin session.
	__31.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__32.  Login as the 'wasadmin' user.
	__33.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__34.  In the list of applications, click the link for the 'DefaultApplication'.
	__35.  Under the list of 'Web Module Properties' click the link for 'Virtual hosts'.
	__36.  Change the virtual host drop-down to 'myhost' and press the OK button.
	__37.  Do not save the changes but instead click the link in the 'Help' area on the right for "Command Assistance".  This will show you the scripting equivalent of changing the virtual host for an application.
	__38.  If a popup window appears click the button or link that allows you to ignore the certificate error if needed and continue to the web site.
	__39.  In the command that is shown notice that it calls the 'edit' function of the 'AdminApp' object.  Notice that there are two parameters (in single quotes) for this function even though the second one is very long.  The parameters are the name of the application and the list of application options to modify.  In this case we see the '‑MapWebModToVH' option that was seen in the scripting session.  We will build a similar command in the script file although it will be simpler because it will use wildcards for some of the values.
	__40.  Close the popup window that is showing the command syntax.
	__41.  Click the Review link at the top of the Admin Console to review the configuration changes that were made.
	__42.  Click the Discard button to discard the configuration changes.  We do not actually want to change the configuration but were simply submitting the changes to see what the equivalent scripting command would be.
	__43.  Confirm that you want to discard the changes by clicking the Yes button.
	__44.  In the navigation section of the console expand the Servers → Server Types section and click the link for Web servers.
	__45.  Check the checkbox next to webserver1 and click the Generate Plug-in button.
	__46.  Click the link in the 'Help' area on the right for "Command Assistance".  This will show you the scripting equivalent of generating the plugin configuration.  Again ignore the certificate error if shown.
	__47.  The first command shown does a 'ping' test but the second command is more interesting.  It invokes a 'generate' function on a "PluginCfgGenerator" MBean to generate the plug-in configuration.  If you were to search the InfoCenter for information on the "PluginCfgGenerator" MBean you would find that the parameters for this function include the configuration root of the profile, the name of the cell, node, and web server to generate, and a boolean for whether or not to also propagate the plug-in configuration.  We will use a version of this function as well in our script file.
	__48.  Close the extra window displaying the command assistance.
	__49.  Logout of the Admin Console and close the web browser.

	Part 2 -  Install Application with Scripting
	__1.  Open a File Browser window and navigate to the <LABFILES_DIR>/Scripting directory.
	__2.  Open the file installHelloWorld.py with a text editor.  In this file there are a few commands with the text COMPLETE that you will need to edit.
	__3.  Examine the first part of the file which prints some usage information for the user. This is important as it is very common for a script to be written by different people than the ones that use it.
	__4.  The section labeled 'SECTION 1' checks how many parameters were passed in when calling the script file.  The 'sys.argv' variable is an array with the command parameters and you can check the length.  This is important because if you try to use an index that is too high you will get a scripting exception.  If the number of parameters is incorrect the script prints out a friendly error and then exits the script which will be much more user friendly.  There is nothing for you to complete in this section.
	__5.  Once the number of parameters has been checked and stored in some more descriptive variable names the script prints out what will happen using the values passed in by the user.
	__6.  In SECTION 2 some code is added to make sure the script is only run for an application that is not already installed.  Modify the code that currently reads 'AdminApplication.COMPLETE' and replace the COMPLETE text with the name of the correct method from the script library that will check if the application is already installed.  Also remember that this method takes the name of the application as a parameter so use the correct variable that was initialized at the beginning of the script.
	__7.  In SECTION 3 there is code to call the method from the scripting library we decided to use to install the application 'installAppWithTargetOption'.  Replace the COMPLETE text with the five parameters this method requires separated by commas.  All of the parameters are variables already initialized.  Be careful to get the parameters in the correct order for the method although the order of the last two parameters doesn't matter because these will be the two servers.
	__8.  In SECTION 4 the code is building a list of options to supply to the AdminApp.edit command.  Replace the COMPLETE text with the name of the option you saw with the AdminApp.options command that will map the application to a virtual host.  Remember to leave the single quotes and the dash as these are needed for the list of options.  Notice that associated with this option is another list which has three values separated by commas.  The first two '.*' values use pattern matching so that every application web module will be mapped to the virtual host indicated by the third value which is the variable storing the name of the virtual host.
	__9.  In SECTION 5 there is just the usual save configuration once the application has been installed and edited for the virtual host.  There is nothing for you to complete in this section.
	__10.  In SECTION 6 the application will be started.  Replace the COMPLETE text with the name of the method that will start the application on all deployed targets.  The parameters have already been supplied for you.
	__11.  SECTION 7 is probably the most complex section.  In this section the code uses scripting commands to regenerate the plug-in configuration file for the web server since a new application was just mapped to it.  There are settings that would allow WebSphere to do this automatically but this code will make sure that all of the latest settings are applied.
	__12.  Examine the first part of the section and notice that the lines of code initialize and modify a 'configRoot' variable which will hold the directory path to the root of the profile configuration.  This is done by dynamically getting the value of the 'USER_INSTALL_ROOT' variable which has the profile root directory and adding '/config' to the end.  There is also code to switch all slashes to '/' since the '\' backslash character can cause some problems in Java Strings.  An extra set of escaped double quotes is also added to the value to protect any space in the directory path from making the script think there are two values being supplied.
	__13.  The last part of SECTION 7 gets a reference to the 'PluginCfgGenerator' MBean and builds the list of options that will be required including the configuration root, cell, node, and web server name, and a final value of 'true' to also propagate the plug-in configuration.  Replace the COMPLETE text with the three parameters required for the AdminControl.invoke command.  Remember this is the MBean to invoke a method on, the name of the method to invoke, and a list of options to provide.
	__14.  Save your file once you have made sure to replace all occurrences of the COMPLETE text with the appropriate code.  You may also want to check your script file against the solution version also provided to help avoid errors when running it.
	__15.  Close the file.
	__16.  Open a terminal window.  
	__17.  In the terminal window, switch to your <WAS_ROOT>/profiles/AppSrv01/bin directory.  Use the value of <WAS_ROOT> that you wrote down in the Directory Paths section.
	__18.  Issue the following command to execute the script file with the six parameters that are required.  Double check that you have spaces between the parameters, the order is correct, and use the correct value for your <nodename> from the Lab Notes section in the command below.  Note this is all one command even though it is on multiple lines below.
	__19.  When prompted, enter a username and password of 'wasadmin'.
	__20.  Wait for several seconds as the script executes.  The last messages you should receive are that the application was started successfully and the plug-in configuration was generated and propagated.
	__21.  If you get any errors you will likely need to login to the Admin Console and uninstall the application before trying to run the script file again.  If you do get errors, check the values that you pass in a parameters to the script in addition to the syntax of the code you typed.  You may want to use the "up arrow" in the terminal window and change the call to wsadmin to use the solution script file with the same parameters to check whether it was the parameter values or the script code that was causing errors.
	__22.  Once the script file installs the application successfully open the admin console and login as wasadmin.  If you were already logged in you may want to logout and back in to verify you do not have any cached settings.
	__23.  In the navigation area of the Console expand the Applications → Application Types group and click the link for WebSphere enterprise applications.
	__24.  You should see that the HelloWorld application is running.
	__25.  Click the link for the HelloWorld application.
	__26.  In the list of Web Module Properties on the right click the link for "Virtual hosts".
	__27.  Note that the web module is mapped to the 'myhost' virtual host.
	__28.  In the "breadcrumbs" at the top of the main console area, click the link for the HelloWorld application.
	__29.  Under the Modules section click the link for Manage Modules.
	__30.  Notice that the web module is mapped to both the application server and the web server.
	__31.  Logout of the Admin Console and close the browser.

	Part 3 -  Test the HelloWorld Application
	__1.  Open a web browser and enter the URL http://was.myhost.com/HelloWeb/ into the address bar of the web browser and hit Return.  You should see the following page.
	__2.  Click the first link to display the standard message of "Hello There!".
	__3.  Press the Back button on the browser to return to the entry page of the application.
	__4.  Fill in the text box with a custom message and press the Display Special Message button.
	__5.  Your special message will be displayed.
	__6.  Close the web browser you used to test the new application.

	Part 4 -  Modify Configuration with Properties Files
	__1.  Be sure you have logged out of any Admin Console windows that may be open and closed the web browsers you were using.
	__2.  Open a terminal window.  
	__3.  In the terminal window, switch to your <WAS_ROOT>/profiles/AppSrv01/bin directory.  Use the value of <WAS_ROOT> that you wrote down in the Directory Paths section.
	__4.  Issue the following wsadmin command to start the wsadmin environment in interactive mode:
	__5.  When prompted, enter a username and password of 'wasadmin'.
	__6.  Make sure that you do not get any authentication errors when connecting.  If you do issue the quit command and start the session again.
	__7.  Issue the following commands to create a Jython list and add some of the options you will need to extract a properties file.
	__8.  Issue the following command to use the list of options to extract a properties file.
	__9.  Make sure you do not get any errors but instead get an empty String printed out.  Leave the scripting session open.
	__10.  Open the /root/LabFiles/Scripting/server.properties file with a text editor.
	__11.  Notice that there are a LOT of properties in this file.  Although this file might be good for the configuration of an entire server it will be best to work with subsets of properties if possible.
	__12.  Close the file without making any changes.
	__13.  Back in the wsadmin scripting session issue the following commands.  This will change the name of the properties file for the second extraction we will perform.
	__14.  Issue the following commands to add to the list some additional options to filter the properties.
	__15.  We are not quite done with our revised options.  The subtypes that you want to filter must be supplied as a list of types embedded within the list of options.  Issue the following commands to create a new list, append the subtypes to it, and append the subtypes list to the options list.
	__16.  Issue the following command to use the list of options to extract a second properties file.
	__17.  Make sure you do not get any errors but instead get an empty String printed out.  Leave the scripting session open.
	__18.  Open the /root/LabFiles/Scripting/serverSubset.properties file with a text editor like WordPad.
	__19.  Notice that even though there are still several properties in the file there is a more manageable number.
	__20.  In the Java Virtual Machine properties which should be near the top change the value for the 'initialHeapSize' property to 50.  Make sure you supply a valid integer and also double check that this is less than the value for the maximum heap size.
	__21.  Search the file for the text 'WebContainer' without the quotes.  This text should only appear once for the properties for the web container thread pool.
	__22.  Change the value for the 'minimumSize' of the thread pool to 10 in the properties of the WebContainer.  Again make sure that it is a valid integer and less than the value of the maximumSize property.
	__23.  Save and close the file.
	__24.  Go back to the scripting session window.
	__25.  Issue the following commands to create a Jython list and add some of the options you will need to validate the properties file.
	__26.  Issue the following command to use the list of options to validate the properties in the file against the environment.
	__27.  You should see a return value of true indicating the values were validated properly. If you get an exception reported examine the printout of the options to check the values that are in the list of options.
	__28.  Open the /root/LabFiles/Scripting/ValidateReport.txt file with a text editor.  
	__29.  Examine the messages in the report which will show you only what values have changed.  There are no specific messages that the properties are OK but there are no errors mentioned so these properties are good.
	__30.  Close the report file.
	__31.  Go back to the scripting session window.
	__32.  Issue the following commands to create a new list of options for applying the properties.  Notice that the new list starts with the first three values in the list of validation options.  This will allow a new file name for the report.  Notice that we are not filtering the report so it will show all of the messages.
	__33.  Issue the following command to use the list of options to apply the properties in the file against the environment.
	__34.  Issue the following command to save the configuration changes.
	__35.  Open the /root/LabFiles/Scripting/ApplyReport.txt file with a text editor.  Notice you have all of the messages including the values that were not changed.
	__36.  Close the file.
	__37.  In the terminal window running the wsadmin session issue the quit command to finish the wsadmin session.

	Part 5 -  Summary

	Lab 14 -  Web Services
	Part 1 -  Update OnlineStore with Web Service
	__1.  Be sure your Application Server is running.  Start it if it is not running.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__5.  Check the checkbox next to the OnlineStore application and press the Update button.
	__6.  Leave the option of Replace the entire application selected and Local File System radio button.
	__7.  Hit the Browse button next to the Full path text box.
	__8.  Navigate to the <LABFILES_DIR>/WebServices directory, select the OnlineStore‑WebService.ear file, and press Open.
	__9.  With the path to the EAR file filled in press the Next button. 
	__10.  Leave the default option of a “Fast Path” installation selected as shown below and press the Next button.
	__11.  On Step 1: Select Installation options leave the default options and press the Next button.
	__12.  On Step 2: Map modules to servers check both the checkboxes next to the OnlineStoreWeb and OnlineStore-HTTPRouter modules.  Select both servers from the list above by holding down the CTRL key as you select each one.  Press the Apply button to apply the changes to the mapping of the web modules.  Make sure BOTH the modules are mapped to BOTH servers as shown below and press the Next button.
	__13.  On Step 3: Map virtual hosts for web modules select myhost from the drop down menu next to both web modules and press the Next button.  This choice will make the application only available by using the was.myhost.com host name on port 80.  This means the web service will also be available only on this address.
	__14.  On Step 4: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__15.  Click the Save link in the messages at the bottom of the Admin Console.

	Part 2 -  Update Web Service HTTP Endpoint
	__1.  If you are not currently viewing the list of enterprise applications, navigate to Applications → Application Types → WebSphere enterprise applications.
	__2.  Click the link for the OnlineStore application.
	__3.  Scroll down and in the list of 'Web Services Properties' on the right click the link for Provide HTTP endpoint URL information.
	__4.  Note that because we mapped the “router” module to a virtual host which has only one alias and that alias is not the default hostname and port of the WebSphere server we do not have any “default” HTTP prefixes available.
	__5.  Fill in 'http://was.myhost.com' without the quotes for the HTTP URL prefix value next to the module listed and press the OK button.  Note that you can just type the value in directly and you do not need to use the options and Apply button above the settings.
	__6.  Click the Save link in the messages at the top of the Admin Console.
	__7.  Back in the list of applications click the link for the OnlineStore application.
	__8.  Scroll down and in the list of 'Web Services Properties' on the right click the link for Publish WSDL files.
	__9.  On the page that appears click the link for the zip file of WSDL files.
	__10.  If prompted to open or save the file, open it with zip file software if possible.  If you can't open it directly save it first and then open the zip file.
	__11.  Expand the folders of the zip file if needed until you see the 'StoreFacadeService.wsdl' file.
	__12.  Open the 'StoreFacadeService.wsdl' file with a text editor like gedit.  If you need to, extract the file first and then open it.
	__13.  Scroll down in the WSDL file and notice at the end that the SOAP address uses a location that starts with 'http://was.myhost.com'.  If we did not set the endpoint URL information for the service the WSDL package to publish would not be useable.
	__14.  Close the WSDL and the zip file.
	__15.  Back in the Admin Console return to the list of enterprise applications by navigating to Applications → Application Types → WebSphere enterprise applications.
	__16.  Check the checkbox next to the OnlineStore application and press the Stop button.  
	__17.  Check the checkbox next to the OnlineStore application and press the Start button. Wait for a message that the application started successfully.
	__18.  Open a Web Browser and enter http://was.myhost.com/Store in the address bar. You should see the homepage of the application.
	__19.  Login as a registered user.
	__20.  Close the web browser.

	Part 3 -  Install Web Service Client
	__1.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__2.  Click the Install button to start the installation process.
	__3.  Next to the Local file system box, press the Browse button.
	__4.  Navigate to the <LABFILES_DIR>/WebService directory, select the OnlineStoreServiceClient.ear file, and press Open.
	__5.  Press the Next button when you have indicated the new EAR to use.
	__6.  Leave the default option of a “Fast Path” installation selected as shown below and press the Next button.
	__7.  On Step 1: Select Installation options leave the default options and press the Next button.
	__8.  On Step 2: Map modules to servers check the checkbox next to the OnlineStoreServiceClientWeb module.  Select both servers from the list above by holding down the CTRL key as you select each one.  Press the Apply button to apply the changes to the mapping of the web module.  Make sure the module is mapped to BOTH servers as shown below and press the Next button.
	__9.  On Step 3: Map virtual hosts for web modules select myhost from the drop down menu next to the web module and press the Next button.  This choice will make the application only available by using the was.myhost.com host name on port 80.  
	__10.  On Step 4: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__11.  Click the Save link in the messages at the bottom of the Admin Console.
	__12.  Check the checkbox next to the OnlineStoreServiceClient application and press the Start button.  Wait for a message that the application started successfully.
	__13.  Open a Web Browser and enter http://was.myhost.com/ServiceClient in the address bar. You should see the homepage of the application.
	__14.  Click the link to 'View Partner Products'.  After several seconds you will get an error that will be explained and fixed in the next section.
	__15.  Close the browser you were using to test the web service client application.

	Part 4 -  Fix Web Service Client
	__1.  Back in the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__2.  Click the link for the OnlineStoreServiceClient application.
	__3.  Scroll down and in the list of 'Web Services Properties' on the right click the link for Service clients.
	__4.  Click the link for the Module on the right.  If you click the service name on the left it will take you to web service policies which are not being used for this web service.
	__5.  In the list of module 'Web Services Properties' on the right click the link for Web services client bindings.
	__6.  In the list you will see two entries for “services” that have the same name.  This is because the code generated by the development tool contains a reference to the service as well as the Servlet used to display the page you saw before.  We will update settings for both.
	__7.  Click the first 'Edit' link in the 'Port Information' column.  Make sure you do not click the link in the 'mappings' column.
	__8.  As you can see from the address listed this is why the client did not work.  It was using the default location that was part of the WSDL generated by the development environment which is not the URL the web service is available on now.
	__9.  Change the hostname of the URL so the entire URL is 'http://was.myhost.com/StoreRouter/StoreFacadeService' without the quotes.  Once your value is set as shown below press the OK button.  Note the screenshot below does not show the end of the URL but the hostname portion is the only thing you need to update.
	__10.  Click the second 'Edit' link in the 'Port Information' column.  Make sure you do not click the link in the 'mappings' column.
	__11.  Notice that the URL of the service reference has already been modified with the new hostname.  This is because both of the service references use the same name of 'StoreFacadeService'.  If the references used different names you would need to change both.
	__12.  Click the Save link in the messages at the top of the Admin Console.
	__13.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__14.  Check the checkbox next to the OnlineStoreServiceClient application and press the Stop button.  
	__15.  Check the checkbox next to the OnlineStoreServiceClient application and press the Start button. Wait for a message that the application started successfully.
	__16.  Open a Web Browser and enter http://was.myhost.com/ServiceClient in the address bar. 
	__17.  Click the link to 'View Partner Products'.  After several seconds you will get the normal response which is a table with the list of products.
	__18.  Close the browser you were using to test the web service client application.
	__19.  Open a File Browser window and navigate to the <IHS_ROOT>/logs directory.
	__20.  Open the 'was.myhost.com-access_log' file with a text editor.  
	__21.  Scroll to the bottom of the file and notice that in addition to calls to the '/ServiceClient/...' application which is the web application of the web service client, there is a call to '/StoreRouter/StoreFacadeService'.  This is the web service implementation and this proves that the web service request from the web service client is being routed through the web server.
	__22.  Close the log file.
	__23.  Logout of the Admin Console and close any extra web browsers or terminal windows.

	Part 5 -  Summary

	Lab 15 -  Create Deployment Manager Profile
	Part 1 -  Create Deployment Manager Profile
	__1.  Open a terminal window. 
	__2.  Use the 'cd' command to change to the <WAS_ROOT>/bin/ProfileManagement directory. Be sure to substitute the value of <WAS_ROOT> from the “Directory Paths” page at the beginning of the lab instructions.
	__3.  Issue the following command to start the Profile Management Tool.
	__4.  Press the Launch Profile Management Tool button in the Welcome screen. 
	__5.  Press the Create button next to the list of profiles.
	__6.  In the Environment Selection dialog, select the option for Management and press the Next button.
	__7.  Leave the default option of Deployment manager selected and press the Next button.  If you get a security prompt unblock the process.
	__8.  Select the option for Advanced profile creation and press the Next button.
	__9.  Leave the default option to deploy the administrative console and press the Next button.
	__10.  Leave the default profile name and directory and press the Next button.
	__11.  Leave the default Node, Host and Cell names.  Write down the values for the Node  name, Host name, and the Cell  name of the Deployment Manager profile in the “Lab 15” section of the Lab Notes section.  Press the Next button.
	__12.  Leave the box for Enable administrative security checked.  Fill in a user and password of wasadmin.  Press the Next button when your screen matches that shown below.
	__13.  In the first page of security certificate options, leave the default to create a new default personal certificate.  Press the Next button.
	__14.  On the second page of security certificate options again leave the defaults and press the Next button.
	__15.  In the Port values assignment page, note the Administrative console port and SOAP connector port.  Write these values down in the Lab Notes section at the beginning of the lab guide in the “Lab 15” section.  Leave the default port numbers as is and press Next. WebSphere ND automatically assigns port numbers that do not clash with the existing port numbers with the existing profile.  It's a good idea to go through the port numbers. 
	__16.  Leave the options on the Linux service screen and press the Next button.  
	__17.  Press Create in the Summary page to begin profile creation. 
	__18.  When the profile creation is complete, leave the option for launching the First Steps console and press the Finish button.
	__19.  When the First Steps console appears, click on the Installation verification link to verify ND installation. 
	__20.  Make sure that you get a message that the verification succeeded.  You may get a few messages that are warnings but there should be no errors.
	__21.  Close the verification window.
	__22.  Leave the Deployment Manager running for the next lab.
	__23.  Close the First Steps console.
	__24.  Select File → Exit on the Profile Management Tool.

	Part 2 -  Summary

	Lab 16 -  Configure Cell Architecture
	Part 1 -  Federate the Node
	__1.  Verify the Deployment Manager is started.  If you did not restart the machine after doing the verification in the Deployment manager profile creation lab it should still be running.  To start the Deployment Manager open a terminal window, switch to the <WAS_ROOT>/profiles/Dmgr01/bin directory, and execute the startManager command. Remember to substitute the value of <WAS_ROOT> from the Directory Paths section of the lab guide.
	__2.  Open a web browser and enter http://localhost:9061/ibm/console in the address bar. Note that the port is slightly different because the Deployment Manager profile used different ports to avoid conflicting with the previous profile.
	__3.  Add an exception for the security certificate so you can continue to the Admin Console.
	__4.  Login as the 'wasadmin' user.
	__5.  In the navigation panel of the Admin Console expand the System Administration section and click the link for Deployment manager.
	__6.  On the right side, under Additional Properties, click the '+' sign to expand the list of Ports and be sure you do not click on the link itself.
	__7.  Look for the value of the SOAP_CONNECTOR_ADDRESS and write it down in the lab 15 section of the Lab Notes as the 'DM_SOAP_PORT' variable.  You may already have this value written down so check that it is the same as shown in the Admin Console.  This port will be used by the nodes to communicate with the Deployment Manager when adding the node.
	__8.  Logout of the Admin Console.  This is very important or you will not see the new node in the Admin Console after it is added.
	__9.  Open a second terminal window.
	__10.  In the terminal window switch to the <WAS_ROOT>/profiles/AppSrv01/bin directory and issue the following command.  Remember that only one node can be added at a time.  Substitute the appropriate values from what you wrote down in the Lab Notes section.
	__11.  Check that the addNode command completed successfully.  Notify your instructor if there are problems.

	Part 2 -  Verify the Cell Configuration
	__1.  Open a web browser and enter http://localhost:9061/ibm/console in the address bar, the URL of the Deployment Manager Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  In the navigation pane select System Administration -> Nodes.
	__4.  Verify that the node you expect to see in the cell is indeed in the cell.  You will see an extra “Node” for the Deployment Manager server which will have a node name that includes “Manager” in the name.
	__5.  In the navigation pane select Servers → Server Types → WebSphere application servers.
	__6.  Verify that you see an entry for the server on the node.  Note the Node listed for each server.  Right now this will just list the 'server1' server but later there will be other servers in this list.

	Part 3 -  Configure VirtualHost
	__1.  In the Admin Console, navigate to Environment -> Virtual Hosts.
	__2.  In the list of virtual hosts notice the 'myhost' virtual host is not present.  The reasoning was discussed in the introduction to this section.
	__3.  Press the New button above the list of virtual hosts.
	__4.  Fill in a Name of myhost.  Press the Apply button to apply the new name and make the additional properties on the right available.
	__5.  Click the link for Host Aliases in the Additional Properties section.
	__6.  Press the New button above the empty list of host aliases.
	__7.  Fill in a Host Name of  'was.myhost.com'.  Leave the default Port value of 80 and press the OK button.
	__8.  Check that the new alias shows up in the list.
	__9.  In the messages at the top of the Console press the link for Preferences.
	__10.  On the Preferences page check the box for Synchronize changes with Nodes and press the Apply button.
	__11.  Click the Save link in the messages at the top of the Console and confirm the node is synchronized.

	Part 4 -  Check Node Resources and Variables
	__1.  In the Admin Console, navigate to Environment -> WebSphere Variables.
	__2.  In the section at the top for the Scope use the drop down box to select All scopes.
	__3.  Scroll down the list of variables and check that the value on the node of the DB2UNIVERSAL_JDBC_DRIVER_PATH variable is filled in with a value that is correct.  Only the “manager” node should not have a value.  Make sure you look at the correct variable name because there are lots of DB2 variables.  This should already be correct since we would not have been able to run the OnlineStore application on that node without a proper value.
	__4.  In the Admin Console navigate to Resources -> JDBC -> Data sources.
	__5.  In the section at the top for the Scope use the drop down box to select All scopes.
	__6.  Note that the data source you configured for the OnlineStore is not listed because it was at cell scope of the previous configuration.  This resource was lost when the node was added to the Deployment manager cell.  You may have one or two data sources but not the data source used by the OnlineStore.
	__7.  Logout of the Admin Console.

	Part 5 -  Summary

	Lab 17 -  Configure Cluster and Remote Web Server
	Part 1 -  Create a Cluster
	__1.  Make sure that the Deployment Manager and the Node Agent are running.  Open a terminal window and run the following commands to check the status.
	__2.  Open a web browser and enter http://localhost:9061/ibm/console in the address bar, the URL of the Deployment Manager Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the navigation pane select Servers → Clusters → WebSphere application server clusters.
	__5.  Press the New button.
	__6.  For Cluster name, enter LabCluster.  Check the checkbox for Configure HTTP session memory-to-memory replication.  
	__7.  Check that your values match that shown above, especially the “replication domain” option which will be important later, and press the Next button.
	__8.  Enter the name of the new cluster member. For Member Name, enter Clustered1.  Cluster member names must be unique for the node they are being added to. 
	__9.  Since you only have one node in this cell that can run application servers you do not need to make a choice for node.  Normally this is how you would choose which machine the cluster member will run on.
	__10.  For Select basis for first cluster member, select the Create the member using an existing application server as a template radio button. This will use your existing 'server1' as the template.
	__11.  Press the Next button to go to the next step.
	__12.  Check that the first cluster member shows up in the list.
	__13.  Enter the name of the next cluster member. For Member Name, enter Clustered2.
	__14.  Review the settings for the new cluster member and press the Add Member button to add the cluster member to the list.
	__15.  Check that the list of cluster members has two servers both configured for your node.  Running both cluster members on the same node is what makes this architecture vertical scaling.  If you need to make changes you can check the checkbox next to the cluster member and use the Edit or  Delete buttons.
	__16.  Once you have correctly configured the list of cluster members press the Next button to move to Step 4.
	__17.  At the summary page, press the Finish button to create the cluster.
	__18.  Back on the list of clusters you should now see the new cluster in the list.
	__19.  Click the Save link in the messages at the top of the Admin Console.
	__20.  Check that your changes are synchronized with the node and press the OK button.  If your changes are not automatically synchronized you should go to System administration -> Console Preferences to enable this option.
	__21.  In the navigation panel of the Admin Console select Servers → Clusters → Cluster Topology.
	__22.  Expand the entries in the hierarchy with the '+' signs like you would directories in a File Browser window.  Be sure not to click any of the links directly as this would take you to the properties of the element.

	Part 2 -  Prepare for Web Server Configuration
	__1.  Open a terminal window.
	__2.  Change directories using the 'cd' command to the <IHS_ROOT>/bin directory.  Be sure to substitute the value of <IHS_ROOT> from the “Directory Paths” page at the beginning of the lab instructions.
	__3.  Execute the following command to stop the web server.
	__4.  Execute the following command to stop the HTTP administration service.
	__5.  Open a File Browser window and navigate to the <IHS_ROOT>/Plugins/config folder. Use the value of <IHS_ROOT> that you had written in the Directory Paths section in the lab guide.
	__6.  Create a new folder in this directory called OnlineStoreWebServer.  You can create a new folder by selecting File -> Create Folder from the menus when viewing the correct directory.  Be sure to match the name of the folder exactly as it will be important in the next section.
	__7.  Right click on the new OnlineStoreWebServer directory in the <PLUGIN_ROOT>/config folder and select “Properties” from the popup.
	__8.  Select the “Permissions” tab along the top of the property dialog.
	__9.  Change the "Folder Access" property for “Group” and “Others” to the 'Create and delete files'.  This will let any user write to the directory.
	__10.  Click the “Close” button to close the folder properties.
	__11.  In the same File Browser window navigate to the <IHS_ROOT>/Plugins/logs directory again substituting the value of <IHS_ROOT> from the Directory Paths section.
	__12.  Create a new folder in the logs directory called OnlineStoreWebServer.  Again double check the name of the new folder.
	__13.  In the File Browser window navigate to the <IHS_ROOT>/conf directory substituting the value of the <IHS_ROOT> variable from the Directory Paths section in the lab guide.
	__14.  Open the httpd.conf file with a text editor.
	__15.  Scroll to the very bottom of the file and find the line that indicates the location of the WebSpherePluginConfig.  Right now this should point into the webserver1 configuration.
	__16.  Change the file name of the plugin configuration to the following value remembering to substitute the value of the <IHS_ROOT> variable from the Directory Paths section.
	__17.  Check that your configuration is similar to that shown below.  Note that the screenshot below wraps the file name onto a second line to display the entire value.  Make sure this is entered without any line breaks.
	__18.  Once the WebSpherePluginConfig file name is set save the web server configuration file.  Be sure the text editor doesn't add a '.txt' extension when saving the file.
	__19.  Close the text editor and File Browser windows you have been using.
	__20.  Open a terminal window and switch to the <IHS_ROOT>/bin directory.
	__21.  Issue the command below to start the web server administrative processes.  Do not start the actual web server yet as it will not start until the next section is complete.
	__22.  If you do not have the console open already then open a web browser and enter http://localhost:9061/ibm/console in the address bar, the URL of the Deployment Manager Admin Console and login as the 'wasadmin' user.
	__23.  Navigate to Servers → Server Types → Web Servers.
	__24.  Check the checkbox next to the web server listed and press the Delete button.
	__25.  Press the OK button to confirm deletion of the web servers.
	__26.  Click the Save link in the messages at the top of the Admin Console.
	__27.  Check that your changes are synchronized with the nodes and press the OK button.

	Part 3 -  Configure Remote Web Server
	__1.  In the navigation pane of the Admin Console select System Administration -> Nodes. 
	__2.  Click on the Add Node button above the list of nodes. 
	__3.  Select the Unmanaged node radio button and press the Next button.
	__4.  Under General Properties, enter the Name as IHSNode. Enter the Host Name of the machine. This should be the value for the <hostname> variable that you have written down in the Lab Notes section of the lab guide.  Leave the default for the Platform Type of Linux.
	__5.  Check that your options match that above and press the OK button.
	__6.  Click the Save link in the messages at the top of the Admin Console and be sure your changes are synchronized with the nodes.
	__7.  In the navigation pane of the Admin Console select Servers → Server Types → Web servers. 
	__8.  Press the New button above the empty list of web servers.
	__9.  On Step 1: Select a node, choose the IHSNode from the drop down list.  Enter the Server name as OnlineStoreWebServer.  Once your values match that shown below press the Next button. 
	__10.  In Step 2: Select a Web server template, select the IHS radio button as the web server template and press the Next button.
	__11.  In Step 3: Enter the properties for the new Web server, enter the following information.  Substitute the value of the Port and <IHS_ROOT> variables with the values you had written down in the Directory Paths section in the lab guide.
	__12.  Check that your values for the new web server match that shown for the last step. Press the Next button when everything matches.
	__13.  In Step 4: Confirm new Web Server, press the Finish button to create the web server.
	__14.  Click the Save link in the messages at the top of the Admin Console and be sure your changes are synchronized with the nodes.
	__15.  In the navigation pane of the Admin Console select Servers → Server Types → Web servers.
	__16.  Check the checkbox next to OnlineStoreWebServer and click the Generate Plug-in button.
	__17.  Check the checkbox next to OnlineStoreWebServer and click the Propagate Plug-in button.
	__18.  Make sure that you get a successful message about propagating the plugin config file.  If you do not it is likely that the settings for the web server administration service including port, user ID, and password are not correct.  Contact your instructor to help resolve this.
	__19.  Check the checkbox next to OnlineStoreWebServer and click the Start button.
	__20.  Make sure that the OnlineStoreWebServer is shown as started.  If it is not contact your instructor.
	__21.  Logout of the Admin Console.

	Part 4 -  Summary

	Lab 18 -  Install Clustered Application
	Part 1 -  Create Cluster Data Source
	__1.  Make sure that the Deployment Manager and the Node Agent are running.  Open a terminal window and run one of the following commands to check the status.
	__2.  If you do not already have one open, open a web browser and enter http://localhost:9061/ibm/console in the address bar, the URL of the Deployment Manager Admin Console, and login as the 'wasadmin' user.  If you did already have one open your session may have expired and you may need to login again.
	__3.  In the admin console, navigate to Resources -> JDBC -> JDBC Providers.
	__4.  Use the drop down for the Scope setting at the top of the list to select Cluster=LabCluster.  Once the scope of Cluster=LabCluster is shown press the New button.
	__5.  On the first screen of the New JDBC Provider setup select the following options.  The contents of the last two drop down lists will change once you start selecting the first two options.  Press  the Next button once you have filled in the options as shown below.
	__6.  On the next page you should see some additional properties related to the Class path.  Look at the setting for Class path and notice it is defined with some environment variables.  Even though the value for the variables appears empty you do not need a value here.  In the previous lab you checked that you already had a value for this variable on the node that will run cluster members.  This means that WebSphere will have a value for this variable set and be able to run the data source.  
	__7.  Press the Next button.
	__8.  Press the Finish button to create the JDBC Provider.  You should see the new JDBC Provider in the list.
	__9.  Click the Save link in the messages at the top of the admin console and make sure your nodes synchronize. Click OK.
	__10.  Click the link for the new JDBC Provider you configured.
	__11.  On the right, under the Additional Properties section, click the link for Data Sources.  Be sure not to select the 'Data Sources (WebSphere Application Server V4)' link.
	__12.  Press the New button above the list of Data Sources.
	__13.  On the first page of the Data Source configuration fill in or change the following values.
	__14.  Press the Next button once your values are filled in as below.
	__15.  On the second configuration page fill in the following values:
	__16.  Press the Next button once your values are filled in as above.
	__17.  On the security aliases step select the following choices and press the Next button.  
	__18.  Press the Finish button to create the Data Source.  You should see the new Data source in the list.
	__19.  Click the Save link in the messages at the top of the admin console and make sure your nodes synchronize.
	__20.  In the navigation pane select Servers → Clusters → WebSphere application server clusters.
	__21.  Check the checkbox next to the LabCluster and press the Start button.
	__22.  Wait until the cluster is completely started and shows a filled in green arrow.  If you need to update the status of the cluster click the “Refresh” icon above the Status column.  It will likely take a few minutes to start the cluster. You can place the mouse over the icon and if shows 'Partial start' then you have to wait a little longer.
	__23.  In the admin console, navigate to Resources -> JDBC -> Data sources.
	__24.  Use the drop down for the Scope setting at the top of the list to select Cluster=LabCluster. 
	__25.  In the list of Data Sources, check the box next to the Online Store DB Data Source and press the Test Connection button.
	__26.  Check that you get a message about a successful test.  If you do not get a successful test, check the values of the database name of the Data Source, the value of the environment variable, and the user ID and password for the authentication alias as these are the most common errors. 

	Part 2 -  Install Clustered OnlineStore Application
	__1.  In the Applications group in the navigation, click the link for New Application.
	__2.  Click the link for New Enterprise Application.
	__3.  Next to the Local file system box, press the Browse button.
	__4.  Find the file <LABFILES_DIR>/Clustering/OnlineStore‑Clustering.ear and select Open in the file chooser dialog.  Remember to substitute the value of the <LABFILES_DIR> variable from the notes at the beginning of the labs.
	__5.  Press the Next button.
	__6.  Check the option for Detailed installation and press the Next button.  This will show all steps.
	__7.  On Step 1: Select installation options leave the default options and press the Next button.
	__8.  On Step 2: Map modules to servers check the checkbox next to both the OnlineStoreEJB and OnlineStoreWeb modules.  Select LabCluster and OnlineStoreWebServer from the list above by holding down the CTRL key as you select each one.  Make sure you pick the correct entries as the order may differ than that shown in the list below.  Press the Apply button to apply the changes to the mapping of the modules.  
	__9.  Click the link for Step 9 on the left to skip to this step.
	__10.  Check that the resource reference mapping for the data source matches the JNDI name you gave the data source in previous sections.  If you are not sure you can use the Browse button to pick the name of the data source from a list.  Once your resource reference mapping is set press the Next button.
	__11.  At this point you might get an error about application resources.  Everything is fine.  Press the Continue button to go to the next step.
	__12.  On Step 10: Map virtual hosts for web modules select myhost from the drop down menu and press the Next button.  This choice will make the application only available by using the was.myhost.com host name on port 80.
	__13.  Click the link for Step 13 on the left to skip to this step.
	__14.  On Step 13: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__15.  Click the Save link in the messages at the bottom of the Admin Console and be sure the configuration is synchronized with the Nodes.
	__16.  In the navigation pane of the Admin Console select Servers → Server Types → Web Servers.
	__17.  Check the checkbox next to OnlineStoreWebServer and click the Stop button.
	__18.  Check the checkbox next to OnlineStoreWebServer and click the Start button.
	__19.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__20.  Check the checkbox next to the OnlineStore application and press the Start button.  Wait for a message that the application started successfully.
	__21.  Logout of the Admin Console.

	Part 3 -  Test the OnlineStore Application
	__1.  Close all open web browsers, including the Admin Console.
	__2.  Open a web browser and enter http://was.myhost.com/Store in the address bar. Note that the first request may take a while as the application is initialized.
	__3.  Notice that in the left navigation there is an area that shows which server responded with your request.
	__4.  Click the Show cookies button on the left.
	__5.  Note that the dialog is empty which means there is no session cookie and you are viewed as a new client.
	__6.  Click the OK button to close the dialog.
	__7.  Register a new customer.  Make sure you do not register as an ID that is already in the database.  The first attempt to register will also probably take longer as the database connection is being initialized.
	__8.  Try some of the other functions of the applications like browsing products, adding and removing items from the cart, submitting orders, and viewing the orders for your user.
	__9.  Make sure you are logged in to the OnlineStore application.
	__10.  Click the Show cookies button on the left.
	__11.  Note the last few characters of the session id cookie before the colon ':'.  You do not need the whole value but just enough to recognize if it changes.
	__12.  Click the OK button to close the dialog.
	__13.  Close all open web browsers.
	__14.  Open a web browser and enter http://was.myhost.com/Store in the address bar.
	__15.  Log back in to the OnlineStore application using the id you registered.
	__16.  Click the Show cookies button on the left.
	__17.  Note the last few characters of the session id cookie before the colon ':'.  The value has changed to indicate that the server views this as a new session since you opened a new browser.  If you see exactly the same value make sure you closed every browser window before trying to access the application again.
	__18.  Notice that the cluster member that is handling your requests should be different than the one that was handling requests the first time.  This is the load balancing of clients between cluster members.

	Part 4 -  Test Server Failover
	__1.  Close all open web browsers.
	__2.  Open a web browser and enter http://localhost:9061/ibm/console in the address bar, the URL of the Deployment Manager Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the navigation pane select Servers → Server Types → Web servers.
	__5.  Click the link for the OnlineStoreWebServer.
	__6.  Under the Additional Properties section click the link for Plug-in properties.
	__7.  Scroll down to the bottom of the page and change the Log level setting to Stats.  Press the OK button when the settings match that below.
	__8.  Click the Save link in the messages at the top of the admin console and make sure the changes are synchronized with the nodes. Click OK.
	__9.  Check the checkbox next to OnlineStoreWebServer and click the Stop button.
	__10.  Check the checkbox next to OnlineStoreWebServer and click the Start button.
	__11.  Open a new web browser and go to the homepage of the application at http://was.myhost.com/Store.
	__12.  Login as an existing user and submit a few requests as you have done before. Make sure that you do not “Logout” of the application.
	__13.  You should see that all of the last few requests have been handled by the same server.  Note which cluster member is now processing all of your requests.
	__14.  Keep the browser window you have been using to submit requests open. This step is critical so you retain the session associated with the user that is logged in.
	__15.  In the navigation pane of the admin console, select Servers → Server Types → Web servers if you are not there already.
	__16.  Click the link for the OnlineStoreWebServer.
	__17.  Under the Additional Properties section click the link for Plug-in properties.
	__18.  Click the 'Runtime' tab at the top of the page of plug-in properties.
	__19.  Next to the name of the plug-in log, click the View button.
	__20.  At the top of the log display, check that there are not more “Total” lines than the “Filtered total”.  If there are, this means you may not be looking at the bottom of the log file.  If this is the case enter a range that would include the last lines of the log file in the “Retrieve Lines” box and hit the 'Refresh' button.
	__21.  Look at the details of how the requests were routed.  You should see that initially that requests may have gone to both servers but then all requests start going to only one server.
	__22.  In the navigation pane of the Admin Console select Servers → Server Types → WebSphere application servers.
	__23.  In the list of Application Servers, check the checkbox next to the server that processed your requests and press the Stop button.
	__24.  Click the OK button to confirm that you want to stop the server.
	__25.  Click the OK button after all the messages about stopping the server have been displayed.
	__26.  Back in the list of servers verify the server that had been processing your requests is stopped.
	__27.  Return to the web browser you were using for the OnlineStore application.
	__28.  Submit another request except a request to logout.  The application will continue to function as normal.  You should see that now the other server is handling your requests.
	__29.  In the navigation pane of the admin console, select Servers → Server Types → Web servers if you are not there already.
	__30.  Click the link for the OnlineStoreWebServer.
	__31.  Under the Additional Properties section click the link for Plug-in properties.
	__32.  Click the 'Runtime' tab at the top of the page of plug-in properties.
	__33.  Next to the name of the plug-in log, click the View button.
	__34.  Again check that there are not more “Total” lines than the “Filtered total”.  If there are, this means you may not be looking at the bottom of the log file.  If this is the case enter a range that would include the last lines of the log file in the “Retrieve Lines” box and hit the 'Refresh' button.
	__35.  Look at the details of how the requests were routed.  You should see a few messages about failing to connect to the original server and then the server being “marked down”.

	Part 5 -  Examine Distributed Sessions
	__1.  Open a web browser and enter http://localhost:9061/ibm/console in the address bar, the URL of the Deployment Manager Admin Console and login as the 'wasadmin' user if you are not already.
	__2.  In the navigation pane select Servers → Server Types → WebSphere application servers.
	__3.  Select the link for the first clustered server in the list.
	__4.  On the right side, in the Container Settings section, click the link for Session management.
	__5.  On the right side, under the Additional Properties, select Distributed environment settings.Note that the current settings already use memory-to-memory replication for distributed sessions.
	__6.  Click the link for Memory-to-memory replication.
	__7.  Notice that the setting is already using a “Replication domain” that matches the name of the cluster.
	__8.  Close the web browser you were using to test the application.
	__9.  Logout of the Admin Console and close the web browser.
	__10.  Close any extra web browsers, File Browser windows, or terminal windows you may have open.

	Part 6 -  Summary

	Alternate Lab 1 -  Enable JMS Messaging Using Default Messaging
	Part 1 -  Configure Service Integration Bus
	__1.  If it is not already running, start the server using the method you are most familiar with.
	__2.  Open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__3.  Login as the 'wasadmin' user.
	__4.  In the navigation pane, select Service integration -> Buses.
	__5.  At the Buses list, press New.
	__6.  For the properties of the new Bus change the following properties.
	__7.  When the properties appear as above press the Next button.
	__8.  Press the Finish button to create the bus.
	__9.  In the list of Buses click the link for the OnlineStoreBus.
	__10.  Under the Topology section click the link for Bus members.
	__11.  Press the Add button.
	__12.  Accept the defaults for Server and press the Next button.
	__13.  Select the Data store option for type of message store.
	__14.  Press the Next button when the option to use a Data store is selected.
	__15.  Leave the default option of Create default data source with generated JNDI name selected and press the Next button.
	__16.  Leave the default options under Tune performance parameters so that the heap size is not adjusted and press the Next button.
	__17.  Press the Finish button to add the server as a Bus member.
	__18.  Ensure the new server is added to the list of bus members.
	__19.  In the “Breadcrumb” trail at the top of the page click the link for OnlineStoreBus to return to the properties of the Bus.
	__20.  Under the Destination Resources section click the link for Destinations.
	__21.  Press the New button.
	__22.  Select a destination type of Queue and press the Next button.
	__23.  Fill in OnlineStoreQueue as the Identifier and press the Next button.
	__24.  Leave the server as the bus member assigned to the Queue and press the Next button.
	__25.  Press the Finish button to complete creating the Queue.
	__26.  Ensure the Queue is listed on the list.
	__27.  Click the Save link in the messages at the top of the Admin Console.

	Part 2 -  Configure the Default Messaging Provider
	__1.  In the navigation pane select Resources -> JMS -> Connection factories.
	__2.  Use the drop down for the Scope setting at the top of the list to select Cell=<cellname>.  Once the scope of your cell is shown press the New button.
	__3.  Select the radio button for Default messaging provider and press the OK button.
	__4.  At the New JMS Connection Factory page, enter the following information.  Write down the JNDI Name of the Connection Factory in the “Lab 7 & Alternate Lab 1” section of the Lab Notes.  Note the screenshots below only show the sections that have settings that are changed.
	__5.  When the properties match that above press the OK button.
	__6.  Click the link in the navigation pane for Resources -> JMS  -> Queues.
	__7.  Check that you are at the cell scope as in previous sections of this lab.  If you need to switch scope, select the scope using the drop down list.
	__8.  At the Queues list, press the New button.
	__9.  Select the radio button for Default messaging provider and press the OK button.
	__10.  At the New Queue page, enter the following information.  Leave the rest of the settings with the defaults.  Write down the JNDI Name of the Queue in the “Lab 7 & Alternate Lab 1” section of the Lab Notes.  Note the screenshots below only show the sections that have settings that are changed.
	__11.  When the values match those above press the OK button.
	__12.  Click the Save link in the messages at the top of the Admin Console.

	Part 3 -  Configure the JMS Activation Specification
	__1.  In the navigation pane select Resources -> JMS -> Activation specifications.
	__2.  Check that you are at the cell scope as in previous sections of this lab.  If you need to switch scope, select the scope using the drop down list.
	__3.  At the JMS Activation Specifications list, press the New button.
	__4.  Select Default messaging provider as the choice for provider so press the OK button.
	__5.  At the New Activation Specification page, enter the following information but do not press the OK button yet.
	__6.  Check that the Destination JNDI name matches the value you had written down in the Lab Notes section.
	__7.  Write down the JNDI name of the Activation Specification in the “Lab7 & Alternate Lab 1” section of the Lab Notes.
	__8.  When the properties match that shown in the previous steps press the OK button.
	__9.  Expand the Troubleshooting section in the navigation panel and expand Runtime Messages.
	__10.  Click the link for Runtime Error messages.
	__11.  Check that your settings for runtime events are set to 'Warning' or 'Error'.  If it is not then any errors that were reported during startup would not be shown in the Admin console.  If it was set to 'None', change the setting to 'Warning' and press the Apply button.
	__12.  Click the Save link in the messages at the top of the Admin Console.
	__13.  Logout of the Admin Console.
	__14.  Restart your Application Server.

	Part 4 -  Install a Messaging Application
	__1.  Return to the web browser you were using for the Admin Console.  If you closed it, open a web browser and enter http://localhost:9060/ibm/console in the address bar, the URL of the Admin Console.
	__2.  Login as the 'wasadmin' user.
	__3.  Expand the Troubleshooting section in the navigation panel and expand Runtime Messages.
	__4.  Click the link for Runtime Error messages.
	__5.  Make sure that you do not see any errors that occurred while starting the server.  If you do, contact your instructor so you can resolve these before continuing.
	__6.  In the Admin Console, navigate to Applications → Application Types → WebSphere enterprise applications.
	__7.  Check the checkbox next to the OnlineStore application and press the Update button.
	__8.  Leave the option of Replace the entire application selected and Local File System radio button.
	__9.  Hit the Browse button next to the Full path text box.
	__10.  Navigate to the <LABFILES_DIR>/Messaging directory, select the OnlineStore‑Messaging.ear file, and press Open.
	__11.  With the path to the EAR file filled in press the Next button.
	__12.  Check the option for Detailed installation.  This will show all steps.
	__13.  Press the Next button.
	__14.  On Step 1: Select Installation options leave the default options and press the Next button.
	__15.  On Step 2: Map modules to servers check the checkbox next to the OnlineStoreWeb module.  Select both servers from the list above by holding down the CTRL key as you select each one.  Press the Apply button to apply the changes to the mapping of the web module.  Make sure the OnlineStoreWeb module is mapped to BOTH servers as shown below and press the Next button.
	__16.  On the list of steps on the left click the link for Step 6 to skip to this step.
	__17.  On Step 6: Provide listener bindings For message-driven beans use the following options for the PurchasePrinter EJB.  Check the values for these compare with the values you have written down in the Lab Notes section.
	__18.  Once you have checked this value press the Next button.
	__19.  Click the link for Step 10 on the list of steps on the left to skip to this step.
	__20.  On Step 10: Map resource references to resources check that the JNDI name of the Connection Factory listed matches what you had written down for these values in the Lab Notes section.  Also check that the JNDI name of the data source is still 'jdbc/store'.  Note that you will need to scroll around to find these values and the screenshots below only show the part of the screen with the settings.  Also note that the screenshot showing the Connection Factory below does not show the entire JNDI name value.  If you need to change these values for any reason you can use the Browse button to select the configured resource from a list which will eliminate chance for errors due to typos.
	__21.  Once you have checked these values press the Next button.
	__22.  On Step 11: Map resource environment entry references to resources check that the JNDI name of the queue matches what you had written down for these values in the Lab Notes section.
	__23.  Once you have checked these values press the Next button.
	__24.  At this point you will get a warning message.  Everything is fine.  Press the Continue button.
	__25.  On Step 12: Map virtual hosts for web modules select myhost from the drop down menu. This option may already be filled in but double check.
	__26.  On the list of steps on the left click the link for Step 15 to skip to the summary.
	__27.  On Step 15: Summary press the Finish button.  Wait for the message that the application was installed successfully.  If you get a message that the installation failed notify your instructor.
	__28.  Click the Save link in the messages at the bottom of the Admin Console.
	__29.  In the list of Enterprise Applications, be sure the OnlineStore application is started. Navigate to Applications → Application Types → WebSphere enterprise applications if this list is not automatically displayed.

	Part 5 -  Test the Application
	__1.  Open a web browser and enter http://was.myhost.com/Store in the address bar.
	__2.  Login as a user that already exists on the system and has placed orders.
	__3.  Once you have logged in, click on the link on the left for Request Email.
	__4.  Once this page is displayed, click on the Request button.  This will generate a message from the Servlet that responds to the request.  You should get a fairly quick reply.  The normal response is shown below.
	__5.  Once you have verified that you can send a message properly, open a File Browser window.
	__6.  Navigate to the directory that contains the SystemOut.log log file you had written down the location of in the Lab Notes section.  This should be the <WAS_ROOT>/profiles/AppSrv01/logs/server1 directory.
	__7.  Open the SystemOut.log file with a text editor.  
	__8.  Search for the text “onMessage” which is printed out when the application receives a message.  Underneath this you should see a section that prints out the details of orders for that user.  
	__9.  Close the log file.
	__10.  Close the web browser you were using to test the application.
	__11.  Logout of the Admin Console and close the web browser.

	Part 6 -  Summary




