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Directory Paths Used in Labs
The following directories will be referred to often in the labs.  To simply lab instructions 
there are many places where the variables listed below will be used in place of the actual 
directory path.

Some directories which should already exist before you start the labs are listed below 
with values.  Please verify the location of these directories matches what is listed here 
and make a note of the change if it does not.  Also notify your instructor if anything does 
not match.

Some directories will not yet exist as you will be installing software in the labs.  These 
are listed here so you can write down the appropriate directory here when installing the 
software.

<SOFTWARE_DIR>:  /usr/JBoss/Software
<LAB_FILES>:  /usr/JBoss/LabFiles
<MYSQL_HOME>:  /var/lib/mysql
<APACHE_HOME>:  /etc/httpd
<ECLIPSE_HOME>:  <SOFTWARE_DIR>/eclipse

<JAVA_HOME>:                                                                                   

<JBOSS_HOME>:                                                                                 
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Availability of Open Source Software
The following open source software is used within the labs for this class.  Although all 
software programs have been made available on your machine to perform the labs the 
versions used and locations to download source code are presented here to comply with 
the licenses of these open source software packages.

Java - JDK 6.0 Update 17 - http://java.sun.com/javase/downloads/

Although not open source, Java is freely available

JBoss - v5.1.0.GA-jdk6 - http://www.jboss.org/jbossas/downloads

Apache Ant – 1.7.1 - http://archive.apache.org/dist/ant/binaries/

Eclipse IDE - Galileo – http://www.eclipse.org/downloads

Eclipse IDE for Java EE and Report Developers - Eclipse-reporting-Galileo-SR2

Eclipse TPTP plug-ins – tptp.runtime-TPTP-4.6.2

Eclipse Memory Analyzer - Galileo v0.8 – http://www.eclipse.org/mat/downloads.php

MySQL JDBC Driver – v5.0.8 - http://dev.mysql.com/downloads/connector/j/5.0.html

Apache Tomcat Connector - v1.2.28 – 
http://www.apache.org/dist/tomcat/tomcat-connectors/jk/binaries/

Apache JMeter – 2.3.4 - http://archive.apache.org/dist/jakarta/jmeter/binaries/

Chainsaw - v2 – http://logging.apache.org/log4j/docs/chainsaw.html

MySQL - v5.0.77 – Part of the CentOS 5.4 Linux distribution

Apache Web Server - v2.2.3 - Part of the CentOS 5.4 Linux distribution
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Lab 1 - Install Java
Setting up JBoss requires configuration of Java.  There are different versions of Java that 
you can use.  JBoss v5.0 requires Java SE 5.0 (or above).  JBoss can be used with Java 6 
although if you use Java 6 you must make some changes to the Jar files that are packaged 
with JBoss since some of the APIs JBoss uses were moved from Java EE to Java SE 6. 
There is also a download version of JBoss which has already had required changes made. 
You can find info about the differences with JBoss with Java SE 6 here (look for the Java 
6 notes):

http://community.jboss.org/wiki/JBossAS5InstallationandGettingStartedGuide

A Java compiler is not required.  This means you can use a Java Development Kit (JDK) 
or a Java Runtime Environment (JRE).  In these directions we will use the JDK 6. 
Although we will be providing a Java installation that has been verified with the labs you 
can download a version for use in your own systems from:

http://java.sun.com/javase/downloads/index.jsp

The version of Java environment should be something decided beforehand so it can be 
standard.  Applications may also require features of a particular version of Java.

There are also a few environment variables that should be set to make sure all of the 
components that will be installed separately can work together.

Part 1 - Install Java RPM Packages
The first step to install Java is to install the RPM packages for the version we want to use.

__1. Login to the machine using the “root” user created during the Cent OS installation 
using the user and password below:

user: root

password: centOS

Note: This user will be used throughout the labs.  JBoss does not have to be run as the 
'root' user but this is done in the labs for simplicity.

__2. Open a Terminal command window.  You should be able to do this by selecting 
'Applications -> Accessories -> Terminal' from the menus on the top panel.

__3. Issue the following command to switch into the <SOFTWARE_DIR> directory 
containing the Java download.  In the following command substitute the value of your 
<SOFTWARE_DIR> directory location from the “Directory Paths” page into the 
command.

cd <SOFTWARE_DIR>/Downloads/Java
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__4. Issue the following command to change the permissions of the Java installation 
program.

chmod a+x jdk-6u17-linux-i586-rpm.bin

__5. Issue the following command to run the Java RPM installation program.

./jdk-6u17-linux-i586-rpm.bin

__6. Hit the <Space> bar until all the pages of the license have been displayed.

__7. When prompted type 'yes' to accept the license.

__8. Wait until the package is successfully installed as shown below.

__9. Press the Enter key to finish the installation.  It may take a few more seconds to 
return to a prompt.

__10. Close a browser if it appears for registration.
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Part 2 - Reconfigure Java for Linux
One of the most difficult steps for installing Java on Linux can be getting the system to 
use the version you install instead of another version that may be installed with the 
system.  Although these steps have been tested with Cent OS other Linux distributions 
would be similar.

Cent OS uses the same “Alternatives” system as Red Hat Enterprise Linux.

__1. Open a Terminal window or use one you already have open.

__2. Issue the following command to remove the current “alternative” configuration for 
Java as shown below.  

rm /var/lib/alternatives/java

__3. Confirm when asked if you want to remove the file.

__4. Execute the two commands below to install alternatives for the 'java' command. 
Note these commands have been broken between lines with '\' as they are long 
commands.

alternatives --install /usr/bin/java java \
/usr/lib/jvm/jre-1.4.2-gcj/bin/java 1

alternatives --install /usr/bin/java java \
/usr/java/jdk1.6.0_17/bin/java 2
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__5. Run the following command to check that the new version of Java is the default.  

alternatives --config java

__6. Hit <Enter> after confirming the new default version.

__7. Enter the following command to change to the /etc/profile.d directory.

cd /etc/profile.d

__8. Enter the command to create a new file 'java.sh' in the directory using vi.

vi java.sh

__9. Hit the 'i' key to enter “Insert” mode on vi.

__10. Enter the following text in the file.

export JAVA_HOME="/usr/java/jdk1.6.0_17"
export JAVA_PATH="$JAVA_HOME"
export PATH="$JAVA_HOME/bin:$PATH"

Note: Some Java programs look for a JAVA_HOME environment variable to locate the 
Java installation.  This part of the lab will configure that variable.  This also adds the 
'bin' directory of Java to the path to allow execution of Java commands from any 
directory.

__11. Hit the <Esc> key to exit “Insert” mode.
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__12. Enter 'ZZ' to save the file and return to the terminal shell.

__13. Enter the command below to check the contents of the file.

cat java.sh

__14. When the contents of the file have been checked, enter the following command to 
“source” the contents into your current terminal session.

source /etc/profile.d/java.sh

__15. Open a new Terminal window.

__16. Issue the following two commands and check from the output that the version of 
the 'java' command being used is the new version installed in the '/usr/java/jdk1.6.0_17' 
directory as shown below.

which java
java -version
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__17. Issue the following command and check that the value of the 'JAVA_HOME' 
variable is set correctly.  Some programs require this value to point to the Java 
installation.

echo $JAVA_HOME

__18. Write the complete path to this directory down in the notes at the beginning of this 
lab guide as the value of the JAVA_HOME directory. 

Part 3 - Install Java Browser Plug-in
The last step that may be required is to enable Java for the web browsers used on your 
system.  This is required because one of the most useful administrative consoles available 
with JBoss uses a Java Applet.  It is possible to skip the steps in this section and install 
the Java plug-in in the web browser when it is needed but this may require each user to 
do it separately.  Although these steps are for the Firefox browser that is the default for 
Cent OS, other browsers and Linux distributions would be similar.

__1. Close all open web browsers.

__2. Open a Terminal command window.

__3. Switch to the '/usr/lib/mozilla/plugins/' directory.

__4. Use the ls command to check that you do not have any current 'libjavaplugin..' files.

__5. Issue the following command to create a link from the Java installation into the 
Firefox plugins directory.  Be sure to include the period at the end and note that the 
screenshot below uses a '\' to split the command between two lines.

ln -s /usr/java/jdk1.6.0_17/jre/plugin/i386/ns7/libjavaplugin_oji.so .

10

EVALUATIO
N O

NLY



__6. Use the ls command to verify that the link was created successfully as shown below.

__7. Close any extra File Browsers or terminal windows.

Part 4 - Summary
You have installed a Java runtime environment on your machine.  This is required to 
support the JBoss installation that will be done in the next lab.
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Lab 2 - JBoss Application Server Installation
In this lab you will install the JBoss Application Server v5.1 on Linux.  Installing JBoss 
can be as easy as unpacking the binaries as you will do here.  Although we will be 
providing a JBoss installation that has been verified with the labs you can download a 
version for use in your own systems from:

http://www.jboss.org/jbossas/downloads/

You will also learn some basics like starting the server, viewing an administration 
console, and stopping the server.

Part 1 - Install the JBoss Application Server
__1. Find the archived version of JBoss we are providing.  It is located at:

<SOFTWARE_DIR>/Downloads/JBoss

__2. Extract the file jboss-5.1.0.GA-jdk6.zip to the <SOFTWARE_DIR> directory.  Be 
sure the Zip utility does not create an extra subdirectory as the contents of the archive 
will do that automatically.

__3. Open a File Browser window and navigate to the <SOFTWARE_DIR> directory. 
You should see a jboss-5.1.0.GA subdirectory that was created by unpacking the files. 

__4. Write the complete path to this directory down in the notes at the beginning of this 
lab guide as the value of the JBOSS_HOME directory.  Most likely this is 
'/usr/JBoss/Software/jboss-5.1.0.GA'.

__5. That's it!  The main step involved in the JBoss install is actually installing a Java 
runtime which you did in the previous lab.
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Part 2 - Start the JBoss Server
__1. Open a terminal prompt.

__2. Change to the <JBOSS_HOME>/bin directory using the cd command.  This would 
most likely be:

cd /usr/JBoss/Software/jboss-5.1.0.GA/bin

__3. Use the ls command to list the contents of the directory.  Notice the most important 
commands of 'run', 'shutdown', and 'twiddle'.

__4. Execute the run.sh script with the following command.  After several seconds you 
should see output similar to the following.

./run.sh

__5. Be sure to leave this window open as closing it would terminate the server.
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Part 3 - Examine the Server Consoles
Besides allowing us to test the JBoss installation, the JBoss Consoles will be one of the 
primary tools for JBoss administration.  We will see the JMX Console, the Web Console, 
and the "Administration Console".

__1. Open a web browser and enter the following address:

http://localhost:8080/

__2. Click on the link for 'JMX Console'.

__3. In the ObjectName Filter textbox fill in a value of type=ServerInfo and press the 
ApplyFilter button. 

__4. If a Security Warning appears, click Continue.

__5. After pressing the button you should see only a single link on the page for 
'type=ServerInfo'. Click on this link.
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__6. Scroll down the page and look at the list of 'MBean attributes'.  This shows various 
properties of the JBoss Server.

__7. Go back to the JBoss Welcome page at:

http://localhost:8080/

__8. Click the link for the 'JBoss Web Console'.

__9. Notice the information presented on the home page of the Web Console is similar to 
what you saw with the JMX Console.
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__10. On the left hand side make sure you see the web console navigation loaded.  This is 
an Applet and this will confirm you have the Java browser plug-in configured properly.

__11. Go back to the JBoss Welcome page at:

http://localhost:8080/

__12. Click the link for the 'Administration Console'.

__13. Login with the default user of 'admin' and password of 'admin'.

16

EVALUATIO
N O

NLY



__14. Notice like the other consoles you have some basic information available and 
navigation within the console.  The difference with this console is you can make 
permanent configuration changes which we will explore later.

__15. Close the browser.

Note: All JBoss Consoles can be used for JBoss administration.  We will use these fairly 
interchangeably throughout the class.  The Web Console is generally easier to navigate 
and explore but the JMX Console is sometimes easier when you know exactly what you 
are trying to find.  The Administration Console can perform a few tasks that 
permanently alter the JBoss configuration.  The Administration Console is one of the 
main features of the JBoss Application Server 5.1 version as previous versions did not 
have a console that could make permanent changes.
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Part 4 - Shutdown the Server
Although there are several ways to shutdown the Server we will use the simplest method 
in this section.

__1. Switch to the terminal window window that shows the server output.

__2. Press CTRL-C to send a shutdown command to the Server.  You will see several 
messages about shutting down the server.

Part 5 - Start the Server with a Particular Configuration
Having several different configurations can be important in testing an application in 
different environments.  In this section we will start JBoss with another of the out-of-the-
box configurations.

__1. Open a File Browser window and view the contents of the following folder:

<JBOSS_HOME>/server

Note: The subfolders of the ‘server’ directory are named configurations of JBoss that 
can be used interchangeably.  You can use the ‘-c’ option on startup to specify the name 
of the configuration to use.  The following configurations are available:

default – The usual starting point for stand-alone servers not part of a cluster.

all – The starting point for clustered servers with several services enabled for clustering 
not available for other configurations.

standard – The configuration that was used to pass the Java EE compatibility tests. 
Usually has slightly different behavior for classloading and application isolation 
compared to the 'default' configuration.

web – An experimental configuration similar to what will be available for the "Web 
Profile" in Java EE 6.  Not suggested for use currently.

minimal – A configuration with very few services enabled so not very useful as a 
starting point for customizing configuration.  Often it is easier to start with the 'default' 
configuration and remove services in a process called "slimming".
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__2. Return to the terminal command window you had used to run JBoss before.  Open a 
new terminal window if you have closed it.

__3. Issue the following command to start JBoss with the ‘default’ configuration:

./run.sh -c default

__4. Look at the messages near the top of the output and notice that the configuration 
name and directory are listed.

__5. Wait until the server starts completely.

__6. Open a second terminal window.

__7. Change to the <JBOSS_HOME>/bin directory using the cd command.  This is 
most likely:

cd /usr/JBoss/Software/jboss-5.1.0.GA/bin

__8. Issue the following command to stop the server.  Make sure to use a capital 'S' for 
the option.

./shutdown.sh -S
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__9. Check that you see messages about the shutdown being initiated.

__10. Switch back to the terminal window that started the server and verify you see 
messages about the server shutting down.

Part 6 - Backup a Configuration
It is always a good idea to regularly backup the server configuration so changes can be 
undone if needed.  Since the server configuration is simply stored as a set of files in a 
directory this is easy to do with a tool like the Linux Archive Manager.

__1. Open a File Browser window and view the contents of the following folder:

<JBOSS_HOME>/server

__2. Use the Archive Manager to archive the entire contents of the ‘default’ directory by 
right clicking on the 'default' directory and selecting 'Create Archive...'.  Be sure you 
preserve the folder structure when archiving the directory.

__3. Rename the file to something more descriptive like ‘Clean Default Config’ and 
select as '.tar' as shown below.  Then click on the Create button.

Note: This method of backup may also backup temporary directories that will be 
recreated when you restart the server anyway.  Later we will use another method that 
might be able to exclude these directories.
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Part 7 - Create a New Configuration
If changes are needed to any services to support a particular application it is often best to 
make these changes to a copy of one of the basic configurations.  Using this practice 
allows the original configurations to remain free of any customization and to be used in 
the future as templates for additional server configurations.  In this section we will make 
a copy of one of the basic configurations and start the server with our custom 
configuration.

__1. Use a File Browser window to view the contents of the following folder:

<JBOSS_HOME>/server

__2. Copy the ‘default’ directory and paste it in the same directory.

__3. Rename the directory you copied to 'myconfig'.

__4. Issue the following command in a terminal window from the 
<JBOSS_HOME>/bin directory to start JBoss with the ‘myconfig’ configuration:

./run.sh -c myconfig

__5. Look at the messages near the top of the output and notice that the configuration 
name and directory are listed.
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__6. Wait until the server starts completely and then go to the JBoss Welcome page at:

http://localhost:8080/

__7. Click the link for the ‘JBoss Web Console’.

__8. In the navigation tree on the left navigate to:

System=>JMX Mbeans=>jboss.system=>jboss.system:type=Server

Note:  You must click on the circles on the very left side of the navigation to expand 
them.

__9. After selecting the type=Server entry, scroll down and find the list of ‘MBean 
operations’.  Find the ‘shutdown’ operation and press the Invoke button.
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__10. Switch back to the terminal window that was running the server and notice that 
shutdown messages are being printed.  The browser that you issued the shutdown 
command from may eventually show an error since the server you were connected to has 
stopped.

Note:  All of the methods of shutting down the server are equivalent.  It is up to you to 
decide which is easier and most appropriate for your environment.

__11. Close any extra terminal windows or File Browser windows you have opened 
during the lab to avoid confusion.

Part 8 - Summary
You have seen that installing JBoss is actually easy and mostly involves the prerequisite 
installation of Java.  You saw several ways to stop and start the server and the various 
server configuration subdirectories that you can use to create unique server 
configurations.
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Lab 3 - Deploy Applications to JBoss
In this lab you will deploy applications to your JBoss server.  You can do this by 
manually copying the file to a deployment directory, using the Administration Console or 
use Ant to copy files.

After manually deploying the application you will see how to test the application, 
undeploy the application, and view the application properties in the Administration 
Console.  You will also start to use an Ant build script to define utility mechanisms for 
managing JBoss deployments.

Part 1 - Manually Deploy Application
In this part you will deploy an application by copying the file directly on the file system. 
You will use the "hot deployment" feature of JBoss to deploy while the server is running.

__1. Issue the following command in a terminal window from the 
<JBOSS_HOME>/bin directory to start JBoss with the ‘myconfig’ configuration:

./run.sh -c myconfig

__2. Wait until the server starts completely.

__3. Open a File Browser window and navigate to the directory 
<LAB_FILES>/SimpleApp.

__4. Copy the HelloWeb.war file from this directory.  This will be the application you 
will deploy.

__5. In the File Browser window navigate to the directory 
<JBOSS_HOME>/server/myconfig/deploy.  You should see many files which all 
represent the standard service configurations for the JBoss server.

__6. Paste the application into this directory by selecting Edit->Paste from the menus.

__7. Switch back to the terminal window running JBoss and you should see the message 
below printed.  Note in particular the value listed for ctxPath as this will be important for 
testing.
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Part 2 - Test Application
Now that the application is running on the server we need to be able to test it.  Since this 
is a web application it makes sense to open a web browser to test the application.  We 
only need to figure out what URL to use to access the application.

__1. Open a web browser and enter http://localhost:8080 in the address bar.  This opens 
the Welcome page for the JBoss server but notice that the 'HelloWeb' application is not 
listed anywhere. This is a simple static page that has links to JBoss documentation and 
management features.

__2. This is where the ctxPath mentioned in the last step comes in handy.  This "context" 
is where JBoss makes the application available and the value is independent of the 
hostname and port of the server.  Add the value of the ctxPath from the last part to the 
URL in the web browser.  Make sure you match capitalization exactly.  The final URL 
should be:

http://localhost:8080/HelloWeb

__3. Press enter to accept the new URL if you haven't done so already.  You should see 
the output shown below.

__4. Since this output doesn't show anything dynamic it could have just as easily been 
served by a normal web server.  Click on the link to display a message on the screen.
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__5. After displaying the normal message of "Hello There!" return to the previous page 
and fill in a special message in the text box.  Press the button to display the special 
message.

__6. Test the application by submitting several more special messages.  Also use the link 
again to prove that the default message will still display after a special message has been 
submitted.

Note:  Even though you can display any message you wish on the second page of the 
application notice that the main part of the URL is always the same.  The URL always 
starts with:

http://localhost:8080/HelloWeb/HelloServlet

This is because the page displaying the message is a dynamically generated page.

__7. Switch back to the terminal window running JBoss.  You should see output 
messages from the Servlet about what message it is displaying.

__8. Leave the web browser open on the home page of the application.

Part 3 - Use Administration Console
A new feature of the JBoss 5.1 server is the new "Administration Console".  The previous 
consoles that were available with JBoss showed runtime information but could not make 
permanent changes to the JBoss configuration.  Although the new Administration 
Console of JBoss is fairly limited compared to the features of other Java application 
servers, managing applications is one feature it does have.  We will see that feature in this 
section.

__1. Open a new browser window or tab and enter the following address:

http://localhost:8080/

__2. Click the link for the 'Administration Console'.

__3. Login with the default user of 'admin' and password of 'admin'.
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__4. In the left navigation, under the group of different types of applications, click the 
link for "Web Application (WAR)s".

__5. On the right side, click the link for the HelloWeb.war.

__6. Notice this lists properties like the path to the application file and the context root.
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__7. Click the Content tab above the list of properties for HelloWeb.war.

__8. Notice this is where you could upload an updated version of the application.  The 
name of the file you upload must be exactly the same as the previous version.

__9. Click the Control tab above the list of properties for HelloWeb.war.

__10. Click the Stop button to stop the application.

__11. Go back to the web browser you were using to test the HelloWeb application and 
refresh the page.  You will get a 404 error since the application is no longer running.  You 
would get the same error if you removed the application.
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__12. Switch back to the Administration Console and press the Start button for the 
application.

__13. Test the application again and verify it responds again.

__14. In the left navigation of the Admin Console, click the link for "Enterprise 
Application (EAR)s".

__15. On the right side of the empty list of applications, click the button to "Add a new 
resource".

__16. Click the Browse button and select the file 
<LAB_FILES>/SimpleApp/HitCount.ear and click Open.

__17. Once you have the proper file selected hit the Continue button.

__18. After several seconds you should get a message about the application being created 
and it should be listed.
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Note: Notice that unlike most other Java application servers, with JBoss you do not get 
a chance to edit the deployment properties of the application.  The Admin Console is 
basically just uploading a file for you to the 'deploy' directory.

__19. In the left navigation of the Admin Console, click the link for "Embedded Web 
Application (WAR)s".

__20. Click the link on the right for HitCountWeb.war.

__21. Notice that the Control tab is not enabled.  If you wanted to stop this application 
you would need to stop the EAR file.

__22. Notice the value of the Context Root is HitCountWeb.

__23. Open a new browser window or tab to the following address to access the HitCount 
application that was installed.

http://localhost:8080/HitCountWeb

__24. Click on the link on the home page of the application to begin a count of hits.
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__25. Refresh the page several times and you should see the count increasing.

Note: This application contains a stateful session EJB which tracks the number of hits to 
the page.  If you were to restart the EAR file the count would be reset as this is not 
stored anywhere permanently.

Part 4 - Undeploy Application
At this point we want to undeploy the applications.  Unfortunately since we have 
deployed one of the applications through the admin console, the safest way to remove 
that application is also through the admin console.  If we do not the state of the admin 
console and the contents of the 'deploy' directory can be out of sync.

__1. In the left navigation of the Admin Console, click the link for "Enterprise 
Application (EAR)s".

__2. Press the Delete button next to the HitCount.ear application and confirm that you 
want to delete the resource.

__3. You should get a message that the application was successfully deleted.

__4. Click the Logout link in the upper right corner of the Admin Console.
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__5. Open a File Browser window and navigate to the directory 
<JBOSS_HOME>/server/myconfig/deploy.

__6. Delete the HelloWeb.war file from this directory.  This will also undeploy the 
application.

Note: You could have actually undeployed either application using either method.  The 
issue is that if you delete the file from the file system and use the Admin Console shortly 
after this the Admin Console may think the application should still be there and mark the 
application as down.  You will also likely get a warning message in the log file that a 
"Managed deployment" was not found.  If you tried to also delete it from the Admin 
Console you would get an error that the file could not be found.  

Eventually the Admin Console should return to a synchronized state with the contents of 
the 'deploy' directory and not list the applications that were deleted manually but it can 
be confusing until it does.

Part 5 - Deploy Using Ant
Although copying files manually or with the Admin Console are ways to deploy 
applications to JBoss it does not represent a very repeatable or automated process.  In this 
section you will use an Ant build script to deploy applications to JBoss.  We are also 
establishing this process now because there are some JBoss configurations we will need 
to do that can't be done through the Admin Console so it will be good to use the same 
process for all labs.

__1. Open a File Browser window and navigate to the directory 
<LAB_FILES>\SimpleApp.

__2. Extract the AntWorkspace.zip file directly to the <LAB_FILES> folder.  Make 
sure the unzip utility does not create a subdirectory using the name of the zip file.

__3. Navigate to the <LAB_FILES>/workspace directory that was created by unzipping 
the file.  Notice there are two subdirectories.  The JBossAnt directory contains the Ant 
build that will be run and the config directory contains files that will be copied to JBoss.

__4. Open the build.properties file in the JBossAnt directory with a text editor.

32

EVALUATIO
N O

NLY



__5. Check that the values for the first two properties, JBossHome and 
ConfigWorkspace are correct.  The JBossHome value should be where you extracted 
JBoss and recorded as <JBOSS_HOME> in a previous lab.  The ConfigWorkspace 
value should be the 'workspace' directory that was created by unzipping the file in the 
previous steps.  If you need to change either of these values make sure they match exactly 
what the path is on the machine.

Note: This file contains external properties so it will be easiest to modify the way the 
Ant build executes.

__6. Close the build.properties file and save any changes if you made them.

__7. Open the build.xml file with a text editor.

__8. Look at the top of the build script.  Notice that the default is to call a target called 
'publishSingle'.  There is also a task that will import the build.properties file.

__9. Find the 'publishSingle' target.  Notice that this target sets a few properties and then 
calls the 'genericPublish' target.
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__10. Find the 'genericPublish' target.  This copies files from the 'config' directory into 
the JBoss server configuration.  If you did not need to change the build properties this 
will copy the '/usr/JBoss/LabFiles/workspace/config' directory into 
'/usr/JBoss/Software/jboss-5.1.0.GA/server/myconfig'.

__11. Examine the other targets like 'genericClean', 'genericBackup', and 
'rebuildSingle'.  The first two will delete a server configuration and create a zip file of a 
server configuration respectively.  The 'rebuildSingle' calls the first two, then copies files 
from the 'default' JBoss configuration, and then calls the 'publishSingle' target.  This will 
"rebuild" the server configuration from scratch to be sure everything is synchronized.

Note:  There are several directories that are excluded from the copy from the 'default' 
configuration during the rebuild.  These directories contain files created during the 
deployment process.  Even though starting the copied configuration would likely replace 
these files it is best not to copy them in the first place.

__12. Close the build.xml file when you are done examining it.

__13. In the File Browser window, navigate to the 
<LAB_FILES>/workspace/config/deploy directory. Notice that it contains the 
HelloWeb.war and HitCount.ear files we deployed earlier.

Note:  Even though right now there are only files in the 'deploy' directory, the Ant build 
is setup so that if other files in the server configuration need to be customized in the 
future, they can be added to the 'config' project and copied over.

__14. Make sure that the JBoss server is still running in the one terminal window.  Start it 
if it is not.  Make sure you start the 'myconfig' server configuration.  If you needed to 
start the server wait until it starts before continuing.

./run.sh -c myconfig

__15. Open a second terminal window.

__16. Change to the <SOFTWARE_DIR>/apache-ant-1.7.1/bin directory.  You will 
likely use a command similar to the following:

cd /usr/JBoss/Software/apache-ant-1.7.1/bin
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__17. Enter the following command to execute the Ant build.  If your workspace 
directory is different make the appropriate change.

   ./ant -buildfile /usr/JBoss/LabFiles/workspace/JBossAnt/build.xml

__18. Make sure that you see a message that two files were copied and the build was 
successful.

__19. Leave this terminal window open.

__20. Switch to the terminal window running JBoss and you will see many messages 
about deploying the HelloWeb and HitCount applications.

__21. As you have before, use a web browser to test the applications at the following 
addresses.

http://localhost:8080/HelloWeb
http://localhost:8080/HitCountWeb
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Part 6 - Rebuild Server Configuration
It will be good to know how to run Ant targets that are not the default.  This section will 
have you "rebuild" the server to do this.

__1. Shutdown the JBoss server in the terminal window.  You can do this by pressing 
CTRL-C.

Note:  This is important to do since we will be deleting the server configuration.

__2. Return to the terminal window you were using to run Ant.  Open a terminal window 
to the <SOFTWARE_DIR>/apache-ant-1.7.1/bin directory if you need to.

__3. Run the following Ant command.  Notice the difference is the 'rebuildSingle' target 
name on the end.  Make sure to enter this command on one line even though it wraps to a 
second line below.
 ./ant -buildfile /usr/JBoss/LabFiles/workspace/JBossAnt/build.xml 
rebuildSingle

__4. Notice there are many more messages but at the end you should see the same 
message about copying two files and the same BUILD SUCCESSFUL message.

__5. If you want you can restart the JBoss server and retest the applications.

__6. Close any extra web browsers, File Browser windows, and terminal windows to 
avoid confusion.
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Part 7 - Summary
In this lab you saw many different ways to deploy applications.  All of them ultimately 
copied the application file to the same directory.  You saw how to view some simple 
information about the application from the Administration Console.  You also saw how to 
automate JBoss server configuration management with Ant.  Even though future labs will 
run the Ant build from within Eclipse you can do the same thing from the command line 
if you wish in your own environment.
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	Lab 1 -  Install Java
	Part 1 -  Install Java RPM Packages
	__1.  Login to the machine using the “root” user created during the Cent OS installation using the user and password below:
	__2.  Open a Terminal command window.  You should be able to do this by selecting 'Applications -> Accessories -> Terminal' from the menus on the top panel.
	__3.  Issue the following command to switch into the <SOFTWARE_DIR> directory containing the Java download.  In the following command substitute the value of your <SOFTWARE_DIR> directory location from the “Directory Paths” page into the command.
	__4.  Issue the following command to change the permissions of the Java installation program.
	__5.  Issue the following command to run the Java RPM installation program.
	__6.  Hit the <Space> bar until all the pages of the license have been displayed.
	__7.  When prompted type 'yes' to accept the license.
	__8.  Wait until the package is successfully installed as shown below.
	__9.  Press the Enter key to finish the installation.  It may take a few more seconds to return to a prompt.
	__10.  Close a browser if it appears for registration.

	Part 2 -  Reconfigure Java for Linux
	__1.  Open a Terminal window or use one you already have open.
	__2.  Issue the following command to remove the current “alternative” configuration for Java as shown below.  
	__3.  Confirm when asked if you want to remove the file.
	__4.  Execute the two commands below to install alternatives for the 'java' command.  Note these commands have been broken between lines with '\' as they are long commands.
	__5.  Run the following command to check that the new version of Java is the default.  
	__6.  Hit <Enter> after confirming the new default version.
	__7.  Enter the following command to change to the /etc/profile.d directory.
	__8.  Enter the command to create a new file 'java.sh' in the directory using vi.
	__9.  Hit the 'i' key to enter “Insert” mode on vi.
	__10.  Enter the following text in the file.
	__11.  Hit the <Esc> key to exit “Insert” mode.
	__12.  Enter 'ZZ' to save the file and return to the terminal shell.
	__13.  Enter the command below to check the contents of the file.
	__14.  When the contents of the file have been checked, enter the following command to “source” the contents into your current terminal session.
	__15.  Open a new Terminal window.
	__16.  Issue the following two commands and check from the output that the version of the 'java' command being used is the new version installed in the '/usr/java/jdk1.6.0_17' directory as shown below.
	__17.  Issue the following command and check that the value of the 'JAVA_HOME' variable is set correctly.  Some programs require this value to point to the Java installation.
	__18.  Write the complete path to this directory down in the notes at the beginning of this lab guide as the value of the JAVA_HOME directory. 

	Part 3 -  Install Java Browser Plug-in
	__1.  Close all open web browsers.
	__2.  Open a Terminal command window.
	__3.  Switch to the '/usr/lib/mozilla/plugins/' directory.
	__4.  Use the ls command to check that you do not have any current 'libjavaplugin..' files.
	__5.  Issue the following command to create a link from the Java installation into the Firefox plugins directory.  Be sure to include the period at the end and note that the screenshot below uses a '\' to split the command between two lines.
	__6.  Use the ls command to verify that the link was created successfully as shown below.
	__7.  Close any extra File Browsers or terminal windows.

	Part 4 -  Summary

	Lab 2 -  JBoss Application Server Installation
	Part 1 -  Install the JBoss Application Server
	__1.  Find the archived version of JBoss we are providing.  It is located at:
	__2.  Extract the file jboss-5.1.0.GA-jdk6.zip to the <SOFTWARE_DIR> directory.  Be sure the Zip utility does not create an extra subdirectory as the contents of the archive will do that automatically.
	__3.  Open a File Browser window and navigate to the <SOFTWARE_DIR> directory. You should see a jboss-5.1.0.GA subdirectory that was created by unpacking the files. 
	__4.  Write the complete path to this directory down in the notes at the beginning of this lab guide as the value of the JBOSS_HOME directory.  Most likely this is '/usr/JBoss/Software/jboss-5.1.0.GA'.
	__5.  That's it!  The main step involved in the JBoss install is actually installing a Java runtime which you did in the previous lab.

	Part 2 -  Start the JBoss Server
	__1.  Open a terminal prompt.
	__2.  Change to the <JBOSS_HOME>/bin directory using the cd command.  This would most likely be:
	__3.  Use the ls command to list the contents of the directory.  Notice the most important commands of 'run', 'shutdown', and 'twiddle'.
	__4.  Execute the run.sh script with the following command.  After several seconds you should see output similar to the following.
	__5.  Be sure to leave this window open as closing it would terminate the server.

	Part 3 -  Examine the Server Consoles
	__1.  Open a web browser and enter the following address:
	__2.  Click on the link for 'JMX Console'.
	__3.  In the ObjectName Filter textbox fill in a value of type=ServerInfo and press the ApplyFilter button. 
	__4.  If a Security Warning appears, click Continue.
	__5.  After pressing the button you should see only a single link on the page for 'type=ServerInfo'. Click on this link.
	__6.  Scroll down the page and look at the list of 'MBean attributes'.  This shows various properties of the JBoss Server.
	__7.  Go back to the JBoss Welcome page at:
	__8.  Click the link for the 'JBoss Web Console'.
	__9.  Notice the information presented on the home page of the Web Console is similar to what you saw with the JMX Console.
	__10.  On the left hand side make sure you see the web console navigation loaded.  This is an Applet and this will confirm you have the Java browser plug-in configured properly.
	__11.  Go back to the JBoss Welcome page at:
	__12.  Click the link for the 'Administration Console'.
	__13.  Login with the default user of 'admin' and password of 'admin'.
	__14.  Notice like the other consoles you have some basic information available and navigation within the console.  The difference with this console is you can make permanent configuration changes which we will explore later.
	__15.  Close the browser.

	Part 4 -  Shutdown the Server
	__1.  Switch to the terminal window window that shows the server output.
	__2.  Press CTRL-C to send a shutdown command to the Server.  You will see several messages about shutting down the server.

	Part 5 -  Start the Server with a Particular Configuration
	__1.  Open a File Browser window and view the contents of the following folder:
	__2.  Return to the terminal command window you had used to run JBoss before.  Open a new terminal window if you have closed it.
	__3.  Issue the following command to start JBoss with the ‘default’ configuration:
	__4.  Look at the messages near the top of the output and notice that the configuration name and directory are listed.
	__5.  Wait until the server starts completely.
	__6.  Open a second terminal window.
	__7.  Change to the <JBOSS_HOME>/bin directory using the cd command.  This is most likely:
	__8.  Issue the following command to stop the server.  Make sure to use a capital 'S' for the option.
	__9.  Check that you see messages about the shutdown being initiated.
	__10.  Switch back to the terminal window that started the server and verify you see messages about the server shutting down.

	Part 6 -  Backup a Configuration
	__1.  Open a File Browser window and view the contents of the following folder:
	__2.  Use the Archive Manager to archive the entire contents of the ‘default’ directory by right clicking on the 'default' directory and selecting 'Create Archive...'.  Be sure you preserve the folder structure when archiving the directory.
	__3.  Rename the file to something more descriptive like ‘Clean Default Config’ and select as '.tar' as shown below.  Then click on the Create button.

	Part 7 -  Create a New Configuration
	__1.  Use a File Browser window to view the contents of the following folder:
	__2.  Copy the ‘default’ directory and paste it in the same directory.
	__3.  Rename the directory you copied to 'myconfig'.
	__4.  Issue the following command in a terminal window from the <JBOSS_HOME>/bin directory to start JBoss with the ‘myconfig’ configuration:
	__5.  Look at the messages near the top of the output and notice that the configuration name and directory are listed.
	__6.  Wait until the server starts completely and then go to the JBoss Welcome page at:
	__7.  Click the link for the ‘JBoss Web Console’.
	__8.  In the navigation tree on the left navigate to:
	__9.  After selecting the type=Server entry, scroll down and find the list of ‘MBean operations’.  Find the ‘shutdown’ operation and press the Invoke button.
	__10.  Switch back to the terminal window that was running the server and notice that shutdown messages are being printed.  The browser that you issued the shutdown command from may eventually show an error since the server you were connected to has stopped.
	__11.  Close any extra terminal windows or File Browser windows you have opened during the lab to avoid confusion.

	Part 8 -  Summary

	Lab 3 -  Deploy Applications to JBoss
	Part 1 -  Manually Deploy Application
	__1.  Issue the following command in a terminal window from the <JBOSS_HOME>/bin directory to start JBoss with the ‘myconfig’ configuration:
	__2.  Wait until the server starts completely.
	__3.  Open a File Browser window and navigate to the directory <LAB_FILES>/SimpleApp.
	__4.  Copy the HelloWeb.war file from this directory.  This will be the application you will deploy.
	__5.  In the File Browser window navigate to the directory <JBOSS_HOME>/server/myconfig/deploy.  You should see many files which all represent the standard service configurations for the JBoss server.
	__6.  Paste the application into this directory by selecting Edit->Paste from the menus.
	__7.  Switch back to the terminal window running JBoss and you should see the message below printed.  Note in particular the value listed for ctxPath as this will be important for testing.

	Part 2 -  Test Application
	__1.  Open a web browser and enter http://localhost:8080 in the address bar.  This opens the Welcome page for the JBoss server but notice that the 'HelloWeb' application is not listed anywhere. This is a simple static page that has links to JBoss documentation and management features.
	__2.  This is where the ctxPath mentioned in the last step comes in handy.  This "context" is where JBoss makes the application available and the value is independent of the hostname and port of the server.  Add the value of the ctxPath from the last part to the URL in the web browser.  Make sure you match capitalization exactly.  The final URL should be:
	__3.  Press enter to accept the new URL if you haven't done so already.  You should see the output shown below.
	__4.  Since this output doesn't show anything dynamic it could have just as easily been served by a normal web server.  Click on the link to display a message on the screen.
	__5.  After displaying the normal message of "Hello There!" return to the previous page and fill in a special message in the text box.  Press the button to display the special message.
	__6.  Test the application by submitting several more special messages.  Also use the link again to prove that the default message will still display after a special message has been submitted.
	__7.  Switch back to the terminal window running JBoss.  You should see output messages from the Servlet about what message it is displaying.
	__8.  Leave the web browser open on the home page of the application.

	Part 3 -  Use Administration Console
	__1.  Open a new browser window or tab and enter the following address:
	__2.  Click the link for the 'Administration Console'.
	__3.  Login with the default user of 'admin' and password of 'admin'.
	__4.  In the left navigation, under the group of different types of applications, click the link for "Web Application (WAR)s".
	__5.  On the right side, click the link for the HelloWeb.war.
	__6.  Notice this lists properties like the path to the application file and the context root.
	__7.  Click the Content tab above the list of properties for HelloWeb.war.
	__8.  Notice this is where you could upload an updated version of the application.  The name of the file you upload must be exactly the same as the previous version.
	__9.  Click the Control tab above the list of properties for HelloWeb.war.
	__10.  Click the Stop button to stop the application.
	__11.  Go back to the web browser you were using to test the HelloWeb application and refresh the page.  You will get a 404 error since the application is no longer running.  You would get the same error if you removed the application.
	__12.  Switch back to the Administration Console and press the Start button for the application.
	__13.  Test the application again and verify it responds again.
	__14.  In the left navigation of the Admin Console, click the link for "Enterprise Application (EAR)s".
	__15.  On the right side of the empty list of applications, click the button to "Add a new resource".
	__16.  Click the Browse button and select the file <LAB_FILES>/SimpleApp/HitCount.ear and click Open.
	__17.  Once you have the proper file selected hit the Continue button.
	__18.  After several seconds you should get a message about the application being created and it should be listed.
	__19.  In the left navigation of the Admin Console, click the link for "Embedded Web Application (WAR)s".
	__20.  Click the link on the right for HitCountWeb.war.
	__21.  Notice that the Control tab is not enabled.  If you wanted to stop this application you would need to stop the EAR file.
	__22.  Notice the value of the Context Root is HitCountWeb.
	__23.  Open a new browser window or tab to the following address to access the HitCount application that was installed.
	__24.  Click on the link on the home page of the application to begin a count of hits.
	__25.  Refresh the page several times and you should see the count increasing.

	Part 4 -  Undeploy Application
	__1.  In the left navigation of the Admin Console, click the link for "Enterprise Application (EAR)s".
	__2.  Press the Delete button next to the HitCount.ear application and confirm that you want to delete the resource.
	__3.  You should get a message that the application was successfully deleted.
	__4.  Click the Logout link in the upper right corner of the Admin Console.
	__5.  Open a File Browser window and navigate to the directory <JBOSS_HOME>/server/myconfig/deploy.
	__6.  Delete the HelloWeb.war file from this directory.  This will also undeploy the application.

	Part 5 -  Deploy Using Ant
	__1.  Open a File Browser window and navigate to the directory <LAB_FILES>\SimpleApp.
	__2.  Extract the AntWorkspace.zip file directly to the <LAB_FILES> folder.  Make sure the unzip utility does not create a subdirectory using the name of the zip file.
	__3.  Navigate to the <LAB_FILES>/workspace directory that was created by unzipping the file.  Notice there are two subdirectories.  The JBossAnt directory contains the Ant build that will be run and the config directory contains files that will be copied to JBoss.
	__4.  Open the build.properties file in the JBossAnt directory with a text editor.
	__5.  Check that the values for the first two properties, JBossHome and ConfigWorkspace are correct.  The JBossHome value should be where you extracted JBoss and recorded as <JBOSS_HOME> in a previous lab.  The ConfigWorkspace value should be the 'workspace' directory that was created by unzipping the file in the previous steps.  If you need to change either of these values make sure they match exactly what the path is on the machine.
	__6.  Close the build.properties file and save any changes if you made them.
	__7.  Open the build.xml file with a text editor.
	__8.  Look at the top of the build script.  Notice that the default is to call a target called 'publishSingle'.  There is also a task that will import the build.properties file.
	__9.  Find the 'publishSingle' target.  Notice that this target sets a few properties and then calls the 'genericPublish' target.
	__10.  Find the 'genericPublish' target.  This copies files from the 'config' directory into the JBoss server configuration.  If you did not need to change the build properties this will copy the '/usr/JBoss/LabFiles/workspace/config' directory into '/usr/JBoss/Software/jboss-5.1.0.GA/server/myconfig'.
	__11.  Examine the other targets like 'genericClean', 'genericBackup', and 'rebuildSingle'.  The first two will delete a server configuration and create a zip file of a server configuration respectively.  The 'rebuildSingle' calls the first two, then copies files from the 'default' JBoss configuration, and then calls the 'publishSingle' target.  This will "rebuild" the server configuration from scratch to be sure everything is synchronized.
	__12.  Close the build.xml file when you are done examining it.
	__13.  In the File Browser window, navigate to the <LAB_FILES>/workspace/config/deploy directory. Notice that it contains the HelloWeb.war and HitCount.ear files we deployed earlier.
	__14.  Make sure that the JBoss server is still running in the one terminal window.  Start it if it is not.  Make sure you start the 'myconfig' server configuration.  If you needed to start the server wait until it starts before continuing.
	__15.  Open a second terminal window.
	__16.  Change to the <SOFTWARE_DIR>/apache-ant-1.7.1/bin directory.  You will likely use a command similar to the following:
	__17.  Enter the following command to execute the Ant build.  If your workspace directory is different make the appropriate change.
	__18.  Make sure that you see a message that two files were copied and the build was successful.
	__19.  Leave this terminal window open.
	__20.  Switch to the terminal window running JBoss and you will see many messages about deploying the HelloWeb and HitCount applications.
	__21.  As you have before, use a web browser to test the applications at the following addresses.

	Part 6 -  Rebuild Server Configuration
	__1.  Shutdown the JBoss server in the terminal window.  You can do this by pressing CTRL-C.
	__2.  Return to the terminal window you were using to run Ant.  Open a terminal window to the <SOFTWARE_DIR>/apache-ant-1.7.1/bin directory if you need to.
	__3.  Run the following Ant command.  Notice the difference is the 'rebuildSingle' target name on the end.  Make sure to enter this command on one line even though it wraps to a second line below.
	__4.  Notice there are many more messages but at the end you should see the same message about copying two files and the same BUILD SUCCESSFUL message.
	__5.  If you want you can restart the JBoss server and retest the applications.
	__6.  Close any extra web browsers, File Browser windows, and terminal windows to avoid confusion.

	Part 7 -  Summary

	Lab 4 -  Using Eclipse Tools
	Part 1 -  Open a New Workspace
	__1.  Locate the 'eclipse' executable program in a file browser.  This should be located in the <SOFTWARE_DIR>/eclipse directory.
	__2.  Double-click the 'eclipse' program to launch Eclipse.  The first time you launch the program it may take a minute to display the next dialog.
	__3.  Add a shortcut to the Eclipse program if you want to the desktop as you will be running it in several labs.
	__4.  When prompted, fill in '<LAB_FILES>/workspace' as your workspace.  It is best NOT to check the box for using this as your default workspace as this prompt is difficult to get back if you do.  Press OK when the dialog contains the workspace below.
	__5.  Close the Welcome screen by clicking the X on the welcome tab at the top.

	Part 2 -  Import JBoss XML Definitions Into Workspace
	__1.  In the Eclipse IDE select File -> Import.
	__2.  In the Import wizard expand the General group and select Existing Projects into Workspace.  Press Next to continue.
	__3.  On the next screen, select the radio button next to 'Select archive file'.
	__4.  Press the Browse button next to the archive file box to browse your file system.
	__5.  Locate the file <LAB_FILES>/JBossXML-Galileo.zip where <LAB_FILES> is most likely '/usr/JBoss/LabFiles'.  Once you have selected this file press the OK button in the Select archive... dialog.
	__6.  Check that the JBossXML project is selected for import as shown below and press the Finish button to import the project.
	__7.  Once you finish importing the project into your workspace, expand it as shown below.  The 'dtd' and 'schema' folders contain the same files that are in the 'docs' directory of the JBoss 5.1.0.GA distribution.  If you use a revised JBoss version in the future you may want to update these files to make sure that any changes to XML syntax are detected.

	Part 3 -  Import XML Catalog Entries
	__1.  Expand the JBossXML project in the Project Explorer view.
	__2.  Double click the 'Galileo.xmlcatalog' file to open it.  It should open in an Eclipse text editor.
	__3.  Notice that there are several entries and that each entry refers to a file in the imported project.  The JBoss 5.0 and 5.1 entries are the primary ones we will use and some of the others are commented out as explained below.
	__4.  Close the file.
	__5.  Select File -> Import from the menu.
	__6.  In the Import wizard expand the XML group, select the XML Catalog import type, and press the Next button.
	__7.  Expand the JBossXML project and select the Galileo.xmlcatalog file as shown below.  Press the Finish button.
	__8.  From the menu select Window -> Preferences.
	__9.  Expand XML on the left of the Preferences dialog and select XML Catalog.
	__10.  Expand the User Specified Entries on the XML Catalog preferences page if it is not already.  Be sure you see several JBoss related entries as shown below.  This shows that the Eclipse XML tools are now aware of the XML syntax defined by the DTD and schema files that were imported.
	__11.  Leave the preferences dialog open for the next section.

	Part 4 -  Set Preferences
	__1.  Select Window -> Preferences from the menus if you closed the preferences in the previous section..
	__2.  Expand the General group and select the Workspace category.
	__3.  Check the checkbox for Refresh automatically as shown below.
	__4.  Press OK to accept the new preference.

	Part 5 -  Import the Configuration Files Project
	__1.  In the Eclipse IDE select File -> Import.
	__2.  In the Import wizard expand the General group and select Existing Projects into Workspace.  Press Next to continue.
	__3.  On the next screen, select the radio button next to 'Select root directory'.
	__4.  Press the Browse button next to the root directory box to browse your file system.
	__5.  Select '<LAB_FILES>/workspace' as your root folder and press the OK button in the Browse for Folder dialog.
	__6.  Make sure that the 'config' and 'JBossAnt' projects are selected to be imported and press the Finish button.  You can ignore any warning.
	__7.  Expand the two new projects that were imported into the workspace.  Notice that these have the same files as you worked with outside of Eclipse.  One project has all of the custom files to copy to the JBoss configuration and the other project is the Ant build that can automate the configuration management.

	Part 6 -  Execute Ant Build in Eclipse
	__1.  Select Window -> Show View -> Other.  
	__2.  From the dialog that appears expand the Ant group and select the Ant view.  Press the OK button.  This will add the Ant view which we will use to run Ant builds.
	__3.  The Ant view will most likely show up in the group of tabs at the bottom.  Click and hold on the tab of this view and drag towards the group on the upper right so it is in a more vertical orientation.  Release the mouse once the gray outline shows the view in a good location.
	__4.  Check that the view is in a more vertical orientation and perhaps grouped with other vertical views on the upper right.  If the view ends up in a location you don't want simply move it again.
	__5.  In the Ant view on the right side of the workspace click the flashlight search icon to bring up the Search for Buildfiles dialog.  You may need to select the Ant view titlebar to display it.
	__6.  Leave the default buildfile name of 'build.xml' and press the Search button.  
	__7.  You should find the 'JBossDeployUtil' Ant build with the targets discussed in the previous lab. Expand it.
	__8.  In the Ant view select the JBossDeployUtil buildfile by clicking on it.
	__9.  Press the green "Run" button in the toolbar of the Ant view.  It may take several seconds to launch the build.
	__10.  Examine the Console view to see the results of the build.  You will see the names of the tasks and what order they were called in.  Most notably look for the BUILD SUCCESSFUL message at the end of the output.  
	__11.  Make sure you do not have any terminal windows running the JBoss server and stop the server if you do.
	__12.  In the Ant view, expand the 'JBossDeployUtil' build and select the 'rebuildSingle' target.
	__13.  Press the green "Run" button in the toolbar of the Ant view.  This will run the 'rebuildSingle' target which is not the default target.
	__14.  Once the build is complete look in the Console view again and see that you see the same sequence of Ant tasks that rebuilt the server configuration from scratch as when you ran it outside of Eclipse.
	__15.  If you want you can start your JBoss server and retest the HelloWeb and HitCountWeb applications.

	Part 7 -  Summary

	Lab 5 -  Build Application from Eclipse IDE
	Part 1 -  Import Application Resources
	__1.  Open Eclipse if it is not already open.
	__2.  Select File -> Import from the menus.
	__3.  In the Import wizard expand the General group and select Existing Projects into Workspace.  Press Next to continue.
	__4.  On the next screen, select the radio button next to 'Select archive file'.
	__5.  Press the Browse button next to the archive file box to browse your file system.
	__6.  Locate the file <LAB_FILES>/BuildApp/OnlineStore.zip.  Once you have selected this file press the OK button in the Select archive... dialog.
	__7.  Check that the three OnlineStore projects are selected for import as shown below and press the Finish button to import the projects.
	__8.  Once you finish importing the projects into your workspace, expand them as shown below.  Notice that each project has an Ant build file that will package that part of the application.  The build in the 'OnlineStore' project will package everything into an EAR file.
	__9.  Open the build.xml file in the OnlineStore project by double-clicking it.
	__10.  Notice the file has targets for building and "exporting" the EAR file.  This build will call builds in the other projects.
	__11.  Close the editor and make sure you haven't made any changes.
	__12.  Open the build.properties file in the OnlineStore project.
	__13.  Switch to the build.properties tab at the bottom of the editor that opens.
	__14.  Notice that the 'earExportLocation' property will copy the final EAR file into the correct location in the 'config' project for export to JBoss.
	__15.  Close the build.properties file.

	Part 2 -  Build OnlineStore Using Ant
	__1.  In the Ant view on the right side of the workspace click the flashlight search icon to bring up the Search for Buildfiles dialog.  You may need to select the Ant view titlebar to display it.
	__2.  Leave the default buildfile name of 'build.xml' and press the Search button.  There should be one file found in each of the projects and displayed in the Ant view as shown below.  You can also expand the buildfiles to see some of the targets in each.
	__3.  In the Ant view select the OnlineStore buildfile by clicking on it.
	__4.  Press the green "Run" button in the toolbar of the Ant view.
	__5.  Examine the Console view to see the results of the build.  You will see the names of the tasks and what order they were called in.  Most notably look for the BUILD SUCCESSFUL message at the end of the output.
	__6.  Expand the OnlineStore and modules folders in the Project Explorer view.  You will see the EAR file and the two modules that were built by the buildfile tasks.
	__7.  Expand the 'deploy' folder in the 'config' project.  You should see the OnlineStore.ear file was copied there as well.

	Part 3 -  Test the OnlineStore Application
	__1.  Open a terminal window and start your JBoss server as you have done before.  Make sure you start the 'myconfig' configuration with the '-c myconfig' option.
	__2.  Wait for the server to start completely.  Near the end of the output you should see messages about deploying the previous applications.
	__3.  Back in Eclipse, in the Ant view select the JBossDeployUtil buildfile by clicking on it.
	__4.  Press the green "Run" button in the toolbar of the Ant view.
	__5.  Examine the Console view to see the results of the build.  You should see a message about copying one file to the JBoss configuration.  This is the new OnlineStore.ear file.
	__6.  Switch back to the terminal window running JBoss and you can look at the various messages about deploying the OnlineStore application.  You should also see a message from the 'TomcatDeployer' about deploying the web application to a content root of '/Store' as shown below.  If you get any Exceptions related to deploying the application notify your instructor.
	__7.  Open a web browser and enter http://localhost:8080/Store in the address bar.  You should get the homepage of the application.
	__8.  Try to click the link to "Browse Products".  You should get an error about needing to be logged in first.
	__9.  Click the link to "Login Here" and attempt to login using any id.  
	__10.  You should get an error that says "No Customer exists with that email".
	__11.  Click the link to "Register", fill in the form, and press the button to Register.  
	__12.  You should get a message about being registered and a link to "Start shopping".
	__13.  Test the rest of the features of the application by browsing products, placing products in your cart, removing items from your cart, and completing purchases.  You can also use the "Find Purchases" link to locate purchases made after you have completed purchases.
	__14.  Test the application to become familiar with the features.  This application will be used extensively in the rest of the labs.
	__15.  Click the Logout link at the top of the page and close the browser.
	__16.  Stop the JBoss server in the terminal window once you are done testing the application.

	Part 4 -  Summary

	Lab 6 -  Connect to External Database
	Part 1 -  Examine Hypersonic Database
	__1.  If it is not running, start your 'myconfig' JBoss server from a terminal window.
	__2.  Open a web browser and go to http://localhost:8080/jmx-console/ in the address bar.
	__3.  In the ObjectName Filter text box enter "*:service=Hypersonic,*" without the quotes and press the ApplyFilter button.
	__4.  Click the link for the Hypersonic MBean.
	__5.  Scroll down until you see the startDatabaseManager operation and press the Invoke button.  Wait a second while the database manager starts.  It starts in a separate window that you may need to select in the taskbar to bring to the front.
	__6.  On the left side examine the tables that are in the database.  Among others you should see CUSTOMER, LINEITEM, PRODUCT, and PURCHASE tables.  Because the OnlineStore application uses JPA, or Java Persistence, these tables have been created automatically by JBoss to manage the data from our persisted Java classes.
	__7.  In the blank area in the upper right enter the following SQL command.
	__8.  Press the Execute SQL button from the toolbar.  You should see a list of the various purchases you have made so far.
	__9.  Select the File -> Exit command to shutdown the database manager.
	__10.  Close the web browser you were using for the JMX Console.
	__11.  Stop your server in the terminal window.

	Part 2 -  Create OnlineStore Database
	__1.  Open a terminal window.  Use a new terminal window rather than one you have used to start JBoss to simplify things.
	__2.  Issue the following command which assumes your <LAB_FILES> directory is '/usr/JBoss/LabFiles'.
	__3.  Enter a password of 'root123' when prompted.  You will not get any other message and will simply be returned to the terminal window.
	__4.  Validate the database creation by entering the following command.  This will attempt to connect to MySQL using the user created by the previous command.
	__5.  Enter a password of 'dbpassword' when prompted.
	__6.  Issue the following command to attempt to switch to the database created and check permissions on the database.
	__7.  After verifying there are no errors switching to the new database issue the command to quit.
	__8.  Close the terminal window.

	Part 3 -  Import JDBC Drivers
	__1.  Open Eclipse in the workspace directory if it is not already.
	__2.  In the Project Explorer view select the config project by clicking on it.
	__3.  Right-click the config project and select New -> Folder from the popup menu.
	__4.  Fill in the Folder name of 'lib' without the quotes and press the Finish button.
	__5.  Open a File Browser window and navigate to the <SOFTWARE_DIR>/Downloads/MySQL folder.
	__6.  Copy the mysql-connector-java-5.0.8-bin.jar file.
	__7.  Return to the Eclipse workspace.
	__8.  Select the newly created lib folder by clicking on it.
	__9.  Paste the file into the lib folder.
	__10.  Expand the lib folder and check that the file was copied to the folder.
	__11.  Make sure your JBoss server is stopped.  This is important because the contents of the 'lib' directory are not immediately available to a server that is already running.  We must restart the server to pick up the new file.
	__12.  In the Ant view select the JBossDeployUtil buildfile by clicking on it.
	__13.  Press the green "Run" button in the toolbar of the Ant view.
	__14.  Examine the Console view to see the results of the build.  You should see a message about copying one file to the JBoss configuration.  This is the file with the JDBC drivers.

	Part 4 -  Check the Availability of the JDBC Driver
	__1.  Switch to a terminal window and start your JBoss server.  If it is already running you must stop it and restart it.  Restarting is required because the lib directory (where you just exported the driver) is only scanned on server startup.
	__2.  Open a web browser and go to http://localhost:8080/jmx-console/ in the address bar.
	__3.  In the ObjectName Filter text box enter "jboss.classloader:*" without the quotes and press the ApplyFilter button.
	__4.  Click the first link for the DefaultDomain MBean.
	__5.  Scroll down through the attributes displayed until you reach the operations section.
	__6.  Find the findClassLoaderForClass operation.  Fill in com.mysql.jdbc.Driver for the only parameter.  This value would be different for different databases.
	__7.  Press the Invoke button and be sure you get the response below.  Since a classloader is listed, this means the class can be found.
	If the class can't be found you will not get any error message.  You will get the message "Operation completed successfully without a return value".  If this happens be sure you have imported the JDBC driver file to the correct location in the project and exported the configuration properly.
	__8.  Close the web browser used for the JMX Console.

	Part 5 -  Create Data Source Configuration
	__1.  Open a File Browser window and navigate to the <JBOSS_HOME>\docs\examples\jca directory.
	__2.  Copy the mysql-ds.xml file being careful not to select any of the mssql-* files as these are for Microsoft SQL Server.
	__3.  Return to the Eclipse workspace.
	__4.  In the Project Explorer view expand the config project and select the deploy directory.
	__5.  Paste the file into the deploy folder.
	__6.  Expand the deploy folder and check that the file was copied to the folder.
	__7.  Double-click the mysql-ds.xml file to open it in the XML editor and select the Design tab at the bottom of the editor.
	__8.  Right click near the top of the XML file and select Add DTD Information...
	__9.  Press the first Browse button by the Public ID value.
	__10.  Scroll down and select the 'JBoss JCA Congif 5.0' entry and press the OK button.
	__11.  Press the OK button back in the DTD information dialog.
	__12.  Expand the various tags of the XML file by clicking the '+' signs next to each tag that has one.
	__13.  Once you can see all of the tags, click in the right column next to the following tags and change the values to what is listed:
	__14.  After changing the last value click somewhere else in the file to be sure the last value has been changed.  
	__15.  Be sure the file appears as below.
	__16.  Save and close the file.
	__17.  Right click on the mysql-ds.xml file in the Project Explorer view and select Validate.  You should get a message about validation completing with no errors or warnings. Click OK.
	__18.  Make sure your JBoss server is running and start it if it is not.  Wait for it to start completely if it was not running.
	__19.  Export the database configuration file by running the JBossDeployUtil build from the Ant view.  You should get a message in the console that one file was copied.
	__20.  Look in the terminal window running the JBoss server and notice the message below about the "ConnectionManager" for the Data Source being "bound" to a JNDI name.

	Part 6 -  View Data Source Configuration in Admin Console
	__1.  Open a new browser window or tab and enter the following address:
	__2.  Click the link for the 'Administration Console'.
	__3.  Login with the default user of 'admin' and password of 'admin'.
	__4.  In the left navigation, under the group of different types of resources, click the link for "Datasources".
	__5.  In the list of data sources on the right, click the link for the 'jdbc/store' data source.
	__6.  Click the Configuration tab above the list of data source properties.
	__7.  Notice the various configuration properties.  Although these are shown for this data source you should NOT make any changes here because this data source was configured through a '-ds.xml' file.
	__8.  In the left navigation expand the Datasources folder until you can see the types of data sources and click the link for Local Tx Datasources.
	__9.  On the right, above the list of data sources, click the Add a new resource button.
	__10.  Do not do so now, but notice you could select a template and continue to fill in all of the configuration properties of a data source similar to the configuration screen you already saw.
	__11.  Click the Cancel button to avoid creating a new data source configuration.
	__12.  Close the browser for the Admin Console.

	Part 7 -  Configure Application to use Data Source
	__1.  In the Project Explorer view of Eclipse expand the OnlineStoreEJB project and the build\classes\META-INF directories.
	__2.  Double click on the persistence.xml file to open it.
	__3.  Look for the element which defines the 'jta-data-source'.
	__4.  Change the value within this element to 'java:/jdbc/store' without the quotes as shown below.
	__5.  Save and close the file after double-checking the jta-data-source property value.
	__6.  In the Ant view on the right side of the workspace, select the OnlineStore buildfile by clicking on it.
	__7.  Press the green "Run" button in the toolbar of the Ant view.
	__8.  Examine the Console view to see the results of the build.  Make sure you see the BUILD SUCCESSFUL message at the end of the output.

	Part 8 -  Export and Test Application
	__1.  Check that your JBoss server is running in a terminal window.  Start it if it is not.
	__2.  Back in Eclipse, in the Ant view select and run the JBossDeployUtil buildfile.
	__3.  Switch to the terminal window running JBoss and look at the many messages about deploying the new version of the OnlineStore application.  If you scroll backwards you should be able to find messages about using the new MySQL data source.
	__4.  Check that the 'TomcatDeployment' service deploys the /Store application.  This should be the last message displayed.
	__5.  Open a web browser to http://localhost:8080/Store and test the application.  Because the database has been switched you will need to register again before using the other functions of the application.  Be sure you test all the functions of the applications including adding and removing items from your cart, completing a purchase, and displaying purchases for a customer.
	__6.  Close the web browser.
	__7.  Open a terminal window.  
	__8.  Enter the following command to connect to MySQL.
	__9.  Enter a password of 'dbpassword' when prompted.
	__10.  Issue the following command to switch to the database used with the OnlineStore application.
	__11.  Issue the following commands to view what tables are part of the database and see some of the data stored in the tables.  The names of the tables are case sensitive so be sure to capitalize the table names.
	__12.  After viewing some of the data issue the command to quit.
	__13.  Close the terminal window.
	__14.  Switch to the terminal window running JBoss and stop your server.

	Part 9 -  Summary

	Lab 7 -  JBoss Logging
	Part 1 -  Modify the Log Configuration Refresh Frequency
	__1.  If your JBoss server is still running, switch to the terminal window running it and stop it.
	__2.  Open Eclipse in the workspace directory if it is not already.
	__3.  In the Project Explorer view select the config project by clicking on it.
	__4.  Right-click the config project and select New -> Folder from the popup menu.
	__5.  Fill in the Folder name of 'conf' without the quotes and press the Finish button.
	__6.  Open a File Browser window and navigate to the <JBOSS_HOME>/server/myconfig/conf folder.
	__7.  Copy the jboss-service.xml file.
	__8.  Return to the Eclipse workspace.
	__9.  Select the newly created conf folder by clicking on it.
	__10.  Paste the file into the conf folder.
	__11.  Expand the conf folder and check that the file was copied to the folder.
	__12.  Open the jboss-service.xml file in an editor by double-clicking it.
	__13.  Switch to the Source tab in the editor if it is not already selected.
	__14.  Search for the mbean tag which configures the Log4jService.  This should be about 1/4 of the way down the file.
	__15.  Look for the RefreshPeriod attribute and change the value to 5 as shown below.  Also note the ConfigurationURL attribute.  This points to a jboss-log4j.xml file which we will import in the next part.
	__16.  Save and close the file.
	__17.  In the Ant view select and run the JBossDeployUtil buildfile.  This will export the new log refresh configuration.  You should get a message about copying one file.
	__18.  Switch to a terminal window and start your server.  If the server was already running be sure to stop it then restart it to pick up the change.  Make sure the server starts with no errors.

	Part 2 -  Import Current Logging Settings
	__1.  Open a File Browser window or use one already open and navigate to the <JBOSS_HOME>/server/myconfig/conf folder.
	__2.  Copy the jboss-log4j.xml file.
	__3.  Return to the Eclipse workspace.
	__4.  Select the newly created conf folder by clicking on it.
	__5.  Paste the file into the conf folder.
	__6.  Be sure the jboss-log4j.xml file was imported to the conf directory as shown below.
	__7.  Open the jboss-log4j.xml file in an editor by double-clicking it.
	__8.  Be sure you have the Source tab selected along the bottom of the editor.
	__9.  Scroll down the file until you find the first appender tag.  This should have a name of "FILE" as shown below.  Notice the name of the file mentioned is server.log.
	__10.  In a File Browser window, navigate to the following directory:
	__11.  Open the server.log file with a text editor.  You may need to try a few programs to open the file as some may not want to open the file while the server is running.
	__12.  Near the bottom of the log file you should see the message that the server "Started in xxs:xxms".  This is the last message from when you just restarted the server.
	__13.  Search through the log for the phrase "shutdown complete".  There may be a few services that use this phrase on shutdown but you should be able to look at the timestamps and see that the server is restarting after these messages are printed out.  This proves that the default setting appends to the current log file.
	__14.  Close the text editor.

	Part 3 -  Change Log Threshold
	__1.  While your server is still running return to the terminal window running the server.  Notice there are lots of INFO messages about starting the applications and server.
	__2.  Open a web browser and go to http://localhost:8080/Store for the homepage of the OnlineStore application.
	__3.  Click the link to Login and attempt to login with a user you know does not exist.  You should get an error in the browser that says "No Customer exists with that email".
	__4.  Return to the terminal window running the server.  Notice there are many error messages being printed out.  Scroll up until you see the messages below.  The easiest thing to look for is where the lines stop using the 'at ...' as the first word on the line and are not displayed with a tab space.  Notice there is an ERROR message from the 'LoginServlet' which says "Error during Customer lookup".  Immediately after that is the error message you saw in the browser "No Customer exists with that email".
	__5.  Open a File Browser window, navigate to the <LAB_FILES>/Logging directory, and open the file LoginServlet.java with a text editor.
	__6.  Find the doPost method in the Servlet.  This is the method that processes the login submission.
	__7.  Notice that the error message that was printed is in a section of the code that "caught" an Exception.  Notice that before "throwing" another Exception (a ServletException) the code calls the error method on the logger to log the error.  This is why the message showed up with an ERROR level in the Console, the code indicated it was an error message by calling this method.  Since we know the Customer did not exist the Exception must have occurred during the 'lookupCustomer' method.  Before that method was called there should have been a "debug" message of "Login for Customer: xx" because the debug method of the logger is called the line before.
	__8.  Close the text editor with the servlet code.
	__9.  Let's see if we can find the "debug" message that is generated.  Return to the terminal window running the server and scroll up until you reach the beginning of the ERROR and WARN messages.  This is where we would expect to see a DEBUG message but notice the previous message was the INFO message about the server starting.
	__10.  Switch to the Eclipse editor which shows the jboss-log4j.xml file or double-click the file to open it up in the editor again.
	__11.  Search the file for the "CONSOLE" appender configuration tag.  Note the Threshold parameter which has a value of INFO.  This means that no matter what kind of messages are generated they will only get appended to the Console output if they are of the level INFO and above.  This would include FATAL, ERROR, WARN, and INFO messages.
	__12.  Change the value of the Threshold parameter to WARN.
	__13.  Save the file.
	__14.  Scroll down to the bottom of the file and look for the <root> category.  The priority of this root logging category can be set with a system property.
	__15.  In the Ant view select and run the JBossDeployUtil buildfile.  This will export the new log configuration.  You should get a message about copying one file.
	__16.  Return to the terminal window running the server.
	__17.  Shutdown your server.  Note that as you stop the server you will not see the same number of messages as before.  In fact, it may be tough to tell that you issued a command to stop the server until you get the "Shutdown complete" message after several seconds.
	__18.  Start the server with the following command.  This will dynamically set the root logging threshold from the startup command.  Make sure there is not a space after the '-D' option before the name of the property.
	__19.  Note the terminal window running the server does not display as many messages. Once the JBoss server configures the Log4jService the INFO messages stop.  This is because the rest of the INFO messages do not meet the Threshold criterion of WARN that you just set.  You only get a few WARN messages from internal JBoss code.
	__20.  After waiting a minute or two to make sure the server is running, open the server.log file in a text editor.  You should be able to see a message near the bottom that the server is indeed started.  You will also see many DEBUG messages that are now shown because the threshold is now set to DEBUG and the server.log file will use this threshold.
	__21.  Close the text editor showing the log file.
	__22.  Return to the web browser you were using to test the OnlineStore application. Open a new one at http://localhost:8080/Store if you had closed it.
	__23.  Click the Login link again.
	__24.  Try to login with an ID that does not exist.
	__25.  In the terminal window running the server you should still see the ERROR messages being printed out because they are still above the Threshold of WARN.
	__26.  Open the server.log file with a text editor.
	__27.  Maximize the text editor to give yourself plenty of room to look through the log file.
	__28.  Search for the text "login for customer" in the log file.  Since this may appear several times it might be best to start searching backwards from the bottom.  You should be able to find the message with the incorrect id you entered.
	__29.  Close the file.
	__30.  In the editor for the jboss-log4j.xml file change the Threshold parameter of the "CONSOLE" appender back to INFO.
	__31.  Save the file.
	__32.  In the Ant view select and run the JBossDeployUtil buildfile.  This will export the new log configuration.  You should get a message about copying one file.
	__33.  Stop the server.
	__34.  Restart the server to prove that INFO messages are once again output to the Console.  This time when you start the server do not use the system property.

	Part 4 -  Modify Log Format
	__1.  Open the server.log file.  Notice that the time stamp, message priority, and the log category which generates the message are nicely aligned.  The message itself is not well aligned because the log category varies in length.  We will add formatting to make the log category the same length which will align the messages.
	__2.  Close the server.log file.
	__3.  Switch to the Eclipse editor for the jboss-log4j.xml file.  Open the file if you closed the editor.
	__4.  Find the "FILE" appender configuration tag.  
	__5.  Locate the layout portion of the configuration which uses the org.apache.log4j.PatternLayout.
	__6.  Alter the category and thread configuration by changing the value as shown below.
	__7.  Save the file.
	__8.  In the Ant view select and run the JBossDeployUtil buildfile.
	__9.  Restart the server to see the effect of the new format.  
	__10.  Open the server.log file and scroll to the bottom.  You may want to disable text wrapping to best see the alignment.  You should now see that the messages are aligned and the log category and thread info are truncated or padded to be uniform lengths.
	__11.  Close the server log.
	__12.  In the terminal window running the server notice that the log messages only output the time of the message and not the date.  In a real JBoss environment the date would also be useful in case we are looking for messages that did not occur today.  The server.log file does output the date but we will change the Console output to show you the options available.
	__13.  In the jboss-log4j.xml file look at the ConversionPattern property of the "CONSOLE" appender and the format around the lowercase 'd'.  This uses the {ABSOLUTE} format which is described by the class 'org.apache.log4j.helpers.AbsoluteTimeDateFormat' and only includes the time.
	__14.  Change the formatting of the date to be '%d{ISO8601}' as shown below.  This will include the date as described by the class 'org.apache.log4j.helpers.ISO8601DateFormat' in a YYYY-mm-dd format.  Also change the category configuration to add '-20.20' without the quotes to make the category in the console output uniform.
	__15.  Save the file.
	__16.  In the Ant view, select and run the JBossDeployUtil buildfile.
	__17.  Restart the server to see the effect of the new format.  
	__18.  In the terminal window you should now see that the date is output as part of the time stamp.  Notice also that the categories are the same length although the line wrapping of the terminal window might confuse things.

	Part 5 -  Create Application Specific Log File
	__1.  Switch to the editor for the jboss-log4j.xml file or open it if it is not already.
	__2.  Find the appender configuration tag for the "FILE" appender.  We will copy this tag as the starting point.
	__3.  Select and copy the entire appender tag.  Be sure you do not copy the beginning or end of any comments that may be just outside of the tag and only copy the content between and including the <appender> and </appender> tags.
	__4.  Place the cursor immediately after the end of the </appender> tag.  Be sure it is not on a line that is within a comment (<!--  -->).
	__5.  Paste the appender tag you copied from the previous step.  Be sure it shows up with several colors and not all blue.  If it is all blue you have pasted it within a comment and it will not be read as part of the configuration.
	__6.  Change the name of the appender to STORE.  Also change the value of the File parameter to store.log.  Both of these changes are shown below.
	__7.  Scroll down the jboss-log4j.xml file and find the comment about "Limit categories".  All the category configuration must occur after all the appender configuration.  Look at some of the other category configurations.
	__8.  Place the cursor immediately after the end of the comment tags which begin the category section.  Be sure it is not on a line that is within a comment (<!--  -->).
	__9.  Add the category tag as shown below.  Notice the category tag has a separate start tag and end tag but the priority and appender-ref tags end with just the '/>' in the same tag.
	__10.  Save the file.
	__11.  In the Ant view select and run the JBossDeployUtil buildfile.
	__12.  Open a web browser to http://localhost:8080/Store and login with an existing user.
	__13.  Add some items to your cart, complete a purchase, and then logout.
	__14.  Open a File Browser window and navigate to the directory <JBOSS_HOME>\server\myconfig\log.
	__15.  Open the store.log file with a text editor.
	__16.  You should see some DEBUG and INFO messages in the log indicating the user logged in, added items to their cart, completed a purchase, and then logged out.
	__17.  Close the program you are using to view the log file.
	__18.  Return to the terminal window running the server.  Notice the INFO messages are also being printed out to the Console.  If you were to open the server.log file you would see the INFO messages there as well.
	__19.  Return to your category configuration in the jboss-log4j.xml editor.
	__20.  Add the additivity attribute with a value of false as shown below.
	__21.  Save the file.
	__22.  In the Ant view select and run the JBossDeployUtil buildfile.
	__23.  In the terminal window running the server, take note of the last message that was printed.
	__24.  In the web browser for the OnlineStore, login with an existing ID, put some items in your cart, complete a purchase, and then log out.  These are the same actions you took before.
	__25.  Look at the terminal window running the server and notice that none of the messages you saw before are printed out.  You should still see the last message that was printed.

	Part 6 -  Adjust Log Level From JMX Console
	__1.  Go to the terminal window running JBoss and stop the server.
	__2.  Open a File Browser window and navigate to the directory <JBOSS_HOME>/server/myconfig/log.
	__3.  Delete the store.log file from the log directory.
	__4.  Return to the terminal window and start your server.
	__5.  Open a web browser to http://localhost:8080/Store and login with an existing user.
	__6.  Add some items to your cart, complete a purchase, and then logout.
	__7.  Open the store.log file with a text editor.  You should see the same mix of DEBUG and INFO messages as before.  Take note of the time of the last message.
	__8.  Close the program you are using to view the log file.
	__9.  Open another web browser and go to http://localhost:8080/jmx-console/ in the address bar.
	__10.  In the ObjectName Filter text box enter "*:service=Logging,*" without the quotes and press the ApplyFilter button.
	__11.  Click the link for the Log4jService MBean.
	__12.  Scroll down until you can see the getLoggerLevel method.
	__13.  Fill in a value of com.myhost and press the Invoke button.
	__14.  You should see that the current level is DEBUG.  This is what is set in the jboss-log4j.xml file.
	__15.  Go back to the previous page.
	__16.  Scroll down to the setLoggerLevel method.
	__17.  Fill in the following values and press the Invoke button:
	logger:	com.myhost
	level:	INFO
	__18.  Return to the web browser you were using to test the OnlineStore application and perform the same steps.  Login as an existing ID, put a few items in your cart, complete a purchase, and logout.
	__19.  Open the store.log file again from the server log directory.  Notice that the messages printed since the last time you looked at the file are all INFO messages because the log level has changed.
	__20.  Close any extra web browsers and File Browser windows.  Also close the editor for the jboss-log4j.xml file.

	Part 7 -  Configure HTTP Access Logs (Optional)
	__1.  Stop your JBoss server.
	__2.  In the Project Explorer view select the config → deploy folder by clicking on it.
	__3.  Right-click the deploy folder and select New -> Folder from the popup menu.
	__4.  Fill in the Folder name of 'jbossweb.sar' without the quotes and press the Finish button.
	__5.  Open a File Browser window and navigate to the <JBOSS_HOME>/server/myconfig/deploy/jbossweb.sar folder.
	__6.  Copy the server.xml file.
	__7.  Return to the Eclipse workspace.
	__8.  Select the newly created jbossweb.sar folder by clicking on it.
	__9.  Paste the file into the jbossweb.sar folder.
	__10.  Expand the jbossweb.sar folder and check that the file was copied to the folder.
	__11.  Double-click the server.xml file to open it in an editor.
	__12.  Scroll down about halfway down the file until you find the Access logger comment.
	__13.  Remove the comments (<!--  -->) around the Valve tag so it is not commented out any more.  Be sure to remove the ending comment tag also.
	__14.  Save the file.
	__15.  In the Project Explorer view select the server.xml file.
	__16.  Right-click the server.xml file and select Validate from the popup menu.  You will get a warning because there is no XML syntax associated with the file but make sure you don't get an error. Click OK.
	__17.  In the Ant view select and run the JBossDeployUtil buildfile.
	__18.  Start the server.  If it was already running, stop and restart it.
	__19.  When the server is started open a web browser to http://localhost:8080/Store
	__20.  Login as an existing user, add items to your cart, complete a purchase, and logout.  This will generate some "normal" requests in the access log.
	__21.  Enter the following URL in the browser to generate a '404' error.
	http://localhost:8080/Store/Bogus
	__22.  Stop the JBoss server.
	__23.  Open a File Browser window and navigate to the directory <JBOSS_HOME>/server/myconfig/log.
	__24.  Open the file localhost_access_log.YYYY-mm-dd file where the YYYY-mm-dd is the current date.
	__25.  You will see several entries for the normal requests that you submitted.  Besides the regular requests to login, display the cart, complete a purchase and logout you may see several requests to download images.  Notice that all of these have a '200' or '304' as the second to last number.  This indicates the requests were completed successfully as '200' is the HTTP code for OK and '304' is the code for unmodifed resources (for caching).  The last entry is for "GET /Store/Bogus ...".  This is for the request that generated the error.  Notice the status code of '404' as the second to last number on this line.  This is the code for 'Not Found'. Note:  You may not see some of the requests for the images if your browser is caching the images.

	Part 8 -  Summary
	IMPORTANT:  Remember that the only reason we are able to see application specific log messages and direct application log output to a separate file is because the code uses the Log4j methods to generate the messages.  If the code did not do this nothing we can configure would capture application specific log messages.


	Lab 8 -  Advanced Troubleshooting
	Part 1 -  Run Chainsaw
	__1.  Open a terminal prompt and switch to the <SOFTWARE_DIR>/chainsaw directory.
	__2.  Run the following command to start Chainsaw.  Leave this terminal window open throughout the lab or Chainsaw may exit.
	__3.  After starting Chainsaw, if you see a prompt about running a "newer version" just hit the No button to ignore it.
	__4.  After dismissing the release notes prompt if you get it you should see a warning about not having any receivers defined.  Select the option for 'Let me use a simple Receiver: SocketReceiver' and change the port in the drop-down to 4560.
	__5.  Once your settings are as shown above hit the OK button.
	__6.  Check on the right side of the window to be sure the new receiver is listed.
	__7.  Hide the Receivers info by selecting View → Show Receivers from the menu.  This will deselect the option and hide the view.
	__8.  You might want to maximize or expand the window a bit if it opens fairly small.

	Part 2 -  Configure JBoss
	__1.  Stop your JBoss server if it is currently running.  This will give us a chance to see lots of log messages in Chainsaw when it is restarted later.
	__2.  Open your Eclipse workspace if it is not already running.
	__3.  Open the config → conf → jboss-log4j.xml file in an editor by double-clicking it.
	__4.  Switch to the Source view if you are not already.
	__5.  Within the root <log4j:configuration ..> tag add the following new "Appender as shown by the bold code below.  Make sure you do not add this within another tag or in a comment by accident.
	__6.  Make sure your file is similar to that shown below and save the file.  Don't close the file yet though.
	__7.  Scroll about 2/3 of the way through the file and add the following appender reference to the 'com.myhost' category as shown in bold.
	__8.  Find the 'root' category at the bottom of the file and add the same appender reference as shown below.
	__9.  Save and close the file.
	__10.  In the Ant view select and run the JBossDeployUtil buildfile.  This will export the new log configuration.  You should get a message about copying one file.

	Part 3 -  Monitor Log Entries in Chainsaw
	__1.  Make sure Chainsaw is still running from part one of this lab.  Start it according to those instructions if it is not.
	__2.  If you do not already have one, open a terminal window to the <JBOSS_HOME>/bin directory.
	__3.  Issue the command to start your JBoss server making sure to use your custom configuration.
	__4.  Bring the Chainsaw window to the front.
	__5.  After several seconds you should see a new tab appear with the hostname of the virtual image.  Click on this tab.
	__6.  Watch the various log messages be posted to Chainsaw as the server starts up.
	__7.  Wait a minute or two and finally, after a few hundred log messages you should see the message that the JBoss microcontainer started in X:XX.
	__8.  Use the drop-down for Refine focus on to select 'LEVEL >= WARN'.
	__9.  You should see that all but a few messages are filtered out.  Click on one of the messages and look at the details below.
	__10.  Open up a web browser and go to the URL of the OnlineStore application.
	__11.  Try to login with a customer ID you know doesn't exist.  Remember that this should create an error message from the application.
	__12.  Return to the Chainsaw window and you should see LOTs of error messages. Select the second to last one in the list as shown below.
	__13.  Scroll down in the lower section until you can see the "Properties" section and you should see the "No Customer exists with that email" message you have seen before.
	__14.  Go back to the list of all messages by simply selecting and clearing the entire expression in the 'Refine focus on' box.  When it is clear as shown below you should see INFO messages again also.
	__15.  Return to the browser you were using to test.
	__16.  Login as a valid user and perform some of the other application functions like browsing for products, placing items in your cart, and completing purchases.
	__17.  Return to the Chainsaw window.
	__18.  On the left, expand Root Logger → com → myhost → servlet.
	__19.  Select each individual Servlet and notice that Chainsaw will highlight the messages from that Servlet but leave the entire list of messages visible.
	__20.  On the left, right click on myhost and select 'Focus on com.myhost'.
	__21.  Click myhost on the left. Notice that now the list of messages is shorter and only includes messages directly from the application.  In particular notice that there is now also just one error message for the bad login attempt.
	__22.  Close Chainsaw by selecting File → Exit and confirm you want to exit.
	__23.  Close the browser used to test the application.
	__24.  Stop your JBoss server.
	__25.  Return to your Eclipse workspace.
	__26.  Open the config → conf → jboss-log4j.xml file in an editor by double-clicking it.
	__27.  Find the Chainsaw appender at the top of the file and comment it out as shown below in bold.  Note that when you start a comment Eclipse will try to end it on the same line so you will have to delete the end of the comment Eclipse tries to add so you can end it after the entire appender.
	__28.  Save and close the file.
	__29.  In the Ant view select and run the JBossDeployUtil buildfile.  This will export the new log configuration.  You should get a message about copying one file.

	Part 4 -  Run JBoss in Debug Mode
	__1.  Open a File Browser to the <JBOSS_HOME>/bin directory.
	__2.  Open the run.conf file in a text editor.
	__3.  Go to the bottom of the file and remove the '#' character from the start of the first lines that set the 'JAVA_OPTS' variable.  Make sure it is the line for the remote socket debugging.
	__4.  Save and close the file.
	__5.  If you do not already have one, open a terminal window to the <JBOSS_HOME>/bin directory.
	__6.  Issue the command to start your JBoss server making sure to use your custom configuration.

	Part 5 -  Import Source and Create Debug Configuration
	__1.  Switch back to your Eclipse workspace.
	__2.  From the Eclipse menus select File → Import.
	__3.  Expand Java EE, select EAR file and then press the Next button.
	__4.  Use the Browse button and select the following file:
	__5.  Once the import options appear as shown below press the Finish button.
	__6.  In the new projects that are created expand the SampleApps-OnlineStoreWeb‑JBoss → Java Resources: src → com.myhost.servlet folders.
	__7.  Double click the CartDisplayServlet.java file to open it.
	__8.  Scroll down and find the 'doPost' method.
	__9.  Double click in the narrow gray margin directly to the left of the first line of code in the method with the "if" statement.  There should be a dot in the margin to indicate that a breakpoint is set. Note. You may see in your new projects some errors, this is because the projects are not compile. This is fine for now.
	__10.   Select Window → Open Perspective → Debug from the Eclipse menus.
	__11.  Select Run → Debug Configurations... from the Eclipse menus.
	__12.  From the type of configurations on the left, right click Remote Java Application and select New.
	__13.  Change the name of the configuration to 'JBoss Debug' and change the port to 8787.
	__14.  Click the Source tab along the top of the configuration details.
	__15.  Click the Add button along the right.
	__16.  Select Java Project and click the OK button.
	__17.  Check the two projects and click the OK button.
	__18.  Click the Apply button once the settings are as shown below.
	__19.  With the configuration still selected press the Debug button.  This will attach to the running JBoss server. You may get an error, click Proceed.
	__20.  In the Debug view you should see the Java process listed.  Notice that there are LOTS of threads running in the server.  This is common in all Java Enterprise servers as they are running lots of services and processing multiple requests simultaneously.

	Part 6 -  Debug Application
	__1.  Open up a web browser and go to the URL of the OnlineStore application.
	__2.  Login with an existing customer id.
	__3.  Select a few items and submit the request to place them in your cart.  This is the request that will trigger the breakpoint.
	__4.  Switch back to Eclipse as you will not get a response in the browser.  You should see that there is a thread paused for the request that was submitted.  The line of the code breakpoint should also be highlighted.
	__5.  At the top of the Debug view click the Step Over button.  Make sure to press it only once.  The highlight in the source code should move to the 'processAdditions' method.
	__6.  Press the Step Over button a second time.  This will execute the 'processAdditions' method without stepping into the code.  The code highlight will move to the 'prepareDisplay' method.
	__7.  Press the Step Into button.  This will move the code highlight into the 'prepareDisplay' method.
	__8.  Notice the thread shows that it is now paused in the 'prepareDisplay' method.
	__9.  Look at the Variables view in the upper right.
	__10.  Press the Step Over button several times and you will see several variable names appear.  During debugging you can see what variables are available and even change the value.
	__11.  Back in the Debug view press the Step Return button.  This will return up one level
	__12.  You will be back in the 'doPost' method.
	__13.  In the Debug view press the Resume button.  That will run to the next breakpoint or where the code stops processing the request.
	__14.  Notice the selected thread is no longer paused.
	__15.  Switch back to the browser you had been using and notice the response is now output.
	__16.  Stop your JBoss server.
	__17.  Return to Eclipse and select Window → Close Perspective from the menus to close the debug perspective.
	__18.  In the Project Explorer view, right click each of the three 'SampleApps‑OnlineStore...' projects and select Delete.  Select the option to delete from the disk also and confirm the project deletion.  Make sure you do not delete the 'OnlineStore' projects.
	__19.  Open a File Browser to the <JBOSS_HOME>/bin directory.
	__20.  Open the run.conf file in a text editor.
	__21.  Add the '#' character back to the start of the 'JAVA_OPTS' line to comment out again the debug options.
	__22.  Save and close the 'run.conf' file.
	__23.  Close any extra web browsers, terminal windows, or File Browsers you may have open.

	Part 7 -  Summary

	Lab 9 -  Manage JBoss Messaging
	Part 1 -  Import New OnlineStore Version
	__1.  Open Eclipse in your workspace if it is not already open.
	__2.  Delete the OnlineStore, OnlineStoreEJB, and OnlineStoreWeb projects from the workspace.  When prompted to confirm also delete the files from the file system.
	__3.  Select File -> Import from the menus.
	__4.  In the Import wizard expand the General group and select Existing Projects into Workspace.  Press Next to continue.
	__5.  On the next screen, select the radio button next to 'Select archive file'.
	__6.  Press the Browse button next to the archive file box to browse your file system.
	__7.  Locate the file <LAB_FILES>/Messaging/OnlineStore.zip.  Once you have selected this file press the OK button in the Select archive... dialog.
	__8.  Check that the three OnlineStore projects are selected for import as shown below and press the Finish button to import the projects.
	__9.  Check that all three projects were imported.
	__10.  In the Ant view on the right side of the workspace click the flashlight search icon to bring up the Search for Buildfiles dialog.  You may need to select the Ant view titlebar to display it.
	__11.  Leave the default buildfile name of 'build.xml' and press the Search button.  There should be one file found in each of the OnlineStore projects and displayed in the Ant view .

	Part 2 -  Examine Application Messaging Resources
	__1.  Open a File Browser window, navigate to the <LAB_FILES>/Messaging directory, and open the file PurchasePrinterServlet.java with a text editor.
	__2.  Look for the '@Resource' code shown below near the beginning of the Servlet class definition.  The "Connection Factory" is a resource already configured in JBoss and is not something we will need to alter.  The important property to note is the 'mappedName' attribute of the destination.
	__3.  Open the PurchasePrinterBean.java file from the same directory in a text editor.
	__4.  Look at the properties of the '@MessageDriven' configuration of the EJB and notice there is also a property for the destination that has the same value as what was used in the Servlet.  This shows that the Servlet will be sending messages to the destination and the message driven EJB will be receiving them.
	__5.  Close both files.

	Part 3 -  Configure Message Destination
	__1.  Switch back to Eclipse.
	__2.  Expand the config project and the deploy folder.
	__3.  Right-click the deploy folder and select New -> Folder from the popup menu.
	__4.  Enter a folder name of 'messaging' without the quotes and press the Finish button.  All JMS configuration in JBoss is done in this 'messaging' subfolder.
	__5.  Open a File Browser window and navigate to the <LAB_FILES>/Messaging directory.
	__6.  Copy the purchasePrinter-service.xml file.
	__7.  Return to the Eclipse workspace.
	__8.  In the Project Explorer view select the messaging directory you just created.
	__9.  Paste the file into the messaging folder.
	__10.  Expand the deploy folder and check that the file was copied to the folder.
	__11.  Double-click the purchasePrinter-service.xml file to open it in the XML editor and select the Source tab at the bottom of the editor.
	__12.  Find the text in the file that says 'YOUR_QUEUE_NAME_HERE' and replace this with "purchasePrinterQueue" without the quotes so it appears as shown below.
	__13.  Look at the rest of the file and notice that this destination depends on some other 'jboss.messaging' services.  This ensures the destination will not be started until after these other messaging services.
	__14.  Save and close the file.
	__15.  In the Eclipse Project Explorer view, right-click the purchasePrinter-service.xml file and select Validate from the popup menu.  Be sure you get a message about the file being valid.

	Part 4 -  Export and Test Destination
	__1.  Stop your server if it is running.
	__2.  In the Ant view, expand the 'JBossDeployUtil' build and select the 'rebuildSingle' target.
	__3.  Press the green "Run" button in the toolbar of the Ant view.  This will run the 'rebuildSingle' target which is not the default target.
	__4.  Start your 'myconfig' JBoss server from a terminal window.  Be sure you do not see any errors in the Console as the server is starting.
	__5.  Open a web browser to http://localhost:8080/jmx-console/
	__6.  In the ObjectName Filter text box enter "*:service=JNDIView,*" without the quotes and press the ApplyFilter button.
	__7.  Click the link for the JNDIView MBean.
	__8.  Scroll down until you reach the operations section.
	__9.  Find the list operation.  Be sure the 'true' parameter is selected and press the Invoke button.
	__10.  In the results scroll down to the Global JNDI Namespace section and look for the group of names bound under 'queue' as shown below.  Make sure you see the 'purchasePrinterQueue' in the list.  Check the spelling a capitalization carefully as this makes a difference with JNDI names.
	__11.  Close the browser for the JMX Console.

	Part 5 -  Build and Test Application
	__1.  In the Ant view on the right side of the workspace select the OnlineStore buildfile by clicking on it.
	__2.  Press the green "Run" button in the toolbar of the Ant view.
	__3.  Examine the Console view to see the results of the build.  Make sure you see the BUILD SUCCESSFUL message at the end of the output.
	__4.  In the Ant view select and run the JBossDeployUtil buildfile.  You should get a message about copying one file to the JBoss configuration.  This is the new version of the OnlineStore application.
	__5.  Switch back to the window running the server.  Be sure you see messages about the application being deployed.  In particular look for a message about the PurchasePrinterBean being started.
	__6.  Open a web browser to http://localhost:8080/Store.
	__7.  Login as an existing user that has made previous purchases.
	__8.  Click on the link on the left side labeled "Request Email".
	__9.  On the page that is displayed press the Request button.  You should get a confirmation that the message has been sent.
	__10.  Switch back to the window running the server.  You should see messages with the details of the orders placed by the user.  In a real world application this would be sent as part of the email to the user.
	__11.  Close the browser used to test the application and stop the server.

	Part 6 -  Summary

	Lab 10 -  Monitor JBoss
	Part 1 -  Explore Web and Admin Consoles
	__1.  Open a terminal window and start the JBoss server with the 'myconfig' configuration if it is not already running.
	__2.  Open a web browser to the following URL for the Web Console.
	__3.  On the left side of the Web Console expand the Monitoring -> Web Status sections. Click the icon for Full Status.  This shows information on the Tomcat web container for JBoss.  Since most applications have some type of web interface this can be a useful source of information.
	__4.  Scroll down the screen and look for the following sections:
	__5.  Open another browser and test the OnlineStore application.  Make sure you login and display the "Browse" page at least a few times.
	__6.  Return to the browser with the Web Console.
	__7.  On the left side, click the entry for Full Status in the Monitoring -> Web Status section.  This will refresh the data.
	__8.  Scroll down to the resources of the OnlineStore application and look for the 'LoginServlet'.  You should see some details about how this component performs.  Depending on other actions you have taken the other resources may have data also.
	__9.  Return to the browser you were using to test the OnlineStore application and perform the "Request Email" function.  Try it more than once to be sure more than one message is sent.
	__10.  Open a web browser to the following URL for the Admin Console.
	__11.  Login with the user and password of 'admin'.
	__12.  On the left, click the link for 'JBoss AS 5 (myconfig)'.
	__13.  Scroll down on the summary page and notice you have some of the key metrics available.
	__14.  Click the Metrics tab along the top.
	__15.  Notice here you have more information available.
	__16.  Under the group of different types of applications on the left of the console, use the arrows to expand Applications → Embedded Web Application (WAR)s → OnlineStoreWeb.war → Embedded Web Application Contexts until you see '//localhost/Store'.
	__17.  Click on the link for '//localhost/Store'.
	__18.  Click the Metrics tab along the top.
	__19.  Note that you have a lot of the same information you got from the Web Console.
	__20.  Under the group of different types of resources on the left of the console, use the arrows to expand Resources → Datasources → Local Tx Datasources until you see 'jdbc/store'.
	__21.  Click the link for 'jdbc/store'.
	__22.  Click the Metrics tab along the top.
	__23.  Note that you can get information about how many connections are currently in use and the historical maximum for the number of active connections.
	__24.  Under the group of different types of resources on the left of the console, use the arrows to expand Resources → JMS Destinations → Queues until you see '/queue/purchasePrinterQueue'.
	__25.  Click the link for '/queue/purchasePrinterQueue'.
	__26.  Click the Metrics tab along the top.
	__27.  Note that normally you might be able to see metrics like the number of messages delivered although the OnlineStore application may not be displaying this information.
	__28.  Close the browser you were using for the consoles and testing the application.

	Part 2 -  Simulate Multiple Users
	__1.  Open a web browser to the OnlineStore application.  If you already have one open you can use it as long as you log out any current user.
	__2.  Register a new Customer using the ID 'test@myhost.com' without the quotes.  The rest of the fields can be whatever you wish as long as the ID matches the above value exactly.  This is the user that the test script that will simulate multiple users will use to login.
	__3.  Open a terminal window.
	__4.  Switch to the directory <SOFTWARE_DIR>/jakarta-jmeter-2.3.4/bin
	__5.  Issue the following command to launch the JMeter program.
	__6.  In the JMeter menus select File -> Open.
	__7.  Browse to the <LAB_FILES>/Monitoring directory and open the 'MultipleUsers.jmx' file.
	__8.  Open a web browser and test the OnlineStore application using the 'test@myhost.com' user.  Make sure you test the "Request Email" messaging function.  Always test the application manually before running any test script with the next command.  This will let the application initialize some components and discover errors before submitting several hundred requests to the server.
	__9.  From the JMeter menus select Run -> Start.  This will run the test script.  Wait for a minute while the test runs.  You will see a green box in the upper right when the test is in progress.
	__10.  On the left side of JMeter expand the 'Test Plan' and 'OnlineStore' entries.  You will see many entries for all of the individual requests that are part of the test but you can ignore them.
	__11.  Select the 'Aggregate Report' from near the top of the list.
	__12.  Scroll to the bottom of the table that shows the statistics and look for the column that shows the error totals.  Be sure there are 0% errors shown.  This table may still be updating with data if the test is still running.  
	__13.  Open a web browser to the Web Console if you do not already have one open.
	__14.  On the left side of the Web Console expand the Monitoring -> Web Status sections. Click the icon for Full Status.
	__15.  Scroll down for localhost/Store.
	__16.  Look for the number of 'Active Sessions'.  This value can be used as an indication of the number of users currently using the site.  The only problem is sessions are marked as "active" until they "expire" even if a user logs out or is not using the application.
	__17.  Scroll down and look for data from other resources in the application, especially the PurchasePrinterServlet.  This is used when the test sends a request to print all the orders for the customer.

	Part 3 -  Monitor MBean Attributes
	__1.  Return to the browser you were using to view the Web Console.
	__2.  Collapse the branch for 'J2EE Domains' so it is not expanded on the left side.
	__3.  On the left hand navigation expand the sections for System -> JMX MBeans -> jboss.system ->  jboss.system:type=ServerInfo. If asks for user/ password enter 'admin' for both.
	__4.  Expand the ServerInfo MBean on the left side so you can see the various attributes.
	__5.  Right click on the FreeMemory attribute and select graph from the popup menu.  A separate window should open and begin graphing the free memory.
	__6.  Return to the JMeter tool and run the script again by selecting Run -> Start from the menus.
	__7.  Bring the window that is graphing free memory back to the front.  You should see the memory go up and down slightly.  At some point you should also see the amount of free memory jump up as shown below.  It is possible that you may have to run the script a few times before you see a big jump in free memory.
	__8.  Close the window for the free memory graph.
	__9.  Back in web console, on the left hand navigation expand the sections for System -> JMX MBeans -> jboss.jca -> jboss.jca:service=ManagedConnectionPool,name=jdbc/store.  Be careful which MBean you select as there are several with very similar names.
	__10.  Expand the jboss.jca:service=ManagedConnectionPool,name=jdbc/store MBean on the left side so you can see the various attributes.
	__11.  Right click on the InUseConnectionCount attribute and select graph from the popup menu.  A separate window will open for the graph.  This will show how many database connections are currently in use.
	__12.  Return to the JMeter tool and run the script again by selecting Run -> Start from the menus.
	__13.  Bring the window that is graphing used database connections back to the front.  While the test is running you should see the number of connections go up and down.  Once the test is done the value should return to zero.  Run the test a second time to show the connections being used again.
	__14.  Close the window for the InUseConnectionCount.

	Part 4 -  Create Snapshot
	__1.  On the left hand navigation expand the sections for System -> JMX MBeans -> jboss.system -> ...:type=ServerInfo
	__2.  Expand the ServerInfo MBean on the left side so you can see the various attributes.
	__3.  Right click on the FreeMemory attribute and select create snapshot from the popup menu.  A web page opens on the right side to supply the properties of the snapshot.
	__4.  In the page that opens to configure the snapshot fill in '5' without the quotes for the Time Period.  You could also change the name if you want although we will leave the default name.
	__5.  Press the Create button to create the snapshot.
	__6.  Once you create the snapshot you will have more options available.  Press the Start Snapshot button to begin collecting data.
	__7.  Close the web browser which you are using to display the Web Console.  This will prove the point that you do not need to be connected to the Web Console for a snapshot to collect data.
	__8.  Return to the JMeter tool and run the test script again.  Do this by selecting Run -> Start.  
	__9.  Run the test a few times.  The easiest way to know the test is done is when the Aggregate Report stops collecting new data.  Always check to be sure you do not get any errors in the report.  If you get errors, restart the server, test manually with a browser, then run the test script.
	__10.  Open a web browser to the Web Console using the following address.
	__11.  On the left side expand Monitoring -> Snapshots and select the FreeMemory Snapshot.
	__12.  On the page that is displayed on the right click the Graph Dataset button.  This will display a graph similar to the popup graphs you saw in the last section.  This shows data that was collected even when the Web Console was closed.
	__13.  Click the link for the FreeMemory Snapshot on the left side again to redisplay the options for the snapshot.
	__14.  Press the Stop Snapshot button to stop collecting data for the snapshot.  You could clear the data and restart the snapshot in the future without reconfiguring the snapshot.
	__15.  Close the web browser for the Web Console.

	Part 5 -  Create Monitor Alert
	__1.  Open a web browser to the Web Console using the following address.
	http://localhost:8080/web-console/
	__2.  On the left hand navigation expand the sections for System -> JMX MBeans -> jboss.system -> ...:type=ServerInfo
	__3.  Expand the ServerInfo MBean on the left side so you can see the various attributes.
	__4.  Right click on the FreeMemory attribute and select create monitor from the popup menu.  A separate web page will open on the right side to supply the properties of the monitor.
	__5.  Supply the following values in the configuration page:
	__6.  Press the Create button to create the monitor.
	__7.  Close the web browser for the Web Console.
	__8.  Restart the server in the terminal window currently running it.  Simply stop the server and issue the command to start it again.
	__9.  Open a web browser and manually test the OnlineStore application to initialize some of the components.  This is required to avoid errors later when using the multi-user test script.
	__10.  Return to the JMeter tool.
	__11.  In the JMeter menus select File -> Open.  Select No if you are prompted to save the file.
	__12.  Browse to the <LAB_FILES>/Monitoring directory and open the 'TriggerMonitor.jmx' file.  This script will not send messages using the "Request Email" feature since this would print lots of messages to the log and prevent us from seeing the monitor trigger. 
	__13.  On the left side of JMeter expand the 'Test Plan' and 'OnlineStore' entries.  Select the 'Aggregate Report' from near the top of the list.
	__14.  In JMeter select Run -> Start to run the test script.  
	__15.  Run the test a few times to be sure the monitor will be triggered.
	__16.  Return to the terminal window running the JBoss server.  If the monitor was triggered you should see a message indicating the "MemoryMonitor" was triggered.  If you do not see the message run the test script a few more times to see if the memory has reached the lower limit yet.  If you still don't see the message skip ahead to the next step.  Opening the web console will trigger the alert if the testing has not.
	__17.  Open a web browser to the Web Console using the following address.
	__18.  On the left side, expand Monitoring and select Monitor Alerts.  You should see the monitor listed along with the fact that it is in "ALERT" status.
	__19.  Expand Monitor Alerts on the left side and select MemoryMonitor from the list.  You should see the value that triggered the alert.
	__20.  Return to the list of monitors by clicking the Monitor Alerts link on the left.
	__21.  Press the Clear All Alerts button.  If the free memory is still low the alert may not clear.  If this happens run the test script again to see if you can force the server to free up memory and try to clear the alert again.
	__22.  Close the web browser you are using for the Web Console.
	__23.  Close the JMeter tool by selecting File -> Exit.  Select No if you are prompted to save changes.
	__24.  Close any extra web browsers you were using to test the OnlineStore application.

	Part 6 -  Run Twiddle Scripts
	__1.  Be sure your server is running in a terminal window and start it if it is not.
	__2.  Open a terminal window.
	__3.  In the terminal window switch to the <JBOSS_HOME>/bin directory.
	__4.  Issue the following command.  Be sure to include the quotes around the name of the MBean.  
	__5.  Issue the following command to display just a single attribute.  
	__6.  Issue the following command to view the maximum size of the Data Source Connection pool.  Note that this command wraps and should all be on one line.
	__7.  Issue the following command to change the maximum number of connections in the Data Source.  Note that this command wraps and should all be on one line.
	__8.  Issue the following command to invoke the 'list' operation on the JNDIView MBean with a parameter of 'false'.  This will display a printout of the JNDI information.  
	__9.  Close the terminal window you are using for twiddle.
	__10.  Close the terminal window you are using for JMeter.
	__11.  Shutdown the server in the terminal window.

	Part 7 -  Summary

	Lab 11 -  Memory Profiling
	Part 1 -  Examine JVM Memory Options
	__1.  Stop your server if it is not already.
	__2.  Open a File Browser to the <JBOSS_HOME>/bin directory.
	__3.  Open the run.conf file in a text editor.
	__4.  Scroll down and find the section shown below for specifying JVM options.  There are some other lines with 'JAVA_OPTS' but this is likely the only line not commented out.
	__5.  Close the run.conf file.
	__6.  Start the JBoss server in a terminal window remembering to start your 'myconfig' configuration.

	Part 2 -  Use JConsole
	__1.  Open a new terminal window.
	__2.  Switch to the <JAVA_HOME>/bin directory using the value you wrote down for JAVA_HOME in the notes of the lab guide.  This is likely:
	__3.  Issue the following command to start the JConsole tool.
	__4.  When the tool starts it will show a dialog for establishing a connection.  Select the local process which is the 'org.jboss.Main' program running your configuration and press the Connect button.
	__5.  After a few seconds you should see the 'Overview' page which shows several useful graphs at once.
	__6.  Change the 'Time Range' drop-down on the overview page to see how you can use it to look in more detail at recent information or look at a long period of time.
	__7.  Click on the Memory tab at the top of the window.  Notice this is a larger version of the memory graph.
	__8.  On the right, press the 'Perform GC' button to trigger garbage collection.  You may notice that the memory use goes down slightly although this is mainly because the server is not using some objects that were used during startup.
	__9.  Back on the left, use the 'Chart' drop-down to pick another type of memory to graph.
	__10.  As you look at the different types of memory notice that the bars in the lower right show the area you are looking at is outlined in blue.  You can also click on these icons to switch the graph.
	__11.  Open a web browser to http://localhost:8080/Store and test the application.  Use several functions of the application to initialize several objects.
	__12.  Close the browser when you are done testing and switch back to JConsole.
	__13.  Click on the Threads tab at the top of the window.  The total number of threads can give you a rough idea of how busy the server is compared to other points in time.
	__14.  Notice at the bottom you can select an individual thread and see what code is executing although this information is not often as useful.
	__15.  Click on the VM Summary tab at the top of the window.  This tab gives you lots of info about the virtual machine and the physical machine also.  It is also good to see all the JVM options that were used to start the server.
	__16.  Click on the MBeans tab at the top of the window.
	__17.  On the left expand com.sun.management → HotSpotDiagnostic → Operations and click on the 'Operations' row.
	__18.  On the right fill in <LAB_FILES>/dump.hprof for the first parameter.  Remember to substitute the value of the <LAB_FILES> directory.  You will also have to clear out the current 'String' before typing in your value.  Note that the screenshot below does not show the entire value so double check yours carefully.
	__19.  When you have the value filled in, click on the dumpHeap button just to the left of the parameters.  
	__20.  After several seconds you should get a confirmation that the operation completed. Click the OK button to close the confirmation.
	__21.  Select Connection → Exit to exit JConsole.
	__22.  Stop your JBoss server.

	Part 3 -  Analyze Heap Dump
	__1.  Open a File Browser to the <LAB_FILES> directory.
	__2.  Check that you have a 'dump.hprof' file in the directory as shown below.  This is the heap dump from the last section.  If you don't have this file notify your instructor and perhaps look for it in a different directory.
	__3.  Locate the 'MemoryAnalyzer' executable program in a file browser.  This should be located in the <SOFTWARE_DIR>/mat directory.
	__4.  Double-click the 'MemoryAnalyzer' program to launch the Eclipse Memory Analyzer.  The first time you launch the program it may take a minute to display the tool.
	__5.  Close the Welcome page by clicking on the 'X' in the upper right of the tab.
	__6.  Select File → Open Heap Dump from the tool menus.
	__7.  Find and open the <LAB_FILES>/dump.hprof file in the dialog that opens.  It should take several seconds to open the file.
	__8.  After the heap dump is opened you should be presented with a wizard.
	__9.  Select Leak Suspects Report from the wizard and press the Finish button.
	__10.  Look at the 'Leak Suspects' report.  Right now you will probably see that the top "Leaks" are internal JBoss classes.  Just because a class is listed here doesn't mean it is actually a memory leak but if any classes from your application show up here that would warrant some further investigation.
	__11.  Close the 'Leaks Suspects' report by clicking the 'X' on the report tab but make sure not to close the overall 'dump.hprof' heap dump.
	__12.  Back in the main window for the dump.hprof heap dump, click the button for Open Dominator Tree.
	__13.  Click on the 'Shallow Heap' column to sort by this column.  These are objects that are of the biggest size by themselves without included the size of other contained objects.  Likely this is all byte or character arrays.
	__14.  Click on the 'Retained Heap' column to sort by this column.  These are objects that are of the biggest size including the size of other contained objects.  This will likely be many of the internal JBoss classes.
	__15.  Don't do it now but notice there is a button to export this information in various ways.
	__16.  Select the 'Group by package' option from the 'Group results by' button.
	__17.  Expand the 'com → myhost package and notice that the size of all objects from this package is very small.  If our application had memory problems we might see a higher percentage.
	__18.  Close the Eclipse Memory Analyzer by selecting File → Exit.

	Part 4 -  Profile From Eclipse
	__1.  Make sure your JBoss server is stopped.  We will be starting the server from Eclipse so it must be shut down.
	__2.  Open your Eclipse workspace if it is not already.
	__3.  Select the Servers view tab along the bottom.  If you don't see it try 'Window → Reset Perspective' to see if it appears.
	__4.  Right click in the empty Servers view and select New → Server.
	__5.  Expand the JBoss group, select JBoss v5.0, and press the Next button.
	__6.  On the next screen, use the Browse button to find and select your <JBOSS_HOME> directory.
	__7.  Once your settings are filled in as shown below press the Next button.
	__8.  Select and change the Server Configuration setting to 'myconfig' without the quotes.  Don't worry about using the drop-down as it is only possible to use a custom configuration by typing it in directly.
	__9.  Once your settings match that shown above press the Finish button to create the server definition in Eclipse.
	__10.  Double click the new server definition in the Servers view to open it.
	__11.  Scroll over to the right and expand the Timeouts section with the arrow next to it.
	__12.  Change the value for both timeouts to '600'.  You can just type in the value instead of using the arrows.
	__13.  Save and close the server definition.
	__14.  Right click your new server configuration from the Servers view and select Profile.  Don't select 'Debug' or 'Start' as this won't use the profiling options to start the server.
	__15.  Leave the default option of performing an "Execution time analysis" selected and press the Finish button.  It will take several seconds to start the server.
	__16.  Click Yes when you are prompted to switch to the Profiling and Logging perspective.  If you are not prompted to switch, select 'Window → Open Perspective → Profiling and Logging'.
	__17.  In the Profiling view you will see an attachment to the server process and you should see that it is already monitoring.
	__18.  Open up a web browser and go to the URL of the OnlineStore application.
	__19.  Login as an existing customer.
	__20.  Place some items in your cart and complete a purchase.
	__21.  Click the 'Request Email' link and submit a request for purchase information.
	__22.  Return to Eclipse and the Profiling view and click the Pause Monitoring button.
	__23.  Right click on the Execution Time Analysis and select Open With → Execution Flow.
	__24.  Look for a thread which has 'http-127...'.  This should be the thread for the requests you submitted.
	__25.  Click and drag a selection box around the area of the thread that shows activity.  There should be several lines and colors which we want to zoom in on.
	__26.  Once you are zoomed in you can see horizontal lines which indicate method calls and vertical bars which indicate the amount of time spent in a particular method.
	__27.  In the lower section click on the 'Cumulative Time' column twice until it has a '<' icon before it.
	__28.  Find the 'http-127.0.0.1-8080' thread and click the arrow to expand it.  The methods that took the longest to execute should be at the top.
	__29.  Click one of the methods and the time when the method executed should be highlighted up above.
	__30.  Back on the left, right click on the Execution Time Analysis and select Open With → Execution Statistics.
	__31.  In the lower section click on the 'Average Base Time' column once until it has a '<' icon before it.
	__32.  Expand the com.myhost.servlet package and it will list the Servlet classes that have the highest response time.
	__33.  Expand the com.myhost.ejb package and some of the EJB classes.  The methods that have the highest response time should be at the top.
	__34.  Back on the left, right click the paused agent and select Detach from Agent.
	__35.  In the Eclipse menus select Window → Close Perspective.
	__36.  When prompted to save profiling data click the Yes button.  This will let you open data analysis in the future.
	__37.  Back in the Servers view make sure the server is selected and click the Stop button.
	__38.  Right click your server configuration from the Servers view and select Profile.
	__39.  Select 'Memory Analysis' for the type of monitoring data.
	__40.  With 'Memory Analysis' selected, press the Edit Options button on the right.
	__41.  Select the 'Track object allocation sites' and click the Finish button.
	__42.  With the memory analysis options set, press the Finish button back in the main profiling dialog.  It will take several seconds to start the server.
	__43.  Click Yes when you are prompted to switch to the Profiling and Logging perspective.  If you are not prompted to switch, select 'Window → Open Perspective → Profiling and Logging'.
	__44.  In the Profiling view you will see an attachment to the server process and you should see that it is already monitoring.
	__45.  Right click the attached monitor and select Run Garbage Collection.
	__46.  Open up a web browser and go to the URL of the OnlineStore application.
	__47.  Use some of the other functions of the application.
	__48.  Back in Eclipse wait several minutes until Eclipse collects memory information for a large number of bytes as shown at the bottom of the window.  If it shows 10,000 bytes or less it has not yet collected all of the memory data and this often takes 4-5 minutes so you might want to take a quick break.
	__49.  In the Profiling Monitor view, click the Pause Monitoring button.
	__50.  Right click on the Memory Analysis and select Open With → Object Allocations.
	__51.  Click the filter button near the upper right and from the drop-down select Manage Filters...
	__52.  Press the New button in the filters dialog.
	__53.  Fill in 'MyHost' for the filter name and 'com.myhost.*' for the filter string.
	__54.  Press the OK button to create the filter with the settings above.
	__55.  Press the OK button again to apply the new filter to the memory data.
	__56.  What you should be left with, are memory statistics for the objects that are coded by the application.
	__57.  Back on the left, right click the paused agent and select Detach from Agent.
	__58.  In the Eclipse menus select Window → Close Perspective.
	__59.  When prompted to save profiling data click the Yes button.  This will let you open data analysis in the future.
	__60.  Back in the Servers view make sure the server is selected and click the Stop button.

	Part 5 -  Summary

	Lab 12 -  Application Security
	Part 1 -  Import and Test New OnlineStore Version
	__1.  Open Eclipse in your workspace if it is not already open.
	__2.  Delete the OnlineStore, OnlineStoreEJB, and OnlineStoreWeb projects from the workspace.  When prompted to confirm also delete the files from the file system.
	__3.  Select File -> Import from the menus.
	__4.  In the Import wizard expand the General group and select Existing Projects into Workspace.  Press Next to continue.
	__5.  On the next screen, select the radio button next to 'Select archive file'.
	__6.  Press the Browse button next to the archive file box to browse your file system.
	__7.  Locate the file <LAB_FILES>/Security/OnlineStore.zip.  Once you have selected this file press the OK button in the Select archive... dialog.
	__8.  Check that the three OnlineStore projects are selected for import as shown below and press the Finish button to import the projects.
	__9.  Check that all three projects were imported.
	__10.  In the Ant view on the right side of the workspace click the flashlight search icon to bring up the Search for Buildfiles dialog.  You may need to select the Ant view titlebar to display it.
	__11.  Leave the default buildfile name of 'build.xml' and press the Search button.  There should be one file found in each of the OnlineStore projects and displayed in the Ant view .
	__12.  In the Ant view on the right side of the workspace select the OnlineStore buildfile by clicking on it.
	__13.  Press the green "Run" button in the toolbar of the Ant view.
	__14.  Examine the Console view to see the results of the build.  Make sure you see the BUILD SUCCESSFUL message at the end of the output.
	__15.  In the Ant view select and run the JBossDeployUtil buildfile.  You should get a message about copying one file to the JBoss configuration.  This is the new version of the OnlineStore application.
	__16.  Start your 'myconfig' JBoss server from a terminal window.  Be sure you do not see any errors in the Console as the server is starting.
	__17.  Open a web browser to http://localhost:8080/Store.
	__18.  Click the link to "Find Purchases".
	__19.  Fill in an ID that you know has made purchases and press the Find button.
	__20.  You will immediately be presented with a challenge dialog prompting you for a password.  This is because the JBoss server now detects this is a secured function.  Fill in a user and password of 'hacker' and press the OK button to submit.
	__21.  You should be prompted for another user name because the first one was incorrect. Fill in 'employee' for the user name and password and press the OK button.  If you are prompted to remember the password, decline because you will be using different IDs to test security.
	__22.  The authentication with a valid user will present you with the same screen that shows purchase summary information.  The only thing different about the new version of the application is you are prompted for security authentication.
	__23.  Click the button next to one of the purchases listed to show the details of a purchase.  Notice you are not prompted for security information again because you have already provided it.  If you were to close your browser, the security authentication would be lost and you would have to re-authenticate when returning to the page.
	__24.  Close the browser you were using to test the application.

	Part 2 -  Examine Security Settings
	__1.  In the Project Explorer view of Eclipse expand the OnlineStoreWeb project.  Expand the build and classes folders.
	__2.  Double-click the roles.properties file to open it in the editor.  This file maps users to roles and maps our 'employee' user to the 'CSR' role which you will see later.
	__3.  Double-click the users.properties file to open it in the editor.  This file provides user name and password combinations recognized by the application.
	__4.  In the Project Explorer view expand the OnlineStoreWeb project.  Expand the WebContent and WEB-INF folders.
	__5.  Double-click the web.xml file to open it in the editor.
	__6.  Switch to the Design tab of the editor.
	__7.  Expand the various tags until you can see all of the security related tags as shown below.  These are near the bottom of the list.  They are explained below.
	__8.  Open a File Browser window, navigate to the <LAB_FILES>/Security directory, and open the file StoreFacade.java with a text editor.
	__9.  Scroll down to the start of the StoreFacade class definition and look for the '@DeclareRoles' annotation.  This defines the same 'CSR' role that was defined in the web module.
	__10.  Scroll about 2/3 of the way down the file and find one of the two methods that have the '@RolesAllowed' annotations.  This annotation restricts all but users in the role listed from accessing that method.
	__11.  Open the PurchasePrinterBean.java file.
	__12.  Scroll to the start of the PurchasePrinterBean definition and find the '@RunAs' annotation.  This annotation indicates that the code of the EJB will run with the role of "CSR".  This is important because this message bean will not have any user identity associated with it but must access some of the secure methods from the other EJB.  Without this annotation it would not be able to.
	__13.  Close all files that are open and be sure you have not made any changes.

	Part 3 -  Create Security Domain
	__1.  Open a File Browser window or use one already open and navigate to the <JBOSS_HOME>/server/myconfig/conf folder.
	__2.  Copy the login-config.xml file.
	__3.  Return to the Eclipse workspace.
	__4.  Expand the config project and select the conf folder by clicking on it.
	__5.  Paste the file into the conf folder.
	__6.  Be sure the login-config.xml file was imported to the conf directory as shown below.
	__7.  Double-click on the login-config.xml file to open it in the editor.
	__8.  Switch to the Source tab in the editor.
	__9.  Scroll to the very end of the file and find the 'other' security policy definition.  This is the default security policy.
	__10.  Copy the content of the 'other' security policy configuration.  Be sure to copy from the tag which starts the application-policy to the tag that ends it and not anything else.  There is a fairly long comment so be sure you copy the start and end application-policy tags.
	__11.  Paste the application-policy tag you copied immediately before the tag which ends the entire file (</policy>).  You can also remove the comment in the middle of the copied tag if you wish being careful to remove all of the comment and no other lines.
	__12.  Change the name of the policy you just added to 'StoreSecurity'.  Check that your file appears as below.
	__13.  Save the file but leave the editor open as we will edit this file again later.
	__14.  In the Project Explorer view expand the OnlineStoreWeb project.  Expand the WebContent and WEB-INF folders.
	__15.  Double-click the jboss-web.xml file to open it in the editor.
	__16.  Switch to the Design view and select the jboss-web element.
	__17.  Right-click the jboss-web element and select Add Child -> security-domain.
	__18.  Click the arrow to expand the jboss-web element if it is not already.
	__19.  Click in the right column next to the security-domain tag and fill in a value of 'java:/jaas/StoreSecurity' without the quotes.  Click somewhere else in the file to be sure the value is changed.
	__20.  Save and close the file.
	__21.  In the Project Explorer view expand the OnlineStoreEJB project and the build, classes, and META-INF folders.
	__22.  Open the jboss.xml file by double-clicking it.
	__23.  Switch to the Design view and select the jboss element.
	__24.  Right-click the jboss element and select Add Child -> security-domain.
	__25.  Click the arrow to expand the jboss element if it is not already.
	__26.  Click in the right column next to the security-domain tag and fill in a value of 'java:/jaas/StoreSecurity' without the quotes.  Click somewhere else in the file to be sure the value is changed.
	__27.  Save and close the file.

	Part 4 -  Export and Test Security
	__1.  In the Project Explorer view expand the config project.  Expand the conf folder and select the login-config.xml file.
	__2.  Right-click the login-config.xml file and select Validate from the popup menu.  You will get a message about there being a validation warning but make sure there are no errors.
	__3.  Make sure your server is not running and stop it if it is.
	__4.  In the Ant view on the right side of the workspace select the OnlineStore buildfile by clicking on it.
	__5.  Press the green "Run" button in the toolbar of the Ant view.
	__6.  Examine the Console view to see the results of the build.  Make sure you see the BUILD SUCCESSFUL message at the end of the output.
	__7.  In the Ant view select and run the JBossDeployUtil buildfile.  You should get a message about copying two files to the JBoss configuration.  This is the new version of the OnlineStore application and the new login-config.xml file.
	__8.  Start your 'myconfig' JBoss server from a terminal window.  Be sure you do not see any errors in the Console as the server is starting.
	__9.  Open a web browser to http://localhost:8080/Store.  Be sure you are using a new web browser and not one from before as the security credentials will still be associated with the old browser.
	__10.  Click the link to "Find Purchases".
	__11.  Fill in an ID that you know has made purchases and press the Find button.
	__12.  Fill in 'employee' for the user name and password and press the OK button.
	__13.  Test some of the other functions to be sure they work as well.
	__14.  Close the browser used for testing to drop the security credentials.
	__15.  Stop the server since we will modify security settings in the next few sections.

	Part 5 -  Import Security Tables to the Database
	__1.  Open a terminal window.  
	__2.  Issue the following command which assumes your <LAB_FILES> directory is '/usr/JBoss/LabFiles'.
	__3.  Enter a password of 'dbpassword' when prompted.
	__4.  Validate the table creation by entering the following command.
	__5.  Enter a password of 'dbpassword' when prompted.
	__6.  Issue the following command to switch to the store database.
	__7.  Issue the following commands to view the contents of the new tables created for security.
	__8.  Take note of the structure of the tables as well as the data.  The USERS table stores login and passwd fields.  The USER_ROLES table stores login and role fields.  There is a 'bob' login with a role of 'CSR' and a 'susan' login with a role of 'User'.  Both have passwords of 'password' to make things simple.
	__9.  After examining the data issue the command to quit.
	__10.  Close the terminal window.

	Part 6 -  Modify Security Domain to Use Database
	__1.  Return to the editor open for the login-config.xml file.  If you had closed it expand the config project and conf folder and double-click it to open it again.
	__2.  Make sure you are in the Design tab of the editor and you can see the very last tag for application-policy which is the StoreSecurity domain you added.
	__3.  Expand the tags for the StoreSecurity settings until you can see the code attribute for the login-module.
	__4.  Click in the right column next to the code attribute and fill in a value of 'org.jboss.security.auth.spi.DatabaseServerLoginModule' without the quotes.  Notice only the last part is different as the JBoss login modules are all defined in the same Java package.
	__5.  Right-click the login-module tag and select Add Child -> module-option from the popup menu.
	__6.  Switch to the Source tab in the editor and find the module-option tag that was just added near the end of the file.
	__7.  Change the syntax of the XML to add the 'name' attribute of 'dsJndiName' without the quotes for the value.  Also add the value of 'java:/jdbc/store' without the quotes for the content of the module-option tag as shown below.
	__8.  Copy the module-option tag and paste a copy within the overall login-module tag.
	__9.  Change the 'name' attribute and value of the module-option tag to match that below.
	__10.  Copy the module-option tag again and paste a copy within the overall login‑module tag.
	__11.  Change the 'name' attribute and value of the module-option tag to match that below.
	__12.  Double check that the syntax of your file matches that shown below.  Double check that all of the 'module-option' tags are inside the 'login-module' tag.
	__13.  Save and close the login-config.xml file.

	Part 7 -  Test Database Security Settings
	__1.  In the Project Explorer view expand the config project.  Expand the conf folder and select the login-config.xml file.
	__2.  Right-click the login-config.xml file and select Validate from the popup menu.  You will get a message about there being a validation warning but make sure there are no errors.
	__3.  Make sure your server is not running and stop it if it is.
	__4.  In the Ant view select and run the JBossDeployUtil buildfile.  You should get a message about copying one file to the JBoss configuration.  This is the new login‑config.xml file.
	__5.  Start your 'myconfig' JBoss server from a terminal window.  Be sure you do not see any errors in the Console as the server is starting.
	__6.  If you haven't already done so open a web browser to http://localhost:8080/Store.  Be sure it is a browser you have just opened.
	__7.  Click the link to "Find Purchases".
	__8.  Fill in an ID that you know has made purchases and press the Find button.
	__9.  Fill in 'bob' for the user name and 'password' for the password and press the OK button.  You should be able to display purchases as this user is associated with the CSR role in the database.
	__10.  Test some of the other functions to be sure they work as well.
	__11.  Close the browser you were using to test and open a new one for the application.  This is required to discard any previous authentication information.
	__12.  Test the 'Find Purchases' function again but use a user and password of 'employee' to attempt to authenticate.
	__13.  You should be prompted again for authentication because this user is not in the database.  This is the user that worked before but the fact that it doesn't now proves that the database is being used even though the property files are still in the application.
	__14.  Attempt to authenticate again using a user of 'susan' and 'password' for the password.
	__15.  You will not be prompted again but will immediately be given a 403 "Access denied" message.  This is because this user is in the table of users but is not assigned to a role that has access to this resource.  The 'employee' user was prompted again because this user was not even in the table of users.  You would also be prompted again if you had a correct user name but incorrect password.  If you can't supply a valid user name and password within a few attempts JBoss will return a 401 "HTTP authentication required" error.
	__16.  Press the "Back" button on the browser to return to the previous page.
	__17.  Attempt to submit the request again by pressing the Find button.  You are not even prompted once and are immediately denied access.  This is because JBoss has already authenticated you as the user 'susan' and does not need to ask again.
	__18.  Close the browser again.
	__19.  Open a terminal window. 
	__20.  Enter the following command.
	__21.  Enter a password of 'dbpassword' when prompted.
	__22.  Issue the following command to switch to the store database.
	__23.  Issue the following commands to insert new user settings into the database.
	__24.  Issue the following commands to verify the rows added to the tables.
	__25.  Issue the command to quit.
	__26.  Close the terminal window.
	__27.  Open a web browser for the application.
	__28.  Attempt to access the "Find Purchases" function as the user 'employee' with a password of 'password'.  Because this user has been added to the user table and associated with the CSR role you should be able to access it.
	__29.  Close the web browser and open a new one for the application.
	__30.  Attempt to access the "Find Purchases" function as the user 'susan' with a password of 'password'.  This attempt will fail even though the proper settings are in the database.  This is because JBoss is caching the previous attempt this user made to access the function before the database was updated.
	__31.  Close the web browser and restart the JBoss server.  Once it is restarted you will be able to access the "Find Purchases" function as the user 'susan' because the cached security credential will be gone and it will reload the settings from the database which will grant access to the function.

	Part 8 -  Summary

	Lab 13 -  Configure JBoss Security
	Part 1 -  Import Security Configuration Files
	__1.  Open your Eclipse workspace if it is not already.
	__2.  Select the config project in the  Project Explorer view of Eclipse.
	__3.  Select File → Import from the Eclipse menus.
	__4.  Expand the General group and select the Archive File import source and press the Next button.
	__5.  Press the Browse button next to the archive file box to browse your file system.
	__6.  Locate the file <LAB_FILES>/Security/SecurityConfigFiles.zip.  Once you have selected this file press the OK button in the Select archive... dialog.
	__7.  Check that the root of the archive file is checked so all files will be imported and that they will be imported into the 'config' folder and press the Finish button.
	__8.  Select Yes or Yes to All if prompted to overwrite files.

	Part 2 -  Configure Messaging Service Security
	__1.  In the Project Explorer view of Eclipse expand the config → deploy → messaging folders.
	__2.  Double click the messaging-jboss-beans.xml file to open it.
	__3.  Find the 'SecurityStore' group of settings and the 'suckerPassword' property which currently has a value of "CHANGE ME!!".
	__4.  Change the value to 'newSuckerPassword' without the quotes as shown below.
	__5.  Save and close the file.
	__6.  Double click the messaging-service.xml file to open it.
	__7.  Scroll almost to the bottom of the file and find the 'SuckerPassword' attribute which is currently commented out.
	__8.  Delete the end of the comment tag around the attribute (-->) and add a new line with the end of a comment tag before the syntax for the attribute.  This will have the effect of "uncommenting" the attribute as shown below.  The colors of the SuckerPassword attribute should change indicating it is no longer a comment.
	__9.  Change the value of the attribute to 'newSuckerPassword' as shown below.  Make sure to put the value between the tags.
	__10.  Save and close the file.

	Part 3 -  Configure JMX Console Security
	__1.  In the Project Explorer view of Eclipse expand the deploy → jmx-console.war → WEB‑INF folders of the config project.
	__2.  Double click the web.xml file to open it.
	__3.  Near the end of the file, find the section with a <security-constraint> tag that is commented out.
	__4.  Remove the end of the comment tag (-->) after the security constraint and add it back in before the start of the <security-constraint> tag as shown below.  The color of the XML should change to indicate it is no longer a comment.
	__5.  Save and close the file.
	__6.  Right click the web.xml file and select Validate.  Be sure you do not get errors.
	__7.  Double click the jboss‑web.xml file to open it.
	__8.  Move the end of the comment tag to before the <security-domain> tag as shown below to uncomment it.  Again the color of the XML should change.
	__9.  Save and close the file.
	__10.  Right click the jboss‑web.xml file and select Validate.  Be sure you do not get errors.
	__11.  Expand the conf folder of the config project.
	__12.  Double-click on the login-config.xml file to open it in the editor.
	__13.  Switch to the Source tab in the editor.
	__14.  Scroll about half way through the file and find the 'jmx-console' <application‑policy> configuration.  Notice that it uses two 'jmx-console' property files in a 'props' subfolder.
	__15.  Close the file and be sure you did not make any changes.
	__16.  Expand the conf and props folders in the config project.
	__17.  Double-click on the jmx-console-roles.properties file to open it in the editor.
	__18.  Notice that the 'admin' user you have used before with the Administration Console is mapped to the 'JBossAdmin' and 'HttpInvoker' roles.  The 'JBossAdmin' role is used by the Administration and JMX consoles and the 'HttpInvoker' role is used by an HttpInvoker service we will see later.
	__19.  Close the file and be sure you did not make any changes.
	__20.  Double-click on the jmx-console-users.properties file to open it in the editor.
	__21.  Notice that this is where the 'admin' user and password we have already used in the Administration Console is set.
	__22.  Close the file and be sure you did not make any changes.
	__23.  In the Project Explorer view you may want to click the '-' button to collapse all of the folders so things aren't as confusing.

	Part 4 -  Configure Web Console Security
	__1.  In the Project Explorer view of Eclipse expand the deploy → management → console-mgr.sar → web-console.war → WEB‑INF folders of the config project.
	__2.  Double click the web.xml file to open it.
	__3.  Near the end of the file, find the section with a <security-constraint> tag that is commented out.
	__4.  Remove the end of the comment tag (-->) after the security constraint and add it back in before the start of the <security-constraint> tag as shown below.  The color of the XML should change to indicate it is no longer a comment.
	__5.  Save and close the file.
	__6.  Right click the web.xml file and select Validate.  Be sure you do not get errors.
	__7.  Double click the jboss‑web.xml file to open it.
	__8.  Move the end of the comment tag to before the <security-domain> tag as shown below to uncomment it.  Again the color of the XML should change.
	__9.  Save and close the file.
	__10.  Right click the jboss‑web.xml file and select Validate.  Be sure you do not get errors.
	__11.  In the Project Explorer view of Eclipse expand the deploy → management → console-mgr.sar → web-console.war → WEB‑INF → classes folders of the config project.
	__12.  Double-click on the web-console-roles.properties file to open it in the editor.
	__13.  Notice that the 'admin' user is mapped to the 'JBossAdmin' role.  The role name only needs to match what is declared in the web.xml file of the Web Console and just happens to be the same as the other consoles.
	__14.  Close the file and be sure you did not make any changes.
	__15.  Double-click on the web-console-users.properties file to open it in the editor.
	__16.  Notice that this is where the 'admin' user and password is set.  Even though the 'admin' user and password is the same as the other consoles this setting could be unique for the Web Console.
	__17.  Close the file and be sure you did not make any changes.

	Part 5 -  Configure Security for JBoss Web Service Management
	__1.  In the Project Explorer view of Eclipse expand the deploy → jbossws.sar → jbossws‑management.war → WEB‑INF folders of the config project.
	__2.  Double click the web.xml file to open it.
	__3.  Near the middle of the file, find the section with a <security-constraint> tag that is commented out.
	__4.  Remove the end of the comment tag (-->) after the security constraint and add it back in before the start of the <security-constraint> tag as shown below.  The color of the XML should change to indicate it is no longer a comment.
	__5.  Save and close the file.
	__6.  Right click the web.xml file and select Validate.  Be sure you do not get errors.
	__7.  Double click the jboss‑web.xml file to open it.
	__8.  Move the end of the comment tag to before the <security-domain> tag as shown below to uncomment it.  Again the color of the XML should change.
	__9.  Save and close the file.
	__10.  Right click the jboss‑web.xml file and select Validate.  Be sure you do not get errors.
	__11.  Expand the conf and props folders in the config project.
	__12.  Double-click on the jbossws-roles.properties file to open it in the editor.
	__13.  Notice that this file uses a new user and does not have the same role name as the other configurations have had.
	__14.  Close the file and be sure you did not make any changes.
	__15.  Double-click on the jbossws-users.properties file to open it in the editor.
	__16.  Notice that there is a 'kermit' user with a password of 'thefrog' which is used as the default user of this security domain.
	__17.  Close the file and be sure you did not make any changes.
	__18.  In the Project Explorer view you may want to click the '-' button to collapse all of the folders so things aren't as confusing.

	Part 6 -  Examine HTTP Invoker Security
	__1.  In the Project Explorer view of Eclipse expand the deploy → http-invoker.sar → invoker.war → WEB‑INF folders of the config project.
	__2.  Double click the web.xml file to open it.
	__3.  Near the end of the file, find the section with a <security-constraint> tag.  Notice that unlike the others it is already active.
	__4.  Close the file and be sure you did not make any changes.
	__5.  Double-click on the jboss-web.xml file to open it in the editor.
	__6.  Notice that the link to the jmx-console security domain is already active.
	__7.  Close the file and be sure you did not make any changes.

	Part 7 -  Configure JMX Invoker Security
	__1.  In the Project Explorer view of Eclipse expand the deploy folder of the config project.
	__2.  Double click the jmx-invoker-service.xml file to open it.
	__3.  Near the end of the file, find the section with a <interceptor> tag that is commented out.  This is an 'AuthenticationInterceptor' configuration that mentions the jmx-console.
	__4.  Remove the end of the comment tag (-->) after the interceptor and add it back in before the start of the <interceptor> tag as shown below.  The color of the XML should change to indicate it is no longer a comment.
	__5.  Save and close the file.
	__6.  Right click the jmx-invoker-service.xml file and select Validate.  You will get a warning but be sure you do not get errors.

	Part 8 -  Configure SSL for Web Container
	__1.  Open a new terminal window.
	__2.  Switch to the <JBOSS_HOME>/server/myconfig/conf directory.
	__3.  Issue the following command to check that they 'keytool' command will execute from the <JAVA_HOME>/bin directory installed in the first lab.
	__4.  Issue the following command to generate a certificate.  Note this is just one command even though it wraps onto several lines below.
	__5.  Open a File Browser window and view the contents of the directory <JBOSS_HOME>/server/myconfig/conf.  There is now a 'ssl.keystore' file in this directory which is the self-signed certificate.
	__6.  Copy the ssl.keystore file from the file system.
	__7.  Back in Eclipse, paste the file in the conf directory of the config project.
	__8.  Close the terminal window and the File Browser window.
	__9.  In the Project Explorer view of Eclipse expand the deploy → jbossweb.sar folders of the config project.
	__10.  Double click the server.xml file to open it.
	__11.  Find the SSL Connector tag which is currently commented out.  This tag is only a page or two from the top of the file.  Look for the port 8443 if you have trouble finding it.
	__12.  Remove the end of the comment tag (-->) after the connector configuration and add it back in before the start of the <Connector> tag as shown below.  The color of the XML should change to indicate it is no longer a comment.
	__13.  Change the following attributes to match the options used to generate the certificate.
	__14.  Double check that your configuration matches that shown below.
	__15.  Save and close the file.

	Part 9 -  Encrypt Data Source Password
	__1.  In the Project Explorer view expand the config project.  Expand the conf folder and open the login-config.xml file.
	__2.  Switch to the Source tab of the editor.
	__3.  Scroll to the bottom of the file and add a few blank lines before the </policy> tag that ends the file.
	__4.  Add the following syntax for a new security domain configuration called 'EncryptDBPassword'.  Leave a few blank lines in the middle as there will be other lines added.
	__5.  Add the following syntax for a <login-module> tag within the <authentication> tag added in the last step.  Carefully check the value of the 'code' attribute so it matches the proper code for the login module.
	__6.  Within the <login-module> tag add a new <module-option> tag with the following values.  This will be the username that will be stored with the security domain instead of in the Data Source configuration.
	__7.  Add a second new <module-option> tag with the following values.  The value is all numbers and the letters a-f.  This will store a masked version of the password.
	__8.  Finally add a third new <module-option> tag with the following values.  This will link the security domain to the Data Source being supplied the masked password.
	__9.  Double check that your syntax matches that shown below.
	__10.  Save and close the file.
	__11.  Expand the deploy directory and double-click the mysql-ds.xml file to open it.
	__12.  Switch to the Design view of the editor if it is not already.
	__13.  Expand the datasources tag and the local-tx-datasource tag until you see the various properties of the Data Source.
	__14.  Select the user-name element by clicking it.
	__15.  Right-click the user-name element and select Remove from the popup menu.
	__16.  Do the same to remove the password element.  This way neither of these elements are in the file and are a security risk.
	__17.  Select the local-tx-datasource tag.
	__18.  Right-click the local-tx-datasource tag and select Add Child → prefill – validate‑on‑match → security-domain from the popup menu.
	__19.  Click in the right column next to the security-domain attribute and fill in 'EncryptDBPassword' without the quotes for the value.  Click somewhere else in the file to be sure the value is changed.
	__20.  Check the values entered and save and close the file.
	__21.  Right-click the mysql-ds.xml file and select Validate from the popup menu. Be sure you get a message about the file being valid.

	Part 10 -  Test Security Configuration
	__1.  Make sure your server is not running and stop it if it is.
	__2.  In the Ant view select and run the JBossDeployUtil buildfile.  You should get a message about copying several files to the JBoss configuration.  
	__3.  Start your 'myconfig' JBoss server from a terminal window.  Be sure you do not see any errors in the Console as the server is starting.
	__4.  Open a web browser to http://localhost:8080/Store.
	__5.  Login as an existing user.  If you are able to login this proves the encrypted Data Source password is working.
	__6.  Modify the address in the browser to https://localhost:8443/Store.  Notice the change to HTTPS protocol and the new port.
	__7.  After a moment you should be presented with the following security alert.  Read the messages and realize this is what we expect because we are using a "self-signed" certificate which is not generated by a company the browser already trusts.  By informing us about this we are being asked to make a decision about the communication.
	__8.  Click the link for 'Or you can add an exception'.  
	__9.  Click the 'Add Exception' button.
	__10.  In the dialog that appears press the 'Get Certificate' button.
	__11.  Click the 'View' button to view the certificate.
	__12.  If you look at the 'General' tab of the certificate display you can see some of the options we used to create the certificate.
	__13.  Close the certificate details and then click 'Confirm Security Exception' to accept the certificate.
	__14.  Test the functions of the application and verify they work as normal.
	__15.  Modify the address in the browser to http://localhost:8080.  This should bring up the JBoss homepage with links to various applications.
	__16.  Click the link for the JMX Console.
	__17.  You should be prompted for security.  Fill in and submit a username and password of 'admin'.
	__18.  Verify that you can access the functions of the JMX Console as normal.  Note that there is no logout in the console.
	__19.  Return to the main page showing the various JBoss links.
	__20.  Click the link for the JBoss Web Console.
	__21.  You should again be prompted for security.  Fill in and submit a username and password of 'admin'.
	__22.  Modify the address in the browser to http://localhost:8080/jbossws/services
	__23.  You should be prompted for security.  Use a username of 'kermit' and a password of 'thefrog' (all one word) and you should be allowed to access the application.  Although there are no services currently deployed we were prompted for security.
	__24.  Close the web browser and stop the server.

	Part 11 -  Summary

	Lab 14 -  Web Services
	Part 1 -  Import New OnlineStore Version
	__1.  Open Eclipse in your workspace if it is not already open.
	__2.  Delete the OnlineStore, OnlineStoreEJB, and OnlineStoreWeb projects from the workspace.  When prompted to confirm also delete the files from the file system.
	__3.  Select File -> Import from the menus.
	__4.  In the Import wizard expand the General group and select Existing Projects into Workspace.  Press Next to continue.
	__5.  On the next screen, select the radio button next to 'Select archive file'.
	__6.  Press the Browse button next to the archive file box to browse your file system.
	__7.  Locate the file <LAB_FILES>/WebService/OnlineStore.zip.  Once you have selected this file press the OK button in the Select archive... dialog.
	__8.  Check that there are four OnlineStore projects selected for import as shown below and press the Finish button to import the projects.
	__9.  Check that all four projects were imported.  The 'OnlineStoreServiceClientWeb' is a new application that will be the client of the web service.
	__10.  In the Ant view on the right side of the workspace click the flashlight search icon to bring up the Search for Buildfiles dialog.  You may need to select the Ant view titlebar to display it.
	__11.  Leave the default buildfile name of 'build.xml' and press the Search button.  There should be one file found in each of the OnlineStore projects and displayed in the Ant view .
	__12.  In the Ant view on the right side of the workspace select the OnlineStore buildfile by clicking on it.
	__13.  Press the green "Run" button in the toolbar of the Ant view.
	__14.  Examine the Console view to see the results of the build.  Make sure you see the BUILD SUCCESSFUL message at the end of the output.
	__15.  In the Ant view on the right side of the workspace select the OnlineStoreServiceClientWeb buildfile by clicking on it.
	__16.  Press the green "Run" button in the toolbar of the Ant view.
	__17.  Examine the Console view to see the results of the build.  Make sure you see the BUILD SUCCESSFUL message at the end of the output.
	__18.  Expand the config → deploy folder and be sure you see the 'OnlineStoreServiceClientWeb.war' file in addition to the usual 'OnlineStore.ear' file.

	Part 2 -  Export and Test Web Service Applications
	__1.  In the Ant view, select and run the JBossDeployUtil buildfile.  You should get a message about copying two files to the JBoss configuration.  This is the new version of the OnlineStore application and the new application which is the web service client application.
	__2.  Start your 'myconfig' JBoss server from a terminal window.  Be sure you do not see any errors in the Console as the server is starting.  If your server was already running you should be able to leave it running since you are only deploying new applications to the 'deploy' directory.
	__3.  Open a web browser to http://localhost:8080/Store.
	__4.  Use some of the existing functions of the application and notice that nothing from the web application we are used to using has changed.  Note that if you use the 'Find Purchases' function you need to use a userid and password of 'employee' because the application is back to using the users packaged in the properties files.
	__5.  Change the URL in the browser to http://localhost:8080/ServiceClient/
	__6.  Click the link for 'View Partner Products'.  You will get an error that will be explained and fixed later.
	__7.  Close the browser you were using to test the application.
	__8.  Go to the terminal window running JBoss and see if you can find in the error messages output a mention of an 'UnknownHostException' and mention of the hostname 'testhost'.  Don't worry too much though if you can't find this message.

	Part 3 -  Examine Web Service Applications
	__1.  In the Eclipse expand the OnlineStoreServiceClientWeb → WebContent → WEB-INF → wsdl folders.
	__2.  Double click the StoreFacadeService.wsdl file to open it.
	__3.  Switch to the Source view of the editor and scroll to the bottom of the file.
	__4.  Notice that the 'soap:address' location lists the 'testhost' hostname which is why the client can't connect to the web service.
	__5.  Close the WSDL file.
	__6.  Open a File Browser window, navigate to the <LAB_FILES>/WebService directory, and open the file StoreFacadeService.java with a text editor.
	__7.  Scroll down and find the '@WebServiceClient' annotation in the code.  Notice that it has a property that points to the 'StoreFacadeService.wsdl' file in the application that you just saw.  Also note the 'name' property of the client annotation.
	__8.  Open the ListPartnerProducts.java file from the File Browser window in a text editor.
	__9.  Look for the '@WebServiceRef' annotation at the top of the Servlet.  Notice that the name of the reference is the same as the other code.
	__10.  Open the StoreFacade.java file from the File Browser window in a text editor. This file is part of the code from the OnlineStore application and we will see what turns the application into a web service.
	__11.  On the class definition notice the '@WebService' annotation.  This indicates that this class is exposed as a web service.
	__12.  Scroll down and find the '@WebMethod' annotation on the 'getProductList' method.  This indicates that this method should be exposed as an operation on the web service.
	__13.  Close the text editor you have used to look at the code.

	Part 4 -  Fix Service Client Application
	__1.  Return to your Eclipse workspace.
	__2.  In the Project Explorer view, select the config project by clicking on it.
	__3.  Right-click the config project and select New -> Folder from the popup menu.
	__4.  Fill in the Folder name of 'wsdl' without the quotes and press the Finish button.
	__5.  Check that the new 'wsdl' folder is in the correct location.
	__6.  Make sure your 'myconfig' JBoss server is still running and start it if it is not.
	__7.  Open a web browser to http://localhost:8080/jbossws/services.
	__8.  You should be prompted for security.  Use a username of 'kermit' and a password of 'thefrog' (all one word) and you should be allowed to access the application.
	__9.  You should see that the web service in the 'OnlineStore' application is listed.  There is nothing specifically in this page that links it to the 'OnlineStore.ear' file that is deployed although you may notice that the 'StoreRouter' context and 'StoreFacade' endpoint match some of the code you looked at before.  You can also get some basic monitoring information on the service from here like number of requests and response times.
	__10.  Click on the link for the "Endpoint Address" that ends in '...?wsdl'. 
	__11.  Scroll to the bottom of the WSDL that is displayed and notice that the 'soap:address' property has a different hostname.  This WSDL was generated by JBoss when deploying the application that contained the web service.
	__12.  From the browser menus select File → Save Page As...
	__13.  Change the name of the file to 'StoreFacadeService.wsdl' and change the 'Save in folder' option to save to the desktop.
	__14.  Click the Save button to save it to the desktop when the dialog appears as shown above.
	__15.  Close the web browser.
	__16.  Find the saved file on your desktop, right click it, and select Copy.
	__17.  Return to your Eclipse workspace.
	__18.  Paste the file in the config → wsdl folder as shown below.
	__19.  In the Project Explorer view, expand the OnlineStoreServiceClientWeb → WebContent → WEB-INF folders.
	__20.  Double-click the jboss-web.xml file to open it in the editor.
	__21.  Switch to the Source view in the editor.
	__22.  Remove the beginning (<!--) and end (-->) comment tag to uncomment the 'service‑ref' tag.
	__23.  Save and close the file.
	__24.  Right click the jboss‑web.xml file and select Validate.  Be sure you do not get errors.
	__25.  In the Ant view on the right side of the workspace select the OnlineStoreServiceClientWeb buildfile by clicking on it.
	__26.  Press the green "Run" button in the toolbar of the Ant view.
	__27.  Examine the Console view to see the results of the build.  Make sure you see the BUILD SUCCESSFUL message at the end of the output.
	__28.  In the Ant view select and run the JBossDeployUtil buildfile.  You should get a message about copying two files to the JBoss configuration.  This is the updated version of the web service client application and the external WSDL file the client will use.
	__29.  Open a browser to http://localhost:8080/ServiceClient/
	__30.  Click the link for 'View Partner Products'.  You should get a response that lists the products of the OnlineStore application.  This proves the client can communicate with the web service.
	__31.  Close the browser you were using to test the application.
	__32.  Stop your JBoss server.
	__33.  Close any other extra windows.

	Part 5 -  Summary

	Lab 15 -  Establish a Standalone Cluster
	Part 1 -  Create the Basic Configuration for the Cluster
	__1.  Open a File Browser window.  
	__2.  Navigate to the <JBOSS_HOME>/server directory.  This directory has a sub-directory for all of your currently configured servers.
	__3.  Copy the all server configuration by selecting it and selecting Edit -> Copy.
	__4.  Paste a copy of the all directory back into the server directory.
	__5.  Rename the copied directory cluster.

	Part 2 -  Examine Start Scripts
	__1.  Open the <LAB_FILES>/Cluster folder in a File Browser.
	__2.  Open the startNode.sh file in a text editor.
	__3.  Check that the value of the JBOSS_HOME variable matches the directory where JBoss is installed and change it if needed.
	__4.  Check that the value of the CONFIG variable matches the renamed copy of the 'all' configuration that you created.  This variable will be used with the '-c' option.
	__5.  Change the 'X's in the PARTITION and UDP variables to match the value of your "Cluster number" that was assigned at the start of the lab.  The values shown below would be used if your cluster number was '5'.
	__6.  Examine the rest of the script.  Notice that the script will take a parameter for the "Node" name.  This will be used to create directories for the 'tmp', 'log' and 'data' directories.  You can use the same configuration for multiple servers at runtime as long as these destinations are unique.  These directories are then passed to the startup command using the matching JBoss properties.
	__7.  Save and close the file.
	__8.  Open the startNode1.sh and startNode2.sh files.  Notice that these are just convenience scripts to call the other script with certain parameters.  This will be important later when we must pass in additional parameters.
	__9.  Close the files and make sure you haven't made changes.
	__10.  Open a terminal window and switch to the <LAB_FILES>/Cluster folder.
	__11.  Run the following command to be sure that all scripts are executable.

	Part 3 -  Verify Port Conflicts
	__1.  Open a terminal window and switch to the <LAB_FILES>/Cluster folder.
	__2.  Run the following command to start the first server.  Wait for it to start completely.
	__3.  After the first server has started completely, open a second terminal window and switch to the <LAB_FILES>/Cluster folder.
	__4.  Run the following command to start the second server.  
	__5.  You will likely see errors fairly quickly.  You will also not get the usual "Started" message.
	__6.  In the window running the second server press CTRL-C to stop the server.  If you do not see the "Shutdown complete" message you may need to close the window to kill the process.
	__7.  Return to the window running the first server and stop the server.

	Part 4 -  Use Different Ports
	__1.  Open the startNode.sh file from the <LAB_FILES>/Cluster folder in a text editor.
	__2.  Modify the test for the number of parameters expected to 2 and update the usage error message.
	__3.  Add the following new variable to store the second parameter passed in as the ports setting to use.
	__4.  Add the following in bold to pass the system property to set the ports binding set to the startup command.  Be sure to add the backslash at the end of the line to continue the command.
	__5.  Save the startNode.sh file.
	__6.  Open the startNode1.sh file in a text editor.
	__7.  At the end of the line that calls the main script add 'ports-default' as the set of ports.
	__8.  Save the file.
	__9.  Open the startNode2.sh file in a text editor.
	__10.  At the end of the line that calls the main script add 'ports-01' as the set of ports.
	__11.  Save the file.
	__12.  Open a terminal window or use an existing one and switch to the <LAB_FILES>/Cluster folder.
	__13.  Run the following command to start the first server.  Wait for it to start completely.
	__14.  After the first server has started completely, open a second terminal window and switch to the <LAB_FILES>/Cluster folder.
	__15.  Run the following command to start the second server.  
	__16.  The startup will proceed better than last time.  You should see quite a number of normal messages for most of the startup.  You will still see a few errors but let the server startup completely.  This time you should see a "Started in x:x:x" message.
	__17.  Look back a few lines from the "Started" message and see that there was an error starting a messaging service.  JBoss messaging in a cluster attempts to contact other servers in the cluster.  In order to do this each server must have a unique 'ServerPeerID'.  Unfortunately both of our servers are using the default so there is still a conflict.
	__18.  Switch to the window running the first server.  You should see a number of messages about the second server joining the group.  This proves we are closer to running the cluster since the servers no longer conflict on ports.
	__19.  Shutdown both servers in their windows, first stop server 2 and then server 1 .  If you have trouble stopping a server you may need to close the window to kill the process.

	Part 5 -  Establish Unique ServerPeerID
	__1.  Open the startNode.sh file from the <LAB_FILES>/Cluster folder in a text editor.
	__2.  Modify the test for the number of parameters expected to 3 and update the usage error message.
	__3.  Add the following new variable to store the third parameter passed in as the ServerPeerID setting to use.
	__4.  Add the following in bold to pass the system property to set the ServerPeerID to the startup command.  Be sure to add the backslash at the end of the line to continue the command.
	__5.  Save the startNode.sh file.
	__6.  Open the startNode1.sh file in a text editor.
	__7.  At the end of the line that calls the main script add '1' as the ServerPeerID parameter.
	__8.  Save the file.
	__9.  Open the startNode2.sh file in a text editor.
	__10.  At the end of the line that calls the main script add '2' as the ServerPeerID parameter.
	__11.  Save the file.
	__12.  Open a terminal window or use an existing one and switch to the <LAB_FILES>/Cluster folder.
	__13.  Run the following command to start the first server.  Wait for it to start completely.
	__14.  After the first server has started completely, open a second terminal window and switch to the <LAB_FILES>/Cluster folder.
	__15.  Run the following command to start the second server.  
	__16.  This time both servers should start successfully.  If you switch to the window running the first server that was started you should see messages about there being two members of the cluster group.  You will also see a warning about the password of the "Message Sucker".  This actually proves that the two messaging services on both servers started successfully.
	__17.  Still in the window for the first server, stop the server.
	__18.  Switch to the window for the other server and notice that there are several messages about how that server is now the only one in the group.
	__19.  Shutdown the second server and close any extra windows.

	Part 6 -  Summary

	Lab 16 -  Clustered Deployment
	Part 1 -  Deploy Application Manually
	__1.  Open a terminal window or use an existing one and switch to the <LAB_FILES>/Cluster folder.
	__2.  Run the following command to start the first server.  Wait for it to start completely.
	__3.  After the first server has started completely, open a second terminal window and switch to the <LAB_FILES>/Cluster folder.
	__4.  Run the following command to start the second server.  Wait for it to start completely and check there are no errors during startup.
	__5.  Open a File Browser window and navigate to the directory <LAB_FILES>/SimpleApp.
	__6.  Copy the HelloWeb.war file from this directory.  This will be the application you will deploy.
	__7.  In the File Browser window navigate to the directory <JBOSS_HOME>/server/cluster/deploy.  
	__8.  Paste the application into this directory by selecting Edit->Paste from the menus.
	__9.  Switch to the terminal window running the first clustered server.  You should see the normal deployment messages for the application.  You should also see some messages about new group members from when the second server started.
	__10.  Open a Web Browser and enter http://localhost:8080/HelloWeb in the address bar. You should see the entry page of the application as shown below.  If you do not see the entry page you may have to change the proxy settings of your browser so it does not forward requests that should go to your local machine.  Test the application to be sure you can get messages back from the HelloWeb application.
	__11.  Switch to the terminal window running the second clustered server.  You should also see the normal deployment messages for the application.  This proves that both servers monitor the same directory to pick up deployments.  It was only the 'log', 'data', and 'tmp' directories that had to be unique.
	__12.  Switch to the Web Browser you were using to test the application.
	__13.  Change the address in the address bar to http://localhost:8180/HelloWeb.  Notice the only thing that changes is the port number which will send this request to Node2. Try the page and check the messages are in the second clustered server
	__14.  Leave the servers running for the next section.

	Part 2 -  Establish Eclipse Deployment to Cluster
	__1.  Open your Eclipse workspace if it is not already.
	__2.  In the Eclipse menus select File -> New -> Project.
	__3.  In the New Project wizard expand the General group and select Project.  Press Next to continue.
	__4.  Fill in a name of clusterConfig for the project name.  Press the Finish button when you are done.
	__5.  Right-click the new clusterConfig project and select New -> Folder from the popup menu.
	__6.  Enter a folder name of 'deploy' without the quotes and press the Finish button.  
	__7.  Open a File Browser window and navigate to the <LAB_FILES>/SimpleApp directory.
	__8.  Copy the HelloWeb.war and HitCount.ear files.
	__9.  Return to the Eclipse workspace.
	__10.  In the Project Explorer view select the deploy directory you just created.
	__11.  Paste the files into the deploy folder.
	__12.  Expand the deploy folder and check that the files were copied to the folder.
	__13.  Expand the JBossAnt project so you can see the Ant files in it.
	__14.  Double click the build.properties file to open it in an editor.
	__15.  Select the 'build.properties' tab along the bottom of the editor.  This will show the contents of the file and not the special options of the Eclipse Ant editor.
	__16.  Change the following property values in the file
	__17.  Save and close the file.

	Part 3 -  Deploy to Cluster from Eclipse
	__1.  In the Ant view select the JBossDeployUtil buildfile by clicking on it.
	__2.  Press the green "Run" button in the toolbar of the Ant view.  
	__3.  Examine the Console view to see the results of the build.  You will see the names of the tasks and what order they were called in.  Most notably look for the BUILD SUCCESSFUL message at the end of the output.  
	__4.  Switch back to the terminal window running the servers.  In both windows you should see messages about deploying the applications.
	__5.  Open a web browser and enter http://localhost:8080/HitCountWeb in the address bar.  Click the link to test the application.
	__6.  Refresh the page a few times to see the count increase as shown below.
	__7.  Change the URL to http://localhost:8180/HitCountWeb.  Notice the port is different and this will access Node2.  Test the application by clicking the link.  Notice you will get the output below which shows the counter reseting to 1.  Refresh the page a few times to show the value increments separately.  You can even open up two browsers, one for each server, to show the separate behavior.  This will be explained in the lab summary.
	__8.  Stop the servers from the terminal windows running the servers.  If you shut them down at the same time expect that you might see some exceptions as they both try to tell the other cluster member they are stopping but the communication channels are already shut down.  If you stop them one at a time you should not see any errors.
	__9.  Close any extra web browsers or File Browser windows.

	Part 4 -  Summary

	Lab 17 -  Configure Apache Web Server for Clustering
	Part 1 -  Copy mod_jk Module Into Apache Installation
	__1.  Open a File Browser window and navigate to the <LAB_FILES>/Cluster-Apache directory.
	__2.  Select the mod_jk.so file and select Edit -> Copy from the menu.
	__3.  Navigate to the <APACHE_HOME>/modules directory.  This is most likely:
	/etc/httpd/modules
	__4.  Paste the file into this directory by selecting Edit -> Paste from the menus.

	Part 2 -  Modify Apache Configuration
	__1.  In the File Browser window navigate to the <APACHE_HOME>/conf directory.
	__2.  Open the httpd.conf file in a text editor.
	__3.  Scroll to the very bottom of the file and enter the following two lines:
	__4.  Save and close the file.
	__5.  Copy the mod-jk.conf file from the <LAB_FILES>/Cluster-Apache directory to the <APACHE_HOME>/conf directory.
	__6.  Open the mod-jk.conf file from the Apache configuration directory with a text editor.  Although you will not change anything in this file it is good to know what it does.
	__7.  Look for the LoadModule directive at the top of the file.  This instructs Apache to load the mod_jk module you just copied to the modules directory.
	__8.  Look for the JkWorkersFile directive.  This tells the module where to find a file that will provide details about the JBoss Web Containers and how to load-balance between them.  You will configure this file in an upcoming step.
	__9.  Look for the JkLogFile and JkLogLevel directives which configure logging for mod_jk.  This logging is separate from the web server and JBoss logging.
	__10.  Look for the JkMount and JkMountFile directives.  These are very important as you must use one of these to tell mod_jk what URLs to forward, or "mount", to the JBoss servers.  Without this information the Apache web server will not forward anything to JBoss.  You will use the  JkMountFile directive and configure the file in an upcoming step.
	__11.  Close the file and be sure you did not make any changes.

	Part 3 -  Configure mod_jk Behavior
	__1.  In you File Browser window copy the uriworkermap.properties file from the <LAB_FILES>/Cluster-Apache directory to the <APACHE_HOME>/conf directory.
	__2.  Open the uriworkermap.properties file from the Apache configuration directory with a text editor.
	__3.  Observe that this file has various URIs for applications you have used or will use with JBoss.  This file tells the Apache mod_jk module which requests to forward to JBoss.  Your own applications deployed to a JBoss cluster would need to have their URIs listed here.  It is best to list the wildcard version and the version without any ending '/' so that the request is forwarded even if a user formats their request for the entry page without the trailing '/'.
	__4.  Close the uriworkermap.properties file and be sure you have not made any changes.
	__5.  In you File Browser window copy the workers.properties file from the <LAB_FILES>/Cluster-Apache directory to the <APACHE_HOME>/conf directory.
	__6.  Open the workers.properties file from the Apache configuration directory with a text editor.
	__7.  At the bottom of the file there are two sections to define the workers labeled 'WorkerXA' and 'WorkerXB'.  Replace the 'X' in all of these directives with your cluster number.  For instance, if your cluster number were 5, the worker names would be 'Worker5A' and 'Worker5B'.  Each directive should start with something similar to the following:
	__8.  Double check that all of the 'X's in the directives have been replaced with your cluster number similar to that shown below.
	__9.  In the worker configuration sections replace 'YOUR_HOSTNAME' with the actual value of your computer hostname.  If you do not know this you can open a terminal window and use the 'hostname' command to find out.
	__10.  Near the top of the file find the directive that ends with 'balance_workers' which has a value of 'YOUR_WORKER_LIST'.  Replace this value with a comma separated list of the names of your workers you defined in the lower sections being careful to match the names exactly including case.  The final value would look like this if your cluster number was 5:
	__11.  Save and close the file.

	Part 4 -  Modify JBoss Configuration
	__1.  Open your Eclipse workspace if it is not already.
	__2.  Select the clusterConfig project in the Project Explorer view.
	__3.  Right-click on the clusterConfig project and select Import... from the pop-up menu.
	__4.  Select File system from the General group and press Next.
	__5.  Press the first Browse button and navigate to your <JBOSS_HOME>/server/cluster directory. Press OK when you have this directory selected in the Import from directory dialog.
	__6.  Expand the cluster entry on the left side of the dialog by clicking the triangle next to it.  Be sure you DO NOT check the checkbox as this will import every file.
	__7.  Expand the deploy directory by clicking the triangle next to it again being careful not to check the box next to the directory.
	__8.  Select the jbossweb.sar directory on the left but do not check the box next to it.
	__9.  On the right side of the Import dialog select the server.xml file by checking the box next to it.
	__10.  Press the Finish button to import the file.
	__11.  Check that your clusterConfig project contains the imported file as shown below and that you do not have any extra directories or files.  If you do contact your instructor.
	__12.  Open the server.xml file by double-clicking it.
	__13.  Switch to the Source view in the editor by clicking the tab along the bottom of the editor.
	__14.  Locate the start of the Engine tag which is about one third of the way down the file.
	__15.  Add an additional attribute to the tag for jvmRoute as shown below.  The value will be a placeholder for a system property.  
	__16.  Save and close the file.
	__17.  Validate the file by right-clicking it and selecting Validate from the pop-up menu. You will get a warning but be sure you don't get any errors.

	Part 5 -  Modify Server Startup
	__1.  Open the startNode.sh file from the <LAB_FILES>/Cluster folder in a text editor.
	__2.  Modify the test for the number of parameters expected to 4 and update the usage error message.
	__3.  Add the following new variable to store the third parameter passed in as the ServerPeerID setting to use.
	__4.  Add the following in bold to pass the system property to set the jvmRoute to the startup command.  Be sure to add the backslash at the end of the line to continue the command.
	__5.  Save the startNode.sh file.
	__6.  Open the startNode1.sh file in a text editor.
	__7.  At the end of the line that calls the main script add 'WorkerXA' as the jvmRoute parameter making sure to substitute the value of your cluster number for the 'X'.  Below is an example of the command if your cluster number were '5'.
	__8.  Save the file.
	__9.  Open the startNode2.sh file in a text editor.
	__10.  At the end of the line that calls the main script add 'WorkerXB' as the jvmRoute parameter making sure to substitute the value of your cluster number for the 'X'.  Below is an example of the command if your cluster number were '5'.
	__11.  Save the file.
	__12.  Close the files.

	Part 6 -  Start Servers and Test
	__1.  Make sure that both servers are stopped and stop them if they are not.
	__2.  In the Ant view of Eclipse select the JBossDeployUtil buildfile by clicking on it.
	__3.  Press the green "Run" button in the toolbar of the Ant view.  
	__4.  You should see one file copied to the configuration.
	__5.  Open a terminal window or use an existing one and switch to the <LAB_FILES>/Cluster folder.
	__6.  Run the following command to start the first server.  Wait for it to start completely.
	__7.  After the first server has started completely, open a second terminal window and switch to the <LAB_FILES>/Cluster folder.
	__8.  Run the following command to start the second server.  Wait for it to start completely and check there are no errors during startup.
	__9.  Make sure you know which window is running which server as this will be important.
	__10.  From the CentOS menus of the upper toolbar select ‘System → Administration → Services’.
	__11.  Scroll down the list of services on the left and select the ‘httpd’ service from the list.
	__12.  Check the box next to the ‘httpd’ service as shown below so it will start automatically when the machine boots.
	__13.  With the ‘httpd’ service still selected click the “Start” button above the list of services.  After a few seconds it should prompt you that the service is started.  Press the “OK” button to confirm the start.
	__14.  Press the “Save” button in the upper left of the window to save the service configuration.
	__15.  Select ‘File -> Quit’ from the menus to close the service configuration.
	__16.  Open a Firefox web browser and enter http://localhost/jkstatus/ in the address bar.  Make sure to include the trailing '/' in the URL as you will get an error if it is not included.  This will bring up the JK Status Manager statistics for your web server.  You should see, as shown below, that both Workers are listed as N/A and neither has processed a request which would be listed in the Acc column.
	__17.  Open a separate Firefox browser and enter http://localhost/HelloWeb/ in the address bar.  You should see the entry page of the HelloWeb application.
	__18.  Return to the browser showing the JK Status and refresh the page.  At least one of the servers should show a request.
	__19.  Return to the browser showing the HelloWeb application and submit several requests to test the application.
	__20.  Return to the browser showing the JK Status and refresh the page.  You should see that one server processes more requests than the other.  This is because Apache is configured to use "sticky" sessions and attempt to send you back to the same server to improve performance.
	__21.  Select 'Edit -> Preferences' from the menus of the Firefox web browser.
	__22.  Select the Privacy group along the top.
	__23.  Press the Show Cookies button.
	__24.  Expand the localhost folder for Site and select the “JSESSIONID” cookie from the list.  Notice that the cookie content indicates which server you were routed to.
	__25.  Press the 'Remove Cookie' button.  This will cause the browser to “forget” about your session on the server.  Without the “JSESSIONID” cookie the web server will treat you like a new client.  Use the method outlined above every time you want to check which server you have been routed to or to get the web server to treat you like a new client.
	__26.  Click the 'Close' buttons twice to close the list of cookies and the browser preferences.
	__27.  Return to the browser you were using to test the HelloWeb application.
	__28.  Submit a few more requests for the application.
	__29.  Return to the browser showing the JK Status and refresh the page.  You should see that the server that had processed fewer requests previously has "caught up" to the other server.  This is because when you tested the HelloWeb application the second time you were viewed as a new user and routed to the server that had processed fewer requests.  In this way Apache can keep things balanced out as much as possible when new users submit requests but improve performance for existing users by routing them to the same server.
	__30.  Use the method you used previously to clear the cookies from the browser.
	__31.  Open a new web browser and enter http://localhost/HitCountWeb/ in the address bar.
	__32.  Return to the browser showing the JK Status and refresh the page.  Make a note of the values for how many requests have been processed by each server.  You may also want to restart the Apache web server to reset the counters to zero before testing the HitCount application.
	__33.  Return to the browser showing the HitCount application and click the link to view the hit count page.  Refresh several times.
	__34.  Return to the browser showing the JK Status and refresh the page.  You should see that only one server was processing your requests.  Figure out which server was processing your requests remembering that worker "A" is Node1 and worker "B" is Node2.
	__35.  Go to the terminal window running the server that was processing your requests.
	__36.  Stop the server that was processing your requests.  Let it shutdown completely before going to the next step.
	__37.  Return to the browser showing the HitCount application.  Refresh the page. You will see that the count starts over as you are directed to the new server but then begins incrementing again.  The Apache web server has detected that the server you were originally going to is unavailable and redirected you to the second server.
	__38.  Return to the browser showing the JK Status.  Refresh the page to update the information. You should see that one worker is listed with an error and the other has started handling all of the requests as we expected.
	__39.  Stop the JBoss server that is still running.
	__40.  Stop the Apache web server by issuing the following command in a terminal window.
	__41.  Close the web browsers you were using to test the applications and view the JK Status.

	Part 7 -  Summary

	Lab 18 -  Modify Applications to Support Clustering
	Part 1 -  Fix Session Clustering
	__1.  Open a File Browser window and navigate to the <LAB_FILES>/Cluster‑Apps/session directory.
	__2.  Open the web.xml file in a text editor.
	__3.  Near the top of the file look for a distributable tag as shown below.  This tag tells the application server that this web application can run in a clustered environment.  This will instruct JBoss to replicate the HTTPSession information to other cluster members.  
	__4.  Close the file.  This file is already packaged in a version of the application you will import.
	__5.  Open a terminal window or use an existing one and switch to the <LAB_FILES>/Cluster folder.
	__6.  Run the following command to start the first server.  Wait for it to start completely.
	__7.  After the first server has started completely, open a second terminal window and switch to the <LAB_FILES>/Cluster folder.
	__8.  Run the following command to start the second server.  Wait for it to start completely and check there are no errors during startup.
	__9.  Make sure you know which window is running which server as this will be important.
	__10.  Open another terminal window.
	__11.  Issue the following command to start the Apache web server.  The 'restart' command will be sure the routing statistics for the web server are reset.  You may get an error about the server name but this is OK.
	__12.  Open a File Browser window and navigate to the <LAB_FILES>/Cluster‑Apps/session directory.
	__13.  Copy the HitCount.ear file.
	__14.  Open your Eclipse workspace if it is not already open.
	__15.  In the Project Explorer view select the deploy directory of the clusterConfig project.
	__16.  Paste the file into the deploy folder.  Confirm that you want to overwrite the existing file.
	__17.  In the Ant view select the JBossDeployUtil buildfile by clicking on it.
	__18.  Press the green "Run" button in the toolbar of the Ant view.  
	__19.  Examine the Console view to see the results of the build.  You should get a message about copying one file to the cluster configuration directory.
	__20.  Switch back to the terminal window running the servers.  In both windows you should see messages about deploying the applications.  You will also see some messages about a "SessionCache" which indicates JBoss is ready to replicate HTTPSessions for the new application.
	__21.  Open a web browser for the JK Status application at http://localhost/jkstatus/ and be sure the statistics are reset.
	__22.  Open a second web browser to the HitCount application at http://localhost/HitCountWeb/.
	__23.  Click the link to view the hit count and refresh the page a few times so it increments.
	__24.  Return to the browser showing the JK Status and refresh the page.  Note which Node was processing your requests remembering that worker "A" is Node1 and worker "B" is Node2.
	__25.  Go to the terminal window running the server that was processing your requests.
	__26.  Stop the server that was processing your requests.  Let it shutdown completely before going to the next step.
	__27.  Return to the browser showing the HitCount application.  Refresh the page one time.  You should see an error as shown below.  Note that the error mentions there was an error communicating with the EJB.  The reason for this will be explained in the introduction of the next step.

	Part 2 -  Fix EJB Clustering
	__1.  Open a File Browser window and navigate to the <LAB_HOME>/Cluster‑Apps/full directory.
	__2.  Open the jboss.xml file.
	__3.  Look for a clustered tag as shown below.  This tag tells the application server that this EJB should be clustered across JBoss servers.
	__4.  Close the file.  It is already in a version you will import.
	__5.  Return to the terminal windows running your servers.
	__6.  Shutdown both of your nodes and then restart them one at a time.  This will be sure both are reset from any previous errors.  Remember to let one node start completely before starting the other.
	__7.  Close all web browsers.
	__8.  In a terminal window, issue the following command to start the Apache web server.  The 'restart' command will be sure the routing statistics for the web server are reset.
	__9.  Open a File Browser window and navigate to the <LAB_FILES>/Cluster‑Apps/full directory.
	__10.  Copy the HitCount.ear file.
	__11.  In the Project Explorer view of Eclipse select the deploy directory of the clusterConfig project.
	__12.  Paste the file into the deploy folder.  Confirm that you want to overwrite the existing file.
	__13.  In the Ant view select the JBossDeployUtil buildfile by clicking on it.
	__14.  Press the green "Run" button in the toolbar of the Ant view.  
	__15.  Examine the Console view to see the results of the build.  You should get a message about copying one file to the cluster configuration directory.
	__16.  Switch back to the terminal window running the servers.  In both windows you should see messages about deploying the applications.  If you scroll up a little you can also see a message about a "SFSBCache" which is the clustering of Stateful Session EJBs.
	__17.  Open a web browser for the JK Status application at http://localhost/jkstatus/ and be sure the statistics are reset. Also remove the cookie to make sure it starts clean.
	__18.  Open a second web browser to the HitCount application at http://localhost/HitCountWeb/.  Be sure to use a different browser than the one you used before or you may retain information from the previous testing.
	__19.  Click the link to display the hit count and refresh the page a few times to see it increment. Make note of the last count you display.
	__20.  Use the JK Status screen to determine which node was processing your requests and stop that node as before in the terminal window running that server.
	__21.  Return to the browser you are using to test the HitCount application.  Refresh the page only once and you should see that the count continues to increment from where you left off!  The first refresh after failover will take a little longer but you will still see the count increment from where you left off and not restart or show an error.
	__22.  Return to the JK Status page and refresh the page.  You should see that the node that was originally processing your requests is listed with an error and the other server has taken over. The difference now is that the user of the HitCount application is not aware that they have begun using the second node as the application behaves the same as if the original server were being used.
	__23.  If you wish you can continue to test failover by switching the server that is running.  Make sure that you always start the second server completely before shutting down the other server.  If you do not, the session and EJB information will not be replicated and will be lost.
	__24.  Shutdown all JBoss servers when you are done testing.
	__25.  Stop the Apache web server by issuing the following command in a terminal window.
	__26.  Close the web browsers you were using to test the applications and view the JK Status.

	Part 3 -  Summary

	Lab 19 -  Deploy Clustered JMS Application
	Part 1 -  Configure Cluster for OnlineStore
	__1.  Open your Eclipse workspace if it is not already open.
	__2.  Right-click the clusterConfig folder and select New -> Folder from the popup menu.
	__3.  Enter a folder name of 'conf' without the quotes and press the Finish button.
	__4.  Expand the config project and the conf directory.
	__5.  Select the login-config.xml file by clicking on it.
	__6.  Select Edit -> Copy from the IDE menus.
	__7.  Expand the clusterConfig project and select the conf directory by clicking on it.
	__8.  Select Edit -> Paste from the Eclipse menus.
	__9.  Expand the conf folder and check that the file was copied to the folder.
	__10.  Expand the config project and the deploy directory.
	__11.  Select the mysql-ds.xml file by clicking on it.
	__12.  Select Edit -> Copy from the Eclipse menus.
	__13.  Expand the clusterConfig project and select the deploy directory by clicking on it.
	__14.  Select Edit -> Paste from the Eclipse menus.
	__15.  Expand the config project and select the lib directory by clicking on it.
	__16.  Select Edit -> Copy from the Eclipse menus.  This should copy the entire directory which includes the MySQL JDBC drivers.
	__17.  Select the root of the clusterConfig project by clicking on it.
	__18.  Select Edit -> Paste from the Eclipse menus.  This should create a new lib folder in the clusterConfig project.
	__19.  Expand the config project and the deploy directory.
	__20.  Select the messaging directory by clicking on it.
	__21.  Select Edit -> Copy from the Eclipse menus.  This should copy the entire directory which includes JBoss Messaging configuration files.
	__22.  Expand the clusterConfig project and select the deploy directory by clicking on it.
	__23.  Select Edit -> Paste from the Eclipse menus.  This should create a new messaging subfolder in the deploy directory of the project.
	__24.  Open a File Browser window and navigate to the <LAB_FILES>/Cluster‑JMS directory.
	__25.  Copy the OnlineStore.ear file.
	__26.  Back in Eclipse, expand the clusterConfig project and select the deploy directory by clicking on it.
	__27.  Select Edit -> Paste from the Eclipse menus.
	__28.  Check that the following files have been copied into the clusterConfig project:

	Part 2 -  Configure JMS for Clustering
	__1.  Be sure all your servers are stopped.  Stop them in the terminal windows running them if they are not.
	__2.  Open a File Browser window.
	__3.  Navigate to the <JBOSS_HOME>/server/cluster/deploy directory.
	__4.  Delete the hsqldb-ds.xml file.  Be careful that you delete only this file.  This is the file that defines the current 'DefaultDS' Data Source.
	__5.  Navigate to the <JBOSS_HOME>/server/cluster/deploy/messaging directory.
	__6.  Delete the hsqldb-persistence-service.xml file.  This is the file that uses Hypersonic for the JMS service.  You will import another file later that uses MySQL for the JMS service.
	__7.  Open a File Browser window and navigate to the <LAB_FILES>/Cluster‑JMS directory.
	__8.  Copy the default-ds.xml file.
	__9.  Return to the Eclipse workspace.
	__10.  In the Project Explorer view select the deploy directory of the clusterConfig project.
	__11.  Paste the file into the deploy folder.
	__12.  Expand the deploy folder and check that the file was copied to the folder.
	__13.  Open a File Browser window and navigate to the <JBOSS_HOME>\docs\examples\jms directory.
	__14.  Copy the mysql-persistence-service.xml file being careful not to select the mssql-* file as this is for Microsoft SQL Server.
	__15.  Return to the Eclipse workspace.
	__16.  In the Project Explorer view expand the clusterConfig project and deploy directory and select the messaging directory.
	__17.  Paste the file into the messaging folder.
	__18.  Expand the messaging folder and check that the file was copied to the folder.
	__19.  Open a terminal window.  
	__20.  Issue the following command which assumes your <LAB_FILES> directory is '/usr/JBoss/LabFiles'.
	__21.  Enter a password of 'root123' when prompted.  This will create a MySQL database called 'jbossdb' which will be used as the central database for the 'DefaultDS' Data Source on every cluster member.
	__22.  Close the terminal window.

	Part 3 -  Test Clustered JMS
	__1.  Make sure that both servers are stopped and stop them if they are not.
	__2.  In the Ant view of Eclipse select the JBossDeployUtil buildfile by clicking on it.
	__3.  Press the green "Run" button in the toolbar of the Ant view.  
	__4.  You should see several files copied to the configuration.
	__5.  Open a terminal window or use an existing one and switch to the <LAB_FILES>/Cluster folder.
	__6.  Run the following command to start the first server.  Wait for it to start completely.  Make sure there are no errors during startup.
	__7.  After the first server has started completely, open a second terminal window and switch to the <LAB_FILES>/Cluster folder.
	__8.  Run the following command to start the second server.  Wait for it to start completely and check there are no errors during startup.
	__9.  Make sure you know which window is running which server as this will be important.
	__10.  Open another terminal window.
	__11.  Issue the following command to start the Apache web server.  The 'restart' command will be sure the routing statistics for the web server are reset.  You may get an error about the server name but this is OK.
	__12.  Open a web browser for the JK Status application at http://localhost/jkstatus/ and be sure the statistics are reset.
	__13.  Open a second web browser to the OnlineStore application at http://localhost/Store
	__14.  Login as an existing user.
	__15.  Click the link to Find Purchases.
	__16.  Fill in a user that has placed orders and press the Find button.  
	__17.  Return to the web browser showing the JK Status and refresh the page.  One server should have processed several more requests than the other.  Make note of which server processed your requests remembering that worker "A" is Node1 and worker "B" is Node2.
	__18.  Return to the browser you are using to test the application and click the link for Request Email.  This is the function that will send a JMS message.
	__19.  Click the Request button and note the results you get.  You should get the normal output no matter which node processed your request.  
	
	__20.  Switch to the terminal window of the server processing the requests and you should see the orders printed out.
	__21.  Select 'Edit -> Preferences' from the menus of the Firefox web browser.
	__22.  Select the Privacy group along the top.
	__23.  Press the Show Cookies button.
	__24.  Press the 'Remove All Cookies' button.
	__25.  Press the 'Close' button twice to close the cookie list and preferences.
	__26.  Close the browser you are using to test the application.
	__27.  Open a new web browser to the OnlineStore application at http://localhost/Store
	__28.  Login as an existing user and test the non-JMS functions of the application as before.
	__29.  Refresh the web browser showing the JK Status to verify that your requests are being processed by the node which did not process requests before.
	__30.  Test the Request Email function again and you should still get the normal response about a message being sent.  
	__31.  Stop the servers one at a time.

	Part 4 -  Modify JMS Destination to be Clustered
	__1.  Make sure both your servers are stopped and stop them if needed.
	__2.  Open a terminal window.
	__3.  Issue the following command to connect to MySQL.
	__4.  Enter a password of 'dbpassword' when prompted.
	__5.  Issue the following command to switch to the common database.
	__6.  Issue the following command to remove the data from the table of messaging destinations.
	__7.  After verifying there are no errors issue the command to quit.
	__8.  Close the terminal window.
	__9.  Open your Eclipse workspace if it is not already.
	__10.  Expand the clusterConfig → deploy → messaging folders.
	__11.  Double click the mysql-persistence-service.xml file to open it.
	__12.  About 2/3 of the way down the file, find the Clustered attribute of the "Post Office" and change the setting to 'true' without the quotes as shown below.
	__13.  Save and close the file.
	__14.  Double click the purchasePrinter-service.xml file to open it.
	__15.  Add the following syntax for a 'Clustered' attribute to the beginning of the mbean definition for the destination.  Note that the lines below besides the new attribute may be split a little differently but you should not change anything but add the new attrobute.
	__16.  Save and close the file.
	__17.  In the Ant view of Eclipse select the JBossDeployUtil buildfile by clicking on it.
	__18.  Press the green "Run" button in the toolbar of the Ant view.  
	__19.  Check that you get a message about exporting two files.

	Part 5 -  Modify Ant Rebuild for Cluster
	__1.  Back in Eclipse expand the JBossAnt project.
	__2.  Double click the build.xml file to open it.
	__3.  Find the existing 'rebuildSingle' target.
	__4.  Select and copy the existing 'rebuildSingle' target making sure to include the entire <target> tag content.
	__5.  Place your cursor after the end of the existing target and paste a second copy of the target.  You will get an error that will be fixed in the next steps.
	__6.  Change the name of the target to 'rebuildCluster' without the quotes as shown below.  The red underlined errors should go away when you do this.
	__7.  Find the fileset that is being copied and change it to copy the 'all' configuration instead of the 'default' configuration.  This is critical to make sure you copy a configuration which has the clustering services that will be required.
	__8.  After the end of the 'copy' task, add two new 'delete' tasks as shown below.  Note that one of the tasks wraps onto a second line below but should all be on the same line in your build file.
	__9.  Check that you have the proper syntax for the task tags and that there are no errors shown in the file.
	__10.  Save and close the file.

	Part 6 -  Test Rebuilt Cluster
	__1.  Make sure you do not have any terminal windows running the JBoss server and stop the server if you do.
	__2.  In the Ant view, expand the 'JBossDeployUtil' build and select the 'rebuildCluster' target.
	__3.  Press the green "Run" button in the toolbar of the Ant view.  This will run the 'rebuildCluster' target which is not the default target.
	__4.  Once the build is complete look in the Console view again and see that you see the sequence of Ant tasks that rebuilt the cluster configuration from scratch.  Pay particular attention to the 'delete' tasks that you added.
	__5.  Open a terminal window or use an existing one and switch to the <LAB_FILES>/Cluster folder.
	__6.  Run the following command to start the first server.  Wait for it to start completely.  Make sure there are no errors during startup.
	__7.  After the first server has started completely, open a second terminal window and switch to the <LAB_FILES>/Cluster folder.
	__8.  Run the following command to start the second server.  Wait for it to start completely and check there are no errors during startup.
	__9.  Close all open browsers.
	__10.  Open a web browser to the OnlineStore application at http://localhost/Store
	__11.  Login as an existing user.
	__12.  Click the link to Find Purchases.
	__13.  Fill in a user that has placed orders and press the Find button.  
	__14.  Click the link for Request Email.  This is the function that will send a JMS message.
	__15.  Click the Request button and note the results you get.  You should get the normal output no matter which node processed your request.  
	
	__16.  If you want you can use the JK Status application at http://localhost/jkstatus/ to check which server is processing requests and test that if you stop that server or force the browser to use the other server by deleting the cookies you will get a normal response on both servers.
	__17.  Stop both of you servers.
	__18.  Close Eclipse and any extra web browsers or other windows you have open.

	Part 7 -  Summary




