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Lab 1 - Basic Mediation Flow Development
In this lab, we will develop a very simple mediation flow. A mediation flow can be used 
to implement most ESB patterns. We will not get into pattern implementation just yet. 
Our focus will be to learn the basics of development and testing using WID. We will also 
get to see a very simple mediation flow in action.

A mediation flow always acts as an intermediary between an actual service provider and 
consumer. To the consumer, the mediation flow appears as the service provider. To the 
provider, the mediation flow is the consumer. The true consumer is decoupled from the 
true provider.

In this lab, we will use a Java class as the service provider. Java class based service 
providers are quicker to develop compared to web services. They are great for testing.

We will not develop any consumer application. Instead, we will use the universal test tool 
to invoke methods of the mediation flow.

The business logic for the service will be very simple. It will have a method called 
sayHello. It will accept as input a string. It will return a greeting message as string. From 
a Java point of view, the method will look like this:

String sayHello(String name)

The business logic is kept intentionally simple so you can focus on the mechanisms of 
software development and testing using WID. Later labs will assume that you know these 
skills and avoid giving detail instructions.

Part 1 - Launch WID
__1. From the Windows Start menu select All Programs > IBM WebSphere 
Integration Developer > IBM WebSphere Integration Developer V6.2 > WebSphere 
Integration Developer V6.2.

__2. When prompted to select a workspace, enter C:\workspace

3

Mediation Flow
(ESB)

Hello World
ServiceConsumer

EVALUATIO
N O

NLY



__3. Click OK.

WID may show the welcome screen.

__4. Close the welcome screen if opens.

By default, WID puts you in the Business Integration perspective. (You can always see 
the name of the perspective in the title bar). Most SCA based development can be done 
from this perspective. For J2EE and other types of development, we will switch the 
perspective to something else.

Part 2 - Create a Mediation Module
SCA development can happen in two types of projects – Module and Mediation Module. 
A Mediation Module only allows you to create artifacts, such as mediation flow, that can 
be deployed in WebSphere ESB. A Module, on the other hand, allows you to create all 
artifacts that can be deployed in WebSphere Process Server. For example, a BPEL 
business process can only be created in a Module. A mediation flow can be created in 
either of the two projects.

Tip: If your target server runtime is WebSphere ESB, you should always use the 
Mediation Module project. This will prevent you from creating an artifact that can not 
be deployed in WebSphere ESB.

__1. From the menubar, select File > New > Mediation Module.

__2. Enter the following values:

Module name: SimpleModule

Target runtime server: WebSphere ESB Server v6.2. Important: By default 
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WebSphere Process Server is selected. Make sure you change it to ESB.

Create mediation component: Uncheck. This adds a dummy component to the 
assembly diagram without any implementation. This is more of an inconvenience than 
helpful. So we uncheck it.

Open module assembly diagram: Uncheck. We will not work with the assembly 
diagram yet. So, uncheck this option.

__3. Click Finish.

__4. WID will create the mediation module. In the Business Integration view, under the 
Projects section, verify that SimpleModule is shown.

Part 3 - Study the Project Structure
We will now observe how exactly a mediation module project is represented on the file 
system.

__1. From the menubar, select Window > Open Perspective > Other.

__2. Select Java EE.

__3. Click OK.
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__4. Notice, three projects have been created:

These projects are as follows.

Project Remarks

SimpleModule This is a plain Java project that represents the actual 
mediation module. All SCA artifacts, like mediation flow 
and data transformation maps, are created here.

SimpleModuleApp This is a J2EE enterprise application project. This is what 
gets deployed to the server as an EAR file. The EAR file 
includes the mediation module Java project as a JAR file.

SimpleModuleEJB This is a EJB module project. For the SCA artifact, various 
EJBs are generated here.

By default, WID generates this code every time you save a 
change to an artifact's file. You should not develop any code 
here since this project can be overwritten by WID at any 
time.

This module is included in the application EAR as a JAR 
file.

__5. Close the Java EE perspective by selecting Window > Close Perspective.

Part 4 - Create a Service Interface
Every SCA service must support one or more interfaces. A service interface is a 
collection of operations. SCA uses WSDL portType to define interfaces. You could also 
use Java interface for that purpose. But, in SOA, vendor and language neutral WSDL is 
always recommended.

We will now create the interface for our very simple mediation flow. recall, it has only 
one operation that looks like this:

String sayHello(String name)

__1. Right click Interfaces and select New > Interface.
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__2. Enter Greeting as the name of the interface.

Note that the namespace defaults to http://SimpleModule/Greeting. We will leave it that 
way. In real life, your organization needs to strictly control the namespace. In that case, 
you need to specify the correct namespace.

__3. Click Finish.

WID will create the interface and open it in the editor.

__4. In the editor, click the Add Request Response Operation toolbar icon to add a new 
operation.

Make the following changes:

__5. Change the name of the operation to sayHello

__6. Change the name of the input parameter to name 

__7. Change the name of the output parameter to message

__8. Save and close the editor.
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Part 5 - Create the Mediation Flow
Our mediation flow will conform to the service interface we have defined in the previous 
part.

__1. Right click Integration Logic and select New > Mediation Flow.

__2. Enter GreeterFlow as the name.

__3. Click Next.

As the source interface, you will add the Greeting interface we have defined previously. 
The source interface is what the mediation flow offers to its consumers.

__4. Click the Add button for Sources interfaces.

__5. The Greeting interface should be selected, just click OK.

The sources interfaces will be updated.

As the target interface, also add the Greeting interface. The actual service provider 
supports this interface.

__6. Click the Add button for Target references.

__7. The Greeting interface should be selected, just click OK.

The target references will be updated.

The source and target interface does not have to be the same. In fact, the data translation 
pattern of ESB requires that they be different. In that case, the actual service consumer 
and provider support different service interfaces. The mediation flow acts as the bridge. 
We will see the implementation of this pattern in a lab later.

__8. Click Finish. WID will create the mediation flow and open it in the editor.

Part 6 - Design the Mediation Flow
Our mediation flow will be the simplest kind. There will be no mediation primitive in the 

8

EVALUATIO
N O

NLY



message flow. We will simply pass the input message straight to the service provider. 
Similarly, the response from the service provider will be sent back to the consumer.

__1. At the top of the editor, you will see two interfaces.

On the left hand side, we see the source interface. On the right hand side, we see the 
partner reference. The partner reference is a place holder for the actual service provider.

When a consumer calls the sayHello operation of the source interface, we will like the 
mediation flow to call the sayHello operation of the service provider. As a result, we need 
to connect to two operations.

__2. Move the mouse pointer over the sayHello operation of the source interface. A 
yellow lollipop will be shown.

__3. Drag the lollipop and drop it on the sayHello operation of the target interface. This 
will connect the two.

Note: Two connected operations can have different names and completely different 
input and output data types. In that case, data and interface translation is applied within 
the mediation flow.

We will now design the request and response message flows for the sayHello source 
operation.

__4. Select the sayHello operation in the source interface.

__5. At the bottom pane, you will notice two tabs – Request: sayHello and Response: 
sayHello.

These tabs are used to switch the editor between request and response flow design.

Note: For one-way operations, there is no response message. In that case, the response 
flow tab is not shown.

__6. Click the Request: sayHello tab to make sure that the request flow design is open.
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__7. Connect the output terminal of sayHello : Greeting (the source interface) to the 
input terminal of sayHello : GreetingPartner.

This creates a very simple passthrough message flow. Later, we will learn how to add 
mediation primitives in that flow to solve complex problems.

__8. Click the Response: sayHello tab to open the response flow design.

__9. Connect the output terminal of sayHello : GreetingPartner (the target interface) to 
the input terminal of sayHello : Greeting.  Make sure you select the pointed output 
terminal of the GreetingPartner and not the rectangular fail terminal.

That means, the output from the service provider is passed as is to the consumer.

__10. Save and close the editor.

__11. Open the Problems view and expand Warnings. You should notice a warning 
about "A direct connection exists from the mediation input to output." This is fine for our 
very simple mediation flow.

There should be no error messages.

Part 7 - Create Service Provider
We will now implement the actual service provider. According to our design, it conforms 
to the Greeting service interface.

__1. Double click Assembly Diagram to open it.

__2. Right click the white area of the editor and select Add > Java.

__3. Change the name of the Java component to GreeterBean
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__4. Right click the component and select Add > Interface.

__5. Select the Greeting interface and click OK.

__6. Right click the component again and select Generate Implementation.

__7. Click New Package.

__8. Enter com.webage.greet as the package name.

__9. Click OK to create the package.

__10. Click OK to select the new package for the implementation.

WID will create a class called com.webage.greet.GreaterBeanImpl and open it in the 
editor.

__11. Change the implementation of the sayHello method as follows.

public String sayHello(String name) {
System.out.println("Saying hello to: " + name);

return "Hello " + name;
}

__12. Save all files (Control+Shift+S).

Note: In this case, our Java class is implementing a service interface which is defined in 
a WSDL file. This is a unique feature of SCA. SCA uses a strict pattern where a service 
implementation, no matter how it is implemented, must support a WSDL based 
interface. In this case, the implementation is a Java class.

__13. Close the Java editor.

Part 8 - Wire the Components
Our mediation flow has a reference partner which is a placeholder for the actual service 
provider. We must wire that reference partner to the Java based service provider we have 
created above.

__1. Make sure that the assembly diagram is still open. If not open it.

__2. Drag the GreeterFlow mediation flow on to the diagram.
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__3. Hover the mouse over the reference partner of the mediation flow and a lollipop will 
open up.

__4. Drag the lollipop and drop it over the interface of the Java implementation. This will 
connect the two as shown below.

__5. Save changes.

Part 9 - Deploy the Application to Server
__1. Open the Servers view.

__2. Right click WebSphere ESB Server v6.2 at localhost and select Start.

The Server Logs view will open showing some messages.

Finally the Server changes to Started.

__3. Right click the server again and select Add Remove Projects...
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__4. Click Add All.

__5. Click Finish.

__6. WID will start publishing the application files. Wait for the status of the server to 
change to Synchronized.

Part 10 - Test the Application
We will test the application by invoking the sayHello operation exposed by the mediation 
flow. We will use the built-in test client for that.

__1. Make sure that the server status is Synchronized before doing any test.

__2. Open the assembly diagram if it is not open.

__3. Right click any white area of the assembly diagram and select Test Module.

WID will open the test client page.

__4. In the test client page, under Detailed Properties, set the Component to 
GreeterFlow. That means, the test client will invoke the operations of the mediation 
flow.

__5. Verify that the sayHello operation is selected since that is the only operation 
available from the interface.

__6. In the Initial request parameters table, set the value of the name parameter to 
something.

__7. Under Events click the Continue toolbar button to invoke the operation.

__8. In the Deployment Location dialog, expand WebSphere ESB Server v6.2 and 
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select WebSphere ESB Server v6.2 at localhost. 

__9. Also, check Use this as the default and do not ask again.

Note: Here, WID is trying to deploy a special application (TestController62) that is used 
by the test client to carry out testing.

__10. Click Finish.

__11. Check the checkbox to always use the same authentication settings and click OK in 
the User Login dialog. 

Security is enabled for the server. This is where the administrative user ID and password 
is entered. Without a valid password, publishing will fail.

__12. After the test ends, the Return parameters table will show the reply.
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__13. Open the Server Logs view. At the very bottom, the output from the Java 
component will be shown.

__14. Close the test page without saving.

Part 11 - Configure Build Activities
Every time you change an SCA artifact file or assembly diagram, WID performs a build. 
As a part of the build, three things have to happen. 

1. Validate the changes made.

2. Generate new code and compile them.

3. Publish updated files to the server.

You can configure how many of these three steps are performed automatically.

__1. Open the Build Activities view.

Note that by default Validate and update deploy code is selected. Here, "update 
deployed code" is referring to code generation.

That means, updated files are not published to the server by default after a build. You can 
click on the Update Running Servers button to do that. Many of the changes will be 
picked up by the server after files are published. In a few rare cases, we have to restart the 
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server.

__2. Close all open files. (Ctrl+Shift+W)

Part 12 - Review
In this lab, we created a very simple mediation flow. During testing, we invoked the 
sayHello operation of the mediation flow. The flow, in turn, invoked the sayHello 
operation of the reference partner. The partner was wired to a Java implementation. As a 
result, the sayHello method of the Java class got invoked.

The response from the service provider Java class was returned back to the test client.

A few things to remember from this lab:

1. Every mediation flow has a source interface and one or more target interface.

2. For each target interface, a reference partner is defined in the mediation flow.

3. A method from the source interface is connected to one or more methods of the 
target interfaces.

4. For each source method, you need to design the request and response flow.

5. Every reference partner needs to be wired to an actual service implementation (or 
an import if the implementation exists outside the module).
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Lab 2 - Using Mediation Primitives
In the previous lab we have not used any mediation primitive in the request or response 
flow. In this lab, we will add the message logger primitive. This primitive can save a 
message in a file or database.

Now, for the first time, our mediation flow will begin to offer some real value. In this 
case, we are essentially implementing the audit logging pattern. A part of the ESB 
pattern, audit logging pattern saves request and response messages for latter retrieval.

Part 1 - Add Primitive to Request Flow
__1. Open GreeterFlow mediation flow in the editor by double clicking on it.

__2. Select sayHello operation in the source interface. This will open the message flow in 
the editor.

__3. In the bottom pane, for the request message flow, select the connection between 
sayHello : Greeting and sayHello : GreetingPartner.

__4. Press the delete key to remove the connection.

__5. On the left hand side of the editor, expand the Tracing section.

__6. Drag and drop the Message Logger primitive on the editor.

__7. Connect the output terminal of sayHello : Greeting to the input terminal of 
MessageLogger1 as shown below.

17

EVALUATIO
N O

NLY



__8. Connect the output terminal of MessageLogger1 to the input terminal of sayHello : 
GreetingPartner.

This means, the request message will first go inside the logger primitive. This primitive 
does not alter the message in any way and outputs the same message that came in as 
input. The output of the logger is then fed into the reference partner as input.

Now, we will configure the logger.

__9. Select MessageLogger1.

__10. Open the Properties view.

__11. Select the Details tab.

__12. Change the Logging type from Database to Custom.

Note: By default, a logger saves messages in a database. The database is pointed to by 
the Data source name property. The default data source name is 
jdbc/mediation/messageLog. This points to a cloudscape (Derby) database where the 
necessary schema is already defined. Alternatively, you can point message logger to a 
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DB2 or Oracle database.

If you set the logging type to custom, then the logger saves the messages in a file.

Part 2 - Add Primitive to Response Flow
__1. At the bottom of the editor, click the Response: sayHello tab to switch to the 
response flow.

__2. Follow the steps in the previous part to insert a logger primitive in the flow.

__3. Change the logging type of the logger to custom.

__4. Save the mediation flow.

Part 3 - Publish Changes
__1. Open the Build Activities tab.

__2. Click Update Running Servers.

__3. Check the 'Do not show this dialog again' box and press the Publish button.
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The server will start publishing, wait until is done.

Part 4 - Test
__1. Open the assembly diagram.

__2. Right click the white area and select Test Module.

__3. Set the component to GreeterFlow.  It may default to GreeterBean but this would 
not test the whole flow.

__4. Enter a name in the input table.

__5. Click the Continue toolbar button under Events.

__6. Close the test without saving it.

We will now inspect the messages saved in the log files. Messages are saved in the folder 
pointed to by the TEMP environment variable (both in Windows and UNIX).

__7. Open a command prompt window.

__8. Enter the following command:

cd  /d  %TEMP%
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__9. List all message log files:

dir  *.log

__10. You should notice these two log files.

• MessageLog0.log – Contains request messages.

• MessageLog1.log – Contains response messages.

__11. View the request message as follows.

type  MessageLog0.log

__12. Similarly, view the response message in MessageLog1.log.

__13. Close the Command prompt window.

__14. Back in WID, close all open files.

Part 5 - Review
In this lab, we implemented the audit logging pattern. Note, how the pattern can be used 
to audit log a service without changing the service implementation. Now, you are 
beginning to see some of the advantages of using an ESB as an intermediary. 
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Lab 3 - Create Business Objects
Business objects represent the data that's passed between service components in your 
SCA modules.  When you create interfaces (WSDL or Java) for your components, which 
you'll do in the next lab, the input and output parameters correspond with business 
objects.  Business objects are defined using XML Schema Definition (XSD) files.  

WebSphere ESB and Process Server uses the Service Data Object (SDO) API to work 
with business objects. Specifically, the commonj.sdo.DataObject interface represents a 
data object.

Business objects can store both simple attributes (e.g., string, int, double, boolean) and 
complex attributes (i.e., other business objects).  An attribute can be multi-valued, which 
means it can be stored as an array.  

In this lab, you will create several business objects.  Specifically, you will create 
Customer, Address, Order, and OrderItem business objects which are inter-related.  A 
Customer can have multiple Orders.  An Order can have multiple OrderItems.  An Order 
can also have a shipping address and billing address, both of which are of type Address.

Following this exercise, you should be able to:
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● Create a default namespace.

● Create a business integration module.

● Create business objects using the Business Object Editor.

● View the physical files created by WID

Part 1 - Create a Default Namespace
Namespaces are used in XML to uniquely identify XML elements and attributes.  They 
help prevent collisions between elements and attributes with the same names. 
Namespaces are analogous to Java packages which uniquely identify class names.  When 
creating an XML schema, a target namespace is specified.  All elements and attributes 
defined in the schema belong to that target namespace.

In this part, you will create a default namespace that's used when creating business 
objects and other kinds of XML artifacts.  Namespaces typically correspond with a URI 
(usually a URL), since they must be unique and URIs are unique.  You will set the default 
namespace to http://www.webagesolutions.com.  Normally, you would set it to your 
company's URL.

__1. Select Window->Preferences from the menu bar.

__2. In the left pane, expand Business Integration and select Default Namespace.

__3. In the right pane, click the New button to create a new default namespace.

__4. Type Corporate Default in the Name field and www.webagesolutions.com in the 
Pattern field.

__5. Click OK to create the namespace.
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__6. Click OK to close the preferences.

Part 2 - Create a Business Integration Module
In this part, you will create a business integration module (module for short) for storing 
your business objects. 

__1. Select File > New > Mediation Module from the menu bar.  

__2. Enter CustomerOrder for the Module Name.

__3. Uncheck Create mediation component.

__4. Uncheck Open module assembly diagram.

__5. Click Finish.  The CustomerOrder project should appear in the Business 
Integration view.

Part 3 - Create the Customer Business Object 
In this part, you will create the Customer business object using the Business Object 
Editor.  You will add simple fields to it, such string, boolean, and int.  You will also see 
how you can specify metadata for the fields, including whether or not its required, has 
enumerated values and/or matches a pattern.

__1. In the Business Integration view, under the CustomerOrder module, right click 
Data Types and select New > Business Object.

__2. Notice that the Namespace field is pre-populated with the default you set earlier: 
http://www.webagesolutions.com.  

__3. Enter Customer in the Name field.
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__4. Click Finish.

The Customer business object will be created and should automatically be opened inside 
the Business Object Editor.

__5.  Now let's define our Customer business object.  Select the Customer object.  Then 
click the field icon (F in a blue circle) to add a field to the business object.  A field called 
field1 should be added to the Customer object of type string.
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__6. Click on field1 and rename it customerId.  You will need to hit <ENTER> to accept 
the new name before you can make other changes.

__7. Click on string and select int from the drop-down.

__8. Using the procedure above, add the following fields:

Name Type

customerType string

active boolean

firstName string

lastName string

homePhone string

workPhone string

Your business object should look as follows:
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__9. Save your changes.

__10. Since the customerId uniquely identifies a customer, it should be required.  To 
specify this, right click on customerId and select Show in Properties from the menu.  

__11. The Properties view should appear at the bottom of WID.  Click the Required 
checkbox.

__12. It's also possible to specify that a field can only contain certain values using the 
enumerations feature.  For example, the customerType can only be set to the values 
silver, gold, or platinum.  Click on the customerType field in the Business Object Editor. 

__13. In the Properties view, check the Only permit certain values checkbox.  

__14. Then, click the Enumerations radio button.
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__15. By default, a single entry named value appears in the list box.  Click the Edit 
button and rename it as silver.  If the value is already highlighted you may not need to 
click the Edit button.

__16. Click the Add button and rename the value entry as gold

__17. Likewise, add the entry platinum

__18. You can also specify a regular expression pattern that a field must match when 
being input.  The homePhone and workPhone fields should be entered in the format: xxx-
xxx-xxxx.  To accomplish this, click on the homePhone field in the Business Object 
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Editor.  

__19. In the Properties view, check the Only permit certain values checkbox.  

__20. Then, click the Patterns radio button.

__21. In the Regular Expression Wizard dialog, select Digit ( \d ) from the Token 
contents drop-down.  

__22. Then, click the Repeat radio button and type 3 in the text field to the right of it.  

__23. Then click the Add button.  

The Current Regular Expression field should now show \d{3} which means the user 
needs to type in 3 digits for the phone number.  We're not done yet.

__24. Type a dash (-) next to \d{3} in the Current regular expression field.

__25. Click the Add button again to append \d{3} to the regular expression. 

__26. Type another dash (-) next to \d{3}-\d{3} in the Current regular expression field. 

__27. Change the Repeat value from 3 to 4 and click Add again.  Voila!  Your regular 
expression is complete.
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__28. WID also allows you test your regular expression to make sure you input it 
correctly.  To do so, click the Next button.  

__29. In the Sample text field, enter 123-456-7890  

__30. The message The text matches the regular expression should appear at the top of 
the dialog.

Try entering an wrongly formatted phone number.

__31. Click Finish.

__32. Repeat the process for the workPhone. 

__33. Save your changes.

__34. Close the file.

Part 4 - Create the Address Business Object 
Up until this point, you've created fields having only simple data types.  It's also possible 
to create fields having complex data types.  The complex data types are themselves other 
business objects.  For example, an Order, which you will be creating shortly, has a 
shipping address and a billing address.  Since an Order has multiple addresses rather than 
just one, it's recommended to create another business object called Address, instead of 
simply adding address fields to the Order business object.  In this part, you'll create the 
Address business object.  

__1. In the Business Integration view, right click on Data Types under CustomerOrder 
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and select New > Business Object.

__2. Type Address in the Name field.  

__3. Click Finish.

The Address business object will be created and should automatically be opened inside 
the Business Object Editor.

__4. Enter the following fields:

Name Type Required

addressId int X

street1 string

street2 string

city string

state string

zip string

country string

name string
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Your business object should look as follows:

Note

You added a name field to Address, since a customer may have an order shipped to an 
address where she doesn't live.  The name would correspond with the name of the 
person who lives at that address. 

__5. Save your changes.

__6. Close the file.

Part 5 - Create the Order and OrderItem Business Objects
In this part, you'll create the Order business object.  You'll use the Address business 
object you created in the last part when declaring the shippingAddress and billingAddress 
fields.  You'll also add an orderItems field to the Order business object.  When declaring 
the orderItems field, you'll create an OrderItem business object on the fly, since an order 
can consist of multiple order items.  Afterwards, you'll complete the Customer business 
object by adding a field called orders to it of type Order.  Since both orderItems and 
orders are multi-valued, you'll declare them as arrays.  

When you create a business object on the fly (e.g., OrderItem) when defining the parent 
business object, this is referred to as a top-down based approach to business object 
development.  On the other hand, when you create the business object in advance (e.g., 
Address and Order), this is referred to as a bottom-up based approach to business object 
development.  Both approaches are valid.

__1. In the Business Integration view, right click on Data Types under CustomerOrder 
and select New > Business Object.
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__2. Type Order in the Name field.  

__3. Click Finish.

__4. The Order business object will be created and should automatically be opened 
inside the Business Object Editor.  Enter the following fields:

Name Type Required

orderId int X

orderDate date

shippingAddress Address

billingAddress Address

__5. When specifying the Address type, you'll need to scroll to the bottom of the type 
drop-down, since that's where all business objects are located.

Your business object should look as follows:

Notice that Address was added to the diagram and two arrows were drawn between 
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Order and Address showing the parent-child relationship between the two business 
objects.  

__6. Click on the plus (+) sign next to Address to expand it and see its fields.  Use the 
bottom arrow to scroll through its fields.  

Also, notice that you can't edit any of Address's fields.  To edit Address, you can simply 
double click on Address and it will open up in the Business Object editor.

__7. Return to the business object editor showing the Order business object if you are 
not there already.  

__8. Add another field named orderItems

__9. This time, when specifying the data type, click the New... option in the drop-down. 
It's located at the top of the drop-down.

__10. In the New Business Object dialog, type OrderItem in the Name field and click 
Finish.  

The OrderItem business object will be created and should automatically be opened 
inside the Business Object Editor.  

__11. For the OrderItem business object, enter the following fields:

Name Type Required

itemId int X

description string

quantity int

price float

__12. Your business object should look as follows:
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__13. Save your changes and close the OrderItem file.

__14. Back in the Order Business Object Editor, specify that an Order can have more 
than one OrderItem by clicking on the orderItems field.  

__15. In the Properties view, check Array.

Notice that a set of square brackets ([ ]) now appears to the right of orderItems 
indicating that it contains an array of OrderItem business objects.

__16. Save your changes and close the file.

__17. Last but not least, open the Customer business object.

__18. Add a field to the Customer business object named orders of type Order.  You 
may need to click the Customer business object in the editor to select it first.

__19. Declare the field as an array.
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Note

WID allows you to view business objects only one level deep.  Consequently, you can't 
view OrderItem in the Customer's Business Object Editor.

__20. Save your changes.

__21. It's also possible to display the Customer business object in a tabular format.  To do 
so, click on the icon on the far right of the editor toolbar.

__22. Now you're in the table view.  In addition to displaying the field names and data 
types for the business object and its children, the table view displays their default values 
(if any) and multiplicity (number of minimum occurrences and maximum occurrences).   

Also observe the following:

● customerId has a Min Occurs and Max Occurs both set to 1.  This means that it 
must have one and only one value, since we declared it as a required field.

● orders has a Min Occurs set to 0 and a Max Occurs set to unbounded.  This 
means that a Customer can have 0 or more orders.  These values are used when 
specifying arrays.  Likewise, orderItems has a Min Occurs set to 0 and a Max 
Occurs set to unbounded, since it's also an array.

● All of the other attributes have a Min Occurs of 0 and Max Occurs of 1, which 
means they're optional fields (as opposed to required fields).
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__23. Switch back to the diagram view by clicking on the icon on the far right of the 
editor toolbar.  Notice the icon has changed.

__24. Close all open files.  Save if there are any unsaved changes.

Congratulations!  You've successfully created a hierarchy of business objects.

Part 6 - View the Physical Files
In this part, you'll see the files that get created behind the scenes when you create a 
business object.  Specifically, you'll see that an XML schema definition (XSD) was 
created for each business object. 

WID tries to keep things as "logical" as possible to make things easier on the integration 
developer, since he/she is only required to have basic programming skills (knows how to 
create loops, conditionals, and perform string manipulation).  WID provides graphical 
editors wherever possible to simplify and abstract complex programming details.  

__1. In the Business Integration view, right click on the CustomerOrder module and 
select Show Files.

__2. WID will open the Physical Resources view and stack it on top of the Business 
Integration view.  Notice that the business objects you created are located directly 
underneath the CustomerOrder project and correspond with XSDs (can tell based on the 
file extension).

Note

In a future lab, you will begin to use folders when creating business objects and other 
kinds of SCA artifacts, so that the resulting files are better organized.  This is especially 
important when creating larger projects.
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__3. Double click on Customer.xsd.  Notice that WID still opens it with the Business 
Object Editor.  

__4. To change this behavior, close the file.  Then right click on it and select Open With-
>Text Editor from the menu.  WID will now open it with a text editor so you can view 
the actual XML.  

Notice the following:

● The targetNamespace attribute is set to http://www.webagesolutions.com, 
which is the default namespace we set at the beginning of the lab.

● The XML schema file Order.xsd is included so the Customer XSD can reference 
the Order element.

● Customer is declared as a complex type, since it contains child elements 
(correspond with the fields we declared).

● The Max Occurs and Min Occurs columns you saw earlier in the Business Object 
Editor's table view correspond with the maxOccurs and minOccurs XSD 
attributes.

<?xml version="1.0" encoding="UTF-8"?>
<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
   targetNamespace="http://www.webagesolutions.com"
   xmlns:bons1="http://www.webagesolutions.com">
   <xsd:include schemaLocation="Order.xsd"></xsd:include>
   <xsd:complexType name="Customer">
      <xsd:sequence>
         <xsd:element minOccurs="1" name="customerId"
            type="xsd:int">
         </xsd:element>
         ...
      </xsd:sequence>
   </xsd:complexType>
</xsd:schema>
__5. Close the file.

Note

You could have also opened the file with the full XML Schema editor.  We opened it 
with the text editor just to see the contents easily.

__6. The Customer.xsd file will automatically be opened with the text editor from this 
point forward unless you change it back to open with the Business Object Editor.  To 
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change this, right click on the file and select Open With > Business Object Editor.  

__7. Close the Business Object Editor.  

__8. Switch back to the Business Integration view.

Part 7 - Review
In this lab, you set a default namespace within WID for any XML files you create.  Next, 
you created four inter-related business objects:  Customer, Address, Order, and 
OrderItem.  Business objects are used to represent data in a SOA.  The business objects 
get passed to and fro between service components when they communicate with one 
another by invoking each other's operations.  You used the Business Object Editor, which 
is quite powerful, to create the business objects.  You also switched to the Physical 
Resources view and saw that WID creates XML schema files behind the scenes to 
represent the business objects.
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	Lab 1 -  Basic Mediation Flow Development
	Part 1 -  Launch WID
	__1.  From the Windows Start menu select All Programs > IBM WebSphere Integration Developer > IBM WebSphere Integration Developer V6.2 > WebSphere Integration Developer V6.2.
	__2.  When prompted to select a workspace, enter C:\workspace
	__3.  Click OK.
	__4.  Close the welcome screen if opens.

	Part 2 -  Create a Mediation Module
	__1.  From the menubar, select File > New > Mediation Module.
	__2.  Enter the following values:
	__3.  Click Finish.
	__4.  WID will create the mediation module. In the Business Integration view, under the Projects section, verify that SimpleModule is shown.

	Part 3 -  Study the Project Structure
	__1.  From the menubar, select Window > Open Perspective > Other.
	__2.  Select Java EE.
	__3.  Click OK.
	__4.  Notice, three projects have been created:
	__5.  Close the Java EE perspective by selecting Window > Close Perspective.

	Part 4 -  Create a Service Interface
	__1.  Right click Interfaces and select New > Interface.
	__2.  Enter Greeting as the name of the interface.
	__3.  Click Finish.
	__4.  In the editor, click the Add Request Response Operation toolbar icon to add a new operation.
	__5.  Change the name of the operation to sayHello
	__6.  Change the name of the input parameter to name 
	__7.  Change the name of the output parameter to message
	__8.  Save and close the editor.

	Part 5 -  Create the Mediation Flow
	__1.  Right click Integration Logic and select New > Mediation Flow.
	__2.  Enter GreeterFlow as the name.
	__3.  Click Next.
	__4.  Click the Add button for Sources interfaces.
	__5.  The Greeting interface should be selected, just click OK.
	__6.  Click the Add button for Target references.
	__7.  The Greeting interface should be selected, just click OK.
	__8.  Click Finish. WID will create the mediation flow and open it in the editor.

	Part 6 -  Design the Mediation Flow
	__1.  At the top of the editor, you will see two interfaces.
	__2.  Move the mouse pointer over the sayHello operation of the source interface. A yellow lollipop will be shown.
	__3.  Drag the lollipop and drop it on the sayHello operation of the target interface. This will connect the two.
	__4.  Select the sayHello operation in the source interface.
	__5.  At the bottom pane, you will notice two tabs – Request: sayHello and Response: sayHello.
	__6.  Click the Request: sayHello tab to make sure that the request flow design is open.
	__7.  Connect the output terminal of sayHello : Greeting (the source interface) to the input terminal of sayHello : GreetingPartner.
	__8.  Click the Response: sayHello tab to open the response flow design.
	__9.  Connect the output terminal of sayHello : GreetingPartner (the target interface) to the input terminal of sayHello : Greeting.  Make sure you select the pointed output terminal of the GreetingPartner and not the rectangular fail terminal.
	__10.  Save and close the editor.
	__11.  Open the Problems view and expand Warnings. You should notice a warning about "A direct connection exists from the mediation input to output." This is fine for our very simple mediation flow.

	Part 7 -  Create Service Provider
	__1.  Double click Assembly Diagram to open it.
	__2.  Right click the white area of the editor and select Add > Java.
	__3.  Change the name of the Java component to GreeterBean
	__4.  Right click the component and select Add > Interface.
	__5.  Select the Greeting interface and click OK.
	__6.  Right click the component again and select Generate Implementation.
	__7.  Click New Package.
	__8.  Enter com.webage.greet as the package name.
	__9.  Click OK to create the package.
	__10.  Click OK to select the new package for the implementation.
	__11.  Change the implementation of the sayHello method as follows.
	__12.  Save all files (Control+Shift+S).
	__13.  Close the Java editor.

	Part 8 -  Wire the Components
	__1.  Make sure that the assembly diagram is still open. If not open it.
	__2.  Drag the GreeterFlow mediation flow on to the diagram.
	__3.  Hover the mouse over the reference partner of the mediation flow and a lollipop will open up.
	__4.  Drag the lollipop and drop it over the interface of the Java implementation. This will connect the two as shown below.
	__5.  Save changes.

	Part 9 -  Deploy the Application to Server
	__1.  Open the Servers view.
	__2.  Right click WebSphere ESB Server v6.2 at localhost and select Start.
	__3.  Right click the server again and select Add Remove Projects...
	__4.  Click Add All.
	__5.  Click Finish.
	__6.  WID will start publishing the application files. Wait for the status of the server to change to Synchronized.

	Part 10 -  Test the Application
	__1.  Make sure that the server status is Synchronized before doing any test.
	__2.  Open the assembly diagram if it is not open.
	__3.  Right click any white area of the assembly diagram and select Test Module.
	__4.  In the test client page, under Detailed Properties, set the Component to GreeterFlow. That means, the test client will invoke the operations of the mediation flow.
	__5.  Verify that the sayHello operation is selected since that is the only operation available from the interface.
	__6.  In the Initial request parameters table, set the value of the name parameter to something.
	__7.  Under Events click the Continue toolbar button to invoke the operation.
	__8.  In the Deployment Location dialog, expand WebSphere ESB Server v6.2 and select WebSphere ESB Server v6.2 at localhost. 
	__9.  Also, check Use this as the default and do not ask again.
	__10.  Click Finish.
	__11.  Check the checkbox to always use the same authentication settings and click OK in the User Login dialog. 
	__12.  After the test ends, the Return parameters table will show the reply.
	__13.  Open the Server Logs view. At the very bottom, the output from the Java component will be shown.
	__14.  Close the test page without saving.

	Part 11 -  Configure Build Activities
	__1.  Open the Build Activities view.
	__2.  Close all open files. (Ctrl+Shift+W)

	Part 12 -  Review

	Lab 2 -  Using Mediation Primitives
	Part 1 -  Add Primitive to Request Flow
	__1.  Open GreeterFlow mediation flow in the editor by double clicking on it.
	__2.  Select sayHello operation in the source interface. This will open the message flow in the editor.
	__3.  In the bottom pane, for the request message flow, select the connection between sayHello : Greeting and sayHello : GreetingPartner.
	__4.  Press the delete key to remove the connection.
	__5.  On the left hand side of the editor, expand the Tracing section.
	__6.  Drag and drop the Message Logger primitive on the editor.
	__7.  Connect the output terminal of sayHello : Greeting to the input terminal of MessageLogger1 as shown below.
	__8.  Connect the output terminal of MessageLogger1 to the input terminal of sayHello : GreetingPartner.
	__9.  Select MessageLogger1.
	__10.  Open the Properties view.
	__11.  Select the Details tab.
	__12.  Change the Logging type from Database to Custom.

	Part 2 -  Add Primitive to Response Flow
	__1.  At the bottom of the editor, click the Response: sayHello tab to switch to the response flow.
	__2.  Follow the steps in the previous part to insert a logger primitive in the flow.
	__3.  Change the logging type of the logger to custom.
	__4.  Save the mediation flow.

	Part 3 -  Publish Changes
	__1.  Open the Build Activities tab.
	__2.  Click Update Running Servers.
	__3.  Check the 'Do not show this dialog again' box and press the Publish button.

	Part 4 -  Test
	__1.  Open the assembly diagram.
	__2.  Right click the white area and select Test Module.
	__3.  Set the component to GreeterFlow.  It may default to GreeterBean but this would not test the whole flow.
	__4.  Enter a name in the input table.
	__5.  Click the Continue toolbar button under Events.
	__6.  Close the test without saving it.
	__7.  Open a command prompt window.
	__8.  Enter the following command:
	__9.  List all message log files:
	__10.  You should notice these two log files.
	__11.  View the request message as follows.
	__12.  Similarly, view the response message in MessageLog1.log.
	__13.  Close the Command prompt window.
	__14.  Back in WID, close all open files.

	Part 5 -  Review

	Lab 3 -  Create Business Objects
	Part 1 -  Create a Default Namespace
	__1.  Select Window->Preferences from the menu bar.
	__2.  In the left pane, expand Business Integration and select Default Namespace.
	__3.  In the right pane, click the New button to create a new default namespace.
	__4.  Type Corporate Default in the Name field and www.webagesolutions.com in the Pattern field.
	__5.  Click OK to create the namespace.
	__6.  Click OK to close the preferences.

	Part 2 -  Create a Business Integration Module
	__1.  Select File > New > Mediation Module from the menu bar.  
	__2.  Enter CustomerOrder for the Module Name.
	__3.  Uncheck Create mediation component.
	__4.  Uncheck Open module assembly diagram.
	__5.  Click Finish.  The CustomerOrder project should appear in the Business Integration view.

	Part 3 -  Create the Customer Business Object 
	__1.  In the Business Integration view, under the CustomerOrder module, right click Data Types and select New > Business Object.
	__2.  Notice that the Namespace field is pre-populated with the default you set earlier:  http://www.webagesolutions.com.  
	__3.  Enter Customer in the Name field.
	__4.  Click Finish.
	__5.   Now let's define our Customer business object.  Select the Customer object.  Then click the field icon (F in a blue circle) to add a field to the business object.  A field called field1 should be added to the Customer object of type string.
	__6.  Click on field1 and rename it customerId.  You will need to hit <ENTER> to accept the new name before you can make other changes.
	__7.  Click on string and select int from the drop-down.
	__8.  Using the procedure above, add the following fields:
	__9.  Save your changes.
	__10.  Since the customerId uniquely identifies a customer, it should be required.  To specify this, right click on customerId and select Show in Properties from the menu.  
	__11.  The Properties view should appear at the bottom of WID.  Click the Required checkbox.
	__12.  It's also possible to specify that a field can only contain certain values using the enumerations feature.  For example, the customerType can only be set to the values silver, gold, or platinum.  Click on the customerType field in the Business Object Editor.  
	__13.  In the Properties view, check the Only permit certain values checkbox.  
	__14.  Then, click the Enumerations radio button.
	__15.  By default, a single entry named value appears in the list box.  Click the Edit button and rename it as silver.  If the value is already highlighted you may not need to click the Edit button.
	__16.  Click the Add button and rename the value entry as gold
	__17.  Likewise, add the entry platinum
	__18.  You can also specify a regular expression pattern that a field must match when being input.  The homePhone and workPhone fields should be entered in the format: xxx-xxx-xxxx.  To accomplish this, click on the homePhone field in the Business Object Editor.  
	__19.  In the Properties view, check the Only permit certain values checkbox.  
	__20.  Then, click the Patterns radio button.
	__21.  In the Regular Expression Wizard dialog, select Digit ( \d ) from the Token contents drop-down.  
	__22.  Then, click the Repeat radio button and type 3 in the text field to the right of it.  
	__23.  Then click the Add button.  
	The Current Regular Expression field should now show \d{3} which means the user needs to type in 3 digits for the phone number.  We're not done yet.
	__24.  Type a dash (-) next to \d{3} in the Current regular expression field.
	__25.  Click the Add button again to append \d{3} to the regular expression. 
	__26.  Type another dash (-) next to \d{3}-\d{3} in the Current regular expression field.  
	__27.  Change the Repeat value from 3 to 4 and click Add again.  Voila!  Your regular expression is complete.
	__28.  WID also allows you test your regular expression to make sure you input it correctly.  To do so, click the Next button.  
	__29.  In the Sample text field, enter 123-456-7890  
	__30.  The message The text matches the regular expression should appear at the top of the dialog.
	__31.  Click Finish.
	__32.  Repeat the process for the workPhone. 
	__33.  Save your changes.
	__34.  Close the file.

	Part 4 -  Create the Address Business Object 
	Up until this point, you've created fields having only simple data types.  It's also possible to create fields having complex data types.  The complex data types are themselves other business objects.  For example, an Order, which you will be creating shortly, has a shipping address and a billing address.  Since an Order has multiple addresses rather than just one, it's recommended to create another business object called Address, instead of simply adding address fields to the Order business object.  In this part, you'll create the Address business object.  
	__1.  In the Business Integration view, right click on Data Types under CustomerOrder and select New > Business Object.
	__2.  Type Address in the Name field.  
	__3.  Click Finish.
	__4.  Enter the following fields:
	__5.  Save your changes.
	__6.  Close the file.

	Part 5 -  Create the Order and OrderItem Business Objects
	__1.  In the Business Integration view, right click on Data Types under CustomerOrder and select New > Business Object.
	__2.  Type Order in the Name field.  
	__3.  Click Finish.
	__4.  The Order business object will be created and should automatically be opened inside the Business Object Editor.  Enter the following fields:
	__5.  When specifying the Address type, you'll need to scroll to the bottom of the type drop-down, since that's where all business objects are located.
	__6.  Click on the plus (+) sign next to Address to expand it and see its fields.  Use the bottom arrow to scroll through its fields.  
	__7.  Return to the business object editor showing the Order business object if you are not there already.  
	__8.  Add another field named orderItems
	__9.  This time, when specifying the data type, click the New... option in the drop-down.  It's located at the top of the drop-down.
	__10.  In the New Business Object dialog, type OrderItem in the Name field and click Finish.  
	__11.  For the OrderItem business object, enter the following fields:
	__12.  Your business object should look as follows:
	__13.  Save your changes and close the OrderItem file.
	__14.  Back in the Order Business Object Editor, specify that an Order can have more than one OrderItem by clicking on the orderItems field.  
	__15.  In the Properties view, check Array.
	__16.  Save your changes and close the file.
	__17.  Last but not least, open the Customer business object.
	__18.  Add a field to the Customer business object named orders of type Order.  You may need to click the Customer business object in the editor to select it first.
	__19.  Declare the field as an array.
	__20.  Save your changes.
	__21.  It's also possible to display the Customer business object in a tabular format.  To do so, click on the icon on the far right of the editor toolbar.
	__22.  Now you're in the table view.  In addition to displaying the field names and data types for the business object and its children, the table view displays their default values (if any) and multiplicity (number of minimum occurrences and maximum occurrences).   
	__23.  Switch back to the diagram view by clicking on the icon on the far right of the editor toolbar.  Notice the icon has changed.
	__24.  Close all open files.  Save if there are any unsaved changes.

	Part 6 -  View the Physical Files
	__1.  In the Business Integration view, right click on the CustomerOrder module and select Show Files.
	__2.  WID will open the Physical Resources view and stack it on top of the Business Integration view.  Notice that the business objects you created are located directly underneath the CustomerOrder project and correspond with XSDs (can tell based on the file extension).
	__3.  Double click on Customer.xsd.  Notice that WID still opens it with the Business Object Editor.  
	__4.  To change this behavior, close the file.  Then right click on it and select Open With->Text Editor from the menu.  WID will now open it with a text editor so you can view the actual XML.  
	__5.  Close the file.
	__6.  The Customer.xsd file will automatically be opened with the text editor from this point forward unless you change it back to open with the Business Object Editor.  To change this, right click on the file and select Open With > Business Object Editor.  
	__7.  Close the Business Object Editor.  
	__8.  Switch back to the Business Integration view.

	Part 7 -  Review

	Lab 4 -  Create a Service Interface
	Part 1 -  Create an Interface
	__1.  In the Business Integration view, expand CustomerOrder.  
	__2.  Right click on Interfaces and select New > Interface.
	__3.  Type CustomerOrder in the Name field.  Do not press Finish yet.
	__4.  Notice that the Namespace field is pre-populated.  It starts with the default namespace, but it ends with the interface name.  Instead, we only want it set to the default namespace.  (This is the only wizard that appends anything to the default namespace.)  To remedy this, uncheck Default and remove /CustomerOrder. The namespace should now be http://www.webagesolutions.com
	__5.  Click Finish.
	__6.  To create the operation, click the Add Request Response Operation icon in the toolbar (first icon on the left).
	__7.  Click on operation1 and rename it createCustomer
	__8.  Click on input1 and rename it customer
	__9.  Click on string and select Customer from the drop-down.
	__10.  Click on output1 and rename it customerId
	__11.  Click on string and select int from the drop-down.
	__12.  Your operation should look as follows:
	__13.  Similarly, create the findCustomer operation. But as Input use CustomerId as type int and as Output define customer as type Customer. 
	__14.  Your interface should look as follows:
	__15.  Save your changes and close the file.
	__16.  Right click on the CustomerOrder project in the Business Integration view and select Show Files.  Notice that CustomerOrder corresponds with the file CustomerOrder.wsdl.
	__17.   Open CustomerOrder.wsdl as text editor.  Observe the following:
	__18.  Close the file.
	__19.  To reset the file to open with the Interface Editor, right click on the file and select Open With > Interface Editor.
	__20.  Close the file.
	__21.  Switch back to the Business Integration view.

	Part 2 -  Review

	Lab 5 -  Manipulating Business Objects with SDO API
	Part 1 -  Create a Java Component
	__1.  In the Business Integration view, expand the CustomerOrder project and open the Assembly Diagram.
	__2.  Add a Java component to the diagram by clicking on the Java icon in the palette (left side of editor) and clicking inside the assembly diagram.
	__3.  Rename the component CustomerOrder by right clicking on and selecting selecting Rename.
	
	__4.  Drag and drop the CustomerOrder interface from the Business Integration view on top of the CustomerOrder component in the assembly diagram.  
	__5.  Right click on CustomerOrder and select Show in Properties.  
	__6.  Click on the Details tab.  Notice that the CustomerOrder interface appears underneath the Interfaces node.  
	__7.  Expand the interface and you will see its operations.
	__8.  In the assembly diagram, right click on CustomerOrder and select Generate Implementation.  
	__9.  In the Generate Implementation dialog, click the New Package... button.
	__10.  In the Create Package dialog, type com.webage and click OK.
	__11.  Select the com.webage package you created and click OK.
	
	__12.  Save your changes to the Assembly Diagram.  
	__13.  Switch back to the Java editor for  CustomerOrderImpl.
	__14.  Click on the Outline view located in the lower left corner of WID.  Notice that CustomerOrderImpl has two public methods which correspond with the operations you defined in your interface.
	
	__15.  Click on the createCustomer(DataObject) method.  WID will jump to the method inside the Java editor and highlight the method name.  The Outline view provides an easy way to navigate a Java file, as well as other types of files.  

	Part 2 -  Implement createCustomer Operation
	__1.  Add the following code in bold after the CustomerOrderImpl class declaration to instantiate a Logger object:
	__2.  A red X will appear in the editor indicating a compile time error.  Fix this error by importing the Logger class into your class.  To do so, right click in the editor and select Source > Organize Imports.  
	__3.  In the Organize Imports dialog, select java.util.logging.Logger and click Finish.
	__4.  Save your changes.  The red X should have disappeared.    
	__5.  Replace the code inside the createCustomer method with the following code in bold.  The code logs the name of the operation to the server log file (SystemOut.log), calls a helper method you'll add next to log the Customer object that was passed in, and returns the customer id:
	__6.  Next, add the logCustomer method beneath the createCustomer method:
	__7.  logCustomer delegates to logOrder for logging each Order business object, so add the logOrder method beneath the logCustomer method.  To speed things up, you can copy and paste the method from C:\LabFiles\Solutions\CustomerOrderImpl.java.
	__8.  Press Ctrl-Shift-O to Organize Imports.  
	__9.  Select java.util.Iterator from the Organize Imports dialog and click Next.
	__10.  Select java.util.List from the Organize Imports dialog and click Finish.
	__11.  Save your changes.  There should be no errors in the Problems view.

	Part 3 -  Implement findCustomer Operation
	In this part, you will implement the findCustomer operation.  In real life, your Java component would retrieve a record from a database and construct a DataObject based on the data.  To simplify things, you'll construct a fake DataObject and return it to the caller. To construct the Customer DataObject, you'll use the BOFactory class.  If you tire of typing the whole method, you can copy and paste the method and supporting methods from C:\LabFiles\Solutions\CustomerOrderImpl.java.    
	__1.  Delete the code inside the findCustomer method.
	__2.  Verify that the findCustomer method is declared as follows. If not notify your instructor.
	__3.  Add the following code to the top of the findCustomer method. The code logs the name of the operation and the input customer id to the server log file (SystemOut.log):
	__4.  Next, add the code to locate the BOFactory using the ServiceManager class.  The ServiceManager class is used for locating services given an SCA service reference.
	__5.  Add the following line of code to create the Customer business object.  The create method takes two parameters, the first of which corresponds with the namespace of the business object and the second of which corresponds with the name of the business object.  Both of these values can be found in the Properties view of the Business Object Editor.
	__6.  Now that you've created the business object, add the following code to populate its scalar (single-value) fields:
	__7.  Save your changes.
	__8.  Add the following code to create the orders field:
	__9.  Add the following code to create an order:
	__10.  Add the following code to populate the orderId and orderDate fields:
	__11.  Add the following code to populate the shippingAddress and billingAddress fields.  
	Notice that when a DataObject has a scalar (single-value) field that is itself a DataObject, you must use its createDataObject(String field) method instead of the BOFactory's create method to create an instance of the DataObject.  This simplifies coding, since the BOFactory's method requires an extra parameter (i.e., namespace).
	__12.  Add the following code to create the orderItems field and populate it:
	__13.  Now that you've finished constructing your order items, add the order items to the order:
	__14.  Now that you've finished constructing your order, add the order to the orders list. 
	__15.  Now that you've finished constructing your order list, add the orders list to the customer.
	__16.  Log the customer returned and return the customer to the caller by adding the final two lines of code to the findCustomer method:
	__17.  Finally, add the createOrderItem helper method below the findCustomer method:
	__18.  Press Ctrl-Shift-O to Organize Imports.  
	__19.  Select com.ibm.websphere.bo.BOFactory from the Organize Imports dialog and click Next.
	__20.  Select java.util.Date from the Organize Imports dialog and click Next.
	__21.  Select java.util.Calendar from the Organize Imports dialog and click Finish.
	__22.  Save your changes.  
	__23.  Make sure there are no errors in the Problems view before proceeding to the next part.
	__24.  Close all open files.

	Part 4 -  Test Java Component
	__1.  Right click on the server in the Servers view and select Start to launch the server if it is not started.
	__2.  Once the server shows a Started status, right click the server and selecting Add and Remove Projects from the menu.
	__3.  Select CustomerOrderApp and click Add to move the CustomerOrderApp project to the Configured projects list.
	__4.  Click Finish.
	__5.  Wait for publishing to end. The Status of the server should become Synchronized.
	__6.  In the Servers view, you can also see the status of the applications.  Expand WebSphere ESB Server v6.2 and you should see each of the applications you deployed listed underneath.  Verify that they are all Synchronized.
	__7.  Open the Assembly Diagram. 
	__8.  Right click on CustomerOrder and select Test Component.  
	__9.  Under Detailed Properties, set the component to be tested to CustomerOrder. The choices should be as follows:
	In order to unit test the createCustomer operation, we need to provide some Customer data, which corresponds with the customer variable.  
	__10.  Enter the following client data by double clicking on the green check marks next to each value:  
	Your Initial request parameters should look as follows:
	__11.  Right click on orders and select Add Elements...
	__12.  The Add Element dialog will appear and allows you add one or more elements to the orders array.  Leave the default value of 1 and click OK.
	
	__13.  Expand orders, shippingAddress, and billingAddress and enter the following data:
	Your Initial request parameters should look as follows:
	__14.  Right click on orderItems and select Add Elements...
	__15.  Leave the default value of 1 in the Add Element dialog and click OK.
	__16.  Enter the following data:
	Your Initial request parameters should look as follows:
	__17.  Now that you've input your data, we can proceed with the test.  Under the Events heading, click the Continue button (white arrow in a green circle).
	
	__18.  Expand WebSphere ESB Server v6.2 and select WebSphere ESB Server v6.2 at localhost.
	__19.  Check Use this as the default and do not ask again checkbox. 
	__20.  Click Finish.
	__21.  Accept the default user ID and password if prompted.
	__22.  After the test finishes running, you should see both Invoke (CustomerOrder:createCustomer) and Return(CustomerOrder:createCustomer) listed in the Events panel, since the createCustomer operation is a request-response operation.
	
	You should also see in the Return parameters pane that a customerId of 0 was returned, since that's the value we supplied as an input.
	
	__23.  Now look in the Console view.  If the Console view is not open select Window > Show View > Console.  You should see the following messages at the end of the list:
	__24.  Click the Invoke icon under the Events heading to run another test.
	__25.  Now  test the findCustomer operation by selecting findCustomer from the Operation drop-down under Detailed Properties.
	
	__26.  Leave the customerId set to 0 and click the Continue button.
	__27.  Examine the customer that gets returned.  It should match the one that you constructed inside the findCustomer method. 
	
	__28.   Notice the customer is also printed to the Console view.
	__29.  Do not close the test as you will use it in the next section.

	Part 5 -  Rerunning a Test
	__1.  If you have closed the CustomerOrderImpl class reopen it by expanding Integration Logic > Java Usages in the CustomerOrder project in the Business Integration view and double clicking on CustomerOrderImpl.
	__2.  Introduce a minor bug in the logCustomer method.  Change:
	__3.  Save your changes.
	__4.  Look in the Servers view.  The state of the server should be Republish, since you changed your code, but didn't deploy the changed code to the server.  To remedy this, right clicking on the server and select Publish.
	__5.  After publishing finishes, you should see the following message in the Console view with a recent timestamp:
	__6.  Switch back to the test editor.
	__7.  Re-run the createCustomer test you ran earlier by right clicking on Invoke (CustomerOrder:createCustomer) under Events and selecting Rerun.
	__8.  This time when the test executes, you'll see the following exception in the Exception trace box, which is what we expected:
	__9.  Fix the problem, publish to the server, and re-run the test.  The test should complete successfully.

	Part 6 -  Storing Test Data in the Data Pool
	Aside from being able to re-run tests using the Integration Test Client, you can also save data to a data pool.  This way if you close the test editor and open a new one later, you don't need to re-enter your test data all over again.  The data in the data pool gets stored inside of your workspace.  In this part, you will store the customer business object you input to the data pool, including its children.  You will close the editor, open a new one, and use the test value from the data pool to run the createCustomer test again.
	__1.  To add the customer data to the data pool, click on Invoke (CustomerOrder:createCustomer) under Events. (select the first one from the list as there will be several from rerunning the test)
	__2.  In the Initial Request Parameters box,  right click on customer and select Add Value to Pool...
	__3.  Click the Next button on the New Data Pool wizard.
	__4.  Click the New button next to the empty list of projects.
	__5.  Enter a project name of TestProject and press the Finish button.
	__6.  Enter a name of TestData for the data pool file and press the Finish button when your dialog appears as below.
	__7.  In the Value Name, provide the following descriptive name for the test value:
	__8.  Click OK.
	__9.  To view values that you added to the pool, click the Data Pool (grid) icon in the Events toolbar.
	
	__10.  The Integration Test Client Data Pool dialog will display any test values you've added to the data pool.  Expand customer and its children to see the test data you input.  
	If you need to change a test value, you can do so from this dialog by modifying the corresponding business object's fields and clicking Update. 
	You can also remove a test value by right clicking on the test value and selecting Remove.  Then click Update.
	__11.  Close the data pool and the test editor.  Don't save your changes.
	__12.  In the Assembly diagram, right click on CustomerOrder and select Test Component.  WID will open a  test editor in the editors pane called CustomerOrder_Test.
	__13.  Make sure createCustomer is the operation under test.  
	__14.  Right click on customer in the Initial request parameters box and select Use Value from Pool...
	__15.  Select customer – Linda Peterson and click OK.
	
	
	__16.  Click the Continue button on the Events toolbar to run the test.  It should run successfully.
	__17.  Close the test editor.  Don't save your changes.
	__18.  Stop the server by right clicking on it and selecting Stop.  When the server finishes running, the message Server server1 stopped will appear in the Console view.  The server will show a status of Stopped in the Servers view.
	__19.  Close all open editors.

	Part 7 -  Review

	Lab 6 -  Web Service Binding and Data Transformation
	Part 1 -  The Business Problem
	Part 2 -  Import the Project
	__1.  From the menu bar select File > Import.
	__2.  Expand Other and select Project Interchange.
	__3.  Click Next.
	__4.  Using the browse button, select C:\LabFiles\DataMappingExample.zip
	__5.  Click Select all to select all projects.
	__6.  Click Finish.

	Part 3 -  Inspect Generic Data Types and Service Interface
	__1.  Expand DataMappingExample > Data Types.
	__2.  Open CustomerGBO. Note, customer's name is broken up in first and last name.
	__3.  Open StatusGBO. Note that the data type of the Code field is int.
	__4.  Expand Interfaces.
	__5.  Open the GenericAccountingSystem interface.
	__6.  Close all open files.

	Part 4 -  Inspect the Web Service
	__1.  Expand AcmeWeb > Java Resources : src > com.acme.accounting.
	__2.  Open ACMEAccounting.java.
	__3.  Note how various JAX-WS annotations like @WebService, @WebMethod, @WebResult and @WebParam are used to create the web service.
	__4.  Study the CustomerASBO and StatusASBO classes.
	__5.  Close all open files.

	Part 5 -  Import Web Service WSDL
	__1.  Start the server if it is not started. Wait for it to start.
	__2.  Deploy AcmeApp project to the server. Make sure to only add that project.  Wait for publishing to end.
	__3.  Right click the server and select Administration > Run administrative console.  If you are notified of a security certificate issue accept the certificate.
	__4.  Log in using user ID and password "admin".
	__5.  Click Applications > Enterprise Applications.
	__6.  Click AcmeApp.
	__7.  Click Publish WSDL files under the Web Services Properties section.
	__8.  Click AcmeApp_WSDLFiles.zip and save it somewhere in the hard drive.
	__9.  Open and Extract the ZIP file in C:\LabFiles folder.
	__10.  Log out of and close the admin console.
	__11.  If you are familiar with WSDL and XML schema, go to C:\LabFiles\AcmeApp.ear\AcmeWeb.war and study the WSDL and XSD files.
	__12.  In WID, right click the DataMappingExample project and select Import.
	__13.  Expand Business Integration and select WSDL/Interface.
	__14.  Click Next.
	__15.  Use the first Browse button to select the C:\LabFiles\AcmeApp.ear\AcmeWeb.war folder and click OK.
	__16.  Check ACMEAccountingService.wsdl
	__17.  Accept the other defaults as shown below.
	__18.  Click Finish.

	Part 6 -  Inspect Application Specific Data Types and Service Interface
	__1.  Expand Data Types in the DataMappingExample project and note that customerASBO and statusASBO are defined.
	__2.  Open each data type and inspect.
	__3.  Expand Interfaces. Note that the ACMEAccounting interface has been defined.
	__4.  Open the interface and study the createAccount operation.
	__5.  Close all files.

	Part 7 -  Create the Mediation Flow
	__1.  Right click Integration Logic in the same project and select New > Mediation Flow.
	__2.  Enter AccountingMediation as the name and click the Next button.
	__3.  As source interface, add GenericAccountingSystem.
	__4.  As target interface, add ACMEAccounting.
	__5.  Click Finish.
	__6.  Connect addCustomerAccount source method to createAccount target method.
	__7.  In the top pane, select addCustomerAccount operation so that we can edit the request message flow.
	__8.  Connect the output terminal of addCustomerAccount to the input terminal of createAccount.
	__9.  Select the XSL transformer primitive – XSLTransformation1.
	__10.  In the Properties view change the display name and name to CustomerGBO_To_CustomerASBO
	__11.  In the Properties view click the Details tab.
	__12.  Click the New button to create a new map.
	__13.  Change the name to CustomerGBO_To_CustomerASBO_Request
	__14.  Click Next.
	__15.  Click Finish.
	__16.  WID will create the map and open it in the editor. We will edit the map later after we are done designing the message flows. So close the map editor for now.
	__17.  Back in the mediation flow editor, click the Response tab at the bottom to start editing the response flow.
	__18.  Connect the output terminal of createAccount to the input terminal of addCustomerAccount.
	__19.  Change the name of the transformation primitive to StatusASBO_To_StatusGBO
	__20.  In the Details tab of the transformation primitive property, click New.
	__21.  Change the name of the map to StatusASBO_To_StatusGBO_Response
	__22.  Click Next.
	__23.  Click Finish.
	__24.  Close the map editor. We will deal with that later.
	__25.  Save the mediation flow. Make sure that there are no error messages in the Problems view.
	__26.  Our mediation flow is now complete. Close the editor.

	Part 8 -  Complete the Data Maps
	__1.  In the same project, expand Mapping > XML Maps > xslt.
	__2.  Double click  CustomerGBO_To_CustomerASBO_Request to open it.
	__3.  Expand the objects to show all the fields as shown below.
	__4.  Mapping the Telephone field to phone field is straightforward. Click and drag the Telephone field and drop it on the Phone field. A Move mapping will be create between the two.
	__5.  First drag FirstName to name and create a basic Move map.
	__6.  Then drag LastName and drop it on the box for Move map. The mapping will automatically change to Concat.
	__7.  Click the box for Concat.
	__8.  In the Properties view, select the General tab.
	__9.  For the FirstName input field, set the Delimiter to a single space character.
	__10.  Save and close the map.
	__11.  Open StatusASBO_To_StatusGBO_Response map in the editor.
	__12.  Setup a basic Move mapping between errorMessage to Message.
	__13.  Setup a basic Move mapping between errorCode and Code.
	__14.  Save changes. Make sure that there are no errors in Problems view.
	__15.  Close all open files.

	Part 9 -  Test the Data Maps
	__1.  We will test CustomerGBO_To_CustomerASBO_Request. Right click the map and select Test.
	__2.  Enter some values in the input table as shown below.
	__3.  Click the Continue toolbar button.
	__4.  Verify that the output looks valid.
	__5.  Close the test editor without saving.

	Part 10 -  Setup Web Service Binding
	__1.  Open the assembly diagram for the mediation module. Remember that we are working with the DataMappingExample project.
	__2.  Expand Web Service Ports and locate the ACMEAccountingPort that was created after the WSDL was imported.
	__3.  Drag  ACMEAccountingPort on the assembly diagram.
	__4.  Select Import With Web Service Binding.
	__5.  Click OK.
	__6.  Select SOAP1.1/HTTP option.
	__7.  Click OK.
	__8.  Select the newly created import. 
	__9.  In the Properties view, select the Binding tab.
	__10.  Note the endpoint address.
	__11.  Drag the AccountingMediation mediation flow on the assembly editor.
	__12.  Wire the reference partner of the mediation flow to the service interface of the web service import.
	__13.  Save changes.

	Part 11 -  Test
	__1.  Start the server if it is not running.
	__2.  Add DataMappingExampleApp project to the server.
	__3.  Wait for publishing to end.
	__4.  Right click anywhere in the white area of the assembly diagram and select Test Module.
	__5.  Set the Component to AccountingMediation.
	__6.  Make sure that the operation is set to addCustomerAccount.
	__7.  In the input parameters table, enter some values.
	__8.  Click the Continue toolbar button.
	__9.  Expand WebSphere ESB Server 6.2 and select WebSphere ESB Server 6.2 at localhost and set it up as default as shown below.
	__10.  Click Finish.
	__11.  Make sure that in the return data, Code is 0.
	__12.  In the Console view, make sure that the output from the web service is shown.  You may need to click the double Xs to remove terminated launches for any mappings.
	__13.  Close the test but do not save it.

	Part 12 -  Expose Mediation Flow as Web Service
	__1.  Open the assembly diagram.
	__2.  Right click AccountingMediation and select Generate Export > Web Service Binding.
	__3.  Choose SOAP1.1/HTTP option.
	__4.  Click OK.
	__5.  Select the newly created export component.
	__6.  In the Properties view select the Binding tab. Note the endpoint URL of the web service binding.
	__7.  Save changes.

	Part 13 -  Test the Exported Web Service
	__1.  Right click the server in the Servers view and select Publish.  Wait for the server to be synchronized.
	__2.  In the Business Integration view expand DataMappingExample > Web Service Ports.
	__3.  Right click the GenericAccountSystemExport1_GenericAccountSystemHttpPort and select Web Services > Test with Web Services Explorer.
	__4.  Under the list of operations click the link for the addCustomerAccount operation.
	__5.  Click the Add link next to the various customer properties like names and phone and add some sample data as shown below.
	__6.  Press the Go button under the parameters to submit the web service request.
	__7.  Check that you get a response in the Status area.  You may need to expand it to see the body of the response.
	__8.  Check in the Console view and you should see that the same message as before is printed.  This proves that the request made to the web service of the mediation flow export made it through the mediation flow and to the end service provider and back.
	__9.  Close all open files.

	Part 14 -  Review

	Lab 7 -  Service Composition Pattern
	Part 1 -  Business Use Case
	Part 2 -  Create the Module
	__1.  From the menubar select File > New > Mediation Module.
	__2.  Enter CompositionTest as the name.
	__3.  Set target runtime to WebSphere ESB Server 6.2.
	__4.  Uncheck Create mediation component.
	__5.  Click Finish.

	Part 3 -  Create the Product Data Type
	__1.  Right click Data Types and select New > Business Object.
	__2.  Enter Product as the name.
	__3.  Click Finish.
	__4.  Read the use case and try to figure out the various attributes of the product. The table below shows the solution. Add the following fields to the data type.
	__5.  Save and close.

	Part 4 -  Identify and Specify Services
	__1.  Right click Interfaces and select New > Interface.
	__2.  Enter  InventoryEnricher as the name and click Finish.
	__3.  Click the Add Request Response Operation toolbar button to create a two-way operation.
	__4.  Make these changes to the operation.
	__5.  Save and close the interface.
	__6.  Create a new interface and call it ProductSink
	__7.  Add a one-way operation.
	__8.  Make these changes to the operation.
	__9.  Save and close.

	Part 5 -  Implement the Message Flow
	__1.  Right click Integration Logic and select New > Mediation Flow.
	__2.  Enter PropagateProductChange as the name.
	__3.  Click Next.
	__4.  As the source interface add ProductSink.
	__5.  Click Finish.
	__6.  In the top pane of the mediation flow editor, click the Add Reference button.
	__7.  Select the InventoryEnricher interface. Accept the default name for the partner – InventoryEnricherPartner.
	__8.  Click OK.
	__9.  Similarly, add the following references.
	__10.  Click the updateProduct operation in the source interface to select it.
	__11.  The Request: updateProduct pane will open.
	__12.  Click the Routing folder in the tool palette and locate the Service Invoke item.
	__13.  Drag the Service Invoke primitive and drop it on the message flow. Note the mouse pointer may look like is not available.
	__14.  Select InventoryEnricherPartner, the operation will change to supplyInventory.
	__15.  Click OK.
	__16.  Change the name of the invoke primitive to EnrichInventory
	__17.  Similarly add two more service invoke primitives with the following specifications.
	__18.  Connect the output terminal of updateProduct : ProductSink to the input of EnrichInventory. WID will insert a XSL transformer in the middle.
	__19.  Connect the output terminal of EnrichInventory to the input of AccountingSystem. Another XSL transformer will be inserted.  Make sure you use the out terminal of EnrichInventory and not the timeout terminal.
	__20.  Connect the output of XSLTransformer2 to the input of WebSite.
	__21.  Verify the message flow design.
	__22.  Save changes.

	Part 6 -  Design the Data Maps
	__1.  Select the first transformer – XSLTransformation1.
	__2.  In the Properties view, select the Details tab.
	__3.  Click New.
	__4.  Accept all defaults and click Finish.
	__5.  In the map editor, connect the two Product objects as shown below.
	__6.  Save and close the map.
	__7.  Select the second transformer – XSLTransformation2.
	__8.  In the Properties view, select the Details tab.
	__9.  Click New.
	__10.  Accept all defaults and click Finish.
	__11.  In the map editor, connect the two Product objects as shown below.
	__12.  Save and close the map.
	__13.  Save the mediation flow. Verify that the problems view has no error messages.

	Part 7 -  Implement the Services
	__1.  Open the assembly diagram.
	__2.  Right click the white area and select Add > Java.
	__3.  Change the name of the component to InventoryEnricher
	__4.  Right click it and select Add > Interface.
	__5.  Select  InventoryEnricher and click OK.
	__6.  Right click the component again and select Generate Implementation.
	__7.  Select (default package) and click OK.
	__8.  Change the supplyInventory method as follows.
	__9.  Save and close.
	__10.  Right click the white area and select Add > Java.
	__11.  Change the name of the component to AccountingSystem
	__12.  Right click it and select Add > Interface.
	__13.  Select ProductSink and click OK.
	__14.  Right click the component again and select Generate Implementation.
	__15.  Select (default package) and click OK.
	__16.  Change the updateProduct method as follows.
	__17.  Save and close.
	__18.  Right click the white area and select Add > Java.
	__19.  Change the name of the component to WebSite
	__20.  Right click it and select Add > Interface.
	__21.  Select ProductSink and click OK.
	__22.  Right click the component again and select Generate Implementation.
	__23.  Select (default package) and click OK.
	__24.  Change the updateProduct method as follows.
	__25.  Save and close.
	__26.  Save the assembly diagram but leave it open.

	Part 8 -  Wire the Solution
	__1.  Drag PropagateProductChange mediation flow and drop it on the assembly diagram.
	__2.  Study each one of its three reference partners by moving the mouse over it and opening the tooltip.
	__3.  Set up these wirings:
	__4.  Save changes. Make sure that there are no errors in the problems view.

	Part 9 -  Test
	__1.  Make sure the server is started in the Servers view and start it if it is not.
	__2.  Right click the server in Servers view and select Add Remove Projects.
	__3.  Click Remove All to undeploy all existing applications.
	__4.  Add the CompositionTestApp.
	__5.  Click Finish.
	__6.  Wait for publishing to end.
	__7.  Right click in the white area of the assembly diagram and select Test Module.
	__8.  Carefully choose PropagateProductChange mediation flow as the component to be tested.
	__9.  In the input area, enter some values. Leave the inventory as 0.
	__10.  Click the Continue button in the test editor.
	__11.  Expand WebSphere ESB Server 6.2 and Choose WebSphere ESB Server 6.2 at localhost as the runtime. Also check to use it as default. Click Finish.
	__12.  Click OK in the user id and password if prompted.
	__13.  In the Console view, verify the message logs shows the progress of the message flow. Note that the sink services received the correct inventory value.
	__14.  Close the test but do not save.
	__15.  Close any other open files.

	Part 10 -  Review

	Lab 8 -  Message Routing
	Part 1 -  Business Problem Use Case
	Part 2 -  Import the Module
	__1.  Import all projects from C:\LabFiles\FilterTest.zip. (use the project Interchange option)
	__2.  Study the following data types. They have been developed following the use case.
	__3.  Study these service interfaces. They have also been developed based on the use case.

	Part 3 -  Model the Message Flow
	Part 4 -  Implement the Message Flow
	__1.  Create a new mediation flow with these specifications:
	__2.  After the mediation flow opens in the editor, connect the placeOrder source operation to the placeOrder target operation.
	__3.  Add a new reference partner with the InventoryManager interface.
	__4.  In the bottom pane, select the input node placeOrder : OrderTaker.
	__5.  In the Properties view, select the Details tab.
	__6.  Next to Transient context click Browse.
	__7.  Select Order and click OK.
	__8.  On the right hand palette, under References expand InventoryManagerPartner.
	__9.  Drag the getInventoryLevel operation and drop it on the message flow. WID will automatically add a service invoke operation properly configured.
	__10.  Change the name of that primitive to GetInventory
	__11.  Connect the output of placeOrder : OrderTaker to the input of GetInventory. WID will add a transformer primitive in the middle.
	__12.  Add a Message Filter primitive to the flow editor.
	__13.  Change its name to CheckInventory
	__14.  Connect the out terminal of GetInventory to the input of CheckInventory.  Make sure you use the out terminal of GetInventory and not the timeout terminal.
	__15.  Connect the match1 terminal of CheckInventory to the input terminal of placeOrder : OrderTakerPartner.  Make sure you hover the mouse to see the name of the terminal as the second one should be the match1 terminal.
	__16.  Add a service invoke primitive by dragging getProductReplacement operation on the flow.
	__17.  Change its name to GetReplacement
	__18.  Connect the default terminal of CheckInventory to the input of GetReplacement. WID will add a XSL transformer.
	__19.  Right click the diagram and select Layout Contents to clean things up.
	__20.  Add another message filter primitive. This will decide if a replacement is available.
	__21.  Change its name to CheckReplacement
	__22.  Connect the out terminal of GetReplacement to the input of CheckReplacement.
	__23.  Add a Stop primitive from the Error Handling group in the Palette.
	__24.  Connect the default terminal of CheckReplacement to the stop primitive.
	__25.  Connect the match1 terminal of  CheckReplacement to placeOrder : OrderTakerPartner. WID will add XSLTransformation4 in the middle.
	__26.  Right click the diagram and select Layout Contents to clean things up.
	__27.  Save changes. There will be several error messages. We will fix them later.
	__28.  Our basic flow design is done. Can you compare the flow with the drawing you made on paper?

	Part 5 -  Complete the Data Maps
	__1.  Select XSLTransformation1. 
	__2.  In the Properties view, select Details tab.
	__3.  Click New.
	__4.  Accept all defaults. Click Next.
	__5.  As the Message Root select  /
	__6.  Click Finish. WID will create the map and open it in the editor.
	__7.  For the input message (on the left hand side), expand body > placeOrder > order.
	__8.  For the output message, expand context > transient.
	__9.  Drag the order element of the source to the transient element of the target.
	__10.  In the target, expand body > getInventoryLevel.
	__11.  Map the sku element from the source to the sku element of the target.
	__12.  Save and close the map.
	__13.  Select XSLTransformation2.
	__14.  In the Properties view, select Details tab.
	__15.  Click New.
	__16.  Accept all defaults. Click Next.
	__17.  As the Message Root select  /
	__18.  Click Finish. WID will create the map and open it in the editor.
	__19.  Map the transient element of the source to the order element of the target body.
	__20.  Save and close the map.
	__21.  Select XSLTransformation3.
	__22.  In the Properties view, select Details tab.
	__23.  Click New.
	__24.  Accept all defaults. Click Next.
	__25.  As the Message Root select  /
	__26.  Click Finish. WID will create the map and open it in the editor.
	__27.  Map the sku element from the transient area of the source to the sku element in the body of the target.
	__28.  Also, map the transient element of the source to the transient element of the target. Otherwise, we will lose the data saved in the transient area.
	__29.  Save and close the map.
	__30.  Select XSLTransformation4.
	__31.  This map receives as input the output of the getProductReplacement operation – a ReplacementProduct object. The output of this message is an Order object. We need to reconstruct the order from what we had saved in the transient context. But, there is a catch. We must replace the SKU in the original order with the replacement product.
	__32.  In the Properties view, select Details tab.
	__33.  Click New.
	__34.  Accept all defaults. Click Next.
	__35.  As the Message Root select  /
	__36.  Click Finish. WID will create the map and open it in the editor.
	__37.  Reconstruct all elements of the order in the target body except for sku from the transient area of the source.
	__38.  Map the toSKU element of the body of the source to the sku element of the target body.
	__39.  Save and close the map.
	__40.  Save the mediation flow. There should be no error messages. There are a few warnings and we will take care of that soon.

	Part 6 -  Define the Routing Logic
	__1.  Select CheckInventory.
	__2.  In the Properties view, select Details tab.
	__3.  Click the Add button to specify a routing rule.
	__4.  Make sure that the terminal to be fired is set as match1.
	__5.  Click the Edit button to define the XPath expression associated with this rule. If this expression evaluates to true, the match1 terminal will fire.
	__6.  Expand ServiceMessageObject > context > transient.
	__7.  Double click quantity to add the XPath for that field to the expression editor.
	__8.  In the Operators list, double click <=.
	__9.  Back in Data Type Viewer, expand ServiceMessageObject > body > getInventoryLevelResponse > inventory.
	__10.  Double click qtyOnHand.
	__11.  Verify that the XPath expression is now like this:
	__12.  Click Finish to create the Xpath expression.
	__13.  Click Finish to create the routing filter pattern.
	__14.  Save changes.
	__15.  Select CheckReplacement.
	__16.  In the Properties view, select Details tab.
	__17.  Click the Add button to specify a routing rule.
	__18.  Make sure that the terminal to be fired is set as match1.
	__19.  Click the Edit button to define the XPath expression associated with this rule. If this expression evaluates to true, the match1 terminal will fire.
	__20.  In the Data Type Viewer, expand ServiceMessageObject > body > getProductReplacementResponse > replacement.
	__21.  Double click replacementAvailable.
	__22.  The XPath expression will be:
	__23.  Click Finish to create the Xpath expression.
	__24.  Click Finish to create the routing filter pattern.
	__25.  Save changes. The design of the mediation flow is now complete.
	__26.  Close the editor.

	Part 7 -  Wire the Solution
	__1.  Open the assembly diagram.
	__2.  Verify that two Java components are already created for you.
	__3.  Double click InventoryManager to view the business logic.
	__4.  Close the Java editor.
	__5.  Drag OrderMediation and drop it on the assembly diagram.
	__6.  Right click the OrderMediation and select Wire to Existing.  This should automatically wire up the reference partners.
	__7.  Save.

	Part 8 -  Deploy the Module
	__1.  Start the server if it is stopped. Wait for it to start.
	__2.  Right click the server and select Add Remove Projects.
	__3.  Click Remove All to undeploy all existing applications.
	__4.  Add FilterTestApp.
	__5.  Click Finish. Wait for publishing to end.

	Part 9 -  Test
	__1.  Right click the assembly diagram and select Test Module.
	__2.  Set the component to be tested to OrderMediation.
	__3.  Enter some input data.
	__4.  Click the Continue button.
	__5.  Choose as always the WebSphere ESB Server v6.2 at localhost runtime and click Finish.
	__6.  Accept the default user ID and password if asks.
	__7.  At the end of the test, the console will show.
	__8.  Under Events click the Invoke button to start another test.
	__9.  Enter some input as shown below.
	__10.  Click the Continue button.
	__11.  Now, the console will show this.
	__12.  Select placeOrder : OrderTaker primitive as shown above. This is the input node and the first primitive to be executed.
	__13.  In the Mediation Message area, note that the transient context is now empty. But the body has the input Order object.
	__14.  Select XSLTransformation1 in the left. At this point, the order data has been copied into the transient area. Also, the body is now ready as input for the getInventoryLevel operation.
	__15.  Select GetInventory. This a service invoke primitive that calls the getInventoryLevel operation.
	__16.  Note that the transient context area has remained unchanged. But the body of the SMO now contains the output of getInventoryLevel. This proves that a service invoke primitive does not alter the message context area but replaces the body with the output of the operation called.
	__17.  Next select CheckInventory. This a message filter primitive. It does not alter the SMO in anyway.
	__18.  Close the test editor without saving it.
	__19.  Close any other open files.

	Part 10 -  Review

	Lab 9 -  Implementing the Splitting and Aggregation Patterns
	Part 1 -  The Business Logic
	Part 2 -  Service Identification
	Part 3 -  Import Mediation Module
	__1.  Import the project interchange file C:\LabFiles\PriceQuoteFlow.zip.
	__2.  Verify that the PriceQuoteFlow mediation module is created.
	__3.  Take a moment to study these data types:
	__4.  Study these service interfaces. The service identification part describes them in details.
	__5.  Close all open editors.

	Part 4 -  Define Shared Context Data Type
	__1.  Create a new business object data type called QuoteSharedContextData.
	__2.  Add these fields
	__3.  Save and close the editor.

	Part 5 -  Create the Mediation Flow
	__1.  Right click Integration Logic and select New > Mediation Flow.
	__2.  Enter OrderMediation as the name and click Next.
	__3.  As the source interface, pick OrderTaker.
	__4.  As the target interface, pick Supplier.
	__5.  Click Finish.
	__6.  Connect the placeOrder operation from the source interface to the placeOrder method of the target.
	__7.  Save changes.

	Part 6 -  Save Order in Shared Context
	__1.  In the message flow editor pane, select the placeOrder : OrderTaker input node.
	__2.  In the Properties view, select the Details tab.
	__3.  Set the data type of shared context to QuoteSharedContextData.
	__4.  Add an XSL Transformation primitive to the message flow.
	__5.  In the Details tab of the Properties view, click New.
	__6.  Accept the default name for the map and click Next.
	__7.  Set the message root to "/".
	__8.  Next to Input Message Body click Browse.
	__9.  Select OrderTaker as the interface.
	__10.  Select the placeOrder operation.
	__11.  Select Input as the Message Category.
	__12.  This will set the message type to placeOrderRequestMsg.
	__13.  Click OK.
	__14.  Similarly, for Output Message Body, select the same message type.
	__15.  Click Finish.
	__16.  For the source message, expand body > placeOrder.
	__17.  For the target message, expand context > shared.
	__18.  Drag the order element from the source on the order element of the target.
	__19.  Save and close the map editor.
	__20.  Connect the output of the placeOrder : OrderTaker node to the input of XSLTransformation1.
	__21.  Save changes.

	Part 7 -  Create a Basic Splitting and Aggregation Flow
	__1.  Expand the Routing pallete.
	__2.  Drag FanOut and drop it on the message flow.
	__3.  Drag FanIn and drop it on the message flow.
	__4.  Select FanOut1 as the primitive that will correspond with the FanIn.
	__5.  Click OK.
	__6.  On the right hand side of the editor, expand the SupplierPartner reference.
	__7.  Drag getPriceQuote and drop it between the FanOut and FanIn.
	__8.  Rename the service invoke to CallAJAX.
	__9.  Similarly, drag and drop getPriceQuote again to create another service invoke. Rename it to CallACME.
	__10.  Connect the output terminal of XSLTransformation1 to the input of FanOut1.
	__11.  Select the FanIn1 primitive. 
	__12.  Select the Details tab in the Properties view.
	__13.  Set the number of input messages that the primitive will wait for to 2.  You may need to scroll in the view to see this option.
	__14.  Save changes.  We will now develop each path of execution.

	Part 8 -  Develop Parallel Flow Paths
	__1.  Connect the out terminal of FanOut1 to the in terminal of CallAJAX.  Make sure you connect the 'out' terminal of the FanOut as it also has a 'noOccurences' terminal.  Hover over the terminals to see the terminal names.
	__2.  Select  XSLTransformation2.
	__3.  In the Details tab of the Properties view, click New.
	__4.  Click Next.
	__5.  Choose "/" as the root.
	__6.  Click Finish.
	__7.  Map the fields as shown below.
	__8.  Save and close the map editor.
	__9.  Add a new XSL Transformation primitive to the right of CallAJAX. The name of the primitive should be XSLTransformation3.
	__10.  Select XSLTransformation3.
	__11.  In the Details tab of the Properties view, click New.
	__12.  Click Next.
	__13.  Set "/" as the root.
	__14.  Next to Input Message Body click Browse.
	__15.  Set the interface to Supplier.
	__16.  Set the operation to getPriceQuote.
	__17.  Set the message category to Output.
	__18.  Click OK.
	__19.  Set the Output Message Body to be the same – getPriceQuoteResponseMsg.
	__20.  Click Finish.
	__21.  First copy the existing shared context data as shown below. When you select "/" as the message root, you must copy context data. Otherwise, they will be lost.
	__22.  Map the response element from the body of the source to the Move map of responses element.
	__23.  Save and close the map editor.
	__24.  Connect the out terminal of CallAJAX to the in terminal of XSLTransformation3.
	__25.  Connect the out terminal of XSLTransformation3 to the in of FanIn1.  Make sure you connect to the 'in' terminal as there is also a 'stop' terminal.
	__26.  Verify that the path for AJAX looks like this.  The layout may differ slightly but the order of the connections should match.
	__27.  Save changes.
	__28.  Repeat the steps from the beginning of this part and implement the flow for ACME. In the end the flows will look like this.
	__29.  Save changes.

	Part 9 -  Pick the Winning Bid
	__1.  In the References section click the Add button to add a new partner reference.
	__2.  Select the WinningQuotePicker interface. 
	__3.  Click OK.
	__4.  Drag the pickQuote operation of the WinningQuotePickerPartner to the right of FanIn1.
	__5.  Rename the service invoke primitive to PickQuote.
	__6.  Connect the output of FanIn1 to the input of PickQuote.  Make sure to select the 'out' terminal of the FanIn as there is also an 'incomplete' terminal.
	__7.  Double click XSLTransformation6 to start creating the map.
	__8.  Click Next.
	__9.  Set the message root to "/".
	__10.  Click Finish.
	__11.  Map the aggregate element from the shared context to the input element of the target body. 
	__12.  Save and close the map.

	Part 10 -  Place the Order
	__1.  Connect the out terminal of  PickQuote primitive to the placeOrder : SupplierPartner node.
	__2.  Double click XSLTransformation7.
	__3.  Click Next.
	__4.  Select "/" as the root.
	__5.  Click Finish.
	__6.  Map the order element from the shared context to the order element in the body of the target.
	__7.  Save and close the map.
	__8.  Save the mediation flow.

	Part 11 -  Dynamic Invocation
	__1.  Open the assembly diagram for the PriceQuoteFlow project.
	__2.  Drag the Supplier interface on the diagram.
	__3.  Select Import with Web Service Binding.
	__4.  Click OK.
	__5.  Select Do not specify a web service port at this time.
	__6.  Click OK.
	__7.  Select SOAP1.1/HTTP.
	__8.  Click OK.
	__9.  Rename the import to AJAXImport.
	__10.  Similarly, add ACMEImport.
	__11.  Drag and drop the OrderMediation component on the diagram.
	__12.  Save the assembly diagram. Ignore various errors.
	__13.  Back in the mediation flow, double click XSLTransformation4. 
	__14.  In the target message, expand headers > SMOHeader > Target.
	__15.  Right click the import element and select Create Assign.
	__16.  Select the Assign map.
	__17.  In the Properties view, set the value to ACMEImport.  Make sure this matches exactly the name you gave the import in the assembly diagram.
	__18.  Save and close the map.
	__19.  Double click the  XSLTransformation2 primitive. 
	__20.  This one is used before CallAJAX. Use the assign mapping to set the import element in the header to be AJAXImport as you just did.
	__21.  Double click XSLTransformation7.
	__22.  First setup a regular move map between supplierId in the source to the import element of the target.
	__23.  Click the down arrow for the Move map and select Custom.
	__24.  In the Properties view, enter the following XPath expression.
	__25.  Save and close the map.
	__26.  Select one of the service invoke primitives, such as CallACME.
	__27.  In the Properties view, select the Details tab.
	__28.  Ensure that Use dynamic endpoint if set in the message header is selected.

	Part 12 -  Review

	Lab 10 -  Service Design and Implementation
	Part 1 -  Create the AJAX Supplier Web Service
	__1.  Ensure that the server is running. WID deploys the web service project to the server when a new web service is created.
	__2.  Open the assembly diagram for PriceQuoteFlow.
	__3.  Right click AJAXImport and select Regenerate Binding.
	__4.  Click OK to confirm.
	__5.  Select Generate a new web service definition and implementation.
	__6.  Click OK.
	__7.  Select SOAP1.1/HTTP since this enables JAX-WS.
	__8.  Click OK.
	__9.  Click the Service Project link.
	__10.  Carefully, enter the Service project name to AJAXWeb and the Service EAR project to AJAXApp
	__11.  Click OK.
	__12.  Verify the page.
	__13.  Click Next.
	__14.  Check Copy WSDL to project.
	__15.  Click Next. You may see the following warning.
	__16.  Click Finish.
	__17.  Add a member variable for a java.util.Logger object.
	__18.  Use Control+Shift+O to organize imports and select java.util.logging.Logger when prompted.
	__19.  Implement the getPriceQuote method as follows.
	__20.  Implement the placeOrder method as follows.
	__21.  Save changes to the service implementation and close it.
	__22.  Back in the assembly diagram, save changes.

	Part 2 -  Create the ACME Supplier Web Service
	__1.  In a previous Lab we worked with the AcmeApp and AcmeWeb projects. We will use these projects in this Lab but we need them clean. So from the Business Integration view right click the AcmeApp and AcmeWeb projects and select Delete. 
	__2.  Then check the Delete project content on disk check box and click OK.
	__3.  Follow the same steps as in the previous part to generate an implementation for the ACMEImport. Except, use "ACME" everywhere "AJAX" appears. Below is a summary.
	__4.  After you are done writing the code for the web service, go back to the assembly diagram and save it. There should be no errors. There will be a few warnings related to not wiring the reference partners of the mediation flow. That is normal for dynamic invocation.

	Part 3 -  Develop the WinningQuotePicker Service
	__1.  Right click the assembly diagram and select Add > Java.
	__2.  Change its name to  WinningQuotePicker.
	__3.  Right click it and select Add >Interface.
	__4.  Select  WinningQuotePicker.
	__5.  Click OK.
	__6.  Right click  WinningQuotePicker again and select Generate Implementation.
	__7.  Click OK.
	__8.  Implement the pickQuote method as follows. It receives as input a QuoteResponseAggregate object and returns the QuoteResponse object with the lowest price.
	__9.  Organize imports selecting the java.util.List interface.
	__10.  Save changes and close the Java editor.
	__11.  Back in the assembly diagram, wire the WinningQuotePickerPartner reference of the mediation flow to the WinningQuotePicker Java component.
	__12.  Save the assembly diagram.

	Part 4 -  Expose Mediation Flow as a Web Service
	__1.  In the assembly diagram, right click OrderMediation and select Generate Export > Web Service Binding.
	__2.  Select SOAP1.1/HTTP.
	__3.  Click OK.
	__4.  Save the assembly diagram.

	Part 5 -  Deploy and Test
	__1.  Deploy only the following three projects to the server.
	__2.  Wait for publishing to end.
	__3.  Clear the Console view.
	__4.  Under PriceQuoteFlow project, expand Web Service Ports.
	__5.  The OrderTakerExport1_OrderTakerHttpPort port is for the export of the mediation flow. Right click it and select Web Services > Test with Web Services Explorer.
	__6.  Click the placeOrder operation.
	__7.  Next to sku, click Add.
	__8.  Enter some value for sku.
	__9.  Similarly, enter some value for quantity and address.
	__10.  Click the Go button.
	__11.  After some seconds in the Console view, there will be a flurry of logging activity. There may even be a few exception stacktraces. Most of them can be ignored. Look for the output from the AJAX and ACME web services as shown below.
	__12.  Make sure that the supplier with the lowest bid has received the order (AJAX in the example above).
	__13.  Clear the console.
	__14.  Repeat the test by clicking the Go button again the web services explorer window. Make sure that winning bid always gets the order.  The subsequent requests will likely come back so quickly you may not even think they were submitted.
	__15.  Close all open files. (Ctrl+Shift+W)

	Part 6 -  Review

	Lab 11 -  Application Integration Using JMS Messaging
	Part 1 -  Business Logic and Architecture
	Part 2 -  Create the Message Queues
	__1.  Start the Server unless it is already running.
	__2.  Right click the server and select Administration > Run administrative console. Click Yes in the security certificate window. 
	__3.  Log in as admin and admin.
	__4.  Click Service integration.
	__5.  Click Buses.
	__6.  Click New to create a new message bus.
	__7.  Enter DemoBus as the name.
	__8.  Clear the Bus Security checkbox to disable security protection for the bus.
	__9.  Click Next.
	__10.  Click Finish.
	__11.  Click DemoBus from the list of buses.
	__12.  Click Bus members.
	__13.  Click Add.
	__14.  Click Next.
	__15.  Click Next again to choose File store as default.
	__16.  Click Next to accept message store properties.
	__17.  Click Finish to add the bus member.
	__18.  Click Buses on the left hand navigation tree.
	__19.  Click DemoBus.
	__20.  Click Destinations.
	__21.  Click New.
	__22.  Choose Queue (default). Note: For pub/sub you will create a topic instead.
	__23.  Click Next.
	__24.  Enter AccountingRequestQ as the identifier.
	__25.  Click Next.
	__26.  The bus member to host the queue should be server1. Click Next.
	__27.  Click Finish to create the queue.
	__28.  Similarly, create another queue called AccountingResponseQ
	__29.  Click the Save link to save your changes.

	Part 3 -  Create JMS Resources
	__1.  In the left hand navigation tree, expand Resources > JMS.
	__2.  Click Queue Connection Factories.
	__3.  Set the scope to server1 as shown below.
	__4.  Click New.
	__5.  Click OK to create the resource for the default messaging provider.
	__6.  Enter these values:
	__7.  Click OK.
	__8.  Click Queues on the left side.
	__9.  Set the scope to server1.
	__10.  Click New.
	__11.  Click OK.
	__12.  Enter these values.
	__13.  Click OK.
	__14.  Click New again and create another destination as follows.
	__15.  Click OK.
	__16.  Save changes.
	__17.  Logout and close the Admin Console.

	Part 4 -  Create the JMS Import
	__1.  Open the assembly diagram for PriceQuoteFlow.
	__2.  Right click and select Add > Import.
	__3.  Change the name of the import to AccountingApp
	__4.  Right click AccountingApp and select Add > Interface.
	__5.  Select WinningQuotePicker and click OK.
	__6.  Right click it again and select Generate Binding > Messaging Binding > JMS Binding.
	__7.  Choose Use pre-configured messaging provider resources.
	__8.  Carefully enter the JNDI names of the JMS resources as shown below.  Double check the spelling carefully.
	__9.  The data format should be set to UTF8XMLDataHandler. This puts messages as XML documents. This is what we want.
	__10.  Click OK.
	__11.  Delete the existing wiring of WinningQuotePickerPartner to the Java component.
	__12.  Wire WinningQuotePickerPartner to the JMS import.
	__13.  Save changes.

	Part 5 -  Configure the JMS Import
	__1.  In the assembly diagram, select the JMS import – AccountingApp.
	__2.  In the Properties view, select the End-point configuration tab.
	__3.  Select the JMS Destinations tab.
	__4.  Expand Callback Destination Properties.
	__5.  Make sure that Specify properties for configuring new messaging provider resource checkbox is selected. Here we will provide enough information so that WebSphere ESB can dynamically create the destination.
	__6.  In the Bus name field, enter DemoBus
	__7.  Press tab to leave the text box. Then save changes.
	__8.  Open the Assembly Diagram for the PriceQuoteFlow project.
	__9.  Select the JMS – AccountingApp.
	__10.  In the Properties view, expand Bindings and select the Method bindings tab.
	__11.  In the right expand Bound Methods and select pickQuote.
	__12.  At the right of it, select the Data Serialization tab.
	__13.  Change the Message type to Text.
	__14.  Save the file.

	Part 6 -  Configure Asynchronous Qualifier
	__1.  In the assembly diagram, select the OrderMediation component.
	__2.  In the Properties view, select the Details tab.
	__3.  Under References, select WinningQuotePickerPartner reference.
	__4.  Click the Qualifiers tab.
	__5.  Select Asynchronous invocation qualifier.
	__6.  Set it's value to Call.
	__7.  Save changes.
	__8.  Select the JMS import – AccountingApp.
	__9.  From the Properties view, expand the Binding tab and select the Message configuration tab.
	__10.  Note that the default setting for correlation scheme is Request Message ID to Correlation ID. That means, the accounting application must copy the request message ID as the correlation ID of the response. We will leave that as it is.

	Part 7 -  A Question of Timeout
	__1.  Verify that for the PickQuote primitive, the timeout is set to 5 seconds by default. Location of the Async timeout property is shown below.

	Part 8 -  Review

	Lab 12 -  Develop the Message Driven Bean (MDB)
	Part 1 -  Create the MDB
	__1.  From the menubar, select File > New > Project.
	__2.  Expand EJB and select EJB Project.
	__3.  Click Next.
	__4.  Enter the following values.
	__5.  Click Next.
	__6.  Uncheck Create an EJB client JAR ...
	__7.  Click Finish.
	__8.  Click Yes when WID asks you to switch perspective to Java EE.
	__9.  Right click  SimpleAccountingEJB project and select New > Enterprise Bean.
	__10.  Choose Message-driven Bean.
	__11.  Enter QuotePicker as the Bean name.
	__12.  Enter com.webage.ejb as the Default package name.
	__13.  Click Finish.
	__14.  Close the class diagram editor without saving.

	Part 2 -  Develop the Code
	__1.  Expand SimpleAccountingEJB > ejbModule > com.webage.ejb.
	__2.  Open the MDB implementation class QuotePickerBean.java
	__3.  A solution for this file is given to you in C:\LabFiles\QuotePickerBean.java. Open the file in notepad. Copy its contents.
	__4.  Replace the entire contents of QuotePickerBean.java in WID with the copied content.
	__5.  Save changes. Make sure there are no compilation errors.

	Part 3 -  Review the MDB Code
	__1.  Locate the onMessage() method. This method is called by the EJB container when the mediation flow posts a new request message.
	__2.  We create a DOM document from the request message.
	__3.  We then iterate through all suppliers in the message and determine the lowest bid.
	__4.  We then create the response DOM document.
	__5.  We save the winning supplier's ID and price in the document.
	__6.  We prepare the response message.
	__7.  We then setup the correlation ID of the response to be same as the ID of the request message. This is the scheme expected by the JMS import we have created in the previous lab.
	__8.  Finally, we post the response message.

	Part 4 -  Configure the MDB
	__1.  Open the administration console for the server.
	__2.  Log in using admin/admin.
	__3.  Expand Resources > JMS.
	__4.  Click Activation specifications.
	__5.  Set the scope to server1.
	__6.  Click New.
	__7.  Click OK.
	__8.  Enter the following values.
	__9.  Click OK.
	__10.  Save changes.
	__11.  Log out of administration console.
	__12.  Under the EJB project double click Deployment Descriptor to open it.
	__13.  Select the Bean tab.
	__14.  Select the QuotePicker Bean.
	__15.  Under WebSphere Binding section, select JCA Adapter.  You may need to scroll down in the lower right section to see this.
	__16.  In ActivationSpec JNDI name enter jms/DemoAS
	__17.  Save and close the deployment descriptor.

	Part 5 -  Deploy Application
	__1.  Add the SimpleAccountingApp project to the server.
	__2.  Since we made many changes, stop and start the server.
	__3.  Wait for the server to start.

	Part 6 -  Test
	__1.  Switch back to the Business Integration Perspective.
	__2.  Under the PriceQuoteFlow project, expand Web Service Ports.
	__3.  Right click OrderTakerExport1_OrderTakerHttpPort and select Web Services > Test With Web Services Explorer.
	__4.  Click placeOrder operation.
	__5.  Next to sku, click Add. 
	__6.  Enter a sku value.
	__7.  Similarly, add a value for quantity and address.
	__8.  Click Go.
	__9.  Open the Console view.
	__10.  Ignore the following exception.
	__11.  Locate various log messages from QuoteMDB logger.
	__12.  Make sure the winning supplier got the order.
	__13.  Close all open files.

	Part 7 -  Review

	Lab 13 -  Using FanOut in Iteration Mode
	Part 1 -  Business Logic and Architecture
	Part 2 -  Modify Schema
	__1.  Create a new business object called SupplierInfo in the PriceQuoteFlow project.
	__2.  Add these fields to the data type.
	__3.  Save and close the editor.
	__4.  Open the Order business object.
	__5.  Add a new field called supplier which is an array of SupplierInfo.
	__6.  Select the supplier field and select in the Properties view the Description tab.
	__7.  Check the box for array.
	__8.  Save and close.

	Part 3 -  Modify the Mediation Flow
	__1.  Open the OrderMediation mediation flow.
	__2.  Delete all three primitives in the path for ACME. (We could have deleted any one of the two paths. Here, we choose ACME).
	__3.  Change the name of the CallAJAX primitive to SendPriceQuote
	__4.  After that, the path coming out of FanOut1 will look like this.
	__5.  Select FanOut1.
	__6.  In the Properties view, select the Details tab.
	__7.  Select the for each element in XPath expression.
	__8.  Click Edit to enter the expression.
	__9.  In the Data Type Viewer, expand ServiceMessageObject > context > shared > order.
	__10.  We need to iterate over the supplier element. Double click the supplier element.
	__11.  The expression will be as follows.
	__12.  Click Finish.
	__13.  Select the FanIn1 primitive.
	__14.  In the Properties view, select the Details tab.
	__15.  Select the associated Fan Out primitive has iterated through all messages.
	__16.  Save changes.

	Part 4 -  Dynamically Set Quote Request to a Supplier
	__1.  Select XSLTransformation2.
	__2.  In the Properties view, select the Details tab.
	__3.  Click New.
	__4.  Click Next.
	__5.  Select "/" as the message root.
	__6.  Click Finish.
	__7.  First re-map the sku and quantity elements from the shared context of the source to the body of the target. This was already done in the old map but we have to do it again. 
	__8.  In the source object, expand  context/primitiveContext/FanOutContext/occurrence.
	__9.  In the target message, expand headers/SMOHeader/Target.
	__10.  Map supplierId from the source to the import element of the target.
	__11.  Click the dropdown icon for the Move map and select Custom.
	__12.  Set the XPath expression to: concat($supplierId, 'Import')
	__13.  Save and close the map.
	__14.  Save the mediation flow.

	Part 5 -  Test
	__1.  Publish changes to the server. Wait for publishing to finish.
	__2.  Expand Web Service Ports in the PriceQuoteFlow project.
	__3.  Right click OrderTakerExport1_OrderTakerHttpPort and select Web Services > Test With Web Services Explorer.
	__4.  Click placeOrder operation.
	__5.  Click the Add link for sku, quantity and address and enter some values.
	__6.  Click the Add link for supplier.
	__7.  Click the Add link for supplierId and enter AJAX
	__8.  Similarly, add another supplier and set its supplierId to ACME
	__9.  Click the Go button.
	__10.  In the Console view, make sure that both suppliers sent a quote reply back.
	__11.  Verify that the supplier with the lowest quote got the order.
	__12.  In the web services explorer, change supplierId ACME to BOB.
	__13.  Click the Go button.
	__14.  There will be a flurry of exceptions in the console. You should be able to locate the following error message. Do a search in the console if you need to.
	__15.  In the web services explorer, select the checkbox for supplier BOB as shown below.
	__16.  Click the Remove link for the supplier element.
	__17.  Make sure that supplier BOB is deleted.
	__18.  Clear the console.
	__19.  Click the Go button.
	__20.  Now, we should see quote from only AJAX which will also be the winning bidder.
	__21.  Finally, delete supplier AJAX also.
	__22.  Click the Go button.
	__23.  Close all open files.

	Part 6 -  Review

	Lab 14 -  Basic Error Handling in Mediation Flow
	Part 1 -  Business Logic and Architecture
	Part 2 -  Alter the Mediation Flow
	__1.  Open OrderMediation.
	__2.  Delete the connection between placeOrder : OrderTaker and XSLTransformation1.
	__3.  Add a Message Filter primitive between those two primitives.
	__4.  Rename the filter to ValidateSupplier
	__5.  Connect the out terminal of placeOrder : OrderTaker to the in terminal of ValidateSupplier.
	__6.  Connect the match1 terminal of ValidateSupplier to the in terminal of XSLTransformation1.
	__7.  In the tool palette, expand Error Handling.
	__8.  Add a Fail primitive from there to near the ValidateSupplier primitive.
	__9.  Connect the default terminal of ValidateSupplier to the in terminal of Fail1.
	__10.  Right click the message flow and select Layout Contents. The modified portion should look like this.
	__11.  Save changes.

	Part 3 -  Specify Filter Rule
	__1.  Select ValidateSupplier.
	__2.  In the Properties view, select Details.
	__3.  Next to the Filters table, click Add.
	__4.  Make sure that Terminal name is match1.
	__5.  Click Edit.
	__6.  In the XPath Expression text area, enter:
	__7.  Click Finish.
	__8.  Click Finish.
	__9.  Save changes.

	Part 4 -  Specify Error Message
	__1.  Select Fail1.
	__2.  In the Properties view, select Details.
	__3.  Enter an error message such as this.
	__4.  Click any  place in the flow.
	__5.  Save changes.

	Part 5 -  Test
	__1.  Publish changes to the server. Wait for publishing to end.
	__2.  Expand Web Service Ports.
	__3.  Right click OrderTakerExport1_OrderTakerHttpPort and select Web Services > Test With Web Services Explorer.
	__4.  Click placeOrder operation.
	__5.  Click the Add link for sku, quantity and address and enter some values.
	__6.  Do not add any supplier. We are trying test for the failure condition.
	__7.  Click the Go button.
	__8.  In the Console view, search for FailFlowException. You should find a line with the exception stacktrace for it. Also, locate the error message.
	__9.  Close all open files.

	Part 6 -  Review

	Lab 15 -  Planned Error Handling
	Part 1 -  Business Logic and Architecture
	Part 2 -  Alter the Service Interface
	__1.  Create a new business object called OrderFailure
	__2.  Add these fields.
	__3.  Save and close the editor.
	__4.  Close the OrderMediation mediation flow editor if it is open. We will make a lot of changes to its service interface. Keeping the editor open can cause problems.
	__5.  Open OrderTaker interface.
	__6.  Click the placeOrder operation to select it.
	__7.  Right click on the placeOrder operation and select Change to Request Response Operation.
	__8.  Select output1. 
	__9.  Right click it and select Delete. The operation does not have any output.
	__10.  Select the placeOrder operation again.
	__11.  Click the Add Fault toolbar button to add a fault.
	__12.  Change the name of the fault parameter to error
	__13.  Set the data type of the fault parameter to OrderFailure
	__14.  Verify that the operation now looks like this.
	__15.  Save and close the editor.

	Part 3 -  Change the Mediation Flow
	__1.  Open OrderMediation mediation flow.
	__2.  Scroll to the very right and you will see that a fault node has been added.
	__3.  Move the fault node close to the ValidateSupplier message filter.
	__4.  Delete the Fail1 primitive. We will not need it any more.
	__5.  Connect the default terminal of ValidateSupplier to the input terminal of the new fault node. WID will automatically insert a XSL transformation (XSLTransformation4) primitive in the middle.
	__6.  Save changes. Changes to our flow is now complete.

	Part 4 -  Specify Error Data
	__1.  Double click XSLTransformation4.
	__2.  Click Finish.
	__3.  Map the sku and quantity elements.
	__4.  Right click the reason element in the target and select Create Assign.
	__5.  In the Properties view, set the error message.
	__6.  Save and close the editor.
	__7.  Save the changes in the OrderMediation and close the editor.

	Part 5 -  Regenerate Export Binding
	__1.  Open the assembly diagram.
	__2.  Right click OrderTakerExport1 and select Regenerate Binding.
	__3.  Click OK to confirm.
	__4.  Select SOAP1.1/HTTP.
	__5.  Click OK.
	__6.  Save the assembly diagram.

	Part 6 -  Test
	__1.  Close all open windows (Control+Shift+W). Specifically, the web services explorer windows should be closed since the service interface has changed.
	__2.  Publish changes to the server. You may see the following error message.
	__3.  Clear the console.
	__4.  Expand Web Service Ports.
	__5.  Right click OrderTakerExport1_OrderTakerHttpPort and select Web Services > Test With Web Services Explorer.
	__6.  Click placeOrder operation.
	__7.  Click the Add link for sku, quantity and address and enter some values.
	__8.  Do not add any supplier. We are trying test for the failure condition.
	__9.  Click the Go button.
	__10.  In the web services explorer, in the Status pane, click the Source link to view the SOAP messages.
	__11.  Verify that the SOAP response contains a fault and the error data.
	__12.  Close all open files.

	Part 7 -  Review

	Lab 16 -  Protocol Translation Pattern
	Part 1 -  Business Logic and Architecture
	Part 2 -  Create a Mediation Module
	__1.  Create a mediation module called AdapterTest. Choose not to create any mediation component.

	Part 3 -  Design Data Model
	__1.  Inside the mediation module that you just created, create a new business object (data type) called ProductACMS
	__2.  Add these fields.
	__3.  Save and close.
	__4.  Create a new business object called ProductGBO
	__5.  Add these fields.
	__6.  Save and close.
	__7.  Create a new data type called ProductListGBO
	__8.  Add a field as follows. It is an array of ProductGBO. Remember to make it array.
	__9.  Save and close.

	Part 4 -  Define the Mediation Service Interface
	__1.  Create a new interface called CatalogManager
	__2.  Add a new one-way operation as follows.
	__3.  Save and close.

	Part 5 -  Create the Adapter Based Service for ACMS
	__1.  Right click the AdapterTest project and select New > External Service.
	__2.  Take a moment to study the list of available adapters.
	__3.  Select Flat File.
	__4.  Click Next.
	__5.  Click Next again.
	__6.  Change the name of the project to CatalogFlatFile
	__7.  Select WebSphere ESB Server v6.2 as the runtime.
	__8.  Click Next.
	__9.  Select Outbound. This is because, the mediation flow will send out data from it.
	__10.  Click Next.
	__11.  Leave the default deployment option. This will cause the JCA project (CatalogFlatFile) to be included in the mediation module application (AdapterTestApp).
	__12.  Set the Data format options to Specify a data format for each operation.
	__13.  Click Next.
	__14.  Click Add.
	__15.  A few things to note in this screen.
	__16.  Click Next.
	__17.  Set the operation name to createProduct
	__18.  Set the input type to ProductACMS
	__19.  In the Data format options drop down select Use a data format configuration.
	__20.  Click Select to choose the format.
	__21.  Click Next.
	__22.  Click Select.
	__23.  Expand Delimited and select CSVDataHandler.
	__24.  Click Finish.
	__25.  Click Next.
	__26.  Click Finish.
	__27.  Our operation design is now complete. Click Finish.
	__28.  Click Next.
	__29.  Change the name of the service to ACMSService
	__30.  Click Finish.
	__31.  Note that a new interface called ACMSService has been created. Open it and study the interface.
	__32.  Close the file.

	Part 6 -  Configure the Import
	__1.  Open the assembly diagram.
	__2.  Note that an EIS import called ACMSService has been created for the adapter based service. Select it.
	__3.  In the Properties page, select the Method bindings tab.
	__4.  Select the createProduct method.
	__5.  Set the output directory name to C:\temp\out
	__6.  Click Advanced.
	__7.  Check Generate a unique file.
	__8.  Save changes and close the assembly diagram.

	Part 7 -  Design the Mediation Flow
	__1.  Right click Integration Logic and select New > Mediation Flow.
	__2.  Enter CatalogMediation as the name.
	__3.  Click Next.
	__4.  As source interface, add the generic interface CatalogManager.
	__5.  As the target reference add the ACMSService interface.
	__6.  Click Finish.
	__7.  Connect the createProduct source method to createProduct target method.
	__8.  Add a Fan Out primitive to the flow.
	__9.  Connect the output of createProduct : CatalogManager to the input of FanOut1.
	__10.  Select FanOut1.
	__11.  In the Properties page, select Details tab.
	__12.  Choose for each element in XPath expression.
	__13.  Click Edit.
	__14.  Enter the following expression. Use the Data Types Viewer if you want.
	__15.  Click Finish.
	__16.  Connect the out terminal of FanOut1 to the in terminal of createProduct : ACMSServicePartner. WID will insert a transform primitive in the middle.
	__17.  Double click XSLTransformation1.
	__18.  Click Next.
	__19.  Choose "/" as the message root. Why do we do this?
	__20.  Click Finish.
	__21.  Map the elements from FanOutContext/occurrence of the source to the target as shown below.
	__22.  Save and close the map.
	__23.  Save the mediation flow. We are done!

	Part 8 -  Wire Components
	__1.  Open the assembly diagram.
	__2.  Add the mediation flow to it.
	__3.  Wire the reference of the mediation flow to ACMSService import.
	__4.  Save changes.

	Part 9 -  Expose Mediation Flow as Web Service
	__1.  In the assembly diagram, right click CatalogMediation and select Generate Export > Web Service Binding.
	__2.  Select SOAP1.1/HTTP.
	__3.  Click OK.
	__4.  Save changes.

	Part 10 -  Deploy and Test
	__1.  Start the server if it is not running. Wait for the server to start.
	__2.  Right click the server and select Add and Remove Projects.
	__3.  Remove all currently deployed projects.
	__4.  Add AdapterTestApp.
	__5.  Expand AdapterTestApp and note that CatalogFlatFile JCA project is a part of it.
	__6.  Click Finish. Wait for publishing to end.
	__7.  Create the output folder C:\temp\out
	__8.  In the AdapterTest module, expand Web Services Ports.
	__9.  Right click CatalogManagerExport1_CatalogManagerHttpPort and select Web Services > Test With Web Services Explorer.
	__10.  Click createProduct.
	__11.  Next to the product element click Add.
	__12.  Add sku, name and price elements and enter some values for them.
	__13.  Similarly, add one more product.
	__14.  Click Go.
	__15.  The console will show an Exception. We can ignore that.
	__16.  Verify that C:\temp\out now contains two files (one for each product).
	__17.  View the contents of the files using Notepad. Make sure that they are valid.
	__18.  Close these files.
	__19.  Back in Business Integration close all open files.

	Part 11 -  Review




