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Lab 1 - WebSphere Workspace Configuration
In this lab you will configure the RAD workspace to work with a WebSphere test 
environment server.  This will include creating a WebSphere "profile" which will have 
the server definition.  It is sometimes useful to have different profile configurations for 
testing purposes so this process is good to be familiar with.

Part 1 - Create Profile
The WebSphere Application Server software is installed along with RAD.  In this section 
you will run a standard WebSphere tool, the Profile Management Tool, to create a profile.

__1. From the Windows Start menu select Start → Programs → IBM Software 
Delivery Platform → IBM Rational Application Developer 8.0 →  Rational 
Application Developer.

__2. In the workspace window, change the Workspace to C:\workspace

__3. Click OK.
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RAD 8.0.4 will start.

__4. In the Runtime environment and profile settings dialog that appears check that the 
option to '<Create a new profile>' is available and click the Next button.

Note: If you DO NOT get this prompt it is possible that a profile was created for this 
workspace already.  Since it is always best for the user who will be using the workspace 
to create the profile restart RAD and use a different workspace with RAD.  Inform your 
instructor of this to see if it is a common problem in the class.

If there is an existing profile listed in the dialog a previous profile may already exist. 
Let your instructor know about this because although this profile can likely be used with 
your workspace, if it has applications deployed to it from another workspace, there may 
be errors when starting the server.  It is also possible to run the 'Profile Management 
Tool' to create a new profile but this will be complex and should be guided by the 
instructor.
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__5. Uncheck the 'enable administrative security on the profile' option as shown 
below and click the Finish button.

The Features with Trial Licenses dialog will open.

__6. Click Ignore.

__7. If prompted about help content select Work without Help.

__8. Wait until the messages in the lower right corner of RAD disappear to know the 
work of creating the server is complete.
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__9. If prompted by Windows firewall security hit the Cancel button.

__10. Close the Welcome page if it appears.

__11. Select the Servers view on the bottom of the Java EE perspective.

__12. Check that a WebSphere Application Server v8.0 server is shown.

__13. Open the following file: 
C:\IBM\WebSphere\AppServer\logs\manageprofiles\AppSrv1_create.log
__14. Look at the end of the file for the message: 

If you see the message INSTCONFSUCCESS, it means that the WebSphere Application 
Server profile was created correctly.
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__15. Close the log file.

__16. Switch back to RAD and the Servers view.

__17. Make sure the server is stopped.

__18. Double click on the server to open the server properties.

__19. On the right, expand Publishing and select the 'Never publish automatically' 
option.

__20. Save and close the server properties.

__21. Select the WebSphere Application Server v8.0 server that was created in the 
Servers view and click the Start the server button on the right.
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__22. From the menu, select Window > Show View > Console.

__23. Check the Console view as the server starts to look for errors.

__24. Switch back to the Servers view and check that the server was started.

__25. Right click the server and select Stop.

__26. Check that the server was Stopped.

Part 2 - Review
You have now configured a test server to use with the RAD workspace.
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Lab 2 - Getting Started
Throughout this class, we will apply various WS-Security protections to a web service 
provider and consumer. In this lab, we will install and test these applications before any 
security is enabled.

Tip: Always function test a provider and consumer before security is enabled. This will 
help you debug problems when security related problems begin to appear.

The business logic for these applications is very simple. The provider is called 
BillingManagerService. It has only one operation called addAccount. A consumer calls 
this operation to create a new customer account.

The consumer is a web based application. When a new account form is submitted, it calls 
the addAccount operation of the web service.

Part 1 - Review Code
We will briefly review the code of the provider and consumer. They have been developed 
using the JAX-WS API. There is nothing special about them. In other words, there is 
nothing done to them specific to WS-Security. All security settings will later be applied 
through policies.

__1. Select Start > All Programs > IBM Software Delivery Platform > IBM Rational 
Application Developer 7.5 > IBM Rational Application Developer.

__2. Enter C:\workspace as the workspace folder.

__3. Click OK.

__4. Close the Welcome screen.

__5. Click Ignore if the Warning: Help content not installed dialog opens. 

__6. Close any dialog that may open related with the Trial version.

__7. From the menu select File > Import.

__8. Expand General and select Existing Projects into Workspace.

__9. Click Next.

__10. Click the second Browse button next to Select archive file.

__11. Select the ZIP file C:\LabFiles\Billing.zip and click Open.
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__12. Click Select All to select all projects.

__13. Click Finish to import the projects.

First, we will review the service provider.

__14. Expand the BillingWeb project.

__15. Then expand Java Resources > src > com.webage.billing.

__16. Double click BillingManager.java to open the provider implementation class.

__17. Notice that the @WebService annotation is used for the class.
@WebService
public class BillingManager {
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__18. The class has only one public method called addAccount. Various JAX-WS 
annotations are used with that method to customize the XML schema for the request and 
response.
@WebMethod
@WebResult(name="status")
public String addAccount(

@WebParam(name="account")
CustomerAccount account) {

This is pretty basic JAX-WS API. If you have any questions about them ask the 
instructor.

__19. Note that the addAccount operation simply prints out a few lines in the log file and 
finally returns "OK".

__20. Close the editor.

Now, we will review the consumer.

__21. Expand ClientWeb project.

__22. Expand WebContent.

__23. Right click index.jsp and select Open With > JSP Editor.

__24. Observe the following:

• The JSP file has a form that is submitted to index.jsp

• If the request method is POST, the BillingManagerPortProxy class is used to 
invoke the addAccount operation.

__25. Close the editor.

Part 2 - Deploy the Applications
Normally, as a developer, you would deploy the projects to the server using RAD. But, in 
the following labs, we will do things like the administrators. That means, we will export 
an EAR file and deploy the EAR using WebSphere admin console. This will give us a 
feel for how policies are actually configured and attached to service providers and 
consumers in real life. That approach will also drive home the point that no code change 
is required to enable security.

__1. Open the Servers view.

__2. Select WebSphere Application Server v8.0 at localhost; for future references we 
will call it 'the Server'.

__3. Right click on it and select Start.
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__4. Wait until the status of the server becomes Started.

__5. Launch a browser window like IE or FireFox.

__6. Enter the URL: 
http://localhost:9060/ibm/console/
__7. Enter anything as user ID (such as www) and log in.

The admin console will open.

__8. Expand Applications.

__9. Click New Application.
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__10. Click New Enterprise Application.

__11. Make sure that Local file system is selected.

__12. Click Browse.

__13. Select C:\LabFiles\BillingApp.ear and click Open.

__14. Click Next.

__15. Leave the default in the How do you want to install the application? page and 
click Next.

__16. In the Step1: Select installation options page just click Next.

__17. In the Step 2: Map modules to servers page, again just click Next.

__18. In the Step 3: Metadata for modules page, again just click Next.

__19. Click Finish.
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__20. The application will be installed, wait until you see the following message: 

__21. Click Save.

Part 3 - Test the Application
__1. On the left hand side, expand Applications > Application Types.

__2. Click WebSphere enterprise applications.

__3. Select the check box next to BillingApp.

__4. Click the Start button.

__5. Launch a new web browser window or tab.

__6. Enter the URL: 
http://localhost:9080/ClientWeb/index.jsp
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__7. The page will be displayed. Add some input as shown below.

__8. Click Add.

__9. The JSP will call the web service. Make sure that the page shows the success 
message:

__10. Back in RAD, the Console view will show the log output from the web service.

Part 4 - Enable SOAP Monitoring
We will use the TCP monitor tool to inspect SOAP messages.

__1. In the Servers view, right click the server and select Monitoring > Properties.

__2. Click Add.

__3. Select the port 9080

The Monitor port will be set to 9081 by default. That means, all HTTP requests 
submitted to localhost:9801 will be forwarded to 9080.

__4. Click OK.

__5. Select the newly added monitor port and click Start.

__6. Click OK.

By default, the consumer submits SOAP request to port 9080. We need to change it to 
9081.
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__7. Open a file browser and navigate to the folder: 
C:\IBM\WebSphere\AppServer\profiles\AppSrv1\installedApps\hostnameNode01Cell\Bi
llingApp.ear\ClientWeb.war\WEB-INF\wsdl

Note: You need to use your hostname as shown in bold below. In this example:
C:\IBM\WebSphere\AppServer\profiles\AppSrv1\installedApps\WA2215Node01C
ell\BillingApp.ear\ClientWeb.war\WEB-INF\wsdl
__8. Open the file BillingManagerService.wsdl using Wordpad.

__9. Scroll to the end of the file and then change the SOAP endpoint to port 9081.
<soap:address 
location="http://localhost:9081/BillingWeb/BillingManagerService"/>
__10. Save and close the editor.

We will now restart the application and test the consumer.

__11. Back in admin console web page, select the checkbox for BillingApp.

__12. Click Stop.

__13. Select again the checkbox for BillingApp.

__14. Click Start.

__15. Go back to the consumer web page (http://localhost:9080/ClientWeb/index.jsp).

__16. Enter some input data and click Add.

__17. Make sure that the success message is shown.

We will now inspect the SOAP messages.

__18. In RAD, select Window > Show View > Other.

__19. Expand Debug and select TCP/IP Monitor.

__20. Click OK.

__21. Maximize the TCP/IP Monitor  view.

Copyright 2014 Web Age Solutions Inc. 16

EVALUATIO
N O

NLY



__22. You should see a request already captured. Select it as shown below. Also, set the 
display type to XML.

__23. Study the request and response messages. They are in plain text since we have not 
enabled any message security.

__24. Click the eraser toolbar in TCP monitor to remove all captured messages.

__25. Restore the size of the TCP/IP Monitor view.

__26. Close all web browsers.

Part 5 - Review
In this lab, we installed a basic web service provider and consumer. They have been 
developed using the JAX-WS API.

We tested the applications to make sure that they are functionally correct.

We have enabled TCP monitoring so that we can inspect the SOAP messages.

In the subsequent labs, we will enable various message protection features.
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Lab 3 - Message Integrity using WS-Security
In this lab, we will implement message integrity for the BillingManagerService provider 
and consumer. But, before that we will review the basics of WS-Security.

The BillingManagerService web service so far has been operating without any form of 
security.  Our clients have been sending SOAP messages to the web service in clear plain 
text, with no regard for security at all.

This is clearly not practical in many production environments. For a web service, the 
concept of security has three concerns:

Integrity: Integrity ensures that a message came from a unique party, and that the 
message has not been tampered with in transmission.  This is achieved by signing the 
outgoing SOAP message. In this lab exercise, we will implement message integrity.

Authority: Ensures that an invocation of a web service is only allowed for authenticated 
clients.  This is achieved by adding a username/password token to the message.  

Confidentiality: Ensures that a message being transmitted can only be understood by the 
receiving party.  This is achieved by encrypting the outgoing SOAP message.

Ideally, we would like to add some combination of these 3 factors into our web service 
layer.  Invoking a service should be done with integrity, with authority and with 
confidentiality.  

But how can we do this?  The hard way would be to add code to our SOAP layer. 
Remember that SOAP (XML) is the underlying communication mechanism for a client 
and service.  For confidentiality, we could go about adding code to our service to return 
encrypted responses; for integrity, we could add code our client to attach a digital 
signature. This would involve an extremely long and complex series of coding additions 
to our client.

Fortunately for us, the JAX-WS spec can help us avoid having to do just that. JAX-WS, 
instead makes use of policies, which will provide all the security layers that we need. 

Security in web services is handled by using the concept of policy set. A policy set is a set 
of policies; policies are rules (defined by a specification) specifying what features should 
be enabled.  For example, a policy  can be created stating that  integrity should be 
enabled; or integrity and authority; or even integrity and authority and encryption. 
(Multiple policies can be combined into a single policy set).   These policies are defined 
by the WS-Security specification, and any JAX-WS compliant run-time must support 
these policies.

Once a policy has been created (in the form of an XML file), it is attached to a service, 
using vendor tools.  No code changes have to be made.  Now, when a client attempts to 
invoke the service, the container (WebSphere) will insist that the client encode the 
request message appropriately (e.g. encrypting the message, attach a signature, etc).  If 
the client does not have the appropriate security measures in place, the service will reject 
the client.
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So, we know how get the service to require security; but how do we get the client to 
attach the required security?  Again, the answer is the use of a policy.  A policy can also 
be attached to a client.  The client stub will read the attached policy and at invocation 
time, the client stub will generate the required SOAP – encrypting, attaching signatures, 
etc- as necessary. 

This means our client code does not have to change; we just have to make sure we attach 
the policy set to the client stub, and the client stub will handle all the rest.

In this lab, we will examine a simple policy set to enable security; we will then attach it 
to a service (and client) and invoke it.

Part 1 - Understanding Policy Set
A policy set is a ZIP file consisting of a file called policySet.xml as well as one or more 
policy.xml files, each in its own sub-directory.  Each policy.xml file contains a list of 
features to be enabled.  The policySet.xml file then contains a list of which policy.xml 
files to use.  

Once a policy set ZIP file has been created, it needs to be imported into the run-time (i.e. 
RAD and WebSphere).  When imported, the run-time will examine set the policy set's 
policySet.xml and, in turn, read each policy.xml that is referenced. 

Out of the box, several policy sets are available.  For example, WebSphere and RAD 
come bundled with a policy set called “WS-ReliableMessaging” - which enables reliable 
messaging.

In this lab, however, we will use our own policy set. We will now briefly inspect a policy 
set ZIP file. We will inspect the policies in more details from within WebSphere 
adminconsole.

__1. Using a Windows file explorer, navigate to C:\LabFiles.  Notice that it contains a 
file called IntegrityOnly.zip.  This is the policy set has a policy that enables message 
integrity.  

__2. Open the ZIP file using Winzip or any other archiving program.

__3. In the PolicySets\IntegrityOnly folder, locate the policySet.xml file.

__4. Open the policySet.xml file. Note that the set includes a single policy as follows:
<ps:PolicyType type="WSSecurity" provides="" enabled="true">
</ps:PolicyType>
__5. Close the file.

__6. Open the PolicyTypes sub-folder. In here, there is a sub-directory called 
WSSecurity – which is exactly what the PolicyType element in policyTypes.xml 
referred to.  Basically, the run-time will read the policyTypes.xml file and then search for 
an appropriate sub-directory with the same name.  

But what goes into the policy type sub-directory? 

Copyright 2014 Web Age Solutions Inc. 19

EVALUATIO
N O

NLY



__7. Open the WSSecurity folder. 

It contains a single file – policy.xml.  This file specifies what features to activate. 

__8. Open policy.xml with a text editor. 

Ouch.  This is a fairly complex XML file.  For now, focus on these elements:
    <wsp:Policy wsu:Id="request:app_signparts">
        <sp:SignedParts>
            <sp:Body/>
...
        </sp:SignedParts>
This enables signing of the SOAP <Body> element.

__9. Close the file and close the ZIP file.

Part 2 - Import the Policy Set
Before a policy set can be attached to a service provider or consumer, we must import it 
in the WebSphere profile.  We will do so now.

__1. In RAD, locate the Servers view.

__2. Start the server if it is not running.

__3. When the server is started, right-click on the server (in the Servers view) and select 
Administration | Run administrative console.

The admin console will open inside RAD. 

This is the administrative front end to WebSphere that you saw in the previous Lab, and 
is where a WebSphere administrator would perform the majority of administration tasks.  
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__4. In the left pane, expand Services | Policy Sets. 

__5. Click Application policy sets.

The right pane will display the Application policy sets screen. 

This lists all the policy sets that are currently deployed to WebSphere.   As mentioned 
above, there are a few “out of the box” policy sets available.  
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__6. Scroll down the list to examine some of them and what they offer.  For example, 
examine the WS-I RSP profile, and look at what it offers.

Instead of using one of these existing profiles, however, we will use the one we examined 
previously.  To do so, we need to import it here.

__7. Scroll up.  Click the Import button, and select From Selected Location... from the 
drop-down.

The screen will change to allow you to specify a location for the policy set.

__8. Click the Browse... button.

__9. Select C:\LabFiles\IntegrityOnly.zip and click Open.

__10. Click OK.
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A Messages pane will appear. 

__11. Click the Save link.

The policy set will be imported.

__12. In the list of policies, scroll down.  You should see the newly imported policy set. 

Part 3 - Attach Policy Set
To enable message integrity, we need to attach the policy set to the provider. And since 
the consumer is also running in WebSphere, we need to attach the policy set to it as well. 
If the consumer was running in a different platform, say .NET, you will have to use 
vendor specific ways to enable integrity. If you do not enable integrity at the client level, 
the server will reject a SOAP request that does not contain a digital signature of the 
message.

First, we will attach the policy set to the provider.

Note: A policy set can be attached to a provider or consumer using either RAD or 
WebSphere adminconsole. The former is perhaps easier during development. Here, we 
will do things like an administrator would in a production environment. That means, we 
will attach policy sets using the adminconsole.

__1. On the left hand side of admin console, expand Services and click Service 
providers.

__2. Click BillingManagerService.
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__3. Select the checkbox for BillingManagerService.

This will select the entire service so that we can attach the policy set to it. Alternatively, 
you can select a specific operation, such as addAccount, and attach a policy set to it. That 
way, different operations can have different policies. In this lab, we will keep things 
simple and attach the policy set for the whole service.

__4. Click the Attach Policy Set button and click IntegrityOnly.

Now, we need to attach a policy set binding to the provider.

What is a policy set binding? A policy simply states what communication behavior 
should be enabled. For example, integrity and encryption. Various encryption and digest 
algorithms are also specified in the policy. A policy does not specify machine or 
installation specific details. For example, it does not describe the location of the private 
key and the password to open the key store file. Policy set binding is used to describe 
those items.

A policy set is generic and not specific to any business or installation of application 
server. For example, the same policy set ZIP file can be copied from development 
machine to production without any modification. A policy set binding ZIP file, on the 
other hand, contains installation specific details.

In this and the next few labs, we will use a predefined policy set binding. This binding 
uses pre-generated keys for the provider and consumer. This is good enough for 
development. In a production environment, you must generate your own keys. 
Preferably a key should be signed by a well known certificate authority. We will learn 
about key management and custom binding design in a latter lab.

__5. Select the checkbox for BillingManagerService again.

__6. Click Assign Binding > Provider sample.
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__7. Verify that the correct policy set and binding is displayed for the service.

__8. Click the Save link at the top of the page to save changes.

Now, we will configure the consumer.

__9. On the left hand side, click Service clients under Services.

__10. Click BillingManagerService.

__11. Select the checkbox for BillingManagerService.

__12. Click Attach Client Policy Set > IntegrityOnly.

__13. Select the checkbox for BillingManagerService again.

__14. Click Assign Binding > Client sample.

__15. Verify that the correct policy set and binding is displayed for the consumer.

__16. Click the Save link at the top of the page to save changes.

Now, integrity should enabled. Before we can test things, we need to restart the server. 
Note: In WebSphere, server must be restarted after policy set and binding attachments 
have been modified for a service provider or client.

__17. Log out of admin console by clicking the Logout link at the top right corner.

__18. Close the browser.

__19. Select the server in Servers view.

__20. Press Control+Alt+R to restart the server or right click the server and select 
Restart.
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__21. Wait for the server status to change to Started.

Part 4 - Test Message Integrity
__1. First make sure that the TCP monitoring proxy service is still running. To do that, 
right click the server and select Monitoring > Properties. Make sure the status is 
Started. Otherwise, start it.

__2. Click OK to close the monitor settings dialog.

__3. Open a browser window and enter the URL for the consumer application: 
http://localhost:9080/ClientWeb/index.jsp
__4. Enter some input value. Then click Add.

__5. Make sure that the success message is displayed.

__6. Back in RAD, open the TCP/IP Monitor view and maximize it.

__7. Change the display mode from Byte to XML for both request and response.

__8. For the request message, observe the SOAP <Body> element of the Request is still 
in plain text. This is expected since we have not enabled encryption.

__9. In the header of the Request, locate the <ds:SignatureValue> element.
<ds:SignatureValue>r43pj30kuKqKy ... Mp10m994z8Rk=</ds:SignatureValue>
This contains the digital signature of the message.

The digest of the message is also available in the <DigestValue> element as shown 
below.
<ds:DigestValue>EVFKYcBANxvWQavJm3spuddWNrk=</ds:DigestValue>
But, that is rather redundant. The signature is the digest encrypted by the consumer's 
private key.

The consumer sends its public key in the form of its certificate. You can see that in the 
BinarySecurityToken element.

A BinarySecurityToken can carry any token that uniquely identifies the consumer. The 
ValueType attribute clearly describes the nature of the token. In our case, it is 
ValueType="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-x509-token-
profile-1.0#X509v3". This value type indicates that the token is a X509 certificate.

Why does the client send its certificate? The provider uses that to decrypt the signature 
and obtain the digest. If encryption is enabled, the provider uses the public key from the 
certificate to encrypt the SOAP response message.

__10. Similarly, locate and observe the  SignatureValue,  DigestValue and 
BinarySecurityToken elements in the SOAP response message.
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Part 5 - Test for Integrity Failure
Now, we will mount a man in the middle attack. We will alter the request message and 
resend it. The TCP/IP Monitor view allows us to modify an existing request and resend it.

First, we need to view the HTTP header of the existing request. If we do not do that, 
headers will be omitted from the modified request. Which appears to be a bug in RAD.

__1. In the TCP/IP Monitor view, move your mouse over the low-arrow at the top-right 
of the menu bar, it will display View Menu. 

__2. Click the View Menu button and select Show Header.

__3. The  TCP/IP Monitor view now will show the header for the Request and 
Response.

__4. In the top pane of the TCP/IP Monitor view, right click the request and select 
Modify request.

The tool will create a modified request.
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Note: The request can be edited in Byte mode only. If you change the display mode to, 
say, XML, the editor will become read only.

__5. In the Request editor, scroll carefully to the right and locate the <address> element 
in the bottom line.

__6. Replace some of the characters in the body of the <address> element. For example, 
change 1 to 2. Or, change an upper case letter to lower case. Important: Make sure that 
the total number of characters remain the same.

__7. Right click the modified request and select Send Modified Request.

__8. The Console view will show an exception from the service.

__9. Back in the TCP/IP Monitor view, for the Response pane, change the display mode 
to XML.
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__10. Notice that a fault has been returned by the server:

__11. Clear all requests in TCP/IP Monitor by clicking the eraser toolbar button.

__12. Hide the Header since you don't need it anymore, remember that you opened the 
header to modify a request.

__13. Close any open web browser.

Part 6 - Review
Message integrity is used to implement the non-repudiation feature. That is a legal term 
which means, a party sending a message can not deny that it had sent that message. In 
addition, it can not claim that a third party had altered the message.

Enabling message integrity is the first step in setting up non-repudiation. The provider 
will validate the request and the consumer will validate the response. Any man in the 
middle attack will be immediately detected. However, to resolve any disputes between 
business at a later date, you need to also save the message, its signature and sender's 
certificate in an audit log. In case of a dispute, the message should be validated again.

In this lab, we enabled message integrity. We also attempted a man in the middle attack 
which was successfully thwarted. 

We also learned a lot of policy set and policy binding. They allow us to change the client 
server communication without changing any code.
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	Lab 1 -  WebSphere Workspace Configuration
	Part 1 -  Create Profile
	__1.  From the Windows Start menu select Start → Programs → IBM Software Delivery Platform → IBM Rational Application Developer 8.0 →  Rational Application Developer.
	__2.  In the workspace window, change the Workspace to C:\workspace
	__3.  Click OK.
	__4.  In the Runtime environment and profile settings dialog that appears check that the option to '<Create a new profile>' is available and click the Next button.
	__5.  Uncheck the 'enable administrative security on the profile' option as shown below and click the Finish button.
	__6.  Click Ignore.
	__7.  If prompted about help content select Work without Help.
	__8.  Wait until the messages in the lower right corner of RAD disappear to know the work of creating the server is complete.
	__9.  If prompted by Windows firewall security hit the Cancel button.
	__10.  Close the Welcome page if it appears.
	__11.  Select the Servers view on the bottom of the Java EE perspective.
	__12.  Check that a WebSphere Application Server v8.0 server is shown.
	__13.  Open the following file: 
	__14.  Look at the end of the file for the message: 
	__15.  Close the log file.
	__16.  Switch back to RAD and the Servers view.
	__17.  Make sure the server is stopped.
	__18.  Double click on the server to open the server properties.
	__19.  On the right, expand Publishing and select the 'Never publish automatically' option.
	__20.  Save and close the server properties.
	__21.  Select the WebSphere Application Server v8.0 server that was created in the Servers view and click the Start the server button on the right.
	__22.  From the menu, select Window > Show View > Console.
	__23.  Check the Console view as the server starts to look for errors.
	__24.  Switch back to the Servers view and check that the server was started.
	__25.  Right click the server and select Stop.
	__26.  Check that the server was Stopped.

	Part 2 -  Review

	Lab 2 -  Getting Started
	Part 1 -  Review Code
	__1.  Select Start > All Programs > IBM Software Delivery Platform > IBM Rational Application Developer 7.5 > IBM Rational Application Developer.
	__2.  Enter C:\workspace as the workspace folder.
	__3.  Click OK.
	__4.  Close the Welcome screen.
	__5.  Click Ignore if the Warning: Help content not installed dialog opens. 
	__6.  Close any dialog that may open related with the Trial version.
	__7.  From the menu select File > Import.
	__8.  Expand General and select Existing Projects into Workspace.
	__9.  Click Next.
	__10.  Click the second Browse button next to Select archive file.
	__11.  Select the ZIP file C:\LabFiles\Billing.zip and click Open.
	__12.  Click Select All to select all projects.
	__13.  Click Finish to import the projects.
	__14.  Expand the BillingWeb project.
	__15.  Then expand Java Resources > src > com.webage.billing.
	__16.  Double click BillingManager.java to open the provider implementation class.
	__17.  Notice that the @WebService annotation is used for the class.
	__18.  The class has only one public method called addAccount. Various JAX-WS annotations are used with that method to customize the XML schema for the request and response.
	__19.  Note that the addAccount operation simply prints out a few lines in the log file and finally returns "OK".
	__20.  Close the editor.
	__21.  Expand ClientWeb project.
	__22.  Expand WebContent.
	__23.  Right click index.jsp and select Open With > JSP Editor.
	__24.  Observe the following:
	__25.  Close the editor.

	Part 2 -  Deploy the Applications
	__1.  Open the Servers view.
	__2.  Select WebSphere Application Server v8.0 at localhost; for future references we will call it 'the Server'.
	__3.  Right click on it and select Start.
	__4.  Wait until the status of the server becomes Started.
	__5.  Launch a browser window like IE or FireFox.
	__6.  Enter the URL: 
	__7.  Enter anything as user ID (such as www) and log in.
	__8.  Expand Applications.
	__9.  Click New Application.
	__10.  Click New Enterprise Application.
	__11.  Make sure that Local file system is selected.
	__12.  Click Browse.
	__13.  Select C:\LabFiles\BillingApp.ear and click Open.
	__14.  Click Next.
	__15.  Leave the default in the How do you want to install the application? page and click Next.
	__16.  In the Step1: Select installation options page just click Next.
	__17.  In the Step 2: Map modules to servers page, again just click Next.
	__18.  In the Step 3: Metadata for modules page, again just click Next.
	__19.  Click Finish.
	__20.  The application will be installed, wait until you see the following message: 
	__21.  Click Save.

	Part 3 -  Test the Application
	__1.  On the left hand side, expand Applications > Application Types.
	__2.  Click WebSphere enterprise applications.
	__3.  Select the check box next to BillingApp.
	__4.  Click the Start button.
	__5.  Launch a new web browser window or tab.
	__6.  Enter the URL: 
	__7.  The page will be displayed. Add some input as shown below.
	__8.  Click Add.
	__9.  The JSP will call the web service. Make sure that the page shows the success message:
	__10.  Back in RAD, the Console view will show the log output from the web service.

	Part 4 -  Enable SOAP Monitoring
	__1.  In the Servers view, right click the server and select Monitoring > Properties.
	__2.  Click Add.
	__3.  Select the port 9080
	__4.  Click OK.
	__5.  Select the newly added monitor port and click Start.
	__6.  Click OK.
	__7.  Open a file browser and navigate to the folder: 
	__8.  Open the file BillingManagerService.wsdl using Wordpad.
	__9.  Scroll to the end of the file and then change the SOAP endpoint to port 9081.
	__10.  Save and close the editor.
	__11.  Back in admin console web page, select the checkbox for BillingApp.
	__12.  Click Stop.
	__13.  Select again the checkbox for BillingApp.
	__14.  Click Start.
	__15.  Go back to the consumer web page (http://localhost:9080/ClientWeb/index.jsp).
	__16.  Enter some input data and click Add.
	__17.  Make sure that the success message is shown.
	__18.  In RAD, select Window > Show View > Other.
	__19.  Expand Debug and select TCP/IP Monitor.
	__20.  Click OK.
	__21.  Maximize the TCP/IP Monitor  view.
	__22.  You should see a request already captured. Select it as shown below. Also, set the display type to XML.
	__23.  Study the request and response messages. They are in plain text since we have not enabled any message security.
	__24.  Click the eraser toolbar in TCP monitor to remove all captured messages.
	__25.  Restore the size of the TCP/IP Monitor view.
	__26.  Close all web browsers.

	Part 5 -  Review

	Lab 3 -  Message Integrity using WS-Security
	Part 1 -  Understanding Policy Set
	__1.  Using a Windows file explorer, navigate to C:\LabFiles.  Notice that it contains a file called IntegrityOnly.zip.  This is the policy set has a policy that enables message integrity.  
	__2.  Open the ZIP file using Winzip or any other archiving program.
	__3.  In the PolicySets\IntegrityOnly folder, locate the policySet.xml file.
	__4.  Open the policySet.xml file. Note that the set includes a single policy as follows:
	__5.  Close the file.
	__6.  Open the PolicyTypes sub-folder. In here, there is a sub-directory called WSSecurity – which is exactly what the PolicyType element in policyTypes.xml referred to.  Basically, the run-time will read the policyTypes.xml file and then search for an appropriate sub-directory with the same name.  
	__7.  Open the WSSecurity folder. 
	__8.  Open policy.xml with a text editor. 
	__9.  Close the file and close the ZIP file.

	Part 2 -  Import the Policy Set
	__1.  In RAD, locate the Servers view.
	__2.  Start the server if it is not running.
	__3.  When the server is started, right-click on the server (in the Servers view) and select Administration | Run administrative console.
	__4.  In the left pane, expand Services | Policy Sets. 
	__5.  Click Application policy sets.
	__6.  Scroll down the list to examine some of them and what they offer.  For example, examine the WS-I RSP profile, and look at what it offers.
	__7.  Scroll up.  Click the Import button, and select From Selected Location... from the drop-down.
	__8.  Click the Browse... button.
	__9.  Select C:\LabFiles\IntegrityOnly.zip and click Open.
	__10.  Click OK.
	__11.  Click the Save link.
	__12.  In the list of policies, scroll down.  You should see the newly imported policy set. 

	Part 3 -  Attach Policy Set
	__1.  On the left hand side of admin console, expand Services and click Service providers.
	__2.  Click BillingManagerService.
	__3.  Select the checkbox for BillingManagerService.
	__4.  Click the Attach Policy Set button and click IntegrityOnly.
	__5.  Select the checkbox for BillingManagerService again.
	__6.  Click Assign Binding > Provider sample.
	__7.  Verify that the correct policy set and binding is displayed for the service.
	__8.  Click the Save link at the top of the page to save changes.
	__9.  On the left hand side, click Service clients under Services.
	__10.  Click BillingManagerService.
	__11.  Select the checkbox for BillingManagerService.
	__12.  Click Attach Client Policy Set > IntegrityOnly.
	__13.  Select the checkbox for BillingManagerService again.
	__14.  Click Assign Binding > Client sample.
	__15.  Verify that the correct policy set and binding is displayed for the consumer.
	__16.  Click the Save link at the top of the page to save changes.
	__17.  Log out of admin console by clicking the Logout link at the top right corner.
	__18.  Close the browser.
	__19.  Select the server in Servers view.
	__20.  Press Control+Alt+R to restart the server or right click the server and select Restart.
	__21.  Wait for the server status to change to Started.

	Part 4 -  Test Message Integrity
	__1.  First make sure that the TCP monitoring proxy service is still running. To do that, right click the server and select Monitoring > Properties. Make sure the status is Started. Otherwise, start it.
	__2.  Click OK to close the monitor settings dialog.
	__3.  Open a browser window and enter the URL for the consumer application: 
	__4.  Enter some input value. Then click Add.
	__5.  Make sure that the success message is displayed.
	__6.  Back in RAD, open the TCP/IP Monitor view and maximize it.
	__7.  Change the display mode from Byte to XML for both request and response.
	__8.  For the request message, observe the SOAP <Body> element of the Request is still in plain text. This is expected since we have not enabled encryption.
	__9.  In the header of the Request, locate the <ds:SignatureValue> element.
	__10.  Similarly, locate and observe the  SignatureValue,  DigestValue and BinarySecurityToken elements in the SOAP response message.

	Part 5 -  Test for Integrity Failure
	__1.  In the TCP/IP Monitor view, move your mouse over the low-arrow at the top-right of the menu bar, it will display View Menu. 
	__2.  Click the View Menu button and select Show Header.
	__3.  The  TCP/IP Monitor view now will show the header for the Request and Response.
	__4.  In the top pane of the TCP/IP Monitor view, right click the request and select Modify request.
	__5.  In the Request editor, scroll carefully to the right and locate the <address> element in the bottom line.
	__6.  Replace some of the characters in the body of the <address> element. For example, change 1 to 2. Or, change an upper case letter to lower case. Important: Make sure that the total number of characters remain the same.
	__7.  Right click the modified request and select Send Modified Request.
	__8.  The Console view will show an exception from the service.
	__9.  Back in the TCP/IP Monitor view, for the Response pane, change the display mode to XML.
	__10.  Notice that a fault has been returned by the server:
	__11.  Clear all requests in TCP/IP Monitor by clicking the eraser toolbar button.
	__12.  Hide the Header since you don't need it anymore, remember that you opened the header to modify a request.
	__13.  Close any open web browser.

	Part 6 -  Review

	Lab 4 -  Message Confidentiality
	Part 1 -  Import Policy Set
	__1.  In RAD, locate the Servers view.
	__2.  Start the server if it is not running.
	__3.  When the server is started, right-click on the server (in the Servers view) and select Administration > Run administrative console.
	__4.  In the left pane, expand Services > Policy Sets. 
	__5.  Click Application policy sets.
	__6.  Click the Import > From Selected Location.
	__7.  Browse and select C:\LabFiles\ConfidentialityIntegrity.zip
	__8.  Click OK.
	__9.  Make sure that the policy set called ConfidentialityIntegrity has been imported.
	__10.  Click Save at the top of the page to save changes.

	Part 2 -  Review the Confidentiality Policy
	__1.  Click ConfidentialityIntegrity.
	__2.  Click WS-Security.
	__3.  Click Main policy.
	__4.  Click Request message part protection. 
	__5.  Note that parts of the request message are protected for both encryption and integrity.
	__6.  Select app_encparts in the Encrypted parts list.
	__7.  Click Edit.
	__8.  Notice that the entire SOAP <Body> is setup to be encrypted.
	__9.  Click Cancel.
	__10.  Click Done.
	__11.  Click Response message part protection. 
	__12.  Verify that the response Body will also be encrypted.

	Part 3 -  Attach Policy Set
	__1.  On the left hand side click Service providers.
	__2.  Click BillingManagerService.
	__3.  Attach the ConfidentialityIntegrity policy set to the BillingManagerService.
	__4.  Assign the Provider sample binding to the service.
	__5.  Save changes.
	__6.  On the left hand side click Service clients.
	__7.  Click BillingManagerService.
	__8.  Attach the ConfidentialityIntegrity policy set to the BillingManagerService.
	__9.  Assign the Client sample binding to the consumer.
	__10.  Save changes.
	__11.  Log out of admin console and close the browser.
	__12.  Restart the server. Wait for the server to start.

	Part 4 -  Test for Confidentiality
	__1.  Open a browser window and enter the URL for the consumer application: 
	__2.  Enter some input value. Then click Add.
	__3.  Make sure that the success message is displayed.
	__4.  Back in RAD, review that the Console shows the output from the service provider.
	__5.  Open the TCP/IP Monitor view and maximize.
	__6.  Change the display mode from Byte to XML for both request and response.
	__7.  For the request message, observe the following. 
	__8.  Similarly, verify that the Body of the response message is also encrypted.
	__9.  Clear all requests and restore the size in the TCP/IP Monitor view.
	__10.  Close the web browser.

	Part 5 -  Review

	Lab 5 -  Selective Encryption
	Part 1 -  Modify the Policy Set
	__1.  In RAD, locate the Servers view.
	__2.  Start the server if it is not running.
	__3.  When the server is started, right-click on the server (in the Servers view) and select Administration > Run administrative console.
	__4.  Expand Services > Policy Sets and select Application policy sets.
	__5.  Click ConfidentialityIntegrity.
	__6.  Click WS-Security.
	__7.  Click Main Policy.
	__8.  Click Request message part protection.
	__9.  Select app_encparts from the  Encrypted parts list.
	__10.  Click Edit.
	__11.  Select the checkbox for Body.
	__12.  Click Remove.
	__13.  Click Add > XPath expression.
	__14.  In the text area for the newly added XPath expression enter the following code:
	__15.  Click OK.
	__16.  Click Done.
	__17.  Click Response message part protection.
	__18.  Select app_encparts in the Encrypted parts list.
	__19.  Click Delete.
	__20.  Save changes.
	__21.  Log out of admin console and close the browser.
	__22.  Restart the server from RAD. Wait for the server to start.

	Part 2 -  Test Selective Encryption
	__1.  Open a browser and enter the URL: 
	__2.  Enter some input data and click Add.
	__3.  Make sure that you see the success message.
	__4.  In TCP/IP Monitor view select XML for both Request and Response.
	__5.  Observe the following about the request.
	__6.  The response body is completely unencrypted.
	__7.  Clear all requests in TCP/IP Monitor.
	__8.  Close the web browser.

	Part 3 -  Review

	Lab 6 -  Authentication
	Part 1 -  Enable Global Security
	__1.  In RAD, locate the Servers view.
	__2.  Start the server if it is not running.
	__3.  When the server is started, right-click on the server (in the Servers view) and select Administration > Run administrative console.
	__4.  In the left hand side, expand Security and select Global Security.
	__5.  In the Available realm definitions drop down, select Federated repositories.
	__6.  Click Configure.
	__7.  As  Primary administrative user name enter wasadmin
	__8.  Click OK.
	__9.  Enter wasadmin also as password.
	__10.  Click OK.
	__11.  You will be at the Global Security screen again.  Change the Available realm definitions back to Federated repositories.  (The admin console will have re-set it to Local OS which is not desirable)
	__12.  Next to Available realm definitions click Set as current.
	__13.  Check Enable administrative security.
	__14.  Verify that Enable application security is checked.
	__15.  Uncheck Use Java 2 security.
	__16.  Click Apply.
	__17.  Save changes.
	__18.  Log out of admin console and close the browser.
	__19.  Stop the server.
	__20.  Double click the server to open configuration settings.
	__21.  Expand Security.
	__22.  Enable security and enter the administrative user ID and password as shown below.
	__23.  Save and close the page.
	__24.  Start the server.

	Part 2 -  Attach Policy Set
	__1.  Open a web browser like IE or FireFox.
	__2.  Enter the URL: 
	__3.  In FireFox you will see that the connection is untrusted, click I understand the risks, then click the Add Exception button and click the Confirm Security Exception button.
	__4.  In IE click Continue to this website.
	__5.  Login using the user ID wasadmin and password wasadmin.
	__6.  Expand Services.
	__7.  Click Service providers.
	__8.  Click BillingManagerService.
	__9.  Attach  Username WSSecurity default policy set to the provider as you did it in previous labs.
	__10.  Assign Provider sample binding.
	__11.  Save changes.
	__12.  Expand Services.
	__13.  Click Service clients.
	__14.  Click BillingManagerService.
	__15.  Similarly, attach the  Username WSSecurity default policy set and Client sample binding to the consumer.
	__16.  Save changes.

	Part 3 -  Specify User Credentials
	__1.  Expand Services > Policy sets.
	__2.  Click General client policy set bindings.
	__3.  Click Client sample.
	__4.  Click WS-Security.
	__5.  Click Authentication and protection.
	__6.  Under Authentication tokens, click gen_signunametoken.
	__7.  Click Callback handler.
	__8.  Under Basic Authentication, enter wasadmin as the user ID and password.
	__9.  Click OK.
	__10.  Save changes.
	__11.  Log out of admin console.
	__12.  Back in RAD restart the server.

	Part 4 -  Test Authentication
	__1.  Open a new web browser and launch the consumer application: 
	__2.  Enter some value and click Add.
	__3.  Make sure that success message is displayed.
	__4.  Close the application browser.

	Part 5 -  Test Failure Condition
	__1.  Log in in the console as wasadmin for Id and password.
	__2.  Follow Part 3 Specify User Credentials and change the password in the policy binding to an invalid one (say, abc123).
	__3.  Make sure that you have restarted the server at the end of the above step.
	__4.  Open a web browser and launch  the consumer application: 
	__5.  Enter some value and click Add.
	__6.  This time the browser will show the following error message.
	__7.  Close all open web browsers.
	__8.  In the Console scroll up and find the message:
	__9.  Restore the password in the admin console to wasadmin the policy binding.
	__10.  Stop the server.

	Part 6 -  Review

	Lab 7 -  WS-SecureConversation
	Part 1 -  Import and Test Starter Projects
	__1.  From the RAD menu select File > Import.
	__2.  Expand General and select Existing Projects into Workspace.
	__3.  Click Next.
	__4.  Click the second Browse button.
	__5.  Select the ZIP file C:\LabFiles\WS-SC-Starter.zip and click Open.
	__6.  Click Select All to select all projects.
	__7.  Click Finish to import the projects.
	__8.  Stop the server if it is not already stopped.
	__9.  Right click the server and select Open.
	__10.  On the right side of the editor, expand the section for Publishing settings for WebSphere Application Server.
	__11.  Select the 'Run server with resources on Server' option as shown below.
	__12.  Save and close the file.
	__13.  Start the server.
	__14.  Right-click on the server and select Add and Remove.
	__15.  Use the Add button to add the 'WS-SC-ClientEAR' and 'WS-SC-ServiceEAR' projects to the server.
	__16.  Click the Finish button and make sure the server publishes the changes.
	__17.  After the server is done publishing the projects, click the Clear Console button in the Console view to clear previous log messages.
	__18.  Open a web browser to the following address.
	__19.  Fill in any name and email, click the Submit button, and make sure you get a response of the profile being created and an ID.
	__20.  Switch back to the Console view in RAD and verify you get a message from the service about receiving the new profile.  This proves the service is being invoked.
	__21.  Close the web browser.
	__22.  Leave the WebSphere server running.

	Part 2 -  Enable WS-SecureConversation Policy on the Service
	__1.  Make sure your WebSphere server is running in the 'Servers' view and start it if it is not.
	__2.  Right click the server and select Administration → Run administrative console. 
	__3.  Login as wasadmin.
	__4.  On the left side navigation, expand Services → Policy sets and click the 'Application Policy Sets' link.
	__5.  Check the box next to the 'Username SecureConversation' policy in the list and click the Copy button from above the table.
	__6.  Provide a name of 'Custom SecureConversation' for the policy copy and click the OK button.
	__7.  Click the Save link in the messages above the table to save the configuration.
	__8.  In the list of Application Policy Sets, click the link for 'Custom SecureConversation' to open the configuration.
	__9.  Click the Add button above the list of policies and click the 'HTTP transport' option.
	__10.  Click the link for the WS-Security policy.
	__11.  Click the 'Main Policy' link.
	__12.  On the right under 'Policy Details' click the link for 'Request Token Policies'.
	__13.  Check the box next to the 'token_auth' entry and click the Delete button.
	__14.  Click the Save link in the messages above the table to save the configuration.
	__15.  On the left side navigation, expand Services → Policy sets and click the 'General client policy set bindings' link.
	__16.  Check the box next to the 'Client sample' binding in the list and click the Copy button from above the table.
	__17.  Provide a name of 'TCPMON Port 9088 HTTP binding' for the policy copy and click the OK button.
	__18.  In the list of client policy set bindings, click the link for 'TCPMON Port 9088 HTTP binding' to open the configuration.
	__19.  Click the link for the HTTP transport policy.
	__20.  Fill in 'localhost' for the Host and '9088' for the Port.
	__21.  Click the OK button when your settings match that above.
	__22.  Click the Save link in the messages above the table to save the configuration.
	__23.  Back on the left side navigation of the admin console, click the link for 'Service Providers' under the 'Services' section of the navigation.
	__24.  Under the list of service providers, click the link for 'CustomProfileManagerService'.  Make sure to click the link under the 'Name' column and not the 'Deployed Asset' column.
	__25.  Check the checkbox next to the top row of the table shown.  This will apply the policy set to the entire service.
	__26.  With the checkbox for the top row checked, click the 'Attach Policy Set' button and pick 'Custom SecureConversation' from the list.
	__27.  Check that the 'Custom SecureConversation' policy set is listed for the top row of the table.  Notice that the other parts of the service inherit this policy set.
	__28.  Click the Save link in the messages above the table to save the configuration.
	__29.  Back on the left side navigation of the admin console, click the link for 'Service Clients' under the 'Services' section of the navigation.
	__30.  Under the list of service clients, click the link for 'CustomProfileManagerService'.  Make sure to click the link under the 'Name' column and not the 'Deployed Asset' column.
	__31.  Check the checkbox next to the top row of the table shown.  This will apply the policy set to the entire service.
	__32.  With the checkbox for the top row checked, click the 'Attach Client Policy Set' button and pick 'Custom SecureConversation' from the list.
	__33.  Check the checkbox next to the top row of the table again.
	__34.  With the checkbox for the top row checked, click the 'Assign Binding' button and pick 'TCPMON Port 9088 HTTP binding' from the list.
	__35.  Check that the 'Custom SecureConversation' policy set and 'TCPMON Port 9088 HTTP binding' binding is listed for the top row of the table.  
	__36.  Click the Save link in the messages above the table to save the configuration.
	__37.  Click the Logout link at the top of the admin console (which will make sure you have no unsaved changes) and close the admin console window.
	__38.  Restart the server in the 'Servers' view.

	Part 3 -  Test WS-SecureConversation
	__1.  Open a Windows Explorer window to the 'C:\LabFiles' directory.
	__2.  Right click on the 'tcpmon.cmd' script file and select Edit.  Make sure not to double click or select 'Open'.
	__3.  In the script check that the value of the 'WAS_BIN' variable points to the correct location for where your WebSphere test environment was installed.  The easiest way to do this might be to copy the entire value (without the quotes) and copy into the Windows Explorer address bar and see if the folder exists.  If the value is not correct for your system find out where the matching directory is, making sure to get the 'bin' directory under the root of the WebSphere test environment install.
	__4.  Save changes if you made any to the file and close the file.
	__5.  Back in the Windows Explorer window showing the 'C:\LabFiles' folder, double click the 'tcpmon.cmd' file to run it.  The command prompt should remain open and after a few seconds you should see the TCPMonitor tool.
	__6.  Fill in a value of '9088' for the 'Listen Port', select the Proxy radio button, and then click the Add button.
	__7.  Select the new tab for port 9088 that should appear at the top of the tool window.  You may also want to maximize the tool.
	__8.  Make sure your WebSphere server is running in the 'Servers' view and start it if it is not.  If you did not restart it at the end of the last section, restart it now to make sure the new settings are being applied.
	__9.  Open a web browser to the following address.
	__10.  Fill in any name and email, click the Submit button, and make sure you get a response of the profile being created and an ID.  The response might take a little longer this time.  Make sure you only submit one request.
	__11.  Leave the web browser open.
	__12.  Switch back to the Console view in RAD and verify you get a message from the service about receiving the new profile.  This proves the service is being invoked.  You may also see an error about a child element but this can be ignored.
	__13.  Switch to the TCPMonitor tool.
	__14.  You should see that there are two entries in the table at the top.  This is the request for the security token along with the actual request for the service operation.
	__15.  In the top of the two windows in the bottom section, scroll down about 1/3 of the way and look for a <wsa:Action ...> element near the end of the SOAP headers.
	__16.  Scroll over to the right for this element and notice that the value of this <wsa:Action ...> element indicates this is the request for the security token.  This is because it references WS-Trust and references 'RST'.
	__17.  Scroll back to the left in the top window.
	__18.  In the bottom of the two windows in the bottom section, scroll down about 1/3 of the way and look for a <wsa:Action ...> element near the end of the SOAP headers.  You should also see a <wsa:RelatesTo ...> element since this is the response to a WS-Addressing request.
	__19.  Scroll over to the right for this element and notice that the value of this <wsa:Action ...> element indicates this is the response for the security token.  This is because it references WS-Trust and references 'RSTR'.
	__20.  Scroll back to the left in the bottom window.
	__21.  Back in the top window that shows the requests, scroll just over halfway down. You can look for the HTTP headers like POST, User-Agent, etc to see where the second request begins.
	__22.  As some of the first SOAP header elements you should see a few <wsc:DerivedKeyToken> elements.  These are the derived keys being used by WS‑SecureConversation.
	__23.  Still in the top window, scroll about 80% of the way down until you see the <wsa:Action ...> element near the end of the SOAP headers.
	__24.  Scroll over to the right for this element and you should see the value is the value expected for the actual request to the web service.  Once the security token is established the actual request for the service is sent.
	__25.  If you want you can find similar elements like the derived keys and service response in the second response message.
	__26.  In the TCPMonitor tool, click the Remove All button under the table of requests.
	__27.  Return to the web browser you were using to submit data with the sample application.
	__28.  Fill in different data with the name and email and submit the new profile.  Make sure you get a response with a different ID for the profile.
	__29.  Go back to the TCPMonitor tool.
	__30.  Scroll down the top window showing the request and notice that there is only one request and it already is using the derived key token.  This is showing the benefit of WS‑SecureConversation.
	__31.  Close the TCPMonitor tool and the web browser window you were using.
	__32.  Stop the server in RAD.

	Part 4 -  Review

	Lab 8 -  Develop a Simple RESTful Service
	Part 1 -  Create the Web Service Project
	__1.  From the menubar, select File > New > Dynamic Web Project.
	__2.  Enter AcmeWeb for the Project name.
	__3.  At the bottom of the window, in the EAR Membership section, click the button marked New Project....  (We will want to add this WAR file into an EAR file)
	The New EAR Application Project screen will appear.
	__4.  Set the Project name to AcmeApp and make sure the target server is WebSphere 8.0.
	__5.  Click Finish to create the EAR project
	__6.  Click Finish.  Both the EAR and the WAR will be created.  
	__7.  If prompted, don't switch to the web perspective by clicking No.
	__8.  Close the 'Technology Quickstarts' if it opens.
	__9.  Right click the newly created AcmeWeb project and select Properties.
	__10.  Now, select the Project Facets property.
	__11.  Note that the JAX-RS facet is not selected. This facet plays no role in developing JAX-RS services for WebSphere 8.0.
	__12.  Click Cancel to close the dialog.

	Part 2 -  Register the REST Application
	__1.  Open Windows file explorer.
	__2.  Go to C:\LabFiles\
	__3.  Copy web.xml
	__4.  In RAD, paste the file inside the WebContent > WEB-INF folder of AcmeWeb.
	__5.  Open web.xml and study how the REST application is configured. Switch to the Source view and specifically, note the servlet mapping:
	__6.  Close the file.

	Part 3 -  Create the Resource Class
	__1.  Right click AcmeWeb project and select New > Class.
	__2.  Enter com.acme.services as the package name and SimpleService as the class name.
	__3.  Click Finish to create the new class.
	__4.  Add a member variable that will help us do logging.
	__5.  Organize imports (Control+Shift+O) and select java.util.logging.Logger.  Make sure you select the correct class as there are several 'Logger' classes on the classpath.
	__6.  Add the method as follows.
	__7.  Save changes.

	Part 4 -  Configure the Resource
	__1.  Define the URI of the root resource, by adding the @Path annotation above the class. 
	__2.  Set the HTTP method and reply MIME type for the testGET() method sub-resource as follows.
	__3.  Organize imports. Select javax.ws.rs.Produces.
	__4.  Save changes.

	Part 5 -  Unit Test
	__1.  Start the WebSphere server.
	__2.  Right click the server and select Add and Remove.
	__3.  Add the AcmeApp project to the server.
	__4.  Click Finish.
	__5.  Right click the server and select Publish. Do this every time you are requested to Publish the server.
	__6.  Open a web browser and enter the URL: 
	__7.  You should see OK in the browser.
	__8.  The Console view in RAD will show the log output.

	Part 6 -  Use Path Extension for Sub-resource
	__1.  First, add this method to the SimpleService class.
	__2.  Annotate the method as follows.
	__3.  Save changes.

	Part 7 -  Unit Test
	__1.  Right click the WebSphere server and select Publish.
	__2.  In a web browser, enter the URL: 
	__3.  Make sure that the Console shows the log output.
	__4.  Open a new browser and re-test the testGET method for regression using the URL: 
	__5.  Close all open files.
	__6.  Close all browsers.

	Part 8 -  Review

	Lab 9 -  Add Support for XML Format
	Part 1 -  Create the Entity Classes
	__1.  In the AcmeWeb project, create a package called com.acme.services.entities
	__2.  Within that package, create a Java class called QuoteRequest
	__3.  In the QuoteRequest class, add these member variables. 
	__4.  Generate getters and setters for the variables. To do this select any variable, then from the menu select Source >  Generate Getters and Setters. Click Select All and click OK.
	__5.  Add the @XmlRootElement JAXB annotation to the class as shown in boldface below.
	__6.  Organize imports.
	__7.  Save changes.
	__8.  Open a file browser and go to C:\LabFiles\entities.
	__9.  Copy all the files within the folder and then paste them into the com.acme.services.entities package.
	__10.  Open each entity class file and review them. Specifically, look at the Order class. Working with list of child objects can be tricky in JAXB. Look at how we are dealing with line items:

	Part 2 -  Generate the XML Schema
	__1.  In the Enterprise Explorer view, right click on the com.acme.services.entities package and select New → Other
	__2.  Select JAXB → Schema from JAXB Classes and click the Next button.
	__3.  Expand the AcmeWeb → src folder and select the com.acme.services.entities package to make sure all Java files in the package are selected to be included.
	__4.  Click the Finish button to generate the schema.
	__5.  After a few seconds check that the root of the project has the schema.
	__6.  Open the generated schema file and study it if you wish.

	Part 3 -  Create the Quote Service Class
	__1.  In the com.acme.services package, create a class called QuoteService
	__2.  Set the root URI of the service as shown in boldface below.
	__3.  Add a member variable for logging.
	__4.  Add the getQuote() method as shown below. The business logic is very simple. We hard code the price and availability.
	__5.  Annotate the method as shown below.
	__6.  Organize imports. Select java.util.logging.Logger and javax.ws.rs.Produces.
	__7.  Save changes.

	Part 4 -  Better Content Handling
	__1.  Add the @Consumes annotation to getQuote as follows in bold.
	__2.  Similarly, change the @Produces annotation to support both MIME types for XML.
	__3.  Organize imports. Select javax.ws.rs.core.MediaType.
	__4.  Save changes.

	Part 5 -  Unit Testing
	__1.  Start the server if it is not running.
	__2.  Publish the server.
	__3.  Open a Windows Explorer file browser and verify the following directory exists.  If it doesn't you might need to find out where WebSphere was installed and alter the next several steps accordingly.
	__4.  Open a command window and change directories with the 'cd' command to C:\Software\RESTClient.
	__5.  Issue the following command assuming the WebSphere java directory was at the location previously mentioned:
	__6.  Run the command:
	__7.  In the URL text box, enter: 
	__8.  Select POST method.
	__9.  Click the Body tab.
	__10.  Click the  icon.
	__11.  From the drop-down select the text/xml content type.
	__12.  Click OK.
	__13.  Click the  icon to open the file.
	__14.  Select C:\LabFiles\quote_request.xml and open it.
	__15.  The tool will offer you an option to change the MIME type to application/xml. This is not necessary (either text/xml or application/xml will work fine), click NO.
	__16.  Study the request document briefly.
	__17.  We are now ready start testing. Click the  icon next to the URL.
	__18.  Make sure that the HTTP reply status code is 200.
	__19.  Click the Body tab for the response.
	__20.  Right click the response body text and select Indent > Indent XML.
	__21.  Study the response document.
	__22.  Back in RAD close all open files.
	__23.  Do not close the REST Client.

	Part 6 -  Review

	Lab 10 -  Securing RESTful Services
	Part 1 -  Enable Application Security
	__1.  Make sure the WebSphere server is running and start it if it is not.
	__2.  In the Servers view, right click the server and select Administration → Run Administrative Console.
	__3.  Login as wasadmin for user and password.
	__4.  In the navigation on the left side, expand the Security section and click the link for Global security.
	__5.  Click the button for Security Configuration Wizard.
	__6.  On the first page, leave the default options so only Enable application security is checked and click the Next button.
	__7.  Switch the option to Federated repositories and click the Next button.
	__8.  Fill in a value of 'wasadmin' without the quotes for the 'Primary administrative user name' and both password fields and then click the Next button.
	__9.  Click the Finish button to complete the security configuration.
	__10.  Click the Logout link in the upper right of the Admin Console.
	__11.  Close the Admin Console window.
	__12.  Switch back to the RAD Servers view.
	__13.  Stop the server.
	__14.  Once the server is stopped, double click on the server to open the server properties. 
	__15.  On the right, expand Security.
	__16.  Make sure the option for 'Security is enabled on this server' is checked as below.
	__17.  Close the server properties.
	__18.  Start the server from the Servers view. 

	Part 2 -  Secure the Quote Service
	__1.  In the AcmeWeb project expand com.acme.services package.
	__2.  Open QuoteService.java.
	__3.  Add the following annotation in bold to the class.
	__4.  Organize imports. 
	__5.  Save changes.
	__6.  In the Enterprise Explorer view, right click the AcmeApp EAR project and select Java EE → Generate Deployment Descriptor Stub.  Make sure it is the AcmeApp project as the AcmeWeb project will have similar options.
	__7.  In the Enterprise Explorer view, expand AcmeApp → META-INF and double click the application.xml file to open it.
	__8.  Select the Design tab.
	__9.  In the Overview section on the left, click the Add button.
	__10.  Select Security Role and click the OK button.
	__11.  With the new security role selected on the left, fill in a Role Name of 'Customer' without the quotes on the right.
	__12.  Save and close the file.

	Part 3 -  Import SimpleClient
	__1.  From the menu, select File → Import.
	__2.  Expand General, select Existing Projects into Workspace and click Next. 
	__3.  Click the second Browse, select C:\LabFiles\SimpleClient.zip and click Open.
	__4.  Click Select All.
	__5.  Click Finish.
	__6.  Right click the server and select Add and Remove.
	__7.  Select SimpleClientEAR and click Add.
	__8.  Click Finish.

	Part 4 -  Test
	__1.  Publish the server.
	__2.  Open a browser and enter the URL: 
	__3.  Enter some data and then click Get Quote.
	__4.  The browser will show an error.
	__5.  Close the browser.

	Part 5 -  Run Server with Resources on Server
	__1.  Make sure the server is started.
	__2.  Right click on the server and choose Add and Remove.
	__3.  In the Add and Remove dialog, click Remove All and then click Finish. Wait for publishing.
	__4.  Right click the server and select Clean. Then click OK to continue.
	__5.  Stop the server.
	__6.  Double click on the server to open the server configuration editor.
	__7.  Verify that under Publishing settings for WebSphere Application Server, the Run server with resources on Server radio button is selected.
	__8.  Close the file.
	__9.  Add the AcmeApp and SimpleClientEAR projects back to the server.
	__10.  Start the server.

	Part 6 -  Configure Security at the Server
	__1.  Make sure the WebSphere server is running and start it if it is not.
	__2.  In the Servers view, right click the server and select Administration → Run Administrative Console.
	__3.  If you receive security alerts they are for the security certificate of the server.  Click Yes or OK to accept the certificate and continue.
	__4.  Login to the WebSphere Admin Console with a user ID and password of wasadmin.
	__5.  In the navigation section on the left side of the Admin Console navigate to Users and Groups -> Manage Users.
	__6.  Type * in the Search for field and click the Search button to list the current users.
	__7.  Click the Create button and fill in the following user information:
	__8.  When the options are filled in as above click the Create button to create the user.
	__9.  Click the Close button and be sure the new user shows up in the list.
	__10.  Navigate to Applications → Application Types → WebSphere enterprise applications.
	__11.  Click the link for the AcmeApp application.
	__12.  Under the Detail Properties section, click the link for Security role to user/group mapping.
	__13.  Check the checkbox next to the Customer role and click the Map Users button.
	__14.  Press the Search button to list available users.
	__15.  Select the bob user and press the right arrow button to move the user over to the “Selected” list on the right.
	__16.  Press the OK button on the user search page to accept the user.
	__17.  Check that the user is listed on the row with the Customer role and press the OK button.
	__18.  Click the Save link in the messages at the top of the Admin Console.
	__19.  Click the Logout link in the upper right corner of the Admin Console.
	__20.  Close the Admin Console window.

	Part 7 -  Modify the Test Client
	__1.  Launch the RESTClient tool if it is not already running.  Use steps from previous labs to set the 'JAVA_HOME' variable in the command prompt to launch the tool.
	__2.  In the URL text box, enter: 
	__3.  Select POST method.
	__4.  Click the Body tab.
	__5.  Click the  icon.
	__6.  From the drop-down select the text/xml content type.
	__7.  Click OK.
	__8.  Click the  icon to open the file. Click Yes to erase the existing code.
	__9.  Select C:\LabFiles\quote_request.xml and open it. The tool will offer you an option to change the MIME type to application/xml. This is not necessary (either text/xml or application/xml will work fine), click NO.
	__10.  Click the  icon next to the URL.
	__11.  Make sure that the HTTP reply status code is 403.
	__12.  Click the Auth tab.
	__13.  Enter these values:
	__14.  Run the test again.
	__15.  Verify that status code 200 is returned.
	__16.  Close all open browsers.
	__17.  Close all open files.
	__18.  Close REST client.

	Part 8 -  Review

	Lab 11 -  Key Management (Optional)
	Part 1 -  Generate Server Keys
	__1.  Make a folder on your file system called C:\keys   We will place the keys in this directory.
	__2.  Open a command prompt window and enter the following:
	__3.  Now, enter the following command:
	__4.  The command should execute without any problems, as shown in the screenshot below.
	__5.  At the command prompt, enter the following:

	Part 2 -  Generate Client Keys
	__1.  In the same command prompt window, enter the following command: 
	__2.  At the command prompt window, enter the following:

	Part 3 -  Key Exchange
	__1.  At the command line, enter the following command:
	__2.  Enter the following command at the command line: 
	__3.  At the command line, enter the following command:
	__4.  At the command prompt, enter the following command:

	Part 4 -  Service Bindings
	__1.  From RAD, start the server.
	__2.  Open a web browser and enter the URL: 
	__3.  Logon to the admin console using wasadmin as ID and password. 
	__4.  In the left pane, expand Services > Policy Sets and click General provider policy set bindings.
	__5.  Check the box next to Provider sample and click Copy...
	__6.  Enter MyProviderBindings for the Name field and click OK.
	__7.  Save changes to the master configuration.
	__8.  Click MyProviderBindings.
	__9.  Click WS-Security.
	__10.  Click Keys and certificates.
	__11.  Scroll down to the bottom of the screen and locate the section named Trust anchor.
	__12.  Click New...
	__13.  Set the Name to be MyServerTrust 
	__14.  Select the External keystore radio button.
	__15.  Set the Full path to C:\keys\serverkeys.jks
	__16.  Leave the Type dropdown as JKS
	__17.  Set the Password and Confirm Password fields to serverkeys   
	__18.  Click OK.
	__19.  Save changes to the master configuration. 
	__20.  In the bread crumb trail at the top of the screen, click WS-Security.
	__21.  Here, click Authentication and protection.
	__22.  Click con_signx509token.  [Note that this is listed in the table as an Asymmetric signature consumer: this means that this is the token that will interpret the incoming signature]
	__23.  Click Callback handler.
	__24.  Set the Certificate store to (none).
	__25.  Set the Trusted anchor store to MyServerTrust.  This is the trust anchor that we defined earlier. 
	__26.  Click OK.
	__27.  Click OK for second time.
	__28.  The list of available tokens will be displayed again. If you are not there then click OK again.
	__29.  Save changes to the master configuration.
	__30.  In the list, click gen_signx509token.
	__31.  Click Callback handler.
	__32.  Under Keystore, click Custom keystore configuration.
	Here, we will specify the server's keystore and its server alias.  This means the certificate for the server will be used to sign outgoing (i.e. going back to the client) messages.  
	Note that there are already some settings configured here; they are pointing at the dummy keys.  We will change that now. 
	Under Keystore:
	__33.  Set the Full path to C:\keys\serverkeys.jks
	__34.  Set the Type drop down to JKS
	__35.  Set the Password and Confirm password to serverkeys
	__36.  Set the Name to be  cn=server,o=webage,c=us
	__37.  Set the Alias to be server
	__38.  Set the Password and Confirm password fields to be serverpass
	__39.  Click OK.
	__40.  Click OK for second time.
	__41.  Click OK again.
	__42.  Save changes to the master configuration.
	__43.  Click con_encx509token  [Note that this is an Asymmetric encyption consumer – which means it will be decrypting incoming messages]
	__44.  Click Callback handler.
	__45.  Under Keystore, click Custom keystore configuration.
	__46.  Set the Full path to be C:\keys\serverkeys.jks
	__47.  Set the Type dropdown to be JKS
	__48.  Set the Password and Confirm password fields to be serverkeys
	Under Key:
	__49.  Set the Name to be  cn=server,o=webage,c=us
	__50.  Set the Alias to be server
	__51.  Set the Password and Confirm password to serverpass
	__52.  Click OK.
	__53.  Click OK.
	__54.  Click OK again.
	__55.  Save changes to the master configuration.
	__56.  Click gen_encx509token. 
	__57.  Click Callback handler.
	__58.  Click Custom keystore configuration. 
	__59.  Set Full path to C:\keys\serverkeys.jks
	__60.  Set the Type to JKS
	__61.  Set the Password and Confirm password to serverkeys
	__62.  Set the Name to be  cn=client,o=webage,c=us
	__63.  Set the Alias to be client
	__64.  Click OK.
	__65.  Click OK for second time.
	__66.  Click OK again.
	__67.  Save changes to the master configuration.  

	Part 5 -  The Client Binding
	__1.  In the left pane, expand Services > Policy Sets and select General client policy set bindings.
	__2.  Check Client sample and click Copy...
	__3.  Set the Name to be MyClientBindings and click OK.
	__4.  Save changes to the master configuration.  
	__5.  Click the link for the newly created MyClientBindings.
	__6.  We will first specify which keystore and which trust. 
	__7.  Click WS-Security.
	__8.  Click Keys and certificates.
	Here, we need to specify which keystore and which certificates to use for trust. 
	__9.  Under Certificate store, click DigSigCertStore.
	__10.  Scroll down and locate the section Intermediate X.509 certificates.
	__11.  Check the box next to the existing certificate and click Delete. 
	__12.  Now, in the Full Path area, enter C:\keys\server.cert  
	__13.  Click OK.
	__14.  Save changes to the master configuration.
	__15.  Now, click DigSigTrustAnchor under Trust anchor.
	As with the provider bindings, we specify a location that contains certificates that we trust.  Since we trust the server, and we have the server's public certificate in our client keystore we will point at it (clientkeys.jks)
	__16.  Set the Full path to C:\keys\clientkeys.jks
	__17.  Set the Type drop down to JKS
	__18.  Set the Password and Confirm password to clientkeys
	__19.  Click OK.
	__20.  Save changes to the master configuration.
	We have now configured the trust.  The next step is to configure the signing and encryption. 
	__21.  At the breadcrumb trail at the top of the page, click WS-Security.
	__22.  Click Authentication and protection.
	__23.  Click gen_signx509token. 
	__24.  Click Callback handler.
	__25.  Click Custom keystore configuration.
	Under Keystore:
	__26.  Set Full path to c:\keys\clientkeys.jks
	__27.  Set the Type to JKS
	__28.  Set the Password and Confirm password to clientkeys
	__29.  Set the Name to be cn=client,o=webage,c=us
	__30.  Set the Alias to be client
	__31.  Set the Password and Confirm password to be clientpass
	__32.  Click OK.
	__33.  Click OK.
	__34.  Click OK again.
	__35.  Save changes to the master configuration.
	__36.  Click con_signx509token.
	__37.  Click Callback handler.
	__38.  Click Custom keystore configuration. (make sure Name is set to Default)
	Under Keystore:
	__39.  Set Full path to C:\keys\clientkeys.jks
	__40.  Set the Type drop down to JKS
	__41.  Set the Password and Confirm password to clientkeys
	__42.  Set the Name to cn=server,o=webage,c=us
	__43.  Set the Alias to server
	__44.  Click OK.
	__45.  Click OK.
	__46.  Click OK again.
	__47.  Save changes to the master configuration.
	__48.  Click con_encx509token.
	__49.  Click Callback handler.
	__50.  Click Custom keystore configuration.
	Under Keystore:
	__51.  Set the Full path to C:\keys\clientkeys.jks
	__52.  Set the Type drop down to JKS
	__53.  Set the Password and Confirm password fields to clientkeys
	__54.  Set the Name to cn=client,o=webage,c=us
	__55.  Set the Alias to client
	__56.  Set the Password and Confirm password to clientpass
	__57.  Click OK.
	__58.  Click OK.
	__59.  Click OK again.
	__60.  Save changes to the master configuration.
	__61.  Click gen_encx509token.
	__62.  Click Callback handler.
	__63.  Click Custom keystore configuration.
	__64.  Set the Full path to C:\keys\clientkeys.jks
	__65.  Set the Type to JKS
	__66.  Set the Password and Confirm password to clientkeys
	__67.  Set the Name to be cn=server,o=webage,c=us
	__68.  Set the Alias to be server
	__69.  Click OK.
	__70.  Save changes to the master configuration. You don't need to click OK two times this time.

	Part 6 -  Use the Bindings
	We now need to associate the provider (our web service) with the newly created provider binding, and then associate the client with the newly created client binding. 
	__1.  In the left pane, expand Services.
	__2.  Click Service providers.
	__3.  Click BillingManagerService.
	__4.  Check the box for BillingManagerService and then click the Assign Binding dropdown.  There, select MyProviderBindings.
	__5.  Save changes to the master configuration.
	__6.  In the left pane, expand Services and click Service clients.
	__7.  Click BillingManagerService.
	__8.  Check the box for BillingManagerService and then click the Assign Binding dropdown.  There, select MyClientBindings.
	__9.  Save changes to the master configuration.

	Part 7 -  Test
	__1.  Logout the admin console.
	__2.  Close all open web browsers.
	__3.  Re-start the server. You may get a message that the security is enabled, just click OK.
	__4.  Make sure the Server's status is Synchronized, if not restart the server. 
	__5.  Open a browser and browse to the usual application:  
	__6.  Enter data and click Add.
	__7.  If you examine the request and response in the TCP/IP monitor, you should still see the encrypted and signed messages; the difference of course, is that now, our generated keys are being used. 
	__8.  Stop the Server.
	__9.  Close all open editors, browsers and windows.

	Part 8 -  Review




