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Lab 1 - Responsiveness, Scalability, and Reliability
This exercise will be a group discussion regarding the tradeoffs and relative merits of 
tracking responsiveness, scalability, and reliability of a system or business process.

Part 1 - Form a Team
__1. Form a group of two to four people.

__2. Select a scribe and a presenter from the group.  

Part 2 - Discuss the similarities and differences between 
responsiveness, scalability, and reliability
__1. When you are given a requirement to provide a certain degree of performance for a 
system, what sort of metrics do you measure?

__2. What relationship, if any, do you see between responsiveness and scalability?  Does 
one trade off with the other?

__3. Is there ever a confusion in terms coming from the business team when they pass 
down a performance requirement?  Do they use "performance" when they really mean 
either scalability or reliability?  

__4. Assuming the previous question is true, what steps could be taken to clarify the 
process of gathering requirements to avoid this sort of confusion?
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Part 3 - Discuss the correlation between these non-functional 
requirements
__1. Does an improvement in responsiveness necessitate an improvement in scalability? 
Said another way, is it possible to make something perform well but not scale well?  Is 
the opposite possible (i.e. something could scale, but not perform)?

__2. Does the reliability of a system improve or decline when its responsiveness 
improves?

__3. Does the reliability of a system improve or decline when it is scaled up?  What about 
when it is scaled out?

Part 4 - Discuss the Results
__1. Have the speaker review your analysis and be prepared to share with the group.

__2. Listen to the other groups describe their findings and make any notes that you find 
particularly interesting or insightful.
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Lab 2 - Parser Performance
Any application dealing with XML must eventually face the issue of parsing.   To parse f 
XML [from code] means to take the raw XML data (e.g. characters, whitespaces, etc), 
read it and turn it into something that the code can make use of. 

A developer needing to read (or write) XML could create their own parser; this means, 
code would have to be written to take a stream containing XML, figure out what to do 
with the raw characters and make something meaningful out of them.  This can be very 
time-consuming to develop. 

Fortunately, a few XML parsers already exist and are available to us – right as a part of 
the core Java libraries!  This means that in order to work with XML, all a developer has 
to do is choose a parser and use its provided API to handle the low-level raw XML 
operations. 

Parsers come in three main categories, based on how they are engineered.  One cateogry 
is DOM; another is SAX, and the third is STaX.  They all perform the same basic 
operations (i.e. parse an XML file allowing a developer to perform operations like getting 
an element name and data), but do so in very different manners.

The choice of a parser really depends on a variety of factors; e.g. if code is going to be 
navigating back and forwards through an XML tree, then DOM would be a better choice 
than SAX.  Alternatively, if memory foot print is a concern, than STaX might be a viable 
option.

In any application that is XML intensive, the choice of XML parser can have a significant 
impact on performance.  In this lab exercise, we will examine that impact.

Using the SAX, DOM and STaX parser, we will perform a simple XML read test, and see 
which one returns the best performance.

Note

This lab is purely focused on the performance details of each of the parsers; it is by no 
means meant to be a lesson on how to code using STaX, DOM or SAX.  In each of the 
code samples below, the code does nothing more than a simple “run” through the XML 
source files, neglecting any details such as obtaining data, or even creating new XML. 
This is all we are concerned with for now. 

For more details on how to actually use these parsers to do actual XML work, consult 
your instructor or other reference material. 
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Part 1 - DOM Parser
The DOM parser works by reading the entire XML file into memory first, and then 
constructing a tree.  The tree is then treated as a Java object; code can make use of the 
DOM tree's API to navigate through the tree, getting (and even creating) data as required. 

We will now write some simple Java code that uses the DOM parser to simply read in the 
XML file.  We will not do anything with the parsed XML; we will simply see how long it 
takes to read in an parse the entire XML file.

We have provided a sample XML file that the application will read.  It is located in 
C:\LabFiles.  You may open it with a text editor if you wish; the contents are just 
garbage.  It is approximately 10 megabytes in size and so will be a reasonably lengthy 
parsing job.

First lets start RAD 7.5.  

__1. From the Start menu, select All Programs > IBM Software Delivery Platform > 
IBM Rational Application Developer 7.5 > IBM Rational Application Developer.

__2. The Workspace Launcher window will appear.  Accept the default that should be 
C:\workspace and click OK. If it is not, then change it.

RAD will launch. 

__3. Click Ignore in the Warning that will open related with the help content.

__4. Close the Welcome view by clicking the X button in its tab if it is displayed.

__5. Switch to the Java Perspective by selecting from the menu, Window > Open 
Perspective > Java.

We will need to create a new Java project. 

__6. From the menu, select File > New > Project...

__7. The New Project window will appear.  Select Java Project and click Next.

__8. For the Project name, enter XML Performance Tests and click Finish.

The project will be created, and should be shown in the Package Explorer view.
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We can now create our DOM parser class. 

__9. In the Package Explorer, right-click on XML Performance Tests and select New > 
Class.

The New Java Class wizard will appear. 

__10. Set the Package to be com.tests.dom

__11. Set the Name to be DOMTest

__12. Check the box for public static void main(String[] args)

__13. Click Finish.

An editor will open on the newly created class.
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We can now start writing our code.

__14. In the main method, add the following code:

String fileName = "C:\\LabFiles\\reallybig.xml";

This will set up a reference to XML file that we will read. 

__15. Add the following code to the main method:

DOMParser parser = new DOMParser();

This creates an instance of the parser which we will need. 

__16. An error will appear.  Hit Ctrl-Shift-O to Organize Imports and the error will go 
away.  Note that this imports org.apache.xercse.parsers.DOMParser, which is the 
DOM parser that ships with the core Java Development Kit (JDK).

__17. Continue adding the following code:

long before = System.currentTimeMillis();
parser.parse(fileName);
long after = System.currentTimeMillis();
System.out.println("Using DOM, the time taken was " + (after - before)

+ " milliseconds");
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Here we actually perform the parse.  We take a timestamp before we perform the actual 
parse, and then again right after the parse.  Finally, we print the difference in timestamp 
which will show us the elapsed time. 

__18. We have an error to fix.  Select all the source code within the main method.  Right-
click on the selected source and select Surround With > Try/catch Block.

RAD will generate the try/catch code as needed.  The errors should go away.  

Your source should now look like the following:

There should be no errors. 

__19. Save the code (Ctrl-S).

__20. Run the code by right-clicking anywhere on the editor and selecting Run As > 
Java Application.
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The code will execute, and the Console view at the bottom will show you the result. 

Specifically, parsing the XML file using the DOM parser has taken this much time. 

__21. Run the test 3 more times and record the times for each run below:

Run Time (ms)

1

2

3

__22. Calculate the average time.   (i.e. Add all 3 times and divide by 3) Record it here:

AVERAGE DOM PARSING TIME: _______ ms

We have successfully completed our DOM performance test!   We have an idea of how 
long it takes DOM to parse the large XML file.  The next step is to draw a comparison 
with another parser – the SAX parser.

Part 2 - SAX Parser
As before, we will create a simple test class that will read the same large XML file, 
except that this time we will make use of the SAX parser.  

__1. In the Package Explorer, right-click on XML Performance Tests and select New > 
Class.
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The New Java Class wizard will appear. 

__2. Set the Package to be com.tests.sax

__3. Set the Name to be SAXTest

__4. In the Superclass field, enter DefaultHandler

__5. Check the box for public static void main(String[] args)

__6. Click Finish.

An editor will open on the newly created class.
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__7. Errors will immediately be visible.  Fix them by performing an Organize Imports 
(Ctrl-Shift-O).  

The errors will disappear. 

__8. Add the following code to the main method.

String fileName = "C:\\LabFiles\\reallybig.xml";

As before, this creates a reference to the XML file to be parsed.

__9. Add the following code to the main method:

SAXParserFactory factory = SAXParserFactory.newInstance();

This obtains an instance of the parsing factory. 

__10. Add the following code: 

SAXParser parser = factory.newSAXParser();
SAXTest sax = new SAXTest();
long before = System.currentTimeMillis();
parser.parse(new File(fileName), sax);
long after = System.currentTimeMillis();
System.out.println("Using SAX, the time taken was " + (after - before) 
+ " milliseconds");

This creates an instance of a SAX handler (which is conveniently what the SAXTest 
class is) and passes it to the parse(..) method.

As before, we take a timestamp before and after the parse call and then print out the 
difference. 
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__11. Perform an Organize Imports (Ctrl-Shift-O). The Organize Imports window will 
appear.  

__12. Select javax.xml.parsers.SAXParser when prompted and click Next.

__13. Select java.io.File when prompted and click Finish.

__14. Select all the code within the main method.  Right-click on it and select Surround 
With > Try/catch Block.

The necessary try/catch code will be generated.  

Your code should now look like the following.  

There should be no errors.

__15. Save the code (Ctrl-S).
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__16. We can now run the code.  As you did before with the other class, run this class 
three times and take the average. 

Run Time (ms)

1

2

3

__17. Calculate the average time.   (i.e. Add all 3 times and divide by 3) Record it here:

AVERAGE SAX PARSING TIME: _______ ms

You should see there is a significant difference between SAX and DOM parse times. 
SAX should be significantly (25% - 40%) faster than DOM.  

On top of that, actually working with DOM involves reading the tree into memory first, 
and then navigating through the tree using DOM API.  With SAX, navigation through the 
tree is done at parse time – which means only one pass through the XML is required.  

This means that if we wanted to do any actual “real” work with the parsed XML (instead 
of just reading it as our examples do), the difference between SAX and DOM 
performance would become much greater, with DOM lagging further behind. 

Part 3 - STaX Parser
A third type of parser is the STaX parser.  STaX is closer to SAX than DOM in that it 
represents an event-driven linear pass through the tree.  However, if operates on a “pull” 
model, as opposed to the “push” model present in SAX.

As we have done with the two other parsers, we will write code that uses the STaX parser 
to read the sample XML file. 

__1. In the Package Explorer, right-click on XML Performance Tests and select New > 
Class.
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The New Java Class wizard will appear. 

__2. Set the Package to be com.tests.stax

__3. Set the Name to be STaXTest

__4. Check the box for public static void main(String[] args)

__5. Click Finish.

An editor will open on the class.

__6. Add the following code to the main method:

FileInputStream fis = new 
FileInputStream("c:\\LabFiles\\reallybig.xml");

XMLEventReader reader = XMLInputFactory.newInstance()
.createXMLEventReader(fis);

As always, we declare a reference to the file.  
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Then we create an instance of an XMLEventReader – which is the class that will 
perform the actual STaX parsing. 

__7. Organize Imports. (Ctrl-Shift-O)

Some errors will remain after doing this; we will fix those later.

__8. Add the following code to the main method:

long before = System.currentTimeMillis();
while (reader.hasNext()) {

reader.nextEvent();
}

long after = System.currentTimeMillis();
System.out.println("Using STaX, the time taken was " 

+ (after – before) + " milliseconds");

__9. As before, select all the code in the main method, right-click on it, and select 
Surround With > Try/catch Block.

The code should now look like the following:
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There should be no errors.

__10. Save the file. 

__11. Run the code 3 times and fill out the following table:

Run Time (ms)

1

2

3
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__12. Calculate the average time.   (i.e. Add all 3 times and divide by 3) Record it here:

AVERAGE STaX PARSING TIME: _______ ms

You should find that STaX performance falls somewhere in between SAX and DOM.  

Congratulations!  You have successfully used 3 different parsers to examine their raw 
performance. 

__13. Close all open files.

Part 4 - Review
In this lab exercise, you wrote simple code that tested the DOM, SAX and STaX parsers 
to see how each one handled a raw XML read, performance wise. 

You saw that SAX was the fastest, followed by STaX, and trailed by DOM.  

Naturally, when it comes to dealing with XML, speed is not necessarily the only factor 
involved in choosing a parser.  Different parsers offer different features, and choices 
should be made accordingly.  

If, however, raw performance is the most important principle, then SAX may be your best 
choice. 
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	__17.  Continue adding the following code:
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	__1.  In the Package Explorer, right-click on XML Performance Tests and select New > Class.
	__2.  Set the Package to be com.tests.sax
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	__14.  Select all the code within the main method.  Right-click on it and select Surround With > Try/catch Block.
	__15.  Save the code (Ctrl-S).
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	__17.  Calculate the average time.   (i.e. Add all 3 times and divide by 3) Record it here:

	Part 3 -  STaX Parser
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	__3.  At the bottom of the window, in the EAR Membership section, change the EAR Project Name to WebServiceProjectEAR
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	__7.  Click on the Servers view at the bottom of the screen.  A server called WebSphere Application Server v7.0 at localhost should be displayed inside.
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	__2.  Set the Package to be com.beans
	__3.  Set the Name to Person.
	__4.  Click Finish.
	__5.  Add the following fields to the class:
	__6.  Save the class.
	__7.  In the Outline view (to the right), expand and select all three fields.
	__8.  Right click on these selected fields and select Source | Generate Getters and Setters...
	__9.  Click the OK button.  
	__10.  Save the file.  There should be no errors.
	__11.  Close the file.  
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	__1.  Right click on WebServiceProjectWAR and select New->Class.
	__2.  Set the Package to be com.simple
	__3.  Set the Name to PersonManager
	__4.  Click Finish.
	__5.  Add the following method to the class:
	__6.  Now, add the following method:
	__7.  Organize imports.  (Ctrl + Shift + O). When prompted, select com.beans.Person and click Finish.
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	__17.  Close the WSE.  

	Part 6 -  Change the JAXB Mappings
	__1.   Open Person.java 
	__2.  Add the following annotation in bold to the class.
	__3.  That means that JAXB will directly access the instance variables (without going through the getter and setter methods). 
	__4.  Now, annotate the fields as follows:
	__5.  A few errors will appear.  Organize imports (Ctrl-Shift-O). When prompted, select javax.xml.bind.annotation.XmlElement and click Finish.
	__6.  Save the class. There should be no errors.  
	__7.  Close Person.java

	Part 7 -  Fix the Return Element
	__1.  Open PersonManager.java
	__2.  Locate the createPerson method, and add the following bolded annotation :
	__3.  Here, we specify that the element returned should be called <prsn>.
	__4.  Organize imports.
	__5.  Save changes.  There should be no errors.
	__6.  Close the file.

	Part 8 -  Test JAXB Binding Changes
	__1.  RAD should have “auto-published” the changes we made to the classes.  Check to make sure that the server Status is Synchronized.  If it is not, manually publish the server. 
	__2.  Open the WSE on the service, as you did before.
	__3.  Run the createPerson operation again.
	__4.  Click both Add links. 
	__5.  Enter a first name and last name and click Go.
	__6.  Examine the response:
	__7.  Examine the source for the response.  (Click the Source link and maximize the pane)
	__8.  Feel free to try out the getPersonName operation too.
	__9.  Stop the server.  
	__10.  Close all open editor windows.

	Part 9 -  Review

	Lab 4 -  Message Transmission Optimization Mechanism
	Part 1 -  Create the SimpleImageProcessor Service
	__1.  Start RAD if it is not already running using the same workspace that you used before. 
	__2.  We need to create a Dynamic Web Project to hold our service.  From the menu, select File > New > Project...
	__3.  The New Project window will appear.  Select Dynamic Web Project and click Next. 
	__4.  Set the Project Name to MTOMTest
	__5.  Click Finish.
	__6.  When prompted to Open Associated Perspective, click Yes.
	__7.  Close the Technology Quickstarts view that has opened by clicking the X in its tab.  It is not needed. 
	__8.  In the Package Explorer, right-click on MTOMTest and select New > Class.
	__9.  Set the Package to com.simple
	__10.  Set the Name to SimpleImageProcessor
	__11.  Click Finish.
	__12.  Annotate the class with the @WebService annotation:
	__13.  An error will appear.  Perform an organize imports (Ctrl-Shift-O).  An import will be added to the class and the error will disappear. 
	__14.  Add the following method to the class:
	__15.  Organize imports (Ctrl-Shift-O).  There should be no errors in the code. 
	__16.  Save the code (Ctrl-S).  It should look like the following:
	__17.  Open the Servers view by clicking on the Servers tab at the bottom of RAD.
	__18.  Right-click on WebSphere Application Server in the list of servers and select Add and Remove Projects...
	__19.  In the left pane, select MTOMTestEAR and click Add.  It should appear in the Configured projects column.
	__20.  Click Finish.
	__21.  Start the server by right-clicking on it (in the Servers view) and selecting Start.

	Part 2 -  Create A SimpleImageProcessor Client
	__1.  From the menu, select File > New > Project...
	__2.  The New Project wizard will appear.  Select Java Project and click Next.
	__3.  The New Java Project window will appear.  Set the Project name to SimpleImageProcessorClient and click Finish.
	__4.  When prompted to Open Associated Perspective, click No.
	__5.  In the Package Explorer, expand MTOMTest > Services.
	__6.  Right-click on the service listed here and select Generate > Client.
	__7.  On the right, under Configuration, click Client project : MTOMTest
	__8.  Change the Client project drop down to SimpleImageProcessorClient and click OK.
	__9.  Back at the Web Service Client window, the configuration should be as follows:
	__10.  Drag the slider on the left down to Assemble Client.
	__11.  Click Finish.
	__12.  In the Package Explorer, expand SimpleImageProcessorClient > src > com.simple.  The generated proxy classes have been created here. 
	__13.  Expand SimpleImageProcessor.java and expand it again.  
	__14.  In the Package Explorer, right-click on SimpleImageProcessorClient and select New > Class.
	__15.  Set the Package to be com.client
	__16.  Set the Name to be SimpleImageProcessorClient
	__17.  Check the box public static void main(String[] args)
	__18.  Click Finish.
	__19.  Add the following code to the main method:
	__20.  Some errors will appear; perform an Organize Imports (Ctrl-Shift-O) and the errors will disappear.  The service is almost ready to be invoked. 
	Before we can invoke the service, we need to get an array of bytes from the image to be sent.  Recall that the service is expecting an array of bytes as a parameter.   So, we need to parse the image as an array of bytes. 
	__21.  Add the following code to the main method:
	We have provided a sample image for you (C:\LabFiles\image.jpg).  The  code here simply reads it as an array of bytes into the buffer imageData.
	__22.  Finally, we can invoke the service.  Add the following code to the main method.  
	We invoke the service and print out what the service sends back (which should be a Success message).
	__23.  Now to fix the errors.  Perform an  Organize Imports. (Ctrl-Shift-O)
	__24.  The Organize Imports window will appear.  Select java.io.File and click Finish.
	__25.  Select all the source within main method.  
	__26.  Right-click on the selected source and select Surround With > Try/catch Block.
	__27.  Save the code (Ctrl-S).
	__28.  Right-click anywhere on the source code and select Run As > Java Application. 
	__29.  Make sure you are watching the SimpleImageProcessorClient execution since RAD may switch to the WAS view, do to this click the Display Selected Console button in the menu of the Console and select <terminated> SimpleImageProcessorClient. 
	__30.  Click the Display Selected Console button next to the Console button and select the WebSphere Application Server entry.

	Part 3 -  Examine the Encoded Message By Enabling the Monitor 
	__1.  Open the Servers view.
	__2.  Right-click on the server and select Monitoring > Properties.
	__3.  Click the Add... button.
	__4.   Select the entry for localhost 9080
	__5.  Click OK.
	__6.  Back at the Monitoring screen, the newly added monitor will be shown. 
	__7.  Select the entry and click  Start.  Its status should change to Started.
	__8.  Click OK. 
	__9.  In the Package Explorer, expand SimpleImageProcessorClient > Services > Clients.  
	__10.  Right-click on the service and select Show > WSDL Interface.
	__11.  Click the Source tab at the bottom of the editor.  We will look at the raw XML source. 
	__12.  Scroll to the bottom of the file, and locate the <soap:address ..> element. 
	__13.  Change the port number to 9081
	__14.  Save and close the WSDL editor.
	__15.  Run the client again.  
	You should see the same SUCCESS message as before.  This time, however, the TCP/IP Monitor view should have opened.  
	__16.  Note that typically the TCP/IP Monitor view opens in the same [lower] pane area as the Console and Server views.  Occasionally, however, it will open in the same pane area as the Outline view, on the right.   If it opens on the right, drag it down across the lower pane. 
	__17.  Double-click on the TCP/IP Monitor tab to “full-screen” it. 
	__18.  In the request and response windows, change the drop-down to XML.
	__19.  Minimize the TCP/IP Monitor  by double-clicking on its tab.

	Part 4 -  Enable MTOM On the Service
	__1.  From the menu, select Window > Open perspective > Other, then select Web and click OK.
	__2.  Right-click on MTOMTest in the Enterprise Explorer, and select New > Package.
	__3.  Set the Name to be com.simple.mtom and click Finish.
	__4.  In the Enterprise Explorer, right-click on SimpleImageProcessor.java and select Copy.
	__5.  In the Enterprise Explorer, right-click on com.simple.mtom and select Paste.
	__6.  Expand com.simple.mtom
	__7.  Right-click on the copied (under com.simple.mtom) SimpleImageProcessor.java and select Refactor > Rename...
	__8.  Set the New name to be MTOMSimpleImageProcessor and click Finish.
	__9.  In the Enterprise Explorer, double-click on MTOMSimpleProcessor.java  
	__10.  In the source, add the following annotation in bold right before the class declaration (after the @WebService annotation).
	__11.  Perform an Organize Imports. (Ctrl-Shift-O)
	__12.  The Organize Imports window will appear. Select javax.xml.ws.soap.SOAPBinding and click Finish.
	__13.  The errors will disappear.  Save the code.
	We have enabled MTOM on our service! 
	__14.  We should publish the new service to the server.  Open the Servers view.  
	__15.  Right-click on the server and select Publish. 
	Wait until its status is Synchronized.
	Our MTOM enabled service is ready to be invoked.  However, we need to create an MTOM-enabled client. 

	Part 5 -  Create an MTOM-Enabled Client
	__1.  In the Enterprise Explorer, expand MTOMTest > Services.
	__2.  Right-click on the mtom.simple.com service and select Generate > Client.
	The Web Service Client window will appear. 
	__3.  Drag the slider on the left down to Assemble client.
	__4.  On the right, under Configuration, click Client project.
	__5.  The Specify Client Project Settings window will appear.  Change the Client project drop-down to SimpleImageProcessorClient and click OK.
	__6.  Click Finish.
	__7.  In the Enterprise Explorer, right click SimpleImageProcessorClient and select Refresh.
	__8.  In the Enterprise Explorer, expand SimpleImageProcessorClient > src and notice that the com.simple.mtom package has been created under src.
	__9.  In the Enterprise Explorer, right-click on SimpleImageProcessorClient.java and select Copy.
	__10.  Right-click on the package com.client and select Paste.
	__11.  Change the name to MTOMSimpleImageProcessorClient and click OK.
	__12.  Double-click on the newly copied MTOMSimpleImageProcessorClient to open it in the editor.  
	__13.  Replace the first two lines of code in the main method to use the MTOM enabled client proxy.  
	__14.  Perform an Organize Imports (Ctrl-Shift-O) to clear some errors.
	__15.  Add the following 3 lines of code in bold immediately before declaring the byte array:
	__16.  There will be some errors.  Perform an Organize Imports. 
	__17.  Select javax.xml.ws.BindingProvider and click Next.
	__18.  Select javax.xml.ws.soap.SOAPBinding and click Finish.
	__19.  Save the code.  There should be no errors.  We can now test it!
	__20.  Make sure your method look like below:
	__21.  Run the code as Java Application.  You should see … the same SUCCESS message as last time. You may need to switch to the Terminate window.
	__22.  In the Enterprise Explorer view, expand SimpleImageProcessorClient > Services > Clients.
	__23.  Right-click on the MTOM-enabled service and select Show > WSDL Interface.
	__24.  As before, scroll to the bottom and change the port definition to 9081
	__25.  Save and close the WSDL file.
	__26.  Run the MTOM-enabled client again.  
	__27.  Open the TCP/IP Monitor view, and double click on its tab to full-screen it.
	__28.  Simple. The difference is that MIME is more compact.  Examine the size of the message that was sent. 
	__29.  Restore the size of the TCP/IP Monitor view.
	__30.  Close all open files.

	Part 6 -  Review

	Lab 5 -  Selecting Performance Strategies
	Part 1 -  Form a Team
	__1.  Form a group of two to four people.
	__2.  Select a scribe and a presenter from the group.  

	Part 2 -  Web Service Scenarios
	__1.  WS #1 – A customer account lookup service allows both internal customer service reps and the sales team to retrieve customer account data formatted according to a custom XML Schema.  This same service is also used by an external-facing web portal so that customers can view their account data when they log into the portal. 
	__2.  WS #2 – A tax calculation service is used on occasion throughout the month and then used extensively during month-end closing when the accounting department is closing up its books for the month.  During this peak usage, the service reliability drops to an unacceptable level, often going off-line and having to be restarted.  What measures would you recommend for dealing with this issue and ensuring that the service is consistently available during this peak usage period?
	__3.  WS #3 – An order processing service accepts XML-formatted purchase order documents from business partners.  Some portions of the XML document are encrypted for security reasons.  This service is currently performing poorly in two ways:

	Part 3 -  Discuss the Results
	__1.  Have the speaker review your analysis and completed diagram and be prepared to share with the group.
	__2.  Listen to the other groups describe their findings and make any notes that you find particularly interesting or insightful.


	Lab 6 -  Performance Testing
	Part 1 -  Configure JMeter Environment
	__1.  Make sure the server is started in RAD 7.5.
	__2.  Using a file explorer, copy these files from C:\LabFiles to C:\Software\jakarta-jmeter-2.3.4\lib\ext
	__3.  From Windows Control Panel, open System.
	__4.  Select the Advanced tab and click the Environment Variables button.
	__5.  Select the Path variable under System variables and click Edit.
	__6.  Add the following at the end of the line:
	__7.  Click OK.
	__8.  Click OK again to close the Environment Variables window.
	__9.  Click OK again to close the System Properties window.
	__10.  Open a command prompt window.
	__11.  Enter the following commands: 
	__12.  You should get a response similar as shown below. 

	Part 2 -  Verify Test Script
	__1.  From the command prompt change to the folder:
	__2.  Launch jmeter by entering the command:
	__3.  From the menu, select File > Open.
	__4.  Select C:\LabFiles\JMeterTestPlan.jmx and click Open.
	__5.  Select WebService (SOAP) Request and review how it has been configured.
	__6.  Using Notepad, open C:\LabFiles\ProcessImageSOAP.xml and review the file.
	__7.  Close the xml file.
	__8.  Select Thread Group and verify that only one thread or user is configured.
	__9.  Hit Control+R to start the test. The test will run too fast that you may don't notice.
	__10.  Select View Results Tree and verify that the request was successful.
	__11.  Hit Control+E to clear results.

	Part 3 -  Run Performance Test
	__1.  Select Thread Group. 
	__2.  Set Number of Threads (users) to 10. 
	__3.  Set Loop count to 100.
	__4.  Right click View Results Tree and select Disable. You are doing this since that listener has overhead.
	__5.  Hit Control+R to start test. Wait for the test to finish (green rectangle in top right will disappear).
	__6.  Click Aggregate Report and analyze the result.
	__7.  Close JMeter and do NOT save changes.
	__8.  Leave RAD running.

	Part 4 -  Review

	Lab 7 -  REST vs. SOAP
	Part 1 -  Create the SOAP Web Service
	__1.  Start RAD if it is not already running using the same workspace that you used before. 
	__2.  Close all open files.
	__3.  We need to create a Dynamic Web Project to hold our service.  From the menu, select File > New > Project...
	__4.  The New Project window will appear.  Select Dynamic Web Project and click Next.
	__5.  Set the Project Name to SimpleSOAPAdder
	__6.  Change the EAR Project Name to  SimpleSOAPAdderEAR
	__7.  Click Finish.
	__8.  If prompted to Open Associated Perspective, click Yes.
	__9.  Close the Technology Quickstarts view that has opened by clicking the X in its tab. It is not needed. 
	__10.  In the Enterprise Explorer, right-click on SimpleSOAPAdder and select New > Class.
	__11.  Set the Package to com.simple.SOAP
	__12.  Set the Name to SimpleAdder
	__13.  Click Finish.
	__14.  Annotate the class with the @WebService annotation:
	__15.  An error will appear.  Perform an organize imports (Ctrl-Shift-O).  An import will be added to the class and the error will disappear. 
	__16.  Add the following method to the class:
	__17.  Organize imports.
	__18.  Save the code (Ctrl-S).  There should be no errors. 
	__19.  Right-click on WebSphere Application Server in the list of servers and select Add and Remove Projects...
	__20.  In the left pane, select SimpleSOAPAdderEAR and click Add.  It should appear in the Configured projects column.
	__21.  Click Finish.
	__22.  If the server is not started then start it.

	Part 2 -  Test the Service
	__1.  In the Enterprise Explorer, expand SimpleSOAPAdder > Services.
	__2.  Right-click on the service listed under Services and select Test with Web Services Explorer.
	__3.  In the right pane, click the link for add under Operations.
	__4.  A form will be displayed. Enter a number for the arg0 and arg1 fields.
	__5.  Click Go.
	__6.  Examine the Status pane.   Maximize it by double clicking on its tab.
	__7.  Click the Source link in it.
	__8.  Restore the Status pane size.

	Part 3 -  The REST Service
	__1.  From the menu, select File > Import...
	__2.  Expand General and select Existing Projects into Workspace.
	__3.  Click Next.
	__4.  Select the Select archive file radio button.
	__5.  Click the Browse... button.
	__6.  Select the C:\LabFiles\SimpleRESTAdder.zip and click Open.
	__7.  Make sure the project is selected.
	__8.  Click Finish.
	__9.  From the menu, select Window > Open Perspective > Other...
	__10.  Select Java and click OK.
	__11.  Expand SimpleRESTAdder > src > com.simple.REST.
	__12.  Double click on SimpleAdderRest.java.  It will open in the editor.
	__13.  Take a moment to look through the code.  Note the following:
	__14.  Right-click anywhere on the source and select Run As > Java Application.
	__15.  Open a browser.
	__16.  Browse to:
	__17.  Add the text   ?x=3&y=4    to the browser address bar. 
	__18.  Hit enter and the browser will submit the request.
	__19.  Now in the browser enter the following URL:
	__20.  Bookmark this URL.

	Part 4 -  Create JMeter Test Script
	__1.  First Launch JMeter. If you don't remember how to do it then open a command prompt window, change to the C:\Software\jakarta-jmeter-2.3.4\bin folder and run the command jmeter.
	__2.  Right click Test Plan and select Add > Thread Group.
	__3.  Right click Thread Group and select Add > Sampler > Web Service(SOAP) Request.
	__4.  Enter these values:
	__5.  Verify your window looks like this:
	__6.  Save the test script as C:\LabFiles\AdderTest.jmx.
	__7.  Right click Thread Group and select Add > Sampler > HTTP Request.
	__8.  Enter these values:
	__9.  Click the Add button below Send Parameters With the Request table to add these parameters:
	__10.  Verify your window looks like this:
	__11.  Save changes.
	__12.  Right click Thread Group and select Add > Listener > Aggregate Report. 
	__13.  Similarly add the View Result Tree listener.
	__14.  Save changes.

	Part 5 -  Verify Script
	__1.  Press Control+R to run the test in single user mode.
	__2.  Select View Result Tree and make sure all requests are successful.
	__3.  Press Control+E to clear results.

	Part 6 -  Run Stress Test
	__1.  Select Thread Group.
	__2.  Set the number of threads to 10. 
	__3.  Set the loop count to 100.
	__4.  Disable View Result Tree.
	__5.  Run the test.
	__6.  Select Aggregate Report and analyze the result. 

	Part 7 -  Review




