
WA1471 Service Oriented Architecture for Architects

Student Labs

Web Age Solutions Inc.

1

EVALU
ATIO

N O
NLY



Table of Contents
Lab 1 - Import and Test Web Services................................................................................3
Lab 2 - Create a Mediation Module and Test Imports.......................................................21
Lab 3 - Create Business Objects........................................................................................37
Lab 4 - Basic Mediation Flow Development.....................................................................58
Lab 5 - Using Mediation Primitives...................................................................................72
Lab 6 - Data Translation and Routing................................................................................78
Lab 7 - Gathering Requirements......................................................................................122
Lab 8 - Design the Business Process Interface................................................................126
Lab 9 - Create the Expense Claim Business Process.......................................................135
Lab 10 - Identify and Specify Services............................................................................148
Lab 11 - Service Design and Implementation..................................................................157
Lab 12 - Process Implementation....................................................................................176
Lab 13 - Create an Interface Map for the Accounting System........................................184
Lab 14 - Assemble the Business Process.........................................................................193
Lab 15 - Deploy and Unit Test the Business Process......................................................198
Lab 16 - Build a Client for the Business Process.............................................................204
Lab 17 - Using File Inbound and Outbound Adapters.....................................................213
Lab 18 - Kicking Off Phase II..........................................................................................234
Lab 19 - Human Services – Add Manager's Review Function........................................242
Lab 20 - Build Business Rules.........................................................................................276
Lab 21 - Publishing JMS Message from a Process..........................................................314
Lab 22 - Asynchronous Notification To Process.............................................................326
Lab 23 - Implement Compensation in a Long Lived Business Process..........................348
Lab 24 - Testing Web Services........................................................................................359
Lab 25 - Pollution Regulation Compliance Process........................................................367
Lab 26 - Create a Profile (Optional)................................................................................369
Lab 27 - Import Lab Solutions (Optional).......................................................................388

2

EVALU
ATIO

N O
NLY



Lab 1 - Import and Test Web Services
In this lab, you will import two existing web services into WebSphere Integration 
Developer (WID).  You will use these in a later lab to construct a mediation flow.  In the 
meantime, you will unit test the web services using the Web Services Explorer.  

Following this exercise, you should be able to:

● Import existing projects into WID

● Unit test a web service using the Web Services Explorer

Part 1 - Import Web Services

In this part, you will import the two web services into WID.  The web services are stored 
in the project interchange format.  You will also briefly examine the web services.

__1. Launch WID by selecting Start->All Programs->IBM WebSphere Integration 
Developer->IBM WebSphere Integration Developer V7.0->WebSphere Integration 
Developer V7.0.

__2.  In the Workspace Launcher dialog, change the workspace  to C:\workspace

__3. Click OK.

__4. If the Welcome page appears, close it.

At this point, you should be in the Business Integration perspective.  The Business 
Integration perspective is a special perspective included with WID which is used for 
creating SCA modules.  

__5. Choose File->Import from the menu bar.

__6. Expand the Other folder and select Project Interchange.  
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__7. Click Next.

__8. Next to the From zip file drop down, click Browse.

__9. Select the C:\LabFiles\Accounting.zip file. Then click Open.

__10. Click the Select All button to select all the projects.

__11. Click Finish.  

After the import is complete, the CanadianAccounting, CanadianAccountingEAR, 
USAccounting, and USAccountingEAR projects will be displayed in the Business 
Integration view.  
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Note

The CanadianAccounting and USAccounting projects correspond with web modules and 
the CanadianAccountingEAR and USAccountingEAR projects correspond with 
enterprise application modules.

__12. Click on the Problems view at the bottom of the screen and make sure there are no 
errors listed.  The number of errors is listed at the top and should be zero.  Errors appear 
as red Xs.  Ignore any warnings, since they won't affect deployment of projects to the 
server.

__13. Examine the USAccountingService web service.  To do so, expand the 
USAccounting project in the Business Integration view.  

__14. Next expand Java Resources > src  > com.webage.accounting.  

__15. Open USAccountingSoapBindingImpl.java by double clicking on it.

Notice that USAccountingSoapBindingImpl is a simple Java class that contains a single 
method called registerClient.  registerClient takes a USAddress object as a parameter 
and logs information about the address to the server log file.  The method returns nothing 
to the caller.
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__16. In the Business Integration view in the same project, expand WebContent-
>WEB-INF->wsdl. 

__17. Open the USAccounting.wsdl file by right-clicking on it and selecting Open With 
->WSDL Editor.  

A graphical representation of the file will be displayed which corresponds with the 
Design tab.

Notice the following:

● USAccounting corresponds with the portType element of the WSDL file, 
which represents the web service's "interface".  Notice that WID has a purple I 
next to it, which is short for interface, to reinforce this concept.  

● The web service exposes a single operation called registerClient which matches 
the Java method you just looked at.  It only contains an input element, which 
makes sense, since the registerClient method has void as its return type.  

● USAccountingService corresponds with the service element of the WSDL file.

__18. If you wish to view the source code for the WSDL file, click on the Source tab. 
Otherwise, proceed onwards.

__19. In a similar manner, review the CanadianAccountingService web service.  
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You'll find it exposes an operation called addCustomer which takes a 
CanadianAddress object as an input.  It logs information about the customer to the 
server log file.

__20. Close any open files (Ctrl+Shift+W).

Part 2 - Back Up WebSphere Process Server Profile

In this part, you will back up the WebSphere Process Server profile that's used for testing 
your applications.  The profile contains the server's configuration files, log files, and 
installed applications.  It's recommended to back up the profile in case something goes 
wrong later when deploying applications to the server and modifying its configuration. 
Should this occur, you can always delete the old profile directory and unzip the archive 
file in its place.

__1. Open Windows Explorer.

__2. Navigate to C:\Program Files\IBM\WID7_WTE\runtimes\bi_v7\profiles.

__3. You will see the qwps folder there.

__4. Make a ZIP copy of this folder using a tool such as WinZip or WinRAR. If you 
don't have any tool installed to ZIP files, then just make a copy of the folder.
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Part 3 - Start the Server

__1. Back in WID, click on the Servers view at the bottom of WID.  WebSphere 
Process Server v7.0 at localhost should be listed, we will refer to it during the labs just 
as Server.  If the server is not there then contact your instructor.

__2. Right click on the server and select Start to launch the server.

The server can take up to several minutes to start.  While the server is starting, the Server 
Logs view will open showing messages.

Once the Server is started the Servers view will open and will show the server as started 
and synchronized.

__3. Open the Servers Logs view, you should see the message Server server1 open for 
e-business.
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__4. Select the Servers view again.

__5. Right click the server and select Administration > Run administrative console.  

The Administrative Console, which is a web-based application included with 
WebSphere Process Server for administering it, will open up in a browser inside of WID.

__6. Click OK in the first Security Alert dialog.

__7. Click Yes in the Security Alert dialog.

__8. Enter admin and admin as User ID and Password.

__9. Click Log In.

The Welcome page will open.
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__10. In the left panel, expand Servers > Server Types and click WebSphere 
Application servers underneath.

__11. In the right panel, click on server1, which is the default server that was created 
when WebSphere Process Server was installed.

10

EVALU
ATIO

N O
NLY



__12. In the application server configuration page, scroll down until you see the 
Communications heading.

__13. Click the + symbol next to Ports.

__14. At a bare minimum, verify the following ports are set correctly:

Port Name Port Description

BOOTSTRAP_ADDRESS 2809 Bootstrap port

SOAP_CONNECTOR_ADDRESS 8880 SOAP connector port

WC_adminhost 9060 Administrative console port 

WC_defaulthost 9080 HTTP transport port 
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WC_adminhost_secure 9043 Administrative console secure port 

WC_defaulthost_secure 9443 HTTPS transport port 

__15. Click the Logout link at the top of the admin console.

__16. Close the admin console.

__17. If the port numbers matched the ones above, you're good to go.  Proceed on to the 
next part of the lab.  

__18. Otherwise, if the port numbers didn't match the ones above, you'll need to create a 
new profile according to the instructions in the "Create a Profile" lab.  Notify your 
instructor of this, since it will take a little while to create a new profile.

Part 4 - Deploy Web Service Applications to the Server

In this part, you will deploy the web service applications to WebSphere Process Server.
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__1. From the menu, select Window > Show View > Console.

This will open the Console view in the bottom right pane where all the messages will be 
displayed.

__2. Select the Servers tab.

__3. Deploy the projects to the server by right clicking on the server and selecting Add 
and Remove Projects... from the menu.

__4. Click Add All to move the CanadianAccountingEAR, and USAccountingEAR 
projects to the Configured projects list.

__5. Click Finish.

__6. Wait until finish publishing and then check the Console view to verify the 
applications were started successfully. At the end you should see the message 
"Application started:  <CanadianAccountingEAR>"

__7. Scroll up and find the message "Application started:  <USAccountingEAR>"
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Troubleshooting:  If you see the error message "Failure uploading archive to server", 
it's probably due to the fact that the server security certificate is configured with an IP 
address instead of a host name.  To resolve this problem:

1.  Stop the server by right clicking on it in the Servers view and selecting Stop.

2.  Exit WID.

3.  Open the config.ini file using Notepad, which is located in the C:\Program 
Files\IBM\WID7\configuration directory.

4.  Comment out the following line of code by placing a pound symbol (#) in front of it:

#com.ibm.ssl.performURLHostNameVerification=true

5.  Save and close the file.

6.  Open WID.

7.  Start the server by right clicking on it in the Servers view and selecting Start.

8.  Verify the changes are published successfully to the server.  The server status should 
changed to Synchronized.

This problem is documented here:

http://www.ibm.com/support/docview.wss?uid=swg21414552

__8. Select the Servers view and expand the server. There you will see the applications 
deployed.
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Part 5 - Unit Test the Web Services

In this part, you will use the Web Services Explorer to unit test the web services.

__1. In the Business Integration view, expand USAccounting->WebContent->WEB-
INF->wsdl.

__2. Right click USAccounting.wsdl and select Web Services->Test With Web 
Services Explorer.  

The Web Services Explorer will open.  

__3. Maximize the Web Services Explorer by double clicking on the title bar.

__4. In the Operations table, click registerClient.  

The child elements of clients should be expanded, that make up a USAddress.  
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__5. Fill in the information as shown below:
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__6. Click Go.

__7. Nothing terribly exciting happened.  Since the US Accounting web service does not 
return an output message, the Status pane doesn't show a response body.

__8. Restore the size of the Web Services Explorer view.

__9. However, look in the Console view.  You should see the following messages, which 
indicates that the web service was really invoked and did what it was supposed to do.

__10. Click the Clear button in the Web Services Explorer next to the Navigator pane.

__11. Close the Web Services Explorer.

Now we will repeat the process for the Canadian Accounting web service.  

__12. In the Business Integration view, expand CanadianAccounting->WebContent-
>WEB-INF->wsdl.

__13. Right click CanadianAccounting.wsdl and select Web Services->Test With 
Web Services Explorer.  

The Web Services Explorer will open.  
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__14. Maximize the Web Services Explorer by double clicking on the title bar.

__15. In the Operations table, click addCustomer.  

__16. Fill in the information as shown below:

__17. Click Go.

__18. Restore the size of the Web Services Explorer view.
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__19. Clear the Web Services Explorer.

__20. Again, nothing terribly exciting happened.  However, look in the Console view. 
You should see the following messages, which indicates that the web service was really 
invoked and did what it was supposed to do.

__21. Close the Web Services Explorer.  

__22. Stop the server by right clicking on it and selecting Stop.  

__23. The server will show a status of Stopped in the Servers view.

__24. When the server finishes running, the message Server server1 stopped will appear 
in the Console view.  

__25. Close any open files.  

Congratulations!  You've successfully tested the web services using the Web Services 
Explorer.
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Part 6 - Review

In this lab, you imported two accounting web services into WID, one for a US accounting 
system and one for a Canadian accounting system.  You inspected the web services, 
including the Java class itself and the WSDL file.  Finally, you unit tested the web 
services using the Web Services Explorer.  The Web Services Explorer is a tool included 
with Eclipse, which WebSphere Integration Developer is built on top of.
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Lab 2 - Create a Mediation Module and Test Imports
In this lab, you will create a mediation module and use it to unit test the web services you 
imported in the previous lab.  You will use these in a later lab to construct a mediation 
flow.  

When creating a mediation module, you need to create an assembly diagram.  An 
assembly diagram is required for any Service Component Architecture (SCA) module 
(a.k.a. service module).  Fortunately for us, WID automatically creates an empty 
assembly diagram when you create a mediation module or module (a.k.a. business 
integration module), both of which are SCA modules.  Assembly diagrams are used to 
wire together the service components (services) contained within the module so they 
communicate with one another when deployed to the server.  

In order to make use of our web services, we need to add a special kind of component to 
an assembly diagram known as an import component.  An import component allows the 
module to access an external service or a service component residing in another module. 
In this case, you will add two import components to access both web services.  

WID provides a test client, known as the Integration Test Client, which allows you to test 
a component within a module or the entire module for that matter.  You will use it to test 
the import components and hence the web services.

Following this exercise, you should be able to:

● Create a mediation module
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● Add import components to an assembly diagram

● Unit test a service component using the Integration Test Client

Part 1 - Create a Mediation Module

In this part, you will create a mediation module.  You will import the WSDL files for the 
web services into the module.  You will examine the Data types, Interface, and Web 
Service Port nodes created after doing an import, which represent different portions of the 
WSDL file.  Finally, you will add import components with web service bindings to the 
module's assembly diagram so you can test them in the next part.  The binding 
information provides the information for communicating with a web service and 
corresponds with the message protocol (SOAP/HTTP), document format/encoding style 
(document/literal), and service endpoint (URL), which are contained inside the 
binding, service, and port elements of a WSDL file.

__1. Select File->New->Mediation Module from the menu bar.

__2. In the New Mediation Module dialog, enter AccountRouter as the Module name. 

__3. Select WebSphere Process Server v7.0 from the Target runtime environment 
drop-down.

__4. Uncheck Create mediation component.

__5. Click Finish.
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The AccountRouter project will be created and should appear in the Business 
Integration view.  Also, the Assembly Diagram for the project should automatically be 
opened in the editors pane.

Part 2 - Import Web Service WSDL

Next, you will import the US Accounting WSDL file into the mediation module so you 
can invoke the web service from it.  

__1. Right click on the AccountRouter project and select Import from the menu.  

__2. In the Import dialog, expand the Business Integration folder and select WSDL 
and XSD.  

__3. Click Next.

__4. Leave selected Local WSDL or XSD file, or both and click Next.

23

EVALU
ATIO

N O
NLY



__5. Click the Browse button and navigate to 
C:\workspace\USAccounting\WebContent\WEB-INF\wsdl.  

__6. Click OK.

__7. Check USAccounting.wsdl in the right pane.

__8. Click Finish.

__9. In the AccountRouter project, expand the Interfaces node.  You should see 
USAccounting listed.  

__10. Import the Canadian Accounting WSDL file following the same procedure as 
above.  This time navigate to C:\workspace\CanadianAccounting\WebContent\WEB-
INF\wsdl and check CanadianAccounting.wsdl in the Import dialog.
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__11. After clicking Finish, you should also see CanadianAccounting listed under the 
Interfaces node.

__12. Open USAccounting and CanadianAccounting.  

Notice that WID opens the WSDL files you imported using the Interface Editor and 
displays the interface of both web services. 

Note

An Interface node is a logical representation of the physical WSDL file.  Had we 
broken the WSDL file up into two files, an abstract WSDL file containing the types, 
message, and portType elements and a concrete WSDL file containing the 
binding and service elements, the Interface node would have pointed to the 
abstract WSDL file.

__13. Expand the Web Service Ports folder.  

Notice that CanadianAccountingPort and USAccountingPort are also listed there. 
These also correspond with the WSDL file you opened before.  

25

EVALU
ATIO

N O
NLY



Note

A Web Service Port node is a logical representation of the physical WSDL file.  Had 
we broken the WSDL file up into two files, an abstract WSDL file containing the 
types, message, and portType elements and a concrete WSDL file containing the 
binding and service elements, the Web Service Port node would have pointed to 
the concrete WSDL file.

__14. Open USAccounting and CanadianAccounting ports. 

__15. Close all the open files.

__16. Last but not least, expand the Data Types node.  These files correspond with the 
complex types defined within the two WSDL files.  

Note

A Data Type node shows all the XML schema elements used by this module.  When 
you import the WSDL of a web service, system also imports all the XML data types. 
These data types may be defined directly within the WSDL or in separate XML schema 
document (XSD) files. 

__17. Open the USAddress and CanadianAddress data types.  

WID opens them with the Business Object Editor which displays a graphical 
representation of the data types.

__18. Close all the open files.

Part 3 - Create SCA Imports for Web Services

We will now create SCA import objects for the US and Canadian accounting web 
services. These imports will act as proxies for these remote services. We will be able to 
invoke operations of these services using the imports.
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__1. Open the Assembly Diagram.  To do so, double click on the Assembly Diagram 
node in the Business Integration view.

__2. Create an import component for the USAccounting web service by dragging 
USAccounting under Web Service Ports onto the Assembly Diagram.

__3. The Select a Transport Protocol window will open, select SOAP1.1/HTTP 
option.

The WSDL file of the web service indicates that SOAP 1.1 should be used. As a result, 
the SOAP 1.2 option is greyed out. Now, we can choose the JAX-WS option or the 
JAX-RPC option. It is recommended that you choose JAX-WS since that is the direction 
WebSphere is heading for. JAX-RPC is deprecated.

When you select SOAP1.1/HTTP, as we do here, JAX-WS is also selected.

__4. Click Finish.

__5. An import named USAccountingImport1 will appear in the assembly diagram.

__6. Right click on the import and select Rename.  Change the name to USAccounting
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__7. Likewise, create an import component for the CanadianAccounting web service by 
dragging the CanadianAccounting node under Web Service Ports onto the Assembly 
Diagram.

__8. Select SOAP1.1/HTTP option.

__9. Click Finish.

__10. Rename the import as CanadianAccounting

__11. Save the assembly diagram.

__12. Click in the Problems view and make sure there are no errors before proceeding to 
the next part.

Part 4 - Unit Test the Web Services

In this part, you will deploy the web service applications and mediation module to 
WebSphere Process Server.  You will then use the Integration Test Client to test the 
imports which indirectly tests the web services.

__1. Start the Server.

__2. Right click the server and select Add and Remove Projects.

__3. Click Add All.

__4. Click Finish. Wait until finish publishing.
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__5. In the Servers view, verify that all projects are Synchronized.

Now that you've successfully deployed the web services applications and mediation 
module, you will test the imports you created.

__6. In the Assembly Diagram, right click on USAccounting and select Test 
Component.

WID will open a test editor in the editors pane called AccountRouter_Test.

Under Detailed Properties, notice that we can see exactly what we're testing:

● Module: AccountRouter

● Component: USAccounting

● Interface:  USAccounting

● Operation: registerClient

In order to unit test the registerClient operation, we need to provide some USAddress 
data, which corresponds with the client variable.

__7. Double click on the Value field next to city.

__8. A text field will pop up.  Enter the following value:  New York
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__9. Enter the remaining client data as follows:  

Name Value

country USA

fullName Linda Peterson

state NY

streetAddress 400 East 63rd Street, Apt 2B

zip 10021

Your Initial request parameters should look as follows:
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Note

You can also use the up and down arrow keys to navigate between the fields.  Also, you 
can simply start typing within a field rather than double clicking it.  WID will 
automatically open the pop-up text field for data entry.

__10. Now that you've input your data, we can proceed with the test.  Under the Events 
heading, click the green arrow (Continue button).

__11. In the Deployment Location dialog, make sure that WebSphere Process Server 
v7.0 is selected.  

__12. Check the box Use this location as the default and do not ask again, so you 
won't be prompted for the deployment location again.
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__13. Click Finish.

__14. A User Login dialog will pop up challenging you for a user id and password. 
admin should already be filled in for both the User ID and Password fields.  If not, go 
ahead and input the value.  Also, check Use the authentication settings in the 
preference and never ask again so you're not prompted for your credentials again.

Note

In WebSphere Application Server, on which WebSphere Process Server is built, 
administrative security and application security are enabled by default.  admin is the 
default user id and password for the server profile that was created when WID was 
installed.

__15. Click OK.
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A dialog called Starting the Integration test client will pop up.  

After the dialog disappears, you will see the test run.

__16. Look in the Console view.  You should see the following messages, which 
indicates that the web service was really invoked and did what it was supposed to do.

__17. Now we will repeat the process for the Canadian Accounting web service.  Click 
the Invoke icon under the Events heading to run another test.

__18. Select CanadianAccounting from the Component drop-down.  The Interface and 
Operation drop-downs will automatically be updated to reflect the 
CanadianAccounting interface and addCustomer operation, respectively.
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__19. In order to unit test the customer operation, we need to provide some 
CanadianAddress data, which corresponds with the customer variable.  

__20. Enter the following customer data:  

Name Value

address1 1200 Bay Street, Suite 
801

city Toronto

country Canada

name Pamela Anderson

postalCode M5R 2A5

province Ontario

Your Initial request parameters should look as follows:
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__21. Now that you've input your data, we can proceed with the test.  Under the Events 
heading, click the Continue button.

This time the Deployment Location dialog and User Login dialogs should not pop up, 
since you indicated that you should never be prompted again.  

__22. Look in the Console view.  You should see the following messages, which 
indicates that the web service was really invoked and did what it was supposed to do.

__23. Close the test editor.  Don't save your changes.

__24. Stop the server.

__25. Close any open files.  

35

EVALU
ATIO

N O
NLY



Congratulations!  You've successfully tested the web services using the Integration Test 
Client.

Part 5 - Review

In this lab, you created a mediation module to test the services.  Next, you imported the 
WSDL files into the mediation module.  You observed that the Data Types, Interfaces, 
and Web Service Ports nodes of the mediation module were populated and contained 
nodes which pointed to different sections of the WSDL files.  Next, you added an import 
component for each web service to the module's assembly diagram so your module could 
communicate with the web services.  Finally, you unit tested the import components, 
which indirectly tested the web services, using the Integration Test Client.

Going forward, we can use the imports to invoke remote web services from a mediation 
flow.
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Lab 3 - Create Business Objects
Business objects represent the data that's passed between service components in your 
SCA modules.  When you create interfaces (WSDL or Java) for your components, which 
you'll do in the next lab, the input and output parameters correspond with business 
objects.  Business objects are defined using XML Schema Definition (XSD) files.  

WebSphere ESB and Process Server uses the Service Data Object (SDO) API to work 
with business objects. Specifically, the commonj.sdo.DataObject interface represents a 
data object.

Business objects can store both simple attributes (e.g., string, int, double, boolean) and 
complex attributes (i.e., other business objects).  An attribute can be multi-valued, which 
means it can be stored as an array.  

In this lab, you will create several business objects.  Specifically, you will create 
Customer, Address, Order, and OrderItem business objects which are inter-related.  A 
Customer can have multiple Orders.  An Order can have multiple OrderItems.  An Order 
can also have a shipping address and billing address, both of which are of type Address.
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Following this exercise, you should be able to:

● Create business objects using the Business Object Editor.

● Create a default namespace.

● View the physical files created by WID

Part 1 - Create a Default Namespace

Namespaces are used in XML to uniquely identify XML elements and attributes.  They 
help prevent collisions between elements and attributes with the same names. 
Namespaces are analogous to Java packages which uniquely identify class names.  When 
creating an XML schema, a target namespace is specified.  All elements and attributes 
defined in the schema belong to that target namespace.

In this part, you will create a default namespace that's used when creating business 
objects and other kinds of XML artifacts.  Namespaces typically correspond with a URI 
(usually a URL), since they must be unique and URIs are unique.  You will set the 

38

EVALU
ATIO

N O
NLY



default namespace to http://www.webagesolutions.com.  Normally, you would set it to 
your company's URL. Having a default namespace set will save us a lot of typing and 
error when we create a new business object.

__1. Select Window->Preferences from the menu bar.

__2. In the left pane, expand Business Integration and select Default Namespace.

__3. In the right pane, click the New button to create a new default namespace.

__4. Type Corporate Default in the Name field.

__5. Enter www.webagesolutions.com in the Pattern field.

__6. Click OK to create the namespace.
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__7. Click OK to close the preferences.

Part 2 - Create a Business Integration Module

In this part, you will create a business integration module (module for short) for storing 
your business objects. 

__1. Select File > New > Mediation Module from the menu bar.  

__2. Enter CustomerOrder for the Module Name.

__3. Select WebSphere Process Server 7.0 as Target runtime environment.

__4. Uncheck Create mediation component.

__5. Uncheck Open module assembly diagram.
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__6. Click Finish.  The CustomerOrder project should appear in the Business 
Integration view.

Part 3 - Create the Customer Business Object 

In this part, you will create the Customer business object using the Business Object 
Editor.  You will add simple fields to it, such string, boolean, and int.  You will also see 
how you can specify metadata for the fields, including whether or not its required, has 
enumerated values and/or matches a pattern.

__1. In the Business Integration view, under the CustomerOrder module, right click 
Data Types and select New > Business Object.

__2. Notice that the Namespace field is pre-populated with the default you set earlier: 
http://www.webagesolutions.com.  

__3. Enter Customer in the Name field.
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__4. Click Finish.

The Customer business object will be created and should automatically be opened inside 
the Business Object Editor.

__5.  Now let's define our Customer business object.  Select the Customer object.  Then 
click the field icon (F in a blue circle) to add a field to the business object.  A field called 
field1 should be added to the Customer object of type string.

__6. Click on field1 and rename it as customerId

You may need to hit <ENTER> to accept the new name before you can make other 
changes.
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__7. Click on string and select int from the drop-down.

__8. Using the procedure above, add the following fields:

Name Type

customerType string

active boolean

firstName string

lastName string

homePhone string

workPhone string

Your business object should look as follows:

__9. Save your changes.
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__10. Since the customerId uniquely identifies a customer, it should be required.  To 
specify this, right click on customerId and select Show in > Properties view from the 
menu.  

__11. The Properties view should appear at the bottom of WID.  Change the Minimum 
occurrences to 1.

It's also possible to specify that a field can only contain certain values using the 
enumerations feature.  For example, the customerType can only be set to the values 
silver, gold, or platinum.  

__12. Click on the customerType field in the Business Object Editor.  

__13. In the Properties view, check the Only permit certain values checkbox.  (you 
may need to scroll down)

__14. Select the Enumerations radio button.

__15. Click the Add button.

__16. Enter silver in the Add Enumeration dialog.

__17. Click OK.

__18. In the same way add gold and platinum in the list.
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__19. You can also specify a regular expression pattern that a field must match when 
being input.  The homePhone and workPhone fields should be entered in the format: xxx-
xxx-xxxx.  To accomplish this, click on the homePhone field in the Business Object 
Editor.  

__20. In the Properties view, check the Only permit certain values checkbox.  

__21. Then, click the Patterns radio button.

__22. Click Add.

__23. In the Regular Expression Wizard dialog, select Digit ( \d ) from the Token 
contents drop-down.  

__24. Then, click the Repeat radio button and type 3 in the text field to the right of it.  

__25. Then click the Add button.  

The Current Regular Expression field should now show \d{3} which means the user 
needs to type in 3 digits for the phone number.  We're not done yet.
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__26. Type a dash (-) next to \d{3} in the Current regular expression field.

__27. Click the Add button again to append \d{3} to the regular expression. 

__28. Type another dash (-) next to \d{3}-\d{3} in the Current regular expression field. 

__29. Change the Repeat value from 3 to 4 and click Add again.  Voila!  Your regular 
expression is complete.

__30. WID also allows you test your regular expression to make sure you input it 
correctly.  To do so, click the Next button.  

__31. In the Sample text field, enter 123-456-7890  
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__32. The message The text matches the regular expression should appear at the top of 
the dialog.

Try entering an wrongly formatted phone number.

__33. Click Finish.

__34. Repeat the process for the workPhone. 

__35. Save your changes.

__36. Close the file.

Part 4 - Create the Address Business Object

Up until this point, you've created fields having only simple data types – string, integer, 
boolean and so on.  It's also possible to create fields having complex data types.  The 
complex data types are themselves other business objects.  For example, an Order, which 
you will be creating shortly, has a shipping address and a billing address.  Since an Order 
has multiple addresses rather than just one, it's recommended to create another business 
object called Address, instead of simply adding address fields to the Order business 
object.  In this part, you'll create the Address business object.  

__1. In the Business Integration view, right click on Data Types under 
CustomerOrder and select New > Business Object.
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__2. Type Address in the Name field.  

__3. Click Finish.

The Address business object will be created and should automatically be opened inside 
the Business Object Editor.

__4. Enter the following fields:

Name Type Minimum 
ocurrences

addressId int 1

street1 string

street2 string

city string

state string

zip string

country string
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Name Type Minimum 
ocurrences

name string

Your business object should look as follows:

Note

You added a name field to Address, since a customer may have an order shipped to an 
address where she doesn't live.  The name would correspond with the name of the 
person who lives at that address. 

__5. Save your changes.

__6. Close the file.

Part 5 - Create the Order and OrderItem Business Objects

In this part, you'll create the Order business object.  You'll use the Address business 
object you created in the last part when declaring the shippingAddress and billingAddress 
fields.  You'll also add an orderItems field to the Order business object.  When declaring 
the orderItems field, you'll create an OrderItem business object on the fly, since an order 
can consist of multiple order items.  Afterwards, you'll complete the Customer business 
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object by adding a field called orders to it of type Order.  Since both orderItems and 
orders are multi-valued, you'll declare them as arrays.  

When you create a business object on the fly (e.g., OrderItem) when defining the parent 
business object, this is referred to as a top-down based approach to business object 
development.  On the other hand, when you create the business object in advance (e.g., 
Address and Order), this is referred to as a bottom-up based approach to business object 
development.  Both approaches are valid.

__1. In the Business Integration view, right click on Data Types under 
CustomerOrder and select New > Business Object.

__2. Type Order in the Name field.  

__3. Click Finish.

__4. The Order business object will be created and should automatically be opened 
inside the Business Object Editor.  Enter the following fields:

Name Type Minimum 
ocurrences

orderId int 1

orderDate date

shippingAddress Address

billingAddress Address

__5. When specifying the Address type, you'll need to scroll to the bottom of the type 
drop-down, since that's where all business objects are located.
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Your business object should look as follows:

Notice that Address was added to the diagram and two arrows were drawn between 
Order and Address showing the parent-child relationship between the two business 
objects.  

__6. Click on the plus (+) sign next to Address to expand it and see its fields.  Use the 
bottom arrow to scroll through its fields.  

Also, notice that you can't edit any of Address's fields.  To edit Address, you can simply 
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double click on Address and it will open up in the Business Object editor.

__7. Return to the business object editor showing the Order business object if you are 
not there already.  

__8. Add another field named orderItems

__9. This time, when specifying the data type, click the New... option in the drop-down. 
It's located at the top of the drop-down.

__10. In the New Business Object dialog, type OrderItem in the Name field and click 
Finish.  

The OrderItem business object will be created and should automatically be opened 
inside the Business Object Editor.  

__11. For the OrderItem business object, enter the following fields:

Name Type Minimum 
occurrences

itemId int 1

description string

quantity int

price float

__12. Your business object should look as follows:

__13. Save your changes and close the OrderItem file.

52

EVALU
ATIO

N O
NLY



Back in the Order Business Object Editor, you will specify that an Order can have more 
than one OrderItem.

__14. Click on the orderItems field.  

__15. In the Properties view, from the drop-down change the Maximum occurrences 
to unbounded.

__16. Click anywhere in the editor.

Notice that a set of square brackets ([ ]) now appears to the right of orderItems 
indicating that it contains an array of OrderItem business objects.

__17. Save your changes and close the file.

__18. Last but not least, open the Customer business object.

__19. Add a field to the Customer business object named orders of type Order.  You 
may need to click the Customer business object in the editor to select it first.

__20. Change the Maximum occurrences  to unbounded to declare the field as an array.
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Note

WID allows you to view business objects only one level deep.  Consequently, you can't 
view OrderItem in the Customer's Business Object Editor.

__21. Save your changes.

__22. It's also possible to display the Customer business object in a tabular format.  To do 
so, click on the icon on the far right of the editor toolbar.

__23. Now you're in the table view.  In addition to displaying the field names and data 
types for the business object and its children, the table view displays their default values 
(if any) and multiplicity (number of minimum occurrences and maximum occurrences).   

Also observe the following:
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● customerId has a Min Occurs and Max Occurs both set to 1.  This means that it 
must have one and only one value, since we declared it as a required field.

● orders has a Min Occurs set to 0 and a Max Occurs set to unbounded.  This 
means that a Customer can have 0 or more orders.  These values are used when 
specifying arrays.  Likewise, orderItems has a Min Occurs set to 0 and a Max 
Occurs set to unbounded, since it's also an array.

● All of the other attributes have a Min Occurs of 0 and Max Occurs of 1, which 
means they're optional fields (as opposed to required fields)

__24. Switch back to the diagram view by clicking on the icon on the far right of the 
editor toolbar.  Notice the icon has changed.

__25. Close all open files.  Save if there are any unsaved changes.

Congratulations!  You've successfully created a hierarchy of business objects.

Part 6 - View the Physical Files

In this part, you'll see the files that get created behind the scenes when you create a 
business object.  Specifically, you'll see that an XML schema definition (XSD) was 
created for each business object. 
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WID tries to keep things as "logical" as possible to make things easier on the integration  
developer, since he/she is only required to have basic programming skills (knows how to 
create loops, conditionals, and perform string manipulation).  WID provides graphical 
editors wherever possible to simplify and abstract complex programming details.  

__1. In the Business Integration view, right click on the CustomerOrder module and 
select Show Files.

__2. WID will open the Physical Resources view and stack it on top of the Business 
Integration view.  Notice that the business objects you created are located directly 
underneath the CustomerOrder project and correspond with XSDs (can tell based on the 
file extension).

Note

In a future lab, you will begin to use folders when creating business objects and other 
kinds of SCA artifacts, so that the resulting files are better organized.  This is especially 
important when creating larger projects.

__3. Double click on Customer.xsd.  Notice that WID still opens it with the Business 
Object Editor.  

__4. To change this behavior, close the file.  Then right click on it and select Open With-
>Text Editor from the menu.  WID will now open it with a text editor so you can view 
the actual XML.  

Notice the following:

● The targetNamespace attribute is set to http://www.webagesolutions.com, 
which is the default namespace we set at the beginning of the lab.

● The XML schema file Order.xsd is included so the Customer XSD can reference 
the Order element.

● Customer is declared as a complex type, since it contains child elements 
(correspond with the fields we declared).
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● The Max Occurs and Min Occurs columns you saw earlier in the Business Object
Editor's table view correspond with the maxOccurs and minOccurs XSD
attributes.

<?xml version="1.0" encoding="UTF-8"?>
<xsd:schema targetNamespace="http://www.webagesolutions.com"
   xmlns:xsd="http://www.w3.org/2001/XMLSchema"
   xmlns:bons0="http://www.webagesolutions.com">
   <xsd:include schemaLocation="Order.xsd"></xsd:include>
   <xsd:complexType name="Customer">

<xsd:sequence>
<xsd:element minOccurs="1" name="customerId"

type="xsd:int">
</xsd:element>
...

</xsd:sequence>
   </xsd:complexType>
</xsd:schema>

__5. Close the file.

Note

You could have also opened the file with the full XML Schema editor.  We opened it 
with the text editor just to see the contents easily.

__6. The Customer.xsd file will automatically be opened with the text editor from this 
point forward unless you change it back to open with the Business Object Editor.  To 
change this, right click on the file and select Open With > Business Object Editor.  

__7. Close the Business Object Editor.  

__8. Switch back to the Business Integration view.

Part 7 - Review

In this lab, you set a default namespace within WID for any XML files you create.  Next, 
you created four inter-related business objects:  Customer, Address, Order, and 
OrderItem.  Business objects are used to represent data in a SOA.  The business objects 
get passed to and fro between service components when they communicate with one 
another by invoking each other's operations.  You used the Business Object Editor, which 
is quite powerful, to create the business objects.  You also switched to the Physical 
Resources view and saw that WID creates XML schema files behind the scenes to 
represent the business objects.
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	Lab 1 -  Import and Test Web Services
	Part 1 -  Import Web Services
	__1.  Launch WID by selecting Start->All Programs->IBM WebSphere Integration Developer->IBM WebSphere Integration Developer V7.0->WebSphere Integration Developer V7.0.
	__2.   In the Workspace Launcher dialog, change the workspace  to C:\workspace
	__3.  Click OK.
	__4.  If the Welcome page appears, close it.
	At this point, you should be in the Business Integration perspective.  The Business Integration perspective is a special perspective included with WID which is used for creating SCA modules.  
	__5.  Choose File->Import from the menu bar.
	__6.  Expand the Other folder and select Project Interchange.  
	__7.  Click Next.
	__8.  Next to the From zip file drop down, click Browse.
	__9.  Select the C:\LabFiles\Accounting.zip file. Then click Open.
	__10.  Click the Select All button to select all the projects.
	__11.  Click Finish.  
	__12.  Click on the Problems view at the bottom of the screen and make sure there are no errors listed.  The number of errors is listed at the top and should be zero.  Errors appear as red Xs.  Ignore any warnings, since they won't affect deployment of projects to the server.
	__13.  Examine the USAccountingService web service.  To do so, expand the USAccounting project in the Business Integration view.  
	__14.  Next expand Java Resources > src  > com.webage.accounting.  
	__15.  Open USAccountingSoapBindingImpl.java by double clicking on it.
	__16.  In the Business Integration view in the same project, expand WebContent->WEB-INF->wsdl. 
	__17.  Open the USAccounting.wsdl file by right-clicking on it and selecting Open With ->WSDL Editor.  
	__18.  If you wish to view the source code for the WSDL file, click on the Source tab.  Otherwise, proceed onwards.
	__19.  In a similar manner, review the CanadianAccountingService web service.  
	__20.  Close any open files (Ctrl+Shift+W).

	Part 2 -  Back Up WebSphere Process Server Profile
	__1.  Open Windows Explorer.
	__2.  Navigate to C:\Program Files\IBM\WID7_WTE\runtimes\bi_v7\profiles.
	__3.  You will see the qwps folder there.
	__4.  Make a ZIP copy of this folder using a tool such as WinZip or WinRAR. If you don't have any tool installed to ZIP files, then just make a copy of the folder.

	Part 3 -  Start the Server
	__1.  Back in WID, click on the Servers view at the bottom of WID.  WebSphere Process Server v7.0 at localhost should be listed, we will refer to it during the labs just as Server.  If the server is not there then contact your instructor.
	__2.  Right click on the server and select Start to launch the server.
	__3.  Open the Servers Logs view, you should see the message Server server1 open for e-business.
	__4.  Select the Servers view again.
	__5.  Right click the server and select Administration > Run administrative console.  
	__6.  Click OK in the first Security Alert dialog.
	__7.  Click Yes in the Security Alert dialog.
	__8.  Enter admin and admin as User ID and Password.
	__9.  Click Log In.
	__10.  In the left panel, expand Servers > Server Types and click WebSphere Application servers underneath.
	__11.  In the right panel, click on server1, which is the default server that was created when WebSphere Process Server was installed.
	__12.  In the application server configuration page, scroll down until you see the Communications heading.
	__13.  Click the + symbol next to Ports.
	__14.  At a bare minimum, verify the following ports are set correctly:
	__15.  Click the Logout link at the top of the admin console.
	__16.  Close the admin console.
	__17.  If the port numbers matched the ones above, you're good to go.  Proceed on to the next part of the lab.  
	__18.  Otherwise, if the port numbers didn't match the ones above, you'll need to create a new profile according to the instructions in the "Create a Profile" lab.  Notify your instructor of this, since it will take a little while to create a new profile.

	Part 4 -  Deploy Web Service Applications to the Server
	__1.  From the menu, select Window > Show View > Console.
	__2.  Select the Servers tab.
	__3.  Deploy the projects to the server by right clicking on the server and selecting Add and Remove Projects... from the menu.
	__4.  Click Add All to move the CanadianAccountingEAR, and USAccountingEAR projects to the Configured projects list.
	__5.  Click Finish.
	__6.  Wait until finish publishing and then check the Console view to verify the applications were started successfully. At the end you should see the message "Application started:  <CanadianAccountingEAR>"
	__7.  Scroll up and find the message "Application started:  <USAccountingEAR>"
	__8.  Select the Servers view and expand the server. There you will see the applications deployed.

	Part 5 -  Unit Test the Web Services
	__1.  In the Business Integration view, expand USAccounting->WebContent->WEB-INF->wsdl.
	__2.  Right click USAccounting.wsdl and select Web Services->Test With Web Services Explorer.  
	The Web Services Explorer will open.  
	__3.  Maximize the Web Services Explorer by double clicking on the title bar.
	__4.  In the Operations table, click registerClient.  
	__5.  Fill in the information as shown below:
	__6.  Click Go.
	__7.  Nothing terribly exciting happened.  Since the US Accounting web service does not return an output message, the Status pane doesn't show a response body.
	__8.  Restore the size of the Web Services Explorer view.
	__9.  However, look in the Console view.  You should see the following messages, which indicates that the web service was really invoked and did what it was supposed to do.
	__10.  Click the Clear button in the Web Services Explorer next to the Navigator pane.
	__11.  Close the Web Services Explorer.
	__12.  In the Business Integration view, expand CanadianAccounting->WebContent->WEB-INF->wsdl.
	__13.  Right click CanadianAccounting.wsdl and select Web Services->Test With Web Services Explorer.  
	The Web Services Explorer will open.  
	__14.  Maximize the Web Services Explorer by double clicking on the title bar.
	__15.  In the Operations table, click addCustomer.  
	__16.  Fill in the information as shown below:
	__17.  Click Go.
	__18.  Restore the size of the Web Services Explorer view.
	__19.  Clear the Web Services Explorer.
	__20.  Again, nothing terribly exciting happened.  However, look in the Console view.  You should see the following messages, which indicates that the web service was really invoked and did what it was supposed to do.
	__21.  Close the Web Services Explorer.  
	__22.  Stop the server by right clicking on it and selecting Stop.  
	__23.  The server will show a status of Stopped in the Servers view.
	__24.  When the server finishes running, the message Server server1 stopped will appear in the Console view.  
	__25.  Close any open files.  

	Part 6 -  Review

	Lab 2 -  Create a Mediation Module and Test Imports
	Part 1 -  Create a Mediation Module
	__1.  Select File->New->Mediation Module from the menu bar.
	__2.  In the New Mediation Module dialog, enter AccountRouter as the Module name. 
	__3.  Select WebSphere Process Server v7.0 from the Target runtime environment drop-down.
	__4.  Uncheck Create mediation component.
	__5.  Click Finish.

	Part 2 -  Import Web Service WSDL
	__1.  Right click on the AccountRouter project and select Import from the menu.  
	__2.  In the Import dialog, expand the Business Integration folder and select WSDL and XSD.  
	__3.  Click Next.
	__4.  Leave selected Local WSDL or XSD file, or both and click Next.
	__5.  Click the Browse button and navigate to C:\workspace\USAccounting\WebContent\WEB-INF\wsdl.  
	__6.  Click OK.
	__7.  Check USAccounting.wsdl in the right pane.
	__8.  Click Finish.
	__9.  In the AccountRouter project, expand the Interfaces node.  You should see USAccounting listed.  
	__10.  Import the Canadian Accounting WSDL file following the same procedure as above.  This time navigate to C:\workspace\CanadianAccounting\WebContent\WEB-INF\wsdl and check CanadianAccounting.wsdl in the Import dialog.
	__11.  After clicking Finish, you should also see CanadianAccounting listed under the Interfaces node.
	__12.  Open USAccounting and CanadianAccounting.  
	__13.  Expand the Web Service Ports folder.  
	A Web Service Port node is a logical representation of the physical WSDL file.  Had we broken the WSDL file up into two files, an abstract WSDL file containing the types, message, and portType elements and a concrete WSDL file containing the binding and service elements, the Web Service Port node would have pointed to the concrete WSDL file.
	__14.  Open USAccounting and CanadianAccounting ports. 
	__15.  Close all the open files.
	__16.  Last but not least, expand the Data Types node.  These files correspond with the complex types defined within the two WSDL files.  
	A Data Type node shows all the XML schema elements used by this module.  When you import the WSDL of a web service, system also imports all the XML data types. These data types may be defined directly within the WSDL or in separate XML schema document (XSD) files. 
	__17.  Open the USAddress and CanadianAddress data types.  
	__18.  Close all the open files.

	Part 3 -  Create SCA Imports for Web Services
	__1.  Open the Assembly Diagram.  To do so, double click on the Assembly Diagram node in the Business Integration view.
	__2.  Create an import component for the USAccounting web service by dragging  USAccounting under Web Service Ports onto the Assembly Diagram.
	__3.  The Select a Transport Protocol window will open, select SOAP1.1/HTTP option.
	__4.  Click Finish.
	__5.  An import named USAccountingImport1 will appear in the assembly diagram.
	__6.  Right click on the import and select Rename.  Change the name to USAccounting
	__7.  Likewise, create an import component for the CanadianAccounting web service by dragging the CanadianAccounting node under Web Service Ports onto the Assembly Diagram.
	__8.  Select SOAP1.1/HTTP option.
	__9.  Click Finish.
	__10.  Rename the import as CanadianAccounting
	__11.  Save the assembly diagram.
	__12.  Click in the Problems view and make sure there are no errors before proceeding to the next part.

	Part 4 -  Unit Test the Web Services
	__1.  Start the Server.
	__2.  Right click the server and select Add and Remove Projects.
	__3.  Click Add All.
	__4.  Click Finish. Wait until finish publishing.
	__5.  In the Servers view, verify that all projects are Synchronized.
	__6.  In the Assembly Diagram, right click on USAccounting and select Test Component.
	In order to unit test the registerClient operation, we need to provide some USAddress data, which corresponds with the client variable.
	__7.  Double click on the Value field next to city.
	__8.  A text field will pop up.  Enter the following value:  New York
	__9.  Enter the remaining client data as follows:  
	Your Initial request parameters should look as follows:
	__10.  Now that you've input your data, we can proceed with the test.  Under the Events heading, click the green arrow (Continue button).
	__11.  In the Deployment Location dialog, make sure that WebSphere Process Server v7.0 is selected.  
	__12.  Check the box Use this location as the default and do not ask again, so you won't be prompted for the deployment location again.
	__13.  Click Finish.
	__14.  A User Login dialog will pop up challenging you for a user id and password. admin should already be filled in for both the User ID and Password fields.  If not, go ahead and input the value.  Also, check Use the authentication settings in the preference and never ask again so you're not prompted for your credentials again.
	__15.  Click OK.
	After the dialog disappears, you will see the test run.
	__16.  Look in the Console view.  You should see the following messages, which indicates that the web service was really invoked and did what it was supposed to do.
	
	__17.  Now we will repeat the process for the Canadian Accounting web service.  Click the Invoke icon under the Events heading to run another test.
	__18.  Select CanadianAccounting from the Component drop-down.  The Interface and Operation drop-downs will automatically be updated to reflect the CanadianAccounting interface and addCustomer operation, respectively.
	__19.  In order to unit test the customer operation, we need to provide some CanadianAddress data, which corresponds with the customer variable.  
	__20.  Enter the following customer data:  
	__21.  Now that you've input your data, we can proceed with the test.  Under the Events heading, click the Continue button.
	__22.  Look in the Console view.  You should see the following messages, which indicates that the web service was really invoked and did what it was supposed to do.
	__23.  Close the test editor.  Don't save your changes.
	__24.  Stop the server.
	__25.  Close any open files.  

	Part 5 -  Review

	Lab 3 -  Create Business Objects
	Part 1 -  Create a Default Namespace
	__1.  Select Window->Preferences from the menu bar.
	__2.  In the left pane, expand Business Integration and select Default Namespace.
	__3.  In the right pane, click the New button to create a new default namespace.
	__4.  Type Corporate Default in the Name field.
	__5.  Enter www.webagesolutions.com in the Pattern field.
	__6.  Click OK to create the namespace.
	__7.  Click OK to close the preferences.

	Part 2 -  Create a Business Integration Module
	__1.  Select File > New > Mediation Module from the menu bar.  
	__2.  Enter CustomerOrder for the Module Name.
	__3.  Select WebSphere Process Server 7.0 as Target runtime environment.
	__4.  Uncheck Create mediation component.
	__5.  Uncheck Open module assembly diagram.
	__6.  Click Finish.  The CustomerOrder project should appear in the Business Integration view.

	Part 3 -  Create the Customer Business Object 
	__1.  In the Business Integration view, under the CustomerOrder module, right click Data Types and select New > Business Object.
	__2.  Notice that the Namespace field is pre-populated with the default you set earlier:  http://www.webagesolutions.com.  
	__3.  Enter Customer in the Name field.
	__4.  Click Finish.
	__5.   Now let's define our Customer business object.  Select the Customer object.  Then click the field icon (F in a blue circle) to add a field to the business object.  A field called field1 should be added to the Customer object of type string.
	__6.  Click on field1 and rename it as customerId
	__7.  Click on string and select int from the drop-down.
	__8.  Using the procedure above, add the following fields:
	__9.  Save your changes.
	__10.  Since the customerId uniquely identifies a customer, it should be required.  To specify this, right click on customerId and select Show in > Properties view from the menu.  
	__11.  The Properties view should appear at the bottom of WID.  Change the Minimum occurrences to 1.
	__12.  Click on the customerType field in the Business Object Editor.  
	__13.  In the Properties view, check the Only permit certain values checkbox.  (you may need to scroll down)
	__14.  Select the Enumerations radio button.
	__15.  Click the Add button.
	__16.  Enter silver in the Add Enumeration dialog.
	__17.  Click OK.
	__18.  In the same way add gold and platinum in the list.
	__19.  You can also specify a regular expression pattern that a field must match when being input.  The homePhone and workPhone fields should be entered in the format: xxx-xxx-xxxx.  To accomplish this, click on the homePhone field in the Business Object Editor.  
	__20.  In the Properties view, check the Only permit certain values checkbox.  
	__21.  Then, click the Patterns radio button.
	__22.  Click Add.
	__23.  In the Regular Expression Wizard dialog, select Digit ( \d ) from the Token contents drop-down.  
	__24.  Then, click the Repeat radio button and type 3 in the text field to the right of it.  
	__25.  Then click the Add button.  
	The Current Regular Expression field should now show \d{3} which means the user needs to type in 3 digits for the phone number.  We're not done yet.
	__26.  Type a dash (-) next to \d{3} in the Current regular expression field.
	__27.  Click the Add button again to append \d{3} to the regular expression. 
	__28.  Type another dash (-) next to \d{3}-\d{3} in the Current regular expression field.  
	__29.  Change the Repeat value from 3 to 4 and click Add again.  Voila!  Your regular expression is complete.
	__30.  WID also allows you test your regular expression to make sure you input it correctly.  To do so, click the Next button.  
	__31.  In the Sample text field, enter 123-456-7890  
	__32.  The message The text matches the regular expression should appear at the top of the dialog.
	__33.  Click Finish.
	__34.  Repeat the process for the workPhone. 
	__35.  Save your changes.
	__36.  Close the file.

	Part 4 -  Create the Address Business Object
	Up until this point, you've created fields having only simple data types – string, integer, boolean and so on.  It's also possible to create fields having complex data types.  The complex data types are themselves other business objects.  For example, an Order, which you will be creating shortly, has a shipping address and a billing address.  Since an Order has multiple addresses rather than just one, it's recommended to create another business object called Address, instead of simply adding address fields to the Order business object.  In this part, you'll create the Address business object.  
	__1.  In the Business Integration view, right click on Data Types under CustomerOrder and select New > Business Object.
	__2.  Type Address in the Name field.  
	__3.  Click Finish.
	__4.  Enter the following fields:
	__5.  Save your changes.
	__6.  Close the file.

	Part 5 -  Create the Order and OrderItem Business Objects
	__1.  In the Business Integration view, right click on Data Types under CustomerOrder and select New > Business Object.
	__2.  Type Order in the Name field.  
	__3.  Click Finish.
	__4.  The Order business object will be created and should automatically be opened inside the Business Object Editor.  Enter the following fields:
	__5.  When specifying the Address type, you'll need to scroll to the bottom of the type drop-down, since that's where all business objects are located.
	__6.  Click on the plus (+) sign next to Address to expand it and see its fields.  Use the bottom arrow to scroll through its fields.  
	__7.  Return to the business object editor showing the Order business object if you are not there already.  
	__8.  Add another field named orderItems
	__9.  This time, when specifying the data type, click the New... option in the drop-down.  It's located at the top of the drop-down.
	__10.  In the New Business Object dialog, type OrderItem in the Name field and click Finish.  
	__11.  For the OrderItem business object, enter the following fields:
	__12.  Your business object should look as follows:
	__13.  Save your changes and close the OrderItem file.
	__14.  Click on the orderItems field.  
	__15.  In the Properties view, from the drop-down change the Maximum occurrences  to unbounded.
	__16.  Click anywhere in the editor.
	__17.  Save your changes and close the file.
	__18.  Last but not least, open the Customer business object.
	__19.  Add a field to the Customer business object named orders of type Order.  You may need to click the Customer business object in the editor to select it first.
	__20.  Change the Maximum occurrences  to unbounded to declare the field as an array.
	__21.  Save your changes.
	__22.  It's also possible to display the Customer business object in a tabular format.  To do so, click on the icon on the far right of the editor toolbar.
	__23.  Now you're in the table view.  In addition to displaying the field names and data types for the business object and its children, the table view displays their default values (if any) and multiplicity (number of minimum occurrences and maximum occurrences).   
	__24.  Switch back to the diagram view by clicking on the icon on the far right of the editor toolbar.  Notice the icon has changed.
	__25.  Close all open files.  Save if there are any unsaved changes.

	Part 6 -  View the Physical Files
	__1.  In the Business Integration view, right click on the CustomerOrder module and select Show Files.
	__2.  WID will open the Physical Resources view and stack it on top of the Business Integration view.  Notice that the business objects you created are located directly underneath the CustomerOrder project and correspond with XSDs (can tell based on the file extension).
	__3.  Double click on Customer.xsd.  Notice that WID still opens it with the Business Object Editor.  
	__4.  To change this behavior, close the file.  Then right click on it and select Open With->Text Editor from the menu.  WID will now open it with a text editor so you can view the actual XML.  
	__5.  Close the file.
	__6.  The Customer.xsd file will automatically be opened with the text editor from this point forward unless you change it back to open with the Business Object Editor.  To change this, right click on the file and select Open With > Business Object Editor.  
	__7.  Close the Business Object Editor.  
	__8.  Switch back to the Business Integration view.

	Part 7 -  Review

	Lab 4 -  Basic Mediation Flow Development
	Part 1 -  Create a Mediation Module
	__1.  From the menubar, select File > New > Mediation Module.
	__2.  Enter the following values:
	__3.  Click Finish.
	__4.  WID will create the mediation module. In the Business Integration view, under the Projects section, verify that SimpleModule is shown.

	Part 2 -  Study the Project Structure
	__1.  From the menubar, select Window > Open Perspective > Other.
	__2.  Select Java EE.
	__3.  Click OK.
	__4.  Notice, the projects have been created for SimpleModule:
	__5.  Close the Java EE perspective by selecting Window > Close Perspective.

	Part 3 -  Create a Service Interface
	__1.  Expand SimpleModule  project.
	__2.  Right click Interfaces and select New > Interface.
	__3.  Enter Greeting as the name of the interface.
	__4.  Click Finish.
	__5.  In the editor, click the Add Request Response Operation toolbar icon to add a new operation.
	__6.  Change the name of the operation to sayHello
	__7.  Change the name of the input parameter to name 
	__8.  Change the name of the output parameter to message
	__9.  Save and close the editor.

	Part 4 -  Create the Mediation Flow
	__1.  Right click Integration Logic and select New > Mediation Flow.
	__2.  Enter GreeterFlow as the name.
	__3.  Click Next.
	__4.  Click the Add button for Sources interfaces.
	__5.  The Greeting interface should be selected, just click OK.
	__6.  Click the Add button for Target references.
	__7.  The Greeting interface should be selected, just click OK.
	__8.  Click Finish. WID will create the mediation flow and open it in the editor.

	Part 5 -  Design the Mediation Flow
	__1.  At the top of the editor, you will see two interfaces.
	__2.  Click over the sayHello operation of the source interface.  
	__3.  The Select a Mediation Flow Template dialog will open, click the Service Integration link.
	__4.  Click Add.
	__5.  The Select Reference Operation window will open showing the sayHello Target operation of GreetingPartner, click OK.
	__6.  Click OK.
	__7.  Connect the output terminal of sayHello of Greeting (the source interface) to the input terminal of sayHello of GreetingPartner (target interface).
	__8.  Click the Response tab to open the response flow design.
	__9.  Connect the output terminal of sayHello of GreetingPartner (the target interface) to the input terminal of sayHello of Greeting.  Make sure you select the pointed output terminal of the GreetingPartner and not the rectangular fail terminal.
	__10.  Click the Overview tab and check that the source and target are connected now.
	__11.  Save and close the editor.
	__12.  Open the Problems view and expand Warnings. You should notice a warning about "A direct connection exists from the mediation input to output." This is fine for our very simple mediation flow.

	Part 6 -  Create Service Provider
	__1.  Double click Assembly Diagram to open it.
	__2.  Right click the white area of the editor and select Add > Java.
	__3.  Change the name of the Java component to GreeterBean
	__4.  Right click the component and select Add > Interface.
	__5.  Select the Greeting interface and click OK.
	__6.  Right click the component again and select Generate Implementation.
	__7.  Click New Package.
	__8.  Enter com.webage.greet as the package name.
	__9.  Click OK to create the package.
	__10.  Click OK to select the new package for the implementation.
	__11.  Change the implementation of the sayHello method as follows.
	__12.  Save all files (Control+Shift+S).
	__13.  Close the Java editor.

	Part 7 -  Wire the Components
	__1.  Make sure that the assembly diagram is still open. If not open it.
	__2.  Drag the GreeterFlow mediation flow on to the diagram.
	__3.  Hover the mouse over the reference partner of the mediation flow and a lollipop will open up.
	__4.  Drag the lollipop and drop it over the interface of the Java implementation. This will connect the two as shown below.
	__5.  Save changes.

	Part 8 -  Deploy the Application to Server
	__1.  Open the Servers view.
	__2.  Start the server. Wait until the status changes to Started.
	__3.  Right click the server again and select Add and Remove Projects...
	__4.  First we will undeploy all the projects running there, since this will help to start and publish faster. Click Remove All.
	__5.  Select SimpleModuleApp and click Add.
	__6.  Click Finish.
	__7.  WID will start publishing the application files. Wait for the status of the server to change to Synchronized.

	Part 9 -  Test the Application
	__1.  Open the assembly diagram if it is not open.
	__2.  Right click any white area of the assembly diagram and select Test Module.
	__3.  Verify the Component is set to GreeterFlow. That means, the test client will invoke the operations of the mediation flow.  It may default to GreeterBean, but this would not test the whole flow.
	__4.  Verify that the sayHello operation is selected since that is the only operation available from the interface.
	__5.  In the Initial request parameters table, set the value of the name parameter to something.
	__6.  Under Events click the  Continue toolbar button to invoke the operation.
	__7.  In the Deployment Location dialog, select WebSphere Process Server v7.0 at localhost. 
	__8.  Also, check Use this as the default and do not ask again.
	__9.  Click Finish.
	__10.  If asked, check the checkbox to always use the same authentication settings and click OK in the User Login dialog. Security is enabled for the server. This is where the administrative user ID and password is entered. Without a valid password, publishing will fail.
	__11.  After the test ends, the Return parameters table will show the reply.
	__12.  Open the Server Logs view. At the very bottom, the output from the Java component will be shown.
	__13.  Close the test page without saving.

	Part 10 -  Review Build Activities
	__1.  Open the Build Activities view.
	__2.  Close all open files. (Ctrl+Shift+W)
	__3.  Stop the server.

	Part 11 -  Review

	Lab 5 -  Using Mediation Primitives
	Part 1 -  Add Primitive to Request Flow
	__1.  Start the Server.
	__2.  Expand SimpleModule > Integration Logic > Mediation Flows.
	__3.  Open GreeterFlow mediation flow in the editor by double clicking on it.
	__4.  Click the sayHello operation in the source interface. This will open the Request flow tab in the editor.
	__5.  In the Request flow, select the connection between  Greeting / sayHello and GreetingPartner / sayHello.
	__6.  Press the delete key to remove the connection.
	__7.  On the left hand side of the editor, expand the Tracing section.
	__8.  Drag and drop the Message Logger primitive on the editor.
	__9.  Connect the output terminal of Greeting  / sayHello to the input terminal of MessageLogger1.
	__10.  Connect the output terminal of MessageLogger1 to the input terminal of GreetingPartner  / sayHello.
	__11.  Select MessageLogger1.
	__12.  Open the Properties view.
	__13.  Select the Details tab.
	__14.  Change the Logging type from Database to Custom.

	Part 2 -  Add Primitive to Response Flow
	__1.  Click the Response tab to switch to the response flow.
	__2.  Follow the steps in the previous part to insert a logger primitive in the flow.
	__3.  Change the logging type of the logger to custom.
	__4.  Save the mediation flow.

	Part 3 -  Publish Changes
	__1.  Open the Build Activities tab.
	__2.  Click Update Running Servers.
	__3.  Make sure WebSphere Process Server v7.0 is selected.
	__4.  Check the 'Do not show this dialog again' box.
	__5.  Press the Publish button.

	Part 4 -  Test
	__1.  Open the Assembly Diagram.
	__2.  Right click the white area and select Test Module.
	__3.  Set the component to GreeterFlow.  It may default to GreeterBean, but this would not test the whole flow.
	__4.  Enter a name in the input table.
	__5.  Click the Continue toolbar button under Events.
	__6.  Close the test without saving it.
	__7.  Open a command prompt window.
	__8.  Enter the following command:
	__9.  List all message log files:
	__10.  You should see MessageLog.log that contains request and response messages.
	__11.  View the request message as follows.
	__12.  There locate the request and response messages as shown below:
	__13.  Close the Command prompt window.
	__14.  Back in WID, close all open files.

	Part 5 -  Review

	Lab 6 -  Data Translation and Routing
	Part 1 -  Complete the Data Model
	__1.  In the Business Integration view, expand AccountRouter.
	__2.  Open CanadianAddress and USAddress under Data Types.  Observe how the two business objects differ in terms of structure.  These business objects are application specific.  A business object which is application specific is referred to as an Application Specific Business Object (ASBO).
	__3.  Right click on Data Types and select New->Business Object.
	__4.  Type AddressGBO in the Name field.
	__5.  Click Finish to create the business object.
	__6.  In the Business Object Editor, add the following fields:
	__7.  Your business object should look as follows:
	__8.  Save your  changes.
	__9.  Close all files.

	Part 2 -  Create a Generic Interface
	__1.  In the Business Integration view, expand AccountRouter->Interfaces. You will see the two interfaces you imported in an earlier lab.
	__2.  Double click the CanadianAccounting interface. Notice that there is one method called addCustomer that takes a CanadianAddress as input.
	__3.  Similarly, open the USAccounting interface. It has one operation called registerClient that takes a USAddress as input.
	__4.  Now, let's create the generic interface.  Right click on Interfaces and select New ->Interface.
	__5.  Type GenericAccounting in the Name field.
	__6.  Uncheck Default and change the namespace to http://www.webagesolutions.com
	__7.  Click Finish to create the interface. 
	__8.  To create the operation, click the Add One Way Operation icon in the toolbar.
	__9.  Click on operation1 and rename it addCustomerToSystem
	__10.  Click on input1 and rename it customer
	__11.  Click on string and select AddressGBO from the drop-down.
	__12.  Your interface should look as follows:
	__13.  Save your  changes.
	__14.  Close all files.

	Part 3 -  Create a Business Object Map
	__1.  In the Business Integration view under AccountRouter, right click on Transformations and select New->Data Map.
	__2.  Select Business object map and click Next.
	__3.  Enter  AddressGBOToCanadianAddress as name.
	__4.  Click Next.
	__5.  Click the Add button next to the Input business objects list.  
	__6.  Select AddressGBO and click OK.
	__7.  Click the Add button next to Output business objects list.  
	__8.  Select CanadianAddress and click OK.
	__9.  Click Finish to create the business object map.
	__10.  WID will create the business object map and open it inside the Business Object Map Editor.
	Ignore the error message (red X) for now.  It will disappear after we finish the mapping.
	__11.  Map the name field of the AddressGBO business object to the name field of the CanadianAddress business object.  To do so, mouse over the name field of AddressGBO.  When the orange lollipop appears, click on  it.  A line will appear.  Drag the line to the name field of CanadianAddress and release the mouse button.
	__12.  Likewise, map the following fields:
	__13.  Your business object map should look as follows:
	Notice that the Move transform was used for all the mappings by default, which is fine since we simply want to copy the data from the source field to the target field.
	__14.  To do a Join, connect streetAddress2 to the Move transform for streetAddress1.  This should be the 2 Move box.  Notice that WID automatically changed the transformation type from Move to Join.  Joins are used when you map two or more fields to a single field of type string. A space is used as the delimiter by default.  
	__15.  To view more details on the join, right click on the Join transform and select show in > Properties view. 
	__16.  Then click on the Details tab.  Notice the following:
	__17.  Save your changes.  There should be no errors or warnings in the editor.
	__18.  Close the editor.
	__19.  Right click on Transformations and select New -> Data Map.
	__20.  Select Business object map and click Next.
	__21.  Enter AddressGBOToUSAddress as name.
	__22.  Click Next.
	__23.  Click the Add button next to Input business object.  
	__24.  Select AddressGBO and click OK.
	__25.  Click the Add button next to Output business object.  
	__26.  Select USAddress and click OK.
	__27.  Click Finish to create the business object map.
	__28.  To perform an automatic mapping of similar fields, right click inside the editor and select Map similar fields. 
	There is also a button in the toolbar for mapping similar fields.
	The following procedure is used for automatic mapping of similar fields:
	__29.  In the Automatic Mapping of Similar Fields dialog, click OK.
	All of the fields except for streetAddress2 should have automatically been mapped.  Pretty cool!
	__30.  Connect the streetAddress2 field to to the Move transform for streetAddress1.  This should be the 5 Move box.  The transform type should change to a Join.
	__31.  To verify that you've mapped to all the fields in the USAddress business object, click the Show untransformed fields button in the toolbar.
	Notice that there are no fields listed in the USAddress business object.  That means you mapped them all.
	__32.  To view all the transformed fields, click the Show transformed fields button.
	__33.  Save your changes.  There should be no errors now.
	__34.  Close the editor.

	Part 4 -  Create a Mediation Flow with Content Based Routing
	__1.  Right click AccountRouter and select New ->Mediation Flow.
	__2.  In the New Mediation Flow dialog, type AccountingMediation in the Name field.
	__3.  Click Next.
	__4.  Click the Add button next to Source interfaces.  
	__5.  Select GenericAccounting and click OK.  This is the interface the mediation flow will expose to a client.
	__6.  Click the Add button next to Target references.  
	__7.  Select CanadianAccounting and click OK.  
	__8.  Click the Add button next to Target references again.  
	__9.  Select USAccounting and click OK.  
	__10.  Click Finish to create the mediation flow.
	WID will create the mediation flow and open it in the Mediation Flow Editor. In the top pane of the editor, the source interface is shown on the left side and the targets on the right side.
	Now we must map the GenericAccounting interface to the CanadianAccounting interface and to the USAccounting interface.  A source operation can be connected to one or more target operations.  The source operation sends the message and one of the target operations receives it.
	__11.  Click on addCustomerToSystem.
	__12.  In the Select a Mediation Flow Template dialog, select Service Integration.
	__13.  Click Add.
	__14.  Select CanadianAccountingPartner as Reference, the Target will change to addCustomer. Then click OK.
	__15.  Click Add again.
	__16.  Select USAccountingPartner as Reference, the Target will change to registerClient. Then click OK.
	__17.  Verify you have both references. Then click OK.
	__18.  Click the Overview tab. You will see the operation connection updated.
	__19.  Go back to the Request tab.
	__20.  Click the Routing folder in the Palette.  
	__21.  Click the MessageFilter icon and add it to the flow by clicking on the canvas in between the input and output nodes.
	__22.  Rename the filter as CountryFilter
	__23.  Connect the Input node to the input terminal of CountryFilter.
	__24.  Right click on CountryFilter and select Show in > Properties view.
	__25.  In the Properties view, click on the Terminal tab.  
	Observe that a Message Filter primitive has a default and match1 output terminal and a fail terminal. The input message is sent to the default terminal if it doesn't meet one of the XPath expressions (conditions) that you define for the filter.  The input message is sent to the fail terminal if an exception occurs while processing the message.
	We need to add two output terminals to the filter, one for the USAccounting system and one for the CanadianAccounting system.  We will then define the XPath expressions that determine which output terminal the input message is sent to based on the value of the country.
	__26.  Right click on match1 and select delete. We will create all output terminal from scratch.
	__27.  Right click on Output terminal in the Properties view and select Add Output Terminal.  
	__28.  Change the Terminal name to toCanada
	__29.  Click OK.
	__30.  Repeat the process above.  This time name the terminal toUS
	__31.  There should now be three output terminals listed in the Properties view and inside the Mediation Flow Editor.
	__32.  Save your changes.
	Now that we've defined the output terminals, let's define the XPath expressions.
	__33.  Select the CountryFilter object and click on the Details tab in the Properties view.  
	__34.  Click the Add button next to Filters to define the first condition.
	__35.  Click The Edit button.
	__36.  Under the Data Types Viewer heading, expand Data Types.
	ServiceMessageObject will be listed.  The messages that mediation primitives process are known as Service Message Objects (SMOs).  They are enhanced Service Data Objects (SDOs).  A SMO consists of headers, a body (a.k.a. message payload), and context information. 
	__37.  Expand ServiceMessageObject > body : addCustomerToSystemRequestMsg > addCustomerToSystem > customer: AddressGBO and select country. 
	__38.  In the Add and optional condition, leave = selected as Operator and enter Canada as Value.
	__39.  Click OK. 
	__40.  In the Add/Edit properties window the Pattern field will show the Pattern that you constructed.
	__41.  Make sure select toCanada is selected for the Terminal name.  
	__42.  Click Finish.
	In XPath, if the input message contained a country node that equaled "Canada", the node would be selected.  From a Message Filter standpoint, the XPath expression is used as a true/false condition.  If the condition evaluates to true, the input message will be propagated to the toCanada output terminal.
	__43.  Click the Add button again to define a second condition.
	__44.  Either use the Simple XPath Expression Builder or type the following value inside the Pattern field:
	__45.  Select toUS for the Terminal name. 
	__46.  Click Finish.  
	__47.  Save your changes.
	There should be no errors in your mediation flow.

	Part 5 -  Add Business Object Mapping to Mediation Flow
	In this part, you will complete the mediation flow by performing a data transformation.  Before the mediation flow can invoke the proper service, the AddressGBO passed to the addCustomerToSystem operation needs to be transformed to either a USAddress or a CanadianAddress. That's where the two business object maps you created earlier come into play.  How do these business object maps get invoked?  Mediation flows provide a Business Object Map primitive to do so.  However, we need to provide a little "glue", in the form of two higher-level business object maps to invoke the existing business object maps.  The top level element for the input of an operation has the same name as the invoked operation. For example, <addCustomerToSystem>, <addCustomer> and <registerClient>. We have not built a map for these elements. We have only mapped the address objects. We will take care of this now.
	__1.  Expand the Transformation folder in the Palette, click on the Business Object Map primitive, and add it to the flow.
	__2.  Rename BOMapper1 to GBO_To_Canada
	__3.  Connect the toCanada terminal of CountryFilter to the input terminal of GBO_To_Canada.  You'll need to mouse over the output terminals to see which one is named toCanada.
	__4.  Connect the out terminal of GBO_To_Canada to CanadianAccountingPartner.
	__5.  Right click on the diagram and select Automatic Layout.
	__6.  Likewise, add another Business Object Map primitive to the canvas.
	__7.  Rename the new Business Object Map as GBO_To_US
	__8.  Connect the toUS terminal of CountryFilter to the input terminal of GBO_To_US.
	__9.  Connect the out terminal of GBO_To_US to USAccountingPartner.
	__10.  Right click on the diagram and select Automatic Layout.
	__11.  Save your changes.  
	__12.  Click on GBO_To_Canada, select the  Properties view and click the Details tab.
	__13.  Specify the Mapping file that's used by the Business Object Map primitive by clicking the Browse... button.  
	__14.  Notice that no mapping files are available, despite the fact that we defined two business object maps. 
	This is because we are lacking a higher-level map which maps that map the elements containing the operation names.  We must create this map.
	__15.  Click OK.
	__16.  In the Properties view, click the New... button next to Mapping File.
	__17.  In the New BO Map dialog, type AddCustomerToSystemToAddCustomer in the Name field.  The name includes the names of the source and target operations.
	__18.  Click Finish to create the business object map.
	__19.  Expand the source and target business objects.  
	Each input message contains an element which corresponds with the operation name (addCustomerToSystem and addCustomer), due to the fact that we're using the document/literal wrapped style.  This element in turn contains an element corresponding with one of the business objects you defined earlier (customer of type AddressGBO and customer of type CanadianAddress).
	__20.  Map the source customer element to the target customer element.  
	__21.  Click the 1 Submap and select the Properties view.
	__22.  Click the Details tab.
	__23.  Select AddressGBOToCanadianAddress from the Business object map drop-down, which corresponds with one of the maps you created earlier.
	Note that instead of using a submap, we could have mapped the individual fields of the two customer elements.  Then we would have had a single map and not two maps.  However, submaps, which employ a child business object map, provide better re usability.  Imagine that our interfaces had more than one operation having a parameter of type AddressGBO and CanadianAddress.  In this case, we could reuse the AddressGBOToCanadianAddress mapping inside each high-level map instead of having to repeat the mapping for each operation.
	__24.  Save your changes to the Business Object Map Editor.  
	__25.  Close the Business Object Map Editor.
	__26.  In the Mediation Flow Editor, click on GBO_To_US, select the Properties view and click the Details tab.
	__27.  In the Properties view, click the New... button next to Mapping File.
	__28.  In the New BO Map dialog, type AddCustomerToSystemToRegisterClient in the Name field.  The name corresponds with the names of the source and target operations.
	__29.  Click Finish to create the business object map.
	__30.  The source business object corresponds with the addCustomerToSystemRequestMsg element and the target business object corresponds with the registerClientRequest element, which are defined in the GenericAccounting and USAccounting interfaces (WSDL files), respectively as input messages for the operations.
	__31.  Expand the source and target business objects.  
	__32.  Map the source customer element to the target client element.  
	__33.  Click 1 Submap, select the Properties view and click the Details tab.
	__34.  Select AddressGBOToUSAddress from the Business object map drop-down, which corresponds with one of the maps you created earlier.
	__35.  Save your changes to the Business Object Map Editor.  There should be no errors or warnings in the editor.
	__36.  Close the Business Object Map Editor.
	__37.  Save your changes in the Mediation Flow Editor.  There should be no errors or warnings in the editor.
	__38.  Close the Mediation Flow Editor.

	Part 6 -  Assemble the Components
	__1.  Open the Assembly Diagram for the AccountRouter project. 
	__2.  In the Business Integration view, expand Integration Logic->Mediation Flows.  
	__3.  Drag and drop AccountingMediation onto the assembly diagram at the left of the objects.
	__4.  Wire the CanadianAccountingPartner reference for the AccountingMediation component to the CanadianAccounting import.
	Mouse over the reference icon (1..1) to see the name of the reference.
	__5.  Wire the USAccountingPartner reference for the AccountingMediation component to the USAccounting import.
	__6.  Create an export for the AccountingMediation component by right clicking on AccountingMediation and selecting Generate Export->Web Service Binding. 
	__7.  Select SOAP1.1/HTTP from the Transport Selection dialog.
	__8.  Click Finish. 
	__9.  Right click on the export and select Refactor->Rename.  
	__10.  Click OK to save the changes.
	__11.  Change the name to AccountingMediationExport 
	__12.  Click Refactor.
	__13.  Save your changes.  There should be no errors or warnings in the editor. 
	__14.  Close all files.

	Part 7 -  Build a Client
	__1.   Select File->New->Project from the menu bar.
	__2.  Scroll down, expand the Web folder.
	__3.  Select Dynamic Web Project and click Next.
	__4.  In the Project name field, type OnlineOrderWeb
	__5.  In the EAR Project Name field, type OnlineOrderApp
	__6.  Click Finish to create the dynamic web project (OnlineOrderWeb) and enterprise application project (OnlineOrderApp).
	__7.  Click Yes when asked to switch to the Web perspective.
	__8.  To create the web service proxy, expand AccountRouter in the Enterprise Explorer view.  
	__9.  Right click on AccountingMediationExport_GenericAccountingHttp_Service.wsdl and select Web Services->Generate Client.
	__10.  Make sure the Service Definition is set to /AccountRouter/AccountingMediationExport_GenericAccountingHttp_Service.wsdl
	__11.  Click the Client project: AccountRouter link.  
	__12.  In the Specify Client Project Settings dialog, select OnlineOrderWeb from the Client project drop-down.
	__13.  Click OK.
	__14.  Click Next.
	__15.  In the Web Service Proxy Page, leave the defaults and click Finish.
	__16.  In the Warning dialog, click Yes All to enable automatic file overwriting.
	The web service proxy and its associated classes will be created inside the src folder of the OnlineOrderWeb project.  
	__17.  In the Enterprise Explorer view, expand OnlineOrderWeb > Java Resources  > src > com.webagesolutions.www.  
	__18.  Open AddressGBO.java.  
	__19.  Open GenericAccounting.java.  
	This interface is also known as the Service Endpoint Interface (SEI) in JAX-RPC terms. Whenever generating a client for a web service, a SEI gets generated.  
	JAX-RPC provides a high-level programming API for rapidly developing Java-based web services and clients.
	__20.  Open GenericAccountingProxy.java.  
	__21.  First, create a package for the Servlet by right clicking on src in the same project and selecting New > Package. 
	__22.  Type com.webage.servlets in the Name field.
	__23.  Click Finish.  
	__24.  Open a file explorer, locate C:\LabFiles\Register.java right click on it and select  Copy, then inside WID paste the class in the new package.
	__25.  In the same way copy C:\LabFiles\register.jsp to the WebContent folder of OnlineOrderWeb.
	__26.  In the same way copy C:\LabFiles\register_success.jsp to the WebContent folder of OnlineOrderWeb.
	__27.  Expand OnlineOrderWeb > WebContent > WEB-INF.
	__28.  Open the web deployment descriptor by double clicking on the web.xml file.
	__29.  Click Add.
	__30.  Select Servlet and click OK.
	__31.  Change the Servlet name and Display name to Register
	__32.  Click OK.
	__33.  Now select Servlet Class. 
	__34.  Click the Browse button at the top right.
	__35.  Enter Register and select Register – com.webage.servlets – OnlineOrderWeb/src from the list.
	__36.  Click OK.
	__37.  Verify your settings.
	__38.  Select Web Application and click Add.
	__39.  Select Servlet Mapping and click OK.
	__40.  From the drop-down, select Register as Servlet Name.
	__41.  Click Add next to URL Pattern.
	__42.  Change the URL to /Register
	__43.  Save the file.
	__44.  Close all open editors.
	__45.  Verify there are no errors in the Problems view.
	__46.  Open register.jsp.  It contains a form which submits a user's address information to the Register servlet.
	__47.  Open register_success.jsp. It simply displays a message thanking the user for registering and indicating the account was created.
	__48.  Open Register.java.  Examine the doPost method.  The following occurs:
	__49.  Close any open files.

	Part 8 -  Test the Mediation Flow
	__1.  Open the Servers view.
	__2.  If it is not running, right click on the server and choose Start to start it. Wait for the server to start. Its status will change to Started.
	__3.  Right click the server again and choose Add and Remove Projects...
	__4.  Add the OnlineOrderApp, AccountRouterApp, USAccountingEAR, and CanadianAccountingEAR projects to the list of Configured projects.
	__5.  Click Finish. 
	__6.  Confirm that all the applications are in a Synchronized state.
	__7.  Right click register.jsp under OnlineOrderWeb > WebContent and select Run as > Run on Server.
	__8.  Leave selected the WebSphere Process Server and check the Always use this server when running this project. 
	__9.  Click Finish. 
	__10.  Enter some kind of input as shown below.  Make sure the country is set to USA.
	__11.  Click Register. 
	__12.  From the menu, select window > Show View > Other. Expand General and select Console, then click OK.
	__13.  Have a look at the log messages in the Console view.  
	__14.  Go back to the registration page and click the Back button.  
	__15.  Enter information and this time select the country to Canada.
	__16.  Click Register.
	__17.  Have a look at the log messages in the Console view. 
	__18.  Close all.
	__19.  Stop the server.

	Part 9 -  Review

	Lab 7 -  Gathering Requirements
	Part 1 -  High Level Problem Statement
	Part 2 -  Setting the Implementation Stages
	Part 3 -  Write Phase I Use Case
	Part 4 -  Where To Go From Here?
	Part 5 -  Review

	Lab 8 -  Design the Business Process Interface
	Part 1 -  Create a Library
	__1.  From the menu bar, select File->New->Other. 
	__2.  Then select Library and click Next.
	__3.  Type ExpenseLibrary in the Library Name field.
	__4.  Click Finish to create the library.  
	__5.  Click Yes to switch perspectives.
	__6.  The library will appear in the Business Integration view like the modules you've created up to this point.  Notice that a library does not contain an Assembly Diagram node.  This is because a library is not allowed to contain service components.

	Part 2 -  Create the Business Objects
	__1.  In the Business Integration view, right click on Data Types, under ExpenseLibrary, and select New->Business Object.
	__2.  Type ExpenseItemGBO in the Name field.
	__3.  Type BusinessObject in the Folder field.  This will create a new folder called BusinessObject if it doesn't already exist.
	__4.  Click Finish to create the business object.
	Up until now, we have not provided any folder names, since WID does a good job of organizing the artifacts in the Business Integration view.  However, if you were to switch to the Physical Resources view, you would see everything is disorganized. Consequently, it's a good idea to create the folders, so that when examining the resulting JAR file, you can tell what is what. 
	You can also view folders in the Business Integration view by clicking on the Show Folders icon.
	__5.  In the Business Object Editor, add the following fields:
	__6.  Your business object should look as follows:
	__7.  Save your  changes.
	__8.  Right click on Data Types, under ExpenseLibrary, and select New->Business Object.
	__9.  Type ExpenseClaimGBO in the Name field.
	__10.  Click the Browse... button next to the Folder field.  
	__11.  Select BusinessObject from the Folder Selection dialog and click OK.
	__12.  Click Finish to create the business object.
	__13.  In the Business Object Editor, add the following fields:
	__14.  Double check that your itemList field is defined as shown below:
	__15.  Your business object should look as follows:
	__16.  Save your changes.
	__17.  Close any open files.

	Part 3 -  Create the Business Process Interface
	__1.  In the Business Integration view, expand ExpenseLibrary.
	__2.  Right click on Interfaces and select New ->Interface.
	__3.  Type ExpenseClaimProcess in the Name field.
	__4.  Type Interface in the Folder field.  This will create a new folder called Interface if it doesn't already exist.
	__5.  Uncheck Default and change the namespace to http://www.webagesolutions.com
	__6.  Click Finish to create the interface.  The interface will be created and should automatically be opened with the Interface Editor.
	__7.  Click the Add One Way Operation icon in the toolbar.
	__8.  Click on operation1 and rename it startProcess
	__9.  Click on input1 and rename it claim
	__10.  Click on string and select ExpenseClaimGBO from the drop-down.
	__11.  Save your changes.
	__12.  Close the file.

	Part 4 -  Review

	Lab 9 -  Create the Expense Claim Business Process
	Part 1 -  Create a Business Integration Module
	__1.  Select File->New->Module from the menu bar.
	__2.  Type ExpensePhase1 in the Module Name field. 
	__3.  Make sure the Open module assembly diagram is not selected.
	__4.  Click Next.
	__5.  Add ExpenseLibrary to the module's dependency list by checking ExpenseLibrary.
	__6.  Click Finish to create the module.
	__7.  Expand ExpensePhase1.
	__8.  Open the Dependency Editor by double clicking on Dependencies.
	__9.  Close the editor.

	Part 2 -  Create the Process
	__1.  Right click ExpensePhase1 and select New->Business Process.
	__2.  Type Process in the Folder field.  This will create a folder named Process.
	__3.  Type ExpenseClaimDev in the Name field.
	__4.  Click Next.
	__5.  In the Select a Business Process Type page, select Microflow, since our process is currently short-running.
	__6.  Click Next.
	__7.  In the Select an Interface page, choose Select an Interface. 
	__8.  Using the Browse button, select the ExpenseClaimProcess interface that we had inspected in an earlier lab.  Notice it comes from the ExpenseLibrary project on which the ExpensePhase1 module is dependent.
	__9.  Click OK.
	__10.  Make sure that the startProcess operation of the selected interface is selected. This is the operation an application will need to call to initiate the business process.
	__11.  Click Finish to create the process. WID will create the process and open it in the Business Process Editor.

	Part 3 -  Inspect the Process
	__1.  Open the ExpenseClaimDev business process if you closed it.
	__2.  In the tray (right side of editor), right click on ExpenseClaimProcess, under Interface Partners, and select Rename. 
	__3.  Change the name to Client
	__4.  Save the changes.
	__5.  Select the claim variable. 
	__6.  In the Properties view, click the Description tab. 
	__7.  Select the Client interface partner. 
	__8.  In the Properties view, note that the interface of this partner is ExpenseClaimProcess.
	__9.  From the diagram, select the Receive activity.
	__10.  In the Properties view, click the Details tab. 

	Part 4 -  Getting the Maximum Expense Limit
	__1.  In the Palette (left side of editor), click the Empty Action icon under Basic Actions. 
	__2.  Then click below the Receive activity on the diagram. Make sure you have a line showing where the action will be added.
	__3.  Click the newly added activity and change its display name to   Get Maximum Limit

	Part 5 -  Build the Rest of the Process
	__1.  Now we will add the choice activity. In the Palette, click the Choice icon under Structures. 
	__2.  Then click below the Get Maximum Limit activity.
	__3.  Change the display name of the choice activity to   Is Expense Within Limit?
	__4.  Each outcome branch of a choice activity is called a case. The system has automatically added a case called Case. Select this case. 
	__5.  In the Properties view, click the Description tab. 
	__6.  Set the display name to Yes and click inside the diagram.
	__7.  Right click the Is Expense Within Limit? and select Add an Otherwise Element. 
	__8.  First we will build the Yes case branch. Click the Empty Action button again that is below Basic Actions and click below the Yes case. Make sure the cursor indicates the action will be added to the 'Case - Yes' before clicking the mouse.
	__9.  Change its display name to   Approve Claim
	__10.  Add another empty action below Approve Claim and call it    Notify Accounting
	__11.  Now we will build the Otherwise case branch. Add an empty action below Otherwise and call it    Reject Claim
	__12.  In the Palette, expand the Faults tab and click the Terminate button. Then click below Reject Claim. The Otherwise branch will now look like this.
	__13.  Save your changes.  One error will show up, since we did not specify a condition yet for the Is Expense Within Limit? choice activity.  We will do this in the  Process Implementation Lab.
	__14.  Close the file.

	Part 6 -  Refine the Data Model
	__1.  Open the ExpenseClaimGBO business object in the ExpenseLibrary project.  
	__2.  Notice that the business object contains the fields employeeId and claimId, which are used for identifying the employee and claim, respectively.
	__3.  Close the file.

	Part 7 -  Review

	Lab 10 -  Identify and Specify Services
	Part 1 -  Make a List of Activities
	__1.  Open the ExpenseClaimDev process in the editor. 
	__2.  Make a list of all activities, excluding the choice. In other words, list all activities that sound like a verb or business task.
	__3.  Verify your list with the solution shown below.
	__4.  Close the file.

	Part 2 -  Group Activities
	Part 3 -  Specify Services
	__1.  First, we will create the interface for the Expense Management System. In the Business Integration view, expand ExpenseLibrary.
	__2.  Right click on Interfaces and select New ->Interface.
	__3.  Browse to the Interface folder. 
	__4.  Type ExpenseManagementSystem in the Name field.
	__5.  Uncheck Default and change the namespace to http://www.webagesolutions.com/external
	__6.  Click Finish to create the interface.  The interface will be created and should automatically be opened with the Interface Editor.
	__7.  Click the Add Request Response Operation icon in the toolbar.
	__8.  Click on operation1 and rename it as getMaximumLimit
	__9.  getMaximumLimit does not require any input.  Select input1.  Right click on it and select Delete. Make sure that you click on the input first before selecting delete or you will delete the entire operation.
	__10.  Click on output1 and rename it as amount
	__11.  Click on string and select double from the drop-down.
	__12.  Click the Add One Way Operation icon in the toolbar.
	__13.  Click on operation1 and rename it as approveClaim
	__14.  Click on input1 and rename it as claim
	__15.  Click on string and select ExpenseClaimGBO from the drop-down.
	__16.  Click the Add One Way Operation icon in the toolbar.
	__17.  Click on operation1 and rename it as rejectClaim
	__18.  Click on input1 and rename it as claim
	__19.  Click on string and select ExpenseClaimGBO from the drop-down.
	__20.  Save your changes.
	__21.  Close the file.
	__22.  Next we will create the interface for the Accounting System. In the Business Integration view, expand ExpenseLibrary.
	__23.  Right click on Interfaces and select New ->Interface.
	__24.  Browse to the Interface folder. 
	__25.  Type AccountingSystem in the Name field.
	__26.  Uncheck Default and change the namespace to http://www.webagesolutions.com/external
	__27.  Click Finish to create the interface.  The interface will be created and should automatically be opened with the Interface Editor.
	__28.  Click the Add One Way Operation icon in the toolbar.
	__29.  Click on operation1 and rename it as payExpenseAmount
	__30.  Click on input1 and rename it as claim
	__31.  Click on string and select ExpenseClaimGBO from the drop-down.
	__32.  Save your changes.
	__33.  Close the file.
	__34.  To display and group your artifacts by namespace, click the Show Namespaces button in the toolbar.
	__35.  To hide the namespaces, click the button (now called Hide Namespaces) again.

	Part 4 -  Merging, Pruning, and Other Refinements
	Part 5 -  Review

	Lab 11 -  Service Design and Implementation
	Part 1 -  Design The Expense Management System Service
	Part 2 -  Design the Accounting System Service
	Part 3 -  Create the Expense Management System Projects
	__1.  Select File->New->Project from the menu bar.
	__2.  Scroll down, expand the Web folder, click Dynamic Web Project, and click Next.
	__3.  In the Project name field, type ClaimWeb
	__4.  In the EAR Project Name field, type ClaimApp
	__5.  Click Finish to create the dynamic web project (ClaimWeb) and enterprise application project (ClaimApp).
	__6.  Click No when asked to switch to the Web perspective.

	Part 4 -  Implement The Expense Management System Service
	__1.  Open the assembly diagram for the ExpensePhase1 module.
	__2.  From ExpenseLibrary, drag the ExpenseManagementSystem interface and drop it on the assembly diagram.
	__3.  Select Import with Web Service Binding.
	__4.  Click OK.
	__5.  Select Generate a new web service definition and implementation.
	__6.  Click OK.
	__7.  Select SOAP1.1/HTTP since this gives us the JAX-WS option.
	__8.  Click Finish. WID will launch the web service wizard.
	__9.  Verify that the top down option is selected. Also, note that the WSDL in Service definition is a temporary one.
	__10.  Set the Service project to ClaimWeb.
	__11.  Click Next.
	__12.  Select Copy WSDL to project.
	__13.  Click Finish.
	__14.  Expand the packages under ClaimWeb > Java Resources > src.
	__15.  Expand ClaimWeb->WebContent->WEB-INF->wsdl->Interface. This folder contains the WSDL files for the service.
	__16.  Save changes in the assembly diagram.

	Part 5 -  Develop Service Code
	__1.  Open ExpenseManagementSystemImport1_ExpenseManagementSystemHttpBindingImpl.java if you closed it.
	__2.  To speed things up, you can copy the code from C:\LabFiles\ ExpenseManagementSystemImport1_ExpenseManagementSystemHttpBindingImpl.java. Or, follow the instructions below to hand code the class.
	__3.  Add these imports.
	__4.  Add a member variable for the logger.
	__5.  Implement the getMaximumLimit method.
	__6.  Add the printClaim utility method that shows the contents of a claim.
	__7.  Implement the approveClaim and rejectClaim methods.
	__8.  Organize Imports.
	__9.  Save your changes.  Make sure there are no compile time errors.
	__10.  Close all open files.

	Part 6 -  Test the Expense Management System Service
	__1.  Start the server if it's not already started.
	__2.  The ClaimApp project should have already been added to the server.  If not, add it.
	__3.  Right click the server and select Publish.
	__4.  Expand ClaimWeb->WebContent->WEB-INF->wsdl->Interface.  
	__5.  Right click ExpensePhase1_ExpenseManagementSystemImport1.wsdl and select Web Services->Test With Web Services Explorer.  
	__6.  In the Operations table, click getMaximumLimit.  
	__7.  getMaximumLimit doesn't require any input parameters, so click Go. 
	__8.  Make sure that the Status pane shows the amount.
	__9.  Now let's test the approveClaim operation.  In the Navigator pane, click the approveClaim link.
	__10.  Enter the following data:
	__11.  Click the Add link next to itemList to add another item.
	__12.  Scroll down and then enter the following data in the new empty fields:
	__13.  Scroll down and click Go.
	__14.  Observe that since the operation is a one-way operation, there is no response displayed in the Status view.  
	__15.  Look in the Console view and you should see the following messages:
	__16.  Finally, let's test the rejectClaim operation.  In the Navigator pane, click the rejectClaim link.
	__17.  Enter the following data:
	__18.  Click the Add link next to itemList to add another item.
	__19.  Enter the following data:
	__20.  Click Go.
	__21.  Observe that since the operation is a one-way operation, there is no response displayed in the Status view.  
	__22.  Look in the Console view and you should see the following messages:
	Congratulations!  Your web service is working as expected.
	__23.  Close the Web Services Explorer.

	Part 7 -  Import the Accounting System Service
	__1.  Select File->Import from the menu bar.
	__2.  Expand Other and select Project Interchange.
	__3.  Click Next.
	__4.  Click the Browse button next to the From zip file field.
	__5.  Navigate to C:\LabFiles\AcmeApp.zip and click Open.
	__6.  Click Select All.
	__7.  Click Finish to import the AcmeApp and AcmeWeb projects.
	__8.  Examine the WSDL file.  To do so, expand AcmeWeb->WebContent->WEB-INF ->wsdl.  
	__9.  Right click on AcmeQuickAccounting.wsdl and select Open With->WSDL Editor.
	__10.  Click on the Design tab.
	__11.  Select Simplified from the View drop-down in the editor.
	__12.  Examine the web service implementation.  To do so, expand AcmeWeb->Java Resources->src->com.acme.  
	__13.  Open AcmeQuickAccountingSOAPImpl.java.
	__14.  Notice the class contains a single method called addNonTaxableBenefit which corresponds with the web service operation.  The method simply logs the input parameters to the server log.
	__15.  Close any open files.

	Part 8 -  Test the Accounting System Service
	__1.  Start the server if it's not already started.
	__2.  Add (deploy) the AcmeApp project to the server.
	__3.  Expand AcmeWeb->WebContent->WEB-INF->wsdl.  
	__4.  Right click AcmeQuickAccounting.wsdl and select Web Services->Test With Web Services Explorer.  
	__5.  In the Operations table, click addNonTaxableBenefit.  
	__6.  Enter the following data:
	__7.  Click Go.
	__8.  Observe that since the operation is a one-way operation, there is no response displayed in the Status view.  
	__9.  Look in the Console view and you should see the following message:
	
	__10.  Close the Web Services Explorer.

	Part 9 -  Review

	Lab 12 -  Process Implementation
	Part 1 -  Create Reference Partners
	__1.  Make sure you are in the Business Integration perspective. 
	__2.  Open the ExpenseClaimDev process under ExpensePhase1 > Integration Logic > Processes.
	__3.  In the tray (right side of the editor), click the green + icon next to Reference Partners.
	__4.  In the Add a Reference Partner dialog, change the name from Partner to expenseSystem
	__5.  Then, select the ExpenseManagementSystem interface and click OK.
	__6.  Verify the expenseSystem reference partner is listed under Reference Partners.
	__7.  Select the expenseSystem reference partner. 
	__8.  In the Properties view, verify the ExpenseManagementSystem interface is listed as the Reference interface.
	__9.  Once again, click the green + icon next to Reference Partners.
	__10.  In the Add a Reference Partner dialog, change the name from Partner to accountingSystem
	__11.  Then, select the AccountingSystem interface and click OK.
	__12.  Verify the accountingSystem reference partner is listed under Reference Partners.
	__13.  Select the accountingSystem reference partner. 
	__14.  In the Properties view, verify the AccountingSystem interface is listed as the Reference interface.
	__15.  Save your changes.

	Part 2 -  Create Invoke Activities
	__1.  Right click the Get Maximum Limit activity and select Change Type->Invoke.  The activity should now have a different icon.
	__2.  Now we will specify the service operation that will be invoked by this activity. Select the Get Maximum Limit activity. 
	__3.  In the Properties view, click the Details tab.
	__4.  Next to Partner click the Browse button. 
	__5.  Select expenseSystem and click OK. 
	__6.  From the Operation drop down, select getMaximumLimit.
	__7.  Now, we will configure a process variable that will save the return data from the getMaximumLimit operation call. Make sure the Use Data Type Variables mapping box is checked.
	__8.  For the amount output of the operation, click the none link. 
	__9.  Click New. 
	__10.  Enter limit as the name of the variable. 
	__11.  Click OK. 
	__12.  WID will automatically create a new process variable called limit of type double. The output of the getMaximumLimit operation will be stored inside this variable.
	__13.  Convert the Approve Claim activity to an Invoke activity. 
	__14.  For the Approve Claim invoke activity, choose the expenseSystem partner and the approveClaim operation.
	__15.  Make sure the Use data type variables mappings is selected. The approveClaim operation takes as input an ExpenseClaimGBO object.
	__16.  For the claim input of the operation, click the none link and choose the claim process variable. 
	__17.  Similarly, convert the Reject Claim empty activity to an Invoke activity. 
	__18.  Choose expenseSystem as the partner and rejectClaim as the operation. 
	__19.  Specify the claim process variable as the input to that operation.
	__20.  Convert the Notify Accounting activity to an Invoke activity. 
	__21.  Choose the accountingSystem partner and the payExpenseAmount operation. 
	__22.  Choose the claim variable as the input.
	__23.  Save your changes.

	Part 3 -  Specify Case Condition
	__1.  Click the Yes case to select it.
	__2.  In the Properties view, select the Details tab.
	__3.  Click the Create a New Condition link.
	__4.  Expand claim : ExpenseClaimGBO process variable and select totalAmount.
	__5.  Choose the < operator.
	__6.  Choose the limit process variable.
	__7.  Save changes and close the file
	__8.  Open the ExpenseClaimDev process again. 
	Our business process implementation is now complete. At this point, there should be no red Xs in any of the activities in the ExpenseClaimDev process.
	__9.  Close all open editors.

	Part 4 -  Review

	Lab 13 -  Create an Interface Map for the Accounting System
	Part 1 -  Import Acme Quick Accounting Web Service Interface
	__1.  Right click on the ExpenseLibrary project and select Import from the menu.  
	__2.  In the Import dialog, expand the Business Integration folder and select WSDL and WSD.
	__3.  Click Next.
	__4.  Select Local WSDL or WSD file, or both and click Next.
	__5.  Click the Browse button and navigate to C:\workspace\AcmeWeb\WebContent\WEB-INF\wsdl.  
	__6.  Click OK.
	__7.  Select the wsdl folder.  Do not check it.
	__8.  Check AcmeQuickAccounting.wsdl in the right pane.
	__9.  Click Finish.
	__10.  Now we need to move the WSDL file to the Interface folder for better organization. Click on the Show Folders icon in the Business Integration view toolbar.
	__11.  Expand Interfaces > Interface and you'll see that AcmeQuickAccounting is not located in the Interface folder.
	__12.  Right click on AcmeQuickAccounting and select Refactor or Analyze Impact  > Move.  
	__13.  In the Multiple Artifact Move dialog, click OK. AcmeQuickAccountingSOAPPort points to the same WSDL file and hence will be moved too.
	__14.  In the Move Artifact dialog, under the second section, expand ExpenseLibrary and select Interface.
	__15.  Click Refactor. 
	__16.  AcmeQuickAccounting should now appear underneath the ExpenseLibrary>Interfaces>Interface  folder.
	__17.  Expand ExpenseLibrary>WebService Ports>Interface. AcmeQuickAccountingSOAPPort should appear underneath the Interface folder.
	__18.  Click on the Hide Folders icon in the Business Integration view toolbar to turn off the folder display.

	Part 2 -  Create an Interface Map
	__1.  Make sure you are in the Business Integration perspective.
	__2.  Inside the ExpensePhase1 project, right click on Transformations and select New ->Interface Map.
	__3.  In the New Interface Map dialog, type InterfaceMap in the Folder field. This will create a new folder called InterfaceMap if it doesn't already exist.
	__4.  Type AccountingSystem_To_AcmeQuickAccounting in the Name field.
	__5.  Uncheck Default.
	__6.  Change the namespace to http://www.webagesolutions.com/mapping
	  
	__7.  Click Next.
	__8.  Select AccountingSystem from the Source interface drop-down.
	__9.  Select AcmeQuickAccounting from the Target interface drop-down.
	__10.  Click Finish to create the interface map.
	WID will create the interface map and open it inside the Interface Mapping Editor.
	Notice the following:
	Next you will connect the payExpenseAmount operation of AccountingSystem to the addNonTaxableBenefit operation of AcmeQuickAccounting.  
	__11.  To do so, mouse over the payExpenseAmount operation.  When the orange lollipop appears, click on  it.  A line will appear.  Drag the line to the addNonTaxableBenefit operation and release the mouse button.
	__12.  Note that payExpenseAmount is now connected to addNonTaxableBenefit.
	__13.  Click the mapping between the two operations.  Notice that the Parameter mappings panel is updated to show the parameters that need to be mapped.
	__14.  Connect claim to employeeId using the same procedure that you used to connect the source and target operations.
	A Move transformation will be applied by default, which simply means the data will be copied from the source field to the target field.  However, this assumes that the source and types are compatible, which they're not.  
	Since the types are incompatible, we'll need to use another transform type to map the parameters.  Since ExpenseClaimGBO contains the data we need (i.e., employeeId), we can use an Extract transform to do the mapping.  An extract transform uses an XPath expression to retrieve the specified data from the source object and copy it to the target object.
	__15.  Click on the Move transform.
	__16.  Click the Properties view.
	__17.  In the Description tab, change the transform type to an extract by selecting Extract from the Parameter Mapping Type drop-down.
	__18.  To specify the XPath expression, click the Details tab in the Properties view.
	__19.  In the XPath field, type  /
	__20.  Press Ctrl+Space to bring up the code completion drop-down if it is not already open.
	__21.  Double click on employeeId from the drop-down.
	__22.  The XPath field should now contain the value /employeeId.
	__23.  Create an Extract mapping between the claim and amount parameters by repeating the process above.  This time, set the XPath field to /totalAmount
	__24.  Create an Extract mapping between the claim and currency parameters by repeating the process above.  This time, set the XPath field to /currency
	__25.  Your mapping should now look like the following:
	__26.  Save your changes.
	__27.  Close the file.
	__28.  Verify there are no errors in the Problems view related to this project.  You may see warnings, but this is OK.

	Part 3 -  Review

	Lab 14 -  Assemble the Business Process
	Part 1 -  Open the Assembly Editor
	__1.  Open the assembly editor by double clicking on ExpensePhase1 ->Assembly Diagram.
	__2.  Drag and drop the ExpenseClaimDev process on the editor.
	__3.  The system shows the two reference partners on the right hand side of the box for the process. If you move your mouse over a reference partner, you'll see the details.

	Part 2 -  Create Web Service Import for Expense Management System
	__1.  Select the import ExpenseManagementSystemImport1 in the assembly diagram editor. 
	__2.  In the Properties view, click the Description tab.
	__3.  Change the name to ExpenseManagementWebService
	__4.  In the Properties view, click the Binding tab. 
	__5.  Save the assembly diagram.

	Part 3 -  Wire the expenseSystem Reference Partner
	__1.  Locate the expenseSystem reference partner in the right-hand side of the box for the ExpenseClaimDev process (refer to Part 1 on how to locate the reference partners) and move your mouse over the reference partner's rectangle. The system will open the Add wire lollipop icon. 
	__2.  When the orange lollipop appears, click on  it.  A line will appear.  Drag the line to the ExpenseManagementWebService import and release the mouse button.  The reference partner is now wired.
	__3.  Save your changes.

	Part 4 -  Wire Business Process to Accounting System
	__1.  Make sure you have opened the Assembly Diagram.
	__2.  Expand ExpenseLibrary->Web Service Ports.
	__3.  Drag and drop AcmeQuickAccountingSOAPPort onto the assembly diagram.
	__4.  Select SOAP 1.1/HTTP.
	__5.  Click Finish.
	__6.  Change the display name of the import to AcmeQuickAccounting.  To do so, right click on the import, select Rename, and enter the new name.
	__7.  Expand ExpensePhase1->Transformations->Interface Maps.
	__8.  Drag and drop AccountingSystem_To_AcmeQuickAccounting onto the assembly diagram.
	__9.  Wire the accountingSystem reference partner of ExpenseClaimDev to the AccountingSystem_To_AcmeQuickAccounting interface.
	__10.  Wire the AccountingSystem_To_AcmeQuickAccounting reference to the AcmeQuickAccounting interface.
	__11.  Save your changes.  There should be no errors.
	__12.  Close the file.

	Part 5 -  Review

	Lab 15 -  Deploy and Unit Test the Business Process
	Part 1 -  Expose the Business Process as a Service
	__1.  Open the assembly diagram of ExpensePhase1.
	__2.  In the assembly diagram, right click the ExpenseClaimDev process and select Generate Export->Web Service Binding. 
	__3.  Select SOAP1.1/HTTP.
	__4.  Click Finish. 
	__5.  WID has also created a WSDL file for the business process Web Service. It is shown under ExpenseLibrary > Web Service Ports as ExpenseClaimProcessExport1_ExpenseClaimProcessHttpPort.
	__6.  Click inside the editor.
	__7.  Save your changes.
	__8.  Close all files.

	Part 2 -  Deploy Business Integration Module
	__1.  Start the server if it's not already started.
	__2.  Deploy the ExpensePhase1App project to the server. If it was already deployed then publish the server. Watch the progress bar at the bottom right hand corner of the screen. Wait for the publishing to end.

	Part 3 -  Unit Test Business Process Web Service
	__1.  Switch to the Java EE perspective. Do this by selecting Window -> Open Perspective -> Other and selecting Java EE and then click OK.
	__2.  Open the Console view by selecting Window > Show View > Console.
	__3.  Under ExpenseLibrary > Interface, select the ExpensePhase1_ExpenseClaimProcessExport1.wsdl file. This is the WSDL file for the business process web service.
	__4.  Right click the file and select Web Services->Test With Web Service Explorer. Wait for the GUI to load.
	__5.  In the Web Services Explorer, click the startProcess operation.
	__6.  First, we will simulate a success condition with a total expense amount less than $200.00. Enter the following input values:
	__7.  Click the Go button.
	__8.  The Status pane will show the following:
	__9.  Look at the Console view. It will look like this:
	__10.  Now, we will simulate a failure condition. Before going forward, clear the Console by right clicking on it and selecting Clear.
	__11.  Back in the Web Services Explorer, change the totalAmount to 350.00.
	__12.  Next to itemList, click Add.
	__13.  For the new expense item, enter the following input values:
	__14.  Click the Go button.
	__15.  Look at the Console again. This time the claim will be rejected. The addNonTaxablePayments method of the AcmeQuickAccounting web service should not be called.
	__16.  Close the Web Services Explorer.

	Part 4 -  Review

	Lab 16 -  Build a Client for the Business Process
	Part 1 -  Use the Expense Management Application
	__1.  Switch to the Web perspective.
	__2.  To create the web service proxy, expand ExpenseLibrary>Interface in the Project Explorer view.  
	__3.  Right click on ExpensePhase1_ExpenseClaimProcessExport1.wsdl and select Web Services->Generate Client.
	__4.  In the Web Service Client dialog, make sure the Service Definition is set to /ExpenseLibrary/Interface/ExpensePhase1_ExpenseClaimProcessExport1.wsdl.   
	__5.  Click the Web service runtime: IBM WebSphere JAX-RPC link.
	__6.  Select IBM WebSphere JAX-WS.
	__7.  Click OK.
	__8.  Click the Client project: ExpenseLibrary link.  
	__9.  Select ClaimWeb from the Client project drop-down.
	__10.  Click OK.
	__11.  Confirm the settings below:
	__12.  Click Finish to create the web service proxy.
	__13.  If prompted to enable automatic file overwriting, click Yes to All.
	__14.  In the Enterprise Explorer view, expand ClaimWeb > Java Resources > src > com.webagesolutions.  
	__15.  Open ExpenseClaimGBO.java.  
	__16.  Close the file.
	__17.  First, create a package for the Servlet by right clicking on Java Resources on the same project and selecting New->Package. 
	__18.  Type com.webage.servlets in the Name field.
	__19.  Click Finish.
	__20.  Copy C:\LabFiles\ClaimServlet.java to the package.
	__21.  Copy C:\LabFiles\claim.jsp and C:\LabFiles\claim_success.jsp to the WebContent folder of ClaimWeb.
	Now we will add an entry to the web deployment descriptor for the ClaimServlet servlet so claim.jsp can invoke the servlet with the URL /ClaimServlet.  
	__22.  Open the web deployment descriptor by double clicking on the ClaimWeb node underneath ClaimWeb.
	__23.  Click the Design tab.
	__24.  Click the Add button.
	__25.  Select Servlet and click OK.
	__26.  Enter  ClaimServlet as Servlet name and Display Name.
	__27.  Click OK.
	__28.  Select Servlet Class: Sample servlet class.
	__29.  In the right under Details, click the Browse button.
	__30.  In the Type Selection  dialog, type  ClaimServlet.
	__31.  Click OK.
	__32.  Select Web Application under the components list and click Add.
	__33.  Select Servlet Mapping and click OK.
	__34.  From the Servlet Name drop down select  ClaimServlet.
	__35.  Click Add next to URL Pattern.
	__36.  Change the URL to  /ClaimServlet
	__37.  Save the Deployment Descriptor. There should be no errors.
	__38.  Close all open files.
	__39.  Verify there are no errors in the Problems view.
	__40.  Open claim.jsp. It contains a form which submits a user's address information to the ClaimServlet servlet.
	__41.  Open claim_success.jsp.  It displays a message indicating the claim was submitted and the claim id.  It also states that an e-mail will be sent to the employee indicating whether or not the claim was accepted or rejected, although in reality, a message will just be printed to the console indicating such.
	__42.  Open ClaimServlet.java.  
	__43.  Examine the doPost method.  The following occurs:
	__44.  Close any open files.

	Part 2 -  Test the Business Process Using the Client
	__1.  In the Servers view, right click on the server and select Publish.
	__2.  Watch the progress bar at the bottom right hand corner of the screen. ClaimApp will be republished to the server.  Wait for the publishing to end.
	__3.  Expand ClaimWeb > WebContent.
	__4.  Right click claim.jsp and select Run as > Run on Server.
	__5.  Leave WPS 7.0 selected and check the box to use it by default.
	__6.  Click Finish.
	__7.  In the web page that opens, enter some kind of input as shown below:
	__8.  Click the Claim Expense button.
	__9.  You should see the Claim Successfully Submitted message.
	__10.  Inspect the Console view regarding the outcome of the form submission. Verify that the process got started and the claim either accepted or rejected.
	The claim shown above should have been accepted, since it was under $200.  The following output should be visible in WID.
	__11.  Close all.

	Part 3 -  Review

	Lab 17 -  Using File Inbound and Outbound Adapters
	Part 1 -  Import Module
	__1.  Switch to the Business Integration view.
	__2.  Import the AdapterTest.zip project interchange file.  This file is located in C:\LabFiles. Use the File -> Import menu option and the Project Interchange import type.
	__3.  Expand the AdapterTest project as shown below.
	__4.  Inspect the CreateCustomerProcess business process.
	__5.  The process is very simple and contains only two activities.  Select the Receive activity and select the Details tab in the Properties view.
	__6.  Select the Call ExternalApp activity.

	Part 2 -  Expose Process as an Inbound File Adapter Based Service
	__1.  Select File->New->External Service from the menu bar.
	__2.  Expand Adapters >Flat File and select Advanced: Create a Flat File service using the complete wizard.
	__3.  Click Next.
	__4.  Select IBM WebSphere Adapter for Flat Files (IBM: 7.0.0.0).
	__5.  Click Next.
	__6.  Change the Connector Project  name to MyFlatFileProject
	__7.  Click Next.
	__8.  Leave selected the Inbound adapter option. 
	__9.  Click Next.
	__10.  Make sure the Deploy connector project drop down is set to With module for use by single application.  This means that WID will include the RAR file you specified earlier (MyFlatFileProject.rar) in the module’s EAR file for exclusive use by the module.
	__11.  Set the Event directory to C:\temp\in. WPS will monitor this folder for files.
	__12.  Click Next.
	__13.  Click the Add button to add an operation.
	__14.  Leave the Data type for the operation to User-defined type. 
	__15.  Click Next.
	__16.  Enter these values:
	__17.  Click Finish to add the operation.
	__18.  Click Next.
	__19.  Now, WID will prompt you to enter the export component’s name. Change the Name to CustomerFlatFileExport
	__20.  Click Finish.
	__21.  Note that WID has created an interface called CustomerFlatFileExport and an export with the same name. Expand as shown below.
	__22.  Open the assembly diagram.
	__23.  Open the dependency editor of AdapterTest module by double-clicking on the Dependencies node to see the project.  
	__24.  Verify that the MyFlatFileProject RAR project is added to the list of dependent J2EE projects.
	__25.  Close all open files.

	Part 3 -  Build the Interface Map
	__1.  Right click Transformations in the AdapterTest project and select New->Interface Map.
	__2.  Enter FlatFile_To_Process as the Name.
	__3.  Click Next.
	__4.  Set the Source interface to CustomerFlatFileExport
	__5.  Set the Target interface to CreateCustomer
	__6.  Click Finish.
	__7.  In the Interface Map editor, click anywhere to hide the deprecated warning message.
	__8.  Connect the onCustomerFileDropped operation to startProcess.
	__9.  Select the connection.
	__10.  Map the onCustomerFileDroppedInput parameter to the customer parameter.  Since the input parameter and output parameter are both of the same type, a Move transform will suffice.
	__11.  Save and close the file.

	Part 4 -  Wire the Export to the Process
	__1.  Open the assembly diagram under AdapterTest.
	__2.  Add the CreateCustomerProcess business process to the diagram.  To do so, drag and drop it onto the diagram.
	__3.  Add the FlatFile_To_Process interface map to the diagram in the same way.
	__4.  Wire the CustomerFlatFileExport export to the interface of the FlatFile_To_Process interface map. 
	__5.  Wire the reference of the interface map to the interface of the CreateCustomerProcess process. The wiring will finally look like this:
	__6.  Save your changes.  Ignore any warnings in the assembly diagram.
	__7.  Close all open files.

	Part 5 -  Create an Outbound File Adapter Based Service
	__1.  Select File->New->External Service from the menu bar.	
	__2.  Expand Adapters > Flat File and select Advanced: Create a Flat File service using the complete wizard.
	__3.  . Click Next.
	__4.  Select the MyFlatFileProject RAR project that was already created. There is no need to create a new project. 
	__5.  Click Next.
	__6.  Select Outbound.
	__7.  Click Next.
	__8.  Click Next.
	__9.  Click Add.
	__10.  Make sure the Operation kind is set to Create.  This means a new file will be created every time the operation is called. 
	__11.  Leave the Data type for the operation to User-defined type.
	__12.  Click Next.
	__13.  Set the Operation name to createCustomer
	__14.  Set the input type to Customer. Make sure to pick the one from the AdapterTest project.
	__15.  Click Finish to add the operation.
	__16.  Click Next.
	__17.  Set the import’s Name to ExternalAppImport
	__18.  Click Finish to create the outbound file adapter based service.

	Part 6 -  Configure the Import
	__1.  Open the assembly diagram.
	__2.  Select the ExternalAppImport import.
	__3.  Go to the Properties view.
	__4.  Select the End-point configuration tab. 
	__5.  Click the Advanced button under Managed Connection Factory Properties (you may need to scroll down).
	__6.  Set the Output directory  to C:\temp\out
	__7.  Set the Sequence file to C:\temp\seq.txt
	__8.  Set the Default target file name to Test
	__9.  Your configuration should look as follows:
	__10.  Select the Method bindings tab.
	__11.  Select the createCustomer method.
	__12.  Click the Advanced button.
	__13.  Notice that you can specify an Output directory and Default target name for each operation if you want.  Again, we choose not to do this, since administrators can not change operation level configurations using the administration console.
	__14.  Save and close the assembly diagram.

	Part 7 -  Create an Interface Map
	Once again we have a mismatch, but this time between the ExternalApp interface and the ExternalAppImport interface. We need to use an interface map to close the gap.
	__1.  Right click Transformations under AdapterTest project, and select New > Interface Map.
	__2.  Enter  Process_To_ExternalAppImport as Name.
	__3.  Click Next.
	__4.  Set the Source interface to ExternalApp and the Target interface to ExternalAppImport
	__5.  Click Finish.
	__6.  Do the mapping as follows:
	__7.  Save and close the map.

	Part 8 -  Wire the Reference Partner to the Import
	__1.  Open the assembly diagram.
	__2.  Add the Process_To_ExternalAppImport interface map to the diagram.
	__3.  Wire the process, interface map, and export as shown below.  One of the easiest ways to do this can be to right click the component you want to wire and select Wire to existing.  WID will create a wiring if there is only one other component that matches, as in the case here.
	__4.  Save and close all files.

	Part 9 -  Test Process
	__1.  First, create the necessary folders:
	__2.  Then, deploy the AdapterTestApp project to the server.  Remember to start the server first if needed.
	__3.  Create a file in C:\temp with this content.  Alternatively, use the file C:\LabFiles\Customer928.xml.
	__4.  Now copy the file to C:\temp\in.
	__5.  You should see a file in C:\temp\out called Test.1.
	__6.  Open the file using Notepad. The content in the file will be identical to the source file since we haven’t converted the data, but it proves the file is read in by the adapter and used by the process.
	__7.  Close the file.

	Part 10 -  Review

	Lab 18 -  Kicking Off Phase II
	Part 1 -  Write the New Use Case
	Part 2 -  Non Functional Requirements
	Part 3 -  Create a Phase II SOA Solution
	__1.  Switch to the Business Integration perspective.
	__2.  Right click on ExpensePhase1 and select Copy.
	__3.  Right click inside the Business Integration view and select Paste.
	__4.  Change the Module Name to ExpensePhase2
	__5.  Click OK.  The new module will appear in the Business Integration view.
	__6.  To verify this, open the ExpensePhase2 assembly diagram.
	__7.  Select ExpenseClaimProcessExport1.  
	__8.  Click on the Binding tab in the Properties view.  
	__9.  In the assembly diagram, right click on ExpenseClaimProcessExport1 and select Delete.
	__10.  In the assembly diagram, right click on ExpenseClaimDev and select Generate Export->Web Service Binding.
	__11.  Select SOAP1.1/HTTP.
	__12.  Click Finish.
	__13.  The new export, called ExpenseClaimProcessExport2, should appear in the assembly diagram wired to the process.
	__14.  Confirm that the binding address for the new export refers to ExpensePhase2Web.
	__15.  Save your changes.
	__16.  Close all files.

	Part 4 -  Deploy Phase 2 SOA Solution
	__1.  Right click on the server and select Add and Remove Projects.  
	__2.  Select ExpensePhase1App and click Remove.
	__3.  Click Finish. Wait for the publishing to complete.
	__4.  Verify that ExpensePhase1App no longer appears in the Servers view.
	__5.  Now add ExpensePhase2App to the server. Again, wait for the publishing to complete.

	Part 5 -  Close the Expense Phase 1 Project
	__1.  In the Business Integration view, right click on ExpensePhase1 and select Close Project. 
	__2.  In the Backing Project Deletion dialog, click Yes.  
	__3.  Right click on the server in the Servers view and select Add and Remove Projects. Notice that ExpensePhase1 no longer appears as an available project to deploy to the server.
	__4.  Click Cancel.
	__5.  Switch to the Java EE perspective and click on the Enterprise Explorer view.
	__6.  Notice the following:  

	Part 6 -  Review

	Lab 19 -  Human Services – Add Manager's Review Function
	Part 1 -  Create a Business Object for the Human Task
	__1.  Switch to the Business Integration view.
	__2.  Expand ExpenseLibrary.
	__3.  Right click on Data Types and select New->Business Object.
	__4.  Browse to BusinessObject in the Folder field.  
	__5.  Type ReviewResponseGBO in the Name field.
	__6.  Click Finish to create the business object.
	__7.  In the Business Object Editor, add the following fields:
	__8.  Your business object should look as follows:
	__9.  Save and close the file.

	Part 2 -  Create the Human Task Interface
	__1.  Switch to Business Integration perspective if you are not there. 
	__2.  Expand  ExpenseLibrary.
	__3.  Right click on Interfaces and select New->Interface.
	__4.  Browse to Interface in the Folder field.  
	__5.  Type ExpenseReview in the Name field.
	__6.  Uncheck Default and change the namespace to http://www.webagesolutions.com/external
	__7.  Click Finish to create the interface.  The interface will be created and should automatically be opened with the Interface Editor.
	__8.  Add a Request Response Operation named review to the interface.  
	__9.  It takes an input named claim of type ExpenseClaimGBO object. 
	__10.  It returns an output named result of type ReviewResponseGBO.
	__11.  Save and close the file.

	Part 3 -  Modify the Business Process
	__1.  Expand ExpensePhase2->Integration Logic->Processes. 
	__2.  Open the ExpenseClaimDev business process.
	__3.  In the tray (right side of editor), click the green + icon next to Reference Partners.
	__4.  In the Add a Reference Partner dialog, change the name from Partner to reviewSystem
	__5.  Then, select the ExpenseReview interface and click OK.
	__6.  Verify the reviewSystem reference partner is listed under Reference Partners.
	__7.  Select the reviewSystem reference partner. 
	__8.  In the Properties view, verify the ExpenseReview interface is listed as the Reference interface.
	__9.  Click the Invoke icon in the Palette.
	__10.  Click beneath the Otherwise activity to add the activity to the diagram.
	__11.  Change the display name as Review by Manager
	__12.  Select Review by Manager.
	__13.  Click on the Details tab in the Properties view.
	__14.  Click the Browse button and select the reviewSystem partner.  Click OK.
	__15.  Make sure the Use data type variables mapping check box is selected. 
	__16.  Verify that the review operation is selected.
	__17.  The review operation takes as an input an ExpenseClaimGBO object.  For the claim input of the operation, use the none link to choose the claim process variable. 
	__18.  The review operation returns as an output a ReviewResponseGBO object.  We need to create a process variable to store this value.  For the result output of the operation, click the none link.
	__19.  Click the New button.
	__20.  In the New Variable dialog, type reviewResult
	__21.  Click OK to create the variable.  Notice it appears in the tray under Variables.
	__22.  Verify that reviewResult is listed as the output variable for the review operation.
	__23.  The manager can choose to accept or reject a claim.  To model this, click the Choice icon in the Palette under Structures.
	__24.  Click below the Review by Manager activity.
	__25.  Rename the choice activity as  Is Approved?
	__26.  Each outcome branch of a choice activity is called a case. The system has automatically added a case called Case. Right click on Case and select Rename.
	__27.  Change the name to Yes
	__28.  Right click the Is Approved? choice activity and select Add an Otherwise Element. 
	__29.  Select both Approve Claim and Notify Accounting using the Shift key.
	__30.  Select Edit->Copy from the menu bar.
	__31.  Right click on the Yes branch beneath Is Approved? and select Paste.  The Approve Claim and Notify Accounting activities will appear beneath Yes.
	__32.  Move them underneath the Otherwise activity by selecting Reject Claim and Terminate and dragging them below Otherwise.  Hold down the Shift key to select both activities.
	__33.  Save your changes.

	Part 4 -  Specify Case Condition
	__1.  Click the Yes case to select it under Is Approved?
	__2.  In the Properties view, select the Details tab.
	__3.  Click the Create a New Condition link.
	__4.  Expand reviewResult : ReviewResponseGBO process variable and select approved.
	__5.  Save your changes.
	__6.  Close all open editors.

	Part 5 -  Making the Process Long Running
	__1.  Open ExpenseClaimDev process.
	__2.  Click anywhere in the white area of the process editor. Make sure no activity is selected. This will cause the system to show the properties of the process in the Properties view.
	__3.  Click the Details tab of the Properties view. 
	__4.  Click the Refactor to Long-running Process link.
	__5.  Confirm the change by clicking the Refactor button.
	__6.  Verify the process changed to Long-running process.
	__7.  Save and close the file.
	__8.  An error will appear in the Problems view related to the assembly diagram.  
	__9.  Open the assembly diagram.
	__10.  To eliminate the errors, delete the ExpenseClaimDev process by right clicking on it and selecting Delete.  
	__11.  Expand Integration Logic->Processes.
	__12.  Drag and drop the ExpenseClaimDev process onto the assembly diagram.
	__13.  Wire the process to its export and reference partners as shown below:
	__14.  Save and close the file.  There should be no errors now.

	Part 6 -  Create the Human Task Implementation
	__1.  Expand ExpensePhase2.
	__2.  Right click on Integration Logic and select New->Human Task. 
	__3.  Type HumanTask in the Folder field.  This will create a new folder called HumanTask if it doesn't already exist.
	__4.  Type ManagerReviewTask in the Name field.
	__5.  Uncheck Default and change the namespace to http://www.webagesolutions.com/external
	__6.  Click Next.
	__7.  There are 3 types of human tasks, depending on who's invoking who.  Since we want a non-human service (in this case, a business process) to invoke the human task, choose To-do Task.
	__8.  Specify that the human task will implement the ExpenseReview interface by selecting ExpenseReview from the Interface drop-down.
	__9.  Click Finish to create the human task.  The human task will be created and should automatically be opened with the Human Task Editor.
	__10.  Notice that the Name and Display Name of the task are listed at the top of the editor.  
	__11.  Click Service Interface to see the ExpenseReview interface and review operation the human task implements.

	Part 7 -  Create a User Interface for the Human Task
	__1.  Switch to the Web perspective.
	__2.  Expand ClaimWeb->WebContent.
	__3.  Copy the C:\LabFiles\human_task folder to the WebContent folder and expand it.
	__4.  Switch back to the Business Integration perspective.  
	__5.  Back in ManagerReviewTask, click the green + symbol next to User Interface.
	__6.  Select Business Process Choreographer Explorer from the drop-down.  
	__7.  Next we will define the input message and output message JSPs.  Select Business Process Choreographer Explorer.
	__8.  In the Properties view, click the Add button.
	__9.  In the JSP Definition dialog, make sure the JSP type is set to Input message JSP.
	__10.  Click the Browse button next to JSP Location.
	__11.  In the Select a JSP dialog, expand ClaimWeb->WebContent->human_task and select review_input.jsp.
	__12.  Click OK.  
	__13.  Click OK.
	__14.  Now let's add the output message JSP.  In the Properties view, click the Add button.
	__15.  In the JSP Definition dialog, make sure the JSP type is set to Output message JSP.
	__16.  Click the Browse button next to JSP Location and select ClaimWeb ->WebContent->human_task->review_output.jsp and click OK.
	__17.  Click OK.  
	__18.  Save and close ManagerReviewTask.

	Part 8 -  Examine the User Interface JSPs
	__1.  Switch to the Web perspective.
	__2.  Expand ClaimWeb->WebContent->human_task.
	__3.  Open review_input.jsp.
	__4.  Notice the following about the input message JSP:
	__5.  Close the file.
	__6.  Open review_output.jsp.  
	__7.  Notice the following about the output message JSP:
	__8.  Close any open files.

	Part 9 -  Complete the Wiring
	__1.  Switch to the Business Integration perspective.
	__2.  Open the Assembly Diagram for the ExpensePhase2 module.
	__3.  Expand ExpensePhase2->Integration Logic->Human Tasks.
	__4.  Drag and drop ManagerReviewTask onto the assembly diagram.
	__5.  Wire the reviewSystem reference partner to ManagerReviewTask.
	__6.  Save your changes.
	__7.  Close the file.

	Part 10 -  Test the New Process
	__1.  Switch to the Java EE perspective.
	__2.  In the Project Explorer view, expand ClaimWeb > WebContent > WEB-INF > wsdl > Interface.
	__3.  Double click on the ExpensePhase1_ExpenseClaimProcessExport1.wsdl file.
	__4.  Click Yes to open the file in the WSDL editor.
	__5.  Click the Source tab at the bottom of the editor.
	__6.  Scroll to the bottom of the file and find the soap:address element.
	__7.  Change the code to use the  ExpensePhase2Web and  ExpenseClaimProcessExport2 as shown below in bold:
	__8.  Save. Make sure there are no compile time errors.
	__9.  Close the file.
	__10.  In the Servers view, right click on the server and select Publish.
	__11.  ExpensePhase2App and ClaimWeb will be republished to the server, since we modified both applications.  Wait for the publishing to complete.
	__12.  Since changes to the business process won't be picked up, add and remove the ExpensePhase2 project from the server.  Otherwise, the server will continue to run the old version of the business process. To do so, right click on the server in the Servers view and select Add and Remove Projects.
	__13.  Select the ExpensePhase2 project in the Configured projects panel and click   Remove.
	__14.  Click Finish, which will close the dialog and begin the removal of the project (undeployment of the application) from the server.
	__15.  Wait for the publishing to complete.  The project has now been removed from the server.
	__16.  To add the project (deploy the application) back to the server, right click on the server in the Servers view and select Add and Remove Projects.
	__17.  Select the ExpensePhase2 project in the Available projects panel and click Add.  
	__18.  Click Finish.
	__19.  Wait for the publishing to complete.  The project has now been added to the server.
	__20.  Expand ClaimWeb > WebContent.
	__21.  Right click claim.jsp and select Run As > Run on Server.
	__22.  Submit a claim for less than $200.00 to test the simple success condition. 
	__23.  Check the Console for log messages.
	__24.  Clear the Console.
	__25.  Now, submit a claim for more than $200.00
	__26.  Open a web browser window and enter the following URL to launch the Business Process Choreographer (BPC) Explorer: 
	__27.  Since application security is enabled by default in WPS, enter admin for both the User Name and Password.  
	__28.  Click Login.
	__29.  Do not remember the password if asked.
	__30.  Select the check box for the instance and click the Work on button above the task.
	__31.  Before completing the task, view the source code for the page.  Right click inside the browser and select View Source.  
	__32.  Search for the text <form id="pageContent".
	__33.  Close the file.
	__34.  Back in the BPC Explorer, enter some kind of comment and click the Approve radio button. 
	__35.  Click the Complete button at the top of the page.
	__36.  Now, look at the Console. You will see a log message for addNonTaxablePayments.
	__37.  In the BPC Explorer, click the My To-dos link at the left to see the human task.  
	__38.  Follow the same steps that you did above, except this time click on the Reject radio button.  
	__39.  Now, look at the Console. You will see a log message for rejectClaim.
	__40.  Close the browser.
	__41.  In WID close all.

	Part 11 -  Review

	Lab 20 -  Build Business Rules
	Part 1 -  Create an Interface for the Business Rules Group
	__1.  Switch to the Business Integration perspective.
	__2.  Expand ExpenseLibrary.
	__3.  Right click on Interfaces and select New->Interface.
	__4.  Browse to Interface in the Folder field.  
	__5.  Type ExpenseLimit in the Name field.
	__6.  Uncheck Default and change the namespace to http://www.webagesolutions.com/rule
	__7.  Click Finish to create the interface.  The interface should automatically be opened with the Interface Editor.
	__8.  Add a Request Response Operation named getMaximumLimit to the interface.  
	__9.  It takes an input named employeeId of type string. 
	__10.  It returns an output named limit of type double.
	__11.  Save and close the file.

	Part 2 -  Create the Business Rule Group
	__1.  Expand ExpensePhase2.
	__2.  Right click on Integration Logic and select New->Rules->Rule Group.
	__3.  Type BusinessRule in the Folder field.  This will create a new folder called BusinessRule if it doesn't already exist.
	__4.  Type ExpenseLimitRG in the Name field.
	__5.  Uncheck Default and change the namespace to http://www.webagesolutions.com/rule
	__6.  Click Next.
	__7.  Select ExpenseLimit from the Interface drop-down.
	__8.  Click Finish to create the business rule group.  

	Part 3 -  Create the Decision Table
	__1.  In ExpenseLimitRG, click on the text Enter Rule Logic and select New decision table... from the drop-down.
	__2.  In the New Decision Table dialog, verify that the Folder field is set to BusinessRule.
	__3.  Change the Name to MaximumLimitDT
	__4.  .  Uncheck Default and change the namespace to http://www.webagesolutions.com/rule.  Ignore the namespace warning.
	__5.  Click Next.
	__6.  In the Decision Table Layout page, you can specify how many conditions and actions your decision table will have.  Leave the default settings, since we will only have one condition.
	__7.  Click Finish to create the decision table.  The decision table should automatically be opened with the Decision Table Editor.
	__8.  Click on the Enter Term text in the first column of the first row.  A drop-down will pop up.
	__9.  Expand employeeId and select CASE_INSENSITIVE_ORDER.
	__10.  Click on CASE_INSENSITIVE_ORDER.  An arrow should appear beneath it. 
	__11.  Click on the arrow, expand Replacements and select charAt.
	__12.  The method charAt will appear to the right of employeeId and a pop up will open.
	__13.  Select Number.
	__14.  Type 0 in the Type a number field and press Enter.
	__15.  Now, let's specify the possible condition values.  Click on the Enter Value text in the second column of the first row.
	__16.  Select is equal to var1 from the drop-down.
	__17.  Type  'M'  in place of the text Select_Variable.
	__18.  Likewise, click on the Enter Value text in the third column of the first row and replace if with the following value:  
	__19.  Last but not least, we need to specify our else (otherwise) condition.  Select the row for employeeId.charAt(0) cell, right click and select Add Condition Otherwise.  
	__20.  Click on the Enter Term text in the second row of the first column.  A drop-down will pop up.
	__21.  Select limit.
	__22.  Now, let's supply the action values.  Type 500.00 in place of the text Enter Value in the second column of the second row.
	__23.  Type 500.00 in place of the text Enter Value in the third column of the second row.
	__24.  Type 200.00 in place of the text Enter Value in the fourth column of the second row.
	__25.  Your decision table should look as follows:
	__26.  Sometimes it's easier to understand a decision table if you change it's orientation. Right click inside the first row of the table and select Change Orientation.  
	__27.  Save your changes.  
	__28.  From the menu, select File > Save All.
	__29.  There should be no errors in the Problems view.

	Part 4 -  Convert Decision Table Rules into a Template
	__1.  Select the first 500.00 cell.  Make sure the border is highlighted and the cursor is not blinking inside.
	__2.  Right click inside the cell and select Convert to Template.
	__3.  Select the General tab of the Properties view and will show the template that was created. 
	__4.  Next we will place a limit constraint on param0, such that a user can't change the limit to any conceivable value.  Click on the text None under Constraint and select Range from the drop-down.  
	__5.  Click the Enter Expression text and choose Inclusive Range from the drop-down.
	__6.  Click on the Enter_Number text to the right of  >=  and select Number from the drop-down.
	__7.  Type 100.00 in the Type a number field and press Enter.
	__8.  Replace the Enter_Number text to the right of  <=  with 1000.00 using the same process as above.  
	__9.  Your template should look as follows:
	__10.  We also need to convert the other two limit cells to templates.  They will re-use Value Template 1.  
	__11.  Select the second 500.00 cell.  Make sure the border is highlighted and the cursor is not blinking inside.
	__12.  Right click inside the cell and select Convert to Template.  
	__13.  Select the General  tab of the Properties view and notice that Value Template 1 is being used for the this cell too.
	__14.  Convert the 200.00 cell into a template using the same procedure as above. Once again, it should use Value Template 1 as its template.
	__15.  Save your changes.  There should be no errors.
	__16.  Close MaximumLimitDT.
	__17.  Back in ExpenseLimitRG, click on the getMaximumLimit operation.
	__18.  Close the file.

	Part 5 -  Modify the Business Process to Invoke the Rule Group
	__1.  Expand ExpensePhase2->Integration Logic->Processes.
	__2.  Open ExpenseClaimDev.
	__3.  In the tray, click the green + icon next to Reference Partners to add a reference partner.
	__4.  Change the name of the partner to expenseLimitSystem and click OK.
	__5.  Select expenseLimitSystem.
	__6.  In the Properties view, click the Browse button next to Reference interface.
	__7.  Select ExpenseLimit from the Interface Selection dialog and click OK.
	__8.  In the tray, click the green + icon next to Variables to add a process variable.
	__9.  Change the name of the variable to employeeId and click OK.
	__10.  Select employeeId.
	__11.  In the Properties view, click the Browse button next to Data Type.
	__12.  Select string from the  Data Type Selection dialog and click OK.
	__13.  Next, let's extract the employeeId from the claim variable and assign it to the employeeId variable we just created.  First, insert an assign activity in between the Receive activity and the Get Maximum Limit activity.  To do so, right click on Get Maximum Limit and select Insert Before->Assign.
	__14.  Rename the assign activity as Set Employee Id
	__15.  Select Set Employee Id.
	__16.  Click the Details tab in the Properties view.
	__17.  Click Select From under the Assign From column.
	__18.  Expand claim in the drop-down and select employeeId.  
	__19.  Click Select To under the Assign To column.
	__20.  Select employeeId from the drop-down.
	__21.  Click on Get Maximum Limit.
	__22.  Click on the Details tab of the Properties view.
	__23.  Click the Browse button to the right of Partner.
	__24.  Select expenseLimitSystem and click OK.
	__25.  Make sure getMaximumLimit is selected from the Operation drop-down.
	__26.  Make sure the Use Data Type Variables box is checked. 
	__27.  Click the none link to the right of Input and choose employeeId from the dialog.
	__28.  Click the none link to the right of Output and choose limit from the dialog. 
	__29.  Save your changes.  

	Part 6 -  Print the Maximum Limit
	__1.  Add a snippet activity after the Get Maximum Limit activity by right clicking on Is Expense Within Limit? and selecting Insert Before->Snippet.
	__2.  Rename the snippet activity as Print Maximum Limit
	__3.  Click on Print Maximum Limit.
	__4.  Click the Details tab in the properties view.
	__5.  Click the Visual radio button to create a visual Java snippet.
	__6.  Maximize the Properties view to give yourself plenty of room to create your snippet.
	__7.  First we will add the string expression "Maximum Limit = " to the canvas.  To do so, click the Expression snippet in the palette and then click anywhere on the canvas. 
	__8.  Click inside the snippet and select String from the drop-down.
	__9.  Type  Maximum Limit =  in the Type a string dialog and press Enter.
	__10.  Now, drag and drop the limit variable beneath the expression snippet.  The limit variable is located in the tray under Variables.
	__11.  Click the Standard snippet in the palette.
	__12.  In the Add a Standard Visual Snippet dialog, expand the converter folder and select convert integer to string.
	__13.  Click OK.
	__14.  Click inside the canvas to add the convert integer to string snippet to the editor.  
	__15.  Connect the limit output to the convert integer to string input.  
	__16.  Now we can concatenate the two strings.  To do, click the Standard snippet in the palette.
	__17.  In the Add a Standard Visual Snippet dialog, expand the text folder and select append text.
	__18.  Click OK.
	__19.  Click inside the canvas to add the append text snippet to the editor.  
	__20.  Connect the "Maximum Limit = " output to the first append text inputs.  
	__21.  Connect the convert integer to text output to the other append text input.  
	__22.  Finally, we want to print the result to the log file.    Click the Standard snippet in the palette.
	__23.  In the Add a Standard Visual Snippet dialog, expand the utility folder and select print to log.
	__24.  Click OK.
	__25.  Click inside the canvas to add the print to log snippet to the editor.  
	__26.  Connect the append text output to the print to log input. 
	__27.  Save your changes.  There should be no errors, other than the one related to the assembly diagram.
	__28.  To view the Java code that's generated based on the visual snippet, click the Java radio button at the top of the Details tab.
	__29.  Read the following dialog. 
	__30.  Click Yes.
	__31.  Notice that the Java code is somewhat messy.  Ultimately, the code uses System.out.println to print the maximum limit to the log file.
	__32.  Click the Visual radio button.
	__33.  Click Yes in the Question dialog.
	__34.  Save your changes.
	__35.  Restore the Properties view.
	__36.  Close all open files.  

	Part 7 -  Update the Assembly Diagram
	__1.  Expand ExpensePhase2.
	__2.  Open the assembly diagram.
	__3.  To eliminate the error, delete the ExpenseClaimDev process by right clicking on it and selecting Delete.  
	__4.  Expand Integration Logic->Processes.
	__5.  Drag and drop the ExpenseClaimDev process onto the assembly diagram.
	__6.  Wire the process to its export and reference partners as shown below:
	__7.  Expand Integration Logic->Rule Groups.
	__8.  Drag and drop ExpenseLimitRG on the diagram.
	__9.  Wire the business process to the business rule group.
	__10.  Save and close the file.  There should be no errors now.

	Part 8 -  Test the Revised Process
	__1.  Changes to the business process are sometimes not picked up.  To be on the safe side, remove the ExpensePhase2App project to the server and wait until finish publishing.
	__2.  Add the ExpensePhase2App project to the server and wait until finish publishing.
	__3.  Expand ClaimWeb > WebContent.
	__4.  Right click claim.jsp and select Run as > Run on Server.
	__5.  Submit a claim for less than $200.00 with an employee id not starting with 'M' to test the simple success condition. A sample is shown below.
	__6.  Check the Console for log messages.  You should see the message Maximum Limit = 200 listed.  Also, the claim should be approved, since it's under $200.
	__7.  The logic that comes after retrieving the maximum limit has not changed.  For regression purposes, try filing a claim for over $200 for the employee above.  
	__8.  The log message in the Console will not show either approval or rejection. We need to manually approve the claim. 
	__9.  Instead of opening a browser window to launch the Business Process Choreographer (BPC) Explorer, you can instead open one directly from within WID.  In the Servers view, right click on the server and select Launch->Business Process Choreographer Explorer.
	__10.  If a Security Alert dialog opens, click Yes. 
	__11.  Since application security is enabled by default in WPS, enter admin for both the User Name and Password and click Login.
	__12.  Select the check box for the instance and click the Work on button above the task.
	__13.  The BPC Explorer will show the Task Message page for the to-do task. Type in a comment and select the Reject radio button.
	__14.  Click the Complete button to reject the claim.
	__15.  The My To-dos list should now be empty.  Check the Console and verify that the claim was rejected.
	__16.  Now let's test a claim for a manager to see whether or not it's approved.  Submit a claim for more than $200.00, but less than $500, with an employee id starting with 'M'. A sample is shown below.
	__17.  Check the Console for log messages.  You should see the message Maximum Limit = 500 listed.  Also, the claim should have been approved, since it's under $500.
	__18.  Feel free to submit a claim for over $500 for the same employee.  If you do so, you'll need to use the BPC Explorer to accept/reject the claim.
	__19.  Close all.

	Part 9 -  Modify the Business Rules using the Business Rules Manager
	__1.  Launch the Business Rules Manager by right clicking on the server in the Servers view and selecting Launch->Business Rules Manager.
	__2.  If you are brought to a login screen, enter admin for both the User ID and Password.
	__3.  In the Business Rules Manager home page, the business rule group you deployed, ExpenseLimitRG, will be displayed both in the left and center panel.  Expand ExpenseLimitRG in the left panel.
	__4.  Under the Business Rule Group, expand getMaximumLimit and notice that the decision table you created, MaximumLimitDT, is now displayed.
	__5.  Click on MaximumLimitDT.  It will be displayed in the center panel.  
	__6.  Click the Edit button to modify the decision table.
	__7.  Because we converted the rules into a template, the action cells are editable.  Try changing the == 'M' and == 'm' cells from 500.00 to 1500.00
	__8.  Notice that both fields are labeled in red and that the Please correct error(s) appears in the Messages box.  This is due to the constraint that you put in place that stated that the limit must be between $100.00 and $1000.00 inclusive.
	__9.  Change the cells from 1500.00 to 700.00.  The cells should change back to white and the error message should disappear. 
	__10.  Click Save to save your changes to the decision table.  
	__11.  Notice that a message appears in the Messages box indicating that the changes have been temporarily saved and that we may publish the changes.  Also, note that the Status of the decision table has changed from Original to Local Change.
	__12.  Click Publish and Revert in the left panel.  The Publish and Revert page will appear in the center panel.
	__13.  Again, you'll see that the Status of the decision table is set to Local Change.  Also, notice that there is a Revert button which allows you to change the rule back to its original state.  Instead, we want to publish our change to the server, so that the rule goes into effect.  To do so, click the Publish button at the top of the page.
	__14.  Expand ExpenseLimitRG->getMaximumLimit in the left panel.
	__15.  Click MaximumLimitDT.  Notice that the Last Published date has changed and that the Status was set back to Original.
	__16.  Close the Business Rules Manager.
	__17.  Run claim.jsp as you did it before.
	__18.  Submit a claim for more than $500.00, but less than $700, with an employee id starting with 'M' to test whether or not a claim for a manager is approved. A sample is shown below.
	__19.  Check the Console for log messages.  You should see the message Maximum Limit = 700 listed.  Also, the claim should be approved, since it's under $700.
	__20.  Close all.

	Part 10 -  Review

	Lab 21 -  Publishing JMS Message from a Process
	Part 1 -  Import the Skeletal Project
	__1.  Import the MessagingDemo module from the C:\LabFiles\MessagingDemo.zip project interchange format.
	__2.  Switch to the Business Integration perspective.
	__3.  Under MessagingDemo project do the following.
	__4.  Open the Customer data type and briefly inspect it.
	__5.  Open the CustomerUpdaterProcess interface and inspect it. This is the process interface.
	__6.  Open the CustomerSink interface and inspect it. This is the generic interface for any application that would like to receive updated customer record.
	__7.  Open the CustomerUpdateProcess business process. This simple process has only one invoke activity. This uses the customerSink reference partner to call the updateCustomer operation. This operation takes a Customer object as input. The goal of this lab is to create a solution so that when this invoke activity is executed, the customer record will be posted to a queue.
	__8.  Close all open files.

	Part 2 -  Create the Messaging Infrastructure
	__1.  Start the Server unless it is already running.
	__2.  Right click the server and select Administration > Run administrative console.
	__3.  If a Security Alert shows up click OK. Also you can check the box to avoid this window in future.
	__4.  Log in as admin and admin for user and password.
	__5.  Expand Service integration and click Buses.
	__6.  Click New to create a new message bus.
	__7.  Enter DemoBus as the name.
	__8.  Clear the Bus security checkbox to disable security protection for the bus.
	__9.  Click Next.
	__10.  Click Finish.
	__11.  Click DemoBus from the list of buses.
	__12.  Click Bus members under Topology.
	__13.  Click Add.
	__14.  Click Next.
	__15.  Click Next again to choose File store as default.
	__16.  Click Next to accept the store properties.
	__17.  Click Next to accept the Tune performance parameters.
	__18.  Click Finish to add the bus member.
	__19.  Click Buses on the left hand navigation tree under Service integration.
	__20.  Click DemoBus.
	__21.  Click Destinations under Destination resources.
	__22.  Click New.
	__23.  Choose Queue (default). Note: For pub/sub you will create a topic instead.
	__24.  Click Next.
	__25.  Enter DemoQueue as the identifier.
	__26.  Click Next.
	__27.  Select server1 and click Next.
	__28.  Click Finish to create the queue.
	__29.  Under Messages, click the Save link to save your changes.

	Part 3 -  Create JMS Resources
	__1.  In the left hand navigation tree, expand Resources->JMS.
	__2.  Click Queue Connection Factories.
	__3.  Set the scope to server1.
	__4.  Click New.
	__5.  Click OK to create the resource for the default messaging provider.
	__6.  Enter these values:
	__7.  Scroll down and click OK.
	__8.  Click Queues on the left side.
	__9.  Set the scope to server1.
	__10.  Click New. 
	__11.  Click OK to select the default messaging provider.
	__12.  Enter these values.
	__13.  Click OK.
	__14.  Save changes.
	__15.  Log out and close the Admin Console.

	Part 4 -  Create an Import
	__1.  Open the assembly diagram for the MessagingDemo module.
	__2.  Right anywhere in the assembly diagram and select Add->Import.
	__3.  Change the name of the import to CustomerSinkJMSImport
	__4.  Right click CustomerSinkJMSImport and select Add Interface.
	__5.  Choose the CustomerSink interface and click OK.
	__6.  Right click the import again and select Generate Binding->Messaging Binding->JMS Binding.
	__7.  Select the Point-to-Point JMS messaging domain. Note: For pub/sub you will choose Publish-Subscribe here.
	__8.  Select the Use pre-configured messaging provider resources radio button.
	__9.  Enter the JNDI names of the connection factory and queue.
	__10.  Under Security configuration section, Make sure the check box is not selected. We have disabled security in the bus and there is no need to supply user credentials.
	__11.  Click OK to create the import.
	__12.  Wire the CustomerUpdateProcess reference partner of the process to the CustomerSinkJMSImport import.
	__13.  Save the assembly diagram.

	Part 5 -  Deploy and Test
	__1.  Add the MessagingDemoApp application to the server. Wait for the publishing process to end.
	__2.  Right click inside the assembly diagram and select Test Module.
	__3.  Choose the CustomerUpdateProcess component and the startProcess operation.
	__4.  Enter some kind of input for the customer record.
	__5.  Click the Continue toolbar button to start testing.
	__6.  If the Deployment Location dialog opens, check the Use this as the default ... check box  and click Finish.
	__7.  If the User Login dialog opens, check the Use the authentication settings ... check box and click OK.
	__8.  Open the admin console again and log in as admin and admin.
	__9.  Expand Service integration.
	__10.  Click Buses in the left hand navigation tree.
	__11.  Click DemoBus.
	__12.  Click Destinations.
	__13.  Click DemoQueue.
	__14.  Click Queue points. A queue point is a physical storage for a queue.
	__15.  Click the DemoQueue@qnode.server1-DemoBus queue point.
	__16.  Click the Runtime tab.
	__17.  Click Messages.
	__18.  Click the message identifier.
	__19.  Click Message body.
	__20.  Verify that the XML document contains the data you had entered in the test tool.
	__21.  Logout of the admin console.
	__22.  Close all open files. Do not save the changes in the Test editor.

	Part 6 -  Review

	Lab 22 -  Asynchronous Notification To Process
	Part 1 -  Alter the Process Interface
	__1.  Switch to the Business Integration perspective and make sure you are in the Business Integration view.
	__2.  Expand ExpenseLibrary->Interfaces. 
	__3.  Double click the ExpenseClaimProcess interface.
	__4.  Click on the Add One Way Operation button.
	__5.  Change the name of the newly added operation to notifyReceiptArrival
	__6.  WID automatically adds one input parameter. Change the name of the input parameter to claimId. The data type will be string by default. There is no need to change it. 
	__7.  Save and close the interface editor.

	Part 2 -  Alter the Process
	__1.  From ExpensePhase2->Integration Logic->Processes, open the ExpenseClaimDev business process in the editor.
	__2.  Click the Receive icon in the Palette.
	__3.  Add a receive activity below the two Approve Claim activities and change their names to Wait for Receipt Arrival as shown below.
	__4.  Save changes. There will be a few errors reported in the Problems view. Ignore them for now.

	Part 3 -  Configure the Receive Activities
	__1.  Select one of the Wait for Receipt Arrival receive activities.
	__2.  In the Properties view, click the Details tab.
	__3.  Next to Partner, click Browse and select Client.  
	__4.  Click OK.
	__5.  From the Operation drop down, select notifyReceiptArrival.
	__6.  Make sure the Use data type variables mapping box is checked.
	__7.  Next to the claimId input parameter, click the none link. 
	__8.  Click on New. 
	__9.  Enter claimId as the variable name and click OK.
	__10.  Configure the other receive activity the same way, except now there is no need to create the claimId variable. Simply select it.
	__11.  Save your changes. Ignore the errors.

	Part 4 -  Configure Correlation
	__1.  In the Process Editor, click the green + icon next to Correlation Sets.
	__2.  Now, we will add a correlation property called ClaimID.  Click the green + icon next to Correlation Properties.
	__3.  Change the name to ClaimID and click OK. 
	__4.  Now, we will specify the data type of the property.  While the newly created correlation property is selected, click on the Properties view.
	__5.  Click on Browse next to Type and double click on string. 
	__6.  Still with ClaimID selected, scroll down in the Properties view and select the startProcess operation under the ExpenseClaimProcess interface.
	__7.  Click the Add button.
	__8.  In the Create Property Alias dialog, expand startProcessParameters: startProcess ->claim: ExpenseClaimGBO and select claimId.
	__9.  Click OK to create the alias.
	__10.  Back in the Properties view, select the notifyReceiptArrival operation under the ExpenseClaimProcess interface.
	__11.  Click the Add button.  
	__12.  This time we will locate the claim ID in the input of notifyReceiptArrival operation. Make the settings as shown below.
	__13.  Click OK.
	__14.  Verify that the two aliases look like this:
	__15.  Select CorrelationSet in the tray and then click the Properties view.  
	__16.  Check the box next to ClaimID.
	__17.  Save your changes.

	Part 5 -  Configure Correlation for the Receive Activities
	__1.  Select the Receive activity as shown below.
	__2.  In the Properties view, click the Correlation tab.
	__3.  Click Add. WID will automatically add the only available correlation set to the table called CorrelationSet.
	__4.  Change the Initiation value to Yes as shown below.
	__5.  Select one of the Wait for Receipt Arrival receive activities. 
	__6.  In the Properties view, select the Correlation tab.
	__7.  Click on the Add button to specify the correlation set. 
	__8.  This time, correlation will be used to identify a process instance, so leave the Initiation value set to No.
	__9.  Similarly, configure the other Wait for Receipt Arrival receive activity.
	__10.  Save changes.   There shouldn't be any errors in the Problems view.

	Part 6 -  Set Activity Names
	__1.  Select the Get Maximum Limit activity and then select the Description tab in the Properties view.
	__2.  Copy the Display Name and then paste it in the Name field, then hit Enter.
	__3.  You can see that the spaces in name are automatically removed.
	__4.  Select each activity in the diagram and do the same change.
	__5.  Note that if the Name is already used, then an incremental number is added to the end.
	__6.  Note too that special characters are also removed.
	__7.  Save the file.
	__8.  Close all open files.

	Part 7 -  Regenerate the Web Service Export of the Process
	__1.  Open the Assembly Diagram for the ExpensePhase2 module.
	__2.  Select the export as shown below.
	__3.  Delete the export.
	__4.  Save changes. Wait for the build process to end.
	__5.  To regenerate the export, inside the assembly diagram, right click the ExpenseClaimDev process and select Generate Export->Web Service Binding. 
	__6.  Select the SOAP1.1/HTTP option. 
	__7.  Click Finish.
	__8.  Save and close the file.

	Part 8 -  Update the Claim Management Application
	__1.  To create the web service client proxy, switch to the Web perspective.
	__2.  Expand ExpenseLibrary->Interface in the Enterprise Explorer view.  
	__3.  Right click on ExpensePhase2_ExpenseClaimProcessExport1.wsdl and select Web Services->Generate Client.
	__4.  In the Web Service Client dialog, make sure the Service definition is set to /ExpenseLibrary/Interface/ExpensePhase2_ExpenseClaimProcessExport1.wsdl.  
	__5.  Change the Web service runtime to IBM WebSphere JAX-WS.
	__6.  Change the client project to ClaimWeb.  
	__7.  Confirm the settings below:
	__8.  Click Finish to create the web service proxy.
	__9.  Copy C:\LabFiles\receipt.jsp to the WebContent folder of ClaimWeb.
	__10.  Copy C:\LabFiles\ReceiptServlet.java to the com.webage.servlets package inside the ClaimWeb project.
	Now we will add an entry to the web deployment descriptor for the ReceiptServlet servlet so receipt.jsp can invoke the servlet with the URL /ReceiptServlet.  
	__11.  Open the web deployment descriptor by double clicking on the ClaimWeb node underneath ClaimWeb.
	__12.  Click Add.
	__13.  Select Servlet and click OK.
	__14.  Enter ReceiptServlet as Servlet name and display name.
	__15.  Click OK.
	__16.  Select Servlet class below Servlet ReceiptServlet.
	__17.  In the right side, click the browse button next to Servlet class.
	__18.  Enter ReceiptServlet and click OK.
	__19.  In the components list, select Web Application.
	__20.  Click Add.
	__21.  Select Servlet Mapping and click OK.
	__22.  Select ReceiptServlet from the drop-down next to Servlet name in the right.
	__23.  Click Add next to URL Pattern. 
	__24.  Change the URL to  /ReceiptServlet
	__25.  Make sure the Deployment descriptor look like this:
	__26.  Save changes.
	__27.  Close all open files.
	__28.  Verify there are no errors in the Problems view.
	__29.  Open receipt.jsp under the WebContent folder of ClaimWeb.
	__30.  Open ReceiptServlet.java under the ClaimWeb project.  
	__31.  Open ClaimServlet.java
	__32.  Expand the imports at the top.
	__33.  Change the import to use the proxy class, located in the com.webagesolutions.binding3 package, that was generated when we created the web service client in the previous steps, as shown in bold below:
	__34.  Save the file.
	__35.  Close all open editors.

	Part 9 -  Test the Solution
	__1.  Changes to the business process are sometimes not picked up.  To be on the safe side, add and remove the ExpensePhase2App project from the server.
	__2.  Run claim.jsp under the ClaimWeb project.
	__3.  Clear the console.
	__4.  File a claim for an item with an amount of $20.00.
	__5.  Wait approximately a minute and then review the Console. The "approveClaim called" message shows that the claim has been approved, but you will not see a message for "addNonTaxablePayments". This means that the process has not notified the accounting system to pay out the amount. It is waiting for the receipts. 
	__6.  Right click the Server and select Launch > Business Process Choreographer Explorer.
	__7.  Log in as admin for user and password.
	__8.  From the Process Templates, click the Currently Valid link in the left panel.
	__9.  Select the check box next to ExpenseClaimDev. 
	__10.  Click on the Instances button.
	__11.  The system should show one instance in a Running state. 
	__12.  Click on the process instance name.
	__13.  In the Process Instance page, click on the Activities tab (not the Activities button).
	__14.  Now, we will simulate the arrival of receipts event. Run the receipt.jsp from the ClaimWeb project.
	__15.  Locate the claim ID in the browser where you submitted the claim.  
	__16.  Copy and paste the ID in the browser. 
	__17.  Click on Log Receipts.
	__18.  Now, the Console view will show the log message from the addNonTaxableBenefit method.
	__19.  Close all.

	Part 10 -  Review
	Part 11 -  Lessons Learned

	Lab 23 -  Implement Compensation in a Long Lived Business Process
	Part 1 -  Add Timeout to the Wait for Receipt Arrival Activity
	__1.  Switch to the Business Integration perspective.
	__2.  Open the ExpenseClaimDev process under ExpensePhase2->Integration Logic ->Processes.
	__3.  Delete the Wait for Receipt Arrival activity in the Yes branch for Is Expense Within Limit? as shown above.  
	__4.  In the Palette, click the Receive Choice icon.
	__5.  Then click in the process between Approve Claim and Notify Accounting.
	__6.  Change the name and the display name of the ReceiveChoice activity to Wait for Receipt Arrival
	__7.  WID has already added a branch for the receive choice (pick) activity. Select the Receive Case activity. 
	__8.  In the Properties view, select the Description tab.
	__9.  In the Description tab, set the Display Name to Wait and hit Enter.
	__10.  Select the Details tab. 
	__11.  Set the Partner to Client.
	__12.  Choose the notifyReceiptArrival operation.
	__13.  Check the Use data types variable mapping check box.
	__14.  Set the input variable to claimId. 
	__15.  Verify your work with the image below:
	__16.  Select the Correlation tab. 
	__17.  Click Add to add the correlation set you created in an earlier lab.  This way the correct process instance is invoked when receipts arrive.
	__18.  Now, drag and drop the Notify Accounting task beneath the Wait activity.
	__19.  Right click the Wait for Receipt Arrival receive activity and choose Add a Timeout Element.
	__20.  Select the Timeout activity.
	__21.  In the Properties view, select the Details tab. 
	__22.  Set the Expression Language to Timeout.
	__23.  Set the Timeout Duration to 30 seconds. (In real life, this will probably be something like 15 business days. To count business days, you will need to use a custom defined calendar that takes into account weekends and holidays.)
	__24.  Now we will throw a fault from the timeout branch. In the Palette, expand Faults and click the Throw activity.
	__25.  Then click below the Timeout activity. This will add the throw activity as shown below.
	__26.  In the Details page of the Properties view, set the Fault Name to timeout. This is a predefined fault type provided by BPEL.
	__27.  Save your changes. 

	Part 2 -  Define Compensation Handler
	__1.  In the Yes branch, right click Approve Claim and select Add a Compensation Handler.
	__2.  Within the compensation handler box, add an Invoke activity. 
	__3.  Change the name and display name of the Invoke activity to Reject Claim
	__4.  From the Details tab of the RejectClaim in the Properties view, make the following changes:
	__5.  Save your changes.

	Part 3 -  Kick Off Compensation on Error
	__1.  To create a global fault handler, right click the start activity (the green circle at the top of the process) and select Add a Fault Handler.
	__2.  Right click anywhere on the fault handler (do not right click Catch). Then select Add Catch All Element from the menu.
	__3.  Select and delete the Catch flow. There is no need for it.
	__4.  In the Palette, click on the Compensate icon under Faults. 
	__5.  Then click below the Catch All flow.
	__6.  A compensate activity can compensate a specific activity or all activities that have been successfully completed. Select the Compensate activity. 
	__7.  In the Properties view, select the Details tab. 
	__8.  Save and close the file. 

	Part 4 -  Test
	__1.  Changes to the business process are sometimes not picked up.  To be on the safe side, add and remove the ExpensePhase2 project from the server.
	__2.  From the ClaimWeb project run claim.jsp
	__3.  File a claim for $20.00.
	__4.  Check the Console view. You will see that approveClaim is called. 
	__5.  Clear the console by right clicking inside the Console and selecting Clear.
	__6.  Wait for 30 seconds. You will see that rejectClaim is called.
	__7.  Close all.

	Part 5 -  Review

	Lab 24 -  Testing Web Services
	Part 1 -  The Purpose of This Lab
	Part 2 -  Manually Test the Web Service
	Part 3 -  Setup JMeter
	__1.  JMeter should be already installed in C:\Software\jakarta-jmeter-2.3.4. Verify that. If it is not there, download jakarta-jmeter-2.3.4.zip from its website and extract it to C:\Software to create C:\Software\jakarta-jmeter-2.3.4.

	Part 4 -  Copy Required JAR Files
	__1.  JMeter requires a few extra JAR files to enable Web Service testing. Copy these JAR files from C:\LabFiles to the C:\Software\jakarta-jmeter-2.3.4\lib\ext folder.

	Part 5 -  Launch JMeter
	__1.  Open a command prompt window.
	__2.  Enter the following command to add the JDK to the path.
	__3.  Change directory to C:\Software\jakarta-jmeter-2.3.4\bin.
	__4.  Enter the command:

	Part 6 -  Create a Test Script
	__1.  Right click Test plan and select Add > Thread Group. A thread group is used to control the concurrent request size.
	__2.  Right click Thread Group and select Add > Sampler > WebService(SOAP) Request. A sampler is used to send a request to the resource being tested (the web service).
	__3.  Change the name to Get Maximum Limit
	__4.  Change the WSDL URL to http://localhost:9080/ClaimWeb/ExpenseManagementSystemImport1_ExpenseManagementSystemHttpService?WSDL
	__5.  Click Load WSDL.
	__6.  In the WebMethod drop-down, select getMaximumLimit.
	__7.  Click Configure.
	__8.  Open C:\LabFiles\GetMaximumLimitSOAP.xml in Wordpad.
	__9.  Select all the content (CTRL+A) and copy (CTRL+C).
	__10.  Back in JMeter, paste it in the Soap/XML-RPC Data field.
	__11.  Select the Read SOAP Response.
	__12.  Right click Thread Group and select Add > Listener >View Results Tree. A listener processes the response from the resource. They are normally used to interpret and display the results of the test.
	__13.  Right click Thread Group and select Add > Listener >Aggregate Report.
	__14.  Click on the Thread Group node. A thread group determines how many separate threads are used to send HTTP or SOAP requests. Each thread counts as an active user. The Number of Threads is currently 1. This is good while we validate the script. After that, we can bump up the thread count. 
	__15.  Set the Loop Count to 100.
	__16.  From the menu, select File > Save.
	__17.  Select C:\LabFiles and name the file as Expense.jmx
	__18.  Click Save.

	Part 7 -  Unit Test the Test Script
	__1.  Click the Aggregate Report listener. We will observe the numbers here while we run the test.
	__2.  Hit Control+R to start the test.
	__3.  Make sure that the Error % column shows 0.00% for both operation calls.
	__4.  Back in WID, make sure that there are no exceptions shown in the Console view.
	__5.  Click the View Result Tree listener. Every request is shown in a list.
	__6.  Select one of the Get Maximum Limit requests. 
	__7.  On the right hand side, select the Response Data tab.
	__8.  At the bottom of the screen, select the Render XML radio button. This will help you browse the DOM tree of the SOAP reply document.
	__9.  In the Response data area, expand soapenv:Envelope → soapenv:Body → ns2:getMaximumLimitResponse → amount. Make sure you see the 200.0 amount.

	Part 8 -  Perform Stress Test
	__1.  Click Thread Group.
	__2.  Set the Number of Threads (users) to 5.
	__3.  Click Aggregate Report. 
	__4.  Hit Control+E to clear all previous results. This is very important. You don't want results from one test contaminated by the previous test.
	__5.  Now, hit Control+R to start the test. Wait until the total number of samples reach 500 (that's 5 user X 100 loops X 1 operation requests per loop).
	__6.  Note down the total average response time (in ms) and % error.
	__7.  Repeat the process with 15 users.
	__8.  Compare the average response time for all two test cases. What possible conclusion can you derive at?

	Part 9 -  Perform Function Test
	__1.  Under Thread Group, right click Get Maximum Limit and select Add->Assertions->XPath Assertion.
	__2.  In the XPath Assertion text box, enter:
	__3.  To run the test, click Aggregate Report. Clear results (Control+E) and start the test (Control+R). The Errors% column should show no errors.
	__4.  In our case, the web service is very simple and always returns the 200.0 amount. To simulate an error condition, we will simply change our XPath rule.
	__5.  Click the XPath Assertion node. Change the amount value to 300.0 from 200.0
	__6.  Click Aggregate Report. Clear results (Control+E) and start the test (Control+R). The Errors% column should show 100% error for the Get Maximum Limit sampler.

	Part 10 -  Review

	Lab 25 -  Pollution Regulation Compliance Process
	Part 1 -  Business Problem Statement
	Part 2 -  Regulation Details
	Part 3 -  The Current IT Landscape
	Part 4 -  What You Need to Do
	Part 5 -  Advanced Challenge

	Lab 26 -  Create a Profile (Optional)
	Part 1 -  Stop the Server
	__1.  If there are projects installed in the server then remove all of them by right clicking on the server, then click Remove All and click Finish, make sure your server is started and it is synchronized when is done. Wait for publishing.
	__2.  Stop the server by right clicking on it and selecting Stop.  
	__3.  Close WID if you have it open to conserve memory.

	Part 2 -  Create a Profile
	__1.  From the Start menu, select All Programs > IBM WebSphere > Process Server 7.0 > Profile Management Tool.
	__2.  The Profile Management Tool  7.0 window will open. Click the Launch Profile Management Tool button.
	__3.  In the Profiles window, click the Create button to create a new profile.
	__4.  Expand WebSphere Process Server and select  Stand-alone process server.
	__5.  Click Next.
	__6.  In the Profile Creation Options page, click the Advanced profile creation button.
	__7.  Click Next.
	__8.  In the Optional Application Deployment page, leave the defaults, which is to deploy the administrative console and deploy the default application.
	__9.  Click Next.
	__10.  In the Profile Name and Location page, check the boxes Create the server using the development template and Make this profile the default.  The name of the template should be set to ProcSrv01 by default.
	__11.  Click Next.
	__12.  In the Node and Host Names page, leave the defaults.  They will be based on your machine name. Click Next.
	__13.  In the Administrative Security page, make sure the Enable administrative security box is checked.  Type admin in the User name, Password, and Confirm password fields.  
	__14.  Click Next.
	__15.  In the Security Certificate (Part 1) page, leave the defaults to create certificates and click Next.
	__16.  In the Security Certificate (Part ) page, again leave the defaults and click Next.
	__17.  In the Port Values Assignment page, click the Default Port Values button.  This will cause the server created to use the default port numbers.
	__18.  Ignore the warning Activity was detected on these ports: 9060, 9043....
	__19.  Click Next.
	__20.  In the Windows Service Definition page, uncheck the Run the process server as a Windows service box.
	__21.  Click Next.
	__22.  In the Web Server Definition page, leave the default settings, which is not to create a web server definition.
	__23.  Click Next.
	__24.  In the Business Process Choreographer page, leave the default settings, which is to configure a sample Business Process Choreographer.
	__25.  Click Next.
	__26.  In the Business Space Configuration page, make sure that Configure Business Space box is checked.
	__27.  Click Next.
	__28.  In the Business Rules Manager Configuration page, check the Configure the Business Rules Manager box.
	__29.  Click Next.
	__30.  In the Database Design page, leave the default and click Next.
	__31.  In the Database Configuration page, leave the default settings, which is to create new Derby databases called WPRCSDB and EVENT.
	__32.  Click Next.
	__33.  In the Database Configuration (Part 2) page, enter WPS as Schema name.
	__34.  Click Next.
	__35.  In the Profile Creation Summary page, confirm the following settings, especially the port numbers.  Your node name, host name, and cell name will be based on your machine name.
	__36.  Click Create.  
	__37.  Uncheck the Launch the First steps console box.
	__38.  Click Finish.
	__39.  Close any open windows.

	Part 3 -  Configure WID to use the New Profile
	__1.  Launch WID by selecting Start->All Programs->IBM WebSphere Integration Developer->IBM WebSphere Integration Developer V7.0->WebSphere Integration Developer V7.0.
	__2.   In the Workspace Launcher dialog, change the workspace to C:\workspace
	__3.  Click OK.
	__4.  Right click on the server and select Delete.
	__5.  Click OK in the dialog to confirm the deletion.
	__6.  Right click in the Servers view and select New->Server.
	__7.  In the New Server dialog, select WebSphere Process v7.0 Server for both the server type and server runtime environment.
	__8.  Click Next.
	__9.  In the WebSphere Application Server Settings page, select ProcSrv01 from the Profile name drop-down.
	__10.  Make sure the Security is enabled on this server box is checked.  
	__11.  Type admin in the User ID and Password fields.  
	__12.  Click Finish to create the server configuration.  
	__13.  Verify that WebSphere Process Server v7.0 at localhost is now listed in the Servers view.
	__14.  Right click on the server and select Start to launch the server.
	__15.  The server can take up to several minutes to start. When  finish publishing will show Started state and Synchronized status.
	__16.  Open the Console view by selecting Window->Show View->Console from the menu bar.
	__17.  Scroll to the bottom and then scroll up slightly.  You should see the message Server server1 open for e-business in the Console view indicating that the server is finished starting.
	__18.  In the Servers view, right click on the server and select Administration->Run administrative console.  
	__19.  Click Yes in the Security Alert dialog.
	__20.  Log in as admin and admin, which corresponds with the user name and password you specified when creating the profile.
	__21.  If you input the correct user name and password, the Welcome page of the admin console will be displayed.  Otherwise, an error message will be displayed and you'll need to click OK and attempt to log in again.

	Part 4 -  Verify that the Server is Running in Development Mode
	__1.  In the left panel, expand Servers > Server Types and click WebSphere Application servers underneath it.
	__2.  In the right panel, click on server1, which is the default server that was created when you created a new profile.
	__3.  In the application server configuration page, verify that the Run in development mode box is checked.  If it's checked, then proceed on to the next part of the lab.
	__4.  If it's not checked, then check the box now.
	__5.  Click the OK button below it.
	__6.  In the Messages dialog, click the Save link to save the changes to the server configuration.  Note that you will need to restart the server later for the changes to take effect.
	__7.  Click the server1 link to return to the server configuration page.

	Part 5 -  Verify that the Server is Using the Correct Port Numbers
	__1.  In the application server configuration page, scroll down until you see the Communications heading.
	__2.  Click the + symbol next to Ports.
	__3.  At a bare minimum, verify the following ports are set correctly:
	__4.  Click the Logout link at the top of the admin console.
	__5.  Close the admin console.

	Part 6 -  Review

	Lab 27 -  Import Lab Solutions (Optional)
	Part 1 -  Remove Existing Projects from Server
	__1.  In WID, start the server if it is not already running.
	__2.  Remove all the projects from the server.  To do so, right click on the server in the Servers view and select Add and Remove Projects.
	__3.  Click the Remove All button.
	__4.  Click Finish, which will close the dialog and begin the removal of all the projects (undeployment of the applications) from the server.
	__5.  Wait for the publishing to complete.  The projects have now been removed from the server.
	__6.  Stop the server.

	Part 2 -  Delete Existing Projects from Workspace
	__1.  Switch to the Business Integration perspective. 
	__2.  Select all the projects in the Business Integration view.
	__3.  Click the Delete key on your keyboard.
	__4.  In the Confirm Multiple Delete dialog, click the Also delete contents in the file system radio button. Then click Yes.
	__5.  After the project deletion completes, the Business Integration view should be empty.  

	Part 3 -  Import the Solutions
	__1.  Select File->Import from the menu bar.
	__2.  In the Import dialog, expand Other and select Project Interchange.
	__3.  Click Next.
	__4.  Click the Browse button and navigate to the Lab 28.zip solution file, which is located in C:\LabFiles\Solutions and then click Open.
	__5.  Click Select All.
	__6.  Click Finish.
	__7.  The projects will now be imported.  Wait until the build process completes.  This can take several minutes.

	Part 4 -  Resolve Any Build Problems
	__1.  Check to see if there any errors in the Problems view.  If there aren't any, then skip to the last part of the lab on deploying the projects to the server.
	__2.  If you see the error A J2EE Enterprise Application must contain one or more modules, then proceed to the next part of the lab to resolve this issue.  If there are any other errors listed, then return to this part afterwards to resolve them.
	__3.  If you see any build related errors, select Project->Clean from the menu bar.  
	__4.  Click the Clean all projects radio button.
	__5.  Click OK.
	__6.  Wait for the build to complete.
	__7.  Check to see if the errors disappeared.  If not, check to see if they correspond with the following errors:
	__8.  If so, exit WID and then open it again.
	__9.  If the errors still haven't disappeared, try doing a clean again.  If the errors still exist, then create a new workspace.  
	__10.  In the Workspace Launcher, enter a new workspace location.
	__11.  Click OK.
	__12.  Import the Lab 28.zip solution into the new workspace using the procedure above.  

	Part 5 -  Relink Web Projects to EAR Projects
	__1.  Double click one of the A J2EE Enterprise Application must contain one or more modules error messages in the Problems view.  This will cause the application deployment descriptor for the corresponding enterprise application project (e.g., AcmeApp) to open in an editor.
	__2.  Click the Module tab at the bottom of the editor.
	__3.  Click the Add button to add a module.
	__4.  Select the corresponding web module, which in this case is AcmeWeb.
	__5.  Click Finish.
	__6.  The module should appear in the list.  
	__7.  Save your changes by pressing Ctrl-S.  The error should disappear from the Problems view.
	__8.  Close the editor.
	__9.  Repeat the process for any other affected enterprise applications.

	Part 6 -  Deploy the Imported Projects
	__1.  Create the directories C:\temp\in and C:\temp\out.  Otherwise, you'll get exceptions when deploying the AdapterTestApp project that was created in the "Using File Inbound and Outbound Adapters" lab.
	__2.  Start the server.
	__3.  Right click on the server and select Add and Remove Projects.
	__4.  Click the Add All button to deploy all the projects.
	__5.  Click Finish.
	__6.  Wait for the publishing to complete.  The projects have now been added to the server.
	__7.  Expand the server in the Servers view and verify that all of the applications have a  Synchronized status.

	Part 7 -  Review




