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Lab 1 - Collections
In this Lab we will be building components for a User Registration application. 

There will be two types of users, namely: the regular user and an administrator. 
Administrators have special privileges not available to the regular users.

A user can register by entering their first name, last name, email address, user name, 
password, and verify password.   All fields except first name are mandatory.  The 
password must match verify password. After a successful registration the program will 
show a thank you message.

One should be able to view a list of all users currently registered in the system. 

We will use three classes: RegularUser, Administrator and Driver.

The Administrator class extends from RegularUser.  The Driver class is the main 
application driver and contains the main() method that we will run.

Goal
In this exercise, we will implement an in-memory, Collections-based storage service for 
our user registration system.  Apart from experimenting with the Collections classes, this 
demonstrates the concept of implementing “mock” system components.  Mock 
components can often be useful in allowing parallel development efforts.  For instance, 
this quick memory-based implementation of the UserStore service could be used to 
facilitate development of the business logic and user interface design even though the 
database structure and design hasn’t been finalized.

Part 1 - Create a Java Application Project
__1. From C:\Software\eclipse execute eclipse.exe

__2. You will be prompted to select a workspace.  Change the the Workspace to 
C:\workspace
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__3. Click the OK button.

__4. You will see the Welcome screen. Close it.

__5. From the menu, select File -> Import.

__6. Expand and select General → Existing Projects into Workspace and click the 
Next button.

__7. Click the Browse button next to the 'Select root directory' option and navigate to 
the C:\LabFiles\LabStarterFiles directory (the actual location of the directory may vary 
on your machine; check with your instructor) then click OK. 

__8. Check the option for 'Copy projects into workspace' if not already selected.
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__9. Click the Finish button once your options match that shown below. 

__10. Expand AdvJava from the Project Explorer view.

You can ignore any errors at the moment. These are pertaining to other labs and we will 
fix them at that point.

Part 2 - Create a Java Package
It is good programming practice to create all your classes inside a package, to prevent 
name conflicts, as projects get more complex.  Recall that to create package names, we 
reverse the components of a domain name that we control, then add a package name 
element.  For instance if we were working on a project called “myProject” in an 
organization with domain name “myco.com”, then you might use a package called 
“com.myco.myProject”.

We will create the classes for Lab 1 under a package called 
“com.webagesolutions.collections”.

__1. In the Package Explorer, right click on the AdvJava project and select New -> 
Package from the context menus.
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__2. Enter  com.webagesolutions.collections  in the Name field:

__3. Press the Finish button.

Part 3 - Create a Collections-based implementation of UserStore
__1. Expand AdvJava > com.webagesolutions.users and examine the interface 
UserStore.  This interface defines a generic service that stores instances of User objects 
and allows a client to retrieve the User objects based on the user’s email address.  We will 
first implement a memory-based UserStore using the collections library. 

Next we will create a new class called ‘InMemoryUserStore’ in the 
‘com.webagesolutions.collections’ package, and have the class implement the UserStore 
interface.  

__2. To create this class, right click on the ‘com.webagesolutions.collections’ package 
and select New -> Class… 

__3. Enter the following:

Name: InMemoryUserStore

Package: com.webagesolutions.collections (should be set already)

__4. Next to Interfaces click Add. 
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__5. Start typing UserStore and you should see UserStore  - com.webagesolutions.users. 
Select it and click OK.

__6. Check Inherited abstract methods.

__7. Uncheck all other options

__8. Click Finish once your options match those shown below.
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Since we select the checkbox above to automatically generate method stubs for the 
interface’s methods (‘Inherited abstract methods’), the generated class should look like:

public class InMemoryUserStore implements UserStore {

@Override
public void putUser(User user, String verifyPassword)

throws UserAddException {
// TODO Auto-generated method stub

}

@Override
public Iterable<User> listAllUsers() {

// TODO Auto-generated method stub
return null;

}

@Override
public User getUser(String email) {

// TODO Auto-generated method stub
return null;

}

}

__9. First we will implement the putUser and listAllUsers methods by storing the users in 
an ArrayList object.  Declare an instance variable called ‘userList’ that stores a reference 
to a List that contains User objects.  Make sure this is defined inside the class definition 
but outside of any methods.  You will have errors until the next step.

public class InMemoryUserStore implements UserStore {
private List<User> userList = new ArrayList<>();

__10. Add the appropriate import statements to import java.util.List and 
java.util.ArrayList (Reminder: you can have Eclipse add them automatically by right 
clicking in the editor window and selecting Source -> Organize Imports in the context 
menu or clicking Ctrl-Shift-O).

import java.util.ArrayList;
import java.util.List;
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__11. Implement the putUser method to add the user into the list.  Before adding the user 
into the list, we need to check the verification password against the password stored in 
the user object.  The code should look like this:

public void putUser(User aUser, String verifyPassword)
throws UserAddException {

if (verifyPassword.equals(aUser.getPassword())) {
userList.add(aUser);

} else {
throw new UserAddException("Password incorrect.");

}
}

__12. Implement the listAllUsers method to return a read-only version of the users 
collection.  Recall that the Collections class contains a utility method to provide an 
unmodifiable view of a List.  The resulting code should look like:

public Iterable<User> listAllUsers() {
return Collections.unmodifiableList(userList);

}

__13. Organize imports by clicking Ctrl+Shift+O to import java.util.Collections.

__14. Save the file. There should be no errors in the class.

The Lab Starter files that you imported contained a class called TestInMemoryUserStore, 
that creates a number of users then prints out the results of running ‘getAllUsers’.  

__15. To run the program, right-click on the TestInMemoryUserStore class in the 
Project Explorer under the com.webagesolutions.users package, then select Run As -> 
Java Application from the context menu.  
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__16. You will be prompted that there are still errors in your workspace, check Always 
launch without asking and click Proceed. 

__17. The output in the Console view should look like:

First Name: Jim
Last Name: Waldo
E-Mail: waldoj@sun.com
User Name: waldoj
Password: note
This user is an Administrator

First Name: Ann
Last Name: Wollrath
E-Mail: wollratha@sun.com
User Name: wollratha
Password: on
This user is a RegularUser

First Name: Samuel
Last Name: Kendall
E-Mail: kendalls@sun.com
User Name: kendalls
Password: distributed
This user is a RegularUser

First Name: Geoff
Last Name: Wyant
E-Mail: wyantg@sun.com
User Name: wyantg
Password: computing
This user is a RegularUser

Jim Waldo's user record is:
--Unknown--

10

EVALUATIO
N O

NLY



__18. Now we’ll add the ability to lookup a user by email address.  To do this, we’ll add 
a HashMap that references the stored users to their email address.  Add the following 
instance variable to the InMemoryUserStore class:

public class InMemoryUserStore implements UserStore {
private List<User> userList = new ArrayList<>();
private Map<String, User> index = new HashMap<>();

__19. Organize imports. (Ctrl+Shift+O) 

__20. In the putUser method of InMemoryUserStore, we need to add code to store the 
User object in the index. Add the following code to the putUser(…) method:

public void putUser(User aUser, String verifyPassword)
throws UserAddException {

if (verifyPassword.equals(aUser.getPassword())) {
userList.add(aUser);
index.put(aUser.getEmail(), aUser);

} else {
throw new UserAddException("Password incorrect.");

}
}

__21. Implement the getUser(…) method to look up the user based on the supplied email 
address:

public User getUser(String email) {
return index.get(email);

}

__22. Save the class.

__23. Run the TestInMemoryUserStore class again.  You can do this by right-clicking 
the TestInMemoryUserStore class and selecting Run As -> Java Application.
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__24. This time the lookup at the end, it should return a user as shown in bold.

First Name: Jim
Last Name: Waldo
E-Mail: waldoj@sun.com
User Name: waldoj
Password: note
This user is an Administrator

First Name: Ann
Last Name: Wollrath
E-Mail: wollratha@sun.com
User Name: wollratha
Password: on
This user is a RegularUser

First Name: Samuel
Last Name: Kendall
E-Mail: kendalls@sun.com
User Name: kendalls
Password: distributed
This user is a RegularUser

First Name: Geoff
Last Name: Wyant
E-Mail: wyantg@sun.com
User Name: wyantg
Password: computing
This user is a RegularUser

Jim Waldo's user record is:
First Name: Jim
Last Name: Waldo
E-Mail: waldoj@sun.com
User Name: waldoj
Password: note
This user is an Administrator 

__25. Close all open files by select Ctrl+Shift+F4. Use this combination every time you 
need to close all open files.

Part 4 - Summary
This exercise has demonstrated the use of the List collection as well as the Map 
collection.
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Lab 2 - Accessing Database
What this exercise is about
In this lab exercise, you will use the JDBC API to connect to a database and perform some 
simple reads/inserts.
You will create code that will work with the UserStore code that we saw in the previous lab. 
Recall that in the previous lab, all users were stored in/retrieved from a collection in memory; 
now, we will create class(es) to store/retrieve users via a database.
Your code will use the Derby database, which is already installed on your computer.

What you will be able to do
✔ Use the SQL API to perform database queries
✔ Use prepared statements to simplify queries

Part 1 - Add the Derby JDBC Drivers to the Eclipse Project
__1. Right click on the ‘AdvJava’ project in the Project Explorer and select Properties.

__2. In the properties window, select the Java Build Path node and the Libraries tab:

__3. Click the Add External JARs… button.

__4. Navigate to the directory  C:\Software\db-derby-10.7.1.1-bin\lib and select 
derbyclient.jar then press Open. 

__5.  Press OK in the Properties dialog.
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Part 2 - Start Derby Server
It is possible to use the database we are using, Derby, in both client/server mode and "embedded" 
mode.  The client/server mode allows multiple concurrent connections which is more like other 
database types so this is the mode we will use.

__1. Open a Windows File Explorer window and navigate to the 
C:\Software\db-derby-10.7.1.1-bin\bin directory.

__2. Double click the startNetworkServer.bat batch file to run the Derby network server.

Note: You must run this command to start the Derby server every time you run a program that 
will access the database otherwise it will not be able to connect.  This is especially important if 
you have restarted the machine between days of class.

__3. Minimize but do not close the command window that appears.  Closing the window will 
stop the Derby server.

Part 3 - Complete DBUtils Implementation
A class has been provided for you that will simplify some of the steps of working with the 
database.  This class implementation is incomplete so that you can add some code to see 
common code that would be required when writing JDBC code with a database.

__1. Back in Eclipse, open the DBUtils class under the com.webagesolutions.users package.

__2. Find the 'readUser' method.  This method will be used to initialize a Java object based on 
the data from the database.

__3. Find the comment 'Set user properties from ResultSet' and add the following code in bold 
after the comment.  Be careful with the spelling of the column names.

if ("Y".equals(isAdmin)) {
u=new Administrator();

} else {
u=new RegularUser();

}
// Set user properties from ResultSet
u.setEmail(rs.getString("EMAIL"));
u.setFirstName(rs.getString("FIRSTNAME"));
u.setLastName(rs.getString("LASTNAME"));
u.setUserName(rs.getString("USERNAME"));
u.setPassword(rs.getString("PASSWORD"));
return u;
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__4. Find the 'writeUser' method.  This method will be used to initialize a Java object based on 
the data from the database.

__5. Examine the Strings used for the update and insert statements.  These have been provided 
for you to avoid typos but are critical in writing JDBC code.  In particular notice that a lot of the 
Strings used in concatenation end with an extra space to make sure that two keywords are not 
concatenated without a space between them.  This is a common error in JDBC statements.

__6. Find the comment 'Set query parameters from User properties' and add the following 
code in bold after the comment.  Be careful to match the correct number for the query parameter 
to the correct property of the user object.

PreparedStatement insert=conn.prepareStatement(insQuery);

/* Try the update. */
// Set query parameters from User properties
update.setString(1, aUser.getFirstName());
update.setString(2, aUser.getLastName());
update.setString(3, aUser.getEmail());
update.setString(4, aUser.getPassword());
update.setString(5, aUser.isAdministrator()?"Y":"N");
update.setString(6, aUser.getUserName());
int count=update.executeUpdate();

Note: Notice that the logic of the method tries an update statement and checks if any rows were 
updated.  If not, an insert statement is run.  The code you added only worked with the update 
statement although the code for the insert statement is similar.  

__7. Replace the getConnection method as follows:

public static Connection getConnection() throws ClassNotFoundException, 
SQLException {

Connection conn = DriverManager.getConnection
  ("jdbc:derby://localhost:1527/C:/LabFiles/Users;create=true");
return conn;

}

__8. Save the class.  There should be no errors or warnings in this class.
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Part 4 - Implement the UserStore Service
We will create a class called “DBUserStore” that wraps a database connection object and uses it 
to supply the UserStore services that client programs will use to manipulate the stored users.

__1. Back in Eclipse, create a new package in your AdvJava project called 
com.webagesolutions.jdbc

__2. Create a class called DBUserStore in the just created com.webagesolutions.jdbc package 
that implements the UserStore interface.

__3. Declare a private instance variable called connection to store a reference to an instance of 
java.sql.Connection.

public class DBUserStore implements UserStore {
private Connection connection;

__4. Organize imports (CTRL+SHIFT+O). Select java.sql.Connection.

__5. Add the following constructor:

public DBUserStore(Connection conn) {
connection=conn;

}

__6. Save the class.  There should be no errors or warnings.
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__7. In the DBUserStore class, implement the “putUser” method to validate the user’s 
password (similar to the previous lab) and then delegate the write operation to DBUtils if the 
validation passes.  The code should look something like this when done:

public void putUser(User user, String verifyPassword)
throws UserAddException {

if (verifyPassword.equals(aUser.getPassword())) {
try {

DBUtils.writeUser(connection, aUser);
} catch (SQLException e) {

e.printStackTrace();
throw new UserAddException(e);

}
} else {

throw new UserAddException("Password incorrect.");
}

}

__8. Organize imports. 

__9. Save the class.  There should be no errors or warnings in this file.

__10. From the com.webagesolutions.users package, right click on CreateUsersTable.java and 
select Run as > Java Application.  

__11. You should see the success message.  

__12. Now you will populate the table. From the com.webagesolutions.users package, right 
click on PopulateUsersTable.java and select Run as > Java Application.  

__13. You should see the success message.  

__14. Open the classes above if you want to look at the code that performed these tasks.
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Part 5 - Browse the data
After the PopulateUsersTable class has been run, you should be able to see the newly created 
records in the database by using a tool to connect directly to the database.

__1. Open a Windows command prompt.  You can do this by selecting Start → Run, entering 
'cmd' without the quotes and clicking the OK button.

__2. Use the 'cd' command to switch to the C:\Software\db-derby-10.7.1.1-bin\bin directory.

__3. Issue the command  'ij.bat'  to launch the Derby command line tool.

__4. Issue the following command to connect to the database:

connect 'jdbc:derby://localhost:1527/C:/LabFiles/Users';

__5. Issue the following command to list the content of the Users table:

select * from Users;

__6. Issue the following command to exit:

exit;

__7. Close the command window.  Make sure to leave the command window running Derby 
open.
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Part 6 - Implementing code
__1. In the com.webagesolutions.users package, there is a class called TestDBUserStore that 
will list all the users that are contained in the database, then search for one particular user by 
email.  If you run that class now, you get a NullPointerException, because we haven’t 
implemented the listAllUsers method yet. Run the TestDBUserStore class to see the exception.

The listAllUsers method needs to return an Iterable object, which is an object that implements 
the iterator() method.  This is a good use for an inner class; the iterator() method will return an 
instance of an inner class that has access to an open ResultSet and iterates through that ResultSet.

__2. In the DBUserStore class, enter the following code for the listAllUsers() method:

public Iterable<User> listAllUsers() {
return new Iterable<User>() {

public Iterator<User> iterator() {
return new ListAllIterator();

}
};

}

__3. Perform Organize imports. Select java.util.Iterator. You will still have an error that will be 
fixed next.

The above method returns an instance of an anonymous inner class that implements the 
Iterable<User> interface (i.e. the generic Iterable<T> interface specialized to iterate over 
instances of the User interface).  As you can verify in the JavaDocs, the Iterable<T> interface 
consists of one method, iterator<T>().  This anonymous inner class returns a new instance of an 
inner class ‘ListAllIterator’ that will implement the iterator.  The next step is to define that inner 
class.

Unfortunately, when we do all the exception handling and implement the required methods, we 
have a large amount of typing for the inner class.  
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__4. Enter the following class definition inside the DBUserStore class, so as to create an inner 
class called ‘ListIterator’.  Instances of this inner class will have access to the instance variables 
of the outer class, namely the open connection object:

Remember to put this code inside the DBUserStore class definition but outside any other 
methods, otherwise it will not have access to the fields of the DBUserStore class it requires.

Note: The file 'C:\LabFiles\ListAllIterator.txt' has been provided if you want to copy code from 
there.  It is ONLY the code for the inner class though and is NOT the full solution to the 
DBUserStore class.  You will still need to be careful to paste the code within the DBUserStore 
class.

private class ListAllIterator implements Iterator<User> {
Iterator<User> iterator = null;

ListAllIterator() {
try (Statement st = connection.createStatement();

ResultSet rs = st.executeQuery("SELECT * FROM USERS")) {
List<User> users = new ArrayList<>();
while (rs.next()) {

users.add(DBUtils.readUser(rs));
}
iterator = users.iterator();

} catch (SQLException e) {
e.printStackTrace();
throw new RuntimeException(e);

}
}

@Override
public boolean hasNext() {

return iterator.hasNext();
}

@Override
public User next() {

return iterator.next();
}

@Override
public void remove() {

throw new UnsupportedOperationException();
}

}

Note: The constructor uses a Java 7 'try-with-resources' statement to make sure the Statement 
and ResultSet are closed at the end of the constructor.  This avoids leaving database resources 
open and instead constructs an Iterator from the query results to use when iterating.

__5. Perform Organize imports. Select java.util.List, java.sql.ResultSet and 
java.sql.Statement. 

__6. Save the class.  You should have no errors at this point.
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Now all that’s left is to implement the getUser(…) method that looks up a user by email address. 
To do this, we need to run a query against the database and create a User object with the resulting 
row, if any.  

__7. Enter the following for the getUser(…) method in DBUserStore:

public User getUser(String email) {
String query = "SELECT * from USERS where EMAIL=?";
try (PreparedStatement st = connection.prepareStatement(query)) {

st.setString(1, email);
ResultSet rs = st.executeQuery();
if (rs.next()) {

return DBUtils.readUser(rs);
} else {

return null;
}

} catch (SQLException e) {
e.printStackTrace();
return null;

}
}

Note: This code uses a Java 7 'try-with-resources' statement that will automatically close the 
PreparedStatement object at the end just as if it were explicitly done with a 'finally' block.

__8. Organize imports.  Select java.sql.PreparedStatement when prompted.

__9. Save the class.  You should have no errors.

Note that in the above method, we make sure to close the statement in ‘finally’ block, so that the 
statement is closed no matter which exit path the routine takes.  The result set is automatically 
closed when we close the Statement object.

__10. Run the TestDBUserStore class again.  You should now see the final lookup returns the 
record for Jim Waldo in addition to all the records being listed.

__11. Close all open files.
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Part 7 - Summary
We have created an alternate implementation of the UserStore service that uses a database as the 
storage mechanism.  You should note that the utility classes in the Lab Starter files do not need to 
know which type of implementation they are dealing with; as an example, see the 
UserStoreUtils.populate() method.  Similarly, your business logic and user interface logic classes 
would not need to be rewritten to adopt the database-backed storage.

We used an inner class to implement the Iterable and Iterator interfaces to load business model 
objects from the database.  This also has the advantage of making it possible for code which uses 
the 'listAllUsers' method to iterate over the collection of users with Java 5’s ‘for-each’ syntax.

Finally, we demonstrated the use of a PreparedStatement object to insert variables into a SQL 
query without having to manipulate the query string using concatenation or formatting.  Apart 
from being easier to read, this approach gives better resistance to SQL script execution attacks in 
form-filling applications.  It also prevents us having to deal with any formatting concerns, for 
instance if we were using date values as parameters.
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Lab 3 - Using JPA
Java Persistence, or JPA, is a Java standard that makes it possible to easily store data from Java 
objects in databases.  This standard was developed when various third party frameworks, like 
Hibernate, first introduced the concept in to the Java community.  Although many times JPA is 
mentioned in relation to Java Enterprise, or Java EE because Java EE servers are required to 
support it, JPA can be used from standalone Java SE applications also.

In this lab you will use JPA from a regular Java project.  Since a Java SE environment is not 
required to support JPA, you will be using a JPA "Provider", Hibernate to actually implement the 
persistence.  Notice though that your code does not refer to Hibernate APIs and the only mention 
of Hibernate will be in some JPA configuration settings.

Part 1 - Lab Setup
To simplify the code that you need to create you will be given a "starter project" to import with 
much of the code.  This will let you focus on the JPA configuration and code.

__1. Open Eclipse if it is not already running.

__2. Select File → Import from the Eclipse menus.

__3. Expand the General group and select Existing Projects into Workspace and press the 
Next button.

__4. Select the radio button next to the Select archive file option and use the matching Browse 
button to find and open the file 'C:\LabFiles\JPAUserStore-Starter.zip'.

__5. Select the project listed in the file if it is not already as shown below.

__6. Press the Finish button to import the project.

__7. In the Markers view check that you have no errors for this project.  You may have errors for 
other projects.
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Part 2 - Modify Project Properties
Right now the project you imported is just a Java project.  There are tools available with Eclipse 
which can add support for JPA.  You will enable these JPA tools for the project because among 
other things they will automatically add the JPA configuration file, called persistence.xml, to the 
project.  You will also add a JAR file for the database we will use and a JPA implementation to 
the project build path.

__1. In Eclipse select Window → Preferences.

__2. In the list of preferences select Java → Build Path → User Libraries.

__3. Press the New button.

__4. Fill in a library name of Hibernate and click the OK button.

__5. With the newly create Hibernate library still selected press the Add External JARs... 
button.

__6. Browse to the 'C:\LabFiles\Hibernate-lib' directory, select all the JAR files by holding the 
CTRL key while selecting them (or use CTRL-A), then click the Open button to complete the 
selection.

__7. Make sure that all 11 of the JAR files are listed as part of the library.
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__8. Click the OK button to close the Eclipse preferences.

__9. Right click on the JPAUserStore project and select Properties.

__10. Select Project Facets from the left side of the project properties.

__11. Check the box for the 'Utility Module' and 'JPA' facets and make sure the version of the 
JPA facet is 2.1.  Do not close the properties yet though.

Note: If this were a Java EE web or EJB module project you would not need the 'Utility 
Module' facet in order to enable the JPA facet.

Also note that the version of JPA when deployed to a Java EE server may be controlled by the 
server.  A Java EE 5 server would supply JPA 1.0, a Java EE 6 server would supply JPA 2.0, and 
a Java EE 7 server would supply JPA 2.1.  In this case we are free to choose JPA 2.1 because 
this is a stand-alone Java project.  The version of Hibernate you are using uses JPA 2.1.

__12. Click on the title of the 'JPA' facet so it is selected and then click the link for 'Further 
configuration required' below.
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__13. On the configuration of the JPA facet, under the setting for 'JPA Implementation' select 
the 'User Library' Type and check the Hibernate library check box; click the OK button when 
your screen looks like shown below.

Note: Notice that the library will be included with the application.  This would be important 
since the project is not running in an environment where JPA support is already available.

Notice you can also use the Eclipse database tools to connect to a database and link the JPA 
project to that database configuration for validation but we won't do this.

__14. Still on the Project Facets page click the Apply button in the lower right.  This will 
configure the build path of the project for Hibernate which is important.

__15. Once you have configured the JPA facet and are back in the project properties select the 
Java Build Path project properties on the left.

__16. Select the Libraries tab of the Java build path properties and click the button for 'Add 
External JARs' on the right.

__17. Navigate to the 'c:\Software\db-derby-10.7.1.1-bin\lib' directory and select the 
'derbyclient.jar' file and press the Open button to complete the selection.

26

EVALUATIO
N O

NLY



__18. Check that the Derby JAR file and Hibernate library is listed as shown and then click the 
OK button to close the project properties. 

Note: We are adding the Derby database drivers this way instead of using a build dependency 
tool like Maven because we won't be writing any code that depends on Derby.  A JPA project 
will need to connect to a database but usually this is done by providing a database connection 
that is configured as part of the environment, like a Java EE server DataSource, so that is not 
done in the project.  We are adding this JAR because we will be configuring a database 
connection with JPA configuration but this is simply because this project will not be deployed to 
a server so this configuration is more for the particular way we are testing this project and not a 
permanent application configuration.

__19. In the Markers view check that you have only warnings and no errors for the 
JPAUserStore project.  You will have more warnings than before because of some of the 
classpath settings but this will be fine.

Part 3 - Configure JPA Entity
In JPA the objects that are saved to the database are "Entities".  The first step in using JPA in the 
project will be to convert Java classes already in the project into Entities.  This is done by adding 
a few simple annotations to the class.

__1. In the Package Explorer view, expand the following folders:

JPAUserStore -> src -> com.webage.users

__2. Open the RegularUser.java file in the com.webage.users package by double clicking it. 
Notice that this is just a regular Java class with a few properties and get/set methods.
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__3. Add the following code annotations in bold to the existing class.  You will have some errors 
until fixed in the next step.

import java.io.PrintStream;

@Entity
public class RegularUser {

private String firstName;
private String lastName;
@Id
private String email;
private String userName;

Note: Only the @Entity and @Id annotations are required for JPA.  There are also other JPA 
annotations that can control the table and column mapping but we will not use these.

__4. Select Source → Organize Imports from the menus.  When prompted select 
javax.persistence.Entity and click the Finish button.

Note: Notice that even though Hibernate has similar code that could be added we are adding 
standard JPA annotations.

__5. Save the class.  You will have another error that will be fixed in a future step.

__6. Open the Administrator.java file in the com.webage.users package by double clicking it.

__7. Add the following code annotation in bold to the existing class.  You will have some errors 
until fixed in the next step.

package com.webage.users;

@Entity
public class Administrator extends RegularUser {

Note: This class does not need to have an @Id property since that is already in the RegularUser 
class which this class extends.
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__8. Select Source → Organize Imports from the menus.  When prompted select 
javax.persistence.Entity and click the Finish button.

__9. Save the class.  You will have another error that will be fixed in a future step.

__10. In the Package Explorer view, expand the following folders:

JPAUserStore -> src -> META-INF

__11. Right click the persistence.xml file and select JPA Tools → Synchronize Class List from 
near the bottom.

__12. Check that the error in the RegularUser and Administrator classes are gone.  Now these 
classes are explicitly listed in the persistence.xml file so JPA will know to manage them.

Part 4 - Complete JPA UserStore Implementation
Although JPA will perform all of the complicated database work for us we still need to have 
some code in the application that works with JPA to indicate which Java objects should be saved 
to the database and perform queries to find existing data.  This is done through the JPA "Entity 
Manager".  Currently there is a skeletal implementation of a 'UserStore' interface that provides 
some of these kinds of methods.  This section will use JPA to implement some of those methods.

__1. In the Package Explorer view, expand the following folders:

JPAUserStore -> src -> com.webage.jpa

__2. Open the JPAUserStore.java file in the com.webage.jpa package by double clicking it. 
Notice that right now it is just an empty implementation of the 'UserStore' interface.
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__3. Add the following new field to the class shown in bold.  This will add the JPA 
EntityManager used to persist data.  You will still have errors in the code.

public class JPAUserStore implements UserStore {
// Put JPA EntityManagerFactory here
private EntityManagerFactory emFactory = Persistence

.createEntityManagerFactory("JPAUserStore");
@Override
public void putUser(RegularUser aUser, String verifyPassword)

Note: In a Java SE environment the EntityManagerFactory is the class that is the entry point 
into JPA.  The parameter of 'JPAUserStore' will match the name of the "Persistence Unit" in the 
persistence.xml file.

__4. Locate the 'putUser' method and replace the implementation with the bold code below. 
This uses a method already supplied by the EntityManager to persist data.

@Override
public void putUser(RegularUser aUser, String verifyPassword)
          throws UserAddException {
     // implement saving user with JPA
     EntityManager em = emFactory.createEntityManager();
     try {
          em.getTransaction().begin();
          em.persist(aUser);
          em.getTransaction().commit();
     } catch (Exception e) {
          throw new UserAddException(e);
     } finally {
          em.close();
     }
}

Note: In a Java SE environment you need to manually create and close the EntityManager as 
well as begin and commit the transaction.  In a Java EE environment these lines of code are 
sometimes omitted if using JPA from an EJB.

__5. Select Source → Organize Imports from the menus.  

__6. Save the class and make sure there are no errors.
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Part 5 - Modify JPA Configuration
The last step to do is to modify the JPA configuration so it contains the various JPA and database 
configurations.

__1. Open the 'src/META-INF/persistence.xml' file.  

__2. Make sure the editor shows the file in the General tab and switch to this tab if needed.

__3. For the value of the "Persistence provider" fill in a value of 
'org.hibernate.jpa.HibernatePersistenceProvider' without the quotes as shown below.

__4. Switch to the Connection tab in the editor.

__5. In the drop-down for 'Transaction type' select the option for 'Resource Local'.

Note: This option indicates the JPA transaction will be linked only to the database transaction 
and not part of a distributed transaction that might be present in a server environment.  This is 
the appropriate option since we will be running in a stand-alone Java application.
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__6. Further down on the page fill in the following properties in the 'JDBC connection 
properties' setting.

Driver: org.apache.derby.jdbc.ClientDriver

URL: jdbc:derby://localhost:1527/JPAUserStore;create=true

User: jpa

Password: jpa

Note: These properties can be set like this because we are using JPA 2.0+ which has 
standardized the name of JPA properties for these settings.  If you were using JPA 1.0 the 
properties for a database connection would be set using property names specific to the JPA 
provider.

Notice also that if you link the JPA project to a database connection from Eclipse's database 
tools you can populate JPA properties with those settings.

__7. Switch to the Properties tab in the editor.  Notice the existing standardized connection 
properties are already present.

__8. Click the Add button to add a row for a new property.
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__9. Fill in the following 'Name' and 'Value' for the new property by typing it in after clicking the 
appropriate column.

Name:hibernate.hbm2ddl.auto

Value: create

__10. Click the Add button a second time to add another new property.

__11. Fill in the following 'Name' and 'Value' for the new property by typing it in after clicking 
the appropriate column.

Name:hibernate.show_sql

Value: true

__12. Save the file and be sure there are no errors from incorrect syntax.

Note: The 'hibernate.hbm2ddl.auto' property indicates to Hibernate if it should automatically 
modify the database schema to reflect the structure of the JPA classes.  The value of 'create' we 
are using will recreate the database tables every time.  This will be good for testing although 
you might often use a different value or not use this property in other environments like 
production.

The 'hibernate.show_sql' property will enable logging of the SQL statements issued by 
Hibernate which can help in debugging issues in complex queries, etc.
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Part 6 - Test JPA Functionality
All of the JPA code and configuration is complete.  In this section you will add to a test class that 
will test the JPA functionality.

__1. Make sure you have the Derby server running, if not then navigate to the 
'C:\Software\db-derby-10.7.1.1-bin\bin' folder and run the 'startNetworkServer.bat' 
command by double clicking it.  Make sure to run the correct command as there are several 
similarly named batch files. Wait for the Derby server to report that it is waiting for connections.

__2. Do not close the command prompt window that is running Derby.

__3. Back in Eclipse, in the Package Explorer view, expand the following folders:

JPAUserStore -> src -> com.webage.jpa

__4. Open the JPAUsersTest.java file in the com.webage.jpa package by double clicking it. 
Notice that right now it is just a Java class with an empty 'main' method.

__5. Add the following new code to the empty 'main' method.  This code simply creates a new 
instance of the JPA 'UserStore' implementation and then passes it to the UserStoreUtils.populate 
method which will create some new users to add to the persistent storage.

public static void main(String[] args) {
// Add code to test JPAUserStore
UserStore store = new JPAUserStore();
UserStoreUtils.populate(store);
System.out.println("Users table was populated succesfully.");

}

__6. Select Source → Organize Imports from the menus.  

__7. Save the file and make sure there are no errors although you will get warnings.
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__8. Right click the JPAUsersTest class and select 'Run As → Java Application'

__9. Look in the Console view and you should see the message that the Users table was 
populated successfully.  You will also see the Hibernate SQL statements (although without the 
actual values) after several other messages from Hibernate about setting up the database 
connection and exporting the database schema to the database.

Part 7 - Implement Other UserStore Methods
Right now the code only persists users to the database.  Although no Exception is thrown we 
don't actually select data from the database to verify that the database contains the data.  In this 
section you will implement methods that query the data.

__1. Return to the JPAUserStore.java file in the com.webage.jpa package and open it if you 
had closed it.
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__2. Provide the following implementation to the 'listAllUsers' method.  Be careful with the 
'createQuery' method syntax as it has several parameters that wrap to several lines below.  You 
will have errors until the next step.

@Override
public Iterable<RegularUser> listAllUsers() {

// implement query with JPA
EntityManager em = emFactory.createEntityManager();
em.getTransaction().begin();
TypedQuery<RegularUser> q = em.createQuery(

"select u from RegularUser u", 
RegularUser.class);

List<RegularUser> results = q.getResultList();
em.getTransaction().commit();
em.close();
return results;

}

Note: This method uses the JPA Query API and the "JPA QL" query syntax to form a query that 
will select all users from the database.  Even though the query looks like SQL it is written in the 
syntax of the JPA entities in the application so does not have to match the database table 
structure like SQL would.  This is especially useful when the table and column names in the 
database do not match the class and property names in Java.

__3. Select Source → Organize Imports from the menus.  When prompted select  java.util.List 
and click the Finish button.
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__4. Next, provide the following implementation to the 'getUser' method.  

@Override
public RegularUser getUser(String email) {

// implement query with JPA
EntityManager em = emFactory.createEntityManager();
em.getTransaction().begin();
RegularUser result = em.find(RegularUser.class, email);
em.getTransaction().commit();
em.close();
return result;

}

__5. Save the file and make sure there are no errors.

__6. Return to the JPAUsersTest.java file in the com.webage.jpa package and open it if you 
had closed it.

__7. Add the following new code to the 'main' method after the current code that populates the 
database.  This code uses the method to get all users and then prints those users from a loop.  It 
also searches for a specific user that had been created in the  UserStoreUtils.populate method.

public static void main(String[] args) {
// Add code to test JPAUserStore
UserStore store = new JPAUserStore();
UserStoreUtils.populate(store);
System.out.println("Users table was populated succesfully.");

System.out.println("Listing all users");
Iterable<RegularUser> users = store.listAllUsers();
for (RegularUser regularUser : users) {

regularUser.printTo(System.out);
}
System.out.println("Searching for: wyantg@sun.com");
RegularUser match = store.getUser("wyantg@sun.com");
if (match != null) {

match.printTo(System.out);
}

}

__8. Select Source → Organize Imports from the menus.

__9. Save the file and make sure there are no errors.
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__10. From the menus select 'Run → Run History → JPAUsersTest'.

__11. This time in the Console view you should see in addition to the output from last time, a list 
of all the users that were selected from the database and then the details of the individual user 
that was searched for by email.

__12. Close all open files.

__13. In a Windows Explorer window, navigate to the 'C:\Software\db-derby-10.7.1.1-bin\bin' 
folder.

__14. Run the 'stopNetworkServer.bat' command by double clicking it.  Make sure to run the 
correct command as there are several similarly named batch files. This will close the Derby 
server.

Part 8 - Review
JPA programming can greatly simplify working with data in databases as the JPA implementation 
does the work of storing the data.  The JPA API really hides a lot of the complexity for us.

Besides the use of the JPA EntityManager API most of the work is configuring the various JPA 
properties in the persistence.xml file.  Since this is a regular Java application there is a little more 
code to create the EntityManager from the EntityManagerFactory and begin and commit the 
transaction but this is pretty standard for any JPA operation.
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	Lab 1 -  Collections
	Part 1 -  Create a Java Application Project
	__1.  From C:\Software\eclipse execute eclipse.exe
	__2.  You will be prompted to select a workspace.  Change the the Workspace to C:\workspace
	__3.  Click the OK button.
	__4.  You will see the Welcome screen. Close it.
	__5.  From the menu, select File -> Import.
	__6.  Expand and select General → Existing Projects into Workspace and click the Next button.
	__7.  Click the Browse button next to the 'Select root directory' option and navigate to the C:\LabFiles\LabStarterFiles directory (the actual location of the directory may vary on your machine; check with your instructor) then click OK. 
	__8.  Check the option for 'Copy projects into workspace' if not already selected.
	__9.  Click the Finish button once your options match that shown below. 
	__10.  Expand AdvJava from the Project Explorer view.
	You can ignore any errors at the moment. These are pertaining to other labs and we will fix them at that point.

	Part 2 -  Create a Java Package
	__1.  In the Package Explorer, right click on the AdvJava project and select New -> Package from the context menus.
	__2.  Enter  com.webagesolutions.collections  in the Name field:
	__3.  Press the Finish button.

	Part 3 -  Create a Collections-based implementation of UserStore
	__1.  Expand AdvJava > com.webagesolutions.users and examine the interface UserStore.  This interface defines a generic service that stores instances of User objects and allows a client to retrieve the User objects based on the user’s email address.  We will first implement a memory-based UserStore using the collections library. 
	Next we will create a new class called ‘InMemoryUserStore’ in the ‘com.webagesolutions.collections’ package, and have the class implement the UserStore interface.  
	__2.  To create this class, right click on the ‘com.webagesolutions.collections’ package and select New -> Class… 
	__3.  Enter the following:
	__4.  Next to Interfaces click Add. 
	__5.  Start typing UserStore and you should see UserStore  - com.webagesolutions.users. Select it and click OK.
	__6.  Check Inherited abstract methods.
	__7.  Uncheck all other options
	__8.  Click Finish once your options match those shown below.
	Since we select the checkbox above to automatically generate method stubs for the interface’s methods (‘Inherited abstract methods’), the generated class should look like:
	__9.  First we will implement the putUser and listAllUsers methods by storing the users in an ArrayList object.  Declare an instance variable called ‘userList’ that stores a reference to a List that contains User objects.  Make sure this is defined inside the class definition but outside of any methods.  You will have errors until the next step.
	__10.  Add the appropriate import statements to import java.util.List and java.util.ArrayList (Reminder: you can have Eclipse add them automatically by right clicking in the editor window and selecting Source -> Organize Imports in the context menu or clicking Ctrl-Shift-O).
	__11.  Implement the putUser method to add the user into the list.  Before adding the user into the list, we need to check the verification password against the password stored in the user object.  The code should look like this:
	__12.  Implement the listAllUsers method to return a read-only version of the users collection.  Recall that the Collections class contains a utility method to provide an unmodifiable view of a List.  The resulting code should look like:
	__13.  Organize imports by clicking Ctrl+Shift+O to import java.util.Collections.
	__14.  Save the file. There should be no errors in the class.
	The Lab Starter files that you imported contained a class called TestInMemoryUserStore, that creates a number of users then prints out the results of running ‘getAllUsers’.  
	__15.  To run the program, right-click on the TestInMemoryUserStore class in the Project Explorer under the com.webagesolutions.users package, then select Run As -> Java Application from the context menu.  
	__16.  You will be prompted that there are still errors in your workspace, check Always  launch without asking and click Proceed. 
	__17.  The output in the Console view should look like:
	__18.  Now we’ll add the ability to lookup a user by email address.  To do this, we’ll add a HashMap that references the stored users to their email address.  Add the following instance variable to the InMemoryUserStore class:
	__19.  Organize imports. (Ctrl+Shift+O) 
	__20.  In the putUser method of InMemoryUserStore, we need to add code to store the User object in the index. Add the following code to the putUser(…) method:
	__21.  Implement the getUser(…) method to look up the user based on the supplied email address:
	__22.  Save the class.
	__23.  Run the TestInMemoryUserStore class again.  You can do this by right-clicking the TestInMemoryUserStore class and selecting Run As -> Java Application.
	__24.  This time the lookup at the end, it should return a user as shown in bold.
	__25.  Close all open files by select Ctrl+Shift+F4. Use this combination every time you need to close all open files.

	Part 4 -  Summary

	Lab 2 -  Accessing Database
	Part 1 -  Add the Derby JDBC Drivers to the Eclipse Project
	__1.  Right click on the ‘AdvJava’ project in the Project Explorer and select Properties.
	__2.  In the properties window, select the Java Build Path node and the Libraries tab:
	__3.  Click the Add External JARs… button.
	__4.  Navigate to the directory  C:\Software\db-derby-10.7.1.1-bin\lib and select derbyclient.jar then press Open. 
	__5.   Press OK in the Properties dialog.

	Part 2 -  Start Derby Server
	__1.  Open a Windows File Explorer window and navigate to the C:\Software\db‑derby‑10.7.1.1‑bin\bin directory.
	__2.  Double click the startNetworkServer.bat batch file to run the Derby network server.
	__3.  Minimize but do not close the command window that appears.  Closing the window will stop the Derby server.

	Part 3 -  Complete DBUtils Implementation
	__1.  Back in Eclipse, open the DBUtils class under the com.webagesolutions.users package.
	__2.  Find the 'readUser' method.  This method will be used to initialize a Java object based on the data from the database.
	__3.  Find the comment 'Set user properties from ResultSet' and add the following code in bold after the comment.  Be careful with the spelling of the column names.
	__4.  Find the 'writeUser' method.  This method will be used to initialize a Java object based on the data from the database.
	__5.  Examine the Strings used for the update and insert statements.  These have been provided for you to avoid typos but are critical in writing JDBC code.  In particular notice that a lot of the Strings used in concatenation end with an extra space to make sure that two keywords are not concatenated without a space between them.  This is a common error in JDBC statements.
	__6.  Find the comment 'Set query parameters from User properties' and add the following code in bold after the comment.  Be careful to match the correct number for the query parameter to the correct property of the user object.
	__7.  Replace the getConnection method as follows:
	__8.  Save the class.  There should be no errors or warnings in this class.

	Part 4 -  Implement the UserStore Service
	__1.  Back in Eclipse, create a new package in your AdvJava project called com.webagesolutions.jdbc
	__2.  Create a class called DBUserStore in the just created com.webagesolutions.jdbc package that implements the UserStore interface.
	__3.  Declare a private instance variable called connection to store a reference to an instance of java.sql.Connection.
	__4.  Organize imports (CTRL+SHIFT+O). Select java.sql.Connection.
	__5.  Add the following constructor:
	__6.  Save the class.  There should be no errors or warnings.
	__7.  In the DBUserStore class, implement the “putUser” method to validate the user’s password (similar to the previous lab) and then delegate the write operation to DBUtils if the validation passes.  The code should look something like this when done:
	__8.  Organize imports. 
	__9.  Save the class.  There should be no errors or warnings in this file.
	__10.  From the com.webagesolutions.users package, right click on CreateUsersTable.java and select Run as > Java Application.  
	__11.  You should see the success message.  
	__12.  Now you will populate the table. From the com.webagesolutions.users package, right click on PopulateUsersTable.java and select Run as > Java Application.  
	__13.  You should see the success message.  
	__14.  Open the classes above if you want to look at the code that performed these tasks.

	Part 5 -  Browse the data
	__1.  Open a Windows command prompt.  You can do this by selecting Start → Run, entering 'cmd' without the quotes and clicking the OK button.
	__2.  Use the 'cd' command to switch to the C:\Software\db-derby-10.7.1.1-bin\bin directory.
	__3.  Issue the command  'ij.bat'  to launch the Derby command line tool.
	__4.  Issue the following command to connect to the database:
	__5.  Issue the following command to list the content of the Users table:
	__6.  Issue the following command to exit:
	__7.  Close the command window.  Make sure to leave the command window running Derby open.

	Part 6 -  Implementing code
	__1.  In the com.webagesolutions.users package, there is a class called TestDBUserStore that will list all the users that are contained in the database, then search for one particular user by email.  If you run that class now, you get a NullPointerException, because we haven’t implemented the listAllUsers method yet. Run the TestDBUserStore class to see the exception.
	__2.  In the DBUserStore class, enter the following code for the listAllUsers() method:
	__3.  Perform Organize imports. Select java.util.Iterator. You will still have an error that will be fixed next.
	__4.  Enter the following class definition inside the DBUserStore class, so as to create an inner class called ‘ListIterator’.  Instances of this inner class will have access to the instance variables of the outer class, namely the open connection object:
	__5.  Perform Organize imports. Select java.util.List, java.sql.ResultSet and java.sql.Statement. 
	__6.  Save the class.  You should have no errors at this point.
	__7.  Enter the following for the getUser(…) method in DBUserStore:
	__8.  Organize imports.  Select java.sql.PreparedStatement when prompted.
	__9.  Save the class.  You should have no errors.
	Note that in the above method, we make sure to close the statement in ‘finally’ block, so that the statement is closed no matter which exit path the routine takes.  The result set is automatically closed when we close the Statement object.
	__10.  Run the TestDBUserStore class again.  You should now see the final lookup returns the record for Jim Waldo in addition to all the records being listed.
	__11.  Close all open files.

	Part 7 -  Summary

	Lab 3 -  Using JPA
	Part 1 -  Lab Setup
	__1.  Open Eclipse if it is not already running.
	__2.  Select File → Import from the Eclipse menus.
	__3.  Expand the General group and select Existing Projects into Workspace and press the Next button.
	__4.  Select the radio button next to the Select archive file option and use the matching Browse button to find and open the file 'C:\LabFiles\JPAUserStore-Starter.zip'.
	__5.  Select the project listed in the file if it is not already as shown below.
	__6.  Press the Finish button to import the project.
	__7.  In the Markers view check that you have no errors for this project.  You may have errors for other projects.

	Part 2 -  Modify Project Properties
	__1.  In Eclipse select Window → Preferences.
	__2.  In the list of preferences select Java → Build Path → User Libraries.
	__3.  Press the New button.
	__4.  Fill in a library name of Hibernate and click the OK button.
	__5.  With the newly create Hibernate library still selected press the Add External JARs... button.
	__6.  Browse to the 'C:\LabFiles\Hibernate-lib' directory, select all the JAR files by holding the CTRL key while selecting them (or use CTRL-A), then click the Open button to complete the selection.
	__7.  Make sure that all 11 of the JAR files are listed as part of the library.
	__8.  Click the OK button to close the Eclipse preferences.
	__9.  Right click on the JPAUserStore project and select Properties.
	__10.  Select Project Facets from the left side of the project properties.
	__11.  Check the box for the 'Utility Module' and 'JPA' facets and make sure the version of the JPA facet is 2.1.  Do not close the properties yet though.
	__12.  Click on the title of the 'JPA' facet so it is selected and then click the link for 'Further configuration required' below.
	__13.  On the configuration of the JPA facet, under the setting for 'JPA Implementation' select the 'User Library' Type and check the Hibernate library check box; click the OK button when your screen looks like shown below.
	__14.  Still on the Project Facets page click the Apply button in the lower right.  This will configure the build path of the project for Hibernate which is important.
	__15.  Once you have configured the JPA facet and are back in the project properties select the Java Build Path project properties on the left.
	__16.  Select the Libraries tab of the Java build path properties and click the button for 'Add External JARs' on the right.
	__17.  Navigate to the 'c:\Software\db-derby-10.7.1.1-bin\lib' directory and select the 'derbyclient.jar' file and press the Open button to complete the selection.
	__18.  Check that the Derby JAR file and Hibernate library is listed as shown and then click the OK button to close the project properties. 
	__19.  In the Markers view check that you have only warnings and no errors for the JPAUserStore project.  You will have more warnings than before because of some of the classpath settings but this will be fine.

	Part 3 -  Configure JPA Entity
	__1.  In the Package Explorer view, expand the following folders:
	__2.  Open the RegularUser.java file in the com.webage.users package by double clicking it.  Notice that this is just a regular Java class with a few properties and get/set methods.
	__3.  Add the following code annotations in bold to the existing class.  You will have some errors until fixed in the next step.
	__4.  Select Source → Organize Imports from the menus.  When prompted select javax.persistence.Entity and click the Finish button.
	__5.  Save the class.  You will have another error that will be fixed in a future step.
	__6.  Open the Administrator.java file in the com.webage.users package by double clicking it.
	__7.  Add the following code annotation in bold to the existing class.  You will have some errors until fixed in the next step.
	__8.  Select Source → Organize Imports from the menus.  When prompted select javax.persistence.Entity and click the Finish button.
	__9.  Save the class.  You will have another error that will be fixed in a future step.
	__10.  In the Package Explorer view, expand the following folders:
	__11.  Right click the persistence.xml file and select JPA Tools → Synchronize Class List from near the bottom.
	__12.  Check that the error in the RegularUser and Administrator classes are gone.  Now these classes are explicitly listed in the persistence.xml file so JPA will know to manage them.

	Part 4 -  Complete JPA UserStore Implementation
	__1.  In the Package Explorer view, expand the following folders:
	__2.  Open the JPAUserStore.java file in the com.webage.jpa package by double clicking it.  Notice that right now it is just an empty implementation of the 'UserStore' interface.
	__3.  Add the following new field to the class shown in bold.  This will add the JPA EntityManager used to persist data.  You will still have errors in the code.
	__4.  Locate the 'putUser' method and replace the implementation with the bold code below.  This uses a method already supplied by the EntityManager to persist data.
	__5.  Select Source → Organize Imports from the menus.  
	__6.  Save the class and make sure there are no errors.

	Part 5 -  Modify JPA Configuration
	__1.  Open the 'src/META-INF/persistence.xml' file.  
	__2.  Make sure the editor shows the file in the General tab and switch to this tab if needed.
	__3.  For the value of the "Persistence provider" fill in a value of 'org.hibernate.jpa.HibernatePersistenceProvider' without the quotes as shown below.
	__4.  Switch to the Connection tab in the editor.
	__5.  In the drop-down for 'Transaction type' select the option for 'Resource Local'.
	__6.  Further down on the page fill in the following properties in the 'JDBC connection properties' setting.
	__7.  Switch to the Properties tab in the editor.  Notice the existing standardized connection properties are already present.
	__8.  Click the Add button to add a row for a new property.
	__9.  Fill in the following 'Name' and 'Value' for the new property by typing it in after clicking the appropriate column.
	__10.  Click the Add button a second time to add another new property.
	__11.  Fill in the following 'Name' and 'Value' for the new property by typing it in after clicking the appropriate column.
	__12.  Save the file and be sure there are no errors from incorrect syntax.

	Part 6 -  Test JPA Functionality
	__1.  Make sure you have the Derby server running, if not then navigate to the 'C:\Software\db‑derby‑10.7.1.1-bin\bin' folder and run the 'startNetworkServer.bat' command by double clicking it.  Make sure to run the correct command as there are several similarly named batch files. Wait for the Derby server to report that it is waiting for connections.
	__2.  Do not close the command prompt window that is running Derby.
	__3.  Back in Eclipse, in the Package Explorer view, expand the following folders:
	__4.  Open the JPAUsersTest.java file in the com.webage.jpa package by double clicking it.  Notice that right now it is just a Java class with an empty 'main' method.
	__5.  Add the following new code to the empty 'main' method.  This code simply creates a new instance of the JPA 'UserStore' implementation and then passes it to the UserStoreUtils.populate method which will create some new users to add to the persistent storage.
	__6.  Select Source → Organize Imports from the menus.  
	__7.  Save the file and make sure there are no errors although you will get warnings.
	__8.  Right click the JPAUsersTest class and select 'Run As → Java Application'
	__9.  Look in the Console view and you should see the message that the Users table was populated successfully.  You will also see the Hibernate SQL statements (although without the actual values) after several other messages from Hibernate about setting up the database connection and exporting the database schema to the database.

	Part 7 -  Implement Other UserStore Methods
	__1.  Return to the JPAUserStore.java file in the com.webage.jpa package and open it if you had closed it.
	__2.  Provide the following implementation to the 'listAllUsers' method.  Be careful with the 'createQuery' method syntax as it has several parameters that wrap to several lines below.  You will have errors until the next step.
	__3.  Select Source → Organize Imports from the menus.  When prompted select  java.util.List and click the Finish button.
	__4.  Next, provide the following implementation to the 'getUser' method.  
	__5.  Save the file and make sure there are no errors.
	__6.  Return to the JPAUsersTest.java file in the com.webage.jpa package and open it if you had closed it.
	__7.  Add the following new code to the 'main' method after the current code that populates the database.  This code uses the method to get all users and then prints those users from a loop.  It also searches for a specific user that had been created in the  UserStoreUtils.populate method.
	__8.  Select Source → Organize Imports from the menus.
	__9.  Save the file and make sure there are no errors.
	__10.  From the menus select 'Run → Run History → JPAUsersTest'.
	__11.  This time in the Console view you should see in addition to the output from last time, a list of all the users that were selected from the database and then the details of the individual user that was searched for by email.
	__12.  Close all open files.
	__13.  In a Windows Explorer window, navigate to the 'C:\Software\db‑derby‑10.7.1.1-bin\bin' folder.
	__14.  Run the 'stopNetworkServer.bat' command by double clicking it.  Make sure to run the correct command as there are several similarly named batch files. This will close the Derby server.

	Part 8 -  Review

	Lab 4 -  Internationalization
	Part 1 -  Currency Formatting
	__1.  Expand the AdvJava project.
	__2.  Create a new package in your AdvJava project called com.webagesolutions.i18n. Make sure to match the package name exactly as that will be important later.
	__3.  Create a class called CurrencyFormats in the existing package com.webagesolutions.i18n.  Include a public static void main(…) method.
	__4.  In the main method, create three Locale references for America, England, and the default locale, as shown in bold below:
	__5.  Organize imports.
	__6.  Create a double precision floating-point value that we will format:
	__7.  To format currency values, we need a NumberFormat instance configured to format currencies in the given locale.  Create three formatters, one for each locale, as follows:
	__8.  Organize imports.
	__9.  Output the value using each of the formats we’ve created:
	__10.  Organize imports. Select java.util.logging.Logger.
	__11.  Save the class.
	__12.  Run the class using Run As -> Java Application, the output should look like (assuming your default locale is US):
	__13.  You can try changing your computer’s default locale using the Window Control Panel. This differs slightly depending on Windows version but generally involves the  Regional and Language Options tool.   Once in this tool, change the value selected under Formats.  If you do change the language it is suggested to use a language or dialect that you can still understand to make sure you can switch it back later.
	__14.  If you changed the language, run the class again and see if the default format changed.
	__15.  Change back to the default format and test again to check everything is working fine.

	Part 2 -  Date and Time Formatting
	__1.  Create a new class called DateFormats in the com.webagesolutions.i18n package and include the main method.
	__2.  In the main method, create a sampling of DateFormat objects for various locales and date formats as follows:
	__3.  Organize imports.
	__4.  Prompt the user for a date in the local default format, and gather the user’s input value:
	__5.  Organize imports again and select java.util.Scanner, java.util.Date and java.util.logging.Logger.
	__6.  Use the default formatter to convert the input string to a Date object.  When we do the conversion, we need to allow for the fact that the user may have entered an invalid date, which would cause the formatter to throw a ParseException.  We’ll use the current date if this happens:
	__7.  Organize imports again and select java.text.ParseException.
	__8.  Finally, we’ll output the user’s date in the various formats:
	__9.  Save the class.
	__10.  Run the class as a Java application. 
	__11.  Enter a date and hit Enter.
	__12.  The output should look like:

	Part 3 -  Resource Bundles
	__1.  In the AdvJava project, right click the com.webagesolutions.i18n package and select New → Other...
	__2.  Select General → File and click the Next button.
	__3.  Fill in a file name of 'messages_en.properties' without the quotes.  Check that you are in the correct folder that matches the package as shown below and then click the Finish button.
	__4.  In the property file that gets created, add the following text and then save and close the file.
	__5.  In a similar fashion, create a file called 'messages_fr.properties' in the same package.
	__6.  In the 'messages_fr.properties' file that is created, add the following text and then save and close the file.
	__7.  In a similar fashion, create a file called 'messages_de.properties' in the same package with the following text for content.
	__8.  Make sure all files are saved and closed.
	__9.  Make sure the contents of the com.webagesolutions.i18n package match that shown below.
	__10.  Create a new class in the com.webagesolutions.i18n package called LocalizedMessages and include a main method.
	__11.  Inside the main method, obtain the resource bundles for various locales, as shown:
	__12.  Organize imports.
	__13.  Output a welcome message in the various locales as shown:
	__14.  Organize imports. Select java.util.logging.Logger.
	__15.  Save the class.
	__16.  Run the LocalizedMessages class as Java Application.
	__17.  Examine the output.
	__18.  Close all open files.

	Part 4 -  Summary

	Lab 5 -  Reflection
	Part 1 -  Create the code
	__1.  Create a package in in the AdvJava project called com.webagesolutions.reflection.
	__2.  Create a new class called MethodExecutor in the new package.  Include a main method.
	__3.  Inside the main method, prompt the user for the name of a class, and gather the user’s input as shown in bold below.  You will have errors until later steps.
	__4.  Declare a variable to hold a reference to an instance of the Class class, and initialize it to null. Give your variable the name clazz.
	__5.  Use the Class.forName() method to locate the Class definition for the class name supplied by the user.  Note that this operation could fail, throwing a runtime exception, and we need to handle that possibility:
	__6.  Use the Class’s newInstance() method to create an instance of the class.  Again, there are several error conditions that need to be handled, by catching any Throwable objects that are thrown:
	__7.  Add an infinite loop that prompts the user for the name of a method to invoke, then attempts to invoke it.  Also check to see if the method name matches ‘-‘ (the user can enter ‘-‘ to exit the program), and break out of the infinite loop if it does:
	__8.  Organize imports, select java.util.Scanner and java.lang.reflect.Method.
	__9.  Save the class and make sure there are no errors.
	__10.  Create a new class called Target in the same package.  The class does not need a main method.
	__11.  Modify the content of the new Target class to match the following bold code:
	__12.  Save the class.
	__13.  Switch back to the MethodExecutor class and run it as a Java application.  Test out various methods.  Sample output should be as shown below.  When done, enter a '-' to end the program.
	__14.  Run the the MethodExecutor again and try it on other classes.  Right now you can only invoke methods that take no parameters.
	__15.  Close all files.
	__16.  If you still have any programs running in the Console view, click the Terminate button.
	__17.  Remove all terminated launches by clicking the Remove All Terminated Launches button.
	__18.  You may have to Terminate and remove all Launches more than one time until the Console is empty.

	Part 2 -  Summary

	Lab 6 -  Annotations - AspectJ
	Part 1 -  AspectJ Development Tool Setup in Eclipse
	__1.  Make sure that Eclipse is running.
	__2.  From the Eclipse menus select Help → Install New Software...
	__3.  Click the Add button on the upper right to add a new update site.
	__4.  Click the Archive... button.
	__5.  In the dialog to choose a file, find and open the file 'C:\Software\AJDT\ajdt_2.2.3_for_eclipse_4.3.zip'.  
	__6.  Once you have chosen the appropriate Zip file, give the update site a name of 'AJDT Archive' and press the OK button when your options are similar to that shown below. You may see any extra characters added at the end of the Location file.
	__7.  Select the AspectJ Development Tools as shown below and click Next.
	__8.  You will see a list of software that will be installed as shown below.  There should be no checkboxes next to any features.  Press the Next button.
	__9.  On the 'Review Licenses' screen, select the radio button in the lower right labeled 'I accept the terms of the license agreements' and press the Finish button.  This will begin installing the software.
	__10.  Leave the dialog box that appears running so that you can see when the installation process completes.
	__11.  Once the installation is complete you will get a prompt to restart Eclipse.  Press the Yes button to restart.
	__12.  Open Eclipse in the same workspace when it restarts.

	Part 2 -  Creating a Java Project With AspectJ Capability
	__1.  Make sure Eclipse in the Java Perspective by selecting Window → Open Perspective → Java.
	__2.  Create a AspectJ Project, File → New → AspectJ Project.
	__3.  Set the project name to: SimpleAspectJProject and click Finish.
	You should see the newly created project.

	Part 3 -  Create Aspect Annotated Class
	Now lets create a business logic class which you want to apply AOP functionality.  This class will not have any AspectJ code.
	__1.  Right click the SimpleAspectJProject and select New → Class.
	__2.  For class name enter Account and for package enter com.simple.account then click Finish.
	__3.  In the opened Account class, add the following code so that your class should look like shown below:
	__4.  Generate Getters and Setters for the Account class.  Do this by right clicking anywhere on the Account class and selecting Source → Generate Getters and Setters..., select balance and click OK.
	__5.  Save and close the file.
	__6.  Right click the SimpleAspectJProject and select New → Class.
	__7.  Enter package name com.simple.logging, for class name enter AuditLogging and click the Finish button.
	__8.  Within the body of the new class add the following bold code.  You will have errors until the next step.
	__9.  Organize imports (Source → Organize Imports).
	__10.  Save the file and make sure there are no errors.
	__11.  Add the following bold '@Aspect' annotation to the declaration of the class.  This will declare the Java class as an Aspect.  You will have errors until later steps.
	__12.  Add the following bold '@Pointcut' annotation to the 'accountOperation' method.  This will declare the expression used to figure out which methods this aspect will apply to.
	__13.  Add the following two bold '@Before' and '@After' annotations to the remaining two methods.  This will define when the code of the Aspect will be applied to the method of the target Java class.
	__14.  Organize imports (Source → Organize Imports).
	__15.  Save the file and make sure there are no errors.
	__16.  In the package Explorer view, right click SimpleAspectJProject → New → Class.
	__17.  Enter package name com.simple.test, for class name enter TestAspectJ and also check to create a main method.
	__18.  Click Finish.
	__19.  Enter the following code in the main method.
	__20.  Organize imports (Source → Organize Imports).
	__21.  Save the file and make sure there are no errors.

	Part 4 -  Test the Application
	__1.  Right click TestAspectJ.java and select Run As → AspectJ/Java Application
	__2.  Expand the Console view if needed. You should see the following 4 log messages:
	__3.  Close all open files.

	Part 5 -  Review

	Lab 7 -  Threading and Synchronization
	Part 1 -  Procedure
	__1.  Expand AdvJava project.
	__2.  In the existing package com.webagesolutions.synch, create a class called SharedBean
	__3.  In this class create a single int property called value.  
	__4.  Create a setter and getter method for ‘value’.  
	__5.  Check that your class appears as shown below.
	__6.  Save the class and make sure there are no errors in the class.
	__7.  Inside the same package, create another class called Incrementor, which implements the Runnable interface. Ensure to check Inherited abstract methods.
	__8.  Define an instance variable in Incrementor called bean that holds a reference to an instance of SharedBean as shown in the bold code below.
	__9.  Add a constructor that takes an instance of SharedBean and stores it in ‘bean’.
	__10.  Implement the run() method in Incrementor as shown below:
	The code above sits in a loop, incrementing the SharedBean’s value property every 75 milliseconds or so.
	__11.  Save the class.
	__12.  Modify in SharedBean class the setValue() method to flag cases where the new value is not the increment of the current value, as shown below:
	__13.  Save the class.
	__14.  Open the com.webagesolutions.synch.RunIncrementors class, which was included in the LabStarterFiles project, and inspect the existing code.  This class creates two existing Incrementor classes and runs them both.
	__15.  Run the RunIncrementors class as a Java application (Run → Run As → Java Application) and inspect the output.  You will likely see many cases where there are ‘bad’ increments because of the concurrent access.
	__16.  Modify the Incrementor class’s run() method to synchronize against the bean for the entire operation. Add in the synchronized block shown in bold face below:
	__17.  Save and make sure there are no errors.
	__18.  Run the RunIncrementors class again.  Do we still get bad increments? Why or why not?
	__19.  Close all open files.

	Part 2 -  Summary

	Lab 8 -  Java SE 5 Concurrency Features
	Part 1 -  Lab Setup
	__1.  Open Eclipse if it is not already running.
	__2.  Select File → Import from the Eclipse menus.
	__3.  Expand the General group and select Existing Projects into Workspace and press the Next button.
	__4.  Select the radio button next to the Select archive file option and use the matching Browse button to find and open the file 'C:\LabFiles\AdvConcurrency-Starter.zip'.
	__5.  Select the project listed in the file if it is not already as shown below.
	__6.  Press the Finish button to import the project.

	Part 2 -  Use ExecutorService
	__1.  In Eclipse, expand the 'AdvConcurrency → src → com.webage.executor' package and open the 'RunnableCounter.java' file.
	__2.  Notice that this class is just a standard implementation of the 'Runnable' interface.
	__3.  Find the currently empty 'run' method and add the following bold code to complete the implementation.  You will have errors until the next step.
	__4.  Organize imports (CTRL+SHIFT+O).
	__5.  Save the file and make sure there are no errors in this class.
	__6.  Open the 'ExecutorThreadPoolTest.java' file in the 'com.webage.executor' package.
	__7.  In the 'main' method, find the comment for the 'single thread executor' and add the following bold code.  This will use the 'Executors' class to get an instance of an 'ExecutorService'.
	__8.  Under the first comment for 'loop to execute runnable counters' as shown below add the following bold code.  This will create instances of the 'RunnableCounter' class you completed and execute them with the 'ExecutorService' instance you just obtained.
	__9.  Find the comment for 'shutdown single thread executor and await termination' and add the following bold code.  This will initiate shutdown and timeout if it takes too long.
	__10.  Save this class and make sure there are no errors.  Ignore the "thread pool" comments as we will add those after testing the single thread executor.
	__11.  With the 'ExecutorThreadPoolTest' class active in the Java editor, select 'Run → Run As → Java Application' from the Eclipse menus.
	__12.  It could take several seconds but you should eventually see many messages from the 'RunnableCounter' instances with the sum values and then a message about how long the 'single thread execution' took.  You can ignore the 'pool execution' as we haven't used that yet.
	__13.  Return to the 'main' method of the 'ExecutorThreadPoolTest' class, find the comment for the 'thread pool executor' and add the following bold code.  This will get an instance of the 'ExecutorService' interface which will use a thread pool.  Notice this uses a value that was declared as a constant already in the class.
	__14.  Under the comment for 'loop to execute runnable counters' add the following bold code.  This will again create instances of the 'RunnableCounter' class and execute them with the thread pool 'ExecutorService' instance you just obtained.
	__15.  Find the comment for 'shutdown thread pool executor and await termination' and add the following bold code.  This will initiate shutdown and timeout if it takes too long.
	__16.  Save this class and make sure there are no errors.  
	__17.  With the 'ExecutorThreadPoolTest' class active in the Java editor, select 'Run → Run As → Java Application' from the Eclipse menus.
	__18.  After several seconds you should see the messages about how long each of the types of execution took.  Depending on the hardware of your machine (in particular the presence of a multi-core processor) you may see a difference or not in the results and the single thread executor may even perform slightly better.
	__19.  If you want, you can go back and change the value of the 'NUM_THREADS' constant at the top of the class, save the file and run it again.
	__20.  Close all open files.

	Part 3 -  Use Callable and Future
	__1.  Expand the 'AdvConcurrency → src → com.webage.future' package.
	__2.  Right click the 'com.webage.future' package and select 'New → Class'.
	__3.  Fill in 'CallableAdder' for the class name but don't yet create the class.
	__4.  Next to the empty list of interfaces click the Add button.
	__5.  In the dialog that appears, type in 'callable' in the top box, pick the 'Callable' interface from the java.util.concurrent package that appears, and click the OK button.
	__6.  The cursor should appear in the line of the interface you just added.  Use it to change the 'Callable<V>' line to 'Callable<Long>' as shown below.
	__7.  Once your settings for the new class match those shown above click the Finish button.
	__8.  In the new class replace the implementation of the 'call' method with the bold code below.  Notice this code does not use the 'Future' interface as that will be done for you.
	__9.  Save the 'CallableAdder' class and make sure there are no errors in the class.
	__10.  Open the 'FutureTest.java' file in the 'com.webage.future' package.
	__11.  In the 'main' method, find the comment for the 'loop to add Callable Adders to a Future result list' and add the following bold code.  This will create instances of the 'CallableAdder' class and submit them to be processed by the executor.  The 'Future' objects that are returned are added to a list to process later in the code.  
	__12.  Look at the 'while' loop near the end of the 'main' method.  Even though there is no code you need to complete here, notice how it loops through the results, checks to see if each one is "done" (this is a method of the 'Future' object) and if it is adds the result to the running total and removes the 'Future' object from the list.  The idea of this code is that if a result were not done it would be skipped but left in the list and the loop would come back to it later.  This shows the asynchronous behavior of the 'Future' object.
	__13.  Save this class and make sure there are no errors. 
	__14.  With the 'FutureTest' class active in the Java editor, select 'Run → Run As → Java Application' from the Eclipse menus.
	__15.  You should fairly quickly get messages back about the size of the list of results and the total sum that was computed.
	__16.  Close all open files.

	Part 4 -  Use Atomic Operations
	__1.  Expand the 'AdvConcurrency → src → com.webage.atomic' package and open the 'SharedBean.java' file.
	__2.  Near the top of the class, find the comment for 'add field for AtomicInteger' and add the following bold code.  You will have some errors until the next step.  Rather than just  regular 'int' or 'Integer' value we use the 'AtomicInteger' class to track the data that will be accessed concurrently.
	__3.  Organize imports (CTRL+SHIFT+O).
	__4.  Find the comment for 'add getValue method' and add the following bold code for a new method declaration.  Notice how we use the 'get' method of the 'AtomicInteger' class to return the data that is being stored.
	__5.  Find the currently empty 'increment' method and add the following bold code to implement the method.  Notice the use of the 'compareAndSet' method that is provided by AtomicInteger.
	__6.  Save the file and make sure there are no errors in this file.
	__7.  Open the 'Incrementor.java' file in the 'com.webage.atomic' package.
	__8.  Notice that this is a fairly basic implementation of the 'Runnable' interface which takes an instance of the 'SharedBean' class and increments it several hundred times with waiting added between increments.  There is no code you need to add to this class.
	__9.  Open the 'RunIncrementors.java' file in the 'com.webage.atomic' package.
	__10.  Notice that this code has a 'main' method and will create two instances of the 'Incrementor' class that will shared the same instance of the 'SharedBean' class.  These will both be executed with an Executor.
	__11.  With the 'RunIncrementors' class active in the Java editor, select 'Run → Run As → Java Application' from the Eclipse menus.
	__12.  As it runs you should see lots of messages about all of the increments that are performed.  At no point should you see a message about a "bad increment" that was performed.
	__13.  Close all open files.

	Part 5 -  Review

	Lab 9 -  Java SE 7 Fork & Join
	Part 1 -  Recursively Find the Maximum in an Array
	__1.  Expand the 'AdvConcurrency → src → com.webage.forkjoin' package and open the 'BigNumberList.java' file.
	__2.  Examine the code in this class.  Notice it is just a way to create an array of random integer values in a fairly large range.  This will be used by the other classes for the "problems" they are trying to solve.
	__3.  Open the 'MaxNumberProblemSolver.java' file in the 'com.webage.forkjoin' package.
	__4.  In the class declaration, add the code in bold below so the class extends the 'RecursiveTask<Integer>' class.  You will have errors until the next few steps.
	__5.  Find the comment 'implement compute method' and add the new method implementation as shown in bold code below.  This 'compute' method returns the result of the task.  Notice the code that will split the problem in half, then use the 'fork' and 'join' methods on one half to process it.
	__6.  Examine the 'computeDirectly' method in the class that is already provided for you. Notice this will simply find the maximum number in an array and is called by the main 'compute' method once the problem is broken down small enough.
	__7.  Save the file and make sure you don't have any errors.
	__8.  Open the 'ForkJoinTest.java' file in the 'com.webage.forkjoin' package.
	__9.  In the 'main' method, find the comment for the 'create MaxProblemSolver instance' and add the following bold code.  The will use the list of random integers with the 'MaxNumberProblemSolver' class you just implemented with a recursive Fork/Join algorithm.
	__10.  Find the comment 'modify to invoke ForkJoinPool on task' and change how the 'maximumResult' variable is initialized as shown in the bold code below.  This will ask the ForkJoinPool that was created in code provided for you to invoke the task that was created and return the result.
	__11.  Save the file and make sure you don't have any errors.
	__12.  With the 'ForkJoinTest' class active in the Java editor, select 'Run → Run As → Java Application' from the Eclipse menus.
	__13.  In the Console view, ignore the messages about sorting the array since we haven't implemented that yet and scroll back to the messages from calculating the maximum in the array.  Your value may be different but you should see that it is a number very close to 500,000.  Also note the number of recursive splits of the problem in what should be a very short processing time.

	Part 2 -  Recursively Sort an Array
	__1.  Open the 'ArraySorter.java' file in the 'com.webage.forkjoin' package.
	__2.  In the class declaration, add the code in bold below so the class extends the 'RecursiveAction' class.  You will have errors until the next few steps.
	__3.  Find the comment 'implement compute method' and add the new method implementation as shown in bold code below.  This 'compute' method does not return any result but performs the action of the class.  Notice the code that will split the problem in half, then call 'invokeAll' on both halves to trigger the fork/join processing.
	__4.  Examine the 'mergeResults' method in the class that is already provided for you. Notice this will simply merge the results of the two smaller sorted arrays back into one.
	__5.  Save the file and make sure you don't have any errors.
	__6.  Open the 'ForkJoinTest.java' file in the 'com.webage.forkjoin' package.
	__7.  In the 'main' method, find the comment for the 'create ArraySorter instance' and add the following bold code.  The will use the list of random integers with the 'ArraySorter' class you just implemented with a recursive Fork/Join algorithm.
	__8.  Find the comment 'invoke ForkJoinPool on task' and add the new line as shown in the bold code below.  This will ask the ForkJoinPool to invoke the task that was created.  Notice that no result is returned from the 'invoke' method.
	__9.  Find the comment 'modify to get sorted list from ArraySorter' and change how the 'sorted' variable is initialized as shown in the bold code below.  This will ask the ArraySorter instance that was created and finished running what the sorted numbers are.
	__10.  Save the file and make sure you don't have any errors.
	__11.  With the 'ForkJoinTest' class active in the Java editor, select 'Run → Run As → Java Application' from the Eclipse menus.
	__12.  In the Console view, check the messages from the sorting portion of the test class that the message 'Sorted list has maximum in last position' is shown.  This should verify that the list is sorted if the maximum value ends up in the last position.  Also note the number of recursive splits of the problem in what should be a very short processing time.
	__13.  Close all open files.

	Part 3 -  Review

	Lab 10 -  Networking with Sockets
	Part 1 -  Main Connection Loop
	__1.  Expand AdvJava project.
	__2.  Create a new package in your project called com.webagesolutions.socks
	__3.  Create a new class in this package, called Responder and create the class with a ‘public static void main(String[] args)’ method.  This class will contain the overall server code that listens for connections and delegates to a handler.
	__4.  Create another new class in the com.webagesolutions.socks package called ResponderHandler that implements the java.lang.Runnable interface.
	__5.  Create a constructor in ResponderHandler that takes a java.net.Socket as its argument, and stores the supplied socket in a private instance variable called socket.
	__6.  Organize imports and save the class.
	__7.  In the main(…) method of the Responder class, declare a variable called serverSocket and initialize it with a new instance of a java.net.ServerSocket attached to port ‘10001’ as shown in bold below.
	__8.  Add the bold code below to declare a variable called threadPool to reference a new instance of a cached thread pool:
	__9.  Add a line to print out a message so you will be able to tell that the Responder is awaiting connections.
	__10.  Add code to repeatedly accept a connection on the socket, create a ResponderHandler based on that connection, then submit the handler to the thread pool for execution:
	__11.  Organize imports to resolve errors relating to imports.  You will still have other errors.
	__12.  Surround the code in try and catch in the main method of Responder.  The easiest way to do this is to highlight the lines of code in the 'main' method, right click, and select Surround with → Try/catch Block.
	__13.  Now that you have the 'try/catch' block, move the declaration and initialization of the serverSocket variable so that it is a "try-with-resources" statement.  Notice that you will need to delete the line inside the 'try' block and add it back in within parenthesis immediately after the 'try' keyword.
	__14.  Save the class. There should be no errors in this class.

	Part 2 -  Connection Handler
	__1.  Return to the ResponderHandler class and implement the run(..) method as follows.  Note that the 'inputScanner' and 'output' variables are declared and initialized within a 'try‑with‑resources' statement.
	__2.  Organize imports and select java.util.Scanner when prompted.
	__3.  Save the file. There should be no errors in any class. 
	__4.  Run the ‘Responder’ class.  It will stay running while you finish the client code in the next section.

	Part 3 -  Console Client
	__1.  Create a new class called Sender in the com.webagesolutions.socks package.  Create the class with a ‘public static void main(String[] args)’ method.
	__2.  Insert the following into the main method.  Notice there are lots of resources declared and initialized within the 'try‑with‑resources' statement.
	__3.  Organize imports and select java.util.Scanner and java.io.DataOutputStream when prompted.
	__4.  Save the class and make sure there are no errors.
	__5.  Verify that the Responder class is running.
	__6.  Now run the Sender class.
	__7.  You may need to select the required console in the Eclipse console window, since you have more than one Java program running.  To do so, click on the select-console drop down box, and select the console you want to see:
	__8.  In the Sender console type   Testing 1,2,3   and hit Enter. 
	__9.  The Responder console will show:
	__10.  Switch back to the Sender console again and notice the response received there is all upper case.
	__11.  In the Sender console again, type    Send to upper case   and hit Enter.
	__12.  Finally, in the Sender console, type  bye  and hit Enter. 
	__13.  Your Responder console should show:
	__14.  Your Sender console should look like this:
	__15.  Close all open files.
	__16.  Click the Terminate button.
	__17.  Remove all terminated launches by clicking the Remove All Terminated Launches button.
	__18.  You probably will have to Terminate and remove all Launches more than one time until the Console is empty.

	Part 4 -  Review

	Lab 11 -  Basic SAX Programming
	Part 1 -  Study the XML Document
	__1.  Open C:\LabFiles\movie.xml using a text editor such as WordPad. 
	__2.  Study the structure of the document. Notice that, the root level element is <database>. It contains a list of <movie> elements. Each movie element can have several <actor> elements.
	__3.  Close the XML file.

	Part 2 -  Parse XML Using SAX
	__1.  From the menu, select File > New > Other.
	__2.  Select Java Project and click Next.
	__3.  Enter XMLTest as Project name and click Finish.  If Eclipse asks you to open the Java perspective click Yes.
	__4.  In the new project create a new package called com.mycom.test
	__5.  In that package create a new Java class called Movie. This class will represent our movie data structure.
	__6.  In the Movie class, add a few member variables as follows:
	__7.  Organize imports. 
	__8.  Save changes.
	__9.  In the Outline view, right click Movie and select Source->Generate Getters and Setters. 
	__10.  Click Select All. 
	__11.  Click OK. This will add various property accessor and mutator methods.
	__12.  Save and close the file.
	__13.  Create a new class called MoviePrinter in the same package. 
	__14.  In the file, add these import statements.
	__15.  Make the class extend the DefaultHandler class as shown in bold.
	__16.  Add two member variables.
	__17.  Now, we will add various event handler methods. In the Outline view, right click MoviePrinter and select Source > Override/Implement Methods. 
	__18.  Select the following methods: characters, endElement, error and startElement. 
	__19.  Click OK. Eclipse will add default implementations of these methods.
	__20.  Set the code for the characters method as follows.
	__21.  Set the startElement method code as follows.
	__22.  Set the endElement method as follows.
	__23.  Set the error method as follows.
	__24.  Copy the implementation of the printMovie() method from C:\LabFiles\ MoviePrinter.java. 
	__25.  Copy the implementation of the main() method from C:\LabFiles\ MoviePrinter.java. 
	__26.  Save the file. There should be no errors.

	Part 3 -  Run the Program
	__1.  Make sure that the Console view is available in the Java perspective. If not add it selecting Window -> Show View -> Console.
	__2.  While the MoviePrinter class editor is active, from the menu bar select Run -> Run As -> Java Application.
	__3.  Make sure that the console shows expected output.
	__4.  Close all open files.

	Part 4 -  Review

	Lab 12 -  Basic DOM Programming
	Part 1 -  Create the Project
	__1.  From the menu bar, select File > New > Java Project. 
	__2.  Enter XMLProject as the Project name and click Finish. 
	__3.  Copy and paste C:\LabFiles\purchaseOrder.xml into the XMLProject project.
	__4.  Open the file and study the structure of the document. Notice that the root element is purchaseOrder.  It contains a shipTo, billTo, and items element. The items element in turn contains item elements.
	__5.  Close the file.

	Part 2 -  Create the Item
	__1.  In the Package Explorer view, right-click on XMLProject and select New | Class.
	__2.  Set the Package to be com.simple
	__3.  Set the Name to be Item
	__4.  Click Finish.
	__5.  Add the following fields to the class:
	__6.  We should generate accessors for these fields.  Right-click anywhere on the editor and select Source | Generate Getters and Setters...
	__7.  Click the Select All button.
	__8.  Click OK.
	__9.  Save the file.  There should be no errors. 
	__10.  Close the file.

	Part 3 -  Create the PurchaseOrder Class
	__1.  Create a new class called PurchaseOrder in the com.simple package.
	__2.  Add the following three fields to the class:
	__3.  Right-click on the source and select Source | Generate Getters and Setters...
	The Generate Getters and Setters window will appear. 
	__4.  Click Select Getters and expand the variables.
	__5.  Click OK.
	__6.  Add the following two methods to the class:
	__7.  Add the following method to the class:
	__8.  Add the following code in bold to the setItems() method.
	__9.  Add the following bolded code inside the loop:
	__10.  Right away we can get the item's part number and set it on our instance.  Add the following bolded code inside the loop:
	__11.  Add the following line to the loop:
	__12.  Add the following bolded loop code into the existing loop, after the itemParts declaration:
	__13.  Add the following bold code right before the outer loop's closing curly brace:
	__14.  Organize imports by pressing Ctrl-Shift-O.
	__15.  Select org.w3c.dom.Node and org.w3c.dom.Element.
	__16.  Save the file.  There should be no errors in your code.  
	We are done!  The method should look like the following:
	__17.  Close the file.

	Part 4 -  Create the OrderPrint Class
	__1.  Create a new Java class called OrderPrint in the com.simple package adding a main method to the class.
	__2.  In the main method, get the command line argument args[0].  This corresponds with the name of the file that we want to parse.
	__3.  Construct an instance of a DocumentBuilderFactory and a DocumentBuilder by adding the following bolded code:
	__4.  Organize imports.  There will still be an error message listed, since we're not handling an exception.  We'll fix this shortly.
	__5.  We can now begin the parsing.  Add the following bolded line of code to the end of the main method to parse the file.
	__6.  Organize imports.  Select org.w3.dom.Document.
	__7.  Now let's fix the errors due to the lack of exception handling.  Select the code inside the main method.  Then select Source->Surround With->Try/catch Block from the menu bar.  
	__8.  Save your changes.  There should no longer be any errors in your code.  
	__9.  From the document node, let us get the portions of the document that refer to the billTo, shipTo and item addresses, respectively.  Add the following bolded code at the end of the try block:
	__10.  Now that we have the appropriate sub-trees, we can create an instance of a PurchaseOrder and use its setXXX methods accordingly.  Add the following bolded code at the end of the try block:
	__11.  Organize imports. Select org.w3.dom.Element.
	__12.  Save your changes.  There shouldn't be any error messages now.
	__13.  We have now parsed the XML file and created a new PurchaseOrder instance to use the read in data.  Let us test this by printing out the data in the instantiated PurchaseOrder.  Add the following bolded code to the method. 
	__14.  Save the class. There should be no errors in the file.

	Part 5 -  Run the Code
	__1.  Right-click on the source and select Run As > Run Configurations...
	__2.  The Run Configurations screen will appear.  In the left pane, double click on Java Application.  
	__3.  OrderPrint should then appear underneath it.  Click on it. 
	__4.  In the right pane, click the Arguments tab.
	__5.  Under Program arguments, add C:\workspace\XMLProject\purchaseOrder.xml
	__6.  Click Run.
	__7.  The application will run.  Examine the console:
	__8.  Close all open files.

	Part 6 -  Review

	Lab 13 -  JAXB Programming
	Part 1 -  Add JAXB Implementation to Project Classpath
	__1.  In Eclipse select Window → Preferences.
	__2.  In the list of preferences select Java → Build Path → User Libraries.
	__3.  Press the New button.
	__4.  Fill in a library name of JAXB and click the OK button.
	__5.  With the newly create JAXB library still selected press the Add External JARs button.
	__6.  Browse to the 'C:\LabFiles\JAXB-lib' directory, select all the JAR files by holding the CTRL key while selecting them, then click the Open button to complete the selection.
	__7.  Make sure that all 6 of the JAR files are listed as part of the library.
	__8.  Click the OK button to close the Eclipse preferences.
	__9.  Back in Eclipse, right click the XMLProject project and select Build Path → Add Libraries.
	__10.  Select User Library and click the Next button.
	__11.  Check the box next to the JAXB library you defined and click the Finish button.
	__12.  Check that the JAXB library is associated with the project.

	Part 2 -  Generating the Bindings
	__1.  Open a Windows Explorer window and navigate to the 'C:\LabFiles' folder.
	__2.  Copy the 'movie.xsd' file from the folder.  Make sure it is the XSD schema file and not the XML file.
	__3.  Return to Eclipse and select the 'XMLProject'.
	__4.  Right click 'XMLProject' and select 'Paste'.
	__5.  Check that you see the 'movie.xsd' file at the root of the project.
	__6.  Right click the movie.xsd file and select Generate → JAXB Classes.
	__7.  Select XMLProject and click Next.
	__8.  Change the Package to 'com.jaxb.movie' as shown below and click the Finish button.  
	__9.  If you get an overwrite warning, click Yes.
	__10.  Expand the src folder of project XMLProject. 
	__11.  A newly created package com.jaxb.movie should appear.  Expand it and you should see the generated binding classes.
	__12.  Open the 'MovieType.java' file from this package.  It is probably the more complex example of how JAXB annotations are used to map between Java and XML.
	__13.  Scroll past the comments at the beginning and look at the various JAXB annotations just before and after the class declaration.  These link back to the XML schema structure along with which attributes were required by the schema.
	__14.  Close the file without making any changes.

	Part 3 -  Use the Binding Classes To Read XML
	__1.  In the XMLProject project, create a new package called com.mycom.test 
	__2.  In the com.mycom.test package, create a new class called JAXBMoviePrinter adding a main method.
	(If you have trouble typing in the following code, we have provided the completed class source code at C:\LabFiles\Solutions\SOLUTION-JAXBMoviePrinter.java  Feel free to copy and paste if necessary).
	__3.  In the main method, we first need to setup the unmarshaler. Add the following code to the main method. 
	__4.  There are some errors in the code.  To fix a few of them, perform an Organize imports. (Ctrl + Shift + O) , selecting javax.xml.bind.Unmarshaller if prompted. After you do this, you will still see some errors, but ignore them for now.  
	__5.  Recall that in our schema, that “top-most” element was database.  If you look at the generated binding classes, you will notice that a Database class was created.  We can use the unmarshaler to create an instance of this object.  Add the following code:
	__6.  Fix this by performing an Organize Imports. Select java.io.File if prompted.  There will still be some errors.  Do not worry about them for now. 
	__7.  Remember that a <database> element contained several <movie> elements. Similarly, the database object will have a field that represents a list of MovieType objects.  We can get this list.  Add the following code:
	__8.  We now have a hold of the list of movies that the database was keeping track of.  We can iterate through it, and operate on it!  Let us simply go through the list and print the title of each movie.  Add the following code:
	__9.  Organize imports again. Select java.util.List when prompted.
	__10.  Select all the code in the main method (but not the method declaration). 
	__11.  Right click on it and select Surround With->Try/catch block.
	__12.  Save the code.

	Part 4 -  Test JAXB
	__1.  Right click on the code and select Run As > Java Application.
	__2.  Close all open editors.

	Part 5 -  Review

	Lab 14 -  Java Logging
	Part 1 -  Create Code with Basic Logging
	__1.  In your Eclipse workspace create a new Java Project called 'LogProject'.
	__2.  In the new project create a new Java class with the following attributes:
	__3.  In the code for the 'HelloWorldLogger' class, add the declaration of a 'Logger' field that will be initialized based on the name of the class.
	__4.  Organize imports (CTRL-SHIFT-O) and select java.util.logging.Logger if prompted.
	__5.  In the class create the following empty method.
	__6.  Within the code of this new method simply add a line to log the name passed as a parameter as an INFO message.
	__7.  Save the 'HelloWorldLogger' class and make sure there are no errors.
	__8.  In the project create a new Java class with the following attributes:
	__9.  Modify the code of the 'main' method to match the following.  You will get errors but they will be fixed next.
	__10.  Add the following empty method to the 'Driver' class.  You can also use the Eclipse 'Quick fixes' to add the code.
	__11.  In the code for the new 'runProgram' method add the declaration of a 'Logger' variable that will be initialized based on the name of the class.
	__12.  Add the following line to declare a new 'HelloWorldLogger' object.
	__13.  Organize imports (CTRL-SHIFT-O).
	__14.  Save the class and there shouldn't be any errors although there will be some warnings.
	__15.  Add the following code that will use the logger and HelloWorldLogger objects. Notice that we are logging from this class also to see the effects of configuration properties later.
	__16.  Save the class and make sure there are no errors.
	__17.  Select Run → Run As → Java Application from the Eclipse menus.
	__18.  Check that in the Console view you get the following output.  Notice that the messages of both classes appear.

	Part 2 -  Control Logging with Properties File
	__1.  Right click on the 'LogProject' project and select 'New → File'.
	__2.  Fill in a name of 'myLogging.properties', make sure the 'LogProject' is selected and click the Finish button.
	__3.  Leave the file open but don't add anything to it yet.
	__4.  Select Run → Run Configurations from the menu.
	__5.  Select the Driver run configuration on the left if it is not already.
	__6.  Switch to the 'Arguments' tab and in the 'VM arguments' section add the following argument:
	__7.  Press the Apply and then the Run buttons to run the modified configuration.
	__8.  You should see in the Console view that nothing appears.  This actually proves that your properties are being picked up and we will fix this in a second.
	__9.  Switch back to the 'myLogging.properties' file.
	__10.  Add the following to the file.
	__11.  Save the 'myLogging.properties' file.
	__12.  Select 'Run → Run History → Driver' to run the program again.  This time you should get the same output as before you had custom properties.
	__13.  Switch back to the 'myLogging.properties' file and add the following to the file.
	__14.  Save the 'myLogging.properties' file and select 'Run → Run History → Driver' to run the program again.  This time you will again get empty output.
	__15.  Switch back to the 'myLogging.properties' file and add the following to the file.
	__16.  Save the 'myLogging.properties' file and select 'Run → Run History → Driver' to run the program again.  This time you will get messages from the 'HelloWorldLogger' class but not the 'Driver' class.

	Part 3 -  Advanced Logging Code
	__1.  Open the 'HelloWorldLogger' class if it is not already and add the following field to the class:
	__2.  Add the code to throw an Exception to the signature of the 'sayHello' method as shown below.
	__3.  Add the following code that will check if the parameter is one of the "bad names" and throw an Exception.
	__4.  Save the file.  You will get errors in the other class that we will fix.  There should be no errors in the 'HelloWorldLogger' class.
	__5.  Switch back to the 'Driver' class and add the following try/catch block around the call to the 'sayHello' method.
	__6.  Save the file.  There should not be any errors in any classes.
	__7.  Select 'Run → Run History → Driver' to run the program again.  This time you will get the 'Severe' message from the Driver class but not any messages from the 'sayHello' method since the exception was thrown before the INFO message would have been printed out.
	__8.  Return to the 'sayHello' method of the 'HelloWorldLogger' class and change the if clause as follows the following code.
	__9.  Save the file.  There should not be any errors in any classes.
	__10.  Select 'Run → Run History → Driver' to run the program again.  Even though you added the 'throwing' method from the logger you don't see it!  Right now the Console logging is filtering out this message so we need to fix that.
	__11.  Switch back to the 'myLogging.properties' file and add the following line as shown below.
	__12.  Save the 'myLogging.properties' file and select 'Run → Run History → Driver' to run the program again.  This time you will get a 'FINER' message about the exception that was thrown.
	__13.  Back in the 'HelloWorldLogger.sayHello' method add the following code.
	__14.  Save the file and select 'Run → Run History → Driver' to run the program again.    This time you will see a log message 'FINER: ENTRY Bob' which indicates the method was called with a name of 'Bob' for the parameter.
	__15.  Add the following code to the 'sayHello' method.
	__16.  Organize imports.
	__17.  Save the file and select 'Run → Run History → Driver' to run the program again.  You will see the INFO message about FINEST logging being available but notice you do not see any FINEST messages.
	__18.  Switch back to the 'myLogging.properties' file and modify the following line.
	__19.  Save the 'myLogging.properties' file and select 'Run → Run History → Driver' to run the program again.  This time you are back to only seeing the SEVERE message.  Notice that the INFO message about the 'FINEST' level being available is also not logged.  You also lose the ENTRY and THROW messages since they were FINER level.

	Part 4 -  Log to a Log File
	__1.  Switch back to the 'myLogging.properties' file and modify the following line in bold.  Also remove the line for the ConsoleHandler since we will not use it.
	__2.  Add the following two new properties.  Note that the 'formatter' property should be entered with the value on the same line.  It wraps to the next line shown below.
	__3.  Save the 'myLogging.properties' file.
	__4.  From the Eclipse menus select Window → Preferences.
	__5.  From the preference groups on the left select General → Workspace.
	__6.  Check the box to 'Refresh using native hooks or polling' and click the OK button.
	__7.  Select 'Run → Run History → Driver' to run the program again.  
	__8.  Check that you see a 'java0.0.log' file show up in the project as shown below.
	__9.  Open the file and you should see the same SEVERE message we saw before.  Take note of the timestamp of the message.
	__10.  Close the file.
	__11.  Select 'Run → Run History → Driver' to run the program again.  
	__12.  Wait several seconds for Eclipse to refresh the projects contents and then open the log file again.  Notice that you see just the one SEVERE message but it should have a different timestamp.
	__13.  Close the log file.
	__14.  Switch back to the 'myLogging.properties' file and add the following line.  
	__15.  Save the 'myLogging.properties' file and select 'Run → Run History → Driver' to run the program again.
	__16.  Wait several seconds for Eclipse to refresh the projects contents and then open the log file again.  This time you should see that the previous message was kept and the logging appended new messages on the end.
	__17.  Close the log file.
	__18.  Switch back to the 'myLogging.properties' file and add the following two lines.  Also modify the 'com.webage.logging.level' property to 'ALL'.
	__19.  Save the 'myLogging.properties' file and select 'Run → Run History → Driver' to run the program again.
	__20.  Wait for the Eclipse project to refresh which should show two log files as shown below.
	__21.  Open the 'java0.1.log' file first.  Notice that this log file should have the earlier SEVERE messages in addition to the start of the loop of FINEST messages.
	__22.  Open the 'java0.0.log' file.  This log file should have the rest of the FINEST messages along with the other expected messages at the end.
	__23.  Close both log files.
	__24.  Delete both log files from the project.

	Part 5 -  Use Memory Buffer Logging
	__1.  Modify the 'handlers' property in the 'myLogging.properties' file as shown below and add the new property to configure the 'target' of the Memory Handler.
	__2.  Save the 'myLogging.properties' file and select 'Run → Run History → Driver' to run the program again.
	__3.  Wait for the Eclipse project to refresh which should show two log files as shown below.
	__4.  Open the 'java0.1.log' file first.  Notice this still starts the complete loop of the FINEST messages.
	__5.  Open the 'java0.0.log' file.  This log file should have the other expected messages at the end.
	__6.  Close both log files.
	__7.  Delete both log files from the project.
	__8.  Add the following line to the 'myLogging.properties' file.  This will limit the number of messages in the memory buffer.
	__9.  Save the 'myLogging.properties' file and select 'Run → Run History → Driver' to run the program again.
	__10.  Wait for the Eclipse project to refresh which should show only one log file.
	__11.  Open the 'java0.0.log' file.  This log file should have only the last few FINEST messages from the loop and the other messages expected at the end.  This proves that it is logging messages of all levels but only the last 5 messages so the log file of a larger program might be easier to find errors but still provide some context for messages immediately before the errors.
	__12.  Close all open files.

	Part 6 -  Review

	Lab 15 -  Distributed Objects with RMI
	Part 1 -  Procedure
	__1.  Before starting this Lab, terminate all programs running in the Console. Click the Terminate button.
	__2.  Remove all terminated launches by clicking the Remove All Terminated Launches button.
	__3.  You probably will have to Terminate and Remove All Launches more than one time until the Console is empty. Make sure nothing is running in the Console.
	__4.  Expand the AdvJava project.
	__5.  In the com.webagesolutions.rmi package, create a new class called RemoteUserStoreService that extends from java.rmi.server.UnicastRemoteObject superclass and implements the RemoteUserStore interface.  Have the wizard generate a 'main' method and stub methods for all the inherited abstract methods. 
	__6.  Once your 'New Java Class' wizard appears as shown above, click the Finish button to create the class.
	__7.  Add the following constructor to RemoteUserStoreService.  Note that the constructor throws RemoteException, since the superclass constructor is declared to throw RemoteException.
	__8.  Save the file but leave it open.  You should have no compilation errors at this point although you may still have warnings.
	__9.  Declare an instance variable called userStore in RemoteUserStoreService that references an instance of UserStore and initialize it to a new instance of InMemoryUserStore as shown in bold below.
	__10.  Organize imports.
	__11.  Add code to the stub methods that were added, such that they delegate the method call to the object referenced by ‘userStore’.  This would be similar to the bold code shown below.  Make sure you match the correct implementation below with the correct method.  
	__12.  Add the following implementation of the main method to RemoteUserStoreService.  It creates a new instance of RemoteUserStoreService and registers it with the rmi naming service.
	__13.  Organize imports, select java.rmi.AlreadyBoundException.
	__14.  Save the class and make sure there are no errors.  You may have warnings.
	__15.  We need to start the rmi naming daemon.  In the Package Explorer, expand the node for JRE System Library…, then expand the node for rt.jar.  
	__16.  Under the “rt.jar” node, expand the package sun.rmi.registry.  
	__17.  Finally locate the class called RegistryImpl under this package.  This class is the implementation class that actually runs when you start ‘rmiregistry’ from the command line.  
	__18.  Right click on RegistryImpl.class and select Run As.. -> Run Configurations...
	__19.  In the left select Java Application.
	__20.  Click New Launch Configuration.
	__21.  Click the Browse button next to Project.
	__22.  Select AdvJava and click OK.
	__23.  Make sure RegistryImpl is Name.
	__24.  Make sure sun.rmi.registry.RegistryImpl is Main class.
	__25.  Make sure your configuration looks like this:
	__26.  Click the Apply button in the lower right if enabled.
	__27.  Click Run.
	__28.  There will be no output in the console window, but the registry daemon is now running.
	__29.  Open a command prompt and navigate the project’s home directory C:\workspace\AdvJava
	__30.  Issue the following command, which will run rmic to generate the remote object proxy (you may need to ensure that the Java 7 SDK’s ‘bin’ directory is in your command path):
	__31.  Back to eclipse, run your RemoteUserStoreService class as Java Application.  The output console should display the following:
	__32.  In the AdvJava project, there is a class that exercises the RemoteUserStoreService class. Open and examine the com.webagesolutions.users.TestRemoteUserStoreService class.
	__33.  Right click on it and select Run As > Java Application. 
	__34.  The output should be (browse back):
	__35.  Remove all terminated launches by clicking the Remove All Terminated Launches button.
	__36.  As you did in the beginning of this lab, terminate running processes in the Console by clicking the Terminate button.
	__37.  You probably will have to Terminate and Remove All Launches more than one time until the Console is empty. Make sure nothing is running in the Console.
	__38.  Close all open files.

	Part 2 -  Summary

	Lab 16 -  JAAS Security
	Part 1 -  The Login Code
	__1.  Create a new package called com.webagesolutions.security in your AdvJava project.
	__2.  Create a new class called Login in the new package above.  Include a public static void main(String[] args) method.
	__3.  Add the following bold code into the main() method:
	__4.  Surround the code in a try-catch block.  You can use 'Source → Surround With → Try/catch Block' after selecting all of the code if you want.
	__5.  Organize imports to add the required import statements for the external classes
	__6.  Save the class.  Make sure there are no errors.

	Part 2 -  Login Configuration
	__1.  Run the Login class as a Java application.  
	__2.  You will get an exception similar to the following:
	__3.  Right click on the AdvJava project in the project explorer, and select New -> File.  
	__4.  Enter Login.acn as the file name, and click Finish.
	__5.  Add the following text into the new file:
	__6.  Save the file.
	__7.  Right click on the Login class and select Run As -> Run Configurations… to edit the runtime configuration for this class.  
	__8.  If a 'Login' configuration does not appear in the configuration list then click 'New launch configuration' then set the 'Project' and 'Main class' settings to match that shown above.
	__9.  Make sure the Login node is selected, and click on the Arguments tab. 
	__10.   Enter the virtual machine argument shown below:
	__11.  Click the Apply button in the lower right corner and then click Run.  
	__12.  The console window should display output similar to:

	Part 3 -  Implement Custom Login Module
	__1.  Expand the 'com.webagesolutions.users' package in the 'AdvJava' project.
	__2.  Open the 'UserLoginModule.java' file.  Ignore the warnings in the file.
	__3.  Find the current implementation of the 'initialize' method and add the bold code below.  This will initialize the list of users we will authenticate against.
	__4.  Find the current implementation of the 'login' method.  After the comment for 'Get a user name and password' add the following bold code.  This will define the elements of the dialog box that will popup to include prompts for email and password.
	__5.  Find the next comment for 'Perform the callbacks' and add the following bold code.  This will end up displaying the dialog box to prompt for credentials.
	__6.  Find the last comment in the 'login' method for 'Authenticate against our user store' and add the following bold code.  Note that you will need to remove the 'return false;' statement that was present before to replace it with the given logic.  This code is taking the email and password information supplied from the popup dialog and 
	__7.  Find the current implementation of the 'commit' method and replace it with the bold code below.  Note that you will need to remove the 'return false;' statement that was present before to replace it with the given logic.  This code creates a 'Principal' object to associate with the authenticated identity using the name that was obtained from our user store.
	__8.  Find the current implementation of the 'logout' method and replace it with the bold code below.  Note that you will need to remove the 'return false;' statement that was present before to replace it with the given logic.  This code resets some of the fields of the LoginModule just to make sure we are back to the state before the login occurred.
	__9.  Save the 'UserLoginModule.java' file and make sure there are no errors.  You may have warnings.
	__10.  Open the Login.acn file if you do not still have it open.
	__11.  Edit the Login.acn file to read as follows:
	__12.  Save the file.
	__13.  Run the program again, you can do it by clicking the green run button in the menu bar.  
	__14.  You should now see a dialog box presented.  
	__15.  Enter an email of ‘waldoj@sun.com’ and a password of ‘note’.  
	__16.  Click OK. 
	__17.  The login should succeed. 
	__18.  Try to run the program again with the same email but a different password.  You should get an exception thrown by the 'UserLoginModule' indicating a bad password.
	__19.  Run the program again and this time supply an email address that is not in the user store.  You should get an Exception about a bad email.
	__20.  Close all open files.

	Part 4 -  Summary

	Lab 17 -  Input/Output with NIO and NIO.2
	Part 1 -  Lab Setup
	__1.  Open Eclipse if it is not already running.
	__2.  Select File → Import from the Eclipse menus.
	__3.  Expand the General group and select Existing Projects into Workspace and press the Next button.
	__4.  Select the radio button next to the Select archive file option and use the matching Browse button to find and open the file 'C:\LabFiles\NIO-Starter.zip'. 
	__5.  Select the project listed in the file if it is not already as shown below.
	__6.  Press the Finish button to import the project.

	Part 2 -  Work With a Path
	__1.  In Eclipse, expand the 'AdvNIO → src → com.webage.nio' package and open the 'FileOperations.java' file.
	__2.  Add a new method to the class as shown below.  Make sure you add this method inside the brackets for the class but outside the brackets for the currently empty 'run' method.  You will have errors until future steps.
	__3.  Organize imports (CTRL+SHIFT+O).
	__4.  Add the following bold code to the empty 'run' method that is already defined.  This will use the root path returned from the other method to locate the 'LabFiles' directory using the 'Paths.get' method.  The path to this directory will then be printed out.
	__5.  Save the file and make sure there are no errors in this class.
	__6.  Open the 'NIOFileSystemDriver.java' file in the 'com.webage.nio' package.  Note that this class simply creates an instance of the 'FileOperations' class and calls the 'run' method.
	__7.  With the 'NIOFileSystemDriver' class active in the Java editor, select 'Run → Run As → Java Application' from the Eclipse menus.
	__8.  In the Eclipse 'Console' view you should get output similar to the following.

	Part 3 -  List Files in a Directory
	__1.  Expand the 'AdvNIO → src → com.webage.nio' package and open the 'FileNamePrinter.java' file.  Notice the class is currently just some simple code with a 'Set' of Strings for an 'excludes' list and a field to count a number of files.
	__2.  In the class declaration, add the code in bold below so the class extends the 'SimpleFileVisitor<Path>' class.  You will have errors until the next few steps.
	__3.  Find the comment 'override methods' and add the new method as shown in bold code below.
	__4.  Organize imports (CTRL+SHIFT+O).
	__5.  Save the file and make sure you don't have any errors.
	__6.  Return to the 'run' method of the 'FileOperations' class, opening the file if you had closed it.  Add the following bold code.  You will have errors until future steps.
	__7.  Add a new method to the class as shown below.  Make sure you add this method inside the brackets for the class but outside the brackets for any other method.  You will have errors until future steps.
	__8.  Organize imports (CTRL+SHIFT+O).
	__9.  Save the file and make sure you don't have any errors.
	__10.  From the Eclipse menus select 'Run → Run History → NIOFileSystemDriver'.
	__11.  The 'Console' view should print several files and then the total number of files in the 'LabFiles' directory.  This number may vary from what is shown below but if you have done any labs that used a Derby database the number should be over 100.
	__12.  Return to the 'FileNamePrinter' class.
	__13.  Add a new method to the class as shown below.  Make sure you add this method inside the brackets for the class but outside the brackets for any other method.  
	__14.  Save the file and make sure you don't have any errors.
	__15.  Return to the 'printFiles' method of the 'FileOperations' class.
	__16.  Modify the first few lines of the method as shown in bold below.  Make sure to change the way the 'FileNamePrinter' constructor is called even though the rest of the line does not change.  You will have errors until future steps.
	__17.  Organize imports (CTRL+SHIFT+O).
	__18.  Save the file and make sure you don't have any errors.
	__19.  From the Eclipse menus select 'Run → Run History → NIOFileSystemDriver'.
	__20.  The 'Console' view should print several files and then the total number of files in the 'LabFiles' directory except for the files in the excluded directories.  Your number may be different than that shown below but it should be less than the number you got previously.

	Part 4 -  Search for Files
	__1.  Expand the 'AdvNIO → src → com.webage.nio' package and open the 'FileSearcher.java' file.  Notice the class is currently just some simple code with a field to count a number of files. 
	__2.  In the class declaration, add the code in bold below so the class extends the 'SimpleFileVisitor<Path>' class.  You will have errors until the next few steps.
	__3.  In the fields of the class declaration, find the comment 'add PathMatcher' and add the following bold code to declare a new field of this type.  You will have errors until the next few steps.
	__4.  Find the constructor for the 'FileSearcher' class and add the following bold line of code to initialize the field for the PathMatcher.
	__5.  Find the comment 'override method' and add the new method as shown in bold code below.
	__6.  Organize imports (CTRL+SHIFT+O).
	__7.  Save the file and make sure you don't have any errors.
	__8.  Return to the 'run' method of the 'FileOperations' class, opening the file if you had closed it.  Add the following bold code.  You will have errors until future steps.
	__9.  Add a new method to the class as shown below.  Make sure you add this method inside the brackets for the class but outside the brackets for any other method.  You will have errors until future steps.
	__10.  Save the file and make sure you don't have any errors.
	__11.  From the Eclipse menus select 'Run → Run History → NIOFileSystemDriver'.
	__12.  The end of the output in the 'Console' view should print JAR several files that match the pattern and then a total number of files that matched the pattern.  Your total number may be different but it should be less than the number of total files printed in the last section.
	__13.  Return to the 'run' method of the 'FileOperations' class and change the pattern to search for by changing the parameter passed to the 'findFiles' method as shown below. 
	__14.  Save the file and make sure you don't have any errors.
	__15.  From the Eclipse menus select 'Run → Run History → NIOFileSystemDriver'.
	__16.  Check that you see different files that match being printed out and a different number of files that matched.

	Part 5 -  Create Subdirectory
	__1.  Return to the 'run' method of the 'FileOperations' class, opening the file if you had closed it.  Add the following bold code to the end of the method.  You will have errors until future steps.
	__2.  Add a new method to the class as shown below.  Make sure you add this method inside the brackets for the class but outside the brackets for any other method.  You will have errors until future steps.
	__3.  Save the file and make sure you don't have any errors.  You will have a warning that can be ignored.
	__4.  From the Eclipse menus select 'Run → Run History → NIOFileSystemDriver'.  The output in the 'Console' view will not be different than last time.
	__5.  Open a Windows Explorer file browser and navigate to the 'C:\LabFiles' directory.
	__6.  Check that you have a newly created 'watched' subdirectory.

	Part 6 -  Watch Directory for New File
	__1.  Return to the 'run' method of the 'FileOperations' class, opening the file if you had closed it.  Modify the code of the method as shown in bold below.  You will have errors until future steps.
	__2.  Add a new method to the class as shown below.  Make sure you add this method inside the brackets for the class but outside the brackets for any other method.  You will have errors until future steps.
	__3.  Finish the new method implementation with the following bold code.  Make sure this code is within the brackets for the method declaration but after the other code you have already added.  You will still have errors in the code.
	__4.  Organize imports (CTRL+SHIFT+O).
	__5.  Save the file and make sure you don't have any errors.  You will have a warning that can be ignored.
	__6.  From the Eclipse menus select 'Run → Run History → NIOFileSystemDriver'.  The output in the 'Console' view will not be different than last time although you should notice that the program does not immediately finish and display '<terminated>' in the status.
	__7.  Open a Windows Explorer file browser and navigate to the 'C:\LabFiles' directory.
	__8.  Copy the 'MoviePrinter.java' file from the directory by selecting 'Edit → Copy' or using 'CTRL-C'.
	__9.  Navigate into the 'watched' subdirectory.
	__10.  Paste the file you copied into the directory by selecting 'Edit → Paste' or using 'CTRL-V'.
	__11.  Return to the 'Console' view of Eclipse.  You should now see that the process is listed as '<terminated>' and that the name of the new file you copied is printed.
	__12.  Return to the Windows Explorer file browser window and navigate to the 'C:\LabFiles' directory.
	__13.  Delete the 'watched' directory and confirm you want to delete the directory.

	Part 7 -  Copy File Contents With Buffers
	__1.  Return to the 'run' method of the 'FileOperations' class, opening the file if you had closed it.  Modify the code of the method as shown in bold below.  You will have errors until future steps.
	__2.  Add a new method to the class as shown below.  Make sure you add this method inside the brackets for the class but outside the brackets for any other method.  You will have errors until future steps.
	__3.  Add another new method to the class as shown below.  Make sure you add this method inside the brackets for the class but outside the brackets for any other method. You will have errors until future steps.
	__4.  Save the file and make sure you don't have any errors.  You will have a warning that can be ignored.
	__5.  From the Eclipse menus select 'Run → Run History → NIOFileSystemDriver'.  
	__6.  Open a Windows Explorer file browser and navigate to the 'C:\LabFiles' directory.
	__7.  Copy the 'MoviePrinter.java' file from the directory by selecting 'Edit → Copy' or using 'CTRL-C'.
	__8.  Navigate into the 'watched' subdirectory.
	__9.  Paste the file you copied into the directory by selecting 'Edit → Paste' or using 'CTRL-V'.
	__10.  You will see that two new files are created that have the same name but have a '-1' and '-2' appended to the end of the file name.  Also notice these files are empty as you haven't done anything with the file contents yet.
	__11.  Navigate back up to the 'C:\LabFiles' directory.
	__12.  Delete the 'watched' directory and confirm you want to delete the directory.
	__13.  Return to the 'makeNCopiesOfFile' method of the 'FileOperations' class, opening the file if you had closed it.  Modify the code of the method as shown in bold below.  You will have errors until future steps.
	__14.  Add a new method to the class as shown below.  Make sure you add this method inside the brackets for the class but outside the brackets for any other method.  Also be careful as this code has several sets of embedded curly brackets and wraps onto the next page.  You will have errors until future steps.
	__15.  Organize imports (CTRL+SHIFT+O).
	__16.  Save the file and make sure you don't have any errors.  You will have a warning that can be ignored.
	__17.  From the Eclipse menus select 'Run → Run History → NIOFileSystemDriver'.  
	__18.  Open a Windows Explorer file browser and navigate to the 'C:\LabFiles' directory.
	__19.  Copy the 'MoviePrinter.java' file from the directory by selecting 'Edit → Copy' or using 'CTRL-C'.
	__20.  Navigate into the 'watched' subdirectory.
	__21.  Paste the file you copied into the directory by selecting 'Edit → Paste' or using 'CTRL-V'.
	__22.  You should see that the same two new files are created but this time they are not empty.
	__23.  Open one of the files that were created and verify that it has content and is the same as the file you copied in.
	__24.  Close all open files.

	Part 8 -  Review

	Lab 18 -  JUnit
	Part 1 -  Create a Java project with JUnit Support
	__1.  From the Eclipse menus, select File → New → Project. 
	__2.  In the New Project window, select Java → Java Project and click Next.
	__3.  Enter JUnit as Project Name.
	__4.  Click Finish. Click yes if asked to switch perspective.
	__5.  From the menu, select File → New → Project. 
	__6.  In the New Project window, select Java →  Java Project and click Next.
	__7.  Enter JUnitTest as Project Name.
	__8.  Click Finish. 
	__9.  Right click the JUnitTest project and select Build Path →  Configure Build Path...
	__10.  Select the Projects tab in the dialog and click the Add button.
	__11.  Check the JUnit project and press the OK button.
	__12.  Select the Libraries tab in the dialog and click the Add Library... button.
	__13.  Select JUnit and click the Next button.
	__14.  Change the drop-down to select JUnit 4 
	__15.  Click the Finish button.
	__16.  Click the OK button to close the build path properties.

	Part 2 -  Create a Java Class and Test Class
	__1.  Right click the JUnit project and select New -> Class.
	__2.  Fill in a package of com.webage.domain 
	__3.  Fill in a class name of Money but do not yet create the class.
	__4.  Press the Add button next to the list of implemented interfaces.
	__5.  Fill in 'Comparable' to select the java.lang.Comparable interface and press the OK button.
	__6.  Click the Finish.
	__7.  Define the class Money as follows:
	__8.  Save the changes. There should not be any compile errors.
	__9.  Right click on the JUnitTest project and select New -> JUnit Test Case.
	__10.  Fill in a class name of MoneyTest but do not yet create the class.
	__11.  Fill in a package of com.webage.domain.test
	__12.  Press the Browse button at the bottom of the dialog next to the “Class under test”.
	__13.  Type Money  and then select the Money class that appears and press the OK button.
	__14.  Press the Next button once the dialog appears as below.
	__15.  Check the box next to the compareTo, equals and toString methods.  This will create tests for these methods.
	__16.  Press the Finish button to create the test class.
	__17.  Notice that JUnit 4 test methods are marked with the @Test annotation.  The wizard in Eclipse that created the test also put a statement that would guarantee the test to fail until we change it.

	Part 3 -  Test and Implement toString
	__1.  Modify the testToString method as follows.  You will have an error until the next step.
	__2.  From the Eclipse menus select Source -> Organize Imports.  This should add an import for the Money class.
	__3.  Save the code and be sure there are no errors.
	__4.  Right click on the MoneyTest.java file and select Run as -> JUnit Test. 
	__5.  The JUnit view should eventually open on the left.  There will be two failures but the testToString test should pass.
	__6.  Back in the MoneyTest class add the following new method.
	__7.  Save the code and be sure there are no errors.
	__8.  Right click on the MoneyTest.java editor and select Run as -> JUnit Test. 
	__9.  Select the testToString_SingleDigitCents method and scroll in the failure trace section. You will see that the zero was not present in one of the things being compared.  Obviously this means we need to adjust the implementation of the toString method to handle this condition.
	__10.  Switch to the Money.java editor or open the file if you closed it.
	__11.  Modify the implementation of the toString method to match the following.
	__12.  Save the code and be sure there are no errors.
	__13.  In the JUnit view, click the Rerun Test button.
	__14.  This time the test should pass in the testToString and testToString_SingleDigitCents tests.  There are still other failures but the two tests we have implemented have passed.  You could add other types of formatting function and define the tests but we will not do that now.

	Part 4 -  Implement compareTo and Tests
	__1.  Open MoneyTest.java
	__2.  Modify the testCompareTo method as follows.  You will have an error until the next step.
	__3.  Add the following import before the class declaration.
	__4.  Save the code and be sure there are no errors.
	__5.  Rerun the JUnit tests.  The test should fail in the testCompareTo method indicating that our implementation is not correct.
	__6.  Switch to the Money.java file and change the implementation of the compareTo method.
	__7.  Save the code and be sure there are no errors.
	__8.  Rerun the JUnit tests.  This time the test should pass in the testCompareTo test.
	__9.  Back in the MoneyTest class add the following new method.  100 US dollars is less than 100 Euros so this test makes sense for now.
	__10.  Save the changes and run the tests.  The test fails in the new method.
	__11.  Change the implementation of the testCompareTo_DifferentCurrencies to the following.  This uses the 'expected' property of the @Test annotation to indicate that this test expects an IllegalArgumentException to be thrown.
	__12.  Make sure you delete the assertTrue(american.compareTo(euros) < 0); line.
	__13.  Save the code and be sure there are no errors.
	__14.  Rerun the tests.  
	__15.  Select the testCompareTo_DifferentCurrencies method. The test will still fail but this time the failure message indicates the expected exception was not thrown.
	__16.  Switch to the Money.java file and change the implementation of the compareTo method.
	__17.  Save the code and be sure there are no errors.
	__18.  Rerun the JUnit tests.  This time the test should pass for the testCompareTo_DifferentCurrencies test.

	Part 5 -  Implement equals and Tests
	__1.  Select MoneyTest.java
	__2.  Modify the testEqualsObject method as follows.  
	__3.  Save the code and be sure there are no errors.
	__4.  Rerun the JUnit tests.  The test should fail and if you select it you can see the custom failure message.
	__5.  Switch to the Money.java file and change the implementation of the equals method.
	__6.  Save the code and be sure there are no errors.
	__7.  Rerun the JUnit tests.  
	__8.  This time the test should pass in all the methods.  Notice when all the tests pass the bar turns green to indicate success.
	__9.  Close all the files.

	Part 6 -  Create a Test Suite
	__1.  In Eclipse, switch to the Package Explorer view on the left which has likely been hidden by the JUnit view.
	__2.  Expand the JUnitTest → src folders until you see the com.webage.domain.test package.
	__3.  Right click this package and select New → Class.
	__4.  Fill in a class name of AllTests and click the Finish button.
	__5.  Add the following code to the declaration of the class.  You will have some errors until the next step.
	__6.  From the Eclipse menus select Source -> Organize Imports.  This should add some JUnit imports.
	__7.  Save the code and be sure there are no errors.
	__8.  Right click on the AllTests.java file and select Run as → JUnit Test. 
	__9.  You should get the same test passing results. Expand all in the JUnit view.  
	__10.  Close all open files.

	Part 7 -  Review




