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From the Editor | Where is Big Blue Heading?

A

t Web Age Solutions, our lives revolve
around deep research into software that
drive todays enterprise infrastructure.
The outside world rarely gets a glimpse of this
activity. Thus Web Age Technical Journal was
born. It will give us a chance to share the fruits
of our cutting edge research with the customers
before they are formally made available
through our training courses. We decided to
keep the issues focused on one specific vendor
or technology area. This issue puts the spot
light on IBM. This issue contains three articles
from three of our senior technical developers –
Matt Silver, Gary Ng and Stuart Smith.
Matt gained a lot of valuable experience
on WebSphere Portal v6.1 clustering while he
was developing the administration course. His
article discusses topics of clustering that may
not be obvious to someone who has studied
IBM documentation on that matter.
Gary Ng, who normally spends a lot of
time with WebLogic, decided to jump head first
into the WebSphere world with WebSphere Application Server v7.0. He had already done a
lot of advanced research on how to develop
web services for WAS v7.0 using JAX-WS.
Later, he got involved in WAS v7.0 administration. He shares his experience in terms of the
new features of WAS v7.0. If you are a veteran
user of WebSphere, you will find his article interesting.
One of the most exciting features of WebSphere Application Server v7.0 is its support for
Java EE 5. And, one of the most important features of Java EE 5 is Java Persistence Architecture (JPA). Stuart shows you how to develop a
JPA based application using Rational Application Developer (RAD) 7.5.

From the software programming point of
view JAX-WS and JPA are definitely exciting to
me because they will increase developer productivity. In the administration side of things,
WebSphere CloudBurst has caught my attention. Increasingly I come across businesses that
deploy WebSphere Application Server and Commerce
in VMWare images. Most of
them
run
WebSphere
products that way for development and testing. IBM
first released WebSphere
Application Server Hypervisor Edition to target this
market. If you wish to run
WebSphere in a virtual environment, you should definitely
look at this product. Hypervisor edition comes
with WebSphere pre-packaged in a Linux virtual
image. You can very easily duplicate the image,
assign a new host name, cell name, administrator user ID and password and create a new image. WebSphere CloudBurst adds the runtime
hardware and management component over
WebSphere Hypervisor. For example, you can
create a new image where Deployment Manager and federated nodes are already created
and IBM HTTP Server is already installed. Several such patterns for image creation are available.
I hope you enjoy reading this issue of WTJ.
Feel free to contact me with suggestions and
article ideas.
BIBHAS BHATTACHARYA
Chief Technology Officer,
bibhas@webagesolutions.com.
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Lessons Learned from WebSphere Portal 6.1 Clustering
Matt Silver,
Silver our Senior Technical Developer, is fresh out of writing the WebSphere Portal 6.1 administration
course. He spent a lot of time researching and experimenting with the topic of clustering. Let him tell you
what he found out!

I

n this article, I will discuss some lessons I learned
the hard way when creating a WebSphere Portal
Server (WPS) cluster, namely:
1. Use a domain-qualified hostname when installing and clustering WPS.
2. Avoid using localhost when configuring an external database and LDAP user registry.
3. Manually enable session failover.
4. Manually start a portlet application and activate its portlets after installing the application in
a cluster.

•

Configure the DM

•

Install WPS on the primary node (i.e., first WPS
node that is added to the DM cell)

•

Transfer the database domains for the
primary node from Derby to an external database (e.g., DB2 or Oracle)

•

Configure the primary node to communicate
with the DM

•

Federate the primary node and create a
cluster

•

Configure an LDAP (e.g., Tivoli Directory Server) or database user registry

•

Configure the Portal cluster with an external
web server (e.g., IBM HTTP Server)

•

Configure WCM content through the external
web server

•

If you're creating a horizontal cluster, then:

Sample Clustered Topology
Figure 1 shows an example of a horizontallyclustered environment, consisting of two WPS cluster
members spread across two machines. You can also
use vertical clustering, where the cluster members are
spread across the same machine, or mixed clustering
(i.e., both horizontal and vertical clustering).

◦ Install WPS on any secondary nodes (i.e.,
any additional nodes that are added to
the DM cell)

Basic Steps for Setting up a Cluster
The basic steps for setting up a cluster are the following:
•

•

Install the WebSphere Application Server Network Deployment (WAS ND) software which
comes packaged with WPS, since it's at the
right maintenance level
Create a Deployment Manager (DM) profile

◦ Federate the secondary nodes and add
them to the cluster
•

If you're creating a vertical cluster, then create
a new cluster member on an existing node
and enable cache replication for it
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•

Configure session failover

The goal of this article is not to explain these steps
in detail, but to examine some of the lessons learned
from the experience.
Machine D

to use that DNS server and the DNS can resolve the fully qualified host names. This is the
preferred solution.
2. In Windows, you can change the DNS suffix
Machine E

Machine A
DM

LDAP
Server

Portal
Database

PortalCluster

Node Agent

Node Agent

WebSphere_Portal

WebSphere_Portal_Node_Name

Machine B

Machine C

Request

Plug-in
Web Server
Machine F
Figure 1. Horizontal WPS Cluster

Lesson #1. Use Domain-Qualified
Hostnames
WPS v6.1 is the first version of WebSphere Portal
Server to require that you specify a domain-qualified
hostname (e.g., host.domain.com) during installation.
You can determine if your hostname is domain-qualified by typing the hostname command. If a short
name is returned, you have several options:
1. Register all machines that will be involved in a
Portal server cluster to your DNS server.
Make sure that these machines are configured

on each of the Portal machines. Information on
this topic can be found in the Windows Help
under the topic “Change the DNS suffix of
your computer”.
3. You can add the fully qualified host names to
the HOSTS file. A HOSTS file is essentially a
replacement for a DNS server. Register host
names of all machines involved in the cluster in
every machine's HOSTS file. That is, make sure
that every name is resolvable from any machine.
6 Web Age Technical Journal | June 2009

Lesson #2. Avoid using localhost
When specifying the host names for DB2 database or LDAP server, avoid using localhost. Doing so
will cause problems when you run Portal server in multiple machines.
When configuring a Portal cluster, you need to migrate from the internal Derby database to an external
database (e.g., DB2) to support clustering. WPS has
six database domains that need to be transferred to
one or more external databases.
Before doing the transfer using the ConfigEngine
utility (i.e., Ant-based configuration tool), there is a
properties file called wkplc_comp.properties that needs to be modified. For each domain,
you need to specify several properties, including the
database type, URL, username, and password. Normally, Type 4 JDBC drivers are recommended for connecting to the external database, since no database
client software needs to be installed on the WPS machine; instead, only the drivers need to be copied to
the machine. The database URL for a Type 4 driver
consists of the database server's hostname. For example, for DB2 the URL has the following format:
jdbc:db2://<YourDatabaseServer>:50000
/wpsdb:returnAlias=0;

When specifying the hostname, you want to be
sure not to use localhost for the host name, even if you
are running DB2 in the primary Portal machine. Otherwise, when you go to federate a secondary node, the
node will not be able to connect to the database
server.
Likewise, when configuring a Portal cluster, it's recommended to use a proper LDAP server for authentication purposes. One advantage to using an LDAP
server is that it allows you to modify users and groups
outside of WAS and WPS. By default, WPS uses the
Virtual Member Manager (VMM) federated security
which consists of a single file-based repository.
Similar to configuring an external database, you

need to specify the host name of the LDAP server in a
properties file called wkplc.properties that's used by
the ConfigEngine utility. For example, if you're using a
standalone LDAP server as your user registry, you'll
need to specify the following property:
standalone.ldap.host=<YourLDAPServer>

Once again, if you specify the hostname localhost,
you will have problems when it comes to connecting to
the LDAP server. There won't be a problem if your
LDAP server was installed on the same machine as
your primary node. The problem will only become apparent when you attempt to federate your secondary
node. To correct the problem, you would need to
modify the hostname for the LDAP server configuration inside the DM's administrative console.
To view the users and groups using the administrative console, you would also need to modify the
LDAP configuration in the VMM's federated repository. You would then need to restart the DM for the
changes to take effect.

Lesson #3. Session Failover not Enabled
by Default
When session failover (a.k.a. server affinity with
failover) is enabled, if a user is directed to another
cluster member due to a server failure, then he will be
treated as an existing user, not a new user. That is, his
HttpSession object will be preserved. However, when
configuring a cluster, WPS does not automatically enable session failover for you.
There are two ways to configure session failover
with WAS: memory-to-memory replication and persistent sessions (i.e., session database).
Memory-to-memory (M2M) replication uses the
Data Replication Service (DRS) of each cluster member. Session information (i.e., HttpSessions and Stateful
Session EJBs) is stored inside of a replication domain.
A replication domain consists of replicas. Each replica,
which corresponds with a cluster member, stores cop7 Web Age Technical Journal | June 2009

ies of session information from one or more other
cluster members in its memory.

Lesson #4. Don't Forget to Activate Your
Portlets

On the other hand, persistent sessions uses an external database to store session information, which
provides true persistence of the session data.
However, persistent sessions only stores HttpSession
information, not Stateful Session EJB information. It also
requires tuning at the database level.

When you install a portlet application in a standalone WPS environment, the corresponding enterprise application gets automatically started and the
portlets get automatically activated (i.e., placed in an
active state so the portlet can be used). At this point,
you can simply add one of the portlets to a page and
view it.

When setting up a Portal cluster, it's simpler to configure M2M replication, since it doesn't involve creating an external database. Also, although the ConfigEngine utility, which is used to create a cluster, does
not enable M2M replication, it does create a replication domain, which is half the battle. By default, each
replica stores the sessions of all of the other cluster
members in the domain (i.e., Number of replicas is set
to Entire Domain). This setting is fine for a small cluster
like the one configured above, but should be used
with care when working with a large cluster. This is
because there's more overhead associated with copying the session information between the cluster members; plus, each server needs to allocate more
memory to store each of the other members' sessions.
Getting back to setting up M2M replication, the
only other things that need to be done are to configure each cluster member to use the replication domain
and to restart the cluster. Perform the following steps
for each cluster member:
•

In the DM's administrative console, navigate
to the server configuration page for the
cluster member and click Session ManageManagement under Container Settings.
Settings

•

Click Distributed environment settings under
Additional Properties.
Properties

•

Click Memory-to-memory replication under
Distributed sessions.
sessions

•

Click OK to use the existing replication settings

•

Save the changes.

However, the same is not true when it comes to
installing a portlet application in a clustered environment. Instead, these steps need to be done manually.
I'll explain why shortly.
Any node can be used to manage portlets, since
all cluster members share the same database. When
you install a portlet application's web module using the
WPS Administration page, the following things happen:
•

WPS updates its database.

•

WPS installs the web module as an enterprise
application by communicating with the DM.

•

If synchronization is automatically enabled (occurs every minute by default), the DM notifies
all the nodes of the new web module during
the next scheduled synchronization phase.

Typically, when installing a portlet application, you
need to manually start the enterprise application. For
example, when using the Manage Web Modules
portlet to install the application, it will normally display
a warning message saying the web module was successfully installed, but could not be started (see Figure
2). This is because node synchronization needs to take
place before the application can be started in the
cluster.
On a rare occasion, if the node synchronization
happened to occur just as you were doing the install,
the application will automatically be started for you.
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However, you always need to manually activate
the portlet. I'll explain how in a moment. Because an
administrator can modify the synchronization settings
for the nodes in the DM cell, it's possible that synchronization may not happen immediately or may

application after all nodes were
synchronized.

Keep in mind that if a portlet is not activated, a
message stating that the portlet is temporarily disabled will be displayed when WPS attempts to

Figure 2. Warning message about portlet application activation.
never take place. Since WPS can't guarantee that the
portlet has been successfully synchronized to every
node in the cluster, WPS can't automatically activate
the portlet during the installation of the web module.
There are two techniques for activating the portlet. Both techniques will start the application for you
too if it was not already started.
1. Using the Manage Web Modules portlet, locate the portlet application's web module and
click the Activate icon.
2. Run the following command:
ConfigEngine activate-portlets
-DPortalAdminPwd=WPS_ADMIN_PASSWORD DwasPassword=DM_ADMIN_PASSWORD

If the nodes in the cluster are not synchronized before attempting to activate the web module, you'll get
a warning message when you click the Activate icon.

render the portlet.

Conclusion
In this article, I pointed out some lessons I learned
from setting up a WPS cluster. Remember to follow
the instructions in the WebSphere Portal 6.1 InfoCenter
(http://publib.boulder.ibm.com/infocenter/wpdoc/v6r1m
0/index.jsp) when setting up a cluster. Better yet, take
our
new
class
(http://www.webagesolutions.com/training/websphere/
wa1684/index.html) to learn more!
Matt Silver specializes in the WebSphere family of
products, including WebSphere Process Server and
Portal Server. Matt can be reached at
matt.silver@webagesolutions.com.

If you click the View Details link, you'll see an error
message like this:
EJPPH0049W: Automatic node
synchronization is enabled for node
[NODE_NAME]. However the portlet
application PA_LabPortletProject will
not be started in the Application
Server. Manually start the
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What's New In WebSphere Application Server v7.0
Gary Ng, Senior Technical Developer, Web Age Solutions, takes you on a tour of the new features of WAS
v7.0.

BM has recently released v7.0 of its award winning WebSphere Application Server (WAS 7.0)
which is one of the premier Java EE application
servers on the market. As has come to be expected from IBM, this new release brings along with it a
wealth of new features that are relevant to both developer and administrator alike.

I

This article will outline in brief some of these new
features which will be of particular interest to WAS administrators and technical planners.

Java EE 5
Especially important to developers is WAS' compliance with Sun's Java EE 5 spec – which includes full
support for Java EE 5's web services and EJB 3.0
specifications (which were previously only supported
by a feature pack download for WAS 6.1.) WAS itself
supports Sun's Java 6 run-time, allowing developers to
make use of Java 6 features.

how to implement important “additional” web service
features such as security and reliable messaging. This
means that it is up to the application server to fill this
gap, and it is here that WAS delivers. WAS will make
use of web service policy sets to address these features and allow for web services to be invoked as
needed, automatically attaching policy sets to web
service invocations when required.
Some developer/administrator work is required to
take advantage of these additional features. The developer will be responsible for creating policy sets
(which are essentially zipped up XML files) which web
services will use. The administrator will be responsible
for uploading [or importing] the created policy sets to
the WAS run-time. At that point, the web service engine in WAS will do the rest.

When developing Java EE applications which will
run on WAS, the development environment of choice
would be IBM's own Rational Application Developer
7.5 (RAD 7.5) which has also recently been released.
RAD 7.5 provides tooling to take advantage of Java
EE 5 features, and this RAD/WAS combination is a
powerful development and run-time pairing.

Web Services
In addition to supporting web services as described in the JAX-WS spec, WAS also supports web
service policy sets. The JAX-WS spec does not discuss

So, if you are using features like reliable mes10 Web Age Technical Journal | June 2009

saging and security, a degree of policy management
will be required. Fortunately, the WAS admin console
provides an easy to use facility for performing this
management. In the admin console, expand Services >
Policy Sets to see the policy set management tools.

Intelligent Provisioning
A JEE application server provides many services
(e.g. a web container, an EJB container, a security
manager, etc) that all require processing power and
memory resources to operate. However, not every
application that WAS will host will require these services – so it can be a little wasteful for WAS to spend
resources on them if they are never used.
New in WAS 7 is the concept of intelligent provisioning; this basically means that WAS will only start
the services required for an application. If, for example, a WAS run-time never need serve EJBs, intelligent provisioning will prevent the EJB container service
from being started unnecessarily. If, however, an application containing an EJB module is deployed to that
server WAS will dynamically start the EJB container.
This provisioning leads to reduced memory footprint and less wasted CPU cycles. A nice side effect is
that this tends to reduce WAS server start time as well.
Handy in large cells. The feature can be activated
from the admin console.

Security Domains
Previously, security configuration was handled exclusively at the cell level; this meant all servers participating in a cell always shared exactly the same security configurations (e.g. pointed at the same user registry, had the same console users, etc). WAS 7
changes that by allowing for the creation of one or
more security domains.
A cell can have multiple security domains, each
one configured differently from the other. This means
individual applications can have their own user populations defined independently. This allows for a much
larger degree of flexibility than would have previously
been available.

Business Level Applications
WAS 7 also introduces the concept of business
level applications.
applications A business level application allows
for the grouping of several JEE archives (and other resources) together into a single unit.
A limitation of the current JEE model of application
distribution is that the EAR file is defined on a “per application” basis; one application is typically packaged
per EAR. If an application is actually split up across
several EARs, then WAS would have to manage each
one (e.g. start and deploy) individually.
The concept of business level applications helps
here; from the administrative interface, several JEE applications (and other assets such as common Java libraries) can be grouped together into a single business
level application.
This single business level application is now easier
to manage; deployment and start/stop operations
only need be applied at one level, and libraries are
easier to share across EAR files. This greatly simplifies
complex deployment scenarios. Business level applications can even contain other business level applications, allowing for increased modularity!
Business level applications can be managed
11 Web Age Technical Journal | June 2009

through the administrative interface; a new business
level application can be created, existing assets added to it, and new assets can be uploaded to it.
In the admin console, select Applications | ApplicaApplication Types | Business-level Applications to work with
business level applications.

Administrative Agent
A new type of node has been introduced in WAS
7. This node represent an administrative agent. An
administrative agent serves to reduce redundancy of
having to deal with multiple administrative points.
Consider a scenario where several base (i.e. nonfederated) nodes of WAS are installed. To administer
each one via the administration console would require
each WAS instance to have its own administrative console service running. This means that the administrator
would have to juggle several admin consoles
WAS 7 offers a solution to this by means of the
administrative agent. An administrative agent node is
created (using the profile management tool) and the
administrative agent server associated with this node
is started (using the startServer command). Other existing WAS base nodes are then registered with the admin agent (using the registerNode command). At that
point, the administrative agent (which has its own administrative console) can be used as an administration
point for the registered nodes.
Once the base nodes have been registered with
the administrative agent, it will no longer be possible
to use each node's instance's admin console. Instead,
the administrator will use the admin console for the administrative agent.
When first connecting to the administrative agent's
admin console, the administrator will be prompted to
select which node to use:

In the screen above, the administrative agent has
been configured to administer base nodes samaelsamaelNode02 and samaelNode03.
The administrator
samaelNode03
would select either of those and click Continue to proceed to the admin console for each of those nodes.
(Note that a node called samaelAANode01 is
also present – selecting this one would allow the administrator to log into the admin console for the admin
agent itself, which can also be configured)
Once a node has been selected, the usual username / password prompt will appear.

After logging in, the admin console for the particular node will be displayed.
In a sense, this administrative agent acts as a
single point of administration for all registered nodes,
somewhat similar to what the Network Deployment
offers – except this does not require the actual network
deployer software to be installed.
Bear in mind, however, that the administrative
agent is not a complete replacement for the network
deployer; facilities such as clustering and plug-in gen12 Web Age Technical Journal | June 2009

eration are not available to an administrative agent.

Job Manager
In addition to the administrative agent, another
node type has been added to WAS 7; that of the job
manager.
manager
A job manager is, as its name implies, a repository
of WAS administrative tasks or jobs. Multiple WAS
nodes are then registered with the job manager and
will “listen” for jobs.
If work on one of the nodes is required, an administrator could submit a job to the job manager Properties of the job, such as what operation is to be performed, and when the job is to be executed [not necessarily right away] can be added to the job information. The job manager will then asynchronously notify
the targeted node about the job. Upon completion,
the job manager can be told to send an e-mail to a
specified address.

groups instead of having to manually target individual
servers.
As you can imagine, using the job manager can
greatly enhance the flexibility of administering WAS!

Conclusion
In this article, we have discussed some of the new
features of WAS 7. Some features are very handy
nice-to-have features (such as the business level application concept), while others fundamentally enhance
WAS' feature set (e.g. the new web service
operations). Additionally, new mechanisms such as the
administrative agent and the job manager significantly
enhance the ways in which we can administer WAS itself.
Gary Ng specializes in WebSphere and WebLogic
family of products. You can reach him
gary.ng@webagesolutions.com.

Essentially, the job manager is an asynchronous
means of administering multiple WAS nodes. This is
helpful when scheduling is a requirement (e.g. perform
this task at 5:00am) or when administering across a
network that is not beefy enough to handle synchronous calls.
Setting up a job manager is simple; the profile tool
is used to create an instance of a job manager node.
Once created, the job manager is started. Nodes are
then added to the job manager, and at that point will
begin polling the job manager for new jobs.
New jobs can be created and submitted by using the wsadmin interface (or through the job manager's own administrative console), specifying job descriptions via scripting. Jobs can be tasks like
starting/stopping servers, starting/stopping applications
and even running any wsadmin script.
Additionally, the job manager has facilities such as
group targeting; any collection of nodes can be
grouped together and tasks can be submitted to those
13 Web Age Technical Journal | June 2009

Java Persistence Development on Rational Application Developer
v7.5
Stuart Smith,
Smith Administration Lead for Web Age Solutions, discusses how to use Rational Application
Developer 7.5 to program Java database applications using the JPA programming model introduced with
Java Enterprise Edition 5.

ational Application Developer v7.5 and
WebSphere Application Server v7.0 support
the Java Enterprise Edition 5 (Java EE 5) programming model. One of the most significant
changes introduced with Java EE 5 was the way Java
applications that work with database data could be
written using JPA, the Java Persistence API. In this article you will get an overview of the JPA programming
model along with an introduction to the JPA and database tools provided by Rational Application Developer v7.5.

R

Overview of JPA
The Java Persistence API is a new specification
that standardizes a POJO persistence model for object-relational mapping. Previously the only standardized persistence available to Java Enterprise applications was the Container Managed Persistence (CMP)
EJB model. This model had many issues since it was
only available to EJB applications and the mapping
between Java and the database was something
vendor-specific which hampered the portability normally enjoyed by Java Enterprise applications. Although JPA was originally developed as part of the
EJB 3.0 improvements in Java EE 5 it is not restricted
to EJB applications and can be used directly from
Java web applications and even from standalone
Java SE applications.
If you are currently using third party libraries like
Hibernate to provide Java persistence it is suggested
that you start writing code according to the JPA spe-

cification.
The foundation of JPA is based around “Entities”.
These are Java classes that are marked as persisted
data. Entity instances in memory will correspond to a
row of data in a database table. Although it is possible to map Java classes to database tables and
columns using an XML file with JPA this is most often
done with annotations. These are qualifications preceded with the '@' sign and associated with the Java
class or Java properties of the class.
The most important annotation for JPA is the '@Entity' annotation. This marks a Java class as a JPA persisted entity. Also important is the '@Id' annotation
which marks the Java property that corresponds to
the primary key of the underlying table. By default the
entity is mapped to the table of the same name and
each property is mapped to a column that matches
the name of the property. You can use the optional
'@Table' and '@Column' annotations to provide your
own mapping if you want.
Figure 1. Sample JPA Entity
@Entity
@Table(name="CUST")
public class Customer implements
Serializable {
@Id
private String email;
private String name;
@Column(name="ADDR")
private String address;
}

14 Web Age Technical Journal | June 2009

Database Tools in RAD 7.5
Although not strictly required, the JPA tools in RAD
7.5 can be enhanced by connecting RAD to a database. By defining a database connection you can
generate Java Persistence Entities from a database
schema or validate the mapping of Java properties to
database columns.
1. Open RAD 7.5 on a workspace.
2. Switch to the Database Development perspective (Window->Open Perspective->Other).
3. In the Data Source Explorer view, right click on
Databases and choose New...
New Note that if
you have a local DB2 database you may
already see it in the list and only need to set
properties like user and password.
4. Choose the type of database and fill in various properties about the database. If you
want to use the database connection to validate JPA code it may be good to save the
password to allow easy validation.
5. There are several different database connection types to choose from. Make sure to
match your database vendor, version, and
type of connection. If you are using something
besides DB2 you might need to click the triangle next to the driver to configure the JAR
files for the driver.
6. Once all of the properties are set you can
click the Test Connection button to make sure
the connection will work.
7. Press the Finish button to create the connection.

10. You can right click a table and select Data →
Sample Contents to see the contents of the
table. If you want to insert new data you can
select Data → Edit.
Edit
11. Leave the connection connected for the next
section. If you want you can set a property
for the connection to connect automatically
when the RAD workspace is opened.

Create a JPA Project
There are several ways to package JPA code.
One of the options is a JPA Project. This is a standard
Java JAR file with files that indicate persistence properties. This type of project can be included in many
other types of projects to promote reuse of code.
1. Switch to the JPA perspective (Window->Open
Perspective->Other). This perspective also has
the Data Source Explorer view to view database contents in addition to JPA views for JPA
properties.
2. Select File → New → JPA Project.
Project
3. Fill in a project name and indicate if you want
to add the project to an EAR file. Press the
Next button.

8. When the connection is created it will connect
automatically. If you need to connect later
simply right click and select Connect.
Connect
9. When connected you can expand the various
elements of the database as shown below.
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4. Select the connection to the database you
created previously. Associating the project
with the connection will enable other JPA tools
described later. You can indicate the default
schema that JPA classes will be part of if you
wish. You will need to connect to the database if you are not already to select the
schema. You can also indicate if JPA annotated classes should be discovered automatically. You would likely use this setting unless you
are adding JPA features to a non-JPA project
(like a Web or EJB project) where scanning lots
of non-JPA classes might reduce performance.

5. Click the Finish button to create the project.
6. If you want to add JPA features to another
type of project, like a Web or EJB project, instead of creating a separate JPA project you
would right click the project and select ProperProperties.
ties
7. You would then select the Project Facets properties and check the box next to the Java PerPersistence facet as shown below.
8. Once you click OK in the project properties
the JPA facet will add JPA features to the project.
9. Once the JPA features are added to the project you can go back in to the project properties and set JPA properties like you can do
during creation of a JPA project.
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4. Fill in a Java package that the code will be
created in. Select the tables that will have JPA
entities generated for them. You will want to
know something about the data model as
tables that have foreign keys to other tables
may not be complete if entities are not generated for both related tables. You can also
change the name of the Java class that will
be created. Press the Finish button to generate the code.
10. Whether you created a JPA project or added
JPA features to another project type you can
now use some of the other JPA tools.

Bottom-Up Development
If you are working with database data, especially
if you have already created a connection to an existing database, it is likely that tables already exist. If the
data model already exists and you are simply creating
a Java model to match this is often called “bottom up”
development. RAD 7.5 has tools to take the tables in
an existing database and generate JPA entities from
those. If you are working on a new project it is always a good time to evaluate the data model to be
sure it is appropriate so bottom up development is not
always the best place to start but it can give you JPA
code quickly that you can further customize if you
want. You can also use bottom up development to
start, make customizations, and then export a new
data model with the changes using tools shown in future sections.
1. Make sure you are in the JPA perspective.
2. Right click on the project you want to add JPA
code to and select JPA Tools → Generate EnEntities... from near the bottom of the menu.
3. Select the database connection and schema
that contains the existing tables you want to
use for creating JPA entities. You can reconnect to the database if you are not already
connected. Press the Next button.

5. The JPA entity code will be added to your project.

Top-Down Development
If you are working on a new project that does not
have an existing database model or if the existing
database model needs significant changes and is not
appropriate you may be creating the JPA entity definitions first. RAD 7.5 provides wizards to create JPA entities from scratch.
1. Make sure you are in the JPA perspective.
2. Right click on the project you want to add JPA
code to and select New → Other...
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3. Expand the JPA group and select Entity and
then press the Next button.
4. The most important properties of the new entity are the Java package and class name although you can add options for JPA inheritance if your entity will take advantage of this.
Although you could press the Finish button at
this point to create an empty entity you can hit
the Next button to add additional properties.

6. The entity will be created and opened in the
editor.

5. On the next screen of the wizard you can
specify additional properties for the entity,
the most notable being the fields that will be
defined in the entity. Defining the entity fields
in this list can save work later on if you know
what they are. Remember to mark the field
that will correspond to the primary key of the
table as a “Key”. You can also map the entity
to a table name that is different than the
name of the entity if you prefer. Mapping the
fields to different column names can't be done
in the wizard. Press the Finish button to create
the entity. The last page of the wizard lets
you add the entity to a class diagram that
RAD 7.5 can create if you wish.

JPA Views in RAD
No matter how the JPA entity is created there are
several tools in RAD that can help simplify the coding.
These tools make it easy to see the structure of a JPA
entity and use some of the more advanced mapping
options available with JPA.
1. Make sure you are in the JPA perspective.
These views are open by default in the JPA
perspective although you could open them in
other perspectives.
2. Open a JPA entity with the Java editor.
Many of these views only show information
when an entity is open in the editor.
3. In the JPA Structure view which is normally in
the upper right you can see the various prop18 Web Age Technical Journal | June 2009

erties that make up the entity. The icons are
very useful especially when an entity property
is involved in a relationship like one-to-many or
many-to-one. You can also right click on the
entity or a property to easily change the
mapping type. You can also see similar information by expanding the JPA Content of the
project in the Project Explorer view although
you can't change mapping type from that
view.

4. By selecting the entity or a property in the JPA
Structure view the code in the editor will be
highlighted and the JPA Details view will show
various JPA properties of the selected item.
Changing these properties in this view will
change the annotations in the code. This view
makes it easy to find out what the default
value for an annotation will be applied if the
annotation is not present and how to use
some of the more complex features of JPA like
primary key generation and “fetch type”.

5. RAD 7.5 can also validate JPA mappings if
there is an active database connection associated with the project. In the example below
a new Java property called “bogus” has been
added and RAD has detected that it does
not match a column in the table for this entity.
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You can then use the JPA Details view for a list
of valid columns and the appropriate JPA annotation will be added for the new mapping.

Summary
The Java Persistence API is an exciting new development for Java applications. Using this new standard
you can write Java applications that work with persistent data without relying on vendor-specific features
or third party libraries.
Although RAD does not provide a migration utility
to migrate Hibernate or CMP EJB 2.x code to JPA you
can use the various JPA tools that are provided to simplify coding JPA applications.

6. Finally, once your JPA code is complete, you
can use RAD to generate the database DDL
script that can create the appropriate database structure. You do this by right clicking on
the project and selecting JPA Tools → GenerGenerate DDL... This creates a Table.ddl file in the
'src/META-INF' folder. Even if you originally
created your JPA entities from a database you
may want to perform this step to make sure
that any changes or additional details that
were developed while coding the JPA entities
is represented in the underlying database
tables.

Stuart Smith specializes in Java EE 5 programming and
Application Server administration. He can be reached
at stuart.smith@webagesolutions.com.
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