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Part 1 - Amazon QwikLabs

This course requires access to the following site, students should use their own account, 8 credits are 
required to buy:

https://amazon.qwiklabs.com/

Part 2 - Minimum Hardware Requirements 

● 64 bits OS

● 8 GB RAM

● 50 GB in the hard disk

Part 3 - Minimum Software Requirements 

● Windows 8.1

● Adobe Acrobat Reader

● Zip extraction utility

● Latest FireFox

● Latest Chrome

● IBM Integration Designer 8.0 * 

● Oracle WebLogic Server 12c *

● Oracle Enterprise Pack for Eclipse *

● JRockit JDK *

● JDK 7 Update 45 * 

* - indicates software provided as part of the courseware.
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Part 4 - Software Provided

The following files are required:

● WA2233_1.ZIP

● WA2233_2.ZIP

● WA2233_3.ZIP

● WA2233_4.ZIP

All other software listed under Minimum Software Requirements is either commercially licensed 
software that you must provide or software that is freely available off the Internet.

Part 5 - Important Ghosting or Imaging Information

None of the software required by this class support ghost or imaging. You can save time by copying the
contents of the zip files to temporary folders on the hard drive and then imaging that hard drive. After 
restoring the image to the other computers and changing the host names, you can then install the 
software from the temporary folders individually.

This course has issues when is cloned. Do not clone it.
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Part 6 - Instructions

__1. Create the user that the students will use during the class.

__2. Give the student user account administrative rights. During the labs the student requires 
this to install software

__3. Login with this user to do the setup.

__4. Extract the 4 ZIP files to C:\

__5. Review that the following folders were created:

• C:\LabFiles

• C:\Software\IID_8.0

• C:\Software\JRockit1.6

• C:\Software\OEPE

• C:\Software\WebLogic

__6. Review that the following files were created:

• C:\Software\jdk-7u45-windows-i586.exe
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Part 7 - Installing IBM Integration Designer 8.0

Warning:  You cannot use ghosting or disk imaging to install this software.  You 
must install the software on each machine separately.  Do not change the 
computer hostname after this software is installed.  Also, do not install this 
software from a network share.  It will only function partially if you do. 

Approximately time for installation of IID 8.0: 90 minutes. It is recommended turning  off the firewall 
to avoid messages during the installation.

__1. Open C:\Software\IID_8.0

__2. Right click launchpad.exe and select Run as Administrator.  

__3. Confirm any Windows security prompts that are presented during the installation.

The Welcome to WebSphere Integration Designer Installation page will open. 
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__4. Select  IBM Integration Designer for IBM Business Process Manager Advanced – Process 
Server.  

__5. Uncheck the box for Start working with IBM Process Center first.

__6. Click Install Selected.  

__7. Confirm any Windows security prompts that are presented.
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__8. The Install Packages page will open. Leave all the defaults selected as shown below and click 
Next.

__9. Accept the license terms and click Next.
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__10. Modify the Installation Manager Directory to "C:\IBM\Installation Manager\eclipse"

Windows Vista/2008/7: It is especially important to modify the installation location on these systems 
as there may be errors saving to the WebSphere configuration if the product is installed under the 
'Program Files' folders.

__11. Make sure you changed Installation Manager Directory as shown above and then click Next.
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__12. Select and Modify the Installation Directory of IBM WebSphere Application Server Network 
Deployment V8.0 to "C:\IBM\WebSphere\AppServer"

Windows Vista/2008/7: It is especially important to modify the installation location on these systems 
as there may be errors saving to the WebSphere configuration if the product is installed under the 
'Program Files' folders.

__13. Make sure you changed the Installation Directory of IBM WebSphere Application Server 
Network Deployment V8.0 as shown above and then click Next.

__14. Click Next in the Translations Supported page.
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__15. Leave all defaults for Features to install and click Next.

__16. Leave the default values for the profile configuration and click Next.
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__17. Change the user name and password DB2 credentials to db2admin as shown below and click 
Next.

__18. Finally click Install to start installing the product. This will take some time. Make sure all 
software will be installed under C:\IBM.
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__19. Verify that installation completed successfully, then select None and click Finish. 

__20. Close the Launchpad.

Part 8 - Assign privileges in DB2 admin group

DB2 was installed with the IBM Business Process Manager installation but only the 'db2admin' user 
has appropriate privileges.  This means that is students login with a different ID, they will have 
permission problems using DB2.

__1. Open the 'Local Computer Management' utility.  Doing this varies by Windows version but 
generally right clicking on an icon for 'Computer' (in a Windows Explorer window or the Start menu) 
and selecting 'Manage' will do it.

__2. Expand 'Computer Management (Local) → System Tools → Local Users and Groups → 
Groups'

13



__3. With the 'Groups' folder selected on the left, open the properties of the 'DB2ADMNS' group on 
the right.  The easiest way is to double click the group.

__4. With the properties of the 'DB2ADMNS' group open, add either the individual IDs on the 
computer the students will use to login or all 'Authenticated Users'.  The method for doing this will 
differ depending on Windows version but you should see the configured users/groups added to the 
'Members' list of the 'DB2ADMNS' group.

Note: Users in the 'DB2ADMNS' group have the proper privileges to run the DB2 services.  You will 
get a DB2 error prompt appear when you login if you don't have the proper permission.

__5. Close any open dialog boxes and the 'Computer Management' window.
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Part 9 - Modify File Permissions

Note: These steps allow full access to the directories used by the WebSphere install.  This is required 
so that students can start the WebSphere server from within development tools and will allow the 
WebSphere server to write to the log files.  Without these steps the students won't be able to start the 
WebSphere server and won't be able to do the labs.

These steps allow full access to the directories used by the WebSphere install.  The steps to 
accomplish this may vary by Windows version but the goal is the same, granting access to all users to 
the WebSphere install.  If you have questions about how to accomplish this contact the setup support 
person for the class.

__1. Right click C:\IBM and select Properties. 

__2. Click the Security tab.

__3. Click Edit. 
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__4. Select the Users entry (add one if not present).

__5. Check Full Control permission option and click OK.

__6. Wait until the process finishes updating security, and close all windows when is done.

__7. Repeat the same steps for Authenticated users.

__8. Now give full privileges to C:\LabFiles to all users as you did it to the IBM folder.

__9. Restart the computer and login with the user that the student will use to do the Labs.

__10. Make sure the user has full access to C:\LabFiles as well as C:\IBM folders.
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Part 10 - Verification of the installation of IID 8.0

__1. From start menu select: All Programs > IBM > IBM Integration Designer ->  IBM Integration
Designer 8.0

__2. Change the workspace to C:\workspaceIID and click OK.

__3. If you are prompted by the Windows firewall about blocking a program unblock it.

The Getting started page will open.

__4. Select the Servers tab.
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__5. Right click the IBM Process Server v8.0 at local host server and select Start. You will see at the 
bottom messages that the server is starting, wait patiently, the first time the server is started launch 
many services.

__6. From the menu, select Window → Show View → Console.

__7. The Console view will open and there you can monitor the server. Starting the server the first time
takes a while (10 minutes) but if the Console shows activity then everything is fine. 

__8. Click OK if the automatically publish message open.

__9. Make sure the Server status changed to [Started, Synchronized].

__10. Now, right click the server and select Stop. 

Server status will change to [Stopped, Synchronized].

__11. Exit the product by selecting File → Exit from the menu bar.

__12. Close all the open files.

Congratulations! The product has successfully been installed.
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Part 11 - Installing JRockit JDK 1.6

Please follow these steps to install JRockit JDK 1.6.

__1. From C:\Software\JRockit1.6 folder, run jrockit-jdk1.6.0_29-R28.2.2-4.1.0-windows-ia32.exe

__2. Click Next.

__3. Change the installation directory to C:\Software\Java 

It is important that you install in this directory as the course depends on it.

__4. Click Next.
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__5. Click Next.

__6. Select No. Don't install public JRE.

__7. Click Next.

Installation will begin.
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__8. Click Done.

Part 12 - Oracle WebLogic Server v12c server Setup

Make sure, WebLogic Server has already been extracted into C:\Software\WebLogic folder.

In this part we will setup necessary Environment variables and run installation configuration script.

Follow the instructions to set up JAVA_HOME, MW_HOME and JAVA_VENDOR environment 
variable.
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JAVA_HOME=C:\Software\Java
MW_HOME=C:\Software\WebLogic
JAVA_VENDOR=Oracle

__1. Login as the user that will do the Labs and make sure has administrative privileges.

__2. Right click on the My Computer icon on your computer and select properties. 

__3. Click the Advanced Tab. 

__4. Click the Environment Variables button. 

__5. From the System Variables list, select Path and click Edit.

__6. At the beginning of the line enter the following:

C:\Software\Java\bin;

__7. Click OK.

__8. Under System Variables, click New. 

__9. Enter the variable name as JAVA_HOME

__10. Enter the variable value as the install path for the Development Kit. 

C:\Software\Java

__11. Click OK. 

__12. Repeat these steps for MW_HOME and JAVA_VENDOR variables.

MW_HOME=C:\Software\WebLogic
JAVA_VENDOR=Oracle
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Once all done it should look like.

__13. Click OK until you close all windows.

Now you will run the installation configuration script in the MW_HOME directory. It should be run 
only once.

__14. Open a command prompt.

__15. Change the directory to C:\Software\WebLogic

__16. Enter configure.cmd and hit Enter.

It takes few minutes to complete. 

You will get a notification when the installation is done.
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__17. Close the command prompt window.

__18. Restart the machine.

__1. Open a Windows command prompt.  You can do this by selecting 'Start -> Run', entering 'cmd', 
and then pressing the OK button.

__2. Enter the following command:

java -version

Make sure you see the response shown below.

__3. Enter the following command:

javac

Verify that you get the options to run the Java compiler:

__4. Close the command prompt window. 
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Part 13 - Configure a server in OEPE

We now need to configure Oracle Enterprise Pack for Eclipse(OEPE) to be able to communicate with 
WLS.  Doing so will allow us to perform simple operations with the server (e.g. Starting, stopping and 
deploying applications).  While this is not strictly necessary for a development environment, it 
significantly simplifies development time. In order to setup the server we should also need to create a 
domain.

As with WLS, OEPE has already been installed on your computer.  We just need to configure it. 

__1. Start OEPE by launching C:\Software\OEPE\eclipse.exe

OEPE will launch.

You will be prompted to select a Workspace. 

__2. Set the Workspace to C:\workspace

__3. Click OK.

OEPE will start. 
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As mentioned earlier, OEPE is built on top of Eclipse.  If you are familiar with Eclipse, you should 
have no problems using OEPE.  

__4. WTP is displaying the Welcome screen (or view).  Close the view by clicking the x in its tab.  

__5. From the menu, select Window > Open Perspective > Java EE.

OEPE will then show the Java EE perspective. (A perspective is a collection of views)

__6. Select Windows | Preferences.

__7. Expand Server | Runtime Environments.
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__8. Click Add...

__9. Expand  Oracle and select Oracle Weblogic Server 12c(12.1.1)

__10. Click Next.
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__11. For Weblogic home, enter C:\Software\WebLogic\wlserver or browse to find the location. 
Similarly enter C:\Software\Java for Java home.

You will see as shown below:

__12. Click Finish.

__13. Click OK.
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__14. We need to create domain and configure OEPE to point at the domain.  Locate the Server view. 
To do this, click the Servers tab in the bottom area of OEPE.

__15. Right click anywhere in the area and select New | Server.

The New Server window will appear. 
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__16. Select Oracle WebLogic Server 12c.

__17. Click Next.

__18. Next to Domain directory, click the create icon and then select Create Domain.

__19. Enter LabDomain as the name. 

__20. Check specify password and enter w1sadmin as password where the password contains 
number one not L. 
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__21. Don’t select any extensions, because we will not be using any of the advanced features like WS-
Addressing.

__22. Click Finish.

__23. After some seconds the below screen will open, make sure Disable Automatic Publishing to 
server is checked.

__24. Click Finish.
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The server connection has been defined, and the server should now be listed in the Servers view.

Part 14 - Verify the Server

__1. In the Servers view, right click on the server and select Start.

The Console view should automatically open.  This will allow us to “see” OEPE booting.  Eventually, 
the server will start and the Servers view will be brought to the focus again.  

After finish publishing the server State should be Started.

__2. Examine the Console window by clicking the Console tab. 

32



In later steps, when we ask you to refer to the server console, this is the view we will be referring to.  

__3. Go back to the Servers view. 

__4. Right click on the server and select Stop.

As with starting the server, the console view will open briefly.  Then the Server view will appear, 
listing the status as Stopped.

__5. Close OEPE.

__6. Restart the machine and login as the user that will do the Labs.
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Part 15 - Summary

You have successfully installed the software for this course!

If you have any question please contact us by email at support@webagesolutions.com 

From US and Canada call: 1-877-812-8887 ext. 26 

International call: 416-406-3994 ext. 26
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